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Getting Started with Modules Setup 
Administration Guide 

Within our documentation, some content might be specific for cloud deployments while other 
content is relevant for on-premises deployments. Any content that applies to only one of these 
deployments is labeled accordingly. 

This document explains how to set up the modules that are used in the Admin or User mode of 
operation. 

Access to system functionality is granted through permissions. The ability to utilize a specific 
function depends on permissions settings (accessed in Admin mode). 

The application has two modes of operation: 

 Admin (Administration) mode

Company administrators work in Admin mode to set up, for example, company and project or 
shell properties, user permissions, templates for major features, and data structures. 
Administrators also configure and set up business process (BP) workflows. 

 User mode

Users spend most of their time in the User mode. The User mode allows users to perform 
day-to-day activities, collaborate through business processes and Mailbox, maintain, for 
example, the Cost Manager, Schedule Manager, and Document Manager, and run reports. 

The Unifier General User Guide explains how to use the options that are available in the 
User mode of operation. 

You can switch between modes using the mode icons ( User mode and Admin mode). 

Note: This option is not available in the Home workspace because it 
does not support Admin mode. 
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Setting up Data Structure 

In This Section 

Creating Data Views ................................................................................................ 21 
Creating Data Cubes ............................................................................................... 29 

Creating Data Views 

Data Views use SQL queries that are defined against system tables and business process 
tables. Data Views are used in Custom Reports, User-Defined Reports (UDRs), and Shell 
dashboards. 

Note: The User-Defined Reports (UDRs) can be created at company 
and project/shell levels. 

Data views must contain project_id in the SQL query for the data view to be displayed in a 
project/shell-level UDR data type list. 

Note: Data views published prior to the Primavera Unifier 9.5 release 
must be republished (that is, set to draft status and then reset to 
published status) before they show up in the UDR data type list. 

The system includes an Explain Plan option that you can use to evaluate your data views. 
Running the Explain Plan provides important feedback that can help you modify the SQL query 
to reduce or eliminate performance issues. 

Before you begin: Define your reporting requirements first. Collaboration between business 
users and technical development teams helps identify the data you must collect and how to 
present that data so report recipients will have an easy-to-read, useful report. 

Step 1: Set permissions for data view creation. See Grant Permissions for Data View 
Creation (on page 22). 

Step 2: Create data views. See Create and Publish Data Views and Metadata (on page 23). 

 Data views must be published (as indicated by the Publish Date) before you can use them 
as data sources in UDRs, data cubes, or custom reports. 

 Test your data view SQL queries in the Development/Test environment before deploying 
them in the Production environment because only by testing can you be sure the query is 
valid and returns the desired data. Oracle recommends that you test your SQL queries in the 
Development environment prior to deploying them in the Test environment or Production 
environment. 
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 Use the Explain Plan feature to evaluate the SQL performance and potential issues of data 
views that you design. 

Note: For translation information, see the Unifier General Administration 
Guide. 

Step 3: View data and metadata. See View Data (Query Results) and Metadata (Columns) 
in the View (on page 25). 

Step 4: Export data. See Export Data (Query Results) (on page 26). 

The Data Views are included in: 

 Custom Report that are using Data Views and ready for Production environment. 

 Data Cube that are using Data Views and ready for Production environment. 

 User-Defined Report (UDR) that are using Data Views and ready for Production 
environment. 

Grant Permissions for Data View Creation 

To grant permission for data view creation 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click User Administration > Access Control. 

3) On the right pane, select Administration Mode Access > Data Structure Setup > Data 
Views. 

The Module Permission Settings window opens. Here you can add, modify, or remove 
permission settings. 

4) Click the Add button. 

5) In the Permissions Setting for Data Views window, click the Add Users/Groups button. 

6) In the Users/Groups window, select the intended users and/or groups and click the Add
button. 

7) To return to the Permissions Settings for Data Views window, click OK. 

8) In the Select Users/Group section of the window, select the users or groups, and then 
select the applicable level of access for the user or group in the Permissions Settings
section. 

 View: Allows users and groups to see the data view settings. 

 Create/Modify: Allows users and groups to define or change data view settings. This 
setting includes View permission. 

9) Click the OK button. 
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10) Click Apply to save changes and keep the window open, or click OK to save changes and 
close the window. 

Create and Publish Data Views and Metadata 

After you create a data view, you must publish it to be able to use it in user-defined reports, data 
cubes, or custom reports. 

Note: If you intend to use data views in user-defined reports, be aware 
that the data views must contain project_id in the SQL query for the data 
view to show up in a project or shell-level UDR data type list. 

Depending on the data elements you choose, you might need to publish the metadata 
associated with the data view. For example, if the selected data element has a data definition 
type of pull-down Menu, you will have to publish the metadata to see the actual label of the 
pull-down rather than the value. In the case where a data element is defined as Actual Value?
based on a Yes/No data element, with 0= No and 1=Yes, if Actual Value? is used in the data 
view, you must publish the metadata of Actual Value? to get the Yes or No value rather than 0 or 
1. 

To create data views 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Views. 

The User-Defined Data Views log opens. 

3) In the toolbar, click New. 

In the Create a Data View window that opens, the Prefix is auto-populated with Unifier_. 

4) Enter the name of the data view, the label, an optional description, and the SQL query for the 
data view. 

For more information on how to create SQL queries used in the creation and management of 
data views, consult the Oracle Consulting Services team. 

5) Click OK. 

Note: When creating data views, the column naming convention must 
follow the Oracle DB guidelines. Do not use the Oracle-reserved words 
such as "(", ")" and so forth to name the column. For details, refer to 
Oracle DB guidelines. 

To check the data view for potential issues 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Views. 

The User-Defined Data Views log opens. 

3) Select the applicable data view. 

4) In the toolbar, click Explain Plan and select Run Explain Plan. 

5) Review the output. 
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6) If an entry in the Operation column is highlighted in yellow, hover over the highlighted entry 
to view additional information. 

7) When you are done reviewing suggestions, click Close. 

After you run an Explain Plan, the system displays an icon in the Performance Alert column 
of the User-Defined Data Views log if potential issues were identified. 

To publish data views 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Views. 

The User-Defined Data Views log opens. 

3) Select an unpublished data view. 

4) In the toolbar, click Status and select Published. 

5) Click OK. 

To publish metadata 

You can associate metadata with its data set for both labels and values. Data views tend to 
contain technical shorthand from system and SQL abbreviations. While clear to the technical 
person who wrote the data view, report consumers will appreciate seeing the same field labels 
and field value selections that they see in their business processes and managers. 

For example, in your data view you might include the data element "year_pd," which represents 
a pull down menu with selections for different years assigned to its data set. In your user-defined 
report, you might want to see the label "Year" instead of "year_pd"; and you might want to query 
on meaningful values, such as 1999, 2001, 2002, and so on, instead of the numeric values of 
the data definition, 1,2,3, and so on. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Views. 

The User-Defined Data Views log opens. 

3) Select a published data view. 

4) In the toolbar, click Metadata. 

5) In the Metadata for <data view> window, double-click the Definition field for each data 
element and select the data definition for the selected element. 

The data definitions available for selection are filtered by the data elements used. 

6) Double-click the Label field for each element you want to use in the UDR, and rename it to 
whatever you want to see in the report. 

7) Click Publish Metadata. 
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Notes:

 The SQL definition will consist of the SQL query used to populate the 
report with specific data based on the desired output. 

 If using the data view as a Main view in a Project-level report, you 
must have a column named project_id. If using the data view in a 
Program-level report, you must have a column named program_id. 

For example, a Project-level data view for a company registry might be: 

SELECT   pu.PID as PROJECT_ID,

         p.PROJECTNUMBER as PROJECTNUMBER,

         c.COMPANYNAME as COMPANY_NAME,

         c.SHORTNAME as COMPANY_SHORT_NAME,

         c.DESCRIPTION as COMPANY_DESCRIPTION,

         c.CONTACTNAME as COMPANY_CONTACT_NAME,

         u.FULLNAME as USER_FULL_NAME,

         u.USERID as USER_ID,

         u.USERNAME as USER_NAME,

         u.EMAIL as USER_EMAIL

FROM     SYS_USER_INFO_VIEW u,

         SYS_COMPANY_INFO c,

         SYS_PROJECT_INFO p,

         SYS_PROJECTUSER pu

WHERE    c.COMPANYID = p.COMPANYID

  AND    p.PID = pu.PID

  AND    u.userid = pu.userid

View Data (Query Results) and Metadata (Columns) in the View 

The Data button will return the query results of the view (essentially, a preview of the report 
results, without any user entered parameters). 

The Metadata button will return all the columns in the view. The Metadata button will return the 
definition of the columns: names, type and labels of the columns used in the view. For example: 

To view query results 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Views. 
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The User-Defined Data Views log opens. 

3) Select a view. 

4) In the toolbar, click Data. 

The results window will display the query results. 

To view columns 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Views. 

The User-Defined Data Views log opens. 

3) Select a view. 

4) In the toolbar, click Metadata. 

The results window will return all the columns in the view. 

If the Data View is in Draft status, the metadata that you see will be based on the last Published 
data. If the Data View has not been published before, no data is displayed. 

You can delete a Data View that was included in the configuration package, indirectly. 

Note: Although deletion of a Data View is possible, if a Data View has 
been used in a UDR, Custom Oracle Business Intelligence Publisher (BI 
Publisher) or Oracle Analytics Publisher report, or Data Cube that was 
included in a configuration package, the configuration package creation 
will fail because of the missing data views. 

Export Data (Query Results) 

The results of the data query can be exported as CSV or SQL files. 

To export data as CSV 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Views. 

The User-Defined Data Views log opens. 

3) Select a view. 

4) In the toolbar, click Data. 

5) In the results window, click the Export As CSV button. 

Depending on your browser, the file will either download automatically or you will be prompted to 
download it.  

The CSV file will contain the data that is displayed on the results log. By default, the first 100 
lines will be displayed. You can click the Display drop-down (in the upper-right corner of the 
results log) and choose 200 to display the first 200 lines. When you click Export As CSV, the 
CSV file will contain the 100 (or 200) lines displayed in the window. 

To export data as SQL 

1) Go to the Company Workspace tab and switch to Admin mode. 
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2) In the left Navigator, click Data Structure Setup > Data Views. 

The User-Defined Data Views log opens. 

3) Select a view. 

4) In the toolbar, click Data. 

5) In the results window, click the Export As SQL button. 

Depending on your browser, the file will be downloaded automatically, or you will be prompted to 
download the file manually.  

This will export your SQL script to create the table required for the data view and the data 
itself. 

Notes on working with the Oracle Database

 Only the 100 or 200 rows will be exported at a time. You cannot 
export the entire result of the view (for example, if there are more 
than 200 rows) in one click. You must export in groups of 200 rows at 
the maximum and then manually combine the exported results. 

 Note that SQL export files have the .sql extension and work best with 
the Oracle database as the field types used in the creation of the 
data view are of Oracle type (for example, VARCHAR). If the 
exported SQL file is to be used in a database other than Oracle, you 
must manually modify that file to replace the field types with the 
types that work with the non-Oracle database. 

 Unifier uses a field type called TIMESTAMP for all date or time fields, 
so you must modify the session date format to match the timestamp 
used in Unifier. For example, you can run the following statement for 
an Oracle database: ALTER SESSION SET NLS_DATE_FORMAT = 
'YYYY-MM-DD HH24:MI:SS'; 

 If you are building multiple data views based on other data views, 
then any changes to a data view (for example, adding a new data 
element) in the lower hierarchy will necessitate the dependent views 
to be changed to Draft, in order to refresh, and the data views must 
be republished, to incorporate the changes. For example, if Dataview 
2 is based on Dataview 1, and you add a new field to Dataview 1 and 
then republish it. You must then change Dataview 2 to Draft and then 
republish it so that it will contain the change you made in Dataview 1. 

 Additional cleaning of the data (in case of export to SQL file) might be 
needed if there are (‘) apostrophes in the values of some fields, or if 
there are ampersands (&). This will result in inconsistent values 
between the results in Unifier and the result in the local database 
after import. 

View Data View Usage in Reports and Data Cubes 

To view reports and data cubes in which a Data View is used 

1) Go to the Company Workspace tab and switch to Admin mode. 
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2) In the left Navigator, click Data Structure Setup > Data Views. 

The User-Defined Data Views log opens. 

3) Select a view. 

4) In the toolbar, click Usage. 

The Usage window opens, listing the reports and data cubes in which the data view is used. 

Edit Data Views 

Data views must be in draft mode to edit. 

To edit data views 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Views. 

The User-Defined Data Views log opens. 

3) Select a view. 

4) In the toolbar, click Status and select Draft. 

5) Click the Open button to access the SQL statement. 

6) Edit the SQL statement and click Apply or OK to save changes. 

7) Select the data view again, click Status and select Publish to make the data view available 
for use in user defined reports, data cubes, and custom reports. 

Delete Data Views 

To delete Data Views 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Views. 

The User-Defined Data Views log opens. 

3) Select a view. 

4) In the toolbar, click Delete. 

You will receive a confirmation message that you want to delete the selected Data View. 

Notes: 

 You cannot delete Published Data Views. You must change the 
Status to Draft to be able to delete a Data View. 

 Although deletion of a data view in Draft status is possible, if a Data 
View has been used in a UDR, Custom BI Publisher/Oracle Analytics 
Publisher report, or Data Cube that was included in a configuration 
package, the configuration package creation will fail because of the 
missing data views. 
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Review Database Table Structure 

Before building your SQL statement, review the database table structure. 

You can find the database table name in two ways: 

1) Using Entity Reference (ER) Views

a. Sign in as a Company Administrator. 

b. Go to the Company Workspace tab and switch to Admin mode. 

c. In the left Navigator, click Data Structure Setup > ER Views. 

d. Open Business Processes View. 

e. Use your browser search function and search for a BP you want to report against (for 
example, Invoices). 

The name of the table appears under the BP Name, in blue (for example, UNIFIER_UI. 
The word "unifier" is the prefix and common to all BP tables. The UI is the ID of the 
Invoices BP). 

2) Using BP IDs

a. Sign in as a Company Administrator. 

b. Go to the Company Workspace tab and switch to Admin mode. 

c. In the left Navigator, click uDesigner > Business Processes. 

d. Locate the BPs that you want to use in the report and find the IDs (first column). 

e. Add your deployment prefix and add an underscore ( _ ) to get the table name (for 
example, UNIFIER_UI). 

Note: To access the Line Items of a BP, add _LINEITEM to the table 

name (for example, UNIFIER_UI_LINEITEM). 

The following lists the column names: 

 Field Name 

 Definition 

 SQL Type 

 Label 

 Description 

Creating Data Cubes 

Data cubes comprise data that you can use to render a variety of charts (bar, area, column, line, 
and table) in a custom data block of a shell dashboard. In this way you can visually compare 
aspects of your data set. 
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Data cubes are either company level or shell level. The data source for data cubes can be from 
a business process or a manager attribute form, or from a data base query. The system does 
not limit the number of data cubes you can create. 

To learn how to create a data cube, see the following: 

 Granting Permissions for Data Cube (on page 33) to create a data cube 

 Defining a Data Cube (on page 30) a new data cube, which includes  

 Selecting the data source for the data cube 

 Completing the data cube properties 

 Publishing the data cube 

 Granting Permissions for Data Cube (on page 33) so they can view the data cube 
composition in Data Cube Definitions 

Defining a Data Cube 

To define a data cube 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Cube Definitions. The Data Cubes 
log opens. 

3) Click either New > Shell Data Cube or New > Company Data Cube. The Create Data Cube 
window opens. 

4) Select Data Type or Data View. 

 A data type comprises business process and manager attribute forms 

 A data view comprises results from a data base query 

Note: When creating data cubes, data views are only seen when you 
select Data View as the source. This is different from UDR creation 
when data views are listed with data types. 

5) Select a business process from the drop-down menu. 

6) Click OK. The Data Cube window opens. 

7) Complete the General tab. 

Name: enter a unique name for the data cube 

Description: this field is optional 

Data Type: this read-only field is automatically completed with the data type selection 

Type: this read-only field is automatically completed with the level selection 

8) Click the Data Source tab. On this tab you can add the data sources you want to include in 
the data cube, for example, a business process, workflow, or shell. 
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9) Click the Add button. The Data Sources window opens listing all available data sources for 
this data cube. 

10) Select at least one data source. You cannot move to the next tab or save the data cube 
without a data source selection. You can add as many data sources as are available. 

11) Click the Data Elements tab. 

12) Select at least one data element. You cannot save the data cube without a data element 
selection. You can add as many data elements as are available. 

The selected data elements are arranged in the Data Elements pane in a grid. 

 Data Source: The data element data source. 

 Label: The data element label. You can modify this label. 

 Name: The data element name. 

 Type: The data element type. 

 Group: Click to define whether the data element can be used as a Grouping element 
when the data cube is used. 

 Summary: Click to define whether the data element can be used as a Summary type. 

On this pane you have the option to add functions. To do so, click Add Functions. Select a 
function type: Formula, Date Difference, Date Add, Date Function. 

 For Formula click Create. Create a formula and click OK. The data source available for 
the formula are based on the data sources you selected in the Data Sources tab. 

 For Date Difference enter a column heading name, specify the dates, and whether to 
show partial days. Click OK. 

 For Date Add enter a column heading name, specify the date and the add function. Click 
OK. 

 For Date Function enter a column heading name and specify the date. Click OK. 

To modify a data element, select the data element and click the Modify button. 

To remove a data element, select the data element and click the Remove button. 

Use the Move Up or Move Down buttons to reorder the listed data elements. 

13) Click the Query tab if you want to add one or more queries to the data cube. See Define 
Report Queries (Query Condition) (on page 557). 

Data Cubes and Configuration Package 

Data Cubes are used for creating Shell dashboards. Data Cubes defined in the 
Development/Test environment can be transferred to the Production environment. 

You can pick and choose which Data Cubes to transfer by including the needed Data Cubes in 
the Component List and creating a Configuration Package by using the list.  

The Data Cubes log contains the following columns: 
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 Name 

 Description 

 Type 

 Source 

 Last Modified 

 Published Date 

 Last Published By 

When the configuration package is created, the system will check to ensure that the Data Cubes 
that have been included are in Publish status or not. If the Data Cubes that have been included 
are not in Publish status, then an error message is displayed at the time of creating the 
configuration package. 

Selecting Data Sources 

To select data sources for data cubes 

1) Click the Data Source tab. This tab lists the available data sources for the data cube. 

2) Click Add to add a data source. The Data Sources window opens. 

3) Select one data source or multiple data sources and click OK. 

4) To remove a data source, select a data source and click the Remove button. 

5) Next, define data elements in the Data Elements tab, as described in the following 
procedure. 

Adding Data Elements 

To add data elements for data cubes 

1) Click the Data Elements tab where you will see the fields listed in the table below these 
directions. 

2) Click Add Elements. 

3) Select one data element or multiple data elements and click OK. 

4) Click Add Functions. Select a function type: 

 Formula: Click Create and click OK after you have entered a formula for the data 
element. The data source available for the formula are based on the data sources you 
selected in the Data Sources tab. 

 Date Difference: Enter a column heading name, specify the dates, and whether to show 
partial days. Click OK. 

 Date Add: Enter a column heading name, specify the date and the add function. Click 
OK. 

 Date Function: Enter a column heading name and specify the date function, using an 
existing date data element. Click OK. 

Field Description 

Data Source The data element data source. 
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Field Description 

Label 
The data element label. You can modify 
this label. 

Name The data element name. 

Type The data element type. 

Group 
Click to define whether the data element 
can be used as a Grouping element when 
the data cube is used. 

Summary 
Click to define whether the data element 
can be used as a Summary type. 

Additional actions you can take 

 Modify a data element by selecting the data element and clicking the Modify button. 

 Remove a data element by selecting the data element and clicking the Remove button. 

 Reorder the listed data element by using the Move Up or Move Down buttons. 

Defining Queries 

To define queries for data cubes 

1) Click the Queries tab. 

2) Build a query. See Define Report Queries (Query Condition) (on page 557) for details on 
creating queries. 

3) When you have finished working with the Data Cube window tabs, click OK. 

Granting Permissions for Data Cube 

To grant permission for data cube creation, modification, or viewing 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, expand the User Administration grouping node and click Access 
Control. 

3) On the right pane, select Administration Mode Access > Data Structure Setup > Data 
Cube Definitions. The Permission Settings window opens. Here you can add, modify, or 
remove permission settings. 

4) Click the Add button. Another window called Permission Settings opens. 

5) Click the Add Users/Groups button. The Users/Groups window opens. 

6) Select the intended users and/or groups and click the Add button 

7) Click the OK button to return to the Permission Settings window. 

8) Select the users or groups in Select Users/Groups, located in the upper portion of the 
window, and select the appropriate level of access for the user or group in Permissions 
Settings, located in the lower portion of the window. 
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Create/Modify: You must have Create/View permission to create or define or change data 
cubes. This setting includes View permission. 

View: You can use this setting to allow users and groups to see the data cubes. 

9) Click the OK button. 

10) Click the Apply button to save changes and keep the window open, or the OK button to 
save changes and close the window. 

Publishing Data Cube 

You must publish data cubes to make them available for use in the configurable dashboard. 

To publish data cubes 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Cube Definitions. The Data Cubes 
log opens. 

3) Select a data cube and click the Publish button. 

Note: You can modify a published data cube, but you must republish it to 
make the changes available to users. 
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Setting up Shells 

A shell is where users can organize business information in one place to make managing it 
easy. You can use a shell to organize the information about projects, or facilities, in one place. A 
shell includes functions and features that are necessary for managing the information about 
projects, or facilities, within that shell. A shell is not required to function like a project. 

In This Section 
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Shell Administration and Set up 

Shell set up involves setting up permissions at several points during configuring and creating 
shells, so the users can have access to various aspects of working with the shell. 

Shell administration and set up involves the following steps: 

Note: The following presumes that the shell types have been designed 
and imported to the Company Workspace. 

1) Setting permissions for configuring the shells, in the Shell Manager. 
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2) Configuring the shells, in the Shell Manager. 

3) Setting permissions for administering the shell templates that can be used to create new 
shells. 

4) Creating shell templates. 

5) Setting permissions for adding, or modifying, shells. 

6) Creating new shells for use. 

Importing Shells 

All designs, including shell designs, are designed in uDesigner and deployed to Unifier. See 
Importing Configuration Packages (on page 619) for more information. 

About importing forms that contain data pickers 

Data pickers point to a data source for the records they display. A data source can be a 
business process, shell, space, planning item, or manager class. If the data source that the 
picker is pointing to is not in the system already, the application will warn you. 

The business process will not operate correctly until the data source is imported. 

CSV import or RESTful Services (Create Shell) 

When you create a shell instance by using CSV import or RESTful Services (Create Shell), the 
system copies the following into the created Shell: 

 The View Forms tab information from the selected shell template. 

 The forms added in the shell template, along with users and groups who are part of the 
viewers list. 

Setting Permissions to Configure Shell Types in the Shell Manager 

After shells are created, for the Users or Groups to be able to access various aspects of working 
with shells, you (the administrator) need to grant access, or permissions, to the Users or Groups 
at several points during the shell setup, or alternatively attain all the permissions from the shell 
template. When a shell is created, the permissions that have been set at the template level will 
be copied over. 

To set up permissions to configure shell types in the Shell Manager: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click User Administration > Access Control. 

3) On the right pane, select Administration Mode Access > Configuration > All > Shell 
Manager. 

For more information, see Edit User or Group Permissions using Access Control in the 
Unifier General Administration Guide. 

4) Click OK. 
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Configuring Shells 

Configuring a shell consists of activating it and organizing it into a hierarchy.  

Note: Before you configure shells, Oracle recommends that you plan the 
shell hierarchy with your users and uDesigner user. The instance, and 
cost settings, affect how you will use the shell and its relationship to 
other shells. Planning will help you achieve the result that will meet your 
business needs. 

As the administrator, you can configure the project numbering and the status of each 
project/shell type. As part of the numbering scheme, you can enable and disable automatic 
numbering and you can update the format and starting number. The system implements the new 
settings for records created after the change is implemented and ensures that unique labeling is 
maintained. If you change the value of Format or Start, the system cannot guarantee that the 
selected sequence is available due to possible conflicts with existing data and might alter the 
selected information to prevent a conflict. Changing this information might also create gaps in 
the numbering sequence. 

Example: If you specify a Format of ABC and a Start of 0001, and records ABC0001 through 
ABC0015 have been created, and you then change the Format to DEF and the Start to 0001, 
the system starts generating new records with DEF0001. If you change the Format to back to 
the original ABC and a Start of 0001, the system would begin the sequencing of new records 
using ABC0016. 

To configure the shell types in the Shell Manager 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > Shell Manager. 

3) Double-click the applicable shell type. 

The <shell name>-General Configuration window opens. 

4) On the General tab, complete the following fields: 

 Enable Automatic Numbering: To allow automatic numbering of projects based on the 
specified Format and Start values, select this option. You can deselect this check box to 
disable automatic numbering; it is selected by default. 

 Format: If you enable automatic numbering, specify the format of the numbering 
schema. By default, Format is blank. 

 Start: If you enable automatic numbering, specify the starting number. Start 
determines the starting number of the numeric schema. By default, Start is 0001. 

 Cost Codes: This read-only field displays the type of cost code specified in uDesigner for 
the shell type. 

 WBS: Standard Cost Manager 

 Generic: Generic Cost Manager 

 Status: Select the applicable status, Active or Inactive. Users cannot access shell types 
that have an Inactive status. The default is Inactive. 
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Note: If a project/shell is open and visible when its corresponding shell 
type is changed to Inactive, you cannot create a new shell of the 
applicable type but existing shells are not affected. 

5) Click the Organize tab. 

On this tab you can specify the sub-shell types that are allowed under the selected shell 
type. For example, assume you have configured a shell called Region, which has the 
sub-shell types Properties and Buildings. Also, Properties has Buildings as a sub-shell. The 
system performs validation during shell configuration, and manages the relationships among 
the shells that you configure. The table below shows the relationships among the shells 
described above. 

To add sub-shell types from the list of imported shells, click Add and select the applicable 
types. You can only add shells that have an Active status. 

6) Select the Active check box for the sub-shell types you want to activate. 

You can deactivate sub-shell types that you do not want users to use for sub-shell instance 
creation. You can deactivate a sub-shell type even if sub-shell instances have been created 
with that type. 

Note: You can remove a sub-shell type from the list by clicking Remove, 
as long as an instance of the sub-shell type is not created under the 
shell. 

7) When you are done, click Save. 

8) Complete the configuration steps for each shell type. 

Shells-> Parent Child Grandchild 

Sub-shells that are allowed 

Parent No No No 

Child Yes No No 

Grandchild Yes Yes No 

Update Generic Cost Sheet Columns and Rows 

You may have a large number of codes that are used within the Generic Cost Manager. In 
addition you may have a large number of shells in your implementation. To update codes and 
columns in your generic cost manager sheets with a minimal effort, you can push columns in a 
project or shell template generic cost sheet from the Columns Log to cost sheets. 
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About updating shell instance dashboards 

A cost sheet must exist in the destination shell. Pushing a column from a template will not create 
a cost sheet that can receive the column. 

You can push one column at a time. 

If a source column is a single data source, the destination column will be created with that single 
data source if it does not exist. (Column A or B in example below) 

If a source column is a formula with only single data sources, pushing the source column will 
create that column in the destination cost sheet, if it does not exist. (Column C in example 
below) 

If a source column is a formula with columns included in the formula, as long as all constituent 
columns contain single data sources, the source column can be pushed; for any columns that do 
not exist in the destination cost sheet, the formula will be changed to a single data source in the 
formula. (Column D in example below) 

If a source column is a formula with constituent columns that include logical data sources, the 
logical data source must exist in the destination cost sheet. The formula for the logical data 
source may be different in the destination cost sheet. Any column that contains a single data 
source will follow the rule above. (Column F in example below) 

To add or update generic cost sheet columns from a template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell-type template to update. 

4) In the shell template, navigate to Configurable Modules > Generic Cost Manager. 

5) Select the Generic Cost Manager Sheet template and click the Structure button. 

6) In the Generic Cost Manager Sheet log, select the cost sheet template and then click the 
Columns button. The Columns Log opens. 

7) Select a cost sheet column. 

8) Click Update Shells and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that were 
designed in uDesigner. When you have isolated the shells to update, click the Update
button. 

 All Shells: You can use this option to update all shells of that shell type. 
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 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

9) Click Yes if you want to proceed with the update, or No to cancel. 

To update generic cost sheet rows from a template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells in the left Navigator. 

3) Open the shell template you want to update. 

4) In the template, navigate to Configurable Modules > Generic Cost Manager. 

5) Select the template and click the Structure button. 

6) Select a row or rows to push to the project/shell level generic cost sheet. You can select 
multiple rows by holding down the Shift or Ctrl keys as you click the rows. 

The application will update leaf-level rows, but not summary rows. 

7) Click Update Shells and choose one of the following: 

 Shells: allows you to choose which shell(s) to update. You can use Find to search for 
specific shells to select from the complete list of shells. You can select as many shells as 
you want to update. The Page and Display fields display on the Shell Update window, but 
are disabled in this case. 

 All Shells: updates all active and on-hold shells 

 History: allows you to view the update history from past updates or cancel a request 
before the update begins. 

An Alert window opens, detailing the information that will be updated. Read the message 
carefully, as once a shell is updated, this action cannot be undone. 

8) Click Yes if you want to proceed with the update, or No to cancel. 

Update Standard Cost Sheet Columns 

To update columns in your cost manager sheets, you can push columns from the Cost Sheet 
Columns log to cost sheets in each shell and shell template. 

A cost sheet must exist in the destination shell. Pushing a column from a template will not create 
a cost sheet that can receive the column. 

To add or update cost sheet columns from a template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell-type template to update. 

4) In the left Navigator for the selected shell template, navigate to Cost Manager > Cost 
Sheet, and open the Cost Sheet template. 

5) In the toolbar, click Menu Options > Columns > Manage Columns. 

The Cost Sheet Column window opens. 

6) If applicable, drag and drop the listed columns to the order that you want to use. 
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7) Select the column, or columns, that you want to use in the update. 

8) Click Update Shells, and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the Update 
Shells window opens, it lists all shells in the project. You can use Search or Find on 
Page to isolate the shells you want to update. The find window contains data elements 
from the Find form that were created in uDesigner. After you have isolated the shells to 
update, click Update Shell(s) in the toolbar, and select either Selected Shell(s) or All 
Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

9) If you want to proceed with the update, click Yes; otherwise, click No to cancel. 

Configuring Shell Manager Configuration Package 

The following configurations can be included in the Shell Manager Configuration Package: 

 General setup 

All the fields included in the General Configuration (General tab). 

 Organize setup 

All the fields included in the Organize tab. 

Notes: 

 The sub-shells defined in the Shell hierarchy are also included in the 
Configuration Package. 

 The sub-shells defined in the Organize tab are included in the 
Configuration Package. 

 You can export the sub-shells. 

For more information, see Configuration Package Management (on page 567). 

Setting Permissions to Administer Shell Templates 

To set Shell Template administration access: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, expand the User Administration grouping node and click Access 
Control. 

3) On the right pane, select Administration Mode Access > Templates > Shells [shell 
node]. 

For more information, see "Edit user or group permissions using Access Control" in the 
Unifier General Administration Guide. 

4) Click OK. 
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Accessing a Created Shell Template 

From the Shells node under Templates, you can access the shell type templates that are 
created. 

One node is created under Shells for each shell type that is imported and that has an active 
configuration status. 

Note: Single-instance shells are not listed under Templates > Shells as 
there can only be one instance created for those shell types, and there is 
no need of a template. 

To access shell templates 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Expand the Shells node. Any shell templates are grouped by shell types. 

One node is created for each shell type imported. For example, Buildings, Linear Assets, 
Projects. 

4) Click one of the shell type nodes, for example Projects. The Projects Templates log opens. 
The log lists any project templates that have been created for that shell type. 

Create a Shell Template Manually 

The following procedure describes how to create a shell template. 

To create a shell template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells, and expand Shells to display the shell types. 

3) Click one of the shell type nodes. 

The <shell> Templates log opens. The log lists any shell templates that have been created 
under that particular shell type. 

4) From the Create menu, select Manual. 

The <shell> templates Details window opens. 

5) On the General tab, complete the fields as described in the table below. 

Note: The General tab that you see will depend on the Shell Attributes 
form that was imported. Required fields are marked with an asterisk (*). 

6) On the Currency tab, click the Add button. 

The New Currency window opens. 
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Note: The Base Currency shown at the top of the window is the Base 
Currency set up for your company. For example, if your company is 
located in the U.S., the Base Currency will likely be United States Dollar 
(USD). If your company does business internationally, you may make 
other currencies available for shell use. 

a. Complete the New Currency window: 

 To access the Currency Picker dialog box, click the Select icon in the Currency 
Name section. 

 Select a currency from the list and click Select. The available currencies were 
defined at the time your company was set up. (The currency list is maintained in 
Standards & Libraries > Exchange Rate.) Contact your Company Administrator 
if you need additional currencies. 

b. If the currency you selected is different from the company Base Currency, complete the 
following: 

 Rate: Enter an exchange rate to use for conversion calculations. 

 If Float is selected, the rate comes from the company active exchange rate set 
(Standards & Libraries > Exchange Rate). 

 A Peg rate is locked at the rate set. (Only an administrator can change the 
Peg rate, or Peg to Float or Hedge.) 

 If the Hedge selection is Yes, the Hedge rate is used. Otherwise, the Float 
rate will be used. If an amount is entered for the Rate, then the hedge rate is 
used until the amount specified is reached (by spends) and then the system 
will revert back to the active exchange rate. 

c. If applicable, enter information in the Comments box. 

d. Click Save to save and exit the New Currency window. 

e. The first currency that you add is selected as the default currency for the shell. If you add 
multiple currencies, you can select a different Default Currency from the drop-down list. 
This will be used as the default shell currency. After you have selected a shell currency 
and saved the template or shell, it cannot be changed. The selections are generated from 
the Currencies list you defined. 

Note: You cannot modify this default currency after you save the 
changes to the template Details window. 

7) On the Images tab, click the Browse (+) button to locate and upload any applicable graphics 
from your computer. 

You can upload an image to display on the landing page of the shell in both Administrator 
and User modes. 

8) On the Options tab, complete the applicable fields. 

You can select the phase of the shell on this tab. The phases available are based on the 
Phase data definition. 

Within the Shell Details, the user can select which attributes forms to use for the Document 
Manager, for both folders and documents. 
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From the Options tab, the user can define which attribute form (Document Manager 
Attribute Form) to use for the document/folder. By default , the "DMS Attributes" folder 
properties attribute form, which is system-defined in Document Manager, can be selected, 
and the corresponding Document Manager Attribute Form is used to determine the DMS 
structure. The user will have an option to choose other attributes forms as well. Only the 
active DM configuration forms will be available for selection. 

In case a previous active Document Manager configuration (in a shell) is marked as 
inactive, the DMS structure keeps that attribute form structure. When you open the shell 
details, the Document Manager Attribute is defaulted to system-defined attribute form 
because the previous configuration has been marked as inactive. The Document Manager 
Attribute Form User will show the previous DM attribute form that is kept by the shell. If you 
click OK, the system displays a message, informing you of this change. 

In case a previous active Document Manager configuration (in a shell) is deleted because 
the associate folder attribute form was deleted, the DMS structure is defaulted to the 
system-defined attribute form of a supported DMS structure for the shells. When you open 
the shell details, the Document Manager Attribute is defaulted to system-defined attribute 
form because the previous configuration has been deleted. The Document Manager 
Attribute Form Used will show the system defined DM attribute form that is kept by the 
shell. If you click OK, the system displays a message, informing you of this change. 

Project/Shell Creation BP behavior

While creating Project/Shell creation BP records, the shell template that has been selected 
via the shell picker keeps the folder properties attribute form that is mentioned in the 
respective templates and have the DMS structure accordingly. 

Company  behavior

The Company Workspace Document Manager is defaulted to the DMS attribute, which is 
system-defined. 

The Options tab also lets you select the entity that provides electronic signature technology 
(DocuSign or Adobe Acrobat Sign [Adobe Sign]). For Projects/Shells, the value for the 
E-Signature Type drop-down list is: Company Default. This means that the Company 
Administrator has selected Company Default in the Company Properties > E-Signatures tab. 
For more information, see Edit Company (E-Signatures Tab) in the Unifier General 
Administration Guide. 

Note: If a value (E-Signature Type) has been determined in the 
Company Properties > E-Signatures tab, the value of the E-Signature 
Type drop-down list (Standards tab) will be read-only. 

You can select a different value from the E-Signature Type drop-down list. 

The Company Administrator can click on the Company Properties > E-Signatures tab to 
change the default value (Default E-Signature Type). This change does not impact the value 
of the E-Signature Type in the project, and the values will remain as: 

 Company Default 

 DocuSign 

 Adobe Sign 
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The Options tab also lets you select the entity that provides electronic signature technology 
(DocuSign or Adobe Sign). For Shells, or Shell Templates, the default value for the 
E-Signature Type drop-down list is: Company Default. This means that the Project 
Administrator has selected the Default E-Signature Type in the Company Properties > 
E-Signatures tab as the E-Signature Type for the project. 

Note: If only one E-Signature provider has been determined in the 
Company Properties > E-Signatures tab, the value of the E-Signature 
Type drop-down list (Standards tab) will be read-only and set as 
Company Default. 

You can select a different value from the E-Signature Type drop-down list. 

The Company Administrator can go to the Company Properties > E-Signatures tab to change 
the default value (Default E-Signature Type). This change does not impact the value of the 
E-Signature Type in the project, and the values will continue to remain as Company Default, 
or as chosen by the Project Administrator. 

9) Complete the Links tab to add links to the shell. 

These links are displayed on the shell landing page in User mode. Use links to provide users 
with access to useful websites, your company's website, an intranet, or other destinations. 
Click Add and enter the name and URL for the links you want to add to the landing page.  

10) On the Calendar tab, create a shell calendar. 

Each shell can have its own calendar. You can use the:  

 Specified shell calendar to override the company calendar. 

 Company calendar for the shell.  

 Company calendar (marked as default calendar) for the shell if there is no shell calendar, 
or if the shell calendar is not being used.  

Shell calendars can be based on Standard Calendars created at the Company level, or 
Custom Calendars created for the specific shell. The shell calendar you create applies only 
to the shell for which you create that calendar. The calendar selected affects shell durations 
and due dates. For example, companies can have multiple projects in different countries that 
have different working and non-working days. These working and non-working days must be 
considered when determining such time-driven factors as business process workflow due 
dates and activity dates. 

Note: Unless otherwise specified, the default calendar for a shell is the 
Company calendar that is marked as default at the Company level. 

a. Open the Calendar tab of the shell or Template window. The calendar you create in this 
tab is known as the Project/Shell Calendar. 

b. You can select a company-level Standard Calendar, or use a Custom Calendar for your 
shell. The calendar that you select displays in the Calendar tab. 

 To use a Standard Calendar as the shell calendar, click the Standard Calendar 
radio button and select a calendar from the drop-down list. 

 To use a Custom Calendar as the shell calendar, click the Custom Calendar radio 
button and click Copy. You can copy a previously-created Standard Calendar and 
use it as the project calendar. 
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c. You can modify the displayed calendar. You can specify the working and non-working 
days for the calendar. Browse to the month and year using the pull-down menus at the 
top of the calendar. Saturdays and Sundays are set as non-working days by default. Do 
one of the following: 

 To set a particular date as a non-working day (for example, a holiday), click the 
date on the calendar and select Non Working. The date will appear grayed out, 
and will not be used in date calculations. 

 To set a non-working day as a working day, click a grayed cell and select 
Working. 

 To set a particular day of the week (for example, every Saturday) as a 
non-working day, click the day at the top of the calendar (for example, "Sat"), then 
click Non Working. All Saturdays in the calendar will be changed to non-working 
days (gray). 

 To set a particular day of the week as a working day, click the day at the top of the 
calendar, then click Working. 

 If you only want to set the day of the week in a particular month as working or 
non-working days, select each day individually and click Working or Non 
Working. 

Note: If you have marked the day of the week as a non-working day 
throughout the calendar by selecting the day at the top of the calendar 
(for example "Sat"), then you will not be able to mark individual days 
(that is, individual Saturdays in this example) as working days. To be 
able to include both working and non-working instances of a day of the 
week on the calendar, you must select them individually. 

d. Click OK. When you click OK, the calendar displayed in the Calendar tab is the shell 
calendar. 

11) When you are ready to save information and exit the window, click Save. 

In this field Do this 

Description 
Enter a description of the shell type 
template. 

Administrator Select an administrator for the template. 

Location Disabled for template creation. 

Status 

You can activate the shell immediately, or 
place it On-hold and activate later. A 
template that is On-hold or Inactive cannot 
be used to create a shell. It is good 
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In this field Do this 

practice to leave a shell or template 
On-hold until you have completed the 
setup. Shell Administrators/Users with 
"modify shell status" rights are the only 
ones who can change the status. 

The Shell Administrator will receive email 
notification when the status of a shell 
changes. The change of shell status could 
occur due to a manual change, bulk 
update, through Web Services or a CSV 
file, or through automatic update. 

Status definitions for shells are: 

 Active: Active, in-progress shell. All 
shell actions in User and Admin mode 
are available. 

 On-hold: The initial shell status. 
On-hold shells appear on the shells 
log. Shell administration functionality is 
available to shell administrators for 
setup and maintenance for users with 
permissions to perform that function. 
Users cannot create records in a shell 
that is On-Hold. If a user attempts to 
access a shell that is On-Hold, the 
system displays an alert message 
stating that the shell is On-Hold. 

 View-Only: For end users, View-Only 
shells can be viewed, printed, 
exported, and included in reports. They 
cannot be modified. When a shell is 
View-Only, the status overrides (but 
does not modify) access control 
permissions, granting only View 
permissions. The shell reverts to the 
access control permissions when the 
shell is made Active. View-Only shells 
can roll up to UDRs and dashboards. 
Business process records cannot be 
auto-created in View-Only shells. Data 
from View-Only shells rolls up to 
Generic Cost Manager cost sheets if 
all the shells in the hierarchy are 
generic. Data rolls up to dashboards 
on a View-Only shell from child shells 
in the hierarchy, and rolls up to a 
parent shell from a View-Only shell. No 
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In this field Do this 

updates can occur to View-Only 
projects through Integration, Mobile, or 
through reverse auto-population. 
View-Only shells cannot be updated 
through templates. Consolidate line 
item functionality is disabled for 
View-Only shells. Users can navigate 
through the shell hierarchy using 
View-Only shell instances. View-Only 
shells have only view, export, and print 
permissions available. Tasks and 
Drafts are not available for View-Only 
shells. Messages are available, but 
users cannot add general comments. 
Mailbox is available for viewing, but 
users cannot send, edit or delete 
messages for View-Only shells. When 
a shell becomes View-only, all 
scheduled jobs associated with it are 
canceled. When the status of the shell 
changes back to Active, you must 
restart any scheduled jobs. 
Administrators can perform all actions 
on View-Only shells. 

 Inactive: Used to suspend shell 
usage. Inactive shells are visible from 
the Admin mode under Sponsored 
Shell log only, but not visible under the 
Shells node (that is, only Sponsor 
Company can access the shell), or in 
User Mode logs and selections. Only 
System and Shell Administrators 
(users with Modify Status rights) can 
reactivate the shell. 

Note: "Late" tasks in an inactive shell may 
still show up in users' tasks logs. Though 
they can access the task, no transactions 
can be performed in the inactive shell.  

Auto-update Status Setup 

The selections on the drop-down list are 
defined automatic status update setups. 
These setups are defined at the Company 
level for use in specific shells. For more 
information, see Setting up Automatic 
Update of Shell Status. If you decide not 
to use the automatic status update, you 
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In this field Do this 

can deactivate it by deselecting a setup 
(by literally selecting the word "Select"). 

Shell Number Unique number that identifies the shell. 

GeoCoding 

Details for mapping. This field appears if 
geocoding was set up in uDesigner for the 
shell.  

Note: After a currency is selected and saved, it cannot be modified. The 
remove option is made available so that you can remove the additional 
currencies and unsaved changes. 

Create a Shell Template by Copying a Template or Shell 

You can create a Shell Template by copying from an existing shell template or an existing shell. 

To create a shell template by copying an existing shell or shell template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells, and then select a shell type. 

3) From the Create menu, select From Template or From Shell. 

You can use the Search and Find on Page options to look for a specific shell or template in 
the list. 

4) In the Select Modules pane, select the modules to include in the new template. 

The modules available depend on the cost code type of the shell or shell template (CBS or 
Generic). See Shell Cloning Window Selections (on page 50) for the lists of available 
modules by cost code type. 

5) After you are done selecting the modules to include, click Done. 

6) In the template Details window, update the applicable tabs and fields. 

Most properties are copied from the original shell or template with the following exceptions: 

 Currency: On the Currency tab, specify the Shell Currency 

 Image: On the Images tab, specify the Shell Image (optional) 

The status is set to On-Hold. 

7) Click Save. Click Yes to confirm. 
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Shell Cloning Window Selections 

In a shell log, when you click the Copy button, the cloning window lists optional calendar, 
module, manager, sheet, and structure selections. You must select an item to include it in the 
new shell. See Create a Shell by Copying a Template or Shell (on page 62). 

Cloning Window Selections for all Shell Templates and Shells (Both CBS and Generic 
Codes) 

The following is a list of the selections:  

User/Groups

This is not an optional selection; users and groups in a template or shell are always included 
by default. 

BP Setup

You have the option to copy all, or none, of the business processes and their setups that are 
in the template or shell. 

Templates do not allow record creation of multiple-record business processes, but they do 
allow record creation of single-record business processes under the Information > General 
node. If you added a single-record business process into the template or shell, and created a 
record, that record with all of its data is cloned when you select this option. 

Configurable Modules > Configurable Managers (CM1 through CM25) >

Configurable Managers are designed in uDesigner, and have flexible coding structures to 
data collection and analysis. Each manager appears in the module selection pane by its 
unique name. 

Custom Calendars

Custom calendars provide a means to address variations in work schedules, holidays, and 
other non-working days. You can add custom calendars to a shell detail form on the 
Calendar tab. 

Dashboard Setup

Shells and templates may have multiple dashboards, each governed by unique permission 
settings. 

Document Folder Structure

Folder templates help standardize document organization in the Document Manager. 

Gates Setup

Gates provide a means of automating when a project moves to the next phase. 

Resource Manager

Manage personnel resources using the Resource Manager. 

Space Manager

Manage levels and facilities using the Space Manager. 

User Defined Reports
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You can create multiple user-defined report templates and include them in the new shell 
during cloning. 

Cloning Window Selections for Only Generic Code Shell Templates and Shells 

The following is a list of selections.  

 Commitment Summaries: In the same way the schedule of values summarizes all cost 
information related to a particular commitment business process, the commitment summary 
tracks commitment record information. 

 Generic Cost Manager (CM0): The Generic Cost Manager captures cost-related 
transactions for a generic shell. Each generic shell can have one Generic Cost Manager. 

Cloning Window Selections only for CBS Code Shell Templates and Shells 

 Cash Flow: Cash flow is the distribution of cost over time— in project management terms, it 
is the movement of cash into or out of a project measured during a specific time period. 

 Commitment Funding Sheet: A funding sheet tracks project funding —where it comes from 
and how it is being spent. You can create one funding sheet per template or shell. See 
Setting up the Funding Manager (on page 390). 

 Cost Sheet: The cost sheet provides detailed tracking of the project's budget and costs. You 
can create one cost sheet per template or shell. See Setting up Cost Sheets (on page 
356). 

 Schedule of Values: The schedule of values summarizes all cost information related to a 
particular commitment business process. See Setting Up Schedule of Values (SOV) (on 
page 419). 

 Rules: Project cost or funding rules impose conditions on project transactions per rule 
queries. See Creating Rules and Rules Templates (on page 438). 

 Schedule Sheet: Schedule sheets track project activities and milestones. You can have 
multiple schedule sheets in a project. Once created, they cannot be deleted. 
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Shell Template Modules and Managers 

In shell templates you can prepare modules and managers to make standardized templates, 
which ensure project uniformity and greatly reduce the potential for errors. You can have 
different templates for different project models. For example, you can have one template for 
"cookie-cutter" projects that do not change, and you can have another template for projects that 
might incur substantial changes. The system will copy any prep-work when you use the template 
to create a new shell, a process called cloning. Manager and module availability can differ 
depending upon CBS or generic code specification in uDesigner. See Create a Shell by 
Copying a Template or Shell (on page 62).  

Managers and Modules Available in all Shell Templates (Both CBS and Generic Codes) 

The following lists the managers and modules that are available in all Shell Templates for both 
CBS codes, and the Generic Codes. 

Member Companies 

In order to make partner companies that you added at the company level available in your 
projects, you add them in Member Companies. Member companies added to a shell template 
automatically copy to a shell during cloning. For more information, see Managing Member 
Companies (on page 63). 

Access Control 

For modules and managers included in a shell template, you can assign user-mode permissions. 
Permissions set in a template will automatically copy to a shell during cloning. Keep in mind, 
records created in user mode may require permission assignment in user mode. 

User Administration 

Users and groups added to a template are copied by default from the template to a new shell 
during cloning. For more information, see User Administration in the Unifier General 
Administration Guide. 

Users

Users added to a template automatically copy to the shell during cloning. Users added to 
shell templates cannot be deleted, only inactivated. 

Groups

Groups added to a template, and any users added to these groups, automatically copy to 
the shell during cloning. 

Setup 

Business Process
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You have the option to copy all, or none, of the business processes and their setups that 
were added to a template. For more information, see General Procedures for 
Setting up Business Processes (on page 243). If you added a single-record 
business process to a template, and created a record, that record with all of its data 
will be copied during cloning. For more information, see Single-Record Business 
Processes (on page 255). 

Dashboards

You can define dashboards in a template and opt to include them when you clone a new 
shell from the template. For more information, see Creating a Shell Dashboard in a 
Template (on page 180). 

Gates

Gates provide a means of automating when a project moves to the next phase. You can 
define gates in a template and opt to include them when you clone a new shell from 
the template. For more information, see How to Set Up Gates (on page 170). 

Planning Manager

This is where you can plan for new projects, and create proposals and forecasts for 
projects already running in the system. 

Resource Manager

This is where you can set up and manage personnel resources in a company, project, or 
shell. 

Material Inventory Manager

This is where you can manage materials within the company, project, or shell. 

Information 

This is where single-record business processes exist. When you clone a template, any 
single-record business processes are copied as well. For more information, see Single-Record 
Business Processes (on page 255). 

Configurable Modules > Configurable Managers (CM1 through CM25) >

Configurable Managers are designed in uDesigner, and have flexible coding structures to 
allow data collection and analysis. 

Document Manager

You can create a folder structure for the Document Manager that can be used across 
shells. These can be created from Folder Structure Templates, or folders can be 
added manually. Unlike Folder Structure Templates, you can also assign users 
folder-level permissions (if they are in the shell template), and can import folders and 
folder properties. 

Space Manager

This is where you can manage facilities for the company, project, or shell.  

Reports

You can create one or more user-defined report templates, which will be used for 
shell-level user-defined reports.  
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Selections Available in only Generic Code Shell Templates 

Configurable Modules > Generic Cost Manager (CM0) 

The Generic Cost Manager captures cost-related transactions in a Generic Shell. These can 
include costs like rent, lease payments, or landscape care that are based on time scales 
such as monthly, quarterly or yearly. Each generic shell can have one Generic Cost 
Manager. 

Cost Manager > Commitment Summaries

In the same way the schedule of values summarizes all cost information related to a 
particular commitment business process, the commitment summary tracks commitment 
record information. See Setting up the Commitment Summary Template (on page 450). 

Selections Available only in CBS Code Shell Templates 

Cost Manager

 Cash Flow 

Cash flow is the distribution of cost over time - in project management terms, it is the 
movement of cash into or out of a project measured during a specific time period. 

 Cost Sheet 

The cost sheet provides detailed accounting of the project's budget and costs. You can 
create one cost sheet per template or shell. See Setting up Cost Sheets (on page 356). Set 
up the standard cost sheet template and copy it into the shell template. 

 Earned Value 

The earned value module provides quantitative tracking information about project or shell 
status using earned value analysis. You can only set User mode permissions in a template. 

 Funding 

The Funding Manager helps you to keep track of where project funding comes from and how 
it is being spent. You can create one funding sheet per template or shell. See Setting up the 
Funding Manager (on page 390). 

 Schedule of values (SOV) 

The SOV sheet summarizes all cost information related to a particular commitment business 
process. This is where you define structures for General Spends, Payment Applications, or 
Summary Payment Applications. 

You can define a General Spends SOV structure by copying from an SOV template in the 
Templates log. 

For Payment Application SOV and Summary Payment Application SOV, the structure is 
copied from the line item grid structure of the Payment Application Business Process. This 
means that you must first complete the Business Process (BP) setup for the Payment 
Application BP before you can create the structure. See Setting Up Schedule of Values 
(SOV) (on page 419). 

Rules

You can define shell-level cost or funding rules. See Creating Rules and Rules Templates (on 
page 438). 
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Schedule Manager

 Schedule Sheets 

A schedule template will be used to create the schedule sheet. Like the cost sheet, once this 
is created, it cannot be deleted. 

Activity Manager

 Activity Sheet 

 WBS Sheet 

 OBS Sheet 

 Custom Calendars 

See the Activity Manager chapter of the Earned Value Management User Guide to learn more 
about the functionality of the Activity Manager nodes. 

Shell Templates

If the Data Element (DE) "uuu_int_schedule_type" is not included in the attribute form, then: 

 The template that has the option "Enable P6 sources" selected is not included when you 
want to create a Cost Sheet using: New > Cost Sheet > Copy from Template. 

 The cost sheet that has the option "Enable P6 sources" selected is not included when you 
want to create a Cost Sheet by copying a cost sheet from a Shell instance. 

If the DE "uuu_int_schedule_type" is included in the attribute form, then: 

When you add a Cost Sheet to the template (using a standalone template or by Copy from 
other Shell instances), you can only select a "Tree" structure cost sheet. 

Notes:

 You can select any Cost Sheet irrespective of whether the option 
"Enable P6 Sources" is selected or not. 

 After you create a Cost Sheet , the option "Enable P6 Sources" is 
available for edit. 

 After you add columns to the Cost Sheet using "P6 Data Sources" 
you cannot clear the property. 

 If you remove the columns using P6 Data Sources, you can deselect 
the "Enable P6 Sources" option. 

The value for the DE "uuu_int_schedule_type" remains blank because the DE is read-only. 

Document Manager Template 

Use the Document Manager template to create folders, perform actions, update shells, and find 
folders. 

 Create Folder: Create folders in the template. 
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 Actions: Perform the following actions (Export, Import, Index Report, Move, Copy, Delete, 
Permissions) on a folder. 

 Update Shell Templates: Use this drop-down menu to update the permissions, or the 
Structure & Permissions for a particular shell template or all shell templates. You can also 
view the update history. 

 Update Shells: Use this drop-down menu to update the permissions, or the Structure & 
Permissions for a particular shell or all shells. You can also view the update history. 

 Delete: Delete a log item. 

 Find on Page: Find folders by filtering on the various columns. 

 Expand/Collapse: To open or close all sub items in the log. 

Note: The Comment, Lock, Ref and BP columns are not displayed in the 
document template log. 

Manage Shell Templates 

To open the shell template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Select a shell type. The shell templates log opens. 

4) Select a shell template from the log and click Open. 

To edit shell template properties 

1) From the shell template home page, click the three dots in the upper right corner and select 
Details. The template Details window opens. 

2) Click the tabs to view or edit shell template properties. 

Adding View Forms in Shell Template 

You (the project administrator) can set up the View forms in shell templates. For details, see 
Setting Up View Forms in Shell Attributes. 

When you create shells using shell templates, the View Forms tab information will be copied 
into the created shell. In addition: 

 All the View forms that are added in the template will be copied into the created shell. 

 All the users or groups, who are a part of the viewers list in the View forms, will become the 
members of the newly created shell. 

Setting Permissions to Create or Modify Shell Instances 

To set shell instance access: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click User Administration > Access Control. 
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3) On the right pane, select Administration Mode Access > Company Sponsored Shells > 
[shell node]. 

4) See Edit User or Group Permissions using Access Control in the Unifier General 
Administration Guide, and select these permissions depending on what access needs to be 
granted: 

 Create: Allows the creation of new shell instances 

 Modify Status: Allows the modification of the status of shell instances 

 Modify Properties: Allows the modification of shell instance properties 

 Configure User Dashboard: Allows the configuration of the shell dashboard in the User 
mode. This is the dashboard listed as My Dashboard in the View Dashboard
(drop-down list) that displays for the end-user in a shell instance. 

5) Click OK. 

Creating a Shell 

There are multiple ways to create a shell. 

 Manually, from scratch 

 Copying from a shell template 

 Copying from an existing shell 

 Importing via a CSV file 

 Using a shell creation business process 

When you create a shell from a shell template or by copying another shell, any shell dashboard 
that exists in the source template, the system copies the dashboard into the destination shell. 

Create a Shell Manually 

To create a shell manually 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells, and then select the applicable type 
from the functional nodes list. 

Notes: 

 Ensure that you configure and test shells in the Development 
environment before you import them into the Test or Production
environment. 

 The DE of type Rich Text DE is not available to be added to the 
Company Sponsored Shells. 

3) From the Create menu, select Manual. 

The Details window opens. 

4) On the General tab, complete the fields as described in the table below. 

Note: The table only lists the required fields that are common across 
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most shells. The shell that was designed for your company will include 
other required and optional fields. Required fields are marked with an 
asterisk (*). 

5) On the Currency tab, click the Add (+) button to add a default currency for the shell, and 
use the information in the table below for guidance. 

Note: You cannot modify this default currency after you save the 
changes to the Details window. When you click Apply to save changes, 
you will receive a confirmation warning that reads:  "You are about to 
create a new <Shell Type Name>. The default currency of this <Shell 
Type Name> is <Currency Name> (<Currency Code>). After the <Shell 
Type Name> has been created, this default currency cannot be 
changed. Are you sure you want to continue?" If you click Yes, you will 
not be able to change the default currency. 

6) On the Images tab, click the Browse (+) button to locate and upload any applicable graphics 
from your computer. 

You can upload an image to display on the landing page of the shell in both Administrator 
and User Modes. 

7) Click the Options tab, and complete the fields. 

You can specify a phase of the shell, select a time zone for background jobs, and configure 
email notification. (For information on this mailbox, see Dedicated Mailbox for Shells.) 

8) Complete the Links tab to add links to the shell. 

These links are displayed on the shell landing page in User mode. Use links to provide users 
with access to useful websites, your company's website, an intranet, or other destinations. 

Click Add and enter the name and URL for the links you want to add to the landing page. 

9) Click the Calendar tab, and select one of the following options: 

 Standard Calendar: This option lets you use a standard calendar for your shell. You can 
select the Company Calendar (Default) or other listed calendars. 

 Custom Calendar: This option lets you use a custom calendar for your shell. You can 
use Copy to select a calendar or create a custom calendar. 

10) If applicable, click the Gateway Integration tab, and enter the Project ID of the Source 
Project. 

11) When you are ready to save information and exit the window, click Save. 

In this field Do this 

Administrator Select an administrator for the shell. 

Location
The Location picker lets you change the 
location of a shell, and is accessible when 
you set up a shell or modify the shell 
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In this field Do this 

details. See Location Picker Behavior
(on page 62) for details. 

Use the Location Picker to select where 
the shell instance will reside. In the 
Location picker: 

 Find searches the current level 

 Open shows the next level of shells 

 Select completes the action 

 Location Picker will allow breadcrumbs 
to display through the hierarchy 

 Work systematically from the top of the 
hierarchy to the bottom 

 There must be an instance of a single 
shell to connect to 

You can use the Location picker to 
reorganize the shell hierarchy. The shell 
can move across tabs, or laterally along 
the hierarchy. When you move a shell 
instance, all of the shell data moves with 
the shell. If an auto-populated business 
process moves with the shell instance, 
then the auto-populated data moves with 
the business process. Data for the 
business process will be collected from the 
new shell location. In addition, if a child 
shell has been designed with linked 
elements, field values on the shell's 
attribute form or single-record BPs will be 
automatically updated to reflect changes 
when the shell is moved. 

Status

You can activate the shell immediately, or 
place it On-hold and activate it later. A 
shell that is On-hold or Inactive cannot be 
used. It is good practice to leave a shell 
On-hold until you have completed the 
setup. Shell Administrators/Users with 
"modify shell status" rights are the only 
ones who can change the status. 

Status definitions for shells are: 

 On-hold: The initial shell status. 
On-hold shells appear on the shells 
log. Shell administration functionality is 
available to shell administrators for 
setup and maintenance for users with 
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In this field Do this 

permissions to perform that function. 
Users cannot create records in a shell 
that is On-Hold. If a user attempts to 
access a shell that is On-Hold, the 
system displays an alert message 
stating that the shell is On-Hold. 

 Active: Active, in-progress shell. All 
shell actions in User and Admin mode 
are available. 

 View-Only: For end users, View-Only 
shells can be viewed, printed, 
exported, and included in reports. They 
cannot be modified. When a shell is 
View-Only, the status overrides (but 
does not modify) access control 
permissions, granting only View 
permissions. The shell reverts to the 
access control permissions when the 
shell is made Active. View-Only shells 
can roll up to UDRs and dashboards. 
Business process records cannot be 
auto-created in View-Only shells. Data 
rolls up to dashboards on a View-Only 
shell from child shells in the hierarchy, 
and rolls up to a parent shell from a 
View-Only shell. No updates can occur 
to View-Only projects through 
Integration, Mobile, or through reverse 
auto-population. View-Only shells 
cannot be updated through templates. 
Consolidate line item functionality is 
disabled for View-Only shells. Users 
can navigate through the shell 
hierarchy using View-Only shell 
instances. View-Only shells have only 
view, export, and print permissions 
available. Tasks and Drafts are not 
available for View-Only shells. 
Messages are available, but users 
cannot add comments. Mailbox is 
available for viewing, but users cannot 
send, edit or delete messages for 
View-Only shells. When a shell 
becomes View-only, all scheduled jobs 
associated with it are canceled. When 
the status of the shell changes back to 



Setting up Shells

61

In this field Do this 

Active, you must restart any scheduled 
jobs. Administrators can perform all 
actions on View-Only shells. 

 Inactive: Used to suspend shell 
usage. Inactive shells are visible from 
the Admin mode under Sponsored 
Shell log only, but not visible under the 
Shells node (that is, only Sponsor 
Company can access the shell), or in 
User Mode logs and selections. Only 
System and Shell Administrators 
(users with Modify Status rights) can 
reactivate the shell. 

Note: "Late" tasks in an inactive shell may 
still show up in users' tasks logs. Though 
they can access the task, no transactions 
can be performed in the inactive shell. 

Currency Name

Select the currency you want to use for the 
cost functions in this project. 

If the currency you select is other than the 
company Base Currency, complete the 
following fields. 

Rate

Enter an exchange rate to use for 
conversion calculations. From the 
drop-down list select one of the following: 

 If Float is selected, the rate is updated 
automatically from the Co. Currency
tab (Standards & Libraries > 
Exchange Rates). 

 A Peg rate is locked at the company 
rate on the day the rate is set. (Only a 
Project Administrator can manually 
modify the Peg rate to a value other 
than the company peg rate.). 

Enable Hedge
If you select this check box, the Hedge 
rate is used for conversion calculations. 
Otherwise, the Float rate will be used. 

Rate

(Optional) If an amount is entered for the 
Rate, the hedge rate is used until the 
amount specified is reached (by spends) 
and then the system will revert back to the 
normal rate. 

Amount (Optional) 
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In this field Do this 

If Float is specified, the system will 
retrieve the rate, based on today's date 
and time. 

If Peg Rate is specified, the field will be 
editable. 

Comments
(Optional) Add any comments that might 
be necessary to explain the default 
currency. 

Location Picker Behavior 

The Location Picker opens when you click the Select button for Location. 

You can use this Location picker to select a shell instance. The multiple instance shells are listed 
under the single shell instances, which are represented as tabs. You can select a tab on which 
the shell is listed on the organization configuration. 

When this picker is first opened, it displays the instance of single shell. You can select an 
instance by highlighting it and clicking the Select button. You can expand or hide the single shell 
instances, and you can use the toolbar to filter or search for a shell instance. 

Create a Shell by Copying a Template or Shell 

You can create shells using the shell templates you created. You can also create shells by 
copying from existing shells. You can verify the shell properties, make changes as necessary, 
update status, or activate as necessary. 

Note: As Shell Administrator, you can receive email notification of the 
successful creation of a shell. This notification can be set up in email 
notifications in uDesigner. Also, you can set your User Preferences to 
control whether you receive these notifications. 

Creating a shell from a shell template or another shell, copies shell dashboards in the source 
template or shell to the destination shell. You can choose to copy any existing Custom 
Calendars from the template or from an existing shell. The system also copies the restrictions 
defined on the Record Properties tab of the Business Process setup from the selected shell or 
shell template to the new shell. For example, if the Record Properties tab is used to prevent 
users from downloading attachments, this restriction carries forward. 

To create a shell from a shell template or existing shell 

1) Go to the Company Workspace tab and switch to Admin mode. 
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2) In the left Navigator, click Company Sponsored Shells, and then select the applicable type 
from the list of functional nodes. 

3) From the Create menu, select From Template or From Shell. 

4) In the Copy from Shell Template or Copy from Shell window, select the applicable 
template or shell. 

You can use the Search and Find on Page options to look for a specific shell or template in 
the list. 

5) In the Select Modules pane, select the modules to include in the new shell. Users and 
Groups are selected by default and copied along with the shell properties. 

For more information about the modules available for selection in the type of shell you are 
cloning, see Shell Cloning Window Selections (on page 50). 

Note: When you copy a shell or template, you also copy existing setups 
in the modules you selected. If you select BP Setup when you copy a 
template, you will copy any existing business process setups, including 
those for any single-record business processes (SRBPs). SRBP setups 
and record data are copied along with everything else. 

6) After you are done select the modules to include, click Done. 

7) In the Details window, update the applicable tabs and fields. 

Most properties are copied from the original template or shell with the following exceptions: 

 Number: On the General tab, enter a Number for the shell template. If automatic 
numbering is specified, this field is read-only. 

 Currency: On the Currency tab, specify the Shell Currency. 

 Image: On the Options tab, specify the Shell Image (optional). 

8) When you finish completing the shell details, click Save. 

9) When the confirmation message appears, click Yes to create the shell. 

Managing Member Companies 

If your company has set up Partner Companies, those companies can become eligible to be 
added to shells. When added to a shell, these companies become Member Companies, and 
their users can participate in shells with any permission level you set for them. 

Note: The list of eligible partner companies is maintained in the Partner 
Companies log. In Admin mode, navigate to User Administration > 
Partner Companies to view the list. 

Add a Member Company to a Shell 

Active partner company users (users with a unique user name, and status of Active or On Hold) 
can be added to shells and assigned permissions, just like sponsor company users. 

To add a member company to a shell 

1) Go to the Company Workspace tab and switch to Admin mode. 
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2) In the left Navigator, click Company Sponsored Shells > <shell type > <shell name > 
Member Companies. The Member Companies log opens. 

3) Click the Add button. The Add Member Companies window opens. This window lists the 
available partner companies that can be added to the shell as a member company. 

You can click the Find button to search for a particular company by Company Name or 
Contact Name. 

4) Select one or more companies from the list and click the Add Member button. 

5) At the confirmation window, click Yes. The company is added to the Member Companies 
log. 

View Member Company Profile 

To view a member company profile 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell] > [shell instance] > 
Member Companies. The Member Companies log opens. 

3) Select a company from the list and click Open. The Company Profile window for the 
company opens. This is a view-only window. This information is maintained by the partner 
company's administrator. 

4) Click the General tab to view general information, and the Address tab to view contact 
information. 

Remove a Member Company from a Shell 

You can remove a member company from the shell's Member Companies list. When a member 
company is removed from a shell, users belonging to the member company will be automatically 
inactivated for that shell. 

To remove a member company 

1) Select the company and click the Remove button. 

2) At the confirmation window, click OK. This will remove the selected company from the list 
and inactivate any users who have been added to the shell. 

Managing Shell Users and Groups 

The User Administration grouping node (Admin mode) lets you manage the following: 

 Partner Companies

 Company Users

 Partner Users

 Groups

 Task Reassignment

 Active User Tasks

 Inactive User Tasks

 Integration Users
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This section discusses adding groups and users to shells, managing shell groups, audit log, and 
managing shell permission levels. 

For more information about integration users, refer to the Unifier Integration Interface Guide. 

Add a User to a Shell 

After you have created a shell, you will need to add users to the list of approved shell users. 
Shell users can be from your own sponsor company, or from approved member companies. 

When adding users from your company to the shell: 

 To add users from your own (sponsor) company, the user must be either Active or 
On-Hold at the company level. When added, the user will automatically be Active for the 
shell. 

 Users who are inactive at the company level cannot be added to a shell. 

When adding users from a partner company to the shell: 

 In order to add a user from a partner company, the company must first be added to the 
Member Companies list for the shell. The user must be either Active or On-Hold at the 
company level. When added, the user will automatically be Active for the shell. 

 The user does not necessarily need to be listed in the Partner Users log at the company 
level in order to be added to a company. If the user is listed in the Partner Users log, the 
user must be Active or On-Hold. If the user is not already in the Partner Users log, they 
will be automatically added to the list of Partner Users with a status of Active. 

To add users to a shell 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell] > [shell instance] > User 
Administration > Users. The Users log opens. The log lists all users that are already part of 
the shell. 

3) Click New. The User/Group Picker opens. 

Note: If a User Attribute form has been imported, the shell user log will 
reflect the design of any designed Partner Log included in that form. For 
more information, see Importing User Attribute Form in the Unifier 
General Administration Guide. 

4) Click the List Names from drop-down list at the top of the picker window and choose the 
company from which to add the new shell user. 

This drop-down lists your sponsor company plus any member companies that have been 
added to the shell. You can click the Member Companies node under the shell to view the list 
of available member companies. 
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Note: By default, new users will have a status of Active. You can 
change the status or other user detail information selecting the user from 
the list and clicking Open. 

5) Select one or more users to add to the shell. You can press the Shift or Ctrl keys to select 
multiple users at once. 

6) Click the Add button. You can continue to select and add names to the Selected Users 
portion of the picker window. 

7) Click OK to add the users to the shell. The new users are listed in the Users log. 

To add a user to a shell template 

Open the shell template and navigate to User Administration > Users. Follow the steps above 
to add a sponsor company or member company user to the template. 

View or Edit a Shell User's Profile 

You can edit a shell user's details. These procedures apply to sponsor company users and 
member company users. 

To view or edit a shell user profile 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell] > [shell instance] > User 
Administration > Users. The Users log opens. 

3) Select a user from the list and click Open. The Edit Shell User window opens. The window 
has the following tabs: General, Groups, Permissions and Custom. 

Note: If a User Administration design has been imported by your 
Administrator, the content of this profile can vary. 

4) In the General tab, review the contact information for the user as it will appear in the Shell 
Directory. By default, the shell address (as defined in the shell details) displays as the 
contact address. You can edit this information as necessary. 

You can also modify the user's shell status: 

 Active: User is listed in Shell Directory, in User/Group Picker, User can log in and 
participate in the shell. New users are Active by default. 

 Inactive: If you deactivate a shell user, the user's name will not appear anywhere for 
selection on any shell-related functions. The user will not be able to access the shell. 
Inactivating a user at the shell level does not affect their status on other shells. 

 On-Hold: User can be added to a shell, or assigned as a participant in a business 
process workflow but cannot log in. 
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5) Select the Show user on the Shell Directory option, if you want the user's information to be 
viewable in the Shell Directory. 

6) In the Groups tab, you can add or remove the shell users to a shell-level group the same 
way that you add company users to company groups. Click the Add button to add a group to 
the user's list, or select a group and click Remove to remove the user from the group. 

7) In the Permissions tab, you can assign shell-related permissions to the user, by module and 
mode. 

8) In the Custom tab, you can view available custom attributes that may have been added to 
the user form. 

Create and Manage Shell Groups 

Groups are a way to aggregate users together so that adding new team members to the shell 
and assigning permissions can be done quickly and efficiently. For example, groups can be 
members of the same shell team, and/or they can be users who share the same access 
privileges. At the company level, groups can span shells. At the shell level, all members of a 
group are members of a given shell. Different members of a shell may have different access to 
functionality, depending on their role on the shell. 

For example, a Finance person might require access to cost modules and reports dealing with 
finances, but not RFIs or Transmittals and their associated reports. An Executive might require 
access to Summary financial information, and not the cost BPs. 

As users are added to a Group, they will inherit the Group's permissions. If they are in more than 
one group, then the highest level of permissions granted in any group for a module will prevail. 

When adding users to the group, you can choose eligible users from the sponsor company and 
any partner company users. The company short name will be listed in the User Picker window 
next to each user. 

Company level groups cannot be copied into a shell. 

To create a group 

1) Open the shell and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell] > [shell instance] > User 
Administration > Groups. The Groups log opens. 

3) Click New. The Groups window opens. 

4) Complete the General tab: 

 Group Name: Enter a name for the group 

 Manager: Click Select and select a user from the User Picker window. This is the person 
who will be responsible for administering the group. 

 Description: Enter an optional description for the group. 

5) Click the Members tab. This is where you add and manage group membership. 

a. Click Add. 

b. From the User/Group Picker, select the users to add to the group and click Add.

c. Click Ok. 
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6) Click the Permissions tab. In this tab, you manage group permission settings. If a user is a 
member of the group, the user will inherit all group permissions. 

Granting permissions to the group is similar to granting permissions to individual users. 
Choose the shell-related permissions for the group that will apply to all members assigned to 
this group. Choose permissions by module and mode. 

7) In the Custom tab, you can view available custom attributes that may have been added to 
the group form. 

To edit group information 

1) Open the shell and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell] > [shell instance] > User 
Administration > Groups. The Groups log opens. 

3) Select a group and click Open, or double-click the selected group. The Groups window 
opens. 

4) Make changes as necessary and click OK. 

Groups and Audit Log 

The Audit Log provides the following information about any action that has been taken on the 
Groups: 

 Date

 Event

 Action

 Field

 Old Value

 New Value

 User Name

 Proxy User

 Attachment

To access the Audit Log for the Groups functional node: 

1) Go to your shell and switch to Admin mode. 

2) In the left Navigator, click User Administration > Groups. 

3) In the Groups log, select a group (select a record), click View, and click Audit Log to open 
the Audit Log. 

The Audit Log captures all the actions that have taken place on that selected record. 

When you (the Admin) add a user to a group by using a user data picker, the user's name will be 
seen in the Audit Log. The Action column of the Audit Log will include the nature of the action 
(Member Added), indicating that a user was added by way of the <data picker label> user data 
picker. The Old Value column will remain empty (null), and the New Value column will include 
the name of the user that was added, followed by a colon (:), followed by the name of the 
company that the user belongs to <firstname lastname:Company Name>. 
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Grant Shell User Permissions through Shell Access Control 

After you have created a shell, assign permissions to the people who need to access the shell. 
You can use Access Control to grant multiple Users or Groups permission simultaneously, rather 
than editing the properties for each User or Group individually. 

To view or change a shell's access control 

Do either of the following: 

 Open the shell, switch to Admin mode and click Access Control in the Navigator. 

 Go to the Company Workspace tab and switch to Admin mode. In the left Navigator, 
click Company-Sponsored Shells > [shell type] > [shell]. Then click Access Control
in the Navigator. 

The system displays a copy of the Navigator menu in the right pane of the window. In this right 
pane, you may click different modules of the Navigator menu to set permissions for those 
functions. 

Generate and Print Access Information Report 

You can generate and print an Access Information summary of user and group access 
(permission settings). The report will display all user and group permissions. 

To generate the Access Information report 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell] > [shell instance] > 
Access Control. 

3) Click the Access Information button. The Access Information window opens. It may take 
several moments to generate the report. 

To print the Access Information report 

1) Generate the Access Information report. 

2) Click the Print button. (When the report is complete, the Print button becomes available.) 

Create Shells using an Imported CSV File 

An Integration interface must be created for shell creation to work via CSV file. 

To create shells using an imported CSV file 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells. 

3) Select a shell type. 

4) From the Actions menu, select Export Template, and then select Shell Creation Template. 

5) Complete the shell creation template CSV file. Some hints: 

 The shell location must have a leading /. Be sure to use the true shell name as entered in 
the Shell Manager configuration. 
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 Shell statuses are Active or Inactive. Use initial capitalization. 

 Administrators must be valid users. You might enter the user's full name (for example, 
Henry James) or the system user name (for example, hjames) depending on the 
configuration. 

 If using currency override, be sure the currency is active in Exchange rates and the CSV 
file contains a valid currency code. 

6) From the Actions menu, select Import > From Template. 

7) Select the modules to include in the shell. 

8) Select the template from the listed templates and click OK.

9) Browse for the CSV file and open it. 

10) Click OK. 

Reasons for a Shell Creation business process CSV failing to import 

 Any incorrect rows will cause the CSV upload to fail and an error message will display the 
incorrect row number. 

 Incorrect shell location used (this has to be set up before importing a CSV). 

 Invalid shell name or number. 

 The location on the imported CSV file is not a valid parent location. 

 The sub-shell of the type that you are importing was not configured under the parent location 
specified. 

 Currency override used an invalid currency code or the currency was not active in Exchange 
rates. 

Notes:

 If shell creation fails, the user who attempted to import the CSV will 
get an email notification of the import failure. 

 When creating a shell through CSV, the Document Manager attribute 
form that is associated with the template, or shell instance, will be 
copied over to the new created shell. 

Create Shells with Shell Creation Business Process 

Before you begin, review these conditions for successful Shell creation from the Shell creation 
business process: 

 Shell creation business process must be designed and deployed in uDesigner and 
configured and set up in Unifier 

 Shell template must be created 

 Shell hierarchies must be correctly configured in Shell Manager 

 Shell number must be unique 

 Shell override currency, if it is to be used, must be active in Exchange Rates 
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The shell creation business process can synchronously auto-create a multiple-instance CBS or 
generic shell anywhere in or across a shell hierarchy. The business process uses a shell 
location picker to assign where the shell will reside in the hierarchy, and a shell picker to select a 
template. This means shell organization must be correctly configured in the Shell Manager and 
the shell template must be created. 

The shell creation business processes designer can define the business process as company 
level or shell level. The designer may use workflow to support review and approval processes, or 
elect to design the business process without workflow. At run time, the system passes select 
information captured in the business process form to the newly created shell, thus avoiding 
redundant data entry. Reaching terminal status, as defined in uDesigner, triggers the 
synchronous shell creation process. If there is a planning item picker on the shell creation 
business process record or line item, the system will link the planning item to the new shell.  

Notification 

The system will send an email notification upon successful shell auto-creation, provided 
notification is set up in business process setup, the system has a valid email address for anyone 
selected to receive notification, and those selected subscribe to email notification in user 
preferences. If auto-creation fails, the system will immediately send an alert to those selected to 
receive notification. 

There are two types of shell creation business processes: simple and line item. 

 Simple-type 

The simple-type shell creation business process creates one shell per record. Reaching a 
terminal record status triggers the synchronous shell auto-creation process. The business 
process designer has the option to either define workflow or not. The designer can define 
integration; in Unifier, you can obtain the business process import template from the 
business process log. 

It is important to note that the CSV import template must be correctly completed or the 
system will reject the CSV file in its entirety and not create any shells. When the system 
rejects a CSV file, it creates an error file that tells you which line item is in error and why it is 
in error. To ensure a successful upload of the shell creation business process CSV file, retain 
the column headings in the same order as exported, and complete all required fields. 

 Line Item-type 

The line item-type shell creation business process creates a shell for each line item. Use the 
upper form to create the parent shell and each line item to create a child shell. Auto-creation 
happens when: 

 Record terminal status is reached 

 Line item status is met 

 A line item passes validation 
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At run time, when the system processes a line item-type shell creation business process 
record, it will create a shell from each line item that passes validation. For example, if there 
are 10 line items in the shell creation record, but only five pass validation, the system will 
create five shells. Shell creation line items can be consolidated, provided consolidation is 
configured. 

CSV Import or RESTful Services (Create Shell) 

When you create a shell instance by using CSV import or RESTful Services (Create Shell), the 
system copies into the created Shell: 

 The View Forms tab information from the selected shell template. 

 The forms added in the shell template, along with users and groups who are part of the 
viewers list. 

Integration Tab 

The Integration tab in shell template attribute window is used to map multiple P6 projects with 
the respective Unifier shell.  

Note: The mapping is only used for the Activity Sheet.  

The Integration tab in shell template attribute window has the following options: 

 Add

 Remove

 Apply

 OK

 Cancel

The Integration tab in shell template attribute window has the following columns: 

 Project ID

An alphanumeric field that can be populated using Add. The Project ID cannot be modified 
or removed from this tab. 

 Project Name

 Schedule Type

While you create the mapping, you are required to enter only the Project ID (marked as 
mandatory field). Unifier populates the other columns (Project Name and Schedule Type) when 
you run project synchronization. 

When you add projects, using this tab, to create an Activity Sheet: 

 You cannot modify, or remove, a Project ID. 

 If the Link Multiple Projects option is not disabled, then the system uses synchronization in 
multiple P6 projects. 

If the user decides to change the existing mapping setup (Activity Sheet), Unifier replaces the 
existing Activity Sheet with P6 projects after the next synchronization. 
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If a user tries to remove (Remove) a project that is mapped to an Activity Sheet, Unifier cannot 
process the change because the schedule for the project is present in the Activity Sheet. 

You can integrate multiple P6 projects into one Unifier project. 

 When you integrate (Project ID mapping) a P6 project into a Unifier project through the 
General tab of the Shell Attribute form, Unifier updates the Schedule Type field in General 
tab. The General tab is mostly used for one-to-one integration (one P6 project mapped to 
one Unifier project). 

 When you integrate (Project ID mapping) multiple P6 projects into one Unifier project through 
the Integration tab of the Shell Attribute form, Unifier does not update the Schedule Type
field in the General tab. In the Integration tab, the Schedule Type column is updated. The 
Integration tab is mostly used for many-to-one integration (many P6 projects mapped to one 
Unifier project). 

CBS Type Shell for a Non-EVM User 

Updating a CBS type shell

In a CBS type shell, when a non-EVM user opens the shell details (My Dashboard ... > 
Details), they can click the Integration tab to add only one P6-related project (click the plus 
sign symbol: Add Project ID). If there is an Activity Sheet available, and the user decides to 
add a schedule for the project, then Unifier will display a message informing the user that the 
existing schedule in the Activity Sheet will be replaced with the added schedule for the 
project. If the user selects Yes, then the new schedule will be included in the Integration tab 
and the Add External Project ID option becomes disabled. 

Use the gear menu to delete the added, or existing, schedule for the project. 

After a non-EVM user adds a new schedule for the project and clicks Save, the shell 
dashboard page opens and displays the new schedule project information in the Details 
block. This enables the non-EVM user to proceed with data synchronization. 

To synchronize data: 

 In the left Navigator, expand the EVM node. 

 Click the Activity Sheet sub-node. The Activity Sheets log opens. 

 Click the Get Data icon. The Get Data window opens. 

 Click inside the Project field and add the schedule for the project. 

 From the Activity Sheets log (on the right panel), click the History tab, and click the 
Refresh icon. 

 From the Activity Sheets log (on the left panel), click the activity sheet to open it. 

The Activity Sheet log lists all of the activities for the added schedule for the project. 

Similar to an EVM user, a non-EVM user can use the following tabs of the Activity Sheet log 
(on the right panel) to see more information: 

 General

 Assignments

 Audit Log

The non-EVM user can click the Assignments tab, click the gear menu of resource, and 
perform the following: 
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 View Assignment Spread

 Assign CBS

 Assign Rate Source

The non-EVM user can click an activity (in the Activity Sheet log) and select the following 
options: 

 View Activity Spread

 Assign CBS

The non-EVM user cannot add a column to the WBS Sheet (WBS Sheet sub-node, from the 
left Navigator). The same limitation (inability to add column) applies to the Cost Sheet (Cost 
Manager node > Cost Sheet sub-node, from the left Navigator). 

Creating a CBS type shell

When creating a new CBS type shell (Company Workspace (Admin mode) > Company 
Sponsored Shells > Projects), a non-EVM user can use the Integration tab to add a single 
source project ID (click Add). 

CBS Type Shell for an EVM User 

The shell Integration tab enables you to link to a single or multiple Oracle Primavera Cloud 
projects. 

 Users with EVM license can add multiple Oracle Primavera Cloud projects to be linked to a 
Unifier project. 

 Users without EVM license will be able to link to a single Oracle Primavera Cloud project 
using the Integration tab. 

You can add the Oracle Primavera Cloud Project ID using the Add option in the Integration tab. 
All validations (regarding valid project ID, duplicate Project ID, and so on) will take place when 
you add a Project ID in the Integration tab. The Project Name and Schedule Type columns will 
be read-only, and the values will be populated once the Oracle Primavera Cloud project is 
synchronized with the Unifier project. 

The Project Name value will populate with the name of the Oracle Primavera Cloud project, and 
the Schedule Type will be populated with the default value: Duration. The following other fields 
(in shell details) are populated if the shell is synchronized with the Oracle Primavera Cloud 
project, using the Project Number from the shell attribute form: 

Shell 
Status

Populated with a valid status value. It can be: Active. 

Note: The Shell Status will be populated or updated only when the shell instance is created by using a new 

OOTB synchronization from Gateway (Send Activity data from Primavera Cloud to Unifier). When a user 

gets activity data using the Get Data option in the Activity Sheets log, the value of the Shell Status will not 

be updated. 

Project 
Start Date

The start date of the project, received from the Oracle Primavera Cloud 
project. This data element in the shell attribute form will get updated only 
when a project is created from the Gateway. 

Integrated 
with

This data element in the shell attribute form will be populated as: 
Primavera Cloud. 
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Note: For projects that are integrated with Oracle Primavera Cloud using 
the shell Integration tab, the Shell Status and the Project Start Date will 
not be updated. 

Project Mappings in Gateway

Oracle Primavera Cloud Gateway Unifier 

projectName Name ProjectName 

dataDate DataDate Data_date 

projectCode Id ProjectNumber 

Start Date DataDate uuu_project_start_date 

status Status uuu_shell_status 

The plus (+) option will be disabled once you add the Oracle Primavera Cloud Project ID, and 
the data from Oracle Primavera Cloud project will be synchronized with the Unifier project in 
case the user does not have an EVM license. 

A user with an EVM license will be able to add multiple Oracle Primavera Cloud Project IDs, and 
the data from multiple Oracle Primavera Cloud projects can be synchronized with the Unifier 
project. Furthermore, the Schedule Type field will be shown as 'Duration' for all of the Oracle 
Primavera Cloud projects in the Integration tab of shell details. In the shell details General tab, 
the field Integrated with is populated as: Oracle Primavera Cloud. 

Managing Shells 

You can verify the shell properties, make changes as necessary, update status, or activate as 
necessary. Oracle recommends that you keep the information up to date to reflect the ongoing 
status and progress of the shell. 

You can also modify shell information in a shell type template and then update one or more 
existing shells by "pushing" the information from the template to the shells (see Updating Shells
(on page 78)). 

To open a shell 

Click the tab for the shell. The shell landing page opens. 

To edit an existing shell 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells, select the shell instance, and 
double-click the applicable shell in the log. The corresponding dashboard opens. 

3) Click the more menu option (the three horizontal dots icon next to My Dashboard) to open 
the drop-down list and click Details to open the shell Details window. 

4) Modify the shell information as necessary. 
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Depending on your permissions, you can modify any of the shell properties any time during 
the shell duration, except for the shell currency. After a shell is set up, the shell currency is 
locked. 

The Location picker lets you change the location of a shell, and is accessible when you set 
up a shell or modify the shell details. See Location Picker Behavior (on page 62) for 
details. 

Use the Location Picker to select where the shell instance will reside. In the Location picker: 

 Find searches the current level 

 Open shows the next level of shells 

 Select completes the action 

 Location Picker will display breadcrumbs through the hierarchy 

 Work systematically from the top of the hierarchy to the bottom 

 There must be an instance of a single shell to connect to 

Note: You can use the Location picker to reorganize the shell hierarchy. 
The shell can move across tabs, or laterally along the hierarchy. When 
you move a shell instance, all of the shell data moves with the shell. If an 
auto-populated business process moves with the shell instance, then the 
auto-populated data moves with the business process. Data for the 
business process will be collected from the new shell location. In 
addition, if a child shell attribute form or a single-record BP in a child 
shell has been designed with linked elements, the child shell attribute 
data and BP data will be automatically changed to reflect the new parent 
shell's current attribute values. 

5) Click Save to save your changes and exit the Details window. 

To deactivate an existing shell 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells, select the shell instance, and 
double-click the applicable shell in the log. The shell window opens. 

3) Click the more menu option (the three horizontal dots icon next to My Dashboard) to open 
the drop-down list and click Details to open the shell Details window. 

4) On the General tab, go to the Status field and select Inactive. 

Note: If you deactivate a single instance shell, you cannot access that 
shell again to activate it. The shell will persist, but not be accessible. 

5) Click Save to save your changes and exit the Details window. 

To copy the customized user attributes from the company-level directory 

You can copy (bulk) any customized user attributes from the company-level directory and paste 
them into the shell. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, expand the Company Sponsored Shells node. 
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3) Click Projects sub-node to open the Projects log. 

4) From the Actions menu, select Export > Export Users, and select one of the following 
options: 

 All Shells

 Selected Shells

5) Follow the prompts. 

After your selection, the system will download (bulk) an Excel sheet (CSV file) with all the 
existing users. To copy the company-level directory values under the Copy Attributes column 
for the shell, click Yes. 

If you do not click Yes, no values will be copied from the company-level directory. 

To complete the importing of the values: 

1) From the Actions menu, select Import > Import Users. 

2) Use the file selection window to select the updated CSV file. 

3) Proceed with importing the values by uploading the Excel sheet (CSV file). The system will 
update (bulk) the user attributes data elements and their values. 

When you create a project or shell using the Create > Manual option, you must either add users 
manually or through a CSV file. After creating the project or shell, you can import the 
information. If you add a user manually, the Copy Attributes from Company Workspace
option (in the General tab of <shell> > User Administration > Users or Groups) lets you 
import the values in the Copy Attributes column of the CSV file. 

If you copy user attributes values from a shell template, the shell template attributes for the 
Users are also copied over. 

By default, the system adds the project administrator to any newly created, or copied, shell. In 
this scenario, the additional attributes will not be copied. 

Packaging Single Instance Shells 

You can package Single Instance Shells that exist in the Development/Test environment in 
order to transfer the Configuration Package to the Production environment. 

The Configuration Package that you create will include: 

 The Shell details data (data from all tabs in the Shell). 

 The currency defined in the Currency tab and if the selected currency does not exist in the 
destination environment, the system will create it. 

Note: The Currency attributes such as Code, Name, Symbol, and so 
forth are not updated when you import the Configuration Package, and 
after you create the shell, the Currency tab content will not be updated 
upon subsequent imports. 

 The calendar from the Calendar tab and if the selected calendar does not exist in the 
destination environment, the system will create it. 

The following Shell details are included in the Single Instance Shell: 
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Note: The following Shell details are exported and imported to the 
destination environment only on the first import. No subsequent updates 
of Shell details data can be performed in the destination environment. 

 Shell data that exists in the form for the following fields: Shell Name, Shell Number, 
Administrator, and Shell Status. 

The Shell log is a user-defined log, and the user-defined columns appear next to the 
system-defined columns. 

When you create a Single Instance Shell Configuration Package successfully, the system 
stamps the Shell with the Last Packaged Date. 

Shells cannot be created if they are not activated in the Configuration module, so the 
configuration of the Shell will be included in the Shell Configuration Package at the time of 
transfer between environments. 

Note: The contents of the Organize tab, which defines the Shell 
hierarchy, will be included. 

Updating Shells 

The Update Shells function lets you quickly add or modify information in a shell. This will "push" 
the new information to the shells that you specify. By allowing data to be entered or modified 
once, this function helps to reduce set up time and ensure cross-shell uniformity. 

The Update Shells function is available for select modules in shell type templates. Go to: 
Company Workspace > Admin mode > Templates > Shells

Note: When you copy a Setup (Company Workspace > Admin mode > 
Templates > Shells > Projects > … > Setup > …) from a Shell template, 
all the fields in the shell details block will be copied. 

The modules that you can update are listed below. 

 Users: users, group membership, permissions 

 Groups: group names, permissions 

 Business Processes and BP Setups: Business processes, setups 

 User-defined Reports: Reports, report permissions 

 Access Control: modules, users, groups, permissions 

 Cost Sheet: Cost sheet columns, column access and restrictions 

 SOV: General and Payment Applications structures 

 Commitment Funding: Commitment funding sheet structure 

 Cash Flow: Properties and permissions 

 Rules: Cost or fund rules 

 Schedule Sheet Properties: title, description, Master Schedule, status, auto-control, 
project start date, and error notification. Updating Schedule Sheet Properties from 
Templates (on page 497) 
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 Gates: Active or Inactive setups 

 Shell Instance Dashboards: dashboards created at the shell level, and are available for 
users to view (but not edit) with granted permissions 

Each of these modules has an Update function where you can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form (designed in 
uDesigner). This makes targeting shells with specific information possible. For example, if you 
add new users, to the company, and need to add them to many shells, but not every shell, you 
can add them to a shell template and use the Update Shells functional to add the users to only 
those shells that require them.  

Shells with a status of Active or On-Hold can be updated with this functionality. Inactive or 
View-Only shells can only have their users or groups updated with this functionality. Users with 
create permission for the shell type template modules can do this operation. 

Note: You update shell information one module at a time. Any Active or 
On-hold shells can be updated in this way. 

When you create a configuration package for your shell templates, the system includes the 
following configurations from the selected component list: 

 All shell templates that are included in the component list. 

 Content of the shell template. 

 Configuration of selected shells and business processes. 

You can package the shell templates that exist in the Development/Test environment and 
transfer the configuration package to the Production environment, and your configuration 
package will include the shell details data (data from all tabs in the shell setup). 

Currency

The currency, defined in the Currency tab, is included as a part of the configuration package. If 
the selected currency does not exist, then the system creates one in the destination 
environment. The currency attributes such as Code, Name, Symbol, and so forth cannot be 
updated by means of configuration package import. The Currency tab content is update upon 
every import. If the exchange rates, defined for currencies in the source shell template, do not 
exist in the destination environment, then the system creates a new exchange rate record for 
that currency and that exchange rate will be set to Active, and: 

 The Effective is set to the configuration package Import Date. 

 The Peg rate is brought over from the source environment. 

 The Float rate is brought over from the source environment, if the rate does not exist in the 
destination environment. 

Calendar

The calendar, from the Calendar tab, is included as a part of the configuration package. If the 
selected calendar does not exist, then the system creates one in the destination environment. 

Shell Details
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The following shell details, in the form, will be exported and imported in the destination 
environment upon every import: 

 Text fields, Pull downs (Integer and String), Radio buttons, check boxes, Integer, Decimal 
and Currency Amounts and Dates. The dataset values, or the default values, will not transfer 
unless you include those in your configuration package. 

Note: Any picker that refers to some other design object like BP pickers, 
data pickers, and so forth will not be included. 

 The contents of the Organize tab (shell configuration), which defines the shell hierarchy, will 
be included. This includes the defined sub-shells. 

Shells cannot be created if you do not activate them in the Configuration module. 

The configuration package creation will fail if: 

 The design of the included shell is not a part of the component list. 

 The shell design version that is included in the component list does not match the deployed 
Shell design version. 

Business Processes

 A Shell Template can have several Business Processes in the Development/Test
environment. 

 Only those Business Processes that have been included in the configuration package, 
marked as publish for production, can be transferred to the Production environment. 

 The configuration package can contain Workflows that have been set up (activated in 
Configuration module). If there are multiple Workflow setups in a Business Process, then all 
the setups are included in the configuration package, regardless of the status. 

 Business Processes, and other design objects, in a template depend on their setups in the 
Configuration module. Only the configuration setups of the Business Processes, and the 
Shell that the Business Process resides in, are included in the template can be a part of the 
configuration package. 

 In Workflow setups, where additional filtering on assignees exist for steps, the published 
design for user attribute form in the configuration package must include the deployed design. 

 In Workflow setups, in case the Advance workflow when next step is determined option 
is selected:  

 When the user updates shells (Update Shells option), all of the shells (or the selected 
shells) will receive the next step setup. 

 When the user updates a BP setup, from an environment different than the current 
environment, then the next step setup will be imported. 

User-Defined Reports (UDRs)

You can transfer User-Defined Reports (UDRs) that have been included in a Shell Template 
(Company Workspace > Admin mode > Templates > Shells) from Development/Test
environment to Production environment. The data source for the reports can be a design, a 
Data View, or a system-provided source. 

Single Record Business Process (BP)
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The data from the Single Record BP gets exported from the source environment and then gets 
imported into the destination environment. This includes: Text fields, Pull downs (Integer and 
String), Radio buttons, check boxes, Integer, Decimal and Currency Amounts and Dates. The 
dataset values, or the default values, will not transfer unless you include those in your 
configuration package. 

The following data/items are not included in the configuration package: 

 Any picker that refers to some other design object like BP pickers or data pickers. 

 Attachments, linked records, and general comments. 

Groups and Users

 Only the Shell Administrator user will be extracted for User Mapping, when importing the 
configuration package. 

 Only groups will be extracted for the selected components in the shell templates. 

Access Control

 For both Admin and User modes, the user can select the permissions for the Design objects 
in shell templates. 

Updating Shell Formation - General Procedure 

In general, the Update Shells feature works like this: 

Step 1. In Admin mode, open a shell type template. 

Step 2. Navigate to one of the modules listed above. Add or edit data. 

Step 3. Click the Update Shells button. Select which information within the module to update, 
and which of your active or on-hold shells to "push" the information to. New information will be 
added to the selected shells. Edited information will overwrite existing data. 

You can also cancel a shell update before it reaches the In Process status. 

Detailed instructions for updating specific types of shell information is found in the following 
sections. 

Updating Shells, Users 

You can add new users to multiple shells at once by adding them to a shell template in the User 
Administration > Users module. 

When adding new users to a shell, you can assign individual permissions directly to the new 
user, or add the user to a group to apply group permissions. 

The Update Shells process runs in the background. Depending on the number of records and 
shells you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Update History window shows the complete date. 
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Notes:

 Users are identified by their unique User ID. 

 Any Active, Inactive or On-hold users can be pushed. 

 Users can be pushed to Active, Inactive, On-Hold, or View Only
shells. 

 If the user does not exist in the shell, the user will be added to the 
shell with the permission settings and group membership. 

 If the user exists in the shell, the user information is updated 
(replaced) with the user information as entered in the shell template. 
This includes permission settings and group membership. 

 If a group that the user was added to does not exist in the shell, the 
group will be added, and the user will be added to the group. Group 
permissions are not updated; this is done by updating groups. 

 If the group exists, the user will be added to it. Group properties and 
permissions will not be affected. 

To add or update users using Update Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell type template to update. 

4) In the shell type template, navigate to the User Administration > Users log. 

5) Add a user to the shell type template, or select a user to edit. Define user parameters and 
assign permissions. 

6) Select one or more users in the Users log. 

7) Click the Update Shells button and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the 
selected shells; there is no undo for the update. 

8) Click Yes if you want to proceed with the update, or No to cancel. 

To delete users 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell type template to update. 

4) In the shell type template, navigate to the User Administration > Users log. 
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5) If you are not an administrator or owner of an item in the template: 

a. Select the shell user for deletion. 

b. You can click on the Usage option, which downloads the usage report. 

c. The usage report lists all the references of the selected user in the template. You can 
check if the deletion would impact any area of the usage report. 

d. Select the Delete option. 

e. A confirmation message is displayed along with Yes and No options. 

f. If you choose Yes, then the item is deleted and all the user references are removed from 
the template. 

The system deletes the user even if the selected user is the only user under the Assignee
section of any workflow BP. You must manually open the BP and save the user in order to 
move them to an Inactive status. You can also assign a new user in the workflow. 

6) If the selected user is an owner of a document, cost sheet, work sheet, schedule sheet, or 
User-defined report: 

a. Select a user ID and click on the Delete option. 

b. A confirmation message is displayed along with Yes and No options. 

c. If you choose Yes, then the system closes the message and automatically downloads the 
usage report without performing a deletion. You can refer to the usage report to 
understand the impact areas and take the necessary action. 

7) If you select multiple users and all of them are owners of a document, cost sheet, work 
sheet, schedule sheet, or User-defined report: 

a. Select the user IDs and click on the Delete option. 

b. A confirmation message is displayed along with Yes and No options. 

c. If you choose Yes, then the system closes the message and automatically downloads the 
usage report for all the selected users without performing a deletion. You can refer to the 
usage report to understand the impact areas and take the necessary action. 

8) If you select multiple users and none of them are owners of any content in the template: 

a. Select the users and click on the Delete option. 

b. You can select all the users and click on the Usage option, which downloads the 
combined usage report for all the selected users. 

c. A confirmation message is displayed along with Yes and No options. 

d. If you choose Yes, then the system deletes all the selected users. 

9) If you select multiple users and a few of them are owners of some elements in the template: 

a. Select the users and click on the Usage option. 

b. The system downloads the combined usage report for all the selected users. 

c. Select the Delete option. 

d. A confirmation message is displayed along with Yes and No options. 

e. If you choose Yes, then the system automatically downloads the usage report for the 
remaining users who are restricted from deletion. 

f. Another confirmation message is displayed along with Yes and No options. 

g. If you choose Yes, then the system deletes the selected users that are not owners. 

You can refer to the usage report to further understand why some users cannot be deleted. 
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10) The push functionality and the copy shells work the same as they did previously. If a user is 
deleted and the record can no longer be selected, then a push cannot be performed. 
However, if a user is deleted and the shell template is copied to create a new template, then 
the deleted user would no longer be included. When a user is deleted and the shell is 
selected for download as part of a Component List in a Configuration Package, the 
deleted user is no longer part of the package. Any existing shells are not affected by the 
changes made and the deletions performed. 

Updating Shells, Groups 

You can add or update Group names and Group permissions by using the  Update Shells
option. That is to state, when you push Groups: 

 Groups will be added or updated 

 Groups Permission will be added or replaced 

The update process runs in the background. Depending on the number of records and shells 
you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Update History window shows the date that it was 
completed. 

 Groups are identified by their unique Group Name. 

 All group properties, including permission settings, will be added or updated in the shells that 
you selected. 

 Groups can be pushed to Active, Inactive, On-Hold, or View Only shells. 

 If the group does not exist, the group will be created with the permission settings. Group 
membership (user list) will not be updated in the shell. 

 If a group of that name exists, the properties and permissions of that group will be replaced 
with the new group, but not the list of users. 

 Users are not automatically added to the group; they need to be added by updating users 
(group membership). 

To add or edit user groups using Update Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell template to update. 

4) In the shell type template, navigate to the User Administration > Groups log. 

5) Select one or more groups from the Groups log. 

6) Click Update Shells and choose one of the following: 
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 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

7) Click Yes if you want to proceed with the update, or No to cancel. 

To delete user groups 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell template to update. 

4) In the shell type template, navigate to the User Administration > Groups log. 

5) If you select a single group in the template: 

a. Select the shell group. 

b. You can click the Usage option, which downloads the usage report for the selected 
group. This behavior is dependent on the browser you are working in. 

c. The usage report lists all the references of the selected group in the template. You can 
check if the deletion would impact any area of the usage report. 

d. Select the Delete option. 

e. A confirmation message is displayed along with Yes and No options. 

f. If you choose Yes, then the item is deleted and all references of the selected group are 
removed from the template. 

 The system deletes the group even if the selected group is the only assignee in any 
workflow BP. You must manually open the BP and save the group for it to move to an
Inactive status. You can also assign a new user in the workflow. 

 The system should not allow the deletion of the Project Administrators group. If you 
select the Project Administrators group and click the Delete option, then a confirmation 
message is displayed along with an OK option. Click the OK option to proceed further. 
You can select the Project Administrators group and click the Usage option to 
download the usage report for the group. 

6) If you select other groups apart from Project Administrators: 

a. Select the shell groups. 

b. You can click the Usage option, which downloads the combined usage report for the 
selected groups. This behavior is dependent on the browser you are working in. 

c. The usage report lists all the references of the selected groups in the template. You can 
check if the deletion would impact any area of the usage report. 

d. Select the Delete option. 

e. A confirmation message is displayed along with Yes and No options. 
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f. If you choose Yes, then the item is deleted and all references of the selected groups are 
removed from the template. 

The system deletes the groups even if the selected group is the only group under the 
Assignee section of any workflow BP. You must manually open the BP and save the group 
for it to move to an Inactive status. You can also assign a new user in the workflow. 

7) If you select multiple groups for deletion that include Project Administrators: 

a. Select multiple shell groups. 

b. You can click the Usage option, which downloads the combined usage report for the 
selected groups. This behavior is dependent on the browser you are working in. 

c. The usage report lists all the references of the selected groups in the template. You can 
check if the deletion would impact any area of the usage report. 

d. Select the Delete option. 

e. A confirmation message is displayed along with Yes and No options. 

f. If you choose Yes, then the system displays another confirmation message along with 
Yes and No options. If you select No, then the operation is aborted. 

g. If you choose Yes, then the selected groups, apart from the Project Administrators
group, are deleted. If you select No, then the deletion is not performed. 

8) The push functionality and the copy shells work the same as they did previously. If a group is 
deleted and the record can no longer be selected, then a push cannot be performed. 
However, if a group is deleted and the shell template is copied to create a template, then the 
deleted group would no longer be included. 

Updating Shells - Setup Node, Business Process 

You can add and update new business processes, or add additional business process setups to 
existing business processes. 

The Update Shell process runs in the background. Depending on the number of records and 
shells you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Update History window shows the complete date. 

The business process setup is identified by the unique combination of business process name, 
setup name, and workflow name. 

If the business process name does not exist, it will be added to project with the BP Setup and 
permissions. 

If the BP exists, but the BP Setup does not, it will be added to the BP. 

If the BP and BP Setup exist, the Setup will be replaced with the new one. 

Users and Groups that are part of a BP setup as assignees are added/updated, but not 
permissions. If a group is created, it will be empty. Users must be added to the group separately 
through user administration. 

BP-related permissions are added/updated 

To add or update business process setups using Update Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 



Setting up Shells

87

2) In the left Navigator, click Templates > Shells. 

3) Open the shell type template to update. 

4) In the shell type template, navigate to Setup > Business Processes. 

5) Add any new business processes, if applicable. (The BP must already have been imported 
into the system and configured at the company level.) 

6) To add or edit business process setups, select the BP to update in the Business Processes 
log. Click Open. The BP Setup log opens. 

7) Create a setup or modify an existing setup. You may create as many setups as you want to 
make available in the shell(s). 

8) Select one or more setups from the BP Setup log. 

9) Click Update Shells and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

10) Click Yes if you want to proceed with the update, or No to cancel. 

Conditions for Creating a Business Process setup Configuration Package 

When you include a Workflow Business Process setup for Configuration Package: 

 If it is a first time export, you must include the BP design in the configuration package. 

 For subsequent exports, you must include the latest BP design in the configuration package. 

When you include a non-Workflow Business Process setup for Configuration Package: 

 If it is a first time export, you must include the BP design in the configuration package. 

 For subsequent exports, if you have included the Data Element used in the setup (for 
example, Auto Creation setup) in the configuration package, then: 

 If published, then it will automatically be included in configuration package, by including 
the BP setup. 

 If not published, then you must include the BP design as well. 

At the time of import, the system transfers the setup information of the design object, irrespective 
of the Configuration status (Active/Inactive). 

For best results, include your design object for Configuration Package after you change the 
configuration of your design. 
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Workflow Setup for Workflow Business Processes 

You have the ability to delete (Delete, or Edit > Delete) an inactive Workflow setup for Workflow 
Business Processes in a Shell Template so that they are not included when a particular BP 
setup is included in the component list for a configuration package. 

Updating Record Properties tab in the BP Setups 

In a shell template, if users or groups have access restrictions to the Audit log, Workflow 
Progress tab, and Record Properties tab of the BP, then when you push the BP setup to the 
shells (selected shells or all shells) those restrictions will be pushed as well. Also, if users or 
groups with access restrictions are not included in the shell, then those users or groups will be 
added as the members of the shell. 

The confirmation message (when pushing BP setup into shells or projects from template) will 
have additional information: "Users and groups permissions, in the Record Properties tab, are 
added to the shell and existing permissions will be updated." 

Updating Shells - Setup Node, Dashboards 

You can add new dashboards to shell instances, for users to view. You can assign the user 
View permission to the shell instance dashboards. 

The Update process runs in the background. Depending on the number of shells you are 
updating, it can take a considerable amount of time to complete. The process is complete when 
the End Date column in the Update History window shows the complete date. 

Notes:

 If granted View permission, users can view shell instance 
dashboards, but cannot modify them. 

 If a user or group is added to shell instance dashboard permissions, 
and that user or group does not exist in the shell, that user or group 
is added to the shell upon update. 

 If a user has created My Dashboard in User mode for a shell, that 
dashboard is not overwritten by Update Shells. 

 The default setting for the dashboard will be added or updated. Users 
and groups who have view permissions to the default dashboard will 
have the default setting updated. 

To add or update shell instance dashboards using Update 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell template] > Setup > Dashboards. 
The Dashboards log opens. 

3) Select one or more shell instance dashboards from the Dashboards log. 

4) Click Update Shells and choose one of the following: 



Setting up Shells

89

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the 
selected shells; there is no undo for the update. 

5) Click Yes if you want to proceed with the update, or No to cancel. 

Conditions for Creating a Dashboard Setup Configuration Package 

Note: You must include the Data Cubes used in the Dashboard. 

The first time that you export a Dashboard, you must include all design objects that form the 
Dashboard data source in the Configuration Package. 

For subsequent exports, ensure that the design object that uses the Data Element that is 
specifically used in the setup is present in the Production Published Package. As long as this 
condition is met, the configuration package creation will be successful. If this condition is not 
met, then the latest design will have to be included in the configuration package. When the data 
source is a business process, the setup must also be included in the configuration package; 
otherwise, the creation process will not complete. 

Dashboards Components in the Configuration Package 

The system includes the following components of a dashboard in the Configuration Package 
(.zip file): 

Dashboards Component Field / Option 

Dashboard Log Name 

Dashboard Log Description 

Dashboard Log Permissions 

Dashboard Tab Block Tab Name 

Dashboard Tab Block Tab Layout 

Dashboard Tab Block Show option 

Dashboard Tab Block Filters 

Dashboard Source Details / Analytics 
Block 

Block Order 
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Dashboards Component Field / Option 

Dashboard Source Details / Analytics 
Block 

Block Title 

Dashboard Source Details / Analytics 
Block 

Source Name 

Dashboard Source Details / Analytics 
Block 

Block Type 

Dashboard Analytics Block URL 

The URL value will be blank 
in the Export package. 
Import process will plug in 
the default value based on 
the Unifier Configurator 
property. 

Dashboard Custom Block Data Cube 

Dashboard Custom Block Show Data From  

Dashboard Custom Block Block Title 

Dashboard Custom Block Display Type 

Dashboard Custom Block Source Grouped By (If 
Group By option is a design 
object then that design 
should also be included in 
the Configuration Package) 

Dashboard Custom Block Output Type 

Dashboard Custom Block Report On 

Dashboard Custom Block Summary Type 

Dashboard Custom Block Show Result 

Dashboard Custom Block Show Total 

Dashboard Custom Block Decimal Places 

Dashboard Custom Block Currency Format 

Dashboard Drilldown Block Data Cube 

Dashboard Drilldown Block Block Title 
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Dashboards Component Field / Option 

Dashboard Drilldown Block Block Filter Elements (If 
filter elements are design 
objects, then they must be 
included in the 
Configuration Package as 
well.) 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Title 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Show Data From 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Display Type 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Source Grouped By (If 
Group By option is a design 
object then that design must 
also be included in the 
Configuration Package.) 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Output Type 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Report On 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Summary Type 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Show Result 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Show Total 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Decimal Places 

Dashboard Drilldown Block / Edit 
Drilldown Details 

Currency Format 

Dashboard Portlet Block Name 

Dashboard Portlet Block URL 

Use Reset to reset the URL. 

Use Get Parameters to get parameters from the 

URL as populated by the user in URL text box. 

When received, use the URL Parameter 

Mapping menu (accordion) to pass the 

values to the parameters in URLs, by mapping 

those to fields from shell attribute form, and 
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Dashboards Component Field / Option 

then format the values so that the URL can 

render in the dashboard during runtime, 

correctly. 

Dashboard Standard Block Source Name 

Dashboard Standard Block Data Type (If Data Type 
option is a design object 
then that design must also 
be included in the 
Configuration Package) 

Dashboard Standard Block Report On 

Dashboard Standard Block Block Title 

Dashboard Standard Block Display Type 

Dashboard Standard Block Show Result 

Dashboard Standard Block Show Total 

Dashboard Standard Block Decimal Places 

Dashboard Standard Block Currency Format 

Updating Shells - Setup Node, Gates 

You can update shells with Active or Inactive Gates setups. The Update Shells process runs in 
the background. Depending on the number of records and shells you are updating, it can take a 
considerable amount of time to complete. The process is complete when the End Date column in 
the Update History window shows the complete date. 

Important Information About Updating Gates (Project Phase Gates) Setups: 

 The Gates setup update will completely overwrite any existing Gates setup, or will be added 
if it did not previously exist. 

 Previously scheduled Gates runs are overwritten by the new Gates setup. If the pushed 
setup is Active, new scheduled Gates runs are scheduled according to the schedule in the 
new setup. 

 Both Inactive and Active Gates setups can be pushed in the update. 

 After the update, the Gates setup reflects the status of the template. 

 After the update, the Current Phase in the Gates setup is reset to the First Phase. 

 After the update, the Gates shells will not run the scheduled refresh if the shell is On-Hold. 
Gates scheduling will resume automatically when the shell becomes Active. 
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 If you have permission to create Gates setups, you can update Gates setups using Update 
Shell, even if you do not have permission to access the individual shells. 

 The phase conditions that have been completed already will reset to incomplete, by the 
system.  

 Users and groups specified in the Email Notification field are added if they do not exist. 

 Newly-created groups are empty. 

 Any conditions that had been previously checked to be ignored will not be checked again, 
and the information about the user who had checked the ignore option will be lost. 

 If the Ignore check box has been used for any of the phase completion conditions, the 
project will not be set to where it was in the Phase Gates progress prior to the template 
update. 

Note: Post update, the next time that the system picks up the scheduled 
runs, the status of the gate phases may vary depending on the setup. 

To update Gates setups using Update Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > [shell type] > [shell instance]. 

3) In the shell template, click Setup and select Gates. 

4) Select a Gates setup. 

5) Click Update Shells and select one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

6) Click Yes if you want to proceed with the update, or No to cancel. 

Conditions for Creating Gates setup Configuration Package 

The first time that you export the Gates setup, you must include the data sources for the query 
condition used in the Gates setup. 

For subsequent exports, ensure that the design which uses the Data Element that is specifically 
used in the setup is present in the Production Published package. As long as this condition is 
met, the package creation will be successful. If this condition is not met, then the latest design 
will have to be included in the package. 

Gates Components in the Configuration Package 

The system includes the following components of Gates in the Configuration Package (.zip file): 
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Gates Component Field / Option 

Log Name 

Log Status 

Gates / General tab Name 

Gates / General tab Description 

Gates / General tab Status 

Gates / Settings tab Phase name  

Gates / Settings tab / Phase Gate 
Configuration 

Note: If the option of Start Date and 
Planned Completion dates are from 
Schedule sheet, then only the dates will 
get copied over. The Master schedule 
sheet will not get copied over.)  

All options 

Gates / Settings tab / Gate Condition 
Elements 

All Gate Condition Elements. The 
corresponding Data type selected for the 
gate condition should also be included in 
the Configuration Package. 

Gates / Settings tab / Gate Conditions All query conditions set up within the Gate 
condition 

Gates / Settings tab Advance to next Project ….option 

Gates / Settings tab / Additional 
Information block 

All options including Users and Groups 

Gates / Settings tab  Reevaluate conditions on every Gates Run 
option 

Gates / Schedule tab All options including the users and groups 
set for email notifications. 

Updating Shells - Setup Node, Planning Manager 

A Shell template might have many planning items in the Development/Test environment; 
however, not all of the planning items might be ready for transfer to another environment. 
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To access the Shell template for Planning Manager, go to the Company Workspace > Admin
mode > Templates > "Shell template" > Setup > Planning Manager

You can select multiple items to include in your configuration package. 

Conditions for Creating a Planning Manager setup Configuration Package 

The first time that you include the Planning Manager setup information in a Configuration 
Package, you must include the corresponding design in the Configuration Package. 

For subsequent exports, you do not need to include the latest design, if the design exists in the 
Published Configuration Package, already. 

At the time of import, the system transfers the setup information of the design object, irrespective 
of the Configuration status (Active/Inactive). 

Oracle recommends that after changing your design you include the updated design in the 
Configuration Package. 

Planning Manager Components in the Configuration Package 

The system includes the following components of Planning Manager in the Configuration 
Package (.zip file): 

Component Field / Option 

Planning Manager Setup / <Item Name> / 
General tab  

Setup Name 

Planning Manager Setup / <Item Name> / 
General tab  

Description 

Planning Manager Setup / <Item Name> / 
General tab 

Help File 

Access Control for Planning Manager Setup 

The configuration package includes permissions settings of Users and Groups from Shell 
templates, Planning Manager. 

To see the permission settings for Dashboards: 

1) Go to the Access Control module (Project/Shell > Admin mode > User Administration > 
Access Control). 

2) Expand Administration Mode Access. 

3) Expand Setup. 

4) Click Planning Manager to open the Module Permission Settings window. 

5) Proceed with adding, modifying, or removing permissions. 

Updating Shells - Setup Node, Resource Manager 

Go to: Company Workspace > Admin mode > Templates > "Shell template" > Setup > 
Resource Manager
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You can select and include the Resource Manager in the Configuration Package. 

Conditions for Creating a Resource Manager setup Configuration Package 

The setup of Resource Manager does not depend on any uDesigner designs or their 
configuration.  

At the time of import, ensure that the Role Based Allocation value is the same between the 
Configuration Package and the Production environment, or destination server. 

Note: The above check is applicable only when the setup has already 
been done. 

At the time of import, the system transfers the setup information of the design object, irrespective 
of the Configuration status (Active/Inactive). 

Oracle recommends that you include your design in the Configuration Package after you change 
the configuration of your design. 

Resource Manager Components in the Configuration Package 

The system includes the following components of Resource Manager in the Configuration 
Package (.zip file): 

Component Field / Option 

Resource Manager Configuration / Role 
Based Allocation block 

Selected option 

Resource Manager Configuration / 
Resource Sheet Defaults  

Timescale Unit 

Resource Manager Configuration / 
Resource Sheet Defaults 

Date From 

Resource Manager Configuration / 
Resource Sheet Defaults 

Date To 

Access Control for Planning Manager Setup 

The Configuration Package includes permissions settings of Users and Groups from Shell 
templates, Resource Manager. 

To see the permission settings for Dashboards: 

1) Go to the Access Control module (Project/Shell > Admin mode > User Administration > 
Access Control). 

2) Expand Administration Mode Access. 

3) Expand Setup. 

4) Click Resource Manager to open the Module Permission Settings window. 

5) Proceed with adding, modifying, or removing permissions. 
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Updating Shells - Setup Node, Configurable Modules (Classes) 

Go to: Company Workspace > Admin mode > Templates > "Shell template" > Setup > 
"Configurable Manager" > "CM0 Classes"/"Class Name" 

Any Configurable Manager of Code and Record type which have classes and which are setup in 
a Shell template can be packaged as part of the Configuration Package. 

You can package any Configurable Manager of Code-type and Record-type as part of the 
Configuration Package, if the: 

 Configurable Manager has classes 

 Configurable Manager was set up in a Shell template 

A shell template might have many CM Classes in the Development/Test environment; however 
not all of CM Classes might be ready for transfer to another environment.  

Conditions for Creating a CM Class setup Configuration Package 

The first time that you include the setup information in the Configuration Package, you must 
include the corresponding design in the Configuration Package. 

For subsequent exports, you do not need to include the corresponding design in the 
Configuration Package. 

At the time of import, the system transfers the setup information of the design object, irrespective 
of the Configuration status (Active/Inactive). 

Oracle recommends that you include your design object for Configuration Package after you 
change the configuration of your design. 

CM Class Components in the Configuration Package 

The system includes the following components of CM Class in the Configuration Package (.zip 
file): 

Component Field / Option 

CM Class Setup / General  Setup Name 

CM Class Setup / General  Description 

CM Class Setup / General  Help File 

CM Class Setup / General  Auto Creator 

CM Class Setup / General Send Error Notification to 

Access Control for CM Class Setup 

The Configuration Package includes permissions settings of Users and Groups from Shell 
templates, CM Class. 

To see the permission settings for Dashboards: 

1) Go to the Access Control module (Project/Shell > Admin mode > User Administration > 
Access Control). 
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2) Expand Administration Mode Access. 

3) Expand Setup. 

4) Click Parts to open the Module Permission Settings window. 

5) Proceed with adding, modifying, or removing permissions. 

Updating Shells - Configurable Modules Node (Sheets) 

Go to: Company Workspace > Admin mode > Templates > "Shell template" > Setup > 
"Configurable Manager" > "CM0 Sheet"/"Sheets Name" 

The generic Cost Sheet template contains the generic cost-code type and setup of the Cost 
Sheet, in the shell template of a cost-code type generic shell. 

You can include the CM0 setup that exists in a Shell template in the Shell Template 
Configuration Package. 

Conditions for Creating a CM Class setup Configuration Package 

The first time that you include the setup information in the Configuration Package, you must 
include the corresponding design in the Configuration Package.  

For subsequent exports, you do not need to include the corresponding design in the 
Configuration Package. 

At the time of import, the system transfers the setup information of the design object, irrespective 
of the Configuration status (Active/Inactive). 

Oracle recommends that you include your design object for Configuration Package after you 
change the configuration of your design. 

CM Class Components in the Configuration Package 

The system includes the following components of CM Class in the Configuration Package (.zip 
file): 

Component Field / Option 

CM Class Setup / General  Setup Name 

CM Class Setup / General  Description 

CM Class Setup / General  Help File 

CM Class Setup / General  Auto Creator 

CM Class Setup / General Send Error Notification to 

Updating Shells - Rules Node 

Rules can be updated in CBS code-based shells. 
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The Update Shells process runs in the background. Depending on the number of records and 
shells you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Update History window shows the complete date. 

Notes: 

 Both active and inactive rules can be pushed. 

 Rules are identified by the combination of rule name and the source. 

 If the rule does not exist, it will be added. 

 If a rule exists with the same name and source, that rule will be 
updated. This includes the status: for example, if the rule being 
pushed is active, and the rule in the shell is inactive, the system will 
update the existing rule and activate it. 

 It is possible to have more than one rule with the same name and 
source in a project/shell or template. If two or more rules exist with 
the same name and source as the rule being pushed, the update will 
not occur and will give an error. 

 When the update process begins, the system will first attempt to 
validate each rule (equivalent to clicking the Validate button). This 
will occur whether the rule is active or inactive in the template. If the 
rule is validated successfully, the system will proceed with the 
update. 

 If the rule fails validation, the rule will not be pushed. The attempt will 
be captured in the History. 

To update rules using Update Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell template to update. 

4) In the Shell Template, navigate to Rules. 

5) Select one or more rules from the log. 

6) Click Update Shells and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

7) Click Yes if you want to proceed with the update, or No to cancel. 
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Conditions for Creating a Rules setup Configuration Package 

The first time that you package the Rules Setup information, you must include the following in 
the package:  

 Design of the Business Processes used in the Rule definition. 

 Corresponding designs. 

The design for Configuration Package. 

For subsequent exports, ensure that the design that uses the Data Element that is specifically 
used in the setup is present in the Production Published package. As long as this condition is 
met, the package creation will be successful. If this condition is not met, the latest design will 
have to be included in the package. 

Importing of Rules based on Rule Status 

Note: For both Active and Inactive, the system does not check for the 
existence of the specific CBS codes in the Cost Sheet (Applicable where 
the Rule definition uses CBS codes). 

Rules with Active Status

At the time of Import, ensure that: 

 The Cost Sheet or Funding Sheet, used in Rules definition, exists either in the Package or in 
the destination server. 

 The data source is present, as a column, in the Funding sheet. 

 The cost sheet columns or the Funding Sheet columns used in Rule definition required for 
Rule Activation are present either in the package or in the destination server. 

When CBS codes are used, ensure that the Cost Sheet used for Rules definition exists either in 
the Package or in the destination server. 

Rules with Inactive Status

The system does not perform any checks at the time of import. 

Rules Components in the Configuration Package 

The system includes the following components of Rules in the Configuration Package (.zip file): 

Component Field / Option 

Rule Properties / General Name 

Rule Properties / General Description 

Rule Properties / General Control Source 

Rule Properties / General Rule Level 

Rule Properties / General Status 

Rule Properties / General  Users / Groups who can override field. 
Users and groups will be part of the 
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Component Field / Option 

Configuration Package. 

(Applicable only for Rule level = Per 
selected CBS Codes and Per selected 
summary CBS codes) 

Rule Properties / General Notify Users / Groups when overridden 
field. Users and groups will be part of the 
Configuration Package. 

(Applicable only for Rule level = Per 
selected CBS Codes and Per selected 
summary CBS codes) 

Rule Properties / Rule Limit expression formula: Formula string. 

The formula string contains BPs. 

Rule Properties / Rule Data Expression: Might be a formula using 
BP data sources. 

Rule Properties / Rule Message when condition not met.  

Rule Properties / CBS Codes CBS Codes 

(Applicable only for Rule level = Per 
selected CBS Codes and Per selected 
summary CBS codes) 

Updating Shells - Cost Manager Node, Cash Flow 

Go to: Company Workspace > Admin mode > Templates > Shells > "Shell template" > Cost 
Manager > Cash Flow.  

The Cash Flow module lets you generate and compare Baseline, Actuals (or “spends”), 
Portfolio, Forecast, and Custom curves in a project or CBS code-based Shell. 

You can use a Cash Flow Curve template to create cash flow curves in CBS-code based Shells. 

All Cash Flows defined in a shell template will be included in the Configuration Package. 

You can select and include multiple items in the Configuration Package. 

Conditions for Creating a Cash Flow setup Configuration Package 

Detail Curve type Component Check 

Project/Level 

Summary CBS 

CBS 

Commitment 

Any Cost = Distribute 
amount from cost 
sheet column 
ensure that the 
checks relevant to 
Cost Sheet are 

Cost Sheet in the 
shell template. 
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Detail Curve type Component Check 

performed. If above 
conditions are not 
met, you will see an 
error. 

Project/Level 

Summary CBS 

CBS 

Commitment 

Any Schedule = Use 
dates from Schedule 
Sheet 

Schedule Sheet in 
the shell template. 

Project/Level 

Summary CBS 

CBS 

Commitment 

Any Filter set to specific 
CBS Codes 

When the Filter is 
set to specific CBS 
codes, ensure that 
the Cost Sheet in 
the Shell template 
has also been 
included. 

Commitment Any Commitment 
Business Processes 
both Commitment 
and Change Orders 

Commit Business 
Process selected 
must be included in 
the Configuration 
Package. If this 
condition is not met, 
throw an error. 

Cash Flow Components in the Configuration Package 

The system includes the following components of Cash Flow in the Configuration Package (.zip 
file): 

 Cash Flow content - Detail Level: Project/Shell 

 Cash Flow content - Detail Level: Summary CBS 

 Cash Flow content - Detail Level: CBS 

 Cash Flow content - Detail Level: Commitment 

Note: For "Additional checks required" see to Conditions for Creating a 
Cash Flow setup Configuration Package, in this topic. 

Cash Flow content - Detail Level: Project/Shell

Component Field / Option 

Cash Flow Properties / General All fields 

Cash Flow Properties / Curves  All Curves 
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Component Field / Option 

Cash Flow Properties / Curves / Curve 
type - Baseline 

All fields including the selected options for 
Distribution, Cost and Schedule. 

1 - If Distribution = Auto by default profile, 
the Distribution Profile will be included in 
the Configuration Package. 

2 - If Cost = Distribute amount from cost 
sheet column, all the cost sheet columns 
available for selection will be included in 
the Configuration Package. In addition to 
this, the value selected for this field will 
also be included in the Configuration 
Package. Additional checks required. Note 
that Cost Sheet must always be included 
in the Package. 

3 - If Schedule = Use dates from Schedule 
Sheet, the schedule sheet selected in the 
field should be included in the Package. 
Additional checks required. DEs selected 
in the From Date and To Date fields will 
also be included in the Configuration 
Package in addition to the possible values 
of the Schedule sheet DEs.  

Cash Flow Properties / Curves / Curve 
type - Forecast / General 

All fields including the selected options for 
Distribution, Cost and Schedule. 

Behavior to be the same as the one 
outlined in Cash Flow / Curves / Baseline 

Cash Flow Properties / Curves / Curve 
type - Forecast / Options 

All options selected for the Forecast Curve 
will be included in the Configuration 
Package 
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Component Field / Option 

Cash Flow Properties / Curves / Curve 
type - Portfolio Budget 

All fields selected for the Forecast Curve 
will be included in the Configuration 
Package 

1 - Additional checks might be needed for 
Portfolio Manager related Configuration. 

2 - Currency is a required field for Portfolio 
Budget curve. The default value is set to 
the Project Currency. However this 
currency might differ from the Project 
Currency. It could be any of the Active and 
Future currencies listed in the Exchange 
Rate table. Therefore, if the currency 
differs from the Project Currency then in 
addition to the Currency value specified in 
this field, the currency and its exchange 
rate information will also be included in the 
Configuration Package. 

Rules for creating Currencies and 
Exchange Rates 

- Currency will get created if it does not 
exist 

- Currency attributes such as Code, Name, 
Symbol, and so on, will not be updated by 
means of Package import. 

- Currency tab content will get updated 
upon every import. 

If exchange rates defined for currencies in 
the source shell template do not exist in 
the destination environment, then a new 
exchange rate record will get created for 
that currency and that exchange rate will 
be set to Active. 

- The Effective date will be set to the 
Package Import Date. 

- The Peg rate will be brought over from 
the source environment. 

- The float rate will be brought over if the 
rate does not exist in the destination 
environment. 

Cash Flow Properties / Curves / Curve 
type - Actuals 

All fields selected for the Forecast Curve 
will be included in the Configuration 
Package. Additional checks required. 
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Component Field / Option 

Cash Flow Properties / Filter Selected Filter options 

If Filter = Select Summary CBS OR Select 
CBS codes, then the selected CBS codes 
will be included as part of Filter options. 

Cash Flow Properties / Options The selected option, Decimal Options or 
Use Currency Decimal Precision, will be 
included in the Configuration Package. 

Cash Flow Properties / Schedule All options set in the Schedule tab will be 
included in the Configuration Package. 

Cash Flow Properties / Summary Not applicable in templates 

Cash Flow / Permissions Users and Groups 

Cash Flow / Filters Filters defined for the curves will also be 
included in the Package 

Cash Flow content - Detail Level: Summary CBS

Component Field / Option 

Cash Flow Properties / General All fields 

Cash Flow Properties / Curves  All Curves 
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Component Field / Option 

Cash Flow Properties / Curves / Curve 
type - Baseline 

All fields including the selected options for 
Distribution, Cost and Schedule. 

1- If Distribution = Auto by default profile 
per summary CBS, the Distribution Profile 
for the corresponding Summary CBS code 
will be included in the Configuration 
Package. Additional checks required. 

2- If Cost = Distribute amount from cost 
sheet column, all the cost sheet columns 
available for selection will be included in 
the Configuration Package. In addition to 
this, the value selected for this field will 
also be included in the Configuration 
Package. Additional checks required. Note 
that Cost Sheet must always be included 
in the Package. 

3- If Schedule = Use dates from Schedule 
Sheet, the schedule sheet selected in the 
field should be included in the Package. 
Additional checks required. DEs selected 
in the From Date and To Date fields will 
also be included in the Configuration 
Package in addition to the possible values 
of the Schedule sheet DEs.  

Cash Flow Properties / Curves / Curve 
type - Forecast / General 

All fields including the selected options for 
Distribution, Cost and Schedule. Behavior 
to be the same as the one outlined in Cash 
Flow / Curves / Baseline 

Cash Flow Properties / Curves / Curve 
type - Forecast / Options 

All options selected for the Forecast Curve 
will be included in the Configuration 
Package 
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Component Field / Option 

Cash Flow Properties / Curves / Curve 
type - Portfolio Budget 

All fields selected for the Portfolio Budget 
Curve will be included in the Configuration 
Package. 

1- Additional checks might be needed for 
Portfolio Manager related Configuration. 

2- Currency is a required field for Portfolio 
Budget curve. The default value is set to 
the Project Currency. However this 
currency might differ from the Project 
Currency. It could be any of the Active and 
Future currencies listed in the Exchange 
Rate table. Therefore, if the currency 
differs from the Project Currency then in 
addition to the Currency value specified in 
this field, the currency and its exchange 
rate information will also be included in the 
Configuration Package. 

Rules for creating Currencies and 
Exchange Rates 

- Currency will get created if it does not 
exist 

- Currency attributes such as Code, Name, 
Symbol, and so on, will not be updated by 
means of Package import. 

- Currency tab content will get updated 
upon every import. 

If exchange rates defined for currencies in 
the source shell template do not exist in 
the destination environment, then a new 
exchange rate record will get created for 
that currency and that exchange rate will 
be set to Active. 

- The Effective date will be set to the 
Package Import Date. 

- The Peg rate will be brought over from 
the source environment. 

- The float rate will be brought over if the 
rate does not exist in the destination 
environment. 

Cash Flow Properties / Curves / Curve 
type - Actuals 

All fields selected for the Forecast Curve 
will be included in the Configuration 
Package. Additional checks required. 
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Component Field / Option 

Cash Flow Properties / Filter Selected Filter options 

If Filter = Select Summary CBS, then the 
selected Summary CBS codes will be 
included as part of Filter options. 
Additional checks required.  

Cash Flow Properties / Options The selected option, Decimal Options or 
Use Currency Decimal Precision, will be 
included in the Configuration Package. 

Cash Flow Properties / Schedule All options set in the Schedule tab will be 
included in the Configuration Package. 

Cash Flow Properties / Summary Not applicable in templates 

Cash Flow / Permissions Users and Groups 

Cash Flow / Filters Filters defined for the curves will also be 
included in the Package 

Cash Flow content - Detail Level: CBS

Component Field / Option 

Cash Flow Properties / General All fields 

Cash Flow Properties / Curves  All Curves 
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Component Field / Option 

Cash Flow Properties / Curves / Curve 
type - Baseline 

All fields including the selected options for 
Distribution, Cost and Schedule. 

Distribution 

Case 1: Auto by default profile per CBS, 
the Distribution Profile for the 
corresponding CBS code will be included 
in the Configuration Package. Additional 
checks required. 

Note: Cost Sheet must always be included 
in the Package. 

Case 2: Use data from Schedule Sheet, 
the schedule sheet will be included in the 
Configuration Package. Additional checks 
required. 

Case 3: Use data from P6 Source, the P6 
source selected in the curve will also be 
included in the Configuration Package. 

If Cost = Distribute amount from cost sheet 
column, all the cost sheet columns 
available for selection will be included in 
the Configuration Package. In addition to 
this, the value selected for this field will 
also be included in the Configuration 
Package. Additional checks required. 

Schedule 

Case 1: Use dates from Schedule Sheet, 
the schedule sheet selected in the field 
should be included in the Package. 
Additional checks required. DEs selected 
in the From Date and To Date fields will 
also be included in the Configuration 
Package in addition to the possible values 
of the Schedule sheet DEs. 

Case 2: Use dates from P6 Source, the P6 
source selected in the curve will also be 
included in the Configuration Package.  

Cash Flow Properties / Curves / Curve 
type - Forecast / General 

All fields including the selected options for 
Distribution, Cost and Schedule. 

Behavior to be the same as the one 
outlined in Cash Flow / Curves / Baseline 
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Component Field / Option 

Cash Flow Properties / Curves / Curve 
type - Portfolio Budget 

All fields selected for the Portfolio Budget 
Curve will be included in the Configuration 
Package 

Cash Flow Properties / Curves / Curve 
type - Forecast / Options 

All options selected for the Forecast Curve 
will be included in the Configuration 
Package 
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Component Field / Option 

Cash Flow Properties / Curves / Curve 
type - Portfolio Budget 

All fields selected for the Portfolio Budget 
Curve will be included in the Configuration 
Package 

1- Additional checks might be needed for 
Portfolio Manager related Configuration. 

2- Currency is a required field for Portfolio 
Budget curve. The default value is set to 
the Project Currency. However this 
currency might differ from the Project 
Currency. It could be any of the Active and 
Future currencies listed in the Exchange 
Rate table. Therefore, if the currency 
differs from the Project Currency then in 
addition to the Currency value specified in 
this field, the currency and its exchange 
rate information will also be included in the 
Configuration Package. 

Rules for creating Currencies and 
Exchange Rates 

- Currency will get created if it does not 
exist 

- Currency attributes such as Code, Name, 
Symbol, and so on, will not be updated by 
means of Package import. 

- Currency tab content will get updated 
upon every import. 

If exchange rates defined for currencies in 
the source shell template do not exist in 
the destination environment, then a new 
exchange rate record will get created for 
that currency and that exchange rate will 
be set to Active. 

- The Effective date will be set to the 
Package Import Date. 

- The Peg rate will be brought over from 
the source environment. 

- The float rate will be brought over if the 
rate does not exist in the destination 
environment. 

Cash Flow Properties / Curves / Curve 
type - Actuals 

All fields selected for the Actuals Curve will 
be included in the Configuration Package. 
Additional checks required. 
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Component Field / Option 

Cash Flow Properties / Filter Selected Filter options 

If Filter = Select CBS, then the selected 
CBS codes will be included as part of Filter 
options. Additional checks required. 

Cash Flow Properties / Options The selected option, Decimal Options or 
Use Currency Decimal Precision, will be 
included in the Configuration Package. 

Cash Flow Properties / Schedule All options set in the Schedule tab will be 
included in the Configuration Package. 

Cash Flow Properties / Summary Not applicable in templates? 

Cash Flow / Permissions Users and Groups 

Cash Flow / Filters Filters defined for the curves will also be 
included in the Package 

Cash Flow content - Detail Level: Commitment

Component Field / Option 

Cash Flow Properties / General All fields. Additional checks required for 
Business Processes. 

Cash Flow Properties / Curves  All Curves 

Cash Flow Properties / Curves / Curve 
type - Baseline 

All fields including the selected options for 
Cash flow granularity, Distribution and 
Commit BPs. Additional checks required 
for Business Processes. 

Cash Flow Properties / Curves / Curve 
type - Forecast / General 

All fields including the selected options for 
Cash flow granularity, Distribution and 
Commit BPs. 

If Distribution Method has a Profile, then 
the Profile will also be included in the 
Configuration Package. 

Behavior to be the same as the one 
outlined in Cash Flow / Curves / Baseline 

Cash Flow Properties / Curves / Curve 
type - Forecast / Options 

All options selected for the Forecast Curve 
will be included in the Configuration 
Package 
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Component Field / Option 

Cash Flow Properties / Curves / Curve 
type - Portfolio Budget 

All fields selected for the Portfolio Budget 
Curve will be included in the Configuration 
Package 

1- Additional checks might be needed for 
Portfolio Manager related Configuration. 

2- Currency is a required field for Portfolio 
Budget curve. The default value is set to 
the Project Currency. However this 
currency might differ from the Project 
Currency. It could be any of the Active and 
Future currencies listed in the Exchange 
Rate table. Therefore, if the currency 
differs from the Project Currency then in 
addition to the Currency value specified in 
this field, the currency and its exchange 
rate information will also be included in the 
Configuration Package. 

Rules for creating Currencies and 
Exchange Rates 

- Currency will get created if it does not 
exist 

- Currency attributes such as Code, Name, 
Symbol, and so on, will not be updated by 
means of Package import. 

- Currency tab content will get updated 
upon every import. 

If exchange rates defined for currencies in 
the source shell template do not exist in 
the destination environment, then a new 
exchange rate record will get created for 
that currency and that exchange rate will 
be set to Active. 

- The Effective date will be set to the 
Package Import Date. 

- The Peg rate will be brought over from 
the source environment. 

- The float rate will be brought over if the 
rate does not exist in the destination 
environment. 

Cash Flow Properties / Curves / Curve 
type - Actuals 

All fields selected for the Actuals Curve will 
be included in the Configuration Package. 
Additional checks required. 
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Component Field / Option 

Cash Flow Properties / Filter Selected Filter options 

If Filter = Select CBS, then the selected 
CBS codes will be included as part of Filter 
options. Additional checks required. 

Cash Flow Properties / Options The selected option, Decimal Options or 
Use Currency Decimal Precision, will be 
included in the Configuration Package. 

Cash Flow Properties / Schedule All options set in the Schedule tab will be 
included in the Configuration Package. 

Cash Flow Properties / Summary Not applicable in templates. 

Cash Flow / Permissions Users and Groups 

Cash Flow / Filters Filters defined for the curves will also be 
included in the Package 

Updating Shells - Cost Manager Node, Cost Sheet 

Go to: Company Workspace > Admin mode > Templates > Shells > "Shell template" > Cost 
Manager > Cost Sheet 

Conditions for Creating a Cost Sheet setup Configuration Package 

When the Sheet Setup information is packaged for the first time, the Cost Attribute design must 
also be included in the configuration package. If this check fails, then the package creation will 
result in an error. For subsequent exports, the deployed version of the design must match the 
Published version of the design. This is mainly being done since the package includes the Cost 
Sheet (CBS) rows and these depend on the deployed design. 

This check will not be performed for customers who do not use Cost attribute forms. If the 
destination server has the cost attribute form, but the Configuration Package does not include 
the Cost Attribute design, then the import will fail and an error will be displayed. 

When the Sheet Setup information is packaged for the first time, the design of any data source 
used in the column definition of the sheet must be part of the package. If this check fails then the 
package creation will result in an error. For subsequent exports, check will be made to ensure 
that the design which uses the Data Element (ex: Status) that is specifically used in the setup is 
present in the Published package. As long as this condition is met, the package creation will be 
successful. If not, the latest design will have to be included in the package. 

Cost Sheet Components in the Configuration Package 

The system includes the following components of Cost Sheet in the Configuration Package (.zip 
file): 
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Component Field / Option 

Cost Sheet / Properties / General Title 

Cost Sheet / Properties / General Description 

Cost Sheet / Properties / General Default View 

Cost Sheet / Properties / Structure Structure option 

Cost Sheet / Properties / Structure All segments 

Cost Sheet / Properties / Options Labels 

Cost Sheet / Properties / Options Forecast Details option 

Cost Sheet / Properties / Options Forecast Inclusion 

Cost Sheet / Properties / Options Forecast Type 

Cost Sheet / Properties / Options P6 Integration: Enable P6 Sources. 

When this option is selected, and if the 
Cost sheet has used any of the P6 Data 
Sources, then the Configuration Package 
will also include the P6 Data sources 
defined in Standards & Libraries. If the P6 
data sources do not exist in this 
destination, then they will get created and 
be in a Published state. 

The system currently allows up to 12 P6 
data sources to be defined in the server. 
So at the time of Import, checks will have 
to be made to ensure that the total number 
of P6 data sources does not exceed 12. 

Cost Sheet / Columns / Column Properties All options 

Because the data source of a cost sheet 
column may be a Cost BP, additional 
checks are performed at the time of the 
Configuration Package creation to ensure 
that the BP is included in the Configuration 
Package as well. 

If the entry method uses Work Sheet, the 
Worksheet must be included in the 
Configuration Package. 

The package will also include the hidden 
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Component Field / Option 

columns.  

Cost Sheet / Columns / Restrictions Users and Groups setup for Restrictions. 

Cost Sheet / Budget Distribution The Budget Distribution option will be 
disabled at the Shell template level. Hence 
user cannot setup any distribution. 

Cost Sheet / Fund Assignment order The Fund assignment option will be 
disabled at the Shell template level. 

Cost Sheet /CBS Codes All rows which include CBS as well as 
Summary CBS codes along with the 
Breakdown. 

Note: If the Cost Codes do not exist in the 
destination environment, that is, if user has 
not packaged the Cost Codes by selecting 
the options of Data Structure > Cost 
Codes at the time of Package creation, the 
cost codes used in the Cost sheet will be 
brought over. However, the value/label pair 
defined in the Cost Code definitions will 
not be brought over. 

Updating Shells - Cost Manager Node, Funding - Funding Sheet 

Go to: Company Workspace > Admin mode > Templates > Shells > "Shell template" > Cost 
Manager > Funding > Funding Sheet 

A CBS Shell template can have a Funding Manager which helps keep track of Funds. A Shell 
Funding sheet can be used to specify the appropriation and assignment of funds from each 
funding source. 

The Funding Sheet setup in the shell template is included in the Configuration Package. 

Conditions for Creating a Funding Sheet setup Configuration Package 

The first time that you package the Sheet Setup information, the Fund Attribute design must also 
be included in the package, which means that the design must be included in the Configuration 
Package. If this check fails, then the package creation will result in an error. The deployed 
version and the Published version of the design must match. 

Note: Although you are not packaging the Funding Rows, the Company 
Fund sheet depends on the deployed version of the design. Fund codes 
in the Company Fund sheet is used in order to create the fund codes in 
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the shell templates. 

This check will not be performed for customers who do not use Fund attribute forms. If the 
destination server has the Fund attribute form, but the Configuration Package does not include 
the Fund Attribute design, then the import will fail and an error will be displayed. 

The first time that you package the Sheet Setup information, the design of any data source used 
in the column definition of the sheet must be part of the package. This means that these designs 
must be included in the Configuration Package. If this check fails then the package creation will 
result in an error. For subsequent exports, check will be made to ensure that the design which 
uses the Data Element (ex: Status) that is specifically used in the setup is present in the 
Published package. As long as this condition is met, the package creation will be successful. If 
not, the latest design will have to be included in the package. 

Funding Sheet Components in the Configuration Package 

The system includes the following components of Funding Sheet in the Configuration Package 
(.zip file): 

Component Field / Option 

Funding Sheet Properties / General Title 

Funding Sheet Properties / General Description 

Funding Sheet Properties / General Display Mode 

Funding Sheet Properties / Assignment / 
Project block 

Process Contributing Assignable Funds  

Funding Sheet Properties / Assignment / 
CBS block 

CBS Fund Source  

Funding Sheet Properties/ Assignment / 
Assignment Levels block 

Assignment Rules 

Funding Sheet / Rows The Fund rows are the ones that exist in 
the Company level Fund Sheet. As a 
result, this data will not be packaged. 

Funding Sheet / Columns All columns 

Funding Sheet / Columns All column properties. Because the data 
source of a Funding sheet column may be 
a Fund BP, additional checks are 
performed at the time of the Configuration 
Package creation to ensure that the Fund 
BP has been included in the Configuration 
Package as well.  

Funding Sheet / Fund assignment Fund assignment order will not be carried 
over because it is dependent on the 
Funding rows. 

Funding Sheet / Filters All filters set in Funding sheet. 
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Updating Shells - Cost Manager Node, Funding - Commitment Funding Sheet 

Go to: Company Workspace > Admin mode > Templates > Shells > "Shell template" > Cost 
Manager > Funding > Commitment Funding Sheet 

A commitment funding sheet is created for each base commit that has been designed for 
Commitment Funding Sheet. 

Funds can be allocated from the Shell template Funding sheet to the Commitment Funding 
Sheet. This sheet works in conjunction with the Schedule of Values (SOV) sheet to track base 
commit and change commit line items and balances. Commitment Funding Sheet templates are 
created and set up in the Templates node, and are used to create the commitment funding sheet 
structure in a project or shell (or in a project or shell template). 

This structure is then used when sheets are created for individual base commit records. A 
Commitment Funding Sheet in a shell template will be included in the Configuration Package. 

The Structure option changes from Create Structure to Update Structure after a selection of the 
Commitment Funding sheet is made. 

If the Structure has not yet been created then an error message will be seen. 

This same behavior will be seen in the following logs:  

 General Spends SOV 

 Payment Applications SOV 

 Summary Payment Applications SOV 

 Document Manager (Structure creation is not applicable here) 

Conditions for Creating a Commitment Funding setup Configuration Package 

The first time that you package the Sheet Setup information, the design of any data source used 
in the column definition of the sheet must be part of the package. 

This means that these designs must be included in the Configuration Package. If this check fails 
then the package creation will result in an error. 

For subsequent exports, check will be made to ensure that the design which uses the Data 
Element (ex: Status) that is specifically used in the setup is present in the Published package. 

As long as this condition is met, the package creation will be successful. If not, the latest design 
will have to be included in the package. 

Other dependency checks performed at the time of Import: 

The first time that the Sheet Setup information is imported, the Funding Sheet defined in the 
shell template must also be included in the package. If this check fails, then the package import 
will result in an error. 

Commitment Funding Components in the Configuration Package 

The system includes the following components of Commitment Funding in the Configuration 
Package (.zip file): 
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Component Field / Option 

Commitment Funding Sheet Properties / 
General 

All fields 

Commitment Funding Sheet Properties / 
Assignment 

All selections 

Updating Shells - Cost Manager Node, Schedule of Values - General Spends 

Go to: Company Workspace > Admin mode > Templates > Shells > "Shell template" > Cost 
Manager > Schedule of Values > General Spends 

The General Spends SOV structure setup, existing in a shell template, will be included in the 
Configuration Package. The structure in the shell template can be created from the SOV 
templates that exist at the company level. 

The Structure option changes from Create Structure to Update Structure after a selection of the 
SOV Structure is made. 

Conditions for Creating a General Spends setup Configuration Package 

The first time that you package the SOV Setup, the design of any data source used in the 
column definition of the sheet must be part of the package. This means that these designs must 
be included in the Configuration Package. If this check fails then the package creation will result 
in an error. For subsequent exports, check will be made to ensure that the design which uses 
the Data Element (ex: Status) that is specifically used in the setup is present in the Published 
package. As long as this condition is met, the package creation will be successful. If not, the 
latest design will have to be included in the package. 

General Spends Components in the Configuration Package 

The system includes the following components of General Spends in the Configuration Package 
(.zip file): 

Component Field / Option 

SOV Structure Properties/ General All fields 

SOV Structure Properties/ Options All fields 

SOV Structure / Columns All columns including the data source and 
formula definitions 

Updating Shells - Cost Manager Node, Schedule of Values - Payment Applications 

Go to: Company Workspace > Admin mode > Templates > Shells > "Shell template" > Cost 
Manager > Schedule of Values > Payment Applications 
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Any Payment Application SOV structure setup existing in a shell template will be included in the 
Configuration Package.  

The Structure option changes from Create Structure to Update Structure after a selection of the 
SOV Structure is made. 

Conditions for Creating a Payment Applications setup Configuration Package 

The first time that you package the SOV Setup, the design of any data source used in the 
column definition of the sheet must be part of the package. 

This means that these designs must be included in the Configuration Package. If this check fails 
then the package creation will result in an error. 

For subsequent exports, check will be made to ensure that the design which uses the Data 
Element (ex: Status) that is specifically used in the setup is present in the Published package. 
As long as this condition is met, the package creation will be successful. If not, the latest design 
will have to be included in the package. 

Other dependency checks performed at the time of Import: 

The first time that the Pay App SOV Setup done in a shell Template is imported, the Cost sheet 
defined and set up in the shell template must also be included in the package. If this check fails 
then the package import will result in an error. For subsequent imports, the Cost sheet setup 
need not be part of the Import Package. 

When the Pay App SOV Setup is packaged for the first time, the BP setup of the Payment 
Application BP must also be included in the package. If this check fails then the package import 
will result in an error. For subsequent imports, the Payment Application BP setup need not be 
part of the Import Package. 

Payment Applications Components in the Configuration Package 

The system includes the following components of Payment Applications in the Configuration 
Package (.zip file): 

Component Field / Option 

Payment Application Properties / General All fields 

Payment Application Properties / Options All fields 

Payment Application Structure / Columns All columns 

Updating Shells - Cost Manager Node, Schedule of Values - Summary Payment 
Applications 

Go to: Company Workspace > Admin mode > Templates > Shells > "Shell template" > Cost 
Manager > Schedule of Values > Summary Payment Applications 

Any Summary Payment Application SOV structure setup existing in a shell template will be 
included in the Configuration Package. 
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The Structure option changes from Create Structure to Update Structure after a selection of the 
SOV Structure is made. 

The content is same as the one mentioned in the "Payment Application" section. 

Conditions for Creating a Summary Payment Applications setup Configuration Package 

The first time that you package the SOV Setup, the design of any data source used in the 
column definition of the sheet must be part of the package. 

This means that these designs must be included in the Configuration Package. If this check fails 
then the package creation will result in an error.  

For subsequent exports, check will be made to ensure that the design which uses the Data 
Element (ex: Status) that is specifically used in the setup is present in the Published package. 
As long as this condition is met, the package creation will be successful. If not, the latest design 
will have to be included in the package. 

Other dependency checks performed at the time of Import: 

The first time that you import the Pay App SOV Setup done in a shell template, Cost sheet 
defined and setup in the shell template must also be included in the package. If this check fails 
then the package import will result in an error. For subsequent imports, the Cost sheet setup 
need not be part of the Import Package. 

The first time that you package the Pay App SOV Setup, the BP setup of the Payment 
Application BP must also be included in the package. If this check fails then the package import 
will result in an error. For subsequent imports, the Payment Application BP setup need not be 
part of the Import Package. 

Updating Shells - Document Manager Node 

The Document Manager (DM), within a Shell template, contains the entire folder structure that a 
particular shell uses to manage all the relevant documents. 

You can use the Document Manager template to update the structure and permissions, or just 
permissions across all shells or to selected shells of the same type. You can apply changes to a 
single or the entire folder hierarchy in the destination shell. Update rules apply to each 
sub-option - for example, in the Structure & Permissions option, if a folder does not exist, it will 
be added 

To push DM template changes and update shells: 

1) Navigate to Company Workspace > Admin mode > Templates > Shells > "Shell 
template" > Document Manager > Documents.

2) To update the structure and permissions: 

a. From the Update Shells drop-down menu, select Structure & Permissions. 

b. To update all shells, select All Shells. To update selected shells, selects Shells. From 
the Shell picker, select the shells and click Update Shell(s).

3) To update the permissions: 

a. From the Update Shells drop-down menu, select Permissions only. 
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b. To update all shells, select All Shells. To update selected shells, selects Shells. From 
the Shell picker, select the shells and click Update Shell(s).

4) To view the history of the template, select History from the Update Shells menu. 

The tagged Document Manager with folders set up in a tagged Shell template will be included in 
the Configuration Package.  

Conditions for Creating a Document Manager setup Configuration Package 

The first time that you package the Setup information, if the folder properties are based on a DM 
attribute form, then the DM Attribute design must also be included in the package. 

This means that the design must be included in the Configuration Package. If this check fails, 
then the package creation will result in an error. 

For subsequent exports, check will be made to ensure that the design which uses the Data 
Element that is specifically used in the setup is present in the Published package. As long as 
this condition is met, the package creation will be successful. If not, the latest design will have to 
be included in the package. This check will not be performed for customers who do not use DM 
attribute form. 

Document Manager Components in the Configuration Package 

The system includes the following components of Document Manager in the Configuration 
Package (.zip file): 

Component Field / Option 

Document Manager  All Folders 

Document Manager / Folder  All Permissions which includes users and 
groups 

Document Manager / Folder All Folder Properties 

DM attributes DM form attributes will get copied over. 

Updating Shells - Space Manager Node, Levels Sheet 

Go to: Company Workspace > Admin mode > Templates > Shells > "Shell template" > Space 
Manager > Levels Sheet 

The Levels Sheet, in Space Manager, provides a sheet view of all the floors and associated 
spaces for a given Project/Shell. Tagged level sheet in a tagged Shell template will be included 
in the Configuration Package.  

Conditions for Creating a Level Sheet setup Configuration Package 

The first time that you package the Setup information, the level design must also be included in 
the package. 



Setting up Shells

123

This means that the design must be included in the configuration package. If this check fails, 
then the package creation will result in an error. 

For subsequent exports, check will be made to ensure that the Data Element used in the setup 
is present in the Published package. As long as this condition is met, the package creation will 
be successful. If not, the latest design will have to be included in the package. 

For Levels Sheet, no checks for inclusion of Configuration setup will be done either at the time of 
packaging the setup for Configuration Package or at the time of importing the setup in a 
destination environment. At the time of import, the setup information is brought over regardless 
of the Configuration status (Active/Inactive) of the design object. However as a best Practice, it 
is recommended that any time the configuration of design object has changed it must be 
included in the Configuration Package. 

Level Sheet Components in the Configuration Package 

The system includes the following components of Level Sheet in the Configuration Package (.zip 
file): 

Component Field / Option 

Levels Sheet Properties Name 

Levels Sheet Properties Description 

Levels Sheet / Columns All columns. Columns in Levels sheet are 
the Data Elements from the Levels. Check 
has to be made to ensure that the latest 
deployed version of Level design has also 
been included in the Configuration 
Package. 

Levels Sheet / Columns  Group columns names 

Updating Shells - Space Manager Node, Stack Plans 

Go to: Company Workspace > Admin mode > Templates > Shells > "Shell template" > Space 
Manager > Stack Plans 

The Stack Plan, which is a two-dimensional graphical display of facility or building data derived 
from Space records for levels, can be setup in a Shell template. The Stack Plans in a shell 
template will be included in the Configuration Package. 

You can select multiple items to include in the Configuration Package. 
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Conditions for Creating a Stack Plans setup Configuration Package 

The first time that you package the Stack plan Setup information, the level and Space designs 
used in the setup must also be included in the package. This means that the designs must be 
included in the Configuration Package. If this check fails, then the package creation will result in 
an error. For subsequent exports, check will be made to ensure that the design which uses the 
Data Element that is specifically used in the setup is present in the Published package. As long 
as this condition is met, the package creation will be successful. If not, the latest design will have 
to be included in the package. 

Configuration Information: 

For Stack Plans, no checks for inclusion of Configuration setup will be done either at the time of 
packaging the setup for Configuration Package or at the time of importing the setup in a 
destination environment. At the time of import, the setup information is brought over regardless 
of the Configuration status (Active/Inactive) of the design object. However as a best Practice, it 
is recommended that any time the configuration of design object has changed it must be 
included in the Configuration Package. 

Stack Plans Components in the Configuration Package 

The system includes the following components of Stack Plans in the Configuration Package (.zip 
file): 

Component Field / Option 

Stack Plan Properties / General Name 

Stack Plan Properties / General Description 

Stack Plan Properties / General Include levels option 

Stack Plan Properties / Options Space Type. Space type is a required field 
in Stack Plans. The latest deployed 
version of the associated Space type must 
also be part of the Configuration Package. 

Updating Shells - Schedule Manager Node, Schedule Sheets 

Go to: Company Workspace > Admin mode > Templates > Shells > "Shell template" > Schedule 
Manager > Schedule Sheets 

The selected Schedule Sheets in Schedule Manager, in the selected Shell template, will be 
included in the Configuration Package.  

The Schedule Sheets can be created by using templates at the company-level. 

Conditions for Creating a Schedule Sheets setup Configuration Package 

The first time that you package the Setup information, then the Schedule Attribute and the 
Resource Assignment attribute designs must also be included in the package. 
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This means that the design must be included in the Configuration Package. If this check fails, 
then the package creation will result in an error. 

For subsequent exports, check will be made to ensure that the design which uses the Data 
Element that is specifically used in the setup is present in the Published package. As long as 
this condition is met, the package creation will be successful. If not, the latest design will have to 
be included in the package. 

Schedule Sheets Components in the Configuration Package 

The system includes the following components of Schedule Sheets in the Configuration 
Package (.zip file): 

Component Field / Option 

Schedule Sheet Properties/ General All fields. Custom calendars should also be 
included in the Package. 

Schedule Sheet Properties / Gantt Chart All fields  

Schedule Sheet Properties / Tracking 
Gantt 

All fields 

Schedule Sheet Properties / Options All fields 

Schedule Sheet Properties / Schedule All fields 

Schedule Sheet / Activities No activity related information will be 
packaged, meaning no rows will be 
included. 

<Schedule Sheet Name> / Scope 
Management Setup (Applicable for shell 
templates) 

No Scope setup will be brought over since 
the scope is tied to an activity.  

Schedule Sheet / Data Mapping All fields. Dependency checks for inclusion 
of Schedule Attribute and Resource 
Assignment forms will be performed to see 
if the relevant designs are part of the 
package.  

Schedule Sheet / Budget and Progress 
Setup 

All applicable options 

Schedule Sheet / Column All columns defined in the sheet. If column 
definition is based on Cost Sheet 
definition, then the Cost Sheet must also 
be included in the configuration package. If 
cost sheet column does not exist, then an 
error will be displayed. 
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Updating Shells - Activity Manager Node, Activity Sheet 

You can add an Activity Sheet to multiple shells at once with an Activity Sheet template.  

The Update Shell process runs in the background. Depending on the number of records and 
shells you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Update History window shows the complete date. 

To add an Activity Sheet to a shell using Update Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Go to Templates > Shells > Projects and select a shell template.  

3) Click to expand the Activity Manager grouping node and select the Activity Sheet
functional node.  

4) Select an Activity Sheet template from the log. 

5) In the top toolbar, click the Update Shells button and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
active and on-hold shells; there is no undo for the update. If you proceed with the update, the 
following changes will be made:  

 If the Activity Sheet with the same name does not exist, it will be added. 

 If the Activity Sheet exists with the same name, it will not be updated or replaced. 

 Assigned WBS attributes to the Activities will be added to the Project WBS Sheet. 

 If Project WBS Sheet does not exist, it will be added. 

 Assigned OBS attributes to the WBS will be added to the OBS Sheet. 

 If OBS Sheet does not exist, it will be added. 

 Sheet permissions will be added 

 Users and Groups will be added if they do not exist. 

 If Group is created, it will be empty. 

 Custom calendars assigned to Activity Sheet will be added. 

6) Click Yes if you want to proceed with the update, or No to cancel. 
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Note: The views that have been defined in the Activity Sheets templates 
will not be carried over to the Activity Sheet in the shell. 

Configuration Packages 

The Activity Manager sub-node, in the configuration package component list, lists all the Activity 
and WBS Sheet templates defined in the shell templates. You can select one or more Activity 
Sheets, Project WBS Sheet and OBS Sheet per shell template that needs to be exported in a 
package.  

If you select Activity Sheet and the attribute form design is not selected, the following error is 
displayed upon error check in the component list or when creating a component package: 

 The design manual Activity attributes is missing in the component list. 

Similarly when you select an Activity Sheet but have not selected the associated WBS Sheet in 
the component list, the following error will appear upon error check in the component list. When 
creating a configuration package make sure along with the Activity Sheet template, the 
associated WBS Sheet template is also a part of the component list. 

 The OBS Name from the OBS Sheet <Sheet name> included in the WBS Sheet <WBS 
Sheet Name> in  <Shell Template Name> shell template is missing in the component 
list. 

When the WBS Sheet in shell templates is selected in the component list, but not the design, the 
following error is displayed: 

 The design WBS Sheet attributes is missing in the component list. 

When the WBS sheet is selected, but not the OBS Sheet, the following error is displayed. The 
same error will appear in the configuration package creation if the associated OBS Sheet is not 
selected:  

 The OBS Name from the OBS Sheet <Sheet name> included in the WBS Sheet <WBS 
Sheet Name> in  <Shell Template Name> shell template is missing in the component 
list. 

When the OBS Sheet is selected in the component list but not the OBS attribute design, then the 
following error is displayed: 

 The design OBS Sheet attributes is missing in the component list. 

There will be no error check for the Cost Codes while creating the package. 

Add-on Configuration Packages 

You can create new configuration packages based on the component lists having activity sheet 
templates, along with WBS Sheet and OBS Sheet templates and be able to import the package 
in the destination environment. The above validations mentioned in the Component Lists will 
apply when creating a package if the associated WBS Sheet or OBS Sheet template or design is 
not selected in the add on component list. 



Modules Setup Administration Guide

128

Import Package 

When a user imports the configuration package that has shell templates with Activity/WBS/OBS 
Sheets, then in the destination, all the following components should be added. 

 Activity Sheets along with activities, activity attributes, dependencies, assigned WBS Codes, 
assigned CBS codes (if cost sheet is selected in package or cost sheet exists in destination 
with same CBS code structure) 

 Project WBS Sheet with all WBS attributes. 

 OBS Sheet with all OBS attributes. 

 Cost Sheet with all Cost codes (if selected in Package). 

Note: If the Cost Sheet is not included in the Activity Sheet that is 
included in the Configuration Package, then when import is completed, 
the Activity Sheet will not have the cost codes. 

Updating Shells - Access Control Node 

You can edit access control parameters and update across shells. 

The Update Shell process runs in the background. Depending on the number of records and 
shells you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Update History window shows the complete date. 

Notes:

 Modules are identified by name. 

 If the module exists in the shell, the module is updated, users/groups 
are created or updated, and permissions are updated for the module. 

 If the module does not exist, the module is added to the shell. 
Users/groups are created and permissions are created for that 
module. 

To update access control using Update Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell template to update. 

4) In the shell-type template, navigate to Access Control and assign user or group 
permissions to the modules as needed. 

5) Click the Update Shells button. The Update Shells window opens, displaying the list of 
modules for which the access control settings can be updated. 

6) Select the module(s) that you want to update. 

7) Click Update Shells and choose one of the following: 
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 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

8) Click Yes if you want to proceed with the update, or No to cancel. 

Updating Cost Sheet Columns in a Shell 

Cost sheet columns can be updated in CBS code-based shells. 

The Update Shell process runs in the background. Depending on the number of records and 
shells you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Shell History window shows the complete date. 

Notes: 

 A column is identified by a unique data source. 

 If the cost sheet does not exist in the shell, the column is not added. 

 If the shell cost sheet is present but the column does not exist, the 
column definition is created, and the column is added. Column 
restrictions are added. Users/Groups are created or updated. 

 For formula columns, be sure to first push the columns or data 
sources that make up the formula (if they do not exist in the cost 
sheet), then push the formula column. 

 Any new column that is created will use the column to its immediate 
left as the reference point for positioning. When a column is added to 
the cost sheet via an update, this means: If the column to the left of 
the column that is being pushed exists in both the template and cost 
sheet, the column will be positioned in the cost sheet according to its 
position in the template. If the column to the left of the column being 
pushed exists in the template but does not exist in the cost sheet, 
then the column will be added to the end (far right) in the cost sheet. 

Cost Column Shell Updating Rules 

If a cost sheet column of the same name exists, it will be replaced according to the following 
matrix. 

If this template (source): 
Is used for this shell 
(destination): 

The template will: 

Single Date Source Column exists Update the column 
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If this template (source): 
Is used for this shell 
(destination): 

The template will: 

Column does not exist 
Create column with the 
same definition 

Logical Data source 
(Formula entry) 

Logical Data source 
Column Exists (Formula 
entry) 

Update and replace the 
formula 

Logical Data source column 
exists (Manual entry) 

Not update the column or 
formula 

Column does not exist 
Create column with same 
definition 

Logical Data source 
(Manual entry) 

Logical Data source 
Column Exists (Manual 
entry) 

Update the column 

Logical Data source 
Column Exists (Formula 
entry) 

Update the column and 
change it to manual entry 

Column does not exist 
Create column with same 
definition 

To add or update cost sheet columns using Update Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the template to update. 

4) In the left Navigator for the shell-type template, navigate to Cost Manager > Cost Sheet, 
and  open the Cost Sheet template. 

5) In the toolbar, click Menu Options > Columns > Manage Columns. 

The Cost Sheet Columns window opens. 

6) If applicable, drag and drop the listed columns to the order that you want to use. 

7) Select the column, or columns that you want to use in the update. 

8) Click Update Shells, and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find on Page to isolate the 
shells you want to update. The find window contains data elements from the Find form 
that was designed. When you have isolated the shells to update, click the Update button. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

9) If you want to proceed with the update, click Yes; otherwise, click No to cancel. 
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Update Schedule of Values Structure 

You can update the SOV structure for general spends or payment applications in CBS 
code-based shells. 

The Update Shell process runs in the background. Depending on the number of records and 
shells you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Update History window shows the complete date. 

Notes: 

 Update Shell can be used to create or update the SOV structure. If 
the structure exists, it will be updated. If not, it will be created 
(restrictions apply for payment applications; see below). 

 When creating or updating the structure of Payment Applications SOV 
and Summary Payment Applications SOV, the Payment Application 
Business Process must be set up in the target shell first. If the 
business process has an active setup, then Update Shell will create 
or update the structure. 

To update SOV structure using Update Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shell in the left Navigator. 

3) Open the shell template to update. 

4) In the Shell Template, navigate to Cost Manager > Schedule of Values. Select one of 
these options: General Spends/Payment Applications/Summary Payment Applications 
(Contracts with summary - SOV). 

5) Click Update Shells and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed in uDesigner. When you have isolated the shells to update, click the Update 
button and select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

6) Click Yes if you want to proceed with the update, or No to cancel. 
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Updating Shells - Reports Node 

You can add and update user-defined reports.  

The Update Shell process runs in the background. Depending on the number of records and 
shells you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Update History window shows the complete date. 

Important information about updating reports in Project/Shell:  

 Reports are identified by the combination of Name and Data Type. 

 Report names do not have to be unique. 

 If the report name and data type does not exist, the new one will be added. 

 The original owner of the report is added to the Users or Groups of the report in the receiving 
Project/Shell (Permission tab). 

 The administrator of the receiving Project/Shell becomes the report owner. 

 If a report exists with the same name and data type in the receiving Project/Shell, the 
existing report will be replaced with the new report, and the following information will be 
according to the new report: 

 Report updates 

 Added or changed Users or groups 

 Added or changed permissions 

To add or update user-defined reports using Update Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell template to update. 

4) In the shell type template, navigate to the Reports > User-Defined Reports log. 

5) Add a UDR to the shell type template, or select UDR to edit. Define properties. 

6) Select one or more reports from the User-Defined Reports log. 

7) Click Update Shells and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the 
selected shells; there is no undo for the update. 

8) Click Yes if you want to proceed with the update, or No to cancel. 
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Update Commitment Funding Structure 

You can update the structure used to create commitment funding sheets in CBS code-based 
shells. 

The Update Shells process runs in the background. Depending on the number of records and 
projects you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Update History window shows the complete date. 

Notes: 

 Update Project can be used to create or update the commitment 
funding structure in the project. If the structure exists, it will be 
updated. If not, it will be created. 

 Updating the structure in a project will not affect existing commitment 
funding sheets. New sheets will reflect the updated structure. 

To update commitment funding structure using Update Shell 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shell in the left Navigator. 

3) Open the shell template to update. 

4) In the shell template, navigate to Cost Manager > Funding > Commitment Funding 
Sheet. 

5) Click Update Shells and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

6) Click Yes if you want to proceed with the update, or No to cancel. 

Update Cash Flow Properties and Permissions 

You can push cash flow detail curve properties and permissions from a shell template to a shell. 
This is available for CBS-code based shells and templates. 

The Update Shell process runs in the background. Depending on the number of records and 
projects you are updating, it can take a considerable amount of time to complete. The process is 
complete when the End Date column in the Update History window shows the complete date. 

Notes about updating cash flow curve properties: 

 Both detail curve properties and permissions are pushed from the 
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template to the project. 

 Cash flow detail curves are identified by name. 

 If a detail curve with the same name exists in the project, it will be 
replaced. All properties, including detail level and time scale, and 
permission settings will be updated. 

 If a detail curve with the same name does not exist in the project, a 
new one will be created. 

 Users and groups will be added if they do not exist. If a group is 
created, it will be empty. 

 In order to push a curve, the destination project must have a cost 
sheet. 

 Commitment detail level curves will not be pushed. 

 A Summary CBS curve cannot be pushed to a project where the cost 
sheet is flat. 

 After a successful update, the updated destination curves will be 
refreshed. 

To update cash flow curve properties and permissions using Update Shell 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shell. 

3) Open the shell template to update. 

4) In the shell template, navigate to Cost Manager > Cash Flow. 

5) Add a cash flow curve to the shell template, or select one to edit. Define properties. 

6) Select a curve from the Cash Flow log. 

7) Click Update Shells and choose one of the following: 

 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that was 
designed. When you have isolated the shells to update, click the Update button and 
select either Selected Shell(s) or All Filtered Shells. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

8) An Alert window opens, detailing the information that will be updated. Read the message 
carefully, because after a shell is updated, this action cannot be undone. Click Yes if you 
want to proceed with the update, or No to cancel. 
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Update Generic Cost Sheet Columns and Rows 

You may have a large number of codes that are used within the Generic Cost Manager. In 
addition you may have a large number of shells in your implementation. To update codes and 
columns in your generic cost manager sheets with a minimal effort, you can push columns in a 
project or shell template generic cost sheet from the Columns Log to cost sheets. 

About updating shell instance dashboards 

A cost sheet must exist in the destination shell. Pushing a column from a template will not create 
a cost sheet that can receive the column. 

You can push one column at a time. 

If a source column is a single data source, the destination column will be created with that single 
data source if it does not exist. (Column A or B in example below) 

If a source column is a formula with only single data sources, pushing the source column will 
create that column in the destination cost sheet, if it does not exist. (Column C in example 
below) 

If a source column is a formula with columns included in the formula, as long as all constituent 
columns contain single data sources, the source column can be pushed; for any columns that do 
not exist in the destination cost sheet, the formula will be changed to a single data source in the 
formula. (Column D in example below) 

If a source column is a formula with constituent columns that include logical data sources, the 
logical data source must exist in the destination cost sheet. The formula for the logical data 
source may be different in the destination cost sheet. Any column that contains a single data 
source will follow the rule above. (Column F in example below) 

To add or update generic cost sheet columns from a template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell-type template to update. 

4) In the shell template, navigate to Configurable Modules > Generic Cost Manager. 

5) Select the Generic Cost Manager Sheet template and click the Structure button. 

6) In the Generic Cost Manager Sheet log, select the cost sheet template and then click the 
Columns button. The Columns Log opens. 

7) Select a cost sheet column. 

8) Click Update Shells and choose one of the following: 
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 Shells: You can use this option to select one or more shells to update. When the update 
window opens, it lists all shells in the project. You can use Find to isolate the shells you 
want to update. The find window contains data elements from the Find form that were 
designed in uDesigner. When you have isolated the shells to update, click the Update
button. 

 All Shells: You can use this option to update all shells of that shell type. 

 History: You can view the update history from past updates or cancel a request before 
the update begins. 

An Alert window opens letting you know that you are about to push changes to the selected 
shells; there is no undo for the update. 

9) Click Yes if you want to proceed with the update, or No to cancel. 

To update generic cost sheet rows from a template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells in the left Navigator. 

3) Open the shell template you want to update. 

4) In the template, navigate to Configurable Modules > Generic Cost Manager. 

5) Select the template and click the Structure button. 

6) Select a row or rows to push to the project/shell level generic cost sheet. You can select 
multiple rows by holding down the Shift or Ctrl keys as you click the rows. 

The application will update leaf-level rows, but not summary rows. 

7) Click Update Shells and choose one of the following: 

 Shells: allows you to choose which shell(s) to update. You can use Find to search for 
specific shells to select from the complete list of shells. You can select as many shells as 
you want to update. The Page and Display fields display on the Shell Update window, but 
are disabled in this case. 

 All Shells: updates all active and on-hold shells 

 History: allows you to view the update history from past updates or cancel a request 
before the update begins. 

An Alert window opens, detailing the information that will be updated. Read the message 
carefully, as once a shell is updated, this action cannot be undone. 

8) Click Yes if you want to proceed with the update, or No to cancel. 

View Update history 

You can view details about previously updated shell modules. 

To view Update Shell History 

1) In the shell type template, navigate to the module to view the update history. 

2) Click the Update Shells button and choose History. The Update Shells: History window 
opens. It lists any previous incidents of using Update Shells. 

3) Select an instance from the list and click Open. The History Details window opens, detailing 
the module information that was updated. History Details displays: 

 Requestor: User who initiated the update process 
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 Shells: Either user-selected or all shells 

 Submitted date: When the update request was submitted 

 Start date: When the update process started 

 End date: When the update process ended 

Cancel a Shell Update Request 

You can cancel an update request that has not yet started; that is, any request that does not 
have a status of In Process or Finished. 

To cancel a shell update request 

1) In the shell type template, navigate to the module in which you want to cancel the update 
request. 

2) Click the Update Shells button and choose History. The Update Shells: History window 
opens. 

3) Select an update that has not yet started. 

4) Click Cancel Request. 

Updating Shell Templates 

You (the Administrator) can create or update Shell Template components from another Shell 
Template. 

Within a shell template, you can use the Update Shell Templates (toolbar option) and push the 
shell template data from source shell template to destination shell template or shell templates of 
the same shell type for the modules described in the following topics. 

Access Control 

For specific modules, you can update the Access Control information in the destination shell 
templates from a source shell template. To do so, use the Update Shell Templates toolbar 
option. After the update completes successfully, all the selected destination shell templates will 
have the Access Control information updated. 

The modules that do not exist in the destination shell template will get added.  

Also, Groups or Users associated with the modules are added. The modules that exist in the 
destination shell template will have the Access Control information replaced. In this case, new 
Groups or Users that do not exist in the destination shell template will get added. 

To access and work with the Update Shell Templates toolbar option: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 
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4) In the left Navigator for the project, click Access Control to open the Access Control 
window. 

5) From the toolbar, click Update Shell Templates to open the Update Shell Templates
window. 

6) From the Update Shell Templates window select as many records (modules, BPs, and so 
on) as you need, click the Update drop-down list, and select the Shell Templates menu 
item to open the Select Shell Templates pop-up window. 

7) From the Projects list (Projects - Current View: All), select the projects that you want to 
update, and click Update. 

8) Review the message that is displayed in the Confirmation window. 

Update Shell Template with Access Control

- Module will be added if does not exist

- Users and Groups will be added if they do not exist

- Module permissions will be added or replaced

This will update selected shell templates and cannot be reverted. Do 
you want to continue?

Pay attention to the last line, which indicates that the update will be applied to the selected 
shell templates. 

9) Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

10) If you click Yes, you will return to the Update Shell Templates window which you can close 
to return to the Access Control window. 

In the Update Shell Templates window, when you select as many records (modules, BPs, and 
so on) as you need and click the Update drop-down list, the following menu items are available: 

 Shell Templates

 All other Shell Templates

 History

The Shell Templates menu item is explained above. 

All other Shell Templates

If you click the All other Shell Templates menu item, a Confirmation window opens with 
the following message: 

Update Shell Template with Access Control

- Module will be added if does not exist

- Users and Groups will be added if they do not exist

- Module permissions will be added or replaced

This will update all other shell templates and cannot be reverted. Do 
you want to continue?

Pay attention to the last line, which indicates that the update will be applied to all of the shell 
templates. 
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Click Yes, if you want to update all of the shell templates, or click No, to cancel. When you 
click Yes in the Confirmation window, the selected modules Access Control information 
(permissions) will be sent (pushed) to all of the other shell templates of same shell type, 
excluding the current source shell template. 

History

If you click the History menu item, the Update Shell Templates: History window opens. 
This window shows the details of the submitted update requests. This window provides 
details such as: 

 Requestor's name (Requestor column) 

 Selected shell templates (Shell Templates column) 

 Date submitted (Submit Date column) 

 Start date and time (Start Date column) 

 End date and time (End Date column) 

 Status of the job (Status column) 

In the case of Access Control information, the history details the actions performed as part 
of Access Control information push to the destination shell templates (all shell templates or 
the user-selected shell templates). 

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

Configuration Package and Access Control 

For specific modules, you can send Access Control information of a component (or selection of 
components) into a destination shell template (or a selection of shell templates), from the source 
shell templates. 

 If any of the selected components exists in the destination shell template, the Access 
Control information will be replaced in the destination shell template.  

 If any of the selected components do not exist in the destination shell template, the Access 
Control information will be added in the destination shell template.  

The associated Groups and Users will also be added into the destination shell templates. 

Business Process and Workflow Setups 

Business Process Setup 

For specific modules, you can update the business process setup for workflow and non-workflow 
business processes information in the destination shell templates from a source shell template. 
To do so, you can use the Update Shell Templates toolbar option. After the update completes 
successfully, all the selected destination shell templates will have the business process setup for 
workflow or non-workflow business processes information updated. The modules that do not 
exist in the destination shell template will get added. 

To access and work with the Update Shell Templates toolbar option: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 
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3) In the Projects Templates log, select and open a project. 

4) In the left Navigator for the project, click Setup > Business Process. 

5) In the Business Processes log, select a BP and open the record. 

6) In the BP record log, select the BP record, and from the toolbar click Update Shell 
Templates to open the Update Shell Templates menu. Your options are as follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Note: If the Record Status defined in the source has been inactivated, 
an error is displayed that requires selection of an active Record Status to 
continue. 

Shells Templates

If you select this option, the Select Shell Templates window opens, which displays a list of 
projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns. 

Select the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed. 

Click Yes to update the selected shell templates, or click No to cancel your update. 

If you click Yes, you will return to the Update Shell Templates window. In the Update Shell 
Templates window, click Close to exit. 

All Other Shell Templates

If you select this option, a Confirmation window opens. Review the message that is 
displayed. 

Click Yes to update all the shell templates, or click No to cancel your update. 

History

If you select this option, the Update Shell Templates: History window opens. This window 
shows the details of the submitted update requests. In the case of business process setup 
for workflow and non-workflow business processes, the history details the actions performed 
as part of information push to the destination shell templates (all shell templates or the 
user-selected shell templates). 

If the job is not successful for specific shell templates, the history details lists the shell 
templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open to see the details about that item. 

The following cases explain the results of sending various non-workflow and workflow BP setups 
to the destination shell templates. 

When you select a non-workflow BP setup to send or push to the destination shell template and 
the BP setup does not exist in the destination shell template: 
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A new BP setup will be added, and the following information (from all the tabs) will be added 
as part of the business process setup creation. The following tabs information will be added 
into the destination shell templates, upon successful push from the source shell template.  

General tab 

All the information in the General tab (such as setup name, description, help file, default 
record status, and so on) will be added. 

Any Groups or Users who are part of the BP setup will be brought over to the current 
shell template as members.     

 If Groups or Users do not exist in the destination shell template, they will be 
added as shell template members. This could be both Owner Company or 
Sponsor Company or Partner Company or Member Company users. 

 If Users exist in the destination shell template, they will be added to the BP 
setup. 

Record Editors tab 

All the record editors of the existing BP setup will be added. 

The Groups or Users selected as record editors will be added as members to the 
destination shell template, if they do not exist. 

View Forms tab 

All the View Forms that are associated with the BP setup will be added. 

Record Properties tab 

All the record properties associated with the BP setup will be added. 

Notifications tab 

All the options under the Notifications selected will be added in the BP setup that is 
created in the destination shell template. 

Auto creation Setup

All the autocreation settings, including the autocreator, will be added in the BP setup that 
is created in the destination shell template. 

Empty Groups will be added, if they do not exist. The permissions related to the BP 
setup will be added as part of this update or push. The Last Modified Date value in 
the BP setup log will be updated to show the latest updated, or added, date. 

When you select a non-workflow BP setup to send or push to the destination shell template, and 
the BP setup does exist in the destination shell template: 

If the BP setup exists in the destination shell template, the existing BP setup will be replaced. 

The tabs information will be replaced with the source shell template BP setup information.  

Groups or Users who do not exist in the destination shell template will be added as part of 
the BP setup update or push. 

When you select a workflow BP setup to send or push to the destination shell template and the 
BP setup does not exist in the destination shell template: 

If the BP setup does not exist in the destination shell template, the BP setup information, 
tabs information, and autocreation setup information will be replaced. 

All the workflows associated to the BP will be added. 
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The following tabs information will be added into the destination shell templates, upon 
successful push from the source shell template. 

General tab 

All of the information in the General tab (description, help file, default record status, and 
so on) will be added. 

Any Groups or Users who are part of the BP setup will be brought over to the current 
shell template as members.  

Record Editors tab 

All of the record editors of the existing BP setup will be added. 

The Groups or Users selected as record editors will be added as members to the 
destination shell template, if they do not exist.     

View Forms tab 

All of the View Forms that are associated with the BP setup will be added. 

Record Properties tab 

All of the record properties associated with the BP setup will be added. 

Notifications tab 

All of the options under the Notifications selected will be added in the BP setup that is 
created in the destination shell template. 

Auto creation Setup

Only the autocreation settings will be added in the BP setup that is created in the 
destination shell template. 

You must send or push a workflow BP setup separately. 

By sending or pushing the BP setup, you can set up changes in other shell templates 
without the need to bring in the workflow setups. 

For any new workflow BP that must be sent or pushed into shell templates, you can 
select the Update Shell Templates option from the workflow setup log. This enables 
the selected workflow, BP setup information, and autocreation workflow setup to be 
sent or pushed to the destination shell templates. 

When you select workflow BP setup to send or push to the destination shell template and the BP 
setup does not exist in the destination shell template: 

If the BP setup exists in the destination shell template, the existing BP setup will be replaced. 

The tabs information will be replaced with the source shell template BP setup information.  

Groups or Users who do not exist in the destination shell template will be added as part of 
the BP setup update or push. The permissions related to the BP setup will be added as part 
of this update or push. The Last Modified Date value in the BP setup log will be updated to 
show the latest updated, or added, date. 
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Workflow Setup 

For specific modules, you can update the Workflow Setup information in the destination shell 
templates from a source shell template. To do so, you can use the Update Shell Templates
toolbar option. After the update completes successfully, all the selected destination shell 
templates will have the business process setup for workflow or non-workflow business 
processes information updated. The modules that do not exist in the destination shell template 
will get added. 

To access and work with the Update Shell Templates toolbar option: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 

4) In the left Navigator for the project, click Setup > Business Process. 

5) In the Business Processes log, select and open a BP. 

6) In the left Navigator, click the Workflow Setup functional node to open the workflow Setup 
log for the selected BP. 

7) In the Setup log, select the applicable workflow, and from the toolbar click Update Shell 
Templates to open the Update Shell Templates menu. Your options are as follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates

If you select this option, the Select Shell Templates window opens, which displays a list of 
projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns. 

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed. 

Click Yes to update the selected shell templates, or click No to cancel your update. 

If you click Yes, you will return to the Update Shell Templates window, which you can close 
to return to the Access Control window.  

All Other Shell Templates

If you select this option, a Confirmation window opens. Review the message that is 
displayed. 

Click Yes to update all of the shell templates, or click No to cancel your update. 

History

If you select this option, the Update Shell Templates: History window opens. This window 
shows the details of the submitted update requests. The history details the actions performed 
as part of information push to the destination shell templates (all shell templates or the 
user-selected shell templates). 

If the job is not successful for specific shell templates, the history lists the shell templates 
where the update has failed and displays the reason for the failure. 
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You can select an item in the list and click Open to see the details about that item. 

The following cases explain the results of sending various workflow setups to the destination 
shell templates. 

When you select workflow setups to send or push to the destination shell template, along with 
the BP setup where the BP does not exist: 

Upon successful completion of the push job, the destination shell template will have the 
workflow setups along with the BP setup.  

New Groups or Users who are associated with either the workflow setup or the BP setup 
will be added and permissions related to the BP setup will be copied. 

The last modified date in the BP setup log will be updated to reflect the newly pushed date. 

When you select workflow setups to send or push to the destination shell template, along with 
the BP setup where the BP exists: 

In the destination shell template, the BP setup will be replaced with the source shell template 
BP setup information. 

All the existing workflow setups will be replaced with the workflow setups of the source shell 
template. 

New Groups or Users who are associated with either the workflow setup or the BP setup 
will be added and permissions related to the BP setup will be copied. Similarly, the existing 
user's permissions related to the BP setup will be updated.  

The last modified date in the BP setup log will be updated to reflect the newly pushed date. 

Gates 

To update the destination shell templates with Gates setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 

4) In the left Navigator for the project, click Setup > Gates to open the Gates Setup log. 

5) Select an item, and click Update Shell Templates in the toolbar to open the menu. Your 
options are as follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates

If you select this option, the Select Shell Templates window opens that displays a list of 
projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns: 

 Project Number
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 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Template with Gates Setup

- If Setup does not exist then it will be added

- Gates Setup will be added or replaced

- Users and Groups will be added if they do not exist

-If Group is created then it will be empty

This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, the push job gets initiated and the History log will show the job details. The 
Gates setup will be added or replaced in the destination shell template, upon successful 
completion of the update or push job. 

If there are no existing Gates Setup in the destination shell template, a new Gates Setup
will be added, and the information in the General, Settings, and Schedule tabs will be 
updated. 

General tab: 

The Setup Name, Description, and Status will be updated based on the source Gates 
Setup values. 

The Status value (Active/Inactive) of the destination shell template Gates Setup will be 
updated with the source. 

Settings tab: 

All the phases in the Settings tab will be updated, and the Gates Setup condition 
elements will be added. 

The Groups and Users associated with the additional Gates Setup information will be 
updated, and they will be added as shell template members if they do not exist. In the 
case of Groups, only the Groups names will be added. 

The Email content and other additional Gates Setup in the Settings tab will be updated 
according to the Gates Setup information of the source. 
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Schedule tab: 

The details related to the schedule runs of the Gates Setup will be updated with the 
Gates Setup information of the source. 

The Gates Setup log information (such as Name, Status, Last Update Date, Creator, 
and Current Phase) will be updated with the Gates Setup information of the source. 

The Last Update Date value will get updated to the current date and time. 

If there are existing Gates Setup in the destination shell template, and the current status of 
the setup is Inactive, then the Gates Setup in the destination shell template will be updated, 
and the status will be updated based on the source Gates Setup. 

All Other Shell Templates

If you select this option, a Confirmation window opens with the following message: 

Update Shell Template with Gates Setup

- If Setup does not exist then it will be added

- Gates Setup will be added or replaced

- Users and Groups will be added if they do not exist

-If Group is created then it will be empty

This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update all of the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, the Update Shell Templates: History window opens. 
This window shows the details of the submitted update requests. This window provides 
details such as: 

 Requestor's name (Requestor column) 

 Selected shell templates (Shell Templates column) 

 Date submitted (Submit Date column) 

 Start date and time (Start Date column) 

 End date and time (End Date column) 

 Status of the job (Status column) 

The History log provides details of each job by showing the actions performed as a part of 
Gates Setup push to the destination shell templates.  

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

Dashboards 

To update the destination shell templates with Dashboards setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 
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3) In the Projects Templates log, select and open a project. 

4) In the left Navigator for the project, click Setup > Dashboards to open the Dashboards log. 

5) Select a dashboard, and click Update Shell Templates in the toolbar to open the menu. 
Your options are as follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates

If you select this option, the Update Shell Templates window opens that displays a list of 
projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Templates with Dashboard Setups

- Dashboard Setups will be added or replaced

- The default setting for the dashboard will be added or updated. Users 
and groups who have view permissions to the default dashboard will 
have the default setting updated

- Users and Groups will be added if they do not exist

- If Group is created then it will be empty

This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, the push job gets initiated and the History log will show the job details. 

The following definitions from the existing selected Dashboards setups will be added or 
replaced in the destination shell templates: 
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Setup information (such as Name, Description, and so on) 

The Last Modified Date value will be updated to the current date, and the Creator will be a 
logged-in user who adds the dashboard. 

All the permissions related to the setup will be added or updated.  

The Groups and Users associated with the additional Dashboards setup information will be 
updated, and they will be added as the shell template members if they currently do not exist. 

The following will be copied: 

 Filters associated with the Dashboards setups. 

 Custom, Drill-down, Portlet, Standard, and Analytics blocks, from the source 
Dashboards setups. 

The default settings will not change in the destination shell template. 

For the existing Dashboard setups, the following additional information will be updated: 

 New Custom, Drill-down, Portlet, Standard, and Analytics blocks within the tabs 
will be added or updated. The new tabs will be added to the existing setup. 

 All the destination shell templates where the Dashboards setups are added or 
replaced will be listed in the history details. 

All Other Shell Templates

If you select this option, a Confirmation window opens with the following message: 

Update Shell Templates with Dashboard Setups

- Dashboard Setups will be added or replaced

- The default setting for the dashboard will be added or updated. Users 
and groups who have view permissions to the default dashboard will 
have the default setting updated

- Users and Groups will be added if they do not exist

- If Group is created then it will be empty

This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update all of the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, the Shell Template History window opens. This window 
shows the details of the submitted update requests. This window has the following columns: 

 Requestor 

 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
Dashboards push to the destination shell templates.  

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 
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You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed. 

Rules 

To update the destination shell templates with Rules setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 

4) In the left Navigator for the project, click Rules to open the Rules log. 

5) Select an item, and click Update Shell Templates to open the menu. Your options are as 
follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates

If you select this option, the Select Shell Templates window opens that displays a list of 
projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar, click Update. When 
the Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Templates with Rules

- Rules will be added or replaced

- Users and Groups will be added if they do not exist

- If Group is created then it will be empty
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This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, the push job gets initiated and the History log will show the job details. 

The Rules setup will be added or replaced in the destination shell templates. 

All Other Shell Templates

If you select this option, a Confirmation window opens with the following message: 

Update Shell Templates with Rules

- Rules will be added or replaced

- Users and Groups will be added if they do not exist

- If Group is created then it will be empty

This will update shell templates and cannot be reverted. Do you want 
to continue? 

Click Yes, if you want to update all of the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, the Update Shell Templates: History window opens. 
This window shows the details of the submitted update requests. This window has the 
following columns: 

 Requestor 

 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
Rules push to the destination shell templates.  

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed. 

Cash Flow 

To update the destination shell templates with Cash Flow setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 
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4) In the left Navigator for the project, click Cost Manager > Cash Flow to open the Cash 
Flow log. 

5) Select a cash flow, and click Update Shell Templates in the toolbar to open the menu. Your 
options are as follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates

If you select this option, the Update Shell Templates window opens that displays a list of 
projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Templates with Cash flow curves

- If Cash flow curve does not exist it will be added

- If Cash flow curve exists it will be replaced

- Users and Groups will be added if they do not exist

- If Group is created then it will be empty

This will update selected templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, the push job gets initiated and the History log will show the job details. 

The Cash Flow setup will be added or replaced in the destination shell templates. 

All Other Shell Templates

If you select this option, a Confirmation window opens with the following message: 
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Update Shell Templates with Cash flow curves

- If Cash flow curve does not exist it will be added

- If Cash flow curve exists it will be replaced

- Users and Groups will be added if they do not exist

- If Group is created then it will be empty

This will update shell all templates and cannot be reverted. Do you 
want to continue?

Click Yes, if you want to update all of the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, the Shell Template History window opens. This window 
shows the details of the submitted update requests. This window has the following columns: 

 Requestor 

 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
Cash Flow push to the destination shell templates.  

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed.  

In the History log: 

 If the destination shell template does not have a Cost Sheet defined, and the user 
tries to add Cash Flow by CBS or Summary CBS curves, the following message 
will be displayed in history log: "Cost Sheet is not defined." 

 If the selected cash flow curve is of the Commitment type and the Commits BP 
setup does not exist in the destination shell template, the following message will 
be displayed in history log: "Business Process <BP name> setup does not exist or 
is in inactive status." 

 If the selected cash flow curve has a schedule selected either from Activity Sheet 
or Schedule Sheet, and the selected Activity Sheet or Schedule Sheet does not 
exist in the destination shell template, then when the user saves the properties of 
the selected cash flow curve in the destination shell template the system will 
display error message. 
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Cost Sheet Columns 

To update the destination shell templates with Cost Sheet Columns setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 

4) In the left Navigator for the project, click Cost Manager > Cost Sheet, and open the Project 
Cost Sheet. 

5) In the toolbar, click Menu Options > Columns > Manage Columns. 

The Cost Sheet Columns window opens. 

6) If applicable, drag and drop the list columns to the order that you want to use. 

7) Select the column, or columns, that you want to use in the update. 

8) Click Update Shell Templates, and choose one of the following: 

 Shell Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shell Templates

If you select this option, the Update Shell Templates window opens that displays a list of 
projects that you can select. You can use Search or Find on Page to isolate the shells you 
want to update. The projects are listed in the Projects log, and the details of each project are 
displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Templates with Cost Sheet Column

- Cost Sheet column will be added or replaced

- Restrictions will be added or updated

- Users and Groups will be added if they do not exist
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This will update selected shell templates and cannot be reverted. Do 
you want to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, the push job gets initiated, and the History log will show the job details. 

The Cost Sheet Columns setup will be added or replaced in the destination shell templates. 

All Other Shell Templates

If you select this option, a Confirmation window opens with the following message: 

Update Shell Templates with Cost Sheet Column

- Cost Sheet column will be added or replaced

- Restrictions will be added or updated

- Users and Groups will be added if they do not exist

This will update all shell templates and cannot be reverted. Do you 
want to continue?

Click Yes, if you want to update all the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, the Shell Template History window opens. This window 
shows the details of the submitted update requests. This window has the following columns: 

 Requestor 

 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
Cost Sheet Columns push to the destination shell templates.  

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed.  

In the History log, if the destination shell template does not have a Cost Sheet defined, the 
following message will be displayed in history log: "Cost Sheet is not defined." 

Commitment Funding Sheet 

To update the destination shell templates with Commitment Funding Sheet setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 
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4) From the navigation pane, click Cost Manager to expand it, click Funding to expand it, and 
click Commitment Funding Sheet to open the Commitment Funding Sheet log. 

5) In the Commitment Funding Sheet log, from the toolbar, click Update Shell Templates to 
open the Update Shell Templates menu items. Your options are as follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates

If you select this option, the Select Shell Templates window opens that displays a list of 
projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Templates with Commitment Funding Sheet Structure

- Structure will be added if does not exist

- Structure will be replaced if does exist

- Properties will be added or replaced

This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, the push job gets initiated and the History log will show the job details. 

The Commitment Funding Sheet setup will be added or replaced in the destination shell 
templates. 

The History log will show the job details. 

All Other Shell Templates

If you select this option, a Confirmation window opens with the following message: 

Update Shell Templates with Commitment Funding Sheet Structure

- Structure will be added if does not exist

- Structure will be replaced if does exist
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- Properties will be added or replaced

This will update shell templates and cannot be reverted. Do you want 
to continue? 

Click Yes, if you want to update all of the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, the Shell Template History window opens. This window 
shows the details of the submitted update requests. This window has the following columns: 

 Requestor 

 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
Commitment Funding Sheet setup push to the destination shell templates.  

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed.  

Document Manager 

To update the destination shell templates with Document Manager setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 

4) In the left Navigator for the project, click Document Manager > Documents to open the 
Documents log. 

The Documents log is divided into two panes. The left pane lists the Project Documents
and the right pane displays the corresponding details for each document. 

5) In the left pane of the Documents log, select a record, and click Update Shell Templates in 
the toolbar to open the menu. Your options are as follows: 

 Structure & Permissions

 Permissions only

 History

You can select to update both the structure and permissions of the documents in the 
destination shell template or just the permissions. 

The following explores each option in detail. 
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Structure & Permissions

The Structure & Permissions option has the following menu items: 

 Shell Templates

 All Other Shell Templates

The following explores each option in detail. 

Shells Templates

If you select this option, the Select Shell Templates window opens that displays a list of 
projects that you can select. The projects are listed in the Projects log, and the 
details of each project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When 
the Confirmation window opens, review the message that is displayed in the 
Confirmation window. 

Update Shell Templates with Folders

- If folder does not exist then it will be added.

- Folder deletions will happen in the Shell Templates when there is 
no document in that hierarchy.

- Folder rename will not happen through this update. The system will 
create a new folder in the Shell Templates with the renamed folder.

- Users and Groups will be added if they do not exist.

- If Group is created then it will be empty.

This will update Shell Templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, the push job gets initiated and the History log will show the job details. 

The applicable document type setup will be added or replaced in the destination shell 
templates. 

The History log will show the job details. 

All Other Shell Templates
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If you select this option, a Confirmation window opens with the following message: 

Update Shell Templates with Folders

- If folder does not exist then it will be added.

- Folder deletions will happen in the Shell Templates when there is 
no document in that hierarchy.

- Folder rename will not happen through this update. The system will 
create a new folder in the Shell Templates with the renamed folder.

- Users and Groups will be added if they do not exist.

- If Group is created then it will be empty.

This will update Shell Templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update all of the shell templates, or click No, to cancel your 
update. 

Permissions only

The Permissions only option has the following menu items: 

 Shell Templates

 All Other Shell Templates

The following explores each option in detail. 

Shells Templates

If you select this option, the Select Shell Templates window opens that displays a list of 
projects that you can select. The projects are listed in the Projects log, and the 
details of each project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When 
the Confirmation window opens, review the message that is displayed in the 
Confirmation window. 

Update Shell Templates with Folders

- Folder creation and deletion will not happen.

- Users and Groups will be added if they do not exist.

- If Group is created then it will be empty.
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This will update Shell Templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, then the push job gets initiated and the History log will show the job 
details. 

The applicable document type setup will be added or replaced in the destination shell 
templates. 

The History log will show the job details. 

All Other Shell Templates

If you select this option, a Confirmation window opens with the following message: 

Update Shell Templates with Folders

- Folder creation and deletion will not happen.

- Users and Groups will be added if they do not exist.

- If Group is created then it will be empty.

This will update Shell Templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update all of the shell templates, or click No, to cancel your 
update. 

History

If you click the History menu item, the Shell Template History window opens. This window 
shows the details of the submitted update requests. This window has the following columns: 

 Requestor 

 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
the Documents setup push to the destination shell templates. 

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed. 

General Spends (SOV Structure) 

To update the destination shell templates with General Spends setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 
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3) In the Projects Templates log, select and open a project. 

4) In the left Navigator for the project, click Cost Manager > Schedule of Values > General 
Spends to open the Schedule of Values: General Spends log. 

5) Select an item, and click Update Shell Templates in the toolbar to open the menu. Your 
options are as follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates

If you select this option, the Select Shell Templates window opens that displays a list of 
projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Templates with General Spends SOV Structure

- Structure will be added if does not exist

- Structure will be replaced if does exist

This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, the push job gets initiated and the History log will show the job details. 

The General Spends setup will be added or replaced in the destination shell templates. 

The History log will show the job details. 

All Other Shell Templates

If you select this option, a Confirmation window opens with the following message: 
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Update Shell Templates with General Spends SOV Structure

- Structure will be added if does not exist

- Structure will be replaced if does exist

This will update shell templates and cannot be reverted. Do you want 
to continue? 

Click Yes, if you want to update all of the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, the Shell Template History window opens. This window 
shows the details of the submitted update requests. This window has the following columns: 

 Requestor 

 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
the General Spends setup push to the destination shell templates.  

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed.  

Payment Applications (SOV Structure) 

To update the destination shell templates with Payment Applications setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 

4) In the left Navigator for the project, click Cost Manager > Schedule of Values > Payment 
Applications to open the Schedule of Values: Payment Applications log. 

5) Select an item, and click Update Shell Templates in the toolbar to open the menu. Your 
options are as follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates
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If you select this option, the Select Shell Templates window opens that displays a list of 
projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Templates with Payment SOV Structure

- Structure will be added if does not exist

- Structure will be replaced if does exist

This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, the push job gets initiated and the History log will show the job details. 

The Payment Applications setup will be added or replaced in the destination shell 
templates. 

The History log will show the job details. 

All Other Shell Templates

If you select this option, a Confirmation window opens with the following message: 

Update Shell Templates with Payment SOV Structure

- Structure will be added if does not exist

- Structure will be replaced if does exist

This will update shell templates and cannot be reverted. Do you want 
to continue? 

Click Yes, if you want to update all of the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, the Shell Template History window opens. This window 
shows the details of the submitted update requests. This window has the following columns: 

 Requestor 
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 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
the Payment Applications  setup push to the destination shell templates.  

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed.  

Summary Payment Applications (SOV Structure) 

To update the destination shell templates with Summary Payment Applications setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) From the Projects Templates log, select and open a project. 

4) From the navigation pane, click Cost Manager to expand it, click Schedule of Values to 
expand it, and click Summary Payment Applications to expand it. Select the desired SOV 
functional sub-node. 

5) In the Schedule of Values: Summary Payment Applications log, from the toolbar, click 
Update Shell Templates to open the Update Shell Templates menu items. Your options 
are as follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates

If you select this option, then the Select Shell Templates window opens that displays a list 
of projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date
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 Administrator

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Templates with Commitment Funding Sheet Structure

- Structure will be added if does not exist

- Structure will be replaced if does exist

This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, then the push job gets initiated and the History log will show the job details. 

The Commitment Funding Sheet setup will be added or replaced in the destination shell 
templates. 

The History log will show the job details. 

All Other Shell Templates

If you select this option, then a Confirmation window opens with the following message: 

Update Shell Templates with Commitment Funding Sheet Structure

- Structure will be added if does not exist

- Structure will be replaced if does exist

This will update shell templates and cannot be reverted. Do you want 
to continue? 

Click Yes, if you want to update all of the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, then the Shell Template History window opens. This 
window shows the details of the submitted update requests. This window has the following 
columns: 

 Requestor 

 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
Summary Payment Applications setup push to the destination shell templates.  

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed.  
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Reports (User-Defined Reports) 

To update the destination shell templates with Reports setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 

4) In the left Navigator for the project, click Reports > User-Defined to open the User-Defined 
Reports log. 

5) In the log, select the needed reports and click Update Shell Templates in the toolbar to 
open the menu. Your options are as follows: 

 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates

If you select this option, the Select Shell Templates window opens that displays a list of 
projects that you can select. The projects are listed in the Projects log, and the details of 
each project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Template with User Defined Reports

- Report will be added if does not exists

- Report will be replaced if does exists

- Users and Groups will be added if they do not exist

This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 



Modules Setup Administration Guide

166

If you click Yes, the push job gets initiated and the History log will show the job details. 

The User-Defined Reports setup will be added or replaced in the destination shell 
templates. 

The History log will show the job details. 

All Other Shell Templates

If you select this option, a Confirmation window opens with the following message: 

Update Shell Template with User Defined Reports

- Report will be added if does not exists

- Report will be replaced if does exists

- Users and Groups will be added if they do not exist

This will update shell templates and cannot be reverted. Do you want 
to continue?

Click Yes, if you want to update all of the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, the Shell Template History window opens. This window 
shows the details of the submitted update requests. This window has the following columns: 

 Requestor 

 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
the User-Defined Reports setup push to the destination shell templates. 

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed. 

Activity Sheets 

To update the destination shell templates with Activity Sheets setup: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) In the Projects Templates log, select and open a project. 

4) From the navigation pane, click Activity Manager > Activity Sheet to open the Activity 
Sheets log. 

5) Select an item, and from the toolbar click Update Shell Templates to open the Update 
Shell Templates menu items. Your options are as follows: 
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 Shells Templates

 All Other Shell Templates

 History

The following explores each option in detail. 

Shells Templates

If you select this option, then the Update Shell Templates window opens that displays a list 
of projects that you can select. The projects are listed in the window, and the details of each 
project are displayed in columns: 

 Project Number

 Project Name

 Status

 Location

 Project Type

 Project Start Date

 Project End Date

 Administrator

Select from the projects that you want to update and from the toolbar click Update. When the 
Confirmation window opens, review the message that is displayed in the Confirmation
window. 

Update Shell Templates with selected Activity Sheets

- If the Activity Sheet with the same name does not exist, it will be 
added.

- If the Activity Sheet exists with the same name, it will not be updated 
or replaced.

- Assigned WBS attributes to the Activities will be added to the Project 
WBS Sheet.

- If Project WBS Sheet does not exist, it will be added.

- Assigned OBS attributes to the WBS will be added to the OBS Sheet.

- If OBS Sheet does not exist, it will be added.

- Sheet permissions will be added.

- Users and Groups will be added if they do not exist.

- If Group is created, it will be empty.

- Custom calendars assigned to Activity Sheet will be added.

This will update selected shell templates and cannot be reverted. Do 
you want to continue?

Click Yes, if you want to update the selected shell templates, or click No, to cancel your 
update. 

If you click Yes, then the push job gets initiated and the History log will show the job details. 

The Activity Sheets setup will be added or replaced in the destination shell templates. 

All Other Shell Templates
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If you select this option, then a Confirmation window opens with the following message: 

Update Shell Templates with selected Activity Sheets

- If the Activity Sheet with the same name does not exist, it will be 
added.

- If the Activity Sheet exists with the same name, it will not be updated 
or replaced.

- Assigned WBS attributes to the Activities will be added to the Project 
WBS Sheet.

- If Project WBS Sheet does not exist, it will be added.

- Assigned OBS attributes to the WBS will be added to the OBS Sheet.

- If OBS Sheet does not exist, it will be added.

- Sheet permissions will be added.

- Users and Groups will be added if they do not exist.

- If Group is created, it will be empty.

- Custom calendars assigned to Activity Sheet will be added.

This will update selected shell templates and cannot be reverted. Do 
you want to continue?

Click Yes, if you want to update all of the shell templates, or click No, to cancel your update. 

History

If you click the History menu item, then the Update Shell Templates: History window 
opens. This window shows the details of the submitted update requests. This window has 
the following columns: 

 Requestor 

 Shell Templates 

 Submit Date 

 Start Date 

 End Date 

 Status 

The History log provides details of each job by showing the actions performed as a part of 
Activity Sheet push to the destination shell templates.  

In the case where in certain shell templates the job is not successful, the history details lists 
the shell templates where the update has failed and displays the reason for the failure. 

You can select an item in the list and click Open, from the toolbar, to see the details about 
that item. 

You have the option to click the Cancel Request option, from the toolbar, if the request is 
not in progress or has not been completed. 

Setting Up View Forms in Shell Attributes 

The shell details page (Details) displays the View Forms tab. To access the shell details page, 
go to Company Workspace > Admin mode > Company Sponsored Shells > shell type > shell 
instance > Menu options (three dots) > Details. 
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The View Forms tab is available in all shell types (single shell or multiple instance shell) details 
page, when there are View forms defined and deployed for that shell type. 

The View Forms tab is not available: 

 If the design does not have a View form. 

 For shell designs deployed prior to this upgrade. 

In the View Forms tab, click the add option (plus icon) to add the View forms (from a list of 
forms displayed in the Select View Forms window) that are associated with the shell. You, the 
administrator, can select multiple View forms to add. After adding the View forms, you can 

remove or change the forms sequence. You can use the gear menu (  ) to remove multiple 
View forms. 

After you add the View forms and click Add, the system opens the User and Group Picker
window which displays all active users or groups that are associated with the Shell. Multiple 
users and groups can be added to the viewers list. 

Click Done when finished. The Details page will split in two and the right side displays the 
Permissions Settings block along with the Add Viewers field. 

If you assign users and groups to a View form, the assigned users and groups can only see the 
General tab of the form. 

If the users or groups have permission to view multiple View forms, then they will see the View 
forms based on the sequence listed in the Details window, under the Form Name block. 

Click Done when finished. 

If a user or group has access to multiple View forms, then the user or group will see the first 
View form that they have access to, based on the sequence of the View forms listed. 

For example, if user 'U1' has access to View Forms VF01 and VF02 both, and when U1 views 
the General tab of the shell details, then the VF01 is displayed if the VF01 is the first View form 
in the sequence order of forms displayed. 

Dedicated Mailbox for Shells 

External emails are important communications that need to be included in shells. Such emails 
can come from project team members or from External Users who do not use Unifier. These 
email communications (and any attachments) can be collected in a central repository for the 
shell, called a Mailbox. After such emails reside in the shell's Mailbox, users can view them, 
forward them to appropriate members, flag them for review, and reply to them. In addition, these 
external emails can be linked to business process records. 

Note: External emails that have been blind carbon-copied (Bcc) are not 
collected by the Mailbox. 

When Unifier is installed on your system, a dedicated email address for your company is 
specified, and whenever a shell is created, Unifier assigns it a unique identifier. Unifier combines 
this email address and shell identifier to create the shell's Mailbox. 

Note: To prevent spam and virus attacks, you will need to create a list of 
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approved email addresses that will be accepted by the shell. For more 
information, see Creating an Approved Email List for Project/Shell 
Mailboxes in the Unifier General Administration Guide. 

When you create a shell, you can notify all shell participants, both within and outside of Unifier, 
of the shell's email address. For more information, see Create a Shell Manually (on page 57). 

User Permissions and Navigation 

Navigation from the Landing Page to a specific place in the sub-shell hierarchy requires 
permissions. Permissions can be: 

 Granted on an instance-by-instance basis 

 Pushed through shell templates 

 Users can be managed through groups or added individually to instances 

How to Set Up Gates 

Before you begin: Verify that the list of phases resides in the Phase data definition drop-down 
(pull-down) data set. This is the same list that is used when selecting a phase manually in the 
shell properties window. You can add or modify the default list as needed. This list makes the 
phases available for any shell instance or shell type template; for each shell or template, you 
select which of the phases to use. Create any business processes that you plan to use to drive 
gates conditions and phase completion. 

Step 1: Define Phases. For each shell instance or shell type template, you define the list of 
phases to include in the setup, choosing from the entire list in the Phase data set. 

Step 2: Define Gate Conditions. For each phase, define one or more gate conditions. A gate 
condition is a combination data element and trigger condition that enable transition to the next 
phase. 

Step 3: Schedule Gates runs. The gates run the validation of gate conditions. You can 
schedule runs automatically. This is optional. 

Step 4: Activate the Gates setup. 

Step 5: Define permissions. 

Notes: 

 If you create a shell by copying a shell template or an existing shell, 
any existing gates setup in the source shell is copied into the new 
shell, including the gates status. The gates phases are restarted at 
the first phase in the new shell, and the scheduled gates run is 
activated. 

 The DE of type Rich Text DE is not available to be added as a Gate 
Condition Element (Gates > Settings).  



Setting up Shells

171

Example of a Gates Setup and Conditions 

You will be setting up phases in gates to represent the actual phases of a shell. For the shell to 
advance from one phase to another, certain conditions must be met. This example will discuss 
phases, conditions, and using business processes in the context of the conditions to advance a 
shell from one phase to another. 

For example, phases for shell Zero could be: 

 Preliminary 

 Investigation 

 Definition 

 Measurement 

 Analysis 

 Start 

 Control 

Previously, you have set up two business processes to use in the conditions for your gates 
setup. These are: 

 Schedule: A single record business process that is updated manually by a shell manager by 
selecting check boxes for the various phases such as Definition Phase Complete? or 
Measurement Phase Complete? 

 Funding: a workflow business process that is automatically updated through the steps of the 
workflow. 

As the shell manager reviews the check boxes in the phases as represented in the Schedule 
business process, the gates runs keep reviewing the statuses of the check boxes. As they are 
checked off, the project advances to the next phase. 

The exception to this procedure is the transition from the Analysis phase to the Start phase. 
Additional approval is needed for funding in order for the project to advance from Analysis to 
Start. The Funding business process is included in the conditions for the Analysis phase. This 
business process must have the status Construction Approved and have a value of greater than 
zero for the Analysis phase to be exited and the Start phase entered for the project. 

Define the Phase List 

To view the phase list 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure > Data Definitions. 

3) Click Basic. 

4) Select the Phase data definition and click Open. The Modify Data Definitions window opens. 

5) Click the Data Set tab. The active phases on this list will be available for phase setup. 

6) Modify the list as needed. Any changes you make here will be reflected in new gates setups. 
Current setups will not be affected. 
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Create a Gates Setup 

You can create a gates setup in shell templates, and in individual shells. There can be one setup 
per shell instance. 

To create a gates setup 

1) Do one of the following: 

 To create the setup in a shell type template, go to the Company Workspace tab and 
switch to Admin mode. In the left Navigator, click Templates > Shells. Open the shell 
template. 

 To create the setup in a shell instance, go to the Company Workspace tab and switch to 
Admin mode. In the left Navigator, click Company Sponsored Shells. Open the shell 
instance. 

2) Choose Setup > Gates. The Gates Setup log opens. 

3) Click New. The gate setup is created automatically. Double-click the setup, or select from 
the list and click Open. The Gates Setup window opens. There are three tabs: General, 
Settings, Schedule. 

4) In the General tab, enter a Setup Name, which displays in the log, and an optional 
Description. At this point, Status is Inactive by default. 

5) In the Settings tab, define phases and gates conditions. 

6) In the Schedule tab, you can schedule regular gates. 

Delete a Gates Setup 

This section describes how to delete a Gates setup from a shell manually. 

Note: You can delete a Gates setup from a specific shell template but 
not from other Projects/Shells that have been created using the 
template. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells. 

3) Open the shell template. 

4) Click Setup > Gates. 

5) Select a Gates setup for deletion. 

6) Click Delete.  

7) When the prompt appears that asks you to confirm deletion, click Yes to delete the Gates 
setup. 

Add Phases to the Gates Setup (Settings Tab) 

Select which of the phases to use in the shell or shell template from the available phase list. You 
can reorder them as necessary for the shell instance or shell type template. 
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To add phases to the new gates setup 

1) Open the Gates Setup window and click the Settings tab. 

2) In the Phases pane, click the Add button. The Select Phases window opens, displaying the 
list of available phases. 

3) Select one or more phases to add to the list. To select multiple phases, hold down the CTRL
or SHIFT keys while selecting. 

4) Click OK. The phases appear in the Phases list. 

The order in which the phases appear on the list is the order they will be followed in the shell. 
The first phase on the list will be the first phase of the shell. 

Access Gate Configuration View 

To access the gate configuration view 

Select a phase. The gate configure view opens in the right pane. See the following table for 
more information about the gate configuration view. 

The Phase Gate Configuration section in the navigator lists the Phases for the current shell. 
The visual order of the Phases depends on the Order specified in the General tab. 

The Gates Conditions Elements section lets you define condition criteria per element. Gate 
Elements will be selected from all data sources and modules available in a particular shell (for 
the Sponsoring company). 

In this field Do this 

Start Date 

The Start date for a particular Phase can 
be manually set or auto populated from a 
Schedule Sheet by linking it to a particular 
activity or milestone (activity with zero 
duration and marked as milestone) where 
it will update dynamically based on the 
start date associated with this activity. If 
there are multiple Start dates, choose the 
Start date used to set Gantt Charts in 
Schedule Manager.  

The start date must fall within Shell date 
ranges. 

Planned Completion 

Can be manually set or auto populated 
from a Schedule Sheet by linking it to a 
particular activity or milestone (activity with 
zero duration and marked as milestone) 
where it will update dynamically based on 
the start date associated with this activity. 
If there are multiple End dates, choose the 
End date used to set Gantt Charts in 
Schedule Manager.  

Note: Dates are for reporting only. Phases 
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In this field Do this 

cannot be date driven. 

Advance to Next Phase... 

This check box enables automatic phase 
advancement. Select the check box if you 
want the shell to move automatically to the 
next phase after all Gate Elements for a 
particular Phase have been checked. 

Notify users on Phase Completion 

Lets you define users who receive phase 
completion notification. You can configure 
the body text in the notification (similar to 
the business process Setup on the End 
Step, where you can specify the message 
text content. 

Reevaluate conditions on every Gates run 

When selected, this check box specifies 
that processing always starts at the First 
phase during a scheduled Gates 
Run/Refresh. You might have to scroll 
down to see this check box. 

If the check box is not selected for a 
phase: 

 If the phase is currently incomplete, 
incomplete conditions are evaluated 
and completed conditions are skipped 

 If the phase is currently complete, 
phase processing is skipped 

If the check box is selected in a phase: 

 Every condition in that phase is 
reevaluated. Including conditions that 
were met 

 All conditions (except conditions that 
were marked as "ignore" manually) are 
marked as incomplete at the beginning 
of every Gates run and refresh. 

Saved Gates run (PDF) from prior runs 
persist. Processing will stop at a Phase 
where first un-met condition is 
encountered. By default this check box is 
deselected. 
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Configure Gate Elements 

To add a Gate Condition Element 

1) In the Gates Setup window, in the Gate Conditions Elements section, select a phase and 
click Add. The Data Type window opens. 

2) Select a Data Type from the drop down menu. 

3) Click OK. The Edit Gate Condition window opens. 

4) Complete the General tab: Enter a Name for the Gate Element. This can be the name of the 
data element or any descriptive name. This appears on the Gate Conditions Elements list. 
You can add an optional Description. 

5) Click Apply to save changes, or OK to save changes and exit the window. 

To define query and trigger conditions 

1) In the Edit Gate Condition window, click the Query tab. 

2) Under Query Conditions, click Add. The Query Condition window opens. 

3) Complete the Query tab: 

Data Element: Click the Select button. The Data Element Picker opens. The list is generated 
from the data type you chose in the General tab. If the data element is a picker, drop-down 
(pull-down), or radio button, the Value field will display the values entered in the data set tab 
of for the data definition associated with the data element. For a full list of data elements and 
data types, refer to the Unifier Data Reference Guide.

 Label: The label defaults to the data element name. You can enter a different label. 

 Condition: Define Gate Condition Element Condition. The condition options vary 
dynamically depending on the selected Data Element. The screen shots below list out the 
various options for different Data Element types. Examples include equals, does not 
equal. 

 Values: Specify value. The Values field varies dynamically depending on the selected 
Data Element and Condition. (For example, if the element is a text box, the condition 
might be Contains, and value might be one or more letters to search for. If the element is 
a drop-down (pull-down) or other data definition with a data set, you will select a value 
from the data set.) 

 Show results matching any condition (Instead of all): Select this check box if you 
have defined multiple query conditions, for which only one needs to be satisfied in order 
to advance to the next phase 

4) The Trigger Condition section operates similarly to the Query Conditions section, except 
you are able to create a formula for the desired condition. 

Change the Order of Phases 

To change the order of the phases in a gates setup 

Select a phase and click the Move Up or Move Down button. 
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Define Gates Runs Schedule (Schedule Tab) 

You can define a gates run schedule in the Gates Setup window, Schedule tab. This run 
evaluates gates conditions, and marks completed conditions as Complete. The update process 
can also be invoked manually in user mode. The scheduler engine is a background process. 

In this field: Do this: 

Enable Scheduled Gates Runs 

Select this check box to enable scheduled 
updating of Gate Elements. Deselecting 
this check box will disable the scheduler, 
and any scheduled future runs will be 
canceled immediately. 

The scheduled gates runs are disabled in 
the last phase provided all conditions are 
met, and the Enable Scheduled Gates 
Runs check box is automatically 
deselected. 

Frequency 
Choose Frequency of the Scheduled 
Gates Runs (Daily, weekly, monthly, 
quarterly, yearly) 

Range of Recurrence 
You can specify a date on which the Gate 
Runs will end, or no end date. 

Auto-email as PDF Attachment to Gates 
creator 

Select this check box to enable automatic 
emailing of the scheduled run results as a 
PDF attachment. The report displays the 
current status of each phase and gate 
condition. 

Activate or Deactivate a Gates Setup 

Activating a gates setup will enable the scheduled gates runs. After activation, if you must edit 
the gates setup, you will need to deactivate it first. To change the status of the gates setup, use 
the Status drop-down menu in the Gates Setup log. 

You can make edits while the setup is inactive, including: adding or removing phases; reordering 
phases; add, modify or remove conditions within a phase. 

Some notes about activating/deactivating gates setup: 

 Reactivating an active shell: If you temporarily deactivate a shell that is in process, and then 
reactivate it, the gates check will start over at the first phase. This is because the setup 
needs to check all phases for new phase additions or new gate conditions that may have 
been added. You can manually update the phases by clicking the Refresh button for gates in 
User mode. This will evaluate all phases starting from the first phase, even if the phase has 
been marked Complete, and mark the first phase as the current phase. 
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Note: This may trigger email notifications regarding gates advancement, as set up in the 
Settings tab (where the users who are notified are defined), and those users' email 
subscription settings (User Preferences). 

 While a gates setup is Inactive: No scheduled gates run will be done. To manually advance 
phases in User Mode Gates for the shell, the gates setup must be active. 

 View-Only and Inactive shells: If a shell has the View-Only or Inactive status, the gates setup 
is inactivated, and you must manually reactivate the setup. 

Set User Permissions for Gates 

To grant User Mode Gates permissions: 

In Access Control or Permissions window, navigate to User Mode Access > Projects/shells > 
Gates. The permissions are:  

 Change Phase: Allows the user to change gates phases. 

 Modify and Refresh: Allows the user to modify gates and refresh gates. 

 Refresh: Allows the user to refresh gates. 

 View: Allows the user to view gates. 

Editing Multiple Shells at once with Bulk Edit 

If you have a large number of shells that need similar edits, you can use bulk edit to update all of 
them at once. You can update a maximum of 200 records using bulk shell edit. The bulk edit 
must be defined in uDesigner, and you must have the Allow Bulk Edit permission set on the 
shells to use the bulk edit.  

The bulk edit function works only on fields from the action form (upper form) for the current step. 
It cannot be used to edit the following: 

 Auto-populated fields 

 Fields in a dynamic data set 

 Read-only fields 

 System-generated fields, such as record number, status, or due date 

Notes:

 An Integration interface must be created for Bulk Edit to work with 
Shells. 

 You can use bulk processing to update users in shells. For more 
information, see Managing Users in Bulk in the Unifier General 
Administration Guide. 
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To edit shells using bulk edit 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells. 

3) Open a shell type and select one or more shells, or perform a Find to search for a group of 
shells to work with. 

You can select the shells from the shell log or the Find log. 

4) From the Actions menu, select Bulk Edit. 

The Bulk Edit window displays. The fields displayed in this window depend on what was 
specified for the shell. 

The Bulk Edit form includes all editable fields for the shell. All system-generated elements 
and formula columns are automatically recalculated during the bulk edit for each record. 

5) Modify the Bulk Edit form as needed. 

6) Select the Update check box for the fields you want to update. 

The check box is automatically selected when you type into or modify a field. You can 
deselect it if you do not want to modify the field at this time. 

7) To launch the bulk update of the selected records, click Update. 

The Bulk Actions Status window opens after you click Update. This window lets you monitor 
the progress of the bulk update. 

Note: If the Record Status defined for any of the targeted shells been 
inactivated, an error is displayed that requires selection of an active 
Record Status to continue. 

8) Click OK after all records have processed. Click Cancel if you want to cancel the bulk 
update in progress. 

About Shell Dashboards 

Shell dashboards display project data in an at-a-glance format. You can control the dashboard 
appearance and content and make it specific to the shell with which you are working; however, 
shell dashboards cannot pull data from across shell hierarchies. For example, consider two 
anchor shells, which are seen as tabs, one is labeled "Capital Projects," and one is labeled 
"Facilities." The Capital Projects dashboard can display data from all levels of the Capital 
Projects hierarchy; however, it cannot display Facilities data because Facilities is the root of a 
separate, independent hierarchy. 

Two types of dashboards are available in project shells: 

1) My Dashboard: All shells have a personal dashboard that a user can define if he or she has 
Setup permission. A user can configure My Dashboard in User mode using the Edit 
Dashboard window. Users can select My Dashboard from the View Dashboard
(drop-down list) on each shell. 
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2) Shell dashboards: Shell dashboards allow users to view shell and subordinate shell data. 
This differs from My Dashboard in that a user cannot share his or her personalized 
dashboard. Administrators can create multiple shell dashboards per shell and push them via 
templates. Users can select this type of dashboard to view from the View Dashboard
(drop-down list) on each shell. These dashboards are maintained at the shell level and are 
available to any user to view (but not edit) provided the user has permissions. 

Each shell dashboard has at least one tab and can have up to five tabs. The default tab name is 
Summary, which you can change. The default shell dashboard layout contains these four blocks: 

 Image: Displays the image your company administrator uploaded for the shell. 

 In the dashboards, if there are multiple images, the system displays all the images as 
rolling images. 

 When a shell has multiple images, the system uses the first image from the list to print 
the shell image through custom prints and reports. 

 Items Requiring Your Attention: Contains items that are generally listed on the Home 
workspace, such as tasks and messages. 

 Details: Lists shell details, including shell number, shell name, administrator, and other 
details. 

 Links: List of links configured for the shell by your company administrator. 

On each tab, you can select a different layout to which you can add blocks of these types: 

 Standard: Use this selection to view project data from, for example, business process, 
manager, users, and active tasks. 

 Portlet: Use this selection to view an external URL, such as a web cam, a frequently visited 
website, or Analytics application. 

To view Analytics in the Portlet block, you must perform additional and required 
configurations in OBIEE in order to allow the OBI analysis to render properly. Go to: 

 Oracle Help Center: http://docs.oracle.com/en/ 

 Middleware > Middleware Documentation 

 Oracle Fusion Middleware > Oracle Fusion Middleware Documentation 

 Products > Oracle Business Intelligence Enterprise Edition 

 Oracle Business Intelligence Enterprise Edition [latest edition] > Books 

 Administration > System Administrator's Guide for Oracle Business Intelligence 
Enterprise Edition 

 Advanced Configuration Reference > Making Advanced Configuration Changes for 
Presentation Services > Protecting Pages in Oracle BI EE from Attack 

 Drilldown: Use this selection to slice and dice project-shell data. 

 Custom: Use this selection to view data from the current shell, subordinate shells, or both 
(cannot cross hierarchies). 

 Analytics: Use this selection to access the link to the Analytics application. 
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Setting Shell Instance Dashboard Permissions 

To set shell instance dashboard permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, expand the User Administration grouping node and click Access 
Control. 

3) On the right pane, select Administration Mode Access > Permissions for Projects/Shells 
> Setup > Dashboards. 

4) Set the permissions as needed: 

 Setup: Administrators can create a shell instance dashboard. 

Creating a Shell Dashboard in a Template 

You can create dashboards in shell templates and push them to shells. 

To create a dashboard in a shell template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell name] > [project shell template] > 
Setup > Dashboards. The Dashboards log opens. 

3) Click Create. 

4) Enter the dashboard name and an optional description. The dashboard name must be 
unique within the shell. 

5) Click Save. The dashboard is listed in the log. 

6) Select the dashboard in the log and click Open from the gear menu ( ). The default view 
of the shell dashboard opens. 

Notes: You might not see data in parts of the dashboard if you do not 
have specific permissions to access data cubes. 

You can edit a dashboard in an established project shell. For details, refer to the Unifier General 
User Guide. 

Copy a Shell Dashboard 

You can create shell dashboards by copying and modifying existing dashboards. Copying a shell 
dashboard does not copy the permissions associated with the dashboard, but will copy all other 
dashboard information. 

To copy a shell dashboard 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell name] > [project shell 
name] > Setup > Dashboards. The Dashboards log opens. 

3) Select a shell dashboard. 
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4) Open the gear menu (  ) and click Copy. 

5) Enter the name of the new dashboard and an optional description. 

6) Click Save. The dashboard is listed in the log. 

7) Select the dashboard in the log, open the gear menu and click Open. The shell dashboard 
editor opens. 

8) Modify the new dashboard as needed and Save. 

Modify Shell Instance Dashboard Properties 

To modify shell instance dashboard properties 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell type] > [shell instance] > 
Setup > Dashboards. The Dashboards log opens. 

3) Select a shell instance dashboard. 

4) In the right pane, click the Properties tab. 

5) Modify the dashboard name or description as needed. 

6) Click Save. 

Delete a Shell Instance Dashboard 

To delete a shell instance dashboard 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell type] > [shell instance] > 
Setup > Dashboards. The Dashboards log opens. 

3) Select a shell instance dashboard and open the gear menu ( ). 

4) Click Delete. 

Find a Shell Instance Dashboard 

To find a shell instance dashboard 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell type] > [shell instance] > 
Setup > Dashboards. The Dashboards log opens. 

3) Use the Find on Page button to filter the log based on column values. 

Set User or Group Permission for a Shell Instance Dashboard 

To set user or group permission for a shell instance dashboard 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [shell type] > [shell instance] > 
Setup > Dashboards. The Dashboards log opens. 
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3) Select a shell instance dashboard. 

4) In the right pane, click the Permissions tab. 

5) Add users or groups as needed. Select the View permission. 

6) Click Save to save or Cancel to exit. 

Set a Default Shell Dashboard 

To set a shell instance dashboard as the default dashboard for the shell 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Company Sponsored Shells > [shell type] > [shell instance] > Setup > 
Dashboards in the left Navigator. The Dashboards log opens. 

3) Select a shell instance dashboard. 

4) From the Gear menu, select Mark as Default.  

5) Click Yes to confirm. The Default column of the log will now display Yes for the default 
dashboard. Only one dashboard can be set as the default dashboard.  

To unmark a shell as default, click the Gear menu for the default dashboard and select Unmark 
Default.  

Migrating Projects (Standard) to CBS Shells 

You can migrate one or multiple standard projects (Projects (Standard)) of any status (Active, 
On-Hold, View-Only, or Inactive) to CBS shell types that you specify. After migration, the new 
CBS shell is created in the shell hierarchy in the location you specify, and the standard project is 
no longer listed in the project log. All the data that existed under the standard project can then 
be accessed from the newly-created CBS shell. 

Note: When you migrate a standard project to a CBS shell, you cannot 
undo the migration and return the shell to the standard project form. The 
migration cannot be reversed, so be sure that you want to perform the 
project-to-shell migration. 

After you migrate standard projects to CBS shells, you can use the features that shells offer, 
such as: 

 Hierarchical distribution, visualization and navigation of capital projects when organized 
under shell hierarchies based on business needs 

 Configurable dashboards 

 Roll up of cost data across the shell hierarchy 

Migrating Projects (Standard) Limitations 

The following are some migration limitations for you to consider: 

 The shell type must be a CBS shell. You cannot migrate standard projects to generic shells, 
only to CBS shells. 
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 Shell name is limited to 128 characters, and shell description is limited to 250 characters. 
However, standard project name is limited to 250 characters, and the project description is 
limited to 2000 characters. For the migration from project to CBS shell to be successful, you 
must modify the project name and description to be within the limits for these fields that exist 
for the shells (128 characters for a shell name, and 250 characters for a shell description). 

 The standard project name cannot contain any special characters, such as: 

/\:*?"<>| 

 You cannot migrate a standard project to a single instance (top-level) shell. You can only 
migrate to multiple-instance shells. 

 Even if the destination CBS shell type has auto-numbering set up, the migration cannot 
incorporate the new shell into the shell auto-numbering; instead, it copies the project number 
while creating the shell. The new shell is identified by the project number of the original 
project. 

 You will have to set up a new configurable shell dashboard for the new shell that is created 
by the migration. Any existing project summary set up does not migrate to the new shell. 

 If any business processes, planning items, assets, or configurable managers in the original 
project use project pickers, you will have to re-create the link between these objects and the 
new shell. 

 Migration from a standard project to a CBS shell cannot be reversed. After the migration is 
complete, the standard project is converted to a CBS shell, and the information from that 
project resides in the newly-created CBS shell. 

Migrating Projects (Standard) Considerations 

Before you migrate: 

 Be sure that you have Integration defined for the CBS shells you plan to use for migration. 

 Examine the shell hierarchy of your CBS shells and determine the location for the new 
migrated shells. You can migrate several projects at once into a shell type, creating a new 
shell instance under that shell type for each migrated project. 

 Examine the setups for the original projects and also for the destination shells, and think 
about the mapping from the project to the shell. You might have to add data elements on the 
project side or the shell side to ensure that the data you need is migrated correctly and 
completely. For example, the shell name is limited to 128 characters, and shell description is 
limited to 250 characters. However, standard project name is limited to 250 characters, and 
the project description is limited to 2000 characters. For the migration from project to CBS 
shell to be successful, you must modify the project name and description to be within the 
limits for these fields that exist for the shells (128 characters for a shell name, and 250 
characters for a shell description). 

 To ensure that the migration is successful and yields the desired result, test your migration in 
your Test environment before implementing it in your Production environment. 

 You can use user-defined reports to gather data regarding which projects to migrate and the 
location they should occupy in the shell hierarchy. 

 Understand that migration cannot be undone; when you migrate a project to a CBS shell, 
you cannot go back to that project. The project is converted completely to a CBS shell when 
the migration completes successfully. 
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Migrating Projects (Standard): Mapping of Project DEs to Shell DEs 

The following table shows the automatic mapping of original project data elements to destination 
CBS shell data elements. These data elements define the fields shown on the project or shell 
setup window tabs. This mapping occurs automatically during the migration. When a standard 
project is migrated to a CBS shell, the project's data element values are automatically populated 
in the equivalent shell data element as listed in the table: 

Standard project data 
element 

CBS shell data element 
Comments on action during 
migration 

General tab of CBS shell 

Project Number Shell Number 
One-to-one mapping 
occurs. 

Project Name Shell Name 
One-to-one mapping 
occurs. 

Description Description 
One-to-one mapping 
occurs. 

Administrator Administrator 
One-to-one mapping 
occurs. 

Project Status Shell Status 
One-to-one mapping 
occurs. 

Auto-update Status Setup Auto-update Status Setup 

Optional on the Shell 
Attribute form; if not present 
on the Shell form, is ignored 
during migration. 

Currency tab of CBS shell 

Currency Name Currency Name 
One-to-one mapping occurs 
for all defined currencies. 

Rate Rate 
One-to-one mapping occurs 
for all defined currencies. 

Type Type 
One-to-one mapping occurs 
for all defined currencies. 

Hedge Rate Hedge Rate 
One-to-one mapping occurs 
for all defined currencies. 

Hedge Amount Hedge Amount 
One-to-one mapping occurs 
for all defined currencies. 

Default Currency Default Currency 
One-to-one mapping 
occurs. 
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Options tab of CBS shell 

Project Image Image 
One-to-one mapping 
occurs. 

Project Phase Phase 
One-to-one mapping 
occurs. 

Links tab of CBS shell 

Name Name 
One-to-one mapping occurs 
for all defined links. 

URL URL 
One-to-one mapping occurs 
for all defined links. 

Migrating Projects (Standard) to shells 

Before you begin: Make sure that you review the limitations, considerations, and mapping 
information described in the preceding topics. 

Step 1: Export the migration template. Export the CSV template. This template will vary 
depending on the data elements included in the configuration of a particular shell type. This 
template contains the fields and format that the system needs to migrate the standard projects to 
CBS shells. See Exporting Migration Template (on page 185). 

Step 2: Modify the exported CSV template. Be sure that you have the correct project 
information ready to enter into the template. After you convert a standard project into a CBS 
shell, you cannot reverse the conversion. See Modifying Exported CSV Template (on page 
186). 

Step 3: Initiate migration. Import the completed CSV file. See Initiating Migration of 
Standard Projects to CBS Shells (on page 187). 

Step 4: View migration history. See Viewing Migration History (on page 187). 

Step 5: Test for shell creation. See Testing for CBS Shell Creation (on page 188). 

You export the template, and then modify it and import it. You will export the template from a 
selected CBS shell, and then import the modified template back into the same CBS shell to 
complete the migration. 

Exporting Migration Template 

To export the migration template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [CBS shell type]. 

Note: The shell type must be for a CBS shell. You cannot migrate 
standard projects to generic shells, only to CBS shells. You cannot 
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migrate a standard project to a single instance (top level) shell, only 
multiple-instance shells. 

3) From the Actions menu in the shell type log, select Export Template > Project Migration 
Template. 

The template, which is downloaded to your computers, will be specific to the shell type of the 
log from which you exported the template. 

Modifying Exported CSV Template 

Be sure that you have the correct project information ready to enter into the template. After you 
convert a standard project into a CBS shell, you cannot reverse the conversion. 

Note: You can use user-defined reports to gather data regarding which 
projects to migrate and where they should be in the shell hierarchy. 

To modify the template 

1) Open and edit the CSV template, per the template content, and the description of the 
template content in this section. 

The content of the migration template will vary depending on the shell type into which you 
choose to migrate. 

The exported template is organized in three sections: 

 Instructions: This section at the top of the template explains how to fill in the template to 
initiate the migration. Do not modify this text. 

 Mapping: This section maps the available standard project attributes with the 
user-defined CBS shell attributes. Use this section to create mapping for data elements 
that you have added in addition to the data elements listed in the table in Migrating 
Projects (Standard): Mapping of Project DEs to Shell DEs (on page 184). The 
Mapping section lists all the project attributes which are not automatically mapped.  If 
you use custom project attributes, these attributes are listed and mapped in this 
section.  The values in this section are overwritten by any literal values that you add in 
the Project section. 

 Project: This section lists the Project Number and Location, and the use-defined CBS 
shell attributes as column headings. Project Number and Location are mandatory; the 
other columns are not, and are based on the attributes listed in the Mapping section. This 
list does not include the automatically-mapped shell attributes such as Shell Name or 
Shell Number. Add a row for each project you want to migrate, and enter the Project 
Number and the Location. The location should be delimited with /. For example: /Capital 
Project/Buildings/Tool Sheds. Add the literal values that are to be changed during the 
migration. 

Note: Projects are identified by the Project Number for migration. Be 
sure that you enter the correct project numbers for standard projects you 
want to migrate to CBS shells. 

2) Save the template CSV file. 
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Initiating Migration of Standard Projects to CBS Shells 

You can migrate several projects at once into a shell type, creating a new shell instance under 
that shell type for each migrated project. Before you initiate the migration, ensure that you have 
the Create permission on the destination shell type. You export the template from a selected 
CBS shell, and then import the modified template back into the same CBS shell to complete the 
migration. 

Note: You cannot undo the migration of standard projects to CBS shells 
after the migration completes successfully. Verify that you have 
completed the CSV migration template correctly, especially in terms of 
the Project Number. 

To initiate migration 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [CBS shell type]. 

3) From the Actions menu in the shell type log, select Import > Migrate Projects into Shells. 

4) Browse for the CSV file and click OK. 

This imports the migration template and performs validations on the data. The migration is a 
background process. Each project listed in the CSV file is migrated into a CBS shell based 
on the mapping and values provided in the CSV. Project migration is either successful or not. 
Validation is performed before migration, and if there are any errors, a project is not 
migrated. Errors can include incorrect mapping or invalid format of the project rows (including 
changing column order or adding or removing columns). 

Viewing Migration History 

You can view the status of each submitted migration by using the Migration History. 

To view migration history 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells > [CBS shell type]. 

3) From the Actions menu in the shell type log, select Import > Migration History. 

Each submitted migration is listed in Migration History with one of these statuses: 

 Not Started: The migration process has not started. 

 In Progress: The migration process is in progress. 

 Completed Successfully: The migration of all standard projects completed, and the 
corresponding CBS shells have been created. 

 Completed with Errors: The migration of standard projects has completed, however, 
there were some errors that prevented the migration of some of the projects to CBS 
shells. 

Potential migration errors: 

 Location entered is invalid. This error can occur if the location does not exist or is inactive 
in the shell hierarchy. 
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 Cannot create an instance of the shell type under the location entered; does not exist in 
the shell hierarchy. 

 Project number might be the same as the number of an existing shell in the hierarchy. 
Shell numbers must be unique. 

 String values are entered incorrectly. Enter the labels for sting values. 

 The standard project name is limited to 250 characters, and the project description is 
limited to 2000 characters. For the migration from project to CBS shell to be successful, 
you must modify the project name and description to be within the limits for these fields 
that exist for the shells (128 characters for a shell name, and 250 characters for a shell 
description). Any error can result if the project name or project description are longer than 
the character limits for the shell name and shell description. 

4) If any of the projects did not migrate due to errors, you can view the CSV with the rows that 
have errors by clicking the Completed with Errors status hyperlink. 

This link allows you to download the CSV containing any errors. This file is in the same 
format as the submitted CSV, with all mapping information retained. However, in the Project 
section, only the rows that have errors in them are shown with an additional column added 
that contains error comments. You can use this CSV file to review the errors and then 
re-import the file after you correct the errors. 

5) Click Close to close the Project Migration History window. 

Testing for CBS Shell Creation 

Ensure that your new CBS shell is created correctly and contains the attributes that you expect: 

 The shell instance should be accessible in Administrator (Admin) and User mode(for Unifier 
and Unifier Mobile under the parent shell it was migrated to. 

 Users should be able to navigate to the business process and other manager data under the 
new CBS shell. 

 Shell creation will trigger email notification. 

 User/groups membership should remain same as on the original standard project. 

 All the auto-population, reverse auto-population, linked elements, and other settings should 
work as they did on the original standard project. 
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Setting up Automatic Update of Shell Status 

At the Company level, you can define the setup of the automatic update of project statuses of 
active projects based on triggering conditions which are defined using various data sources as 
parameters. For example: 

 A selected activity on the schedule sheet is in the Completed status 

 A single-record business process record is set to a specified status 

 A business process workflow reaches a specified status 

Depending on the setup and the conditions that are set, the status of the shell can change from 
Active to a non-active status (On-Hold, View-Only, or Inactive). You can define multiple setups 
for each shell. After you define these setups, they can be used on shell instances, or on 
templates to enable the automatic update of shell status. 

The data sources that you use in the triggering conditions can be either from shell level or from 
the Company level. These data sources can be business processes, sheets, or attribute forms. 
You can define the frequency at which the system evaluates the conditions to see if a particular 
active shell should change its status, and you can define a list of users or groups to be notified 
when the shell status is changed. The highest frequency is daily. 

This automatic update of shell status can be useful for users that have a large number of shells 
and want many of these shells to change their status based on certain triggering conditions, and 
thus the users do not have to search for and modify these shells manually. For example, you 
can define a setup that contains a triggering condition that changes the status of an active shell 
to "On-Hold" if the shell funds consumption exceeds the funds appropriated for that shell. This 
allows the shell manager to review the shell and take appropriate action. If, in this case, the shell 
manager is able to get additional funding for the shell, the Administrator can change the shell 
status back to Active to restart the shell activities. 

Note: An automatic shell status update can change the status of a shell 
from Active to inactive. If you want the inactive shell status to revert to 
Active, you must activate the shell manually. 

Step 1: Create setups - general information. 

Step 2: Verify the order of shell statuses. 

Step 3: Define shell status triggering conditions. 

Step 4: Define the schedule for automatic update of shell status. 

Step 5: Activate the automatic update of shell status. 

Step 6: Define permissions. 
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Create an Automatic Shell Status Update Setup 

Multiple setups can be defined at the company level and then used to configure individual shells. 

Note: You must have imported a shell attribute form that contains the 
uuu_au_setup_picker data element to be able to set up the automatic 
update of shell status. 

To create a shell status update setup 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Company Workspace > Auto-update Status Setup. The Auto-Update Status Setup 
log opens. 

3) Click New. The Auto-update Status Setup window opens. There are three tabs: General, 
Settings, Schedule. 

4) In the General tab, enter a Setup Name, which displays in the log, and an optional 
Description. 

5) In the Settings tab, define the order of the non-active statuses and the status change query 
and trigger conditions. For details, see Choose the Order of Non-Active Statuses 
(Settings Tab) (on page 190) and Define Status Change Query and Trigger Conditions 
(Settings Tab) (on page 191). 

6) In the Schedule tab, you can schedule the shell status update. See Define Shell Status 
Update Schedule (Schedule Tab) (on page 192). 

7) After you have defined the setup, you must activate it to be able to apply it to a shell. See 
Activate or Deactivate an Auto-Update Status Setup (on page 192). 

Note: You must deactivate a setup to be able to modify it. 

Choose the Order of Non-Active Statuses (Settings Tab) 

By default the order of the listed statuses is On-Hold, View-Only, and Inactive. These are listed 
on the left side of the Settings tab in the Status pane. You can change the order using the 
Move Up or Move Down buttons. You can change the order of the non-active statuses. The 
order of the statuses is significant because the triggering conditions for the statuses are 
evaluated in the order in which they are listed on this tab, with the verification of the triggering 
conditions occurring for each condition listed in turn. 
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For example, if the conditions for the first listed status are not met, then the conditions for the 
next listed status are evaluated. If the conditions for that status are not met, then the triggering 
conditions for the third status conditions are evaluated. As soon as the first match occurs, the 
system will automatically change the shell status and does not perform further evaluation. 

To reorder non-active shell statuses 

1) Open the Auto-update Status Setup window and click the Settings tab. 

2) In the Status pane, select the status you want to move. 

3) Click the Move Up or Move Down button to reposition the selected status. 

4) Click Apply to save changes, or OK to save changes and exit the window. 

Define Status Change Query and Trigger Conditions (Settings Tab) 

The Conditions Elements section lets you define condition criteria per element. Elements can 
be selected from all data sources and modules available at the Company level. 

In this field: Do this: 

Notify users and groups on Status change 
Lets you define the users and groups who 
will receive status change notification. 

Email content 

Enter the content of the email you want to 
send to notified users and groups. This 
content appears in the Additional 
Information section of the email. 

To define query and trigger conditions 

1) Under Conditions Elements, click Add. 

2) Select a Data Type, and click OK. The Query Condition window opens. 

3) Complete the General tab by entering a name for the query and a brief description. The 
Data type and Element is auto-populated from the selection you make on the Query tab. 

4) Click the Query tab. 

5) Click Add. 

6) Complete the Query tab: 

 Data Element: Click the Select button. The Data Element Picker opens. The list is 
generated from the data type you chose in the General tab. If the data element is a 
picker, drop-down (pull-down), or radio button, the Value field will display the values 
entered in the data set tab of for the data definition associated with the data element. For 
a full list of data elements and data types, refer to the Unifier Data Reference Guide. 

 Label: The label defaults to the data element name. You can enter a different label. 

 Condition: Define Gate Condition Element Condition. The condition options vary 
dynamically depending on the selected Data Element. The screen shots below list out the 
various options for different Data Element types. Examples include equals, does not 
equal. 
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 Values: Specify value. The Values field varies dynamically depending on the selected 
Data Element and Condition. (For example, if the element is a text box, the condition 
might be Contains, and value might be one or more letters to search for. If the element is 
a drop-down (pull-down) or other data definition with a data set, you will select a value 
from the data set.) 

7) Select the trigger conditions. 

8) Click OK. 

Define Shell Status Update Schedule (Schedule Tab) 

You can define a schedule to check the conditions for the automatic update in the Auto-update 
Status Setup window, Schedule tab. 

The maximum frequency that the system will verify whether triggering conditions are met is daily. 
If you have a need for greater frequency of verification, you must monitor the shell with the shell 
manager and then change the shell status manually as needed. For example, if the triggering 
condition verification is performed in the morning, and the shell funds are being spent during the 
course of the day, the shell could exceed its budget before the condition verification occurs the 
next morning, and the shell status is automatically changed. 

In this field: Do this: 

Enable Scheduled Runs 

Select this check box to enable scheduled 
evaluating of the automatic update status. 
Deselecting this check box will disable the 
scheduler, and any scheduled future runs 
will be canceled immediately. 

The scheduled evaluation is disabled for 
the last status in the list, provided all 
conditions are met, and the Enable 
Scheduled Runs check box is 
automatically deselected. 

Frequency 
Choose Frequency of the Scheduled Runs 
(Daily, weekly, monthly, quarterly, yearly) 

Range of Recurrence 
You can specify a date on which the 
Scheduled Runs will end, or no end date. 

Activate or Deactivate an Auto-Update Status Setup 

You must activate a setup in order to be able to apply it to a shell. 
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Note: You must deactivate a setup to be able to modify it. 

To activate or deactivate a shell status update setup 

1) To activate or deactivate a new setup to use in shells, go to the Company Workspace tab 
and switch to Admin mode. 

2) Click Company Workspace > Auto-update Status Setup. The Auto-Update Status Setup 
log opens. 

3) Select a setup in the log. 

4) Click the Status button. You can choose Active or Inactive. 

Set Permissions for Automatic Update of Shell Status 

To set permissions for automatic status update: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, expand the User Administration grouping node and click Access 
Control. 

3) On the right pane, select Administration Mode Access > Company Workspace > 
Auto-update Status Setup. The permissions are: 

 Create: Allows the creation of new auto-update status setups, edit existing auto-update 
status setups and activate or deactivate auto-update status setups. 

 Modify:  Allows the edit of existing auto-update status setups and activate or deactivate 
auto-update status setups. This permission excludes the ability to create an auto-update 
status setup. 

 View: Allows viewing of existing auto-update status setups. 
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Setting up Data Structure Setup Node 

This section explains how to set up the information in the Data Structure Setup grouping node 
which includes: 

System Modules

Functionality is loaded into the system through various modules (grouping nodes and functional 
nodes). 

Data Cube Definitions

A data cube definition is a query tool you can use to extract data and display it on dashboards. 

Data Definitions

Data definitions describe how data is entered and stored. The definition consists of: 

 The data type (whether it is an alphabetical string or a number), 

 The data size (in number of characters for strings), and 

 The input method (from a text box, drop-down [pull-down] menu, radio button, or check box). 

You must create data definitions before you specify the data elements for forms. A data 
definition can belong to one of the following categories: 

 Basic: Predefined or user-defined Data Definitions that contain all Data Definitions except 
the Cost Code definitions. 

 For the SYS User Date Format Data Definition, the data set supports the 24-hour time 
format. In the User Preferences form, under the Regions tab, the field Date Format uses 
SYS User Date Format Data Definition. 

 Cost Codes: Displays the type of cost code (fields that define the structure of the Cost 
Codes) specified in uDesigner for the project. The type of cost code available for 
Projects/Shells is CBS. 

 Data Picker: Data pickers work with business processes logs and can be used to fetch items 
from across multiple shells and configurable managers that function across a shell hierarchy. 
The purpose of a Data Picker is to make it easier for users to choose records: 

 From a business process log 

 From a class in a configurable manager that operates across shells 

 For auto-creation across shells 

A data picker log, when defined accordingly, can contain navigation structure that makes 
it easier for users to choose records to work with. 

In operation, a data picker navigates to a specific business process, shell, or configurable 
manager and then extracts the records to display on the data picker list (by using 
pre-defined Query conditions that were included on the data picker). 

 Line Item Data Picker: This is a system-defined Basic data definition. 
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Data Elements

A Data Element is a field, and it is defined by using a Data Definition. A Data Element consists of 
a name and label. The forms that the users see are filled by data elements. A data element can 
be: 

 A text box, where the user types in information 

 A drop-down (pull-down) menu of choices (also known as a picker), such as dates or names 

 A radio button, where the user must select one of the options presented 

 A check box, where the user has the option of choosing something or not 

Data Views

Provides a view of data obtained via SQL query. It allows access to all Unifier database tables in 
a company registry (registry dependency ensures data security). Data Views enable 
administrators to design and deploy custom reports, create user-defined reports (UDRs), and 
utilize data as a source for Data Cube Definitions in dashboards. 

Dynamic Data Sets

A dynamic data set is comprised of a "set" of data elements where one data element, known as 
Master Data Element, controls the values and behavior of other data elements in the set. 

Reports

The System and Custom Logs report modules are loaded by the Site Administrator. 

Statuses

Statuses are created in the Data Structure Setup node and indicate the position of an asset, line 
item, record, and tag at any point in the business process, such as “approved,” “pending,” or 
“closed.” The status is what drives the workflow from one step to the next. 

 Assets Statuses: An asset status controls which assets are displayed on an Asset class 
sheet, instead of impacting the disposition of a business process or line item like other 
statuses. 

 Line Item Statuses: A line item status is the status of the line item that belongs to a 
business process record. 

 Record Statuses: At each transaction, the user must apply a status to the record. Each 
business process produces at least one, and sometimes many, transaction records during its 
workflow. 

ER Views

Provides a tabular view of Data Elements and Data Definitions used in modules. 
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Working with System and Configurable Modules 

Functionality is loaded into the system through various modules. For example, the Cost Manager 
and Schedule Manager are system modules that provide cost and scheduling functionality. Also, 
your system might contain various configurable modules created in uDesigner. 

Some modules can be customized with "custom attributes," which are customized data fields, 
described later in this section. 

View Available System and Configurable modules 

To view the System Modules log: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > System Modules. 

The Modules log opens, showing all the modules and functions that have been loaded into 
your environment. 

View Custom Attributes for the Project/Shell Sponsorship Module 

You can view custom attributes that were assigned to standard projects that were previously 
deployed. 

To view custom attributes 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > System Modules. 

3) In the Modules log, double-click Project/Shell Sponsorship. 

4) Use the Custom Attributes window to view information such as the Name and Status. 

5) When you are done, click Close. 

Working with Data Definitions 

Data definitions define the data type and input type of a data element. Data elements are 
created from data definitions. The following lists the types of data definitions: 

 Basic

 Cost Codes

 Data Picker
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About Data Definition Properties 

Data definitions can be of the following Data Types: 

 String: Any alphanumeric character or special character like * or # 

 Integer: A non-decimal number. Can be used for drop-down (pull-down) menus, radio 
buttons, or check box fields 

 Date: For date fields 

 Float: This is applicable to currency amounts only 

 Input: This determines how data is entered or displayed in the field 

This input method: Does this: 

Check box 
Provides an option that the user can select 
("check") or not. "Not checked" is the 
default value. 

Multi-line text area 
Use this element for multiple text lines for 
entries up to 4000 characters long, such 
as descriptions or remarks. 

Multi-select Input 
Lets the user make multiple selections 
from a list. 

Picker 

Lets users choose from lists of items. 
Pickers are system-defined and cannot be 
created in Unifier. The system has a 
number of pre-defined pickers. 

A Picker can be added to a BP to lets 
users cross-reference another record. 

Pickers include, but not limited to: 

 BP Picker 

 BPO Picker 

 User Picker 

 Company Picker 

 Line Item Picker 

 SOV Picker 

 Fund Picker 

 Asset Picker 

 Project Picker Shell Picker 

Pull-down menu 
Provides a list of items the user can 
choose from but cannot change (for 
example, a date picker). 

Radio buttons Use where two values are possible and 
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This input method: Does this: 

one must be selected. 

Text box 
A text box is usually used for smaller text 
(1 to 64 characters), but could be longer. 

Dynamic Data Set 

A dynamic data set allows one data 
element on the form to control both values 
and behavior of other data elements on the 
same form. 

(In this example, choosing Yes in the 
Single Project field activated the Project 
Picker field below it.) 

To prevent the Upper Form or Detail form of any BP, for a field with DD set as Integer data type 
with input-type pull-down menu (option value for DE of type Integer) from displaying the field 
(and the field label) in the BP record, ensure that the value of 1, or above, is assigned to the DD 
set as Integer data type with input-type pull-down menu (option value for DE of type Integer) to 
that field. Assigning the value of zero will result in the field (and the field label) to be displayed in 
the BP record, when the user does not enter a value in such fields during runtime. 

View Basic Data Definitions 

To access Basic Data Definitions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Definitions > Basic. The Basic 
Data Definitions log opens. The system-generated data definitions are listed as Company or 
System in the Category field. 

Field Description 

Name 

Descriptive name for the data definition. 
This is the database name, and accepts 
alphanumeric characters, spaces, - (dash) 
and _ (underline). 

Category 
General: Defaults to Company 

Cost Code: Defaults to CBS Code 

Data Type 

String or Integer 

String: Any alphanumeric character or 
special character like * or # 

Integer: Non-decimal numbers 

If a Data Definition (DD) with the Data 
Type = Integer or Input Type - Pull-down 
Menu, and the Data Set value of 0 (zero), 
then the value of 0 (zero) overrides the 
default value. If a Data Element (DE) 
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Field Description 

exists for such DD, and the DE is used as 
the master DE in a Data Definition 
Structure (DDS), then the DDS will not 
override the DE value when the DD is 
created, if the default value of the master 
DE is set to a field that has the value of 0 
(zero). 

Data Size 

This field is available for text entry fields. 
Displays the number of characters that the 
data definition will accept. 

Notes: 

 The maximum limit for the Data Size is 
determined by the database being 
used with your installation. Check with 
your Site Administrator for the actual 
maximum allowable characters in a 
field. 

 Ensure that the data you enter is within 
the limit set in Unifier; otherwise, the 
system will ask you to shorten the 
number of the characters that you had 
entered (message: Data entered 
exceeds the allowed space limit for this 
field in the database. You must remove 
few characters before submitting.). 
This is mainly applicable to multi-byte 
character languages such as 
Japanese, Korean, and Chinese. 

Input Type 

Select one of the options. This determines 
how data is entered or displayed in the 
field: 

 Pull-down Menu: users can choose a 
value from a selection list 

 Text Box: for short text entries 

 Multi-line Text Area: for longer text 
entries 

 Radio Buttons: users select one of 
multiple options presented 

 Checkbox: users have the option of 
selecting or not 

 Multi-select Input: users can choose 
one or more values from a selection list

The following is applicable when deleting 
or otherwise modifying the options in the 
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Field Description 

data definition design process, after the 
system has deployed the design and the 
data has been saved:  

 When you modify or delete an option in 
the data structure design, the system 
will not modify the existing record data. 
Consequently, within the BP logs, log 
preview panes, and UDRs, the system 
will display the option with the value 
that was originally saved in the record 
form, as read-only. 

 When you delete an option, the value 
will be displayed but not the label.  

 When you rename an option, or when 
you add the option later with the same 
value, the existing value will be 
associated with a different label, but in 
forms only the active options are 
available and only the labels (not 
values) will be visible.  

Example 

The value for the Priority drop-down field 
is set as High in the record details of a 
selected existing record. 

Based on an enhancement, you must 
remove this value (High) from the list of 
originally applicable values (High, 
Medium, Low). 

You proceed and remove High from the 
list of values in the record form and save 
your changes: Company workspace 
(Admin mode) > Data Structure Setup
grouping node > Data Definitions
sub-grouping node > Basic. 

When you go to the BP log, preview pane, 
or UDRs and select that record, the 
system will still display the record details 
(in the right pane) with the value that was 
originally included in the Priority field 
(High), as read-only. 

Default Value 
Available for text entry fields. You may 
enter an optional default value to the field. 

Separator For multi-select input, where users can 
select one or more values to enter into a 
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Field Description 

field. The separate (for example, a 
comma) is used to separate the values. 

All the Integer-type Data Elements (DEs) will have a default value of "0" (zero). As a result, when 
processing an Integer drop-down list (Pull-down field), if the system finds "0" (zero) as a Data 
Set value, then the corresponding data set value/label associated with “0” will be seen. 

Example 

An Integer drop-down list (Pull-down field) is named "Risk Priority." 

If the Data Definition (DD) has: 

1. Data Set value of "0" (zero), and the label is "No." 

2. Data Set value of "1," and the label is "Yes." 

Then, when a record is being created (in User mode), the value for the "Risk Priority" field 
will be "No" because the default value for an Integer drop-down list (Pull-down field) is 
"0" (zero). 

View Cost Code Data Definitions 

Cost Code Data Definitions are used in the Cost Manager to build the identifier for a row of cost 
data. Your company may refer to these as Account Codes, Cost Codes or CBS Codes. For 
example, these could link costs on a project or shell to the General Ledger for Finance. 

CBS Codes can be built with one to a maximum of 10 cost code segments. Each segment is 
defined by a different data definition, so a five-segment CBS Code would require five cost code 
data definitions. 

Cost Code values may be entered one at a time or imported from a CSV file. 

To access Cost Code Data Definitions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Definitions > Cost Codes. The 
Cost Code Data Definitions log opens. 

Add a Basic Data Definition 

The following procedures describe how to add a new Basic data definition. 

To create a basic data definition 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Definitions > Basic. 

3) Click the New button. The Create New Data Definition window opens. 

4) In the Name field, enter a unique name for the data definition. 

 The name can include alphanumeric characters, spaces, dashes, and underlines. 

 The name is case-sensitive. 
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 The name cannot begin the name with a prefix reserved by Oracle Primavera: SYS, 
UUU, or Picker. 

5) In the Data Type field, specify whether the definition will be a string or integer data type. 

When you specify the data type, the system displays an additional field, Input Type. 

If you choose a string data type, include the maximum number of characters in the Data Size
field. 

6) In the Input Type field, select the method the user will use to enter the data. 

7) Click Apply to open the data set tab, or OK to close the Create New Data Definition window. 

Add a Cost Code Data Definition 

To create a cost code data definition 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Definitions > Cost Codes. 

3) Click the New button. The Create New Data Definition window opens. 

4) Enter a unique name for the cost code (General tab - Create New Data Definition block). 

The Category field is read only. 

5) Enter a Label for the cost code. 

6) Select an input type: either Text Box or Pull-down Menu. 

7) Click OK. 

Add a Data Picker Data Definition 

To create a Data Picker data definition 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Definitions > Data Picker. 

3) Click the New button. The Create New Data Definition window opens. 

4) Enter a unique name for the Data Picker. 

5) Click the Select drop-down list and select a category for the list. 

6) Click the Data Source drop-down list and select a source. 

7) Click the Display Element drop-down list and select an element. 

The Data Element field is read only. 

8) Click OK. 

The Data Picker Data Definition appears in the Data Picker Data Definitions log. 

Adding and Managing Data Sets 

Data Set Values are applicable to data definitions that provide the user with a set of values from 
which to choose, for example, drop-down (pull-down) menus, radio buttons, and multi-select 
types. Some data definitions have been supplied with data set values; others must be entered. 
Data Set values can be added, removed or changed. 
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Some examples of Data Definitions for which data sets must be defined: 

 Project/Shell Type, Project/Shell Site and Project/Shell Phase 

 Discipline (for example, Architectural or Engineering; appears on some business process 
forms) 

 Unit of Measure (appears for Line Item entry) 

 Spend Category (for certain Cost-type business processes) 

Add Data Set Values to a Pull-down (Drop-down) Menu or Radio Button 

You can add or import data set values for data definitions that require data sets. These values 
are used to populate the available choices on drop-down (pull-down) menu fields, radio buttons, 
or check boxes on a form or attribute form. 

Note: The default values (in a drop-down list) are populated only on 
creation form of the business process. 

A couple of things to take note of: 

 If the cost code field is a text box, you can set a default value; otherwise, you cannot set a 
default value. 

 If the data definition is an integer type, and will be used in a formula, the value will be used in 
the formula, not the label. For integer data definitions, use care when assigning the value. 

 Avoid semicolons and commas in data set values, as this can cause problems in the 
selection list. 

To add data set values to a Data Definition (all except Multi-select Input) 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Definitions > Basic or Cost 
Codes. 

3) Select a data definition and click Open (ensure that the value in the Input Type column is 
set as: Pull-down Menu). The Modify Data Definition window opens. 

4) Click the Data Set tab. 

5) Click Add. An editable row appears on the window. You can press the Tab key to move from 
one field to the next, or click inside a field. 

6) Enter a Value. This value is the data that is stored in the database. This value will appear on 
the form if you do not enter a label. 

7) Enter an optional Label. This is what is presented to the user as a drop-down (pull-down) 
menu or radio button option. This can be different from the value. 

8) In the Status field, enter Active or Inactive. The default is Active. If you want the value to 
remain on the data set but not show up for users at runtime, you can Inactivate it, rather than 
remove it. 
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9) You can select the Default check box for one of the values on the data set list. This will 
display in the field at runtime. Selecting a default value is optional. 

10) To add another row, click Add. 

 To insert a data set value in the middle of the list, select a value and click Add. The new 
row will be added above your selection. 

 To add a new value to the bottom of the list, be sure a row is not selected, and click Add. 
(Or press the Tab key and tab through the fields of the last row, until the Add button is 
highlighted.) 

11) If you want the data set list to be non-editable, select the Non-Modifiable check box. 

Select this if you do want other users to be able to alter the list. Use caution before selecting
Non-Modifiable. After you select this check box, you will be able to rearrange the order and 
select a different default value, but you will not be able to modify or remove values from the 
data set. 

If this option is selected by a user with create permissions, other users cannot modify the 
data set value list. If it is selected by a user with modify permissions, the option cannot be 
deselected again, except by a user with create permissions. 

12) Click Apply to save your entries, or OK to save and exit. 

Add Data Set Values to a Multi-select Input Data Definition 

Multi-select input type data definitions allow users at runtime to select more than one value to 
enter into the field at runtime. In the field, the values the user selected are separated with the 
Separator displayed on the General tab of the Data Definition window (such as a comma). 

Note: Do not use an apostrophe (‘) in the data for a multi-select input 
type data definition. This can result in blank data in the selector. You 
cannot set a default value for this input type. 

To add data set values to a Multi-select Input data definition 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Definitions > Basic. The Modify 
Data Definition window opens. 

3) Create or open a Multi-select Input data definition and click the Data Set tab. 

4) Click Add. An editable row appears on the window. You can press the Tab key to move from 
one field to the next, or click inside a field. 

5) Enter a Value (128 character limit). This value will appear on the form. Values can contain 
spaces, but cannot contain the separate value (displayed on the General tab, for example, 
comma). 

6) In the Status field, enter Active or Inactive. The default is Active. If you want the value to 
remain on the data set but not show up for users at runtime, you can Inactivate it, rather than 
remove it. 

7) To add another row, click Add. (Or press the Tab key and tab through the fields of the last 
row, until the Add button is selected.) 

8) If you want the data set list to be non-editable, then select the Non-Modifiable check box. 
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Select this if you do want other users to be able to alter the list. Use caution before selecting 
Non-Modifiable. After you select this, you will be able to rearrange the order and select a 
different default value, but you will not be able to modify or remove values from the data set. 

If this option is selected by a user with create permissions, other users cannot modify the 
data set value list. If it is selected by a user with modify permissions, the option cannot be 
deselected again, except by a user with create permissions. 

9) Click Apply to save your entries, or OK to save and exit. 

Import Data Set Values 

If you have a large number of data set values to enter (for example, if you want to populate a 
State drop-down [pull-down] menu with all 50 U.S. states), you can use a CSV file to import the 
values. This can be done for any data definition that uses a Data Set. 

Importing data set values consists of the following: 

Step 1: Export the CSV template file

a. Open the Data Definition and click the Data Set tab. 

b. Click the Export button. 

c. Save the file to your local drive. The file will contain any values that have already been 
entered for the data set. 

Step 2: Complete the CSV file

a. Open the CSV template file. 

Note there are no column headers in the template. Start at the top left corner of the file. 
The first column of the CSV file is the Value and the second column is the Label. 

b. Delete any existing values. There cannot be duplicate values in a data set. 

c. For each row, enter the Value and the Label. Include only two columns, and do not 
include a header row in the file. Do not add a status column; the status will be Active by 
default upon import. 

d. Save the CSV file. 

Step 3: Import the CSV file

a. Click the Import button. 

b. Browse to the completed CSV file and click OK. 

New rows are appended to any existing entries. The system validates the import file to 
ensure that valid CSV format is used. Duplicate entries are not allowed. After importing, 
you can rearrange the order of the rows if necessary. 

c. If you see an error message after importing, proceed to Step 4 below. 

Step 4: View the import validation error file (if applicable)

a. If an error occurs during import and you are presented with an error message, click Yes. 
You can then choose Open to open the file or Save to save the file to your local machine 
before opening. 

b. Open the error file, which is a CSV file. Error messages are listed next to the row in which 
the error occurred (for example, if you have a duplicate row). 
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c. You can use fix the errors in this file (for example, remove duplicate rows) and re-import it 
after fixing the listed errors. Be sure to remove all extraneous text, including the error 
messages, before importing. 

Modify or Remove Data Set Values 

You can edit or remove values in data set lists. When you modify an existing data set, the new 
values will become available when new records are created that use the field (for example, 
create a business process). 

To edit a data set value 

1) Open a Data Definition and click the Data Set tab. 

2) Double-click the value or label to modify. The field becomes editable. Edit the field as 
needed and click OK. 

To activate or deactivate a data set value 

1) Open a Data Definition and click the Data Set tab. 

2) Click the Status drop-down (pull-down) menu and choose Active to activate, or Inactive to 
deactivate. Click OK. 

Inactive values do not appear on the list at runtime. 

To remove a data set value from the data definition drop-down list 

1) Open a Data Definition and click the Data Set tab. 

2) Do one of the following: 

 To permanently remove a value, select it from the list and click Remove. 

 To remove the value from the data definition drop-down selection list that the user is 
presented with, but retain it in the data set value list, click Inactive. 

3) Click OK. 

Reorder Data Set Values 

You can rearrange the order of data set lists. When you modify an existing data set, the new 
values will become available when new records are created that use the field (for example, 
create a business process). 

To rearrange the order of the data set value list 

After you have added the data set values, you can rearrange the order of their appearance on 
drop-down lists, multi-select input fields, and radio buttons. You can do this in two ways: 

 Using the Move Up and Move Down keys 

 Changing the order of the rows by editing the Row column 

To rearrange the order using the Move Up/Move Down keys 

1) Open the Status Definition window and click the Data Set tab. 

2) On the Data Set tab, highlight the data element and click the Move Up or Move Down key 
until the element is in the order you want. 
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3) Click OK. 

To rearrange the order by Editing the Row column: 

1) Open the Status Definition window and click the Data Set tab. 

2) On the Data Set tab, highlight (or double-click) the row number of the element you want to 
reorder. 

3) Enter the new row number the element should occupy. 

4) Repeat step 2 for any other data elements you want to reorder. 

5) Click the Update Order button; click OK to save the change and close the window. 

Row Numbering follows a Relative Numerical Progression 

Row numbers on the list start at 1. When you change the order of the rows, you can enter just 
about any number; even positive, negative, and duplicate numbers. 

If you enter: 

 A negative number (for example, -100): The row will move to the top, becoming row 1. If you 
enter two negative numbers, the "most negative" number becomes row 1, and the "next 
negative" number becomes row 2. 

 Zero (0): The row will move to the top, becoming row 1 (or the row following any negative 
number you entered). 

 A number greater than the existing number of rows (for example, 100 when there are only 50 
rows): The row will move to the end, becoming row 50. If you enter two numbers greater 
than the existing number of rows (for example, 100 and 101), the sort will retain the order of 
the numbers. In this example, 100 and 101 will become rows 49 and 50. 

 A duplicate number (that is, the same number for two or more different rows): The 
duplicate-numbered rows will become adjacent rows (in no specific order). 

Working with Data Elements 

A data element is a data field on a business process. Data Elements and their properties are 
defined by Data Definitions. 

You can use a Data Definition to define the properties of more than one data element. Data 
Elements are defined under the Data Structure Setup node as well as the Attribute forms. 

You can export a CSV file listing specific data elements. 

You can also view the usage of each data element, that is, the list of specific business 
processes where the data element is used. 

Access Data Elements 

To access the Data Elements log 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Elements. The Data Elements log 
opens. 
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The log lists the data elements used for your company. For each data element, the log 
displays the Data Definition on which it is based, the Form Label, which is how the data 
element appears on a form, and Usage. 

Export Data Elements 

You can create a CSV file containing the current list of data elements. This can be useful if you 
must create different combinations of data set values for Dynamic Data Sets, taking from 
different sources of data definition data set values. 

To export data elements 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Elements. The Data Elements log 
opens. 

3) From the Data Elements log, click the Export button. Depending on your browser, the file 
will be automatically downloaded or you will be prompted to download it manually. 

View Data Element Usage 

The Usage button in the Data Elements lets you view the business processes or attribute forms 
that the data element is being used. 

To view data element usage 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Elements. The Data Elements log 
opens. 

3) From the Data Elements log, select a data element and click Usage. The Usage window 
displays the forms that use the data element. 

Modify Data Element 

When you open a Data Element in the Data Elements log, the Modify Data Element window 
opens. The following fields are available in this window: 

 Data Element Name 

 Data Definition Source 

 Form label 

 Description 

 Tooltip 

You can enter the system-level tooltip in the field. 

Upper Forms

Navigate to Company Workspace tab > Admin mode > uDesigner node > Business 
Processes node. Select a BP > Click Upper Forms to open the Forms log. In the Forms 
log, the Tooltip toolbar option enables you to see the list of Data Elements of the combined 
Upper Forms. 

Detail Forms
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Navigate to Company Workspace tab > Admin mode > uDesigner node > Business 
Processes node. Select a BP > Click Detail Form to open the Detail Form log. In the Detail 
Form log, the Tooltip toolbar option enables you to see the list of Data Elements of the 
combined Detail Form. 

RFB Business Process

There are four types of tooltip: 

 Requestor > Upper Forms

 Requestor > Detail Form

 Bidder > Upper Forms

 Bidder > Detail Form

Other Business Processes 

There are two types of tooltip: 

 Upper Forms

 Detail Form

In the Tooltip window, click the Data Element (for example, status), click Update from Data 
Element Properties (system-level) to open the Edit Tooltip window, enter the text in the 
field. Use the arrows (<< or >>) to move to the next Data Element (for example, title) and 
enter the text in the field. 

You can perform bulk update from Data Element properties. In the Tooltip window click 
Update from Data Element Properties to open the Update tooltip Description window. 
Ctrl+click multiple data elements to select and click Update. 

Internationalization and Tooltips 

All the tooltips are extracted as custom strings. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > Internationalization. 

3) Click Find to open the Find window. 

4) Select uDesigner in the Source Type equals field. 

5) Enter "tooltip" in the String contains field. 

Configuring Dynamic Data Sets 

This flexible uDesigner option can be used on business processes and attributes forms. It allows 
one data element on the form to the control both values and behavior of other data elements on 
the same form.  
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A dynamic data set is comprised of a "set" of data elements that includes a master data element 
and dependent data elements, which can be drop-down (pull-down) menus or radio buttons. The 
values that are available to users at runtime for the dependent fields are dependent on the 
selection the user makes for the master data element field. A dynamic data set can be used on 
business processes and attributes forms, and allows one data element on the form to control 
both values and the behavior of other data elements on the same form. 

For example, you can define a dynamic data set that includes a Country, State, City, Postal 
Code and Zip Code data elements that function as drop-down (pull-down) menus on a form. The 
Country field is a master data element. The set can be configured so that, at runtime, the user 
must select a value for Country, which dynamically controls the values that are available to be 
chosen for State. The user then selects a State, which drives the choices available for City. 

Field behavior (such as required, or read-only) can also be controlled by the dynamic data set. 
For example, a dynamic data set might include data elements for Country, Zip Code and Postal 
Code. At runtime, depending on the selected value for the Country, the Zip code field may get 
become enabled and a required field, while the Postal Code field becomes disabled. 

How to Set Up a Dynamic Data Set 

Dynamic data sets are imported automatically when you import a business process or attribute 
form that has the dynamic data set on it. 

Setting up a dynamic data set consists of the following: 

1) Prepare elements and data set values. View dynamic data set properties to identify 
elements of the dynamic data set: 

 Master Data Element, which drives the behavior of the set. 

 Value Set, which lists the data elements whose values will be controlled by the master 
element (for example, if the master element is Country, then the value set might include a 
drop-down [pull-down] data element State, the values of which will change depending on 
the country chosen). 

 Behavior Set, listing elements whose behavior is controlled by the master element (for 
example, a field that becomes Required, Disabled, or Disabled and Clear depending on 
the value chosen for the master element (for example, the Country chosen might dictate 
whether the Postal Code or Zip Code field is enabled for the user). 

Verify that data definition data sets are populated. The data elements that can be part of a 
dynamic data set can be drop-down (pull-down) menus or radio buttons. The values for the 
selections are maintained in the Data Set tab of the data definition properties. Be sure that 
the individual data definitions have valid data sets. (For example, if you have a State 
drop-down [pull-down] data element, the data set corresponding to the data definition for the 
State field must be populated with the state options you want to make available to users. 

2) Define the Value Set and Behavior Set. The value set consists of the fields whose values 
will be controlled by the master data element selection at runtime. The Master data element 
is the first element on the list. You will define the values that display at runtime. 
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The behavior set contains the fields whose behavior (Required, Disabled, Disabled and 
Clear) will be controlled by the master data element selection at runtime. While Required
contains a required text field and Disabled changes the field to read-only, Disabled and 
Clear clears any previous values in the field and then disables the field, making it read-only. 
With selecting Disabled and Clear, you avoid entering invalid data and therefore improve 
data entry. 

Access Dynamic Data Sets 

Dynamic data sets are imported into the system when a business process or attribute form on 
which they appear are imported. 

To access dynamic data sets 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Dynamic Data Sets. The Dynamic Data 
Sets log opens. 

View Dynamic Data Set Properties 

The dynamic data set properties and data elements are designed in uDesigner. The properties 
window identifies:  

 Master Data Element, which drives the behavior of the set. 

 Value Set, which lists the data elements whose values will be controlled by the master 
element (for example, if the master element is Country, then the value set might include a 
drop-down [pull-down] data element State, the values of which will change depending on the 
country chosen). 

 Behavior Set, listing elements whose behavior is controlled by the master element (for 
example, a field that becomes Required or Disabled depending on the value chosen for the 
master element (for example, the Country chosen might dictate whether the Postal Code or 
Zip Code field is enabled for the user). 

To view dynamic data set properties 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Dynamic Data Sets. The Dynamic Data 
Sets log opens. 

3) Select the dynamic data set to edit and click Properties. The Properties window opens. The 
Properties window is view-only. 

4) The General tab displays the general information about the dynamic data set: 

 Name and Description 

 Master Data Element: the data element that serves as the master data element for the 
set 

 Data Definition: the data definition corresponding to the master data element. The data 
definition will be a drop-down (pull-down) menu or radio buttons. The values available for 
the master data element are entered in the Data Set tab for the data definition. 
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 Form Label: the form label of the master data element 

5) Click the Value Set tab. This tab displays the data elements of the value set, which are the 
fields whose values will be controlled by the master data element selection at runtime. The 
Master data element is the first element on the list. Values of each data element are based 
on the data set values defined under base Data Definition. 

6) Click the Behavior Set tab. This tab displays the data elements of the behavior set, whose 
behavior (Required, Disabled) will be controlled by the master data element selection at 
runtime. 

Define the Value Set and Behavior Set Values 

You can add values to dynamic data sets manually one a time, or by importing multiple values 
from a CSV file. The following describes adding dynamic data set values manually. 

Fields defined with a Value Set have values limited by the master data element. For example, a 
Country master data element can control the values that display for a State field. 

To define the value set and behavior set combination 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Dynamic Data Sets. The Dynamic Data 
Sets log opens. 

3) Select the dynamic data set and click Open. The dynamic data set log opens for the 
selected set. 

4) Click New. The Add/Edit <set name> window opens. 

5) Complete the window. The fields on the window will depend on how the dynamic data set 
was designed. It may include a value set, a behavior set, or both: 

 Value Set: These are the data elements that will be controlled by master data element 
selection at runtime. The Master data element is the first element on the list. 

Click the drop-down list and select a value for each data element. The drop-down list values 
are based on the data set values defined under the base data definition. 

In the example in the following figure, the value set is Country and State. At runtime on the 
form, when the user selects a Country, the State field will populate with the states that are 
associated with that country. These value sets determine the combinations of Country-State 
that display. 

 Behavior Set: The behavior of these data elements (Required, Disabled, Disabled and 
Clear) will be controlled by the master data element selection at runtime. 

Click the drop-down and select Required (Field displays a *), Disabled (Field is read-only), 
or Disabled and Clear (Field is cleared and disabled, becoming read-only). If you leave the 
selection blank (or "Select" on the drop-down), there will be no change in behavior for the 
element. 

In the example in the following figure, the behavior set is Mail Stop and Zip Code. In this 
case, at runtime, depending on the Country chosen, either Mail Stop or Zip Code will become 
a required field, or will be disabled. 

6) To add another Value Set and Behavior Set combination, click Add, which will save the 
combination you just entered and let you add another. 
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7) When you are done adding combinations, click OK. The set displays on the dynamic data 
set log. 

Data Elements that can be set as Disabled and Clear 

The behavior set fields of all data types can be set as Disabled and Clear. Exceptions are 
mentioned below: 

 Status 

 Due_Date 

 Creator_ID 

 Record_No 

 Data elements starting with “uuu” 

 Data definitions starting with “SYS,” and the ones not of the following input types: 

 Text 

 Textarea 

 Picker 

 Date Picker 

 Date Only Picker 

 Bitemid 

Import Dynamic Data Set Values 

Importing dynamic data set values consists of: 

Step 1: Export the CSV template file

a) Click the Export button. 

b) Save the file to your local drive. 

Step 2: Complete the CSV file

a) Open the CSV template file. 

b) Enter values for each column as applicable: 

 Value set: The columns correspond to the date elements that make up the value set. 
The values you enter here must match values in the data set for the data definition. 

 Behavior set: The behavior set column is labeled with a (B). Valid values are Required
(makes the data element a required field), Disabled (the data element is read-only),
Disabled and Clear (Field is cleared and disabled, becoming read-only), or you can 
leave it blank. 

c) Save the CSV file. 
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Notes:

 When using a CSV template file, the following header is displayed: 
"For data elements that are required, enter Required as a value. To 
disable a data element, enter Disabled as a value. To disable and 
clear any previous value, enter Disabled and Clear. Do not enter 
any value if there is no behavior change needed.” 

 If the CSV template has restricted DEs in the behavior set and the 
value of Disabled and Clear has been set for the restricted DEs, 
then the system prevents the import and an alert is seen. 

Step 3: Import the CSV file

a) Click the Import button. 

b) Browse to the completed CSV file and click OK. 

c) To download a CSV file containing status details of the import, click Yes at the prompt. 

The rows that you completed in the CSV file are appended to existing entries. Duplicate 
entries are allowed. 

Delete a Dynamic Data Set Combination 

You can delete a dynamic data set combination (value set and behavior set). This removes the 
combination from use with the dynamic data set. 

To delete a dynamic data set combination 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Dynamic Data Sets. The Dynamic Data 
Sets log opens. 

3) Select the dynamic data set and click Open. The dynamic data set log opens for the 
selected set. 

4) Select an entry and click Delete. Click Yes to confirm. 

Edit a Dynamic Data Set Combination 

When you edit a dynamic data set, any changes you make will not reflect in forms. The data 
element must be deleted from the form and added again in uDesigner, and the form re-imported.  

To edit a dynamic data set 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Dynamic Data Sets. The Dynamic Data 
Sets log opens. 

3) Select the dynamic data set and click Open. The dynamic data set log opens for the 
selected set. 

4) Select an entry and click Open, or double-click to open it. 

5) Make modifications to Value Set or Behavior Set as necessary and save. 
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View Dynamic Data Set Usage 

You can view the forms on which a dynamic data set is used. 

To view dynamic data set usage 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Dynamic Data Sets. The Dynamic Data 
Sets log opens. 

3) Select a dynamic data set and click the Usage button in the toolbar. The Usage window 
opens, listing the forms on which the dynamic data set is used. 
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Setting up Multiple Company Calendars 

The system supports multiple calendars, which lets you create a library of calendars that can be 
selected for use at the company, shell, and project levels. The multiple calendars let you have 
calendars to support varying work schedules (depending on locality) and to account for holidays 
and other non-working days. For example, some countries in the Middle East have weekends 
that are other than Saturday and Sunday. Unless otherwise specified, the default calendar for a 
project or shell is the Company calendar that is designated as the default calendar. The 
calendar selected affects project or shell durations and due dates. 

The calendars can be used in project/shell templates, and are automatically applied when the 
template is updated. Also, users can create activity calendars to use in schedule sheets, specific 
activities in schedule sheets. Calendars also affect business process task dues dates, workflow 
due dates, and formula calculations.  

Step 1: Set permissions for multiple calendars. Grant permissions to allow the configuration of 
company-level multiple calendars. See Setting Multiple Calendar Permissions (on page 217). 

Step 2: Create and manage calendars (create, copy, modify, delete, set as default). See 
Creating Multiple Calendars (on page 218) and Modify, Delete, or Mark a Calendar as 
Default at Company Level (on page 219). 

In This Section 

Setting Multiple Calendar Permissions .................................................................. 217 
Creating Multiple Calendars .................................................................................. 218 
Modify, Delete, or Mark a Calendar as Default at Company Level ......................... 219 

Setting Multiple Calendar Permissions 

You must have permissions granted to be able to create, modify, or view the calendars. 

To set multiple calendar permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, expand the User Administration grouping node and click Access 
Control. 

3) On the right pane, select Administration Mode Access > Standards & Libraries > 
Calendars. 

4) Set the permissions as needed: 

 Create: Users can create, modify, view, delete, mark as default. These calendars are 
known as Standard Calendars. 

 Modify: Users can modify and view Standard Calendars. 

 View: Users can view existing Standard Calendars. 
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Creating Multiple Calendars 

You can create a calendar and use it as the standard calendar at the company level, shell level, 
project level, template level, activity level, and business processes. 

There is a default company calendar available titled: Company Calendar (Default). You can: 

 Use the default calendar as the standard calendar. 

 Use the default calendar to create a standard calendar. 

 Copy an existing calendar and modify it to create a calendar that can be used as a standard 
calendar. 

 Create a custom calendar. 

You must have Create permission to be able to create standard calendars. 

To create a standard calendar at company level 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Calendars. The Calendars log opens. 

3) Click New. The Calendar Properties window opens. 

4) Enter the calendar name and an optional description. 

5) Modify the working and non-working days that are specific to the new calendar you are 
creating. Select the calendar day and click the Working or Non Working options as needed, 
then set the Start Time and Hours/Day. By default, the standard calendar will have 
Saturdays and Sundays marked as non-working days, and the Default Work Time will have a 
Start Time of 08:00 AM with 8 hours per day. For more information about modifying the 
calendar days and Default Work Time, see Modify, Delete, or Mark a Calendar as Default 
at Company Level (on page 219). 

6) Click OK. 

To copy an existing calendar at company level 

1) Go to the Company Workspace tab and click Standards & Libraries > Calendars in the 
left Navigator. The Calendars log opens. 

2) Select a calendar in the log. 

3) Click Copy. The Calendar Properties window opens with the calendar description and 
calendars days specified. 

4) Enter the calendar name and change the optional description as needed. 

5) Modify the working and non-working days that are specific to the new calendar you are 
creating, as well as the Default Work Time. 

6) Click OK. 
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Modify, Delete, or Mark a Calendar as Default at Company Level 

You can modify a standard calendar if you have Modify permission. You can delete a standard 
calendar if you have Create permission. If you use a calendar in a shell, project, schedule 
sheets, or schedule sheet activities, and you are asked to replace the calendar, you can delete 
the existing calendar and replace it with a new one. You can also specify a default standard 
calendar if you have Create permission. Unless otherwise specified, the default calendar for a 
project or shell is the company calendar that is designated as the default calendar. 

Note: The calendar selected affects project/shell durations and due 
dates. 

To modify a calendar at company level 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Calendars. The Calendars log opens. 

3) Click the company calendar to select and click Open. The Calendar Properties window 
opens. 

4) Modify the calendar name and change the optional description as needed. 

5) Modify the working and non-working days that are specific to the new calendar you are 
creating. Select the calendar day and click the Working or Non Working options as needed. 

a. To change a particular date from a working to a non-working day, click the date cell to 
highlight and click Non Working. You can select multiple dates. This change impacts the 
months individually and does not impact the rest of the calendar or subsequent years. 

b. To change Saturdays and Sundays from non- working days to working days, click the day 
cell for example "Sat," to highlight and click Working. This will make all Saturdays, or 
Sundays, of the calendar as working days, including subsequent years. In this scenario, 
you can select individual dates under Saturdays or Sundays and mark them as 
non-working dates. 

6) Click OK. 

To delete a calendar at company level 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Calendars. The Calendars log opens. 

3) Select one or more calendars in the log. 

4) Click Delete. If a calendar is not in use, it is deleted. If a calendar is in use, the Select a 
Calendar window displays to let you select a replacement calendar. Select an alternate 
calendar and click OK. 



Modules Setup Administration Guide

220

Note: You cannot delete calendars that are used by view-only projects 
or shells. 

To specify a default calendar 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Calendars. The Calendars log opens. 

3) Select a calendar in the log. 

4) Click Default. 

To change working and non-working days on a calendar at company level 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Calendars. The Calendars log opens. 

3) Select a calendar and click Open to open the Calendar Properties window. 

a. To change a particular date from a working to a non-working day, click the date cell to 
highlight and click Non Working. You can select multiple dates. This change impacts the 
months individually and does not impact the rest of the calendar or subsequent years. 

b. To change Saturdays and Sundays from non- working days to working days, click the day 
cell for example "Sat," to highlight and click Working. This will make all Saturdays, or 
Sundays, of the calendar as working days, including subsequent years. In this scenario, 
you can select individual dates under Saturdays or Sundays and mark them as 
non-working dates. 

A non-working date appears grayed out, and it will not be used in date calculations. 

To change default work time on a calendar at company level 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Calendars. The Calendars log opens. 

3) Select a calendar and click Open to open the Calendar Properties window. 

4) Enter values for the Start Time and Hours/Day fields.  
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Setting up Business Processes 

Information is entered and stored using electronic business process forms and routed via 
configurable workflows. Business processes -- and their workflows, logs, and even search 
parameters -- can be created and designed in uDesigner. They are then imported into Unifier, 
configured for use, and set up for use in specific projects, shells or the company workspace.   

Setting up business processes for use consists of the following steps: 

Step 1: Import and deploy business processes. 

Step 2: Configure the BPs. This configuration enables the BP to be set up for use. It consists of 
establishing the record number sequence, determining which BP log the records will be stored 
in, and activating workflows. 

Step 3: Set up the BPs. After configuring, BPs must be set up for use at the company level or in 
individual projects or shells. For workflow BPs, you can create multiple setups that let you use 
the same BP form with any number of customized workflows. 

Step 4: Grant permissions. After setting up and activating a business process, you must grant 
User mode permission to all users (including yourself) who will need to view records or 
participate in a workflow. 
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Note: Not all BPs work in all areas of the system. For a table that lists all 
available BPs and the areas in which they are available for use, see 
Business Process Functionality (on page 313). 

In This Section 

Master Log - Business Processes Node ................................................................ 222 
Advanced Logs and Standard Logs ....................................................................... 224 
Importing Business Processes ............................................................................... 224 
Configuring Business Processes ........................................................................... 224 
Configuring Business Process Configuration Package........................................... 243 
General Procedures for Setting up Business Processes ........................................ 243 
Loading a Business Process .................................................................................. 244 
Setting up a Non-Workflow Business Process ....................................................... 245 
Setting up a Workflow Business Process ............................................................... 262 
Creating, Adding, and Deleting Business Process Help Files ................................. 294 
Auto-creating BP Record or Planning Item Based on Conditions or Frequency ..... 296 
Setting up Auto-Creation of Cash Flow Curves from Contracts .............................. 302 
Copying Workflow Setups from Other Schemas .................................................... 304 
Setting up a Blanket Purchase Order Summary Template ..................................... 308 
Setting up a Base Commit Business Process ........................................................ 308 
Setting up a Request for Bid (RFB) Business Process ........................................... 311 
Business Process Permission Settings .................................................................. 313 
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Query-Based Tab in Business Processes .............................................................. 315 
Creating Query-Based Tab in Business Processes ................................................ 319 

Master Log - Business Processes Node 

The Master Log - Business Processes node is located in the Home workspace. The node lets 
you access all or a subset of records of the same type, in a single log that spans multiple shells 
or projects. The node also lists all business process types at the project/shell level in separate 
nodes for each type. This includes workflow, non-workflow, and multiple record business 
processes. 

Note: The company-level and single-record business processes are not 
listed under the Master Log - Business Processes node. 

For example, your company might have a shell hierarchy of buildings. A dispatcher who is 
responsible for translating service requests into work orders could use the Master Log - 
Business Processes node to create and edit work order records for any building shell from a 
single, "master" log, rather than drilling into each building shell to access the records. 
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The Master Log - Business Processes node can also be filtered to display only certain 
records. For example, a regional Lease Manager might need to access all of the active leases in 
the system that have lease amounts greater than $50,000 per year. Using the filter feature, the 
lease manager could display only these leases in the Master Log. 

Note: If you do not grant users the permission to view or access any of 
the business process types listed under the Master Log - Business 
Processes node, the users will not see the Master Log - Business 
Processes node in the Home workspace. 

Setting the Master Log - Business Processes Node Permissions 

You must give explicit permission(s) to users to access the Master Log - Business Processes
node. You can grant permissions for users to access all business processes in the Master Log, 
or to individual business process types. To view business process records, users must also: 

 Be an active member in the project, shell, or sub-shell 

 Have access to at least one business process in the Master Log - Business Processes
node 

All project/shell business processes in the system (except inactive and single-record BPs) are 
listed alphabetically in their corresponding Master Log - Business Processes node. 

To set permissions for Master Log - Business Processes node: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click User Administration > Access Control. 

3) On the right pane, select User Mode Access > Home workspace > Master Log > 
<business process>. 

4) Set the permissions as needed: 

 View: Users can view all business process records across all projects and all records in 
the shell hierarchy (subject to their highest level of shell membership in the hierarchy) 
independent of whether or not they are assignees on or have permissions to view and 
manage individual records within a particular Shell or Project. These users can also view 
saved searches. 

 Allow Bulk Edit: Users can select one or more records within a Master Log and perform 
Bulk Edit on business process records. Selected records can potentially span across 
multiple shells. Users having this permission automatically have View permissions. 

Single Record Business Process in the Master Log - Business Processes Node 
Permissions 

In the Master Log, you can assign the View and Allow Bulk Edit permissions to Users and 
Groups for a single record business process. 

To assign permissions: 

1) Go to the Access Control functional node. 

2) In the Access Control window, click User Mode Access to expand it. 

3) Click Master Log - Business Processes to expand it and click All. 

4) Click Project Configuration to open the permissions setting window. 
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5) Add Users or Groups, if needed, and select one or both of the following permissions: 

 Allow Bulk Edit

 View

Additional Information about Single Record BPs in the Master Log

The system will maintain the shell-level BP permissions, when displaying the single record BPs 
in master log. 

Based on the list at the shell-level, you can: 

 Edit the records that you have created 

 Edit the records that you are the record editor of 

 Select multiple single record BPs, in the master log, click Bulk Edit (Actions options), and 
see all of the DEs that have been defined in the Integration tab with direction set as Both 

 Edit multiple DEs in the Bulk Edit window and click Update. Note that this causes all of the 
selected DE values to be updated, across all shells. 

Advanced Logs and Standard Logs 

For Business Processes, Shells, the Space Manager, and Code and Records-based managers, 
you can design either a Standard log or an Advanced log for display in Data Pickers. An 
Advanced Log creates an extra navigation structure that makes it easier for the user to choose 
records to work with. 

Note: The default elements and fields (log layout, view, search, and so 
on) that are defined in uDesigner for the Standard Log determine the 
Standard user interface elements and fields of all logs. 

Importing Business Processes 

All designs, including Business Processes, are designed in uDesigner and deployed to Unifier. 
See Importing Configuration Packages (on page 619).  

Configuring Business Processes 

Business process configuration lets you configure and activate the company-level information for 
each business process you will use. After business processes are deployed, they are available 
for use. Configuring allows activation of the business process and specific workflow schema that 
can be used in projects, shells, or the company level. 

Configuration consists of: 

 Activating or deactivating a BP (deactivating an active BP will also deactivate all of its 
setups) 

 Determining which BP log the BP records will be stored in (for example, project logs, shell 
logs, company logs, Data Manager, and so on) 

 Establishing the BP record numbering sequence 
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 For workflow BPs, activating the workflows that will be allowed for use with the BP 

 Creating a custom-designed print layout that can be used to print BP records 

Note: Configuration of the Data Picker and Data Elements (and when 
applicable: Unique and Auto Sequence settings) must be done in 
uDesigner. 

Accessing Business Process configuration log 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > Business Process. 

The Configuration - Business Processes log opens. The log lists the Business Processes 
that have been imported into the system. 

The newly imported Business Processes are inactive by default and are activated during 
configuration. The ID column shows the short code used to identify the Business Process, as 
defined in uDesigner. During configuration, you can choose to include this identifier as part of 
the record number (for example, if a BP has an ID of uaici, individual record numbers created 
for the BP might be uaici-0001, uaici-0002, and so on).  

Configure and Activate a BP 

The following procedure describes how to configure and activate a business process. If the 
business process form contains a data picker, you must also configure the data picker.  

To configure and activate a BP: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > Business Process. 

The Configuration - Business Processes log opens. The log lists the Business Processes 
that have been imported into the system. 

3) Select a BP and then click Open to go to the Configuration - <BP NAME> log or window of 
the selected BP. 

4) In the Configuration - <BP NAME> window, select Open, and enter values in each tab as 
described below. 

 General tab 

In this tab, you can specify the log in which the BP records will appear, the numbering 
sequence for the records, the status, and record termination restrictions. The tab also 
shows whether the BP is company, project, or shell level. 

 Workflow tab 

In this tab, you can activate one or more workflows that have been imported with the BP. 
A business process may have multiple workflows. Non-workflow BPs will not appear in 
this tab. 

 Query tab 
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In this tab, you can set query and refresh conditions. 

The following explains the fields on the General tab: 

In this field: Do this: 

Level 

Select the level at which the BP displays: 

 Company

 Project/Shell

Default Location 

Choose where the BP records will be 
stored. Some BP types will default to a log 
and cannot be changed. 

If you are using the user configurable 
Navigator, you might not immediately see 
the BP in the User Mode log, even after 
granting permissions. You must manually 
move the BP into the correct User Mode 
node. 

Sequence Policy 

This determines how the record numbers 
for each BP record are sequenced. The 
record number is displayed on the form 
and in the Business Process log. 

 Company Based: Regardless of 
which project a BP record is created in, 
the record numbering sequence starts 
with this number on the first record of 
the first project or shell. 

 Project/Shell Based: A new record 
numbering sequence begins for each 
new project or shell. 

Sequence Format 

The prefix and starting number that will be 
used for BP record numbers. 

Use Base Commit's Record Number: 
This is for identifying workflow Change 
Commits (Line Items with CBS Code Cost 
BPs) at the project or shell level. For this 
type of change commit, you can use the 
base commit record number as part of the 
prefix of the change commit record number 
toidentify the base commit associated 
withthe change commit. It will also  
sequentially numberthe change commits 
so users can see how many change orders 
have been initiated for the base commit. 

To specify this addition to the prefix 
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In this field: Do this: 

number, you must include a separator, 
such as a period, and a starting number for 
the change commits. The maximum 
number of characters for the starting 
number is 8. For the total format, including 
the base commit's record number and the 
sequential numbers, the maximum number 
of characters is 20. 

For example, a base commit record might 
be numbered PO-00123456. For a change 
commit record that refers to this base 
commit, the change commit record number 
could be PO-00123456, followed by a 
separator (such as - ) and a number for the 
change commit. The sequence format for 
change commits attached to this base 
commit could be numbered: 

PO-00123456-001

PO-00123456-002

PO-00123456-003

This numbering sequence will be frozen 
after it is used for a change commit in a 
project or shell. Any change to this 
numbering sequence will only affect 
change commits created in a new project 
or shell. 

Business Process Log 

There are two options: 

 Standard 

 Advanced

If standard, the option Standard is 
selected. 

Record Creator 

Options available are: 

 Do not allow to terminate record:
Selecting this option will remove the 
default permission for the record 
creators, and it can be set in Access 
Control. 

 Allow to modify record: Selecting this 
option lets the creator of a workflow BP 
modify the record at any time, whether 
or not the creator is an assignee on the 
step. Additionally, the creator can 
modify the record while an assignee is 
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In this field: Do this: 

working on the record. 

Note: Updates 
made and saved 
by the creator are 
viewable at any 
time. The system 
lists all changes in 
the audit log. 

 Do not allow to transfer ownership 
of records: Selecting this option will 
remove the default permission for the 
record creators, and it can be set in 
Access Control. 

Enable audit of record print 

Deselected by default. 

If selected, the user can view the audit log 
entries for print and discover the number of 
times that a record has been printed. 

When you select this option, the following 
user actions on a record will create an 
audit entry: 

 Printing from BP record 

 Single & Bulk Printing from the BP log. 

 Single & Bulk Printing from the Tasks 
log 

For bulk print, the number of entries seen 
in the audit log will be the same as the 
number of records that were printed by 
way of the bulk print action. 
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In this field: Do this: 

Mobile Application 

Enable

This option will make this business 
process available for the native mobile 
apps. You can use the Mobile Log Views 
setup to configure customized log views. 

Allow camera as the only source for 
attachments and image fields

For BP record and BP line item 
attachments, this option is applicable only 
when "My Computer" is a source of 
attachments. When checked, the user will 
only be allowed to take pictures from the 
device camera and add them as 
attachments and images in the image 
picker fields. 

Email Notifications 

Replace attachments with links

Use this option when the BP record and 
the BP line item attachments are large in 
size. In order to reduce the load on email 
server and accommodate to maximum 
email size, the user receives the links to 
the attachments, in the email. The user 
must log in to view and download the 
attachments. 

Use the Replace attachments with links
option when the BP record, and line item, 
attachments are large in size. When 
selected, to reduce the load on email 
server and accommodate to maximum 
email size, the user receives the links to 
the attachments in email. The user must 
log into the system to view and download 
the attachments. You (the Admin) must 
enable the option, if requested. 

See the topic after this table for details 
about Email Notifications and Unifier 
users. 

Document Publishing 

Override DM Permissions: Select this 
option if you want to enable users to 
publish the attachments in a BP by 
overriding its Document Manager 
permissions.  
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In this field: Do this: 

Status 

Active enables the BP to be set up and 
used to create BP records. 

Inactive prevents set up or use of the BP. 

Email Notifications and Users 

The following functionalities are applicable to the following users: 

 Standard Users 

 Portal Users 

 Collaborator Users 

Note: The user must have the appropriate permissions to access 
attached files. 

1) For BPs that have the Replace attachments with links option enabled, the email 
notification will contain an organized list of attachment names (related to their origin) derived 
from the BP upper form, or the BP line item. 

2) The attachment name: 

 Contains an underlying unique link that enables the user to navigate through the system 
and access the corresponding attachments. 

 Shows the file size beneath the name. 

3) In the email notification the attachment names are listed in three columns, per row. The 
system will truncate any attachment name that exceeds the allocated width of the column 
(suffixed by ellipsis before the extension name so that extension name is evident to user). 
The user can hover over the attachment in order to see the full file name. 

4) The system displays the list of attachments after the email notification content. 

5) The View in Unifier option in the email notification contains a link that redirects the user to 
Unifier and opens the task or BP record. All email notifications have the View in Unifier
option. The View in Unifier option redirects the user to Unifier, and after the user has signed 
in to the system will open the associated BP record. If the user has already signed in, 
clicking the View in Unifier option would open the associated BP record.  

6) The Download All Attachments option enables the user to download all of the attachments 
together and at once. You can close the Your download is being prepared window and 
continue working. The download is triggered after it is prepared in the background. The delay 
is to accommodate the processing of the zip file. The zip file has the files organized; 
therefore, the root folder has all the record attachments, and each BP line item attachment is 
in separate folder with the folder name being the name of line item tab name.     

 If the user logs out before the download is initiated, then the download preparation is 
canceled. 

 If an attachment is deleted after the email notification has been sent, then the attachment 
will not be included in the zip file, if the name of the zip file is the same as the one that is 
attached to email notifications. 

7) The system will use the current permissions, and the BP configuration, for the signed in user. 
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 If the permissions are changed after the email notification has been sent, then the user 
will not have the permission to download any attachments.  

 If the permissions are changed to 'download only a few files,' the "Download All 
Attachments" option will only include the files that the user has permissions to download. 

 If the permissions for the BP record are changed, then the system redirects the user to 
the landing page and does not open the BP record. 

8) If the user has set up a daily digest for the email notifications, then: 

 Email notifications from the BPs that have the Replace attachments with links option 
enabled will have attachment links. 

 Email notifications from the BPs that do not have the Replace attachments with links 
option enabled will not have attachment links and instead will contain the raw file as the 
attachment. 

 If the daily digest email size exceeds the limit, then the attachment links are retained 
while the raw files are replaced with a warning message. 

9) As a result of the BP setup at a project level or a shell level, and the user preferences: 

 For workflow BPs: 

 If the Include both record and line item attachments option (in the BP 
configuration) is enabled, then the option will be selected, before every 
notification-triggering event. 

 Every email notification that has been sent to the user based on the user's 
preferences will have the  "Include both record and line item attachments" option 
(in the BP configuration) selected. 

 For non-workflow BPs: 

 If Include both record and line item attachments option (in the BP 
configuration) is enabled, then the option will be selected, before every 
notification-triggering event. 

10) After the user clicks on download and signs in to the system, the user will be redirected to 
the Downloading Email Attachment Landing Page. The landing page opens in a new tab 
when a session is active. 

Note: If you are not signed in to Unifier, the system will redirect you to 
the Unifier sign in page when you try to download an attachment. 

Configure a Query for a Query Based Data Element on a BP 

You can configure a Query, for a Query-based data element, on a BP. The Query-based data 
elements give you the ability to query data from business processes and manager sheets, and 
display the results on a business process. For example, you can create a small cost report on a 
business process. This reduces referring back to the cost sheet while a user is working in the 
business process. 

When a Query-based data element (Query Based Data Element [QBDE]) is added in a BP 
Form, you can define the query on which the element gets refreshed (trigger element). 
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Example 

Go to: Company Workspace > Admin mode > uDesigner > Business Processes > 
Action items - Home > Upper Forms. 

Add a Query-based data element in an Upper form of a BP and deploy it. 

Go to the Configuration Tab > Business Process> Required BP and open it to see the 
Query tab. 

During configuration, for each query-based data element (up to five per business process), you 
can define a query formula and any conditions that will filter query results. For example, if you 
want to see the total project commitment, which includes the original commitment amount plus 
any changes to the original commitment, you can build a query formula to show that value from 
the cost sheet. You may limit, or filter, the query results by adding a condition. You can also 
define the refresh condition that will prompt a data update for these query-based data elements. 
When a user opens the business process, the system looks at the refresh condition to determine 
if it can display the last calculated value or values in the business process. 

Notes: 

 This feature is not available for a single-record business process at 
the company level. 

 The difference between a refresh condition and a trigger: A refresh 
occurs when a user opens a business process. A trigger works when 
the BP is already open, and a user changes a value in a "trigger 
element" on that BP form. The trigger element prompts the system to 
run the query again and dynamically update the value in the 
query-based field. 

To configure the query 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > Business Process. 

The Configuration-Business Processes log opens, displaying the BPs that have been 
imported into your company. 

3) Select the business process that contains the query-based data element, click Open and go 
to the Query tab. 

4) Under Query Conditions, click the Add button. 

The Define Query window opens. The Define Query window shows two sections, a 
Definition section and a Condition section. 

Fields in the Definition section: 

 Data Element: Select the data element you want to configure. The list shows only the 
query-based data elements on the form. 

 Data Type: Select the source from which the system will extract the values (for example, 
a column in the CBS Cost Sheet or a business process). 

 Datasource: Click the Select button and on the Formula Creation window that appears, 
build a formula to calculate the value you want to see in the field on the BP form. For 
information on creating a formula for a query, see Queries in the Unifier General 
Administration Guide. 
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5) To specify a condition to filter the data that is extracted by the definition and refine the 
condition further, complete the following steps: 

a. Click the Add button. The Add Query Condition window opens. 

b. Use the instructions under About Queries to complete the query condition. 

c. Click OK. 

6) On the Define Query window, click OK. 

7) On the Data Elements Configuration window, under Refresh Conditions, click the Add 
button. The Refresh Condition window opens. Fields in the Refresh section: 

 Data Element: Select the data element you want to prompt the field refresh. 

 Condition: Select the condition this data element must meet to prompt the refresh. 

 Values: Enter or select the value this data element must contain to prompt the refresh. 

 AND/OR: Select the "And" or "Or" condition between multiple queries. 

8) Click OK, then click Close on the Data Elements Configuration window. 

Configure a BP Workflow (Workflow Tab) 

Workflow business processes may have one or more workflows, which, along with the BP 
settings, control how BP records flow through the steps of the creation, response, review, and 
approval process. Workflows are designed in uDesigner and included with the BP. You must 
activate the workflows that you plan to set up and use.  

Note: This is applicable for workflow BPs only. Non-workflow BPs will 
not display this tab. 

To configure and activate a workflow 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > Business Process. 

3) Open the applicable BP. 

4) In the Configuration - <BP NAME> window, click the Workflow tab. 

5) To activate a workflow, select the workflow and click Activate. 

6) Alternatively, you can select a workflow and click Modify. The Workflow Configuration
window opens. 

 In the General tab, you can edit the name or description if necessary. 

 You can change the status to active in this tab. 

 To view the steps of the workflow, click the Step tab. 

 Click OK to exit the Workflow Configuration window. 

7) If you have edited or added a workflow to an existing business process and re-imported, you 
may need to add the new workflow. Click Add to add newly defined workflows, if any exist. 

8) Click Apply to save your changes, and OK to exit the Business Process Configuration 
window. 
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Creating BP Log Views in Admin Mode 

When users configure Business Processes (BPs), they can also create log views for the BPs. 

Log views are the views which drive the content and behavior of the BP logs seen at run time. 
The Administrators can create customized "default" log views that meet the requirements of the 
company and users. 

Note: Users can only create the view in each project for the BPs that the 
users have access to. 

This topic explains the following: 

 BP Log Views 

 BP Log Views at Runtime 

 BP Log Views and Configuration Package 

BP Log Views 

BP log views can be created for: 

 Project-level BPs 

 Company-level BPs 

The views defined for the BPs are applicable to both BP logs and the Master Log - Business 
Processes log. 

The Business Process node (Company Workspace tab > Admin mode > Configuration) has 
the following sub-nodes related to log views: 

 Log Views

 Mobile Log Views

The Log Views sub-node, seen in all types of BPs, lets you: 

Create your log view, similar to creating BP logs in User mode. 

 Reorder the BPs. 

 Change the status of a BP. 

 Delete inactive views. 

Note: Users must have "Configuration" permission before they can 
access the Log Views node or create log views. 

The Log Views log has the following features: 

 Toolbar 

 Create: To enable the administrator to create a view. 

 Manage Views: To take one of the following two actions: Activate a view (Active) or 
delete a view (Delete). 

Status identifies whether a view is active or inactive. You can select the check box next to 
a view to activate or deactivate a view. 
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Delete lets you delete a view. You can delete a view that has been marked as inactive. If 
you select multiple views and delete, only the inactive views will be deleted. 

 Refresh: To refresh the views in the log. 

 Find on Page: To find a specific view on the displayed page. 

 Columns 

 No.: The system-generated number to help the user identify the sequence of the views. 

Changing the sequence of the views (moving them up or down on the page) will result in 
change of the system-generated number. 

At least one BP log view must be active. The administrator cannot deactivate all BP log 
views. 

The user cannot create two BP log views with the same name for a single BP. 

When a user changes the sequence of the BP log views that were initially provided 
according to the BP configuration, the system retains the user's sequence even if the 
administrator makes changes to the sequence. 

If an administrator creates BP log views, the system appends the new BP log views to the 
end of the BP log views list. 

 Name: The name of the view. 

 Status: Active or Inactive 

 Last Modified Date: The date that the view was last modified. For a new view, this will 
be the creation date. The field is initially blank for existing system-defined views, when no 
modifications have been done. 

 Last Modified By: The name of the user who last modified the view. The field is initially 
blank for existing system-defined views, when no modifications have been done. 

The gear menu (  ), which appears when you click a record, has the following options: 

 Move Up: To move a record up on the log. This option is not available for the first view on 
the log. 

 Move Down: To move a record down on the log. This option is not available for the last view 
on the log. 

 Active: Sets the view status to Active. 

 Inactive: Sets the view status to Inactive. 

BP Log Views at Runtime 

BP log views will be a part of BP configuration. Only active views will be seen at runtime. All 
active views pertaining to a BP can be seen by all users who have access to the log (BP logs 
and Master Log - Business Processes log). System provided views can also be modified in the 
Log Views to better suit your business needs. 

 All Records

 Records Created by Me

 Records Received by Me

 Records Created and Received by Me

 AI view

 Create New View
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 Manage Views

BP Log Views and Configuration Package 

Use the Log Views node (Company Workspace tab > Admin mode > Configuration Package 
Management > Component Lists > Configuration > Log Views) to include the designs for the 
selected log views in your configuration package. 

BP log views in Component list/Configuration Package: 

The users can include BP log views and deployed designs. 

The users can include updated BP log views without any changes to the underlying columns 
used in the View definition. 

When the configuration package is imported, it replaces any existing BP log views that were 
created by the administrator. 

Note: The BP log view component will be included as part of the impact 
analysis report, error report, and print report. 

Configure Pickers in Admin Mode 

The information in this topic applies to the following pickers:  

 CBS Picker 

 CM0 Picker  

 CMx Picker  

Note: Each class of CMx pickers can have its own query conditions.  

 Funding Picker 

If the picker Data Element (DE) is added on the BP form, you can also configure the query 
condition on the picker Data Definition (DD) to restrict the visibility of available data at runtime. 

As an administrator, you can: 

 Configure query condition on picker DE to restrict the visibility of available data at runtime. 

 See whether or not any query condition is added.  

 Perform the following actions: 

 Add new query condition 

 Modify/delete existing query 

 Apply And/Or condition 

 Add a query based on different data selection to filter data that needs to be available at 
runtime 

 Change And/Or conditions among different queries 

 Save so that only saved changes are applicable and data is filtered based on saved 
queries or cancel changes made in query conditions 
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 See a list of all available picker attributes in the required DD field, on the Add Query 
Condition and Modify Query Condition windows. This lets you select an attribute value 
from the drop-down (pulldown) menu to apply the condition on. 

 See a list of all available options for the required Condition, field based on the DD field 
value on the Add Query Condition and Modify Query Condition windows, while 
adding or modifying a query condition. This lets you select the appropriate condition to 
apply between the DD and values.  

Note: To define a query condition, you can use the Date Picker and Date 
Only Picker. No other pickers are supported. Also, the cost code and 
cost attribute pickers cannot be used in the query condition. 

 Select the value (Value field) as Dynamic or Constant, if the DD and the Condition 
fields have values on the Add Query Condition and Modify Query Condition windows, 
while adding or modifying a query condition. This is so you have a choice to: 

 Define that a comparable value will be provided at runtime, based on the Data 
Source selection, or 

 The value can be a constant value.  

The system compares the DE value against a given or selected constant value and filters 
the data based on the defined condition at runtime. 

 Have different options (such as Cancel, Add Another, and Add or Update) while adding 
or modifying a query condition. You can select: 

 Cancel - to cancel the changes 

 Add Another - to add another query condition 

 Add - to add the query in the query log 

 Update - to update the existing query, in the query log 

 See added or modified query conditions in query log. This is so you can see all of the 
added query conditions in one place, and if required,  delete or modify the existing query 
condition. Also, it will provide the  option to put And/Or condition in the defined query 
conditions. 

When you go to your Company Workspace (Admin mode) > Configuration > Business 
Processes and select and open a BP, in the left Navigator, you see the Pickers functional 
sub-node, in addition to the other sub-nodes, such as Log Views, Mobile Log Views, and 
Customize Email. 

The Pickers functional sub-node is available if the picker DE has been added on the BP form. 
The Pickers functional sub-node log has the following panes: 

 Pickers Configurations (the left pane) which displays the DEs, under the Data Elements
block. The Data Elements block displays the available pickers. 

 <picker name> Query Conditions (the right pane) which displays the query conditions. In 
the <picker name> Query Conditions you can use the following toolbar options: 

 Click Add to open the Add Query Condition window, select the DE, determine the 
condition for the query, create and add your query conditions.  

The Data Element drop-down field is a required pulldown field that will list all the 
attributes. You can select any of these attributes to define the query. 
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The Condition field is a required field that is disabled by default. After the value for Data 
Element is selected, the system enables the Condition field and lists the values to select 
from. 

For numeric type DEs, the conditions will differ from string and date type elements. 

If the values for the Data Element and Condition are selected, then a new section will be 
displayed labeled Value. The Value has the following options to select from: 

 Dynamic

 Constant

Query condition value as Dynamic

By default, the option Dynamic is selected and there will be drop-down fields to select the 
data source and data element (based on Data Source value). The Data Source value 
can be <BP Name>, upper form, <BP Name> detail form, single instance BPs, and shell 
attributes. Based on the data source that you select, the list of matching DEs will be 
listed. 

Query condition value as Constant

If you select Constant, then a text box or pulldown is displayed, based on the type of the 
value under the Data Element field. In case of the text box, a placeholder text 'Type 
here' will be displayed. You can enter a constant value. 

To select a value from predefined data set, a pulldown will be displayed, and you must 
select a constant value from the pulldown. 

Example 

If the Data Element value is Status, then the constant will be a pulldown with values as 
Active or Inactive. 

Query on Date type data element

When you select the Date DE for the type of the value under the Data Element field, the 
Condition drop-down field will list all the available conditions for the Date DE. Depending 
on the selection in the Condition drop-down field, different options will be displayed. 

After all queries are added, they will be listed within the Query Condition log with the 
And condition as a check box, not selected by default. 

 Select the Show results matching any of the following conditions option to apply the 
And/Or condition to multiple query conditions. By default, this option will be deselected. 
You will be able to change the selection. 

The <picker name> Query Conditions has the following columns: 

 Data Element

 Condition

 Value

 And/Or

 Delete

 Edit 

The Cancel and Save options will appear at the bottom, when you make changes to an 
existing query or add a new query. When you click Save, the query conditions will be saved 
in the database. After you click the Save or Cancel options, the system will not display those 
options on the pane, until the next change. 
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Note: The attributes added on the detail form will be available to define 
query conditions even if it is a part of a hidden block. 

As soon as a query is added to the log, the Delete and Edit options will be displayed in log. The 
Delete option will delete the selected row, and the Edit option will open the Modify Query 
Condition, where you can view or modify the condition. Double-clicking an existing query in the 
query log also lets you view or modify the condition. 

After performing any action, you must click Save to save the changes. 

Date Type Query Condition 

If the value for the Condition drop-down is empty, or not empty, there is no need to define any 
value. 

You can select the value for Condition as between and select a date range between two dates: 
Date 1 and Date 2. The available options are: 

 Dynamic

Selected by default. You are required to select a date for Data Source and a Data Element
value to define value of the Date field. 

 Date

To select the date from the system calendar. 

 Today

To select the current date. 

In the Condition field, if you select any value other than between, is empty, or is not empty, 
then different options will be displayed for selecting the date value: 

 Date

You can select one of these options: 

 Dynamic

Selected by default and the user needs to select a date 'Data Source' and 'Data Element' 
to define Date. 

 Date

To select the date from calendar. 

 Today

To select the current date. 

 Add/Subtracts days

Your options are: Plus, Minus, and None. By default, Plus is selected. 

 Number of days

Displayed only if Plus or Minus is selected. You can select one of the following options: 

 Dynamic

Selected by default. You must select a date Data Source and a Data Element to 
define the Date. 

 Days

To set a numeric value. 
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Creating BP Mobile Log Views in Admin Mode 

Administrators can create customized "default" mobile log views that meet the requirements of 
the company and users. 

BP Mobile Log Views 

To create mobile log views, you must first make sure the BP is mobile enabled. Navigate to the 
Business Process node (Company Workspace tab > Admin mode > Configuration). Open 
the BP for which you want to create mobile log views and navigate to the Mobile Log Views 
node in the left Navigator. 

The Mobile Log Views sub-node, seen in all types of BPs, lets you: 

Create your mobile log view, similar to creating BP logs in User mode. 

 Reorder the BPs. 

 Change the status of a BP. 

 Delete inactive views. 

Note: Users must have "Configuration" permission before they can 
access the Mobile Log Views node or create log views. 

The Mobile Log Views log has the following features: 

 Toolbar 

 Create: To enable the administrator to create a view. 

 Manage Views: To take one of the following three actions: to make the status of a view 
Active or hidden, to delete a view, or to reorder views. 

 Refresh: To refresh the page. 

 Find on Page: To find a specific view on the displayed page. 

 Columns 

 No.: The system-generated number to help the user identify the sequence of the views. 

Changing the sequence of the views (moving them up or down on the page) will result in 
change of the system-generated number. 

At least one BP log view must be active. The administrator cannot deactivate all BP log 
views. 

The user cannot create two BP log views with the same name for a single BP. 

When a user changes the sequence of the BP log views that were initially provided 
according to the BP configuration, the system retains the user's sequence even if the 
administrator makes changes to the sequence. 

If an administrator creates BP log views, the system appends the new BP log views to the 
end of the BP log views list. 

 Name: The name of the view. 

 Status: Active or Inactive 
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 Last Modified Date: The date that the view was last modified. For a new view, this will 
be the creation date. The field is initially blank for existing system-defined views, when no 
modifications have been done. 

 Last Modified By: The name of the user who last modified the view. The field is initially 
blank for existing system-defined views, when no modifications have been done. 

The gear menu (  ), which appears when you click a record, has the following options: 

 Move Up: To move a record up on the log. This option is not available for the first view on 
the log. 

 Move Down: To move a record down on the log. This option is not available for the last view 
on the log. 

 Active: Sets the view status to Active. 

 Inactive: Sets the view status to Inactive. 

BP Mobile Log Views at Runtime 

BP log views will be a part of BP configuration. Only active views will be seen at runtime. All 
active views pertaining to a BP and can be seen by all users who have access to the log. 

BP Mobile Log Views and Configuration Package 

Use the Mobile Log Views node (Company Workspace tab > Admin mode > Configuration 
Package Management > Component Lists > Configuration > Mobile Log Views) to include 
the designs for the selected log views in your configuration package. 

BP mobile log views in Component list/Configuration Package: 

The users can include BP mobile log views and deployed designs. 

The users can include updated BP mobile log views without any changes to the underlying 
columns used in View definition. 

When the configuration package is imported, it replaces any existing BP mobile log views that 
were created by the administrator. 

Note: The BP log view component will be included as part of the impact 
analysis report, error report, and print report. 

Customizing Email Subject Line 

When you send task notification emails from various trigger points, you can customize the email 
subject line to provide more context to those notifications. You must have the permissions to 
configure a Business Process to access the node Customize Email grouping node. The 
customized email subject can be a combination of simple text, shell information, data elements 
from the Business Process Upper forms, and Workflow steps. 
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Note: The email subject lines can be configured only for workflow-type 
business processes. 

The Subject Line node contains a table of email types and preferred languages. You can 
configure the email subject line in multiple languages as set in the Company Preferences. The 
language that is set to "Active" in the Internationalization node is the only language displayed 
in the right pane. 

To Customize the Email Subject Line 

1) Click Configuration > Business Process > select a Business Process name from the right 
pane > select Customize Email > Subject Line. 

2) Go to the column of the desired language and select the Configure icon for the email type. 

Note: The preferred language must be selected as "Active" in the 
Internationalization node. 

3) In the window that appears, enter or edit the subject line in the free form text field. 

Notes: 

 The subject line can be a combination of simple text, shell 
information, data elements from the BP Upper Forms, and Workflow 
steps. 

 The maximum number of characters must be fewer than 299.  

4) Select the data elements from the grid that follows. 

Note: The <DE Label> is displayed if the selected data element does not 
hold a value in the runtime. 

5) Click Save. 

The language column shows the email subject line corresponding to the email type. 

Note: DEs of type Rich text are not available to be added in the email 
subject line configuration, or to be added to the custom email content. 

Customizing Email Content 

Just like the subject line, you can also customize the email content of task notifications.  

The Content node contains a table of email types and preferred languages. You can configure 
email subject line in multiple languages as set in the Company Preferences. The language that 
is set to "Active" in the Internationalization node is the only language displayed in the right 
pane. 

To Customize the Email Content 

1) Click Configuration > Business Process > select a Business Process name from the right 
pane > select Customize Email > Content. 
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2) Click Create. 

3) In the window that appears, select the tab for the preferred language.  

4) Enter a Name for the email content template. 

5) Type the content for the email in the box below. Select data elements to include in the email 
as needed. 

Note: The <DE Label> is displayed if the selected data element does not 
hold a value in the runtime. 

6) Click Save. 

The language column in the Email Content log shows the total size of the email content. 

Configuring Business Process Configuration Package 

If tagged for Configuration Package, the system allows you to include the following 
configurations in the Business Processes: 

 General setup 

All the fields included in the General Configuration (General tab). 

 Custom Print 

Word and PDF templates, if any. 

 BIP Custom Print 

All the Oracle Business Intelligence Publisher (BI Publisher) and Oracle Analytics Publisher 
Custom Print in the Custom Prints and Reports. 

 Workflows 

All configured Workflows. 

 Query 

All queries that have been configured based on data elements. 

For more information, see Configuration Package Management (on page 567). 

General Procedures for Setting up Business Processes 

Business processes must be set up before use. The general procedures apply to company-level 
and project-or shell-level business processes, with some differences. 

Workflow Business Processes

Workflow business processes can have one or more BP setups, which define the workflow setup 
options. These include configuring the workflow and each step. These options control step 
behaviors as the BP moves through the steps of the workflow. Each step can have an 
associated duration and the workflow (consisting of all the steps) can have an overall duration, 
which facilitates project or shell data flow-through and tracking. BP setup is the process of 
choosing a configuration, assigning users or groups to each step, configuring the actions they 
can take on that step, and setting the durations. 
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You may want to create multiple workflows per BP to accommodate different ways for the 
workflow to operate. For example, you can configure an RFI workflow with or without a 
coordinator. You may or may not have a need for both workflows on your project or shell. 

Non-workflow Business Processes

For non-workflow business processes, one setup is allowed. Setup includes adding the list of 
users who can create a non-workflow BP. 

Set up of auto-creation of business processes or line items

Both workflow and non-workflow BPs support auto-creation. Auto-creation can be based on a: 

 Condition that is met 

 Date that passes 

 Condition and a date 

 Frequency (at periodic intervals, for example) 

 Condition and frequency 

You can auto-create BPs or line items from the upper form or the detail form, using creator 
elements. See Set up auto-creation for a non-workflow BP or planning item (on page 251) 
for non-workflow auto-creation setup and Set up auto-creation for a workflow BP (on page 
271) for workflow auto-creation. 

Auto-creation of BPs based on workflow steps

You can specify that some workflow BPs include steps during the workflow that enable the 
auto-creation of BPs from an S-Step. See Define the Business Process Workflow (on page 
275) for details. 

Special setups

There are special setup procedures for blanket purchase order BPs and Request for Bid (RFB) 
BPs. There is an additional option for auto-creation of a commitment-level cash flow curve in 
setups for base commit business processes. 

Loading a Business Process 

Loading the business process is part of setting it up. In this step, you will be loading the 
configured business process into the area where it should reside—the Company Workspace or a 
project/shell. This step filters the business processes by company, shell, or project level, thereby 
narrowing the number of BPs so that the users do not have to sift through your company's entire 
list of BPs. 

When you load a business process, you also load the permission infrastructure and the ability to 
grant permissions for this BP. 

To load a business process 

1) Go to the Company Workspace tab and switch to Admin mode. 

 To load a BP into the Company Workspace, click Company Workspace > Business 
Process Setup in the left Navigator. 
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 To load a BP into a shell, click Company Sponsored Shells > [shell type] > [shell] > 
Setup > Business Process in the left Navigator. 

 To load a BP into the templates for a shell, click Templates > Shells > in the left 
Navigator. Then choose the [shell type] > [template]. Then select Setup > Business 
Process in the left Navigator. 

2) Click New. 

The New Business Processes window opens, showing the business processes that are 
available for loading. 

3) Select the business process you want to load and click OK. 

The system displays the business process in the right pane. 

Setting up a Non-Workflow Business Process 

This procedure is applicable to project, shell, and company level non-workflow business 
processes. Be sure you have added the business process to the log first. 

Basic Non-workflow Set Up in General Tab and Settings Tab 

To set up a non-workflow business process - General Tab 

1) Open the project or shell, or (for a company-level business process) go to the Company 
Workspace tab. 

2) Switch to Admin mode. 

3) Navigate to the Business Processes log. 

4) Select the non-workflow BP and click Open. The Setup log opens on the General tab. 

5) Click New. The Business Process Setup window opens. 

6) Complete the tabs as described below and click OK. 

7) Click Yes to activate the BP and make it available to users, or click No to keep the BP 
inactive until a later date. 

In this field: Do this: 

Setup Name Enter a unique name (required field). 

Description 
Enter a description. This is optional, but 
recommended. 

Help File Lets you add a custom PDF help file. 

Default Record Status 

Use this field in setting up the creation of 
non-workflow business processes. The 
status you enter here will be used as the 
beginning status for a record created using 
any method—manual, integration, or 
auto-creation of any type. 

Note: If the default status that you select 



Modules Setup Administration Guide

246

In this field: Do this: 

has been set to Inactive, an error message 
appears when you activate the business 
process setup, the selected status is 
removed from the list, and you must select 
a different status. 

Send error notification to: 
Specify the user to receive error 
notifications. 

Save Record Information to Document 
Manager 

Select this check box if the records 
produced by this business process should 
be automatically saved in the Document 
Manager. If you select this option, the 
system will send a copy of the business 
process' records, along with their 
comments and attachments, to a specified 
folder* in the Document Manager. The 
owner of the published record will be the 
assignee of the business process that 
published it. If the record exists in the 
folder, the record will be published as a 
revision. If the path to the folder is invalid 
for any reason, the record will be sent to 
the Unpublished Documents node. 

Depending on how you set up the 
business process, it can be automatically 
published to the Document Manager 
whenever an email notification is sent 
regarding the status of the business 
process. 

* This folder is identified on the business 
process with this data element 
uuu_dm_record_info_path. For 
information about this element, refer to the 
Unifier Data Reference Guide. 

Default Record format for Notification and 
Document Manager 

This option has two purposes: 

 If you want notification sent to users 
whenever a business process record is 
created or modified, use this option to 
specify the format in which you want 
the notification to be sent. 

 If you have checked the Save Record 
Information to Document Manager
check box, use this option to specify 
the format in which the business 
process records should be saved. 
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In this field: Do this: 

Cash Flow: Default Template 

This option only appears in CBS 
code-based Base Commit business 
processes. It lets you enable the 
auto-creation of a commitment-level cash 
flow curve at runtime for the business 
process record. The curve is based on the 
selected commitment-level cash flow 
template, and is created when the record 
is complete. 

Click Add and choose a template. 

For more information, see Setting up 
Auto-Creation of Cash Flow Curves 
from Contracts (on page 302). 

Settings tab 

Add the creator and editor on the Settings tab: 

In this field: Do this: 

Creator(s) 
Click Select to choose the creators of the 
BP, those users who may create a BP 
record from this setup. 

Editor(s) 

Optionally, click Select to choose users 
and/or groups who can edit the business 
process without being granted explicit 
record-level permission. This allows users 
other than the assignee to edit the 
business process record. The Editors field 
can include users and groups that are also 
entered under Creator(s). 

The Editors can be added on these BP 
types: 

 Line Item 

 Cost (all types, including Lease and 
Line Item with Multiple Codes) 

 Document 

 Simple 

 RFB 

 Text 

Users or groups that you add as Editors 
can open and edit any record that they can 
see listed in the business process log, per 
their view access permission. Access 
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In this field: Do this: 

permissions are View User Records, 
View Company Records, or View All 
Records. The user who is designated as 
an Editor must have at least one of these 
permissions to be able to view the record 
in the log to access it to edit. 

Notes: 

 When you set up view permissions for 
non-workflow BPs, by design, the 
"View Company Records" option is not 
permitted.  

 To assign proper view permission for 
non-workflow BPs, you (Admin) must 
assign the view permission on each 
non-workflow BP, individually. 

Allow Quick Calendar Entry 

Click Select and choose the users and/or 
groups who will be allowed to use the 
quick entry feature to reserve the object of 
this business process, or to edit or delete it 
from the calendar. 

Note: This option will appear only on those 
business processes that have been 
calendar-enabled by design. 

Selecting BI Publisher/Oracle Analytics Publisher Custom Print (Format > Custom) 

The following is a list of conditions applicable to BI Publisher/Oracle Analytics Publisher Custom 
Print. 

Only Published BI Publisher/Oracle Analytics Publisher Custom print templates can be selected 
while setting up the Business Process; however, if you make any changes to the Published 
template and do not re-publish it to the BI Publisher/Oracle Analytics Publisher server, the 
selected template will continue to remain in the Business Process (BP) setup option. 

 If the BP setup has been done in a Project/Shell template, the setup will get pushed when 
you update the setup information onto instances of Projects/Shells. 

 If you delete the BI Publisher/Oracle Analytics Publisher Custom Print template selected in 
the BP Setup window, the system removes the deleted BI Publisher/Oracle Analytics 
Publisher Custom Print template from the BP setup. 

 If the system does not generate the print output, for example due to server issues, the email 
attachment, which contains the record information, generates an error message. 

 Custom Print template included in the BP setup can be exported in the Configuration 
Package. By virtue of tagged BP design, the corresponding BP Setup from the tagged Shell 
template will also be included. If the Custom Print Template is not tagged, the Configuration 
Package export will result in an error. 
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Note: If the BI Publisher/Oracle Analytics Publisher Custom Print output 
could not be generated because of connection issues to the BI 
Publisher/Oracle Analytics Publisher server or inconsistencies in 
between Custom Print on Unifier and the BI Publisher/Oracle Analytics 
Publisher server, the notification emails for Business Process 
modification will have an "error.html" document (as an attachment) 
instead of a record information document. In such a case, if the record 
information is Published to the Document Manager, a 0 KB document 
will be published. 

Set up email notification for a non-workflow BP 

Use the Notification tab to set up automatic email notifications to users and groups whenever a 
non-workflow business process is created or modified, either manually, or via auto-creation, 
reverse auto-population, CSV, or integration. 

Note: If the business process has been designed to allow users to 
include additional users or groups in the email, the email notification will 
be sent to them as well. 

1) Use the information in the table below to complete the Notification tab. 

2) Click Apply to save your changes and OK to exit. 

In this field: Do this: 

Send notifications to Click Select and choose those users or 
groups that should be notified whenever a 
non-workflow business process is created 
or modified. 

Notify creator on record modification By default, this check box is checked. If 
you do not want the BP creator to be 
notified when the business process is 
modified, deselect this check box. 

Notification triggering events The fields you select here will tell the 
system when to notify the users or groups.

Create Record Select this check box if notification should 
go out whenever a record is created. 

Edit Upper Form Select this check box if notification should 
go out whenever the upper form of a 
record is edited. 

Add/Edit/Delete Line Items Select this check box if notification should 
go out whenever a line item is added to the 
record, edited, or deleted from the record. 

Add General Comment Select this check box if notification should 
go out whenever comments are added to a 
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In this field: Do this: 

record. 

Add/Remove Attachments Select this check box if notification should 
go out whenever attachments are added to 
or removed from a record. 

Attachments The fields you select here will tell the 
system how to add attachments to the 
record. 

Include both record and line item 
attachments 

Select this check box if the notification 
should include both the record and the line 
item attachments. 

Include record information as attachment Select this check box if the notification 
should include the record information as 
an attachment. 

Override default format If you have specified a default record 
format on the General tab, you can use 
this check box to override the default 
format. For example, you can use the 
General tab to specify that the default 
record format for both email notifications 
and records saved in the Document 
Manager be in PDF format. If necessary, 
you could then use the Override default 
format check box to override the format 
and choose Custom for the notification 
only. 

Format PDF/Custom Select the form. 

The attachments are PDF or a custom 
format. 

BI Publisher/Oracle Analytics Publisher 
Custom Prints are available to be selected 
for the Notification format. 

For custom format, select the print format 
defined for the business process. 

Note: The system sends emails for reverse auto-population failures. 
There may be cases when email notifications are not sent. For such 
cases, you can find the reasons for the reverse auto-population (RAP) 
failures in the audit log of the business process record. In addition, on 
occasion the system generates error codes for reverse auto population 
failures which can be used to troubleshoot the reverse auto population 
failures. 
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Set up auto-creation for a non-workflow BP or planning item 

On the Auto-Creation tab, you can set up the auto-creation of another record or line item for the 
business process you are setting up. You can also set up the auto-creation for other business 
processes that will be spawned by this business process. 

For information about auto-creating business processes, see Auto-creating a Business 
Process record or Planning Item Based on conditions or frequency (on page 296). 

The data elements of type rich text are not available to create conditions for auto-creation 
elements in a BP Setup (Company Workspace > BP Setup and Shell > BP Setup). 

When a line item is auto-created (by using the line item auto-creation logic), the values in the 
fields on the line item that are based on a data picker in that line item will not be auto-populated. 

To set up auto-creation of a non-workflow business process or planning item 

1) Click the Auto Creation tab. 

2) Under Settings for auto creation of [name of the business process, planning item, or line 
item you are setting up], in the Creator field, click the Select button and choose the name of 
the auto-creator. 

3) Under the section Settings for auto-creation of other business process records or line 
items, select the BP creator element under the upper or detail form. The Auto creation of 
line identifies the business process or the line item that the creator element you selected will 
create.  

4) (Not an option for line item creation.) In the Assignee/Creator field, click the Select button 
and choose the name of the user or group who should assume ownership of the 
auto-created record. 

5) Ignore the Duration field. 

6) To create the conditions that will trigger the auto-creation, select the Enable condition 
based auto creation check box and continue as follows: 

Note: If you leave this check box un-checked, the BP, planning item, or 
line item will be available for manual creation only. 

a. To add a trigger condition, click the Add button. The Add Condition window opens. 

b. On the General tab, enter a name for the trigger and a description. 

c. Click the Query tab. 

The Query tab is where you will define the conditions the data must meet before the 
system will auto-create the new business process record or line item.  

In the upper section of the window, you can specify that a field on the business process 
form: 

 Must meet a certain criteria or value 

 Must meet a certain value based on a formula using the numeric fields on the form 
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Click the Add button to specify a condition for a field on the business process form. Click 
the Add Formula button to create a formula that the value of the field must meet. Use the 
information in the Queries section of the Unifier General Administration Guide to complete 
the query. 

Select the match ANY condition (instead of ALL) check box if the query can match any 
single condition to extract the information. If the query must match ALL conditions, leave 
this check box unmarked. 

In the lower section of the window, you can specify a date condition that will trigger the 
auto-creation. Use the information in the Queries section of the Unifier General 
Administration Guide. 

Date condition triggers are not available for line item auto-creation. 

About Date Triggers: 

 If you want to create a continual date trigger condition, make sure you use the 
Date Trigger Condition section of the window to create it. Although you can 
also create a date trigger using a formula in the upper section of the window, 
the system will process the triggers differently. 

 The conditions you specify in the upper section of the window will be 
processed only once, when the user clicks the Finish Editing button on the 
form. However, the date conditions you specify in the DateTrigger Condition 
section will be processed daily. 

 This behavior is important to consider when you are creating a date condition 
that occurs in the future. A date trigger specified under the Date Trigger 
Condition section will be processed daily, and will, therefore, "catch" the trigger 
condition when the future date occurs. 

d. Click OK. 

7) If you want the auto-created record or line item to include attachments from the original 
(source) record, select the Include Attachments check box. 

Note: This step is not applicable for Document type business processes. 

If you select this option: 

 Any record-level attachments made to the source record will appear at the record 
level of the destination record. 

 Any attachments made to the line items of the source record will appear at the line 
item level of the destination record. 

8) (Not an option for line item creation.) If you want to bypass the I step that this auto-creation 
normally creates, select the Bypass initiation step during auto creation check box. 

If you select this option, the auto-created BP or planning item will skip the initiation step and 
will appear in the user's Tasks Log and BP Log or Planning Item Log with the status that was 
specified on the General tab of the business process setup window. For more information, 
see Auto-creating a Business Process record or Planning Item Based on conditions or 
frequency (on page 296). 

9) If you want to copy any records that are linked to the original record, select the Copy Linked 
Records check box. 
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10) (Not an option for line item creation.) If you are creating a record from a detail form, you can 
group line items into a single record. To do so, select the Enable grouping of line items 
when autocreating records from line item tabs check box. 

In the Group By field, click Select and select the data element (or elements) you want to 
group by. If the values in these data elements match for any of the line items, the system will 
auto-create a single record for them. For more information, see Grouping line items into 
single records (on page 298). 

Note: If you leave the Group By field blank, the system will auto-create a 
single record containing all the line items on the source record. 

11) Click Apply to save your changes, or OK to save and exit the window. 

You can find the reasons for the auto-creation failures in the audit log of the business process 
record. In addition, on occasion the system generates error codes for auto-creation failures 
which can be used to troubleshoot the auto-creation failures. 

Set up record and line item copy options 

Use this feature to set up copy options for users when they copy a record with line items and 
references. 

The options you specify here will give the user the ability to copy specific (rather than all) line 
items, as well as the ability to include attachments and linked records, and retain or remove 
references to auto-created records. 

To set up these options, you must create a condition the data element must meet in order for the 
line item to be included for these copy options. 

For example, you could create a set of options specifying that all line items with a status of 
"open" be copied, and their attachments be included in the copy. Using this example, you could 
set up a weekly meeting minutes business process that automatically generates action item 
business processes for each task that arises from the meeting. Using these copy options, you 
could roll over action items that are still open to the next week's meeting minutes. 

At runtime, the options you set up here will be given to users to choose from when they copy 
records. The following shows a list of BPs where the Record Copy option is supported: 

Type Sub-type Classification 

Cost Line item with WBS Code Generic 

Transfer 

Base Commit 

Change Commit 

General Spends 
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Line Item with Multiple Codes Generic 

Transfer 

Base Commit 

Change Commit 

General Spends 

Line Item Generic 

Transfer 

Line Items to filter 
company Business 
Process records 

To set up copy options 

1) Open the business process for which you want to set up the copy options. 

2) Click the Record Copy tab. The Record Copy Setup window opens. 

3) Click the Add button. The Copy Condition Setup window opens. 

4) In the Name field, enter a name for this copy setup. The name should be unique, and can be 
up to 250 characters long. 

This is the name that will appear on the list of copy options the user will see when they copy 
a record or line item. 

5) (Optional) In the Description field, enter a description of what this setup does. 

Note: For clarity, include a precise description of what the copy options 
are for the setup. This description will appear on the list of copy options 
the user will see when they copy the record, and a good description will 
tell them exactly what will be copied. You can enter up to 4000 
characters. 

6) Under the Condition area of the window, click the Add button. The Query Condition window 
opens. 

7) In the Data Element field, select the of the field on the line item form that you want to use to 
identify which lines items can be copied. 

8) In the Condition field, select the operator that the system should use to test the data 
element you selected. 

A condition is a state or restriction the value in the data element (field) must meet. A 
condition of the value might be that it must be equal to a certain number (maybe 10) or that it 
must contain a certain string of letters (such as "due date of"). 

If the data element meets the condition you specify, the system will include this line item on 
the list the user can choose from. Use the information in the Queries section to complete the 
query. 

9) Click OK. 
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10) On the Copy Condition Setup window, specify these additional copy options as shown in 
the table below. 

11) Click OK. 

Select this check box: To: 

Include Attachments Include attachments in the copy operation.

Copy Linked Records 
Include any linked records in the copy 
operation. 

Retain reference to auto-created business 
process records on record upper form 

Keep the references to business 
processes that were auto-created from the 
upper form. 

Retain reference to auto-created business 
process records on line items across all 
tabs 

Keep the references to business 
processes that were auto-created from the 
line item (detail) form. This applies to all 
line items from all tabs. 

Single-Record Business Processes 

Single-record business processes store information that you use repeatedly in your projects. 
Think of them as file cabinets where you keep things like industry standards; federal, state, and 
local regulations and statutes; policies; and FAQs. You can have multiple single-record business 
processes in a project, each with its own information focus. From these single-records you can 
auto-populate fields in business processes, including constant values. 

To facilitate single-sourcing of your data, create the single-record business process in the project 
or shell template prior to creating your project from the template. When you clone a project or 
shell template, you have the option to select BP Setup, which not only copies all business 
process setups, but all single-record business process records and their data. 

Data copied from single record business processes includes: 

 Attachments to records and line items, if applicable 

 All data pickers (Business Process, Configurable Managers, Shell Manager, User Attributes) 

 Any other pickers except business process pickers 

 Linked elements 

 Permissions associated with the single-record business process 

Copying a single record business process does not include: 

 Business process pickers 

 Linked records 

 Linked mail 

 General comments 
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You can also use CSV or web services to clone a shell or project template that contains the 
single record business process. 

To create a single-record business process 

Before you begin: 

 Ensure you have Setup permission for the business process. For more information, see 
Edit User or Group Permissions using Access Control in the Unifier General 
Administration Guide. 

 Follow the directions to set up a non-workflow business process. For more information, 
see Basic Non-workflow Set Up in General Tab and Settings Tab (on page 245). 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell] and on the right pane, open the 
template in which the single-record business process resides. 

3) In the left Navigator, click Information > General. 

4) On the right pane, open the single-record business process record and complete all required 
fields. 

5) Click Save or Submit, as appropriate. Both actions save the record, but Save leaves the 
record in Edit mode, and Submit leaves the record in a read-only state. 

Notes: 

 When you create a non-workflow BP record, you can only select a 
Status that is Active. 

 If you click Submit and the record is in a terminal status, you will not 
be able to edit that record again. 

6) Assign record permissions as appropriate. 

Set up View Forms for Non-Workflow Business Processes 

As an Administrator, for non-workflow BPs, you can set up different view forms so that details 
that are relevant to users are seen. 

Note: Up until now, a non-workflow business process had only one form 
(Action form) that held all the data. 

Assigning view forms to non-workflow BPs enables administrators to control the visibility of 
certain data to various users or groups. 

You can create view forms for all: 

 Non-workflow BPs regardless of the type. 

 Non-workflow BPs existing at both Project and Company Level 

 Non-workflow BPs of both Single Record and Multiple records 

Furthermore, the validations applicable to all: 

 Non-workflow BPs that only have one Action form. 

 Non-workflow BPs that have multiple view forms. 
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To add, remove, or edit view reports, open the non-workflow BP and follow the instructions in 
Set up View Forms for Workflow Business Processes (on page 288). 

If users have access to a deployed view form and that view form is deleted in uDesigner, at 
runtime, after a user opens the BP record, the system checks that user's permission to any of 
the BP view forms that exist in the setup. If the user does not have access to any of the BP view 
forms that exist in the setup, the system displays the Action form for that BP in view-only mode. 

Important information about deleting View Forms 

As indicated in the Unifier uDesigner User Guide, you can design a BP form (in the Staging 
environment), add view forms associated with a BP form design to the Business Process Setup 
(View Forms tab), assign permissions to users and groups for the individual view forms, and 
deploy the view forms so they can be accessed through the record preview in the log (Logs and 
Company Logs) for viewing record details. 

Due to the system limitations, an anomaly occurs when you delete a view form from the 
Business Process Setup. The following explains this anomaly: 

You have created and deployed the following view forms for a BP form ABC: 

 VF01 

 VF02 

 VF03 

You decide to delete one of the view forms. As a result, you navigate to uDesigner, delete the 
view form (for example, VF01), and ensure that the deleted view form has been remove from the 
Business Process Setup. 

You decide to add a new view form (for example, VF04), for the BP form ABC, so you proceed 
to add the new view form in uDesigner and deploy the new view form, VF04. 

At this point, due to the system limitations, the system will automatically add the newly created 
view from, VF04, to the Business Process Setup using the users and groups assignments 
originally assigned to the deleted view form, VF01. Furthermore, the availability of this added 
new view form (in the Business Process Setup) goes against the method that is used to deploy a 
new view form. 

As an administrator, you must ensure that in such scenario, you open the newly created view 
form and assign appropriate permissions.  

Additional information about View Forms for Non-Workflow Business Processes 

If a view form that users have access to gets deleted, then at runtime (when a user opens the 
Non-Workflow BP record), the system checks to see whether the user has permission to any of 
the view forms that exist in the BP Setup. If the user does not have access to any of the other 
view forms, the system displays the default form, the Action form, in view mode. 

Set up Record Properties for Non-Workflow Business Processes 

In both Non-Workflow BPs and Workflow BPs (at the company, shell, and project levels) you 
(the administrator) can use the Record Properties tab to establish:  
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 The availability or visibility of the BP form properties tabs for users and groups. 

 The ability to download attachments when users and groups access the BP records in user 
mode. 

The Record Properties tab has the following sections: 

Top: For setting up restrictions (setting restriction is done through Edit Restrictions) 

Left: For Upper Form and Line Item (detail forms) properties and setting up restrictions for 
downloading attachments from the Upper Form and Line Items (detail forms). The left 
section displays all of the record tabs seen in both upper and detail forms. In case of Simple 
type and Text type BPs, only the upper form properties tabs will be seen. The Upper Form or 
Line Item properties options that were hidden in uDesigner will not be displayed.  

Right: Users info (users or groups who cannot see the properties) 

The Record Properties window displays a read-only view of all the users and groups who are 
restricted to the visibility of selected tabs, or to download of attachments for selected tabs, in 
Edit Restrictions window. You can use the Edit Restrictions button to apply restrictions to 
users and groups. 

Restricting the Audit Log and Workflow Progress options below will result in the automatic 
update of the same options in Permissions Settings of Access Control. The same operation 
applies in reverse. 

The Attachments in Upper Form Properties section will not be shown for the system-defined 
Line Item tab in the Document type BP. 

The additional section Do not allow download of Attachments will show the users and groups 
who are restricted to download the attachments from Upper Form or Line Item tabs in the 
business process record, when the attachments are visible. 

The first tab seen in the Do not allow download of Attachments are the Upper Form 
Attachments followed by the Line Item tabs names (for example Gauges & Meters or 
Components) which will be in the same order as seen in the Line Item Properties. 

The Upper Form Attachments tab will not be shown for the Text type and Document type BPs. 
Additionally, the system-defined tab will not be shown for the Document type BP, under the Do 
not allow download of Attachments section.  

The tabs seen in the Upper Form and Detail Form properties will be based on each BP type. 

The tabs shown in Upper Form and Line item Properties will be in the same order seen in the 
BP record at run time. 

The Upper Form Properties and Line Item Form Properties which are already hidden in 
uDesigner will not be shown in this list. 

Example 
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If Linked Records and Linked Mail tabs, from the Upper Form Properties, are set to be 
hidden in uDesigner > Record Properties, then those two tabs will not be seen in the BP 
Setup under Upper Form Properties. Similarly, if the user-set Attachments tab in the Upper 
Form Properties is hidden in uDesigner > Record Properties, then in the BP Setup > Record 
Properties the user will not be able to see the following tabs: 

 Do not allow download of Attachments 

Upper Form Attachments 

 Upper Form Properties 

Attachments 

Adding tab visibility and download of attachments restrictions to users and groups 

You can add restrictions to the users and groups through the Edit Restrictions option. The 
restricted users and groups will be seen on the right block for the property selected on the left 
side. 

Edit Restrictions window: 

When you click the Edit Restrictions option, a window displays which lets you select or add 
user and groups and assign attribute form restrictions. The Select Users/Groups block (the 
left pane of the window) will be empty if there are no existing restrictions; otherwise, the 
block will list the existing restricted users and groups. Use the Remove option to remove the 
users and groups listed in this block. You can select one or more users or groups and select 
the Remove option to remove users or groups from the tab visibility restrictions. 

In the right section of the window, you can access and hide all of the following form 
properties: 

Hide All Upper Form Properties

 Attachments 

 Do not allow download of Attachments 

 Comments 

 Linked Records 

 Linked Mail 

 Workflow Progress 

 Audit Log 

 Reference Records 

Hide All Line Item Properties

 <Line item tab1 name> Attachments 

 Do not allow download of Attachments 

 <Line item tab2 name> Linked Records 

 <Line item tab2 name> Attachments 

 Do not allow download of Attachments 
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 <Line item tab2 name> Linked Records 

The Detail Form Attributes will be shown based on the Line Item tabs available in the 
selected business process. Additionally, users and groups can be restricted to download the 
attachments only from the business process record. 

If a single user or group is selected on the left side, the selected user or group's existing 
restrictions will be shown. 

The Cancel and Save options will remain disabled if you do not make any changes in the 
right block. If you select a user or group and change the restriction options, the Cancel and 
Save options will be enabled. The Cancel and Save options let you save or cancel the 
changes that you have made in the right block. 

After you close the Edit Restrictions window, the restricted users and groups will be added 
in Record Properties window. 

You can select multiple rows in Users/Groups section, edit the restriction check boxes, and 
save or cancel your changes. 

If multiple users or groups (on the left block) are selected, the existing restrictions will not be 
shown in the right block. 

In the Attachments case, a user who has restrictions to Download will be able to view or 
access the attachment but cannot download or save to a local system. 

Users/Groups window 

When you click Add, the User/Group window opens. This picker window displays all of the 
users and groups that are available and selected. After the users and groups are added, you 
can select the users or groups (from the left block) and set the hide permissions for the form 
attributes (in the right block). 

Note: Users or groups cannot be removed from the User/Group Picker 
window. You can use this picker window to add additional users and 
groups to the Edit Restrictions window. You can remove your added 
users and groups by selecting one or multiple rows in the Selected 
Users/Groups block. 

After you add restrictions in the Edit Restrictions window, the left block displays the list of 
all users and groups with restrictions to the form attributes. When you select a form attribute 
such as Audit Log or Comments, the right block displays the list of all the restricted users 
and groups. A user who has restricted access to selected record attributes like Audit Log, 
Comments, or Linked Mail viewing in the business process record will not see those tabs. 

Example 

User U1 has "Hide Upper Form Properties - Comments and Linked Records." At run time, 
when user U1 creates a business process record or opens an existing record, both 
the Comments and the Linked Records tabs will not be seen in the record. 

Attachments

When a user is restricted to only the download of the attachments, in user mode the user can 
view the attachments in the business process record but will not be able to download them. 
The Download option is removed from Attachments tab and also in Review window. 

In this case a restricted user who views the attachment in native view will see the attachment 
open in the Viewer and in read-only mode. 
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A restricted user will not be able to receive the attachments through email notifications 
received from a business process record for which the user has restrictions to download 
attachments. 

Line item Attributes

You can assign restrictions to users and groups for the Detail Form properties (Attachments 
and Linked Records for each Line Item tab). These additional Detail Form attributes will be 
seen only for the business processes that have the Detail Form defined in them. 

The Detail Form properties seen in the Record Properties window will vary for each business 
process and is based on the design. 

Users and groups can be restricted to download attachments from the Line Item tab, similar 
to the Upper Form, as described in the Attachments section above. 

Additional information

Users and Groups who have permissions to "Hide Record Audit Log" and "Hide Task Statuses" 
are added to the restricted users and groups viewers list in the "Record Properties" tab, in the 
business process setup. 

All of the record level and Line Item tab restrictions are available for all business processes 
(company, shell, and project levels) that supports standard UI. 

The restrictions are applicable to all users or creators, task assignees, step editors, record 
editors, and CC'd users who are part of the workflow in the record. 

Visibility of tabs will be applicable to both Action and View Forms when the user has tab 
restrictions to the BP. 

For Non-Workflow BPs, "Workflow Progress" (under the Upper Form properties) will not be 
available in the Record Properties, both at the design and at the setup level. 

For Company-level BPs, "Linked Mail" will not be available in Form Properties. 

For Simple and Text-type BPs, the option to hide the Detail Form properties will not be available. 

For Document-type BPs, "Attachments" will not be seen in the Upper Form Properties and the 
system defined tab in Line Item Properties. 

Note: The additional restrictions are not applicable to bid users. Bidders 
will be able to see all the attributes even though the requestor has 
restricted access. 

When certain form properties are hidden for a business process, those form properties are not 
shown in the Record Properties tab in the BP setup. 

If the users or groups do not have View permission, then the BP record tabs will not be 
displayed, at run time. This is applicable to both company sponsored and partner users. 

Projects or shells do not show Rich Text type DEs in the following scenarios: 

 When creating conditions for auto-creation elements in a BP setup. 

 When editing Gate settings and setting up Gate Condition Elements. 
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Assigning restrictions to users and groups will impact their ability to see the record properties 
tabs (tabs in the right pane, when the user opens a record) of the following nodes: 

 Logs 

 Drafts 

 Tasks 

 Master Log 

 Company Log 

 Single-Record BP Log 

 Portal BP Log 

Set up Permissions for Record Properties Tab (Non-Workflow) 

To set up permissions for the Record Properties tab:  

1) Go to the Company Workspace tab and switch to the Admin mode. 

2) Click Company Sponsored Shells to expand it, and select the <BP NAME> and open the 
BP (Workflow or Non-Workflow). 

3) Click Setup to expand it. 

4) Click Business Process, open <SETUP NAME>, and click the Records Properties tab. 

Setting up a Workflow Business Process 

The Business Process functional node contains the following sub-nodes: 

 Business process <BP Name> sub-node 

 The Workflow Setup sub-node 

The next two topics will provide detailed information about the sub-nodes. The procedures in the 
subsequent topics are applicable to project, shell, and company-level workflow business 
processes. 

Important information

After a workflow record is created by using any workflow schema (unique combination of Setup 
Name + Workflow Name), the workflow record continues to reference the workflow schema even 
if the Status of the workflow schema has been set to Inactive. 

This condition includes workflow records that are in the following statuses: 

 Draft 

 Initiation Step (I-Step) 

 Also, this condition includes any workflow record at any other step in the workflow. 

If there is an Active BP Template, the Template continues to create records referencing the 
Inactive workflow schema. For instructions on creating a template, see Creating BP Templates 
and Scheduling BP Creation in the Unifier Business Processes User Guide.  
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Business Process Node 

The business process <BP Name> node lets you set up specific information about that BP. 

When you click the business process <BP Name> node (listed under the Business Process
functional node), the <BP Name> Setup log opens. When you open the BP listed in the log, the 
Business Process Setup window opens showing the following tabs, which let you enter set 
specific information about that BP: 

General tab 

To see the BP name and description. You can use this tab to: 

 Add or remove a help file for that BP 

 Select who to send the error notifications to 

Settings tab 

To select the record editors from the User/Group Picker. 

View Forms tab 

You can add View Forms to the BP setup (Add > Select View Forms) and assign permissions 
(Permission Settings) to the users and groups (Viewers > User/Group Picker) for each 
individual view form. This lets you set up and use a different view from the one that is assigned 
to the workflow step. 

The users and groups will use the View Forms to preview a record and its details in the BP log. 

A user or group having permissions to multiple View Forms: 

 Will see the View Forms based on the sequence that is seen in the Forms list 

 Can apply the View Forms settings for when the Task Assignees and CC'd users view 
records 

If you select the Also apply View Form Settings when Task Assignees and CC'd users view 
records option in this tab, the system will override the view form of the workflow step design 
with the view form that the user has access to, through this setup. 

Record Properties tab 

To set up restrictions for Form Tabs and Attachments. 

You can restrict the ability of a user or group to view certain record tabs or download record 
attachments. Groups restrictions will override Users restrictions. 

Restricting the Workflow Progress and Audit Log options (under the Upper Form Properties) 
will result in the automatic update of the same options in the Permissions Settings (or Access 
Control). The same operation applies in reverse. 

Click the Edit Restrictions option to open the Edit Restrictions window for the BP. Use this 
window to select users or groups and determine restrictions for the following elements within the 
BP. You can also remove the users or groups, and their restrictions, in this window. 

 Hide All Upper Form Properties       

 Attachments 
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 Do not allow download of Attachments       

 Comments       

 Linked Records       

 Linked Mail 

 Workflow Progress 

 Audit Log       

 Reference Records 

Notification tab 

To set up the details for the following elements: 

 Send Notifications to:

 Notify Creator on Record Modification 

 Notify Assignee on Record Modification 

 Notify Cc on Record Modification 

 Notification Triggering Events:

Record Modification 

 Edit Upper Form 

 Add General Comments 

 Add/Remove Attachments  

 Attachments:

 Include both record and line item attachments 

 Include record information as attachment 

 Custom Notifications:

 Personal Tasks: 

 Decline Tasks: 

 Overdue Personal Tasks: 

 Messages: 

 Record Workflow Complete: 

 Record Modification: 

Auto Creation tab 

Use this tab to: 

 Set up the auto creation specifications for the BP. You can determine the action (Setup:), 
select users or groups (Creator:), and set up the specific action that the system must take 
(Action:). 

 Set up auto creation of other Business Process records or line items. 

More information about the tabs, and the fields within each tab, is provided in the preceding and 
following topics. 
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Workflow Setup Node 

Use the Workflow Setup node to: 

 Add or Edit Workflow Setups for the selected BP 

 Choose a workflow design and assign a name for the workflow setup 

 Determine the workflow status 

 Select which record format for Notification and Document Manager the system should use 

 Set details for the workflow settings such as phases and select users or groups who will be 
notified when the workflow is complete. 

To access the workflow setup fields, in the left Navigator, click the Workflow Setup functional 
node to open the Workflow Setup or Workflow Configuration window. The Workflow 
Configuration window has the following tabs: 

General tab 

Use the fields in this tab to: 

 Assign a name for the workflow setup 

 Determine the status of the workflow 

 Conduct an error check  

 Select which record format the system should use for Notification and Document Manager 
(you can also specify this per step as indicated in the previous topic) 

Settings tab 

Use the fields in this tab to set the details of the workflow and workflow steps. This tab is divided 
into two panes. The left pane shows the workflow and workflow steps. The right pane (Workflow 
Configuration) shows the properties of the workflow and workflow steps. 

When you select the top node <Workflow Name> from the left pane, you can set the following 
parameters in the Workflow Configuration (the right pane): 

 Workflow Settings 

 Enable Workflow Duration

 Workflow Duration

 Override Workflow Due Date

 Phases 

 Allowed in all phases

 Allow only in phases

 Additional Information

 Notify users or groups on workflow completion:

Lets you select users or groups who will be notified when the workflow is complete. 

As mentioned above, the Custom Notifications lets you determine whether the default 
notification must be sent or a customized one (determined by the email notification elements 
selected on the view form in the BP design). 
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If you select a user or group in the Send Notifications to: field (in the Notification tab) and do 
not select a user or group for the Notify users or groups on workflow completion field, the 
system will only send the email notification to the selected users (indicated in the Send 
Notifications to: field) if one of the following triggering events occur: Edit Upper Form, Add 
General Comments, or Add/Remove Attachments. 

The Custom Notifications fields: 

 Are used only for specifying what type of email notification template to use for different email 
notification types 

 Are not related to any of the triggering events 

If you want an email notification to be sent when the workflow is complete, or at the end step, 
you must set up the specifics when you are setting up the workflow because when you are 
setting up the workflow you can determine the step-specific notifications that are triggered by the 
BP record moving from one step of the workflow to the next step. 

When you select a sub-node <Step Name> from the left pane, you can set the following email 
notification options in the Email Notification block: 

 Email Response: Enable response via email

To allow the user to respond to an email.  

 Email Attachments:

To allow the user to: 

 Include both record and line item attachments

 Include record information as attachment

 Override default format

 Format:

To allow the user to select a print format: 

 PDF

 Custom

 Email content

To allow the user to include the email content. 

Note: Within all the steps, the Additional Information block lets you 
select to Save Record Information to Document Manager. 

Basic workflow setup in General tab 

To set up a workflow business process 

1) From the Business Processes log, select a BP and click Open. The Setup log opens. 

2) Click New. The Select Workflow window opens. 

3) Click the Workflow selection list and click OK. The Business Process Setup window opens. 



Setting up Business Processes

267

Note: You may configure a setup for multiple workflows by repeating this 
procedure for each workflow available for the business process. 

4) Complete the General tab (see the table below). 

In this field: Do this: 

Setup Name Enter a unique name (required field). 

Description Enter an optional description of the setup. 

Help File Lets you add a custom PDF help file. 

Auto Creation Workflow 
The workflow to use for the auto-created 
BP. Workflow Setup in General and 
Setting Tabs (on page 273). 

Auto Creator 
Select the name to use as the creator of 
any auto-created records of this BP. 

Auto Action 
Select the step to use as the first step in 
the workflow of auto-created records. 

Send error notification to 
Specify the user to receive error 
notifications. 

Default Record format for Notification and 
Document Manager 

This option has two purposes: 

 If you want notification sent to users 
whenever a business process record is 
created or modified, use this option to 
specify the format in which you want 
the notification to be sent. 

 If you have checked the Save Record 
Information to Document Manager 
check box, use this option to specify 
the format in which the business 
process records should be saved. 

Selecting BI Publisher/Oracle Analytics Publisher Custom Print (Format > Custom) 

The following is a list of conditions applicable to BI Publisher/Oracle Analytics Publisher Custom 
Print. 

Only Published BI Publisher/Oracle Analytics Publisher Custom print templates can be selected 
while setting up the Business Process; however, if you make any changes to the Published 
template and do not re-publish it to the BI Publisher/Oracle Analytics Publisher server, the 
selected template will continue to remain in the Business Process (BP) setup option. 

 If the BP setup has been done in a Project/Shell template, the setup will get pushed when 
you update the setup information onto instances of Projects/Shells. 
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 If you delete the BI Publisher/Oracle Analytics Publisher Custom Print template selected in 
the BP Setup window, the system removes the deleted BI Publisher/Oracle Analytics 
Publisher Custom Print template from the BP setup. 

 If the system does not generate the print output, for example due to server issues, the email 
attachment, which contains the record information, generates an error message. 

 Custom Print template included in the BP setup can be exported in the Configuration 
Package. By virtue of tagged BP design, the corresponding BP Setup from the tagged Shell 
template will also be included. If the Custom Print Template is not tagged, the Configuration 
Package export will result in an error. 

Note: If the BI Publisher/Oracle Analytics Publisher Custom Print output 
could not be generated because of connection issues to the BI 
Publisher/Oracle Analytics Publisher server or inconsistencies in 
between Custom Print on Unifier and the BI Publisher/Oracle Analytics 
Publisher server, the notification emails for Business Process 
modification will have an "error.html" document (as an attachment) 
instead of a record information document. In such a case, if the record 
information is Published to the Document Manager, a 0 KB document 
will be published. 

Designate additional editors for Business Process records 

Normally, the editors of any record must be an assignee on the step of the workflow. However, 
there are times when a record may need editing by someone other than the step assignees. For 
example, the owner of a purchase order record should be able to attach revised documents to 
the PO at the end step of the workflow. Or an engineer who has sent a task to an architect 
realizes that some drawings are missing from the record. The engineer should be able to attach 
the documents to the record, even though the task assignee is now the architect. 

The Settings tab is where you can designate non-assignee editors for business process records. 
(These editors must have permission to at least view the record.) Editors designated on this tab 
can open records and modify the upper or line item content of the record. Changes made by 
these editors are recorded in the audit log. Whereas step assignees will see the form that is 
attached to a step, the record editors you designate on this tab will see a specific form for 
editing. This form must be specified when the business process is created. 

Note: The editors you specify on this tab are record-level editors. You 
can designate additional editors at the step level when you set up the 
workflow. See Define the Business Process Workflow (on page 275) 

To designate additional editors for records 

1) Click the Settings tab. 

2) In the Record Editor(s) field, click the Select button and choose the users or groups who 
should have editing privileges on this record. 

3) Click Apply to save these settings. 
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Set up Email Notification for a Workflow BP 

Use the Notification tab to set up automatic email notifications to users and groups whenever a 
workflow business process is created or modified, either manually, or via auto-creation, reverse 
auto-population, CSV, or integration. 

If the business process has been designed to allow users to include additional users or 
groups in the email, the email notification will be sent to them as well.  

The values that you must use to customize your email notification (these values appear in 
the drop-down fields of the Custom Notifications block in the Notifications tab) are set in 
the Company Workspace (Admin mode) > Configuration > Business Process > open 
<BP_NAME> > Customize Email > Content > Email Content log. You can see the existing 
templates, or create templates, in the Email Content log. To create a template, click Create
to open the Create Template window. Enter a template name and from the right pane 
(Available Data Elements) select the language and the elements that you want in your new 
template, and click Save and Close. Your changes will appear in the Notification tab within 
the fields listed in the Custom Notifications block. See the following for more details. 

When a notification triggering event occurs, if users or groups have been identified, then the 
system will notify the identified users or groups through the default system notification or the 
customized email template (specified in the Custom Notifications block in the Notifications
tab). 

To set up the email notification for a workflow BP 

Note: The system sends emails for reverse auto-population failures. 
There may be cases when email notifications are not sent. For such 
cases, you can find the reasons for the reverse auto-population (RAP) 
failures in the audit log of the business process record. In addition, the 
system occasionally generates error codes for reverse auto-population 
failures, which can be used to troubleshoot the failures. 

1) Go to the project/shell tab and switch to Admin mode. 

2) In the left Navigator, click Setup > Business Process to open the Business Processes
log. 

3) In the log, select and open the BP that you want to set up the email notification for. The 
Business Processes Setup window opens showing the following tabs: 

 General tab 

 Settings tab 

 View Forms tab 

 Record Properties tab 

 Notification tab 

 Auto Creation tab 

4) Click the Notification tab. 
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Use the information below to complete the fields in the Notification tab. Click Apply to save 
your changes and OK to exit. 

Send notifications to:

1. Click Select to select users or groups that should be notified whenever the workflow 
business process is created or modified. 

2. Select one of the following options, if applicable: 

 Notify Creator on Record Modification

Select this option if you want the BP creator to be notified when the BP is 
modified. 

 Notify Assignee of Record Modification

Select this option if you want the step assignees to be notified when the BP is 
modified. 

 Notify Cc on Record Modification

Select this option if you want the step users or groups who have been Cc'd to be 
notified when the BP is modified. 

Notification Triggering Events:

Based on your need, you can select all or some of the following triggering options that are 
listed under Record Modification: 

 Edit Upper Form

Select this option if you want the system to send notification when the upper form of a BP 
record is changed. 

 Add General Comments

Select this option if you want the system to send notification when a comment is added to 
a BP record. 

 Add/Remove Attachments

Select this option if you want the system to send notification when an attachment is 
added to, or removed from, a BP record. 

Attachments:

 Include both record and line item attachments

Select this option if you want the system to include both the record and the line item 
attachments. 

 Include record information as attachment

Select this option if you want the system to include the record information as an 
attachments. 

Custom Notifications:

 Personal Tasks:

To select a custom email notification format for personal tasks. 

 Decline Tasks:

To select a custom email notification format for declining tasks. 

 Overdue Personal Tasks:
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To select a custom email notification format for overdue personal tasks. 

 Messages:

To select a custom email notification format for messages. 

 Record Workflow Complete:

To select a custom email notification format for completed workflows. 

 Record Modification:

To select a custom email notification format for record modifications. 

Set up auto-creation for a workflow BP 

On the Auto Creation tab, you can set up this business process to automatically create another 
record or line item for this business process. You can also set up this business process to 
automatically create other business processes, planning items, or line items if the form includes 
a creator element. 

For information about auto-creating business processes or planning items, see Auto-creating 
BP Record or Planning Item Based on Conditions or Frequency (on page 296).  

The data elements of type Rich Text are not available to create conditions for auto-creation 
elements in a BP Setup (Company Workspace > BP Setup and Shell > BP Setup). 

When a line item is auto-created (by using the line item auto-creation logic), the values in the 
fields on the line item that are based on a data picker in that line item will not be auto-populated. 

To set up auto-creation of a workflow business process 

1) Click the Auto Creation tab. 

2) Under Settings for auto creation of [name of the business process, planning item, or line 
item you are setting up], complete the following fields as shown in the table below (at the end 
of this topic). 

3) Under the section Settings for auto-creation of other business process records or line 
items, select the creator element under the upper or detail form. The Auto creation of line 
identifies the business process or the line item that the creator element you selected will 
create.  

4) (Not an option for line item creation.) In the Assignee/Creator field, click the Select button 
and choose the name of the user or group who should assume ownership of the 
auto-created record. 

5) (Not an option for line item creation.) In the Duration field, specify the duration of the 
workflow to ensure a due date is calculated and displayed for the auto-created record.  

6) If you want the auto-created record to include attachments from the original (source) record, 
select the Include Attachments check box. 

If you select this option: 

 Any record-level attachments made to the source record will appear at the record level of 
the destination record. 

 Any attachments made to the line items of the source record will appear at the line item 
level of the destination record. 
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Note: This step is not applicable for Document type business processes. 

7) (Not an option for line item creation.) If you want to bypass the I step that this auto-creation 
normally creates, select the Bypass initiation step during auto creation. 

If you select this option, the auto-created BP will skip the initiation step and will appear in the 
user's BP log at the appropriate step in the workflow. (For more information, see 
Auto-creating BP Record or Planning Item Based on Conditions or Frequency (on page 
296).) 

8) If you want to copy any records that are linked to the original record, select the Copy Linked 
Records check box. 

9) (Not an option for line item creation.) If you want to group line items into a single record, 
select the Enable grouping of line items when autocreating records from line item tabs
check box. 

In the Group By field, click Select and select the data element (or elements) you want to 
group by. If the values in these data elements match for any of the line items, the system will 
auto-create a single record for them. For more information, see Grouping line items into 
single records (on page 298). 

Copying line items is limited to a single picker or a single referenced data element. 

Note: If you leave the Group By field blank, the system will auto-create a 
single record containing all the line items on the source record. 

10) To create the conditions that will trigger the auto-creation, select the Enable condition 
based auto creation check box and continue as follows: 

Note: If you leave this check box un-checked, the BP, planning item, or 
line item will be available for manual creation only. 

a. To add a trigger condition, click the Add button. The Add Condition window opens. 

b. On the General tab, enter a name for the trigger and a description. 

c. Click the Query tab. 

The Query tab is where you will define the conditions the data must meet before the 
system will auto-create the new business process record or line item.  

In the upper section of the window, you can specify that a field on the business process 
form: 

 Must meet a certain criteria or value 

 Must meet a certain value based on a formula using the numeric fields on the form 

Click the Add button to specify a condition for a field on the business process form. Click 
the Add Formula button to create a formula that the value of the field must meet. Use the 
information in the Queries section to complete the query. 

Select the match ANY condition (instead of ALL) check box if the query can match any 
single condition to extract the information. If the query must match ALL conditions, leave 
this check box deselected. 

In the lower section of the window, you can specify a date condition that will trigger the 
auto-creation. Use the information in the Queries section to complete the query. 
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Date condition triggers are not available for line item auto-creation. 

About Date Triggers: 

 If you want to create a continual date trigger condition, make sure you use the 
Date Trigger Condition section of the window to create it. Although you can 
also create a date trigger using a formula in the upper section of the window, 
the system will process the triggers differently. 

 The conditions you specify in the upper section of the window will be 
processed only once, when the user clicks the Send button on the form to send 
the form to the next step in the workflow. However, the date conditions you 
specify in the Date Trigger Condition section will be processed daily. 

 This behavior is important to consider when you are creating a date condition 
that occurs in the future. A date trigger specified under the Date Trigger 
Condition section will be processed daily, and will, therefore, "catch" the trigger 
condition when the future date occurs. 

d. Click OK. 

11) Click Apply to save your changes, or OK to save and exit the window. 

In this field: Do this: 

Setup 
Specify the workflow setup that the 
auto-created business process or planning 
item should use. 

Creator 

Click the Select button and choose the 
name of the person or group who should 
assume ownership of the auto-created 
record. 

Action 

Specify the step in the workflow that 
should be used as the first step in the 
workflow of the auto-created BP or 
planning item records. 

You can find the reasons for the auto-creation failures in the audit log of the business process 
record. In addition, on occasion the system generates error codes for auto-creation failures 
which can be used to troubleshoot the auto-creation failures. 

Workflow Setup in General and Setting Tabs 

This section explains how to set up workflows. Workflow setups can be time-consuming. The 
system offers other options of copying workflow setups. To use these options, see Copying 
Workflow Setups from Other Schemas (on page 304).  

1) In Admin mode: 
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 To set up a workflow in a company level business process, go to the Company 
Workspace tab and click Company Workspace > Business Process Setup in the 
Navigator. 

 To set up a workflow in a project/shell level business process, click the project or shell 
tab and, in the Navigator, go to Setup > Business Process. 

2) On the right pane, double-click the business process you want to set up. 

3) In the Navigator, click Workflow Setup and on the right pane, double-click the name of the 
workflow you want to set up. 

The Workflow Setup window opens. 

4) Complete the General tab for the workflow. See the table below. 

5) Click the Settings tab to configure the workflow. Define the Business Process Workflow
(on page 275). 

You can filter assignees (Assignees block) and use some specific conditions on filtering the 
users. 

To create the conditions you must choose among the list of the user attributes that are 
available. After you select an assignee, from the Assignee drop-down list, for the selected 
workflow step, click Define (next to the Additional conditions to filter assignees option) to 
define the additional conditions in the pop-up window. When finished, click Add and then 
click the drop-down field and select: 

 User Attributes from the company (Company Workspace): Represented with a prefix 
"Company/" 

 User Attributes defined at project-level or shell-level: Represented with a prefix "Shell/" 

The same conditions apply to Allow Cc field. 

When the setup is complete, return to the General tab and click the Error Check button. This 
validates the setup, including checking that all steps have assignees. An error window opens 
identifying any errors that will prevent the setup from being activated. 

If there are no errors, click OK in the Setup window. You will be prompted to activate the BP. 
Click Yes to activate the BP and make it available to users, or click No to keep the BP inactive 
until a later date. 

In this field: Do this: 

Setup Name 
Enter a workflow business process setup 
name. 

Description 
Enter an optional description of the 
workflow setup. 

Status Select Active or Inactive. 

Error Check 
Click to check the workflow for errors when 
the workflow setup is complete. 

Default format of record information 
attached to email notification 

Select PDF of Custom. If you select 
Custom, click Add to choose the custom 
print format. 
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Define the Business Process Workflow 

In the Settings tab of the Business Process Setup window, you can configure the workflow 
details. The workflow step settings are arranged in a tree structure, showing all of the steps. 
From here you can set up the overall workflow setup, individual step setting, steps that lead to 
conditional routing, links with auto-creation of a business process, and sub-workflow 
settings. These procedures are applicable to project- and company-level workflow business 
processes. 

Overall Workflow Settings 

The following describes the settings for the overall workflow. Select the top option in the left 
navigation pane to access these settings. Click the scroll bar on the right to scroll down the 
window and view all fields. 

 Enable Workflow Duration: When Yes is selected, records created with this instance will 
be marked as late when the defined amount of time passes. 

 Workflow Duration: You can optionally set the duration of the workflow. 

 Override Workflow Due Date: User can override the due date for the workflow. Be sure to 
select Yes for this option if you are using Scope Management and have selected Enforce 
Activity Finish Date for the Record Due Date for the activity business process. For more 
information, see Setting up Scope Management for Activities (on page 511). 

 Project Phase (Project-level BPs only): Setup is valid only during the specified project 
phase. This is not applicable for company level BPs. 

 Notify users or groups on workflow completion: Selected users or groups will be notified 
after the workflow is complete. 

Settings for Standard Workflow Steps 

This setup is for standard workflow steps. The Settings tab displays the steps that are available 
for the selected BP, and therefore will vary depending upon how the BP has been designed. Not 
all selections discussed below will be available for all workflow steps. In addition, depending on 
the BP design, not all fields will be editable. The following is primarily an example of a creation 
step. Click the scroll bar on the right to scroll down the window and view all fields. 

Select a workflow step to access these settings. 

About Create and End Steps 

The Create and End steps in a workflow have unique characteristics you should be aware of 
during the design and setup of the workflow. 

For the Create step: 

 In uDesigner: 
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 You can rename the Create step to something else if you want. 

 You can place only outgoing links on the Create step. 

 You can attach only action forms to the Create step. 

 You cannot send a link back to the Create step. If the workflow requires that a form be 
sent back to the creator (Create step), add a separate "back step" or "revision step" that 
will send the form back to the creator. 

 In Unifier Administration: 

 You cannot "Cc" users on the Create step. 

 A workflow cannot send a link back to the Create step. If the workflow requires that a 
form be sent back to the creator (Create step), the workflow design should include a 
separate "back step" or "revision step" that will send the form back to the creator. If your 
workflow includes such a "back step," specify match step <Creation> for the Assignees 
on that step. 

For the End step: 

 In uDesigner: 

 You cannot rename the End step. 

 You can place only incoming links on the End step 

 You can attach either an action form or a view form to the End step. 

 In Unifier Administration: 

 You can "Cc" users on the End step. 

 You can send the form to the editors who have been assigned to the form. 

 You can add comments to a business process at the End step, and also at any status in 
a workflow, including "terminated." 

In this field: Do this: 

Step Name 

You can click the link to view a graphical 
representation of the workflow, with the 
current step highlighted. Be aware that 
workflows can often be very large. If you 
are viewing a large workflow, you can 
enlarge the canvas screen to make it 
easier to see all the steps to the workflow 
progression. 

To enlarge the canvas, you can drag the 
window sides until the workflow fits in the 
window, or you can quickly maximize the 
canvas. To maximize the canvas, click the 
icon in the upper-right corner of the 
window. To restore the canvas window to 
its normal size, click the Restore icon. 
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In this field: Do this: 

Description 
Enter an optional description to help 
identify the workflow. 

Duration Choose the time length for this step. 

Override Task Due Date 
Allows user to override due date for an 
individual task. 

Allow Assignees to Decline Task 
Click Yes if you want the assignees to 
have the ability to decline an action on an 
assigned task. 

Enable Step for Integration 

Click the radio button if you want this step 
to be available for integration with an 
external system, such as Web Services. If 
you make the step available for integration, 
the user can use the external system to 
view a read-only copy of the BP at that 
step. 

Note: If you select this option, the 
Completion Policy field (see below) will be 
set to "Single," and the Assignment Policy 
field for the following step must be set to 
"Preassigned." 

Assignment Policy 

For User Select (default), the individual 
who creates a record (such as an invoice) 
from this workflow instance can choose the 
users to assign to this task from the list of 
assignees for this step. For Preassigned, 
every user on the assignee list is 
automatically assigned to the step when 
the record is created. 

Assignees 

Select the users to assign to this step. 
These users will receive task notifications, 
instructing them to take action at this step. 
When you click the Select button, you can 
choose one these options: 

User Picker: The system displays the 
User/Group Picker window. Choose one or 
more users or groups to add as assignees.

Dynamic: Choose a step in the workflow 
from the Select Step pop-up window. The 
assignees from that step become the 
assignees used on this step. You cannot 
choose Dynamic when adding assignees 
to the first step (Creation) in the workflow. 
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In this field: Do this: 

You can constrain the list of assignees for 
this step by selecting the Additional 
conditions to filter assignees check box. To 
constrain the list of assignees, you must 
create a query to filter the assignees using 
criteria you specify. To do this, click the 
Define button and specify a field 
comparison. For information on creating 
this type of query, use the information in 
the Queries section to complete the query. 
If you filter the assignees, the group 
names will not be visible to users in the 
Workflow Action Details dialog.  

The filter conditions defined are used, as 
AND/OR, depending on the check box: 
Show results matching any condition 
(instead of All)

Allow Cc 

Allows assignees to add cc users who will 
receive a view-only copy of the BP record. 
Choose one of the options: 

No: Does not allow sending copies to 
other users. 

Yes: Click Select to create the list of users 
or groups from whom the BP users can 
choose to Cc. (This option also activates 
the Allow Add Cc functionality.) 

Preassigned: Click Select to choose the 
users who will be automatically cc'd. No 
other users can be copied. 

Preassigned and Allow Add Cc: Click 
Select to choose the users who will be 
automatically cc'd. The Allow Add Cc 
option is set to Yes. 

Note: You cannot allow Ccs on the Create 
step. 

You can constrain the list of Cc users for 
this step by selecting the Additional 
conditions to filter Cc users check box. To 
constrain the list of Cc users, you must 
create a query to filter the Cc users using 
criteria you specify. To do this, click the 
Define button and specify a field 
comparison. For information on creating 
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In this field: Do this: 

this type of query, use the information in 
the Queries section to complete the query. 
If you filter the Cc user list, the group 
names will not be visible to users in the 
Workflow Action Details dialog.  

The filter conditions defined are used, as 
AND/OR, depending on the check box: 
Show results matching any condition 
(instead of All)

Allow Add Assignees 

Allows assignees to add additional 
assignees in addition to those defined in 
the Assignees field to the current step. 
Assignees can add the additional 
assignees before accepting the task. This 
is done by clicking the Edit menu and 
choosing Add Assignees to Current 
Step. 

For example, user A has been sent a BP 
for review. User A wants to add user B as 
an assignee to the review step as well. 
Before clicking Accept Task, user A 
chooses Edit > Add Assignees to Current 
Step and adds user B. User B is notified 
(depending on email preferences) of the 
new task. Both user A and user B can 
accept the task and participate in the 
review step of the workflow. 

Note: You cannot add assignees on the 
Create step. 

Allow Add Cc 

This option has two functions: 

1. When the Allow Cc field is set to 
Preassigned and Allow Add Cc, this option 
is set to Yes automatically. It enables BP 
users at runtime to copy additional users 
on a BP step that already has a 
preassigned cc user. This is done on the 
action form of the BP during the regular 
workflow step by selecting the Cc button. 
Click Select and choose the users/ or 
groups that can be copied. 

2. This option becomes available (choose 
Yes or No) if Allow Cc is set to Yes. Similar 
to Allow Add Assignees, this option allows 
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In this field: Do this: 

assignees to send a copy of the current 
step of the BP to additional users in 
addition to those defined in the Add Cc 
field. Assignees can add the additional cc 
users before accepting the task. This is 
done by clicking the Edit menu and 
choosing Copy Users to Current Step. 

For example, user A has been sent a BP 
for review. User A wants to add user B as 
an assignee to the review step as well. 
Before clicking Accept Task, user A 
chooses Edit > Add Assignees to Current 
Step and adds user B. User B is notified 
(depending on email preferences) of the 
new task. User A can accept the task and 
participate in the review step of the 
workflow. User B can review the view-only 
copy. 

Note: You cannot add Ccs on the Create 
step. 

Step Editors 

Optionally, you can define one or more 
editors per each defined step in the 
business process workflow setup. Editors 
are users who can edit the business 
process without being granted explicit 
record-level permission or as assignees of 
the step. This allows users other than the 
assignee to edit the business process 
record. If you are an Editor on a business 
process step, you can open and edit any 
record on the step. 

Editors can be added on these BP types: 

Line Item 

Cost (all types, including Lease and Line 
Item with Multiple Codes) 

Document 

Simple 

RFB 

Text 

The Editor functionality has these 
attributes: 

The user who is designated as an editor 
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In this field: Do this: 

must have a minimum of View User 
Records to the BP log in question. 

All edits are done through the BP Log. 

Editors cannot edit a workflow record until 
the task assignee accepts the task, and 
saves the draft. 

Editors cannot be defined on the creation 
step of a business process. 

Editors can be defined on the end step. 

Editors can be defined on a workflow step 
only if the Completion Policy is Single. 
(The system will generate an error if 
Completion Policy is set to All Majority or 
Consensus.) 

Editors on a task receive notification each 
time a draft is created. 

If multiple editors and the assignee are 
editing the business process record draft, 
the data saved by the last update will 
overwrite all previous updates. 

Edits performed on the End step of a 
workflow business process affect the 
record directly, as no draft exists. 

Edits that occur on the end step are 
captured in the audit listing the editor who 
performed the edit. 

Edits performed by record editors appear 
in the Audit log. 

Note: You cannot assign editors on the 
Create step. 

Step Revisiting 

If a step is rejected and sent back for 
clarification or editing, this option 
determines to whom the BP can be sent 
back (which assignees will be available for 
selection): 

Include only previous action takers:
Only the assignee users who were 
selected when the workflow moved into 
that step originally are eligible to be 
reselected. 

Include all step assignees: All assignee 
users are eligible to be selected. 

Note: You cannot specify step revisiting on 
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In this field: Do this: 

the Create step. 

Completion Policy 

Choose one of the following: 

 Single: If any assignee completes the 
task, no matter which action is taken, 
the record moves forward to the next 
step. 

 All-Majority: All assignees are 
required to respond. If there is no clear 
majority, the system uses the resolving 
action to determine what path through 
the workflow to take. 

 All-Consensus: All assignees are 
required to respond. If there is no 
consensus (all must agree on the 
action), the system uses the resolving 
action to determine what path through 
the workflow to take. 

Note: You cannot assign a completion 
policy on the Create step. 

Advance workflow when next step is 
determined 

Select this option if you want to allow the 
user to choose that a step be completed 
without all assignees having to act on it, if 
the result can be determined without the 
assignee action. This is to prevent users 
unnecessarily waiting to take action on the 
record before moving it to the next step. 

Note: If you select the Completion Policy 
as "All - Majority" or "All - Consensus", the 
system enables this check box. The check 
box is deselected by default. 

Resolving Action 

This moves the step to either a following 
step, a previous step, or a conditional step 
that essentially "re-addresses" the task. 
This step must be completed before the 
workflow can continue. The assignees on 
this resolving action step can include the 
original task assignees and can also 
include new assignees. 

Note: You cannot assign a resolving 
action on the Create step. 

Overdue Policy 
You can choose to send late notifications 
to all assignees if the step passes its 
duration. 
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In this field: Do this: 

Note: You cannot assign an overdue 
policy on the Create step. 

Comments 

For the Creation step, you have the option 
to select Do not allow creators to add 
hidden comments to prevent users from 
adding hidden comments.  

For steps other than Creation, other 
comment-related options are available. 
These other options refer only to the 
general comments on BP forms. 

Allow assignees to hide/unhide their 
own comments: Allows users to show or 
hide their own comments. The comments 
will remain as part of the record, and 
administrators and others with permissions 
can view the comments, which are not 
visible to others without the view 
permission. 

Allow assignees to delete their own 
comments: Allows users with permission 
to delete comments that they previously 
added to the BP record. 

Allow assignee to delete/hide/unhide all 
comments: Allow assignee users in the 
specific workflow step to hide, show, and 
delete their own comments and comments 
added by other users comments added in 
the previous workflow steps. It also allows 
users to update comments added in 
previous steps of the workflow. 

Allow CC users to add general 
comments: Allows users copied on a step 
to add comments on the selected workflow 
step. Not available on the end step. 

Allow CC users to add hidden 
comments: Allows users to hide 
comments that they add to a business 
process. This option is available only if 
Allow cc users to add general 
comments is selected. 

Note: Task assignees can always add 
general comments without accepting the 
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In this field: Do this: 

task. 

Email Response: Enable response via 
email 

By default, this check box is deselected. 
When enabled, if a workflow reaches the 
current step, and the system sends an 
email, then the user can respond to the 
email (in Unifier). The check box appears 
on all workflow steps other than the 
creation step. The email that the user 
receives includes hyperlinks to workflow 
actions. 

When you are taking an action in a 
Workflow by way of email, if you include 
attachments, the attachments can be seen 
under the General Comments section of 
the BP record. 

Notes:

- You cannot enable email response on the 
Create step. 

- To enable the attachment of files to email 
responses to workflow actions, this option 
must be selected as well as the Add 
Attachments option on the Options tab in 
the Action Form design. 

Email Attachments: 

Include both record and line item 
attachments 

Include record information as attachment 

Select to specify the content and format of 
email attachments. You can include 
business process record and line item 
attachments, as well as business process 
record information. Also, you can override 
the attachment format set in the General 
tab if necessary. 

Note: You cannot enable email 
attachments on the Create step. 

Override default format 

If you have specified a default record 
format on the General tab, you can use 
this check box to override the default 
format. For example, you can use the 
General tab to specify that the default 
record format for both email notifications 
and records saved in the Document 
Manager be in PDF format. If necessary, 
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In this field: Do this: 

you could then use the Override default 
format check box to override the format 
and choose Custom for the notification 
only. 

Note: Hidden comments on a particular 
step in the Workflow and permission 
settings applied to certain data in the UI 
are retained in the custom print output. 

Email Content 

You can add additional information that will 
be sent out as part of task notification. 

Note: You cannot add additional 
information on the Create step. 

Cash Flow Default Template 

This option only appears in CBS 
code-based Base Commit business 
processes. It lets you enable the 
auto-creation of a commitment-level cash 
flow curve at runtime for the business 
process record. The curve is based on the 
selected commitment-level cash flow 
template, and is created upon being sent 
from the step. 

Click Add and choose a template. 

For more information, see Setting up 
Auto-Creation of Cash Flow Curves 
from Contracts (on page 302). 

Additional Information 

Save Record information to Document 
Manager 

Select this check box if the record 
information (including BP comments and 
attachments) should be automatically 
saved at this step in the Document 
Manager. 

About Completion Policies, Resolving Actions, and Their Statuses 

As an administrator, you will set a completion policy on each step in a workflow. This policy 
determines when the step is complete and where the step proceeds from there. A step can be 
complete under the following conditions: 

 Any single user can accept a task and complete it, and the record will move forward to the 
next step. This is called a single completion policy. 

 All assignees to the task have responded to it and a majority has agreed on the action that 
moves the record forward to the next step. This is called an all-majority completion policy. If 
there is no clear majority on the action, the system will use a resolving action to determine 
how the record moves forward. 
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 All assignees to the task have responded to it and all assignees have agreed on the action 
that moves the record forward to the next step. This is called an all-consensus policy. If 
there is no consensus on the action, the system will use a resolving action to determine how 
the record moves forward. 

A resolving action moves the step to either a following step, a previous step, or a conditional 
step that essentially "re-addresses" the task. This step must be completed before the workflow 
can continue. The assignees on this resolving action step can include the original task 
assignees and can also include new assignees. 

The statuses you see on this window are internal to the system and are used only to display the 
status of the workflow step relative to the completion policy. These statuses are: 

 Not Started: The assignee has not accepted the task. 

 In Progress: The assignee has accepted the task. 

 Locked: This status is used when the step has a single completion policy and one of the 
assignees accepted the task. This status denotes those assignees who were also assigned 
to the task, but because of the single completion policy, the task was locked and these 
assignees no longer have access to it. 

 View Only: This status indicates that this user was cc'd on the task, but is not expected to 
take action on the task. 

 Completed: This status is given to an assignee's action if the task was finished and needed 
no resolving action. At any step, a task can have only one status of "Completed." 

 Closed: This status is given to an assignee's action if the task was finished, but triggered a 
resolving action. The task will either return to a previous step, move forward to a next step, 
or divert to a conditional step, which will resolve the condition and move the task forward in 
the workflow. The step the action moves to for resolution will show a status of "Not Started." 
The number of times the task shows a "Closed" status indicates the number of times the 
step has been revisited. 

Settings for Conditional Routing Steps 

Conditional routing steps are child nodes of the steps that lead to the condition routing. 
Auto-routing steps are shown with a diamond in front. Set up routing conditions on these steps. 

Remember that the next step in the business process workflow will be dependent upon the value 
entered on the BP for the data element. When you are finished setting up this conditional routing 
step, the Settings tab will show two steps that represent the two options for the step that follows 
this auto-routing step. You define both of them, but the BP will follow just one of them based on 
the trigger. 

In this field: Do this: 

Condition Name 
Name of the condition. Can be configured 
for each setup. 

Resolving Condition 
Select this check box if this routing action 
goes to a step that is meant to resolve the 
condition. 

Operator AND: All the conditions that are defined 
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In this field: Do this: 

should be satisfied to satisfy a condition. 

OR: At least one of the conditions should 
be satisfied to satisfy a condition. 

Trigger Elements 

Elements that are selected as part of 
design. Value of these elements will be 
resolved to route workflow. Can be one or 
more elements depending upon design. 

Settings for Auto-Create Steps 

Some steps include the ability to auto-create other records, depending on the status of the 
previous step. It is displayed as a child node from which the link is drawn out. For document-type 
BPs, the auto-creation of BP records will also copy attachments from the original record. 

In this field: Do this: 

Auto-create records 

Choose one of the following: 

 As per workflow design: Auto-create 
BPs that were configured as part of the 
design. 

 Based on user selection during 
execution: During execution, user will 
be given a list of BPs that are selected 
under workflow design in uDesigner. 
User can choose which BP record 
should be auto-created. 

 Process list: Select a list of BPs for 
which the system will auto-create 
records during execution. 

Settings for Sub-Workflows 

A sub-workflow is a mini workflow within a main workflow and is part of the uDesigner workflow 
design. It is a grouping of one or more steps. A sub-workflow node will be child node of the main 
workflow and a sibling of other steps and sub-workflow nodes.  
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In this field: Do this: 

Sub-workflow Name 
You can click the link to view the graphic of 
the sub-workflow. 

Description 
Capture more information about the 
sub-workflow. 

Enable Sub-workflow duration 
Similar to the main workflow. A duration 
can be set for the group of steps. 

Overall Sub-workflow duration 
Similar to the main workflow. Overall 
duration for the group of steps. 

Override Sub-workflow due date 
Similar to main workflow. User can 
override sub-workflow due date during 
execution. 

Set up View Forms for Workflow Business Processes 

A view form is the read-only version of a business process form that appears when the recipient 
first opens the form. The system uses the view form to show a preview of the record in the log. 
The view form enables the user to view record details. The fields in a view form cannot be 
edited. A view form may also be used when the designer does not want the user to be able to 
change the data on the form. 

Note: Business process forms can only be printed from a view form. 

As an Administrator, you can set up different view forms such that details that are relevant to 
users are seen. Up until now, there was no provision to assign view options to specific users or 
groups. That is to state that the users with only "View" permission could see the entire form and 
there was no way to control which segments of the form could be viewed. With this 
enhancements you can set user-permissions so users can view the entire form, a portion of the 
form, or a limited set of data on the form, for record preview in the log as well as for viewing 
record details. 

When you set up a workflow business process (all levels and record instances), you can use the 
View Forms tab of the Business Process Setup window to set up different view forms such 
that details that are relevant to users are seen. To access the View Forms tab: 

1) Go to your project or shell and switch to the Admin mode. 

2) In the left Navigator, expand the Setup node, and click the Business Process sub-node. 

3) Open the business process that you want to set up different view forms for. 

4) Select an item under the Setup Name column and open it. 

5) Click the View Forms tab to open it. 

Use the steps above to remove, move up, or move down existing view forms. 

From the View Forms tab: 
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 You can add view forms to a BP setup. 

 Assign settings to users and groups for individual view forms. 

 Apply your settings to task assignees and copied (cc'd) users who view the record. 

 If ask assignees and copied (cc'd) users have restricted access to only one of the view 
forms listed in the window, then that view form will be displayed at runtime. 

 If ask assignees and copied (cc'd) users have access to none of the view forms listed in 
the window, then the step form will be displayed at runtime. 

 For copied (cc'd) users the restricted view form will be seen both from Notifications and 
Logs. 

Note: If the users or groups have permission to view multiple view forms, 
then they will see the view forms based on the sequence listed in this 
window. 

To add a view form: 

1) In the View Forms tab, click Add to open the Select View Forms window. 

2) Under the View Forms column, a list of view forms from the BP design is displayed. Select 
as many forms as you need and click OK to add the view forms. 

3) After the form has been added, the right section will display the Permission Settings block. 
The Permission Settings block contains the Viewers field. Use the Select option to see the 
users or groups picker (Users/Groups) and add. The list of users and groups seen here will 
be the same as the ones seen when assignees are being set up in the workflow setup. 

An administrator can select the view forms that need to be set up for a given project or shell. The 
design for a BP can have multiple view forms, but for a select project template, or shell template, 
the administrator can set up only one view form. 

If users have access to a deployed view form and that view form is deleted in uDesigner, at 
runtime, after a user opens the BP record, the system checks that user's permission to any of 
the BP view forms that exist in the setup. If the user does not have access to any of the BP view 
forms that exist in the setup, the system displays the Action form for that BP in view-only mode. 

Important information about deleting View Forms 

As indicated in the Unifier uDesigner User Guide, you can design a BP form (in the Staging 
environment), add view forms associated with a BP form design to the Business Process Setup 
(View Forms tab), assign permissions to users and groups for the individual view forms, and 
deploy the view forms so they can be accessed through the record preview in the log (Logs and 
Company Logs) for viewing record details. 

Due to the system limitations, an anomaly occurs when you delete a view form from the 
Business Process Setup. The following explains this anomaly: 

You have created and deployed the following view forms for a BP form ABC: 

 VF01 

 VF02 

 VF03 
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You decide to delete one of the view forms. As a result, you navigate to uDesigner, delete the 
view form (for example, VF01), and ensure that the deleted view form has been remove from the 
Business Process Setup. 

You decide to add a new view form (for example, VF04), for the BP form ABC, so you proceed 
to add the new view form in uDesigner and deploy the new view form, VF04. 

At this point, due to the system limitations, the system will automatically add the newly created 
view from, VF04, to the Business Process Setup using the users and groups assignments 
originally assigned to the deleted view form, VF01. Furthermore, the availability of this added 
new view form (in the Business Process Setup) goes against the method that is used to deploy a 
new view form. 

As an administrator, you must ensure that in such scenario, you open the newly created view 
form and assign appropriate permissions.  

Set up Record Properties for Workflow Business Processes 

In both Non-Workflow BPs and Workflow BPs (at the company, shell, and project levels) you 
(the administrator) can use the Record Properties tab to establish:  

 The availability or visibility of the BP form properties tabs for users and groups. 

 The ability to download attachments when users and groups access the BP records in user 
mode. 

The Record Properties tab has the following sections: 

Top: For setting up restrictions (setting restriction is done through Edit Restrictions) 

Left: For Upper Form and Line Item (detail forms) properties and setting up restrictions for 
downloading attachments from the Upper Form and Line Items (detail forms). The left 
section displays all of the record tabs seen in both upper and detail forms. In case of Simple 
type and Text type BPs, only the upper form properties tabs will be seen. The Upper Form or 
Line Item properties options that were hidden in uDesigner will not be displayed.  

Right: Users info (users or groups who cannot see the properties) 

The Record Properties window displays a read-only view of users and groups who have 
restricted visibility to and download of attachments for selected tabs in the Edit 
Restrictions window. You can use the Edit Restrictions button to apply restrictions to users 
and groups. 

Restricting the Audit Log and Workflow Progress options below will result in the automatic 
update of the same options in Permissions Settings of Access Control. The same operation 
applies in reverse. 

The Attachments in Upper Form Properties section will not be shown for the system-defined 
Line Item tab in the Document type BP. 

The additional section Do not allow download of Attachments will show the users and groups 
who are restricted to download the attachments from Upper Form or Line Item tabs in the 
business process record, when the attachments are visible. 
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The first tab seen in the Do not allow download of Attachments is the Upper Form 
Attachments followed by the Line Item tabs names (for example, Gauges & Meters or 
Components) which will be in the same order as seen in the Line Item Properties. 

The Upper Form Attachments tab will not be shown for the Text type and Document type BPs. 
Additionally, the system-defined tab will not be shown for the Document type BP, under the Do 
not allow download of Attachments section.  

The tabs seen in the Upper Form and Detail Form properties will be based on each BP type. 

The tabs shown in Upper Form and Line item Properties will be in the same order seen in the 
BP record at run time. 

The Upper Form Properties and Line Item Form Properties that are already hidden are not 
shown in this list. 

Example 

If Linked Records and Linked Mail tabs, from the Upper Form Properties, are set to be 
hidden in uDesigner > Record Properties, then those two tabs will not be seen in the BP 
Setup under Upper Form Properties. Similarly, if the user-set Attachments tab in the Upper 
Form Properties is hidden in uDesigner > Record Properties, then in the BP Setup > Record 
Properties the user will not be able to see the following tabs: 

 Do not allow download of Attachments 

Upper Form Attachments 

 Upper Form Properties 

Attachments 

Adding tab visibility and download of attachments restrictions to users and groups 

You can add restrictions to the users and groups through the Edit Restrictions option. The 
restricted users and groups will be seen on the right block for the property selected on the left 
side. 

Edit Restrictions window: 

When you click the Edit Restrictions option, a window displays which lets you select or add 
user and groups and assign attribute form restrictions. The Select Users/Groups block (the 
left pane of the window) will be empty if there are no existing restrictions; otherwise, the 
block will list the existing restricted users and groups. Use the Remove option to remove the 
users and groups listed in this block. You can select one or more users or groups and select 
the Remove option to remove users or groups from the tab visibility restrictions. 

In the right section of the window, you can access and hide all of the following form 
properties: 

Hide All Upper Form Properties

 Attachments 

 Do not allow download of Attachments 
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 Comments 

 Linked Records 

 Linked Mail 

 Workflow Progress 

 Audit Log 

 Reference Records 

Hide All Line Item Properties

 <Line item tab1 name> Attachments 

 Do not allow download of Attachments 

 <Line item tab2 name> Linked Records 

 <Line item tab2 name> Attachments 

 Do not allow download of Attachments 

 <Line item tab2 name> Linked Records 

The Detail Form Attributes will be shown based on the Line Item tabs available in the 
selected business process. Additionally, users and groups can be restricted to download the 
attachments only from the business process record. 

If a single user or group is selected on the left side, the selected user or group's existing 
restrictions will be shown. 

The Cancel and Save options will remain disabled if you do not make any changes in the 
right block. If you select a user or group and change the restriction options, the Cancel and 
Save options will be enabled. The Cancel and Save options let you save or cancel the 
changes that you have made in the right block. 

After you close the Edit Restrictions window, the restricted users and groups will be added 
in Record Properties window. 

You can select multiple rows in Users/Groups section, edit the restriction check boxes, and 
save or cancel your changes. 

If multiple users or groups (on left block) are selected, the existing restrictions will not be 
shown in the right block. 

In the Attachments case, a user who has restrictions to Download will be able to view or 
access the attachment but cannot download or save to a local system. 

Users/Groups window 

When you click Add, the User/Group window opens. This picker window displays all of the 
users and groups that are available and selected. After the users and groups are added, you 
can select the users or groups (from the left block) and set the hide permissions for the form 
attributes (in the right block). 
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Note: Users or groups cannot be removed from the User/Group Picker 
window. You can use this picker window to add additional users and 
groups to the Edit Restrictions window. You can remove your added 
users and groups by selecting one or multiple rows in the Selected 
Users/Groups block. 

After you add restrictions in the Edit Restrictions window, the left block displays the list of 
all users and groups with restrictions to the form attributes. When you select a form attribute 
such as Audit Log or Comments, the right block displays the list of all the restricted users 
and groups. A user who has restricted access to selected record attributes like Audit Log, 
Comments, or Linked Mail viewing in the business process record will not see those tabs. 

Example 

User U1 has "Hide Upper Form Properties - Comments and Linked Records." At run time, 
when user U1 creates a business process record or opens an existing record, both 
the Comments and the Linked Records tabs will not be seen in the record. 

Attachments

If a user does not have permission to download the attachments, then the user can only view 
the attachments, in the BP record. The Download option is removed from Attachments tab 
and also in Review window. 

In this case a restricted user who views the attachment in native view the attachment will 
open in in read-only mode in Unifier Viewer. 

A restricted user will not be able to receive the attachments through email notifications 
received from a business process record for which the user has restrictions to download 
attachments. 

Line item Attributes

You can assign restrictions to users and groups for the Detail Form properties (Attachments 
and Linked Records for each Line Item tab). These additional Detail Form attributes will be 
seen only for the business processes that have the Detail Form defined in them. 

The Detail Form properties seen in the Record Properties window will vary for each business 
process and is based on the design. 

Users and groups can be restricted to download attachments from the Line Item tab, similar 
to the Upper Form, as described in the Attachments section above. 

Additional information

Users and Groups who have permissions to "Hide Record Audit Log" and "Hide Task Statuses" 
are added to the restricted users and groups viewers list in the "Record Properties" tab, in the 
business process setup. 

All of the record level and Line Item tab restrictions are available for all business processes 
(company, shell, and project levels) that supports standard UI. 

The restrictions are applicable to all users or creators, task assignees, step editors, record 
editors, and CC'd users who are part of the workflow in the record. 

Visibility of tabs will be applicable to both Action and View Forms when the user has tab 
restrictions to the BP. 
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For Non-Workflow BPs, "Workflow Progress" (under the Upper Form properties) will not be 
available in the Record Properties, both at the design and at the setup level. 

For Company-level BPs, "Linked Mail" will not be available in Form Properties. 

For Simple and Text-type BPs, the option to hide the Detail Form properties will not be available. 

For Document-type BPs, "Attachments" will not be seen in the Upper Form Properties and 
system defined tab in the Line Item Properties. 

Note: The additional restrictions are not applicable to bid users. Bidders 
will be able to see all the attributes even though the requestor has 
restricted access. 

When certain form properties are hidden for a business process, those form properties are not 
shown in the Record Properties tab in the BP setup. 

If the users or groups do not have View permission, then the BP record tabs will not be 
displayed, at run time. This is applicable to both company sponsored and partner users. 

Projects or shells do not show Rich Text type DEs in the following scenarios: 

 When creating conditions for auto-creation elements in a BP setup. 

 When editing Gate settings and setting up Gate Condition Elements. 

Assigning restrictions to users and groups will impact their ability to see the record properties 
tabs (tabs in the right pane, when the user opens a record) of the following nodes: 

 Logs 

 Drafts 

 Tasks 

 Master Log 

 Company Log 

 Single-Record BP Log 

 Portal BP Log 

Set up Permissions for Record Properties Tab (Workflow) 

To set up permissions for the Record Properties tab:  

1) Go to the Company Workspace tab and switch to the Admin mode. 

2) Click Company Sponsored Shells to expand it, and select the <BP NAME> and open the 
BP (Workflow or Non-Workflow). 

3) Click Setup to expand it. 

4) Click Business Process, open <SETUP NAME>, and click the Records Properties tab. 

Creating, Adding, and Deleting Business Process Help Files 

Oracle provides standard business processes. 

For Cloud
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If you must download, deploy, and access a local copy of the business processes help files, 
download the help.zip. Contact your cloud administrator for more information. 

For On-Premises

If you must download, deploy, and access a local copy of the business processes help files, 
download the help.zip file and follow the instructions in the Unifier Installation Guide.  

You can also develop your customized business process and create your own help files. 

Note: The help files must be in Adobe Acrobat PDF format. 

You can add the help file to new or existing business process setups. If you add the help file 
after individual business process records have been created, the help file will not be available to 
the existing records; however, it will be available immediately from the business process log or in 
any new business process that is created after the help file has been added. 

Note: Custom business process help files can be added to project-level 
or company-level BPs. 

To create a custom business process help file 

1) Be sure that you have installed on your system Adobe Acrobat or other software application 
that includes a plug-in allowing the ability to create a PDF file. 

2) In Microsoft Word or a similar software application, write the business process instructions 
that you want to be made available to other business process users. Save the business 
process help file, but do not close it. 

3) With your business process help file still open, do one of the following to create a PDF file. 
This will depend on how your system is set up. 

 Print to PDF file: Click the File menu and choose Print. From the Printer drop-down list, 
select Adobe PDF as the printer, and click OK. Name the PDF file and click OK. 

 Save as PDF file: Click the File menu and choose Save as PDF. Name the PDF file and 
click OK. 

The PDF file will be generated, and can be viewed using Adobe Acrobat Reader. 

To add a custom business process help file to a new or existing business process setup 

1) In Admin mode: 

 For a business process at the company level, go to the Company Workspace tab and 
click Company Workspace > Business Process Setup in the left Navigator. 

 For a business process in a project or shell, open the project or shell and click Setup > 
Business Process in the left Navigator. 
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Note: Even though the help file is added to an individual setup window, it 
is automatically added to all setups for that business process. The help 
file will be available immediately to all users with access to the business 
process log in User mode, and will be available to any individual 
business process record created after adding the help file. 

2) Select the business process from the log and click Open. The Setup log for the business 
process opens. 

3) Click New to create a setup, or select an existing setup from the log and click Open. The 
Business Process Setup window opens. 

4) In the General tab, click the Help File Add button. The File Upload window opens. 

5) Click Browse and navigate to the help file that you want to add. The help file must be an 
Adobe Acrobat PDF file. Click OK to attach the file and close the File Upload window. 

6) When you have completed the Business Process Setup window, click OK. 

To delete a business process from an existing setup 

Note: You can delete a business process from a specific shell template 
but not from other Projects/Shells that have been created using the 
template. 

1) Open the project or shell tab and switch to Admin mode. 

2) In the left Navigator, click Setup > Business Process. 

3) Select a business process for deletion. 

4) Click Delete. 

5) When the prompt appears that asks you to confirm deletion, click Yes to delete the business 
process. 

To access the business process Help link 

1) In User mode, navigate to the business process log. 

2) Click the Help menu, then click the business process name, which appears at the bottom of 
the Help menu. If a business process help file has been added to the business process form 
setup, the PDF file will open. 

3) You can also access the file from the business process form. Open a business process 
record, click the Help menu, and click the business process name. 

Auto-creating BP Record or Planning Item Based on Conditions or Frequency 

Using uDesigner, users can design a form that automatically creates a new business process 
(BP), line item, or planning item from a source form to a destination (auto-created) form after 
certain criteria are met. Users who have modify ownership permissions in the source record can 
enable auto-creation. You can override conditional auto-creation and immediately invoke the 
auto-creation manually if needed. 

This type of auto-creation automatically generates a new record based on: 

 A condition, such as a dollar amount 
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 A frequency, such as a daily or weekly time frame 

Note: Line items cannot be created with a frequency trigger. 

 Both a condition and a frequency 

When a business process or line item reaches the trigger(s), the form will automatically create a 
new record or line item. This type of auto-creation uses a BP Creator, Planning Item Creator, or 
BP Line Item Creator data element on the upper and/or detail form to generate the new business 
process(es), line items, or planning item(s). 

You can use auto-created business processes to manage repeated events, such as: 

 Line items of lease business process generating payment request business process 
records: A lease business process with a pre-generated payment schedule can use this 
functionality to generate payment request records at appropriate preset days in advance of 
the payment due date to be routed for approvals. 

 Preventive maintenance business process line items generating work orders business 
process records: A preventive maintenance type business process (Preventive 
Maintenance Book) can be set up to create work orders for assets at periodic intervals 
depending on the service needs of the asset. 

For example, if you wanted to use auto-creation to create a work order business process to 
order maintenance on a vehicle, you would first create a preventative maintenance business 
process (the source business process) and have your administrator set up the auto-creation 
of a work order for vehicle maintenance business process (the destination business process) 
to order the work on the vehicle. 

In this example, the uDesigner user set up which business process is the source business 
process and which is the destination business process. The company administrator specifies 
the conditions and defaults for the auto-creation. End users can set up the periodic 
auto-creation, based on their needs. 

In the Preventive Maintenance Book, for: 

Floating Line Items holding non-terminal work orders, you cannot edit the following DEs: 

 Family Identifier 

 Line Item Status 

 Schedule Type 

Fixed Line Items holding non-terminal work orders, you can edit the following DE: 

 Line Item Status 

 Create action items from meeting minutes: Create and assign tasks to different people 
creating a fully automated flow for routing of action items from meeting minutes. 

 Create a planning item: Create a planning item when an initiative business process has 
been approved. The planning item could then be fleshed out with details, such as budgets, 
locations, personnel. 

 Add a new line item to an existing record: You can add a line item to an existing business 
process. For example, a submittal registry record could contain line items that auto-create 
separate submittal business process forms for each contractor on a project. In the course of 
work, you might realize that the original submittal registry record is missing a submittal for an 
architectural drawing. You could submit a new submittal business process form that would 
add the missing architectural drawing submittal to the original registry record. 
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For Line Item Creation: 

 Users cannot create a line item on a record that is at a terminal or terminated status. 

 For line items created on a non-workflow cost type business process, the cost amount(s) will 
roll up to the Cost Sheet. 

 For line items created on workflow cost type business process, the cost amount(s) will NOT 
roll up to the Cost Sheet. 

After a new workflow record is created, the system sends it to the assignees as an initiation 
task (I Step) that appears on the user's Tasks log and the business process log to which the 
record belongs. If a new record is sent as an initiation task, the user must accept the task to 
manually launch the record. 

Note: Regardless of the number of assignees or creators, only one user 
may accept the I-Step task. 

After a new non-workflow record is created, the system sends it to the designated creators as 
an initiation task (I Step) that appears on the user's Tasks log and the business process log to 
which the record belongs. The user must accept the task to view the record. 

Grouping line items into single records 

The system auto-creates new business process records using a BP Creator element. If this 
element is on the upper form of the business process, it will auto-create a single record. If the 
BP Creator element is on the detail or line item form, it will auto-create a record for every line 
item on the source record. For example, if source tab A has a BP Creator element and 10 line 
items, and source tab B has the same BP Creator element and 7 line items, 17 new records will 
be auto-created. 
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Sometimes, however, creating a record for every line item is cumbersome. You can end up with 
17 records that differ in only one aspect, such as a color. For cases like this, you can group line 
items for auto-creation in order to create fewer generated records. In a simple example for a 
lumber yard order, you might have doors made of wood or steel, both in colors of white and red. 
You could group the line items according to the material (wood or steel) and color (red or white) 
to create fewer work order records. 

Notes:

 If the auto-created business process is set up to include line item 
attachments, the attachments will be appended to the upper form of 
the destination business process if it is not a line item type. 

 If the auto-creation uses a date trigger, the system will ignore this 
grouping feature. 

 The system will not group line items if: 
- The steps in the workflow are of different duration 
- The task assignees are different 
- The locations (such as shells) are different 

See also Set up auto-creation for a non-workflow BP or planning item (on page 251) and 
Set up auto-creation for a workflow BP (on page 271). 
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Bypassing the I Step 

During the business process setup you can set up an auto-created workflow BP to skip 
the Initiation step and send the record directly into the workflow, where it normally arrives at the 
first step after the Create step (or the first step in a conditional routing). For a workflow BP, you 
can specify the schema, the step in the workflow that the record should use as its first step, the 
workflow duration, and the name of the person or group who will be the owner of the 
auto-created record. When the record is created, data will roll up to the manager sheets at the 
appropriate status; however, if the system encounters errors or invalid data, the record will 
remain at the Create step, and roll-ups will not occur until the user resolves the errors. 

For a non-workflow BP, you can set up an auto-created record to skip the Initiation step. In this 
case, the non-workflow BP will be created and will appear in the BP log in either an "edit" or 
"finish edit" mode. If it appears in an "edit" mode, the user will have to open the record and add 
or correct information on the form. If it appears in a "finish edit" mode, the record is considered 
complete, and data will roll up to manager sheets. 

Auto-Creation Protocol for Bypassing the I Step 

Auto-creation uses details specified in the BP Creator element to create the record. If these 
details are not present in the BP Creator element, the auto-creation feature will use the following 
protocol to attempt to create the record. 

For a Non-Workflow BP For a Workflow BP 

Checks for owner specification:

Checks the source BP setup 

Checks the destination BP setup 

If no owner can be identified, sends an 
error notification to those specified in 
source BP 

Checks for owner specification:

Checks the source BP setup 

Checks the destination BP setup 

If no owner can be identified, sends an 
error notification to those specified in 
source BP. 

Checks for status:

Checks the destination BP setup 

If no status found, creates the record and 
puts it into "edit" mode for user to correct. 

Checks for a workflow schema:

Checks the destination BP setup 

If no schema is specified, the record will be 
sent as an I Step to the user's Tasks log 
and the BP log to which the record 
belongs. The user must accept the task to 
manually launch the record. 

Checks for an action specification

Checks the destination BP setup 

If no action is specified, the record will be 
sent as an I Step to the user's Tasks log 
and the BP log to which the record 
belongs. The user must accept the task to 
manually launch the record. 
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Rules for Checking Conditions for Auto-Creation 

There are rules that govern when the Unifier scheduler checks the conditions for auto-creation, 
and then if these conditions are met, it auto-creates the BP. 

Rule 1 

The Company Administrator selected the Enable Auto creation check box for BP Creator when 
the auto-creation was set up. 

If the Enable Auto creation check box is selected, it implies system based auto-creation, and the 
BP Creator Select button is not displayed in User mode. 

For non-workflow BPs: The condition check occurs on Submit. If condition met, creates record 
and shows the link for the auto-created BP. If no condition is specified auto-creates records and 
shows the link for the auto-created BP. 

For workflow BPs: The condition check occurs on Send. If end step reached and Action Form 
is used on End Step, the condition check occurs on Save instead of Send. If condition met, 
creates record and shows the link for the auto-created BP. If no condition specified blindly 
creates records and shows the link for the auto-created BP. 

If the Enable Auto creation check box is not selected, it implies manual creation. 

For non-workflow BPs: The condition check does not occur on Submit. 

For workflow BPs: The condition check does not occur on Send. 

BP Creator - Select button shown in User mode so that the user can create the business 
process manually. If clicked, creates BP record without checking any condition, and creates 
record and shows the link. 

Rule 2 

Date Trigger Condition check: Are checks on the specified Date Data Element. For workflow 
or non-workflow BPs, this setup implies that the condition checks are done on a date instead of 
Finish Edit/Send, if a link does not exist next to BP creator element. If a link exists, it will not 
create any new records for that BP Creator element in the chosen line item of the record. 

Rule 3 

Trigger Condition check based on frequency (Periodic): Are checks on frequency for BP 
Creator elements with Enable Auto creator checked. If specified, these are the only time 
condition checks are done. This overrides any other checks for date. This is the only method to 
create multiple records even if a link exists and a record has already been created for this BP 
Creator element. The link created using this will always point to last auto-created record. 
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Setting up Auto-Creation of Cash Flow Curves from Contracts 

An additional cash flow option is available on the setup window for CBS code-based base 
commit business processes. This option enables the automatic creation of a commitment cash 
flow curve for each base commit record in a project or shell. To do this, you simply designate a 
commitment-level cash flow template to use for the auto-created curve. 

For workflow business processes, this option is available in the Workflow Setup window Settings 
tab for every step other than the Create step. At runtime, when the record is sent from that step, 
the cash flow curve auto-creation is triggered and the curve is created in the Cash Flow log for 
the project or shell. 

Note: The permissions will get copied over to the created Cash Flow. 

For non-workflow business processes, this option is available in the Business Process Setup 
window on the General tab. At runtime, the cash flow curve auto-creation will be triggered when 
the Finish Edit button is clicked on the BP record. 

When copying a cash flow to create a new one, all permissions will be copied to the new cash 
flow curve. 

The following procedures describe enabling the auto-create cash flow option. See Setting up a 
Non-Workflow Business Process (on page 245) and Setting up a Workflow Business 
Process (on page 262) for more details on setting up business processes. 

Notes:

 This option is available for base commit business processes only; that 
is, cost-type business processes with sub-type of "Line Items with 
CBS Code" and classification of "Base Commit." For all other types 
of business processes, this option will not display. The cash flow 
curves that are auto-created are based on commitment detail level 
curve templates (either company-level or curves created in project or 
shell templates). 

 Because your organization might have multiple cash flow jobs and 
automatic snapshots scheduled to run for a multitude of projects, you 
can use the Cash Flow Jobs functional node to manage the jobs and 
auto-snapshots and their impact on system performance. For more 
information, see the Unifier General Administration Guide. 

To enable auto-creation of commitment-level cash flow curves in non-workflow base 
commit BP records 

1) Navigate to the Business Process Setup window for the base commit business process. 

a. Open the project/shell (or project/shell template) and switch to Admin mode. 

b. In the left Navigator, click Setup > Business Process. Double-click the base commit 
business process from the log. 

c. Double-click the business process again to open the Business Process Setup window. 

2) On the General tab, locate the Cash Flow Template field. 
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3) Click Add. The Cash Flow Templates window opens. It lists all commitment detail-level cash 
flow templates created in the Company Workspace tab (in the Standards & Libraries > 
Cash Flow >Templates) or in project or shell templates (in the Cash Flow node). 

4) Choose a template and click Select. 

Note: Entering a template in this field enables the cash flow auto-create 
feature. To disable this feature, click the Remove button to remove the 
cash flow template from the field. 

5) Click OK to save and exit the Business Process Setup window. 

At runtime, a commitment cash flow curve will be created in the project or shell when the 
base commit record is complete—that is, the user clicks the Finish Editing button on the 
record. The data used for the cash flow curve will be taken from the line item values on the 
record at the time the record is sent. 

To enable auto-creation of commitment-level cash flow curves in workflow base commit 
BP records 

1) Navigate to the Business Process Setup window for the base commit business process. 

a. Open the project/shell (or project/shell template) and switch to Admin mode. 

b. In the left Navigator, click Setup > Business Process. Double-click the base commit 
business process from the log. 

c. Click Workflow Setup, and double-click a setup name (or create a new BP setup) to 
open the Workflow Setup window. 

2) Click the Settings tab. 

3) Select any step other than the Create step. Scroll down the Step Configuration options and 
locate the Cash Flow: Default Template field. 

4) Click Add. The Cash Flow Templates window opens. It lists all commitment detail-level cash 
flow templates created in the Company Workspace tab (in Standards & Libraries > Cash 
Flow > Templates) or in project or shell templates (in the Cash Flow node). 

5) Choose a template and click Select. 

Note: Entering a template in this field enables the cash flow auto-create 
feature. To disable this feature, click the Remove button to remove the 
cash flow template from the field. 

6) Click OK to save and exit the Workflow Setup window. 

At runtime, a commitment cash flow curve will be created in the project or shell when the 
base commit record is sent from the selected step. The data used for the cash flow curve will 
be taken from the line item values on the record at the time the record is sent. If record line 
item values are edited during the course of the workflow, then the curve values will update 
the next time the curve is refreshed. 

Note: This option is not available in the Create step. If you designate a 
cash flow template in more than one workflow step, the cash flow curve 
will be created at the first step in which this option is enabled; the 
auto-creation will be ignored in any subsequent steps, because only one 
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cash flow curve can be created per base commit record. 

Copying Workflow Setups from Other Schemas 

Some workflows can encompass many steps, as well as conditional routing and sub-workflows. 
Most of your time as administrator can be spent setting up the workflow schemas in your 
company. To make setting up workflow schemas easier and faster, the system provides you the 
option of copying existing setups from other workflow schemas. 

For example, if you have set up a large schema for an approval process that includes separate 
workflows for different provisos, you can copy the setup of one schema to another workflow, and 
make incidental changes where necessary, rather than set up the entire workflow schema again. 

Or, if you have a complex schema for setting up a project or shell, you can copy that schema to 
set up a different project or shell in your same Unifier environment. 

You can copy a setup from here: To here: 

A business process in the Company 
Workspace 

The same business process in the same 
Company Workspace 

If any users or groups are defined in the 
setup, they will be copied over if they do 
not exist; matching will be done on the 
name. 

A project template for a business process 

Another project template for the same 
business process 

If any users or groups are defined in the 
setup, they will be copied over if they do 
not exist; matching will be done on the 
name. 

A business process in a project 

A project template for the same business 
process 

If any users or groups are defined in the 
setup, they will be copied over if they do 
not exist; matching will be done on the 
name. 

A shell template for a business process 

Another shell template (of any shell type) 
for the same business process 

If any users or groups are defined in the 
setup, they will be copied over if they do 
not exist; matching will be done on the 
name. 

A business process in a shell 

A shell template (of any shell type) for the 
same business process 

If any users or groups are defined in the 
setup, they will be copied over if they do 
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not exist; matching will be done on the 
name. 

Business Processes Must Match

In all cases, the business process name, type, sub-type, classification, studio owner, and version 
number must match or the copy function will fail. 

About the version number

The number in the Version column of the business process log shows the uDesigner version 
number. This number represents the number of times the design has been changed from Draft 
mode to Complete. 

The uDesigner module automatically increments the version number whenever a design is 
returned to Draft mode. When the draft is changed to Complete, it shows that number. This 
version of the design in uDesigner may or may not be the version that is active in Unifier. 

The version number that appears on this log in Unifier shows the last deployed version that was 
imported. This number may not match the version number uDesigner, but it is the last active 
version of the design in Unifier. The version number of the BP you are copying from must match 
the version number of the BP you are copying into. 

At the Company Level, Copy a Setup from Another Setup in the Same BP 

In this copy action, you copy a setup to another setup in the same business process in the same 
company workspace.  

To copy a workflow setup 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Workspace > Business Process Setup. 

3) On the right pane, double-click the business process to open it. 

4) In the Navigator, click Workflow Setup, and in the right pane, select the setup you want to 
copy. 

5) Click the Copy button. The Workflow Setup window opens. 

6) On the General tab, enter a name and description for the new setup and make the status 
Active or Inactive as necessary. 

7) Click Apply. 

8) Click the Settings tab. The Settings tab opens, showing the workflow of the setup you 
copied. 
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On this tab, you can make any changes you want to the setup you copied to accommodate 
the new setup. 

9) To save the new setup, click OK. 

If the setup Active is active, the system performs an error check on the new setup and 
notifies you of any errors it encounters; otherwise, the error check will not occur until the 
setup is activated. 

Copy a Setup from One Project/Shell Template to Another 

In this copy action, you copy a setup from a business process in one project/shell template to 
the same business process in another project/shell template. 

To copy a setup from one project/shell template to another 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell type]. 

3) In the right pane, double-click the shell that contains the BP you want to copy the setup into. 

4) In the left Navigator, click Setup > Business Process. 

5) In the right pane, double-click the name of the business process into which you want to copy 
the setup. 

6) In the left Navigator, click Workflow Setup. 

7) Click the Copy From button and choose Templates. A copy window opens, listing all the 
workflow templates for that BP that exist in all the projects and shells in your environment. 

8) Select the template you want to copy and click Copy. The Workflow Setup window opens. 

9) On the General tab, enter a name and description for the new setup and make the status 
Active or Inactive as necessary. 

10) Click Apply. 

11) Click the Settings tab. The Settings tab opens, showing the workflow of the schema you 
copied. 

On this tab, you can make any changes you want to the setup you copied to accommodate 
the new setup. 

12) To save the new setup, click OK. 

The system adds the template to the workflow setup log. If the setup Active is active, the 
system performs an error check on the new setup and notifies you of any errors it 
encounters; otherwise, the error check will not occur until the setup is activated. 
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Copy a Setup from a Project/Shell to a Template 

In this copy action, you copy a workflow setup from a business process in a project or shell and 
make it a template in the BP you copy the setup into. 

To copy a setup from a project/shell to a template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell type]. 

3) In the right pane, double-click the shell that contains the BP you want to copy into. 

4) In the left Navigator, click Setup > Business Process. 

5) In the right pane, double-click the name of the business process into which you want to copy 
the setup. 

6) In the left Navigator, click Workflow Setup. The right pane lists the workflow setups that 
currently exist for this business process. 

7) Click the Copy From button and choose Project/Shell. 

A copy window opens, listing all the workflow setups for that BP that exist in all the projects 
and shells in your environment. 

8) Select the setup you want to copy and click Copy. The Workflow Setup window opens. 

9) On the General tab, enter a name and description for the new setup and make the status 
Active or Inactive as necessary. 

10) Click Apply. 

11) Click the Settings tab. The Settings tab opens, showing the workflow of the setup you 
copied. 

On this tab, you can make any changes you want to the setup you copied to accommodate 
the new setup. 

12) To save the new setup, click OK. 

The system makes a template of the setup you copied and adds the template to the workflow 
setup log. If the setup Active is active, the system performs an error check on the new 
schema and notifies you of any errors it encounters; otherwise, the error check will not occur 
until the setup is activated. 
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Setting up a Blanket Purchase Order Summary Template 

If you have set up a company-level blanket purchase order (a uDesigner created, company-level 
cost subtype commit BP), you must then set up a summary template to enable validation against 
individual commit BPs that reference the blanket PO. 

To set up the summary template for a blanket PO 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Workspace > Business Process Setup. The business 
process log opens. 

3) In the log, double-click the name of the blanket PO business process. A setup log opens. 

4) On the log, select the business process and click the Summary Template button. 

5) You may add additional columns as needed. Click Columns, then click New. Complete the 
Column Properties. The data source choices for columns include: 

 Single source: All active cost BPs for your company (and their statuses), regardless of 
project. You determine which statuses you want to appear on the sheet. If you import and 
set up cost BPs that might reference the blanket PO, be sure to add them to the 
summary sheet template to track them against the total. 

 Logical source: Total commits and remaining balance. These should be set up as 
formulas, where total commits is the sum of the commits that you added as columns, and 
the remaining balance is the difference between the original amount and total commits. 

To enable validation, include a total commits column to keep track of commit BPs that 
reference the blanket PO, and a remaining balance column to ensure that you do not exceed 
the original amount. 

Setting up a Base Commit Business Process 

A Base Commit classification of a Cost Type Business Process (BP) can create a schedule of 
values; a General Spends classification can create an invoice at the CBS level. 

Use the Base Commit BP for: 

 For monies committed to be spent; for example, a contract or purchase order. 

 For creating a Schedule of Values (SOV) sheet for a General Spends, Payment Applications, 
or Summary Payment Applications. 

Note: In Standard Cost Manager, the Base Commit BP creates a 
Schedule of Values (SOV) sheet. 

With the Base Commit type of BP, you can: 

 Reference against a company-level commit BP 

 Enforce the line items against a company-level commit amount 

 Create a commitment summary when the BP is in a terminal status 

 Consolidate line items 
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From this type of BP, you can: 

 Select only a General Spends type of commitment summary 

 View commitment summary line items only by individual line items, or grouped by commit 
codes 

To set up the for a Base Commit BP: 

1) Go to the project and switch to Admin mode. 

2) In the left Navigator, click the Setup node. 

3) In the left Navigator, click Business Process to open the Business Process Setup - 
Current View/log. 

4) Select the business process that you want to set up and open. 

5) In the Business Process Setup window, General tab, enter values. 

6) Continue on with entering values in the Settings, Notifications, Auto Creation, and 
Record Copy tabs. 

7) When finished, click Apply and OK. 

Removing Restrictions Related to the Multiple Payment Application Submissions 
(Remove SOV restrictions) 

When you create a Workflow BP record, the BP record shall remain in progress (in-flight) until 
the record reaches its terminal stage. 

You can set up a Base Commit type of BP that is based on an existing Schedule of Value 
(SOV), and in progress (in-flight), to accommodate: 

 Multiple Payment Application records can be created for the same commit record. 

 Multiple Negative Change Orders can also be created for a given Base Commit. 

 Payment application when a negative change order is in-flight. 

A negative change order refers to a Change Commit (change order) that has been issued to 
deduct the original committed contract amount. This means that a user has created a record 
of Change Commit BP type with negative line item amounts. 

In the Business Process Setup window, General tab, you have the option of applying or 
removing restrictions on multiple payment applications or multiple negative Change Commit in 
the Base Commit BP. This enables users to create: 

 Create and submit a Payment Application when another Payment Application is in progress. 

 Create and submit a Payment Application when a Change Commit (change order), with a 
negative line item, is in progress. 

 Create and submit a Change Commit (change order), with a negative line item, when a 
Payment Application is in progress. 

 Create and submit a Change Commit (change order), with a negative line item, when 
another Change Commit (change order), with a negative line item, is in progress. 

In the Business Process Setup window, General tab, you have the option of applying or 
removing restrictions on multiple payment applications or multiple negative Change Commit in 
the Base Commit BP. This enables users to create: 

 Create and submit a Payment Application when another Payment Application is in progress. 



Modules Setup Administration Guide

310

 Create and submit a Payment Application when a Change Commit (change order), with a 
negative line item, is in progress. 

 Create and submit a Change Commit (change order), with a negative line item, when a 
Payment Application is in progress. 

 Create and submit a Change Commit (change order), with a negative line item, when 
another Change Commit (change order), with a negative line item, is in progress.  

Note: The options listed above are available for Base commits of SOV 
type = Payment Applications or Summary Payment Applications. 

Additional information about Removing SOV restrictions 

Users can modify this option (Remove SOV restrictions) at any time except when all the 
Payment Applications and Negative Change Orders that refer to the BP have reached the 
terminal step. 

When you select or deselect this option (Remove SOV restrictions) in an existing Workflow 
template that you plan to use for updating existing Workflow schema in the destination 
Project/Shell, then the selected SOV restriction option (existing in the BP setup level) will get 
updated in the Project/Shell instance. 

When you select or deselect this option (Remove SOV restrictions) in an existing Workflow 
template that you plan to use to create Workflow schema in the destination Project/Shell, then 
the selected SOV restriction option (existing in the BP setup level) will not get updated in the 
Project/Shell instance. 

When you select or deselect this option (Remove SOV restrictions) in an existing Workflow 
template that you plan to use to create Workflow schema in the destination Project/Shell, and if 
this new Workflow schema are used in the Auto Creation tab of the BP setup, then the selected 
SOV restriction option (existing in the BP setup level) will get updated in the Project/Shell 
instance. 

When the SOV restriction option setup is ready and you include the BP in the Configuration 
Package, if there are any in progress (in-flight) records for the Payment Application, or Change 
Commit (change order), then the import will be successful but the system does not update the 
setup information for that BP. 

If the user does not select the Remove SOV restrictions option, then: 

 Multiple payments cannot be created. 

 Multiple negative Change Commits cannot be created. 

 Positive Change Commit will not affect the in transit payment and Merge message will not be 
shown. 

If the user selects the Remove SOV restrictions option, then: 

 Multiple payments can be created. 

 Multiple negative Change Commits can be created. 
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 Merge message is shown only when another payment or Change Commit is created, while 
the first payment is in-flight. 

 Positive Change Commit impacts the SOV Sheet and not the multiple payments. In order to 
support multiple payments, merge needs to occur. 

Setting up a Request for Bid (RFB) Business Process 

A Request for Bid (RFB) business process allows companies to invite bids from multiple 
vendors. The Request for Bid process requires the following components to operate in Unifier: 

 Master Vendor BP (Vendor Master BP): A simple or Line Item type BP (Company level) 
that lists the available vendors who can be invited to bid. A company can have only one 
master vendor BP. The system allows your company to only designate one Vendors 
business process as the RFB master vendor list. 

 Requestor form: This is the BP form the user uses to distribute bid requests from vendors. 

 Bidder form: This is the BP form the vendors use to submit their bids. 

 A workflow for the requestor form: This workflow or workflows can be used to approve the 
RFB before inviting bids, to distribute the RFB, and to approve the final bid award. 

 (Optional) A bid comparison sheet: This is a sheet designed specifically for your company 
for the purpose of comparing the bids you receive from vendors. (If your company has not 
designed one, the system provides a default sheet you can use.) 

Verify the RFB Has Been Designed Correctly 

In uDesigner: 

1) Verify that the correct vendor list is linked to the RFB. 

a. Open your vendor master (Master Vendor BP/Vendor Master BP) business process 
properties and click the Options tab. 

b. Make sure the field Use this process as RFB master vendor list is checked. This 
option links the vendor list to your RFB. 

2) Make sure the correct vendor list has been specified as the RFB's reference process. 

a. Open the RFB and click Reference Processes in the Navigator. 

b. Verify that the RFB references the correct vendor BP. 

In uDesigner, for the RFB business process (BP), you can select a BP Data Picker that 
references a Line Item type BP that can be used to filter the available bidders in the Option tab. 

The BP Data Picker that is available for selection is the one that has been added to the 
Requestor Upper Forms. 

The selected BP Data Picker points to the Line Item type BP that contains the BP Data Picker 
(BP Picker) that is in the Detail Form and subsequently points to the Master Vendor BP/Vendor 
Master BP, at the Company level. 

The following explains the workflow: 

 In the RFB BP, the Options tab enables you to set the data picker that you need to connect 
to the Line Item type BP. 

 The Requestor BP form contains the data picker that points to the Line Item type BP. 
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 In the Line Item type BP, the Details Line Item record contains the BP Data Picker/BP Picker 
that is required to connect to the Vendor BP. 

 The Data Picker/BP Picker points to a Master Vendor BP/Vendor Master BP record at the 
Company level. You can use the query condition, on the data picker, to filter the list of 
vendors (for example: within the same project or before certain dates). 

 The Vendor BP contains the list of vendors who are available for bidding. 

Set up a Bid Management Account 

To enable the vendors to sign in and submit bids, you must create a "bidder" account. In the 
preferences you set up for this account, you must specify certain settings to make the bidding 
process possible. You will enter this bidder's account in your company's preferences. 

Note: Do not link the bid management account to an actual user in your 
company. Create this account strictly for the bidding process so that you 
can set up the account preferences specifically for bidding. If you set up 
a special "bid management" user account, you can prevent users from 
inadvertently changing the settings. 

1) To set up this "bidder" account, add the bidder as a user. 

For more information, see User Administration in the Unifier General Administration Guide. 

2) Sign in as the user with the bidder account. 

3) In the upper-right corner of your window, click your User Name to open a contextual menu. 

4) Click the Preferences link. The User Preferences window opens. 

5) Click the Options tab. 

6) Set the Time Zone field to match that of the bid requestor's (either your company's time 
zone, or the zone from which the bid invitation is sent). 

If your bidders are in a different time zone from yours, this will protect them from mistakenly 
submitting bids after the bidding process is closed. 

Controlling the Display of Information

On the RFB Bidder Portal, the bidder can see the Requestor Package with the Estimated Unit 
Cost, and the Amount. 

As a requestor, there are occasions that you want to ensure that: 

 Bidders do not see bids offered by other bidders. 

 Bidders do not see the cost-related or estimate-related information on the requestor's form. 

As a result, the system allows you to hide values of the requestor's detail form fields from bidder. 
Refer to the Unifier uDesigner User Guide (or uDesigner Help) to learn which options to select.  
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Set up the RFB 

To set up the RFB (in Admin mode): 

1) Follow the standard procedures to import (Importing Business Processes (on page 224)), 
configure (Configuring Business Processes (on page 224)), and set up (see General 
Procedures for Setting up Business Processes (on page 243)) the RFB. 

2) Define a link for the bidders to use to submit bids: 

a. Go to the Company Workspace tab and switch to Admin mode. 

b. In the left Navigator, click your company name. The company landing page opens. 

c. Click the Open button. 

d. In the Edit Company window, click the General tab. 

e. In the Bid Management Account field, enter the account name of the user who will be 
managing the bids that your company receives. 

This is the account that contains the bidder's preferences you created using the 
instructions under Set up a Bid Management Account (on page 312). 

Business Process Permission Settings 

Refer to the Unifier Data Reference Guide for permission settings. 

Business Process Functionality 

Not all BPs work with all functional areas of Unifier. This table lists the available BPs and the 
areas in which the BP works. 

Type Subtype Classification Shell (CBS) 
Shell 
(Generic) 

Company 

Cost 
Commit at 
Company 
level 

- X 

Cost 
Line item 
with CBS 
code 

Generic X 

Cost 
Line item 
with CBS 
code 

Transfer X 

Cost 
Line item 
with CBS 
code 

Base 
Commit 

X 

Cost 
Line item 
with CBS 
code 

Change 
Commit 

X 
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Type Subtype Classification Shell (CBS) 
Shell 
(Generic) 

Company 

Cost 
Line item 
with CBS 
code 

General 
Spends 

X 

Cost 
Line item 
with CBS 
code 

Payment 
Applications 

X 

Cost 
Line item 
with fund 
code 

Generic X 

Cost 
Line item 
with fund 
code 

Transfer X 

Cost 

Line item 
with both 
fund and 
CBS code 

Generic X 

Cost 

Line item 
with both 
fund and 
CBS code 

Transfer X 

Cost 

Line item 
with 
company 
account code

Generic X 

Cost 

Line item 
with 
company 
account code

Transfer X 

Cost 
Line item 
with asset 
code 

- X 

Cost 
Line item 
with multiple 
codes 

Generic X 

Cost 
Line item 
with multiple 
codes 

Transfer X 

Cost 
Line item 
with multiple 
codes 

Base 
Commit 

X 
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Type Subtype Classification Shell (CBS) 
Shell 
(Generic) 

Company 

Cost 
Line item 
with multiple 
codes 

Change 
Commit 

X 

Cost 
Line item 
with multiple 
codes 

General 
Spends 

X 

Cost 
Line item 
with multiple 
codes 

Lease X 

Line item - - X 

Line item - - X X 

RFB - - 

Simple - - X 

Simple - - X X 

Document 
With folder 
structure 

No detail 
form 

X X X 

Document 
With folder 
structure 

With detail 
form 

X X X 

Document 
Without 
folder 
structure 

No detail 
form 

X X X 

Document 
Without 
folder 
structure 

With detail 
form 

X X X 

Text - - X X X 

Resource 
Resource 
booking 

- 

Resource Time sheets - X 

Query-Based Tab in Business Processes 

The Query tab allows access to all Business Processes/Space/Level records, related to a 
Business Process, by way of Query-based Tab (QBT).  

Example 
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If you need to see all approved Spaces related to your BP, you can use the QBT to 
query/fetch those records. After a Query-based Tab (QBT) is successfully created and 
deployed using uDesigner, the Query Tabs appear in the required BP, in User mode. 

A Query-based tab (QBT) is a mini business process log that displays a filtered list of business 
process records in the tab line item list. The QBT can be used in all: 

 Line Item business processes 

 Cost business processes 

 Space business processes 

 Document-type business processes 

Example 

A contract QBT can display just the change orders issued against the contract. Another QBT 
can display only invoices against the contract. Records displayed in the QBT line item list are 
from the same level (project/shell or company.) 

QBTs are not supported in the following business processes: 

 Simple 

 Resource 

 Text 

 Request for Bid (RFB) 

 Project/Shell creation 

In uDesigner, the "Query Items" is a new parent node in the Business Processes (left 
Navigator) with two sub-nodes: 

 Query Tabs

To define the QBTs that will be added to the business process. Query tabs can be created as 
long as the maximum number of tabs (fifteen) has not been reached. 

 Summary Elements

To define summary data elements to be added to the Upper Form of the business process. 
The summary elements specify the type of summary information 
(average/count/total/maximum/minimum) that will be shown from the selected query tab, for 
example, the total amount of records in the tab. 

As a pre-process to defining the Query tab in the business process, you need to use a reference 
picker in one of the upper forms of the business process, Space, or Level from where you want 
to create the Query tab. For defining a Query tab, click the Query Tabs link in uDesigner, click 
New, and select a business process, Space, or Level. The system allows you to create a 
maximum of fifteen tabs in uDesigner, including the QBT. 

Query-based tab enables the user to: 

 View a filtered list of business process records associated with the parent business process. 

After the QBT in a business process is correctly configured and deployed, the QBT appears 
in the business process (User mode) for which the QBT has been configured. 

 Create a new business process from the QBT in the same Project/Shell, where the parent 
business process resides. 
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Users can create new business process records from the QBT provided that the users have 
permission to create business process records for the Project/Shell that contains the 
business process. 

 Copy a business process in the same location as the parent business process. 

Users can copy a business process either with or without attachments. In addition, a user 
can copy any of the records, in the QBT, and create a new business process record. 

Note: Users can copy one record at a time. 

When the user copies a business process record in order to create a new business process, 
the new business process record contains all the information present in the copied/based 
business process record.. So, in case of business records with attachments, the user has the 
option of including or excluding (copying or not copying) the attachments when copying a 
business process record. 

 Search for business process records based on user-entered criteria. 

Users can find any record from the list of records included in the QBT. 

Note: The fields available for the Find feature must be defined in the 
uDesigner for the business process. 

Use the Properties option (log toolbar) to configure the tab. The options are: 

 Line Items 

 Standard 

 Gauges & Meters 

 Hide current tab 

User-Defined Report (UDR) and Query-Based Tab 

Users will be able to use the Summary Elements, from any of the QBTs, in any of the UDRs 
that the user wants to use if the UDR is based on the same business process record. 

Query Tab and Document-type Business Process 

The Document-type business processes support QBTs and Line Item tabs along with the 
existing standard tab. 

To define the Query tab in a Document-type business process, you must add a reference picker 
in the Upper Form of the business process that you want to run the query against. This includes 
business process picker, new data definition, or business process picker for the destination 
business process. 

When users click the Properties option, for an Upper Form on a Document-type business 
process, the Options tab displays the following: 

 Standard Tab (for Document-type business process) 

 Line Item Tab (similar options across each line item type tab) 

 Query Based Tab (similar options across each QBTs) 

Standard Tab (for Document-type business process)
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 Hide current tab 

 Add/Copy Line Items 

 Remove Line Items 

 Allow Modification of Line Item, except when status is 

 Allow Line Item Status to be modified 

 Add Attachments 

 Remove Attachments 

 Append Line Item Folder Structure to Auto Publish Path 

 Make Attachment to a Line Item mandatory 

 Allow comments 

 Allow marking of comments as 'Final' 

 Additional 

 Allow linking Mailbox 

 Attachment Source 

 Unifier Folders 

 My Computer 

Line Item Tab (similar options across each line item type tab)

 Hide current tab 

 Add/Copy Line Items 

 Remove Line Items 

 Allow Attachments to the line item 

 Allow Modification of Line Item, except when status is 

 Allow Line Item Status to be modified 

 Additional 

 Allow linking Mailbox 

 Attachment Source 

 Unifier Folders 

 My Computer 

Query Based Tab (similar options across each QBTs)

 Hide Tab 

 Additional 

 Allow linking Mailbox 

 Attachment Source 

 Unifier Folders 

 My Computer 

To view, or use, a QBT: 

1) Go to the parent business process log in Project/Shell. 

2) Open a record to view the QBT. 

Note: The source business process of the QBT must be active in order 
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for the tab to display. 

See the following topics for more information about creating QBTs. 

Creating Query-Based Tab in Business Processes 

To create a Query tab 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click uDesigner > Business Processes.

3) Select and open a business process (BP). 

4) In the left Navigator for the BP, click Query Items > Query Tabs. 

5) In the Query Tabs log, click New. 

6) In the Select Business Process window, click the drop-down list (under Select Business 
Process/ Attribute field), select a business process or attribute, and click OK to open the 
Query Tab window. 

7) In the Query Tab window, enter values in the Name, Description, and Reference Picker
fields (this is to filter records in the Query tab). 

The value for the Reference Picker field is auto-populated when a user creates a new 
business process record based on a QBT. In such a case, the record number of the parent 
record will be auto-populated and the user can edit the number and change it to a desired 
record number. After the business process record is successfully created, the reference 
graph shows the intended business process record. 

8) When finished, click OK. 

9) In the left Navigator, click Item Logs to begin designing the log. You can have a total of 8 
(eight) tabs, including the Query tabs. 

The log for the Items Log has several columns. The Type column enables you to distinguish 
between the Detail Form line items list and the Query Items. The Tab Name column appears 
before the Name column. Define query conditions in the setup for filtering the list of records 
returned at runtime. 

Note: You can sort Item Logs using the Name, Last Saved, or Type 
column. You cannot sort the log using the Tab Name, Tab Order, or 
System Defined column. 

10) Click to open the Query items window and click the Query tab to begin setting your 
condition. 

11) Click Add to open the Query Condition window. If you do not add a query, the tab returns 
all the records, based on the reference process. 

12) Select and enter values in the Data Element and Condition fields. You can add multiple 
conditions. the system performs the query with "And" operand, on the conditions. 

13) In the left Navigator, go to the Upper Forms node to configure the Query tab options, similar 
to the Detail Forms. 

14) Complete your business process. 

15) Deploy the business process form. 
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Note: When setting two BPs that are dependent on each other with a 
Query Based Tab (QBT), ensure that you do not assign a Summary DE 
(Data Element) to both BPs.  

Additional information: 

Within a selected BP, the Query Items sub-node provides the following two links: 

 Query Tabs

 Summary Elements

Query Tabs

You can use the Query Tabs sub-node to define and maintain the various Query tabs that are 
defined within the business process. 

General Tab

In the General tab, you can enter the name, description, and reference picker for the required 
QBT. 

In case, you have already included the reference picker in the Upper Form of the business 
process, the reference picker appears in the drop-down list of the Reference Picker field. In this 
case, the Name field is populated with the name of the business process, but you can change 
the name of the QBT, if necessary. The name and reference pickers are mandatory fields on the 
General Tab, so you cannot create a QBT if you have not included the reference picker on the 
Upper Form of the business process. 

Query Tab

The Query Tab of the QBT is used to create a query to filter the results, displayed within the 
QBT, based on any particular condition. 

To access the Query Tab, go to Item Logs sub-node, open the QBT that was created, and 
switch to the Query tab. 

Note: It is not mandatory to have a query. If no queries are defined, all 
records display in the QBT, in User mode. 

You can define multiple queries within the Query tab. 

The Query Tabs log allows you to: 

 See all the Query Tabs 

 Create a new QBT (New). 

 Open an existing QBT to review or change content (Open). 

 Delete an existing QBT (Delete). 

Summary Elements

You can use the summary elements on the Upper Form of the business process to show the 
data that is being exchanged. You can use the following types of the summary elements in QBT: 

 Average 

 Count 
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 Total 

 Maximum 

 Minimum 

You can define multiple summary elements. To create summary elements: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click uDesigner > Business Processes.

3) Go to your business process, click the Summary Elements node and use the QBT to create 
your summary elements. After defining the summary elements, click OK to save. 

The log for the Summary Elements node allows you to: 

 See all the Summary Elements. 

 Create a new Summary Element (New). 

 Open an existing Summary Element to review or change content (Open). 

 Delete an existing Summary Element (Delete). 

After you create the summary elements, you can include them in the Upper Form of your 
business process. 





323

Setting up Updates for Business Process 
Records 

Business Processes (BPs) can be associated with a specific Project or Shell (Project/Shell-level 
BP), or they can be applicable for the entire Company (company-level BP) and not be specific to 
a Project/Shell. The Administrator (Project/Shell or Company) determines which forms are to be 
used and how the workflows operate. 

To set up a BP record to receive updates in a Company or Project/Shell, do one of the following: 

For a Company, switch to the Admin mode > Company Workspace > Business Process 
Updates

For a Project/Shell, switch to the Admin mode > Company Sponsored Shells > Business 
Process Updates

In This Section 

Company Workspace and Business Process Updates .......................................... 323 
Project/Shell and Business Process Updates ........................................................ 327 

Company Workspace and Business Process Updates 

To update a Business Process (BP) in the Company Workspace, go to Company, switch to the 
Admin mode > Company Workspace > Business Process Updates. 

Business Process Updates Log in Company Workspace 

The Business Process Updates log in Company Workspace allows you to set up updates from 
a template to a record, at the Company level. The log consists of the following: 

Menu

 File 

 Edit 

 View 

 Help 

Toolbar

 New 

 Open 

 Find 

 Cancel Request 

 View Details 
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Note: These options can be accessed through the Business Process 
Updates log menu options. 

Columns

 Name 

 Source Business Process 

 Source Business Process Record 

 Submit Date 

 Schedule date 

 Start Date 

 Completion Date 

 Status 

 Requested By 

The functions of the elements in the Business Process Updates log are explained in the 
proceeding sections. 

Company Workspace and Preventive Maintenance Type BP 

Preventive Maintenance Business Process (BP) Line Items generate Work Order BP records. 
You can set up a Preventive Maintenance type BP (Preventive Maintenance Book) to create 
Work Order BP records for assets at periodic intervals according to the service needs of the 
asset. 

In the Preventive Maintenance Book, for: 

 Floating Line Items holding non-terminal work orders, you cannot edit the following DEs: 

 Family Identifier 

 Line Item Status 

 Schedule Type 

 Fixed Line Items holding non-terminal work orders, you can edit the following DE: 

 Line Item Status 

The Work Order BP records refer to a Preventive Maintenance type BP (Preventive 
Maintenance Book) in order to view all the Work Order BP records for that Preventive 
Maintenance type BP (Preventive Maintenance Book). 

The Business Process Updates log in Company Workspace allows you to set up updates from a 
PM Book Template to a PM Book record, at the Company level. 

The following explains the following toolbar options:  

Note: These options can be accessed through the Business Process 
Updates log menu options. 

 New

 Open

 Find
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 Cancel Request

 View Details

The New option enables you to create new update requests from the PM Book Template type, 
and the log displays all the PM Book Template updates that exist at the Company level. 

The drop-down list of the New option lists all the BPs of PM Book Template type that have been 
set up in the Company Workspace. If a BP is not Active, or it does not have Active setups, then 
the system does not include the BP in this list. 

Note: If there are no BPs that have Active setups, the New option will be 
disabled. 

When you select a BP from the New option list, the BP record selection window opens which 
enables you to select the source PM Book Template record for the update. 

The BP record selection window contains the log elements/options that have been set in the 
Business Process Configuration. 

The toolbar of the BP record selection window has the same option as the Data Picker window. 

The Open option enables you to view the request details; however, depending on the status of a 
record, this option may not be available, as explained here: 

 If the Status of a record is "Completed/In Progress/Error/Failed," the log has a Close option. 
In this case, you can only view the update request details. 

 If the Status of a record is "Not Started/Not Scheduled," the update setup window opens. 

The Find option enables you to search for a particular request in the log, using the following 
search parameters: 

 Name

 Source Business Process

 Source Business Process Record

 Status

Note: The logical operators are the same as in any String or Pull Down 
field. 

The Cancel Request option enables you to cancel a scheduled update. You can only cancel a 
request that has not started (that is, you can cancel a record that is not stamped with a Start 
Date.). You can cancel multiple requests. After you cancel an update request, the system 
changes the: 

 Status of the request to: Not Started 

 Schedule option to: None 

The View Details option enables you to view the details of an update request. When you click 
this option, the system opens a report in PDF format that outlines the details of all of the PM 
Book records that were updated successfully and those that were not. 
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PM Book Record Update Window 

After you select the source PM Book Template record for the update, the PM Book Record 
Update window opens which contains multiple tabs. These tabs are based on the PM Book 
Template design and are not query-based tabs. 

Note: Depending on the design of the Asset Business Process in 
uDesigner, you may see other tabs (Detail Form tabs) in the PM Book 
Record Update window. For example, you can see Time Schedules tab, 
Gauge Meter Schedules tab, and so forth. 

The following describes each tab in detail: 

 General tab

The General tab is fixed and has the following fields: 

 Name (required) 

 Description (optional) 

 Source Business Process (read-only): The value in this field is the name of the PM 
Book Template Business Process. 

 Source Business Process Record (read-only): The value in this field is the number of 
the PM Book Template record that is the source of the update. 

 Schedule (block): This block has two fields (date and time picker) impacting the schedule 
of the update (Date and None). The date that you select must be greater than the current 
date and time. 

 Main Form tab

The Main Form tab is fixed. The fields in this tab enables you to update the Upper Form field 
values of the PM Book record from the Upper Form field values of the PM Book Template 
record. 

The Data Elements in the Main Form tab are based on the Data Elements that exist in the 
PM Book Template. 

By default, all Data Elements are selected. Use the check box next to Data Element to select 
or deselect all other Data Elements. 

The order of the fields are based on the Upper Form design. 

Use the View Record Details option to open a read-only copy of a record. This is to assist 
the user with reviewing the existing values of the PM Book Template record. 

 Detail Form tabs (Other tabs) 

The Update PM Book Records window displays tabs based on the design of the Detail 
Form (uDesigner > Business Processes > PM Book Templates > Design Form). For 
example, if the Detail Form contains Time Schedules and Gauge Meter Schedules, then the 
Update PM Book Records window displays the Time Schedules tab, Gauge Meter Schedules 
tab, in addition to the fixed tabs (General tab and Main Form tab). 

The Detail Form tabs enables you to select the Line Items that need to be updated in the 
auto-created PM Book records, from the PM Book Template. 

The following elements are available in each Detail Form tab: 

Line Items
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From this block, you can specify the Line Items that you want to get updated in the PM Book 
records, from the PM Book Template. The Line Items block displays all Line Items that exist 
in the selected template record and includes the following information about each Line Item: 

 Line No.

The line number of the Line Item in the PM Book Template. The line number in the PM 
Book record may not have a one-to-one connection with the line number existing in the 
BP Book Template. 

 Short Description

 Line Item Details 

Each Line Item has a View, hyperlink, option that enables you to view the Line Item 
details, in View only mode. 

Data Elements - <name> tab

This section displays the list of applicable Data Elements. Use the Data Element check box 
to select/deselect all elements. The Line Items listed here exist in the auto-created PM Book 
record. 

When an Asset auto-creates a PM Book record, the Line Items, and contents, are copied 
over from the PM Book Template record associated with the Asset. The system associates a 
unique "guide" for each of the Line Items in the PM Book record and maintains a reference to 
the Line Items in the parent PM Book Template record. Since such a reference exists, the 
Line Item in the parent PM Book template record is changed, and the corresponding Line 
Item in the destination PM Book record is updated by means of this Push update. 

New line items can only be added to the Time based tab. If new Line Items are added to the 
PM Book Template record, you need to conduct a push to add the new Line Items to the PM 
Book record, as new Line Items. The Data Elements of the PM Book records are updated as 
part of this push. 

If the Line Items do not exist in the auto-created PM Book records, then the system creates 
the Line Items. The new Line Item creation, in the PM Book records, follow the Line Item 
auto-creation logic, and the new Line Item creation does not refer to the Data Elements 
section of the tabs, at the time of update. The tab mapping that has been set in the design of 
the Asset BP forms the basis for copying over the field values in the PM Book records. 

Project/Shell and Business Process Updates 

To update a Business Process (BP) in the Project/Shell, go to Project/Shell, switch to the 
Admin mode > Setup > Business Process Updates. 

Business Process Updates Log in Project/Shell 

The Business Process Updates log in Project/Shell allows you to set up updates from a 
template to a record, at the Project/Shell level. The log consists of the following: 

Menu

 File 

 Edit 

 View 
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 Help 

Toolbar

 New 

 Cancel Request 

 Open 

 Find 

 View Details 

Note: These options can be accessed through the Business Process 
Updates log menu options. 

Columns

 Name 

 Source Business Process 

 Source Business Process Record 

 Submit Date 

 Schedule date 

 Start Date 

 Completion Date 

 Status 

 Requested By 

The functions of the elements in the Business Process Updates log are explained in the 
proceeding sections. 

Project/Shells and Preventive Maintenance Type BP 

Preventive Maintenance Business Process (BP) Line Items generate Work Order BP records. 
You can set up a Preventive Maintenance type BP (Preventive Maintenance Book) to create 
Work Order BP records for assets at periodic intervals according to the service needs of the 
asset. 

In the Preventive Maintenance Book, for: 

 Floating Line Items holding non-terminal work orders, you cannot edit the following DEs: 

 Family Identifier 

 Line Item Status 

 Schedule Type 

 Fixed Line Items holding non-terminal work orders, you can edit the following DE: 

 Line Item Status 

The Work Order BP records refer to a Preventive Maintenance type BP (Preventive 
Maintenance Book) in order to view all the Work Order BP records for that Preventive 
Maintenance type BP (Preventive Maintenance Book). 

The Business Process Updates log in Project/Shell allows you to set up updates from a PM 
Book Template to a PM Book record, at the Project/Shell level. 
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If you link your Time and Meter Schedules within a PM Book BP, you can avoid generating 
multiple PM work orders if a meter-schedule occurs sooner than a time-schedule, or vice versa. 
The following scenario provides a good example for this feature: 

A commercial vehicle is scheduled for an oil change either when it reaches 5000 miles 
(meter) or 12 months (time) after the last oil change, whichever is reached first. If the vehicle 
reaches 5000 miles prior to 12 months, then the system generates a PM work order and 
automatically prevents a second PM work order when the 12 months time-frame comes. 
Conversely, if 12 months passes and the vehicle does not reach 5000 miles, then the system 
generates a PM work order and automatically prevents a second PM work order when the 
vehicle reaches 5000 miles. 

To prevent generating an additional work order, in such a case, you can use the 
"uuu_rec_related_family_id" data element to link the meter-schedule and the time-schedule 
within a PM book or PM book template. To update the "uuu_rec_related_family_id" data 
element from PM Book templates to use for all PM Books, go to either of these locations: 

  Shell (Admin mode > Setup > Business Process Updates node) 

 Company Workspace tab (Admin mode > Company Workspace node > Business 
Process Updates) 

Once selected, all of the PM Books will be updated with correct values from the related PM Book 
Template, according to the push schedule defined within this log. 

For more information, see Company Workspace and Preventive Maintenance Type BP (on 
page 324). 
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Setting up the Code and Records-based 
Configurable Manager 

Configurable manager, as well as classes, forms, and corresponding logs are designed in 
uDesigner (Configurable Modules) and deployed to Unifier. You must also define the business 
processes that work with the configurable manager. 

Note: Assign a specific name for the configurable manager in 
uDesigner. The generic term used in the instructions is configurable 
manager. 

Step 1: Design Code and Records-based configurable manager in uDesigner (Configurable 
Modules). 

Step 2: Setup the Business Process Data elements under the Options tab and deploy the 
manager. After the manager has been deployed, classes can be designed and deployed. 

Step 3 Set permissions. 

Step 4: Configure the code and records-based manager. 

Step 5: Set the template administration permissions. 

Step 6: Create template sheets and add columns. 

Step 7: Set permissions for the user. 

In This Section 

Setting Permissions to Import Configurable Managers .......................................... 332 
Importing Code and Records-Based Configurable Managers ................................ 332 
Deleting a Material Inventory Manager .................................................................. 332 
Setting Permissions to Import Classes .................................................................. 332 
Importing Classes for Code and Records-based Configurable Managers .............. 332 
Configure configurable manager classes ............................................................... 333 
Run an Error Check on a Class ............................................................................. 333 
Configure a Data Picker for the Manager .............................................................. 334 
Setting Template Administration Permissions ........................................................ 335 
Managing Class Template Sheets (Classic view) .................................................. 336 
Managing Class Template Sheets (Standard view) ............................................... 342 
Setting User Permissions for Code and Records-Based Managers ....................... 342 
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Setting Permissions to Import Configurable Managers 

You must have modify permission under User Administration > Access Control > 
Administration Mode Access > Data Structure Setup > Configurable Modules to import 
configurable managers. You can set view permissions to allow users to view configurable 
modules. 

Importing Code and Records-Based Configurable Managers 

All designs, including configurable managers, are designed in uDesigner and deployed to 
Unifier. See Importing Configuration Packages (on page 619). 

Note: Importing Forms that Contain Data Pickers: Data pickers point to a 
data source for the records they display. If that data source—the BP, 
shell, or manager class—to which the picker is pointing is not already in 
Unifier, you will receive a warning. The business process will not operate 
correctly until the data source is imported. 

Deleting a Material Inventory Manager 

This section describes how to manually delete a record under Material Inventory Manager from a 
shell template. 

Note: You can delete a record under Material Inventory Manager from a 
specific shell template but not from other Projects/Shells that have been 
created using the template. 

1) Open the project/shell and switch to Admin mode 

2) In the left Navigator, click Setup > Material Inventory Manager. 

3) Select a record from Material Inventory Manager for deletion. 

4) Click Delete. 

5) When the confirmation message appears, click Yes to delete the record from the Material 
Inventory Manager. 

Setting Permissions to Import Classes 

Classes must be deployed before you can set permissions. Set permissions based on existing 
permissions for the Company > uDesigner. 

Importing Classes for Code and Records-based Configurable Managers 

To import a class into the Unifier Production environment, see Importing Configuration 
Packages (on page 619). 
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Configure configurable manager classes 

Imported configurable manager classes are listed in the manager configuration log, with a 
default status of inactive. 

To configure a configurable manager class 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > [configurable manager]. The Configurable 
Manager log opens. The log lists the classes. 

3) Select a class record from the log and click Open. The Configuration window opens. 

4) Complete the General tab as described in the table below. 

5) On the Custom Print tab, using the Microsoft Word XML schema, you can create a 
customized printed output. 

6) To make the class active, click Active. This enables classes and sheets to be created in 
User mode. The class is also available to use as a project category or shell type. 

7) Click OK. 

In this field: Do this: 

Sequence Format 

Define the sequence of the record 
numbers for records created for this class 
in User mode. This is similar to business 
process numbering. 

Help File 
You can upload a PDF file to use as a help 
file for the manager. 

Auto Creator Select the auto-creator. 

Status 

Activating the configuration makes the 
class available in User and Admin mode 
for creating records, sheets, and 
templates. 

Run an Error Check on a Class 

To error-check imported classes 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click uDesigner > Configurable Modules > [configurable manager] in the left Navigator 
to open the Configurable Manager log. 

3) Select one or more classes in the log. To select multiple classes, press the Ctrl key or Shift
key while selecting the classes. 

4) Click the Error Check button. After validation, the error check window opens, listing any 
errors that were found. 

5) To fix the errors, make the changes in uDesigner. 



Modules Setup Administration Guide

334

Configure a Data Picker for the Manager 

If your Code and Records-based manager includes a data picker or a user data picker, it must 
be configured to examine and extract the records that should appear on the picker list. To do 
this, you need to create a database query. (For more information on data pickers, see About 
Data Pickers and About User Data Pickers in the Unifier uDesigner User Guide. For more 
information on queries, see Queries in the Unifier General Administration Guide.) 

After you have set up the query or queries for a data picker, and the picker is active, the queries 
will be launched whenever: 

 The user clicks the data picker field on a form 

 The business process is auto-created 

 A record is created or updated through integration (both CSV and Web Services) 

 The data picker is updated via reverse-auto-population 

In addition to setting up queries to extract records for the picker, you can configure the picker to 
filter the records that the query returns so that only certain records appear on the picker. This is 
particularly convenient, for example, if the manager attribute form contains a user data picker 
that automatically assigns users to an object as it is created. 

To configure a data picker 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click uDesigner and select any functional sub-node. 

3) Open an item from the log (design object).  

4) Select the design and click Open > Data Picker to open the Data Picker Configuration
window. 

5) In the left pane, click the name of the data picker. 

6) Create the query. 

The query will search the database and extract the records to display on the data picker. The 
query will filter the records returned from the database according to a condition or conditions 
you specify. The condition(s) will "test" a field on the form to see if it passes or fails the 
criteria. If the field passes the criteria, Unifier will include it on the data picker. 

a. Click the Add button. Unifier displays the Add Query Condition window. 

b. In the Data Element field, select the field on the business process that you want to test 
with the condition. 

For example, the condition might be that the status field on the shell must be "Active." 

The window expands to show an active Condition field and additional fields where you 
can specify the query criteria. 

Note: If any field in the query or queries is subsequently removed from 
the configurable manager attribute form, the entire query operation will 
be ignored. That is, if one query fails because a field was removed from 
the design, the system will ignore all the queries. If a field has been 
removed from a design, you must amend the query. 

c. In the Condition field, select the condition the value in the field must meet. 
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The remaining fields on this window vary, depending on the data element and the 
condition you specified. For help in completing these fields, use the information in the 
Queries section of the Unifier General Administration Guide to complete the query. 

d. Repeat steps a through c to include additional query conditions. 

7) (Optional) Filter the returned records. 

This filtering option appears on configurable manager attribute forms that contain user data 
pickers. This option will filter the list of groups or users that appear on the picker. Use the 
instructions in the table below to filter the returned records. 

8) When you have finished, click OK. 

In this field: Do this: 

Filter list of 
Users/Groups 
based on 
Project/Shell 
Membership 

Select this check box if you want to filter the list of users on the 
picker to show only those with project or shell membership. 

In operation, the system will auto-populate and 
reverse-auto-populate the data picker with all users or groups, 
regardless of this check box. However, at runtime, the system will 
filter the picker for the user if you select this check box. 

Note: If you select this option, the rest of the filtering options will 
be disabled. 

Group Membership 
Select the group from which you want to specify a user or users. 
The drop-down list shows all the groups that are at the company 
level. 

Project/Shell 
Membership. 

If you want the system to add these users to the shell 
membership, select the Add user to Project/Shell check box. If 
you want to also add these users to the group under the shell, 
select the Add user as a member to the selected group check 
box 

Note: To use this option, the user data picker must be on the 
upper form, not the detail form. 

Show results 
matching any 
condition 

If the check box is selected, the query conditions will be "OR." 
When this option is selected, the value in the AND/OR column 
will be updated to "OR." 

If the check box is deselected, the value in AND/OR column will 
be "AND." If the check box is selected, then records satisfying 
any of the query conditions would be displayed at run-time. 

If the check box is deselected, then records which satisfy all of 
the query conditions will be displayed.  

Setting Template Administration Permissions 

After you have configured a configurable manager, you can create templates to use with the 
manager. 
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When you activate a new class, you must grant permission to yourself, another administrator, or 
a group such as company administrators to administer class templates and create classes in 
User mode. 

You must have administrator permission granted under User Administration > Access Control 
> Administration Mode Access > Data Structure Setup > Configurable Modules to 
administer configurable managers. 

Managing Class Template Sheets (Classic view) 

You can create one or more class templates for each class for each configurable manager. 

Create a class template 

You can create a new class template manually or by copying an existing template that is the 
same class as the new template. 

To manually create a class template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Configurable Modules. 

3) On the right pane, expand Administration Mode Access and then expand General 
Administration. 

4) In the left Navigator, select the configurable manager. The templates log for the classes 
opens. 

5) Click the New button. Select the class for which you want to create the new template. The 
Properties window opens. Complete the window as described in the following table and then 
click OK. 

In this field: Do this: 

Title 
Enter the name of the sheet, which reflects 
the class name and is read only. 

Description Enter an optional description. 

Display Mode 

Choose one of the following: 

 Tree: Lists the codes in a hierarchical 
manner based on the code segments, 
mimicking the tree structure in the 
Navigator. 

 Flat: Lists the codes in a flat structure. 

Picker 

Choose one of the following to include: 

 All Records: All records created in the 
class are displayed on the sheet. 

 Records with statuses: Only records 
of the selected status are displayed on 
the sheet. Click Select and choose 
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one or more statuses from the list. 

To copy an existing template 

1) To copy a template from the company level, select a class template from the log and click 
Copy > Template. The Properties window opens with the information from the original 
template. 

2) To copy a template from the project or shell level, click Copy > Project or Copy > shell 
name. 

3) Make changes as needed and click OK to save the new template. 

To access configurable manager class templates 

1) In Admin mode, go to the Company Workspace tab and click Company > Templates > 
Configurable Modules. 

2) In the left Navigator, select the configurable manager. The templates log for the classes 
opens. 

To search for a class template 

In the class template log, click Find. You can search for the template based on the fields 
available on the form used for the template. These fields vary depending on the design. 

Add columns to sheet templates 

You can add columns to configurable manager sheet templates. You can use these columns to 
capture data from business processes or manually entered data. You can add columns to the 
template, but cannot add rows. 

Users with create permission on class sheets are allowed to create and define columns. 

To add a sheet column 

1) Open the sheet. 

2) Click Columns. The Columns Log opens. 

3) Click New. The Column Properties window opens. Complete the window as described in the 
following table. 

In this field: Do this: 

Name 

The Name field is populated with the data 
source value selected. You can change 
this name as desired. It is helpful, but not 
required, to use a unique name. 

Datasource 

Select a data source. You can use a data 
source only once; however, you can use 
the column in a formula. For example, if 
one data source is Commits (Approved), 
and another is Change Commits 
(Approved), you can add them together in 
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a new column called Total Commits 
(Approved). 

Entry Method 

Choose the data-entry method to use for 
the column. The choices available depend 
on the data source selected. The options 
include: 

 Manual entry: Users can enter data 
directly into the cell, or data is rolled up 
from another source, such as the form.

 Formula: The options are Numeric, 
Date Difference, and Date Add. See 
Add a formula column (on page 339) 
for details on adding formula columns. 

 Data Type: Applicable if the data 
source is SYS Business Process, a 
business process, or information from 
the project cost sheet. After selecting 
the data type, click Define to choose 
the data element or define a formula 
based on the data element. 

Data Format 

Specify how you want the data in numeric 
columns to appear. 

 Show as Percentage: Data displays 
as a percentage. For example, if a user 
enters 0.25, it displays as 25%. 

 Decimal Places: Select the number of 
decimal places to display. 

Note: When entering the percentage 
values in your sheet, if you are working in 
Classic View, then enter the value by using 
decimal number format. For example, for 
ten percent, enter: 0.1, and if you are 
working in Standard View, then enter the 
value by using percent format. For 
example, for ten percent, enter: 10%. The 
value that Unifier uses to validate the value 
of the Percentage column, when 
applicable, will be: 0-100. 

If the data element was defined in 
uDesigner with a specific decimal amount, 
it will override any decimal amount you 
specify here. 

 Use 1000 Separator (,): Data uses a 
separator for thousands. For example, 
1,000 with a comma, not 1000. 

 Negative Number Format: Select 
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whether negative values are displayed 
with a negative sign or in parentheses. 

Display Mode 
Select Hide to make the column invisible 
to users, or Show to display it. 

Total 

Controls what displays in the bottom 
summary row for each column: 

 Blank: The summary row remains 
blank. 

 Sum of All Rows: Displays the sum 
total of all row values for this column. 

 Use Formula Definition: Use the 
formula entered in the Formula field. 

Column Position After 
Determines the position of the column on 
the sheet. Select a column from the list. 

To copy a column 

1) In the Column log, select a column and click Copy. The Column Properties window opens. 

2) Make changes as necessary for the new column. You must change at least the data source. 

Add a formula column 

You can add a formula column to the sheet for data sources that are based on either the data 
definitions SYS Numeric Logical Datasource or SYS Date Logical Datasource. 

You can define formulas for the following types: 

 Numeric: This option is available if the data source is SYS Numeric Logical. 

 Data Difference: This option is available if the data source is SYS Numeric Logical. It is 
used for formulas that calculate the difference between two dates. 

 Date Add: This option is available if the data source is SYS Date Logical. It can be used to 
add values to a date to calculate a new date. 

To create a numeric formula 

1) In the column Properties window, choose Formula and select Numeric. 

2) Click Create. The Create Formula window for numeric formulas opens. 

3) Select either Item or Sheet from the data type drop-down list. Item lists data elements that 
are defined on the form. Sheet lists columns that are already defined on sheet. 

4) Build a formula by doing the following: 

 To include a data source in the formula, select the data source from the list and click 
Select. 

 Click a mathematical modifier (plus, minus, and so on) and numbers on the keypad. 

5) When the formula is complete, click OK. 
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To create a date difference formula 

1) In the column Properties window, choose Formula and choose Data Difference. Click 
Create. The Date Difference window opens. 

2) For Earlier Date and Later Date, click Select. Select a data element. The list includes date 
type data elements from the form or existing date type columns on the sheet. 

3) Choose one of the following: 

 Calculations based on Calendar Days: The calculation is based on calendar days and 
does not take company non-working days into account. 

 Calculations based on Work Days: The calculation is based on the company calendar 
working and non-working days. 

 Show Partial Day

4) Click OK. 

To create a date add formula 

1) In the column Properties window, choose Formula and choose Data Add. Click Create. The 
Date Add window opens. 

2) For the Date field, click Select and choose a data element from the list. 

3) For the Add field, click Select and choose a data element from the list. 

4) Choose one of the following: 

 Calculations based on Calendar Days: The calculation is based on calendar days and 
does not take company non-working days into account. 

 Calculations based on Work Days: The calculation is based on the company calendar 
working and non-working days. 

5) Click OK. 

Copy sheets under project or shell templates 

You can copy one sheet for each project or shell template. 

To copy a sheet under a project or shell template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Projects > All or Company > Templates > Shells > 
[shell]. 

3) To copy a template from the company level, select a class template from the log and click 
Copy > Template. The Properties window opens with the information from the original 
template. 

4) To copy a template from the project or shell level, click Copy > Project or Copy > shell. 

5) Make changes as needed and click OK to save the new template. 

Deleting Sheets Template 

This section describes how to manually delete a sheet associated with code-based or 
record-based Manager from a shell. 
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Note: You can delete a sheet associated with code-based or 
record-based Manager from a specific shell template but not from other 
Projects/Shells that have been created using the template. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Configurable Modules > Material Inventory 
Manager > Sheets. 

3) Select a sheet associated with code-based or record-based Managers. 

4) Click the Delete icon. 

5) When the confirmation message appears, click Yes to delete the sheet from the code-based 
or record-based Managers. 

Manage sheet properties 

The Properties window for the sheet maintains the name and display options. 

To open the summary sheet Properties window 

In the Configurable Manager Sheets log, select the sheet and click the Properties button. 

In this field: Do this: 

Title 
This is the name of the sheet, which 
reflects the class name and is read-only. 

Description Enter an optional description. 

Class 
Read-only field that displays the class 
associated with the sheet. 

Display Mode 

Choose one of the following: 

 Tree: Lists the codes in a hierarchical 
manner based on the code segments, 
mimicking the tree structure in the 
Navigator. 

 Flat: Lists the codes in a flat structure. 

Picker 

Choose one of the following to include: 

 All Records: All records created in the 
class are displayed on the sheet. 

 Records with statuses: Only records 
of the selected status are displayed on 
the sheet. Click Select and choose 
one or more statuses from the list. 
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Managing Class Template Sheets (Standard view) 

View Code-Based Managers Log 

For details on how to view the code-based managers log, refer to the Unifier Managers User 
Guide. 

View Code and Records-based Managers Log 

For details on how to view the Code and Records-based managers log, refer to the Unifier 
Managers User Guide. 

Setting User Permissions for Code and Records-Based Managers 

For users to be able to work with the configurable manager class sheet, you must set user 
permissions for the class sheet under Access Control > User Mode Access > Company 
Workspace > configurable manager name > Class Sheets. 
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Setting up the Cost Manager 

The Cost Manager consists of several modules designed to help you track and manage cost in 
projects/shells and across the company. 

In This Section 

Cost Manager Overview ........................................................................................ 343 
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Cost Manager Overview 

The Cost Manager consists of the modules and features listed below. 

Cost Sheets 

Project/Shell cost sheet: The project or shell cost sheet is a detailed accounting of the project's 
or shell's budget and costs. It works much like a spreadsheet within the system that calculates 
and maintains the project or shell cost information stored in the project or shell. The project or 
shell cost sheet rows contain unique CBS codes (or cost codes), which can be used to link 
project or shell costs to the general ledger for finance. Cost information can be entered 
manually, pulled from work packages or worksheets, or rolled up automatically from business 
processes when transactions occur. 

Company cost sheet: The company administrator can create a company-level cost sheet to 
display cost data across project or shells. Projects or shells on the company cost sheet are 
added by default as project- or shell-level cost sheets are created. Only active and on-hold 
projects or shells should be rolled up to a company-level cost sheet. Projects and shells are 
listed in order by project or shell number in an ascending order. Data rolls up to the company 
cost sheet columns from individual project or shell cost sheet columns by data source. 

Work packages: In addition to a project or shell cost sheet, multiple work packages may also be 
defined. A work package is a group of cost sheet rows that is a subset of the project or shell cost 
sheet. Work packages provide insight into the budget without providing full access to the details 
of the project or shell cost sheet. 
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Worksheets: Cost worksheets can be created to support the project or shell cost sheet. They 
can be used as sub-cost sheets, enabling specific calculations or data entry in a separate sheet, 
which can then be rolled up into a defined project or shell cost sheet column. For example, a 
worksheet can be used to offload complex calculations, which can be rolled up into a single cost 
sheet column. Worksheets support manual data entry and formulas. Business processes do not 
roll up to worksheets. Permissions can be controlled for individual worksheets. Worksheets are 
not independently reportable; however, cost sheet columns that reference worksheets can be 
reported on. 

Funding Manager 

Company funding sheets: The company funding sheet tracks all sources of funding across all 
projects or shells. You create only one sheet per company. Funding sources that are made 
available at project or shell sheet level are rolled up to the company sheet, which maintains the 
overall fund information. After it is created, the company funding sheet can be edited, but not 
deleted. The company funding sheet must be created before creating individual project or shell 
funding sheets. 

Project/Shell funding sheets: The project or shell funding sheet tracks how funding is being 
allocated and consumed at the project or shell level. Project or shell fund sheets work in 
conjunction with the company funding sheet. Allocating funding sources at project or shell level 
can be done manually or through a business process. A funding template and company funding 
sheet must be complete before you can create a project or shell funding sheet. 

Commitment funding sheets: You can optionally set up commitment level funding, which 
allows you to allocate specific project/shell funds to individual base commit records. This works 
in conjunction with the SOV sheet to track base and change commit lines and balances. 

Cash Flow 

The advanced Cash Flow module includes the ability to create multiple baseline, spends, 
forecast and custom curves and compare them on one cash flow worksheet. You can create 
data source, distribution profiles, and cash flow curve templates to simplify creation of cash flow 
in multiple projects and shells. Administrators can also set up base commit business processes 
to automatically create cash flow curves for the commitment record at a particular workflow 
step,(or for non-workflow BPs, when the record is complete). 

Earned Value 

The earned value module provides quantitative tracking information about project or shell status 
using earned value analysis. It provides specific numerical measurements for reviewing progress 
as the project or shell team advances through the work tasks allotted to the project or shell 
schedule. The module helps project or shell managers track whether projects or shells are on 
schedule and on budget. It provides accurate and consistent methods to estimate the percent of 
budget spent, percent of work done, and percent of time elapsed. 
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Schedule of Values (SOV) Sheet 

The schedule of values (SOV) module provides a way to assemble information from contract, 
change order and invoice/payment business processes into an SOV sheet, streamlining the 
process of invoicing for completed phases of a project or shell. SOV functionality is available 
with uDesigner-created cost BPs for which the Allow creation of Schedule of Values option is 
defined. 

The business processes can be designed to create an SOV sheet automatically upon reaching 
the designated step. 

The following are the SOV sheets types: 

 General Spends 

 Payment Applications 

 Summary Payment Applications 

Generic Cost Manager 

The Generic Cost Manager captures cost-related activities for a generic shell. These include 
costs like rent, lease payments, landscape care, building maintenance and repair, remodel of 
building interiors, and more. 

With this manager, you can capture and view cost transaction information based on a timescale, 
such as quarterly or yearly. Each shell can have one Generic Cost Manager. The Generic Cost 
Manager uses specific generic cost business processes as a data source. 

Grouping Line Items and Auto-Creation 

You can group line items during auto-creation of BP records, in Lease type business process 
(BP).  

1) Go to the project/shell tab and switch to Admin mode. 

2) In the left Navigator, click Setup > Business Process to open the Business Processes log 
pane. 

3) From the Business Processes log, select a Leases BP, for example, Leases - Tenant BP. 

4) Select a BP record and click Open to open the Business Process Setup window. 

5) Click the Auto Creation tab. 

6) From the left pane, click Payment Request (or Payment Invoice). 

7) On the right pane, select Enable grouping of line items when auto-creating records from 
line item tabs. 

8) From the Group By field, click Select and proceed to select the data element, or elements, 
that you want from the Select Data Elements window. 
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9) When finished, click Apply, and then click OK. 

Consolidating strings cannot take place if the field values are different. As a result: 

 If you select a data element other than "Payment Type" (uuu_lse_pay_type), in the Group 
By field and the auto-created record, has a different payment type across the grouped line 
items, then the auto-created BP record will have a blank payment type. 

 Same logic is followed if a data element is present in the auto-created BP record, but the 
data element has a different value across the line items. 

Cost Managers and Unifier Functional Areas 

The standard Cost Manager and the Generic Cost Manager work with different areas of the 
system. This table lists the areas and indicates which cost manager works with each area. 

Cost Manager Company Shell (CBS) Shell (Generic) 

Cost Manager 
(standard CBS) 

X X 

Generic Cost 
Manager 

X 

The cost data from Project (Standard) and Shell (CBS) can both roll up to the Company level. 
The cost data from Shell (Generic) does not roll up to Company Level. 

About Currencies and Exchange Rates 

The cost management system supports multiple currencies and exchange rates. The functions 
that the system uses are exchange rates sets, effective dates, future exchange rates, base 
currency, project currency, transaction currency, project/shell currency options, and currency 
pickers. What follows are descriptions of each of these functions and how they are used. 

Currencies 

Standards & Libraries > Currencies: This is where an Administrator can manually add new 
currencies to suit the company business needs, in addition to the predefined list of currencies. 
You must have the applicable permission to access the Currencies sub-node. Depending on 
your permissions, you can use the Currencies log to add new, modify, and delete currencies. 
You can also search for a specific currency. 

You can see the Currencies node in the Permission tab of the User properties: Company 
Workspace > User Administration > Access Control > Administration Mode Access > 
Standards & Libraries > Currencies. 

An Administrator can set up both users and Groups permissions to the Currencies sub-node. 

 A user that has the "Create" permission can add, modify, and view currencies. 

 A user that has the "Modify" permission can modify and view currencies. 

 A user that has the "View" permission can view currencies. 
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The Currencies log includes a list of predefined currencies displayed in alphabetical order. In 
addition: 

 Currency code is displayed for all the existing currencies. 

 If currency symbols exist, the currency symbols are populated under the Currency symbol 
column. 

 Users who have permissions can modify the predefined currencies. 

 Description lists all the countries that use that currency. 

 The Decimal Places field is read only, as it matches the decimal places used by the 
currency.  

Note: The number of decimal places can only be defined when a new 
currency is added. The number of decimal places for an existing 
currency cannot be edited.  

To add new currencies 

1) In the toolbar, click New. 

2) In the Currency Details dialog box, enter the following: 

 Currency Name: (required) Enter a name in this text field (maximum of 250 characters). 
The Pipe character (|) and back slash (\) are not allowed. 

 Currency Code: (required) Enter a code in this text field (maximum of 8 characters). The 
Pipe character (|) and back slash (\) are not allowed. 

 Currency Symbol: Enter a symbol in this text field (maximum of 8 characters). The 
following characters and patterns are not allowed: 

 Single characters such as: . , () - 

 Characters such as: | ' " \ 

 Patterns such as: $$ $& $` $' 

 Description: Enter a description in this text field (maximum of 500 characters). 

 Decimal Places: Select the applicable number of decimal places, from 0 to 4. 

Note: After the currency is saved, the Decimal Places field becomes 
read-only and cannot be changed. 

3) To save the currency, click OK. 

4) Validate the new currency by ensuring that the: 

 Currency Name is unique and does not exist in the predefined list. 

 Currency Code is unique and does not exist in the predefined list. 

 Number of characters entered in the text field does not exceed the limit. 

To update a currency 

1) Double-click the applicable currency. 

You can also select the currency and click Open. 

2) Make the applicable changes. 
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After you have created a currency and defined the exchange rates for it, you can modify the 
Currency Name, Currency Symbol, and Description. You cannot modify the Currency Code. 

3) To save your changes, click OK. 

To add new currencies 

Select the applicable currency and click Delete. 

Notes:

 You cannot delete a currency that has been used to define exchange 
rates. 

 You cannot delete the Base Currency defined by your Company 
Administrator. 

To search for a currency 

1) In the toolbar, click Find. 

2) In the Find window, select the logical operator and enter the applicable search parameter in 
the Currency Code or Currency Name text field, or both. 

3) Click Search. 

To view the Audit Log 

1) Select the applicable currency. 

2) From the View menu, select Audit Log. 

The Audit Log displays the additions and modifications applied to currencies. Audits log lets you 
select a record to see the audit information. 

Show Currency List window 

The Show Currency List window, which you can see when you are defining the exchange rates, 
displays a list of currencies that you have defined in the Currencies sub-node. The Show 
Currency List window includes a Description field that lists the country name; if there are multiple 
countries that share the same Currency Name, the country names are listed and separated by a 
comma (for example, for Currency Name of Euro (EUR), the Description field lists: Andorra, 
Belgium, France, and so forth). 

Note: If the currency name is modified, the existing exchange rate CSV 
template fails. You must export the exchange rate template again for the 
new currency name. The existing Web Services calls for record 
creations and updates fails if the currency names are modified. 

Similar to other custom string translations the currency names can be translated for 
internationalization. 
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Base currency 

The Base Currency is the default currency specified by your Company Administrator when that 
person signs into the system the first time. Upon creation, the Base Currency is fixed and cannot 
be changed. The Base Currency becomes the default currency for projects and shells; however, 
the default currency can be changed during project or shell creation. Company-level cost data 
roll-ups can draw from multiple projects and shells. Each of these projects or shells can have a 
different project currency. 

Project currency 

A Project Currency is the currency that was selected as the project or shell-level default currency 
during project or shell creation. This can be different from the Base Currency, and you must take 
the following steps before you save the new project or shell. 

 First: Before creating the project or shell, verify that the non-base currency exists in the 
Exchange Rate Set. 

 If it does not, you can add it. 

 If the exchange rate effective date is in the future, you cannot add it to the project or shell 
currency set. 

 Second: During project/shell creation, add the non-base currency to the project or shell. 

 Third: During project/shell creation, select the non-base currency as the project or shell 
default currency. 

The system calculates and stores costs in the project currency. Business process records 
created in a non-project currency, such as a transaction currency, use the exchange rate that 
was active at the time of record creation for currency conversion to project currency. 

Project/shell currency options 

When adding a currency to a project or a shell, you have the options to float, hedge, or peg the 
currency rate. These options establish how to handle fluctuations in that currency's market rate. 

 Float: A currency's value fluctuates according to the foreign exchange market. The system 
updates currency exchange rates according to the effective date of the Exchange Rate set. 

 Hedge: Intended to reduce future risk of currency fluctuations. 

 Peg: The currency exchange rate is fixed. Pegging impedes project currency conversion in a 
project or a shell. 

Role rates changes due to currency exchange rate changes only consider Float and disregard 
Hedged or Pegged rates. 

Transaction currency 

This is a currency that was added to the project or shell Currencies, and picked at run time using 
a currency picker on the commitment business process. Upon record creation, the system uses 
the current active currency exchange rate in the Exchange Rate table to convert a transaction 
currency to the project currency. 
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Cash flow curves display data in the transaction currency, if different from the project currency. 
At run time, users can switch between currency views, but they can only modify values in the 
transaction currency view. 

Currency picker 

Currency pickers are available only for the upper form of a cost-type commitment business 
processes such a contract or a change order. This means all line items will be in the record, or 
transaction, currency. 

Exchange Rates 

Standards & Libraries > Exchange Rates: This is where you can add currencies and define 
their exchange rates against the base currency, which was specified by your Company 
Administrator when that person signed into the system the first time. You can add currencies, 
manage currency exchange rates, and set currency effective dates as needed. Each line in the 
Exchange Rates log is considered a set. 

Note: In addition to the predefined list of currencies, an Administrator 
can add new currencies to suit the company business needs. 

Currency conversions use the exchange rate defined in the active Exchange Rates set. Until you 
modify a currency rate, the system uses the last active rate for that currency. 

You can take the following actions to manage currencies: 

 Create a New Exchange Rates set. You can make the set active today, or you can set the 
effective date to a future date, or you can set the effective date in the past. 

 Modify an existing Exchange Rates set that has a future effective date. You can modify rates 
in a set until it reaches the effective date. You can change the effective date to as soon as 
tomorrow, but you cannot change the effective date to today. You can edit Exchange Rate 
Records whose effective dates are in the past. 

 Set an Effective date: On the chosen date, at 12:00 am system date and time -- in your time 
zone -- the effective date becomes active. 

For example: 

 Your time zone is Munich, Germany (UTC + 1) 

 April 20 you add a future exchange rate and set the effective date as May 1 

 May 1 at 12:00 am the currency rate takes effect in Munich's time zone 

 April 30 at 3:00 pm the currency rate takes effect in Los Angeles' time zone 
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Note: Effective dates for the new exchange rates records can be set in 
the past. 

View Exchange Rates 

According to the date, it displays: 

 Currency Name 

 Currency Symbol 

 1.0 Base Currency 

 Effective Date 

Future currency exchange rates 

Future exchange rates let you plan ahead for currency fluctuations. The system uses the active 
exchange rate based on the effective date; however, cash flow curves show currency rate 
changes at the beginning of the first full month the rate is in effect. 

In the Baseline details example that follows, you can see differences in values due to future 
exchange rate conversions. 

 The transaction currency is INR. 

 The project currency is EUR. 

 The distribution is linear. 

 The distributed values are 37,000 INR per time period. 

 May and June rates take effect on the first of the month, respectively. 

 A July future exchange rate takes effect in Unifier on 07/02/2012, so the system continues to 
display the value of the June rate in the cash flow. 

 The August rate shows up in the cash flow curve on 08/01/2012.  

Additional information 

For Cost transactions, the exchange rate used is based on the latest update date of the BP 
record. 

The uuu_effective_date is not used for determining the rate to be used on a BP Record. 
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Managing Currencies and Exchange Rates 

The exchange rate set defines the currencies that are available for use within the system and 
their corresponding exchange rates, which are based on the company base currency. The 
exchange rate set that is currently active in the system will display a status of Active. All previous 
sets are retained, so you can view the currencies and rates that were active in the system in the 
past. Future currency rates are also listed in the log. 

To view the company base currency 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates 
log opens, displaying the following information: 

 Effective Date: This is the date the base currency and its associated exchange rates 
became active. If you have not yet created an exchange rate set, there will be one default 
listed in the log, created by the Site Administrator. 

 Base Currency: This is the base currency used by the company. 

 Created By: This field identifies the user who created or modified the exchange rate set. 

 Status: The status indicates which set is active. Only one exchange rate set can be 
active at a time. View currencies and exchange rates (exchange rate set). 

To view an exchange rate set 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates 
log opens. 

3) Select a set from the list and click Open (or double-click the selection). The Edit Currency 
window opens, displaying the list of available currencies and their exchange rates. 

Add a currency to the exchange rates 

To add additional currencies, you must create a new exchange rate set. Existing exchange rate 
sets can be modified until the effective date is reached and that set becomes active. Old sets 
are inactivated and saved for archival purposes. You can add as many sets as you like, as long 
as each set uses a unique effective date. 

To add a currency to the exchange rate set 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates 
log opens. 

3) Click New. The Edit Currency window opens. The Co. Currency tab of the window displays 
all currencies that were added in previous exchange rates sets. 

 The Base Currency field is fixed. 

 In the Effective Date field, you can select a future effective date, or a past effective date, 
for any exchange rate in the exchange rate set. 

4) Click Add. The Edit Exchange Rate window opens. 

 In the Currency Name field select a currency from the currency list. 
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 In the Rate field, enter the exchange rate multiplier to convert the new rate to the 
company base rate. For example, if the base currency is United States Dollar (USD), and 
you are adding Euro (EUR), then the exchange rate is the number of EUR in $1 USD; 
that could look like 0.76 = $1, so in this case you would enter .76. 

5) Click the date icon in the Effective Date field, and select the date this exchange rate set 
becomes effective. 

 If you do not select an effective date, the system uses 12:00 am local time (tomorrow 
morning) as the effective date. 

 If the effective date is in the future, the current exchange rate set remains active until the 
effective date of the new exchange rate set. 

 The future exchange rate set remains editable until the effective date is reached. 

 Before you save the exchange rate set, you can remove a currency that you just added. 
After the exchange rate set is saved, you cannot remove that currency and the system 
will carry forward that currency in any new currency exchange rate sets. 

 You can create new exchange rates records for effective dates in the past. 

 These past dated exchange rates can only be used to define Derived Curves within Cash 
Flow, in Schedule Manager and for EVA calculations. 

 Existing cost transactions in the system will not get updated on creation of new Exchange 
rate records with historical effective dates. 

6) Click OK to save the exchange rate set. 

To modify an exchange rate 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates 
log opens. 

3) Click New. The Edit Currency window opens. 

4) Select a currency from the list and click Modify. The Edit Exchange Rate window opens. 

5) Enter the new rate and click OK. 

6) Enter the Effective Date. The effective date defaults to 12:00 am local time tomorrow 
morning. 

 If you want the rate to take effect immediately, you can enter today's date. 

 You can enter a future effective date, and the current exchange rate set remains active 
until the effective date. 

7) Click OK to save and exit the Edit Currency window.



Modules Setup Administration Guide

354

Note: You can edit the Exchange Rates defined in existing Exchange 
rate records (open an existing record to open the Edit Currency
window). 

To copy an exchange rate set 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates 
log opens. 

3) Select an exchange rate set. 

4) Click the Copy button. The Edit Currency window opens. 

From here you can: 

 Add additional currencies. 

 Modify exchange rates. 

 Set an effective date for the exchange rate set. 

5) Click OK to save and exit the Edit Currency window. 

Importing and Exporting Exchange Rates 

You can create and update exchange rates through a CSV file. For example, you can import the 
exchange rates you are using in your enterprise resource planning (ERP) system into the 
system so that the rates match in both systems. 

You can import exchange rates with a CSV file by doing the following: 

 Export a copy of the CSV file structure. 

 Populate the CSV file with currency rate information. 

 Import the CSV file into the system. 

To export a copy of the CSV file structure 

1) Go to the Company Workspace tab and switch to Admin mode.

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates
log opens 

3) Choose File > Export.  

Depending on your browser, the CSV file will be automatically downloaded or you will be 
prompted to download the file manually. 

To populate the CSV file with exchange rate information 

1) Open Microsoft® Excel (or another program compatible with the CSV format), and open the 
exported CSV file. 

2) Enter currency exchange rate information in the spreadsheet. The fields are discussed in the 
table below. 
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Notes: 

 Do not delete or change the order of the columns. 

 Successful import creates a currency exchange rate set with 
the Active status. 

 Only the currency code is validated, but the system will add 
to the exchange rate set the values you specify in the CSV 
upload file. 

 Only the absolute value for the exchange rate is considered. 
If you enter a negative value, the negative sign is dropped 
and only the value is considered. 

 You can enter new rates, or update existing rates. 

 Only the first five decimal values of the exchange rate are 
imported; if less than five decimal values are entered, zeros 
are added during the import to add up to five values. 

 If you remove an exchange rate from the CSV file, the rate is 
retained in the system, and is not deleted. 

 If there are errors in the CSV file, the system will not import 
the CSV file. 

3) Save in CSV format. 

In this column: Do this: 

Currency Name 

Enter the name of the currency. For 
example, United States Dollar. This 
currency name is not validated and is for 
reference only. 

Currency Code 
Enter a valid currency code. Only the 
Currency Code is required and validated. 

1.0 Base Currency = 

Enter the exchange rate for the currency. 
The number you enter rounds at ten 
decimal places. Enter numbers and 
decimal points only; do not enter special 
characters. 

To import the CSV file 

1) Go to the Company Workspace tab and switch to Admin mode.

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates
log opens 

3) Choose File > Import to import the completed CSV file. 

4) Click Browse and navigate to where you saved the file. 

5) Click OK to import. 



Modules Setup Administration Guide

356

Only files with exchange rate information in the correct format will be imported. If the upload 
fails, the CSV file will contain an error message that explains why the upload failed. The user 
who imported the CSV file is listed in the Audit log as the User. 

To fix import errors 

1) Re-open the CSV file. 

2) Delete rows that were successfully imported. 

3) Fix the rows that were not imported correctly. 

4) Re-import the file. 

To export exchange rates to your desktop 

1) Go to the Company Workspace tab and switch to Admin mode.

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates
log open. 

3) Choose File > Export. 

Depending on your browser, the CSV file will be automatically downloaded or you will be 
prompted to download the file manually. 

Setting up Cost Sheets 

The following is provided as a reference for creating, setting up and managing the Cost Sheet 
portion of the Cost Manager. 

How to Set Up the Cost Manager (Cost Sheets) 

Before you begin: Ensure that currencies and exchange rates have been set up. Verify that all 
Cost Codes have been added or imported. Before you can create the Cost Template, you must 
create the necessary Cost Codes Data Definition(s) which will be used to build your CBS Codes. 
CBS Cost Codes can be single or multi segment codes. See Importing and Exporting 
Exchange Rates (on page 354), Add a Basic Data Definition (on page 202). 

Step 1: Design and deploy the cost attribute form. After it is deployed, the cost attribute form 
becomes the CBS Detail window, used to create and manage CBS codes in the project or shell 
cost sheet. This is an optional step. If you do not create a cost attribute, a default form will be 
used to create CBS codes. (See Importing the Cost Attribute Form (on page 357).)  

Step 2: Configure permissions. (Refer to the Unifier Data Reference Guide for cost manager 
permission settings.) 

Step 3: Create a cost sheet template. You must create at least one cost template before you 
can create cost sheets. You can use the template to create project or shell cost sheets, or a cost 
sheet within a project or shell template. You can add columns to the template, which can be 
used to capture transaction data from cost business processes, create formulas, manage the 
budget, manually enter data, link to the funding manager, and much more. You can create the 
CBS codes in the template, which are the rows on the sheet. You can also set up columns and 
rows on individual cost sheets, following the same procedures. 
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Step 4: Create a project or shell cost sheet. You can create a cost sheet directly in the project 
or shell, or in a project or shell template (when you create project or shells from the template, 
you can include the cost sheet). (See Creating a Project or Shell Cost Sheet (on page 380).) 

Step 5: Define the project or shell budget. After creating the project or shell cost sheet, you 
can distribute the budget. This is done in User mode. 

Optional steps:

 Create work packages. This is done in user mode. 

 Create worksheets. Worksheets can be used as mini-cost sheets, linked to project or 
shell cost sheet columns. You create a worksheet template first. (See Creating 
Worksheet Templates (on page 374).) 

 Create company cost sheets. This is optional. The company cost sheets are used to 
summarize project data. You can configure these sheets to display specific data by 
adding or removing desired columns. The rows correspond to each individual project cost 
sheet. The company-level cost sheet summarizes project data across the company. The 
company cost sheet can also be mapped to company level account codes, which can 
allow you to link project CBS codes with company level account codes. (See Setting up 
the Company Cost Sheet (on page 382).) 

 Design and deploy cost business processes. Use these to enable transactions 
against the cost sheet. 

 Set up a company accounts sheet. (See Setting up a Company Accounts Sheet (on 
page 385)) 

 Set up SOV. (See Setting Up Schedule of Values (SOV) (on page 419)) 

 Set up Funding. (See Setting up the Funding Manager (on page 390)) 

 Set up Rules. (See Setting up the Rules Engine (on page 435)) 

Importing the Cost Attribute Form 

A cost attribute form (created in uDesigner) is used as the CBS Detail window. The CBS Details 
window is used to create rows (CBS Codes) to project or shell cost sheets. 

You can have only one Cost Attribute form per company, which will be used for CBS Details 
window across all projects or shells. 

To import and deploy a cost attribute form into Unifier Production environment, see Importing 
Configuration Packages (on page 619). 

Configuring Cost Manager Permissions 

Refer to the Unifier Data Reference Guide for cost manager permission settings. 
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Cost Sheet Template at Company Level 

To access cost sheet templates at the Company level: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

You can use this log (Create) to create a Cost Sheet or Worksheet. 

Create a Cost Sheet Template at Company Level 

The following procedure describes how to create a cost sheet template at the Company level, 
from the Company Workspace tab. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Click Create and select Cost Sheet. to open the Create Cost Sheet Template window. 

4) Enter the needed information in the fields under the following blocks: 

 General block 

Defines general properties of the template: 

 Enter a unique Name, which is used to identify the template in the log and when 
creating a project or shell cost sheet from the template. When you create a cost 
sheet from the template, the title will default to Project Cost Sheet and will not be 
editable. 

 Enter the CBS Code title that your company uses. For example, Account Code, 
Cost Code, or CBS Code. 

 Enter the CBS label that your company uses. For example, CBS Item, Cost Item, 
or Account Description. 

You can select a Default View for the template. This can be edited in the Project Cost 
Sheet. For details, see Define Cost Sheet Default View (General tab). 

 Structure block 

Defines the structure of the CBS Codes (or Cost Codes) for use within the cost sheet. 
This remains editable in cost templates, but after it is set in a project or shell cost sheet, it 
cannot be changed as this tab defines the CBS Code structure for the project or shell. 

 Options block 

Defines labels for the two default columns, and details on forecast handling. For details, 
see Define Cost Sheet Options at Shell Level (on page 368). 

5) Click Save. 

The cost template that you create appears in the Cost Templates log. After creating the cost 
sheet template, you must open the sheet to add columns and rows. 

To open the cost sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Select a template and open it either by double-clicking it, or by way of the gear menu (  ). 
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Define Cost Sheet Default View (General Block) at Company Level 

The cost sheet default view refers to how the cost sheet appears when it is first opened. 

To define the general properties of the template: 

Enter values in the following fields: 

 Name

Enter a unique name. This field is used to identify the template in the log and when creating 
a project or shell cost sheet from the template. When you create a cost sheet from the 
template, the title will default to Project Cost Sheet and will not be editable. 

 CBS Code Label (no more than 32 characters) 

Enter the CBS Code title that your company uses. For example, Account Code, Cost Code, 
or CBS Code. 

 CBS Item Label (no more than 32 characters) 

Enter the CBS label that your company uses. For example, CBS Item, Cost Item, or 
Account Description. 

The labels determine how the CBS code columns will be labeled, according to your company 
conventions. 

Note: If you will be importing cost sheet data, it is important that the 
column labels match those in the import files. 

To define the cost column labels 

1) In the cost template Properties tab, go to the General Block. 

2) Enter new labels for the CBS Code Label and/or CBS Item Label columns. 

3) Click Save to save changes. 

Note: You can also define the forecast (Forecast block) behavior for the 
sheet as well as enabling P6 as a source (P6 Integration block) in the 
Options block. You must select Tree as the structure of the new cost 
sheet template when it is enabled for P6 integration. 

Define Cost Code Structure (Structure Block) at Company Level 

You can define the structure of the cost codes used in the sheet, in the Structure block. The 
cost codes that are built from this structure are used throughout the project or shell, for example, 
in cost type business processes for cost transactions. 

For an existing template, you can edit the cost template properties, rows, and columns, in the 
Structure block. You can also add default data to direct entry cells which can be copied to cost 
sheets created from the template. The following procedure describes how to edit a cost sheet 
template from the Company Workspace tab. 

This structure remains editable in cost templates, which lets you make adjustments to the 
structure as needed. In project or shell cost sheets, after the structure has been defined, it 
cannot be edited. 
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The Structure block has the following elements: 

 Structure

This defines the structure of the CBS Code rows and how they will appear on the cost 
template and sheets. Choose Flat (no indenting of rows) or Tree (allows indented, nested 
rows, and summary). 

 Flat

If you choose Flat, the cost sheet will display the CBS codes (rows) in a flat structure, 
with no indented rows. This is useful if you want to display all CBS codes at once. 

 Tree

If you choose Tree, you have the option of creating indented, nested rows, which can be 
collapsed into summary, or grouping, rows. This is useful if you will be creating a large 
number of rows that can be grouped into categories. 

 Sort CBS

If you select the Sort CBS check box, the rows will be sorted in ascending order by CBS 
Code automatically when new cost codes are added (flat structure only). 

The summary rows act only as grouping rows for their indented child, or leaf, rows. Data 
cannot be entered directly into a summary row. 

 Segment Preview

 Segment 1

 ...

 Segment 10

Determine how many segments to use for cost codes. For example, your company may have 
a three-segment CBS code based on numerical values. You may have as little as one 
segment (each cost code is a single entity), or as many as 10. For Segment 1, click the 
drop-down (pull-down) menu and choose the first segment. 

The available segments correspond to the list of Cost Code Data Definitions found in Admin 
mode in Company Workspace > Data Structure Setup > Data Definitions > Cost Codes. 

This is where you build the CBS codes (or "account" codes) that will be used for the cost 
sheet rows. CBS codes may consist of one or multiple (up to 10) segments. Each segment 
consists of a separate cost code data definition, as defined in Admin mode > Your Company 
> Data Definitions > Cost Codes. You must define at least one segment. 

Select one or more segments, up to 10, in the order (left to right) you want them to appear in 
the Cost Sheet rows. 

Repeat the previous step for each additional segment you want to add. 

Define Cost Sheet Options (Options Block) at Company Level 

Under the Options block, you can set the following options for the cost sheet template: 

 Forecast Details

 User Line Items

 Transactions

 Forecast Inclusion

 Manual
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 Auto

 Enable Cost Sheet Forecasting

 Enable p6 sources

For the Forecast Details and Forecast Inclusion options, specify the configuration for managing 
the Forecast column of the Cost Sheet. User Line Items/Manual is the default configuration; the 
following are the configuration options: 

 User Line Items and Manual: At any time, the cost sheet user can add, edit, or delete Line 
Items in the Cell Detail Window of the Project or Shell Cost Sheet for the Yet to 
Buy/Allowance For Change (YTB/AFC) column. The user has to manually choose which 
commits are included in the forecast. Options for choices are: 

 Auto-adjust YTB/AFC: For example, if you include a Commit for $100 in Forecast, then 
$100 is automatically deducted from YTB 

 Manually adjust YTB/AFC 

 Make no change to YTB/AFC 

 User Line Items and Auto: Do not use this combination. This scenario will automatically 
inflate the Forecast due to the manual adjustment of Yet To Buy (YTB). 

 Transactions and Auto: Note the following: 

 Commits (for example, Base Contract, Change Order, Purchase Requisition) are 
automatically updated with changes to the Forecast, depending on the formula. 

 Adjustments are automatically included in the Forecast column upon approval as defined 
by the workflow. 

 Transactions and Manual: Line Items can be added to the Cell Detail window of the Project 
or Shell Cost Sheet. No deletions or modifications can occur on existing line items. The user 
has to manually choose which commits are included in the forecast. Options for choices are: 

 Auto-adjust YTB/AFC: For example, if you include a Commit for $100 in Forecast then 
$100 is automatically deducted from YTB 

 Manually adjust YTB/AFC 

 Make no change to YTB/AFC 

To define the cost forecast details and inclusion 

1) In the cost Properties windows, click the Options tab. 

2) Complete the forecast details fields as described above. 

3) Click Save when finished. 

For the P6 Integration, the Enable P6 sources allows you to enable the Cost Sheet Template 
in Unifier to acquire data from the P6 Summary Sheets.  

 If you select this option, you must select Tree for the Cost Sheet Structure. 

 The Data Format in Cost Sheet Template Column "Properties" window shows has the 
"Decimal" option. 
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Cost Sheet Columns at Company Level 

Cost columns specify the data sources (business process transactions, formulas, values entered 
manually, and so on) that will be displayed on the cost sheet. Default columns are the CBS 
Code and CBS Item. Cost columns can be added to cost templates, to project- or shell-level 
and company-level cost sheets, and to worksheets.  

These procedures apply to adding columns to a Cost Sheet, a Cost Sheet template, or a 
Worksheet template at the following levels: 

 Project or Shell 

 Company 

Cost Sheet columns can be of the following types: 

 From Business Process

Data is rolled up automatically from cost type business processes when the BP reaches the 
specified status (Business process transaction column). 

 Direct Entry

Users can enter data directly to the sheet through line item or direct entries. Custom data 
sources can be applied to these columns to allow project or shell cost data to roll up to 
company cost sheets, and be reportable through user-defined reports (Manual entry column). 

 Line Item Content

 From Worksheet

 From Activity Sheet

 Formula

The column values are calculated based on a formula that normally includes values from 
other columns. For example, if there are multiple cost type business processes affecting the 
sheet, you may want to have a column that shows the sum of all of them ("Total Commits"). 
Custom data sources can be applied to these columns to enable them to roll up to company 
cost sheets, and be reportable (Formula column). 

 Fund

Provides additional functionality to work with the Funding sheet. For more information, see 
Add a Funding Column to Project or Shell Cost Sheet (on page 402) (Fund column). 

 SOV

Provides additional functionality to work with Schedule of Value sheets. 

In a Cost Sheet: 

 If you set the format for the Total field as "Blank" in the column properties, then the user will 
see a blank value for the Summary of All Rows (under the parent CBS Codes), and 

 If the user exports the Summary Sheet by way of a CSV file, then the exported CSV file will 
also include a blank value for the Summary of All Rows. 
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Add a Cost Sheet Column at Company Level 

This general procedure can be used for adding columns is the same whether you are adding 
columns to a cost sheet (project/shell or company level), a cost sheet template, or a worksheet. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Select a cost template from the log. 

4) Click the gear menu (  ) next to the cost template and click open. 

5) Form the toolbar options, click Add Column (the icon with three vertical lines) to open the 
New Column window. 

6) Complete the fields as described below. 

7) Click: 

a. Cancel to discard your changes 

b. Save to save your changes 

c. Save & Add New to save your changes and begin to add a new column. 

In this field: Do this: 

Name

The name you choose will appear as the 
column header on the Project or Shell Cost 
Sheet. If you leave the Name field blank, 
the selection you make in the Datasource 
field will automatically populate the Name 
field. 

Type

Cost Sheet columns can be of the 
following types:  

 From Business Process

Data is rolled up automatically from 
cost type business processes when the 
BP reaches the specified status 
(Business process transaction column).

 Direct Entry

Users can enter data directly to the 
sheet through line item or direct 
entries. Custom data sources can be 
applied to these columns to allow 
project or shell cost data to roll up to 
company cost sheets, and be 
reportable through user-defined reports 
(Manual entry column). 

 Line Item Content

 From Worksheet

 From Activity Sheet

 Formula
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The column values are calculated 
based on a formula that normally 
includes values from other columns. 
For example, if there are multiple cost 
type business processes affecting the 
sheet, you may want to have a column 
that shows the sum of all of them 
("Total Commits"). Custom data 
sources can be applied to these 
columns to enable them to roll up to 
company cost sheets, and be 
reportable (Formula column). 

Datasource

All columns must be associated with a 
data source. The data source that you 
choose will determine which of the 
following options are available. The types 
of Data sources available are: 

 Single Sources: These values roll up 
from other sources. These include cost 
type business processes, some 
predefined cost columns. 

 Logical Sources: Choose one to 
create Manual Entry or Formula 
columns. 

 P6 Sources: To select the P6 
Summary Sheet from which cost 
should role up. 

See Project or shell Cost Sheet Column 
Data Sources (on page 369).  

Data Format

 Currency: Right-aligns column 
contents and includes a currency 
symbol, formatting the value to the 
specified currency for the sheet. 

 Percentage: Right-aligns the contents 
and includes a percentage symbol 

 Decimal: Right-aligns column contents 
and presents the value for the column 
as a Decimal (with two decimal digits). 
The prefix of currency symbol, or the 
suffix of percent symbol, does not 
appear in columns with a Decimal data 
format. 

Display Mode
Refers to whether the column is displayed 
on the cost sheet. 

 Show: This is the default choice. This 
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indicates that column will display by 
default on the cost sheet to all users 
with at least "view" permission for the 
cost sheet. 

 Hide: Hidden columns are active but 
not displayed on the cost sheet. 
Hidden columns can be accessed by 
users with "create" permission on the 
cost sheet. 

Total

Determines what will display in the "Total" 
(bottom) row for the column: 

 Blank: The total of this column is not 
applicable and will not display on the 
cost sheet. Choose this column for 
percentage columns and other 
columns where it does not make sense 
to display the sum total. 

 Sum of All Rows: The sum total of the 
column values is displayed. 

 Use Formula Definition: For formula 
columns; the formula will be applied to 
the "Total" row in the same way it is 
applied to other rows in the column. 

Column Position After
The new column will be inserted after the 
column selected. 

Create a Formula in a Cost Sheet Column 

This procedure addresses how to create a formula column for use on a cost sheet. (The general 
procedure also applies to cost sheet templates and work sheets.) 

When creating a cost sheet column, selecting a logical data source lets you build a formula in 
which you can include: 

 Other columns from this cost sheet 

 Single data sources, such as business processes in a certain status 

 Total elements, such as the tallied value of a column 

 Data elements from single-record, non-workflow business processes 

If you are creating a formula for forecasts (unaccepted), data sources are limited to business 
processes flagged in uDesigner for cost sheet forecasting. For example, if base commits and 
change commits were enabled for cost sheet forecasting, you will see base commits 
(unaccepted) and change commits (unaccepted) as available data sources for use in the 
forecasts (unaccepted) formula. You will not see other data sources that were not flagged in 
uDesigner for this purpose.  
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When you build your formula, think about which data sources will generate the result you want in 
your cost sheet column. For example, if you want to see total commitments, you can add 
contracts (approved) and change orders (approved). 

Note: Use care when selecting the Cost Column that you use to build 
your formula. You can possibly choose from Columns (columns in the 
sheet), Data Sources (values of business processes), Total Elements 
(totals from columns), or Data Elements (data elements on 
Information/General record(s), typically named Project Information). The 
source column that you use can affect the data values in your cost 
sheet. If you select an incorrect source, you can get a result you do not 
expect. Be sure that you know the source to use before you build your 
formula. 

To create a formula 

1) In the New Column window, choose Formula as the type, select a Datasource, then click the
Select button in the Formula field. 

2) Enter the first value in the formula: 

 To enter numerical values into the formula, click the number keys on the on-screen 
keypad. (Include parentheses, % or decimal point as necessary.) 

 To add a data element or column value (existing columns on the sheet you are working 
on) into the formula, double-click an item from the left pane. 

As you build the formula, it appears in the Formula box in the upper portion of the window. 

3) Click the appropriate operator: add, subtract, multiply, or divide. 

4) Continue to alternate between choosing values and operators to add to the formula. 

Note: The system applies the operators in the order of proper 
mathematical procedure: from left to right, with multiplication and division 
first, followed by addition and subtraction. 

5) You may click Undo at any time to undo the last action. Click the Clear All button to clear 
the entire formula. 

6) When the formula is complete, click Save to save your formula and return to the Column 
Properties window. 

Example Formula 

A user wants to create a "Yet To Buy" column that calculates 7% of the Assigned Budget 
column. To create this formula using the keypad in the Formula Creation window: 

1) Click 7 then click the percent % key. The value is displayed as 7/100 

2) Click the multiplier X 

3) Select Assigned Budget from the Cost Column pane on the left, then click Select 

The final formula looks like this: 7/100 * Assigned Budget
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Cost Sheet Template at Shell Level 

Project or shell cost sheets are created by copying from a cost sheet template or from an 
existing project or shell cost sheet in another project or shell; therefore, when you first set up the 
cost manager, you must start with at least one cost template that you can use to create a project 
or shell cost sheet (or cost sheet in a project or shell template). 

To access cost sheet templates at the shell level: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects > [Shell template]. 

3) Expand the Cost Manager node and click Cost Sheet to open the Cost Sheet log. 

You can only use this log (Create) to create Worksheet with the following options: 

 From Template

 From Projects

You cannot create a project cost sheet. 

Get Data

If the activity data is integrated by way of old Get Data synchronization (by adding P6 project ID 
in shell details, General tab), then the activity data will not roll up from the Activity Sheet to the 
Cost Sheet columns. 

If the activity data is integrated by way of old (or new) Get Data synchronization (by adding P6 
project ID in shell details, Integration tab), then the activity data will roll up from the Activity 
Sheet to the Cost Sheet columns. 

Create a Cost Sheet Template at Shell Level 

You cannot create a project cost sheet template at shell level; however, a Cost Sheet is created 
by copying from a cost template or another project or shell cost sheet. See Creating a Project 
or Shell Cost Sheet (on page 380) for details. 

View Cost Sheet Properties at Shell Level 

To view the cost sheet properties for Shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) Expand the Cost Manager node and click Cost Sheet to open the Cost Sheet log. 

4) Open a template. 

5) Click Menu Options and select Properties.  
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Define Cost Sheet Options at Shell Level 

In the cost sheet template at the shell level Properties window, you can only define the P6 
Integration option by enabling P6 as source (Enable P6 sources). This option allows you to 
enable the Cost Sheet Template in Unifier to acquire data from the P6 Summary Sheets. You 
can select this option only if Tree is selected as the Cost Sheet Structure, at the Company 
level (cost sheet template).  

The Properties window at shell level has the following fields and the options that are selected 
are based on the selection at the Company level (cost sheet template): 

 Name

 Structure

 Segments

 CBS Code Label

 CBS Item Label

 Forecast Details

 Forecast Inclusion

 Enable Cost Sheet Forecasting

 Enable P6 sources

Cost Sheet Columns at Shell Level 

Cost columns specify the data sources (business process transactions, formulas, values entered 
manually, and so on) that will be displayed on the cost sheet. Default columns are the CBS 
Code and CBS Item. Cost columns can be added to cost templates, to project- or shell-level, 
and company-level cost sheets, and to worksheets. 

These procedures apply to adding columns to a Cost Sheet, a Cost Sheet template, or a 
Worksheet template at the following levels: 

 Project or Shell 

 Company 

Cost Sheet columns can be of the following types: 

 From Business Process

Data is rolled up automatically from cost type business processes when the BP reaches the 
specified status (Business process transaction column). 

 Direct Entry

Users can enter data directly to the sheet through line item or direct entries. Custom data 
sources can be applied to these columns to allow project or shell cost data to roll up to 
company cost sheets, and be reportable through user-defined reports (Manual entry column). 

 Line Item Content

 From Worksheet

 From Activity Sheet

 Formula
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The column values are calculated based on a formula that normally includes values from 
other columns. For example, if there are multiple cost type business processes affecting the 
sheet, you may want to have a column that shows the sum of all of them ("Total Commits"). 
Custom data sources can be applied to these columns to enable them to roll up to company 
cost sheets, and be reportable (Formula column) 

 Fund

Provides additional functionality to work with the Funding sheet. For more information, see 
Add a Funding Column to Project or Shell Cost Sheet (on page 402) (Fund column). 

 SOV

Provides additional functionality to work with Schedule of Value sheets. 

In a Cost Sheet: 

 If you set the format for the Total field as "Blank" in the column properties, then the user will 
see a blank value for the Summary of All Rows (under the parent CBS Codes), and 

 If the user exports the Summary Sheet by way of a CSV file, then the exported CSV file will 
also include a blank value for the Summary of All Rows. 

Project or Shell Cost Sheet Column Data Sources 

Data Source Description 

Single Sources 

Columns in which data is manually rolled 
up from business processes after the 
appropriate terminal status is reached. 
Can also include other specified sources. 

Cost-type Business Processes 

Included in the Single Sources list are all 
of Cost BPs that are available for your 
project or shell, and all of their terminal 
statuses. 

AFC 

Assigned Budget 

This column is closely related to budget 
distribution. It allows the user to create 
specific, detailed line-items for each CBS 
code in the budget. Each line item can be 
assigned individually. 

Funded Records 

This column shows records in which the 
CBS code is funded, that is, spend-type 
business process records that consume 
funds. 

Unfunded Records 
This corresponds to spend-type BP 
records that are not funded. 
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Prior Forecasts Prior forecasts 

Yet To Buy 

Part of the commitment that still must be 
purchased. For example, a base contract 
is for 1000 items, and 500 have been 
bought. There are 500 items "yet to buy." It 
is based on a currency amount. In Cost 
Sheet Properties, setting "Auto" 
"Transaction" options will track the yet to 
buy information. 

Logical Sources 
These values are based on formulas or 
user-defined entries. 

Budget Remaining Balance 
This is a place holder for a formula you 
create (optional). 

Budget Variance 
This is a place holder for a formula you 
create (optional). 

Commits 
This is a place holder for a formula you 
create (include all commit columns; 
optional). 

Forecasts 
This is a place holder for a formula you 
create (optional). 

Forecasts (Unaccepted) 
This is a place holder for a formula you 
create (optional). 

Forecasts Variance 
This is a place holder for a formula you 
create (optional). 

CBS Funding 
Requires additional setting in Funding 
Sheet; see Setting up the Funding 
Manager (on page 390). 

Manual Funding by CBS 
Requires additional setting in Funding 
Sheet; see Setting up the Funding 
Manager (on page 390). 

Revised Budget 
This is a place holder for a formula you 
create (optional) 

Spends 
This is a place holder for a formula you 
create (include all spend columns; 
optional). 

Project or shell Cost 1-25 

These can be used to roll up manual and 
formula columns to company cost sheets. 
Each data source can be used for one 
column. 



Setting up the Cost Manager

371

Adding Cost Rows (CBS Codes) 

The following procedures are applicable to Cost Templates and Cost Sheets 

Each cost sheet row corresponds to the unique CBS (or Cost) codes that link costs on a project 
or shell to the General Ledger for Finance. They may be added manually or imported from a 
CSV file. 

CBS codes may consist of one or a maximum of 10 segments. Each segment is defined by a 
different data definition. For example, a five segment CBS Code would require five data 
definitions. Segments can be defined via a selection list or text entry. 

If the cost sheet has been set up to automatically sort CBS codes, then all new rows will be 
sorted by ascending order. 

You cannot create duplicate CBS Codes at the same row level on the sheet. If you choose a Flat 
structure for your cost sheet (no indented rows), then you will not be allowed to create duplicate 
CBS Codes. If you choose a Tree structure, you can use the same CBS Code as long as each 
instance is within a different grouping (or parent) row. 

To manually add rows to a cost sheet or cost template 

1) Open the Cost Template or Cost Sheet. 

2) Click the Manage Rows button. The Manage Rows window opens. 

3) Click Add. The CBS Detail window opens. 

4) Click to edit all required fields in the row. 

5) Click Save when finished. 

To rearrange rows 

1) Open the Manage Rows window. 

2) Click and drag a row to move it to another position.  

About the CBS Detail Window 

Following is an overview of the fields and tabs in the CBS Detail window. 

The CBS Detail window displays CBS properties. You can add notes or file attachments to the 
CBS code in this window. You can also specify CBS Breakdowns in this window, which are used 
in Schedule of Values (SOV) sheets. 

The values that are available in the CBS code selection come from the Cost Codes data 
definitions. 

Navigate to Company Workspace tab > Admin mode > Data Structure Setup > Data 
Definitions > Cost Codes. The log will show whether the code is a Text Box or Pulldown Menu. 

The codes listed in the log are those that are available to use when building the CBS Code 
segments. 

This section discusses the default CBS Detail window. If your company has designed a 
uDesigner-created Cost Attribute Form, the fields may differ. Fields with a red asterisk are 
mandatory.  
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In this field: Do this: 

CBS Code 
Click Select to choose the cost code 
segments for the CBS code.  The Cost 
Code Selection window opens. 

CBS Item 

Enter a label that will display on the cost 
sheet next to the CBS Code, this can help 
other users to identify what the code 
represents. 

Description 
Enter an optional description to describe 
the row. 

Additional information about the CBS Detail window: 

 The appearance of the Cost Code Selection window will depend on how your cost sheet was 
set up, which CBS Codes (cost codes) were used in the definition, and how each code was 
set up. 

 If the CBS code segment has a Select button, then click the button and choose the segment 
values from the list. 

 If the CBS code segment does not have a Select button, then type the value of the segment 
into the field. 

Create a Summary Row (Classic view) 

If you select a Tree Structure format, you can indent rows. These indented rows can be used to 
capture cost transactions. The parent node acts as a summary row, summarizing the information 
present for each of the indented "child" rows. You cannot enter information directly into a 
summary row. 

To create a summary row by indenting 

1) In the Rows window, select the check box of the row(s) to indent under the summary row. 

2) Click the Indent button. The row immediately above will become a summary row. All 
monetary values in the detail lines below a summary row will be rolled up to the summary 
row automatically. 

To outdent a row 

1) In the Rows window, select an indented row by clicking its check box. 

2) Click the Outdent button. The row will no longer be part of the summary row. 

Import Cost Rows (CBS Codes) 

You can create CBS Codes in a cost sheet by importing them from a CSV file. This procedure 
can also be used to copy the CBS codes from one cost sheet or template to another (the 
structure and code segments must be the same). 

Step 1: Export the file template
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Open the cost sheet or template, open the Menu Options, select Export, and select CBS 
Details. 

Depending on your browser, the CSV file will be automatically downloaded, or you will be 
prompted to download the file manually. 

Step 2: Add the CBS code rows to the CSV file

a) Navigate to and open the CSV file (in Microsoft Excel or another compatible program). 

If the Cost Template already contains rows, they will be listed. If summary rows exist, the 
CBS column will display them with two tilde symbols (~~) separating the parent row from the 
child row. 

For example: 2000000 ~~210000, where 2000000 is the parent and 210000 is the child. 

b) Enter information in the required fields and save the file. 

Note: Do not change or delete any of the listed CBS Codes that exist in 
the system or you will get an error. Changes to the CBS Code must be 
done within the system. 

Required fields: 

 CBS Code: must be a match to a CBS Code in the Cost Sheet 

 CBS Item: must be a match to the CBS Item for the associated CBS Code in the 
Cost Sheet 

 Cost Type: Capital or Expense 

 Status: Active or Inactive 

Step 3: Import the rows

a) In the cost sheet or template, open the Menu Options, select Import, and select CBS 
Details. 

b) In the Upload window, browse to and add the CSV file. 

c) Click Open. After the import, your Cost Sheet will show the new rows. 

To copy CBS codes from one cost sheet or template to another 

1) In the source cost sheet or template, click Export > CBS Details. Save the CSV files. You 
can go in to the file and add additional codes if needed. 

2) In the destination cost sheet or template, click Import > CBS Details. Browse to the CSV file 
and import. 

Note: The structure of the two sheets must be the same: Both must be 
tree or flat structure. Verify the structures by opening the Properties 
window and clicking the Structure tab. Be sure you are using the same 
CBS code segments. 
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Creating Worksheet Templates 

Worksheets are extensions of the cost sheet. They can be used as "sub-cost sheets," enabling 
specific calculations or data entry in a separate sheet, which can then be rolled up into a defined 
project or shell cost sheet column. For example, a worksheet can be used to off-load complex 
calculations, which can be rolled up into a single cost sheet column. The rows equal the CBS 
codes on the cost sheet. Worksheets can have multiple columns for data entry or formula 
calculations, but do not support data rolled up from business processes. 

A cost sheet column can be associated with a worksheet as the data entry method. A worksheet 
column can also be associated with another worksheet, as long as there is not a circular 
reference. There can be multiple worksheets in a project or shell. 

Note: A circular reference is referred to a reference in which the last field 
references the first field and creates a closed loop. 

A worksheet template can be created in Admin mode. Permissions can be controlled for 
individual worksheets. Worksheets are not independently reportable; however, cost sheet 
columns that reference worksheets can be reported on. 

Create a Worksheet Template 

You can use this template to create worksheets for individual project or shell cost sheets, or for 
cost sheets in project or shell templates. 

Worksheets are created similarly to cost sheets. The user who creates a worksheet will be the 
owner of the Worksheet. The owner can grant permissions to other users and groups in User 
mode. 

To create a worksheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Cost Sheets. The Cost Templates log opens. 

3) Click the Create button and choose Worksheet. The Worksheet Properties window opens. 

4) Complete the Worksheet Properties window: 

 Name: Enter a unique title to identify the worksheet or template. This is a required field. 

 Description: Enter an optional description. This is especially useful if you plan to create 
multiple templates for use in different project or shells, or multiple worksheets for a 
project or shell. 

5) Click Save to save and exit the window. The worksheet template is listed in the log. 

You can open the worksheet template and configure it by adding columns; the rows will be 
the CBS codes within the corresponding cost sheet. 

Open the Worksheet Template 

After creating the worksheet template, you must open the sheet to add columns. 

To open the worksheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 
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2) In the left Navigator, click Templates > Cost Sheets. 

3) Select the worksheet template and click Open from the gear menu (  ), or double-click the 
selected sheet. The worksheet template window opens. 

Create a Worksheet Column 

Adding a column to a worksheet is similar to adding a column to the cost sheet. You can add 
manual entry (direct or line item) columns or formula columns. You can also add columns that 
reference other worksheets. This allows interaction between worksheets. 

The available datasources are Project Worksheet Cost 1 through 50. 

To add a column 

1) Open the worksheet and click the Add Column button. The New Column window opens. 

2) Complete the Column Properties as usual for a column. 

If you are creating a formula, the datasources that are available for the formula are limited to 
the other columns on the worksheet. 

3) Complete the window and click Save or Save & Add New. 

Create a Worksheet in a Shell Template 

You can create a worksheet in the project or shell template Cost Manager by copying from a 
template or copying from a project or shell. 

To create a worksheet from a template 

1) Navigate to a shell template (Company Workspace > Admin mode > Templates > Shells
> [Shell Template] > Cost Manager > Cost Sheet).

2) Click Create > Worksheet > From Template. This option will let you create a worksheet by 
copying one from a company level template. 

3) Select a worksheet template and click Save. 

To create a worksheet from another project or shell 

1) Navigate to a shell template (Company Workspace > Admin mode > Templates > Shells
> [Shell Template] > Cost Manager > Cost Sheet). 

2) Click Create > Worksheet > From Projects. The Copy from Projects or Shells window 
opens. This window will list worksheets from all project or shells. 

3) Select any Cost Sheet and click the Save button to create a Cost Sheet. 

Delete a Worksheet 

User will not be allowed to delete a Worksheet if it is referred as a Column Entry method in Cost 
Sheet. Only owner of Worksheet will be allowed to delete Worksheet along with user with Create 
permission at module level. 

To delete a worksheet 

Select the worksheet in the log and click Delete from the gear menu (  ). 
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Managing Cost Templates 

You can edit the cost template properties, rows, columns, or add default data to rows. 

Note: Your edits to a template will be reflected in cost sheets that are 
created from it, but will not affect exiting cost sheets. 

To access your cost templates 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Cost Sheets to open the Cost Templates log which 
lists the cost templates. 

The Cost Templates log has the following toolbar options: 

Create To let you create: 

 Cost Sheet

 Worksheet

View To change the view of the cost sheet to the 
following options: 

 All

 Group by Type

Delete To delete a cost template. 

Refresh To refresh the items listed on the page. 

Print To print the list of cost templates with the 
following options: 

 Print

 Export To CSV

 Export To Excel

Find on Page To search for an item on the page. 

The Cost Templates log has the following tabs on the right pane: 

Properties tab To view or edit the fields of your cost 
template. 

Audit Log tab To review the history of changes that have 
been incorporated on a selected cost 
template. 
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View or Edit Cost Template Properties 

The Properties tab of a cost template is fully editable. This lets you make changes as necessary 
to use when creating subsequent cost sheets from the template. 

Notes: 

 Many of the properties that are editable in cost templates are not 
editable in the Properties tab of the cost sheet itself, after it has been 
created in the project or shell or in a project or shell template. 

 Any edits that you make to a cost template will affect new project or 
shell cost sheets created from the template, and the existing cost 
sheets will not be affected. 

To view or edit cost template properties 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Select a cost template from the log. The Properties tab is displayed on the right pane. The 
Properties tab has the following blocks with fields that let you enter values, when permitted: 

 General

 Name 

 Description 

 CBS Code Label 

 CBS Item Label 

 Structure

 Flat 

 Tree 

 Sort CBS 

 Segment Preview 

 Options

 Forecast Details: User Line Items - Transactions 

 Forecast Inclusion: Manual - Auto 

 Enable Cost Sheet Forecasting 

 Enable P6 source 

4) In the Properties tab, you can make edits as necessary. 

Note: Any edits that you make to a cost template will affect new project 
or shell cost sheets created from the template, and the existing cost 
sheets will not be affected. 

5) When finished, click Save to save your changes. Click Cancel to discard your changes. 

Delete a Cost Template 

You can delete a cost template from the Cost Templates log. 
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Note: The cost sheets in project or shell templates or in project or shells 
cannot be deleted. Deleting a template will have no effect on cost sheets 
created from it. 

To delete a template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Select a cost template from the log. 

4) Click the gear menu (  ) next to the cost template and click Delete. 

Edit Cost Templates Log Columns 

You can edit the properties of a column, including the entry method, as long as this is applicable 
for the selected data source. 

Note: Although it is possible to change the entry method for a column, 
use caution when doing so when data exists in the column. Information 
such as detailed line item entries could be lost. For example, if you 
change the data entry method from line item entry to direct entry, the 
value will appear in the cell, but all line item details will be lost. 

To edit Cost Templates log columns 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Right-click a (any) column heading, and you can: 

a. Sort Ascending

b. Sort Descending

c. Columns (Name, Date Created, Created By, Type) 

d. Lock after this Column

4) Select a cost template from the log. 

5) Click the gear menu (  ) next to the cost template and click Open. The Cost Sheet
<name> window opens. See the table below for the Cost Sheet <name> window elements. 

You can delete a cost template from the Cost Templates log. 

Note: The cost sheets in project or shell templates or in project or shells 
cannot be deleted. Deleting a template will have no effect on cost sheets 
created from it. 

Move a Column (Project Cost Sheet) 

To move a column of a project cost sheet (Company Workspace tab > Templates > Shells > 
Projects > [project template] > Cost Manager > Cost Sheet > Project Cost Sheet): 
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From the Columns log, click and drag a column header to a different spot in the log. A blue line 
will appear where the column will be placed. 

Delete a Column (Project Cost Sheet) 

If a column is being used in a formula in another column, you must remove the column from the 
formula before you can delete it. If the column contains a cell with line item data, you must first 
remove each line item before it can be deleted. 

To delete a column 

1) Right-click a column header from the log. 

2) Click Delete and Yes to confirm. 

Hide Cost Sheet Columns (Project Cost Sheet) 

You can hide a cost sheet column. Hidden columns are not visible on the cost sheet, but 
otherwise function like other cost columns. For example, you might want to hide a column that is 
used in a formula column, but is unnecessary to display. Hidden columns can be viewed from 
the Columns Log by users with "create" permission on the cost sheet. 

To hide a cost sheet column 

1) Right-click a column header from the log. 

2) Select Hide. The column is hidden. 

To unhide a hidden cost sheet column 

1) In the cost sheet template, click the Menu Options (three horizontal bars). 

2) Select Columns > Unhide. 

3) Select the column to unhide. 

Edit a Cost Row 

You can edit rows in templates and cost sheets. However, in cost sheets, if you have already 
distributed and locked the budget, you must unlock it first before you can access the Rows 
window and edit rows. 

To edit a row 

1) From the Cost Templates log (Templates node > Cost Sheets), open the cost sheet. The 
Cost Sheet - <name> window opens. 

2) From the toolbar options row, click Manage Rows (icon with three horizontal lines) to open 
the Manage Rows window. 

3) In the Manage Rows window, you can use the Add option to add a row, select a row and 
delete it. 

For the Project Cost Sheet: 

1) From the Cost Sheet log (Templates node > Shells > ... > Cost Manager > Cost Sheet), 
open the cost sheet. The Cost Sheet - <name> window opens. 
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2) From the toolbar options row, click Manage Rows (icon with three horizontal lines) to open 
the Manage Rows window. 

3) In the Manage Rows window, you can use the Add option to add a row, select a row and 
delete it. 

View or Edit CBS Details 

The CBS Detail window displays CBS properties. Notes and files can be attached to 
transactions via the CBS Detail window. You can also specify CBS Breakdowns in the CBS 
Detail window, which are used in SOV sheets. 

Note: If you have locked the budget, you will need to unlock it first in 
order to access the Rows window or CBS Detail window. 

To view and edit CBS Details 

1) Open the Cost Sheet. 

2) From the cost sheet, click the Manage Rows button to open the Manage Rows window. 
Modify the values of the editable fields for each row as needed. 

3) Click the CBS Code to be edited, which appears as a link. The right pane opens to display 
the Breakdown and Audit Log tabs. 

4) Make changes to the Breakdown Tab as necessary. 

5) Click Save. 

Creating a Project or Shell Cost Sheet 

The Cost Sheet is created by copying from a cost template or another project or shell cost sheet. 
Only one project or shell cost sheet may be defined per project or shell. You may define multiple 
work packages or work sheets. 

If a worksheet is associated with the cost sheet or template (that is, if a cost sheet column 
definition refers to Worksheet as Data Entry method), the worksheet will also be copied. 

Note: After a cost sheet has been created, it cannot be deleted. Be sure 
the structure (tree or flat) of the template is what you want to use for the 
cost sheet. The structure is not editable for cost sheets. You can add, 
modify or delete columns and rows to the sheet as necessary. 

To create a cost sheet by copying a template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) Open the project template. 

4) Click Cost Manager grouping node to expand it, and select the Cost Sheet functional node. 

5) Click Create, click Worksheet, and select From Template. This option will allow the user to 
create a Cost Sheet by copying one from a company level template. 

6) Select a template and click Save. 
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To create a cost sheet by copying from another project or shell 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > Projects. 

3) Open the project template. 

4) Click Cost Manager grouping node to expand it, and select the Cost Sheet functional node. 

5) Click Create, click Worksheet, and select From Project. This option will allow the user to 
create a Cost Sheet by copying one from another project or shell. 

6) Select a worksheet and click Save. 

Add Cost Sheet Columns and Rows 

Rows and columns are added to project or shell cost sheet the same way as they are to cost 
sheet templates. 

Add CBS Breakdown 

Breakdowns are used in SOV sheets. Invoices can be created from SOVs that can include CBS 
breakdowns. The breakdowns are not accessible in any BP except Spends BPs, and are not 
associated with data definitions, and so are not reportable. 

The breakdown applies to a single project or shell, and can be applied across projects or shells 
by adding CBS code rows and breakdowns to Cost templates, or creating cost sheets from 
previous project or shell cost sheets with breakdowns. 

You may add as many breakdowns as you need. When you click OK, the system will perform a 
validation check. If the CBS code is already in use in a cost sheet transaction, the system will 
not allow the addition of a breakdown. 

Note: If you have locked the budget, you will need to unlock it first to 
access the Rows window. 

You can also add breakdowns directly to SOV sheet. This is done in User mode on the SOV 
sheet. 

To add a CBS Breakdown 

1) From the Cost Sheet, click the Manage Rows button. The Rows window opens. 

2) Click the CBS Code to be edited, which appears as a link. The right pane opens to display 
the Breakdown and Audit Log tabs. 

Note: The Breakdown tab becomes accessible after the row has been 
created. To see the Breakdown tab, you must first create the CBS Code 
and click Save. 

3) Click the Add Breakdown button. 

4) Add a Breakdown Name and Description and click Save. 
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Modify cost sheet default view 

The cost sheet default view refers to how the cost sheet appears when it is first opened. The 
cost sheet Properties window offers two options regarding the cost sheet default view, described 
in the procedure below. These options control how the cost sheet opens for all users. 

To modify the cost sheet default view 

1) In User mode, open the cost sheet Properties window (click the Properties button from the 
log toolbar, or open the cost sheet and click File > Properties). 

2) On the General tab, you may optionally choose either or both of the Default View check box 
options: 

 Open in maximized view: When the cost sheet is opened, it will automatically open 
maximized, or full-screen. 

 Open in split mode: When the cost sheet is opened, it will automatically open as split 
(same as clicking the Split button). 

If these options are not selected, the cost sheet will open by default to a size slightly smaller 
than the screen, and not split. 

Setting up the Company Cost Sheet 

The company cost sheet can be set up to roll up project or shell cost data across all company 
project or shells. 

Create a Company Cost Sheet 

Company cost sheet will not be auto-created. The company administrator must create one. Cost 
sheets are added by default. 

To create a company cost sheet 

1) In User mode, navigate to Company Workspace > Cost Manager > Cost Sheet. The Cost 
Sheet log opens. 

2) Click Create. After a cost sheet has been created it cannot be deleted. 

Add Company Cost Sheet Columns 

Cost sheet columns can be added to company cost sheets the way they are added to cost 
templates. Predefined data sources at project or shell (CBS) level will roll up to company level 
automatically. 

Company Cost Sheet Data Sources 

Data Source Description 

Single Sources 

Data from single datasources Project 
Cost1 to Project Cost25 is rolled up from 
project-level cost sheets. Users can also 
view datasources based on business 
process data rolled up from the 
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Data Source Description 

project-level. Following are the available 
datasources: 

Business Process (All statuses) 
Included in the Single Sources list are all 
of Cost BPs that are available for your 
project, and all of their terminal statuses. 

AFC 
Allowance for Change. This is a 
contingency value. 

Funded Records 

This column shows records in which the 
CBS code is funded, that is, spend-type 
business process records that consume 
funds. 

Unfunded Records 
This corresponds to spend-type BP 
records that are not funded. 

Prior Forecasts Prior forecasts 

Yet To Buy 

This is a portion of a commit that you still 
need to buy. This can be automated for 
uDesigner BPs (commit BPs can track 
YTB). In Cost Properties, you must set 
"Auto" "Transaction" options, which track 
YTB.  

Project Cost 1 to Project Cost 25 Roll up from all projects 

All Project Single Sources 
All other data sources are similar to Project 
Cost Sheet. 

Logical Sources These sources are formulas. 

Company Budget Remaining Balance 
This is a place holder for a formula you 
create (optional). 

Company Budget Variance 
This is a place holder for a formula you 
create (optional). 

Company Commits Can be used for company commit BPs 

Company Forecasts 
This is a place holder for a formula you 
create (optional). 

Company Forecasts (Unaccepted) 
This is a place holder for a formula you 
create (optional). 

Company Forecasts Variance 
This is a place holder for a formula you 
create (optional). 

Company Funding You can roll up all project funding here. 
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Data Source Description 

Company Spends You can roll up spends BPs here. 

Company CBS Funding 
This requires additional setting in Funding 
Sheet; see Setting up the Funding 
Manager (on page 390). 

Company Manual Funding by CBS 

Company Cost 1-25 

Map cost sheet column to an account code 

You can define mapping between a company cost sheet column and a company account code. 
This allows you to link an account code with project or shell cost data that is rolled up from a 
project or shell cost sheet into the cost sheet. 

Notes: 

 You can map a cost column to more than one account code. For 
example, Column A can be mapped to both Account Code X and 
Account Code Y. This means that the Total will display for both 
account codes in that column. However, each account code can be 
mapped only once (Account Codes X and Y cannot be mapped to 
any other columns). 

 If you remove a column from the asset sheet that is associated with 
an account code, the mapping will be lost. 

To map a cost sheet column to an account code 

1) In User mode, navigate to the company cost sheet. 

2) Open the Properties window and click the Options tab. 

3) Click Add. The Add Mapping window opens. 

4) Complete the window: 

 Column Name: Company Cost Sheet Column drop-down will show list of all columns 
that are defined on the cost sheet. 

 Account Code: Click Select. A picker window opens displaying active codes from the 
accounts sheet. Select a code and click Open. 

 Account Name: This field is populated with the name of the account code chosen in the 
previous field, as defined in the accounts sheet. 

5) Click OK to save the Add Mapping window. 

6) Click Add to add additional mapping if necessary. 

7) Click OK to save and exit the Properties window. 
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After mapping is complete, data from the company cost sheet (which reflects data rolled up from 
project or shell cost sheets) will be rolled up to the Accounts Sheet under the Projects data 
source. Only the total value will be rolled up. If the Total value in the cost sheet column changes, 
the change is reflected on the accounts sheet. 

Note: The process used to update the accounts sheet with mapped cost 
sheet data runs in the background. After mapping a cost column to the 
accounts sheet, or updating the cost sheet data, the change may not 
reflect in the accounts sheet immediately. 

To modify mapping 

In the Properties window, Options tab, select a mapping and click Modify. You can make 
changes in the Add Mapping window. 

To remove mapping 

In the Properties window, Options tab, select a mapping and click Remove. This removes the 
mapping. Data will no longer roll up to the accounts sheet. 

Deleting Cost Sheets 

This section describes how to manually delete a cost sheet from a shell. 

Note: You can delete a cost sheet from a specific shell template but not 
from other Projects/Shells that have been created using the template. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell type] > [shell Template] > Cost 
Manager > Cost Sheet. 

3) Select a sheet for deletion. 

4) Click Delete. 

5) When the prompt appears that asks you to confirm deletion, click Yes to delete the cost 
sheet. 

Setting up a Company Accounts Sheet 

The company accounts sheet is used to track company level accounts information, such as 
assets, resources, and facility maintenance. It is similar to a project or shell cost sheet, using 
account codes instead of CBS codes. 

Account codes are independent of CBS codes, but are similar in structure format. Company 
level business processes can be designed in uDesigner to roll up to the accounts sheet (line 
items are associated with account codes). 
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How to set up a company accounts sheet 

Before you begin: A Company Account code attribute form must be deployed in uDesigner. 
This is used as the detail form for creating account codes (rows) on the accounts sheet. There is 
no default form available. The design also includes creating an account code picker, which can 
be used on BP forms used with the accounts sheet, and for mapping account codes to project or 
shell cost sheet columns. 

Step 1: Deploy the company Account Code attribute form in uDesigner, similar to other design 
deployment in uDesigner. 

Step 2: Grant Accounts Sheet permissions. 

Step 3: Create a company level accounts sheet. There is one accounts sheet per company. 
There is no template for an accounts sheet. After creation, you add columns and rows. The 
columns can be formulas, they can roll up data from company cost (accounts) business 
processes, or they can roll up asset data, project or shell cost data, or resource data. Adding 
rows to the accounts sheet creates the account codes that are used. You need to activate the 
account codes after adding the rows. 

Optional steps: To roll up transactions to the accounts sheet, you must create and set up 
company-level cost business processes (also known as an account type business process). 
These BPs use account codes rather than the CBS codes used in project or shell level cost BPs. 
These are discussed in the Business Process sections. Other options assume that you have 
configured and set up an Assets Sheet (for rolling up asset data). 

Import Company Account Code Attributes Form 

To import Company Account Code Attributes form, see Importing Configuration Packages (on 
page 619). 

Create a Company Accounts Sheet 

You can create an accounts sheet to create new company account codes and capture and view 
company level cost. 

To create an accounts sheet 

1) Go to the Company Workspace tab and switch to User mode. 

2) In the left Navigator, click Cost Manager > Accounts Sheet. The Accounts Sheet log 
opens. You can have one accounts sheet per company. 

3) Click New. The Properties window opens. 

4) Complete the General tab. 

 Title: This will be displayed in the log 

 Description: Enter an optional description 

 Display Mode: Choose Flat or Tree. Account codes are segmented, similar to CBS 
Codes. You can switch between Flat or Tree at any time. The same data is displayed in 
Tree or Flat structure. 

 Default View: You may choose either or both of the Default View check box options: 
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 Open in maximized view: when the sheet is opened, it will automatically open 
maximized, or full-screen 

 Open in split mode: when the sheet is opened, it will automatically open as split 
(same as clicking the Split button) 

If these options are not selected, the accounts sheet will open by default to a size slightly 
smaller than the screen, and not split. The window can be resized by clicking the Minimize or 
Maximize/Restore buttons in the upper right corner of the window, or by dragging the edges 
of the window to the size that you need. 

5) Click OK. The new accounts sheet appears in the log. 

To open the company accounts sheet 

1) Go to the Company Workspace tab and switch to User mode. 

2) In the left Navigator, click Cost Manager > Accounts Sheet. 

3) Select the accounts sheet in the log and click Open, or double-click the sheet to open it. The 
Accounts Sheet opens. You can do the following: 

 Add rows (account codes) or columns 

 Split the screen vertically, which is useful for viewing columns or entering data while 
keeping the account codes in view (click the Split button) 

 Check the Account Status 

 Import Account Codes or Column Details  

Add a Column to an Accounts Sheet 

You can add as many columns as necessary to the accounts sheet. There are two default 
columns: Company Account Code and Company Account Name. You can add columns for 
formulas, for transaction data from company level cost business processes (account type), or to 
roll up data from project or shell cost sheets, or resource actuals.  

To add a column 

1) Open the accounts sheet. 

2) Click the Columns button. The Columns log opens. 

3) Click New. The Column Properties window opens. 

4) Complete the columns log as described in the following table. 

5) Click OK. 

In this field: Do this: 

Name 
The name is populated with the data 
source 

Data Source 

Click the drop-down and choose the data 
source for the column. Options include: 

Single Sources: 

 Company account type BPs, listed by 
name and status. These are company 
level cost BPs of subtype line items 
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with accounts code. 

 Projects/Shells (CBS): Data is rolled 
up from project or shell cost sheets into 
the company cost sheet, based on the 
mapping of cost sheet columns and 
account code. 

 Resource Actuals: Data is rolled up 
from company level time sheet 
records. 

Logical Sources: 

 Accounts Code 1 through 25. You 
can use these to create a formula or 
manual entry column. These are 
reportable. 

Entry Method 

Select one of the options (options available 
are dependent on the data source; 
applicable when a Logical data source is 
selected): 

 Manual: User enters data directly into 
an accounts sheet cell 

 Formula: Can create a formula from 
other accounts sheet columns 

Data Format 
Choose Currency (base currency) or 
Percentage (%) 

Display Mode Show or Hide the column from user view 

Column Position After 
Select the column after which you want the 
current column to appear 

To roll up project or shell cost sheet data to the accounts sheet 

1) Be sure the project or shell cost sheet data rolls up to a company cost sheet column, using a 
data source Project/Shell Cost 1 through 25 for the cost sheet column. 

2) Map the company cost column to an account code. (In the company cost sheet Properties 
window, Options tab. See Map cost sheet column to an account code (on page 384).) 

3) Roll up the mapped company cost column data to the accounts sheet column, choosing 
Projects/Shell data source. The column will show the Total of the company cost column. 

As project or shell level transactions take place, the company cost column will reflect the 
changes, which in turn will roll up to the accounts sheet. 

Adding and Managing Accounts Sheet Rows 

Regardless of the order you add or import rows, they are automatically sorted alphanumerically 
by account code. 
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Add Rows to the Accounts Sheet 

You can add account codes to the accounts sheet manually or by importing. 

To add a row to the accounts sheet manually 

1) Open the Accounts Sheet. 

2) Click the Add Row button. 

3) Complete the Account Code Details form. This is the attribute form and will vary based on 
your company's design. Account codes are built like CBS codes, from segments that can be 
text fields or pulldown menus. 

4) Click OK. 

Delete Accounts Sheet Rows 

You cannot delete a row if it contains line item or rolled-up data, or if the code is mapped to a 
cost or asset sheet column. 

To delete rows from the accounts sheet 

1) Open the accounts sheet. 

2) If you are using a tree structure, click the plus (+) next to segment rows (shaded blue) to 
view account code rows. 

3) Select a check box next to the account code to be deleted. 

4) Click the Delete Rows button. 

5) Click Yes to confirm. 

Import Account Sheet Rows 

Step 1: Export template

a) Open the accounts sheet. 

b) Click the Export button and choose Account Codes. 

c) In the File Download window, click Save. Enter a file name, browse to where you want to 
save the file, and click Save. 

Step 2: Edit Template in Excel

a) Open the CSV file you just exported. 

b) If the accounts sheet already contains rows, they will be listed. Note the format and 
structure. 

c) Delete any existing rows. 

d) Enter new account codes into the columns and save the file. 

Step 3: Import the CSV file

a) On the Account Sheet toolbar, click Import and choose Account Codes. 

b) In the Upload window, browse to and add the CSV file. 

c) Click OK. After the import, the accounts sheet will show the new rows. Rows are sorted 
alphabetically by account code (adjusts for tree or flat structure). 
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Activate an Account Code 

If an account code is inactive it should still be displayed on accounts sheet but should not be 
available through an account code picker. 

To activate or deactivate an account code 

1) Open the Accounts Sheet. 

2) Click the Account Status button. The Account Code Status window opens. 

3) Select one or more account codes and click Activate or Deactivate. 

Modify Accounts Sheet Default View 

The accounts sheet Properties window offers two options regarding how the sheet will appear 
when it is first opened. These options control how the sheet opens for all users. 

To modify the accounts sheet default view 

1) Open the accounts sheet Properties window (select the sheet and click the Properties
button from the log toolbar, or open the sheet and click File > Properties). 

2) On the General tab, you may choose either or both of the Default View check box options: 

 Open in maximized view: when the accounts sheet is opened, it will automatically open 
maximized, or full-screen 

 Open in split mode: when the sheet is opened, it will automatically open as split (same 
as clicking the Split button) 

If these options are not selected, the accounts sheet will open by default to a size slightly 
smaller than the screen, and not split. 

Setting up the Funding Manager 

The Funding Manager helps you to keep track of where project or shell funding comes from and 
how it is being spent. The Funding Manager is available in CBS shells. Use the Project or Shell 
Funding sheet to specify the appropriation and assignment of funds from each funding source. 
You can automate fund appropriation and assignment when used with cost business processes. 

Sometimes, it may be necessary to allocate specific funds to use on a particular contract, and 
have a means to control consumption on the invoices created against that contract. This can be 
done through commitment-level funding. A commitment funding sheet is created for each base 
commit that has been designed for commitment funding. You allocate funds from the project or 
shell funding sheet to the commitment funding sheet. This sheet works in conjunction with the 
Schedule of Values (SOV) sheet to track base commit and change commit line items and 
balances. 

Company Funding Sheet vs. Project or Shell Funding Sheets vs. Commitment Funding 
Sheets 
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The first step to setting up funding is to create and set up a company funding sheet, where 
individual funding sources are maintained. 

For example, a corporation's funding sources may include different types of corporate accounts. 
For municipal or educational facilities, funds may come from bond measures, grants, donations 
or other sources. All of these funding sources will be listed and tracked on the company funding 
sheet. As funds are consumed via business processes or manually in individual project or shells, 
this data is rolled up to the company funding sheet. 

Project or shell funding sheets track how your company's funding is being spent on each project 
or shell. It tracks individual transactions, which are rolled up to the company funding sheet. All 
project or shell funding sheets must be created based on a funding template. 

If you are using commitment funding, you will start with a commitment funding template, which is 
used to create the commitment funding structure within a project or shell. As base commits (that 
are designed for commitment funding in uDesigner) are routed and approved, a commitment 
funding sheet is created, based on this structure, for each base commit record. This sheet works 
with the SOV sheet to track and control funding of each SOV line.  

How to set up the Funding Manager 

The following is an overview of the steps needed to set up funding for use in projects and shells, 
plus the steps needed to set up the optional commitment level funding. Details for each step are 
in the sections that follow, unless otherwise noted. 

Setting up company and project/shell funding 

Before you begin. The fund attribute form can be designed in uDesigner. This will be used as 
the Fund Details window when adding new funds to the company funding sheet, or viewing fund 
properties. If your company does not design a fund attribute form, a simple default form is used. 

Import and set up fund business processes. You can use business processes for fund 
allocations, fund assignment (also known as consumption; enabled on spends type business 
processes), and fund credits (also enabled on spends business processes). This step can be 
done at any point in this general procedure. Be sure you know which funding business 
processes you will be using for the project or shell before defining funding rules on the project or 
shell funding sheet. 

Step 1: Import and deploy the fund attribute form. Once imported, the fund attribute form 
becomes the Fund Details window, used to create and manage fund codes in the company 
funding sheet. When designing the form, you can also design the fund picker, which is used to 
add funds to business processes and project/shell funding sheets, as well as "Find" on the 
picker. This is an optional step. If you do not create a fund attribute form, a default fund code 
form and fund picker will be used. 

Step 2: Create and set up the Company Funding Sheet (User mode). You define the funds in 
the company funding sheet, which can then be used for funding project or shells. Only one 
company-level funding may be created per company. All project or shell funding sheets refer to 
the company funding sheet. 

Step 3: Create and set up Project/Shell Funding Template (Admin mode). The funding 
template is used to create project or shell funding sheets. 
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Step 4: Create and set up the Project/Shell Funding Sheet (User mode). The project or shell 
funding sheet is based on the funding template. (You can also define the project/shell funding 
sheet in a project or shell template.) The funding sources available for the project or shell are 
defined in the company funding sheet. 

Step 5: Define funding assignment rules. Funding assignment rules can be defined in the 
project/shell funding sheet or the funding template (or both). You can also determine the order in 
which to consume funds if you will be using automatic fund assignment from business 
processes. (This step can be done any time after creating the funding template. If you define 
assignment rules in a template, they will be carried over to the sheets created from them.) 

Additional steps: Create funding rules in the rules engine. You can create funding rules in 
the rules engine that can help you manage your funds and fund balances. The most common 
rule is to keep your company fund balances from becoming less than zero. Configure 
permissions. As you create funding sheets and set up funding business processes, remember to 
configure the permissions to go with them. Refer to the Unifier Data Reference Guide for funding 
permissions. 

Setting up commitment level funding 

Commitment level funding is optional. To set it up, first set up funding in the project or shell, then 
follow these additional steps. 

Commitment funding works in conjunction with general spends and payment applications SOV 
sheets. 

Before you begin. Be sure that the project/shell funding has been set up, with funds allocated 
and available on the project/shell funding sheet. Data sources are available for project/shell 
funding sheets (and company funding sheets) to track funding that is assigned for specific base 
commits. Also, be sure you have added the data source "Scheduled Value" to the SOV structure 
for the project or shell. Commitment funding uses the SOV to track base commit and change 
commit amounts, and uses the Scheduled Value column to track remaining balances. 

Import and set up business processes for commitment funding. In addition to business 
processes that are used for project/shell funding, you can design business processes for use 
with commitment funding. In uDesigner, commitment funding is enabled on the base commit 
(and linked change commit); automatic generation of an SOV must also be enabled. Then, the 
ability to create (and later access) the commitment funding sheet can be enabled on the form. 
Be sure the spends business process that is linked to the base commit has been enabled to 
consume funding. 

Step 1: Create and set up Commitment Funding Template (Admin mode). This template is 
used to create a commitment funding structures in the project or shell, which in turn is used to 
create the individual commitment funding sheets for each base commit record. You can add 
columns to the template, but not rows. 

Step 2: Define funding assignment rules. This is done in the Assignment tab of the Properties 
window. Assignment rules can be defined in the commitment funding template, structure or 
sheets. (This step can be done any time after creating the funding or commitment funding 
template. If you define assignment rules in a template, they will be carried over to the structure 
and sheets created from them.) 
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Step 3: Create Commitment Funding Sheet Structure (User mode). Structures are created at 
the project level in User mode from a commitment funding template. When commitment funding 
sheets are created from base commit records, this default structure is used. You can also create 
a commitment funding structure in a project or shell template. 

Step 4: Create individual commitment funding sheets. This is done automatically the first 
time you click the Funding button on a base commit business process form (this button becomes 
available on specific steps as designed in uDesigner). After creation, the commitment funding 
sheet is available for viewing or modification by clicking the Funding button on the base commit 
or associated change commits, or from the Commitment Funding log itself. 

Additional steps: Configure permissions. Module permissions must be granted to the 
commitment funding template, to the commitment funding sheet in a project or shell template (if 
using), to commitment funding sheet in a project or shell (in order for the node to be visible). In 
addition, record level permission must be granted to individual commitment funding sheets. By 
default, the owner of the base commit will have permissions to the sheet. Additional users must 
be granted view or edit permissions. Refer to the Unifier Data Reference Guide for general 
funding permissions. Sheet permissions are granted User mode. Additional assignment 
details. After the commitment funding sheet and SOV sheet are created, additional funding 
assignment details can be defined on the Fund Assignment window (accessed from the SOV 
sheet or commitment funding sheet). 

Importing Fund Attribute Form 

The Fund Details form can be configured by creating a Fund Attribute form in uDesigner. With 
the import of this attribute form, you are also importing designs for the fund picker, which is used 
to add funds to business processes and project/shell funding sheets, as well as "Find" on the 
picker. If you do not create a fund attribute form, a default fund code form and fund picker will be 
used. 

Only one fund attribute form may be created and imported per company. 

Notes: 

 Use caution when modifying and re-importing an attribute form. For 
example, if you make changes to a data definition, such as Fund 
Category after it is being used in the funding sheet, the system may 
not see the new data definition and will produce an error. 

 Oracle strongly recommends that you use the Development
environment to create your uDesigner business processes and 
attribute forms before deploying to the Test/Production 
environment. 

To import a fund attribute form into Unifier Production environment, see Importing 
Configuration Packages (on page 619). 
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Creating a Company Funding Sheet 

The Company Funding Sheet tracks all sources of funding across all projects or CBS shells. You 
create only one sheet per company. Funding sources that are made available at project or shell 
sheet level or commitment level are rolled up to the company sheet, which maintains the overall 
fund information.  

After it is created, the company funding sheet can be edited, but not deleted. The company 
funding sheet must be created before creating individual project or shell funding sheets. 

To create the company funding sheet 

1) Go to the Company Workspace tab and switch to User mode. 

2) In the left Navigator, click Cost Manager > Funding. The Company Funding Log opens. 

3) Click New. The Properties window opens. 

4) Enter a Title and Description. 

5) For Display Mode, choose Flat (no indenting of rows) or Tree (allows indented, nested 
rows). 

6) Click Save. The funding sheet is listed in the Company Funding log. 

Add Columns to the Company Funding Sheet 

The columns on the company funding sheet are used to track project/shell level funding, as well 
as commitment level funding if you are using it, and keep track of fund balances.  

To add a column to the company funding sheet 

1) From the Company Funding log, select the company funding sheet and click Open from the

gear menu (  ), or double-click the company funding sheet. The Company Funding Sheet 
window opens. 

2) Click the Add Columns. The New Column window opens. 

3) Complete the fields  as described in the following table. 

4) Click Save to add the new column to the company funding sheet. 

In this field: Do this: 

Name 

The name you choose will appear as the 
column header. You may manually enter a 
column name, or, if you leave the Name 
field blank, the selection you make in the 
Datasource field will automatically 
populate the Name field. 

Type 

Choose one of the following types: 

 From Business Process

 Direct Entry
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In this field: Do this: 

 Line Item Content

 Formula

Datasource 

All columns must be associated with a 
data source. The data source that you 
choose will determine which of the 
following options are available. The types 
of Data sources available are as follow. 

 Single Sources: These values roll up 
from a single, defined source, such as 
a business process or a system 
defined source. 

 Logical Sources: These include 
user-defined Manual Entry or Formula 
columns. 

Single Source 

Data sources that contain funding sources 
and consumption information; that is, Fund 
subtype of Cost business processes, 
which allocate funding, Spends business 
processes that consume funding, and 
Commit business processes that trigger 
commitment funding, if used. 

 Business Processes: List of cost-type 
business processes that include 
funding data definitions. 

 Project/Shell Funding: Sum of all 
funding sources at project or shell level 
for each project or shell, as rolled up 
from each individual project or shell 
funding sheet. The information that 
gets rolled up to this column is 
dependent on the project or shell 
funding sheet setup for each project or 
shell. 

 CBS Funding: Sum of all funding 
sources at CBS level for each project 
or shell, rolled up from each individual 
project or shell funding sheet. The 
information that gets rolled up to this 
column is dependent on the project or 
shell funding sheet setup for each 
project or shell. 

 Manual Funding by project/shell: 
Sum of all project or shell-level funds 
that are allocated at project or shell 
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In this field: Do this: 

level manually. 

 Manual Funding by CBS: Sum of all 
funds that are allocated at CBS level 
manually. 

 Commitment Funding: Sum of all 
funds that are allocated at the 
commitment level (if used) for each 
project or shell. 

 Records Funded at Project/Shell 
Level: Sum of all records that are 
funded at project or shell level. These 
are records that have already ended 
their workflow or hit terminal status. 

 Records Funded at CBS Level: Sum 
of all records that are funded at CBS 
Level. These are records that have 
already ended their workflow or hit 
terminal status. 

 Records Funded at Commitment 
Level: Sum of all records that are 
funded at the commitment level 
(spends BPs that are linked to base 
commits enabled for commitment 
funding). These are records that have 
already ended their workflow or hit 
terminal status. 

 Transient Records Funded at CBS 
Level: Sum of all records that are 
funded at CBS Level. These are 
records that are currently in process. 

 Transient Records Funded at 
Project Level: Sum of all records that 
are funded at project or shell level. 
These are records that are currently in 
process. 

 Transient Records Funded at 
Commitment Level: Sum of all 
in-process records that are funded at 
the commitment level. 

 Fund1 to Fund25: Generic data 
sources that can be used for manual 
entry or formula columns to make the 
values reportable. 
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In this field: Do this: 

Logical Sources 

Logical sources include the following data 
sources. 

 Company Funding: This is commonly 
the column to use to manually enter 
the starting amount for each fund. 

 Company Fund1 to Fund25: Generic 
data sources that can be used for 
manual entry or formula columns to 
make the values reportable. 

Data Format 

The following options are applicable for 
Manual Entry or Formula columns. 

 Currency: right-aligns column contents 
and includes a currency symbol, 
formatting the value to the specified 
currency for the sheet. 

 Percentage: right-aligns the contents 
and includes a percentage symbol 

Display Mode 

The following options refer to whether the 
column is displayed on the sheet. 

 Show: Choose this option to allow 
users to view this column. 

 Hide: Hidden columns are active but 
not displayed and can be accessed by 
users with "create" permission on the 
funding sheet. 

Column Position After 
The new column will be inserted after the 
column selected. 

Note: As funding is consumed from individual funds, the new balance 
will not be reflected on the company funding sheet by default. You can 
track your fund balances by adding columns to roll up funding 
assignments from business process or by manual assignments from the 
project/shell funding sheets, and commitment funding sheets if used, 
then adding a formula column to keep track of the balance. You can also 
use the rules engine to create a rule to keep this balance from going less 
than zero (or another amount). 
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Add Rows (Funds) to the Company Funding Sheet 

Each row of a Company Funding Sheet represents an individual source of funds. The funds 
defined here are used in individual project or shell funding sheets. 

Note: After fund assignments have been made against them on project 
or shell funding sheets, you will not be able to edit company funding 
sheet rows. 

To add company funding sheet rows (funds) 

1) From the Company Funding Sheet, click Add Row. 

2) Complete the Fund Attributes window fields: 

 Fund Code

 Fund Description

 Fund Category

 Fund Name

 Fund Long Description

3) Click Save. The fund appears as a row on the Funding Sheet in alphabetical order. 

To edit a row 

1) Click a fund code in a row, which appears as a link. The Fund Attributes tab opens in 
another pane. 

2) Make changes and click Save. 

Activate or deactivate a row 

1) From the Company Funding Sheet, click the Menu Options and select Fund Status. 

2) Select the check boxes for each row you want to edit. 

3) Click Activate or Deactivate. All the selected rows will have their status changed to Active 
or Inactive. 

4) Click OK to close the confirmation window. 

To delete a row 

1) From the Company Funding Sheet, click the Menu Options and select Fund Status. 

2) Select the check boxes for each row you want to edit. 

3) Click Delete and Yes to confirm. All selected rows will be deleted. 

Creating a Project or Shell Funding Sheet Template 

Funding templates are created and set up in the Templates node, and are used to create 
individual project or shell funding sheets. They can also be used to create a funding sheet in a 
project or shell template. 

Setting up the funding template consists of adding columns, which correspond to the data 
sources (for example, business process transactions, formulas, values you enter manually, and 
so on) that you want to track for each funding source. It can also include adding rows (funds). 
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You can specify fund assignment rules in the template or individual project/shell funding sheets. 
See Defining Fund Assignment Options for Project/Shell Funding (on page 405). 

To create a funding sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Funding > Funding Sheet. 

3) Click the New button. The Properties window opens. 

4) Enter a Title and Description. 

5) For Display Mode, choose Flat (no indenting of rows) or Tree (allows indented, nested 
rows). 

6) Click OK. The template is listed in the log. 

After creating the funding template, you can open the sheet and define columns and add 
funds (rows). 

Add a Column to the Funding Template (or Project/Shell Funding Sheet) 

These procedures are applicable to funding sheet templates, funding sheets, and funding sheets 
created in project or shell templates. 

Funding columns specify the data sources (business process transactions, formulas, values 
entered manually, and so on) that will be displayed on the project or shell funding sheet. Default 
columns on funding sheet are Fund Code and Fund Name. If a Fund Attribute form has been 
imported, in which the label of Fund Code data element and Fund Name data element were 
modified, then the new labels will be displayed as column headers. 

Note: Some project funding columns require assignment information at 
the project level and cannot be created in the template (for example, 
Consumed Funds, CBS Funding). 

To add a funding column 

1) Open the funding sheet or template: 

2) Open the funding template and click the Columns button. The Column Log opens, 
displaying the list of existing columns. 

3) Click New. The Column Properties window opens. 

4) Complete the Column Properties window as described in the table below. 

5) Click OK to add the new column. 

In this field: Do this: 

Name 

The name you choose will appear as the 
column header. You may manually enter a 
column name, or, if you leave the Name 
field blank, the selection you make in the 
Datasource field will automatically 
populate the Name field. 

Datasource All columns must be associated with a 
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In this field: Do this: 

data source. The data source that you 
choose will determine which of the 
following options are available. The types 
of Data sources available are: 

Single Sources: These values roll up from 
other sources. These include cost type 
business processes, some pre-defined 
cost columns. 

Logical Sources: These include 
user-defined Manual Entry or Formula 
columns. 

Single Source 

Data sources that contain funding sources 
and consumption information; that is, Fund 
subtype of Cost business processes, 
which allocate funding, Spends business 
processes that consume funding, and 
Commit business processes that trigger 
commitment funding, if used. 

 Business Processes: List of cost-type 
business processes that include 
funding data definitions. 

 Manual Funding by CBS: Sum of all 
funds that are allocated at CBS level 
manually. 

 Commitment Funding: If commitment 
funding is used, this datasource tracks 
funds that are allocated across base 
commit and change commit business 
process records enabled for 
commitment funding. Reflects sum of 
Funding Across All Funds and Funding 
By Discrete Funds datasources on 
commitment funding sheets. Click the 
link to view cell details. 

 Records Funded at Project/Shell 
Level: Sum of all records that are 
funded at project or shell level. These 
are records that have already ended 
their workflow or hit terminal status. 

 Records Funded at CBS Level: Sum 
of all records that are funded at CBS 
Level. These are records that have 
already ended their workflow or hit 
terminal status. 

 Records Funded at Commitment 
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In this field: Do this: 

Level: Sum of all records that are 
funded at the commitment level 
(spends BPs that are linked to base 
commits enabled for commitment 
funding). These are records that have 
already ended their workflow or hit 
terminal status. 

 Transient Records Funded at CBS 
Level: Sum of all records that are 
funded at CBS Level. These are 
records that are currently in process. 

 Transient Records Funded at 
Project Level: Sum of all records that 
are funded at project or shell level. 
These are records that are currently in 
process. 

 Transient Records Funded at 
Commitment Level: Sum of all 
in-process records that are funded at 
the commitment level. 

Logical Sources 

Logical sources include: 

 Project/Shell Funding: Sum of all 
funding sources at project or shell 
level. The information that gets rolled 
up to this data source is dependent on 
the project or shell Funding Sheet 
setup for each project or shell. 

 CBS Funding: Sum of all funding 
sources at CBS level. The information 
that gets rolled up to this data source is 
dependent on the project or shell 
Funding Sheet setup for each project 
or shell. 

 Manual Funding by Project/Shell: 
Sum of all funds that are allocated at 
project or shell level manually. 

 Fund1 to Fund25: Generic data 
sources that can be used for manual 
entry columns to make the values 
reportable. 

Entry Method 
This is applicable for logical data sources. 

Manual Entry: Choose Direct Entry into 
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In this field: Do this: 

Cell to allow entry directly into the cell, or 
Line Item Content to allow data entry 
through a line item window. 

Formula: Values are calculated based on 
a specified formula entered for the column. 
Formulas can include the values of other 
columns. Click the Create button to create 
the formula. 

Data Format 

Applicable for Manual Entry or Formula 
columns: 

Currency: right-aligns column contents 
and includes a currency symbol, formatting 
the value to the specified currency for the 
sheet. 

Percentage: right-aligns the contents and 
includes a percentage symbol 

Display Mode 

Refers to whether the column is displayed 
on the sheet. 

Show: This is the default choice. This 
indicates that column will display by default 
on the funding sheet to all users with at 
least "view" permission for the funding 
sheet. 

Hide: Hidden columns are active but not 
displayed and can be accessed by users 
with "create" permission on the funding 
sheet. 

Column Position After 
The new column will be inserted after the 
column selected 

Add a Funding Column to Project or Shell Cost Sheet 

Cost sheets can show fund related information as part of a Funding Manager solution. The 
following section discusses funding columns you can add to the project or shell cost sheet. 

To add a funding column to the Project/Shell Cost Sheet 

1) Open the Cost Sheet template and click the Add Column button. The New Column window 
opens. 

2) Complete the fields in the New Column window. For Data Source, choose from the following: 

 Line Item Content type: Data sources that contain fund related information: 

 Funded Records: Sum of all Records that are funded at CBS Level. 
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 Unfunded Records: Sum of all Records that are not funded at CBS Level. 

 Manual Funding by CBS: Sum of all funding sources that are allocated at CBS 
level manually. 

 Formula type: Data sources that are available at project or shell level: 

 CBS Funding: Sum of all funding sources at CBS level. The information that gets 
rolled up to this data source is dependent on Project/Shell Funding Sheet setup for 
each project or shell. 

Note: You cannot select this data source unless a funding source is 
selected under "Processes Contributing Assignable Funds" for CBS 
level. This is located under Project Funding sheet > Properties > 
Assignment Tab. 

3) Click Save to add the new funding column to the project or shell cost sheet. 

To edit a column 

1) Click the hyperlink text in the CBS Code column. The General tab will open in a secondary 
pane. 

2) Edit information as necessary.  

Note: Although it is possible to change the entry methods for a column 
(for example, from "Line item content" to "Direct entry into cell"), use 
caution when doing so if you have already entered values in the column 
cells. For example, if you change from line item entry to direct cell entry, 
the Amount value shown in the cell will appear correctly, but will be an 
editable direct entry amount, and detailed line item information will be 
lost. 

To move a column 

Click and drag the column headers in the log to rearrange columns. A blue line will appear, 
indicating where the column will be placed. 

To delete a column 

Right-click a column header and select Delete. A confirmation window will appear, and you will 
need to click Yes in order to proceed with deletion. 

Note: If the column is being used in a formula in another column, you 
must remove the column from the formula before you can delete it.  If 
the column contains a cell with line item data, you must first remove 
each line item before it can be deleted 

Add Rows to the Funding Template 

These procedures are applicable to funding sheet templates, funding sheets, and funding sheets 
created in project or shell templates. 
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Each row of a project or shell funding sheet represents an individual source of funds. The funds 
added here are funds that are active under the company funding sheet. 

Note: After fund assignments have been made against them, you will not 
be able to edit project or shell funding sheet rows. To view the status of 
a fund, click the Fund Status option in the Menu Options. 

To add rows (funds) to the funding template or project/shell funding sheet 

1) Open the funding sheet or template. 

2) Click Rows, and then click Add Row. The Fund Detail window opens. If you have imported 
a Fund Attribute form, a customized Fund Detail window will open. 

3) Select a fund from the fund picker (or Fund Code field). 

You can search for a specific fund in the fund picker by clicking the Find button and opening 
the Find form. Enter search criteria and click Search. This limits the number of funds that are 
displayed to those that match the search criteria. 

4) You can search for a specific fund in the fund picker: 

a. Click the Find button. The Find window opens. The window that opens will depend on the 
design in uDesigner. 

 If an attribute form is not defined, the default Find window will allow you to search 
by Fund Code or Fund Name. 

 If an attribute form is defined, the Find window can also be designed in uDesigner, 
and you may have additional fields to search by. 

b. Enter search criteria and click Search. This limits the number of funds that are displayed 
to those that match the search criteria. 

5) Click OK. The fund appears as a row on the Funding Sheet. Funds are displayed in 
alphabetical order on funding sheet. 

6) To view fund details click on a fund under fund code column. If you import a Fund Attribute 
form then you will see customized detail form instead of a generic fund detail form. 

Creating a Project/Shell Funding Sheet 

The Project/Shell Funding Sheet tracks how funding is being allocated and consumed at the 
project or shell level. Project or shell funding sheets work in conjunction with the company 
funding sheet. Allocating funding sources at project or shell level can be done manually, or 
through a business processes. 

A Funding Template and Company Funding Sheet must be completed before you can create a 
project or shell Funding Sheet. 
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To create the project or shell funding sheet 

1) In User mode, open the project, and click Cost Manager > Funding in the left Navigator. 
The Project/Shell Funding Log opens. 

2) Click Create. The Select Template window opens. 

3) Select a template, and click Create. 

4) Click Yes to confirm. The Project/Shell Funding Sheet displays in the log. You can use the 
funding sheet as it is or set it up to meet the needs of the project or shell. 

Add Columns to the Project/Shell Funding Sheet 

Columns are added to a Project/Shell Funding Sheet in the same way as they are added to a 
Funding Template. See Add a Column to the Funding Template (or Project/Shell Funding 
Sheet) (on page 399). 

Add Project or Shell Funds (Rows) 

Rows are added to a Project/Shell Funding Sheet in the same way as they are added to a 
funding template. Add Rows to the Funding Template (on page 403) 

To edit a row 

1) From the Funding Sheet, click the Manage Rows button. 

2) Use the arrow buttons to move items from the Available Company Fund Codes section to the 
Selected section. 

3) Select all desired columns and click Save. 

To remove a row 

1) From the Funding Sheet, click the Manage Rows button. 

2) Use the arrow buttons to move items out of the selected section. 

3) Remove all desired columns and click Save. 

Defining Fund Assignment Options for Project/Shell Funding 

The following options are available as part of assignment rules at project or shell level and CBS 
level. These can be defined in a funding template, or individual project/shell funding sheets. 

Project and CBS Level: Specify the sources of funds for this project or shell, either manual or 
via fund appropriation business processes. 

Assignment Levels and Rules: For each funding business process (and each status) that has 
been set up for the project or shell, you specify manual, Auto Order, or Auto Ratio. 

For details, see the following procedures. 
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Set up Funding Assignment Options 

After you create a project or shell funding sheet, you can set up assignment options. This 
includes specifying whether manual assignment is allowed; defining the business processes that 
can be used to assign funds to project or shells or to specific CBS codes; and defining 
assignment levels. 

Project Level and CBS Level: Specify how funds can be added for this project or shell. This 
can be Manual (appropriate funds manually from the company funding sheet, and/or through 
funding appropriation business processes that appropriate company funds for the project or 
shell. 

You can define funding appropriations at the project level (not associated with specific CBS 
codes), and at the CBS level (funding is specified per CBS code). You can "mix and match" for 
each project, with some business processes using project level funding, and others CBS level. 
Manual fund appropriations can be done at both levels. 

Assignment Levels and Rules: For each funding business process that has been set up for the 
project or shell, you specify manual, Auto Order, or Auto Ratio. You also choose to assign funds 
at the Project Level (funding is consumed based on the total of the spends business process, 
providing greater flexibility for fund assignment), or CBS Level (funding is consumed per line 
item of a spends business process, which provides greater control over how funds are spent on 
each item.) 

 Manual: Funds can be manually assigned. As spends business processes (for example, 
invoices or payment applications) are routed and reach specified statuses, the amounts to 
be funded are collected under the Unassigned total on the funding sheet. Funds are 
assigned manually to these spends records. 

 Auto Order: Funds are assigned automatically when a spends business process reaches a 
specified status. Funds are assigned based on the fund order, which is defined on the 
funding sheet by clicking the Fund Assignment Order button. When funds are consumed on 
one fund, then the next funding source is used for funding. After all funds are consumed, 
remaining spends are collected under Unassigned. 

 Auto Ratio: Funds are assigned automatically when a spends business process reaches a 
specified status. Funds are assigned based on the fund ratio, which is automatically 
calculated based on current fund levels. After all funds are consumed, remaining spends are 
collected under Unassigned. 

Note: Be sure you have imported and set up any business processes 
you will be using for fund appropriation and assignment in the project or 
shell before setting assignment rules 

To set up fund assignment rules 

1) Open the company or shell funding sheet template (Templates > Funding > Funding 
Sheets or Templates > [shell type] > [shell template] > Cost Manager > Funding >
Funding Sheet). 

2) Select the template in the log and click the Properties button. 

3) Click the Assignment tab. 

4) Complete the window as described in the following table. 
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5) Click OK. 

In this field: Do this: 

Funding Assignment 

Select the Funding Assignments sources. 
The sources can be at the CBS level, 
where funds are assigned to specific CBS 
codes, or project or shell level, which 
allows project or shell level funding without 
assigning funds to specific CBS codes. 

Project/Shell Level 

Click Add to add project or shell level 
sources. Options include: 

Manual: Allows manual entry of project or 
shell fund assignments on the sheet 

Business Processes: Any cost type 
business process that is created with 
sub-type Line Items with Fund Code and 
Classification as Generic. 

CBS Level 

Click Add to add CBS level sources. 
Options include: 

Manual: Allows manual entry of CBS level 
fund assignments on the sheet 

Business Processes: Any cost type 
business process that is created with 
sub-type Line Items with both CBS Code 
and Fund Code and Classification as 
Generic. 

Assignment Levels 

Allows you to set fund assignment rule for 
each spend-type business process that is 
configured in your project or shell. The 
assignment level will only show those 
spend type business processes that 
consume funds. This option is available 
while designing a spend type business 
process in uDesigner.   

Assignment Rules 

Click the drop-down list and select a 
project- or shell-level or CBS-level rule. 

Project /Shell Level:

Manual (Assign by BP Record Total): All 
spends are collected as Unassigned. 
These spends should be assigned 
manually to one or more funds at project or 
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In this field: Do this: 

shell record Level. 

Manual (Assign by BP Line Item): All 
spends are collected as Unassigned. 
These spends should be assigned 
manually to one or more funds at the 
project or shell line item. 

Auto Order (Assign by BP Record Total): 
Funding sources are arranged in a 
prescribed order, and spend are assigned 
in that order. The assignment order is 
defined under project or shell Funding 
Sheet  Fund Assignment Order  Fund 
Assignment Order Window. 

Auto Order (Assign by BP Line Item): 
Funding sources are arranged in a 
prescribed order, and spend are assigned 
in that order at line item level. The 
assignment order is defined under project 
or shell Funding Sheet  Fund Assignment 
Order  Fund Assignment Order Window. 

Auto Ratio (Assign by BP Record Total): 
Funding sources are proportionally 
consumed until fully depleted. The fund 
level itself automatically defines the ratio. 
After the funds are consumed, remaining 
spends are collected as Unassigned. 

Auto Ratio (Assign by BP Line Item): 
Funding sources are proportionally 
consumed until fully depleted at line item 
level. The fund level itself automatically 
defines the ratio. After the funds are 
consumed, remaining spends are collected 
as Unassigned. 

CBS Level:

Manual: All spends are collected as 
Unassigned, and are manually assigned to 
one or more funds at CBS level. 

Auto Order: Funding sources assigned to 
that CBS are arranged in a prescribed 
order, and spends are assigned in that 
order. After all funds are consumed, 
remaining spends are collected as 
Unassigned. Fund Assignment Order for 
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In this field: Do this: 

CBS can be defined under Cost Sheet > 
Fund Assignment Order > Fund 
Assignment Order Window. 

Auto Ratio: Funding sources assigned to 
that CBS are proportionally consumed until 
fully depleted. The fund level itself 
automatically defines the ratio. After all 
funds are consumed, remaining spends 
are collected as Unassigned. 

SOV Auto Order: This option indicates that 
the assignment should be at SOV level 
using Auto order option. The order 
assignment will be defined under SOV > 
Fund Assignment Window. 

SOV Auto Ratio: This option indicates that 
the assignment should be at SOV level 
using Auto ratio option. The ratio will be 
defined under SOV > Fund Assignment 
Window. 

Set Fund Assignment Status and Order 

You can control whether a fund is available when assigning funds to spend by activating or 
deactivating the fund at the project or shell level. Fund assignment order is required if you 
decide to consume funds automatically. You can also view the Fund order. This will be the order 
that will be used while assigning funds with Auto Order option. 

Funds can be automatically consumed at project or shell level by following fund order defined 
under Fund Assignment Order window on project or shell Funding Sheet. 

To set the fund assignment status and assignment order 

1) Open the project or shell Funding Sheet (Templates > [shell type] > [shell template] >
Cost Manager > Funding > Funding Sheet). 

2) Click Fund Assignment Order button on the toolbar. The Fund Assignment Order window 
opens showing whether funds are active or inactive. 

3) Select a fund in the table, and click Activate or Deactivate. Deactivating a fund prevents it 
from being available when assigning funds to spend. 

4) If you want to change the assignment order, select a fund and click Move Up or Move 
Down. 

5) Click Close to exit the window. 
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Set Fund Assignment Order at the CBS Level 

The Unassigned (CBS Level) link on the Project/Shell Funding Sheet displays the total of funds 
at the CBS level. Funds can be automatically consumed at CBS level by following fund order 
defined for each CBS Code from the Fund Assignment Order window on the Project/Shell Cost 
Sheet.   

To set fund assignment order at CBS Level 

1) Go to Templates > Shells > Projects > [project template] > Cost Manager > Cost Sheet. 

2) Open the Project Cost Sheet.  

3) Click the three dots at the bottom of the sheet, and then click the Fund Assignment Order 
tab.  

4) Select a CBS code from the upper pane. A list of funds that are available for this CBS will be 
displayed on the bottom pane. 

The bottom pane will also display assignment status of funds. You can modify assignment 
status of a fund from Project Funding Sheet > Fund Assignment Order window. Funds with 
Inactive status will not be used as part of consumption process. 

5) Select a fund and click Move Up or Move Down button to change fund order. 

6) If you have defined Breakdowns for a CBS code, then select breakdown to view funds. 

Set Fund Assignment Order at the SOV Level 

Funds can be automatically consumed at the SOV level by following fund order or fund ratio 
defined for each CBS in the Fund Assignment Order window on a SOV Sheet. You have ability 
to defined order or ratio for each SOV.  

Note: Fund assignment details can be set on the SOV sheet when you 
are doing project/shell level funding as well as commitment level funding. 
The following procedure discusses how to do SOV Auto Order at the 
project/shell level. If the base commit that created the SOV has been 
enabled for commitment funding, then fund assignment is done at the 
commitment level. 

To Set the Fund Assignment Order at the SOV Level: For CBS—SOV Auto Order  

1) Open the SOV Sheet. 

2) Select the Fund Assignment tab. 

3) You can set Fund Order or Fund Ratio. This is dependent upon the Assignment Rule that 
you choose for spend under the Project/Shell Funding Sheet > Properties > Assignment 
Tab. 

4) Select a CBS code. 

5) Select a fund and then click OK. 



Setting up the Cost Manager

411

The assignment status of funds displays. You can modify assignment status of a fund from 
Project Funding Sheet > Fund Assignment Order window. Funds with Inactive status will 
not be used as part of consumption process. 

6) Perform any of the following actions:  

 Select a fund to change the fund order. 

 If you have defined Breakdowns for a CBS code, then select breakdown to view funds. 

 To add a fund: 

a. Click the + Add button.  

b. In the Add Funds window, select a fund available for the selected CBS Code, and then 
click OK. 

7) Click Save. 

To Set the Fund Assignment Order and Ratio at the SOV Level: For CBS—SOV Auto Ratio 

1) Open the SOV Sheet. 

2) Select the Fund Assignment tab. 

3) You can set Fund Order or Fund Ratio. This is dependent upon the Assignment Rule that 
you choose for spend under Project/Shell Funding Sheet > Properties > Assignment 
Tab. 

4) Select a CBS code. 

The assignment status of funds displays. You can modify assignment status of a fund from 
Project Funding Sheet > Fund Assignment Order window. Funds with Inactive status will 
not be used as part of consumption process. 

5) Perform any of the following actions: 

 Select a fund to change the fund order. 

 If you have defined Breakdowns for a CBS code, then select breakdown to view funds. 

 To add a fund, click the + Add button.  

a. In the Add Funds window, select a fund available for the selected CBS Code, and then 
click OK. 

b. Select a fund and enter a % value. 

6) Click Save. 

Creating Commitment Funding Sheet Templates 

Commitment Funding Sheet templates are created and set up in the Templates node, and are 
used to create the commitment funding sheet structure in a project or shell (or in a project or 
shell template). This structure is then used when sheets are created for individual base commit 
records. 

Setting up the commitment funding template consists of adding columns, which correspond to 
the data sources (for example, business process transactions, formulas, values you enter 
manually, and so on) that you want to track for each funding source. 
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You can specify fund assignment rules in the template, structure or individual commitment 
funding sheets. 

To create a new commitment funding sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Funding > Commitment Funding Sheet. 

3) Click the New button. The Properties window opens. 

4) Enter a Title and Description. 

5) Click OK. The template is listed in the log. 

After creating the funding template, you can open the sheet and define columns. 

Add and Manage Commitment Funding Sheet Columns 

These procedures are applicable to commitment funding sheet templates, commitment funding 
structures created in a project or shell, commitment funding sheet structures created in project or 
shell templates, or individual commitment funding sheets. 

Funding columns specify the data sources (business process transactions, formulas, values 
entered manually, and so on) that will be displayed on commitment funding sheet. 

To add a column to a commitment funding template, structure or sheet 

1) Open the commitment funding sheet, template or structure. 

2) Click the Columns button. The Column Log opens, displaying the list of existing columns. 

3) Click New. The Column Properties window opens. 

4) Complete the Column Properties window as described in the following table. 

5) Click OK to add the new column. 

In this field: Do this: 

Name 

The name you choose will appear as the 
column header. You may manually enter a 
column name, or, if you leave the Name 
field blank, the selection you make in the 
Datasource field will automatically 
populate the Name field. 

Datasource 

All columns must be associated with a 
data source. 

Note: In these datasource definitions, the 
terms All Funds and Discrete Fund refer to 
the fund assignment options. These 
options determine how the SOV lines (and 
therefore, the commit lines) will be funded, 
either automatically or manually from the 
entire list of funds available to the commit, 
or by one specific fund. (See "Define 
Commitment Fund Assignment Details
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(on page 417)). 

The data sources available for 
commitment funding sheets are: 

 Funding Across All Funds: Use this 
column to enter (or calculate) the 
amount of each fund to allocate for this 
base commit record. The rows on the 
sheet are the funds that will be used to 
fund the commit. The value entered 
here will be the fund amount available 
for all commit lines that have "All 
Funds" as assignment. This can be a 
manual entry column, or a formula that 
uses another manual entry column as 
the basis of the formula. 

 Funding By Discrete Fund: This 
column displays the sum total of all the 
line items of base and change commits 
that are funded by a specific (or 
"discrete") fund. This value can be 
used to determine the fund balance 
during consumption. 

 Records Funded Across All Funds: 
Reflects the total of funds consumed 
from records that are funded based on 
All Funds, whether funding is done 
manually or automatically. 

 Records Funded By Discrete Fund: 
Displays the total of funds consumed 
from records that are funded based on 
a discrete fund, whether funding is 
done manually or automatically. 

 Fund Balance Across All Funds: 
This column tracks the fund balance 
across all funds. The formula used is 
(Funding Across All Funds) - (Records 
Funded By All Funds). 

 Fund Balance By Discrete Fund: 
This column tracks the fund balance by 
specific fund chosen in the Fund 
Assignment window. The formula used 
is (Funding By Discrete Fund) - 
(Records Funded By Discrete Fund). 

 Funding Ratio Across All Funds: 
The value of this column is calculated 
automatically. It reflects the % ratio to 
use when performing fund assignment 
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ratio during consumption. The formula 
is (Fund Balance Across All Funds Per 
Fund) / Total of Fund Balance Across 
All Funds). 

 Commitment Funding 1 to 25: 
Numeric data sources that are 
available to use to enter values 
manually or create formulas based on 
other columns. These are reportable 
via user-defined reports. 

Entry Method 

Choose one (the options that are available 
are dependent on the data source 
chosen): 

 Manual Entry: Users enter values 
directly on the sheet. 

 Formula: Values are calculated using 
the entered formula. Formulas can 
include the values of other columns. 
Click the Create button to create the 
formula. 

Display Mode 

This controls the display of numeric 
column data. 

 Show as percentage. Data is 
displayed as % 

 Decimal places. Choose 2 to 8 

Total 

Determines what will display in the "Total" 
(bottom) row for the column: 

 Blank: The total of this column is not 
applicable and will not display on the 
cost sheet. Choose this column for 
percentage columns and other 
columns where it does not make sense 
to display the sum total. 

 Sum of All Rows: The sum total of the 
column values is displayed. 

 Use Formula Definition: For formula 
columns; the formula will be applied to 
the "Total" row in the same way it is 
applied to other rows in the column. 

Column Position After 
The new column will be inserted after the 
column selected 

To create a formula column 

1) In the Column Properties window, choose Formula as the Entry Method, then click the 
Create button. The Formula Creation window opens. 
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2) Enter the first value in the formula: 

To enter numerical values into the formula, click the number keys on the on-screen keypad. 
(Include parentheses, % or decimal point as necessary.) 

To add a column value into the formula, select it from the list in the left pane, then click the 
Select button (or double-click it). Options include: 

 Columns: These are columns that have been added to the sheet. The value in the 
corresponding row will be used in the formula. 

 Total Elements: These are the columns on the sheet that display a total (either the sum 
or formula definition, as defined in the Total option for that column). The value of the 
Total for that column will be used in the formula. 

 An additional default Total Element is also available: Commitment Total Funded By All 
Funds. It is the sum of all commit line items (base and change commits) that have the 
assignment option "All Funds" (as selected for each commit line on the Fund Assignment 
window). 

As you build the formula, it appears in the Formula box in the upper right portion of the 
window. 

3) Click the appropriate operator: add, subtract, multiply, or divide. 

4) Continue to alternate between choosing values and operators to add to the formula. 

5) You may click Undo at any time to undo the last action. Click the Clear All button to clear 
the entire formula. 

6) When the formula is complete, click OK to save your formula and return to the Column 
Properties window. 

7) If you need to change the formula after creating it, click the Modify button (next to the 
Formula option). Clear the old formula first (click Undo or Clear All), then re-enter it. 

To create a column by copying an existing column 

1) In the Column log, select a column and click Copy. The Column Properties window opens. 

2) Make changes as necessary for the new column. You must change at least the data source. 

To edit a column 

In the Columns Log , select a column and click Open. The Column Properties window opens. 

Make edits as necessary and click OK. 

Note: Although it is possible to change the entry methods for a column, 
use caution when doing so. For example, if you change the entry method 
from Manual Entry to Formula, any existing values you have entered in 
that column will be replaced with the formula. Some column properties 
for some system data sources cannot be modified. 

To move a column 

In the Columns Log, select a column to move, and then click Move Up (Left) or Move Down 
(Right). The order in which the columns appear in the Log window is the order (from left to right) 
that they appear on the sheet. 



Modules Setup Administration Guide

416

To delete a column 

Select a column from the Columns Log and click Delete. The column will be deleted. 

Note: If the column is being used in a formula in another column, you 
must remove the column from the formula before you can delete it. 

Defining Fund Assignment Options for Commitment Funding 

Fund Assignment refers to how funds are to be consumed as spends type business processes 
(for example, invoices and payment applications) come in against the base commit that is being 
funded. 

The first step is defining the Assignment rules—whether funding is to be done manually or by 
auto ratio. The assignment levels and rules are defined on the Assignments tab in the Properties 
window of the commitment funding sheet. This step is mandatory in order to do commitment 
level funding. 

The Assignment tab lists the spends business processes that are linked to base commits 
enabled for commitment level funding. For each listed business process, you define how fund 
assignment will be done when these spends records come in against the base commit (either 
manually, or automatically by fund ratio). 

You can define these assignment rules on the commitment funding template. When you create a 
commitment funding structure in a project or shell, these assignment rules will be copied to it, 
and when you create new sheets from the structure, they will be copied to the sheets. If you 
need to, you can modify these rules on individual structures and sheets. 

The next step is optional: define Fund Assignment details per SOV line; that is, define whether a 
specific fund must be used to fund a particular line on the commit. This allows you to provide 
details about fund assignment or consumption for each line on the base commit or any change 
commits. You access the Fund Assignment window by clicking the Fund Assignment button on 
the commitment funding sheet or SOV sheet associated with the base commit. 

If you do not define any assignment options in this window, then All Funds is the default 
selection. This means that all funds that have been allocated to the base commit on the 
commitment funding sheet will be available for funding each line of the spends business process 
created against it (either manually or by auto ratio, as defined by the assignment rules). 

Fund assignment on these lines is tracked by commitment funding sheet columns using data 
sources that for records or fund balance "across all funds." For more information, see Add and 
Manage Commitment Funding Sheet Columns (on page 412). 

Sometimes, you may need to specify that a specific fund be used to fund a specific CBS code or 
SOV line. For these lines, you can select a specific fund (or "discrete fund"). Fund assignment is 
then tracked by commitment funding sheet columns using data sources for records or fund 
balance "by discrete fund.") 

For details, see the following procedures. 
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Define Commitment Fund Assignment Rules 

The fund assignment rules define how assignment will be done on the spends business 
processes created against the base commit being funded: either manually or automatically by 
fund ratio. 

Funding assignment levels and rules can be defined in the commitment funding template, 
structure, or individual sheets. It is easiest to set them once, in the template, and have them 
carried forward into the structures and sheets created from it. If necessary, these options can be 
modified later for individual structures and sheets. These rules must be defined on the 
commitment funding sheet in order to do commitment level funding. 

To set up commitment funding assignment rules 

1) Open the Properties window of the commitment funding template, structure or sheet. (From 
the File menu, choose Properties.) 

2) Click the Assignment tab. The list displays all General Spends and Payment Application 
Business Processes that are linked to a Base Commits that has been enabled for 
commitment funding and has been designed to consume funds according to the design. 

3) For each listed spends business process, click the Assignment Rule drop-down and select 
one of the following: 

 Commitment Level - Manual: Funds are manually assigned at runtime. As spends 
business processes are routed and reach specified status, the amounts to be funded are 
collected under the Unassigned total on the commitment funding sheet, similar to 
project/shell level manual funding. You can then select each line of the spends BP and 
assign funds at runtime. Consumed funds roll up to the commitment funding sheet and 
the project funding sheet. 

 Commitment Level - Auto Ratio: Funds are assigned automatically when the spends 
business process reaches a specified status. Funds are assigned based on the fund 
ratio, which is calculated based on the fund levels (using the value in the column of data 
source Funding Ratio Across All Funds on the commitment funding sheet), and is 
managed and tracked on the commitment funding sheet. If all funds are consumed, any 
remaining spends amounts are collected under Unassigned. 

4) Click OK. 

Define Commitment Fund Assignment Details 

This is an optional step that allows you to provide details about fund assignment or consumption 
for each line on the base commit or any change commits. The commitment funding sheet works 
in conjunction with the SOV sheet in tracking the individual line items on the base commit and 
any change commits. Therefore, you can define details about fund assignment per SOV line. 
This is done on the Fund Assignment window. 

By default, all funds that have been allocated to the base commit on the commitment funding 
sheet will be available for funding each line of the spends business process created against it 
(either manually or by auto ratio, as defined by the assignment rules). 

However, if you need to specify that a specific fund must be used to fund a specific CBS code 
(or SOV line), you can specify a specific (or "discrete") fund to use. 
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You can do fund assignment one row at a time, or several rows at a time (bulk assignment). See 
the following procedures. 

Note: If you do not define fund assignment options, the default will be All 
Funds for each SOV line. 

To set fund assignment details (one row at a time) 

1) Open the commitment funding sheet or the SOV sheet template. 

2) Click the Properties button on the toolbar and open the Assignment tab. The fund 
assignment grid view displays each line that is present on the SOV sheet, including CBS 
breakdowns. (The Fund Assignment button is available on the commitment funding sheet 
once the SOV has been created for the base commit.)  

3) In the Assignment column, click the drop-down and choose the assignment: 

 All Funds: This is the default option. This means that all funds allocated to the 
commitment funding sheet are available to fund the SOV line or breakdown. (This option 
must be used if you are doing assignment by auto-ratio.) 

On the commitment funding sheet at runtime, funding consumption will roll up to the 
column using data source "Funding Across All Funds." 

 <Fund Code-Fund Name>: Each fund that has been allocated to the commitment funding 
sheet will display on the drop-down alphabetically. These are referred to as "discrete 
funds." You can choose to assign a specific fund to an SOV line or breakdown. This 
means that only that fund will be used to fund that line. (You can choose the same fund 
code for multiple lines.) 

On the commitment funding sheet at runtime, funding consumption will roll up to the 
column using data source "Funding By Discrete Fund." 

Note: If an SOV line has a breakdown, then select an assignment for 
each breakdown, not the SOV line itself. 

4) Click Save to save the sheet. 

To set fund assignment on multiple rows on the SOV sheet (bulk assignment) 

1) Open the commitment funding sheet or SOV sheet. 

2) Click the Properties button on the toolbar and open the Assignment tab. The fund 
assignment grid view displays each line that is present on the SOV sheet, and includes an 
Assignment column. 

3) Select a row, or multiple rows by holding down the Shift key (to select a range of rows) or 
Ctrl key (to select rows throughout the sheet) while clicking the rows. 

4) Click the Bulk Assignment button. The Bulk Assignment window opens. 

5) Click the Assignment drop-down and choose the assignment. The values listed are the 
same as on the Fund Assignment window for the individual SOV lines. 

6) Click the Update button. 

7) Click Save on the Fund Assignment window to save your changes. 
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Setting Up Schedule of Values (SOV) 

The Schedule of Values (SOV) sheet provides a view of all the following information in one 
Sheet: 

 Purchase Orders (Base Commits) 

 Change Orders (Change Commits) 

 Payment History (Pay App) 

The system supports the following types of SOV: 

 General Spends 

 Payment Applications 

 Summary Payment Applications 

The needed SOV type is designed in uDesigner. 

The data for the SOV sheet comes from the following BP types: 

 Base Commit 

 Change Commit 

The business processes can be designed to create an SOV sheet automatically upon reaching 
the designated step. 

When line items are added to the SOV sheet, the order of line items in the sheet is based on the 
time line that the line items were rolled up from the Base Commit and Change Commit records. 

The data seen in the SOV sheet is based on the order in which the SOV lines were created. You 
can use the numeric column to sort the data based on the number that you specify. 

When a Base Commits Business Process (BP) is approved, it creates a Schedule of Values 
(SOV) sheet. The SOV sheet is the "working document" on which committed monies are 
entered. The committed monies shown on the SOV sheet are rolled up to the Company Cost 
Sheet. 

Note: The Change Commits BPs continue to change or add costs to the 
SOV during the life of the Project/Shell. 

The Schedule of Values (SOV) functionality provides a way to assemble information from 
contract, change order, and invoice/payment BPs into a SOV sheet, streamlining the process of 
invoicing for completed phases of a Project/Shell. 

SOV functionality is available for Cost type BPs in which the Allow creation of Schedule of 
Values option is defined, or selected, in the design properties. The BPs can be designed to 
create an SOV sheet automatically upon reaching the designated step. 

You may define one SOV sheet per Commit BP, for example, a Purchase Order or a Contract. 
Rows are automatically populated based on the CBS/Cost/Accounts codes defined in the 
Commit BP. 

Before you can create an SOV: 
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 Design Commit type BP in uDesigner and deploy. 

 Configure and set up commit BP. 

SOV functionality is available with commit BPs, for example a Purchase Order for which the 
Create SOV option is selected in uDesigner. For these BPs, the system automatically 
creates a SOV sheet upon reaching the designated step. There may be one SOV sheet per 
Commit Business Process. Rows are automatically populated based on the CBS/Account 
Codes defined in the Commit BP. 

 Create and set up the Project/Shell Cost sheet. 

How to Set Up SOV 

Before you begin

Base Commits and Change Commits Business Processes must be set up for the Project/Shell. 

Step 1: Create and set up SOV template (General Spends only) 

You can create a template in the Templates log in Admin mode. If you are using General 
Spends SOV, the structure that will be used for the SOV sheets is created from the template. 

Note: You can define a General Spends SOV structure by copying from 
an SOV template in the Templates log. 

Step 2: Set up SOV Structure (User mode) 

a) SOV Sheets are created, either manually or automatically, from Base Commits, based on 
the structure that is set up in Step 1. 

b) For General Spends SOV, the SOV structure is copied from an SOV template. 

c) For Payment Application SOV and Summary Payment Application SOV, the structure is 
copied from the line item grid structure of the Payment Application Business Process. This 
means that you must first complete the Business Process (BP) setup for the Payment 
Application BP before you can create the structure. 

Step 3: Create SOV Sheets

You can create General Spends, Payment Applications, and Summary Payment Applications 
SOV structures in project templates.  

Creating an SOV Template 

An SOV Template needs to be created and set up before you can create a SOV sheet. SOV 
sheets are created using an SOV Template that defines the columns that will appear on the 
SOV sheet. 
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Note: All SOV sheets in a single Project/Shell will use the same template 
structure. 

If an SOV Template does not exist when an SOV sheet is auto-created from a Cost type BP, one 
will be created automatically with the default columns CBS Code and CBS Item and Breakdown 
Data. You can edit this structure as needed, but the default columns are not editable. 

To create an SOV Template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > Projects to expand it. 

3) Click [shell template] > Cost Manager > Schedule of Values > Payment Applications. 

4) From the toolbar, click Update Structure to open the Payment SOV Structure window. 

5) From the menu, click File > Properties to open the Properties window. 

The Properties window has two tabs: General and Options. 

6) In the General tab, enter values in the Name and Description fields. 

7) Click the Options tab. 

Use the Options tab to define the labels (Labels block) that will be used for the SOV column 
headings. 

The fields listed in the Labels block are the name of labels that are displayed as column 
headings on the SOV sheet. 

You may change the labels or accept them as is. 

For clarity, consider using the same labels as is used in the Cost Template and Cost sheets. 

8) Read the following and when finished click Apply and then OK. 

The following explains how to set up the fields in the Properties window, Options tab: 
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Field Description 

Item # Applicable to both Company level 
templates and Project/Shell level 
templates. 

 At the Project/Shell level: Company 
Workspace tab > Admin mode > 
Templates > shell templates > Cost 
Manager > Schedule of Values > 
Payment Applications. 

 At the Project/Shell level: Company 
Workspace tab > Admin mode > 
Templates > shell templates > Cost 
Manager > Schedule of Values > 
Summary Payment Applications. 

 At the company level: Company 
Workspace tab > Admin mode > 
Templates > General Spends SOV. 

The Item # field is a system-defined 
column, with a fixed location on the 
screen, and it is not available in the 
column structure window. 

You can change the Item # column name 
in the SOV properties page.  

Ref Refers to a reference number for the entire 
commit. (Another example of a label for 
this column is "Order Number.") 

CBS Code This field is not editable. 

CBS Item This field is not editable. 

Breakdown The CBS Code Breakdown that you 
specify in the CBS Detail window for that 
code. 

Description This label refers to the line item description 
when the SOV is in line item mode. 

The Schedule of Values node, under Project/Shell templates, contains the following sub-nodes: 

 General Spends 

 Payment Applications 

 Summary Payment Applications 

The Summary Payment Applications sub-node lists the Business Processes (BPs) of the 
Summary Payment Applications SOV sheets that have been configured in the template. 
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You cannot define the structure if a Base Commits or Change Commits BP of Summary 
Payment Applications SOV sheet is not configured in the template. 

You can define one Summary Payment Applications SOV type template for every Base Commits 
of Summary Payment Applications SOV type BP. 

If the Summary Payment Applications SOV sheet is configured in the Project/Shell templates, 
you can select columns from the Data Elements that are defined on the Detail form of the 
Summary Payment Applications SOV sheet, and the Base Commits.  

Add SOV Columns 

Columns determine what data is displayed on the SOV sheets. You can add, modify, delete, 
hide/unhide columns on the structure. Any modifications you make on the structure will be 
reflected on all SOV sheets for that project or shell. Columns can be added to the SOV Template 
or Structure. Each column represents a data source. At a minimum, include a column for 
Commits Remaining Balance to enable validation of Spends against the Commits.  

Note: This information is applicable to adding or editing columns in an 
SOV template or structure. 

To add an SOV column 

1) Open the SOV template or structure. 

2) Click the Columns button. The columns log opens. 

 The three default columns (CBS Code, CBS Item, and Breakdown), for the General 
Spends and Payment Applications, are not editable and do not appear in the log. 

 The default columns (Cost Code, Code Name, Cost Line Item Type, and Description), for 
the Summary Payment Applications, are also not editable and do not appear in the log. 

3) Click New. The Column Properties window opens. 

4) Complete the Column Properties window and click OK. 

In this field: Do this: 

Name 

The name you choose will appear as the 
column header. You may manually enter a 
column name, or, if you leave the Name 
field blank, the selection you make in the 
Datasource field will automatically 
populate the Name field. 

Datasource All columns must be associated with a 
data source. The data source that you 
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In this field: Do this: 

choose will determine which of the 
following options are available.  

Single Sources 
These values roll up from single defined 
sources, including business processes. 

Logical Sources 

The options are: 

 None: Lets you manually configure the 
column as a manual entry or formula 
column to suit your needs. 

 Commits Remaining Balance: 
Commits Remaining Balance is a 
column on the SOV 
Template/Structure. It reflects the 
amount of your commits minus the 
spends, according to a formula you 
define. 

 Scheduled Value: This is a formula 
column can be used to keep track of 
the remaining SOV balance. (Example 
formula: Base Commit (Approved) + 
Change Commit (Approved) - General 
Spends Invoice (Approved)) 

Note: Be sure to add a Scheduled Value
column to the SOV sheet if you will be 
doing commitment level funding.  

Entry Method 

This is applicable for logical data sources. 

 Manual Entry: Choose Direct Entry 
into Cell to allow entry directly into the 
cell, or Line Item Content to allow data 
entry through a line item window. 

 Formula: Values are calculated based 
on a specified formula entered for the 
column. Formulas can include the 
values of other columns. Click the 
Create button to create the formula. 

Data Format 

Applicable for Manual Entry or Formula 
columns: 

 Currency: right-aligns column contents 
and includes a currency symbol, 
formatting the value to the specified 
currency for the sheet. 

 Percentage: right-aligns the contents 
and includes a percentage symbol 
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In this field: Do this: 

Display Mode 

Refers to whether the column is displayed 
on the cost sheet. 

 Show: The default choice. This 
indicates that column will display by 
default on the cost sheet to all users 
with at least "view" permission for the 
cost sheet. 

 Hide: Hidden columns are active but 
not displayed on the cost sheet. 
Hidden columns can be accessed by 
users with "create" permission on the 
cost sheet. 

Column Position After 
The new column will be inserted after the 
column selected 

Allow sub-breakdown with validation 

If this option is selected, the sum of 
breakdown amounts is validated against 
the CBS summary amount. That is, the 
sum of the breakdowns cannot exceed the 
amount of the CBS code itself. 

Deleting Schedule of Values 

This section describes how to delete a Schedule of value-based record from a specific shell 
template. 

Note: You can delete a Schedule of value-based record from a specific 
shell template but not from other Projects/Shells that have been created 
using the template. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell type]  > [shell template] > Cost 
Manager > Schedule of Values > Payment Applications. 

3) Select a schedule of value-based record for deletion. 

4) Click Delete. 

5) When the prompt appears that asks you to confirm deletion, click Yes to delete the schedule 
of value-based record. 

Setting Up Cash Flow 

The Cash Flow module lets you generate and compare Baseline, Actuals (or "spends"), 
Portfolio, Forecast, Derived, and Custom curves in a project or CBS code-based shell. The 
curve detail levels include: 
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 Cash Flow by Project/Shell

You can track the costs associated with an entire Project/Shell over time. 

 Cash Flow by CBS

The creation of a CBS detail curve is similar to cash flow by Project/Shell. Use this option if 
cash flow needs to be tracked at the CBS level as opposed to the Project/Shell level, by 
allowing you plot cash flow curves by specific CBS codes, or all codes, in the Project/Shell. 

 Cash Flow by Summary CBS

The creation of a Summary CBS detail curve is very similar to cash flow by CBS. Use this 
option if cash flow needs to be tracked by summary CBS codes. In order to select this option, 
the Project/Shell cost sheet must use a tree structure (and therefore has summary CBS 
codes) rather than a flat structure. 

 Cash Flow by Commitment

This option allows you to plot and analyze cash flow data for an entire commit record 
(including base commit, any change commits, and related invoices). You can choose a 
specific business process commitment record within the Project/Shell, such as a purchase 
order or contract, and track the cost information over time. Each commitment record can 
have one baseline curve. 

The system displays Cash Flow curve detail level data in a Cash Flow Worksheet. The cash 
flow curve worksheet can display any number of Baseline, Forecast, Actual (or Spends), 
Portfolio Budget, Derived, or Custom curves (based on the same detail level). Depending on 
curve set up, you can manually enter data, pull data automatically from other sources such 
as business processes, cost sheet columns and schedule manager dates (depending on the 
curve type), and compare multiple curves. 

At runtime, the user can view the cost distribution information by CBS code from a schedule 
sheet.  

To facilitate creation of cash flow curves and roll up of data to company cash flow worksheets, 
you can create the following in Admin mode: 

 Data Sources

 You create data sources that can be used to create and identify cash flow curves, and 
roll up data to company worksheets. You will need to create data sources in order to 
create cash flow curves. 

 Data sources are created based on a Curve Type: Baseline, Forecast, Actual (or 
Spends), Portfolio Budget, Derived, or Custom curves. Each curve type has its own logic 
to address different business requirements. 

 Distribution Profiles

These are optional. Distribution profiles can be applied to cash flow curves to automatically 
distribute cost data across a specified time period. At runtime, you will have the option of 
manually distributing data in the cash flow worksheet, or automatically distributing the data 
using one of these profiles. 

 Company-level Templates

These are also optional. You can create cash flow detail curve templates, which can be used 
to create curves at runtime within a project and shell. 
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 Project/Shell-level Templates

You can create cash flow curves within a project template or a CBS-code based shell 
template. These can be used to create curves in projects or shells; they can also be used to 
"push" out updates to existing curves. For more information, see Update Cash Flow 
Properties and Permissions. 

How to Set Up Cash Flow 

Here is an overview of the steps required to set up the cash flow module. 

Note: There are two Cash Flow modules: the module in effect prior to 
the 9.3 release is called Cash Flow (Basic); the module introduced in 9.3 
and discussed here is named Cash Flow. Each module has its own User 
and Admin mode permissions. 

Step 1: Grant yourself permissions to configure the cash flow modules.

Step 2: Create custom cash flow data sources. These are used to create curves in projects 
and shells. You also define a color for each data source, which will display as the curve color on 
the cash flow graphs. See Creating Cash Flow Data Sources. 

Step 3: Create distribution profiles. These profiles can be used to distribute cost or any value 
over a period of time. See Distributing Cost Data. 

Step 4: Create cash flow templates. You can create any number of cash flow templates at the 
company level, or create cash flow curves within a project/shell template. Setting up cash flow 
templates is essentially the same as creating the curves manually in a project or shell (or a 
project/shell template), with some exceptions that are mentioned in the setup procedure details. 
You can use company-level and project/shell level templates to quickly create cash flow detail 
curves and rollup curves in projects and shells. See Cash Flow Curve Templates. 

Step 5: Create cash flow in a project or shell. You can create any number of cash flow curves 
in a project or shell. These can be detail level or rollup curves. You can create them manually, 
by copying an existing curve, or by copying a template, see Cash Flow in the Unifier Managers 
User Guide. 

Step 6: Create cash flow in a  company. You can create rollup curves in the company 
workspace (Company Workspace tab), and roll up cash flow data from projects/shells. See 
Create Roll-up Templates. 

Step 7: Grant cash flow permissions to users.

Grant Yourself Permissions to Configure Cash Flow 

You must grant permission to yourself, another administrator, or group such as Company 
Administrators, to configure cash flow modules. 

To grant yourself configure permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, expand the User Administration grouping node and click Access 
Control. 
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3) On the right pane, select Administration Mode Access > Standards & Libraries > Cash 
Flow > Data Sources. 

4) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 

6) Select the user(s) to whom you want to give configuration permission and click the Add
button. Then click OK. 

The system adds the name(s) to the Permission/Access Control window. 

7) Under Permission Settings, select Modify and View and click OK. The system adds the 
name(s) to the Permission Settings window. 

8) Repeat these instructions to grant permission to cash flow Distribution Profiles and cash flow 
Templates. (Give these modules Create permission.) 

9) Click OK. 

Create a Cash Flow Distribution Profile 

You can create profiles manually or by copying an existing profile. 

To create a distribution profile manually 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Cash Flow > Distribution Profiles. The 
Distribution Profiles log opens. 

The default Distribution Profiles record displays in the log. All profiles are stored in this 
record. 

3) Select Distribution Profiles in the log and click Open (or double-click Distribution Profiles). 
The Edit Distribution Profiles window opens. 

The left side of the window displays the list of the distribution profiles. The right side of the 
window displays a graphical representation of the profile and is used to define it. 

4) Click the New button. This adds a new row to the Distribution Profiles list. 

5) Enter a unique Name for the profile (up to 30 characters). 

6) Be sure the Active check box is selected if you want it to be available for cash flow curves. If 
you deselect this check box, the profile will not be available for selection on curves. 

7) Define the distribution profile on the graph by entering values in the Profile % slots. 

By default, when you create a distribution profile, the graphical display will be a linear 
distribution. (5% is entered into each of the 20 slots: 5% x 20=100%.) You can modify this 
profile by entering a value for each slot for the Profile %. The graph will reflect the values that 
you enter. 

You can enter values with up to two decimal places per slot. Press the Tab key to move one 
slot to the next. The total of all the slots for the Profile % must add up to exactly 100%. 

8) When the distribution profile is complete, click the Save button. 

To create a distribution profile by copying an existing profile 

1) In the Edit Distribution Profiles window, select a profile and click Copy. A new row is added, 
and the selected profile information is copied. 
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2) Enter a new Name for the copied profile. Make any changes to the profile values as needed 
and click Save. 

Note: Per design (for example, in a Front Loaded Distribution Profile), if 
the Profile % reaches 100% before the 20th bucket (the zero is 
displayed at this point), and there is still unallocated budget remaining, 
when a Cash Flow Forecasting is linked to the Spends, the remaining 
unallocated budget will not be automatically distributed to the buckets 
with zeros. 

Delete a Distribution Profile 

You can delete distribution profiles as long as they are not currently being used in the system. If 
a distribution profile is being used, you can delete it as long as you replace it with another profile 
first. This is explained in the following procedure. 

To delete a distribution profile 

1) Open the Distribution Profile window. 

2) Select one or more profiles from the list on the left. Press the Ctrl or Shift key to select 
multiple profiles. 

3) Click the Delete button. 

 If the profiles you selected are not currently being used by the system, a warning 
message opens. Confirm that you want to delete the profiles by clicking Yes. 

 If you selected multiple profiles and one or more of them are being used by the system, 
an error message opens displaying the profiles currently in use. 

 To delete a profile that is currently in use, go to Step 4. 

 Close the error window. 

 You can delete the profiles that are not in use by selecting them again from the 
Distribution Profiles window and clicking Delete. 

4) If you select a single profile that is being used by the system, you will be prompted to replace 
the profile with another profile. 

 The Select a Distribution Profile window opens. 

 Click the Select button and select a new profile from the list. 

 Click OK. The profile being deleted is replaced with the profile selected in this window. 
When the curve using the profile is refreshed at runtime, the new profile will take effect. 

Edit a Distribution Profile 

You can edit a distribution profile. The change will take effect in curves that use the profile the 
next time the curve is refreshed. 

To edit a distribution profile 

1) Open the Distribution profile window. 

2) On the left side of the window, select the distribution profile to edit. 
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 You can edit the profile Name. If the profile is used by a curve, the name change will be 
reflected in the curve Properties. 

 You can select or deselect the Active check box. Active profiles are available for 
selection when choosing a default profile for auto distribution. Inactive profiles will not 
show up on the selection list. If you inactivate a profile and a curve is already using it, the 
curve will not be affected; it will still use the profile. 

 On the right side of the window, you can change the Profile % values. Change will be 
reflected in curves that use the profile when the curve is refreshed. 

3) Click Save to save the changes. If the profile is being used by one or more curves, the 
profile change will take affect the next time the curves are refreshed. 

Creating Cash Flow Data Sources 

You can add multiple curves to a cash flow worksheet so you can view and compare curves side 
by side. These curves are based on the data sources you add here. 

Each data source is used to identify one of the curves on a worksheet, and therefore can be 
used once per worksheet. However, you can reuse the data sources on different worksheets. 
You can create as many data sources as you need to create cash flow curves. 

When you create a data source, you associate it with a Curve Type. Each curve type has a 
built-in logic when creating the curve using the data source. The curve types are: 

 Baseline

Choose this to create a Baseline curve. You can choose to manually enter the cost data, or 
automatically pull the data from a cost column, such as a Budget. 

 Forecast

Choose this to create a curve that helps forecast future cash flow based on actual spends 
records. 

 Actuals (Spends) 

Choose this to plot spends data over time. 

 Portfolio Budget

Choose original or shared option to create a Portfolio Budget curve. 

 Derived

Choose to create a Derived curve. 

 Custom

You can create Custom curves that you can use to enter data, or to compare against other 
curves. The setup is similar to the Baseline curves. 

To create a Cash Flow data source 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Cash Flow > Data Sources. The Data 
Sources log opens. By default, there is one Data Sources record displayed in the log. All 
data sources are stored in this record. 

3) Select Data Sources in the log and click Open (or double-click Data Sources). The Edit Data 
Source window opens. 
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4) Click the Add button. This adds a new row to the window. 

5) Enter a Name for the data source. The name must be unique and not exceed 30 characters. 

Press the Tab key to move to the next field. 

6) Select a Curve Type from the drop-down list: Baseline, Forecast, Actual (or Spends), 
Portfolio Budget, Derived, or Custom curves. 

You can make your selection by clicking the field and selecting from the list, pressing the first 
letter of your selection on the keyboard (for example, press the B key to select Baseline), or 
you can use the arrow keys on your keyboard to browse the list and make your selection. 

Press Tab to move to the next field. 

7) Select a Color. 

This color will be used on the cash flow graph at runtime when a curve is generated from the 
data source. There are 256 colors (including "0" for black) to choose from. 

Like the Curve Type field, you can click the field and select from the list; press the arrow keys 
to browse the colors; or, if you know the number of the color that you want, you can type it 
directly then press Enter. 

8) To rearrange the data sources, select on the list and click the Move Up or Move Down
buttons. This is the order in which the data sources will be presented when a user creates a 
curve. 

9) Click OK to save and exit the window. 

Delete a Cash Flow Data Source 

You can remove a data source from the list only if it is not being used by any cash flow curves. 

If a data source is in use and you want to delete it, you must first delete any curves using it 
(these are the curves defined in the cash flow Properties window, Curves tab). 

To delete a cash flow data source 

1) Open the Edit Data Source window. (In Admin mode, navigate to Standards & Libraries > 
Cash Flow > Data Sources. Double-click Data Sources.) 

2) Select the data source to delete and click the Remove button. The row is deleted. 

3) Click OK to save and exit the window. 

Edit a Cash Flow Data Source 

You can edit the data source color, which changes the color of the curves using the data source. 
You can also change the row order, which changes the order that data sources appear on the 
selection list when creating a curve. 

Notes: 

 Curve Type is not editable. 

 The data source name can be changed, but use caution when doing 
so. If you rename a data source, the curves that use the data source 
will not recognize the new name, and the data will not be visible on 
the curves. If you change the name back to the original name, the 
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data will appear again on the curves. 

To edit a cash flow data source 

1) Open the Cash Flow Data Sources (Cashflow Datasources) window. 

2) You can make changes as necessary, based on the information. 

3) Click OK to save and exit the window. 

Distributing Cost Data 

When you create a cash flow curve, the system distributes cost data using the distribution 
method defined in the cash flow curve properties. Distribution can be either manual, or automatic 
from a defined profile. 

In User mode, the system displays commitment curve cost data in the record transaction 
currency, but stores costs in project currency. Currency conversion uses the active exchange 
rate set. 

 Baseline curves use the exchange rate that was active at the time of record creation.

 Actuals curves use the exchange rate that was active at the time the money was paid.

 Forecast curves use the exchange rates in effect for each time period over the 
duration of the curve.

If the transaction currency is different from the project currency, you can change the currency 
view between transaction and project currencies. You can only edit data in the transaction 
currency view. If there is a more recent value in the exchange rate table, refreshing the curve will 
refresh the cost data. You will not see the currency menu if the business process record was 
created in the project currency. 

Manual distribution 

When you select manual distribution in the curve properties, you manually enter the data for 
distribution in the curve details window at run time. The system preserves cost distribution and 
duration when you change the From Date (start date) of baseline, custom, and forecast curves 
(when there are no actuals) in project/shell, summary CBS, and CBS detail curves. In other 
words, if you change a cash flow curve to start on a different date then it originally did, the 
system shifts the curve along the timeline to reflect the new date and moves the cost data to 
retain the integrity of the curve. The system pegs the distribution of cost data to the From Date, 
rather than the end or To Date. Here is how this works when the From Date changes: 

 If the modified curve is the same length as the original curve, the curve shifts along the 
timeline to reflect the new start date and all cost data remains in the curve. 

 If the modified curve is longer than the original curve, the curve will shift along the timeline to 
reflect the new start date, but existing data is not redistributed to the additional time periods. 
Each time period retains its original value and additional columns have values of zero. 

 If the modified curve is shorter than the original curve, then the curve will shift along the 
timeline to reflect the new start date, and existing data is truncated at the new end date. 
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Auto by default profile distribution 

A distribution profile lets you predefine the way you want the system to distribute cost data in 
User mode. You can add any number of profiles in the Edit Distribution Profiles window. 

The left side of the window contains: 

 A list of previously created distribution profiles. Initially this list is empty. 

 The Active check box, which controls whether the profile is available for selection for a curve. 

The right side of the window contains: 

 Graph: The graph is a graphical representation of the profile % that you enter over the 
duration %. 

 Duration %: These are the x-axis units of the graph. The x-axis starts at zero (0), with 
another 20 slots, equally distributed up to 100%. 

 Profile %: Starts at 0, with 20 remaining slots to enter the profile distribution percent values. 
You will enter incremental values in these slots. The total value of the profile % must add up 
to 100%. You cannot enter negative numbers in these slots. The values you enter will 
determine the shape of the curve, and distribution of the data. 

By default, when you create a distribution profile, the graphical display will be a linear distribution 
(5% is entered in each of the 20 data slots). 

Following are some distribution profile examples. 

Cash Flow Curve Templates 

You can create cash flow curve templates that can be used to create cash flow curves in 
projects and CBS-code based shells. If you are using company-level cash flow, you can create 
roll-up curve templates. See Create Roll-up Templates (on page 435). 

Template creation methods are manual or involve copying an existing one. After creating a 
template, you can set refresh frequency and activate or deactivate curves. 

Creating and setting up a template is essentially the same as setting up the curves manually in a 
project or shell. The major difference is you cannot select individual records in the template; 
these must be chosen from within the projects or shells. See Cash Flow Curves in the Unifier 
Managers User Guide. 

The detail curve creates a worksheet in the project or shell that can include several curves. You 
can create detail curves and detail curve templates at the following detail levels: 

 Cash flow by project or shell: You can track the costs associated with an entire project or 
shell over time. 

 Cash flow by CBS: The creation of a CBS detail curve is similar to cash flow by 
project/shell. Use this option if cash flow needs to be tracked at the CBS level as opposed to 
the project or shell level, which lets you plot cash flow curves by specific CBS codes, or all 
codes, in the project or shell. 
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 Cash flow by Summary CBS: The creation of a Summary CBS detail curve is very similar 
to cash flow by CBS. Use this option if cash flow needs to be tracked by summary CBS 
codes. To select this option, the project/shell cost sheet must use a tree structure—and 
therefore has summary CBS codes—rather than a flat structure. 

 Cash flow by commitment: This option lets you plot and analyze cash flow data for an 
entire commit record (including base commit, any change commits, and related invoices). 
You can choose the specific business process commitment record within the project/shell, 
such as a purchase order or contract, and track the cost information over time. 

 Note: You can set up the automatic creation of a cash flow curve 
when a base commit record is created and completed or reaches a 
particular step. This is done in the BP Setup for the business 
process. For more information, see Setting up Auto-Creation of 
Cash Flow Curves from Contracts (on page 302). 

To create a cash flow detail level curve in a template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, do one of the following: 

 To create a detail curve in a project or shell template, click Templates. Open the project 
or shell template, then click Cost Manager > Cash Flow in the Navigator. This cash flow 
model can be copied during project or shell cloning. 

 To create a template, click Standards & Libraries > Cash Flow > Templates. This is a 
template users can select at run time. This option is available in Classic view only. 

The Cash Flow log opens. 

To create a cash flow detail level curve in a template from Templates 

1) Click Create. The New Cash Flow Worksheet window opens. 

2) Fill out the General block of the form by defining the name, description, and detail level. 

3) Configure the additional options as needed: 

 Filter CBS Codes or Filter Summary CBS Codes

 Rollup cashflow data to company?

 Time Scale: Set the period type, choose by month or by year, and set the format of the 
curve dates.If you select Financial Period, for a project or shell template, you can define 
the Cutoff Spends and the snapshot date in the Period Close Settings for cash flow 
curves by Project, by CBS, and by Summary CBS for the shell templates.  

4) Add curves in the right pane. Select a curve type from the drop-down list and fill out all fields. 

5) Click Save & Close when finished.  

To create a cash flow detail level curve in a template from Standards & Libraries (Classic 
view) 

1) Click the New button. The Properties window opens. 

2) Fill out the following tabs, and click OK when finished. 

 General tab: Define the name, description, detail level, time scale and period close 
settings. 
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 Curves tab: Define individual curves (Baseline, Forecast, Actual (or Spends), Portfolio 
Budget, Derived, and Custom curves) that will be part of the group of curves that make 
up the cash flow detail curve. 

 Filters tab: Limit the cash flow data on your curve to a particular set of CBS codes or (if 
the cost sheet is tree structure) summary CBS codes. If you do not specify a filter, then 
all codes will be used for the data. 

 Options tab: Define the format to use for the numbers displayed on the cash flow 
worksheet. 

 Schedule tab: Enable automatic refresh of the cash flow curve, and set the refresh 
schedule. 

 Summary tab: A Summary Cash Flow Curve displays selected cash flows from your 
project. 

Create Roll-up Templates 

Use roll-up curves in the company-level Cost Manager to roll up cash flow data from all 
projects/shells in which cash flow is being used. You can create roll-up curve templates and use 
the templates to create the roll-up curves.  

To create a roll-up template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Cash Flow > Templates. The Cash 
Flow Standard Templates log opens. 

3) Click New. The Properties window opens in the General tab. 

4) In the General tab, set the Rollup Status to Active. If the status is active, data can be rolled 
up from project and shell cash flow curves. 

The rest of the process is similar to the setup of other detail curves through the Standards & 
Libraries grouping node. See Cash Flow Curve Templates (on page 433). 

Setting up the Rules Engine 

Rules constrain the sending of cost-type business process records, and affect making changes 
to Cost and Funding sheets. That is, they give some control over costs by helping you to enforce 
cost constraints. For example, you could create a rule that prevents invoices from exceeding a 
contract budget. 

As the administrator, you can create rules and rule templates. Rules can be created at the 
project or shell level or company level. Rule templates can be created for project- or shell-level 
rules. 

You will be using a formula to create a rule, much as you use formulas to create field values. 
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About Rules 

A rule is triggered when a user attempts to "send" a business process record to the next step 
whose status activates the rule. For example, the rule may be designed to activate when a 
record gets to the Pending or Approved status. A rule can prevent the record from proceeding to 
the next step if doing so will violate the rule. Rules affect how users can work with: 

 Funding sheets (at project or shell or company level) 

 Project/Shell Cost sheets 

 Schedule of Values 

When you create a rule, you can designate specific groups or users who can override the rule 
exception. 

When a rule violation occurs, the system displays a "Rule Exceptions" window. 

If the user has override control, they can click Override to ignore the rule exception, or Cancel to 
accept the rule and remain on the step. If the user clicks Override, the system will ignore the rule 
exception and send information to the audit log about the override transaction. 

Rule exceptions can be triggered by: 

 Adding or copying a line item on the Cost Sheet 

 Copying data from one column to another on the Cost Sheet 

 Entering data directly into a cell on the Cost Sheet 

 An email action that sends cost data to the sheet 

 An integration transaction that sends cost data to the sheet 

 I-Step and S-Step business process auto-creation 

 A business process record that rolls up cost data to the sheet 

Note: The system does not display a Rule Exception window if the rule 
validation is triggered from an email action, or integration. If the user has 
override control, the system will assume the user wants to override the 
rule exception and sends the override information to the audit log. 

About Control Sources and Levels 

When you create a rule, you choose the control source (that is, whether the rule will affect cost 
or fund transactions), and the rule level (what the rule will enforce). 

Control Source 

In projects or shells, you can create rules for cost (choose Project Cost as the control source) 
or funding (choose Project Fund as the source). At the company level, you can create rules for 
funding (the control source is Company Fund). 



Setting up the Cost Manager

437

Note: "Commit" refers to a commit business process, such as a 
purchase order, and also would include change commit business 
processes if specified in the rule; additionally, the term "budget" can 
mean any cost sheet data source being validated against with the rule, 
which is usually, but not necessarily, budget-related. 

Rule Levels 

Project Cost: Rules with Project Cost as the source provide validation to business processes 
that affect project or shell cost sheets. Rule levels are: 

 Per CBS: These rules provide control per CBS code across the project or shell budget. For 
example, if you have an assigned budget amount for specific CBS codes, you can create 
rules that check all commit business processes (and change commits if specified) to verify 
that those assigned budget amounts, per CBS code, are not exceeded. 

Note: If a business process record has several line items, even if only 
one of the line items will violate the rule, the entire record will be 
rejected. 

 Per Total for Entire Project: This rule looks at the total, cumulative amount of commit 
business processes and verifies the total against the project or shell budget (or another 
parameter that you choose). This type of rule can ensure that the project or shell budget is 
not exceeded, but does not verify specific CBS code or funding amounts. 

 Per Fund within each CBS: Applicable if the project or shell includes funding at the CBS 
level. The rule will validate the amount being charged on the commit business process 
record for each CBS code against the assigned fund amount per CBS, as specified in the 
fund information on the cost sheet. 

 Per CBS within each Commit: Related to SOV. For example, the rule can validate that the 
total amount of a purchase order and related change orders will not exceed a certain amount 
for a specific CBS code. 

 Per selected Summary CBS Codes: Lets you select one or more summary CBS codes on 
which to enforce the rule. This option is applicable when the cost sheet has a tree structure; 
cost sheets with flat structures do not have summary codes. You can choose to enforce the 
rule on each summary code individually, or on the total of the selected codes. Because you 
must select summary CBS codes from the cost sheet for this rule, this option is not available 
in rule templates; it is available for rules within project templates and shell templates, and 
within projects and shells. 

 Per selected CBS Codes: Lets you select one or more "leaf" level CBS codes (that is, 
codes that are not summary codes) on which to enforce the rule. You can choose to enforce 
the rule on each code individually, or on the total of the selected codes. This option is 
applicable for cost sheets with a tree or flat structure. Similar to the previous option, this is 
available in rules within project templates and shell templates, and within projects and shells, 
not in rule templates. 

Project Fund: This control source option provides validation to business processes that affect 
project or shell funding sheets. Rule levels are: 

 Per Fund: These rules provide control per fund per project or shell, similar to "Per CBS" 
above. 
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 Per Total for Entire Project/Shell: Provide control over entire funding amount for the 
project or shell, similar to cost rules. 

Company Fund: Company level rules can be created for company funding sheets: 

 Per Fund: These rules provide validation against the total amount of each fund, regardless 
of project or shell distribution. 

 Per Total of all funds: Provides validation for the total of all funds available to the company. 

Access a Rule or Rule Template 

To access a rule or rule template 

Rules can be created and accessed in the following logs in Admin mode: 

 Company Workspace node > Rules

 Company > Templates > Rules

 Project > Rules

 Project Template > Rules

 Shell > Rules

 Shell Template > Rules

Creating Rules and Rules Templates 

All new rules are created in a similar way. You can create rules and rules templates manually or 
by copying from another rule or template. 

Rules can also be added to existing active and on-hold projects and shells by updating 
("pushing") them from a project or shell template using Update Projects or Update Shells. 

Note: In order to start using a rule after it has been created, it must be 
validated and activated. After creating rules, see Validating and 
Activating Rules (on page 443). 

Create a Rule Template 

You can create a rule template, or a rule within a project or shell template. By default, rule 
templates remain inactive; the Validate, Activate and Deactivate buttons on the toolbar are 
disabled. Rules within project and shell templates can be validated and activated. 

You can create a rule manually or by copying an existing rule. If you create a rule within a 
project or shell template, the rule can be "pushed" to existing projects or shells. 

To create a rule template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click one of the following: 

 Company Workspace > Rules

 Templates > Rules

 Templates > Shells > [shell] > [template] > Rules
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Note: At the Template > Shells level, you can create rules only for CBS 
shells, not generic shells. 

3) Click New. The Create a New Rule window opens. 

4) Select the Control Source and Rule Level. 

Note: For details on choosing the source and level, see About Control 
Sources and Levels (on page 436). 

5) Click OK. The Edit Rule window opens. 

6) Use the information in the first table below to complete the fields on the General tab. 

7) Click the Rule tab and complete the fields using the information in the second table below. 

8) In project or shell templates, if you chose "Per selected CBS Summary Codes" or "Per 
selected CBS Codes" as the rule Level, then the CBS Codes tab appears in the Edit Rule 
window. See the following procedure for selecting CBS codes. 

9) Click OK to save and close the Edit Rule window. 

In this field: Do this: 

Name Enter a name for the rule. 

Description Enter a description of the rule. 

Control Source 
The system displays the control source 
you chose in this field. 

Rule Level 
The system displays the rule level you 
chose in this field. 

Status 
The system displays the current status of 
the rule. 

Users/Groups who can override 

(Optional; appears only at the project and 
shell templates level) 

This option is available only for the 
following rule levels: 

 Per selected summary CBS codes 

 Per selected CBS codes 

Click the Select button and from the picker 
that appears, select the users or groups 
that will be allowed to override this rule at 
runtime. 

If you select this option, the specified 
users/groups should be able to override a 
rule failure condition during a workflow. 
The system will display the name(s) of the 
overriding user(s) and any comments in 
the Audit Log. 

Note: If you use this option, users/groups 
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In this field: Do this: 

can override this rule, even if the data is 
not valid. Also, the users/groups specified 
in this option will be added to the 
project/shell if they do not exist there. 

Notify Users/Groups when overridden 

(Optional; appears only at the project and 
shell templates level) Click the Select 
button and from the picker that appears, 
select the users or groups that should be 
notified if this rule is overridden. 

In this field: Do this: 

Limit Expression 

This defines the Upper Limit that the rule 
validates against and is static. For 
example, for cost rules, this might be the 
Assigned Budget, or can include the sum 
of several budget-related data sources on 
the cost sheet. 

Click the Formula button. The Formula 
Creation window opens. The data source 
list includes all available cost sheet data 
sources for cost-related rules, or funding 
sheets data sources for fund-related rules. 
This is the value on the left of the 
Condition. Pending positive values are not 
considered. 

Note: The system identifies the 
non-terminal documents as pending. 

Include positive pendings in calculation 

Deselected by default. 

When this option is selected (checked) by 
the user, the system will consider positive 
values from non-terminal records in the 
Limit Expression formula calculation. 

When this option is deselected by the user, 
the system will ignore positive values from 
non-terminal records in the Limit 
Expression formula calculation.  

Condition 

The option "greater than or equal to" is the 
only selection available. Rules always 
check that the "Upper Limit" (Limit 
Expression) is greater than or equal to the 
amount calculated by the Data Expression.
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In this field: Do this: 

Data Expression 

This is what is being validated. For 
example: 

Purchase Order (Pending) + Purchase 
Order (Approved) + Change Commit 
(Pending) + Change Commit (Approved) 

Click the Formula button. The Formula 
Creation window opens. The data source 
list includes all available cost sheet data 
sources for cost-related rules, or funding 
sheets data sources for fund-related rules. 
This is the value on the right of the 
Condition. Pending negative values are not 
considered. 

Include negative pendings in calculation 

Deselected by default. 

When this option is selected (checked) by 
the user, the system will consider positive 
values from non-terminal records in the 
Data Expression formula calculation. 

When this option is deselected by the user, 
the system will ignore positive values from 
non-terminal records in the Data 
Expression formula calculation. 

Show this message when condition is not 
met 

This field is required. Enter a message to 
display to users if the rule condition is not 
met. 

Select CBS Codes or Summary Codes 

To select CBS codes or summary codes: 

1) In the Edit Rule window, click the CBS Codes tab. (This tab is available if you chose "Per 
selected CBS Summary Codes" or "Per selected CBS Codes" as the rule Level.) 

2) Click Add. The CBS Picker opens. 

 If you chose "Per selected CBS Summary Codes," the picker displays the summary CBS 
codes on the sheet. This is only applicable if the project/shell cost sheet uses a tree 
structure. Cost sheets with flat structures do not have summary CBS codes. 

 If you chose "Per selected CBS Codes," the picker displays the "leaf" CBS codes 
(individual, non-summary codes). This is applicable for both tree and flat cost sheets. 

3) Select one or more codes from the picker and click Select. 

To locate the CBS codes you need, you can click the Find button in the CBS Picker. For tree 
structure cost sheets, you can also click Expand or Collapse to help you navigate the code 
structure. 
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After you select the CBS codes, they are listed in the CBS Codes tab. You can add as many 
CBS codes as needed. At runtime, the rule will be applied only to the CBS codes selected. 

Note: Summary CBS codes must all be at the same summary level (that 
is, the same indent level). 

4) For Validation, choose one of the following: 

 Validate total of selected rows: the system will calculate the sum of the selected CBS 
codes and then apply the rule to the total 

 Validate selected rows independently: the system will apply the rule to each selected 
CBS code individually 

5) To remove a CBS code from the list, select it and click Remove. 

6) Click OK to save and close the Edit Rule window. 

Note: If you add a CBS code or summary code to this list and it is later 
removed from the cost sheet, the rule will not be affected. The code will 
still appear on the CBS Codes tab. At runtime, the rule engine will ignore 
the code that was removed from the cost sheet. Similarly, in a tree 
structure, if a summary code is changed to a leaf code (or vice versa) 
after adding it to the CBS Codes tab, at runtime, the rule engine will 
ignore the code that was changed and not create an error. 

Create a Project or Shell Rule 

You can create a rule in a project or shell manually or by copying a rule template or existing rule. 

In addition to these procedures, rules can also be added to existing active and on-hold projects 
and shells by updating ("pushing") them from a project or shell template using Update Projects 
or Update Shells. 

To create a project or shell level rule 

1) Open the project or shell and switch to Admin mode. 

2) In the left Navigator, click Rules. 

3) Click New. Follow the procedure for creating a Rule Template. 

To create a rule by copying a rule template 

1) Open the project or shell and switch to Admin mode. 

2) In the left Navigator, click Rules. 

3) Click the Copy button and select Template. The Copy from Rule Template window opens. 

4) Select a template from the list and click Copy. The Edit Rule window opens. 

You may make edits to the Edit Rule window if necessary. For example, by default, the 
Name will display as "Copy of (name of rule template)," which you may want to change. 

5) Click OK. The new project or shell rule will be added to the project or shell Rules log. 

To create a rule by copying an existing rule 

1) Open the project or shell and switch to Admin mode. 



Setting up the Cost Manager

443

2) In the left Navigator, click Rules. 

3) Select a Rule from the log. 

4) Click the Copy button and select Rule. The Edit Rule window opens. 

You may make edits to the Edit Rule window if necessary. For example, by default, the 
Name will display as "Copy of (name of the copied rule)," which you may want to change. 

5) Click OK. The new project or shell rule will be added to the project or shell Rules log. 

Create a Company Rule 

At the company level, you can create rules for the company funding sheet. You can create rules 
that help you manage you manage each fund, or the total of all funds. 

To create a company level rule 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Workspace > Rules. 

3) Click New. The Create a new rule window opens. 

4) Select the Control Source: Company Fund. 

5) Select the Rule Level: Per Fund or Per Total of all funds. 

6) Click OK. The Edit Rule window opens. 

7) Complete the Edit Rule window as in the Rule Template procedure and click OK. 

Validating and Activating Rules 

Rules must be active before they can take effect. Before activating a rule, they must first be 
validated to make sure there are no conflicts associated with it. Rules within projects and shells 
as well as within project templates and shell templates can be validated and activated. Rule 
templates cannot be activated or validated. 

Validate a rule 

You can validate rules in projects or shells, and company level rules. You can also validate rules 
in project or shell templates to help ensure that they will work in the project or shell, even if you 
do not immediately activate them. Validation is not available in rule templates, because part of 
the validation process involves verifying that the cost or fund sheet is set up and any referenced 
business processes are active. 

It is good practice to validate a rule before attempting to activate it. If you try to activate a rule 
directly, the system will first validate it anyway, but if there is a conflict, you will simply see an 
error and may not be able to assess what the issue is. By validating first, the system provides 
more information if the validation fails. 

To validate a rule 

1) Select a rule from the Rules log. 

2) Click the Validate button on the toolbar. The Validation Results window opens. 

If the validation failed, the errors will be listed in the window. Edit the rule as necessary and 
revalidate. 
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Activate or Inactivate a rule 

You can activate rules in projects or shells, and company level rules. You can also activate rules 
in project or shell templates. In this way, the rules in the projects or shells that are created from 
these templates will be active as soon as the project or shell is active. 

You cannot activate a rule template. 

To activate a rule 

1) Select one or more rules in the Rules log. Be sure that the rules have passed validation. 

2) Click the Activate button. 

To deactivate a rule 

1) Select one or more activate rules in the Rules log. 

2) Click the Deactivate button. 

Manage Rules 

Rules can be accessed in the following logs in Admin mode: 

 Company Workspace node > Rules

 Company > Templates > Rules

 Project > Rules

 Project Template > Rules

 Shell > Rules

 Shell Template > Rules

Rules can also be updated in active and on-hold projects and shells by updating ("pushing") the 
changes from a project or shell template using Update Projects or Update Shells. 

To edit a rule 

1) Select the rule in the Rules log. If the rule is active, you must deactivate it before editing. 

2) Click the Edit button. The Edit Rule window opens. 

3) Make edits as necessary and click OK. 

To delete a rule 

Select a rule from the Rule Log. Click Delete, and then click Yes when prompted to confirm. 

To view a rule audit log 

1) Select a rule from the Rules log. 

2) Click the View menu and choose Audit Log. The Audit Log opens, listing each event 
associated with the rule. The date and time stamp of each event reflect users' current time 
zone as set in their User Preferences. 

3) In the Audit Log, double-click a listed event to view the audit record detail, which details the 
action taken. The details also include the user's current time zone for reference. 
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To print the audit log 

1) In the Audit Log, click the Print button. A PDF file is created. 

2) Do one of the following: 

 Click Open to open the file in Adobe Acrobat Reader. From the Reader window, you can 
view, save, or print the file. 

 Click Save. In the Save As window, navigate to the location in which you want to save 
the PDF file. Open the file in Adobe Acrobat Reader and choose File > Print to print. 

Setting up a Generic Cost Manager 

You can define a Generic Cost Manager to capture cost-related activities for a Generic Shell. 
These include costs like: 

 Rent 

 Lease payments 

 Landscape care 

 Building maintenance and repair 

 Remodel of building interiors 

With this manager, you can capture and view cost transaction information based on a time scale, 
such as quarterly or yearly. Each shell can have one Generic Cost Manager. 

The Generic Cost Manager uses specific Generic Cost business processes and business 
processes with the type Line Items with Multiple Codes as data sources. 

Before you begin. The Generic Cost Manager and the Generic Cost Manager Attribute form 
must first be designed in uDesigner. 

Step 1: Set the permissions for importing the Generic Cost Manager. 

Step 2: Import the Generic Cost Manager. 

Step 3: Import and deploy the Generic Cost Manager Attribute form. 

Step 4: Set template permissions. 

Step 5: Create the Generic Cost Sheet template at the company level. 

Step 6: Create a Generic Cost Sheet. 

Step 7: Work with Generic Cost BPs. 

Step 8: Set up the Commitment Summary Template. 

Note: The name of the Generic Cost Manager you will work with is 
determined by the name given to it in uDesigner. For documentation 
purposes, the manager is referred to as the Generic Cost Manager. 

Setting Generic Cost Manager Permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 
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2) Open the User Administration grouping node and click Access Control in the left 
Navigator. 

3) In the right pane, select Configurable Modules > Generic Cost Manager.

The permissions are: 

 Modify: Allows the user to import configurable modules from uDesigner 

 View: Allows the user to view configurable modules imported from uDesigner 

Import Generic Cost Manager 

To import an asset class into Unifier Production environment, see Importing Configuration 
Packages (on page 619). 

Import Generic Cost Manager Attribute form 

To import and deploy an attribute form into Unifier Production environment, see Importing 
Configuration Packages (on page 619). 

Creating a Cost Sheet Template for a Generic Manager 

You can create a Generic Cost Sheet template to use with the Generic Cost Manager. 

Create a Generic Cost Sheet template 

The name of the template is based on whatever name was given to the Generic Cost Manager. 
You create this template at the company level, and use it in shells that are of the type Generic. 

To create a Generic Cost Sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates> Configurable Modules > Generic Cost Manager in the left Navigator. 

3) Click New to create a new Generic Cost Sheet template. You can create multiple templates. 
The Properties window displays. 

4) In the General tab, enter general information for the template: 

a. Enter a unique Title, which is used to identify the template in the log, and when creating a 
new Generic Cost Sheet from the template. 

b. Enter an optional Description for the template. 

c. Choose a default display mode for the sheet. 

 If you choose Flat, the cost sheet will display the codes (rows) in a flat structure, 
with no indented rows. This is useful if you want to display all codes at once. 

 If you choose Tree, you have the option of creating indented, nested rows, which 
can be collapsed into summary, or grouping, rows. This is useful if you will be 
creating a large amount of rows that can be grouped into categories. You can 
check Expand all codes to expand the row structure by default. 

d. Choose a Default View. The choices are: 

 Current Shell 
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 Current Shell and sub-shells 

 Subshells 

5) In the Segments tab, define the segments of the cost codes that will be created on the sheet 
by choosing the Segment Sources. The segment sources are those that were defined in 
uDesigner. After you click Apply, you cannot add or remove any of the segments. If you want 
to use different segments, you must create a new template. 

6) Click Apply to save changes, or OK to save and exit the window. 

Structure a Generic Cost Sheet template 

After you create the template, you can define the structure by adding rows and columns. 

To add rows to a Generic Cost Sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates> Configurable Modules > Generic Cost Manager in the left Navigator. 

3) Select a Generic Cost Template. 

4) Click the Structure button. The Template Structure Setup window opens. 

5) Click Add Rows. The Generic Cost Code Details window opens. 

6) To form cost codes (rows) click Select next to the Account Code field. 

7) Enter the cost code segments and click OK. 

8) Optionally, enter a code name for the account code. 

9) Select a status (Active or Inactive). 

10) Click Add to add the row and then continue to add rows, or click OK to exit. 

To add columns to a Generic Cost Sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates> Configurable Modules > Generic Cost Manager in the left Navigator. 

3) Select a Generic Cost Template. 

4) Click the Structure button. The Template Structure Setup window displays. 

5) Click Columns. The Cost Sheet Columns window opens. 

6) Click the New button. The Column Properties window opens. 

7) Complete the fields in the Column Properties window as described in the table below. 

8) Click OK when you are done with the column properties. 

In this field: Do this: 

Name 

Enter a column name. The name you 
choose will appear as the column header 
on the sheet. If you leave the Name field 
blank, the selection you make in the 
Datasource field will automatically 
populate the Name field. 

Datasource Choose a datasource. All columns must be 
associated with a data source. The data 



Modules Setup Administration Guide

448

source that you choose will determine 
which of the following options are 
available. The types of Data sources 
available are: 

Single Datasource: These values roll up 
from business processes that have these 
attributes: 

Level: Project/Shell 

Type: Cost 

Sub-Type: Line Items with Multiple Codes 

Configurable Manager: <name of Generic 
Cost Manager> 

Logical Datasource: Generic Cost 
Manager (1-25). 

Entry Method 

Choose an entry method. This is 
applicable for logical data sources. 

Manual Entry: Users enter values by 
clicking the cell and entering values 
directly into the cell. 

Formula: Values are calculated based on 
a specified formula entered for the column. 
Formulas can include the values of other 
columns. Click the Create button to create 
the formula. 

Data Format 

Choose a data format. Applicable for 
Manual Entry or Formula columns: 

Show as percentage: Display the data in 
percentages. 

Decimal Places: Number of decimal 
places to display. 

Display Mode 

Choose a display mode. Refers to whether 
the column is displayed on the cost sheet. 

Show: Default; indicates that column will 
display by default on the cost sheet to all 
users with at least "view" permission for 
the cost sheet. 

Hide: Hidden columns are active but not 
displayed on the cost sheet. Hidden 
columns can be accessed by users with 
"create" permission on the cost sheet. 

Total: Choose to designate the content of 
the Total row of the column. Default is 
Blank. You can choose Sum of All Rows or 
Use Formula Definition. 
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Average: Display the average row of the 
column. 

Total 

Choose how the total is displayed. 
Determines what will display in the "Total" 
(bottom) row for the column: 

Blank: The total of this column is not 
applicable and will not display on the cost 
sheet. Choose this column for percentage 
columns and other columns where it does 
not make sense to display the sum total. 

Sum of All Rows: The sum total of the 
column values is displayed. 

Use Formula Definition: For formula 
columns; the formula will be applied to the 
"Total" row in the same way it is applied to 
other rows in the column. 

Average 

Choose how the average is displayed. 

Blank

Avg of All Rows

Column Position After 
Choose the column position. The new 
column will be inserted after the column 
selected. 

Setting Generic Cost Sheet Template Permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Open the User Administration grouping node and click Access Control in the left 
Navigator. 

3) In the right pane, select Templates > Generic Cost Manager.

4) Select the Generic Cost Sheet template. 

The permissions are: 

 Create: Allows user to create a new Generic Cost Sheet template. 

 Modify Properties: Allows the user to modify the template properties. 

 Modify: Allows the user to modify an existing template. 

 View: Allows the user to view templates. 

Creating a Generic Cost Sheet 

You create a Generic Cost Sheet in the same way you create a standard Cost Sheet. See 
Create a Company Cost Sheet (on page 382) for details. Remember that the Generic Cost 
sheet can only be added to a generic shell, not to a project. 
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Setting up the Commitment Summary Template 

When a Generic Cost BP of the Base Commit type reaches Terminal status, it will create a 
record in the Commitment Summary sheet, which tracks commits in the context of a shell. When 
subsequent Change Commits and General Spend Generic Cost BPs that are associated with 
the original Base Commit, BP will update the Base Commit record on the Commitment Summary 
sheet. 

Create a Commitment Summary Sheet Template 

To create a Commitment Summary sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Commitment Summaries. 

3) Click New to create a new Commitment Summary sheet template. You can create multiple 
templates. 

4) In the General tab, enter a unique Name and an optional Description. 

5) In the Options tab, enter the following column names: Ref, Cost Code, Code Name, 
Breakdown, and Description. 

Depending on design in uDesigner, some columns may not display in the Commitment 
Summary sheet. 

6) Click OK. 

To add columns to a Commitment Summary sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Commitment Summaries. 

3) Select a Commitment Summary sheet template. 

4) Click the Columns button. The Columns Log opens. 

5) Click the New button. The Column Properties window opens. 

6) Complete the fields in the Column Properties window as described in the table below. 

7) Click OK when you are done with the column properties. 

In this field: Do this: 

Name 

Enter a column name. The name you 
choose will appear as the column header 
on the sheet. If you leave the Name field 
blank, the selection you make in the 
Datasource field will automatically 
populate the Name field. 

Datasource 

Choose a datasource for the column. The 
data source that you choose will determine 
which of the following options are 
available. The types of Datasources 
available are: 

Single Datasource: These values roll up 
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from business processes that have these 
attributes: 

 Sub-Type: Line Items with Multiple 
Codes 

 Classification: Base Commit, Change 
Commit, or General Spends 

Logical Datasource: 

 Commitment Cost 1 to Commitment 
Cost 25 

 Commitment Remaining Balance 

Entry Method 

This is applicable for logical data sources. 

 Manual Entry, Direct entry into cell: 
Users enter values by clicking the cell 
and entering values directly into the 
cell. 

 Formula: Values are calculated based 
on a specified formula entered for the 
column. Formulas can include the 
values of other columns. Click the 
Create button to create the formula. 

Data Format 

Choose the data format: 

 Currency: Formats data in a currency 
format with a comma (,) separator. 

 Percentage: Formats data as a 
percentage (%). 

Display Mode 

Choose a display mode. This refers to 
whether the column is displayed on the 
cost sheet. 

 Show: Default; indicates that column 
will display by default on the cost sheet 
to all users with at least "view" 
permission for the cost sheet. 

 Hide: Hidden columns are active but 
not displayed on the cost sheet. 
Hidden columns can be accessed by 
users with "create" permission on the 
cost sheet. 

Column Position After 
Choose the column position. The new 
column will be inserted after the column 
selected. 

Allow sub-breakdown with validation 

Select to be able to manually enter values 
against breakdowns in lines created on the 
sheet through Base Commit and Change 
Commit. 
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Create a Commitment Summary Sheet 

To create a Commitment Summary sheet: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates> Shells > [Shell name] > Cost Manager > Commitment Summary in the 
left Navigator. The Commitment Summary log opens. 

3) Click the Create Structure button. The Select Template window opens. 

4) Choose a template and click OK. 

5) Click Columns to add columns. 

6) Choose File > Properties to edit the sheet properties. 

7) In the General tab, enter a unique Name and an optional Description. 

8) In the Options tab, enter the following column names: Ref, Cost Code, Code Name, 
Breakdown, and Description. 

Depending on the design in uDesigner, some columns may not display in the Commitment 
Summary sheet. 

9) Click OK. 

Update a Commitment Summary Sheet from a Template 

To update a Commitment Summary sheet from a template: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates> Shells > [shell] > Cost Manager > Commitment Summary in the left 
Navigator. The Commitment Summary log opens. 

3) Modify the Commitment Summary 

4) Click the Update Shells button. The Update Shells window opens. 

5) Choose the shells to update and click OK. 
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Setting up the Document Manager 

A document attribute form and folder attribute form can be designed in uDesigner. These are 
used as the Properties window for documents and folders in the project-, shell-, and 
company-level Document Manager, which allows you to specify the fields that you want to 
associate with folders and documents (these are reportable). 

Step 1: Import and deploy Document Manager attribute forms. This is an optional step. If you do 
not import these forms, default forms will be used for document and folder properties. 

Note: Configuration of the Data Picker and Data Elements (and when 
applicable: Unique and Auto Sequence settings) must be done in 
uDesigner. For more information, see the Document Manager 
Overview topic in the Unifier uDesigner User Guide. 

Step 3: Create a folder structure template. This can be used to create the folder structures in the 
Document Manager at the project, shell, and company level. 

Step 4: Lock the folder structure. This is an optional step. This locks the first-level folder 
structure in User mode, which prevents users from creating or editing first-level folders, allowing 
you to maintain a consistent structure across projects and shells and at the company level. 
Users can still add or edit subfolders. You can unlock the folder structure later for editing if 
necessary. 

For security, the Company Administrators can specify the list and size of files that can be 
uploaded to the Company Properties page, by users and per company policy. For more 
information, see Access Company Details (Edit Company Window) in the Unifier General 
Administration Guide. 

In This Section 
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Document and Folder Properties 

Users have the ability to create attribute forms to customize the document properties and folder 
properties in the Document Manager, using the uDesigner. The data elements on the Properties 
window are fully reportable through user-defined reports. 
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The project documents, shell documents, and company documents log columns can also be 
customized through uDesigner, as well as the find function for searching on document and 
folders properties. You can import one document properties attribute form and one folder 
properties attribute form. Refer to the Unifier uDesigner User Guide for details about creating 
Document Manager attribute forms.  

Permissions 

The Document Manager permissions are set at the module level through the Permissions 
window or Access Control. Permissions for the Project-level, Shell-level, and company-level 
Document Manager are set separately. When permission is granted to view the Project 
Documents, Shell Documents, or Company Documents node, this only grants the user the ability 
to access the module and potentially to view documents stored there. Users must also be 
granted specific permission to create, modify, or view specific documents and folders in User 
Mode. This can be done by the folder or document's owner, or an administrator with full access 
permissions. Permissions at the folder or document level can be inherited from permission 
settings in the parent folder. 

A user granted full access permissions will have access with full permissions to create, modify, 
or delete any folder or document, regardless of the permission setting at the folder or document 
level. In addition, a user who is the owner of a folder or document will have full access 
permissions on that folder or document. Any folder or document level permissions are ignored. 
However, if the owner transfers ownership to another user, the permission setting for the former 
owner will be determined by the folder or document level permission setting. 

A user designated as the document administrator should have permission to create and 
maintain folder structure templates. Optionally, it is useful for the document administrator to have 
full access permissions granted for the Project Documents, Shell Documents, Company 
Documents, and Unpublished Documents nodes. 

Categories 

Categories are controlled by the data definition SYS Category. This is managed like other data 
definitions. Category values are added as the data set. 

When entering document or folder properties in the Document Manager, a category can be 
defined by choosing from the values in the data set. Category information is reportable in 
user-defined reports. 

Importing Document Manager Attribute Forms 

You can customize the document and folder properties by creating DMS attribute forms in 
uDesigner. Ensure that you have checked for errors and changed the status to complete in 
uDesigner. 

When deploying the attribute forms, the following will be updated with the customized interface 
designed in uDesigner: 
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 Project Documents log 

 Shell Documents log 

 Company Documents log 

 Search by Properties Criteria 

You can have only one document and folder attribute form per company, which will be used for 
the document and folder properties in the company-level Document Manager and across all 
projects and shells. 

To import and deploy a Document Manager attribute form into Unifier Production environment, 
see Importing Configuration Packages (on page 619). 

Setting Document Manager Administration and User Permissions 

To grant auto-sequencing configuration permission: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click User Administration > Access Control. 

3) On the right pane, select Administration Mode Access > Configuration > All > Document 
Manager. This opens the Module Permission Settings window for the Document Manager. 

4) Click Add to assign permissions to a user that is not in the permission list, or Modify to edit 
the permissions of a user that is already in the permission list. The Permission/Access 
Control window opens. 

5) Click Add Users/Groups to open the User/Group Picker. 

6) Select users to add and click Add. Click OK when finished. 

7) In the Permission/Access Control window, select the desired users and select or deselect 
the Configure check box in the Permission Settings block.  

8) Click OK when finished. 

To grant User mode permissions: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click User Administration > Access Control. 

3) On the right pane, select: 

 User Mode Access > Company Workspace > Document Manager > Company 
Documents or 

 User Mode Access > [project or shell] > Document Manager > Documents. 

4) Click Add to assign permissions to a user that is not in the permission list, or Modify to edit 
the permissions of a user that is already in the permission list. The Permission/Access 
Control window opens. 

5) Click Add Users/Groups to open the User/Group Picker. 

6) Select users to add and click Add. Click OK when finished. 

7) In the Permission/Access Control window, use the check boxes to assign the following 
permissions to selected users: 

 Full Access

 Create
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 Organize

 View. 

8) Click OK when finished. 

For Unpublished Documents, the permissions are Publish, Download, Open, View. 

For Document type business process permission settings, refer to the Unifier Data Reference 
Guide. 

Working with Folder Structure Templates 

You can standardize the setup of the Document Manager across your projects and shells and at 
the company level by creating folder structure templates. These templates let you create the 
folders and sub-folders that you can then import into the company Document Manager, or into 
any project and shell or project or shell template to organize your documents. 

After importing, you can add, move, rename, or delete folders as needed. You can import a 
folder structure directly under the Project Document, Shell Document, or Company Documents 
node to create the main folder structure, or create specialized structures to import under existing 
folders to create sub-folders. 

You cannot use special characters / \ : * ? " < > | when naming a folder or publish path.  

Note: By default, files attached to business processes are placed in the 
Unpublished Documents folder in the Document Manager. A Publish 
Path data element can be designed in business processes in uDesigner 
to specify the automatic publishing of documents to a specified path and 
override the default. For document-type business processes With Folder 
Structure, you can specify that a configured folder path be appended to 
the folder structure. This appended path is based on the path configured 
in the uuu_dm_publish_path data element on the business process form, 
and the selection of the Append Line Items Folder Structure to 
AutoPublish Path option, which is documented in the Unifier uDesigner 
User Guide. 

To create a folder structure template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Folder Structures. 

3) Click the New button, or click the File menu and choose New > Create New Template. The 
Create Folder Template window opens. 

4) Enter a name for the template. 

5) Click Add. A sub-folder will be created in the Template Folder. The Template Folder 
corresponds to the folder into which you will import the folder structure in the Document 
Manager. 

6) Continue to add folders. 
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Select the parent folder before clicking Add. Clicking Add without selecting a folder will 
default to the last folder created. 

7) To modify the folders, do any of the following: 

 Click + (plus sign) to the left of the folder to expand it and display the sub-folders. 

 Select a folder and click Remove to delete a folder. 

 Select a folder and click Rename to change the name. 

 Select a folder and click Move Up or Move Down to move it. 

8) Click OK. 

To create a folder structure from an existing project or shell 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Folder Structures. 

3) Click File > Copy from Project or New > Copy from Shell. The Projects or Shells window 
opens. 

4) Select a project or shell from the list and click Select. You can click Find to search for the 
project or shell. The Copy Folder Template window opens, displaying the entire folder 
structure of the project or shell you chose. 

5) Give the new template a name. You can add, modify, delete, or move the listed folders as 
needed. 

6) Click OK to save the template. 

The structure can be imported into the Document Manager. See Import a folder structure 
template. 

To modify a folder structure template 

1) In the Folder Structure Template log, select the folder structure template to modify and click 
the Open button. The View Folder Structure Template opens. 

2) Click + (plus sign) to the left of a folder to expand it and display the sub-folders. 

3) To modify folders, do any of the following: 

 Select a folder and click Remove to delete a folder. 

 Select a folder and click Rename to change the name. 

 Select a folder and click Move Up or Move Down to move it. 

 Click OK. 

To delete a folder structure template 

In the Folder Structure Template log, select the folder structure to delete and click the Delete
button. Click Yes to confirm. 

Lock and Unlock the First-level Folder Structure 

An administrator with full Document Manager permissions (full access or create permission on 
the Project Documents, Shell Documents, or Company Documents node) has the ability to lock 
or unlock the first-level folder structure. The first-level folder structure refers to the folders 
directly beneath the Project Documents, Shell Documents, or Company Documents node.  
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This allows an administrator to establish a standard first-level folder structure that cannot be 
modified. Users will not be able to add, modify, or delete the first-level folders, but can add 
sub-folders or documents. Permissions to lock first-level folders can be modified. 

You can lock the folder structure at the Project Documents, Shell Documents, or Company 
Documents root folders. 

To lock the first-level folder structure 

1) In User mode, do one of the following: 

 Open a project or shell and click Document Manager > Documents in the left Navigator. 
Be sure the Project or Shell Documents folder is selected at the highest level (click the 
house icon at the top of the log). 

 Go to the Company Workspace tab and click Document Manager > Company 
Documents in the left Navigator. Be sure the Company Projects or Company Shells 
folder is selected at the highest level (click the house icon at the top of the log). 

2) In the right pane, click the Options tab. 

3) Select the check box Lock first level folder structure below Project Documents (or 
Company or Shell) at the bottom of the window. You may need to scroll down. 

Users with permissions will be able to add documents and sub-folders, but cannot add, 
modify, or delete the first-level folders. 

Note: This check box is only available in the Project, Shell, and 
Company Documents folder properties. 

4) Click Save. 

To unlock the first-level folder structure 

Open the Folder Properties window, Options tab, and deselect the check box. 

Configuring Document Manager 

When configuring Document Manager, the user can create log views for the Document log. 

All the DM attributes forms available in Folder Properties node (in Document Manager) are 
included in the configuration once the DM design is deployed. For more details on DM attributes 
refer to the: 

 Unifier Shells and Projects User Guide, "Working with Multiple Document Manager Attribute 
Forms." 

 Unifier uDesigner User Guide, "Creating Multiple Attributes Forms." 

Unifier creates the configuration, by default, when the attributes form is deployed in the 
Document Manager, in uDesigner, and marked as Active.  

The configuration for system-defined attribute form will always be Active. The user will be able 
to create log views whether configuration is Active or Inactive. 

Only the active DM configuration forms will be available for selection in shells or shell templates. 
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If the user deletes the attribute form related to the DM configuration, the system deletes the 
configuration for the attribute form after the user deploys the DM design. 

When the user opens a configuration for the Document Manager, a sub-node appears under 
the Document Manager node ("{document manager log name } - Log Views"). This sub-node 
will be available in Document Manager log regardless of status (active or inactive), and the user 
can define log views for the respective DM logs. For example, if the user clicks on EMAAR 
Attributes, then a sub-node appears as "EMAAR Attributes - Log views." 

Permission and Access Control 

Only a user with Configuration permission, for Document Manager, will be able to access this 
node and create views. To set permission, go to Company Workspace tab > Admin mode > 
User Administration > Access Control > Administration Mode Access > Configuration > 
Document Manager: Permission Settings > Configure. 

Creating Document Manager Log Views in Admin Mode 

The following list of views in the log are included in the OOTB (out of the box) views. These 
views can be modified only at the Admin level. Views defined in the Configuration node will also 
be treated as OOTB views. 

To define log views for Document Manager, use the Document Manager node (Company 
Workspace tab > Admin mode > Configuration). The Document Manager log has the 
following operational options: 

 Create

Enables the administrator to create a view. 

 Actions

Possible actions is status which can be marked as active or inactive. 

 Status (Active - Inactive)

 Delete

 Find on Page

To filter the results seen on Document Manager log and find a specific view on the 
displayed page. 

Note: The user will not be able to inactivate the DM configuration 
associated with a system-defined attribute form. 

The Document Manager log has the following columns: 

 No.

This is a system-generated number. When populated, it enables the user to know the 
sequence of the views. 

 Name

Name of the view. 

 Status

Can be Active or Inactive. 
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 Last Modified Date

The date that the View was last modified. For a new view this will be the creation date. For 
existing system-defined views, for the very first time, when no modifications are done, this 
field will be blank. 

 Last modified by

The user who modified the view. For existing system-defined views, for the very first time, 
when no modifications are done, this field will be blank. 

Important Information about Creating DM Log Views 

The Administrator cannot inactivate all the views. At least one view must be active. 

The 'check for duplicate view' names will be performed per user. A user will not be allowed to 
create two views with the same name per DM log. 

If a user changes the sequence of the views that was initially provided as per DM configuration, 
or if an Administrator has made few changes to the sequence, the user's view sequence will not 
change. 

The new active views will be appended to the end of the list, in user view, in Document 
Manager. 

You cannot modify the view names "All" and "Current Phase" of the View option. 

Defining New View 

When you click Create, the New View window opens. From top to bottom, this window has the 
following elements: 

 Save View As

 Cancel

 Save

 Columns tab

 Filters tab

 Group By tab

 Sort By tab

 Gear menu

Enables the user to conduct the following: 

 Move Up

This option is not available for first view. 

 Move Down

This option not available for last view. 

 Delete

This option not available for Active view. 

Changing the sequence will change the number seen for the view. The sequence seen is the 
sequence seen in the log. When a drag and drop is done to re-sequence the views, the 
numbers will change. 

The Actions option enables the user to set: 
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 Status

The user will be able to define the view status as Active or Inactive. The user can select one 
or more views and click Status to either Activate or inactivate the views. 

 Delete

The user will be able to delete the views. Deletion of views will be possible only for Inactive 
views. If multiple views are selected and one of the views is active then post action only the 
Inactive views will be deleted. 

Document Log Views and Configuration Package 

Use the Log Views node (Company Workspace tab > Admin mode > Configuration Package 
Management > Component Lists > Configuration > Log Views) to include the designs for the 
selected log views, for Document Manager, in your configuration package. 

DM log views in Component list/Configuration Package: 

 The users can include DM log views and deployed designs. 

 The users can include updated DM log views without any changes to the underlying columns 
used in View definition. 

 When the configuration package is imported, it replaces any existing DM log views that were 
created by the administrator. 

Note: The DM log view component will be included as part of impact 
analysis report, error report, and print report. In Impact Analysis Report, 
the name for log view will appear as "{DM configuration name} - Log 
View". In other reports the name will be maintained as is as seen in the 
DM configuration. 

After a DM log view is included, the system will package all of the log Views for that particular 
DMS in the configuration package. When imported, the package replaces all of the log views 
created by the Administrator. 

Note: The user-created view (the runtime created views) will not be 
impacted by Configuration package import. 

The component name will be listed as Document Manager, for log views, and the location as 
Configuration > Log Views. 
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Setting up the Planning Manager 

Before you begin: Planning types are designed in uDesigner and deployed to Unifier. A 
planning type consists of planning item forms and planning sheet forms. Examples of planning 
types include Capital Planning, IT Planning, and so on. The planning item forms are used to 
create new planning initiatives for that type, and the sheet forms are used to create the 
associated planning sheet. The types, forms, and corresponding logs are designed in 
uDesigner. 

Step 1: Design Planning Type attribute in uDesigner and deploy to Unifier. This is similar to any 
other design deployment in uDesigner. 

Step 2: Grant yourself permissions to create a default sheet structure and configure the planning 
type. 

Step 3: Create a default structure for the planning sheets. This is a template that you will create 
to specify the default columns that should be on the planning sheets. 

Step 4: Configure (activate) each planning type. 

Step 5: Grant Planning Manager permissions to users. In User mode, the permissions for 
planning items and sheets are Full Access, Create and View. 

After you have completed these steps, the Planning Manager is ready for use in Unifier (User 
mode). 

In This Section 
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Importing a Planning Type 

To import and deploy a planning type into Unifier Production environment, see Importing 
Configuration Packages (on page 619). 
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Granting Yourself Permissions 

When you import a new planning type, you must grant permission (to yourself, another 
administrator, or group such as Company Administrators) to configure the planning type and 
create a default structure for the planning sheets. 

To grant configure permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, expand the User Administration grouping node and click Access 
Control. 

3) On the right pane, select Administration Mode Access > Configuration > All > Planning 
Manager. 

4) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 

6) Select the user(s) to whom you want to give configuration permission and click the Add
button. Click OK. The system adds the name(s) to the Permission/Access Control window. 

7) Under Permission Settings, select Configure and click OK. The system adds the name(s) to 
the Permission Settings window. 

8) Click OK. 

Creating a Default Structure for the Planning Sheet 

Creating a sheet structure produces a template that users can use to create a planning sheet. 
You must create a default sheet structure before you can use the Planning Manager at the 
company level, or load the Planning Manager into a shell. 

To create a planning sheet structure 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Planning Manager in the left Navigator. 

3) Select the planning item for which you want to create a structure. 

4) Click the Default Structure button. The Planning Sheet Template window opens. 

5) Add columns by clicking the Columns button. The Column Log opens. 

6) Click New. The Column Properties window opens. 

7) Use the information in the following table to complete the Column Properties window. 

In this field: Do this: 

Data Source

Select the field you want to appear on the 
sheet. (This list shows the fields (data 
elements) that were included on the 
Planning Item attribute form.) When you 
select the field, the system displays the 
field label in the Name field. 

Entry Method Specify: 
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 Manual Entry if the user must 
manually enter values into this field 

 Formula if the field will be 
automatically calculated with a formula. 
(To create the formula, see Add a 
Column Based on a Formula 
Calculation (on page 466).) 

 Query to retrieve data from the 
database that meets specific 
conditions and display it in this column. 
(To create the query, see Add a 
Column based on a Database Query
(on page 467).) 

Show as percentage If you chose Formula or Query as the 
data entry method, use these options to 
specify how the value should be shown. 

Note: If the data element was defined in 
uDesigner with a specific decimal amount, 
it will override any decimal amount you 
specify here. 

Decimal Places

Display Mode
Use this option to hide or display this field 
on the sheet. 

Total

If you created a formula or query to 
calculate the values for this column, you 
can specify: 

 Blank to leave the total of this column 
blank. (Choose "blank" for percentage 
columns and other columns where it 
does not make sense to display a 
total.) 

 Sum of All Rows to display the sum 
total of all the column values. 

 Use Formula Definition to display the 
total; that is, the same formula will be 
applied to the total that was applied to 
all the values in this column. 

Average

If you created a formula or query to 
calculate the values for this column, you 
can specify: 

 Blank to leave the average of this 
column blank. (Choose "blank" for 
percentage columns and other 
columns where it does not make sense 
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to display an average.) 

 Avg of All Rows to display the value 
as an average of all the rows' values. 

Column Position After
Use this field to specify where the column 
should appear on the sheet. 

Add a Column Based on a Formula Calculation 

If you choose Formula as the data entry method, you can create a numeric, a "date add," or a 
"date difference" type of formula to automatically calculate the values for the fields in the column. 

The numeric formula option is only available if the data source you specify has been built on the 
SYS Numeric Logical Datasource data definition. 

A "data add" formula takes the value from a date field and adds the value of another field to it. 
This option is only available if the data source you specify has been built on the SYS Date 
Logical Datasource data definition. 

A "date difference" formula takes the value from a date or date field and subtracts it from the 
value in another date or date field. This option is only available if the data source you specify 
has been built on the SYS Numeric Logical Datasource data definition. 

To create a numeric formula for a column 

1) In the Data Source field, choose the field that contains the value you want to include in this 
column. 

2) In the Entry Method field, choose Formula and click the Create button. The Formula 
Creation window opens. 

3) In the Data Type field, specify where the field comes from—a planning item, or the planning 
sheet. The Formula Creation window opens, showing a list of the fields from the data type 
you selected. 

4) Create the formula using the field values in this data source, or field values and numeric 
operators, such as add, subtract, or multiply. 

5) Click OK. 

To create a "date add" formula for a column 

1) In the Data Source field, choose the field on the sheet that should show the value you are 
calculating here. 

2) In the Entry Method field, click Formula, then click the Create button. The Create Formula 
window opens. 

3) In the Date field, select the field to which you want to add another value as follows. 

a. Click the Select button. The Date Element Picker window opens. 

b. In the Data Type field, specify where the date field you want to add to comes from—a 
planning item, or the planning sheet. The system displays a list of the fields on the 
planning item form, or the planning sheet. 
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c. Select the field and click OK. 

4) In the Add field, select the field that contains the value you want to add to the field. 

5) Specify whether the calculation should be based on calendar days or work days. 

6) Click OK. The system displays the formula on the Column Properties window. 

To create a "date difference" formula for a column 

1) In the Data Source field, choose the field on the sheet that should show the value you are 
calculating here. 

2) In the Entry Method field, click Formula and select Date Difference from the list. 

3) Click the Create button. The Date Difference window opens. 

4) For the Earlier and Later Dates, you can use either the last date the Planning Sheet was 
updated, or you can choose another field from the sheet or a planning item to supply the 
date value. 

5) In the Calculation based on field, specify whether the calculation should be based on 
calendar days or workdays. 

6) If you want the value in include fractions of days, select the Show Partial Days check box. 

7) Click OK. 

Add a Column based on a Database Query 

If you choose Query as the data entry method, use these instructions to add a column to the 
Planning Sheet that will contain values extracted from the database. These values will be 
retrieved from the database only if they meet the conditions you specify. (In operation, you will 
be extracting data from the database and testing it to determine whether or not it should be 
included in this column.) 

The Query option is only available if the data source you specify has been built on one of the 
following data definitions: 

 SYS Numeric Datasource

 SYS Date Datasource

To create a query 

1) In the Data Source field, choose the field on the sheet that should show the value you 
retrieve from this query. 
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2) In the Entry Method field, choose Query and click the Define button. The Query Definition 
window opens. 

3) In the Data Type field, select the functional area the data should come from. 

This field is the first step in describing where the data resides in the database. For example, 
the data type could be a Cost BP, a fund allocation request, or a cash flow. 

4) In the Datasource field, click the Select button. The Formula Creation window opens, 
showing a list of the fields from the data type you selected. 

You can drill down into the data type for other data sources by clicking the arrow beside this 
field and selecting other data source areas. 

5) (Optional) Create a formula using the field values in this data source, or field values and 
numeric operators, such as add, subtract, or multiply. Click OK to return to the Query 
Definition window. 

6) Specify the query condition as follows: 

a. Click Add. The Query Condition window opens. 

b. In the Data Element field, click Select to open the Data Element Picker. 

c. In the Data Source field, select the functional area the data should come from. The 
application displays a list of the fields from the data source you selected. 

d. From the list, select the field that contains the value you want to place conditions on and 
click OK. 

 If the value meets the condition you specify, it will be included in this column on 
the sheet. 

 If the field you select is a date field, the system will display an additional field, 
Timescale Units, in which you will need to specify the option that matches the 
column definition. For example, if the column is a yearly budget, you would select 
Years. If the column is to show a quarterly value, you would select Quarters. 

e. In the Condition field, select the condition the value must meet to be included on the 
Planning Sheet, such as equals, or does not contain. For example, the value in the data 
element must equal 10, or the value in the data element must not equal (that is, "is not") 
Yes. 
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f. In the Values field, enter the value you want to test the condition on (or select the value 
from the list that appears when you click the Select button).  
The Select button may or may not appear, depending on the data element you choose. 
For example, for a data source of "Business Process/Status," you could choose a status 
from the list of statuses associated with that BP. This would limit the column data to 
business process records of that status. 

g. Click OK. 

7) On the Query Definition window, click OK. 

Create a Planning Column Group 

This allows you to group columns together and assign a group name, which is displayed on the 
planning sheet above the columns. Columns in a group must be contiguous. 

Note: If you need to add a column to an existing group, first ungroup the 
existing columns, then create a new group to include the new column. 

To group planning sheet columns 

1) Go to the Configuration - Planning Manager log and click Default Structure. 

2) Select Columns. Columns must be contiguous, and cannot belong to more than one group. 

3) Click Group Columns > Group. The Edit Column Groups window opens. 

4) Name the group and click Ok. Group names must be unique. The Group Name will appear in 
the planning sheet log and also on the Planning Sheet above the columns. 

To ungroup columns 

Select grouped columns and click Group Columns > Ungroup. Ungroup will remove group 
name from all columns that are part of that group. 

To add or remove columns to the group 

1) Ungroup the columns. 

2) Select a new group of contiguous columns. Add or move columns as necessary. 

3) Group the new columns. 

To change the group name 

1) Select any column in the group. 

2) Click Group Columns > Group. 

3) Enter a new Name and click OK. 

Edit Planning Sheet Properties 

You can edit the properties in individual planning sheets or the default structure. 

To edit planning sheet properties 

1) Open the planning sheet or default structure. 
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2) Click File > Properties. The Properties window opens. 

3) Complete the General tab: You can enter or change the Name of the sheet, and add an 
optional Description. 

4) Click the Options tab: 

 Sort by Column: Choose the column to sort the planning item rows by. The default is 
Name (planning item name). As you add additional columns to the sheet, these columns 
will be available for selection. 

 Sort Order: Choose Ascending or Descending; works in conjunction with Sort By 
Column. 

 Update Planning Items: When this check box is selected, it allows planning sheet users 
to manually edit planned item data. This helps to prevent conflicting data from multiple 
planning items. 

This box can be checked on only one sheet per Planning Type. When this box is checked, 
the sheet is moved to the top of the log, and displayed in bold font, thereby acting as a 
master planning sheet. 

5) Click OK. 

Configuring the Planning Type 

Configuring a planning type makes it active, gives it a numbering sequence for the records, and 
specifies an optional Help file and hard copy layout for printing. 

To configure a planning type 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Planning Manager in the left Navigator. Each planning type will be 
listed here. 

3) Select a planning item and click Open (or double-click). The Planning Configuration window 
opens. 

4) Complete the General tab: 

 Sequence Format: This will define how planning item records will be numbered under 
this Planning type. 

 Help File: This will allow user to upload a PDF file as help file for Planning Item. This file 
should be available from Planning Item log and individual planning item record. 

 Status: This defines if this planning type is active or not. If it is not active, it will not be 
visible under User mode even if a user has permission to access it. 

5) Click OK. 

Deleting a Planning Manager 

This section describes how to manually delete a Planning Manager from a shell. 
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Note: You can delete a Planning Manager from a specific shell template 
but not from other Projects/Shells that have been created using the 
template. 

1) Open the project/shell and switch to Admin mode. 

2) In the left Navigator, click Setup > Planning Manager. 

3) Select a Planning Manager for deletion. 

4) From the Edit menu, select Delete. 

5) When the confirmation message appears, click Yes to delete the record from the Planning 
Manager. 

Configuring Planning Manager Configuration Package 

The following configurations can be included in the Planning Manager Configuration Package: 

 General setup 

All the fields included in the General Configuration (General tab) 

 Custom Print 

Word and PDF templates, if any. 

 BIP Custom Print 

All the Oracle Business Intelligence Publisher (BI Publisher) and Oracle Analytics Publisher 
Custom Print in the Custom Prints and Reports. 

 Default structure 

The default structure of the Planning sheet. 

For more information, see Configuration Package Management (on page 567). 

Granting Planning Setup Permissions 

After you have created a default sheet structure and activated the planning type, you need to 
grant yourself and other users setup permission to the Planning Manager. 

To grant setup permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Open the User Administration grouping node and click Access Control in the left 
Navigator to open the Access Control log. Navigate as follows: 

 For a Planning Manager at the company level, navigate to User Mode Access > 
Company Workspace > Planning Manager. 

 For a Planning Manager at the project of shell level, navigate to a project/shell and click
Setup > Planning Manager. 

3) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

4) Click the Add Users/Groups button. The User/Group Picker opens. 
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5) Select the user(s) to whom you want to give configuration permission and click the Add
button. Then click OK. 

The system adds the name(s) to the Permission/Access Control window. 

6) Under Permission Settings, select Setup and click OK. The system adds the name(s) to the 
Permission Settings window. 

7) Click OK. 

Loading the Planning Manager 

Loading the Planning Manager is part of setting it up. In this step, you will be loading the 
manager into the area where it should reside—the Company Workspace or a project/shell. 

When you load the Planning Manager, you also load the permission infrastructure and the ability 
to grant permissions for the manager. 

To load the Planning Manager 

1) Do one of the following: 

 To load the Planning Manager into the Company Workspace, go to the Company 
Workspace tab and switch to Admin mode. In the left Navigator, click Company 
Workspace > Planning Manager. 

 To load the Planning Manager into a project/shell, go to the shell or sub-shell and switch 
to Admin mode. In the left Navigator, click Setup > Planning Manager. 

2) Click New. 

The New Business Processes window opens, showing the Planning Managers that are 
available for loading. 

3) Select the planning manager you want to load and click OK. 

The system displays the manager in the right pane. 

Granting User Permissions 

After you have loaded the Planning Manager into the company workspace, or the shell, you 
need to grant user permissions to the Planning Manager. 

To grant user permissions 

1) Open the shell or sub-shell in which the Planning Manager resides.  

2) In the right pane, under Administration Mode Access, click Access Control. 

3) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

4) Click the Add Users/Groups button. The User/Group Picker opens. 

5) Select the user(s) to whom you want to give permissions and click the Add button. Then 
click OK. The system adds the name(s) to the Permission/Access Control window. 

6) Under Permission Settings, select the permissions you want to grant the user(s) and click 
OK. The system adds the name(s) to the Permission Settings window. 

7) Click OK. 

8) In the right pane, under User Mode Access, click Planning Manager. 
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9) For both the planning items and planning sheets, repeat steps step 3 through 6. 

Master Log - Planning Items for the Planning Manager 

The master log (Master Log - Business Processes node) is located in the Home workspace. 
The master log enables users to access all or a subset of records of the same type, in a single 
log that spans multiple shells or projects. The master log for Planning items list all Planning item 
types at the project/shell level in separate nodes for each type. 

Note: The name of the master log (Master Log - Business Processes
node) can be customized. 

The master log is available for all Planning Manager logs; however, they are not visible to users 
unless they have permission to view the log. 

Note: The company-level planning items are not listed under the master 
log. 

In order for users to view and work with the master log (Master Log - Business Processes
node), you must grant permissions to it. You can grant permissions for users to access all 
planning items in the master log, or to individual planning items. 

To view planning items, users must also: 

 Be an active member of the project, shell, or sub-shell 

 Have access to at least one business process in the master log 

To set permissions for planning items master log (Master Log - Planning Items node): 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Open the User Administration grouping node and click Access Control in the left 
Navigator. 

3) On the right pane, select User Mode Access > Home > Master Log - Planning Items > 
[planning item]. 

4) Add the user(s) and set the permissions as needed: 

 View: Users can view all records across all projects and all records in the shell hierarchy 
(subject to their highest level of shell membership in the hierarchy) independent of 
whether or not they are assignees on or have permissions to view and manage individual 
records within a particular shell or project. These users can also view saved searches. 

 Allow Bulk Edit: Users can select one or more records within a master log and perform 
bulk edits on records. Selected records can potentially span across multiple shells. Users 
having this permission automatically have View permissions. 
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Setting up the Portfolio Manager 

The Portfolio Manager is where the budget forecast planners in your company can gather cost 
and schedule information on projects (both planned and in execution) and perform analyses on 
"what if" scenarios. These scenarios are used to propose an optimal mix of projects for a 
portfolio, based on available budget targets and the strategic goals of the company. 

Portfolio planners can create a portfolio for a specific "planning horizon" (for example, from 2014 
through 2020) and then create multiple scenarios in that portfolio. Each scenario can use 
forecast numbers and actuals, as well as schedule dates, for both planned and active projects in 
a specific shell type across a hierarchy in the company. 

Budget forecast planners create these scenarios on sheets, one for each scenario. The scenario 
sheets can pull in the following data from any shell type in a hierarchy: 

 Project information from the shell attribute form or single-record business process 

 Project start and end dates from the shell attribute form or single-record business process 

 Cash flow data (both forecasted and actual) from each project's Cost Manager 

With this data, you can forecast costs over a specific time period (called a "period structure"). 
You can then manipulate scenarios by: 

 Including or excluding projects 

 Pushing start dates for planned projects into the future 

 Modify project end dates to change the project's duration 

 Proposing different cash flow distribution numbers by manually editing the cash flow columns 

 Negotiating proposed budgets with project managers 

Note: The numbers the planner proposes in a scenario will NOT affect a 
project's live data. The proposed numbers are stored only in the Portfolio 
Manager and will not affect live project data until a scenario has been 
approved by your company management. 

After these scenario analyses have been completed, the best (or several best) scenario(s) can 
be sent to the executive decision makers for approval. 

After a scenario has been approved, the system: 

 Marks the approved scenario "shared" so that project managers can see the approved dates 
and numbers. The scenario is set to read-only mode and can no longer be modified or 
deleted. 

 Updates each project's original budget numbers with the proposed numbers on the approved 
scenario. 

 Updates each project's monthly or yearly cash flow numbers with the proposed numbers on 
the approved scenario. 

 Updates the project start date (if it was changed) for any planned projects that will begin 
during the portfolio's planning period. 

 Locks the budget and cash flow numbers to prevent any further changes. 
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To set up the Portfolio Manager 

Before you begin: A portfolio attribute (detail) form is designed in uDesigner and deployed to 
Unifier. This attribute form is what you and other users will use to create new portfolios. 

Step 1: Design the Portfolio Manager attribute form in uDesigner and deploy to Unifier. This is 
similar to any other design deployment in uDesigner. 

Step 2: Grant yourself permissions to configure the portfolio and create period structures. See 
Create Period Structures (on page 477). 

Step 3: Create period structures under the Standards & Libraries node. Primavera Unifier 
uses these period structures to calculate costs for the portfolio's forecasted budget. See Create 
Period Structures (on page 477). 

Step 4: Configure the portfolio. 

Step 5: Grant Portfolio Manager permissions to users. 

After you have completed these steps, the Portfolio Manager is ready for use in Primavera 
Unifier User mode. 

In This Section 

Import a Portfolio ................................................................................................... 476 
Grant Yourself Permissions ................................................................................... 476 
Create Period Structures ....................................................................................... 477 
Configuring the Portfolio Manager ......................................................................... 480 
Configuring Portfolio Manager Configuration Package .......................................... 486 
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Import a Portfolio 

To import and deploy a portfolio manager into Unifier Production environment, see Importing 
Configuration Packages (on page 619). 

Grant Yourself Permissions 

When you import a new portfolio, you must grant permission (to yourself, another administrator, 
or group such as Company Administrators) to configure the portfolio and set up period structures 
in the Standards & Libraries. 

To grant configure permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, expand the User Administration grouping node and click Access 
Control. 

3) In the right pane, select Administration Mode Access > Configuration > All > Portfolio 
Manager. 
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4) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 

6) Select the user(s) to whom you want to give configuration permission and click the Add
button. Then click OK. 

The system adds the name(s) to the Permission/Access Control window. 

7) Under Permission Settings, select Configure and click OK. 

The system adds the name(s) to the Permission Settings window. 

8) Click OK. 

To grant permissions to create period structures 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, expand the User Administration grouping node and click Access 
Control. 

3) In the right pane, select Administration Mode Access > Standards & Libraries > Period 
Structure. See Create Period Structures (on page 477). 

4) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 

6) Select the user(s) to whom you want to give configuration permission and click the Add
button. Then click OK. The system adds the name(s) to the Permission/Access Control 
window. 

7) Under Permission Settings, select Create and click OK. The system adds the name(s) to 
the Permission Settings window. 

8) On the Permission Settings window, click OK. 

Create Period Structures 

Each portfolio needs a defined period of time in order to be able to calculate costs for the 
forecasted budget. Creating a period structure designates the time scale for the period, the 
format the period should appear in at runtime on the period picker, and whether or not the period 
is active (available for use at runtime). 

After you have created a period structure, it cannot be deleted. In addition, after a period is in 
use in a deployed Portfolio Manager, it cannot be modified or inactivated. 

To create a period structure 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Period Structure. 

3) Click New. The Period structure window opens. 

4) Use the information in the table below to complete the fields in the Period Structure window. 

5) Click OK. 
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In this field: Do this: 

Period Structure Enter a name for the period structure. 

Description 
Enter a description of this period. This is 
not mandatory, but is recommended. 

Status 
Specify whether this period is active 
(available for use) or inactive. 

Period Type 

"Standard Planning Period" & "Financial 
Periods" 

For Financial Periods below Period 
Settings, options will be disabled and new 
Table with Financial Period will appear. 

Period Settings 

Specify the time scale for this period. 

Period: Select the time period for the 
analysis. This list shows years, each 
beginning with a month in the year and 
ending at the end of the month preceding 
the beginning month. 

Identify Period By: Use this option to 
accommodate time periods that span 
across two years. For example, if your 
fiscal planning period is from July 2010 to 
June 2011, use this option to tell the 
system that the planning year is based on 
either a starting month of July or an ending 
month of June. 

Format: Specify the format the date should 
appear in: 

 For Year, YYYY or YY 

The Period Structures support financial periods, while keeping the current period structures 
intact. The following period types enable the user to create financial periods, in separate tab: 

 Standard Planning Period 

 Financial Periods 

The user can toggle between the period type until saving the Period structure. After the user 
creates the financial period, and uses it (Shell options or PPM configuration), the user will not be 
able to delete or modify the financial period. 

The following explains the options: 

Option Description 

Add
Lets you create a default row, in the grid 
below starting from today date with end 
date, as weekly. You can modify the data. 
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Option Description 

Remove To remove a row in the grid. 

Generate
Opens a window and lets you select start 
and end dates and generate group of data.

There is no gap between the end date and start date for two consecutive periods, while creating 
sub periods. 

The following explains the columns present in the auto generated periods: 

Column Description 

No. 
The sequence number for the sub period 
being generated. 

Period Name 

Every sub period will have a name 
automatically assigned to it based on the 
start date. For example, if the sub period 
start date is 01/08/17, then 01/08/17 will be 
the period name. 

Start Date Sub period start date. 

End Date Sub period end date. 

Year 
Financial year for sub period being 
generated. 

The date format will depend on the selection made in the User Preferences. 

The following is an example of Financial Period, where: 

No.: The number of Sub Period 

Sub Period Name: Monthly 

Identify Date by: Period Start 

Date: "01/09/17" (It can be any date and not just the start date for the week, month, quarter, and 
so on.) 

No. Sub Period 
Name 

Start Date End Date Year 

1 1-Sep-17 1-Sep-17 30-Sep-17 2017 

2 1-Oct-17 1-Oct-17 31-Oct-17 2017 

The Year will be the year for the start date of first financial period until it reaches the same date 
next year (completes 365 days). Then it will move to next financial year. 

Use the Export option to export data in all of the columns. 
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Configuring the Portfolio Manager 

Configuring a portfolio means configuring the scenarios that will be analyzed in a portfolio. By 
configuring a scenario, you create a "template" for the sheets that planners can use to create the 
scenarios for analyzing and forecasting capital budgets. 

The template will contain: 

 The planning options for the scenario sheet, such as the period structure and data linking 
options 

 Project phases that identify a project as planned or in execution 

 The data sources to be used for the analysis, such as project dates and cash flow sources. 

 The query that will extract the project data that should be included in the portfolio 

 The column layout that will appear on the scenario sheet 

To configure: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > Portfolio Manager. Each portfolio will be listed 
here. 

3) Select a portfolio and click Open (or double-click). The Portfolio Configuration window 
opens. 

4) Enter values in the fields of the following tabs as explained below. 

General tab 

1. Use the following table to enter values in the fields: 

In this field: To this: 

Status Specify whether this portfolio is active 
(available for use) or inactive. When you 
activate a portfolio, the system loads it into 
all shells, but it will not be available to 
users until you grant user permissions to it. 
(See Grant User Permissions.) 

Include Projects of Type Specify the shell type that contains the 
project data that should be analyzed. The 
list will show all multiple-instance CBS 
shell types from any hierarchy, and data 
from all shells of this type will be used in 
the analysis. 
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In this field: To this: 

Additional attributes from The portfolio will automatically include data 
from the portfolio attribute (detail) form; 
however, you can also include information 
from single-record business processes, if 
they are appropriate. If there is a 
single-record business process that 
contains information that you want to 
include in this portfolio, select the name of 
the record you want to include. 

Yearly Planning Fields that specify the following 
requirements. 

Period Structure Specify the time period this portfolio should 
use. These period structures were created 
under the Standards & Libraries node after 
the portfolio was imported. The option 
shows what the period is (yearly, quarterly, 
or monthly) and the format in which the 
period will appear on the Period Structure 
Picker at runtime. 

Planning Phases If you are including planned projects, you 
must specify what phases of these projects 
you want to include in the analysis for this 
portfolio. 

Select the planning phases whose data 
should be used in the portfolio analysis. 
You can select multiple phases. 

Projects added to a scenario are initially As the administrator, you can specify that 
projects in a portfolio are linked or unlinked 
to project data when the user first opens 
the scenario sheet. After the scenario 
sheet is open, the user can choose to link 
or unlink the projects as appropriate. 

Linked: This option links the project data 
to the project database and updates the 
data in the portfolio every time the user 
opens a scenario sheet. 

Unlinked: This option unlinks the project 
data from the database. Select this option 
if you do not want the project data 
dynamically updated. 
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In this field: To this: 

Project Data Sources Specify where the data should come from 
for the portfolio. In this option, you will be 
choosing the data elements that will 
provide the values for the scenario 
analyses. 

Start Date Select the name of the field (data element) 
that contains the project start date. The 
elements you see on this list come from 
the project attribute form and any 
single-record business process you 
included. 

Update project start date upon approval

Select this check box if you want to update 
a planned project's start date on the 
attribute form when a scenario is approved 
for the current budget. The approved 
scenario may contain an adjusted start 
date. If the start date is adjusted on the 
scenario, the system will change the date 
on the project's/shell's attribute form to 
reflect the new date. If the Schedule sheet 
properties are configured to drive the 
schedule start date from the project/shell 
attribute form, the form will then update the 
start date on the Schedule sheet.  

End Date Select the name of the field (data element) 
that contains the project end date. The 
elements you see on this list come from 
the project attribute form and any 
single-record business process you 
included. 

Budget Source Select the budget source that should be 
used in the analysis. This budget source 
was defined under Standards & Libraries
> Cash Flow. 
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In this field: To this: 

Forecast Source Select the forecast source that should be 
used in the analysis. This forecast source 
was defined under Standards & Libraries
> Cash Flow. 

If the value of the Forecast Source is 
Forecast, then the Display monthly 
breakdown of Actuals option is available 
for you to select. 

You have the ability to show monthly 
breakdown of Actuals by selecting the 
check box. 

 If the check box remains deselected, 
then for the current year the existing 
functionality for the Portfolio Manager 
will be maintained. 

 If the check box is selected, then the 
user will be able to the see the monthly 
breakdown for Actuals, and the values 
displayed would be read-only for 
months prior to the current month for 
the current year. 

By default, the check box will be 
deselected. 

Select the data source according to your 
business case. 

The curves of the selected data sources 
must have the same currency. 

Portfolio Manager Configuration for 
Derived Curve

When the user selects the forecast source 
as a Derived Curve, in Portfolio Manager: 

After the configuration takes place, in User 
mode, the Portfolio Manager scenario 
sheet synchronizes with Cashflow and 
displays the data through a Derived Curve.

The user has the ability to show monthly 
breakdown of actuals by selecting the 
check box to display the monthly actuals. 

By default, the check box is deselected. 

If the check box is deselected in the 
Portfolio Manager configuration, then for 
the current year the existing functionality is 
maintained, for Portfolio Manager. 

Portfolio Manager Configuration for 
Label on Monthly Actuals

Use the check box "Display financial 
period breakdown of Actuals" for 
breakdown based on financial period. 
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In this field: To this: 

Additional Information Specify the list of users, and groups, who 
receive notification emails when a 
particular scenario is shared, or approved. 

Notify users or groups when a scenario is 
shared or approved 

Click Select to see a list of company-level 
users, or groups, and select one. 

The system only sends the email 
notification to existing users, or groups, at 
the project-level. If selected recipients do 
not exist at the project-level, the system 
will not send any notifications. 

2. Click Apply, then click the Query tab. 

If the financial period type of period structure is selected in the configuration General tab, the 
system hides the following drop-down list items (under Planning horizon in columns tab) 
because: 

 The number of years will be determined by the number of unique years in the sub periods for 
the financial periods. 

 The number of years planned in months will be same as the number of years planning with 
month as a sub period (the "Apply actuals to each sub period/month" check box). 

Query tab 

On the Query tab, you create a query that will search the database and extract the shell records 
to display on the scenario sheets in the portfolio. The query will filter the records returned from 
the database according to a condition or conditions you specify. The condition(s) will "test" a 
field or fields on the form to see if they pass or fail the criteria. If the fields pass the criteria, the 
system will make it available for the scenario sheets. 

The query that extracts the projects from the database is a dynamic process that occurs 
whenever users open a scenario sheet. The projects that appear on the sheet will fluctuate, 
depending on whether they still meet the criteria for inclusion. For example, a project that was 
previously on the sheet may be dropped from the sheet if it no longer meets the query criteria. 
Another project may be added to the sheet because it now meets the query criteria. 

The query will search the database and extract the shell records to display on the scenario 
sheet. The query will filter the records returned from the database according to a condition or 
conditions you specify. The condition(s) will "test" a field on the form to see if it passes or fails 
the criteria. If the field passes the criteria, the system will include it on the scenario sheet. 

1) Under Projects, select the Auto-add/auto-remove projects to and from the portfolio 
based on the query field if you want the system to automatically add and remove projects to 
and from scenario sheets. 

2) Create the query: 
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The query will search the database and extract the shell records to display on the scenario 
sheet. The query will filter the records returned from the database according to a condition or 
conditions you specify. The condition(s) will "test" a field on the form to see if it passes or 
fails the criteria. If the field passes the criteria, the system will include it on the scenario 
sheet. 

a. Click the Add button. The system displays the Add Query Condition window. 

In the Data Element field, select the field on the attribute form, or single-record business 
process, that you want to test with the condition. For example, the condition might be that 
the status field on the shell attribute form must be "Active." 

The window expands to show an active Condition field and additional fields where you 
can specify the query criteria. 

b. In the Condition field, select the condition the value in the field must meet. 

c. Click OK. 

The remaining fields on this window vary, depending on the data element and the 
condition you specified. For help in completing these fields, use the information in the 
Queries section. 

Note: If any field in the query or queries is subsequently removed from the shell or 
single-record BP design, the entire query operation will be ignored. That is, if one query 
fails because a field was removed from the design, the system will ignore all the queries. 
If a field has been removed from a design, you must amend the query. 

3) Repeat steps a through d to include additional query conditions. 

4) Click Apply, then click the Columns tab. 

Columns tab 

Use the following table to enter values in the fields: 

In this field: To this: 

Scenario Columns Specify what additional columns you want 
to appear on the scenario sheet. 

You can add the Project Phase Data 
Element (DE) to the Portfolio in order to 
see the latest value of Project Phase 
(Planning, Conceptual Design, Schematic 
Design, and so on) in the Portfolio as it 
changes (manually or via Gates) without 
having to take a manual step of saving a 
single record BP within a Shell. To add the 
Project Phase DE, go to the Configuration 
window, click Add, and from the Data 
Element drop-down list select Project 
Phase. 

Initial Sort Column Use this to specify the column by which 
the scenario sheet is initially sorted when 
the user opens the sheet. The user can 
change the column sorting. 
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In this field: To this: 

Sort Order Specify whether the projects on the sheet 
should appear in ascending or descending 
alphanumeric order. 

Freeze column up to This option affects the scrolling behavior of 
the scenario sheet. Scenario sheets 
contain certain columns that must always 
appear on the sheet. As administrator, you 
can add more columns to the sheet. Of 
these columns you add, you must specify 
that 1 of those columns must remain fixed 
when the user scrolls the sheet 
horizontally. 

Number of years planning Select the number of years to be included 
in this scenario. 

The default horizon is 10 years. This 
option designates the year columns that 
will appear on the scenario sheet. 

Number of years planned in months Specify how many years the planner wants 
to plan by months. For example, the 
planner may want to plan by month for the 
first two years; thereafter, by year. 

Users can define the column width for the Project Portfolio Manager (PPM) columns. 

Defining the column width can be done in the Column Properties window, when adding a new 
column in the Columns tab. The default value is set to 120 characters, and the user can change 
the value to a custom value. For the existing columns in Portfolio Manager (in the Configuration), 
the system sets the width to the default column width. The changes made in Configuration 
(Column width , Freeze column up to, and so on) remain in the new PPM. 

You can edit the width for the following columns in the PPM configuration: 

 Project Name 

 Start Date 

 End Date 

Configuring Portfolio Manager Configuration Package 

The following configurations can be included in the Portfolio Manager Configuration Package: 

 General setup 

All the fields included in the General Configuration (General tab), including: Yearly Planning 
and Project Data Sources. 

Note: Cash Flows that have been selected in the Budget Source and 
Forecast Source fields are included in the Configuration Package. If data 
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sources do not exist in the destination environment, the system will 
create the data sources. 

 Query 

All queries that have been configured based on data sources. 

 Columns structure 

The structure of the Column that has been defined in the Columns tab. 

You can include the portfolios that you want to include in your configuration package. To include 
a Portfolio: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration Package Management > Component Lists > 
[Component List] > Designs > Portfolio Manager. 

3) Select the required portfolio. 

4) Name the component list. 

5) Conduct an Error Check. 

6) Click Save. 

7) Go to the Company Workspace tab and switch to Admin mode. 

8) In the left Navigator, click Configuration Package Management > Configuration 
Packages. 

9) On the Configuration Pages log, click Create. 

10) Select your portfolio manager from the Component Lists. 

11) Enter values in the Package Name and File Name fields and click Next to see the preview. 

12) Click Next and review the contents. 

13) Click Next. 

14) Click Create. 

Note: For a successful inclusion of a portfolio, the shell and 
single-record business process must be a part of the Configuration 
Package. 

For more information, see Configuration Package Management (on page 567). 

If the user selects a Portfolio Manager, then the financial period selected in the configuration is 
included in the Configuration Package. 

Updated Cash Flow and Shell Templates are also available for the Configuration Package. 

Delete Columns from a Sheet 

You can delete columns from a sheet from either the Portfolio Configuration window, or the 
Column Properties window. 

To delete columns from the Portfolio Configuration window 

1) Click the Columns tab. 
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2) In the Scenario Columns section of the configuration window, select the name of the column 
and click the Remove button. 

Grant User Permissions 

When the Portfolio Manager is active in a shell, you must grant user permissions to the Portfolio 
Manager. 

To grant user permissions 

1) Open the shell where the Portfolio Manager resides and switch to Admin mode. 

2) Open the User Administration grouping node and click Access Control in the left 
Navigator. 

3) In the right pane, under User Mode Access, click Portfolio Manager. 

4) Click the portfolio. The Permission Settings window opens. 

5) In the Permission Settings window, click the Add button. The User/Group Permissions 
window opens. 

6) Click the Add Users/Groups button. The User/Group Picker opens. 

7) Select the user(s) to whom you want to give permissions and click the Add button. The 
system adds the name(s) to the Permission/Access Control window. 

8) Under Permission Settings, select the permissions you want to grant the user(s) and click 
OK. The system adds the name(s) to the Permission Settings window. 

9) Click OK. 

Templates (Shell Attribute Form) 

In the Shell Attribute Form, Options tab, the user can select a financial period from the Financial 
Period picker. 

The Financial Period picker has a list of all financial period type of period structures present in 
the Standards & Libraries (standards and libraries). 

The following explains the financial period in: 

 Shell 

 Cash Flow 

Shell 

Depending on the financial period selected at the Shell level, when the user tries to create a 
scenario under Portfolio Manager, the user will only see the list of projects with the same 
financial period present in the respective Shell options. 

If the user has selected a financial period at the Shell level, then the selected option overrides 
the financial period coming from Portfolio Manager by way of configuration. 

The same selected financial period will also be used under Cash Flow curves, for the time scale 
of the financial period type. 
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The user is able to change the financial periods when there are no cashflows associated with 
that financial period. 

Accordingly, when the Cash Flow is refreshed, it uses the new period structure. 

If the user selects a period from the period picker in the Shell details window, the selected period 
will be used across Cash Flow curves (if time scale type is financial period) and Portfolio 
Manager. 

Cash Flow 

The Portfolio Budget curves (Shared, Approved, and Original), in Cash Flow, are linked to 
Portfolio Manager scenarios. 

User can attain data from the Portfolio Budget curves (Shared, Approved, and Original), from the 
Portfolio Manager scenario in Parent Shell, into the Cash Flow curves within a Project/Shell. 

During a portfolio analysis, the Portfolio Manager can produce the following Portfolio Budget 
curves: 

 Shared Budget curve

The Shared Budget curve displays the portfolio planner's proposed number for the project. 

The User can include the Shared Budget curve on the Cost worksheet (along with the 
forecast budget or any other budget curve) in order to see the difference between the project 
numbers and the planner's proposed budget numbers. 

 Approved Budget curve

When a scenario is approved in the Portfolio Manager, the budgets for each project in the 
scenario are marked "approved." 

Unifier lock and stores the budgets in Portfolio Manager. 

An Approved Budget curve displays the approved budget for the project for the planning 
period (usually a year). 

 Original Budget curve

The Original Budget is the last approved budget for the project before it moves into its 
execution phase. 

The approved Original Budget becomes the project original budget. This original budget (and 
any changes that occur to the numbers during the life of the project) becomes the project 
approved budget. 

The Portfolio Manager scenario (with Financial Period as the Period Structure) created in the 
parent Shell will push/pull the data from respective curve only. That is to say: 

 For the child Shell, it has the same Financial Period in its options, and 

 It will consolidate the data for only those Cash Flows where the timescale has been 
selected as Financial Period. 

If the user selects a financial period from the ‘by' drop-down list, then the corresponding 
drop-down list for financial period will get populated with the Financial Period present in the 
Shell options. 

Other options, in timescale, will be disabled (for format and so forth), and it will remain blank 
with other options enabled (for format and so forth). 
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For Baseline and Forecast type curves, the summary sheet spreads and schedule manager 
spreads will be assigned to the relevant period. 

For the Actuals, the cost sheet columns and effective dates will be used to assign the values 
to the relevant period. 

For a Cash Flow curve, the X-axis for graph will still remain the same but the points in the curve 
will be based on the Financial Period that has been selected. The columns in the grid will be 
based on the Financial Period that has been selected, also. 
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Setting up the Resource Manager 

The Resource Manager is used to view current roles and resources in Unifier. 

Before you begin: The Resource Manager Attribute form is designed in uDesigner and then 
deployed to Unifier. 

In This Section 

Configuring Resource Manager at Company-level ................................................ 491 
Configuring Resource Manager Configuration Package ........................................ 491 

Configuring Resource Manager at Company-level 

The Resource Manager can be configured at the company level. 

To configure the Resource Manager at the company level: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > Resource Manager. 

3) Select Resource Manager and click Open. 

4) Complete the Resource Manager General Configuration window as described in the 
following table and then click OK. 

In this field: Do this: 

Resource Code 

Choose one of the following: 

 Manual: Allows you to enter a resource code 
manually while defining resources. Validation is 
performed to ensure resource codes are unique. 

 Automatic: Automatic numbering generates 
unique resource codes using a sequence. 

 Sequence Format: For automatic numbering, 
enter an alpha-numeric prefix for the resource 
code (for example, RES). 

 Start: Enter a number to start the sequence. 
Numbers are generated from the start number in 
increments of 1. 

Configuring Resource Manager Configuration Package 

The following configurations can be included in the Resource Manager Configuration Package:  
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 General setup 

All the fields included in the General Configuration (General tab) 

For more information, see Configuration Package Management (on page 567). 
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Setting up the Schedule Manager 

Here is the overall process for setting up schedule sheets in projects or shells: 

Step 1: Import and deploy the Activity Attribute form in uDesigner. If a configured schedule 
attribute form will be used, import it into Unifier. If a schedule attribute form has not been 
designed, Unifier will use a default attribute forms for the Schedule Manager and the activities. 

Note: Configuration of the Data Picker and Data Elements (and when 
applicable: Unique and Auto Sequence settings) must be done in 
uDesigner. 

Step 2: Set customer calendar permissions, if necessary. 

Step 3: Create a schedule sheet template. There are two places where you can create schedule 
sheet templates: At the company-level, under Templates > Schedule Sheets; and in project/shell 
templates. The process for creating schedule sheets is similar in both types of templates. 

Note: The advantage of creating schedule sheets in a project/shell is 
that when you clone a project/shell template, you can copy all schedule 
sheets in that template. 

After you have completed these steps, the Schedule Manager is ready for use in User mode. 

In This Section 

Additional Options for Setting Up the Schedule Manager ...................................... 493 
Importing an Activity Attribute Form ....................................................................... 494 
Create Schedule Sheet Templates ........................................................................ 494 
Deleting Schedule Sheets ..................................................................................... 496 
Grant Schedule Manager Permissions to Users .................................................... 496 
Refresh Schedule Sheet Data ............................................................................... 496 
Updating Schedule Sheet Properties from Templates ........................................... 497 
Update Schedule Sheet Activities from Templates ................................................ 499 
Importing Schedule Files ....................................................................................... 502 
Scope Management Setup .................................................................................... 510 
About activity-level editing ..................................................................................... 512 
Permissions for the System WBS Sheet ................................................................ 514 

Additional Options for Setting Up the Schedule Manager 

Configure a project/shell template schedule sheet as a Master Schedule Sheet. After cloning 
the project/shell, you can use the Master Schedule Sheet to create other schedule sheets in 
the project/shell that have the same sheet properties, including start and finish dates. 

 Link schedule sheets in a project/shell template to project/shell schedule sheets. 
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 Configure data mapping to allow direct importing of external sources such as Microsoft 
Project or Primavera schedules. 

Note: Many of the tasks you might perform as Administrator can also be 
done at the user level. The tasks you can perform only at the 
Administrator level are completely described in this section. For those 
activities that overlap levels, refer to the Unifier Managers User Guide for 
detailed instructions. 

Importing an Activity Attribute Form 

The Schedule Manager needs attribute forms to define the activities for a project schedule, 
including its start and end dates. 

When creating new activities on the schedule sheet, the system opens this form as the General 
tab of the Activity Properties form. 

Note: If there is no attribute form for the Schedule Manager, the system 
will create a default schedule sheet with the following columns: ID, 
Activity name, Start date, Finish dates, and Duration. 

The Resource Manager and the Schedule Manager can work together for resource 
management. If you have deployed the Resource Manager, the system uses the Resource 
Assignment Attribute form as the Resource tab of the Activity Properties form. 

To import and deploy a schedule attribute form or a resource assignment attribute form into 
Unifier Production environment, see Importing Configuration Packages (on page 619). 

Create Schedule Sheet Templates 

There are three locations for schedule sheet templates: in company Templates, in a project 
template, or in a shell template. Project and shell schedule sheet templates are copied into a 
new project or shell during cloning, provided you selected Schedule Sheets in the cloning 
window. 

The creation steps are similar for any schedule sheet template; however, Activity Properties in 
the company-level template only allow you to set up the General and Dependencies tabs. In 
project or shell schedule sheet templates, you can set up all properties. 

To create a schedule sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

 For a company-level template, in the left Navigator, click Templates > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > 
[shell template] > Schedule Manager > Schedule Sheets. 

2) To create the schedule sheet for the template, use the instructions on creating a schedule 
sheet in the Cash Flow section of the Unifier Managers User Guide. 

The Schedule Sheets can be created by using templates at the company-level. 
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Conditions for Creating a Schedule Sheets setup Configuration Package 

The first time that you package the Setup information, the Schedule Attribute and the Resource 
Assignment attribute designs must also be included in the configuration package. 

This means that the design must be included in the Configuration Package. If this check fails, 
then the package creation will result in an error. 

For subsequent exports, check will be made to ensure that the design which uses the Data 
Element that is specifically used in the setup is present in the Published package. As long as 
this condition is met, the package creation will be successful. If not, the latest design will have to 
be included in the configuration package. 

Schedule Sheets Components in the Configuration Package 

The system includes the following components of Schedule Sheets in the Configuration 
Package (.zip file): 

Component Field / Option 

Schedule Sheet Properties/ General All fields. Custom calendars should also be 
included in the configuration package. 

Schedule Sheet Properties / Gantt Chart All fields  

Schedule Sheet Properties / Tracking 
Gantt 

All fields 

Schedule Sheet Properties / Options All fields 

Schedule Sheet Properties / Schedule All fields 

Schedule Sheet / Activities No activity related information will be 
packaged, meaning no rows will be 
included. 

<Schedule Sheet Name> / Scope 
Management Setup (Applicable for shell 
templates) 

No Scope setup will be brought over since 
the scope is tied to an activity.  

Schedule Sheet / Data Mapping All fields. Dependency checks for inclusion 
of Schedule Attribute and Resource 
Assignment forms will be performed to see 
if the relevant designs are part of the 
package.  

Schedule Sheet / Budget and Progress 
Setup 

All applicable options 

Schedule Sheet / Column All columns defined in the sheet. If column 
definition is based on Cost Sheet definition 
then the Cost Sheet also must be included. 
If cost sheet column does not exist, then 
an error will be displayed. 
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Deleting Schedule Sheets 

This section describes how to manually delete a schedule sheet from a shell. 

Note: You can delete a schedule sheet from a specific shell template but 
not from other Projects/Shells that have been created using the 
template. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule 
Manager > Schedule Sheets. 

3) Select a sheet for deletion. 

4) Click Delete. 

5) When the confirmation message appears, click Yes to delete the schedule sheet. 

Grant Schedule Manager Permissions to Users 

After the Schedule Manager is active in a shell, you need to grant user permissions to the 
manager and the custom calendars. 

To grant user permissions to the Schedule Manager 

1) Open the shell where the Schedule Manager resides and switch to Admin mode. 

2) In the left Navigator, open the User Administration grouping node and click Access 
Control. 

3) In the right pane, under User Mode Access, click Schedule Manager to expand it. All 
functional sub-nodes can have their permissions edited, including Custom Calendars, 
Schedule Sheets, and Activity Sheets. 

4) In the Permission Settings window, click the Add button. The User/Group Permissions 
window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 

6) Select the user(s) to whom you want to give permissions and click the Add button. The 
system adds the name(s) to the Permission/Access Control window. 

7) Under Permission Settings, select the permissions you want to grant the user(s) and click 
OK. The system adds the name(s) to the Permission Settings window. 

8) Click OK. 

Refresh Schedule Sheet Data 

A schedule sheet refresh updates cost data associated with the schedule sheet. During the 
refresh, the system recalculates dates, activity role rates, and costs if there were any changes to 
the schedule sheet, such as copying rows into the sheet. Alternatively, you can set up a 
schedule to automatically refresh the sheet data. 

Note: A scheduled refresh can fail if (1) an activity has more than one 
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CBS code, or (2) a cost sheet column to which a schedule sheet column 
is associated is deleted from the cost sheet. 

To manually refresh schedule sheet templates 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Schedule Sheets in the left Navigator. 

Schedule sheet templates that require refreshing are shown on the Schedule Sheet log with 
a refresh icon: 


3) Select a template and click the Refresh button. 

To set up a refresh schedule 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule 
Manager > Schedule Sheets. 

3) On the Schedule Sheets log, select one or more schedule sheet templates. 

4) Choose Refresh > Set Frequency. 

5) Select the Enable scheduled refresh check box. 

6) Select the Frequency and the Range of Recurrence. 

7) Click OK. 

Manual Schedule of Activities 

When auto-scheduling is disabled, you will be able to manually determine the schedule of 
activities, if desired. You can do this by refreshing it through manual Schedule refresh, Cost 
and Schedule refresh or enabling Schedule refresh. 

When you refresh the schedule, the entire schedule sheet will be re-scheduled, according to the 
latest dates entered in the Activity Property. 

When auto-scheduling is disabled, user will be able to manually determine the schedule of 
activities, if desired. This can be done by refreshing it through manual Schedule refresh, Cost 
and Schedule refresh, or enabling Schedule refresh. 

When you refresh the schedule, the entire schedule sheet will be re-scheduled, according to the 
latest dates entered in the Activity Property. 

Updating Schedule Sheet Properties from Templates 

If you create project or shells with a template, you can update schedule sheet properties in the 
projects and shells from schedule sheets in the template. Both the source and destination 
schedule sheets must have the same name. 

What you can do with Schedule Sheet Update: 

 Change the schedule's status (active/inactive) 
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 Change auto-control (on/off) 

 Change auto-update options 

 Change the scheduled refresh frequency 

 Change the schedule's calendar 

 Change the schedule start date, unless there are activities already in progress or 
completed 

 Change activity level access 

 Change Gantt chart bar labels and dates 

Note: Updates of linked schedule sheets do not occur to sheets in 
projects or shells that have Inactive or View-Only status. 

Calendars and Linked Schedule Sheets

When a schedule sheet is initially linked, any calendar associated with that schedule sheet is 
copied over with the sheet. However, when there are any subsequent updates to the linked 
sheet from a template, the calendar is not again updated on the sheet. 

To update schedule sheet properties from project or shell templates 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule 
Manager > Schedule Sheets. 

3) From the Schedule Sheets log, select the schedule sheet to push. 

Both the source and destination schedule sheets must have the same name. 

4) Click the Update button and choose Properties > [shell] or All Shells. 

5) Select shells to update and click Update Shells. 

An Options window opens. 

6) On the Options window, select the properties to update: 

 Description 

 Status 

 Auto-control: You can still manually initiate business processes. The system disregards 
predecessor/successor dependency relationships when you manually start an activity, 
even if auto-control is set to On in the schedule sheet properties. 

 Auto-Schedule 

 Calendar 

 Schedule Start Date: You can only change the schedule start date if there are no 
activities in progress or completed. Changing the start date can prompt the system to 
recalculate and roll up resource amounts. 

 Notify users and/or group on errors 

 Enforce Group Permission 

 Auto update activity status based on Actual Start/Finish Date 

 Activity Progress requires an Actual Start date 

 Schedule Refresh Properties 
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 Enforce Activity 100% Complete against Actual Finish date 

 Auto-Update % after entering Actual Finish Date 

7) Click OK. You will receive a confirmation of the update. Click OK. 

View schedule sheet properties update history 

To view update history: 

1) From the Schedule Sheets log, select the schedule sheet with the updates you want to see. 

2) Click the Update button and select History. The Update Shells History window opens. This 
window lists the update history for each submitted update. 

3) Click the Close Window button when you are finished viewing the history. 

Auto-Scheduling 

If the auto-scheduling is enabled for the template, then the properties (Update > Properties) in 
the destination Shell Schedule Sheets (with the same name as the template Schedule Sheet) 
will be updated. That is to state that the destination will also have automatic re-scheduling 
enabled and refreshed to reschedule the Activity Data. 

If the auto-scheduling is disabled for the template, then the properties (Update > Properties) in 
the destination Shell Schedule Sheets (with the same name as the template Schedule Sheet) 
will be updated. That is to state that the destination will also have automatic re-scheduling 
disabled. 

The Start Date, Duration, or Finish Date of particular Activity can be changed upon template 
push, but because auto-scheduling is disabled, none of the changes will be reflected in 
dependent activities. 

Update Schedule Sheet Activities from Templates 

If you create project or shells with a template, you can update schedule sheet properties in the 
projects and shells from schedule sheets in the template. Updating Schedule Sheet Properties 
from Templates (on page 497). 

You can also update the activities on a schedule sheet by using a separate "linking" function that 
links a schedule sheet to a template for the specific purpose of updating activities. This feature is 
also convenient if you have imported a schedule and want to push it to your projects or shells. 

Note: Projects or shells that are in Inactive or View-Only status will not 
be updated. 

What you can do with Linked Templates: 

If you link a schedule sheet to a template in this way, you can use the template schedule sheet 
to push the following changes to sheet columns and activities: 

 Imported CSV or MPP files to the destination sheet 

 Added activities 
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 Changes to activity status 

 Changes to column order 

 Added new columns 

 Removed column 

 Hidden columns 

 Column indents and outdents 

What you cannot do with Linked Templates: 

 Change schedule sheet properties, activity dates, CBS codes, or activity resources. 

 Delete activities 

 Modify activity name or code associations 

 Modify Scope Management setup 

After you link a schedule sheet to a template in this way, users can change dates and other data 
on the sheet, but they cannot add activities, delete activities, or otherwise change the structure 
of a sheet. You can only change the structure of the sheet and activities by changing the 
template and pushing the changes to the project/shell sheets. 

Permissions

You do not need to have permission on the destination schedule sheet in order to update the 
sheet via a project/shell template schedule sheet. You must have the Edit Structure and Data 
permission to set up linked schedule sheets. 

Enable and Disable Schedule Sheet Linking 

Before you can link project or shell schedule sheets to a template for updating, you must enable 
the template for linking. 

To enable linking for a schedule sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

3) For a shell template, in the left Navigator, click Templates > Shells > [shell type] > [shell 
template] > Schedule Manager > Schedule Sheets. 

4) On the Schedule Sheets log, select a Schedule Sheet template. 

5) From the Edit menu, select Sheet Linking > Enable. 

To disable linking for a schedule sheet template 

1) On the Schedule Sheets log, select a Schedule Sheet template. 

2) From the Edit menu, select Sheet Linking > Disable. 

Disabling Sheet Linking disconnects all project/shell schedule sheets from the linked 
template; the schedule sheets can no longer receive updates from the template. 
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Link a Template to a Shell Schedule Sheet 

1) On the Schedule Sheet log, select the schedule sheet template that you want to link. 

This template must have been enabled for linking. (See Enable and Disable Schedule 
Sheet Linking (on page 500).) 

2) Choose View > Linked Schedule Sheets. 

The Linked Schedule Sheets window opens, listing the schedule sheets that are currently 
linked to the template. 

3) Click Add. The Add Schedule Sheets window opens. 

This window lists Active and On-Hold projects or shells and the corresponding active 
schedule sheets for those projects or shells. 

4) Select one or more schedule sheets and click Select. You will receive a confirmation 
message that the data in the newly linked sheet will be modified when the update is 
completed using the link between the template and the sheet. 

When you link a schedule sheet to the template, the system: 

 Deletes the existing data on the project/shell schedule sheet, including all activities, 
columns and cell data 

 Retains the schedule sheet properties, including the Schedule Start Date 

5) To link the sheets, click OK. 

6) When you are finished adding linked sheets, click Close Window. 

Update Linked Schedule Sheets from Shell Templates 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

3) For a shell template, in the left Navigator, click Templates > Shells > [shell type] > [shell 
template] > Schedule Manager > Schedule Sheets. 

4) On the Schedule Sheets log, select the Schedule Sheet template that should update the 
activities on the linked schedule sheets. 

5) Click Update > Linked Schedule Sheets. 

The system will update the activities and columns on all the schedule sheets that are linked 
to the template. It will not, however, push changes to activity dates. 

Impact on Scope Management 

Scope Management setups that are updated through the use of linked schedule sheets allow 
updates to any activities that are not yet initiated. This includes business process name, 
responsible users, duration flag, completion conditions. 

Unlink a Template From a Shell Schedule 

1) On the Schedule Sheet log, select the schedule sheet template that you want to unlink. 

2) Choose View > Linked Schedule Sheets. The Linked Schedule Sheets window opens, 
listing the schedule sheets that are currently linked to the template. 
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3) Select the sheet you want to unlink and click Remove. 

The system will disconnect the schedule sheet from the template. 

4) Repeat steps 2 and 3 for any other sheets you want to disconnect from the template. 

5) When you are finished unlinking sheets, click Close Window. 

View Linked Schedule Sheets 

You can view a list of schedule sheets that have been linked to the template. These are the 
destination schedule sheets that update when you push changes from the template. 

To view linked schedule sheets 

1) On the Schedule Sheet log, select the schedule sheet template. 

2) Choose View > Linked Schedule Sheets. Schedule sheets that are available for updating 
from the linked schedule sheet template are listed in the Linked Schedule Sheets window. 
Master schedule sheets are listed as well as non-master sheets. 

3) When you have finished viewing the linked sheets, click Close Window. 

Auto-Scheduling 

If the user clicks on Update > Linked Schedule Sheets, only the Activity Data will get updated 
on the destination (linked) Schedule Sheets from the template, and not the sheet properties. 

 If Auto-scheduling is enabled in the Linked (destination) Schedule Sheet, then after the 
Activity Dates update through Update> Linked Schedule Sheets, the re-scheduling will 
take place. 

 If Auto-scheduling is disabled in the Linked (destination) Schedule Sheet, then only the 
Activity Dates is updated and no re-scheduling occurs. That is to state that the change will 
be reflected in dependent activities. 

Importing Schedule Files 

Unifier supports working with schedule files such as Primavera. After you import these schedule 
files, your external data becomes available. In the application, users have access to the 
Schedule Manager's analytical tools. For example, they can forecast project costs, monitor 
project progress at the activity and resource levels, and track earned value with schedule data. 

If users assign resources in non-Unifier software, Unifier will soft-book those resource 
assignments, provided you created a data set for those assignments (see Add Data Set Values 
to a Pull-down (Drop-down) Menu or Radio Button (on page 204)). 

Overall steps to import schedule files 

1) Save the schedule files. 

For Primavera XML files 

a. Export the Primavera file to XML. 

b. Modify the XML file to use with web services, as described in the Unifier Integration 
Interface Guide. 
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c. Select Import distribution data from external source (refer to the "Select the activity 
budget distribution profile" section in the Unifier Managers User Guide). 

For Microsoft Project files 

d. Save the files as MPP, or export the Microsoft Project file to CSV or XML. Use this file as 
a template. 

2) Define data mapping. 

3) Import the CSV or XML files to create or modify schedule sheet activities. 

Primavera Considerations 

For Primavera:  

 Unifier Schedule Manager integrates with Primavera scheduling software by way of Web 
Services. 

 Unifier retains the Primavera Current Data Date entry when calculating earned value 
(BCWS, BCWP, ACWP, EAC). 

 When importing Primavera XML files into Unifier, you must configure the number of CBS 
code segments, and you can specify a suffix mask. 

 Refer to the Unifier Integration Interface Guide for data elements you can use with Web 
Services. 

Microsoft Project Considerations 

Unifier uploads Microsoft Project directly into a schedule sheet. 

 To use the Activity Calendar from Microsoft Project, first create a calendar in Unifier with 
the same name as the external calendar. Refer to "Create a custom calendar in the 
schedule manager" in the Unifier Managers User Guide for additional information. 

 To import Resource Assignments from Microsoft Project, first add the same MPP 
resource types to the SYS Resource Type data set in Unifier. Oracle recommends using 
MPP standard resource types: Work, Material, and Cost. (See Working with Data 
Definitions (on page 197).) 

 Configuring CBS code segments is not necessary for Microsoft Project. See CBS code 
options for Primavera XML and Microsoft Project XML (on page 508). 

Overall steps to import third-party schedule files 

1) Save the third part schedule files. 

For Microsoft Project files (this is available through the user interface, only): 

 Save the files as MPP or export the Microsoft Project file to CSV or XML. 

 Use this file as a template (the MPP files do not require mapping). 

For Primavera XML files (this is available through the Web Services, only): 

 Export the Primavera file to XML. 

 Modify the XML file to use with web services, as described in the Unifier Integration 
Interface Guide. 

 Select Import distribution data from external source (refer to the "Select the activity 
budget distribution profile" topic in Unifier Managers User Guide). 
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2) Define data mapping. 

3) Import the CSV or XML files to create or modify schedule sheet activities. 

Define Data Mapping 

Data mapping establishes a 1 to 1 association between fields in a Unifier schedule sheet and a 
schedule sheet, such as Primavera P6. The data map creates a CSV or XML file into which the 
data from the external schedule can be loaded. Once loaded with data values, these files can 
then be imported into a Unifier schedule. 

You can create multiple data maps and select the data mapping you want to use when you 
import the schedule files to create or modify schedule sheet activities. 

Note: You must create at least one mapping. Unifier will use this 
mapping as a default if there are no others. 

Unifier supports multiple data formats: CSV, MPP, MPP XML, P6 XML. You must map any 
specific fields from an external source that you want to see in the application. 

Data format Data mapping requirements 

CSV 
Requires mapping; you can select the 
mapping when you upload the file. 

MPP 

Mapping is not required. Imported fields 
are limited to Start Date, Finish Date, and 
Duration. 

Do not select a default data mapping if you 
will be asking Unifier to consider an activity 
calendar. 

Primavera XML Requires default data mapping. 

Microsoft Project SML 
Requires mapping; you can select the 
mapping when you upload the file. 

To define data mapping 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

3) In the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule 
Manager > Schedule Sheets. 

4) From the Schedule Sheets log, open the Schedule Sheet template you want to map. 

5) Choose File > Data Mapping. The Data Mappings window opens. 

The Data Mappings window lists any mappings created for schedules such as Primavera P6 
or Microsoft ® Project. 

If a mapping on this list is marked as the default mapping, Unifier will use this mapping when 
the schedule is imported. If you do not mark a mapping as the default, Unifier will prompt the 
users to select a mapping whenever they import a schedule. 
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6) Click Add. The Data Mapping window opens. 

7) On the General tab, enter the name and the description for the data mapping and click 
Apply. 

8) Click the Activity tab. 

Use this tab to create the structure of the CSV or XML file for the export and import 
operations. On this tab, you can map schedule sheet columns to external CSV headers and 
XML tags in order to import or export activity information. 

a. Click the Add button. Another data mapping window opens. 

b. Use the information in the first table below to complete the fields on this window. 

9) (Optional) On the Resources tab, you can map resource information through XML 
integration. Enter the header in the XML element that corresponds to the column. 

Note: Mapping resources is mandatory only if you select Import 
Resource Assignments on the Options tab. 

a. Click the Add button. Another data mapping window opens. 

b. Select the column and enter the header in the XML element that corresponds to the 
column. 

10) Click Apply on the Resources tab. 

11) Click the Options tab. On this tab, you can configure XML options that are used when 
importing data. 

12) Use the information in the second table below to complete the fields on the Options tab. 

13) Click OK. 

Data format Data mapping requirements 

Column 
Select the data elements you want to import. Minimum required fields for 
XML import are Activity ID, Activity Name, Start date, Finish date, and 
Duration. 

CSV Header Enter the CSV header from the external source. 

XML 
Element 

Enter the XML from the external source 

In this field: Do this: 

XML Import 
Define options for importing XML activity schedules into Unifier. 
Importing data, from the Unifier Schedule Sheet, only supports Microsoft 
XML. The P6 XML is supported through Web Services.  

Options 

You can either retain existing schedule information in Unifier, or 
overwrite it complete upon importing an external XML file. 

 Merge into existing schedule. With this selection, you have a 
sub-option to Delete Activities removed from the source schedule. 

 Overwrite existing schedule replaces the existing schedule. 
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Data 
Elements 

Select the appropriate check boxes if you want to import activities (rows),

Activity Dependencies: Select this check box to retain activities from 
the XML source file. 

Activity Calendar: Select this check box to retain the activity calendar 
from the XML source file. If imported, the activity calendar will trigger the 
recalculation of activity dates as needed, and will override any existing 
activity calendar association. If a calendar is not imported, the activity will 
use the existing calendar defined in the Schedule Sheet properties. 

Note: There must be a calendar in Unifier with the same name as the 
calendar in the import file. 

Resource Assignments: Select this check box to retain the resource 
assignments from the XML source file. If you want to import resources, 
define the resource types for the data definition SYS Resource Type. For 
Microsoft Project files, use standard resource types: Work, Material, and 
Cost. Upon import, these resource types will soft book. 

CBS Codes: Select this check box to import CBS codes. See CBS code 
options for Primavera XML and Microsoft Project XML (on page 508) 
for details. 

Number of Levels: (for Primavera XML only) Specify the segments that 
should be considered in the Primavera XML file for the codes (from 1 to 
9) and the CBS code suffix mask. See CBS code options for 
Primavera XML and Microsoft Project XML (on page 508) for details. 

Suffix Mask: (for Primavera XML only) You can use a constant or a data 
element value in the Suffix Mask. 

 To use a constant in the Suffix Mask, click the Constant radio button, 
and enter the suffix you want to have appended to the CBS code. 

 To use the value from a data element in the Suffix Mask, click the 
Data Element radio button and select a data element. 

XML Export Define options for exporting through XML into another application 

Data 
Elements 

Select the appropriate check boxes if you want to export activities (rows), 
and whether to include dependencies, resource assignments, and/or 
CBS codes. 

CBS Code Options for Primavera XML and Microsoft Project XML

Unifier can recognize the CBS codes imported through XML files and match these codes to 
equivalent codes in a project/shell cost sheet. For Primavera XML files, you need to specify the 
Number of Levels and a Suffix Mask. (The codes in Microsoft Project XML files are 
automatically resolved by Unifier when the file is imported.) 

The number of levels specifies the number of segments that should be included to build CBS 
codes based on data from the Primavera XML file. The number of segments considered starts 
from the top of the imported XML file. If you specify a number of segments and the data in the 
XML file has fewer segments than that number, then all segments are processed. 
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The Suffix Mask you enter is added to the CBS code elements that Integration derives from the 
XML file. The CBS code derived from the XML file with the mask is validated against the CBS 
codes (leaf level) created for the project/shell Cost Sheet. 

While deriving the CBS codes from the XML file, Integration separates segments retrieved from 
the XML file with the cost code separator specified in uDesigner). When specifying the Suffix 
Mask, be sure to use the same cost code separator if the mask contains more than one 
segment. 

Import CSV, XML, or MPP files to create or modify schedule sheet activities 

After you have saved the schedule files in an importable format (CSV, XML, or MPP) and 
defined the data mapping, you are ready to import the files into the Unifier schedule sheet 
template. 

To import a CSV file 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

3) In the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule 
Manager > Schedule Sheets. 

From the Schedule Sheets log, open the Schedule Sheet template into which you want to import 
the schedule. The Schedule Sheet template opens. 

1) Choose File > Import > From CSV. 

When you import the file, you can select the data mapping you want to use for the importing 
files. If a default mapping was created, you will not have to select a mapping. If not, Unifier 
will display a Select Data Mapping window. If this window opens, select the data mapping 
you want to use for this import and click OK. 

The File Upload window opens. 

2) Browse to select the CSV file to upload. 

3) Click OK. 

To import XML and MPP files 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator.  

3) In the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule 
Manager > Schedule Sheets. 

4) From the Schedule Sheets log, open the Schedule Sheet template into which you want to 
import the schedule. The Schedule Sheet template opens. 

5) Choose File > Import > From External Source. 

When you import the file, you can select the data mapping you want to use for the importing 
files; however, in some cases, MPP files do not require that you to select a data mapping. 

If a default mapping was created, you will not have to select a mapping. If not, Unifier will 
display a Select Data Mapping window. If this window opens, select the data mapping you 
want to use for this import and click OK. 
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6) Use the table below to complete the fields in this window. 

7) Click OK. The File Upload window opens. 

8) Browse to select the file to upload. 

9) Click OK. 

In this field: Do this: 

MPP 
Data mapping is not required; leave the 
Data Mapping field empty. 

MPP XML 
Data mapping is required; select the 
mapping you want to use. 

MPP activity calendar 

Select Consider Activity Calendar. 

Note: This requires an existing calendar in 
Unifier with the same name. See Creating 
Multiple Calendars (on page 218) 

If an activity calendar is not imported and 
considered, the activity will use the existing 
calendar defined in the schedule sheet 
properties. 

MPP Resource assignments 

Data mapping is not required; leave the 
Data Mapping field empty. 

Note: This requires a data set for the SYS 
Resource Type data element. See Add a 
Basic Data Definition (on page 202). Use 
MPP standard resource types: Work, 
Material, and Cost. Upon import, Unifier 
will soft-book these resource types. 

CBS code options for Primavera XML and Microsoft Project XML 

Unifier can recognize the CBS codes imported through XML files and match these codes to 
equivalent codes in a project or shell cost sheet. 

To enter the CBS code options 

1) On the Data Mapping Options tab, select the CBS Codes check box. 

2) Enter the Number of Levels (from a minimum of 1 to a maximum of 9). This specifies the 
number of segments that should be included to build CBS codes based on data from the 
Primavera XML file. The number of segments considered starts from the top of the imported 
XML file. If you specify a number of segments and the data in the XML file has fewer 
segments than that number, then all segments are processed. 

Note: You must enter a number of levels if you select the CBS Codes 
check box. However, for Microsoft Project XML files this value is ignored. 
The CBS Codes are resolved automatically by using the CBS code 



Setting up the Schedule Manager

509

element in the Microsoft Project XML schema when the Microsoft Project 
XML file is imported. 

3) Optionally, (for Primavera XML only) enter the Suffix Mask you want to use for the CBS code 
mapping. The mask you enter is added to the CBS code elements that Integration derives 
from the XML file. The CBS code derived from the XML file with the mask is validated 
against the CBS codes (leaf level) created for the project or shell Cost Sheet. 

While deriving the CBS codes from the XML file, Integration separates segments retrieved 
from the XML file with the pre-defined Cost Code Separator (previously defined under Data 
Definitions in uDesigner). When specifying the Suffix Mask, be sure to use the same Cost 
Code Separator if the mask contains more than one segment. You do not need to start the 
Suffix Mask with the Cost Code Separator. Unifier will add this separator to combine the CBS 
codes derived from the XML file and the Suffix Mask you enter. 

You can use a constant suffix, or use the value of a data element as a suffix: 

 To use a constant in the Suffix Mask, click the Constant radio button, and enter the suffix 
you want to have appended to the CBS code. 

 To use a data element values in the Suffix Mask, click the Data Element radio button and 
select a data element. 

4) Click OK. 

Primavera XML and Microsoft Project XML CBS Code interpretation 

The data Unifier derives from the Primavera XML file consists of CBS Code segments, and 
activity and resource data. Upon import, a tree of CBS code elements are combined to form a 
CBS Code. Each element is a segment of a CBS code. The Activity element is attached to last 
node of the CBS Code segment. Activity Resource Assignment information is considered. 

This is an example of CBS code structure during import from an XML file: 

<CBS 1> 

<CBS 11> 

<CBS 111> 

<Activity A> 

In above example, actual CBS Code is <CBS 1>.<CBS 11>.<CBS 111>. Activity A contains a 
reference to its parent (<CBS 111>) CBS code segment. When processing the import of the 
XML data, Unifier first checks the Activity CBS code element and then builds the rest of the CBS 
code by moving up the CBS tree structure. In this example, Activity A has CBS 111 as a 
reference and Unifier uses the structure to build the CBS code as CBS 1.CBS 11.CBS 111. 

After this CBS code is built, a Suffix mask (for Primavera XML files) is added to the beginning 
and end of the derived CBS code to create a Unifier CBS code. When this code is created, it is 
validated against the CBS code created in the project or shell Cost Sheet. 

If an activity is moved from one CBS code to another CBS code, Unifier will move the activity 
during the XML file processing. If an activity or CBS code is deleted in the imported XML file, 
and the same activity exists in Unifier, Unifier will not delete that activity or CBS code. 
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Note: Importing data, from the Unifier Schedule Sheet, only supports 
Microsoft XML. The P6 XML is supported through Web Services. 

Updating User Information in Schedule Sheet Properties Using Bulk Processing 

You can use bulk processing to update user information in schedule sheet properties for a large 
number of sheets. This user data pertains to the groups or individual users who are notified of 
errors and also the groups who are given activity-level permissions. You can perform this bulk 
processing at the shell or project level. 

Note: You can update 200 records at a time using bulk processing. 

To add or remove user group assignments in bulk 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Shells, and select the applicable shell type. 

3) In the log on the right pane, select the shell(s) that you want to update. 

4) From the Actions menu, select Export > Export Schedule Sheet Properties. 

This will export the current properties for all the schedule sheets for the selected shells or 
projects to a CSV file. 

5) Click Open to open the CSV file, or Save to save the file to your desktop. 

6) Modify the sheet in the CSV file as needed. 

All column values are required, except for Notify Users and Notify Groups. Group and user 
names are separated by semi-colon (;). 

7) Save the CSV file when you are finished modifying the user group assignments or adding 
new users. 

8) Navigate back to the log and select Import > Import Schedule Sheet Properties from the 
Actions menu. 

9) Upload the modified CSV file and click OK. 

You will receive an email notification when the update is finished. 

Scope Management Setup 

Scope management is a framework that defines deliverables, responsible roles, actual 
assignees and their schedules. In other words, Scope Management drives coordinated 
production of these deliverables. Scope Management initiates actions for producing deliverables 
based on the completion of dependencies. It routes them to responsible person/group, monitors 
their completion and updates deliverable statuses automatically. It manages different activities 
across schedules for different team members simultaneously. 
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Note: Scope Management is not available for launching non-workflow 
business processes. 

This feature allows you to use existing Schedule Management functionality with added data 
elements to automate the management of a project's scope and schedule with all associated 
activities, tasks, and deliverables. This feature provides project managers with the ability to 
manage each scope item's task assignments, ownerships, and durations. 

Project managers can use Scope Management as the solution to manage high volume, 
quick-turn around projects that have standardized scope and scheduled activities. Examples of 
projects that would benefit from the use of Scope Management functionality are retail 
construction projects such as bank branches or chain fast food restaurants. Scope Management 
capabilities are also useful for large capital projects with complex scope and schedules, and that 
have numerous dependent activities and milestones with associated tasks and deadlines. 

Scope Management coordinates the creation of the defined deliverables using the schedules of 
the various assignees, and automatically moves tasks to the next assignee. Scope Management 
then routes tasks related to the deliverables to the next responsible assignee (person or group), 
monitors the state of the tasks, and updates deliverable status automatically. Actions for the 
creation of deliverables are based on fixed time durations and the completion of dependencies. 

This functionality can be enabled on any schedule sheet, including a Master schedule sheet. 
Scope Management enables you to link BPs with schedule sheet task activities and route those 
BPs, with automatic update of status as they are routed and worked on. The BPs represent the 
work that needs to be done to complete the task. Also, you can override the automatic routing at 
any time and launch the activity-associated BPs manually. The BP-related task is deemed done 
when specified completion conditions are met. 

Setting up Scope Management for Activities 

After you create the project/shell-level schedule sheet template at the company level, you can 
set up the following for each activity: 

 Linked BP 

 Responsible users or groups 

 Due date 

 Completion conditions 

To set up Scope Management for an activity 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule 
Manager > Schedule Sheets. 

The Schedule Sheets log opens. 

3) Select the template from the log and click the Open button, or double-click the selected 
template. The schedule sheet template opens. 

4) To set up scope management for the template, use the instructions in the Unifier Managers 
User Guide on setting up scope management for activities. 
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About activity-level editing 

At the project shell level, you can configure the Schedule Sheet so that specific cells can be 
edited only by designated groups of users. In a project, the project manager is usually 
responsible for the entire schedule, with various activity owners responsible for managing dates 
on specific project tasks. Enforcing activity-level editing controls the users and groups who can 
edit certain data, such as group-specific start and finish dates for activities. 

Notes: 

 You can set up the activity-level editing restrictions in a template, and 
the editing control configuration will be copied into any schedule 
sheet created from that template. 

 The system will ignore any data imported through CSV or XML for 
restricted fields. If there is any failure in validation, the system will 
stop the import. 

 The Gantt Chart will be disabled if the Start, Finish, and Duration 
fields are restricted. 

Activity-level editing allows the project manager and other activity owners to collaborate on a 
project and discuss the impact of changes to start and finish dates across the entire schedule. 
This collaboration allows the project manager or activity owners to enter new start and finish 
dates for activities without immediately affecting the start and finish dates for all activities. The 
editing restrictions prevent the proposed dates from affecting the entire schedule before the 
dates are approved or adjusted. Only those users with appropriate permissions can edit 
restricted dates. 

Note: Updates that occur from Activity Sheets are also subject to 
activity-level editing restrictions if the restrictions are configured on the 
corresponding schedule sheet, as are updates from CSV import or Web 
Services Integration. 

The following table shows an example of the impact on dates in a schedule sheet with 
activity-level editing configured, and with activities and group-specific date columns. In this 
example, the groups Const, IT, and ATM all have group-specific start dates and finish dates for 
activities: 
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A less restrictive implementation of activity-level editing allows specific groups to edit all cells in 
selected rows. In this implementation, when project manager changes activity start or finish 
dates, those changes could affect other dates in the schedule, due to dependencies among the 
activities: 

Set up Activity-level Editing 

Before you set up activity-level editing: 

 Be sure the Activity Attribute form has been designed to include the Filtered Group data 
element and any group-specific start date and finish date data elements. For more 
information, see Schedule Manager Overview in the Unifier uDesigner User Guide. 

 Be sure the Add the Filtered Group data element and any group-specific date data elements 
have been included as columns on the schedule sheet. 

 Create the groups who should have permissions for activity-level editing. For more 
information, see User Administration in the Unifier General Administration Guide. Be sure 
not to include the project manager in any of these groups (as the group manager, for 
example), as this will result in conflicting permissions if later you add any restrictions to the 
columns schedule sheet. 

 Give these groups the View All Sheets permission for the Schedule Sheets for the 
project/shell. Do not grant Full Access permissions, as that will override any activity-level 
configuration to restrict editing. 

To set up activity-level editing 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

3) In the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule 
Manager > Schedule Sheets. 

The Schedule Sheets log opens. 

4) On the Schedule Sheets log, select the schedule sheet and click the Permission button on 
the toolbar. The Edit Permission window opens. 

5) Add the group or groups for activity-level permissions and specify Edit Data in the 
Permissions section of the window. 

6) Give the project manager Modify Permission. 
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7) Click OK. 

8) Click the Properties button on the toolbar. 

9) On the General tab, select the Permissions: Enforce Activity Level Permission by Group
check box and select a Default Group from the drop-down list. 

10) Open the schedule sheet (either in the template or in the project or shell). 

11) Under the Filtered Group column, click the activity for which you want to specify editing. 

12) From the drop-down list, select the group you want to have activity-level editing permission. 

The group selection you make in the activity row controls the access for editing that activity. 
For example, if you select IT Group as the Filtered Group for an activity, then only users who 
are members of the IT Group can modify data for that activity (in that row). 

Note: For a less restrictive, row-level implementation of activity-level 
editing, you can stop here and not perform the next step, which provides 
further restrictions to the cell level. 

To set up more cell-level editing restrictions 

In addition to activity-level editing permissions, and can use column restrictions to enforce that 
only certain groups can edit certain cells. For example, for project managers, you could restrict 
the group-specific date columns only. For the activity-owner groups, you could restrict access to 
all columns except for the group-specific date columns. For example, for the IT Group, you could 
restrict access to all columns except for IT Start Date and IT End Date. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

3) In the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule 
Manager > Schedule Sheets. 

The Schedule Sheets log opens. 

4) Open the schedule sheet you want to restrict. 

5) From the File menu, choose Restrictions. The Restrictions Setup window opens. 

6) Under User/Group Name, add the user or group name whose access you want to restrict. 

7) Under Activity Restriction Settings, choose the fields on the sheet that you want to restrict. 

8) (Optional) Under Resource Assignment Restriction Settings, choose the resource-related 
fields on the sheet that you want to restrict. 

Permissions for the System WBS Sheet 

Currently, the Unifier administrator can grant the Modify and View permissions for the System 
WBS Sheet that is auto-created through gateway integration from P6 or Oracle Primavera 
Cloud. 

The WBS Sheet permission allows the user to create a manual WBS Sheet, if one does not 
exists. By default, this permission will be deselected. This permission can be selected for any 
user or group. 

To grant permission to create a manual WBS Sheet from the log to capture the work breakdown 
structure for the project: 
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1) From the left Navigator, open the User Administration grouping node and click Access 
Control. 

2) In the Access Control log, click to expand the User Mode Access. 

3) Click Activity Manager to expand it. 

4) Click WBS Sheet to open the Permissions Settings for: WBS Sheet window. 

5) Select from the following permission settings: 

 Modify 

 View 

 Hide Audit Log 

 Create Manual WBS Sheet 

The "Modify" and "View" permissions are available for System WBS Sheet. 

A user with "Modify" permission can do the following in a manual WBS Sheet, as well as 
conducting edits on a System WBS Sheet: 

 Manage WBS 

 Add new WBS rows 

 Update existing WBS rows 

 Delete the WBS rows that are not used 

 Update column structure 

A user with "View" permission can do the following in a manual WBS Sheet and System WBS 
Sheet: 

 View the data including WBS details and transaction details for costs. 

 Switch between manual WBS Sheet and System WBS views, by using the Project field 
(drop-down). 
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Setting up the Earned Value Management 
Permissions 

You can assign Earned Value Management permissions in the following permissions-related 
modules: 

 Permission Templates under Standards & Libraries

 Access Control, and Users / Groups under User Administration

Permissions correspond to the: 

 Activity Manager and it sub-nodes 

 Earned Value Analysis in shell (User mode) 

 Master Rate Sheet in the Company Workspace (User mode). 

In addition, Gateway configuration permissions are required to set up the synchronizations at the 
Company Workspace (Admin mode level). 

Assumptions

Permissions for other related areas (Exchange Rates under Standards & Libraries) are 
granted at the Company Workspace (Admin mode level), and permissions to modify 
properties of the shell types under Company Sponsored Shells are also given. 

The Permission Settings values for the Earned Value Analysis Report (EVA Report) are: 

 Full Access

 Create

 View

 View and Run

In This Section 
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Gateway Permissions 

The permissions for Gateway are as follows:  

 Configure

 Get/Send Activity Sheet Data
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Master Rate Sheet Permissions 

The permissions for Master Rate Sheet are as follows:  

 Get Data

If this permission is enabled, user will be able to take action "Get Data" for Master Rate 
Sheet (Company Workspace) which will update the roles and resources list from P6. When 
Get Data is checked, the "View" permission gets checked automatically. User has the ability 
to deselect the "View" permission. This automatically deselects "Get Data" permission. Thus, 
the user cannot have "Get Data" permission without the "View" permission but can have 
"View" permission without the "Get Data" permission. 

 View

If this permission is enabled, the user will be able to view the Rate Sheet node at company 
workspace along with the Master Rate Sheet present in that node (if applicable). 

 Create

If this permission is enabled, the user will be able to create the Rate Sheet and Master Rate 
Sheet.  

Activity Sheet in Shell (User Mode) Permissions 

The permissions for Activity Sheet in a shell (User mode) are as follows: 

 Send Data

 Get Data - All

If this permission is enabled, user will be able to take action ‘Get Data" for system Activity 
Sheet which will update the system Activity Sheet from P6. When Get Data is checked, the 
"View All" and "View Current" permissions are not selected automatically. 

User has the ability to deselect the "View" permission. This automatically deselects "Get 
Data" permission. Thus, the user cannot have "Get Data" permission without the "View" 
permission but can have "View" permission without the "Get Data" permission. 

 Get Data - Current

If this permission is enabled, when user clicks on Get Data, the user can only get the current 
project data from P6, the user cannot get the baseline project data from P6. 

 Modify - All

If this permission is enabled, then the user can modify both baseline and current P6 project 
data. 

If Modify - All permission is given, the user will be given view All permission implicitly even if 
the permission has not been selected. 

 Modify - Current

If this permission is enabled, the user can only modify the current P6 project data. 

The user will be given View - Current permission implicitly even if the permission has not 
been selected. 

 View - All

If this permission is enabled, then the user can view both baseline and current P6 project 
data, present in the Activity Sheet. 
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 View - Current

If this permission is enabled, then the user will be able to view the Activity Sheet sub-node 
along with the Activity Sheet present in that node (if applicable). 

 Full Access

If this permission is enabled, then the user will get full access to the Activity Sheet with all the 
permissions mentioned above. In addition, the user can see the schedule tab, where the user 
can schedule the Gateway synchronizations. 

 Create Manual Activity Sheets

If this permission is enabled, then the user will be able to:  

 Create, update, delete, and view all sheets. 

 Receive and send the scheduling and resource spread data into the Activity Sheet from 
P6 or Oracle Primavera Cloud. 

Rate Sheet in Shell (User Mode) Permissions 

The permissions for Rate Sheet in a shell (User mode) are as follows: 

 Full Access

 Create

 View

When selected, this will allow the user to view the Rate Sheet node and the Rate Sheets 
present in the associated log. 

Earned Value Permissions 

The permissions for Earned Value are as follows: 

Permission Description 

Full Access When selected, this will allow the user to 
access all attributes of the Earned Value 
functional node. 

Modify When selected, this will allow the user to 
make edits to items in the Earned Value 
functional node. 

View When selected, this will allow the user to 
view the Earned Value functional node 
with the list of records. 

To grant permissions: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click User Administration > Access Control. 

3) On the Access Control log, click User Mode Access to expand it. 

4) Click Projects/Shells to expand it. 
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5) Click Cost Manager grouping node to expand it. 

6) Click Earned Value to open the Module Permission Settings window. 

7) Click Add to open the Permission/Access Control window. 

8) Click Add Users/Groups and add users, or groups, or both. 

9) In the Permission Settings block select the necessary permissions and click Add. 

10) When finished, follow the prompts to close windows and complete granting permissions. 

OBS Sheet Permissions 

To grant access, go to Access Control and select the OBS Sheet.  

The following permissions are available: 

 Create and Add Users to Project - Allow user to bring in active users from template or from 
an existing project while creating OBS Sheet from template or from project.  

 Create - Allow users to create an Organization Breakdown Structure (OBS) sheet by copying 
from template or project or create a new structure. 

 Modify - Allows users to edit an existing structure. 

 View - Allow users to view the OBS sheet. 

 Hide Audit Log - Allow users to see audit if the permission is not enabled. 

WBS Sheet Permissions 

To grant access, go to Access Control and select the WBS Sheet. 

The following permissions are available: 

 Modify - Allows users to edit WBS Attributes (including CSV Import) & view WBS Sheet. 

 View - Allow users to view the Work Breakdown Structure (WBS) Sheet. 

 Hide Audit Log - Allow users to see audit if the permission is not enabled. 

 Create Manual WBS Sheet - Allow users to create a manual WBS Sheet. 
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Setting up the Space Manager 

The Space Manager is where you can perform the tasks of facilities management. 

Using the Space Manager, you can gather data about the levels in your facility (such as floors 
and parking lots) and the spaces that exist on each level (cubicles, offices, conference rooms, 
and so on). Categories (called types) of spaces can be designed in uDesigner, and you can then 
add records of individual spaces to these types and manage them on an electronic sheet. 

The Space Manager is a means of organizing all the square footage in your facility to make 
monitoring, maintaining, and revising your facility more efficient. The Space Manager can be 
integrated with other managers or business processes to give you a broader view of your 
company's physical capital and resources. For example, the Space Manager can be integrated 
with the Resource Manager to include the employees who occupy each space on a level. 

In uDesigner, one attribute form is designed for a “level” type in your facility and multiple attribute 
forms for “spaces” types. With these attribute forms, you can create a hierarchy of levels and 
spaces within levels to store the facilities data you choose to collect. 

Notes: 

 In the Space Manager, think of a level as the “platform” on which 
spaces reside. 

 Configuration of the Data Picker and Data Elements (and when 
applicable: Unique and Auto Sequence settings) must be done in 
uDesigner. 

The Sheets node in the Space Manager stores the manager sheet on which all the levels in 
your facility are shown. The system automatically creates a level sheet for every level type that 
is created. From the level sheet, you can also automatically update individual level records with 
data added to the sheet, either manually or via a formula created for a column. 

The Stack Plans node is where you can create stack plans to show the actual usage of the 
levels in the company's building(s). You can choose the information (data elements or specific 
spaces) you want to see on the stack plan and update the plan periodically to keep abreast of 
changes in the levels' space usage. For example, you might want to know the square footage 
used by each department on each floor (level); or how many square feet of a floor are vacant 
versus leased. 

The Levels node lists all the levels that exist in your facility. This is where you can create new 
levels or update existing ones, import data from CSV files, or export templates to CSV. 

The Spaces node shows a list of all the space types, and under the space type sub-node, all the 
spaces that exist in your facility. This is where you can create new spaces or update existing 
ones, import data from CSV files, export templates to CSV, and select spaces to view on the 
level drawing. 

The Space Manager allows you to identify floors and each space by type and associate 
attributes to the particular spaces. For example, a multi-floor building could have many types of 
spaces, such as offices, cubicles, restrooms, conferences room, laboratories, and eating areas. 
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You manage spaces according to space type. Examples of space types are: 

 Gross measured area, which is the entire square footage of a floor, from wall to wall 

 Common area, such as hallways, lobbies, and entrances 

 Usable space, such as cubicles, offices, and conference rooms 

 Vertical penetration, which includes elevators, stairwells, and columns 

The Space Manager is available within a shell. Each shell can have only one Space Manager. A 
building is at the shell level. An example hierarchical arrangement of objects in the Space 
Manager is as follows: 

 Buildings (shell level) 

 Levels (Floors) of the building or other similar structures (in this case, Floor is an example 
of a level record) 

 Spaces in the building. These are the various spaces in the structure, such as 
storage rooms, offices, and other interior spaces (space records). Spaces is a 
fixed node designed in uDesigner. 

The Space Manager includes a sheet to help you manage levels and spaces. The sheet will 
allow you to create formulas to calculate total leasable and rentable space for a facility or 
building. 

In This Section 
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Space Manager Prerequisites 

The following is a list of prerequisites: 

 Generic or CBS shells configured 

 Level and space attribute forms defined in uDesigner 

Importing and Configuring Levels and Space Types 

Importing and configuring levels and space types for the Space Manager consists of the 
following steps: 

Step 1: Import level and space types. Levels and space types are created in uDesigner. 

Step 2: Configure the level and spaces. This configuration enables these types to be set up. 

Step 3: Setup Level Sheet Templates
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Step 4: Create stack plan templates

Step 5: Set permissions. After setting up and configuring levels and spaces, you must set User 
mode permission to all users who will need to work with these components of the Space 
Manager. 

In order to create levels and space types, the Space Manager module has to be loaded. Contact 
the Company or Site Administrator. 

The Space Manager can have only one level type design but multiple space type designs. You 
have to first deploy the level design in uDesigner before deploying any Space type designs. 

To import and deploy a level or space attribute form into Unifier Production environment, see 
Importing Configuration Packages (on page 619). 

Configuring Levels and Space Types 

Level and Space configuration allows you to activate the level and space types for use in the 
Space Manager. 

To access the level and space configuration log 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Space Manager in the left Navigator. The Configuration - Space 
Manager log opens. The log lists the level and space types that were imported into the 
system. 

The newly imported level and space types are inactive by default and can be activated during 
configuration. 

Configuring a Level or Space Type 

The following describes how to activate a level or space types. 

To configure a level or space type 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Space Manager in the left Navigator. The Configuration-Space 
Manager log opens, displaying the level and space types that have been imported into your 
company. 

3) Select a level or space type and click Open. The Configuration window for the level or space 
type opens. 

4) Complete the General tab. In this tab, you can add a custom Help file and change the status 
of the level or space type to Active. 

5) Click the Options tab. This tab is optional; it allows you to customize the layout of a PDF 
document leveraging the XML style design format. 

6) Click OK. 
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Configuring Fill Colors and Text for Space Types 

You can configure fill colors and text for uCAD drawings to support visual analysis of the 
drawings to facilitate space planning. For example, users might want to see a floor plan with 
each space type on that plan highlighted in a different color based on the department using that 
space.  

To configure fill colors and text for a space type 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Space Manager in the left Navigator. The Configuration-Space 
Manager log opens, displaying the level and space types that have been imported into your 
company. 

3) Select a space type and click Open. The Configuration window for the space type opens. 

4) For space types, click the Options tab. On this tab, you can enter information regarding 
spaces that enables users to color code spaces shown in uCAD. Users can also specify the 
display text that will appear on drawings. 

5) Complete the CAD Drawing Options as described in the table below. 

6) Click OK. 

In this field: Do this: 

Default Color Click Select to specify the color codes 
used by default when displaying spaces of 
this type. The system default is white (no 
color). You can select a color from the 255 
color code palette. This ACI color is 
converted to the corresponding HEX 
HTML color. The default color is used for 
space outlines. 

Text Element Sort Click Select to specify the sort order of the 
data elements in the space log, as defined 
in uDesigner. 

You can use Add to select the data 
elements to display and select a data 
element and click Remove to delete data 
elements from the list of displayed data 
element text. Use the Move Up and Move 
Down buttons to re-order selected data 
elements. Also, you can re-order the data 
elements by editing the Row number, and 
clicking Update Order to refresh the 
window. Click OK to exit the Data Element 
window. 
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Fill Display Elements Click Select to specific the drop-down list 
data elements (Input Type Pull-down 
Menu) that are available to be used for 
visual analysis with the color code palette, 
and to specify a color for each value in the 
Data Set for that Pull-down Menu. 

Select a Data Element and select Enable 
Fill By. Select colors for the data element 
data set values. Click OK. 

Configuring Space Manager Configuration Package 

The following configurations can be included in the Space Manager Configuration Package: 

 General setup 

All the fields included in the General Configuration (General tab). 

 Custom Print 

Word and PDF templates, if any. 

 BIP Custom Print 

All the Oracle Business Intelligence Publisher (BI Publisher) and Oracle Analytics Publisher 
Custom Print in the Custom Prints and Reports. 

 Space Attributes 

The content of the Options tab for Space Attributes, including Default Color, Text Element 
Sort, and Fill Display Elements. 

Note: If you do not select the Data Structure setup option at the time of 
creating the Configuration Package, the Data Definition selected in the 
Fill Display Elements field will not contain the Value or Label datasets 
and only the colors can be seen. 

For more information, see Configuration Package Management (on page 567). 

Creating Level Sheet Templates 

To open a level sheet 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell or shells] > Space Manager> Level Sheets in the left 
Navigator. The Level Sheets log opens. There is one level sheet per shell. 

3) Select the sheet in the log and click Open. 

To open the Level Sheet properties window 

In the Level Sheets log, select the sheet and click Properties. 
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To create a template for a level sheet 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell or shells] > Space Manager> Level Sheets in the left 
Navigator. 

3) Click New. The Levels Sheet Properties window opens. 

4) Enter an optional description. You cannot change the sheet title. 

5) Choose whether to include all levels on the sheet or just levels with selected statuses. 

6) Click OK. 

To add columns to a level sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell or shells] > Space Manager> Level Sheets in the left 
Navigator. 

3) Select the level sheet, and click Open. 

4) Click Columns. The Columns Log opens. 

5) Click New. The Column Definition window opens. 

6) In the Datasource drop-down list, select the data source to use. The list includes the data 
elements found on the level forms. 

7) For Entry Method, choose how information is entered in the column. The choices depend 
on the data source selected. 

8) For Data Format, select the format for numeric columns. The options are: 

 Show as Percentage: Displays data in percentage. For example, if 0.25 is entered, it 
displays as 25%. 

Note: When entering the percentage values in your sheet, if you are 
working in Classic View, then enter the value by using decimal number 
format. For example, for ten percent, enter: 0.1, and if you are working in 
Standard View, then enter the value by using percent format. For 
example, for ten percent, enter: 10%. The value the system uses to 
validate the value of the Percentage column, when applicable, will be: 
0-100. 

 Decimal Places: Select the number of decimal places to display. 

If the data element was defined in uDesigner with a specific number of decimal places, it 
will override any decimal places you specify here. 

9) For Display Mode, select Hide to make the column invisible to users or Show to display it. 

10) For Total, select what is shown in the bottom summary row for each column. The options 
are: 

 Blank: Summary row is blank. 

 Sum of All Rows: Displays the sum total of all row values for this column. 

 User Formula Definition: Displays the result of the formula entered in the Formula field. 

11) For Average, select Blank or the average of all rows. 

12) For Column Position After, select a column from the list to specify its position on the sheet. 
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13) Click OK. 

Creating a Stack Plan Template 

A stack plan is a two-dimensional graphical display of facility or building data. Usually, these 
graphs display area calculations by different attributes (for example, rented, leased, vacant, 
occupied by a tenant). Stack plans allow users to view area information across all building levels 
or floors based on defined attributes. Stack plans display only space records. With permissions, 
users can create or modify a stack plan under a shell. 

To create a stack plan 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell] > Space Manager> Stack Plans in the left Navigator. 

3) Click New. The Properties window opens. 

4) Complete the General tab as described in the first table below. 

5) Click the Options tab and complete as shown in the second table below. 

6) Click Apply to save changes, or OK to save and exit. 

In this field: Do this: 

Name Enter the stack plan name. 

Description Enter an optional description. 

Include: 

 All Levels 

 Levels with statuses 

Select to specify that all levels be included 
in the stack plan, or that only levels of 
selected status be included in the stack 
plan. 

In this field: Do this: 

Space Types Select a space type. 

Stack By: 

 Space Type 

 Data Element 

Select whether to stack by selected space 
type or by a data element. 

Stacking View Select to specify standard stacking or 
100% stacking. 

Sort Floors By: Select to sort floors by a selected data 
element from the Level Attribute form. 

Show Legend Select to display a legend for the stack 
chart. 
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Conditions Add a condition to filter the number of 
space records included in the stack plan 
calculation. The stack plan calculation 
logic sums up the values from the 
uuu_area data element used on the 
space-type detail form. 

To modify stack plan properties 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell] > Space Manager> Stack Plans. 

3) Select a stack plan and click Properties. The Properties window opens. 

4) Modify the stack plan properties as needed. 

5) Click OK. 

To update a stack plan across shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell ] > Space Manager> Stack Plans. 

3) Select a stack plan in the log. 

4) Click Update Shells. You can choose to update the stack plan in selected shells, or all 
shells. 

Setting Permissions for the Space Manager 

You must set the user permissions for the various components of the Space Manager. The 
Space Manager components are: 

 Sheets 

 Stack Plans 

 Levels 

 Individual space types 

To set the Space Manager components permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Open the User Administration grouping node and click Access Control in the left 
Navigator. 

3) On the right pane, select User Mode Access > Space Manager. The permissions for each 
component are: 

 Sheets: Create, Modify, View 

 Levels: Create, Modify, View, Allow Bulk Edit 

 Spaces > All > <space types>: Create, Modify, View, Delete, Allow Bulk Edit 

 Stack Plans: Create, Modify, View 
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Note: Users with Modify permission can import drawing files into a level 
record. 

Query Tabs in Spaces 

The Query tab allows access to all BP records, related to Space, by way of Query-based Tab 
(QBT). For example, if you need to see all approved BPs related to your Space, you can use the 
QBT to query/fetch those records. After a Query-based Tab (QBT) is successfully created and 
deployed using uDesigner, the BP Query Tabs appear in the required Space, in User mode. 

As a pre-process to defining the Query Tab in the Space, you need to use the Space picker in 
one of the upper forms of the BP from where you want to create the Query Tab. For defining a 
Query Tab, click the Query Tabs link in uDesigner, click New, and select a Business Process. 
The system allows you to create a maximum of 8 Query Based Tabs in uDesigner. To define a 
Query Tab, go to uDesigner: 

1) Click Query Tabs. 

2) Click New. 

3) Select a BP. 

Note: You can use the Space picker (uuu_phy_space_picker) for the 
Query Tabs in the Upper form of the Business Process (BP), where you 
want the Query Tab to originate from. 

All the functionalities that are available with Query Tabs for Business Processes (BPs) are also 
available for the Space Manager. 

The Query Items sub-node under the Space Manager node (uDesigner > Admin mode > Space 
Manager > [Space]) allows you to include references to other BPs in a form of a Query-based 
tab. 

Within a selected Space, the Query Items sub-node provides the following two links: 

 Query Tabs 

 Summary Elements 

Query Tabs 

After a Query-based Tab (QBT) is successfully created and deployed using uDesigner, the BP 
Query Tabs appear in the required Space, in User mode. You can use the Query Tabs sub-node 
to define and maintain the various Query Tabs that are defined within the Space. For more 
information, see the Opening Space Records and Creating a New Space Record topics in the 
Unifier Managers User Guide. 

General Tab

In the General tab, you can enter the name, description, and reference picker for the required 
QBT BP. 
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In case, you have already included the Space picker in the Upper form of the BP, the Space 
picker appears in the drop-down list of the reference picker. In this case, the Name field is 
populated with the name of the BP, but you can change the name of the QBT, if necessary. The 
name and reference pickers are mandatory fields on the General Tab, so you cannot create a 
QBT if you have not included the Space picker on the Upper form of the BP. 

Query Tab

The Query Tab of the QBT is used to create a query to filter the results, displayed within the 
QBT, based on any particular condition. 

Note: It is not mandatory to have a query, so in case no queries are 
defined all records display in the QBT, in User mode. 

You can define multiple queries within the Query tab. 

After you finish adding values in both General and Query tabs, click Save. The Query Tabs log 
allows you to: 

 See all the Query Tabs 

 Create a new QBT (New). 

 Open an existing QBT to review or change content (Open). 

 Delete an existing QBT (Delete). 

 Rearrange the ordering of the QBTs that are displayed (Tab Order). 

Summary Elements 

You can use the Summary Elements on the Detail form of the Space to show the data that is 
being exchanged. You can use all existing types of Summary Elements (Average, Count, Total, 
Maximum, and Minimum) in the QBT. 

You can define multiple Summary Elements. To create Summary Elements, go to uDesigner > 
your space [Space] > Summary Elements and use the Space QBT to create your Summary 
Elements. After defining the Summary Elements, click OK to save. The Summary Element log 
allows you to: 

 See all the Summary Elements. 

 Create a new Summary Element (New). 

 Open an existing Summary Element to review or change content (Open). 

 Delete an existing Summary Element (Delete). 

After you create the Summary Elements, you can include them in the Detail form of your space 
[Space]. 
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Setting up the User-Defined Reports 

These are the recommended steps to set up the User-Defined Report (UDR) functionality: 

Step 1: Create a UDR template. 

Step 2: Create project or shell UDRs. 

Step 3: Create a program UDR. 

Step 4: Create a company UDR. 

In This Section 

Creating and Setting up a UDR Template ............................................................. 531 
Access Control Permissions for UDRs .................................................................. 561 
Creating User-Defined Project, Shell, Program, and Company Reports ................ 562 

Creating and Setting up a UDR Template 

Report templates lets you create templates that a user can then copy from to create 
User-Defined Reports (UDRs). Report templates are based on specific data types and 
pre-defined data elements that differ depending on the data type. In addition to creating 
system-based report templates, you can also create permission-based report templates. 

Report templates define queries used to search the database for transaction or Project/Shell 
data and report layout. 

You can create UDR templates for the following UDR report types: 

 Tabular 

 Cross Tab 

 Summary 

 Alert 

UDR Data Types 

The following table summarizes data types in user-defined reports. Data types also include 
project- or shell-level and company-level business processes, asset classes, planning items, and 
sheets. The "x" in a column indicates that the information comes from that source, not where the 
report is written. (Company UDRs can access project/shell data sources.) 
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Data Type 
Project 
UDR 

Shell UDR 
Program 
UDR 

Company 
UDR 

UDR 
Template 

Use for 
Maintenanc
e 
Manageme
nt Only 

Accounts 
Sheet 

x 

Active 
Task 
Information

x x x x 

Asset 
Summary 
Sheet 

x 

Audit x x 

Commitme
nt 
Summary 

x x x 

Company 
Cash Flow 

x 

Company 
Cost 

x 

Company 
User 
Information

x 

Cost Sheet 
- CBS 

x x x x 

Cost 
Transactio
ns -CBS 

x x x x 

Cost 
Transactio
ns MC - 
CBS 

x x 

Data 
Views 

x x x x x 

Document 
Manager 

x x x x x 

Document 
Manager—
Company 

x 
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Data Type 
Project 
UDR 

Shell UDR 
Program 
UDR 

Company 
UDR 

UDR 
Template 

Use for 
Maintenanc
e 
Manageme
nt Only 

Equipment x x 

Funding x x x x 

Gates x x x x 

Inventory  x x 

Inventory 
On-hand 
Detail 

x x 

Item 
Master 

x x 

Job Plan  x x 

Master PM 
Book 

x x 

Master PM 
Meter 
Schedule 

x x 

Master PM 
Time 
Schedule 

x x 

Material 
Transactio
n 

x x 

Partner 
User 
Information

x 

PM Book  x x 

PM Meter 
Schedule 

x x 

PM Time 
Schedule 

x x 

Program 
Cash flow 

x 

Program 
Cost 

x 
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Data Type 
Project 
UDR 

Shell UDR 
Program 
UDR 

Company 
UDR 

UDR 
Template 

Use for 
Maintenanc
e 
Manageme
nt Only 

Program 
Schedule 

x 

Resource 
Booking 

x x 

Resource 
Manager—
All Actuals 

x 

Resource 
Manager—
Allocated 
Roles 

x x x 

Resource 
Manager—
Booked 
Resources

x x x 

Resource 
Manager—
Project 
Actuals 

x x x 

Resource 
Manager - 
Resources 
(Company)

x 

Resource 
Manager—
Roles 

x 

Resource 
Manager—
Sheets 

x x x 

Service 
Center 

x x 

Service 
Request 

x x 

Schedule 
of Values 

x x x x x 
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Data Type 
Project 
UDR 

Shell UDR 
Program 
UDR 

Company 
UDR 

UDR 
Template 

Use for 
Maintenanc
e 
Manageme
nt Only 

Shell or 
Project 
Cash Flow 

x x x x x 

Shell or 
Project 
Cost 

x x x x 

Shell or 
Project 
Groups 

x x x x 

Shell or 
Project 
Information

x x x 

Shell or 
Project 
Users 

x x x 

Workflow 
Information

x x x x x 

Work 
Order 

x x 

Work 
Order 
Items 

x x 

Work 
Order Role

x x 

(Asset 
class 
name) 

x 

(Business 
process 
name) 

x x x 

(Planning 
type name)

x 

Note: The COST SHEET - CBS data source does not support the 
formula columns. Use the Project/Shell Cost data source to view the 
formula column values. 
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Accessing UDR Templates 

To access Shell UDR templates: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Shells > [shell type] > [shell template]. 

3) In the left Navigator, click a shell to open the log, select a shell from the log, and click Open. 

4) In the left Navigator, click Reports > User-Defined. 

The User-Defined Reports log for the (Shell UDR templates) contains all the UDR templates 
that have been defined for a specific Company. 

The User-Defined Reports log contains the following menu options: 

Field Description 

File Lets you create a report (New), copy a 
report template (Copy > Template), open 
a selected report (Open), Update Shell 
Templates, or Update Shells. 

Edit Lets you delete (Delete) a selected report. 

View Lets you choose to view all the reports 
(All), find a particular report in the log 
(Find), view a set of saved parameters 
(Saved Results), and access the audit log 
(Audit Log). 

Help Lets you access the following: 

 User Help

 Admin Help

 uDesigner Help

 Unifier Library

 User Productivity Kit

The User-Defined Reports log contains the following toolbar options: 
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Field  Description 

New Lets you open the Create a new report
window for system or permission-based 
data sources, and create a report by way 
of entering the following data: 

 Data Type

 Element

 Report Type (Tabular - Cross Tab - 
Summary - Alert) 

 Access Type

Copy Lets you copy a report or report template 
(Copy > Template). 

Open Opens a report. 

Edit Opens the Edit Report window, which 
contains the following tabs that let you 
change, enter, or select various data about 
a report: 

 General tab 

 Data Elements tab 

 Query tab 

 Layout tab 

 Shells tab 

 Permission tab 

 Schedule tab 

Delete Lets you delete a selected report. 

Find Lets you find a particular report in the log. 

Update Shell Templates Lets you push report template changes to 
multiple shell templates. 

Update Shells Lets you push report changes to multiple 
shells. 

The User-Defined Reports log contains the following columns: 
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Field Description 

First column. Indicator that the report has 
been enabled for integration. 

This icon indicates that reports created 
based on this template will be enabled for 
web services integration. The integration 
option is available only for project-level, 
shell-level, and company-level reports. 

Note: The icon is displayed only when the 
UDR log is in Classic view. The presence 
of this icon is an indicator that the report 
has been enabled for integration. 

Name The name of the report template 

Description The description of the report template 

Data Type The type of data on which the report is 
being run, for example, business 
processes, Cost Manager elements, 
project or shell information, workflow 
information, and so on 

Access Type Permission-Based or System 

Report Type Tabular, cross tab, summary, or alert 

Owner The creator of a report is its owner. 

Creation Date The date the report was created 

Last Modified By The person who last modified the report 

Last Modified Date The last date that the report was modified 

Scheduled The scheduled frequency of a scheduled 
report 

Last Run Date The last time the report was run 

Creating a UDR Template 

These procedures are applicable for UDR templates or for manually creating a UDR in User 
mode. 

To create a UDR template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click one of the following: 

 Templates > Reports

 Templates > Shells > [shell type] > [shell template] > Reports > User-Defined
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3) Click the New button, and select System Data Sources or Permission Based Data 
Sources. 

The Create a new report window opens. 

4) Fill in the fields using the information in the table below. 

5) Click OK. The Edit Report window opens. This window has multiple tabs for defining the 
report layout and content. The actual tabs that display will depend on the type of report you 
are creating. These tabs are: 

 General tab: In this tab, you enter the report name, the title that displays on the report at 
runtime, and define general settings, such as enabling it for integration, and setting a 
default time zone to use where time stamps appear on the report. 

 Data Elements tab: Lets you specify the data elements on which to report, and which will 
appear as columns on the report at runtime. The Data Elements tab differs with each 
report type. In addition, the data elements that are available to be added to the report 
depend on the data type chosen during report creation. The data elements can include 
business process fields, columns in cost, funding, SOV, and schedule sheets, and project 
data such as project name, status, user name, and so on. 

 Query tab: Defines query parameters to input at report runtime. 

 Layout tab: Lets you customize the layout and presentation of the report. If you do not 
define layout parameters, a default layout will be used. The Layout tab differs with each 
report type. 

 Projects/ Shells tab: This tab appears only in program-level and company-level reports. 
It displays which projects or shells will be included in the report. 

 Shells tab: This tab appears only in shell-level reports. It displays which shells can be 
included in the report. 

 Permission tab: Enables the report owner to grant permission to other users to run or 
edit the report. This tab is available only in User mode and not in the report template. 

 Schedule tab: Lets the report owner schedule and configure automatic report generation 
and optionally save or email the results. 

6) Complete the tabs in the Edit Report window as described in the following sections, and click 
OK. 

In this field: Do this: 

Data Type 

Select from the list. The Data Type list 
includes all available business processes 
(for example, base contracts), pre-defined 
data types (for example, project users), 
modules (for example, Document 
Manager), data views in Published status 
(listed in alpha order, project/shell-level 
requires project_id in query), and may also 
include custom data types. 

Note: If you are creating a 
permission-based template, the Data Type 
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In this field: Do this: 

list includes all the permission-aware data 
sources that might be visible to the user, 
depending on the user's access 
permissions. 

Element 

If you chose a business process or a 
uDesigner BP-driven feature (such as 
funding, schedule of values, project 
information) as the data type, the Element 
drop-down list becomes available. Select 
one of the following options as available 
for your data type choice: 

 All Fields: Makes all fields on the BP 
available for the report. 

 General (Header) Fields: Only the BP 
header fields will be available, which 
provides a less detailed report. 

 Custom Defined: This is automatically 
selected for uDesigner-created BPs 
and related functions. This enables all 
the custom data element fields on the 
BPs to be available for the report. 

Report Type Choose a report type. 

Access Type 
(Read-only) Depending on which option 
you selected, this field displays either 
System or Permission Based. 

General Tab (All Reports) 

The General tab defines the report name, title, and description and displays the data type and 
report type (tabular, cross tab, summary, or alert). The General tab is the same for each report 
type. Below is a sample of the General tab. 

In this field: Do this: 

Report Name 
The name appears on the user-defined 
reports log. 

Report Title 
The title appears on the report itself. By 
default, the field is populated automatically 
with the report name and is editable. 

Description Description is optional. 
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Data Type, Access Type, Element, Report 
Owner, and Report Type 

Automatically populated from the options 
selected during the creation of the report. 

Enable for Integration 

Selecting this option flags the report as 
eligible for integration through web 
services (uLink). Contact Oracle Customer 
Support for more information about web 
services integration and uLink. This option 
is available for project-, shell-, and 
company-level reports only. 

When the check box is selected, the 

integration icon  appears in the UDR 
log next to the report name. 

Note: Because web services uses the 
report name to identify reports, each report 
marked for integration must have a unique 
name. If there are two reports with the 
same name, only one of those reports can 
be marked for integration. This is true even 
if you cannot see the other report with the 
same name. For example, another user 
has created a report with the same name, 
for which you do not have view permission, 
and marked it for integration. 

Default Time Zone 

This option lets you choose the default 
time zone that will be used where time 
stamps appear on the report (such as 
data/time data elements). There are two 
options: 

 Click the drop-down (pull-down) and 
choose a specific time zone in which to 
display date/time information in the 
report at runtime. Use this option when 
you want all instances of the report to 
display results in a fixed time zone, for 
example, the project location. 

 You can also choose to default to 
user's time zone. When this option is 
chosen, users in different locations will 
see report results that reflect their own 
time zone. 

Note: For scheduled reports, all users will 
get the same report results. If the user time 
zone option is chosen, then the report 
owner's time zone is used. 
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Data Elements Tab (Tabular Report) 

Each column of a tabular report corresponds to a data element or function (formula, date, or 
date difference). You can add or modify the data elements or functions on this tab. The Data 
Elements tab differs with each report type. The data elements depend on the data type chosen 
during report creation (see below). The data elements can include business process fields, 
columns in cost, funding, SOV, and schedule sheets, project data such as project name, status, 
user name, and so on.  

This button: Does this: 

Add Functions 
Click to open the Data Element Properties 
window. Lets you create a formula, data 
difference, or date column in the report. 

Add Elements 

Click to open the Data Element Picker 
window. The data sources and elements 
that are available vary based on the data 
type that you chose when creating the 
report. 

Modify Modify data element properties. 

Sort 
Determines which column to sort report 
results by. 

Remove 
Select a listed data element and click to 
remove it. 

Move Up (Left) 
Select a data element and click to move 
the column to the left. 

Move Down (Right) 
Select a data element and click to move 
the column to the right. 

Current width 

This field displays the width of the report in 
pixels. The report width is determined by 
the number and column width of data 
elements that are added. 

Maximum available width 
The maximum width of the report is 
determined by the page size and 
orientation as selected in the Layout tab. 

Data Elements Tab (Cross Tab Report) 

Cross tab reports allow the display of data on two axes. For example, the report below is being 
set up to track amount per CBS code per phase, where the CBS codes are the rows, the phases 
are the column headings, and the body data is made up of the line item amount. 
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Cross tab reports enable users to run time-series reports defined by two data sources, for 
example, payments made per quarter per vendor. 

In this field: Do this: 

1st Column
This determines the data element that will 
be used for each row. 

Data Element 

Click Select and choose the data element. 
The list will depend upon the data type 
chosen. The data type will be listed before 
the data element, separated with a slash 
(/). For example: Funding/Funding Type, 
where Funding is the data type chosen on 
the General tab, and Funding Type is the 
data element. 

Heading 
The heading will automatically populate 
with the data element that you choose, but 
you can edit this as necessary. 

Width 

You can specify a column width for the 1st 
column, or leave it blank to use the default 
width (automatically adjusts depending on 
the number of body columns in the report).

Body Columns

This determines the series for which the 
data will be presented. The list is 
pre-defined and will depend on what was 
chosen for the 1st Column. Typically, 
these are system-defined data elements 
related to the 1st column choice, for 
example, status, creation date, and so on. 

Data Element 

 Click Select. The Data Element Picker 
window opens. 

 Click the Data Source list at the top of 
the window and select a data source. 
This determines which data elements 
will be available for the report. The 
choices will include the data type you 
chose in the General tab, as well as 
related data sources. 

 Select a data element and click OK. 
Some data sources might not have 
data elements. 

Width 
You may specify body column width or 
leave it blank to have it automatically 
adjusted. 

Body Data This determines the data that will show up 
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In this field: Do this: 

in the body of the report. 

Data Element 
The list is dependent on what is chosen for 
the other parameters, and is determined 
by what is logically reportable. 

Row/Column 

 Select Show Total if you want column 
and row sum totals to be included in 
the report. 

 Choose Left or Right alignment. 

 Choose Ascending or Descending to 
determine the sorting order of the 
columns and rows. 

Decimal Places 
Select the number of decimal places to be 
used in the body data.  

Currency Format Select from the Project or Base currency. 

Data Elements Tab (Summary Report) 

On this tab, you specify the data that will be reported and how it will be presented on the project 
summary page. In the example below, a cost sheet report is being set up to display the value of 
total commits against CBS code. 

In this field: Do this: 

1st Column

This determines the data element that will 
be used for each of the rows. In the 
example above, this is CBS code. Click 
Select and choose the data element. The 
list will depend upon the data type chosen. 
The data type will be listed before the data 
element, separated with a slash (/). For 
example: Funding/Funding Type, where 
Funding is the data type chosen on the 
General tab, and Funding Type is the data 
element. 

Heading 
This field will automatically populate with 
the data element that you choose, but you 
can edit it as necessary. 

Width 
You may specify a column width or leave it 
blank to use the default width. 
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In this field: Do this: 

If the data element is a date type, you can 
specify time parameters 

 By: Choose the year, quarter, month, 
or day to display the data. 

 Format: How the heading will display 
the date 

 From and To: Establishes the date 
range to include in the report. 

2nd Column
This determines what information is being 
presented. 

Record Count 
Displays the total number of records. For 
example, for a report on a BP type, it will 
display the number of BP records. 

Summary Value 

Displays a value. In the above example, 
the value is the total value of the commits 
(Contracts + Change Orders) for each 
CBS code. To enter a formula, click the 
Formula button. 

Summary Type 

Choose one of the following: 

 Summary: Provides a summary value.

 Average: Displays the average value. 

 Maximum: Displays the maximum 
value. 

Heading Type a heading for the 2nd column. 

Width 

You may specify a column width or leave it 
blank to use the default width. 

Decimal Places 
Select the number of decimal places to be 
used in the body data.  

Currency Format Select from the Project or Base currency. 

Data Elements Tab (Alert Report) 

On this tab, you define the parameters that will trigger the alert that will be sent you. In the 
example below, the alert will be triggered for invoices that are greater than $1,000. 

In this field: Do this: 

Alert Column 
This determines what information is being 
presented. 
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In this field: Do this: 

Record Count Displays the total number of records. 

Summary Value 

Displays a value. In the above example, 
the value is the total value of the commits 
(Contracts + Change Orders) for each 
CBS code. To enter a formula, click the 
Formula button. 

Summary Type 

Choose one of the following: 

 Summary: Provides a summary value.

 Average: Displays the average value. 

 Maximum: Displays the maximum 
value. 

 Minimum: Displays the minimum 
value. 

Condition 
Specify the condition that will trigger the 
alert. This can be used for record count or 
summary value. 

Trigger Value 
Enter the value of the record count or 
summary value that will trigger the alert. 

Indicator 

Lets you specify a flag icon (red, yellow, or 
green) in the alert to help you identify the 
level or type of alert. The flags have no 
meaning other than user-defined 
identification. 

Data Elements 

Data Element Description 

Query parameters 
This data element will allow query 
parameters to be printed with the report 
result. 

Project/Shell list 
This data element will allow project or shell 
list information to be printed with the report 
result. 

The display of numeric data elements can be formatted. The following formats are available: 

 Decimal place: Number of decimals to display 

 User1000 separator: Display of comma separator 

 Negative number format: Minus sign or parenthesis; for example, -1234 or (1234) 
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Query Tab (All Reports) 

The Query tab defines query parameters to input at report runtime. For example, for a funding 
report, the query can be set to run the report only on specific company funds. You can define the 
funds or allow the user to specify them at runtime. 

The data elements available for the query will depend on the report data type. Defining a query 
is optional. See Define Report Queries (Query Condition) (on page 557). 

This button: Does this: 

Add 
Lets you add a query condition to the 
report. 

Add Formula 
Lets you add a condition based on a 
formula comprised of other data elements. 

Modify 
Select a query condition and click to 
modify. 

Remove 
Select a query condition and click to delete 
it from the report. 

Show results matching any condition 
(instead of all) 

Select this to show report results matching 
one or more of the listed query conditions. 
If you do not select this option, the report 
results will include only those that match 
all listed query conditions. 

Layout Tab (All Reports) 

The Layout tab lets you configure the layout and presentation of the report results. If you do not 
define layout parameters, the default settings will be used. The Layout tab is the same for all 
reports with the following exceptions: Cross tab reports and tabular reports each include an 
additional layout option specific to their report types (see Layout Tab (Cross Tab Setting) (on 
page 549) and Layout Tab (Group By Setting) (on page 550)). 

Click the Report Properties options on the left side of the window to define each layout. 

Layout Tab (Page Setup Setting) 

The Page Setup on the Layout tab lets you configure the size and orientation of the report (see 
below). 

In this field: Do this: 

Report Properties Choose Page Setup. 

Size 
Choose the paper size from the drop-down 
list (letter, legal, ledger, or A4). 
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In this field: Do this: 

Orientation 
Report can be generated as portrait or 
landscape. 

Layout Tab (Title Page, Header, Footer, Summary Page Settings) 

The Title Page, Header, Footer, and Summary Page options let you define general layout and 
presentation of the report results. If you do not define layout parameters, the default settings will 
be used. A number of standard and report-specific data elements are available to add to your 
report. 

Note: If you want users to be able to add a runtime note, include the 
data element Runtime Notes in the layout. 

Report Properties Description 

Title Page 
You can create an optional title page, 
which will be the first page of the report. 

Header 

You may enter a header for the report. 
This will display at the top of each page of 
the body of the report. The header will not 
display on the title page or the summary 
page. 

Footer 

The footer will display at the bottom of 
each page of the body of the report. The 
footer will not display on the title page or 
the summary page. 

Summary Page 
The summary page will display as the last 
page of the report. 

For more information about setting up these report properties, see Set up Title Page, Header, 
Footer, and Summary Page (on page 558). 

This button: Does this: 

Add 
Click the Add button to add additional 
rows of text to the title page, header, 
footer, or summary page. 

Modify Select a row and click Modify to edit it. 

Remove Select a row and click Remove to delete it.

Move Up or Move Down 
Select a row and click Move Up or Move 
Down to change the order of the rows. 
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This button: Does this: 

Current Height 
Displays the total height of the text (sum of 
the pixels of all lines) in the header, footer, 
title page, and summary page. 

Maximum Available Height 
Displays the maximum height available, 
based on the paper size and orientation. 

Show Border 
Select if you want the text to be enclosed 
in a border. 

Layout Tab (Cross Tab Setting) 

For cross tab reports. The fields here are applicable for time stamp data element types in the 
first column and body columns, as selected in the Data Elements tab). 

In this field: Do this: 

By 
Sets the time period for the report by year, 
quarter, month, or day. 

Format Select the format of the By field. 

From and To 
Specify the date range on which you want 
to report. You can select Auto Range 
instead. 

From: Auto Range 

The Auto Range feature automatically 
displays data in report results without 
specifying a date range. You can select 
Auto Range for either or both to and from 
dates. If the From Auto Range option is 
selected, all available data up until the 
specified end date will display in the report. 
For example, if you want to view all data 
up to 2005 but want to exclude 2006, you 
will click Auto Range From and select a To 
date of 2005. 

To: Auto Range 

If the To Auto Range option is selected, all 
available data from the specified start date 
until present will display in the report. For 
example, if you want to view data starting 
from 2004 to present, click Auto Range 
and select From Date of 2004. 
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Layout Tab (Group By Setting) 

Tabular reports can include grouped data element results, for example, grouping BP record 
results by BP creator. 

Note: For Unifier Mobile users, if the Group By option is set on reports 
(that is, group by user name), you cannot mark these reports as mobile. 
Reports marked as mobile cannot contain groupings of data results. 

This button: Does this: 

Add Click to add a group. 

Modify 
Select a group and click to modify the 
Group By properties. 

Remove Select the group and click to remove. 

Move Up or Move Down 
Select a row and click Move Up or Move 
Down to change the order of the rows. 

Projects Tab (Program-Level Reports, All Types) 

This tab appears only in program-level and company-level reports, and displays which projects 
will be included in the report (see below.) The Projects tab is set up the same way for each 
report type. 

For program-level reports, the projects that are part of the program are listed in the Projects tab 
and are not editable. 

Shells Tab (Shell-level Reports, All Types) 

This tab appears only in shell-level reports, and displays which shells will be included in the 
report. 

This button or option: Does this: 

Shells 

The options in this field are: 

Current Shell and sub-shells 

Current Shell Only 

Subshells Only 

User-Defined 

The User-Defined option lets you choose 
from among the shells in which you are a 
member. 

Exclude Inactive Shells Lets you exclude shells with the status 
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This button or option: Does this: 

Inactive. This is checked by default. 

Add 

When you click Add, the Select shell 
window opens. Select the shells and click 
the Add button. This button is available 
only if you have selected the User-Defined 
option in the Shells field. 

Remove 

Select a shell and click Remove to remove 
it from the report. This button is available 
only if you have selected the User-Defined 
option in the Shells field. 

Allow users to modify User-defined list 
during execution 

This check box is enabled if User-Defined
is chosen. When this check box is 
selected, users will be able to change 
which shells from the available list to 
include in the generated report at runtime. 

Permission Tab (All Reports) 

In the Permission tab, you can grant permission to other users to run, edit, or modify the 
permissions of this report. This tab is available only in User mode and not in the report template. 

Schedule Tab (All Reports) 

The Schedule tab enables report owners to create a schedule to automatically run user-defined 
reports and save the results as PDF, XML, or CVS files, automatically save the report in the 
Document Manager, and to specify whether to email the report results to the report owner or to 
specified users and groups. 

In this field: Do this: 

Enable Scheduled Report Runs 
Select this check box to enable scheduling 
of automatic report runs. Define the 
following parameters. 

Output Format 
Specify the format of the scheduled report 
results: PDF, XML, or CSV. 

Frequency 

Specify the frequency with which the report 
will be run: 

Daily: Runs once at the end of the day 
(23:59:59). 

Weekly: Specify the day on which the 
report will be generated, for example, from 
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In this field: Do this: 

previous week Saturday (00:00:00) to this 
week Friday (23:59:59). 

Monthly: Specify the date on which the 
report will be generated. If the scheduled 
date is past the last day of the month (for 
example, the 31), the report will 
automatically be generated on the last day 
of that month. For example, monthly 
(08/04/06) frequency should take last 
month (07/05/06 00:00:00) to this month 
(08/04/06 23:59:59). 

Quarterly: Generated at the end of each 
calendar quarter. For example, data 
generated end of Q2 should be Q2 
(04/01/06 00:00:00) to end of quarter Q2 
(06/30/06 23:59:59). Q1 is Jan to March, 
Q2 is April to June, Q3 is July to Sept, Q4 
is Oct to Dec. 

Yearly: Report is generated at the end of 
the calendar year. For example, data 
generated end of 2006 should be 2006 
01/01/06 00:00:00 to 2006 12/31/06 
23:59:59. 

Range of Recurrence 

Choose the range of recurrence of the 
scheduled report: 

No end date: The report will be generated 
according to schedule indefinitely. 

End by: A date after which the scheduled 
report will not be generated. 

Auto-email as attachment to report owner 

Select to have a PDF, XML, or CSV copy 
of the report emailed to the report owner 
after generation. You can select this option 
and Auto-email as attachments to users 
and groups at the same time. 

Auto-email as attachments to users and 
groups 

Select to have a PDF, XML, or CSV copy 
of the report emailed to selected users and 
groups. Click Select, specify the users and 
groups, and click OK. You can select this 
option and Auto-email as attachments to 
report owner at the same time. 

Note: If a user is selected twice, as an 
individual user and as a member of a 
selected group, the user will receive only 
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In this field: Do this: 

one email. 

Saved Result Log 
Select this check box to save the report, 
where you can view it at your convenience

Document Manager 

Use these options to save the report in the 
Document Manager. 

In the Save as field, the system shows the 
name of the report; however, you can 
enter another name for the report if you 
want. 

In the Location field, click Select and 
choose the folder in the Document 
Manager in which the report should be 
saved. (You must have permissions to the 
folder.) 

Add and Manage Data Elements (Columns) to the Report 

The following procedures describe how to add data elements to a user-defined report or 
template. These become the columns on the report at runtime, and determine what data will be 
displayed on the report. 

To add data elements to the report 

1) In the Edit Report window, click the Data Elements tab. 

2) Click Add Elements. The Data Element Picker opens. 

3) Choose one or more data elements from the list. (Press the Ctrl or Shift keys to select 
multiple data elements.) 

4) Click OK. 

Add formulas to data elements 

If you want to display the results of calculations based on data elements available for the data 
type you chose, you can create a formula column on the report. 

Note: Use caution when creating a formula with data elements. It is 
possible to create a formula where the denominator is zero, which can 
cause a data conflict error when the report is run. 

To add a formula 

1) In the Edit Report window, Data Elements tab, click the Add Functions buttons. The Data 
Element Properties window opens. 

2) From the Data Element drop-down list, choose Formula. The Data Element Properties 
window expands. 
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3) Enter a column heading, which is displayed on the report. 

You may specify how the column is displayed by specifying the alignment, column width, 
decimal places, 1000 separator, and negative number format. 

4) If you select Hide Column, the column will not be displayed on the report. 

5) Selecting Summary will display the sum of the column values at the end of the column. 

6) Select the number of Decimal Places and the Currency Format of the data element.  

7) Click Formula to open the Formula Creator. Create the formula and click OK. 

To add a date add column 

1) In the Edit Report window, Data Elements tab, click the Add Functions button. The Data 
Element Properties window opens. 

2) From the Data Element drop-down list, choose Date Add. The Data Element Properties 
window expands. 

3) Enter a column heading, which is displayed on the report. 

You may specify how the column is displayed by specifying the width (in pixels) and 
alignment. If you select Hide Column, the column will not be displayed on the report. 

4) For the Date field, click Select and choose the date data source. 

5) For the Add field, select the numerical data source. This is the value that will be added to the 
date element to arrive at the final value to display in the report. 

6) If you want the time to also display as well as the date, then select the Display Timestamp
check box. 

7) Click OK. 

To add a date difference column 

1) In the Edit Report window, Data Elements tab, click the Add Functions button. The Data 
Element Properties window opens. 

2) From the Data Element drop-down list, choose Date Difference. The Data Element 
Properties window expands. 

3) Enter a column heading, which is displayed on the report. 

You may specify how the column is displayed by specifying the width (in pixels) and 
alignment. If you select Hide Column, the column will not be displayed on the report. 

4) Specify the earlier date and later date. Choose Today if you want to use the current day as 
one of the dates, or click Select to open the Data Element Picker. Select a data source from 
the drop-down list, then select a data element from the resulting list. 

5) If you want to show results with partial days, then select the Show Partial Days check box. 

Note: Date Picker data elements (as opposed to Date Only pickers) 
include timestamps. When calculating the difference between these date 
and times, it is possible to get a result in partial days. If you select this 
check box, results will display two decimal places; if you do not select 
this check box, results will be in whole numbers. 

6) Click OK. The calculation is Later Date - Earlier Date, in days. 
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Manage Report Column (Data Element) Properties 

You can refine the display of the report columns by modifying the data element properties. You 
can modify the column heading, width and alignment, as well as hide a column, or choose to 
display the timestamp for date pickers. 

To view or modify column properties 

1) In the Edit Report window, Data Elements tab, select the listed data element and click 
Modify. 

2) You can modify the column heading, column width, and alignment for how you want it to 
appear in the report results. 

3) Click OK. 

To hide data elements in the report output 

1) Select the listed data element and click Modify. 

2) Select Hide Column if you do not want the column to appear on the report (for example, 
columns added as part of a formula calculation but do not need to be printed). 

3) Click OK. 

To display the timestamp on date data elements 

1) Select the listed date picker data element and click Modify. For date picker elements that 
include timestamps, the Data Element Properties window displays an additional option: 
Display Timestamp. This option is not available for data elements based on date-only 
pickers, or other elements that do not capture timestamps. 

Note: The Schedule Manager ignores timestamps, therefore, date fields 
associated with the Schedule Manager will not display the time, even if 
this option is selected. 

2) Select Display Timestamp. At runtime, the time displays next to the date. 

3) Click OK. 

To remove a listed data element 

Select the data element to remove from the report and click Remove. 

To change the order of the data element columns 

Select a data element from the list. Click Move Up (Left) to move the element up the list to the 
left on the report), or Move Down (Right) to move it down to the right on the report. 

To choose the column by which to sort the report 

1) Click the Sort button. 
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2) In the Column Heading list box, select the data element column by which you want to sort 
the report findings. For example, choose Creator Name to sort by the creator of each record. 

3) Click the right arrow button >> to move it to the Sort By field. 

4) In the Sort Order list, choose Ascending or Descending. Click OK. 

Set Auto Range 

The auto range feature for cross tab report types automatically displays report data without 
having to specify a date range. During set up, you select the data types. Only time stamp types 
enable the option for configuring the date range and auto range. 

For example, if 2005 to 2006 is specified as the date range but only values for 2005 have been 
entered, the report will only display data for 2005. If a date range is not specified, all data will be 
displayed in the generated report. 

At runtime, users will have the option to select dates or auto range. 

To enable the auto range option 

1) From the Edit Report window, click the Data Elements tab. 

2) Set time stamp data element (date) under First Column or Body Columns. 

If no timestamp data element is specified, all dates with data will be displayed when the 
report is generated. 

3) Click Apply. 

To set the auto range 

1) Click the Layout tab, then click Cross Tab. There are two check boxes for auto range. 

Note: Only report columns with data appear for non-time-stamp data 
types. If a data value is not entered, the column will not appear in a 
cross tab report. If you select the time stamp data type, report columns 
appear, even if data is not entered. 

2) For From Date, click the Auto Range radio button. 

The date selection option will be grayed out. If From Date is selected and To Date is 
deselected, all data up until the specified end date will display in the report. For example, to 
view data up to 2005 but exclude 2006, click Auto Range and enter a To Date of 2005. 

Alternatively, to view data from 2004 to present, deselect Auto Range and enter a From Date 
of 2004. 

3) For To Date, click the Auto Range radio button. 

The date selection option will be grayed out. If From Date is deselected, data entered from 
the specified start date until present will display in the report. For example, to view data 
starting from 2004 to the present, click Auto Range and enter a From Date of 2004. 

Alternatively, to view data up to 2005 but exclude 2006, deselect Auto Range and enter a To 
Date of 2005. 

If you select both options for the Auto Range From and To dates, only the data supplied for 
this period will appear in the report. 
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Grant Report Edit or Run Permissions to Other Users 

If you are the creator or owner of a report, or if you are an administrator with full access 
permissions, you can grant permission to other users to access or run a report. 

To grant report permission to other users 

1) In User Mode, navigate to the user-defined report log. Select the UDR and click the Edit
button. The Edit Report window opens. 

2) Click the Permission tab. 

3) Click the Add button. The User/Group Picker opens. 

4) Select users or groups, click Add and OK. 

5) Select the newly added user or group, and select the permissions to grant: 

 Modify Permission: Allows the user to modify other users' permission settings for the 
report. 

 Edit Report: Allows user to edit report parameters. 

 Run: Enabled by default. Allows the user to run the report. 

6) Click Apply to save your changes and then OK to exit the Edit Report window. 

Define Report Queries (Query Condition) 

You can define query parameters that users can input at report runtime. For example, for a 
funding report, the query can be set to run the report only on specific company funds that the 
user specifies at runtime. Defining a query is optional. 

The data elements available for the query will depend on the report data type, and the condition 
options will be dependent upon the data element type chosen. 

To define a query 

1) From the Query tab, click Add. The Query Condition window opens. 

2) Click the Select button to open the Data Element Picker. Choose a data source from the 
drop-down list, and then choose a data element from the list. 

Note: If you choose a date-type data element, the Use timestamp in 
query check box becomes available; if you select this option, the 
timestamp as well as the date will be taken into account in the query. 

3) The Label field is populated based on the selection and can be modified. 

4) Select a condition from the resulting list. 

For example, choose equals to generate reports that exactly meet certain conditions or 
between to generate a report when the value of the data element is between the two 
specified values in the query condition. 

5) For Values, click the Select button and select one or more values for the condition (for 
example, Pending or Approved). 

For maximum flexibility, choose a list of conditions but leave the value empty. This allows the 
user who runs the report to choose to use one or all of the queries to limit the data on which 
the report will be based. 
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6) If you want users to be able to modify these values when running the report, select Allow 
users to modify value(s) during execution. This option is checked by default and 
recommended to provide flexibility at report runtime. 

7) Click OK. 

Set up Title Page, Header, Footer, and Summary Page 

You can set up the report's title page, header, footer, and summary page from the Layout tab. 
These are all set up in a similar way. 

 The title page is printed as the first page of the report. 

 The header is printed at the top of each of the results pages. 

 The footer is printed at the bottom of each of the results pages. 

 The summary page is printed at the end of the report, after the results. 

To set up the title page, header, footer, and summary page 

1) In the Edit Report window, click the Layout tab. 

2) Under Report Properties, click Title Page, Header, Footer, or Summary Page. 

3) Click Add. 

4) Click Content and select from the list. The drop-down options are the same for left, center, 
or right columns. 

 Number of Projects/shells: Displays the number of projects or shells within the phrase 
"This report contains data from n projects or shells." 

 Page: Shows the page number for each page of the report. 

 Shell List: Provides a list of all of the projects or shells from which data is used for the 
report, in the format Project/Shell Number: Project/Shell Name. Can be used for reports 
on one or multiple projects or shells. 

 Shell Name: Displays the project or shell name when the report is for a single report. If 
multiple projects or shells are included in the report, the names will not be displayed (use 
Project/Shell List instead). 

 Shell Number: Displays the project or shell number when the report is for a single report. 
If multiple projects or shells are included in the report, the numbers will not be displayed 
(use Project/Shell List instead). 

 Query Parameters: Displays the query parameters entered from the report. 

 Report Owner: Displays the report owner. 

 Report Run By: Displays the user who ran the report. If the report was generated by 
schedule, the name of the report owner will be displayed. 

 Report Title: Displays the title of the report. 

 Run Date: Displays the date on which the report was run. This date/time reflects server 
time, that is, the time zone in which the server running your Unifier environment is 
located; for most users, this will be Pacific Time (GMT -8). If you have any questions 
regarding server time for your environment, contact your Company Administrator. 

 Run Date and Time: Displays the date and time on which the report was run. This 
date/time reflects server time. 
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 Time Zone: Displays the time zone that is applicable for the report, as chosen in the 
General tab of the Edit Report window (a default time zone or the user's at runtime). 

 Runtime Notes: Choosing this option does two things: provides a text box in which to 
enter notes that will appear on each report (for example, "Runtime Notes:"), and activates 
a Runtime Notes text box in the Notes tab during runtime in which the user running the 
report can add notes that will appear on the current report only. 

 Text: Provides a text box in which you may enter text to be displayed on the report. 

5) Use the Vertical Alignment, Font Size, and text style fields to edit the content. 

6) Keep an eye on the fields in the bottom of the window: 

 Current height (pixels): Displays the total height of the text (sum of the pixels of all 
lines) in the header, footer, title page, or summary page. 

 Maximum available height: Total allowable height. 

 Show Border: Selecting this check box will display a four-sided border around the title 
page, header, footer, or summary page text. 

Schedule Report Runs 

Report owners can schedule automatic generation of user-defined reports. The report can be 
scheduled to run daily, weekly, monthly, quarterly, or yearly. Schedule report results will be 
saved and can be retrieved later, or can be optionally emailed. 

Users with run permissions will be able to retrieve the generated reports. Report owners can 
schedule generation of the report. 

To schedule report runs 

1) Open the Edit Report window for the report and choose the Schedule tab. 

2) Select the Enable Scheduled Report Runs check box. 

3) Select the output format: 

 PDF: The results will be saved in a PDF file, which can be read using Adobe Acrobat 
Reader. 

 XML: The results will be saved in an XML file. 

 CSV: The results will be saved in a CSV file, which can be read using Microsoft Excel or 
another application that uses CSV. 

4) Specify the frequency with which the report will be run: 

 Daily: Report will be run daily. 

 Weekly: Specify the day on which the report will be generated. 

 Monthly: Specify the date on which the report will be generated. If the scheduled date is 
past the last day of the month (for example, the 31st), the report will automatically be 
generated on the last day of that month. 

 Quarterly: Generated at the end of each calendar quarter. 

 Yearly: Report is generated at the end of the calendar year. 

5) Specify the range of recurrence of the scheduled report: 

 No end date: The report will be generated according to schedule indefinitely. 

 End by: A date after which the scheduled report will not be generated. 
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6) Select Auto-email as attachment to report owner to have a copy of the report emailed as 
a PDF, XML, or CSV file attachment, based on your output format selection. 

Or select Auto-email as attachment to users and groups to have a copy of the report 
emailed as a PDF, XML, or CSV file attachment, based on your output format selection. Click 
Select, specify the users and groups, and click OK. You can select this option and 
Auto-email as attachments to report owner at the same time. 

Note: Be sure to specify Results from scheduled reports in your user 
preferences email management to receive the email and attachment. 

7) Select the Saved Result Log check box to save the report in the system, where you can 
view it at your convenience. 

8) Select the Document Manager check box to save the report in the Document Manager. 

In the Save as field, the system shows the name of the report; however, you can enter 
another name for the report if you want. 

In the Location field, click Select and choose the folder in the Document Manager in which 
the report should be saved. (You must have permissions to the folder.) 

9) Click OK. 

Report Run Times 

Run time reflects server time, that is, the time zone in which the server running your Unifier 
environment is located; for most users, this will be Pacific Time (GMT -8). If you have any 
questions regarding server time for your environment, contact your Company Administrator. 

 Daily: 23:59:59 

 Weekly: For example, from previous week Saturday (00:00:00) to this week Friday 
(23:59:59). 

 Monthly: For example, monthly (08/04/07) frequency should take last month (07/05/07 
00:00:00) to this month (08/04/07 23:59:59) 

 Quarterly: For example, data generated end of Q2 should be Q2 (04/01/07 00:00:00) to end 
of quarter Q2 (06/30/07 23:59:59). 

 Q1 is Jan to March, Q2 is April to June, Q3 is July to Sept, Q4 is Oct to Dec. 

 Yearly: For example, data generated end of 2007 should be 2007 01/01/07 00:00:00 to 2007 
12/31/07 23:59:59. 

Enable a Report for Web Services Integration 

You can flag project or shell and company user-defined reports as eligible for integration. This 
enables report results to be available for integration with other systems through web services 
and uLink. This option is not available for program-level reports. Contact Oracle Customer 
Support for information regarding XML integration via web services. 

To enable a user-defined report for web services integration 

1) Open the Edit Report window and choose the General tab. 

2) Select the Enable for Integration check box and click OK. The integration icon  will 
display in the UDR log next to the report. 
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Report Names: Because web services uses the report name to identify 
reports, each report marked for integration must have a unique name. 
For project- or shell-level reports, this applies to all UDRs within a 
specific project or shell. For company-level reports, it applies to all 
company-level UDRs. If there are two reports with the same name, only 
one of those reports can be marked for Integration. This is true even if 
you cannot see the other report with the same name. For example, 
another user has created a report with the same name, for which you do 
not have view permission, and marked it for integration. 

Access Control Permissions for UDRs 

You can assign User-Defined permissions in the following permissions-related module: 

 Access Control

1. Go to the Company Workspace tab and switch to Admin mode. 

2. In the left Navigator, click User Administration > Access Control. 

3. In the right pane, click User Mode Access > Projects/Shells > Reports. 

Project/Shell, Program, and Company Level 

Use the Create Permission Based permission to define whether the User-Defined report (UDR) 
being created will have data sources that are permission-aware. The permission-aware data 
sources are defined as data sources that only return data that the user has permissions to see 
by way of the user-interface (UI). This is based on records returned. That is, the user will be able 
to see the data that is in hidden blocks or hidden tabs. The following data sources are available 
to create permission-aware UDRs: 

 Business Process (BP) 

 Document Manager 

By default, Create Permission Based will be selected when user selects the Create permission 
for the user-defined reports. 

Permission Level Description 

The following permissions are selected: 

 Create All

 Create Permission Based

The user will be able to create report for all 
data sources as well as permission aware 
BP data sources. 

The following permissions are selected 
with "Full Access" attribute. 

 Create All

 Create Permission Based

The user will be able to create report for all 
data sources as well as permission aware 
BP data sources. 

The Create Permission Based 
permission is selected. 

The user will only be able to create report 
for permission aware BP data sources. 

The "Full Access" attribute is selected. The user will be able to create report for all 
data sources as well as permission aware 
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Permission Level Description 

BP data sources. 

The "Access All Projects" attribute is 
selected. 

The user will be able to create report in all 
projects. 

Note: The user will not be able to clear the Create Permission Based 
permission and only select the Create All permission. 

You can assign User-Defined permissions in the following permissions-related module, and the 
Create Permission Based permission is available in these modules: 

Note: Templates (for both Company-level and Project/Shell-level UDRs) 
will only be able to create system data sources templates. 

 User Administration

1. Go to the Company Workspace tab and switch to Admin mode. 

2. Click the Access Control node. 

3. Click to expand User Administration. 

4. Assign through Company Users, Partner Users, or Groups sub-nodes. 

 Standards & Libraries

1. Go to the Company Workspace tab and switch to Admin mode. 

2. Click the Access Control node. 

3. Click to expand Standards & Libraries. 

4. Assign through Permission Templates sub-node. 

Access Control Changes after Upgrade (Migration) 

In both Project/Shell Access Control and Company-level Access control: 

 If the previous Create permission was selected, then after upgrade (migration) both check 
boxes (Create All and Create Permission Based) will be selected. 

 If the Full Access permission is selected (all three check boxes) after upgrade (migration), 
then the Full Access, Create All, and Create Permission Based will be selected, after 
upgrade (migration). 

Creating User-Defined Project, Shell, Program, and Company Reports 

Before running a report, it must first be created and set up to define its parameters. The 
following procedures describe creating UDRs at the project or shell, program and company 
levels. This section will show you how to: 

 Access project, shell, program, and company UDRs 
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 Create a UDR by copying a template 

 Create a UDR by copying an existing report in the same log 

 Create a UDR from scratch 

Company Workspace Admin Mode UDR 

The following describes the User-Defined Reports log elements, for the Company Workspace 
tab (Admin mode).  

Go to Company Workspace (Admin mode) > Templates > Reports. The User-Defined 
Reports - Current View: All log opens.  

User-Defined Reports log menu options: 

File Enables you to perform the following 
actions: 

 New

 Copy

 Template

 Open

Edit Enables you to edit or Delete a report. 

View Enables you to perform the following 
actions: 

 All

 Find

 Saved Results

 Audit Log

Help Enables you to access: 

 Unifier Help

 Admin Help

 uDesigner Help

 Unifier Library

 User Productivity Kit

User-Defined Reports log toolbar options: 

New Enables you open the Create a new 
report (Create User-defined Report) 
window and set up the following fields: 

 Data Type

 Element

 Report Type

 Access Type
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Copy Enables you to copy a Template.

Open Enables you to open a record. 

Edit Enables you to edit a report. 

Delete Enables you to delete a report. 

Find Enables you to find a report on the log. 

User-Defined Reports log columns: 

The columns provide the following details about each UDR. 

 Enabled for Integration

 Name

 Description

 Data Type

 Access Type

 Report Type

 Owner

 Creation Date

 Last Modified By

 Last Modified Date

 Scheduled

Create a UDR from a report template 

The following procedure explains how to create a UDR by copying an existing report template. 

To create a user-defined report from a template 

1) Navigate to the project, shell, program, or company User-Defined Reports log. 

2) Click the Copy button and choose Template. The Copy From Report Template window 
opens. 

3) Select a template from the list and click the Copy button. The Edit Report window opens. 

4) Review the parameters on each of the tabs and edit as necessary. See Creating a UDR 
Template (on page 538) for details on the tabs. 

5) Click Apply to save changes, or OK to save changes and close the Edit Report window. The 
report is listed in the log. 

To create a user-defined report from an existing report 

1) Navigate to the project, shell, program, or company User-Defined Reports log. 

2) Select a report from the log. 
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3) Click the Copy button and choose Report. The Edit Report window opens. The default 
name is "Copy of Template Name." 

4) Follow the steps in the procedure Creating a UDR Template (on page 538). 

To create a user-defined report manually 

1) Navigate to the project, shell, program, or company User-Defined Reports log and click New. 

2) Follow the instructions in the procedure Creating a UDR Template (on page 538). 

Accessing User-Defined Reports (UDRs) 

User-defined reports (UDRs) are set up and run in User mode. 

You can run UDRs at the: 

 Project level 

 Shell level 

 Program level 

 Company level 

To access project-level, shell-level, program-level, or company-level user-defined reports: 

In User mode, Navigate to Reports > User-Defined. The User-Defined Reports log opens. 

When you are running a report based on a permission-aware Document Manager data source, 
the system lets you see the report only if you have permission to see the data source, in case of: 

 Document Manager - Company 

 Document Manager - Project/Shell 

Editing or Deleting User-Defined Reports 

You can edit most report parameters and assign report permissions to each report in User 
mode. You can also view the list of projects or shells that will be included in program-level 
reports, and select the projects or shells to include in company-level reports. 

This is applicable if you are the report owner, if you have edit permission, or if you are an 
administrator with full access permissions. 

To edit a user-defined report 

1) Navigate to the UDR log and select the report to edit. 

2) Click the Edit button. The Edit Report window opens. Review or edit the parameters on the 
tabs. For more information about each of the tabs, see Creating a UDR Template (on page 
538). 

3) Click Apply to save changes, or OK to save changes and close the Edit Report window. 

To delete a user-defined report 

Select a report from the log and click Delete. 
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Importing User-Defined Reports into Project or Shell Templates 

You can import user-defined reports into project templates from project templates in other 
Companies or other Unifier environments. Also, you can import user-defined reports into shell 
templates of the same shell type from other Companies or other Unifier environments. This lets 
you reuse reports created in other companies or environments. 

To import user-defined reports 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Reports > User-Defined Reports. 

3) In the User-Defined Reports log, from the toolbar, click Import to open the Unifier Login
window. 

4) Enter the following information: 

 Company Short Name: This is the identifier used for your company, and was set up at 
the time of company configuration. 

 Authentication Key: This key is set up at the time the company was configured. Contact 
your Site Administrator for further information. 

 Unifier URL: The web address of the Unifier server. 

 Search For: Use to narrow your search for the report you want to import. 

5) Click OK. The Import Report Template from Unifier window opens, listing the user-defined 
reports. 

6) Choose the report or reports and click Import. 

In case of errors, the UDR Import Error window opens, listing any import errors. These are 
some possible report import errors: 

 Source and destination report environments have different versions of Unifier 

 Report exists in the destination if the report is enabled for Integration 

 Report data sources vary between the report source and destination 

If there are no errors, all reports are imported; if there are errors, none of the reports are 
imported until the errors are rectified. 

Note: If you are importing a user-defined report into a shell template, the 
report you import must be from a shell of the same type as the 
destination shell template. 

7) When the import is complete, click OK. 

8) Click Close to exit the Import Report Template from Unifier window. The reports are 
added to the User-Defined Reports log. 

When you import a user-defined report, you are listed as the report owner. For more 
information about the User-Defined Reports log, see Accessing User-Defined Reports 
(UDRs). 
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Configuration Package Management 

You can manage the configuration package creation and import through the Configuration 
Package Management grouping node in the left Navigator. 

The Configuration Package Management grouping node enables you to: 

 Review the existing items in the Component Lists 

 Create a new Component List 

 Review the add-on component lists 

 Create new add-on component list 

 Review the existing configuration packages 

 Create new Configuration Package 

 Import a Configuration Package 

 Review the add-on configuration packages, if permitted 

Accessing Configuration Package Management 

To access the Configuration Package Management node, go to Company Workspace tab > 
Admin mode > Configuration Package Management. 

The Configuration Package Management grouping node has the following functional nodes: 

 Component Lists

A central repository that contains all the component lists designed in a given environment. 

 Add-on Component Lists

To create add-on component list in order to create configuration package that can be 
imported in to a different development environment. 

Note: The Add-on Component Lists functional node, when included 
with the Component Lists functional node, is only available in the 
development servers. 

The Add-on Component Lists functional node is available for the users who have "enable" 
permission for the Configuration Package Management grouping node. 

 Configuration Packages

The configuration packages in form of zip files that exist in the given environment. The 
packages displayed in the log are the packages that you have created in, or imported from, 
the given environment. 

 Add-on Configuration Packages

To create add-on configuration packages that can be imported in to a different development 
environment. 
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Note: The Add-on Configuration Packages functional node, along with 
the Component Lists functional node, is only available in the 
development servers. 

The Add-on Configuration Packages functional node is available for the users who have 
"enable" permission for the Configuration Package Management module. 

The following topics explain how to access the Configuration Package Management grouping 
node and the details for each of its functional nodes. 

In This Section 

Accessing Configuration Package Management Node .......................................... 569 
Component Lists ................................................................................................... 569 
Add-on Component Lists ....................................................................................... 572 
Configuration Packages ........................................................................................ 577 
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Configuration Package with Custom User Attributes (Exporting) ........................... 615 
Configuration Package with Custom User Attributes (Importing) ........................... 616 
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Importing Configuration Packages ......................................................................... 619 
Viewing Configuration Packages ........................................................................... 625 
Transferring Configuration Package (On Premises Only) ...................................... 625 
Installing Base Products (On Premises Only) ........................................................ 626 
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Accessing Configuration Package Management Node 

Access to the Configuration Package Management grouping node is controlled by 
permissions. 

To grant permissions to the Configuration Package Management grouping node: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click User Administration > Access Control. 

3) On the right pane, expand Administration Mode Access and then select Configuration 
Package Management. 

4) Use the Module Permission Settings window to add, modify, or remove users and groups.  

When you click Add to add a user, the Permission/Access Control window opens. In this 
window (under Permission Settings field), you can grant permissions to both users and 
groups by selecting Enable. 

Note: Users are able to view the contents of this node. 

Additional Information About Permissions in Configuration Package

By design, the system adds permission to the default group, in the destination module or source. 
To avoid conflict, ensure that you remove the default group. 

Component Lists 

The Component Lists functional node is a central repository that contains all the component 
lists existing in an environment.  

Note: If you created a Component List that is not currently listed, 
right-click the Component Lists functional node, and select Reload. 

The Component Lists node provides the following toolbar options: 

Create

Click Create to open the New Component List window. This window is divided into two 
panes. The left pane lists all the modules that you can select to include their components in 
your new component list, and the right pane lists the corresponding components to select. 
So, if you select the Data Cube Definitions from the left pane, the right pane displays the 
names of the components, the descriptions of the components, and the option to replace the 
component in the destination. 

Name

This is a required field that lets you to enter the name for the new component list. 

Error Check

This option lets you verify whether there are any errors or warnings related to the component 
list. 

Cancel
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This option lets you cancel creation of the new list. 

Save

This option lets you save the new list. 

Save As

This option lets you save a created component list as a different list. 

Find on Page

After you create a new component list, the system places the newly created component list in 
the Component Lists log. You can use the gear icon menu, next to the newly created 
component list, to conduct the following operations: 

 Open

 Delete

The user can delete the component list; however, if the component list is a part of any Draft 
status configuration package, then the user will not be able to delete the component list, and 
the user will see the following alert message: "The component list is used in a Draft 
Configuration Package and cannot be deleted." 

 Print

 Download last checked error/warning report

The Component Lists log displays all of the created component lists 
and provides the following details in column format: 

 List Name

The name assigned to the component list by the user at the time of creation. The component 
list name will be unique. If the user tries to create a duplicate list the system displays an alert 
message. For more information, see Creating Component List. 

 Last Error Check Status

The status for component list is determined by the Error Check action. There are three 
different statuses for the component list: 

 Pending: This status will be seen for the list which has not been error checked by the 
user. 

 Complete: This status will be seen when the user has performed the error check and 
there are no errors existing for the component list. 

 Error: This status will be seen when the user performed error check and there are errors 
which need to be resolved for the component list. 

 Creation Date

The date that the component list was created. This will retain the user's date preferences. 

 Last Error Check

The date that the error check was performed. This will retain the user's date preferences. If 
the list is in Pending status then the Last Error Check column will show empty for the 
corresponding list. 

 Last Modified Date

The date the component list was last modified on. 
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The Component Lists log is sorted by default on the Creation Date column. All other columns 
can be sorted as desired. 

Component List Associated with your Configuration Package 

To prevent errors, you do not need to create the component list manually to create a 
configuration package replicating the one in the Development environment. 

You can: 

 Create a new configuration package based on the component list that you have imported 
into the destination environment. 

 Replace the existing component list when you create the component  list through the 
configuration package. 

 Edit the new component lists created through configuration package import, once it is 
completed 

The preceding operations apply to both unpublished and published configuration packages. 

Replace in Destination Column (Import and Export) 

You can select which components will replace or override existing components, when you have 
created a configuration package for export. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration Package Management > Component Lists. 

3) In the Component List log, double-click the component that you want to open. 

The Edit Component List log opens. The Edit Component List log has two panes. The left 
pane is the components navigation pane, and the right-pane is the components log pane, 
corresponding to the component select from the navigation pane. 

In the Edit Component List log, from the components navigation pane, when you click any 
component, the corresponding component log includes the Replace in Destination column (the 
last column). 

When you select a component, you select the corresponding check box in the Replace in 
Destination column to indicate whether your selected component can replace the existing 
component in the destination. 

In case of Business Processes (from the components navigation pane click Setup, under the 
Company Workspace), you can do the same and indicate whether your selected BP can replace 
the existing BP in the destination by way of selecting the corresponding check box in the 
Replace in Destination column. 
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Note: For a single-record BP, whether you select the option Replace in 
Destination, or whether you do not select the option Replace in 
Destination, the system will replace the destination BP. 

When importing the configuration package, the components that have the additional Replace in 
Destination check box deselected will not override the existing component values with the 
contents from the package. The After Import Status value for those components will be No 
Change.  

If the component exists in the destination, it will get overridden, based on selecting Replace in 
Destination for that components in the package. If the component does not exist in the 
destination, it will be added by default. 

Example 

If a string drop-down (pulldown) DD such as Assigned Department which has been used in 
user attributes is modified in the destination server, and if the configuration package has 
same string drop-down (pulldown) DD (Assigned Department), where the Override option 
is not selected, then it will be ignored while importing the configuration package and in the 
destination server the Assigned Department values remains the same after the 
configuration package import. 

Note: Currently, all of the associated groups for the tagged components 
will be part of the configuration package (for some components users will 
also be tagged), and when the configuration package is imported, even 
though the components do not get updated because the Replace in 
Destination is set to No Change, the associated groups and users will 
be added into the destination. 

Add-on Component Lists 

The Add-on Components Lists sub-node lists all of the added component lists existing in the 
development environment and has the following toolbar options: 

Notes: 

 The Add-on Component Lists and the Add-on Configuration 
Packages follow the same naming convention as regular Component 
Lists and Configuration Packages, for package names. 

 The file names for Add-on and Component Lists cannot contain these 
characters: forward slash (/), backslash (\), colon (:), asterisk (*), 
angle brackets (< >), and vertical bar, or the pipe (|), quotation marks 
(“ ”), and question marks (?). You can use close bracket ([ ]), open 
and close braces, or curly brackets ({ }), apostrophe or single quote 
('), and semicolon (;). 

 The file names for Add-on and Configuration Packages (Package 
Name in Create and Import) cannot contain these characters: 
forward slash (/), backslash (\), colon (:), asterisk (*), angle brackets 
(< >), and vertical bar, or the pipe (|), quotation marks (“ ”), and 
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question marks (?). You can use close bracket ([ ]), open and close 
braces, or curly brackets ({ }), apostrophe or single quote ('), and 
semicolon (;). 

Create

Click to create an add-on component list. When you click Create, the Shell Templates window 
opens. 

From the Shell Templates window you must select a shell template. 

Notes: 

 Ensure that the components (from the selected shell template) do not 
contain dependencies on any shell attributes. 

 You must use unique names when you create multiple add-on 
component lists. 

The user can create a configuration package by using the add-on component list, based on a 
selected shell template. 

The Shell Templates window lists all of the available shell templates defined in the server. The 
shell templates are grouped by the shell type, in the Type drop-down list, regardless of the 
status of the shell template. 

The Shell Templates window has the following toolbar options: 

 Type: Enables you to select one of the shell types of multiple instance shells. 

 Search: Enables you to filter the displayed list, based on the search parameters defined in 
uDesigner. 

 Find on Page: To search for a particular item. 

You can only select one shell template. After you select a shell template from the Shell 
Templates window, you can click the Select option to open the New Add-on Component List
window. 

Depending on the shell template that you select, the New Add-on Component List window 
groups the types of components available to export on the left Navigator, as grouping nodes. 
The following lists some of such components: 

 Designs 

 Data Definitions 

 Data Elements 

 Data Structure Setup 

 Configuration 

 Designs, Log Views, Customize Email Subject, Custom Templates 

 Company Workspace: Setup 

 "Shell Template Name:Shell Template Number" 
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Note: The Designs component will not show the Shell Manager grouping 
node in add-on packages because you cannot include shell designs in 
the component list. 

If the selected "Shell Template Name:Shell Template Number" is displayed in the grouping 
node, then the components that are available for the shell template are as follows: 

Note: This list is based on the selected shell template. 

 Access Control 

 Setup 

 Folder Structures 

 Sheets 

 Rules 

 User Defined Reports 

 Dashboards 

All of the components available to be selected or tagged will be displayed similar to a regular 
component lists. For example, when you select "Setup," all of the components (such as the 
Business Processes, Dashboards, Gates, Configurable Managers, and so forth) that can be 
tagged will be displayed. 

When you create an add-on component list, you can perform the following additional actions, 
similar to the component lists: 

 Error Check: To open the Add-on Component Analysis window (read below) which 
displays the list of errors or warnings related to the components selected. 

 Save: To save add-on component list, with a user-specified list name. The list name will be 
shown in the log. 

 Save As: To save a component list with a new name. This allows you to work edit a 
component list. When you create an add-on component list and click Save or Save As, a 
unique name validation will take place. 

 Cancel: To discard your changes and close the window. 

Find on Page

To search for a particular item (a component list) in the Add-on Component Lists log. 

The Add-on Component Analysis window is displayed when you tag the components in the 
add-on component list and perform an error check. 

This window displays all of the dependency errors along with the miscellaneous errors or 
warnings. When you tag a shell template components and run an error check, you will see an 
error if the tagged shell template component has a dependency on the shell attribute design of 
the selected shell template. 

For example, if the BP setup component of the shell template is tagged, and the BP design has 
data elements (such as shell picker, shell data picker, linked elements, or any data element) that 
have a dependency on the shell attribute design of the selected shell template, then the Add-on 
Component Analysis window displays an error which explains why the BP setup component 
cannot be included in the component list. 
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At this stage, you will be able to fix the shell attribute design dependency errors either by 
deselecting the components that have a dependency on the shell attribute design of the selected 
shell template, or by saving it as a draft and making the necessary design changes accordingly 
and proceed to include component back in the add-on component list. This rule applies to all 
tagged shell template components such as BP Setups, Dashboard Setups, User Defined 
Reports, and so forth. 

Note: The published designs will not be included in this add-on 
component list for the selected components. 

When you finish, you can cancel the changes or apply the changes that you have made. 

If the Add-on Component Analysis window displays no errors or warnings (related to the 
add-on component list), the system displays the message: "There are no errors/warnings in the 
add-on component list." 

The Add-on Components Lists sub-node has the following columns: 

List Name The name assigned to the add-on component list, by the user, during 
creation. This is a required field in the add-on component list 
window. 

The List Name column will display the name of the component lists 
that have been created. The error check status will display the status 
of the component list, whether it is complete or in draft, similar to the 
regular component lists. 

Source Shell 
Template

This column will populate with the value "Shell Template Name:Shell 
Template Number" that the user has selected for the component list. 

Shell Type This column will display the shell type value based on the selected 
shell template. 

The tagged components might have dependency on Cost Manager 
of that shell type. 

The Shell Type field will be populated as either CBS Cost Codes or 
Generic Cost Codes, regardless of the components that are tagged 
with in the shell template. 

Note: The Shell Type field will be populated based on the shell 
template that the user has selected. 

One of the following values will be displayed based on the shell 
template selected. Selected shell template can be of the two types: 

 Generic Cost Codes 

 CBS Cost Codes 

Last Error 
Check Status

The status will be displayed based on the error check. The values 
can be one of the following: 

 Pending 

 Complete 

 Error 
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Creation Date The date the add-on component list was created. The date form is 
according to the user preferences. 

Last Error 
Check

The date the last error check was performed. The value will be 
empty if no error check was done for the add-on component list. 

The user can save the add-on component lists with errors. 

The user can also save the add-on component lists without doing an 
error check. 

The date component list is validated for any errors will be displayed 
in the Last Error Check column. 

Last Modified 
Date

The date the add-on component list was last modified. 

The gear menu options for each item in the Add-on Component Lists log: 

Open To edit the component lists that have been created. When you click 
Open, the Edit Add-Component List window opens. 

From the upper-right corner, use the Selected Components in the 
List menu (Numbered list icon) to open the Selected Components
window and view, see the total number of, or update the selected 
components. The function is similar to the function of the View > 
Selected Components option; however, this menu option enables 
you to select or deselect an item from the list and click Update to 
update the list of selected or not selected components. 

You can use the Print menu (printer icon) to print the items on the 
Edit Add-Component List window log. 

Use the Name field to change the name of the component. 

Use the Error Check option to run an error check for the items 
displayed on the log. 

Use Save to save any changes that you have made on an item. 

Use Save As to save an item with a different name. 

The Expand-Collapse option (plus or minus icon) enables you to 
expand or collapse the items on the log. 

The View option enables you to set the log view through the 
following options: 

 All Components: To see all of the components, in the window. 

 Selected Components: To see only the selected components, 
in the window. 

 Not Selected Components: To see only the components that 
have not been selected, in the window. 

The Actions menu allows you to select and deselect components 
from the list in bulk. 

Use the Find on Page to search for a specific item on the log. 
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Delete To delete the list name if it is not used in a draft of the Add-on 
Configuration Package. 

Print To print the package contents. 

Download last 
checked 
error/warning 
report

To download the last error or warning report. 

Configuration Packages 

The Configuration Packages page contains the following options: 

 Create

 Import

 Find on Page

The Configuration Packages log has the following columns: 

 Package Name 

 File Name 

 Description 

 Status 

 Last Modified By 

 Creation Date 

 Published By 

 Published to Production Date 

The Configuration Packages log is sorted based on the Creation Date column. 

The configuration package name (Package Name) is unique and cannot be duplicated. 

The options available under the gear icon (  ) are: 

 Open

 Download (Only for status Created, Import Success) 

 Download impact analysis report (Only for Import Success,  Import Failed, or Import 
Error) 

 Delete

 Download error/warning report

In addition to the regular errors and warnings, you can download the error report to see 
limited information about the exception context. 

Review the following topics for more information about: 

 Creating Configuration Packages (on page 605) 

 Importing Configuration Packages (on page 619) 
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 Viewing Configuration Packages (on page 625) 

Note: Pre-17.6 configuration package zip files will not be available in the 
log. If you want to view your pre-17.6 log content, Oracle recommends 
that you print your pre-17.6 log content prior to the upgrade. 

Add-on Component Lists and Add-on Configuration Packages 

Similar to the component lists and configuration package creation, when a user selects the shell 
template components to create an add-on component list, if the selected components have 
references to the custom user attributes, and the user attribute design is not included, the 
system displays messages regarding the inclusion of the custom user attributes (including 
pickers) when you are creating an add-on component list and add-on configuration packages. 

Note: If the custom user attributes are shell data pickers, then when you 
click export the system displays error messages while creating add-on 
component list or add-on configuration package because shell data 
pickers are dependent on the shell attribute design. 

Example 

The business process workflow setup filtering conditions has a shell picker as user attribute 
'Site Picker 1' in the filtering condition. 

Add-on Configuration Packages 

The Add-on Configuration Packages sub-node is available for the users who have "enable" 
permission for the Configuration Package Management module. This sub-node lists all of the 
added configuration packages existing in the development environment and has the following 
toolbar options: 

Notes: 

 The Add-on Component Lists and the Add-on Configuration 
Packages follow the same naming convention as regular Component 
Lists and Configuration Packages, for package names. 

 The file names for Add-on and Component Lists cannot contain these 
characters: forward slash (/), backslash (\), colon (:), asterisk (*), 
angle brackets (< >), and vertical bar, or the pipe (|), quotation marks 
(“ ”), and question marks (?). You can use close bracket ([ ]), open 
and close braces, or curly brackets ({ }), apostrophe or single quote 
('), and semicolon (;). 

 The file names for Add-on and Configuration Packages (Package 
Name in Create and Import) cannot contain these characters: 
forward slash (/), backslash (\), colon (:), asterisk (*), angle brackets 
(< >), and vertical bar, or the pipe (|), quotation marks (“ ”), and 
question marks (?). You can use close bracket ([ ]), open and close 
braces, or curly brackets ({ }), apostrophe or single quote ('), and 
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semicolon (;). 

Create:

To open the New Add-on Configuration Package window and create new add-on 
configuration packages. The process has the following steps (wizard interface): 

 Add-on Package Details

 Add-on Package Components - Error/Warnings

 Create

When you are done with each step, click Next to go to the next step. 

Use the Save as Draft option to save your work and change it at a later time. 

Add-on Package Details

This step allows you to enter or select the following for the add-on configuration package : 

 Add-on Package Name (required field) 

 File Name (required field) 

 Description

 Select an add-on component list (required field): A list of added add-on component 
lists is displayed under this field which enables you to select an item in order to include it 
in the add-on configuration package. You cannot select more than one item (add-on 
component list) for the add-on configuration package. The component list must have at 
least one component selected. The Shell Type field is read-only and the value is 
populated based the component list that you have selected from the list. The possible 
values for the Shell Type field are: CBS Cost Codes and Generic Cost Codes. 

After you select the required fields in the Add-on Package Details step and click Next, the 
configuration package components are shown from the components selected during the first 
step. This is a read-only view of all of the components from the selected component lists. For 
Example, if you select "Add-on Component List1" (including the Designs, Configurations, and 
Setups from Shell Template1), then packaged components will show the components from 
the selected list as follows: 

 Designs 

 Configurations 

 Setups (grouped by Shell Templates node) 

 User Defined Reports 

The left section of the window displays the grouping node of the packaged components. This 
is similar to the regular configuration package component view. The right side of the window 
shows all of the packaged components, for each grouping node. 

In the right side of the window, the toolbar options are context sensitive and you can expand, 
collapse, search for the items on the page. You can also filter the components seen on the 
right side. 

Add-on Package Components - Error/Warnings
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During this step, first the error check will be performed to determine if the package has errors 
or not. If the package has no errors, then you can see the Create step. You will see errors 
when the packaged components have dependency to the shell attribute design. You can 
resolve the shell design dependency errors by removing the elements from the tagged 
components which are dependent on the shell attribute design. In the case of seeing errors, 
you must use Save as Draft, fix the errors at the application level, and then proceed to push 
the package to the Create step. 

Create

When all of the errors are resolved, or there are no errors in the add-on configuration 
package, you can access the Create step and create the add-on configuration package, with 
the selected set of components. You can download the package after the creation. 

Import:

To import the new add-on configuration package in the destination development 
environment. The process has the following steps (wizard interface): 

 Select File

 Add-on Package Details

 User Mapping

 Import

When you are done with each step, click Next to go to the next step. 

Select File

The fields seen in the Select File step are as follows: 

 File Name: The exported zip file can be added in this field. 

Note: If you select the add-on package in the regular configuration 
package, then the following message will be displayed: "The 
Configuration Package zip file is an add-on package, not a valid regular 
package." 

 Add-on Package Name: You can specify the package name that can be used for import 
in this field. 

 Description: You can provide additional description for the add-on package details in 
this field. 

 Source Shell Type: This field shows the selected package to import along with the shell 
type components. The system will populate the shell type value of the selected package. 
The shell type value is read-only field and can have one of the following values, after you 
select the file: CBS Cost Codes and Generic Cost Codes. 



Configuration Package Management

581

 Select a destination shell template: This option enables you to select the destination 
shell template, where the components from source template can be added. By default, it 
will not show any shell templates. In this shell template log the Shell Number, Shell 
Name, and Status columns will be available. The Shell Number and Shell Name columns 
will display the number and name of the shell template. The Status column will show the 
status of the shell template. All of the shell templates seen are grouped by Shell Type. 
The list of shell templates will be displayed once you select the package file name. The 
shell templates list displayed will be based on the source shell type. For example, if the 
add-on configuration package that you have created has source shell template 
components which are based on CBS Cost Codes (shell), then the destination shell 
templates will show only the shell templates which are of CBS Cost Codes type. The 
same process applies to the Generic Cost Codes. Based on the source shell type the 
list of destination shell templates will be displayed in the Import step of the add-on 
package window. All active, inactive, and on-hold shell templates will be displayed based 
on the source shell type. The Find on Page option will be available to search for the shell 
template based on the name or number. By default, this option will not show any shell 
templates until you select the file name. 

 Destination Shell Template: This field gets populated with the selected shell template, 
from the right side. It displays the "Shell Template Name:Shell Template Number." This is 
a read-only field and shows the selected shell template. By default, this field does not 
show any value. If you do not select the destination shell template and click Next, then 
the following alert message is displayed: "Select a destination shell template before 
proceeding to next step." You must select all of the required fields before proceeding to 
next step, in the import add-on package wizard. 

Add-on Package Details

When you select the destination shell template in first step and click Next, you can view the 
selected package details. This is similar to the Add-on Package Components while creating 
the add-on configuration package. The package components from the selected zip file will be 
displayed. The options seen in the left navigation list will be the following, based on what is 
coming from the selected add-on component lists: 

 Designs (except shell manager) 

 Data Structure Setup

 Data Views

 Configuration

 Company Workspace > Setup

 Source Shell Template Components

The Designs node will show all of the designs that are a part of the add-on configuration 
package. The Data Structure Setup will show the data elements, or the data definitions, that 
are in the add-on configuration package. Similarly, the other grouping nodes will be shown 
based on the add-on configuration package contents. The Shell Template will show all of 
the components such as setups, access control, and so forth that are a part of the selected 
add-on configuration package. 

User Mapping
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After you click Next at the Add-on Package Details step, you will see the User Mapping
step. In this step, the BP Auto creator, in BP Setup component, will be extracted for user 
mapping. For the other component where users or groups are assigned (Example: WF setup 
or Access Control): 

 If all of the assignees are groups, then the groups will be extracted. 

 If all of the assignees are a mix of users and groups, then only the groups will be 
extracted. 

 If there are no users to map to, then the system displays the message: "There are no 
users to perform user mapping. Proceed to next step." 

All other validations will be same as currently seen in User Mapping window while importing 
configuration packages. 

Import

After you click Next at the User Mapping step, you will see the Import step, and the 
following message will be displayed: "When imported, the designs and setup components in 
the add-on configuration package overwrite the corresponding designs and setup 
components residing in destination server. Components from source template will be added 
to the destination shell template." You have the option to download the impact analysis 
report. The impact analysis report will be available for you to view after the import has been 
performed whether the import has been successful or not. Even if you deselect the option, 
you can still download the impact analysis report (from the gear menu) which will be 
available for packages in the import-related statuses in the configuration package log. 

Find on Page: To filter the rows displayed in the log. 

The Add-on Configuration Packages log has the following columns: 

 Package Name

 File Name

 Shell Type

 Description

 Status

 Last Modified By

 Creation Date

The gear menu for each item in the Add-on Configuration Packages log has the following 
options: 

Open To open the item 

Download Applicable only to the items with status: Created or Import Success 

Download 
impact 
analysis 
report

Applicable only to items with status: Import Success, Import Failed, or 
Import Error 

Delete To delete the item 
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Download 
error/warning 
report

Applicable only to items with status: Import Success, Import Failed, or 
Import Error 

The Add-on Configuration Packages log items are sorted according to the value of the 
Creation Date column, by default. The configuration package name must be unique and 
duplicated names are not accepted. If a configuration package exists in draft form, the system 
will not allow you to create a new (add-on) configuration package. 

The following restrictions will be applied for the Add-on Configuration Packages: 

 Additional Add-on Component Lists and Add-on Configuration Packages will be 
available only on the development server. 

 The option "Publish to Production" (in the gear menu) will not be available for the Add-on 
Configuration Packages. 

 The add-on configuration packages can be imported only within the development servers, 
from the Add-on Configuration Packages node. 

Creating Component List 

When you create a new component list, you can perform the following actions: 

 Error Check

When user clicks Error Check, the Component Analysis window opens displaying the list 
of errors/warning related to the component list. 

 Save

When user clicks Save, the component list will be saved with the user entered name. 

 Save As

When user clicks on Save As, a new window will open asking the user to enter the name for 
the new list. After clicking the OK button on the window, the existing component list will show 
the newly displayed name for component list and the user will be able to work on the 
component list for further edits. At this point, if the previous list has components selected, 
then those components will be retained for the new list. Also, the log will be refreshed to 
show the new component list created using Save As action. The unique validation for 
component list will be checked when the user clicks the OK button. 

 Cancel

When user clicks on Cancel, the window will be closed. 

With the Actions menu, you can also: 

 Select Components & Set Replace in Destination

When a user chooses Select Components & Set Replace in Destination, all highlighted 
components in the list will be selected for the configuration package, along with the Replace 
in Destination check box for each component. After the configuration package is deployed, 
all selected components will be available in the destination environment, and any existing 
components in the destination environment will be replaced by the same component in the 
configuration package, if the component has the Replace in Destination check box 
selected. 

 Select Components & Do not set Replace in Destination
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When a user chooses Select Components & Do not set Replace in Destination, all 
highlighted components in the list will be selected for the configuration package, but the 
Replace in Destination check box for each component will not be selected. After the 
configuration package is deployed, all selected components will be available in the 
destination environment, but any existing components in the destination environment will not 
be replaced, unless the same component has the Replace in Destination check box 
selected. 

 Deselect Components

When a user chooses Deselect Components, all highlighted components in the list will be 
deselected for the configuration package and will not be sent to the destination environment 
once deployed. If the component has the Replace in Destination check box selected, it will 
also be deselected. 

 Deselect Replace in Destination

When a user chooses Deselect Replace in Destination, all highlighted components in the 
list will no longer have the Replace in Destination check box selected. However, if the 
component is selected for the configuration package, it will not be deselected with this action.  

The left pane of the log displays the components that you can select. When you select a 
particular component, the items for the selected component that can be added are listed, and 
you can select the items individually. You can: 

 Use the check box, on top, to select/deselect all the items. 

 Use the View filter option to perform a quick filter. 

 Use the print option to print the list of selected components, in a consolidated format. 

 Use the expand all/collapse all to expand or collapse the component seen in the Grouping. 

The component list name is unique. If the user tries to create a duplicate list, the system displays 
an alert message. 

The left pane (navigation tree) in the window displays the following nodes: 

 Designs (folder) 

 Data Structure Setup (folder) 

 Basic Data Definitions 

 Cost Code Data Definitions 

 Data Cube Definitions 

 Data Views 

 Dynamic Data Sets 

 Company Access Control 

 Configuration  

 Designs 

 Log Views 

 Mobile Log Views 

 Pickers 

 Customize Email Subject 

 Customize Email Content 
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 Customize Templates 

 User Mode Navigator 

 Portal Landing Page 

 Company Workspace 

 Setup 

 Rules 

 Auto Update Status Setup 

 User Defined Reports 

 Company Templates 

 Cash Flow 

 Sheets 

 Folder structures 

 Rules 

 User Defined Reports 

 Shell Templates 

 Access Control 

 Setup 

 Folder Structures 

 Sheets 

 Rules 

 User Defined Reports 

 Single Instance Shells 

 Access Control 

 Setup 

 Rules 

 User Defined Reports 

 Analytics 

The following explains each node in detail. 

Designs 

The Design components can be selected and included in the component list required for 
creating configuration packages. The selected Design components overwrite, or insert, 
deployed/published versions of design components in the destination environment. Overwrite 
only occurs if the Replace in Destination check box is selected for the component. If the 
component does not exist in the destination environment, the configuration package will always 
insert the component into the destination environment. 

Displays the following design components, in groups: 

 Business Processes 

 Configurable Modules 
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 Cost Manager 

 Document Manager 

 Planning Manager 

 Portfolio Manager 

 Resource Manager 

 Schedule Manager 

 Space Manager 

 Shell Manager 

 User Administration 

 Activity Manager 

The following columns will be seen for each group: 

 Name

 Design ID

 Status

 Level

 Type

 Published Version

 Deployed Version

The log is sorted by default on the "Name" column and you can sort the other columns. The 
upper-right corner of the log has the following options: 

 Selected Components in the List menu

Enables you to open the Selected Components window and see the components that you 
have selected. This window allows you to find specific components that you have selected 
and update the list if you have deselected or selected more components. 

 Print

Enables you to print the list of selected components, in a consolidated format. 

 Close

Enables you to close the log. 

When the user selects the designs, for any of the design components, the deployed design 
version will be included as part of the component list. 

The published design version will be automatically considered as part of the component list only 
when there is a dependency from another selected component (for example, selected Setup or 
Configuration), in the component list. If user has not selected an existing published design, it will 
not be included in the component list. 

The published design version will not be included as a part of the component list if there are no 
dependencies. If any selected component is dependent upon the current published design 
version, the system displays messages during error check of the component list, or when the 
configuration package is being created. 
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Designs and Document Manager 

When the DMS attributes from of the Document Manager is included in the component list (to 
be further included in the configuration package), all of the folder properties attribute forms must 
be included in the component list with the corresponding document properties attribute forms 
and the document logs. 

Data Structure Setup 

The Data Structure Setup components can be selected and included in the component list 
required for creating configuration packages. The selected Data Structure Setup components 
overwrite, or insert, data set/default values in the destination environment. Overwrite only occurs 
if the Replace in Destination check box is selected for the component. If the component does 
not exist in the destination environment, the configuration package will always insert the 
component into the destination environment. 

The following are the sub-nodes available under Data Structure Setup: 

 Basic Data Definitions 

 Cost Code Data Definitions 

 Data Cube Definitions 

 Data Views 

 Dynamic Data Sets 

Each node, when selected, displays the columns: 

 Basic Data Definitions 

 Name 

 Input Type 

 Used in Selected Designs 

 Replace in Destination 

 Cost Codes Data Definitions 

 Name 

 Input Type 

 Replace in Destination 

 Data Cube definitions 

 Name 

 Description 

 Replace in Destination 

 Data Views 

 Name 

 Label 

 Description 

 Replace in Destination 

 Dynamic Data Sets 

 Name 
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 Description 

 Used in Selected Designs 

 Replace in Destination 

The default column sort is the Name column. 

Data Structure Setup - Basic Data Definitions

All basic data definitions are available for selection except for the: 

 Picker type 

 Data picker type 

 Check box type DDs 

When imported, the data sets/default values of the selected data definitions (included in the 
package) overwrite the existing data definitions in the destination environment only if the
Replace in Destination field is checked. 

If the data definitions do not exist in the destination environment, then all of the new data 
definitions imported as a part of the configuration package are inserted into the destination 
environment, by the system. 

The data sets/default values are not included for the data definitions that are not selected. 

If users have defined the data sets/default values in the destination server, then those values 
remain as they are. 

Used in Selected Designs

The column will have a "Yes" value for the Data Definitions (DDs) which are being used in 
the selected designs. If you deselect any particular design in the Design node, then if you go 
back to the Data Definitions node, the value will be empty for respective DDs. 

Note: The data set values are always included for Project phase data 
definition. 

Data Structure Setup - Cost Codes

All cost codes are available for selection. 

The selected Cost Codes (included in the package), when imported, overwrite as data sets 
values for the corresponding Cost Codes existing in the destination environment only if the
Replace in Destination field is checked. If the Cost Codes do not exist in the destination 
environment, the new cost codes, imported in as part of the configuration package, are 
inserted into the destination environment. 

The data sets/default values are not included for the data definitions that are not selected. 

Data Structure Setup - Data Views

All Data Views are available for selection. 

The selected Data Views (included in the package), when imported, overwrite in the 
destination environment only if the Replace in Destination field is checked. If the Data 
Views do not exist in the destination environment, the new Data Views, imported in as part of 
the configuration package, are inserted into the destination environment. 

The dependency errors related to data views not selected will be checked when component 
analysis is performed during the configuration package creation. 
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Note: For a Data View that is dependent on another Data View, there 
are no dependency errors that are when component analysis is 
performed during the configuration package creation; however, 
publishing of the Data View fails because of the dependency and the 
system displays an error message upon import. 

Data Structure Setup - Dynamic Data Sets (DDS)

The DDS are available for selection. 

The selected DDS, included in the configuration package when imported, either create a new 
configuration or overwrite the existing configuration in the destination environment, only if the
Replace in Destination field is checked. 

If the DDS does not exist in the destination environment, then the new DDS imported as a 
part of the configuration package are inserted into the destination environment, by the 
system. 

When a dynamic data set (DDS) is used in a uDesigner object (such as a business process), 
the DDS configuration that exists in the package must match the DDS configuration that 
exists in the destination environment; otherwise, Unifier will mark the process as a data 
definition conflict, and the import will fail. 

Used in Selected Designs

The column will have a "Yes" value for the Dynamic Data Sets (DDS) which are being used 
in the selected designs. If you deselect any particular design in the Design node, then if you 
go back to the Dynamic Data Sets node, the value will be empty for respective DDS. 

Company Access Control 

The Company Access Control permissions can be selected and included in the component list 
required for creating configuration packages. The selected Company Access Control 
permissions overwrite, or insert, permissions related to groups in the destination environment. 
Overwrite only occurs if the Replace in Destination check box is selected for the component. If 
the component does not exist in the destination environment, the configuration package will 
always insert the component into the destination environment. 

Displays the following access control permissions, in groups: 

 Administrator Mode Access 

 User Mode Access 

For static modules, there are no error check performed during component analysis. For dynamic 
modules (such as BP setup in Admin mode access or Data Cubes as non navigational nodes in 
User mode access), if the user selects modules dependent on components which have not been 
selected, when the component analysis is performed, the system displays a warning message 
indicating that the dependent component has not been selected, but the permissions have been 
selected. 
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Upon a successful import, the system updates the permissions for the selected modules. If the 
permissions (transferred as a part of the configuration package for dynamic modules) do not 
have the dependent components in the destination environment, and the configuration package, 
then the permissions will not be imported into the destination environment, and the system 
displays a message; however, if the dependent components are present in the destination 
environment, then the system updates the permissions, when imported successfully. By default, 
for "creator users," the permissions will be set to the "importer user" upon the configuration 
package creation, and in the destination environment. 

All Access Control permissions are available for selection. 

The selected permissions (included in the package), when imported, overwrite in the 
destination environment only if the Replace in Destination field is checked. If the 
permissions do not exist in the destination environment, the new  permissions, imported in 
as part of the configuration package, are inserted into the destination environment. 

Configuration 

The Configuration can be selected and included in the component list required for creating 
configuration packages. The selected Configuration overwrites, or gets inserted, in the 
destination environment. Overwrite only occurs if the Replace in Destination check box is 
selected for the component. If the component does not exist in the destination environment, the 
configuration package will always insert the component into the destination environment. 

The following sub-nodes are displayed under the Configuration node:  

 Designs

 Log Views 

 Mobile Log Views

 Pickers

 Customize Email Subject

 Customize Email Content

 Custom Templates (Custom Prints and Reports)

 User Mode Navigator

 Portal Landing Page

Designs 

Displays the configuration for the design components available for selection. The grouping, by 
headers, is as follows: 

 Business Processes 

 Configurable Module: <CM name> 

 Planning Manager 

 Portfolio Manager 

 Resource Manager 

 Shell Manager 

 Space Manager 

The following columns are displayed: 
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 Name 

 ID 

 Level 

 Replace in Destination 

Log Views 

Displays the log views available for selection. The grouping, by headers, is as follows: 

 Business Processes 

See Creating BP Log Views in Admin Mode (on page 234) (BP Log Views and 
Configuration Package) for more information. 

 Document Manager Log Views 

See Setting up the Document Manager (on page 453) (Document Log Views and 
Configuration Package) for more information. 

The following columns are displayed: 

 Name 

 ID 

 Level 

 Replace in Destination 

Mobile Log Views 

Displays the log views available for selection, for the Unifier mobile application. The following 
columns are displayed: 

 Name 

 ID 

 Level 

 Replace in Destination 

Pickers 

Displays a list of pickers that can be added under Configuration. After you add pickers in the 
component list, the pickers will be listed in the Selected Components window. 

The Component Lists function node, in the New Component List window, you can click 
Pickers to see the BPs that have CBS Picker (on the form) listed. 

If pickers are added in the Configuration Package for export, then after importing the package 
the pickers are shown under the Components pane in the Configuration Packages log. After 
importing the configuration package, if the pickers configuration was added, then there will be an 
entry for Pickers under Configuration in the "Impact Analysis Report," with the status and 
<Business Process name>. The Name column displays the value in this format: <Business 
Process name> - Pickers  

The values for Status are: 

 Added 

 Updated 
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 No change 

The following columns are displayed: 

 Name 

 ID 

 Level 

 Replace in Destination 

Customize Email Subject 

Displays the email subjects available for selection. The following columns are displayed: 

 Name 

 ID 

 Level 

 Replace in Destination 

Customize Email Content 

Displays the email contents available for selection. The grouping, by headers, is as follows: 

 Business Processes 

 Configurable Module: <CM name> 

 Planning Manager 

 Portfolio Manager 

 Resource Manager 

 Shell Manager 

 Space Manager 

The following columns are displayed: 

 Name 

 ID 

 Level 

 Replace in Destination 

Custom Templates 

Displays the Custom Templates available for selection. The grouping, by headers, is as follows: 

 Custom Email 

 Custom Print 

 Custom Report 

Note: The system does not display the application type and external 
type of reports. 

The following columns are displayed: 

 Name 

 Key 
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 Description 

 Replace in Destination 

User Mode Navigator 

Displays the active and inactive User Mode Navigator available for selection. The following 
columns are displayed: 

 Name 

 Type 

 Status 

 Replace in Destination 

Portal Landing Page 

Displays the active or inactive portal landing page setup available for selection. The following 
columns are displayed: 

 Name 

 Status 

 Replace in Destination 

Note: To include in the configuration package, you must include all 
image files and hyperlinks. 

Additional Information 

Portfolio Manager

As a part of Project Portfolio Manager (PPM) configuration, the "Display monthly breakdown of 
Actuals" option is included for the Configuration Package. 

If the check box for the "Display monthly breakdown of Actuals" option is selected when the 
PPM configuration is being included in the Configuration Package, then upon import to the 
destination environment, the user will see the check box selected. 

The Actuals source curve values displayed in the source environment (in the Derived curve 
properties) will be seen in the destination environment as well, when the Cash Flow is packaged 
as part of the Configuration Package. 

Company Workspace 

The components for the Company Workspace node can be selected and included in the 
component list required for creating configuration packages. The selected components for the 
Company Workspace overwrite, or get inserted, in the destination environment. Overwrite only 
occurs if the Replace in Destination check box is selected for the component. If the component 
does not exist in the destination environment, the configuration package will always insert the 
component into the destination environment. 

The following are the sub-nodes for the Company Workspace node: 
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 Setup

 Rules

 Auto Update Status Setup

 User Defined Reports

Setup

Displays the Setup (Company level) for the design components (Business Process and Planning 
Manager) available for selection. The grouping, by headers, is as follows: 

 Business Process 

 Planning Manager 

The following columns are available: 

 Name 

 ID 

 Status 

 Replace in Destination 

Rules

Displays the Rules (Company level) available for selection. The following columns are available: 

 Name 

 Control Source 

 Status 

 Replace in Destination 

Auto Update Status Setup

Displays the Auto Update Status Setup (Company level) available for selection. The following 
columns are available: 

 Name 

 Status 

 Replace in Destination 

User Defined Reports

Displays the UDRs (Company level) available for selection. The following columns are available: 

 Name 

 Data Type 

 Report Type 

 Replace in Destination 

Note: The UDRs listed are in User mode. 

All of the sub-nodes logs are sorted by default on the "Name" column and you can sort on any of 
the other columns. 
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Company Templates 

The components for the Templates (Company level) can be selected and included in the 
component list required for creating configuration packages. The selected components for the 
Templates overwrites, or gets inserted, in the destination environment. Overwrite only occurs if 
the Replace in Destination check box is selected for the component. If the component does not 
exist in the destination environment, the configuration package will always insert the component 
into the destination environment. 

The following are the sub-nodes for the Company Templates: 

 Cash Flow

 Sheets

 Folder Structures

 Rules

 User Defined Reports

Cash Flow

Displays the company-level Cash Flow templates available for selection. The following columns 
are available: 

 Name 

 Detail Level 

 Time Scale 

 Replace in Destination 

Sheets

Displays the company-level Sheets templates available for selection. The grouping, by headers, 
is as follows: 

 Commitment Funding Sheets 

 Commitment Summaries 

 Configurable Modules : <CM name> 

 Cost Sheets (The worksheets will be shown under this same grouping. However the name 
for worksheet will be shown as Worksheet : <worksheet name> ) 

 Funding Sheets 

 General Spends SOV sheets 

 Schedule Sheets 

The following columns are available: 

 Name 

 Description 

 Replace in Destination 

Folder Structures

Displays the company-level Folder Structures templates available for selection. The following 
columns are available: 

 Name 
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 Replace in Destination 

Note: For Folder structures, under Company Templates, you see the 
name column that correspond to all of the template name entries coming 
from Unifier. Only those templates that the user selects are included in 
the component list. 

Rules

Displays the company-level Rules templates available for selection. The following columns are 
available: 

 Name 

 Control Source 

 Status 

 Replace in Destination 

User Defined Reports

Displays the company-level UDRs templates available for selection. The following columns are 
available: 

 Name 

 Data Type 

 Report Type 

 Replace in Destination 

All of the sub-nodes logs are sorted by default on the "Name" column and you can sort on any of 
the other columns. 

Shell Templates 

The components for the Shell Templates can be selected and included in the component list 
required for creating configuration packages. The selected components for the Shell Templates 
overwrites, or gets inserted, in the destination environment. Overwrite only occurs if the Replace 
in Destination check box is selected for the component. If the component does not exist in the 
destination environment, the configuration package will always insert the component into the 
destination environment. 

Note: The respective folder properties and associated document 
properties attributes form and document log must be included as part of 
the configuration package when any shell, or shell template, (shell, or 
shell template that does not use the default form) is included. While 
creating configuration package the user will be notified of the inclusion of 
these attribute forms by a message. 

The Shell Templates displays the available shell templates grouped by their shells. You must 
select a shell template before selecting the following sub-nodes: 

 Access Control

 Setup



Configuration Package Management

597

 Folder Structures

 Sheets

 Rules

 User Defined Reports

The components are grouped based on the shell template that you have selected. The following 
explains each component under Components: 

Access Control

The Shell Templates Access Control permissions can be selected and included in the 
component list required for creating configuration packages. The selected Shell Templates 
Access Control permissions overwrite, or insert, permissions related to groups in the destination 
environment. 

Displays the Shell Templates Access Control permissions available for selection. The grouping, 
by headers, is as follows: 

 Administrator Mode Access 

 User Mode Access 

The following columns are available: 

 Module 

 Replace in Destination 

The log is sorted by default on the "Module" column and you can sort the other columns. 

For static modules, there are no error check performed during component analysis. For dynamic 
modules (such as BP setup in Admin mode access or Data Cubes as non navigational nodes in 
User Mode Access), if the user selects modules dependent on components which have not been 
selected, when the component analysis is performed, the system displays a message indicating 
that the dependent object have not been selected, but the permissions have been selected. 

Upon a successful import, the system updates the permissions for the selected modules. If the 
permissions (transferred as a part of the configuration package for dynamic modules) do not 
have the dependent components in the destination environment, and the configuration package, 
then the permissions will not be imported into the destination environment, and the system 
displays a message; however, if the dependent components are present in the destination 
environment, then the system updates the permissions, when imported successfully. By default, 
for "creator users," the permissions will be set to the "importer user" upon the configuration 
package creation, and in the destination. environment. 

Setup

Displays the Shell Templates Setup available for selection. The grouping, by headers, is as 
follows: 

 Business Process 

 Gates 

 Planning Manager 

 Resource Manager 

 Configurable Modules : <CM name> 

 Dashboard 
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 Replace in Destination 

For more information, see Conditions for Creating a Dashboard Setup Configuration 
Package. 

The following columns are available: 

 Name 

 ID 

 Status 

 Replace in Destination 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Folder Structures

Displays the Shell Templates Folder Structures available for selection. The following columns 
are available: 

 Name 

 Replace in Destination 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Note: For Folder Structures under Shell Templates, only the "Name" is 
displayed, at the root folder name. For Example if there is a folder 
Test12 available in Documents, then the name for the structure will be 
seen as Documents. 

Sheets

Displays the Shell Templates Sheets available for selection. The grouping, by headers, is as 
follows: 

 Configurable Modules: <CM name> 

All CM sheets for that specific configurable module will be seen in this group by 

 Cost Manager 

This group will list all the cost sheets, Cash Flow sheets, for the following: 

 Commitment Summaries 

 Commitment Funding sheet 

 General Spends 

 Payment applications 

 <BP name> - SOV 

Only those will be seen for which the structure has been created for that particular 
template. 

 Space Manager 

All Stack plans and level sheets will be seen under this group. 

 Schedule Manager 

All schedule sheets will be seen under this group. 

 Activity Manager 
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Includes Activity Sheet, WBS Sheet, and OBS Sheet.  

The following columns are available: 

 Name 

 Description 

 Replace in Destination 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Rules

Displays the Shell Templates Rules available for selection. The following columns are available: 

 Name 

 Control Source 

 Status 

 Replace in Destination 

The log is sorted by default on the "Name" column and you can sort the other columns. 

User Defined Reports

Displays the Shell Templates UDRs available for selection. The following columns are available: 

 Name 

 Data Type 

 Report Type 

 Replace in Destination 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Note: Based on the shell template selected, only the components related 
to the selected shell template are displayed and available for selection. If 
you deselect a previously selected shell template, the components of the 
deselected shell template do not display; however, if you select the 
deselected shell template, the components are displayed. 

Defining Shell-Specific Custom Print Templates for Business Processes 

In addition to editing shells that you have permissions for, you can view all Custom Print 
Templates and define them at the shell level. After you choose a shell template in the Company 
Workspace tab, you must select the Details icon in the upper-right corner of the dashboard. In 
the Details window, a Custom Print Template tab is available. 

The Custom Print Template tab contains a short description detailing its functionality and an 
Add Selective Custom Print Templates check box. The check box is deselected by default, 
which means every template that is available for BPs is available at run-time. If the check box is 
selected, only the selected templates are available at run-time. 
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Note: For further explanation of the check box, hover your cursor over 
the Question Mark icon next to the check box. 

Upon selecting the check box, a grid is displayed with Add Custom Print Template and Find 
on Page options. When you select Add Custom Print Template, a new window is displayed 
where you can select a Business Process from the dropdown. 

After you choose a BP, you can select the custom print templates that you want to add in the 
shell. The options for custom templates include all Published and Legacy templates. 

After you select one or more templates, you can add them to the Selected Items list by clicking 
the Right arrow. If you want to remove a template from the list, select the template and click the 
Left arrow. After selecting Save, the Add Custom Print Template window is closed and the 
chosen templates are displayed in the previous grid. 

To delete a newly added template, select the Trash Bin icon in the far right column of the grid. 
To find a specific template, select the Find on Page option. 

Supporting Shell Attribute View Forms 

Since you can include View Forms in shell attributes and restrict users and group (who are 
members of the shell) to view the forms added to the shell properties (View Forms tab), you can 
use the Configuration Package to export and import the View Forms tab information (along 
with other tabs) of the shell properties of your selected shell templates or single instance shells. 

In general, you can export and import the shell attribute design (which includes both the action 
forms and the view forms), and the view form permission settings (added in the View Forms tab 
of the shell or shell template properties), by way of Configuration Package. 

Configuration Package export for shell templates and single instance shells

When you tag one or more shell templates that have view forms setup in the Component 
List, then along with other shell tabs the View Forms tab information will be exported, when 
you create the Configuration Package. 

Along with the view forms, the users, groups, and shell administrator, who are part of the 
permission settings of view forms, will be exported. For other modules in the BP setup, the 
users, groups, and shell administrator associated to the permission settings will not be 
exported. In other word, the users, groups, and shell administrator associated to the 
permission settings in the View Forms tab of the BP setup will not be exported; however, the 
users, groups, and shell administrator permission settings in the view forms setup (in the 
shell attribute form) will be exported. 

When the published shell design does not have all the view forms added in the tagged shell 
template in the Component List, then the design dependency error is displayed, when you 
conduct error check in the Component List. Add the dependency component to fix this 
error. 
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If you tag a shell template (that has view forms) in the Component List, and the published 
design has those view forms already, then the system does not validate for the latest 
deployed design. Also, if the tagged shell template does not have any view forms, and the 
shell design is published, then the system does not validate for any latest deployed design 
while creating the Configuration Package. Similarly, when you tag a single instance shell, 
and the selected shell instance has view forms setup, then along with the other tab 
information all of the view forms and permission settings (for the users, groups, and shell 
administrator) will be exported. 

Import of Configuration Package containing shell templates with view forms

When you import the Configuration Package containing shell templates with view forms 
into the destination server: 

 If the shell template does not exist, then a new template will be created and view forms 
setup information (forms and permission settings for groups) will be added. 

 If the destination server already has the shell template, then the view forms setup 
information will be updated by way of importing the Configuration Package. 

 If Configuration Package created has a single instance shell with the view forms setup, 
then in destination server the single instance shell will be imported when the component 
does not exist. The view forms setup information are also imported along with the other 
tabs. In the case the destination server already has a single instance shell, then the 
single instance shell information will not be updated, including view forms information. 

Single Instance Shells 

The components for the Single Instance Shells can be selected and included in the component 
list required for creating configuration packages. The selected components for the Single 
Instance Shells overwrites, or gets inserted, in the destination environment. 

Note: The Replace in Destination option is not available for components 
in this node, as all components will be overwritten.  

The Single Instance Shells displays the available shells for selection. You must select a shell 
from the Single Instance Shells before selecting the following sub-nodes: 

 Access Control

 Setup

 Rules

 User Defined Reports

The components are grouped based on the shell template that you have selected. The following 
explains each component under Components: 

Access Control

The Single Instance Shells Access Control permissions can be selected and included in the 
component list required for creating configuration packages. The selected Single Instance Shells 
Access Control permissions overwrite, or insert, permissions related to groups in the destination 
environment. 
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Displays the Single Instance Shells Access Control permissions available for selection. The 
grouping, by headers, is as follows: 

 Administrator Mode Access 

 User Mode Access 

The following columns are available: 

 Module 

The log is sorted by default on the "Module" column and you can sort the other columns. 

For static modules, there are no error check performed during component analysis. For dynamic 
modules (such as BP setup in Admin mode access or Data Cubes as non navigational nodes in 
User Mode Access), if the user selects modules dependent on components which have not been 
selected, when the component analysis is performed, the system displays a message indicating 
that the dependent object have not been selected, but the permissions have been selected. 

Upon a successful import, the system updates the permissions for the selected modules. If the 
permissions (transferred as a part of the configuration package for dynamic modules) do not 
have the dependent components in the destination environment, and the configuration package, 
then the permissions will not be imported into the destination environment, and the system 
displays a message; however, if the dependent components are present in the destination 
environment, then the system updates the permissions, when imported successfully. By default, 
for "creator users," the permissions will be set to the "importer user" upon the configuration 
package creation, and in the destination. 

Setup

Displays the Single Instance Shell Setup available for selection. The grouping, by headers, is as 
follows: 

 Business Process 

 Gates 

 Planning Manager 

 Resource Manager 

 Configurable Modules : <CM name> 

 Dashboard 

The following columns are available: 

 Name 

 ID 

 Status 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Rules

Displays the Single Instance Shells Rules available for selection. The following columns are 
available: 

 Name 

 Control Source 

 Status 
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The log is sorted by default on the "Name" column and you can sort the other columns. 

User Defined Reports

Displays the Single Instance Shells UDRs available for selection. The following columns are 
available: 

 Name 

 Data Type 

 Report Type 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Note: Based on the Single Instance Shells selected, only the 
components related to the selected Single Instance Shells are displayed 
and available for selection. If you deselect a previously selected Single 
Instance Shells, the components of the deselected Single Instance 
Shells do not display; however, if you select the deselected Single 
Instance Shells, then the components are displayed. 

Defining Shell-Specific Custom Print Templates for Business Processes 

In addition to editing shells that you have permissions for, you can view all Custom Print 
Templates and define them at the shell level. After you choose a shell template in the Company 
Workspace tab, you must select the Details icon in the upper-right corner of the dashboard. In 
the Details window, a Custom Print Template tab is available. 

The Custom Print Template tab contains a short description detailing its functionality and an 
Add Selective Custom Print Templates check box. The check box is deselected by default, 
which means every template that is available for BPs is available at run-time. If the check box is 
selected, only the selected templates are available at run-time. 

Note: For further explanation of the check box, hover your cursor over 
the Question Mark icon next to the check box. 

Upon selecting the check box, a grid is displayed with Add Custom Print Template and Find 
on Page options. When you select Add Custom Print Template, a new window is displayed 
where you can select a Business Process from the dropdown. 

After you choose a BP, you can select the custom print templates that you want to add in the 
shell. The options for custom templates include all Published and Legacy templates. 

After you select one or more templates, you can add them to the Selected Items list by clicking 
the Right arrow. If you want to remove a template from the list, select the template and click the 
Left arrow. After selecting Save, the Add Custom Print Template window is closed and the 
chosen templates are displayed in the previous grid. 

To delete a newly added template, select the Trash Bin icon in the far right column of the grid. 
To find a specific template, select the Find on Page option. 
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Analytics 

The Analytics can be selected and included in the component list required for creating 
configuration packages. The selected Analytics overwrites, or gets inserted, in the destination 
environment. Overwrite only occurs if the Replace in Destination check box is selected for the 
component. If the component does not exist in the destination environment, the configuration 
package will always insert the component into the destination environment. 

When you click Analytics, the system displays a list of analytics available for selection. 

The log contains the "Name" and "Replace in Destination" columns only. 

Cost Attributes - Cost Sheet 

If the Analytics Cost Sheet node is selected, users can export and import the Configuration 
Package to other environments. 

After you defined mappings (in the Data Mapping - Cost Attributes tab), if the option Cost 
Sheet is selected (the Component Lists node > Configuration Package Management > 
Analytics), then the source design, in uDesigner (Cost Code Attributes (Design ID = 
standard_cost)) has to be selected. 

Component Analysis for Component Lists 

You can perform component analysis for the components that you have selected in the 
component list. When you click Error Check, in the component list creation screen, the system 
displays the component analysis screen. 

The following conditions apply when you import a configuration package containing referenced 
user attributes into your destination environment that has user attribute design: 

 You can import a configuration package containing referenced user attributes into your 
destination environment that has user attribute design provided that the user attribute design 
in your destination environment has matching data element names and data definitions. 

 You cannot import a configuration package containing referenced user attributes into your 
destination environment that has user attribute design, but the user attribute design does not 
have matching data element names and data definitions. 

 To import a configuration package containing referenced user attributes into your destination 
environment that does not have user attribute design, you must first add the user attributes 
to the user attribute design of the destination environment and deploy before you can 
complete the import successfully. 

In case of errors, the system displays the following error types; 

 Dependency errors 

 Miscellaneous errors 

 Warnings 
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Dependency Errors 

These errors are displayed when the components available inside the component list have 
dependency errors. Dependency errors occurs when the user has selected primary components 
in the component list but did not select the dependent components. 

Example 

While creating a component list, the user selected a UDR report but did not select the 
dependent BP design. 

The system displays dependency errors as groups, in the Component Analysis screen, and the 
Fix Action column displays a symbol. If you hover over the symbols displayed, the system 
displays the action that you need to take. 

To correct a dependency error, you have two options: 

a) Add the missing component    (check mark in a circle) 

You can add the dependent components (in the error list) and resolve the errors. 

b) Remove the existing component (minus sign in a circle) 

You can remove the selected components from the list and resolve the errors. 

The system processes the error list and the list can be refreshed by clicking Refresh. 

Miscellaneous Errors 

These errors are encountered when the components have other miscellaneous errors that have 
to be fixed at the application level. 

Warnings 

The system displays warnings related to components present in the component list, using  
(the yellow triangle symbol). 

Creating Configuration Packages 

In the Configuration Packages log, when you click Create the New Configuration Package
window opens, displaying the Package Details step of the creation wizard, by default. 

The creation wizard has the following steps: 

Note: You cannot create a configuration package with a component list 
that has no components selected. 

 Package Details

Mandatory details related to the configuration package must be entered in this step. 

 Package Components

Displays the configuration package component preview, based on the selected items from 
the Components Lists. 
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 Create

Enables you to publish the configuration package for production and download the 
configuration package zip file. 

In the configuration package log, you can create configuration packages that do not have user 
attribute design included in the package but have custom user attributes, including the picker 
elements. All of the referenced processes must be included in the configuration package. If the 
custom user attribute is a data picker, then the data source and display element will be included 
in the package, if created successfully after error resolutions. 

Package Details 

The Package Details contains the following fields, selections, and columns: 

 Package Name (required) 

 File Name (required) 

 Description

 Select one or more component lists (required) followed by two columns listing the 
components lists (find and multiple selection is available) and the creation dates. 

The File Name and Description fields will be auto-populated once you enter the Package 
Name. You will be able to edit both the fields further. 

You can select one or more component lists that have components which refer to the custom 
user attributes. After you select the component lists and navigate to the next step, the Package 
Components window displays all of the components that are in the selected component list, 
including the user data picker data definitions and custom user attributes data definitions. The 
referenced user attributes will be included in the package. 

Note: The Designs node (the left navigator of the New Configuration 
Package window) will not have the User Attribute form included. 

Package Components 

When you click Next in the Package Details step, you go to the Package Components step. The 
Package Components page displays the package components from the selected components 
list (from the Package Details step). 

Only two categories, and components, that are part of the selected component list are shown. 

Example 

If the user selected, List 1 (with categories Designs and Analytics) and List 2 (with categories 
Designs and Configuration and Configuration included business processes, only), then the 
following is displayed in the package components: 

Categories 

 Designs 

 Configuration 

 Analytics 
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Since the configuration included the component business process, the business process 
components are displayed under Configuration. Based on what is transferred from the 
selected items under Component Lists, you will see: 

 Designs (There will be tab to see the Published designs , if any published designs are 
coming as part of the selected component lists. ) 

 Data Structure Setup 

 Access Control 

 Configuration 

 Company Workspace 

 Company Templates 

 Shell Templates 

 Single Instance Shells 

 Analytics 

You can use the filter option to search data for each column. 

The print option prints the consolidated report, based on the selected components. 

Click Next to go to the Creation step. 

Errors and Warnings 

When you click Next in the Package Components step, the system performs an error check to 
determine whether the configuration package is complete. 

If there are no errors, you can see the last step, Create. 

If there are errors, the system displays the Error/Warnings step. In this step, you can resolve 
errors dependency errors dynamically. After you fix the errors dynamically, click Back to see the 
results. 

For other types of errors, you must save as draft, fix the errors at the application level, and then 
run the step. 

The Refresh option enables you to refresh the dynamically resolved errors and proceed with the 
error processing. 

When all the errors are resolved, or there are no errors in the configuration package, you can 
click Next in the Package Components step and go to the Create step. 

The Errors/Warnings window displays the warning messages related to the: 

 Inclusion of custom user attributes referenced in the selected components. 

 User attribute design that is missing in the selected component list. 

The following additional note will be displayed in the Errors/Warnings top section, if the 
component lists part of this package have references to custom user attributes, but the user 
attribute design is not included: "This package contains component lists which do not have user 
attribute design and therefore cannot be published for production server use." 

Note: The user attribute design will be included when there is a 
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published version, in this case. 

For the configuration packages that do not have the user attribute design included but have the 
custom user attributes included, if you click Publish to Production (in the Configuration 
Package log), the system displays the following message: "This package contains components 
that have references to custom user attributes but user attribute design is not included and 
therefore cannot be published for production server use." In this case, in the Create step, the 
option is not available. 

Create 

In the Creation step, you can publish your configuration package for production and download 
the configuration package zip file after creation. 

When you click Create, the system creates the configuration package. 

Creating a Configuration Package for Export 

When creating a configuration package for export, if the selected components have references 
to the custom user attributes, you are not required to tag the user attribute design. 

When you create a component list, or when you edit an existing component list, if the tagged 
components have dependency on the user attribute design, then the Component Analysis
window does not displays the dependency errors, instead the Component Analysis window 
displays the warnings related to the user attribute design that were not selected. 

Note: If there are component lists that are in Error Status because the 
user attribute design was not included before an upgrade, the Error 
Status will remain unless you run the error check again. 

Example 

The "EmployeeID" data element, in the user attributes, is referenced in filtering conditions in 
the "Action Items" BP workflow setup. In this case, the "EmployeeID" data element will be 
included in the packaged components, and the following warning messages will be 
displayed, with the first warning message indicating that the user attribute design is not 
included in the component list: 

 The selected components have references to the custom user attributes and <user 
attribute design name> is missing in the component list. 

 The additional filtering conditions in the component list, defined in the workflow business 
process setup of Action Items, requires the "EmployeeID" data element in user attributes 
and will be included. 

The first warning message indicating that user attribute design will not be included in the 
component list will be shown only when user attribute design is not selected and the design is 
not published. 

 Component Name should be User Administration. 

 Location Column should be shown as Design. 

 Name should be shown as <user attribute name>. 
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There will be an additional note displayed in the top section of the Component Analysis
window, and it will be as follows: "Note: The package created using this component list does not 
include user attribute design. You can include the user attribute design by fixing the dependency 
warning to create a package for production." 

In this case, the Component Analysis window will show warning messages detailing the 
inclusion of customer user attributes referenced by user pickers, user data pickers, BP setup 
filter conditions, and so forth that are in the selected components. 

All of the custom user attributes referenced by the selected designs, setups, and so forth, in the 
component list, will be included without including the user attribute design. 

In the Component Analysis window, the Fix Action option    is provided to enable you to 
include the dependent user attribute design into the component list created and apply the 
changes. 

The components which have custom user attributes references will be displayed as warnings in 
the Component Analysis window, and there will be a resolving action (minus sign in a circle) to 
enable you to exclude those components. 

Note: If in the source environment the user attribute design is already 
published, then the design will always be included and no additional 
warnings will be seen. 

If the published user attribute design does not have all of the data elements that are referenced 
by the selected components (such as BPs), then an error message will be displayed. 

If, in the source server, the components selected in the component list have custom user 
attributes that are data pickers that refer to another design, then Unifier displays errors when you 
are creating the configuration package, or performing error check in the component list. You 
must select the user attribute design if there are pickers in the custom user attributes in the 
package. 

Example 

When a BP WF setup assignee filter conditions have Space DP display as one of the 
conditions, the following error message will display while performing export: "The additional 
filter conditions defined in the workflow for Action Items business process setup requires 
data picker elements Space DP in user attribute design [User Attributes]. The user attribute 
design that has data picker elements must be included in the component list." 

The above error can be resolved by including the user attribute design into the component list. 

Exporting CBS Picker Query Modifications 

You can export a BP configuration package that contains a CBS Picker with defined query 
condition into the shell template.  

If you select the Replace in Destination option, then you ensure that your CBS Picker with 
defined query condition are accessible in the destination server, after importing the added 
configuration package (as add-on) in the development environment. 

Pickers in Add-on Component List
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In the New Add-on Component List window, left pane, you can click the Pickers 
configuration component to see the list of BPs that contain CBS Picker data element 
(bitemID). 

The Selected Components window lists the added BPs, which contain the CBS Picker data 
element (bitemID), under the Configuration category, with Picker as the Component. 

Add-on Component Analysis

After you tag a component in the add-on component list, the system opens the Add-on 
Component Analysis window and displays errors and warnings, if applicable. 

Note: You cannot include a shell design in the add-on component list. 

If pickers are added in the add-on configuration package for export, then after importing the 
add-on configuration package the system will include Add-on Configuration Components
as a functional node under the Configuration Package group node, in the left Navigation. 

The system will also include an entry for pickers under Configuration in the Selected 
Components window. Additionally, in the Impact Analysis Report, there will be an entry for 
pickers under Configuration including the status (Added, Updated or No change) and the 
BP name. 

Creating a Configuration Package for Import 

In the Configuration Packages log, when you click the Import toolbar option, the Import 
Configuration Package window opens. 

The Import Configuration Package window has the following steps that you can complete 
through corresponding wizards: 

Select File This step has the following fields: 

 File Name (required) 

 Package Name (required) 

 Description

You must select a valid zip file from the 
local system for the File Name.  
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Package Details This is a view-only step enabling you to 
view the configuration package 
components. 

This step displays the configuration 
package components, from the selected 
zip file. It also shows only those 
categories, and components, that are in 
the selected configuration package. 

If available, the "Data Structure Setup" 
category (on the left navigator) shows the 
additional user attributes data definitions 
and dependent user data picker definitions 
that are a part of the configuration 
package. 

User Mapping Unifier extracts the user's information for 
user mapping: 

 Shell Administrator 

 Auto-Creator for Business Process 
records or line item. 

Only the groups will be extracted from 
other components. 

Import See below. 

Import 

In this step you can: 

 Indicate whether you want to import the associated component lists along with the 
configuration package.  

When you select the Do you want to import the associated component list? option, the 
system allows you to import the associated component lists along with the configuration 
package, if necessary. For more information, see Creating Configuration Packages (on 
page 605). 

When you select the option the system enables you to enter the name of the associated 
component list in the List Name field. In this case, the system will perform the necessary 
validations when you click Import. 

If you enter the name of an existing component list in the List Name field, then the system 
will replace the existing component list; otherwise, the system will create a new component 
list, upon a successful import of the configuration package.  

When you import the configuration package successfully, the system creates the new 
component list and assigns the error check status as pending. 

All of the packaged components are shown as selected in the component list. 

If the component list has the option Replace in Destination selected in the source, then the 
system retains the property for the selected components in the component list. 
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When the configuration package has been imported successfully, the system adds the 
published designs into the configuration package automatically, if the designs have been 
referenced, and the component is in the destination. In this case, the system tags all of the 
published designs that have been referenced in the component list that has been created in 
the destination. 

You can filter the selected component lists. 

The system will always create a component list, if: 

 It is selected to create one in the import step, and  

 The package import is successful. 

 Select Download the Impact Analysis Report option and click Import. 

In the Import User Attributes window, you will see whether the selected configuration package 
has custom user attributes that are not existing in the user attribute design in destination 
environment. If the custom user attributes exist in the destination, the Import User Attributes
window will not be displayed. 

In the Import User Attributes window, you will be provided with the list of data elements (from 
the configuration package) that do not exist in the destination user attribute design. The Import 
User Attributes window allows you to choose one of the following actions, if in the destination 
user attribute design does not exist: 

 Add the data elements to the <destination user attribute form> user attribute design. 
(selected by default) 

Select this option and proceed with the import of package by clicking Continue. The import 
process might result in an error if, for example, the status of the user attribute design is 
Draft, or if there is a mismatch between the "design" and the "deployed" versions of the 
"design." 

This option enables the import process to continue. If there are no other errors, then the 
custom user attributes will be added to the destination user attribute design if the "design" 
and the "deployed" versions are the same and the "design" is in a complete status. 

 Add the data elements to the Data Structure Setup but not to the user attribute design

Select this option and proceed with the import of package by clicking Continue. The import 
process results in an error because the user attributes are not added to the user attribute 
design. Add the data elements to the user attribute design and try to import again. 

This option enables the import process to continue. The data elements will get added into the 
destination server even if the import fails because of referenced user attributes in the 
configuration package. 

During import, the additional custom user attributes that do not exist in the destination will be 
added to the user attribute design, based on the following conditions: 

 User attribute design in the destination should be in Complete status. 

 In the destination server, the user attributes design and the deployed version should 
match. 

If the above two conditions are met, then the additional custom user attributes will be added 
to the destination user attribute design, after the import. 
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Note: In the above case, the destination server user attribute design is 
allowed to have a higher version than the source. 

If any one of the above conditions are not met, then the import fails. 

You have the option to download the impact analysis report and view the import errors and 
warnings, by using the gear menu which will be available for the configuration packages that 
you had selected for import (in the configuration package log). In addition, if the custom user 
attributes that are coming as part of the configuration package exist in the destination, then: 

 If the data element name and data type (or data definition) match (and are not currently a 
part of the user attribute design), the data elements will be added, if the above conditions 
are met. 

 If the data element name and data type (or data definition) match (and are currently a 
part of the destination user attribute design), no changes are needed. 

 If the data element name and data type (or data definition) do not match, import fails. In 
the case of adding new data elements (custom user attributes) into the destination, and 
the data definition exists with same name but with different definition, the following error 
message is displayed in the errors and warnings report: "The data element {0} from the 
Configuration Package cannot be added to the destination environment due to conflict in 
data definition {1}." The "Component" for this message is the "User Attributes," and the 
"Location" will be "Designs." 

If you click Cancel, or close the Import User Attributes window, the following confirmation 
message is displayed: "The import process will be canceled. Do you want to continue?" If you 
click "Yes," then the Import User Attributes window closes, and the import process stops. 

The data elements that do not exist in the destination server are displayed in the grid and will 
have the following columns: 

 Data Element: Displays the name of the data element. 

 Data Definition: Display the data definition of the data element. 

 Data Type: Displays the data type of the data definition. 

 Input Type: Displays the Input Method of the data definition. 

When the destination server does not have user attribute form defined, if in the destination 
server there is no user attribute design, and the configuration package has custom user 
attributes, then the following message appears in the errors and warnings report, after you click 
Import: "Import has failed. The destination server does not have the user attribute design that 
can add the custom user attributes included in your package." 

When you import the configuration package (Import Configuration Package window), and you 
select to create a component list associated to the configuration package (Do you want to 
create a Component List associated to the package? > Yes), the system will update the 
component list entries, but the entries will not display in the log, right away. To see the updated 
component list, click Reload on the Configuration Packages functional node.  
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Data Structure Setup Component in Impact Analysis Report 

The impact analysis report is created whether the configuration package import succeeds or 
fails. When a configuration package has custom user attributes, and you have selected to add 
the custom user attributes (data elements and dependent data definitions) in the Import User 
Attributes window (Add the data elements to the Data Structure Setup but not to the user 
attribute design), then the impact analysis report lists all of the data elements that are added 
into the destination server. That is to state that the Data Structure Setup window lists 
components affected in data structure setup by providing the following information in column 
format: 

 Component

 Status

 Name

 Description

The Data Structure Setup module shows the additional data elements that were included in the 
destination server because of importing the configuration package. In the report: 

 Name column will show data element name that was added 

 Description column will show as "Included but have not been added to user attribute 
design." 

 Status column shows "Added." The Status column also shows the data elements that are 
not added because of the data definition conflicts as "Not Added" and the corresponding 
Description column cell provides the reason for not adding the data elements to the 
destination server data structure setup. The data elements that are not added, or basically 
not changed, in the destination server will be captured because the elements exist in the 
destination server. In this case, importing of the configuration package will result in error 
even if the data elements are added to the Data Structure Setup. 

If you select the Add the data elements to the <destination user attribute form> user attribute 
design option in the Import User Attributes window, then the impact analysis report displays 
the user attribute design (in the destination server) as updated. In this case: 

 An additional section for the Data Structure Setup components will be displayed in the 
impact analysis report. The impact analysis report will be the same as seen when the data 
elements are added as a part of the design import. 

 The Description for the data elements added will be displayed as: "Included and have been 
added to user attribute design." 

Similarly, if the import results in error because of the data definition mismatch, then it will be 
captured as a part of the regular error/warnings report. 

In the case when you select the Add the data elements to the Data Structure Setup but not 
to the user attribute design option, but the import fails because of the user attribute design (in 
the destination server) is not in complete status, if the custom user attributes exist in destination 
server, then the user data elements will be added. In this case, the impact analysis report 
displays the list of the data elements that are added, and the data elements that are not 
changed. This is the case where custom user data elements are added successfully in the 
destination server. 
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The descriptions for the data elements that are added to the destination server but not to the 
user attribute design will show: "Included and added to the data structure setup." 

The descriptions for the data elements that are added to the destination server but not to user 
attribute design will show: "Ignored because the data element exists in destination server." 

Importing the User Data Pickers 

The data elements and data definitions of the user data picker will be imported into the 
destination server if the user data picker definition is not defined. 

The display element will be added into the user attribute design if you select the option to add 
the display element into the user attribute form of the destination server. 

Unifier ignores the user data picker in the configuration package ("There is a mismatch between 
the package and this server for the display element of <user data picker> data definition. No 
changes will be done to the existing definition upon import."). 

The errors and warnings report displays the detail of the user data pickers that are ignored 
during the configuration package import, if they exist in the destination server. 

Configuration Package with Custom User Attributes (Exporting) 

Even if the configuration package components have references to custom user attributes, as an 
administrator you can export (and import to the destination environment) a configuration 
package that includes all types of custom user attributes without the need to include the source 
user attribute design in the configuration package. This includes shell data pickers, BP data 
pickers, and so forth. 

Note: The export process applies to both the configuration packages 
and the add-on configuration packages. 

The following lists the referenced user attributes in a component package that can be imported 
to the destination environment: 

 Data elements that are data pickers and shell pickers and do not exist in the destination 
server. 

 Data elements that are user data pickers and display elements and do not exists in the 
destination server. 

 Data elements that are data pickers, shell pickers, along with referenced data sources and 
display elements that exist in the destination. 

 Data elements that are data pickers, shell pickers, and the referenced data sources that do 
not exist in the destination. 

Note: If the custom user attribute is a user data picker, then both the 
data picker element and its associated display element will be included 
in the configuration package. 

The system will display messages if custom user attributes such as data pickers are referenced 
in the following components of the configuration package: 

 Workflow setup filtering conditions 
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 User Data Picker query conditions 

 User Defined Report or Data Cube query conditions 

 Auto update Status Setup query conditions 

 Auto populate and reverse auto populate definitions referencing User Data Picker in any 
design 

 Any design that has custom user attributes referenced through User Data Picker 

Configuration Package with Custom User Attributes (Importing) 

This topic explains the importing of a Configuration Package with custom User Attributes that 
includes pickers without user attribute design. 

Note: The import process applies to both the configuration packages 
and the add-on configuration packages. 

When you select the component package that has custom user attributes without including user 
attribute design in the import wizard, navigate to the last step, and click Import, the Import User 
Attributes window opens. 

Note: The Import User Attributes window will be displayed only if the 
component package have custom user attributes without the source user 
attribute design. 

In Import User Attributes window: 

 The list of data elements will include all the custom user attributes that are a part of the 
source package and do not exist in destination environment user attribute design. 

 The list of data elements will also include the pickers like shell data picker, shell pickers, and 
other data pickers that are referenced in the components in the source server. In case that 
the user data picker is a custom user attribute, the display data element of the user data 
picker will also be seen in the list of data elements. 

 You can see the list of data elements from the component package that do not exist in the 
destination environment user attribute design. 

 You can add the data elements into the destination environment user attribute design by 
selecting the Continue option. If you decide not to change the destination environment user 
attribute design, then you can select Cancel or close the window to cancel the importing 
process. 

Importing Data Elements that are not Pickers 

This topic explains the importing of a Configuration Package with custom User Attributes that do 
not include pickers. 

When you select the component package that has custom user attributes that are not present in 
the destination environment user attribute design, the Import User Attributes window opens. 

In Import User Attributes window, the list of data elements will include all the custom user 
attributes that do not exist in the destination environment user attribute design. You (the 
administrator) will have an option to continue with the import of custom user attributes into 
destination environment user attribute design, or they can cancel the import. 
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When importing the data elements into the destination environment user attribute design: 

 If the data elements and data definitions do not exist in destination environment user 
attribute design, then Unifier creates the data elements and data definitions and adds them 
to the destination environment user attribute design. 

 If the data elements do not exist, but the data definitions exist with same definition type, then 
Unifier creates the data elements and adds them to the destination environment user 
attribute design. 

 If the data elements do not exist, but the data definitions exist with a different definition type 
(different than that of the source), then Unifier does not create the data elements, and the 
import fails. 

Impact Analysis Report

In case of the import being successful, the impact analysis report shows that the user 
attribute design in the destination environment as updated. An additional section for Data 
Structure Setup Components will be included in the impact analysis report, and the custom 
user attributes will be added. 

In the case where the data elements are added, Unifier displays the message: Added to the 
Data Structure Setup and included in the destination user attribute design. 

The Data Structure Setup Components section in the impact analysis report will show the 
user attributes (data elements) that are added or not changed only when the import of adding 
custom user attributes into the destination environment user attribute design is successful. 
The Status column will show the status of the data element accordingly as either added or 
not changed. The Description column will show the details. 

Importing Data Elements that are Pickers 

This topic explains the importing of a Configuration Package with custom User Attributes that 
include pickers, but the pickers do not exist in destination user attribute design. 

When you select the component package that has custom User Attributes that include pickers, 
but the pickers do not exist in destination user attribute design, the Import User Attributes
window opens. 

In Import User Attributes window, when the custom user attributes are picker elements, the list 
of picker data elements are shown in the Import User Attributes window, similar to other data 
elements if they do not exist in the destination environment user attribute design. The following 
provides more details: 

 When the data picker element, data source, and display element do not exist in the 
destination server

 If in the destination server the custom user attribute which is a data picker element does 
not exist, then the data picker definition will be added to the destination server by adding 
the data source and display element. The user attribute data picker element will be 
created and added to the destination user attribute design. Similarly, the display element 
will be added, if the display element does not exist in the destination. 

 If the display element exists with different definition, then the import will fail and no data 
picker definition will be created in the destination server. 
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 If the data source has referenced another design, then the referenced design is imported 
to the destination server. The import will fail if the referenced design exists with different 
ID and so forth. All of the existing import logic for the referenced designs will remain as 
is.  

 When the data picker element and data source do not exist, but the display element 
exists in the destination server

 If in the destination server the custom user attribute which is a data picker element and 
the referenced data source do not exist but the display element exists, then the data 
picker definition will be added by adding the data source. Also, the referenced data picker 
user attribute will be created and added to the destination user attribute design. 

 If the display element does not exist but the data definition of the display element exists 
with different definition from the source, then the import will fail while adding display 
element and no data picker definition will be added. All of the existing import errors will 
be displayed in this case. 

 When the data picker element does not exists but data source exist in the destination 
server

 If in the destination server the custom user attribute which is a data picker element does 
not exist but the data source exists with the same ID or Design, then the data picker 
definition will be added, and the element will be created successfully. The display 
element will be added if it does not exist in the destination server, and the referenced 
picker element will be added to the destination user attribute design. 

 The import will fail if: 

 The data picker source design does not match with the source, or 

 The display element exists with different data definitions, or 

 The display element data definition name exists with different definitions 

All of the existing import errors will be displayed in this case. 

 When the data picker element exist with different data source in the destination server

If in the destination server the data picker element data definition exists with source 
different that the one in the package, then the data picker element creation will result in 
error, and the import will fail. All of the existing import errors will be displayed in this case. 

 If in the destination server the data picker element with data definition exists but the 
display element is different than the one in the source, then the destination data picker 
element will not change, and the import will be successful after adding the data picker 
element to the destination user attribute design. 

 When the data source has picker elements which refer to another designs

 When the data picker data source has referenced other designs, the referenced designs 
will be imported into the destination along with the data source import. All of the existing 
import errors will be displayed in the case where the referenced design ID or name 
exists, but it does not match with the source. 

Impact Analysis Report

The impact analysis report will show the custom user attributes which are data pickers, or 
shell pickers, that were added, not added, or not changed along with other user attributes, in 
case of successful and failed imports. The Status and Description fields will provide details. 
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Component Analysis for Add-on Component Lists 

Similar to the Component Lists, when you select the shell template components to create an 
add-on component list, if the selected components have references to the custom user 
attributes, the system displays a warning message informing you that the user attribute design is 
missing in the Add-on Component List and provides the option to include the design through 

Fix Action option   . 

The following warning message is displayed in the Add-on Component Analysis window when 
the selected components have references to custom user attributes and user attribute design is 
not selected: "The selected components have references to the custom user attributes and 
<user attribute design name> is missing in the component list." 

In the Add-on Component Analysis window you can use the Fix Action option    to include 
the dependent user attribute design into the component list created and apply your changes. 
After applying your changes, the warnings (related to user attribute design not included in the 
component list) will not be displayed. 

The Add-on Component Analysis window also displays additional warning messages for the 
referenced custom user attributes in the selected components (such as designs, BP setups, 
UDRs, and so forth) that will be included in the configuration package, when the user attribute 
design is not included. 

Example 

The "Action Items BP" has the user data picker "Assignee DP," and the "Assignee DP" has 
display element name "empEmployeeDepartment" which is a custom user attribute. In this 
case, the following warning message is displayed: "empEmployeeDepartment in User 
Attributes is referenced by data definition Assignee DP will be included." 

The add-on component lists can be saved with or without performing error check, similar to the 
component lists. 

The components that have custom user attributes references will display warnings in the 
Component Analysis window, and there will be a resolving action in order for you to exclude 
those components. 

Importing Configuration Packages 

When a configuration package is imported into the destination environment, the items in the 
Component Lists that have been modified override (replace) the existing items in the 
destination environment, if they exist in the destination environment. 

There are cases that require the new configuration package not to override (replace) the existing 
items in the destination environment. 

Example 

In the Production environment, a user changes the: 

 Values associated with a drop-down (pull-down) data definition 

 Data Views 

 Custom Templates 
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In this case, the user does not want those values to be replaced when a new 
configuration package is imported. 

You (the Administrator) can define whether certain types of elements in the Component Lists of 
the configuration package can override (replace) the existing items in the destination 
environment, if they exist in the destination environment. As a result, as an Administrator, when 
you import a configuration package, you can see the following after the import: 

 Components that exist in the destination environment and are set to not be replaced are not 
replaced or overridden. 

 Components that exist in the destination environment and are set to be replaced are 
replaced or overridden. 

 Components that did not exist in the destination environment are created. 

For more information, see Replace in Destination Column (Import and Export) (on page 
571). 

To import Configuration Packages 

1) To activate the Configuration Package Import wizard, click Import. 

2) Select a valid zip file and click Next. 

After you click Next in the Package Components step, the system displays the package 
components from the selected zip file. 

Only the components available in the zip file are displayed in the Package Components 
preview. 

Example 

If the user selected a zip file (with categories Designs, Analytics, and 
Configuration), the Package Components preview displays the following 
Categories: 

 Designs 

 Configuration 

 Analytics 

Because the configuration includes component Business Process, Business 
Process components are displayed under Configuration. 

The Designs node will also have separate sub node Published Designs to show 
the published designs coming in as part of the configuration file. The Group sub 
node will also appear in the categories Shell Templates and Single Instance 
Shells. For Groups, the column that will be seen is the Name where the group 
name should be seen. 

There will be a filter option available that lets you filter data for search for every 
column. The print option prints the consolidated report based on the user selected 
components. 

In the Package Components preview, the Status column is displayed for all the components 
with the following indicators: 

 Add

When imported successfully, the component will be added in the destination environment. 

 Update
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When imported successfully, the component will be updated in the destination 
environment. 

 No Change

When imported successfully, there will be no changes applied to the component in the 
destination environment. 

When you click Next in the Package Components step, you go to the User Mapping step, 
and the following operations take place: 

 The system extracts the following information, for user mapping: 

 Shell administrator. 

 Auto Creator for Business Process records or line items. 

 BP Auto Creator in the BP Setup. 

 For other component where users/groups are assigned, for example, Workflow Setup, 
Access Control, column restrictions in Cost Sheet, or Portfolio Manager: 

 If all assignees are Groups, then the Groups will be extracted. 

 If the assignees are a mix of users and groups, then only the groups will be 
extracted and the users will be ignored. 

 (Portfolio Manager) If the assignees is a list of users only, then during error check, 
the following error message appears, while creating component list and during 
export of Configuration Package: 

The users assigned to {name of PPM} cannot be extracted. Include 
at least one group to proceed further

 The other creator users for components that the user does not select or cannot be 
changed, for example, creator of Cost sheet, then those creator users are replaced with 
the user who is performing the import. 

 When performing import for the first time in the destination environment, by default, the 
destination login name (present in the destination environment) is displayed in the 
column for users who are present in the environment. The destination login name will be 
empty for users who are not present in the environment. 

 The last entered values for the User Mapping (from the last import) will be remembered in 
the same environment. The system auto-populates the last User Mapping values once 
the user reaches the User Mapping step. 

 You can enter the mapping details. 

 You can edit the destination login name for any value. 

 You can map different imported users to the same user in the destination environment. 

Note: Although group name and the group permission is available, the 
members of the group cannot be extracted. 

3) When you are done with the User Mapping step, click Next to go to the Import step. 

4) In the Import step, select or deselect the option to download the impact analysis report. 

 If you deselect this option, you can download the impact analysis report later using the gear 
menu in the Configuration Package log. 

5) If applicable, select the Do you want to create a Component List associated to the 
package option. 
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6) When you are ready to import the configuration package, click Import . 

Note: If you selected the Do you want to create a Component List 
associated to the package option, the list might not appear in the 
Component Lists window immediately after the configuration package 
is imported. However, you can right-click the Component Lists
functional node and select Reload to view the list. 

Configuration Package Report and Audit Log 

You can view the configuration package contents in a report format by generating a PDF file. 
The print option is displayed when you are viewing the configuration package. 

After you import a configuration package, all included modules that support auditing will continue 
to do so. The following lists the specifics: 

 Auditing is done post import and in the destination environment. 

 New attributes are not added to the Audit log. 

 The Date. 

 The User Name is the user who last imported the configuration package. 

Conditions for User Mapping in Configuration Package 

User Mapping 

Many Unifier modules have user information as a part of setup information. When you create 
and export configuration package, the user information is included in the package; however, 
when you export, the user information will not be created in the Production environment and the 
import process will fail. 

To prevent this, you can map the Development/Test environment users to a user in the 
Production environment. 

Note the following conditions: 

 The user mapping that you set at this point applies to the particular configuration package 
that you are working with. 

 The names that you enter in the Destination Login Name field (Production) must exist in 
the destination environment. 

 The system validates the user names at the time of import. 

 If no user exists by that name, the import fails. 

 The Destination Login Name is a text field and the system validates the character length 
against the existing character length limit for the field. 

 You cannot map a two-source user to the same destination user. 

Configuration Packages Import Rules 

The following explains import rules for the configuration packages. 



Configuration Package Management

623

Manually, a design object such as a business process can be set up in a Shell template, Single 
Instance Shell, Company Workspace only if the design object has an Active Configuration, which 
is set in the Configuration node. 

Because the system does not perform checks for the existence of an Active status configuration 
at the time of import, the configuration setup is imported irrespective of configuration status 
(Active or Inactive). As a result, the user must tag the configuration of the corresponding design, 
in the Development/Test environment, so that it is a part of the Configuration Package. 

This rule applies to the following components: 

 Business Process 

 Asset Manager 

 Planning Manager 

 Portfolio Manager 

 Resource Manager 

 Shell Manager 

 Space Manager 

 Configurable Manager 

The system imports all content included in the Configuration Package. 

The system aborts the import process if there is an error. 

For a successful import, you must load all necessary modules, for each component, in the 
destination server. For example, if the configuration package includes Cash Flow Curves, then 
the Cash Flow module must be loaded in the Production environment, or destination server. 

If the following objects do not exist in the Production environment, or destination server, the 
system creates these objects in the Production environment, or destination server, 
automatically: 

 Design 

 Data structure setup components 

 Shell templates 

If a report does not exist in the Production environment, or destination server, the system 
creates the report after a successful import. 

If the configuration package components exist in the Production environment, or destination 
server, the system performs an update upon a successful import. 

System updates result in complete replacement. For example, if the Auto Creation setup has 
changed in the BP setup, the system applies the updates to all the tabs in the BP setup. 

If you include Oracle Business Intelligence Publisher (BI Publisher) or Oracle Analytics Publisher 
reports in your configuration package, ensure that: 

 The application modules have been deployed in the imported environment, prior to import. 

 The BI Publisher/Oracle Analytics Publisher reports are at application level. 

If the application modules have not been deployed in the imported environment prior to 
import, the import process will fail. 
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Unifier module options that have associated files are always based on the Configuration 
Package. 

The components for the following objects in the Configuration Package overwrite the 
components of the corresponding objects in the Production environment, or destination server, 
after a successful import: 

 Shell templates 

 Templates 

 Company Workspace 

 Single Instance Shells 

If the components of the objects do not exist in the Production environment, or destination 
server, then the system adds the components of the objects in the Production environment, 
or destination server, after a successful import. 

If the components of the objects exist in the Production environment, or destination server, 
the system updates the components of the corresponding objects in the Production
environment, or destination server, after a successful import. 

When the User Mode Navigator setup is included in the Configuration Package, the system 
deploys the setup after a successful import. 

If external Custom Reports are used in the User Mode Navigator, ensure that the external 
Custom Reports names and locations in the Configuration Package match those existing in the 
Production environment, or destination server; otherwise, the import process will fail. 

If the names of the following components of Cost Manager sheets (Funding), in a Template, do 
not match, then the import process will fail: 

 Funding Sheets 

 Commitment Funding Sheets 

The registry name of Data Views that are imported into the Production environment, or 
destination server, must match those in the Configuration Package. Data Views can only be 
imported between two servers belonging to the same registry. This condition also applies to the 
following components, which use Data Views: 

 Data Cubes 

 UDRs 

 BI Publisher/Oracle Analytics Publisher reports 

Impact Analysis Report 

The impact analysis report enables the user to view the impact of component after the import 
has been completed, whether successfully or not. 

An Impact Analysis Report contains the following information: 

 Import Date 

 Imported by 

 Import Status 
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In case of Success, Error, or Failed conditions, the components that will be seen in the report 
are the ones that impacted the destination system. For example, if there are no changes related 
to Shell Templates, then the shell template information will not be seen the report. The 
sequence for information seen will be same as seen in the component list screen (the 
left-navigation tree). 

The Status column of the report states the impact on the respective component as follows: 

 Added

When imported, the component has been added in the destination environment. 

 Updated

When imported, the component has been updated in the destination environment. 

 No Change

When imported, no changes are applied to the component in the destination environment. 

Viewing Configuration Packages 

When you open a configuration package with Draft status, the system displays the wizard for the 
Package Details step. 

When you view a successfully created/imported configuration package, only the components 
and categories are displayed that are a part of the configuration package contents. 

Example 

If the user successfully created a configuration package using List 1 (with categories Designs 
and Analytics) and List 2 (with categories Designs and Configuration and Configuration 
included business processes, only), then the following is displayed in the package 
components Categories: 

 Designs 

 Configuration 

 Analytics 

Since the configuration included the component business process, the business process 
components are displayed under Configuration. 

The Designs node has a separate tab for the published designs that are a part of the 
configuration file. The Group sub node appears in the categories Shell Templates and Single 
Instance Shells. For Groups, the Name column is displayed (group name). 

In case of warnings, the Errors/Warnings step is displayed next to the Package Components 
step, listing the warnings contained in the configuration package. 

In case of configuration package in Error status, when you open the configuration package, all 
the errors, or warnings, related to the configuration package, are displayed in the 
Errors/Warnings step. 

Transferring Configuration Package (On Premises Only) 

The following is a workflow for transferring your configuration package from one environment to 
another. 
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Oracle recommends that you follow this workflow: Development > Test and Development > 
Production. 

Development

All the designs, configurations, setups, and any components needed to be transferred to other 
environment must be done in the Development environment. 

After all the components are ready, create the component list which creates the configuration 
package. The publish for production is optional, based on where you want to transfer the 
configuration package. 

Test

The Test environment can import published and unpublished configuration packages. 

After the configuration package is transferred to the Test environment successfully, you must 
test all the components of the system that have been impacted by the configuration package. 

Any changes made (for example, setup or configuration) in the Test environment must be made, 
manually, in the Development environment before transferring the configuration package to the 
Production environment. 

Production

Only the published configuration packages that have been tested thoroughly (in both 
Development and Test) must be transferred to the Production environment. 

Installing Base Products (On Premises Only) 

The Unifier Platform (Basic) is preloaded in Unifier with the option to install the Project Controls 
and Facilities and Asset Management base products through configuration package import. For 
more information, see Importing Configuration Packages (on page 619). 

For the Development environment: 

The Unifier Platform (Basic) is preloaded, by default. You have the option to install the 
Project Controls base product or Facilities and Asset Management base product. The base 
products are installed with all of the designs, but the designs are not published. You need to 
create configuration packages, related to each base product, in the Development 
environment, and set them as published before you can use them (transferring, designing, 
configuring, and setting up) in the Production environment. 

Note: Oracle recommends that you follow this workflow: Development > 
Test and Development > Production. 

For the Test environment: 

The Unifier Platform (Basic) is preloaded, by default. You have the option to install the 
Project Controls base product or Facilities and Asset Management base product. The base 
products are installed with all of the designs, but the designs are not published. You need to 
create configuration packages, related to each base product, in the Development 
environment, and set them as published before you can use them (transferring, designing, 
configuring, and setting up) in the Production environment. 
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For the Production environment: 

The Unifier Platform (Basic) is preloaded, by default. You do not have the option to install the 
Project Controls base product or Facilities and Asset Management base product; however, 
you can transfer the base products by way of the configuration package. 
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