Oracle Analytics Cloudへの接続中の障害
問題
Oracle Analytics Cloud本番環境で、ユーザーがOracle Smart View for OfficeインストールからOracle Analytics Cloudに接続しているときに問題が発生する場合があります。
この状況が発生することがあるシナリオのタイプを次に示します。
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ユーザーがVPNを介してOracle Analytics Cloudに接続します
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Oracle Analytics Cloudが、インターネット・プロキシを介して要求されるOracle Identity Cloud Serviceによって保護されています
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Oracle Identity Cloud Serviceが、Ping Identityなどのフェデレーテッド・シングル・サインオン・システムと統合されています
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2つの異なるドメインのユーザーが、Microsoft Application Virtualization (Microsoft App-V)を使用して配布されるパッケージを介してSmart Viewをインストールしています
接続しようとすると、空のログイン画面が繰り返しポップアップ表示され、最終的にログインが失敗します。これは、接続URLをプライベート接続パネルに貼り付けるときに発生することがあります。
原因
この問題の根本的な原因は、Smart Viewのパッケージ化バージョンが、ログインの前にielowutil.exe
というブラウザ・プロセスを開いたことにあります。パッケージ化されていないローカル・インストールのSmart View、またはすでに実行中のMicorosoft Internet Explorerとパッケージ化されたインストールの両方が、かわりにiexplore.exe
を起動済です。
ielowutil.exe
ファイルは、Low MIC [Medium Integrity Cookie] Utilityという特別に保護されたバージョンのInternet Explorerです。これは、整合性が異なるプロセス間でCookieデータを共有できないようにします。
これは、Oracle Analytics Cloudへのログインが失敗する場合があることの理由を説明できます。Oracle Identity Cloud ServiceとPing Identityの両方によって設定されたCookie情報を必要とし、ユーザーがログインしないと見なし続けるため、12回後にエスケープするまでループでOracle Identity Cloud Serviceにリダイレクトします。
ノート:
Microsoft社は、Internet Explorerのサポートを2022年6月15日で終了しました。ただし、Internet Explorerをアンインストールしないでください。詳細は、Internet Explorer 11のサポート終了とSmart Viewを参照してください。
解決策
プロセス モニター(Windows Sysinternals)を使用すると、ブラウザの読取りに使用されるレジストリ・キーはそれぞれ異なり、次のように識別されました。
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機能しているキー:
HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{0002DF01-0000-0000-C000-000000000046}\(Default)
次の値を表示します。
Internet Explorer(Ver 1.0)
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機能していないキー:
HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32\(Default)
次の値を表示します。
"%ProgramFiles(x86)%\Internet Explorer\ielowutil.exe" -CLSID:{0002DF01-0000-0000-C000-000000000046}
レジストリ・キー:
HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32\(Default)
次へのポインタです。
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32\(Default)
このキーを新しい値に変更:
"%ProgramFiles(x86)%\Internet Explorer\iexplore.exe"
その結果、かわりにSmart Viewパッケージがiexplore.exe
を呼び出し、ログインが成功しました。
すべてのレジストリの確認および変更は、ローカル・システムが保持されるように、Smart Viewパッケージと同じApp-V Package/Version ID環境で実行される必要があります。つまり、次のようにします。
regedit /appvve:307790F2-DE31-4EBE-B3BC-4C9337032E73_0BE1C6E6-85CC-48C3-A0FF-3BBB789681C3
通常、ユーザーは管理アクセス権を持っていないため、同じパスにキーを追加してHKEY_CURRENT_USER
への修正をロールアウトしてください。
HKEY_CURRENT_USER\Software\Classes\Wow6432Node\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32\(Default)
様々なドメインに異なるSmart Viewパッケージ化バージョンがある場合(一部はApp-V接続グループ内)、PowerShellスクリプトを作成してSmart Viewパッケージを識別し、正しいレジストリ変更を行うことができます。
テストでは、このキー変更は、正常に一貫してOracle Analytics CloudにログインできるSmart Viewユーザーに対して行われる必要があります。