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Preface

Understanding the PeopleSoft Online Help and PeopleBooks

The PeopleSoft Online Help is a website that enables you to view all help content for PeopleSoft
applications and PeopleTools. The help provides standard navigation and full-text searching, as well as
context-sensitive online help for PeopleSoft users.

Hosted PeopleSoft Online Help

You can access the hosted PeopleSoft Online Help on the Oracle Help Center. The hosted PeopleSoft
Online Help is updated on a regular schedule, ensuring that you have access to the most current
documentation. This reduces the need to view separate documentation posts for application maintenance
on My Oracle Support. The hosted PeopleSoft Online Help is available in English only.

To configure the context-sensitive help for your PeopleSoft applications to use the Oracle Help Center,
see Configuring Context-Sensitive Help Using the Hosted Online Help Website.

Locally Installed Help

If you’re setting up an on-premise PeopleSoft environment, and your organization has firewall restrictions
that prevent you from using the hosted PeopleSoft Online Help, you can install the online help locally.
See Configuring Context-Sensitive Help Using a Locally Installed Online Help Website.

Downloadable PeopleBook PDF Files

You can access downloadable PDF versions of the help content in the traditional PeopleBook format on
the Oracle Help Center. The content in the PeopleBook PDFs is the same as the content in the PeopleSoft
Online Help, but it has a different structure and it does not include the interactive navigation features that
are available in the online help.

Common Help Documentation

Common help documentation contains information that applies to multiple applications. The two main
types of common help are:

*  Application Fundamentals
» Using PeopleSoft Applications

Most product families provide a set of application fundamentals help topics that discuss essential
information about the setup and design of your system. This information applies to many or all
applications in the PeopleSoft product family. Whether you are implementing a single application, some
combination of applications within the product family, or the entire product family, you should be familiar
with the contents of the appropriate application fundamentals help. They provide the starting points for
fundamental implementation tasks.
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In addition, the PeopleTools: Applications User's Guide introduces you to the various elements of the
PeopleSoft Pure Internet Architecture. It also explains how to use the navigational hierarchy, components,
and pages to perform basic functions as you navigate through the system. While your application or
implementation may differ, the topics in this user’s guide provide general information about using
PeopleSoft applications.

Field and Control Definitions

PeopleSoft documentation includes definitions for most fields and controls that appear on application
pages. These definitions describe how to use a field or control, where populated values come from, the
effects of selecting certain values, and so on. If a field or control is not defined, then it either requires
no additional explanation or is documented in a common elements section earlier in the documentation.
For example, the Date field rarely requires additional explanation and may not be defined in the
documentation for some pages.

Typographical Conventions

The following table describes the typographical conventions that are used in the online help.

Typographical Convention Description

Key+Key Indicates a key combination action. For example, a plus sign
(+) between keys means that you must hold down the first key
while you press the second key. For Alt+W, hold down the Alt
key while you press the W key.

... (ellipses) Indicate that the preceding item or series can be repeated any
number of times in PeopleCode syntax.

{ } (curly braces) Indicate a choice between two options in PeopleCode syntax.
Options are separated by a pipe (| ).

[ ] (square brackets) Indicate optional items in PeopleCode syntax.

& (ampersand) When placed before a parameter in PeopleCode syntax,
an ampersand indicates that the parameter is an already
instantiated object.

Ampersands also precede all PeopleCode variables.

> This continuation character has been inserted at the end of a
line of code that has been wrapped at the page margin. The
code should be viewed or entered as a single, continuous line
of code without the continuation character.

ISO Country and Currency Codes

PeopleSoft Online Help topics use International Organization for Standardization (ISO) country and
currency codes to identify country-specific information and monetary amounts.
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ISO country codes may appear as country identifiers, and ISO currency codes may appear as currency
identifiers in your PeopleSoft documentation. Reference to an ISO country code in your documentation
does not imply that your application includes every ISO country code. The following example is a
country-specific heading: "(FRA) Hiring an Employee."

The PeopleSoft Currency Code table (CURRENCY CD TBL) contains sample currency code data. The
Currency Code table is based on ISO Standard 4217, "Codes for the representation of currencies," and
also relies on ISO country codes in the Country table (COUNTRY TBL). The navigation to the pages
where you maintain currency code and country information depends on which PeopleSoft applications
you are using. To access the pages for maintaining the Currency Code and Country tables, consult the
online help for your applications for more information.

Region and Industry Identifiers

Information that applies only to a specific region or industry is preceded by a standard identifier in
parentheses. This identifier typically appears at the beginning of a section heading, but it may also appear
at the beginning of a note or other text.

Example of a region-specific heading: "(Latin America) Setting Up Depreciation"

Region Identifiers

Regions are identified by the region name. The following region identifiers may appear in the PeopleSoft
Online Help:

¢ Asia Pacific
*  Europe
e Latin America

¢ North America

Industry Identifiers

Industries are identified by the industry name or by an abbreviation for that industry. The following
industry identifiers may appear in the PeopleSoft Online Help:

e USF (U.S. Federal)

¢ E&G (Education and Government)

Translations and Embedded Help

PeopleSoft 9.2 software applications include translated embedded help. With the 9.2 release, PeopleSoft
aligns with the other Oracle applications by focusing our translation efforts on embedded help. We

are not planning to translate our traditional online help and PeopleBooks documentation. Instead we
offer very direct translated help at crucial spots within our application through our embedded help
widgets. Additionally, we have a one-to-one mapping of application and help translations, meaning that
the software and embedded help translation footprint is identical—something we were never able to
accomplish in the past.
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Using and Managing the PeopleSoft Online Help

Select About This Help in the left navigation panel on any page in the PeopleSoft Online Help to see
information on the following topics:

» Using the PeopleSoft Online Help.
* Managing hosted Online Help.

* Managing locally installed PeopleSoft Online Help.

PeopleTools Related Links

PeopleTools 8.59 Home Page

PeopleSoft Search and Insights Home Page

“PeopleTools Product/Feature PeopleBook Index” (Getting Started with PeopleTools)

PeopleSoft Online Help

PeopleSoft Information Portal

PeopleSoft Spotlight Series

PeopleSoft Training and Certification | Oracle University

My Oracle Support

Oracle Help Center

Contact Us

Send your suggestions to psoft-infodev_us@oracle.com.

Please include the applications update image or PeopleTools release that you’re using.

Follow Us

Icon Link

@ Watch PeopleSoft on YouTube
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Icon Link
N Follow @PeopleSoft Info on X.
A\

Read PeopleSoft Blogs

Connect with PeopleSoft on LinkedIn
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Chapter 1

Getting Started with PeopleSoft Application
Designer

PeopleSoft Application Designer Overview

PeopleSoft Application Designer is the core development tool used to build and modify PeopleSoft
applications. PeopleSoft Application Designer enables you to build a variety of definitions, including:

» Fields

* Records (Tables)
* Pages

+ Components

*  Menus

* PeopleCode

+ SQL

PeopleSoft Application Designer Implementation

This section discusses:
» Installation-level steps.

* Main application development steps.

Installation-Level Steps

This table lists the steps you must complete before you can begin using PeopleSoft Application Designer:
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Step

Explanation

Reference

Set up security.

For developing and customizing
PeopleSoft applications, you need
access to the definitions involved, such
as fields, records, pages, and so on.
Your administrator can provide access
by adjusting your definition security
settings. Your administrator also might
need to grant general PeopleTools
permissions for maintaining and
upgrading data. These permissions
include Build and Data Administration,
Change Control, and Upgrade.

See “Setting PeopleTools Permissions”
(Security Administration).

Set up workstations.

PeopleSoft Application Designer is a
Microsoft Windows-based program. To
run PeopleSoft Application Designer,
you must have a supported version of
Windows with ample CPU and memory
resources. Also, you must use PeopleSoft
Configuration Manager to configure
your workstation with connectivity to

the appropriate database and to set all
required environment variables.

See “Configuring Developer
Workstations” (System and Server
Administration).

Main Application Development Steps

This table presents the main steps for creating a PeopleSoft application:

Step

Reference

1. Design application.

Review your in-house development cycle and documentation.

2. Create fields.

See Creating New Field Definitions.

3. Create record definitions.

See Understanding the Planning Process.

See Creating New Record Definitions.

4. Build SQL tables.

See Understanding Data Administration and the Build Process.

5. Create pages.

See Improving Online Performance.

See Understanding Page Controls.

See Understanding Scroll Areas, Scroll Bars, and Grids

See Understanding Page Design and Development.

6. Create components.

See Understanding Component Definitions.

24

Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 1 Getting Started with PeopleSoft Application Designer

Step Reference
7. Register components. See Understanding the Registration Wizard.
8. Test the application. Review your in-house testing procedures and documentation.

Other Sources of Information

This section provides information you should consider before you begin to use PeopleSoft Application
Designer. In the planning phase of your implementation, take advantage of all Oracle sources of
information, including the installation guides and troubleshooting information. A complete list of these
resources appears in the preface in About These PeopleBooks, with information about where to find the
most current version of each.

Related Links
Getting Started with PeopleTools

Copyright © 1988, 2023, Oracle and/or its affiliates.

25



Getting Started with PeopleSoft Application Designer Chapter 1

26 Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 2

Using PeopleSoft Application Designer

Understanding PeopleSoft Application Designer

Every PeopleSoft Pure Internet Architecture application contains a collection of related definitions that
work together for a specific purpose. Developing and adapting PeopleSoft applications is a step-by-

step process in which you define and build the definitions, establish relationships among the definitions,
implement security, run your PeopleSoft application in an internet browser, and test every aspect
thoroughly. You use one interactive tool, PeopleSoft Application Designer, for the majority of these
activities. PeopleSoft Application Designer is an integrated development environment that enables you to
work with the numerous definitions of a business application in a single work area.

Note: Your user interface might appear differently than what you see in this product documentation. The
look and feel of PeopleSoft Application Designer varies based on the release of your Microsoft Windows
operating system.

Using PeopleSoft Application Designer

This section provides an overview of the eight steps of application development and discusses how to
work with the Application Designer interface.
Understanding the Eight Steps of Application Development

Application development is a systematic process. Between the design and implementation of the
application, you define and build application definitions, establish relationships, implement security, and
test every aspect thoroughly. When developing in the PeopleSoft environment, it is helpful to look at the
development phase as an eight step process:

1. Design the application.

2. Create field definitions.

3. Create record definitions.

4. Build application data tables.
5. Create page definitions.

6. Define components.

7. Register components.

8. Test the application.
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Step One - Designing the Application

Create a development plan. The first phase of development in any environment is always planning.
Designers might spend 80 percent of their time designing a sound plan before they work on the first step.
In PeopleSoft applications, you will need to fully understand the other seven steps of development to
design a good plan. When you finish the development plan, you should have a business requirements
document that specifies the tables required and the relationships among them, a list of required definitions
(fields, records, and so on) complete with detailed specifications and naming conventions, mock-ups of
page layouts, and a navigational hierarchy that will give users access to the pages you create.

Step Two - Creating Field Definitions

Field definitions in PeopleSoft are slightly different from other environments. Designers define fields
apart from any tables they may belong to and ensure that they can be reused in any number of separate
database tables. The field definition is the basis for all the steps that follow.

Step Three - Creating Record Definitions

PeopleTools-based applications are table-based systems. When creating a record definition, you are
actually defining two layers of information: the record level and the field level. At the record level, you
define the structure of the database table, and the ultimate purpose of the record definition, and how the
system will use the definition. At the field level, you define the characteristics of the fields and any online
processing that you want to occur behind the scenes when a user enters data.

Step Four - Building Application Data Tables

After you define a record definition, you must create or build the underlying SQL tables that house the
application data that users will enter online in the production environment. This build process is the
centerpiece of the data administration features in PeopleSoft Application Designer. The build process
takes all of the properties of a record definition and creates a database table from them. Unless you
complete this step, no table will exist in the database to accept the application data.

Step Five - Creating Page Definitions

Pages are the user interface for the application. Pages present data to the users and enable them to enter
data into the application data table created in the previous step. In this step, you add page controls to a
page, associate the page controls with record fields, and configure appearance of the page. The system
displays the page to users in a browser window as HTML.

Step Six - Defining Components

Component definitions represent complete business transactions in PeopleSoft applications and are central
to navigation and security access. A component holds one or more pages that the user navigates between
using tabs or links. In this step, you define the search record and search attributes, the processing mode,
and the toolbar buttons that appear at the bottom of each page in the component.

Step Seven - Registering Components

The Registration Wizard makes registering a component easy. In this step, you attach the component to
a menu, assign security access for users, and place navigational links in the registry. After you register a
component, the user interface is complete and you can view the application in the browser.
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Step Eight - Testing the Application

The final step of application development is to thoroughly test the application before delivering the
finished product to users. You must test all aspects of the application by opening a transaction in your
browser and entering test data into the application. As issues arise, you can cycle back through each of the
previous steps to resolve the issues.

Starting PeopleSoft Application Designer

Open PeopleSoft Application Designer from the Start menu. Alternatively, if you have set up a shortcut
on your desktop, you can open the application from there. At the PeopleSoft Signon dialog box, enter
the Database Name or Application Server Name (depending on your connection type), User ID, and
Password. PeopleTools opens automatically to PeopleSoft Application Designer.

Note: Specific PeopleSoft utilities require you to set an environment variable, PS SERVER CFQG, to
run properly. However, PeopleSoft Application Designer is not compatible if PS SERVER CFG is set.
Before you start PeopleSoft Application Designer, you must ensure that PS SERVER CFG is not set.

A convenient way to do this is to use a DOS batch file to unset PS SERVER CFG, launch PeopleSoft
Application Designer, and then—after PeopleSoft Application Designer exits—reset PS_ SERVER CFG
to its previous value.

In addition to launching PeopleSoft Application Designer from the Start menu, you can also do so using
the command line syntax and the available parameters listed there.

PeopleSoft Application Designer offers a variety of command line parameters that you can use to control
the database to which it connects. By using these parameters, you can automatically navigate to the part of
the system that you need.

Use the values from the following tables to specify specific parameters.

Syntax

The following command line syntax applies to all actions identified in this topic:
PSIDE [-parameter value [-parameter value . . .]]

Use this command line syntax to start PeopleSoft Data Mover:

PSDMT [-parameter value [-parameter value . . .]]

You can include as many or as few parameters as you need.

Each parameter starts with a hyphen (-) or a forward slash (/). The value for each parameter follows the

hyphen or slash, separated by zero or more spaces. In general, the value does not need to have quotation
marks around it, even if it has internal spaces, because the system treats all text following the parameter
as part of the value up to the next parameter or the end of the command line.

Note: You must enclose a value in quotation marks only when it includes a hyphen or forward slash or to
include leading or trailing spaces. If the value itself includes a quotation mark character, then precede the
double quotation mark with a backslash (\).
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Available Parameters

The available parameters for pside.exe fall into two general categories:
* Parameters that provide login information.

* Parameters that set general options.

If the command line includes login parameters, it uses them only if no PeopleSoft applications are
currently running. If a PeopleSoft application is already running, then the system starts a new instance by
using the same login information as the active instance.

This table lists all of the available parameters:

Parameter Value Description

-CT Database type Enter the type of database to which

you are connecting. Valid values are
ORACLE, MICROSFT, and DB2ODBC
(note the spelling of MICROSEFT).

-CS Server name Enter the name of the database server
for the database to which you are
connecting. This setting is required for
some database types.

-CD Database name Enter the name of the database to which
you are connecting as you would enter it
into the PeopleSoft Signon dialog box.

-CO User ID Enter the PeopleSoft user ID used for
sign in.

-CP Password Enter the password for the specified user
ID.

Passwords entered on the command line
can be clear text or encrypted.

-CI Connect ID Enter the ID that is used to connect to the
database server.

-CW Password Enter the password for the specified
connect ID.

Passwords entered on the command line

can be clear text or encrypted.
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Parameter

Value

Description

NO

Use to suppress the appearance of the
PeopleSoft splash screen. Any other
value will cause the splash screen to
appear.

-SN

NO

Use to suppress the sound that plays
when you sign in to the PeopleSoft
system. Any other value will allow the
sound to play.

-QUIET

(none)

Use to run in quiet mode so that no
message boxes appear.

-HIDE

(none)

Use to hide the PeopleSoft Application
Designer interface.

For more information on using the Application Designer command line parameters, see ‘“‘Understanding

PeopleSoft Application Designer Command Line Parameters” (Lifecycle Management Guide).

Example

This command line statement starts PeopleSoft Application Designer and signs the user in to the
DEP7TST database:

PSIDE -CT MICROSFT -CS SEPNTDBO5 -CD DEP7TST -CO VPl -CP password
This command line statement starts PeopleSoft Application Designer using an encrypted password.
pside.exe -CT ORACLE -CO PTDMO -CP encrypted password -CD QAHRTST
In this case, encrypted _password should be substituted with the actual encrypted password value.

For more information on encryption, see “Using the PSCipher Utility” (Security Administration).

Using the PeopleSoft Application Designer User Interface

This table describes the six main elements that comprise the PeopleSoft Application Designer user
interface:
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Element Description

Title bar Displays the name of the database, the active project
(optional), and the active definition (optional) in the following
format:
Application Designer - DB NAME - PROJECT=
_ NAME - DEFN NAME (Type)

Menu Provides access to PeopleSoft Application Designer items and
features.

Toolbar Displays buttons that are useful in editing the active definition.

Project workspace

Provides a graphical representation of the components that are
contained in a project. The project workspace has two folder
tabs:

*  Development View.

*  Upgrade View.

Definition workspace

Displays individual definitions that you open.

Output window

Contains the output text from PeopleSoft Application Designer
operations, such as Build (SQL Create and Alter), Find
Definition References, Upgrade, Results, Validate, and
PeopleCode Log.

Note: You should maximize the PeopleSoft Application Designer window to make optimal use of the

different workspaces.

Application Designer Menus

This topic reviews the general PeopleSoft Application Designer menus. Specific menus appear for each
definition when it is open and active. Those menus are discussed in the topic about each definition.

Note: The menu items that appear on each menu often depend on the type of definition that is open in the
definition workspace. Those menu items are described in the corresponding topics.

In addition to the standard Microsoft Windows File menu items, several PeopleTools-specific items
appear in the File menu. This table lists the PeopleTools-related File menu items:

File Menu Items

Usage

Save Project

Save the project.

32
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File Menu Items

Usage

Save Project As

Save the active project definition. This menu item enables you
to change the name of the project when you save it.

Print Project

Print an Upgrade Project report for all the elements in the open
project.

Merge Projects Create a new project from selected definitions of two existing
projects.
Project Properties Edit properties for the open project.

Definition Properties

Provide general comments and change attributes for the active
definition. You can change attributes for Use, Type, and
Internet properties, depending on the definition type.

View Report

View a report of the definition in an open window in the
workspace.

Report from File, Print Preview

View a print preview of a selected report file that is saved to a
disk.

Report from File, Print

Print a selected report file from a disk.

Report from File, View Report

View a report from a selected report file that is saved to a disk.

List of last opened definitions

View and open one of the last few definitions you opened. You
can configure the maximum number of definitions that appear
in the list.

See Setting PeopleTools Options.

In addition to the standard Microsoft Windows-based menu items, such as Cut and Paste, two
PeopleTools-specific menu items appear in the Edit menu. This table describes their use:

Edit Menu Items

Usage

Find Definition References

Search for all related definitions and references (fields,
records, pages, PeopleCode, application packages, and so on)
to the current open definition. The results appear on the Find
Definition References tab of the Display window.

See Finding Definition References.
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Edit Menu Items

Usage

Find In

Search through all PeopleCode, SQL programs, HTML
definitions, and Free form sub style sheets for a text string that
you describe in a dialog box. You can also specify which type
of PeopleCode and SQL programs to search.

See “Using the Find In Feature” (PeopleCode Developer’s
Guide).

This table describes the use of View menu items:

View Menu Items

Usage

View Definition

View a definition that is referenced in the active definition. For
example, if you highlight a record field in a record definition,

then selecting this option opens the selected field definition.

View PeopleCode View PeopleCode characteristics of the active definition.
Filtering Select a filter option for your view of upgrade:
*  No Filtering.
»  Selected for Upgrade Action.
*  Not Selected for Upgrade Action.
*  Custom Filtering.
Toolbar Show or hide the toolbar.
Status Bar Show or hide the status bar.

Project Workspace

Show or hide the project workspace.

Output Window

Show or hide the output window.

Property Window

Show or hide the property window.

This table describes the use of Insert menu items:
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Insert Menu Items

Usage

Current Definition into Project

Insert the active definition into the project.

Definitions into Project

Display a dialog box to insert definitions into the project.

This table describes the use of Build menu items:

Build Menu Items

Usage

Current Definition

Display a dialog box to build or alter the record definition that
is currently active in the definition workspace.

Project Display a dialog box to build (SQL Create and SQL Alter) all
project records.
Settings Display a dialog box in which you set parameters that apply to

build operations.

This table describes the use of Debug menu items:

Debug Menu Items

Usage

PeopleCode Debugger Mode

Start the PeopleCode Debugger, which invokes a debugging
session and causes a full Debug menu to appear. When in
Debugger mode, a Local Variables pop-up window appears in
the definition workspace.

See “Understanding the PeopleCode Debugger” (PeopleCode
Developer’s Guide).

This table describes the use of Tools menu items:

Tools Menu Items

Usage

Validate Project

Validate attributes of the active project.

Validate Database for WSRP

Validates all of the appropriate definitions within a database
for WSRP compliance.

See “Validating WSRP Compliance” (Portal Technology).
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Tools Menu Items

Usage

Compile All PeopleCode

Validate all of the PeopleCode in the current database.
Displays the Compile All PeopleCode dialog box where
you can choose to compile and save all PeopleCode and all
Directive PeopleCode.

See “Compiling All PeopleCode Programs at Once”
(PeopleCode Developer’s Guide) and“Compiling and Saving
Directive PeopleCode” (Lifecycle Management Guide).

Compile Project PeopleCode

Validate the PeopleCode in the current project.

Diff / Merge Project PeopleCode

Compare and merge two PeopleCode definitions during an
upgrade.

Diff / Merge External Text

Compare and merge two versions of an external text file (such

as a Data Mover script or a SQL script) during an upgrade.

Compare and Report

Compare two projects and report on the differences.

Copy Project

Copy the current project to a database or a file, or export a
project from a file to your database.

Data Administration

Open dialog boxes that describe space allocation in the
database.

Change Control Open dialog boxes to view history or set system-wide change
control options as the administrator.

Upgrade Upgrade an application project.

Translate Translate base and operator language databases.

Miscellaneous Definitions

Set custom field formats, toolbars, colors, styles, access
profiles, and file type codes.

Important! Styles are a deprecated feature. You must
maintain styles by using style sheet definitions.

See Understanding Style Sheets and Style Classes.

Bulk Operations

Insert, modify, or delete certain definition types across your
entire database in one operation.

36

Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 2

Copyright

Using PeopleSoft Application Designer

Tools Menu Items

Usage

Options

Select commands specifying insertion commands, definition
language preference, validating options, PeopleCode fonts,
definition owner ID, and more.

This table describes the use of Window menu items:

Window Menu Items

Usage

Cascade Cascade all of the definitions that are not minimized in the
definition workspace into overlapping layers of definitions
with the definition names visible.

Tile Reorganize and resize all of the definitions that are not

minimized in the definition workspace so that they are all
visible and do not overlap.

Arrange Icons

Group all of the minimized definitions in the definition
workspace.

Close All

Close all of the definitions in the definition workspace.

This table describes the use of Help menu items:

Help Menu Items

Usage

Current Window

Provide context-sensitive help that is related to the active
window by opening the appropriate documentation in the

appropriate location.

PeopleBooks Library

Go to the PeopleSoft Online Library (the online
documentation for PeopleTools and your licensed PeopleSoft

applications).

About PeopleTools

Display the PeopleTools release level, application release,
user ID, database name, database type, and application server
name.

PeopleSoft Application Designer Toolbars

In addition to the standard Microsoft Windows toolbar button items, such as Cut, Paste, and Save, several
items are PeopleTools-specific. The command name appears in parentheses following its description.
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Field or Control

Description

Open the Definition Properties dialog box (File > Definition
Properties).

Open the Build dialog box (Build > Current Definition).

Toggle the display of the project workspace (View > Project
Workspace).

Project Workspace

View projects and their associated definitions in the project workspace. A project organizes a collection of
definitions in logical groups for easier development, adaptation, maintenance, and upgrade.

This example illustrates the fields and controls on the Project workspace shown with a project open. You
can find definitions for the fields and controls later on this page.

&5 PTESZ_10211
+ |:| Application Engine Programs
+-{_7] Application Packages
=5 Components
+ IE_GATEWAY (GEL)
IE_HOME_PAGE (GEL)
IB_INTMET DET {GBL)

+|- [+

IE_INTHET_OWRVIEW
IE_INTMET _PUBHDR.
IE_INTMET _PUBCOM
IE_INTMET _SUBCOM
IE_IMTMET_SYNC
IE_INTMET_DOMSTAT

+
+

+ IE_INTMETWORE (GEL)

+ IE_INTHETWORK? (GEL)
+ IB_LOGICALSCHEMA {GEL)
+ IE_ROUTINGDEFN {SEL)
+-f=f I SERWICE (GBL

IE_INTHET_MOMITOR (GEL)

IE_INTMET _MOMSETUP {GEL)
IE_INTMET_SYMC_DET (GBL)

% Development |#% Uporade

Work with a development project or an upgrade project by selecting either the Development tab or the

Upgrade tab at the bottom of the project workspace.

The text on the Development and Upgrade tabs might not appear if your monitor is not large enough to

display it.
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Definition Workspace

Use the definition workspace to create and modify definitions. You can maximize, minimize, cascade, or
tile them in the workspace.

Output Window

The output window displays status messages of various PeopleSoft Application Designer operations. The
output is organized into different categories by using tabs at the bottom of the window.

The text that appears in the output window is context-sensitive, which enables you to select it and perform
related operations. For example, if you have a field definition open, select Edit > Find Definition
References to list the definitions that reference the active field definition. The list appears in the output
window. Double-click any of the related definitions listed to open them.

The output window has several tabs that relate to numerous functions that you can perform with
PeopleSoft Application Designer: This table describes the use of the tabs:

Tab Usage

Build Create tables, indexes, views, triggers, and alter tables. If you
select the Log to Output Window option in the Build settings,
then errors, warnings, and informational messages appear here.

You can control the level of detail that appears.

Find Definition References View definitions that other references use or reference.
Double-click a definition to open it.

Upgrade View upgrade actions that are initiated from PeopleSoft
Application Designer.

Results View messages related to project operations, like opening a
project or inserting definitions into a project.

Validate Validate projects and components, and view the results.

Find In View the Find In dialog box output. Double-click a definition
to open it. You can limit the Find In search to a specific project
rather than the entire database.

PeopleCode Log View errors that you receive when you are in the debugger
stepping through code.

Setting PeopleTools Options

You can set preferences for various features in the Options dialog box. Select Tools > Options to access
the Options dialog box. Seven tabs appear on the dialog box and each tab features configurable options
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for different areas of PeopleSoft Application Designer. Most of these options are described in further
detail in other, more relevant areas of the product documentation. The following topics provides a general
description of each tab and a link to further details about the options:

Project
Set various project options.

See Setting Project Options.

Validate

Set project validation options, enable the PeopleSoft Application Designer spell check feature, and enable
WSRP validation.

See Validating Projects.

See Enabling the Spell Check Feature.

Editors
Set Word Wrap options for the various editors in PeopleSoft Application Designer.
See “Understanding the PeopleCode Debugger” (PeopleCode Developer’s Guide).

See “Understanding the SQL Editor Window” (PeopleCode Developer’s Guide).
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General

This example illustrates the fields and controls on the Options dialog box: General tab. You can find
definitions for the fields and controls later on this page.

Options -

| Praoject I W alidate | Editu:urs| General | Dwner 1d | Image | Browwzer |

|Indo/Redo Buffer Depth

b amirmurmn b ozt Recently Used
Drefirition

o =
=

Feport Output
Report Qutput Directory:

c:htemp | L]

Page Dezigner

[ ] Enable Tranzlatability Options
Show Hidden Borders
Enable Property wWindow

k. | | Cancel

Field or Control Description

Undo/Redo Buffer Depth Enter the number of most recently performed actions for
PeopleSoft Application Designer to store in memory. The
default value is /0, which mean that you can undo up to 10
immediately previous actions, such as adding or deleting page
fields from a page.

Maximum Most Recently Used Definition Enter the number of recently opened definitions to appear in a
list at the bottom of the File menu in PeopleSoft Application

Designer. The default value is 3.
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Field or Control

Description

Report Output Directory

Enter the output destination of the reports that you run in
PeopleSoft Application Designer. Reports include upgrade,
build, and definition reference reports.

Enable Translatability Options

Select to enable the following translatability options:

*  When you save a page, PeopleSoft Application
Designer warns you if a page control label violates the

recommended translation buffer.

*  When you add or modify translate values, a warning
appears if the Short Name field value exceeds the
recommended length of six characters.

*  When you add or modify field labels, a warning appears
if the Short Name field value exceeds the recommended
length of ten characters.

*  When you work with page definitions, PeopleSoft
Application Designer disables the Static Text tool so that

you cannot insert new static labels on pages.

Note: Translation warnings only appear when your base
language value in Configuration Manager is English.

Show Hidden Borders

Select to enable the borders of hidden group boxes and frames
to appear as dashed lines indicating the boundary of all hidden
group box and frame page control types.

Enable Property Window

Select to enable the property window for page controls. See
Using the Property Window for more information.

Note: You must close and restart Application Designer for this
setting to take effect.

Owner Id

Set the default owner ID for new definitions you create. Alternatively, leave the option blank, which is the
default, to allow users to select the owner ID they want. The Owner ID helps identify which applications

team last made a change to a definition.

Image

Set the preferred storage format for newly created image definitions.

See Specifying an Image Storage Format.

Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 2 Using PeopleSoft Application Designer

Browser

Enter the base uniform resource indicator (URI) to be used by the browser to locate the application and
the node name.

See Configuring Browser Options.

Related Links
Manipulating Page Controls

Working with Keyboard Shortcuts

For convenience and efficiency, you can use these keyboard shortcuts in Application Designer for
selected tasks. The action (or menu equivalent) depends on the currently selected definition.

Keyboard Shortcut Action (Menu Equivalent)

Ctrl+N File > New...

Ctrl+O File > Open...

Ctrl+S File > Save

Alt+Enter File > Definition Properties

Ctrl+P File > Print

Ctrl+Z Edit > Undo

Ctrl+Y Edit > Redo

Ctrl+X Edit > Cut

Ctrl+C Edit > Copy

Ctrl+V Edit > Paste

Ctrl+Delete Edit > Delete

Ctrl+R Edit > Find Definition References
Edit > Find Definition References...

Ctrl+Shift+F Edit > Find In...
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Keyboard Shortcut Action (Menu Equivalent)
Ctrl+Enter Edit > Page Field Properties

Edit > Record Field Properties
Ctrl+D View > View Definition
Ctrl+E View > View PeopleCode

View > View Page PeopleCode
Shift+E View > View Record PeopleCode
Alt+O View > Project Workspace
Alt+1 View > OQOutput Window
Alt+2 View > Property Window
F7 Insert > Current Definition into Project
Ctrl+F7 Insert > Definitions into Project...
Ctrl+Shift+R Find Definition References - Field...
Ctrl+Alt+R Find Definition References - Record Field

When you are working with results in the output window, such as after a Find Definition References or
Find In request, you can use your keyboard to navigate the results.

Output Window Keyboard Shortcuts

Description

Up/Down Arrow

Navigate up and down output window results.

Enter

Opens the definition associated with that output window
result.

When you are working with page definitions, you can use the tab key to move from control to control, and
when within a grid, use the left and right arrow keys to navigate between columns in the grid.

When working with projects, you can use the up and down arrows to navigate the list of definitions in
the project workspace, and you can use Ctrl+D to open the currently selected definition. You can select
multiple definitions using the Ctrl key and open them simultaneously.
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Using the PeopleCode and Other Programming Language Editors

This section provides an overview of PeopleCode and discusses how to use the various programming
language editors.

Note: When using the programming language editors, keep these items in mind.

Highlighting the syntax of strings in the HTML Editor and the PeopleCode Editor is done only for single-
line strings, not for multi-line strings.

Word wrap can cause strings to be displayed in various colors if the strings span across multiple lines.
String color-coding, when used with an escape sequence, may be displayed incorrectly in Application
Designer but perform properly at runtime.

Accessing and Using the PeopleCode Editor

PeopleCode is the structured programming language built into PeopleTools that extends the functionality

of the PeopleTools environment, enabling you to add business logic to critical application definitions. All
PeopleCode programs are associated with and considered a part of the parent definition. When you create,
view, or modify a definition, you may simultaneously create, view, or modify its PeopleCode.

You can associate PeopleCode programs with many items, such as record fields, pages, components,
Application Engine programs, and so on. You can access any PeopleCode program from its related
definition. When you have a definition open in Application Designer, you can access the PeopleCode
written for that definition by:

*  Clicking the View PeopleCode button in the toolbar.

* Right-clicking on the definition and selecting View PeopleCode from the popup menu.
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Term Definition
1o For definitions where PeopleCode can be inserted, the View
z PeopleCode button appears in the dynamic Application

Designer toolbar. Click this button to launch the PeopleCode
Editor and view the PeopleCode associated with the current
definition.

The View PeopleCode button appears for these definition
types:

*  Records

*  Pages

*  Components

*  Menus

*  Component interfaces
*  Messages

*  Application Engine programs

Note: Depending on the definition type, the label of the button
and the number of buttons that appear might be different.

For example, with pages, you see two buttons: View Page
PeopleCode and View Record PeopleCode.
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This example illustrates accessing PeopleCode from the current definition open in the Application
Designer workspace. By selecting View PeopleCode from the popup menu, the system launches the
PeopleCode Editor displaying the PeopleCode for the selected record field.

=8 QE_ABSENCE_HIST (Record)

Record Fields IRecnrdTypr ]

Hum Field Hame
LE_EMPLID
LE_ABSEMCE_TWPE
QE_BEGIN_DT
QE_RETURHN_DT :
QE_DURATION_DAYS ! Yiew Definition
LE_DURATIOM_HOURS Yigw PeopleCode
[E_REASOM Wiew Translates
LE_PalD_UNPAID View Field Properties
LE_EMPLOYER_APPROV
QE_COMMENTS Zuk
Copy
Faste

OO0 =l T TR 0 —

—_
=

Delete

Prink

Find Definition References - Field, .,
Find Definition References - Record Field

Recaord Field Properties
Record Properties

To view Record Field PeopleCode there is an additional option:
1. Open a record definition in PeopleSoft Application Designer.
2. Click the View PeopleCode toolbar button to view the PeopleCode display for the record.

3. Locate the field containing PeopleCode in the record definition for which you want to access the
PeopleCode.

4. Double-click the cell (the check mark)] under the column heading for the type of PeopleCode that you
want to view.

The PeopleCode editor is a text editor that enables you to construct, modify, and review PeopleCode
programs and associate them to PeopleSoft definitions and events. The PeopleCode editor enables you to
edit and navigate all PeopleCode programs that belong to the same parent definition.

The user interface of the PeopleCode editor consists of two drop-down lists boxes and an area where you
enter text. The drop-down list box that is on the left side of the editor is a displays the current field and
other available fields, records, and components. Any field with PeopleCode attached appears in bold. The
drop-down list box that is on the right side of the editor displays the current PeopleCode event and other
events that are appropriate for that definition. Events already containing PeopleCode for that definition
appear in bold.

Beneath the drop-down list boxes is where you enter your text. In this area, you can add, delete, and
change text and you can use the find and replace function. The PeopleCode editor validates the syntax of
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your code and the editor automatically formats the code according to PeopleSoft standards when you save
the definition.

This example illustrates the fields and controls on the Example of working in the PeopleCode editor. You
can find definitions for the fields and controls later on this page.

EHQE_ABSENCE_HIST (Record)

Record Fields IRecnrdT\_,-'pe ]

Hum Field Hame
[E_EMPLID
[E_ABSEMCE_TYPE
QE_BEGIM_DT
QE_RETURM_DT

AF DIRATINN DAYS ;

= QE_ABSENCE_HIST.QE_RETURN_DT.FieldC
| QE_RETURM DT [field) leieIdEhange

iIf AlL(QE_ABSENCE _HIST.QE_BEGIN DT, QE_ABSENCE HIST.QE_EETUEN DT) &nd
QE_AB3ENCE _HIST.(QE_BEGIN DT <= QE_ABRSENCE HIST.(QE_RETUEN DT Then
sDURATION DAYI = OE_ABIENCE_HIST.(QE_RETUEN DT - QE_AB3ENCE_HIST.QE_EE!
If &<DURATION DaAYTS > 999 Then
QE_ABSENCE_HIST.(QE DURATION DATH 9949
Elze
QE_AESENCE HIST.QE DURATION DAYS sDURATION DAYS
End-If:
End-If:

L0 00 el T TR D e —

—_
]

[

Note: You can embed strings in the PeopleCode editor that generate HTML, JavaScript, CSS, and XML
markup. However, it is not considered a best practice.

Note: Multiple programmers may save changes to different PeopleCode programs associated with the
same definition. However, the system displays an error if multiple programmers attempt to save the same
PeopleCode program associated with the same definition and PeopleCode event.

Note: With the PeopleCode Editor active, you can select View, Line Numbers to display line numbers to
the left of each line in the program, beginning with 001.

Related Links
“Understanding PeopleCode Programs and Events” (PeopleCode Developer’s Guide)

Using Additional Programming Language Editors
This section discusses these programming editors:
*  SQL editor

* Application packages editor
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¢ HTML editor

» Free form style sheet editor

SQL Editor

The SQL editor is a text editor that enables you to construct, modify, and review a SQL statement and
save it as a reusable SQL definition. Using the SQL editor, you can add, delete, and change text and you
can use the find and replace function. The SQL editor formats the text, but the editor does not validate the
SQL syntax.

You can access the SQL editor from these definitions:
* Record definitions that are based on SQL and dynamic views.
» PeopleSoft Application Engine actions.

* PeopleCode editor.

Application Packages Editor

From an Application Package you can access the PeopleCode programs that are associated with the
classes of the package. The Application Packages editor and the PeopleCode editor interfaces are similar.
You can add, delete, and change text; you can use the find and replace function; and you can validate the
syntax. When you save your application package, the code is automatically formatted, just as it is in the
PeopleCode editor.

HTML Editor

The HTML editor interface offers some of the same functionality as the other editors. In the HTML editor
you can add, delete, and change text; and you can use the find and replace function. While the editor does
format certain elements of your code, such as variables, methods, and strings, the editor does not validate
the syntax. Because the HTML editor is free form, you can enter any type of text in it because there is

no validation of any kind. However because the HTML editor output is used in web pages, typically, you
enter only the following markup languages: HTML, JavaScript, CSS, and XML

Free Form Style Sheet Editor

The free form style sheet editor interface enables you to create text-based sub style sheets that enable
you to take advantage of Cascading Style Sheets - Level 2 (CSS2), AJAX, and DHTML. In the free form
style sheet editor you can add, delete, and change text; and you can use the find and replace function. The
editor does not format the text or validate the syntax.

Related Links

“Using the PeopleCode Editor” (PeopleCode Developer’s Guide)

“Using the SQL Editor” (PeopleCode Developer’s Guide)
“Understanding Application Packages” (PeopleCode Developer’s Guide)
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Working with Definitions

This section provides as overview of definitions and discusses how to:

L]

Open definitions.

View definitions.

View and edit definition properties.
Create definitions.

Save definitions.

Close definitions.

Rename definitions.

Delete definitions.

Find definitions.

Use the Multiple Document interface.
Use drag-and-drop mouse techniques.
Use dynamic toolbars and menus.
Use pop-up menus.

Configure the Application Designer user interface.

Work with generated files.

Note: Certain dialog boxes only allow the selection of All Projects in the Project field.

Understanding Definitions

50

You can create or modify many types of definitions in PeopleSoft Application Designer. This table lists
development definitions:

Definition Description

Activity Workflow map showing the individual steps, events, and
routings that comprise a complete activity in a business
process.

Analytic Model The representation of a methodology used exclusively with the
PeopleSoft Analytic Calculation Engine.
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Definition Description

Application Engine Program comprising SQL statements and PeopleCode
programs that runs in batch mode as an alternative to using
COBOL or SQR programs.

Application Package Packages for creating Application Classes, which you can use

to extend the functionality of existing PeopleTools classes
(Rowset, Array, and so on) or to create your own classes.

Approval Rule Set

Workflow maps that provide a visual representation of
approval rules. Virtual Approver reads approval rule sets to
determine who must approve transactions.

Business Interlink

Gateway between PeopleSoft applications and the services of
an external system.

Business Process

Workflow maps that provide a visual overview of the activities
involved in a procedure.

Component

Representation of a logical business transaction or a set of
logically related pages that are processed together.

Component Interface

Way of externalizing access to a component so that it can be
used by a third party or an application message.

Field Individual pieces of data, such as an employee ID, that a user
can enter and the system can store in the database, in a column
on a table, or in a view.

File Layout Definition (or mapping) of a file to be processed. It identifies
where data fields are located in a file.

HTML Definition that represents static HTML that can be included on
a page definition.

Image Definition that stores and displays graphics or other images,

such as icons, that appear throughout the application.
Note: Image definitions and image fields are not the same.

Menu Definition that organizes the components that you build and
the pages contained in the components.

Message Based on a multilevel structure, similar to components, a way

of defining the data to insert into an application message at
runtime.
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Definition Description

Message Channel Corresponding to groups of message definitions, these help
order messages properly, enhance scalability, and provide
a simple way to define processing characteristics of many
similar messages as a single group.

Page User-defined collection of controls created for entering,
viewing, and editing data online. The system validates user
input, writes it to the database, and retrieves and displays it
upon request.

Project User-defined collection of related definitions created for
developing, adapting, or upgrading a PeopleSoft application.

Problem Type In optimization, a way to tie the optimization application
records, the optimization transactions, and the optimization
plug-in together as one entity.

Record Tables that store all of the data that resides in PeopleSoft
applications part of a relational database system. Tables are
the same as records, and each record definition describes the
properties of an underlying SQL table.

SQL Entire SQL programs or fragments of SQL statements
available for reuse.

Style Sheet Collection of styles that PeopleSoft Pure Internet Architecture
application pages can use.

Opening Definitions
Use the definition workspace to access or create definitions.
To open a definition:
1. Select File > Open or click the corresponding toolbar button.

The Open Definition dialog box appears.
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This example illustrates the fields and controls on the Open Definition dialog box.

Open Definition >
D efinition FPage -
Selection Criteria Cancel
Narme | FTFF | Project Al Projects w
Mew 5 h
Cescription | | Owner 1D All Dwrers iy e
Type All Pages w
Definitionz matching zelection critenia: @
M arme Type Drezcription 6
FTFPCLOUD_PRWDRS Standard ... Cloud Attach Config Page
PTFP_ADMIN_PERS Standard ... Adminiztrator personalization
PTFFP_ATOMPROP_SEP Subpage ... Atom Feed Properties Sub Page
PTFP_CATEGORIES Standard ... Pagelet‘\Wizard Categories
PTFFP_COMFROP_SBP Subpage ...  Common Feed Properties SubPage
PTFP_COMFIRK_DEL Standard ... Delete Canfirrmation
PTFP_COMFIRM_SAVE Standard ... Save Confirmation
PTFP_DATATYPE Standard ... Feed Data Types
FTFP_DELETE Standard ... Delete Feed Definitonz b
35 definition(z] found

Select the type of definition that you want to open from the Definition drop-down list box.

Provide selection criteria.

Enter a definition name or description (or the beginning characters of either). Other selection criteria

options might be available, depending on the definition type.

Click Open, or press ENTER, to display definitions matching the selection criteria that you entered.

To clear the current selection criteria and start over, click New Search. To change how the system
displays the search list, perform one of these actions:

*  Click the List button to see only the names of the definitions.

*  Click the Details button to see the names and descriptions of the definitions. This is the default.

Select a definition to open.

Double-click the definition that you want to open in the definition workspace, or highlight the
definition and click Open.

You can also use the shift-click selection technique to select more than one definition to open in a
single action, or you can right-click to view a pop-up menu, where you can open, print, rename, or
delete the selected definition.
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Note: The print menu is disabled when you right-click any of the following definitions: activity,
approval rule set, business process, component interface, component, and project.

Note: When the definition is open and able to be modified, "Ready" appears in the lower left-hand
corner of the workspace.

Viewing Definitions

In the project workspace, you can view a definition that is referenced by the active definition.

To view a definition, select View > View Definition. You can also right-click the definition you want to
view and select View Definition from the pop-up menu.

Viewing and Editing Definition Properties

54

Properties are associated with each definition type. To view or edit definition properties, select File >
Definition Properties. You can also click the toolbar button, press Alt+Enter, or right-click the definition
and select Properties from the pop-up menu.

The Definition Properties dialog box almost always includes a General tab that provides a place to display
and enter descriptions and comments about the definition. An optional Owner ID drop-down list box
designates the owner of an individual definition. This ID helps identify which application team last made
a change to a definition. Set the default owner ID for new definitions in the Options dialog box on the
Owner ID tab.
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This example illustrates the fields and controls on the Example of a Property sheet. You can find
definitions for the fields and controls later on this page.

Record Properties b_q

General | ze

ﬁ AMM_DERMED

Description: App Mag Monitor work: recard

Recard Definition:;

Thiz denved record iz uged by the Application Meszage Moritor.

Dwner 1D FPeopleT oolz "

Last Updated
Crate/Time: 0 A06A2011 926534 M

By Uzer FPLSOFT

[ ] 4 l[ Canicel ]

With PeopleSoft Application Designer, every definition that you can open (menus, pages, components,
records, fields, and so on) has an associated property sheet. Definition properties that are specific to the
definition type are grouped together in these definition property sheets. For example:

* Record type and record use properties are found in the Definition Properties sheet for records.
* Translate values are found in the Definition Properties sheet for fields.
*  Menu groups and menu labels are found in the Definition Properties sheet for menus.

* Search record, actions, and internet settings are found in the Definition Properties sheet for
components.

Copyright © 1988, 2023, Oracle and/or its affiliates. 55



Using PeopleSoft Application Designer Chapter 2

Creating Definitions

When building or adapting an application, try to use existing definitions as much as possible; when that is
not possible, create new definitions.

To create a new definition:
1. Select File > New or click the corresponding toolbar button.
2. Select the definition type.

The new definition appears in the definition workspace.

Saving Definitions

To retain your changes, you must save the definition. You must name new definitions before you can save
them.

To save a definition:

1. Click the Save button on the toolbar or select either File > Save or File > Save As to save a
definition.

The Save and Save As commands save a single definition. Use the File, Save All command or the
Save All toolbar button to save all open definitions at once.

2. Ifyou are saving a page or component, specify the language or market.

For a page definition, the Language drop-down list box appears; for a component, the Market drop-
down list box appears.

Definition Naming Conventions
When naming definitions, use the following guidelines:

» Use only uppercase alphabetic characters (A—Z), numeric characters (0-9), or underscore (_). Other
special characters, such as the em dash (—), dollar sign, number sign, question mark, and so on, are
not permitted.

* Names must begin with an alphabetic character.
* Embedded spaces are not permitted.

Instead, use an underscore.
* Avoid using accented characters.

Names containing these characters may not sort consistently, depending on workstation or locale
settings, which results in problems during an upgrade.

» System definitions such as records, fields, styles, and so on generally have a name and a label or
description. Generally, you should use US-ASCII characters only for the definition name. Labels or
descriptions, which appear to the user, can contain non-ASCII characters.
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Note: Existing Business Process and Business Process Map definitions may already contain mixed case

characters. Nonetheless, newly created definition names must be all uppercase.

Closing Definitions

To close a definition, either select File > Close or click the Close Window icon on the title bar of the
window of the active definition. You can also select Window > Close All to close all open definitions.

Renaming Definitions

You can rename existing definitions in a database at any time.

This example illustrates the fields and controls on the Rename Definition dialog box.

Renarme Definition >
D efinition Record ~
Selection Criteria Cancel
Name ACCESS | Project &l Projects
. Mew Search
D escription | |
Type Table .
Definitions matching selection criteria: @
M ame Type Dezcnption
ACCESS_GRP_LAMG Table Related Language T able
ACCESS_GRP_TBL Takle Tree Access Groups

2 definition(z] found

To rename a definition in the database:

1.

Select File > Rename.

The Rename Definition dialog box looks like the Open Definition dialog box, and you select

definitions in the same way.

want to rename.

Specify the definition type and any selection criteria that are useful in locating the definition that you

The Rename Definition dialog box does not have a Select button. So, after entering either a partial
name or description of the definition, press Enter to retrieve a list of definitions matching your

selection criteria.
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3. Select the definition that you want to rename.

4. Click the Rename button in the dialog box and double-click the selected definition, or right-click to
select Rename from the pop-up menu.

The selected definition name in the Rename Definition dialog box is in edit mode.
5. Change the selected definition name and press Enter.

When you press Enter, PeopleSoft Application Designer prompts you first, to close any open
definitions before you can save the new name, and then to confirm the rename before you can save a
change.

6. Click OK to complete the renaming of the selected definition.

Deleting Definitions

58

Deleting a definition is different from removing a definition from a project. When you remove a
definition from a project, the reference to the definition is removed from the project, but the definition
still exists in the database and, thus, may be part of another project. Deleting a definition, however,
permanently removes the definition from the database. Any projects or other definitions that contain the
deleted definition are affected.

Before deleting a definition you should find all references to that definition by running the Find
Definition References process. For example, a field definition that you want to delete may be referenced
by both record and page definitions.

Note: If you delete a component definition, you must delete all component interfaces that are based on
that definition.

Note: A component definition must contain at least one page. If you attempt to delete a page definition
that is the only page definition within a component, the system does not allow the delete to occur and
displays an error message. If the page definition is the only page within a component, the error message
appears during a File, Delete action or during an upgrade copy to database (with a Delete action).
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This example illustrates the fields and controls on the Delete Definition dialog box.

Delete Definition >

D efinition Page e
Selection Criteria Cancel
Name #35BF | Project A4ll Projects w

. Mew Search

Description | | Language English iy
Type Subpage w | Dwner D Al Owners w

Definitions ratching selection critena: @
M arme Type Drezcription Language ™
ADDRESS_DFT_SBF Subpage ... Address default subpage EMG
AGC_Ck_MalL1_SBF Subpage ... AGC Context Key'fal 1 Sub Pg EMG
AGC_Ck_MalLZ_SBF Subpage ... AGC Context Key'fal 2 Sub Pg EMG
AGC_CK_MalL3 _SBF Subpage ... AGC Context Key'fal 3 5ub Pg EMG
AGC_CK_MalLa_SBF Subpage ... AGC Context Key'fal 4 Sub Pg EMG
AGC_CK_WALE_SBF Subpage ... AGLC Context Key'fal 5 Sub Pg EMG
AGC_CK_WRK_SEF Subpage ... AGC Contest Kep'fal 1 Sub Pg EMG
AGC_FILTER_SEF Subpage ...  File Information transfer EMG W
£ >

E49 definition(z] found

To delete a definition from the database:

1. Select File > Delete.

The Delete Definition dialog box looks like the Open Definition dialog box, and you select definitions

in exactly the same way.

2. Specify the definition type and any selection criteria that are useful in locating the definition that you

want to delete.

After entering either a partial name or description of the definition, press Enter to retrieve a list of

definitions matching your selection criteria.

3. Select the definition that you want to delete.

To select multiple definitions, hold down either Shift or Ctrl while clicking the appropriate

definitions.

4. Click the Delete button and confirm that you want to delete the selected definition.

Finding Definition References

Before making significant changes, such as deleting a definition or modifying a definition, you

must see what other parts of the application might be affected by the change. The Find Definition
References feature enables you to assess the impact of a potential change to a definition, by performing
a comprehensive search of the database pinpointing all definitions in which the definition in focus is

located.
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Note: Although a project keeps track of your definitions, the definitions are not actually embedded in the
project.

Note: The distinction between related definitions and referenced definitions is significant. A related
definition is one that is used by the current definition. A referenced definition is one that uses the current
definition. For example, in the case of a record definition, fields in the record are related definitions. The
records that use the fields are its definition references.

Using the Find Definition References Feature

This example illustrates how to find definition references.

] Application Designer - H92DP911 - DAP_DROPZONES - BEGIN_DT (Field) =1/[O/Hx!
File Edit View Insert Build Debug Tools Go Window Help
NEHO & $B@
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40 Components
=53 Pages &@ BEGIN_DT (Field) SCIES
- [5] CHANGE_PASSWORD Ep—
[ EMPL_NAME_FL 58P e [Dae
[ HR_EE_ADDR_SBF
[ HR_EE_CONTACTS FL Field Labels
. [ HR_EE NAME SBF Label ID Long Neme ShartHame -
e:-[E] PT_ERCSUBPAGE.STUB 1 [EE Bean Date Begin Date
[ PT_GROUPBUILDER FL 2 BEGIN_END_OI— Begaina PecintE a0y =
4[] PTCS_SUBPNL_SRCH 3 DATE Find Definition References
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SearchFilers
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Usedin PeopleCods: HRS_JOB_OPENING_MANAGER(APPLICATION_PACKAGE) .0BJ_HRS_JO_ROMT(APPLICATION_PACKAGET) . BUS(APPLICATION_PACKAGE2) . JORqm{APPLICATION_CLASS). OnExecuie(METHOD) s FIELD(Rechame) . BEGIN_DT Field
Usedin PeopleCode: TL_FL_TIMESHEE T(APFLICATION_PACKAGEL. Tine_Enty8PPLICATION_PACKAGE1). TineSheetFunciionsPPLICATION_CLASS) . DrExeculsMETHOD) as DERIVED_TL WEEK(Rechlame). BEGIN_DT(Field)
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To find definition references:
1. Open the definition in the definition workspace.

2. Select Edit > Find Definition References > or right-click the definition and select Find Definition
References from the pop-up menu.

After you select this item, a search of the database takes place, and the results appear on the Find
Definition References tab of the output window.

3. For Records, fields, record fields, and field labels, select any filtering options from the Find
Definitions References dialog box.

See the following sections for information on filtering search results for these definition types.
4. Select any definition that appears in the output window by double-clicking it.
The selected definition opens in the definition workspace.

5. After you find a definition, select the definition reference and right-click to view the pop-up menu.
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Note: Double-clicking an entry in the Find Definition References output window opens the
appropriate mode of PeopleSoft Application Designer. If you double-click a related record that was
found, the record opens and the field for which you were looking is highlighted.

Common Controls for Find Definition References Filtering

When you select Find Definition References for a record, field, record field, or field label, the Find
Definition References dialog box appears, providing additional options for filtering and refining the
definitions in which you want to search for references. The following sections describe the options and

usage.

Field or Control

Description

Definition Name

To filter search results by a definition name, enter the

definition name or partial definition name.

Owner ID To filter search results by a specific owner ID, select the owner
ID from the drop-down list.

Select All Select all definition types in the definition filter tree.

Clear All Clear all definition type selections in the definition filter tree.

Expand All Expand all applicable definition type nodes in the definition
filter tree.

Collapse All Collapse all applicable definition type nodes in the definition

filter tree.
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Using the Find Definition References Feature for Fields

This example illustrates the Find Definition References dialog for fields displaying the options to select
for narrowing the scope of the search.

Find Definition References

Field |BEGIN_DT |

Search Filkers

Drefinition M ame:

Owiner 1d:

Cancel

|PHES

v]

| PeopleT oolzPPT

vl

=

= -- Records

- |wf] Page
- [w] Project

- [w] Message
—[w¥] Chanrel

- [w¥] PeopleCode

- [w¥] Companent [nterface
- [w] Analptic Type

- [w] Aanalytic: M odel

L]

R

| Selectall |

| Cleardll | | Ewpandal |

| Collapse Al

When you select Find Definition References for a field definition, the Find Definition References dialog
box displays a set of options for filtering the definition types searched. For example, if you select to
search only in Records (all types listed) and Page only references in record and page definition types will
appear in the output window, enabling you to find the applicable references quicker.

For fields, you can select to search for references in these definition types:

Records
¢ Record
*  Query View

¢ RecField Set Control Field

* Record Set Control Field

Page
Project

PeopleCode
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*  Component Interface
* Analytic Type

*  Analytic Model

*  Message

e Channel

* File Layout

e Test

Using the Find Definition References Feature for Records

This example illustrates the Find Definition References dialog for records displaying the options to select
for narrowing the scope of the search.

Find Definition References

E3
Record  [OE_BOOK |

Cancel

Search Filters

Drefirition M arne: | h |

Owarner 1d: | v |

L]

v Edit T able
- [w] Default Becaord
- [w#] Parent Becard
- [v#] Felated Language Fecord
[ Quem Security Becaord
[ Aaiadit Fecard
- [w#] Subrecaord
] Queny Wiew
- [v#] Record Groups

+-[v] Fages

- |wf] Search Record in Mernu
- [wf] Component Interfaces y

| Selectall | | Cleardl | | Espand&ll | | Collapse Al

When you select Find Definition References for a record definition, the Find Definition References dialog
box displays a set of options for filtering the definition types searched. For example, if you select to
search only in Records (all types listed) and Pages (all types listed) only references in record and page
definition types will appear in the output window, enabling you to find the applicable references quicker.

For records, you can select to search for references in these definition types:

¢ Records
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Edit Table

Default Record

Parent Record

Related Language Record
Query Security Record
Audit Record

Sub record

Query View

Record Groups

Pages

Panel

Tree Control Panel

Search Record in Panel Group
Add Search Record in Panel Group

Tree

Search Record in Menu

Component Interfaces

Project

Virtual Approver

Application Engine

State records

Temp records

Problem Type Definition

Business Process Designer

PeopleCode

Messaging

File Layouts

Analytic Model

Chapter 2
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Using the Find Definition References Feature for Record Fields

This example illustrates the Find Definition References dialog for record fields displaying the options to
select for narrowing the scope of the search.

Find Definition References

Record Field |OE_BOOK.OE_BOOK_NAME |

Search Filters

=

Drefinition M ame: |

Dwner 1d: |

Cancel
v|
v|

- [w] Default [Record. Field)

- [w#] Parel Field

- [w] TreeCantral an Parnel

-] Query Wiew

- [w] Tree

] Buginess Process Designer
- [w] Aspalytic: Type

- [wf] nalytic Model

—[w¥] File Layouts

- [w] PeopleCode

Select#ll | | Cleardl | | Ewpandal |

| Collapse Al

For record fields, you can filter your search by:

Record Field (default)

Panel Field (page field)

Tree Control on Panel (page)
Query View

Tree

Business Process Designer
Analytic Type

Analytic Model

File Layouts
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Using the Find Definition References Feature for Field Labels

Chapter 2

This example illustrates the Find Definition References dialog for field labels displaying the options to

select for narrowing the scope of the search.

Find Definition References

Field Label  |[BOOK_MAME |

Search Filters

Cancel

Drefinition M ame: |

Dwner 1d: |

=
v
v

Select#ll | | Cleardl | | Ewpandal |

| Collapse Al

For field labels, you can filter your search by:
e Record

* Panel (page definitions)

Related Links

“Using the Find In Feature” (PeopleCode Developer’s Guide)

Using the Multiple Document Interface

PeopleSoft Application Designer makes use of multiple document interface (MDI). Consequently, each
window in the definition workspace of PeopleSoft Application Designer represents a view of a definition,
and you can have multiple windows open at the same time. These definition windows must stay inside the
borders of the definition workspace, but you can maximize, minimize, cascade, or tile them in that space.

66
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You can have different types of definition windows open at the same time, such as menu, field, record,
and page windows. As a result, you can work with different definitions simultaneously, which simplifies
the process of designing a group of related definitions.

Active Windows

Although you can have multiple windows open at the same time, only one window can be active at any
moment. Make a window active by selecting it in the definition workspace. The active window always
appears on top with the title bar in active window title color.

In addition to clicking a window to make it active, you can also use the Window menu shown in the
following example. This menu displays the windows that are currently open by displaying a check mark
next to the active one. Change the window that is currently active by selecting it from the menu.

This example illustrates the fields and controls on the Example of the Window menu. You can find
definitions for the fields and controls later on this page.

“J A pplication Designer, - Untitled - ACCESS_GRP_TBL (Record) =3
File Edit ¥ew Insert Build Debug Tools Go RUGGEEE]

DEHO & 480 & gL o

Tile

. ; i Arrange Icons
@ Untitled L - Close all

1 ACCESS_GROUP (Field)
2 SCRTY_ACC_GRP (Record)
v 3 ACCESS_GRP_TBL (Record)

Field

Fiel Short Hame
ACCESS_GROUP A Grip Lp
J Char 30 Iixed Deser Dezeription

= Long 1} Deser Dezeription

Other commands from the Window menu include Cascade, Tile, Arrange Icons, and Close All windows.

Using Drag-and-Drop Mouse Techniques

PeopleSoft Application Designer makes ample use of drag-and-drop mouse techniques. For example, you
can drag a field from a record definition and drop it onto a page definition. You can then drag the page
onto a component and drag the component onto a menu. Using the drag-and-drop technique is faster and
simpler than using menu commands to manipulate definitions.

To drag and drop a definition:

1. Open the definition in either the project workspace or the definition workspace from which you want
to drag.

For example, to drag a field from an existing record definition to a new page definition, first open the
record containing the field. You can open it in the definition workspace or expand the record in the
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project workspace so that the fields appear. With the appropriate field displayed, you can drag and
drop it into another definition.

2. Open the definition to which you want to drag.

3. Drag the definition from one definition to the other.

Using Dynamic Toolbars and Menus

The PeopleSoft Application Designer toolbar and menus change based on the type of definition that
is active. For example, when a page definition is active, the toolbar displays buttons that represent the
definitions that you can add to a page. This technique is also known as morphing.

The change is so subtle that you can easily miss it. The change is easy to miss because the menu bar
names are consistent among definition types. However, if you look at the menu items and toolbars closely,
you see a distinct difference. For example, if a page window is active, then the menus and toolbars change
to include actions and options applicable to a page definition, as in the Show Grid option on the View
menu and the introduction of the Layout menu. In addition, page-specific toolbars appear.

In the same respect, if a record window is active, the menus and toolbars morph to include actions and
options applicable to a record definition. For example, different options (such as View, Field Display, and
so on) are available in the View menu . Different toolbar buttons for record definition actions also appear.

Using Pop-up Menus

68

Pop-up menus are context-sensitive menus that appear at the current location of the mouse pointer
whenever you click the alternate mouse button (typically, the right mouse button). They provide efficient
access to numerous PeopleSoft Application Designer commands. Because pop-up menus appear at the
current location of the pointer, they eliminate the need to move the pointer up to the menu bar or to a
toolbar. A pop-up menu contains only the commands that apply to the selected definition or the current
context. This example shows the component definition pop-up menu:
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This example illustrates the fields and controls on the Example of the Component definition pop-up
menu. You can find definitions for the fields and controls later on this page.

551 PTaS2_t02R1 ~
+ |:| Application Engine Programs
=3 Components
T IB_DOMAINSTATUS {GEL)

+

¥ IE HOME P Wigw Definition

+ I6_INTMET |  View PeopleCode

: BINTRET | Jciude In Project

4 1B_INTRET_ Remaowe From Project el

+ F= 1B_INTMET !

E: IBE_INTMETY  Shaw Histary

+ IB_IMTRETY

F= 1B LoaIoal Clase All Folders

4 IB_MONITO e befinition References

T IB_MOMITO

T IB_ROUTINE

+ I6_SERYICE _

+ 52 16 seryicg  Yalidate

+ IE_SERVICE

+ IE_SERVICE

& B SVEETL o anstate k
+ IE_SYSTEME e ey 3

_ﬁjnevelupment |é"'l Uparade ]

Configuring the Application Designer User Interface

PeopleSoft Application Designer is highly configurable, enabling you to tailor the tool to your needs or
preferences.

Splitter Bars

A splitter bar is a thin vertical or horizontal bar that separates windows inside a parent window. Using the
splitter bar enables you to resize two windows at the same time. Splitter bars are used between the project
workspace, definition workspace, and output window. This example shows splitter bars:
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This example illustrates the fields and controls on the Example of Splitter bars used to resize a workspace.
You can find definitions for the fields and controls later on this page.

] Application Designer, - Untitled
File Edit Wiew Insert Build Debug Tools Go  Window Help

NsHY & s =20 =83 |
21 Untitled

| # Development |é“'l Uparade I

Opening project ...
0 total definition(z] in project.

>

4| Pl\ Buid } Upgrade } Results f ¥alidate }  Find Definition Refersnces  §

Ready

Drag the splitter bar to change the size of the project workspace, definition workspace, or output window.

Dockable Windows and Toolbars

You can freely move PeopleSoft Application Designer windows and toolbars to either anchor (dock) to
parts of the main application window or float freely anywhere that you want them to appear. When you
dock a toolbar or window, you anchor it to the top, sides, or bottom of the main window.

To move or dock a PeopleSoft Application Designer window or toolbar, drag the window title bar or the
appropriate toolbar to a new location. If you move the window or toolbar near the top, bottom, or sides
of the main window, the window or toolbar snaps into place, meaning that it is docked. However, if you
press and hold Ctrl and then drag the window or toolbar, you can prevent it from automatically docking
when it is near the edge of the window.

Note: Use caution when running the PeopleCode Debugger with undocked windows.

View Menu

The View menu enables you to display or hide different PeopleSoft Application Designer elements, such
as the project workspace, output window, and toolbar.
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Working with Generated Files

When working with PeopleSoft Application Designer, you often generate scripts, logs, reports, and so on.
When specifying the full path for a file reference in PeopleSoft Application Designer, you are limited to
100 characters. This limit applies to all file references, which include build scripts, build logs, compare
reports, and so on. For example, a reference to a build log, such as c:\temp\...\psbuild.log, cannot exceed
100 characters.

Using Miscellaneous Definitions

Several definition types differ from the standard definitions described in previous sections. These
definitions control your work environment or affect other definitions that you create. These miscellaneous
definitions are found under the Tools menu and include:

* Field Formats

* System Colors
* Styles

* Access Profiles

* File Type Codes

Field Formats

PeopleTools provides formatting at both the field and page levels. Field format specifications affect
internal values that are stored in the database, and page format specifications affect the visual presentation
of values. Several formatting options are available for U.S. Social Security Numbers, Canadian Social
Insurance Numbers, postal codes, telephone numbers, and various currencies, dates, and times.

Custom field formats extend these formatting provisions to support the same types of data in other
countries. They also support other types of formatted information, such as bank codes, credit card
numbers, part numbers, and serial numbers.

Custom field formats enable you to create your own format definitions using format notation and apply
them to fields. These formats are organized into format families, which can include one or more unique
formats.

See Changing Format Families.

System Colors

You can establish definitions for colors that you use in your applications. You define colors by associating
a color name either with an existing color in the PeopleSoft Internet Architecture or with a custom color
that you define. Since taste in color is subjective, PeopleTools allows individual operators to customize
their color settings. Users can use the default color definitions you establish in PeopleSoft Application
Designer, or they can override them with their own color definitions.
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This example illustrates the fields and controls on the Setting default system colors. You can find

definitions for the fields and controls later on this page.

Set System Default Colors E|
Colar Mame:
| 3 | () Use Windows Colar
() Use Custom Calar
Chooze Color
S ample

B -

To modify default system colors:

1.

2.

Select Tools > Miscellaneous Definitions > System Colors.

Select the Color Name you want to modify.

To change the color, click the Choose Color button.

Choose from the available colors or click Define Custom Colors to create your own color.
Click OK.

The new color appears in the Sample area of the Set System Default Colors dialog box.

To create new system colors:

1. Type a new name in the Color Name field and click the New button.

2. Select the Use Custom Color radio button to select a custom color.

3. Click the Choose Color button.

4. Choose from the available colors or click the Define Custom Colors button.
5. Click OK in both dialog boxes to accept the new color.

Styles

This feature is deprecated. You set styles using style sheet definitions.

Chapter 2
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See Understanding Style Sheets and Style Classes.

Access Profiles

Access profiles are the security profiles the system uses to connect to the PeopleSoft database. The
product documentation for PeopleTools security provides detailed information about access profiles.

See “Setting Up Access Profiles” (Security Administration).

File Type Codes

You may need to set up file type codes when creating change projects. You create change projects to work
with the PeopleSoft Application Designer Change Packager tool to package system customizations in
preparation for an upgrade. The file type code stores generic information that is applicable to a group of
files within the same target directory.

See “Understanding Change Packages” (Change Assistant and Update Manager).

Using the PeopleSoft Application Designer Spell Check Feature

This section provides an overview of the PeopleSoft Application Designer spell check feature and
discusses how to:

* Enable the spell check feature.

» Configure browser options.

Understanding the Spell Check Feature

The PeopleSoft Application Designer spell check feature checks the spelling for user-facing labels and
text in projects and legacy data. Use this feature before building your application. The spell check feature
verifies spelling for these items:

* Message Catalog entries.

» Page definitions (label text).

e Translate (XLAT) tables.

e Component definitions (tab and menu labels).
» Portal registry (labels and attribute labels).

¢ Record field labels.

Spell Check Results

The system logs spell check results on the Spell Check tab in the PeopleSoft Application Designer output
window. The text Begin Spell Check always appears as the first line on the tab. The first line for each spell
check category indicates the total number of entries that were checked for the project. The last line in the
output window indicates the total misspelled words encountered during the check.
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For each spell check category the results may read differently. This table describes how to read the spell

check results for each category:

Output by Error Type

Description

Message Catalog:
Message Set www Nbr xxx (yyy) - zzz

For example: Message Set 1 Nbr 1 (Message Text) -
Distributed Object Mgr: Xelp Xme=Xangage=abc rtz

Where:
www = Message set number.
xxx = Message number within the message set.

Yyy =-

Message text, indicating that zzz is the complete message
text.

Explain text, indicating that zzz is the complete explain
text.

Misspelling, indicating that zzz is a misspelled word in
either message text or explain text.

XLAT:

[vvwv.www.xxx] (yyy) - zzz

Where:

vvv = Database field name.

www = Field value.

xxx = Effective date.

yyy =

Long name, indicating that zzz is the complete text for the
long name.

Short name, indicating that zzz is the complete text for the
short name

Misspelling, indicating that zzz is a misspelled word in
either a long or short name.
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Output by Error Type Description
Component: Where:
[vvv.www] Item Name xxx (yyy) - zzz vvv = Component name.

www = Market code.
xxx = [tem name for the component.
yyy =

+  Item label, indicating that zzz is the complete text for the
item label of the component.

»  Folder tab label, indicating that zzz is the complete text
for the folder tab label of the component.

*  Misspelling, indicating that zzz is a misspelled word in
either the item label or the folder tab label.
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Output by Error Type

Description

Portal Registry:

[ttt.uuu.vvv] www xxx (yyy) - zzz

Where:

ttt = Portal name.

uuu = C for content reference, F for folder.
vvv = Portal object name.

WWW =:

*  Empty.

*  Attribute.

*  System attribute.

XXX =

*  Empty if www is empty.

*  Attribute name if www is attribute.

*  System attribute name if www is system attribute.
yyy =

»  Label name, indicating that zzz is the complete text for
the label name.

»  Display name, indicating that zzz is the complete text for
the display name of an attribute.

*  Misspelling, indicating that zzz is a misspelled word in
either the label name or the display name.

Field Label:

[www.xxx] (yyy) - zzz

Where:
www = Field name.
xxx = Field label name.

Yyy=

»  Long name, indicating that zzz is the complete text for the
long name.

»  Short name, indicating that zzz is the complete text for the
short name

*  Misspelling, indicating that zzz is a misspelled word in
either a long or short name.
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Output by Error Type

Description

Page:

[www] Field ID xxx (yyy) - zzz

Where:

www = Page name.

xxx = Field ID within the page.
yyy =

»  Label text, indicating that zzz is the complete text for the
label text of the field.

»  Scroll area, indicating that zzz is the complete text for
label text within a scroll area.

*  Misspelling, indicating that zzz is a misspelled word in
the label text.

You can launch an identified definition directly from the output window by double-clicking the error line.
PeopleSoft Application Designer launches the appropriate content to correct the misspelling, as described

in this table:
Error Type Launches
Message Catalog NA
XLAT Field definition.
Component Component definition.
Portal registry Browser to display the Content or Folder Administration page.
Field label Field definition.
Page Page definition.

Enabling the Spell Check Feature

The spell check feature is turned off by default. You enable the spell check feature in the Options dialog
box on the Validate tab. Enabling the spell check option ensures that spell check is run on the designated

project when you validate the project.

To enable spell check in PeopleSoft Application Designer:

1. Select Tools > Options from the PeopleSoft Application Designer menu.
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2. Select the Validate tab.
3. Select the Validate Spelling check box.

4. (Optional) Select the Log to file check box if you want the spell check results to be saved to a file on
your system.

5. Enter a file name in the File name field or click the browse button to search for a specific file.

Otherwise, the system applies the default file name of spellcheck.log and saves the results to the temp
directory. This field is required when the Log to file option is selected.

Configuring Browser Options

The Browser tab on the Options dialog box enables you to specify values that are required to compose a
URL for the browser to locate a portal page. The spell check feature uses the information recorded in this
dialog box to launch portal pages from the Spell Check tab in the output window when you double-click a
portal registry misspelling.

This example illustrates the fields and controls on the Options dialog box: Browser tab. You can find
definitions for the fields and controls later on this page.

(s '1

Options r5_<|

Project | Walidate | Editars | General | Dwner 1d Image| Brawzer |F'eu:up|eD:u:|e

Enter the baze URI to be used by the Browser to locate the Application.
Example: http:/flocalhost/pepdped

| http: //localhost/pepfpsd

Enter the node name to be used:

IJze default local node

] l [ Cancel

To configure browser options:
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Select Tools > Options and click the Browser tab.

2. Enter the base URI or use the default setting.

This value is the URI of the node that hosts the portal.
Set the node name to be used with the base URI.

The Use default local node check box is selected by default. Deselecting this check box enables the
Select button, which allows you to set the node name in the Select Node dialog box.

The Select Node dialog box displays the list of available nodes by project. You can search for the
appropriate node by clicking the Select button.

Building and Maintaining Data

This section discusses how to:

Build and maintain data.

Create SQL tables.

Building and Maintaining Data

You must keep underlying database definitions synchronized with PeopleSoft definitions. Therefore, from
PeopleSoft Application Designer, you must:

Submit SQL Alter and Create commands for all types of database definitions.
Manage the database index.
Manage the table space.

Manage the DDL model for tables, indexes, and table spaces.

Creating SQL Tables

To access data, you must create a SQL table and then store data in the fields and records. The process of
running the SQL to synchronize the database with records, indexes, and DDL is called the Build process.

The Build feature processes definitions at these levels:

Current record.

Selected records in the project workspace.

All records in the project.

Related Links
Understanding Data Administration and the Build Process
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Using PeopleSoft Application Designer Command Line
Parameters
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PeopleSoft Application Designer offers a variety of command line parameters that you can use to control
the database to which it connects. By using these parameters, you can automatically navigate to the part of
the system that you need.

Use the values from the following tables to specify certain parameters.

Syntax

The following command line syntax applies to all actions identified in this topic:
PSIDE [-parameter value [-parameter value . . .]]

You can include as many or as few parameters as you need.

Each parameter starts with a hyphen (-) or a forward slash (/). The value for each parameter follows the
hyphen or slash, separated by zero or more spaces. In general, the value does not need to have quotation
marks around it, even if it has internal spaces: the system treats all text following the parameter as part of
the value, up to the next parameter or the end of the command line.

Note: You must enclose a value in quotation marks only when it includes a hyphen or forward slash, or
to include leading or trailing spaces. If the value itself includes a quotation mark character, precede the
double quote with a backslash (\).

Important! Application Designer command line parameters are used extensively during upgrade and
update procedures run through Change Assistant and PeopleSoft Update Manager. As such, the use of
these options is documented primarily in the PeopleTools: Lifecycle Management Guide.

Related Links
“Using the PeopleSoft Data Mover Command-Line Interface” (Lifecycle Management Guide)

“Understanding PeopleSoft Application Designer Command Line Parameters” (Lifecycle Management
Guide)
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Understanding Projects

While not one of the eight steps of application development, using projects is an efficient way to organize
your definitions as you develop and configure your application. A project keeps track of all definition
types as a simple list of definition names; the definitions are not stored in the project. Development
definitions exist outside of the project in your PeopleSoft database.

You are not required to use projects in PeopleSoft Application Designer; and you can create and edit
individual definitions without associating them with a project. However, using projects can help you:

* Organize related definitions.

* Understand relationships among definitions.
* Coordinate the work of several developers.
*  Streamline upgrade tasks.

* Search for fields or records.

* Access related definitions easily.

Viewing Projects

On the left-hand side of your screen, the project workspace displays one project at a time and all of its
definitions, making them easily accessible for opening and editing. The project workspace includes two
views representing the collection of definitions in the project: Development and Upgrade. Switch between
the views by selecting the folder tabs at the bottom of the project workspace.

This section discusses how to:
*  Access project definitions.

* Use the upgrade view.

Accessing Project Definitions

In the Development view, the project folder contains a folder for each definition type included in

the project. To open folders and view related definitions, click the expand (+) button. Access project
definitions by double-clicking the definition. This example shows the Development view in the project
workspace:
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This example illustrates the fields and controls on the Example of the Development view in the project
workspace. You can find definitions for the fields and controls later on this page.

571 QE&S2_10511
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+)-{_7] Fields
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+-{_7] Pages
=45 Records
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k3 QE_ORG_IM_SRCH
k3 OF_ORG_MODE
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& QE_OCHART_MNODEID
& QE_ORG_IM
k3 QE_ORG_SCH_DRY
k=d QF_ORG_SCHEMA
k=4 QF_ORG_TNODE_DR

7

¥ [

%I Development |§% Uporade

The definitions are organized by definition type and appear in a project tree. The project tree enables you
to see all definitions associated with the project and their connection by showing the definitions in an
hierarchical format. By expanding definitions that have nested levels, such as records, you can see the
field definitions included in that record.

Using the Upgrade View

82

The Upgrade view helps to streamline the migration of definitions—such as records, pages, or
PeopleCode—from one PeopleSoft database to another. It displays all of the definitions available for
upgrade and the attributes related to the upgrade process. When you double-click a definition type in
the Upgrade view, an upgrade definition window appears in the definition workspace, displaying the
definitions of that type that are available for upgrade and the associated upgrade options. This example
shows the Upgrade view in the project workspace:
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This example illustrates the fields and controls on the Example of the Upgrade view in the project
workspace. You can find definitions for the fields and controls later on this page.
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The Upgrade view is important when you move changes into production and when you upgrade to new
PeopleSoft releases. Definitions in development projects and upgrade projects are interchangeable,
meaning that users can use the Upgrade view to copy or compare components that were developed in
PeopleSoft Application Designer.

Related Links
“Understanding a PeopleSoft Upgrade” (Lifecycle Management Guide)

Creating and Saving Projects

This section discusses how to:
* Create new projects.

* Save projects.

Note: Changes that you make to a definition in a project are also reflected outside the project. Before you
change a definition in a project, be aware of how it might affect other definitions outside the project. For
example, when you rename or delete a field, you do so globally. Although you can enter a project name
as selection criteria in certain PeopleSoft Application Designer dialog boxes (such as Open, Rename, and
Delete), this is just to narrow the list of definitions returned in the selection list.

Creating New Projects

When you start PeopleSoft Application Designer, an empty project titled Untitled always appears,
whether you use the project or not. Unlike other definitions, only one project can be open at a time.
Although you are encouraged to develop in projects, you can hide the project workspace window and
ignore the project entirely.

To create a new project:
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1. Select File > New.

2. Highlight Project as the new definition type to create and click OK.

Note: Another way to create a new project is to open an existing project, select File > Save Project As
and then enter a new name for the project. The system copies all of the existing definitions in the project.

See Saving Definitions.

To open an existing project, follow the same procedure as you would for any other definition type.

See Opening Definitions.

Saving Projects

When you save an entire project, you use a different command then what you use to save other types of
definitions.

To save a project, select File > Save Project. You can also select File > Save Project As to save the
project with a new name. Selecting File > Save Project As is a good way to make a copy of a project
because the original project still exists under the original name.

The Save toolbar button saves whichever definition is active in the definition workspace, but you cannot
use it to save an entire project.

Setting Project Properties

84

Use the Project Properties dialog box to enter information about a project. Access Project Properties from
the File menu.
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This example illustrates the fields and controls on the Project Properties dialog box. You can find

definitions for the fields and controls later on this page.

r

Project Properties
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=

Dezcription:

Comments:

Dwner 1D

Laszt Updated
Drate/Tirme:

By Uzer:

PPLTLSE5
|F'ED|:|IET oolz 8.50 Project
PeopleT oolz 8.50 Project
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Izer:
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Cancel

Working With Projects

On the General tab, enter a description of the project and any additional comments you might want others

to be aware of when using the project. Select the Change Project check box only if you are creating a

change project to be used with the Change Packager. Selecting this option enables the Update IDs and the

Pre-Requisites tabs, which also are used only with the Change Packager.
See “Understanding Change Packages” (Change Assistant and Update Manager).

Select the appropriate Owner ID for the project. The Owner ID allows for a way to identify which
definitions are owned by which PeopleSoft applications, such as PeopleSoft General Ledger, Accounts

Receivables, and so on. The values in the drop-down list box are translate table values associated with the
OBJECTOWNERID field.

Inserting Definitions Into Projects

You can add definitions to a project by selecting Definitions into Project from the Insert menu.

This section discusses how to:

* Insert individual definitions into a project.
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This example illustrates the fields and controls on the Insert into Project dialog box. You can find

Insert a group of definitions into a project.

definitions for the fields and controls later on this page.
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Select Al
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4 definition[z] found

Inserting Individual Definitions into a Project

To insert individual definitions into a project:

1.

Open the definition that you want to insert into the project.

Make sure that the definition is the active definition in the definition workspace.

Select Insert > Current Definition into Project.

The system adds the definition to whichever project is currently open.

Inserting a Group of Definitions into a Project

To insert a group of definitions into a project:

L.

Select Insert > Definitions into Project.

The Insert into Project dialog box appears.

2. Select the type of definition to insert from the Definition drop-down list box.
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To see all available definitions of one type, including upgrade-only definition types, click the Insert
button or press Enter.

3. (Optional) Enter the selection criteria.

Field or Control Description

Name Enter the definition name or a partial field name and press
ENTER.

Type Narrow your search by selecting a specific definition type,

such as View for a record definition.

which the definition is used.

Owner ID Narrow your search further by selecting an application with

4. Select the definitions to insert.

To select multiple definitions, hold down either the Shift key or the Ctrl key while clicking the
appropriate definitions.

(Optional) Specify which related definitions to insert.

To insert related definitions, specify them in the list of related definitions. To select multiple related
definitions, hold down either the Shift key or theCtrl key while clicking the appropriate definitions.

Note: After you insert definitions into a project, the upgrade-only definitions appear in the Upgrade
view of the project workspace, not the Development view.

The status bar at the bottom of the Insert into Project dialog box indicates that definitions were
inserted. Additionally, the Results tab on the output window displays the number of definitions
inserted each time you perform an insert.

Removing Definitions From Projects

Removing a definition from a project is different than deleting it from the database. When you remove
a definition from a project, the reference to the definition is removed from the project, but the definition
still exists in the database and thus may be part of another project.

To remove definitions from projects:

1.

In the project workspace, select the definition that you want to remove from the project.

To select multiple items, highlight one or more nodes by using the Ctrl key while clicking the
definitions to remove.

Press the Delete key or right-click to select Remove from Project from the pop-up menu.

This action does not delete the definition; it only removes it from the project.
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Merging Projects

88

You can merge two or more projects by inserting all of the definitions from one project into another.

This example illustrates the fields and controls on the Merge Projects dialog box. You can find definitions
for the fields and controls later on this page.
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To merge projects:

1.

2.

Open the project in which you want to insert another project.
Select File > Merge Projects.
The Merge Projects dialog box appears.

Enter selection criteria.

a. Enter a project name or description (or the beginning characters of either).

b. Click Insert or press the Enter key to display projects that match the selection criteria you

entered.

Select a project to insert into your currently open project.

Double-click the project that you want to insert or highlight the project and click Insert. To select

multiple projects, use the Shift and Ctrl keys.

Click Insert.
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The system inserts all of the selected definitions into the project in one action. After each insert, note
the information in the status bar and on the Results tab in the output window.

Using Change Projects

Use change projects with the Change Packager feature to group definitions that are affected by PeopleSoft
application updates. Combined with the PeopleSoft Change Assistant, the Change Packager feature
significantly reduces the complexity and time required to apply PeopleSoft application updates.

When you create a change project, you must set the appropriate update IDs and prerequisites.

See “Creating a Change Project” (Change Assistant and Update Manager).

Setting Project Options

Set processing options for all project operations in the Project Options dialog box:
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This example illustrates the fields and controls on the Project options dialog box. You can find definitions
for the fields and controls later on this page.

Dptions -

Fraject |"Jalidate | E ditors | General | Ohwner Id | Image | Browzer |

Imzert Definition into Project
() when definition iz opened
(@) ‘When definition iz modified and saved, or deleted

() Manually
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(® Do not inzert related definitions with current definition

() Prompt user to pick related definitions to ingert

[ ] Reload last project at startup
[ ] 5how definitions in project
[ Prompt for properties when definition is saved

[ Suppress PeopleCode compile success messages

k. | | Cancel

To set project options:
1. Select Tools > Options.
The Options dialog box appears.
2. Select the Project tab in the Options dialog box.

Define when and how definitions are added to the project and how the project appears in the project

workspace.
Field or Control Description
When definition is opened Automatically inserts any definition that you open into the
current project.
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Field or Control

Description

When definition is modified and saved, or deleted

Automatically inserts any definition that you save or delete
into the current project.

Manually

Does not automatically insert any definition into the current
project. This value is the default option. Use the Insert menu
bar to insert a definition into the project.

Do not insert related definitions with current definition

Does not prompt you to include related definitions. Inserts
only the specified definition, not related definitions.

Prompt user to pick related definitions to insert

After you select Insert > Current Definition into
Project a dialog box appears, prompting you to pick which
related definitions to insert.

Reload last project at startup

When starting PeopleSoft Application Designer, the
project that was last opened in the previous session opens
automatically.

Show definitions in project

Displays a black mark next to icons for definitions that are
explicitly in a project (Development view) to indicate that
they are in the project. Attribute definitions, which are not
explicitly part of the project, are not marked.

Prompt for properties when definition is saved

Prompts you with a definition properties dialog box before
you can save the definition.

Suppress PeopleCode compile success messages

Suppress the messages for successful PeopleCode program
compiles and compile warnings displayed on the Validate
tab if you are importing a project and have selected the
option: Compile PeopleCode after import.

Only errors will be displayed if selected.

See “Copying Projects” (Lifecycle Management Guide).

Validating Projects

Using the Validate Project option ensures the integrity of a project, checking that the definitions in a
project are valid and present. While it is good practice to perform validation on a regular basis, it is
especially important to do before and after migrating a project to other databases during development,
upgrades, or updates. Results of the validation check appear in the Validate tab in the output window.

To validate a project:
1. Close all active component definitions in the definition workspace.

Otherwise, the validation occurs in the component, rather than the project.
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2. Select Tools > Options.

3. Select the Validate tab in the Options dialog box.
4. Select Validate project integrity.

5. Click OK.

6. Select Tools > Validate Project.

7. Review the results in the Validate tab in the output window.

Chapter 3

This example illustrates the results displayed in the log file generated by the validate project option.

| 2048239022 _RPT IT.log - Notepad

= | B i

File Edit Format Yiew Help

validate Project Integrity
03/28/14 06:55:29 B
Project Name - IT

PeopleTools Release 8.54

.

m

Be?iﬂ validate Project Integrity
Delete Invalid Definitions - No

Invalid Records: ASSET_ACQ _SKU
Invalid Pages:
Invalid Pages:
Invalid Components:
Invalid Components:
Invalid Components:
Invalid Components:
Invalid Components:
Invalid Components:
Invalid Components:

UT_IT_HRDWR_CACHE

UT_IT_PRG5_5TG

IT_FIN_STAT_RUN.GBEL

IT_SEARCH_TEST_01. GBL

IT_SEARCH_TEST_02.GBL

IT_SFTWR_PEND_OLD. GBEL

IT_SFTWR_RENEW_OLD. GBEL

UT_IT_DISCO. GBEL

UT_IT_PRG5_S5TG. GEL

IT_ASS5ET_LOG. BUSINESS_UNIT. SearchInit: FAM
IT_ASSET_LOG. BUSINESS_UNIT. Searcnsave: FAM

Invalild Record PeopleCode:

Invalid Record PeopleCode:

Invalid Record PeopleCode: IT_FIN_STAT_RUN.OPRID.FieldDefault:

Invalid rRecord PeopleCode: IT_FIN_STAT_RUN.OPRID.RoOwWINit:

Invalid Record PeopleCode: TEST_ASSET_GRFP.RUN_PB.FieldChange:

Invalid Record PeopleCode: UT_PAGES_WKO.GUID.FieldFormula:

Invalid SQL: AM_LEASE_LIB300000 sStep0l 5.1

Invalid SQL: AM_LEASE_LIB300000 sStep03 D.1

Invalid SQL: AM_LEASE_LIBLEASE Step02 D.1

Invalid SQL: ASSET_ACQ _SKU. 2

Invalid sQL: IT_AGING_LIEBE00000 sStepll 5.1

Invalid sqL: IT_DEPT_EU.2 i

IT_FIN_STAT_RUN.ASOFDATE. SaveEdit:

4|

T

Note: For PeopleCode, if the associated definition has an owner ID specified, the system displays the
owner ID at the end of the entry, as in :FAM.

Note: The Validate WSRP compliance option applies to projects that contain PeopleSoft content
intended for WSRP production.

See “Validating WSRP Compliance” (Portal Technology).
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Setting System IDs

System ID functionality simplifies system ID maintenance for developers, used mainly for deprecated
mobile application technology.

You can set the system ID for an overall project or for the current record definition in the project
workspace.

To set system IDs for a project:
1. Open the project.
2. Select Build > Set System IDs for Project

The Build Progress dialog box appears, displaying the progress of the command for the number of
objects affected by this command.

Related Links
“Setting Data Field Length Checking” (Global Technology)
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Understanding Field Definitions

Fields are the basic building blocks in your PeopleSoft system; in database terms, they represent columns
in a table or view. Field definitions are stand-alone development definitions, defined in PeopleSoft
Application Designer, and can be shared across multiple record definitions. Changes to field properties
affect all records that include that field.

Each field definition includes attributes, such as data type, field name, long name, short name, field
length, and various formatting values.

Fields in Record Definitions

By grouping fields that share a common theme, you build a record definition. For example, a department
table (record definition) might include a department ID field, department name field, location field, and so
on.

For each field definition that you add to a record definition, you define additional characteristics, called
record field properties, that are specific to the way the field is used in that particular record. Record field
properties are not shared with other records in which the field is used.

Creating New Field Definitions

This section lists prerequisites and discusses how to:
* Create a new field definition.

* Specify attributes for a new field definition.

» Specify Character field attributes.

* Specify Long Character field attributes.

* Specify Number field attributes.

» Specify Date field attributes.

* Specify Time field attributes.

* Specify Datetime field attributes.

» Specify Image field attributes.

*  Specify ImageReference field attributes.
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Work with additional Oracle data type mappings.

Work with additional Microsoft SQL Server 2005 data type mappings

Prerequisite

You should be familiar with the general terminology and functions of PeopleSoft Application Designer.

Creating a New Field Definition

96

To create a new field definition:

L.

Click the New button on the PeopleSoft Application Designer toolbar.
The New dialog box appears.

Select Field.

Click OK.

A new character field opens in the definition workspace area.

Select one of the following field types from the Field Type drop-down list box.

Note: Make sure you name your fields according to accepted naming conventions.

See Saving Definitions.

Field or Control Description
Character (Char) Alphanumeric field of fixed length.
Long Character (Long) Alphanumeric field of variable length used for textual

entries, such as comments or descriptions.

Number (Nbr) Positive numeric field of fixed length for which decimals are
allowed.
Signed Number (Sign) Positive or negative numeric field of fixed length for which

decimals are allowed.

Date (Date) Date field of constant length. The system edits dates and
prohibits incorrect ones, such as day 42 or month 20. Date
fields always store a four-digit year.

Time (Time) Time field of a constant length. Built-in edits prohibit
impossible times, such as hour 26, minute 70, or second 94.
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Field or Control Description

Datetime (DtTm) Date and time field of constant length. Built-in edits prohibit
impossible dates and times, as defined in the individual date
and time fields. Datetime fields always store a four-digit

year.
Image (Img) Image field to store images in a user-defined format, such as
JPG or GIF.
ImageReference (Iref) Field in which to change an image dynamically at runtime

using PeopleCode.

Attachment (Att) Field that maps to a BLOB database type to hold the
contents of a file attachment. However, you should use the
existing field, FILE _DATA, if you need a BLOB column.
For attachments, use the subrecord ATTACH_DETAIL,
which contains FILE DATA.

After you select a field type, a field definition window appears in the definition workspace. Use the
field definition window to specify attributes to complete your new field definition.

Specifying Attributes for a New Field Definition
Access the field definition window for a new field definition.

All field types share the following property settings.

Note: Multiple views of this dialog box are available, depending on which field type you select. Fields
that are common to all views are documented first.

Field or Control Description

Label ID Enter a unique identifier for the field that is less than 18
characters, without spaces, and in uppercase. Make this the
default label by selecting the Def check box in the last column;
otherwise, the first label is the default. You can set only one
field label as the default.

Note: You can specify multiple labels for one field and change
them at runtime using PeopleCode.

Label IDs must contain alphanumeric characters only and
cannot consist entirely of spaces.

See Using Multiple Labels.
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Field or Control

Description

Long Name

Enter up to 30 characters. The name that you enter here
appears as the RFT Long option for a page field. This label is
also used for the tool tip, or hover text, for links at runtime if it
is different from the assigned display value of the link.

Note: Do not use the \ (backslash) character in the long name
of cubes and members. Unexpected behavior might occur.

Short Name

Enter up to 15 characters as an alternate name to use on pages
and reports if you have insufficient space to display the long
name. If you leave this field blank, the system automatically
copies the first 15 characters of the long name into this field.
The name that you enter here appears as the RFT Short option
for a page field.

Note: If you name the field the same as the default label ID,
you can identify it more easily when using PeopleCode.

Note: Do not use the \ (backslash) character in the short name
of cubes and members. Unexpected behavior might occur.

Def (default)

When you enter the first label ID, the system automatically
selects the Def check box. The system uses this default field if
you have multiple labels. You can have only one default field.

Not Used

This check box is always read-only in the field definition
properties dialog box. You can change its value using
PeopleCode, causing the field to be:

»  Skipped as part of the unique index.

*  Exposed to PeopleCode for read and write operations.
* Ignored in Query.

» Ignored in PS/nVision.

*  Unavailable to users in search pages or list boxes if it is a
search key or list box item.

See “SetDBFieldNotUsed” (PeopleCode Language
Reference).

Chart Field

This field is read-only in the field definition properties dialog
box. It is used for character fields and by financial applications
to specify a usage pattern. You can change the value using
PeopleCode.
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Field or Control

Description

Encrypt

Select this option to encrypt the field using Oracle Transparent
Data Encryption (TDE).

Note: The Encrypt option is disabled for field types that
do not support encryption, for database platforms other than
Oracle, as well as for Oracle database versions that do not
support TDE.

See “Encrypting Fields” (Data Management).

Specifying Character Field Attributes

Use character fields for names, codes, and any fields with letter values. Also use them for numbers for
which you want to contain formatting attributes and the data itself. Examples of such fields are those

in which you enter telephone numbers and zip or postal codes. You cannot use character fields for
calculations. You can enter decimal numbers in character fields, but you cannot use them mathematically

until you convert them back to numeric fields.

You can specify character field attributes at design time, and you can access most of them at runtime with

PeopleCode.

Field or Control

Description

Field Length

Enter a whole number between 1 and 254 for the length of the
field.
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Field or Control

Description

Format Type

Select one of the following values:

Uppercase: Converts the field value to uppercase and
signifies that no other formatting options apply to this
field. Use this option for code values, such as department
ID, for which it does not matter whether the user enters
the value in uppercase or lowercase. Uppercase is the
default format.

Mixedcase: Stores uppercase and lowercase characters

as entered. Use this option for fields that contain textual
data, such as a department or company division name. For
example, Accounting - Receivables is more readable than
ACCOUNTING - RECEIVABLES.

Numbers Only: Forces entries to be numeric, which is
useful for enforcing numeric values without redefining
the field as a number field. This option automatically
populates fields with leading zeros. For example, if the
user enters / in a three-digit field, the system changes this
value to 001.

SSN: Formats the entry in U.S. Social Security Number
format (999-99-9999). Define the field length as 9, even
though the display length is 11. The system automatically
adds dashes when formatting the field for display, but the
number is stored in the database without the dashes.

SIN: Formats the entry in Canadian Social Insurance
Number format (999-999-999) and performs the standard
check-digit verification for SIN. Define the field length
as 9, even though the display length is 11. The system
automatically adds dashes when formatting the field for
display, but the number is stored in the database without
the dashes.

Raw Binary: Allows character fields containing
embedded null values, such as encrypted values.

Name: Indicates that the field entry uses the PeopleSoft
standard name convention:

[Lastname] [Suffix], [Prefix] [First=>
name] [Middle name/Initial]

The entry can contain alphanumeric characters, spaces,
periods, hyphens, and apostrophes. Uppercase and
lowercase characters are preserved as entered, that is,
mixed case formatting is used automatically.

Important! While a space is a valid character, it is not
allowed immediately after the comma separating the last
name from the first name.

Valid entries might include:

¢ O’Brien,Michael

¢ Jones IV, James
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Field or Control

Description
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e Phillips MD,Deanna Lynn
*  Reynolds Jr.,Dr. John Q
*  Phipps-Scott,Ms. Adrienne

¢ Knauft,Glinter

Note: For names that include Chinese, Japanese,
or Korean (CJK) ideographic characters, different
standard name conventions apply. See “Using CJK
Ideographic Characters in Name Character Fields”
(Global Technology).

*  Postal Code North America: Formats the entry to U.S. zip
code format or Canadian postal code format. Canadian
postal codes are edited to ensure that alphabetical and
numeric characters are entered in the correct positions.

The following entry formats apply. Stored formats appear
in parentheses following the entry format:

* 99999 (99999)
*99999-9999 (99999-9999)
* 999999999 (99999-9999)
* A9A9A9 (A9A 9A9)
* A9A 9A9 (A9A 9A9)

*  Postal Code International: Allows the entry of
international postal codes. You must enter at least 7 digits.
If you enter 9 digits, the system assumes that the value
is a U.S. zip code; if the entry is in A9A9A9 format, the
system assumes that the value is a Canadian postal code.
The system formats the value accordingly. For all other
entries, no formatting is applied.

*  Phone Num North America (phone number North
America): Formats the entry in North American telephone

number format.

The following entry formats apply. Stored formats appear
in parentheses following the entry format:

* 9999999 (999-9999)
*999-9999 (999-9999)
* 9999999999 (999/999-9999)
*999/999-9999 (999/999-9999)
*  Phone Number International: Allows the entry of

international telephone numbers. If you enter 7 or 10
digits (and no other characters), the system assumes that
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Field or Control Description

the value is a North American phone number and formats
it accordingly. For all other entries, no formatting is
applied.

*  Custom: If you select this value, the Family Name and
Display Name fields become available for entry. These
selections enable you to apply additional formatting
attributes that affect how the field appears on a page.

Specifying Long Character Field Attributes
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Depending on your database environment, the maximum length of a long character field ranges from
several thousand characters to 32,767 characters (64,000 bytes). Using a long character field instead of a
regular character field enables more information to be added, and the user can insert a tab at runtime by
pressing Ctrl+Tab.

The maximum Large Object (LOB) size allowed by PeopleTools is 50 MB.

Note: For Db2 for z/OS, the maximum Large Object (LOB) size is approximately 32700 KB, depending
on the page size (as determined by the Buffer Pool) and the internal Db2 lengths of the rest of the
columns in the row.
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Field or Control

Description

Maximum Length

To control the length of a long character field, enter the
maximum number of bytes that you want the system to

write to this field. If you do not specify a maximum length,

or specify 0 (zero), you can enter an unlimited number of
characters, depending on the capacity of your database system.

When working with fields, be aware that your chosen database
system limits the amount of data contained in a field. For
Oracle the field size is truncated to 1333 characters. Consider
this limitation when choosing to use fields of a Long Character
data type.

For Oracle: If the maximum length of a long field is less
than 4001 bytes, the field can be stored more efficiently

as a VARCHAR2(4000). To support the PeopleSoft

Unicode implementation on the Oracle platform, we defined
long columns with a specified length of 1330 or less as
VARCHAR? columns. If the length specified was greater than
1330, then the column was generated as a long VARCHAR or
long raw, depending on the setting of the Raw Binary check
box. This setting allows for the maximum possible usage of

a tripled VARCHAR? character length for Unicode-defined
databases.

For Db2 for z/OS: Character fields defined with a length
specification greater than 254 are automatically defined
as LONG VARCHAR in EBCDIC databases and LONG
VARGRAPHIC in Unicode databases.

Note: For all supported database platforms, it is more efficient
to define a reasonable length for long character fields than

to simply use 0. Specifying 0 forces PeopleTools to define
LOBs automatically for those databases for which LOBs are
supported. Due to potential performance implications, LOBs
should not be used indiscriminately.

Raw Binary

Select to store data that is not converted when moving data
between different systems. Raw binary is intended for binary
data and byte strings. For example, raw binary can store
graphics, sound, documents, and arrays of binary data.

Specifying Number Field Attributes

When you create a new field, two field types are available for numbers:

¢ Number fields

* Signed number fields

Both field types are fixed in field length and allow the entry of positive numbers. Only signed numbers,
however, allow the entry of negative numbers. Otherwise, both number field types are the same.
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Unlike character fields, a number field can contain decimals but does not contain special formatting, such
as the formatting for telephone numbers. Use number fields for calculations. If you use number fields for
codes, you sacrifice flexibility to change your coding structure to alphanumeric in the future.

This example illustrates the fields and controls on the Number Field type. You can find definitions for the
fields and controls later on this page.

Field Type: |Number

Integer Positions: |3

Field Labels

W

| Long Hame

H Label ID

[]Signed

Decimal Positions: |0

Short HName Def

Field or Control

Description

Integer Positions

Specify the number of integer positions to the left of the
decimal. If the number contains only decimal positions, leave
this field blank.

Decimal Positions

Specify the number of decimal positions to the right of the
decimal. If a number contains only integer positions, leave this
field blank. In calculations, the system rounds up the result to
the number of decimal positions defined here.

Note: Number fields cannot exceed 31 positions. Therefore,
the sum of integer and decimal positions cannot exceed 31.
The field length notation differs between PeopleSoft
Application Designer and SQL. If you specify a field length
of 8 integer positions and 3 decimal positions in PeopleSoft
Application Designer, SQL processes that as a length notation
of 11.3.

SQL describes field length in terms of precision and scale.
Precision is the total number of integer and decimal positions.
Scale is the number of decimal positions. Thus, 11.3 means

8 integer positions and 3 decimal positions; 11.0 means 11
integer positions and 0 decimal positions.

When you enter 0 in the Decimal Positions field and enter 5
or 10 in the Integer Positions field, the RawBinary format
option appears. The RawBinary format converts a number
field value to a full-length 16- or 32-bit integer. See the
example in the table that follows.

Signed

Select this check box for a field that is used for arithmetic
calculations that might contain a negative value.

This table shows how the integer position affects the RawBinary storage format:
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Integer Position Maximum Value Number Stored As
5 65535 16-bit integer
10 4294967295 32-bit integer

Specifying Date Field Attributes

Date fields contain calendar dates. A date field has a field length of 10 and is maintained by the system.
The default format of a date field is defined by the database and can be overridden by your browser

settings.
Field or Control Description
Default to 2000 if year less than or equal to Specify the last two digits of a year, which is typically what

users enter in a date field. If you enter 50, the default century

becomes 2000 when someone enters 0 through 50 as the year

in a date field. If someone enters a number between 5/ and 99
in a date field, the default century becomes 1900. The default

value is 50.

Note: When working with date and time fields on pages and search pages, carefully consider search
criteria. Assume the date, time, and time zone fields are separate with the condition that the time is time
zone-controlled by the time zone field and the time is associated with the date field. In this case, you need
to provide date, time and time zone on the search page if any one of those search criteria is required.

Specifying Time Field Attributes

Time fields are fixed-length fields (15 positions, format of HH:MI:SS.999999) that contain the time of
day. The maximum time precision varies, depending on your database.

Field or Control Description

Time Formatting Specify the formatting for this field. HH represents hours,
MI represents minutes, SS represents seconds, and 999999
represents microseconds.

Note: You can use %CLIENTDATE as the default constant for the Time field. %CLIENTDATE adjusts
the date as appropriate to the time zone of the browser.

Related Links
“%ClientDate” (PeopleCode Language Reference)
“%Date” (PeopleCode Language Reference)
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Specifying Datetime Field Attributes

The Datetime field is a fixed-length field (26 positions, format of YYYY-MM-DD-HH-MI-SS.999999)
that holds dates and times. The maximum date and time precision depends on your database.

Note: You can use %CLIENTDATE as the default constant for the Datetime field. %CLIENTDATE
adjusts the date as appropriate to the time zone of the browser.

Related Links
“%ClientDate” (PeopleCode Language Reference)
“%Date” (PeopleCode Language Reference)

Specifying Image Field Attributes
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Use Image fields to store application data that takes the form of images. Image fields are functionally
no different from any other type of field. Just as end-users employ character fields to store names and
addresses, they can employ image fields to keep track of all types of digital pictures. This field enables
you to store pictures of assets, company logos (in SQL tables), or scanned images of employees (as part
of their personal data rows).

Field or Control Description

Maximum Length Specify the maximum number of bytes available to store an
image. If you do not specify a maximum length, the maximum
length is determined by your database platform. If a user
attempts to cut and paste an image that is larger than the
maximum length or database capacity, an error message
appears.

The following databases apply these maximums:

*  Oracle (2 gigabytes).

*  Db2 for z/OS: Approximately 32700 kilobytes, depending
on the page size, (as determined by the Buffer Pool) and
the internal Db2 lengths of the rest of the columns in the

Trow.

*  Microsoft SQL Server (2 gigabytes).

Image Format Select an image format. The format specified on the field
definition restricts valid images to that type only.

Image fields support BMP, CUT, DIB, GIF, EPS, JPG, PCT,
PCX, PNG, RLE, TGA, and SVG formats. At runtime

using the PeopleCode “Insertlmage” (PeopleCode Language
Reference) function, users can upload BMP, DIB, JPG, PNG,
and SVG images to the database.

Note: For the record that contains an image field, the record must have at least one key if the image field
is to be displayed on a page. This is requirement so that unique image file names can be generated.
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Note: When using images of the SVG format, be sure that the XML declaration of the SVG image is of
an expected format. For example:

<?xml version="1.0" encoding="utf-8"7?7>

or,

<?xml version="1.0" standalone="no"?>

If the XML declaration is not formatted correctly, this can result in errors, such as errors when creating
the definition, not being able to view height and width in Application Designer, not being able to view the
image at runtime, and so on.

Specifying ImageReference Field Attributes

Use the ImageReference ficld to store static images that you can change at runtime using PeopleCode.
By associating image definitions with an ImageReference field on a page, you can display images
dynamically. For example, to have different images appear on an employee profile depending on the
status of the employee’s current review, use the ImageReference field to reference the current review
field and display the appropriate image.

Working With Additional Oracle Data Type Mappings

If your site has upgraded to a PeopleSoft 9.x application and performed the appropriate conversion
process during the application upgrade, different data type mappings exist between PeopleSoft field types
and the underlying Oracle system.

See The upgrade documentation and release notes for your release for information about the conversion
process.

The following table describes how the PeopleSoft field types map to the underlying Oracle data types:

PeopleSoft Field Type Pre-Conversion Oracle Data Type | Post-Conversion Oracle Data Type
Mapping Mapping
Character ANSI: VARCHAR2(n) ANSI: VARCHAR2(n)

Unicode:VARCHAR2(n*3)

Unicode: VARCHAR2(n)

Note: For Unicode the VARCHAR2
column is interpreted as the number
of Unicode characters due to init.
ora parameter NLS LENGTH
SEMANTICS being set to "CHAR".
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PeopleSoft Field Type

Pre-Conversion Oracle Data Type
Mapping

Post-Conversion Oracle Data Type
Mapping

Long Character

If 1<n <2000
ANSI: VARCHAR2

Unicode:VARCHAR2(n*3) CHECK
(Length <field name>) < n)

If n =0 orn>2000
ANSI: LONG VARCHAR

Unicode :LONG VARCHAR

ANSI: VARCHAR2(n) when 1 <1 <
4000

CLOB when n=0, or n> 1333

Unicode: VARCHAR?2 (n) when 1 <n <
1333

CLOB when n =0, orn> 1333

Note: For Unicode the VARCHAR2
column is interpreted as the number
of Unicode characters due to init.
ora parameter NLS LENGTH
SEMANTICS being set to "CHAR".

Long Character with Raw Binary
attribute

ANSI: LONG RAW

Unicode: LONG RAW

ANSI: BLOB

Unicode: BLOB

Image ANSI: LONG RAW ANSI: BLOB
Unicode: LONG RAW Unicode: BLOB
Attachment ANSI: LONG RAW ANSI: BLOB
Unicode: LONG RAW Unicode: BLOB
Date DATE DATE
Datetime DATE TIMESTAMP
Time DATE TIMESTAMP

Working With Additional Microsoft SQL Server 2005 Data Type Mappings
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If your site has upgraded to a PeopleSoft 9.x application and performed the appropriate conversion
process during the application upgrade, different data type mappings exist between PeopleSoft field types
and the underlying Microsoft SQL Server 2005 system.

See The upgrade documentation and release notes for your release for information about the conversion

process.

The following table describes how the PeopleSoft field types map to the underlying Microsoft SQL

Server data types:
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PeopleSoft Field Type Pre-Conversion Microsoft SQL Post-Conversion Microsoft SQL
Server Data Type Mapping Server Data Type Mapping
Character ANSI: CHAR ANSI: VARCHAR(n)
Unicode: NCHAR Unicode: NVARCHAR(n)
Long Character ANSI: TEXT ANSI: VARCHAR(MAX)
Unicode: NTEXT Unicode: NVARCHAR(MAX)
Long Character with Raw Binary Image | IMAGE (ANSI and Unicode) VARBINARY(MAX) (ANSI and
Attachment Unicode)

Using Multiple Labels

This section provides an overview of multiple labels and discusses how to:
* Add anew label.
* Delete a label.

¢ Select record field labels.

Understanding Multiple Labels

You can define multiple label pairs for any field. By adding multiple labels to a field definition, you can
expand its usability and create a more intuitive user experience at the same time.

For example, here you see the Date field with multiple labels.
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This example illustrates the fields and controls on the A date field showing multiple field labels. You can
find definitions for the fields and controls later on this page.

=4 DATE (Field) H[=1E3

Field Type: |Date w

Field Labels

Label ID Long HName | Short Name Def

Begin Date

ﬂ [rate of Birth Birthday ]
3 | Date Date
M Firet Dray of Clazzes Clazzesz Begin ]
5 Start Date Starts il
5| El

Default Century

Default to 2000 if yvear less than or equal a0

You could use this field in a student registration application and select the First Day of Classes label. You
could also use this field in an application that tracks employee personal information, but select the Date of

Birth label. In each case, you use the same field definition but you vary the label to reflect what the user
sees and should understand about its context.

The underlying data structure for the field does not change when you change its label. At the database

level, the column name in the table is DATE. You are merely manipulating the label to accommodate the
context in which you use the field.

The system displays multiple labels in alphabetical order and sorted by label ID. You can sort the labels

in a field by double-clicking the column header. The sorting is not saved, but it is helpful for quickly
viewing the labels.

Adding a New Label
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Open the field definition in the definition workspace.

To add a new label, enter the label ID, long name, and short name in the last row. Each label can have
related language labels. After defining the multiple labels, you can select appropriate labels when
designing a record or page. You also can specify different labels in PeopleCode. To add a line feed for
Long Name and Short Name, enter \n (backslash and the letter n). For example, work \n month adds a line
feed between the words work and month.
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When you create multiple labels, the first label ID is the default label . You can change the default label
by selecting the Def check box for a different row. Only one label can be the default.

Note: Each label ID must be unique so that each field definition label can be identified separately, and it
must be entered using uppercase letters with no spaces.

Deleting a Label
Open the field definition in the definition workspace.

To delete a label, right-click a field label row and select Delete Label from the pop-up menu. You cannot
delete labels that are currently in use. To determine where the label is used, select the label and select Find
Definition Reference from the pop-up menu. The results appear in the Find Definition Reference output
window.

Selecting Record Field Labels

Access the Record Field Properties dialog box.
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This example illustrates the fields and controls on the Record Field Properties dialog box. You can find
definitions for the fields and controls later on this page.

Record Field Properties
Use |Edis |

Field Mame:  REVIEWER_ID

—Kenz
V¥ Key
[T Duplicate Order Key
[T &ltemate Search Key
[ Descending Key
[T Search Key

™| Seanch Edi
™ List Bax ltermn
™ From Search Field
[ Thiough Search Field
™| Default Search Field

[T Dizable Advanced
Search Optiohs
[~ &llow Search Events for

Prarmpt Dialogs

<]

— Fecord Field label 1D

== | |ze Default Label == j

— Default Walue

Consztant: I

ar
Fecord Mame: I j
Field Mame: I j

— Default Fage Control
I System Default j

— Budit
[~ Field Add

[ Field Change
[ Field Delete

—Autocomplete Configuration
[ Dizable Autocomplete for this field

™| Enable sutacomplete when used in Search Becord

— Perzizt in Menu Configuration
™| Persiztin Menu

[ Spstemn b aintained
[T sutollpdate

0k, I Cancel

For the record definition, the Record Field label ID drop-down list box is available on the Use tab of the
Record Field Properties dialog box. The drop-down list box displays the label ID, short name, and long
name that you set in the field definition. The default selection is *** Use Default Label ***. The record

field label changes automatically whenever you change the default label in the field definition.

Opening an Existing Field Definition

You can open a field definition in several ways:

* Select File > Open from the menu.
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From this dialog box, you can view all available fields in the database. You can open all fields of a
certain type or from a specific project, or you can open a specific field or set of fields.

Clone an existing definition.

To create a field definition with attributes similar to an existing one:
1. Open an existing field definition.

2. Select File > Save As.

3. Enter a new name and click the OK button.

Open a field from the project workspace.

Double-click a field from the project workspace to open a field definition window in the definition
workspace.

Open a field from the record.

Open an existing record definition. When the record definition window opens, you can:
1. Select a field.

2. Right-click the field.

3. Select View Definition from the pop-up menu.

Viewing Field Properties

You can view field properties in several ways:

While in the field definition workspace, click the Properties button.
Select File > Definition Properties.

While in a record definition:

1. Select the field.

2. Right-click the field name.

3. Select View Field Properties from the pop-up menu.

The General tab in the Field Properties dialog box provides a place for you to enter comments
documenting the purpose of the field definition. The Owner ID drop-down list box enables you to select
a valid owner, as in application project or role. The Last Updated group box contains information—date,
time, and user ID—about the last time that the field definition was modified.
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Note: The Runtime Definition field displays whether the field definition was created as a runtime
definition by the “CreateFieldDefn” (PeopleCode Language Reference) PeopleCode built-in function. A
runtime field definition is not editable in Application Designer. In addition, it cannot be used in design
time definitions (such as records, pages, components, or others) in Application Designer. However, a
runtime field definition can be added to a project definition.

The Translate Values tab is available only for character fields.

Related Links
Using the Translate Table

Changing Field Definitions

This section provides an overview of the effects of changing field definitions and discusses how to:
*  Change field types.

* Rename field definitions.

» Delete field definitions.

¢ Print field definitions.

Understanding the Effects of Changing Field Definitions
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When you develop new record definitions or modify existing ones, you might need to change
characteristics or attributes for a field. If you change attributes in a field definition, the change affects
every occurrence of the field in every record definition. So, before you change basic attributes in a field
definition, consider how it affects all of the record definitions in which the field occurs. If the change is
not appropriate for every occurrence of the field, consider defining a new field instead.

If a change is still needed, you should determine the extent of the change by finding out how many
records are affected. Do this by using the Find Definition References tool. Open the field definition and
select Edit > Find Definition References or right-click and select the option from the pop-up menu. If
you are in a record definition window, another method is to select the field, right-click the field name, and
select Find Definition References - Field from the pop-up menu.

The Find Definition References tab in the Output window displays a list of all projects, record definitions,
page definitions, messages, channels, file layouts, and PeopleCode programs in which the field is used.
Double-click a line of output to open the corresponding definition in the definition workspace.

Note: Changing the name or length of a field definition requires that you modify the underlying SQL
table. Do this either by running the build process and specifying Create Tables or Alter Tables, or by
carrying out an action issued by your system administrator. For example, if you change the length of a
field definition and 30 record definitions contain the same field name, then you must create or alter 30
records.
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Changing Field Types

Change a field type by opening a field and selecting another field type from the drop-down list box.
However, this feature is intended as a design-time change—that is, before your tables are created in the
database. While you can convert some field types, the results vary depending on your database platform.

Note: If you change a field from one type to another, you must rebuild all records containing that field by
running the Alter process. Use Find Definition References to find all instances of the changed field.

See Altering Tables.

Renaming Field Definitions

You can use either the Rename Definition dialog box or the Open Definition dialog box to rename a field
definition.

Using the Rename Definition Dialog Box

To rename a field definition from the Rename Definition dialog box:

1. Select File > Rename to open the Rename Definition dialog box.
2. Select Field as the definition type.

3. Enter the name of the field.

If you are not sure of the name or the correct spelling, use the search criteria fields to locate the field
to rename. The list displays field names that match your search criteria.

4. To rename a field in the list, select the field and click Rename or double-click the field.
The field name becomes available for entry, and you can enter a new name.
5. When you finish typing the new name, press enter or click the Rename button.

The Rename Field dialog box appears. Select the records in which you want the field to be renamed.
The De-select All button toggles to Select All.

6. Click OK.

Using the Open Definition Dialog Box
To rename a field definition from the Open Definition dialog box:
1. Select File > Open to access the Open Definition dialog box.
This dialog box enables you to set up search criteria for locating field names.
2. Select Field as the definition type.

If you have additional information, use the Name field. You can further narrow your search criteria by
selecting a field type or the name of the project that contains the field to delete.

3. Click the Open button or press enter when you have completed your search criteria.

Copyright © 1988, 2023, Oracle and/or its affiliates. 115



Creating Field Definitions Chapter 4

4. You can rename a field in the Open Definition dialog box by selecting the field, right-clicking the
field name, and selecting Rename.

You can also select the field name and click it a second time. The field name becomes available for
entry and you can enter a new name.

5. When you finish typing the new name, press enter or click the Rename button.

Results of Renaming Field Definitions

When you rename a field, the system automatically changes all occurrences of it, including data in tables
with columns named FIELDNAME where the data matches the field being renamed.

The only references that are nof renamed are the text portions of SQL functions, such as SQLExec and
ScrollSelect. If you already used SQL Create to create the underlying tables for the record definitions that
contain the field that you renamed, you must recreate or alter those tables. If the tables contain data that
you want to preserve, use the SQL Alter function to rename the database table fields.

Deleting Field Definitions
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You can use either the Delete Definition dialog box or the Open Definition dialog box to delete a field
definition.

Using the Delete Definition Dialog Box

To delete field definitions by using the Delete Definition dialog box:

1. Select File > Delete to open the Delete Definition dialog box.
Set up search criteria for locating field names.

2. Select Field as the definition type.

3. Ifyou have additional information, use the Name field.

4. Select a field type or the name of the project that contains the field that you want to delete.
This selection further narrows your search criteria.

5. When your search results appear in the output window, delete the field definition by selecting the field
and clicking the Delete button or double-clicking the field name.

Note: You cannot delete a field that is currently used in any records. Before you delete a field definition,
you must first remove it from records in which it appears.

Using the Open Definition Dialog Box
To delete field definitions by using the Open Definition dialog box:
1. Select File > Open to access the Open Definition dialog box.
This dialog box enables you to set up search criteria for locating field names.

2. Select Field as the definition type.
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3. Ifyou have additional information, enter it in the Name field.

4. You can further narrow your search criteria by selecting a field type or the name of the project that
contains the field that you want to delete.

5. When you have completed your search criteria, click Open or press enter.
6. Right-click the field that you want to delete from the list of field names displayed.

7. Select Delete from the pop-up menu.

ng Field Definitions

If you plan to make changes to your field definitions, you should view your field definition before you
proceed. You can view it on your screen or print it to a one-page report that combines information from
several resources. This method can also serve as a paper audit trail to document your database.

To print a field definition, select File > Print from the field definition window (or click the Print button
in the toolbar) to open the Print dialog box, where you specify printing options. You can also print field
definitions from the Open Definition dialog box. On the list resulting from your search, right-click the
name of the field definition that you want to print, and select Print from the pop-up menu to view your
printing options.

Setti

Unde

Unde

Copyright

ng Custom Field Formats

This section provides overviews of custom field formats and format notation and discusses how to:
* Change format families.

» Edit formats.

* Use family options.

e Test formats.

rstanding Custom Field Formats

PeopleTools has formatting provisions at both the field and page levels. The field format specifications
affect internal values that are stored in the database, and the page formats affect the visual presentation of
values.

Several formatting options are available for U.S. Social Security Numbers, Canadian Social Insurance
Numbers, postal codes, telephone numbers, and various currencies, dates, and times. Custom field formats
extend these formatting provisions to support the same types of data in other countries. They also support
other types of formatted information, such as bank codes, credit card numbers, part numbers, or serial
numbers.

rstanding Format Notation

Stored and display formats are defined by strings that contain lexical, literal, and meta characters:
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* Lexical characters delimit character expressions and designate interpretation rules.

» Literal characters represent only themselves.

* Meta characters represent a class of characters.

Use the format symbols in the following tables to create the format notation for your own custom field

formats:

Meta Symbol Description

# Digit placeholder.
If the number has more digits to the right of the decimal point
than there are # symbols to the right in the format, the system
truncates the number to as many decimal places as there are #
symbols to the right.
If the number has more digits to the left of the decimal point
than there are # symbols to the left in the format, the system
displays the extra digits.
If the number has fewer digits to the right of the decimal point
than there are # symbols to the right of the decimal point in the
format, the system adds spaces.
If the number has fewer digits to the left of the decimal point
than # symbols to the left of the decimal point in the format,
the system also adds spaces.
Example format: ### ##
Input: 1234.567 - Matches? Yes - Output: 1234.56

0 (zero) Digit placeholder.
Follows the same rules as for # except that if the number has
fewer digits than there are 0s in the format, the system displays
the extra 0s.
Example format: 000.00
Input: 1.2345 - Matches? Yes - Output: 001.23

(period) Decimal point.

This symbol determines how many digits (0 or #) appear to the
right and left of the decimal point.

If the format contains only # symbols to the left of this
symbol, numbers less than one appear with a decimal point.

This symbol has meaning only in conjunction with the # and 0
symbols.

Example format: ###.##

Input: . 12345 - Matches? Yes - Output: ./2
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Meta Symbol

Description

Required numeric placeholder.

If the number does not have the same number of digits as there
are 9s, the system displays an error message.

Example format: 999
Input: 723 - Matches? Yes - Output: /23

Input: 12 - Matches? No

Matches any alphabetic character: A— Z or a—z.
Example format: AA
Input: Sd - Matches? Yes - Output: Sd

Input: 44 - Matches? No

Matches any alphabetic or numeric value: A—Z, a—z, or 0—9.
Example format: ZZ
Input: 3g - Matches? Yes - Output: 3g

Input: A3C - Matches? No

Matches any character.
Example format: @@@

Input: /q? - Matches? Yes - Output: /g?

Lexical Symbol

Description

Matches zero or more occurrences of this character expression.
Example format: a*b

Input: b - Matches? Yes - Output: b

Input: ab - Matches? Yes - Output: ab

Input: aab - Matches? Yes - Output: aab
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Lexical Symbol

Description

Matches occurrences of this character expression.
Example format: a+b

Input: b - Matches? No

Input: ab - Matches? Yes - Output: ab

Input: aab - Matches? Yes - Output: aab

Denotes a character expression that matches the input
character if the input character is the same as any character in
the list enclosed by square brackets.

If the expression matches, the input character appears. The
system interprets all characters enclosed in square brackets as
literal characters.

Example format: [ab]c

Input: ac - Matches? Yes - Output: ac

Input: be - Matches? Yes - Output: bc

{3

Denotes a character expression that matches the input
character if the input character matches any character in the
list enclosed by curly braces.

If the expression matches, the first character in the list (not the
input character) is copied to output. All characters enclosed in
curly braces are interpreted as literal characters.

Example format: {ab}c

Input: ac - Matches? Yes - Output: ac

Input: bc - Matches? Yes - Output: ac

This expression is optional. It is copied to output only if it
appeared in input.

Example format: a?b
Input: ab - Matches? Yes - Output: ab

Input: b - Matches? Yes - Output: b

This expression is optional. It is copied to output regardless of
whether or not it is matched.

Example format: alb
Input: ab - Matches? Yes - Output: ab

Input: b - Matches? Yes - Output: ab
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Lexical Symbol Description
~ This expression is optional. It is copied to output regardless of
whether or not it is matched.
Example format: a~b
Input: ab - Matches? Yes - Output: b
Input: b - Matches? Yes - Output: b
\ Example format: a\?b
Input: ab - Matches? No
Input: a?b - Matches? Yes - Output: a?b
) Groups expressions.
Example format: (abc)!99
Input: abci2 - Matches? Yes - Output: abcl2
Input: 72 - Matches? Yes - Output: abcl2

Changing Format Families

Custom field formats enable you to create your own format definitions using format notation and apply
them to fields. These formats are organized into format families, which can include one or more unique

formats.

This example illustrates the fields and controls on the Format Families dialog box. You can find
definitions for the fields and controls later on this page.

Format Families

F arnily
CTI_MUMBERS
HUMBERS
UFPPERCASE

Farmats

1
1
1

Description

Mumberz Only
MHumbers Only
| ppercase input

e, ..

Edi...

Delete

Where zed

Test

To change format families:
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1. Select Tools > Miscellaneous Definitions > Field Formats to access the Format Families dialog
box.

The Format Families dialog box lists the defined format families and enables you to edit, delete,
or create new families. You can also determine where each family is used in your applications and
perform tests.

2. To define a new format family, click the New button.
The New Family dialog box appears.
3. Enter a name for your new format family, and click OK.
The Formats dialog box appears.
4. In the Stored group box, enter a name and format.
This information defines how the format family is to be stored in the database and printed in reports.
5. Enter the format notation that you want to use for storing the data in the Format field.

Because a stored format cannot exist alone, a display format is always required. If you are adding

to a family that has existing stored formats, a display name and format pair is optional. PeopleSoft
Application Designer automatically places all of the current display formats in the new stored format.
The display format default is the stored format that you can redefine later.

6. In the Display group box, enter a name for the format.
This information defines how the format family appears online.
7. Enter the format notation that you want to use for displaying the data in the Format field.

8. Click the Add button to add the new format family, and then click OK when you are finished.

Max Display Length

Max Display Length (maximum display length) enables you to override the default length that PeopleSoft
Application Designer uses to determine the length of the edit field in custom format. This setting is useful
when the displayed data is longer than the defined field length. For example, you might store data as 999
(field length in the database is 3 characters), but the display format of the data is 9-9-9 (5 characters).

PeopleSoft Application Designer uses the field length of 3, by default, for the edit field, which is not
long enough to hold the five characters of the reformatted data. By entering 5 in the Max Display Len
(maximum display length) field, the page uses five characters for the edit field without requiring that the
field length in the database be five characters long.

Editing Formats

The Edit Formats dialog box presents a tree where you define the stored and display formats for a family
and all options and attributes. This dialog box enables you to:

* Add, update, and delete stored and display formats.

* Enter a description for the family.

122 Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 4 Creating Field Definitions

* Specify options, such as uppercase and smart punctuation, for the family.
Click OK to save changes.

This example illustrates the fields and controls on the Formats dialog box. You can find definitions for the
fields and controls later on this page.

F armily Farmnily Dptions

(]
M arie: POSTAL_CODE Smart Punctuation:
Description; | Postal Code | Use:

M ax Dizplay Length: EI (0=Ulze field length) Characters: | $-[):
take ppercaze

£3 POSTAL_CODE

=& [CaN]A%4 99
[NORMAL] 494 949 Stored

= &) [Us4] 99399-3933

Marne: | |
[NORM&L] 99939-9999
=8 [U542]99999 Format | | [ agd
[NORMaL] 93939
=& [0THER] @ Display
[NORMaL] @
Mame: | |

Farmat: |

This section discusses how to:

* Add a new stored format.

* Add a new display format to a stored format.
* Update a display format.

¢ Delete stored formats.

Adding a New Stored Format

To add a new stored format:

1. Open the format family to which you want to add a format.
2. Select the format family name.

3. Enter the stored and display names and format notation.

4. Click Add.

The new format appears in the tree below the existing formats.
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Adding a New Display Format to a Stored Format

To add a new display format to a stored format:

1. In the tree, select the stored format name to which you want to add a display format.
2. In the Display group box, enter a new name and format notation.

3. Click the Add button to add the display format.

The new display format appears in the tree, attached to the stored format to which it belongs.

Updating a Display Format
To update a display format:

1. Select the display format in the tree view.

Note: Clicking the Update button applies only to display formats.

2. Select a display format and enter the enabled fields.

3. Click Update to update the display.

Deleting Stored Formats
To delete a stored format:

1. Select the display format.
2. Click the Delete button.

PeopleSoft Application Designer displays a warning message indicating that deleting a display format
might strand stored data. Select Yes to continue with the deletion.

Note: Stored formats cannot be deleted directly. Therefore, all display formats for a specific stored format
must be deleted first to ensure that data is not stranded in the database under an invalid format. When the
last display format is deleted for a stored format, the stored format is automatically deleted.

Using Family Options
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Family options include:
*  Smart punctuation

e Make uppercase

Smart Punctuation

Smart punctuation automatically adds or removes punctuation characters to the data that users enter.
For instance, if you enter a phone number, 8005551212 and press the tab key to exit the entry field, the
system reformats the value as §00-555-1212.
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The system uses the punctuation characters specified in the punctuation list to strip out unwanted input
and to modify the pattern specified before applying the pattern to the data.

Note: Smart punctuation and the standard set of characters are enabled by default.

You can modify the standard set of characters by selecting Custom in the options drop-down list box and
typing another set of punctuation characters to use. Smart punctuation processes the characters defined in
the standard set or custom set as follows:

» The input has all characters in the punctuation set stripped out—similar to ignoring white spaces.
* The pattern has all characters in the punctuation set expanded if they are not found in the input.
To do this, enclose each punctuation character in the punctuation set with "[ punc_char]!".

* The formatter runs on the modified data to apply the modified pattern.

Warning! Use meta characters and lexical characters in the punctuation sets with caution. Step 2 of
the transformation process modifies the format pattern so that PeopleSoft Application Designer might
sometimes convert special characters to literals (when they are inside the left or right brace).

For example:

* Input: (800)555-1212.

* Display pattern: 999-999-9999.

e Punctuation set: ()-.

* Stored pattern: 999999999,

o The "(", )", and "-"are stripped out of the input because they appear in the punctuation set.
Now the input looks as follows: 8005551212.

The display pattern is modified to 999/-7/999/-]/9999 because "-" is in the punctuation set. The
transformed data (8005551212) is matched against the display pattern of 999/-7/999/-719999. The match
1s successful, so the raw data is transformed into 800-555-1212.

Now, the input data has successfully matched the expected display format. The next step is to transform
this data into what we want stored. In this case, the stored format has no dashes, as in 999999999.

The transformed data (8§00-555-1212) is stripped of the smart punctuation characters (§005551212), and
the pattern of the stored format is 999999999. A match is made so that the system stores 8005551212 in
the database.

Finally, the stored data is reformatted back to the display using 8005551212 and the display pattern.
Output to the display is reformatted to §00-555-1212.

Make Uppercase

Custom format fields support mixed case. With uppercase activated, PeopleSoft Application Designer
transforms the data into uppercase when you press the tab key to exit the field.
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Testing Formats

The Test Format dialog box enables you to test a specific format or unformatted path for a family without
having to build a page:

This example illustrates the fields and controls on the Test Format dialog box. You can find definitions for
the fields and controls later on this page.

Test Format

Selected Family

Farily Marne: Stared Farmat Mame: Dizplay Farmat Mane:
POSTAL_CODE | N | | NORMAL v |
Purctuation: Stored Format Pattern: Dizplay Format Pattern:

| |99999-9959 | |aaaaa-9599 |

Transhorm: | Results
Input: | |

&5
=

Field or Control Description
Stored Format Name and Display Format Name Select a stored and display format pair to test.
DB->Display Click this button to process the input field like data from the

database. The system applies the stored format pattern to the
input, and then applies the display format pattern to the result.
The output appears in the Transform field, which is the same
output displayed for a field using this format.

Display->DB Click this button to process the input field like user input from
a page. The system applies the display format pattern to the
input, and then applies the stored format pattern to the result.
The transformed output appears in the Transform field. This
output reflects what is stored in the database if the operation
is successful. On an actual page, when the user presses the
tab key to exit the field, the system calls the DB->Display
function to reformat the user input for the display.

Using the Translate Table

This section provides an overview of the Translate table and discusses how to:
* Add values to the Translate table.
* Change translate values.

¢ Delete translate values.
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¢ Save the Translate table.

Understanding the Translate Table
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The Translate table is a prompt table, similar to an all-purpose data dictionary, that stores values for fields
that do not need individual prompt tables. As a general rule, store field values in the Translate table if the

field meets the following criteria:

» Field type is Character.

e Field length is 1 to 4 characters.

» Field values consist of a relatively small, static set of values that are not maintained by the user.

¢ No other fields relate to this field.

Note: If the only values for a field are Y (yes) and N (no), you do not need to enter them in the Translate
table. The Translate table comes with a field for ¥ and N named PSYESNO. When you select Yes/No
Table Edit, the system automatically points to the PSYESNO field in the Translate table.

Example of When to Use the Translate Table

Consider the relative attributes of a department ID field and a gender field in a company database. In the
following table, Department ID is not a good case for using the Translate table because it requires its own
prompt table. However, the Gender field is a good case for using the Translate table:

Characteristic Department ID Gender
Field type Character. Character.
Field length Longer than 3 characters. 1 character.

Field values

Could be many values, 20 or more.

Two possible values.

Other related fields

Related to other fields, like department

manager.

Not related to other fields.

Requires maintenance

Yes, users might have to add

departments.

No, gender is a static value.

Translate Table Attributes

The system maintains the structure of the Translate table and you supply the data. This table contains the

following fields:
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Field Name Description

FIELDNAME Field name, such as ABSENCE_TYPE.

LANGUAGE_CD Language code.

FIELDVALUE Value for the field.

EFFDT Effective date.

VERSION Internal version number (system-maintained).

EFF_STATUS Status: active or inactive.

XLATLONGNAME Thirty-character description; used as a label on pages and
reports.

XLATSHORTNAME Ten-character description; used as a label on pages and reports.

LASTUPDDTTM Datetime field showing the last time that a field was updated.

LASTUPDOPRID User ID of the user who most recently updated the field.

If you must define more information about a field than the preceding attributes, create a separate prompt
table for the field instead of adding it to the Translate table.

When the user presses the prompt button to prompt for valid values in a field on a page, the system
displays a list of the translate values for a field.

Each value in the Translate table has an effective date, and the date must be earlier than the effective dates
of any rows that reference the value. The translate values delivered by PeopleSoft all have an effective
date of January 1, 1900. Choosing a different value for translate values that you add enables you to
quickly differentiate delivered values from your values.

Note: Null values are not supported as effective dates.

Adding Values to the Translate Table
Access the Add Translate Table Value dialog box.
To add translate values to the Translate table:
1. From a field definition window, select File > Definition Properties.

You can also right-click and select Field Properties, or press Alt+Enter.
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2. From arecord field definition window, right-click the field and select View Translates from the pop-

up menu.

3. Select the Translate Values tab.

The Translate Values dialog box displays existing values for the field and enables you to add, change,
or delete values. In the Last Updated box, you see information—date, time, and user ID—about the

last update for the selected translate value.

4. Click Add to define a new value.

5. Enter the field value, effective date, long name, and short name that your users enter on the page.

Field or Control

Description

Field Value

Enter the translate value for the field. The system
automatically sorts values in ascending order as you enter
them. If you enter three translate values with field values 4,

T and C, they appear in the Translate Values dialog box as
ACT

Effective Date

Enter the date on which you want this value to take effect.
The default value is today’s date. If you want the effective
date to predate all rows on your database, enter 01011900
(January 1, 1900).

Note: The Add button only allows you to add a new,
distinct translate value. To add a different effective date for
the same translate value, select the translate value and use
the Change button. As long as the effective date is changed,
the system saves the modified entry.

Inactive

When a value for a field becomes obsolete, you should
select the Inactive check box rather than deleting the value.
Deactivating a value enables fields in the database that still
contain the value to use the correct long and short names. If
you delete an obsolete code from the Translate table and you
still have records in the database that contain that value, then
you must change all of those values to active values.

Long Name

Enter up to 30 characters.

Short Name

Enter up to 10 characters. If you leave this field blank,
the system automatically copies the first 10 characters of
the long name into this field. Use mixed case to improve
readability.

Note: The recommended character length of translate
short name values is six. You can configure PeopleSoft
Application Designer to alert you if the recommended
length is exceeded.

See Setting PeopleTools Options.
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Changing Translate Values

Sometimes the meaning of a translate value changes, but you still need to retain both values in the
Translate table. For example, suppose that your PROFICIENCY field has a value of £ (extremely high).
You have been in production for five years when upper management decides to change the meaning of the
value to Exceptional as of January 1, 1998.

You can accommodate this type of change by creating a second active entry for the same translate value.
The first value is valid in the time range between the effective dates of January 1, 1990, and December
31, 1997. The second entry is valid from January 1, 1998, onward. You do not want to delete the existing
entry because the database might contain rows that predate January 1, 1997, and contain this value. You
might also maintain the existing definition for historical reporting.

To change an existing translate value, select the value and click Change or double-click the value. The
system displays the Change Translate Table dialog box, in which you can make the necessary changes.

Deleting Translate Values

Use caution when deleting a translate value, unless you are removing an invalid value that was entered by
mistake. To deactivate a value because it is no longer used or its meaning has changed, either change the
long and short names, or change the status to /nactive. To delete the value, select it and click the Delete
button. The system removes the row.

Saving the Translate Table
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After you have made all of your changes to the Translate table, you must save the entire field definition.
The system has no save option specifically for translate values. Click OK from the Field Properties dialog
box, and then save the field definition by clicking the Save button or selecting File > Save.

To save the Translate table, you must be authorized to modify field definitions. A special Translates Only
security access level is available for fields; it allows authorized users to update translate values but not
other field attributes.
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Planning Records, Control Tables, and
Tablesets

Understanding the Planning Process

This topic discusses:

» Table-based systems.

* Normalized relational databases.
* Record definition planning.

» Effective dates.

* Control tables.

e Tablesets.

Table-Based Systems

Planning is the first step in the application development process. As a system designer, you must consider
how to store, retrieve, manipulate, and process data that is stored in the tables in your application
database.

PeopleTools-based applications are table-based systems. A database for a PeopleTools application
contains three major sets of tables:

» System Catalog tables store physical attributes of tables and views, which your database management
system uses to optimize performance.

*  PeopleTools tables contain information that you define using PeopleTools.

* Application Data tables house the actual data that your users enter and access through PeopleSoft
application pages.

This diagram shows PeopleSoft database tables and sample names:
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The following image explains about the different tables in a PeopleSoft database

SYSCOLUMNS
—_—
m Catalog SYSTAEBLES
ables
FPSRECDEFM
——» PSPNLDEFN
pleTools
- PSMENUDEFN
PS_VNDRID
plication ———» PS_EMERGENCY
Tables FS_JOB

Chapter 5

Like a spreadsheet, each of these tables contains columns and rows. Columns define the structure of how
the data is stored. Rows represent the actual data that is stored in the database.

Every time that you create a new definition using PeopleTools, the system inserts rows of data into
various PeopleTools tables. The entries in these tables determine the online processing of the system and
what happens during imports. PeopleSoft maintains the structure of these tables. You maintain data in the
PeopleTools tables related to definitions that you create or adapt using PeopleTools. You can view the
PeopleTools tables in the PPLTOOLS project using the PeopleSoft Application Designer.

To create the application data tables that store the rows of data that your users manipulate:
1. Create a record definition.

In doing so you determine the structure of the table, the characteristics of the fields, and any online
processing that you want to occur behind the scenes when a user enters data.

2. Apply the SQL Create option to build the SQL table in which your application data will reside based
on a subset of parameters in your record definition.

During this process, the system automatically gives the application data table the same name as your
record definition, prefaced with PS .

Normalized Relational Databases
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To better understand the structure of your PeopleSoft system, you should be familiar with the concept of
a normalized relational database. A normalized table adheres to standards that are designed to improve
the productivity of the database user. Normalization makes the database more flexible, allowing data to be
combined in many different ways.

The standards for a normalized database are called forms, such as first normal form, second normal form,
and so on.

First Normal Form

The first normal form requires that a table contain no repeating groups of non-key fields. In other words,
when you set up a record definition, if you encounter a field that could have multiple occurrences, put
that field in a separate record that is subordinate to the primary record definition (a child record). This
setup allows unlimited occurrences of a repeating field rather than a specified number. Each row of
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data is uniquely identified by a primary key, which can be a single field or a group of fields that, when
concatenated together, form a unique key.

For example, look at the record definition structure of the tables that we use to schedule exam times for
different locations in our training database. Here are the necessary fields, in order of importance:

«  LOCATION
« EXAM DT
« EXAM TIME

You know that you have multiple exam dates and times per location. You could set up record definitions
to accommodate this data as follows:

Record Definition Fields Key?
LOCATION LOCATION Yes
EXAM LOCATION Yes
EXAM DT Yes
EXAM_TIME LOCATION Yes
EXAM DT Yes
EXAM TIME Yes

Because multiple exam dates per location might exist, we added exam dates to the second record
definition (child record) that is subordinate to the first (parent) record. Similarly, because one date could
have multiple exam times, exam times are located in a third record definition that is subordinate to the
second.

Second Normal Form

The second normal form dictates that every non-key field in a table must be completely dependent on the
primary key. If two fields make up the key to a table, every non-key field must be dependent on both keys
together. For example, if a table has the Employee ID and the Department ID fields as keys, you would
not put the Department Name field in the table because this field is dependent only on the Department ID
field and not on the Employee ID field.

Third Normal Form

The third normal form is a corollary to the second; it requires that a non-key field not be dependent on
another non-key field. For example, if a table is keyed by the Employee ID field and Department ID is a
non-key field in the table, you would not put the Department Name field in the record because this field
is dependent on a non-key field (Department ID). You would find the Department Name field only in the
table that is keyed by the Department ID field, not in any other table that contains Department ID.

© 1988, 2023, Oracle and/or its affiliates. 133



Planning Records, Control Tables, and Tablesets Chapter 5

With the third normal form, you store shared fields in tables of their own and reference them elsewhere.
For example, you would not put the Department Name field in every record definition in which the
Department ID field appears. Instead, you would create a prompt table of department IDs and department
names. Similarly, you would create a prompt table of job codes and job titles instead of putting a job title
in every employee’s record.

Note: When designing record definitions, you should adhere to the third normal form to increase
flexibility and reduce data redundancy.

Record Definition Planning

Before you begin to create record definitions, you should know how you plan to use the record definition,
the fields that it will contain, special edits that you would like to see performed on the record definition,
or specific fields in the definition.

You define two layers of information:
* Record level
* Field level

At the record level, determine the ultimate purpose of the record definition and how it will be used in the
system. Is it destined to define an underlying SQL table to hold data? Are you building a view to join

or retrieve information from other tables? Do you need a temporary work record where you can store
derived data?

You can audit record-level changes, as opposed to individual fields contained in the record definition,
which is an efficient alternative if you plan to audit several fields. You can also establish a more
sophisticated use of record definitions, such as sharing information in tablesets and multi-language
controls, at the record level.

At the field level, plan the details of what types of fields to add. Should they be character fields or number
fields? Should automatic formatting be used? What are the keys to the data stored in the database? Which
fields should you audit? Do you want to specify prompt tables so that users can select from lists of valid
values that are stored elsewhere in the database?

In most cases, if you are creating a record definition for a SQL table, you don’t have to worry about
record-level definitions for parameters and conditions. Unless you change how a record definition is used,
the system automatically assumes that you are defining a record definition for an underlying SQL table.

Effective Dates

134

Effective dates enable you to keep historical, current, and future information in tables. You can use the
information to review the past and plan for the future. Three types of effective dates are available:

Term Definition

Future Data rows that have effective dates that are after the system
date, which is usually today’s date.
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Current Data row with the most recent effective date that is closest to
today’s (system) date, but not a future date. Only one row is
the current row.

History Data rows that have effective dates before the current data row.

The EFFDT (Effective Date) field has special properties related to the processing of effective dates on
rows and should be used only when needed.

Unlike regular date fields, which you can use anywhere in the system, use the EFFDT field only in record
definitions for which you want to maintain data history—future, current, and past—to store rows of data
in sequence. Using EFFDT fields only for this circumstance enables you to store multiple occurrences of
data based on when it goes into effect.

For effective-dated rows, you can have multiple occurrences of future and history but only one current
row of data.

EFFDT is almost always a key and almost never a list item. Activate the Descending Key attribute so
that the row with the most recent effective date appears first on pages. You might enter %DATE (current
system date) as the default constant for this field.

Note: Alternatively, you can use %CLIENTDATE as the default constant for the date field.
%CLIENTDATE adjusts the date as appropriate to the time zone of the browser.

To enable you to track an accurate history of your effective-dated information, the system invokes special
logic when you access a record definition that contains EFFDT. The action that you select dictates
whether you can access the row type and what you can do with each type of row:

Action Type View Change Insert New Rows

Update/Display Current, Future Future Only Effective Date Greater Than
the Current Row

Update/Display All History, Current, Future Future Only Effective Date Greater Than
the Current Row

Correction History, Current, Future All Existing Rows Add New Rows with No
Effective Date Restrictions

Note: For records that do not contain EFFDT, all actions (Update/Display, Update/Display All, and
Correction) operate the same way: they retrieve all existing rows for the specified keys.

When you run a page with effective-dated records and you insert a row, the system copies the contents of
the previous row into the new row to save you keying time. In a large effective-dated table, you do not
want to reenter all of the data when only a single field changes. Also, anytime you insert an effective-
dated row using PeopleCode, the system copies the contents of the previous row.
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Effective Status In prompt tables, EFF_STATUS (Effective Status) usually
accompanies EFFDT. When used with EFFDT, it is part of the
mechanism that enables the system to select the appropriate
effective-dated rows.

You can also use EFF_STATUS by itself as a simple status
field, but do not change the translate values. They must be
A (active) and [ (inactive) for EFFDT to work properly. If
you need a status field with different values, use or define a
different field.

Effective Sequence The EFFSEQ (Effective Sequence) field serves different
purposes, depending on whether it is paired with EFFDT. If
EFFSEQ is not paired with EFFDT, then EFFSEQ has no
special function and can be used as a simple sequencing field
wherever you need one.

If EFFSEQ is paired with EFFDT, it enables you to enter more
than one row with the same effective date. You assign a unique
sequence number to each row that has the same effective date.

Do not make EFFSEQ a required field; a value of unrequired

allows the first EFFSEQ to be zero. Select Display Zero in the
page definition to have zeros appear on the page.

For example, suppose that you want to enter both a transfer
and a pay rate change for an employee, and both actions are
effective on the same day. Enter the transfer on the job data
pages as usual, and leave the Effective Sequence Number
field as 0 (zero). Then, insert a row to enter the change in pay
rate. This time, the effective date is identical to the previous
row, but enter / in the Effective Sequence Number field.

Related Links
“%ClientDate” (PeopleCode Language Reference)
“%Date” (PeopleCode Language Reference)

Control Tables

Control tables store information that controls the processing of an application. This type of processing
might be consistent throughout an organization (in which case the entire organization shares the same
control information), or it might be used only by portions of the organization for more limited sharing of
data.

Sharing One Set of Common Values

The first type of sharing is to create one table that everyone shares; it stores common information that is
valid for all users, such as a country table to store country codes or a department table to store department
codes. Such control tables are ordinarily maintained centrally because the data is shared throughout the
entire organization.
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Sharing Common Values in Overlapping Plans

What do you do if the codes that are stored in a table are valid only for some users? Consider benefit
plans, for example. Typically, you store information for benefits plans in a plan table. However, not all
plans are valid for all employees; their validity might depend on whether the employee is full-time or
part-time, union or nonunion. Some plans might overlap; some might be appropriate for all employees
and others only for some. In a relational database, you do not want to define the same plan value—and
associated data—more than once.

In this case, you can easily resolve the problem by using two tables. The first is the plan table, which
stores the relevant data for each plan. The second table defines which plans are valid for various benefit
programs or groups of plans. For example, one benefit program might be valid for nonunion employees,
and another benefit program might contain the plans as negotiated with a union.

This table shows how you might set up the two tables to reflect the benefits offered:

Benefit Program Table Benefit Plan Table
Key Valid Values Key Description Field Field
Nonunion Program | Plan 1 Plan 1 Health
Plan 2 Plan 2 Life
Union Program Plan 2 Plan 3 Savings
Plan 3 Plan 4 Health-Union
Plan 4

These tables are ordinarily centrally maintained because the data is shared by various groups in the
organization.

Tablesets

When none of the information stored in control tables is valid for all users, but the structure of these
common tables is the same, you can set up a way to share multiple sets of values. For example, a multi-
company organization must store completely different sets of accounting codes for its various operating
entities, and the data for these accounting codes is maintained in a set of relevant control tables. The
actual data values differ, but the structure of the control tables remains the same. PeopleTools enables you
to share sets of values in a control table through tablesets.

To better understand Typesets, consider an organization that has two retail stores with common
accounting codes, two pharmaceutical firms with another set of accounting codes, and two shipping firms
with yet another set of codes.
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The following image explains about maintaining multiple account codes for multiple companies

RETAIL PHARMACEUTICAL SHIPPING
COMPANIES COMPANIES COMPANIES
Company 1 Company 1 Company 1
Company 2 Company 2 Company 2

If each of these companies has completely different accounting codes, you can establish six different sets
of account codes to be maintained by each company. If they all have exactly the same accounting codes,
you can limit them to one set of values. However, the reality is usually somewhere in between. That is,
there is one set of account codes for each type of business: retail, pharmaceutical, and shipping. Rather
than having six different companies maintaining separate copies of this common data, you can reduce the
number to three sets:

The following image illustrates the concept of sharing multiple account codes among companies

RETAIL PHARMACEUTICAL SHIPPING
COMPANIES COMPANIES COMPANIES
Company 1 Company 1 Company 1
Company 2 Company 2 Company 2
v v v

RETAIL PHARMACEUTICAL SHIPFING
Account Codes Account Codes Account Codes

You can also handle exceptions. Suppose that Retail Company 2, a recently acquired company, has its
own unique set of account codes. A separate set of values should be maintained for this company as an
exception to the retail rule:
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The following image explains sharing account codes among companies with exceptions

Six Sets of
zﬂﬁs'b'f Cod RETAIL PHARMACEUTICAL SHIPPING
ccount Lodes COMPANIES COMPANIES COMPANIES
Company 1 Company 1 Company 1
Company 2 Company 2 Company 2
Three Sets of h 4 h 4 A A L
3533?3“& col RETAIL CEE;;:E PHARMACEUTICAL| | SHIPPING
of Unique Account Codes Account Codes Account Codes Account Codes
Nalues I ‘
|
Three Standard Sets +
Flus One Exception ACCOUNT CODES
for Retail Company 2
Retail TableSet
Pharmaceutical
TableSet
Shipping TableSet
Retail Company2

When you share tables in PeopleTools applications, you add the SETID field as an additional key or
unique identifier to the table that you want to share. This key identifies the sets of information in the table
that are shared by multiple companies or business units under your corporate umbrella. You then specify
a set control field, which identifies which fields map between the original key and the tablesets. You can
specify any field that logically identifies the tablesets. In this example, you might assign the Company
field as the set control:

Copyright © 1988, 2023, Oracle and/or its affiliates. 139



Planning Records, Control Tables, and Tablesets

Chapter 5

The following diagram illustrates linking set controls and tablesets where in you can specify any field that
logically identifies the tableset

SET CONTROL FIELD

VALUE COMPANY NAME
RCO1 Retail Company 1
RCO2 Retail Company 2
PCO1 | Pharmaceulical Company 1
PCO2 | Pharmaceulical Company 2
SCO1 Shipping Company 1
SCo2 Shipping Company 2

Exception

k4

™

TABLESET ID
SETID DESCRIPTION
RETL Retail TableSet
RCO2 ROC2UniqueTableSet
PHARM | Pharmaceutical TableSet
PHARM | Pharmaceutical TableSet
SHIP Shipping TableSet
SHIP Shipping TableSet

Sharing Groups of Record Definitions

While this example illustrates how you might share data values for a single table—Account Codes—you
typically share data that is stored in many tables that are based on the same tablesets. To minimize the
overhead of defining tablesets, you can define record groups that share table data in a similar manner. For
example, rather than using the tablesets that you establish for accounting codes solely for the Accounting
Code table, you can group all accounting related tables into one record group.

Tablesets and PeopleSoft Applications

Some PeopleSoft applications already take full advantage of tablesets and table sharing. Throughout the
PeopleSoft Financials and HCM product lines, tablesets are used extensively, in most cases triggered by
business unit.

Sharing Tables

140

This section provides an overview of table sharing and discusses how to:

Add the SETID field to record definitions.

Define set control fields as the fields controlling the assignment of tablesets.

Modify set control fields.

Create setIDs.

Define record groups to identify the tables and subordinate (child) tables that are affected.

Define tablesets controls.

Share trees.
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Understanding Table Sharing

To share tables, you must modify the record definitions for both the table that you want to share and the
one that contains the set control field. Using the online PeopleTools utilities for tablesets, you define the
terms or controls for sharing.

For example, the PeopleTools database holds data for three companies: one U.S.-based parent company
(PST) and two sister companies (CCB in the U.S. and VNB in Canada). In this organization, all of the
U.S.-based companies share one set of accounting codes, and all of the Canadian-based VNB companies
share another:

U.S. Account Codes Canadian Account Codes Description

123456789 123456789 Teller

987654321 987600000 Customer Service
CCB-4476-EXTSAL-USA VNB-4476-EXTSAL-CDN Extraordinary Salary Employees
CCB-4476-REGSAL-USA VNB-4476-REGSAL-CDN Regular Salary Employees

These two groups of companies must maintain parallel sets of accounting codes and, in some cases, use
the same code, uniquely identified for U.S. or Canadian companies.

You must set up the Account Code table so that users who access that page or prompt for valid values
see only the values for their respective companies, depending on whether they are located in the U.S. or
Canada.

To do this:

1. Modify the Account Code table, which will be shared, and the Company table, the values of which
(CCB, PST, VNB) control the tablesets that are used.

2. Create two tableset IDs:
* USA: For U.S. companies.

* CAN: For Canadian companies.
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The following diagram explains how two groups of companies can maintain parallel sets of accounting
codes that contain unique tablesets and set control fields

USs BASED CANADIAN
COMPANIES COMPANIES
PST WHNB

CCB WHNE - Quebec
i v
UsA CANADIAMN
Account Codes Account Codes

I

ACCOUNT CODES

USA TableSet

CAN TableSet

Assigning Set Control Fields

If you plan to use the Table Sharing feature to add an additional high-level key to identify common sets of
values and handle exception values, you enter a set control field. The set control field determines which
set of values appears, based on how you define table sharing.

Table sharing is usually applied in multi-company environments, in which you might want to share
certain tables in some operating entities while allowing others to retain control over the contents of their
own. Use the feature to maintain a single table in which you can store multiple sets of values to be used
by different entities in your organization.

When you create a record definition that will be shared, you add the field SETID as a high-level key.
The setID value is controlled by the key that you select in the Set Control Field drop-down list box in
the Record Properties dialog box. These setIDs identify groups of tables to be shared and enable each
business entity to identify whether it wants to use the corporate-wide table or maintain its own. Enter the
name of the key as your set control field for each record definition that will be shared.

For example, if you have several companies in your organization, many of which share the same set
of account codes, add a SETID field to the ACCOUNT table record definition. In this definition, enter
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Company as the set control field. The set control enables different companies to access the account values

stored in the same Account table. As each company defines its set controls, it has the option to use the

shared Account table or maintain control of its own.

Adding the SETID Field to Record Definitions

Add the setID field to the record definition for table sharing purposes.

This example illustrates the fields and controls on the Adding setIDs to record definitions. You can find

definitions for the fields and controls later on this page.

=8 DEPT_ACCESS_TBL {Record)

Record Fields |Record Type }

Format Short

Hum) Field Hame Type | Len

Hame Long Hame

1 A pper

| 2 |TREE_MNODE Char 20 pper Mode Tree Mode

| 3 |EFFDT Date | 10 Eff D ate Effective Date

| 4 |SEQNUM Mbr 3 Sequm Seguence number

| 5 |EFF_STATUS Char 1 pper Statuz Statusz az of Effective D

| B |EMaILID Char il b imed Email ID Email IO

| 7 |DISTID Char a0 b imed ] Driztribution 1D

| 8 |DISTIDTYPE Char 3 pper D Tope Drigtribution 1D Type
To add a setID:

1. Open the record definition for the table that you want to share.

2. Select New > Field > Character.

Enter the special field that PeopleTools provides for table sharing:

SETID is a 5-character field. Add it to the top of your record definition list, and define it as a required
key, search and list item, with a prompt table edit against the PeopleTools SETID TBL.

Defining Set Control Fields

After you add the setID field to your record, identify the set control field in Record Properties.

To define the set control field:

1.

2.

Select Edit > Definition Properties from the menu.
Select the Use tab.
Select the field that identifies the appropriate setID in the Set Control Field drop-down box.

See Understanding Table Sharing.

Click OK to save your changes.

Use the SQL Alter process to alter your underlying SQL table.
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6. When the system prompts you for a default setID, enter the most common setID for your company.

Modifying Set Control Fields

If you are sharing tables or using a set control field that is not already defined as such in your PeopleSoft
application, you must make some modifications to the record definition for the table in which you

store values for your specified set control field. For example, all PST company codes are stored in the
COMPANY TBL.

Here, you must add PeopleCode to the set control field so that each time you add a new value, the system
populates the set controls in PeopleTools utilities, where you assign the appropriate tablesets.

This example illustrates the fields and controls on the Attaching PeopleCode to your set control field. You
can find definitions for the fields and controls later on this page.

!__JAEET_ED_TBL [Record PeopleCode] M= E

|sETID x| [5aveFostChg =]

declare function add tableset _cntrl peoplecode FUONCLIE UTIL. FIELDNAME
FieldFormula;

declare function add setid peoplecode FUNCLIE UTIL. FIELDHNAME
FieldFormula;

if %Mode = "A" then
add_setid (COMPANY, DE3CR, DESCESHORT)
add_tahlset cntrl ("COMPANY™, COMPANY, COMPANT)
end-if;

This program assigns a default setlD with the same value as the Set Control Field value, for each new
COMPANY row that you add to the COMPANY _TBL. For example, when you add a row for CCB in the
Company table, it creates a default setlD of CCB. This way, each value that you add is assigned a unique
tableset until you assign shared tablesets in the Utilities window.

You can easily clone and modify this program to change the ADD SETID and

ADD TABLESET CNTRL statements to reflect your table sharing objectives. Alternatively, if you are
working with existing tableset functionality, you can point to a model setID that is delivered with your
PeopleSoft application.

Related Links
Altering Tables
Creating SetIDs
After you prepare for sharing your table, you define the setIDs that logically group information. When

you define setIDs, you create groups that might naturally share more than one table. For example,
although CCB and VNB are planning to share only the ACCT _CD_TBL now, the setIDs that you set up
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might define logical divisions in the organization that serve as the basis for sharing all accounting-related
tables. Describe your sets to give them as broad an application as is practical in your organization.

If possible, use descriptions that denote the shared table and set control field. For example, for CCB and
VNB, we added two tableset IDs, identifying them as related to accounting codes for companies:

setlD Description Short Description
USA Accounting Codes - USA Co.s AcctCd USA
CAN Accounting Codes - CAN Co.s AcctCd CAN

You create setIDs on the TableSet ID page in PeopleTools > Utilities > Administration > Maintain
TableSet IDs.

Related Links
“TableSet IDs” (System and Server Administration)

Defining Record Groups

Record groups are a set of logically and functionally related control tables and views. They help enable
tableset sharing, which eliminates redundant data entry and ensure that it is applied consistently across all
related tables and views.

In the record group table, you group the record definitions for the tables that you want to share and any
dependent record definitions. If you add a table to a PeopleSoft application, an appropriate record group
might already be defined. However, if you add new business functions, you might need to add a new
record group for the tables that you define. You access the record groups table in PeopleSoft Pure Internet
Architecture on the Record Group page.

Related Links

“Create TableSet Record Groups” (System and Server Administration)

Defining Tableset Controls

As you add values for your set control, the system automatically populates the Tableset Controls 1 table
with default values. You define tableset controls in PeopleTools > Utilities > Administration >
Maintain TableSet Controls using the browser. Here you can enter the set control value for which you
want to assign a tableset.

For example, we use Company as our set control field, and PST, CCB, and VNB are values that we want
to add to the Company table. The system automatically assumes that each new set control value maintains
its own set of tables and does not enable table sharing. So, the default values are the same as the set
control value. In this case, when we added the value CCB to the Company table, the system populated the
tableset controls with a default setID of CCB.

Because CCB is a U.S.-based company that should share the same U.S. accounting codes, we must
change the defaults to USA.
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Related Links

“Maintain TableSet Control” (System and Server Administration)

Sharing Trees

146

To share trees as well as tables and views, complete Tableset Controls 2 in the same way that you did
Tableset Controls 1. For example, if PST and CCB want to share one department tree for organizational
security and VNB another, you assign the appropriate setID for each value.

Defining Tableset Controls for Trees
To define tableset controls for trees:

1. Select PeopleTools > Ultilities > Administration > TableSet Control in PeopleSoft Pure
Internet Architecture.

2. Enter the name of the set control value for which you want to assign a tableset on the search page.

For example, we use Company as our set control field, and PST, CCB, and VNB are values that we
want to add to the Company table.

Because you already assigned a default setID in Tableset Controls 1, the system displays the default
setID that you assigned to this field value. If you create another tableset for sharing trees, you can
change this value.

3. Specify the tree name.

Click the prompt button next to the Tree Name field for a list of only the tree definitions with the
same set control field (which has SavePostChange PeopleCode that recognizes it as a tableset control
field).

This prompt list comes from a SQL view of tree definitions with those set control fields that have not
already been associated with a tree group.

4. In each tree row, specify the appropriate setlD.

5. Save your changes.

Viewing All Record Definitions Associated With a Set Control

You can view all record definitions that are associated with a set control on the Record Group tab of the
TableSet Controls page.

Example of Set Controls

After you set up and define all of your set controls, you can see the results by looking at pages on which
you reference codes that are stored in a shared table. For example, on Administer Workforce, Use, Job
Data 1 and 2 pages, Account Code is an optional field that is edited against the ACCT_CODE_TBL.

In this component, the system identifies the company based on the department to which an employee is
assigned. For example, Simon Schumacher is in department /0100, which is associated with the company
CCB.

Select the Job Data 2 tab and enter 8001 or Simon Schumacher in the search record dialog box to retrieve
a CCB row, for which the company is defined in the department table. Here, you can see that Simon
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works in department 00001, which identifies him as a CCB employee. If you click the prompt button
next to the Account Code field, the system displays only those rows in the Account Code Table that are
associated with USA, the setID for CCB.

Alternatively, if you access the job row for Joan Avery, an employee of VNB, and click the prompt button

for the same Job Data 2 Account Code ficld, the system retrieves only values that are associated with
CAN, the setID for VNB.
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Understanding Record Definitions

Fields that are grouped together as a unit are record definitions. A record definition represents what the

underlying SQL database tables look like and how they process data. Two tabs exist in record definitions.

Use the Record Fields tab to access the fields that compose the record definition.

This example illustrates the fields and controls on the Record Fields tab. You can find definitions for the

fields and controls later on this page.

£ OE_DEPT_TBL (Record)

Record Fields [Record Type |

Mum Field Name Type | Len | Format Shont Hame Long Mame
1 |SETID Char ] Upper SetlD SetlD
2 |DEPTID Char 10 Upper DeptlD D epartment
3 |EFFDT Date 10 Eff Date Effective Date
4 |EFF_STATUS Char 1 Upper Status Status az of Effective D
5 |DESCR Char 30 b imed Deszcr Description
E |DESCRSHORT Char 10 b imed Short Desc Shaort D ezcrphion

Use the Record Type tab to specify way that the record definition is to be used, for example a SQL table

or view, or perhaps a temporary table.
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This example illustrates the fields and controls on the Record Type tab. You can find definitions for the
fields and controls later on this page.

Ef DE_DEPT_TBL (Record)

Record Fields ~ Record Type I

I

I

8 i i i i

— Record Type

SOL Table

SOL Yiew
Diynamic View
Denvedwiork
SubRecord
[uiem Wi
Temporan T able

Mon-Standard SOIL
T able Mame:

Build Sequence Ma:

e

Click to open SGL Editar

Understanding Record Types
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Select the Record Type tab to view the record definition types. Select from these types:

Term Definition

SQL Table Select to define a record definition that has a corresponding
physical SQL table in the database. Create this table when you
run the Build Operation from the Build menu. This value is the
default setting.

SQL View Select to define a record definition that corresponds to a SQL

view, which is not a physical SQL table in the database but
fields from one or more SQL tables that are reorganized into
a different sequence. SQL view provides an alternate view of
information that is stored in tables.

To create the SQL view, click the Click to open SQL Editor
button, enter a SQL Select statement, and then run the Build
process.

See Creating SQL View and Dynamic View Select Statements.
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Term

Definition

Dynamic View

Select to define a record definition that can be used like a
view in pages and PeopleCode, but is not actually stored as a
SQL view in the database. Instead, the system uses the view
text as a base for the SQL Select that is performed at runtime.
Dynamic views can provide superior performance in some
situations, such as search records and in PeopleCode Selects,
because they are optimized more efficiently than normal SQL
views.

Note: Keys for dynamic views should not be effective date
fields.

The dynamic view should contain only fields whose names
exactly match the fields comprising the SQL query.

Derived/Work

Select to define the record definition as a temporary workspace
to use during online page processing. A derived or work
record is not stored in the database, so you do not build it.

SubRecord

Select to define the record definition as a subrecord: a group of
fields that is commonly used in multiple record definitions and
that you can add to other record definitions. This way, you can
change a group of fields in one place, as opposed to changing
each record definition in which the group of fields is used.

Query View

Select to define the record definition as a view that is
constructed using the PeopleSoft Query tool. Before you can
create the view, PeopleSoft Application Designer prompts you
to save the definition.

Temporary Table

Select to define the record definition as a temporary table. You
can specify temporary images of the table on the PeopleTools
Options page. Use temporary tables for running PeopleSoft
Application Engine batch processes. Temporary tables

can store specific data to update without risking the main
application table.

When creating a temporary table on an Oracle RDBMS, you
have the option of creating a Global Temporary Table (GTT).
Using GTTs can enhance Application Engine performance.

Non Standard SQL Table Name

Specify the SQL table name that you are defining to override
the standard convention of prefixing PS_ to the record name.
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Term

Definition

Build Sequence No.

This field is available when the record type is a SQL or Query
view. Set the order in which the view is to be created. The
default value is / when the record or view is initially created.
Views that must be created first can be set to 0, while views
that you want created last can be set to any number from / to
99. The build sequence number is stored with the other details
of the record or view in the database.

Note: The maximum valid entry for the sequence number is
99.

When building temporary tables on an Oracle database, you have the option of implementing Global

Temporary Tables (GTT) for enhanced performance.

This example shows the Record Type tab when creating a temporary table on the Oracle platform with the
Global Temporary Table option displayed.

Efi AE_GL_REC1 {Record)

Record Fields ~ Record Type I

I

8N Nie Nis e

0

~ Fecord Type

SOL Table

SOL Yiew
Dynamic “igw
Denived Mok
SubRecaord
Cluery Wiew
Temporary T able

Man-Standard SEL
T able Mame:

[ Global Termparar Table [GTTE

L |

When building a GTT, using the Application Designer Build feature, the SQL generated to build the table
appears similar to the following example:

CREATE GLOBAL TEMPORARY TABLE PS QE AETEST
DECIMAL (10)

NOT null,

QE AE INT 1 SMALLINT NOT null,
QE_AE APPLID VARCHAR2 (12) NOT null,
QF_AE SECTION VARCHAR2 (8) NOT null,
QE_AE STEP VARCHAR2 (8) NOT null,
JOB_INSTANCE DECIMAL(10) NOT null,
PROCESSINSTANCE INTEGER NOT null,
QF RETURN CD SMALLINT NOT null,

RUN CNTL ID VARCHAR2 (30) NOT null,

(PROCESS INSTANCE
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AS OF DATE DATE NOT null,
QE AE SQLROWS INTEGER NOT null,
CURRENCY CD VARCHARZ (3) NOT null,
ANNUAL RT DECIMAL (18, 3) NOT null) ON COMMIT PRESERVE ROWS
TABLESPACE PTAPP
/
CREATE UNIQUE iNDEX PS QE AETEST ON PS QE AETEST (PROCESS INSTANCE)

/

Note: If you select the Global Temporary Table option, the temporary table name cannot exceed 11
characters.

Note: A Global Temporary Table must be assigned to the PSGTTnn tablespace, where nn is the
tablespace number (01, 02, and so on).

Global Temporary Tables are discussed in more detail in the product documentation for: PeopleTools:
Data Management. See “Improving Process Performance with Global Temporary Tables” (Data
Management). They are also discussed in the product documentation for PeopleTools: Application
Engine. See “Understanding Global Temporary Tables” (Application Engine).

Working with Materialized Views

When building SQL views or query views on an Oracle database, you have the option of implementing a
materialized view.

A materialized view acts as a database table that contains the results of a query. Once created, the data in a
materialized view can be synchronized (automatically or manually) with its source information as needed
with little or no programming effort.

A view has a logical existence, but a materialized view has a physical existence. All the characteristics
and tasks that can be performed with a table can also be done with a materialized view. For example, a
materialized view can be indexed, analyzed, and so on.

Materialized views are discussed in more detail in the product documentation forPeopleTools: Data
Management. See “Using Materialized Views” (Data Management).

Copyright © 1988, 2023, Oracle and/or its affiliates. 153



Creating Record Definitions

Chapter 6

This example shows the Record Type tab when creating a temporary table on the Oracle platform with the

Global Temporary Table option displayed.

Ef QE_AETEST {Record)

Record Fields ~ Record Type I

IS [=] E3

~Record Type —— Mon-Standard SAL
" SOL Table Table Marme:
&+ 50L View I
" Dynamic View Build Sequence Mo
i~ DerivedMwiork I-I
" SubRecord
" Query Yiew Click to open SOL E ditor
” Temporany Tabls

v Materialized Wiew

I

— Materialized Yiew Options
Refresh Method
= Complete

~ Fast

Fefresh Mode
= OnDemand
= Orn Commit

Build Options
= Immediate

" Deferred

|

Term

Definition

Materialized View

Select to create a materialized view for Oracle database
systems when SQL View or Query View is also selected. This
option is available only for Oracle systems. When selected, the
Materialized View Options group box appears to the right.

Materialized View Options

Term

Definition

Refresh Method

Complete: The materialized view table will be refreshed
completely. (Default)

Fast: The materialized view table will be refreshed
incrementally when running the Application Designer Build

option.
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Term Definition

Refresh Mode On Demand: Administrators refresh the view through
Materialized View Maintenance page. (Default)

On Commit: During a commit, the Oracle system executes
triggers and updates the materialized view log tables.

Build Options Immediate: The system creates the view and populates the
view from the base tables. This may be time consuming
depending upon the complexity of the view and data. (Default)

Deferred: The system creates the view but does not populate
the view during the build process. An administrator must run a
refresh from the Materialized View Maintenance page.

Materialized views are discussed in more detail in PeopleTools: Data Management. See “Using
Materialized Views” (Data Management).

Similar options exist for IBM Db2 for z/OS (Materialized Query Tables) and Microsoft SQL Server
(Indexed Views).

Related Links
“Working with Indexed Views” (Data Management)
“Working with Materialized Query Tables” (Data Management)

Viewing Record Definitions

You can see four views of a record by selecting View from the main toolbar: Field Display, Use Display,
Edits Display, and PeopleCode Display.

This section discusses how to:

* View basic field definitions.

* View key-related characteristics and default values.
* View editing options.

e View PeopleCode program types.

* Reorder fields.

¢ Size and sort columns.
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Field or Control

Description

Num (number)

The number of the field in the order in which it is defined in
the record.

Field Name

The name of the field in the SQL database.

Type

The data type of the field, such as character, number, or date.

Viewing Basic Field Definitions

Field Display mode shows the basic field definition characteristics for fields in the record definition. Field
definition characteristics are global: they affect all record definitions in which the field is used. To open
the associated field definition, right-click it while in Field View and select View Definition.

Field or Control

Description

Len (length) decimal precision setting for field definitions

Indicates the maximum length of the field, including decimal
places.

Format

Notes special formatting for the field, such as mixed case,
date, international phone number, or RawBinary.

Short Name and Long Name

Displays the short and long names of the field as users see
them on pages.

Viewing Key-Related Characteristics and Default Values
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Use Display mode shows key-related characteristics and default values for fields that determine how
fields are used in a record. The use characteristics might differ for fields that are used in more than one
record definition. Double-click the field to access the Record Field Properties dialog box in which you

define these parameters.

Field or Control

Description

Key

Indicates whether the field is a key to the record definition.
Key fields are included in an index that is automatically
created during the table build process.

The word Not in this column indicates that this field cannot be
used as a chart field. You can set this parameter only through
PeopleCode using the SetDBFieldNotUsed function.

See “SetDBFieldNotUsed” (PeopleCode Language
Reference).
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Field or Control

Description

Ordr (order)

Indicates the order of key fields in the index. You can
configure this order from the Index dialog box. It is reflected
in this column.

Dir (direction)

Indicates the order in which the key field indexes are created
in the database: ascending or descending.

CurC (currency control)

The currency format for this field is controlled by the currency
code in another field.

Srch (search) Indicates a search key, that is, a field for which one is
prompted from a search record dialog box.
List Indicates a list box item, that is, whether the values for the

field appear in the search record list box.

Sys (system)

Indicates that the system generates and maintains the field.

Audt (audit) Specifies whether additions, changes, or deletions to data in
this field are written to the standard PeopleTools Audit Tables
(PSAUDIT and PSAUDITEXT).

InAutoComp Indicates that the field is used as an autocomplete field and

appears in the autocomplete window.

EnAutoComp for Srch Record

Specifies whether autocomplete is enabled in a search record.

Default

Represents the default value that is used to initialize the field.

Viewing Editing Options

Edits Display mode shows all editing options (edit as a validation rule) that are available for fields in
a record. Edits on a field vary from one record definition to another. To define parameters, access the
Record Field Properties dialog box by double-clicking the field.

Field or Control

Description

Req (required)

Indicates whether the field is required. A user must enter a
value before the record can be written to the database.
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Field or Control

Description

Edit

Specifies that the values for this field are validated against a
table.

The translate table stores the codes and translate values:
Y/N (yes or no): Only two values, Y or N, are valid.

Prompt: Values reside in a designated prompt table.

Prompt Table

Indicates the prompt table for a field. When a user clicks the
prompt button or presses the ALT+5 key combination on a
page, the system retrieves the values that are stored in this
table.

Set Control Field

If you plan to use the Table Sharing feature to add an
additional high-level key to identify common sets of values
and handle exception values, add the name of the key here.
The set control field determines which set of values appears,
based on how you define table sharing.

Rs Dt (reasonable date)

Specifies whether a reasonable date test is performed on a date
field. All date fields are automatically edited to ensure that you
can enter only valid values. The reasonable date test warns if
the date is outside a 30-day range before and after the current
date. You can use this, among other tests, to guard against
entering the wrong year in a date.

Event

Indicates whether any type of PeopleCode was added for this
field. In addition, if PeopleCode was added, the field name
will be boldface.

Viewing PeopleCode Program Types

PeopleCode Display mode has a column for each PeopleCode program type. If a field contains a
PeopleCode event, a check mark appears in the event type column. Double-click in a cell to launch the
PeopleCode Editor. Note that fields containing PeopleCode are in bold in all display modes.
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This example illustrates the fields and controls on the PeopleCode Display mode with PeopleCode Editor.
You can find definitions for the fields and controls later on this page.

Record Fields }Rewrdwpe |

Num| Field Name | Type | FDe| FE| FCh| FFo| Rin| Ris |RDe| RSe| SEd| SPr| SPo| Srl | S15 | wik| PPy
1 _SETID Char v

2 |TREE_NODE Char

3 EFFDT Date

4 |SEQNUM Mbr

5 |EFF_STATUS Char
B
7
B

EMAILID Char
DISTID Char
DISTIDTYPE Char

EOX

DISTIDTYPE (field) v || FieldChange

If DEPT_ACCESS_TEL.DISTIDTYPE = "2 Then
DERIVED.EDITTAELE = Record.PRCSUSER_WW:
Elze
If DEPT_ACCEZS TEL.DISTIDTYPE = "3 Then
DERIVED.EDITTAELE = Record.PRCAROLE_V;
End-If;
End-If:

Reordering Fields

You can reorder the appearance of fields in a record definition by double-clicking the attribute name. For
example, if you double-click Field Name, the fields appear in alphabetical order; double-clicking Num
returns the fields to their numeric order. This action does not change the order of the fields in the actual
record. The numbers that the fields are originally assigned remain the same. This fact is important when it
comes to key fields.

To actually reorder the fields in the records, you must cut and paste or select a field and move it.

Sizing and Sorting Columns

You can change column lengths in any of the displays by dragging them to the appropriate size with your
cursor. For example, you might make the short name column smaller so that the entire long name for each
field appears. The default sizing of all columns returns after you close the record and reopen it.

You can also sort the rows in columns by double-clicking the column heading. For example, double-
clicking the Num column heading returns the list of record fields to the default sort order.

Saving Record Definitions

You should save your work every time you define a new record definition. As soon as you add or change
one element in the new definition, save your work and name the record. You cannot save a record
definition until you make at least one change to the record definition by changing record properties,
adding or deleting at least one field, or changing the record field properties.

You cannot add PeopleCode to a field until you save the record definition.
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To save a new record definition, select File > Save or File > Save As. If you have not named the
definition, the system prompts you to enter a record name. The system also prompts you to set the
tablespace using the Change Space dialog box.

See Setting the Tablespace.

Naming Record Definitions
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Use these guidelines for record definition names:

* The name length can be up to 15 characters, with the exception of the Temporary Table type, which
has a maximum length of 13 characters.

* The name must begin with a letter and can contain underscores to make it more readable.
* Avoid special characters, such as # or $, which can cause problems in some database environments.

See Saving Definitions.

Record Naming Conventions

To help identify the purpose of different types of record definitions, you should adopt these naming
conventions for record definition names and use these suffixes:

Field or Control Description

_TBL Identifies edit or prompt tables that contain data that is used
for validation, as opposed to data that is maintained by the
application. Prompt tables store commonly used values.
They include, but are not limited to, control tables, which
store company-wide values. For example, the location table
(LOCATION_TBL) stores values for all operating locations
in which your company does business; the country table
(COUNTRY_TBL) stores values for all valid countries.

VW Identifies record definitions that are physically implemented
by defining a SQL view.

_DVW Identifies dynamic views.

~WRK Identifies derived work records.

_SBR Identifies subrecords.

_QVW Identifies query views.
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Field or Control Description

WL Identifies records as worklist record definitions.

In some cases, PeopleSoft also uses these prefixes to identify special types of record definitions:

Field or Control Description

R Identifies work record definitions for Structured Query Report
reports. The remainder of the record name consists of the
program or report ID.

AUDIT _ Identifies record definitions that store audit information for

other record definitions in the database.

WEBLIB Identifies record definitions that store internet scripts. Internet
scripts are generally located in FieldFormula PeopleCode
events. You must grant access in the Security component for a
WEBLIB record with an internet script before it can be run in
a PeopleCode program.

FUNCLIB_ Identifies record definitions that contain written PeopleCode
functions, as opposed to built-in functions. You can include
these records in the component and call them as functions.
These self-developed functions are generally located in
FieldFormula events, and the records are usually derived.

DERIVED _ Identifies shared record definitions (across an application
module or group) that have fields for PeopleCode events.

Creating New Record Definitions

This section discusses how to create new record definitions.
To create a new record definition:
1. Select File > New.
2. Select Record.
3. Click OK.
The object workspace appears so that you can build a list of fields in a record definition.

4. Select the Record Type tab to define the type of record definition.
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Related Links

Manipulating Fields in Record Definitions

Opening Existing Record Definitions

Open a record definition in the same way that you open other definitions in PeopleSoft Application
Designer. In the open dialog box, you can narrow the search by selecting a record type or project. You can
also open an existing record from the project tree view by double-clicking a record name.

Manipulating Fields in Record Definitions

This section provides an overview of fields in record definitions and discusses how to:
* Insert fields into records.

e Insert subrecords into records.

Understanding Fields in Record Definitions

You create record definitions by adding field definitions to a new record definition or by cloning and
modifying an existing record definition. You can add fields in any order and reorder them at any time.
Locate keys at the top of the record definition, in order of importance.

Each field has basic attributes that are shared across all records that contain the field. These field
properties include data type, field name, long name, short name, field length (or integer and decimal
positions), formatting, help context number, and translate values. If you change any of these attributes
for a field, the change affects every occurrence of the field in every record definition. If the change is not
appropriate for every occurrence of this field, consider defining a new field instead.

Note: Changing a field name or length requires modification of the underlying SQL table, either by
running the SQL Build or SQL Alter menu items or by a system administrator action. For example, if
you change a field length for one record definition and 30 other record definitions contain the same field
name, then you must build or alter 31 records. If the records are all within one project, you can run the
build process on the project instead.

Inserting Fields Into Records
You can insert a field into a record in one of several ways:
» Using the project workspace tree.

To insert a field into a record definition directly from the project workspace by using the drag-and-
drop method:

1. Locate a field using the PeopleSoft Application Designer project workspace tree.

2. Drag the field from the project workspace tree to the object workspace.
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The field and its attributes are automatically added to the list of fields in the record definition.

» Using the Insert menu (Insert, Field).

Use the Insert, Field menu selection to search for fields with selection criteria, and then add them
to the record using the Insert button. You can also double-click a selected field definition and
select Insert the Field Definition. The system inserts the fields below the selected field in the record
definition.

* Dragging fields from existing records.
To drag a field from one record definition to another:
1. Open a record that contains the fields that you need.
2. Select the field.

3. Drag the field to a new record.

Inserting Subrecords into Records

Subrecords enable you to aggregate and configure a group of fields as a set, which you can then insert in
multiple record definitions. All subrecord fields and configured properties propagate to the subsuming
record definition.

You must define a subrecord before you can insert it into a record definition. You create and configure

a subrecord as you do any record definition; however, you do not build subrecords because they are
PeopleSoft structures, not standalone database structures. Select Insert > Subrecord... to search, select,
and insert subrecords into a record.

Viewing a Subrecord

Any open record in which a subrecord is inserted can have the subrecord expanded into the same record
definition window by selecting View > Expand All Subrecords. After selecting this option, the parent
record definition expands to show the fields in the subrecord. Subrecord fields are shaded.

When the subrecord is expanded, you cannot insert, cut, delete, paste, reorder, or sort fields. If you
reordered the display of the fields, you cannot expand the subrecords.

The expanded subrecord fields are read-only, which means that you cannot change the properties of these
fields. To access the properties, first open the subrecord. The shortcut to opening a subrecord is to click
the expanded subrecord and select View Definition. This action opens a subrecord definition from which
you can view the properties of the fields.

Collapse the subrecord by selecting View > Collapse All Subrecords.

Nesting Subrecords

Nested subrecords are fully supported to any level. Expanding a record toggles the record field list to
show all of the fields from all levels of nesting. Changes to subrecords are immediately reflected in
expanded records.
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Editing PeopleCode in Subrecords

You can edit PeopleCode that is attached to a subrecord field by double-clicking the appropriate field as it
appears in the expanded record. Any PeopleCode changes that you make apply to all records that contain
that subrecord.

Configuring Persist in Menu Properties

Important! Persistent search, the drop-down menu, and other forms of classic navigation are no longer
supported. The default navigational interface for PeopleSoft applications in the current release is based on
the fluid banner, which can be used for both classic and fluid applications.

All Persist in Menu properties that you explicitly define on record fields in subrecords propagate to all
subsuming record definitions. When you configure custom persistent search fields, the Persist in Menu
properties in both the subrecord and its subsuming records are counted toward the maximum number
of persisted fields. Selecting the Persist in Menu property for record fields in a subrecord that is already
being used by other record definitions displaces any lower order fields that, as a result of the subrecord
reconfiguration, are beyond the five-field maximum.

See Configuring Search Results Grid Columns in Persistent Searches.

Setting Record Properties

After you create a record definition, you will want to apply attributes so that the record functions. Access
the dialog box by selecting Record Properties, and then select either the General tab or the Use tab. This
section discusses how to:

» Set general properties.
» Set use properties.

¢ Create user-defined audit record definitions.

Setting General Properties
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Access the Record Properties, General tab.

Field or Control Description
Description Enter a descriptive name for the record.
Record Definition Enter appropriate comments in this area, including details

about the record type, use, parent and child relationships,
or other information that is important to other application
designers.
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Field or Control Description

Owner ID Displays a list of applications with which this record is used.
This list is helpful to identify the applications with which the
record is associated during application development.

Last Updated Displays the date and time of the last modification that was
made to the record and the name of the user who made the
modification.

Runtime Definition Displays whether the record definition was created as a

runtime definition by the “CreateRecordDefn” (PeopleCode
Language Reference) PeopleCode built-in function. A runtime
record definition is not editable in Application Designer. In
addition, it cannot be used in design time definitions (such

as pages, components, or others) in Application Designer.
However, a runtime record definition can be added to a project
definition.

Setting Use Properties
Access the Record Properties, Use tab.
These properties control the way the record definition is used in the system.

Specify the field with which the system maps between the original key and the tablesets in the Set
Control Field drop-down list box.

See Defining Set Control Fields.

Record Relationship Settings

Field or Control Description
Parent Record If this is a subordinate or child record, specify the parent
record.
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Field or Control

Description

Related Language Record

Specify a related language record:

*  The master record definition, which contains the
appropriate key and non-key field definitions.

* A clone of the master record definition, to which you add
an additional key for language code.

This is the related language record definition. This
definition should contain only those non-key fields for
which contents vary by language. Link the two record
definitions by specifying the name of the related language
record definition in this field on the master record

definition.

At runtime, the system checks the user’s language
preference and retrieves the data value from the
appropriate related language record definition.

Query Security Record

Specify a query security record if you want secure access to a

record using a security view.

Advanced Query Security

Click to display Advanced Query Security Record Mapping
dialog box, which you can use to specify multiple query
security records. Using multiple query security records is
described in more detail in the product documentation for
PeopleTools: Query. See “Using Row-Level Security and
Query Security Record Definitions” (Query).

Analytic Delete Record

Specify a delete record to use for optimization.

Record Name

Specify the user-defined audit record.

Audit Options

While you can audit individual fields at the field level, you might find it more efficient to have the system
audit the entire row whenever a user adds, changes, or deletes information. For record-level audits, the
system focuses on rows of data instead of specific fields. Consequently, a record-level audit writes a
single row of audit data rather than writing multiple rows for each insert, change, or delete transaction at

the field level.

Field or Control

Description

Add

Inserts an audit table row whenever a new row is added to the

table underlying the record definition.
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Field or Control

Description

Inserts one or two audit table rows whenever a row is changed

Change
in the table underlying this record definition.
Selective Inserts one or two audit table rows whenever a field that is also
included in the record definition for the audit table is changed.
Delete Inserts an audit table row whenever a row is deleted from the

table underlying the record definition.

Record-Level Auto-Update Options

These settings are used exclusively for mobile applications, enabling developers to display derived values
on a mobile page. These settings are not available for subrecords.

Important! PeopleSoft Mobile Agent is a deprecated product. These features exist for backward

compatibility only.

Field or Control

Description

System ID Field

Set this field to assign a unique way to identify the record for
mobile synchronization purposes. You must create a user-
defined index for this field.

Timestamp Field

Set this field to automatically update the field with the date
and time when there is a change to the record for mobile

synchronization purposes.

Record Information

Record Information contains options used during PeopleSoft upgrades.

Field or Control

Description

Identifies SQL tables owned by PeopleSoft PeopleTools

Tools Table
development, which is typically the same ownership as
indicated by the PPLTOOLS project.

Managed Identifies SQL tables owned by PeopleSoft PeopleTools

development that contain information that is used by managed
(cached) objects.
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Field or Control Description

Append ALL (Dynamic Views) Applies to dynamic views. If it is set, then at runtime the
system appends the WHERE clause generated at runtime to all
the SELECT statements in a dynamic view with a UNION.

Also, if it is set, at runtime the system generates FILL as the
table alias in the WHERE clause condition. For example,
FILL .<record field name> LIKE '%0%". You need to specify
which table corresponds to the FILL in the dynamic view
definition. For example, FROM table A FILL. You must
specify the corresponding table because the same record field
name may exist in two different records.

Oracle In Memory

These settings apply only to the Oracle database, beginning with Oracle 12c. Use these settings to
implement Oracle In-memory Column Store (IM column store) technology with your PeopleSoft system.

For more information on the Oracle In Memory feature, see “Working With Oracle Database In-Memory”
(Data Management).
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Field or Control

Description

All Fields

Select if you want all fields in the record definition to be
stored in the IM column store.

When selected, the system prepares all record fields to become
part of the IM column store, except for those fields which are
not supported for IM operations. That is, the In Memory check
box will be enabled and selected for all record fields in the
record definition where the record field is supported for IM

column store processing.

IM column store technology does not support these data types:
* LONG VARCHAR

«  LONGRAW

*  Out-of-line columns (LOBs, VARRARYS, nested table
columns)

+  Extended data type columns

Note: If you select All Fields, and the table contains any fields
with a data type that is not supported for IM processing, the
system will change your selection to Selective Fields upon
Save. Only the record fields that are supported for IM column
store processing will have the In Memory check box selected
automatically by the system in the record field properties.

Note: If All Fields is selected, and the record definition
contains fields that are not supported for IM column store
processing, those fields will be explicitly excluded from the
build process DDL.

Selective Fields

Select if you want to choose individual fields to include in IM
column store processing. Once selected, the In Memory check
box becomes enabled on the Record Field Properties, Use tab

for all record fields supported for IM column store processing.

For more information on the In Memory record field property,
see Setting Record Field Use Properties.

Note: After selecting any Oracle In Memory options, you must alter the table in order for the feature to

take effect. See Specifying Alter Options.

Creating User-Defined Audit Record Definitions

To audit at the record level, you must create a record definition and SQL table in which you store audit
information. When you create a new audit record definition, name it with an AUDIT _prefix. Some

Copyright © 1988, 2023, Oracle and/or its affiliates.

169



Creating Record Definitions Chapter 6

170

processes, such as the Employee ID Change and Employee ID Delete processes in the PeopleSoft Human
Resources Management product line, change fields, such as EMPLID. These processes do not affect
record definitions that begin with the AUDIT prefix, leaving your audit data secure.

The easiest way to create an audit table is to open the record definition that you want to audit and save
it as a new record definition, prefaced with AUDIT . Audit record definitions cannot contain key fields.
Therefore, if you clone a record definition to create an audit record definition, you must remove all key
attributes.

You should also use the audit-specific fields that are already defined for the PeopleTools audit tables
(PSAUDIT and PSAUDITEXT), which the PeopleSoft application uses to track field-level audits. Place
these audit fields at the top of the audit record definition, as you would keys. If you are creating several
user-defined audit record definitions, you might consider creating and using a subrecord definition with
these audit fields instead of adding them individually to each audit record definition.

This table lists audit field names and their purpose:

Audit Field Name Purpose

AUDIT OPRID Identifies the user who caused the system to trigger the audits,
either by performing an add, change, or delete to an audited
field.

AUDIT _STAMP Identifies the date and time the audit was triggered.

Note: If there is a possibility that multiple audit rows would be
generated within the same second or millisecond, then AUDIT
_ STAMP must be set as a duplicate key.

AUDIT _ACTN Indicates the type of action that the system audited. Possible
actions include:

* A:Row inserted.

*  D: Row deleted.

*  C: Row changed (updated), but no key fields changed.
The system writes existing values to the audit table.

*  K: Row changed (updated), and at least one key field
changed.

The system writes existing values to the audit table.

*  N: Row changed (updated), and at least one key field
changed.

The system writes new values to the audit table.

AUDIT RECNAME Identifies the name of the record definition that was audited.
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In most cases, you should include AUDIT OPRID, AUDIT STAMP, and AUDIT ACTN. The
AUDIT STAMP must be given the attribute AUTOUPDATE. You might also add AUDIT RECNAME if
you are creating an audit table to audit more than one record definition.

Note: Select the Auto-Update check box in the Record Field Properties dialog box; otherwise, the audit
record does not receive a date and time stamp.

Setting Record Field Properties

This section provides overviews of record field properties and record key considerations, and discusses
how to manage record fields.

Understanding Record Field Properties

When you add a field to a record definition, you must define attributes for how the field is used in that
record. These attributes include key settings, default values, table edits, and PeopleCode programs.

The properties of record fields are not shared among records; they are specific to a single record definition
and are stored with the record. Therefore, even though you might add the same field to multiple records,
each record stores a unique set of record field properties, while the primary field definition remains the
same.

When you access field properties from within a record definition, you set the record field properties, not
field definition properties or record definition properties.

To edit record field properties from a record definition, select the record field, then select Edit > Record
Field Properties from the PeopleSoft Application Designer menu. You can also double-click a record
field to set the properties.

Understanding Record Key Considerations

When creating key fields in your record definition, keep in mind several guidelines that are discussed in
the following topics.

Records With Multiple Keys

You can specify more than one field as a key to a record definition; that is, a record definition can have a
compound key. This example shows a compound key structure:
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This example illustrates the fields and controls on the Example of a compound key structure in the
PO_LINE record definition. You can find definitions for the fieclds and controls later on this page.

£4 PO_LINE {Record)

Record Fields IRE.;grd Type l
Numl Field Mame | Type Ke_l,l| I]ldll Dir |I:ur[115mh| List| S_l,ls| Audt |||'IAU| EnAull:ll Default |
| | 1 GBUSINESS_UNIT Char  ikep @ 1 hAsc ez ez Mo MNo Mo
| |2 PO_ID Char ikey @ 2 iDesc Ye: iver Mo Mo Mo
| | 3 LIME_MBR Mbr FKey 3 Asc Yer iWer Mo Mo Mo
| | 4 STATUS Char Mo Mo Mo Mo Mo
| |5 CINV_ITEM_ID Char Al ¥ Mo ez Mo Mo Mo
| | B CATEGORY_ID Char Mo Mo Mo Mo Mo
7 CUNIT_OF_MEASURE Char Mo Mo Mo Mo Mo

The keys to the PO_LINE record definition are BUSINESS UNIT, PO_ID, and LINE_NBR. Therefore,
each purchase order must be unique to a business unit, and each line item in a purchase order must have a
unique number.

Keys in Parent and Child Tables

In some cases, you have a field in a table for which you want to allow multiple occurrences, in which
case you create a subordinate or child table. For example, for employee reviews, an employee can be
reviewed for performance in multiple categories—organization skills, interpersonal skills, and so on.

These categories and ratings are stored in a separate child table, EE REVIEW_RT, which is directly

related to REVIEW_DT, the parent table that stores information about employee reviews.

The keys that you establish in a parent record definition determine which keys are required in child record
definitions. The child must have the same keys as the parent, plus one or more keys that uniquely identify

each row:

Item Parent Table Child Table
Record Definition REVIEW DT EE REVIEW RT
Key Fields EMPLID EMPLID

REVIEW DT REVIEW DT
CATEGORY

Most record definitions have either one primary key, or multiple keys that comprise independent, or
parent and child key combinations. Exceptions exist, however, such as record definitions without keys
and duplicate order keys.

Records Without Keys

Some record definitions, such as INSTALLATION, do not require keys because only one row of data
exists in the table. Whereas a table normally has keys to help distinguish between multiple occurrences of
data, when a table has only one row of data you do not need to distinguish one row from another. Another
primary use for keys is to build database indexes to rows; because each table has only one row, the record
does not need indexes. This example shows a record definition with no defined key structure:
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This example illustrates the fields and controls on the INSTALLATION table: example of record
definition with no defined key structure. You can find definitions for the fields and controls later on this

page.

£ INSTALLATION {Record) X

Record Fields IRechdTypE ]
Num| Field Hame | Type | Keyl I]rdl| Dirl[:urq SrcH List| 5ys| Audtllnﬁq EnAuln| Default ~

| 1 |COMPAaNY Char No  [Mo Mo MNo Mo

| 2 |MIN_STD_HRS Mbr Mo Mo Mo Mo Mo

| 3 |Max_5TD_HRS Mhbr Ma (Mo |No Ma Mo

| 4 |STD_HRS_DEFAULT Mbr Mo Mo |Mo Mo Mo )

| 5 |TEMP_S5N_MaSK Char Mo Mo |Mo Mo Mo 399’

| 6 |COMMIT_AFTER Mhbr Ma (Mo |No Ma Mo ‘300’

| 7 |POSITION_MGMT Char Mo [Mo  |No Mo Mo M

| & |COUNTRY Char No  [Mo Mo MNo Mo

| 9 |COMP_FREQUENCY Char Ma (Mo |No Ma Mo W'

|10 |EMPLID_LAST_EMPL Mhbr Ma (Mo |No Ma Mo

| 11 |EMPLID_LAST_APFL Mbr Mo Mo |Mo Mo Mo
MOM_EMPLOYEE_LAST Mbr Mo Mo |Mo Mo Mo

Records With Duplicate Order Keys

Occasionally, you might encounter situations in which a unique identifier for each row does not exist.
Duplicate order keys are a way of ordering data in the table when duplicate values are allowed.

For example, in the EDUCATION table, PeopleSoft developers anticipated that an employee can receive
two degrees of the same type on the same date. For example, though rare, Simon Schumaker could
receive two honorary degrees in computer science on the same day. Because no unique identifier exists—
the employee ID, date earned, and degree are all the same—the user must maintain the data differently.
The key, instead of defining a unique row, defines a group of rows. In that group, you must determine the
order in which you want to display the information.

In the EDUCATION record definition, three keys together determine how information is stored
and retrieved. EMPLID identifies the group of rows; and the placement of the duplicate order keys,
DT EARNED and DEGREE, instructs the system to order rows in the group first by date and then by

degree:
EMPLID DT_EARNED DEGREE
8001 June 1, 1992 HON

June 1, 1992 HON

The system concatenates or joins keys when it checks for uniqueness. In this case, the system accepts
duplicate entries in the DEGREE and DT _EARNED fields because they are part of a set that is identified
by EMPLID.

Note: Records with duplicate order keys should not have related language tables associated to them. If
the record requires a related language record, you must remove the order keys. Do not create a related
language record with a duplicate order key.
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Note: If you intend to perform data integrity validation on your record data when the system performs a
save, don't use duplicate order keys on your record. With duplicate order keys, the system cannot ensure a
unique row of data for validation.

Note: If you create a duplicate order key on a record, you see a warning message when you save the
record. During runtime, there is more information written to the log file. Use the Set Trace Flags option
Component Buffers Before Save, and search for more information in the log file.

Ordering Keys

The position of keys relative to one another is critical in a record definition; always list them in order of
importance. The primary key must be the first field in the record, followed by the next most important
key, and so on.

Key fields are followed by duplicate order keys, in order of importance, and then by fields that are not
keys. You can scatter alternate key fields anywhere among regular fields, in any order. They do not need
to be grouped.

Key, Duplicate Order Key, and Alternate Search Key are mutually exclusive.

Note: The display of key fields in record definition views does not always match the order in the record.
Always check the Num column to see the actual order.

Each alternate search key that you configure creates a database index when the SQL creates the table.
While database indexes are important, they consume disk space and, when the system must support the
alternate key, processing time. Therefore, do not add alternate search keys unless you really need them.
For both records and subrecords, you can only add 10 alternate search keys.

Setting Record Field Use Properties

174

As you add fields to a record definition, you must decide which fields uniquely identify each row; these
become the record keys. The nature of the data that you are storing should naturally determine the keys
for the information in the database.

The record field properties options that are available for field types might vary slightly; for example,
some of the properties that you assign might be relevant only to a character field in a record and not to
a date or time field. However, all of the options are described in this section. This example shows the
available record field properties options:
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This example illustrates the fields and controls on the Record Field Properties dialog box: Use tab. You
can find definitions for the fields and controls later on this page.

Uze |Edis

Record Field Properties

Field Mame:  PSIMAGEVER

K.enz
[ ] Key
[ ] Duplicate Order Key
[ ] Alernate Search Key
Dezcending Key
Search Kep
Search Edit
[ List Box Item
[ ] From Search Field
[ ] Through Search Field
[ ] Default Search Field

[ ] Dizable &dvanced
Search Options

[ ] Allow Search Events for
Prampt Dialogs

Audit
[ ] Field Add

[ Field Change
[ Field Delate

[ ] Systemn M aintained
Auto-Update

Record Field label |0

= lze Default Label =

Drefault Y alue

Congtant: |

ar

Becord Marne: |

Field Wame: |

Currency Control Field

Default Fage Control

| System Default

Autocomplete Configuration

Enable Autocomplete when uzed in Search Record

Perzizt in Menu Configuration

Perzizt in kenu

Cancel
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Field or Control

Description

Key

Select to identify the field as the search criteria that uniquely
identifies each row. You cannot have duplicate values for
primary keys. For example, EMPLID is the only key to the
PERSONAL DATA record definition. Therefore, EMPLID
must be a unique value for each employee, and only one
PERSONAL_ DATA row can exist per employee.

Duplicate Order Key

Select to indicate that duplicate values can occur. The order in
which you place duplicate order keys in a field list determines
the order in which the system retrieves duplicate keys.

Alternate Search Key

Select to make this field part of the search structure when
accessing your application data. Duplicate values are allowed
in an alternate search key field.

If you define a field as an alternate search key in a search
record or prompt record, the system includes the field on the
dynamically generated search page or prompt lookup dialog

box that you use to enter search criteria.

Descending Key

Note: This option no longer produces an index with
descending order.

Select to identify the field as descending if you want rows

of data to be retrieved in reverse alphanumeric order (for
example, 3, 2, 1). If you deselect this check box, the key is
ascending, meaning that rows are stored and retrieved in
alphanumeric order (for example, 1, 2, 3). This option applies
only to a field that is specified as a key, duplicate order key, or
alternate search key. PeopleSoft applications use descending
order primarily for effective date fields; most character keys

are ascending.
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Field or Control

Description

Search Key

Select to make the field available for entering search criteria
on the basic and advanced search pages, the lookup prompt
pages, and as a column that is stored in the menu structure for
persistent searches. A search key is valid only for keys and
should be used only in search and prompt records. If you select
this check box, the system automatically selects the List Box
Item check box.

Important! Persistent search, the drop-down menu, and other
forms of classic navigation are no longer supported. The
default navigational interface for PeopleSoft applications in
the current release is based on the fluid banner, which can be
used for both classic and fluid applications.

Search Edit

Enabled only if Search Key is selected. Select to enforce the
required property and table edits on the search page. It also
enforces these edits under circumstances in which the search
page would be bypassed. When this option is enabled, the user
no longer has the ability to perform partial searches on this
field.
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Field or Control

Description

List Box Item

Select to include the field as a column in the search results grid
on:

»  Standard component search pages. The system includes
all fields designated as list box items in the search results
list.

*  Prompt lookup pages. The system includes a// fields
designated as list box items in the search results list.

*  Recent (persistent) search results pages. The system
includes no more than five list box items in the search
results list.

Note: This behavior is the default. To explicitly define
which fields appear in the recent (persistent) search
results, you must set other configuration options.

Important! Persistent search, the drop-down menu, and other
forms of classic navigation are no longer supported. The
default navigational interface for PeopleSoft applications in
the current release is based on the fluid banner, which can be
used for both classic and fluid applications.

See “Configuring Caching” (Portal Technology).

See Configuring Search Results Grid Columns in Persistent

Searches.

If the field has values in the translate table and you designate
it as a list box item, the list box automatically shows the
translated value instead of the code.

If you select this check box, the system enables but does not
select the Persist in Menu check box.

From Search Field and Through Search Field

Select for fields that are used as search records. If you select
From Search Field, the displayed list contains rows in which
the field value is greater than or equal to a value that the user
enters. If you select Through Search Field, the displayed list
contains rows in which the field value is less than or equal to a
value that the user enters.

If you do not want these fields to be in a search list box, clear
the List Box Item check box, even if the field is an alternate
search key.
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Field or Control Description

Default Search Field Select to control which field name appears in the Search By
drop-down list box on the basic search page.

Disable Advanced Search Options Select to prevent runtime search pages from displaying
advanced search features for this field.

Allow Search Events for Prompt Dialogs Select to enable the SearchSave and Searchlnit PeopleCode
events on a prompt dialog for this field. The default value is
Cleared.

Note: Limit your use of these events in this context. The
amount and complexity of the PeopleCode affects the speed of

data retrieval.

Note: If you configure one of the OPRID, OPRCLASS, or ROWSECCLASS security fields as a Key, do
not configure the field as a List Box item. See the section on “Defining Row-Level Security and Query
Security Records” (Security Administration) for more on security fields.

Audit

Field-level auditing captures updates to selected fields and records the information in PeopleTools audit
tables.

Audit options apply only to data that is manipulated on a normal PeopleSoft application page through
component processing. These options do not apply to data that is added using means other than
component processing, including SQLExec, Record.Insert, or Record.Update PeopleCode.

PSAUDIT and PSAUDITEXT are the standard PeopleTools audit tables for field-level audits. Both audit
tables log identical information such as the user ID, time of change, and so on as well as the values of
audited fields both before (OLD) and after (NEW) any changes.

Note these differences in the field properties of the two audit tables:
e Inthe PSAUDIT table, the field length of the OLDVALUE and NEWVALUE fields is 65 characters.

* Inthe PSAUDITEXT table, the field length of the PTOLDVALUE and PTNEWVALUE fields is 254
characters.

If you are auditing a field with a field length greater than 65 characters, you should query PSAUDITEXT
to retrieve the field value.

Note: If a value is too long to fit in the audit table, the system writes an error to the appserv.log, and no
row will be inserted into the audit table. This applies to the OLDVALUE and NEWVALUE fields in
PSAUDIT and the KEY1-KEY 15 fields in both PSAUDIT and PSAUDITEXT.
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You can control when the fields are audited. For example, you can only record changes or deletions,
depending on business requirements. To audit several fields in a record definition, consider specifying
audits at the record definition level.

Field or Control Description

Field Add Audits this field whenever a new row of data is added.

Field Change Audits this field whenever the content changes.

Field Delete Audits this field whenever a row of data is deleted.
Miscellaneous

Field or Control Description

System Maintained Select to indicate that the field value is system-generated. This

option is for documentation purposes only and does not affect
processing.

Auto-Update Select to have the field updated with the server’s current date
and time whenever a user creates or updates a row. Any user
entries—even if permitted on a page—are overwritten by the

server time.
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In Memory
Field or Control Description
In Memory Select to enable the Oracle In-Memory Column Store feature

for this record field.

This check box is enabled only if the Oracle In-Memory
option Selective Fields is selected for the record definition to
which the record field belongs, and the field is supported for
Oracle IM column store processing.

If the Oracle In Memory option All Fields is selected for the
record definition to which the record field belongs, and all the
fields for this record definition are supported for IM column
store processing, the In Memory check box for the record
fields will be selected automatically and greyed out (disabled).

Note: If a field is not supported for IM column store
processing, the In Memory check box will be greyed out
(disabled) and cleared automatically.

For more information on implementing the Oracle In-Memory

Column Store feature, see Setting Use Properties.

Record Field Label ID

Specify which label, long name or short name, to use for the record. The default value is ***Use Default
Label***, This setting enables you to change labels of record fields dynamically anytime that the default
label on the field definition is changed.

For example, a field definition has three labels:

* Labell (Long Namel, Short Namel), marked as default.
e Label2 (Long Name2, Short Name2).

* Label3 (Long Name3, Short Name3).

When the label ID in a record field is set to Use Default Label, initially the long name and short name are
Long Namel and Short Namel. If the default label is changed to Label3 in the field definition, then the
long name and short name automatically become Long Name3 and Short Name3.

Default Value

Select the most commonly used value as the default. You can always enter a different value if the default
is inappropriate. The more defaults that you provide, the more data entry time you will save your users.

For a field, you can enter a default value as a system variable or as a combination of record and field
names.
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Field or Control

Description

Constant

Specify a default value.

This value is case-sensitive. If the record has translate values
for this field, the values appear in a drop-down list.

You can specify a system variable only when you want to
display the value of the current date or time. The accepted
system variables to be used as constants are:

*  %Date for Date, Time, Or Datetime fields. Returns a Date

value.
e %Time for Time fields.
e %DateTime for Datetime fields.

*  %ClientDate for Date, Time, Or Datetime fields. Returns
a Date value.

Record Name and Field Name

Enter the record and field names of the default value.

Field or Control

Description

Default Page Control

Specify the default appearance of a field as it appears on
the page that corresponds with the record field that you are

creating.

Currency Control Field

Enables the user to specify where to find the currency code that is used to display the currency symbol,
decimal digits, and scale of a number field. To use this option, the multi-currency option must be set. You
might also want to enable the current display when you define the field on the page.

Autocomplete Configuration

Note: Autocomplete is sometimes referred to as “type ahead.”
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Field or Control

Description

Disable Autocomplete for this field

Select to disable the autocomplete process for this field at

runtime.

Note: If selected, the end user cannot personalize

autocomplete settings for this field.

This setting enables you to control the autocomplete process
for certain fields at design time. For example, in some cases,
the autocomplete process for a field may be unnecessary or it

may present undesired performance impacts.

Enable Autocomplete when used in Search Record

Select to make this field appear as a column in the
autocomplete list when the containing record is used as a
search record.

This field is enabled for character, number, and signed number

fields if the following conditions are met:

*  The Default Page Control field value is Edit Box or
System Default.

*  The field is a search key or an alternate search key.

Persist in Menu Configuration

Important! Persistent search, the drop-down menu, and other forms of classic navigation are no longer
supported. The default navigational interface for PeopleSoft applications in the current release is based on
the fluid banner, which can be used for both classic and fluid applications.

Field or Control

Description

Persist in Menu

Select to explicitly include the field as a column in the search
results grid of a persistent search; select only if the field does
not appear in the search results grid by default.

The Search Key and List Box Item properties determine which
columns appear in the search results grid by default.

You must enable recent search results caching at the system
level in the web profile for this property to take effect.

See Setting Record Field Properties.

See “Configuring Caching” (Portal Technology).
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Important! If you select this check box for any record field in a search record, then the search results
grid uses this property—not the list box item property—to determine al// fields that appear in the grid.
Consequently, you must select the Persist in Menu check box for each record field that you want to
include in the search results grid.

See Configuring Search Results Grid Columns in Persistent Searches.

Time Zone and Related Date Fields

These fields are enabled only if the current field is a time or date and time field. They determine whether
the field is displayed or entered in a specified time zone.

Field or Control Description

Specified Time Zone Times are always stored in a database base time zone, but
when you place a time field on a page, you can display the
time in the base time zone or another time zone.

If you deselect this check box, the time appears in the database
base time zone. If you have users in multiple time zones, you
can reduce confusion by showing the time zone along with the

time.

If you select this check box, the system converts the time
according to the time zone specified in Time Zone Control
field. This control field must be a field in the current record.
Set an appropriate default value for the time zone control field.

Date Control Field Select which related date field in the current record stores the
calendar date to which this field should be adjusted.

Typically, you want to make a date field a descending key so that the row with the latest and most current
time appears first. If you want the default value to be the current system date, enter the value %date (or
%time) as the constant in the Default Values group box.

In general, each Time record field that is related to the Time Zone field should also be related to a Date
field in that same record. Otherwise, the time data that appears or is saved may not properly reflect the
appropriate state of daylight savings in that time zone. Furthermore, each Time record field should be
associated with a different Date record field.

For applications where two Time record fields need to share a common Date record field (as in, records
with a start time and an end time always occurring on the same date), you can relate each Time record
field to the same Date record field. However, keep in mind that the Date record field will only consider
itself associated with one Time record field—the related Time record field that has the earliest position in
the record field ordering for that record.

Related Links
“Using Autocomplete to Suggest Valid Values” (Applications User’s Guide)
“Setting Autocomplete Options” (Applications User’s Guide)
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Configuring Search Results Grid Columns in Persistent Searches

Important! Persistent search, the drop-down menu, and other forms of classic navigation are no longer
supported. The default navigational interface for PeopleSoft applications in the current release is based on
the fluid banner, which can be used for both classic and fluid applications.

The Persist in Menu property enables you to override the default fields that appear on the persistent search
page and explicitly determine which fields the system includes in the search results grid. If you select

the Persist in Menu property for any record field in the search record, then you must select the same
property for each field, including search key fields, that you want to appear as columns in the search
results grid.

Note: This property, when selected, controls the appearance of the persistent search results grid. Search
key fields remain in the menu structure but are hidden from view.

To explicitly define the fields that appear in the results grid for a recent (persistent) search:
1. Open the search record.

2. Double-click the field you want to include in the results grid and select the List Box Item check box
to enable the Persist in Menu check box.

3. Select the Persist in Menu check box for the field.
4. Click the OK button.
5. Double-click each additional field that you want to include and repeat Steps 2 and 3.

6. Save the record.

Note: When you save the record definition, PeopleSoft Application Designer alerts you if your custom
configuration exceeds the maximum number of fields that can appear in the search results grid of a
persistent search page. This alert is informational.

Adding From and Through Logic to a Search Page

Refer to the following example when applying from and through logic to a search page:
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This example illustrates the fields in the CNT CLAUSE TBL record, an example search record.

El CNT_CLAUSE_TEL [Record)

Record Fields IRgcurd Type I

Mum Field Hame Type | Len | Format Short Name Long Hame
COWNTRACT _CLAUSE 3 Upper | Clause Contract Clause
2 |EFFDT Date 110 Eff Date Effective Date
3 |EFF_STATUS Char 1 pper | Statuz Status ag of Effective D
4 |DESCRH Char a0 Mixed Dezcr Dezcription
5 |DESCRSHORT Char 10 Mixed Short Desc Short Description
& |DESCR254 Char | 254  |Mixed Long Descr Long Descrphion
¥ |COMMEMTS Long 0 Comment Comment

To apply the from and through logic to a search page:
1. Determine which component you want to change.

You must modify the search record for a particular page, so you must first identify the appropriate
component.

2. Determine on which field to use the from and through search logic.

Open the component in PeopleSoft Application Designer and examine the search record that

is associated with the component. In the CNT _CLAUSE TBL record, the search record is
CNT_CLAUSE _TBL, and the field to which you want to apply the from and through search logic is
CONTRACT CLAUSE.

3. Create a new view that contains the same fields as the original search record.

To use the from and through search logic, the search record must be a view. If the search record is
already based on a view, you can modify the existing view instead of creating a new view.

4. Select the From Search Field property for the field.

In the new view, select the from search field and apply the following record field properties: Key,
Search Key, and From Search Field (List Box Item is optional).

5. Create a new field with exactly the same attributes as the from field.

For example, if CONTRACT CLAUSE represents the field from which you want to search, then
create a field called CONTRACT CLAUSE TO representing the field through which you want to
search.

6. Insert the new field directly below the original field.
7. Select the Through Search Field property for the field.

Select the new through search field and apply the following record field properties: Key, Search Key,
and Through Search Field only.

8. Update the SQL view text.
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Update the SQL view Select statement in the new view to reflect the new column. That is, the view
text should select the same field twice in a row (as shown in the example that follows this procedure)

because the same field is used for the from logic and the through logic.
9. Save and build the new view.
10. Update the component properties.

You must update the search record so that the component uses the new view.
11. Test the new search page.

The search page should now include the new through field so that the user can specify a range of
values for the field. Because you want to search on both fields, you must use an advanced search.

The results in the list box should reflect a range of values between the from and through fields that

are specified. The results are inclusive: they include the minimum and maximum values that the user

specified.

Example of Updating the SQL View Select Statement

After you define a search field as a Through Search Field, you need to update the SQL view text, as
shown in this example:

This example illustrates the fields and controls on the Example of updating the SQL view Select
statement. You can find definitions for the fields and controls later on this page.

=i CONTACT_ALL_¥W (Rec

Fecond Fields Eecord Type I

—Record Type- N CONTACT_ALL_¥W.2 (S

(e

Tempora

€ SOLTAE ([default] |
& SOLYiE [T sELECT DISTINCT setid
) Dynamic ;, contact_id
. ; hamel
€ Deyed! FROM ps_contact
£ SubRec: WHEFE eff status = 'A'
-~
r-

Setting Record Field Edit Properties

Copyright

The Edits tab enables you to specify whether the system is to perform special edits or validations on
a record field. You also name the record definition for the prompt table that stores the valid values, as
shown in this example:
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This example illustrates the fields and controls on the Example of the Record Field Properties dialog box:
Edits tab. You can find definitions for the fields and controls later on this page.

Record Field Properties D_(l

Uze | Edits |

Fiegld Marme:
[ ] Required
Edit Type:
(Mo Edit (%) Table Edit
Table Edit:
Type: | Frompt Table E dit w |

Frompt Table: | W |

Set Contral Field:

Dizplay in Autocomplete 'Windov

] l [ Cancel

Field or Control Description

Required Select if you do not want users to skip a field or leave it blank.

Users are unable to save their work until they complete all of
the required fields on a page.

Note: The system only checks required fields when the page
field is changed or the record buffer is changed.
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Edit Type

Field or Control Description

No Edit Select if you do not want to edit the contents of this field
against a table. This value is the default; it makes the options
in the Table Edit group box unavailable.

Table Edit Select to edit the contents of the field against the values that
are maintained in the specified table. When you select Table
Edit, the Type field becomes available in the Table Edit
group box.

Display in Autocomplete Window Select to make this field appear in the autocomplete list.

This property is enabled for date, Datetime, time, character,
number, and signed number fields if the following conditions

are met:
e The field is a list box item.

e The field is not a search item.
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Field or Control

Description

Type

Select from the drop-down list box:

Prompt Table with No Edit: Provides users with a list of
suggested values but does not edit the contents of the field
against the prompt table. Users can enter any value. Selecting
this option makes the Prompt Table field available.

Prompt Table Edit: Edits the contents of the field against

the values that are maintained in the specified prompt table.
Selecting this option activates the Prompt Table field. When
you enter a prompt table name and exit the field by pressing
the tab key, the Set Control Field is activated.

Translate Table Edit: Edits the contents of the field against
the translate table. The translate table stores values for fields
that must be validated but do not need individual tables of
their own. If you select this option, the Prompt Table and Set
Control Field fields become unavailable.

Yes/No Table Edit: Makes the values for this field Y (yes) and
N (no) only. If you select this option, Prompt Table and Set
Control Field fields become unavailable.

For this 1/0 table edit, 1=True and 0=False.

Note: The list of available table edit types is dependent on the
field type.

If you add a field (other than with the paste action) to a

record and the field name is already defined in the database
with previously defined translate values, then the system
automatically selects Table Edit and selects Translate Table

Edit as the table type. For both Translate Table Edit and Yes/

No Table Edit, you should follow PeopleSoft design standards,
select Required, and specify a default value for the field in the
Record Field Properties dialog box.
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Field or Control

Description

Prompt Table

Enter the name of the record definition that you want to use as
the prompt table for this field.

If you want the prompt table to vary depending on the context
of the field, indicate a field in the derived or work record
(DERIVED) that contains the name of the prompt table at

runtime. Then, in this field enter %FieldName.

The % is required, and indicates that you are referencing

a derived or work record definition named DERIVED.
FieldName is the name of the field in the DERIVED record
definition.

Set Control Field

Select a set control field that overrides the set control field of
the record definition specified in the prompt table. If you do
not specify a name in this field, the default is the set control
field of the record definition specified in the prompt table.

Reasonable Date

Select if you want the system to test the field value to
determine whether it is within 30 days of the current date. If
the date is out of range, a warning message appears when the
user exits the field.

Moving Fields in the Same Record

You can move fields in a record by dragging a field to another place in the open record definition. In
addition, you can change the visible order of fields by clicking any of the grid headings. In this sample
record definition, the DIM_DATA_ SRC TYPE field is being moved to the location that is indicated by

the red line:

This example illustrates the fields and controls on the Moving field to new position. You can find
definitions for the fields and controls later on this page.

=8 DIM_DATA_SRC {Record)

To move a field in the same record definition:

Copyright © 1988, 2023, Oracle and/or its affiliates.

Record Fields lRecnrd Type ]
Num| Field Hame | Type | Len | Format Short Hame Long Hame |

| 1 |DATA_SAC_MUM Mbr 4 [rput Mbr [rput Mumber

2 |DIMEMSION_ID Char 30 Upper | Dimension Dimenzion/Meazure /bt
| 3 |SEQUENCE_MER l}g Mbr 2 Sequence Sequence Mumber
| 4 |GRYNAME fwy | Char a0 pper Quen Mame Input Mame
| 5 |TREE_MODE Char 20 Upper  |Mode Tree Mode

6 |LEWELS_FROM_TOP Mbr 3 Levels From Top | Lewvels From Top

7 |DIM_DATA SRC_TYPE Char pper Sz Type zion Data Source
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1.

Select the field that you want to move.
Press the Ctrl and Shift keys to select multiple fields at once.
Drag the selected field number to the new position in the record definition window.

A red line between rows indicates the new placement options as you drag the field. The Num column
automatically renumbers the fields.

Note: The fields are reordered only in the visible display of the record definition, not in the actual
table.

Moving Fields to Another Record Definition

To move fields from one record definition to another, you can cut and paste the fields. You can also drag a
field from the project workspace into a record definition in the object workspace or between open record
definitions.

To move a field from one record definition to another:

1.

2.

Open the two records between which you want to move the field.
Select the field that you want to move.

Move multiple fields by using the Ctrl or Shift key.

Select Edit > Cut.

If this is the correct field to cut from the record, click Yes.

Select the new position for the field in the destination record.

Select Edit > Paste to paste the field into the new record definition.

Note: PeopleCode that is associated with fields is not carried over with cut and paste operations. The
same is true for delete and undo with field deletions in records. Record field attributes, such as key, search
key, and so on, are retained.

Deleting Fields From a Record Definition
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To delete a field from a record definition:

1.

Select the field that you want to remove and press the Delete key.

This action deletes the field completely and does not copy it to the clipboard, unlike a cut operation,
which does copy it to the clipboard.

When the system prompts you to confirm the deletion, click Yes.

If you already created the underlying table for the record definition from which you are deleting the
field, recreate the table or use the SQL Alter function to alter the table.

Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 6 Creating Record Definitions

Important! If you delete a field from a record definition, you must also delete it from any pages on
which it appears. When you delete a field, the system does not automatically delete references to
the field in PeopleCode, so you must do this manually. To determine where the field is referenced in
PeopleCode, use the Find Object References feature.

You can also reference the following two reports: "Fields and Records" (XRFFLRC) shows which
records contain the field; "Fields Referenced by PeopleCode Programs" (XRFFLPC) shows
PeopleCode that refers to the field in the record.

Modify or remove PeopleCode when you find references to the deleted field.

Renaming Record Definitions
To rename a record definition:
1. Select File > Rename.
The Rename Definition dialog box appears.
2. Select Record from Definition Type.
3. Click Rename.
4. Select the record and click Rename.
A rectangular box appears around the name.

5. Enter the new name and press the Enterkey.

Results of Renaming Record Definitions

When you rename a record definition, the system automatically renames all references to it, including
data in tables with columns named RECNAME where the data matches the record being renamed.

The only references that are nof renamed are the text portion of SQL functions, such as SQLExec
and Scroll Select, and the record names in the view text. To find the text portion of SQL functions in
PeopleCode or record names in view text, select Edit > Find In to search for matching text.

If you already created the underlying tables for the record definition that you renamed, recreate that table.
To preserve data in the tables, use the SQL Alter function to rename the database tables.
Deleting Record Definitions
To delete a record definition:
1. Select File > Delete.
2. Select the record definition to delete.

3. Click Delete.

Warning! When you delete a record definition, the system automatically deletes any PeopleCode that
is associated with the record.
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4. Click Yes if you really want to delete the record definition.

Note: Notify your database administrator about which record definition you deleted so that the
administrator can drop the underlying SQL table and its contents from the database.

Printing Record Definitions
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You can print your record definitions as references identifying all of the fields and their various attributes
—any special use, edits, or PeopleCode that you applied.

To print a record definition, it must be open in the object workspace.

To print a record definition:

1. Select File > Print Setup to change any of the print record defaults.

The system retains your changes until you reset them again. The Print Setup dialog box appears.

2. Select printing options.

Field or Control

Description

Definition Print a picture of what the definition looks like.
PeopleCode Select if you want the report to include a listing of any
PeopleCode programs that are attached to each field,
identifying the program type and listing all of the
PeopleCode statements. Selected by default.
Graphics Not used for record definition printing.

Margins(mm) [margins (millimeters)]

Set the distance (in millimeters) from the edge of the page
to the left, right, top, and bottom edges of the page image or
report. The defaults are: 20 (top), 5 (bottom), 5 (left), and 0

(right).

Header

Print a header at the top of the report indicating the date and
time at which you printed the report and the database name,
record name, version number, and page number. Selected by
default.

Footer

Print a footer at the bottom of the report indicating the date
and time at which you printed the report and the database
name, record name, version number, and page number.
Deselected by default.

Border

Print a border or box around a record definition report.

To print reports faster, clear this check box so that the
printer can print the report in character mode, rather than in
graphics mode. Deselected by default.
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Field or Control

Description

Border Space(mm)

Insert a set amount of space between a graphical boarder
around the record definition report and the margins of the
report. The default value is 3.

3. Click OK when you are done, to close the Print Setup dialog box and save your settings.

4. Select File > Print.

Record Definition Report

The following table lists the columns in the record definition report and their contents:

Column Contents

Field Name The name of the field.

Type The field type.

Length The length of the field (not specified for long character fields).
Format The field format.

Long Name The 30-character name of the field.

Short Name The 15-character name of the field.

Key Identifies key attributes (characters defined by position).

Req (required) Yes indicates that the field is required.

TbIEdt (table edit) Prompt: Field values are edited against a specified prompt

table.
Y/N: The field uses the Yes/No Table.

Xlat: The field has values in the translate table. Values (if
printed) are listed below the field.

AU (auto-update)

Yes indicates that the auto-update option is enabled.

Dt (date)

Yes indicates that the reasonable date option is enabled.
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Column Contents
PC (PeopleCode) Yes indicates that the field contains PeopleCode. PeopleCode
text (if printed) appears below the field.
Aud (audit) Yes: The field audit flag is enabled.
A: Audit add.
C: Audit change.
D: Audit delete.
Prompt Table The name of the prompt table.
Default Value Any default value or constant.

You might also see these additional reference lines below each field or at the end of the report:

Reference

Description

SQL View

Shows the SQL view Select statement for view-type record
definitions. This appears at the top of the report.

System Maintained

Indicates that the System Maintained check box is selected.
Because this option is for documentation purposes only, it
doesn’t warrant its own column heading.

DbField Help Context: nnn

Indicates that the field has been assigned a field help context
number to link it to a help file that describes how the field is
used wherever it appears in the database.

RecField Help Context: nnn

Indicates that the field has been assigned to a record field help
context number to link it to a help file that describes how the
field is used only as it appears in this record definition.

Audit Record Identifies a user-defined audit record. Lists the audit record
name and the type of audit.
Set Control Field Identifies a set control field that is designated for the record

definition.

Related Language Record

Identifies a related language record that is designated for the
record definition.
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Reference Description

Query Security Record Identifies views that are used to restrict query access to data
that is stored in the table.

Parent Record Name Identifies the hierarchical relationship of the record for query
reporting.

Printing records with subrecords takes into account whether the record view is expanded or collapsed. If
the record view is expanded, the subrecord fields are indented to the appropriate level of nesting.

Creating SQL View and Dynamic View Select Statements

If you are creating a SQL view or dynamic view record definition, you must enter a SQL view Select
statement to indicate which field values you want to join from which tables. The only difference between
the standard view and dynamic view is that the dynamic view is not defined as a view to the database; it
is stored on the client and run as a Select at runtime. Dynamic views avoid some constraints on views on
some platforms.

Field or Control Description

Non-Standard SQL Table Name Override the standard convention of prefixing each record
name with PS .

Build Sequence No (build sequence number) Set the order in which the view is to be created. The default
value is / when the record or view is initially created. Views
that must be created first can be set to 0, while views that you
want created last can be set to any number from / to 99. The
build sequence number is stored with the other details of the
record or view in the database.

Click to open SQL Editor The view text is saved when the record is saved by selecting
File > Save. The record must be saved first, before you open
the SQL Editor.

As a general guideline, the SQL used for dynamic views should be as simple as possible because the
runtime system appends WHERE clauses to the SQL definition to add key field lookup criteria and does
not parse the dynamic view SQL definition to find correlation names. For example, we do not recommend
the following format:

SELECT...FROM(SELECT * FROM...WHERE...)

Rather than having a WHERE clause in the subquery, one approach would be to create a static view that
the dynamic view references. For example, that static view might be:

ABC_PRD_INS VW as
SELECT B.SETID AS SETID

, A.BO_ID CUST AS BO ID CUST
, A.INST PROD ID AS INST PROD ID
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, B.PRODUCT_ID AS PRODUCT ID
, B.DESCR AS DESCR
, A.SERIAL ID AS SERIAL ID
A.INSTALLED DATE AS INSTALLED DATE
"FROM PS_RF INST PROD A
, PS_PROD ITEM B
, PS_RF_INST PROD ST C
, PS_PROD PGRP LNK D
WHERE A.SETID = B.SETID
AND A.PRODUCT ID = B.PRODUCT ID

AND A.SETID = C.SETID

AND A.INST PROD ID = C.INST PROD ID
AND C.INST PROD STATUS <> 'UNI'

AND A.SETID = D.SETID

AND A.PRODUCT ID = D.PRODUCT ID
AND D.PRODUCT GROUP = '00'

Which is referenced by the dynamic view:

SELECT SETID
,BO_ID CUST
, INST PROD_ID
, PRODUCT ID
» DESCR
, SERIAL ID
, INSTALLED_DATE
FROM PS ABC PRD INS VW
WHERE SETID = :1
AND BO_ID CUST = :2
AND INST PROD ID = :3

Chapter 6

Note: The order of the columns in the Select statement must be identical to the field order in the
corresponding record definition. Also, only certain types of meta-SQL statements can be used in view

text.

Note: Related language records should not use dynamic views but should be limited to physical views

and records.

Related Links
Using Cross-Platform Meta-SQL for Dynamic Views
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Understanding Data Administration and the Build Process

Using PeopleSoft Application Designer, you create several kinds of definitions that represent database
components. For instance, field definitions represent table columns, and record definitions represent
tables and views. From these field and record definitions, you can create tables, views, and indexes.

The important concept to remember is that the definitions are just the blueprints for the actual, physical
database components with which they are associated. In the context of the entire application development
cycle, use the Build process to create SQL tables, views, triggers, and indexes after you define new fields
and create the record definitions. After you build the SQL tables, you begin creating page definitions.

After you create and define your field and record definitions, you must create or build the underlying SQL
tables that house the application data that your users enter online in your production environment. The
Build process is the centerpiece of the data administration features in PeopleSoft Application Designer.
The Build process uses DDL to construct a physical database component that is based on the associated
record and field definitions that you created. Using the Build feature, you can create:

* Tables.
* Indexes.
*  Views.
» Triggers.

You can also use the Build feature to alter existing tables if you change the record definition after the
table already exists. Altering a table is useful, because it enables you to make changes without losing

the application data that is already housed in the table. In general, the results of the build operation are
written to a script file that a database administrator can run later. On some database platforms, you can
run the SQL online, if you prefer, so that your changes are immediately reflected in the physical database.
However, if you run the SQL immediately, you cannot review it to make sure that the table that was built
truly meets all of your requirements.

Before you begin using the data administration tools and running a build process, make sure you:
* Review what DDL means for PeopleSoft applications.

*  Grant build authority.

Reviewing DDL

DDL is the part of SQL that pertains to the creation of tables, indexes, views, triggers, and tablespaces.
DDL is also the part of SQL that differs most between the various relational database platforms. Each
database vendor provides different syntax and configuration options for creating and organizing tables
and for optimizing performance. Because PeopleTools supports multiple database platforms, PeopleSoft
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developers designed a flexible way of specifying DDL that enables you to take advantage of each
vendor’s features. The basic components of the PeopleSoft DDL support include the following:

» DDL model definition: A complete set of the supported DDL statements for each database platform.

Statements include Create Table, Create Tablespace, and Create Index. Each DDL model statement
has substitution parameters that can be specified at the database level or overridden for individual
records.

* Record DDL: Specify the DDL model substitution parameters for an individual record.
* Index DDL: Specify the DDL model substitution parameters for an index.

» Sizing sets: A way to maintain multiple versions of your DDL model statements for a database
platform.

For example, you can use one sizing set during a development phase, when tables have only test data,
and another during production, when tables have more data.

Granting Build Authority

PeopleSoft Security enables you to specify which users can build scripts, run scripts (Execute SQL now),
maintain DDL, and so on. Access Security from the PeopleTools link in the menu.

Related Links

“Setting PeopleTools Permissions” (Security Administration)

Running the Build Process

This section provides an overview of the Build menu and discusses how to:
* Select the build scope.

e Select build options and run the Build process.

Understanding the Build Menu

Access all of the commands and options that are associated with building tables, views, indexes, triggers,
and altering tables from the Build menu. When you choose to build an item from the Build menu, the
tasks for creating or running SQL scripts that define the underlying database components are included in
the Build dialog box.

200 Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 7

Build

Build Scope

QE_ORG_ADR_DATA
OE_ORG_ADR_POP
QE_ORG_DT_14 DR
OE_ORG_DT DR
OE_ORG_MNFIC_DRY
QE_ORG_SCH_DRY
OE_ORG_SCHZ
BE_ORG_SCHZ_DRY
OE_ORG_Z2 DRV
OE_ORG_Z3 DRY
QE_ORG_Z00M2
OE_ORG_Z00M3
QE_PCCORD
QE_PCCURT
OE_RATEBOX_DR
OE_RE_TALENT 4w/

Cancel

IIIM

Settings...

Build Ophions

[ ] Create T ables

[] Create Indexes

[ ] Create Yiews

[]aer Tables

] Create Trigger

Build Execute Options

) Build script file

) Execute SGL now

(%) Execute and build script

Copyright © 1988, 2023, Oracle and/or its affiliates.

Administering Data

This example illustrates the fields and controls on the Build dialog box. You can find definitions for the
fields and controls later on this page.

The settings for the Build process in the Build Settings dialog box enable you to configure various
aspects of the process. Depending on which build option you are running, your settings vary. The Build
Settings that you select are stored on your workstation so that they can be reused during future PeopleSoft
Application Designer sessions. Access the Build settings by selecting Settings from the Build menu in
PeopleSoft Application Designer or click theSettings button in the Build dialog box.
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This example illustrates the fields and controls on the Build Settings dialog box. You can find definitions
for the fields and controls later on this page.

Build Settings §|
Create | Alter | Logging || Scripts

Table Creation Dptions
) Recreate table if it aleady exists

(%) Skip table if it already exists

Wiew Creation Optionz
(%) Recreate view if it already exists
(3 Skip view if it already exists

|ndex Creation Options
() Recreate index if it already exists

(%) Recreate index only if modified

[ ] 4 l [ Cancel

When you select the Create Tables, Create Indexes, or Create Views options in the Build dialog box,
specify the appropriate options on the Create tab of the Build Settings dialog box. For example, you might
need to specify whether an existing table, view, or index is skipped or dropped and then recreated.

If you modify your record definitions, the tables in your production database should reflect those changes
to maintain your data integrity. When you alter a table, select the appropriate options, such as the options
in the Drop Column Options area on the Alter tab of the Build Settings dialog box.

You can monitor the Build process by reviewing the log files that it automatically generates. Keep in
mind that the log file is entirely separate from the script file. The amount of information that the log file
contains is up to you. You can set up logging so that all statuses (both good and bad) appear in the log, or
you can specify that only errors or warnings appear in the log. Control the settings for the Build log file
(such as the logging level and the location for the output log file) on the Logging tab of the Build Settings
dialog box.

If you build a script file, then the Build process generates a script file that contains all of the CREATE
and ALTER SQL statements so that you can review them before running the SQL through another SQL
command processor. If the generated script file meets your requirements, a database administrator (DBA)
can run the script later. The Build process can produce multiple scripts during a single run—one for each
build option—depending on the script settings that you specify at runtime. For example, you can specify
that the Build process generate a separate script for your tables, views, indexes, triggers, and alters, or you
can have all of the SQL for each action contained in one script. Use the Scripts tab of the Build Settings
dialog box to specify where the SQL script is written, whether you want multiple scripts generated for
each definition type, and whether you want previous scripts overwritten.
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Selecting the Build Scope

The Build feature includes three different scopes that determine the size of your build project. Depending
on what you actually want to build—one record or an entire project—you can determine the scope by
selecting one of the scopes described in the following topics.

Current Definition

Select Current Definition from the Build menu to build or alter the active record definition. Active
definition means the definition that is currently active in the definition workspace.

Project

Select Project from the Build menu to build or alter all of the records, indexes, triggers, and views in
the current project—that is, all of the records that appear in the project workspace. You typically find
numerous record definitions in the Build Scope list box.

To build all definitions in a database, create a new project and insert all of the appropriate records. For
example, insert records of a particular type, such as views. If you create another record after the al/
records project is built, you must manually add the new record to the project.

You may also build a project using the command line and specific parameters. The prerequisites for using
the command line to build a project are:

* The project exists with all objects.

e The build settings need to be set in the Windows registry.

Note: The Build Project process accesses every single record that is in the project, including work
records, even if they are marked to be deleted.

Select Definitions Into Project

In some situations, you might want to build a subset of the records in the project that is currently open. If
you do not want to build an entire project or even the current project, you can build only the definitions
that you select in the project workspace by pressing the Ctrl key and selecting multiple records in the
project workspace. After you select the appropriate records, right-click and select Build from the pop-up
menu. Only the definitions that are selected in the project workspace appear in the Build Scope list box.

Note: You must invoke the Build process from the pop-up menu; you cannot build selected definitions
from an open project using the Build menu.

Selecting Build Options and Running the Build Process

Copyright

Access the Build dialog box.
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Field or Control Description

Build Scope This list box displays all of the definitions that are included in
the current Build process. The records that appear in this list
box cannot be selected or deselected. If you must narrow the
scope of your build, do so before accessing the Build dialog
box.

Build Click this button to start the Build process. While the Build
process is running, the Build Progress dialog box appears,
showing the current record being processed, the record number
being processed in the series, and the total number of records
that comprise the build. To stop a running Build process, click
the Cancel button. When the Build process completes, the
Cancel button is unavailable, and the Close button is the only
valid button.

Settings Click this button to open the Build Settings dialog box, where
you can view or change your options.

Note: After the Build process begins, no runtime prompts appear until the process is complete. All events
are written to the Build log.

Build Options

The Build Options group box enables you to specify what action you want to occur: Create Tables,
Create Indexes, Create Views, Alter Tables, or Create Trigger. If you select Create Tables or Alter
Tables, Create Indexes is automatically selected by default. Also, if you select Alter Tables, Create
Indexes and Create Trigger are automatically selected by default.

Note: You can select both Alter Tables and Create Tables to run concurrently if the Skip table if it
already exists option is enabled on the Create tab in the Build Settings dialog box. Otherwise, the system
cannot determine whether you want to alter or recreate a table that already exists.

Build Execute Options

Field or Control Description

Build script file Select this option to review and update the SQL before
running the script. This method is the safest.

Execute SQL now Select this option if you do not want to invoke another
program to run the SQL; the SQL runs as part of the Build
process. The disadvantage of running the SQL immediately
is that you have no opportunity to review the SQL before it is
committed to the database.
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Field or Control Description

Execute and build script Select this option to review the SQL that the Build process just
ran.

To run the SQL script file that the Build process generates, you must use a third-party SQL tool, such
as Oracle SQL Developer or Microsoft ISQL/W. Most database vendors include a native command
processor that you can run on the client or the server.

Note: The Execute SQL now option is unavailable if you use the Alter Tables Build option. However,
you can use the Execute and build script option when using Alter Tables. Selecting this option builds a
script with the entire altered SQL. This script may help if errors are encountered during the alter process.
However, if an alter process has multiple tables and an error occurs, the errors are reported to a log file
and the process continues to the next table.

Creating Tables

This section provides an overview of the Create Table process and discusses how to:
* Create a table.

* Specify Create options.

*  Specify Logging options.

*  Specify Script options.

¢ Confirm a table build.

Understanding the Create Table Process

The Build process generates the appropriate SQL Create statements to build tables based on both your
record definition and your platform. It prefaces each new application SQL table with PS to identify it as
an application that was built using PeopleTools. For example:

PS ABSENCE HIST

Note: PeopleTools does not preface table names with PS _if you specified a custom name in the Non-
Standard SQL Table Name edit box located on the Type tab of the Record Properties dialog box.

The Build process also creates the appropriate indexes. Because long-character fields operate more
efficiently in some database environments when they are located at the end of a table, the Build process
automatically positions long-character fields at the end of the table for each database environment.

The Create Table process creates a new application table based on parameters defined in the record
definition. When a new table is created, the database management system updates the system catalog
tables to reflect the attributes of the new table.
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The Create Table process is illustrated by the following diagram:

The following diagram illustrates the process of Create Table that creates a new application table based on
the parameters defined in the record definition

Database Server

Catalog <—— A, Create the application data
bles table and indexes based on record
: definition parameters.

eTools ~ | B.

bles A. B. Update the system catalog
4J tables to reflect the new
| application data table and
cation indexes.

Tables

After you create an updated SQL build script and run it, the PeopleTools tables and the system catalog
tables are synchronized; and the record definition and the application data table are synchronized. The
following table lists the steps of the Create Table process and the associated record definition parameters:

Create Table Process Record Definition Parameter Usage
Drop the table if it already exists. NA NA
Create the application data table. Record definition name. Table name (add PS_ prefix).
Field names. Column names.
Field type. Column type.
Field length. Column length.
Create indexes. Key fields. Unique index: ()
Alternate search key fields. Alternate index: 10 (0-9) per table.
Custom indexes. Custom index: (A—V) per table.

The following procedure covers all of the high-level steps that you need to successfully complete for the
Create Table build process. Steps that involve a variety of options include links to the area where those
options appear in this product documentation.

Note: You can have a maximum of 500 columns per table.

Creating a Table
To create a table:

1. Open the project for which you want to build SQL tables.
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2. Select Build > Project.
3. From the Build menu, select the appropriate scope of your build.

See Selecting the Build Scope.

The Build dialog box appears.
4. Select the Create Tables in the Build Options group box.

PeopleSoft Application Designer automatically activates the Create Indexes option. If you are
rebuild or recreate tables, then the indexes that the system uses to extract information from those
tables must also be updated. Definitions to be built appear in the Build Scope list box, which does not
allow you to edit, remove, or add definitions.

5. Select one of the Build Execute options.

The default option builds an SQL script file containing the commands to run the selected build
options.

6. Click the Settings button in the Build dialog box to set user-defined defaults.
The Create tab in the Build Settings dialog box appears.
7. Select the appropriate settings on the Create tab.

See Specifying Create Options.

Recreating a table removes all data contained in the table as well as views or grants referencing that
table.

8. Select the Logging tab.

9. Set the Logging Levels and associated options.
See Specifying Logging Options.

10. Select the Scripts tab.

11. Specify the script file options.

If you selected Execute SQL Now as your build option in the Build dialog box, you can skip the
Scripts tab because you will run the SQL online. Settings on the Scripts tab are relevant only if you
are building a SQL script to run later.

See Specifying Script Options.

12. Click OK to close the Build Settings dialog box.
13. In the Build dialog box, click the Build button to run your build option.

The length of a Build process depends on the number of definitions that require building. Watch the
Build Progress dialog box to monitor the Build process. When the process completes, check any
errors listed in the log file.
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Specifying Create Options
Access the Build Settings dialog box and select the Create tab.

This example illustrates the fields and controls on the Build Settings dialog box: Create tab. You can find
definitions for the fields and controls later on this page.

Build Settings [‘S_<|

Create | Aller | Logging | Seripts

Table Creation Options
() Recreate table if it already exists

(%) Skip table if it aleady exists

Wiew Creation Optionz
(%) Recreate view if it already exists

() Skip view if it already exists

|ndex Creation Optiohs
() Recreate index if it already exists

(%) Recreate index only if modified

] 4 l [ Cancel

Table Creation Options

These options determine when a table should and should not be created.

Field or Control Description

Recreate table if it already exists Select to drop and recreate a table if it already exists. Select
this option with extreme care because if data already resides
in the table, it is also dropped. If you select this option, the
Build process prompts you to confirm your intention before
performing any destructive action. If you do not care about
losing the data that resides in the table, then this option is
faster than the Alter Tables option.
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Field or Control

Description

Skip table if it already exists

Select to create only newly defined tables. If you want to
preserve the data that already resides in existing tables or
if you are only interested in creating the tables that do not

already exist, select this option.

View Creation Options

Similar settings are available for creating views that you use for creating tables.

Field or Control

Description

Recreate view if it already exists

Because views are only logical views of data, you can safely
select this option; you do not run the risk of losing physical
data. Using this option ensures that all views in the project are

rebuilt, whether they need to be or not.

Skip view if it already exists

If you are concerned only with creating views that do not
already exist in the database, select this option. This option is
useful if you want to run Build Project on a large project and
only a subset of the views in the project must be created. This
option consumes less time than recreating all of the views in

the project.

Index Creation Options

These options determine when an index should be recreated.

Field or Control

Description

Recreate index if it already exists

Select to recreate the index for your tables, even if you already
have one in place. This option recreates the index no matter

what the situation.

Recreate index only if modified

Select to recreate the index only if the data in the indexes is
being modified.

Specifying Logging Options

Access the Build Settings dialog box and select the Logging tab.
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This example illustrates the fields and controls on the Build Settings dialog box: Logging tab. You can
find definitions for the fields and controls later on this page.

Build Settings

Create | Alter | Logging |Sn:ri|:|ts

X

Logaing Lewvel

) Fatal ermors only

(%) Fatal enors and warnings

() Fatal erors, warkings and informational meszages

Logging Clutput

0g o output window 0g zettings
[+] Log to output wind [F] L t
Lag to file

Log file name: CATEMPAPSBUILD.LOG

Ok

l [ Cancel

Logging Level

Specify the level of detail of information that you want in your Build log output.

Field or Control

Description

Fatal errors only

Select this option if you want to see only the operations that
failed.

Fatal errors and warnings

Select this option to add warnings to the fatal errors.

Fatal errors, warnings and informational messages

Select this option to see all the definitions that processed
successfully and all of the errors and warnings.

Note: These options are personal preferences and do not affect the actual build of your SQL tables, but
they might help you track down potential failures. For example, if you are processing a large number of
definitions, you will want to see only the operations that failed. Whereas, if you are processing a small
number of definitions, you will want to see all of the successful operations, too.
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Specify where and in what form you want to view your log output.

Field or Control

Description

Log to output window

Select to write the same information that appears in the log
file to the PeopleSoft Application Designer output window.
Always be aware of the level that you select. If you expect a
lot of detail (high logging level plus many records to process),
you may want to copy the logging information to a file and
print it later.

Log to file

Select to write the log to a file. If you select this check box,
you can specify a location and name for your log file in

the Log file name edit box. To search for a name, click the
Browse button. Select a .LOG type file from the Build File
Selection dialog box. If you do not select this check box, the
edit box is unavailable for entry.

Log settings

Select to write all of the runtime options to the log. If you
select this check box, you do not need to rerun a test when you
have a problem. If you must report a problem with the Build
process or troubleshoot, you need to know the settings that
were active.

Note: You should select the Log to file check box and the Log to output window check box with a
minimum logging level of fatal errors and warnings. In case you run into a problem, you already have the
information you need to research the problem. Otherwise, you must run the process again with a higher

logging level.

Example Log Results

The following are samples of the type of information that you can expect to see in your log output that
corresponds to the selections that you make on the Logging tab:

* Fatal errors:

SQL Build process began on 7/30/2003 at 8:46:46 PM for database
OM51U020

Error: BI BILL BY F VW - Unable to retrieve current DDL space name.
Alter processed failed. (76,47)

Error: BI CHARGE VW - Unable to retrieve current DDL space name.
Alter processed failed. (76,47)

Error: PS BI CYCLE VW - alter failed due to an unknown column type
(UNDEFINED) found for field BILL CYCLE 1ID. (76,22)

Error: PS BI IVCLAYOUT VW - alter failed due to an unknown column
type (UNDEFINED) found for field INVOICE LAYOUT ID. (76,22)

Error: CARINA - alter failed because SQL table does not exist. (76,7)
SQL Build process ended on 7/30/2003 at 8:54:34 PM.

2487 records processed, 11 errors, 0 warnings

SQL Build script for all processes written to file C:\TEMP\step38.SQL.
SQL Build log file written to C:\TEMP\step38.LOG
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Warnings:

SQL Build process began on 8/27/2003 at 4:00:32 PM for database DXD7L
Warning: ABSENCE HIST2 - data would be truncated by altering
REASON. Record processed. (76,24)

Fatal errors, warnings, and informational messages:

SQL Build process began on 8/27/2003 at 3:58:58 PM for database DXD7L
Warning: ABSENCE HIST2 - data would be truncated by altering

REASON. Record processed. (76,24)
Error: ABSENCE HIST2 - field PAID UNPAID to be deleted has data
present. Record skipped. (76,23)

Informational: ACCOMPLISHMT VW - view created and scripted
successfully. (76,18)

Informational: ACCT AD2 INV VW - view created and scripted
successfully. (76,18)

Informational: ACCT ADJ INV VW - view created and scripted
successfully. (76,18)

Informational: ACCT ISS INV VW - view created and scripted
successfully. (76,18)

Informational: ACCT STK INV VW - view created and scripted
successfully. (76,18)

Informational: ACCT TYPE VW - view created and scripted
successfully. (76,18)

Informational: ACTION SP VW - view created and scripted
successfully. (76,18)

Informational: ACTION XLAT VW - view created and scripted
successfully. (76,18)

Informational: ADJUST INV2 VW - view created and scripted
successfully. (76,18)

Informational: ADJUST INV VW - view created and scripted
successfully. (76,18)

11 records processed, 1 errors, 1 warnings

SQL Build script for all processes written to file
C:\TEMP\PSBUILD.SQL.

SQL executed online.

SQL Build log file written to C:\TEMP\PSBLD.log
Log settings:

*x%*%* Begin Build Settings for this Run

Create Tables = No

Create Indexes = Yes

Create Views = No

Create Triggers = Yes

Alter Tables = Yes

Log to File = Yes

Log to Window = Yes

Write comments to script = No

Always overwrite files = Yes

Execute SQL Now = No

Write SQL to script file = Yes

Logging level = Log fatal errors, warnings and informational messages
Table creation option = Skip table if it exists

View creation option = Drop and recreate view if it exists
IndexCreationOption = Drop and recreate index always

Alter Adds = Yes

Alter Changes = Yes

Alter Renames = Yes

Alter Deletes = Yes

Alter even if no changes = No

Alter Table Option = Alter by Table Rename

Write script output to: Single file

Log filename = c:\temp\PSBUILD.LOG

Single script filename = c:\temp\PSBUILD.SQL

Alter drop column option = skip record if data present
Alter truncate column option = skip record if data would be truncated
Target database platform = MICROSFT

Chapter 7
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Target sizing set = 0

Working With the Output Window

You can navigate from error messages in the PeopleSoft Application Designer output window to the
corresponding record definition by selecting the appropriate line in the Build log and double-clicking
anywhere on that line. PeopleSoft Application Designer opens the corresponding record in the definition
workspace.

Also, you can double-click any line in the output window that corresponds to a file, not just a record.
PeopleSoft Application Designer opens that file with whatever application that you defined to open files
with a particular extension. For example, if you associated SQL files with your native SQL command
utility, then your SQL utility opens and loads your PSBUILD.SQL script when you double-click the line
that reads:

Single script file name = C:\Temp\PSBUILD.SQL

Note: PeopleSoft Application Designer uses the standard Microsoft Windows method for defining which
programs are associated with particular file types. To modify the file associations, open My Computer,
select Tools > Folder Options and then select the File Types tab.

Specifying Script Options

Access the Build Settings dialog box and select the Scripts tab.

This example illustrates the fields and controls on the Build Settings dialog box: Scripts tab. You can find
definitions for the fields and controls later on this page.

Build Settings §|

Create | Aler | Logging | Scripts

Comments Script File
[ ]'white Alter comments to script Save as Unicode

Script File Options File Owerwrite Options
(&) Output to single file (%) Always ovenwrite
(3 Output to zeparate files (" Prampt far each overwrite

Scrpt File Mames

Al Dutput File Manne: C:ATempPSBUILD.SGL [:]

ak. l [ Cancel
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Comments

The Write Alter comments to script check box enables you to either include or suppress alter
comments. The following example displays the types of comments that you see in your PSALTER.SQL
script if you enable this option:

-- Alters for record PS_AE RUN_CONTROL ;
-- AE THREAD - change ;

—-= OPRID - change ;

—-—- Start the Transaction ;
-- Data Conversion ;

-- Drop 0ld Indexes ;

DROP INDEX SYSADM.PS AE RUN CONTROL
/

-- Add Columns ;

ALTER TABLE PS_AE RUN CONTROL ADD Z TMP ALTER 1 DECIMAL(12,4)
/
ALTER TABLE PS_AE RUN CONTROL ADD Z TMP ALTER 2 CHAR(12)
/
UPDATE PS_AE RUN CONTROL SET
Zz_TMP ALTER 1 = AE_ THREAD,
Z_TMP_ALTER 2 = OPRID

/

If you do not view the alter comments, the script containing the same commands as the previous script
looks like this:

DROP INDEX SYSADM.PS AE RUN CONTROL

gLTER TABLE PS AE RUN CONTROL ADD % TMP ALTER 1 DECIMAL(12,4)

éLTER TABLE PS_AE RUN CONTROL ADD % TMP_ ALTER 2 CHAR(12)

/

UPDATE PS_AE RUN CONTROL SET
Z TMP ALTER 1 = AE THREAD,
Zz_TMP_ALTER 2 = OPRID

Script File

The default for the Save as Unicode check box is based on the UNICODE/ANSI database. This check
box is available when using Oracle, Microsoft SQL Server, and Db2 for z/OS databases.

The following table lists the default settings for the Save as Unicode check box:

Database Type Default for Save as Unicode Check Box
Unicode Selected
ANSI Unavailable
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The script file option, Save as Unicode, is stored in the registry with the other build settings. Therefore,
the previous setting is always the default every time that the dialog box is opened.

The type of script file that is generated during the Build process is based on the Save as Unicode check
box setting for the UNICODE/ANSI build and UNICODE/ANSI database. This table lists details:

Database Platform Unicode ANSI
SQL Server UCS2 ANSI
Oracle UTFS8 ANSI
Db2 for z/OS UTF8 ANSI

Script File Options

If you want all of your CREATE TABLE statements to be written to one SQL script file and your
CREATE INDEX statements to another, then select the Qutput to separate files option. If you prefer
to have all of your statements, CREATE, ALTER, and so on, contained in a single file, then select the
Output to single file option.

Note: Script files can be quite large. To reduce the size of files so that they are easier to manage, select
the Qutput to separate files option. Also, the system never appends script files; it overwrites them or you
can terminate the process if you elected to be prompted before a build script file is overwritten.

Depending on which output option you select, the options in the Script File Names group box change to
suit one file or multiple files.

File Overwrite Options

These options indicate whether you want to overwrite automatically or be prompted before script files are
overwritten. Your personal preference determines which technique you employ.

Field or Control

Description

Always overwrite

Select to overwrite your previous build scripts.

Prompt for each overwrite

Select to be alerted when a script is about to be overwritten.

To avoid the possibility of overwriting files altogether, you
can use a naming convention that, in itself, prevents any
overwrites. For example, you could specify a unique name for

each build script, as shown:
+  CATEMP\PSINDEX1.SQL

+  C:\TEMP\PSINDEX2.SQL
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Script File Names
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The options available to select in this group box depend on your selection in the Script File Options

group box.

Field or Control

Description

Output to single file

When you select this option, an edit box appears in the Seript
File Names group box: All Output File Name. The default
name for the generated script is PSBUILD.SQL.

Note: Script files can be quite large. To reduce the size of
files so that they are easier to manage, select the Output to
separate files option. Also, the system never appends script
files; it overwrites them or you can terminate the process

if you elected to be prompted before a build script file is
overwritten.

Output to separate files

If you select this option, the following edit boxes appear, one

for each build option:

*  Create Table File Name: The default name for this script
is PSTABLE.SQL.

*  Create Index File Name: The default name for this script
is PSINDEX.SQL.

*  Create Trigger File Name: The default name for this
script is PSTRIGGER.SQL.

*  Create View File Name: The default name for this script
is PSVIEW.SQL.

*  Alter Table File Name: The default name for this script
is PSALTER.SQL.
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This example illustrates the fields and controls on the Output to separate files. You can find definitions for
the fields and controls later on this page.

Build Settings

Create | Aler | Logging | Scripts

Comments

[ 'white Alter comments to script

Script File Options
3 Output to single file
(&) Output to separate files

Script File M ames

Create Table File Mame: | C:ATempiPSTABLE.SGOL
Create Index File Mame: | C:\TemphPSINDER SUL
Create Trigger File Mame: | C:ATemptPSTRIGGER.SQL

Create View File Mame: | C:ATemphPSWIEW SEL

Alter T able File Wame: C:ATemphPSALTER.SGL

X]

Scrpt File
Save az Unicode

File Overwrite Ophions
(%) Always ovenwrite

" Prompt for each ovenwite

0 630 o 630 O 6 A

ok H Caticel ]

Confirming a Table Build

If you are running SQL online, complete Steps 1 and 3; Step 2 is not required.

To confirm a table build:

1. Review the SQL script that was generated by the Build process.

Use your native SQL command processor to open the SQL script. The script is located where you
specified on the Scripts tab of the Build Settings dialog box.

2. Run the script against your database.

3. Confirm that the tables now exist.

Use your query tool and SQL Select statements to confirm that the Create Table process created an
application table that corresponds to your record definition and updated the system catalog tables. The

SQL statement that you use to confirm depends on the table that you just created.

Creating Indexes

This section provides an overview of indexes and discusses how to:
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* Configure indexes.
* Add a custom index.

* Edit the DDL.

Understanding Indexes

218

Indexes are an important part of your physical database because they affect the efficiency and speed with
which your application can store and retrieve data. PeopleSoft application indexes are defined in two
ways.

Some indexes are defined for you automatically, based on the key, search key, list box items, and alternate
search keys that you specified in your record definition. The application processor uses these indexes for
quick access when you use the online system.

However, sometimes you need to define additional indexes to improve the performance of demanding
queries, reports, or batch programs. You define and modify these additional indexes using the data
administration tools in PeopleSoft Application Designer.

Note: You can only create indexes for record definition types that are SQL or temporary tables. You
would not create indexes on views, such as a SQL view, because views are never physically created. The
Indexes option in the Tools, Data Administration menu is disabled when a view is open.

When you use SQL Create or SQL Alter for a table, the system automatically builds database indexes

to the SQL table that are based on the keys and list items that you specify in the record definition. Your
database uses indexes to find definitions in the database the same way that you use indexes to find
specific information in a book. If an index entry exists for a specific field in a table, the database can
search and quickly find what it needs to complete your request; otherwise, it must search the contents of
the entire table.

Indexes enhance system performance by generating key lists that the application processor uses to extract
the data that it uses to populate pages and search records. The system automatically creates:

» Standard indexes (key or duplicate order key indexes) if at least one field in the table is a key or
duplicate order key.

The index contains all key and duplicate order key fields. The system automatically names this index
with a prefix of PS .

* Alternate search key indexes for each alternate search key.

The system automatically names this index with a prefix of PSn, in which #z is a number between 0
and 9.

* Custom indexes, which you can define using the Edit Index, Edit DDL, and Add Index dialog box in
the PeopleSoft Application Designer administration tools.

The system automatically names this index with a prefix of Psa, in which a can be any letter between
A and V. The system does not create custom indexes automatically.

For most database tables (those with unique keys), the key index defines unique keys for a table, but the
system also uses it to access high-level keys and orders by all keys. Alternate search key indexes support
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the search record and field prompts. The purpose of these different indexes is to enable the system to
respond to all system prompts through index-only SQL access, minimizing direct database table access.

Note: If you use Create Table or Alter, the Create Index option is automatically selected. With the
Create Table or Alter options, you cannot deselect the Create Index option.

The alter process takes care of indexes regardless of the Alter Table Options you select on the Alter tab of
the Build Settings dialog box. In the case of the Alter by Table Rename option, the indexes are dropped
automatically when the temporary table is dropped. For the Alter in Place option, the index creation
process goes through the Recreate index only if modified option on the Create tab.

When creating indexes with the Alter method, before altering the table, drop the statistics using "DROP
STATISTICS" that were created explicitly in columns using "CREATE STATISTICS."

The following record definition modifications require you to create new indexes:

* Add, delete, or modify keys, duplicate order keys, alternate search keys, or descending keys in the
Record Field Properties dialog box.

* Change the order of keys (ascending, as opposed to descending) in the Change Record Indexes dialog
box.

* Change the Unique settings in the Edit Index dialog box.

Platform Support for Indexes

Most database platforms support indexes with an unlimited number of keys. However, Microsoft SQL
Server supports indexes that have a maximum of 16 keys only. PeopleSoft Application Designer supports
indexes for these databases by creating functional indexes. If a record definition has more than 16 keys,
the Build process automatically alters the table to support functional indexes. The system adds a warning
message to the log file indicating this.

For Microsoft SQL Server, if an index has more than 16 keys, the key fields are concatenated to a
functional key. This key field is then added to the table as the last column, called MSSCONCATCOL.
A unique index is created for MSSXCONCATCOL as well as an additional index called PSW<record
name>, which is used as a search index.

Note: For the Microsoft SQL Server platform, if your database has tables containing the
MSSCONCATCOL column, you will see SQL to alter the tables and re-create their associated indexes,
even though the underlying tables and indexes may not have changed.

You can find sample code for functional indexes for each of these platforms in the “Understanding
Functional Indexes” topic.

Note: Beginning with PeopleTools 8.54, descending indexes are no longer supported on the Oracle
platform for performance reasons.

Related Links

“Converting Descending Indexes” (Data Management)
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Configuring Indexes
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For performance tuning, you might want to change the order of your index keys. PeopleSoft Application
Designer provides direct control over all of the indexes created by PeopleTools. You can inspect, add,

or change all defined indexes or delete custom indexes for any record in the system through the Change
Record Indexes dialog box.

Standard indexes are based on the key, duplicate order key, or alternate search key only. However, with
the Change Record Indexes dialog box, you can modify those indexes and create additional indexes,
which might be required if you do custom processing. Any of the indexes that you entered can be
maintained for all database platforms or for a list of specific platforms. All indexes and keys created by
PeopleTools are stored in PeopleSoft system tables.

This example illustrates the fields and controls on the Change Record Indexes dialog box. You can find
definitions for the fields and controls later on this page.

Change Record Indexes E|
. . Fecord Fields
Index | Type | Urnig | Clust | Custarn Order| /0 | Key Fields | Platfm
key Voo M T -~ EMPLID ~

&zc [EMPLID EMPL_RCD
Azc |EMPL_RCD EFFDT
Desc |EFFDT EFFSED
Desc |EFFSEQ DEPTID

o |al M N M Al JOBCODE
Asc DEFTID POSITION_MER
Asc ErPLID POSITION_OVERRIDE
Aze |EMPL_RCD POSM_CHANGE_RECOR
Desc |EFFDT EMPL_STATUS
Dezc (EFFSEQ ACTIOM

1 |Al N o| M M Al ACTION_DT
Azc  |JOBCODE ACTIOW_REASON
Asc [EMPLID LOCATION
sz |EMPL_RCD Thx_LOCATION_CD
Desc |EFFDT 2 JOB_ENTRY_DT
E—— DEPT_EMTRY_DT

dddindex | | Ediindes | | EdtDDL | POSITION_ENTRY_DT o

[ 0k ] [ Cancel l

To edit the index key order:
1. Open the record definition for which you want to make the custom index.
2. Select Tools > Data Administration > Indexes to access the Change Record Indexes dialog box.

The Custom Order column indicates whether the index keys were configured. The default selection is
N, indicating that no index keys were configured.

3. Double-click N or Y in the Custom Order column for the index that you want to alter, or click Edit
Index.

4. Select the Custom Key Order check box.
5. Click OK.

The Custom Order entry changes from N to Y.
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Drag and drop the field that you want to move into the appropriate order.

After configuring the key order, to reset the key order of the index to the original order as defined in
the record definition, deselect the Custom Order entry (Y to N), and click OK. The order of the key
fields reset to the original position in the Change Record Indexes dialog box.

Check the key order in the Use Display mode of your record definition.

The Num (number) column represents the original order of the keys in your record, and the Ordr
(order) column reflects the key order in the index.

Create the indexes:
a. Select Build > Current Project.
b. Select Create Indexes in the Build Options group box.

Make sure that you select the appropriate build settings.

Run the Build process to either generate a script or run the SQL online.

Confirm the construction of the new index with your native SQL command processor.

Note: Users might also configure indexes for parent records that contain one or more subrecords
without key fields, such as the ADDRESS SBR subrecord . However, if the subrecords contain key
fields, then index key order changes are restricted. The Custom Key Order option is deactivated
and cannot be changed from N to Y. Change the index key order for the parent before inserting the
subrecord.

Adding a Custom Index

To add a custom index:

1.

2.

4.

Open a record.
Select Tools > Data Administration > Indexes to access the Change Record Indexes dialog box.
Click Add Index.

The Add Index dialog box enables you to determine for which database platforms you want to define
the index if you selected the Some option for Platform. The system selects the Custom Key Order
check box to ensure that the underlying record definition is not adversely affected by the change to
your index.

For all user-defined indexes, you must enter a description of the index in the Comments section. You
should know the purpose of the index, the transactions and processes that use this index, and other
relevant information. This information assists you when you want to remove unused indexes. An error
message appears if you do not remove unused indexes.

Note: You cannot add more than 22 user indexes (A—V). The system disables the Add Index button if
the record already contains 22 user indexes.

Indicate the database platforms for which you want to create an index.
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I1.

12.

13.

Click the OK button to add a row to the Change Record Indexes dialog box and to enable the arrow
buttons.

Move the field under the new index row:
a. Inthe Record Fields list box, select the field that you want indexed.
b. Click the arrow button or double-click the field.

c. Repeat this step for each field that you want to add.

Click OK.

Save the record definition.

Select Build > Current Project.

Select Create Indexes under Build Options.

Make sure that you select the appropriate build settings.

Run the Build process to either generate a script or run SQL online.
Run the generated SQL script if you opted to generate one.

Confirm the construction of the new index with your native SQL command processor.

Editing the DDL

222

In the Change Record Indexes dialog box, you can view the DDL for the index and override DDL
parameters that are defined in the DDL model for this index.

To edit the DDL:

L.

2.

In the Change Record Indexes dialog box, select the index that you want to edit.
Click the Edit DDL button to access the Maintain Index DDL dialog box.

The upper list box in this dialog box lists the platform and DDL parameter, and the lower list box
shows the DDL templates for the various platforms. Your database might have fewer platforms
enabled. The sizing set enables different collections of tables to have different model statements and
parameters.

Select the platform and sizing set.
Click View DDL.

The dialog box that appears shows the index DDL for the platform and sizing set that you selected.
Review this DDL statement.

Click the Close button when you are finished.
Select the parameter that you want to edit in the upper list box.

The default value is set in the DDL Model Defaults dialog box. You can change this setting
by selecting Go > PeopleTools > Utilities > Use > DDL Model Defaults in PeopleSoft
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Application Designer, or by selecting PeopleTools > Utilities > Use > DDL Model Defaults in
the browser.

7. Click the Edit Parm (edit parameter) button to access the Edit Override Parm Value (edit override
parameter value) dialog box.

8. Enter the override value for the parameter that you selected.

9. Select OK for both open dialog boxes.

Altering Tables

This topic provides an overview of the Alter process and discusses how to perform the Alter process.

Understanding the Alter Process

The Alter process enables you to make changes to your record definitions at any time without losing

the application data that is already housed in the table. To ensure that the Alter process produces the
appropriate results, be aware of when to alter an existing table and what types of conversions PeopleSoft
Application Designer supports. To preserve data that is stored in tables and also reflect a recent change in
the table definition, use the alter tables function to make the appropriate changes.

The alter function simplifies the process of modifying database tables when new data fields are added
or when existing data fields are modified. It effectively eliminates the need to write SQL statements to
perform the same function.

The alter process was specifically designed to automate the task of writing alter scripts and to protect the
integrity of your database. In essence, it protects your interests by ensuring that you always control data
loss. The alter function performs tests that verify whether data will be lost during the conversion of each
column to be altered. Data loss normally occurs when reducing the character width of a column, dropping
a column that contains data, or converting a number field to a character field that is too small.

The generated statements for this method are sent to a SQL script file, the alter script. After the script
has completed, you are responsible for reapplying any SQL table DDL that you applied outside of
PeopleTools. Typically, this SQL table DDL consists of GRANT and REVOKE statements that control
security.

Note: In Oracle databases, procedural language/SQL (PL/SQL) is required to use the PeopleSoft
Application Designer Build process.

Alter Settings

The Alter tab in the Build Settings dialog box handles the most common types of data conversions,
including:

* Increasing the length of character fields.
* Changing a character (CHAR) field to a long character (LONG VARCHAR) field.

* Increasing the size of number or character fields.
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Reducing the decimal positions in number fields.

If any column of the table has data that will be lost when truncating, the system action is determined
by the Change Column Length options.

Changing integer-only number fields to character fields, where the character field is formatted with
leading zeros.

If any column of the table has a number that does not fit in the new character field, the system action
is determined by the Change Column Length options to prevent data from being lost.

Adding columns to SQL tables.

*  Dropping columns from SQL tables.

¢ Renaming columns in SQL tables.

* Renaming SQL tables.

*  Moving tables to a new tablespace.

The following sections describe the types of alter conversions that you can expect to occur during the
Build process.

Data Conversions

When altering tables with existing field data, PeopleSoft Application Designer handles conversions as
outlined in the following table. A No value indicates that conversion cannot take place. A number in
the cell following a Yes value indicates that restrictions are involved with the conversion. Refer to the
corresponding numbered note following the table for additional information:

Previous | New Format
Format
— Char Oracle |Long |Image |Long | Number/ Signed Number | Date Time | Datetime
-Long | Char Char **
Char * - Raw
Binary .
Smallint Integer | Decimal
*kk *kkk *kkkk
Char Yes (1) |Yes(1) |Yes(9) |No No No No No No No No
Oracle Yes (1) |Yes(1) |Yes No No No No No No No No
- Long
Char *
LongChar | Yes (2) |Yes(2) |Yes(8) |[No No No No No No No No
©)
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Previous | New Format
Format
— Char Oracle |Long |Image |Long | Number/ Signed Number | Date Time | Datetime
-Long | Char Char **
Char * - Raw
Binary .
Smallint Integer | Decimal
*kk *kkk *kkkk
Image No No No Yes (8) | Yes(8) |No No No No No No
Long No No No Yes (8) | Yes (8) |No No No No No No
Char -
RawBinary
Smalllnt | Yes (5) |Yes(5) |No No No No Yes (4) | Yes (4) | No No No
wkx Action
Integer Yes (5) |Yes(5) |No No No Yes (4) | No Yes (4) | No No No
ook Action
Decimal | Yes (7) |Yes(7) |No No No Yes (3) |Yes(3) |Yes(3) |No No No
sfeskoskesesk
Date No No No No No No No No No No No
Action
Time No No No No No No No No No No No
Action
Datetime | No No No No No No No No Yes (6) | Yes No Action
(6)
Notes
* with length <2000
*ok where n = length and d = decimal. See notes ***, **¥* ap( *****
*kk n<4,d=0;n=>5,d=0RawBinary
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Notes

Hokkok n>4,d=0;n=10,d=0 RawBinary

EEEE Y n>9,d>0

1 If data fits or data truncation is allowed.

2 Not allowed in Oracle.

3 If data fits or data truncation is allowed (for decimal portion only).

4 If data fits. No data truncation can occur, even with the option to allow data truncation.

5 If data fits.

6 If data truncation is allowed by selecting theTruncate data if field too short option on the Alter tab of the
Build Settings dialog box.

7 If data fits, except if data has decimal values.

8 If image or long character change from Null to Not Null or Not Null to Null, otherwise, no action.

9 Allowed on all platforms.

Alter Process Tips
As you create and run alter scripts, keep the following information in mind.
e Temporary tables during alter:

When you run the Alter process, the script might create a temporary table. Temporary tables are
named PSY %tablename%, and they are created in the tablespace of the altered table, that is, the
tablespace currently defined in the record definition.

e Alter process on tables containing LONGS on Oracle:

Oracle does not allow an INSERT or SELECT FROM command if a table contains a LONG
VARCHAR or LONG RAW data type. Therefore, in Oracle databases, PeopleSoft Application
Designer uses an Oracle PL/SQL script to perform alters on tables that contain any type of LONG
data type.

»  Alter process on Oracle on records with CHAR fields greater than 1333 bytes but less than 2000
bytes:
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For Oracle, records with CHAR fields of length greater than 1333 characters and less than 2000
characters will appear in the alter SQL script as needing to be altered, even if the information has
not changed. In Oracle Unicode databases, PeopleSoft applications triple the length of a field while
creating a table with a VARCHAR?2 column in the database to store all three bytes of the Unicode
character. In Oracle databases, VARCHAR?2 can store up to 4000 bytes, which means a restriction
exists to store only 1333 characters (with three bytes each).

For example, if a LONG CHAR field is designed with a length of 1999 characters, then PeopleSoft
applications interpret the field as a VARCHAR?2 and create the column with a size of 1333 characters.
The field length of that LONG CHAR field will be stored as 1999 in the PSRECFIELD table, but in
the database it will be created with a size of 1333. So, each time a record with a LONG CHAR field
of 1999 (or any value > 1333), the alter process detects the difference between the 1999 character
length in PSRECFIELD and the 1333 character length in the database and generates the alter script. In

addition, PeopleSoft applications also create a constraint on the VARCHAR?2.

e View dependencies:

PeopleSoft Application Designer does not keep track of view dependencies. When the structure of
a table changes, you should recreate all views. Many database environments track this information,
so you might be able to determine view dependencies by issuing a query directly against the system
catalog. However, if you are not the DBA, you might not have the authority to run such a query

successfully.

Also, renaming or dropping a table, view, or column might invalidate view text, dynamic view text,
and possibly other stored queries.

This table describes what happens to views by database platform:

Database Platform

What Happens to the
Dependent Views When
a Table Is Dropped?

Do the Inoperative Views
Become Operative When
the Table is Recreated?

Comments

Microsoft SQL Server

Becomes inoperative.

Yes

The dependency reported by
sp_depends is incorrect until
you recreate the view.

Oracle

Becomes inoperative.

Yes, but only after the first
use of the dependent view.

The VIEW object that
became invalid remains
invalid until its first use.
The Oracle catalog table for
objects marks the view as

valid again.

Db2 for z/OS

Is dropped when the table is
dropped.

NA

Views need to be recreated
because the system drops
them along with the table
drop.

*  Alter script:
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After you invoke the Alter process, the system uses the default value that is defined in the record
definition to populate the column in the altered table. The alter script that is generated contains
detailed comments indicated by the (--) to assist you if you must modify the script manually.

* Preserve storage parameters on Oracle databases:

Alter by table rename preserves customized storage parameters for tables only (with some limitations)
not for indexes, by taking DDL parameters from the system catalog.

When to Alter Tables

The following record definition changes affect synchronization with the application table and require an
alter process:

* Add or delete a field in the record.

*  Modify the length of a field.

* Change the required status of a date, time, Datetime, or long field.
* Rename a field.

* Rename a record.

The Alter Table process is similar to the Create Table process except that it does not drop existing
application data tables and the data that they contain.

Note: The Build process automatically alters records with more than 16 keys to support functional
indexes. A warning message indicating this is included in the log file for Microsoft SQL Server.

Working With Alters on Db2 for z/OS

You must be aware of a variety of considerations and maintenance tasks when performing alters on Db2
for z/OS. For example, you must consider:

* Tablespace versioning.

* Advisory Reorg Pending status.
* Rebuild Pending status.

* Avoiding SQL Code -4702.

These topics are discussed in detail in “Working with Alters on Db2 z/OS” (Data Management).

Determining Tables To Be Altered After a Field Change
To determine tables to be altered after a field change:
1. Create a new project.
2. Open the altered field.

3. Select Edit > Find Definition References.
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The referenced definitions appear in the output window.
Select all of the rows that appear in the output window.

Right-click the selected rows and select Insert Into Project from the pop-up menu.

Altering a Table

To alter a table:

L.

2.

Open the project for which you must perform an alter.

From the Build menu, select the appropriate scope of your build.
The Build dialog box appears.

Select the Alter Tables option in the Build Options group box.

Selecting the Alter Tables option automatically selects and disables the Create Indexes and Create
Trigger (only if triggers are needed) option. In the Build Execute Options group box, only the Build
script file option is enabled.

Click the Settings button in the Build dialog box to set user-defined defaults.

Select the appropriate alter, logging, and scripts settings.

Note: The alter process takes care of the indexes, regardless of the Alter Table Options you select
on the Alter tab of the Build Settings dialog box. In the case of the Alter by Table Rename option,
the indexes are dropped automatically when the temporary table is dropped. For the Alter in Place
option, the index creation process goes through the Recreate index only if modified option on the
Create tab.

In the Build dialog box, click Build to run the Alter Tables process.

The length of a build process depends on the number of definitions that require building. Watch the
Build Progress dialog box to monitor the Build process. When the process completes, check any
errors listed in the log file.

Specifying Alter Options

Access the Build Settings dialog box and select the Alter tab.
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This example illustrates the fields and controls on the Build Settings dialog box: Alter tab. You can find
definitions for the fields and controls later on this page.

Build Settings -

| Ereate| Alter |Ln:|gging | Sn::ripts|

Drop Column Options Ailter A

() Drop column if data present idds

(® Skip record if data present Changes
Renames

Change Colurmn Length Optionz
Deletes

() Truncate data if field too shart

(® Skip record if field too shart T y H
er even if no changes.

Alter Table Options
() Alver in Place

[ ] &lter Table In Memony
() Alter by Table Renarme

ak. | | Cancel

Drop Column Options

These options are referenced whenever a field is deleted from a PeopleTools record definition in which
data exists in the database for that column.

Field or Control Description

Drop column if data present Select to drop the column and data, and write a warning to the
build log.

Skip record if data present Select to end the alter for that record and write an error
message to the log. Processing continues with the next record.

Note: Whenever you select the Drop column if data present option, you run the risk of losing data, and
you are prompted at runtime to confirm your selection of this option.

Change Column Length Options

Use these options whenever the length of a character column is reduced in PeopleTools and an alter could
result in data truncation.
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Field or Control Description

Truncate data if field too short Select to alter the record and write a warning message to the
build log. Note that the system does not truncate data for
numeric fields because of possible data loss.

Skip record if field too short End the alter for that record and write an error message to the
build log. Processing continues with the next record.

Note: Whenever you select the Truncate data if field too short option, you run the risk of losing data,
and you are prompted at runtime to confirm your selection of this option. Also, numeric fields are not
truncated to avoid any loss of data.

Alter Table In Memory

If you have selected any of the Oracle In Memory options for your record or record fields, you need to
select Alter Table In Memory for those options to take effect and alter the table.

See the Oracle In Memory option for records description here:Setting Use Properties.

See the Oracle In Memory option for record fields description here: Setting Record Field Use Properties.

The following example illustrates the build script generated for a table with All Fields selected on the
record definition Oracle In Memory settings, and all record fields contained in that record definition are
supported for IM column store processing.

ALTER TABLE PS QE JOBCODE TBL INMEMORY MEMCOMPRESS FOR QUERY PRIORITY
LOW

/

SELECT COUNT (*) FROM PS QE JOBCODE TBL

/

The following example illustrates the build script generated for a table with All Fields selected on the
record definition Oracle In Memory settings, and all record fields contained in that record definition are
not supported for IM column store processing.

Alter in memory ALL ge book selective

ALTER TABLE PS QE BOOK INMEMORY MEMCOMPRESS FOR QUERY PRIORITY LOW NO
INMEMORY (QE BOOK DESCR, QE BOOK COVER IMG)

/

SELECT COUNT (*) FROM PS_QE BOOK

Note that the system adds the NO INMEMORY (QE BOOK DESCR, QE BOOK COVER IMG)
statement automatically, including the fields that are not supported for IM column store processing. These
fields are of type Long Character and Image, respectively.

The following example illustrates the build script generated for a table Selective Fields selected on the
record definition Oracle In Memory settings, and all record fields contained in that record definition are
not supported for IM column store processing. In this case, the NO INMEMORY statement will include
automatically the record fields that are not supported for IM column store processing and the record fields
not selected (manually) for IM column store processing.

ALTER TABLE PS QE BOOK INMEMORY MEMCOMPRESS FOR QUERY PRIORITY LOW NO
INMEMORY (QE_ADDED DT, QE BOOK DESCR, QE BOOK COVER_IMG, PSIMAGEVER)
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/
SELECT COUNT (*) FROM PS QE BOOK
/

Alter Any

PeopleTools assumes that you want to perform alters for any modifications made to tables, so, by default,
all of the check boxes in the Alter Any group box are selected. The Alter Any group box enables you to

customize alter processing for adds, changes, renames, and deletes. For example, you have the flexibility
to add, change, and rename fields but not to delete any removed columns. When you complete any other

custom external conversion processes, you can then enable the delete processing to drop columns that are
no longer defined.

Normally, you select all of these options, but during upgrades or operations requiring data conversion
steps you might select a subset of actions. For example:

e Perform alter with Adds and Changes selected.

* Perform data conversion routines to populate the new and changed columns (perhaps from columns
that are ultimately to be dropped).

¢ Perform alter with Rename and Delete selected.

Alter even if no changes

Select this check box to force an alter, even if no changes were made to the tables. This check box is
deselected by default. If selected, the Alter by Table Rename option in the Alter Table Options group
box is automatically selected and the Alter in Place option is disabled.

Alter Table Options

When altering tables, the alter process takes care of the indexes, regardless of the Alter Table Options
you select on the Alter tab of the Build Settings dialog box. In the case of Alter by Table Rename, the
indexes are dropped automatically when the temporary table is dropped. For the Alter in Place option,
the index creation process goes through the Recreated index only if modified option on the Create tab.

¢ Alter in Place

Selected by default. For database platforms in which Alter in Place is not supported, alter is
automatically done by Alter by Table Rename (even if that option is not selected).

Database platforms vary in the capabilities for Alter in Place table operations. This table displays the
limitations for each operation by platform:

Database Add Column Change Column Rename Table Delete Column
(data type, size,

Platform precision, scale,
and null/not null
property change)

Microsoft SQL Server | Yes * Yes * Yes * Yes *
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Database Add Column Change Column Rename Table Delete Column
(data type, size,

Platform precision, scale,
and null/not null
property change)

Oracle Yes * No Yes Yes *

Db2 for z/OS Yes * Yes * Yes * No

* Certain restrictions might apply to this operation. Refer to the documentation for your specific
database platform for more information.

* Alter by Table Rename

Select to create a temporary table (with changes made to the original table or its fields); the data from
the original table is imported into the temporary table. The original table is then dropped and the
temporary table is renamed to the original table.

Note: For Oracle databases only, Alter by Table Rename preserves customized storage parameters for
tables (with some limitations), by taking DDL parameters from the system catalog.

If a table is renamed from the old name to a new name, the indexes that were created for the old table
are moved to the new table, but the index names remain in the name of the old table. With Alter by
Table Rename selected, the indexes of the old table are dropped before being renamed to the new
table name, and the indexes are recreated after the table is renamed to the new name. This way, the
index is created in the name of the new table.

See “Working with Alters on Db2 z/OS” (Data Management).

Confirming Your Table Alter
To confirm your table alter:
1. Review the SQL script that was generated by the Alter process.

Use your native SQL command processor to open the SQL script. The script is located where you
specified on the Scripts tab of the Build Settings dialog box.

2. Run the script against your database.

3. Use your query tool and SQL Select statements to confirm that the Alter Tables process created an
application table that corresponds to your record definition and updated the system catalog tables.

Creating Triggers

A database trigger is a type of stored procedure that runs automatically when a user makes a specific data-
modification statement (INSERT, UPDATE, or DELETE) on a specified table. Within PeopleTools, you
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create triggers for optimization servers. Do not create triggers for all records; create them only for records
that have specific properties set.

Related Links

“Creating and Building Optimization Records” (Optimization Framework)

Creating Views

This section provides an overview of online views and discusses how to:
* Create views.
* Use joins in views.

»  Use cross-platform meta-SQL for dynamic views.

Understanding Online Views

Views in PeopleSoft applications are comparable to views used in traditional relational database
management system (RDBMS) technology. A view, in essence, is a virtual table. It is created from the
results of a query run against one or more tables.

When you create views to use online, you must keep the views synchronized with the database. Like
SQL tables, you must have a record definition for online views because the system checks the record
definitions for online processing rules. You must build the view before you can use or reference it online.

If you use a view as the basis for a page, you select existing information to display on the page. Therefore,
when you create the record definition for your view, you can clone an existing record definition, delete
any fields that are not used in the view, and proceed to define the view. Query views are processed the
same way as view text, which is defined as part of the record.

The order in which PeopleTools creates views is based on the build sequence number that you set on the
Record Type tab while the record is open. The default build sequence number is /. For the dependent
views to be created first, the build sequence number should be 0. This way, all of the 0 views are created
first, then the / views, and finally the views that are greater than /. The maximum build sequence that
can be set is 99. Although the views are sorted alphabetically in the project, they are created based on the
build sequence number.

Related Links
Creating SQL View and Dynamic View Select Statements

Understanding Record Types

Creating Views

If you are already familiar with creating record definitions and writing SQL queries, creating online views
is similar.

To create online views:
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1. Clone a record definition:
a. Open an existing record definition.
b. Select File > Save As.

c. Specify the name of the view that you want to create.

2. Delete and add the appropriate fields.

All columns that are selected in your view should have a corresponding field in the record definition.
3. Set the record type to SQL View:

a. Select the Record Type tab for the record definition.

b. Select SQL View in the Record Type group box.

4. Click the Click to open SQL Editor button.

The order in which you list the columns in your SQL SELECT statement should match the order that
you specified in the record definition. A SQL statement can be given for each platform.

See Creating SQL View and Dynamic View Select Statements.

5. Save the record definition.
6. Select Build > Current Definition to create the view in the database.
7. Select the Create Views check box under Build Options.

8. Click Build.

Using Joins in Views

If you plan to use a join regularly, you can save it as a SQL script or you can create a view—a single
virtual table—using the join as the logical representation of the data. After you create a view, the users
never need to know that the data they are viewing is stored in multiple tables. To users, the relative
complexity of your view is transparent. For example:

SELECT A.EMPLID,
A.NAME,
B.CONTACT NAME,
B.RELATIONSHIP
FROM PS_PERSONAL DATA A,
PS_EMERGENCY CNTCT B
WHERE A.EMPLID = B.EMPLID;

Using Cross-Platform Meta-SQL for Dynamic Views

PeopleTools includes functionality to produce meta-SQL constructs for dynamic views, which means that
dynamic SQL views that are created using PeopleSoft Application Designer can be used on any platform
that is supported by PeopleSoft. The PeopleTools: PeopleCode Developer's Guide contains a full list of
the meta-SQL that is supported in the PeopleSoft Internet Architecture.

Copyright © 1988, 2023, Oracle and/or its affiliates. 235



Administering Data Chapter 7

Related Links
“Meta-SQL Placement Considerations” (PeopleCode Language Reference)

Administering DDL

Select Data Administration from the Tools menu in PeopleSoft Application Designer to access critical
dialog boxes that enable you to define the record location and structure and other guidelines for
PeopleTools to extract information from your selected database.

This section discusses how to:
* Use the record DDL.

» Set the tablespace.

» Use physical data storage.

* Manage partition DDL.

Using the Record DDL

236

Use the record DDL to define parameters and default values for the tables in your database. PeopleSoft
applications provide templates for each database platform that PeopleTools supports. The templates
contain the typical parameters for each database platform. The mechanics of editing and viewing record,
index, and unique index DDL are the same as for space DDL.

Access the Maintain Record DDL dialog box from Tools > Data Administration > Record DDL.
The Data Administration menu option is only enabled if a record definition is open.
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This example illustrates the fields and controls on the Maintain Record DDL dialog box. You can find
definitions for the fields and controls later on this page.

Maintain Record DDL - DEPT_NODE_TBL

Flatform | 5256t |Parameter | Default Value | Override W alue
DB 1] S
OwMER
Oracle 1]
IMIT 40000
MHET 100000
bALERT LIMLIMITED
PCT 0
PCTFREE (10
PCTUSED |80
Infarrnis N 3
Y = L PO n

SOL Templates

Platform: DBZ, SizeSet: 0 ”
CREATE TABLE =0wWHER™ [TEBMAKME] [[TBCOLLIST]) [FOLATILE] IM [DEMHARE].
[TESPCHAME]:

Platform: Oracle, SizeSet: 0
CREATE TAELE [TEMAKME] [[TECOLLIST]I TABLESFALCE [TESPCHAME] STORAGE [IMITIAL
H|MIT= NESRT “NEST™ MAHERTENTS “Ma=ExT= PCTINCREASE =PCT*] PCTFREE w

[ ok, l [ Cancel ]

Field or Control Description

View DDL Select a Platform row in the Maintain Record DDL dialog box
to enable the View DDL button. This button opens the DDL
Statements dialog box, which displays the CREATE TABLE
DDL for the current record on each of the database platforms.

Edit Parm (edit parameter) Select a Parameter row in the Maintain Record DDL dialog
box to enable the Edit Parm button. This button opens the
Edit Override Parm Value dialog box, where you can enter a
new value to override the Default Value listed in the table. The
new value is stored in the PSRECDDLPARM override table.

Setting the Tablespace

The Change Space dialog box is an editing tool with which you can select the space name and view the
records attributed to the named space in the database.

Access this dialog box by selecting Tools > Data Administration > Set Tablespace. This dialog

box also appears automatically when you attempt to save a new record definition. For each new record
definition that is created in PeopleSoft Application Designer, you must allocate a tablespace name. For
the Change Space dialog box to appear upon saving a new record definition, you must select the Platform
Compatibility Mode check box under PeopleTools > Utilities > Administration > PeopleTools
Options.
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This example illustrates the fields and controls on the Change Space dialog box. You can find definitions

for the fields and controls later on this page.

Change Space

Fecord Mame:

X]

Avallable Space Mame-DB Mame:
| PTTEL.PSPTDMO v|

Flatform:
e ]
Space Mame DB Mame:

\PTTELPSPTDMOD |

Fecaords Allocated to thiz Space:

ACCESS_GRP_TEL -
ACL_PRESRUNCNTL
AE_PTTSRPLC_AET
AE_PTTSUNDO_AET
AE_TIMINGS_DT
AE_TIMINGS_LG
AEDAEMONMGR_AET
aMM_FILTER
ANALYSIS_DE
ANALYSIS_DE_DIM
ANALYSIS MODEL
ANL_DE_BIND_valL
ANL_DE_GRY_ESS
ANL_MOD_DAT_SRC
Al BN Tk

Cancel

Field or Control

Description

Record Name

display-only.

Displays the name of the current record definition. This field is

Platform

assign the designated space name.

Select from the available database platforms to which you can

Space Name.DB Name (tablespace name.database name)

current record. This field is display-only.

Displays the available space name that is assigned to the

name-database name)

Available Space Name-DB Name (available tablespace

record.

Select the space name and database name to assign to the

Records Allocated to this Space

Name drop-down list box. This field is display-only.

Displays all of the records that are already allocated to the
space that you selected from the Available Space Name-DB

Using Physical Data Storage

238

You have control over the physical storage of your data. You can view and edit the DDL for creating
tables, indexes, and tablespaces in the browser.

Access the DDL Model Defaults page (PeopleTools > Utilities > Administration > DDL Model

Defaults.)
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This example illustrates the fields and controls on the DDL Model Defaults page. You can find definitions
for the fields and controls later on this page.

DDL Model Defaults

Platform ID: 1 DBz &l

Sizing Set: 0

Find | View Al First Bl 1 of5 I Last

[+ [=]

Statement Type: Table

“Model SQL: CREATE TABLE **OWNER* [TBNAME] ([TBCOLLIST]) [VOLATILE] IN
[DBNAWEL[TBSP CNAME],

Parameter Count; 1

Parameters Personalize | Find | View Al | B First K 4 or 1 I Last

DDL Parm DODL Parameter Value

(OWNER | [=]

To view or edit the DDL parameters for creating tables, indexes, and tablespaces:
1. Open the component.
2. Press the Enter key to view platform names.
3. Select a platform name.
The DDL Model Defaults page appears.

The Model SQL edit box shows the DDL template for the specified platform and sizing set. The items
in square brackets are special parameters that are populated when instances of SQL are generated. For
example, the preceding example shows an index model statement for ALLBASE. In this example:

* [TBNAME] is the name of the table.
* [TBCOLLIST] is replaced by the columns that are specified in the index definition.

The model statements also contain parameter names enclosed in pairs of asterisks. A parameter name is
replaced by a value when instances of the SQL are generated. The preceding example has one parameter,
**FILESET** When DDL is generated using this model, the FILESET parameter is replaced by FILE
unless it is overridden for the specific record or tablespace. The other text in the model statement is
copied to the generated SQL.

Related Links

“Using Administration Utilities” (System and Server Administration)

ging Partition DDL
On Oracle databases, you can implement Oracle Partitioning.

Partitioning enables you to subdivide tables and indexes into smaller pieces, such that the database system
can access and manage the partitioned objects at a finer level of granularity. This provides for more
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efficiency for administration with faster backups, for example, and for better transaction performance
with queries being able to isolate the relevant data more quickly through partitions.

To mange partition DDL, in Application Designer select Tools > Data Administration >
Partitioning.

This example illustrates the use of the Maintain Partitioning DDL dialog box for managing partitioning
DDL.

Rietrieve Partitioning DDL

o PSFT Delivered |
Table Partitioning DD L

FARTITION BY RANGE (QE_BEGIMN_DT]
{
PARTITION TESTT VALUES LESS THAN [TO_DATE[1387-07-14"'DD-MON-Y")) TABLESPACE PSIMAGE.

PARTITION TESTZ2 VALUES LESS THAN [TO_DATE(1935-06-06", DD-MON-Y")) TABLESPACE PSIMAGE,
FARTITION PE_MaxALUE WALLIES LESS THAN [MaddalLUE] TABLESPACE PSIMAGE

]
PCTFREE 20 EMABLE ROW MOVEMENT

Index Partitioning DOL

I™ &pply Partitioning Reset | Save | Ok I Cancel |

Important! PeopleTools performs no validation on SQL entered in the Table or Index partitioning DDL
edit boxes. You must validate the syntax on your own.

Details for implementing this feature are covered in the product documentation for PeopleTools: Data
Management.

Related Links

“Maintaining Partition Definitions” (Data Management)
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Using Page Controls

Understanding Page Controls

You use three categories of controls for page design and development. You determine which types of
controls you want to add to your page definition by considering how you want to organize information on
a page, as well as how your users will enter data.

This section discusses:
¢ Aesthetic controls.
* Data entry controls.

» Function and data processing controls.

Aesthetic Controls

Use aesthetic controls to help organize, display, or emphasize information on a page. Usually, aesthetic
controls are not associated with a particular record field that is defined in a record definition and
maintained in a database. With the exception of the image control, these controls never update data in the
database. Aesthetic controls include:

Term Definition

Chart Draws a frame that serves as a placeholder for a chart that you
instantiate using the GetChart function in PeopleCode. Using
the chart control, you draw a box in which the chart appears to
the user at runtime. Associate the chart control with a record
field in a record definition.

Frame Draws a display-only box of variable size to visually group a
set of controls on a page. You can draw a frame around almost
any control. You can isolate controls, such as HTML areas,
from other controls on a page and then hide the frame. Frames
generate HTML tables for viewing in a browser.

Group Box Draws a display-only box of variable size with a text label

to visually group and identify related controls, such as radio
buttons. Like a frame, you can resize a group box to any length
or width. However, with a group box you can assign a visible
label. Like frames, group boxes generate HTML tables for
viewing in a browser.
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Term

Definition

Horizontal Rule

Draws a horizontal line to separate parts of a page. Use a
horizontal rule control as a visual break between controls.

Image

Draws a frame that you can associate with a variable image
from a record field in a database. The record field stores

a graphic, such as a scanned image of an employee or a
picture of an asset, in the format that you defined in the record
definition. Because an image can change at runtime and is
associated with a record and field definition, it is considered a
data entry control and an aesthetic control.

The field that you associate with your image can be either a
standard Image type field or an ImageReference type field,
where images might be associated with it depending on user
input. The ImageReference field type is a pointer to an image
definition, which enables you to display images dynamically.
An example of this is referencing a red, yellow, or green light
image definition on a page, depending on the context when the
page runs.

See Specifying Image Field Attributes.

See Specifying ImageReference Field Attributes.

Static Image

Draws a frame that you can associate with an image definition.
It can help organize or identify information that appears on a
page. A static image is different from an image because it does
not change at runtime, and it is not associated with a record

field but instead with a predefined image definition.

For example, you might select a static image, such as the
yellow Clear button, from the image catalog and place it on
top of a push button control so that the user knows to click that
button to clear the contents of the page.

See Understanding Image Definitions.

Static Text

Adds a static text item, a display-only alphanumeric field
with a maximum length of 60 characters, to describe a page,
control, or group of controls.

You might use static text for a static note, an extension of

a control label, and occasionally a control label itself. You
should avoid using text items because they make it more
difficult to translate pages to other languages. Instead, you
should reference message catalog text to facilitate translation
and other maintenance issues. Other methods of displaying
text on a page are display-only edit boxes, field labels, and
display-only long edit boxes.

The system disables the static text button when you
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Data Entry Controls

Using Page Controls

Use data entry controls to offer different ways to enter and maintain information. These types of controls
are always associated with a record field that is defined in a record definition and maintained in a

database.

Note: PeopleSoft Application Designer allows you add up to 405 fields on a page. When you reach this
limit, typical system behavior includes being unable to select, move, or edit the page fields with an order
number exceeding the 405-field limit. While this limit has no effect on the page at runtime, it has the
potential to disrupt productivity during design time. If you find a page nearing the 405-field limit, you
should use subpages to decrease the number of fields on a single page.

See Using Subpages.

Term

Definition

Check Box

Adds a small square box that operates as a toggle switch—on
and off—for data controls that can have one of two values (yes
or no, 1 or 0).

During data entry, when the page is saved, the enabled or
disabled value (whichever represents the current state of the
check box) is written to the database. If values are specified in
the page definition, the fields are left blank in the database, but
you can still select or deselect the check box on the page. You
will not know that the database fields are blank until you run a
query or report on the field.

Drop-Down List Box

Adds a drop-down list box from which you select a single
value from a list of valid values. Use drop-down list boxes
to enable data selection from a list of three or more possible
choices. In its closed state, the control displays the current
value for the control. The user opens the list to change the
value.

Drop-down list boxes are a good design choice when
presenting users with a small number of selections from which
they must select one value. However, when designing for grids
and scroll areas, prompts give you better performance.

Edit Box

Adds an edit box, which you use for data entry. You also use
edit boxes for displaying fields and translatable text. Use an
edit box for text data entry, for example, for a record field that
is defined as character, number, signed number, or date.
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Term

Definition

Long Edit Box

Adds a long edit box, which is a variable-length, alphanumeric
control used for entering long, textual items, such as
comments. The length of the control is determined by its
content rather than the physical size of the box on the page.

Use long edit boxes to display long, translatable text. Each
long edit box has a built-in scroll bar that enables users to
enter and display more data than can be shown at one time
on a page. The scroll bar on the long edit box is used only to
scroll through the text in the long edit box.

Unlike edit boxes, which are limited to the field size that is
defined in your record definition, long edit boxes can contain
a relatively unlimited number of characters, up to a theoretical
maximum of 64KB. This space, however, is shared by a
number of other programming elements, so the true size might
be closer to 15 to 25KB, depending on the location of the field
in your application and the state of the application.

Typically, you use long edit boxes for comments or
descriptions, or you configure the long edit box as a rich text

editor.

See Setting Options Properties.

Radio Button

Adds a small, round button that represents one value for a
control with multiple defined values. Add radio buttons in
groups. A user can select only one radio button in a group at
one time, like station buttons on a radio—hence the name. Use
radio buttons to enable selection of one out of two possible
choices. If you have three or more choices, use a drop-down
list box.

Subpage

Adds a predefined, presized group of controls, such as address
controls, that are defined in a separate subpage definition.
During design time, you add only the subpage control to
represent all of the controls in the subpage. You maintain those
controls in only one place, the subpage definition. At runtime,
you see all of the controls that are defined in the subpage on
the page.

Use function and data processing controls to provide a mechanism for running commands and to maintain

levels of information on a page.
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Term

Definition

HTML Area

Adds an area where you can write your own HTML. With
other controls, the PeopleSoft system automatically generates
the HTML code and then inserts the HTML code into the
dynamically generated code at runtime.

See Using HTML Areas.

Tree

The dynamic tree control is a deprecated feature. Use
PeopleCode with the HTML area to create a hierarchical tree.

Push Button/Hyperlink

Adds a push button or link that represents an internal or
external link, PeopleCode command, process through
PeopleSoft Process Scheduler, prompt action, scroll action,
secondary page, or toolbar action. You can specify whether
the control appears as a traditional push button or as a link
(highlighted, underlined text).

Secondary Page

Adds an invisible control that associates a secondary page
with the primary page. You then associate the secondary

page with a command push button, link, or a pop-up menu.
Secondary pages gather or display supplemental information
that is related to the data in a primary page but less frequently
referenced or updated. Secondary pages are displayed

using the DoModal and DoModalComponent PeopleCode
functions.

See Using Secondary Pages.

See “DoModal” (PeopleCode Language Reference).

Scroll Area

Provides an easy way for you to group or repeat multiple fields
of data in a defined area. Like a grid, users can easily navigate
through the rows using links and buttons in a navigation bar,
and they can add or delete rows using push buttons. These
features are automatically placed in the navigation bar. The
navigation bar also provides several other settings, such as a
Find feature that enables the user to search all fields and rows
for specific data and a View All option so that the user can see
all rows of data at once.

You can place the fields in the scroll area randomly, one on top
of the other, or side by side. Unlike a grid, you are not limited
to the type of controls that you can place in a scroll area. You
can even place a grid inside a scroll area.
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Term Definition

Scroll Bar Like the scroll area, scroll bars contain push buttons and
links for navigation, but not in the form of navigation bars.
Developers must manually position all navigation items.

Like grids and scroll areas, the actual scroll control that you
see in PeopleSoft Application Designer when working with
scroll bars in page definitions does not appear at runtime.
Instead, the scroll bar control has scroll action buttons to
replace the visual rendering of the scroll bar as push buttons
and links on the web.

Grid Adds a grid, which looks and behaves like a spreadsheet that
is embedded in a page. It has column headings and cells and
uses push buttons, links, and tabs to navigate through the

data. It is similar to a scroll area on a page. Each row in the
grid corresponds to a set of controls in a scroll occurrence.
Navigation links and push buttons replace the actual visual
scroll bar, and add and delete push buttons enable a user to
insert and delete rows. Use instead of a single-level scroll area
or scroll bar to manage multi-row sets of data.

Using Charts

Use the Chart Properties dialog box to:
¢ Associate a chart with a record definition and record field.

* Assign a page field name.

Set label attributes.
e Set the chart as a page anchor.

On the Label tab, add an information-only name for your chart. This label does not appear at runtime,
but it does appear on the control order list on the Order tab of the page definition and any page definition
report that you print. Assigning a label is helpful if you have multiple charts on your page.

Related Links
“GetChart” (PeopleCode Language Reference)

Using Frames

Note: Frames are not supported in fluid applications.

Use the frame control to visually group a set of controls on a page.

To change frame labels and display options:
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Double-click a frame to open the Frame Properties dialog box.
On the Label tab, enter a brief text description of the function of the controls in the frame.

The default frame label is Frame. Any label that you attach to a frame is for information only—it does
not appear on your page, but it does appear on the page definition printout and in the control order list.
Use labels to differentiate among multiple frames on your page.

For example, if you are enclosing address controls, you might use the label Address Frame.
Select the style for the frame.

You can control the line color and thickness and the background color of a frame by specifying a
style.

See Understanding Style Sheets and Style Classes.

Select the Hide Border check box to hide the border of a frame.

Use this option to use the style to shade only the background of the framed area or to apply other
styles. If you select Hide Border, it overrides the border options that are specified in a style.

You might also use a frame with a hidden border to facilitate HTML generation. When you insert
a frame in a page section, the system generates that section as a table in HTML. This functionality
is useful to ensure the correct layout. However, in some browsers, adding more HTML tables can
degrade performance.

See Improving Online Performance.

Select the Adjust Layout for Hidden Fields check box to enable automatic vertical adjustments to
the frame size when hidden fields are present.

If visible fields are not present to the right or left of the hidden field in a frame, the frame collapses to
surround the remaining fields.

If the field is associated with multi-currency processing, select the Multi-Currency Field option on
the Use tab in the Frame Properties dialog box.

This selection causes the field to appear at runtime only if the Multi-Currency option on the
PeopleTools Options page is selected.

Using Group Boxes

Use group boxes to visually associate relevant page field controls and to create a page that is intuitive to
the user.

In fluid applications, group boxes have additional uses. See “Working with Group Boxes” (Fluid User
Interface Developer’s Guide) for more information.

Inserting and Moving a Group Box

To insert and move a group box:
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1. Select Insert > Group Box.

2. Position the mouse where you want the initial location of the group box and click.
3. Move the group box to the appropriate location by clicking and dragging.

4. Adjust the group box size and shape using the handles on the edge of the group box.

5. Remove cursor focus from the group box by clicking anywhere outside of the group box in your page
workspace.

Setting Group Box Properties
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Use group boxes to visually associate relevant page field controls and to create a page that is intuitive to
the user.

Setting Group Box Record Properties

Although the group box Record Field properties are optional, associating the group box with a record
definition and record field enables you to:

* Distinguish individual group boxes when multiple group boxes appear on the page definition Order
tab.

* Use PeopleCode to programmatically control the properties of the group box.

Access the Group Box Properties dialog box. Select the Record tab.

Field or Control Description

Record Name Select the record definition to which you would like to
associate this group box.

Field Name Select the field definition to which you would like to associate
this group box. Only the fields in the previously selected

record definition appear in this list.

Setting the Group Box Label Properties
Use group box label properties to reflect how the fields that appear inside the group box are related.

In some cases, the group box may surround a variety of disparate controls. In those situations, you might
opt to enter a label manually rather than associating the group box with a record definition and field.

Access the Group Box Properties dialog box. Select the Label tab.

1. Select the label Type:
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Field or Control

Description

Text

Select to enter the group box label manually. Selecting this
option enables the Text field and disables the Label ID
field.

Note: You do not enter the text until the next step.

RFT Short (record field text short)

Select to access the Short Name record field label properties
of the record field that you associate with this group box.
Selecting this option disables the Text field and enables the
Label ID field.

Note: You do not select the label until the next step.

RFT Long (record field text long)

Select to access the Long Name record field label properties
of the record field that you associate with this group box.
Selecting this option disables the Text field and enables the
Label ID field.

Message Catalog

Select to use a value stored in the message catalog as the
label for the group box. Selecting this enables the Message
Set/Number field in the Label Text group box.

2. Select or enter the specific Label Text.

Field or Control

Description

Text

Enter or view the text that is to appear as the label in the
group box header.

If you select the RFT Short or RFT Long label type, the
system automatically populates this field based on the Label
ID that you choose and then disables it.

Group box labels are limited to 50 characters, regardless
of whether the label is static text or retrieved from the field

definition.
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Field or Control

Description

Label ID

Select the value that is to appear as the label in the group
box header. The values that appear in this list depend on

the label type option that you selected in the previous step
and the label properties of the field definition. Changing the
Label ID value automatically changes the value in the Text
field.

See Understanding Multiple Labels.

Context

Enter a context for the label.

Message Set/Number

Enter the message set and message number of the message
catalog entry to be used as the group box label value.
Available only if the Type selection is Message Catalog.

Label Style

Select a value to determine the look and feel of the label.

Note: Not all style classes are appropriate for labels.
Changing the default style can produce unexpected results.

See Overriding the Default Page Field Styles.

Select an Embedded Help Pop-up option. (See Configuring Embedded Help for Scroll Areas, Grids,

and Group Boxes for more information.

Note: Embedded help is not supported for group boxes, grids, and scroll areas on fluid pages.

Field or Control

Description

No Popup

Select this option to disable embedded pop-up help.

This value is the default.

Message Catalog Popup

Select this option to enable the embedded pop-up help icon
on the grid at runtime. Selecting this option enables the
Message Set/Number edit boxes.

Message Set/Number

Enter the message set number and message number of the
message catalog entry to appear when the user clicks the
embedded help icon.

Text

Displays the message that appears when the user clicks the
embedded help icon. This field is display-only.
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4. Select an alignment option for the label.

5. Select the Display Options of the label.

Using Page Controls

Field or Control

Description

Body Style

You can control the color, line thickness, and background of
the body section of a group box by specifying a style.

See Understanding Style Sheets and Style Classes.

Adjust Layout for Hidden Fields

Select to have the group box adjust its borders to
accommodate any hidden fields.

Note: For the group box to adjust automatically, the hidden
fields inside the group box must be surrounded by open
space or have other hidden fields to the right or left.

Hide Border

Select to hide the outside border of the group box. This

selection overrides the border options specified in a style.

Suppress Accessible Label

Select to hide any label applied for accessibility reasons.

Setting Group Box Use Properties

Access the Group Box Properties dialog box. Select the Use tab.

Field or Control

Description

Multi-Currency Field

Select to associate this field with multi-currency processing. If
the Multi-Currency option on the PeopleTools Options page
is selected, the field displays at runtime only.

Hide all Fields when Group Box Hidden

Select to hide all visible and hidden fields when the group box
is hidden. Hide a group box by associating it with a record
and field and invoking the relevant PeopleCode field class
property.

See “Visible” (PeopleCode API Reference).
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Field or Control Description

Collapsible Data Area Select to collapse the group box into a small image that the

user must click to expand. Collapsing the group box enables
the Default Initial View to Expanded State check box and
enables you to select label images for both the expanded and

collapsed states, typically small triangles.

Each time that a user opens or closes a collapsible section, a
transmission to the application server is required. Therefore,
the initial state of whether the collapsible section is open

or closed is important. You should carefully evaluate the
performance and usability aspects of using collapsible sections
versus designing a long page that displays all of the data using

deferred processing mode instead.

Example of Collapsible Group Boxes
Spain is expanded while the group boxes for France, Italy, and USA are collapsed:

This example illustrates the fields and controls on the Example of collapsible group boxes. You can find
definitions for the fields and controls later on this page.

- B Spain
=i 4] o
Effective Date Military Status Social Security Affiliation Dt
1 | l E &=
" I France
I W W icay
P ysa

Using Horizontal Rules

This section discusses how to:
¢ Draw a horizontal rule.

* Set horizontal rule properties.

Drawing a Horizontal Rule
To draw a horizontal rule:

1. Select Insert > Horizontal Rule.
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2. Draw a horizontal line of the appropriate length on the page.

Setting Horizontal Rule Properties

This section discusses how to apply informational labels to a horizontal rule and configure how the
horizontal rule is used on a page.

Setting Horizontal Rule Label Properties
To set horizontal rule label properties:
1. Open the Horizontal Rule Properties dialog box.

2. On the Label tab, enter an information-only label to differentiate the line from other frames and lines
on your field order list.

3. Select the style for the line.
You can control the color and line thickness of a horizontal rule by specifying a style.

See Understanding Style Sheets and Style Classes.

Setting Horizontal Rule Use Properties

Access the Horizontal Rule Properties dialog box. Select the Use tab.

Field or Control Description

Multi-Currency Field See Setting Use Properties.
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Field or Control

Description

Set to Level

Manipulate the occurs level of your controls on the page while
still preserving the physical tab order at runtime. If you adjust
the sequence of fields on the Order tab of the page definition,
the tab order for the user at runtime is adjusted to that new
order, which may not be the desired tab order. In which case,
you can insert a horizontal rule, and set the level to apply to
any control beneath the horizontal rule. In doing so, you can
maintain a consistent, logical tab order.

Use this setting to specify a scroll level organization that
differs from the order of page fields on the Order tab. For
example, you might want to create a page that contains
multiple collapsing group boxes with each containing level-
based controls. By placing a horizontal rule between each of
the collapsing sections and setting the level to 0, you return the
occurs level to 0 so that you can add additional levels without
having to alter the order of controls on the Order tab.

Likewise, assume you insert a hyperlink within a level 1 scroll
area, but below a level 2 scroll area that exists within the

level 1 scroll area. However, you want the hyperlink to be
considered part of level 1 for tabbing purposes. By placing the
horizontal rule between the level 2 scroll and the hyperlink
and adjusting the Set to Level value to /, you can associate the
hyperlink with the other level 1 elements for tabbing purposes.

See Level-Based Controls.

Using Images

This topic describes using images within PeopleSoft applications.

Understanding Static Images

254

A static image is different from an image because it:
* Does not change at runtime.

* Is not associated with a record field.

Static images are associated with a predefined image definition. For example, you might select a static
image, such as a yellow Clear button, from the image catalog and place it on top of a push button control
so that the user knows to click that button to clear the contents of the page.
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Adjusting Static Image Size and Shape

You can adjust the size of a static image by dragging the handles on the edge of the image box , or you

Using Page Controls

can adjust the size in the Static Image Properties dialog box on the Label tab by changing the width and

height in pixels.

Setting Static Image Properties

This example shows the options available on the Static Image Properties dialog box. Descriptions of the

options follow.

static Image Properties

Label | General | Fluid

Alt tag far image

Label Type: | Text W |

Label | Static Image |
Image

Image 1D: | ARROWT v| [

Type: Wwidth; Height:

Image Format / Size

® Scale () Size

‘width: Height

| Rezet to actual image zize |

]9

Cancel

For more information on images, see Understanding Image Definitions.
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Field or Control

Description

Label Type

None: Select for no image label.
Text: Select to add an image label manually.

Message Catalog: Select if the label for the image is stored in
the message catalog.

The label does not appear on your page at runtime. Use it to
track your images in your scroll order list box and on page
definition reports.

Message Set

If your label value is stored in the message catalog, specify the
message set.

Msg Number

If your label value is stored in the message catalog, specify the
message number.

Label

If you have selected a Label Type as Text, enter the image
label.

Image

Field or Control

Description

Image ID Select the image name from the drop-down list.

Type Displays the image type, such as GIF, JPG, and so on.
Width/Height Displays the dimensions of the graphic in pixels.

Preview A preview of the image appears in the preview box below the

controls in the Image group box.

Note: Not all image types can be previewed in Application
Designer during design time. For example, these image types
cannot be previewed: PNG, ICO, and SVG.
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Image Format / Size

Field or Control Description

Scale Select to scale the image to the size of the frame that you set
using the control selection handles or by the width and height
that you enter. The scaling occurs when you view the page in a

browser.

Size Select to display the image as is, regardless of the control size
on the page.

Width/Height Use to specify custom dimensions for an image.

Reset to actual image size If you have scaled or adjusted the image dimensions, click to

reset the image to the actual size of the image.

Note: You can define your own static images, such as your company logo, by creating a new image
definition. After you create the image definition, you can then add your logo to a page using a static
image control.

Setting Image Properties
To set image properties:
1. Open the Image Properties dialog box.
2. On the Record tab, select the record and field names with which this image field is associated.

3. Set the image format and size attributes.

Field or Control Description

Scale Select to scale the image to the size of the frame that you
set using the control selection handles or by the width and
height that you enter. The scaling occurs when you view the
page in a browser.

Size Select to display the image as is, regardless of the control
size on the page.

4. Specify the alignment of your image.

5. Select a style for the image.
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Setting Image Label Properties

Be sure to assign an informational label to your image. Assigning an informational label to your image is
especially important if your application works with screen reader software.

To document an image control with an informational label:
1. Enter a text description in the Alt tag for image region.

2. Select one of the following settings from the Type drop-down list box:

Field or Control Description

None Select if you do not want a label. The Text field becomes

unavailable for entry.

Text Select to enter a custom label. This value is the default
setting.
Message Catalog Select to use a preset message from the message catalog.

The Message Set and Msg Number (message number)
fields become available for entry.

RFT Long (record field table long) and RFT Short (record | Select to use a preset label from the record field set on the
field table short) Record tab. The Label ID drop-down list box becomes
available for entry.

Setting Image Use Properties
The Use tab of the Image Properties dialog box is the same as for that of an edit box.

See Setting Use Properties.

Using Static Text

Access the Static Text Properties dialog box.
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Label Text

Field or Control Description

Text If you select Text, you can use either uppercase or lowercase
characters. The text label is limited to 60 characters in length.
You can also split your text item into multiple lines. To do this,
position the cursor in the Text field where you want the split to
occur and click the Insert Line Feed button. A thick vertical
bar character appears in the Text field, and, when you close
the dialog box, your text item is split into multiple lines.

Message Catalog If you select Message Catalog, enter the appropriate message
set and number. As with a text label, you are limited to
message catalog text of 60 characters.

Style

You can control the color, font, size, and other characteristics of the text by specifying a style.

See Understanding Style Sheets and Style Classes.

Alignment

Set the horizontal alignment of your text control, as determined by the left-hand edge of the field. You can
align controls to the left-of-center, centered, or to the right-of-center.

Use Tab

If a text item is associated with multi-currency processing, select the Multi-Currency Field option. This
selection causes the text item to appear at runtime only if the Multi-Currency option on the PeopleTools
Options page is selected.

Using Check Boxes

When you insert a check box on a page, it appears with a default label, Dummy Name, until you specify a
record definition name and field name, or a text label.

Setting Check Box Properties
Define the check box control by assigning the appropriate properties.

Setting Check Box Record Properties
To link check boxes with associated record definitions:

1. Open the Check Box Properties dialog box.
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2. On the Record tab, select the record and field names from the drop-down list boxes.

3. Enter the enabled and disabled values for the check box.

For example, if the enabled value of the check box is Y for yes and the check box is selected when
the user saves the row, then the Y value is written to the database. If the disabled value of the check
box is N for no and the check box is deselected when the user saves, then the N value is written to the
database.

The enabled and disabled values that you enter validate against the Translate table. If the system does
not find a value, it displays a warning message but allows the value to remain. You might find this
functionality useful when you create prototype pages before defining record definitions.

Setting Check Box Label and Use Properties

After you link the check box to a record definition and field, set the label properties. Otherwise, the
default check box label is the field long name. Set how the check box will be used on the Use tab.

Related Links
Setting Page Field Properties for Controls

Setting Use Properties

Using Drop-Down List Boxes

This section discusses how to:

Set drop-down list box record properties.

Set drop-down list box label and use properties.

Setting Drop-Down List Box Record Properties

260

To set drop-down list box record properties:

1.

2.

Open the Drop-Down List Box Properties dialog box.

On the Record tab, associate the drop-down list box with a record and field.
Select a style.

Set the font and color attributes of your drop-down list box data.

See Understanding Style Sheets and Style Classes.

Select a displayed text option:
e Xlat Short.
*  Xlat Long.

*  Prompt Table Field.
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5. Ifyou selected Prompt Table Field, enter the field name in the Prompt Table Field area.

6. Set the field size for the drop-down list box.

Setting Drop-Down List Box Label and Use Properties

You can set the label and use properties for a drop-down list box.

Related Links
Setting Label Properties

Setting Use Properties

Using Radio Buttons

This section provides an overview of radio buttons and discusses how to:
» Setradio button record properties.
* Set radio button label properties.

» Set radio button use properties.

Understanding Radio Buttons

When you insert a radio button on a page, it appears with the default label, Dummy Name, until you
specify a record definition name, field, and value for the radio button. Like edit box labels, radio button
labels display a dashed box to indicate the translation buffer.

For radio buttons to function as a single group, they must be associated with the same record field and
they must be adjacent fields on the Order tab of the page definition. To save time, add all radio buttons in
a set, one after the other. After you add the first radio button, the system remembers the record definition
name and field name for all subsequent radio buttons; you must enter only the database value for each.
Then, place a group box around all of your radio buttons to keep them together and labeled, as in this
example:

This example illustrates the fields and controls on the Example of radio buttons. You can find definitions
for the fields and controls later on this page.

(*) Hours
) Minutes

Setting Radio Button Record Properties

To link a record with radio buttons:
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1. Open the Radio Button Properties dialog box.
2. On the Record tab, select the record and field name.

The system retrieves the default label text if you enter the record or field.
3. Enter the database translate value for this radio button.

In the preceding radio button example, N is for Normal. If you select the drop-down list box for the
value, you see the translate value and the long name that was assigned to the field. When the user
selects this radio button, it indicates a Normal value.

Setting Radio Button Label Properties

To set the label of a radio button:

1. Open the Radio Button Properties dialog box.

2. On the Label tab, select the type of label if it is other than the default of XLAT Long.
3. Select the radio button label location: to the left or right.

See Setting Label Properties.

Setting Radio Button Use Properties

You might want to change the way that a radio button is used on a page. For example, you might want the
selected value of a radio button to control what appears in another control.

See Setting Use Properties.

Using Edit Boxes and Long Edit Boxes
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This topic discusses information related to applying various options to edit boxes or long edit boxes.

When you insert edit boxes and long edit boxes on a page, they appear with the default label, Dummy
Name, until you specify a record and field for them or until you specify a text type field label. The

space between the edit box label and the control is more than required: PeopleSoft Application Designer
provides 25 percent extra space for the edit box label for translation purposes.

You control source data, labels, and how the control is used in the respective edit box and long edit box
properties dialog boxes in PeopleSoft Application Designer. The settings for these two controls are mostly
the same.

Related Links

Setting Use Properties

Understanding Pop-up Pages

“DisplayOnly” (PeopleCode API Reference)
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Long Edit Box Character Limit Counter

Long edit boxes do not limit the number of characters that a user can enter in the browser, regardless of
any limits defined in the underlying record field. As such, characters entered by the user that exceed the
field length of the field definition may be truncated. For example, if you enter 012345678901234 into a
long edit box associated with a field with a field length of 10, the input would be truncated and saved to
the database as 0123456789.

To help users avoid this situation, you can select Enable Long Edit Counter on the Long Edit Box
Properties, Use tab.
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The following example shows the Enable Long Edit Counter option on the Long Edit Box Properties

dialog box.

Long Edit Box Properties

.Hecu:urdl Label Use |General| Fluid I Dplionsl

 Field Uze Options

[ Dizplay Dry [~ Multi-Curency Field
[ Inwvisible [~ Related Field
T Modifiablz by
JawaSenpt

[~ Expand Field When

r Enable when Fage Display Orily

iz Cizplay Ml

[T wiap Long Words
[T Persist Grid Colum it Menu

[ Dizsplay in Modal Window
| Gererate in HTHL ¥ Enable Long Edit Cournter

Fielated Control Field:

Popup Menu

! [

¥ Allow Deferred Processing
v Set Component Changed

]|

Q. I Cancel |

With this option on, a counter appears below the long edit box on the page, notifying the user how many
characters can be entered before reaching the field limit (N characters remaining).

The following example shows the character limit counter alerting the user of the amount of characters that

can still be accepted by the field.

Long Description:
(254 Characters)

51 characters remaining

Selectto setthe grid to a height carresponding to the number of rows in the occurs count attribute. The grid
remains fixed atthat height even ifthe actual number of data rows varies from that numher.
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The following example shows the character limit counter alerting the user that the character limit has been
exceeded, with the character value becoming negative (-).

Selectto setthe grid to a height carresponding to the number of rows in the occurs count attribute. The grid
rermains fixed at that height even ifthe actual nurmber of data rows varies from that nurmber. Ifthe fixed height
(254 Characters) nronery is not used. the size of the arid dvnamicallv chanaes based onthe occurs count and the number of A

-98 characters remaining

Long Description:

-

Note: The system treats carriage returns (ASCII=13) and line feeds (ASCII=10) the same as any other
character. If there is no character limit on the field, the counter does not appear. For long edit boxes within
grids, the counter becomes visible only after displaying the long edit box in a modal window (that is,
performing a long edit zoom). The character limit counter is not applicable for use with fields enabled for
the rich text editor. If a field is enabled for rich text editor, the system does not display the character limit
counter.

Character Counter on Fluid Pages

Similar to classic pages, when the character counter is enabled on a fluid page, it is displayed beneath

the bottom right corner of the long edit box. If you want the character counter to be displayed beneath

the bottom left corner, apply the psc_counter-left style in the Application-Specific Styles: Style Classes
field on the Fluid tab. Oracle recommends that you do not use a psc_control-width*pct style to control the
width of the long edit box itself because you will then need to develop and apply custom styling to get the
character counter aligned with the long edit box.

Note: Because the Display in Modal Window option is not supported in fluid applications, the character
limit counter cannot be displayed for long edit boxes in fluid grids.

Mouse Over Pop-up Edit Boxes

You can associate mouse over pop-up pages with edit boxes. The pop-up page appears when you hover
your mouse over any edit box that is pop-up enabled. You can identify edit boxes with mouse over pop-up
pages associated with them because these edit boxes are both display-only and they appear with a dashed
line beneath the control.

You can configure edit boxes to display pop-up pages at runtime by configuring properties on the Use tab
at design time.
Display-Only Edit Boxes

Some edit boxes should be display-only. You might want a page field to govern what appears in
another control. In some cases, you might want the page control to be invisible because it is required by
PeopleCode but is not accessible by a user.

If you designate the long edit box as display-only, select the Expand Field When Display Only check
box to hide the scroll and automatically expand the size of the edit box as necessary to display large
amounts of text in the field.

You can configure controls to be display-only at runtime by configuring properties on the Use tab at
design time.
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Rich Text-Enabled Long Edit Boxes

Long edit boxes can be enabled with rich text, which allows you to create formatted and styled text, rather
than just plain text. When a long edit box is also enabled for editing, the rich text editor includes toolbars
that allow you to specify paragraph and font formatting, insert images and hyperlinks, and so on.

You enable long edit boxes to display rich text at runtime by configuring properties on the Options tab at
design time.

Note: You cannot enable the rich text on long edit boxes within grids.

Note: On fluid pages, do not enable spell check on long edit boxes that also have rich text enabled.

Note: On fluid pages, if there is a rich text editor field in a scroll area, do not enable a row action for the
scroll area.

Related Links

Setting Options Properties

Modifying the Rich Text Editor User Interface

“Working With Rich Text Editor Fields” (Applications User’s Guide)

Display in Modal Window

Note: The Display in Modal Window option is not supported in fluid applications.

Select this option to enable the end user to display (zoom) a long edit box in a modal window.

When an end user clicks Display <Field Name> in Modal Window for a long edit box at runtime, the
pop-up modal window displays a title matching the current component description. If the component
description is empty, then the system displays a title matching the current menu item name. Make sure
that one of these values is suitable for end user display.

Protecting Sensitive Field Data Online

You may not want to expose some field data online, such as passwords, PIN numbers, identification
numbers, and so on. For such fields, you can use the Password and Input Only display options to prevent
end users from seeing the actual field value.

This example illustrates the Password and Input Only edit box display options.

Dizplay Optionz

[ ] Display Zero [ ] Dizplay Century
Pazaword [ Currency Symbal
Showe Prompt Button [ ] 1000 Separator

[ ] &wato Fil [ ] Auta Decimal

[ ] Display Time Zone [ ]Enable Spell Check
[put Oy
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If neither Password or Input Only is selected, the system displays the field data online just as it appears in
the database (as normal — in its clear case or encrypted form).

Select Password to mask the field value online with black dots or asterisks (depending on the operating
system and/or browser), while having the actual field value available in the page HTML.

Input Only can be selected only if Password is also selected. The Input Only option displays masked
characters in the field, but it also prevents the field value from appearing in the page HTML.

In both cases, the user can change the value of the field without ever seeing the value entered or the actual
value stored in the database.

Note: With both options, the actual field value is stored in the panel buffer and can be accessed and
utilized as part of normal processing, such as PeopleCode usage.

This example illustrates the online formatting of the field value (black dots) with the Password option
selected. The number of masked characters matches the number of characters in the actual field length.

Password

This example illustrates the Input Only option not selected. In this example only Password is selected so
just the online page field is affected. Note the field value attribute populated in the HTML.

<input name="MCF_USER_IM_ CFG_MCF_PASSWORDE®™ tabindex="166"
class="PSEDITBOX" id="MCF_USER_IM_CFG_MCF_PASSWORDE®" style="width:
237px; " type="text™ maxlength="254" wvalue "5;‘553#1FAFH4="F<Iinput>

With the Input Only option selected, the online appearance of the field matches the Password option
selection. The HTML appears as follows:

<input name="MCF_USERIM CFG_MCF_PASSWORD$0" tabindex="166"

class="PSEDITBOX" id="MCF_USERIM CFG MCF PASSWORDSO" style="width:237px;"
type="text" maxlength="254" value="****x*x&*xix">/input>

Note the field value is masked also in the HTML.

Display Option Online HTML

Password: Not Selected Displays field data as stored in the The HTML input value attribute contains
database. If the data is encrypted or the same value as the online field.
hashed in the database, it displays that
format.

Password: Selected Displays field data as masked characters. | The HTML input value attribute contains
field data as stored in the database. If
the data is encrypted or hashed in the
database, it displays that format.
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Display Option Online HTML

Password: Selected Displays field data as masked characters. | The HTML input value attribute contains
a masked value.
Input Only: Selected

Using Pop-up Pages

Note: Pop-up pages are not supported in fluid applications.

This section provides an overview of pop-up pages and discusses how to:
*  Define pop-up pages.
* Associate pop-up pages with fields.

» Enable Message Catalog pop-up pages.

Understanding Pop-up Pages
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Pop-up pages are a type of PeopleSoft page that displays information that supplements, expands, or
enhances the transaction page data. Pop-up pages are ideal for displaying additional, more detailed
information that is pertinent to a subset of users. For example, you can create a Purchase Order Header
Details pop-up page that displays customer details such as contact information and payment data. You
can then associate the details pop-up page with the Purchase Order Line Items page so that an account
representative who is reviewing line items can quickly access customer contact data without having to
leave the transaction. Similarly, you can create an Employee Details pop-up page to display an employee's
ID, name, department, current job assignment, phone number, and email address. You then associate the
Employee Details pop-up page to a specific field on an employee-related transaction page. At runtime,
when you move your mouse over this field, the pop-up page appears and displays information that is
contextually relevant to the employee data on the transaction page.

Pop-up pages look and behave differently from standard PeopleSoft transaction pages. For example:

»  Pop-up pages are not standalone pages; they are linked to, dependent upon, and accessed from their
primary transaction pages.

*  Pop-up pages do not appear unless you hover your mouse over the page control with which you
associated the pop-up page.

*  Pop-up pages support only a subset of page controls.
*  Pop-up pages cannot contain scroll areas or grids.
*  Pop-up page fields are display-only.

*  You should place pop-up page PeopleCode either in the page Activate event or on the RowlInit event
of work records associated with the pop-up page.
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* Ifavalue at level 0 on the pop-up page comes from one of the search key fields and if no non-search
key value from that record appears at level 0 on the main page, then RowlInit PeopleCode in that
record does not run.

In addition, if a non-search key value from that record appears on the pop-up page only, then the
system does not consider the field to be part of the main page. Because of this, no values for the non-
search key fields are retrieved from the database. To populate non-search key fields on the pop-up
page with data, you must place a non-search key value from that record on the main page. The field
can be hidden on the main page, but it has to exist there.

Designing Context-Sensitive Pop-up Pages

To create pop-up pages that retrieve data that maintains the key field context of the main page, you must
ensure that these conditions are met:

»  For each record definition that the pop-up page references, key field values must exist on the main
page.

Note: If the key field value is not found, use the Set Trace Flags option Related Displays, and search
for more information in the log file.

* The names of the main page fields in which these key values exist must be identical to the names of
the key fields of the record definitions referenced on the pop-up page.

Note: While the field names must be identical, they do not have to be key fields in the record
definition referenced by the main page.

* The fields in which the key values appear must appear in either the same scroll area as the field to
which you associate the pop-up page or at a preceding level. The page field to which you link the pop-
up page can be one of the fields that contains the key field values; frequently, it is the lowest order
key.

Consider this scenario:

If PRec s the record that the pop-up page references and the key fields are PRec.K1 and PRec.K2, then,
the K7 and K2 fields must exist on the main page as MRec.K1 and MRec.K2, where MRec is the record
that the main page references.

If the field on the main page to which the pop-up page is attached is in Scrol//4—a level one scroll area—
then both MRec.K1 and MRec.K2 must either exist in ScrollA or at level zero.

Note: On the main page, it is not necessary that the K/ and K2 fields appear in the same record, MRec in
the previous case. The fields could be MRec.K1 and NRec.K2, where NRec.K2 is some other field on the
main page in the correct context.

Context-Sensitive Pop-up Page Example

In this example, you see a User Details pop-up page. This page is associated with a view, which retrieves
information so that the page displays the employee's name, photo, department, phone number, address,
and web site URL.
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This example illustrates the fields and controls on the User Details pop-up page. You can find definitions

for the fields and controls later on this page.

Empl ID: _B_EQ

Employee Photo Employee Job Information

*Effective C
Employee
Last Name
First Name

*Departmel

Social Sec
Humber:

25000
[Marketing

617-283-5604

DeHaven James

309 Route 20

Chester, MA01011-88399

The fields on the pop-up page reference PS EMPL VW. The key field of PS EMPL VW is EMPLID,
which requires that the EMPLID field exist on the main page.

The field to which the pop-up page is linked is at level 0, which requires that EMPLID be at level 0 also.

Note: EMPLID is a key field on the PS_ EMPL VW record that the pop-up page references. While

EMPLID also happens to be a key field on the PS_ EMPL_JOB record that the transaction page
references, it is not a requirement.

Identifying Valid Controls on Pop-up Pages

You may insert these controls only on a pop-up page:

Frames

Group boxes
Horizontal rules
Static text

Static images

Check boxes
Drop-down list boxes
Edit boxes

Images
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* Long edit boxes
*  Push Button/Hyperlinks
* Radio buttons

¢ Charts

Note: Except for Push Button/Hyperlink page controls, these controls are automatically set as display-
only at runtime even if you do not set the Display-Only property on the control.

Using Push Buttons and Links on Pop-up Pages
You may use only these destination type values on a pop-up page:
» External link

* Internal link

* PeopleCode command

*  Process

e Secondary page

Note: Do not use other destination types for push button/hyperlink controls on pop-up pages because
unexpected results will occur.

ing Pop-up Pages

Before you define your pop-up pages, you should determine which data is appropriate for pop-up
information. Typically, this is data that supplements and enhances the data on the primary page or
information that you might access from more than one main page.

Note: When designing pop-up pages, carefully consider how to make them more versatile and reusable.

To define pop-up pages:

1. Select File > New and select Page from the New Definition dialog box.

2. Insert the record fields on the pop-up page.

3. Right-click the page and select Page Properties to open the Page Properties dialog box.
4. Select the Use tab.

5. Select Popup Page from the drop-down list box in the Page Type group box.

6. Select the page size:
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Field or Control Description

Auto-Size Select to size the page automatically to fit the fields that are
defined on it.

Custom Size Select to size the pop-up page by dragging the edge or by
entering the width and height in pixels.

(Optional) Select Adjust Layout for Hidden Fields.
Click OK and save your pop-up page.

If you selected Auto-Size, the system sizes the page automatically to fit the fields that are defined on
it when you save.

Associating Pop-up Pages with Fields

272

To associate pop-up pages with fields:

L.

2.

Select File > Open and select the main page.

Select Insert, Edit Box or Insert Push Button/Hyperlink..

Note: You can associate pop-up pages with display-only edit box and push button/hyperlink controls
at level 0 or inside of scroll areas only. If you associate pop-up pages with controls that are in grids,
you will receive an error.

Double-click the control.

Select the Use tab.

Select the Display Only check box.

In the Mouse Over Popup group box, select the Page Popup option.

Select the name of the pop-up page from the drop-down list box.

Note: Only pop-up pages appear in the drop-down list.

Click the OK button.
A dashed line should appear beneath the field to indicate its association with a pop-up page.

Save the page.

Note: If page controls are placed too close together on a page, the dashed line, which indicates an
associated mouse over pop-up page, might not appear beneath the control.
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Enabling Message Catalog Pop-up Pages

You can enable Message Catalog pop-up pages to embed context sensitive help on any PeopleSoft page.
This section discusses how to:

* Enable message catalog pop-up pages.

* Embed context-sensitive help in pop-up pages.

Enabling Message Catalog Pop-up Pages
To enable message catalog pop-up pages:

1. Double-click the field that accesses the pop-up page.
2. Select the Use tab.

3. Select the Display-Only check box.

Note: You must select Display-Only.

4. Select the Message Catalog Popup option.

5. Enter the Message Set and Message Number of the message whose Message Text and Explain strings
appear in the Message Catalog pop-up page.

6. Click the OK button.

Note: You can also set the Message Catalog entry for mouse over pop-up pages by using PeopleCode.

See “MouseOverMsgNum” (PeopleCode API Reference), “MouseOverMsgSet” (PeopleCode API
Reference).

Embedding Context-Sensitive Help in Pop-up Pages

You can add variables to a message to make a Message Catalog pop-up page context-sensitive to the
PeopleSoft product documentation online help.

Note: You must correctly configure and implement PeopleSoft online help.

To add variables to messages to embed context-sensitive help:

1. Access the Message Catalog (PeopleTools, Utilities, Administration, Message Catalog to access the
Message Catalog).

2. Select an existing message or create a new message.
3. Enter an explanation and place the variable in the Explanation field.

The table in the next section describes the variables and their usage.

Note: The text in the Message Text field appears as the pop-up page header. The text in the
Explanation field appears in the pop-up page body.
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4. Enable the pop-up page on the desired edit box control.

See Defining Pop-up Pages.

Embedded Help Variables

This table describes the variables that you can add to the embedded help content in the Message Catalog.
Use these variables to generate links on the embedded help pop-up page that enable the user to access

additional online help.
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Note: Your PeopleSoft online help option must be configured for any Help link to function properly.

Variable URL Label
SPBCTXT () This variable uses the current page Because no message is referenced,

name as the %o CONTEXT_ID% to build
the Help URL so that the embedded
link takes the user to the Help content
associated with the current page.

the label of the help link appears as
PeopleBooks Help.

$PBCTXT (sn, mn)

The argument sn is the Message
Set Number. The argument mn is the
Message Number.

This variable uses the current page name
as the %CONTEXT_ID% to build the
PeopleBooks Help URL so that the
embedded link takes the user to the
PeopleBooks content associated with the
current page.

Because a message is referenced, the
label of the help link appears as the value
that is stored in the Message Text field
for the referenced message.

If you reference an invalid message, the

label appears as PeopleBooks Help.

$PBCTXT (CTXT PG NM)

The argument CTXT PG _NM is a page

definition name.

This variable uses the CTXT PG NM
argument as the %CONTEXT_ID% to
build the PeopleBooks Help URL so that
the embedded link takes the user to the
PeopleBooks content associated with the
page referenced by the argument.

Because no message is referenced,
the label of the help link appears as
PeopleBooks Help.

$PBCTXT (CTXT PG _NM, sn,mn)=

The argument CTXT PG_NM is a page
definition name.

The argument sn is the Message
Set Number. The argument mn is the
Message Number.

This variable uses the CTXT PG_NM
argument as the %CONTEXT ID% to
build the PeopleBooks Help URL so that
the embedded link takes the user to the
PeopleBooks content associated with the
page referenced by the argument.

Because a message is referenced, the
label of the help link appears as the value
that is stored in the Message Text field
for the referenced message.

If you reference an invalid message, the
label appears as PeopleBooks Help.

$PBURLTBL (URL IDENTIFIER, s=
n,mn)

The URL IDENTIFIER is any URL ID
that is stored in the URL Maintenance
component.

See “URL Maintenance” (System and

Server Administration).
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This variable uses the URL

IDENTIFIER argument to build the help

URL so that the embedded link takes the

user to the site associated with the URL
1D.

Because a message is referenced, the
label of the help link appears as the value
that is stored in the Message Text field

for the referenced message.

If you reference an invalid message,
the system uses the URL _IDENTIFIER
argument as the label.
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Variable

URL

Label

The argument sn is the Message
Set Number. The argument mn is the

Message Number.

$PBLNK (http://www.site.com=>
,Sn,mn)

The argument sn is the Set Number. The
argument mn is the Message Number.

This variable uses the hard-coded URL
so that the embedded link takes the user
to the specified site.

Because a message is referenced, the
label of the help link appears as the value
that is stored in the Message Text field
for the referenced message.

If you reference an invalid message, the
system uses the URL as the label.

Example

In this example, the $PBCTXT variable uses QRY ADMIN as a CONTEXT ID that references the
Query Administration page in PeopleBooks:

This example illustrates the fields and controls on the Message Catalog page with context-sensitive
variable embedded in text. You can find definitions for the fields and controls later on this page.

Message Catalog

Message Set Number: 4

Description:

Short Description: HFR

Last Update Timestamp: 07/23/2010
]

*Message Number:

*Severity:

|Help Processor

Find | Wiew Al

1:45P 1

Message

First Kl 6 of7 I Last

[#[=]

*Message Text:

|Cnmpress Queries on Web Server

Description:

Selectthis check hoxto compress queries before sending them to the
wehb server. Far more infarmation an this tapic, click this link:

HPBCTAT(QRY_ADMIN,4,7)

In the Description field, the 4, 7 parameters refer to Message Catalog entry (4,7), which contains the

label to use for the generated link.
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This example illustrates the fields and controls on the Message Catalog page showing Query
Administration label in the Message Text field. You can find definitions for the fields and controls later on

this page.

Message Catalog

Message Set Number: 4

Description: |He|p Processor @

Short Description: HFR

First Kl 7 or7 [7] Last

Messages Find | View Al

[+][=]

Last Update Timestamp: 03/10/2009 9:564M

*Message Number: [
“sovery

*Message Text: |Query Administration &

Explanation:

On the Web Profile Configuration page at runtime, mouse over the selected control to see the generated
pop-up page:

This example illustrates the fields and controls on the Web Profile - General page showing the message
catalog pop-up page. You can find definitions for the fields and controls later on this page.

MNew Window | Help | Customize Page | B!

2C lual Addressing ookie R

Compress Queries on the Web Server

Profile Name: DEV
Description: Installation Defaults | Select this check box to compress queries befare sending

them to the web server. For mare information on this topic,
Authentication Domain: | click this link:
Query Administration
Help URL: http:/ipecplebooks.p
[“] compress Respol

Compress Respol

Compress Mime T|

[“] compress Query @')
Save Confirmation Display Time: 3000 Williseconds ¢

Enable Processing Message 7

Enable Hew Window 7

Notice that the pop-up text comes from Message Catalog entry (4,6) and the link label, Query
Administration, defined by the %PBCTXT(QRY_ADMIN, 4, 7) function comes from Message Catalog
entry 4,7. Click the Query Administration link, and the system accesses the PeopleBooks entry for the
ORY ADMIN CONTEXT _ID using that Help URL entry to ascertain the PeopleBooks location on the

web server.
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Note: You define the location of your online PeopleBooks by entering a URL in the Help URL field that
is located on the Web Profile - General page (PeopleTools, Web Profile, Web Profile Configuration).

See “Configuring General Portal Properties” (Portal Technology).

Related Links
Configuring Embedded Help for Scroll Areas, Grids, and Group Boxes

Understanding Pop-up Pages in Screen Reader Mode

For a user in screen reader mode, for every mouse over control, the system displays an additional image
that looks like an exclamation point ("!"). The accessibility user can click the image to display the mouse
over popup page. The user can press the escape button (Esc) to close the mouse over popup page.

This example illustrates the icon that appears next to fields with associated pop-up pages.

‘SEIlD: QEDM Depanment: DDDDi‘

Using Subpages

This section provides an overview of subpages and discusses how to:
e Define subpages.
» Insert subpages into pages.

* Specify informational subpage labels.

Understanding Subpages
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Subpages are a powerful means of factoring out commonly used page functionality in your application.
Rather than duplicating the same set of page fields on two or more pages, you can create a single subpage
that contains those page fields and then add it to any page. Subpages provide an easy way to maintain the
functionality that the page fields represent.

Subpages are even more effective when used with corresponding subrecords. To support the use of
subrecords with subpages, the system uses a record name substitution mechanism for subpage-type

page fields. Each subpage has a from record that is determined dynamically by the page definition in
PeopleSoft Application Designer and by PeopleSoft Pure Internet Architecture. The from record is a
record associated with one of the page fields on the subpage. Which page field depends on the page field
ordering, the types of page fields on the subpage, and whether the associated record is a subrecord. The
subpage itself must be fully expanded to make this determination. (Keep this fact in mind when working
with subpages that contain other subpages.)

You specify the to record in the Subpage Record Name Substitution field in the Insert Subpage dialog
box that appears after you insert the subpage into a page. (It also appears on the Subpage tab of the
Subpage Properties dialog). At runtime, when a subpage-type page field is expanded, each page field
that is associated with the dynamically determined from record is instead associated with the to record
that you specify. For example, you can populate a subpage with page fields that are associated with a
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subrecord so that the subrecord is determined to be the from record; then, when that subpage is used as a
subpage-type page field, you can specify the to record as one of the records that contains that subrecord.
You are able to associate a single set of page fields (through the subpage) with a variety of different
records (each containing the subrecord).

Defining Subpages

Creating a subpage is like creating a page definition except that you define it as a subpage rather than a
standard page in the Page Properties dialog box.

To define a subpage:
1. Select File > New > Page.
2. Insert the record fields on the page.
See Adding Page Controls.
3. Select File, Definition Properties to access the Page Properties dialog box.
Use this dialog box to define the type, size, and layout of the page.
4. Select Subpage in the Page Type drop-down list box.
5. Select the size of the page.
See Changing Page Use Information.
6. Select Adjust Layout for Hidden Fields if necessary.
7. Select Allow Deferred Processing if appropriate.

See Understanding Processing Modes.

Inserting Subpages Into Pages

After you create a subpage definition, insert a subpage control on your primary page and associate it with
the subpage definition.

To insert a subpage into a page:

L.

2.

Open the page into which you want to insert the subpage.

Select Insert > Subpage.

The Insert Subpage dialog box appears.

Select a subpage definition.

Specify the name of the subpage that you want to insert into the open page definition.
Select a record definition in the Subpage Record Name Substitution field.

The subpage writes its fields to a generic record. Specify the application-specific record name to
which you want the information in the subpage written.
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Note: All of the fields in a subpage must be associated with fields of a subrecord in the specified
record definition.

Click the OK button.

The subpage appears on the page. Its size reflects the size of the page control group, and it is
identified by the subpage definition name. During design time, the fields within the subpage are not
visible. At runtime, pages containing subpages are dynamically expanded. Be sure to leave a few
pixels of space between the left edge of the main page and the subpage page field to ensure sufficient
padding at runtime.

When saving a page with multiple subpages, be aware that you may receive a warning message if
duplicate fields are present.

Inserting a Subpage Into a Grid

You insert a subpage into a grid as you would any other column.

See Inserting and Manipulating Grid Columns.

Specifying Informational Subpage Labels

Document the purpose of the subpage by changing its informational label. The default subpage label is
Subpage. Any label that you attach to a subpage is for information only: it does not appear on the page,
but it does appear on the page definition printout and in the control order list. Use labels to differentiate
among multiple subpages on a page.

To specify informational subpage labels:

L.

Open the Subpage Properties dialog box.

Note that the Subpage tab displays the information that you entered on the Insert Subpage dialog box.
On the Label tab, enter your informational text label.

Enter the page field name in the General tab.

(Optional) Select Enable as Page Anchor if you want the subpage to serve as a jump destination on
the page.

Click OK.

Using Secondary Pages

This section provides an overview of secondary pages and discusses how to:

280

Define secondary pages.

Insert secondary page controls.
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* Associate secondary pages with primary pages.

Understanding Secondary Pages

Secondary pages are pages that you access through another page, usually by clicking a link or push
button. Secondary pages are ideal for entering and updating data that is supplemental to the data on

the primary page or data that is common to and can be accessed from multiple primary pages. While a
secondary page might sometimes appear as just another page to the user at runtime, secondary pages have
certain characteristics that are not shared with standard pages. For example:

* Secondary pages are not standalone pages that you access through the menu structure. You can
only access a secondary page from its primary page; the primary page and the secondary page are
associated by push button or link page controls.

* Secondary pages include OK and Cancel or Return buttons (or equivalent alternatives) so that the
user can accept or discard input, dismiss the secondary page, and return to the primary page.

* Secondary pages display no component buttons, such as Save, Return to Search, and so on.

Understanding Modal Secondary Pages

Modal secondary pages do not appear in a browser window. Modal secondary pages appear in front of a
browser window, capturing focus and disabling the primary page until you dismiss the secondary page.

You can move modal secondary pages by dragging the page title bar. Moving the page is useful when you
want to view information on the primary page while working with the secondary page. The appearance of
the cursor changes to indicate that you can move the page.

Use these guidelines to determine whether to specify secondary pages as modal. Specify a secondary page
as modal when:

» The content of the secondary page is relevant to the context of the primary page.
For example, you need to be able to see both the secondary page and primary page simultaneously.

» The content of the secondary page is such that the user can complete the transaction quickly and
easily.

By default, secondary pages appear as modal pages. You can change the default behavior at the definition
level by deselecting the Disable Display in Modal Window When Not Launched by DoModal
Peoplecode check box that appears on the Use tab on the Page Properties dialog box of the secondary
page. You also control secondary page modality by using any of the DoModal* PeopleCode functions.

Important! Do not select the Disable Display in Modal Window When Not Launched by DoModal
Peoplecode check box for fluid secondary pages. Fluid secondary pages must always be displayed in a
modal window.

Example: Modal Secondary Page

In this example, the user clicks the Change password link to access the Change password secondary page
in a modal window. The Change password page is displayed over the General Profile Information page,
which is the primary page.
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This example illustrates the Change password modal secondary page.

General Profile Information

PS5 User

Password

Change password
Change or set up forgotten passwo Change password X

Help

L Current Password
Personalizations

New Password
My preferred language fO]

My preferred language for re| Confirm Password

OK Cancel
Def

If you will be temporarily unavailable, you can select an alternate user to receive your routings.

Alternate User ID Q
From Date (example:12/31/2000)
To Date (example:12/31/2000)

Modeless Windows

In addition to modal secondary windows, you can create modeless secondary windows. A modeless
window is different from a modal window launched by any of the DoModal* functions in that its state

is separate from that of the parent, launching component. When a modeless window is launched from a
classic component using the TransferModeless function, the modeless window does not mask the parent
window, which allows the user to update the modeless and parent window from the same browser session
at the same time.

However, when a modeless window is launched from a fluid component using either the
ViewContentURLModeless or ViewURLModeless functions, the parent window is masked and cannot
be accessed until the modeless window is dismissed. In this respect and from the user’s perspective,

a modeless window launched from a fluid component operates similar to a modal window; but
programmatically, its state is separate from that of the parent, launching component.

Similar to modal, secondary windows opened by any of the DoModal* functions, the modeless window
does not include the browser title bar, browser menus, and the browser tool bars, status bar, and tool icons
associated with most browser windows.

Note: While the title bar of a modeless window includes an X (or cancel) button, it cannot include any
custom buttons.

Important! Only one active child modeless window can be open at one time. Therefore, after opening
a modeless child window from the parent, you cannot open a second modeless child window from that
modeless window. However, you can open a modal window from that modeless window.
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Defining Secondary Pages

Access the Page Properties dialog box for the page definition. (With the page open > select File >
Definition Properties.)

This example illustrates the fields and controls on the Page Properties dialog box: Secondary page type.
You can find definitions for the fields and controls later on this page.

F i

Page Properties [‘5_<|

eneral | Uze |

Page Type

| Secondary page

Prirmary Aecard:

QF & Cancel buttonz [ ]Close Box
Fage Size

| Auto-zize L |

width: |:| Height: |:|

Shyle
Page Style Sheet: == g Default Stple == w |
Page Backaround: | == Uze Default Style == “ |

Allovs Deferred Processing

[ ] Adiust Layout for Hidden Fields

] Dizable Digplay in Modal ‘Window When
Mat Launched by Dok odal Peoplecode

FPopup Menu: w |

[ ak. ] [ Caticel

To define secondary pages:

1. Select File > New and select Page from the New Definition dialog box.

2. Right-click the page and select Page Properties to open the Page Properties dialog box.
3. Select the Use tab.

4. Select Secondary Page from the Page Type drop-down list box.

5. Deselect the OK & Cancel buttons and the Close Box check boxes if you plan to develop
alternative buttons that dismiss the page. To use the standard buttons, accept the default values.

See Using Push Buttons and Links.

6. Select the page size:
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Field or Control

Description

Auto-Size

Select to have PeopleSoft Application Designer size the
page to accommodate the page controls that are defined
therein. The right and bottom edges of the page move left
and up, respectively, to eliminate any vacant space at the
right side and bottom of the page. The top and left edges of
the page are stationary, leaving any vacant space at the right
side and bottom of the page.

Custom Size

Select to manually size the secondary page by dragging the
edges or by entering the width and height in pixels.

7. Select the page style sheet to associate with the secondary page.

10.

I1.

12.

13.

To override the application default style sheet, select a different style sheet from the drop-down list
box. The style sheet that you select is available only for the controls on the secondary page.

Select the page background.

You can control the background of the page and any controls that do not have a style sheet associated
with them by specifying a style in the page background.

(Optional) Deselect Allow Deferred Processing if you want processing to occur each time the user
presses the Tab key to advance through the page controls.

(Optional) Select Adjust Layout for Hidden Fields if you want the page borders to adjust
automatically to accommodate fields that are hidden.

Note: For the page to adjust automatically, the hidden fields must be surrounded by open space or

have other hidden fields to the right or left.

(Optional) Select Disable Display in Modal Window When Not Launched by DoModal
Peoplecode if you want the page to appear within the browser frame comparable to the standard
application pages. If you select this option, you must use one of the DoModal* PeopleCode functions
if you want the secondary page to appear as a modal page. Leave this check box deselected if you
want the secondary page definition itself (not PeopleCode) to control the appearance.

Important! Do not select the Disable Display in Modal Window When Not Launched by DoModal
Peoplecode check box for fluid secondary pages. Fluid secondary pages must always be displayed in a

modal window.

Note: This option is disabled when the page type is set to Popup page.

Click the OK button.

The page definition size automatically adjusts if you set the page size to Auto-Size.

Add other page controls as is appropriate for the relationship of the data on the secondary page to the

primary page.
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To ensure that no data values are lost in the secondary page if it is opened from a grid on the primary
page using either the DoModalPopup or DoModal PeopleCode functions, you have two options:

*  Make sure the first field referenced in the secondary page is from the context record of the row
passed to the DoModal* PeopleCode function.

* Add the secondary page control to your grid on the primary page.

However, if the secondary page is opened by specifying Secondary Page in the Destination field on
the Type tab, data loss is not an issue because this methodology also requires that the secondary page
control be added to the grid on the primary page.

Related Links
“Creating Other Fluid Page Types” (Fluid User Interface Developer’s Guide)
“Working with Secondary Pages” (Fluid User Interface Developer’s Guide)

Inserting Secondary Page Controls

After you define a secondary page, you can place a secondary page control on your primary page and
associate it with the secondary page you just created.

To insert a secondary page control, access the primary page:

1.

2.

Select Insert > Secondary Page.
Click the primary page where you want to display the secondary page control.

The secondary page control looks like a small push button with the secondary page icon on it. This
control is invisible at runtime.

Double-click the control to access the Secondary Page Properties dialog box: Secondary Page tab.
Select the name of the secondary page to associate with the secondary page control on the active page.

Only secondary pages can be associated with secondary page controls. You cannot associate a
standard page or subpage with the secondary page control.

Select the Label tab.

This label is for informational purposes only. It appears in the Order tab of the page definition and in
the page description printout.

Position the secondary page control at the proper scroll level on the Order tab.

See Specifying Type Properties for Push Buttons or Links.

Save the page definition.

Note: When you use secondary page controls on primary pages, you must also insert a push button
control and write PeopleCode that invokes the secondary page.
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Associating Secondary Pages With Primary Pages
You can use two page controls to associate a secondary page with a primary page:
* Insert a push button or link page control on the primary page.

When you use this control type, you must set the Type properties to invoke the secondary page. At
runtime, when the user clicks the push button or link, the secondary page appears. Use this control
when:

*  You need no procedural PeopleCode logic before the secondary page appears (PeopleCode can be
used on the secondary page just like any other page).

* You want to control the formatting of the information (therefore, you want to use a page and not
use the Prompt function).

*  You use the secondary page multiple times.

See Using Push Buttons and Links.

» Insert a secondary page control on the primary page.

This control looks like a command push button, but it is invisible at runtime. When you use a
secondary page control, you must also insert and configure a push button on the primary page. After
you set the push button Type properties to invoke Command PeopleCode, you then call any of the
DoModal* PeopleCode functions from the FieldChange event for the push button to display the
secondary page.

See Inserting Secondary Page Controls.

See Using Push Buttons and Links.

See “Modal Windows and Secondary Pages” (PeopleCode Language Reference).

Using HTML Areas

This section provides an overview of HTML area controls and discusses how to:
* Insert HTML areas.

* Populate HTML areas.

* Change HTML area labels.

* Include HTML areas in the page tab order.

Understanding HTML Area Controls

You can insert an HTML area control on any PeopleSoft page. You can insert it at any level on a page,
and you can place it in a grid control. This control is rectangular and is easy to resize.

Populate the HTML area control in one of these ways:
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* Statically, in the page field property sheet.
* Dynamically, by associating the control with a record field or HTML definition.

If the control is linked to a record field, the value of the record field appears in the HTML area. Use
PeopleCode to associate the HTML area control with a predefined HTML definition.

When using HTML areas, consider:
*  HTML areas are downloaded to Microsoft Excel as a non-breaking space (&nbsp).

e HTML areas are not searched with the Find feature.

Generating Trees in HTML Areas

You can use the GenerateTree PeopleCode function with HTML areas. This example shows the tree that
is created by the GenerateTree PeopleCode function on the Select New Parent Folder page:

This example illustrates the fields and controls on the Example of a tree in an HTML area. You can find
definitions for the fields and controls later on this page.

Time Reporing
Personal Information
[= Payroll and Compensation
JE [view Paycheck]
B [view Payslips]
B Diew Payslip GBR]
B [3rd Party Pay Inguiry]

Populating HTML Areas

You can populate an HTML area either statically, using the HTML Area Properties dialog box, or
dynamically, by associating the control with a record field. Because the HTML that you write is included
in the HTML that is dynamically generated by the system at runtime, consider the following:

* The HTML that you include can affect the page layout.

Complying with the design-time sizing of the HTML area is the best way to ensure that you do not
affect the layout of the other page field controls. Adding an invisible frame around the HTML area
control can help ensure that you do not affect other page fields.

* You can use only certain types of HTML tags. These tags are not supported by the HTML area
control:

o <body>
e <frame>

¢ <frameset>
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o <form>
e <head>
e <html>
e <meta>
o <title>

Using JavaScript in HTML Areas

When using an HTML area field for adding JavaScript, make sure that JavaScript code is added only once
per page. It should not be added in multiple places on a single page unnecessarily. This improves browser
performance, especially for display on mobile devices.

Using Rich Text Editor-Generated HTML in an HTML Area

When you use the rich text editor to generate HTML that appears in an HTML area page control, you
must call the ProcessRTEHTML function to process the rich text editor-generated HTML before you
assign it to the HTML area. The ProcessRTEHTML function wraps the HTML inside a <div>
element, sets the style class to PT_RTE DISPLAYONLY, and attaches the image processing JavaScript.
Use the following code as an example:

Declare Function ProcessRTEHTML PeopleCode WEBLIB PTRTE.ISCRIPT1 FieldFormula;
&HTMLAAREA.value = ProcessRTEHTML ("URL ID of the image target", "HTML Data To be P>
rocessed") ;

Your code might look like this:

&HTMLAAREA.value = ProcessRTEHTML (URL.PT RTE IMG DB LOC, "<p>example</p>");

The &HTMLAAREA.value should be similar to this:

<div 1d="RTEDiv188" class="PT RTE DISPLAYONLY">

<p>example</p>
<script type="text/javascript" language="JavaScript">
PTRTE CheckImages ("", "PT RTE IMG DB LOC", "RTEDiv188");
</script>
</div>

Using HTML Areas in AJAX Mode

Note the following code restrictions in HTML areas when running the application in AJAX mode:
* Do not include XML tags, such as CDATA.

* Do not include empty or commented out <script> elements.

* Donotinclude document.write as partofthe HTML in an HTML area.
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Using HTML Areas in Grids or Scroll Areas

I[f HTML area fields are used in a grid or in a scroll area, they can cause performance degradation if there
are more than 50 rows in the grid or in the scroll area, or if there are many HTML area fields in the grid
or in the scroll area. This is due to the behavior of partial page refresh. During a partial page refresh, the
system cannot determine what has been changed within the fields of an HTML area, so all fields in an
HTML area are refreshed, regardless, which can hamper performance.

Related Links

“Using the GenerateTree Function” (PeopleCode Developer’s Guide)
Inserting HTML Areas

To insert an HTML area on a page:

1. Select Insert > HTML Area.

2. Draw the HTML area on your page.

3. Move the HTML area control by dragging it with the mouse or by pressing the arrow keys.

Populating HTML Areas

This section discusses how to:
e Populate an HTML area statically.

* Populate an HTML area dynamically.
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This example illustrates the HTML tab of the HTML Area Properties dialog box. The Constant radio
button has been selected, which determines that static HTML code can be entered in the edit box.

HTML Area Properties -
HTML | Label | Gereral | Fluid |

Yalue
() Field [ THTML Tags Only
Becord Mame:
Field Mame:

y

L
[ ] Bespond Only Once

OF. | | Cancel

Field or Control Description

Field Select the Field radio button to enable selection of a record
field for populating the HTML area dynamically at run time.

Constant Select the Constant radio button to enable entering static
HTML code in the text entry area below.

HTML Tags Only Select this check box to disable processing of the HTML
code that will relocate special tags such as <meta> and
<script> from the body of the code into the <head> section
of the HTML document. Therefore, this check box should be
selected only when the HTML code includes tags that are for
the <body> section of the HTML document.
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Field or Control Description

Record Name When the Field radio button is selected, select the record
name.

Field Name When the Field radio button is selected, select the field name

that contains the HTML code at runtime.

Respond Once Only Select this check box to indicate that this HTML area is to be
included in the AJAX response one time only, except when
some other properties of the HTML area have been changed,
such as its content, label, and so on. When this check box is
unselected, the HTML area is always included in the AJAX
response. This setting applies to HTML areas at any level
(from level 0 to level 3).

Note: This setting can be overridden by the
“ForceUpdateOnce” (PeopleCode API Reference) property of
the Field class.

Populating an HTML Area Statically

To populate an HTML area statically:

1. Access the HTML Area Properties dialog box.

2. On the HTML tab, select Constant as the value type.

3. In the text entry area, enter the HTML code that you want to appear in the HTML area.

Populating an HTML Area Dynamically

To populate an HTML area dynamically:

1. Access the HTML Area Properties dialog box.

2. On the HTML tab, select Field as the value type.

3. Specify the record and field to which you want to associate the HTML area control.

The value of the record field generates the HTML code that is included at runtime in the HTML area.

Note: When you associate an HTML area control with a field, make sure that the field is long enough
to contain the data that you want to pass to it. For example, if you associate an HTML area control
with a field that is only 10 characters long, only the first 10 characters of your text will appear. You
should use long character fields for record fields that are associated with an HTML area control.

Changing HTML Area Labels

Assign a distinct label to your HTML area to distinguish it from other HTML area controls on the Order
tab of the page definition.
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Note: Unlike other page controls, the label for an HTML area is displayed on the Order tab only and is
not displayed at runtime when the page is rendered in the browser.

This example illustrates the Label tab of the HTML Area Properties dialog box.

| HTML | Label | General | Flid |

Label Text
Type: |N one

Text: |

Label 1D | ~""|

Contest: | |

Meszage Set: I:I kzg Humber: I:I

Cancel
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Field or Control

Description

Type

Select the label type:
*  None — Select to display no label on the Order tab.

»  Text— Select to display text that you enter in the Text
field. The default text is the long name for the field from
the associated record definition.

*  Message Catalog — Select to display a Message Catalog
entry as the label.

*  RFT Long — Select to display the RFT long name for the
field from the associated record definition. This value is
the default.

*  RFT Short — Select to display the RFT short name for
the field from the associated record definition.

Text

Enter the text to display on the Order tab.

Label ID

Select from the drop-down list box the label you want to use
for the HTML area. The available choices are based on the
Label ID column and the Long Name column for the selected
field definition.

The default setting for this option is Use Default Label. This
default is determined by the label you select as the default for
the field definition.

Context

Displays text to assist the translation team determine the
context of the field label to be translated. The context is
determined by the field name and label ID combination. If
no contextual information exists in the database, then no text
appears in this field.

Message Set/Msg Number

Enter the message set number and message number to specify
the label text.

To change an HTML area label:
1. Access the HTML Area Properties dialog box.
2. Select the Label tab.

3. Enter a brief text description of the HTML area.

This label does not display at runtime; however, it appears on the Order tab of the page definition.

Including Fields Within HTML Areas in the Page Tab Order

Copyright

When the PeopleSoft system generates HTML for a page, it creates a tab index, or order, including every
control or widget on the page, based on the field order for that page in Application Designer. However,
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with HTML areas, the system skips any control defined within an HTML area, by default, when building
the tab index. In some situations, this may be confusing to an end user, such as in the case when screen
readers are used.

To include the controls in an HTML area within the page tabbing order, add the %tabindex meta-variable
to the HTML. At runtime, for each field inside an HTML area that is defined with the %tabindex meta-
variable, %tabindex will be replaced with the tab index of the HTML area itself.

In the following example, two fields have been defined with the %tabindex meta-HTML variable, while
one has not:

<a href="http://www.w3schools.com" tabindex="%$tabindex">Visit W3Schools.com!</a>

<a 1d="HELP" name="HELP" href="javascript:some functionl();" tabindex="%tabindex">H=>
elp</a>
<a 1d="NEWWIN" name="NEWWIN" href="javascript:some function2();">New Window</a>

At runtime, if the tab index for the HTML area is 20, then this HTML fragment resolves to:

<a href="http://www.w3schools.com" tabindex="20">Visit W3Schools.com!</a>
<a 1id="HELP" name="HELP" href="javascript:some functionl();" tabindex="20">Help</a>
<a id="NEWWIN" name="NEWWIN" href="javascript:some function2();">New Window</a>

This meta-variable is documented in more detail in the PeopleCode documentation, see “%tabindex”
(PeopleCode Language Reference) for more information.

Note: The tab order of controls within an HTML area cannot be customized by end users.

Using Push Buttons and Links

This section provides an overview of push buttons and links and discusses how to:
e Insert push buttons or links.

*  Specify type properties for push buttons or links.

*  Specify label properties for push buttons or links.

»  Specify use properties for push button or link.

*  Programmatically change hover text for push buttons or links.

Understanding Push Buttons and Links
PeopleSoft Pure Internet Architecture supports these features for push button and link controls:
* Selecting link style.
» Selecting these types of push buttons and links:
* External link.
* Internal link.

* Page anchor.
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*  PeopleCode command.
* Process.

*  Prompt action.

» Scroll action.

* Secondary page.

¢ Toolbar action.

* Selecting these image options:
*  On mouse over.

¢ When disabled.

Inserting Push Buttons or Links

After you add a push button or link control to your page, you can define the attributes by opening the
Push Button/Hyperlink Properties dialog box.

To insert a push button or link:
1. Select Insert > Push Button/Hyperlink.
2. Click where you want the upper, left-hand corner of the control to begin.
A push button of small image size appears.
3. Double-click the push button to access the Push Button/Hyperlink Properties dialog box.
4. On the Type tab, select whether the control appears as a push button, hyperlink, or action widget.
5. Select a destination type from the Destination drop-down list box.

See Specifying Type Properties for Push Buttons or Links.

6. Select the record and field names with which you want to associate the push button or link.
7. Select any of the remaining Type options based on your destination type.
8. On the Use tab, select the purpose of the control.

See Specifying Use Properties for Push Buttons or Links.

9. Save the page.

Specifying Type Properties for Push Buttons or Links

Access the Push Button/Hyperlink Properties dialog box.
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This example illustrates the fields and controls on the Push Button/Hyperlink Properties dialog box: Type
tab. You can find definitions for the fields and controls later on this page.

Push Button/Hyperlink Properties

X
Type Label Use  General Fluid
Type External Link
(O Push Button ®) Hyperlink. (O Action Widget Static Dynamic
Destination: Intemal Link b
Record Name: _DEHNED-PSWD V| URL Encoded by Application
Field Name: | v
- Internal Link
LT Use Default Styls ** )
Partal |U se Current v
Aclions Node LOCAL_NODE v
Menu: | “
Process N
Secondary Page
[] Use data from current page in search
Action Widget Settings

Related Content Event
Usze Default JavaScnpt

Dizplay in Related Action Menu
Show in Page

Achon Widget

Cancel

Type Tab

Each destination type that you select enables a different region on the Type tab, enabling you to further
define your push button or link. Select one of these values from the Destination drop-down list box:
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Field or Control

Description

Type

Select a type of push button or hyperlink. Options are:

Push Button: Adds control in the shape of a button with
borders that end users click.

Hyperlink: Adds a control of underlined text with no
border that users click.

Action Widget: Adds a hyperlink that triggers JavaScript
when clicked. When selected, the system defaults the
Destination to PeopleCode Command and activates the
Action Widget Settings group box.

Important! The combination of record and field names
associated with the action widget must be 28 characters or
less.
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Field or Control

Description

External Link

Accesses a uniform resource locator (URL). You can select a
value from the URL table or use the value of a record field to
define the destination.

Selecting this option enables the External Link group box.
You can choose to have the URL encoded or not by selecting
the Encoded by Application check box.

Selecting this option applies an external link to your page in
the form of a push button or link that accesses a new page,
taking the user to the external web site that you designate. To
return to the primary page, the user closes the new page. When
setting the record and field name, consider these points:

+ Ifyou specify a dynamic external link, you must enter a

record name and field name.

The system uses the value of the record and field
specified as the value of the link.

*  Whether the external link is static or dynamic, you can
use the specified record and field names to control the
page field in PeopleCode when you want, for example, to
hide the link dynamically with PeopleCode.

*  The tool tip, or mouse over text, that appears with the link
at runtime comes from the RFT long label assigned to the
record field.

However, the RFT long label appears only if it is different
from the assigned display value of the link and it is not
null. If the link appears as an image button, the tool tip

is derived from the label text if it exists. Otherwise, the
system uses the RFT long label.
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Field or Control

Description

Internal Link

Accesses a PeopleSoft page. Parameters include the menu path
to the page and a check box to specify whether data from the
current page should be used in the search dialog box.

Selecting this option enables the Internal Link group box.

Selecting this option adds an internal link in the form of a push
button or link that you can use to access another component or
page from within the system or another PeopleSoft database

or node. You can even specify the type of action mode to

open in for that page. To control the push button or link in
PeopleCode, enter the record and names.

Like the external link, if you associate a record and field name
with this link, the tool tip that appears at runtime draws from
the RFT long label for the record field. However, the RFT long
label only appears if it is different from the assigned display
value of the link.

Instant Messaging Action

Important! Do not select this option. MCF instant messaging
has been deprecated in PeopleTools 8.59 and is no longer
supported. This option will be removed in a future release.

Page Anchor

Enables the user to jump to the anchor tag that you designate
for a page field on the General tab of the properties dialog box
for that field.

Selecting this option enables the user to jump from one
destination (the link that you assign as the page anchor) to
another (the field that you enable as the page anchor) in your
page. When you select this option, the page fields that you
previously set as page anchors on the General tab of the
properties dialog box appear in the Related Control drop-
down list box in the Actions group box. You can place as
many page anchor buttons or links on the page as necessary.

PeopleCode Command

Associates a record field, so when the user clicks the push
button or link, the system runs any FieldChange PeopleCode
that is associated with that field. Enter the record and field
names. The field must have PeopleCode in the FieldChange
event.

Important! The combination of record and field names
associated with the action widget must be 28 characters or less.
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Field or Control

Description

Process

Runs processes that you set up previously with PeopleSoft
Process Scheduler. Associate process push buttons with a
specific process definition; the process is run each time that a
user clicks the button.

Selecting this value enables the Process group box, where you
can specify the type and name of the process that you want to

run.

See “Submitting Process Requests” (Process Scheduler).

Prompt Action

Displays a prompt dialog box for a specific control field. Adds
a custom prompt button or link next to a field on the page in
place of the standard prompt that is associated with that field.
For example, you might want the prompt to read Find an
Airport Code.

Selecting this value enables the Actions group box. In the
Related Control drop-down list box, select the field that you
want to associate with the prompt. The systems sets the action
type, Prompt, automatically. Set the text label properties for
the link on the Label tab.

Scroll Action

Represents certain actions that a user can perform on a grid,
scroll area, and scroll bar, such as bottom, top, insert row, and
SO on.

Use to provide action buttons for the grid, scroll area, or scroll
bar in areas outside of that control, such as at the bottom of the
page or outside the borders of the control.

Selecting this value enables the Actions group box, where you
can specify the action type and related control. The Action
Type field enables you to select the action to be performed

in the specific level. The level is specified in the Related
Control field. Specify one of the following scroll actions:
Bottom, Next, Previous, Row Delete, Row Insert, and Top.

For example, if you want a user to be able to move through
a page at runtime, set the action type to Next or Previous and
specify which scroll area you want those actions to control.
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Field or Control

Description

Secondary Page

Access an existing secondary page. After you design a
secondary page, you must associate it with a control on the
primary page. The secondary page push button or link is the
starting point for the user of that secondary page. Selecting
this option enables the Secondary Page group box, where you
can select the name of the secondary page that you want to
associate with the push button or link.

Toolbar Action

Represents the various toolbar actions available to the user.
A user can perform several actions on a page, such as save,
display the next page in a group, correction mode, and so on.
These normally reside on the toolbar at the bottom of each

PeopleSoft Pure Internet Architecture page. Use this type
of push button or link for placing save, next in list, or other

toolbar functions on the page.

Selecting this value enables the Actions group box, where you
can specify the action type: Add, Correction, Next in list, Next
in Worklist, Next Page, Notify, Previous in List, Previous in
Worklist, Previous Page, Refresh, Return to List, Save, Update/
Display, Update/Display All, or View Worklist.

The following action types are supported on fluid pages only:
Back, Clear Prompt, Help Link, Home, IN Prompt, Logout,
Nav Bar, New Window, Search, Search Cancel, and SUOW

Save.

External Link Group Box

In this group box, select Dynamic or Static and enter the URL ID, if necessary. Select a value from the
URL Maintenance table of a record field to define the destination. For example, a derived record field
might be used to set the destination value dynamically at runtime. The value of the derived record field is

placed in the <href> tag of the HTML.

See “URL Maintenance” (System and Server Administration).

Internal Link

Field or Control

Description

Portal

Select the portal to which you want the internal link to point.

Use Current is the default. Valid values include all of the
values in the PORTAL NAME column of the PSPRDMDEFN
table.
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Field or Control

Description

Node

Select the PeopleSoft database to which you want the internal
link to point. Local stands for the node that is marked as the
default only. If the content reference you need is registered
with a non-default local node, make sure you choose the exact

same value from this drop-down list box.

Valid values include all of the values in the
MSGNODENAME column of the PSMSGNODEDEFN table.
If you select a node other than Local, the Use data from
current page in search check box is deselected.

The node that you select should match the node for the
destination component in the Registration Wizard or on the
Content Ref Administration page. Select PeopleTools >
Portal > Structure and Content. Click the Edit link to

access the Content Ref Administration page.

Menu

Select the menu name in which the destination page is
contained.

Component

Select the component in which the destination page is
contained. These values depend on the menu that you select.

Market

Select the market of the destination component.

See Specifying Market-Specific Components.

Page

Select the page that should be active. These values depend on
the component that you select.

Action

Select the action mode in which you want the page to begin.

Use data from current page in search

Select if you want data from the current page to be used in

the search dialog box. This option ensures that the new page
inherits the proper keys from the context of the current page.
The process is almost identical to the Transfer( ) PeopleCode

function, and it performs a similar function.

If this check box is selected, the system discards the existing
key list; builds a new key list from the current component
buffer using the context of the field (when a choice exists
between rows in a scroll area); and uses this key list to start the

new component.

If this option is deselected, the system uses the existing key list
in the normal manner.
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The default usage for the action widget is to add a control to a page that when clicked displays a drop-
down menu containing the related actions associated with that widget. However, this widget can also be

used to trigger custom JavaScript.

Field or Control

Description

Use Default JavaScript

Select to make the Custom JavaScript edit box read-only and
populate the edit box with the with the default JavaScript,
RelatedActionJsS.

If you want to revert the field to the default, just select this
check box and the system repopulates the field with the default
value.

Custom JavaScript

When enabled, enter the name of the custom JavaScript to
execute.

See “Understanding the PeopleSoft Related Content Framework™ (Portal Technology)

Specifying Label Properties for Push Buttons or Links

This section discusses how to:
*  Specify a text label.

*  Specify an image label.
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This example illustrates the fields and controls on the Push Button/Hyperlink Properties dialog box: Label
tab. You can find definitions for the fields and controls later on this page.

Push Button/Hyperlink Properties x

Type Label Use  General Fluid

Label Type Label Image Format / Size
() Test (® Image [Both Scale Size
Reset to actual image size
Label Size : R
(®) Small Image (O Large Image Label Image
() Standard Test () Custom Image |D: v

Al tag for image

Type: Static Text v
Text: |
On Mouse y
Owver:
Context: |
When
Disabled: -

Label Alignment

Left Centered Right

Cancel

Specifying a Text Label

To specify a text label for a push button or link:

Important! For an action widget, Text is the only valid label type selection. Even though Both is
presented as an option, do not select Both; if you do, the action widget will not be displayed.

1. Access the Push Button/Hyperlink Properties dialog box.
2. Select the Label tab.

3. In the Type group box, select Text.

4. Select the size.

Standard push buttons can be one of three sizes, depending on what kind of text or image you want to
display on the button face.
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Field or Control

Description

Small Image

Creates toolbar-sized buttons that handles small 16 x 16
pixel images.

Large Image

Handles 32 x 32 pixel images.

Standard Text

Matches the Microsoft standard dimensions for text push

buttons.

Custom

Select if none of these sizes meets your needs. When you
click OK, the push button displays selection handles that

you can use to resize it.

5. Specify the type of label text.

Depending on the destination type that you selected, the values in the Type drop-down list box differ.

Field or Control

Description

Message Catalog

Select to reference a message that exists in the message
catalog. Enter the message set and number. Message catalog
items are all translatable.

RFT Short (record field table short)

Select to label the push button with the short name for the
field from a record definition. The RFT stores attributes

for fields in a record definition. Use this option only if you
specified a record definition and field name on the Type tab
in the Push Button/Hyperlink Properties dialog box. The
RFT short name appears on the push button when you click
OK and return to the page. Select the label ID if you do not
want to use the default label if more than one label has been
set for the record field.
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Specifying an Image Label
To specify an image label for your push button or link:
1.

2.
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Field or Control

Description

RFT Long (record field table long)

Select to label the push button with the long name for

the field. Use this option only if you specified a record
definition and field name on the Type tab in the Push
Button/Hyperlink Properties dialog box. The RFT long
name appears on the push button when you click OK and
return to the page. Select a different label ID if you do not
want the default label if more than one label has been set for
the record field.

The system uses the RFT long label as the tool tip at runtime
for links if it is different from the assigned display value of
the link and it is not null. If more than one label is stored for
the record field, you can select an alternate tool tip from the
Label ID drop-down list box.

Static Text

Select to enter the text to appear on the label.

URL Description

Select if you selected External Link as the destination on the
Type tab. Select the style from the drop-down list box.

See Understanding Style Sheets and Style Classes.

Select the alignment.

This option is only available if you selected Hyperlink for the type on the Type tab. Push button text
is automatically centered for controls that appear as push buttons. Push buttons with text and images
are automatically center-aligned when used in grids.

Access the Push Button/Hyperlink Properties dialog box.

Select the Label tab.
Select Image for the type.

Specify the size.

If you select Custom, the Image/Format Size group box becomes available.

Field or Control

Description

Scale

Select to adjust the width and height as percentages.
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Field or Control

Description

Size

Select to set the image size by altering the width and height
in pixels.

Reset to actual image size

Resizes the image according to its natural size. That is, the
image size is not manipulated by custom width or height

values.

5. Specify the image ID.

Select one of the predefined image definitions or click the Browse button to view push button images.

See Understanding Image Definitions.

6. Inthe Alt tag for image group box, specify the hover text type.

Field or Control

Description

Message Catalog

Select to reference a message that exists in the message
catalog. Enter the message set and number. Message catalog

items are all translatable.

RFT Long (record field table long)

Select to use the long name of the record field as the
hover text. Use this option only if you specified a record
definition and field name on the Type tab in the Push
Button/Hyperlink Properties dialog box.

The system uses the RFT long label as the tool tip at runtime
for links if it is different from the assigned display value of
the link and it is not null. If more than one label is stored for
the record field, you can select alternate hover text from the
Label ID drop-down list box.

RFT Short (record field table short)

Select to use the short name of the field as the hover text.
Use this option only if you specified a record definition and
field name on the Type tab in the Push Button/Hyperlink
Properties dialog box. If more than one label is stored for
the record field, you can select alternate hover text from the
Label ID drop-down list box.

Static Text

Select to enter the text that will appear on the label.

7. (Optional) Select the image that will appear on a mouse over.

For example, you might want to highlight an image so that users can easily see which option they are

selecting.

Copyright © 1988, 2023, Oracle and/or its affiliates.

307



Using Page Controls Chapter 8

8. (Optional) Select an image that will appear when the button is disabled.

Selecting Both Option

Select the Both check box to display a text label and an image label on your push button or hyperlink.

Important! The Both option can be used only within fluid applications or pages; it is not supported on
classic pages.

You can specify whether the text label appears before the image or after the image by using the Label
Rendering group box on the Fluid tab. See “Setting Properties on the Fluid Tab” (Fluid User Interface
Developer’s Guide).

Specifying Use Properties for Push Buttons or Links

Access the Push Button/Hyperlink Properties dialog box and click the Use tab.
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This example illustrates the fields and controls on the Push Button/Hyperlink Properties dialog box: Use
tab. You can find definitions for the fields and controls later on this page.

Push Button/Hyperlink Properties >

Type  Label Use  General Fluid

Field Use Options touze Over Popup
[] Enable 'when Page iz Display Orly (®) Mo Popup
Open in Mew window (") Page Popup
Beplace Current Window (0 Message Catalog Popup
[] Activate by Enter Key
Message Set/Mumber. 0 0

[ 5et Component Changed
Persizt Grid Colurnn in bMenu Teut:

[J Execute PC on Row/Group Click

[J Execute SearchSave Evert

Grid Cell Alignment
Left Centered Right

Cancel

Field Use Options

This table describes the Field Use options:

Field or Control Description

Enable When Page is Display Only Select to make the push button or link available to users who
have display-only access to this page.

Display-only access is set in the permission list properties.
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Field or Control

Description

Open in New Window

Select to open the target content page in a new browser
window. This option is enabled when the destination type is
either Internal Link or External Link. This option and Replace

Current Window are mutually exclusive.

Note: This option is not supported on fluid pages. To open a
page in a new window for a fluid page, use PeopleCode, such
as ViewURL or ViewContentURL.

Replace Current Window

Select to replace the existing content in the target area. This
option is enabled when the destination type is either Internal
Link or External Link. This option and Open in New window

are mutually exclusive.

Activate by Enter Key

Select to activate the push button or link when the user presses
the Enter key. You can have more than one push button or
link with this feature set per page, as long as only one of these
fields is enabled at runtime. Otherwise, only one push button
or link with this attribute enabled is allowed per page. This
feature is available for all control types except external links.

When using Activate by Enter Key in a scroll area or grid with
an occurs count greater than one, the Enter key triggers the
first row only.

Note that on a secondary page with the standard OK and
Cancel buttons enabled, the Enter key activates the OK
button rather than a custom button or link.

Note: On fluid pages, only the button with this feature on the
main page is triggered. Buttons with this feature on fluid side
pages, fluid header page, or fluid footer page are not triggered.
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Field or Control Description

Set Component Changed Enables the system to issue a save warning for the field if

the user changes the value and attempts to exit the page
before saving. This setting reinforces current save warning
behavior. This option is set by default for edit boxes, long
edit boxes, radio buttons, check boxes, and drop-down list
boxes. Deselecting this option overrides the save warning
that normally appears to users. The user will not see a save
warning after changing the value of the field and attempting
to exit the page. An example of when this might be necessary
is for a drop-down list box that includes links to another page.
If the user selects a link from this field to transfer to another
page but has not made any other changes to the page, then the
system is not required to issue a save warning.

By deselecting the Set Component Changed flag, you ensure
that no save warning message is issued for this field. This
option works for fields associated with a derived work field or
database record field.

For the push button/hyperlink control, the default setting is
deselected instead of selected, unlike with other page controls.

Persist Grid Column in Menu Important! Persistent search, the drop-down menu, and other

forms of classic navigation are no longer supported. The
default navigational interface for PeopleSoft applications in
the current release is based on the fluid banner, which can be
used for both classic and fluid applications.

Select to include the field as a list box item in the persistent
search results grid. You must also select the Persist in Menu
grid property for the grid that contains the field.

This property is disabled on check boxes and radio buttons.

You must enable recent search results caching at the system

level in the web profile for this property to take effect.

Note: This property applies only to fields that appear in grids
on pages that are used as custom, application-specific search

pages.
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Field or Control

Description

Execute PC on Row/Group Click

Important! Use this property in fluid applications only.

Select to identify this button or hyperlink as a trigger field for
either the grid row or group box containing this page field.
When the user clicks or taps anywhere in the grid row or
group box, the system executes any FieldEdit and FieldChange
PeopleCode associated with this field.

Note: On fluid pages, if there is a rich text editor field in a
scroll area, do not enable a row action for the scroll area.

Execute SearchSave Event

Important! Use this property on custom fluid search pages or
custom fluid prompt pages only.

Select to trigger the execution of SearchSave PeopleCode on
a Search button appearing on a fluid search page or a fluid
prompt page.

Grid Cell Alignment

Push buttons with images or text are center-aligned automatically when in a grid. Otherwise, select Lef,

Centered, or Right.

Note: Grid cell alignment properties are only enabled when the control is contained within a grid and the

control type is configured as a text hyperlink.

Mouse Over Popup

Select the Display Only check box to enable the Mouse Over Popup options.

Note: The mouse over option is intended for hyperlinks and display-only edit box fields, not for Push

Buttons.

Select from these mouse over pop-up options:

Field or Control Description
No Popup Select to have no pop-up page. This value is the default.
Page Popup Select to associate this control with a pop-up page that you

select from the drop-down list box. Only pop-up pages appear
in the Page Popup drop-down list box.
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Field or Control Description

Message Catalog Popup Select to associate this control with a system-defined
message pop-up page that displays a message from the
Message Catalog. When you select this option, the Message
Set/Number fields are enabled. You can also design and
implement Message Catalog pop-up pages to be context

sensitive.

See “Message Catalog” (System and Server Administration).

Message Set/Number Enter the message set and message number of the message.
These fields are enabled when you select Message Catalog
Popup.

Text Displays the message text of the message set/number that you

select. This field is display-only.

Note: Attempts to make a push button/hyperlink editable at runtime when it has a mouse over pop-up
page associated with it, for example, using PeopleCode, will fail.

Related Links
Understanding Pop-up Pages

Programmatically Change Hover Text for Push Buttons or Links

Copyright

Hover text or mouse over text enables you to display additional or supplemental information about a
button or link. Under certain circumstances, you might want to vary the hover text based on the context of
application data on the page.

You can alter hover text by using the PeopleCode HoverText Field property. This property sets the
hover text for any buttons or links associated with the field. The maximum length of hover text is 100
characters. You can use the Message Catalog to store hover text.

Example: Changing Hover Text Programmatically

To set hover text for a push button or link at runtime, use PeopleCode to define the HoverText property
for a field definition.

QE ABSENCE HIST.QE ABSENCE TYPE.HoverText = MsgGetText (95, 5037,
"Personalize Layout");

Note: The HoverText Field class property is available for the push button/hyperlink page control only.
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Understanding Scroll Areas, Scroll Bars, and Grids

A page must reflect the underlying table structures so that the system knows where to store data in the
database. When you have more than one underlying record definition on a page, the role of scroll areas,
scroll bars, and grids in page processing is important. Scroll controls and grids define parent and child
record definition relationships on a page.

You assign an occurs level to each scroll control or grid on the page to indicate the relationship between
the record definitions and the controls and to determine how the data is processed. The primary record
on a page at level 0 has no scroll area or occurs level associated with it. If the page contains a record
that is subordinate to the primary table, it has a scroll control with an occurs level of 1. A table that is
subordinate to the level 2 record has a scroll area or grid with an occurs level of 2. PeopleTools does not
support nesting beyond three levels.

PeopleSoft Application Designer automatically nests the scroll area after you set the occurs levels
sequentially. Each field that you place on the page after each scroll area is automatically placed inside the
scroll area preceding it until you place the next level-based control on the page.

Using Scroll Areas and Scroll Bars

This section provides an overview of scroll areas and scroll bars and discusses how to:
* Set scroll area general attributes.

* Set scroll area label properties.

* Set scroll area use properties.

»  Set scroll bar label properties.

* Set scroll bar use properties.

*  Control scrollable data.

* Convert scroll bars to grids.

Understanding Scroll Areas and Scroll Bars

Scroll areas, rather than scroll bars, are the preferred control for representing multiple rows of data from
a table because they are easier to use during design time and offer a wider array of features. The final
product at runtime appears more contained because the default setting places a border around the data.

The benefits of using scroll areas rather than scroll bars are:
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* The navigation tools that you select for a scroll area are automatically positioned on the navigation
bar or footer bar.

For scroll bars, you must place these buttons and links on the page manually.
*  Scroll areas provide the option of showing or hiding a border around the data.
* Scroll areas provide the option of a View All button and a Find feature.

* Scroll areas enable you to determine the text or image that appears for the action items in the
navigation bars.

* Scroll areas provide a row separator when you select multiple occurrences of data.

Scrolls, Record Relationships, and Page Processing

A page must reflect the underlying table structures so that the system knows where to store data in the
database. When you have more than one underlying record definition on a page, the role of scroll areas
and scroll bars in page processing is important. Scroll controls define parent and child record definition
relationships on a page.

You assign an occurs level to each scroll control on the page to indicate the relationship between the
record definitions and the controls and to determine how the data is processed. The primary record on a
page at level 0 has no scroll area or occurs level associated with it. If the page contains a record that is
subordinate to the primary table, it has a scroll area with an occurs level of 1. A table that is subordinate
to the level 2 record has a scroll area with an occurs level of 2. PeopleTools does not support nesting
beyond three levels.

PeopleSoft Application Designer automatically nests the scroll area after you set the occurs levels
sequentially. Each field that you place on the page after each scroll area is automatically placed inside the
scroll area preceding it until you place the next level-based control on the page.

Scroll Areas

A scroll area looks like a group box with various controls. The title bar in a scroll area, however, can also
serve as a navigation bar. The navigation bar gives the user various options for viewing the data. The plus
and minus buttons in the body of the scroll enable the user to add and delete rows of data.

This example illustrates the fields and controls on the Example of a scroll area. You can find definitions
for the fields and controls later on this page.

4] )]

Last Update Timestamp: 06/04/1999 8:24AM ][]
*Message Number: 1
*Saverity: I Errar :I'
‘Message Text invalid use of . ¢
Description: The exclamation symbaol (1) can only be used as a token within - @

FeopleCode as part of a not-equal operator (1=).

Either make the operator a proper not-equal expression or delete the Ll
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Related Links
Level-Based Controls

Setting Scroll Area General Attributes

Assign the general attributes of a scroll area. These settings are the same for a scroll area as they are for a
grid control.

See Setting Grid General Properties.

Manipulating Fields After Setting the Occurs Count

If you set the occurs count to a number greater than 1, you must reposition the fields in the scroll area.

If you change the occurs count after placing fields in the scroll area, they might appear one on top of the
other, very close together. Unless you indicate otherwise (in the body area of the Label tab), row separator
lines might appear to distinguish one row from the next.

In the following example, the occurs count was set to 5 after placing one field, Access Group, in the
scroll area. You must reposition the fields and possibly the labels so that they are evenly spaced in the row
separator lines.

This example illustrates the fields and controls on the Multiple occurs counts in a scroll area. You can find
definitions for the fields and controls later on this page.

&= Page? (Page) E@E|

Layout |order |

CAccess Group,
o ACCESS Group’
1 Access Group

Before you do so, it is helpful to know a few rules about how you can move these fields in relationship to
one another. For example, you do not need to move individual fields to their proper destination. For this
example, we call the first field in the column of fields, or the original field that you placed in the scroll
area, the head field. The fields following the head field are other occurrences.
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¢ The head field controls the horizontal movement of all other occurrences that are below it.
*  You cannot move the other occurrences horizontally.

» To evenly space the occurrences vertically, drag the last occurrence in the column to the appropriate
position between the bottom edge of the scroll area and the last row separator.

All occurrences above it reposition themselves equidistant from the others.

*  You cannot move the add and delete push buttons (represented by the gray boxes on the right side of
the scroll area) horizontally on the page.

You can move them only vertically in the same manner as the fields.

After you move the lowest field, the scroll area should look similar to this:

This example illustrates the fields and controls on the Fields moved to accommodate multiple occurs
counts. You can find definitions for the fields and controls later on this page.

i Page? (Page)

Layout |order |

Access Group

Setting Scroll Area Label Properties

You can configure links or push buttons in three places on a scroll area to help users navigate through
multiple rows of data in a scroll area. These options and the associated settings are the same as those for
grids. This section references the setting definitions for grid controls that are described later in this topic.
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Using Scroll Areas, Scroll Bars, and Grids

Use the header area properties to configure the title properties, navigation bar properties, and embedded
help properties associated with the scroll area. These properties enable users to access controls for
viewing the previous, next, top, or bottom row; to control the settings for the Find, Download, and View

All features; and to access embedded help.

The Display Header check box is selected by default and enables access to Header Area properties. To
disable the header, deselect the Display Header check box.

To configure title properties for the scroll area:

1. Select the Display Title check box.

2. Select the Left, Center, or Right title alignment option.

3. Click the Display Title Properties button to open the Title Properties dialog box.

4. Enter the Label Text that you want to appear in the scroll area title.

Field or Control

Description

Type Select the type of label text to appear in the navigation bar.
Message Catalog: Select this option to use a message in the
Message Catalog as the grid title.
Static: Select this option to enter manual text as the grid
title.

Text Enter the text to appear as the title of the scroll area. This

field is enabled when you select Static as the Label Text
type.

Message Set/Number

Enter the message set number and message number of the
message in the Message Catalog to appear as the title of the
scroll area. This field is enabled when you select Message
Catalog as the Label Text type.

To configure navigation bar properties for the scroll area:

1. Select the Display Navigation Bar check box.

2. Select the Left, Center, or Right navigation bar alignment option.

3. Click the Display Navigation Bar Properties button to open the Header Navigation Bar Properties

dialog box.

The Header Navigation Bar Properties dialog box contains seven tabs, each pertaining to different
settings on the navigation bar. Each tab has the same settings. All settings are set to display by default.
Select the Invisible check box that appears in the upper right corner of each tab to hide the tab

attribute from the user.
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This example illustrates the fields and controls on the Header Navigation Bar Properties dialog box.
You can find definitions for the fields and controls later on this page.

-
Header Mavigation Bar Properties ['>__<|

Tap |F'revi0us Fiow Crtr || Mext | Bottom | Find Wit Al

Type
() Text " lmage [ Irwisible
Label Test Image
Tope: | Meszzage Catalog W |
Text: | |
Mezzage Set/Mumber: ‘125 | |42 |

ultiple Dzcurs Label Test

[ ak. I ’ Cancel

This table describes the tabs in the Header Navigation Bar Properties dialog box:

Field or Control Description

Controls the attributes for how a user returns focus to the

Top
top of the grid or the first row of data in the grid. 7ext is the
default setting using First from the Message Catalog. You
can also enter static text.

Previous Controls how a user can move to a previous row in the grid.

Image is the default setting, and the Show Previous Row
button is the default image.
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Field or Control

Description

Row Cntr (row counter)

Tracks the number of rows in the grid and in which row the
cursor focuses. 7ext is the default setting, and, for example,
1-6 of 6 appears in the navigation bar if the grid has six

TOWS.

The Image Type is not enabled on this tab.

Note: The row count that appears is controlled by the occurs
count that you set on the General tab in the Grid Properties
dialog box (unless the user displays all). Using the previous
example, if the occurs count is set to 5, then the row counter
is -5 of 6.

Next

Focuses on the next row in the grid. /mage is the default
setting, and the Show Next Row button appears to the right
of the row counter.

Bottom

Controls the attributes for how a user moves focus to the last
row of the grid. 7ext is the default setting using Last from
the Message Catalog. You can also enter static text.

Find

Displays a link that enables the user to search any field in
the grid or scroll area. You can select either text or an image
to represent the Find feature. The Find feature searches for
matches in edit boxes, display-only fields, disabled fields,
dynamic links, and text in long edit boxes. It does not search
column headings, field labels, text values in icons, static
links, and hidden fields, nor does it search outside the grid.

Note: The system ignores fields in HTML areas when
running a Find request.

View All

Enables the user to view all rows of data at once. 7ext is the
default setting using View All as the Message Catalog entry.

To configure embedded help pop-up properties for the scroll area, use these options:

Note: Embedded help is not supported for group boxes, grids, and scroll areas on fluid pages.
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Field or Control Description

No Popup Select this option to disable embedded pop-up help.

This value is the default.

Message Catalog Popup Select this option to enable the embedded pop-up help icon on
the grid at runtime. Selecting this option enables the Message
Set/Number edit boxes.

Message Set/Number Enter the message set number and message number of the
message catalog entry to appear when the user clicks the
embedded help icon.

Text Displays the message that appears when the user clicks the

embedded help icon. This field is display-only.

See “Accessing Embedded Help” (Applications User’s Guide).

View All Feature

The View All feature provides a threshold to enable the user to view the data in manageable pieces. If the
database returns a number of rows for the grid or scroll area that is greater than the threshold, the View
All link displays "View <threshold value>." This feature also modifies the occurs count and the values for
the number of non-displayed rows left to scroll through.

The Next and Previous buttons retrieve rows according to the size of the threshold. If the database returns
a total number of rows for the grid or scroll area that is less than the View All threshold, then the View
All link on the navigation bar remains and functions as is.

The following example uses the View All threshold, occurs count, and total rows in database values:
*  View All threshold = 100

*  Occurs count =10

» Total rows in database = 160

The result is:

This example illustrates the fields and controls on the Viewing 10 rows. You can find definitions for the
fields and controls later on this page.

B & 0 D e

When the user selects View 100, the view value changes to reflect the original occurs count set for the
grid. The value for the number of non-displayed rows changes to 100 to match the View All threshold,
and the View 100 display changes to View 10:
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This example illustrates the fields and controls on the Viewing 100 rows. You can find definitions for the
fields and controls later on this page.

H | & g1 D |

If the Occurs Count, which you define in the properties for grid and scroll areas, is set to a number
greater than or equal to the view all threshold, then the threshold takes precedence. The View All display
changes to View <threshold value> and the link is unavailable. If you select Unlimited Occurs Count,
the grid or scroll area displays all rows in the buffer.

Body Area Properties

Use the body area properties to configure the row action buttons and set display properties for the body of
the scroll area.

This table describes the Body Area properties:

Field or Control Description

Row Action Buttons Select to display Insert and Delete buttons on each grid row
at runtime. The action buttons can appear on the left or right
side of the scroll area. Click the Properties button to open the
Body Area Row Action Button Properties dialog box.

Background Style Select a background style to display for the scroll area as a
whole. The style selected here applies to all areas of the scroll

area that are not covered by other elements.

Show Border Select to display a standard border around your scroll area.
The default is selected.

Show Row Separator Select to display vertical separator lines between rows when
multiple rows are returned from the database. The default is
selected.

Adjust Layout for Hidden Fields Select to have the scroll area adjust its borders to

accommodate any hidden fields.

Note: For the scroll area to adjust automatically, the hidden
fields inside the scroll area must be surrounded by open space
or have other hidden fields to the right or left.

Click the Row Action Buttons Properties button in the Body Area group box to open the Body Area Row
Action Button Properties dialog box. It contains two tabs: Insert and Delete. The default settings for these
tabs are to display the Insert and the Delete buttons. Alternatively, you can select static or message catalog
text, or you can make these items invisible so that they do not appear.
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This example illustrates the fields and controls on the Body Area Row Action Button Properties dialog
box. You can find definitions for the fields and controls later on this page.

F i
Body Area Row Action Button Properties E|
Insert | Delete
Type
) Tent ) Image [ Irvisible
Al tag for image Image
Tupe: Message Catalog 3 Image ID: | * Use Default Image “ [Z]
Teut:
Mezzage Set/Mumber: 0 a O M
n Mouse

Ower: b E]
Multiple Dzcurz Label Tewt

E\;?:I;}ed: == | lge Default Image = w E]

(] ] [ Cancel

Footer Area Properties

In the footer of your scroll area, you can display row action buttons and a navigation bar. To enable

either of these features, select the appropriate check box, Display Row Action Buttons or Display
Navigation Bar, and click the Properties button to configure the settings. Clicking the Properties button
opens a separate dialog box: Footer Row Action Button Properties or Footer Navigation Bar Properties
respectively.

The row action buttons are the same for the footer area as those described for the body area. The
navigation bar property options are the same as those described for the header area. However, all other
navigation bar settings for the footer are invisible by default.

Summary Properties

Summary properties enable you to provide a brief description of the functionality and content of the scroll
area. This property is pertinent for users who access the application by using screen readers. The default
value for the Summary Text field is the same as the Title of the scroll area. You can also enter static text
or use the Message Catalog to store the summary information.

Access the Summary Properties dialog box.
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This example illustrates the fields and controls on the Summary Properties dialog box. You can find
definitions for the fields and controls later on this page.

-
Summary Properties

Summary

[ ] Default ta Title

) Test (%) Meszage Catalog
Ilser Roles

Mezzage Set/Mumber: |4E | | 423
(%) Teu i) E=planation

[ OF. ] [ Cancel ]

X]

This table describes the summary properties of the grid:

Field or Control

Description

Default to Title

Select this check box to have the summary property the same
as the grid title. Clear this check box to activate the Text and
Message Catalog options.

Text Select this option to enter up to 254 characters in the
Summary Text field. Selecting this option disables all
Message Catalog option related fields.

Message Catalog Select this option to choose a message stored in the Message

Catalog. Selecting this option disables all Text option related
fields. Select one of these two options:

»  Text - Select this option to use only the message text from
the message catalog.

*  Explanation - Select this option to use only the message
explanation from the message catalog.

To change the Summary properties:

1. Click the Properties button located in the Summary group box.

2. Clear the Default to Title check box to activate the other Summary options.
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3. Enter static text or enter a Message Set and Number to retrieve information from the message catalog.
4. Click the OK button.
5. Save the page.

Related Links
Setting Grid Label Properties

Setting Scroll Area Use Properties

You can select several options to determine how you use the scroll area. As with the label properties, the
settings on the Use tab of the Scroll Area Properties dialog box are the same as those on the Use tab of the
Grid Properties dialog box, except that the scroll area contains fewer attributes than a grid.

When working with the row counter when designing pages in PeopleSoft Application Designer, consider
the following:

» Ifthe header area navigation bar is set to invisible, the system displays no header area navigation
bar row counter button. Likewise, if the footer area navigation bar is set to invisible, the system
displays no footer area navigation bar row counter button. If the row counter button of the header
area navigation bar is set to invisible, the system displays no header area navigation bar row counter
button.

» If'the row counter button of the footer area navigation bar is set to invisible, no footer area navigation
bar row counter button is displayed. Otherwise, if not set to invisible, the row counter button will be
displayed as "|<< your label >>|" where your label is the specified text.

» If the text of the label is an empty string or the label refers to the message catalog with a message set
of 0 and a message number of 0, then "your label" appears as an empty string and the label will be
rendered as "|<< >>|",

Related Links
Setting Grid Use Properties

Setting Scroll Bar Label Properties

326

Note: Scroll bars are not supported in fluid applications.

To help identify scroll bars on the page definition, document the purpose of each scroll bar with an
informational field label.

To specify a scroll bar label:

1. Access the Scroll Bar Properties dialog box.
2. Select the Label tab.

3. Enter the text label in the Text field.

This label is for your information only—it doesn’t appear on the page. This label is useful for
reordering page controls in the order list if you include a meaningful identifier in the label,
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such as the primary record definition for the scroll bar. For example, you might want to label it
ABSENCE _HIST SCROLL.

Setting Scroll Bar Use Properties

Note: Scroll bars are not supported in fluid applications.

You set the scroll action buttons on the Use tab of the Scroll Bar Properties dialog box:

This example illustrates the fields and controls on the Specifying scroll bar Use. You can find definitions
for the fields and controls later on this page.

Scroll Bar Properties f'5_<|

Label | Usze |General
Scroll Attributes

Ocours Level: Ozours Count;

Field |l ze Optionz

[ Irwisible [ ] Default \width
[ Mo futo Select [ Mo Ao Update
[ Mo Row Ingert [ Mo Row Delete
Scroll Action Buttonz

[] Previous Page [ Mext Page

[] Row Ingert [ ]Row Delete
[1Top [ ] Bottam

[ Show Fiow Counter

Fopup Menu

| v

Allove Deferred Procezsing

[ OF. l [ Cancel

Access the Scroll Bar Properties dialog box. Select the Use tab.
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Field or Control

Description

Occurs Level

Having an occurs level for the scroll bar enables you to
designate the hierarchical parent and child relationship.
Entering / specifies that the scroll bar is at the first level.
Entering 2 specifies that a scroll is at the second level and is
a child of, or nested in, the first level of data, and so on up to
3. A scroll can be nested in another scroll or scroll area, but it

cannot be nested in a grid.

See Level-Based Controls.

Occurs Count

Enter the number of rows to appear at one time in the grid at
runtime.

See Level-Based Controls.

Note: Always reorder your controls, if necessary, before you

enter an occurs count.

Field Use Options

Field or Control

Description

Invisible

Select to make the scroll bar invisible.

Default Width

This does not apply because the scroll bar does not appear on
the page at runtime.

No Auto Select

Select to prevent the system from retrieving data automatically
from the database. Select to populate the scroll bar with data
using the ScrollSelect PeopleCode functions.

No Auto Update

Select to prevent the system from updating data automatically
based on the existing key list. Select when the scroll bar
contains work field controls that should affect only a page and
not the underlying database.

No Row Insert

Select to prevent the row insert function so that the user cannot

insert new rows.

No Row Delete

Select to prevent the delete function so that the user cannot
delete rows.
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Scroll Action Buttons

If you select a Scroll Action Button option, it appears on the page next to the scroll bar in PeopleSoft
Application Designer. You must manually move it to the appropriate location on the page definition.

Field or Control Description

Previous Page Select to display a link that enables the user to move to the

previous row or set of rows in the scroll buffer.

Row Insert Select to display a button that enables the user to add a row.

Top

Select to display a link that enables the user to go to the first
row of the scroll.

Show Row Counter Select to display a counter to show users what rows they are

viewing and the total number of rows in the scroll bar, for
example: <1 of 3>.

Next Page Select to display a link that enables the user to move to the

next row or set of rows in the scroll buffer.

Row Delete Select to display a button that enables the user to delete a row.

Bottom Select to display a link that enables the user to go to the last

row of the scroll bar.

Controlling Scrollable Data

You can control scrollable data using the PeopleCode Data Buffer Access Classes.

See “Understanding Data Buffer Access” (PeopleCode Developer’s Guide).

Converting Scroll Bars to Grids

You can convert a single-level scroll bar to a grid control. PeopleSoft Application Designer provides a
utility to automate this task. The Convert Scroll to Grid function:

Designates the size and position of the grid as set to the area covered by the left-most label to the
scroll bar.

Issues warnings before deleting controls that are not supported by the grid.
Converts radio buttons to drop-down list boxes.

Sets label alignment of check boxes to center.
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The conversion utility provides warnings for scroll bars that can’t be converted to grids due to grid control
limitations. The conversion utility validates to the following limitations:

*  No more than one grid can exist on a page.

* The scroll bar to be converted must not have any nested scroll areas or bars under it.

e The grid control must be the last control on the page.

* Radio buttons are not supported in grids and must be replaced with drop-down list boxes.
To convert a scroll to a grid:

1. Select the scroll bar.

2. Right-click and select Convert Scroll To Grid from the pop-up menu.

This menu option is available only for scroll bars that can be converted. This utility searches for all
page fields that are defined in the field order after the selected scroll bar control, up until the next
scroll bar or scroll area control. It does the following for each field:

* Confirms that the scroll control type can be displayed in a grid control.
* Creates a grid column of the appropriate type.

* Populates the attributes.

3. Click OK to display the new grid.

If any of the page fields cannot be displayed in a grid or if other problems are found, the utility displays
an error message explaining why the scroll bar cannot be converted to a grid.

Using Grids

This section provides overviews of grids and discusses their properties and options.

Note: A specific type of grid called an analytic grid can be used exclusively for applications built for the
PeopleSoft Analytic Calculation Engine.

Related Links
“Understanding Analytic Grid Design” (Analytic Calculation Engine)

Understanding Grids

Scroll controls and grid controls function very similarly. Grids are more compact and display fields
in a spreadsheet-like format. You insert page controls into a grid and associate the controls to record
definitions, just as you do in a scroll control.

You can insert these page controls into a grid:

¢ Check boxes.
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Drop-down list boxes.
Edit boxes.

HTML areas.

Images.

Long edit boxes.
Push buttons or links.

Radio buttons.

Note: You must add a group of at least two radio buttons within a grid. Moreover, unlike check boxes,
a solitary radio button cannot be added to a grid to be used as a row selector.

Secondary pages.
Subpages.

Tab separators.

Note: When designing grids, use prompts in place of drop-down list boxes for better performance.

Understanding Grid Properties

When you accept the default settings of grids, the grid appears with :

A data navigation bar at the top of the table that enables the user to page through additional rows of
data.

Delete and Add buttons at the end of each row that enable the user to insert and delete rows in the
grid.

The inserted row appears under the current row. These buttons appear automatically as determined by
the grid properties (display-only, no row insert, and no row delete).

An occurs count of /.

You can set the grid to be any size at design time and then set the occurs count to control the
maximum number of rows to display at runtime.

There are three areas on a grid to which you can apply labels or image buttons to help the user navigate
through the data in the grid. Set properties for these areas:

Header
Body

Footer
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Understanding Grid Personalization
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PeopleSoft Application Designer enables the user to personalize a grid at runtime. By default, grid
personalization is enabled. To change the default settings for grid personalization, open the Grid
Properties dialog box and click the Display Navigation Bar Properties button. Grid personalization
settings appear on the Personalize tab in the Header Navigation Bar Properties dialog box.

Note: If you do not display the grid header bar, the Personalize link is not available to the user unless you
enable it for the footer area.

This example illustrates the fields and controls on the Personalize Column and Sort Order page. You can
find definitions for the fields and controls later on this page.

Personalize Column and Sort Order

To arder columns or add fields to sort arder, highlight column name, then press the appropriate button.

Frozen columns display under every tab.
Permission List [ Permission List A
Description = = X
View Definition
™ Hidden ™ Descending
I” Frozen
Ok Cancel Freview | Copy Settings

B e B b |

Permission List Description View Definition
HCCPAM Absence Mngmnt Administrator Wiew Definition
HCCPAMSE01 Absence Self-Senvice Wiew Definition
HCCPSCAW1030  AWE Employee Wiew Definition
HCSPWEBLIB Standard WebLib Permissions Wiew Definition

When the user clicks the Personalize link for a grid on a transaction page, the system opens the
Personalize Column and Sort Order page, where custom parameters can be set for that grid. This page
contains a sample grid that displays a few rows of real data from the buffer in display-only format. If there
is no data in the buffer for that grid, only the column headings appear. Tabs in the grid are active so that
the user can view all sample data.

From this personalization page, users can control the column and sort order, as well as copy other users'
grid settings or choose to share their settings with other users once they save their changes.

The Column Order grid displays the columns in their current order, including tab separators. The list of
fields is driven by the page definition but excludes columns that are hidden by PeopleCode. The user can
hide columns and change their sort order. Users can also freeze grid columns. Columns that you freeze
at design time automatically appear to the user as already frozen. However, the user has the option of
overriding this setting.

The Sort Order grid enables the user to control the ascending and descending sort of each column, with
the exception of tab separators, images, push buttons, links, and HTML areas. Users can sort hidden
fields, however. The default setting is ascending for each column.
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After making changes, the user can accept, preview, restore defaults, or cancel selections. If the user
saves the new settings by selecting OK, the system stores the new settings as persistent values for

that user based on a key structure. Therefore, each time the user accesses this grid, the system uses all
personalization options that were set previously. The user can restore all default settings by selecting the
Delete Settings link to remove all stored personalization settings from the database.

The user can override the persistent sort order directly on the transaction page by clicking the linked field
label to affect the sort. Clicking the link repeatedly toggles between ascending and descending sort order
for that column. This type of sorting directly in the transaction page is not persistent.

Note: You can continue to use the Sort method of the Rowset class, but the user can override the defined
sort with this feature.

Important! Modifying a grid or a page definition that contains a grid removes all runtime user
personalizations associated with the modified page and the grid. Therefore, if users personalize grid
column and sorting options for a grid, make sure they are aware that after system administrators apply
updates and upgrades, it is likely that users will need to reapply their personalization options.

After the user has applied personalization on the columns in a grid and saved the settings, if you insert a
column in the grid, the system preserves the user personalization and adds the newly inserted column as
the last column in the grid for that user.
Inserting and Resizing Grid Controls
To insert a grid on a page:
1. Select Insert > Grid.
2. To adjust the grid width, drag the horizontal or vertical control handles.
The horizontal grid width should be roughly equivalent to the columns that you insert into the grid.
Otherwise, your grid might appear wider than necessary at runtime.
Inserting and Manipulating Grid Columns
This section discusses how to:
e Insert grid columns.
» Delete grid columns.
*  Move grid columns on the Layout tab.
e  Move grid columns on the Order tab.

» Resize grid columns.

Inserting Grid Columns
To insert a grid column:

1. Use one of these methods to insert a column:
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* Select a page control from the Insert menu or the page control toolbar and click the grid.
* Drag a page field from inside the current page or from another page.
* Copy and paste a page field or record field.

* Drag a definition (such as a record field, a page field, or an entire record definition) from the
project workspace.

The new location of the definition or control is determined by the location of the upper left-hand
corner of the drag rectangle, or by the mouse cursor if no drag rectangle appears. PeopleSoft
Application Designer automatically places the first column on the left-hand side of the grid.

Click your mouse or release the field in the gray area of the grid.

Place new columns to the right of existing columns by clicking or releasing the control in the gray
area of the grid where no columns are present. To place a column between two grid columns, release
the new column in the first of the two columns.

When inserting subpages into your grid as a column, be aware that:

L]

You can insert subpages by dragging them from the project workspace or by cutting and pasting from
the page to the grid.

Only one column displays in the grid in PeopleSoft Application Designer representing all fields in the
subpage.

At runtime, all fields display in the order they appear on the Order tab of the subpage.

You cannot insert subpages that contain fields that are not allowed in grids such as static text or radio
buttons.

The system generates an error indicating the invalid field type. Similarly, if at a later point an invalid
field type is added to a subpage already in a grid, the system generates a runtime error when the user
accesses the page containing the subpage.

The subpage you insert can contain fields that are associated with subrecord record fields.

The same record name substitution mechanism that applies to subpages inserted onto a page applies
to those inserted as grid columns. The system replaces the name of the subrecord as part of the
expansion process and it is never seen at runtime.

See Understanding Subpages.

Note: The rich text editor is not supported within grids. If you insert a long edit box and make it rich text-
enabled, the system automatically sets the long edit box Use properties to Display Only. (Use tab > Field
Use Options > Display Only.)

Note: Long edit boxes inserted into grids and set to display only always display the field content in
expanded mode, regardless of how the Expand Field When Display Only option is set. (Use tab > Field
Use Options > Expand Field When Display Only.)

Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 9 Using Scroll Areas, Scroll Bars, and Grids

Deleting Grid Columns
To delete a grid column:
1. Select a column by right-clicking the column heading.

Be sure that you select only the column and not the grid as a whole; otherwise, you might delete the
entire grid instead of just the column. The grid is selected when control boxes appear around the
edges of the grid. The column is selected when it turns black.

2. Select Delete from the pop-up menu.

Moving Grid Columns on the Layout Tab
To move grid columns on the Layout tab:

1. Select a column by clicking the column heading.
2. Drag the column to its new location.

3. Release the mouse button over the column that is to the left of the new location.

Moving Grid Columns on the Order Tab
To move grid columns on the Order tab:
1. Select the column row by clicking the row number.

The grid and grid columns are clearly distinguished from other page fields on your page. The grid
is identified by the Type column. All columns in the grid are directly below in a lighter green. Other
page field rows are white.

2. Drag the row to the new position in the grid.

A red line indicates the new position of the column before you release it. You cannot move a column
outside of the grid when working on the Order tab. Similarly, you cannot move an existing page field
from elsewhere on the page into the grid. Both of these operations can be performed on the Layout
tab.

Resizing Grid Columns
You can resize grid columns in PeopleSoft Application Designer by dragging the right border of the

column heading.

Setting Column Properties

After you insert the page control or field into your grid, you can set the properties for that field as you
would set properties for any other page control. Access the field properties by double-clicking the column
heading.

Column headings and their alignment are derived from the label text that you select on the Label tab of
the page field properties dialog box. The alignment of column contents is derived from the alignment
settings on the Record tab of the page field properties dialog box. If alignment settings aren't available on
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the Record tab, then the system uses the Label alignment settings. For column headings, use the following
guidelines for label alignment. Do not use colons in column labels.

Field Type Label Alignment
Push button Center Align

Link Left Align
Character Left Align
Numeric Right Align

Check box Center Align

Field data Auto (automatic)

Default Image Field Dimensions in Scrollable Grids

When working with scrollable layout grids that include image fields, consider these default behaviors:

The default row height is 28 pixels.
The header label width determines the default column width.

Grid cell dimensions do not resize automatically to accommodate a stored image with dimensions that
exceed the default dimension.

If you have images with dimensions that exceed the default dimensions of (28 x (column width)) then
users are unable to see the entire image because the grid cell is smaller than the image. To prevent images
from being cropped by the page control:

1.

2.

Determine and record the dimensions of the largest image in the field.
Access the Image properties dialog box of the image page field.
On the Record tab, enter the recorded values from step one in the Width and Height fields.

Click the OK button and save the page definition.
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This example illustrates the fields and controls on the Image Properties dialog box with non-default size
values. You can find definitions for the fields and controls later on this page.

Image Properties

Fecord | Label | Use | General|

]|

— Field

Record Mame: I_'.J_E EMPL PHOTOZ

Field Mame:

[QE_EMPLOYEE_PHOTO |

— Image Format £ Size

™ Scale
{* Size

Width: I 79 Height: 100

— Alignment
f* Left

i Center

Style: = lee Default Style =

Cancel

ok |

Creating Tabbed Grids

Oracle recommends using a tabbed grid design if your grid contains many columns that extend past the
right side of the page. Do this by adding tab separator controls to your grid.
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This example illustrates a tabbed grid on the Define Personalizations page. The grid includes three tabs
labeled Definition, Format, and Explanation.

Define Personalizations

Option Category Level:  PeopleTools

alizations

." 2 - Format Explanation

*User Option Description Option Category Group Option Category E?L—;Opﬁﬂ IE_‘::zlde

|.i.CCESS |.L:ccessihwlit-,-Features |PSInternet Architecture j |Genera|0pt\-:uns j |S-,-'stem ﬂ r EIE|
[scEGRDCOLS | [MaxcC Analytic Grid | PS Internet Architecture = [Mavigation Persenalizations =l [system = T [+] [=]
[sCEGRDROWS | [Max Rowiview All-Analytic Grid [Ps Internet Architecture x| [1avigation Personalizations =l sstem = T [+l [=]
|."—'.DEITI‘-J |Tah over Add/Del Buttons (+-) |PS Internet Architecture j |r-JavigatiDn Personalizations j |S-,-'stem j - [+ [=]
|."—'.DES |.é:ﬂern-3-3n designatar (FM, pm} |PS Internet Architecture j |Regi-:ma| Settings j |S-,-'stem j el [#] [=]

You can give users the option of expanding all of the columns to the right so that they are visible when
using the browser’s horizontal scroll bar. This is particularly useful to power users who do a great deal of
intensive data entry. The Enable View All Columns check box on the Use tab in the Grid Properties dialog
box controls this feature and is selected by default. The Expand All button appears to the right of the grid
tabs, as shown in the preceding screen shot. After the grid is expanded, the Show Tabs button appears to
enable the user to collapse the grid so that the tabs appear again.

Note: Each time the user selects a new tab results in a trip to the web server to retrieve the next set of
columns.

This example illustrates the page definition that corresponds to the preceding example. Within the grid
control, note the three tab separators: Definition (tab order 6), Format (tab order 14), and Explanation (tab
order 24).

e PSUSEROPTNDEFN (Page) [=][=]E]
Layout Order l
Tab Order | Field ID Ealenl Dizplay Control| Related Field | Control Field || ~
1
2 28 0 :Update Version N {Edit Box UPDATE WERSI :DERIWED_LISRO ] ]
] 1 0 :Option Category Edit Box OPTH_CATEGOD PSOPTHCATLWL [] []
4 2 0 :Description Edit Box DESCR PSOPTMCATLWL
5]
o 4 1 iDefinition Tab Separator
7 5 1 :Option Category Edit Box OPTH_CATEGO :PSUSEROPTND ] ]
8 g 1 :User Option Edit Box USEROPTH PSUSEROPTHND L] L]
9 & 1 Description Edit Box DESCR PSUSEROPTHD [] []
10 E 1 iOption Category G Drop Down Lst (0OPTH_CATEGO :PSUSEROPTHD [ ] [ ]
11 7 1 iOption Category :Drop Down Lst (0OPTW_CATEGO :PSUSEROPTHD [] []
12 10 1 iUszer Option Type i Drop Down Lst (USEROPTH_TYFPSUSEROPTHD
13 27 1 :Locale Baged Check Box LOCALE BASED :PSUSEROPTND [] []
14 1 1 Format Tah Separator [] []
15 12 1 :Field Format Drop Down Lst (FORMAT_CNTL (PSUSEROPTHD [] []
16 13 1 ‘Format Length  Edit Box FORMATLENGT :PSUSEROPTND [] []
17 14 1 Record [Table] N Edit Box RECHNAME PSUSEROPTHD [] []
18 15 1 :Field Name Edit Box FIELDMNAME PSUSERCPTHD L] L]
19 29 1 (Edit Table Edit Box EDITTABLE DERIVED [] []
20 24 1 Ovemde Value Edit Box USER_OPTIOM_:PSUSEROPTND [] []
21 25 1 :Option Default Val E dit Box USER_OPTM_DE:DERIWED_UISRO
22 22 1 SecPage
23 21 1 :Set Option Default Push Bin/Link ~ (SET_OPTION_D :DERIVED_USRO
24 16 1 :Explanation Tab Separator
25 17 1 Message Set Num Edit Box MESSAGE_SET_:PSUSEROPTND [] [] e
£ >

To create a tabbed grid:

1. Insert a grid control on the page.
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2. (Optional) If you want to freeze one or more columns so that they are displayed on all grid tabs, insert

those columns first. Select the Freeze Grid Column check box on the Use tab for each frozen column.
See Freezing Grid Columns for more information.

3. Insert a tab separator control for the first grid tab.

4. Double-click the tab separator to access the Tab Separator Properties dialog box:

a. Specify the label properties on the Label tab.

Select None, Text, or Message Catalog. 1f you select Text, enter the label text and select the label
alignment. The label text that you select appears on the tab in the grid.

b. On the General tab, determine whether you want to enable the tab separator as a page anchor.
If so, select the Enable as Page Anchor check box and enter a page field name.

c. On the General tab, determine whether you want to specify row headers for screen readers. See
“Columns and Row Headers” in Setting Grid General Properties for more information.

Note: To set row headers, you will need to complete step 5 to insert all of the columns for the tab.

5. Insert the set of columns to appear on the first tab.
6. For each tab, repeat steps 3—5 as necessary.

Alternatively, you can place all of the columns in your grid first and then insert tab separators before each
set of columns.

Note: The grid tab must contain at least one visible, non-frozen column or the tab is not displayed.

Freezing Grid Columns

Copyright

Note: To avoid unexpected results, do not freeze columns in fluid flex grids with stacked columns.

You can freeze the first column or the first several columns in a tabbed grid so that these columns appear
on all tabs. To freeze a column, it should appear in the grid before the first tab separator. Then, select the
freeze option for each column that you want to appear on the following tab.

Important! When you freeze a grid column, the columns preceding it also become frozen regardless of
whether they have been explicitly frozen.

Freezing grid columns impacts the horizontal scrolling ability of the grid at design time. If you freeze a
grid column that is not visible inside the boundaries of the grid at design time, you are not able to view all
columns in your grid. Lengthen the width of your grid to accommodate all columns.

Freeze a grid column by selecting the Freeze Grid Column check box on the Use tab of the properties
dialog box for that column. Note that the effects of selecting this attribute are visible only at runtime, not
design time.
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You can place as many grids on a page as you want, provided that they are at the same occurs level. They
can be one above the other or they can be side-by-side, such as those in the following example. This is

helpful when you must transfer data from one grid to another without switching between pages.

In the following example, the user can transfer data from the Source Competencies grid on the right to
the Assigned Competencies grid on the left by using the double left arrow button. The push button is

associated with a PeopleCode program, enabling it to transfer the data between the two grids.

This example illustrates the fields and controls on the Grids side-by-side on a page. You can find

definitions for the fields and controls later on this page.

| Competency Evaluation | Competency Assignrment % Competency Rating /. Competency Verification |

Evaluation IDType: 01 Customer
Category Type

Smith,Jahn Employee ID: FG7025 Linkto Career Planning

Competency Assignment First (4] 101 [P Last

Populatefrnmanl Searchiy.  |Abilly =] [custsen: 5]

Assighed e - - - Source i - -

e view Al First @] 15015 [ Last Competencies  1Ew Al First [0 130r3 [ Last

Description Category Description

Ahility to listen & respond Ability l_ Service Orientation

Set & achisve goals Ahility ™ Relationship Building

Dehates issues unabrasively Ahility @ _ _

Conceptual thinking Ahility [T Develop & implement solutions

Ahstract thinking Ahility

Sawve Feturn to Search | | +Z MextinList | | +2 Prewious in List =l Include History Correct History

=] Q 2l @

Cornpetency Evaluation | Competency Assignment | Competency Rating | Competency Yerification

As you can with other level-based controls, you can nest a grid in a scroll area or scroll bar. However, you

cannot nest a grid in another grid.

Disabling Grid Personalization on Classic Grids
Grid personalizations are enabled by default. To disable grid personalization:
1. Open the Grid Properties dialog box.
2. Select the Label tab.
3. Click the Personalize button for the header navigation bar.
This opens the Header Navigation Bar Properties dialog box.
4. Select the Personalize tab.
5. Select the Invisible check box.
6. Click the OK button.

To enable grid personalization in the navigation footer:
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1. Open the Grid Properties dialog box.
2. Select the Label tab.
3. Select the Display Navigation Bar check box in the Footer Area group box.
4. Click the Properties button for the footer navigation bar.
This opens the Footer Navigation Bar Properties dialog box.
5. Select the Personalize tab.
6. Clear the Invisible check box.

7. Click the OK button.

Setting Grid General Properties

Access the Grid Properties dialog box. Select the General tab.
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This example illustrates the fields and controls on the Grid Properties dialog box: General tab. You can
find definitions for the fields and controls later on this page.

General | Label | Use | Fluid |

General Attnbutes

M ain B ecard: F'

Fage Field Mame: |F'SL|SEF|EM.-‘-‘-.IL

Columnz

Occurs Count: I:I

Occurs Lewvel:

[w] Unlimited Ocours Count [roves)

[] Enable as Page dnchor

Email Address

Email Type

Frimary Ermail Account
Uzer D

General Attributes

Field or Control

Description

Main Record

Select the record that contains most of the fields that you want
to use in the grid. Fields that you display in the grid that are
not from the main record should be display-only or related
fields, which you can set on the Use tab of the properties
dialog box for that column.
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Field or Control

Description

Page Field Name

Enter a name for the grid. The default is the main record for
the grid, however, you can rename the grid as long as it is a
unique name for the page or component. This name is used by
the PeopleCode GetGrid function to create a grid definition.

See “Understanding File Layout” (PeopleCode API
Reference), “GetGrid” (PeopleCode Language Reference).

Occurs Level

Enter a 1, 2, or 3 to represent at which level the grid resides

on the page. Having an occurs level for the grid enables you to
designate the hierarchical parent-child relationship. Entering /
specifies that the grid is at the first level. Entering 2 specifies
that a grid is at the second level and is a child of, or nested

in, the first level of data, and so on up to 3. A grid can be
nested in another level-based control, but it cannot be nested in
another grid.

See Level-Based Controls.

Occurs Count

Enter the number of rows to display initially at runtime.

Note: When an occurs count is set to a number other than 1,
the grid displays the specified number of rows. However,
when it is set to 1, the grid displays as many rows as possible
within the physical space allocated for the grid control at
design time.

See Multiple Occurrences of Data.

Unlimited Occurs Count

Select instead of setting an occurs count if you want the
system to display all rows of data in the buffer for this grid.
Navigation links do not appear at runtime and the size of the
grid depends on the number of rows in the buffer.

Enable as Page Anchor

Select to apply an anchor tag to serve as a jump destination on
the page.

Columns and Row Headers

The Row Headers list box enables you to specify which column in the grid should be used for the row
header when presenting a data table for screen readers. The default row header generated is the first
display-only edit field. Therefore, by default, all of the columns in the grid appear in the Columns list
box; the value in the Row Headers list box is blank (no column selected).

When selecting row header values for tabbed or non-tabbed grids, consider these points:
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*  For optimal results, it is recommended to use display-only or disabled fields as the row headers.

* PeopleTools does not perform any validation regarding whether a column can be made a row header,
such as in the case of a radio button field. Implementation teams need to select appropriate values.

*  With tabbed grids, when all tabs are expanded the system uses the row header from the first tab.

» Ifarow header is specified, PeopleTools generates the field label of the table cells as column header
+ row header. If no row header is specified, PeopleTools generates the field label as the column
header.

Separate considerations apply to non-tabbed grids versus tabbed grids:

»  For non-tabbed grids: The Row Header list box appears on the Grid Properties dialog box: General
tab. You can select up to two columns as the row header. If you select a custom value, at run time,
PeopleTools generates the row header using the column value (or values) you selected.

»  For tabbed grids: The Row Header list box on the Tab Separator Properties dialog box: General tab.
Just as with non-tabbed grids, the default row header generated is the first display-only edit field. You
can select up to two columns as the row header for each tab separator with the column names to be
selected from the group of columns under control of that tab separator. If you select a custom value, at
run time, PeopleTools generates the row header using the column value (or values) you selected.

If you have any frozen grid columns set as a row header in a tabbed grid, the system applies that value
to all tabs in the same grid, which will override previous values selected. Likewise, if a frozen grid
column is deselected as a row header, the system applies those changes to all tabs in the same grid,
requiring you to select a new row header value as needed.

For more information on tabbed grids, see Creating Tabbed Grids.

Related Links
“SetRowHeader” (PeopleCode API Reference)

Setting Grid Label Properties

344

Access the Grid Properties dialog box. Select the Label tab.
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This example illustrates the fields and controls on the Grid Properties dialog box: Label tab. You can find
definitions for the fields and controls later on this page.

Grid Properties

Generall Label |L|se

X]

Dizplay Header
Header frea

Dizplay Title

Dizplay M avigation B ar

() Left
(0 Left

Style: |

ze Default Style = w |

Embedded Popup Help
) Mo Popup
{*) Meszage Catalog Popup

) Canter
) Center

Mezzage Set/Mumber: |3 | ‘1

Text: |

Body Area

R ow Action Buttons

) Left

(® Right

Backaround Style:

= U ge Default St

vl

Shaow Border [ 5how Grid Lines

Colurin Headings
Show Colurmn Headings [runtime)

[] Display Footer
Footer Area
Dizplay Row Action Buttons Left
Dizplay Mavigation Bar Left

Summary
Summary attribute for Accessibiliby

Show Row Headings [runtime)

Stule:

Center

Center

) Right
{® Right

| PAGRIDHEADERTAT

Right
Right

Properties

Froperties

[ Ok ] [ Cancel

The Grid Properties, Label tab provides five main grid setting areas for you to configure:

* Header Area.

*  Body Area.

e Column Headings.
* Footer Area.

*  Summary.
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Certain grid label properties such as label text and summary text can also be set through PeopleCode.

See “Grid Class Properties” (PeopleCode API Reference).

Header Area Properties

Use the header area properties to configure the title properties, the navigation bar properties, and
embedded help properties associated with the grid. These properties enable users to access controls
for viewing the previous, next, top, or bottom row; to control the settings for the Find, Personalize,
Download, and View All features; and to access embedded help.

The Display Header check box is selected by default and enables access to Header Area properties. To
disable the header, clear the Display Header check box.

To configure title properties for the grid:

1. Select the Display Title check box.

2. Select Left, Center, or Right title alignment option.

3. Click the Display Title Properties button to open the Title Properties dialog box.

4. Enter the label text that you want to appear in the grid title.

Field or Control Description

Type Select the type of label text to appear in the navigation bar.

Message Catalog: Select this option to use a message in the

Message Catalog as the grid title.

Static: Select this option to enter manual text as the grid
title.

Text Enter the text to appear as the title of the grid. This field is
enabled when you select Static as the Label Text Type.

Message Set/Number Enter the message set number and message number of the
message in the Message Catalog to appear as the title of
the grid. This field is enabled when you select Message
Catalog as the Label Text Type.

To configure navigation bar properties for the grid:
1. Select the Display Navigation Bar check box.
2. Select Left, Center, or Right navigation bar alignment option.

3. Click the Display Navigation Bar Properties button to open the Header Navigation Bar Properties
dialog box.
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The Header Navigation Bar Properties dialog box contains seven tabs, each pertaining to different
settings on the navigation bar. Each of these tabs has the same settings. All settings are set to display
by default. Select the Invisible check box that appears in the upper right corner of each tab to hide the

tab attribute from the user.

This example illustrates the fields and controls on the Header Navigation Bar Properties dialog box.
You can find definitions for the fields and controls later on this page.

Header Mavigation Bar Properties

Top | Frevious | Fow Cntr || Mest | Bottom | Find || Yiew All | Download | Personalize
Type
() Text () Image [ Irwisible
Label Text Image
Type: | Meszage Catalog W |
Text: | |
tessage Set/Mumber: ‘125 | |42 |
tulbiple Docurs Label Test
[ (]84 l l Cancel

This table describes the tabs on the Header Navigation Bar Properties dialog box:

Field or Control

Description

Top

Controls the attributes for how a user returns focus to the
top of the grid or the first row of data in the grid. Text is the
default setting, using First from the message catalog. You
can also enter static text.

Previous

Controls how a user can move to a previous row in the grid.
Image is the default setting, with the Show Previous Row
button as the default image.

Copyright © 1988, 2023, Oracle and/or its affiliates.

347



Using Scroll Areas, Scroll Bars, and Grids

348

Chapter 9

Field or Control

Description

Row Cntr (row counter)

Tracks the number of rows in the grid and in which row
the cursor holds focus. 7ext is the default setting with, for
example, /-6 of 6 appearing in the navigation bar if there are

six rows in the grid.

The Image Type is not enabled on this tab.

Note: The row count that appears is controlled by the occurs
count that you set on the General tab in the Grid Properties
dialog box (unless the user displays all). Using the previous
example, if the occurs count is set to 5, then the row counter
is 1-5 of 6.

Next

Brings focus to the next row in the grid. /mage is the default
setting with the Show Next Row button appearing to the
right of the row counter.

Bottom

Controls the attributes for how a user moves focus to the last
row of the grid. Text is the default setting, using Last from
the message catalog. You can also enter static text.

Find

Displays a link that enables the user to search any field in
the grid or scroll area. You can select either text or an image
to represent the find feature. The Find feature searches for
matches in edit boxes, display-only fields, disabled fields,
dynamic links, and text in long edit boxes. It does not find
column headings, field labels, text values in icons, static
links, and hidden fields, nor does it search outside the grid.

Note: The system ignores fields in HTML areas when
running a Find request.

View All

Enables the user to view all rows of data at once. 7ext is the
default setting using View All as the message catalog entry.
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Field or Control

Description

Download

Available for grids only. Displays a download image button
in the header or footer bar that enables users to download all
active, non-hidden rows to a Microsoft Excel spreadsheet,
regardless of how many rows are visible on the screen. The
default for this setting in the header area is /nvisible. For the
footer area of a grid, the download button appears by default
when you select the Display Navigation Bar check box

in the Footer Area group box of the Label tab in the Grid
Properties dialog box.

Important! In Application Designer, select the Allow
Embedded Excel Functions check box only when you want
to allow certain character field data to be interpreted as
Excel functions in the downloaded spreadsheet data.

Note: When you download a column of links comprised
of numeric values, the values are downloaded as numbers
instead of as quoted strings unless doing so causes Excel to
modify the format of the numbers.

Note: Microsoft Excel may display Unicode comma-
delimited data differently because Microsoft Excel may

be expecting a tab-delimited file. If display abnormalities
occur, you have two options.

In Microsoft Excel, after highlighting the first column, you
can select Data, Text to Columns and select the options
required to set Microsoft Excel to expect a comma-delimited
file.

Or, in Application Designer change the file layout

from comma-delimited to tab-delimited. Keep in mind

that changing the file layout properties in PeopleSoft
Application Designer could cause the data to change such
that other applications may no longer recognize the data.
Also, changing the file layout properties may impact more
than one application, if that file layout is shared.
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Field or Control

Description

Personalize

Available for grids only.

For classic grids, the Invisible check box is deselected by
default, which displays a Personalize link in the header
bar that enables the user to access all grid personalization

options. See Disabling Grid Personalization on Classic
Grids.

For fluid grids, two options are available:

*  Personalize Columns — Select to display the
Personalize button in the grid header. The Personalize
button allows users to change the order of grid
columns, hide or show columns, freeze or unfreeze
columns on tabbed grids, and specify the sort order on

up to three columns.

*  Save Sort — Select to display the Sort button in the grid
header. The Sort button allows users to specify a sort on
one column and save this sort personalization.

Note: Save Sort is selected by default on fluid grids.

To configure embedded help pop-up properties for the grid, select from these options:

Note: Embedded help is not supported for group boxes, grids, and scroll areas on fluid pages.

Field or Control Description

No Popup Select this option to disable embedded pop-up help.
This is the default.

Message Catalog Popup Select this option to enable the embedded pop-up help icon on
the grid at runtime. Selecting this option enables the Message
Set/Number edit boxes.

Message Set/Number Enter the message set number and message number of the
message catalog entry to appear when the user clicks the
embedded help icon.

Text Displays the message that appears when the user clicks the
embedded help icon. This field is display-only.
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View All Feature

The View All feature provides a threshold to enable the user to view the data in manageable pieces. If the
database returns a number of rows for the grid or scroll area that is greater than the threshold, the View
All link displays "View <threshold value>." This feature also modifies the occurs count and the values for
the number of non-displayed rows left to scroll through.

The Next and Previous buttons retrieve rows according to the size of the threshold. If the database returns
a total number of rows for the grid or scroll area that is less than the View All threshold, then the View All
link on the navigation bar remains and functions as is.

The following example uses the View All threshold, occurs count, and total rows in database values:
*  View All threshold = 100

*  Occurs count =10

* Total rows in database = 160

These values result in the following for the user:

This example illustrates the fields and controls on the Viewing 10 rows. You can find definitions for the
fields and controls later on this page.

B ] D]

When the user selects View 100, the view value changes to reflect the original occurs count set for the
grid. The value for the number of non-displayed rows changes to 100 to match the View All threshold,
and the View 100 display changes to View 10:

This example illustrates the fields and controls on the Viewing 100 rows. You can find definitions for the
fields and controls later on this page.

G D st

If the Occurs Count, which you define in the properties for grid and scroll areas, is set to a number
greater than or equal to the view all threshold, the threshold takes precedence. The View All display
changes to View <threshold value> and the link is unavailable. If you select Unlimited Occurs Count, the
grid or scroll area displays all rows in the buffer.

Body Area Properties

Use the body area properties to configure the row action buttons and set display properties for the body of
the grid.

This table describes the Body Area properties:
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Field or Control

Description

Row Action Buttons

Select to display Insert and Delete buttons on each grid row at
runtime. The action buttons can appear on the left or right side
of the grid. Click the Properties button to open the Body Area
Row Action Button Properties dialog box.

Background Style

Select a background style to display for the grid as a whole.
The style selected here applies to all areas of the grid that are
not covered by other elements.

Show Border Select to display a standard border around your grid. The
default is selected.
Show Grid Lines Select to show grid lines on the grid. The default is to not

display grid lines (this option is deselected).

This setting should remain deselected as grid lines are set
through the style class.

Note: Show Grid Lines has no effect on fluid applications.
Grid lines (if required) are applied through grid styles.

Show Row Headings (runtime)

Select to number the rows at runtime. This option is selected
by default.

Note: The row headings column appears at design time even if
Show Row Headings (runtime) is not selected. This enables
you to more easily select the grid if necessary.

Click the Row Action Buttons Properties button in the Body Area group box to open the Body Area Row
Action Button Properties dialog box. It contains two tabs: Insert and Delete. The default settings for these
tabs are to display the Insert and Delete buttons. Alternatively, you can select static or message catalog
text, or you can make these items invisible so that they do not appear.
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This example illustrates the fields and controls on the Body Area Row Action Button Properties dialog
box. You can find definitions for the fields and controls later on this page.

Body Area Row Action Button Properties

Inzert | Delete

Tvpe
) Temt {*) Image
Al tag for image
Type: lezzage Catalog b
Text:

Mezzage Set/Mumber: 0

Multiple Dzcurz Label Tewt

Image

EE

Image ID: | ** Use Default Image

On Mousze
Ower:

E\;?:I;}ed: == | lge Default Image

EE

X

[ Irvisible

=

=

=

ok

] [ Cancel

Column Heading Properties

You can set the grid to display column headings, and you can select the style in which to display them.
Select a predefined column heading style from the drop-down list box or use the default. Changing styles
alters the foreground, background, and font in the column headings, making it different from the data
rows. The default for Show Column Headings is selected.

Footer Area Properties

In the footer of your grid, you can display row action buttons and a navigation bar. To enable either of
these features, select the appropriate check box, Display Row Action Buttons or Display Navigation
Bar, and click the Properties button to configure the settings. Clicking the Properties button opens

a separate dialog box: Footer Row Action Button Properties or Footer Navigation Bar Properties,

respectively.

The row action buttons are the same for the footer area as those described for the body area. The
navigation bar property options are the same as those described for the header area. However, all other
navigation bar settings for the footer are invisible by default.

Summary Properties

Summary properties enable you to provide a brief description of the functionality and content of the grid.
This property is pertinent for users who access the application by using screen readers. The default value
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for the Summary Text field is the same as the Title of the scroll area. You can also enter static text or use
the Message Catalog to store the summary information.

Access the Summary Properties dialog box.

This example illustrates the fields and controls on the Summary Properties dialog box. You can find
definitions for the fields and controls later on this page.

F B
Summary Properties E|
Summary
[ ] Default ta Title
() Teut (%) Message Catalog
Ilzer Roles
Meszage Set/Mumber |4E | | 422 |
) Text () Explanation
[ (] l [ Cancel ]

This table describes the summary properties of the grid:

Field or Control Description

Default to Title Select this check box to have the summary property the same
as the grid title. Deselect this check box to activate the Text
and Message Catalog options.

Text Select this option to enter up to 254 characters in the
Summary Text field. Selecting this option disables all
Message Catalog option related fields.

Message Catalog Select this option to choose a message stored in the Message
Catalog. Selecting this option disables all Text option related
fields. Select one of these two options:

*  Text: Select this option to use only the message text from
the Message Catalog.

*  Explanation: Select this option to use only the message
explanation from the Message Catalog.
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To change the Summary properties:

1. Click the Properties button located in the Summary group box.

2. Clear the Default to Title check box to activate the other Summary options.

3. Enter static text or enter a Message Set and Number to retrieve information from the message catalog.
4. Click the OK button.

5. Save the page.

Setting Grid Use Properties

On the Use tab in the Grid Properties dialog box, you control data entry, row style, and display options,
as well as whether your grid has a pop-up menu in the navigation bar at runtime. Both the grid and scroll
area share many of the same attributes. Refer to the proceeding term tables for information about these
shared settings.
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This example illustrates the fields and controls on the Grid Properties dialog box: Use tab. You can find

definitions for the fields and controls later on this page.

Grid Properties

General Label Use Fluid
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[ ]Horizontal Wertical

Fowsz b ghow in Scrollable Lapout;

Fiowe Styles
(dd Pow Style: v|
Ewven Row Shyle: e |
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[IMo Row Insert Allowvy Colurmn Sorting 0dd / Even Row Style

[JMo Row Delets [ Pessist in Menu [] 5how Column when Cells Hidden

[] Eixted Height [nurber of rows)

Flow Selection Indicatar Enable Wiew Al Columne

(0 Ma Seletion Indicator [] Dizable Dizplay in Modal Window
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(®) Multiple Fow [check bos) [ Collapsible Drata Area
Fopup Menu
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Gnid Style

(Grid Layaout: FIEe:.: Grid Layout wt |

Drefault Initial Wiew to Expanded State

Cancel

Data Options

This table describes the data options properties:
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Field or Control

Description

No Auto Select

Suppresses the system from retrieving data from the database
automatically. Select to populate the grid or scroll area with
data using the ScrollSelect PeopleCode functions.

See “RowScrollSelectNew” (PeopleCode Language
Reference).

No Auto Update

Suppresses the system from automatically updating data based
on the existing key list. Select when the grid or scroll contains
work field controls that should affect only a page and not the
underlying database.

No Row Insert

Suppresses the Add button in the body area so that the user
cannot insert rows. If this option is selected, PeopleSoft
Application Designer automatically selects and disables the
Invisible check box on the Insert tab of the properties dialog
box for the body area.

No Row Delete

Suppresses the Delete button in the body area so that the
user cannot delete rows. If this option is selected, PeopleSoft
Application Designer automatically selects and disables the
Invisible check box on the Delete tab of the properties dialog
box for the body area.

Allow Deferred Processing

Set by default, this option ensures that the grid or scroll
area processes in deferred mode. This setting overrides any
individual field-level settings in your level-based control.

Allow Multi-Row Insert (Allow Multiple Row Insert)

Enables the user to add multiple blank rows at once to a grid
after a page is displayed. This feature is available only in Add
and Update modes. When the user clicks the Add Multiple
Blank Rows button, a JavaScript prompt appears so that the
user can specify the number of rows to insert; the user can
insert between 1 and 99 rows.

Allow Column Sorting

Enables the end user to perform temporary sorts in a grid
at runtime by clicking the column headings. The default is
selected to allow column sorting automatically.
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Field or Control Description

Persist in Menu Important! Drop-down menus and other forms of classic

navigation are no longer supported.

Stores the most recent transaction search in browser memory
or web server memory and makes the results accessible
through the drop-down navigation menu structure. To specify
which fields appear as columns in the search results grid, use
the Persist Grid Column in Menu property.

Note: This property applies only to fields that appear in grids
on pages that are used as custom, application-specific search

pages.

See Setting Record Field Use Properties.

Note: If multiple grids exist on a custom search page and you
enable this property on more than one grid, the system stores
the search for only the first grid as it appears in the page order
on the Order tab.

You must enable recent search results caching at the system
level in the web profile for this property to take effect.

See “Configuring Caching” (Portal Technology).

Multirow Insert Option

Each time that a user adds a row to a grid or scroll area requires a transmission to the application server.
With the multirow insert option, this transmission occurs only once when the user wants to add multiple
blank rows. Selecting this option can significantly enhance the user’s experience when doing data entry
and also meets the developer’s goal of limiting page processing.

At design time in PeopleSoft Application Designer, this feature is disabled by default. If the No Row
Insert check box is selected, then the Allow Multi-Row Insert check box is deselected and disabled.
Where the multirow insert button appears, in the row or in the footer, depends on how you define the grid
or scroll area properties on the Label tab.

You can set any occurs count for your grid. When the end user inserts # rows, the occurs count for the
grid or scroll area is temporarily increased to n +  (if necessary), showing one row of context plus the
new rows. If you select an unlimited occurs count for the grid, this temporary adjustment is not necessary.

Note: This feature should not be enabled for grids and scroll areas with effective-dated rows.

When the user saves the page, normal save processing runs, including save-edits on all rows. New,
unchanged rows are not saved. After save processing, new, unchanged (and unsaved) rows are deleted
from the buffer. The only exception is when only one row exists and it is new and unchanged. This row
remains in the buffer, even though it has not been saved, because a rowset must always contain one row.
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For an end user, pressing the Alt+7 keys works the same with the multirow Add button as it does with the
standard Add button.

Row Selection Indicator

These options enable the user to select one or more rows in the grid and scroll area. At runtime, indicators
appear to the left of row numbers for grids and in the upper left corner for scroll areas. A transmission to
the server triggers the selection of the row or rows that the user designates. These selections can then be
detected in PeopleCode via the selected property on the row class for each row of data.

Field or Control Description

No Selection Indicator This value is the default selection. Prevents the user from
selecting rows on the transaction page.

Single Row (radio button) Enables the user to select a single row in a grid or scroll area.
Inserts a radio button to the left of each row that the user can
select.

Multiple Row (check box) Enables the user to select multiple rows in a grid or scroll area.

Inserts a check box to the left of each row that the user can
select. Users can select as many rows as needed.

Set Component Changed Enables the user to receive a save warning if a change is
made to a row selection indicator in the grid. At runtime, the
transaction page uses this option to set the PPR. CHANGED
flag. This option is deselected by default.

This property ensures that if any changes occur to the grid, the
data is saved to the database.

If you disable this property, any row insert, row delete, or field
change on the rowset using PeopleCode would not cause the
system to treat the component data as changed.

Note: For the row selection options, PeopleCode can change the selected property, which affects which
boxes are selected when the page is regenerated.

Popup Menu

Select a preset pop-up menu from the drop-down list box. The pop-up menu button appears in the left-
hand corner of the navigation header at runtime.

See Creating Pop-up Menu Definitions.

Row Styles

You can control the color, font, and other characteristics of a row, active tab, inactive tab, and navigation
bar by specifying a style in the drop-down list box for each of the row style options.
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These options enable the advanced grid properties available with scrollable grid layout only.

See “Viewing Data in Scrollable Layout Grids” (Applications User’s Guide).

Field or Control

Description

Grid Layout

See the table below for descriptions of each grid layout option.

Rows to show in scrollable layout

Enter n (number) to set the height of the scrollable grid to »
visible rows.

This value represents the number of rows to show when
Scrollable Grid Layout is selected and the Vertical Scrollbar
check box is selected. If this number is greater than the

Occurs Count set on the General tab, then no vertical scroll
bar appears, regardless of whether the Vertical Scrollbar
check box is selected. If this number is lower than the Occurs
Count and the Vertical Scrollbar check box is selected, then a
vertical scroll bar appears and this number of rows will appear
in the scroll area. The scroll bar will scroll over the entire
Occurs Count number of rows. To see more rows in this case,

use the row navigation controls on the grids navigation bar.

If this field is set to /, then the vertical scroll bar will not
appear except in View All mode, in which case the scroll bar
will display the number of rows listed in the Occurs Count
setting.

The default value is /5.

Horizontal Select to activate a horizontal grid scroll bar at the bottom of
the scrollable grid.
Note: This option affects scrollable grid layout only.
Vertical Select to activate a vertical grid scroll bar at the right side of

the grid.

Note: This option affects scrollable grid layout only.

Note: Some of the grid layout types are supported only for classic pages; these all begin with the word
Classic. Others are intended only for fluid pages; these do not begin with the word Classic.. If you add
a classic grid layout type to a fluid page, in some situations the system displays a JavaScript error. For
example, if on a fluid page, you select Classic Grid Layout for a grid, then at runtime you will see a
JavaScript error when working with the grid, such as when adding new rows. To resolve the error, select
Flex Grid Layout for the grid layout type for the fluid page.
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Grid Layout

Description

Classic Grid Layout

Original grids are the standard grid layout in releases prior to PeopleTools 8.50. With original
grids, you can see navigation headers and footers; insert, multi-row insert, and delete buttons; and
grid separator tabs. If the Personalize link is enabled by the developer, you can search for data

within the grid, sort grid data; and rearrange, freeze, and hide columns to personalize your grids.

Classic Scrollable Grid
Layout

Unlike original grids, scrollable grids take advantage of AJAX technology, which enables you
to change the grid structure and content directly on the grid. You can make changes to scrollable
grids directly from the transaction page without using the Personalize link. Additionally,
scrollable grids can be configured to scroll data within the grid control so as to keep frozen
columns or column headers from scrolling out of view. Scrollable grids enable you to navigate
from cell to cell vertically and horizontally.

Important! If you have a Classic Scrollable Grid Layout grid displaying over 300 rows and you

encounter performance issues in the browser, Oracle recommends that you convert the grid to the
Classic Grid Layout. This allows the page in the browser to scroll, but not the grid. This reduces

the overhead of keeping the grid column headers fixed and they will scroll along with the rest of

the page content.

Note: For scrollable grids, PeopleTools does not support any other style class apart from the
default style classes applied to scrollable grids by the system. The styles applied to scrollable
grids should not be customized, and you should not apply custom styles.

Note: With Scrollable Grid Layout selected for a grid, on mobile devices, such as tablets or
smartphones, the system displays the grid on the mobile device as Original Grid Layout.

Note: HTML area controls should not be inserted into grids set to Scrollable Grid Layout. The
system cannot calculate an HTML area's width and height data, which is required for the grid
columns to be aligned and to display the correct number of grid rows.

List Grid Layout
(Unordered)

Used to contain a list grid for displaying lists of items. It represents a grid as an unordered list
(using <ul> and <li> tags).

List Grid is not a table grid. Therefore the proper use can be to have a grid with only one visible
grid column.

Data Grid Layout

Select so users will not see the grid displayed on the fluid page, as if the grid is hidden. The data
in the grid is stored in two JavaScript variables, as in one for the grid header columns and one
for grid row data. You need to write custom JavaScript to use the grid data stored in the two
variables.

Div Grid Layout

Represents a grid as a structure of HTML <div> elements. This allows for the dynamic creation
of structures on a page that are not restricted to the display of tables or lists. It creates a structure
of containers that allows more dynamic displays of data, if needed.
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Description

Flex Grid Layout

A table-based grid recommended for displaying tabular data on a fluid page. This grid layout type
is based on the Original Grid Layout, but enhanced to take advantage of the “flex” model on fluid

pages.

Classic List Grid Layout
(Unordered)

Creates a bulleted list in a one-column grid.

The system generates an unordered list with <ul> </ul> HTML tags instead of <table> </table>
tags, indicating the content is an unordered list containing rows of list item tags (<li> </1i>) for
the rows of data.

Classic List Grid Layout
(Ordered)

Creates a numbered list in a one-column grid.

Similar to the unordered list, except that instead of unordered list tags (<ul> </ul>) tags the

system generates ordered list tags ( <ol> </ol>) to contain the list items.

Classic Presentation Grid
Layout

The system generates the <table> tag with the role = “presentation” clause added to it. This
indicates to a screen reader that the grid is for presentation and layout purposes, rather than data.

In some cases, you may want to use a table for layout purposes only (keeping elements aligned in
a certain way, for example). By specifying this option, PeopleTools adds a WAI-ARIA tag to the

table so a screen reader will ignore the table (not treat it as a data table).

List Grid Layout (Ordered)

Used to contain a list grid for displaying lists of items. It represents a grid as an ordered list (using
<ol> and <li> tags).

List Grid is not a table grid. Therefore the proper use can be to have a grid with only one visible
grid column.

Menu Grid Layout

Use as a container for a pop-up menu.

See “Creating Fluid Pop-up Menus” (Fluid User Interface Developer’s Guide).

Tab Set Grid Layout

Use to as a container for a set of sectional tabs embedded on a page.

See “Creating Sectional Tabs on a Page” (Fluid User Interface Developer’s Guide).

For the Classic List Grid Layout types (ordered and unordered), the following restrictions apply:

*  Only the first edit box or hyperlink column in the grid will be displayed. Any subsequent columns in
this type of grid will be ignored as will any other type of column that comes first. For example, push
buttons, drop-down lists, check boxes, and so on, will all be ignored and not displayed.

* The grid will be display only, regardless of how it is set in Application Designer.

* The Add Row and Delete Row controls will not be displayed on the rows.

* Odd/Even row highlighting will be disabled, regardless of how it is set in Application Designer.
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* Header and Footer areas that would normally be available in other types of grids will not be
displayed. These would normally contain elements like navigation controls, such as (First <1 — 10 of
80 > Last), the Find and Personalize links, the Download to Excel and Zoom controls, and so on.

*  Column headers will not be displayed.

For the Classic Presentation Grid Layout, these restrictions apply.

* Odd/Even row highlighting will be disabled, regardless of how it is set in Application Designer.

* Header and Footer areas that would normally be available in other types of grids will not be
displayed. These would normally contain elements like navigation controls, such as (First <1 — 10 of
80 > Last), the Find and Personalize links, the Download to Excel and Zoom controls, and so on.

*  Column headers will not be displayed.

The grid layout type can also be specified in PeopleCode. See “Layout” (PeopleCode API Reference) for

more information.

Display Options

Field or Control

Description

Invisible

Select to make the grid or scroll area and its associated fields
and records invisible. Use this setting for work grids or
scrolls for which you want the underlying processing to be
transparent to users. Typically, you associate invisible work
grids and scrolls with PeopleCode Scroll functions that enable
you to further control application processing.

Display Only

In some cases, you might design grids that enable users to
view but not change information. Select this check box if you
do not want the user to enter data into the fields in any of the

TOwWS.

Odd/Even Row Style

Selected by default, this attribute displays the grid with
contrasting colors by row. The Odd Row Style and Even Row
Style drop-down list box options appear instead of the single
Row Style option in the Row Styles group box.

Note: Odd/even row styling is not supported for fluid grids.

Show Column When Cells Hidden

Select if you want the columns to appear even if all of the cells
in a column are hidden. Columns do not collapse.
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Field or Control

Description

Fixed Height (number of rows)

Select to set the grid to a height corresponding to the number
of rows in the occurs count attribute. The grid remains fixed at
that height even if the actual number of data rows varies from
that number. If the fixed height property is not used, the size
of the grid dynamically changes based on the occurs count and
the number of data rows retrieved.

Enable View All Columns

Displays an expand all button to the right of a tabbed grid,
enabling the user to view all columns of the grid by scrolling
to the right using the horizontal scroll bar of the browser
instead of selecting the grid tabs. The Show Grid Tab button
appears when columns are expanded to enable the user to view
the tabs again.

Disable Display in Modal Window

Select to disable the zoom capability of the grid.

Disable Row Highlighting

Select to disable grid row highlighting.

By default, when an end user hovers the mouse over a row
or selects the row, the system highlights that row to indicate
it is the row of current focus. However, highlighting can be
distracting or unnecessary for some interfaces for varying

reasons, such as the form factor of the device displaying the
page.

Collapsible Data Area

Select to create a collapsible grid or collapsible scroll area.
When a grid or scroll area is collapsed, the user is presented
with a header bar that includes a small image that the user
must click to activate or expand the data area. Selecting this
option enables the Default Initial View to Expanded State
check box. You can also select the label image to represent the

collapsed and expanded states.

Note: Collapsible data areas are not supported for fluid grids
and scroll areas.

This example illustrates a collapsible grid in the collapsed state.

Define Personalizations
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This example illustrates the same collapsible grid in the expanded state.

Define Personalizations Personalize | Find | View All | | Q First ‘&) 1-25of 67 '}’ Last
Definition Format Explanation

*User Option Description *Option Category Group Option Category #;:ErOption g:;zl‘:
1AUTO Auto Dismiss [PS Internet Architecture | [Pop-up Notification +|[System ~ 0O [+ [=]
2POPUPWIN Queued State [P= Internet Architecture | [Pop-up Noification ~|[System | O [ =]
3POPUPWIN Processing State [PS Internet Architecture | [Pop-up Notification v|[sistem ] 0O [+ =]
4POPUPWIN Success State [P= Internet Architecture | [Pop-up Noification ~|[System | O [ =]
5POPUPWIN No Success State [PS Internet Architecture | [Pop-up Notification +|[System ~ O [+ [=]
EPOPUPWIN Posted State [P= Internet Architecture | [Pop-up Noification ~|[System | O [ =]

Configuring Embedded Help for Scroll Areas, Grids, and Group

Boxes

You can configure scroll areas, grids, and group boxes to display an embedded help pop-up message that
you create and store in the Message Catalog.

This diagram illustrates the business process flow for creating, configuring, and accessing embedded help:

The following diagram illustrates the business process flow for creating, configuring, and accessing

embedded help

E =
g Datermine the
i Create help

location of the
5 el content and enter
E or group box that - m':::asge;n
5 needs embedded Catal 9
= help. °g.
=
w

L J
_ Add technical SO
2 parameters to the + gna.
I=] | or group box and
o embedded help \ -
z essaga in associate it with
(]} Message Catalog the embedded
help message.

- Y

B

= Access page and

: .

s click embedded oW embedaed
2 help icon. p popup page.

This section discusses how to:
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Enter embedded help messages in the Message Catalog.

Associate help messages with scroll areas, grids, and group boxes.

Note: Embedded help is not supported for group boxes, grids, and scroll areas on fluid pages.

Entering Embedded Help Messages in the Message Catalog

366

To configure embedded help, first you must create Message Catalog messages that you specifically design
for use by scroll areas, grids, and group boxes. To enter embedded help messages in the Message Catalog:

1.

2.

Access the Message Catalog (PeopleTools, Utilities, Administration, Message Catalog).

Select an existing or create a new message.

Note: You should create new message sets to avoid extra upgrade maintenance tasks.

Enter the help content in the Explanation field. Include the necessary variables if you want to
generate other help links that appear on the embedded help pop-up page. The table at the end of this
section describes the variables and their usage.

Note: The help content should be contextual and specific to the page control to which it will be
associated in the next section.

Save the message entry.

Embedded Help Variables

This table describes the variables that you can add to the embedded help content in the Message Catalog.
Use these variables to generate links on the embedded help pop-up page that enable the user to access
additional online help.
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Note: You must install the Online PeopleBooks Library for any PeopleBooks Online Help link to

function properly.
Variable URL Label
$PBCTXT ()

This variable uses the current page
name as the %CONTEXT_ID% to

build the PeopleBooks Help URL so

the embedded link takes the user to the
PeopleBooks content associated with the
current page.

Because no message is referenced, the
label of the help link appears as Help.

$PBCTXT (sn, mn)

The argument sn is the Message
Set Number. The argument mn is the
Message Number.

This variable uses the current page name
as the %CONTEXT ID% to build the
PeopleBooks Help URL so that the
embedded link takes the user to the
PeopleBooks content associated with the
current page.

Because a message is referenced, the
label of the help link appears as the value
that is stored in the Message Text field
for the referenced message.

If you reference an invalid message, the
label appears as Help.

$PBCTXT (CTXT PG NM)

The argument CTXT PG _NM is a page
definition name.

This variable uses the CTXT PG_NM
argument as the % CONTEXT ID% to
build the PeopleBooks Help URL so that
the embedded link takes the user to the
PeopleBooks content associated with the
page referenced by the argument.

Because no message is referenced, the
label of the help link appears as Help.

%PBCTXT (CTXT_PG_NM, sn,mn)

The argument CTXT PG_NM is a page

definition name.

The argument sn is the Message
Set Number. The argument mn is the
Message Number.

This variable uses the CTXT PG NM
argument as the %CONTEXT_ID% to
build the PeopleBooks Help URL so that
the embedded link takes the user to the
PeopleBooks content associated with the
page referenced by the argument.

Because a message is referenced, the
label of the help link appears as the value
that is stored in the Message Text field

for the referenced message.

If you reference an invalid message, the
label appears as Help.

$PBURLTBL (<URL_IDENTIFIER>=
,Sn, mn)

The argument <URL IDENTIFIER>
is any URL_ID that is stored in the URL

Maintenance component.

See “URL Maintenance” (System and

Copyright

Server Administration).
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This variable uses the <URL

IDENTIFIER> argument to build help

URL so that the embedded link takes the

user to the site associated with the URL
ID.

Because a message is referenced, the
label of the help link appears as the value
that is stored in the Message Text field
for the referenced message.

If you reference an invalid message, the
system uses the <URL _IDENTIFIER>
argument as the label.
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Variable

URL

Label

The argument sn is the Message
Set Number. The argument mn is the

Message Number.

$PBLNK (http://www.site.com=>

,Sn,mn)

The argument sn is the Set Number. The

argument mn is the Message Number.

This variable uses the hard-coded URL
so that the embedded link takes the user
to the specified site.

Because a message is referenced, the
label of the help link appears as the value
that is stored in the Message Text field
for the referenced message.

If you reference an invalid message, the
system uses the URL as the label.

Related Links

“Configuring General Portal Properties” (Portal Technology)

“Message Catalog” (System and Server Administration)

Associating Help Messages with Scroll Areas, Grids, and Group Boxes
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After entering a message, you associate the message to a page control. To associate help messages to

scroll areas, grids, and group boxes:

1. Open a page definition.

2. Double-click the scroll area or grid to access the properties dialog box.

3. Access the Label tab.

4. Inthe Embedded Help Popup section, select the Message Catalog Popup option.

5. Enter the Message Set/Number values of the message that you want to appear in the embedded help

pop-up page.

The message should appear in the Text field.

6. Verify that the message in the Text field is correct.

7. Click the OK button.

8. Save the page definition.

9. In the browser, access the page and test the embedded help.

Note: Use the preceding steps to associate Help messages to group boxes, too.

Related Links

“Accessing Embedded Help” (Applications User’s Guide)
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Understanding Page Design and Development

Pages are the graphical interface between your users and your application database. As a system designer,
you configure or build pages that meet the data requirements of the application and that are easy to

use and understand. Using PeopleSoft Application Designer, you can create, modify, and delete page
definitions in your PeopleSoft system.

This section discusses:

* Level-based controls.

» Keys for accessing pages.

*  Multiple occurrences of data.
*  Prompt fields.

* Derived and work fields.

» Sensitive data.

* Hidden pages.

» Upgrade considerations.

» End-user page personalization.

Level-Based Controls

You determine your page design based on the type of data that you plan to access and maintain. In some
cases, a page references a single record definition; in others, you may want to reference multiple records.
To accommodate a variety of page designs, PeopleSoft Application Designer uses level-based controls.
The three level-based controls are:

¢ Qrids
e Scroll areas
e Scroll bars

You specify the level of these controls by setting the occurs levels on the Record tab of the page field
properties dialog box for the level-based control that you are configuring. Level-based controls have four
levels:

e LevelO
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This level directly corresponds to the high-level key information of the underlying record. Level 0
fields are usually physically located at the top of the page, set to be display-only, and display the data
that the user entered on the initial search page.

e Levels 1-3

These levels correspond to lower level key information that is subordinate to the Level 0 key values.
Level 1 is subordinate to Level 0; Level 2 is subordinate to and nested within Level 1; and Level 3 is
subordinate to and nested within Level 2.

Note: You can nest level-based controls up to three levels.

The first occurs level on a page is Level 0. In general, this level is reserved for the primary key fields that
are used to search for data. A page might not contain any level-based controls; in such a case, all fields
are set to Level 0. This case is particularly true for secondary pages or subpages that contain few data
entry fields, as shown in the following example. The third column, Lvl (Level), that appears in the grid on
the Order tab indicates that all fields on the page are at Level 0:

This example illustrates the fields and controls on the Example of page definition Order tab. You can find
definitions for the fields and controls later on this page.

§& ACTIVITY_GUIDE_SBP (Page)

Layout Order l

Tab Order | Field ID |Lv]  Label | Type | Field | Record |Display Control ~
1 1 0 Subpags NOSEARCH_ v [

2 2 0 |Activity Name | Group Box ACTIVITYNAME | PSACTIVITYGEUL [

3 3 0 |Step 1 Link PushBin/Link | STEF_T_URL  |PSACTIWITYGEUI |[]

4 4 0 |Image 1 Image STEP_2_IMAGE | PSACTIWMITYGUI |[]

5 5 0 |Image 1 Image STEP_1_IMAGE | PSACTIMITYGUI |[]

B 3 0 |Step 2Lirk Push Btr/Lirk | STEP_2_URL  [PSACTIWITYGEUL [

7 7 0 Image 1 Image STEP_3 IMAGE | PSACTIMITYGUI |[]

g g 0 |Step 3Lirk Push Btr/Lirk | STEP_3_URL  [PSACTIWITYGEUL [

g g 0 lImage 1 Image STEP_4_IMAGE | PSACTIMITYGUI [[]

10 10 0 |Step 4 Lirk Push Btn/Link | STEP_4_URL  [PSACTIWITYGEUL [ v
< »

When you add a level-based control, a scroll area or a grid, to your page, the default occurs level for that
control is set to 1 in the properties dialog box. If you place a field in or below that scroll area, it is also set
to Level 1 on the Order tab, even if it is another level-based control. If necessary, you can use the Set to
Level 0 feature of the horizontal rule control to restart the occurs level on a page.

Note: You can have any number of level-based controls at the same level.

Nested Level-Based Controls

Nesting controls involve two or more level-based controls on a page, such as two scroll areas, when the
second scroll area has an occurs level of 2. You nest controls when the new data that you want to add is a
repeating set of data for each entry in your first level-based control. In doing so, you create a hierarchical,
or parent and child, relationship between the controls and the processing of the record definitions. The
Level 2 control is the child of and is subordinate to the Level 1 control.
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For example, on the Compensation page, the Level 2 grid is nested in the Level 1 scroll area. On the

Amounts tab of the grid, each compensation action in the Level 1 scroll area has two rate codes:

Creating Page Definitions

This example illustrates the fields and controls on the Example of Compensation page with nested grid in

scroll area. You can find definitions for the fields and controls later on this page.

Compensation Find First K 10f1 I3 Last
Effective Date: 01/0142000 . GoToRow |
Effective Sequence: 0 Action: Hire
HR Status: Active Reason:
Payroll Status: Active Job Indicator: Primary Job

Current [
Compensation Rate: 1,776.67 5 AUD (@, “Frequency: M Ionthly

¥ Comparative Information
} Pay Rates

Default Pay Companents Caontract Change Prorate Option

customize | Find | BV | % First B 122082 0 Last

" Controle || Changes || Conversion | [F==

*Rate Code Seq Comp Rate Currency Frequency Points Percent Rate Code Group
1[kaBso1 @ [ o | 1776667000/ [AUD @, M Q, =
2kaBSTL 1@, [ 0 | 19505000005 [AUD @, (M Q@ =

Calculate Compensation

This example of the Additional Pay 1 page shows three levels of data, two of which are nesting scroll

areas in the Earnings scroll area:

This example illustrates the fields and controls on the Example of Additional Pay 1 page with nested

scroll areas. You can find definitions for the fields and controls later on this page.

Additional Pay 1

Albion,Charles Employes ID: Z1000 EmplRcd#: O
*Code: I Q
=]

Eff Date and Default Job Data ine ]

Effective Date: IU?J’USJ’EUUU @ EI

Compensation Rate Frequency: §&,000.000000  Monthly

Standard Hours: 40.00 Employee Type: Salaried

Or Overrides to Job Data Find | %

. Earnings End

addiseq s [ Dato: | & =]

Rate Code: I <l Reason: I Mot Specif -]

Earnings: I Hnurs:l Hourly Rate: |
Goal Amt: | GoalBal: |

Sep Chk #: |_ "' Disable Direct Deposit [ Prorate Additional Pay [ OK to Pay
Applies to Pay Periods: M First [T - | -
[QReturn te Search) (+§ Hextin List) (?E ) (@ :I @ Include History) @Correct History)

Additional Pay 1 | Additional Pay 2 | Additional Pay 3

Copyright © 1988, 2023, Oracle and/or its affiliates.

371



Creating Page Definitions

372

In this case, we want to maintain information about the compensation history for a single employee and,
for each change or override in compensation status, enter details about that change. The first scroll area,
Earnings, associates the earning code with the second, subordinate scroll area, Eff Date (effective date)
and Default Job Data, which enables the user to enter the effective date for the status change. The third
scroll area, Or Overrides to Job Data, which is subordinate to the second, enables the user to enter the
overrides to the default job data that appears in the second scroll area.

For each of the three scroll areas, you can have several rows of data. While you do not see actual scroll
bars on your page, the navigation buttons and links in the navigation bars for each scroll area enable you
to navigate or scroll through the rows.

Nested Grids in Scrolls

As shown previously, you can nest a grid in a scroll or scroll area. The following example shows the
Other Earnings grid at Level 3, which is nested in the Earnings scroll area at Level 2, which is nested in
the Paysheet Details scroll area at Level 1. A nested grid serves the same function as a nested scroll area.
It can offer a more compact way of viewing many fields of data, particularly if you use a tabbed grid.

Chapter 10

Note: You can nest a grid in a scroll area, but you cannot nest a scroll area in a grid or a grid in another
grid.

This example illustrates the fields and controls on the Example of Paysheet page with three levels of
nesting.

One-Time Deductions

One-Time Garnishment One-Time Taxes Fage Balances

Earnings Begin:

Other Eamnings
*Code Seq Hbr

Rate Code

Hours

Company: Br1 Pay Group: B2M Pay Period End Date: 1213111998 Page: 1
Line: 1 Empl ID: B-REMASET3 Retmaset3,name #[=]
Empl Record: 0 Benefit Record: 0 I” Manual Check
Check Number: Check Date: Total Gross: Net Pay:

Transaction Message: Mo Message
Eamings Find | View A1l First K1 10f1 I Last
¥ OK to Pay ¥ Job Pay ™ override Hourly Rate ™ Ho Direct Deposit [+ [=]
I~ Gross-Up [T TL Records
Reg Hours: 173.33 OT Hours: Hourly Rate: 17.307692 Reg Salary:
Reg Rate Code: OT Rate Code:
Shift: MIA State: CA Locality:
1210111998 Earnings End: 121311998 Additional Data

Customize | Find | View A1 | B | 8 First £ 4 054 I Last

Rate

Amount Source

| @ | @ |

[#|=

Levels and Runtime Processing

Levels play an important role in runtime processing. The component processor relies on the level at which
you place a field on a page to determine how to process any PeopleCode attached to the field in the record

definition.
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Effective Dates and Level-Based Controls

The EFFDT (effective date) field must be the on/y key field that is controlled by level-based controls that
you create to help users maintain multiple occurrences of data that is keyed by effective date. Otherwise,
the effective date processing for update actions does not function correctly.

Related Links
“Understanding Data Buffer Access” (PeopleCode Developer’s Guide)

Keys for Accessing Pages

No matter how much time you spend defining and refining your page, your work is useless unless the user
can access it. You must add it to a component, and then you must add that component to a menu. When
you add a page to a component, you determine what actions the user must perform to access the page and
the keys that are required to retrieve rows of information.

The search record that you define for a component determines the key list; that is, search keys for which
users are prompted when they select a page and an action. A search record can be either a view that
concatenates information stored in several tables or the underlying table itself. Select the search record
that contains all of the key items for the primary record underlying the page.

The keys for which the search dialog box prompts should populate the high-level (Level 0 in the page
definition) key controls on a page. These key controls always appear before any level-based control on the
page and are typically display-only. A search record might differ from a primary record definition, but it
must contain all of the Level 0 keys that you placed on the page.

Using Keys for Views

When you create a view that should use key values from a page, each key must be:

» Listed as an output column from the view (not just referenced in the WHERE clause of the view).
* Marked as a key field of the view.

For example, suppose that a page has PERSON.PERSONID as a Level 0 field. PERSONID is the key of
the PERSON record. A grid on the page uses the PERSON_ADDRESS VW view to display addresses
for the current person. The SQL statement for the view cannot only mention PERSON.PERSONID in the
WHERE clause; PERSONID must be both an output column of the view and a key field of the view.

Related Links
Understanding Record Definitions
Understanding Component Definitions

Multiple Occurrences of Data

On some pages, you may want a few of the field controls to display multiple rows or occurrences of data.
To do this, you can add a level-based control: a scroll area, a grid, or a scroll bar. Users can then add, edit,
delete, find, and scroll through multiple occurrences of data in a page control or group of controls using
action buttons, links, or the browser scroll bar, depending on how you set the occurs count. Using a scroll
area or a grid, rather than a scroll bar, is the preferred page design to show multiple occurrences of data.
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For example, this Checklist Table page contains the Assignment Checklist Item grid with an occurs
count of 5. The Checklist Item scroll area in which it is nested must have an occurs count of 1 since we
can see only one row of data in the scroll area:

This example illustrates the fields and controls on the Example of Person Checklist page with a grid
of occurs count 5 nested in a scroll area of occurs count 1. You can find definitions for the fields and
controls later on this page.

Person Checklist

Susan Jones Person ID: 0002
4 ]
*Checklist Date: 0817/2011 5 [+ [=]
*Checklist: DEUTER (@, Termination
Comment: @
) Kl 1
*Sequence *lterm Code Description *Status Link ID
1000 |TERD1 OJ Cancel Security Access Im ﬂ ﬂ
200, [TER02 @, |Update Social Insurance Data [infisted  #]  Update Social Insurance Data +]|[=]
500 [TER0S @, Holiday status/ bonus [intisted =] [+]}[=]
800 |[TERDS OJ Frocess Job Change Im Jab Change Request ﬂ j
900 |[TERDA O, Verify Termination Date Im Verify Termination Date [+]{[=]

To see the next set of five rows in the Assignment Checklist Item grid, a user can click the right arrow
button. To see all rows of data at once, in either the grid or scroll area, the user can select the View All
link in the navigation bar.

In PeopleSoft Application Designer, you set the occurs count for a level-based control on the General

tab in the properties dialog box. You can set the occurs count to any number. You also have the option of
selecting Unlimited Occurs Count so that the user sees all rows of data. If the page has more options than
can be viewed in the window at runtime, the browser displays a scroll bar enabling the user to scroll to the
bottom of the page.

Note: When an occurs count is set to a number other than /, the grid displays the specified number of
rows. However, when it is set to /, the grid displays as many rows as possible within the given space
allocated for the grid control at design time.

Prompt Fields

374

You can enable your users to look up the valid values that they can enter in a field. For this, PeopleSoft
Application Designer provides prompts, or lookup buttons. Your PeopleSoft applications use the
following three types of prompts:

*  Drop-down list box

This type of prompt generates a list of values, which appears directly below the prompt field when the
user clicks the down arrow that appears beside the field.
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The drop-down list box is a predefined control that you place on your page. The Job Indicator field
on the Work Location page is an example of drop-down list box.

» Calendar prompt

This type of prompt generates a small calendar, which appears next to the date field, when the user
clicks the calendar button. Users can navigate the calendar to find and select a date. The Effective
Date, Position Entry Date, and Department Entry Date fields on the Work Location page are
examples of calendar prompts. The calendar prompt appears automatically as part of any edit box
control that you associate with a date field as long as the Show Prompt Buttoncheck box display
option on the Record tab is selected.

*  Lookup button

A prompt or lookup button opens a lookup page in the user's browser populated with up to 300
available values for that field. The user can then either select the desired value or refine their search
further. For extremely large tables, the system administrator has the option of excluding that table
from auto prompting on the lookup exclusion list via PeopleTools, Utilities, Administration, Auto
Lookup Exclusion List.

In Application Designer, you can only associate a lookup button with an edit box control. The look
up button appears automatically as part of any edit box control as long as the Show Prompt Button
check box display option on the Record tab is selected and the record field with which you associate
the edit box lists values in either the Translate table or a prompt table.
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This example illustrates the fields and controls on the Work Location page showing sample prompt fields.
You can find definitions for the fields and controls later on this page.

" Wao acation | Job Information Job Labor Payrall Salary Plan Compensation
Jaime Salazar Empl ID: KYLA1S
Emplayee Empl Record: 0
*Effective Date: 01/01/2008 B GoToRow [+][=]
X X
Effective Sequence: o IPGT Rate Change =l
HR Status: Active [January =] |2008 =] | otner =l
Payroll Status: Active s M T W T F s Primary Job =l
Mot Applicable
1 2 3 4 &8
Position Number: § 7 8 9 10 11 12 Secondary Job
Override 13 14 15 18 17 18 19
20 21 22 23 24 28 28
Paosition Entry Date: I,
" 2T 28 2% 0 0o
[~ position
*Regulatory Region: MEX @ c tDate [B)
Lurren are
s‘[:DI"I’]DEI"I‘,‘: KYF CUTTTEENTE TTTaTTeTeETd
*Business Unit: KY0O1 2 Unidad de Negacios 1 - México
*Department: 22000 2 Sales and Senices
Department Entry Date: ~ (01/0112000 5
*Location: KYDF @ Mexico Headquarers
Establishment ID: @ Date Created: 12M18/2008
Last Start Date: 01/01/2000
Expected Job End Date: e
P Spain
[ E'Japan
Job Data Employment Data Earnings Distribution Benefits Program Participation

Related Links

Using Drop-Down List Boxes
Specifying Date Field Attributes
Using the Translate Table

“Lookup Exclusion” (System and Server Administration)

Derived and Work Fields

You can use a field definition from a derived or work record to store a temporary value that PeopleCode
uses to determine the values of other field controls on the page.

For example, for a budgeting transaction in PeopleSoft General Ledger, assume that you have an annual
amount that you must spread to multiple accounting periods. You can create a page that includes both

a field control from a derived record for the annual amount and an amount control for each accounting
period. You then write PeopleCode to derive the amount per accounting period from the annual amount.
When a user enters the annual amount in the derived field control, PeopleCode calculates the amount per
accounting period and inserts it into each accounting period field control. The annual amount is not stored
in the database, but the period amounts are.
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Sensitive Data

You can allocate sensitive data to a single page and limit access to that page to the users who need to
update it. Alternatively, you can enter PeopleCode to hide certain fields on pages based on appropriate
criteria. The page approach is simpler, however, and can be used in most situations. For secondary pages,
this sort of security is more complex to manage.

Related Links
“Hide” (PeopleCode Language Reference)

Hidden Pages

Hidden pages are work pages that are associated with derived or work records; they are often used in
work groups. You can store all of your work field controls on hidden pages. Create these pages when you
want PeopleCode calculations to be performed in the background so that the user does not see them. As a
convention, the names of work pages that are delivered with your application names end with the suffix
_WRK; you should follow the same naming convention. An example name is: MC_TYPE WRK.

Hide a page by selecting the Hidden check box in the component grid as you set up the component
definition.

Related Links
Setting Page Attributes

Upgrade Considerations

If you adapt a PeopleSoft application, you might affect your use of future PeopleSoft releases. The closer
your PeopleSoft system is to the standard product, the easier your upgrades will be. Avoid superfluous or
cosmetic changes to data structures in the standard product. Document all of your changes in the comment
area on the General tab in the Page Properties dialog box.

End-User Page Personalization

End users of PeopleSoft applications can personalize various settings on a page, including tab order, the

display state of scroll areas and grids, and the state of collapsible sections. Users can also choose that the
default page display for a component each time they open that component. In addition, users can choose

to share their personalization settings with or copy settings from another user.

The page personalization option is set in the Component Properties dialog box, Internet tab. The
Personalize Page Link check box is selected by default to enable the Personalize Page link in the
pagebar at runtime for all pages.

Related Links

Setting Internet Properties

“Personalizing Pages” (Applications User’s Guide)
Understanding Scroll Areas, Scroll Bars, and Grids

Using Page Development Tools
Adding Page Controls
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Manipulating Page Controls

Using Page Development Tools

This section discusses how to:

Use page definition menus.
Use page definition toolbars.

Use the page layout grid.

Using Page Definition Menus

As you build pages, use the tools and options in these menus:

378

File Menu

In addition to the standard options for opening, deleting, and renaming pages, use this menu to access
the definition (page) properties and project properties.

Edit Menu

Access the page field properties from this menu. To find out what other definitions reference the
active page, select Find Definition References. You can also search for a text string in types of
PeopleCode or SQL objects.

View Menu

* Select View Definition to view the underlying definition, such as the subpage or record, for the
selected control.

You can view the PeopleCode for the page or the underlying record definition.

» The properties Edit Fill Display, Edit Fill All, and Edit Fill None refer to how controls appear only
during design time. They do not affect the page during runtime.

» Use the Show Page Control Inspector tool to view summary data of the selected page field.

» Use Show Grid to display or hide a layout grid on the page that you are designing to help you
place controls more accurately.

Insert Menu

Use this menu to insert different types of controls on your page. You can also insert the page on which
you are working into a project.

Tools Menu

This menu provides access to various utilities, such as data administration, change control, upgrade,
and translate.

Layout Menu
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Use this menu to modify the number of pixels between points on the layout grid. Options on this
menu also enable you to align page controls, align page control labels, view the processing order of
the controls on the page, and test the tab order between fields on your page.

L]

Use the Align functions to move selected page controls or page control labels to ensure
consistency of vertical and horizontal placement among the selected elements. All selected
elements align to the last element that you select in the set.

Use the Auto Size Page function to resize your page to the best height and width that
accommodates your page controls.

Use the View in Browser function to see a very general image of the page in the selected browser
without data. Note, however, that PeopleCode is not run on this page rendering, so the page may
look significantly different to users if PeopleCode is used to hide or reveal page fields.

Use the Generate HTML function to create a text file containing the HTML for your page. The
file is saved to the Temp directory of your local drive. Note that the HTML that is generated
contains no data or context. It is, therefore, likely to differ from the HTML on a page at runtime.

Using Page Definition Toolbars

The toolbars in PeopleSoft Application Designer change, depending on the active window. When a page
window is active, you see the page definition toolbar and the page control toolbar.

Page Definition Toolbar

Field or Control Description

Click the Properties button to open the Page Properties dialog
box (Alt+Enter).

Click the Project Workspace button to display or hide the
project workspace (View > Project Workspace or Alt+0).

Click the Select Group button to select several controls at
once (Edit > Select Group menu item or Ctrl+P).

Click the Default Ordering button to reorder all of the fields
on the page based on their relative locations on the page
(Layout > Default Ordering).

Click the Test Page button to test the tab order of your page
design (Layout > Test Mode or Ctrl+T).

Click the View Page in Browser button frequently throughout
the design process (Layout > View in Browser).
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Field or Control

Description

Click the Toggle Inspector button to display or hide the
floating Definition Inspector window (View > Show Page
Control Inspector).

Click the Auto Size button to size a subpage or secondary
page to fit around page controls.

Click the Toggle Grid button to display or hide the page grid
(View > Show Grid or Ctrl+G).

Click the Left Label Position button to place the page control
label for the currently selected field immediately to the left
(Layout > Left Label Position or Ctrl+D).

= & ST # o

Click an Align (position) button to move the selected page
controls so that the edges or center points of the selected page
controls share a common axis (Layout > Align (position).

See Aligning Page Controls and Page Control Labels.

Click an Align Label (position) button to move the selected
labels so that the edges or center points of the selected labels

share a common axis (Layout > Align > Label (position).

=

Click the Auto Size Fields button to resize the selected edit
box and drop-down list box page controls so that they are
all the same width as the last page control that you select.
(Layout > Align > Auto Size Fields)

Click the Show Help button to view the page definition help.

Page Control Toolbar

The page control toolbar contains a button for each type of page control that you insert. The buttons
display images that look like the controls that they insert. You can move this toolbar on your workspace
independently of the system toolbar or the other half of the page definition toolbar.
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Field or Control Description
Frame.
S|
Iial Group box.

Horizontal rule.

Static text.

Static image.
= Grid tab separator.
=5 P
® Check box.
— Drop-down list box.
Ba

Edit box.
HTML area.
El Image.
Long edit box.
Push button/hyperlink.
® Radio button.
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Field or Control Description

Tree.

E Grid.
m Scroll area.

E Scroll bar.
Secondary page.

Subpage.
Chart.

Using the Page Layout Grid

382

When you open a page definition, evenly spaced dots appear in the workspace. This is the page layout
grid that you use to align controls. When you run applications, the grid does not appear on pages. It
appears only as a design aid in the page definition. This example shows the Layout Grid dialog box:

This example illustrates the fields and controls on the Example of Layout Grid dialog box with default
values. You can find definitions for the fields and controls later on this page.

Layout Grid

Spacing

k.
Wfidth: IEI pige|3 -
Height: pisels

Show Grid (%) ve: ()Mo

The default grid spacing is 4 x 4, which means that each row has one dot per 4 pixels and that the rows
are 4 pixels apart on the vertical axis. Most pages in PeopleSoft applications are built using this grid. To
change the spacing, open the Layout Grid dialog box by selecting Grid Settings from the Layout menu.

You can turn off the grid view of your page by clicking the Toggle Grid button in the page definition
toolbar.
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Changing Page Layout Grid Settings

To change grid spacing:

1.

2.

Select Layout > Grid Settings.
Enter values for the width and the height, which is the spacing of the dots in pixels.

The smaller the value, the finer the grid. The finer the grid, the more difficult it is to align fields
precisely without using the align functionality. Note that if either the width or height is set to one, then
the grid will be slightly off.

Select a Show Grid option to activate or deactivate the page grid.

If you copy an existing page and save it by another name, you also copy the grid settings that were
used to create the original page. For example, if the original page was built with a 5 x 5 grid, then
your new page also will have a 5 x 5 grid, by default. You can change the grid settings anytime while
working on a page. Doing so has no effect on the position of a field.

The snap-to-grid functionality is only available when the layout grid is showing.

Creating New Page Definitions

To create a new page definition, either clone an existing page or begin with a blank page. Cloning is more
efficient because you do not have to recreate controls that are common to all pages. You can also create a
template that contains only the controls that you need.

This section discusses how to:

Clone page definitions.

Create a blank page.

Note: When saving new definitions, always make sure to adhere to accepted naming conventions.

See Saving Definitions.

Cloning Page Definitions

To clone a page definition:

1.

Select File > Open.

The Open Definition dialog box appears.

Specify Page for the definition and locate the page that you want to clone.

When the system retrieves the page definition, select File > Save As.

If you save after you make modifications, you might accidentally overwrite the old page definition.

Enter a new page name.

Copyright © 1988, 2023, Oracle and/or its affiliates. 383



Creating Page Definitions Chapter 10

To create a new page template, name the page so that it appears at the top of your page list.

5. Click OK.

Note: Record definition names are restricted to a maximum of 15 characters; page names can have up to
18 characters.

Related Links

Opening Definitions

Saving Definitions

Creating a Blank Page
To create a new page without copying an existing page, select File > New > Page.
When saving the page, make sure that you adhere to the accepted naming conventions.

See Saving Definitions.

Adding Page Controls

You can add page fields to a page in a number of ways. You can copy page fields from one page and paste
them onto another, or you can drag-and-drop page fields from one page to another. In addition to these
basic methods, this section discusses how to:

* Drag field definitions from a record onto a page.

* Drag record fields from the project workspace onto a page.
» Drag record definitions onto a page.

» Use the page control toolbar.

¢ Use the Insert menu.

Important! While PeopleSoft Application Designer does not limit the number of page controls you can
add to a page, you might experience unexpected performance issues when you develop pages that contain
very high numbers of page controls.

Dragging Field Definitions From a Record Onto a Page
To drag field definitions from a record onto a page:
1. Open an existing record definition by selecting File > Open > Record.
2. Open a new page by selecting File > New > Page.

3. Drag field definitions from the record to the page.
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The system selects the page definition control type based on the record field attributes. In the
preceding page, the EMPLID (employee identification) field was defined as a prompt table edit in the
record, so a Prompt button was added for EMPLID when it was dragged onto the page.

4. Double-click the new page field to set the properties.
When you drag field definitions, the properties from the record definition are used to set page field
default properties. You can alter the properties using the Properties dialog box.
Dragging Record Fields from the Project Workspace onto a Page
To drag record fields from the project workspace onto a page:
1. Open the project that you want to drag from an existing or new page.
2. Drag record fields from the project workspace to the page.

3. Double-click the new page field to set the properties.

Note: When you drag fields from the project workspace, you must use fields that are contained in records
(that is, record fields), not standalone field definitions.

Dragging Record Definitions Onto a Page

You can add an entire record definition to a page at once, which can save a great deal of time when
generating pages. You can then arrange the fields as desired on the page.

Note: You can also drag an entire record definition into a grid control that you have placed on a page.

See Inserting and Manipulating Grid Columns.
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This example illustrates the fields and controls on the Dragging a record definition to a page. You can find
definitions for the fields and controls later on this page.
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To drag record definitions onto a page:
1. Open the project that you want to drag from an existing or new page.
2. Drag the record definition onto the page.

PeopleSoft Application Designer positions the record fields on the page as page fields in a cascading
manner. Fields are in the order that they appear in the record with the appropriate control value
assigned to each one.

3. Reposition the fields as necessary on your page.

4. Double-click each new page field to set its properties.

Using the Page Control Toolbar

386

You can insert page controls by using the page control toolbar. When you click one of the page control
buttons, the cursor changes to a cross-shaped icon or hand, depending on which control type you select.
You can then move the cursor to where you want to position the control and click once. If you select a
control from the toolbar erroneously and want to cancel the selection, press the Esc key and then select
the desired page control button.

If the control is a fixed size during insertion, the cursor changes to a cross-shaped icon. If the control
type requires that you define the size of the control at the time of insertion, the cursor changes to the
monogrammed hand icon. When a hand-shaped icon appears, press and hold the left mouse button as you
drag the hand diagonally downward to where you want the lower, right-hand corner of the frame. Release
the mouse button.

If the control is not correct the first time that you draw it, you can easily adjust it. The dotted box and
black or blue handles surrounding the control indicate that it is selected. Use any of the four directional
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arrow keys on the keyboard to move the frame one page grid unit in the indicated direction. You can also
use Shift+ the arrow key to resize the page control.

Using the Insert Menu

Select the control that you want to add to your page from the Insert menu. Your cursor changes to a cross-
shaped icon or a hand, depending on which control type you select. Move the cursor to where you want to
position the control and click once.

Manipulating Page Controls

After you place a control on a page, you have several choices for manipulating it.
This section discusses how to:

*  Select controls.

* Resize controls.

*  Use the Page Control Inspector.

* Delete controls.

* Move controls on the same page.

*  Copy and move controls to another page.

* Position page control labels.

Selecting Controls

Before you manipulate a control, you must select it. You can do this by clicking the control or by using
the Edit menu. A check mark beside the option in the menu indicates which of these modes you are in:

Field or Control Description

Select Field Select one control on the page by clicking on it. To deselect
a control, click once outside the dotted box. Deselected is the
default mode.

Select Group Select a group of controls by drawing a box around the
controls that you want to select. You can also activate this
option by clicking and dragging over the target fields.

Note: You are in Select Group mode when the cursor changes
to a pointing finger. If the cursor does not change when you
select Edit > Select Group try first selecting an individual
control on the page and then selecting Edit > Select Group
again.

Copyright © 1988, 2023, Oracle and/or its affiliates. 387



Creating Page Definitions

Chapter 10

Field or Control

Description

Select All

Select all of the controls on the active page. The result is the
same as using the Select Group option to draw a box around
the controls.

Resizing Controls

388

You can adjust the size or shape of any page control that displays selection handles when it is selected:

This example illustrates the fields and controls on the Resizing a control with selection handles. You can
find definitions for the fields and controls later on this page.
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Note: Some browsers do not support the resizing of certain control types. In these cases, changing the size
in PeopleSoft Application Designer has no effect upon the runtime size of the field.

See Troubleshooting Browser Limitations available on the My Oracle Support website.

To resize a control, use one of these methods:

* Select the control and drag a handle to adjust the height or width.

Note: For some control types, you can adjust only the width.

* Hold down the Shift key while pressing the Up Arrow, Down Arrow, Left Arrow, or Right Arrow

key.

The frame size is adjusted one grid unit in the indicated direction.

Note: The position of the top, left corner of the frame does not change; resizing with the keyboard occurs

by adjusting the position of the bottom, right corner.
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Using the Page Control Inspector

The Page Control Inspector provides location, size, type, and data source information for the selected
page control on the page. The first six values, Left, Width, Right, Top, Height, and Bottom, display the
exact bounding coordinates in pixels of the control on your page in PeopleSoft Application Designer. The
remaining values help distinguish the selected control from others on the page.

Access the Page Control Inspector from the View menu or by clicking the Toggle Inspector button on the
page definition toolbar. When you finish viewing the values for one control, click another control to view
its values. You can check multiple controls on a page in quick succession.

This example illustrates the fields and controls on the Page Control Inspector. You can find definitions for
the fields and controls later on this page.
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Note: The HTML that is generated for your page uses table layout, rather than pixel layout. You should
preview how your page might look in the PeopleSoft Pure Internet Architecture as you design it. Spacing
of fields at runtime may not appear exactly the same as during design time.

While the Page Control Inspector displays values for a grid, no information is available for individual grid
columns.

Deleting Controls

If you remove a control from a page, look for other controls that are related to it, such as display controls
or invisible controls used by PeopleCode. You may need to delete them as well or alter their attributes so
that they can be standalone fields.

Check for PeopleCode that references this control on the page by opening the field definition and
selecting View > Find Definition References. If any references exist, modify or delete them because
the control no longer exists on the page.

To delete controls from a page:
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1. Select the controls.

2. Select Edit > Clear.

Moving Controls on the Same Page

To move controls to another position on the same page, use one of these methods:

e Select a control and drag it to the new position.

* Select a control and press the Up Arrow, Down Arrow, Left Arrow, or Right Arrow key.
The control moves one grid unit in the indicated direction.

* Select a group of controls and drag them to the new location.

Moving Controls on Long Pages

Long pages are too big to be seen in their entirety in the definition workspace. Scroll bars appear on the
right and bottom enabling you to move about the page. To move controls that appear in the visible area of
the page to an area that is outside the visible area:

1. Select the set of controls by using Edit, Select Group.

2. Click and hold the set of controls.

3. Without releasing the mouse button, scroll the mouse wheel to move up or down the page.
4. Release the button to place the controls.

5. Save the page.

Copying and Moving Controls to Another Page

To copy a single control to another page, drag the control from one page to the other. For a group of
controls, you also can select the controls and use the copy and paste functionality.

To move a group of controls to another page, cut and paste the group onto the new page.

Positioning Page Control Labels
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PeopleSoft Application Designer enables you to change the relative position of most page controls and
their labels. This section discusses how to:

* Move page control labels.

* Prevent translation buffer overlap.

Moving Page Control Labels
To move page control labels, use one of these methods:

*  Select multiple labels and either click one of the Align Label (position) buttons in the toolbar or
select Layout > Align > Align Label (position).
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PeopleSoft Application Designer aligns the selected labels based on the last label that you select.
Alignment is based on the first letter, last letter, or middle letter of the labels; the translation buffer is
ignored.

» Select the label and drag it to the new position on the page.

*  Select the label and use a directional arrow key on the keyboard to move the label one grid unit in the
indicated direction.

* Access the control properties dialog box, select the Label tab, and then select an option in the
Position group box (the Location group box for radio button and check box controls). The Custom
option is informational only; it does not move the label. All other options move the label to the
selected position when you click the OK button.

*  Click the Left label position button in the toolbar to move the label to the default left position of the
page control.

Note: Select the control itself when you want to move both the control and its label and retain their
relative positioning.

Preventing Translation Buffer Overlap

Often, when you translate your own field labels, the label in the new language requires more space than
the English label. When you create or modify pages, you need to accommodate this requirement by
leaving additional space between the label and the field control. This space is called the translation buffer.
If you do not account for the translation buffer during page design, labels and controls can overlap, which
can interfere with readability after the translation.

PeopleSoft Application Designer automatically calculates the translation buffer size as 30 percent of
the current label length + the length of 2 upper case'Ns. The calculation uses the number of characters,
but it ignores the individual character itself. The combined character length and translation buffer
length is limited to 60 characters for static text labels, 30 characters for RFT_LONG labels, and 15 for
RFT_SHORT labels.

Based on the calculation, a page control label appears with dashed lines that surround and extend

beyond the label, visually indicating the appropriate translation buffer. PeopleSoft Application Designer
appropriately moves and adjusts the translation buffer indicators whether you align your labels to the

left, right, or center. For most page controls, the translation buffer indicators envelope only the label.
However, the translation buffer indicators for push buttons and links enclose the entire control because
these labels are embedded in the controls themselves. By default, PeopleSoft Application Designer resizes
push buttons and links automatically to accommodate the combined length of the label and the translation
buffer.

Note: Group box, grid, and scroll area controls do not display translation buffer indicators.

When you save a page, PeopleSoft Application Designer warns you if the page control label translation
buffer overlaps a control. When you dismiss the warning dialog box, PeopleSoft Application Designer
brings focus to the problematic page control. If more than one label is inappropriately positioned, the first
one receives the focus. When your page contains no translation buffer overlaps, the page saves without
warning.
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Note: Translation buffer indicators appear even if you do not translate your labels. Translation buffer
overlap, however, is inconsequential to English language pages.

Example: Translation Buffer Indicators

In this example, you see the translation buffer indicators for seven page controls. The link and the push
button demonstrate center label alignment. The Employee ID , Employment Status, and Flag for Review
labels demonstrate left alignment. The Description and Option 1 labels demonstrate right alignment:

This example illustrates the fields and controls on the Translation buffers indicators on several page
control types showing different label alignment settings. You can find definitions for the fields and

controls later on this page.
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Example: Translation Buffer Overlap

In this example, the Effective Date label maintains the translation buffer, but the Short Description label
does not maintain the translation buffer and overlaps the associated edit box page control:

This example illustrates the fields and controls on the Field labels demonstrating proper label positioning
(Effective Date) and translation buffer overlap (Short Description). You can find definitions for the fields

and controls later on this page.
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Setting Page Field Properties for Controls

For each page control that you add to a page you can control how it looks and functions in your
application page by setting page field properties. In most cases, you access the property settings by
double-clicking the control. Alternatively, you can highlight the control and select Page Field Properties
from the Edit menu or the pop-up menu, which is activated by right-clicking the control.

This section discusses how to:

Use the property window.
* Set record properties.

* Set label properties.

» Set use properties.

» Set general properties.

» Set option properties.

Using the Property Window

Use the property window to view and update page field properties. The property window can be used in
lieu of or in addition to using the page field properties dialog box.

In the following example, the property window displays the page field properties for the selected group
box. In addition, the Type field has been selected illustrating that properties can be updated directly in the
property window.
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These operations affect the use and display of the property window:
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Setting Record Properties
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e The property window is enabled by default.

Chapter 10

To disable or re-enable the property window, select Tools > Options.... Then select the General tab.

See Setting PeopleTools Options.

*  The property window is visible by default.

To hide or view the property window, select View > Property Window (Alt+2). Alternatively, to
hide the property window when it’s already visible, right-click anywhere on the property window,

then select Hide from the pop-up menu.

*  The property window is docked by default.

To make the property window undocked, right-click anywhere on the property window, then deselect
Allow Docking from the pop-up menu. See “Dockable Windows and Toolbars” in Configuring the
Application Designer User Interface for more information.

For most controls, you must set record properties to assign the control to a specific field in a record
definition. No distinct correlation exists between the field types in a record definition and the controls in a

page definition.

Use this table to select the appropriate page control type to associate with the corresponding field in your

record definition:

Record Definition Field Type

Page Definition Control Type

Character Edit box

Character (Yes or No Table Edit) Check box
Edit box

Character (Translate Table Edit) Radio button
Edit box

Drop-down list box

Long Character

Long edit box, HTML area

Note: Do not associate Long Character fields to edit box
controls; use a long edit box control. Associating a Long
Character field to an edit box control can produce unexpected
behavior on the page.

Number

Edit box

Signed Number

Edit box
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Record Definition Field Type Page Definition Control Type
Date Edit box
Time Edit box
Datetime Edit box
Subrecord Not applicable
Note: A direct association to subrecords is not available.
Image Image

To set the record properties for a page control, access the page field properties for the control and select
the Record tab:
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This example illustrates the fields and controls on the Edit Box Properties dialog box: Record tab. You
can find definitions for the fields and controls later on this page.

Edit Box Properties -
Record | Label | Usze | Generall Fluid |
Field
Record Name: | EEEAMGEETE vl
Fild Mame:  |EMPLID v
Style: == | lze Default Style == W | Fill Character: |:|
Size Alignment
® Average i) Auto
() b aimum 0 Left
() Custom i) Right

Digplay Optians

[ ] Display Zera [ ] Display Century

[ ] Password [ ] Curency Symbal

Show Prompt Button ] 1000 S eparator

[ ] &utoFil [ ] &wuto Decimal

[ ] Digplay Time Zone [ 1Enable Spell Check,
[rput ey

] | | Cancel

Note: This section applies to both edit boxes and long edit boxes. Other controls may contain only a few,

if any, of the properties listed in the following tables. Refer to the discussion of the specific control for
more information.
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Field or Control

Description

Record Name

Select the record name of the record definition where the
field is located. If you already added a field to your page and
associated it with a record definition, the system uses the last
record definition name that you entered.

Field Name

Select the field name. If the field is a related display field that
contains a long name or short name from the Translate Table,
use PSXLATDEFN as the record definition name. The field
name is either a long name (30 characters) or a short name (10
characters).

Style

Set the font and color attributes of your control data. The
default style class for an edit box is PSEDITBOX, which
controls how the data portion of the edit box appears. Control
the color, font, and other characteristics of an edit box by
specifying a different style class.

Note: Certain browsers always display the background of an
edit box as white.

See "Troubleshooting Browser Limitations" on Customer
Connection.

Size

After you link a control with a record name and field, the system automatically calculates the page
control size. The size is based on the length of the field that is defined in your record definition, the font
metrics of the field style, and any formatting options (currency symbol, 1000 separators, and so on) that
apply. Because many fonts have variable width characters (for example, a ¥ character is wider than a 1

character) three size options are available.

Note: Some browsers do not support custom sizing for edit boxes, long edit boxes, drop-down list boxes,

and push buttons.

See Troubleshooting Browser Limitations available on the My Oracle Support website.

Field or Control

Description

Average Select to provide sufficient space to display the field control
length in average-width characters.
Maximum Select to provide enough space to display the field control

length in maximum-width characters.
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Field or Control Description

Custom Select to define a custom size for edit boxes that are not
display-only. If you set a display-only edit box to Custom, it
appears as its defined length. If your edit box is in a grid, this
field wraps.

Alignment

Alignment indicates the runtime alignment of data within a page field. These settings have no affect on
the relative alignment of page fields.

Field or Control Description

Auto Select to left-justify the content of character fields and right-
justify the content of number and signed number fields. This
value is the default.

Left Select to left-justify the content of a field.

Note: If the field is not display-only, the alignment is always
left-justified. If the field is display-only, the system uses the
alignment that you specify.

Right Select to right-justify the content of the field. Do not use this
option in the PeopleSoft Pure Internet Architecture for fields
that are not display-only.

Family Name Displays the current family name, which was set when the
field was created, if it is applicable to your control.

Display Name Select an option to override the display format that is
associated with a field.
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Field or Control

Description

Display Zero

Select if the content of the page control are numeric and
you want to display a zero value instead of a blank field.
Sometimes, seeing a zero helps users remember that a page
control is not blank. For example, in a tax table you might
show the lowest tax bracket as starting at zero instead of
leaving it blank.

Display Century

Select for date fields to enable users to enter a date with a four-
digit century, as in 1999. Dates are always stored with the
four-digit century in the database, but only the last two digits
appear unless you select Display Century. If this option is not
selected, the century is automatically set to the century of your

system date.

Password

Select to hide the value that is entered or displayed in a page
control. When selected, characters in this control appear online
as black dots.

The component processor stores the actual value, making it

available for normal processing, such as PeopleCode.

Use this option for pages that capture sensitive information,
such as personal identification numbers (PINs), passwords,

and so on.

For more information on options for displaying sensitive field

data, see Protecting Sensitive Field Data Online.

Currency Symbol

Select to display a currency symbol in the field. This selection
expands the display length of the field by the length of the
currency symbol.

Show Prompt Button

Select to display a prompt button next to the edit box, which

enables the user to look up valid values for that field.

1000 Separator

Select if the content of the page control is numeric and you
want to insert thousand separators to make the numbers easier
to read. The system automatically calculates the number

of thousand separators to insert and determines where they
should be positioned. This selection expands the display length
of the edit box by one character for each separator.
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Field or Control

Description

Auto Fill

Select to have the system automatically populate the page
control with the character specified in the Fill Character field.
The direction in which it populates depends on the alignment

that you select. If a field is left-aligned, then it populates from
left to right. If a field is right-aligned, it populates from right to
left.

For example, suppose that you define a six-character control
as left-aligned, specify a fill character of 0, and activate Auto
Fill. When you type /23 in the control online, the system
displays /23000. Similarly, if you changed the alignment to
right, the system would display 000123.

Note: Auto Fill can affect the actual value of the control, not

just its visual representation.

Auto Decimal

Select to insert a decimal point automatically if none is
provided in the data that is entered into the control. Where the
system inserts the decimal point depends on how you define

the control.

For example, in a record definition if you define a numeric
field with a length of 4.2 (allowing four characters to the

left of the decimal and two to the right) and activate Auto
Decimal, the system inserts a decimal at the second digit from
the right. This option applies only to numeric field controls
and affects the actual value of the field control, not just its

visual representation.

Display Time Zone

Select if you are setting the properties for a Time or a
Datetime field and you want to display the related time zone.
This setting helps users understand whether the time reflects
the base time zone of the database or of some other time zone.
This setting does not determine which time zone is actually
used, only whether the time zone appears. The record field
properties determine which time zone is used.
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Field or Control Description

Input Only Select for edit boxes containing sensitive information that you
want to protect by:

» Displaying only masked characters s in the page field in
the browser. (Black dots or asterisks, depending on the
operating system and/or browser)

*  Preventing the field value from being accessible in the
page HTML.

The component processor stores the actual value, making it
available for normal processing, such as PeopleCode.

Use this option for pages that capture sensitive information,
such as personal identification numbers (PINs), passwords,

and so on.

For more information on options for displaying sensitive field

data, see Protecting Sensitive Field Data Online.

Copyright © 1988, 2023, Oracle and/or its affiliates. 401



Creating Page Definitions

Chapter 10

Field or Control

Description

Enable Spell Check

For edit boxes and long edit boxes only, this option enables the
user to check spelling on field content. This feature supports
17 languages using 36 dictionaries. Users have the option

of selecting the appropriate dictionary to meet the language
needs.

Note: On fluid pages, do not enable spell check on long edit
boxes that also have the rich text editor enabled.

The behavior of this feature is as follows:

*  Design time behavior: The default setting is deselected.
When theEnable Spell Check check box is selected,
the Show Prompt Button option is deselected and
disabled; a field can either be spell checked or validated,
but not both. Like the Look-Up button, the spell check

button appears to the right of the field and is not visible
on the page definition. Be sure to leave extra space to

accommodate it when placing other fields on the page.

*  Runtime behavior: The spell check button appears to the
right of the edit box and at the upper right corner of a
long edit box. Each click of the spell check button forces
a transmission to the application server, opening the
Spell Check page. The user then has the option to accept
or reject the recommended spelling for the individual
word or for all incidences of the term in the field. If no
misspellings occur, a message box indicates so without
leaving the current page. The Alt+5 hot key invokes spell
check while cursor focus is on the spell check field.

The spell check feature uses the current session language
when applying a foreign language dictionary, unless the
user changes it by means of Personalizations. The system
uses PSLANGUAGES to provide the SCLANG default

for each supported session language.

Fill Character

Enter a character to replace blank spaces in an edit box when
the system displays the content of the field. For instance, if the
length of a Net Pay field is 8.3 and you specify a fill character
of * then a value of $1,250 appears as:

***%%$1,250.000

You can use any character as a fill character.
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Example: Auto Decimal

This table shows how the Auto Decimal option affects a numeric field control with a length of 4.2,
depending on what you enter online:

Entered Displayed
100 1.00

100. 100.00

1 0.01

Setting Label Properties

The Label tab enables you to set the label that appears on a control. This label can be the long or short

name that is specified in the record definition or in other text. Use this tab to verify the label ID that is
used as the internal reference.

Access the page field properties for the control and select the Label tab.
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This example illustrates the fields and controls on the Edit Box Properties dialog box: Label tab. You can

find definitions for the fields and controls later on this page.

Edit Box Properties
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(] I Cancel

Note: This section applies to the following controls: edit boxes, long edit boxes, check boxes, drop-down

list boxes, group boxes, radio buttons, and static text.

Type

Select the type of label. If you want the label to remain blank, you must first set up a blank label in the
field definition that you are using. The blank label then appears as an option in the Label ID drop-down

list box.
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Field or Control Description

None Select to display no control label on the page. Use this option
for controls such as related displays.

Text Select to display text that you enter in the Text field. The
default text is the long name for the field from the associated
record definition.

For translation purposes, avoid using this option if possible.

RFT Short (record field table short) Select to display the RFT short name for the field from the
associated record definition.

RFT Long (record field table long) Select to display the RFT long name for the field from the
associated record definition. This value is the default.

Label Text

Field or Control Description

Text Enter the text exactly as it should appear on the page. The
default is Dummy Name until you assign a record and field to
the control. This field is only enabled if you selected Text as
the type. Otherwise, the system displays the label text assigned
to the field for the Label ID you select.

Label ID Select from the drop-down list box the label you want to

appear for the page field. The available choices are based
on the Label ID column and the Long Name column for the

selected field definition.

The default setting for this option is Use Default Label. This
default is determined by the label you select as the default for
the field definition.
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Field or Control

Description

Context

Displays text to assist the translation team determine the
context of the field label to be translated. The context is
determined by the field name and label ID combination. If
no contextual information exists in the database, then no text

appears in this field.

This property appears on edit box, long edit box, drop-down
list box, push button, image, chart, tree, group box, and check
box page controls.

Application users define the contextual information on
the Context Information page. See “Providing Context
Information” (Global Technology).

Insert Line Feed

Click to split your control label into multiple lines at the
position of the cursor in the Text field. A thick vertical bar
character appears in the Text field. When you close the
properties dialog box, the label is split into multiple lines. This
option is only active when you select 7ext for the type.

Style Select an option to control the color, font, and other
characteristics of a label. If you do not select a label style
that is different than the default, Use Default Style, then the
system uses the label style specified on the style sheet on the
PeopleTools Options page.

Alignment

The label alignment in the page field properties controls the alignment for both page fields placed on a
page and page fields as grid columns. For a grid column, the label becomes the column heading and is
aligned within the column boundaries as specified by this attribute, either left, centered, or right.

Field or Control

Description

Left Select to align the label to the left-of-center horizontally. This
value is the default.

Centered Select to center the label horizontally.

Right Select to align the label to the right-of-center horizontally.

Note: By default, the system uses left label alignment. To make all new page field labels use right label
alignment (design time), set the Right Align Field Labels check box on the PeopleTools Options page.

406
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Note: Push buttons with images or text are automatically center aligned when in a grid. Push buttons with
images or text are automatically left aligned when not in a grid.

Position

These position options are available for edit boxes, long edit boxes, and drop-down list boxes only.

Field or Control Description

Left Positions label immediately adjacent to the left side of the
field. Left is the default position of the label for fields newly
added to the page. If you move the label on the page from the
left position, PeopleSoft Application Designer changes the

selection to Custom.

Top Positions label above the field. Selecting this option
automatically moves the label to the top of the field. If
you later move the label on the page from the top position,
PeopleSoft Application Designer changes the selection to
Custom.

Custom Indicates that the label was manually moved on the page.
Labels can be adjusted using the keyboard arrows. Selecting

this option does not automatically move the label on the page.

See Positioning Page Control Labels.

To set labels to the left position for individual page fields:
1. Select the control that you want to affect.
2. Select Layout > Left Label Position.

The Left Label Position option is only enabled if the label is set to the custom position. The system
moves the label for the selected control to the left position. The position indicator in the page field
properties does not change from Custom. Note that you may need to readjust the positioning of other
fields and labels to accommodate this change.

Note: If you move a page field label manually on the page, the label position in the page field properties
dialog box automatically updates to Custom.

Display Options

Field or Control Description

First occurs only Select to display the label only with the first occurrence of a
child page field in a scroll area.
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Field or Control Description

No colon Select this option if you do not want a colon to appear at the
end of the label text. This option is selected by default for edit
boxes and long edit boxes.

Special Label Considerations

If you add a related display page control with a label type of None, enter an information-only label that
identifies the related field but that is not identical to the label on the control field. A little documentation
now can save you time in the future if you modify this page again. For example:

Control Label Related Field Label (Information-Only)

Department Department Description

Jobcode Jobcode Description

Regular/Temporary Regular/Temporary XLAT (XLAT is from the Translate Table)

When defining labels for columnar controls in a multi-occurrence scroll, you can apply several
techniques. The first technique is to select First occurs only. This selection limits the appearance of the
label to the first scroll occurrence on the control, allowing the label to be used as a column heading. The
second technique is to select No colon to omit the colon from the label (column headings typically do not
need a colon).

Setting Use Properties

408

The Use tab defines how a field functions on a page. Use this tab to disable or hide fields; to define the
display and related control fields and the processing of the control; and to define a field as a mouse over
pop-up field.

Access the page field properties for the page control and select the Use tab.

Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 10

Creating Page Definitions

This example illustrates the fields and controls on the Edit Box Properties dialog box: Use tab. You can

find definitions for the fields and controls later on this page.

Edit Box Properties

eneral | Fluid

Labar | Use

Field U=e Options

[ Digplay Oy [ ] Multi-Currency Field
[ Irrvisible [ ] Display Contral Field
Shaw Label [ | Related Field
todifiable by
JavaScript Perzizt Grid Columr it b enu
Enable \When Page iz
Dizplay Only

Generate in HTRL

Related Contral Field:

Popup Menu

| v

Allaw Deferred Processing
Set Component Changed
Dizplay-Only Appearance
(®) Text Only () Dizabled Edit Contral

[ | Paragraph
[ ]'wrap Long Words

kouze Over Popup
Mo Popup
Fage Popup
b ezzage Catalog Popup

1] 1]

ok

Cancel

Note: These controls contain the same or similar use properties: edit boxes, drop-down list boxes, check

boxes, images, long edit boxes, push button/hyperlinks, and radio buttons.

Field Use and Other Options

Note that long edit boxes have slightly different field use options.
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Field or Control

Description

Display Only

Select to prevent users from modifying the content of

the control during application data entry. The system
automatically selects Display Only when you select Related
Field.

Invisible

Select to make the control physically present on a page but
invisible to users. Typically, you add an invisible control
because it is required for a PeopleCode program that is
associated with the page. An invisible control can also be used

as a display control field.

When you select the Invisible check box, the Show Label,
Modifiable by JavaScript, and Enable When Page is
Display Only fields are enabled.

Show Label

Select to make the control label visible while the control
itself is invisible. This option is useful if you add an invisible
display control field to a page to show its related description.
Show Label is enabled only if Invisible is selected.

Important! The Show Label option is not supported for page

controls on fluid pages.

Modifiable by JavaScript

This feature is security related and should always be
deselected unless you are familiar with modifying an invisible
field using JavaScript in an HTML area. If the Invisible

check box is deselected, then Modifiable by JavaScript is
deselected and unavailable for entry. If the Invisible check box
is selected, then the Modifiable by JavaScript check box is
deselected by default.

Enable When Page is Display Only

Select to enable hyperlink actions on read-only pages. This
check box is active when the Invisible check box is selected.
This check box is deselected by default.

Note: This property appears on Edit box, Long Edit box, and
Image controls.

410
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Field or Control

Description

Generate in HTML

Select to generate an invisible field (hidden field) on the
HTML page sent to the browser where it can be manipulated
by JavaScript in the browser.

Only use this option if you are familiar with modifying an
invisible field using JavaScript due to potential security

concerns.

This check box is active only when the Invisible check box is
selected. This check box is deselected by default.

If you want the application server to update the invisible field
with data sent back from the browser, in addition to having
the Generate in HTML check box selected, also make sure to
select the Modifiable by JavaScript check box.

This option is available for edit boxes, long edit boxes, check
boxes, radio buttons, and drop-down list boxes (only list boxes
with a single value for selection).

Expand Field when Page is Display Only

Select to automatically resize a disabled (display-only) long
edit box so that all text within the field is visible at runtime.
The field automatically enlarges to accommodate text. This
check box is deselected by default. When selected, this option
enables the Wrap Long Words option.

Multi-Currency Field

Select to identify the control as associated with multi-currency
processing. This selection causes the field to appear at runtime
only if Multi-Currency is selected on the PeopleTools
Options page.

Display Control Field

Select to indicate that the field controls another field at the
same page level. The controlled field is a related field. For
example, on many pages Department ID is the display control
field and Department Name is the related field. The system
uses Department ID to retrieve Department Name from the

Department table to display on the page.
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Field or Control

Description

Related Field

Select to specify that the content of this control is controlled
by another field on the same page level, one that you selected
as a display control field. When you select this check box, the
system automatically selects the Display Only option. It also
makes the Related Control Field drop-down list box available
for you to select the related control field.

When you select Related Field, Display Only is
automatically selected. If the related field is located on a
record definition with multiple keys, relate the display field to
the lowest order key field that both record definitions have in
common, with the exception of EFFDT and EFFSEQ, in the
control record definition. The system searches for the higher
order keys by matching field control names on the current
level and all higher levels for the other keys.

If the related display field contains a long name or short name
from the Translate Table, use PSXLATDEFN as the record

definition name.

Enable When Page is Display Only

Select this check box to enable the user to select radio buttons
and check boxes on runtime pages to perform certain tasks and
processes despite the entire page being in display-only mode.

Note: This property appears on Check Box and Radio Button

controls only.
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Field or Control

Description

Paragraph

The Paragraph property applies only to these page field
controls:

»  Static Text
» Edit Box
* Long Edit Box

If Paragraph is selected, PeopleTools generates a text field

for the supported controls and inserts the page field content
within a paragraph tag (<p>), rather than a span tag (<span>
).Content within a paragraph tag is easier to access with screen
reading devices.

The Paragraph property applies to classic and fluid
applications. For classic pages, PeopleTools generates a
paragraph tag if the Paragraph property is selected or the

controls have one of the following styles applied:

PAPAGEINSTRUCTIONS

+  PAADDITIONALINSTRUCTIONS

+ PAADDITIONALINSTRUCTDISABLED
+ PAADDITIONALINSTRUCTACTIVE

*  PAERRORTEXT

»  PSTEXT

PeopleTools suppresses any label generation for the paragraph

fields; field values are generated, but field labels are omitted.

PeopleTools ignores the Paragraph property in these
conditions:

*  Rich Text Editor is enabled.
*  The field is not set as display only.

*  The field is disabled using PeopleCode. When using
PeopleCode, PeopleTools ignores the Paragraph property
if the Disabled property is set instead of the DisplayOnly

property.

* Inthe case of long edit boxes, the Paragraph tag can be
selected in Application Designer only if the Expand Field
When Display Only property is also selected.
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Field or Control

Description

Wrap Long Words

Select to wrap long words that do not contain spaces, such as
long URLs, in a page field at runtime for Microsoft Internet
Explorer only. The word wraps to the length of the field set at
design time. Other browsers automatically stretch the width
of the page to accommodate the longer text. This option has
no effect at runtime to applications running on browsers other
than Microsoft Internet Explorer. This setting is deselected by
default.

The Wrap Long Words option is available for edit boxes,
long edit boxes, and drop-down list boxes only. You can apply
it to standalone page fields and grid columns. For edit boxes
and drop-down list boxes, this option is disabled if Disabled
Edit Control is selected. For long edit boxes, this option

is available only if the Expand Field When Display Only
option under Field Use Options is selected.

Note: The system does not restrict an edit box or drop-down
list box that is configured as Display Only and Text Only

to one line of height. The text is wrapped to the next line as
necessary.

Also, the Wrap Long Words property does not affect

the word wrapping behavior of shorter words that can be
accommodated by the page field size at runtime. This text
automatically wraps at word boundaries in accordance with the

page field size, regardless of whether this option is set.

Persist Grid Column in Menu

Important! Persistent search, the drop-down menu, and other
forms of classic navigation are no longer supported. The
default navigational interface for PeopleSoft applications in
the current release is based on the fluid banner, which can be
used for both classic and fluid applications.

Select to include the field as a list box item in the persistent
search results grid. You must also select the Persist in Menu
grid property for the grid that contains the field.

Note: This property applies only to fields that appear in grids

on pages that are used as custom, application-specific search

pages.

This property is disabled on check boxes and radio buttons.

You must enable recent search results caching at the system
level in the web profile for this property to take effect.
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Field or Control Description

Related Control Field When you select Related Field, a list of all controls on the
page that are marked as display control fields appears in this
drop-down list box. Select the field to which this control is
related. You must define the use of the initial control field
before it appears as an option in the Related Control Field
drop-down list box. For example, after the Pay Group field is
designated as a display control field, it appears in the Related
Control Field drop-down list box for the control that you set
as the related field.

Note: The number that appears before each entry in the
Related Control Field drop-down list box is the page field
order number associated with that entry.

Set Component Changed Enables the system to issue a save warning for the field if

the user changes the value and attempts to exit the page
before saving. This setting reinforces current save warning
behavior. This option is set by default for edit boxes, long
edit boxes, radio buttons, check boxes, and drop-down list
boxes. Deselecting this option overrides the save warning
that normally appears to users. The user will not see a save
warning after changing the value of the field and attempting
to exit the page. An example of when this might be necessary
is for a drop-down list box that includes links to another page.
If the user selects a link from this field to transfer to another
page but has not made any other changes to the page, then the
system should not issue a save warning.

By deselecting the Set Component Changed flag, you indicate
that no save warning message is issued for this field. This
option works for fields associated with a derived work field or
database record field.

For the push button/hyperlink control, the default setting is

deselected instead of selected, unlike most other page controls.
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Allow Deferred Processing Deselect this option to allow this field to operate in interactive
mode. Typically, set a field to interactive only if you want

to perform a server trip for an action that can be deferred
otherwise—for example, to execute FieldEdit or FieldChange
PeopleCode, when data is entered in a field with a prompt
table edit, or in a field with a related display.

The setting of this field is ignored if either the page or
the component is set to run in interactive mode. See

Understanding Processing Modes for more information.

Note: The default setting is selected.

Display-Only Appearance Option

The Display-Only Appearance option attributes, Text Only option, and Disabled Edit Control option
apply only to edit boxes and drop-down list boxes. These properties, in conjunction with other attributes
you apply to the field, such as Display Only on the Use tab, or the Gray function or the Enabled property
in PeopleCode to disable the field, and whether or not the field is in a grid control the base style that the
system uses to render these controls at runtime.

The default base style for a normal edit box, meaning editable and enabled (as opposed to display-only
or disabled), is PSEDITBOX. The default base style for drop-down list boxes is PSDROPDOWNLIST.
The base style then changes depending on the attributes that you select and where you place your field, as
shown by the default base style examples in the following table.

If you choose a custom base style for the field on the Record tab of the control properties, then the
system uses the associated display-only and disabled variants of the style as appropriate to create the
additional looks. For example, if you select XYZ base style and set the field as display-only, then the
related XYZ DISPONLY style is used if it exists; otherwise, the base XYZ style is used.

Display-Only Appearance | Normal Edit Field Display-Only Edit Field Disabled Edit Field
Option
Text Only Non-Grid: PSEDITBOX Non-Grid: PSEDITBOX Non-Grid: PSDISABLED
DISPONLY
Grid: PSEDITBOX Grid: PSEDITBOX
Grid: PSEDITBOX DISPONLY
DISPONLY
Disabled Edit Control Non-Grid: PSEDITBOX Non-Grid: PSDISABLED Non-Grid: PSDISABLED
Grid: PSEDITBOX Grid: PSDISABLED Grid: PSDISABLED

Note that for Text Only disabled edit boxes using the default PSEDITBOX base style, the system applies
PSDISABLED to non-grid fields and PSEDITBOX DISPONLY to fields in a grid. As a result, these
fields render differently at runtime, as shown in the following example. If the field is outside of a grid, for
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example, selecting the Display Only field use option with the Text Only appearance option displays the
field value as disabled text within a grayed border, whereas if the field is located in a grid with the same
attributes, the field value renders as display only text without a border.

This example illustrates the fields and controls on the Example of Display-Only Appearance settings at
runtime using the base PSEDITBOX style. You can find definitions for the ficlds and controls later on this

page.
Normal Edit: Display Only Edit: Disaled Edit:
Appearance = Text Only |N|:|rmal display anly
MNormal Edit: Display Only Edit: Disalled Edit:

Appearance = Disabled Edit |N|:|rmal

Appearance = Text Dnl1u|' Find | Yiew Al | B8 First (4 1 .:|f 1 III| Last |
Maormal display only disabled ll ;l
Appearance = Disabled Edit Fimd | “ieswe Al |E First [4] »i of 1 |I|| Last |
|N|:|rrnal ll ;I

See Default Style Classes.

Note: Depending on the style sheet that your application uses, the appearance of your pages and fields
might deviate slightly from the appearance of the page and fields in the previous example.

Mouse Over Popup Options

Select the Display Only check box to enable the Mouse Over Popup options. Select from these mouse
over pop-up options:

Field or Control Description

No Popup Select to have no pop-up page. This value is the default.

Page Popup Select to associate the edit box with a pop-up page that you
choose from the drop-down list box. Only pop-up pages
appear in the Page Popup drop-down list box.
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Field or Control

Description

Message Catalog Popup

Select to associate this edit box with a pop-up page that
displays a message from the message catalog. You can design
and implement message catalog pop-up pages to be context

sensitive.

See Enabling Message Catalog Pop-up Pages.

See “Message Catalog” (System and Server Administration).

Message Set/Number

Enter the message set number and the message number of the
message whose text you want to appear in the pop-up window.

Text

This field displays the message of the message catalog entry
that you enter in the message set/number fields.

Note: If you associate a mouse-over pop-up page to an edit box, then do not attempt to make the edit box
editable at runtime, for example by using PeopleCode; the operation will fail.

Setting General Properties

The General tab enables you to specify an optional internal page field name that is referenced by the page.

Access the page field properties for the control and select the General tab.

418

Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 10 Creating Page Definitions

This example illustrates the fields and controls on the Edit Box Properties dialog box: General tab. You
can find definitions for the fields and controls later on this page.

Edit Box Properties E3 I

‘Record | Label | Use  General | Fluid |

Page Field Mame:
i

[~ Enable as Page Anchar

(1] 4 I Cancel

Note: For most controls, the General tab contains only the Page Field Name and Enable as Page
Anchor settings. Grids and scroll areas have additional settings on the General tab that are described later.
The Enable as Page Anchor check box is available for all controls that have a page field name.
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Field or Control

Description

Page Field Name

Enter a name for the page field that you are creating. This is a
system-only setting. It does not appear as the label for the page
field. The page field name enables you to refer to a particular
field on a page using PeopleCode.

This setting is optional unless you select the Enable as Page
Anchor check box.

Enable as Page Anchor

Select to apply an anchor tag to the current page field on the
page. If you select this check box, you must add a page field
name to identify this field when setting the related control for
the link. This check box is deselected by default.

See Specifying Type Properties for Push Buttons or Links.

The Options tab enables you to add rich text editing capabilities to the long edit box.

Note: This section applies to long edit boxes only.

Access the page field properties for the long edit box page control and select the Options tab.
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This example illustrates the fields and controls on the Long Edit Box Properties dialog box: Options tab.
You can find definitions for the fields and controls later on this page.

r

Long Edit Box Properties

Record || Label | Usze General| ':'l:'ti':'r‘l$|

Rich Text Ophions
Enable Rich Text

Configuration Settings |d: |

Image Location URL 1d: | PT_RTE_IMG_DB_LOC

Plugin File | |

Template File [d: |

Style File 12k |

| ok

] [ Cancel

Note: On a page with multiple rich text editor-enabled fields, if a custom configuration file is configured
for one or more such enabled fields, then the custom configuration that is loaded last will be applied to

all rich text editor-enabled fields on the page. Similarly, if a custom plug-in file is configured for one or
more such enabled fields, then the custom plug-in file associated with the custom configuration file that is
loaded last will be applied to all rich text editor-enabled fields on the page.

Field or Control

Description

Enable Rich Text

Select to enable rich text editor functionality for the long edit
box. Selecting this check box enables the remaining fields on
this tab.

Note: When you select this option the Multi-Currency and
Wrap Long Words properties on the Use tab are disabled;
and the Allow Deferred Processing property on the Use tab is
selected and disabled.

Note: At design time, standard long edit boxes and rich text-
enabled long edit boxes look the same.
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Field or Control

Description

Configuration Settings Id

Select a value to use a custom configuration file that modifies
the editor toolbar. By default, this field is blank and the system
uses the default configuration file with the default toolbar
settings.

HTML definitions that are prefixed with PT RTE CFG appear
in this drop-down list box.

See Modifying the Rich Text Editor User Interface.

Image Location URL Id

Select a value to indicate the storage location of any images
inserted as part of the text in the long edit box. The default
value for this field is the PT_RTE IMG_DB_LOC URL.

URL IDs that are prefixed with PT RTE IMG appear in
this drop-down list box. The URLs must be stored in the
application by using the URL Maintenance page.

See “URL Maintenance” (System and Server Administration).

Note: The URL format for file attachments stored in the
database is record://RECORD _NAME—for example, record://
PTRTDB.

Plugin File Id

Important! The CKEditor v4 API differs from the CKEditor
v5 API, which will become the supported version in a future
PeopleTools 8.60 patch. Therefore, you are encouraged to
research the differences between these APIs as soon as feasible
so that you can update and test any custom plug-ins that
you’ve created.

Select a value to enable plug-ins for this instance of the rich
text editor. By default, this field is blank.

HTML definitions that are prefixed with PT RTE _PLUGIN
appear in this drop-down list box.

See Creating Custom CKEditor Plug-ins for more information.

Template File Id

Important! The use of custom template files is deprecated
with CKEditor v5 in PeopleTools 8.59.16 and later versions.
Therefore, you are encouraged to discontinue your use of
custom template files as soon as feasible.

Select a value to enable an alternative template definition for
this instance of the rich text editor. By default, this field is
blank.

HTML definitions that are prefixed with PT RTE TMPL
appear in this drop-down list box.
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Field or Control Description

Style File 1d Important! The use of custom style files is deprecated with

CKEditor v5 in PeopleTools 8.59.16 and later versions.
Therefore, you are encouraged to discontinue your use of
custom style files as soon as feasible.

Select a value to enable an alternative style sheet definition
for this instance of the rich text editor. By default, this field is
blank.

HTML definitions that are prefixed with PT RTE STYLE
appear this drop-down list box.

Data Conversion Considerations

The rich text editor is an HTML editor that converts rich text to HTML, which the application stores in
the database. When you access your data, the editor decodes the HTML at the time that it appears on
the transaction page. Existing data is stored as plain text, which can cause unexpected warnings the first
time the data is accessed after rich text support is enabled on a long edit box page field. Your test plan
should include either updating the data to prevent the warnings or communicating with users to expect
this warning.

To update the data, you must access the page; change the data in some way, such as adding a Space; and
then save the component. The editor automatically encodes and updates the data.

Modifying the Rich Text Editor User Interface

The rich text editor extends the capabilities of a long edit box to display rich text or editable rich text at
runtime. PeopleTools 8.59.16 and later versions support CKEditor v5.

The CKEditor topics are separated based on the PeopleTools release and the supported CKEditor version:

» Users on PeopleTools 8.59.16 or later should refer to the CKEditor v5 for PeopleTools 8.59.16 and
Later topic.

» Users on PeopleTools 8.59.15 or earlier should refer to the CKEditor v4 for PeopleTools 8.59.15 and
Earlier topic.

Related Links
“Working With Rich Text Editor Fields” (Applications User’s Guide)

CKEditor v5 for PeopleTools 8.59.16 and Later

The following topics describe the user interface of CKEditor v5 and its use.

Copyright © 1988, 2023, Oracle and/or its affiliates. 423



Creating Page Definitions Chapter 10

424

This example illustrates an editable rich text-enabled long edit box at runtime.

[Q ®¥n Paragraph v Av Alv AvAvy B I U

S - —@Bvy@ 2 Qv Qv E = =

The rich text editor enables you to add rich formatting of text content, including common structural
treatments such as lists; formatting treatments such as bold, underline, and italic text; drag-and-drop
inclusion; paste-as-text; and sizing of images. The rich text editor toolbar is extensible through the use of
HTML definitions that define your configuration, which enables you to design and implement an interface
that is specific to the needs of your users.

Important! Use caution when modifying the rich text editor interface; it is recommended that you never
include or enable the Source button in the toolbar.

Securing CKEditor Files

By default, CKEditor files can be accessed without authentication on the web server. Oracle recommends
that after your PeopleSoft Internet Architecture installation, you make sure to secure any files or folders
at the web server level as needed. To secure CKEditor files, security has to be setup at web server level.
How you configure this security varies according to your web server product.

For information on implementing security on Oracle WebLogic see “Securing Servlets on WebLogic”
(System and Server Administration).

Creating Custom Configurations

CKEditor v5 does not provide a default configuration file. If you want to create a custom configuration
file, you may copy the PeopleTools delivered configuration file for CKEditor v5.

To create a custom configuration:

1. In Application Designer, search for the PeopleTools delivered configuration file (PT RTE CFG), and
copy the code in the configuration file.

2. Create a new HTML definition.

3. Paste the code into the HTML definition.
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4. Save the HTML definition. Prefix the definition name with PT RTE CFG for example,
PT RTE CFG_MYCONFIG.

Note: Only HTML definitions with the PT” RTE CFG prefix appear in the Configuration Settings Id
drop-down list box.

5. Modify the code in the HTML definition as necessary and save. The code might look like this

example:

const cketoolbarconfig = |

1

'heading’',
'findAndReplace’',
'italic',

Iy,

'link',
'numberedList’',

Iy,

'indent',

'outdent',
'alignment:left',
'alignment:right',
'alignment:center',
'alignment:justify',
l‘l,

'InsertImage’,
'blockQuote’,
'insertTable',
'undo',

'redo',
'SpecialCharacters’',
'fontSize',
'fontFamily',
'fontColor',
'fontBackgroundColor'

6. To use the new configuration, open the Long Edit Box Page Field Properties dialog box; select the
Options tab; click the Configuration Settings Id drop-down list box; and then select the HTML

definition name from the list of values that appear.

See Setting Options Properties.

Creating Custom Plug-In Files

A plug-in enables you to create an application-specific toolbar button.

See CKEditor v5 API Documentation.

Modifying the Default Image Storage Location

By default, when you upload images the system stores them in the PTRTDB table. The default URL ID is
PT RTE IMG DB_LOC. To create a different storage location and URL ID, follow these steps:

1. Create a new record definition.

2. Insertthe FILE ATTDET SBR subrecord.

3. Save and then build the record definition.

4. Clone these record definitions:

Copyright © 1988, 2023, Oracle and/or its affiliates.

425


https://ckeditor.com/docs/ckeditor5/latest/api/index.html

Creating Page Definitions Chapter 10

« PTRTDB BMP
+ PTRTDB _GIF
+ PTRTDB JPG
5. Save the record definitions, name them like this: <myrecord> BMP, <myrecord> GIF, and
<myrecord> JPG.

6. For each record, open the SQL Editor and change the FROM statement in the SQL to this:

FROM PS <your record name from step 3>

7. Save and build each view.

Note: FTP storage is not supported.

Note: It often will require end users to refresh a page or access it twice in order to display an image in
a rich text editor field after the following events: browser cache has been cleared, web server cache has
been cleared, the posting using the rich text editor field (such as a job posting) is new.

CKEditor v4 for PeopleTools 8.59.15 and Earlier
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The following topics describe the user interface of CKEditor v4 and its use.

This example illustrates an editable rich text-enabled long edit box at runtime.

Details @ & & B & HE EO0E&88 O €
Faormat ~ | Fant ™| Size B I U =k
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The rich text editor enables you to add rich formatting of text content, including common structural
treatments such as lists; formatting treatments such as bold, underline, and italic text; drag-and-drop
inclusion; paste-as-text; and sizing of images. The rich text editor toolbar is extensible through the use of
HTML definitions that define your configuration, which enables you to design and implement an interface
that is specific to the needs of your users.

Important! Use caution when modifying the rich text editor interface; it is recommended that you never
include or enable the Source button in the toolbar.
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Securing CKEditor Files

By default, CKEditor files can be accessed without authentication on the web server. Oracle recommends
that after your PeopleSoft Internet Architecture installation, you make sure to secure any files or folders
at the web server level as needed. To secure CKEditor files, security has to be setup at web server level.
How you configure this security varies according to your web server product.

For information on implementing security on Oracle WebLogic see “Securing Servlets on WebLogic”
(System and Server Administration)

Creating Custom Configurations

The default configuration filename is config.js. You can locate this file in the PI4_HOME\webserv
\domainname\applications\peoplesoft\PORTAL.war\sitename\ckeditor directory.

To create a custom configuration:

1. Copy the code in the config.js file.

2. Open Application Designer and create a new HTML definition.
3. Paste the code into the HTML definition.

4. Save the HTML definition. Prefix the definition name with PT RTE CFG for example,
PT RTE CFG_MYCONFIG.

Note: Only HTML definitions with the PT_RTE CFG prefix appear in the Configuration Settings Id
drop-down list box.

5. Modify the code in the HTML definition as necessary and save. The code might look like this
example:

CKEDITOR.editorConfig = function( config )
{

config.toolbar =
[ ['Templates', 'Styles', 'Cut', 'Copy', 'Paste', 'Bold', 'Italic', 'Underline"', 'Strik=
e'l,
17
bi

6. To use the new configuration, open the Long Edit Box Page Field Properties dialog box; select the
Options tab; click the Configuration Settings Id drop-down list box; and then select the HTML
definition name from the list of values that appear.

See Setting Options Properties.

Creating Custom Template Files

Important! The use of custom template files is deprecated with CKEditor v5 in PeopleTools 8.59.16 and
8.60.04 patches. Therefore, you are encouraged to discontinue your use of custom template files as soon
as feasible.
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The rich text editor delivers templates that help you format the text in predetermined ways. The default
template file is default.js. You can locate this file in the PS_ HOME\webserv\domainname\applications
\peoplesoft\PORTAL.war\sitename\ckeditor\plug-ins\templates\templates folder.

To create a custom template file:

1. In Application Designer, create an HTML definition and save it as PT_ RTE_ TMPL_TEMPLATE.
The definition name should always be prefixed with PT RTE TMPL, and the HTML must include
'pt_rte template' as you see in this example:

CKEDITOR.addTemplates ('pt rte template', {imagesPath:CKEDITOR.getUrl (CKEDITOR.p=
lug-ins.getPath ('templates')+'templates/images/'), templates: [{title:'Image and=
Title',image: 'templatel.gif',description:'One main image with a title and tex=>

t, which surrounds the image.', html:'
<h3><img style="margin-right: 10px" height="100" alt="" width="100" align="lef=

t"/>Type the title here</h3>
<p>Type the text here</p>'}1});

Note: The name 'pt_rte_template' is the fixed name, which has to be set for any custom template that
you create. The template name should be exactly the same as mentioned above.

Save the HTML definition.

Note: It is recommended that if you create a custom template file, that you create a custom
configuration file for it to reference.

2. To use the new configuration, open the Long Edit Box Page Field Properties dialog box; select the
Options tab; click the Template File Iddrop-down list box; and then select the HTML definition
name from the list of values that appear.

See Setting Options Properties.

3. Click the OK button.

4. Save the page definition.

Note: When associated to a long edit box, all templates in an HTML definition are available to all users.
To limit the available templates for specific rich text enabled long edit boxes, create a new template
HTML definition to contain only the templates that you would like for the application user to see and
associate that definition to the field.

Creating Custom Style Files

Important! The use of custom style files is deprecated with CKEditor v5 in PeopleTools 8.59.16 and
8.60.04 patches. Therefore, you are encouraged to discontinue your use of custom style files as soon as
feasible.

The rich text editor delivers styles to assist you in entering data using specific styles that combine color,
font and format. The default configuration file is default.js and is in the PIA._ HOME/webserv/.../styles
folder.

To create a custom style file
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3.

4.

Creating Page Definitions

In Application Designer, create an HTML definition and save it as PT_ RTE STYLE MYSTYLE.
The HTML Object name used for defining styles should always be prefixed by PT RTE STYLE.

This is sample code for an HTML style definition:

CKEDITOR.stylesSet.add( 'pt rte style', [{name:'Blue
Title',element:'h3',styles:{color:'Blue'}}]);

Note: In this style example, the name "pt_rte_style' is the fixed name, which has to be set for any
custom style that you create. The style name should be exactly the same as mentioned above.

To use the new configuration, open the Long Edit Box Page Field Properties dialog box; select the
Options tab; click the Style File Iddrop-down list box; and then select the HTML definition name
from the list of values that appear.

See Setting Options Properties.

Click the OK button.

Save the page definition.

Note: When associated to a long edit box, all styles in an HTML definition are available to all users.

To limit the available styles for specific rich text enabled long edit boxes, create a new style HTML
definition to contain only the styles that you would like for the application user to see and associate that
definition to the field.

Creating Custom Plug-In Files

A plug-in enables you to create an application-specific toolbar button.

See CKEditor v4 API Documentation.

Modifying the Default Image Storage Location

By default, when you upload images the system stores them in the PTRTDB table. The default URL ID is
PT RTE IMG_DB LOC. To create a different storage location and URL ID, follow these steps:

1.

2.

Create a new record definition.

Insert the FILE ATTDET SBR subrecord.
Save and then build the record definition.
Clone these record definitions:

« PTRTDB BMP

 PTRTDB_GIF

 PTRTDB_JPG

Save the record definitions, name them like this: <myrecord> BMP, <myrecord> GIF, and
<myrecord> JPG.
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6. For each record, open the SQL Editor and change the FROM statement in the SQL to this:
FROM PS <your record name from step 3>

7. Save and build each view.

Note: FTP storage is not supported.

Note: It often will require end users to refresh a page or access it twice in order to display an image in
a rich text editor field after the following events: browser cache has been cleared, web server cache has
been cleared, the posting using the rich text editor field (such as a job posting) is new.

CKEditor Features Deprecated in PeopleTools 8.59.16 and 8.60.04 Patches

PeopleTools 8.59.16 currently supports CKEditor v5, which does not support certain features available in
CKEditor v4. You can no longer use the CKEditor v4 features listed in the following table.

Important! To stay current with the latest information on deprecated features, subscribe to the following
technical bulletin on My Oracle Support: Data Compatibility with Updated Rich Text Editor Technology
in PeopleTools (Doc ID 2945233.1)

The following CKEditor v4 features are deprecated. Features identified as plug-ins are rendered as button
in the rich text editor toolbar.

Feature Description

Anchor plug-in This plug-in provides the capability to insert anchors with some properties; this is part of
the Links plug-in.

Button (form control) plug-in This plug-in adds a button form control element in the editor content.

Check box (form control) plug-in This plug-in adds a check box form control element in the editor content.

Custom style files The use of custom style files with Application Designer is deprecated with CKEditor v5.

Custom template files The use of custom template files with Application Designer is deprecated with CKEditor
V5.

Elements Path plug-in This plug-in displays a list of HTML element names in the current cursor position. By

default, the list appears at the bottom of the editor interface and can give you contextual
information about the content that you are creating.

Insert Smiley plug-in This plug-in provides a set of emoticons to insert into the editor via a dialog window.
Maximize plug-in This plug-in adds a toolbar button maximizing the editor inside a browser window.
New Page plug-in This plug-in adds a toolbar button that clears the editing area and creates a new page.
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Feature Description

Radio button (form control) plug-in | This plug-in adds a radio button form control element in the editor content.

Selection field (form control)plug-in | This plug-in adds a selection field (a drop-down) form control element in the editor
content.

Show Blocks plug-in This plug-in adds the command to visualize all block-level elements by surrounding
them with an outline and displaying their element name at the top left.

Text area (form control) plug-in This plug-in adds a text area (a long edit box) form control element in the editor content.

Text field (form control) plug-in This plug-in adds a text field (an edit box) form control element in the editor content.

Related Links
CKEditor v5 API Documentation

Creating Display Control and Related Fields

This section discusses how to:
» Use display control and related fields.
¢ Create related edit fields.

¢ Create invisible control fields.

Using Display Control and Related Fields

A related display field is for display purposes only—it always references a row that’s not being updated
from the current page. The display control and related display fields must both be at the same level. In the
Work Location page, the Regulatory Region, Company, Business Unit, Department, and Location fields
all show related display fields to their right. Search level fields, such as those shown above the Work
Location group box, are display-only fields.
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This example illustrates the fields and controls on the Work Location page. You can find definitions for
the fields and controls later on this page.

Job Information Job Labor Payrall Salary Plan Compensation
Caroline SABBARICH Empl 1D: GF100MEZ80
Employes Empl Record: 0
Kl 12
*Effective Date: 0140142000 5 GoToRow | [+][=]
Effective Sequence: 0 *Action: IH”E =l
HR Status: Active Reason: I ﬂ
Payroll Status: Active *Job Indicator: |Primar:.-'J-:|h ﬂ
Current m
OJ

Position Number:

Override.Rosition Bata

Position Entry Date: Eﬂ

™ Position Management Record
“Regulatory Region: FRA Q France
Company: GF2 Societe Francaise production
*Business Unit: GFOO1 @ French Business Unit Q4
*Department; GFDEVD2 @ Department Developt QADZPP
Department Entry Date: 01/01/2000 Eﬂ
*Location: GFPARISO @ PARIS 04

Because of the nature of control fields and related fields, PeopleSoft recommends that you:
* Place them side-by-side on a page to indicate their relationship.

* Provide adequate space between the fields.

* Do not overlap them; otherwise, they appear skewed when viewed through the browser.
* Change the label type for the related field to None so that it doesn't appear on the page.

* Enter a text description to document the purpose of the field.

Note: The display control and related fields must be in the correct order on the order page. The display
control field must be positioned before the associated related field; otherwise, a warning dialog box
appears when you save the page. Also, fetching the related field after the control field is entered requires a
transmission to the server at runtime.

Note: If you copy fields that have display control/related field associations configured from one page
to another, the mappings between the related field and the control field will be lost. After copying these
fields, you need to reset the control field/related field associations on the target page.

Creating Related Edit Fields
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Related edit fields are slightly different from related display fields. Related edits enable users to enter
descriptive values instead of code values and enable prompting on those descriptive values. Changing

the value in the control field updates the related edit field, and changing the value in the related edit field
updates the value in the control field. If appropriate, the control field can be display-only or even invisible
to hide code values from the user.
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At runtime, when a user edits a related edit field, it is treated as if the user changed the control field
directly. Edits, including any assigned PeopleCode, are run on the control field. PeopleCode is not run for
the related edit field.

The following partial screen shot is an example of a related edit field with a control field that is available
for entry. When entering company information, the data-entry clerk may not have all company codes
memorized, but instead knows just the name of the company. By entering the more descriptive company
name in the Description field, (the related edit field) the company code (display control field) is
automatically populated in the Company field.

If the user enters Payroll in the Description field and exits that field, the system searches for a match to
this value and populates the field if only one is found. The field reads Payroll Services Technology. If
more than one match is found, the field turns red, and an error message appears indicating that the user
must use the lookup page to view all related values. Alternatively, the user could enter more detailed
information in the field before clicking the prompt to further narrow the search.

The following partial screen shot is an example of a related edit field with a control field that is available
for an entry

*Description: |F'a~_.fr|:|ll Semvices Technology ﬂ Compamy: [FST

At design time, you set up a related edit field in the same way that you create a related display field,
except that you clear the Display Only check box in the Field Use Options group box so that the field is
active at runtime. The control field's prompt table is used. You do not need to define a prompt table for
the related edit field, just the control field. The related edit field must be a key or an alternate key in the
prompt table. PeopleSoft recommends that the related values in your prompt table be unique so that there
is a one-to-one mapping to the control values. This prevents the user from receiving a warning and having
to access the prompt page to select the proper value.

In some instances, you may not want the control field to be apparent to the user. PeopleSoft Global
Payroll, for example, relies heavily on PINs. While PINs are key values, and therefore very important

for tracking and storing information in the database, you may not want to distract the user with such a
number. However, you still want this data to be entered into the database with the transaction. Related edit
fields are particularly helpful in these situations. You can associate the PIN field with a descriptive field
and have only the descriptive, related edit field appear on your page. To do so, hide the control field using
PeopleCode.

Note: If the hidden control field that you select is a required field, PeopleSoft Pure Internet Architecture
changes the related edit field into a required field as well. At runtime, an asterisk appears next to the field
label, marking the field as required. If the user does not enter information in the related edit field, the
system displays an error message.

Related Links
“Hide” (PeopleCode Language Reference)
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Creating Invisible Control Fields

Your page design may require an invisible control field. For example, if users are interested only in the
contents of the related display field, then make the control field invisible. Unlike visible control fields,
you can overlap an invisible control field and its related display field.

Note: If you specify a field as invisible in PeopleSoft Application Designer, you cannot make it visible
using the Visible property in PeopleCode.

To add an invisible control field with a visible label:

1.

2.

9.

Access the properties dialog box for the invisible control for which you want the label to appear.
Select the Use tab.
Set the appropriate field use options:

a. Select Display Only, Invisible, and Show Label to make the field invisible and its label visible.

Important! The Show Label option is not supported for page controls on fluid pages.

b. Select Display Control Field.

Select OK.

Add an edit box to your page.

Place this edit box directly to the right of the display control field that you just set.
Access the properties dialog box for the new edit box.

Select the Use tab.

Select Related Field.

Select the appropriate control field from the Related Control Field drop-down list box.

10. Select OK.

Ordering and Spacing Page Controls
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This section provides an overview of page control order and spacing and discusses how to:

Order controls visually.
Order controls logically.
Test page control order.
Apply control order rules.

Change control order using the order list.
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* Find a field on a page definition.
*  Use default order.

*  Space controls on pages.

Understanding the Page Definition Order Tab

Page definitions include an Order tab. Here, the system populates a grid with the names and properties
of the page controls associated with the page definition. Properties, which appear as grid column
headings, include:

* Tab Order
* Field ID

* Level

* Label

* (Control) Type

+ Field

* Record

» Display Control

* Related Field

* Control Field

* Page Field Name

e Allowed Deferred Processing
»  Popup Help

You can use the Order tab as a diagnostic tool, which can save time in addressing issues your page might
have with page field processing order and page field tab order among other visual and logical page-
processing properties. All values on the Order tab are display-only. Some property values, such as record
and field names appear as text; other values, such as Popup Help appear as check boxes in which case, a
check indicates that the property is applicable to the page control.

Understanding Page Control Order and Spacing

The order of the page controls that are on your new page is important to both how your users interact with
the page and how the component processor interprets the underlying record and field relationships.

Two types of page control order are important on pages:

* The order in which you visually arrange controls on the page.
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* The logical processing order—governed by levels—that the system requires to correctly process the
page data.

As you add controls to a page, the system automatically builds a processing control order list that can
be viewed on the Order tab of the page definition. Usually, you don't want to preserve this order for
processing, so you can reorder your controls on the Order tab to indicate how the system should process
your page.

Ordering Controls Visually

Organize fields from top left to bottom right in a page. Include most important information at top. Use
group boxes to group related fields and indicate the hierarchy of information on a page. Guidelines for
grouping information include:

*+  Keys
Group all key fields at the top of a page (such as business unit, employee ID, and setID).
* Level 1-3

Controls at these levels must be enclosed by a scroll area or grid. At design time, these levels can be
stacked. At runtime, they appear nested.

Ordering Controls Logically
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Tab ordering through a page at runtime is strictly defined by page field ordering. When you add a control
to a page, PeopleSoft Application Designer automatically inserts it in the order list based on where you
position it on the page. You can manipulate the ordering of fields on your page by moving them up or
down on the Order tab in the page definition. In doing so, you also change the tab order that users follow
as they move through fields on the page.

In general, field tab order should flow from top left to bottom right on a page. The flow should reflect the
way that the eye naturally scans information. On a page with multiple scroll levels, the tab order should
follow the scroll level order, from Level 0 to Level 1, and so on.

On a page where the fields are not arranged in columns, the tab order should go from left to right on each
line from top to bottom as depicted in this figure:

Key: Key Value
Field 1 Fiald 2 | Field3 |
I

Field 4 [ A | Field 5 | .

Copyright © 1988, 2023, Oracle and/or its affiliates.



Chapter 10 Creating Page Definitions

On a page with columns, the tab order should go from the top to the bottom of the first column, then from
the top to the bottom of the second column, and so on.

Key: Key Value

Field 1 |:| Field 4
Field 2 L
A4

Figld 3

Field & }"
Field 7 L
Field 8

Fields that share the same label should follow consecutively in the tab order from left to right.

Testing Page Control Order

After you have placed all of the controls on your page, you should test the tab order. You can do this using
either the test mode or by viewing the page in the browser. Using the View Page in Browser mode is more
useful because you can also check the placement of controls and subfields that are on your page. In these
testing modes, you can enter data into edit boxes and select radio buttons and check boxes. However, you
cannot save data that you enter, and push buttons and links do not function.

Note: The tab order that you establish at design-time may not apply for all browsers.

See Troubleshooting Browser Limitations available on the My Oracle Support website.
To test tab flow using View Page in Browser mode:

1. Open the page in PeopleSoft Application Designer that you want to test.

2. Select Layout > View in Browser.

3. Select the appropriate browser from the drop-down list box.

4. Press the Tab key to move from one field to the next.

Press Shift+Tab to move to the previous field.

Applying Control Order Rules

If you’re working with a complex page or you’re new to order lists, you might print out a page definition
and work on the hard copy. The sequence number of each control is reflected in the Num column on the
page report. You can easily mark where you need to move a control to make your page function properly,
or you can look at the Lvl column on the Order tab of the page definition.

Use these rules to order your controls:
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Radio Buttons

For radio buttons to function in a single group, they must be associated with the same record field and
be listed together on the Order tab of the page definition. The only control that you can place between
related radio buttons is the static text control to extend radio button labels. Put the text immediately after
the radio button to which it relates.

Level-Based Controls

List level-based controls (scroll areas, grids, and scroll bars) immediately before the first control that they
govern, followed by the controls that are directly governed by that control. Level-based controls directly
govern all controls that are listed below them on the order list until they encounter another level-based
control that is at the same or lower level (higher occurs level number).

Display Controls

Place display controls before related displays that they govern. The related display controls don't have to
follow the display controls immediately, but they must be inside the same scroll area or scroll. However,
if you have more than one related display control, placing each immediately following its display control
makes the order page easier to read and understand.

Changing Control Order Using the Order Tab
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The Order tab of the page definition displays attributes about each of the page controls and their
processing order. The Field ID column represents the order in which the control was added to the

page. If you modify the order of page fields on the page, note that the numbers assigned to each field
remain constant. Thus the IDs might not always appear in sequential order. When a database compare is
performed, the Field ID appears on the Compare report to assist you in identifying specific page fields.

Reorder page fields on the Order tab by dragging them in the same view. Changing the order list doesn't
change the physical location of controls on the page. It changes only the logical order or tab order in
which controls are processed. When you have added and arranged all of your controls, you may want to
print your page definition to see how you might need to reorder your controls.

The Order tab also governs processing rules for scrolls and record or field relationships. Consider
which controls are associated with which scroll area or scroll bar and which secondary relationships are
important to page processing.

To change the order list:
1. Open the page.
2. Select the Order tab on the open page.
The Order view appears. Use this view to change the logical processing order of fields on your page.

3. To move a control to another position in the control order list, select the control that you want to
move.

Press the Shift key to select multiple controls.

4. Drag the selected control to the new position on the Order view.
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The system moves the control to the new location in the list. The ID value remains static. The visual
display of the page still looks the same—changing the order list doesn't move the control on the page,
only the logical processing order of the control.

Important! When viewing your page in “Test Mode,” page fields cannot be accessed, moved, or
modified from the Order tab if the page definition contains a sub page. Exit “Test Mode” to rearrange
page fields in the order list.

Finding a Field on a Page Definition

Use the Order view to locate a field on a page definition. Using this method of locating fields is useful
when you are working with detailed page definitions that contain many fields.

To find a field on a page:

1. Access the Order tab of your page definition.

2. Select the field that you want to locate on the page.
3. Select the Layout tab.

The field that you selected on the Order tab is selected in the Layout view.

Using Default Order

You can reorder the field list on the Order tab so that the logical control order reflects the physical control
order as shown on the Layout tab. Do so by selecting Layout > Default Page Field Ordering. You can
use this tool in either the Layout or Order view for your page definition. The system creates the default
order by reading the page as though it was on a pixel-by-pixel grid, from top to bottom and left to right.

Note: Use the default ordering option sparingly on existing pages. It may offset any previous order that
was created. However, on new pages, you may find default ordering a useful starting point for your
control order list.

Spacing Controls on Pages

Provide adequate space between controls on a page so that fields and their labels don't touch or overlap
other controls or labels in PeopleSoft Application Designer. If they do, then when your page appears in
the browser, the label is offset automatically and the overlapped control might shrink.

Overlapping Fields

You can layer or overlap fields only if the one that you are overlapping is set to /nvisible on the Use tab of
the properties dialog box for that control. When you move through the data entry controls on a page, the
component processor recognizes only visible, non-hidden fields as available for entry.

You can layer multiple invisible fields. However, you must set up your stacks of edit boxes so that all but
one field in the stack are invisible or hidden at RowlInit time.
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Designing Inquiry Pages

You can design pages for inquiry purposes only. Inquiry pages are usually based on search records that
extract specific information from different tables to display different views of your database, such as a
summary of expenses by department.

To create an effective inquiry page:
* Make all of the fields display-only.
* Build in sufficient display control and related field relationships to show relevant descriptions.

*  When using level-based controls, disable the row action buttons so that the user cannot add or delete
TOWS.

This example illustrates the fields and controls on the Workforce Job Summary inquiry page. You can find
definitions for the fields and controls later on this page.

Workforce Job Summary

Caroline SABBARICH EMP Empl ID: GF100ME280

General | B Work Location Salary Plan Compensation
Org Empl — Job Empl Empl Full/Part Standard - .
Relation Record SEETE R SR Code Type Status Time LEDTETTD Hours ST [PATEL
EMP 0/01/01/2000 0 GFJOO7  MotAppl. |Active Full-Time Regular 35.00 | Weekly

Aligning Page Controls and Page Control Labels
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When you are in page design mode, the Align and Align Label buttons on the page definition toolbar
enable you to align your page controls and their labels relative to each other, both horizontally and
vertically.

PeopleSoft Application Designer uses relative alignment; the /ast item that you select is the guide, or
anchor. All selected page controls or page control labels align relative to the anchor. The anchor does not
move when you select an alignment option.

You can align page controls and their labels together by using the Align buttons. Both the control and
its label move when you use this option. You can also align labels by themselves without moving the
associated controls by using the Align Label buttons. The Align and Align Label buttons are enabled
when you select two or more page controls or page control labels.

In addition to using the Align buttons, from the menu you can also select Layout, Align and then the
control or label alignment position.

Note: Align the page controls before you align their labels.

Aligning Page Controls

To align page controls:
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1. Select the controls that you want to align by pressing Ctrl and then clicking each page control.

Note: You can also select multiple page fields by clicking and dragging the cursor around the
controls. However, for relative alignment purposes, the Ctrl + click is the preferred method of
selection, because it enables you to explicitly set the anchor control.

2. Click the appropriate Align button in the toolbar: Align Left, Center, Right, Top, Middle, or Bottom.

When the page controls move, their labels move with them maintaining relative positioning to the
associated controls.

You can manually move page controls after relative alignment, though previous alignment is not
preserved.

Aligning Page Control Labels

To align page control labels:

1. Select the labels that you want to align by pressing Ctrl and then clicking each label or control.

2. Click the appropriate relative alignment button in the toolbar: Align Label Left, Center, or Right.
When the labels move, their controls remain stationary.
You can manually move labels after relative alignment, though previous alignment is not preserved.

Related Links

Selecting Controls

Maximizing Performance

Page definitions permit controlled access to application data. The system can validate the data, write it to
the database, and then retrieve and display it upon request. Behind the scenes, the component processor—
the PeopleTools runtime processor—builds SQL statements that are based on the actions that you perform
on pages. The component processor:

* Manages the flow of data processing as users enter information on pages.

e Issues INSERT, DELETE, and UPDATE statements to maintain data in the database and SELECT
statements to retrieve data.

As you design your pages, some features can adversely affect page performance. There's always a trade-
off between eliminating a useful feature and speeding up page processing. Guidelines for improving page
performance include:

* Be judicious about references to record definitions other than the primary record definition under each
scroll area.

References to other record definitions can include:

» Related display controls.
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* PeopleCode references (such as edits and defaults) to other records.
*  Defaults to fields on other record definitions.
* Field controls on derived or work records.
» Put the field control on the appropriate derived or work record, rather than on a regular data record
definition to derive its value.

For example, FTE (full-time equivalent) on the JOB record definition would be moved to the
DERIVED_ HR derived or work record because its value is derived by the system.

* Use as few record definitions as possible in a component.

When you open a page in a component, the system loads all record buffers from the entire component
into buffers.

* Do not remove table edits to improve performance, even though an edit against another table causes a
short pause.

Eliminating them may compromise data integrity.

* Frames, scroll areas, scroll bars, grids, and group boxes all create HTML tables, which, in some
browsers, might slightly degrade the performance of your system.

Be judicious about the number of these types of controls that you use on a page.
*  Apply deferred processing when possible to fields, pages, and components.

Related Links

Improving Online Performance
“Understanding the Component Processor” (PeopleCode Developer’s Guide)

Accessing PeopleCode in Page Definitions

Page fields are associated with a specific record field. You can access the PeopleCode for that record field
from the page field in the page definition. You might add PeopleCode to a field to achieve a variety of
tasks, ranging from real-time editing of fields to altering the appearance of fields on a page. You can also
associate PeopleCode with a component, component record, and component record field.
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This example illustrates the fields and controls on the Editing PeopleCode. You can find definitions for
the fields and controls later on this page.

!.'EURR_QUIIITE_TBL.RATE_TRIANGULATE.FieIdEhangE {Record PeopleCode)

| RATE_TRIANGULATE ([field) j IFieIdEhange j

beclare Function Setfuotelescription FeopleCode CURE_QUOTE_TEL.RATE _DIRECT FieldChange:; |4

If %Panel = Panel.CURE_QUOTE_FNL Then
Setluotelescriptioni)

End-If:

If CURE_QUOTE_TEL.RATE_TRIANGULATE = "Y¥" Then
InGray (CURE_QUOTE_TEL.FEF _CUE]):

Elze
GetDefault (CURR_QUOTE_TEL.REF_CUR) :
CURE,_QUOTE_TEL.XFATE OVERRIDE = "N":
Gray (CURR_QUOTE_TEL.REF CUR) :

End-If:

If CURR_QUOTE_TEL.RATE_TRIANGULATE = "V And

A11 (CURE._QUOTE_TEL.FEF _CUR) Then

CURR_QUOTE_WRK.FROM_TO LABEL = CURR_QUOTE_TEL.FROM CUR | " --» " |
CURE_QUOTE_TEL.TO_CUR:

CURR_QUOTE_WRE.FROM_REF_LABEL = CURR_QUOTE_TBL.FROM CUR | " --% |
CURE_QUOTE_TEL.REF_CUR:

CURFR_QUOTE_WRK.FEF_T0O_LABEL = CURR_QUOTE_TEL.EEF CUR | " --» " |

CURR_QUOTE_TEL.TO_CUR;
TG ay [CURE_QUOTE TEL.XRATE OVERRIDE) : | |
UnGray (CURR_QUOTE_TEL. FRIMARY VISUAL)
If CURF_QUOTE_TEL.XRATE_OVERRIDE = "¥" Then
Tniray (CURR_QUOTE TEL. XRATE RECALD) :

Elze
Gray (CURE_QUOTE_TEL.XRATE_FECALC):
End-If;
Elze -
| o

To edit or add record field PeopleCode through a page definition:

1. Select File > Open to open the page definition through which you want to access PeopleCode.
2. Select the field on the page for which you want to view the associated PeopleCode.

3. Select View > View Record PeopleCode.

The PeopleCode editor appears, providing access to all of the PeopleCode for the record that owns
that field.

4. Select the PeopleCode event type from the drop-down list box in the PeopleCode editor.
You can also select other fields in the primary record from that drop-down list box.

5. Select File > Save to save your changes.

Related Links
“Understanding PeopleCode Programs and Events” (PeopleCode Developer’s Guide)
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Previewing Pages in the Browser

This section discusses how to:

*  Work with the View in Browser feature.
e Maintain the list of browsers.

* Preview fluid pages.

* Preview classic pages.

¢ Generate HTML.

Working With the View in Browser Feature

444

During the page design process, you might want to periodically preview how your page looks in the
browser. How your page appears in Application Designer at design time may look different when viewed
online. This is particularly true for fluid pages, which do not follow the pixel perfect WYSIWYG
paradigm of classic pages. With fluid pages, CSS determines how the page and how the page elements are
displayed to the user. The physical placement of the page elements often has no bearing on how the fluid
page will appear at run time. Therefore, you must either preview fluid pages from Application Designer
or view them in a runtime browser session.

After you open either a fluid or classic page definition in Application Designer, you can select Layout >
View in Browser, and then select a browser from the list of configured browsers to preview the page.

Limitations

The View in Browser feature provides an approximate idea of how your page will look. For the complete
view of the page at run time, including any component settings, assign your page to a component and
register the component to the portal registry structure using the Registration Wizard. Then, you can access
the component and page in a browser online.

Note the following limitations on previewing pages from Application Designer:

¢  Only page definitions as a standalone definition can be previewed. Therefore, none of the component
properties or settings are available as part of a page preview.

e No PeopleCode or JavaScript is run during page preview.

For example, flex grid column headings will not be aligned properly because this relies on JavaScript.
In addition, scrolling enabled in Application Designer will not function since this also relies on
JavaScript.

e The content of an HTML area that is populated dynamically via the value of a record field (that is, via
PeopleCode) is not displayed. However, the content of an HTML area that is populated statically via a
constant value is displayed.

* Application data such as high-level keys, related display data, and grid or scroll data is not displayed.

*  Most page controls are inoperable.
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* In addition, for fluid pages, the following limitations apply:

* You can preview the following page types only: Standard, Subpage, and Secondary. For other
fluid page types, the View in Browser menu item displays this message: (Not available for this

page type).
* Any styles applied via PeopleCode or JavaScript will not be in effect.

* Pages are previewed in extra large form factor only; styles and overrides specific to this form
factor will be applied. However, form factor overrides for any other form factor will be ignored.

* An empty fluid banner is displayed at the top of the page for standard page types only. Since the
component definition includes all the settings that determine what is displayed in the fluid banner,
none of this information is available in the page definition during page preview.

» Secondary page types are not displayed in a modal window; the content is previewed in a full

screen.

» In addition, for classic pages, the portal wrapper (the portal header and footer defined in PeopleTools
branding) is not displayed.
Previewing Fluid Pages

The following examples demonstrate the rendering of a fluid page preview using the PeopleTools-
delivered Change Password (CHANGE PASSWORD) page.

The following example shows the CHANGE PASSWORD page definition in Application Designer:

i CHANGE_PASSWORD (Page) ==]Be

Layout ]order |

ey -~ _____ -

User ID| AAAAAAAAAAAAAAAAAAAAAAAAAAAAAS |

Description:| AAAAAAAAAAAAAAAALAASANASASLAAA

————————————————————

| aaaaaaaaaaaaaaaaaaa |
Current Pasgword| | ....................

[ AnsansassAARARRARAA|
New Passwordl | -

Confirm Password| |

Change Passwaord
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The following example shows the Change Password page when rendered using the page preview feature
in Application Designer:

User ID AAAAAAAAAAAAAAAAAAAAAAAAAAAAAA

Description AAAAAAAAAAAAAAAAAAAAAAAAAAAAAA

*Current Password
*New Password

*Confirm Password

| Change Password |

The following example shows the Change Password page when rendered at run time:
< My Homepage Change Password w : @

User D

Description

*Current Password
*New Password

*Confirm Password

Change Password

Note that the following styles and settings are honored when previewing fluid pages:

» Styles and settings on the Fluid tab of the Page Properties dialog box. Form factor overrides for the
extra large form factor are honored; overrides for all other form factors are ignored.

» Styles and settings on the Fluid tab of any page field properties dialog box. Form factor overrides for
the extra large form factor are honored; overrides for all other form factors are ignored.

» In addition, any browser-specific styles are applied.

Because page-specific style sheets are added via PeopleCode, these style sheets are not automatically

included during page preview like they would be in the a runtime rendering. Therefore, use the Apply
Additional Style Sheets menu item to apply page-specific style sheets in page preview. See "Applying
Additional Style Sheets" in this topic for more information.
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Viewing Related Content Drop Zones

You might also want to preview the location of the group boxes configured as related content drop zones
in relation to other page controls when previewing a fluid page.

Note: However, because embedded related content and dynamic subpages are configured outside of
Application Designer and rely on data that is only available at runtime, the content within these drop
zones cannot be displayed as part of fluid page preview.

To view drop zone group boxes during fluid page preview:
1. Select Layout, View in Browser, View Related Content Drop Zones.

Once this option has been selected, a check mark will appear next to View Related Content Drop
Zones in the menu indicating that drop zone group boxes will be displayed during fluid page preview.
This setting remains in effect only for the duration of the Application Designer session or until it has
been deselected.

2. Select Layout, View in Browser and select a browser to preview a fluid page displaying drop zone
group boxes.

The following is an example only, which shows three drop zone group boxes on the
MYQUICKCONTACTS page definition in Application Designer:

™ MYQUICKCONTACTS (Page) [=][=]E
Layout lomer |

Top of Page Drop Zone
[PT_ERCSUBPAGE_STUB |

USB[ID‘ ____________________________________________________________ I Add Save

Contacts

Contacts By Last Name

All Contacts

User 0] AAAAAAAAAAAAAAAAAAAAARAAAAAAAA I
Sequence Number| 2222
First Name| |

Last Name| |

Telephone‘ ‘

Email AUUIESS‘

Data Area Drop Zone (Level 1)

FT_ERCSUBPAGE STUB |

Bottom of Page Drop Zone

PT_ERCSUBPAGE_STUB
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The following example shows related content drop zones on the MYQUICKCONTACTS page when
rendered using the page preview feature in Application Designer:

Contacts

All Contacts A-M N-Z

*First Name
*Last Name
Telephone

Email Address

| Data Area Drop Zone (Level 1)

Drop Zone: Related Content or Subpage Target

Edit Delete

Bottom of Page Drop Zone

Drop Zone: Related Content or Subpage Target

Note: Page preview includes the labels for the related content drop zones for configuration purposes only.
These labels are available to the administrators who are configuring embedded related content or dynamic
subpages. At run time, these labels are not displayed. In addition, if no label is defined on the group box,
the label displayed in fluid page preview will differ from what is shown in the example here and what is
available to administrators who are configuring embedded related content or dynamic subpages.

Applying Additional Style Sheets

While page preview does apply the standard system style sheet, since custom style sheets are applied via
PeopleCode, they are not available during page preview.

Therefore, to apply custom free form style sheets, you need to create a text file on the local file system
that lists the custom style sheets, one per line. Specify the Application Designer definition name for each
custom free form style sheet. You can also include comments in this file preceded by the # symbol only.
The following example illustrates the contents of a text file that identifies two custom free form style
sheets:

# Custom style sheets for fluid page preview:
MY STYLESHEET 1
STYLESHEET 25
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To apply custom free form style sheets during fluid page preview:

L.

2.

Create a text file listing the style sheets on the local file system.

In Application Designer, select Layout, View in Browser, Apply Additional Style Sheets.
In the Apply Additional Style Sheets dialog box, browse to and select the text file.

Select the Apply Style Sheets check box.

Click OK.

Once the Apply Style Sheets check box has been selected, a check mark will appear next to Apply
Additional Style Sheets in the menu indicating that custom style sheets will be applied to each fluid
page that is previewed. This setting even remains in effect between Application Designer sessions. To
preview fluid pages without applying custom style sheets, deselect the Apply Style Sheets check box.

Select Layout, View in Browser and select a browser to preview a fluid page with the specified style
sheets applied.

Related Links
“Working with Embedded Related Content” (Fluid User Interface Developer’s Guide)
“Applying Styles” (Fluid User Interface Developer’s Guide)

Previewing Classic Pages

The following examples demonstrate the rendering of a classic page preview using the PeopleTools-
delivered My System Profile (USER_SELF SERVICE) page.
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The following example shows the USER_SELF SERVICE page definition in Application Designer.

Layout ]Drder ]

= USER_SELF_SERVICE (Page)

[==]

eneral Profile Information

Change or set up forgotten password hel

efault Mobile Page

AAAAAAAAAAAAAAAAA

Vorkflow Attributes

Ermail Type

Email Address

IM Infarmation
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The following example shows the My System Profile page as previewed from Application Designer:

Creating Page Definitions

General Profile Information

Password
Change password

Change or set up forgotten password help

Personalizations

Alternate User

Alternate User ID

From Date
To Date
Workflow Attributes
[ Email User [ worklist User

Miscellaneous User Links

Email

OO0 I I I O O I O O O I O O O O N O O O I O O O O I N I Y O O

My preferred language for PlIAweb pages is:

Language{:ode| v|

Currency Code Q
Default Mobile Page QL

If you will be temporarily unavailable, you can select an atternate user to receive your routings.

a
E;J AABAANAPAA BN PSRN ABABAA AR
E‘J AAAAALARAAANABAA RS AS AR A R RA DR

Personalize | Find | B2 First ‘4’ 10of1 '} Last

Primary Email Account Email Type Email Address
O v [+ [=]
IM Information Personalize | Find | First ‘& 1of1 “&' Last
Protocol XMPP Domain UserlD
LR T T A L L T L R L T R T T R T L R T T TR R T L T LT T o'}
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The following example shows the My System Profile page as rendered at run time:

¢ My Homepage General Profile .. \ ot

General Profile Information

Password

Change or set up forgotten passwaord help

Personalizations

My preferred language for PIA web pages is:  Enalish

My preferred language for reports and email is | English “ |

Currency Code Q
Default Mobile Page &}

Alternate User

If you will be temporarily unavailable, you can select an atternate user to receive your routings.

Alternate User ID Q
From Date Bl (example:12/31/2000)
To Date Bl (example:12i31/2000)

Workflow Attributes
[ Email User B workiist User

Miscellaneous User Links

Email Personalize | Find | 2] L& First ‘4 10of1 '} Last
Primary Email Account Email Type Email Address
Business v| gedmo@oracle.com [+l [=]
IM Information Personalize | Find | 2| E First ‘&' 10of1 '} Last
Protocol XMPP Domain UserlD Password
XMPP Q [+ [=]
[F] Save

Mew Window | Help | Personalize Page

Chapter 10

Previewing a Page as Classic Plus

When working with classic pages, you can preview a page as classic plus regardless of component
settings and regardless whether any reworking has been completed to make the page more suitable for
classic plus. In fact, you can use this feature to assess what rework might be required. For guidance on

what may need to be reworked, see Reworking Components for Classic Plus Display.
To preview a classic page as classic plus:

1. Select Layout, View in Browser, View as Classic Plus.
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Once this option has been selected, a check mark will appear next to View as Classic Plus in the menu
indicating that classic plus styling will be applied to each classic page during page preview. This
setting remains in effect only for the duration of the Application Designer session or until it has been
deselected.

2. Select Layout, View in Browser and select a browser to preview a classic page as classic plus.

The following examples demonstrate the classic plus rendering of the PeopleTools-delivered My System
Profile page.

The following example shows the My System Profile page when previewed as classic plus from
Application Designer:

General Profile Information

OO I I O I I Y I O Y I I I O I O O I S T

Password

Change password
Change or set up forgotten password help

Personalizations

My preferred language for PlA web pages is:

Language Code E|

Currency Code Q

Default Mobile Page Q

Alternate User

If you will be temporarily unavailable, you can select an alternate user to receive your routings.

Alternate User ID Q
From Date
To Date
Workflow Attributes
[l Email User ] Worklist User
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The following example shows the My System Profile page when rendered as classic plus at run time:

< My Homepage General Profile .. \ o E
MNew Window | Help | Personalize Page|

General Profile Information

Password

Change or set up forgotten password help

Personalizations

My preferred language for PIAweb pagesis:  Endlish

My preferred language for reports and email is | English ~

Currency Code Q

Default Mobile Page Q

Alternate User

If you will be temporarily unavailable, you can select an alternate user to receive your routings.

Alternate User ID Q
From Date (example: 12/31/2000)
To Date (example:12/31/2000)

Workflow Attributes

Email User Worklist User

Miscellaneous User Links

Eunn mill

Maintaining the List of Browsers

Application Designer will automatically detect your default system browser. You can add additional
browsers to the list of browsers to use for previewing. After you set up a new browser, you can select in
which browser you want to view your pages.

To maintain the list of browsers:

1. Open a page definition in Application Designer.
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Select Layout > View in Browser > Edit Browser List.

The Browsers dialog box is displayed.

Click the Add button to add a browser to the list.

The Browser Definition dialog box is displayed.

Click the Browse button to locate the browser to add.

You must select the correct path and browser application for the new browser to function properly.

Click the Find Name/Type/Version button to automatically enter the name, type, and version of the
browser.

The name and version that you enter appears in the Layout, View in Browser menu.

Note: If the browser is updated in the future, this version information will be out of sync with the
actual browser version. However, the preview function will still work unless the location or name of
the executable has changed.

Generating HTML

You can view the HTML that is created for classic or fluid pages page by using the Generate HTML
menu item. This feature writes the HTML code to a file in a subfolder of the folder defined by the TMP
environment variable—for example, in % TMP%\2\pshtml. This feature is mainly used for debugging
purposes and typically is not needed when you're designing and developing pages.

Configuring Drop Zones

This topic provides an overview of drop zones and discusses how to:

Insert configurable drop zones.

Note: Typically, as an Oracle customer, you should skip this step. PeopleSoft application teams have
already added and delivered one or more configurable drop zones on selected pages.

Create custom subpages for dynamic injection into drop zones.

Configure drop zones.

Related Links
“Understanding the Drop Zone Configuration Classes” (PeopleCode API Reference)

Understanding Drop Zones

Configurable drop zones allow you to add fields to delivered pages without customizing the delivered
component or page definition. Your fields are displayed and processed along with fields from the main
page definition and any nested subpages or secondary pages.

Copyright © 1988, 2023, Oracle and/or its affiliates. 455



Creating Page Definitions Chapter 10

At design time, a placeholder subpage stub (PT_ERCSUBPAGE STUB) is inserted into a special group
box on the page definition, creating what is referred to as a “drop zone.” Drop zones can be added to a
main page, to subpages at any nesting level, and to secondary pages. Typically, PeopleSoft application
teams (PeopleSoft HCM, PeopleSoft FSCM, and so on) have identified which delivered pages can be
extended by customers and have already added one or more configurable drop zones on these pages,
subpages, and secondary pages. Then, you create custom subpage definitions and associate your subpages
to one or more drop zones. Finally, at runtime during the component build process, the configured
subpage dynamically replaces the subpage stub. The records and fields defined on your subpage are
loaded into the component buffer along with the records and fields from the main page definition.

The complete procedure for inserting and configuring drop zones includes three tasks described within
this topic:

1. (Optional) Inserting configurable drop zones.

Important! This task is described for informational purposes only. Drop zones are delivered by
PeopleSoft application teams. Therefore, this step is typically not performed by you. While you could
add drop zones to your own custom application pages, there really is no reason to do so. Moreover,

if you were to add drop zones to pages delivered by Oracle, those changes would be considered
customizations.

To understand the process used by PeopleSoft application development teams, see Inserting
Configurable Drop Zones.

2. Creating subpages for these drop zones.

See Creating Custom Subpages for Drop Zones.

3. Configuring a selected drop zone by associating a custom subpage to it.

See Configuring Drop Zones.

Inserting Configurable Drop Zones

456

Important! This task is described for informational purposes only. Drop zones are delivered by
PeopleSoft application teams. Therefore, this step is typically not performed by you. While you could
add drop zones to your own custom application pages, there really is no reason to do so. Moreover, if you
were to add drop zones to pages delivered by Oracle, those changes would be considered customizations.

Guidelines for Creating Configurable Drop Zones

Note: The following guidelines are valid for conventional components only. For “derived components”—
that is, components with a derived record structure—you must carefully evaluate the derived record

and key structure and database fetch, save, and commit mechanisms since these will not necessarily

rely on the built-in processing of the PeopleTools component processor. Depending on the component’s
architecture, adding a drop zone may or may not work and must be tested thoroughly.

Adhere to the following guidelines when inserting configurable drop zones:

» Insert the group box type that is appropriate to the page type (fluid pages versus classic pages).
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Insert the PT_ERCSUBPAGE_STUB subpage stub into the group box . (This subpage stub is
identified on the PeopleTools Options page.)

Do not insert any other page controls within the group box.

If you add a drop zone on a secondary page, then you must also insert a secondary page control on the
main page or subpage that launches the secondary page.

If you add a drop zone on a subpage or a secondary page rather than on the main page,

then you must ensure that each drop zone that will be displayed along with the main page

at runtime can be uniquely identified. The PeopleSoft system uses the combination of

occurs 1v1l.RECORD NAME.FIELD NAME.Field ID to identify each group box as a page
record field. By associating each group box to a unique record field, you will ensure that each can be
uniquely identified.

The information that uniquely identifies page field can be found on the page definitions
Order tab. In the following example, Top of Page Drop Zone is uniquely identified as
0.MYQKCONT WRK.MQC DZ 1.2.

= MYQUICKCONTACTS (Page) [=]=]E
Layout Order l
Tab Order | Field 1D [Lv| Label | Type | Field | Record | Parent Fi| Display Control] Related Field | Cor
1 |1 o | Giroup Box | | MYQUICKE | | ] |
i 0 [Top of Page Drop Zone Group Box MOC_DZ_1 MY OKCONT_Ww/REK MY GLICKC] ]
3 5 0 Subpage MY QUICKC][ ] ]
4 E] 0 [UserlD Edit Box OPRID MYQKCONTACT | MYGUICKE][ ] O]
5 18 0 Group Box MY QUICKL]

Important! Because the PeopleSoft system uses the combination of

occurs 1v1l.RECORD NAME.FIELD NAME.Field ID to identify each drop zone, you cannot
make any updates that would change any of the elements of this unique identifier such as moving the
drop zone to a different occurs level, changing the associated record field, or deleting the drop zone.
Any such change will orphan and break existing configurations based on that drop zone. If you need
to make any such updates, delete any existing configurations first so that they are not orphaned. Make
the required changes. Then, re-establish the configuration.

Inserting a Group Box as a Drop Zone

To insert a group box as a drop zone:

1.

Insert the group box on your page in the general position you would like to display the content from
the custom subpage.

Note: On classic pages, similar to inserting other page controls, ensure that there is a minimum of a 5
pixel vertical gap between the drop zone group box and other page controls.

Double-click the group box to open the Group Box Properties dialog box.
Then, configure the group box depending on the page type:
a. For fluid pages, on the Fluid tab, set the Group Box Type to Related Content.

b. For classic pages, on the Use tab, select these check boxes: Drop Zone Group Box and Hide all
Fields when Group Box Hidden.
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4. (Optional) Apply styling, if needed, to this group box that will only be rendered if a subpage is
configured for this drop zone.

5. Select the Label tab and enter a descriptive label to identify this group box as a drop zone. Enter
a label that describes the position, purpose, or both for this drop zone. The label is not rendered at
runtime, but it will help at design and configuration time by:

» Differentiating this drop zone from any others on this page as well as any associated subpages or
secondary pages.

* Providing a label on the drop zone during page preview in Application Designer.
* Providing a label for the drop zone during the drop zone configuration task, which displays all
available drop zones from the component.
6. Associate a record field to this drop zone to ensure that it has a unique page field identifier.

7. Insert the PeopleTools-defined PT_ ERCSUBPAGE STUB subpage stub into the related content
group box:

e On fluid pages, the upper left corner of the subpage must be located within the group box. On
classic pages, the entire subpage must be located inside the boundaries of the group box.

In this example, the PT_ERCSUBPAGE STUB subpage is located within the drop zone group
box in a manner that satisfies both fluid and classic requirements on placement.

Data Area Drop Zone [Level 1)

IPT_ERCSUBPAGE_STUB |

*  The subpage must be listed immediately after the group box on the Order tab for the page
definition.
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In this example, the PT_ERCSUBPAGE _STUB subpage immediately follows the Data Area Drop

Zone (Level 1) group box on the Order tab.

e MYQUICKCONTACTS (Page) ==&
Layout Order l
Tab Order | Field ID |Lv Label Type Field Record Parent Fi|Display Control| Related Field | Cor
7
2 2 0 |Top of Page Drop Zone Group Box MEC_DZ_1 MYRRCONT_wWRK MYQUICKC][ ] ]
3 5 0 Subpage MYQUICKC][ ] []
4 9 0 |UserlD Edit Box OFRID MYIKCONTACT Wi MY OUICKC|[] []
5 18 0 Group Box MYQUICKC][ ] ]
[ 19 i Group Box MYOUICKD
7 20 0 |&dd Push Bin/Link. |ADD_PB MYEKCONT_wRE MY AUICKE|[ ] []
g 21 0 [Save Push Bin/Link  |SAVE_PB MTEKCONT_wRE MYQUICKL][ | []
E] 7 0 |Contacts Group Box MYQUICKC][ ] ]
0 27 0 |Contacts By Last Mame Group Box MEC_TABSET MYRKCONT_WRK MYQUICKC][ ] []
1 28 1] Group Box MOC_TART MYIKCONT_WREK MY OUICKC|[] []
2 23 0 Al Contacts Fush Bin/Link MEC_TABLINK_ALL | MYQKCONT_wWRK MYAUICKE|[] []
3 30 0 Group Box MOC_TAB2 MYOKCONT_WRK MYOUICKC
4 32 0 |&-M Push Bin/Link MEC_TABLINK_AM | MYQKCONT_wWHE MY AUICKE|[ ] []
5 il 0 Group Box MGC_TAR3 MTEKCONT_wRE MYQUICKL][ | []
5 33 0 |N-Z Push Bin/Link MEC_TABLINK_MNZ | MYQKCONT_wWRK MY AUICKC|[ ] []
7 26 0 |Total Edit Box MOC_TOTAL MYEKCONT_wWRE M AUICKC][ | []
g8
3 10 1 |UserlD Edit Box OFRID MYIKCONTACTSTEL MYAUICKE|[] []
20 11 1 |Sequence Number Edit Box SEGQNBR MYOKCONTACTSTEL MYOUICKC
21 12 1 |First Name Edit Box FIRST_MAME MYEKCONTACTSTEL MY AUICKE|[ ] []
2 13 1 |Last Mame Edit Box LAST_NAME MTYQKCONTACTSTEL  [MYQUICKC|[ | []
23 14 1 | Telephone Edit Box PHONE MYEKCONTACTSTEL MY AUICKC|[ ] []
24 15 1 |Email Address Edit Box EMAIL_ADDR MY IKCONTACTSTEL M OUICKC( [ []
25 16 1 [Datadrea Drop Zone [Level 1) [Group Box 2 1K M C
7 1 Subpage I C
27 23 1 Group Box MY QUICKC][ ] []
28 24 1 |Edit Push Bin/Link EDIT_BTN MYIKCONTR_WHRE MY AUICKE|[ ] []
29 25 1 |Delete Push Bin/Link  [DELETE_BTN MTYOKCONTR_WRE MYQUICKL][ | []
a0 4 0 Harizntl Rule MY AUICKC|[ ] []
]l 3 0 |Bottom of Page Drop Zone Group Box MEC_DZ_3 MYRKCONT_WRK MYQUICKC][ ] []
32 E 0 Subpage MYQUICKC][ ] ]

Important! If you insert multiple drop zones on the same page, always inspect and fix the order
of group boxes and subpages on the Order tab.

8. For classic pages only, open the Page Properties dialog box. On the Use tab, select the Adjust Layout
for Hidden Fields check box.

9. Save your changes.

10. (Optional) Use the page preview in Application Designer to preview the page with drop zones.

Special Considerations for Drop Zones on Fluid Pages

Note that adding a related content group box on a fluid page creates a “drop zone.” These fluid drop zones
can be configured for two purposes:

Embedded related content only.

Note: The absence of the PT_ERCSUBPAGE STUB subpage means that such a group box can be

configured for embedded related content only.

Embedded related content was introduced in PeopleTools 8.55. While the procedure for creating and
configuring embedded related content has not changed, the group box itself is now also referred to
as a drop zone. See “Working with Embedded Related Content” (Fluid User Interface Developer’s

Guide).

Dynamically injected custom subpages or embedded related content.
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A related content group box created for dynamically injected custom subpages could be configured
for embedded related content instead. However, both uses cannot coexist simultaneously. If a drop
zone already configured with embedded related content is reconfigured with a custom subpage, then
the embedded related content configuration is overridden. If a drop zone is already configured with a
custom subpage, it will not be available for configuration with embedded related content.

Related Links

“Configuring PeopleTools Options for Fluid Applications” (Fluid User Interface Developer’s Guide)
Previewing Pages in the Browser

“Working with Embedded Related Content” (Fluid User Interface Developer’s Guide)

Creating Custom Subpages for Drop Zones

Considerations for Creating Custom Subpages
Consider the following when creating custom subpages for dynamic injection into drop zones:

* The records and fields defined on your subpage will be loaded into the component buffer along with
the records and fields defined on the page containing the drop zone.

* However, the fields from your subpage that are dynamically added to the component buffer at
runtime are not available in the component’s search record or its add search record.

» In addition, the fields from your subpage that are dynamically added to the component buffer at
runtime are also not available in component interfaces.

*  Multiple updatable tables are allowed at level 0 only.

» Ifyou add a grid or scroll area to the subpage, you must add a horizontal rule after it to reset the level
to 0.

» Unlike when a subpage is added directly as a page control on a main page definition, with this sort of
dynamically injected subpage you cannot perform a record name substitution (that is, identify a from
record on the subpage and a to record from the main page as described in Understanding Subpages).

* Record field PeopleCode defined on your subpage runs as part of the events in the component
processor flow. If your implementation requires other scenarios or PeopleCode events, (for example,
page Activate, PreBuild, PostBuild, component record, or component record field events), then you
must use PeopleCode event mapping to avoid customizing delivered components and pages. See
“Mapping Application Class PeopleCode to Component Events ” (Portal Technology) for more
information.

Note: While drop zones can be added to pages in unregistered components, unregistered components
do not support event mapping.

Creating a Fluid Subpage Definition
To create a fluid subpage definition:

1. In Application Designer, select File, New.
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Select Page (Fluid) in the New Definition dialog box, and click OK.
Select PSL_SIMPLE SBP to create a fluid subpage.
Click Choose, and then enter the name for your custom subpage in the Save As dialog box.

Indicate whether you’d like to save the PeopleCode associated with the layout page for your new page
(Yes/No).

Note: Typically, click Yes to include any PeopleCode from the layout page.

Open the Page Properties dialog box.
On the Use tab, select Subpage to specify this as a fluid subpage.

Add page controls on your subpage definition.

Creating a Classic Subpage Definition

To create a classic subpage definition:

1.

2.

In Application Designer, select File, New.

Select Page in the New Definition dialog box, and click OK.

Open the Page Properties dialog box.

On the Use tab, select Subpage to specify this as a classic subpage.

Insert a container that encompasses the full extents of the page definition. All other page controls
inserted on your custom classic subpage must be enclosed by this container. You can use either a
group box or a frame as this container.

Apply styling and settings to the container per your requirements. In some circumstances, you may
want a title and borders on the container:

For a group box container:

Important! Do not select Drop Zone Group Box on the Use tab. This setting pertains only to the drop
zone itself, which is found on the main page.

*  Clear the label text on the Label tab.
»  Set the Label Style to PAGROUPBOXLABELINVISIBLE.

» If'the drop zone appears in a classic plus component, set the Body Style to
PSGROUPBOXCONTAINER to remove margins, padding, and the label from the container.

» Select the Adjust Layout for Hidden Fields check box.
*  Optionally, select the Hide Border check box.
For a frame container:

¢ (Clear the label text on the Label tab.
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*  Set the Style to PSGROUPBOXCONTAINER.

» If the drop zone appears in a classic plus component, set the Body Style to
PSGROUPBOXCONTAINER to remove margins, padding, and the label from the container.

» Select the Adjust Layout for Hidden Fields check box.

*  Optionally, select the Hide Border check box.

7. Add page controls on your subpage definition.

Related Links
Understanding Page Design and Development
Using Subpages

Configuring Drop Zones

Use the Configure Drop Zones pages to search for, select, and configure components containing
configurable drop zones, including unregistered components.

Navigation:
PeopleTools > Portal > Configure Drop Zones

This example illustrates the fields and controls on the Configure Drop Zones search page. You can find
definitions for the fields and controls later on this page.

Component Search Criteria
Use the following criteria to search for a component to be configured for drop zones.You may use a percent sign (%) to indicate a wildcard.
Note: Search results may include components that cannot be configured because no drop zones are available in the component.

Component |%HGA%
Type ©
Description
Market W
Object Owner ID ~

Configured Subpage

- [

Search Results

30 rows

Component Name Market Object Owner ID Description Configured List of Configured Subpages
HGA_ABS_PGLT Global TL Rules and Monitoring Absences Approval Mo
HGA_CAN_XFER Global Absence Management Absence Cancel transfer No
HGA_DYN_TIL_CON_FL Global Absence Management Dynamic Tile Content Mo
HGA_EA CS_DATA Global Absence Management Extended Absence Detail Mo
HGA_EA REQ_DTL_FLU Global Absence Management Manage Extended Absence No

You must enter one or more search criteria to perform a search using this page. You may use % as a
wildcard.
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Field or Control Description
Component Enter a definition name for the component as search criteria.
Type Select either Fluid or Classic to limit search results to either

fluid or classic components.

Description Enter the description as defined on the General tab of the
Component Properties dialog box as search criteria.

Market Select the market for the component from the drop-down list.

Object Owner ID 