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Get Help

Get Help
There are a number of ways to learn more about your product and interact with Oracle and other users.

Get Help in the Applications
Use help icons    to access help in the application. If you don't see any help icons on your page, click your user image
or name in the global header and select Show Help Icons.

Get Support
You can get support at My Oracle Support. For accessible support, visit Oracle Accessibility Learning and Support.

Get Training
Increase your knowledge of Oracle Cloud by taking courses at Oracle University.

Join Our Community
Use Cloud Customer Connect to get information from industry experts at Oracle and in the partner community. You
can join forums to connect with other customers, post questions, suggest ideas for product enhancements, and watch
events.

Learn About Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program. Videos included in
this guide are provided as a media alternative for text-based topics also available in this guide.

Share Your Feedback
We welcome your feedback about Oracle Applications user assistance. If you need clarification, find an error, or just
want to tell us what you found helpful, we'd like to hear from you.

You can email your feedback to oracle_fusion_applications_help_ww_grp@oracle.com.

Thanks for helping us improve our user assistance!

i

https://support.oracle.com/portal/
https://www.oracle.com/corporate/accessibility/learning-support.html#support-tab
https://www.oracle.com/education/
https://cloudcustomerconnect.oracle.com/pages/home
https://community.oracle.com/customerconnect/categories/idealab-guidelines
https://www.oracle.com/corporate/accessibility/
mailto:oracle_fusion_applications_help_ww_grp@oracle.com


Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Get Help

ii



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 1
About This Guide

1  About This Guide

Audience and Scope  
If you import and export business data in CX Sales and Fusion Service, then this guide is for you.

Note:  Oracle has discontinued the File-Based Data Import and Export support for CX Sales and Fusion Service
Objects with the 20D Update. We strongly recommend that you move to the new Import and Export Management
application (available from Navigator > Tools > Import Management/Export Management) to continue importing
and exporting your data. As you migrate to the new framework, make sure you upgrade both manual processes and
automated or scheduled processes. Note that data maps aren't portable between frameworks and must be recreated
as a one-time activity.

Before getting started, make sure your company's CX Sales and Fusion Service is up and running at a basic level. You
can find these details in the use case contained in the Getting Started with Your Sales Implementation guide.

To set up and work with the additional features of CX Sales and Fusion Service, see CX Sales and Fusion Service
documentation on Oracle Help Center at https://docs.oracle.com.

Related Guides  
You can refer to the following related guides to understand more about the tasks covered in this guide.

Title Description

Oracle Applications Cloud Configuring
Applications Using Application Composer
 

Provides information on how sales administrators and implementors can make application changes
using the available configuration toolset.
 

Getting Started with Your Sales
Implementation
 

Provides you with the concepts and procedures you need to implement a sales automation solution.
 

Implementing Customer Data
Management for CX Sales and Fusion
Service
 

Provides conceptual information and procedures needed to implement customer data management-
specific components and features of your application.
 

Implementation Reference
 

Provides conceptual information and procedures used to implement sales application components and
features.
 

Using Sales
 

Provides information about performing day-to-day tasks in your sales applications.. If you're a sales
person, sales manager, or any other sales user, then this guide is for you.
 

1
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Title Description

Using Customer Data Management for CX
Sales and B2B Service
 

Provides information about managing customer information and customer data quality. If you're an
end user of the customer data management functionality such as customer data steward and data
steward manager, then this guide is for you.
 

Related Topics
• Oracle Help Center

2
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Chapter 2
Overview of Import Management

2  Overview of Import Management

About Import Management Documentation  
This topic provides an overview of the types of help available for importing data into Oracle Applications Cloud using
Import Management.

You can get the information about import from the following:

• Sales and Fusion Service documentation on the Cloud Help Center (https://docs.oracle.com/en/cloud/saas/
index.html).

◦ Explore the latest critical reference content supporting Sales and Fusion Service.

◦ Download PDF versions of guides, find links to reference materials and white papers, and search for
specific topics.

◦ Browse import data topics on the Administer tab that provide key import information.

• Understanding Import and Export Management for Sales and Fusion Service guide available on the Help Center
(http://www.oracle.com/pls/topic/lookup?ctx=cloud&id=FAIEM)

To understand what attributes are available for import for each object, start by searching help using the
keywords Import Your <Object Name> Data. For example, to get help on importing accounts, enter Import Your
Account Data.

What are the available data import options?  
You can import your data from an external application into Oracle Applications Cloud in several different ways, including
using public web services.

Which import method you use depends on the type of data you're importing, the volume of data, and technical
requirements. If you're integrating one cloud service with other cloud services, then you must use additional import
methods as described in the appropriate guides.

When you're importing data for a particular object, you must make sure that any prerequisite objects already exist in
the application. For example, if you're importing contacts for an account, then the account must already exist in the
application. If one import job depends on the contents of another import job, then complete the prerequisite job before
starting the dependent job. For example, if you're importing both accounts and opportunities, then import accounts
before importing opportunities.

The following table lists the import methods and references to further information.

Import Method Description When to Use How to Access For More Information

Quick Import Excel Macros
 

You can use the import
macros to speed up and
simplify the import of up

These are best to import
data in your initial
deployment.

You can download the Excel
macros and any required
mapping files from the

The chapters in the
Getting Started with Your
Sales Implementation

3
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Import Method Description When to Use How to Access For More Information

to 5000 records at a time
for some objects. They
validate your data entries,
 provide list of values, and
automatically populate
constant values.
 
The macros create data
files that are automatically
imported using Import
Management.
 
You can import the
following objects using
import macros:
 

• Sales Users

• Products and product
groups

• Accounts

• Contacts

• Account Hierarchy

• Leads

• Opportunities

 
The macros are targeted to
the simple proof of concept
sales automation use case
covered in the Importing
Sales Users chapter of
the Getting Started with
Your Sales Implementation
guide. For example, the
import macros assume that
you're importing account,
 contact, and lead records
for one country at a time.
 
The macros generate log
files with information about
the File Import job, and
these log files can also
serve as a learning tool for
more complex import.
 

Getting Started with Your
Implementation: Quick
Import Macros (Document
ID 2229503.1) article on My
Oracle Support.
 

guide provide detailed
instructions and video
tutorials for using the
macros.
 
For instructions on how
to add your own fields to
the macros, see. How to
Configure Quick Import
Macro for importing
Employee Resources (Doc
ID 2364229.1) article on My
Oracle Support.
 

Import Management
 

Import Management
improves definition, error
handling, and performance
for importing flat files
(.CSV). For example, Import
Management has drag and
drop mapping capabilities
and validates the first ten
records in your data file
before you import to ensure
the data meets the import
constraints of the various
attributes.
 
Import Management is
available for importing data
for the following application
objects and their child
objects:
 

• Access Groups

• Account

• Action

• Action Plan

• Activity

• Address

• Asset

• Attachment

Use Import Management
for importing outside
the scope of the Getting
Started with Your
Implementation guide.
 
 

Click Import Management
in the Navigator.
 

See the Understanding
Import and Export
Management guide for
instructions on using the
import.
 

4
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Import Method Description When to Use How to Access For More Information

• Business Plan

• Campaign

• Case

• Classification

• Classification Code

• Competitor

• Consumer

• Contact

• Contract

• Contests

• Country Structure

• Deal Registration

• Hierarchy

• Hierarchy Member

• Household

• Hub Source System
Reference

• Incentive Rule
Assignments

• Incentive Rule
Attribute Values

• Incentive Rules

• Incentive Transaction

• Interaction

• MDF Budget

• MDF Claim

• MDF Request

• Note

• Objective

• Opportunity

• Organization

• Partner

• Partner Program

• Person

• Price Book Header

• Product

• Product Group

• Program Enrollment

• Promotion

• Queue

5
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Import Method Description When to Use How to Access For More Information

• Relationship

• Resource

• Resource Capacity

• Sales Lead

• Sales Order

• Sales Territory

• Sales Territory Quota

• Self-Service Role

• Service Request

• Standard Text

• Standard Text Folder

• Standard Text User
Variable

• Subscription

• Template

• Template Action

• Territory Geographies

• Any additional objects
you create

External Data Loader Client
 

Command-line tool that's
used to import high-
volume flat source data
files into CX Sales and
Fusion Service. This tool
splits a large data file into
multiple smaller files to
adhere to import volume
limits, and enables the
tracking of import status.
 
The client supports the
same objects as Import
Management.
 

Use this import method
for importing very large
data files for the objects
supported by Import
Management.
 

You can download the
client from Oracle Support
Document 2325249.1
(External Data Loader
Client) on My Oracle
Support.
 

Instructions for using the
client are available in the
document and in the client
itself.
 
The chapter Import Data
Using External Data
Loader Client in the guide
Understanding Import and
Export Management for CX
Sales and Fusion Service
provides information about
using the External Data
Loader Client.
 

Web Services
 

Web services are available
for external client
applications to start and
monitor import jobs.
You can manage Import
Management jobs using
REST web services, and File
Import jobs using SOAP
web services.
 

Use web services to
manage import jobs to
import directly from an
external application.
 

Public APIs are available
for both the Import
Management/REST
services and the File
Import/SOAP services.
 
The following REST APIs
are available for import:
 

• Import Activities

• Import Activity Maps

• Import Export Objects
Metadata

For REST API
documentation, see the
REST API for CX Sales and
Fusion Service guide.
 
For SOAP API
documentation, see the
SOAP Web Services for CX
Sales and Fusion Service
guide.
 

6
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Import Method Description When to Use How to Access For More Information

The SOAP service is called
the File Import Activity
Service.
 

High-Volume Import
 

The high-volume import
mode is designed to import
millions of records at
once. This mode doesn't
trigger any custom logic
configured through the
application composer. This
option is available for the
following objects and their
child objects:
 

• Account

• Address

• Asset

• Classification Code

• Contact

• Contract

• Contract Line

• Country Structure

• Custom Object
(custom top level
objects and custom
child objects)

• Geography

• Hierarchy

• Hierarchy Member

• Household

• Hub Source System
Reference

• Incentive Transaction

• Organization

• Person

• Sales Territory Quota

• Territory Geographies

Use this import mode
for importing very large
number of records for the
objects supported.
 

You can access High-
Volume Import either using
REST services or using
External Data Loader Client.
 
When importing using
REST, set the "High-
volume" attribute to enable
this mode of import.
 
When importing using the
External Data Loader Client,
set the command-line
parameter "-high-volume"
to enable this mode of
import.
 

For REST API
documentation, see the
REST API for CX Sales and
Fusion Service guide.
 
The chapter Import Data
Using External Data
Loader Client in the guide
Understanding Import and
Export Management for CX
Sales and Fusion Service
provides information about
using the External Data
Loader Client.
 

Note:  Object work flows can't be invoked using Import Management.

The following figure provides an architectural overview of the different import methods:

• File Import uses the SOA architecture to import data into Oracle CX Sales.

• Quick Import uses the REST Web services to import data into Oracle CX Sales. When you import data using
the quick import Excel macros, you're creating an import activity in Import Management using the REST web
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services. The macro import creates the same import activity and uses the same mapping as you do when you
initiate the import from the application. You can monitor each import in the macro or in the application itself.

• Both Import Management and the External Data Loader Client use the same scheduled processes for import.
When you import very large files using the client, the REST APIs create multiple processes to respect the Import
Management file size limit.

• To import from an external application, use the SOAP and REST web services directly.

Related Topics
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Overview of Import Process  
This topic provides an overview of the components used to import data.

Import Process Flow
The following figure explains the various stages in the import process:

1. Evaluate your import data.
2. Identify the relevant import objects.
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3. Map your data to the import objects.
4. Create an import activity.
5. Verify the import results.

Import Objects and Import Queue
You can find details about the attributes such as data type, length, and user key information for each object on the
Import Objects tab. You can download the template for each import object by clicking the Download icon. You can
create a mapping either while creating an import or separately using the Import Objects tab. On the Import Object
Details page, click the Display Name link for the object to navigate to the Manage Mapping page. On this page, you
can create a new import mapping, upload a map, or manage an existing mapping.

The Import Queue tab lets you view the imports that are in various statuses, such as active, completed, or unsuccessful.
You can further drill down into an import activity by clicking the import name link to view the status details.

Application Composer and Custom Extensions
If you create additional attributes to an existing object or create custom objects in Application Composer, then these
extensions are available for import and export once you publish your sandbox.

Related Topics
• Define Objects

What are the file-size limits for import?  
You can import a maximum of 50,000 records per data file. This limit is applicable for files imported using the User
Interface and the REST service (low-volume). The size of the data file can't exceed 250 MB.

You can submit multiple jobs at one time. The application dynamically calculates the number of jobs that will run
parallelly at a time. All other jobs are queued and executed as and when the previous jobs complete.

Note:  If you're using the importActivities REST service to submit jobs (also known as 'import activities'), then each
job can contain up to 20 CSV files in the request payload. This means that 10 jobs, each with 20 CSV files of 50,000
records, can instruct the application to process up to one million records at a time.

To import much higher volumes of data, you must use the External Data Loader Client (EDLC). EDLC accepts files with
more than 50,000 records. It breaks these larger files into smaller pieces of 50,000 each and imports them. Using the
high-volume mode of EDLC, you can split and import in pieces of 500,000 records each.

Here are the file and record limits for Import Management:

Import Channel and Mode Maximum Number of Files per job
Submission

Maximum Records Processed in a Single
Submission

User Interface (low-volume)
 

1 file (50k records)
 

50k records
 

REST Service (low-volume)
 

50k records per file
 

Unlimited (Must be manually split by the user
into 50k record files)
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Import Channel and Mode Maximum Number of Files per job
Submission

Maximum Records Processed in a Single
Submission

 

EDLC (low-volume)
 

50k records per file
 

Unlimited (EDLC splits into 50k record files by
default, and submits in a single REST call.)
 

User Interface (high-volume)
 

1 file (500k records)
 

Unlimited (Must be manually split by the user
into 500k record files)
 

REST Service (high-volume)
 

500k records per file
 

Unlimited (Must be manually split by the user
into 500k record files)
 

EDLC (high-volume)
 

500k records per file
 

Unlimited (EDLC splits into 200k record files by
default, and submits in a single REST call.)
 

Note:  Oracle recommends that you use EDLC (high-volume) import for the supported objects and that you limit
the job to 2 million records with 20 files per job (around 100k records per CSV file). If you plan to run parallel import
batches, Oracle recommends that you run a maximum of 10 parallel batches. User performance will vary based on
your data and configuration. The recommendation of 10 parallel batches of 100 K records is a tip to get you started.
You need to explore and identify the configuration that best suits your organization's requirements.

Note:  Ensure that purge and imports aren't running in parallel for the same object at the same time.

Note:  Split the data into multiple files if the import with large number of fields or 50k records fails.

Note:  Order the records to have better performance. Keep all the child levels belonging to the same parent in the
same file. Such as keep all the Subscription cover levels belonging to the same parent "Subscription Product " in the
same file.

How You Use Alternate Keys to Import Records  
Alternate keys help you uniquely identify object records, so that you can create, update, delete, and manage
relationships. This helps you import and build relationships to other objects, without the need to know the system-
generated primary keys of each record.

Use of known alternate keys also eliminates the need to requery and remap data.

Here are some examples of Alternate Keys:

• Public Unique Identifier (PUID) - supports the ability to define an auto-generated sequence number.

• Original System/Original System Reference (OS/OSR) - consists of two fields:

◦ Original System - refers to the source system from which the record was sourced. Administrator must
configure this field.
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◦ Original System Reference - refers to the unique identifier for the record in the source system.

• Email Address - the email address value of a record can be used on some objects (such as Employee Resource)
to identify a record.

The keys resolve in the following order of precedence:

1. Primary Key (PK)
2. Public Unique Identifier (PUID)
3. OS/OSR (if applicable)
4. Any other alternate keys (PUID must be the first alternate key in the order of precedence if more than one

alternate key is supported)
Here is the use case supported in Import Management, high-volume import mode, and External Data Loader Client:

What You're Trying to do How to do it

Update a value on a record
 

• Refer to the record using object-specific Primary Key(s) or using object specific PUID(s). For
example, LeadId(PK) and ResourceId(PK) or LeadNumber(PUID) and PartyNumber
(PUID)

• Refer to the record only by one of its defined AK values

• Refer to the record only by one of its defined OS/OSR values

When performing updates using Import Management, if you have multiple rows in the source CSV file, each using the
same PK or PUID values, then the records in your source file may not be processed in the order in which they're listed.

Scenarios for Creating, Updating, and Deleting Records
Scenario A shows the different ways of creating, updating, and deleting records using different combinations of keys
with account object as an example. The following image and tables highlight the use cases for this scenario:
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Scenario A for alternate key import

Column Meaning

PartyId
 

Primary key. Value comes from system-generated document sequence number. Never null.
 

PartyNumber
 

PUID. When record is created value is either passed in or system-generated. Never null.
 

SourceSystem
 

Source system name. Can be null. (Only a limited number of objects support OS/OSR construct)
 

SourceSystemReferenceValue
 

Source system reference. Can be null. (Only a limited number of objects support OS/OSR construct)
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Column Meaning

CEOName
 

This is a non-key data attribute on the object. Can be null.
 

Use Case Source file
contents

Description PK PUID OS OSR Non-key Data

Create a record,
 pass in PUID on
primary object
 

PartyNumber:
CA4139
 
CEOName: John
Smyth
 

A record created
 

98769 (system-
generated)
 

CA4139
 

N/A
 

N/A
 

John Smyth
 

Create a record,
 without passing
PUID value on
primary object
 

CEOName: John
Smyth
 

A record created
 

98770 (system-
generated)
 

CA4140
(system-
generated)
 

N/A
 

N/A
 

John Smyth
 

Create a record,
 pass in OS/
OSR on primary
object
 

SourceSystem:
Siebel CRM
 
SourceSystemReferenceValue:
3-0007
 
CEOName: John
Smyth
 

A record created
 

98771 (system-
generated)
 

CF380A
(system-
generated)
 

Siebel CRM
 

3-0007
 

John Smyth
 

Update data
attribute on
existing record,
 using PK to
identify the
record
 

PartyId : 98769
 
CEOName:
Soloman
 

Record updated
 

98769
 

N/A
 

N/A
 

N/A
 

Soloman
 

Update data
attribute on
existing record,
 using OS/OSR
to identify the
record
 

SourceSystem:
Siebel CRM
 
SourceSystemReferenceValue:
3-0007
 
CEOName:
Soloman
 

Record updated
 

98771
 

N/A
 

Siebel CRM
 

3-0007
 

Soloman
 

Delete existing
record, using PK
to identify the
record
 

PartyId : 98769
 

Record deleted
 

98769
 

N/A
 

N/A
 

N/A
 

N/A
 

Delete existing
record, using
PUID to identify
the record
 

PartyNumber :
CA4140
 

Record deleted
 

98770
 

CA4140
 

N/A
 

N/A
 

N/A
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Use Case Source file
contents

Description PK PUID OS OSR Non-key Data

Delete existing
record, using
OS/OSR to
identify the
record
 

SourceSystem:
Siebel CRM
 
SourceSystemReferenceValue:
3-0007
 

Record deleted
 

98771
 

N/A
 

Siebel CRM
 

3-0007
 

N/A
 

Scenario B shows the different ways of creating child records, updating and deleting relationship to the parent record.
Here account is the parent and address is the child object. The following image and tables highlight the use cases for
this scenario:

Scenario B for alternate key import
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Column Meaning

PartyId
 

Primary key. Value comes from system-generated document sequence number. Never null.
 

PartyNumber
 

PUID. When record is created value is either passed in or system-generated. Never null.
 

SourceSystem
 

Source system name. Can be null.
 

SourceSystemReferenceValue
 

Source system reference identifier. Can be null.
 

CEOName
 

This is a non-key data attribute on the object. Can be null.
 

PartyId
 

Foreign key to the parent record. This value contains the PK of the record in the parent object.
 

PartyNumber
 

Foreign key to the parent record. This value contains the PUID of the record in the parent object.
 

AddressNumber
 

This value contains the PUID of the record in the child object.
 

PartySourceSystem
 

Source system value of the parent object.
 

PartySourceSystemReferenceValue
 

Source system reference value of the parent object.
 

Use Case Source
file
contents

DescriptionPK PUID Parent
PUID

Parent
OS

Parent
OSR

OS OSR Non-key
Data

Foreign
Key

Create
a child
record,
 pass in
custom
PUID and
parent
object PK
value
 

PartyNumber:
CA2700
 
CEOName:
Rhode
 
PartyId:
98770
 

A child
record is
created,
relationship
to
parent is
established
through
PK
 

5001
(system-
generated)
 

CA2700
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

Rhode
 

98770
 

Create
a child
record,
 pass in
parent
object
PUID
value
 

CEOName:
Rhode
 
PartyNumber:
CA2700
 

A child
record is
created,
relationship
to
parent is
established
through
PUID
 

5002
(system-
generated)
 

system-
generated
 

CA2700
 

N/A
 

N/A
 

N/A
 

N/A
 

Rhode
 

N/A
 

Update
the
relationship
to point to

PartyNumber:
CA2700
 

Existing
child
record
updated

5001
 

CA2700
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

Rhode
 

98772
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Use Case Source
file
contents

DescriptionPK PUID Parent
PUID

Parent
OS

Parent
OSR

OS OSR Non-key
Data

Foreign
Key

a different
parent,
 using the
PUID of
the child
as the key
 

AddressNumber:
CF383
 

relationship
to a new
parent
established
through
PUID
 

Delete the
relationship
to the
parent
 

PartyId:
5002
 

ERROR
- child
record
should
not exist
stand
alone.
Must have
relationship
to a
parent.
(Address
object
is an
exception
to this.)
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

Create
a child
record,
 pass in
parent
object
OS/OSR
value
 

PartySourceSystem:
Siebel
CRM
PartySourceSystemReferenceValue:
3-0001
SourceSystem:
Siebel
CRM
SourceSystemReferenceValue:
3-9001
 

A child
record is
created,
relationship
to
parent is
established
through
OS/OSR
 

system-
generated
 

CA2701
 

N/A
 

Siebel
CRM
 

3-0001
 

Siebel
CRM
 

3-9001
 

N/A
 

N/A
 

Create
a child
record,
 pass in
parent
object
PUID
value
 

PartyNumber:
CDRM-2001
 

A child
record is
created,
relationship
to
parent is
established
through
Parent
PUID
 

system-
generated
 

CA2702
 

CDRM-2001
 

N/A
 

N/A
 

Siebel
CRM
 

3-9002
 

N/A
 

N/A
 

Create
a child
record,
 pass in
parent
object
foreign
key value
 

PartyId:
1234
 

A child
record is
created,
relationship
to
parent is
established
through
foreign
key
 

system-
generated
 

CA2703
 

N/A
 

N/A
 

N/A
 

Siebel
CRM
 

3-9003
 

N/A
 

1234
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Use Case Source
file
contents

DescriptionPK PUID Parent
PUID

Parent
OS

Parent
OSR

OS OSR Non-key
Data

Foreign
Key

Delete
child
record
using
PUID to
identify
the record
 

AddressNumber:
CDRM-9001
 

Delete
a child
record
using the
PUID of
the record
 

N/A
 

CDRM-9001
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

Delete
child
record
using OS/
OSR to
identify
the record
 

SourceSystem:
Siebel
CRM
SourceSystemReferenceValue:
3-0007
 

Delete
a child
record
using OS
and OSR
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

Siebel
CRM
 

3-0007
 

N/A
 

N/A
 

Delete
child
record
using
primary
key
 

AddressId:
9898989
 

Delete
a child
record
using
primary
key
 

9898989
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

N/A
 

Import Management and Access Groups  
If you're using access groups to manage your users access to data, and if you want to import business data into your
Sales and Service applications, review the information in this topic.

When you use the Import Management functionality to import data for business objects that have child objects, for
example, opportunities or accounts, you have to import the CSV file for the parent object first so that the parent records
exist before you import the child object records. If you’re using access groups for data access, once the parent object
is successfully imported, you must also run the Perform Object Sharing Rules Assignment process to make sure the
parent records are correctly assigned and available. Then you can import the child object records.

If you were provisioned with the sales application for the first time in Update 22B or later, system access groups and
object sharing rules are used to manage your users access to data by default. So you must always run the Perform
Object Sharing Rules Assignment process before you import child object records for parent object records.

See Run the Perform Object Sharing Rule Assignment process.
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Overview of Oracle WebCenter Content Document
Transfer Utility  
The WebCenter Content Document Transfer Utility is a set of command line interface tools that provide capabilities to
import and export content from a local system to the Oracle WebCenter Content Server.

The tool has the following components:

• The DownloadTool is used to retrieve a content item from Oracle WebCenter Content Server and save its
contents to a local file.

• The UploadTool is used to create a new content item in Oracle WebCenter Content Server based on contents
streamed from a local file.

• The SearchTool is used to locate content items within Oracle WebCenter Content Server matching specific
query criteria.

• The StorageTool is used for migrating applicable Oracle WebCenter Content Server documents from the server's
file system to secure file storage within the Oracle Database.

You can find the details of using each tool, along with sample commands, in the Readme html file downloaded as part
of the tool.

Variants of the Utility
Two forms of the transfer utilities exist:

• The transfer utility based on Remote Intradoc Client (RIDC), (oracle.ucm.fa_client) which is a feature-set Java
library that encapsulates Oracle WebCenter Content RIDC and uses standard HTTPS to communicate with the
Oracle WebCenter Content server. Tools belonging to the RIDC-based transfer utility begin with the package
oracle.ucm.client, such as oracle.ucm.client.UploadTool. This utility has no additional library dependencies. The
feature-set Java library that bundles the RIDC-based transfer utility repackages the RIDC classes and leverages
the HTTP client provided by the Java Virtual Machine (JVM).

• The generic soap-based transfer utility (oracle.ucm.fa_genericclient) which requires the Java Required Files
(JRF) web service supporting libraries and uses Java API for XML Web Services (JAX/WS) over HTTPS to
communicate with the Oracle WebCenter Content server. Tools belonging to the generic soap-based transfer
utility begin with the package oracle.ucm.idcws.client, such as oracle.ucm.idcws.client.UploadTool. This utility
has dependencies on the JRF JAX/WS web service client stack and Oracle Web Services Manager (WSM). The
stack in turn also looks for Middleware Platform Security and Audit Framework configuration files and libraries,
and logs warnings if these are unavailable.

Downloading the Tool
You can download the Oracle WebCenter Content Document Transfer Utility by navigating to the My Oracle Support
(support.oracle.com) document Oracle WebCenter Content Document Transfer Utility Readme (document ID 1624063.1).
Once downloaded, you can run the tool by navigating to the ridc folder after extraction.
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Command Documentation
Documentation for the tools is contained in the root directory of the tool download ZIP in a file named "WebCenter
Content Document Transfer Utility Readme.html". This documentation describes various program options available,
along with requirements such as Java version and supporting libraries required. A change log is included as well.
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3  Get Started with Import

How do I import data?  
Use Import Management from the Tools work area, to import data from text files. This topic is your guide to importing
data in sales, service, and incentive compensation.

You can create, update, or delete records through import.

The import options and other details differ by the type of data that you're importing. Before importing, understand how
the data in your file maps to the attributes in Oracle Applications Cloud and what values are expected in the import file.
The data records in the CSV source file may not be processed in the listed order. To learn how to monitor the status of
your import, see the topic How You Monitor Your Import Activities in the Related Topics section.

Note:  Don't submit duplicate import jobs for the same import object as they create duplicate object records.

To help you get started, you can use the example import object templates described in the related topics.

Import Data from a File
To import data:

1. Click Tools > Import Management.
2. On the Manage Imports  page, click the Create Import Activity button.
3. On the Enter Import Options page provide values for each field as shown in the following table:

Field Description of the value

Name
 

Name of the import.
 

Object
 

Object that you're importing.
 
If you can't find your object, then search for it by clicking the Search link. In the Search and
Select dialog box, enter the object name in the Object text box and click the Search button.
Select your object from the result list and click OK.
 
You can also use the advanced search option by clicking the Advanced button. Here you can
search based on various filter criteria such as object name, Attachment supported, creation
date, and so on.
 
If the object you're importing isn't listed then verify if you have the roles and privileges required
to import the object. For information on the roles, see the topic Roles Required for Import and
Export Management referenced in the Related Topics section.
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Field Description of the value

Attachment Object
 

To import an attachment for an existing object record in the database select the Attachments
object from the Object drop-down list. Next select the object from the Attachment Object
drop-down list.
 
For more details on importing attachments, review the topic Import Attachments.
 

File Name
 

Browse and select a text file in CSV format. The first row of the source file is treated as the
header row. Provide a file name within 40 characters.
 

Note:
If your source file has more than 50,000 records, then you must manually split the file into
several smaller files with less than 50,000 records each. The file import page only permits
50,000 records for each import job. Alternatively, you can use the External Cloud Data
Loader Client, which can accept files with more than 50,000 records. See the My Oracle
Support (support.oracle.com) document External Data Loader Client (document ID 2325249.1)
for more information about this tool.
 

Import Object Hierarchy
 

To import a hierarchy of objects, such as child and grandchild objects, click on the Import
Object Hierarchy link after you upload the source file for the parent object. Next select the
Enabled check box for the child object you want to import, and select the related source file.
 

4. Optionally, to set additional import configurations, click the Advanced Options section. Here you can configure
settings under Source File, Import Options, or Create Schedule sections.

a. In the Source File and Import Options regions, some of the options in the following table might not be
available depending on the object that you're importing:

Option Description

Import Mode
 

You can specify whether you want to create and update records or update them only.
 

- Update and create records - a new record is created if a matching record isn't
found. This is the default option.

- Create records - all the records in the file are new records which have to be created.
If there are any existing matching records, then they're marked as errors.

- Delete records - all the records in the file are deleted.

Enable High-Volume Import
 

The high-volume import mode is designed to import millions of records at once. This
mode doesn't trigger any custom logic configured through the application composer. For
a list of supported objects, see the topic Data Import Options.
 
By default, this mode is enabled for the supported objects.
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Option Description

Note:
If ZCA_FILE_IMPORT_ENABLE_CUSTOM_BUSINESS_LOGIC is set to “Yes”, then you
won’t be able to use High Volume import.
 

 

Enable Survivorship
 

Survivorship on update is available for Account, Organization, Contact, and Person. The
check box is visible if the attribute survivorship is configured on the objects. You can use
high-volume import mode, only when the survivorship configuration uses only Source
Confidence. You can't use the high-volume import mode when Data Quality Rules are
enabled.
 

Notification email
 

The email of the individual who receives import processing notifications. The user
submitting the import receives an email notification automatically. To have more than
one email recipient, separate the email addresses with a semicolon. If you don't want to
receive the notification, then set the profile option ORA_ZCA_IMPEXP_ENABLE_EMAIL_
NOTIFY to 'N' at user level.
 

Enable Custom Business Logic
 

If you select this check box, then any custom triggers and validations configured for
the object are enabled. This may affect import performance, because of configurations.
Hence, disable this option for better performance.
 
To enable this check box by default, set the profile option ZCA_FILE_IMPORT_ENABLE_
CUSTOM_BUSINESS_LOGIC to 'Yes' by navigating to the Manage Administrator Profile
Values task.

Note:
If ZCA_FILE_IMPORT_ENABLE_CUSTOM_BUSINESS_LOGIC is set to “Yes”, then you
won’t be able to use High Volume import.
 

 

Note:
This selection has no effect on events and object workflows, and is applicable only on
triggers and validations.
 

Delimiter
 

If your file doesn't use a comma to separate values, then select the correct delimiter in the
Delimiter drop-down list. Possible values are:
 

- Caret Symbol

- Closing Curly Bracket

- Closing Parenthesis

- Closing Square Bracket

- Colon
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Option Description

- Comma

- Exclamatory Mark

- Minus

- Opening Curly Bracket

- Opening Parenthesis

- Opening Square Bracket

- Pipe Symbol

- Plus

- Question Mark

- Semi-Colon

- Star Symbol

- Tilde Symbol

Decimal Separator
 

The decimal separator used in your import file.
 

Date Format
 

The format of the date fields in your file.
 

Time Stamp Format
 

The format of the time fields in your file.
 

File Encoding
 

The format in which your source file is encoded. The possible values are:

- Chinese Simplified - GB, CP936

- Chinese Traditional - CP950

- Eastern European - Win, CP1250

- Greek - MS Windows, CP932

- Japanese - Shift- JIS, CP932

- Unicode - UTF-16

- Unicode- UTF-16BE, Mac, Unix

- Unicode - UTF-16LE, MS Windows

- Unicode - UTF-8

- Western European - Win, CP1252

Note:  The above mentioned encoding formats are the only ones supported. Importing
file with any other format, such as ANSI, will cause unexpected characters to be
imported.

 

b. In the Create Schedule region, schedule the import to run immediately or at a future date. If you select a
future date, then provide the date and time to start the import.

You can save the Advanced Options for subsequent reuse by clicking on the Save advance options link in the UI.
The options will be retained till you click on the Reset link and reset the options to application defaults.

Note:  All fields except Import Mode, Enable Custom business Logic, Enable High-Volume Import, Enable
Survivorship Logic, Schedule Mode, and Schedule Start Time will be saved.
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5. Click Next. The Map Fields page shows the first row of the data from your source file. By default, the
application tries to automatically map each of the source file columns to the appropriate target object attribute.
If some of the columns in your file couldn't be mapped, then drag the target attribute onto the Attribute
Display Name column under the Source File region.

The data in unmapped columns aren't imported.

You can save your import map by clicking on Save As in the Create Import Activity page. You can use the saved
map for future imports. You can view your saved maps by clicking on the Import Mapping drop down list in the
Create Import Activity page.

Also, you can select and then edit your saved maps for the specific objects in the Import Objects page.
6. You select a predefined mapping from the list of available mappings under the Import Mapping drop-down

list. If you're reusing an import mapping, then both the source and target columns are already populated.

Leave the Attribute Display Name field blank for any column that you don't want to import.

Click Validate Data to check the field mapping.
7. In the case of hierarchical import, you can see the mapping information for child objects in the subsequent

tabs. Note that data validation isn't done for these objects.
8. Click Next. On the Review and Submit page, review the import activity configuration. If you had not run the

prevalidation on the Map Fields page, then you get a notification message to run the validation process. You
can view any unmapped columns of parent or child objects on this page.

9. Click Validate Data to check the data in your source file. Validation errors, if any, are displayed on the Mapping
Validation screen. If you get warnings about unmapped columns, then you can ignore these columns, and
proceed to submit the import job. Validations are for informational purposes and applicable only for low-
volume imports.

Note:  In import activity with single CSV hierarchical records, explicit validation from the mapping UI isn't
supported. For example, while importing the sales territory object, if there are matching values for the
attributes ParentUniqueTerritoryNumber and UniqueTerritoryNumber, then validation isn't supported.

Note:  During the import validation process on the Mapping page, the following custom triggers aren't
supported:

◦ Before InValidate

◦ Before Remove

◦ Before Insert in Database

◦ Before Update in Database

◦ Before Delete in Database

◦ Before Rollback in Database

◦ After Changes Posted to Database

10. Click Submit to queue the import.

Note that business events aren't fired when using Import Management.
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Automating and Scheduling Import Jobs
You can automate import jobs using the import REST services. The import REST services let you manage import
activities, manage activity maps, and export object metadata. You can use an external scheduler that uses these REST
services to run recurring import jobs, create and run import activities, manage maps, and review object metadata.

You can use the Oracle WebCenter Content Document Transfer Utility to manage the import files used by the scheduler.
You can download the Oracle WebCenter Content Document Transfer Utility by navigating to the My Oracle Support
(support.oracle.com) document Oracle WebCenter Content Document Transfer Utility Readme (document ID 1624063.1).
Once downloaded, you can run the tool by navigating to the ridc folder after extraction.

For detailed instructions on automating and scheduling file import using REST API, see Oracle CX Sales and Fusion
Service: Automating and Scheduling File Import Activity Using REST API (Doc ID 2308691.1) article on My Oracle Support
(support.oracle.com).

Set Up Event Notifications for Resources
In file-based data import, the SendCredentialsEmailFlag attribute allowed the import to specify the notification setting
for each employee resource. You can do this in Import Management using the User Category option but this applies to
all resources in a single import.

To set up notifications for all events:

1. Navigate to Tools >  Security Console on the home page.
2. Click the User Categories tab.
3. Click DEFAULT. Click the Notifications tab.
4. Click the Edit button. If you want to turn on all notifications, then select the Enable Notifications check box

under the Notification Preferences heading.
5. Click the Save button.
6. Click the Done button.

To set up notifications for a specific event:

1. Navigate to Tools >  Security Console on the home page.
2. Click the User Categories tab.
3. Click DEFAULT. Click the Notifications tab.
4. Click the Edit button.
5. If you want to turn on a specific event notifications, click the template for the desired event.
6. On the Template Information page, select the Enabled check box and click Save and Close.
7. Click the Save button.
8. Click the Done button.

Import FCLs and DCLs
Setting FCL Field values

You must pass the lookup code in order to set the FCL field using import management.

Setting FCL and DCL Fields to Null

You must pass #NULL value for the FCL field in order to nullify a value for an FCL using Import Management.

Here is an example to nullify TargetGlobalPJDetailFlag1_c field:
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PartyId TargetGlobalPJDetailFlag1_c

100000001527765
 

#NULL
 

Related Topics
• How do I import attachments?

• How do I monitor import activities?

• How do I map import fields?

• What are the available data import options?

• What are the roles required to import or export data?

How do I delete data?  
This topic shows how to delete data using import management

To delete data:

1. Create an import activity as described in the topic How do I import data?
2. Enter a name for your import.
3. In the Object drop-down list, select the Object.
4. Click Advanced Options and under the Import Options section, select Delete records from the Import Mode

drop-down list. Click Next.
5. On the Map Fields page, map the source and target attributes.
6. Click Next to navigate to the Review and Submit page. Review the import activity configuration and click

Submit to activate the import. You can view the status of the submitted import on the Manage Imports page.

Note:  The identifier that you use to delete a record should be unique across the database.

Related Topics
• How do I import data?

• Delete Attachments

• Delete Notes

• Delete Custom Object Data

How do I import attachments?  
You can import attachments associated with any supported object.
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Supported Objects and File Types
The following objects support importing attachments:

• Account

• Activity

• Asset

• Business Plan

• Contact

• Custom Object

• Deal Registration

• Household

• Message

• Objective

• Opportunity

• Opportunity Revenue

• Partner

• Partner Program

• Product

• Sales Lead

• Sales Lead Product

• Service Request

The following file types are supported for attachment files:

• CSV

• DOC

• DOCX

• JPG

• PDF

• PNG

• PPTX

• TIF

• TEXT

• XLSX

• XML

• ZIP

How to Create ZIP File
To import an attachment, you must create a ZIP file that contains the source data file and optionally one or more
attachment files. Make sure you always name the source file as 'Attachment.csv'. You must mention each of the
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attachment file names in the Attachment.csv file. The Attachment.zip file has the structure shown in the following
image:

Here are the examples for the attachment.csv file shown in purple box in the image above:

Pk1Value ObjectPuid FileName Url

100100004247330
 

  http://www.yahoo.com
 

100100004247330
 

 Clouds.jpg
 

 

100100004247330  Taxdocs.docx  
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Pk1Value ObjectPuid FileName Url

  

 CDRM_6493
 

 http://www.google.com
 

 CDRM_6493
 

Holidays.pdf
 

 

Note:
• Pk1Value and ObjectPuid column values uniquely identify an existing object record. FileName indicates the

name of attachment files. Url indicates the value of URL attachment to import.

• The exact file name must exist in the zip file such as Document.pdf

• The attachment ZIP file name can include characters such as parenthesis (), ampersand (&), dots (.),
and apostrophe (') only. You shouldn't have more than one period (.) in your attachment name. Also, the
rootname.extension shouldn't be more than 80 characters.

• An attachment can only be associated with an existing record of the object. A single record can be associated
with multiple attachments by having multiple rows in the CSV file. You can import any number of attachments
in an import job, but the ZIP file should not exceed 250 MB in size.

• A record in the CSV file can't have values for both FileName and Url columns. You can pass either the Primary
key or the PUID for an object record. If you pass both Primary key and PUID values, then Primary key will be
considered and PUID will be ignored.

• The AttachedDocumentId should be left blank.

• The DatabaseTitle shouldn't be higher than 79 character.

How to Import Attachments
To import attachments:

1. Click Tools > Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. On the Enter Import Options page, enter a name for your import. From the Object drop-down list select

Attachments.
4. In the Attachment Object drop-down list that appears, select the object associated with the attachment.
5. Select the ZIP file that you created in the previous section.
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6. Click Next. On the Map Fields page, click the Apply button next to the Import Mapping drop-down list to map
the source and target attributes automatically.

7. Click Next to navigate to the Review and Submit page.

Review the import activity configuration and click Submit to activate the import. The Manage Imports page shows
the status of the submitted import. The topic Import Data in the related topics section contains more details about the
import process.

Related Topics
• How do I import data?

Delete Attachments  
This topic shows how to delete attachments using Import Management. You can delete attachments associated with
any supported object.

Before You Start
To delete attachments during an import activity, you need the source object ID (either the parent public unique identifier
or the primary key).

Steps to Retrieve the Source Object IDs

• Run a GET query on the source object (with valid filter criteria) to obtain the correct source object keys (such as
public unique identifier, primary key and so on). For example, you can retrieve PartyNumber and Party ID of the
account object using GET query on the account object.

• Alternatively you can submit an export activity using Export Management on the source object (with valid filter
criteria) to obtain the correct Source object keys.

Delete Attachments Using Import Management
To delete attachments using Import Management:

1. Create an import activity as described in the topic Import Data.
2. Enter a name for your import. In the Object drop-down list select Attachment.
3. In the Attachment Object drop-down list, select the object associated with the attachment.
4. Select the ZIP file that contains the attachment files and the source data file with the object records information

for which you want to delete the attachment.
5. Click Advanced Options and under the Import Options section, select Delete records from the Import Mode

drop-down list.
6. The ZIP file must contain at least a file named Attachment.CSV, and optionally one or more attachment files.

The Attachment. CSV file has the following format:

Pk1Value ObjectPuid FileName

300100111735265 N/A ReadMe.txt
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Pk1Value ObjectPuid FileName

   

N/A
 

CDRM_L1011
 

N/A
 

300100111735265
 

N/A
 

N/A
 

N/A
 

CDRM_L1212
 

Template.txt
 

Pk1Value and ObjectPuid column values uniquely identify an existing object record. FileName indicates the
name of attachment files to delete during the import.

You can associate an attachment only with an existing object record. A single record can be associated with
multiple attachments by having multiple rows in the CSV file. There's no limit on the number of attachments
that can be deleted in a single import job. However, the size of the attachment ZIP file can't exceed 250 MB.

Note:  You can pass either the Primary key or the Public Unique Identifier, but not both for an object record.

7. Click Next and map the source and target attributes.
8. Click Next to navigate to the Review and Submit page. Review the import activity configuration and click

Submit to activate the import. You can view the status of the submitted import on the Manage Imports page.

Related Topics
• How do I import data?

• How do I import attachments?

How do I import notes?  
This topic shows how to import notes using the Import Management feature. You can attach a note to an existing object
record.

Types of Notes
Note can be one of the following types:

• GENERAL

• REFERENCE

• SPECIAL

A note with line break may not be imported with the correct formatting. To ensure you import the content with the line
breaks, insert a <br> instead of a line break in the note. Refer to Notes Imported Does Not Show In Correct Format In UI 
for more information.
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Before You Start
Before importing the note, make sure to import the object record to attach the note. You can import an object, such
as Sales Lead, using Import Management. See the topic Import Data for the details on importing. After the import
completes, note the primary key and PUID of the record created using the success log file.

How You Import the Note
You're set to import the note and associate with the object record. Use the following steps to import notes using Import
Management.

1. Click Tools > Import Management.
2. On the Manage Imports page, click the Create Import Activity button. On the Enter Import Options page,

enter a name for your import. In the Object drop-down list select Note.
3. In the Note Object drop-down list that appears, select the object to associate with the note, such as Sales Lead.
4. Create the note CSV file in the following format.

ObjectPuid or SourceObjectId NoteTxt NoteTypeCode

CDRM_82807 or 300100181729328
 

A sample note text
 

SPECIAL
 

You must provide either ObjectPuid or SourceObjectId in the source file, but not both.

ObjectPuid - The public unique identifier of the object. In case of Sales Lead, this refers to the LeadNumber
value.

SourceObjectId - The primary key of the object. For Sales Lead, this refers to the LeadID value.

NoteTxt - The note entry.

NoteTypeCode - The category of the note. The possible values are GENERAL, REFERENCE, and SPECIAL.
5. Browse the source CSV file and create the import activity.
6. Review the import activity configuration and click submit to activate the import. The Manage Imports page

shows the status of the submitted import.

Delete Notes  
This topic shows how to delete notes using Import Management.

To delete notes:

1. Create an import activity as described in the topic Import Data.
2. Enter a name for your import. In the Object drop-down list, select Note.
3. In the Note Object drop-down list, select the object associated with the note.
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4. Create your source file as per following table:

NoteId NoteTxt

300100177503663
 

Note Text
 

Here NoteId uniquely identifies the note record, and NoteTxt is the text associated.
5. Click Advanced Options and under the Import Options section, select Delete records from the Import Mode

drop-down list. Click Next.
6. On the Map Fields page, map the source and target attributes.
7. Click Next to navigate to the Review and Submit page. Review the import activity configuration and click Submit

to activate the import. You can view the status of the submitted import on the Manage Imports page.

Note:  You can use the same method to update a note. However, select the Import Mode 'Update and create
records'.

Related Topics
• How do I import data?

Manage Hierarchical Import Templates  
Hierarchical import templates contain import object hierarchy and advanced import job configurations that you can
reuse every time you create an import.

Hierarchical import template is a CSV file that contains information about the import activity such as import object
name, object hierarchy details, and advanced import configurations. This topic describes the various options to manage
these templates.

Why use Hierarchical Import Templates
Templates have the following benefits:

• They are useful while creating hierarchical imports. You can reuse the template file every time you create an
import with the same object hierarchy and import configuration.

• You can easily migrate the templates from one environment to another.

• Administrators can create a set of templates that can then be downloaded and reused at multiple sites.

Create Hierarchical Import Template
To create a template file:

1. Navigate to Tools > Import Management > Import Configuration > Manage Template > Create Template.
2. On the Create Template page, provide the template summary information such as name, object details, and

the description.
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3. Select the import object from the Object drop-down list and click the Import Object Hierarchy link to select
the object hierarchy. Select the Enabled check box for each object to import. You can select the child objects
under the parent hierarchy only after selecting parent object.

4. Select the advanced options for your import and click Save and Close.

Upload Hierarchical Import Template
You can upload the templates to use them across environments. For example, you might want to download the template
from one environment, and upload to another environment.

You can upload a template file in CSV format using the Upload Template button on the Manage Template page.

Edit Hierarchical Import Template
To edit an existing template:

1. On the Manage Template page, click the template number link for the template to edit.
2. On the Template Summary page, you can change the object in the hierarchy by selecting the Enabled check

box.
3. After making any desired changes on the page, click Save and Close.

Copy, Download, or Delete a Hierarchical Import Template
To copy, download, or delete a template:

1. On the Manage Template page, click the template number link for the required template.
2. On the Template Summary page, under the Actions menu, you can find the options to copy, download, or

delete your template file.
3. If you want to copy a template, click Copy Template. A copy of the currently selected template is created

and the template name is prefixed with the text 'Copy of'. Make any required changes to the template name,
description, and advanced import options. Click Save and Close.

4. To download a template file, click the Download Template option from the Actions menu. You can save the file
as a CSV file to your directory.

5. To delete a template, click the Delete Template option from the Actions menu. Only the user who created the
template can delete it.

Import Using Hierarchical Import Template Files
To create an import activity using a template file:

1. Navigate to Tools > Import Management > Import from Template.
2. The Template Summary section shows the list of available templates for use, along with the top-level import

object. When you select a template, the Hierarchy Objects section shows the object hierarchy for the template.
3. Select your template and click Continue with Template. On the Enter Import Options page, your object

hierarchy is preselected and the advanced import configurations are already selected for you. If required, you
can change these configurations for your import.

4. Upload the CSV files for your selected objects and click Next.
5. Provide the mapping information for your import on the Map Fields page.
6. Review your import details on the Review and Submit page, and submit. For more details on creating an

import, see the topics Example of Importing Contracts Using Hierarchical Import and Import Data.
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Related Topics
• How do I import data?

• Example of Importing Contracts Using Hierarchical Import

Example of Importing Contracts Using Hierarchical
Import  
You can use Import Management to import objects with complex hierarchies and relationships, such as Territories,
Contracts, and Subscriptions. The hierarchical import feature helps you to import a hierarchy of objects.

You can set up a parent-child hierarchy of objects, define the CSV files to import for each hierarchy node, start, track,
and monitor the status of the overall import job. This example explains how to import Contracts hierarchical data using
hierarchical import. Following is the schematic of object hierarchy:

• Contract

◦ Contract Line

◦ Contract Party

- Contract Party Contact

Import Contracts Data
To import the Contract object, its children Contract Line and Contract Party objects, and the Contract Party Contact
grandchild object using hierarchical import:

1. Click Tools > Import Management  > Create Import Activity.
2. On the Enter Import Options page, select the parent Contract object, enter the import name, and select the

source CSV file for Contract object. For more information about creating an import, see the topic Import Data.
3. Click the Import Object Hierarchy link. Now you can see the object hierarchy for Contract, showing the child

and grandchild objects. Select the Enabled check box for the objects you want to import. For this example,
select the check boxes for Contract Line, Contract Party, and the Contract Party Contact objects in that order.

4. Select the CSV file for each of these objects and click Next.
5. On the Map Fields page, the application tries to automatically map the target attributes to the source file

attributes for each object. For the attributes that couldn't be mapped, you should map manually by clicking the
Save As button. You can see the mapping information for child objects on the subsequent tabs. After mapping
each object attribute, click Next.

6. After reviewing the import information on the Review and Submit page, submit the import.
7. On the Manage Imports page, you can see the status of import for parent, child, and grandchild objects in the

form of tree structure.
8. You can verify your contracts after import completes by navigating to Contract Management > Contracts.

Related Topics
• How do I import data?
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Import Descriptive Flexfields  
A flexfield is a flexible data field that your organization can configure according to your business needs. Descriptive
Flexfields (DFF) capture additional business information such as the name of the company's owner.

DFF's data are stored in the attributes. These are fixed set of custom fields and can be of data type VARCHAR2, NUMBER,
DATE, or TIMESTAMP.

For more information on DFFs see the chapter Flexfields in the guides Oracle Applications Cloud Configuring
and Extending Applications (http://www.oracle.com/pls/topic/lookup?ctx=cloud&id=OAEXT) and Oracle Sales
Implementing Incentive Compensation (http://www.oracle.com/pls/topic/lookup?ctx=cloud&id=OAWIC) available on
the Help Center.

Objects Supporting the DFF Import
The objects that support the DFF fields are:

• Contract (child object is Contract Header Descriptive Flexfield)

• Contract Line (child object is Contract Line Descriptive Flexfield)

• Contract Party (child object is Contract Party Descriptive Flexfield)

• Contract Party Contact (child object is Contract Party Contact Flexfield)

How you Register new Objects for DFF Support
Follow these steps to register any new object for DFF support:

1. In the Navigator, click Tools  > Import Management.
2. On the Manage Imports page, click the Create Import Activity button.
3. Create an import by selecting the Contract object from the drop-down list. For more information on creating an

import, see the topic Import Data.
4. Once the import completes, create another import by selecting the Contract Header Descriptive Flexfield child

object from the drop-down list.
5. In the source CSV file, include the ContractPuid header attribute and provide the value you entered for the

parent object import. For each DFF field, provide its Table Column name in the header. Select the source CSV
file and click Next.

6. Click Next to go to the Map Fields page. Here you can see only the AttributeNames and not the DFF attribute
labels. Map the attributes and click Next. Submit the import on the Review and Submit page.

7. To verify your contracts after import completes, navigate to Contract Management  > Contracts.

Note:  Only high-volume import supports importing DFF fields.

37



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 3
Get Started with Import

Related Topics
• How do I import data?

• Import Your Contract Line Descriptive Flexfield Data

• How do I import contract header descriptive flexfield data?

• Import Your Contract Party Contact Descriptive Flexfield Data

• Import Your Contract Party Descriptive Flexfield Data

• Flexfield Components

• Overview of Flexfields

How do I generate the diagnostics log for import?  
The diagnostic log files provide complete information about an import job and its errors. If you have errors in your
import job, then provide the diagnostic logs to technical support to help them resolve the issue.

You can generate the diagnostic logs by clicking the Generate button. You can then attach the log files (in ZIP format) to
the Service Request (SR). This helps technical support to resolve the issues.

To generate the diagnostic logs for an import:

1. Click Tools > Import Management.
2. On the Manage Imports  page, click the Name link for your import that has failed.
3. On the Import Status page, click the Generate Diagnostics button in the Action menu to generate the

diagnostics files.
See the Import Attachments section for the link to download the generated files. Click Download under the Actions
column to download the file. For more information about the files, click on the details icon.

Import Data with Special Characters  
You need to format the data, if your import file includes special characters. Follow the methods described in this topic to
ensure that source data is properly parsed and imported by Sales and Fusion Service.

Build the CSV File
To build your CSV file for importing data:

1. Click Tools > Import Management > Import Objects.
2. On the Import Object Details page, click the Download icon to save the CSV template file for your object to your

desktop.
3. You can edit the file to include only those fields that you import. For more information on using the import

object template, see the topic Use Import Object Templates to Import Data.
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Enter Data in the CSV File
After creating the CSV file, you must enter the data to be imported. Some of the special characters are quotation
marks(") and a comma(,). You must prefix the special characters with quotation marks(").This list shows the different
formats in which the input data can be entered for the Lead object CSV file and how it's interpreted due to the presence
of special characters. LeadName and LeadNumber are the header fields for the file.

This table lists five Lead records of a CSV file, each with the LeadName first, followed by the LeadNumber (120, 121, and
so on).

LeadName LeadNumber

Mark Twain lead
 

120
 

"Twain "secondary" lead"
 

121
 

Twain, Mark
 

122
 

Twain, Mark "Spring 2015" lead
 

123
 

"Twain "Fall 2014" lead
 

124
 

You can use escape characters for the Lead Name source data records, as shown in this table.

Row Number Source Data for
LeadName

How LeadName is
Written to Database
if no Escape
Characters are Added

Data with Escape
Characters to
Preserve Original
Data

How LeadName is
Written to Database
When Escape
Characters are
Included

Comment Regarding
Escape Characters

1
 

Mark Twain lead
 

Mark Twain lead
 

Not applicable
 

Not applicable
 

No escape characters
are needed as the
source data contains
no special characters.
 

2
 

"Twain "secondary"
lead"
 

Twain secondary"
lead"
 

"""Twain ""secondary""
lead""",121
 

"Twain "secondary"
lead"
 

The two series of three
quotation mark each:
 
 

• The quotation
marks
surrounding
the field which
is required to
precede the
quotation marks
in the source
data

• The quotation
marks in the
source data
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Row Number Source Data for
LeadName

How LeadName is
Written to Database
if no Escape
Characters are Added

Data with Escape
Characters to
Preserve Original
Data

How LeadName is
Written to Database
When Escape
Characters are
Included

Comment Regarding
Escape Characters

3
 

Twain, Mark
 

Twain
 

"Twain, Mark",122
 

Twain, Mark
 

Double quotation
mark is required to
surround the field
entry, as a comma
is in the source
data. No additional
escape character is
required to precede
the comma.
 

4
 

Twain, Mark "Spring
2015" lead
 

Twain
 

"Twain, Mark ""Spring
2015"" lead",123
 

Twain, Mark "Spring
2015" lead
 

A double quotation
mark is required to
surround the field
entry, as at least one
special character is
present in the source
data. Every double
quotation mark in the
source data requires a
double quotation mark
escape character. No
additional escape
character is required
to precede the
comma.
 

5
 

"Twain "Fall 2014" lead
 

Twain Fall 2014" lead
 

"""Twain ""Fall 2014""
lead",124
 

"Twain "Fall 2014" lead
 

Although the missing
end quotation mark
in the source data
is likely a typo, the
source data must be
written as it appears.
Enter three double
quotation marks at the
beginning, but only a
single (surrounding)
double quotation mark
at the end.
 

• If the source data contains at least one special character, the field of source data must be entered in double
quotation marks in the CSV file.

• If the data for a field contains separator such as a comma (,), you must enclose the content within two double
quotation marks.

• If the first field has a special character at the beginning but not any matching special character at the end, the
content of the second field will also be considered as part of the first field, and the second field is blank. You
must provide a matching escape character.

• If you don't precede the special characters by an escape character, the import process may write incorrect data
for a field, or incorrectly write data to the subsequent fields.
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When you import files with special characters, the special characters are converted into unreadable characters. You can
resolve the issues by saving the import file in UTF-8 format.To save a file in UTF-8 format:

• Choose File->Save as from the menu.

• In the 'Save as type' drop down > select 'Text (Tab delimited) (*.txt)'

• Select 'Web Options' in the 'Tools'

• Select the 'Encoding' tab.

• In the 'Save this document as:' drop down, select 'Unicode (UTF-8)'"

• Click Save

Related Topics
• Use Import Object Templates to Import Data

• How do I import data?

What are the roles required for import and export
management?  
You require certain duties and roles to perform activities related to import and export management. Oracle ships several
OOTB roles with access to Import and Export data from CX Sales. You can select and use administrator level roles as
needed.

You can get additional information about the duties and roles in the Security Reference for Sales and Fusion Service
guide.

Enhanced Data Privacy
You can only view import and export jobs that you submitted. You can't view the import and export jobs and associated
data files submitted by other users. However, you can still view import jobs as part of the management reporting
hierarchy. Managers can view their directs' imports and exports.

Administrators can configure this by setting the profile option ORA_ZCA_IMPEXP_RESTRICT_USERACCESS  to Y by
navigating to Setup and Maintenance  >  Search >  Manage Administrator Profile Values task  Search for the profile
option code.

Roles for Import and Export
This table lists the set of roles required to import and export top-level objects. The values in brackets are the role codes.
In the case of multiple roles listed, you need any one of the mentioned roles.

Note:  You can import or export a child-level object if you have the role applicable to the parent object.
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Access Groups
 

Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Account
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Action
 

Internal Service Request Administrator
(ORA_SVC_INTERNAL_HELPDESK_
ADMINISTRATION)
 

Service Request Administrator (ORA_SVC_SR_
ADMINISTRATOR)
 

Action Plan
 

Service Request Administrator (ORA_SVC_SR_
ADMINISTRATOR)
 
Internal Service Request Administration
(ORA_SVC_INTERNAL_HELPDESK_
ADMINISTRATION)
 
HR Help Desk Administration (ORA_SVC_
HELPDESK_ADMINISTRATION)
 

Service Request Administrator (ORA_SVC_SR_
ADMINISTRATOR)
 
Internal Service Request Administration
(ORA_SVC_INTERNAL_HELPDESK_
ADMINISTRATION)
 
HR Help Desk Administration (ORA_SVC_
HELPDESK_ADMINISTRATION)
 

Activity
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Sales Manager
(ORA_ZBS_SALES_MANAGER_JOB),
 Sales Representative (ORA_ZBS_SALES_
REPRESENTATIVE_JOB), Channel Administrator
(ORA_ZPM_CHANNEL_ADMINISTRATOR_
JOB), Channel Operations Manager (ORA_
ZPM_CHANNEL_OPERATIONS_MANAGER_
JOB), Marketing Operations Manager
(ORA_MKT_MARKETING_OPERATIONS_
MANAGER_JOB), Channel Partner Portal
Administrator (ORA_ZPM_CHANNEL_
PARTNER_PORTAL_ADMINISTRATOR_
JOB), Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB) Customer Relationship
Management Application Administrator
(ORA_ZCA_CUSTOMER_RELATIONSHIP_
MANAGEMENT_APPLICATION_
ADMINISTRATOR_JOB),
 

Asset
 

Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB),
 Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Attachments
 

FUSION_APPS_CRM_ESS_APPID, FUSION_
APPS_CRM_ODI_APPID, FUSION_APPS_CRM_
SOA_APPID, Trading Community Import Batch
Management (ORA_MANAGE_TRADING_
COMMUNITY_IMPORT_BATCH_DUTY)
 
Sales Lead Processing (ORA_MKL_SALES_
LEAD_PROCESSING_DUTY)

Customer Contract Administrator(ORA_OKC_
CUSTOMER_CONTRACT_ADMINISTRATOR_
JOB), Opportunity Administration (ORA_
MOO_OPPORTUNITY_ADMINISTRATION_
DUTY) , Enterprise Contract Administrator
(ORA_OKC_ENTERPRISE_CONTRACT_
ADMINISTRATOR_JOB), Supplier Contract
Administrator (ORA_OKC_SUPPLIER_
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Corporate Marketing Manager (ORA_MKT_
CORPORATE_MARKETING_MANAGER_JOB)
 
Marketing Analyst (ORA_MKT_MARKETING_
ANALYST_JOB)
 
Marketing Manager (ORA_MKT_MARKETING_
MANAGER_JOB)
 
Marketing Operations Manager (ORA_MKT_
MARKETING_OPERATIONS_MANAGER_JOB)
 
Marketing VP (ORA_MKT_MARKETING_VP_
JOB)
 
Opportunity Administration (ORA_MOO_
OPPORTUNITY_ADMINISTRATION_DUTY)
 
Customer Contract Administrator (ORA_OKC_
CUSTOMER_CONTRACT_ADMINISTRATOR_
JOB)
 
Customer Contract Manager (ORA_OKC_
CUSTOMER_CONTRACT_MANAGER_JOB)
 
Enterprise Contract Administrator (ORA_OKC_
ENTERPRISE_CONTRACT_ADMINISTRATOR_
JOB)
 
Enterprise Contract Manager (ORA_OKC_
ENTERPRISE_CONTRACT_MANAGER_JOB)
 
Supplier Contract Administrator (ORA_OKC_
SUPPLIER_CONTRACT_ADMINISTRATOR_JOB)
 
Supplier Contract Manager (ORA_OKC_
SUPPLIER_CONTRACT_MANAGER_JOB)
 
Subscription Specialist (ORA_OSS_
SUBSCRIPTION_SPECIALIST_JOB)
 
Sales Catalog Administrator (ORA_QSC_SALES_
CATALOG_ADMINISTRATOR_JOB)
 
HR Help Desk Administration (ORA_SVC_
HELPDESK_ADMINISTRATION)
 
Service Request Administrator (ORA_SVC_SR_
ADMINISTRATOR)
 
Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 
Sales Manager (ORA_ZBS_SALES_MANAGER_
JOB)
 
Sales Representative (ORA_ZBS_SALES_
REPRESENTATIVE_JOB)
 
Customer Relationship Management
Application Administrator (ORA_ZCA_

CONTRACT_ADMINISTRATOR_JOB), HR Help
Desk Administration (ORA_SVC_HELPDESK_
ADMINISTRATION), Sales Administrator
(ORA_ZBS_SALES_ADMINISTRATOR_JOB),
 Channel Administrator (ORA_ZPM_CHANNEL_
ADMINISTRATOR_JOB), Sales Administrator
(ORA_ZBS_SALES_ADMINISTRATOR_
JOB), Service Request Administrator
(ORA_SVC_SR_ADMINISTRATOR),
 Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
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CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 
Channel Account Manager (ORA_ZPM_
CHANNEL_ACCOUNT_MANAGER_JOB)
 
Channel Administrator (ORA_ZPM_CHANNEL_
ADMINISTRATOR_JOB)
 
Channel Operations Manager (ORA_ZPM_
CHANNEL_OPERATIONS_MANAGER_JOB)
 
Channel Partner Manager (ORA_ZPM_
CHANNEL_PARTNER_MANAGER_JOB)
 
Channel Partner Portal Administrator (ORA_
ZPM_CHANNEL_PARTNER_PORTAL_
ADMINISTRATOR_JOB)
 
Channel Sales Director (ORA_ZPM_CHANNEL_
SALES_DIRECTOR_JOB)
 
Channel Sales Manager (ORA_ZPM_CHANNEL_
SALES_MANAGER_JOB)
 
Sales Analyst (ORA_ZSP_SALES_ANALYST_
JOB)
 

Business Plan
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Campaign
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Case
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Administration (ORA_SVC_HELPDESK_
ADMINISTRATION), Internal Service Request
Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Administration (ORA_SVC_HELPDESK_
ADMINISTRATION), Internal Service Request
Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Classification Code
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Competitor
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Consumer
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Contact
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
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Contract
 

Customer Contract Administrator (ORA_OKC_
CUSTOMER_CONTRACT_ADMINISTRATOR_
JOB), Customer Contract Manager (ORA_OKC_
CUSTOMER_CONTRACT_MANAGER_JOB),
 Enterprise Contract Administrator (ORA_OKC_
ENTERPRISE_CONTRACT_ADMINISTRATOR_
JOB), Enterprise Contract Manager (ORA_OKC_
ENTERPRISE_CONTRACT_MANAGER_JOB),
 Supplier Contract Administrator (ORA_OKC_
SUPPLIER_CONTRACT_ADMINISTRATOR_
JOB), Supplier Contract Manager (ORA_OKC_
SUPPLIER_CONTRACT_MANAGER_JOB)
 

Customer Contract Administrator (ORA_OKC_
CUSTOMER_CONTRACT_ADMINISTRATOR_
JOB), Customer Contract Manager (ORA_OKC_
CUSTOMER_CONTRACT_MANAGER_JOB),
 Enterprise Contract Administrator (ORA_OKC_
ENTERPRISE_CONTRACT_ADMINISTRATOR_
JOB), Enterprise Contract Manager (ORA_OKC_
ENTERPRISE_CONTRACT_MANAGER_JOB),
 Supplier Contract Administrator (ORA_OKC_
SUPPLIER_CONTRACT_ADMINISTRATOR_
JOB), Supplier Contract Manager (ORA_OKC_
SUPPLIER_CONTRACT_MANAGER_JOB)
 

Contests
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Country Structure
 

Geography Administration (ORA_GEO_ADMIN_
DUTY)
 

Geography Administration (ORA_GEO_ADMIN_
DUTY)
 

Custom Object
 

Custom Objects Administration (ORA_
CRM_EXTN_ROLE), Customer Relationship
Management Application Administrator
(ORA_ZCA_CUSTOMER_RELATIONSHIP_
MANAGEMENT_APPLICATION_
ADMINISTRATOR_JOB), Sales Administrator
(ORA_ZBS_SALES_ADMINISTRATOR_JOB)
 

Custom Objects Administration (ORA_
CRM_EXTN_ROLE), Customer Relationship
Management Application Administrator
(ORA_ZCA_CUSTOMER_RELATIONSHIP_
MANAGEMENT_APPLICATION_
ADMINISTRATOR_JOB)
 

Deal Registration
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Channel Operations
Manager (ORA_ZPM_CHANNEL_OPERATIONS_
MANAGER_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Channel Operations
Manager (ORA_ZPM_CHANNEL_OPERATIONS_
MANAGER_JOB)
 

Duplicate Resolution Request
 

ORA_ZCH_DATA_STEWARD_MANAGER
 

ORA_ZCH_DATA_STEWARD_MANAGER
 

Event
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Event Team Member
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Geography
 

Geography Administration (ORA_GEO_ADMIN_
DUTY)
 

Geography Administration (ORA_GEO_ADMIN_
DUTY)
 

Goals
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Hierarchy
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

45



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 3
Get Started with Import

Object Name Recommended Role for Import and Export
(Code)

Administrator Level Roles (Code)

Hierarchy Member
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Household
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Hub Source System Reference
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Incentive Rule Assignments
 

Incentive Compensation Analyst (ORA_
CN_INCENTIVE_COMPENSATION_
ANALYST_JOB), Incentive Compensation
Integration Specialist (ORA_CN_INCENTIVE_
COMPENSATION_INTEGRATION_SPECIALIST_
JOB), Incentive Compensation Manager
(ORA_CN_INCENTIVE_COMPENSATION_
MANAGER_JOB), Incentive Compensation
Plan Administrator (ORA_CN_INCENTIVE_
COMPENSATION_PLAN_ADMINISTRATOR_
JOB), Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Incentive Compensation Analyst (ORA_
CN_INCENTIVE_COMPENSATION_
ANALYST_JOB), Incentive Compensation
Integration Specialist (ORA_CN_INCENTIVE_
COMPENSATION_INTEGRATION_SPECIALIST_
JOB), Incentive Compensation Manager
(ORA_CN_INCENTIVE_COMPENSATION_
MANAGER_JOB), Incentive Compensation
Plan Administrator (ORA_CN_INCENTIVE_
COMPENSATION_PLAN_ADMINISTRATOR_
JOB), Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Incentive Rule Attribute Values
 

Incentive Compensation Analyst (ORA_
CN_INCENTIVE_COMPENSATION_
ANALYST_JOB), Incentive Compensation
Integration Specialist (ORA_CN_INCENTIVE_
COMPENSATION_INTEGRATION_SPECIALIST_
JOB), Incentive Compensation Manager
(ORA_CN_INCENTIVE_COMPENSATION_
MANAGER_JOB), Incentive Compensation
Plan Administrator (ORA_CN_INCENTIVE_
COMPENSATION_PLAN_ADMINISTRATOR_
JOB), Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Incentive Compensation Analyst (ORA_
CN_INCENTIVE_COMPENSATION_
ANALYST_JOB), Incentive Compensation
Integration Specialist (ORA_CN_INCENTIVE_
COMPENSATION_INTEGRATION_SPECIALIST_
JOB), Incentive Compensation Manager
(ORA_CN_INCENTIVE_COMPENSATION_
MANAGER_JOB), Incentive Compensation
Plan Administrator (ORA_CN_INCENTIVE_
COMPENSATION_PLAN_ADMINISTRATOR_
JOB), Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Incentive Rules
 

Incentive Compensation Analyst (ORA_
CN_INCENTIVE_COMPENSATION_
ANALYST_JOB), Incentive Compensation
Integration Specialist (ORA_CN_INCENTIVE_
COMPENSATION_INTEGRATION_SPECIALIST_
JOB), Incentive Compensation Manager
(ORA_CN_INCENTIVE_COMPENSATION_
MANAGER_JOB), Incentive Compensation
Plan Administrator (ORA_CN_INCENTIVE_
COMPENSATION_PLAN_ADMINISTRATOR_
JOB), Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Incentive Compensation Analyst (ORA_
CN_INCENTIVE_COMPENSATION_
ANALYST_JOB), Incentive Compensation
Integration Specialist (ORA_CN_INCENTIVE_
COMPENSATION_INTEGRATION_SPECIALIST_
JOB), Incentive Compensation Manager
(ORA_CN_INCENTIVE_COMPENSATION_
MANAGER_JOB), Incentive Compensation
Plan Administrator (ORA_CN_INCENTIVE_
COMPENSATION_PLAN_ADMINISTRATOR_
JOB), Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
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Incentive Transaction
 

Incentive Compensation Analyst (ORA_
CN_INCENTIVE_COMPENSATION_
ANALYST_JOB), Incentive Compensation
Integration Specialist (ORA_CN_INCENTIVE_
COMPENSATION_INTEGRATION_SPECIALIST_
JOB), Incentive Compensation Manager
(ORA_CN_INCENTIVE_COMPENSATION_
MANAGER_JOB), Incentive Compensation
Plan Administrator (ORA_CN_INCENTIVE_
COMPENSATION_PLAN_ADMINISTRATOR_
JOB), Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Incentive Compensation Plan Administrator
(ORA_CN_INCENTIVE_COMPENSATION_
PLAN_ADMINISTRATOR_JOB), Customer
Relationship Management Application
Administrator (ORA_ZCA_CUSTOMER_
RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB)
 

Interaction
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Administration (ORA_SVC_HELPDESK_
ADMINISTRATION), Internal Service Request
Administration(ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Administration (ORA_SVC_HELPDESK_
ADMINISTRATION), Internal Service Request
Administration(ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Kpi
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

MDF Budget
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Channel Operations
Manager (ORA_ZPM_CHANNEL_OPERATIONS_
MANAGER_JOB), Marketing Operations
Manager (ORA_MKT_MARKETING_
OPERATIONS_MANAGER_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Channel Operations
Manager (ORA_ZPM_CHANNEL_OPERATIONS_
MANAGER_JOB)
 

MDF Claim
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Channel Operations
Manager (ORA_ZPM_CHANNEL_OPERATIONS_
MANAGER_JOB), Marketing Operations
Manager (ORA_MKT_MARKETING_
OPERATIONS_MANAGER_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Channel Operations
Manager (ORA_ZPM_CHANNEL_OPERATIONS_
MANAGER_JOB)
 

MDF Request
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Channel Operations
Manager (ORA_ZPM_CHANNEL_OPERATIONS_
MANAGER_JOB), Marketing Operations
Manager (ORA_MKT_MARKETING_
OPERATIONS_MANAGER_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Channel Operations
Manager (ORA_ZPM_CHANNEL_OPERATIONS_
MANAGER_JOB)
 

Note
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Sales Manager
(ORA_ZBS_SALES_MANAGER_JOB),
 Sales Representative (ORA_ZBS_SALES_
REPRESENTATIVE_JOB), Marketing
Operations Manager (ORA_MKT_
MARKETING_OPERATIONS_MANAGER_
JOB), Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Customer Relationship
Management Application Administrator
(ORA_ZCA_CUSTOMER_RELATIONSHIP_
MANAGEMENT_APPLICATION_
ADMINISTRATOR_JOB)
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APPLICATION_ADMINISTRATOR_JOB),
 FUSION_APPS_CRM_ESS_APPID, FUSION_
APPS_CRM_ODI_APPID, FUSION_APPS_CRM_
SOA_APPID
 

Objective
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Opportunity
 

Opportunity Administration (ORA_MOO_
OPPORTUNITY_ADMINISTRATION_DUTY) ,
 Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), FUSION_APPS_CRM_
ESS_APPID, FUSION_APPS_CRM_ODI_APPID,
 FUSION_APPS_CRM_SOA_APPID
 

Opportunity Administration (ORA_MOO_
OPPORTUNITY_ADMINISTRATION_DUTY) ,
 Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Organization
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Partner
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Channel Operations
Manager (ORA_ZPM_CHANNEL_OPERATIONS_
MANAGER_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Channel Operations
Manager (ORA_ZPM_CHANNEL_OPERATIONS_
MANAGER_JOB)
 

Partner Programs
 

Channel Operations Manager (ORA_ZPM_
CHANNEL_OPERATIONS_MANAGER_JOB)
 

Channel Operations Manager (ORA_ZPM_
CHANNEL_OPERATIONS_MANAGER_JOB)
 

Person
 

Trading Community Import Batch Management
(ORA_MANAGE_TRADING_COMMUNITY_
IMPORT_BATCH_DUTY)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Price Book Header
 

Sales Administrator (ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ZBS_SALES_
ADMINISTRATOR_JOB)
 

Product
 

Sales Administrator (ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ZBS_SALES_
ADMINISTRATOR_JOB)
 

Product Group
 

Sales Catalog Administrator (ORA_QSC_
SALES_CATALOG_ADMINISTRATOR_JOB),
 Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Program Enrollments
 

Channel Operations Manager (ORA_ZPM_
CHANNEL_OPERATIONS_MANAGER_JOB)
 

Channel Operations Manager (ORA_ZPM_
CHANNEL_OPERATIONS_MANAGER_JOB)
 

Promotion
 

Loyalty Program Administrator (ORA_LOY_
LOYALTY_PROGRAM_ADMINISTRATOR_JOB)
 

Loyalty Program Administrator (ORA_LOY_
LOYALTY_PROGRAM_ADMINISTRATOR_JOB)
 

Queue
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
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Administration(ORA_SVC_HELPDESK_
ADMINISTRATION), Internal Service Request
Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Administration(ORA_SVC_HELPDESK_
ADMINISTRATION), Internal Service Request
Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Quote and Order
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Resource
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
 

Resource Capacity
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Administration(ORA_SVC_HELPDESK_
ADMINISTRATION), Internal Service Request
Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Administration(ORA_SVC_HELPDESK_
ADMINISTRATION), Internal Service Request
Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Sales Lead
 

Marketing Analyst (ORA_MKT_MARKETING_
ANALYST_JOB), Sales Administrator (ORA_
ZBS_SALES_ADMINISTRATOR_JOB), Marketing
Manager (ORA_MKT_MARKETING_MANAGER_
JOB), Sales Lead Processing (ORA_MKL_
SALES_LEAD_PROCESSING_DUTY), Marketing
Operations Manager (ORA_MKT_MARKETING_
OPERATIONS_MANAGER_JOB), Corporate
Marketing Manager (ORA_MKT_CORPORATE_
MARKETING_MANAGER_JOB), Marketing
VP (ORA_MKT_MARKETING_VP_JOB), Sales
Analyst (ORA_ZSP_SALES_ANALYST_JOB),
 FUSION_APPS_CRM_ODI_APPID, FUSION_
APPS_CRM_SOA_APPID, FUSION_APPS_CRM_
ESS_APPID
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Sales Lead Processing
(ORA_MKL_SALES_LEAD_PROCESSING_DUTY)
 

Sales Territory
 

Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB),
 Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Territory Management
Administration (ORA_MOT_TERRITORY_
MANAGEMENT_ADMINISTRATION_DUTY),
 Sales Manager (ORA_ZBS_SALES_MANAGER_
JOB), Sales Restricted User (ORA_ZBS_SALES_
RESTRICTED_USER_JOB), Sales VP (ORA_ZBS_
SALES_VP_JOB), Channel Account Manager
(ORA_ZPM_CHANNEL_ACCOUNT_MANAGER_
JOB), Channel Operations Manager (ORA_
ZPM_CHANNEL_OPERATIONS_MANAGER_
JOB), Channel Partner Manager (ORA_ZPM_
CHANNEL_PARTNER_MANAGER_JOB),
 Channel Sales Director (ORA_ZPM_CHANNEL_
SALES_DIRECTOR_JOB), Channel Sales
Manager (ORA_ZPM_CHANNEL_SALES_
MANAGER_JOB), FUSION_APPS_OBIA_BIEE_
APPID, FUSION_APPS_CRM_ESS_APPID,
 FUSION_APPS_CRM_ADF_BI_APPID

Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB),
 Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Territory Management
Administration (ORA_MOT_TERRITORY_
MANAGEMENT_ADMINISTRATION_DUTY)
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Object Name Recommended Role for Import and Export
(Code)

Administrator Level Roles (Code)

 

Sales Territory Quota
 

Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB),
 Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Territory Management
Administration (ORA_MOT_TERRITORY_
MANAGEMENT_ADMINISTRATION_DUTY),
 Sales Manager (ORA_ZBS_SALES_MANAGER_
JOB), Sales Restricted User (ORA_ZBS_SALES_
RESTRICTED_USER_JOB), Sales VP (ORA_ZBS_
SALES_VP_JOB), Channel Account Manager
(ORA_ZPM_CHANNEL_ACCOUNT_MANAGER_
JOB), Channel Operations Manager (ORA_
ZPM_CHANNEL_OPERATIONS_MANAGER_
JOB), Channel Partner Manager (ORA_ZPM_
CHANNEL_PARTNER_MANAGER_JOB),
 Channel Sales Director (ORA_ZPM_CHANNEL_
SALES_DIRECTOR_JOB), Channel Sales
Manager (ORA_ZPM_CHANNEL_SALES_
MANAGER_JOB)
 

Customer Relationship Management
Application Administrator (ORA_ZCA_
CUSTOMER_RELATIONSHIP_MANAGEMENT_
APPLICATION_ADMINISTRATOR_JOB),
 Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB), Territory Management
Administration (ORA_MOT_TERRITORY_
MANAGEMENT_ADMINISTRATION_DUTY)
 

Self Service Role
 

Service Request Administrator (ORA_SVC_SR_
ADMINISTRATOR)
 

Service Request Administrator (ORA_SVC_SR_
ADMINISTRATOR)
 

Service Request
 

Service Request Administrator (ORA_SVC_
SR_ADMINISTRATOR), HR Help Desk Service
Request Management (ORA_SVC_HELPDESK_
SR_MANAGEMENT), HR Help Desk Analysis
(ORA_SVC_HELPDESK_ANALYSIS), HR Help
Desk Administration (ORA_SVC_HELPDESK_
ADMINISTRATION)
 

Service Request Administrator (ORA_SVC_
SR_ADMINISTRATOR), HR Help Desk Service
Request Management (ORA_SVC_HELPDESK_
SR_MANAGEMENT)
 

Standard Text
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Service Request Management (ORA_SVC_
HELPDESK_SR_MANAGEMENT), HR Help Desk
Analysis (ORA_SVC_HELPDESK_ANALYSIS),
 HR Help Desk Administration (ORA_SVC_
HELPDESK_ADMINISTRATION), Internal
Service Request Administration (ORA_SVC_
INTERNAL_HELPDESK_ADMINISTRATION),
 Internal Service Request Analysis (ORA_SVC_
INTERNAL_HELPDESK_ANALYSIS), Internal
Service Request Management (ORA_SVC_
INTERNAL_HELPDESK_SR_MANAGEMENT),
 Service Request Channel User (ORA_SVC_
SR_CHANNEL_USER), Service Request Power
User (ORA_SVC_SR_POWER_USER), Service
Request Troubleshooter (ORA_SVC_SR_
TROUBLESHOOTER)
 

Service Request Administrator (ORA_SVC_
SR_ADMINISTRATOR), HR Help Desk Service
Request Management (ORA_SVC_HELPDESK_
SR_MANAGEMENT), Internal Service Request
Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Standard Text Folder
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Service Request Management (ORA_SVC_
HELPDESK_SR_MANAGEMENT), HR Help Desk

Service Request Administrator (ORA_SVC_
SR_ADMINISTRATOR), HR Help Desk Service
Request Management (ORA_SVC_HELPDESK_
SR_MANAGEMENT), Internal Service Request
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Object Name Recommended Role for Import and Export
(Code)

Administrator Level Roles (Code)

Analysis (ORA_SVC_HELPDESK_ANALYSIS),
 HR Help Desk Administration (ORA_SVC_
HELPDESK_ADMINISTRATION), Internal
Service Request Administration (ORA_SVC_
INTERNAL_HELPDESK_ADMINISTRATION),
 Internal Service Request Analysis (ORA_SVC_
INTERNAL_HELPDESK_ANALYSIS), Internal
Service Request Management (ORA_SVC_
INTERNAL_HELPDESK_SR_MANAGEMENT),
 Service Request Channel User (ORA_SVC_
SR_CHANNEL_USER), Service Request Power
User (ORA_SVC_SR_POWER_USER), Service
Request Troubleshooter (ORA_SVC_SR_
TROUBLESHOOTER)
 

Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Standard Text User Variables
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Service Request Management (ORA_SVC_
HELPDESK_SR_MANAGEMENT), HR Help Desk
Analysis (ORA_SVC_HELPDESK_ANALYSIS),
 HR Help Desk Administration (ORA_SVC_
HELPDESK_ADMINISTRATION), Internal
Service Request Administration (ORA_SVC_
INTERNAL_HELPDESK_ADMINISTRATION),
 Internal Service Request Analysis (ORA_SVC_
INTERNAL_HELPDESK_ANALYSIS), Internal
Service Request Management (ORA_SVC_
INTERNAL_HELPDESK_SR_MANAGEMENT),
 Service Request Channel User (ORA_SVC_
SR_CHANNEL_USER), Service Request Power
User (ORA_SVC_SR_POWER_USER), Service
Request Troubleshooter (ORA_SVC_SR_
TROUBLESHOOTER)
 

Service Request Administrator (ORA_SVC_
SR_ADMINISTRATOR), HR Help Desk Service
Request Management (ORA_SVC_HELPDESK_
SR_MANAGEMENT), Internal Service Request
Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Subscription
 

Subscription Specialist (ORA_OSS_
SUBSCRIPTION_SPECIALIST_JOB)
 

Subscription Specialist (ORA_OSS_
SUBSCRIPTION_SPECIALIST_JOB)
 

Subscription Service Charge Mappings
 

Subscription Specialist (ORA_OSS_
SUBSCRIPTION_SPECIALIST_JOB)
 

Subscription Specialist (ORA_OSS_
SUBSCRIPTION_SPECIALIST_JOB)
 

Subscription Usage Event
 

Subscription Specialist (ORA_OSS_
SUBSCRIPTION_SPECIALIST_JOB)
 

Subscription Specialist (ORA_OSS_
SUBSCRIPTION_SPECIALIST_JOB)
 

Template
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Administration (ORA_SVC_HELPDESK_
ADMINISTRATION), Internal Service Request
Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Service Request Administrator (ORA_
SVC_SR_ADMINISTRATOR), HR Help Desk
Administration (ORA_SVC_HELPDESK_
ADMINISTRATION), Internal Service Request
Administration (ORA_SVC_INTERNAL_
HELPDESK_ADMINISTRATION)
 

Territory Geographies
 

Geography Administration (ORA_GEO_ADMIN_
DUTY)
 

Geography Administration (ORA_GEO_ADMIN_
DUTY)
 

Vehicles
 

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)

Sales Administrator (ORA_ZBS_SALES_
ADMINISTRATOR_JOB)
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Object Name Recommended Role for Import and Export
(Code)

Administrator Level Roles (Code)

  

Related Topics
• Schedule the Send Pending LDAP Requests Process
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4  Import Queues

Overview of Import Queues  
The Manage Imports page of the Import Queue tab shows the following four types of import queues as infotiles:

• All Imports: This infotile displays the count of active, completed, and unsuccessful imports submitted by all
users. Click on this infotile to see a list of all import jobs.

• Active Imports: This infotile displays the count of all import jobs submitted that are either in progress or in
queued status. Click on this infotile to see a list of active import jobs.

• My Completed Imports: This infotile displays the count of imports submitted by the current user that are
completed (either successful or failed with warnings or errors). Click on this infotile to see a list of completed
import jobs created by the current user.

• Unsuccessful Imports: This infotile displays the count of unsuccessful imports submitted by all users. Click on
this infotile to see a list of unsuccessful import jobs. These are the imports which couldn't complete because of
application error in the import flow.

Import Activities Details
Click on the infotiles to see the following details about the import job:

Column Description

Name
 

The name of the import job.
 

File Name
 

The name of the source file.
 

Object
 

The object imported.
 

Status
 

The status of the import job. For more information about the statuses, see the topic How You Monitor
Your Import Activities in the related topics section.
 

Cancel Job
 

Click the close icon to cancel an active import, if it's running for a long time. Only the user who
submitted the import job or an administrator can cancel the job. Once you cancel an import job, you
can't restart or resume it.
 
Canceling the import job commits the data processed till that point and leaves the application in a
clean state. A partial import may occur depending on the actual stage of the import, when the cancel
option is selected. You can manually generate the reports for any processed records from the import
status page.
 

Note:
You can't cancel a high-volume import job.
 

Estimated Completion Time The date and time when the import job is expected to be completed.
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Column Description

  

Start Time
 

The start date and time of the import.
 

Next Scheduled Date
 

The date and time when the import job is scheduled to run.
 

End Time
 

The end date and time of the import.
 

Submitted By
 

The user who submitted the import.
 

Rank
 

The rank associated with the paused job. The job with the highest rank is executed from the job queue.
Possible values are integers such as 1, 2, and so on with 1 being the highest.
 

You can filter the list by clicking on any of these columns.

Related Topics
• How do I monitor import activities?

How do I monitor import activities?  
You can monitor imports that were scheduled to run, have completed successfully, or have failed with errors. For each
import, you can view the details and make the necessary updates for any failed records that you want to import again.

You can view the list of imports from the Manage Imports page of the Import Queue tab. To view the status of an
import job click the link in the import's Name column. The Import Status page shows the status of the most recently
executed instance of the import. The Import Status page contains the following sections:

• Status Bar

• Details

• Import Attachments

Status Bar
The status bar shows the progress of the import in a graphical format. It shows the following stages during the import
process:

• Import activity queued: The import request is queued for processing, and is waiting to begin execution.

• Preparing data for import: The data from the source file are being loaded in the temporary staging table for
further processing.

• Importing data: The data from the source file are being validated and loaded in the target tables.

• Completing import activity: The import data have been loaded in the target tables, and cleanup tasks, such as
the generation of log files, are in progress.

• Completed with errors: The import has completed with errors.

54



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 4
Import Queues

• Successful: The import has completed successfully.

• Completed with warnings: The import has completed with warnings.

• Canceled: The import was canceled by the user.

• Unsuccessful: The import was unsuccessful.

Hovering your mouse over the progress bar shows the status on the number of records imported.

Note:  If the job is in the same status for a long time, then generate a diagnostic log as described in the topic Generate
the Diagnostics Log for Import in Related Topics section. When you raise a service request, attach the diagnostic log
files to help technical support to resolve the issue.

Activity and Record Details
The Activity Details section shows the name of the import, import activity identifier, object name, and the name of the
user who submitted the import. The section on date and time displays the start and end times, estimated completion
time, and the time taken to complete the import.

The Record Details section displays the number of import records in each stage of processing. The various status
details are summarized in the following table:

File Processing Summary Information Description

Records Read From File
 

The number of records read from the source file. Clicking the link for the number of records lets you
download the spreadsheet file with the records.
 

Records Loaded Successfully
 

The number of import object records that were imported to the application destination tables.
 

Records With Errors Reported
 

The number of records that failed with errors when importing data from the interface tables to the
destination tables. You can view the error details in the Exception and Error files attached to the
process. Clicking the link for the number of records lets you download the spreadsheet file with the
error records.
 

Records With Warnings
 

The number of records that were uploaded with warnings when importing data from the interface
tables to the destination application tables. Clicking the link for the number of records lets you
download the spreadsheet file with the warning records.
 

Unprocessed
 

The number of records that weren't processed.
 

Clicking on the Advanced Options section shows the advanced configuration options that you had selected when
creating the import activity.

The rejected file records don't contain the error message when import job ends in unsuccessful status.

Note:  In the files that are generated after the completion of an import activity, all error message values are enclosed
within double quotation marks. The use of double quotation marks improves the format of the log files by ensuring
that the error messages containing commas aren't treated as multiple values.
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Detailed Import Status
The Detailed Import Status page shows the status of the different steps in the import activity. You can navigate to this
page by selecting View Detailed Import Status from the Actions menu on the Status page. For each step, this page
shows the individual sub tasks of the import process. This information helps the technical support team to fix any issues
during the import.

Purge Import Data
Import Management periodically runs an automatic process that purges all data associated with import jobs. This
process purges data older than 7 days by default. You can extend this time to 30 days by setting the value in the profile
option ZCA_IMPORT_PURGING_DURATION.

If you wish for the data to be purged instantaneously on job completion, you can do the same using the
ZCA_IMPORT_PURGE_ON_JOBCOMPLETION profile option. The default value for this profile option is Y and impacts
data for all objects except the ones registered as 'ObjectPostProcess'

Alternately, if you want to control purging through the UI from the Import Object Details Page, you can set the
ZCA_IMPORT_PURGE_FROM_UI profile option to Y to display the purge option on the Import Object Details page.

Import Attachments
The Import Attachments  section lists the files associated with this import in a table. The Actions column
lets you either download the file or view more details. Success log file isn't generated after the import job is
completed successfully. To generate success logs for even successfully completed jobs, set the profile option
ZCA_IMPORT_SUPPRESS_SUCCESSLOG_GENERATION to 'No'. You can download the following files from this section:

• Process Log: Click Action  > Generate Log.

• Diagnostics Log file: Click Action  > Generate Diagnostics.

• Map file: Click the Download link to download the import activity map file in CSV format.

• Source CSV file used for the import.

• Exception files that include a row for each record that failed. All the errors for that row are concatenated and
displayed in the Error Message column of the file.

• Error file that includes all the errors for each record that failed validation.

Related Topics
• How do I import data?

• How do I generate the diagnostics log for import?

How You Monitor Import Activities Using REST APIs  
You can receive import completion notification through REST resource. This avoids the need to keep checking the
import status.

To receive import completion notification through REST service, you must define the REST service endpoint in
Application Composer. You can configure and register your REST endpoint to receive notification whenever your import
job completes.
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Register an External REST Endpoint in Application Composer
To register an endpoint for notification:

1. Create and enter into a sandbox by navigating to Configuration >  Sandboxes >  Create Sandbox.
2. Navigate to Configuration >  Application Composer >  Web Services. Note that this option is available only

when you're inside the sand box.
3. You can edit the existing endpoints, or create a new endpoint such as ExternalEndPoint1, by clicking the Create

icon.
4. Enter the name of the endpoint and the URL, and select the authentication scheme. For example, your URL can

be in the format https://servername/ic/api/integration/v1/connections/cbveTest.
5. Select and configure the POST method by clicking the check box for POST. Currently only POST method is

supported for the Import Notification feature.
6. Select and provide the code samples for the request and response payloads. Following is the sample for

request and response payloads:

{
"items": [],
"count": 0,
"hasMore": false,
"limit": 25,
"offset": 0,
"links": [{
"rel": "self",
"href": "https://servername/ic/api/integration/v1/connections/cbveTest",
"name": "ExternalEndPoint1",
"kind": "collection"
}]
}

7. Click Save and Close.
8. After making the changes, publish the sandbox to commit your changes.

Validate the Endpoint
You can validate the REST endpoint to ensure that your REST web service configuration in Web Services in Application
Composer is correct and the import process can call the endpoint successfully. To validate your REST endpoint and set
an endpoint as default:

1. Navigate to Tools >  Import Management >  Import Configuration >  REST Notification.
2. Here, select REST Notification as the notification type, and select the endpoint you registered from the

Notification Endpoint drop-down list. In our example, select ExternalEndPoint1.
3. To make this connection as the default one while creating import jobs, select the Set as default check box.
4. To validate, click the Payload Details section, and click the Validate REST Endpoint button. If your endpoint is

valid, then you see one of the following response statuses in the Response text box:

◦ 200

◦ 201

◦ 202

◦ 204

Any other response status indicates that the endpoint is invalid.
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Create the Import Activity and Monitor the Status

1. Navigate to Tools >  Import Management >  Create Import Activity.
2. Create the import activity, enter the name, and select the object and source file.
3. Click the Advanced Options section and select the notification endpoint ExternalEndPoint1 from the

Notification Endpoint drop-down list. If you don't want to receive the notification, then select a blank value in
the drop-down list.

4. Click Next and map the attributes on the Map Fields page. Review the configurations and submit the job. For
more information on creating an import activity, see the topic Import Data.

5. Once you submit the import, you can monitor the status by accessing the configured endpoint.
6. Alternatively, you can verify whether the notification is submitted by downloading the log files. The last entry in

the file indicates the status of notification.

Import Notification in REST and External Data Loader Client (EDLC)
You can use the EDLC command listResthooks to get the list of resources registered in Application Composer. For
example,

java -jar oscdataloader.jar listResthooks -username importuser -target-url https://mypod.oracle.com 

You can then use the notification endpoint to get the import notification with the following command:

java -jar oscdataloader.jar submit -input-file "AccountCSV.csv" -import-name "AccountImport" -mapping-number
 30010011859 -object Account -username importuser -target-url https://mypod.oracle.com -high-volume -rest-
notification "ExternalEndPoint1"

You can use the RestNotification attribute to specify your notification endpoint while creating your import activity using
REST. For example, you can use the following sample payload to create your import activity:

{
 "Name": "RESTImportActivity",
 "ObjectCode": "Account",
 "HighVolume": "YES",
 "Activate": "YES",
 "RestNotification": "ExternalEndPoint1",
 "DataFiles" : [
 {
 "InputFileContentId": "UCMFA00012159"
 }
]
}

The following table describes the behavior when you don't provide the REST notification endpoint in REST and EDLC.

REST Notification Value Endpoint Used for Import Job REST Notification Behavior

null
 

Default endpoint is selected
 

REST Notification is sent to the default REST
endpoint.
 

REST notification not passed
 

Default endpoint is selected
 

REST Notification is sent to the default REST
endpoint.
 

""
 

No REST endpoint is selected
 

No REST Notification is sent.
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5  Manage Import Mappings

How do I map import fields?  
After entering the import options, map the fields in the source file to the corresponding target attributes.

You can do these in the section:

• Automatic Mapping

• Map Fields

• Save the Import Mapping

Automatic Mapping
The automatic mapping feature maps the source file columns to the target attribute columns. The application
automatically saves the mapping created under the name Automatic Mapping and lists it in the Import Mapping drop-
down list.

For an import file attribute to get automatically mapped, the column header for the attribute in the import file should be
same as the Attribute Name. You can view the Attribute Name and Attribute Display Name in the Import Objects tab.

Note:  You must map the column headers to the attribute display name when using an exported file to import. The
exported file contains the display name as column headers, hence doesn't get automatically mapped.

You can download the import object templates from the Import Objects tab, and use them to create the source CSV file
for your import. The templates have prepopulated column headers that ensure that the attributes are automatically
mapped.

For auto mapping to work correctly provide the name of the columns in the input CSV. Follow the below steps to create
the source CSV file for your import:

1. Navigate to Tools > Import Management > Import Objects
2. Filter the object based on display name of the object or language Independent Code (ObjectCode)
3. Download the file and decompress it.
4. In the file named like <ObjectCode>.csv, remove the 2nd row.
5. Use the names in the first row for column names of the input csv file.

For more details please refer readme.txt.

You can override a column mapping, by dragging target attributes from Target Attributes section to the Attribute
Name field of the Source File section. If you change the mapping, then you must save the mapping with a different
name. Once you provide the name, the date and year time stamp is appended to the mapping name. The newly created
mapping appears in the Import Mapping drop-down list. To apply the automatic mapping instead of your custom
mapping, select Automatic Mapping from the Import Mapping drop-down list and click Apply.

Map the Fields
The Map Fields section can be subdivided into source file columns and target attribute columns. The source column
header value is derived from the source file.
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The following table outlines the source columns.

Source Column Description

Column Header
 

Represents the column header for the text files.
 

Example Value
 

Values are derived from the first source file saved with the predefined mapping. If you didn't select
a predefined mapping, then the example values are taken from the first data row in the source file
selected in the first step of the Import Activity definition.
 

Attribute Name
 

Represents the target attribute that's to be mapped to the source column.
 

The following table outlines the target columns.

Target Column Description

Target Attribute
 

The attribute name that represents the corresponding table column for the object.
 

Required
 

Indicates whether the target attribute is a required or a user key. Required indicates that the key is
required while creating a new record. User key indicates that the key is required while updating an
existing record.
 

Note:  For required fields, ensure that data is available for the respective attributes in the input CSV file. You can use
the validate function to check if all required fields are available before submitting the import job.

Save the Import Mapping
You can use automatic mapping to map the source file attributes to target attributes as described in the previous
section. To map more attributes or override existing mappings, then click Save As and save your custom map. The
name of a mapping file must be unique for the object.

For more information on how to import your data, see the object-specific import topics in the chapter Import Your Data.
These topics are titled Import Your <Object-Name> Data. They provide the following information about importing data:

• How to map your source data to Oracle Applications Cloud object attributes. This way the import process would
know where to insert each of the information bits.

• Required attributes and validations for the object.

• How to create the source CSV file with the data you want to import.

• How to start an import activity.

• How to check the import results to know if the import went well.

Related Topics
• How do I import data?
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Create Import Mappings  
An import mapping lets you quickly map your source object attributes to the object attributes in Sales and Fusion
Service. You must be an administrator or setup user to create import mappings.

You can create an import mapping in one of the following two ways:

• Create an import mapping manually.

• Generate the import map from the sample source file.

• Create an import mapping only once if your CSV file has the same set of fields.

Create Maps Manually
1. Click Tools > Import Management > Import Objects.
2. Click the Account link under the Display Name column to create a mapping for the Account object.
3. On the Manage Mapping page, click the Create Import Mapping button.
4. On the Edit Import Mapping page, enter the name of the mapping, and provide a description for the mapping.

The Target Attributes section displays the attributes of the Account object that should map to the source file
columns. Check the Required column to see if the attribute is required or is a user key.

5. In the Source File section, click the Add Column button to insert a column to the mapping file.
6. To create the mapping column for the Organization Name attribute, drag and drop the Organization Name

attribute from Target Attributes section to the Attribute Display Name column under the Source File section.
7. Provide the column header name, such as organization name and an example value, such as Green Corp.

Follow the steps 5 to 7 to add any additional mapping columns.
8. Click the Save and Close button to save the mapping.

To edit or download the mapping file, click the mapping number link for your mapping on the Manage Mapping
page. On the Edit Import Mapping page, click Download Map from the Actions menu.

Generate Maps from the Source File
1. Click Tools > Import Management > Import Objects.
2. Click the Account link under the Display Name column to create a mapping for the Account object.
3. On the Manage Mapping page, click the Create Import Mapping button.
4. On the Edit Import Mapping page, enter name of the mapping, select the object such as Account, and provide

a description for the mapping. The Target Attributes section displays the attributes of the Account object that
should map to the source file columns. Also, check the Required column to see if the attribute is required or is a
user key.

5. From the Actions menu under Source File section, click Select Source File.
6. In the Source File dialog box, choose the CSV file that should be the source for your mapping file. This creates

the mapping file based on the column header and example values in the source file.
7. Click Save and Close button. And we're done.

For more information on how to import your data, see the object-specific import topics in the chapter Import
Your Data. These topics are titled Import Your <object-name> Data. They provide the following information
about importing data:

◦ How to map your source data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.
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◦ Required attributes and validations for the object.

◦ How to create the source CSV file with the data you want to import.

◦ How to kick off an import activity.

◦ How to check the import results to know if the import went well.

Manage Import Mappings  
Import Mappings map your source data to the fields in the Oracle Applications database. You can reuse existing
mappings by editing them. Also, you can download an existing import mapping from one Oracle application instance
and upload the mapping into another Oracle application instance.

Copy and Modify a Mapping
To copy or modify a mapping:

1. Click Tools > Import Management > Import Objects.
2. In the Import Object Details section, choose the Object name for which you need the template.

Click the link under Display Name column to get to the Manage Mapping page.
3. Click the link under the Mapping Number column.
4. On the Edit Import Mapping page, select the Copy Import Mapping option from the Actions menu. Edit the

mapping by dragging the target attributes to the Attribute Display Name field under Source File section.
5. Add more attributes by clicking the Add Column button.
6. Once done, give a name for the mapping and click Save.

If you don't want the mapping that you see on the list, select  Delete Import Mapping from the Actions menu.

Download the Map File
To download a map file:

1. Click Tools > Import Management > Import Objects.
2. In the Import Object Details section, click the Object name link for which you need the template.
3. Click the link under the Mapping Number column for the required mapping.
4. On the Edit Import Mapping page, select Download Map from the Actions menu.

When prompted, save the file to a location.

Upload the Map File
To upload a map file:

1. Click Tools > Import Management > Import Objects.
2. In the Import Object Details section, click the Object name link for which you need the template.
3. On the Manage Mapping page, click the Upload Map button. Select a map file and click OK.
4. On the Edit Import Mapping page, give a name and save the mapping.
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Download the Import Object Templates
Import Templates give you an idea about the object attributes. Most attributes in the templates include example values
that help you know what value to provide in the import file. To download an import object template:

1. Click Tools > Import Management > Import Objects.
2. In the Import Object Details section, click the Object name link for which you need the template.
3. On the Manage Mapping page, click the link in the Mapping Number column for the required mapping.
4. On the Edit Import Mapping page, select Download Template option from the Actions menu.

For more information on how to import your data, see the object-specific import topics in the chapter Import Your Data.
These topics are titled Import Your <Object-Name> Data. They provide the following information about importing data:

• How to map your source data to Oracle Applications Cloud object attributes. This way the import process would
know where to insert each of the information bits.

• Required attributes and validations for the object.

• How to create the source CSV file with the data you want to import.

• How to kick off an import activity.

• How to check the import results to know if the import went well.

Import Mappings  
Click Tools Import Management Import Objects . Click the Object link to navigate to the Manage Mapping page.

You can create a mapping by clicking the Create Import Mapping button. For more details about creating a mapping,
refer to the topic Create Import Mappings. Click the mapping you created to navigate to the Edit Import Mapping page
where you can edit your mapping.

The Edit Import Mapping page contains the following sections:

• Source File

• Target Attributes

Source File
Here are the details related to columns provided in the source file:

Source Column Description

Column Header
 

The column name expected in the source file.
 

Example Value
 

Values from the first data row in the source file.
 

Attribute Display Name
 

Represents the target attribute that's to be mapped to the source column.
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Source Column Description

Select Source File
 

Use this button from the Action menu to import mapping from a source file.
 

Delete Column
 

Use this button from the Action menu to delete a column from the mapping file. This option is enabled
only when at least one column is added to the Source File section.
 

Target Attributes
Here are the details related to corresponding attributes in the target application table:

Target Attributes Description

Target Attribute
 

The attribute name that represents the corresponding table column for the object.
 

Required
 

Indicates whether the target attribute is a user key or a required key.
 

Default Value
 

Default value for the attribute if any.
 

Description
 

Provides a brief description of the attribute.
 

For more information on how to import your data, see the object-specific import topics in the chapter Import Your Data.
These topics are titled Import Your <Object-Name> Data. They provide the following information about importing data:

• How to map your source data to Oracle Applications Cloud object attributes. This way the import process would
know where to insert each of the information bits.

• Required attributes and validations for the object.

• How to create the source CSV file with the data you want to import.

• How to kick off an import activity.

• How to check the import results to know if the import went well.

Related Topics
• How do I import data?

• Create Import Mappings
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6  Manage Import Objects

How do I manage import objects?  
Import Objects correlate with the tables in Oracle Applications. Understand import objects and their attributes to
manage the data that you want to import. Objects for which you don't have license or access won't show up in the UI.

Import Object Details
Click Tools > Import Management > Import Objects. To see the details of an import object, select it on the Import
Object Details page. Here are the details that you see about each importable object.

Column Description

Display Name
 

The object as it's called in the User Interface.
 

Language Independent Code
 

The internal name of the object.
 

Parent Object
 

The parent object of the selected object. If there are multiple parents for an object, they're shown
separated by comma.
 

View Hierarchy
 

Clicking on the View Hierarchy icon shows the hierarchy between the parent and child objects in a
graphical format.
 

User Key
 

The attribute or the group of attributes that's used to uniquely identify a record.
 

Required Attributes
 

The attribute or the group of attributes for which values are required to create a record. These can't be
NULL when updating a record.
 

Description
 

A short description of the object.
 

Download
 

Link to download the import object template files for each object and its child objects.
 

Target Attributes
Here are the details that you see for each target attribute.

Column Description

Display Name
 

Name of the target attribute in the User Interface.
 

Attribute Name Internal or field name of the attribute.
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Column Description

  

Required
 

Indicates whether the attribute is mandatory or not.
 

Default Value
 

The default value for the attribute, if any.
 

Type
 

Data type of the target attribute.
 

Length
 

Maximum allowed length for the target attribute values.
 

Description
 

A short description of the target attribute.
 

Related Topics
• Define Objects

Use Import Object Templates to Import Data  
You can download an import object template for an object, such as account, and use it as a source file to import data.
Templates make it easy for you to use the automapping feature.

For automapping to work, the column headers in the source file must match the names of the columns (attributes)
of the objects imported. The column headers shown in the first row of the downloadable templates are the same
as the column names of the corresponding objects. Therefore, building source files from the templates allows the
automapping process.

For example, if your source file has a column "URL" then it's mapped to the Account URL column. However if your
source file's column header is "Website", then automapping fails and you should map manually.

Download the Import Object Templates
To download an import object template:

1. Click Tools > Import Management > Import Objects.
2. On the Manage Import Objects page, click the Download icon for the object, such as account, for which you

want to download the template.

The next section explains the procedure to update the template to import data.

Populate the Import Object Templates
Extract the contents of the ZIP file to a folder. The extracted folder contains the template text files for each of the parent
and child objects. The readme text file within the folder contains instructions on how to use the template files to create
source file for importing data. Here are the steps to import data using the downloaded template:

1. Open the CSV template file for the object you want to import.
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The file for each object contains two rows. The first row contains all the column names in a format that's
compatible with the automatic mapping functionality. The second row contains the display names as shown on
the import mapping user interface.

2. Before populating the CSV template file with the data to be imported, delete the display name values in the
second row, and populate the columns with the data to import.

3. Use the updated file as the source when you're creating an import activity on the import user interface. For
more details on the import process, see the topic Import Data in the related links section.

The automatic mapping functionality maps all the columns automatically. You can see both the mapped column names
and the corresponding column names in your language on the Map Fields page.

For more information on how to import your data, see the object-specific import topics in the chapter Import Your Data.
These topics are titled Import Your <Object-Name> Data. They provide the following information about importing data:

• How to map your source data to Oracle Applications Cloud object attributes. This way the import process would
know where to insert each of the information bits.

• Required attributes and validations for the object.

• How to create the source CSV file with the data you want to import.

• How to kick off an import activity.

• How to check the import results to know if the import went well.

Related Topics
• How do I import data?

Define Objects  
Using Application Composer, modify an application's object model so that you can track and store any additional data
you might need. For example, add new fields to an existing object (standard objects), or create entirely new objects
(custom objects).

Standard objects are objects that are delivered with an application, and made available to Application Composer for
application changes. Custom objects are objects that you create using Application Composer. You can create either top-
level objects (objects without a parent) or child objects (objects created in the context of a parent).

Read this topic to learn about these tasks:

• Browsing the object tree

• Creating a custom object

• Deleting a custom object

• Using the Object Overview page

• Editing an object's attributes

• Selecting the display icon for the object's set of UI pages

• Viewing child and related objects
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Use Application Composer's Object Tree
Access Application Composer from the Navigator menu. The first view of Application Composer is the main Overview
page, which is the entry point into all your application change options.

On the main Overview page, the regional pane at left displays the object tree, which lets you browse an application's
existing object configuration in a tree format. The object tree reflects the latest configuration of the application: both
standard objects as well as custom objects.

To use the object tree:

1. Select Application Composer from the Navigator menu, under the Configuration category.
2. For each object node, whether standard or custom, expand it further to view and edit object details.

For example, look at object details such as fields and UI pages where the object is exposed.

Note:  At the top of the object tree, you can also click the New icon to create a new custom object.

For both standard and custom objects, you can view and edit the following details:

◦ Fields

Add new fields to an object.

◦ Pages

Modify the pages on which an object appears.

◦ Actions and links

Add actions or links to pages.

◦ Server scripts

Write application logic that controls the behavior of an object's records.

For custom objects, you can also view and edit details to security. For example, you can implement functional
and data-level security for an object and its records.

Create a Custom Object
Create a custom object if you want to track data about an object that's not already delivered with your cloud service.
After you create the object, you then add custom fields and design user interface pages where your users can enter
object records. There's no fixed limit on the number of custom objects that you can create.

To create a custom object:

1. On the main Overview page of Application Composer, select the Custom Objects node in the object tree, or
click the icon in the local area of the main Overview page.

2. On the resulting summary table, click the New icon, or at the top of the object tree, click the New icon.
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3. Complete the primary identifying attributes for a custom object:

a. Display Label

An object's display label is the user-friendly label for an object, and also becomes the default page title
for the object's work area.

b. Plural Label

The plural label is used as the title of the object's work area. The label is also used as the search string in
the regional search, as well as in the saved search on the object's runtime overview page.

c. Record Name Label

Use the Record Name Label field to specify the display label for the object's RecordName attribute. The
RecordName attribute stores the user-entered "name" of the record. For example, if you're creating a
custom object, Book. In the Record Name Label field for this object, you would enter something like
"ISBN Number." At runtime, for each new record, your users would use the ISBN Number field to enter
the book's International Standard Book Number (ISBN), which uniquely identifies books published
internationally.

Typically, this field is the object's primary user-recognizable identifier that runtime users drill down on,
from the landing page to the detail page. For example, at runtime, your users would click any ISBN to drill
down to review details about the book, such as book title and author.

d. Record Name Data Type

Select either Text or Automatically Generated Sequence.

For record names of Text data type, the maximum length that users can enter is 32 characters. For record
names of Automatically Generated Sequence data type, the sequence number is based on a display
format which is up to 28 characters and has at least one number token: {0}.

e. Select the Prevent duplicate values? check box to prevent users from entering records with duplicate
names.

i. If the Prevent duplicate values? check box is selected, then the Treat "ABC" and "Abc" as
distinct values check box is enabled.

Select this check box if you want the assessment for duplicate records to be case sensitive.
f. Object Name

The object name is the internal name for the object.

Note:  You can use a custom object's internal name only once across the mainline code and all
existing sandboxes. If you previously used an object's internal name in a sandbox, you can reuse
that same internal name, but you must first you delete all other sandboxes where the internal name
was previously used.  You can use a custom object's display name as many times as you want across
sandboxes. The restriction applies only to the internal name.

g. Description
4. Click OK.

Once your custom object is created, you must add fields and then create the UI pages where your users can
create actual records. See Define Fields and Create a Set of Application Pages for Custom Objects.
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Tip:  To create a custom child object, click the Create Child Object button from the parent object's Object Overview
page. See the next section in this topic. Once created, a child object can't be changed to a parent object. Similarly, a
parent object can't be changed to a child object. Child objects are discussed below.

Delete a Custom Object

Application Composer doesn't support the deletion of either standard or custom objects. If you no longer need an
object that was already published to the mainline metadata, optionally enter a note in the description that the object is
no longer used.

Use the Object Overview Page
The Object Overview page provides a high-level overview of a standard or custom object. The Object Overview page
displays the primary attributes for an object, plus a list of child objects and related objects, if any.

To access the Object Overview page:

1. On the main Overview page, select the object in the object tree or select the Standard Objects or Custom
Objects node in the object tree, or the icon in the local area of the main Overview page.

2. Select the object from the resulting summary table, and click the Edit icon.

From the Object Overview page, you can:

• Edit the object's primary attributes, described in the previous section. For example, change the Display Label or
Record Name Label.

• Change the display icon for the object.
This process is described as follows:

• View the parent child relationships that were created for this object.
You can also create new child objects from this page, which implicitly creates a new parent child relationship.

• View the non-parent child relationships that were created for this object.

Edit an Object's Attributes
After an object has been created, you can edit its attributes from its Object Overview page.

To edit an object's attributes:

1. Access the Object Overview page for the object, as described earlier.
2. On the Object Overview page, click Edit:

◦ Change the object's primary attributes, such as display label, description, and record name, at any time.

◦ You can't change the Object Name and API Name after the object has been created.
A custom object's API name is automatically derived using the logical name followed by _c. You use the
API name in Groovy expressions that you build with the expression builder, when writing business logic
for the object.

Select the Display Icon for Objects
From the Object Overview page, you can select the display icon to use for the object's UI pages. You can select the
display icon for custom objects (although a default icon is provided), and you can change the icon for standard objects.
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The icon you select determines which icon and theme display to your end users in a variety of locations, such as on the
Navigator, subtabs, mobile pages, and the springboard strip on application pages.

Tip:  The icon selected for standard objects is inherited across your applications. For example, if you change the
display icon for the Opportunity object, then all UI pages are automatically updated to the new icon. This includes
even custom subtabs that you added using Application Composer.

To select the icon:

1. Click the object's node in the object tree to view the object's Overview page.
2. On the Overview page, set the icon for the object in the Display Icon region.

View Child and Related Objects
The Object Overview page displays a list of child objects and related objects, if any. You can also create new child objects
from this page.

• A child object is an object with a cascade delete relationship to a parent object. This means that if you delete
the parent object record, then all its child records are automatically deleted. A child object doesn't exist outside
the context of the parent object, and doesn't have its own work area. You can't change a child object to a parent
object after the child object has been created.

• Related objects can exist independently of each other, even if one object is deleted. Related objects are
connected in a foreign key-based relationship between two top-level objects, not as parent and child. These
types of relationships include reference relationships and dynamic choice list relationships.

Related objects can have either a one-to-many or a many-to-one relationship with the current object. Note that
an object can be related to itself to model a hierarchy of the object. In this case, the object itself is displayed on
its Object Overview page as a related object. For example, the Department and Sub-department objects would
be displayed in this way.

Note:  You don't create these types of relationships from this page. Instead, manage relationships from the
Relationships page, which you can access from Application Composer's main Overview page. Or, create a
dynamic choice list relationship by creating a dynamic choice list field for an object, which derives its choice
list values from another object.

To create a child object for a standard or custom object:

1. Navigate to an object's Object Overview page.
2. Click the Create Child Object button. Creating a child object is the same as creating a custom object, except:

◦ The current object is automatically displayed as the parent object.

◦ Specify the Child Collection Name field to specify the internal name for this set of child object records,
which can be used later when writing Groovy scripts.

Related Topics
• Application Pages for Custom Objects
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7  Import Custom Objects

How do I enable import of custom objects?  
This topic describes how to enable the import of custom objects. Before you can import and export data for custom
objects created with Application Composer, you must ensure that the required object artifacts have been generated.

Object artifacts are required to register your extensions and make them available for importing. When you publish your
sandbox after your configurations, artifacts are automatically generated and the custom objects are available for import
and export. With a single publishing, you can generate configurations for CRM, ERP, and SCM cloud applications.

How you Enable Import of Custom Objects
To enable the import of custom object data:

1. Create a sandbox and add configurations to the objects.
2. Publish the sandbox. See Publish Sandboxes for more information.
3. Artifact generation is triggered automatically as part of the sandbox publish. Artifacts are generated for objects

that are changed inside sandbox only.
4. You can monitor the artifact generation status on the Generate Import and Export Artifacts tab by navigating

to Tools >  Import Management >  Import Configuration. You can perform this only once you're outside the
sandbox.

After the artifact is generated, you're ready to import. If some artifacts aren't generated automatically, then you have to
manually generate them using the Generate button. See How do I generate artifacts manually? .

To download the diagnostics log of the artifact generation, click the Generate button under the Diagnostics tab, and
then click the link under the Attachments column. Note that you must import the custom child objects only after
importing the parent object.

Note:  If your custom field is missing from import mapping after generating the artifacts, then enable the profile
option ORA_ZCA_OBJECT_METADATA_COMPLETE_GENERATION to 'Yes' from Setup and Maintenance >  Manage
Administrator Profile Values . Then generate your artifacts again and turn the profile option back to "No".

You can update the profile option ORA_ZCA_IMPORT_EXPORT_QUEUE_SIZE to specify the size of import and export
queues for dynamic queue configurations. The possible values are LOW, MEDIUM, HIGH, and FIXED. After updating the
profile option, you must generate the artifacts for the changes to reflect.

If you have configured security in the Application Composer for create, update, or delete scenario, then such validations
aren't honored by high-volume imports. Validations are applicable only for low-volume imports.

Relationships Between Custom Objects
Parent object resources expose the child objects of top-level custom objects. For objects to interact with one another,
relationships must be created between them. The related objects can be either standard or custom objects. For
example, if you want attributes from the Employee object to be available in the Trouble Ticket object workspace, a
relationship must be defined between the Employee object and the Trouble Ticket object.
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You can use Application Composer to create relationships between objects. Using Application Composer, you can create
two types of relationships:

• Parent-child: When you define a parent-child relationship, the link to the child object is included in the parent
object description. A child object doesn't have its own workspace, and the child object's records are deleted if
the parent object record is deleted.

• Reference: When you define a reference relationship, the primary key of the source object is included as a
foreign key in the description of the target object.

Intersection Objects

Use Application Composer to create many-to-many relationships between custom objects. In this case, you create
an intersection object that references the source and target objects. For example, consider two object resources,
Trouble Ticket and Resource, related by a many-to-many reference relationship, with the Assignment resource as the
intersection object. In such a case, the following applies:

• The Assignment resource has Trouble Ticket as the source object and Resources as the target object. The
objects Trouble Ticket and Resources have many-to-many relationships.

• The Assignment resource is the child resource of both Trouble Ticket and Resources.

How you Import Record Name Values
By default, the Record Name field is automatically generated and is updated using automatic sequence. The value you
provide in the source file is ignored. If automatic record-name generation is disabled in the Application Composer, then
you must provide the value in the source file and this value is imported. However, high-volume import doesn't support
automatic generation of Record Name field; you must provide the Record Name value in the source file.

Specify the RecordNumber Attribute
When defining your custom object in Application Composer, RecordNumber field is always unique. The import activity
uses RecordNumber as the user key to resolve the record in the target database.

When you modify the PUID (RecordNumber) make sure you follow by Application Composer guidelines, to prevent
recordNumber collisions with the existing database sequence. This is applicable for both high-volume import and
import using REST service. For more information on how to prevent conflict in PUID, see the topic Custom Object Public
Unique IDs in the related topics section.

Support of Record Name Attribute
You can update custom object records by using the Record Name attribute to identify records. To enable this, you must
set the profile option ORA_ZCA_IMPORT_ENABLE_RECORDNAME_SUPPORT to Y. By default this profile option has a
value N. If you use the Record Name attribute to update records, the following order of precedence is used to identify
the records:

1. ID (PK)
2. RecordNumber (PUID)
3. RecordName (AlternatePUID)

However, you can't update the Recordname attribute value.

Related Topics
• Publish Sandboxes
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Import Custom Object Data  
You can import custom object data into Sales and Fusion Service. Before importing custom data, create the parent and
child custom objects for the data you want to import.

In this example, we will create a parent object (CustomOrder) and a child object (CustomOrderItem) with the required fields
and then import data for these objects.

Create the Parent and Child Objects
To create parent and child custom objects:

1. Navigate to Application Composer.
2. Click the Custom Objects icon on the Overview screen.
3. Click the Create New Object icon to bring up the Create Custom Object window. Note that your environment

must be in an active sandbox to perform this action.
4. Enter the value CustomOrder for Display Label. The other fields are automatically filled, which creates the parent

custom object CustomOrder.
5. Create the custom fields by clicking the Fields option under the CustomOrder object. Enter the display names

OrderName and OrderCount for the fields.
6. Click the CustomOrder icon on the side pane. On the Overview page, click the Create Child Object button to

create the child object CustomOrderItem.
7. Create the custom fields ItemName and ItemCount.
8. After creating the custom objects, publish and sign out from the sandbox.

Import Data for Parent Custom Object
To import data for parent custom objects only, follow these steps:

1. Create the CSV file using the following table:

RecordName OrderName OrderCount

CustomOrder1

 
01-A1-inventory
 

2000
 

CustomOrder2

 
02-B3-inventory
 

3000
 

2. Click Tools > Import Management.
3. On the Manage Imports page, click the Create Import Activity button to create an import activity

InsertCustomObject. For more information about creating an import, see the topic Import Data mentioned in
Related Topics section.

4. On the Create Import Activity page, provide the file name InsertCustomObject and select the custom object
CustomOrder from the Object drop-down list. Browse the CSV file that you created in step 1. Click Next.

5. On the mapping page, map the attributes as shown in the following table:

Column Header Example Value Attribute Display Name

RecordName CustomOrder1 CustomOrder Name
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Column Header Example Value Attribute Display Name

   

OrderName
 

01-A1-inventory
 

OrderName
 

OrderCount
 

2000
 

OrderCount
 

6. Review and activate the import activity.

Note:  If there are any mandatory fields in the custom object, then they must be included in the CSV file and a
value must be provided for all records when performing an import. The required values must be mapped on
the mapping page. In this example, OrderName is a mandatory attribute.

Import Multiple Child Records for an Existing Parent Record
After importing the parent record you can import data for child records associated with the parent record. To import
data for multiple child records for an existing parent custom object, follow these steps:

1. Create the CSV file using the following table.

RecordName CustomOrder_Id_c ItemName ItemCount

CustomOrder1_Item1
 

300100035820958
 

Electronics
 

150
 

CustomOrder1_Item2
 

300100035820958
 

Stationery
 

200
 

CustomOrder1_Item3
 

300100035820958
 

Computer Accessories
 

500
 

Note:  You can import the custom child of an object using the ParentRecordName attribute also.

2. Click Tools > Import Management.
3. On the Manage Imports page, click the Create Import Activity button to create an import activity

InsertCustomObject. For more information about creating an import, see the topic Import Data mentioned in
Related Topics section.

4. On the Create Import Activity page, provide the file name InsertCustomObject and select the custom object
CustomOrderItem from the Object drop-down list. Browse the CSV file that you created in step 1. Click Next.

5. On the mapping page, map the attributes as shown in the following table.

Column Header Example Value Attribute Display Name

RecordName
 

CustomOrder1_Item1
 

CustomOrderItem Name
 

CustomOrder_Id_c
 

300100035820958
 

CustomOrder_Id_c
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Column Header Example Value Attribute Display Name

ItemName
 

Electronics
 

ItemName
 

ItemCount
 

150
 

ItemCount
 

6. Review and activate the import activity.

Import Multiple Child Records with Different Parent Records
After importing the parent record you can import data for child records of the parent record. The Parent Record Object
Key values will be different depending on which parent record the child records are being imported for. To import data
for multiple child records with different parent object records, follow these steps:

1. Create the CSV file using the following table.

RecordName CustomOrder_Id_c ItemName ItemCount

CustomOrder1_Item1
 

300100035820958
 

Switches
 

50
 

CustomOrder1_Item2
 

300100035820958
 

Sockets
 

100
 

CustomOrder1_Item3
 

300100035820958
 

Regulators
 

50
 

CustomOrder2_Item1
 

300100035820960
 

Pencils
 

50
 

CustomOrder2_Item2
 

300100035820960
 

Sharpener
 

100
 

CustomOrder2_Item3
 

300100035820960
 

Eraser
 

50
 

Note:  You can import the custom child of an object using the ParentRecordName attribute also.

2. Click Tools > Import Management.
3. On the Manage Imports page, click the Create Import Activity button to create an import activity

InsertCustomObject. For more information about creating an import, see the topic Import Data mentioned in
the Related Topics section.

4. On the Create Import Activity page, provide the file name InsertCustomObject and select the custom object
CustomOrderItem from the Object drop-down list. Browse the CSV file that you created in step 1. Click Next.

5. On the mapping page, map the attributes as shown in the following table.

Column Header Example Value Attribute Display Name

RecordName CustomOrder1_Item1 CustomOrderItem Name
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Column Header Example Value Attribute Display Name

   

CustomOrder_Id_c
 

300100035820958
 

CustomOrder_Id_c
 

ItemName
 

Electronics
 

ItemName
 

ItemCount
 

150
 

ItemCount
 

6. Review and activate the import activity.

High Volume Import of Custom Objects
You can now use auditing functionality while performing high-volume import of custom objects. You can control base
table auditing by setting the profile option ORA_ZCA_IMPORT_ENABLE_AUDIT_HIGHVOLUME to Yes. The default value
is No.

1. To enable base table auditing, go to Setup and Maintenance.
2. Search for Manage Administrator Profile Values Profile Option code:

ORA_ZCA_IMPORT_ENABLE_AUDIT_HIGHVOLUME.
3. Set it to Yes, then Save.

Related Topics
• How do I import data?

Update Custom Object Data  
This example shows how to update custom object data in Sales and Fusion Service.

Update Only Parent Records
To create the parent and child custom objects, review the topic Import Custom Object Data referenced in the Related
Topics section. Perform the following steps to update only the parent records:

1. Create the CSV file based on the following table:

ID RecordName OrderName OrderCount

300100035820958
 

CustomOrder1

 
01-A1-inventory
 

90000
 

300100035820960
 

CustomOrder2

 
01-A1-inventory
 

70000
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2. Click Tools > Import Management.
3. On the Manage Imports page, click the Create Import Activity button to create an import activity

UpdateCustomObject. For more information about creating an import, see the topic Import Data mentioned in
the Related Topics section.

4. On the Create Import Activity page, provide the file name UpdateCustomObject and select the custom object
CustomOrder from the Object drop-down list. Browse the CSV file that you created in step 1. Click Next.

5. On the mapping page, map the attributes as shown in the following table.

Column Header Example Value Attribute Display Name

ID
 

300100035820958
 

Record ID
 

RecordName
 

CustomOrder1

 
CustomOrder Name
 

OrderName

 
01-A1-inventory
 

OrderName
 

OrderCount
 

90000
 

OrderCount
 

6. Review and activate the import activity.

Note:  The Parent Record Object Key should be taken from the log file generated by the parent insert import
job.

Update Only Child Records
To create the parent and child custom objects, review the topic Import Custom Object Data referenced in the Related
Topics section. Perform the following steps to update only the child records.

1. Create the CSV file using the following table.

ID RecordName ItemName ItemCount

300100035821118
 

CustomOrder1_Item1

 
Switches
 

2500
 

300100035821120
 

CustomOrder1_Item2
 

Sockets
 

1000
 

2. Click Tools > Import Management.
3. On the Manage Imports page, click the Create Import Activity button to create an import activity

UpdateCustomObject.
4. On the Create Import Activity page, provide the file name UpdateCustomObject and select the custom object

CustomOrderItem from the Object drop-down list. Browse the CSV file that you created in step 1. Click Next.
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5. On the mapping page, map the attributes as shown in the following table.

Column Header Example Value Attribute Display Name

ID
 

300100035821118
 

Record ID
 

RecordName
 

CustomOrder1_Item1
 

CustomOrder Name
 

ItemName

 
Switches
 

ItemName

 

ItemCount
 

2500
 

ItemCount
 

6. Review and activate the import activity.

Related Topics

Delete Custom Object Data  
This example shows how to delete custom object data in Sales and Fusion Service.

Perform the following steps to delete the custom object records:

1. Create the CSV file based on the following table:

ID RecordName

300100035820958
 

CustomOrder1

 

300100035820960
 

CustomOrder2

 

Note that you can delete a record using the Public Unique Identifier (PUID) key also.
2. Click Tools >  Import Management.
3. On the Manage Imports page, click the Create Import Activity button to start creating an import activity.
4. On the Create Import Activity page, enter the import activity name and select the custom object from the

Object drop-down list. Browse the CSV file that you created in step 1. In the Advanced Options section, select
the Import Mode as 'Delete records'. Click Next.

5. On the Map Fields page, map the attributes as shown in the following table.

Column Header Example Value Attribute Display Name

ID 300100035820958 Record ID
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Column Header Example Value Attribute Display Name

   

RecordName
 

CustomOrder1

 
CustomOrder Name

 

6. Review and submit the import activity.
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8  Import Your Data

Import Account Data  

How do I import account data?  
You can use Import Management to create, update, or delete your account data.

You can import account records using these steps:

1. Map your source account data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.

2. Create the source CSV file with the account data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import account data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to
target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Note:   You can enable automatic territory-based assignment after sales accounts are imported. You can enable this
feature by turning the profile option ZCA_BATCH_ASSIGN_ON_BULK_IMPORT ON. If the profile option is disabled,
then you must manually run a batch assignment or assign each sales account individually.

To better manage your account information, the account object has the following child objects:

• Address

• Classification

• Relationship

• Sales Team Member

Note:  You can't set an attribute value to NULL in high-volume import (import management with the option Enable
High-Volume Import selected). However, when updating a record, you can change an attribute value from NOT NULL
to NULL
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If you're importing account records with attributes specific to the parent account object or along with single child record
details (like phone, email, address, and so on), then you can include the child record details in the same .csv file for
account object. However, if you're importing multiple records of any child object, then you must create multiple .csv
files to import- one for each child which has multiple records that you're importing. For example, if you're importing 5
emails, 5 phones, and 5 addresses for an account, then you must create three import files - one for Account object, one
for Contact Point object (phone and email), and one for Address object. There are separate help topics describing how
to import each of these child objects. For more information, see the related topics section.

Note:  High-volume import for accounts now supports hierarchy management and generation.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data. For example, when
using source system reference information to identify your account records, the source system of the account
object should be enabled for parties using the Manage Trading Community Source Systems task.

• You have all parent records in place before importing child records. For example, when importing the address of
an account, ensure the account exists.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For account object, the attribute is PartyNumber and shows up
in the UI as Party Number. For more information about public unique identifiers, see the topic "How You Use
Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new accounts or are
updating accounts that have source system reference data, then provide the source system and source system
reference values. For account object, these are SourceSystem and SourceSystemReferenceValue and show up
as Party Source System and Party Source System Reference Value in the UI.

Review Required Attributes and Validations for Account Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for account records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an Account
Record

Updating an Existing
Account Record

Deleting an Existing
Account Record

SourceSystem
 

The source system for
the sales account.
 

Know the source
system.
 

Conditionally Required
 

Conditionally Required
 

Conditionally Required
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an Account
Record

Updating an Existing
Account Record

Deleting an Existing
Account Record

To view source
systems, use the
Manage Trading
Community Source
System task.
 

To identify an account
record, use one of
these:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

To identify an account
record, use one of
these:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

To identify an account
record, use one of
these:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

SourceSystemReferenceValue
 

The reference number
or text representing
the source system
unique ID for the party
(account or contact) to
which the sales profile
belongs.
 

Know the source
system reference
value.
 
To view the source
systems reference, use
the Manage Trading
Community Source
System task.
 

Conditionally Required
 
To identify an account
record, use one of
these:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

Conditionally Required
 
To identify an account
record, use one of
these:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

Conditionally Required
 
To identify an account
record, use one of
these:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

PartyNumber
 

The public unique
identifier of the party.
 

The party must exist.
 
You get a list of all
party IDs and party
numbers by exporting
the Party object.
 

Conditionally Required
 

Conditionally Required
 

Conditionally Required
 

OrganizationName
 

The name of the party
of the Organization
party type.
 

Organization names
are listed in the
Resource Directory.
 

Required
 

Conditionally Required
 

Conditionally Required
 

OwnerPartyId
 

The identifier of the
account owner.
 

This attribute is
required only in
import management,
but optional in high-
volume import.
 

Required
 

Not Required
 

Not Required
 

Note:  When deleting or updating accounts, you must ensure that the account related to the party number provided
has the Sales Account usage. If you provide the party number of an account that doesn't have the Sales Account
usage, then the relationships for that account are also deleted. For example, if you provide the party number
ORA17292 that doesn't have a Sales Account usage, then the related partners, contacts, and so on are also deleted.

For the extension child objects of account, RecordName field isn't unique. Hence you can't update the records only by
passing RecordName.

You can use the profile option ORA_HZ_IMPORT_MULTI_ADDRESS_TYPE to control how address types are entered. By
default this profile option is set to Yes, so you can enter multiple address types, during high-volume import of Account,
Contact, and Household objects . You can disable this profile option to improve the import performance. When you set
this profile option to No, you can enter only a single address type.
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Note:   When importing accounts or legal entities, you can retrieve duplicates using the Customer Data Management
Duplicates LOV only if you have licensed the data quality functionality. Once licensed, you must rebuild the keys for
your matching configuration using the Manage Enterprise Data Quality Matching Configurations task. After the keys
are rebuilt, the matching functionality uses the settings in the match configuration to identify duplicates.

Go to Navigator  > Tools >  Import Management >  Import Objects to see all the attributes of the account object. The
page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Account object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Providing the ZIP and Country Code values in the import CSV file won't automatically populate the State/County/City
fields. Values for these fields should be separately provided in the import file.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the account information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Account from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Note:  After importing your data successfully, you need to run a couple of post processing jobs for duplicate
identification, duplicate resolution, and account assignment. For more information on import management post
processing jobs, see the topic Import Management Post Processing Jobs

When importing accounts you can now load the account hierarchy data. Use the following attributes to import accounts:

• ParentAccountPartyId

• ParentAccountPartyNumber

• ParentAccountSourceSystem

• ParentAccountSourceSystemReferenceValue

You can load account hierarchy data. To load the account hierarchy data:

1. Load the account data without providing values for the parent attributes mentioned above.
2. Load the account hierarchy using the Hierarchy and Hierarchy Member import objects. For more information,

see How do I import hierarchy data? and How do I import hierarchy member data?

Delete an Account

Related Topics
• How do I import data?

• Import Your Address Data

• How do I import contact point data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• How You Enable Automatic Account Assignment

Example of Adding or Updating Primary Contact  
You can add or update the primary contact of an account using import management. Before adding or updating the
primary account, ensure that the contact exists.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can add or update a primary contact by submitting any one or more
of the unique identifiers.

List of Account Identifiers:

• PartyId

• PartyNumber

• SourceSystem and SourceSystemReferenceValue
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List of Contact Identifiers:

• PrimaryContactPartyId

• PrimaryContactPartyNumber

• PrimaryContactSourceSystem and PrimaryContactSourceSystemReferenceValue

To add or update the primary contact of an account, you must create a source file (CSV) and import it using import
management. Below table lists the attributes using Party ID and Primary Contact Party ID as identifier:

Attribute Name Value

PartyId
 

300100545540269
 

PrimaryContactPartyId
 

300100545059765
 

Create the Import Activity
After you have the CSV file ready, create an import activity to import the account information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Account from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• How You Enable Automatic Account Assignment
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Example of Changing or Assigning Owner of an Account  
You can change or assign the owner of an account using import management. Before changing or assigning the owner,
ensure that the account exists and the owner is an active or valid resource.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can change or assign the owner of an account by submitting any one
or more of the unique identifiers.

List of Account Identifiers:

• PartyId

• PartyNumber

• SourceSystem and SourceSystemReferenceValue

List of Owner Identifiers:

• OwnerPartyId

• OwnerPartyNumber

• OwnerSourceSystem and OwnerSourceSystemReferenceValue

To change owner of an account, you must create a source file (CSV) and import it using import management. Below
table lists the attributes using Party ID and Owner Party ID as identifier:

Attribute Name Value

PartyId
 

300100545540596
 

OwnerPartyId
 

300100545540269
 

Create the Import Activity
After you have the CSV file ready, create an import activity to import the account information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• How You Enable Automatic Account Assignment

How do I import account contact data?  
You can use Import Management to create update, or delete Account Contact records as child under Account object.
This automatically also creates relationship record, associating referenced contact and account which can be viewed
under relationship child object.

To import Account Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Account Contact data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent or referenced records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can import account contact object by submitting any one or more
of the conditionally required attributes. You can provide a combination of Account and Contact identifiers for create
and update. Alternatively for Update scenario, you can provide the primary unique identifier or one of the relationship
identifiers.

List of Contact Identifiers:

• ContactPartyId

• ContactPartyNumber

• ContactSourceSystem and ContactSourceSystemReferenceValue

List of Account Identifiers:

• AccountPartyId

• AccountPartyNumber

• AccountSourceSystem and AccountSourceSystemReferenceValue

List of Relationship Identifier:

• RelationshipRecId

• RelationshipSourceSystem and RelationshipSourceSystemReferenceValue

Primary unique identifier: AccountContactId is the primary unique identifier which is auto generated. You can use this
identifier to update account contact record.

Required Attributes and Validations for Account Contact Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Account
Contact records, required attributes for updating Account Contact records, prerequisite setup tasks for the attributes,
and specific validations, if any, for Account Contact import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Account
Contact Record

Updating an Existing
Account Contact Record

AccountContactId
 

The unique identifier of the
account contact which is
system generated.
 

Should be a valid value
which exists in the
application
 

Not Applicable
 

Conditionally Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Account
Contact Record

Updating an Existing
Account Contact Record

RelationshipRecId
 

Alternate unique identifier
for the account contact
which is system generated.
 

Should be a valid value
which exists in the
application
 

Not Applicable
 

Conditionally required
 

ContactPartyId
 

The primary key identifier
of the subject in this
relationship. Either
one of ContactPartyId,
 ContactPartyNumber,
 or a combination of
ContactSourceSystem and
ContactSourceSystemReferenceValue,
 is used to identify the
subject party of the
relationship.
 

The contact must exist
 

Conditionally Required
 
Provide a value along
with Account identifier
to uniquely identify
referenced account and
contact records to create
account contact record
 

Conditionally Required
 
Provide a value along
with Account identifier to
uniquely identify account
contact record for update
 

ContactPartyNumber
 

The public key identifier
for the Contact party of
the relationship. Either
one of ContactPartyId,
 ContactPartyNumber,
 or a combination of
ContactSourceSystem and
ContactSourceSystemReferenceValue,
 is used to identify the
Contact party of the
relationship.
 

The contact must exist
 

Conditionally Required
 
Provide a value along
with Account identifier
to uniquely identify
referenced account and
contact records to create
account contact record
 

Conditionally Required
 
Provide a value along
with Account identifier to
uniquely identify account
contact record for update
 

ContactSourceSystem
 

The name of external
source system for the
subject party in the
relationship, which are
defined by an administrator
as part of system setup. To
be used in combination of
ContactSourceSystemReferenceValue.
 

The value for this attribute
should be predefined using
the setup task Manage
Trading Community Source
Systems
 

Conditionally Required
 
Provide a value along with
ContactSourceSystemReferenceValue
for uniquely identifying a
contact record
 
Additionally, provide an
Account Identifier
 

Conditionally Required
 
Provide a value along with
ContactSourceSystemReferenceValue
for uniquely identifying a
contact record
 
Additionally, provide an
Account Identifier
 

ContactSourceSystemReferenceValue
 

The identifier for the
subject party in the
relationship from external
source system. To be
used in combination with
ContactSourceSystem.
 

The Source System
Reference value should
exists for the Contact
 

Conditionally Required
 
Provide a value along with
ContactSourceSystem
for uniquely identifying a
contact record
 
Additionally, provide an
account identifier
 

Conditionally Required
 
Provide a value along with
ContactSourceSystem
for uniquely identifying a
contact record
 
Additionally, provide an
account identifier
 

AccountPartyId
 

The primary key identifier
of the object in this
relationship. Either
one of AccountPartyId,
 AccountPartyNumber,
 or combination of
AccountSourceSystem and
AccountSourceSystemReferenceValue,
 is used to identify the

The Source System
Reference value should
exists for the Contact
 

Conditionally Required
 
Provide a value along
with Contact identifier
to uniquely identify
referenced account and
contact records to create
account contact record
 

Conditionally Required
 
Provide a value along
with Contact identifier to
uniquely identify account
contact record for update
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Account
Contact Record

Updating an Existing
Account Contact Record

Account party of the
relationship.
 

AccountPartyNumber
 

The public unique
identification number
for the object party of
the relationship Either
one of AccountPartyId,
 AccountPartyNumber
or combination of
AccountSourceSystem and
AccountSourceSystemReferenceValue,
 is used to identify the
Account party of the
relationship.
 

No Validation
 

Conditionally Required
 
Provide a value along
with Contact identifier
to uniquely identify
referenced account and
contact records to create
account contact record
 

Conditionally Required
 
Provide a value along
with Contact identifier to
uniquely identify account
contact record for update
 

AccountSourceSystem
 

The name of external
source system for the
subject party in the
relationship, which
are defined by an
administrator as part
of system setup. To be
used in combination with
AccountSourceSystemReferenceValue.
 

The value for this attribute
should be predefined using
the setup task Manage
Trading Community Source
Systems
 

Conditionally Required
 
Provide a value along with
AccountSourceSystemReferenceValue
for uniquely identifying an
account record
 
Additionally, provide a
contact identifier
 

Conditionally Required
 
Provide a value along with
AccountSourceSystemReferenceValue
for uniquely identifying an
account record
 
Additionally, provide a
contact identifier
 

AccountSourceSystemReferenceValue
 

The name of external
source system for the
subject party in the
relationship, which are
defined by an administrator
as part of system setup.
To be used in combination
with AccountSourceSystem.
 

The Source System
Reference value should
exist for the Account
 

Conditionally Required
 
Provide a value along with
AccountSourceSystem for
uniquely identifying an
account record
 
Additionally, provide a
contact identifier
 

Conditionally Required
 
Provide a value along with
AccountSourceSystem for
uniquely identifying an
account record
 
Additionally, provide a
contact identifier
 

RelationshipSourceSystem
 

The name of external
source system for the
relationship record,
 which are defined by
an administrator as part
of system setup. To be
used in combination with
RelationshipSourceSystemReferenceValue.
 

The value for this attribute
should be predefined using
the setup task Manage
Trading Community Source
Systems
 

Optionally Required
 

Conditionally Required for
uniquely identifying an
account contact record
 
Additionally,
 provide a value for
RelationshipSourceSystemReferenceValue
 

RelationshipSourceSystemReferenceValue
 

The name of external
source system for the
relationship record,
 which are defined by
an administrator as part
of system setup. To be
used in combination with
RelationshipSourceSystem.
 

The Source System
Reference value should
exists for the Contact.
 

Optionally Required
 

Conditionally Required for
uniquely identifying an
account contact record
 
Additionally
provide a value for
RelationshipSourceSystem
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You can view the Account Contact object and its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Account Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Account Contact from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records
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Import Your Action Data  
You can use the import functionality to create, update, or delete your action data.

You can import action records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the action data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import action data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to
target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the action import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

To better manage your action information, the action object has the following child objects:

• Action Attribute

• Action Condition

If you want to import only a few records, then you can create a single CSV file for all action attributes. However if you
want to import a large number of records, then you may decide to create multiple CSV files, one for each of the action
child objects. Note that you must have imported the CSV file for action object successfully before trying to import the
CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For
more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
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attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new actions or are
updating actions that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Action Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for action records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Action record Updating an Existing
Action record

Action
 

The name of the action
that's associated associated
with an action plan
template or action plan
instance.
 

None
 

Required
 

Not required
 

Action Id
 

The unique Id of the
existing Action record
in the Oracle Fusion
destination table.
 

Identify the Action ID
value by exporting the
Action object. To export,
 navigate to Tools >  Export
Management >  Create
Export Activity.
 

Required
 

A value is required if you're
updating an existing
Action and you're not
providing the Action
Number. The Action ID is
autogenerated in Oracle
Fusion applications, if you
don't specify a value.
 

ActionNumber
 

The unique ID for the
existing Action record
in the Oracle Fusion
destination table.
 

None
 

Optional
 

A value is required if you're
updating an existing Action
and you're not providing
the Action Id.
 

Parent Entity Name
 

The entity name of the
object for which the action
can be used in an action
plan.
 

None
 
If providing a value, it must
be ServiceRequest.
 

Conditionally required
 
A value is required only
when you're inserting
a parent entity name.
However, a value isn't
required when you delete
or update an existing
parent entity name.
 

Conditionally required
 
A value is required only
when you're inserting
a parent entity name.
However, a value isn't
required when you delete
or update an existing
parent entity name.
 

Duration
 

The estimated time to
complete the action.
 

None
 

Required
 

Required
 

Duration Unit
 

The unit of measurement
for lead time.
 

None
 
If you intend to specify a
value, select a value from

Required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Action record Updating an Existing
Action record

the list of valid values in the
lookup type ORA_SVC_AP_
LEAD_TIME_UNIT.
 

Object Entity Name
 

Entity name of the object
on which the action is
based.
 

None
 

Conditionally required
 
A value is required only
when you're inserting
an object entity name.
However, a value isn't
required when you delete
or update an existing object
entity name.
 

Conditionally required
 
A value is required only
when you're inserting
an object entity name.
However, a value isn't
required when you delete
or update an existing object
entity name.
 

Original System Reference
 

Specifies the original
system reference if this
record was imported.
 

Identify the original system
and system reference
values from your source
system that were imported
when you imported the
resource.
 

Optional
 

Optional
 

Object Entity Type
 

The entity type of the
object on which the action
is based.
 

The valid values are
ServiceRequest, Task, and
Appointment.
 

Required
 

Not required
 
A value is required only
when you're inserting an
object entity type. However,
 a value isn't required when
you delete or update an
existing object entity type.
 

Visibility
 

Indicates the visibility level
of the action.
 

If you intend to specify a
value, select a value from
the list of valid values in the
lookup type ORA_SVC_AP_
VISIBILITY_CD.
 

Required
 

Not required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the action object. The
page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Action object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the action information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Action.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Action from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Action Attribute Data  
You can use the import functionality to create, update, or delete action attribute data.

You can import action attribute records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the action condition data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.
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How You Map Your Source Data to Target Object Attributes
You import action attribute data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the action import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all action conditions. However if you
want to import a large number of records, then you may decide to create multiple CSV files, one for each of the action
child objects. Note that you must have imported the CSV file for action object successfully before trying to import the
CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For
more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new actions or are
updating actions that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Action Attribute Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for action attribute records, prerequisite setup tasks and specific validations, if
any:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Action
Attribute record

Updating an Existing
Action Attribute record

Action Attribute Id
 

The unique Id of the
existing Action Attribute
record in the Oracle Fusion
destination table.
 

Identify the Action Attribute
ID value by exporting
the Action object by
navigating to Tools > 
Export Management > 
Create Export Activity.
 

Not required
 

A value is required if you're
updating an existing Action
attribute and you're not
providing the Action source
system (original system)
 

Action Code
 

Indicates the operation to
be performed on a row,
 such as insert, update, and
so on
 

If a value isn't provided,
 records are matched to
determine if a record is
updated (if it already exists)
or inserted (if it doesn't
exist).
 

Not required
 

A value is required, if you're
deleting an action attribute.
 

ActionId
 

Specifies the foreign key
that references the Action
ID to which the action is
assigned.
 

Identify the Action ID
value by exporting the
Action object by navigating
to Tools >  Export
Management >  Create
Export Activity.
 

Not required
 

A value is required, if you're
updating an existing Action
Id and you're not providing
the Action Id source system
code and reference Action
OSR.
 

ActionOSR
 

Specifies the action original
system reference, if the
record was imported.
 

Identify the original
system and system
reference values from
your source system which
were imported when you
imported the resource.
 

Required
 

A value is required if you're
updating an existing Action
Id record and you're not
providing the record's
unique ID (ActionId)
 

AttributeName
 

Attribute from the entity
object of the associated
action.
 

None
 

Not Required
 

Not Required
 

AttributeValue
 

The value to be set on the
Action attribute.
 

None
 

Not Required
 

Not Required
 

AttributeValueContextCd
 

The context of how the
attribute value should be
interpreted (for example, as
an attribute of the parent
action's object, an attribute
of the parent action, or a
custom value).
 

The valid values provided
by the lookup type ORA_
SVC_AP_CONTEXT_CD.
 

Required
 

Not required
 

Deleted
 

Indicates whether the
service request is to be
deleted. If the value is Y,
 then the service request is
deleted. The default value
is N.
 

None
 

Not required
 

Not required
 

ErrorMessage
 

This column displays the
error messages, if any.
 

None
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Action
Attribute record

Updating an Existing
Action Attribute record

ErrorMessage
 

This column displays the
error messages, if any.
 

None
 

Not required
 

Not required
 

InternalOvn
 

This is meant for internal
use.
 

None
 

Not required
 

Not required
 

JobDefinitionName
 

Indicates the name of the
job that created or last
updated the row.
 

None
 

Not required
 

Not required
 

JobDefinitionPackage
 

Indicates the package name
of the job that created or
last updated the row.
 

None
 

Not required
 

Not required
 

UsageCd
 

Indicates when the attribute
is to be used.
 

The valid value is ORA_
SVC_CREATE.
 

Required
 

Not required
 

You can view the Action Attribute object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Action Attribute object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the action attribute information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Action Attribute from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
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7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Import Your Action Data

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Action Condition Data  
You can use the import functionality to create, update, or delete your action condition data.

You can import action condition records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the action condition data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import action condition data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the action import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all action conditions. However if you
want to import a large number of records, then you may decide to create multiple CSV files, one for each of the action
child objects. Note that you must have imported the CSV file for action object successfully before trying to import the
CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For
more information, see the related topics section.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

The preferred option to uniquely identify an object record is through the Internal ID.

If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the
record, a system-generated unique identifier attributes with "id" in the attribute name are typically internal IDs. You can
determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional
database query. Using an internal ID typically provides better performance and reduces the import duration. For the
Action Condition Object, the attributes are Action ConditionId and ActionId:

Required Attributes and Validations for Action Condition Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for action condition records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Action
Condition record

Updating an Existing
Action Condition record

ActionCode
 

Indicates the operation to
be performed on a row,
 such as insert, update, and
so on
 

If a value isn't provided,
 records are matched to
determine if a record is
updated (if it already exists)
or inserted (if it doesn't
exist).
 

Not required
 

A value is required, if
you're deleting an action
condition.
 

Action ConditionId
 

The unique Id of the
existing Action Condition
record in the Oracle Fusion
destination table.
 

Identify the Action
Condition ID value by
exporting the Action
object. To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Not required
 

A value is required if you're
updating an existing Action
Condition attribute and
you're not providing the
Action source system
(original system)
 

Action Id
 

Specifies the foreign key
that references the Action
ID to which the action is
assigned.
 

Identify the Action ID
value by exporting the
Action object. To export,
 navigate to Tools >  Export
Management >  Create
Export Activity.
 

Not required
 

A value is required, if you're
updating an existing Action
Id and you're not providing
the Action Id source system
code and reference Action
OSR.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Action
Condition record

Updating an Existing
Action Condition record

ActionStatus
 

Indicates the status to set
an action if the condition is
met.
 

Valid values provided by
the lookup type ORA_SVC_
AP_STATUS_CD.
 

Required
 

Not required
 

ActionNumber
 

Specifies the action original
system reference, if the
record was imported.
 

Identify the original
system and system
reference values from
your source system which
were imported when you
imported the resource.
 

Required
 

A value is required only if
you're not specifying the
Action ID.
 

You can view the Action Condition object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Action Condition object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the action condition information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Action Condition from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
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2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Import Your Action Data

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Action Plan Data  
You can use Import Management to create or update Action Plan records.

To import Action Plan records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Action Plan data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
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attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new action plans or are
updating action plans that have source system reference data, then provide the source system and source
system reference values.

Required Attributes and Validations for Action Plan Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Action Plan
records, required attributes for updating Action Plan records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Action Plan import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Action Plan
Record

Updating an Existing
Action Plan Record

ActionPlanId
 

The unique identifier of the
action plan.
 

A valid primary key for
the action plan record in
the destination system
is required. Either the
ActionPlanNumber or the
ActionPlanId is required. If
both are present, then the
ActionPlanId is preferred.
 

Not Required
 
Auto-generated in the
destination system
 
 

Optional
 
Either the
ActionPlanNumber or the
ActionPlanId is required to
update the row.
 

CalendarId
 

The calendar identifier
associated with the action
plan.
 

A valid calendar record in
the destination system.
 

Required
 

Not Required
 

ObjectEntityName
 

The parent entity object
name of the action plan.
 

A valid value from the ORA_
SVC_AP_OBJ_ENTITY_
NAME lookup in the
destination system.
 

Required
 

Not Required
 

ObjectId
 

The object identifier of the
action plan.
 

A valid primary key for
the parent record in the
destination system.
 

Required
 

Not Required
 

StatusCd
 

The status of the action
plan.
 

A valid value from the ORA_
SVC_AP_PROCESS_CD
lookup in the destination
system.
 

Optional
 
If no value is passed, then
the default value ORA_
SVC_CREATE is used.
 

Optional
 

TemplateNumber
 

The reference number of
the action plan template.
 

A valid PUID for action
plan template row in the
destination system. It is
optional if the action plan
is created without an action
plan template.
 

Optional
 
Required only when there is
a Template ID for the action
plan in the source system.
 

Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Action Plan
Record

Updating an Existing
Action Plan Record

ActionPlanNumber
 

The reference number of
the action plan.
 

A valid PUID for the action
plan row in the destination
system.
 

Optional
 
The PUID can be provided
if it needs to be maintained
between the source and
destination systems.
 

Required
 

You can view the Action Plan object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Action Plan object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Action Plan.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Action Plan from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Action Plan.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Action Plan Action Data  
You can use Import Management to create or update Action Plan Action records.

To import Action Plan Action records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Action Plan Action data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.
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• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new action plan actions or
are updating action plan actions that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Action Plan Action Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Action Plan
Action records, required attributes for updating Action Plan Action records, prerequisite setup tasks for the attributes,
and specific validations, if any, for Action Plan Action import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Action Plan
Action Record

Updating an Existing
Action Plan Action Record

SkipFlag
 

Contains the values, Y or
N. If Y is used, then the
action for the action plan is
skipped. If N is used, then
the action for the action
plan isn't skipped.
 

The default value is 'N'.
 

Optional
 

Optional
 

TemplateNumber
 

The reference number of
the action plan template.
 

A valid PUID for action
plan template row in the
destination system. It is
optional if the action plan
is created without an action
plan template.
 

Optional
 
Required only when there is
a Template ID for the action
plan action in the source
system.
 

Not Required
 

ActionId
 

The unique identifier of the
action.
 

A valid action Id in the
destination system.
 

Optional
 

Not Required
 

ActionNumber
 

The reference number of
the action.
 

A valid PUID action value
in the destination system.
Either the ActionId or the
ActionNumber is required.
If both are present, then the
ActionId is preferred.
 

Required
 
Either the ActionId or the
ActionNumber is required
to create the action row in
the destination system.
 

Not Required
 

ActionPlanActionId
 

The action identifier of the
action plan.
 

A valid primary key for the
action plan action record
in the destination system
is required. Either the
ActionPlanActionNumber
or the ActionPlanActionId
is required. If both
are present, then the
ActionPlanActionId is
preferred.
 

Not Required
 

Optional
 
Either the
ActionPlanNumber or the
ActionPlanId is required to
update the row.
 

DeletedFlag
 

Contains the values, Yes or
No. If Yes is used, then the
action in the action plan is
deleted. If No is used, then
the action in the action plan
isn't deleted.

A valid value from the YES_
NO lookup.
 

Optional
 

Optional
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Action Plan
Action Record

Updating an Existing
Action Plan Action Record

 

MandatoryFlag
 

Contains the values, Yes
or No. If Yes is used, then
the action in the action
plan is mandatory. If No is
used, then the action in the
action plan isn't mandatory.
 

A valid value from the YES_
NO lookup.
 

Optional
 

Optional
 

ActionPlanNumber
 

The reference number of
the action plan.
 

A valid PUID for the action
plan row in the destination
system.
 

Required
 
Either the ActionPlanId
or the ActionPlanNumber
is required to create
the action row in the
destination system.
 

Not Required
 

ActionPlanId
 

The unique identifier of the
action plan.
 

A valid primary key for
the action plan record in
the destination system
is required. Either the
ActionPlanNumber or the
ActionPlanId is required. If
both are present, then the
ActionPlanId is preferred.
 

Optional
 

Not Required
 

ActionPlanActionNumber
 

The reference number
of the action plan action
object.
 

A valid action plan action
PUID in the destination
system.
 

Optional
 

Required
 

You can view the Action Plan Action object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Action Plan Action object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Action Plan Action.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Action Plan Action from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Action Plan Action.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Action Plan Action Relation Data  
You can use Import Management to create or update Action Plan Action Relation records.

To import Action Plan Action Relation records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Action Plan Action Relation data into Oracle Applications Cloud, you need to populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new action plan action
relations or are updating action plan action relations that have source system reference data, then provide the
source system and source system reference values.

Required Attributes and Validations for Action Plan Action Relation Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Action Plan
Action Relation records, required attributes for updating Action Plan Action Relation records, prerequisite setup tasks
for the attributes, and specific validations, if any, for Action Plan Action Relation import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Action Plan
Action Relation Record

Updating an Existing
Action Plan Action
Relation Record

DeletedFlag
 

Contains the values, Yes
or No. If Yes is used, then
the dependency record is
deleted. If No is used, then
the then the dependency
record isn't deleted.
 

A valid value from the YES_
NO lookup.
 

Optional
 

Optional
 

RelationId
 

The relation identifier
between actions in an
action plan.
 

A valid primary key for the
action plan action relation
record in the destination
system is required.
 

Not Required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Action Plan
Action Relation Record

Updating an Existing
Action Plan Action
Relation Record

DepActionPlanActionNumber
 

The relation identifier
between action plan action
rows for an action plan.
 

A valid action plan action
PUID in the destination
system is required.
 
The combination of
ActionPlanActionNumber
and
DepActionPlanActionNumber
should be unique for a
Action Plan.
 

Optional
 
A Null value is accepted.
 

Optional
 
A Null value is accepted.
 

DepActionPlanActionId
 

The dependent action
identifier of an action plan.
 

A valid primary key for
the action plan action
record in the destination
system is required. Either
the DepActionPlanActionId
or the
DepActionPlanActionNumber
is required. If both
are present, then the
DepActionPlanActionId is
preferred.
 

Optional
 
A Null value is accepted.
 
Either
DepActionPlanActionNumber
or DepActionPlanActionId
is required to locate a
ActionPlanAction row.
 

Optional
 
A Null value is accepted.
 

ActionPlanActionId
 

The action identifier of the
action plan.
 

A valid primary key for the
action plan action record
in the destination system
is required. Either the
ActionPlanActionNumber
or the ActionPlanActionId
is required. If both
are present, then the
ActionPlanActionId is
preferred.
 

Optional
 
Either
ActionPlanActionNumber
or ActionPlanActionId is
required to locate a Action
Plan Action row.
 

Optional
 

ActionPlanActionNumber
 

The reference number
of the action plan action
object.
 

A valid action plan action
PUID in the destination
system.
 

Required
 

Optional
 

You can view the Action Plan Action Relation object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Action Plan Action Relation object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Action Plan Action Relation.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Action Plan Action

Relation from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Action Plan Action Relation.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

How do I import activity data?  
You can use Import Management to create, update, or delete your activity data.

You can import activity records using these steps:

1. Map your source activity data to Oracle Applications Cloud object attributes. This way the import process would
know where to insert each of the information bits.

2. Create the source CSV file with the activity data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.
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How You Map Your Source Data to Target Object Attributes
You import activity data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to
target Oracle Applications Cloud object attributes.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

To better manage your activity information, the activity object has the following child objects:

• Activity Assignee

• Activity Contact

• Activity Objectives

If you want to import only a few records, then you can create a single CSV file for all activity attributes. However if you
want to import a large number of records, then you may decide to create multiple CSV files, one for each of the activity
child objects. Note that you must have imported the CSV file for activity object successfully before trying to import the
CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For
more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new activities or are
updating activities that have source system reference data, then provide the source system and source system
reference values.
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Required Attributes and Validations for Activity Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for activity records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
record

Updating an Existing
Activity record

AccountId
 

The internal identifier of
the account associated
with the activity. Examples
of account are: customer,
 organization, person,
 partner.
 

The party must exist. You
can determine the PartyId
of the party by exporting
the Party object. To export,
 navigate to Tools >  Export
Management >  Create
Export Activity.
 

Not Required
 

If during update, you
associate the activity with
an account party, then
you must provide either
the internal ID, such as
AccountId, or the public
unique value, such as
AccountPartyNumber,
 or the combination of
original system and original
system reference, such as
AccountOrigSystem and
OsrAccountId.
 

AccountOrigSystem
 

The code representing
the source system for the
account associated with the
activity.
 

The party must exist.
Identify the source system
code that was used when
you imported the party in a
prior batch.
 

Not Required
 

If during update, you
associate the activity with
an account party, then
you must provide either
the internal ID, such as
AccountId, or the public
unique value, such as
AccountPartyNumber,
 or the combination of
original system and original
system reference, such as
AccountOrigSystem and
OsrAccountId.
 

AccountPartyNumber
 

The public unique identifier
of the account associated
with the activity.
 

The party must exist and
be a valid party unique
identifier
 

Not Required
 

If during update, you
associate the activity with
an account party, then
you must provide either
the internal ID, such as
AccountId, or the public
unique value, such as
AccountPartyNumber,
 or the combination of
original system and original
system reference, such as
AccountOrigSystem and
OsrAccountId.
 

ActionCode
 

Indicates explicitly the
operation to be performed
on a row: INSERT to
create a new record in the
destination tables, UPDATE
to update an existing record
in the destination table,

The valid values are
INSERT, UPDATE, and
DELETE. If not provided,
 record matching is used to
determine whether a record
is updated (if it already

Not Required
 

To delete a record, you
must provide the value
as DELETE. It is optional
to provide values for
insert and update as the
framework internally
decides the action as
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
record

Updating an Existing
Activity record

 DELETE to delete the
record.
 

exists) or inserted (if it
doesn't exist).
 

INSERT if it's a new record
or UPDATE if it's an existing
record.
 

ActivityEndDate
 

The date and time when
an appointment ends or
the time when a task is
completed.
 

This must be a valid date
and should not be less than
the ActivityStartDate.
 

A value is required
if you're creating a
new activity having
ActivityFunctionCode as
APPOINTMENT.
 

Optional
 

ActivityFunctionCode
 

Identifies the activity as
an appointment or a task.
This attribute is for internal
use only and the value is
set based on the user's
navigation to the activity.
 

Valid values are
APPOINTMENT, TASK, and
CALLREPORT. Lookup type
used is ZMM_ACTIVITY_
FUNCTION_TYPE_CD.
 

A value is required while
creating an activity.
 

Not Required
 

ActivityId
 

The internal identifier of
the activity.
 

Automatically generated
by the import process if
creating a new activity
record.
 

Not Required
 

A value is required if you're
updating an existing
activity and you're not
providing other values to
identify the activity record.
 
To update an existing
activity, choose one of the
following options to identify
the record:
 

• The unique ID for the
record (ActivityId)

• The activity number
(ActivityNumber)

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode)

ActivityNumber
 

The public unique identifier
of the activity. Indicates a
default system-generated
number for the activity.
 

If a value is provided while
creating a new activity, the
value must be unique. For
update, you can determine
the existing unique value of
the object by exporting the
Activity object. To export,
 navigate to Tools >  Export
Management >  Create
Export Activity.
 
The table ZMM_ACTY_
ACTIVITIES with column
ACTIVITY_NUMBER holds
the existing value.
 

Required
 

A value is required if you're
updating an existing
activity and you're not
providing other values to
identify the activity record.
 
To update or delete an
existing activity you must
choose one of the following
options to identify the
record:
 

• The unique ID for the
record (ActivityId)

• The activity number
(ActivityNumber)

• The source system
code and reference
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
record

Updating an Existing
Activity record

(OrigEntityNumber
and OrigEntityCode)

ActivityStartDate
 

The starting date and time
of an appointment or a
task. The default value for
an appointment is null. The
default value for a task is
the date and time at which
the task is created.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

A value is required
if you're creating a
new activity having
ActivityFunctionCode as
APPOINTMENT.
 

Optional
 

ActivityTypeCode
 

The channel through which
communication has taken
place.
 

If no value is provided,
 the corresponding value
from Activity production
table is used. If the
ActivityFunctionCode is
'APPOINTMENT' and the
action is 'INSERT' then
the default value is set to
'MEETING'.
 

If no value is provided,
 the corresponding value
is used from the Activity
production table. If the
ActivityFunctionCode
is APPOINTMENT and
the action is INSERT, the
default value is set to
MEETING.
 

Optional
 

CampaignId
 

The internal identifier of
the related campaign.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an Activity,
 if you associate the Activity
with a campaign, then
you must provide either
the internal ID, such as
CampaignId, or the public
unique value, such as
CampaignNumber.
 

When updating an Activity,
 if you associate the Activity
with a campaign, then
you must provide either
the internal ID, such as
CampaignId, or the public
unique value, such as
CampaignNumber.
 

CampaignNumber
 

The public unique identifier
of the related campaign.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an Activity,
 if you associate the Activity
with a campaign, then
you must provide either
the internal ID, such as
CampaignId, or the public
unique value, such as
CampaignNumber.
 

When updating an Activity,
 if you associate the Activity
with a campaign, then
you must provide either
the internal ID, such as
CampaignId, or the public
unique value, such as
CampaignNumber.
 

ClaimCode
 

The public unique identifier
for claim.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an Activity,
 if you associate the Activity
with a claim, provide either
the internal ID, such as
claim ID, or the public
unique value, such as claim
code. Ensure that this is a
valid claim code from MKT_
BDT_CLAIMS.
 

Optional. Ensure that this
is a valid claim code from
MKT_BDT_CLAIMS.
 

ClaimId
 

The internal identifier of
the claim.
 

You can determine the
public unique value of the
object by exporting the
object.
 

When creating an activity,
 if you associate the activity
with a claim, then you must
provide either the internal
ID, such as claim ID, or the
public unique value, such as

Optional. Ensure that this
is a valid claim ID from the
MKT_BDT_CLAIMS table.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
record

Updating an Existing
Activity record

To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

claim code. Ensure that this
is a valid claim ID from the
MKT_BDT_CLAIMS table.
 

CorpCurrencyCode
 

The corporate currency
used by the activity.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

If no value is provided,
 the corresponding value
is used from the Assignee
production table.
 

If no value is provided,
 the corresponding value
is used from the Assignee
production table.
 

CurcyConvRateType
 

The rate of currency
conversion for an activity.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

If no value is provided,
 the corresponding value
is used from the Assignee
production table.
 

If no value is provided,
 the corresponding value
is used from the Assignee
production table.
 

CurrencyCode
 

The corporate currency
used by the activity.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

If no value is provided,
 the corresponding value
is used from the Assignee
production table.
 

If no value is provided,
 the corresponding value
is used from the Assignee
production table.
 

CustomerAccountId
 

The internal identifier of
the customer account
related to the activity.
It is the sales activity
identifier from ZCA_SALES_
ACCOUNTS table.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

The internal identifier of
the customer account
related to the activity.
It is the sales account
identifier from ZCA_SALES_
ACCOUNTS table.
 

This should be a valid sales
account identifier from the
ZCA_SALES_ACCOUNTS
table.
 

DealId
 

The internal identifier
of the related deal
registration.
 

You can determine the
public unique value of the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Optional
 
When creating an activity,
 if you associate the activity
with a deal, you must
provide either the internal
ID, such as dealId, or the
public unique value, such as
DealNumber.
 

Optional
 
When creating an activity,
 if you associate the activity
with a deal, you must
provide either the internal
ID, such as dealId, or the
public unique value, such as
DealNumber.
 

DealNumber
 

The public unique identifier
of the deal associated with
the activity. The identifier
can also be generated from
an external source.
 

You can determine the
public unique value of the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Optional
 
When creating an activity,
 if you associate the activity
with a deal, you must
provide either the internal
ID, such as dealId, or the
public unique value, such as
DealNumber.
 

Optional
 
When creating an activity,
 if you associate the activity
with a deal, you must
provide either the internal
ID, such as dealId, or the
public unique value, such as
DealNumber.
 

DelegatorId
 

The internal identifier
of the activity resource
that delegated activity
ownership to another
resource.
 

The party must exist. You
can determine the PartyId
of the party by exporting
the Party object.
 
To export, navigate
to Tools >  Export

Optional
 
The party must exist. You
can determine the PartyId
of the party by exporting
the Party object.
 

Optional
 
The party must exist. You
can determine the PartyId
of the party by exporting
the Party object.
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Creating an Activity
record

Updating an Existing
Activity record

Management >  Create
Export Activity.
 

To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

DelegatorOrigSystem
 

The source system
reference to the delegator
of original system identifier.
 

The party must exist.
Identify the source system
code that was used when
you imported the party in a
prior batch.
 

The party must exist.
Identify the source system
code that was used when
you imported the party in a
prior batch.
 

Optional
 

DirectionCode
 

The direction options for
an activity. The options
are inbound, outbound, or
optional. The default value
is null.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

This should be a valid
lookup code corresponding
to ZMM_ACTIVITY_
DIRECTION from fnd_
lookups.
 

This should be a valid
lookup code corresponding
to ZMM_ACTIVITY_
DIRECTION from fnd_
lookups.
 

DueDate
 

The date the activity is due
to be completed.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

This should be a valid date.
 

This should be a valid date
 

Duration
 

The actual duration of the
activity in the appropriate
unit of measure.
 

If no value is provided,
 then the corresponding
value from Activity
production table is used. If
the ActivityFunctionCode
is 'APPOINTMENT' and
the Duration is NULL then
the default value is the
duration of days between
the Activity Start Date and
the Activity End Date.
 

This is a derived field. Any
value provided is ignored.
 

This is a derived field. Any
value provided is ignored
 

EnrollmentId
 

The internal identifier
of the related program
enrollment.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with a program enrollment,
 then you must provide
either the internal ID, such
as EnrollmentId, or the
public unique value, such
as EnrollmentNumber.
This must be a valid value
in the ZPM_PROGRAM_
ENROLLMENTS table.
 

If during update, you
associate the activity with
a program enrollment,
 then you must provide
either the internal ID, such
as EnrollmentId, or the
public unique value, such as
EnrollmentNumber.
 

EnrollmentNumber
 

The public unique identifier
of the related program
enrollment.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with a program enrollment,
 then you must provide
either the internal ID, such
as EnrollmentId, or the
public unique value, such
as EnrollmentNumber.
This must be a valid value

If during update, you
associate the activity with
a program enrollment,
 then you must provide
either the internal ID, such
as EnrollmentId, or the
public unique value, such as
EnrollmentNumber.
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Creating an Activity
record

Updating an Existing
Activity record

in the ZPM_PROGRAM_
ENROLLMENTS table.
 

FundRequestCode
 

The foreign key to FUND_
REQUEST_CODE of
the MKT_BDT_FUND_
REQUESTS table.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with a fund request,
 you must provide either
the internal ID, such as
FundRequestId, or the
public unique value, such
as FundRequestCode. This
must be a valid value in
the MKT_BDT_FUND_
REQUESTS table.
 

When updating an activity,
 if you associate the activity
with a fund request,
 you must provide either
the internal ID, such as
FundRequestId, or the
public unique value, such
as FundRequestCode. This
must be a valid value in
the MKT_BDT_FUND_
REQUESTS table.
 

FundRequestId
 

The internal identifier of
the fund request.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with a fund request,
 you must provide either
the internal ID, such as
FundRequestId, or the
public unique value, such
as FundRequestCode. This
must be a valid value in
the MKT_BDT_FUND_
REQUESTS table.
 

When updating an activity,
 if you associate the activity
with a fund request,
 you must provide either
the internal ID, such as
FundRequestId, or the
public unique value, such
as FundRequestCode. This
must be a valid value in
the MKT_BDT_FUND_
REQUESTS table.
 

LeadId
 

The internal identifier of
the related lead.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with a lead, then you must
provide either the internal
ID, such as LeadId, or the
public unique value, such as
LeadNumber. Must be valid
in the MKL_LM_LEADS
table.
 

If during update, you
associate the activity with
a lead, then you must
provide either the internal
ID, such as LeadId, or the
public unique value, such as
LeadNumber.
 

LeadNumber
 

The public unique identifier
of the related lead.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with a lead, then you must
provide either the internal
ID, such as LeadId, or the
public unique value, such as
LeadNumber. Must be valid
in the MKL_LM_LEADS
table.
 

If during update, you
associate the activity with
a lead, then you must
provide either the internal
ID, such as LeadId, or the
public unique value, such as
LeadNumber.
 

ObjectiveId
 

The internal identifier of
the objective.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with a sales objective,
 you must provide either
the internal ID, such as
ObjectiveId, or the public
unique value, such as
ObjectiveNumber. It must
be a valid value in the ZCA_
OBJECTIVES table.

When updating an activity,
 if you associate the activity
with a sales objective,
 you must provide either
the internal ID, such as
ObjectiveId, or the public
unique value, such as
ObjectiveNumber. It must
be a valid value in the ZCA_
OBJECTIVES table.
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Creating an Activity
record

Updating an Existing
Activity record

  

ObjectiveNumber
 

The public unique identifier
of the related objective.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with a sales objective,
 you must provide either
the internal ID, such as
ObjectiveId, or the public
unique value, such as
ObjectiveNumber. It must
be a valid value in the ZCA_
OBJECTIVES table.
 

When updating an activity,
 if you associate the activity
with a sales objective,
 you must provide either
the internal ID, such as
ObjectiveId, or the public
unique value, such as
ObjectiveNumber. It must
be a valid value in the ZCA_
OBJECTIVES table.
 

OpportunityId
 

The internal identifier of
the related opportunity.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with an opportunity,
 you must provide either
the internal ID, such as
OpportunityId, or the public
unique value, such as
OpportunityNumber. This
must be a valid value in the
MOO_OPTY table.
 

If during update, you
associate the activity
with an opportunity, then
you must provide either
the internal ID, such as
OpportunityId, or the public
unique value, such as
OpportunityNumber.
 

OpportunityNumber
 

The internal identifier of
the related opportunity.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with an opportunity,
 you must provide either
the internal ID, such as
OpportunityId, or the public
unique value, such as
OpportunityNumber. This
must be a valid value in the
MOO_OPTY table.
 

If during update, you
associate the activity
with an opportunity, then
you must provide either
the internal ID, such as
OpportunityId, or the public
unique value, such as
OpportunityNumber.
 

OrigEntityCode
 

The code indicating the
original source of the
record.
 

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.
 
If the record was created in
the Activity Management
component, the value is
ACTIVITY.
 

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.
 
If the record was created in
the Activity Management
component, the value is
ACTIVITY.
 

One of the following must
be provided while updating
an activity:
 

• ActivityId

• ActivityNumber

• Combination of
OrigEntityNumber
and OrigEntityCode

OrigEntityNumber
 

The original unique
identifier of the existing
task, appointment, or
interaction in the source
system.
 

If the internal action
code is 'INSERT' and
OrigEntityNumber and
ActivityNumber are NULL
then it's defaulted to
the provided value. If no
value is provided, the
corresponding value from
Activity production table is
used.
 

If the internal action
code is "INSERT" and
OrigEntityNumber and
ActivityNumber are NULL,
 it's defaulted to the
provided value.
 

One of the following must
be provided while updating
an activity:
 

• ActivityId

• ActivityNumber

• Combination of
OrigEntityNumber
and OrigEntityCode

122



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
record

Updating an Existing
Activity record

OsrAccountId
 

The internal identifier
(reference number or text)
of the account party in the
original source system.
 

The party must exist. You
can determine the Original
System Reference for the
party by exporting the
Party object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Optional
 
When creating an activity,
 if you associate the activity
with an account party, then
you must provide either
the internal ID, such as
AccountId, or the public
unique value, such as
AccountPartyNumber,
 or the combination of
original system and original
system reference, such as
AccountOrigSystem and
OsrAccountId
 

If during update, you
associate the activity with
an account party, then
you must provide either
the internal ID, such as
AccountId, or the public
unique value, such as
AccountPartyNumber,
 or the combination of
original system and original
system reference, such as
AccountOrigSystem and
OsrAccountId.
 

OsrDelegatorId
 

The source system
reference to the Delegator
ID.
 

The party must exist. You
can determine the Original
System Reference for the
party by exporting the
Party object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Optional
 
The party must exist. You
can determine the Original
System Reference for the
party by exporting the
Party object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Optional
 
The party must exist. You
can determine the Original
System Reference for the
party by exporting the
Party object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

OsrOwnerId
 

The internal identifier
(reference number or text)
of the person who owns
the activity in the original
source system.
 

The party must exist. You
can determine the Original
System Reference for party
by exporting the Party
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

One of the following must
be provided while creating
an activity:
 

• OwnerId

• OwnerResourceNumber

• Combination of
OwnerOrigSystem and
OsrOwnerId

The party must exist. You
can determine the Original
System Reference for the
party by exporting the
Party object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

OsrPrimaryContactId
 

The internal identifier
(reference number or text)
of the contact party in the
original source system.
 

The party must exist. You
can determine the Original
System Reference for the
party by exporting the
Party object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Optional
 
When creating the activity,
 if you associate the activity
with a contact party, then
you must provide either
the internal ID, such as
PrimaryContactId, or the
public unique value, such as
PrimaryContactPartyNumber,
 or the combination of
original system and original
system reference, such as
PrimaryContactOrigSystem
and OsrPrimaryContactId.
 

When updating an activity,
 if you associate the activity
with a contact party, then
you must provide either
the internal ID, such as
PrimaryContactId, or the
public unique value, such as
PrimaryContactPartyNumber,
 or the combination of
original system and original
system reference, such as
PrimaryContactOrigSystem
and OsrPrimaryContactId.
 

OsrReferenceCustomerId
 

The internal identifier
(reference number or text)

The party must exist. You
can determine the Original

When creating an activity,
 you associate the

When updating an activity,
 if you associate the
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Creating an Activity
record

Updating an Existing
Activity record

of the customer in the
original source system.
 

System Reference for the
party by exporting the
Party object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

activity with a referenced
customer party, then
you must provide either
the internal ID, such as
ReferenceCustomerId,
 or the public unique
value, such as
RefCustPartyNumber,
 or the combination of
original system and original
system reference, such as
RefCustOrigSystem and
OsrReferenceCustomerId.
 

activity with a referenced
customer party, then
you must provide either
the internal ID, such as
ReferenceCustomerId,
 or the public unique
value, such as
RefCustPartyNumber,
 or the combination of
original system and original
system reference, such as
RefCustOrigSystem and
OsrReferenceCustomerId.
 

OutlookFlag
 

Indicates whether the
activity is created in
Outlook. If the value is
Y, then the activity is
created in Outlook and
synchronized.
 

If no value is provided,
 the corresponding value
from Activity production
table is used. If the
ActivityFunctionCode is
'APPOINTMENT' and the
Action is 'INSERT' then the
value is set to 'N'.
 

If the ActivityFunctionCode
is APPOINTMENT and the
action is INSERT, the value
is set to N. Possible values
are Y and N.
 

Optional
 
Possible values are Y and N.
 

OwnerId
 

The internal identifier of
the activity owner. The
owner has to be an existing
party (person) in system.
 

The party must exist. You
can determine the PartyId
of a person by exporting
the Party object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Provide one of the
following while creating an
activity:
 
(OwnerId,
 OwnerResourceNumber,
 or a combination of
OwnerOrigSystem and
OsrOwnerId)
 

Optional
 
Provide one of the
following while updating an
activity:
 
(OwnerId,
 OwnerResourceNumber,
 or a combination of
OwnerOrigSystem and
OsrOwnerId)
 

OwnerOrigSystem
 

The code representing the
source system for the party
(person) who owns the
activity.
 

The party must exist. You
can determine the PartyId
of a person by exporting
the Party object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Provide one of the
following while creating an
activity:
 
(OwnerId,
 OwnerResourceNumber,
 or a combination of
OwnerOrigSystem and
OsrOwnerId)
 

Optional
 
Provide one of the
following while updating an
activity:
 
(OwnerId,
 OwnerResourceNumber,
 or a combination of
OwnerOrigSystem and
OsrOwnerId)
 

OwnerResourceNumber
 

The public unique identifier
of the party (person) who
owns the activity.
 

The party must exist. You
can determine the PartyId
of a person by exporting
the Party object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Provide one of the
following while creating an
activity:
 
(OwnerId,
 OwnerResourceNumber,
 or a combination of
OwnerOrigSystem and
OsrOwnerId)
 

Optional
 
Provide one of the
following while updating an
activity:
 
(OwnerId,
 OwnerResourceNumber,
 or a combination of
OwnerOrigSystem and
OsrOwnerId)
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Creating an Activity
record

Updating an Existing
Activity record

 

ParentActivityId
 

The related activity
identifier and only
applicable if the record is a
follow up activity.
 

Conditionally Required only
for follow-up activity. One
of the following options to
identify the parent record
must be provided:
 

• The unique ID for the
ParentActivityId.

• The parent
activity number
(ParentActivityNumber)

• The source system
code and source
reference code
(ParentOrigEntityNumber
and
ParentOrigEntityCode)

A value is required if
you're creating a follow-up
activity. While creating an
activity, choose one of the
following options to identify
the record:
 

• The unique ID for the
ParentActivityId.

• The parent
activity number
(ParentActivityNumber)

• The source system
code and source
reference code
(ParentOrigEntityNumber
and
ParentOrigEntityCode)

Optional
 
While updating an activity,
choose one of the following
options to identify the
record:
 
The unique ID for the
ParentActivityId.
 
The parent activity number
(ParentActivityNumber).
 
The source system code
and source reference code
(ParentOrigEntityNumber
and ParentOrigEntityCode).
 

ParentActivityNumber
 

The public unique identifier
of the related activity and
only applicable if the record
is a follow up activity.
 

Conditionally Required only
for follow-up activity. One
of the following options to
identify the parent record
must be provided:
 

• The unique ID
for the record
(ParentActivityId)

• The parent
activity number
(ParentActivityNumber)

• The source system
code and source
reference code
(ParentOrigEntityNumber
and
ParentOrigEntityCode)

A value is required if
you're creating a follow-up
activity. While creating an
activity, choose one of the
following options to identify
the record:
 

• The unique ID
for the record
(ParentActivityId)

• The parent
activity number
(ParentActivityNumber)

• The source system
code and source
reference code
(ParentOrigEntityNumber
and
ParentOrigEntityCode)

Optional
 
While updating an activity,
choose one of the following
options to identify the
record:
 
The unique ID for the
record (ParentActivityId).
 
The parent activity number
(ParentActivityNumber).
 
The source system code
and source reference code
(ParentOrigEntityNumber
and ParentOrigEntityCode).
 

ParentOrigEntityCode
 

The source of the activity
record that indicating
whether it's coming from
Task entity, Interaction
entity, or Appointment
entity.
 

Conditionally Required only
for follow-up activity. One
of the following options to
identify the parent record
must be provided:
 

• The unique ID
for the record
(ParentActivityId)

• The parent
activity number
(ParentActivityNumber)

• The source system
code and source
reference code
(ParentOrigEntityNumber

A value is required if
you're creating a follow-up
activity. While creating an
activity, choose one of the
following options to identify
the record:
 

• The unique ID
for the record
(ParentActivityId)

• The parent
activity number
(ParentActivityNumber)

• The source system
code and source
reference code

Optional
 
While updating an activity,
choose one of the following
options to identify the
record:
 
The unique ID for the
record (ParentActivityId).
 
The parent activity number
(ParentActivityNumber).
 
The source system code
and source reference code
(ParentOrigEntityNumber
and ParentOrigEntityCode)
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Creating an Activity
record

Updating an Existing
Activity record

and
ParentOrigEntityCode)

(ParentOrigEntityNumber
and
ParentOrigEntityCode)

 

ParentOrigEntityNumber
 

The entity number of the
parent entity in the original
system to which the activity
is related
 

Conditionally Required only
for follow-up activity. One
of the following options to
identify the parent record
must be provided:
 

• The unique ID
for the record
(ParentActivityId)

• The parent
activity number
(ParentActivityNumber)

• The source system
code and source
reference code
(ParentOrigEntityNumber
and
ParentOrigEntityCode)

A value is required if
you're creating a follow-up
activity. While creating an
activity, choose one of the
following options to identify
the record:
 

• The unique ID
for the record
(ParentActivityId)

• The parent
activity number
(ParentActivityNumber)

• The source system
code and source
reference code
(ParentOrigEntityNumber
and
ParentOrigEntityCode)

Optional
 
While updating an activity,
choose one of the following
options to identify the
record:
 
The unique ID for the
record (ParentActivityId).
 
The parent activity number
(ParentActivityNumber).
 
The source system code
and source reference code
(ParentOrigEntityNumber
and ParentOrigEntityCode).
 

PartnerProgramId
 

The internal identifier
of the related partner
program.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 
For partner programs,
 export the Program
Enrollments object.
 

When creating an activity,
 if you associate the activity
with a partner program,
 you must provide either
the internal ID, such as
PartnerProgramId, or the
public unique value, such as
PartnerProgramNumber.
 

When updating an activity,
 if you associate the activity
with a partner program,
 then you must provide
either the internal ID, such
as PartnerProgramId, or the
public unique value, such as
PartnerProgramNumber.
 

PartnerProgramNumber
 

The public unique identifier
of the related partner
program.
 

You can determine the
public unique value of the
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 
For Partner programs,
 export the Program
Enrollments object.
 

When creating an activity,
 if you associate the activity
with a partner program,
 then you must provide
either the internal ID, such
as PartnerProgramId, or the
public unique value, such as
PartnerProgramNumber.
 

When updating an activity,
 if you associate the activity
with a partner program,
 then you must provide
either the internal ID, such
as PartnerProgramId, or the
public unique value, such as
PartnerProgramNumber.
 

PrimaryContactId
 

The internal identifier of
the activity contact.
 

The party must exist. You
can determine the PartyId
of the party by exporting
the Party object.
 

Optional
 
When creating an activity,
 if you associate the activity
with a contact party, then
you must provide either

When updating an activity,
 if you associate the activity
with a contact party, then
you must provide either
the internal ID, such as
PrimaryContactId, or the
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Creating an Activity
record

Updating an Existing
Activity record

To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 
If no value is provided, the
corresponding value from
Activity production table is
used.
 

the internal ID, such as
PrimaryContactId, or the
public unique value, such as
PrimaryContactPartyNumber,
 or the combination of
original system and original
system reference, such as
PrimaryContactOrigSystem
and OsrPrimaryContactId.
 

public unique value, such as
PrimaryContactPartyNumber,
 or the combination of
original system and original
system reference, such as
PrimaryContactOrigSystem
and OsrPrimaryContactId.
 

PrimaryContactOrigSystem
 

The code representing
the source system for the
activity contact.
 

The party must exist.
Identify the source system
code that was used when
you imported the party
in a prior batch. You can
determine existing source
system codes and create
new ones.
 
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Trading
Community Source
Systems

Optional
 
When creating an activity,
 if you associate the activity
with a contact party, then
you must provide either
the internal ID, such as
PrimaryContactId, or the
public unique value, such as
PrimaryContactPartyNumber,
 or the combination of
original system and original
system reference, such as
PrimaryContactOrigSystem
and OsrPrimaryContactId.
 

When updating an activity,
 if you associate the activity
with a contact party, then
you must provide either
the internal ID, such as
PrimaryContactId, or the
public unique value, such as
PrimaryContactPartyNumber,
 or the combination of
original system and original
system reference, such as
PrimaryContactOrigSystem
and OsrPrimaryContactId.
 

PrimaryContactPartyNumber
 

The public unique identifier
of the activity contact.
 

The party must exist.
You can determine the
PartyNumber of a party by
exporting either the Person
object or the Organization
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

Optional
 
When creating an activity,
 if you associate the activity
with a contact party, then
you must provide either
the internal ID, such as
PrimaryContactId, or the
public unique value, such as
PrimaryContactPartyNumber,
 or the combination of
original system and original
system reference, such as
PrimaryContactOrigSystem
and OsrPrimaryContactId.
 

When updating an activity,
 if you associate the activity
with a contact party, then
you must provide either
the internal ID, such as
PrimaryContactId, or the
public unique value, such as
PrimaryContactPartyNumber,
 or the combination of
original system and original
system reference, such as
PrimaryContactOrigSystem
and OsrPrimaryContactId.
 

PriorityCode
 

The priority of the activity.
The default value is 2. The
possible values are 1, 2, 3.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

Not required
 
The default value is 2
(Medium). To change this
value during create, you
must pass this value. Valid
values are 1, 2, and 3
 

When updating an activity,
 if you must modify the
priority of an Activity,
 provide a valid value for
PriorityCode.
 

PrivateFlag
 

Indicates whether the
activity is private.
 

If no value is provided, the
corresponding value from

Optional
 

When updating an activity,
 if you must mark an
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
record

Updating an Existing
Activity record

Activity production table is
used.
 

When creating an Activity,
 if you must mark an
Activity as private, set this
variable to 'Y'.
 

Activity as private, set this
variable to 'Y'.
 

RecurSerOrigEntityNumber
 

The entity number of the
recurring appointment
in the original system, to
which this activity is related
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

A value is required if
you're creating a recurring
activity (appointment).
While creating an activity,
choose one of the following
options to identify the
record:
 

• The unique ID for the
record (RecurSeriesId)

• The recurring series
activity number
(RecurSeriesActivityNumber)

• The entity number
of the recurring
appointment in the
original system,
 to which this
activity is related
(RecurSerOrigEntityNumber)

Optional
 

RecurSeriesActivityNumb
 

The activity number of an
instance of a series.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

A value is required if
you're creating a recurring
activity (appointment).
While creating an activity,
choose one of the following
options to identify the
record:
 

• The unique ID for the
record (RecurSeriesId)

• The recurring series
activity number
(RecurSeriesActivityNumber)

• The entity number
of the recurring
appointment in the
original system,
 to which this
activity is related
(RecurSerOrigEntityNumber)

Optional
 

RecurSeriesId
 

The internal identifier
for the series that links
instances of a series
together.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

A value is required if
you're creating a recurring
activity (appointment).
While creating an activity,
choose one of the following
options to identify the
record:
 

• The unique ID for the
record (RecurSeriesId)

Optional
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
record

Updating an Existing
Activity record

• The recurring series
activity number
(RecurSeriesActivityNumber)

• The entity number
of the recurring
appointment in the
original system,
 to which this
activity is related
(RecurSerOrigEntityNumber)

RecurWeekday
 

The activity that recurs
on every weekday such
as Monday to Sunday,
 Weekday, Weekend, and so
on.
 

If no value is provided, the
corresponding value from
Activity production table is
used.
 

Conditionally required
for a weekly recurring
appointment. Must
be a valid value from
ZMM_ACTIVITY_RECUR_
DAYWEEK_CD lookup.
 

Conditionally required
for a weekly recurring
appointment. Must
be a valid value from
ZMM_ACTIVITY_RECUR_
DAYWEEK_CD lookup.
 

RefCustOrigSystem
 

The source system code for
the reference customer.
 

The party must exist.
Identify the source system
code that was used when
you imported the party
in a prior batch. You can
determine existing source
system codes and create
new ones.
 
Navigate to the following in
the Setup and Maintenance
work area:.
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Trading
Community Source
Systems

The party must exist.
Identify the source system
code that was used when
you imported the party
in a prior batch. You can
determine existing source
system codes and create
new ones.
 
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Trading
Community Source
Systems

When updating an activity,
 if you associate the
activity with a referenced
customer party, then
you must provide either
the internal ID, such as
ReferenceCustomerId,
 or the public unique
value, such as
RefCustPartyNumber,
 or the combination of
original system and original
system reference, such as
RefCustOrigSystem and
OsrReferenceCustomerId.
 

RefCustPartyNumber
 

The public unique identifier
of the reference customer
who's associated with the
activity.
 

The party must exist.
Identify the source system
code that was used when
you imported the party
in a prior batch. You can
determine existing source
system codes and create
new ones.
 
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

The party must exist.
Identify the source system
code that was used when
you imported the party
in a prior batch. You can
determine existing source
system codes and create
new ones.
 
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

When updating an activity,
 if you associate the
activity with a referenced
customer party, then
you must provide either
the internal ID, such as
ReferenceCustomerId,
 or the public unique
value, such as
RefCustPartyNumber,
 or the combination of
original system and original
system reference, such as
RefCustOrigSystem and
OsrReferenceCustomerId.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
record

Updating an Existing
Activity record

• Task: Manage Trading
Community Source
Systems

• Task: Manage Trading
Community Source
Systems

ReferenceCustomerId
 

The internal identifier of
the reference customer
who's associated with the
activity.
 

The party must exist.
Identify the source system
code that was used when
you imported the party
in a prior batch. You can
determine existing source
system codes and create
new ones.
 
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Trading
Community Source
Systems

The party must exist.
Identify the source system
code that was used when
you imported the party
in a prior batch. You can
determine existing source
system codes and create
new ones.
 
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Trading
Community Source
Systems

When updating an activity,
 if you associate the
activity with a referenced
customer party, then
you must provide either
the internal ID, such as
ReferenceCustomerId,
 or the public unique
value, such as
RefCustPartyNumber,
 or the combination of
original system and original
system reference, such as
RefCustOrigSystem and
OsrReferenceCustomerId.
 

SrId
 

The foreign key to SR_
ID in the SVC_SERVICE_
REQUESTS table.
 

You can determine the
public unique value of this
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with a service request, then
you must provide either
the internal ID, such as SrId,
 or the public unique value,
 such as SrNumber. This
must be a valid value in
SVC_SERVICE_REQUESTS.
 

When updating an activity,
 if you associate the activity
with a service request, then
you must provide either
the internal ID, such as SrId,
 or the public unique value,
 such as SrNumber. This
must be a valid value in
SVC_SERVICE_REQUESTS.
 

SrNumber
 

The foreign key to SR_
NUMBER in the SVC_
SERVICE_REQUESTS table.
 

You can determine the
public unique value of this
object by exporting the
object.
 
To export, navigate
to Tools >  Export
Management >  Create
Export Activity.
 

When creating an activity,
 if you associate the activity
with a service request, then
you must provide either
the internal ID, such as SrId,
 or the public unique value,
 such as SrNumber. This
must be a valid value in
SVC_SERVICE_REQUESTS.
 

When updating an activity,
 if you associate the activity
with a service request, then
you must provide either
the internal ID, such as SrId,
 or the public unique value,
 such as SrNumber. This
must be a valid value in
SVC_SERVICE_REQUESTS.
 

StatusCode
 

The status of the activity.
The default value is Not
Started.
 

If no value is provided, the
default is NOT_STARTED.
The lookup Type used is
ZMM_ACTIVITY_STATUS_
CD.
 

If no value is provided, the
default is NOT_STARTED.
The lookup Type used is
ZMM_ACTIVITY_STATUS_
CD.
 

Optional
 
The lookup Type used is
ZMM_ACTIVITY_STATUS_
CD.
 

Subject
 

The unique subject, name,
 or title of the activity.
 

No validation
 

A value is required if you're
creating a new activity.
 

Not Required
 

SubmittedBy
 

The user who submitted
the call report.
 

Conditionally required for
a call report in Submitted
status.

Conditionally required for
a call report in Submitted
status.

Optional
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
record

Updating an Existing
Activity record

  
It must be a valid value in
the HZ_PARTIES table.
 

Conditionally required for
a call report in Submitted
status.
 
It must be a valid value in
the HZ_PARTIES table.
 

SubmittedDate
 

The date and time when
the call report was
submitted.
 

None
 

Conditionally required for
a call report in Submitted
status. This must be a valid
date.
 

Conditionally required for
a call report in Submitted
status. This must be a valid
date.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the activity object. The
page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Activity object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the activity information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Activity from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
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2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Activity Assignee Data  
You can use Import Management to create, update, or delete your activity assignee data.

You can import activity assignee records using these steps:

1. Map your source activity assignee data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the activity assignee data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import activity assignee data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

If you want to import only a few records, then you can create a single CSV file for all activity assignee attributes.
However if you want to import a large number of records, then you may decide to create multiple CSV files, one for
each of the activity assignee child objects. Note that you must have imported the CSV file for activity assignee object
successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to
import each of these child objects. For more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
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• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new accounts or are
updating accounts that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Activity Assignee Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for activity assignee records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Assignee record

Updating an Existing
Activity Assignee record

ActivityId
 

The internal identifier of
the activity to which the
assignee is associated.
 

Automatically generated
by the import process if
creating a new activity
record.
 

Optional
 

A value is required if you're
updating an existing
activity and you're not
providing other values to
identify the activity record.
 
To update an existing
activity, choose one of the
following options to identify
the record:
 

• The unique ID for the
record (ActivityId)

• The activity number
(ActivityNumber)

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode)

ActivityNumber
 

The public unique identifier
of the activity to which the
assignee is associated
 

If a value is provided while
creating a new activity, the
value must be unique. For
update, you can determine
the existing unique value of
the object by exporting the
Activity object.
 

A value is required if you're
creating a new activity.
 

A value is required if you're
updating an existing
activity and you're not
providing other values to
identify the activity record.
 
To update an existing
activity, choose one of the
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Assignee record

Updating an Existing
Activity Assignee record

Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Schedule Export
Processes

The table ZMM_ACTY_
ACTIVITIES with column
ACTIVITY_NUMBER holds
the existing value.
 

following options to identify
the record:
 

• The unique ID for the
record (ActivityId)

• The activity number
(ActivityNumber)

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode)

AssigneeId
 

The internal identifier of
the HZ_PARTY record
having PARTY_USAGE as
Resource.
 

If no value is provided, the
corresponding value from
Assignee production table
is used.
 

A value is required if you're
associating a new assignee
to an activity.
 
One of the following must
be provided while creating
an assignee:
 

• AssigneeId

• AssigneeResourceNumber

• Combination of
AssigneeOrigSystem
and OsrAssigneeId

To update or delete an
existing activity assignee
you must choose one of the
following options to identify
the record:
 

• The unique ID for the
record (ActivityId,
 AssigneeId)

• The activity number
(ActivityNumber,
AssigneeId)

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode)

AssigneeOrigSystem
 

The source system
reference to the assigned
resource organization.
 

None
 

A value is required if you're
associating a new assignee
to an activity.
 
One of the following must
be provided while creating
an assignee:
 

• AssigneeId

• AssigneeResourceNumber

• Combination of
AssigneeOrigSystem
and OsrAssigneeId

Not Required
 

AssigneeResourceNumber
 

The resource number
associated with an
assignee.
 

None
 

A value is required if you're
associating a new assignee
to an activity.
 
One of the following must
be provided while creating
an assignee:
 

• AssigneeId

Not Required
 

134



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Assignee record

Updating an Existing
Activity Assignee record

• AssigneeResourceNumber

• Combination of
AssigneeOrigSystem
and OsrAssigneeId

OrigEntityCode
 

The code indicating the
original source of the
activity the activity to which
the assignee is associated.
 

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.
 
If the record was created in
the Activity Management
component, the value is
ACTIVITY.
 

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.
 
If the record was created in
the Activity Management
component, the value is
ACTIVITY.
 

A value is required if you're
updating or deleting an
existing activity and you're
not providing other values
to identify the activity
record.
 
To update or delete an
existing activity you must
choose one of the following
options to identify the
record:
 

• The unique ID for the
record (ActivityId)

• The activity number
(ActivityNumber)

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode)

OrigEntityNumber
 

The original unique
identifier of the existing
task, appointment, or
interaction in the source
system.
 

If the internal action
code is 'INSERT' and
OrigEntityNumber and
ActivityNumber are NULL
then it will be defaulted
to the provided value. If
no value is provided, the
corresponding value from
Assignee production table
is used.
 

If the internal action
code is 'INSERT' and
OrigEntityNumber and
ActivityNumber are NULL,
 the value will be set to
the value provided by the
user. If no value is provided,
 the corresponding value
is used from the Assignee
production table.
 

A value is required if you're
updating or deleting an
existing activity and you're
not providing other values
to identify the activity
record.
 
To update or delete an
existing activity you must
choose one of the following
options to identify the
record:
 

• The unique ID for the
record (ActivityId)

• The activity number
(ActivityNumber)

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode)

OsrAssigneeId
 

The source system
reference of the assignee..
 

The party must exist. You
can determine the Original
System Reference for the
party by exporting the
Party object.
 

A value is required if you're
associating a new assignee
to an activity. One of the
following must be provided
while creating an assignee:
 

• AssigneeId

Not Required
 

135



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Assignee record

Updating an Existing
Activity Assignee record

Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Schedule Export
Processes

• AssigneeResourceNumber

• Combination of
AssigneeOrigSystem
and OsrAssigneeId

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the activity assignee
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Activity Assignee object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the activity assignee information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Activity Assignee from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
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3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

How do I import activity contact data?  
You can use Import Management to create, update, or delete your activity contact data.

You can import activity contact records using these steps:

1. Map your source activity contact data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the activity contact data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import activity contact data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
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All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new activity contacts or
are updating activity contacts that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Activity Contact Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for activity contact records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Contact record

Updating an Existing
Activity Contact record

ActivityId
 

The internal identifier of
the activity to which the
contact is associated.
 

Automatically generated
by the import process if
creating a new activity
record.
 

The value is generated
automatically by the import
process if creating a new
activity record.
 

A value is required if you're
updating an existing
activity and you're not
providing other values to
identify the activity record.
 
To update an existing
activity, choose one of the
following options to identify
the record:
 

• The unique ID for the
record (ActivityId).

• The activity number
(ActivityNumber).

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode).

ActivityNumber
 

The public unique identifier
of the activity to which the
contact is associated
 

If a value is provided while
creating a new activity, the
value must be unique. For
update, you can determine
the existing unique value of
the object by exporting the
Activity object.
 
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

A value is required if you're
creating a new activity.
 

A value is required if you're
updating an existing
activity and you're not
providing other values to
identify the activity record.
 
To update an existing
activity, choose one of the
following options to identify
the record:
 

• The unique ID for the
record (ActivityId).
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Contact record

Updating an Existing
Activity Contact record

• Functional Area: Data
Import and Export

• Task: Schedule Export
Processes

The table ZMM_ACTY_
ACTIVITIES with column
ACTIVITY_NUMBER holds
the existing value.
 

• The activity number
(ActivityNumber).

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode).

ContactId
 

The party of type person
who's involved with this
appointment..
 

If no value is provided, the
corresponding value from
the Contacts production
table is used.
 

A value is required if you're
associating a new contact
to an activity. One of the
following must be provided
while creating a contact:
 

• ContactId

• ContactPartyNumber

• Combination of
ContactOrigSystem
and OsrContactId

To update or delete an
existing activity contact,
 select one of the following
options to identify the
record:
 

• The unique ID for the
record (ActivityId,
 ContactId).

• The activity number
(ActivityNumber,
ContactId).

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode).

ContactOrigSystem
 

The source system for the
activity with which the
contact is associated.
 

No Validation
 

A value is required if you're
associating a new contact
to an activity.
 
One of the following must
be provided while creating
a contact:
 

• ContactId

• ContactPartyNumber

• Combination of
ContactOrigSystem
and OsrContactId

Not Required
 

ContactPartyNumber
 

The party number of the
contact.
 

This must be a valid party
in the HZ_PARTIES table.
 

A value is required if you're
associating a new contact
to an activity.
 
One of the following must
be provided while creating
a contact:
 

• ContactId

• ContactPartyNumber

• Combination of
ContactOrigSystem
and OsrContactId

This must be a valid party
in the HZ_PARTIES table
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Contact record

Updating an Existing
Activity Contact record

CorpCurrencyCode
 

The corporate currency
used by the activity to
which the contact is
associated.
 

If no value is provided, the
corresponding value from
the Contacts production
table is used.
 

If no value is provided,
 the corresponding value
is used from the Contacts
production table.
 

If no value is provided,
 the corresponding value
is used from the Contacts
production table.
 

OrigEntityCode
 

The code indicating the
original source of the
activity the activity to which
the contact is associated.
 

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.
 

Note:
If the record was
created in the
Activity Management
component, the value is
ACTIVITY.
 

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.
 

Note:
If the record was
created in the
Activity Management
component, the value is
ACTIVITY.
 

A value is required if you're
updating or deleting an
existing activity and you're
not providing other values
to identify the activity
record.
 
To update or delete an
existing activity you must
choose one of the following
options to identify the
record:
 

• The unique ID for the
record (ActivityId).

• The activity number
(ActivityNumber).

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode).

OrigEntityNumber
 

The ID that identifies the
entity record in the original
system..
 

If the internal action
code is 'INSERT' and
OrigEntityNumber and
ActivityNumber are NULL
then it will be defaulted
to the provided value. If
no value is provided, the
corresponding value from
Contacts production table
is used.
 

If the internal action
code is 'INSERT' and
OrigEntityNumber and
ActivityNumber are NULL,
 the value will be set to
the value provided by the
user. If no value is provided,
 the corresponding value
is used from the Contacts
production table.
 

A value is required if you're
updating or deleting an
existing activity and you're
not providing other values
to identify the activity
record.
 
To update or delete an
existing activity you must
choose one of the following
options to identify the
record:
 

• The unique ID for the
record (ActivityId).

• The activity number
(ActivityNumber).

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode).

OsrContactId
 

The source system
reference of the contact..
 

The contact must exist in
system. You can determine
the original system
reference for the Contact
by exporting the Contacts
object.
 

A value is required if you're
associating a new contact
to an activity. One of the
following must be provided
while creating an assignee:
 

• ContactId

The contact must exist in
system. You can determine
the original system
reference for the Contact
by exporting the Contacts
object.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Contact record

Updating an Existing
Activity Contact record

Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Schedule Export
Processes

• ContactPartyNumber

• Combination of
ContactOrigSystem
and OsrContactId

Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Schedule Export
Processes

OsrContactOrgId
 

The source system
reference to the contact
organization. It is used to
update the RELATIONSHIP_
ID in the interface table
(ZMM_IMP_ACTY_
CONTACTS) based on HZ_
PARTIES.
 

This must be a valid
organization type in the
HZ_PARTIES table.
 

This must be a valid
organization type in the
HZ_PARTIES table.
 

This must be a valid
organization type in the
HZ_PARTIES table.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the activity contact
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Activity Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the activity contact information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Activity Contact from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Activity Objective Data  
You can use Import Management to create, update, or delete your activity objective data.

You can import activity objective records using these steps:

1. Map your source activity objective data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the activity objective data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import activity objective data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

If you want to import only a few records, then you can create a single CSV file for all activity objective attributes.
However if you want to import a large number of records, then you may decide to create multiple CSV files, one for
each of the activity objective child objects. Note that you must have imported the CSV file for activity objective object
successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to
import each of these child objects. For more information, see the related topics section.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new activity objectives or
are updating activity objectives that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Activity Objective Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for activity objective records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Objective record

Updating an Existing
Activity Objective record

ActionCode
 

Indicates explicitly the
operation to be performed
on a row: INSERT to
create a new record in the
destination tables, UPDATE
to update an existing record
in the destination table,
 DELETE to delete the
record.
 

If value isn't provided,
 record matching is used to
determine whether a record
is updated (if it already
exists) or inserted (if it
doesn't exist). The valid
values are INSERT, UPDATE,
 and DELETE.
 

Optional
 

To delete a record, you
must provide the value
as DELETE. It is optional
to provide values for
insert and update as the
framework internally
decides the action as
INSERT if it's a new record
or UPDATE if it's an existing
record.
 

ActivityId
 

The internal identifier of
the activity to which the
Objective is associated.
 

Automatically generated
by the import process if
creating a new activity
record.
 

A value is required if you're
updating or deleting an
existing activity and you're
not providing other values
to identify the activity
record.
 
To update or delete an
existing activity you must
choose one of the following

A value is required if you're
updating or deleting an
existing activity and you're
not providing other values
to identify the activity
record.
 
To update or delete an
existing activity you must
choose one of the following
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Objective record

Updating an Existing
Activity Objective record

options to identify the
record:
 

• The unique ID for the
record (ActivityId)

• The activity number
(ActivityNumber)

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode)

A value is required if
you're associating a new
objective to an activity
and you're not providing
other values to identify
the objective record. You
must choose one of the
following options to identify
the objective record:
 

• ObjectiveId

• Combination of
ActivityId and
(ObjectiveCode or
ObjectiveFreefmtText)

options to identify the
record:
 

• The unique ID for the
record (ActivityId)

• The activity number
(ActivityNumber)

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode)

A value is required if
you're associating a new
objective to an activity
and you're not providing
other values to identify
the objective record. You
must choose one of the
following options to identify
the objective record:
 

• ObjectiveId

• Combination of
ActivityId and
(ObjectiveCode or
ObjectiveFreefmtText)

ActivityNumber
 

The public unique identifier
of the activity to which the
Objective is associated
 

If a value is provided while
creating a new activity, the
value must be unique. For
update, you can determine
the existing unique value of
the object by exporting the
Activity object.
 
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Schedule Export
Processes

The table ZMM_ACTY_
ACTIVITIES with column
ACTIVITY_NUMBER holds
the existing value.
 

A value is required if you're:
 

• Creating an activity

• Updating or deleting
an existing activity
and you're not
providing other values
to identify the activity
record.

To update or delete an
existing activity you must
choose one of the following
options to identify the
record:
 

• The unique ID for the
record (ActivityId).

• The activity number
(ActivityNumber).

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode).

A value is required if you're
updating an existing
activity and you're not
providing other values to
identify the activity record.
 
To update or delete an
existing activity you must
choose one of the following
options to identify the
record:
 

• The unique ID for the
record (ActivityId).

• The activity number
(ActivityNumber).

• The source system
code and reference
(OrigEntityNumber
and OrigEntityCode).

ObjectiveCode
 

The set of predefined
objectives defined by the
administrator
 

A value is required if
you're associating a new
objective to an activity
and you're not providing
other values to identify

A value is required if
you're associating a new
objective to an activity
and you're not providing
other values to identify

A value is required if
you're associating a new
objective to an activity
and you're not providing
other values to identify
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Objective record

Updating an Existing
Activity Objective record

the objective record. You
must choose one of the
following options to identify
the objective record:
 

• ObjectiveId

• Combination of
ActivityId and
(ObjectiveCode or
ObjectiveFreefmtText)

the objective record. You
must choose one of the
following options to identify
the objective record:
 

• ObjectiveId

• Combination of
ActivityId and
(ObjectiveCode or
ObjectiveFreefmtText)

the objective record. You
must choose one of the
following options to identify
the objective record:
 

• ObjectiveId

• Combination of
ActivityId and
(ObjectiveCode or
ObjectiveFreefmtText)

ObjectiveFreefmtText
 

The objective in free form
text as provided by the
user.
 

A value is required if
you're associating a new
objective to an activity
and you're not providing
other values to identify
the objective record. You
must choose one of the
following options to identify
the objective record:
 

• ObjectiveId

• Combination of
ActivityId and
(ObjectiveCode or
ObjectiveFreefmtText)

A value is required if
you're associating a new
objective to an activity
and you're not providing
other values to identify
the objective record. You
must choose one of the
following options to identify
the objective record:
 

• ObjectiveId

• Combination of
ActivityId and
(ObjectiveCode or
ObjectiveFreefmtText)

A value is required if
you're associating a new
objective to an activity
and you're not providing
other values to identify
the objective record. You
must choose one of the
following options to identify
the objective record:
 

• ObjectiveId

• Combination of
ActivityId and
(ObjectiveCode or
ObjectiveFreefmtText)

ObjectiveId
 

The internal identifier of
the objective associated
with the activity.
 

If no value is provided, the
corresponding value from
the Objectives production
table is used.
 

A value is required if
you're associating a new
objective to an activity
and you're not providing
other values to identify
the objective record. You
must choose one of the
following options to identify
the objective record:
 

• ObjectiveId

• Combination of
ActivityId and
(ObjectiveCode or
ObjectiveFreefmtText)

A value is required if
you're associating a new
objective to an activity
and you're not providing
other values to identify
the objective record. You
must choose one of the
following options to identify
the objective record:
 

• ObjectiveId

• Combination of
ActivityId and
(ObjectiveCode or
ObjectiveFreefmtText)

OrigEntityCode
 

The code indicating the
original source of the
activity the activity to which
the Objective is associated.
 

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.
 
If the record was created in
the Activity Management
component, the value is
ACTIVITY
 

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.
 
If the record was created in
the Activity Management
component, the value is
ACTIVITY.
 

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.
 
If the record was created in
the Activity Management
component, the value is
ACTIVITY.
 

OrigEntityNumber
 

The original unique
identifier of the existing
task, appointment, or

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.

Valid values for upgraded
records are TASK,
 APPOINTMENT, or
INTERACTION.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Activity
Objective record

Updating an Existing
Activity Objective record

interaction in the source
system.
 

 
If the record was created in
the Activity Management
component, the value is
ACTIVITY
 

 
If the record was created in
the Activity Management
component, the value is
ACTIVITY.
 

 
If the record was created in
the Activity Management
component, the value is
ACTIVITY.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the activity objective
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Activity Objective object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the activity objective information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Activity Objective from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Additional Name Data  
Use this topic to import Additional Name data into Oracle Applications Cloud. You can use the import functionality to
create, update, or delete Additional Name records.

To import Additional Name records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Additional Name data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You need to set certain options for some attributes in the application before you can populate them. When importing a
child record, ensure that its parent record exists in the database.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Internal ID. If you're identifying a record
that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated
unique identifier Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID
of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an
internal ID typically provides better performance and reduces the import duration. For the Additional Name object, the
attributes are NameID and RegistryID.
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Required Attributes and Validations
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Additional Name records, required attributes for updating Additional Name records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Additional Name import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Additional
Name Record

Updating an Existing
Additional Name Record

NameId
 

Unique identifier of the
address record as the
primary key
 

No Validation
 

Not required
 

Optional
 
Either the NameId or a
combination of Source
System and Source System
Reference can be passed.
 

StatusFlag
 

The status of the additional
name
 

Defaults to Y during
creation.
 

Not required
 

To inactivate an existing
active Additional Name
record, provide the value as
"N".
 

NameType
 

Additional Name Type
 

This must be a valid name
type. The name types can
be managed in Manage
Name Types.
 

Required
 

If you don't provide the
primary key, provide the
existing additional name
type.
 

PartyNumber
 

The public unique identifier
of the party record to which
the Additional Name is
associated.
 

The party number should
exist.
 

Conditionally required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId (internal ID)

• PartySourceSystem
and
PartySourceSystemReference(source
system code and
source system
reference values)
provided when
importing the
organization profile

• Party Number (public
unique identifier
for an organization
profile)

Not required
 

PartySourceSystem
 

The code representing
the source system for the
party (account, contact,
 household, or legal entity)
to which the Additional
name belongs.
 

Identify the source system
code that was used when
you imported the party in
a prior batch, or identify
the source system code
that you will use when
importing the party in

Conditionally required
 
Provide one of the
following :
 

• PartyId (internal ID)

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Additional
Name Record

Updating an Existing
Additional Name Record

the same batch as this
Additional Name.
 

• PartySourceSystem
and
PartySourceSystemReference(source
system code and
source system
reference values)
provided when
importing the
organization profile

• Party Number (public
unique identifier
for an organization
profile)

PartySourceSystemReferenceValue
 

The reference number
or text representing the
source system unique ID for
the party (account, contact,
 household, or legal entity)
to which the Additional
Name belongs.
 

Identify the reference value
from your source system
that was used when you
imported the party in a
prior batch, or identify the
source system reference
that you will use when
importing the party in
the same batch as this
Additional Name.
 

Conditionally required
 
Provide one of the
following :
 

• PartyId (internal ID)

• PartySourceSystem
and
PartySourceSystemReference(source
system code and
source system
reference values)
provided when
importing the
organization profile

• Party Number (public
unique identifier
for an organization
profile)

Not required
 

PartyId
 

The unique identifier
as primary key of the
party record to which
the additional name is
associated.
 

Identify the party ID value
by exporting the relevant
Party object such as
Account, Contact, and so
on.
 

Conditionally required
 
Provide one of the
following :
 

• PartyId (internal ID)

• PartySourceSystem
and
PartySourceSystemReference(source
system code and
source system
reference values)
provided when
importing the
organization profile

• Party Number (public
unique identifier
for an organization
profile)

Not required
 

SourceSystem
 

Name of external source
system of the account,
 contact or household

The source system should
exist.
 

Optional
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Additional
Name Record

Updating an Existing
Additional Name Record

with which the address is
associated.
 

You can manage source
systems from the Manage
Source Systems task.
 

If the source of your
data is a third party or
external system, and you
intend to import updates
to previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

SourceSystemReferenceValue
 

Specifies the identifier in
the original source system
 

No validation
 

Provide a valid value.
 

Not required
 

You can view the Additional Name object and attributes in the Manage Import Objects page of the Import Management
flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
The CSV file is provided as input to the file-based data import process. You must populate the CSV file with the data you
want to import into Oracle Applications Cloud.

You can either create a CSV file on your own or use templates available in preexisting mappings. To download a
template, do the following:

1. In the Navigator, under Tools, click Import Management.
2. Click Import Objects tab to open the Import Object Details page.
3. Select the object you're interested in the Import Object Details page and click the Download icon next to that

object name.
4. Save the template CSV file to a location on your desktop.

You must edit the template CSV file and provide valid values for the required attributes. You can attach different types of
files, giving each file a specific description.

PartyNumber NameType AdditionalName

RN_PTY_06_MAR_19_A1
 

LEGAL
 

Test_Addname_A1
 

RN_PTY_06_MAR_19_A2
 

LEGAL
 

Test_Addname_A2
 

RN_PTY_06_MAR_19_A3
 

LEGAL
 

Test_Addname_A3
 

RN_PTY_06_MAR_19_A4
 

LEGAL
 

Test_Addname_A4
 

RN_PTY_06_MAR_19_A5
 

LEGAL
 

Test_Addname_A5
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Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Additional Name from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• How do I import data?

Import Your Additional Identifier Data  
You can use Import Management to create or update Additional Identifier records.

To import Additional Identifier records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Object Attributes
To import your Additional Identifier data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. Use this option only if you're updating Additional Identifiers. You can determine the
internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database
query. Using an internal ID typically provides better performance and reduces the import duration. For the
Additional Identifier object, the attributes are PartyIdentifierID and PartyID.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Additional Identifier object, the
attribute is PartyNumber.

Required Attributes and Validations for the Additional Identifier Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Additional Identifier records, required attributes for updating Additional Identifier records, prerequisite setup tasks for
the attributes, and specific validations, if any, for Additional Identifier import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Additional
Identifier Record

Updating an Existing
Additional Identifier
Record

PartySourceSystem
 

The code representing
the source system for the
party (account, contact,
 household, or legal entity)
to which the Additional
identifier belongs
 

Identify the source system
code that was used when
you imported the party in
a prior batch, or identify
the source system code
that you will use when
importing the party in
the same batch as this
Additional identifier.
 

Conditionally required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId (internal ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile

• Party Number (public
unique identifier
for an organization
profile)

Not required
 

PartySourceSystemReferenceValue
 

The reference number
or text representing the
source system unique ID for
the party (account, contact,
 household, or legal entity)
to which the Additional
identifier belongs.
 

Identify the reference value
from your source system
that was used when you
imported the party in a
prior batch, or identify the
source system reference
that you will use when
importing the party in
the same batch as this
Additional identifier.
 

Conditionally required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId ( internal ID)

• PartySourceSystem
and
PartySourceSystemReference(source
system code and
source system
reference values)
provided when
importing the
organization profile

• Party Number (public
unique identifier
for an organization
profile)

Not required
 

PartyIdentifierID
 

Unique identifier of the
additional identifier of the
party
 

No validation
 

Not required
 

Required
 

StatusCode
 

The status of the additional
identifier
 

Not required
 
This defaults to Y during
creation.
 

Not required
 

To inactivate existing active
Additional Name record,
 provide the value as N.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Additional
Identifier Record

Updating an Existing
Additional Identifier
Record

PartyIdentifierType
 

The type of the Additional
Identifier import
 

The Identifier Type must
exist. You can manage
additional types using the
Manage Additional Name
Types task.
 

Required
 

Not required
 

PartyIdentifierValue
 

Value to be imported for
the Identifier Type
 

Mandatory field
 

Required
 

Not required
 

PartyNumber
 

The public unique identifier
of the party record to which
the Additional identifier is
associated.
 

The party number should
exist.
 

Conditionally required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId (internal ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile

• Party Number (public
unique identifier
for an organization
profile)

Not required
 

PartyID
 

The unique identifier
as primary key of the
party record to which the
additional identifier is
associated.
 

Identify the party ID value
by exporting the relevant
Party object such as
Account, Contact, and so
on.
 

Conditionally required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId (internal ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile

• Party Number (public
unique identifier
for an organization
profile)

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Additional
Identifier Record

Updating an Existing
Additional Identifier
Record

SourceSystem
 

Name of external source
system of the account,
 contact or household
with which the Additional
identifier is associated.
 

The source system should
exist.
 
You can manage source
systems from the Manage
Source Systems task.
 

Optional
 
If the source of your
data is a third party or
external system, and you
intend to import updates
to previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

Not required
 

SourceSystemReferenceValue
 

Specifies the identifier in
the original source system.
 

The combination of Source
System and Source System
Reference Value should be
unique.
 

Optional
 
If the source of your
data is a third party or
external system, and you
intend to import updates
to previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

Not required
 

You can view the Additional Identifier object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Additional Identifier object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Additional Identifier

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
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5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the
mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Address Data  
You can use the import functionality to create, update, or delete address records.

You can import address records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the address data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import address data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to
target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the address import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate addresses while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all address attributes. However if you
want to import a large number of records, then you may decide to create multiple CSV files, one for each of the address
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child objects. Note that you must have imported the CSV file for address object successfully before trying to import the
CSV files for the child objects. There are separate help topics describing how to import each of these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new address or are
updating address that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Address Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for address records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Address
record

Updating an Existing
Address record

PartyId
 

The internal ID for the
party (account, contact,
 household, or legal entity)
to which the address
belongs
 

Identify the party ID value
by exporting the relevant
Party object such as
Account, Contact, and so
on.
 

Conditionally Required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId ( internal ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile.

• Party Number (public
unique identifier

Conditionally Required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId ( internal ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile.

• Party Number (public
unique identifier
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Address
record

Updating an Existing
Address record

for an organization
profile), which
is PARTY_SITE_
NUMBER for address

for an organization
profile), which
is PARTY_SITE_
NUMBER for address

PartyNumber
 

The code representing
the source system for the
party (account, contact,
 household, or legal entity)
to which the address
belongs.
 

Identify the party ID value
by exporting the relevant
Party object such as
Account, Contact, and so
on.
 

Conditionally Required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId ( internal ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile.

• Party Number (public
unique identifier
for an organization
profile), which
is PARTY_SITE_
NUMBER for address

Conditionally Required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId ( internal ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile.

• Party Number (public
unique identifier
for an organization
profile), which
is PARTY_SITE_
NUMBER for address

PartySourceSystem
 

The code representing
the source system for the
party (account, contact,
 household, or legal entity)
to which the address
belongs.
 

Identify the source system
code that was used when
you imported the party in
a prior batch, or identify
the source system code
that you will use when
importing the party in the
same batch as this address
 

Conditionally Required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId (internal ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile.

• Party Number (public
unique identifier
for an organization
profile), which
is PARTY_SITE_
NUMBER for address

Conditionally Required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId (internal ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile.

• Party Number (public
unique identifier
for an organization
profile), which
is PARTY_SITE_
NUMBER for address

PartySourceSystemReferenceValue
 

The reference number
or text representing the
source system unique ID

Identify the reference value
from your source system
that was used when you

Conditionally Required
 

Conditionally Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Address
record

Updating an Existing
Address record

for the party (account,
contact, household, or legal
entity) to which the address
belongs.
 

imported the party in a
prior batch, or identify the
source system reference
that you will use when
importing the party in the
same batch as this address.
 

Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId (Sales and
Fusion Service internal
ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile.

• Party Number (public
unique identifier
for an organization
profile), which
is PARTY_SITE_
NUMBER for address

Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId (Sales and
Fusion Service internal
ID)

• PartySourceSystem
and
PartySourceSystemReference
(source system
code and source
system reference
values) provided
when importing the
organization profile.

• Party Number (public
unique identifier
for an organization
profile), which
is PARTY_SITE_
NUMBER for address

PrimaryFlag
 

Identifies the primary
address for the parent party
record.
 

Only one of the child
records can be Primary.
 

Optional
 

Optional
 
Pass Y to set Primary and N
to reset an existing primary
record.
 

Status
 

Indicates the current status
of the address record.
 

Not required
 
Defaults to A (Active)
 

Not required
 
Defaults to A (Active)
 

Optional
 
Pass A to set the status
to Active and I to set the
status to Inactive.
 

AddressId
 

Unique identifier of the
address record as primary
key.
 

No validation
 

Not required
 

Optional
 
Either the AddressId or the
AddressNumber can be
passed.
 

Country
 

The country code
component of the postal
address.
 

Identify valid country
codes.
 

Required
 

Not required.
 

LocationId
 

The unique ID for the
existing location record in
the destination table.
 

Identify the LOCATION_
ID for an existing location
by exporting the Location
object.
 

Optional
 

Optional
 

StartDateActive
 

The date on which the
address becomes valid.
 

No validation
 

This is a PUID for Address.
If a value is passed, it will be

The Address record can
be updated by passing the
Address Number.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Address
record

Updating an Existing
Address record

imported. Otherwise, it will
be auto-generated.
 

 

AddressNumber
 

The address internal unique
identifier that's internally
generated when creating an
address
 

None
 

This is a PUID for Address.
If a value is passed, it will be
imported. Otherwise, it will
be auto-generated.
 

The Address record can
be updated by passing the
Address Number.
 

SourceSystem
 

Name of external source
system of the account,
 contact or household
with which the address is
associated.
 

The source system should
exist.
 
You can manage source
systems from the Manage
Source Systems task.
 

Optional
 
If the source of your
data is a third party or
external system, and you
intend to import updates
to previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

Not required
 

SourceSystemReferenceValue
 

Specifies the identifier in
the original source system
 

Combination of Source
System and Source System
Reference Value should be
unique.
 

Optional
 
If the source of your
data is a third party or
external system, and you
intend to import updates
to previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

Not required
 

DoNotValidateFlag
 

Option to indicate that
a specific location isn't
eligible for address
validation
 

No validation
 
The values can be Y, N, or
blank.
 

Optional
 
If you don't pass a value,
 set to No.
 

Optional
 

DunsNumberC
 

A unique nine-digit
identification number
assigned to business
entities by Dun and
Bradstreet
 

No validation
 

Not required
 

Not required
 

PartySiteName
 

User defined name for the
site
 

No validation
 

Not required
 

Not required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the address object. The
page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.
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You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Address object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Providing the ZIP and Country Code values in the import CSV file will not automatically populate the State/County/City
fields. Values for these fields should be separately provided in the import file.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the address information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Address from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Note:  After importing data successfully, you need to run the following scheduled processes:
1. Validate Geographies of Addresses against Master Geographies: This job helps you validate an address

against master geography data and generates geography naming references. For more information about the
Validate Geographies of Addresses against Master Geographies post processing job, see the section "Validate
Geographies of Addresses against Master Geographies" in the Understanding Scheduled Processes guide.

2. Populate Location Latitude and Longitude Information: This job helps you select and geocode newly created
or updated addresses at regular time intervals. For more information about the Populate Location Latitude
and Longitude Information post processing job, see the section "Populate Location Latitude and Longitude
Information" in the Understanding Scheduled Processes guide.
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Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Address Locale Data  
You can use Import Management to create, update, or delete your address locale data.

You can import address locale records using these steps:

1. Map your source address locale data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the address locale data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import address locale data into Oracle Applications Cloud from a CSV file with your source data that's mapped to
target object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the address locale import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for each attribute in your source data.

• You have all the parent records in place before importing child records. For example, when importing the
address locale, ensure the address exists.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.
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• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system.

Required Attributes and Validations for Address Locale Object
To import data into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you
provide valid values for these attributes so that they pass import validations inbuilt into the application. This table lists
the required attributes for address locale records, prerequisite setup tasks for the attributes, and specific validations, if
any.

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Address
Locale Record

Updating an Existing
Address Locale Record

LocationId
 

Location ID
 

To obtain a list of all
locations, export the
address object.
 

Conditionally required
 
To create address locale
record, one of the following
is required:
 

• Combination of
SiteSourceSystem and
SiteSourceSystemReference

• AddressNumber

• LocationId

Conditionally required
 
To update an existing
address locale record, one
of the following is required:
 

• Combination of
SiteSourceSystem and
SiteSourceSystemReference

• AddressNumber

• LocationId

• LocationLocaleId

LocationLocaleId
 

Address Locale ID. The
unique ID for the existing
address locale record.
 

N/A
 

Not required
 

If available, you can provide
this to update other
attributes
 

AddressNumber
 

Party site number of the
address locale.
 

To obtain a list of all
address IDs and address
numbers, export the
address object.
 

Conditionally required
 
To create address locale
record, one of the following
is required:
 

• Combination of
SiteSourceSystem and
SiteSourceSystemReference

• AddressNumber

• LocationId

Conditionally required
 
To update an existing
address locale record, one
of the following is required:
 

• Combination of
SiteSourceSystem and
SiteSourceSystemReference

• AddressNumber

• LocationId

• LocationLocaleId

SiteSourceSystem
 

Source system of the
address
 

Know the source system.
To view source systems,
 use the Manage Trading
Community Source System
task.
 

Conditionally required
 
To create address locale
record, one of the following
is required:
 

• Combination of
SiteSourceSystem and
SiteSourceSystemReference

• AddressNumber

Conditionally required
 
To update an existing
address locale record, one
of the following is required:
 

• Combination of
SiteSourceSystem and
SiteSourceSystemReference

• AddressNumber
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Address
Locale Record

Updating an Existing
Address Locale Record

• LocationId • LocationId

• LocationLocaleId

SiteSourceSystemReferenceValue
 

Source system reference of
the address
 

Know the source system
reference. To view source
systems reference, use
the Manage Trading
Community Source System
Reference task.
 

Conditionally required
 
To create address locale
record, one of the following
is required:
 

• Combination of
SiteSourceSystem and
SiteSourceSystemReference

• AddressNumber

• LocationId

Conditionally required
 
To update an existing
address locale record, one
of the following is required:
 

• Combination of
SiteSourceSystem and
SiteSourceSystemReference

• AddressNumber

• LocationId

• LocationLocaleId

TransliterationLanguage
 

Language code in which
the address locale is
created
 

To view the languages, use
the Manage Languages
task
 

Required
 

Not Required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the address locale
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data you want to import into Oracle Applications Cloud in a CSV file.

You can use the templates available in the Import Object Details page to create the source CSV file. To download a
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Address Locale object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the address locale information.

To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity button on the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Address Locale from the

Object drop-down list.
4. Select the CSV file in the File Name, field, and click Next.
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5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required. Click Next.

6. Check the file for unmapped columns or data format issues by clicking Validate Data.
7. Review the import details on the Review and Submit page and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Import Activity page. This page has the status of all active, completed,
and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier. The Import Status column shows

the status of the import activity.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Address Purpose Data  
You can use the import functionality to create or update Address Purpose records.

You can import Address Purpose records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Address Purpose data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Address Purpose data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Address Purpose import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Address Purposes while importing, to avoid redundant data.
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If you want to import only a few records, then you can create a single CSV file for all Address Purpose attributes.
However if you want to import a large number of records, then you may decide to create multiple CSV files, one for
each of the Address Purpose child objects. Note that you must have imported the CSV file for Address Purpose object
successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to
import each of these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing a new Address Purpose or
are updating Address Purpose records that have source system reference data, then provide the source system
and source system reference values.

Required Attributes and Validations for Address Purpose Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Address Purpose records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Address
Purpose record

Updating an Existing
Address Purpose record

SiteSourceSystem
 

The name of the external
source system for the
Address record to which
the Address Purpose is
associated.
 

A combination of a valid
SiteSourceSystem and
SiteSourceSystemReferenceValue
which are already imported
 

Either the AddressId,
 Address Number or
the combination of
SiteSourceSystem and
SiteSourceSystemReferenceValue
is required.
 

Not required
 

SiteSourceSystemReferenceValue
 

The identifier of the source
system for the address
record to which the Address
Purpose is associated.
 

A combination of a valid
SiteSourceSystem and
SiteSourceSystemReferenceValue,
 which are already imported
 

Either the AddressId,
 Address Number or
the combination of
SiteSourceSystem and
SiteSourceSystemReferenceValue
is required.
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Address
Purpose record

Updating an Existing
Address Purpose record

PrimaryPerType
 

This specifies the record
that's imported as the
primary key for a site use
type. Specify Y for a record
to set the specified site use
type as the primary key.
 

Y, N, or NULL
 
Enter Y or N. Alternatively,
 don't enter any value. The
default value is N.
 

Not required
 

Not required
 

AddressPurposeId
 

The primary key of the
Address Purpose record
 

No validation
 

Not required
 

Conditionally Required
 
To identify an address
purpose record, use one of
these:
 

• SourceSystem and
SourceSystemReferenceValue

• AddressPurposeId

Purpose
 

The site codes such as
SHIP_TO and BILL_TO
that identify the Address
Purpose
 

The values are validated
against the Lookup values
for Site use codes.
 

Required
 

Not required
 

StartDate
 

The start date of the
Address Purpose
 

The date can't be earlier
than the Address start date.
 

Not required
 

Not required
 

EndDate
 

The end date of the
Address Purpose
 

This date can't be later than
the Address end date.
 

Not required
 

Not required
 

AddressId
 

The primary key of the
Address record
 

No validation
 

Either the AddressId,
 Address Number or
the combination of
SiteSourceSystem and
SiteSourceSystemReferenceValue
is required.
 

Not required
 

AddressNumber
 

The public unique identifier
of the address
 

Valid Address Number
(Party Site Number)
 

Either the AddressId,
 Address Number or
the combination of
SiteSourceSystem and
SiteSourceSystemReferenceValue
is required.
 

Not required
 

SourceSystem
 

Name of external source
system of the address
purpose for the address
that's associated with
the account, contact, or
household.
 

The source system should
exist.
 
You can manage source
systems from the Manage
Source Systems task.
 

Optional
 
If your data source data is
a third party or external
system, and you intend
to import updates to
previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

Conditionally Required
 
To identify an address
purpose record, use one of
these:
 

• SourceSystem and
SourceSystemReferenceValue

• AddressPurposeId
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Address
Purpose record

Updating an Existing
Address Purpose record

SourceSystemReferenceValue
 

Specifies the identifier in
the original source system
for the Address Purpose
record.
 

The combination of Source
System and Source System
Reference Value should be
unique.
 

Optional
 
If your data source is a third
party or external system,
 and you intend to import
updates to previously
imported records from the
same system, provide the
original source system and
source system reference
values.
 

Conditionally Required
 
To identify an address
purpose record, use one of
these:
 

• SourceSystem and
SourceSystemReferenceValue

• AddressPurposeId

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Address Purpose
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Address Purpose object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Address Purpose information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Address Purpose from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Queue.
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2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Asset Data  

Import Your Asset Data  
You can use the Import Management to create, update, or delete asset records.

You can import asset records using these steps:

1. Map your source asset data to Oracle Applications Cloud object attributes. This way the import process would
know where to insert each of the information bits.

2. Create the source CSV file with the asset data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your asset data into Oracle Applications Cloud, you must populate a .csv file with your source data and map
that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

To better manage your asset information, the asset object has the following child objects:

• Asset Contact

• Asset Resource

If you want to import only a few records, then you can create a single CSV file for all asset attributes. However if you
want to import a large number of records, then you may decide to create multiple CSV files, one for each of the asset
child objects. Note that you must have imported the CSV file for asset object successfully before trying to import the
CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For
more information, see the related topics section.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and
source system reference is a unique identifier within the external system. If you're importing new assets or are
updating assets that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Asset Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for asset records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Asset record Updating an Existing
Asset record

AssetNumber
 

The unique ID for the
existing asset record in the
destination table.
 

None
 

Required
 

Required
 

AssetOrigSystem
 

A source system code
that identifies the original
source system of the asset.
 

None
 

Not required
 

Not required
 

AssetOrigSystemReference
 

A source system reference
that's the unique ID of the
asset in your legacy or
external system.
 

None
 

Not required
 

Not required
 

CustomerId
 

The unique ID for the
existing customer party
record in the destination
table.
 

The party must exist.
 

Required
 

Not required
 

AccountSourceSystem Specifies the account
source system.

You must enter a valid
source system and source

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Asset record Updating an Existing
Asset record

system reference for the
account.

AccountSourceSystemReferenceSpecifies the account
source system reference.

You must enter valid source
system and source system
reference for the account.

Not required
 

Not required
 

ContactSourceSystem Specifies the contact source
system.

You must enter a valid
source system reference
information.

Not required
 

Not required
 

ContactSourceSystemReferenceSpecifies the contact source
system reference.

You must enter a valid
source system reference
information.

Not required
 

Not required
 

ItemSourceSystem Specifies the item source
system.

You must enter a valid item
source system reference
number and purchase date.

Not required
 

Not required
 

ItemSourceSystemReference Specifies the item source
system reference.

You must enter a valid item
source system reference
number and purchase date.

Not required
 

Not required
 

EmailAddress The email address
associated to the asset.

You must enter a valid
resource email.

Not required
 

Not required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the asset object. The
page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Asset object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the asset information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Asset from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
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7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Import Your Asset Contact Data

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• Import Your Asset Resource Data

Example of Updating the Status of an Asset  
You can change the status of an asset by updating its end-date and setting the status to 'EXPIRED'. To update an asset,
your source file must include the values that let the import process identify the existing records.

Before You Begin
The scenario in this example assumes that the following prerequisites have already been set up.

• Assets must exist in the application.

• User accounts are set up for the already existing assets.

• Appropriate business units are set up using the Manage Business Unit task.

To find the business unit, navigate to the following in the Setup and Maintenance work area:

◦ Offering: Sales

◦ Function Area: Data Import and Export

◦ Task: Manage Business Units

• Appropriate legal entities are set up using the Manage Legal Entities task. To find the legal entity, navigate to
the following in the Setup and Maintenance work area:

◦ Offering: Sales

◦ Function Area: Data Import and Export

◦ Task: Manage Legal Entities
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Scenario
In this scenario, AssetNumber for the given asset is 782400089. Note the name of this asset, say 'Green Server 5000'.
You must create a source file (CSV) with the attributes and import it using import management as shown in this table.

Attribute Name Value

AssetNumber
 

782400089
 

EndDate
 

6/1/2005
 

StatusCode
 

'EXPIRED'
 

You can import the source data file as explained below:

1. Navigate to Tools >  Import Management.
2. Click Create Import Activity on the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assets from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.
8. You can navigate to Workspace and search for the asset name 'Green Server 5000' to verify the updated status.

Example of Updating the Owner Name of an Asset  
You can change the owner name of an asset. To update an asset, your source file must include the values that let the
import process identify the existing records.

Before You Begin
The scenario in this example assumes that the following prerequisites have already been set up.

• Assets must exist in the application.

• User accounts are set up for the already existing assets.

• Appropriate business units are set up using the Manage Business Unit task.

To find the business unit, navigate to the following in the Setup and Maintenance work area:

◦ Offering: Sales
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◦ Function Area: Data Import and Export

◦ Task: Manage Business Units

• Appropriate legal entities are set up using the Manage Legal Entities task. To find the legal entity, navigate to
the following in the Setup and Maintenance work area:

◦ Offering: Sales

◦ Function Area: Data Import and Export

◦ Task: Manage Legal Entities

Scenario
In this scenario, AssetNumber for the given asset is 782400089. Note the name of this asset, say 'Green Server 5000'.
You must create a source file (CSV) with the attributes and import it using import management as shown in this table.

Attribute Name Value

AssetNumber
 

782400089
 

AccountNameTransientForLOV
 

FSACCOUNT (DENVER, US)
 

You can import the source data file as explained below:

1. Navigate to Tools >  Import Management.
2. Click Create Import Activity on the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assets from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.
8. You can navigate to Workspace and search for the asset name 'Green Server 5000', to verify the updated

owner name.

Import Your Asset Contact Data  
You can use Import Management to create, update, or delete your asset contact data.

174



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

You can import asset contact records using these steps:

1. Map your source asset contact data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.

2. Create the source CSV file with the asset contact data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import asset contact data into Oracle Applications Cloud from a CSV file with your source data that's mapped to
target object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the asset import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for each attribute in your source data. For example, when using source
system reference information to identify your asset records, the source system of the asset object should be
enabled for parties in the Manage Trading Community Source Systems task.

• You have all the parent records in place before importing child records. For example, when importing the asset
contact, ensure the asset exists.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For asset object, the attribute is AssetNumber and shows up in the
UI as Asset Number. For more information about public unique identifiers, see the topic "How You Use Alternate
Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new accounts or are
updating accounts that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Asset Contact Object
To import data into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you
provide valid values for these attributes so that they pass import validations inbuilt into the application. This table lists
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the required attributes for asset contact records, prerequisite setup tasks for the attributes, and specific validations, if
any.

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Asset Contact
record

Updating an Existing
Asset Contact record

ContactPartyId
 

Unique party identifier
representing a contact.
 

The party must exist.
 

Required
 

Required
 

AssetId
 

The unique ID for the
existing asset record in the
destination table.
 

An asset record with the
Asset ID should exist.
 

Conditionally required
when you don't provide the
Asset Number.
 

Conditionally required
when you don't provide the
Asset Number.
 

AssetNumber
 

The unique ID for the
existing asset record in the
destination table.
 

An asset record with the
Asset Number should exist.
 

Conditionally required
when you don't provide the
Asset ID.
 

Conditionally required
when you don't provide the
Asset ID.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the account object. The
page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data you want to import into Oracle Applications Cloud in a CSV file.

You can use the templates available in the Import Object Details page to create the source CSV file. To download a
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Asset Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

AssetNumber ContactPartyId ContactFunctionCode

900546
 

300000018487543
 

ORA_ZCM_ASSET_MANAGER
 

900604
 

300000018487544
 

ORA_ZCM_MAINTENANCE_ENGINEEER
 

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the asset information.

To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity button on the Manage Imports page.
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3. In the Enter Import Options page, provide a name for the import activity, and select Asset Contact from the
Object drop-down list.

4. Select the CSV file in the File Name, field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required. Click Next.
6. Check the file for unmapped columns or data format issues by clicking Validate Data.
7. Review the import details on the Review and Submit page and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Import Activity page. This page has the status of all active, completed,
and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier. The Import Status column shows

the status of the import activity.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Import Your Asset Resource Data  
You can use Import Management to create, update, or delete your Asset Resource data.

To import asset resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import activity.

How You Map Your Source Data to Target Object Attributes
You import Asset Resource data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

To better manage your Asset Resource information, the Asset Resource object has the following child objects:

• Address
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• Classification

• Relationship

• Sales Team Member

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Asset Resources or
are updating Asset Resources that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for the Asset Resource Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for Asset Resource records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Asset
Resource record

Updating an Existing
Asset Resource record

AssetId
 

The unique ID for the
existing asset record in the
destination table.
 

An asset record with the
Asset ID should exist
 

Conditionally required
when you don't provide the
Asset Number
 

Conditionally required
when you don't provide the
Asset Number
 

AssetNumber
 

The unique ID for the
existing asset record in the
destination table.
 

An asset record with the
Asset Number should exist
 

Conditionally required
when you don't provide the
Asset ID
 

Conditionally required
when you don't provide the
Asset ID
 

Resource Party ID
 

Unique party identifier
representing a resource
 

The party must exist.
 

Required
 

Required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Asset Resource
object. The page also lists attribute information like type, length, description, and so on.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Asset Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Asset Resource information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Asset Resource from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Assignment Rule Candidate Data  
You can use Import Management to create, update, or delete your assignment rule candidate data.
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You can import assignment rule candidate records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
You import assignment rule candidate data into Oracle Applications Cloud from a CSV file containing your source data
that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new action plans or are
updating action plans that have source system reference data, then provide the source system and source
system reference values.

Review Required Attributes and Validations for Assignment Rule Candidate
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for assignment rule candidate records, prerequisite setup tasks and specific
validations, if any:
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Review Required Attributes and Validations for Assignment Rule Candidate Object

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Assignment Rule
Candidate Record

Updating an Existing
Assignment Rule
Candidate Record

Deleting an Existing
Assignment Rule
Candidate Record

RuleNumber The alternate identifier
of the assignment rule.

None Required Not Required Not Required

CandidateObjectPUID The alternate identifier
of the candidate
object.

Validate the PUID/ID
exist in the system
for corresponding
candidate object.

Conditionally
Required.
Provide value if
CandidateObjectId
isn’t provided.

Not Required Not Required

CandidateObjectId The unique identifier
of the candidate
object.

Validate the PUID/ID
exist in the system
for corresponding
candidate object.

Conditionally
Required.
Provide value if
CandidateObjectPUID
isn’t provided.

Not Required Not Required

RuleCandidateNumber The identifier of the
assignment rule
candidate.

None Not Required Required Required

You can view the Assignment Rule Candidate object along with all its attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Assignment Rule Candidate object in the table and click Download.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the assignment rule candidate information. To
create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assignment Rule Candidate

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Assignment Rule Condition Data  
You can use Import Management to create, update, or delete your assignment rule condition data.

You can import assignment rule condition records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
You import assignment rule condition data into Oracle Applications Cloud from a CSV file containing your source data
that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new action plans or are
updating action plans that have source system reference data, then provide the source system and source
system reference values.

Review Required Attributes and Validations for Assignment Rule Condition
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for assignment rule condition records, prerequisite setup tasks and specific
validations, if any:

Review Required Attributes and Validations for Assignment Rule Condition Object

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Assignment Rule
Condition Record

Updating an Existing
Assignment Rule
Condition Record

Deleting an Existing
Assignment Rule
Condition Record

RuleNumber The alternate identifier
of the rule.

None Required Not Required Not Required

RuleConditionNumber The alternate identifier
of the rule condition.

None Required Required Required

Object The object on
which the condition
rule will apply,
 such as Accounts,
 Opportunities, Lead,
 Deals, and Partner
Account.

The object must
correspond to the
given rule.

Conditionally
Required. Provide
value if ObjectCode
isn’t provided.

Not Required Not Required

ObjectCode The code of the object. The object must
correspond to the
given rule.

Conditionally
Required. Provide
value if ObjectCode
isn’t provided.

Not Required Not Required

ObjectAttributeName The attributes of the
object.

The attribute must
correspond to
the given object
and registered in
assignment metadata.

Conditionally
Required.
Provide value if
ObjectAttributeCode
isn’t provided.

Not Required Not Required

ObjectAttributeCode The code of the
attributes of the
objects.

The attribute must
correspond to
the given object

Conditionally
Required.
Provide value if

Not Required Not Required
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Assignment Rule
Condition Record

Updating an Existing
Assignment Rule
Condition Record

Deleting an Existing
Assignment Rule
Condition Record

and registered in
assignment metadata.

ObjectAttributeName
isn’t provided.

Operator The operation values
according to which the
rules would apply such
as Equals, Start with,
 and so on.

The right operator
must be passed on
the attribute type.
Validate the operator
if matching object is
passed.

Required Not Required Not Required

Value The value to which
the operation would
match.

None Conditionally
Required. Not
Mandatory in case the
operator value is Is not
blank or you're using
Matching Object.

Not Required Not Required

You can view the Assignment Rule Condition object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Assignment Rule condition object in the table and click Download.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the assignment rule condition information. To
create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assignment Rule Condition

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Assignment Rule Data  
You can use Import Management to create, update, or delete your assignment rule data.

You can import assignment rule records using these steps:

• Map your source data to Oracle Applications Cloud object attributes.

• Create source Comma Separated Values (CSV) file for import.

• Create the import activity.

• Review the import results.

How You Map Your Source Data to Target Object Attributes
You import assignment rule data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
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• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new action plans or are
updating action plans that have source system reference data, then provide the source system and source
system reference values.

Review Required Attributes and Validations for Assignment Rule Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for assignment rule records, prerequisite setup tasks and specific validations, if
any:

Review Required Attributes and Validations for Assignment Rule Object

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Assignment Rule
Record

Updating an Existing
Assignment Rule
Record

Deleting an Existing
Assignment Rule
Record

RuleSetNumber The alternate identifier
of the assignment rule
set.

None Required Not Required Not Required

RuleName The name of the
assignment rule.

A valid name must
begin with a letter. The
remaining characters
in the name can be
an alphanumeric
character, a single
space, colon (:), dash
(-), period (.), slash (/),
or underscore (_).

Required Not Required Not Required

RuleNumber The alternate identifier
of the assignment rule.

None Not Required Required Reqiured

You can view the Assignment Rule Set object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.
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You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Assignment Rule Set object in the table and click Download.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the assignment rule set information. To create an
import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assignment Rule Set from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Assignment Rule Set Data  
You can use Import Management to create, update, and delete your assignment rule set data.

You can import assignment rule set records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
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4. Review the import results.

How You Map Your Source Data to Target Object Attributes
You import assignment rule set data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new action plans or are
updating action plans that have source system reference data, then provide the source system and source
system reference values.

Review Required Attributes and Validations for Assignment Rule Set Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for assignment rule set records, prerequisite setup tasks and specific validations, if
any:
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Review Required Attributes and Validations for Assignment Rule Set Object

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Assignment Rule Set
Record

Updating an Existing
Assignment Rule Set
Record

Deleting an Existing
Assignment Rule Set
Record

Application The name of the
application.

The application
should be one of
the following: Lead
Management, Sales
and Partner Center,
 Customer Center,
 Object Sharing,
 Service.

Required Not Required Not Required

Category The display name of
the rule category.

It should belong to
the passed application
or code will be given
preference.

Conditionally
Required. Provide
value if CategoryCode
isn’t provided.

Not Required Not Required

CategoryCode The code of the rule
category.

It should belong to
the passed application
or code will be given
preference.

Conditionally
Required. Provide
value if Category isn’t
provided.

Not Required Not Required

RuleSetNumber The alternate identifier
of the assignment rule
set.

None Not Required Required Required

RuleSetName The name of the
assignment rule set.

A valid name must
begin with a letter. The
remaining characters
in the name can be
an alphanumeric
character, a single
space, colon (:), dash
(-), period (.), slash (/),
or underscore (_). It
must be unique for a
particular application.

Required Not Required Not Required

You can view the Assignment Rule Set object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Assignment Rule Set object in the table and click Download.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the assignment rule set information. To create an
import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assignment Rule Set from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Associated Project Data  
You can use Import Management to create or update associated projects records.

To import associated project records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your associated projects data into Oracle Applications Cloud, you must populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
associated project object, the attribute is LinePUID.

Required Attributes and Validations for the Associated Project Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
associated project records, prerequisite setup tasks for the attributes, and specific validations, if any, for associated
project import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Associated
Project Record

Updating an Existing
Associated Project Record

LinePuid
 

The unique PUID that
identifies the contract line
 

This must be a valid
contract line PUID.
 

Required
 

Not required
 

ExtSource
 

The external source of
the associated project
information.
 

This must be a unique
combination of external
source and key.
 

Required
 

Required
 

ExtKey
 

The external key of
the associated project
information.
 

This must be a unique
combination of external
source and key.
 

Required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Associated
Project Record

Updating an Existing
Associated Project Record

ProjectId
 

The ID of the project being
associated with the contract
line.
 

This must be a valid project
ID.
 

A value is required if
the project number isn't
passed.
 

Not required
 

ProjectNumber
 

The number of the project
being associated with the
contract line.
 

This must be a valid project
number.
 

A value is required if the
project ID isn't passed.
 

Not required
 

TaskId
 

The ID of the task being
associated with the contract
line.
 

This must be a valid task ID.
 

A value is required if the
task number isn't passed.
 

Not required
 

TaskNumber
 

The number of the task
being associated with the
contract line.
 

This must be a valid task
number.
 

A value is required if the
task ID isn't passed.
 

Not required
 

You can view the associated project object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Associated Project object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Associated Project from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Attachment Data  
You can use Import Management to create, update, or delete Attachment records.

You can import attachment records using these steps:

1. Map your source attachment data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.

2. Create the source CSV file with the attachment data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import attachment data into Oracle Applications Cloud from a CSV file containing your source data that's mapped
to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the attachment import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For attachment object, the attribute is PartyNumber and shows up
in the UI as Party Number. For more information about public unique identifiers, see the topic "How You Use
Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new attachments or are
updating attachments that have source system reference data, then provide the source system and source
system reference values. For attachment object, these are SourceSystem and SourceSystemReferenceValue and
show up as Party Source System and Party Source System Reference Value in the UI.

Required Attributes and Validations for Attachment Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for attachment records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Attachment
record

Updating an Existing
Attachment record

PK!Value
 

This is the primary key
of the record to which
the attachment is being
associated.
 

When creating or updating
attachments, the parent
record to which the
attachment is associated
must exist in the database.
 

Either Pk1Value or PUID is
mandatory.
 

Either Pk1Value or PUID is
mandatory.
 

ObjectPUID
 

This is the public unique
identifier of the record to
which the attachment is
being associated.
 

When creating or updating
attachments, the parent
record to which the
attachment is associated
must exist in the database.
 

Either Pk1Value or PUID is
mandatory.
 

Either Pk1Value or PUID is
mandatory.
 

Category
 

Category to which the
attachment belongs. If
you don't specify a value,
 the default is considered.
For example, the default
attachment category
for lead is MKL_LEAD_
CATEGORY.A source
system reference that's
the unique ID of the
Attachment in your legacy
or external system.
 

If passing the category, it
should be a valid category
for that object.
 

Not required
 
If you don't provide a value,
 the default is used.
 

Not required
 
If you don't provide a value,
 the default is used.
 

Description
 

A brief description of the
attachment.
 

This can be any string of
specified length.
 

Not Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Attachment
record

Updating an Existing
Attachment record

FileName
 

Name of the attachment
file in which the attachment
is stored.
 

This can be any string of
specified length.
 

Either the File name or the
URL is mandatory.
 

Either the File name or the
URL is mandatory.
 

PK2 Value
 

This is the primary key
of the record to which
the attachment is being
associated.
 

This is useful when the
object has a composite
primary key.
 

This is useful when the
object has a composite
primary key.
 

This is useful when the
object has a composite
primary key.
 

PK3 Value
 

This is the primary key
of the record to which
the attachment is being
associated.
 

This is useful when the
object has a composite
primary key.
 

This is useful when the
object has a composite
primary key.
 

This is useful when the
object has a composite
primary key.
 

PK4 Value
 

This is the primary key
of the record to which
the attachment is being
associated.
 

This is useful when the
object has a composite
primary key.
 

This is useful when the
object has a composite
primary key.
 

This is useful when the
object has a composite
primary key.
 

PK5 Value
 

This is the primary key
of the record to which
the attachment is being
associated.
 

This is useful when the
object has a composite
primary key.
 

This is useful when the
object has a composite
primary key.
 

This is useful when the
object has a composite
primary key.
 

URL
 

If the attachment type is
url, this specifies the url.
 

The URL format is
validated.
 

Either the file name or the
URL is mandatory.
 

Either the file name or the
URL is mandatory.
 

For more information on importing an attachment, see the topic Import Attachments in the related links section.

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the attachment object.
The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Attachment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the attachment information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Attachment from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import attachments?

Import Your Bill Plan and Revenue Plan Data  
You can use Import Management to create or update bill plan and revenue plan records.

To import bill plan and revenue plan records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your bill plan and revenue plan data into Oracle Applications Cloud, you must populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
bill plan and revenue plan object, the attribute is ContractPuid.

Required Attributes and Validations for the Bill Plan and Revenue Plan
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new bill
plan and revenue plan records, prerequisite setup tasks for the attributes, and specific validations, if any, for bill plan and
revenue plan import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Bill Plan and
Revenue Plan Record

Updating an Existing Bill
Plan and Revenue Plan
Record

ContractPuid
 

The PUID of the contract
for which the bill plan
or revenue plan is being
created or updated.
 

This must be a valid
contract PUID.
 

Required
 

Not required
 

ExtSource
 

The external source of the
bill or revenue plan.
 

This must be a valid
combination of external
source and key.
 

Required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Bill Plan and
Revenue Plan Record

Updating an Existing Bill
Plan and Revenue Plan
Record

ExtKey
 

The external key of the bill
or revenue plan.
 

This must be a unique
combination of external
source and key.
 

Required
 

Required
 

BillPlanName
 

The bill plan or revenue
plan name.
 

N/A
 

Required
 

Not required
 

BillMethodId
 

The bill or revenue method
ID.
 

This must be a valid bill
method ID.
 

Required if bill method
name isn't passed.
 

Not required
 

BillMethodName
 

The bill or revenue method
name.
 

This must be a valid bill
method name.
 

Required if bill method ID
isn't passed.
 

Not required
 

BillToCustAcctId
 

The bill-to customer
account ID of the bill plan.
 

This must be a valid
customer account ID.
 

Required if customer
account name isn't passed.
 

Not required
 

BillToCustAcctNumber
 

The bill-to customer
account number of the bill
plan.
 

This must be a valid
customer account number.
 

Required if customer
account ID isn't passed.
 

Not required
 

BillToContactId
 

The bill-to contact ID of the
bill plan.
 

This must be a valid contact
ID.
 

Required if contact name
isn't passed.
 

Not required
 

BillToContactName
 

The bill-to contact name of
the bill plan.
 

This must be a valid contact
name.
 

Required if contact ID isn't
passed.
 

Not required
 

BillToSiteUseId
 

The bill-to site use ID of the
bill plan
 

This must be a valid party
site use ID.
 

Required if party site use
location isn't passed.
 

Not required
 

BillToSiteUseLocation
 

The bill-to site use location
of the bill plan.
 

This must be a valid party
site use location.
 

Required if party site use ID
isn't passed.
 

Not required
 

InvoiceCurrencyOptCode
 

The billing currency type
code of the bill plan.
 

This must be a valid
currency type code.
 

Required if the currency
type name isn't passed.
 

Not required
 

InvCurrOptMeaning
 

The billing currency type
name of the bill plan.
 

This must be a valid
currency type name.
 

Required if the currency
type code isn't passed.
 

Not required
 

BillingCycleId
 

The billing cycle ID of the
bill plan.
 

This must be a valid billing
cycle ID.
 

Required if the billing cycle
name isn't passed.
 

Not required
 

BillingCycleName
 

The billing cycle name of
the bill plan.
 

This must be a valid billing
cycle name.
 

Required if the billing cycle
ID isn't passed.
 

Not required
 

PaymentTermId
 

The payment terms ID.
 

This must be a valid
payment terms ID.

Required if the payment
terms name isn't passed.

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Bill Plan and
Revenue Plan Record

Updating an Existing Bill
Plan and Revenue Plan
Record

  

PaymentTermName
 

The payment terms name.
 

This must be a valid
payment terms name.
 

Required if the payment
terms ID isn't passed.
 

Not required
 

BillSetNum
 

The bill set of the bill plan.
 

N/A
 

Required
 

Not required
 

LaborInvoiceFormatId
 

The labor format ID of the
bill plan.
 

This must be a valid labor
format ID.
 

Required if the labor format
name isn't passed.
 

Not required
 

LaborInvoiceFormatName
 

The labor format name of
the bill plan.
 

This must be a valid labor
format name.
 

Required if the labor format
ID isn't passed.
 

Not required
 

NlInvoiceFormatId
 

The nonlabor format ID of
the bill plan.
 

This must be a valid
nonlabor format ID.
 

Required if the nonlabor
format name isn't passed.
 

Not required
 

NlInvoiceFormatName
 

The nonlabor format name
of the bill plan.
 

This must be a valid
nonlabor format name.
 

Required if the nonlabor
format ID isn't passed.
 

Not required
 

EventsInvoiceFormatId
 

The event format ID of the
bill plan.
 

This must be a valid event
format ID.
 

Required if the event
format name isn't passed.
 

Not required
 

EventsInvoiceFormatName
 

The event format name of
the bill plan.
 

This must be a valid event
format name.
 

Required if the event
format ID isn't passed.
 

Not required
 

You can view the bill plan and revenue plan object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Bill Plan and Revenue Plan object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
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2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Bill Plan and Revenue Plan

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Billing Control Data  
You can use Import Management to create or update billing control records.

To import billing control records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your billing control data into Oracle Applications Cloud, you must populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
billing control object, the attribute is ContractPuid.

Required Attributes and Validations for the Billing Control Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new billing
control records, prerequisite setup tasks for the attributes, and specific validations, if any, for billing control import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Billing Control
Record

Updating an Existing
Billing Control Record

ContractPuid
 

The PUID of the contract
with which the billing
control is being associated.
 

This must be a valid
contract PUID.
 

Required if the contract line
PUID isn't passed.
 

Not required
 

LinePuid
 

The PUID of the contract
line with which the billing
control is being associated.
 

This must be a valid
contract line PUID.
 

Required if the contract
PUID isn't passed.
 

Not required
 

ExtSource
 

The external source of the
billing control.
 

This must be a unique
combination of external
source and external key.
 

Required
 

Required
 

ExtKey
 

The external key of the
billing control.
 

This must be a unique
combination of external
source and external key.
 

Required
 

Required
 

RbsElementId
 

The ID of the billing control
element.
 

This must be a valid
element ID.
 

Required if element name
isn't passed.
 

Not required
 

RbsElementAlias
 

The name of the billing
control element.
 

This must be a valid
element name.
 

Required if element ID isn't
passed.
 

Not required
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You can view the billing control object and attributes in the Manage Import Objects page of the Import Management
flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Billing Control object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Billing Control from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?
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Import Your Business Plan Data  
You can use Import Management to create, update, or delete your business plan data.

You can import business plan records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Business Plan data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records. For example, when importing the address of
an account, ensure the account exists.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Business Plan object, this attribute is BusinessPlanId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
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record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the BusinessPlan object, the
attribute is BusinessPlanNumber.

Review Required Attributes and Validations for Business Plan Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Business Plan records, required attributes for
updating Business Plan records, prerequisite setup tasks for the attributes, and specific validations, if any, for Business
Plan import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Business Plan
record

Updating an
Existing Business
Plan record

BusinessPlanId
 

Unique Identifier
 

Long
 

18
 

None
 

Not required
 

Required
 

BusinessPlanNumber
 

Public Unique
Identifier
 

String
 

64
 

None
 

Not required
 

A value is
required either for
BusinessPlanId
or for
BusinessPlanNumber.
 

PeriodTypeCode
 

Period Type such
as Year, Quarter, or
Period
 

String
 

30
 

Use the Manage
Calendar Profile
Option task to
set a value for
ZCA_COMMON_
CALENDAR.
 

Required
 

Not Required
 

StatusCode
 

Status of the
BusinessPlan such
as ORA_DRAFT,
 ORA_APPROVED
 

String
 

30
 

None
 

Required
 

Not required.
 

PeriodEndDisplayName
 

End Period Display
Name
 

String
 

60
 

None
 

Required
 

Not required.
 

PeriodStartDisplayName
 

Start Period
Display Name
 

String
 

60
 

None
 

Required
 

Not required.
 

Name
 

Unique name of
the business plan
 

String
 

60
 

Enter a unique
value.
 

Required
 

Not required.
 

BusinessPlanClassCode
 

Class of the
business plan such
as Account or
Partner
 

String
 

20
 

Navigate to the
following in
the Setup and
Maintenance Work
area:
 

Required
 

Not required.
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Business Plan
record

Updating an
Existing Business
Plan record

• Offering:
Sales

• Functional
Area: Data
Import and
Export

• Task: Manage
Business Plan
Classes

The default value is
PARTNER.
 

PartnerId
 

Internal identifier
of the Partner
 

Long
 

18
 

Enter the PartnerId
if you select the
BusinessPlanClassCode
as PARTNER.
 

A value is required,
 if you don't
specify the
PartnerNumber.
 

Not required
 

PartnerNumber
 

Public unique
identifier of the
Partner
 

String
 

30
 

Enter the PartnerId
if you select the
BusinessPlanClassCode
as PARTNER.
 

A value is required,
if you don't specify
the PartnerId.
 

Not required
 

CustomerId
 

Internal identifier
of the Account
 

Long
 

18
 

Enter the PartnerId
if you select the
BusinessPlanClassCode
as PARTNER.
 

A value is required,
 if you don't
specify the
CustomerNumber.
 

Not required
 

CustomerNumber
 

Public unique
identifier of the
Account
 

String
 

30
 

Enter the
CustomerId or the
CustomerNumber,
 if you select the
BusinessPlanClassCode
as ACCOUNT.
 

A value is required,
if you don't specify
the CustomerId.
 

Not required
 

You can view the Business Plan object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Business Plan from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

Import Your Business Plan SWOT Data  
You can use Import Management to create, update, or delete your business plan SWOT data.

To import Business Plan SWOT records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Business Plan SWOT data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records. For example, when importing the address of
an account, ensure the account exists.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Business Plan SWOT object, this attribute is SWOTId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the BusinessPlan SWOT object, the
attribute is SWOTNumber.

Required Attributes and Validations for Business Plan SWOT Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Business Plan SWOT records, required attributes for
updating Business Plan SWOT records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Business Plan SWOT import:
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Business Plan
SWOT Record

Updating an
Existing Business
Plan SWOT
Record

SWOTTypeCode
 

Identifies one of
the four seeded
and not extensible
SWOT type codes:
 

• STRENGTH

• WEAKNESS

• OPPORTUNITY

• THREAT

String
 

30
 

None
 

Required
 

Not required
 

SWOTDescription
 

A brief description
of the SWOT types
 

String
 

2000
 

None
 

Required
 

Not required
 

SWOTId
 

Unique identifier of
the SWOT
 

Long
 

18
 

None
 

Not required
 

Required
 

SWOTNumber
 

A unique number
that identifies the
SWOT record
 

String
 

64
 

None
 

Not required
 

Either the
SWOTNumber
or the SWOTId is
required to update
the records.
 

BusinessPlanId
 

The primary key of
the parent record
 

Long
 

18
 

None
 

A value is required
to define to which
business plan this
child record of the
SWOT belongs.
 

Not required.
 

BusinessPlanNumber
 

A unique number
that identifies the
business plan
 

String
 

64
 

None
 

A value is required
either for the
BusinessPlanId
or for the
BusinessPlanNumber.
 

Not required.
 

You can view the Business Plan SWOT object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data
you want to import into Oracle Applications Cloud.

You can either create a CSV file on your own or use templates available in preexisting mappings. To download a
template, do the following:

1. In the Navigator, under Tools, click Import Management.
2. Click Import Objects tab to open the Import Object Details page.
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3. Select the object you're interested in the Import Object Details page and click the Download icon next to that
object name.

4. Save the template CSV file to a location on your desktop.

You must edit the template CSV file and provide valid values for the required attributes. You can attach different types of
files, giving each file a specific description.

Description SWOTTypeCode BusinessPlanNumber

swot description
 

THREAT
 

myBP_0173
 

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Business Plan SWOT from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• How do I import data?
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Import Your Business Plan Team Data  
Use this topic to import Business Plan Team data into Oracle Applications Cloud. You can use the import functionality to
create or update Business Plan Team records.

To import Business Plan Team records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Business Plan Team data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You need to set certain options for some attributes in the application before you can populate them. When importing a
child record, ensure that its parent record exists in the database.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides
better performance and reduces the import duration. For the Business Plan Team object, this attribute is
BusinessPlanResourceId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
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the object's UI, you can use the Number attribute to identify the record. For the Business Plan Team object, the
attribute is BusinessPlanResourceNumber.

Required Attributes and Validations
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Business Plan Team records, required attributes for
updating Business Plan Team records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Business Plan Team import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Business Plan
Team Record

Updating an
Existing Business
Plan Team Record

ResourceId
 

Specifies the
resource added to
the business team
plan
 

Long
 

18
 

None
 

Required
 

Not required
 

BusinessPlanId
 

Specifies the
parent record ID
for which this child
record is being
created
 

Long
 

18
 

None
 

Required
 

Not required
 

BusinessPlanResourceNumber
 

A unique number
that identifies the
business plan
 

String
 

230
 

None
 

Not required
 

Required
 

ResourceNumber
 

A unique identifier
that identifies the
resource (team
member) number
 

String
 

30
 

None
 

Either the
ResourceNumber
or the ResourceId
is required when
creating a record.
 

Not required.
 

BusinessPlanResourceId
 

The unique
identifier of the
business plan
 

Long
 

18
 

None
 

Not required
 

Either the
BusinessPlanResourceId
or the
BusinessPlanResourceNumber
is required to
update the records.
 

BusinessPlanNumber
 

A unique number
that identifies the
business plan
 

String
 

64
 

None
 

Either the
BusinessPlanResourceId
or the
BusinessPlanResourceNumber
is required to
create the records.
 

Not required.
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You can view the Business Plan Team object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data
you want to import into Oracle Applications Cloud.

You can either create a CSV file on your own or use templates available in preexisting mappings. To download a
template, do the following:

1. In the Navigator, under Tools, click Import Management.
2. Click Import Objects tab to open the Import Object Details page.
3. Select the object you're interested in the Import Object Details page and click the Download icon next to that

object name.
4. Save the template CSV file to a location on your desktop.

You must edit the template CSV file and provide valid values for the required attributes. You can attach different types of
files, giving each file a specific description.

MemberFunctionCode ResourceId BusinessPlanNumber

ORA_BUS_DEVELOPMENT
 

100010032635399
 

myBP_0173
 

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Business Plan Team from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
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2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,
such as status, name, object, and so on.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• How do I import data?

Import Your Campaign Data  
You can use Import Management to create or update Campaign records.

To import Campaign records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Campaign data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. If you're creating records, then you can provide an easily understandable
public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes
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are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute
to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys
to Import Records" in Related Topics section.

Required Attributes and Validations for Campaign Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Campaign
records, required attributes for updating Campaign records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Campaign import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Campaign
Record

Updating an Existing
Campaign Record

CreatedByModule
 

The module used to create
the campaign.
 

By default, Web Service
module is used to create
the campaign.
 

Not Required
 

Not Required
 

OwnerId
 

The unique identifier of the
campaign owner.
 

The party must exist.
Export the Party object to
determine the PartyId of a
person.
 

Not Required
 

Not Required
 

OwnerPartyName
 

The party name of the
owner.
 

The party must exist.
Export the Party object to
determine the PartyName
of a person.
 

Not Required
 

Not Required
 

OwnerPartyNumber
 

The party number of the
owner.
 

The party must exist.
Export the Party object
to determine the
PartyNumber of a person.
 

Not Required
 

Not Required
 

ParentCampaignNumber
 

The public unique identifier
of the parent campaign.
 

Export the Campaign
records to identify the
CampaignNumber of the
parent campaign.
 

Not Required
 

Not Required
 

Status
 

The status of the campaign.
 

The default value is Draft.
 

Not Required
 

Not Required
 

CampaignId
 

The unique identifier of the
campaign.
 

No validation
 

Not Required
 

Either CampaignId or
CampaignNumber is
required.
 

CampaignName
 

The name of the campaign.
 

No validation
 

Required
 

Not Required
 

CampaignNumber
 

The PUID of the campaign.
 

No validation
 

Not Required
 

Required
 

You can view the Campaign object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
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Note:  Create your campaign data in Eloqua and then synchronize to Sales to maintain consistency of data.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Campaign object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Campaign from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?
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Import Your Campaign Member Data  
You can use Import Management to create or update Campaign Member records.

To import Campaign Member records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Campaign Member data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. If you're creating records, then you can provide an easily understandable
public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes
are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute
to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys
to Import Records" in Related Topics section.

Required Attributes and Validations for Campaign Member Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Campaign
Member records, required attributes for updating Campaign Member records, prerequisite setup tasks for the attributes,
and specific validations, if any, for Campaign Member import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Campaign
Member Record

Updating an Existing
Campaign Member
Record

CampaignMemberId
 

The primary key of the
campaign member.
 

No Validation
 

Required
 
Auto-generated
 

Either
CampaignMemberId or
CampaignMemberNumber
is required.
 

CreatedByModule
 

The module used to create
the campaign member.
 

No Validation
 

Not Required
 

Not Required
 

CampaignCampaignNumber
 

The Campaign PUID
associated with the
campaign member row.
 

Identify the Campaign
Number by exporting the
Campaign objects.
 

Not Required
 

Not Required
 

MemberResponseDate
 

The date when the
campaign member
responded to the
campaign.
 

No Validation
 

Required
 

Required
 

ContactPartyNumber
 

The contact party number
of the campaign member.
 

Identify the Party
Number for Contact by
exporting the Contact
party associated with the
campaign member.
 
Either provide the Lead
Number or Contact Number
value.
 

Required
 

Required
 

LeadLeadNumber
 

The lead number for the
campaign member.
 

Identify the Party Number
for Lead by exporting the
Lead party associated with
the campaign member.
 
Either provide the
LeadNumber or the Contact
Number.
 

Required
 

Required
 

CampaignId
 

The unique identifier of the
campaign.
 

Identify the Campaign Id
by exporting the Campaign
objects.
 

Required
 

Required
 

CampaignNumber
 

The PUID of the campaign.
 

Identify the Campaign
Number by exporting the
Campaign objects.
 

Not Required
 

Not Required
 

CampaignMemberNumber
 

The PUID of the campaign
member.
 

No Validation
 

Not Required
 

Required
 

You can view the Campaign Member object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Campaign Member object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Campaign Member from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Case Data  
You can use Import Management to create update, or delete Case records.
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To import Case records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Case data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map
that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new cases or are updating
cases that have source system reference data, then provide the source system and source system reference
values.

Required Attributes and Validations for Case Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Case records,
required attributes for updating Case records, prerequisite setup tasks for the attributes, and specific validations, if any,
for Case import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case Record Updating an Existing Case
Record

CaseId
 

Indicates the case identifier
 

A valid primary key in the
destination system. Either
the CaseNumber or the
CaseId should be entered.
If both are entered, the
CaseId is preferred.
 

Not required
 
This is auto generated.
 

Optional
 
Either the CaseNumber or
the CaseId is required.
 

StatusTypeCd
 

Indicates the status type of
the case
 

A valid value is required.
 

Optional
 
The default value is ORA_
SVC_ACTIVE.
 

Optional
 

StripeCd
 

Indicates the stripe code for
the case
 

A valid value is required.
 
The Lookup code that
indicates the stripe code
such as CRM, HCM, or PRM
 

Optional
 
The default value is ORA_
SVC_CRM.
 

Not required
 

StatusCd
 

Indicates the status of the
case
 

A valid value is required.
 

Optional
 
The default value is ORA_
SVC_NEW.
 

Optional
 

PrimaryContactPartyNumber
 

The alternate key of the
case primary contact
 

A valid PUID for the
PrimaryContactPartyNumber
in the destination system
 

Optional
 

Optional
 

PrimaryHouseholdPartyName
 

Indicates the name of the
case primary household
 

A valid unique name in the
destination system
 

Optional
 

Optional
 

PrimaryHouseholdPartyNumber
 

The alternate key of the
case primary household
 

A valid PUID for the
PrimaryHouseholdPartyNumber
in the destination system
 

Optional
 

Optional
 

QueueName
 

The name of the queue
associated with the case
 

A valid unique name in the
destination system
 

Optional
 

Optional
 

QueueNumber
 

The alternate key of the
queue associated to the
case
 

A valid unique name in the
destination system
 

Optional
 

Optional
 

ReportedByPartyNumber
 

The alternate key of the
user who reported the case
 

A valid PUID for
ReportedByPartyNumber in
the destination system
 

Optional
 

Optional
 

LastUpdatedByPartyNumber
 

The alternate key of the
user who last updated the
case
 

A valid unique name in the
destination system
 

Optional
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case Record Updating an Existing Case
Record

Title
 

Indicates the title of the
case
 

No validation
 

Required
 

Optional
 

AssigneePartyName
 

Indicates the party name of
the case assignee
 

A valid unique name in the
destination system
 

Optional
 

Optional
 

AssigneePartyNumber
 

The alternate key of the
case assignee
 

A valid PUID for
AssigneePartyNumber in
the destination system
 

Optional
 

Optional
 

CategoryName
 

Indicates the name of the
category associated with
the case
 

A valid value in the
destination system
 

Required
 

Not required
 

PrimaryContactPartyName
 

Indicates the name of the
case primary contact
 

A valid unique name in the
destination system
 

Optional
 

Optional
 

CaseCategoryId
 

Indicates the category of
the case
 

A valid CaseCategoryId in
the destination system
 

Optional
 

Optional
 

CreatedByPartyNumber
 

The alternate key of the
user who created the case
 

A valid
CreatedByPartyNumber
for the case row in the
destination system
 

Required
 

Not required
 

CaseNumber
 

Indicates the reference
number of the case
 

A valid PUID for the case
row in the destination
system
 

Optional
 
If required, provide the
PUID for the source and
destination systems.
 

Required
 

You can view the Case object along with all its child objects and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Case object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Case from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Case Contact Data  
You can use Import Management to create update, or delete Case Contact records.

To import Case Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Case Contact data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Case Contacts or are
updating Case Contacts that have source system reference data, then provide the source system and source
system reference values.

Required Attributes and Validations for Case Contact Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Case Contact
records, required attributes for updating Case Contact records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Case Contact import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case Contact
Record

Updating an Existing Case
Contact Record

CaseContactId
 

Indicates the case contact
identifier
 

A valid Id for the
CaseContact row in the
destination system
 

Not required
 

Required
 

PartyId
 

Indicates the PartyId of the
contact
 

A valid PUID for the PartyId
in the destination system
 

Required
 
A valid value is required
either for the PartyId or the
ContactPartyNumber in the
destination system
 

Required
 
A valid value is required
either for the PartyId or the
ContactPartyNumber in the
destination system
 

ContactPartyNumber
 

Indicates the party number
of the contact
 

A valid PUID for the
ContactPartyNumber in the
destination system

Required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case Contact
Record

Updating an Existing Case
Contact Record

 A valid value is required
either for the PartyId or the
ContactPartyNumber in the
destination system
 

A valid value is required
either for the PartyId or the
ContactPartyNumber in the
destination system
 

PartyName
 

Indicates the party Id of the
contact
 

A valid PUID for the
PartyName in the
destination system
 

Required
 
A valid value is required
either for the PartyId or
the PartyName in the
destination system. If both
values exist, the PartyId is
considered.
 

Required
 
A valid value is required
either for the PartyId or
the PartyName in the
destination system. If both
values exist, the PartyId is
considered.
 

CaseId
 

Indicates the case to which
this contact is associated
 

A valid CaseId in the
destination system
 

Not required
 

Not required
 

CaseNumber
 

Indicates the case number
to which this contact is
associated
 

A valid CaseNumber in the
destination system
 

Not required
 

Not required
 

You can view the Case Contact object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Case Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Case Contact from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
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6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Case Household Data  
You can use Import Management to create update, or delete Case Household records.

To import Case Household records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Case Household data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
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• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Case Households or
are updating Case Households that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Case Household Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Case Household
records, required attributes for updating Case Household records, prerequisite setup tasks for the attributes, and
specific validations, if any, for Case Household import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case
Household Record

Updating an Existing Case
Household Record

CaseHouseholdId
 

Indicates the case
household identifier
 

A valid Id for the
CaseHousehold row in the
destination system
 

Not required
 

Required
 

PartyId
 

Indicates the PartyId of the
household
 

A valid PUID for the PartyId
in the destination system
 

Required
 
A valid value is required
either for the PartyId or the
HouseholdPartyNumber in
the destination system
 

Required
 
A valid value is required
either for the PartyId or the
HouseholdPartyNumber in
the destination system
 

HouseholdPartyNumber
 

Indicates the party number
of the household
 

A valid PUID for the
HouseholdPartyNumber in
the destination system
 

Required
 
A valid value is required
either for the PartyId or the
HouseholdPartyNumber in
the destination system
 

Required
 
A valid value is required
either for the PartyId or the
HouseholdPartyNumber in
the destination system
 

HouseholdName
 

Indicates the name of the
household
 

A valid unique
HouseholdName in the
destination system
 

Required
 
A valid value is required
either for the PartyId or
the HouseholdName in the
destination system. If both
values exist, the PartyId is
considered.
 

Required
 
A valid value is required
either for the PartyId or
the HouseholdName in the
destination system. If both
values exist, the PartyId is
considered.
 

226



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case
Household Record

Updating an Existing Case
Household Record

CaseId
 

Indicates the case to
which this household is
associated
 

A valid CaseId in the
destination system
 

Not required
 

Not required
 

CaseNumber
 

Indicates the case number
to which this household is
associated
 

A valid CaseNumber in the
destination system
 

Not required
 

Not required
 

You can view the Case Household object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Case Household object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Case Household from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
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3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Case Message Data  
You can use Import Management to create update, or delete Case Message records.

To import Case Message records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Case Message data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
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the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Case Messages or
are updating Case Messages that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Case Message Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Case Message
records, required attributes for updating Case Message records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Case Message import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case Message
Record

Updating an Existing Case
Message Record

LastEditedDate
 

Indicates the last edited
date of the message for the
case
 

No validation
 

Not required
 

Not required
 

MessageId
 

Indicates the case message
identifier
 

A valid Id for the MessageId
row in the destination
system
 

Not required
 

Required
 

MessageTypeCd
 

Lookup code that indicates
the type of message
 

A valid unique
MessageTypeCd in the
destination system
 

Required
 

Not required
 

OriginationDate
 

Indicates the date on which
the message was posted
 

No validation
 

Not required
 

Not required
 

PostedByPartyNumber
 

Indicates the party number
of the user who posted the
message
 

A valid PUID for the
PostedByPartyNumber in
the destination system
 

Optional
 

Optional
 

RichTextFlag
 

Indicates whether the
message content is in rich
text format (Y or N)
 

A valid value from the
lookup Y_N
 

Required
 

Optional
 

VisibilityCd
 

Lookup code that indicates
the visibility of a message
 

A valid value in the
destination system
 

Optional
 
The default value is ORA_
SVC_INTERNAL.
 

Not required
 

StatusCd
 

Lookup code that indicates
the status of the message
 

A valid value in the
destination system
 

Required
 

Optional
 

CaseId
 

Indicates the case to which
this message is associated
 

A valid CaseId in the
destination system
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case Message
Record

Updating an Existing Case
Message Record

CaseNumber
 

Indicates the case number
to which this message is
associated
 

A valid CaseNumber in the
destination system
 

Not required
 

Not required
 

MessageNumber
 

Indicates the reference
number of the message ID
 

A valid MessageNumber in
the destination system
 

Not required
 

Not required
 

You can view the Case Message object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Case Message object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Case Message from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Case Opportunity Data  
You can use Import Management to create update, or delete Case Opportunity records.

To import Case Opportunity records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Case Opportunity data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.
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• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Case Opportunities
or are updating Case Opportunities that have source system reference data, then provide the source system
and source system reference values.

Required Attributes and Validations for Case Opportunity Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes.
Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Case
Opportunity records, required attributes for updating Case Opportunity records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Case Opportunity import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case
Opportunity Record

Updating an Existing Case
Opportunity Record

CaseOpportunityId
 

Indicates the case
opportunity identifier
 

A valid identifier for the
CaseOpportunityId row in
the destination system
 

Not required
 

Required
 

OptyId
 

Indicates the opportunity
associated with the case
 

A valid PUID for the OptyId
in the destination system
 

Required
 
A valid value is required
either for the OptyId or
the OptyNumber in the
destination system. If both
values are present, the
OptyId is considered.
 

Required
 
A valid value is required
either for the OptyId or
the OptyNumber in the
destination system. If both
values are present, the
OptyId is considered.
 

OptyNumber
 

Indicates the opportunity
number of the case
opportunity
 

A valid PUID is required
for OptyNumber in the
destination system
 

Required
 
A valid value is required
either for the OptyId or
the OptyNumber in the
destination system. If both
values are present, the
OptyId is considered.
 

Required
 
A valid value is required
either for the OptyId or
the OptyNumber in the
destination system. If both
values are present, the
OptyId is considered.
 

CaseNumber
 

Indicates the case
number to which this case
opportunity is associated
 

A valid CaseNumber in the
destination system
 

Not required
 

Not required
 

CaseId
 

Indicates the case to which
this case opportunity is
associated
 

A valid CaseId in the
destination system
 

Not required
 

Not required
 

You can view the Case Opportunity object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.
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You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Case Opportunity object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Case Opportunity from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Case Resource Data  
You can use Import Management to create update, or delete Case Resource records.

To import Case Resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.

233



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Case Resource data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Case Resources or
are updating Case Resources that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Case Resource Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Case Resource
records, required attributes for updating Case Resource records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Case Resource import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case Resource
Record

Updating an Existing Case
Resource Record

CaseResourceId
 

Indicates the case resource
identifier
 

A valid identifier for the
CaseOpportunityId row in
the destination system

Not required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Case Resource
Record

Updating an Existing Case
Resource Record

 

PartyId
 

Indicates the party
identifier of the resource
 

A valid PUID for PartyId in
the destination system
 

Required
 
A valid value is required
either for the PartyId or the
ResourcePartyNumber in
the destination system. If
both values are present, the
PartyId is considered.
 

Required
 
A valid value is required
either for the PartyId or the
ResourcePartyNumber in
the destination system. If
both values are present, the
PartyId is considered.
 

ResourcePartyNumber
 

Indicates the party number
of the resource
 

A valid PUID for the
ResourcePartyNumber in
the destination system
 

Required
 
A valid value is required
either for the PartyId or the
ResourcePartyNumber in
the destination system. If
both values are present, the
PartyId is considered.
 

Required
 
A valid value is required
either for the PartyId or the
ResourcePartyNumber in
the destination system. If
both values are present, the
PartyId is considered.
 

ResourceName
 

Indicates the name of the
resource
 

A valid unique
ResourceName in the
destination system
 

Required
 
A valid value is required
either for the PartyId or the
ResourcePartyNumber in
the destination system. If
both values are present, the
PartyId is considered.
 

Required
 
A valid value is required
either for the PartyId or the
ResourcePartyNumber in
the destination system. If
both values are present, the
PartyId is considered.
 

CaseId
 

Indicates the case to which
this resource is associated
 

A valid CaseId in the
destination system
 

Not required
 

Not required
 

CaseNumber
 

Indicates the case number
of the case to which the
resource is associated
 

A valid CaseNumber in the
destination system
 

Not required
 

Not required
 

You can view the Case Resource object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Case Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Case Resource from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

How do I import my category data?  
You can use Import Management to create, update, or delete your category data.

You can import category records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
You import category data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to
target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You've completed all the prerequisites for importing each attribute in your source data.

• You've all parent records in place before importing child records.

Review Required Attributes and Validations for Category Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for category records, prerequisite setup tasks and specific validations, if any:

Review Required Attributes and Validations for Category Object

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating a Category
Record

Updating an Existing
Category Record

Deleting an Existing
Category Record

CategoryId The unique identifier
of the category,
 an auto generated
number and primary
key for this table.

Must be a valid
CategoryId when
updating a category.

Not Required Conditionally
Required. Provide
value if CategoryCode
isn’t provided.

Conditionally
Required. Provide
value if CategoryCode
isn’t provided.

CategoryCode The public unique
identifier of the
category.

Must be unique across
all business units and
application stripes.

Required Conditionally
Required. Provide
value if CategoryId
isn’t provided.

Conditionally
Required. Provide
value if CategoryId
isn’t provided.

CategoryName The name of the
category. This field
is displayed in the
service request UI.

None Required Not Required Not Required

CategoryShortName A short code for the
category.

This field is
automatically set with
the same value as the
CategoryCode.

Not Required Not Required Not Required

StripeCd The application stripe
of the category.

Must be one of the
following values: ORA_
SVC_CRM, ORA_SVC_
HCM, ORA_SVC_
HRHD, ORA_SVC_ISR.

Conditionally
Required. Provide
value if you don’t want
the default value of
ORA_SVC_CRM.

Not Required Not Required

BUOrgId The unique identifier
of the business unit
associated with the
category.

Manage Business
Units under Setup and
Maintenance.

Required Not Required Not Required
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating a Category
Record

Updating an Existing
Category Record

Deleting an Existing
Category Record

ParentCategoryId The unique identifier
of the parent category.

Parent category must
exist in the application.

Conditionally
Required. Provide
value if importing a
child category and
ParentCategoryCode
isn’t provided.

Not Required Not Required

ParentCategoryCode The public unique
identifier of the parent
category.

Parent category must
exist in the application.

Conditionally
Required. Provide
value if importing a
child category and
ParentCategoryId isn’t
provided.

Not Required Not Required

You can view the Category object along with all its child objects and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Note:
1. If you're importing child categories, you must make sure that the parent category already exists in the

application.
2. To import category name for non primary languages, you must change the session language before importing.

You can change the session language by navigating to Settings and Actions  > Set Preferences  > Language
and Changing the Value for the Current Session.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Category object in the table and click Download.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After the CSV file is ready, create an import activity to import the category information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Category from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You'd see that the source and target attributes are automatically mapped in the Map Fields page. Review and

edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data.
7. Click Next.
8. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

How do I import classification data?  
You can use Import Management to create, update, or delete your classification data.

You can import classification records using these steps:

1. Map your source classification data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.

2. Create the source CSV file with the classification data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import classification data into Oracle Applications Cloud from a CSV file containing your source data that's mapped
to target Oracle Applications Cloud object attributes.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

If you want to import only a few records, then you can create a single CSV file for all classification attributes. However
if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the
classification child objects. Note that you must have imported the CSV file for classification object successfully before
trying to import the CSV files for the child objects. There are separate help topics describing how to import each of
these child objects. For more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new classifications or are
updating classifications that have source system reference data, then provide the source system and source
system reference values.

Required Attributes and Validations for Classification Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for classification records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Classification
Record

Updating an Existing
Classification Record

PartySourceSystem
 

The code representing
the source system for the
party(account, contact,
 household, or legal entity)
to which the Classification
belongs.
 

Identify the source system
code that was used when
you imported the party in
a prior batch, or identify
the source system code
that you will use when
importing the party in
the same batch as this
Classification.
 

Conditionally required
 
Provide one of the
following :
 

• PartyId (internal ID)

• PartySourceSystem
and
PartySourceSystemReference(source
system code and
source system
reference values)
provided when
importing the
organization profile.

Optional
 

PartySourceSystemReferenceValue
 

The reference number
or text representing the
source system unique ID for
the party (account, contact,
 household, or legal entity)
to which the classification
belongs.
 

Identify the reference value
from your source system
that was used when you
imported the party in a
prior batch, or identify the
source system reference
that you will use when
importing the party in
the same batch as this
classification.
 

Conditionally Required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId ( internal ID)

• PartySourceSystem
and
PartySourceSystemReference(source
system code and
source system

Optional
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Classification
Record

Updating an Existing
Classification Record

reference values)
provided when
importing the
organization profile.

• Party Number (public
unique identifier
for an organization
profile)

PrimaryFlag
 

Identifies primary
classification for the parent
party record.
 

Only one of the child
records can be Primary.
 

Optional
 

Optional
 
Pass Y to set Primary and N
to reset an existing primary
record.
 

CodeAssignmentId
 

The unique identifier for
the customer classification
assignment.
 

It should be a valid existing
value.
 

Not required
 

Either the Code assignment
Id or a combination of
Source System and Source
System Reference is
required.
 

ClassCategory
 

The classification category
name
 

The class category must
exist. You can manage
class categories from the
Manage Class Categories
task.
 

Required
 
A value is required if
creating a new classification
association record.
 

Not Required
 

ClassCode
 

The classification code,
 within the classification
category, assigned to the
party.
 

The value must be a valid
code for the classification
category. You can only
assign one code if the
category definition isn't
enabled for multiple code
assignments to a party
within the same category.
The code assignment must
not already exist within the
same time period. You can
obtain classification codes
for a classification category.
 

Conditionally required
 
A value is required if
creating a new classification
association record.
 

Not Required
 

StartDateActive
 

The date on which the
classification becomes
valid.
 

This should be a valid date.
 

This defaults to the current
date.
 

Not required
 

PartyId
 

The internal ID for the
party (account, contact,
 household, or legal entity)
to which the address
belongs
 

Identify the party ID value
by exporting the relevant
Party object such as
Account, Contact, and so
on.
 

Conditionally required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId (internal ID)

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Classification
Record

Updating an Existing
Classification Record

• PartySourceSystem
and
PartySourceSystemReference(source
system code and
source system
reference values)
provided when
importing the
organization profile.

• Party Number (public
unique identifier
for an organization
profile)

PartyNumber
 

The public unique identifier
of the party record to which
the classification category
and classification code are
associated.
 

The party number must
exist.
 

Conditionally Required
 
Provide reference
information to identify
the existing party. The
reference information can
be:
 

• PartyId (internal ID)

• PartySourceSystem
and
PartySourceSystemReference(source
system code and
source system
reference values)
provided when
importing the
organization profile

• Party Number (public
unique identifier
for an organization
profile)

Not required
 

EndDateActive
 

The date on which the
classification code is no
longer valid.
 

This should be a valid date.
 

Optional
 

Not required
 

SourceSystem
 

Name of external source
system of the account,
 contact or household
with which the address is
associated.
 

The source system should
exist.
 
You can manage source
systems from the Manage
Source Systems task.
 

Optional
 
If the source of your
data is a third party or
external system, and you
intend to import updates
to previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

Not required
 

SourceSystemReferenceValue
 

Specifies the identifier in
the original source system
 

The combination of Source
System and Source System
Reference Value should be
unique.

Optional
 
If the source of your
data is a third party or

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Classification
Record

Updating an Existing
Classification Record

 external system, and you
intend to import updates
to previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the classification object.
The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Classification object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the classification information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Classification from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Classification Code Data  
You can use Import Management to create or update Classification Code records.

To import Classification Code records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Classification Code data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Required Attributes and Validations for the Classification Code Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Classification Code records, prerequisite setup tasks for the attributes, and specific validations, if any, for Classification
Code import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Classification
Code Record

Updating an Existing
Classification Code
Record

ClassCategory
 

User-defined classification
category
 

No validation
 

Required
 

You can't update the
ClassCategory. However,
 it's required to identify the
existing data.
 

ClassCode
 

User defined class codes
for the user defined class
category
 

No validation
 

Required
 

You can't update the
ClassCode. However, it's
required to identify the
existing data.
 

Description
 

Brief description of the
classification code
 

No validation
 

Required
 

Required
 

Meaning
 

The meaning of the
classification code
 

No validation
 

Required
 

Required
 

ModifyHierarchy
 

Option to indicate if the
parent and child hierarchies
of the classification codes
are to be modified
 

No validation
 

Optional
 

Not required
 

ParentClassCode
 

If there is a hierarchy set
between the classification
codes, then provide the
parent classification
code to which the child
classification code belongs.
 

User- defined
ClassCategory via the
"Manage Classification
Categories" UI.
 

Optional
 

Not required
 

You can view the Classification Code object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Classification Code object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Classification Code from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Condition Attachment Data  
You can use Import Management to create, update, or delete Public Sector Condition Attachment records.

To import Public Sector Condition Attachment records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Public Sector Condition Attachment data into Oracle Applications Cloud, you need to populate a CSV file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new cases or are updating
cases that have source system reference data, then provide the source system and source system reference
values.

Required Attributes and Validations for Public Sector Condition
Attachment Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Public Sector
Condition Attachment records, required attributes for updating or deleting Public Sector Condition Attachment records,
prerequisite setup tasks for the attributes, and specific validations, if any, for Public Sector Condition Attachment
import:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Public
Sector Condition
Attachment Record

Updating an
Existing Public
Sector Condition
Attachment Record

Deleting an
Existing Public
Sector Condition
Attachment Record

CoaPuid The unique PUID that
identifies the migrated
condition of approval.

This must be a valid
PUID.

Required Required Required

AttachmentPuid The unique PUID that
identifies the migrated
condition of approval
attachment.

This must be a unique
PUID.

Required Not Required Not Required

FileName Name of the
attachment file in

This can be any string
of specified length.

Required Not Required Not Required
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Public
Sector Condition
Attachment Record

Updating an
Existing Public
Sector Condition
Attachment Record

Deleting an
Existing Public
Sector Condition
Attachment Record

which the attachment
is stored.

MigratedDataFlag Indicates if the
comment is migrated
from legacy system.

This value must be Y
if the data is migrated
from legacy system.

Required Not Required Not Required

Description A brief description of
the attachment.

This can be any string
of specified length.

Required Not Required Not Required

You can view the Public Sector Condition Attachment object and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools > Import Management  >  Import Objects.
2. Select the Public Sector Condition Attachment  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Public Sector Condition

Attachment  from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Condition of Approval Comment Data  
You can use Import Management to create, update, or delete Public Sector Condition of Approval Comment records.

To import Condition of Approval Comment records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Condition of Approval Comment data into Oracle Applications Cloud, you need to populate a CSV file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.
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• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new cases or are updating
cases that have source system reference data, then provide the source system and source system reference
values.

Required Attributes and Validations for Condition of Approval Comment
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Public Sector
Condition of Approval Comment records, required attributes for updating or deleting Public Sector Condition of
Approval Comment records, prerequisite setup tasks for the attributes, and specific validations, if any, for Condition
Approval Comment import:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Condition
of Approval
Comment Record

Updating an Existing
Condition of
Approval Comment
Record

Deleting an Existing
Condition of
Approval Comment
Record

CoaPuid The unique PUID that
identifies the migrated
condition of approval.

This must be a valid
PUID.

Required Required Required

CommentPuid The unique PUID that
identifies the migrated
condition of approval
comment,

This must be a unique
PUID.

Required Not Required Not Required

CommentText The comment
entered at the time of
resolution.

None Required Not Required Not Required

MigratedDataFlag Indicates if the
comment is migrated
from legacy system.

This value must be Y
if the data is migrated
from legacy system.

Required Not Required Not Required

Visibility Indicates if the
visibility of comments.

This must be a Y or N. Required Not Required Not Required

You can view the Public Sector Condition of Approval Comment object and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools > Import Management  >  Import Objects.
2. Select the Public Sector Condition of Approval Comment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Public Sector Condition

of Approval Comment from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Condition of Approval Transaction Data  
You can use Import Management to create, update, or delete Public Sector Condition of Approval Transaction records.

To import Public Sector Condition of Approval Transaction records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Public Sector Condition of Approval Transaction data into Oracle Applications Cloud, you need to
populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications
Cloud.
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You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new cases or are updating
cases that have source system reference data, then provide the source system and source system reference
values.

Required Attributes and Validations for Public Sector Condition of Approval
Transaction Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Public Sector
Condition of Approval Transaction records, required attributes for updating or deleting Public Sector Condition of
Approval Transaction records, prerequisite setup tasks for the attributes, and specific validations, if any, for Public Sector
Condition of Approval Transaction import:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Public
Sector Condition of
Approval Transaction
Record

Updating an
Existing Public
Sector Condition of
Approval Transaction
Record

Deleting an Existing
Public Sector
Condition of
Approval Transaction
Record

CoaPuid The unique PUID that
identifies the migrated
condition of approval.

This must be a valid
PUID.

Required Required Required
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Public
Sector Condition of
Approval Transaction
Record

Updating an
Existing Public
Sector Condition of
Approval Transaction
Record

Deleting an Existing
Public Sector
Condition of
Approval Transaction
Record

LnpRecordPuid The unique PUID
of the planning and
zoning application.

This must be a unique
in all planning and
zoning application.

Required Required Required

ConditionType The identifier of the
type of the condition.

This must be a valid
condition type.

Required Not Required Not Required

CategoryId The identifier of the
type of the category.

This must be a valid
category.

Required Not Required Not Required

SubcategoryId The identifier of
the type of the
subcategory.

This must be a valid
subcategory.

Required Not Required Not Required

Condition The identifier of the
type of the condition.

None Required Not Required Not Required

Status The status of the
condition of approval.

This must be a valid
status.

Required Not Required Not Required

PrintSeq Indicates the print
sequence of the
condition.

This must be a
number value.

Required Not Required Not Required

You can view the Public Sector Condition of Approval Transaction object and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools > Import Management  >  Import Objects.
2. Select the Public Sector Condition of Approval Transaction object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Public Sector Condition

of Approval Transaction from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
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5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Condition Comply Period Data  
You can use Import Management to create, update, or delete Public Sector Condition Comply Period records.

To import Condition Comply Period records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Condition Comply Period data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

254



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new cases or are updating
cases that have source system reference data, then provide the source system and source system reference
values.

Required Attributes and Validations for Condition Comply Period Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Condition
Comply Period records, required attributes for updating or deleting Condition Comply Period records, prerequisite setup
tasks for the attributes, and specific validations, if any, for Condition Comply Period import:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Condition
Comply Period
Record

Updating an Existing
Condition Comply
Period Record

Deleting an Existing
Condition Comply
Period Record

CoaPuid The unique PUID that
identifies the migrated
condition of approval.

This must be a valid
PUID.

Required Required Required

CoaTransComplyPuid The unique PUID that
identifies the migrated
condition of approval
transaction complies.

This must be a valid
PUID

Required Not Required Not Required

ComplyPrdId The identifier of the
compliance associated
with the conditions of
approval.

This must be a valid
comply ID

Required Not Required Not Required

Status The status of the
condition of approval.

This must be a valid
status

Required Not Required Not Required

Comments The comment
entered at the time of
resolution.

None Required Not Required Not Required

EnabledFlag Indicates if the
compliance is

This must be a Y or N Required Not Required Not Required
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Condition
Comply Period
Record

Updating an Existing
Condition Comply
Period Record

Deleting an Existing
Condition Comply
Period Record

applicable to the
conditions of approval.

You can view the Condition Comply Period object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools > Import Management  >  Import Objects.
2. Select the Public Sector Condition Comply Period object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Public Sector Condition

Comply Period from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records
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How do I import compensation plan data?  
You can use Import Management to create and update Compensation Plan records.

To import Compensation Plan Record records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Compensation Plan data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Compensation Plan Record
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for creating and updating Compensation Plan records, prerequisite setup tasks for
the attributes, and specific validations, if any, for Compensation Plan Record import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Compensation
Plan Record

Updating an Existing
Compensation Plan
Record

Name
 

The name of the
compensation plan.
 

None
 

Required
 

Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Compensation
Plan Record

Updating an Existing
Compensation Plan
Record

CompensationPlanID
 

The unique identifier of
the Compenstaion Plan
generated internally.
 

None
 

Not Required
 

Required
 

ApprovalStatus
 

The status of the
compensation plan in the
approval process.
 

Possible values include
APPROVED, NOT_
APPROVED, PENDING, and
REJECTED. Default value is
NOT_APPROVED. A list of
acceptable values is defined
in the lookup CN_PLAN_
APPR_STATUS.
 

Required
 

Not Required
 

AllowCreditCategoryOverlapFlag
 

Indicates whether a credit
category can exist in
multiple plan components
within the compensation
plan.
 

Possible values include N,
 or FALSE, and Y, or TRUE.
The default value is FALSE.
A list of acceptable values is
defined in the lookup CN_
ECAT_OVERLAP_FLAG.
 

Required
 

Not Required
 

OrgId
 

The unique ID of the
business unit to which
the compensation plan
belongs.
 

Must be a valid business
unit ID.
 

Required
 

Required
 

EndDate
 

The date on which the
compensation plan
becomes inactive.
 

Must be a valid date.
 

Required
 

Not Required
 

Description Description of the
compensation plan.

None Not Required Not Required

DisplayName The name of the
compensation plan that
is displayed on the sales
representative's user
interface.

None Not Required Not Required

PlanDocumentTemplate The name of the report
template used to create a
compensation plan.

None Not Required Not Required

TargetIncentive The expected earnings
(variable compensation) of
a participant when all the
objectives or goals in a plan
are met. The default value
is 0.

None Not Required Not Required

You can view the Compensation Plan object and its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

258



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Note:  Before importing compensation plan, you must ensure that the compensation plan's status matches (per
business logic) the performance measure's status. For example, a compensation plan with status  Complete can't
have a performance measure with status as Incomplete .

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Compensation Plan object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Compenstation Plan

Flexifield from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records
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Import Your Compensation Plan Component Data  
You can use Import Management to create and update Compensation Plan Component records.

To import Compensation Plan Component records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Compensation Plan Component data into Oracle Applications Cloud, you need to populate a CSV file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Compensation Plan
Component Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for creating and updating Compensation Plan Component records, prerequisite
setup tasks for the attributes, and specific validations, if any, for Compensation Plan Component Record import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Compensation
Plan Component Record

Updating an Existing
Compensation Plan
Component Record

CompensationPlanComponentId
 

The unique identifier
generated internally

None
 

Not Required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Compensation
Plan Component Record

Updating an Existing
Compensation Plan
Component Record

that associates a plan
component with a
compensation plan.
 

CompensationPlanID
 

The unique identifier of
the Compenstaion Plan
generated internally.
 

Must be the identifier for
an existing compensation
plan.
 

Required
 

Required
 

PlanComponentId
 

The unique identifier of a
plan component.
 

Must be the identifier for an
existing plan component.
 

Required
 

Not Required
 

StartDate
 

The date and time when
the plan component
associated with
compensation plan
becomes active.
 

Must be a valid date. Required
 

Not Required
 

EndDate
 

The date and time when
the plan component
associated with
compensation plan
becomes inactive.
 

Must be a valid date.
 

Not Required
 

Not Required
 

CalculationSequence
 

Indicates the order in
which the calculation
engine considers the
plan component within a
compensation plan.
 

Must be a valid number.
The default value is 1.
 

Not Required
 

Not Required
 

TargetIncentivePercent
 

The percentage of
influence a plan component
has on the compensation
plan.
 

Must be a number. The
default value is 100.

Not Required Not Required

You can view the Compensation Plan Component object and its attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Compensation Plan Component object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Compenstation Plan

Component from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Compensation Plans Flex Data  
You can use Import Management to create and update Compensation Plans Flex records.

You can use Import Management to create and update Compensation Plan Flexfield records.

To import Compensation Plan Flexifield records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import activity.

How You Map Your Source Data to Target Object Attributes
To import your Compensation Plan Flexifield data into Oracle Applications Cloud, you need to populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.
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You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Asset Resource Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for creating and updating Compensation Plan Flexfield records, prerequisite setup
tasks for the attributes, and specific validations, if any, for Compensation Plan Flexfield Record import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Compensation
Plan Flexifield record

Updating an Existing
Compensation Plan
Flexifield record

CompPlanId
 

The unique identifier of
the the compensation plan
generated internally.
 

Must be the identifier for
an existing compensation
plan.
 

Required
 

Required
 

CompensationPlanID
 

The unique identifier
of the Compensation
Plan Flexifield generated
internally.
 

None
 

Not Required
 

Required
 

__FLEX_Context
 

The flex context segment
code for the compensation
plan. It determines which
context-sensitive segments
are displayed.
 

None
 

Not Required
 

Not Required
 

__FLEX_Context_
DisplayValue
 

The flex context segment
display name for the
compensation plan. It
determines which context-
sensitive segments are
displayed.
 

None
 

Not Required
 

Not Required
 

Attribute1
 

Attribute 1 of the
descriptive flexfield
 

None
 

Not Required
 

Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Compensation
Plan Flexifield record

Updating an Existing
Compensation Plan
Flexifield record

AttributeNumber1
 

Numeric Attribute 1 of the
descriptive flexfield.
 

None
 

Not Required
 

Not Required
 

AttributeDate1
 

Date Attribute 1 of the
descriptive flexfield
 

None
 

Not Required
 

Not Required
 

You can view the Compensation Plan Flexfield object and its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Compensation Plan Flexfield object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Asset Resource information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Asset Resource from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

How do I import competitor data?  
You can use Import Management to create or update Competitor records.

To import Competitor records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Competitor data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the
record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can
determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional
database query. Using an internal ID typically provides better performance and reduces the import duration. For the
Competitor object, the attributes are Party Id and Registry Id.
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Required Attributes and Validations for the Competitor Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Competitor records, prerequisite setup tasks for the attributes, and specific validations, if any, for Competitor import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Competitor
Record

Updating an Existing
Competitor Record

Organization Name
 

Competitor Name - The
name that identifies the
competitor object
 

Not Applicable
 

Required
 

Conditionally Required
 

Name
 

Competitor Name - The
name that identifies the
competitor object
 

Not Applicable
 

Conditionally Required
 

Conditionally Required
 

Party Type
 

Competitor Party Type -
Type of party record
 

Not Applicable
 

Conditionally Required
 
The default value is
ORGANIZATION.
 

Do not provide a value.
 

Party ID
 

PartyId -The unique ID for
the existing competitor
record.
 

A list of all party IDs is
obtained by exporting the
Competitor object.
 

Do not provide a value.
 

Required
 

Registry ID
 

Registry ID (PartyNumber) -
The public unique identifier
of the Competitor.
 

Not Applicable
 

Do not provide a value.
 

Conditionally Required
 

You can view the Competitor object and attributes in the Manage Import Objects page of the Import Management flow.
You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Competitor object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

266



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Competitor from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Contact Data  

How do I import contact data?  
You can use the Import Management to create, update, or delete contact records.

You can import contact records using these steps:

1. Map your source contact data to Oracle Applications Cloud object attributes. This way the import process would
know where to insert each of the information bits.

2. Create the source CSV file with the contact data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your contact data into Oracle Applications Cloud, you must populate a .csv file with your source data and map
that source data to target object attributes in Oracle Applications Cloud.
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You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

To better manage your contact information, the contact object has the following child objects:

• Address

• Classification

• Relationship

• Sales Team Member

Note:  You can't set an attribute value to NULL in optimized import (standard import with the option Enable High-
Volume Import selected). However, when updating a record, you can change an attribute value from NOT NULL to
NULL

If you want to import only a few records, then you can create a single CSV file for all contact attributes. However if you
want to import a large number of records, then you may decide to create multiple CSV files, one for each of the contact
child objects. Note that you must have imported the CSV file for contact object successfully before trying to import the
CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For
more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new contacts or are
updating contacts that have source system reference data, then provide the source system and source system
reference values.
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Required Attributes and Validations for the Contact Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for contact records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup
Task or Import
Validations

Creating a Contact
Record

Updating an Existing
Contact Record

Deleting an Existing
Contact Record

SourceSystem
 

The code representing
the source system for
the contact.
 

Identify the source
system or configure
source systems either
by using the Manage
Trading Community
Source System task,
 or by importing
the source system
information into
Oracle Applications
Cloud using the
Source System
Reference import
object.
 

Conditionally
Required For uniquely
identifying a contact
record, provide one of
the following reference
information:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

Conditionally
Required For uniquely
identifying a contact
record, provide one of
the following reference
information:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

Conditionally
Required For uniquely
identifying a contact
record, provide one of
the following reference
information:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

SourceSystemReferenceValue
 

The reference number
or text representing
the source system
unique ID for the
contact.
 

Identify the source
system or configure
source systems either
by using the Manage
Trading Community
Source System task,
 or by importing
the source system
information into
Oracle Applications
Cloud using the
Source System
Reference import
object.
 

Conditionally
Required For uniquely
identifying a contact
record, provide one of
the following reference
information:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

Conditionally
Required For uniquely
identifying a contact
record, provide one of
the following reference
information:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

Conditionally
Required For uniquely
identifying a contact
record, provide one of
the following reference
information:
 

• SourceSystem
and
SourceSystemReferenceValue

• PartyNumber

PartyNumber
 

The public unique
identifier of the
contact.
 

No prerequisite tasks
 

Conditionally Required
 

Conditionally Required
 

Conditionally Required
 

FirstName
 

First name of a person
party.
 

No prerequisite tasks
 

Required
 

Not required
 

Not required
 

LastName
 

Last name of a person
party.
 

No prerequisite tasks
 

Required
 

Not required
 

Not required
 

Note:  For the Time Zone import attribute, specify the time zone of the contact to know the preferred time to call or
send e-mail to the contact.
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You can use the profile option ORA_HZ_IMPORT_MULTI_ADDRESS_TYPE to control how address types are entered. By
default this profile option is set to Yes, so you can enter multiple address types, during high-volume import of Account,
Contact, and Household objects . You can disable this profile option to improve the import performance. When you set
this profile option to No, you can enter only a single address type.

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the contact object. The
page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Providing the ZIP and Country Code values in the import CSV file won't automatically populate the State/County/City
fields. Values for these fields should be separately provided in the import file.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the contact information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Note:  After importing your data successfully, you need to run a couple of post processing jobs for duplicate
identification, duplicate resolution, and account assignment. For more information on import management post
processing jobs, see the topic: Import Management Post Processing for Accounts and Contacts.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Example of Adding or Updating Primary Account  
You can add or update the primary account of a contact using import management. Before adding or updating the
primary account, ensure that the account exists.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can add or update a primary account by submitting any one or more
of the unique identifiers.

List of Contact Identifiers:

• PartyId

• PartyNumber

• SourceSystem and SourceSystemReferenceValue

List of Account Identifiers:

• PrimaryAccountPartyId

• PrimaryAccountPartyNumber

• PrimaryAccountSourceSystem and PrimaryAccountSourceSystemReferenceValue

To add or update the primary account of a contact, you must create a source file (CSV) and import it using import
management. Below table lists the attributes using Party ID and Account Party ID as identifier:

Attribute Name Value

PartyId
 

300100545540596
 

PrimaryAccountPartyId
 

300100545540269
 

Create the Import Activity
After you have the CSV file ready, create an import activity to import the account information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
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5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• How You Enable Automatic Account Assignment

Example of Changing or Assigning Owner of a Contact  
You can change or assign the owner of a contact using import management. Before changing or assigning the owner,
ensure that the contact exists and the owner is an active or valid resource.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can change or assign a primary account by submitting any one or
more of the unique identifiers.

List of Contact Identifiers:

• PartyId

• PartyNumber

• SourceSystem and SourceSystemReferenceValue

List of Owner Identifiers:

• OwnerPartyId

• OwnerPartyNumber

• OwnerSourceSystem and OwnerSourceSystemReferenceValue

To change owner of a contact, you must create a source file (CSV) and import it using import management. Below table
lists the attributes using Party ID and Owner Party ID as identifier:
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Attribute Name Value

PartyId
 

300100545540596
 

OwnerPartyId
 

300100545540269
 

Create the Import Activity
After you have the CSV file ready, create an import activity to import the account information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• How You Enable Automatic Account Assignment

Import Your Contact Member Data  
You can use the Import Management to create, update, or delete contact member records.

You can import contact member records using these steps:

1. Map your source contact member data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the contact member data you want to import.
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3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your contact member data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new contact members or
are updating contact members that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Contact Member Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for contact member records, prerequisite setup tasks and specific validations, if
any:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contact
Member record

Updating an Existing
Contact Member record

MemberId
 

The unique ID for the
existing member record
in the Oracle Fusion
destination table.
 

The unique Id for the
existing account Id record
in the Oracle Fusion
destination table.
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
Member ID and you're
not providing the Service
Request ID and Party ID.
 

PartyId
 

The unique ID for the
existing party record in the
Oracle Fusion destination
table.
 

Do not provide a value if
creating a new party in
the same import batch
as this additional party
name. If you provide the
value for an existing party,
 the value must exist in
the HZ_PARTIES table,
 column PARTY_ID. You can
obtain the PARTY_ID for an
existing party by exporting
the Party object. To export,
 navigate to Tools >  Export
Management >  Create
Export Activity.
 

Not required
 

Not required
 

Relationship Type Code
 

Indicates relationship
with the contact, such as
ALTERNATE, FOLLOWER,
 or THIRD_PARTY.
 

If providing a value, the
value must exist in the
FND_LOOKUPS table with
LOOKUP_TYPE='ORA_SVC_
CONTACT_REL_TYPE_CD'.
 

Required
 

Required
 

Service Request ID
 

Indicates the service
request Id to which the
contact member belongs.
 

No validation
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
contact and you're not
providing the SRNumber.
 

SRNumber
 

The unique number used to
identify a service request.
You can configure the
service request number to
a format that's best suitable
to your organizational
requirements.
 

No validation
 

Conditionally required
 
A value is required if you're
updating an existing record
and you're not providing
the Service Request ID..
 

Conditionally required
 
A value is required if you're
updating an existing record
and you're not providing
the Service Request ID.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the contact member
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.
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You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contact Member object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the contact member information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact Member from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

How do I import contact point data?  
You can use Import Management to create, update, or delete Contact Point records. You can use contact point to import
customer contact information such emails, phone numbers, instant messenger address, web URL, and so on.

To import Contact Point records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
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2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Contact Point data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

• Ensure that you don't insert duplicate addresses while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new contacts or are
updating contacts that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Contact Point Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Contact Point
records, required attributes for updating Contact Point records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Contact Point import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contact Point
Record

Updating an Existing
Contact Point Record

ContactPointType
 

Type of the contact point
that's imported or updated
 

This has to be a lookup_
code in HZ_LOOKUPS
with a lookup_type as
COMMUNICATION_TYPE
 

Provide one of these
values:
 

• EMAIL, if the email
address is to be
imported.

• INSTANT_
MESSAGING, if the
instant messenger
address is to be
imported.

• WEB, if the URL is to
be imported.

• PHONE, if the phone
number is to be
imported.

Not required
 

PartyId
 

The internal ID for the party
to which the contact point
belongs
 

No validation
 

Provide one of the
following :
 

• PartyId

• Party Number

• A combination of
Party Source System
and Party Source
System Reference
Value

Not required
 

PartyNumber
 

Specifies the PUID of the
party
 

No validation
 

Provide one of the
following :
 

• PartyId

• Party Number

• A combination of
Party Source System
and Party Source
System Reference
Value

Not required
 

PartySourceSystem
 

Specifies the original
source system of the party
 

This has to be in HZ_ORIG_
SYSTEMS_B with the status
"A".
 

Provide one of the
following :
 

• PartyId

• Party Number

• A combination of
Party Source System
and Party Source
System Reference
Value

Not required
 

PartySourceSystemReferenceValue
 

Specifies the party's source
system reference in the
original source system

No validation
 

Provide one of the
following :
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contact Point
Record

Updating an Existing
Contact Point Record

 • PartyId

• Party Number

• A combination of
Party Source System
and Party Source
System Reference
Value

SourceSystem
 

Specifies the original
source system name
 

This has to be in HZ_ORIG_
SYSTEMS_B with the status
"A".
 

Provide a valid value.
 

Not required
 

SourceSystemReferenceValue
 

Specifies the identifier in
the original source system
 

No validation
 

Provide a valid value.
 

Not required
 

ContactPointId
 

System generated unique
identifier. This is the
primary key.
 

No validation
 

Not required
 

If you can export the
existing contact point,
 provide this primary key
to identify the record for
further updates.
 

Status
 

The status of the contact
point.
 

Not required
 
This defaults to Y during
creation.
 

Not required
 

To inactivate an existing
active contact point record,
 you need to set the Import
Mode to "Delete Records"
and pass Contact Point
Id. Contact point Source
system, or Contact point
Source system reference.
 

DoContactPreferenceFlag
 

Add or update a contact's
preference to receive e-
mail or phone calls on
the contact, account or
household contact points.
This attribute identifies if a
contact has made a choice
to be contacted.
 

Don't set both
this attribute and
DoNotContactPreferenceFlag
to Y simultaneously.
 
Set either this attribute or
DoNotContactPreferenceFlag
to "Y". These are non-
mandatory values.
However, you can set
both this attribute and
DoNotContactPreferenceFlag
to "N".
 

Not required
 

Not required
 

DoNotContactPreferenceFlag
 

Add or update a contact's
preference not to receive
e-mail or phone calls on
the contact, account or
household contact points.
This attribute identifies if a
contact has made no choice
to be contacted.
 

Don't set both
this attribute and
DoContactPreferenceFlag
to Y simultaneously.
 
Set either this attribute or
DoContactPreferenceFlag
to "Y". These are non-
mandatory values.
However, you can set
both this attribute and

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contact Point
Record

Updating an Existing
Contact Point Record

DoContactPreferenceFlag
to "N".
 

DoNotContactReason
 

Add or update the reason
for a contact not to receive
e-mail or phone calls on
the contact, account or
household contact points.
 

This is used for
DoNotContactPreferenceFlag.
It is a non-mandatory field.
 

Not required
 

Not required
 

You can view the Contact Point object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contact Point object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact Point from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.

280



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Contest Data  
You can use Import Management to create update, or delete Contest records.

To import Contest records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Contest data into Oracle Applications Cloud, you need to populate a CSV file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
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the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new contests or are
updating contests that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Contest Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Contest records,
required attributes for updating Contest records, prerequisite setup tasks for the attributes, and specific validations, if
any, for Contest import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contest Record Updating an Existing
Contest Record

ContestId
 

The unique identifier of the
contest
 

No validation
 

Not required
 
This is auto generated.
 

Conditionally required
 
Either the ContestId or the
ContestNumber is required.
 

ContestName
 

The name of the contest
 

No validation
 

Required
 

Not required
 

OwnerId
 

The unique identifier of a
valid employee resource
who owns and manages the
contest
 

The resource should exist.
 

Not required
 
This is auto defaulted to
creator.
 

Not required
 

StartDate
 

The start date of the
contest
 

Current date and time or a
future date
 

Required
 

Not required
 

EndDate
 

The end date of the contest
 

This must be later than the
start date.
 

Required
 

Not required
 

KPIId
 

The unique identifier of the
KPI selected for the contest
 

The KPI record should exist.
 

Either the KPIId or the
KPINumber is required
 

Not required
 

OwnerNumber
 

The unique alternate
identifier of the resource
who owns and manages the
contest
 

The resource should exist.
 

Not required
 
This is auto defaulted to
creator.
 

Not required
 

KPINumber
 

The unique alternate
identifier of the KPI
selected for the contest
 

The KPI record should exist.
 

Either the KPIId or the
KPINumber is required.
 

Not required
 

ContestNumber
 

The unique alternate
identifier for the contest
 

No validation
 

Not required
 
This is auto generated.
 

Conditionally required
 
Either the ContestId or the
ContestNumber is required.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contest Record Updating an Existing
Contest Record

 

You can view the Contest object along with all its child objects and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contest object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contest from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?
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Import Your Contest Resources Data  
You can use Import Management to create update, or delete Contest Resources records.

To import Contest Resources records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Contest Resources data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new contest resources or
are updating contest resources that have source system reference data, then provide the source system and
source system reference values.
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Required Attributes and Validations for Contest Resources Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Contest
Resources records, required attributes for updating Contest Resources records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Contest Resources import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contest
Resources Record

Updating an Existing
Contest Resources Record

Contest ResourceId
 

The unique identifier of the
contest resource
 

No validation
 

Not required
 
This is auto generated.
 

Conditionally required
 
A value is required if the
composite key isn't used.
 

ResourceId
 

The unique identifier of the
resource associated with
the contest
 

The resource should exist.
 

Required
 
Either the ResourceId or
the ResourceNumber is
required.
 

Not required
 
This can be used as
a composite key with
ContestId when the primary
key isn't used.
 

ResourceNumber
 

The unique alternate
identifier of the resource
associated with the contest
 

The resource should exist.
 

Required
 
Either the ResourceId or
the ResourceNumber is
required.
 

Not required
 
This can be used as
a composite key with
ContestNumber when the
primary key isn't used.
 

ContestId
 

The unique identifier of the
contest
 

The contest should exist.
 

Required
 
Either the ContestId or the
ContestNumber is required.
 

Not required
 
This can be used as
a composite key with
ResourceId when the
primary key isn't used.
 

ContestNumber
 

The unique alternate
identifier for the contest
 

The contest should exist.
 

Required
 
Either the ContestId or the
ContestNumber is required.
 

Not required
 
This can be used as
a composite key with
ResourceNumber when the
primary key isn't used.
 

You can view the Contest Resources object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
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2. Select the Contest Resources object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contest Resources from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Contract Data  

How do I import contract data?  
You can use Import Management to create or update Contract data.

To import Contract records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
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3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application.

Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique
identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually
named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify
the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import
Records" in Related Topics section.

Note:  You can't update or customize a PUID. You can provide a unique value. If left blank, the system will generate a
unique identifier.

Required Attributes and Validations for the Contract Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Record

Updating an Existing
Contract Record

ContractNumber
 

The alternate unique
identifier of the Contract.
 

No validation
 

Required
 

Not required
 

ContractPuid
 

The unique PUID that
identifies the Contract.
 

This number identifier must
be unique across Contracts
of all types.
 

Required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Record

Updating an Existing
Contract Record

ContractTypeId
 

The unique ID of the
Contract type. The Contract
type sets various properties
for the Contract such as the
type of permitted Contract
lines, party roles, Contract
validation checks, and the
Contract acceptance and
signature requirements.
 

You can determine and
manage Contract types.
 
Navigate to the following in
Setup and Maintenance:
 

• Offering: Sales

• Functional Area: Sales

• Task: Manage
Contract Types

Required if
ContractTypeName isn't
entered.
 

Not required
 

ContractTypeName
 

The name of the Contract
type. The Contract type
sets various properties for
the Contract such as the
type of permitted Contract
lines, party roles, Contract
validation checks, and the
Contract acceptance and
signature requirements.
 

You can determine and
manage Contract types.
 
Navigate to the following in
Setup and Maintenance:
 

• Offering: Sales

• Functional Area: Sales

• Task: Manage
Contract Types

Required if ContractTypeId
isn't entered.
 

Not required
 

Currency
 

The name of the currency
in which Contract amounts
are entered.
 

This must be a valid
currency.
 

Required if CurrencyCode
isn't entered
 

Not required
 

CurrencyCode
 

The code of the currency
in which Contract amounts
are entered.
 

This must be a valid
currency.
 

Required if Currency isn't
entered
 

Not required
 

InvOrganizationId
 

The unique Id representing
the item master
organization
 

This must be a valid
ORGANIZATION_ID
from the HR_ALL_
ORGANIZATION_UNITS_F
table.
 

Required if the InvOrgName
isn't entered
 

Not required
 

InvOrgName
 

The name representing the
item master organization.
 

This must be a valid
ORGANIZATION_ID
from the HR_ALL_
ORGANIZATION_UNITS_F
table.
 

Required if the
InvOrganizationId isn't
entered
 

Not required
 

LegalEntityId
 

The unique Id of the legal
entity to which the Contract
belongs.
 

This must be a valid record
as per GL_LEDGER_LE_V.
 

Required if the
LegalEntityName isn't
entered.
 

Not required
 

LegalEntityName
 

The name of the legal
entity to which the Contract
belongs.
 

This must be a valid record
as per GL_LEDGER_LE_V.
 

Required if the
LegalEntityId isn't entered.
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Record

Updating an Existing
Contract Record

OrgId
 

The unique Id of the
business unit to which the
Contract belongs.
 

This must be a valid
business unit Id.
 

Required if the OrgName
isn't entered
 

Not required
 

OrgName
 

The name of the business
unit to which the Contract
belongs.
 

This must be a valid
business unit name.
 

Required if the OrgId isn't
entered
 

Not required
 

StartDate
 

The date on which the
Contract comes into effect.
 

No validation
 

Required
 

Not required
 

StsCode
 

The code of the Contract
status. Examples are
ACTIVE, DRAFT, CLOSED,
 and CANCELED.
 

Navigate to the following in
Setup and Maintenance:
 

• Offering: Sales

• Functional Area: Sales

• Task: Manage
Standard Lookups

Search for the Contract
Statuses lookup.
 
Activating a draft contract,
and one-time import of
closed, canceled, and active
contracts is supported. You
can't update the contract
status from active to any
other status. Also, you can't
update a contract once it is
active.
 
You can't import contracts
in EXPIRED status directly
in the system. You must
import the contracts with
ACTIVE status and then
update contract status to
EXPIRED.
 

Required
 

Not required
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Note:  Keep a note of the following:

• The attribute GeneratedInvoiceStatus must have one of the following values:

◦ D for Draft

◦ S for Submitted for approval

◦ R for Released

◦ Ensure to provide one of the values D, S, or R while importing Project contracts.

• SupplierId is the party identifier of the supplier and SupplierSiteId is the party site identifier of the vendor.

• When you import contracts using the contract type column with the contract numbering method set as
Automatic, you can leave the ContractNumber column blank in the CSV file for the application to generate the
contract numbers automatically. You can also enter the contract number manually when you don't want the
application to assign the contract numbering automatically.

• When the contract type has the contract numbering method set as Manual, you can't leave the contract
number blank. If the contract number is left blank, then the application generates an error.

• To activate a contract while importing, provide the value 'ACTIVE' for the StsCode attribute. This will also
activate the lines added to the contract.

• To import contracts that are closed, canceled, or on hold, you must first import the contract with all required
import files, and then re-import the contract import file with the following information:

◦ Closed contracts: You must include Status (the status will be Closed), Close reason code,
CloseReasonSetCode, Termination Date.

◦ On-Hold Contracts: You must include Status (the status will be Hold), Hold Reason Code, Hold reason
Set Code, Hold Until Date.

◦ Canceled contracts: You must include Status (the status will be Canceled), Cancel Reason, Cancel
reason set code, Cancel date.

◦ To avoid the modification of the contribution percentage you must include the contribution percentage
in the same import file that you're using to activate the contract.

• To import data in other languages, use the column attributes "Language and Source Language" in Contract
header file and set the preferred language. Then import the parties with the desired values.You can view the Contract object and attributes in the Manage Import Objects page of the Import Management flow.

You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Example of Importing Contract Data  
A contract is an agreement between two or more than two parties to fulfill an agreed scope of work. This example
demonstrates how to import contract data using Import Management.

In this example, you have a source file containing contract data that you want to import into the application.

Summary of the Tasks
You perform the following steps to create an import activity and activate the import:

1. Determine what information is in the source file.
2. Create and schedule the import activity.

Determine the Information in the Source File
You include the data that you want to import into Sales and Fusion Service in a source CSV file. A sample input CSV file
for importing contracts with the required attributes:
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Sample CSV file to Import Contracts

ContractNumberContractPuid ContractTypeNameCurrency InvOrgName LegalEntityNameOrgId StartDate StsCode

GP-12345
 

GP-12345 1 Service
Contract
 

US Dollar Vision
Operations

Vision
Operations

204
 

1/1/2020
 

DRAFT
 

SP-5695 SP-5695 AOKC_
SellLines

US Dollar Vision Project
Mfg
 

Vision Project
Mfg
 

600 22/5/2022
 

DRAFT
 

AB-88601 AB-88601 AOKC_
BuyLines

US Dollar Vision
Services

Vision
Services

458 5/8/2022 DRAFT
 

Note the following:

• When you import contracts using the contract type column with the contract numbering method set as
Automatic, you can leave the ContractNumber column blank in the CSV file for the application to generate the
contract numbers automatically. You can also enter the contract number manually when you don't want the
application to assign the contract numbering automatically.

• When the contract type has the contract numbering method set as Manual, you can't leave the contract
number blank. If the contract number is left blank, then the application generates an error.

• To activate a contract while importing, provide the value 'ACTIVE' for the StsCode attribute. This will also
activate the lines added to the contract.

• To import contracts that are closed, canceled, or on hold, you must first import the contract with all required
import files, and then re-import the contract import file with the following information:

◦ Closed contracts: You must include Status (the status will be Closed), Close reason code,
CloseReasonSetCode, Termination Date.

◦ On-Hold Contracts: You must include Status (the status will be Hold), Hold Reason Code, Hold reason Set
Code, Hold Until Date.

◦ Canceled contracts: You must include Status (the status will be Canceled), Cancel Reason, Cancel reason
set code, Cancel date.

You can create an import activity, enter the import details, and schedule the import.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract from the Object

drop-down list.

Note: In the Advanced Options section, the option Enable High-Volume Import is selected by default. This mode is
designed to import millions of records at once.

1. Select the CSV file in the File Name field, and click Next.
2. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
3. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
4. Review the import details on the Review and Submit page, and click Submit.
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Import Your Contract Bill Line Data  
You can use Import Management to create or update Contract Bill Line records.

To import Contract Bill Line records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Bill Line data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Contract Bill Line object, the attributes are LinePUID and SequenceNumber.

Required Attributes and Validations for the Contract Bill Line Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
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Contract Bill Line records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Bill Line
import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Bill
Line Record

Updating an Existing
Contract Bill Line Record

LinePuid
 

The unique PUID that
identifies the contract line
 

This must be a valid PUID.
 

A value is required if the
covered asset external
source and external key
aren't specified.
 

Not required
 

SequenceNumber
 

The sequence number of
the contract bill line
 

No validation
 

Required
 

Not required
 

ChargeDefinitionCode
 

The charge definition code
 

This must be a valid charge
definition code defined in
the contract pricing.
 

A value is required if the
charge definition isn't
passed.
 

Not required
 

ChargePeriod
 

The charge period
 

No validation
 

Required
 

Not required
 

ChargeDefinition
 

The charge definition
 

This must be a valid charge
definition defined in the
contract pricing.
 

A value is required if the
charge definition code isn't
passed.
 

Not required
 

ExtSource
 

The external source of the
bill line
 

This must be a unique
external source across all
bill lines.
 

Required
 

Required
 

ExtKey
 

The external key of the bill
line
 

This must be a unique
external key across all bill
lines.
 

Required
 

Required
 

CoveredAssetExtSource
 

The external source of the
covered asset
 

This must be a valid
covered asset external
source.
 

A value is required if the
line PUID isn't passed.
 

Not required
 

CoveredAssetExtKey
 

The external key of the
covered asset
 

This must be a valid
covered asset external key.
 

A value is required if the
line PUID isn't passed.
 

Not required
 

DateToInterface
 

The date to interface
 

No validation
 

Required
 

Not required
 

DateBilledFrom
 

The date from which the
contract bill line becomes
effective.
 

No validation
 

Required
 

Not required
 

DateBilledTo
 

The date till which the
contract bill line is effective
 

No validation
 

Required
 

Not required
 

RecurringFlag
 

The option indicating if this
line is recurring
 

The valid values are Yes or
No.
 

Required
 

Not required
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You can view the Contract Bill Line object and attributes in the Manage Import Objects page of the Import Management
flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Bill Line object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Bill Line from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?
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Import Your Contract Billing Milestone Data  
You can use Import Management to create update, or delete Project Contract Billing Milestone records.

To import Milestone records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Project Contract Billing Milestone data into Oracle Applications Cloud, you need to populate a CSV file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

• Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new cases or are updating
cases that have source system reference data, then provide the source system and source system reference
values.
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Required Attributes and Validations for Project Contract Billing Milestone
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Project Contract
Billing Milestone records, required attributes for updating or deleting Milestone records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Milestone import:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Project
Contract Billing
Milestone Record

Updating an Existing
Project Contract
Billing Milestone
Record

Deleting an Existing
Project Contract
Billing Milestone
Record

LinePuid The unique PUID that
identifies the contract
line.

This must be a valid
PUID.

Required Not Required Not Required

ExternalSourceKey The external source
of the milestone
information.

The external source
and key combination
must be unique.

Required
 
A combination of
external source
and external key is
required.
 

Required Required

ExternalReferenceKey The external key of the
milestone information.

The external source
and key combination
must be unique.

Required
 
A combination of
external source
and external key is
required.
 

Required Required

MilestoneName The name of the
milestone.

No validation A value is required
if you're creating a
new milestone on
a contract line, as
opposed to adding
an existing project
plan milestone to the
contract line.

Not Required Not Required

ProjectId The unique identifier
of the project that
owns the milestone.

The project must have
an active association
to the contract line.

Required if
ProjectNumber isn't
entered.

Not Required Not Required

ProjectNumber The number of the
project that owns the
milestone.

The project must have
an active association
to the contract line.

Required if ProjectId
isn't entered.

Not Required Not Required

ParentTaskId The unique identifier
of the project plan
parent task under
which the milestone is
created.

The parent task of a
milestone must be on
or below the level at
which the project is
associated with the
contract line. Don't
populate this attribute
if you want to create
a milestone with the
project as the parent.

Either ParentTaskId or
ParentTaskNumber is
required if the project
is associated to the
contract line at a task
level.

Not Required Not Required
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Project
Contract Billing
Milestone Record

Updating an Existing
Project Contract
Billing Milestone
Record

Deleting an Existing
Project Contract
Billing Milestone
Record

ParentTaskNumber The unique number of
the project plan parent
task under which the
milestone is created.

The parent task of a
milestone must be on
or below the level at
which the project is
associated with the
contract line. Don't
populate this attribute
if you want to create
a milestone with the
project as the parent.

Either ParentTaskId or
ParentTaskNumber is
required if the project
is associated to the
contract line at a task
level.

Not Required Not Required

PlannedFinishDate The expected finish
date of the milestone.

The planned finish
date must be within
the effective dates of
the milestone's parent
in the project plan if
the Automatically Roll
Up Task Planned Dates
setting is not enabled.
The planned finish
date must also be
within the effectivity
dates of the contract
line. If the milestone
is for an Award, then
the planned finish date
must be on or after the
earlier of the preaward
date or the contract
line start date and
on or before the later
of the close date or
contract line end date.

A value is required
if you're creating a
new milestone on
a contract line, as
opposed to adding
an existing project
plan milestone to the
contract line.

Not Required Not Required

MilestoneAmount The bill transaction
amount for the
milestone.

No validation Required Not Required Not Required

TransactionCurrency The currency code of
the bill transaction
amount for the
milestone.

The bill transaction
currency must be
the same as the
contract currency for
milestones.

Required Not required Not Required

EventTypeId The unique identifier
of the event type
of the billing event
created for the
milestone.

The event type must
be active as of the
current date. Event
types with the Allow
Item option enabled
can't be used for
milestones.

Required if
EventTypeName isn't
entered.

Not Required Not Required

EventTypeName The name of the event
type of the billing
event created for the
milestone.

The event type must
be active as of the
current date. Event
types with the Allow
Item option enabled
can't be used for
milestones.

Required if
EventTypeId isn't
entered.

Not Required Not Required
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Project
Contract Billing
Milestone Record

Updating an Existing
Project Contract
Billing Milestone
Record

Deleting an Existing
Project Contract
Billing Milestone
Record

ProjectPlanMilestoneId The unique identifier
of the milestone in the
project plan.

The project plan
milestone must be
billable, lowest-level
in the project plan,
have no duration,
isn't in a Complete
status, and isn't
already associated to a
contract line.

To add an existing
project plan
milestone to a
contract line, either
ProjectPlanMilestoneId
or
ProjectPlanMilestoneNumber
is required.

Not Required Not Required

ProjectPlanMilestoneNumberThe unique number of
the milestone in the
project plan.

The project plan
milestone must be
billable, lowest-level
in the project plan,
have no duration,
isn't in a Complete
status, and isn't
already associated to a
contract line.

To add an existing
project plan
milestone to a
contract line, either
ProjectPlanMilestoneId
or
ProjectPlanMilestoneNumber
is required.

Not required Not Required

You can view the Project Contract Billing Milestone object and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools > Import Management  >  Import Objects.
2. Select the Project Contract Billing Milestone object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Project Contract Billing

Milestone from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Contract Charge Data  
You can use Import Management to create or update Contract Charge records.

To import Contract Charge records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Charge data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Contract Charge object, the attribute is LinePUID.

Required Attributes and Validations for the Contract Charge Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Charge records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Charge
import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Charge Record

Updating an Existing
Contract Charge Record

LinePUID
 

The PUID of the contract
line
 

This must be a valid line
PUID.
 

A value is required if the
charge is associated with a
contract line.
 

Required
 

CoveredAssetExtSource
 

The external source of the
covered asset
 

This must be a valid
covered asset external
source.
 

A value is required if the
charge is associated with a
covered asset.
 

Required
 

CoveredAssetExtKey
 

The external key of the
covered asset
 

This must be a valid
covered asset external key.
 

A value is required if the
charge is associated with a
covered asset.
 

Required
 

ChargeDefinitionCode
 

The charge definition code
 

This must be a valid charge
definition code defined in
contract pricing.
 

A value is required if the
charge definition name isn't
passed.
 

Not required
 

ChargeDefinition
 

The charge definition name
 

This must be a valid charge
definition name defined in
contract pricing.
 

A value is required if the
charge definition code isn't
passed.
 

Not required
 

PricePeriodicityCode
 

The price periodicity code
 

This must be a valid price
periodicity code.
 

A value is required if the
price periodicity name isn't
passed.
 

Not required
 

PricePeriodicity
 

The price periodicity name
 

This must be a valid price
periodicity name.
 

A value is required if the
price periodicity code isn't
passed.
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Charge Record

Updating an Existing
Contract Charge Record

ExtSource
 

The external source of the
charge
 

This must be a unique
value across the Charge
table.
 

Required
 

Not required
 

ExtKey
 

The external key of the
charge
 

This must be a unique
value across the Charge
table.
 

Required
 

Not required
 

You can view the Contract Charge object and attributes in the Manage Import Objects page of the Import Management
flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Charge object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Charge from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.

302



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Charge Component Data  
You can use Import Management to create or update Contract Charge Component records.

To import Contract Charge Component records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Charge Component data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Required Attributes and Validations for the Contract Charge Component
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Charge Component records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Contract Charge Component import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Charge Component
Record

Updating an Existing
Contract Charge
Component Record

ExtSource
 

The external source of the
charge component
 

This must be a unique
value across the Charge
Components table.
 

Required
 

Required
 

ExtKey
 

The external key of the
charge component
 

This must be a unique
value across the Charge
Components table.
 

Required
 

Required
 

ContractChargeExtSource
 

The external source of the
charge
 

This must be a valid charge
external source.
 

Required
 

Not required
 

ContractChargeExtKey
 

The external key of the
charge
 

This must be a valid charge
external key.
 

Required
 

Not required
 

HeaderCurrencyUnitPrice
 

The unit price of the charge
 

No validation
 

Required
 

Not required
 

You can view the Contract Charge Component object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Charge Component object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Charge

Component from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Covered Assets Data  
You can use Import Management to create or update Contract Covered Assets records.

To import Contract Covered Assets records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Covered Assets data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Contract Covered Assets object, this attribute is AssetId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Contract Covered Assets object,
the attributes are LinePUID and LineNumber.

Required Attributes and Validations for the Contract Covered Assets Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Covered Assets records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract
Covered Assets import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Covered Assets Record

Updating an Existing
Contract Covered Assets
Record

LinePuid
 

The PUID of the contract
line
 

This must be a valid line
PUID.
 

Required
 

Not required
 

EndDate
 

The end date of the
covered asset
 

No validation
 

Not required
 

Not required
 

ExtKey
 

The external key of the
covered asset
 

This must be a unique
external key across all
covered assets.
 

Required
 

Required
 

ExtSource
 

The external source of the
covered asset
 

This must be a unique
external source across all
covered assets.
 

Required
 

Required
 

LineNumber
 

The line number of the
covered asset
 

No validation
 

Required
 

Not required
 

PriceUom
 

The price unit of measure
 

This must be a valid price
UOM.
 

A value is required if the
priceuomcode isn't
passed.
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Covered Assets Record

Updating an Existing
Contract Covered Assets
Record

PriceUomCode
 

The price unit of measure
code
 

This must be a valid price
UOM code.
 

A value is required if the
priceuom isn't passed.
 

Not required
 

Quantity
 

The contract covered assets
quantity
 

No validation
 

Required
 

Not required
 

StartDate
 

The date on which the
contract covered asset
begins
 

No validation
 

Required
 

Not required
 

Status
 

The status of the contract
covered asset
 

This must be a valid status.
 

A value is required if the
status code isn't passed.
 

Not required
 

StatusCode
 

The status code of the
contract covered asset
 

This must be a valid status
code.
 

A value is required if the
status isn't passed.
 

Not required
 

AssetId
 

The unique identifier of the
asset
 

This must be a valid asset
ID.
 

A value is required if the
asset name isn't passed.
 

Not required
 

AssetName
 

The name of the asset
 

This must be a valid asset
name.
 

A value is required if the
asset ID isn't passed.
 

Not required
 

You can view the Contract Covered Assets object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Covered Assets object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
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3. In the Enter Import Options page, provide a name for the import activity, and select Contract Covered Assets
from the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

How do I import contract header descriptive flexfield
data?  
You can use Import Management to create or update Contract Header Descriptive Flexfield records.

To import Contract Header Descriptive Flexfield records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Header Descriptive Flexfield data into Oracle Applications Cloud, you must populate a .csv file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.
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• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Contract Header Descriptive Flexfield object, the
attribute is Contract Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Contract Header Descriptive
Flexfield object, the attribute is Contract PUID.

Required Attributes and Validations for the Contract Header Descriptive
Flexfield Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Header Descriptive Flexfield records, prerequisite setup tasks for the attributes, and specific validations, if any,
for Contract Header Descriptive Flexfield import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Header Descriptive
Flexfield Record

Updating an Existing
Contract Header
Descriptive Flexfield
Record

ContractId
 

The Id of the contract.
 

This must be a valid
contract Id.
 

Not required
 

Not required
 

ContractPuid
 

The unique PUID that
identifies the contract.
 

This must be a valid
contract PUID.
 

Required
 

Required
 

AttributeCategory
 

Attribute category of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Header Descriptive
Flexfield Record

Updating an Existing
Contract Header
Descriptive Flexfield
Record

Attribute1
 

Attribute 1 of the
descriptive flexfield
 

No validation
 

Required
 

Not required
 

Attribute2
 

Attribute 2 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute3
 

Attribute 3 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute4
 

Attribute 4 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute5
 

Attribute 4 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

You can view the Contract Header Descriptive Flexfield object and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Note:  For importing Context Sensitive DFFs you need to run a query in the "okc_k_headers_all_b" table that contains
the DFF you want to import. It lets you find out and populate your "AttributeCategory" field that is required to perform
the operation. It's recommended to perform the query on an already existing contract that contains the DFF you want
to import, so you can easily find the "AttributeCategory" field.To provide the Attribute category: 1. Create/Update a
contract with the Context of DFF you're expecting 2. Get the query output of "Select ATTRIBUTE_CATEGORY from
okc_k_headers_all_b where contract_number = '<<Contract Number>>'" 3. Update the value fetched from the above
query in the import data file

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Header Descriptive Flexfield object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Header

Descriptive Flexfield from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Header Translation Data  
You can use the import functionality to create, update, or delete your contract header translation data.

You can import contract header translation records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the contract header translation data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import contract header translation data into Oracle Applications Cloud from a CSV file containing your source data
that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the contract header translation import object.
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• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all contract header translation
attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files,
one for each of the contract header translation child objects. Note that you must have imported the CSV file for contract
header translation object successfully before trying to import the CSV files for the child objects. There are separate help
topics describing how to import each of these child objects. For more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new contract header
translation or are updating contract header translation that have source system reference data, then provide
the source system and source system reference values.

Required Attributes and Validations for Contract Header Translation Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for contract header translation records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Header Translation record

Updating an Existing
Contract Header
Translation record

ContractPuid
 

The PUID of the contract
for which the translation
information is captured.
 

Must be a valid contract
PUID.
 

Required
 

Required
 

Lang
 

The language of the
translation.
 

Must be a valid language.
You can find valid values in
OKC_CONTRACT_TYPES_
TL table.
 

Required
 

Required
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Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the contract header
translation object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Header Translation object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the contract header translation information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Contract Header Translation from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• Tables and Views for Sales and Fusion Service

How do I import contract line data?  
You can use Import Management to create or update Contract Line records.

To import Contract Line records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Line data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
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Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Contract Line object, the attributes are Line Id and Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Contract Line object, the
attribute is Line PUID.

Required Attributes and Validations for the Contract Line Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Line records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Line
import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Line
Record

Updating an Existing
Contract Line Record

ContractPuid
 

The unique PUID that
identifies the contract
 

No validation
 

Required
 

Not required
 

ItemName
 

The item name for an item
type of line
 

This must be a valid
inventory item.
 

Required for an item type of
line
 

Not required
 

ItemNameTxt
 

The item name for a free
form type of line
 

No validation
 

Required for a free form
type of line
 

Not required
 

ItemQuantity
 

The line quantity.
 

No validation
 

Required for an item type of
line
 

Not required
 

LineAmount
 

The line amount.
 

No validation
 

Required for a free form
type of line
 

Not required
 

LineNumber
 

The number of the contract
line.
 

This must be a unique
number within a contract.
 

Required
 

Not required
 

LinePuid
 

The unique PUID that
identifies the contract line.
 

This must be a unique
PUID across all contract line
records.
 

Required
 

Required
 

LineStatus
 

The line status
 

This must be one of Active,
 Draft, Closed, or Canceled.
 

Required if StsCode isn't
entered
 

Not required
 

LineTypeId
 

The Id that represents the
line type.
 

This must be valid as per
OKC_CONTRACT_TYPE_
LINES.
 

Required if LineTypeName
isn't entered
 

Not required
 

LineTypeName
 

The name of the line type.
 

This must be valid as per
OKC_CONTRACT_TYPE_
LINES.

Required if LineTypeId isn't
entered
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Line
Record

Updating an Existing
Contract Line Record

 

StartDate
 

The date from which the
contract line becomes
effective.
 

No validation
 

Required
 

Not required
 

StsCode
 

The code that represents
the line status
 

This must be one of
ACTIVE, DRAFT, CLOSED,
 or CANCELED
 

Required if LineStatus isn't
entered
 

Not required
 

UnitOfMeasure
 

The unit of measure of the
contract line.
 

This must be a valid unit of
measure in INV_UNITS_OF_
MEASURE_TL.UNIT_OF_
MEASURE.
 

Required if the UOMCode
isn't entered
 

Not required
 

UnitPrice
 

The unit price of the line.
 

No validation
 

Required for an item type of
line
 

Not required
 

UOMCode
 

The UOM code of the
contract line.
 

This must be a valid unit of
measure in INV_UNITS_OF_
MEASURE_B.UOM_CODE.
 

Required if the
UnitOfMeasure isn't
entered
 

Not required
 

You can view the Contract Line object and attributes in the Manage Import Objects page of the Import Management
flow. You can find attribute information like type, length, description, and so on, on this page.

Note:  The attribute PriceAsOf can't be updated.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Line object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
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3. In the Enter Import Options page, provide a name for the import activity, and select Contract Line from the
Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Line Descriptive Flexfield Data  
You can use Import Management to create or update Contract Line Descriptive Flexfield records.

To import Contract Line Descriptive Flexfield records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Line Descriptive Flexfield data into Oracle Applications Cloud, you must populate a .csv file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Contract Line Descriptive Flexfield object, the attribute is
Line Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Contract Line Descriptive
Flexfield object, the attribute is Line PUID.

Required Attributes and Validations for the Contract Line Descriptive
Flexfield Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Line Descriptive Flexfield records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Contract Line Descriptive Flexfield import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Line
Descriptive Flexfield
Record

Updating an Existing
Contract Line Descriptive
Flexfield Record

LineId
 

The Id of the contract line.
 

This must be a valid
contract line Id.
 

Not required
 

Not required
 

LinePuid
 

The unique PUID that
identifies the contract line.
 

This must be a valid
contract line PUID.
 

Required
 

Required
 

AttributeCategory
 

Attribute category of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute1
 

Attribute 1 of the
descriptive flexfield

No validation
 

Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Line
Descriptive Flexfield
Record

Updating an Existing
Contract Line Descriptive
Flexfield Record

 

Attribute2
 

Attribute 2 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute3
 

Attribute 3 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute4
 

Attribute 4 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute5
 

Attribute 5 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

You can view the Contract Line Descriptive Flexfield object and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Line Descriptive Flexfield object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Line Descriptive

Flexfield from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

319



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Line Internal Attribute Data  
You can use Import Management to create or update contract line internal attribute records.

To import contract line internal attribute records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your contract line internal attribute data into Oracle Applications Cloud, you must populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
contract line internal attribute object, the attribute is LinePUID.

Required Attributes and Validations for the Contract Line Internal Attribute
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
contract line internal attribute records, prerequisite setup tasks for the attributes, and specific validations, if any, for
contract line internal attribute import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Line
Internal Attribute Record

Updating an Existing
Contract Line Internal
Attribute Record

LinePuid
 

The PUID of the contract
line for which the internal
attributes are captured.
 

This must be a valid
contract line PUID.
 

Required
 

Not required
 

ExtSource
 

The external source of
the contract line internal
attribute information.
 

This must be a unique
combination of external
source and key.
 

Required
 
A combination of external
source and external key is
required.
 

Required
 

ExtKey
 

The external key of the
contract line internal
attribute information.
 

This must be a unique
combination of external
source and key.
 

Required
 
A combination of external
source and external key is
required.
 

Required
 

ProviderBusinessUnitId
 

The provider business unit
ID. This is applicable for
inter-company contract
 

This must be a valid
business unit ID.
 

Required if a business unit
name isn't passed.
 

Not required
 

ProviderBuName
 

The provider business unit
name. This is applicable for
inter-company contract.
 

This must be a valid
business unit name.
 

Required if a business unit
ID isn't passed.
 

Not required
 

RcvrBusinessUnitId
 

The receiver business unit
ID. This is applicable for
inter-company contract.
 

This must be a valid
business unit ID.
 

Required if a business unit
name isn't passed.
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Line
Internal Attribute Record

Updating an Existing
Contract Line Internal
Attribute Record

RcvrBuName
 

The receiver business unit
name. This is applicable for
inter-company contract.
 

This must be a valid
business unit name.
 

Required if a business unit
ID isn't passed.
 

Not required
 

ReceiverProjectId
 

The receiver project ID.
This is applicable for inter-
company and inter-project
contracts.
 

This must be a valid project
ID.
 

Required if a project
number isn't passed.
 

Not required
 

ReceiverProjectNumber
 

The receiver project
number. This is applicable
for inter-company and
inter-project contracts.
 

This must be a valid project
number.
 

Required if a project ID isn't
passed.
 

Not required
 

ReceiverTaskId
 

The receiver task ID. This
is applicable for inter-
company and inter-project
contracts.
 

This must be a valid task ID.
 

Required if a task number
isn't passed.
 

Not required
 

ReceiverTaskNumber
 

The receiver task number.
This is applicable for inter-
company and inter-project
contracts.
 

This must be a valid task
number.
 

Required if a task ID isn't
passed.
 

Not required
 

You can view the contract line internal attribute object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Line Internal Attribute object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
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3. In the Enter Import Options page, provide a name for the import activity, and select Contract Line Internal
Attribute from the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Line Sales Credit Data  
You can use Import Management to create or update Contract Line Sales Credit records.

To import Contract Line Sales Credit records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Line Sales Credit data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Contract Line Sales Credit object, the attribute is Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Contract Line Sales Credit
object, the attributes are Sales Credit PUID and Line PUID.

Required Attributes and Validations for the Contract Line Sales Credit
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Line Sales Credit records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract
Line Sales Credit import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Line
Sales Credit Record

Updating an Existing
Contract Line Sales Credit
Record

LinePuid
 

The unique PUID that
identifies the contract line
 

This must be a valid
contract line PUID.
 

Required
 

Not required
 

SalesCreditPuid
 

The unique ID that
identifies a sales credit
record
 

This must be a unique PUID
for all sales credit records.
 

Required
 

Required
 

Percent
 

The percent credit obtained
by a sales person
 

This must be less than or
equal to 100%.
 

Required
 

Not required
 

SalesrepId
 

The unique identifier for a
sales person

This must be a valid sales
person.

Required if SalesrepName
isn't entered.

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Line
Sales Credit Record

Updating an Existing
Contract Line Sales Credit
Record

   

SalesrepName
 

The name that identifies
the sales person
 

This must be a valid sales
person.
 

Required if SalesrepId isn't
entered.
 

Not required
 

SalesCreditTypeId
 

The unique identifier for
the sales credit type
 

To manage your sales credit
types:
 

1. In Setup and
Maintenance, go to
the Manage Standard
Lookups task.

2. Search for the Sales
Credit Type lookup.

Required if SalesCreditType
isn't entered
 

Not required
 

SalesCreditType
 

The name that identifies
the sales credit type
 

To manage your sales credit
types:
 

1. In Setup and
Maintenance, go to
the Manage Standard
Lookups task.

2. Search for the Sales
Credit Type lookup.

Required if
SalesCreditTypeId isn't
entered
 

Not required
 

You can view the Contract Line Sales Credit object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Line Sales Credit object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Line Sales Credit

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
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5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the
mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Line Translation Data  
You can use the import functionality to create, update, or delete your contract line translation data.

You can import contract line translation records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the contract line translation data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import contract line translation data into Oracle Applications Cloud from a CSV file containing your source data
that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the contract line translation import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all contract line translation attributes.
However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each
of the contract line translation child objects.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and
source system reference is a unique identifier within the external system. If you're importing new contract line
translation or are updating contract line translation that have source system reference data, then provide the
source system and source system reference values.

Required Attributes and Validations for Contract Line Translation Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for contract line translation records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Line
Translation record

Updating an Existing
Contract Line Translation
record

LinePuid
 

The PUID of the contract
line for which the
translation information is
captured.
 

Must be a valid contract
PUID.
 

Required
 

Required
 

Lang
 

The language in which the
translation is captured.
 

Must be a valid language.
 

Required
 

Required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the contract line
translation object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.
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You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Line Translation object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the contract line translation information. To create
an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Contract Line Translation from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Contract Manual Adjustments Data  
You can use Import Management to create or update Contract Manual Adjustments records.
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To import Contract Manual Adjustments records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Manual Adjustments data into Oracle Applications Cloud, you must populate a .csv file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Contract Manual Adjustments object, the attribute is SequenceNumber.

Required Attributes and Validations for the Contract Manual Adjustments
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Manual Adjustments records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Contract Manual Adjustments import:

329



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Manual Adjustments
Record

Updating an Existing
Contract Manual
Adjustments Record

ExtSource
 

The external source
identifying a manual
adjustment
 

This must be a unique
value across the
Adjustments table.
 

Required
 

Required
 

ExtKey
 

The external key identifying
a manual adjustment
 

This must be a unique
value across the
Adjustments table.
 

Required
 

Required
 

ChargeExtSource
 

The external source of a
charge
 

This must be a valid charge
external source.
 

Required
 

Not required
 

ChargeExtKey
 

The external key of the
charge
 

This must be a valid charge
external key.
 

Required
 

Not required
 

SequenceNumber
 

The sequence number of
the adjustment
 

No validation
 

Not required
 

Not required
 

AdjustmentTypeCode
 

The adjustment type code
 

This must be a valid
adjustment code.
 

A value is required if the
adjustment type isn't
passed.
 

Not required
 

AdjustmentType
 

The adjustment type
 

This must be a valid
adjustment name.
 

A value is required if the
adjustment type code isn't
passed.
 

Not required
 

AdjustmentValue
 

The adjustment value
 

No validation
 

Required
 

Not required
 

ReasonCode
 

The code representing the
reason for the adjustment
 

This must be a valid reason
code.
 

A value is required if the
reason in not passed.
 

Not required
 

Reason
 

The reason for the
adjustment
 

This must be a valid reason
name.
 

A value is required if the
reason code isn't passed.
 

Not required
 

ChargePeriodFrom
 

The charge period from
which the adjustment is
effective
 

This must be within the line
start and end dates.
 

Not required
 

Not required
 

ChargePeriodUntil
 

The charge period until
which the adjustment is
effective
 

This must be within the line
start and end dates.
 

Not required
 

Not required
 

You can view the Contract Manual Adjustments object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Manual Adjustments object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Manual

Adjustments from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Party Data  
You can use Import Management to create or update Contract Party records.
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To import Contract Party records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Party data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Contract Party object, the attributes are Id and Party Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Contract Party object, the
attributes are Party Number, Party Role PUID, and Contract PUID.

Required Attributes and Validations for the Contract Party Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
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Contract Party records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Party
import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Party
Record

Updating an Existing
Contract Party Record

ContractPuid
 

The unique PUID that
identifies the contract.
 

This must be a valid
Contract PUID.
 

Conditionally Required.
Provide a value if Id isn't
provided.
 

Not required
 

Id The unique identifier of the
contract.

This must be a valid
identifier.

Conditionally Required.
Provide a value if
ContractPuid isn't provided.

Not required

PartyRolePuid
 

The unique identifier for
the party record
 

This must be a unique
PUID for all contract party
records.
 

Required
 

Required
 

PartyRoleCode
 

The code that represents a
party role
 

This must be a valid party
role code defined for the
contract type.
 

Required if the Role isn't
entered.
 

Not required
 

Role
 

The name that represents a
party role
 

This must be a valid party
role defined for the contract
type.
 

Required if the
PartyRoleCode isn't
entered.
 

Not required
 

PartyId
 

The unique identifier for a
party
 

This must be a valid party -
HZ_PARTIES.
 

Required if PartyName isn't
entered or if there is more
than one party with the
same party name.
 

Not required
 

PartyName
 

The name that represents a
party
 

This must be a valid and
unique party name -
HZ_PARTIES. If there is
more than one party with
the same party name, then
you must provide PartyId.
 

Required if PartyId isn't
entered
 

Not required
 

You can view the Contract Party object and attributes in the Manage Import Objects page of the Import Management
flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Party object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Party from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Party Contact Data  
You can use Import Management to create or update Contract Party Contact records.

To import Contract Party Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Party Contact data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Contract Party Contact object, the attributes are Id and
Contact Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Contract Party Contact object,
the attribute is Contact PUID.

Required Attributes and Validations for the Contract Party Contact Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Party Contact records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract
Party Contact import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Party
Contact Record

Updating an Existing
Contract Party Contact
Record

PartyRolePuid
 

The unique identifier of the
party record.
 

No validation
 

Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Party
Contact Record

Updating an Existing
Contract Party Contact
Record

ContactPuid
 

The unique identifier of the
party contact record.
 

No validation
 

Required
 

Required
 

ContactRoleCode
 

The role played by the
contact in this contract.
 

OKC_PARTY_CONTACT_
SOURCES.CONTACT_
ROLE_CODE
 

Required if the role isn't
entered
 

Required
 

Role
 

The name of the role played
by the contract in this
contract.
 

No validation
 

Required if
ContactRoleCode isn't
entered
 

Not required
 

ContactId
 

The unique identifier of the
contract party contact.
 

HZ_RELATIONSHIPS
 

Required if
PartyContactName isn't
entered
 

Not required
 

PartyContactName
 

The name of the contract
party contact.
 

Valid name as per HZ_
PARTIES record
 

Required if ContactId isn't
entered
 

Not required
 

OwnerYn
 

Indicates whether the
contact is a contract owner
 

The values must be either
YES or NO.
 

Required
 

Not required
 

AccessLevel
 

The access level of a team
member.
 

This must be one among
FULL, READ, or NO_
ACCESS.
 

Required if
AccessLevelName isn't
entered
 

Not required
 

AccessLevelName
 

The access level of a team
member.
 

This must be one among
Full, Read, or No Access.
 

Required if AccessLevel
isn't entered
 

Not required
 

You can view the Contract Party Contact object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Note:  Prior to the 20B release, the logged in user was getting defaulted as the contract owner for a contract
automatically. From the 20B release, the logged in user won't get defaulted automatically when you import the
contract header. You need to specify the contract owner information in the Contract Party Contact CSV file and import
it.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Party Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Party Contact

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Party Descriptive Flexfield Data  
You can use Import Management to create or update Contract Party Descriptive Flexfield records.

To import Contract Party Descriptive Flexfield records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Contract Party Descriptive Flexfield data into Oracle Applications Cloud, you need to populate a CSV file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

• Ensure that you don't insert duplicate addresses while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new contacts or are
updating contacts that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Contract Party Descriptive Flexfield
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Contract Party
Descriptive Flexfield records, required attributes for updating Contract Party Descriptive Flexfield records, prerequisite
setup tasks for the attributes, and specific validations, if any, for Contract Party Descriptive Flexfield import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Party
Descriptive Flexfield
Record

Updating an Existing
Contract Party Descriptive
Flexfield Record

Id
 

The unique identifier of the
contract party record.
 

This must be a valid
contract party Id.
 

Not required
 

Not required
 

PartyRolePuid
 

The unique PUID that
identifies the contract party
record.

This must be a valid
contract party PUID.
 

Required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Party
Descriptive Flexfield
Record

Updating an Existing
Contract Party Descriptive
Flexfield Record

 

AttributeCategory
 

Attribute category of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute1
 

Attribute 1 of the
descriptive flexfield
 

No validation
 

Required
 

Not required
 

Attribute2
 

Attribute 2 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute3
 

Attribute 3 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute4
 

Attribute 4 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute5
 

Attribute 5 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

You can view the Contract Party Descriptive Flexfield object along with all its child objects and attributes in the Manage
Import Objects page of the Import Management flow. You can find attribute information like type, length, description,
and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Party Descriptive Flexfield object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Party Descriptive

Flexfield from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
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5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Contract Party Contact Descriptive Flexfield
Data  
You can use Import Management to create or update Contract Party Contact Descriptive Flexfield records.

To import Contract Party Contact Descriptive Flexfield records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Contract Party Contact Descriptive Flexfield data into Oracle Applications Cloud, you need to populate a
CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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• Ensure that you don't insert duplicate addresses while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new contacts or are
updating contacts that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Contract Party Contact Descriptive
Flexfield Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Contract Party
Contact Descriptive Flexfield records, required attributes for updating Contract Party Contact Descriptive Flexfield
records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Party Contact Descriptive
Flexfield import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Party
Contact Descriptive
Flexfield Record

Updating an Existing
Contract Party Contact
Descriptive Flexfield
Record

Id
 

The unique identifier of
the contract party contact
record.
 

This must be a valid
contract party contact Id.
 

Not required
 

Not required
 

ContactPuid
 

The unique PUID that
identifies the contract party
contact record.
 

This must be a valid
contract party contact
PUID.
 

Required
 

Required
 

AttributeCategory
 

Attribute category of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute1
 

Attribute 1 of the
descriptive flexfield

No validation
 

Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Party
Contact Descriptive
Flexfield Record

Updating an Existing
Contract Party Contact
Descriptive Flexfield
Record

 

Attribute2
 

Attribute 2 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute3
 

Attribute 3 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute4
 

Attribute 4 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

Attribute5
 

Attribute 5 of the
descriptive flexfield
 

No validation
 

Not required
 

Not required
 

You can view the Contract Party Contact Descriptive Flexfield object along with all its child objects and attributes in
the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length,
description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Party Contact Descriptive Flexfield object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Party Contact

Descriptive Flexfield from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Contract Pricing Terms Data  
You can use Import Management to create or update Contract Pricing Term records.

To import Contract Pricing Term records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Pricing Terms data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

343



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifiers. If you're creating new
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Contract Pricing Terms object, the attributes are Line PUID and Pricing Terms PUID.

Required Attributes and Validations for the Contract Pricing Terms Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Pricing Terms records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract
Pricing Terms import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Pricing Terms Record

Updating an Existing
Contract Pricing Terms
Record

AdjustmentAmount
 

The adjustment amount of
a pricing term
 

No validation
 

Not required
 

Not required
 

AdjustmentType
 

The type of adjustment
 

To manage your
adjustments:
 

1. In Setup and
Maintenance, go to
the Manage Standard
Lookups task.

2. Search for Contract
Price Adjustment
Types lookup.

Required if
AdjustmentTypeCode isn't
entered
 

Not required
 

AdjustmentTypeCode
 

The code that represents
the type of adjustment
 

To manage your
adjustments:
 

1. In Setup and
Maintenance, go to
the Manage Standard
Lookups task.

2. Search for Contract
Price Adjustment
Types lookup.

Required if AdjustmentType
isn't entered
 

Not required
 

AllowCustomAdjustmentsFlag
 

The option to indicate if
custom adjustments are
permitted.
 

The valid values are Yes or
No.
 

Not required
 

Not required
 

LinePuid
 

The PUID of the contract
line
 

This must be a valid line
PUID
 

Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Pricing Terms Record

Updating an Existing
Contract Pricing Terms
Record

ListPrice
 

The list price
 

No validation
 

Not required
 

Not required
 

PricingTermsPuid
 

The PUID of the pricing
term
 

This must be unique across
pricing terms.
 

Required
 

Required
 

You can view the Contract Pricing Terms object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Pricing Terms object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Pricing Terms

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Related Document Data  
You can use Import Management to create or update Contract Related Document records.

To import Contract Related Document records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Related Document data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
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performance and reduces the import duration. For the Contract Related Document object, the attributes are Id,
Contract Id, and Related Contract Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Contract Related Document
object, the attributes are Related Object PUID, Contract PUID, and RelatedContractPUID.

Required Attributes and Validations for the Contract Related Document
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Related Document records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Contract Related Document import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Related Document Record

Updating an Existing
Contract Related
Document Record

RelObjPuid
 

Unique PUID of the related
contract record.
 

No validation
 

Required
 

Required
 

ContractPuid
 

The PUID of the source
contract.
 

This must be a valid source
contract PUID.
 

Required
 

Not required
 

RelatedContractPuid
 

The PUID of the target
contract.
 

This must be a valid target
contract PUID.
 

Required
 

Not required
 

RelationshipCode
 

The code that represents
the relationship between
the two contracts
 

You can manage the
relationships.
 
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage
Contract Relationship
Types

Required if Relationship
isn't entered
 

Not required
 

Relationship
 

The name that represents
the relationship between
the two contracts
 

You can manage the
relationships.
 
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

Required if
RelationshipCode isn't
entered
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract
Related Document Record

Updating an Existing
Contract Related
Document Record

• Functional Area: Data
Import and Export

• Task: Manage
Contract Relationship
Types

You can view the Contract Related Document object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Related Document object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Related

Document from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Contract Sales Credit Data  
You can use Import Management to create or update Contract Sales Credit records.

To import Contract Sales Credit records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Sales Credit data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
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Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Contract Sales Credit object, the attribute is Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Contract Sales Credit object, the
attributes are Sales Credit PUID and Contract PUID.

Required Attributes and Validations for the Contract Sales Credit Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Contract Sales Credit records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract
Sales Credit import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Sales
Credit Record

Updating an Existing
Contract Sales Credit
Record

ContractPuid
 

The unique PUID that
identifies the contract
 

This must be a valid
contract PUID.
 

Required
 

Not required
 

SalesCreditPuid
 

The unique Id that
identifies a sales credit
record
 

This must be a unique PUID
for all sales credit records.
 

Required
 

Required
 

Percent
 

The percent credit obtained
by a sales person
 

This must be less than or
equal to 100%.
 

Required
 

Not required
 

SalesrepId
 

The Id that identifies the
sales person
 

This must be a valid sales
person.
 

Required if the
SalesrepName isn't entered
 

Not required
 

SalesrepName
 

The name that identifies
the sales person
 

This must be a valid sales
person.
 

Required if the SalesrepId
isn't entered
 

Not required
 

SalesCreditTypeId
 

The unique identifier for
the sales credit type
 

To manage your sales credit
types:
 

1. In Setup and
Maintenance, go to
the Manage Standard
Lookups task.

2. Search for the Sales
Credit Type lookup.

Required if SalesCreditType
isn't entered
 

Not required
 

SalesCreditType
 

The name that identifies
the sales credit type
 

To manage your sales credit
types:
 

1. In Setup and
Maintenance, go to
the Manage Standard
Lookups task.

Required if SalesCreditId
isn't entered
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Contract Sales
Credit Record

Updating an Existing
Contract Sales Credit
Record

2. Search for the Sales
Credit Type lookup.

You can view the Contract Sales Credit object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the CSV templates available in the Import Objects UI page to create the source CSV file. To download a CSV
template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Contract Sales Credit object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Sales Credit from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Conversation Data  
You can use Import Management to create, update, or delete Conversation records.

To import Conversation records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Conversation data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

Select a Unique Identifier for Your Records
All records must be unique in the application. If you're creating records, then you can provide an easily understandable
public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes
are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute
to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys
to Import Records" in Related Topics section.

Required Attributes and Validations for Conversation Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Conversation
records, required attributes for updating Conversation records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Conversation import:
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a
Conversation Record

Updating an Existing
Conversation Record

Deleting an Existing
Conversation Record

ConversationId
 

The unique identifier
of the conversation.
 

Must be a valid
ConversationId
when updating a
conversation.
 

Not Required
 

Conditionally
Required. Provide
value if the
ConversationNumber
isn't provided.
 

Conditionally
Required. Provide
value if the
ConversationNumber
isn't provided.
 

ConversationNumber
 

The public unique
identifier of the
conversation.
 

Must be a valid
ConversationNumber
when updating a
conversation.
 

Not Required
 

Conditionally
Required. Provide
value if the
ConversationId isn't
provided.
 

Conditionally
Required. Provide
value if the
ConversationId isn't
provided.
 

StripeCd
 

The application stripe
of the conversation.
 

Must be a valid
application stripe.
Valid values are: ORA_
SVC_CRM, ORA_SVC_
HCM, ORA_SVC_
HRHD, ORA_SVC_ISR
 

Not Required. If not
passed, it will be
defaulted to ORA_
SVC_CRM.
 

Not Required
 

Not Required
 

ConversationStatusCd
 

The status of the
conversation.
 

Must be a valid
conversation status.
Valid values are: ORA_
SVC_OPEN, ORA_SVC_
CLOSED.
 

Not Required. If not
passed, it will be
defaulted to ORA_
SVC_OPEN.
 

Not Required
 

Not Required
 

PrimaryMessageNumber
 

The public unique
identifier of the
primary message in
the conversation.
 

None
 

Not Required
 

Not Required
 

Not Required
 

BUOrgId
 

The identifier of the
business unit.
 

None
 

Not Required
 

Not Required
 

Not Required
 

You can view the Conversation object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Note:  You can pass any attribute with a valid value to create a conversation.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Conversation object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Conversation from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Conversation Message Data  
You can use Import Management to create, update, or delete Conversation Message records.

To import Conversation Message records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Target Object Attributes
To import your Conversation Message data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

Select a Unique Identifier for Your Records
All records must be unique in the application. If you're creating records, then you can provide an easily understandable
public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes
are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute
to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys
to Import Records" in Related Topics section.

Required Attributes and Validations for Conversation Message Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Conversation
Message records, required attributes for updating Conversation Message records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Conversation Message import:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a
Conversation
Message Record

Updating an Existing
Conversation
Message Record

Deleting an Existing
Conversation
Message Record

MessageId
 

The unique identifier
of the conversation
message.
 

Must be a valid
MessagesId
when updating a
conversation message.
 

Not Required
 

Conditionally
Required. Provide
value if the
MessagesNumber isn't
provided.
 

Conditionally
Required. Provide
value if the
MessagesNumber isn't
provided.
 

MessageNumber
 

The public unique
identifier of the
conversation message.
 

Must be a valid
MessagesNumber
when updating a
conversation message.
 

Not Required
 

Conditionally
Required. Provide
value if the
MessagesId isn't
provided.
 

Conditionally
Required. Provide
value if the
MessagesId isn't
provided.
 

355



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a
Conversation
Message Record

Updating an Existing
Conversation
Message Record

Deleting an Existing
Conversation
Message Record

ParentMessageNumber
 

The public unique
identifier of the parent
message.
 

Must be a valid
message number.
 

Only if you want to
create parent-child
relationship between
messages.
 

Not Required
 

Not Required
 

MessageStatusCd
 

The status of the
conversation message.
 

Valid values
are: ORA_SVC_
DRAFT, ORA_SVC_
COMMITTED, ORA_
SVC_CORRECTED.
 

Not Required. If not
passed, it will be
defaulted to ORA_
SVC_COMMITTED.
 

Not Required
 

Not Required
 

MessageTypeCd
 

The type of the
conversation message.
 

Valid values are: ORA_
SVC_INBOUND, ORA_
SVC_OUTBOUND,
 ORA_SVC_NOTE,
 ORA_SVC_SYSTEM_
REPLY, ORA_SVC_
SYSTEM_NOTE, ORA_
SVC_INTERNAL_
COLLABORATION.
 

Required
 

Not Required
 

Not Required
 

MessageContent
 

The content of the
message.
 

It must by passes
in base 64 encoded
value.
 

Required
 

Not Required
 

Not Required
 

InboundStatusCd
 

The status of the
message if the
conversation message
is an inbound
message.
 

Valid values are: ORA_
SVC_NEW, ORA_SVC_
REPLIED.
 

Not Required. If not
passed, it will be
defaulted to ORA_
SVC_NEW.
 

Not Required
 

Not Required
 

You can view the Conversation Message object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Conversation Message object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Conversation Message

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Conversation Message Recipient Data  
You can use Import Management to create, update, or delete Conversation Message Recipient records.

To import Conversation Message Recipient records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Conversation Message Recipient data into Oracle Applications Cloud, you need to populate a CSV file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Identify the target object attributes that are required in the CSV file for a successful import.

• Ensure parent records exist before importing child records.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. If you're creating records, then you can provide an easily understandable
public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes
are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute
to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys
to Import Records" in Related Topics section.

Required Attributes and Validations for Conversation Message Recipient
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Conversation
Message Recipient records, required attributes for updating Conversation Message Recipient records, prerequisite setup
tasks for the attributes, and specific validations, if any, for Conversation Message Recipient import:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a
Conversation
Message Recipient
Record

Updating an Existing
Conversation
Message Recipient
Record

Deleting an Existing
Conversation
Message Recipient
Record

MessagesId
 

The unique identifier
of the message.
 

Must be a valid
Conversation Message
Identifier.
 

Conditionally
Required. Provide
value if the
MessagesNumber isn't
provided.
 

Not Required
 

Not Required
 

MessagesNumber
 

The public unique
identifier of the
message.
 

Must be a valid
Conversation Message
PUID.
 

Conditionally
Required. Provide
value if the
MessagesId isn't
provided.
 

Not Required
 

Not Required
 

RecipientId
 

The unique identifier
of the message
recipient record.
 

Must be a valid
RecipientId when
updating a message
recipient.
 

Not Required
 

Conditionally
Required. Provide
value if the
RecipientNumber isn't
provided.
 

Conditionally
Required. Provide
value if the
RecipientNumber isn't
provided.
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a
Conversation
Message Recipient
Record

Updating an Existing
Conversation
Message Recipient
Record

Deleting an Existing
Conversation
Message Recipient
Record

RecipientNumber
 

The public unique
identifier of the
message recipient
record.
 

Must be a valid
RecipientNumber
when updating a
message recipient.
 

Not Required
 

Conditionally
Required. Provide
value if the RecipientId
isn't provided.
 

Conditionally
Required. Provide
value if the RecipientId
isn't provided.
 

RecipientPartyId
 

The party identifier of
the message recipient.
 

Must be a valid party
identifier.
 

Not Required.
Recommend
to pass one of
RecipientPartyId,
RecipientPartyNumber,
 or FreeFormAddress.
 

Not Required
 

Not Required
 

RecipientPartyNumber
 

The public unique
identifier of the
message recipient.
 

Must be a valid Party
PUID.
 

Not Required.
Recommend
to pass one of
RecipientPartyId,
RecipientPartyNumber,
 or FreeFormAddress.
 

Not Required
 

Not Required
 

RecipientTypeCd
 

The type of the
message recipient,
 such as TO, CC, BCC.
 

Valid values are: ORA_
SVC_BCC, ORA_SVC_
CC, ORA_SVC_FROM,
 ORA_SVC_TO.
 

Not Required. If not
passed, it will be
defaulted to ORA_
SVC_TO.
 

Not Required
 

Not Required
 

FreeFormAddress
 

The free form address
of the recipient such
as email address.
 

None
 

Not Required.
Recommend
to pass one of
RecipientPartyId,
RecipientPartyNumber,
 or FreeFormAddress.
 

Not Required
 

Not Required
 

You can view the Conversation Message Recipient object and its attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Conversation Message Recipient object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Conversation Message

Recipient from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Conversation Reference Data  
You can use Import Management to create, update, or delete Conversation Reference records.

To import Conversation Reference records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Conversation Reference data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Identify the target object attributes that are required in the CSV file for a successful import.

• Ensure parent records exist before importing child records.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• Ensure parent records exist before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. If you're creating records, then you can provide an easily understandable
public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes
are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute
to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys
to Import Records" in Related Topics section.

Required Attributes and Validations for Conversation Reference Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Conversation
Reference records, required attributes for updating Conversation Reference records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Conversation Reference import:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a
Conversation
Reference Record

Updating an Existing
Conversation
Reference Record

Deleting an Existing
Conversation
Reference Record

ReferenceId
 

The unique identifier
of the conversation
reference.
 

Must be a valid
ReferenceId
when updating
a conversation
reference.
 

Not Required
 

Conditionally
Required. Provide
value if the
ReferenceNumber isn't
provided.
 

Conditionally
Required. Provide
value if the
ReferenceNumber isn't
provided.
 

ReferenceNumber
 

The public unique
identifier of the
conversation
reference.
 

Must be a valid
ReferenceNumber
when updating
a conversation
reference.
 

Not Required
 

Conditionally
Required. Provide
value if the
ReferenceId isn't
provided.
 

Conditionally
Required. Provide
value if the
ReferenceId isn't
provided.
 

ObjectTypeCd
 

The object type of the
functional object such
as Service Request,
 Sales Lead, and so on.
 

Valid values are:
ORA_SVC_SERVICE_
REQUESTS, ORA_
SVC_SERVICE_
REQUESTS_HRHD,
 ORA_SVC_SERVICE_
REQUESTS_ISR, ORA_
MKL_LM_LEADS,
 ORA_ZMM_ACTY_

Required
 

Not Required
 

Not Required
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a
Conversation
Reference Record

Updating an Existing
Conversation
Reference Record

Deleting an Existing
Conversation
Reference Record

ACTIVITIES, ORA_
MOO_OPTY, ORA_
HZ_ORGANIZATION_
PROFILES.
 

ObjectId
 

The unique identifier
of the functional
object associated with
the conversation.
 

Must be a valid
function object ID
such as Sales Lead ID,
 Service Request ID,
 and so on.
 

Conditionally
Required. Provide
value if the
ObjectNumber isn't
provided.
 

Not Required
 

Not Required
 

ObjectNumber
 

The public unique
identifier of the
functional object
associated with the
conversation.
 

Must be a valid
function object
number such as SR
PUID, Lead PUID, and
so on.
 

Conditionally
Required. Provide
value if the ObjecId
isn't provided.
 

Not Required
 

Not Required
 

ConversationId
 

The conversation
reference identifier,
 an auto generated
number and primary
key for this table.
 

Must be a valid
ConversationId.
 

Conditionally
Required. Provide
value if the
ConversationNumber
isn't provided.
 

Not Required
 

Not Required
 

ConversationNumber
 

The public unique
identifier of the
conversation
Reference.
 

Must be a valid
conversation PUID.
 

Conditionally
Required. Provide
value if the
ConversationId isn't
provided.
 

Not Required
 

Not Required
 

You can view the Conversation Reference object and its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Conversation Reference object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Conversation Reference

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Country Structure Data  

Import Your Country Structure Data  
You can use Import Management to create Country Structure records. It is recommended you use Import Management
only if you're importing high-volume third-party data.

If you 're importing licensed data from one of our vendors, then you can create the country structure by navigating to
Setup and Maintenance > Manage Geographies Task page.

To import Country Structure records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Target Object Attributes
To import your Country Structure data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Identify the target object attributes that are required in the CSV file for a successful import.

Required Attributes and Validations for Country Structure Object
To import data successfully into Oracle Applications Cloud, your CSV file must include values for the required attributes.
This table lists the required attributes for importing new Country Structure records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Country Structure import:

Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Country Structure
Record

CountryCode
 

The code for the country for which
the country structure is applicable.
 

The GeographyType has to be
"Country" and the LevelNumber
has to be "1" for a country.
 
You can't pass different country
codes when importing a record.
 

Yes
 

GeographyType
 

Geopolitical divisions such as
Country, State, City, and so on.
For example, for US the different
geography types would be State,
 County, City, and Postal Code.
For India, the different geography
types would be State, District,
 City, and Postal Code. For Mexico,
 it would be State, Municipality,
 Locality, and Postal Code.
 

The country has to be present.
 

Yes
 

LevelNumber
 

You need these to create parent-
child relationships between
geography types for your country.
The values can be 1, 2, 3, and so on.
 

To define a country, you must
specify the LevelNumber as 1.
 

Yes
 

You can view the Country Structure object and its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on the Manage
Import Objects page. You can view the list of valid values for country codes in the UI by navigating to the Manage
Geographies task and searching with % as the Country Code value. For more information on Geographies, see Overview
of Geographies, Geographic Entities, and Locations in the Related Topics section.
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Note:  Note the following:
• The import job will fail if you try to load any already existing country structure. Delete the existing country

structure in the UI in Manage Geographies Tasks and import again.

• You can't load additional lower geography structure levels for an existing country structure while importing
geography country structure. You can add additional geography levels in the UI for an existing country
structure in the Manage Geographies task page.

Create the Source CSV File
You include the data that you want to import into Oracle Applications Cloud in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Country Structure object in the table and click Download.

You can now edit the downloaded file and provide values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Country Structure from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Click Validate Data to check the file for unmapped columns or data format issues. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details
of the import activity. Here, you can download and review the successfully imported user data records, the
mapping details used for import activity, and the data file that you provided in CSV format.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

• Overview of Geographies, Geographic Entities, and Locations

• How do I manage geography validation?

Example of Importing Country Structure Data  
You use the country structure of a country to define which geography types are part of the country and how the
geography types are hierarchically related within the country.

For example, you can create geography types called State, City, and Postal Code. Then you can rank the State
geography type as the highest level within the country, the City as the second level, and the Postal Code as the lowest
level within the country structure.

To add a country structure using import management, your source file must contain information about the country to
which the country structure belongs. You can view the list of valid values for country codes in the UI by navigating to
the Manage Geographies task and searching with % as the Country Code value. You also need to specify the level at
which the geography types need to be placed. By default, all countries are at Level 1. You create the country structure
by increasing the level number as you go down the country structure. You place the geography types such as states,
provinces, and so on at Level 2, districts or counties at Level 3, and so on. To add a country structure, your source file
must include the values that let the import process identify the existing records.

Sample Input CSV File
You include the data that you want to import into CX Sales and Fusion Service in a source CSV file. Here is a sample
input CSV file for country as US.

CountryCode LevelNumber GeographyType

US
 

1
 

COUNTRY
 

US
 

2
 

STATE
 

US
 

3
 

COUNTY
 

US
 

4
 

CITY
 

US
 

5
 

POSTAL CODE
 

Here is another input CSV file for importing the country structure for India.

CountryCode LevelNumber GeographyType

IN 1 COUNTRY
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CountryCode LevelNumber GeographyType

   

IN
 

2
 

STATE
 

IN
 

3
 

DISTRICT
 

IN
 

4
 

CITY
 

IN
 

5
 

POSTAL CODE
 

In case you want to import the country structure for Mexico, your input CSV file would look like this:

CountryCode LevelNumber GeographyType

MX
 

1
 

COUNTRY
 

MX
 

2
 

STATE
 

MX
 

3
 

MUNICIPALITY
 

MX
 

4
 

LOCALITY
 

MX
 

5
 

POSTAL CODE
 

In this example, we are importing the Country Structure for US. You must create a source file (CSV) file with the
attributes as shown in this table and import it using Import Management.

Attribute Name Value Description

CountryCode
 

US
 

The code for the country for which the country
structure is applicable.
 

LevelNumber
 

1
 

The level number of the geography in the
hierarchy. For example, Country is at Level 1
(Top level) and State (California) is at Level
2. You need these to create parent-child
relationships between geography types for your
country.
 

GeographyType
 

COUNTRY
 

Geopolitical divisions such as Country, State,
 City, and so on. For example, for US the
different geography types would be State,
 County, City, and Postal Code. For India, the
different geography types would be State,
 District, City, and Postal Code. For Mexico,
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Attribute Name Value Description

 it would be State, Municipality, Locality, and
Postal Code.
 

Create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Country Structure from

the Object drop-down list.

Note:  In the Advanced Options section, the option Enable High-Volume Import is selected by default. This
mode is designed to import millions of records at once.

4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit.

Import Your Deal Product Data  
You can use Import Management to create, update, or delete your deal product data.

To import Deal Product records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Deal Product data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records. For example, when importing the address of
an account, ensure the account exists.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Deal Product object, this attribute is DealProdId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Deal Product object, the
attribute is DealProdNumber.

Review Required Attributes and Validations for Deal Product Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Deal Product records, required attributes for updating
Deal Product records, prerequisite setup tasks for the attributes, and specific validations, if any, for Deal Product import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Deal
Product record

Updating an
Existing Deal
Product record

DealNumber
 

The public unique
identifier value for
the deal.
 

Text
 

30
 

You can obtain
the Deal Number
for an existing
deal registration
from the Deal
Registration work
area.
 

Conditionally
required
 
Provide either
the DealId or the
DealNumber to
identify the deal.
 

Conditionally
required
 
Provide either
the DealId or the
DealNumber to
identify the deal.
 

DealId
 

The unique ID
for the existing
deal record in the
destination table..
 

Number
 

18
 

The deal must
exist.
 

Conditionally
required
 
Provide either
the DealId or the

Conditionally
required
 
Provide either
the DealId or the
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Deal
Product record

Updating an
Existing Deal
Product record

DealNumber to
identify the deal.
 

DealNumber to
identify the deal.
 

DealProdNumber
 

The relationship
between the deal
registration and
the deal product.
 

Text
 

30
 

You can obtain the
DealProductNumber
for an existing
deal registration
product from the
Deal Registration
work area.
 

Required
 

Conditionally
required
 
Provide either
the DealId or the
DealNumber to
identify the deal.
 

ProductGroupNumber
 

The public unique
identifier value
for the deal
registration
product group.
 

  You can obtain
the ItemNumber
for an existing
deal registration
product from the
Deal Registration
work area.
 

Conditionally
required
 
When you
import a new
deal registration
product item (as
opposed to a
product group),
 then you must
provide either the
ProductGroupNumber
or the
ProductGroupId.
 

Conditionally
required
 
When you
import a new
deal registration
product item (as
opposed to a
product group),
 then you must
provide either
ProductGroupNumber
or ProductGroupId
 

DealProdId
 

The unique ID for
the existing deal
product record in
the destination
table.
 

Number
 

18
 

The deal product
must exist.
 

Not required
 

Conditionally
required
 
You must provide
either the
DealProductId
or the
DealProductNumber
to identify the
product.
 

ItemNumber
 

The public unique
identifier value
for the deal
registration
product item.
 

Text
 

30
 

You can obtain
the ItemNumber
for an existing
deal registration
product from the
Deal Registration
work area.
 

Conditionally
required
 
When you
import a new
deal registration
product item (as
opposed to a
product group),
 then you must
provide either the
ItemNumber or the
InventoryItemId.
 

Conditionally
required
 
When you update
deal registration
product item (as
opposed to a
product group),
 then you must
provide either
ItemNumber or
InventoryItemId.
 

InventoryItemId
 

The unique ID for
the existing sales
catalog product

Number
 

18
 

You can
determine the
InventoryItemId
by exporting the

Conditionally
required
 

Conditionally
required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Deal
Product record

Updating an
Existing Deal
Product record

(item) record in the
destination table.
 

Product Group
Products object.
Navigate to the
following in
the Setup and
Maintenance work
area:
 

• Offering:
Sales

• Functional
Area: Data
Import and
Export

• Task:
Schedule
Export
Processes

When you
import a new
deal registration
product item (as
opposed to a
product group),
 then you must
provide either the
ItemNumber or the
InventoryItemId.
 

When you update
deal registration
product item (as
opposed to a
product group),
 then you must
provide either
ItemNumber or
InventoryItemId.
 

ProductGroupId
 

Unique Product
Group ID defined
in sales product
catalog.
 

Number
 

18
 

You can determine
the ProdGroupId
by exporting the
Product Group
Products object.
Navigate to the
following in
the Setup and
Maintenance work
area:
 

• Offering:
Sales

• Functional
Area: Data
Import and
Export

• Task:
Schedule
Export
Processes

Conditionally
required
 
When you
import a new
deal registration
product item (as
opposed to a
product group),
 then you must
provide either the
ItemNumber or the
InventoryItemId.
 

Conditionally
required
 
When you update
deal registration
product item (as
opposed to a
product group),
 then you must
provide either
ItemNumber or
InventoryItemId.
 

UomCode
 

Specifies the Unit
of measure
 

Number
 

None
 

You can determine
the units of
measure. Navigate
to the following
in the Setup and
Maintenance work
area:
 

• Offering:
Financials

• Functional
Area: Items

• Task: Manage
Units of

Conditionally
required
 
A value is required
when you import
a new deal
registration that's
associated with
product (Items).
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Deal
Product record

Updating an
Existing Deal
Product record

Measure
Profiles

RegisteredPrice
 

The value for
the price of the
product item
associated to the
deal registration.
 

Number
 

None
 

You can obtain the
RegisteredPrice
for an existing
deal registration
using the Deal
Registration work
area.
 

Not required
 

Not required
 

InvOrgId
 

The unique ID
for the existing
product item
organization's
record in the
destination table.
 

Number
 

18
 

You can determine
the InvOrgId by
exporting the
Product Group
Products object.
Navigate to the
following in
the Setup and
Maintenance work
area:
 

• Offering:
Sales

• Functional
Area: Data
Import and
Export

• Task:
Schedule
Export
Processes

Conditionally
required
 
A value is required
when you import
a new deal
registration that's
associated with
product (Items).
 

Conditionally
required
 
A value is required
when you update
an existing deal
registration
that's associated
with product
(Items), and you
don't provide
the product's ID
(InventoryItemId).
 

You can view the Deal Product object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Deal Product object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Deal Product from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

Import Your Deal Registration Data  
You can use import management to create or update Deal Registration records.

To import Deal Registration records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Deal Registration data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. Use this option only if you're updating Deal Registrations. You can determine the
internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database
query. Using an internal ID typically provides better performance and reduces the import duration. For the Deal
Registration object, the attribute is DealID.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Deal Registration object, the
attributes are:

◦ AccountPartyNumber

◦ ContactPartyNumber

◦ OwnerPartyNumber

◦ MatchedAccountPartyNumber

◦ MatchedContactPartyNumber

◦ OptyNumber

◦ LeadNumber

◦ PartnerCompanyNumber

◦ ProgramEnrollmentNumber

◦ DealNumber
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Required Attributes and Validations for Deal Registration Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes.
Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Deal
Registration records, required attributes for updating Deal Registration records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Deal Registration import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Deal
Registration Record

Updating an Existing Deal
Registration Record

AccountPartyNumber
 

The public unique identifier
of account party on the
deal registration
 

None
 

Required
 

Not required
 

ContactPartyNumber
 

The public unique identifier
of contact party on the deal
registration
 

None
 

Required
 

Not required
 

OwnerPartyNumber
 

The public unique identifier
of owner party on the deal
registration
 

None
 

Required
 

Not required
 

MatchedAccountPartyNumber
 

The public unique
identifier of the matched
account party on the deal
registration
 

The deal registration
should have the status
"Approved".
 

Not required
 

Not required
 

MatchedContactPartyNumber
 

The public unique
identifier of the matched
contact party on the deal
registration
 

The deal registration
should have the status
"Approved".
 

Not required
 

Not required
 

OptyNumber
 

The public unique identifier
of the opportunity
associated with the deal
registration
 

The deal registration
should have the status
"Approved".
 

Not required
 

Not required
 

LeadNumber
 

The public unique identifier
of the lead associated with
the deal registration.
 

The deal registration
should have an associated
lead.
 

Not required
 

Not required
 

PartnerCompanyNumber
 

The unique identifier of the
partner associated with the
deal registration
 

None
 

Required
 

Not required
 

ProgramEnrollmentNumber
 

The unique identifier
of the partner program
enrollment in the context of
the deal registration
 

The partner associated with
the deal registration should
be enrolled in a program.
 

Not required
 

Not required
 

DealID
 

The unique identifier of the
deal registration.

None
 

Required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Deal
Registration Record

Updating an Existing Deal
Registration Record

 

DealNumber
 

The alternate identifier of
the deal registration.
 

None
 

Required
 

Not required
 

You can view the Deal Registration object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Deal Registration  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Deal Registration from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Deal Resource Data  
You can use the Import Management to create, update, or delete deal resource records.

To import Deal Resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Deal Resource data into Oracle Applications Cloud, you must populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Begin
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
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Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Deal Resource object, this attribute is DealResourceId.

• Public unique identifiers: If you're creating records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Deal Resource object, the
attribute is DealResourceNumber.

Required Attributes and Validations for Deal Resource Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Deal Resource records, required attributes for
updating Deal Resource records, prerequisite setup tasks for the attributes, and specific validations, if any, for Deal
Resource import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Deal
Resource record

Updating an
Existing Deal
Resource record

DealId
 

The unique ID
for the existing
deal record in the
destination table.
 

Number
 

18
 

The deal must
exist.
 

Conditionally
required
 
Provide either
the DealId or the
DealNumber to
identify the deal.
 

Conditionally
required
 
Provide either
the DealId or the
DealNumber to
identify the deal.
 

DealNumber
 

The public unique
identifier value for
the deal.
 

Text
 

30
 

You can obtain
the Deal Number
for an existing
deal registration
from the Deal
Registration work
area.
 

Conditionally
required
 
Provide either
the DealId or the
DealNumber to
identify the deal.
 

Conditionally
required
 
Provide either
the DealId or the
DealNumber to
identify the deal.
 

DealResourceNumber
 

The unique
identifier for
the relationship
between the
resource and the
deal registration.
 

Number
 

18
 

You can obtain the
DealResourceNumber
for an existing
deal registration
product from the
Deal Registration
work area.
 

Required
 

Conditionally
required
 
Provide either the
DealResourceId
or the
DealResourceNumber
to identify the
resource.
 

DealResourceId
 

The unique ID for
the existing deal
product record in
the destination
table.
 

Number
 

18
 

The deal resource
must exist.
 

Not required
 

Conditionally
required
 
You must provide
either the
DealResourceId
or the
DealResourceNumber

378



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Deal
Resource record

Updating an
Existing Deal
Resource record

to identify the
resource.
 

ResourcePartyNumber
 

The public unique
identifier value for
the resource party
record.
 

Number
 

18
 

You can obtain the
ResourcePartyNumber
for a resource
associated with
an existing deal
registration
from the Deal
Registration work
area.
 

Conditionally
required
 
You must provide
one of the
following to
identify the
resource:
 

• ResourcePartyNumber

• ResourcePartyId

• combination
of
ResourcePartyOrigSys
and
ResourcePartyOrigSysRef.

Conditionally
required
 
You must provide
one of the
following to
identify the
resource:
 

• ResourcePartyNumber

• ResourcePartyId

• combination
of
ResourcePartyOrigSys
and
ResourcePartyOrigSysRef.

ResourcePartyId
 

The unique ID for
the existing deal
resource record
in the destination
table.
 

Number
 

18
 

The resource must
exist.
 

Conditionally
required
 
Provide either the
ResourcePartyNumber
or the
ResourcePartyId
to identify the
resource.
 

Conditionally
required
 
Provide either the
ResourcePartyNumber
or the
ResourcePartyId
to identify the
resource.
 

You can view the Deal Resource object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Deal Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Deal Resource from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Eligibility Rule Data  
You can use the Import Management to create or update Eligibility Rule records.

To import Eligibility Rule records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Eligibility Rule data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Eligibility Rule object, this attribute is EligibilityRuleId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Eligibility Rule Item object, the
attributes are ParPGReferenceNumber, ItemNumber, and GeographyCode.

Required Attributes and Validations for Eligibility Rule Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Eligibility Rule records, required attributes for
updating Eligibility Rule records, prerequisite setup tasks for the attributes, and specific validations, if any, for Eligibility
Rule import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Eligibility Rule
Record

Updating an
Existing Eligibility
Rule Record

EligibilityRuleId
 

Autogenerated
Id to update the
record.
 

Long
 

18
 

No validation
 

Not Required
 

Required
 

381



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Eligibility Rule
Record

Updating an
Existing Eligibility
Rule Record

RuleType
 

This can have
only two values -
AVAILABLE and
NOTAVAILABLE.
 

String
 

30
 

No validation
 

Required
 

Not Required
 

StartDate
 

The start date of
the eligibility rule
 

Date Time
 

 The StartDate can't
be greater than the
EndDate
 

Not Required
 

Not Required
 

EndDate
 

The end date of
the eligibility rule
 

Date Time
 

 No validation
 

Not Required
 

Not Required
 

ProductNumber
 

Product number
against which this
eligibility rule is
created or updated
 

String
 

300
 

No validation
 

Required
 

Required
 

ProdGroupId
 

Required if
creating a new
eligibility rule using
the Internal ID
 

Long
 

18
 

No validation
 

Required
 

Not Required
 

ParPGReferenceNumber
 

Required if
creating or
updating an
existing eligibility
rule using the PUID
 

String
 

50
 

No validation
 

Required
 

Required
 

InventoryItemId
 

Required if
creating a new
eligibility rule using
the Internal ID
 

Long
 

18
 

No validation
 

Required
 

Not Required
 

InvOrgId
 

Required if
creating a new
eligibility rule using
the Internal ID
 

Long
 

18
 

No validation
 

Required
 

Not Required
 

GeographyId
 

Required if
creating a new
eligibility rule using
the Internal ID
 

Long
 

18
 

There can't be
more than one
eligibility rule for
the same country.
 

Required
 

Not Required
 

CountryName
 

Specify value to
update the country
for an existing
eligibility rule using
the PUID.
 

String
 

 No validation
 

Not Required
 

Not Required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Eligibility Rule
Record

Updating an
Existing Eligibility
Rule Record

GeographyCode
 

Required if
creating or
updating an
existing eligibility
rule using the
PUID.
 

String
 

 There can't be
more than one
eligibility rule for
the same country.
 

Required
 
To create an
Eligibility Rule for
all the countries,
 specify the
Geography code
value as "ALL".
To create an
Eligibility Rule for
a specific country
(for example,
 USA), specify the
Geography code
value as "US".
 

Required
 
When updating
an Eligibility Rule
with the PUID, if
you update the
Geography Code
from "ALL" to "US",
 specify the value
of Geography
Code as "ALL" in
the import CSV
file. Specify the
value as "United
States" for the
"CountryName"
attribute.
 

You can view the Eligibility Rule object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Eligibility Rule object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Eligibility Rule from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

383



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Geography Data  

How do I import Non-Oracle Licensed geography data?  
You can use Import Management to create Geography data. It's recommended to use import management if you're
importing Non-Oracle Licensed geography data or while loading your own geography from other vendors. You can
also add alternate name or code to existing geographies with import. For more information see Example of Importing
Geography Data.

To import Geography data, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Geography data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Create Country Structure before importing Geography data. For information on how to create Country
Structure, see Import Your Country Structure and Example of Importing Country Structure in Related Topics
Section.

• Identify the target object attributes that are required in the CSV file for a successful import as mentioned in the
table Required Attributes and Validations for the Geography Object below.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data such as creating a
country structure.

Required Attributes and Validations for the Geography Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide values for the attributes. The following table lists the required attributes for importing new Geography
records, prerequisite setup tasks for the attributes, and specific validations, if any, for Geography import:

Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Geography Record

CountryCode
 

The code of the country to which
the geography belongs.
 

This is validated against the
country structure to check if
the structure is defined for this
country.
 

Required
 

PrimaryGeographyName
 

The primary name of the
geography.
 

This is validated against the name
of country if geography type is
'Country' or LevelNumber is 1.
 

Required
 

RecordTypeCode
 

The record type code that
represents the intent of the import
data. The values are:
 

• 0 - indicates the geography
that already exists in the base
table.

• 1 - indicates the intent to
create a new geography.

• 2 - indicates the intent to
add an alternate identifying
name or code to an existing
geography.

No Validation
 

Required
 

LevelNumber
 

The level number of the geography
in the hierarchy. For example,
 Country is at Level 1 and State
(California) is at Level 2.
 

The level should exist in the
country structure.
 

Required
 

SourceID
 

The source ID for the geography,
 along with the parent source ID
is used to identify the geography
parent and child relationship
within the source file data and the
interface table data.
 

None
 
 

Required
 

ParentSourceID
 

The parent source ID for the
geography, along with the
source ID is used to identify the
geography's parent and child

None
 

Required
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Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Geography Record

relationship with records within the
source file data. This should be null
for the country record, as Country
is at the top of the hierarchy.
 

You can view the Geography object and attributes in the Manage Import Objects page of the Import Management flow.
You can find attribute information like type, length, description, and so on, on this Manage Import Objects page.

Note:   Keep a note of the following:

• You can't update geographies via import.

• You can't add alternate names or alternate code of country via import. You can do so only via UI.

• Before adding a new alternate name, make sure that the alternate name does not exist with the same value
for any other geography name.

• You can enable high-volume import for the Geography import object in the Manage Import Objects page.

• PrimaryGeographyCodeType and PrimaryGeographyCode can't be added after PrimaryGeographyName is
created via import. You must create them together. Alternatively, you can add primaryGeographyCodeType
and PrimaryGeographyCode from the UI after the import is complete.

• The attributes ProviderGeoId, ParentProviderGeoId, and ParentGeographyId are currently Not Supported.Create the Source CSV File
You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Geography object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Geography from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
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7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Note:  Geography names aren't translatable and are always displayed in the same language in which they were loaded
irrespective of the language of the signed in user. If you need different options of display, you can use the alternative
names option.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• Import Your Country Structure Data

• How do I import data?

• Example of Importing Country Structure Data

• Example of Importing Geography Data

Example of Importing Geography Data  
This example demonstrates how to import data using Import Management.

In this example, you have a source file containing geography data that you want to import into the application to
make the geography data available for real time address validation and tax purposes. A geography is any region with a
boundary around it, regardless of its size. It might be a state, a country, a city, a county, or a ward.

Summary of the Tasks
You perform the following steps to create an import activity and activate the import:

1. Determine what information is in the source file.
2. Create and schedule the import activity.

Before You Start
1. You use the country structure of a country to define which geography types are part of the country. For more

information about an example of importing a country structure, see the topic "Example of Importing Country
Structure Data".

2. Ensure that Source ID values are unique for each row of data within a single import.
3. Ensure that all the parents of a child geography are included in your data file so that the child geography can be

added. For example, if you originally imported US, CA, and San Francisco, and now you want to import the city
of San Jose in CA, then your data file must include US, CA, and San Jose.
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4. Check that your source data file has the correct values for the geography data that you have already loaded. For
example, if your initial import included the value US for country and CA as state, and in a subsequent import
you have California as a state, then your geography import creates two state records (CA and California) in the
application data, with the US as the country parent.

Determine the Information in the Source File
The source geography data files must include a unique Source ID value for each row of data and Parent Source ID value
for the parent of that row of data. You include the data that you want to import into CX Sales and Fusion Service in a
source CSV file. A sample input CSV file for country as US is shown in this table.

RecordTypeCode PrimaryGeographyNameCountryCode LevelNumber SourceId ParentSourceId LanguageCode

0
 

United States
 

US
 

1
 

1
 

<blank>
 

US
 

1
 

California
 

US
 

2
 

11
 

1
 

US
 

1
 

San Mateo
 

US
 

3
 

111
 

11
 

US
 

1
 

Redwood City
 

US
 

4
 

1111
 

111
 

US
 

1
 

94065
 

US
 

5
 

11111
 

1111
 

US
 

Here is a sample CSV file to import geographies with alternate name and code for country India:

RecordType PrimaryGeographyNameCountryCode LevelNumber SourceId ParentSOurceIdIdentifierType IdentifierSubTypeIdentifierValue

0
 

India
 

IN
 

1
 

1
 

    

1
 

Karnataka
 

IN
 

2
 

2
 

1
 

   

1
 

Bengaluru
 

IN
 

3
 

3
 

2
 

   

2
 

Bengaluru
 

IN
 

3
 

3
 

2
 

NAME
 

Standard_
Name
 

Bangalore
 

1
 

Whitefield
 

IN
 

4
 

4
 

3
 

   

1
 

560066
 

IN
 

5
 

5
 

4
 

   

2
 

560066
 

IN
 

5
 

5
 

4
 

CODE
 

ISO_
COUNTRY_
CODE
 

91
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Note:   Keep a note of the following:

• The hierarchy is modeled in the CSV file using the SourceId and ParentSourceId. The ParentSourceId for the
Country Record (level Number 1) is always null.

• If defining an alternate name (RecordTypeCode = 2) for any level below the country (LevelNumber >1), ensure that
the SourceId and ParentSourceId columns match the values for the original record respectively.

• You can't update geographies via import.

• You can't add alternate names or alternate code of country via import. You can do so only via UI.

• Before adding a new alternate name, make sure that the alternate name doesn't exist with the same value
for any other geography name. You can check the existing values for alternate names in the Manage
Geographies task page under Hierarchy Defined.

• You can find the list of IdentifierSubTypes in Manage Geography Lookups page in the UI.

• PrimaryGeographyCodeType and PrimaryGeographyCode can't be added after PrimaryGeographyName is
created via import. You must create them together. Alternatively, you can add PrimaryGeographyCodeType
and PrimaryGeographyCode from the UI after the import is complete.

You must create a source file (CSV) file with the attributes and import it using import management as shown in this
table.

Attribute Name Value Description

RecordTypeCode
 

1
 

The record type code that represents the intent
of the import data. The values are:
 

• 0 - indicates the geography that already
exists in the base table.

• 1 - indicates the intent to create a new
geography.

• 2 - indicates the intent to add an alternate
identifying name or code to an existing
geography.

PrimaryGeographyName
 

India
 

This is the primary geography name. This
will be marked as the primary name for the
Geography and also displayed in the Manage
Geographies Page.
 

CountryCode
 

IN
 

This indicates the Country Code for the country
for which you're importing data.
 

LevelNumber
 

2
 

The level number of the geography in the
hierarchy. For example, Country is at Level 1 and
State (California) is at Level 2.
 

SourceId
 

2
 

The source ID for the geography, along with
the parent source ID is used to identify the
geography parent and child relationship within
the source file data and the interface table data.
 

389



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Name Value Description

ParentSourceId
 

1
 

The parent source ID for the geography, along
with the source ID is used to identify the
geography's parent and child relationship with
records within the source file data. This should
be null for the country record, as Country is at
the top of the hierarchy.
 

IdentifierType
 

Name
 

The type of the identifier. It can be either Name
or Code.
 

IdentifierSubtype
 

Standard_Name or Standard_Code
 

The IdentifierSubtype can be Standard_Name
or Secondary_Name. The default value is
Standard_Name.
 
The valid Sub Types for Type "CODE" are FIPS_
CODE, GEO_CODE, ISO_COUNTRY_CODE,
 PRIMARY_CITY, or UNKNOWN
 

IdentifierValue
 

Bangalore
 

The value of the identifier.
 

You can create an import activity, enter the import details, and schedule the import.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Geography from the

Object drop-down list.

Note:  In the Advanced Options section, the option Enable High-Volume Import is selected by default. This
mode is designed to import millions of records at once.

4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit.

Import Your Goal Data  
You can use Import Management to create update, or delete Goal records.

To import Goal records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Target Object Attributes
To import your Goal data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map
that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new goals or are updating
goals that have source system reference data, then provide the source system and source system reference
values.

Required Attributes and Validations for Goal Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Goal records,
required attributes for updating Goal records, prerequisite setup tasks for the attributes, and specific validations, if any,
for Goal import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Goal Record Updating an Existing Goal
Record

GoalId
 

The unique identifier of the
goal
 

No validation
 

Not required
 
This is auto generated.
 

Conditionally required
 
Either the GoalId or the
GoalNumber is required.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Goal Record Updating an Existing Goal
Record

OwnerNumber
 

The unique alternate
identifier of the resource
who owns and manages the
goal
 

The resource should exist.
 

Required
 
This is auto defaulted to
creator.
 

Not required
 

KPINumber
 

The unique alternate
identifier of the KPI
selected for the goal
 

The KPI should exist.
 

Required
 
Either the KPIId or the
KPINumber is required.
 

Not required
 

GoalName
 

The name of the goal
 

No validation
 

Required
 

Not required
 

OwnerId
 

The unique identifier of a
valid employee resource
who owns and manages the
goal
 

The resource must exist.
 

Not required
 
This is auto defaulted to
creator.
 

Not required
 

KPIId
 

The unique identifier of the
KPI selected for the goal
 

The KPI record should exist.
 

Either the KPIId or the
KPINumber is required
 

Not required
 

StartDate
 

The start date of the goal
 

The current date and time
or a future date
 

Required
 

Not required
 

EndDate
 

The end date of the contest
 

This must be later than the
start date.
 

Required
 

Not required
 

Frequency
 

The interval of repetition
of the goal such as daily,
 weekly, monthly, and so on
 

This must be a valid
lookup code value from
the lookupType ORA_ZCA_
GOAL_FREQUENCY.
 

Required
 

Not required
 

GoalNumber
 

The unique alternate
identifier for the goal
 

No validation
 

Not required
 
This is auto generated.
 

Conditionally required
 
Either the GoalId or the
GoalNumber is required.
 

You can view the Goal object along with all its child objects and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Goal object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Goal from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Goal Participant Data  
You can use Import Management to create update, or delete Goal Participant records.

To import Goal Participant records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Goal Participant data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new goal participants or
are updating goal participants that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Goal Participant Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Goal Participant
records, required attributes for updating Goal Participant records, prerequisite setup tasks for the attributes, and
specific validations, if any, for Goal Participant import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Goal
Participant Record

Updating an Existing Goal
Participant Record

GoalParticipantId
 

The unique identifier of the
goal participant
 

No validation
 

Not required
 
This is auto generated.
 

Conditionally required
 
A value is required if the
composite key isn't used.
 

ResourceId
 

The unique identifier of the
resource associated with
the goal
 

The resource should exist.
 

Required
 
Either the ResourceId or
the ResourceNumber is
required.

Not required
 
This can be used as a
composite key with the
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Goal
Participant Record

Updating an Existing Goal
Participant Record

 GoalId when the primary
key isn't used
 

ResourceNumber
 

The unique alternate
identifier of the resource
associated with the goal
 

The resource should exist.
 

Required
 
Either the ResourceId or
the ResourceNumber is
required.
 

Not required
 
This can be used as a
composite key with the
GoalNumber when the
primary key isn't used.
 

GoalId
 

The unique identifier of the
goal
 

The goal should exist.
 

Required
 
Either the GoalId or the
GoalNumber is required.
 

Not required
 
This can be used as a
composite key with the
ResourceId when the
primary key isn't used.
 

GoalNumber
 

The unique alternate
identifier for the goal
 

The goal should exist.
 

Required
 
Either the GoalId or the
GoalNumber is required.
 

Conditionally required
 
This can be used as
a composite key with
ResourceNumber when the
primary key isn't used.
 

You can view the Goal Participant object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Goal Participant object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Goal Participant from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
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5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

How do I import hierarchy data?  
You can use the import management to create Hierarchy data.

The hierarchies supported are:

• Customer hierarchy

• Dun and Bradstreet hierarchy

• Trading Community Party hierarchy

To import Hierarchy records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Hierarchy data into Oracle Applications Cloud, you need to populate a CSV file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.
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• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identifying an object record is the Internal ID. If you're identifying a record that
already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique
identifier Attributes with "ID" in the attribute name are typically internal IDs. Use this option only if you're updating
Hierarchies. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by
doing a transactional database query. Using an internal ID typically provides better performance and reduces the import
duration. For the Hierarchy object, the attributes are TreeStructureCode, TreeCode, TreeName, and TreeVersionName.

Required Attributes and Validations for Hierarchy Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Hierarchy records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Hierarchy import:

Attribute Description Data Type Data Length Prerequisite Setup
Task/ Import
Validations

Creating a Hierarchy
Record

TreeStructureCode
 

Unique identifier for a
tree structure.
 

Varchar2
 

30
 

Seeded data needs to
be present.
 

Required
 

TreeCode
 

User defined Identifier
for the tree code.
 

Varchar2
 

30
 

No validation
 

Required
 

TreeName
 

Name of the tree
 

Varchar2
 

80
 

No validation
 

Required
 

TreeVersionName
 

Version Name of the
tree
 

Varchar2
 

80
 

No validation
 

Required
 

LangCode
 

Indicates the code
of the language
into which the
contents of the
translatable columns
are translated.

Varchar2
 

4
 

No validation
 

Required
 

397



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Data Type Data Length Prerequisite Setup
Task/ Import
Validations

Creating a Hierarchy
Record

 

AsofDate
 

The date that's used
to determine the
tree version when
you're updating a tree
version.
 

Date
 

 No validation
 

Optional
 

You can view the Hierarchy object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Note:  You can find TreeStructureCode values from the lookup type PARTY_HIERARCHY_TYPE. FND_TREE_NODE
table holds the nodes of trees. Navigate to Setup and Maintenance > Search Task  > Manage Standard Lookups
and search lookup type as PARTY_HIERARCHY_TYPE. For more information see Account Hierarchy Database Table.

Create the Source CSV File
The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data
you want to import into Oracle Applications Cloud.

You can either create a CSV file on your own or use templates available in preexisting mappings. To download a
template, do the following:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Hierarchy object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. In the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Hierarchy from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.
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Note:  Initiate the Tree Flattening Service manually. Do one of the following:

◦ From the navigator, select Scheduled Processes. In the Schedule New Process dialog, search for
Party Hierarchy Generation and click OK.

◦ From Setup and Maintenance, search and run the Trading Community Party Hierarchy
Generation task.

Review the Import Results
You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

How do I import hierarchy member data?  
You can use the import functionality to create or update Hierarchy Member records.

To import Hierarchy Member records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Hierarchy Member data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Public unique identifiers. If you're creating new
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Hierarchy Member object, the attributes are:

• TreeStructureCode

• TreeCode

• PartyNumber

• ParentPartyNumber

• AsofDate

Required Attributes and Validations for Hierarchy Member Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Hierarchy Member records, required attributes for
updating Hierarchy Member records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Hierarchy Member import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Hierarchy
Member Record

Updating an
Existing Hierarchy
Member Record

TreeStructureCode
 

Unique identifier
for a tree structure.
 

Varchar2
 

30
 

Seeded data needs
to be present.
 

Required
 

Required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Hierarchy
Member Record

Updating an
Existing Hierarchy
Member Record

TreeCode
 

User defined
identifier for the
tree code.
 

Varchar2
 

30
 

No validation
 

Required
 

Required
 

PartySourceSystem
 

Original System Id
for the party.
 

  An account needs
to exist.
 

Required
 

Required
 

PartySourceSystemReference
 

Original System
Reference for the
party.
 

  An account needs
to exist.
 

Required
 

Optional
 

PartyId
 

Unique Id for the
Party.
 

Number
 

18
 

An account needs
to exist.
 

Required
 

Required
 

ParentPartyId
 

Unique Id for the
Parent Party.
 

Number
 

18
 

An account needs
to exist.
 

Required
 

Required
 

ParentPartySourceSystem
 

Original System
Id for the parent
party.
 

Varchar2
 

30
 

An account needs
to exist.
 

Required
 

Optional
 

ParentPartySourceSystemReference
 

Original System
Id for the parent
party.
 

Varchar2
 

240
 

An account needs
to exist.
 

Required
 

Optional
 

LabelShortName
 

Label Name based
on the position in
the tree hierarchy
with respect to the
child.
 

Varchar2
 

80
 

Seeded data has to
exist.
 

Required
 

Optional
 

PartyNumber
 

Unique
identification
number for this
party.
 

Varchar2
 

30
 

An account needs
to exist.
 

Required
 

Optional
 

ParentPartyNumber
 

Unique
identification
number for this
parent party.
 

Varchar2
 

30
 

An account needs
to exist.
 

Required
 

Optional
 

You can view the Hierarchy Member object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.
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Create the Source CSV File
The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data
you want to import into Oracle Applications Cloud.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Hierarchy Member object in the table and click Download.

You must edit the template CSV file and provide valid values for the required attributes. You can attach different types of
files, giving each file a specific description.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Hierarchy Member from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Note:  Initiate the Tree Flattening Service manually. Do one of the following:

◦ From the navigator, select Scheduled Processes. In the Schedule New Process dialog, search for
Party Hierarchy Generation and click OK.

◦ From Setup and Maintenance, search and run the Trading Community Party Hierarchy
Generation task.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
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3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Household Data  
You can use Import Management to create or update Household records.

To import Household records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Household data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Note:  You can't set an attribute value to NULL in optimized import (standard import with the option Enable High-
Volume Import selected). However, when updating a record, you can change an attribute value from NOT NULL to
NULL

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the
internal ID of the record, a system-generated unique identifier Attributes with "ID" in the attribute name are
typically internal IDs. Use this option only if you're updating Households. You can determine the internal ID of
a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using
an internal ID typically provides better performance and reduces the import duration. For the Household object,
the attributes are OwnerPartyId and PartyId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Household object, the attribute
is PartyNumber.

Required Attributes and Validations for Household Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Household records, required attributes for updating
Household records, prerequisite setup tasks for the attributes, and specific validations, if any, for Household import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Household Record

Updating
an Existing
Household Record

SourceSystem
 

The code
representing the
source system for
the household
 

String
 

30
 

Identify the
source system or
configure source
systems either
by using the
Manage Trading
Community Source
System task, or
by importing the
source system
information into
Oracle Applications
Cloud using the
Source System
Reference import
object.
 

Optional
 

Required
 

SourceSystemReferenceValue
 

The reference
number or text
representing the
source system
unique ID for the
household

String
 

240
 

Identify the
source system or
configure source
systems either
by using the
Manage Trading

Optional
 

Required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Household Record

Updating
an Existing
Household Record

 Community Source
System task, or
by importing the
source system
information into
Oracle Applications
Cloud using the
Source System
Reference import
object.
 

PartyNumber
 

The public unique
identifier of the
party.
 

String
 

30
 

Identify the party
number value
by exporting the
Household object.
 

Optional
 

Required
 

PartyId
 

The public unique
identifier of the
party
 

Long
 

18
 

Identify the party
number value
by exporting the
Household object.
 

Optional
 

Required
 

Name
 

The name of the
household
 

String
 

360
 

Identify the
organization name
of the resource by
navigating to the
Resource Directory.
 

Required.
 

Conditionally
required
 

OwnerPartyId
 

Indicates the party
ID of the resource
who's designated
as the owner of the
household
 

Long
 

18
 

None.
 

Conditionally
required.
 

Conditionally
required
 

You can use the profile option ORA_HZ_IMPORT_MULTI_ADDRESS_TYPE to control how address types are entered. By
default this profile option is set to Yes, so you can enter multiple address types, during high-volume import of Account,
Contact, and Household objects . You can disable this profile option to improve the import performance. When you set
this profile option to No, you can enter only a single address type.

You can view the Household object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Household object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Household from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Hub Source System Reference Data  
You can use Import Management to create or update Hub Source System Reference records.

To import Hub Source System Reference records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Hub Source System Reference data into Oracle Applications Cloud, you need to populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

• Ensure that you don't insert duplicate addresses while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new hub source system
reference records or are updating hub source system reference records that have source system reference data,
then provide the source system and source system reference values.

Required Attributes and Validations for Hub Source System Reference
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Hub Source
System Reference records, required attributes for updating Hub Source System Reference records, prerequisite setup
tasks for the attributes, and specific validations, if any, for Hub Source System Reference import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Hub Source
System Reference Record

Updating an Existing Hub
Source System Reference
Record

OwnerEntityId
 

Internal identifier or
primary key of a record that
exists in the OSC table
 

If provided, it has to be
an active primary key
value from the table
name provided for the
OwnerEntityObject.
 

If you export data from
the OSC table provided for
the OwnerEntityObject,
 provide the primary key
data to this attribute. If
you can't provide this
data, provide valid values

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Hub Source
System Reference Record

Updating an Existing Hub
Source System Reference
Record

for the combination of
ExistingSourceSystem and
ExistingSourceSystemReferenceValue.
 

StartDateActive
 

The date on which the hub
source system reference
becomes valid.
 

If provided, this date should
be earlier than the end
date. If you don't specify
a date, this defaults to the
current date.
 

Optional
 

Optional
 

EndDateActive
 

The date on which the hub
source system reference is
no longer valid.
 

If provided, this date should
be later than the start date.
If you don't specify a date,
 this defaults to 12/31/4712.
 

Optional
 

Optional
 

SourceSystem
 

Specifies the original
source system name
 

This has to be present in
the HZ_ORIG_SYSTEMS_B
table with the status "A".
 

Provide a valid value.
 

Conditionally required.
 
Provide one of the
following:
 

• SourceSystemReferenceId

• A combination of
SourceSystem,
SourceSystemReference
and
OwnerEntityObject

SourceSystemReferenceValue
 

Specifies the original
source system reference
text or number in the
original source system
 

No validation
 

Provide a valid value.
 

Conditionally required.
 
Provide one of the
following:
 

• SourceSystemReferenceId

• A combination of
SourceSystem,
SourceSystemReference
and
OwnerEntityObject

OwnerEntityObject
 

Specifies the OSC table in
which the record exists
 

This has to be a valid
lookup code in the lookup
type ORA_ZCH_OWNER_
ENTITY_OBJECT.
 

Provide a valid value.
 

Conditionally required.
 
Provide one of the
following:
 

• SourceSystemReferenceId

• A combination of
SourceSystem,
SourceSystemReference
and
OwnerEntityObject

SourceSystemReferenceId
 

Specifies the source system
reference identifier. This is
a primary key.

If provided, this has to be
an active primary key value

Not required
 

Conditionally required.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Hub Source
System Reference Record

Updating an Existing Hub
Source System Reference
Record

 from the table HZ_ORIG_
SYS_REFERENCES.
 

Provide one of the
following:
 

• SourceSystemReferenceId

• A combination of
SourceSystem,
SourceSystemReference
and
OwnerEntityObject

ExistingSourceSystem
 

Specifies the original
source system name of
data that exists in Oracle
Engagement Cloud
 

This has to be present in
the HZ_ORIG_SYSTEMS_B
table with status "A".
 

If you can't provide
the OwnerEntityID,
 provide a combination of
ExistingSourceSystem and
ExistingSourceSystemReferenceValue
values. Export the
Source System Reference
repository to obtain this
value.
 

Not required
 

ExistingSourceSystemReferenceValue
 

Specifies the original
source system reference of
data that exists in Oracle
Engagement Cloud
 

No validation
 

If you can't provide
the OwnerEntityID,
 provide a combination of
ExistingSourceSystem and
ExistingSourceSystemReferenceValue
values. Export the
Source System Reference
repository to obtain this
value.
 

Not required
 

You can view the Hub Source System Reference object along with all its child objects and attributes in the Manage
Import Objects page of the Import Management flow. You can find attribute information like type, length, description,
and so on, on this page.

Note:  A lookup type ORA_ZCH_OWNER_ENTITY_OBJECT is now available. You can now use this lookup without
specifying the underlying physical tables, when providing input data in the CSV import file. When you migrate from
File-Based Data Import to Optimized or Import Management, the underlying physical tables are secured to external
parties.

Create the Source CSV File
You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Hub Source System Reference object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Hub Source System

Reference from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

How do I import incentive compensation participants?  
You can use the import management functionality to create or update Incentive Compensation Participants. You can
specify the exact parties you want to import as participants.

You can import Incentive Participants using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Target Object Attributes
You import Incentive Participants into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Incentive Participants import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Incentive Participants while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for Incentive Participants Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Incentive Participants, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Incentive
Participant

Updating an Existing
Incentive Participant

PartyNumber
 

The party number of the
participant. This is used to
find the party that's to be
imported as a participant.
 

The PartyNumber must
match an existing party.
 

Required
 

Required
 

Business Unit
 

Unique numeric identifier
for the Oracle Fusion
Incentive Compensation
business unit
 

The business unit should
be valid.
 

Required
 

Not Required
 

Type
 

Indicates whether the
participant is an Analyst
or Participant. Analysts
administer and manage the
application. Participants
are individuals who can
receive compensation or
sales credits inside the
application.
 

The valid values are
ANALYST or PARTICIPANT.
 

Required
 

Not required for update.
This field can't be updated
or changed after the
participant is created.
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Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Incentive
Participants object. The page also lists attribute information like type, length, description, and so on.

Note:   You can't update participant detail records through import after the initial creation. You can update them by
creating a new import, via the UI, or through a REST call.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Incentive Participants object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Incentive Participants information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Incentive Participants.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Incentive Participants from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Incentive Participants.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel
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Import Your Incentive Compensation Performance
Measure Data  
You can use Import Management to create and update Incentive Compensation Performance Measure records.

To import incentive compensation performance measure records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import activity.

How You Map Your Source Data to Target Object Attributes
You import incentive compensation performance measure data into Oracle Applications Cloud from a CSV file
containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Incentive Compensation
Performance Measure Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Incentive
Compensation Performance Measure records, required attributes for updating Performance Measure records,
prerequisite setup tasks for the attributes, and specific validations, if any, for Incentive Compensation Performance
Measure import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Incentive
Compensation
Performance Measure
record

Updating an Existing
Incentive Compensation
Performance Measure
record

Name
 

The name of the
performance measure.
 

None
 

Required
 

Not Required
 

PerformanceMeasureId
 

The unique identifier of
the performance measure
generated internally.
 

None
 

Not Required
 

Required
 

OrgId
 

The unique ID of the
business unit to which
the performance measure
belongs.
 

None
 

Required
 

Required
 

StartDate The date on which the
performance measure
becomes active.

Must be a valid date. Requried Not Required

EndDate The date on which the
performance measure
becomes inactive.

Must be a valid date. Required Not Required

MeasureFormulaExpressionNameThe name of the expression
used in measure formula
to calculate output of the
performance measure.

None Conditionally Required.
Provide a value if
MeasureFormulaExpressionId
isn’t entered.

Not Required

MeasureFormulaExpressionIdThe unique identifier
for the measure formula
expression for this
performance measure.

None Conditionally Required.
Provide a value if
MeasureFormulaExpressionName
isn’t entered.

Not Required

Description The description of the
performance measure.

None Required Not Required

UnitOfMeasure The standardized quantity
used as a factor to express
occurring quantities of
the performance measure
property.

Possible values include
AMOUNT, PERCENT,
 QUANTITY, and SCORE.
The default value is
AMOUNT. A list of
acceptable values is
defined in the lookup CN_
MEASURE_UOM.

Not Required Not Required

NumberOfDimensions The number of dimensions
of the score card used in
the performance measure.

None Not Required Not Required

UseExternalFormulaFlag Indicates whether the
performance measure uses
an external formula from an
external package.

Possible values include
FALSE and TRUE. The
default value is FALSE. A
list of acceptable values
is defined in the lookup
CN_YES_NO. Review and
update the value for this
attribute using the Setup
and Maintenance, Manage

Not Required Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Incentive
Compensation
Performance Measure
record

Updating an Existing
Incentive Compensation
Performance Measure
record

Incentive Compensation
Lookups task.

ExternalFormulaName The name of the external
formula. This should
be passed only if the
UseExternalFormulaFlag is
true.

None Not Required Not Required

IncludeInParticipantReportsFlagIndicates whether to display
the measure attainment in
all views and reports.

Possible values include
FALSE and TRUE.

Not Required Not Required

RunningTotalFlag Indicates whether to
accumulate a calculation
input, such as credit
amount or credit quantity,
 over a period.

The default value is N so
you need to explicitly pass
Y if processing transaction
is set as GROUP. Possible
values include FALSE
and TRUE. The default
value is FALSE. This
attribute is not applicable
if ProcessTransactions is
GROUP.

Not Required Not Required

SplitOption Specifies how to split the
input number to a score
card dimension.

Possible values include
NONE to apply a single rate
for the entire attainment,
 NON_PROPORTIONAL
to apply multiple rates,
 which are fixed for an
attainment within a tier,
 and PROPORTIONAL to
apply multiple rates, which
are proportional for an
attainment within a tier.
The default value is NONE.
A list of acceptable values is
defined in the lookup CN_
SPLIT_TYPE_OPTION.

Not Required Not Required

ProcessTransactions Indicates how the
application processes
transactions individually or
in a group in a measure.

The possible values
include GROUP for group
transactions for the
specified interval, for
attainment calculation
(when selecting GROUP,
 pass Accumulation Flag
as Y), and INDIVIDUAL to
evaluate each transaction
independently, for
attainment calculation.
So each transaction is
considered independently.
This can’t be updated once
performance measure
has been created. A list
of acceptable values is
defined in the lookup CN_
PROCESS_TXN.

Not Required Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Incentive
Compensation
Performance Measure
record

Updating an Existing
Incentive Compensation
Performance Measure
record

PerformanceInterval The interval value that the
performance is measured
for. Also, for running total,
 the accumulated value is
reset based on this interval
value. Interval would
represent a unit of time like
month, quarter, year.

The default value is '-1000'.
To get this value, describe
the resource and use the
finder listed to get all
possible values.

Not Required Not Required

DisplayName The name of the
performance measure
displayed on the user
interface to represent the
performance measure.

None Not Required Not Required

You can view the Performance Measure object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Incentive Compensation Performance Measure object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Performance Measure information. To create
an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Incentive Compensation

Performance Measure from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Incentive Compensation Rate Table Rates
Data  
You can use the import management functionality to update Incentive Compensation Rate Table Rates.

You can specify the exact parties you want to import as participants. You can also use import specifically for
individualized rates. Individualized rates are used when each participant has different rates based on their achievement.
Based on Plan Components and participant plan assignments individualization can be enabled.

Note:  The individualization must be enabled prior to importing individualized rate table rates.

You can import Incentive Compensation Rate Table Rates using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
You import Incentive Compensation Rate Table Rates into Oracle Applications Cloud from a CSV file containing your
source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Incentive Participants import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.
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• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Incentive Participants while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for Incentive Compensation Rate Table
Rates Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Incentive Compensation Rate Table Rates, prerequisite setup tasks and specific
validations, if any.

Note:  To load rates at the plan component level, you must specify the measure name as 
planComponentName_IncFrm . The addition of  _IncFrm  is to differentiate the record loading between measure level
and plan component level.

Attribute Description Prerequisite Setup Task/ Import
Validations

Updating an Incentive
Compensation Rate Table Rate

BusinessUnit The unique numeric identifier
for the Oracle Fusion Incentive
Compensation business unit.

None Conditionally Required. Provide a
value if OrgId isn’t provided.

OrgId The unique identifier of the
organization.

The business unit should be valid. Conditionally Required. Provide a
value if BusinessUnit isn’t provided.

ParticipantName The name of the participant. Must match unique participant in
business unit. If it isn’t unique then
provide additional identifiers.

Conditionally Required. Provide
a value if PartyNumber or
ParticipantId isn’t provided.

ParticipantId The unique identifier of the
participant.

None Conditionally Required. Provide
a value if ParticipantName isn’t
provided.

PartyNumber The alternate unique identifier of
the party.

The PartyNumber must match a
participant for the given BU.

Conditionally Required. Provide
a value if ParticipantName isn’t
provided.

CompPlanName The name of the compensation
plan.

Must be a valid compensation
plan that is assigned to a specified
participant.

Conditionally Required. Provide a
value if CompPlanId isn’t provided.

PlanAssignStartDate The date when the plan
assignment starts.

Must match start dates of an
existing plan assignment for
specified participant

Conditionally Required. Provide a
value if you're setting the rates for
a specific plan assignment. Also
required if someone is assigned to
the same plan at different times.
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Attribute Description Prerequisite Setup Task/ Import
Validations

Updating an Incentive
Compensation Rate Table Rate

PlanAssignEndDate The date when the plan
assignment ends.

Must match end dates of an
existing plan assignment for
specified participant

Conditionally Required. Provide a
value if you're setting the rates for
a specific plan assignment. Also
required if someone is assigned to
the same plan at different times.

PlanComponentName The name of the plan component. Must be a valid plan component
with individualization set to All or
Rates

Conditionally Required. Provide
a value if PlanComponentId isn’t
provided.

RateTableName The name of the rate table. None Required

RateTableStartDate The date when the rate table starts. None Conditionally Required. Provide
a value if multiple rate tables
are assigned to the same plan
component or performance
measure.

RateTableEndDate The date when the rate table ends. None Conditionally Required. Provide
a value if multiple rate tables
are assigned to the same plan
component or performance
measure.

RateValue The value of the rate. None Required

Dim1Name The dimension name. None Required

Dim1Tier The dimension tier None Required

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Incentive Compensation
Rate Table Rates object. The page also lists attribute information like type, length, description, and so on.

Note:
• The import won’t make changes to non-individualized rate table rates that are established when setting up

plans.

• When configuring compensation plans, multiple rate tables can be added to a plan component or performance
measure using effective dates. When multiple rate tables are associated in this way, values must be included for
Rate Table Start and End Dates to specify which set of rates are to be adjusted.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Incentive Compensation Rate Table Rates object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the Incentive Participants information. To create an
import activity:

1. Go to Navigator > Tools > Import Management > Import Incentive Participants.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Incentive Compensation Rate Table Rates from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator > Tools > Import Management > Incentive Compensation Rate Table Rates.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Incentive Participant Goal Data  
You can use Import Management to update Incentive Participant Goal records.

To import Incentive Participant Goal records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Incentive Participant Goal data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

Required Attributes and Validations for Incentive Participant Goal Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for updating Incentive Participant
Goal records, prerequisite setup tasks for the attributes, and specific validations, if any, for Incentive Participant Goal
import.

Note:  To load rates at the plan component level, you must specify the measure name as 
planComponentName_IncFrm . The addition of  _IncFrm  is to differentiate the record loading between measure level
and plan component level.

Required Attributes and Validations for Incentive Participant Goal Object

Attribute Description Prerequisite Setup Task/ Import
Validations

Updating an Existing Participant
Goal Record

ParticipantName This is the full name of the
participant as stored in HZ_Parties.

Must match unique participant
in business unit. If not unique
additional identifiers can be
provided.

Required.
If duplicate participant names are
found in the Business Unit, you will
need to provide Party Number or
Participant Identifier to uniquely
identify the participant.
 

BusinessUnit The name of the Oracle Incentive
Compensation business unit.

None Required unless OrgID is provided.

OrgId The unique numeric identifier
for the Oracle Fusion Incentive
Compensation business unit.

A valid OrgId. Required unless BusinessUnit is
provided.

ParticipantId The unique identifier of the
participant.

None Provide value to uniquely identify
participant.

PartyNumber The unique alternate identifier for
the participant.

The PartyNumber must match a
participant for the given BU.

Conditionally Required. Provide
value to uniquely identify
participant.

EmailAddress The email address associated with
the participant.

None Conditionally Required. Provide
value to uniquely identify
participant.

HrPersonNumber Typically the HR person number of
the participant.

None Conditionally Required. Provide
value to uniquely identify
participant.
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Attribute Description Prerequisite Setup Task/ Import
Validations

Updating an Existing Participant
Goal Record

MeasureName The name of the performance
measure for which goals are being
assigned.

Must match a performance
measure in BU and be assigned to
specified participant.

Required unless FormulaID
provided.

StartDate Start date of the period for which
the goals are being updated.

Must match start date of valid
calendar period.

Required unless Period provided.

EndDate End date of the period for which
the goals are being updated.

Must match end date of valid
calendar period.

Required unless Period provided.

PeriodName The name of the calendar period
for which goals are being updated.

Must be a valid period in calendar
for specified business unit.

Required unless Start & End Date
are provided.

Target The period target the user wishes
to set for the participant.

None Required

UpdateAllOccurences Indicates if specified goal value
should be updated for all plans
and plan components where the
performance measure is used.

Valid values are Y, N, or left blank. Optional. Defaulted to N if left
blank.

EnforceAssignment Indicates if goal updates should be
restricted only to periods for which
the participant was assigned to a
specific compensation plan.

Valid values are Y, N, or left blank. Optional. Defaulted to Y if left
blank.

PlanName Name of the specific compensation
plan where the goal is being
updated.

None Optional. Required when
UpdateAllOccurrences is set to N
and unless plan ID is provided.

ComPlanId Unique numeric identifier of the
compensation plan where the goal
is being updated.

None Optional

CompPlanName Name of the specific plan
component where the goal is being
updated.

None Conditionally Required.
Required when
UpdateAllOccurrences is set to N or
Plan Component ID isn't provided.
 

PlanComponentId Unique numeric identifier of the
plan component where the goal is
being updated.

None Optional

FormulaId Unique numeric identifier of the
performance measure for which
goals are being updated.

Must match a performance
measure in BU and be assigned to
specified participant.

Optional

You can view the Incentive Participant Goal object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.
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Note:
• Goals are set at the performance measure level for a specific period and participant. Sometimes, performance

measures are reused in different plan components and plans. When setting goals you have the option to set
different goals for a performance measure based on the associated plan or plan component. When using
Update All Occurrences with the value Y, the goal will be loaded for all instances of where the performance
measure is used for that participant. If it is set to N, you can specify the specific plan or plan component you
wish to assign the goal to.

• The Enforce Assignment attribute can be set to Y or N. If left blank it will default to Y.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Participant Goal object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Incentive Participant Goal

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

423



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

How do I import incentive participant role assignments
data?  
You can use Import Management to create or update Incentive Participant Role Assignments.

To import Incentive Participant Role Assignments records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import activity.

How You Map Your Source Data to Target Object Attributes
You import Participant Role Assignments data into Oracle Applications Cloud from a CSV file containing your source
data that's mapped to target Oracle Applications Cloud object attributes.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Incentive Participant Role
Assignments Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.
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This table lists the required attributes for Incentive Participant Role Assignments, prerequisite setup tasks and specific
validations, if any

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Incentive
Participant Role
Assignment record

Updating an Incentive
Participant Role
Assignment record

ParticipantRoleId
 

The unique identifier of the
participant role assignment.
 

None
 

Not Required
 

Required

ParticipantId
 

The unique identifier of a
specific participant.
 

It must be a valid
participant identifier.
 

Required
 

Conditionally Required.
Provide a value if
ParticipantRoleId isn't
provided.

RoleId
 

The unique identifier of the
role to which the participant
is being assigned.
 

It must be a valid role
identifier.
 

Required
 

Not Required

RoleStartDate Effective start date of the
role assignment.

None Required Conditionally Required.
Provide a value if you want
to change the start date.
 

RoleEndDate The end date of the role
assignment.

None Optional. Null signifies
open end date.
 

Optional. Null signifies
open end date.
 

AccessType This indicates whether the
role is a Manager role or
Member role.

None Not Required Not Required

PreserveAssignment Preserve the changes
done to the participant
role assignment and
prevent the automatic role
assignment from updating
or deleting this assignment.
 

None Not Required. Default value
is Yes.

Not Required

You can view the Incentive Participant Role Assignments object with its attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Incentive Participant Role Assignments object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the Participant Role Assignments information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Incentive Participant Role

Assignments from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Incentive Rule Assignment Data  
You can use the import functionality to create, update, or delete Incentive Rule Assignment records.

You can import Incentive Rule Assignment records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Incentive Rule Assignment data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Incentive Rule Assignment data into Oracle Applications Cloud from a CSV file containing your source data
that's mapped to target Oracle Applications Cloud object attributes.

426



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Incentive Rule Assignment import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Incentive Rule Assignments while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Incentive Rule Assignment
attributes.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use the public unique identifier to identify records. If you're
creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted
with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're
updating a record with a Number attribute, then use the Number attribute to identify the record. For more information
about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

Required Attributes and Validations for Incentive Rule Assignment Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Incentive Rule Assignment records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating an Incentive
Rule Assignment
record

Updating an Existing
Incentive Rule
Assignment record

Deleting an Existing
Incentive Rule
Assignment record

RuleNumber
 

PUID of the rule
 

The RuleNumber
should exist.
 

A value is required
if the Name isn't
provided.
 

A value is required
if the Name isn't
provided.
 

A value is required
if the Name isn't
provided.
 

Name
 

Name of the rule
 

The Rule name should
exist.
 

A value is required if
the RuleNumber isn't
provided.
 

A value is required if
the RuleNumber isn't
provided.
 

A value is required if
the RuleNumber isn't
provided.
 

AssignedObjectType
 

The type of the object
assigned to the rule.
 

A value is required
only when importing
credit rules. Values
can be INDIVIDUAL

Optional
 

Optional
 

Optional
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating an Incentive
Rule Assignment
record

Updating an Existing
Incentive Rule
Assignment record

Deleting an Existing
Incentive Rule
Assignment record

or PARTICIPANT_ON_
TXN.
 

AssignedObjectId
 

The unique internal
identifier of the object
being assigned to the
rule.
 

• For credit, rollup
and team rules,
 the object is
participant.

• For classification
rules, the object
is credit category.

• For Participant
assignment rules,
 the object is role.

• For analyst
hierarchy, the
object is analyst.

This is validated
against the
corresponding object
depending on the type
of rule assignment
being imported.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

When the object
is a participant,
 provide one among
EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, or
PartyNumber.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

When the object
is a participant,
 provide one among
EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, or
PartyNumber.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

When the object
is a participant,
 provide one among
EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, or
PartyNumber.
 

AssignedObjectName
 

The name of the
object being assigned
to the rule.
 

• For credit, rollup
and team rules,
 the object is
participant.

• For classification
rules, the object
is credit category.

• For Participant
assignment rules,
 the object is role.

• For analyst
hierarchy, the
object is analyst.

This validated against
the corresponding
object depending
on the type of rule
assignment being
imported.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

When the object
is a participant,
 provide one among
EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, or
PartyNumber.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

When the object
is a participant,
 provide one among
EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, or
PartyNumber.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

When the object
is a participant,
 provide one among
EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, or
PartyNumber.
 

EmailAddress
 

The Email address
of the participant.
This is applicable only
when the object is a
participant.
 

This is validated
against the
participant's email
address.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating an Incentive
Rule Assignment
record

Updating an Existing
Incentive Rule
Assignment record

Deleting an Existing
Incentive Rule
Assignment record

EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, and
PartyNumber are only
valid for participants.
 

EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, and
PartyNumber are only
valid for participants.
 

EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, and
PartyNumber are only
valid for participants.
 

HrPrimaryWorkerNumber
 

The Worker Number
of the participant.
This is applicable only
when the object is a
participant.
 

This is validated
against the worker
number of the
participant.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, and
PartyNumber are only
valid for participants.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, and
PartyNumber are only
valid for participants.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, and
PartyNumber are only
valid for participants.
 

HrPersonNumber
 

The Person Number
of the participant.
This is applicable only
when the object is a
participant.
 

This is validated
against the person
number of the
participant.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

When the object
is a participant,
 provide one among
EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, or
PartyNumber.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

When the object
is a participant,
 provide one among
EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, or
PartyNumber.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

When the object
is a participant,
 provide one among
EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, or
PartyNumber.
 

PartyNumber
 

The Party Number
of the participant.
This is applicable only
when the object is a
participant.
 

This is validated
against the party
number of the
participant.
 

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber

Provide one of the
following :
 

• AssignedObjectId

• AssignedObjectName

• EmailAddress

• HrPrimaryWorkerNumber

• HrPersonNumber

• PartyNumber
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating an Incentive
Rule Assignment
record

Updating an Existing
Incentive Rule
Assignment record

Deleting an Existing
Incentive Rule
Assignment record

EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, and
PartyNumber are only
valid for participants.
 

EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, and
PartyNumber are only
valid for participants.
 

EmailAddress,
HrPrimaryWorkerNumber,
 HrPersonNumber, and
PartyNumber are only
valid for participants.
 

StartDate
 

The start date of
the rule assignment,
 if applicable to the
object.
 

None
 

Required
 

Required
 

Required
 

EndDate
 

The end date of the
rule assignment,
 if applicable to the
object.
 

None
 

Optional
 

Optional
 

Optional
 

SplitPct
 

The percentage split
applicable to the
participant assigned to
the credit rule.
 

None
 

Required for credit
rules
 

Optional
 

Optional
 

RevenueType
 

The revenue type
applicable to the
participant assigned
to the credit or rollup
rule.
 

The valid values
are the lookup
codes setup for
lookup type CN_RS_
REVENUE_TYPE. This
is applicable only to
credit and rollup rules.
 

Required for credit and
rollup rules.
 

Optional
 

Optional
 

RollupFlag
 

Option to determine
if direct credit should
be rolled up to every
individual on parent
rules. This is applicable
only to credit rules.
 

The valid values are Y
and N.
 

Required for credit
rules
 

Optional
 

Optional
 

SummaryFlag
 

Option to determine
if credits should be
summarized. This is
applicable to direct
credit and rollup rules.
 

The valid values are Y
and N.
 

Required for credit and
rollup rules.
 

Optional
 

Optional
 

GroupMemberCreditFlag
 

Option to determine
if the member gets
credit from any direct
credit receivers in
group or child groups.
This is applicable to
rollup rules.
 

The valid values are Y
and N.
 

Required for rollup
and hierarchy analyst
rules
 

Optional
 

Optional
 

RuleAssignmentId
 

The unique internal
identifier of the Rule
Assignment record.

This validates against
the Rule Assignment
table when you update

Leave this blank.
 

Optional
 

Optional
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating an Incentive
Rule Assignment
record

Updating an Existing
Incentive Rule
Assignment record

Deleting an Existing
Incentive Rule
Assignment record

 and delete incentive
rule assignment
records.
 

ActionCode
 

Indicates explicitly
the operation to be
performed on a row:
 

• INSERT to create
a new record in
the destination
tables

• UPDATE to
update an
existing record in
the destination
table

• DELETE to delete
the record.

The value can be
blank, UPDATE, or
DELETE.
 

Optional
 
Leave this blank.
 

Required
 
Enter the value as
UPDATE.
 

Required
 
Enter the value as
DELETE.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Incentive Rule
Assignment object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Incentive Rule Assignment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Incentive Rule Assignment information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Incentive Rule Assignment.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Incentive Rule Assignment from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
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7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Incentive Rule Assignment.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Incentive Rule Attribute Values Data  
You can use the import functionality to create or delete Incentive Rule Attribute Value records.

You can import Incentive Rule Attribute Value records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Incentive Rule Attribute Value data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Incentive Rule Attribute Value data into Oracle Applications Cloud from a CSV file containing your source
data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Incentive Rule Attribute Values import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Incentive Rule Attribute Values while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Incentive Rule Attribute Values
attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files,
one for each of the Incentive Rule Attribute Value child objects. Note that you must have imported the CSV file for
Incentive Rule Attribute Values object successfully before trying to import the CSV files for the child objects. There are
separate help topics describing how to import each of these child objects.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for Incentive Rule Attribute Values
Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Incentive Rule Attribute Value records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Incentive Rule
Attribute Value record

Deleting an Existing
Incentive Rule Attribute
Value record

RuleNumber
 

PUID of the rule
 

The rule number should
exist.
 

A value is required, if the
Name isn't provided.
 

A value is required, if the
Name isn't provided.
 

Name
 

Name of the rule
 

The rule name should exist.
 

A value is required if the
RuleNumber isn't provided.
 

A value is required if the
RuleNumber isn't provided.
 

AttributeName
 

Name of the qualifier
 

The attribute should have
been setup as a qualifier
in the Manage Custom
Qualifier setup task.
 

Required
 

Required
 

OperatorName
 

Name of the operator
 

This is validated for
operators that are enabled
while setting up the
attribute as a qualifier
in the Manage Custom
Qualifier setup task.
 

Required
 

Required if deleting a value.
 
Not Required if deleting the
qualifier.
 

LowValueChar
 

Qualifying attribute value
 

This is validated for the
value set, if defined during
setup in the Manage
Incentive DFF setup task.
 

Required
 

Required if deleting a value.
 
Not Required if deleting the
qualifier.
 

HighValueChar
 

Indicates a higher range of
qualifying attribute value if
the operator is "Between"
 

This is validated for the
value set, if defined during
setup in the Manage
Incentive DFF setup task.
 

Required, if the
OperatorName is
"Between"
 

Required, if the
OperatorName is
"Between"
 
Required if the
OperatorName is
"Between" and you're
deleting a value.
 
Not required if you're
deleting the qualifier.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Incentive Rule
Attribute Value record

Deleting an Existing
Incentive Rule Attribute
Value record

 

RuleAttrValueId
 

Unique internal identifier of
the rule attribute value
 

This is validated for the
Rule Attribute Value table
when deleting an incentive.
 

Leave this blank.
 

Optional
 

ActionCode
 

Indicates explicitly the
operation to be performed
on a row:
 

• INSERT to create a
new record in the
destination tables

• DELETE to delete the
record.

The value can be either
blank or DELETE.
 

Optional
 
Leave this blank.
 

Required
 
Enter the value as DELETE.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Incentive Rule
Attribute Values object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Incentive Rule Attribute Values object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Incentive Rule Attribute Values information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Incentive Rule Attribute Values.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Incentive Rule Attribute Values from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Incentive Rule Attribute Values.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Incentive Rules Data  
You can use the import functionality to create or update Incentive Rule records.

You can import Incentive Rule records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Incentive Rule data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Incentive Rule data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Incentive Rules import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Incentive Rules while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Incentive Rules attributes. However
if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the
Incentive Rule child objects. Note that you must have imported the CSV file for Incentive Rules object successfully
before trying to import the CSV files for the child objects. There are separate help topics describing how to import each
of these child objects.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use the public unique identifier to identify records. If you're
creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted
with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're
updating a record with a Number attribute, then use the Number attribute to identify the record. For more information
about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

Required Attributes and Validations for Incentive Rules Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Incentive Rule records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating an Incentive
Rule record

Updating an Existing
Incentive Rule record

Deleting an Existing
Incentive Rule record

OrgName
 

The name of the
business unit
 

To find the business
unit, navigate to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Function Area:
Data Import and
Export

• Task: Manage
Business Units

In the Search results
area, search for the
name and select the
name that's displayed.
 

Note:
Export the results to
a spreadsheet. Use
this information to
identify and assign
the business unit
values to the data
you're preparing.
 

Required
 

Required
 

Required
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating an Incentive
Rule record

Updating an Existing
Incentive Rule record

Deleting an Existing
Incentive Rule record

UsageName
 

Indicates the incentive
rule usage
 

The valid values are:
 

• Crediting

• Rollup Hierarchy

• Classification

• Participant
Assignments

• Team

• Analyst Hierarchy

Required
 

Required
 

Required
 

RuleNumber
 

PUID of the rule
 

None
 

Optional
 

A value is required
if the Name isn't
provided.
 

A value is required
if the Name isn't
provided.
 

Name
 

The name of the rule
 

None
 

Required
 

A value is required if
the RuleNumber isn't
provided.
 

A value is required if
the RuleNumber isn't
provided.
 

Description
 

A brief description of
the rule
 

None
 

Optional
 

Optional
 

Optional
 

StartDate
 

The start date of the
rule
 

This must be in the
open period.
 

Required
 

Optional
 

Optional
 

EndDate
 

The end date of the
rule
 

This must be in the
open period.
 

Required
 

Optional
 

Optional
 

EnabledFlag
 

Option to either
enable or disable the
rule
 

Y or N
 

Optional
 

Optional
 

Optional
 

Rank
 

The rank of the rule
 

None
 

Optional
 

Optional
 

Optional
 

NumWinners
 

The number of
winners for this rule.
 

None
 

Optional
 

Optional
 

Optional
 

ParentRuleNumber
 

The rule number of
the parent rule.
 

This must be an
existing rule number
or a rule number that's
created in the same
file.
 

Optional for the
topmost rule in the
hierarchy
 

Optional
 

Optional
 

ParentName
 

The rule name of the
parent rule.
 

This must be an
existing rule name
or a rule name that's
created in the same
file.

Optional for the
topmost rule, if the
rule has no parent in
the hierarchy
 

Optional
 

Optional
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating an Incentive
Rule record

Updating an Existing
Incentive Rule record

Deleting an Existing
Incentive Rule record

 

ActionCode
 

Indicates explicitly
the operation to be
performed on a row:
 

• INSERT to create
a new record in
the destination
tables

• UPDATE to
update an
existing record in
the destination
table

• DELETE to delete
the record.

The value can be
blank or one of the
following:
 

• UPDATE

• DELETE

• DELETE
HIERARCHY

Optional
 
Leave this blank.
 

Optional
 
Either leave this blank
or enter UPDATE.
 

Required
 
The value should be
DELETE for a leaf
node or DELETE
HIERARCHY for the
rule hierarchy
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Incentive Rules
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Incentive Rules object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Incentive Rules information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Incentive Rules.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Incentive Rules from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Incentive Rules.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

How do I import incentive transaction data?  
You can use the import functionality to create or update Incentive Transaction records.

To import Incentive Transaction records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Incentive Transaction data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identifying an object record is through the Internal ID. If you're identifying a record that
already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique
identifier Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating
Incentive Transactions. You can determine the internal ID of a record by exporting Oracle Applications Cloud object
data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces
the import duration. For the Incentive Transaction object, the attributes are Transaction Number and Transaction Type.

Required Attributes and Validations for Incentive Transaction Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Incentive Transaction records, required attributes for
updating Incentive Transaction records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Incentive Transaction import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Incentive
Transaction
Record

Updating an
Existing Incentive
Transaction
Record

Business Unit
 

Name of the
business unit
 

Varchar2
 

240
 

To find the
business unit:
 

1. Navigate to
Setup and
Maintenance.

2. Navigate to
the Manage
Business
Units task.

3. In the Search
results region,
 search for
the name and
select the
name that's
displayed.

Note:
You can export
the results to
a spreadsheet
and use this
information to
identify and
assign the
Business Unit
values to the
data that you're
preparing.
 

Required
 
A value is required
either for the
Business Unit or
the Business Unit
Id.
 

Required
 
A value is required
either for the
Business Unit or
the Business Unit
Id.
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Incentive
Transaction
Record

Updating an
Existing Incentive
Transaction
Record

Business Unit ID
 

Unique numeric
identifier for
the Oracle
Fusion Incentive
Compensation
business unit.
 

Number
 

18
 

To find the
business unit:
 

1. Navigate to
Setup and
Maintenance.

2. Navigate to
the Manage
Business
Units task.

3. In the Search
results region,
 click the
View menu
and add the
Business Unit
ID Column.

Note:
You can export
the results to
a spreadsheet
and use this
information to
identify and
assign the
Business Unit
ID values to the
data that you're
preparing.
 

Required
 
A value is required
either for the
Business Unit or
the Business Unit
Id.
 

Required
 
A value is required
either for the
Business Unit or
the Business Unit
Id.
 

Event Date
 

When the
transaction
triggers an
incentive event
associated with the
row, for example,
 salespeople are
compensated
when an invoice is
booked or an order
is posted.
 

Date
 

 The period must
be open before
you can collect the
transaction into
the application.
 

Required
 

Required
 

Transaction
Amount
 

The transaction
amount to be
evaluated by the
credit and earning
processes.
 

Number
 

 If providing a
monetary amount,
the amount should
be in the currency
of the source
application.
 

Required
 

Required
 

Transaction
Number
 

Unique transaction
identifier used
in the source
application. The

Varchar2
 

30
 

Map an identifier
that end users
recognize and
can search. For

Required
 

Required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Incentive
Transaction
Record

Updating an
Existing Incentive
Transaction
Record

combination of
Source Transaction
Number and
Transaction
Type values
must be unique,
 and is validated
during the Collect
Transactions
process.
 

example, map
your source
invoice number
and invoice line
number to this
field.
 

Transaction Type
 

Defines the type
of the transaction.
Predefined
transaction types
are CLAWBACK,
 CUSTOMER_
SATISFACTION,
 GRP, INVOICE,
 ITD, MANUAL,
ORDER, PAYMENT,
 and RAM_
ADJUSTMENT.
 

Varchar2
 

30
 

The value must
be a valid lookup
code for lookup
type CN_TP_
TRANSACTION_
TYPE. To define
your own
transaction types:
 

1. In Setup and
Maintenance,
 go to the
Manage
Incentive
Compensation
Lookups task.

2. Search for
CN_TP_
TRANSACTION_
TYPE.

3. Add your
transaction
types.

Required
 

Required
 

You can view the Incentive Transaction object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Note:  Don't use the Transaction Sub-Type attribute. It's intended for internal use only.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Incentive Transaction object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Incentive Transaction

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Interaction Data  
You can use the Import Management to create or update Interaction records.

To import Interaction records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Target Object Attributes
To import your Interaction data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Interaction object, this attribute is InteractionId:

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Interaction object, the attribute
is InteractionNumber.

Required Attributes and Validations for Interaction Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Interaction records, required attributes for updating
Interaction records, prerequisite setup tasks for the attributes, and specific validations, if any, for Interaction import:
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating an
Interaction
Record

Updating
an Existing
Interaction
Record

InteractionId
 

The unique
identifier of the
interaction
 

Long
 

18
 

None
 

Not required
 

Required
 

InteractionNumber
 

The Public Unique
Identifier of the
interaction
 

Varchar
 

30
 

None
 

Not required
 

Not required
 

ChannelId
 

The unique
identifier of the
interaction channel
 

Long
 

18
 

The referenced
record must exist.
 

Required
 

Not Required
 

StripeCd
 

The code
indicating the
stripe of the
interaction. A list
of valid values
is defined in the
lookup ORA_SVC_
STRIPE_CD.
 

Varchar2
 

30
 

None
 

Not required
 

Required
 

StatusCd
 

The current status
of the interaction.
Interactions are
either in the ORA_
SVC_OPEN or
ORA_SVC_CLOSED
status.
 

Varchar
 

30
 

Default "ORA_
SVC_OPEN"
 

Not required
 

Not required
 

DirectionCd
 

The code
indicating whether
the interaction
is inbound or
outbound. The
default value
is ORA_SVC_
INBOUND,
 indicating inbound
interactions. The
value is ORA_
SVC_OUTBOUND
for outbound
interactions.
 

Varchar
 

30
 

Default "ORA_
SVC_INBOUND"
 

Not required
 

Not required
 

ParentInteractionId
 

The unique
identifier of the
parent interaction.
 

Long
 

18
 

The referenced
record must exist,
 if included.
 

Not required
 

Not required
 

Description
 

The brief
description of the
interaction
 

Long
 

1000
 

None
 

Not required
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating an
Interaction
Record

Updating
an Existing
Interaction
Record

AccountPartyId
 

The unique
identifier of the
account associated
with the interaction
 

Long
 

18
 

The referenced
record must exist,
 if included.
 

Not required
 

Not required
 

ContactPartyId
 

The unique
identifier of the
contact associated
with the interaction
 

Long
 

18
 

The referenced
record must exist,
 if included.
 

Not required
 

Not required
 

OwnerResourceId
 

The unique
identifier of the
owner of the
interaction
 

Long
 

18
 

The referenced
record must exist,
 if included.
 

Not required
 

Not required
 

MediaItemId
 

The unique
identifier for the
media item
 

Long
 

18
 

The referenced
record must exist,
 if included.
 

Not required
 

Not required
 

StartTime
 

The time when
the interaction
becomes active
 

Date Time
 

None
 

None
 

Required
 

Not required
 

EndTime
 

The time when
the interaction
becomes inactive
 

Date Time
 

None
 

None
 

A value is required
if the status
is "ORA_SVC_
CLOSED".
 

Not required
 

OriginalSystemReference
 

The system
reference used by
the interaction
 

Varchar
 

255
 

None
 

Not required
 

Not required
 

SubStatusCd
 

The code
indicating the
sub-status of
the interaction.
A list of valid
values is defined
in the lookup
ORA_SVC_IM_CLOSED_SUBSTATUS_CD.
 

Varchar
 

30
 

None
 

Not required
 

Not required
 

QueueId
 

The unique
identifier of the
interaction queue
 

Long
 

18
 

The referenced
record must exist,
 if included.
 

Not required
 

Not required
 

AgentHTTPSessionId
 

The HTTP session
Id of the agent
 

Varchar
 

100
 

None
 

Not required
 

Not required
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You can view the Interaction object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Interaction object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Interaction from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?
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Import Your Interaction Participant Data  
You can use the Import Management to create or update Interaction Participant records.

To import Interaction Participant records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Interaction Participant data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all Interaction records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides
better performance and reduces the import duration. For the Interaction Participant object, this attribute is
InteractionParticipantId
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• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Interaction Participant object,
the attribute is InteractionParticipantNumber.

Required Attributes and Validations for Interaction Participant Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Interaction Participant records, required attributes for
updating Interaction Participant records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Interaction Participant import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating an
Interaction
Participant

Updating
an Existing
Interaction
Participant
Record

InteractionParticipantIdThe auto-
generated number
and primary key
for this participant.

Long 18 None Required Required

ContactPartyNumberThe party number
of the contact if
the participant was
a contact.

String 30 The referenced
record must exist,
 if included.

Required Required

ResourcePartyNumberThe party number
of the resource if
the participant was
a resource.

String 30 The referenced
record must exist,
 if included.

Required Required

InteractionId The interaction id
of the interaction
to which the
participant
belongs.

Long 18 The referenced
record must exist,
 if included.

Required Not Required

InteractionNumber The alternate key
identifier for the
interaction.

String 30 The referenced
record must exist,
 if included.

Required Not required

InteractionParticipantNumberThe public unique
identifier for
the Interaction
Participant.

String 30 None Conditionally
Required.
Provide a value
if InteractionId
isn’t provided.
Participant ID has
precedence.

Conditionally
Required.
Provide a value
if InteractionId
isn’t provided.
Participant ID has
precedence.

ResourcePartyId The party Id of
the resource if the
participant is a
resource.

Long 18 The referenced
record must exist,
 if included.

Not required Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating an
Interaction
Participant

Updating
an Existing
Interaction
Participant
Record

ContactPartyId The PartyId of
the contact if the
participant is a
contact.

Long 18 The referenced
record must exist,
 if included.

Not required Not required

ParticipantTypeCd The type of
participant.

String 30 The value is
sourced from the
lookup ORA_SVC_
PARTICIPANT_
TYPE_CD.

Not required Not required

StartTime The time when the
participant joined
the interaction.

Timestamp None None Not required Not required

EndTime The time when the
participant left the
interaction.

Timestamp None None Not required Not required

DurationMinutes The number
of minutes the
participant was on
the conference.
You can join, drop,
 and rejoin the
conference.

Integer 9 None Not required Not required

ParticipantName The name
from the web
conference. Does
not necessarily tie
to Fusion data.

String 128 None Not Required Not Required

Email The email of the
participant.

String 128 None Not Required Not Required

Phone The phone number
of the participant.

String 128 None Not required Not required

OriginalSystemReferenceSpecifies the
original system
reference if record
was imported.

String 225 None Not required Not required

Json The JSON String. ClobDomain None None Not required Not required

You can view the Interaction Participants object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Note:  Contact details, participant details, resource details, start time, and end time should be included to have a
correct representation of the data.
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Create the Source CSV File
You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Interaction Participant object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Interaction from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• Import Your Interaction Data

Import Your Interaction Reference Data  
You can use Import Management to create Interaction Reference records.
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To import Interaction Reference records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Interaction Reference data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. For more information about public unique identifiers, see the
topic "How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and
source system reference is a unique identifier within the external system. If you're importing new interaction
references that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Interaction Reference Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Interaction
Reference records, prerequisite setup tasks for the attributes, and specific validations, if any, for Interaction Reference
import:
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Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Interaction Reference
Record

ReferenceId
 

The unique identifier of the
interaction reference.
 

No validation
 

Required
 

ObjectTypeCd
 

The code that indicates the object
type present in the interaction
reference.
 

If a service request interaction
reference (ObjectId) is imported,
 then both the interaction and the
service request records must exist
before the import process.
 
Valid values:
 
SVC_SERVICE_REQUESTS, SVC_
CHATS, MOO_OPTY, MKL_LM_
LEADS, ZMM_ACTY_ACTIVITIES,
 SVC_WORK_ORDERS
 

Required
 

ObjectId
 

The unique identifier of the object
associated with the interaction
reference.
 

If a service request interaction
reference (ObjectId) is imported,
 then both the interaction and the
service request records must exist
before the import process.
 

Either the ObjectId or the
ObjectNumber is required. If both
are present, then the ObjectId is
preferred.
 

InteractionId
 

The unique identifier of the
interaction.
 

An interaction record must exist
before an interaction reference can
be created/imported.
 

Either the InteractionId or the
InteractionNumber is required.
If both are present, then the
InteractionId is preferred.
 

InteractionNumber
 

The public unique identifier of the
interaction.
 

No validation
 

Either the InteractionId or the
InteractionNumber is required.
If both are present, then the
InteractionId is preferred.
 

ObjectNumber
 

The public unique identifier of
the object associated with the
interaction reference.
 

If a service request interaction
reference (ObjectId) is imported,
 then both the interaction and the
service request records must exist
before the import process.
 

Either the ObjectId or the
ObjectNumber is required. If both
are present, then the ObjectId is
preferred.
 

Note:  Update operation isn't supported for interaction reference records.

You can view the Interaction Reference object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools >  Import Management >  Import Objects.
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2. Select the Interaction Reference object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Interaction Reference.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Interaction Reference

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Interaction Reference.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Linked Party Data  
You can use the import management to create or delete your Linked Party records.

To import Linked Party records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Target Object Attributes
To import your Linked Party data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record.

Required Attributes and Validations for Linked Party Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Linked Party records, required attributes for deleting Linked
Party records, prerequisite setup tasks for the attributes, and specific validations, if any, for Linked Party import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Linked Party
Record

Deleting a Linked Party
Record

LinkType
 

Indicates the type of Link
Sets such as B2F_EQUIV.
 

None
 

Required
 

Required

RelatedPartyId
 

Fusion identifier of the
Party which is related to the
Link Set.
 

None
 

Conditionally Required.
Either RelatedPartyId or
RelatedPartyNumber must
be provided. It should be
party of the Customer party
usage.
 

Not Required

RelatedPartyNumber
 

Public unique identifier of
the Party which is related
the the Link Set.

None
 

Conditionally Required.
Either RelatedPartyId or
RelatedPartyNumber must
be provided. It should be
party of the Customer party
usage.
 

Required

PartyId
 

Fusion unique identifier of
the party.
 

None Conditionally Required.
Either PartyId or
PartyNumber must be
provided. It should be a
party of Sales such as Sales
Prospect or Sales Account
party usage.
 

Not Required

PartyNumber
 

The public unique identifier
of the party.
 

None
 

Conditionally Required.
Either PartyId or
PartyNumber must be
provided. It should be a
party of Sales such as Sales
Prospect or Sales Account
party usage.
 

Required

You can view the Linked Party object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Create the Source CSV File
You include the data that you want to import in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Linked Party object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Here is a recommended format for the CSV file:
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LinkType RelatedPartyNumber PartyNumber MainLink

B2F_EQUIV FinancialParty-2 SalesParty-1 Y

B2F_EQUIV FinancialParty-3 SalesParty-1 Y

B2F_EQUIV SalesParty-1 FinancialParty-2 N

B2F_EQUIV SalesParty-1 FinancialParty-3 N

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Linked Party from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Marketing Development Funds (MDF)
Budget Data  
You can use import management to create or update MDF Budget records.

To import MDF Budget records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Marketing Development Funds (MDF) Budget data into Oracle Applications Cloud, you need to populate
a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the
internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are
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typically internal IDs. Use this option only if you're updating MDF Budgets. You can determine the internal ID of
a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using
an internal ID typically provides better performance and reduces the import duration. For the MDF Budget
object, the attributes are Budget Id and Owner Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the MDF Budget object, the
attributes are Owner Party Number and Company Party Number.

Required Attributes and Validations for MDF Budget Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Budget
records, required attributes for updating MDF Budget records, prerequisite setup tasks for the attributes, and specific
validations, if any, for MDF Budget import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Budget
Record

Updating an Existing MDF
Budget Record

BudgetID
 

System generated unique
identifier.
 

None
 

Not required
 

Required
 
MDF budgets can be
imported if they're in the
following status: Draft,
 Active, or Inactive.
 

Start Date
 

The date after which
the MDF budget can be
activated any time.
 

If provided, this must be
before the end date.
 

Required
 

Not required
 

Claim Deadline
 

Specifies the date by which
claims should be submitted.
 

If provided, this must be
equal to or greater than the
end date.
 

Required
 

Not required
 

Request Deadline
 

Specifies the date by which
fund requests should be
submitted.
 

If provided, this must be
between the start date and
the end date.
 

Required
 

Not required
 

OwnerID
 

Identifies the owner of the
MDF budget
 

None
 

Required
 

Required
 

Owner
 

Identifies the owner name
of the MDF budget
 

None
 

Not required
 

Not required
 

Partner
 

Identifies the partner
associated with the MDF
budget
 

This is applicable only
when the MDF budget type
is "Discretionary- Single
Partner".
 

Not required
 

Not required
 

OwnerPartyNumber
 

Identifies the owner's party
number of the MDF budget

None
 

Not required
 

Not required
 

459



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Budget
Record

Updating an Existing MDF
Budget Record

 

PartnerCompanyNumber
 

The unique identifier of the
partner associated with the
MDF Budget
 

This is applicable only
when the MDF budget type
is "Discretionary- Single
Partner".
 

Not required
 

Not required
 

Name
 

Specifies the name of the
MDF budget.
 

None
 

Required
 

Not required
 

Currency
 

Specifies the transaction
currency for MDF budget
amounts
 

If providing a value, the
value must exist in the
CURRENCY_CODE column
of the FND_CURRENCIES_
VL table. You can view valid
currency codes. Navigate to
the following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage
Currencies

Required
 

Not required
 

Initial Amount
 

Specifies the initial amount
allocated to the MDF
budget.
 

None
 

Required
 

Not required
 

Status
 

Current status for the
Budget such as Draft ,
 Active, or Inactive.
 

None
 

Required
 

Not required
 

Code
 

Unique identifier of an MDF
budget.
 

None
 

Conditionally required, if
you're providing a budget
name for a new MDF
budget.
 

Required if updating an
existing budget and you
aren't providing the unique
Id of the MDF budget.
 

You can view the MDF Budget object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the MDF Budget  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Budget from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your MDF Budget Countries Data  
You can use import management to create or update MDF Budget Countries records.

To import MDF Budget Countries records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your MDF Budget Countries data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Internal ID. If you're identifying a record that
already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique
identifier Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating MDF
Budget Countries. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or
by doing a transactional database query. Using an internal ID typically provides better performance and reduces the
import duration. For the MDF Budget Countries object, the attribute is BudgetCountryID.

Required Attributes and Validations for MDF Budget Countries Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Budget
Countries records, required attributes for updating MDF Budget Countries records, prerequisite setup tasks for the
attributes, and specific validations, if any, for MDF Budget Countries import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Budget
Countries Record

Updating an Existing MDF
Budget Countries Record

Budget CountryID
 

Specifies the budget
country associated with the
MDF budget
 

None
 

Required
 

A value is required, if
changing from one country
to another and the country
code isn't provided.
 

Country Code
 

The code representing
the country to which the
country structure belongs.
 

None
 

Required
 

A value is required, if
changing from one MDF
budget country to another
and the country ID isn't
provided.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Budget
Countries Record

Updating an Existing MDF
Budget Countries Record

Budget Code
 

Unique identifier of an MDF
budget
 

None
 

A value is required, if the
unique ID of the budget
isn't provided.
 

A value is required, if the
unique ID of the budget
isn't provided.
 

You can view the MDF Budget Countries object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the MDF Budget Countries  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Budget Countries

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your MDF Budget Team Data  
You can use import management to create or update MDF Budget Team records.

To import MDF Budget Team records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your MDF Budget Team data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. Use this option only if you're updating MDF Budget Teams. You can determine the
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internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database
query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF
Budget Team object, the attributes are Budget Team Id and Budget Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the MDF Budget Team object, the
attribute is Resource Party Number.

Required Attributes and Validations for MDF Budget Team Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Budget
Team records, required attributes for updating MDF Budget Team records, prerequisite setup tasks for the attributes,
and specific validations, if any, for MDF Budget Team import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Budget
Team Record

Updating an Existing MDF
Budget Team Record

Budget Team ID
 

This is a system generated
unique identifier to identify
the MDF budget team.
 

None
 

Required
 

Required
 

Resource Party Number
 

Identifies the budget team
resource
 

None
 

Required
 

Required
 

Code
 

Unique identifier of an MDF
budget
 

None
 

Required
 

Required
 

Budget ID
 

Specifies the MDF budget
to which the budget team is
associated
 

None
 

Not required
 

Required
 

You can view the MDF Budget Team object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the MDF Budget Team  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Budget Team from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your MDF Claim Data  
You can use import management to create or update MDF Claim records.

To import MDF Claim records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your MDF Claim data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.
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• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the
internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are
typically internal IDs. Use this option only if you're updating MDF Claims. You can determine the internal ID of
a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using
an internal ID typically provides better performance and reduces the import duration. For the MDF Claim object,
the attributes are Claim ID, Fund Request ID, and Owner ID.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the MDF Claim object, the attribute
is Owner Party Number.

Required Attributes and Validations for MDF Claim Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Claim
records, required attributes for updating MDF Claim records, prerequisite setup tasks for the attributes, and specific
validations, if any, for MDF Claim import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Claim
Record

Updating an Existing MDF
Claim Record

Claim ID
 

This is a system generated
unique identifier to identify
the MDF Claim.
 

This is automatically
derived from the import
process when you import a
new MDF claim.
 

Not required
 

A value is required if you're
not providing an identifier
for the MDF claim.
 

Fund Request Code
 

Unique fund request
identifier
 

If provided, the Status Code
of the FundRequestCode
must be either Approved or
Terminated.
 

A value is required when
importing a new MDF claim
and you're not providing
the unique identifier of the
request.

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Claim
Record

Updating an Existing MDF
Claim Record

 

Owner Party Number
 

A unique public identifier
for the owner number
 

None
 

Conditionally required
 
For a new MDF claim with
any StatusCode, provide
either the Owner ID or the,
 Owner Party Number.
 

Conditionally required
 
When updating the owner
of an MDF claim, provide
either the Owner ID or the
Owner Party Number.
 

Budget
 

Identifies the MDF budget
associated with the claim
 

None
 

Not required
 

Not required
 

Fund Request ID
 

Identifies the fund request
to which the MDF claim is
associated
 

If provided, the Status Code
of the fund request ID must
be Approved or Terminated.
 

A value is required when
importing a new MDF claim
with any Status Code.
 

Not required
 

Name
 

Identifies the name of the
MDF claim.
 

None
 

Required
 

Not required
 

Currency
 

The code that represents
the currency for the MDF
claim
 

None
 

Not required
 

Not required
 

Requested Amount
 

Specifies the amount for
the MDF claim
 

None
 

Required
 

A value is required when
updating the requested
amount of an MDF claim
with Status Code Draft or
Returned.
 

MDF Request
 

Specifies the name for the
fund request
 

None
 

A value is required when
importing a new MDF
claim.
 

Not required
 

Owner ID
 

Identifies the owner for the
MDF claim
 

None
 

Conditionally required
 
For a new MDF claim with
any StatusCode, provide
either the Owner ID or the
Owner Party Number.
 

Conditionally required
 
When updating the owner
of an MDF claim, provide
either the Owner ID or the
Owner Party Number.
 

Owner
 

Identifies the owner of the
MDF claim
 

None
 

Required
 

Not required
 

Status
 

Identifies the current status
of the MDF claim such as
Draft, Submitted, Pending
Approval, Approved, or
Rejected
 

This defaults to Draft when
creating a new MDF claim.
 

Required
 

Not required
 

Conversion Rate to Budget
 

Specifies the conversion
exchange rate. Stores the
currency exchange rate

None
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Claim
Record

Updating an Existing MDF
Claim Record

used for converting the
user entered currency on
the MDF claim to the CRM
corporate currency
 

Code
 

Unique MDF claim
identifier.
 

None
 

Not required
 

A value is required if
updating an existing
MDF claim and you're
not providing any other
identifier for the MDF claim.
 

You can view the MDF Claim object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Note:  When you create a record in the "Draft" status, it can't be moved directly to a terminal status such as
"Approved", "Rejected", "Terminated", "Withdrawn" or "Returned". It should be converted from the "Draft" status to
the OOTB defined status "Pending Approval" before it can be moved to a terminal status. You can create a record in
any status except "Pending Approval".

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the MDF Claim  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Claim from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your MDF Claim Settlement Data  
You can use import management to create or update MDF Claim Settlement records.

To import MDF Claim Settlement records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your MDF Claim Settlement data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the
internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are
typically internal IDs. Use this option only if you're updating MDF Claim Settlements. You can determine the
internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database
query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF
Claim Settlement object, the attributes are Claim Settlement ID and Claim ID.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the MDF Claim Settlement object,
the attribute is ClaimSettlementCode.

Required Attributes and Validations for MDF Claim Settlement Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Claim
Settlement records, required attributes for updating MDF Claim Settlement records, prerequisite setup tasks for the
attributes, and specific validations, if any, for MDF Claim Settlement import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Claim
Settlement Record

Updating an Existing MDF
Claim Settlement Record

Claim Settlement ID
 

System generated unique
claim settlement identifier
 

This is automatically
derived from the import
process when importing a
new MDF claim settlement.
 

Not required
 

A value is required if you're
not providing another
identifier for the MDF claim
settlement.
 

Type
 

Specifies the type of
transaction for the MDF
claim settlement
 

None
 

Required
 

Not required
 

Accounting Type
 

Specifies the type of MDF
claim settlement - Credit or
Debit. This is for reference
only, as the MDF claim
settlements doesn't have
any effect on the available
budget.
 

This is derived when the
payment type is selected.
Accounting Type = Credit if
Payment Type is Payment.
 

Not required
 

Not required
 

Status
 

Specifies the current
status of the MDF claim
settlement
 

The default value is
Incomplete.
 

Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Claim
Settlement Record

Updating an Existing MDF
Claim Settlement Record

Currency
 

Transaction currency for
the claim amount
 

If providing a value, the
value must exist in the
CURRENCY_CODE column
of the FND_CURRENCIES_
VL table. You can view
the valid currency codes.
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage
Currencies

A value is required when
importing a new MDF claim
with any Status Code.
 

A value is required when
updating an MDF claim
with Status Code Draft or
Returned.
 

Amount
 

Specifies the amount being
settled in the MDF claim
settlement
 

This amount can't exceed
the outstanding claim
liability.
 

Required
 

A value is required if
updating an existing MDF
claim settlement with the
Status Code Incomplete.
 

Claim ID
 

System generated unique
identifier
 

If provided, the Status Code
must be either Approved or
Terminated.
 

A value is required when
importing an MDF claim
settlement with any Status
Code.
 

Not required
 

Claim Code
 

Specifies a unique claim
identifier
 

If provided, the Status
Code of the Claim Code
must be either Approved or
Terminated.
 

A value is required when
importing a new MDF claim
settlement and you're
not providing the unique
identifier of the MDF claim.
 

Not required
 

Claim Settlement Code
 

Specifies the unique
identifier for MDF claim
settlements
 

None
 

Not required
 

A value is required if
updating an existing MDF
claim settlement and you're
not providing any other
identifier for the MDF claim
settlement.
 

You can view the MDF Claim Settlement object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the MDF Claim Settlement  object in the table and click Download.
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You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Claim Settlement

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your MDF Claim Team Data  
You can use import management to create or update MDF Claim Team records.

To import MDF Claim Team records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Target Object Attributes
To import your MDF Claim Team data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the
internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are
typically internal IDs. Use this option only if you're updating MDF Claim Teams. You can determine the internal
ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query.
Using an internal ID typically provides better performance and reduces the import duration. For the MDF Claim
Team object, the attributes are Claim Resource ID, Resource ID, and Claim ID.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the MDF Claim Team object, the
attribute is Resource Party Number.

Required Attributes and Validations for MDF Claim Team Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Claim
Team records, required attributes for updating MDF Claim Team records, prerequisite setup tasks for the attributes, and
specific validations, if any, for MDF Claim Team import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Claim
Team Record

Updating an Existing MDF
Claim Team Record

Resource Party Number
 

Identifies the resource for
the MDF claim team
 

None
 

Not required
 

Not required
 

Claim Resource ID
 

System generated unique
identifier
 

None
 

Not required
 

Optional or conditionally
required
 

Resource ID
 

Specifies the resource
added to the MDF claim
team
 

None
 

Required
 
Provide either the Resource
ID or the Resource Party
Number.
 

Not required
 

Code
 

Specifies a unique claim
identifier
 

None
 

A value is required if you're
not providing the unique ID
of the request.
 

A value is required if you're
not providing the unique ID
of the request.
 

Claim ID
 

System generated unique
identifier
 

None
 

Required
 

Not required
 

You can view the MDF Claim Team object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the MDF Claim Team  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Claim Team from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
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6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your MDF Request Data  
You can use import management to create or update MDF Request records.

To import MDF Request records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your MDF Request data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the
internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are
typically internal IDs. Use this option only if you're updating MDF Requests. You can determine the internal
ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query.
Using an internal ID typically provides better performance and reduces the import duration. For the MDF
Request object, the attributes are Fund Request ID, Partner ID, and Owner ID.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the MDF Request object, the
attributes are Owner Party Number and Partner Company Number.

Required Attributes and Validations for MDF Request Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Request
records, required attributes for updating MDF Request records, prerequisite setup tasks for the attributes, and specific
validations, if any, for MDF Request import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Request
Record

Updating an Existing MDF
Request Record

Fund Request ID
 

System generated unique
fund request identifier
 

This is automatically
derived from the import
process when importing a
new MDF request.
 

Not required
 

Required
 

Owner Party Number
 

A unique public identifier
for the owner party number
 

None
 

A value is required for a
new MDF request with any
Status Code.
 

Required
 

Partner Company Number
 

A unique public identifier
for the partner company
number
 

None
 

A value is required for a
new MDF request with any
Status Code.
 

A value is required, when
updating the partner of an
MDF request in the Draft
Status Code.
 

Name
 

Specifies the name of the
fund request
 

None
 

A value is required when
importing a new MDF
request.
 

Not required
 

Currency
 

Specifies the transaction
currency for MDF request
amounts
 

If providing a value, the
value must exist in the
CURRENCY_CODE column
of the FND_CURRENCIES_

A value is required when
importing a new request
with any Status Code.
 

A value is required when
updating a request with
Status Code Draft or
Returned.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Request
Record

Updating an Existing MDF
Request Record

VL table. You can view valid
currency codes. Navigate to
the following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage
Currencies

 

Requested Amount
 

Specifies the amount
requested by the MDF
request
 

None
 

Required
 

A value is required when
updating the requested
amount of a request
with Status Code Draft or
Returned.
 

Partner
 

Identifies the partner
associated with the MDF
request
 

None
 

Not required
 

Not required
 

Partner ID
 

Identifies the partner for
the MDF request
 

None
 

A value is required for a
new MDF request with any
Status Code.
 

A value is required when
you're updating the partner
of an MDF request in the
Draft Status Code.
 

Owner ID
 

Identifies the owner for the
MDF request
 

None
 

A value is required for a
new MDF request with any
Status Code.
 

Required
 

Owner
 

Identifies the owner of the
MDF request
 

None
 

Not required
 

Not required
 

Code
 

Unique MDF fund request
identifier
 

None
 

Conditionally required if
you're providing a request
name for a new MDF
budget.
 

A value is required if you're
updating an existing MDF
request and you're not
providing the unique MDF
request ID.
 

You can view the MDF Request object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Note:  When you create a record in the "Draft" status, it can't be moved directly to a terminal status such as
"Approved", "Rejected", "Terminated", "Withdrawn" or "Returned". It should be converted from the "Draft" status to
the OOTB defined status "Pending Approval" before it can be moved to a terminal status. You can create a record in
any status except "Pending Approval".
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the MDF Request  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Request from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your MDF Request Team Data  
You can use import management to create or update MDF Request Team records.
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To import MDF Request Team records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your MDF Request Team data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. Use this option only if you're updating MDF Request Teams. You can determine the
internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database
query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF
Request Team object, the attributes are MDF Request Resource ID, Resource ID, and Fund Request ID.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the MDF Request Team object, the
attribute is Resource Party Number.

Required Attributes and Validations for MDF Request Team Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Request
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Team records, required attributes for updating MDF Request Team records, prerequisite setup tasks for the attributes,
and specific validations, if any, for MDF Request Team import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a MDF Request
Team Record

Updating an Existing MDF
Request Team Record

MDF Request Resource ID
 

Specifies the unique fund
request identifier in the
MDF request team
 

None
 

Not required
 

Optional or Conditionally
required
 

Resource ID
 

Specifies the resource
added to the MDF request
team
 

None
 

Required
 

Not required
 

Resource Party Number
 

The public unique identifier
of the resource party
 

If providing a value and
creating or updating a team
resource, the value must
exist.
 

Required
 

Not required
 

Code
 

Unique MDF fund request
identifier
 

None
 

A value is required if you're
not providing the unique ID
of the MDF request.
 

A value is required if you're
not providing the unique ID
of the MDF request.
 

Fund Request ID
 

System generated unique
fund request identifier
 

None
 

A value is required if you're
adding a new member to
the MDF request team
 

Not required
 

You can view the MDF Request Team object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the MDF Request Team  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
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3. In the Enter Import Options page, provide a name for the import activity, and select MDF Request Team from
the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Message Data  
You can use the Import Management to create, update, or delete service request message records.

You can import message records using these steps:

1. Map your source message data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.

2. Create the source CSV file with the message data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your message data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new messages or are
updating messages that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Message Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for message records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Message
record

Updating an Existing
Message record

Message Content
 

Content of the message
that's not an attachment.
 

None
 

Required
 

Required
 

Message Type Code
 

Indicates the type of
message. If providing a
value, it must be one of the
following:
 

• ORA_SVC_
CUSTOMER_ENTRY

• ORA_SVC_RESPONSE

• ORA_SVC_INTERNAL_
NOTE

• ORA_SVC_SYSTEM_
NOTE

If providing a value, it must
be one of the following:
 

• ORA_SVC_
CUSTOMER_ENTRY

• ORA_SVC_FORWARD

• ORA_SVC_CHAT_
TRANSCRIPT

• ORA_SVC_INTERNAL_
NOTE

• ORA_SVC_RESPONSE

• ORA_SVC_SYSTEM_
NOTE

• ORA_SVC_SYSTEM_
RESPONSE

Required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Message
record

Updating an Existing
Message record

• ORA_SVC_WRAP_UP

Object ID
 

ID of the object (such as
Note, Defect, Other SR)
referencing the service
request or referenced by
the service request.
 

No validation
 

Do not pass if the Message
Type Code = ORA_SVC_
INTERNAL_NOTE
 

Do not pass if the Message
Type Code = ORA_SVC_
INTERNAL_NOTE
 

Object Type Code
 

Lookup code that indicates
the object type based on
the OBJECT_ID table, such
as SVC_SR_MESSAGES.
 

No validation
 

Do not pass if the Message
Type Code = ORA_SVC_
INTERNAL_NOTE
 

Do not pass if the Message
Type Code = ORA_SVC_
INTERNAL_NOTE
 

Posted By ID
 

The Party Id of the person
who posted the message.
This person can be an
internal resource or a
customer contact.
 

No Validation
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
Posted By ID and you're
not providing the party Id
which is obtained from the
table HZ_IMP_PARTIES_T.
 

Service Request ID
 

Specifies the service
request to which the
message belongs.
 

No validation
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing record
and you're not providing
the SRNumber.
 

SR Number
 

The unique number used to
identify a service request.
You can configure the
service request number to
a format that's best suitable
to your organizational
requirements.
 

No validation
 

Conditionally required
 
A value is required if you're
updating an existing record
and you're not providing
the Service Request ID.
 

Conditionally required
 
A value is required if you're
updating an existing record
and you're not providing
the Service Request ID..
 

Status Code
 

Indicates the status of
the message, such as
DRAFT, COMMITTED, and
CORRECTED.
 

If providing a value, it must
be one of the following:
 

• ORA_SVC_DRAFT

• ORA_SVC_
COMMITTED

• ORA_SVC_
CORRECTED

Required
 

Required
 

Notification Processing
Status Code
 

The notification processing
status code.
 

No validation
 

Do not pass if the Message
Type Code = ORA_SVC_
INTERNAL_NOTE
 

Do not pass if the Message
Type Code = ORA_SVC_
INTERNAL_NOTE
 

Notification Retry Count
 

The notification retry count.
 

No Validation
 

Do not pass if the Message
Type Code = ORA_SVC_
INTERNAL_NOTE

Do not pass if the Message
Type Code = ORA_SVC_
INTERNAL_NOTE
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Message
record

Updating an Existing
Message record

  

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the message object.
The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Message object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the message information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Message from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Nonduplicate Data  
You can use the import functionality to create or update Nonduplicate records.

To import Nonduplicate records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Nonduplicate data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identifying an object record is through the internal ID. If you're identifying a record that
already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique
identifier Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating
Nonduplicates. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by
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doing a transactional database query. Using an internal ID typically provides better performance and reduces the import
duration. For the Nonduplicate object, the attribute is NonduplicateId.

Required Attributes and Validations for Nonduplicate Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Nonduplicate records, required attributes for updating
Nonduplicate records, prerequisite setup tasks for the attributes, and specific validations, if any, for Nonduplicate
import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Nonduplicate
Record

Updating
an Existing
Nonduplicate
Record

NonDuplicateId
 

The unique
identifier of the
non-duplicate
record.
 

Long
 

18
 

No validation
 

Conditionally
Required
 

Required
 

NonDuplicatePartyId
 

The internal
unique identifier
of the party
associated with
the non-duplicate
record.
 

Long
 

18
 

No validation
 

Conditionally
Required
 

You can't update
the Nonduplicate.
 

NonDuplicatePartyNumber
 

The alternate key
identifier of the
party associated
with the non-
duplicate record.
 

String
 

 The
NonDuplicatePartyNumber
is evaluated when
you don't provide
a value for the
NonDuplicatePartyId.
 

Conditionally
Required
 

You can't update
the Nonduplicate
 

MasterPartyId
 

The unique
identifier of the
master party
associated with
the non-duplicate
record.
 

Long
 

18
 

No validation
 

Conditionally
Required
 

You can't update
the Nonduplicate
 

MasterPartyNumber
 

The alternate
key identifier of
the master party
associated with
the non-duplicate
record.
 

String
 

 The
MasterPartyNumber
is evaluated when
you don't provide
a value for the
MasterPartyId.
 

Conditionally
Required
 

You can't update
the Nonduplicate
 

StartDate
 

The date when the
exclusion starts.
 

Date
 

 No validation
 

Optional
 
By default, the
current date
(sysdate) is
considered.

You can't update
the Nonduplicate
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Nonduplicate
Record

Updating
an Existing
Nonduplicate
Record

 

EndDate
 

The date when the
exclusion ends.
 

Date
 

 No validation
 

Optional
 
By default, the
date 31/12/4712 is
considered.
 

Required
 

You can view the Nonduplicate object along with all its child objects and attributes in the Manage Import Objects page
of the Import Management flow. You can find attribute information like type, length, description, and so on, on this
page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Nonduplicate object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Nonduplicate from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
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3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

How do I import opportunity data?  
You can use the Import Management to create, update, or delete opportunity records.

You can import opportunity records using these steps:

1. Map your source opportunity data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.

2. Create the source CSV file with the opportunity data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your opportunity data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

To better manage your opportunity information, the opportunity object has the following child objects:

• Opportunity Competitor

• Opportunity Contact

• Opportunity Lead

• Opportunity Partner

• Opportunity Revenue

• Opportunity Source

• Opportunity Team Member

If you want to import only a few records, then you can create a single CSV file for all opportunity attributes. However
if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the
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opportunity child objects. Note that you must have imported the CSV file for opportunity object successfully before
trying to import the CSV files for the child objects. There are separate help topics describing how to import each of
these child objects. For more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new opportunities or are
updating opportunities that have source system reference data, then provide the source system and source
system reference values.

Required Attributes and Validations for Opportunity Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for opportunity records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Record

Updating an Existing
Opportunity Record

Deleting an Existing
Opportunity Record

Business Unit ID
 

The business unit that
owns the opportunity
transaction. If a value
isn't provided, then
the business unit ID is
set to a default value
based on the signed in
user details.
 

Not applicable
 

Required
 

Do not provide
 

Do not provide
 

Name
 

Opportunity Name
- The name that
identifies the
opportunity.
 

Not applicable.
 

Required
 

Required
 

The attribute is
neither required nor
conditionally required.
 

OptyId
 

Opportunity ID
- The unique ID

You can obtain
the OptyID for an

Conditionally Required
 

Conditionally Required
 

Conditionally Required
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Record

Updating an Existing
Opportunity Record

Deleting an Existing
Opportunity Record

for the existing
opportunity record in
the destination table.
 

existing opportunity
by exporting the
Opportunity object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

Either OptyId or
OptyNumber is
required.
 

OptyNumber
 

The public unique
identifier of the
opportunity.
 

Not applicable.
 

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Do not provide.
 

Conditionally Required
 

Note:
• The profile options MOO_CLOSE_COMP_REQD and MOO_CLOSE_WINLOSS_REQD can be configured to

enforce the Competitor and Winloss Reason Code to be required if the Status is closed.

• You can only import into the Effective Date field and not in the Actual Close Date field.

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the opportunity object.
The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Opportunity object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
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2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics

How do I import opportunity competitor data?  
You can use the Import Management to create, update, or delete opportunity competitor records.

You can import opportunity competitor records using these steps:

1. Map your source opportunity competitor data to Oracle Applications Cloud object attributes. This way the
import process would know where to insert each of the information bits.

2. Create the source CSV file with the opportunity competitor data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your opportunity competitor data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and
source system reference is a unique identifier within the external system. If you're importing new opportunity
competitors or are updating opportunity competitors that have source system reference data, then provide the
source system and source system reference values.

Required Attributes and Validations for Opportunity Competitor Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for opportunity competitor records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity
Competitor Record

Updating an Existing
Opportunity
Competitor Record

Deleting an Existing
Opportunity
Competitor Record

OptyCompetitorId
 

The unique identifier
for Competitors of the
Opportunity, that's
generated by the
application.
 

Not Applicable
 

Do not provide
 

Conditionally Required
 

Conditionally Required
 

OptyId
 

The unique ID
for the existing
opportunity record in
the destination table.
 

You can obtain
the OptyID for an
existing opportunity
by exporting the
Opportunity object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity
Competitor Record

Updating an Existing
Opportunity
Competitor Record

Deleting an Existing
Opportunity
Competitor Record

• Task: Schedule
Export Processes

OptyNumber
 

The public unique
identifier of the
opportunity.
 

Not applicable.
 

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
 

CmptPartyId
 

The party identifier
with competitor party
usage.
 

Not applicable
 

Required
 

Do not provide.
 

Do not provide
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the opportunity
competitor object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Opportunity Competitor object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity competitor information. To create
an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Competitor

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I update existing setup data?

Import Your Opportunity Contact Data  
You can use the Import Management to create, update, or delete opportunity contact records.

You can import opportunity contact records using these steps:

1. Map your source opportunity contact data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the opportunity contact data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your opportunity contact data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new opportunity contacts
or are updating opportunity contacts that have source system reference data, then provide the source system
and source system reference values.

Required Attributes and Validations for Opportunity Contact Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for opportunity contact records, prerequisite setup tasks and specific validations,
if any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Contact
Record

Updating an Existing
Opportunity Contact
Record

Deleting an Existing
Opportunity Contact
Record

OptyId
 

The unique ID
for the existing
opportunity record in
the destination table.
 

You can obtain
the OptyID for an
existing opportunity
by exporting the
Opportunity object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 
You can use
TargetPartyID to
associate the Account
if you're assigning
Account Contact as
the Primary Contact of
Opportunity.
 

Conditionally Required
 

Conditionally Required
 

OptyNumber
 

The public unique
identifier of the
opportunity.

Not applicable.
 

Conditionally Required
 

Conditionally Required
 

Conditionally Required
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Contact
Record

Updating an Existing
Opportunity Contact
Record

Deleting an Existing
Opportunity Contact
Record

 Either OptyId or
OptyNumber is
required.
 

PERPartyId
 

The party identifier of
the contact associated
with the opportunity.
 

Not applicable
 

Required
 

Required
 

Required
 

Go to Navigator  > Tools >  Import Management >  Import Objects page, to see all the attributes of the opportunity
contact object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Opportunity Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity contact information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Contact from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
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3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I update existing setup data?

Import Your Opportunity Deal Data  
You can use Import Management to create update, or delete Opportunity Deal records.

To import Opportunity Deal records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Opportunity Deal data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
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attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Opportunity Deals or
are updating Opportunity Deals that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Opportunity Deal Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Opportunity
Deal records, required attributes for updating Opportunity Deal records, prerequisite setup tasks for the attributes, and
specific validations, if any, for Opportunity Deal import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Opportunity
Deal Record

Updating an Existing
Opportunity Deal Record

DealId
 

The unique identifier for
the existing deal record in
the destination table
 

You can obtain the Deal
Number for an existing deal
registration from the Deal
Registration work area.
 

Conditionally required
 
A value is required either
for the DealId or the
DealNumber.
 

Conditionally required
 

OptyDealId
 

The unique identifier of the
opportunity deal
 

No validation
 

Conditionally required
 

Conditionally required
 

DealNumber
 

The unique identifier value
of the deal
 

No validation
 

Conditionally required
 
A value is required either
for the DealId or the
DealNumber.
 

Conditionally required
 

OptyId
 

The unique identifier for
the existing opportunity
record in the destination
table
 

You can obtain the
OptyID for an existing
opportunity by exporting
the Opportunity object
by navigating to the
following in the Setup and
Maintenance work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Schedule Export
Processes

Conditionally required
 
A value is required either
for the OptyId or the
OptyNumber.
 

Conditionally required
 

OptyNumber
 

The public unique identifier
value of the opportunity
 

No validation
 

Conditionally required
 
A value is required either
for the OptyId or the
OptyNumber.
 

Conditionally required
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You can view the Opportunity Deal object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Opportunity Deal object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Deal from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?
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Import Your Opportunity Lead Data  
You can use the Import Management to create, update, or delete opportunity lead records.

You can import opportunity lead records using these steps:

1. Map your source opportunity lead data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the opportunity lead data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your opportunity lead data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new opportunity leads or
are updating opportunity leads that have source system reference data, then provide the source system and
source system reference values.
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Required Attributes and Validations for Opportunity Lead Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for opportunity lead records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Lead
Record

Updating an Existing
Opportunity Lead
Record

Deleting an Existing
Opportunity Lead
Record

OptyLeadId
 

The unique identifier
of the opportunity
lead.
 

Not applicable
 

Conditionally Required
 

Conditionally Required
 

Conditionally Required
 

OptyId
 

The unique ID
for the existing
opportunity record in
the destination table.
 

You can obtain
the OptyID for an
existing opportunity
by exporting the
Opportunity object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

 

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
 

OptyNumber
 

The opportunity's
public unique
identifier value.
 

Not applicable.
 

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
 

LeadNumber
 

The lead's unique
identifier value.
 

You can obtain the
Lead Number for
an existing lead
registration using the
Lead registration work
area.
 

Required
 

The attribute is
neither required nor
conditionally required.
 

Conditionally required.
To identify the existing
lead relationship
record,provide
either the record
ID (OptyLeadId),
 or provide the
lead number
(LeadNumber) and
the opportunity's
record ID (OptyId),
 or provide the
lead number
(LeadNumber) and the
opportunity number
(OptyNumber).
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Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the opportunity lead
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Opportunity Lead object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity lead information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Lead from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics

Import Your Opportunity Partner Data  
You can use the Import Management to create, update, or delete opportunity partner records.
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You can import opportunity partner records using these steps:

1. Map your source opportunity partner data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the opportunity partner data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your opportunity partner data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new opportunity partners
or are updating opportunity partners that have source system reference data, then provide the source system
and source system reference values.

Required Attributes and Validations for Opportunity Partner Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for opportunity partner records, prerequisite setup tasks and specific validations,
if any:
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Partner
Record

Updating an Existing
Opportunity Partner
Record

Deleting an Existing
Opportunity Partner
Record

PartOrgPartyId
 

The party identifier of
a partner.
 

Not applicable
 

Required
 

Required
 

Required
 

OptyId
 

The unique ID
for the existing
opportunity record in
the destination table.
 

You can obtain
the OptyID for an
existing opportunity
by exporting the
Opportunity object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
 

OptyNumber
 

The public unique
identifier of the
opportunity.
 

Not applicable.
 

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the opportunity partner
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Opportunity Partner object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity partner information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
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3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Partner from
the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I update existing setup data?

Import Opportunity Revenue Data  

Import Your Opportunity Revenue Data  
You can use the Import Management to create, update, or delete opportunity revenue records.

You can import opportunity revenue records using these steps:

1. Map your source opportunity revenue data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the opportunity revenue data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your opportunity revenue data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new opportunity revenues
or are updating opportunity revenues that have source system reference data, then provide the source system
and source system reference values.

Required Attributes and Validations for Opportunity Revenue Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for opportunity revenue records, prerequisite setup tasks and specific validations,
if any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Revenue
Record

Updating an Existing
Opportunity Revenue
Record

Deleting an Existing
Opportunity Revenue
Record

RevnId
 

The unique identifier
of the summary
revenue for this
Opportunity.
 

Not applicable
 

Not Required
 

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
 

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Revenue
Record

Updating an Existing
Opportunity Revenue
Record

Deleting an Existing
Opportunity Revenue
Record

OptyId
 

The unique ID
for the existing
opportunity record in
the destination table.
 

You can obtain
the OptyID for an
existing opportunity
by exporting the
Opportunity object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
 

OptyNumber
 

The public unique
identifier of the
opportunity.
 

Not applicable.
 

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
 

RevnNumber
 

Revenue Number
- The opportunity
revenue's unique
identifier value.
 

Identify the Revenue
Number for an
existing opportunity
revenue using the
Revenue Management
work area and by
exporting the Revenue
object by navigating
to the following
in the Setup and
Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

Not Required
 

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
 

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
 

BUOrgId
 

The unique identifier
of the business unit.
 

Not applicable
 

Required
 

Do not provide
 

Do not provide
 
 

RevnAmountCurcyCode
 

Currency - The code
that represents
the currency of the
opportunity amount.
 

You can view valid
currency codes by
navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

Required
 

The attribute is
neither required nor
conditionally required.
 

The attribute is
neither required nor
conditionally required.
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Revenue
Record

Updating an Existing
Opportunity Revenue
Record

Deleting an Existing
Opportunity Revenue
Record

• Functional Area:
Sales Foundation

• Task: Manage
Currencies

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the opportunity
revenue object. The page also lists attribute information like type, length, description, and so on.

Note:   To update multiple revenue lines belonging to the same opportunity, you must increase the import commit
size in the profile option ZCA_STANDARD_IMPORT_COMMIT_SIZE. It is recommended that you set the value to an
optimum level based on your requirements.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Opportunity Revenue object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Note:  When you add a product or a product group, a separate line will be added in the opportunity revenue. However,
you can't add both the product and the product group simultaneously. You need to use separate requests to add
multiple products and product groups.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity revenue information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Revenue

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I update existing setup data?

Example of Importing Split Revenue Lines  
You can use import management to create, update, and delete split revenue lines. Split revenue lines is a type of
revenue which is also known as Sales Credit.

There are two types of split revenue known as Revenue Sales Credit and Overlay Sales Credit. For more information on
Split Revenue Lines or Sales Credit see Best Practices for Sales Credit in the Related Topics section.

How You Map Your Source Data to Target Object Attributes
To import your split revenue lines data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.
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• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new opportunity revenues
or are updating opportunity revenues that have source system reference data, then provide the source system
and source system reference values.

Required Attributes and Validations for Importing Opportunity Split Revenue Lines
Data
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for split revenue lines records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating a Split
Revenue Line Record

Updating a Split
Revenue Line Record

Deleting a Split
Revenue Line Record

RevnId
 

The unique identifier
of the summary
revenue for this
Opportunity.
 

Not applicable
 

Not Required
 

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
 

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
 

OptyId
 

The unique ID
for the existing
opportunity record in
the destination table.
 

You can obtain
the OptyID for an
existing opportunity
by exporting the
Opportunity object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Not Required
 

Not Required
 

OptyNumber
 

The public unique
identifier of the
opportunity.
 

Not applicable.
 

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Not Required
 

Not Required
 

RevnNumber
 

Revenue Number
- The opportunity

Identify the Revenue
Number for an
existing opportunity

Not Required
 

Conditionally Required
 

Conditionally Required
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating a Split
Revenue Line Record

Updating a Split
Revenue Line Record

Deleting a Split
Revenue Line Record

revenue's unique
identifier value.
 

revenue using the
Revenue Management
work area and by
exporting the Revenue
object by navigating
to the following
in the Setup and
Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
 

Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
 

SplitParentRevnId
 

The unique identifier
of the split parent
revenue.
 

Must be a valid
Revenue ID
 

Required
 

Not Required
 

Not Required
 
 

ResourcePartyId
 

The identifier of the
resource associated
with the child split
revenue.
 

It must be a valid
Resource ID
 

Required
 

Not Required
 

Not Required
 

SalesCreditTypeCode
 

The code indicating
the type of the sales
credit, such as quota
or non-quota. A list
of valid values is
defined in the lookup
MOO_SALES_CREDIT_TYPE.
 

None
 

Required
 

Not Required
 

Not Required
 

SplitTypeCode
 

The code indicating
the Split type of
the Revenue, such
as ParentSplit or
ChildSplit.
 

Must be a valid value
as per Lookup MOO_
REVN_SPLIT_TYPE.
 

Required
 

Not Required
 

Not Required
 
 

ProductGroupId
 

The unique identifier
of the product group.
 

None
 

Required
 

Not Required
 

Not Required
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Note:  Note the following:
• You can't create revenue lines and split revenue line in a single import. You must create a revenue line first and

then a split revenue line. You can also create split revenue lines on an existing revenue line.

• Ensure that the commit size is set to a higher value before running imports for a split revenue line. It should be
more than the maximum number of split children that are present for any given revenue. Also, you must enable
the profile ZCA_STANADR_IMPORT_COMMIT_SIZE.

• To delete a revenue sales credit, you need to update the split percentage of the record to be deleted to 0% and
then delete in a separate request. You can't update and delete using a single .csv file.

• To delete an overlay sales credit, you must provide value for either RevnNumber or RevnId for identifying a
record of Opportunity Revenue. If both are passed then only the RevnId field is checked. Not passing either of
these results in error.

• While passing split lines in .csv, parent split line always has to be added after all child splits to satisfy 100% split
percent validation.

• You should provide value for SplitPercent while importing, otherwise an amount with 0 will be created.

Sample Input CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file. Here is a sample .csv file
to import split revenue line data:

OptyNumber ProdGroupId ResourcePartyId SalesCreditTypeCode SplitPercent SplitParentRevnId

CDRM_121495
 

100000011628005
 

100010032635399
 

QUOTA
 

50
 

300100541953926
 

CDRM_121495
 

100000011628005
 

100010025532672
 

QUOTA
 

50
 

300100541953926
 

Create the Import Activity
After you have the CSV file ready, create an import activity. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Revenue

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

513



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• Best Practices for Sales Credits

Example of Importing Recurring Revenue Data  
You can use import management to create, update, and delete recurring revenue data. Recurring schedules in
opportunities enables you to enter and track opportunity products or product groups that are part of a subscription
business model.

For more information see Overview of Recurring Opportunity Products in the Related Topics section.

How You Map Your Source Data to Target Object Attributes
To import your recurring revenue data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new opportunity revenues
or are updating opportunity revenues that have source system reference data, then provide the source system
and source system reference values.
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Required Attributes and Validations for Importing Recurring Revenue Data
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for recurring revenue data records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating a Recurring
Revenue Record

Updating a Recurring
Revenue Record

Deleting a Recurring
Revenue Record

RevnId
 

The unique identifier
of the summary
revenue for this
Opportunity.
 

Not applicable
 

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
 

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
 

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
either of these results
in error.
 

OptyId
 

The unique identifier
for the existing
opportunity record in
the destination table.
 

You can obtain
the OptyId for an
existing opportunity
by exporting the
Opportunity object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Not Required
 

Not Required
 

OptyNumber
 

The public unique
identifier of the
opportunity.
 

Not applicable.
 

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Not Required
 

Not Required
 

RevnNumber
 

The alternate unique
identifier of the
revenue.
 

Identify the Revenue
Number for an
existing opportunity
revenue using the
Revenue Management
work area and by
exporting the Revenue
object by navigating
to the following
in the Setup and

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing

Conditionally Required
 
Either RevnNumber
or RevnId must
be passed for
identifying a record of
Opportunity revenue.
If both are passed then
only the RevnId field is
checked. Not passing
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating a Recurring
Revenue Record

Updating a Recurring
Revenue Record

Deleting a Recurring
Revenue Record

Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

either of these results
in error.
 

either of these results
in error.
 

either of these results
in error.
 

RecurFrequencyCode
 

The code that
indicates the
frequency of
recurrence for the
child revenue.
 

A list of valid values is
defined in the lookup
MOO_RECURRING_
FREQUENCY.
 

Required
 

Not Required
 

Not Required
 
 

RecurNumberPeriods
 

The number of times
the child revenue
should recur.
 

None
 

Conditionally Required
 
Either
RecurNumberPeriods
or RecurEndDate is
required
 

Not Required
 

Not Required
 

RecurEndDate
 

The date when
the child revenue
recurrence ends.
 

None
 

Conditionally Required
 
Either
RecurNumberPeriods
or RecurEndDate is
required
 

Not Required
 

Not Required
 

RecurStartDate
 

The date when the
recurrence starts.
 

None
 

Conditionally Required
 
Either RecurStartDate
or EffectiveDate is
required
 

Not Required
 

Not Required
 
 

EffectiveDate
 

The date when the
child revenue closes.
 

None
 

Conditionally Required
 
Either RecurStartDate
or EffectiveDate is
required
 

Not Required
 

Not Required
 

ScheduleAction
 

The transient attribute.
Need to pass a
value to indicate the
action to be taken on
recurring schedule
such as ADD and
DELETE.
 

None
 

Required
 

Not Required
 

Required
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Sample Input CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file. Here is a sample .csv file
to import recurring revenue data:

OptyNumber RevnId RecurFrequencyCode RecurNumberPeriods EffectiveDate ScheduleAction

CDRM_123532
 

300100546223965
 

MONTHLY
 

3
 

12/25/2021
 

ADD
 

Create the Import Activity
After you have the CSV file ready, create an import activity. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Revenue

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• Overview of Recurring Opportunity Products

Import Your Opportunity Source Data  
You can use the Import Management to create, update, or delete opportunity source records.

You can import opportunity source records using these steps:

1. Map your source opportunity source data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the opportunity source data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your opportunity source data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.
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You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new opportunity sources
or are updating opportunity sources that have source system reference data, then provide the source system
and source system reference values.

Required Attributes and Validations Opportunity Source Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for opportunity source records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Source
Record

Updating an Existing
Opportunity Source
Record

Deleting an Existing
Opportunity Source
Record

OptySrcId
 

The unique ID
for the existing
campaign source code
relationship record in
the destination table.
 

Identify the ID
for an existing
campaign source
code relationship
by exporting the
Opportunity Source
object by navigating
to the following
in the Setup and

The attribute is
neither required nor
conditionally required.
 

The attribute is
neither required nor
conditionally required.
 

Conditionally required.
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Source
Record

Updating an Existing
Opportunity Source
Record

Deleting an Existing
Opportunity Source
Record

Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

OptyId
 

The unique ID
for the existing
opportunity record in
the destination table.
 

You can obtain
the OptyID for an
existing opportunity
by exporting the
Opportunity object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
 

OptyNumber
 

The public unique
identifier of the
opportunity.
 

Not applicable.
 

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the opportunity source
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Opportunity Source object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity source information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Source from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics

Import Your Opportunity Team Member Data  
You can use the Import Management to create, update, or delete opportunity team member records.

You can import opportunity team member records using these steps:

1. Map your source opportunity team member data to Oracle Applications Cloud object attributes. This way the
import process would know where to insert each of the information bits.

2. Create the source CSV file with the opportunity team member data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your opportunity team member data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.
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• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new opportunity team
members or are updating opportunity team members that have source system reference data, then provide the
source system and source system reference values.

Required Attributes and Validations for Opportunity Team Member Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for opportunity team member records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Team
Member Record

Updating an Existing
Opportunity Team
Member Record

Deleting an Existing
Opportunity Team
Member Record

OptyResourceId
 

The unique identifier
for the opportunity
resource.
 

Not applicable.
 

Required
 

Conditionally Required
 

Conditionally Required
 

OptyId
 

The unique ID
for the existing
opportunity record in
the destination table.
 

You can obtain
the OptyID for an
existing opportunity
by exporting the
Opportunity object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an
Opportunity Team
Member Record

Updating an Existing
Opportunity Team
Member Record

Deleting an Existing
Opportunity Team
Member Record

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

OptyNumber
 

The public unique
identifier of the
opportunity.
 

Not applicable.
 

Conditionally Required
 
Either OptyId or
OptyNumber is
required.
 

Conditionally Required
 

Conditionally Required
 

ResourceId
 

The unique party
ID for the existing
Account Team
Member record.
 

Identify the resource
ID value by exporting
the resource object
by navigating to the
following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area:
Data Import and
Export

• Task: Schedule
Export Processes

The attribute is
neither required nor
conditionally required.
 

To identify the
party, provide
either the record ID
(PartnerAccountId)
or both the source
system code and
reference values that
you provided when
importing the party in
a prior import batch
(PartyOrigSystem
and
PartyOrigSystemReference.
 

The attribute is
neither required nor
conditionally required.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the opportunity team
member object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Opportunity Team Member object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity team member information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
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3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Team
Member from the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I update existing setup data?

How do I import organization data?  
You can use Import Management to create or update Organization records.

To import Organization records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Organization data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.
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• Identify the target object attributes that are required in the CSV file for a successful import.

• Ensure that you don't insert duplicate addresses while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new organizations or are
updating organizations that have source system reference data, then provide the source system and source
system reference values.

Required Attributes and Validations for Organization Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Organization
records, required attributes for updating Organization records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Organization import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Organization
Record

Updating an Existing
Organization Record

SourceSystem
 

The original source system
name
 

Know the source system.
 
To view source systems,
 use the Manage Trading
Community Source System
task.
 

Conditionally Required
 
To identify an organization
record, use one of these:
 

• Combination of
SourceSystem and
SourceSystemReferenceValue

• PartyNumber

Conditionally Required
 
To identify an organization
record, use one of these:
 

• Combination of
SourceSystem and
SourceSystemReferenceValue

• PartyNumber

SourceSystemReferenceValue
 

The identifier in the original
source system
 

Know the source system
reference value.
 
To view the source systems
reference, use the Manage
Trading Community Source
System task.
 

Conditionally Required
 
To identify an organization
record, use one of these:
 

• Combination of
SourceSystem and
SourceSystemReferenceValue

Conditionally Required
 
To identify an organization
record, use one of these:
 

• Combination of
SourceSystem and
SourceSystemReferenceValue
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Organization
Record

Updating an Existing
Organization Record

• PartyNumber • PartyNumber

PartyNumber
 

The public unique identifier
of the party.
 

Know party number.
 
To obtain a list of all party
IDs and party numbers,
 export the Party object.
 

Conditionally Required
 

Conditionally Required
 

OrganizationName
 

The name of the party of
the Organization party
type.
 

The organization names
are listed in the Resource
Directory.
 

Required
 

Conditionally Required
 

PartyUsageCode
 

Specifies the party
usage code to which the
organization is associated
 

This should be an active
value in the HZ_PARTY_
USAGES_B table.
 

Required
 

Not required
 

CleanlinessScore
 

The overall score for
the account or contact
record for the category
Cleanliness
 

No validation
 

Optional
 

Optional
 

CompletenessScore
 

The overall score for
the account or contact
record for the category
Completeness
 

No validation
 

Optional
 

Optional
 

DataConfidenceScore
 

The overall data confidence
score that indicates the
level of data quality for a
record
 

No validation
 

Optional
 

Optional
 

DuplicateIndicator
 

Signifies the duplicate
status of the record that's
determined as follows:
 

• A null value indicates
that the record isn't
a duplicate or hasn't
been evaluated.

• The record can also
have one of 2 other
values - DUPE (record
is a duplicate) or LINK
(record is linked to
another record).

No validation
 

Optional
 

Optional
 

DuplicateScore
 

The overall score for the
account or contact record
for the category Duplicate
 

No validation
 

Optional
 

Optional
 

EnquiryDuns
 

A unique identifier used
to query the Dun and
Bradstreet data. If the

No validation
 

Optional
 

Optional
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Organization
Record

Updating an Existing
Organization Record

location is a branch,
 in some countries the
"DUNS" number of the
headquarters is used to
run the query. Otherwise,
 the "DUNS" number is
considered.
 

EnrichmentScore
 

The overall score for
the account or contact
record for the category
Enrichment
 

No validation
 

Optional
 

Optional
 

LastScoreUpdateDate
 

The date and time at which
this record was updated by
the source system in the
last update source system
column
 

No validation
 

Optional
 

Optional
 

RecencyScore
 

The overall score for the
account or contact record
for the category Recency
 

No validation
 

Optional
 

Optional
 

ThirdPartyFlag
 

This option tracks if a party
has a direct relationship
with the organization
using Oracle receivables
or through a third party
supplier. The value Y
denotes third party
relationship, while the
value N denotes direct
relationship. If Oracle
Service is installed, the
Third Party field in the
Customers window is
mandatory.
 

No validation
 

Optional
 

Optional
 

ValidatedFlag
 

Indicates if the party was
validated. The value Y
denotes a validated party,
 while the value N denotes a
party that's not validated.
 

No validation
 

Optional
 

Optional
 

ValidityScore
 

The overall score for the
account or contact record
for the category Validity
 

No validation
 

Optional
 

Optional
 

You can view the Organization object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
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Create the Source CSV File
You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Organization object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Organization from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Overflow Queue Resource Data  
You can use Import Management to create or update Overflow Queue Resource records.
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To import Overflow Queue Resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Overflow Queue Resource data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new overflow queue
resources or are updating overflow queue resources that have source system reference data, then provide the
source system and source system reference values.

Required Attributes and Validations for Overflow Queue Resource Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Overflow Queue
Resource records, required attributes for updating Overflow Queue Resource records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Overflow Queue Resource import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Overflow
Queue Resource Record

Updating an Existing
Overflow Queue Resource
Record

QueueResourceId
 

The unique identifier of the
overflow queue resource.
 

No Validation
 

Not Required
 

Not Required
 

ObjectId
 

The unique identifier of the
overflow queue added as a
queue resource.
 

The queue should exist.
 

Conditionally Required
 
Either the ObjectId or the
OverflowQueueNumber is
required.
 

Not Required
 

OverflowQueueNumber
 

The public unique identifier
of the overflow queue
associated with the queue.
 

The queue should exist.
 

Conditionally Required
 
Either the ObjectId or the
OverflowQueueNumber is
required.
 

Not Required
 

QueueId
 

The unique identifier of the
queue.
 

The queue should exist.
 

Conditionally Required
 
Either the ObjectId or the
OverflowQueueNumber is
required.
 

Not Required
 

QueueNumber
 

The public unique identifier
of the queue to which the
resource is associated.
 

The queue should exist.
 

 
Conditionally Required
 
Either the ObjectId or the
OverflowQueueNumber is
required.
 

Not Required
 

EnabledFlag
 

Contains the values, True
or False. If True, then the
queue resource member is
enabled. If False, then the
queue resource member
isn't enabled. The default
value is True.
 

No Validation
 

Not Required
 

Not Required
 

Priority
 

The priority of the overflow
queue resource.
 

No Validation
 

Not Required
 

Not Required
 

You can view the Overflow Queue Resource object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
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2. Select the Overflow Queue Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Overflow Queue Resource.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Overflow Queue Resource

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Overflow Queue Resource.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Partner Data  
You can use the Import Management to create or update Partner records.

To import Partner records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Target Object Attributes
To import your Partner data into Oracle Applications Cloud, you need to populate a CSV file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Partner object, this attribute is PartyId:

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Partner object, the attribute is
CompanyNumber.

Required Attributes and Validations for Partner Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

To update the status of a partner, create an import by providing values for the attributes PartyId, Status,and
CompanyNumber in the CSV file.

This table lists the required attributes for importing new Partner records, required attributes for updating Partner
records, prerequisite setup tasks for the attributes, and specific validations, if any, for Partner import:
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Partner
Record

Updating an
Existing Partner
Record

OrganizationName
 

The name of the
organization
 

Text
 

360
 

The value is
required if
creating a new
organization.
 

Required
 

Not required
 

AddressLineOne
 

The first line of the
postal address
 

Text
 

240
 

No validation
 

Required
 

Not required
 

Country
 

The country code
of the postal
address
 

Text
 

2
 

If providing
a value, the
value must exist
in the FND_
TERRITORIES_
B table. You can
view valid country
codes. Navigate
to the following
in the Setup and
Maintenance work
area:
 

• Offering:
Sales

• Functional
Area: Data
Import and
Export

• Task: Manage
Territories

Required
 

Not Required
 

PartyId
 

The unique
ID for the
existing partner
organization's
party record in the
destination table
 

Number
 

18
 

Identify the
PARTY_ID for an
existing partner
party by exporting
the Partner Profile
object. Navigate
to the following
in the Setup and
Maintenance work
area:
 

• Offering:
Sales

• Functional
Area: Data
Import and
Export

• Task: Manage
Bulk Data
Export,
 Schedule
Export
Processes

Not required
 

A value is
required either
for PartyId or
CompanyNumber.
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Partner
Record

Updating an
Existing Partner
Record

CompanyNumber
 

The company
number of the
partner.
 

Text
 

30
 

If providing a value
and importing
a new party in
the same import
batch as this
certification,
 the value must
be unique in
the ZPM_IMP_
PARTNER table. If
providing a value
for an existing
party, the value
must exist in the
ZPM_PARTNER_
PROFILES
table, column
COMPANY_
NUMBER.
 

Not required
 

A value is
required either for
CompanyNumber
or PartyId.
 

You can view the Partner object along with all its child objects and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Partner object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

You can specify the required role while creating the first partner contact for a partner. Also, once the first partner
contact has been created, you can update the role for this partner contact.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Partner from the Object drop-down list.
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4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Partner Account Resource Data  
You can use the import functionality to create or update Partner Account Resource records.

You can import Partner Account Resource records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Partner Account Resource data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Partner Account Resource data into Oracle Applications Cloud from a CSV file containing your source data
that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Partner Account Resource import object.
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• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Partner Account Resources while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Partner Account Resource
attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files,
one for each of the Partner Account Resource child objects. Note that you must have imported the CSV file for Partner
Account Resource object successfully before trying to import the CSV files for the child objects. There are separate help
topics describing how to import each of these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Partner Account
Resource or are updating Partner Account Resource that have source system reference data, then provide the
source system and source system reference values.

Required Attributes and Validations for Partner Account Resource Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Partner Account Resource records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Partner
Account Resource record

Updating an Existing
Partner Account Resource
record

AccessLevelCode
 

The attribute that
determines the access type
(namely, Edit, Full Access,
 View Only) granted to the
resource.
 

A value is required when
adding a new resource to
the team.
 

Not Required
 
If no value is passed, then
the default value, Full
Access is used.
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Partner
Account Resource record

Updating an Existing
Partner Account Resource
record

AssignmentTypeCode
 

The attribute that
determines how the
resource was assigned to
the partner account team.
 

If no value is passed, then
the default value is used.
 

Not Required.
 

Not required
 

PartnerAccountResourceId
 

The primary key of the
resource on the partner
account team.
 

This unique identifier is
auto-generated if no value
is passed.
 

Not required
 

Required
 

ResourceId
 

The unique identifier of the
resource.
 

The value should be a
PartyID of a valid resource.
 

Either the
ResourcePartyNumber or
the ResourceId is required.
 

Not required
 

ResourcePartyNumber
 

The party number of the
resource.
 

The value should be a
PartyNumber of a valid
resource.
 

Either the
ResourcePartyNumber or
the ResourceId is required.
 

Not required
 

PartnerCompanyNumber
 

The company number of
the partner.
 

The value should be a
company number of a valid
partner company.
 

Required
 

Not required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Partner Account
Resource object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Partner Account Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Partner Account Resource information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Partner Account Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
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5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Note:  To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the
Channel operations manager.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Partner Address Data  
You can use the import functionality to create or update Partner Address records.

You can import Partner Address records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Partner Address data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Partner Address data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Partner Address import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.
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• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Partner Address while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Partner Address attributes. However
if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the
Partner Address child objects. Note that you must have imported the CSV file for Partner Address object successfully
before trying to import the CSV files for the child objects. There are separate help topics describing how to import each
of these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Partner Address or
are updating Partner Address that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Partner Address Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Partner Address records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Partner
Address record

Updating an Existing
Partner Address record

LocationId
 

The internal ID for the
location.
 

No validation
 

Not Required
 

Not Required
 

PrimaryFlag
 

The attribute indicates the
primary address of the
partner.
 

No validation
 

Required. If not passed, the
default value, 'N' is used.
 

Not Required
 

Country
 

The country of the
specified partner address.
 

No validation
 

Not Required
 

Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating an Partner
Address record

Updating an Existing
Partner Address record

AddressId
 

The primary key for the
Partner Address record.
 

No validation
 

Auto-generated
 

Required
 

PartyId
 

The party ID of the partner
company.
 

Either the PartyId or
the CompanyNumber is
required.
 

Required
 

Not Required
 

CompanyNumber
 

The company number of
the partner company.
 

Either the PartyId or
the CompanyNumber is
required.
 

Required
 

Not Required
 

AddressNumber
 

The PUID of the address
object.
 

No validation
 

This is auto-generated
or can be passed while
creating a record.
 

Either the AddressNumber
or the AddressId is
required.
 

Go to Navigator > Tools >  Import Management >  Import Objects, to see all the attributes of the Partner Address
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Partner Address object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Partner Address information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Partner Address from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Note:  To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the
Channel operations manager.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Partner Certification Data  
You can use the import functionality to create Partner Certification records.

You can import Partner Certification records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Partner Certification data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Partner Certification data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Partner Certification import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Partner Certification records while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Partner Certification attributes.
However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each
of the Partner Certification child objects. Note that you must have imported the CSV file for Partner Certification object
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successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to
import each of these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. For more information about public unique identifiers, see the
topic "How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and
source system reference is a unique identifier within the external system. If you're importing a new Partner
Certification record that has a source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Partner Certification Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Partner Certification records, prerequisite setup tasks and specific validations,
if any:

Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Partner Certification
record

CertificationCode
 

The code for the certification.
 

No Validation
 

Required
 

PartnerMultivalLovId
 

The primary key for the partner
certification record.
 

No Validation
 

Auto-generated
 

PartnerCompanyNumber
 

The company number of the
partner.
 

No Validation
 

Required
 

Note:  The Update operation isn't supported for Partner Certification records.

Go to Navigator > Tools >  Import Management >  Import Objects, to see all the attributes of the Partner Certification
object. The page also lists attribute information like type, length, description, and so on.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Partner Certification object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Partner Certification information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Partner Certification from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Note:  To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the
Channel operations manager.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel
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Import Your Partner Contact Data  
Use this topic to import Partner Contact data into Oracle Applications Cloud. You can use the Import Management to
create or update Partner Contact records.

To import Partner Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Partner Contact data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Partner Contact object, this attribute is PartyId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
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record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Partner Contact object, the
attribute is PartyNumber.

Required Attributes and Validations for Partner Contact Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Partner Contact records, required attributes for updating
Partner Contact records, prerequisite setup tasks for the attributes, and specific validations, if any, for Partner Contact
import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Partner
Contact record

Updating an
Existing Partner
Contact record

FirstName
 

The first name of
the person
 

Text
 

150
 

A value is required
if creating a new
person party.
 

Required
 

Not required
 

LastName
 

The last name of
the person
 

Text
 

150
 

A value is required
if creating a new
person party.
 

Required
 

Not required
 

EmailAddress
 

The Email address
of the partner
contact
 

Text
 

320
 

While importing
the partner
contacts which
have the
createUserAccountFlag
attribute set to 'Y',
 the username
value must
be unique. If
the username
attribute isn't set,
 then the email
address value
should be unique.
 

Required
 

Not Required
 

CompanyNumber
 

The company
number of the
partner
 

Text
 

30
 

The value must
exist in the column
COMPANY_
MUMBER of the
ZPM_PARTNER_
PROFILES table.
Identify the
COMPANY_
NUMBER for an
existing partner
by exporting the
Partner Profile
object. Navigate
to the following
in the Setup and
Maintenance work
area:

A value is
required either for
CompanyNumber
or PartnerPartyId.
 

Not Required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Partner
Contact record

Updating an
Existing Partner
Contact record

 
• Offering:

Sales

• Functional
Area: Data
Import and
Export

• Task: Manage
Bulk Data
Export,
 Schedule
Export
Processes

PartyNumber
 

The party number
of the contact
 

Text
 

30
 

The PartyNumber
must be unique
when you're
creating a new
record and the
value needs to be
the same as that
of a valid partner
contact, when
you're updating an
existing record.
 

A value is
optionally required
when creating a
record.
 

A value is
required either
for PartyNumber
or PartyId when
updating a record.
 

PartnerPartyId
 

The unique
ID for the
existing partner
organization's
party record in the
destination table
 

Number
 

18
 

Identify the
PARTY_ID for an
existing partner
party by exporting
the Partner Profile
object. Navigate
to the following
in the Setup and
Maintenance work
area:
 

• Offering:
Sales

• Functional
Area: Data
Import and
Export

• Task: Manage
Bulk Data
Export,
 Schedule
Export
Processes

A value is
required either for
CompanyNumber
or PartnerPartyID
when creating a
record.
 

Not required
 

PrimaryFlag
 

Indicates if the
partner contact is a
primary contact
 

String
 

1
 

Set this attribute
for a partner
contact, if the
corresponding
partner doesn't

Required
 

Not required
 

545



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Partner
Contact record

Updating an
Existing Partner
Contact record

have a primary
contact. This can
be either Y or N.
 

Note:  When importing partner contacts, use the CompanyNumber attribute. Don't use the PartnerCompanyNumber
attribute.

You can view the Partner Contact object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Partner Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Partner Contact from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Note:  To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the
Channel operations manager.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Partner Focus Area Data  
You can use the import functionality to create Partner Focus Area records.

You can import Partner Focus Area records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Partner Focus Area data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Partner Focus Area data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Partner Focus Area import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Partner Focus Area records while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Partner Focus Area attributes.
However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each
of the Partner Focus Area child objects. Note that you must have imported the CSV file for Partner Focus Area object
successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to
import each of these child objects.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. For more information about public unique identifiers, see the
topic "How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing a new Partner Focus Area
record that has a source system reference data, then provide the source system and source system reference
values.

Required Attributes and Validations for Partner Focus Area Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Partner Focus Area records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Partner Focus Area
record

ProductName
 

The name of the specialty product.
 

No Validation
 

Either the ProductId or the
ProductName is required.
 

PartnerDimMembersId
 

The primary key of the partner
focus area record.
 

No Validation
 

Auto-generated
 

CompanyNumber
 

The company number of the
partner company.
 

No Validation
 

Required
 

Note:  The Update operation isn't supported for Partner Focus Area records.

Go to Navigator > Tools >  Import Management >  Import Objects, to see all the attributes of the Partner Focus Area
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.
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You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Partner Focus Area object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Partner Focus Area information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Partner Focus Area from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Note:  To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the
Channel operations manager.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Partner Geography Served Data  
You can use the import functionality to create Partner Geography Served records.
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You can import Partner Geography Served records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Partner Geography Served data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Partner Geography Served data into Oracle Applications Cloud from a CSV file containing your source data
that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Partner Geography Served import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Partner Geography Served records while importing, to avoid redundant
data.

If you want to import only a few records, then you can create a single CSV file for all Partner Geography Served
attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files,
one for each of the Partner Geography Served child objects. Note that you must have imported the CSV file for Partner
Geography Served object successfully before trying to import the CSV files for the child objects. There are separate help
topics describing how to import each of these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. For more information about public unique identifiers, see the
topic "How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing a new Partner Geography
Served record that has a source system reference data, then provide the source system and source system
reference values.
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Required Attributes and Validations for Partner Geography Served Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Partner Geography Served records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Partner Geography
Served record

PartnerDimMembersId
 

The primary key for the Partner
Geography Served record.
 

No Validation
 

Auto-generated
 

GeographyName
 

The name of the geography where
the partner is located.
 

No Validation
 

Either the GeographyName or the
GeographyId is required.
 

OwnerId
 

The party ID of the partner.
 

No Validation
 

Either the Owner ID or the
CompanyNumber is required.
 

CompanyNumber
 

The company number of the
partner.
 

No Validation
 

Either the Owner ID or the
CompanyNumber is required.
 

Note:  The Update operation isn't supported for Partner Geography Served records.

Go to Navigator > Tools >  Import Management >  Import Objects, to see all the attributes of the Partner Geography
Served object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Partner Geography Served object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Partner Geography Served information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
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3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select
Partner Geography Served from the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Note:  To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the
Channel operations manager.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Partner Program Country Data  
You can use the Import Management functionality to create or update Partner Program Country records.

To import Partner Program Country records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Partner Program Country data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.
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• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record is through the Internal ID. If you're identifying a record that
already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique
identifier Attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a
record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal
ID typically provides better performance and reduces the import duration. For the Partner Program Country object, this
attribute is ProgramCountryId.

Required Attributes and Validations for Partner Program Country Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Partner Program Country records, required attributes for
updating Partner Program Country records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Partner Program Country import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Partner
Program Country
record

Updating an
Existing Partner
Program Country
record

ProgramCountryID
 

The unique
identifier of the
program country
 

Integer
 

18
 

None
 

Not required
 

Not required
 

CountryCode
 

The public unique
identifier value
for the country
associated with the
partner program
 

String
 

2
 

None.
 

Required
 

Not required
 

PartnerProgramID
 

Unique identifier
for the partner
program
 

Integer
 

18
 

None
 

A value is required
if the program
number isn't
specified.
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Partner
Program Country
record

Updating an
Existing Partner
Program Country
record

ProgramNumber
 

A unique number
generated for each
program
 

Varchar2
 

30
 

None
 

A value is required
if the partner
program ID isn't
specified.
 

Not required
 

You can view the Partner Program Country object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Partner Program Country object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Partner Program Country from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
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2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Partner Program Tier Data  
You can use the Import Management functionality to create, update, or delete Partner Program Tier records.

To import Partner Program Tier records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Partner Program Tier data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.
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The preferred option to uniquely identify an object record is through the internal ID. If you're identifying a record that
already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique
identifier Attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a
record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal
ID typically provides better performance and reduces the import duration. For the Partner Program Tier object, this
attribute is ProgramTierId.

Required Attributes and Validations for Partner Program Tier Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Partner Program Tier records, required attributes for updating
Partner Program Tier records, prerequisite setup tasks for the attributes, and specific validations, if any, for Partner
Program Tier import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating an
Partner Program
Tier record

Updating an
Existing Partner
Program Tier
record

ProgramTierId
 

The unique
identifier of the
program tier
 

Integer
 

18
 

None
 

Not required
 

Required
 

TierId
 

The unique
identifier of the
partner tier
 

Integer
 

18
 

None
 

Required
 

Required
 

PartnerProgramID
 

Unique identifier
and primary key
for the partner
program
 

Integer
 

18
 

None.
 

A value is required
if the program
number isn't
specified.
 

Not Required
 

ProgramNumber
 

A unique number
generated for each
partner program
 

Varchar2
 

30
 

None
 

A value is required
if the partner
program ID isn't
specified.
 

Not required
 

You can view the Partner Program Tier object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Partner Program Tier object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Partner Program Tier from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Partner Type Data  
You can use the import functionality to create Partner Type records.

You can import Partner Type records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Partner Type data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.
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How You Map Your Source Data to Target Object Attributes
You import Partner Type data into Oracle Applications Cloud from a CSV file containing your source data that's mapped
to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Partner Type import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Partner Type records while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Partner Type attributes. However
if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the
Partner Type child objects. Note that you must have imported the CSV file for Partner Type object successfully before
trying to import the CSV files for the child objects. There are separate help topics describing how to import each of
these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. For more information about public unique identifiers, see the
topic "How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing a new Partner Type record
that has a source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Partner Type Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Partner Type records, prerequisite setup tasks and specific validations, if any:
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Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Partner Type record

IntegrationId
 

This is an internal attribute and
should not be used.
 

No Validation
 

Not Required
 

PartnerTypeName
 

The partner type assigned to the
partner.
 

No Validation
 

Either the PartnerTypeName or the
PartnerTypeCode is required.
 

PartnerDimMembersId
 

The primary key of the Partner
Type object.
 

No Validation
 

Auto-generated
 

PartnerCompanyNumber
 

The company number of the
partner.
 

No Validation
 

Required
 

Note:  The Update operation isn't supported for Partner Type records.

Go to Navigator > Tools >  Import Management >  Import Objects, to see all the attributes of the Partner Type object.
The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Partner Type object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Partner Type information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Partner Type from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Note:  To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the
Channel operations manager.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Performance Measure Credit Category Data 

You can use Import Management to create Performance Measure Credit Category records.

To import Credit Category records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import activity.

How You Map Your Source Data to Target Object Attributes
You import Credit Category data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Performance Measure Flex
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Performance
Measure Credit Category records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Performance Measure Credit Category import:

Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Performance Measure
Credit Category record

PerformanceMeasureCreditCategoryId
 

The unique identifier generated
internally that associates a
performance measure with a credit
category.
 

None
 

Not Required
 

PerformanceMeasureId
 

The unique identifier for a
performance measure.
 

Must be the identifier for an
existing performance measure.
 

Required
 

CreditCategoryId
 

The unique identifier of a credit
category.
 

Must be the identifier for an
existing credit category.
 

Conditionally Required. Provide a
value if CreditCategoryName isn’t
populated.
 

CreditCategoryName The name of the credit category. Must be a valid credit category. Conditionally Required. Provide
a value if CreditCategoryId isn’t
populated.

You can view the Performance Measure Credit Category object with its attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Performance Measure Credit Category object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the Performance Measure information. To create
an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Performance Measure

Credit Category from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Performance Measure Flex Data  
You can use Import Management to create and update Performance Measure Flex records.

To import Performance Measure Flex records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import activity.

How You Map Your Source Data to Target Object Attributes
You import Performance Measure Flex data into Oracle Applications Cloud from a CSV file containing your source data
that's mapped to target Oracle Applications Cloud object attributes.
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You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Performance Measure Flex
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Performance
Measure Flex records, required attributes for updating Performance Measure Flex records, prerequisite setup tasks for
the attributes, and specific validations, if any, for Performance Measure Flex import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Performance
Measure Flex record

Updating an Existing
Performance Measure
Flex record

FormulaId
 

The unique identifier of
the performance measure
generated internally.
 

None
 

Required
 

Required
 

__FLEX_Context
 

The flex context segment
code for the performance
measure. It determines
which context-sensitive
segments are displayed.
 

None
 

Conditionally Required.
Provide a value if __FLEX_
Context_DisplayValue isn’t
populated.
 

Conditionally Required.
Provide a value if __FLEX_
Context_DisplayValue isn’t
populated.
 

__FLEX_Context_
DisplayValue
 

The flex context segment
display name for the
performance measure. It
determines which context-
sensitive segments are
displayed.
 

None
 

Conditionally Required.
Provide a value if __FLEX_
Context isn’t populated.
 

Conditionally Required.
Provide a value if __FLEX_
Context isn’t populated.
 

You can view the Performance Measure Flex object with its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Performance Measure Flex object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Performance Measure Flex information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Performance Measure

Flex from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records
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Import Your Performance Measure Rate Dimensional
Input Data  
You can use Import Management to update Performance Measure Rate Dimensional Input records.

To import Performance Measure Rate Dimensional Input records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import activity.

How You Map Your Source Data to Target Object Attributes
You import Performance Measure Rate Dimensional Input Record data into Oracle Applications Cloud from a CSV file
containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Performance Measure Rate
Dimensional Input Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for updating Performance
Measure Rate Dimensional Input records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Performance Measure Rate Dimensional Input import:
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Attribute Description Prerequisite Setup Task/ Import
Validations

Updating an Existing
Performance Measure Rate
Dimensional Input record

PlanComponentInputExpressionId
 

The unique identifier of the input
expression record for the plan
component.
 

This gets created when the rate
table is assigned to the plan
component. So it has to be an
existing value.
 

Required
 

IncentiveFormulaId
 

The unique identifier of the
incentive formula record. There can
be only one incentive formula for
one plan component.
 

None
 

Required
 

RateDimSequence
 

The order of the input expressions
for the rate table.
 

None
 

Required
 

InputExpressionName The name of the input expression
for the rate dimension of a rate
table used in the plan component.

The expression name must exist. Conditionally Required. Provide
a value if InputExpressionId isn’t
populated.

InputExpressionId The unique identifier of the input
expression for the rate dimension
of a rate table.

The expression id must exist. Conditonally Required. Provide a
value if InputExpressionName isn’t
populated.

SplitFlag When splitting the rate across
tiers, the split option can apply
to only one rate dimension input
expression. This specifies which
rate dimension input expression
(rate dimension) to use.

Possible values are Y or N Not Required

You can view the Performance Measure Rate Dimensional Input object with its attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Performance Measure Rate Dimensional Input object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the Performance Measure Rate Dimensional Input
information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Performance Measure

Rate Dimensional Input from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Performance Measure Score Card Data  
You can use Import Management to create and update Performance Measure Score Card records.

To import Performance Measure Score Card records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import activity.

How You Map Your Source Data to Target Object Attributes
You import Performance Measure Score Card data into Oracle Applications Cloud from a CSV file containing your source
data that's mapped to target Oracle Applications Cloud object attributes.
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You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Performance Measure Score
Card Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Performance
Measure Score Card records, required attributes for updating Performance Measure Score Card records, prerequisite
setup tasks for the attributes, and specific validations, if any, for Performance Measure Score Card import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Performance
Measure Score Card
record

Updating an Existing
Performance Measure
Score Card record

PerformanceMeasureScorecardId
 

The unique identifier
generated internally that
associates a scorecard
within a performance
measure.
 

None
 

Not Required
 

Not Required
 

PerformanceMeasureId
 

The unique identifier for a
performance measure.
 

Must be the identifier for
an existing performance
measure.
 

Required
 

Required
 

ScorecardId
 

The unique identifier of the
the scorecard generated
internally.
 

Must be the identifier for an
existing rate table.
 

Conditionally Required.
Provide a value if
ScorecardName isn't
populated.
 

Required
 

ScorecardName The name of the scorecard. Must be the name of an
existing rate table.

Conditionally Required.
Provide a value if
ScorecardId isn’t populated.

Not Required

StartDate The date when the score
card becomes active for the
performance measure.

Must be a valid date. Required Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Performance
Measure Score Card
record

Updating an Existing
Performance Measure
Score Card record

EndDate The date when the
scorecard becomes inactive
for the performance
measure.

Must be a valid date. Not Required Not Required

You can view the Performance Measure Score Card object with its attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Performance Measure Score Card object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Performance Measure information. To create
an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Performance Measure

Score Card from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

How do I import person data?  
You can use import management to create or update Person data.

You can import Person records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Person data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Person data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to
target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Person import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Person while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: You can pass the PUID when creating Person records. If the PUID isn't passed, it
will be auto generated. You can optionally provide the PUID when creating Person records. If you're updating
records, then you can provide an easily understandable public unique identifier. These are, usually, denoted
with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If
you're updating a record with a Number attribute, then use the Number attribute to identify the record. For
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more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records"
in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Persons or are
updating Persons that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Person Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Person records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Person record Updating an Existing
Person record

PartyId
 

The internal ID for the
Person type party
 

When updating the record,
 this should already exist.
 

Not required
 

Conditionally required.
 
To identify a person record,
 use one of these:
 

• Combination of
SourceSystem and
SourceSystemReferenceValue

• PartyNumber

• PartyId

Country
 

The country code of the
postal address
 

Identify valid country
codes using the Setup and
Maintenance, Manage
Territories task.
 

Conditionally required
 
A value is required only
when you're creating an
address for the Person
record.
 

The attribute is neither
required nor conditionally
required.
 

AddressNumber
 

The internal unique
identifier that's internally
generated when creating an
address
 

No validation
 

This is a PUID for Address.
If a value is passed, it will be
imported. Otherwise, it will
be auto-generated.
 

Pass the AddressNumber.
 

OrganizationPartyNumber
 

The party number of the
organization to which the
person is related
 

This should already exist.
 

Not required
 

Not required
 

DeceasedFlag
 

The option that indicates
whether the person
imported is deceased
 

Y or N
 
The default value is N.
 

Not required
 

Not required
 

PartyNumber
 

The unique identifier of the
party
 

Know the party number. To
obtain a list of all party IDs
and party numbers, export
the Person object.
 

This is a PUID for Person. If
a value is passed, it will be
imported. Otherwise, it will
be auto-generated.
 

Conditionally required
 
To identify a person record,
 use one of these:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Person record Updating an Existing
Person record

• Combination of
SourceSystem and
SourceSystemReferenceValue

• PartyNumber

• PartyId

FirstName
 

The first name of the
person
 

No validation
 

Required. A value is
required for the FirstName,
 MiddleName, or LastName.
 

Not required
 

MiddleName
 

The middle name of the
person
 

No validation
 

Required. A value is
required for the FirstName,
 MiddleName, or LastName.
 

Not required
 

LastName
 

The last name of the
person
 

No validation
 

Required. A value is
required for the FirstName,
 MiddleName, or LastName.
 

Not required
 

PartyUsageCode
 

Specifies the party usage
code to which the person is
associated
 

Select one of the following
values:
 

• EXTERNAL_PAYEE

• CONTACT

• PAYMENT_ISSUING_
AUTHORITY

• PARTY_OF_INTEREST

• VIRTUAL_ASSISTANT

• FS_TECH

You can assign a limited
set of unrestricted party
usages through the Person
import object. To create
persons of other types, use
the specific import objects
created for those purposes.
 

Required
 

Not required
 

SourceSystem
 

The original source system
name
 

Know the source system.
To view source systems,
 use the Manage Trading
Community Source System
task.
 

Conditionally required
 
To identify a person record,
 use one of these:
 

• Combination of
SourceSystem and
SourceSystemReferenceValue

• PartyNumber

Conditionally required
 
To identify a person record,
 use one of these:
 

• Combination of
SourceSystem and
SourceSystemReferenceValue

• PartyNumber

• PartyId

SourceSystemReferenceValue
 

The identifier in the original
source system
 

Know the source system
reference value. To view
source system reference,
 use the Manage Trading

Conditionally required
 
To identify a person record,
 use one of these:

Conditionally required
 
To identify a person record,
 use one of these:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Person record Updating an Existing
Person record

Community Source System
task.
 

 
• Combination of

SourceSystem and
SourceSystemReferenceValue

• PartyNumber

 
• Combination of

SourceSystem and
SourceSystemReferenceValue

• PartyNumber

• PartyId

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Person object. The
page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Person object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Person information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Person from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
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3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• Why can't I see the people I just imported?

Import Your Plan Component Data  
You can use Import Management to create and update Plan Component records.

To import Plan Component records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Plan Component data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use the public unique identifier to identify records. If you're
creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted
with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're
updating a record with a Number attribute, then use the Number attribute to identify the record. For more information
about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
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Required Attributes and Validations for the Plan Component Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for creating and updating Plan Component records, prerequisite setup tasks for
the attributes, and specific validations, if any, for Plan Component records import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Plan
Component Record

Updating an Existing Plan
Component Record

PlanComponentId
 

The unique identifier of the
plan component generated
internally.
 

None
 

Not Required
 

Required
 

Name
 

Name of the plan
component.
 

None
 

Required
 

Not Required
 

CalculateIncentive
 

The nature of the plan
component calculating per
event or per interval.
 

Possible values include
COMMISSION for per event,
and BONUS for per interval.
A list of acceptable values is
defined in the lookup CN_
PLAN_INCENTIVE_TYPE.
 

Required
 

Not Required
 

OrgId
 

The unique ID of the
business unit to which the
plan component belongs.
 

Must be a valid business
unit ID.
 

Required
 

Required
 

EarningType
 

The attribute used
to classify earnings
into monetary and
nonmonetary categories.
 

The attribute used
to classify earnings
into monetary and
nonmonetary categories.

  

StartDate
 

The date on which the
plan component becomes
active.
 

Must be a valid date.
 

Required
 

Not Required
 

EndDate
 

The date on which the
plan component becomes
inactive.
 

Must be a valid date.
 

Required
 

Not Required
 

IncentiveType
 

The attribute repesenting
incentive type, such as
bonus or commission
 

Possible values include
BONUS, COMMISSION,
 and STANDARD. A list of
acceptable values is defined
in the lookup CN_REPORT_
GROUP.
 

ValidforCalculation
 

Indicates whether the plan
component is ready for
calculation.
 

Possible values include
COMPLETE for valid and
ready for calculation and
INCOMPLETE for not
valid and not ready for
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Plan
Component Record

Updating an Existing Plan
Component Record

calculation. The default
value is INCOMPLETE. A
list of acceptable values is
defined in the lookup CN_
FORMULA_STATUS.
 

Description
 

The description of the plan
component.
 

None
 

Not Required
 

Not Required
 

CalculationPhase
 

The phase in which the
application considers plan
component for calculation.
Two supported phases:
Phase 1 and Phase 2.
 

Possible values include 1
and 2.The default value is 1.
A list of acceptable values is
defined in the lookup CN_
CALCULATION_PHASE.
 

PaymentPlanCategory
 

The payment plan category
which is used to allocate
payment adjustments
from a participant's
payment plan among plan
components.
 

Possible values include
BONUS , COMMISSION ,
 GUARANTEE , and
STANDARD which is a
generic term applied to
any plan component used
for determining payment
plan adjustments. The
default value is STANDARD.
A list of acceptable values
is defined in the lookup
CN_PAYMENT_PLAN_
CATEGORY.
 

PaymentMadeThroughThirdPartyFlag
 

Indicates whether the
payment for this plan
component can be made
through other resources.
 

Possible values include N
or FALSE and Y or TRUE.
The default value is FALSE.
A list of acceptable values is
defined in the lookup CN_
YES_NO.
 

DisplayName
 

The name of the plan
component that is
displayed on the sales
representative's user
interface.
 

None
 

Not Required
 

Not Required
 

SplitOption
 

Indicates how to split the
input number to a rate table
dimension.
 

Possible values include
NONE to apply a single rate
for the entire attainment,
 NON_PROPORTIONAL
to apply multiple rates,
 which are fixed for an
attainment within a tier,
 PROPORTIONAL to apply
multiple rates, which
are proportional for an
attainment within a tier,
 and PROPORTIONAL_
WITH_THRESHOLD which
is proportional only after

Not Required
 

Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Plan
Component Record

Updating an Existing Plan
Component Record

the first threshold tier. The
default value is NONE. A
list of acceptable values is
defined in the lookup CN_
SPLIT_TYPE_OPTION.
 

You can view the Plan Component object and its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Plan Component object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Compenstation Plan

Component from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Plan Components Flex Data  
You can use Import Management to create and update Plan Components Flexfield records.

To import Plan Component Flexfield records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Plan Component Flexfield data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Plan Component Flexfield
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for creating and updating Plan Component Flexfield records, prerequisite setup
tasks for the attributes, and specific validations, if any, for Plan Component Flexfield records import:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Plan
Component Flexfield
Record

Updating an Existing Plan
Component Flexfield
Record

PlanComponentId
 

The unique identifier of the
plan component generated
internally.
 

None
 

Required
 

Required
 

__FLEX_Context
 

The flex context segment
code for the plan
component. It determines
which context-sensitive
segments are displayed.
 

None
 

Conditionally Required.
Provide a value if __FLEX_
Context_DisplayValue isn’t
populated.
 

Conditionally Required.
Provide a value if __FLEX_
Context_DisplayValue isn’t
populated.
 

__FLEX_Context_
DisplayValue
 

The flex context segment
display name for the plan
component. It determines
which context-sensitive
segments are displayed.
 

None
 

Conditionally Required.
Provide a value if __FLEX_
Context isn’t populated.
 

Conditionally Required.
Provide a value if __FLEX_
Context isn’t populated.
 

Attribute1
 

Attribute 1 of the
descriptive flexfield.
 

None
 

Required
 

Not Required
 

Attribute2
 

Attribute 2 of the
descriptive flexfield.
 

None Not Required
 

Not Required
 

You can view the Plan Component Flexfield object and its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Plan Component Flexfield object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Compenstation Plan

Component from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
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5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Plan Component Incentive Formula Data  
You can use Import Management to update Plan Component Incentive Formula records.

To import Plan Component Incentive Formula records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Plan Component Incentive Formula data into Oracle Applications Cloud, you need to populate a CSV file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Plan Component Incentive
Formula Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for updating Plan Component Incentive Formula records, prerequisite setup tasks
for the attributes, and specific validations, if any, for Plan Component Incentive Formula records import:

Attribute Description Prerequisite Setup Task/ Import
Validations

Updating an Existing Plan
Component Incentive Formula
Record

IncentiveFormulaId
 

The unique identifier for the
incentive formula record. There
can be only one incentive formula
for one plan component. This gets
created when the plan component
header record gets created.
 

This gets created when the plan
component header record gets
created. So IncentiveFormulaId has
to be an existing value.
 

Required
 

IncentiveFormulaExpressionName
 

The name for the expression used
in the incentive formula. This is the
expression that is used to calculate
the earnings.
 

The expression name must exist.
 

Required
 

IncentiveFormulaExpressionId
 

The unique identifier of the
expression record used in the
incentive formula. This is the
expression that is used to calculate
the earnings.
 

The expression id must exist.
 

Conditionally Required.
Provide a value if
IncentiveFormulaExpressionName
isn’t populated.
 

TrueUpFlag
 

Indicates whether the earnings
calculated for the current
period includes the previously
calculated or paid amount
(Cumulative.) Calculation engine
then automatically subtracts
previous earnings from the current
earning calculated.
 

Possible values are Y or N
 

Not Required
 

PayoutFrequency
 

This is the interval value that
determines how often the earning
is calculated. Interval would
represent a unit of time like month,
 quarter, year.
 

The default value is '-1000'. Not Required
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Attribute Description Prerequisite Setup Task/ Import
Validations

Updating an Existing Plan
Component Incentive Formula
Record

ResetInterval
 

It is the span of time for which the
true up or cumulative earnings are
calculated. Interval would represent
a unit of time like month, quarter,
 year.
 

This is applicable only if True Up is
Y.
 

Not Required
 

IncludeIndirectCredits
 

Type of indirect credits to include
in the calculation, for the plan
component.
 

Possible values include ALL for
all indirect credits, MGR for only
rollup indirect credits, NONE for no
indirect credits, and TEAM for only
team indirect credits. The default
value is NONE. A list of acceptable
values is defined in the lookup CN_
PLAN_INDIRECT_CREDIT.
 

Not Required

CalculateEnddateParticipantFlag
 

Indicates whether participants
who have an end date before the
current calculation period are
considered for calculation.
 

Possible values are Y or N. A list of
acceptable values is defined in the
lookup CN_YES_NO. This is only
applicable if Calculate Incentive
field is Per interval ('BONUS').
 

Not Required
 

You can view the Plan Component Incentive Formula object and its attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Plan Component Incentive Formula object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Compenstation Plan

Component from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
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7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

How do I import plan component performance measure
data?  
You can use Import Management to create and update Plan Component Performance Measure records.

To import Plan Component Performance Measure records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Plan Component Performance Measure data into Oracle Applications Cloud, you need to populate a CSV
file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Plan Component Performance
Measure Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for creating and updating Plan Component Incentive Formula records,
prerequisite setup tasks for the attributes, and specific validations, if any, for Plan Component Incentive Formula records
import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Plan
Component Performance
Measure Record

Updating a Plan
Component Performance
Measure Record

PlanComponentPerformanceMeasureId
 

The unique identifier
generated internally
that associates a plan
component with a
compensation plan.
 

None
 

Not Required
 

Required
 

PerformanceMeasureId
 

The unique identifier for a
compensation plan.
 

Must be the identifier for
an existing compensation
plan.
 

Required
 

Required
 

PlanComponentId
 

The unique identifier of a
plan component.
 

Must be the identifier for an
existing plan component.
 

Required
 

Required
 

CalculationSequence
 

Indicates the order in which
the calculation engine
considers a performance
measure within a plan
component.
 

Must be a number. The
default value is 1.
 

Not Required
 

Not Required
 

PerformanceMeasureWeight
 

The percentage of
influence a plan component
has on the compensation
plan.
 

Must be a number. The
default value is 100.

Not Required
 

Not Required
 

EarningBasis
 

Specifies whether
attainment and earnings
calculations use the same
credit categories and
whether the incentive
formula uses the measure
attainment in calculations.
 

Possible values include Y, N.
The default value is Y.
 

Not Required
 

Not Required
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You can view the Plan Component Performance Measure object and its attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Plan Component Performance Measure object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Compensation Plan

Component from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records
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Import Your Plan Component Rate Dimensional Input
Data  
You can use Import Management to update Plan Component Rate Dimensional Input Data records.

To import Compensation Plan Component records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Plan Component Rate Table data into Oracle Applications Cloud, you need to populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Plan Component Rate
Dimensional Input Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for updating Plan Component Rate Dimensional Input records, prerequisite setup
tasks for the attributes, and specific validations, if any, for Plan Component Rate Dimensional Input records import:
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Attribute Description Prerequisite Setup Task/ Import
Validations

Updating an Existing Plan
Component Rate Dimensional
Input Record

PlanComponentInputExpressionId
 

The unique identifier of the input
expression record for the plan
component.
 

This gets created when the rate
table is assigned to the plan
component. So it has to be an
existing value.
 

Required
 

IncentiveFormulaId
 

The unique identifier for the
incentive formula record. There can
only be one incentive formula for
one plan component.
 

None Required
 

RateDimSequence
 

The order of the input expressions
for the rate table.
 

None Required
 

InputExpressionName
 

The name of the input expression
for the rate dimension of a rate
table used in the plan component.
 

The expression name must exist.
 

Conditionally Required. Provide
a value if InputExpressionId isn’t
populated.
 

InputExpressionId
 

The unique identifier of the input
expression for the rate dimension
of a rate table.
 

The expression id must exist. Conditionally Required. Provide
a value if InputExpressionId isn’t
populated.
 

SplitFlag
 

When splitting the rate across
tiers, the split option can apply
to only one rate dimension input
expression. This specifies which
rate dimension input expression
(rate dimension) to use.
 

Possible values are Y or N
 

Not Required
 

You can view the Plan Component Rate Table object and its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Plan Component Rate Dimensional Input object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Compenstation Plan

Component from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Plan Component Rate Table Data  
You can use Import Management to create and update Plan Component Rate Table records.

To import Compensation Plan Component records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Plan Component Rate Table data into Oracle Applications Cloud, you need to populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite steps are complete, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Required Attributes and Validations for the Plan Component Rate Table
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for creating and updating Plan Component Rate Table records, prerequisite setup
tasks for the attributes, and specific validations, if any, for Plan Component Rate Table records import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Plan
Component Rate Table
Record

Updating an Existing Plan
Component Rate Table
Record

PlanComponentRateTableId
 

The unique identifier of the
rate table associated to the
plan component generated
internally.
 

None
 

Not Required
 

Required
 

IncentiveFormulaId
 

The unique identifier
for the incentive record.
There can only be one
incentive formula for one
plan component.
 

This gets created when the
plan component header
record gets created. So
IncentiveFormulaId has to
be an existing value.
 

Required
 

Required
 

RateTableId
 

The unique identifier of the
rate table.
 

The rate table id should
exist in the business unit.
 

Conditionally Required.
Provide a value if
RateTableName isn't
populated.
 

Conditionally Required.
Provide a value if
RateTableName isn't
populated.
 

RateTableName
 

The name of a rate table.
 

The rate table name should
exist in the business unit.
 

Conditionally Required.
Provide a value if
RateTableId isn’t populated.
 

Conditionally Required.
Provide a value if
RateTableId isn’t populated.
 

StartDate
 

The date when the rate
table becomes active for
the plan component.
 

Must be a valid date. Required
 

Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Plan
Component Rate Table
Record

Updating an Existing Plan
Component Rate Table
Record

EndDate
 

The date when the rate
table becomes inactive for
the plan component.
 

Must be a valid date.
 

Required
 

Not Required
 

You can view the Plan Component Rate Table object and its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Plan Component Rate Table object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Compenstation Plan

Component from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Price Book Header Data  
You can use the Import Management functionality to create or update Price Book Header records.

To import Price Book Header records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Price Book Header data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
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are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Price Book Header object, this attribute is PriceBookId .

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Price Book Header object, the
attribute is PricebookCode.

Required Attributes and Validations for Price Book Header Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Price Book Header records, required attributes for updating
Price Book Header records, prerequisite setup tasks for the attributes, and specific validations, if any, for Price Book
Header import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Price
Book Header
Record

Updating an
Existing Price
Book Header
Record

CurrencyCode
 

Specifies
the currency
associated with the
price book header
 

String
 

15
 

LOV validation
for the existing
currency code
 

Required
 

Not required
 

Name
 

Specifies the name
of the price book
header
 

String
 

150
 

Enter a unique
value.
 

Required
 
Enter a unique
value.
 

You can update the
Price book header
only if it's in the
DRAFT status.
 

StatusCode
 

Specifies the pre-
defined code used
to indicate the
status
 

String
 

30
 

When creating a
record, the valid
values are DRAFT
or ACTIVE. When
updating a record,
 the changes
acceptable are:
 

• DRAFT to
ACTIVE

• ACTIVE to
EXPIRED

• EXPIRED to
ACTIVE

Defaults to DRAFT
 

Optional
 

PricebookId
 

A unique identifier
for the price book
 

Long
 

18
 

The value is auto
generated.
 

The value is auto
generated.
 

Required
 

PricebookCode
 

The code
indicating the price
book

String
 

80
 

Setup the on prefix
and radix. Navigate
to the following

The value is auto
generated. You can
also enter a value.

Required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Price
Book Header
Record

Updating an
Existing Price
Book Header
Record

 in the Setup and
Maintenance work
area:
 

• Offering:
Sales

• Functional
Area: Data
Import and
Export

• Task: Manage
Public Unique
Identifier
Sequence
Generation

 

Description
 

A brief description
of the price book
 

String
 

1999
 

No validation
 

Not required
 

Optional
 

HeaderExternalKey
 

Specifies the
external Keys to
identify the price
book header
 

String
 

120
 

The
combination of
HeaderExternalKey
and
HeaderExternalSource
has to be unique.
 

Default Value
 

Optional
 

HeaderExternalSource
 

Specifies the
external source
keys to identify the
price book header
 

String
 

120
 

The
combination of
HeaderExternalKey
and
HeaderExternalSource
has to be unique.
 

Default Value
 

Optional
 

You can view the Price Book Header object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Price Book Header object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Price Book Header from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Price Book Line Data  
You can use the Import Management functionality to create or update Price Book Line records.

To import Price Book Line records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Price Book Line data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Price Book Line object, this attributes are InvItemId,
InvOrgId, PricebookId and PricebookItemId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Price Book Line object, the
attributes are ItemNumber and PricebookCode.

Required Attributes and Validations for Price Book Line Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Price Book Line records, required attributes for updating Price
Book Line records, prerequisite setup tasks for the attributes, and specific validations, if any, for Price Book Line import:
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Price
Book Line Record

Updating an
Existing Price
Book Line Record

InvItemId
 

The internal
identifier of the
item or the product
for which the list
price is specified.
 

Long
 

18
 

Ensure that the
data used is part
of the BASE usage
catalog hierarchy.
 

A value is required
if the primary key
is used.
 

Not required
 

PriceUOMCode
 

The internal code
of the unit of
measure in which
the item or the
product is priced.
 

String
 

30
 

This is validated
for the applicable
UOM for the item
used.
 

Required
 

Optional
 

ItemNumber
 

The number of
the item for which
the list price is
specified.
 

String
 

300
 

Ensure that the
data used is part
of the BASE usage
catalog hierarchy.
 

A value is required
if the PUID is used.
 

A value is required
if the PUID is used.
 

PricebookItemId
 

The internal
identifier of the
price book item.
 

Long
 

18
 

This is auto
generated.
 

A value is auto
generated.
 

A value is required
if the primary key
is used.
 

PricebookId
 

The internal
identifier of the
price book which is
the parent of this
price book line.
 

Long
 

18
 

Parent record
primary key
 

A value is required,
 if the primary key
is used.
 

Not required
 

PricebookCode
 

The unique
identifier of the
price book
 

String
 

80
 

Parent record PUID
 

A value is required
if the PUID is used.
 

A value is required
if the PUID is used.
 

ListPrice
 

The list price of
the item or the
product referred in
the inventory item
ID
 

BigDecimal
 

Ensure that this
value is greater
than zero for
price books either
in "ACTIVE" or
"EXPIRED" status.
 

A value is required,
 if the price book
is either in the
"ACTIVE" or
"EXPIRED" status.
 

Optional
 

ItemExternalSource
 

The external key
and source key
from the source
system are used to
uniquely identify
and update or
delete the price
book line
 

String
 

120
 

Ensure that the
combination of
ItemExternalSource
and
ItemExternalKey is
unique.
 

Not required
 

Optional
 

ItemDescription
 

A brief description
of the price book
item
 

String
 

No validation
 

Not required
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Price
Book Line Record

Updating an
Existing Price
Book Line Record

InvOrgId
 

The unique
identifier of
the inventory
organization
 

Long
 

18
 

Validate for
the applicable
organization ID for
the selected item.
 

A value is required,
 if the primary key
is used.
 

Not required
 

CurrencyCode
 

Specifies
the currency
associated with the
price book header
 

String
 

15
 

Validate for the
existing currency
code.
 

Not required
 

Optional
 

ItemExternalKey
 

The external key
and source key
from the source
system are used to
uniquely identify a
price book which is
the parent of this
price book line
 

String
 

120
 

Ensure that the
combination of
ItemExternalSource
and
ItemExternalKey is
unique.
 

Not required
 

Optional
 

You can view the Price Book Line object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Price Book Line object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Enter Import Options page, provide a name for the import activity, and select Price Book Line from the

Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
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5. In the Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Product Data  
You can use the Import Management functionality to create or update Product records.

To import Product records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Product data into Oracle Applications Cloud, you need to populate a CSV file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

598



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Product object, the attributes are OrganizationId and
InventoryItemId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Product object, the attribute is
ItemNumber.

Required Attributes and Validations for Product Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Product records, required attributes for updating Product
records, prerequisite setup tasks for the attributes, and specific validations, if any, for Product import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Product Record

Updating an
Existing Product
Record

OrganizationId
 

A value that
uniquely identifies
the organization
 

Long
 

18
 

 
• SCM setup

to create
a master
inventory
organization

• Auto
populates
with value
setup for
"Sales
Products Item
Organization"
under

Don't specify a
value. The value is
auto populated.
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Product Record

Updating an
Existing Product
Record

manage
product
group profile
options

Name
 

Name of the
product
 

String
 

240
 

No validation
 

Required
 

Required
 

DefaultUOMCode
 

The default unit
of measure (UOM)
code for the
product
 

String
 

3
 

SCM setup to
UOM, mandatory
for creating
products. This is a
standard DCL field.
 

Required
 

Not required
 

DefaultUOM
 

The default unit of
measure (UOM) for
the product
 

String
 

25
 

Either the
UOMCode or the
UOM is mandatory.
It is validated
against the UOM
DCL.
 

Required only
when the Default
UOMCode isn't
specified
 

Not required
 

ProductType
 

Specifies the Sales
Product Type
 

String
 

80
 

No validation
 

Not required
 

Not required
 

EligibleToSell
 

Indicates whether
the item can be
sold
 

String
 

80
 

No validation
 

Not required
 

Not required
 

InventoryItemId
 

A unique identifier
for the inventory
item
 

Long
 

18
 

No validation
 

Don't specify a
value. The value is
auto populated.
 

Required
 

ItemNumber
 

Unique system
generated ID of the
product
 

String
 

300
 

This has to be
unique. If you don't
specify a value,
 it will be auto
generated. You
can't update this
value.
 

Required
 
A value is auto
generated, if not
specified. Ensure
that you provide a
unique value.
 

Required
 

ItemCatalogGroupId
 

A unique value that
provides metadata
common to all
items that share
the category
 

Long
 

18
 

No validation
 

Not required
 

Optional
 

Description
 

Brief description of
the product
 

String
 

4000
 

No validation
 

Not required
 

Optional
 

ProductTypeCode
 

Specifies the code
of the product type

String
 

30
 

Select a value from
the drop down list.

Not required
 

Optional
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Product Record

Updating an
Existing Product
Record

  

SalesProductLookup
 

The lookup type
for the sales
product type
 

String
 

80
 

No validation
 

Not required
 

Optional
 

ModelConfigAttributes
 

Model attributes
 

String
 

4000
 

No validation
 

Not required
 

Optional
 

ModelName
 

Name of the model
 

String
 

1000
 

No validation
 

Not required
 

Optional
 

InventoryItemStatusCode
 

Specifies the
status code of the
inventory item
 

String
 

10
 

Defaults to Active
status
 

Required
 
The value is auto
populated to
Active.
 

Optional
 

EligibleToSellFlag
 

Indicates whether
the item can be
sold
 

String
 

1
 

This can be either
Y or N.
 

Required
 
The default value
is Y.
 

Optional
 

EligibleForService
 

Indicates whether
the item is enabled
for service
 

String
 

 This can be Y only
when the sales
product type is
either empty or
has any of the
following values:
 

• Goods

• Installation

• Training

• Subscription

• One time
service

Not required
 

Optional
 

AttachmentEntityName
 

Name of the
attachment entity
 

String
 

 No validation
 

Not required
 

Optional
 

CSSEnabled
 

Enable Customer
Self-Service
 

String
 

1
 

This can be either
Y or N.
 

Not required
 

Optional
 

You can view the Product object along with all its child objects and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.
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You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Product object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Product from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

How do I import product group data?  
You can use the import management to create or update Sales Catalog Product Group or Product Group records.
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To import Product Group/Sales Catalog Product Group records:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import Product Group data into Oracle Applications Cloud, you need to populate a CSV file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You need to set certain options for some attributes in the application before you can populate them. When importing a
child record, ensure that its parent record exists in the database.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Product Group object, this attribute is ProdGroupId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Product Group object, the
attribute is ProductGroupReferenceNumber.

Required Attributes and Validations
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

603



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

This table lists the required attributes for importing new Product Group records, required attributes for updating
Product Group records, prerequisite setup tasks for the attributes, and specific validations, if any, for Product Group
import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Product Group
Record

Updating an
Existing Product
Group Record

ProdGrpDetailsId
 

The unique
identifier of the
product group
details.
 

Long
 

18
 

No validation
 

Not required
 

Not required
 

StartDate
 

The date and time
from when the
product group is
available in the
catalog.
 

Time stamp
 

 The start date can't
be later than the
end date.
 

Not required
 

Optional
 

EndDate
 

The date and time
when the product
group is no longer
available in the
catalog.
 

Time stamp
 

 The end date has
to be later than the
start date.
 

Not required
 

Optional
 

InternalName
 

The product
group's unique
name
 

String
 

150
 

Enter a unique
name.
 

Required
 

This can't be
updated.
 

ProdGroupName
 

The product group
name displayed in
the catalog.
 

String
 

250
 

No validation
 

Required
 

Optional
 

ActiveFlag
 

Indicates whether
the product
group is active or
inactive.
 

String
 

1
 

Enter either Y or N.
 

Defaults to Y
 

Optional
 

AllowDuplicateContentFlag
 

Indicates whether
products or
product groups
are allowed to
be added to the
product group
hierarchy more
than once.
 

String
 

Required
 

Optional
 

Defaults to N
 

Optional
 

ProdGroupId
 

Unique identifier of
the product group
 

Long
 

18
 

No validation
 

A value is auto
generated.
 

Required
 

ProductGroupReferenceNumber
 

The unique value
used to identify the
product group.
 

String
 

50
 

Setup the on prefix
and radix. Navigate
to the following
in the Setup and

A value is auto
generated. You can
also enter a value.
 

Required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Product Group
Record

Updating an
Existing Product
Group Record

Maintenance work
area:
 

• Offering:
Sales

• Functional
Area: Data
Import and
Export

• Task: Manage
Public Unique
Identifier
Sequence
Generation

RevenueRoleCode
 

The code
indicating the
revenue role
associated with
the product group.
For example, Sales
revenue line set or
Sales revenue line
set member.
 

String
 

30
 

FCL validated
against MOO_
REVENUE_ROLE
lookup
 

Not required
 

Optional
 

RevenueCategoryCode
 

The code
indicating the
revenue category
associated with the
product group. For
example, Software,
 Maintenance,
 Service, Training,
 Hardware, or Back
Maintenance.
 

String
 

30
 

FCL validated
against MOO_
REVN_CATEGORY
lookup
 

Not required
 

Optional
 

AllowSelectionFlag
 

Indicates whether
the product group
is available for
selection
 

String
 

1
 

Enter either Y or
N. The import
operation fails, if
updating a record
results in:
 

• Circular
hierarchy

• Parent
product
group
with allow
duplicate N
and child with
Y.

• Hierarchy
with allow
duplicate
N results in

Defaults to Y
 

Optional
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Product Group
Record

Updating an
Existing Product
Group Record

repeated
child/
products.

ModelName
 

Unique name of
the model
 

String
 

1000
 

No validation
 

Not required
 

Optional
 

ModelConfigAttributes
 

Model attributes
 

String
 

4000
 

No validation
 

Not required
 

Optional
 

ProdGroupDescription
 

Brief description of
the product group
 

String
 

1000
 

No validation
 

Not required
 

Optional
 

UsageRootFlag
 

Indicates whether
the product
group is the root
product group in a
hierarchy.
 

String
 

1
 

Enter either Y or N.
 

Defaults to N
 

Optional
 

AttachmentEntityName
 

Unique name of
the Attachment
Entity
 

String
 

255
 

No validation
 

Not required
 

Optional
 

You can view the Product Group object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You provide the .CSV file as input during the file-based data import process. You must populate the .CSV file with the
data you want to import into Oracle Applications Cloud.

You can either create a CSV file on your own or use templates available in preexisting mappings. To download a
template:

1. In the Navigator, under Tools, click Import Management.
2. Click Import Objects tab to open the Import Object Details page.
3. Select the object you're interested in the Import Object Details page and click the Download icon next to that

object name.
4. Save the template CSV file to a location on your desktop.

Note:  To import the product group successfully, you should split the import file into Group, Subgroup, and Item.

You must edit the template CSV file and provide valid values for the required attributes. You can attach different types of
files, giving each file a specific description.
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ProductGroupReferenceNumberInternalName ProdGroupNameProdGroupDescriptionUsageRootFlag ActiveFlag AllowDuplicateContentFlagStartDate EndDate

PGSIImport_
001
 

PGSIImport_
001
InternalName
 

Display
name of
PGSIImport_
001
 

Description of
PGSIImport_
001
 

Y
 

Y
 

Y
 

05/10/2019
10:10
 

06/11/2019
11:11
 

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Product Group from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• How do I import data?
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Import Your Product Group Item Data  
You can use the Import Management functionality to create or update Product Group Item records.

To import Product Group Item records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Product Group Item data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides
better performance and reduces the import duration. For the Product Group Item object, the attributes are
InventoryItemId, InvOrgId, and ProdGroupId, when creating a product group item and ProdGroupItemsId, when
updating a product group item.
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• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Product Group Item object, the
attributes are ParPGReferenceNumber and ProductNumber.

Required Attributes and Validations for Product Group Item Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Product Group Item records, required attributes for updating
Product Group Item records, prerequisite setup tasks for the attributes, and specific validations, if any, for Product Group
Item import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Product Group
Item Record

Updating an
Existing Product
Group Item
Record

ActiveFlag
 

Indicates whether
the product group
item is active or
inactive.
 

String
 

1
 

Enter either Y or N.
 

Defaults to Y
 

Optional
 

StartDate
 

The date and time
when the product
group item is
available in the
catalog.
 

Time stamp
 

 Start date can't be
later than the end
date.
 

Not required
 

Optional
 

InventoryItemId
 

A unique identifier
for the inventory
item
 

Long
 

18
 

No validation
 

Required
 

Not required
 

InvOrgId
 

The unique
identifier of
the inventory
organization
 

Long
 

18
 

No validation
 

Required
 

Not required
 

EndDate
 

The date and time
after which the
product group
item is no longer
available in the
catalog.
 

Time stamp
 

 Start date can't be
later than the end
date.
 

Not Required
 

Optional
 

ProductNumber
 

The product
number/code of
the product
 

String
 

300
 

No validation
 

Required if
importing the
record using the
PUID
 

Required if
updating the
record using the
PUID
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Product Group
Item Record

Updating an
Existing Product
Group Item
Record

ProdGroupItemsId
 

Unique identifier
for a product group
item
 

Long
 

18
 

No validation
 

Auto generated
 

Required if
updating the
record using the ID
 

ProdGroupId
 

Unique identifier
for a product group
 

Long
 

18
 

No validation
 

Required
 

Not required
 

ParPGReferenceNumber
 

The unique value
used to identify the
product group.
 

String
 

50
 

No validation
 

Required if
importing the
record using the
PUID
 

Required if
updating the
record using PUID
 

DisplayOrderNum
 

Number indicating
the order in which
this product group
is displayed in the
sales catalog.
 

Long
 

18
 

No validation
 

Not Required
 

Optional
 

You can view the Product Group Item object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Product Group Item object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Product Group Item from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
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5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Product Group Relation Setup Data  
You can use the Import Management functionality to create or update Product Group Relation Setup records.

To import Product Group Relation Setup records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Product Group Relation Setup data into Oracle Applications Cloud, you need to populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Product Group Relation Setup object, the attributes
are RelProdGroupId and ProdGroupRelationshipId, when creating a Product Group Relation Setup record and
ProdGroupRelationshipId when updating a Product Group Relation Setup record.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Product Group Relation Setup
object, the attributes are PGDetailsReferenceNumber and ParPGReferenceNumber.

Required Attributes and Validations for Product Group Relation Setup
Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Product Group Relation Setup records, required attributes for
updating Product Group Relation Setup records, prerequisite setup tasks for the attributes, and specific validations, if
any, for Product Group Relation Setup import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Product Group
Relation Setup
Record

Updating an
Existing Product
Group Relation
Setup Record

ActiveFlag
 

Indicates whether
the product
group is active or
inactive.
 

String
 

1
 

Enter either Y or N.
 

Defaults to Y
 

Optional
 

RelProdGroupId
 

A unique identifier
of the Product
group relationship
 

Long
 

18
 

This is auto
generated.
 

Required
 

Not Required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Product Group
Relation Setup
Record

Updating an
Existing Product
Group Relation
Setup Record

StartDate
 

The date and time
when the product
group relation is
available in the
catalog.
 

Time stamp
 

The start date can't
be later than the
end date.
 

Not Required
 

Optional
 

EndDate
 

The date and time
when the product
group relation is no
longer available in
the catalog.
 

Time stamp
 

The start date can't
be later than the
end date.
 

Not Required
 

Optional
 

PGDetailsReferenceNumber
 

The unique value
used to identify the
product group.
 

String
 

50
 

No validation
 

Required
 

Required
 

ProdGroupRelationshipId
 

A unique identifier
of the product
group relation
 

Long
 

18
 

No validation
 

Not Required
 
A value is auto
generated.
 

Required
 

ProdGroupId
 

A unique identifier
of the product
group
 

Long
 

18
 

No validation
 

Required
 

Not required
 

ParPGReferenceNumber
 

The unique value
used to identify the
product group.
 

String
 

50
 

No validation
 

Required
 

Required
 

DisplayOrderNum
 

Number indicating
the order in which
this product
group relation is
displayed in the
sales catalog.
 

Long
 

18
 

No validation
 

Not Required
 

Optional
 

You can view the Product Group Relation Setup object along with all its child objects and attributes in the Manage
Import Objects page of the Import Management flow. You can find attribute information like type, length, description,
and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Product Group Relation Setup object in the table and click Download.
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You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Product Group Relation Setup from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Program Benefit Detail Data  
You can use the Import Management to create, update, or delete Program Benefit Details records.

To import Program Benefit Detail records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Target Object Attributes
To import your Program Benefit Detail data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the internal ID. If you're identifying a record that
already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique
identifier Attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a
record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal
ID typically provides better performance and reduces the import duration. For the Program Benefit Detail object, this
attribute is ProgramBenefitDetailID.

Required Attributes and Validations for Program Benefit Detail Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Program Benefit Detail records, required attributes for updating
Program Benefit Detail records, prerequisite setup tasks for the attributes, and specific validations, if any, for Program
Benefit Detail import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating an
Program Benefit
Detail record

Updating an
Existing Program
Benefit Detail
record

ProgramBenefitDetailID
 

The system-
generated unique
identifier for the

Integer
 

18
 

None
 

Not required
 

Required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating an
Program Benefit
Detail record

Updating an
Existing Program
Benefit Detail
record

partner program
benefit
 

ProgramBenefitID
 

The unique
identifier for the
benefit
 

Integer
 

18
 

None
 

Required
 

Not required
 

Name
 

A unique name
for the partner
program benefit
 

Varchar2
 

155
 

None
 

A value is required
if the program
benefit ID isn't
specified.
 

Not Required
 

PartnerProgramID
 

The primary
key and unique
identifier for the
partner program
 

Integer
 

18
 

None
 

A value is required
if the program
number isn't
specified.
 

Not required
 

ProgramNumber
 

A unique number
generated for each
partner program
 

Varchar2
 

30
 

None
 

A value is required
if the partner
program ID isn't
specified.
 

Not required
 

You can view the Program Benefit Detail object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Program Benefit Detail object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Program Benefit Detail

from the Object drop-down list.
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4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Program Enrollments Data  
You can use Import Management to create or update Program Enrollment records.

To import Program Enrollment records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Program Enrollment data into Oracle Applications Cloud, you must populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

617



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides
better performance and reduces the import duration. For the Program Enrollment object, this attribute is
ProgramEnrollmentId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Program Enrollment object, the
attribute is EnrollmentNumber.

Required Attributes and Validations for Program Enrollment Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Program Enrollment records, required attributes for updating
Program Enrollment records, prerequisite setup tasks for the attributes, and specific validations, if any, for Program
Enrollment import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Program
Enrollment record

Updating an Existing
Program Enrollment
record

ProgramEnrollmentId
 

The unique ID for
the existing program
enrollment record.
 

None.
 

Not required
 

A value is required if the
enrollment number isn't
specified.
 

PartnerPartyId
 

The internal ID to identify a
partner
 

The partner can't be in the
Perspective or Rejected
status.
 

A value is required if the
partner company number
isn't specified.
 

Not required
 

PartnerProgramId
 

The internal ID to identify a
program
 

The program needs to be in
the Published status.
 

A value is required if the
program number isn't
specified.
 

Not Required
 

618



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Program
Enrollment record

Updating an Existing
Program Enrollment
record

ProgramNumber
 

The public unique identifier
to identify a program
 

The program needs to be in
the Published status.
 

A value is required if the
partner program ID isn't
specified.
 

Not required
 

PartnerCompanyNumber
 

The public unique identifier
to identify a partner
 

The partner can't be in the
Perspective or Rejected
status.
 

A value is required if the
partner party ID isn't
specified.
 

Not required
 

EnrollmentNumber
 

The public unique identifier
to identify an enrollment
 

None
 

Not required
 

A value is required if the
program enrollment ID isn't
specified.
 

You can view the Program Enrollment object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Program Enrollment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Program Enrollment from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Promotion Data  
You can use Import Management to create or update Promotion records.

To import Promotion records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Promotion data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Promotions or are
updating Promotions that have source system reference data, then provide the source system and source
system reference values.

Required Attributes and Validations for Promotion Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Promotion
records, required attributes for updating Promotion records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Promotion import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Promotion
Record

Updating an Existing
Promotion Record

SalesPromotionId
 

The unique identifier of the
promotion record
 

No validation
 

Not applicable
 
This is system generated.
 

Not applicable
 

StatusCode
 

The status of the
promotion record
 

Navigate to the following in
Setup and Maintenance:
 

• Offering: Sales

• Functional Area: Sales

• Task: Manage
Standard Lookups

Search for the
Promotion Status
lookup.

Required
 

Required
 

AdjustmentTypeCode
 

The type of promotion
adjustment
 

Validation based on lookup
type Promotion Adjustment
Types
 

Required
 

Required
 

Name
 

The name of the promotion
 

No validation
 

Required
 

Required
 

SalesPromotionCode
 

The promotion code
applicable to the promotion
 

No validation
 

Optional
 

Optional
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You can view the Promotion object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Promotion object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Promotion from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?
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Import Your Queue Data  
You can use Import Management to create or update Queue records.

To import Queue records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Queue data into Oracle Applications Cloud, you need to populate a CSV file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new queues or are
updating queues that have source system reference data, then provide the source system and source system
reference values.
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Required Attributes and Validations for Queue Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Queue records,
required attributes for updating Queue records, prerequisite setup tasks for the attributes, and specific validations, if
any, for Queue import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Queue Record Updating an Existing
Queue Record

QueueId
 

The unique identifier of the
queue.
 

No Validation
 

Not Required
 

Conditionally Required
 
Either the QueueId or the
QueueNumber is required.
 

QueueName
 

The name of the queue.
 

No Validation
 

Required
 

Not Required
 

EnabledFlag
 

Contains the values, True or
False. If True, the queue is
enabled. If False, the queue
isn't enabled. The default
value is True.
 

No Validation
 

Not Required
 

Not Required
 

ExternalFlag
 

Indicates whether
the automatic agent
assignment on the queue
is handled by Omnichannel
Routing or by a third-party
routing system.
 

No Validation
 

Not Required
 

Not Required
 

StripeCd
 

The lookup code that
defines the stripe code
such as CRM or HCM.
 

No Validation
 

Not Required
 

Not Required
 

AutoRoutingFlag
 

Contains the values, True
or False. If True, then the
queue supports automated
routing. If False, then the
queue supports manual
routing. The default value is
False.
 

No Validation
 

Not Required
 

Not Required
 

OverflowEnabledFlag
 

Indicates whether the
Overflow feature is enabled
in the queue.
 

No Validation
 

Not Required
 

Not Required
 

OwnerPartyId
 

The unique identifier
of the user (resource)
to whom any service
requests in the queue
are assigned. The user
is responsible for further
service request assignment
and scheduling.
 

The party should exist.
 

Conditionally Required
 
Either the OwnerPartyId or
the OwnerPartyNumber is
required.
 

Conditionally Required
 
Either the OwnerPartyId or
the OwnerPartyNumber is
required.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Queue Record Updating an Existing
Queue Record

OwnerPartyNumber
 

The public unique identifier
of the user (resource)
to whom any service
requests in the queue
are assigned. The user
is responsible for further
service request assignment
and scheduling.
 

The party should exist.
 

Conditionally Required
 
Either the OwnerPartyId or
the OwnerPartyNumber is
required.
 

Conditionally Required
 
Either the OwnerPartyId or
the OwnerPartyNumber is
required.
 

QueueNumber
 

The public unique identifier
of the queue.
 

No Validation
 

Not Required
 

Conditionally Required
 
Either the QueueId or the
QueueNumber is required.
 

You can view the Queue object along with all its child objects and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Queue object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Queue from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Queue Resource Data  
You can use Import Management to create or update Queue Resource records.

To import Queue Resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Queue Resource data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new queue resources or
are updating queue resources that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Queue Resource Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Queue Resource
records, required attributes for updating Queue Resource records, prerequisite setup tasks for the attributes, and
specific validations, if any, for Queue Resource import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Queue
Resource Record

Updating an Existing
Queue Resource Record

QueueResourceId
 

The unique identifier of the
queue resource member.
 

No Validation
 

Not Required
 

Required
 

ObjectId
 

The unique identifier of
the individual resource
added as a queue resource
member.
 

The party should exist.
 

Conditionally Required
 
Either the ObjectId or the
PartyNumber is required.
 

Required
 

PartyNumber
 

The public unique identifier
of the party record
associated with the queue
resource member.
 

The party should exist.
 

Conditionally Required
 
Either the ObjectId or the
PartyNumber is required.
 

Required
 

QueueId
 

The unique identifier of the
queue.
 

The queue should exist.
 

Conditionally Required
 
Either the QueueId or the
QueueNumber is required.
 

Not Required
 

QueueNumber
 

The public unique identifier
of the queue to which the
resource is associated.
 

The queue should exist.
 

 
Conditionally Required
 
Either the QueueId or the
QueueNumber is required.
 

Not Required
 

EnabledFlag
 

Contains the values, True
or False. If True, then the
queue resource member is
enabled. If False, then the

No Validation
 

Not Required
 

Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Queue
Resource Record

Updating an Existing
Queue Resource Record

queue resource member
isn't enabled. The default
value is True.
 

You can view the Queue Resource object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Queue Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue Resource.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Queue Resource from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue Resource.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Queue Resource Team Data  
You can use Import Management to create or update Queue Resource Team records.

To import Queue Resource Team records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Queue Resource Team data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.
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• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new queue resource
teams or are updating queue resource teams that have source system reference data, then provide the source
system and source system reference values.

Required Attributes and Validations for Queue Resource Team Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Queue
Resource Team records, required attributes for updating Queue Resource Team records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Queue Resource Team import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Queue
Resource Team Record

Updating an Existing
Queue Resource Team
Record

QueueResourceId
 

The unique identifier of the
queue resource team.
 

No Validation
 

Not Required
 

Not Required
 

ObjectId
 

The unique identifier of the
resource team added as a
queue resource member.
 

The team should exist.
 

 
Conditionally Required
 
Either the ObjectId or the
TeamNumber is required.
 

Not Required
 

TeamNumber
 

The public unique identifier
of the queue resource
team.
 

The team should exist.
 

Conditionally Required
 
Either the ObjectId or the
TeamNumber is required.
 

Not Required
 

QueueId
 

The unique identifier of the
queue.
 

The queue should exist.
 

Conditionally Required
 
Either the QueueId or the
QueueNumber is required.
 

Not Required
 

QueueNumber
 

The public unique identifier
of the queue to which the
resource is associated.
 

The queue should exist.
 

Conditionally Required
 
Either the QueueId or the
QueueNumber is required.
 

Not Required
 

EnabledFlag
 

Contains the values, True
or False. If True, then the
queue resource member is
enabled. If False, then the
queue resource member
isn't enabled. The default
value is True.
 

No Validation
 

Not Required
 

Not Required
 

You can view the Queue Resource Team object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Queue Resource Team object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue Resource Team.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Queue Resource Team

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue Resource Team.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Relationship Data  
You can use the Import Management to create or update Relationship records.
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You can import Relationship records using these steps:

1. Map your source relationship data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.

2. Create the source CSV file with the relationship data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your Relationship data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new relationships or are
updating relationships that have source system reference data, then provide the source system and source
system reference values.

Required Attributes and Validations for Relationship Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for relationship records, prerequisite setup tasks and specific validations, if any:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Relationship
record

Updating an Existing
Relationship record

RelationshipRecId
 

The unique ID for the
existing Relationship record
in the destination table.
 

None
 

Don't provide a value.
 

Conditionally required
 
Either the
RelationshipRecId
or a combination of
RelationshipSourceSystem
and
RelationshipSourceSystemReferenceValue
is required.
 

SubjectPartyId
 

The primary key identifier
of the subject in this
relationship.
 

The party must exist.
 

Either one of
SubjectPartyId,
 SubjectPartyNumber,
 and a combination of
SubjectSourceSystem and
SubjectSourceSystemReferenceValue,
 is used to identify the
subject party of the
relationship.
 

Optional
 
Either one of
SubjectPartyId,
 SubjectPartyNumber,
 and a combination of
SubjectSourceSystem and
SubjectSourceSystemReferenceValue,
 is used to identify the
subject party of the
relationship.
 

RelationshipType
 

The relationship type name.
For example, CUSTOMER_
SUPPLIER. A list of valid
relationship types is
defined in the lookup HZ_
RELATIONSHIP_TYPE.
 
The unique ID for the
existing customer party
record in the destination
table.
 

The party must exist.
 

Required
 

Not required
 

RelationshipCode
 

Indicates whether this is
a forward or a backward
relationship code.
 

A list of valid relationship
codes is defined in
the lookup PARTY_
RELATIONS_TYPE.
 

Required
 

Not required
 

StartDate
 

The date when the
relationship was created.
 

This should be a valid date.
 

Optional
 
Defaults to current date
 

Not required
 

EndDate
 

The date when the
relationship ends.
 

This should be a valid date.
 

Optional
 

Optional
 

SubjectType
 

Subject type of the
relationship type.
 

This should be a valid party
type.
 

Optional
 

Not required
 

ObjectType
 

Object type of the
relationship type.
 

This should be a valid party
type.
 

Optional
 

Not required
 

633



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Relationship
record

Updating an Existing
Relationship record

ObjectPartyId
 

The primary key identifier
of the object in this
relationship.
 

The party must exist.
 

Either one of ObjectPartyId,
 ObjectPartyNumber,
 and combination of
ObjectSourceSystem and
ObjectSourceSystemReferenceValue,
 is used to identify the
object party of the
relationship.
 

Optional
 
Either one of ObjectPartyId,
 ObjectPartyNumber,
 and combination of
ObjectSourceSystem and
ObjectSourceSystemReferenceValue,
 is used to identify the
object party of the
relationship.
 

SubjectPartyNumber
 

Unique identification
number for the subject of
relationship
 

No validation
 

Either the SubjectPartyId or
the SubjectPartyNumber is
required.
 

Either the SubjectPartyId
or SubjectPartyNumber,
 or the combination of
SubjectSourceSystem and
SubjectSourceSystemReferenceValue
is required.
 

ObjectPartyNumber
 

Unique identification
number for the object of
the relationship
 

The party must exist.
 

Either one of ObjectPartyId,
 ObjectPartyNumber,
 and combination of
ObjectSourceSystem and
ObjectSourceSystemReferenceValue,
 is used to identify the
object party of the
relationship.
 

Optional
 
Either one of ObjectPartyId,
 ObjectPartyNumber,
 and combination of
ObjectSourceSystem and
ObjectSourceSystemReferenceValue,
 is used to identify the
object party of the
relationship.
 

SubjectSourceSystem
 

Original System ID for the
Subject of the Relationship
 

The source system should
exist.
 
You can manage source
systems from the Manage
Source Systems task.
 

Conditionally required
 

Conditionally required
 

SubjectSourceSystemReferenceValue
 

Original System Reference
for the Subject of the
Relationship
 

No validation
 

Conditionally Required
 
If the source of your
data is a third party or
external system, and you
intend to import updates
to previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

Conditionally Required
 

ObjectSourceSystem
 

Original System ID for the
Object of the Relationship
 

No validation
 

Conditionally required
 

Conditionally required
 

ObjectSourceSystemReferenceValue
 

Original System Reference
for the Object of the
Relationship
 

No validation
 

Conditionally required
 

Conditionally required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Relationship
record

Updating an Existing
Relationship record

RelationshipSourceSystem
 

Original system of this
relationship
 

The party must exist.
 

Optional
 
If the source of your
data is a third party or
external system, and you
intend to import updates
to previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

Conditionally required
 
Either the
RelationshipRecId
or a combination of
RelationshipSourceSystem
and
RelationshipSourceSystemReferenceValue
is required.
 

RelationshipSourceSystemReferenceValue
 

Original system reference
of this relationship
 

It should be a unique value
for a source system.
 

Optional
 
If the source of your
data is a third party or
external system, and you
intend to import updates
to previously imported
records from the same
system, provide the original
source system and source
system reference values.
 

Conditionally required
 
Either the
RelationshipRecId
or a combination of
RelationshipSourceSystem
and
RelationshipSourceSystemReferenceValue
is required.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the relationship object.
The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Relationship object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the relationship information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Relationship from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

635



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Resolution Link Data  
You can use the import functionality to create or update Resolution Link records.

To import Resolution Link records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Resolution Link data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identifying an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the
internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are
typically internal IDs. Use this option only if you're updating Resolution Links. You can determine the internal
ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query.
Using an internal ID typically provides better performance and reduces the import duration. For the Resolution
Link object, the attribute is LinkId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Resolution Link object, the
attribute is LinkNumber.

Required Attributes and Validations for Resolution Link Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Resolution Link records, required attributes for updating
Resolution Link records, prerequisite setup tasks for the attributes, and specific validations, if any, for Resolution Link
import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Resolution Link
Record

Updating
an Existing
Resolution Link
Record

Link Number
 

The unique
identifier of the
link.
 

String
 

 No validation
 

Optional
 
If you don't provide
a value, the LinkId
is considered by
default.
 

Required
 

Link Status
 

The status of a
link. The list of
accepted values
are A (active) and I
(inactive).

String
 

 You can't create an
inactive link.
 

Optional
 

Optional
 
Update the status
to I to delete a link.
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Resolution Link
Record

Updating
an Existing
Resolution Link
Record

 

PartyType
 

The party type that
defines whether
the party is an
organization, a
person, a contact
or any other user-
defined party type.
 

String
 

 No validation
 

Required
 

You can't update
the resolution link.
 

You can view the Resolution Link object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data
you want to import into Oracle Applications Cloud.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Resolution Link object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Resolution Link from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.
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Review the Import Results
You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Resolution Link Member Data  
You can use the import functionality to create or update Resolution Link Member records.

To import Resolution Link Member records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Resolution Link Member data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

639



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identifying an object record is through the public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Resolution Link Member object, the attributes are LinkNumber and PartyNumber.

Required Attributes and Validations for Resolution Link Member Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Resolution Link records, required attributes for updating
Resolution Link Member records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Resolution Link Member import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Resolution Link
Member Record

Updating
an Existing
Resolution Link
Member Record

Link Number
 

The unique
identifier of the
link.
 

String
 

 No validation
 

Required
 

Required
 

PartyId
 

The unique
internal identifier
of a link member.
 

Long
 

18
 

Either the
PartyId or the
PartyNumber
is required to
uniquely identify
the link member
record with
which the link is
associated.
 

Conditionally
Required
 

Don't use when
updating a
resolution link
member.
 

PartyNumber
 

The unique
identifier of a link
member.
 

String
 

 No validation
 

Required
 

You can't update
the resolution link.
 

MemberStatus
 

The status of a link
member. The list
of accepted values

String
 

 You can't create
an inactive link
member.

Optional
 

Optional.
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Resolution Link
Member Record

Updating
an Existing
Resolution Link
Member Record

are A (active) and I
(inactive).
 

 Update to I to
remove the link
member.
 

MasterFlag
 

The master
member of the
link.
 

String
 

 The accepted
values are Y or N.
 

Required
 

Optional.
 
Update to Y to
change the master.
 

You can view the Resolution Link Member object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Resolution Link Member object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Resolution Link Member from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
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You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Resource Data  

How do I import resource data?  
You can use import management to create or update resource records.

To import resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your resource data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.

• Have all parent records in place before importing child records.

• Use the Manage Business Unit task to set up appropriate business units.

• Use the Manage Legal Entity task to set up appropriate legal entities .

• Use the Manage Resource Roles task to define resource roles. Sales Administrator role is required to load the
resource data.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new
records, then you can provide a user-friendly public unique identifier (Party Number). If you update a record for which
you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can
use the Number attribute to identify the record. For the resource object, the attribute is ResourcePartyNumber.

Required Attributes and Validations for the Resource Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. When you create a new resource, associated employee records are also
created. For more information about creating resources for existing employee records, see the topic "Example of Adding
Resource Profile to Existing Employees". The following table lists the required attributes for importing new resource
records, required attributes for updating resource records, prerequisite setup tasks for the attributes, and specific
validations, if any, for resource import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Resource
Record

Updating an Existing
Resource Record

FirstName
 

The first name of the
resource.
 

No validation
 

Required
 

Pass the party number as
the key.
 

LastName
 

The last name of the
resource.
 

No validation
 

Required
 

Pass the party number as
the key.
 

BusinessUnit
 

The name of the business
unit associated with the
resource.
 

It should be a valid existing
value.
 

Required
 

Not updatable
 

LegalEntity
 

The name of the legal
entity associated with the
resource.
 

It should be a valid existing
value.
 

Required
 

Not updatable
 

ResourcePartyNumber
 

The public unique identifier
(PUID) of the resource
party.

This should be unique.
 

Conditionally required
 

Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Resource
Record

Updating an Existing
Resource Record

 
This is also known as
Registry Id.
 

This is auto-generated.
However, you can provide
a value to replace the auto-
generated value when
creating the resource
record.
 

ResourceEmail
 

The email address of the
resource
 

The email address must be
unique. Specify the email Id
when creating the resource.
 

Required
 

Pass the party number as
the key.
 

IndividualRoleCode
 

The code that represents
the resource role assigned
to the resource.
 

A resource can have only
one individual role code
assigned for a given
date range. You define
and review resource role
types and codes using the
Manage Resource Roles
task.
 

Conditionally required
 
A value is required when
creating a standalone
resource.
 

Pass the party number as
the key.
 

Username
 

The user account name of
the resource used to login
to the application.
 

The user name has to be
unique.
 

Optional
 

Not Updatable
 

ResourceOrgRoleCode
 

The code indicating
the role of the resource
in association with
organization membership.
For example, SALES_
REPRESENTATIVE, SALES_
MANAGER, and so on.
 

One organization
membership role is allowed
for a given date range.
 

Conditionally required
 
A value is required when
creating a resource as
a part of the resource
hierarchy.
 

Pass the party number as
the key.
 

RawWorkPhoneNumber
 

The work phone number of
the resource
 

No validation
 

Optional
 

Optional
 

WorkPhoneCountryCode
 

The work phone country
code of the resource
 

Enter a value when
you specify the
RawWorkPhoneNumber.
 

Note:
When providing
a value for the
RawWorkPhoneNumber,
 ensure that you also
provide a value for the
WorkPhoneCountryCode.
If you don't enter a valid
WorkPhoneCountryCode,
 the format of the
RawWorkPhoneNumber
will be inaccurate.
 

Conditionally required
 
A value is required
when you provide the
RawWorkPhoneNumber.
 

Conditionally required
 
A value is required
when you provide the
RawWorkPhoneNumber.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Resource
Record

Updating an Existing
Resource Record

RawMobilePhoneNumber
 

The mobile phone number
of the resource
 

No validation
 

Optional
 

Optional
 

MobilePhoneCountryCode
 

The mobile phone country
code of the resource
 

Enter a value when
you specify the
RawMobilePhoneNumber.
 

Conditionally required
 
A value is required
when you provide the
RawMobilePhoneNumber.
 

Conditionally required
 
A value is required
when you provide the
RawMobilePhoneNumber.
 

RawFaxNumber
 

The fax number of the
resource
 

No validation
 

Optional
 

Optional
 

FaxCountryCode
 

The fax country code of the
resource
 

Enter a value when you
specify the RawFaxNumber.
 

Conditionally required
 
A value is required
when you provide the
RawFaxNumber.
 

Conditionally required
 
A value is required
when you provide the
RawFaxNumber.
 

You can view the resource object and attributes in the Manage Import Objects page of the Import Management flow.
You can find attribute information like type, length, description, and so on, on this page.

The following role codes are now available in Import Management.

• ResourceOrgRoleCode - Specifies the role that the resource plays as part of the hierarchy in the organization.

• IndividualRoleCode - Specifies the role assigned to the individual resources. You can also assign additional roles
to the resource in the hierarchy to provide additional privileges to the resource.

You should not use a Resource Users import in Import Management or REST on an environment with full blown HCM
Services implementation. In such cases, Import Management or REST must be used only to convert existing HR workers
as resources. This is because, Resource Users REST API only supports vary basic attributes of the HR person/worker. It
doesn't support Oracle Human Capital Management (HCM) custom attributes defined on HR Person/Worker.
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Note:
• To identify a party number for a resource, you may use File Export, Resource User REST, or resource directory

user interface.

For more information about exporting data, see the topic "Export Data" in the "Related Topics" section.

• In File-based Data Import, resource can be imported to load (create/update) HR workers (Employees
and Contingent Workers) without any resource related attributes. However, this isn't possible in Import
Management.

• You can't create a standalone worker using this feature. To create a standalone worker, use the HCM Data
Loader. For more information about creating a standalone worker, see the Oracle Global Human Resources
Cloud Getting Started with Your HR Implementation guide.

• You can speed up import of up to 5,000 records at a time by using Microsoft Excel macros provided by Oracle.
The macros validate your data entries, provide lists of values, and automatically populate constant values. After
you enter your data, click a button in the macro to import data. Download the Excel macros from the Oracle
Sales: Getting Started with Your Sales Implementation: Import Macros (Document ID 2229503.1) article on My
Oracle Support.

• Loading of only worker attributes isn't supported.

• Resource Team memberships aren't supported.

• Automatic re-parenting of the child organizations or direct employees when a manager leaves the resource
organization isn't supported.

• Move all reporting resources and child organizations to a different organization, when the organization
membership of the current manager is ended either due to the movement of the manager to a different
organization or the termination of the manager.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

You must run the following scheduled processes after creating or updating a resource:

1. Reporting Hierarchy Generation: This job updates the reporting hierarchy in accordance with the changes in
internal resource hierarchy. The resource's reporting manager isn't updated unless you run this scheduled
process. Run this scheduled process after you make any changes to the hierarchy such as changing the
manager or the organization.

For more information about the Reporting Hierarchy Generation scheduled process, see the section
"Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

2. Update Person Search Keywords: The After Batch Load parameter should be set to Y before you run the update
person search keywords schedule process. If you run this scheduled process, you can search the person in the
Manage Users UI. The application searches for keyword values in these attributes of a person's records such as
person name, user name, primary email, primary phone, work location, and so on. Run this scheduled process
when you create a new resource.
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For more information about updating person search keywords, see the section "How You Update Person Search
Keywords" in the Oracle Talent Management Cloud Implementing Talent Management Base guide.

3. Send Pending LDAP Requests: This job processes the pending LDAP requests to provision the user accounts
and roles. You can specify the parameters User Type and Batch Size with this job. You must specify User Type
(usually select All); if you leave it as blank, then this process won't process any requests. If you don't set Batch
Size, the default will be A for automatic, which is 1/10th of the total requests number. You can specify a number
for batch size to instruct the process to group that number of requests together for single batch process. If you
want the process to pick up the FAULTED requests from previous run, you can set Batch Size as AF. Run this
scheduled process when you create a new resource along with the user account.

4. Synchronize User GUID: This job synchronizes the user GUID of users including employees and contingent
workers.

For more information about the Synchronize User GUID scheduled process, see the section "Synchronize User
GUID" in the Understanding Scheduled Processes guide.

Related Topics
• How do I export data?

• How do I import data?

• Schedule the Send Pending LDAP Requests Process

• How do I generate the resource reporting hierarchy?

• How do I synchronize the GUID of users?

How do I create a standalone resource?  
You can import resource data from an external data source into Sales and Fusion Service using Import Management.
You must create or import resources before you can associate them with resource organizations.

Before You Begin
The scenario in this example assumes that the following prerequisites have already been set up.

1. Employees must exist in the application.
2. User accounts and email IDs are set up for the already existing employees.
3. Appropriate business units are set up using the Manage Business Unit task.

To find the business unit, navigate to the following in the Setup and Maintenance work area:

◦ Offering: Sales

◦ Function Area: Data Import and Export

◦ Task: Manage Business Units

4. Appropriate legal entities are set up using the Manage Legal Entities task.

To find the legal entity, navigate to the following in the Setup and Maintenance work area:

◦ Offering: Sales

◦ Function Area: Data Import and Export
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◦ Task: Manage Legal Entities

Scenario
In this scenario, Lina John is created as a SALES_REPRESENTATIVE. You must create a source file (CSV) with the
attributes and import it using import management as shown in this table.

Attribute Name Value

FirstName
 

Lina
 

LastName
 

John
 

UserName
 

LINA.JOHN@VISION.COM
 

ResourceEmail
 

lina.john@vision.com
 

BusinessUnit
 

Vision Corporation Enterprise
 

LegalEntity
 

Vision Corporation
 

IndividualRoleCode
 

SALES_REPRESENTATIVE
 

Note:  To create a Sales Manager, specify SALES_MANAGER for the Individual Role Code attribute.

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.
8. Navigate to Resource Directory and search for Lina in the Search section.
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Related Topics
• How do I import resource data?

• How do I import data?

• Schedule the Send Pending LDAP Requests Process

Example of Creating a Sales Representative in a Resource
Organization  
You can use import management to create resources as a sales representative and add them to the resource hierarchy.
You need to specify additional information such ResourceManagerEmail or ResourceParentOrganizationName to create
a sales representative as a standalone resource.

Before You Begin
The scenario in this example assumes that the following prerequisites have already been set up.

1. Appropriate business units are set up using the Manage Business Unit task.
2. Appropriate legal entities are set up using the Manage Legal Entity task.
3. Email Ids and user names should be unique.

Scenario
In this scenario, Bob Frank is created as a resource with the role SALES_REPRESENTATIVE. You must create a source file
(CSV) with the attributes and import it using import management as shown in this table.

Attribute Name Value

FirstName
 

Bob
 

LastName
 

Frank
 

UserName
 

BOB.FRANK@VISION.COM
 

ResourceEmail
 

bob.frank@vision.com
 

BusinessUnit
 

Vision Corporation Enterprise
 

LegalEntity
 

Vision Corporation
 

ResourceOrgRoleCode
 

SALES_REPRESENTATIVE
 

ResourceManagerEmail
 

charlotte.edwards@vision.com
 

ResourceParentOrganizationName
 

Global HQ
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Note:  Providing the user name is optional. If you don't provide the user name, the application will generate the user
name by default. Provide values either for the ResourceManagerEmail or the ResourceParentOrganizationName
attribute. If neither of these is provided, then the resource is associated with the root resource organization as parent
organization.

When you're creating a new resource user, the CreateUserAccountFlag controls the user account creation for the
resource. The default value for CreateUserAccountFlag is Y. If you don't want the user account to be created, then you
can set the attribute CreateUserAccountFlag to 'N'.

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

To enable or disable notifications for resources, see the section Set Up Event Notifications for Resources in the topic
Import Data.

You must run the following scheduled processes after creating the sales representative in the resource organization:

1. Reporting Hierarchy Generation: This job re-generates the resource reporting hierarchy when there is a change
in the organization hierarchy. For more information about the Reporting Hierarchy Generation scheduled
process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

2. Send Pending LDAP Requests: This job processes the pending LDAP requests to provision the user accounts
and roles. You can specify the parameters User Type and Batch Size with this job. You must specify User Type
(usually select All); if you leave it as blank, then this process won't process any requests. If you don't set Batch
Size, the default will be A for automatic, which is 1/10th of the total requests number. You can specify a number
for batch size to instruct the process to group that number of requests together for single batch process. If you
want the process to pick up the FAULTED requests from previous run, you can set Batch Size as AF. Run this
scheduled process when you create a new resource along with the user account.

3. Update Person Search Keywords: This job copies the keyword values automatically from the originating records
to the PER_KEYWORDS table, where they are indexed to improve search performance.

Related Topics
• How do I import data?
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Example of Creating a Sales Manager in an Existing or New
Resource Organization  
In this example, you create a sales manager using import management and add them to the resource hierarchy. You can
create a new organization or use an existing organization which doesn't have a manager.

Before You Begin
The scenario in this example assumes that the following prerequisites have already been set up.

1. User accounts and e-mail IDs should be unique.
2. Appropriate business units are set up using the Manage Business Unit task.

◦ To find the business unit, navigate to the following in the Setup and Maintenance work area:

- Offering: Sales
- Function Area: Data Import and Export
- Task: Manage Business Units

3. Appropriate legal entities are set up using the Manage Legal Entities task.

◦ To find the legal entity, navigate to the following in the Setup and Maintenance work area:

- Offering: Sales
- Function Area: Data Import and Export
- Task: Manage Legal Entities

Scenario
In this scenario, you create Tom Johnson as a manager of the resource organization North American Sales in the
resource parent organization Global HQ. He is created as a resource with the role of SALES_MANAGER. You must create
a source file (CSV) with the attributes and import it using import management as shown in this table.

Attribute Name Value

FirstName
 

Tom
 

LastName
 

Johnson
 

UserName
 

TOM.JOHNSON@VISION.COM
 

Email
 

tom.johnson@vision.com
 

BusinessUnit
 

Vision Corporation Enterprise
 

LegalEntity
 

Vision Corporation
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Attribute Name Value

ResourceOrgRoleCode
 

SALES_MANAGER
 

ResourceParentOrganizationName
 

Global HQ
 

ResourceOrganizationName
 

North American Sales
 

Note:  Providing the user name is optional. If you don't provide the user name, the application will generate the user
name by default. Provide values either for the ResourceManagerEmail or the ResourceParentOrganizationName
attribute. If neither of these is provided, then the resource is associated with the root resource organization as parent
organization.

The following figure shows the resource Tom Johnson created as a sales manager in the hierarchy.
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To create a top resource in an existing resource organization, you must use the TopResourceFlag attribute in import
management and REST services. This attribute indicates that the resource is a top resource, and is used by the Sales
Setup Assistant.

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
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Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

You must run the following scheduled processes after creating the sales manager:

1. Reporting Hierarchy Generation: This job re-generates the resource reporting hierarchy when there is a change
in the organization hierarchy. For more information about the Reporting Hierarchy Generation scheduled
process see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

2. Send Pending LDAP Requests: This job processes the pending LDAP requests to provision the user accounts
and roles. You can specify the parameters User Type and Batch Size with this job. You must specify User Type
(usually select All); if you leave it as blank, then this process won't process any requests. If you don't set Batch
Size, the default will be A for automatic, which is 1/10th of the total requests number. You can specify a number
for batch size to instruct the process to group that number of requests together for single batch process. If you
want the process to pick up the FAULTED requests from previous run, you can set Batch Size as AF. Run this
scheduled process when you create a new resource along with the user account.

Examples of Adding a Resource to Existing Employees  
You can add a resource to existing employees using import management. You can identify specific employees or
contingent workers in Oracle Human Capital Management (HCM) as resources in Sales and Fusion Service.

You can specify details about a resource using the Resource target import object. This target object saves information
about a resource and allows import of the resource's information, such as resource organization membership and user
account details. After you have identified these new resources, you can assign them to organizations and teams, as
needed.

Scenario
Tory Griffiet is an employee in Oracle Human Capital Management (HCM) and doesn't have any associated resource
information.

In this scenario, Troy Griffiet who's an employee in Oracle Human Capital Management (HCM) is identified to be a
resource in Sales and Fusion Service. Troy is converted to a SALES_REPRESENTATIVE under Ross Hayes. The reporting
hierarchy and organization details of Ross Hayes before Troy Griffiet is moved under him are as shown in this image:

To identify Troy as a resource in Sales and Fusion Service, you must create a source file (CSV) file with the attributes and
import it using import management as shown in this table.
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Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

ResourceOrgRoleCode
 

SALES_REPRESENTATIVE
 

ResourceParentOrganizationName
 

VPSales2_OrgAug
 

Note:  The ResourceOrganizationName attribute is ignored for non-managerial resource.

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when
there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation
scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

Tory Griffiet is now converted from an employee in HCM to a resource in Sales and Fusion Service and all the resource
information is populated.

The reporting hierarchy and organization details of Ross Hayes after Troy has been moved under him are shown in this
image:

Scenario
You can convert an employee to a manager resource and add that employee to the hierarchy. You must create a source
CSV file with the attributes and import it using file-based import, as shown in this table.
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Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

ResourceOrgRoleCode
 

SALES_MANAGER
 

ResourceOrganizationName
 

JSmithOrg
 

ResourceParentOrganizationName
 

Global HQ
 

Scenario
You can convert a resource without adding it to the hierarchy. You must create a source CSV file with the attributes and
import it using file-based import, as shown in this table.

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

IndividualRoleCode
 

SALES_REPRESENTATIVE
 

Examples of Changing a Resource from Manager to a Non-
Manager Role  
You can make role-change related updates to a resource by changing the resource information such as resource role
code and resource role type code. Before you change a manager to a non-manager role, move the employees reporting
to this manager to a different manager.

These scenarios illustrate the various role-change related updates you can make to a resource.

• Sales Manager changed to Sales Representative under the same manager.

• Sales Manager changed to Sales Representative under a different manager.

Sales Manager Changed to Sales Representative under the Same Manager
Geriant Jones is a Sales Manager reporting to Charlotte Edwards. The reporting hierarchy and organization details of
Geriant Jones are as shown in this image:
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In this scenario, Geriant's role is changed to Sales Representative under Charlotte Edwards, without any change in the
reporting hierarchy. Move employees reporting to Geriant Jones to Geriant Jones' parent organization. In this example,
move Ed Joyce under Charlotte Edwards as salesperson before demoting Geriant Jones.

To change Geriant Jones' role to Sales Representative, you must create a source file (CSV) with the attributes listed
in this table and import it using import management. You can use either ResourceParentOrganizationName or
ResourceManagerEmail for Organization or Manager-related changes.

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

ResourceManagerEmail
 

charlotte.edwards@vision.com
 

ResourceOrgRoleCode
 

SALES_REPRESENTATIVE
 

ResourceParentOrganizationName
 

SVP2VisionCorpEntSales_Org
 

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
2. In the Scheduled Processes page, click Schedule New Process.
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3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP
Requests.

4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when
there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation
scheduled process see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

The reporting hierarchy and organization details of Geriant Jones after his role has been changed from
SALES_MANAGER to SALES_REPRESENTATIVE are as follows:

Note:  The sales representatives reporting to the manager being demoted should be moved under their manager's
manager or another manager. In this scenario, Ed Joyce who was reporting to Geriant should be moved under
Charlotte Edwards who was Edward's manager, as shown in this image.

Sales Manager Changed to Sales Representative under a Different Manager
Darren Gough is a Sales Manager reporting to Andrew Flintoff. The reporting hierarchy and organization details of
Darren Gough are as shown in this image:

In this scenario, Darren's role is changed to a Sales Representative and would be reporting to Charlotte Edwards, a
different manager. To change role of Darren Gough from Sales Manager to Sales Representative under Charlotte
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Edwards, you must create a source file (CSV) with the attributes listed in the following table and import it using import
management. You can use either ResourceParentOrganizationName or ResourceManagerEmail for Organization or
Manager-related changes.

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

ResourceOrgManagerEmail
 

charlotte.edwards@vision.com
 

ResourceOrgRoleCode
 

SALES_REPRESENTATIVE
 

ResourceParentOrganizationName
 

SVP2VisionCorpEntSales_Org
 

You can import the source data file

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
2. In the Scheduled Processes page, click Schedule New Process.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP

Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when
there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation
scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.
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Note:  Before demoting the manager, the sales representatives reporting to the manager being demoted should be
moved under their manager's manager or another manager. In this scenario, before Darren's demotion to a different
manager, Rosalie Birch who was reporting to Darren should be moved under Andrew Flintoff who was Darren's
manager as shown in this image.

The reporting hierarchy and organization details of Darren Gough after his role has been changed from
SALES_MANAGER to SALES_REPRESENTATIVE under Charlotte Edwards are as follows:

Examples of Changing a Resource from Non-Manager to a
Manager Role  
You can make role-change related updates to a resource by changing the resource information such as resource role
code and resource role type code. The scenarios herein illustrate the different role-change related updates you can
make to a resource.

• Sales Representative role changed to Sales Manager under the same manager

• Sales Representative role changed to Sales Manager under a different manager

Sales Representative Role Changed to Sales Manager under the Same Manager
Shea Lynn is a Sales Representative reporting to Braun Travis. The reporting hierarchy and organization details of Shea
Lynn are as shown in this image:
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In this scenario, Shea's role is changed to a Sales Manager reporting to Braun Travis, without any change in the
reporting hierarchy. To change the role of Shea Lynn to Sales Manager, you must create a source file (CSV) with the
attributes and import it, as explained in this table.

Attribute Name Value

ResourcePartyNumber
 

Conta504976
 

ResourceOrgRoleCode
 

SALES_MANAGER
 

ResourceOrganization
 

Mgr4Vision_Org
 

ResourceParentOrganizationName
 

Mgr1Vision_Org
 

Note:  Changes performed via import activity will only reflect the day after the end date. The new assignment starts a
day after the end date only.

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when
there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation
scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
2. In the Scheduled Processes page, click Schedule New Process.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP

Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.

The reporting hierarchy and organization details of Shea Lynn after her role has been changed from
SALES_REPRESENTATIVE to SALES_MANAGER as shown in this image:

Sales Representative Role Changed to Sales Manager under a Different Manager
Vang Duffy is a Sales Representative reporting to Braun Travis. The reporting hierarchy and organization details of Vang
Duffy are shown in this image:

In this scenario, Vang's role is changed to a Sales Manager and would be reporting to Ewing Yu, a different manager.
To change Vang Duffy's role to Sales Manager under Ewing Yu, you must create a source file (CSV) with the following
attributes and import it, as explained in this table.
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Attribute Name Value

ResourcePartyNumber
 

Conta504976
 

ResourceOrgRoleCode
 

SALES_MANAGER
 

ResourceOrganization
 

Mgr4Vision_Org
 

ResourceParentOrganizationName
 

Mgr3Vision_Org
 

ResourceOrgManagerEmail
 

ewing.yu@vision.com
 

Note:  Changes performed via import activity will only reflect the day after the end date. The new assignment starts a
day after the end date only.

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when
there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation
scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
2. In the Scheduled Processes page, click Schedule New Process.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP

Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.
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The reporting hierarchy and organization details of Vang Duffy after his role has been changed from
SALES_REPRESENTATIVE to SALES_MANAGER under Ewing Yu are as follows:

Examples of Disabling or Reenabling User Accounts  
You can disable or reenable user accounts using import management. User accounts enable the user to sign in to Sales
and Fusion Service.

When you run the resource import to upload users or enter users in the Manage Users UI, users are created in Sales and
Fusion Service. User accounts for these users are created and maintained in a Lightweight Directory Access Protocol
(LDAP) directory local to CX Sales and Fusion Service by Oracle Identity Management (OIM). You can't delete the user
account. However, you can disable or suspend the user account when an employee leaves your company. When you
disable the user account, it prevents the user from being able to sign in to Sales and Fusion Service. As a result, the
user's access to all the associated transaction objects, such as sales territories, leads, opportunities, and so on, are also
disabled.

Note:  You may want to transfer these transaction objects to another resource user. For information about initiating
mass transfer, see the section "Records Transfer Between Users" in the Implementing Sales guide.

Disabling the user account doesn't mean the termination of the employee work relationship or end dating of the
resource. When an employee's work relationships are terminated and the employee has no roles, the employee's user
account is suspended automatically. If the employee is subsequently rehired, the suspended account is automatically
re-enabled. When an employee is re-hired, depending on availability, you might get the same user account. For
example, an employee Rob Smith has the email Id rob.smith@vision.com before leaving the organization. When he's re-
hired, his email Id is rob.x.smith@vision.com.You can enable or disable user accounts using import management.

These scenarios illustrate the various user account related updates you can make to a resource:

• Disabling User Account

• Reenabling User Account
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Disable the User Account
Pat Tyme is a Sales Director who's an employee at Vision Corporation Enterprise. To view the user information for Pat:

1. Navigate to the following in the Setup and Maintenance work area:

◦ Offering: Sales

◦ Functional Area: Users and Security

◦ Task: Manage Users

2. Search for Pat Tyme. The user account status of Pat Tyme appears in the active status.

In this scenario, Pat Tyme has moved to another organization and all the user accounts must be disabled. To disable the
user account for Pat Tyme, you must create a source file (CSV) with the attributes listed in this table and import it using
import management.

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

UserStatus
 

S
 

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
2. In the Scheduled Processes page, click Schedule New Process.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP

Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.
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As Pat Tyme's user account has been disabled, he won't be able to sign in to Sales and Fusion Service. However, you can
verify if Pat's user account is disabled.

1. Go to Navigator, Tools, Import Management, Import Queue.
2. In the Navigator, select My Team and User and Roles.
3. Search for Pat Tyme.

The user account status of Pat Tyme appears in the inactive status.

Reenable the User Account
Ellis Gibson is a Sales Representative who's an employee at Vision Corporation Enterprise. To view the user information
for Ellis:

1. Go to Navigator, Tools, Import Management, Import Queue.
2. Go to Navigator, My Team, User and Roles.
3. Search for Ellis Gibson.

The user account status of Ellis Gibson appears in the inactive status.

In this scenario, Ellis Gibson has recently joined Vision Corporation Enterprise and he doesn't have a user account. To
enable the user account for Ellis Gibson, you must create a source file (CSV) with the attributes listed in this table and
import it using import management.

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

UserStatus
 

A
 

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
2. In the Scheduled Processes page, click Schedule New Process.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP

Requests.
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4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK and Close.
7. In the Scheduled Processes page, click the Refresh icon.
8. Verify if the status of the process has completed successfully.

As Ellis Gibson's user account has been enabled, he can sign in to Sales and Fusion Service. Alternatively, you can also
verify if Ellis Gibson's user account is enabled.

1. Go to Navigator, Tools, Import Management, Import Queue.
2. Go to Navigator, My Team, User and Roles.
3. Search for Ellis Gibson.

The user account status of Ellis appears in the active status.

Related Topics
• How do I export data?

Examples of Making Manager Transfer Related Updates  
You can transfer a sales representative or sales manager from the existing manager to a new manager using import
management. This new manager might either already exist in the application or be a newly created manager.

You can transfer the resource by changing the resource information such as manager e-mail address or parent
organization name.

The following scenarios illustrate the various manager transfer related updates to a resource.

• Transfer of Sales Representative from the Existing Manager to a Different Manager

• Transfer of Sales Manager from the Existing VP to a Different VP (With the Entire Organization)

Transfer of Sales Representative from the Existing Manager to a Different Manager
Wu Orozco is a Sales Representative reporting to Frank Gibbs. The reporting hierarchy and organization details of Wu
Orozco are as shown in this image:
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In this scenario, Wu is transferred from Frank Gibbs to a different manager, Li Yu, who's already existing in the
application. To transfer Wu Orozco from Frank to Li Yu, you must create a source file (CSV) with the attributes and
import it using import management as shown in this table.

Attribute Name Value

ResourcePartyNumber
 

Conta765974
 

ResourceManagerEmail
 

li.yu@vision.com
 

ResourceParentOrganizationName
 

Mgr3SMVision_Org
 

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when
there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation
scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.
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The reporting hierarchy and organization details of Wu Orozco after he has been transferred from Frank Gibbs to Li Yu
are as shown in this image:

Transfer of Sales Manager from the Existing VP to a Different VP (With the Entire
Organization)
Marsh Tyler is a Sales Manager reporting to Tim May. The reporting hierarchy and organization details of Marsh Tyler
are as shown in this image:

In this scenario, Marsh Tyler is a sales manager and is transferred with his entire organization from Tim May to
Pena Schwartz. Pena Schwartz is another vice-president already existing in the application. When Marsh Tyler is
transferred, by default, his entire organization moves with him. Therefore, Noble Hooper who reports to Marsh Tyler
is also moved along with Marsh. To transfer Marsh from Tim May to Pena Schwartz, you must create a source file
(CSV) with the attributes and import it using import management as shown in this table. Provide a value either for the
ResourceOrgManagerEmail or the ResourceParentOrganizationName attribute.

670



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

ResourceOrgManagerEmail
 

pena.schwartz@vision.com
 

ResourceParentOrganizationName
 

SVP2VisionSalesMarketing_Org
 

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when
there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation
scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

The reporting hierarchy and organization details of Marsh Tyler after he has been transferred from Tim May to Pena
Schwartz are as follows:

Note:  The sales representatives reporting to the manager being transferred are moved along with the manager.
In this scenario, Noble Hooper who reports to Marsh Tyler is transferred along with Marsh from Tim May to Pena
Schwartz as shown in this image.

671



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Examples of Making Resource Role Related Updates  
You can make resource role related updates to a resource by changing the resource information such as resource role
code.

The following scenarios illustrate the various resource role related updates you can make to a resource.

• The resource is part of the hierarchy.

• The resource isn't part of the hierarchy.

You can also add a standalone (non-manager or manager) resource to a hierarchy.

Resource is a part of the Hierarchy
Cox Parker is a Sales Representative reporting to Ross Hayes. The reporting hierarchy, organization, and role details of
Cox Parker are displayed as shown in this image:

In this scenario, Cox's role is changed from Sales Representative to Sales Administrator within the same organization. To
change the role of Cox Parker to Sales Administrator, you must create a source file (CSV) with the attributes and import
it using import management as shown in this table.
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Attribute Name Value

ResourcePartyNumber
 

Conta504976
 

ResourceOrgRoleCode
 

SALES_ADMINISTRATOR
 

Note:  You can obtain the ResourcePartyNumber either from the Resource Directory or through Data Export. For
information about obtaining the ResourcePartyNumber either from the Resource Directory or through Data Export,
see the topic "Obtaining the ResourcePartyNumber for a Resource".

Note:   If you specify a value for the ResourceOrgRoleCode attribute, you don't need to specify a value for the
IndividualRoleCode attribute.

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
2. In the Scheduled Processes page, click Schedule New Process.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP

Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when
there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation
scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

The details of Cox Parker after the role change update from SALES_REPRESENTATIVE to SALES_ADMINISTRATOR are
displayed as shown in this image:
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Employee Resource isn't part of the Hierarchy
Pat Tyme is a Sales Manager who's not part of the hierarchy.

In this scenario, Pat's role is changed from Sales Manager to Sales Director. To change Pat's role to Sales Director, you
must create a source file (CSV) with the attributes and import it using import management as shown in this table.

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

IndividualRoleCode
 

SALES_DIRECTOR
 

Note:  This scenario assumes that the user is assigned one IndividualRoleCode.

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
2. In the Scheduled Processes page, click Schedule New Process.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP

Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
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6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.

Adding a Standalone Resource to a Hierarchy
You can add a standalone resource (non-manager or manager) to a hierarchy. To add a resource to the hierarchy, you
must create a source CSV file with the attributes and import it using import management, as shown in this table.

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

ResourceOrgManagerEmail
 

charlotte.edwards@vision.com
 

ResourceParentOrganizationName
 

Global HQ
 

ResourceOrganizationName
 

JsmithOrg
 
(Optional)
 

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when
there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation
scheduled process see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

Note:  Provide values for the ResourcePartyNumber, ResourceOrgManagerEmail, and
ResourceParentOrganizationName attributes when adding a non-manager resource to the hierarchy. Optionally,
provide a value for the ResourceOrganizationName attribute when adding a manager resource to the hierarchy

Examples of Making Resource End-Dating Related Updates  
You can end-date a resource when a worker leaves your enterprise, using import management. This example illustrates
what happens when you end date a Sales Representative and a Sales Manager.

When a worker leaves your enterprise, you terminate them. When you terminate a worker, the person type of the worker
record changes to ex-employee or ex-contingent worker and the associated resource usage is end-dated. However,
the records of the ex-employee or ex-contingent worker remain in the database and you can reinstate or rehire the ex-
employee or ex-contingent worker later to create a new period of service. You can also end date a resource, if you want
to end all the assignments that are associated with the resource.

Note:  You may want to transfer the transaction objects related to end-dated resources to another resource.

These scenarios illustrate the various end-dating changes you can make to a resource.

• End-dating a Sales Representative

• End-dating a Sales Manager
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End-Dating a Sales Representative
Allen King is a Sales Representative reporting to Pat Tyme. The reporting hierarchy and organization details of Allen
King are displayed in this image:

In this scenario, Allen King resigns from Vision Corporation and his resource assignment is end-dated. To end-date
Allen, you must create and import a source file (CSV) with the attributes listed in this table using import management.

Note:  When Allen King is end-dated, all the transaction objects owned by him, such as sales territories, leads,
opportunities, and so on, may need to be manually transferred to his manager or another resource.

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

ResourceEndDate
 

6/12/2020
 

You can import the source data file from the Import Management work area. Then, create mappings between the
attributes in your source data file and the attributes in Sales and Fusion Service using the values given in the table.

The reporting hierarchy and organization details after Allen King is removed from Pat Tyme's organization are displayed
in this image:
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End-Dating a Sales Manager
Nelon Pascal is a Sales Manager reporting to Jane Reifer. The reporting hierarchy and organization details of Nelon
Pascal are displayed in this image:

In this scenario, Nelon Pascal is a sales manager who has two sales representatives, Neya Pali and Carlton Baugh,
reporting to him. Nelon Pascal resigns from Vision Corporation and his resource assignment is end-dated. If the
salespeople in the resource organization have any transactions assigned to them, then these are available once another
manager assumes the vacant resource organization membership as manager. Before Nelon's resource assignment
is end dated, Oracle recommends that you move his reports to a different manager such as Nelon's manager, Jane
Reifer. However, if you want to move Nelon's reports to another manager, then you must provide additional rows in your
source file (CSV) for the reports and specify all the mandatory attributes. To end date Nelon Pascal, you must create a
source file (CSV) with the attributes and import it using import management as listed in this table.

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

ResourceEndDate
 

12/10/2020
 

You can import the source data file from the Import Management work area.

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
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2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
2. In the Scheduled Processes page, click Schedule New Process.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP

Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.

Note:   Before you run the Send Pending LDAP Requests schedule process, you need to run the "Autoprovision Roles
for All Users" schedule process with 'Process Generated Role Requests' parameter to NO to avoid performance issues.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when
there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation
scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

The reporting hierarchy and organization details after Nelon Pascal is removed from Jane Reifer's organization are as
shown in this image.

678



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

How do I update employee information using import
management?  
You can update a resource by changing the resource information such as first name, last name, and email address. You
can also update a resource with additional information such as fax number, phone number, middle name, and so on.

Note:  End dated resources can't be updated using import or REST.

How to update the last name of a resource?
Vang Duffy is a Sales Manager in Sales and Fusion Service. You can view the resource details of Vang Duffy from the
Resource Directory. From the Navigator, click Resource Directory and search for Vang Duffy in the Search section, his
resource details appears as shown in this image.

The reporting hierarchy and organization details of Vang Duffy are as follows:

In this scenario, Vang Duffy changes his name to Vang Smith. To update Vang's last name, you must use the Resource
Party Number and Last Name attributes in your source file. To update Vang's last name from Duffy to Smith, create a
source file (CSV) with these attributes and import it using import management.
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Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

LastName
 

Smith
 

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After running the import file, navigate to Resource Directory and search for Vang in the Search section. The resource
details of Vang after the last name is updated appear as shown in this image:

Also, note that Vang's last name is updated in the reporting hierarchy.
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How to update the email address of a resource?
Rina Nash is a Sales Representative in Sales and Fusion Service. You can view the resource details of Rina Nash from the
Resource Directory. From the Navigator, click Resource Directory and search for Rina Nash in the Search section. Rina's
resource details are displayed.

In this scenario, Rina Nash changes her name to Rina Pinto Jacob after marriage. Rina not only wants to change her last
name, but also wants to update her email ID and middle name.

To update Rina's last name, email address, and middle name, you must create a source file (CSV) with these attributes
and import it using import management. However, in this scenario, to update Rina's email ID, you must provide the
email address in your CSV file.

Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

ResourceEmail
 

rina.jacob@vision.com
 

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.
8. Navigate to Resource Directory and search for Rina in the Search section.

Rina's email address will be updated and visible in the resource pages, such as the resource directory.

How to update the phone number of a resource?

Rina Nash is a Sales Representative in Sales and Fusion Service. You can view the resource details of Rina Nash from the
Resource Directory. From the Navigator, click Resource Directory and search for Rina Nash in the Search section. Rina's
resource details are displayed.

In this scenario, Rina Nash changes her name to Rina Pinto Jacob after marriage. Rina not only wants to change her last
name, but also wants to update her work phone number and middle name.

To update Rina's last name, work phone number, and middle name, you must create a source file (CSV) with these
attributes and import it using import management. However, in this scenario, to update Rina's phone number, you must
provide the work phone country code and work phone number in your CSV file.
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Attribute Name Value

ResourcePartyNumber
 

Conta765976
 

WorkPhoneCountryCode
 

+1
 

RawWorkPhoneNumber
 

510-599-7487
 

You can import the source data file.

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note:  Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about
unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations
are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.
8. Navigate to Resource Directory and search for Rina in the Search section.

Rina's email address is updated and visible in the resource pages, such as the resource directory.

Obtain the ResourcePartyNumber for a Resource  
You can obtain the ResourcePartyNumber for a resource either from the Resource Directory or through data export.

To obtain the ResourcePartyNumber for a resource from the Resource directory:

1. From the Navigator, click Resource Directory.
2. From the Search drop-down list, select one of the following:

◦ First Name

◦ Last Name

◦ E-mail

3. Click Search.
The Registry ID is displayed in the search results.

Alternatively, you can obtain the ResourcePartyNumber for a resource through Data Export. Export data using the
Export Management option from the Tools work area. For information about exporting data, see the topic Export Data.
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Related Topics
• How do I export data?

Import Your Resource Capacity Data  
You can use Import Management to create, delete, or update Resource Capacity records.

To import Resource Capacity records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Resource Capacity data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
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performance and reduces the import duration. For the Resource Capacity object, these attributes are CapacityId
and PartyId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Resource Capacity object, the
attribute is CapacityNumber.

Required Attributes and Validations for Resource Capacity Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Resource Capacity records, required attributes for
updating Resource Capacity records, prerequisite setup tasks for the attributes, and specific validations, if any, for
Resource Capacity import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Resource Capacity
record

Updating an
Existing Resource
Capacity record

CapacityId
 

The unique
resource capacity
identifier.
 

Integer
 

18
 

None
 

Not required
 

Required
 

CapacityNumber
 

The public unique
identifier for
resource capacities
 

String
 

30
 

Default Expression
 

Not required
 

Not required
 

ChannelTypeCd
 

The channel type
that can be used
by a resource
 

String
 

30
 

Expected values
include:
 

• ORA_SVC_
CHAT

• ORA_SVC_
NONE

• ORA_SVC_
VIDEO

• ORA_SVC_
COBROWSE

Required
 

Not Required
 

ObjectTypeCd
 

The object type to
which a resource
can be assigned
 

String
 

30
 

This can be
null. The only
allowed value is
"SVC_SERVICE_
REQUESTS".
 

Not required.
 

Not required
 

MaximumCapacity
 

The maximum
capacity for a
resource in a
channel type and
object type
 

Integer
 

5
 

This value must
be greater than or
equal to zero.
 

Required.
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
Resource Capacity
record

Updating an
Existing Resource
Capacity record

PartyId
 

The resource
unique identifier
 

Integer
 

18
 

This can be null. If
a value is provided,
 the Resource Party
Id must exist.
 

Not required.
 

Not required
 

You can view the Resource Capacity object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Resource Capacities object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Resource Capacity from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
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You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Sales Forecast Quota Data  
You can use Import Management to create, update, or delete your Sales Forecast Quota data.

You can import Sales Forecast Quota records using these steps:

• Map your source data to Oracle Applications Cloud object attributes.

• Create source Comma Separated Values (CSV) file for import.

• Create the import activity.

• Review the import results.

How You Map Your Source Data to Target Object Attributes
You import Sales Forecast Quota data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new action plans or are
updating action plans that have source system reference data, then provide the source system and source
system reference values.

Review Required Attributes and Validations for Sales Forecast Quota
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for Sales Forecast Quota records, prerequisite setup tasks and specific validations,
if any:

Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an Sales
Forecast Quota
Record

Updating an Existing
Sales Forecast Quota
Record

Deleting an Existing
Sales Forecast Quota
Record

ResourceQuotaEffectiveDateThe resource quota
effective date is used
to identify the period
for the sales forecast
quota.

A value must be
provided. The date
format must be in
mm/dd/yy.

Required Not Required Not Required

MetricCode The metric code for
the sales forecast
quota.

Value should match
with RESOURCE_
QUOTA.

Required Not Required Not Required

CorporateMetricValue The corporate metric
value for the sales
forecast quota.

A value must be
provided.

Required Not Required Not Required

MetricValue The metric value in
the entered currency
for the sales forecast
quota.

A value must be
provided.

Required Not Required Not Required
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Attribute Description Prerequisite Setup
Tasks or Import
Validations

Creating an Sales
Forecast Quota
Record

Updating an Existing
Sales Forecast Quota
Record

Deleting an Existing
Sales Forecast Quota
Record

CurrencyCode The currency code
entered for the sales
forecast quota.

A value must be
provided

Required Not Required Not Required

CurrencyConversionRateThe currency
conversion rate from
entered currency to
corporate currency
for the sales forecast
quota.

A value must be
provided.

Required Not Required Not Required

QuotaNumber Finds the sales
forecast quota by
primary by PUID.

None Not Required Required Required

You can view the Sales Forecast Quota object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Sales Forecast Quota information. To create an
import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Forecast Quota from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• How You Use Alternate Keys to Import Records
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How do I import sales lead data?  
Use this topic to import Sales Lead data into Oracle Applications Cloud. You can use the import functionality to create,
update, or delete Sales Lead records.

To import Sales Lead records, perform the following tasks:

1. Map your source sales lead data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

Use the Contact time zone field to save the preferred time zone of a contact pursued on your sales lead. The contact
time zone is based on the contact address and helps you know the preferred time to call or email a prospect or
customer. You can also use the functional "who" columns to save the record history of a sales lead. The columns let you
accurately report on sales leads that are imported from other systems.

Other sales lead management features help to align marketing and sales objectives from sales lead generation to sales
lead execution. Sales Lead information is generated from a variety of sources and obtained from:

• A company's existing contacts

• Marketing campaigns

All sales leads then undergo the qualification and assessment process and are qualified either manually by a
salesperson or automatically based on predefined rules. Finally, qualified sales leads are converted into opportunities.

How You Map Your Source Data to Target Object Attributes
To import your sales lead data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

To better manage your sales lead information, the sales lead object has the following child objects:

• Sales Lead Contact

• Sales Lead Product

• Sales Lead Resource

If you want to import only a few records, then you can create a single CSV file for all sales lead attributes. However if
you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the
sales lead child objects. Note that you must have imported the CSV file for sales lead object successfully before trying
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to import the CSV files for the child objects. There are separate help topics describing how to import each of these child
objects. For more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Sales Lead object, this attribute is LeadId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Sales Lead object, the attribute
is LeadNumber.

Required Attributes and Validations for Sales Lead Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Sales Lead records, required attributes for updating Sales Lead
records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Lead import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Lead
record

Updating an Existing
Sales Lead record

AcceptedDate
 

The date the recommended
lead generated by the Sales
Prediction engine was
accepted by a sales person
or lead qualifier to pursue
 

No validation
 

A value is required if
you specify the value for
LeadAcceptedFlag as Y.
 

Not required
 

ActionCode
 

Indicates explicitly the
operation to be performed
on a row: INSERT to
create a new record in the
destination tables, UPDATE
to update an existing record
in the destination table,

If no value is provided,
 the record is updated if
it already exists. Else, it's
inserted
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Lead
record

Updating an Existing
Sales Lead record

 DELETE to delete the
record.
 

ConvertedTm
 

The date when the lead
was converted to an
opportunity
 

No validation
 

A value is required if you
specify the value for Lead
StatusCd as CONVERTED.
 

Not required
 

LeadName
 

The name that identifies
the lead
 

No validation
 

A value is required if you're
creating a new lead.
 

Not required
 

LeadNumber
 

The Lead's public unique
identifier value
 

If providing a value to
update an existing lead,
 the value must exist in the
column LEAD_NUMBER.of
the MKL_LM_LEADS table.
 

If providing a value and
creating a new lead, the
value must be unique.
 

A value is required, if
updating an existing lead
and you're not providing
the unique ID of the lead
(ObjectKey)
 

ObjectKey
 

The unique ID for the
existing lead record in the
destination table
 

Automatically generated
by the import process
if creating new record.
If updating an existing
record and providing the
LEAD_NUMBER, the import
process defaults the LEAD_
ID.
 

Do not provide a value if
creating a new lead.
 

A value is required, if
updating an existing lead
and you're not providing
the LeadNumber.
 

OwnerId
 

The unique ID for the
existing resource party
in the destination table.
The owner must also be an
internal resource included
as a member of the lead's
sales team
 

If providing a value, the
value must exist in the
column PARTY_ID of the
HZ_PARTIES table, The
value must also exist in
the column PARTY_ID of
the JTF_RS_RESOURCE_
PROFILES table. The
identified party must be
assigned as a sales team
resource for the existing
lead or included in the
resources imported in the
same batch as this record.
 

A value is required, if
creating a new lead and
you don't provide the
owner's source system
code and reference
(OwnerOrigSystem and
OwnerOrigSystemReference)
 

Not required
 

QualifiedDate
 

The date when the lead was
qualified
 

No validation
 

A value is required, if you
optionally provide the lead
status (StatusCd) value as
QUALIFIED, indicating that
the lead is qualified.
 

Not required
 

RejectedTm
 

The date when the lead was
rejected
 

No validation
 

A value is required, if you
optionally provide the
lead registration status
(ApprovalStatus) value as
REJECTED, indicating that
the lead is rejected.
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Lead
record

Updating an Existing
Sales Lead record

RetiredTm
 

The date when the lead was
retired
 

No validation
 

A value is required, if you
optionally provide the lead
status (StatusCd) value as
RETIRED, indicating that
the lead is retired.
 

Not required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the sales lead object.
The page also lists attribute information like type, length, description, and so on.

Note:  Sales lead is hard deleted from the system. You can get information about the deleted leads if you have Audit
Reports enabled while deleting.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Lead object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the sales lead information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Lead from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
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3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Sales Lead Contact Data  
You can use the Import Management to create, update, or delete sales lead contact records.

You can import sales lead contact records using these steps:

1. Map your source sales lead contact data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the sales lead contact data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your sales lead contact data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
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All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new sales lead contacts or
are updating sales lead contacts that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Sales Lead Contact Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for sales lead contact records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Lead
Contact record

Updating an Existing
Sales Lead Contact record

LeadOrigSystem
 

The code that identifies the
original source system for
the sales lead
 

If providing a value and
importing a new sales lead
in the same import as this
lead contact association,
 the value must be part of a
unique combination of the
source system reference
(LeadOrigSystemReference)
and the source system code
(LeadOrigSystem) in the
MKT_IMP_LEADS_T table.
 

Conditionally required,
 when the lead is created in
the same batch as adding a
new lead contact
 

Not required
 

LeadOrigSystemReference
 

The ID that identifies the
original source system
reference for the sales lead
 

If providing a value and
importing a new sales lead
in the same import as this
lead contact association,
 the value must be part of a
unique combination of the
source system reference
(LeadOrigSystemReference)
and the source system code
(LeadOrigSystem) in the
MKT_IMP_LEADS_t table.
 

Conditionally required,
 when the lead is created in
the same batch as adding a
new lead contact
 

Not required
 

LeadId
 

The unique ID for the
existing lead record in the
destination table
 

The value provided must
match the value in the
LEAD_ID column of the
MKL_LM_LEADS table.
 

Conditionally required,
 when the lead is created in
a different batch as adding
a new lead contact.
 

Not required
 

PartyOrigSystem
 

The code that identifies the
original source system for
the contact
 

If providing a value,
 the combination of
source system reference
(PartyOrigSystemReference)

Conditionally required,
 when you don't provide the
contact's party ID (PartyId)
 

Conditionally required,
 when you don't provide
the unique ID for the record
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Lead
Contact record

Updating an Existing
Sales Lead Contact record

and source system code
(PartyOrigSystem) must
exist in the columns ORIG_
SYSTEM_REFERENCE and
ORIG_SYSTEM of the HZ_
ORIG_SYS_REFERENCES
table.
 

(LeadTcMembersId) or the
contact's party ID (PartyId)
 

PartyOrigSystemReference
 

The ID that identifies the
original source system
reference for the contact
 

If providing a value,
 the combination of
source system reference
(PartyOrigSystemReference)
and source system code
(PartyOrigSystem) must
exist in the columns ORIG_
SYSTEM_REFERENCE and
ORIG_SYSTEM of the HZ_
ORIG_SYS_REFERENCES
table.
 

Conditionally required
when you don't provide the
contact's party ID
 

Conditionally required
when you don't provide the
unique ID for the record
(LeadTcMembersId) or the
contact's party ID (PartyId)
 

PartyId
 

The unique ID for the
existing contact's party
record in the destination
table
 

The value provided must
match the value in the
PARTY_ID column of the
HZ_PARTIES table.
 

Conditionally required
when you don't provide
the contact's source
system and source system
reference
 

Conditionally required
when you don't provide
the contact's source
system and source system
reference
 

PrimaryFlag
 

Specifies whether the
provided contact is a
primary contact on the
sales lead
 

The value must be either Y
or N.
 

Conditionally required, as at
least one contact for a lead
has this value set to Y.
 

Conditionally required, as at
least one contact for a lead
has this value set to Y.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the sales lead contact
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Lead Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the sales lead contact information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Lead Contact from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Sales Lead Product Data  
You can use the Import Management to create, update, or delete sales lead product records.

You can import sales lead product records using these steps:

1. Map your source sales lead product data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the sales lead product data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your sales lead product data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.
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You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new sales lead products
or are updating sales lead products that have source system reference data, then provide the source system
and source system reference values.

Required Attributes and Validations for Sales Lead Product Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for sales lead product records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Lead
Product record

Updating an Existing
Sales Lead Product record

ItemId
 

The unique ID for the
existing sales catalog
product (item) record in the
destination table
 

The value provided must
match the value in the
INVENTORY_ITEM_
ID column of the EGP_
SYSTEM_ITEMS_B table.
 

Conditionally required,
 when you don't provide
the ProductName
and ProductGroupId/
ProductGroupName
 

Conditionally required,
 when you don't provide
the ProductName
and ProductGroupId/
ProductGroupName
 

ItemNumber
 

The unique ID for the
existing sales catalog
product (item number)

The value provided must
match the value in the
ITEM_NUMBER column of

Conditionally required,
 when you don't provide
the ProductName

Conditionally required,
 when you don't provide
the ProductName
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Lead
Product record

Updating an Existing
Sales Lead Product record

record in the destination
table
 

the EGP_SYSTEM_ITEMS_
B table.
 

and ProductGroupId/
ProductGroupName
 

and ProductGroupId/
ProductGroupName
 

LeadNumber
 

Leads Public Unique
Identifier value
 

The value provided must
match the value in the
LEAD_NUMBER column of
the MKL_LM_LEADS table.
 

Conditionally required,
 when you don't provide the
LeadId
 

Conditionally required,
 when you don't provide the
LeadId
 

PrimaryFlag
 

Indicates whether the
product or product group
is the primary product of
interest for the lead
 

The value must be either Y
or N.
 

Conditionally required,
 as at least one product or
product group for a lead
has this value set to Y
 

Conditionally required,
 as at least one product or
product group for a lead
has this value set to Y
 

ProductGroupInternalName
 

Internal name for the sales
catalog product group
 

The value provided
must match the value in
the INTERNAL_NAME
column of the QSC_PROD_
GROUPS_B table.
 

Conditionally required,
 when you don't provide
the ProductGroupId and
ItemId/ProductName
 

Conditionally required,
 when you don't provide
the ProductGroupId and
ItemId/ProductName
 

ProductGroupId
 

The unique ID for the
existing product group
record in the destination
table
 

The value provided
must match the value
in the PROD_GROUP_ID
column of the QSC_PROD_
GROUPS_B table.
 

Conditionally required,
 when you don't provide the
ProductGroupName and
ItemId/ProductName
 

Conditionally required,
 when you don't provide the
ProductGroupName and
ItemId/ProductName
 

ProductGroupName
 

The internal name for the
sales catalog product group
 

The value provided
must match the value in
the INTERNAL_NAME
column of the QSC_PROD_
GROUPS_B table.
 

Conditionally required,
 when you don't provide
ProductGroupId and
ItemId/ProductName
 

Conditionally required,
 when you don't provide
ProductGroupId and
ItemId/ProductName
 

ProductName
 

The internal name for the
sales catalog product
 

The value provided must
be defined for the sales
catalog specified for the
QSC_SALES_PRODUCTS_
INVENTORY_ORG_ID
profile.
 

Conditionally required,
 when you don't
provide the ItemId
and ProductGroupId/
ProductGroupName
 

Conditionally required,
 when you don't
provide the ItemId
and ProductGroupId/
ProductGroupName
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the sales lead product
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Lead Product object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the sales lead product information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Lead Product from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Sales Lead Resource Data  
You can use the Import Management to create, update, or delete sales lead resource records.

You can import sales lead resource records using these steps:

1. Map your source sales lead resource data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the sales lead resource data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.
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How You Map Your Source Data to Target Object Attributes
To import your sales lead resource data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new sales lead resources
or are updating sales lead resources that have source system reference data, then provide the source system
and source system reference values.

Required Attributes and Validations for Sales Lead Resource Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for sales lead resource records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Lead
Resource record

Updating an Existing
Sales Lead Resource
record

LeadId
 

The unique ID for the
existing lead record in the
destination table

The value provided must
match the value in the

Conditionally required,
 when you don't provide the
LeadNumber

Conditionally required,
 when you don't provide the
LeadNumber
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Lead
Resource record

Updating an Existing
Sales Lead Resource
record

 LEAD_ID column of the
MKL_LM_LEADS table.
 

  

LeadNumber
 

The Lead's Public Unique
Identifier value
 

The value provided must
match the value in the
LEAD_NUMBER column of
the MKL_LM_LEADS table.
 

Conditionally required,
 when you don't provide the
LeadId
 

Conditionally required,
 when you don't provide the
LeadId
 

LeadOrigSystem
 

The code that identifies the
original source system for
the sales lead
 

If providing a value and
importing a new sales lead
in the same import as this
lead resource association,
 the value must be part of a
unique combination of the
source system reference
(LeadOrigSystemReference)
and the source system code
(LeadOrigsystem) in the
MKT_IMP_LEADS_T table.
 

Conditionally required,
 when the lead is created in
the same batch as adding a
new team member
 

Not required
 

LeadOrigSystemReference
 

The ID that identifies the
original source system
reference for the sales lead
 

If providing a value and
importing a new sales lead
in the same import as this
lead resource association,
 the value must be part of a
unique combination of the
source system reference
(LeadOrigSystemReference)
and the source system code
(LeadOrigSystem) in the
MKT_IMP_LEADS_T table.
 

Conditionally required,
 when the lead is created in
the same batch as adding a
new team member
 

Not required
 

LeadResourceId
 

The unique ID for the
existing sales team
member (resource)
association record in the
destination table
 

Automatically generated by
the import process
 

Automatically generated
by the import process if
creating a new record
 

Required
 

ResourceId
 

The unique ID for the
existing resource's party
record in the destination
table
 

Provided value must match
with PARTY_ID column of
HZ_PARTIES table.
 

Conditionally required,
 when you don't provide
the resource's source
system and source system
reference or the resource's
user name.
 

Conditionally required,
 when you don't provide
the unique ID for the record
or the resource's source
system and source system
reference.
 

ResourceOrigSys
 

The source system code
that identifies the original
source system of the lead
sales team members party
 

If providing a value,
 the combination of
source system reference
(ResourceOrigSysRef)
and source system code
(ResourceOrigSys) must
exist in the columns ORIG_
SYSTEM_REFERENCE and
ORIG_SYSTEM of the HZ_

Conditionally required,
 when you don't provide
the resource's party ID
(ResourceId)
 

Conditionally required,
 when you don't provide
the unique ID for the
record (LeadResourceId)
or the resource's party ID
(ResourceId)
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Lead
Resource record

Updating an Existing
Sales Lead Resource
record

ORIG_SYS_REFERENCES
table.
 

ResourceOrigSysRef
 

The ID that identifies the
lead sales team member's
party in your legacy or
external system
 

If providing a value,
 the combination of
source system reference
(ResourceOrigSysRef)
and source system code
(ResourceOrigSys) must
exist in the columns ORIG_
SYSTEM_REFERENCE and
ORIG_SYSTEM of the HZ_
ORIG_SYS_REFERENCES
table.
 

Conditionally required,
 when you don't provide
the resource's party ID
(ResourceId)
 

Conditionally required,
 when you don't provide
the unique ID for the
record (LeadResourceId)
or the resource's party ID
(ResourceId)
 

UserName
 

The resources application
user name.
 

No validation
 

Conditionally required,
 when you don't provide
the resource's source
system and source system
reference or the resource's
unique ID
 

Not required
 

PrimaryFlag
 

Indicates whether the
resource is the Owner of
the lead
 

The value must be either Y
or N.
 

Conditionally required, as at
least one contact for a lead
has this value set to Y
 

Conditionally required, as at
least one contact for a lead
has this value set to Y
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the sales lead resource
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Lead Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the sales lead resource information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
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3. In the Enter Import Options page, provide a name for the import activity, and select Sales Lead Resource from
the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Sales Objective Data  
You can use the Import Management to create or update Sales Objective records.

To import Sales Objective records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Sales Objective data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Sales Objective object, this attribute is ObjectiveId:

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Sales Objective object, the
attribute is ObjectiveNumber.

Required Attributes and Validations for Sales Objective Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Sales Objective records, required attributes for updating Sales
Objective records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Objective import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Sales
Objective record

Updating an
Existing Sales
Objective record

ObjectiveTypeCode
 

Stores the type of
the objective
 

String
 

30
 

Identify the
objective type.
Navigate to the
following in
the Setup and
Maintenance Work
area:
 

• Offering:
Sales

• Functional
Area: Data
Import and
Export

Required
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Sales
Objective record

Updating an
Existing Sales
Objective record

• Task: Manage
Objective
Types

PeriodTypeCode
 

Specifies the type
of period such as
quarter or year
 

String
 

30
 

Use the Manage
Calendar Profile
Option task to
set a value for
ZCA_COMMON_
CALENDAR..
 

Required
 

Not required
 

Name
 

Objective Name
 

String
 

60
 

No validation
 

Required
 

Not Required
 

StartDisplayPeriodName
 

Objective Start
Period Display
Name
 

String
 

60
 

No validation
 

Required
 

Not Required
 

EndDisplayPeriodName
 

Objective End
Period Display
Name
 

String
 

60
 

No validation
 

Required
 

Not Required
 

ObjectiveId
 

Internal unique
identifier
 

Long
 

18
 

No validation
 

Not required
 

A value is required,
if you don't provide
the PUID.
 

ObjectiveNumber
 

Public unique
identifier
 

String
 

64
 

No validation
 

Not required
 

A value is required,
if you don't provide
the ObjectiveID.
 

You can view the Sales Objective object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Objective object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Objective from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria,

such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note:  On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Sales Promotion Data  
You can use the Import Management to create or update Sales Promotion records.

To import Sales Promotion records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
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3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Sales Promotion Setup data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Promotion object, this attribute is SalesPromotionId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Promotion object, the attribute
is SalesPromotionCode.

Required Attributes and Validations for Sales Promotion Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Sales Promotion records, required attributes for updating
Sales Promotion records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Promotion
import:
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Sales
Promotion Record

Updating an
Existing Sales
Promotion Record

StatusCode
 

A unique identifier
for the current
status of the sales
promotion
 

String
 

30
 

Accepts either
ACTIVE or
INACTIVE
 

This defaults to
Active status.
 

Optional
 

AdjustmentTypeCode
 

Abbreviation that
identifies the type
of manual price
adjustment
 

String
 

30
 

Accepts either
LNDISCPERC or
LNDISCAMT
 

This defaults to
LNDISCPERC.
 

Optional
 

SalesPromotionId
 

The unique
identifier of the
sales promotion
 

Long
 

18
 

No validation
 

This is auto
generated.
 

Required
 

Name
 

The name of the
sales promotion
 

String
 

150
 

Enter a unique
value.
 

Required
 

Optional
 

SalesPromotionCode
 

The code
indicating the
type of the sales
promotion. This
value is generated
when a sales
promotion is
created.
 

String
 

80
 

No validation
 

This is auto
generated.
 
You can also enter
a value.
 

Required
 

AdjustmentBasisCode
 

The code
indicating the
basis of the
sales promotion
adjustment when
the adjustment
type is Percent. For
example List Price
or Net Price
 

String
 

30
 

Accepts either
LISTPRICE or
NETPRICE
 

Defaults to
LISTPRICE
 

Optional
 

Description
 

A brief description
of the sales
promotion
 

String
 

1999
 

No validation
 

Not required
 

Optional
 

StartDate
 

The date and
time at which the
sales promotion is
available
 

Date
 

Start date can't be
later than the end
date.
 

Not required
 

Optional
 

EndDate
 

The date and time
up to which the
sales promotion is
available
 

Date
 

Start date can't be
later than the end
date.
 

Not required
 

Optional
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Sales
Promotion Record

Updating an
Existing Sales
Promotion Record

AdjustmentValue
 

The value of the
sales promotion
adjustment
 

BigDecimal
 

A value is
mandatory if the
status is set to
ACTIVE.
 

A value is required
if the status is
Active.
 

Optional
 

CurrencyCode
 

The currency
code of the
sales promotion
adjustment when
the adjustment
type is "Amount"
 

String
 

15
 

A value is
mandatory if the
AdjustmentTypeCode
is LNDISCAMT.
 

A value is
required if the
AdjustmentTypeCode
is LNDISCAMT.
 

Optional
 

You can view the Promotion object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Promotion object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Promotion from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note:  Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Sales Resource Period Quota Data  
You can use the import functionality to create or update Sales Resource Period Quota records.

You can import Sales Resource Period Quota records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Sales Resource Period Quota data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Sales Resource Period Quota data into Oracle Applications Cloud from a CSV file containing your source
data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Sales Resource Period Quota import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Sales Resource Period Quota while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: You can't create Sales Resource Period Quota records. If you're updating records, then
you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number'
and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating
a record with a Number attribute, then use the Number attribute to identify the record. For more information
about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics
section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Sales Resource
Period Quotas or are updating Sales Resource Period Quotas that have source system reference data, then
provide the source system and source system reference values.

Required Attributes and Validations for Sales Resource Period Quota
Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Sales Resource Period Quota records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Sales
Resource Period
Quota record

Updating an Existing
Sales Resource
Period Quota record

Deleting an Existing
Sales Resource
Period Quota record

QuotaPlanName
 

Name of the Quota
Plan
 

Quota plan has to
be in Active status
and tracked. The
territory should be
non-excluded and not
published.
 

Required
 

Required
 

Required
 

TerritoryNumber
 

Territory number for
which data is imported
 

The territory must
exist. It must be non-
excluded and not
published.
 

Required
 

Required
 

Required
 

GoalNumber
 

The public unique
identifier of the goal
 

When creating a sales
resource quota record,
 the goal should be in
Active status.
 

Required
 

Required
 

Required
 

PeriodName
 

The period for which
data is imported
 

The calendar setup for
the year.
 

Not applicable
 
You can't create a
Sales Resource Period
Quota record.
 

Not updatable
 

Not required
 

ResourcePeriodQuota
 

The quota value to be
imported

Enter a positive
number.

Not applicable
 

This is updatable, if
the Territory Quota

Not required
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Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Sales
Resource Period
Quota record

Updating an Existing
Sales Resource
Period Quota record

Deleting an Existing
Sales Resource
Period Quota record

  You can't create a
Sales Resource Period
Quota record.
 

is in "Not Published"
status.
 

ResourceEmail
 

This is the territory
resource's email
address for which you
need to set the quota.
 

It should be a valid
email address of the
territory resource.
 

Required
 

Required
 

Required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Sales Resource
Period Quota object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Resource Period Quota object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Sales Resource Period Quota information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Sales Resource Period Quota from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
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3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Sales Resource Quota Data  
You can use the import functionality to create or update Sales Resource Quota records.

You can import Sales Resource Quota records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Sales Resource Quota data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Sales Resource Quota data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Sales Resource Quota import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Sales Resource Quota while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: You can't create Sales Resource Quota records. If you're updating records, then you
can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and
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visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a
record with a Number attribute, then use the Number attribute to identify the record. For more information
about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics
section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Sales Resource
Quotas or are updating Sales Resource Quotas that have source system reference data, then provide the source
system and source system reference values.

Required Attributes and Validations for Sales Resource Quota Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Sales Resource Quota records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup
Task/ Import
Validations

Creating a Sales
Resource Quota
record

Updating an Existing
Sales Resource Quota
record

Deleting an Existing
Sales Resource Quota
record

QuotaPlanName
 

Name of the Quota
Plan
 

Quota plan has to
be in Active status
and tracked. The
territory should be
non-excluded and not
published.
 

Required
 

Note:
When you create
a Sales Resource
Quota record, the
corresponding
Sales Resource
Period quota record
also gets created.
 

Required
 

Required
 

Note:
When you delete
a Sales Resource
Quota record, the
corresponding
Sales Resource
Period quota record
also gets deleted.
 

TerritoryNumber
 

Territory number for
which data is imported
 

The territory must
exist. It must be non-
excluded and not
published.
 

Required
 

Required
 

Required
 

GoalNumber
 

The public unique
identifier of the goal
 

When creating a sales
resource quota record,
 the goal should be in
Active status.
 

Required
 

Required
 

Required
 

ResourceQuota
 

Quota value to
be imported for a
territory resource
 

This must be greater
than or equal to zero.
 

This can't be created
for the owner with
Sales Revenue Goal
(GOAL_1000).
 

This can't be deleted
for the owner with
Sales Revenue Goal
(GOAL_1000).
 

Not required
 

ResourceEmail
 

This is the territory
resource's email
address for which you
need to set the quota.
 

It should be a valid
email address of the
territory resource.
 

Required
 

Required
 

Required
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Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Sales Resource
Quota object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Resource Quota object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Sales Resource Quota information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Sales Resource Quota from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel
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How do I import sales team member data?  
You can use Import Management to create or update sales team member records.

You can import sales team member records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the sales team member data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import sales team member data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the sales team member import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate sales team member while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records. Also ensure that the parent records, such as
accounts, are in active status.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Sales Team Members
or are updating Sales Team Members that have source system reference data, then provide the source system
and source system reference values.
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Required Attributes and Validations for Sales Team Member Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for sales team member records, prerequisite setup tasks and specific validations,
if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Team
Member record

Updating an Existing
Sales Team Member
record

TeamMemberId
 

Sales Team Member ID.
This is the primary key.
 

N/A
 

N/A
 

If available, provide this to
update other attributes.
 

SalesProfileID
 

Sales Profile ID
 

Active SalesProfileID to
have been created already.
 

Conditionally required
 
To be provided if none of
the following are available:
 

• PartyID

• PartyNumber

• Combination of
PartySourceSystem
and
PartySourceSystemReferenceValue

Conditionally required
 
To be provided if
TeamMemberID isn't
available. To be provided
along with ResourceID or
ResourcePartyNumber or
ResourceEmailAddress.
 

PartyID
 

Sales Account ID
 

N/A
 

Conditionally required
 
To be provided if
SalesProfileID isn't
available.
 

Conditionally required
 
To be provided if
TeamMemberID or
SalesProfileID isn't
available. To be provided
along with ResourceID or
ResourcePartyNumber or
ResourceEmailAddress.
 

PartySourceSystem
 

Party source system of the
Sales account
 

N/A
 

Conditionally required
 
To be provided if
SalesProfileID isn't
available. To be
provided along with
PartySourceSystemReferenceValue.
 

Conditionally required
 
To be provided if
TeamMemberID or
SalesProfileID or
PartyID isn't available.
To be provided along
with ResourceID or
ResourcePartyNumber or
ResourceEmailAddress.
 

PartySourceSystemReferenceValue
 

Party source system
reference of the Sales
account
 

N/A
 

Conditionally required
 
To be provided if
SalesProfileID isn't
available. To be provided
with PartySourceSystem.
 

Conditionally required
 
To be provided if
TeamMemberID or
SalesProfileID or
PartyID isn't available.
To be provided along
with ResourceID or
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Team
Member record

Updating an Existing
Sales Team Member
record

ResourcePartyNumber or
ResourceEmailAddress.
 

PartyNumber
 

Party number of the sales
account/PUID
 

N/A
 

Conditionally required
 
To be provided if
SalesProfileID isn't available
 

Conditionally required
 
To be provided if
TeamMemberID or
SalesProfileID or
PartyID isn't available.
To be provided along
with ResourceID or
ResourcePartyNumber or
ResourceEmailAddress.
 

ResourceID
 

Resource identifier
 

Active ResourceID to have
been created already.
 

Conditionally required
 
To be provided if
ResourcePartyNumber or
ResourceEmailAddress isn't
available.
 

Conditionally required
 
To be provided if
TeamMemberID isn't
available. To be provided
along with SalesProfileID
or PartyID or PartyNumber
or PartySourceSystem
along with
PartySourceSystemReference.
 

ResourcePartyNumber
 

Resource party number/
PUID
 

N/A
 

Conditionally required
 
To be provided if
ResourceID isn't available.
 

Conditionally required
 
To be provided if
TeamMemberID or
ResourceID isn't available.
To be provided along
with SalesProfileID or
PartyID or PartyNumber
or PartySourceSystem
along with
PartySourceSystemReference.
 

ResourceEmailAddress
 

Resource email address
 

N/A
 

Conditionally required
 
To be provided if
ResourceID isn't available
 

Conditionally required
 
To be provided if
TeamMemberID
or ResourceID or
ResourcePartyNumber isn't
available. To be provided
along with SalesProfileID
or PartyID or PartyNumber
or PartySourceSystem
along with
PartySourceSystemReference.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the sales team member
object. The page also lists attribute information like type, length, description, and so on.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the sales team member object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the sales team member information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Sales Team Member from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

Import Your Sales Territory Data  
You can use Import Management to create, update or delete Sales Territory records.
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To import Sales Territory records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Sales Territory data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

◦ When creating a territory, the sales territory import file must be imported before importing the sales
territory resource, sales territory coverage, or sales territory line of business import files.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

• You have created a proposal in the Classic Territories pages, if you want to update territories as part of a
proposal. Optionally, you can add territories to update the proposal.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Public unique identifier. If you're creating new
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Sales Territory object, the attributes are UniqueTerritoryNumber, ProposalNumber and OwnerResourceNumber.

Required Attributes and Validations for the Sales Territory Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new Sales
Territory records, required attributes for updating Sales Territory records, required attributes for deleting Sales Territory
records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Territory import:
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Attribute Description Data Type Prerequisite
Setup Task/
Import
Validations

Creating a Sales
Territory Record

Updating a Sales
Territory Record

Deleting an
Existing Sales
Territory Record

UniqueTerritoryNumber
 

The public unique
identifier number
of the territory
 

Text
 

Not applicable
 

Optional
 

Required
 

Required
 

ProposalNumber
 

The public unique
identifier number
of the proposal
 

Text
 

Not applicable
 

A value is required
if you're creating a
territory that's part
of a proposal.
 

Not required
 

Not required
 

ParentTerritoryUniqueTerritoryNumber
 

The public unique
identifier number
of the parent
territory
 

Text
 

Not applicable
 

A value is required
unless you're
creating a top level
territory.
 

A value is required
if you're moving a
territory under a
different parent.
 

Don't provide a
value.
 

TypeCode
 

The type of the
territory such
as PRIME or
OVERLAY
 

Text
 

Not applicable
 

Required
 

Conditionally
required if you
need to update the
territory type
 

Don't provide a
value.
 

CoverageModel
 

Coverage Model
 

Text
 

Not applicable
 

Required.
 
The available
values are SALES_
ACCOUNT_
CENTRIC or
PARTNER_
CENTRIC
 

Don't provide a
value.
 

Don't provide a
value.
 

StatusCode
 

The status of the
territory, such as
FINALIZED.
 

Text
 

Not applicable
 

A value is required
if you're creating
an active territory.
The value is
FINALIZED.
 

Don't provide a
value.
 

Don't provide a
value.
 

TerritoryName
 

The name that
identifies the
territory.
 

Text
 

Not applicable
 

Required
 

Optional
 

Don't provide a
value.
 

Owner
 

The name of the
owner resource
 

Text
 

Not applicable
 

Don't provide a
value.
 

Don't provide a
value.
 

Don't provide a
value.
 

OwnerResourceNumber
 

The public unique
identifier number
of the owner
resource
 

Text
 

Not applicable
 

Required
 

Conditionally
required if you
need to update the
owner
 

Don't provide a
value.
 

You can view the Sales Territory object and attributes in the Manage Import Objects page of the Import Management
flow. You can find attribute information like type, length, description, and so on, on this page.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Territory object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Territory from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.

◦ The ParentUniqueTerritoryNumber isn't automatically mapped to the Parent Unique Territory Number.
Use the Save As option to create a mapping, name the mapping, and map the Parent Unique Territory
Number target attribute to the Source File ParentUniqueTerritoryNumber Attribute, by dragging the
target attribute to the Attribute Display Name. Select and apply this new import mapping in the Map
Fields page of a future sales territory import activity.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?
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Import Your Sales Territory Coverage Data  
You can use Import Management to create or delete Sales Territory Coverage records.

To import Sales Territory Coverage records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Sales Territory Coverage data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

◦ When creating a territory, the sales territory import file must be imported before importing the sales
territory resource, sales territory coverage or sales territory line of business import files.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Public unique identifier. If you're creating
new records, then you can provide the appropriate user-friendly public unique identifiers (attributes denoted with
'Number' and usually visible in the business object's UI). For the Sales Territory Coverage object, the attributes are
UniqueTerritoryNumber, CoverageTypeCode and DimensionCode. If you delete a sales territory resource record, you
can use a combination of the UniqueTerritoryNumber and CoverageNumber attributes to identify the record. Oracle
recommends that you don't update the Sales Territory Coverage object. For example, to update the AddressCity of the
Addr (DimensionCode) coverage record, delete the record and create a new record with the correct AddressCity value.
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Required Attributes and Validations for Sales Territory Coverage Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new Sales
Territory Coverage records, required attributes for deleting Sales Territory Coverage records, prerequisite setup tasks for
the attributes, and specific validations, if any, for Sales Territory Coverage import:

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

UniqueTerritoryNumber
 

The public unique identifier
number of the territory
 

Text
 

Not applicable
 

Required
 

CoverageNumber
 

The public unique identifier
number of the territory
coverage
 

Text
 

Not applicable
 

Don't provide a value.
 

CoverageTypeCode
 

The code of the territory
coverage type
 

Text
 

Not applicable
 

Required Values are
REGULAR, INCLUSION, and
EXCLUSION
 

TerrDimensionCode
 

The code of the dimension
 

Text
 

Not applicable
 

Required if passing the
related dimension member
information. The values are:
 

• Acct

• AcTyp

• Addr

• Aux1

• Aux2

• Aux3

• Bunit

• CSize

• Geo

• Indst

• Prtnr

• Prod

• OrgTp

• Schnl

don't provide a value, if
creating a dimensional
coverage of Any (for every
dimension including
Address)
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Depending on the dimension coverage there may be additional required attributes for importing new Sales Territory
Coverage records. The following tables list the required attributes for importing new Sales Territory Coverage records,
prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Territory Coverage import:

If the DimensionCode = Acct

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

RegistryId
 

The public unique identifier
number of the account
 

Text
 

Not applicable
 

Either the RegistryID or
the OriginalReference is
Required.
 

OriginalReference
 

The original system /
original system reference of
the account.
 

Text
 

Not applicable
 

Either the RegistryID or
the OriginalReference is
Required.
 

CoverageTypeCode
 

The code of the territory
coverage type

Text
 

Not applicable
 

Required Values are
REGULAR, INCLUSION, and
EXCLUSION
 

IncludeHierarchyFlag
 

An indicator of whether
the account hierarchy is
included
 

Text
 

Not applicable
 

Optional. Applicable values
Y or N.
 

Note:  During import, the application attempts to lookup the account using RegistryId, but if not found it uses
OriginalReference. If values for both RegistryID and OriginalReference are passed, then the RegistryID is used first.

If the DimensionCode = Geo

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

GeographyName
 

The geography name
including the hierarchy
 

Text
 

Not applicable
 

Required
 

GeographyHighName
 

The upper level of the
geography name range
including the hierarchy
 

Text
 

Not applicable
 

Required only if defining
a range of geography
dimension members
 

If the DimensionCode = Addr

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

AddressCountry
 

The code of the address
country
 

Text
 

Not applicable
 

Required
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Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

AddressState
 

The address state
 

Text
 

Not applicable
 

Optional
 

AddressProvince
 

The address province
 

Text
 

Not applicable
 

Optional
 

AddressCounty
 

The address county
 

Text
 

Not applicable
 

Optional
 

AddressCity
 

The address city
 

Text
 

Not applicable
 

Optional
 

AddressPostalCode
 

The address postal code
 

Text
 

Not applicable
 

Optional
 

AddressElementAttribute1
 

The additional address
element 1
 

Text
 

Not applicable
 

Optional
 

AddressElementAttribute2
 

The additional address
element 2
 

Text
 

Not applicable
 

Optional
 

AddressElementAttribute3
 

The additional address
element 3
 

Text
 

Not applicable
 

Optional
 

AddressElementAttribute4
 

The additional address
element 4
 

Text
 

Not applicable
 

Optional
 

AddressElementAttribute5
 

The additional address
element 5
 

Text
 

Not applicable
 

Optional
 

If the DimensionCode = OrgTp

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

OrganizationTypeCode
 

The code of the
organization type
 

Text
 

Not applicable
 

Required
 

If the DimensionCode = Indst

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

IndustryCode
 

The code of the industry
 

Text
 

Not applicable
 

Required
 

If the DimensionCode = Csize
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Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

CustomerSizeCode
 

The code of the customer
size
 

Text
 

Not applicable
 

Required
 

If the DimensionCode = AcTyp

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

AccountTypeCode
 

The named account code
 

Text
 

Not applicable
 

Required
 

If the DimensionCode = Prod

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

ProductGroupNumber
 

The public unique identifier
number of the product
group
 

Text
 

Not applicable
 

Required if creating a sales
territory coverage for a
product group
 

ItemNumber
 

The public unique identifier
number of the item
 

Text
 

Not applicable
 

Required if creating a sales
territory coverage for an
item
 

InventoryOrgId
 

The identifier of the
inventory organization
 

Number
 

Not applicable
 

Required if creating a sales
territory coverage for an
item, but only when the
value is different from
the default inventory
organization identifier
specified in the profile
option QSC_SALES_
PRODUCTS_INVENTORY_
ORG_ID.
 

If the DimensionCode = BUnit

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

BusinessUnitName
 

The name of the business
unit
 

Text
 

Not applicable
 

Required
 

If the DimensionCode = Aux1
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Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

Auxiliary1Code
 

The code of the auxiliary
classification 1
 

Text
 

Not applicable
 

Required
 

If the DimensionCode = Aux2

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

Auxiliary2Code
 

The code of the auxiliary
classification 2
 

Text
 

Not applicable
 

Required
 

If the DimensionCode = Aux3

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

Auxiliary3Code
 

The code of the auxiliary
classification 3
 

Text
 

Not applicable
 

Required
 

If the DimensionCode = Schnl

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

SalesChannelCode
 

The code of the sales
channel
 

Text
 

Not applicable
 

Required
 

SubSalesChannelCode
 

The code of the sub sales
channel
 

Text
 

Not applicable
 

Optional
 

If the DimensionCode = Prtnr

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Coverage Record

PartnerNumber
 

The public unique identifier
number (or company
number) of the partner
 

Text
 

Not applicable
 

Required
 

You can view the Sales Territory Coverage object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.
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Required Attributes and Validations for Deleting Sales Territory Coverage
Object
You can delete a sales territory coverage record using Unique Territory Number, Dimension Code and other attributes or
Unique Territory Number and Coverage Number.

Delete a Sales Territory Coverage using Attribute and Dimension Code

A Sales Territory Coverage record can be deleted using the following fields:

• Unique territory number (UniqueTerritoryNumber): The public unique identifier number of the territory

• Coverage type code (CoverageTypeCode): The coverage type code. Possible values are REGULAR, INCLUSION,
or EXCLUSION

• Dimension code (TerrDimensionCode) : The possible values are listed in the table below:

Dimension Field(s)

Dimension Dimension Code Dimension Field

Sales Channel Either SalesChannelCode or
SubSalesChannelCode

Product Prod ProductGroupNumber or ProductGroupId OR
ItemNumber or InventoryItemId

Account Type AccTp AccountTypeCode

Address Addr AddressCountry and (optionally) one or more of
the following:

• AddressState

• AddressProvince

• AddressCounty

• AddressCity

• AddressPostalCode

• AddressElementAttribute1

• AddressElementAttribute2

• AddressElementAttribute3

• AddressElementAttribute4

• AddressElementAttribute5

Auxiliary 3 Aux3 Auiliary3Code

Auxiliary 1 Aux1 Auiliary1Code

Auxiliary 2 Aux2 Auiliary2Code

Business Unit BUnit BusinessUnitName or BusinessUnitId

Customer Size CSize CustomerSizeCode
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Dimension Dimension Code Dimension Field

Geography Geo GeographyId or GeographyName (the full path
needs to be provided e.g. >United States>CA or
~Global~North America)
 
For Geo ranges, also provide
 
GeographyHighId or GeoHighName - the full
path needs to be provided (optional)

Industry Indst IndustryCode

Organization Size OrgTp OrganizationTypeCode

Partner Prtnr PartnerNumber or PartnerId

Account Acct RegistryId or OriginalReference or AccountId

Delete a Sales Territory Coverage using Unique Territory Number and Coverage Number

A Sales Territory Coverage record can be deleted using the Unique Territory Number and Coverage Number.

Required Attributes to Delete a Sales Territory Coverage

Attribute Description Data Type Prerequisite Setup Task/
Import Validations

Deleting an Existing Sales
Territory Coverage Record

UniqueTerritoryNumber The public unique identifier
number of the territory.

Text Not applicable Required

CoverageNumber The public unique identifier
number of the territory
coverage.

Text Not applicable Required

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Standard Text object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Territory Coverage

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. Under Advanced options, select the Import Mode as Create records or Delete Records.
6. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
7. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
8. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

• Remove Customer Inclusions Using Import Management

• Add Customer Inclusions Using Import Management

Import Your Sales Territory Line of Business Data  
You can use Import Management to create or delete Sales Territory Line of Business records.

To import Sales Territory Line of Business records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Sales Territory Line of Business data into Oracle Applications Cloud, you must populate a .csv file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

◦ When creating a territory, the sales territory import file must be imported before importing the sales
territory resource, sales territory coverage, or sales territory line of business import files.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide the appropriate user-friendly public unique identifiers (attributes denoted with
'Number' and usually visible in the business object's UI). For the Sales Territory Line of Business object, the attributes
are UniqueTerritoryNumber and LobCode. If you delete a sales territory line of business record, you can use a
combination of the UniqueTerritoryNumber and LobCode attributes to identify the appropriate record.

Required Attributes and Validations for Sales Territory Line of Business
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new Sales
Territory Line of Business records, required attributes for deleting Sales Territory Line of Business records, prerequisite
setup tasks for the attributes, and specific validations, if any, for Sales Territory Line of Business import:

Attribute Description Data Type Prerequisite Setup
Task/ Import
Validations

Creating a Sales
Territory Line of
Business Record

Deleting an Existing
Sales Territory Line
of Business Record

UniqueTerritoryNumber
 

The public unique
identifier number of
the territory
 

Text
 

Not applicable
 

Required
 

Required
 

LobCode
 

The code of the line of
business.
 

Text
 

Not applicable
 

Required.
 

Required
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You can view the Sales Territory Line of Business object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Territory Line of Business object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Territory Line of

Business from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. Under Advanced options, select the Import Mode as Create records or Delete Records.
6. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
7. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
8. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?
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Import Your Sales Territory Period Quota Data  
You can use the import functionality to create or update Sales Territory Period Quota records.

You can import Sales Territory Period Quota records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Sales Territory Period Quota data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import Sales Territory Period Quota data into Oracle Applications Cloud from a CSV file containing your source data
that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Sales Territory Period Quota import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Sales Territory Period Quota while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Sales Territory Period Quota
attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files,
one for each of the Sales Territory Period Quota child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: You can't create Sales Territory Period Quota records. If you're updating records, then
you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number'
and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating
a record with a Number attribute, then use the Number attribute to identify the record. For more information
about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics
section.
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• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Sales Territory Period
Quotas or are updating Sales Territory Period Quotas that have source system reference data, then provide the
source system and source system reference values.

Required Attributes and Validations for Sales Territory Period Quota Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Sales Territory Period Quota records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Period Quota record

Updating an Existing
Sales Territory Period
Quota record

QuotaPlanName
 

Name of the Quota Plan
 

Quota plan has to be in
Active status and tracked.
 

Not applicable
 
You can't create a Sales
Territory Period Quota
record.
 

Not updatable
 

TerritoryNumber
 

Territory number for which
the period data is imported
 

The territory must exist and
be non-excluded.
 

Not applicable
 
You can't create a Sales
Territory Period Quota
record.
 

Not updatable
 

PeriodName
 

Period for which data is
imported
 

The calendar setup for the
year.
 

Not applicable
 
You can't create a Sales
Territory Period Quota
record.
 

Not updatable
 

TerritoryPeriodQuota
 

Quota value to be imported
 

Enter a positive number.
 

Not applicable
 
You can't create a Sales
Territory Period Quota
record.
 

This is updatable, if the
Territory Quota is in "Not
Published" status.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Sales Territory
Period Quota object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Territory Period Quota object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Sales Territory Period Quota information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Sales Territory Period Quota from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Sales Territory Quota Data  
You can use the import functionality to create or update Sales Territory Quota records.

You can import Sales Territory Quota records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Sales Territory Quota data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.
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How You Map Your Source Data to Target Object Attributes
You import Sales Territory Quota data into Oracle Applications Cloud from a CSV file containing your source data that's
mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Sales Territory Quota import object.

• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.

• Know how you can uniquely identify the records.

• Check the target object attributes required in the CSV file for a successful import.

• Ensure that you don't insert duplicate Sales Territory Quota records while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Sales Territory Quota attributes.
However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each
of the Sales Territory Quota child objects. Note that you must have imported the CSV file for Sales Territory Quota object
successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to
import each of these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: You can't create Sales Territory Quota records. If you're updating records, then you can
provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible
in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with
a Number attribute, then use the Number attribute to identify the record. For more information about public
unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Sales Territory
Quotas or are updating Sales Territory Quotas that have source system reference data, then provide the source
system and source system reference values.

Required Attributes and Validations for Sales Territory Quota Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Sales Territory Quota records, prerequisite setup tasks and specific validations,
if any:
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Sales Territory
Quota record

Updating an Existing
Sales Territory Quota
record

QuotaPlanName
 

Name of the Quota Plan
 

Quota plan must be in
Active status and tracked.
 

Not applicable
 
You can't create a Sales
Territory Quota record.
 

Not updatable
 

TerritoryNumber
 

Territory number for which
data is imported
 

The territory must exist and
be non-excluded.
 

Not applicable
 
You can't create a Sales
Territory Quota record.
 

Not updatable
 

TerritoryQuota
 

Quota value to be imported
 

Enter a positive number.
 

Not applicable
 
You can't create a Sales
Territory Quota record.
 

This is updatable, if the
Territory Quota is in "Not
Published" status.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the Sales Territory
Quota object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Territory Quota object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Sales Territory Quota information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select

Sales Territory Quota from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How You Use Alternate Keys to Import Records

• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Sales Territory Resource Data  
You can use Import Management to create or delete Sales Territory Resource records.

To import Sales Territory Resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Sales Territory Resource data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

◦ When creating a territory, the sales territory import file must be imported before importing the sales
territory resource, sales territory coverage, or sales territory line of business import files.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Public unique identifier. If you're creating
new records, then you can provide the appropriate user-friendly public unique identifiers (attributes denoted with
'Number' and usually visible in the business object's UI). For the Sales Territory Resource object, the attributes are
UniqueTerritoryNumber and ResourcePartyNumber. If you delete a sales territory resource record, you can use
a combination of the UniqueTerritoryNumber and ResourcePartyNumber attributes to identify the appropriate
record. Oracle recommends that you don't update the Sales Territory Resource object. For example, to update the
FunctionCode of the record; instead delete the record and then create a new record with the correct FunctionCode
value.

Required Attributes and Validations for the Sales Territory Resource Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new Sales
Territory Resource records, required attributes for deleting Sales Territory Resource records, prerequisite setup tasks for
the attributes, and specific validations, if any, for Sales Territory Resource import:

Attribute Description Data Type Prerequisite Setup
Task/ Import
Validations

Creating a Sales
Territory Resource
Record

Deleting an Existing
Sales Territory
Resource Record

UniqueTerritoryNumber
 

The public unique
identifier number of
the territory
 

Text
 

Not applicable
 

Required
 

Required
 

ResourcePartyNumber
 

The public unique
identifier number of
the resource
 

Text
 

Not applicable
 

Required.
 

Required
 

FunctionCode
 

The code of the
function (or role) of
the territory member
 

Text
 

Not applicable
 

Optional.
 
Required if changing
the function of the
territory owner or
member.
 

Don't provide a value.
 

AdministratorFlag
 

An indicator of
whether the territory
member is a delegated
administrator for the
territory

Text
 

Not applicable
 

Optional
 
Required if changing
the delegated
administrator of the

Don't provide a value.
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Attribute Description Data Type Prerequisite Setup
Task/ Import
Validations

Creating a Sales
Territory Resource
Record

Deleting an Existing
Sales Territory
Resource Record

 territory owner or
member.
 

ManageForecastFlag
 

An indicator of
whether the territory
member is the
forecasting delegate
 

Text
 

Not applicable
 

Optional
 
Required if changing
the forecasting
delegate of the
territory owner or
member.
 

Don't provide a value.
 

You can view the Sales Territory Resource object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Sales Territory Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Territory Resource

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. Under Advanced options, select the Import Mode as Create records or Delete Records.
6. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.

◦ The ResourcePartyNumber isn't automatically mapped to the Resource Registry ID. Use the Save As
option to create a mapping, name the mapping and map the Resource Registry ID target attribute to
the Source File ResourcePartyNumber attribute, by dragging the target attribute to the Attribute Display
Name. Select and apply this new import mapping in the Map Fields page of a future sales territory
resource import activity.

7. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
8. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Self-Service Role Data  
You can use Import Management to create self-service users and can also use it to delete existing self-service users or
grant them additional roles.

To import Self-Service users, perform the following tasks:

1. Map your source data to Self-Service Role object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Self-Service Role data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
All records must be unique in the application. If you're creating records, then you can provide an easily understandable
public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes
are usually named <object> Number. For more information about public unique identifiers, see the topic "How You Use
Alternate Keys to Import Records" in Related Topics section.

Required Attributes and Validations for Self-Service Role Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Self-Service
Role records, prerequisite setup tasks for the attributes, and specific validations, if any, for Self-Service Role import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Self-Service
Role Record

Deleting an Existing Self-
Service Role Record

ContactPartyId
 

The party ID of the contact
record of the self-service
user associated with the
role.
 

The contact must exist.
 

Provide a valid value if the
ContactPartyNumber isn't
specified.
 

Not Required
 

RequestTypeCd
 

The code that indicates the
Registration Request type.
The list of accepted values
is defined in the ORA_SVC_
CSS_REQ_TYPE_CD lookup
type.
 

No Validation
 

Provide one of the
following values:
 

• ORA_CSS_REQ_TYPE_
CONTACT

• ORA_CSS_REQ_TYPE_
CONSUMER

Not Required
 

RelationshipTypeCd
 

The code that indicates
the role type. The list of
accepted values is defined
in the ORA_SVC_CSS_REL_
TYPE_CD lookup type.
 
The following values can be
assigned:
 

• ORA_CSS_USER:
Corresponds to the
Digital Customer
Service User role.

• ORA_CSS_ACC_MGR:
Corresponds to the
Digital Customer
Service Account
Manager role.

• ORA_CSS_ACC_
ADMIN: Corresponds
to the Digital
Customer Service
Account Administrator
role.

Multiple roles can be
assigned to a user and

No Validation
 

Provide one or more of the
following values:
 

• ORA_CSS_USER

• ORA_CSS_ACC_MGR

• ORA_CSS_ACC_
ADMIN

Not Required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Self-Service
Role Record

Deleting an Existing Self-
Service Role Record

must be concatenated with
the character, '&'.
 
For example, ORA_CSS_
USER&ORA_CSS_ACC_
ADMIN
 

ContactPartyNumber
 

The party number of the
contact record of the self-
service user associated with
the role.
 

The contact must exist.
 

Provide a valid value if
the ContactPartyId isn't
specified.
 

Not Required
 

AccountPartyNumber
 

The party number of the
account of the self-service
user associated with the
role.
 

An account must exist.
 

Provide a valid value if
the AccountPartyId isn't
specified.
 

Not Required
 

RoleId
 

The unique identifier of the
self-service user role.
 

A user role must exist.
 

The RoleId should not be
provided.
 

Required
 

LoginId
 

The login Id of the self-
service user associated with
the role.
 
If the SVC_CSS_IMP_SIGN_
IN_ATTR_NAME profile
option is set, then the
LoginId is optional.
 

Login ID should be unique
to each user.
 

Provide a valid value if the
SVC_CSS_IMP_SIGN_IN_
ATTR_NAME profile option
isn't set.
 

Not Required
 

AccountPartyId
 

The party ID of the account
of the self-service user
associated with the role.
 

An account must exist.
 

Provide a valid value if the
AccountPartyNumber isn't
specified.
 

Not Required
 

Note:  You can only create and delete self-service role records. You can't update self-service role records.

You can view the Self-Service Role object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Self-Service Role object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Consider the following points:

• Role Id should be removed.

• Either the contact party ID or the contact party number is required.

• Either the account party ID or the account party number is required.

Examples

• Example 1: Party ID is used for creating self-service users

AccountPartyId,ContactPartyId,RelationshipTypeCd,RequestTypeCd

300100110957452,300100156316610,ORA_CSS_USER&ORA_CSS_ACC_ADMIN,ORA_CSS_REQ_TYPE_CONTACT

• Example 2: Party Number is used for creating self-service users

AccountPartyNumber,ContactPartyNumber,RelationshipTypeCd,RequestTypeCd

CDRM_67617,CDRM_743628,ORA_CSS_USER,ORA_CSS_REQ_TYPE_CONTACT

CDRM_67617,CDRM_743711,ORA_CSS_USER&ORA_CSS_ACC_ADMIN,ORA_CSS_REQ_TYPE_CONTACT

CDRM_67617,CDRM_743651,ORA_CSS_USER &ORA_CSS_ACC_MGR,ORA_CSS_REQ_TYPE_CONTACT

• Example 3: Login ID is explicitly provided for creating self-service users

AccountPartyNum,ContactPartyNum,LoginId,RelationshipTypeCd,RequestTypeCd

CDRM_67617,CDRM_743628,Mary.Smith,ORA_CSS_USER,ORA_CSS_REQ_TYPE_CONTACT

CDRM_67617,CDRM_743711,John.Rogers,ORA_CSS_USER&ORA_CSS_ACC_ADMIN,ORA_CSS_REQ_TYPE_CONTACT

CDRM_67617,CDRM_743651,Pat.Williams,ORA_CSS_USER&ORA_CSS_ACC_MGR,ORA_CSS_REQ_TYPE_CONTACT

• Example 4: Consumer request type is provided for creating self-service users

ContactPartyId,RelationshipTypeCd,RequestTypeCd

300100194440555,ORA_CSS_USER,ORA_CSS_REQ_TYPE_CONSUMER

• Example 5: RoleId is provided for deleting self-service users

300100194434646

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Self-Service Role.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Self-Service Role from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
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You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Self-Service Role.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Service Profile Data  
You can use Import Management to create update or delete Service Profile records.

To import Service Profile records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Service Profile data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new cases or are updating
cases that have source system reference data, then provide the source system and source system reference
values.

Required Attributes and Validations for Service Profile Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Service Profile
records, required attributes for updating or deleting Service Profile records, prerequisite setup tasks for the attributes,
and specific validations, if any, for Service Profile import:

Attributes Description Prerequisite Setup
Task/Import
Validation

Creating a Service
Profile record

Updating a Service
Profile record

Deleting a Service
Profile record

PartySiteId The site address of the
service profile.

The value must exist
in the HZ_PARTY_
SITES table, column
PARTY_SITE_ID. The
PARTY_SITE_ID should
be child record of
CUSTOMER_PARTY_
ID.

Required. Either
PartySiteId or
PartySiteNumber is
required

Not Required Not Required

CustomerPartyId The customer having
the service profile.

The value must exist
in the HZ_PARTIES
table, column PARTY_
ID.

Required. Either
CustomerPartyId or
CustomerPartyNumber
is required

Not Required Not Required

ServiceProfileId The unique identifier
of the service profile.

A valid primary key
in the destination
system. Either the
ServiceProfileNumber
or the ServiceProfileId
should be entered.
If both are entered,
 the ServiceProfileId is
preferred.

Not Required Conditionally
Required. Provide
value if the
ServiceProfileNumber
isn't provided.

Conditionally
Required. Provide
value if the
ServiceProfileNumber
isn't provided.
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ServiceProfileNumber The PUID of the
service profile.

A valid unique PUID
for the Service Profile
in the destination
system.

Required. If not passed
it will be defaulted to
PartySiteNumber of
the PartySiteId

Conditionally
Required. Provide
value if the
ServiceProfileId isn't
provided.

Conditionally
Required. Provide
value if the
ServiceProfileId isn't
provided.

ServiceProfileName The name of the
service profile.

User defined name for
the Service Profile.

Required. If not
passed, it will
be defaulted to
<Customer Name>
(<PartySiteNumber>).

Optional Optional

StatusCd Indicates whether
the service profile is
active.

A valid value is
required.

Required. If not
passed, it will be
defaulted to ORA_
SVC_ACTIVE.

Optional
 
Pass ORA_SVC_
INACTIVE to set the
status to Inactive.
 

Not Required

StripeCd Indicates the
type of service
implementation for
the service profile.
For example, CRM or
Internal Help Desk
service profile.

A valid value is
required.

Required. If not
passed, it will be
defaulted to ORA_
SVC_CRM.

Not Required Not Required

TypeCd The type of service
profile.

A valid value is
required.

Required. If not
passed, it will be
defaulted to ORA_
SVC_SITE.

Not Required Not Required

PartySiteNumber The PUID of the
service profile site
address.

The value must
exist in the HZ_
PARTY_SITES table,
 column PARTY_SITE_
NUMBER.

Required. Either
PartySiteId or
PartySiteNumber is
required

Not Required Not Required

CustomerPartyNumber The PUID for the
customer party of the
service profile.

The value must exist
in the HZ_PARTIES
table, column PARTY_
NUMBER.

Required. Either
CustomerPartyId or
CustomerPartyNumber
is required

Not Required Not Required

BillToCustomerId The customer to
be billed for work
performed for the
service profile.

The value must exist
in the HZ_PARTIES
table, column PARTY_
ID.

Conditionally required
 
A valid value is
required if passed.
 

Conditionally required
 
A valid value is
required if passed.
 

Not Required

BillToCustomerPartyNumberThe PUID for the
customer to be billed
for work performed for
the service profile.

The value must exist
in the HZ_PARTIES
table, column PARTY_
NUMBER.

Conditionally required
 
A valid value is
required if passed.
 

Conditionally required
 
A valid value is
required if passed.
 

Not Required

BillToCustomerAccountIdThe customer account
to be billed for work
performed for the
service profile.

The unique
identifier of the
BillingCustomerAccountId
and should belong to
BillingAccount.

Conditionally required
 
A valid value is
required if passed.
 

Conditionally required
 
A valid value is
required if passed.
 

Not Required

BillToCustomerAccountNumberThe PUID for the
customer account
to be billed for work

The public unique
identifier of the
BillingCustomerAccount

Conditionally required
 
A valid value is
required if passed.

Conditionally required
 
A valid value is
required if passed.

Not Required
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performed for the
service profile.

and should belong to
Billing Account.

  

BillToCustomerAccountSiteIdThe customer account
site to be billed for
work performed for
the service profile.

The unique
identifier of the
BillingCustomerAccountSiteId
and should belong to
BillingCustomerAccount.

Conditionally required
 
A valid value is
required if passed.
 

Conditionally required
 
A valid value is
required if passed.
 

Not Required

BillToPartySiteId The party site to
be billed for work
performed for the
service profile.

The unique identifier
of the Billing
PartySiteId.

Conditionally required
 
A valid value is
required if passed.
 

Conditionally required
 
A valid value is
required if passed.
 

Not Required

BillToPartySiteNumber The PUID for the party
site that will be billed
for work performed for
the service profile.

The public unique
identifier of the Billing
PartySiteNumber.

Conditionally required
 
A valid value is
required if passed.
 

Conditionally required
 
A valid value is
required if passed.
 

Not Required

PrimaryContactPartyId The primary contact of
the service profile.

The value must exist
in the HZ_PARTIES
table of Contact
PartyType, column
PARTY_ID.

Conditionally required
 
A valid value is
required if passed.
 

Conditionally required
 
A valid value is
required if passed.
 

Not required

PrimaryContactPartyNumberThe party number
of the service profile
primary contact.

The public unique
identifier of the
PrimaryContactPartyId.

Conditionally required
 
A valid value is
required if passed.
 

Conditionally required
 
A valid value is
required if passed.
 

Not Required

You can view the Service Profile object and attributes in the Manage Import Objects page of the Import Management
flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools > Import Management  >  Import Objects.
2. Select the Service Profile object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Service Profile from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
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5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Your Service Profile Contact Data  
You can use Import Management to create, update, or delete a Service Profile Contact record.

To import Service Profile Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Service Profile Contact data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new cases or are updating
cases that have source system reference data, then provide the source system and source system reference
values.

Required Attributes and Validations for Service Profile Contact Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Service Profile
Contact records, required attributes for updating or deleting Service Profile Contact records, prerequisite setup tasks for
the attributes, and specific validations, if any, for Service Profile Contact import:

Attributes Description Prerequisite Setup
Task/Import
Validation

Creating a Service
Profile Contact
record

Updating a Service
Profile Contact
record

Deleting a Service
Profile Contact
record

SpContactId The unique identifier
of the service profile
contact.

A valid primary key
in the destination
system.

Not Required Required Required

ServiceProfileId The service profile
for the service profile
contact.

The value must exist
in the SVC_SERVICE_
PROFILES, column
SERVICE_PROFILE_ID.

Required. Provide
value if the
ServiceProfileNumber
isn't provided.

Not Required Not Required

ServiceProfileNumber The PUID of the
service profile for the
service profile contact.

The public unique
identifier of the
ServiceProfileId.

Required. Provide
value if the
ServiceProfileId isn't
provided.

Not Required Not Required

PartyId The contact for the
service profile contact.

The value must exist
in the HZ_PARTIES
table of Contact
PartyType, column
PARTY_ID.

Required. Provide
value if the
ContactPartyNumber
isn't provided.

Not Required Not Required

ContactPartyNumber The PUID of the
contact belonging to
the service profile.

The public unique
identifier of the
PartyId.

Required. Provide
value if the PartyId
isn't provided.

Not Required Not Required
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You can view the Service Profile Contact object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools > Import Management  >  Import Objects.
2. Select the Service Profile Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Service Profile Contact

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records
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How do I import service request data?  
You can use the Import Management to create, update, or delete service request records.

You can import service request records using these steps:

1. Map your source service request data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the service request data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your service request data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

To better manage your service request information, the service request object has the following child object:

• Service Request Reference

If you want to import only a few records, then you can create a single CSV file for all service request attributes. However
if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the
service request child objects. Note that you must have imported the CSV file for service request object successfully
before trying to import the CSV files for the child objects. There are separate help topics describing how to import each
of these child objects. For more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
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All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new service requests or
are updating service requests that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Service Request Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for service request records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Service
Request record

Updating an Existing
Service Request record

Account ID
 

The unique Id for the
existing account Id record
in the Oracle Fusion
destination table.
 

Do not provide a value
if creating a new service
request. If updating an
existing service request,
 the value must exist in the
SVC_SERVICE_REQUESTS
table, column ACCOUNT_
PARTY_ID.
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
Account ID.
 

AssetID
 

The unique internal ID for
the existing service request
record..
 

Do not provide a value
if creating a new service
request. If updating an
existing service request,
 the value must exist in the
ZCA_ASSET table, column
ASSET_ID.
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
service request for this
service request.
 

Business Unit
 

The unique ID of the
business unit name
associated with the service
request.
 

No validation
 

Required
 

Required
 

Category ID
 

Unique ID of a means of
grouping service objects to
enable easy identification
and downstream reporting.
 

If providing a value, the
value must exist in the
table SVC_SR_CATEGORIES
(CATEGORY_ID).
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
Category ID for this service
request.
 

Inventory Item ID
 

The unique internal Id for
the existing sales catalog
product (item) record.

If providing a value, the
value must exist in the
EGP_SYSTEM_ITEMS_B

Conditionally required
 

Conditionally required
 

754



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Service
Request record

Updating an Existing
Service Request record

 table, column INVENTORY_
ITEM_ID. The identified
product must be defined
for the sales catalog (QSC_
PROD_GRP_ITEMS_TREE_
V view). You can obtain
the InventoryItemId for
an existing product (item)
by exporting the Product
Group Products object.
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Bulk
Data Export, Schedule
Export Processes

You can add products
(items) to the sales catalog.
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Product
Groups

A value is required if
you're creating a new item
inventory.
 

A value is required if
you're updating an item
inventory and you're not
providing the product's ID
(InventoryItemId).
 

Inventory Organization ID
 

The unique internal Id for
the existing product item
organization's record in the
destination table.
 

If providing a value,
 the value must exist
in the EGP_SYSTEM_
ITEMS_B table, column
ORGANIZATION_ID.
The identified item
organization must be the
same organization defined
for profile QSC_SALES_
PRODUCTS_INVENTORY_
ORG_ID. You can view the
profile value. Navigate to
the following in the Setup
and Maintenance work
area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Product Groups
Profile Option Values

You can obtain the
InventoryOrgId for an
existing product (item)
by exporting the Product

Conditionally required
 
A value is required if
you're creating a new item
inventory.
 

Conditionally required
 
A value is required if
you're updating an item
inventory and you're not
providing the product's ID
(InventoryItemId).
 

755



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Service
Request record

Updating an Existing
Service Request record

Group Products object.
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Bulk
Data Export, Schedule
Export Processes

Partner Account Party ID
 

Foreign key that references
HZ_PARTIES (PARTY_ID).
 

Do not provide a value if
creating a new partner
account in the same import
batch as this additional
party name. If you provide
the value for an existing
party, the value must exist
in the HZ_PARTIES table,
 column PARTY_ID. You
can obtain the PARTY_ID
for an existing party by
exporting the Party object.
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Bulk
Data Export, Schedule
Export Processes

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
Partner Account for this
service request.
 

PartyID
 

The unique ID for the
existing party record in the
Oracle Fusion destination
table.
 

Do not provide a value if
creating a new party in
the same import batch
as this additional party
name. If you provide the
value for an existing party,
 the value must exist in
the HZ_PARTIES table,
 column PARTY_ID. You
can obtain the PARTY_ID
for an existing party by
exporting the Party object.
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

Not required
 

Conditionally required
 
A value is required if you're
updating an existing party
ID and you're not providing
the party ID.
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Service
Request record

Updating an Existing
Service Request record

• Task: Manage Bulk
Data Export, Schedule
Export Processes

Primary Contact ID
 

The initial reported by
contact and ongoing
primary customer contact
of the service request.
 

Do not provide a value if
creating a new Primary
Contact Id in the same
import batch as this
additional party name.
If you provide the value
for an existing primary
contact, the value must
exist in the HZ_PARTIES
table, column PARTY_ID.
You can obtain the PARTY_
ID for an existing party by
exporting the Party object.
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Bulk
Data Export, Schedule
Export Processes

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
Primary Contact ID for this
service request.
 

Reference Number
 

The unique number used to
identify a service request.
You can configure the
service request number to
a format that's best suitable
to your organizational
requirements.
 

No validation
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
reported by record and
you're not providing the
service request ID.
 

Service Request ID
 

The unique Id for the
existing Service Request
record in the Oracle Fusion
destination table.
 

No validation
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
Service Request Id and
you're not providing the
Service Request Number.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the service request
object. The page also lists attribute information like type, length, description, and so on.

Note:   When importing closed SRs, the ClosedDate and LastResolvedDate are set to the current date (instead of the
dates in the import file) if there is an update to the status or description of the SR. As a workaround, you can import
the SRs again to take the ClosedDate and LastResolvedDate from the import file.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Service Request object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the service request information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Service Request from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Service Request Contact Data  
You can use Import Management to create or update Service Request Contact records.

758



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

To import Service Request Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Service Request Contact data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new service request
contacts or are updating service request contacts that have source system reference data, then provide the
source system and source system reference values.

Required Attributes and Validations for Service Request Contact Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Service Request
Contact records, required attributes for updating Service Request Contact records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Service Request Contact import:

759



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Service
Request Contact Record

Updating an Existing
Service Request Contact
Record

MemberId
 

The unique ID for the
Service Request (SR)
Contact record in the
Service Request Contact
object.
 

Auto-generated
 

Not Required
 

Conditionally required
 
While updating the
SR contact record, if
the SRId and either
one of the PartyID or
ContactPartyNumber
aren't provided, then the
MemberId is required.
 

PartyId
 

The unique party identifier
of the contact.
 

If a value is provided to
create a new SR contact
record or update an
existing SR contact record,
 then the value must exist
in the column PARTY_ID of
the HZ_PARTIES table.
 

Conditionally required
 
A value is required if a
new contact is added to a
service request, and the
Contact Party Number
(public unique identifier of
the contact) isn't provided.
 

Conditionally required
 
A value is required if an SR
contact record is updated,
 and the Contact Party
Number isn't provided.
 

ContactPartyNumber
 

The public unique identifier
of the contact.
 

If a value is provided to
create a new SR contact
record or update an
existing SR contact, the
value must exist in the
column PARTY_NUMBER of
the HZ_PARTIES table.
 

Conditionally required
 
A value is required if a
new contact is added to a
service request, and the
Party Id isn't provided.
 

Conditionally required
 
A value is required if an SR
contact record is updated,
 and the Party Id isn't
provided.
 

ContactPartyName
 

The name of the contact.
 

No Validation
 

Not Required
 

Not Required
 

SrId
 

The service request to
which the contact is
associated.
 

If a value is provided to
create or update an SR
contact record, then the
value must exist in the
column SR_ID of the SVC_
SERVICE_REQUESTS table.
 

Conditionally required
 
A value is required if an SR
contact record and the SR
Number isn't provided.
 

Conditionally required
 
A value is required if an
existing SR contact record
is updated, and the SR
Number isn't provided.
 

SrNumber
 

The public unique identifier
of a service request.
 

No Validation
 
If a value is provided to
create or update an SR
contact record, the value
must exist in the SR_
NUMBER column of the
SVC_SERVICE_REQUESTS
table.
 

Conditionally required
 
A value is required if an SR
contact record is created
and the SRId isn't provided.
 

Conditionally required
 
A value is required if an
existing SR contact record
is updated and the SRId
isn't provided.
 

You can view the Service Request Contact object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.
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Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Service Request Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Service Request Contact.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Service Request Contact

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Service Request Contact.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?
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Import Your Service Request Message Communication
Data  
You can use the Import Management to create Service Request (SR) message communication records.

You can import message communication records using these steps:

1. Map your source message data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.

2. Create the source CSV file with the message communication data you want to import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your message communication data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records. Make sure that you have imported SR and
SR Messages before importing the message communication records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.
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Required Attributes and Validations for Message Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for message communication records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Message
Communication record

MessageNumber
 

The public unique identifier of the
service request message.
 

None
 

Conditionally Required. Either
pass value for MessageNumber of
ObjectId.
 

ChannelId
 

The unique identifier of the
channel.
 

None
 

Required
 

Object ID
 

ID of the object (such as Note,
 Defect, Other SR) referencing the
service request or referenced by
the service request.
 

No validation
 

Conditionally required. Provide
value for either ChannelId or
ChannelShortName.
 

ChannelShortName
 

The public unique identifier of the
channel.
 

No validation
 

Conditionally required. Provide
value for either ChannelId or
ChannelShortName.
 

PartyId
 

The unique party identifier of the
person being communicated with.
 

No Validation
 

Conditionally required. Either pass
PartyId or PartyNumber if you want
to capture the message recipient or
sender.
 

PartyNumber
 

The public unique identifier of the
contact associated with the service
request message.
 

No validation
 

Conditionally required. Either pass
PartyId or PartyNumber if you want
to capture the message recipient or
sender.
 

PartyViaEndPoint
 

The endpoint used to
communicate with the customer
contact. For example Primarily
used for Email.
 

No validation
 

Conditionally required. Provide
value if you want to capture the
email address of the message
recipient.
 

RoutingCd
 

The code indicating how the
message was routed through the
endpoint.
 

No Validation
 

Conditionally required if you want
to capture the sender or recipient
of the message. Valid values are:
ORA_SVC_BCC, ORA_SVC_CC,
 ORA_SVC_FROM, ORA_SVC_TO
 

ObjectId
 

The unique identifier of the object.
 

No validation
 

Conditionally Required. Either
pass value for MessageNumber of
ObjectId.
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Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the message
communication object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Service Request Message Communication  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the message communication information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Service Request Message

Communication from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?
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Import Your Service Request Reference Data  
You can use the Import Management to create, update, or delete service request reference records.

You can import service request reference records using these steps:

1. Map your source service request reference data to Oracle Applications Cloud object attributes. This way the
import process would know where to insert each of the information bits.

2. Create the source CSV file with the service request reference data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your service request reference data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new service request
references or are updating service request references that have source system reference data, then provide the
source system and source system reference values.
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Required Attributes and Validations for Service Request Reference Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for service request reference records, prerequisite setup tasks and specific
validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Service
Request Reference record

Updating an Existing
Service Request
Reference record

Article ID
 

References CSO_
CONTENT_TEXT
(ANSWER_ID) which
uniquely identifies the
specific version of the
article.
 

If the article Id is empty, the
object Id must have a value.
 

Conditionally required
 
A value is required if you're
creating a new reference Id
record.
 

Conditionally required
 
A value is required if you're
updating an existing
reference Id record and
you're not providing
the record's unique ID
(ReferenceId).
 

Article Locale
 

Specifies locale of the
document, such as en_US.
 

No validation
 

Conditionally required
 
A value is required if you're
creating a new reference Id
record.
 

Conditionally required
 
A value is required if you're
updating an existing
reference Id record and
you're not providing
the record's unique Id
(ReferenceId).
 

Object ID
 

Id of the object (such as
Note, Defect, Other SR)
referencing the service
request or referenced by
the service request.
 

If the object Id is empty, the
article Id must have a value.
 

Conditionally required
 
A value is required if you're
creating a new reference Id
record.
 

Conditionally required
 
A value is required if you're
updating an existing
reference Id record and
you're not providing
the record's unique Id
(ReferenceId).
 

Object Type
 

Indicates the type of object
(such as Note, Article,
 Defect, Other SR) in
reference to SR_ID.
 

If providing a value, it must
be ORA_SVC_ARTICLE.
 

Conditionally required
 
A value is required if you're
creating a new reference Id
record.
 

Conditionally required
 
A value is required if you're
updating an existing
reference Id record and
you're not providing
the record's unique Id
(ReferenceId).
 

Reference ID
 

Unique Id for reference
 

No validation
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
reference Id and you're
not providing the object
Id (objectId) or (article Id,
object type code and article
locale), or (Article Id, Object
Type and Article Locale).
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Service
Request Reference record

Updating an Existing
Service Request
Reference record

 

Relation Type
 

Indicates the type of
relationship (for example,
 Related SR).
 

No validation
 

Required
 

Required
 

Service Request ID
 

Service request to which
the reference belongs.
 

No validation
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
contact and you're not
providing the Service
Request Number.
 

SR Number
 

The unique number used to
identify a service request.
You can configure the
service request number to
a format that's best suitable
to your organizational
requirements.
 

No validation
 

Conditionally required
 
A value is required if you're
updating an existing record
and you're not providing
the Service Request ID.
 

Conditionally required
 
A value is required if you're
updating an existing record
and you're not providing
the Service Request ID.
 

Title
 

If an article or note is linked
to the service request, this
is the title of the article.
 

No validation
 

Required
 

Required
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the service request
reference object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Service Request Reference object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the service request reference information. To
create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.

767



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

3. In the Enter Import Options page, provide a name for the import activity, and select Service Request Reference
from the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Service Request Resource Data  
You can use the Import Management to create or update service request resource records.

You can import service request resource records using these steps:

1. Map your source service request resource data to Oracle Applications Cloud object attributes. This way the
import process would know where to insert each of the information bits.

2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Check the import results.

How You Map Your Source Data to Target Object Attributes
To import your service request resource data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Service Request Resource object, the attributes are
MemberID, ServiceRequestID, and ServiceRequestTeamMemberResourceID.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Service Request Resource
object, the attributes are ResourceNumber and ServiceRequestNumber.

Required Attributes and Validations for Service Request Resource Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for importing new Service Request Resource records, required attributes for
updating Service Request Resource records, prerequisite setup tasks for the attributes, and specific validations, if any
for Service Request Resource import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Service
Request Resource record

Updating an Existing
Service Request Resource
record

Member ID
 

The unique ID for the
existing member record
in the Oracle Fusion
destination table.
 

This is auto generated.
 

Not required
 

Conditionally required
 
A value is required if you're
updating an existing
Member ID and you're
not providing the Service
Request Id and Party Id
(PartyId and SrId).
 

ResourceNumber
 

Unique resource number
that identifies the party Id.
 

If providing a value to
update an existing service
request resource, the value
must exist in the HZ_
PARTIES table, column
PARTY_NUMBER.
 

Conditionally required
 
A value is required if you're
creating a service request
resource record and not
providing the Service
Request Team Member
Resource ID.

Conditionally required
 
A value is required if you're
adding a new resource to a
service request or updating
an existing service request
resource record and you're
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Service
Request Resource record

Updating an Existing
Service Request Resource
record

 not providing the record's
unique Id (PartyId).
 

Service Request ID
 

Specifies the service
request to which the service
request resource member
belongs.
 

No validation
 

Conditionally required
 
A value is required if you're
creating a service request
resource record and not
providing the service
request number.
 

Conditionally required
 
A value is required if you're
updating an existing
service request team and
you're not providing the
service request number
(the public unique identifier
of the service request).
 

Service Request Team
Member Resource ID
 

The unique Id of the
resource being added/
updated to the service
request team.
 

If providing a value to
update an existing account,
 the value must exist in the
HZ_PARTIES table, column
PARTY_ID.
 

Conditionally required
 
A value is required if you're
adding a new resource to a
service request and you're
not providing the Resource
Number (public unique
identifier of the resource).
 

Conditionally required
 
A value is required if you're
adding a new resource to a
service request or updating
an existing service request
resource record and you're
not providing the record's
public unique Id (Party
Number).
 

Name
 

The name of the resource
added as the service
request resource member.
 

No validation
 

Not required
 

Not required
 

Service Request Number
 

The unique number used to
identify a service request.
You can configure the
service request number to
a format that's best suitable
to your organizational
requirements.
 

No validation
 

Conditionally required
 
A value is required if you're
adding a record and you're
not providing the service
request ID.
 

Conditionally required
 
A value is required if you're
updating an existing record
and you're not providing
the Service Request ID.
 

Assigned To
 

Specifies the resource to
which the service request is
assigned.
 

No validation
 
If the service request is
assigned to the resource,
 this field can be set to Y.
 

Not required
 

Not required
 

You can view the Service Request Resource object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
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2. Select the Service Request Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the service request resource information. To create
an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Service Request Resource

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your SmartText Data  
You can use Import Management to create, update, or delete SmartText records.

To import SmartText records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Object Attributes
To import your SmartText data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure any prerequisite setups are completed.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "Id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the SmartText object, this attributes is StdTxtId.

• Public unique identifiers: If you are creating new records, then you can provide a user-friendly public unique
identifier (PUID) which is an attribute denoted with 'Number'. For the SmartText object, the attribute is
StdTxtUniqueNumber. If you update a record for which you have previously provided a StdTxtUniqueNumber,
you can use the StdTxtUniqueNumber attribute to identify the record.

Required Attributes and Validations for SmartText Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new SmartText
records, required attributes for updating SmartText records, prerequisite setup tasks for the attributes, and specific
validations, if any, for SmartText import:
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Smart
Text Record

Updating an
Existing Smart
Text Record

StdTxtId
 

The unique Id
for the existing
SmartText record
in the Oracle
Fusion destination
table.
 

Number
 

18
 

No Validation
 

Not required
 

Conditionally
required
 
A value is required
if you're updating
an existing Smart
Text and you're
not providing the
Standard Text
Unique Number.
 

StdtxtName
 

Name of the
SmartText
 

Varchar
 

50
 

Validation is
performed for
the creation of
a SmartText
to ensure
the following
combination of
values doesn't
exist:
 

• StdtxtName

• Registry ID

• Domain

• StripeCd

• BuOrgId

Required
 

Not required
 

StdTxtUniqueNumber
 

The public unique
identifier (PUID)
used to identify
a SmartText. You
can configure
the standard text
unique number
to a format that is
most suitable to
the need of your
organization.
 

Varchar
 

30
 

Validation
performed for
the creation of
a smarttext,
 ensuring the
smart text unique
number isn't
already in use.
 

Not required
 
You can accept
system generated
values or provide
a unique value
according to your
organizational
business needs.
 

Conditionally
required
 
A value is required
if you're updating
an existing Smart
Text and you're
not providing
the Smart
Text Identifier
(StdTxtId).
 

StripeCd
 

The stripe to which
this SmartText is
associated
 

Varchar
 

30
 

A value is
defaulted based
on the application
context. However,
 if a value is
populated,
 validation is
performed against
the list of valid
values in the
lookup type ORA_
SVC_STRIPE_CD.
 

Not Required
 
A value is
defaulted based
on the application
context.
 

Not required
 

HtmlFlag
 

A Y/N value
indicating if the

Varchar
 

1
 

A default value of
"N" is provided. If a

Not required
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Smart
Text Record

Updating an
Existing Smart
Text Record

SmartText contains
HTML.
 

value is populated,
 validation is
performed against
the list of valid
values in the
lookup type YES_
NO.
 

The value "N" is
defaulted, if no
value is provided.
 

Scope
 

Indicates if the
SmartText is
private or public
 

Varchar
 

20
 

A default value of
"ORA_SVC_USER"
is provided. If a
value is populated,
 validation is
performed against
the list of valid
values in the
lookup type ORA_
SVC_STDTXT_
SCOPE_CD.
 

Not required
 
The value "ORA_
SVC_USER" is
defaulted, if no
value is provided.
 

Not required
 

Domain
 

Specifies the
domain to which
the SmartText is
assigned
 

Varchar
 

30
 

No default value
is provided. If a
value is populated,
 validation is
performed against
the list of valid
values in the
lookup type ORA_
SVC_STDTXT_
DOMAIN_CD.
 

Not required
 

Not required
 

Object
 

Specifies the
business object
to which the
SmartText is
associated.
 

Varchar
 

150
 

No default value
is provided. The
value provided
should be a
value of the
VIEW_OBJECT_
CODE from the
SVC_STD_TXT_
OBJECTS table.
For instance,
ServiceRequestVO.
 

Required
 

Not required
 

StartDate
 

Allows you
to specify a
date when the
SmartText is valid.
 

Date
 

The system date is
used, if no value is
specified.
 

Not required
 

Not required
 

EnabledFlag
 

Specifies if the
SmartText is
available for use.
 

Varchar
 

1
 

A default value of
"Y" is provided. If a
value is populated,
 validation is
performed against
the list of valid
values in the

Not required
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Smart
Text Record

Updating an
Existing Smart
Text Record

lookup type YES_
NO.
 

UserPartyId
 

The foreign key
value to the Parties
table
 

Number
 

18
 

Import any new
parties into the
database.
 

Conditionally
Required.
 
If the Scope is
set to ORA_SVC_
USER, either the
UserPartyId or
the Registry ID is
required.
 

Not required
 

Registry ID
 

This is the public
unique identifier of
the user assigned
to this private
SmartText.
 

Varchar
 

30
 

Import any new
parties into the
database.
 

Conditionally
Required.
 
If the Scope is
set to ORA_SVC_
USER, either the
UserPartyId or
the Registry ID is
required.
 

Not required
 

Folder ID
 

The foreign key
value to the
SmartText folders
table
 

Number
 

18
 

Import any new
SmartText folders
into the database.
 

Conditionally
Required.
 
If the Scope is
set to ORA_SVC_
GLOBAL, either the
Folder ID or the
FolderUniqueNumber
is required.
 

Not required
 

FolderUniqueNumber
 

This is the public
unique identifier of
the user assigned
to the folder of this
SmartText.
 

Varchar
 

30
 

Import any new
SmartText folders
into the database.
 

Conditionally
Required.
 
If the Scope is
set to ORA_SVC_
GLOBAL, either the
Folder ID or the
FolderUniqueNumber
is required.
 

Not required
 

BuOrgId This is the
business unit
organization Id. If
multiple business
unit support is
enabled using
the HZ_ENABLE_
MULTIPLE_BU_
CRM profile option,
this value will allow
segregation of
data accordingly.

Number 18 No Validation Not Required
 
A value is
defaulted based
on the application
context.
 

Not Required
 
A value is
defaulted based
on the application
context.
 

775



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Smart
Text Record

Updating an
Existing Smart
Text Record

Text
 

This is the text
of the SmartText
record.
 

Long Text
 

No Validation
 

Required
 

Not required
 

Language
 

This is the
language code for
which the text is
associated.
 

Varchar
 

4
 

No Validation
 
The value must
exist in the
LANGUAGE_
CODE from FND_
LANGUAGES_VL.
 

Required
 

Not required
 

You can view the SmartText object and attributes in the Manage Import Objects page of the Import Management flow.
You can find attribute information like type, length, and description on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the StandardText object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select StandardText from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You will see that the source and target attributes are automatically mapped in the Map Fields page. Review and

edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit to complete the request.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your SmartText Folder Data  
You can use Import Management to create or update SmartText Folder records.

To import SmartText Folder records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your SmartText Folder data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure any prerequisite setups are completed.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "Id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the StandardTextFolder object, this attribute is Folder ID.

• Public unique identifiers: If you are creating new records, then you can provide a user-friendly public unique
identifier (PUID) which is an attribute denoted with 'Number'. For the SmartText object, the attribute is
FolderUniqueNumber. If you update a record for which you have previously provided a FolderUniqueNumber,
you can use the FolderUniqueNumber attribute to identify the record.

Required Attributes and Validations for SmartText Folder Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new SmartText
Folder records, required attributes for updating SmartText Folder records, prerequisite setup tasks for the attributes,
and specific validations, if any, for SmartText Folder import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
SmartText Folder
Record

Updating
an Existing
SmartText Folder
Record

FolderId
 

The unique Id
for the existing
SmartText Folder
record in the
Oracle Fusion
destination table.
 

Number
 

18
 

No Validation
 

Not required
 

Conditionally
required
 
A value is required
if you're updating
an existing
SmartText Folder
and you're not
providing the
Folder Unique
Number.
 

ParentId
 

The Folder ID of
the parent folder
 

Number
 

18
 

No Validation
 

Not required
 
If populated,
 this can be
used instead of
ParentFolderUniqueNumber.
 

Not required
 

Name
 

Name of the
SmartText Folder
 

Varchar
 

50
 

Validation is
performed for
the creation of
a SmartText
folder to ensure
the following

Required
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
SmartText Folder
Record

Updating
an Existing
SmartText Folder
Record

combination of
values doesn't
exist:
 

• Name

• UserPartyID

• Domain

• StripeCd

• BuOrgId

FolderUniqueNumber
 

The unique
number used
to identify a
SmartText folder.
You can configure
the folder unique
number to a
format that's best
suitable to your
organizational
requirements.
 

Varchar
 

30
 

Validation is
performed for
the creation of a
SmartText folder,
ensuring the folder
unique number
isn't already in use.
 

Not required
 
You can accept
system generated
values or provide
a unique value
according to your
organizational
business needs.
 

Conditionally
required
 
A value is required
if you're updating
an existing
SmartText Folder
and you're
not providing
the SmartText
Folder Identifier
(FolderId).
 

ParentFolderUniqueNumber
 

The unique
number used to
identify a Parent
SmartText Folder.
 

Varchar
 

30
 

Validation is
performed for
the creation of a
SmartText Folder,
 ensuring the
Parent SmartText
Folder unique
number is a valid
Folder Unique
Name.
 

Not required
 
If populated,
 this can be
used instead of
ParentFolderId.
 

Not required
 

StripeCd
 

The stripe to which
this SmartText
folder is associated
 

Varchar
 

30
 

A value is
defaulted based
on the application
context. However,
 if a value is
populated,
 validation is
performed against
the list of valid
values in the
lookup type ORA_
SVC_STRIPE_CD.
 

Not Required
 
A value is
defaulted based
on the application
context.
 

Not required
 

Domain
 

Specifies the
domain to which
the SmartText
folder is assigned
 

Varchar
 

30
 

No default value
is provided. If a
value is populated,
 validation is
performed against
the list of valid
values in the

Not required
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
SmartText Folder
Record

Updating
an Existing
SmartText Folder
Record

lookup type ORA_
SVC_STDTXT_
DOMAIN_CD.
 

BuOrgId This is the
business unit
organization ID. If
multiple business
unit support is
enabled using
the HZ_ENABLE_
MULTIPLE_BU_
CRM profile option,
this value will allow
segregation of
data accordingly.

Number 18 No Validation Not Required
 
A value is
defaulted based
on the application
context.
 

Not Required
 
A value is
defaulted based
on the application
context.
 

You can view the StandardTextFolder object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, and description on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the StandardTextFolder object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select StandardTextFolder from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit to complete the request.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your SmartText User Variable Data  
You can use Import Management to create, update, or delete SmartText User Variable records.

To import SmartText User Variable records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your SmartText User Variable data into Oracle Applications Cloud, you must populate a .csv file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure any prerequisite setups are completed.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use
the internal ID of the record, a system-generated unique identifier Attributes with "Id" in the attribute name
are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the SmartText User Variable object, this attributes is
VariableId.

• Public unique identifiers: If you are creating new records, then you can provide a user-friendly public
unique identifier (PUID) which is an attribute denoted with 'Number'. For the SmartText object, the
attribute is VariableUniqueNumber. If you update a record for which you have previously provided a
VariableUniqueNumber, you can use the VariableUniqueNumber attribute to identify the record.

Required Attributes and Validations for SmartText User Variable Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new SmartText
User Variable records, required attributes for updating SmartText User Variable records, prerequisite setup tasks for the
attributes, and specific validations, if any, for SmartText User Variable import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
SmartText User
Variable Record

Updating
an Existing
SmartText User
Variable Record

VariableId
 

The unique Id
for the existing
SmartText User
Variable record in
the Oracle Fusion
destination table.
 

Number
 

18
 

No Validation
 

Not required
 

Conditionally
required
 
A value is required
if you're updating
an existing
SmartText User
Variable and you're
not providing the
Variable Unique
Number.
 

Variable
 

Name of the
SmartText User
Variable
 

Varchar
 

50
 

Validation is
performed for
the creation of a
SmartText user
variable to ensure
the following
combination of
values doesn't
exist:
 

• Variable

• Context

Required
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
SmartText User
Variable Record

Updating
an Existing
SmartText User
Variable Record

• StripeCd

• BuOrgId

VariableUniqueNumber
 

The unique
number used
to identify a
SmartText user
variable. You can
configure the
variable unique
number to a
format that's best
suitable to your
organizational
requirements.
 

Varchar
 

30
 

Validation
performed for
the creation of a
SmartText user
variable, ensuring
the SmartText user
variable unique
number isn't
already in use.
 

Not required
 
You can accept
system generated
values or provide
a unique value
according to your
organizational
business needs.
 

Conditionally
required
 
A value is required
if you're updating
an existing
SmartText User
Variable and you're
not providing the
SmartText User
Variable Identifier
(VariableId).
 

StripeCd
 

The stripe to which
this SmartText
user variable is
associated
 

Varchar
 

30
 

A value is
defaulted based
on the application
context. However,
 if a value is
populated,
 validation is
performed against
the list of valid
values in the
lookup type ORA_
SVC_STRIPE_CD.
 

Not Required
 
A value is
defaulted based
on the application
context.
 

Not required
 

Object
 

Specifies the
business object
to which the
SmartText
user variable is
associated.
 

Varchar
 

30
 

No default value
is provided. The
value provided
should be a
value of the
VIEW_OBJECT_
CODE from the
SVC_STD_TXT_
OBJECTS table.
For instance,
ServiceRequestVO.
 

Not required
 

Not required
 

Context
 

Specifies the
context to which
the SmartText
user variable is
associated.
 

Varchar
 

50
 

A default value
of ORA_SVC_
SR is provided.
However, if a
value is populated,
 validation is
performed against
the list of valid
values in the
lookup type ORA_
SVC_STDTXT_
TYPE_CD.
 

Not required
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a
SmartText User
Variable Record

Updating
an Existing
SmartText User
Variable Record

BuOrgId This is the
business unit
organization ID. If
multiple business
unit support is
enabled using
the HZ_ENABLE_
MULTIPLE_BU_
CRM profile option,
this value will allow
segregation of
data accordingly.

Numver 18 Not Required
 
A value is
defaulted based
on the application
context.
 

Not Required
 
A value is
defaulted based
on the application
context.
 

You can view the StandardTextUserVariable object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, and description on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the StandardTextUserVariable object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select StandardTextUserVariable

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit to complete the request.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
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2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Source System Reference Data  
You can use Import Management to create or update Source System Reference records.

To import Source System Reference records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Source System Reference data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.
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The preferred options for uniquely identifying an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the
internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are
typically internal IDs. Use this option only if you're updating Source System References. You can determine the
internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database
query. Using an internal ID typically provides better performance and reduces the import duration. For the
Source System Reference object, the attributes are SourceSystemReferenceId and PartyId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object's UI, you can use the Number attribute to identify the record. For the Source System Reference
object, the attribute is PartyNumber.

Required Attributes and Validations for Source System Reference Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Source System
Reference records, required attributes for updating Source System Reference records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Source System Reference import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Source
System Reference
Record

Updating an
Existing Source
System Reference
Record

SourceSystemReferenceId
 

Source system
reference identifier.
This is a primary
key.
 

Number
 

18
 

No validation
 

Not required
 

If you can export
the existing
source system
reference, provide
this primary key
to identify the
record for further
updates.
 

SourceSystem
 

Original source
system name
 

Varchar
 

30
 

This has to be
in HZ_ORIG_
SYSTEMS_B with
status "A".
 

Provide a valid
value.
 

Not required
 

SourceSystemReferenceValue
 

Identifier in the
original source
system.
 

Varchar
 

255
 

No validation
 

Provide a valid
value.
 

Not required
 

Status
 

Denotes either
ACTIVE or
INACTIVE
 

Varchar
 

1
 

No validation
 

Not required
 

Not required
 

StartDate
 

Start date of the
source system
reference in the
source system.
 

Date
 

 No validation
 

If you don't provide
a value, it defaults
to the current date.
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Source
System Reference
Record

Updating an
Existing Source
System Reference
Record

EndDate
 

End date of the
source system
reference in the
source system.
 

Date
 

 No validation
 

If you don't provide
a value, it defaults
to 12/31/4712.
 

Not required
 

PartyId
 

Party identifier to
which the source
system reference is
associated
 

Number
 

18
 

No validation
 

Provide one of the
following :
 

• PartyId

• Party Number

• A
combination
of Party
Source
System and
Party Source
System
Reference
Value

Not required
 

PartyNumber
 

Party's PUID to
which the source
system reference is
associated
 

Varchar
 

30
 

No validation
 

Provide one of the
following :
 

• PartyId

• Party Number

• A
combination
of Party
Source
System and
Party Source
System
Reference
Value

Not required
 

Party Source
System
 

Specifies the
original source
system of the party
 

Varchar
 

30
 

No validation
 

Provide one of the
following :
 

• PartyId

• Party Number

• A
combination
of Party
Source
System and
Party Source
System
Reference
Value

Not required
 

Party Source
System Reference
Value

Specifies the
party's source
system reference

Varchar
 

255
 

No validation
 

Provide one of the
following :
 

Not required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Source
System Reference
Record

Updating an
Existing Source
System Reference
Record

 in the original
source system
 

• PartyId

• Party Number

• A
combination
of Party
Source
System and
Party Source
System
Reference
Value

You can view the Source System Reference object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Note:  To directly update the SourceSystemReferenceValue field, you must use the SourceSystemReferenceId as the
record identifier.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Source System Reference object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Source System Reference

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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You can use the following steps to inactivate origin system and origin system reference for the source system reference
object:

1. Create a source CSV file with values for the attributes SourceSystem, SourceSystemReferenceValue, and
SourceSystemReferenceId. You can find the values for these attributes by exporting the source system
reference object records using Export Management.

2. Create an import activity using the object Source System and the import mode Delete records.
3. If required, map the attributes on the Map Fields page, and submit the import activity.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

How do I import subscription data?  
You can use import management to create or update Subscription records.

To import Subscription records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription object, the attributes are SubscriptionNumber, ExemptCertificateNumber, and BillToAccountNumber.

Required Attributes and Validations for Subscription Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
records, required attributes for updating Subscription records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Subscription import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Record

Updating an Existing
Subscription Record

ChargeDefinition The definition that
indicates the purpose of the
charge.

This must be setup in
Fusion Pricing.

Required Not Required

DefinitionOrganizationId
 

The item master
organization
 

This must be a valid
ORGANIZATION_ID
from the HR_ALL_
ORGANIZATION_UNITS_F
table.
 

Not required
 

Not required
 

PartialPeriodType
 

The partial period type. The
values might be actual or
fixed.
 

Lookup: ORA_OSS_
PERIOD_TYPE
 

Not required
 

Not required
 

PartialPeriodStart
 

The partial period start.
The values might be
calendar or service.
 

Lookup: ORA_OSS_
PERIOD_START
 

Not required
 

Not required
 

SubscriptionId
 

The subscription ID
 

This is automatically
generated when the record
is created.
 

Not required
 

Not required
 

BusinessUnitId
 

The business unit ID
 

This must be a valid
business unit ID.

Required
 

Not required
 

790



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Record

Updating an Existing
Subscription Record

 

LegalEntityId
 

The legal entity ID
 

This must be value record
as per GL_LEDGER_LE_V.
 

Required
 

Not required
 

SubscriptionProfileId
 

The subscription profile ID
 

This must be a valid
subscription profile ID -
OSS_SUBSCRIPTION_PROFILE.
 

Required
 

Not required
 

PrimaryPartyId
 

The primary party ID
 

Lookup: HZ_PARTIES
 

Required
 

Not required
 

Currency
 

The subscription currency.
 

This must be a valid
currency.
 

Required
 

Not required
 

Status
 

The subscription status
 

This must be ORA_DRAFT
or ORA_ACTIVE.
 

Required
 

Not required
 

AccountingRuleId
 

The accounting rule ID
 

RA_RULES.RULE_ID where
TYPE in 'A','ACC_DUR', 'PP_
DR_ALL', or 'PP_DR_PP'
 

Not required
 

Not required
 

TransactionTypeName
 

The accounts receivables
transaction type name
 

This must be a valid
transaction type name as
per the RA_CUST_TRX_
TYPES_ALL table.
 

Required
 

Not required
 

BillToAccountId
 

The bill-to account ID
 

HZ_CUST_
ACCOUNTS.CUST_
ACCOUNT_ID
 

Required
 

Not required
 

BillToSiteUseId
 

The bill-to site use ID
 

HZ_CUST_SITE_USES_
ALL.SITE_USE_ID
 

Required
 

Not required
 

SubscriptionNumber
 

The subscription number
 

This must be a unique
number. It can be an
alphanumeric value. This
serves as the PUID for the
subscription.
 

Required
 

Required
 

ShipToPartySiteId
 

The ship-to part site ID
 

HZ_CUST_SITE_USES_
ALL.SITE_USE_ID
 

Not required
 

Not required
 

ShipToSite
 

The ship-to site
 

HZ_CUST_SITE_USES_
ALL.SITE_USE_ID
 

Not required
 

Not required
 

PaymentMethod
 

The payment method
 

This must be ORA_
PURCHASE_ORDER or
ORA_WIRE.
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Record

Updating an Existing
Subscription Record

PaymentMethodName
 

The payment method name
 

This must be Purchase
Order or Wire.
 

Not required
 

Not required
 

PaymentTermsName
 

The payment terms name
 

RA_TERMS_VL.NAME
 

Not required
 

Not required
 

TaxClassificationCode
 

The tax classification code
 

LOOKUP_TYPE:
ZX_OUTPUT_
CLASSIFICATIONS
 

Not required
 

Not required
 

TaxClassificationMeaning
 

The tax classification
meaning
 

LOOKUP_TYPE:
ZX_OUTPUT_
CLASSIFICATIONS
 

Not required
 

Not required
 

ExemptCertificateNumber
 

The tax exempt certificate
number
 

ZX_EXEMPTIONS_
V.EXEMPT_CERTIFICATE_
NUMBER
 

Not required
 

Not required
 

ExemptReason
 

The tax exempt reason
code
 

LOOKUP_TYPE: ZX_
EXEMPTION_CONTROL
 

Not required
 

Not required
 

ExemptReasonMeaning
 

The tax exempt reason
meaning
 

LOOKUP_TYPE: ZX_
EXEMPTION_CONTROL
 

Not required
 

Not required
 

TaxExemptionHandling
 

The tax exemption
handling code
 

LOOKUP_TYPE: ZX_
EXEMPTION_CONTROL
 

Not required
 

Not required
 

TaxExemptionHandlingName
 

The tax exemption
handling name
 

LOOKUP_TYPE: ZX_
EXEMPTION_CONTROL
 

Not required
 

Not required
 

DocumentFiscalClassification
 

The document fiscal
classification
 

ZX_FC_DOCUMENT_
FISCAL_
V.CLASSIFICATION_CODE
 

Not required
 

Not required
 

CustomerAcceptance
 

The customer acceptance
 

Lookup:
ORA_OSS_CUST_ACCEPTANCE
- Values REQUIRED OR
NOTREQUIRED
 

Not required
 

Not required
 

InternalApproval
 

The internal approval
 

Lookup: ORA_OSS_INT_
APPROVAL_OPTIONS
 

Not required
 

Not required
 

LayoutTemplate
 

The layout template
 

This must be a valid layout
template setup in the BI
publisher.
 

Not required
 

Not required
 

CommunicationChannel
 

The communication
channel
 

Lookup:
ORA_OSS_COMM_CHANNEL

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Record

Updating an Existing
Subscription Record

- Values EMAIL, OFFLINE,
ONLINE, CUSTOM
 

PrimarySalesPerson
 

The primary sales person
 

This must be a valid sales
person.
 

Not required
 

Not required
 

NegotiationLanguage
 

The negotiation language
 

fnd_languages_
vl.LANGUAGE_CODE
 

Not required
 

Not required
 

QuoteToContactId
 

The contact ID to which
renewal quote is sent to
 

This must be a valid contact
ID.
 

Not required
 

Not required
 

EnableRenewalRemindersFlag
 

Check box for the enable
renewal reminders
 

Y or N
 

Not required
 

Not required
 

RenewalProcess
 

Renewal Process
 

Lookup: ORA_OSS_
RENEWAL_TYPE
 

Not required
 

Not required
 

CurrencyConversionRate
 

The currency conversion
rate
 

This must be valid as per
GL_DAILY_CONVERSION_
TYPES.
 

Not required
 

Not required
 

CurrencyConversionRateType
 

The currency conversion
rate type
 

This must be valid as per
GL_DAILY_CONVERSION_
TYPES.
 

Not required
 

Not required
 

Duration
 

The subscription duration
 

This must be an integer.
 

Not required
 

Not required
 

Period
 

The subscription period
 

This must be a valid value
from OSS_TIME_CODE_
UNITS.
 

Not required
 

Not required
 

EndDate
 

The end date of the
subscription
 

This date must be equal to
or later than the start date.
 

Not required
 

Not required
 

CloseReason
 

The close reason
 

Lookup: ORA_OSS_CLOSE_
REASONS
 

Not required
 

Not required
 

BusinessUnitName
 

The business unit name
 

This must be a valid
business unit name.
 

Not required
 

Not required
 

LegalEntityName
 

The legal entity name
 

This must be valid as per
the GL_LEDGER_LE_V
table.
 

Not required
 

Not required
 

SubscriptionProfileName
 

The subscription profile
name
 

This must be a valid
subscription profile name.

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Record

Updating an Existing
Subscription Record

OSS_SUBSCRIPTION_
PROFILE
 

PrimaryPartyName
 

The primary party name
 

This must be a valid party
name.
 

Not required
 

Not required
 

CurrencyName
 

The name of the
subscription currency.
 

This must be a valid
currency name.
 

Not required
 

Not required
 

RenewalSubscriptionProfileId
 

The renewal subscription
profile ID
 

This must be a valid
subscription profile ID -
OSS_SUBSCRIPTION_PROFILE.
 

Not required
 

Not required
 

DefaultLanguage
 

The default language
 

fnd_languages_
vl.LANGUAGE_CODE
 

Not required
 

Not required
 

GenerateBillingSchedule
 

The check box for
generating the billing
schedule
 

Must be Y or N
 

Not required
 

Not required
 

TransactionType
 

The accounts receivables
transaction type
 

This must be a valid
transaction type as per the
RA_CUST_TRX_TYPES_ALL
table.
 

Not required
 

Not required
 

PricingSystem
 

The pricing system
 

ORA_OSS_FUSION, ORA_
OSS_THIRD_PARTY
 

Not required
 

Not required
 

RenewalCustomerAcceptance
 

The renewal customer
acceptance
 

This must either
be REQUIRED or
NOTREQUIRED.
 

Not required
 

Not required
 

RenewalInternalApproval
 

The renewal internal
approval
 

This must either
be REQUIRED or
NOTREQUIRED.
 

Not required
 

Not required
 

RenewalPriceAdjustmentBasis
 

The renewal price
adjustment basis
 

Lookup:
ORA_OSS_RNWL_PRICE_ADJ_BASIS
Value - ORA_NET_PRICE
 

Not required
 

Not required
 

RenewalPriceAdjustmentPercent
 

The renewal price
adjustment percentage
 

This must be a positive
integer.
 

Not required
 

Not required
 

RenewalPriceAdjustmentType
 

The renewal price
adjustment type
 

Lookup:
ORA_OSS_RNWL_PRICE_ADJ_TYPE
Values - ORA_MARKUP,
ORA_MARKDOWN,
ORA_REPRICE
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Record

Updating an Existing
Subscription Record

UsageCapture
 

The usage capture mode
for the subscription
 

ORA_FUSION, ORA_THIRD_
PARTY
 

Not required
 

Not required
 

ClosedDate
 

The date on which the
subscription was closed.
 

This date must be later than
the start date.
 

Not required
 

Not required
 

CloseCreditMethod
 

The close credit method
 

Lookup: ORA_OSS_CLOSE_
CREDIT_METHOD
 

Not required
 

Not required
 

CancelReason
 

The reason for canceling
the subscription
 

This must be a valid
reason. Lookup: ORA_OSS_
CANCEL_REASONS
 

Not required
 

Not required
 

CanceledDate
 

The date on which the
subscription was canceled
 

This must be between the
start date and the end date.
 

Not required
 

Not required
 

BillService
 

The bill service code
 

Lookup: ORA_OSS_BILL_
SERVICE. Values could be
ORA_DO_NOT_BILL, ORA_
BILL, or ORA_BILL_ON_
RENEWAL.
 

Not required
 

Not required
 

BillServiceName
 

The bill service option
 

Lookup: ORA_OSS_BILL_
SERVICE. The values might
be Do not bill, Bill, or Bill on
renewal.
 

Not required
 

Not required
 

InvoicingRuleId
 

The invoicing rule ID
 

RA_RULES.RULE_ID where
TYPE ='I'
 

Not required
 

Not required
 

InvoicingRuleName
 

The invoicing rule name
 

RA_RULES.NAME where
TYPE ='I'
 

Not required
 

Not required
 

BillingDateCode
 

The billing date code
 

Lookup: ORA_OSS_
BILLING_DATE
 

Not required
 

Not required
 

BillingDateName
 

The billing date name
 

Lookup: ORA_OSS_
BILLING_DATE
 

Not required
 

Not required
 

BillingFrequency
 

The billing frequency code
 

oss_time_code_units.user_
uom_code
 

Not required
 

Not required
 

BillingFrequencyName
 

The billing frequency name
 

oss_time_code_units.user_
uom_code
 

Not required
 

Not required
 

AccountingRuleName
 

The accounting rule name
 

RA_RULES.NAME where
TYPE in ('A','ACC_DUR', 'PP_
DR_ALL','PP_DR_PP')

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Record

Updating an Existing
Subscription Record

 

BillingSystem
 

The billing system
 

Lookup: ORA_OSS_
BILLING_SYSTEM
 

Not required
 

Not required
 

BillToAccountNumber
 

The bill-to account number
 

HZ_CUST_
ACCOUNTS.ACCOUNT_
NUMBER
 

Not required
 

Not required
 

BillToAccountDescription
 

The bill-to account
description
 

Lookup: HZ_CUST_
ACCOUNTS
 

Not required
 

Not required
 

BillToAddress
 

The bill-to address
 

Lookup: HZ_CUST_SITE_
USES_ALL
 

Not required
 

Not required
 

ShipToParty
 

The ship-to party
 

Lookup: HZ_PARTIES
 

Not required
 

Not required
 

ShipToPartyName
 

The ship-to party name
 

Lookup: HZ_PARTIES
 

Not required
 

Not required
 

You can view the Subscription object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

796



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Note:
• To generate the billing schedule based on your pricing, set the GenerateBillingSchedule option to Yes and re-

import the Subscription.csv file after all files have been imported. Also, to activate your subscription, you need
to re-import the Subscription.csv file after importing all required files.

Before generating the billing schedule through import make sure the imported subscription has charges in
product's pricing tab. If there isn't any charge then you need to import the subscription product charge first and
then generate the billing schedule.

• You can DELETE records for Subscription management while in DRAFT status.

• To create an included warranty, you need to set the value of WarrantyYN to Y. Included warranty can be imported
only if the subscription is in Active status.

• To import subscription contracts and supporting documents see Import Your Attachment Data in the Related
Topics section. The codes for attachment categories are OSS_SUBCSRIPTION_AGREEMENT for supporting
documents and OSS_SUPPORTING_DOCUMENTS for subscription primary contract attachment.

• You can update usage quantity through import by passing UsageAcquiredFlag as Y. Don't pass ListPrice, Amount,
and UsagePricedFlag attributes in your CSV file.

• When a Subscription is activated using Import management, the approval rules aren't triggered. You can trigger
the approval rules in the UI.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription  object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

• Import Your Attachment Data

Import Your Subscription Bill Adjustment Data  
You can use import management to create or update Subscription Bill Adjustment records.

To import Subscription Bill Adjustment records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Bill Adjustment data into Oracle Applications Cloud, you need to populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Bill Adjustment object, the attribute is SequenceNumber.

Required Attributes and Validations for Subscription Bill Adjustment
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Bill
Adjustment records, required attributes for updating Subscription Bill Adjustment records, prerequisite setup tasks for
the attributes, and specific validations, if any, for Subscription Bill Adjustment import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Bill Adjustment Record

Updating an Existing
Subscription Bill
Adjustment Record

BillAdjustmentId
 

The bill adjustment ID
 

Do not pass any value.
 

Not required
 

Not required
 

AdjustmentValue
 

The adjustment value
 

This must be a positive
number.
 

Required
 

Not required
 

AdjustmentType
 

The adjustment type
 

ORA_DISCOUNT_AMOUNT,
ORA_DISCOUNT_PERCENT,
 ORA_MARKUP_AMOUNT,
 ORA_MARKUP_PERCENT,
 ORA_PRICE_OVERRIDE
 

Required
 

Not required
 

AdjustmentBasis
 

The adjustment basis
 

ORA_LIST_PRICE, ORA_
NET_PRICE

Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Bill Adjustment Record

Updating an Existing
Subscription Bill
Adjustment Record

 

SequenceNumber
 

The adjustment sequence
number
 

This must be a unique
bill adjustment sequence
number.
 

Not required
 

Not required
 

AutoAdjustmentFlag
 

Option indicating whether
the subscription bill should
be auto adjusted
 

Y or N
 

Required
 

Not required
 

BillLineId
 

The bill line ID
 

Do not pass any value.
 

Not required
 

Not required
 

BillLinePuid
 

The bill line PUID
 

This must be a valid bill line
PUID.
 

Required
 

Not required
 

BillAdjustmentPuid
 

The bill line PUID
 

This must be a valid bill line
PUID.
 

Required
 

Not required
 

SubscriptionId
 

The subscription ID
 

Do not pass any value.
 

Not required
 

Not required
 

SubscriptionProductId
 

The subscription product ID
 

Do not pass any value.
 

Not required
 

Not required
 

ChargeAdjustmentId
 

The charge adjustment ID
 

Do not pass any value.
 

Not required
 

Not required
 

Effectivity
 

The effectivity of the
subscription bill adjustment
 

Do not pass any value.
 

Not required
 

Not required
 

NumberOfPeriods
 

The number of periods of
adjustment
 

Do not pass any value.
 

Not required
 

Not required
 

PeriodFrom
 

The period from when the
subscription bill adjustment
starts
 

Do not pass any value.
 

Not required
 

Not required
 

PeriodUntil
 

The period till when the
subscription bill adjustment
is valid
 

Do not pass any value.
 

Not required
 

Not required
 

CurrencyCode
 

The currency code
 

Do not pass any value.
 

Not required
 

Not required
 

BasisEnableFlag
 

Option for basis
enablement
 

Do not pass any value.
 

Not required
 

Not required
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You can view the Subscription Bill Adjustment object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Bill Adjustment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Bill

Adjustment from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?
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Import Your Subscription Charge Adjustment Data  
You can use import management to create or update Subscription Charge Adjustment records.

To import Subscription Charge Adjustment records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Charge Adjustment data into Oracle Applications Cloud, you need to populate a CSV file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Charge Adjustment object, the attribute is SequenceNumber.
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Required Attributes and Validations for Subscription Charge Adjustment
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
Charge Adjustment records, required attributes for updating Subscription Charge Adjustment records, prerequisite
setup tasks for the attributes, and specific validations, if any, for Subscription Charge Adjustment import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Charge Adjustment
Record

Updating an Existing
Subscription Charge
Adjustment Record

ChargeAdjustmentId
 

The charge adjustment ID
 

Do not pass any value.
 

Not required
 

Not required
 

ChargePuid
 

The charge PUID
 

This must be a valid charge
PUID.
 

Required
 

Not required
 

ChargeId
 

The charge ID
 

Do not pass any value.
 

Not required
 

Not required
 

ChargeAdjustmentPuid
 

The charge adjustment
PUID
 

This must be a unique
charge adjustment PUID.
 

Required
 

Required
 

PeriodFrom
 

The period from which
the subscription charge
adjustment is valid
 

This must be a valid billing
period.
 

A value is required
when the charge type is
RECURRING and effectivity
is ORA_SPECIFIC_PERIODS.
 

Not required
 

PeriodUntil
 

The period till which
the subscription charge
adjustment is valid
 

This must be a valid billing
period. It must be greater
than or equal to the value in
PeriodFrom.
 

A value is required
when the charge type is
RECURRING and effectivity
is ORA_SPECIFIC_PERIODS.
 

Not required
 

AdjustmentType
 

The adjustment type
 

ORA_DISCOUNT_AMOUNT,
ORA_DISCOUNT_PERCENT,
 ORA_MARKUP_AMOUNT,
 ORA_MARKUP_PERCENT,
 ORA_PRICE_OVERRIDE
 

Required
 

Not required
 

AdjustmentValue
 

The adjustment value
 

This must be a positive
number.
 

Required
 

Not required
 

AdjustmentBasis
 

The adjustment basis
 

ORA_LIST_PRICE, ORA_
NET_PRICE
 

A value is required when
the adjustment type is
discount percent or markup
percent
 

Not required
 

SequenceNumber
 

The sequence number
 

This must be a unique
charge adjustment
sequence number.
 

Not required
 

Not required
 

SubscriptionId The subscription ID Do not pass any value. Not required Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Charge Adjustment
Record

Updating an Existing
Subscription Charge
Adjustment Record

     

SubscriptionProductId
 

The subscription product ID
 

Do not pass any value.
 

Not required
 

Not required
 

AutoAdjustmentFlag
 

Option for auto adjustment
 

Y or N
 

Not required
 

Not required
 

Effectivity
 

The effectivity of the
subscription charge
adjustment
 

ORA_ALL_TERM, ORA_
PERIODS_BEFORE_END_
DT, ORA_PERIODS_AFTER_
START_DT, ORA_SPECIFIC_
PERIODS
 

A value is required
when the charge type is
RECURRING.
 

Not required
 

NumberOfPeriods
 

The number of periods
 

This must be a positive
integer.
 

A value is required
when the charge type is
RECURRING and effectivity
is ORA_PERIODS_AFTER_
START_DT or ORA_
PERIODS_BEFORE_END_
DT.
 

Not required
 

You can view the Subscription Charge Adjustment object along with all its child objects and attributes in the Manage
Import Objects page of the Import Management flow. You can find attribute information like type, length, description,
and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Charge Adjustment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Charge

Adjustment from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
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6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Subscription Charge Tier Data  
You can use import management to create or update Subscription Charge Tier records.

To import Subscription Charge Tier records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Charge Tier data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Charge Tier object, the attribute is SequenceNumber.

Required Attributes and Validations for Subscription Charge Tier Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
Charge Tier records, required attributes for updating Subscription Charge Tier records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Subscription Charge Tier import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Charge Tier Record

Updating an Existing
Subscription Charge Tier
Record

SequenceNumber
 

The sequence number of
the charge tier
 

This must be a unique
sequence number for the
charge tier.
 

Required
 

Not required
 

TierFrom
 

The tier from
 

This must be a positive
integer.
 

Required
 

Not required
 

ListPrice
 

List price for the
subscription charge tier
 

This must be a positive
integer.
 

Required
 

Not required
 

PriceFormat
 

The price format
 

Lookup: ORA_OSS_PRICE_
FORMAT
 

Required
 

Not required
 

ChargeTierId
 

The charge tier ID
 

Do not pass any value.
 

Not required
 

Not required
 

ChargePuid
 

The charge PUID
 

This must be a valid charge
PUID.
 

Required
 

Not required
 

ChargeId
 

The charge ID
 

Do not pass any value.
 

Not required
 

Not required
 

ChargeTierPuid
 

The charge tier PUID
 

This must be a unique
charge tier PUID.
 

A value is auto generated
when a record is created.
 

Required
 

SubscriptionId
 

The Subscription ID
 

Do not pass any value.
 

Not required
 

Not required
 

SubscriptionProductId The subscription product ID Do not pass any value. Not required Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Charge Tier Record

Updating an Existing
Subscription Charge Tier
Record

     

TierTo
 

The tier to
 

This must be greater than
or equal to the value in tier
from.
 

Required
 

Not required
 

BlockSize
 

The block size
 

This must be a positive
number or null.
 

Required
 

Not required
 

You can view the Subscription Charge Tier object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Note:  You must define the Tiers in Pricing system only if you're using Fusion pricing application. Importing Tiers
won't have any effect if Pricing System is Fusion.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Charge Tier object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Charge Tier

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Subscription Contact Data  
You can use import management to create or update Subscription Contact records.

To import Subscription Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Contact data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Contact object, the attributes are ContactPuid and PartyPuid.

Required Attributes and Validations for Subscription Contact Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
Contact records, required attributes for updating Subscription Contact records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Subscription Contact import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Contact Record

Updating an Existing
Subscription Contact
Record

SubscriptionContactId
 

Identifier of the
subscription contact record
 

Do not pass any value. This
value is auto generated.
 

Not required
 

Not required
 

ContactPuid
 

PUID of the subscription
contact record
 

This must be a unique
contact PUID.
 

Required
 

Required
 

SubscriptionId
 

Identifier of the
subscription
 

Do not pass any value.
 

Required
 

Not required
 

SubscriptionPartyId
 

Identifier of the
subscription party
 

Do not pass any value.
 

Required
 

Not required
 

PartyPuid
 

PUID of the subscription
party
 

This must be a valid party
PUID.
 

Required
 

Not required
 

PartyId
 

Identifier of the party
 

Do not pass any value.
 

Not required
 

Not required
 

ContactId
 

Identifier of the contact
 

HZ_RELATIONSHIPS for
external contacts, JTF_RS_
RESOURCE_PROFILES for
internal contacts
 

Required
 

Not required
 

ContactRole
 

Role played by the contact
 

Lookup: ORA_OSS_PARTY_
CONTACT_ROLES
 

Required
 

Not required
 

StartDate
 

Start date of the
subscription contact

Do not pass any value.
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Contact Record

Updating an Existing
Subscription Contact
Record

 

EndDate
 

End date of the
subscription contact
 

Do not pass any value.
 

Not required
 

Not required
 

AccessLevel
 

Access level
 

Do not pass any value.
 

Not required
 

Not required
 

BillingOwnerFlag
 

Option for Billing owner
 

Y or N
 

Not required
 

Not required
 

InternalFlag
 

Internal option
 

Y or N
 

Not required
 

Not required
 

ContactName
 

Contact name
 

Do not pass any value
 

Not required
 

Not required
 

ContactEmail
 

Email address of the
contact
 

Do not pass any value
 

Not required
 

Not required
 

You can view the Subscription Contact object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Contact from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
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7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Subscription Covered Bill Line Data  
You can use import management to create or update Subscription Covered Bill Line records.

To import Subscription Covered Bill Line records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Covered Bill Line data into Oracle Applications Cloud, you need to populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Covered Bill Line object, the attributes are:

• CoveredLevelPuid

• BillLinePuid

• TransactionNumber

• NewCreditMemoPUID

Required Attributes and Validations for Subscription Covered Bill Line
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
Covered Bill Line records, required attributes for updating Subscription Covered Bill Line records, prerequisite setup
tasks for the attributes, and specific validations, if any, for Subscription Covered Bill Line import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Covered Bill Line Record

Updating an Existing
Subscription Covered Bill
Line Record

BillLineId
 

The bill line ID
 

Do not pass any value
 

Not required
 

Not required
 

BillingPeriod
 

The billing period
 

This must be a positive
number and unique for the
product.
 

Required
 

Not required
 

DateToInterface
 

The date to interface
 

This must be a valid date.
 

Not required
 

Not required
 

DateBilledFrom
 

The date from which the
billing starts
 

This must be a valid date.
 

Required
 

Not required
 

DateBilledTo
 

The date up to which the
billing is valid
 

This must be a valid date.
 

Required
 

Not required
 

RecurringFlag
 

Option indicating whether
this line is recurring
 

Y or N
 

Required
 

Not required
 

InterfacedFlag
 

Option indicating whether
the bill line is interfaced

Y or N
 

Required
 

Not required
 

812



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Covered Bill Line Record

Updating an Existing
Subscription Covered Bill
Line Record

 

CoveredLevelId
 

The covered level ID
 

Do not pass any value.
 

Not required
 

Not required
 

CoveredLevelPuid
 

The covered level PUID
 

This must be a valid
covered level PUID.
 

Required
 

Not required
 

BillLinePuid
 

The bill line PUID
 

This must be a unique bill
line PUID.
 

Required
 

Required
 

SubscriptionId
 

The subscription ID
 

Do not pass any value.
 

Not required
 

Not required
 

SubscriptionProductId
 

The subscription product ID
 

Do not pass any value.
 

Not required
 

Not required
 

ChargeId
 

The charge ID
 

This must be a valid charge
ID.
 

Required
 

Not required
 

Amount
 

The amount
 

This must be a positive
number.
 

Required
 

Not required
 

UsageFlag
 

Option indicating whether
the line is a usage line
 

Y or N
 

Required
 

Not required
 

UsageAcquiredFlag
 

Option indicating whether
the usage has been
acquired
 

Y or N
 

Not required
 

Not required
 

UsagePricedFlag
 

Option indicating whether
usage line has been priced
 

Y or N
 

Not required
 

Not required
 

TransactionClass
 

The transaction class
 

This must be INV for
invoice and CM for credit
memo.
 

Required
 

Not required
 

TransactionTax
 

The transaction tax
 

This must be a positive
number.
 

Not required
 

Not required
 

TransactionAmount
 

The transaction amount
 

This must be a positive
number.
 

Not required
 

Not required
 

InvoiceBillLineId
 

The invoice bill line ID
 

Do not pass any value.
 

Not required
 

Not required
 

UsageCaptureDate
 

The usage capture date
 

This must be a valid date.
 

Not required
 

Not required
 

UsageQuantity
 

The usage quantity
 

This must be a positive
number.

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Covered Bill Line Record

Updating an Existing
Subscription Covered Bill
Line Record

 

ChargePeriod
 

The charge period
 

This must be a valid charge
period.
 

Not required
 

Not required
 

PricingError
 

The pricing error
 

Do not pass any value.
 

Not required
 

Not required
 

ListPrice
 

The list price
 

This must be a
positive number when
TransactionClass is INV and
number when it's CM.
 

Required
 

Not required
 

RevenueLineId
 

The revenue line ID
 

Do not pass any value.
 

Not required
 

Not required
 

TransactionClassMeaning
 

The meaning of transaction
class lookup
 

Invoice or Credit Memo
 

Not required
 

Not required
 

InvoiceDate
 

The invoice date
 

This must be a valid date.
 

Not required
 

Not required
 

NewCreditMemoPUID
 

The credit memo PUID
 

Do not pass any value.
 

Not required
 

Not required
 

CreditMemoAmount
 

The credit memo amount
 

Do not pass any value.
 

Not required
 

Not required
 

CreditMemoFlag
 

The credit memo option
 

Do not pass any value.
 

Not required
 

Not required
 

CreditMemoReason
 

The credit memo reason
 

Do not pass any value.
 

Not required
 

Not required
 

CustomerTrxTypeSequenceId
 

The customer transaction
type sequence ID
 

This must be a number.
 

Not required
 

Not required
 

You can view the Subscription Covered Bill Line object along with all its child objects and attributes in the Manage
Import Objects page of the Import Management flow. You can find attribute information like type, length, description,
and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Covered Bill Line object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
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Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Covered Bill

Line from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Subscription Covered Level Data  
You can use import management to create or update Subscription Covered Level records.

To import Subscription Covered Level records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Subscription Covered Level data into Oracle Applications Cloud, you must populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.
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You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud

• Ensure prerequisite setups are done, if applicable

• Understand your options for uniquely identifying the records

• Ensure parent records exist before importing child records

• Identify the target object attributes that are required in the CSV file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier For Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Covered Level object, the attributes are SubscriptionProductPuid and CoveredLevelPuid.

Required Attributes and Validations for Subscription Covered Level Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Subscription Level records, required attributes for updating Subscription Covered Level records, prerequisite setup tasks
for the attributes, and specific validations, if any, for Subscription Covered Level import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Covered Level record

Updating an Existing
Subscription Covered
Level record

Type
 

The type
 

ORA_OSS_COVERED_
LEVEL
 

Required
 

Not required
 

StartDate
 

The start date
 

This must be later than or
equal to the subscription
product start date.
 

Required
 

Not required
 

CoveredLevelId
 

The covered level ID
 

Do not pass any value. This
is auto generated.
 

Not required
 

Not required
 

Quantity
 

The quantity
 

This must be a positive
integer.

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Covered Level record

Updating an Existing
Subscription Covered
Level record

 

SubscriptionProductPuid
 

The subscription product
PUID
 

This must be a valid
subscription product PUID.
 

Required
 

Not required
 

SubscriptionProductId
 

The subscription product ID
 

This is auto generated
when a record is created.
 

Not required
 

Not required
 

SubscriptionId
 

The subscription ID
 

Do not pass any value.
 

Not required
 

Not required
 

CoveredLevelPuid
 

The covered level PUID
 

This must be a unique
PUID.
 

Required
 

Required
 

LineNumber
 

The line number
 

This must not be duplicate
 

Required
 

Not required
 

InventoryItemId
 

The inventory item ID
 

EGP_SYSTEM_ITEMS_
B.INVENTORY_ITEM_ID
 

Required
 

Not required
 

AssetId
 

The asset ID
 

CSE_ASSETS_VL.ASSET_ID
 

Not required
 

Not required
 

AssetName
 

The asset name
 

CSE_ASSETS_VL.ASSET_
NUMBER
 

Not required
 

Not required
 

AssetSerialNumber
 

The asset serial number
 

CSE_ASSETS_VL.SERIAL_
NUMBER
 

Not required
 

Not required
 

ProductName
 

The product name
 

Do not pass any value.
 

Not required
 

Not required
 

TypeName
 

The type name
 

ORA_OSS_COVERED_
LEVEL
 

Not required
 

Not required
 

ItemUnitOfMeasure
 

The item unit of measure
 

INV_UNITS_OF_MEASURE_
B.UOM_CODE
 

Not required
 

Not required
 

TotalContractValue
 

The total contract value
 

Do not pass any value.
 

Not required
 

Not required
 

GenerateBillingSchedule
 

The generate billing
schedule indicator
 

Must be Y or N
 

Not required
 

Not required
 

EndDate
 

The end date
 

This must be earlier
than the end date of the
subscription product.
 

Not required
 

Not required
 

Duration
 

The duration
 

This must be a positive
integer.
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Covered Level record

Updating an Existing
Subscription Covered
Level record

Period
 

The period
 

This must be a valid value
from OSS_TIME_CODE_
UNITS.
 

Not required
 

Not required
 

Status
 

The status
 

This must be ORA_D.RAFT
 

Not required
 

Not required
 

SuspendedDate
 

The date of suspension
 

This must be between the
start date and end date of
the subscription product.
 

Not required
 

Not required
 

StatusName
 

The status meaning
 

Draft
 

Not required
 

Not required
 

PriceUnitOfMeasure
 

The price unit of measure
 

INV_UNITS_OF_MEASURE_
VL.UOM_CODE
 

Not required
 

Not required
 

PriceUnitOfMeasureName
 

The price unit of measure
meaning
 

INV_UNITS_OF_MEASURE_
VL.UNIT_OF_MEASURE
 

Not required
 

Not required
 

PriceListId
 

The price list ID
 

Do not pass any value.
 

Not required
 

Not required
 

PricingError
 

The pricing error
 

Do not pass any value.
 

Not required
 

Not required
 

TaxAmount
 

The tax amount
 

Do not pass any value.
 

Not required
 

Not required
 

CancelReason
 

The cancel reason
 

This must be a valid
reason. Lookup: ORA_OSS_
CANCEL_REASONS
 

Not required
 

Not required
 

CanceledDate
 

The canceled date
 

This must be between the
start date and end date.
 

Not required
 

Not required
 

CanceledAmount
 

The canceled amount
 

Do not pass any value.
 

Not required
 

Not required
 

ClosedDate
 

The closed date
 

This must be later than the
start date.
 

Not required
 

Not required
 

CloseReason
 

The close reason
 

Lookup: ORA_OSS_CLOSE_
REASONS
 

Not required
 

Not required
 

ClosedAmount
 

The closed amount
 

Do not pass any value.
 

Not required
 

Not required
 

ReturnCreditMethod
 

The return credit method
 

Lookup: ORA_OSS_CLOSE_
CREDIT_METHOD
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Covered Level record

Updating an Existing
Subscription Covered
Level record

SuppressedCreditAmount
 

The suppressed credit
amount
 

Do not pass any value.
 

Not required
 

Not required
 

InvoicedAmount
 

The invoiced amount
 

Do not pass any value.
 

Not required
 

Not required
 

CreditedAmount
 

The credited amount
 

Do not pass any value.
 

Not required
 

Not required
 

RenewedDate
 

The renewed date
 

Do not pass any value.
 

Not required
 

Not required
 

RenewalType
 

The renewal type
 

Lookup: ORA_OSS_
RENEWAL_ACTION
 

Not required
 

Not required
 

CurrencyCode
 

The currency code
 

Do not pass any value
 

Not required
 

Not required
 

PutOnHoldFlag
 

Indicates whether the
covered level is put on hold
 

Y or N
 

Not required
 

Not required
 

RemoveHoldFlag
 

Indicates whether the hold
is removed
 

Y or N
 

Not required
 

Not required
 

SuspendCreditMethod
 

The suspend credit method
 

Lookup: ORA_OSS_CLOSE_
CREDIT_METHOD
 

Not required
 

Not required
 

SuspendReason
 

The suspend reason
 

Lookup: ORA_OSS_CLOSE_
REASONS
 

Not required
 

Not required
 

TaxError
 

The tax error
 

Do not pass any value.
 

Not required
 

Not required
 

You can view the Subscription Covered Level object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Subscription Covered Level object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Covered Level

from the Object drop-down list.
4. Select the CSV file in the File Name field and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page, which provides the status details of
the import activity.

Import Your Subscription Covered Level Charge Data  
You can use import management to create or update Subscription Covered Level Charge records.

To import Subscription Covered Level Charge records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Subscription Covered Level Charge data into Oracle Applications Cloud, you must populate a CSV file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud

• Ensure prerequisite setups are done, if applicable

• Understand your options for uniquely identifying the records

• Ensure parent records exist before importing child records

• Identify the target object attributes that are required in the CSV file for a successful import
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier For Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute,
or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record.
For the Subscription Covered Level Charge object, the attributes are CoveredLevelPuid, PrePaymentNumber and
SequenceNumber.

Required Attributes and Validations for Subscription Covered Level Charge
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Subscription Level records, required attributes for updating Subscription Covered Level Charge records, prerequisite
setup tasks for the attributes, and specific validations, if any, for Subscription Covered Level Charge import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Covered Level Charge
record

Updating an Existing
Subscription Covered
Level Charge record

PriceType
 

The price type
 

RECURRING or ONE_TIME
 

Required
 

Not required
 

ChargeId
 

The charge ID
 

Do not pass any value.
 

Not required
 

Not required
 

CoveredLevelPuid
 

The covered level PUID
 

This must be a valid
covered level PUID.
 

Required
 

Not required
 

CoveredLevelId
 

The covered level ID
 

Do not pass any value.
 

Not required
 

Not required
 

ChargePuid
 

The charge PUID
 

This must be a unique
charge PUID.
 

Required
 

Required
 

BillLineId
 

The bill line ID
 

Do not pass any value.
 

Not required
 

Not required
 

PricePeriodicity
 

The price periodicity
 

This must be a valid value
from oss_time_code_units.
 

Required
 

Not required
 

821



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Covered Level Charge
record

Updating an Existing
Subscription Covered
Level Charge record

RollupFlag
 

The option indicating
whether charges should be
rolled up
 

Y or N
 

Not required
 

Not required
 

SequenceNumber
 

The sequence number
 

This must be a positive
number.
 

Not required
 

Not required
 

SubscriptionId
 

The subscription ID
 

Do not pass any value.
 

Not required
 

Not required
 

SubscriptionProductId
 

The subscription product ID
 

Do not pass any value.
 

Not required
 

Not required
 

UnitListPrice
 

The unit list price
 

This must be a valid
number.
 

Required
 

Not required
 

Allowance
 

The allowance
 

Do not pass any value.
 

Not required
 

Not required
 

BlockSize
 

The block size
 

This must be a positive
number.
 

Not required
 

Not required
 

TierType
 

The tier type
 

Do not pass any value.
 

Not required
 

Not required
 

UsagePriceLockFlag
 

Option indicating whether
the usage price is locked
 

Do not pass any value.
 

Not required
 

Not required
 

PricePeriodicityName
 

The price periodicity name
 

Do not pass any value.
 

Not required
 

Not required
 

MeterDefinitionId
 

The meter definition ID
 

This must be a valid meter
definition ID.
 

Not required
 

Not required
 

MeterId
 

The meter ID
 

This must be a valid meter
ID.
 

Not required
 

Not required
 

InitialMeterReadingId
 

The initial meter reading ID
 

This must be a valid meter
reading ID.
 

Not required
 

Not required
 

AggregationMethod
 

The aggregation method
 

This must be a valid
aggregation method.
 

Not required
 

Not required
 

TieredFlag
 

The option indicating
whether the charge has
tiers
 

Y or N
 

Required
 

Not required
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You can view the Subscription Covered Level Charge object along with all its child objects and attributes in the Manage
Import Objects page of the Import Management flow. You can find attribute information like type, length, description,
and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Subscription Covered Level Charge object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Covered Level

Charge from the Object drop-down list.
4. Select the CSV file in the File Name field and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page, which provides the status details of
the import activity.

Import Your Subscription Party Data  
You can use import management to create or update Subscription Party records.

To import Subscription Party records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
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2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Party data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Party object, the attributes are Subscription PartyPUID, SubscriptionNumber, and PartyNumber.

Required Attributes and Validations for Subscription Party Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
Party records, required attributes for updating Subscription Party records, prerequisite setup tasks for the attributes,
and specific validations, if any, for Subscription Party import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Party Record

Updating an Existing
Subscription Party Record

SubscriptionPartyId
 

Identifier of the
subscription party record
 

Do not pass any value. This
is autogenerated.
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Party Record

Updating an Existing
Subscription Party Record

PartyPuid
 

PUID of the subscription
party record
 

This must be a unique
party PUID.
 

Required
 

Required
 

SubscriptionId
 

Subscription ID
 

Do not pass any value.
 

Conditionally required
 

Not required
 

SubscriptionNumber
 

Subscription Number
 

This must be a valid
subscription number.
 

Conditionally required
 

Not required
 

PartyId
 

Party ID
 

This must be a valid party -
HZ_PARTIES
 

Required
 

Not required
 

PartyName
 

Name of the party
 

This must be a valid party
name - HZ_PARTIES
 

Not required
 

Not required
 

PartyNumber
 

Number of the party
 

This must be a valid party
number - HZ_PARTIES
 

Not required
 

Not required
 

PartyRole
 

Role of the party
 

Lookup: ORA_OSS_PARTY_
ROLES
 

Required
 

Not required
 

PrimaryFlag
 

Check box indicating
whether this party is
primary
 

Value must be Y or N
 

Required
 

Not required
 

InternalFlag
 

Check box indicating
whether this party is
internal
 

Value must be Y or N
 

Required
 

Not required
 

You can view the Subscription Party object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Party object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Party from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

How do I import subscription product data?  
You can use import management to create or update Subscription Product records.

To import Subscription Product records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Product data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.
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• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Product object, the attributes are:

• LineNumber

• SubscriptionProductPuid

• BillToAccountNumber

• ExemptCertificateNumber

Required Attributes and Validations for Subscription Product Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
Product records, required attributes for updating Subscription Product records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Subscription Product import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Record

Updating an Existing
Subscription Product
Record

LineNumber
 

The line number
 

• This must not be
duplicate within a
subscription.

• Don't pass values in
LineNumber column
in import file if there
is a requirement to
generate auto_line_
number.

• Don't enable the auto
numbering from

Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Record

Updating an Existing
Subscription Product
Record

subscription profile if
values are provided in
LineNumber column
in import file.

• Don't enable
the check-box
for Automate
Subscription Line
Numbering in
Subscription profile if
there is requirement
to use line number
in following format
'xxxxx-xx-xx'

 

DefinitionOrganizationId
 

The item master
organization
 

This must be a valid
ORGANIZATION_ID
from the HR_ALL_
ORGANIZATION_UNITS_F
table.
 

Not required
 

Not required
 

InventoryItemId
 

The inventory item ID
 

EGP_SYSTEM_ITEMS_
B.INVENTORY_ITEM_ID
 

Required
 

Not required
 

StartDate
 

The start date of the
subscription
 

This must be later than or
equal to the subscription
start date.
 

Required
 

Not required
 

Currency
 

The subscription product
currency
 

Do not pass any value.
 

Not required
 

Not required
 

InvoicingRuleId
 

The invoicing rule ID
 

RA_RULES.RULE_ID where
TYPE ='I'
 

Not required
 

Not required
 

BillingFrequency
 

The billing frequency
 

oss_time_code_units.user_
uom_code
 

Not required
 

Not required
 

AccountingRuleId
 

The accounting rule ID
 

RA_RULES.RULE_ID where
TYPE in ('A','ACC_DUR', 'PP_
DR_ALL','PP_DR_PP')
 

Not required
 

Not required
 

TransactionTypeName
 

The transaction type name
 

This must be a valid
transaction type name per
RA_CUST_TRX_TYPES_ALL
table.
 

Not required
 

Not required
 

BillToAccountId
 

The bill-to account ID
 

HZ_CUST_
ACCOUNTS.CUST_
ACCOUNT_ID
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Record

Updating an Existing
Subscription Product
Record

BillToSiteUseId
 

The bill-to site use ID
 

HZ_CUST_SITE_USES_
ALL.SITE_USE_ID
 

Not required
 

Not required
 

PaymentTermsId
 

The payment terms ID
 

RA_TERMS_VL.TERM_ID
 

Not required
 

Not required
 

SubscriptionProductId
 

The subscription product ID
 

This is auto generated
when a record is created.
 

Not required
 

Required
 

Status
 

The subscription product
status
 

This must be ORA_DRAFT.
 

Not required
 

Not required
 

SubscriptionId
 

The subscription ID
 

Do not pass any value.
 

Not required
 

Not required
 

SubscriptionNumber
 

The subscription number
 

This must be a valid and
existing subscription
number.
 

Required
 

Not required
 

SubscriptionProductPuid
 

The subscription product
PUID
 

This must be a unique
subscription product PUID.
 

Required
 

Not required
 

EnablePricingTermsFlag
 

Option indicating whether
the pricing terms are
enabled
 

Y or N
 

Not required
 

Not required
 

SummarizedBillingFlag
 

Option indicating whether
billing is summarized at
covered product level
 

Y or N
 

Not required
 

Not required
 

InterfaceOffsetDays
 

The interface offset days
 

This must be a number.
 

Not required
 

Not required
 

CoverageName
 

The coverage name
 

OSS_COVEREAGE_
HEADERS.COVERAGE_
HEADER_ID
 

Not required
 

Not required
 

SuspendReason
 

The suspend reason
 

Lookup: ORA_OSS_CLOSE_
REASONS
 

Not required
 

Not required
 

SuspendedDate
 

The date of suspension
 

This must be between the
start date and end date.
 

Not required
 

Not required
 

SuspendCreditMethod
 

The suspend credit method
 

Lookup: ORA_OSS_CLOSE_
CREDIT_METHOD
 

Not required
 

Not required
 

ResumeDate
 

The date of resumption of a
suspended subscription
 

This must be a valid date.
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Record

Updating an Existing
Subscription Product
Record

ResumeDuration
 

The duration for which the
suspended subscription
isn't resumed
 

This must be a positive
integer.
 

Not required
 

Not required
 

ResumePeriod
 

The period for which the
suspended subscription
isn't resumed
 

This must be a valid value
from OSS_TIME_CODE_
UNITS.
 

Not required
 

Not required
 

AutoExtendFlag
 

Option indicating whether
the subscription should be
auto extended
 

Y or N
 

Not required
 

Not required
 

ChurnProbability
 

The churn probability of the
subscription product
 

Do not pass any value.
 

Not required
 

Not required
 

InvoicedAmount
 

The invoiced amount
 

Do not pass any value.
 

Not required
 

Not required
 

CreditedAmount
 

The credited amount
 

Do not pass any value.
 

Not required
 

Not required
 

CanceledAmount
 

The canceled amount
 

Do not pass any value.
 

Not required
 

Not required
 

ClosedAmount
 

The closed amount
 

Do not pass any value.
 

Not required
 

Not required
 

LineNumber
 

The line number
 

This must not be duplicate
within a subscription.
 

Required
 

Not required
 

Duration
 

The duration
 

This must be a positive
integer.
 

Not required
 

Not required
 

Period
 

The subscription product
period
 

This must be a valid value
from OSS_TIME_CODE_
UNITS.
 

Not required
 

Not required
 

GenerateBillingSchedule
 

Option indicating whether
billing schedule is to be
generated
 

Must be Y or N
 

Not required
 

Not required
 

PriceListName
 

The price list name
 

Do not pass any value.
 

Not required
 

Not required
 

PricingTermsPricingMethod
 

The pricing terms pricing
method
 

ORA_MARKUP_AMOUNT,
 ORA_MARKUP_PERCENT,
 ORA_REPRICE
 

Not required
 

Not required
 

PricingTermsPeriod
 

The pricing terms period
 

This must be a valid value
from OSS_TIME_CODE_
UNITS.

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Record

Updating an Existing
Subscription Product
Record

 

PricingTermsDuration
 

The pricing terms duration
 

This must be a positive
integer.
 

Not required
 

Not required
 

PricingTermsAdjustmentPCT
 

The pricing terms
adjustment
 

This must be a positive
integer. Lookup:
 

Not required
 

Not required
 

AmendCreditMethod
 

The amend credit method
 

ORA_OSS_CLOSE_CREDIT_
METHOD
 

Not required
 

Not required
 

AmendCreditMethodName
 

The amend credit method
name
 

Lookup: ORA_OSS_CLOSE_
CREDIT_METHOD
 

Not required
 

Not required
 

AmendEffectiveDate
 

The amend effective date
 

This date must be between
the start and the end dates.
 

Not required
 

Not required
 

AmendReason
 

The amend reason
 

Lookup: ORA_OSS_CLOSE_
REASONS
 

Not required
 

Not required
 

AmendReasonName
 

The amend reason name
 

Lookup: ORA_OSS_CLOSE_
REASONS
 

Not required
 

Not required
 

SalesProductType
 

The sales product type
 

SUBSCRIPTION, COVERAGE
 

Not required
 

Not required
 

ItemUnitOfMeasure
 

The item unit of measure
 

INV_UNITS_OF_MEASURE_
B.UOM_CODE
 

Not required
 

Not required
 

ProductName
 

The product name
 

This must be a valid item
description.
 

Not required
 

Not required
 

Quantity
 

The quantity
 

This must be a positive
integer.
 

Not required
 

Not required
 

CloseReason
 

The reason why the product
was closed
 

Lookup: ORA_OSS_CLOSE_
REASONS
 

Not required
 

Not required
 

CloseCreditMethod
 

The close credit method
 

Lookup: ORA_OSS_CLOSE_
CREDIT_METHOD
 

Not required
 

Not required
 

CancelReason
 

The reason why the product
was canceled
 

This must be a valid
reason. Lookup: ORA_OSS_
CANCEL_REASONS
 

Not required
 

Not required
 

ClosedDate
 

The date on which the
product was closed
 

This must be later than the
start date.
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Record

Updating an Existing
Subscription Product
Record

CanceledDate
 

The date on which the
product was canceled
 

This must be between the
start and end dates.
 

Not required
 

Not required
 

RenewedDate
 

The date on which the
product was renewed
 

Do not pass any value.
 

Not required
 

Not required
 

PriceListId
 

The price list ID
 

Do not pass any value.
 

Not required
 

Not required
 

UnitPrice
 

The unit price
 

This must be a positive
integer.
 

Not required
 

Not required
 

InvoicingRuleName
 

The invoice rule name.
 

RA_RULES.NAME where
TYPE ='I'
 

Not required
 

Not required
 

BillingFrequencyName
 

The billing frequency name
 

oss_time_code_units.base_
uom_code
 

Not required
 

Not required
 

AccountingRuleName
 

The accounting rule name
 

RA_RULES.NAME where
TYPE in ('A','ACC_DUR', 'PP_
DR_ALL','PP_DR_PP')
 

Not required
 

Not required
 

BillToAccountNumber
 

The bill-to account number
 

HZ_CUST_
ACCOUNTS.ACCOUNT_
NUMBER
 

Not required
 

Not required
 

BillToAccountDescription
 

The bill-to account
description
 

HZ_CUST_ACCOUNTS
 

Not required
 

Not required
 

BillToAddress
 

The bill-to address
 

Lookup: HZ_CUST_SITE_
USES_ALL
 

Not required
 

Not required
 

ShipToPartyId
 

The ship-to party ID
 

Lookup: HZ_PARTIES
 

Not required
 

Not required
 

ShipToPartyName
 

The ship-to party name
 

Lookup: HZ_PARTIES
 

Not required
 

Not required
 

ShipToPartySiteId
 

The ship-to party site ID
 

Lookup: HZ_CUST_SITE_
USES_ALL
 

Not required
 

Not required
 

ShipToPartySiteName
 

The ship-to party site name
 

Lookup: HZ_CUST_SITE_
USES_ALL
 

Not required
 

Not required
 

PaymentMethod
 

The payment method ID
 

This must be ORA_
PURCHASE_ORDER or
ORA_WIRE.
 

Not required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Record

Updating an Existing
Subscription Product
Record

PaymentMethodName
 

The payment method name
 

This must be Purchase
Order or Wire.
 

Not required
 

Not required
 

PaymentTermsName
 

The payment terms name
 

RA_TERMS_VL.NAME
 

Not required
 

Not required
 

TaxExemptionHandling
 

The tax exemption
handling
 

LOOKUP_TYPE: ZX_
EXEMPTION_CONTROL
 

Not required
 

Not required
 

TaxExemptionHandlingName
 

The tax exemption
handling name
 

LOOKUP_TYPE: ZX_
EXEMPTION_CONTROL
 

Not required
 

Not required
 

ExemptCertificateNumber
 

The exempt certificate
number
 

ZX_EXEMPTIONS_
V.EXEMPT_CERTIFICATE_
NUMBER
 

Not required
 

Not required
 

ExemptReason
 

The exempt reason
 

LOOKUP_TYPE: ZX_
EXEMPTION_CONTROL
 

Not required
 

Not required
 

OutputTaxClassification
 

The output tax
classification
 

LOOKUP_TYPE:
ZX_OUTPUT_
CLASSIFICATIONS
 

Not required
 

Not required
 

TaxError
 

The tax error
 

Do not pass any value.
 

Not required
 

Not required
 

CoverageScheduleId
 

The coverage schedule ID
 

Do not pass any value.
 

Not required
 

Not required
 

RenewalType
 

The renewal type
 

Lookup: ORA_OSS_
RENEWAL_ACTION
 

Not required
 

Not required
 

BillingDateCode
 

The billing date code
 

ORA_DAY, ORA_OFFSET,
 ORA_PERIOD_END, ORA_
PERIOD_START
 

Not required
 

Not required
 

BillingDateName
 

The billing date name
 

Day, Offset, Period end,
 Period start
 

Not required
 

Not required
 

TotalContractValue
 

The total contract value
 

Do not pass any value.
 

Not required
 

Not required
 

EstimatedTax
 

Estimated Tax
 

Do not pass any value.
 

Not required
 

Not required
 

PricingError
 

The pricing error
 

Do not pass any value.
 

Not required
 

Not required
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Note:  To generate the billing schedule based on your pricing, set the GenerateBillingSchedule option to Yes and re-
import the Subscription.csv file after all files have been imported. You should not provide the GenerateBillingSchedule
option in the Subscription Product CSV file but only in the Subscription CSV file.

You can view the Subscription Product object along with all its child objects and attributes in the Manage Import Objects
page of the Import Management flow. You can find attribute information like type, length, description, and so on, on
this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Product object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Product from

the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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How do I import subscription product bill line data?  
You can use import management to create or update Subscription Product Bill records.

To import Subscription Product Bill records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Product Bill data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Product Bill object, the attributes are CoveredLevelPuid, PrePaymentNumber and SequenceNumber.

Required Attributes and Validations for Subscription Product Bill Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
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Product Bill records, required attributes for updating Subscription Product Bill records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Subscription Product Bill import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Bill Record

Updating an Existing
Subscription Product Bill
Record

DateBilledTo
 

The date up to which the
subscription product is
billed
 

This must be a valid date.
 

Required
 

Not required
 

RecurringFlag
 

Option indicating whether
this line is recurring.

Note:  Pass recurring
flag as 'Y' if you need to
create Credit Memo.

 

Y or N
 

Required
 

Not required
 

BillingPeriod
 

The billing period
 

This must be a positive
number and unique for the
product.
 

Required
 

Not required
 

DateToInterface
 

The date to interface
 

This must be a valid date.
 

Not Required
 

Not required
 

DateBilledFrom
 

The date from which the
subscription product is
billed
 

This must be a valid date.
 

Required
 

Not required
 

BillLineId
 

The bill line ID
 

Do not pass any value.
 

Not Required
 

Not required
 

InterfacedFlag
 

Option indicating whether
the bill line is interfaced
 

Y or N
 

Required
 

Not required
 

SubscriptionProductPuid
 

The subscription product
PUID
 

This must be a valid
subscription product PUID.
 

Required
 

Not required
 

SubscriptionId
 

The subscription ID.
 

Do not pass any value.
 

Not Required
 

Not required
 

SubscriptionProductId
 

The subscription product
ID.
 

Do not pass any value.
 

Not required
 

Not required
 

BillLinePuid
 

The bill line PUID.
 

This must be a unique bill
line PUID.
 

Required
 

Required
 

Amount
 

The amount
 

This must be a positive
number.
 

Required
 

Not required
 

UsageFlag
 

Option indicating whether
the line is a usage line.

Y or N
 

Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Bill Record

Updating an Existing
Subscription Product Bill
Record

 

UsageAcquiredFlag
 

Option indicating whether
the usage has been
acquired.
 

Y or N
 

Not required
 

Not required
 

UsagePricedFlag
 

Option indicating whether
usage line has been priced.
 

Y or N
 

Not required
 

Not required
 

TransactionClass
 

The transaction class.
 

This must be INV for
invoice and CM for credit
memo.
 

Required
 

Not required
 

TransactionTax
 

The transaction tax.
 

This must be a positive
number.
 

Not required
 

Not required
 

TransactionAmount
 

The transaction amount.
 

This must be a positive
number.
 

Not required
 

Not required
 

InvoiceBillLineId
 

The invoice bill line ID.
 

Do not pass any value.
 

Not required
 

Not required
 

UsageCaptureDate
 

The usage capture date.
 

This must be a valid date.
 

Not required
 

Not required
 

UsageQuantity
 

The usage quantity.
 

This must be a positive
number.
 

Not required
 

Not required
 

ChargePeriod
 

The charge period.
 

This must be a valid charge
period.
 

Not required
 

Not required
 

PricingError
 

The pricing error.
 

Do not pass any value.
 

Not required
 

Not required
 

ListPrice
 

The list price.
 

This must be a
positive number when
TransactionClass is INV and
a number when it's CM.
 

Required
 

Not required
 

RevenueLineId
 

The revenue line ID.
 

Do not pass any value.
 

Not required
 

Not required
 

TransactionClassMeaning
 

The meaning of transaction
class lookup.
 

Invoice or Credit Memo
 

Not required
 

Not required
 

InvoiceDate
 

The invoice date.
 

This must be a valid date.
 

Not required
 

Not required
 

NewCreditMemoPUID
 

The credit memo PUID.
 

Do not pass any value.
 

Not required
 

Not required
 

CreditMemoAmount The credit memo amount. Do not pass any value. Not required Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Bill Record

Updating an Existing
Subscription Product Bill
Record

     

CreditMemoFlag
 

The credit memo option.
 

Do not pass any value.
 

Not required
 

Not required
 

CreditMemoReason
 

The credit memo reason.
 

Do not pass any value.
 

Not required
 

Not required
 

CustomerTrxTypeSequenceId
 

The customer transaction
type sequence ID.
 

This must be a number.
 

Not required
 

Not required
 

CoveredLevelId
 

The covered level ID.
 

Do not pass any value.
 

Not required
 

Not required
 

ChargeId
 

The charge ID.
 

This must be a valid charge
ID.
 

Required
 

Not required
 

You can view the Subscription Product Bill object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Note:  Total cost value (TCV) isn't automatically calculated while importing bill lines. You need to manually calculate
it and add it to header and product level. You can automatically calculate the TCV and generate bill line by setting
Generate Billing to Y in header.

Note:  To import Subscription Bill Line Credit memo, you must include BillLinePuid, CreditMemoAmount,
CreditMemoFlag, and CreditMemoReason attributes in the CSV file. The BillLinePuid should be the PUID of the existing
Invoice Bill Line for which a Credit memo needs to be added.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Product Bill object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
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2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Product Bill

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Subscription Product Charge Data  
You can use import management to create or update Subscription Product Charge records.

To import Subscription Product Charge records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Product Charge data into Oracle Applications Cloud, you need to populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.
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Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Product Charge object, the attributes are SubscriptionProductPuid, ChargePuid, and SequenceNumber.

Required Attributes and Validations for Subscription Product Charge
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
Product Charge records, required attributes for updating Subscription Product Charge records, prerequisite setup tasks
for the attributes, and specific validations, if any, for Subscription Product Charge import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Charge Record

Updating an Existing
Subscription Product
Charge Record

PriceType
 

The price type
 

RECURRING or ONE_TIME
 

Required
 

Not required
 

ChargeId
 

The charge ID
 

Do not pass any value.
 

Not required
 

Not required
 

SubscriptionProductPuid
 

The subscription product
PUID
 

This must be a valid
subscription product PUID.
 

Required
 

Not required
 

SubscriptionId
 

The subscription ID
 

Do not pass any value.
 

Not required
 

Not required
 

SubscriptionProductId
 

The subscription product ID
 

Do not pass any value.
 

Not required
 

Not required
 

ChargePuid
 

The charge PUID
 

This must be a unique
charge PUID.
 

Required
 

Required
 

BillLineId
 

The bill line ID
 

Do not pass any value.
 

Not required
 

Not required
 

CoveredLevelId The covered level ID Do not pass any value. Not required Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Charge Record

Updating an Existing
Subscription Product
Charge Record

     

PricePeriodicity
 

The price periodicity
 

This must be a valid value
from oss_time_code_units.
 

Required
 

Not required
 

RollupFlag
 

The option indicating
whether charges should be
rolled up
 

Y or N
 

Not required
 

Not required
 

SequenceNumber
 

The sequence number
 

This must be a positive
number.
 

Not required
 

Not required
 

UnitListPrice
 

The unit list price
 

This must be a valid
number.
 

Required
 

Not required
 

Allowance
 

The allowance
 

Do not pass any value.
 

Not required
 

Not required
 

BlockSize
 

The block size
 

This must be a positive
number.
 

Not required
 

Not required
 

TieredFlag
 

Option indicating whether
the charge has tiers
 

Y or N
 

Required
 

Not required
 

TierType
 

The tier type
 

Do not pass any value.
 

Not required
 

Not required
 

Generate Billing Schedule
 

The option to generate the
billing schedule
 

Y or N
 

Not required
 

Not required
 

UsagePriceLockFlag
 

Option indicating whether
the usage price is locked
 

Do not pass any value.
 

Not required
 

Not required
 

PricePeriodicityName
 

The price periodicity name
 

Do not pass any value.
 

Not required
 

Not required
 

MeterDefinitionId
 

The meter definition ID
 

This must be a valid meter
definition ID.
 

Not required
 

Not required
 

MeterId
 

The meter ID
 

This must be a valid meter
ID.
 

Not required
 

Not required
 

InitialMeterReadingId
 

The initial meter reading ID
 

This must be a valid meter
reading ID.
 

Not required
 

Not required
 

AggregationMethod
 

The aggregation method
 

This must be a valid
aggregation method.
 

Not required
 

Not required
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Note:  To generate the billing schedule based on your pricing, set the GenerateBillingSchedule option to Yes and re-
import the Subscription.csv file after all files have been imported.

You can view the Subscription Product Charge object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Product Charge object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Product

Charge from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?
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Import Your Subscription Product Sales Credit Data  
You can use import management to create or update Subscription Product Sales Credit records.

To import Subscription Product Sales Credit records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Product Sales Credit data into Oracle Applications Cloud, you need to populate a CSV file
with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Product Sales Credit object, the attribute is SubscriptionProductPuid.
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Required Attributes and Validations for Subscription Product Sales Credit
Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
Product Sales Credit records, required attributes for updating Subscription Product Sales Credit records, prerequisite
setup tasks for the attributes, and specific validations, if any, for Subscription Product Sales Credit import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Product Sales Credit
Record

Updating an Existing
Subscription Product
Sales Credit Record

SalesCreditId
 

Internal ID of the sales
credit record
 

Do not pass any value.
 

Do not pass any value. This
will be auto-created.
 

Not required
 

SalesCreditPuid
 

PUID of the sales credit
record
 

Enter a unique PUID.
 

Required
 

Required
 

SubscriptionProductPuid
 

PUID of the subscription
product for which this sales
credit is being created or
updated.
 

This must be a valid
subscription number.
 

A value is required if you're
creating a sales credit for a
subscription.
 

Not required
 

SubscriptionProductId
 

ID of the subscription
product
 

Do not pass any value.
 

Not required
 

Not required
 

SubscriptionId
 

ID of the subscription
 

Do not pass any value.
 

Not required
 

Not required
 

SalesCreditTypeId
 

Sales credit type ID
 

This must be a valid value
as per the sales quota
lookup.
 

Required
 

Not required
 

StartDate
 

Start date of the sales credit
 

Do not pass any value.
 

Not required
 

Not required
 

EndDate
 

End date of the sales credit
 

Do not pass any value.
 

Not required
 

Not required
 

Percentage
 

Percentage of sales credit
 

This must be greater than
zero and less than or equal
to 100.
 

Required
 

Not required
 

You can view the Subscription Product Sales Credit object along with all its child objects and attributes in the Manage
Import Objects page of the Import Management flow. You can find attribute information like type, length, description,
and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.
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You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Product Sales Credit object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Product

Sales Credit from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Subscription Sales Credit Data  
You can use import management to create or update Subscription Sales Credit records.

To import Subscription Sales Credit records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
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How You Map Your Source Data to Target Object Attributes
To import your Subscription Sales Credit data into Oracle Applications Cloud, you need to populate a CSV file with your
source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating
new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually
visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the
Subscription Sales Credit object, the attributes are SalesCreditPUID and SubscriptionNumber.

Required Attributes and Validations for Subscription Sales Credit Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription
Sales Credit records, required attributes for updating Subscription Sales Credit records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Subscription Sales Credit import:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Sales Credit Record

Updating an Existing
Subscription Sales Credit
Record

SalesCreditPuid
 

PUID of the sales credit
record
 

Enter a unique PUID.
 

Required
 

Required
 

SubscriptionNumber
 

Subscription number
 

This must be a valid
subscription number.
 

A value is required if you're
creating a sales credit for
subscription.
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Subscription
Sales Credit Record

Updating an Existing
Subscription Sales Credit
Record

SubscriptionId
 

Subscription ID
 

This must be a valid
subscription ID.
 

A value isn't required if the
subscription number is
entered.
 

Not required
 

SubscriptionProductId
 

Subscription product ID
 

Do not use this column
 

Do not use this column
 

Not required
 

SalesrepId
 

Sales representative ID
 

This must be a valid sales
person ID.
 

Conditionally required
 
A value is required if the
SalesPerson isn't entered.
 

Not required
 

SalesPerson
 

Sales person name
 

This must be a valid sales
person name.
 

Conditionally required
 
A value is required if the
SalesrepId isn't entered.
 

Not required
 

SalesCreditTypeId
 

Sales credit type ID
 

This must be a valid value
as per the sales quota
lookup.
 

Required
 

Not required
 

Percentage
 

Percentage of sales credit
 

This must be greater than
zero and less than or equal
to 100.
 

Required
 

Not required
 

You can view the Subscription Sales Credit object along with all its child objects and attributes in the Manage Import
Objects page of the Import Management flow. You can find attribute information like type, length, description, and so
on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Subscription Sales Credit object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
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3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Sales Credit
from the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Import Your Template Data  
You can use the Import Management to create, update, or delete template records.

You can import template records using these steps:

1. Map your source template data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.

2. Create the source CSV file with the template data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your template data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import
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To better manage your template information, the template object has the following child object:

• Template Action

If you want to import only a few records, then you can create a single CSV file for all template attributes. However if you
want to import a large number of records, then you may decide to create multiple CSV files, one for each of the template
child objects. Note that you must have imported the CSV file for template object successfully before trying to import the
CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For
more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new templates or are
updating templates that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Template Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for template records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Template
record

Updating an Existing
Template record

Calendar
 

The unique Id of the
existing Calendar record
in the Oracle Fusion
destination table.
 

Provide a valid Calendar ID..
 

Required
 

Not required
 

Template
 

Name of the Template.
 

None
 

Required
 

Not required
 

Context
 

Indicates the context of the
Template. Currently, the

The Valid Value is
ServiceRequest.
 

Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Template
record

Updating an Existing
Template record

context of the template is
always 'Service Request'.
 

Template Id
 

The unique Id of the
Template record in the
Oracle Fusion destination
table.
 

None
 

Not required
 

A value is required if you're
updating an existing
Template and you're not
providing the Template
Number
 

TemplateNumber
 

Specifies the original
system reference (Template
Unique Id), if the record was
imported
 

None
 

Not required
 

A value is required if you're
updating an existing
Template and you're not
providing the Template ID
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the template object.
The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Template object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the template information. To create an import
activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Template from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Template Action Data  
You can use the Import Management to create, update, or delete template action records.

You can import template action records using these steps:

1. Map your source template action data to Oracle Applications Cloud object attributes. This way the import
process would know where to insert each of the information bits.

2. Create the source CSV file with the template action data you want to import.
3. Kick off an import activity.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your template action data into Oracle Applications Cloud, you must populate a .csv file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
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• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new template actions or
are updating template actions that have source system reference data, then provide the source system and
source system reference values.

Required Attributes and Validations for Template Action Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for template action records, prerequisite setup tasks and specific validations, if
any:

Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Template
Action record

Updating an Existing
Template Action record

Action Id
 

Specifies the foreign key
that references the Action
ID to which the action is
assigned
 

Identify the Action ID value
by exporting the Action
object for the actions
marked as "ORA_SVC_
CUSTOMER_VISIBLE".
Navigate to the following in
the Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Bulk
Data Export, Schedule
Export Processes

Required
 

Not required
 

Template Action Id
 

Specifies the unique Id
of the Template Action
record in the Oracle Fusion
destination table
 

None
 

Not required
 

A value is required if you're
updating an existing
Template Action and you're
not providing the Template
Number.
 

Template Id
 

Specifies the foreign
key that references the
Template ID to which the
action is assigned
 

Identify the Template ID
value by exporting the
Template object. Navigate
to the following in the

Required
 

Not required
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Attribute Description Prerequisite Setup Task/
Import Validations

Creating a Template
Action record

Updating an Existing
Template Action record

Setup and Maintenance
work area:
 

• Offering: Sales

• Functional Area: Data
Import and Export

• Task: Manage Bulk
Data Export, Schedule
Export Processes

TemplateNumber
 

Specify a value for
this attribute to add
a new record for
templateAction. To update
the templateAction ,
 specify a value for the
templateActionID attribute
 

None
 

Not required
 

A value is required if you're
updating an existing
Template and you're not
providing the Template
Action ID.
 

Go to Navigator  > Tools >  Import Management >  Import Objects, to see all the attributes of the template action
object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Template Action object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the template action information. To create an
import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Template Action from the

Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

• How do I import data?

Import Your Wrap Up Data  
You can use Import Management to create or update Wrap Up records.

To import Wrap Up records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Wrap Up data into Oracle Applications Cloud, you need to populate a CSV file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.
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Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Wrap Up or are
updating Wrap Up that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Wrap Up Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Wrap Up
records, required attributes for updating Wrap Up records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Wrap Up import:

Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Wrap
Up Record

Updating an
Existing Wrap Up
Record

Interaction ID The unique
identifier of the
interaction. A
wrap up is a child
resource of the
interaction.

Integer 18 If a value is
provided to create
or update a Wrap
Up record, then
the value must
exist in the column
INTERACTION_
ID of the SVC_
INTERACTIONS
table.

Required Required

Summary ID The unique
identifier of the
wrap up. This
value is generated
during creation.

Integer 18 None Required Required

Call Notes The call notes is
used to store large
content related to
the call.

String None Not Required Not Required

Communication
Reason Code

The code
indicating the
reason for the
occurrence of the
interaction. A list
of accepted values
is defined in the
lookup ORA_SVC_
MCA_COMM_
REASON_CD.

String 30 None Not Required Not Required
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Attribute Description Data Type Data Length Prerequisite
Setup Task/
Import
Validations

Creating a Wrap
Up Record

Updating an
Existing Wrap Up
Record

Interaction Notes The notes
associated with the
interaction.

String 4000 None Not Required Not Required

Interaction
Number

The alternate
identifier of the
interaction.

String 30 None Required Conditionally
Required. Either
InteractionId or
InteractionNumber
is required.

Resolution Code The code
indicating the
resolution code
of the interaction.
A list of accepted
values is defined
in the lookup
ORA_SVC_MCA_
RESOLUTION_CD.

String 30 None Not Required Not Required

Message ID The unique
identifier of the
service request
message.

Integer 18 None Not Required Not Required

Summary Number The summary
number of the
interaction.

String 30 None Not Required Not Required

Transfer Reason The reason the
interaction was
transferred to
another user.
This is optional
and typically
provided only
for a transferred
interaction.

String 400 None Not Required Not Required

Verified Indicates if the
associated contact
has been verified.

Boolean 1 None Not Required Not Required

Wrap Up End Time The date and time
when the wrap up
ends.

Timestamp None Not Required Not Required

Wrap Up Start
Time

The date and time
when the wrap up
begins.

Timestamp None Not Required Not Required

You can view the Wrap Up object along with all its child objects and attributes in the Manage Import Objects page of the
Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.
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You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Wrap Up object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When
Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Wrap Up from the Object

drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review

and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
• How do I import data?

• Potential Issues When Opening CSV Files in Excel

• How You Use Alternate Keys to Import Records

Import Territory Geographies Data  

Import Your Territory Geographies Data  
You can use Import Management to create or update Territory Geographies records.

To import Territory Geographies records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
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2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Territory Geographies data into Oracle Applications Cloud, you must populate a .csv file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

• Ensure prerequisite setups are done, if applicable.

• Understand your options for uniquely identifying the records.

• Ensure parent records exist before importing child records.

• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.

• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the
internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are
typically internal IDs. Use this option only if you're updating Geographies. You can determine the internal ID
of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query.
Using an internal ID typically provides better performance and reduces the import duration. For the Territory
Geographies object, the attributes are Batch Id and Interface Row Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's UI, you can use the Number attribute to identify the record. For the Territory Geographies object,
the attribute is Import Activity Identifier.

Required Attributes and Validations for the Territory Geographies Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. The following table lists the required attributes for importing new
Territory Geographies records, prerequisite setup tasks for the attributes, and specific validations, if any, for Territory
Geographies import:
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Attribute Description Prerequisite Setup Task/ Import
Validations

Creating a Territory Geographies
Record

GeographyOrZoneName
 

The primary name of the
geography or zone.
 

The geography name code is
validated against the country
structure to check if the structure is
defined for this country.
 

Required
 

GeographyOrZoneType
 

The type of the geography or zone.
 

No validation
 

Required
 

You can view the Territory Geographies object and attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator  > Tools >  Import Management >  Import Objects.
2. Select the Territory Geographies object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note:  For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Territory Geographies

from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator  > Tools >  Import Management >  Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

859



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 8
Import Your Data

Related Topics
• Potential Issues When Opening CSV Files in Excel

• How do I import data?

Example of Importing Territory Geography Data  
This example demonstrates how you can import data using Import Management. In this example, you have a source file
containing territory geography data that you want to import into the application.

A territory is an area of responsibility of a salesperson over a set of sales accounts. A territory can be based on various
dimensions, such as the geography, product, organization type, industry, business size, account, account type, and sales
channel dimension. The territory geography defines the boundaries of a territory according to the selected dimensions,
such as Europe, USA, or Asia. Dimensions are attributes that define jurisdictional boundaries of territories. You can use
geography dimensions to define territories by country or postal code, based on Territory Geographies. You must create
or import territory geographies before they can be used in territory definitions.

Summary of the Tasks
You perform the following steps to create an import activity and activate the import.

1. Determine what information is in the source file.
2. Create and schedule the import activity.

Before You Start
1. You use the country structure of a country to define which geography types are part of the country. For more

information about an example of importing a country structure, see the topic "Example of Importing Country
Structure Data".

2. Ensure that the combination of the Source ID and Parent Source ID values is unique for each row of data within
a single import. However, your source data files don't need to have the same Source ID and Parent Source ID
values as your previously imported geography data. If the geography structure levels and the parents for each
geography value are the same, then the changed IDs will not affect the import.
For example, when importing a country, which is the upper node, and its state, you may provide the following
values:

◦ Data for a country: SOURCE_ ID = 1; PARENT_ID = (NULL). The PARENT_ID is null because the country is
the upper level of the territory geography hierarchy and has no parent.

◦ Data for a province: SOURCE_ ID = 2; PARENT_ID = 1 (the source ID of the country)

Determine the Information in the Source File
You include the data that you want to import into Sales and Fusion Service in a source CSV file. A sample input CSV file
is shown below.

GeographyOrZoneNameLanguageCode SourceId ParentSourceId GeographyOrZoneTypeZoneCode CountryName GeoParentName1

GLOBAL
 

US
 

1
 

 GLOBAL
 

GBL
 

USA
 

United States
 

North America US 2 1 COUNTRY  Canada  
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GeographyOrZoneNameLanguageCode SourceId ParentSourceId GeographyOrZoneTypeZoneCode CountryName GeoParentName1

      

REGION 1
 

US
 

3
 

2
 

REGION
 

 USA
 

United States
 

Note:   Note the following:
• The hierarchy is modeled in the CSV file using the SourceId and ParentSourceId. The ParentSourceId for the

Country Record (level Number 1) is always null.

• If defining an alternate name (RecordTypeCode = 2) for the country, ensure that the ParentSourceId is the same
as the SourceId for the Country record (RecordTypeCode=0) and the SourceId is a unique number.

• If defining an alternate name (RecordTypeCode = 2) for any level below the country (LevelNumber >1), ensure
that the SourceId and ParentSourceId columns match the values for the original record respectively.

You must create a source file (CSV) file with the attributes and import it using import management as shown in this
table.

Attribute Name Value Description

GeographyOrZoneName
 

GLOBAL
 

The primary name of the geography or zone.
 

LanguageCode
 

US
 

The unique language code of the country to
which the territory geography belongs. The
default value is US.
 

SourceId
 

1
 

The source ID for the territory geography, along
with the parent source ID, is used to identify the
territory geography's parent/child relationship
within the source file data and subsequent
interface table data.
 

ParentSourceId
 

11
 

The parent source ID for the geography, along
with the source ID is used to identify the
geography's parent and child relationship with
records within the source file data. This should
be null for the country record, as Country is at
the top of the hierarchy.
 

GeographyOrZoneType
 

COUNTRY
 

The type of the geography or zone.
 

ZoneCode
 

GBL
 

A unique user-defined code of the zone to
which the territory geography belongs. It's used
only for zones.
 

CountryName
 

USA
 

The name of the country for that geography. It's
used only for master geographies.
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Attribute Name Value Description

 

GeoParentName1
 

United States
 

This is used to specify the complete path
of any master geography, starting with
the country name. For example, if your
TerritoryGeographyName is San Francisco,
 then the path of the master geography is
GeoParentName1 = "United States".
 

You can create an import activity, enter the import details, and schedule the import. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Territory Geographies

from the Object drop-down list.

Note:  In the Advanced Options section, the option Enable High-Volume Import is selected by default. This
mode is designed to import millions of records at once.

4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the

mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit.

Related Topics
• How do I export data?

Import Management Post Processing for Accounts and
Contacts  

Import Management Post Processing Jobs  
After importing your data successfully, you must run a couple of post processing jobs for duplicate identification,
duplicate resolution, and account assignment.

Import Management Post Processing Job for Deduplication
After you import your account and contact data, verify if the imported data contains any duplicates. Alternatively, you
must also check if your imported data has any duplicates in the database. Therefore, after you import, it's a good idea to
run duplicate identification batches, and if any duplicates are found resolve them either by creating resolution requests
to merge or link them.
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Identify Duplicates
You can identify duplicates from the duplicate identification work area. To run duplicate identification batches, navigate
to the Duplicate Identification work area as follows: Navigator > Customer Data Management > Duplicate Identification
Refer to the following topics linked from the related topic section for details on how to perform this task:

• Create Duplicate Identification Batches and Define Subset Rules

• Considerations for Creating Duplicate Identification Batches

• How You Manage Duplicate

Resolve Duplicates
You can resolve duplicates from the duplicate resolution work area. To resolve duplicates, navigate to the Duplicate
Resolution work area as follows - Navigator > Customer Data Management > Duplicate Resolution. Refer to the
following topics linked from the related topic section for details on how to perform this task:

• Process Duplicate Resolution Requests

• Considerations for Selecting the Duplicate Resolution Request Type

• Override System Mapping

Import Management Post Processing Job for Account Assignment
You can schedule and run the Request Account Assignments scheduled process using the Scheduled Processes page.
You must have the Run Sales Party Batch Assignment privilege to define and run account batch assignment. You can
access the Scheduled Processes page as follows: Navigator > Tools > Scheduled Processes. Refer to the following topic
linked from the related topic section for details on how to perform this task:

• Account Assignment Scheduled Processes

Delete Child Entities of Inactive Party Records
You can delete child entities of inactive parent records for Accounts, Contacts, Households, Hub Organizations, and Hub
Persons. All the child and grandchild entities of the inactive (deleted) or merged parent will be inactivated or end dated.
This will also delete address purpose child of the deleted address record where the parent party record is still active.

You must be a sales administrator or a CDM administrator to run this schedule process. You can delete child entities
of inactive party records as follows: Navigator Tools >Scheduled Processes and search for Delete Child Entities of
Inactive Party Records.

For more information see Delete Child Entities of Inactive Party Records in the Related Topics Section.

Related Topics
• Create Duplicate Identification Batches and Define Subset Rules

• Schedule Account Assignment

• Considerations for Creating Duplicate Identification Batches

• How You Manage Duplicates

• How do I override system mapping?

• Process Duplicate Resolution Requests

• How do I delete child entities of inactive party records?
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How You Enable Automatic Account Assignment  
You can enable automatic account assignment after importing data using import management, and setting the
respective Profile Options for Account Assignment.

You can configure the following profile options:

• Sales Account Automatic Assignment on Import Enabled (ZCA_BATCH_ASSIGN_ON_BULK_IMPORT) - Enable
automatic territory based assignment after sales accounts are imported. If disabled, manually run a batch
assignment or assign each sales account individually The default option is No.

• Sales Account Automatic Assignment on Create Enabled (ZCA_SA_AUTO_ASSIGN_ON_CREATE) - Enable
automatic territory based assignment processing after a sales account is created. This Profile is set to Yes for
Import Management for Sales Account Assignment.

• Sales Account Automatic Assignment on Update Enabled (ZCA_SA_AUTO_ASSIGN_ON_UPDATE) - Enable
automatic territory based assignment processing after a sales account is updated. This Profile is set to Yes for
Import Management for Sales Account Assignment.
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9  Import Data Using External Data Loader
Client

Overview of External Data Loader Client  
This topic provides an overview of the External Data Loader Client.

The External Data Loader Client is a command-line tool that breaks a large data file into smaller importable data
files. This improves the performance of large-volume imports. You can also queue the multiple file import activities
required to import a large data set, in a single action instead of manually or programmatically triggering multiple import
activities.

How do I download and install the external data loader
client?  
This topic shows how to download and install the External Data Loader Client.

Here are the steps involved in this process:

1. Download and Install the Client
2. Set up Credentials

Before You Start
Ensure that your computer has Java version 1.8 installed.

Ensure that your Operating System is one of these:

• Microsoft Windows 7

• Microsoft Windows 8

• Microsoft Windows 10

• Microsoft Windows 11

Ensure that your Operating System is one of these.

Note:  The External Data Loader client doesn't support Java versions higher than version 1.8.

Required Privileges

To download the client, you must have access to My Oracle Support (support.oracle.com). To use the tool to import data
into Sales and Fusion Service you must be able to access REST services and import data for the objects.

Prerequisite Steps
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The Data Loader client doesn't require any specific configuration within Sales and Fusion Service. However, you must
create an import map before using it. The client passes a mapping number value when submitting an import request.
You can't create a new import mapping from the Data Loader Client application.

Download and Install the Client
You can download the client from My Oracle Support (Doc ID 2325249.1).

The download contains a ZIP file, with sub-folders. Save the ZIP file to a directory in which the full file path contains no
white spaces. You must extract all of the files to a folder on your computer.

Note:  When executing the client from the command line the application uses the name oscdataloader.jar. For
example,

> java -jar oscdataloader.jar -h

Set up Credentials
You can install and use the client for automated imports while hiding the credentials that are used with the help of the
Credential Store. The Credential Wallet holds one set of user credentials (user name and password pair). To save your
credentials use the savepassword command,

> java -jar oscdataloader.jar savepassword -username John.Doe

Enter your password:

>

You are prompted to enter the password for the specified user name value. This password is masked so that it can't be
viewed in the command window. You can then use the tool to submit or retrieve the status or log files for an import by
only providing the user name value. This protects the password of the integration user by preventing other users from
viewing the password either on the command line (by scrolling back through recently executed commands, viewing the
password in the scheduling utility, or opening a configuration file containing the password value.

You can get the options for each command, by using the option -h for that command. For example, the following
command lists the options available for the submit command.

> java -jar oscdataloader.jar submit -h

Use the Configuration File
The default configuration file is oscdataloader.config located in the config folder. This is used for all imports, unless
otherwise mentioned. You can use another configuration file using the -config parameter.

> java -jar oscdataloader.jar listimports -config c:\test\configfile.txt

The configuration file should have all parameters, with each line of the file containing a key-value pair. For example:

import-name=Testing

input-file=c:\\testing\\testing.csv

mapping-number=888100111272708

target-url=https://mypod.oracle.com
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object=Account

username=john.doe

Note:  You can save your password by setting the parameter wallet=true in the oscdataloader.config file.

How do I import using the external data loader client?  
This topic describes how to import using the External Data Loader Client tool.

You can use the tool to split a source file into multiple smaller files for upload and then import. This lets you import large
files that exceed the import size limits. You can split a CSV file in one of two ways:

• Independently - the specified CSV file can be split based on selected parameters and no import is performed

• As part of import - the specified CSV file is split and then each of the resulting files is uploaded and then
imported

The following steps are involved in using the tool:

• Submit Import Jobs

• Review Status of Import Jobs

• Retrieve Log Files

Submit Import Jobs
The submit operation, takes the source single CSV file, splits the file into smaller files (if necessary), uploads those files
to the Webcenter Content Repository and then imports the files. When executing the client from the command line, you
must provide the URL of the pod to run the import, the user credentials for authentication, the import object name, the
import map number, and the import source file name.

> java -jar oscdataloader.jar submit -target-url https://mypod.oracle.com -username importuser -input-file
 Account.csv -import-name "Account Import" -object Account -mapping-number 123565

If multiple import activities are created due to splitting of files, then import activity name values are the same. The file
name values are suffixed with a count value. For example, if the source file Account.csv is split into two files, then file
name values are called Account_1.csv and Account_2.csv.

Note:  If the target isn't open through public internet, it wouldn't be accessible through public internet.

You can retrieve the list of imports that have recently run on a server using the listimports command. For example,

> java -jar oscdataloader.jar listimports -target-url https://mypod.oracle.com -username importuser

lists the imports as a table in the command window. An example of the output would contain the following information:
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Identifier Name Object Attachment
Object

Start Time End Time Status Submitted By Activate

0123456789012345
 

Account
Import
20170410
 

Account
 

N/A
 

20170410
14:56T05:00
 

20170410
16:56T05:00
 

Completed
 

John.Doe
 

Yes
 

7878787878787878
 

Opportunity
Sync
 

Opportunity
 

N/A
 

20170411
17:06T05:00
 

20170411
20:06T05:00
 

Completed
with errors
 

John.Doe
 

Yes
 

Note:  You should place the import source files in local folders while using EDLC. Remotely mounted files might cause
performance issues.

Review Status of Import Jobs
To get the status of an import activity, enter the identifier value of the import on the command line. For example:> java
-jar oscdataloader.jar getlogs -target-url https://mypod.oracle.com -username importuser -log-type Exception -

import-activity 012345678912345

This command displays the detailed status of the matching import request (if no matching request is found, then an
error is displayed). An example of the output contains the following information:

Object Attachment
Object

Status Start Time End Time Number of
File Splits

Records
Read

Successfully
Loaded

Errors
Reported

Warnings
Reported

Account
 

N/A
 

Completed
 

20170410
14:56T05:00
 

20170410
17:36T05:00
 

2
 

50,000
 

49,950
 

50
 

0
 

Retrieve Log Files
You can get the log files generated by an import activity using the getlogs command. For example,

> java -jar oscdataloader.jar getlogs -target-url https://mypod.oracle.com -username importuser -log-type
 Exception -import-activity 012345678912345

Log files retrieved by the getlogs command are stored in the importlogs folder by default. Log file of the External Data
Loader Client is stored in the oscdataloaderlogs folder.

Import Job Statuses  
The import job status indicates the status of the import job performed.

The import job can have one of these statuses:

• Completed - all batches have completed.

• Completed with Errors - one or more batches have completed with errors.

• In Progress - one or more batches are currently in progress.
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• Unsuccessful - one or more batches are unsuccessful.

• Completed with Warnings - one or more batches have completed with warnings.

Command-Line Parameters  
This topic describes the available command-line parameters for External Data Loader Client.

You can use the help option to see a list of all the commands that are available. For example, the following command
lists all the command-line options.

> java -jar oscdataloader.jar help

You can get the options for each command, by using the option -h for that command. For example, the following
command lists the options available for the submit command.

> java -jar oscdataloader.jar submit -h

If you're using a proxy server while importing using the EDLC, then you must specify the proxy parameters in the
command-line call. The following example shows how:

java -Dhttps.proxyHost=host_name -Dhttps.proxyPort=80 -jar
oscdataloader.jar listobjects -target-url https://<your_pod> -u importuser -w

Here are the command-line parameters.

Command and Options (Preceded by
Hyphen)

Description

config
 

The path where the configuration file is located.
 

-desc
 

The description of the import job submitted.
 

-delimiter
 

The delimiter used in your source file. The default value is COMMA_DELIMITER. Possible values are:
 

• COMMA_DELIMITER: Indicates the comma delimiter

• OTHER_CARET: Indicates the caret symbol delimiter

• OTHER_COLON: Indicates the colon delimiter

• OTHER_CLOSING_CURLY_BRACKET: Indicates the closing curly bracket delimiter

• OTHER_CLOSING_PARENTHESIS: Indicates the closing parenthesis delimiter

• OTHER_CLOSING_SQUARE_BRACKET: Indicates the closing square bracket delimiter

• OTHER_EXCLAMATORY: Indicates the exclamatory mark delimiter

• OTHER_MINUS: Indicates the minus delimiter

• OTHER_OPENING_CURLY_BRACKET: Indicates the opening curly bracket delimiter

• OTHER_OPENING_PARENTHESIS: Indicates the opening parenthesis delimiter

• OTHER_OPENING_SQUARE_BRACKET: Indicates the opening square bracket delimiter

• OTHER_PIPE: Indicates the pipe delimiter

• OTHER_PLUS: Indicates the plus delimiter

869



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 9
Import Data Using External Data Loader Client

Command and Options (Preceded by
Hyphen)

Description

• OTHER_QUESTION_MARK: Indicates the question mark delimiter

• OTHER_STAR: Indicates the star symbol delimiter

• OTHER_TILDE: Indicates the tilde symbol delimiter

• SEMI_COLON_DELIMITER: Indicates the semicolon delimiter

-df
 

The date format that's used in your source CSV file. The default value is ORA_ZCA_US_FORMAT.
Possible values are:
 

• ORA_ZCA_EUROPE_FORMAT: EU - YYYY/MM/DD

• ORA_ZCA_ISO8601_FORMAT: ISO 8601 - YYYY-MM-DD

• ORA_ZCA_UK_CANADA_FORMAT: UK/Canada - DD/MM/YYYY

• ORA_ZCA_US_FORMAT: US - MM/DD/YYYY

-ds
 

The decimal separator is used in your source file. The default value is Period (.). Possible values are:
 

• , (Comma)

• . (Period)

-ecl
 

Enable or disable custom business logic for the import job. The default value is false. Possible values
are:
 

• true

• false

-encoding
 

The source file encoding. Possible values are:
 

• ORA_ZCA_UTF8_ENCODING

• ORA_ZCA_UTF16_ENCODING

• ORA_ZCA_UTF16BE_ENCODING

• ORA_ZCA_UTF16LE_ENCODING

• UTF8

-export
 

Download the exported attachment files from the content management server to your local directory.
For example,
 

java -jar oscdataloader.jar export -object Attachments -export-id
 300100189790029 -target-url https://<your_pod> -output-path "C:
\MyAttachments"

Make sure that the directory you provide as output path already exists with read and write permissions
for the user performing the export.
 

getlogs
 

Get log files of an import activity.
 

-help
 

Display help text containing possible commands.
 

help
 

Show the usage message.
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Command and Options (Preceded by
Hyphen)

Description

-high-volume
 

Activate high-volume import for supported objects. By default, this option is set to true for all the
supported objects. To use low-volume import, set this option to false. For example,
 

> java -jar oscdataloader.jar submit -high-volume false -input-file
 Account.csv -import-name "Account Import" -object Account

-import-activity (required)
 

The import activity identifier of the job. This is used to track the status of the import job.
 

-import -name
 

The name of the import job.
 

-input -file (required)
 

The name of source CSV file. Provide a file name within 40 characters.
 

-latest
 

Indicates that the import jobs should be sorted by the latest creation date, when used with the
listimports command. If this parameter isn't used, then the import jobs are listed sorted by the
oldest creation date. For example,
 

> java -jar oscdataloader.jar listimports -target-url https://mypod.oracle.com
 -username importuser -latest 

lists the imports sorted by the latest creation date. This parameter can take the value true or false. A
value of true indicates that the imports are sorted by the latest creation date. By default, this parameter
has the value false.
 

--limit
 

The number of import jobs to be listed by the listimports command. It can have possible values
ranging from 1 to 500. Default value is 25. For example,
 

> java -jar oscdataloader.jar listimports -target-url https://mypod.oracle.com
 -username importuser -limit 100 

lists the first 100 import jobs.
 

listimports
 

Get the list of import activities. You can get the list sorted by latest creation date by using the
parameter latest.
 

listobjects
 

List the objects supported by External Data Loader Client.
 

-log-type (required)
 

Specify the type of log file to generate. Possible values are Exception, Error, Diagnostic, and All.
 

-mapping-number (required)
 

The mapping number.
 

-mode
 

The import mode which is to be used for the import job. The default mode is CREATE_RECORD.
Possible values are:
 

• CREATE_ONLY: Create records

• CREATE_RECORD: Update and create records

• DELETE_RECORD: Delete records

• UPDATE_RECORD: Update records

-nemail The email address to which the import job status would be sent.
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Command and Options (Preceded by
Hyphen)

Description

  

-object (required)
 

The object to import.
 

-offset
 

The import offset.
 

-s
 

The mode of scheduling the import job which determines whether the import job executes
immediately or at a future date. The default value is ONE_TIME_IMMEDIATE. Possible values are:
 

• ONE_TIME_IMMEDIATE: Immediate

• ONE_TIME_SCHEDULE: Future

savepassword
 

Save credential in credential store wallet.
 

split
 

Split the import data file into multiple smaller files. The Split Size parameter is used to configure the
split size that's used by EDLC. You can use either a low-volume split size or a high-volume split size.
 
 
You can use the split records option to use low-volume split. Low-volume split has a default
split size value of 50000 records. You can either set the default split size using the profile option
ORA_ZCA_IMPORT_LOW_VOLUME_CHUNK_SIZE, or specify the split size using the split records
command. Possible values are 10k,20k,30k,40k,and 50k.
 
Example command:
 

> java -jar oscdataloader.jar submit -input-file Account.csv -import-name
 "Account Import"-object Account -mapping-number 123565 -split-records 30000

You can use the high volume split option to use high-volume split. High-volume split has a default
split size value of 200000 records. You can either set the default split size using the profile option
ORA_ZCA_IMPORT_HIGH_VOLUME_CHUNK_SIZE, or specify the split size using the split records
command. Possible values are 100k,200k,300k,400k,and 500k.
 
Example command:
 

> java -jar oscdataloader.jar submit -input-file Account.csv -import-name
 "Account Import" -object Account -mapping-number 123565 -high-volume-split-
records 200000

Note:
You can use this parameter when the default values slow down the performance or if an optimum
size is recommended for the data pattern being imported. This parameter is provided to reduce the
number of records that need to split for each EDLC job.
 

-st
 

Scheduled future time stamp for an import activity job.
 

status
 

Retrieve the status of the specified import.
 

submit
 

Submit file import request in Sales and Fusion Service.
 

-target-url (required)
 

The environment against which the command is run.
 

872



Oracle Fusion Cloud Customer Experience
Understanding Import and Export Management for Sales
and Fusion Service

Chapter 9
Import Data Using External Data Loader Client

Command and Options (Preceded by
Hyphen)

Description

-tsf
 

The time stamp format used in your source file. The default value is ORA_ZCA_US_FORMAT. Possible
values are:
 

• ORA_ZCA_CANADA_FORMAT: Canada - DD/MM/YYYY hh:mm:ss PM

• ORA_ZCA_EUROPE_FORMAT: EU - YYYY/MM/DD 24:mm:ss

• ORA_ZCA_ISO8601_FORMAT: ISO 8601 - YYYY-MM-DDThh:mm:ss.sss+/-hh:mm

• ORA_ZCA_UK_FORMAT: UK -DD/MM/YYYY 24:mm:ss

• ORA_ZCA_US_FORMAT: US - MM/DD/YYYY hh:mm:ss PM

-username (required)
 

Specify the user name of the user running the command.
 

-wallet
 

The Credential Store that holds one set of user credentials (user name and password pair).
 

validate-settings-for-
performance

Validate settings to check high-volume import performance. You can use this parameter when you
have performance issues while import importing data in high volume for Account, Contact, Address,
Relationship, Organization, and Person objects. To validate the settings, you must pass this parameter
as “true”. When the parameter is set to “true”, then import job validates the value of the following
profile options to determine if the profile options have been set to the recommended values.

Profile Option Recommended Value

HZ_POST_IMPORT_GNR_
INVOKE

N

ZCH_ENABLE_
SURVIVORSHIP

N

ORA_HZ_ENABLE_
SIMPLIFIED_IMPORT_STATS

Y

ZCA_BATCH_ASSIGN_ON_
BULK_IMPORT

N

ZCA_IMPORT_PURGE_ON_
JOBCOMPLETION

Y

ZCA_IMPORT_SUPPRESS_
SUCCESSLOG_GENERATION

Y

ZCA_IMPORT_PURGE_
FROM_UI

Y

ZPM_ENABLE_PARTNER_
EVENTS

N

ZCA_PUBLIC_BUSINESS_
EVENTS

N

ZCX_CUSTOM_OBJECT_
EVENTS

No

HZ_ENABLE_ENTITY_
EVENTS

No
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Command and Options (Preceded by
Hyphen)

Description

Profile Option Recommended Value

HZ_INVOKE_OBJ_WF_ON_
TRACKING

No
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10  Overview of Export Management

About Export Management  
You can use Export Management to move data out of Oracle Applications Cloud in the form of CSV files.

To export data, you start by creating an export activity. As part of the export activity, you select a parent object and its
relevant child objects. You also must define filters on these objects to specify the records you want to export.

Scenarios for Export
You may want to export data in the following scenarios:

• You might want to move data out of Oracle Applications Cloud into another application. To perform this activity
you have to export the data into a ZIP file and import the exported data into the target application.

• You might want to format the data as per your requirements.

• You may want to identify the unique identifiers of an object such as Party ID or Party Number. You can use this
information to update an object record.

You can schedule an export either immediately or at a future date. If you schedule it for a future date, then provide the
start date and time while defining the export activity.

Note:  Currently recurring export isn't supported. You can however use the Export REST resource to schedule
recurring export activities through REST API. For more information see REST API for CX Sales and Fusion Service.

Using Export Filters
You can define the conditions for the records to export in the export filter. The exported data sets contain only those
records that match the specified filter criteria on the parent/child object. It is recommended that you use multiple filters
to reduce the number of records to export.

You can create a filter by navigating to Tools >  Export Management >  Export Objects and clicking on the Display
Name link for the export object. On the Manage Filters page, click the Create Filter button to create a filter. On the
Script Edit page, enter the filter name, filter parameters, and the order by clause if required. You can reuse an existing
filter by selecting a value from the Existing Filters drop-down list. Once you're done with your changes, click Validate
Script and then click Save and Close to save your new filter. You can also create a filter while creating an export activity,
on the Map Fields page.

You can delete a filter on the Manage Filters page, by clicking the delete icon for your filter under the Delete Filter
column. Note that you can delete only the filters created by you and those that aren't used in an active export job.

Split Export Data
There are no limits to file size for exporting data. However, you can split the exported data set based on a split size.
You can enable split from the UI by checking the Enable Split check box in the set up page and select the split size. The
default is 100k. You can specify the split size in multiples of 100k records, ranging from 100k to 1000k. Each CSV file can
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contain a maximum of 50k records. Hence, the exported data will be split into two CSV files after 50k records. The CSV
files will then be zipped together and exported.

For example, if an export job fetches 300k records and split is enabled with a split size of 200k, then 2 export ZIP files
will be generated. The first one will contain a total of 200k records which will be divided into 4 CSV files each with 50k
records. The second ZIP file will contain a total of 100k records which will be divided into 2 CSV files each with 50k
records.

Related Topics
• How do I export data?

• How You Monitor Export Activity

How do I manage export objects?  
Export objects correlate with tables in Oracle Applications Cloud. Understand export objects and their attributes to
manage the data that you want to export.

Supported Objects
You can export these objects and their child objects using Export Management:

• Access Groups

• Account

• Action

• Action Plan

• Activity

• Asset

• Assignment Rule Candidate

• Assignment Rule Condition

• Assignment Rule

• Assignment Rule Set

• Billing Contract Milestone

• Business Plan

• Campaign

• Case

• Compensation Plan

• Compensation Plan Component

• Compensation Plans Flex

• Competitor

• Condition Attachment

• Condition of Approval Comment

• Condition of Approval Transaction
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• Condition Comply Period

• Contact

• Contract

• Contests

• Deal Registration

• Duplicate Resolution Request

• Geographies*

• Goals

• Household

• HRHelpDeskRequest

• Hub Source System Reference

• Inbound Message

• Incentive Compensation Performance Measure

• Incentive Participant

• Incentive Participant Goal

• Incentive Participant Role Assignments

• Interaction

• Interaction Participant

• KPI

• Linked Party

• MDF Budget

• MDF Claim

• MDF Request

• Nonduplicate

• Note

• Objective

• Opportunity

• Organization

• Partner

• Partner Programs

• Performance Measure Flex

• Performance Measure Rate Dimensional Input

• Performance Measure Score Card

• Plan Component

• Plan Component Flex

• Plan Component Performance Measure

• Plan Component Rate Dimensional Input

• Plan Component Rate Table

• Price Book Header
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• Product

• Product Group

• Program Enrollments

• Promotion

• Queue

• Relationship

• Resolution Link

• Resolution Request

• Resource

• Resource Capacity

• Sales Forecast Quota

• Sales Lead

• Sales Orders

• Sales Territory

• Sales Territory Quota

• Self-Service Role

• Service Profile

• Service Profile Contact

• Service Request

• Standard Lookups

• Standard Text

• Standard Text Folder

• Standard Text User Variable

• Subscription

• Template

• Territory Geographies. For more information see Export Territory Geography Zone Hierarchies? (Doc ID
2853475.1) on My Oracle Support.

• Transaction

• Trees

• Wrap Up

Note:  Legal Note: By exporting the Geographies data from the Oracle environment to Your environment, You agree
that (a) Oracle is granting You only a restricted right to download the exported Geographies data specifically for Your
use with the Oracle Fusion services; (b) the Geographies data may not be used, transferred, or uploaded for any other
purposes; and (c) except for the restricted right granted in (a), all provisions of the Oracle Cloud Services Agreement
(CSA) or Schedule C, as applicable to You, remain in full force and effect, including specifically section 3.4 thereof.

Export Object Details
Click Tools > Export Management > Export Objects. To see the details of an export object, select it on the Export
Object Details page. Here are the details that you see about each exportable object:
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Column Description

Display Name
 

The object as it's called in the user interface.
 

Language Independent Code
 

The internal name of the object.
 

Parent Object
 

The parent object of the selected object. If there are multiple parents for an object, they're shown
separated by commas.
 

View Hierarchy
 

Clicking on the View Hierarchy icon shows the hierarchy between the parent and child objects in a
graphical format.
 

User Key
 

The attribute or the group of attributes that's used to uniquely identify a record.
 

Required Attributes
 

The attribute or the group of attributes for which values are required to create a record. These can't be
NULL when updating a record.
 

Target Attributes
Here are the details that you see for each target attribute.

Column Description

Display Name
 

Name of the target attribute in the user interface.
 

Attribute Name
 

Internal or field name of the attribute.
 

Required
 

Indicates whether the attribute is mandatory or not.
 

Default Value
 

The default value for the attribute, if any.
 

Type
 

Data type of the target attribute.
 

Length
 

Maximum allowed length for the target attribute values.
 

Description
 

A short description of the target attribute.
 

Export Inactive and Merged Data
You can export inactive and merged accounts, contacts, households, organizations, and persons using export
management. You don't need to rely on data model queries to fetch the deleted or merged records.
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Note:  To export inactive records, you need to explicitly add the condition to the criteria, or else only the active records
will be exported. For example, I for Inactive and M for merged. All associated child records (active or inactive) will be
exported irrespective of their status, if no criteria is added.

Export Queues  
This topic describes the different infotiles displayed on the Manage Exports page of the Export Queue tab.

Export Queue
The following infotiles are displayed on the Manage Exports page:

• All Exports: This infotile displays the count of active, completed, and unsuccessful exports submitted by all
users. Click to see the exports created by all the users and in all possible statuses.

• Active Exports: This infotile displays the count of exports submitted by all users that are either in progress or in
queued status. Click to see the active exports created by all the users.

• My Completed Exports: This infotile displays the count of exports submitted by the current user that are either
successful or failed with warnings or errors. Click to see the completed exports created by the current user.

• Unsuccessful Exports: This infotile displays the count of unsuccessful exports submitted by all users. Click to
see the unsuccessful exports created by all users.

Note:  The export activity records appear in the queue for thirty days, after which they're removed. The exported ZIP
files and diagnostic files are removed from the server on the 7th day of the export.

Export Details
You can view more details about the exports on clicking the infotiles. The following details about the export are
displayed:

Column Description

Name
 

The name of the export job. Click to go to the Export Status page.
 

Object
 

The object exported.
 

Status
 

The status of the export job. For more information about the statuses, see the topic How You Monitor
Export Activity in the related topics section.
 

Start Time
 

The start date and time of the export.
 

End Time
 

The end date and time of the export.
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Column Description

Submitted By
 

The user who submitted the export.
 

Exported data file
 

The link to download the exported data file in ZIP format.
 

You can filter the export using any of the columns in the preceding table. You must select the filter value from the
Search drop-down list and enter the criteria in the adjacent text box.

Related Topics
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11  Export Your Data

How do I export data?  
You can export your object data using the Export Management option from the Tools work area. This topic is your guide
to exporting data.

You can find the list of objects supported in Export Management in How do I manage export objects?

To export data:

1. Click Tools > Export Management.
2. On the Manage Exports page, click the Create Export Activity button.
3. On the Enter Export Options page, enter values for each of the following fields:

Field Description of the value

Name
 

The name of the export activity.
 

Object
 

The object to export. You must select the parent or child object from the drop-down list.
 
If you can't find an object in the drop-down list, then click the Search link. In the Search and
Select dialog box, enter the object name in the Object text box and click the Search button.
Select your object from the result list and click OK.
 
You can also use the advanced search option by clicking the Advanced button. Here you can
search based on various filter criteria such as object name, attachment supported, creation
date, and so on.
 

Note:
If the object you're exporting isn't listed then verify if you have the roles and privileges
required to export the object. For information on the roles, see the topic Roles Required for
Import and Export Management referenced in the Related Topics section.
 
The object must not include any field with display name length greater than 120 characters.
Your export job may fail if it includes a field with display name length greater than 120
characters.
 

Description
 

The optional description of the export activity.
 

File Name
 

The name of the export file to generate in ZIP format. This field is populated based on the
object and date time stamp.
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Field Description of the value

Export Attachments
 

Select to export the attachments related to the object. This option is enabled only if the
selected object supports attachments.
 

4. Optionally to set additional export configurations, click the Advanced Options section. Here you can configure
settings in the Output File, Export Options, or Create Schedule sections.

◦ Following are the options in the Output File and Export Options regions:

Option Description Default Value

Delimiter
 

If your file doesn't use a comma to
separate values, then select the correct
delimiter in the Delimiter drop-down list.
Possible values are:
 

- Caret Symbol

- Closing Curly Bracket

- Closing Parenthesis

- Closing Square Bracket

- Colon

- Comma

- Exclamatory Mark

- Minus

- Opening Curly Bracket

- Opening Parenthesis

- Opening Square Bracket

- Pipe Symbol

- Plus

- Question Mark

- Semi-Colon

- Star Symbol

- Tilde Symbol

Comma
 

Escape Special Characters
 

If selected, then RFC4180 format is used,
 and quotes are escaped with another set
of quotes.
 

Deselected
 
 

Decimal Separator
 

The decimal separator used in your
export file. Possible values are Comma
and Period.
 

Period
 

Date Format
 

The format of the date fields in your file.
Possible values are:
 

US - MM/DD/YYYY
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Option Description Default Value

- EU-YYYY/MM/DD

- ISO 8601 - YYYY-MM-DD

- UK/Canada - DD/MM/YYYY

- US - MM/DD/YYYY

Time Stamp Format
 

The format of time fields in your file.
Possible values are:
 

- Canada - DD/MM/YYYY hh:mm:ss
PM

- EU - YYYY/MM/DD 24:mm:ss

- ISO 8601 - YYYY-MM-
DDThh:mm:ss sss+/-hh:mm

- UK - DD/MM/YYYY 24:mm:ss

- US - MM/DD/YYYY hh:mm:ss PM

US - MM/DD/YYYY hh:mm:ss PM
 

File Encoding
 

The format in which the characters within
your source file are encoded. Possible
values are:
 

- Chinese Simplified - GB, CP936

- Chinese Traditional - CP950

- Eastern European - Win, CP1250

- Greek - MS Windows, CP1253

- Japanese - Shift-JIS, CP932

- Unicode - UTF - 8

- Unicode - UTF - 16

- Unicode - UTF - 16BE, Mac, Unix

- Unicode - UTF - 16LE, MS Windows

- Western European - Win, CP1252

Unicode - UTF - 8
 

End of Line
 

The character used to indicate end of line
in the export file. Possible values are:
 

- Carriage Return

- Carriage Return and Line Feed

- Line Feed

Line Feed
 

Quote Character
 

The character used to indicate a quote.
This field is read-only.
 

N/A
 

Language Independent Header
 

Select to export column headers. If you're
modifying the exported data manually,
 then exporting column headers help in
automatic mapping during the reimport
process.
 

N/A
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Option Description Default Value

Notification Email
 

The email to send export-processing
notifications. The user submitting the
export receives an email notification
automatically. You use this field to specify
any additional recipients. If you want
to have more than one email recipient,
separate the email addresses with a
comma or semicolon. You can also
specify a mailing list address so that
a large number of recipients can be
notified. If you don't want to receive the
notification, then set the profile option
ORA_ZCA_IMPEXP_ENABLE_EMAIL_NOTIFY
to 'N' at user level.
 

N/A
 

Enable Split
 

Select to split the export data set based
on a specified record count. On selecting
this check box, you can see the Split Size
drop-down list, with a default value of
100k. You can specify the split size in
multiples of 100k records, ranging from
100k to 1000k.
 
The exported data is split into multiple
CSV files, and each file has a maximum
of 50K records. You can further split the
exported data into multiple ZIP files,
 based on the specified split size. For
example, if your export job retrieves 300k
records and split is enabled with a split
size of 200k, then 2 export ZIP files are
generated. The first ZIP file contains 200k
records which is divided into 4 CSV files
each with 50k records. The second ZIP
file contains 100k records which is then
divided into 2 CSV files each with 50k
records.
 

N/A
 

◦ In the Create Schedule region, you can schedule the export to run either immediately or at a future date.
If you select a future date, then provide the date and time to start the export.

You can save the Advanced Options for subsequent reuse by clicking on the Save advance options link in the UI.
The options will be retained till you click on the Reset link and reset the options to application defaults.

Note:  All fields except Schedule Mode and Schedule start time will be saved.
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5. Click Next. On the Map Fields page you can see the exportable object, its child objects, and the associated
attributes. The Export Mapping drop-down list shows the maps that were used in earlier export jobs. You can
select an existing mapping from the drop-down list and click Apply.

You can save your export maps for future use by clicking on the pencil icon (Save As) in the Create Export
Activity page. You can also mark your maps as private by checking the Private Map check box. Private maps
can only be viewed and reused by the user who created and saved the map. Maps marked as private won't get
purged by the daily purge job.

Note:  Your maps will only be saved once the job is completed.

To select and apply your saved maps, check the My Maps check box, select the required map from the Export
Mapping drop down and click Apply in the Create Export Activity page.

6. You can select the child objects to export by selecting the Enabled check box. Selecting the Enabled check box
for a child object displays the associated attributes in the Available Fields section. You can select the attributes
to export by double-clicking the attribute in the Available Fields list. Alternatively, you can move the attribute
from Available Fields list to the Selected Fields list. If you select any formula fields for export, it might impact
your export performance.

7. You must provide a filter criterion for at least the top-level object. To filter the records to export using
conditions, click the Filter Name icon. On the Filter Name dialog box, you can create the filter for the export
attributes using the operators AND, OR, >, <, =, and !=. On the Fields tab select the attribute and click the Insert
button. In the Script Edit window, provide the filter conditions for the selected attribute. After creating the filter
criteria script, click Validate Script. Click Save and Close to save the filter.

Note:  You must use GeographyCode='TM' filter to export the Zone Hierarchies. To export both Zone
Hierarchy information and Geography Country Information, you need to use filter GeographyCode='TM' Or
CountryCode='DE'. For more information see How to Use Export Management to Export Territory Geography
Zone Hierarchies?

8. Click Next. On the Review and Submit page, review the export activity configuration. If you want to change
any configuration, then click the Back button. Submit to activate the export activity. After the export activity
completes, clicking the My Completed Exports infotile shows your export status. Click the ZIP file link in the
Exported Data File column to download the exported file.

You can cancel the export by clicking the Cancel icon in the Manage Exports page when the job status is
Paused, Queued for Export, Preparing data to Export, or Exporting Data.

Note:   The cancel job option is available for the logged in user and the hierarchy user only when the profile
option ORA_ZCA_IMPEXP_RESTRICT_USERACCESS is enabled.

Note:   CSV String Escape: By default, the escape character is a " (double quote) for CSV-formatted files. If a value
contains a comma, a newline character, or a double quote then the string must be enclosed in double quotes. For
example: "Newline char in this field \n". A double quote must be escaped with another double quote. For example:
"The double quote character "" is offensive.".
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Note:  By default, you can't view the Personally Identifiable Information(PII) such as mobile numbers in the exported
data. To view this information, follow these steps:

1. Navigate to Tools >  Security Console.
2. Search for the role ORA_MOT_QUOTA_EXPORT_MANAGEMENT_DUTY.
3. Edit role and click the Data Security Policies link.
4. Click the Create Data Security Policy button, and add a new data security policy on the database resource

Trading Community Contact Point with the following details.

◦ Policy Name: Custom Grant on Person Contact and Mobile Phone Data (you can provide any name)

◦ Database Resource: HZ_CONTACT_POINTS

◦ Data Set: All Values

◦ Actions: View Trading Community Person Contact, View Trading Community Mobile Phone Number

5. Click OK to save and navigate to Summary step to review and save changes.

Related Topics
• How You Monitor Export Activity

• Export Queues

• What are the roles required to import or export data?

How You Monitor Export Activity  
This topic explains how to monitor export activities and view their statuses.

View the Export Status
On the Manage Exports page, click the export activity name link to see additional information about the export activity.
The Export Status page contains the following sections:

• Status Bar

• Details

• Export Attachments

The Export Status Bar
The status bar shows the progress of the export activity in a graphical format. It shows the following stages during the
export process:

1. Queued for Export: The export request is queued for processing, and is waiting to begin execution.
2. Preparing data for Export: The data are loaded in the temporary staging table for further processing.
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3. Exporting data: The data from the target objects are loaded into the export files (CSV).
4. Completing export activity: The export data have been loaded in the source files, and cleanup tasks, such as the

generation of log files, are in progress.
5. Completed with errors: The export activity has completed with errors.
6. Completed with warnings: The export activity has completed with warnings.
7. Unsuccessful: The export activity was unsuccessful.

Activity and Record Details
The Activity Details section shows the name of the export activity, export job identifier, object exported, and the name
of user who submitted the export. The section on date and time displays the start and end times, and the time taken to
complete the export activity.

The Record Details section displays the number of records estimated, number of records exported, and the number of
records with errors.

The object must not include any field with display name length greater than 120 characters. Your export job may fail if it
includes a field with display name length greater than 120 characters.

Export Attachments
You can generate the diagnostics and log files from the Action menu. The Export Attachments section displays the
list of files associated with this export activity in tabular format. The Actions column in this section lets you either
download the file or view more details. These files include the diagnostics and log files generated.

Note:   The export data is stored on the UCM server for some time before it's purged. The duration after which export
data should be purged is set in the profile option ZCA_EXPORT_UCM_PURGE_DURATION. The default value is 30.

How You Monitor Export Activities Using REST APIs  
This topic explains how to receive completion notification through REST resource and also avoid the need to constantly
keep checking the export status.

To receive export completion notification through REST service, you must define the REST service endpoint in
Application Composer. You can configure and register your REST endpoint to receive notifications whenever your
export job completes.

Register an External REST Endpoint in Application Composer
To register an endpoint for notification:

1. Create and enter into a sandbox by navigating to Configuration >  Sandboxes >  Create Sandbox.
2. Navigate to Configuration >  Application Composer >  Web Services. Note that this option is available only

when you're inside the sand box.
3. You can edit the existing endpoints, or create a new endpoint such as ExternalEndPoint1, by clicking the Create

icon.
4. Enter the name of the endpoint and the URL, and select the authentication scheme. For example, your URL can

be in the format https://servername/ic/api/integration/v1/connections/cbveTest.
5. Select and configure the POST method by clicking the check box for POST. Currently only POST method is

supported for the Export Notification feature.
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6. Select and provide the code samples for the request and response payloads. Following is the sample for
request and response payloads:

{
"items": [],
"count": 0,
"hasMore": false,
"limit": 25,
"offset": 0,
"links": [{
"rel": "self",
"href": "https://servername/ic/api/integration/v1/connections/cbveTest",
"name": "ExternalEndPoint1",
"kind": "collection"
}]
}

7. Click Save and Close.
8. After making the changes, publish the sandbox to commit your changes.

Validate the Endpoint
You can validate the REST endpoint to ensure that your REST web service configuration in Web Services in Application
Composer is correct and the export process can call the endpoint successfully. To validate your REST endpoint and set
an endpoint as default:

1. Navigate to Tools >  Export Management >  Export Configuration >  REST Notification.
2. Here, select REST Notification as the notification type, and select the endpoint you registered from the

Notification Endpoint drop-down list. In our example, select ExternalEndPoint1.
3. To make this connection as the default one while creating export jobs, select the Set as default check box.
4. To validate, click the Payload Details section, and click the Validate REST Endpoint button. If your endpoint is

valid, then you see one of the following response statuses in the Response text box:

◦ 200

◦ 201

◦ 202

◦ 204

Any other response status indicates that the endpoint is invalid.

Create the Export Activity and Monitor the Status

1. Navigate to Tools >  Export Management >  Create Export Activity.
2. Create the export activity, enter the name, and select the object to export.
3. Click the Advanced Options section and select the notification endpoint ExternalEndPoint1 from the

Notification Endpoint drop-down list. If you don't want to receive the notification, then select a blank value in
the drop-down list.

4. Click Next and select the attributes to export on the Map Fields page. Create a filter for at least the top-level
object, and click Next. For more information on creating an export activity, see the topic Export Data.

5. Review your export configurations and submit the export job. Once you submit the export, you can monitor the
status by accessing the configured endpoint.

6. Alternatively, you can verify whether the notification is submitted by downloading the log files. The last entry in
the file indicates the status of notification.
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Export Notification in REST
You can use the RestNotification attribute to specify your notification endpoint while creating your export activity using
REST. For example, you can use the following sample payload to create your export activity:

{
 "Name": "Account_Export",
 "ExportObject": "Account",
 "ExportFilterCriteria": "OrganizationName IS NOT NULL",
 "ExportFileName": "Account.zip",
 "Activate": "YES",
 "RestNotification": "ExternalEndPoint1"
}}

The following table describes the behavior when you don't provide the REST notification endpoint.

REST Notification Value Endpoint Used for Export Job REST Notification Behavior

null
 

Default endpoint is selected
 

REST notification is sent to the default REST
endpoint.
 

REST notification not passed
 

Default endpoint is selected
 

REST notification is sent to the default REST
endpoint.
 

""
 

No REST endpoint is selected
 

No REST notification is sent.
 

Related Topics
• How do I export data?

How do I export attachments?  
This topic explains how to export and download the object attachments to your local directory. Here is a list of objects
that support exporting of attachments:

• Account

• Activity

• Assets

• Competitor

• Contact

• ConversationMessage

• DealRegistration

• Household

• HRHelpDeskRequest

• InternalServiceRequest

• Opportunity
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• Partner

• PartnerContact

• Product

• ProductGroup

• ServiceRequest

• WrapUp

You can export the attachments in two steps:

1. Export the object records and the attachment information based on the selected search criteria of the object.
2. Download the attachment files from the content management server using the External Data Loader Client tool.

Export the Object Records and the Attachment Information
To export the object records and the attachment information:

1. Click Tools > Export Management.
2. On the Manage Exports page, click the Create Export Activity button.
3. On the Enter Export Options page, enter the export activity information such as export name, export object,

and the file name. For more information on exporting data, see the topic Export Data.
4. Select the Export attachment check box to enable exporting the object attachments. You can optionally enter

the advanced configuration options. Click Next.
5. On the Map Fields page, you can select the attributes to export by dragging them from the Available Fields

section to the Selected Fields section. The Export Mapping drop-down list shows the maps used in earlier
export jobs. You can select an existing mapping from the drop-down list and click Apply. You can select the
Enabled check box to export the child object attributes.

6. You must provide a filter criterion for at least the top-level object. To filter the records to export using
conditions, click the Filter Name icon and enter the filter criteria for your object records. Click Next. On the
Review and Submit page, review the export activity configuration and click Submit.

7. After the export activity completes, clicking the My Completed Exports infotile shows your export status. Click
the ZIP file link in the Exported Data File column to download the exported file.

Download the Attachment Files
The ZIP file you downloaded in the previous step contains the following files:

• The attachment information CSV file - this file contains information about the attachment records such as
content ID, REST resource URL, attachment file name, and so on.

• Attachment download instructions file - this HTML file contains the export details, and the sample EDLC
command to download the attachments.

You can use the export command of EDLC to download the attachment files from the content management server to
your directory. For example, use the following command to download your attachments exported from the previous
step:

java -jar oscdataloader.jar export -object Attachments -export-id {export-id} -username {username} -target-
url {environment-url} -output-path {output-directory-path}

Following are the parameters used in the command:

Parameter Description

-objects Indicates the object type exported. Currently this parameter supports only the value Attachments.
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Parameter Description

  

-export -id
 

Job ID of the export job.
 

-username
 

User name of the user submitting the export command. This must be the same user who submitted
the export activity.
 

-target-url
 

URL of the environment.
 

-output-path
 

Directory path of the folder where the attachment files and reports are downloaded. The reports folder
contains details about the attachment files exported, such as their status and error details if any This
should be an existing directory with read and write permissions for the user performing the export.
 

You can view the details of all available parameters and their descriptions using the command export -help.

Related Topics
• How do I export data?

• Overview of External Data Loader Client

• Command-Line Parameters
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12  Round-Trip Export-Import

Round-Trip Feature  
This topic gets you started on the round-trip feature of Import and Export Management.

It explains how to

• Export the data from one instance of CX Sales and Fusion Service

• Makes any changes in the exported CSV files as required

• Reimport the updated CSV files either into the same instance or another instance

You can do this task without manually mapping the source file and the object attributes.

Export Data
You can use Export Management to export the data fields of an object. You can select the fields that you want to export.
If you're importing the data into another instance of CX Sales and Fusion Service, then select the Enable Round Trip
check box in the Advanced Options section of the Create Export page. This generates the header row in the exported
CSV file that enables the round-trip feature. Don't modify the header row values in the CSV file.

You can export a single object and its child objects with attributes for each export activity. If the exported ZIP file
contains the parent and child record files, then import the parent CSV file followed by the child CSV file.

You can either schedule the export process at a future date or run it immediately. The export activity generates a ZIP file
that you can download.

Import Data
You can import the exported data into either the same instance or another instance of CX Sales and Fusion Service. You
must use the CSV file extracted from the downloaded ZIP file. Don't edit the header row in the CSV file.

You import the data using the Import Management feature in the User Interface. During the import, the automatic
mapping feature automatically maps the columns in your source file to the application attributes.

Note:   While doing round trip import, you need to remove the attributes FileNameSystaskId and FileRecordNum from
the CSV.

Related Topics
• How do I export data?

• How do I import data?
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Export and Import Account Data between CX Sales and
Fusion Service Instances Using the Round-Trip Feature  
This example shows how to export the Account object from one instance of CX Sales and Fusion Service and import the
exported data into another instance of CX Sales and Fusion Service using the round-trip feature.

You can do this without manually mapping the source file and the application attributes.

Export Data from CX Sales and Fusion Service Using Export Management
You can export Account object records from CX Sales and Fusion Service using Export Management as follows:

1. Create an export activity for the Account object as explained in the topic Export Data.
2. Click the Advanced Options section. Select the Enable Round Trip check box. This enables the round-

trip support for your export activity. This option generates the header row in the exported CSV file and is
responsible for automatic mapping during the import. So don't modify any of the header row values. Review
and submit the export activity.

3. On the Manage Exports page, you can see the status of your export. Once the export activity completes, click
the My Completed Exports infotile to see the status of your export.

4. Click the link under the Exported Data File column to download your exported ZIP file. Save the ZIP file, and
extract the CSV file.

Import Data from CX Sales and Fusion Service Using Import Management
You can import data into CX Sales and Fusion Service instance using the following steps:

1. Create an import activity for the Account object as explained in the topic Import Data. Browse and select the
CSV file that you had exported in the last section.

2. Click Next to get the Map Fields page. On the Map Fields page, the round-trip feature automatically maps the
source file attributes for you.

3. Click Next to review the import configurations and Submit.
4. On the Manage Imports page, you can see the status of your import. Once the import activity completes click

the My Completed Imports infotile to see the status of your import.

Related Topics
• Round-Trip Feature

• How do I export data?

• How do I import data?
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13  Best Practices and Troubleshooting

What are the best practices for high volume data import?
 
Here are some best practices for high volume data import.

At some time, you might need to load large volumes of data into your CX Sales and B2B Service instance. For example,
during initial roll-out, expanding use of CX Sales and B2B Service to other users or divisions, or expanding use of CX
Sales and Fusion Service to include other object types (for example, adding support for Service objects).

When loading large volumes of data to CX Sales and Fusion Service, one of the key considerations is the time taken
to import data. Reducing the amount of time required to import a large volume of data is crucial, if you have a limited
period of time to run the data imports (for example, during a weekend migration). Oracle recommends certain best
practices that you can use to improve the performance of the data import.

Actual throughput varies for users based on a number of factors including the volume of data contained in each record,
the number of relationships being created during data import, and the number of records in your source file.

Before executing the data import in a production environment, Oracle recommends that you perform these functional
validation and performance optimization procedures in your test environment:

• Data Cleansing

• Validate Functional Import

• Optimization Process

Performing these exercises in your test environment ensures that these exercises don't impact existing operations or
the data in your production environment.

Data Cleansing
Before proceeding with high volume imports, you need to clean the data being imported thoroughly. Ensuring that your
data is in the correct format reduces the number of errors that are encountered during data import. This benefits your
overall throughput in two ways:

• Processing time isn't wasted on attempting to import records that can't be imported.

• You don't have to review error logs, fix issues, and reimport data. It costs less to clean your data before
attempting a data import than it does to fix issues that arise during data import.

When cleaning the data, note the following:

• Field Length - ensure that the data doesn't exceed the maximum field length in OSC

• Data Type - ensure that the data is of the correct type for the field to which it's being imported in OSC

• Required - ensure that a value is provided for all mandatory fields

• Conditionally Required - in some cases, a value is required based on the value provided for another field (for
example, for Opportunity a Close Date is required if the Status of the Opportunity is set to Closed)
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• Foreign Keys - provide a valid value for foreign keys to create relationships between records. The foreign keys
can vary for every object.

By ensuring that your data is clean, you can avoid many issues associated with importing your data from your legacy
application into CX Sales and Fusion Service.

Validate Functional Import
To verify that you have successfully cleaned your data, Oracle recommends that you validate your import in your test
environment with a small set of data. Follow these guidelines to validate the functional import:

• Before you import large volumes of data, ensure that your import completes successfully and that the resulting
data matches your expectations. This includes ensuring that the data is imported to the correct object, fields
have been mapped correctly, and relationships are imported properly.

• Import a small number of records including values for each attribute. Oracle recommends that you use the
smallest set of input data possible that can still save the variations present in your full data set.

• Identify any data issues that are reported in the import log files. Fix any specific issues reported for rows with
errors. If a row doesn't have an error reported, then don't reimport that row. After you resolve all the issues
and successfully import your subset of data, apply any changes to your larger data set (for example, if you
determine that your time stamp format is incorrect, fix this for all records in the input data file for your full data
set).

Optimization Process
Importing high volume of data is a project and should be included in the project plan for your implementation. You need
to allocate time for the actual import of data and for the design and optimization of the import process for your data
set.

When optimizing the data import, you identify the number of records to be included in your input data file as well as
the number of concurrent import activities that can be activated. You trigger concurrent import activities by running
more than multiple data import operations simultaneously. The number of concurrent import activities is the number of
data imports that are running and haven't yet completed. Running import activities serially or running too many import
activities concurrently can lower your throughput. Finding the right values for these two parameters is a key aspect
of designing your import process. There's no right answer for every situation. Every data set is different; you need to
repeat this process for any new data import operations that you plan to perform.

Note:  Don't import more than 100,000 records in a single import operation or perform more than five concurrent
import activities.

Oracle recommends that you adhere to this process when planning high volume data import:

• Establish baseline performance

• Scale up import volume

• Optimizing Concurrent Import Activities

Each of these steps is explained in greater detail.
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Establish Baseline Performance
Oracle recommends that after you have cleaned your data and validated that your import is functionally correct, you
should begin the process of scaling up your import volumes. The first step in this process is to establish a performance
baseline. This involves performing a set of serial imports using a high volume of records.

Oracle recommends that you begin by importing a small number of records (a few hundred to a few thousand) in a
single import activity. For example, you may import 10,000 records using four import activities of 2,500 records each.
After these data import activities have completed, you should note the time required to complete the import of records
and calculate the overall throughput (number of records imported per second).

Note:  You may also want to track the time between data import operations.

Scale Up Import Volume
After you have established a baseline, you can increase the number of records in your input file and begin to run
multiple imports concurrently. Scale the volumes in a controlled manner and note your throughput at every step.

Optimize Concurrent Import Activities
You can run multiple import activities simultaneously. This can improve your overall throughput versus serially running
the same imports. The optimal number of concurrent import activities can vary across objects and use cases; you must
perform testing prior to beginning your production data load to identify the most efficient data import plan.

You can run multiple data import activities concurrently by submitting a new import activity while the first activity is
still being processed. CX Sales and Fusion Service processes both import activities without waiting for the first activity
to complete before starting the second activity. You can continue to run multiple data import activities concurrently for
additional data import activities.

For example, you first run a test to measure the throughput when importing 200,000 records using four serial activities
of 50,000 records each. You may then run a test to import a total of 600,000 records as shown in this table:

Test Number Total Number of
Records

Number of Records
per Activity

Number of Activities Concurrency Average Throughput

1
 

200,000
 

50,000
 

4
 

Serial
 

2.1
 

100,000
 

50,000
 

2
 

Concurrent
 

2.2
 

200,000
 

50,000
 

4
 

Concurrent
 

2.3
 

300,000
 

50,000
 

6
 

Concurrent
 

At every step, you should note the average throughput. If you reach a point where throughput is decreasing, then you
may have exceeded your optimal concurrency. You may want to repeat the tests to ensure that you have sufficient data
points to draw a correct conclusion.

You can import file attachments to some record types. Importing attachments impacts import performance and should
be considered when planning your data import activities.
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You can also adjust the data import based on the number of records in your input data file. For example, start with
25,000 records and increase by 25,000 records with every run. As you increase the number of records in each batch,
note the average throughput. If you reach a point where throughput is decreasing, then you may have exceeded your
optimal number of records. Oracle doesn't recommend importing more than 100,000 records in a single import activity
and exceeding five concurrent import activities.

Pod Size
Significant changes to your usage patterns such as adding many new users or the execution of high volume data
imports may change your pod sizing assessment. Ensure that your environment is properly sized to handle the import
data volumes generated by your organization along with other operations that are performed by your users. Before
starting a high volume import process or one time data load, you may want to have Oracle review your sizing. Contact
Oracle help desk to start this review process.

Potential Issues When Opening CSV Files in Excel  
Whenever you open the import source file or the exported source file in Excel, you might face issues with some of the
field values. This topic explains the various issues that might occur and how to fix them.

Potential Issues
Potential issues that might occur include:

• Saving ID fields:
Issue: If you save your CSV file and then reopen it in Excel, IDs and other large numbers are typically displayed
in scientific notation: the product of a decimal number and a power of 10. For example, the value 123456789012
is displayed as 1.23457E+11.
Cause: By default, Excel displays numbers that are greater than 11 characters in scientific notation.
Workaround:

a. Highlight the column containing the value.
b. Right-click and select Format Cells.
c. In the Format Cells dialog box, select the Category Number and set the decimal places to 0. Click OK.

• Saving date-related fields:
Issue: If you save your CSV file and then reopen it in Excel, date-related fields such as PeriodName are typically
displayed in yy-mmm format. For example, the value 12-16 is displayed as 16-Dec.
Cause: By default, Excel displays date-related numbers in yy-mmm format.
Workaround:

a. Highlight the column containing the value.
b. Right-click and select Format Cells.
c. In the Format Cells dialog box, select the Category Custom and enter the type mm-yy or any other date

format of your choice. Click OK.
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• Saving numeric values that have more than 15 digits:

Issue: If your CSV file has a value with more than 15 digits, such as 1234567890123456, then Excel displays it as
1234567890123450 when the file is opened. Excel replaces the digits beyond 15 with zeroes.

Cause: Excel supports only 15 digits of precision.

Workaround:

Method 1

a. Highlight the column containing the value.
b. Right-click and select Format Cells.
c. In the Format Cells dialog box, select the Category Text and click OK.
d. Enter the value again in the cell.

Method 2

a. Highlight the cell containing the value.
b. On the Formula Bar, precede the value with an apostrophe. For example, type the value

'1234567890123456 and press enter.

Best Practices for Round-Trip Export and Import  
You export data and then import it into CX Sales and Fusion Service environment forming round-trip operation. You can
perform round-trip operations within an CX Sales and Fusion Service environment or between two different CX Sales
and Fusion Service environments.

Before performing a round-trip operation, you must consider the identifiers and configurations. Although you can
import most data directly into a target environment, you must ensure that the configurations from your source
environment have been replicated in the target environment. Additionally, system-generated identifiers can't be
imported and must be excluded from either the export or the import during round trip.

Use of Identifier Values
When importing records during a round-trip operation, you must ensure that the record to which you're associating (for
example, if you're importing a Contact and want to assign an Owner value) already exists in the target application. You
can't provide an identifier for a record that hasn't already been imported. If you attempt to associate with a record which
can't be uniquely identified by the user-key provided, an error is displayed.

CX Sales and Fusion Service uses these two types of identifiers:

• Record IDs, which contain system-generated values.

• Alternate keys, whose values are set by the user.

Record IDs

Record ID values are generated by the application when you create a record. During round trip, the target application
assigns record ID values to all the imported records; you can't set these using a value contained in the input data file.
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When performing a round-trip operation, you have two options:

• You can exclude the record ID value during export.

• You can ignore the ID value during import mapping.

Record ID values are generally named using the convention "Record Type ID". For example, Account ID, Opportunity ID,
or Contact ID.

Alternate Keys

When importing data during a round-trip operation, you must use alternate key values to identify associations between
records. The alternate key values that are available for a record in the source system can be included in the data file as
they're set by the user and can be assigned the same value as the source system. The set of alternate key values that are
available vary by object, but generally include one or more of the following:

• Original System and Original System Reference

• Record Number (for example Account Number, Opportunity Number)

• Record Name (Custom Objects if field is marked as unique)

• Email

Round-Trip Export and Import of Extensible Object and Attributes
If the object you have exported is a custom object or a standard object with custom attributes, then you must ensure
that the object definition is identical between environments. This means that the custom object and attributes must
exist in the target application and must use the same object and attribute names. During data import, if a difference
in the object or attribute definition prevents the import of a record, then an error is generated and reported in the
import logs. For example, if the length or data type of a field differs between the source and target applications, the
data import operation may not complete.
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