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Get Help

There are a number of ways to learn more about your product and interact with Oracle and other users.

Get Help in the Applications

Some application pages have help icons ® to give you access to contextual help. If you don't see any help icons on
your page, click your user image or name in the global header and select Show Help Icons. If the page has contextual
help, help icons will appear.

Get Training

Increase your knowledge of Oracle Cloud by taking courses at Oracle University.

Join Our Community

Use Cloud Customer Connect to get information from industry experts at Oracle and in the partner community. You
can join forums to connect with other customers, post questions, suggest ideas for product enhancements, and watch
events.

Share Your Feedback

We welcome your feedback about Oracle Applications user assistance. If you need clarification, find an error, or just
want to tell us what you found helpful, we'd like to hear from you.

You can email your feedback to oracle_fusion_applications_help_ww_grp@oracle.com.

Thanks for helping us improve our user assistance!
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1 About This Guide

Audience and Scope

This guide is intended for the end users of the customer data management functionality such as customer data
stewards and data steward managers.

It contains conceptual information and procedures needed to manage customer information and customer data quality.
You can use this guide to work with the customer data management capabilities such as duplicate identification,
duplicate resolution, address verification, and data enrichment.

Related Guides

You can refer to the related guides listed in the following table to understand more about the tasks covered in this guide.

Title Description

Getting Started with Your Customer Data Describes how to get started with the implementation of Oracle CX Customer Data Management
Management Implementation capabilities, such as managing customer information, identifying and resolving duplicates, verifying
addresses, and enriching data.

Using Customer Data Management Describes how to manage customer information and identify and resolve duplicates, verify addresses,
and enrich data.

Implementing Customer Data Describes tasks to configure and set up Oracle CX Customer Data Management capabilities, such as,
Management duplicate identification, duplicate resolution, address verification, and data enrichment.

Using Account and Contact Enrichment by  Describes how to use Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B) to update

Dun & Bradstreet company and contact data in your Oracle Cloud application.
Using Oracle Address, Email, and Phone Describes how to use Oracle Address, Email, and Phone Verification to verify and standardize
Verification addresses, emails, and phone numbers in your Oracle Cloud application.
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2 Manage Customer Information

Overview of Customer Data Management

You can use Oracle Customer Data Management Cloud to clean, consolidate, and enrich customer information, and to
create a trusted master customer profile.

Customer data management comes with these capabilities and components:
- Work areas to manage customer information
Data quality configurations
Data quality management capability during import process
- Separate work areas for duplicate identification, duplicate resolution, and address cleansing
- Work area for hierarchy management

Data enrichment capability

Customer Information Management

You can manage customer information, such as profile, usage assignments, relationships, classifications, source system
references, hierarchy memberships, linked records, accounts, and contacts, in the Organizations, Persons, and Groups
work areas. You can also use these work areas to create customers.

Data Quality Configurations

You use data quality configurations to define how data quality services, such as data quality matching and cleansing,
run during real-time and during batch execution. Data quality services use these configurations to call appropriate
services of the embedded data quality engine to consolidate, cleanse, and enrich customer data.

Data Quality Management During Data Import

You can configure the import process to:

Define deduplication within the data being loaded.

Define deduplication of the data being loaded against the records that exist in the registry.

You can also select a matching configuration to identify duplicates and specify the action to perform on the duplicate
records during the import process.

Duplicate Identification, Duplicate Resolution, and Address Cleansing

Duplicate identification lets you identify potential duplicates during data entry, data integration, or among records
already in the application.

Duplicate resolution lets you resolve duplicates either by directly merging them or by creating duplicate resolution
request such as merge or link. The resolution request can be verified, approved or rejected, and processed at a later
date.
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Address cleansing lets you cleanse address data existing in the registry and ensures data accuracy over time. Real-
time address cleansing ensures that the incoming data from source systems follows the same convention as the target
system for consistent information.

Hierarchy Management

You can make use of the hierarchy of your customers in many business processes. For example, you can use the
hierarchy management capability to capture your customer's corporate hierarchy and to show how headquarters,
branches, subsidiaries, and so on are related. You can use the corporate hierarchy information to process payments
from one customer and apply them to another customer in the same hierarchy.

Data Enrichment

You can use data enrichment to make account and contact data more comprehensive. Data enrichment improves the
quality of your existing account or contact data and address information as well as enriches that data with additional
information.

Manage Organization Information

You can use the Organization entity to manage information for different types of institutional customers, such as
business organizations and professional bodies.

An Organization exists separately from any business relationship that it enters into with another entity. For example,
the same Organization can enter into different business relationships, such as buying or selling, and can be referred

to differently, such as a customer or supplier, in different business flows across the application. In some Oracle Cloud
applications, organizations are referred to as accounts.

You can use the Organizations work area, to search for an organization, retrieve organization data from various systems,
review the data, and edit the data. The Organizations work area also provides you separate tabs to manage different
types of organization information such as profile, usage assignments, relationships, classifications, source system
references, hierarchy memberships, and linked records.

Create Organizations

To create organizations:

1. Navigate to the Organizations work area as follows: Navigator>Customer Data Management>Organizations.
2. Click the Create action menu option or button.
3. Complete the mandatory fields. Enter the following sample data:

o Usage: Party of Interest.
o Name: Green Corp.

o Registry ID: This is auto populated. However, you can override it with a unique identifier of your choice.

Note: You can create organizations with pre-defined or customer defined party usages. These party
usages must be created with the Unconditional Assignment as Yes.

4. Click Save and Close or Save and Edit, as required.
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Search Organizations Using Saved Searches

You can use several saved searches to find the organization you want to work with. Let's say you want to find all
organizations associated with a particular address, you can use the Search Organization saved search as follows:

Navigate to the Organizations work area as follows: Navigator>Customer Data Management>Organization.
Select Search Organizations from Saved Search.

Expand Search.

Click Add Fields and select any option prefixed with Address -. For example, Address- Address Line 1.

Enter the search phrase.

Provide value for one of the required fields such as Name or Registry ID.

Click Search.

You can see a list of organizations associated with the particular search phrase.

cUupPpUWND=
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Edit Organizations

To edit organizations:

1. Navigate to the Organizations work area as follows: Navigator>Customer Data Management>Organizations.
2. Search for the organization that you want to edit. You can search by entering criteria such as the organization
name or registry ID. You can also use the saved searches.

3. Select the organization you want to edit from the Search Results region and click through its name or registry ID
to navigate to the Edit Organization page.

4. On the Edit Organizations page, you can edit the organization's details such as usage assignments,
relationships, source system references, classifications, and linked records.

5. Click Save and Close.

Manage Person Information

You can use the Person entity to manage information for different types of individual customers and business contacts.

A Person exists separately from any business relationship that it enters into with another entity. For example, the same
Person can enter into different business relationships, such as buying or selling, and can be referred to differently, such
as a customer or supplier, in different business flows across the application. In some Oracle Cloud applications, person

customers are referred to as contacts.

You can use the Persons work area, to search for a person, retrieve person data from various systems, review the
data, and edit the data. The Persons work area also provides you separate tabs to manage different types of person
information such as profile, usage assignments, relationships, classifications, source system references, hierarchy
memberships, and linked records.

Create Persons
To create persons:

1. Navigate to the Persons work area as follows: Navigator >Customer Data Management >Persons.
2. Click the Create action menu option or button.
3. Complete the mandatory fields. Enter the following sample data:
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o Usage: Contact
o Fist Name: Andrew
o Last name: Flintoff
4. C(lick Save and Close or Save and Edit, as required.

Search Persons Using Saved Searches

You can use several saved searches to find the person you want to work with. Let's say you want to find all persons
associated with a particular address, you can use the Search Persons saved search as follows:

Navigate to the Persons work area as follows: Navigator>Customer Data Management>Persons.
Select Search Persons from Saved Search.

Expand Search.

Click Add Fields and select any option prefixed with Address -. For example, Address- Address Line 1.
Enter the search phrase.

Provide value for one of the required fields such as Name or Registry ID.

Click Search.

You can see a list of persons associated with the particular search phrase.

cuhlhuUNA
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Edit Persons

To edit persons:

1. Navigate to the Persons work area as follows: Navigator >Customer Data Management>Persons.

2. Search for the persons that you want to edit. You can search by entering criteria such as the person name or
registry ID. You can also use the saved searches.

3. Select the person you want to edit from the Search Results region and click through its name or registry ID to
navigate to the Edit Person page.

4. On the Edit Person page, you can edit the person's details such as usage assignments, relationships, source
system references, classifications, and linked records.

5. Click Save and Close.

How do | manage group information in Customer Data
Management

You can use the Group entity to create a customer record consisting of a collection of persons and organizations, and
have a business relationship with other entities. You can assign a group to opportunities and leads.

A group includes basic information such as name, type, and certification level, and child entities such as group
members, relationships, classifications, and contact methods. The group type such as Couple, Household, or Joint
Ownership classifies a group based on its purpose. The Groups work area provides you separate tabs to manage
different types of group information, such as profile, usage assignments, relationships, source system references, and
linked parties.

ORACLE



Oracle Fusion Cloud Customer Experience Chapter 2
Using Customer Data Management (CDM) Manage Customer Information

Group Members

A group member can be a person or an organization, and their member type attribute defines the relationship of the
member with the group. For example, a member of type Group Contact is the contact for the group. You can manage
members of a group from the Profile tab of the Group work area.

Create Groups

To create groups:

1. Navigate to the Groups work area as follows: Navigator > Customer Data Management > Groups.
2. Click the Create action menu option or button.
3. Complete the mandatory fields. Enter the following sample data:

o Name: John and Family
o Usage: Party of Interest
o Type: Household
4. Click Save and Close or Save and Edit, as required.

Edit Groups

To edit groups:

1. Navigate to the Groups work area as follows: Navigator > Customer Data Management > Groups.

2. Search for the group that you want to edit. You can search by entering criteria such as the group name, registry
ID, and type. You can also use the saved searches.

3. Select the group you want to edit from the Search Results region and click through its identifier to navigate to
the Edit Group page.

4. On the Edit Group page, you can add new group members as well as edit group details such as usage
assignments, relationships, source system references, classifications, and linked records.

5. Click Save and Close.

How You Manage Profile Information

The profile for any customer entity, such as Group, Person, or Organization, includes information such as customer
details, additional names, additional identifiers, addresses, and contact points.

You can add most of the customer profile information during record creation, except for some profile attributes, such as
an organization's financial and bank details. You can edit these profile attributes for an entity from the Edit page for that
entity, such as, Edit Group, Edit Person, or Edit Organization. The Edit page for an entity lets you set a primary contact
point or address for that entity.

One way to quickly view the history of changes made to a customer profile is to navigate to the Profile History page.

Some of the profile attributes, such as certification and primary contact details are common for all entity types and
usages. However, some other profile attributes are specific to a customer type. They are as follows:

- Organization: Includes name, organization information, certification information, legal information, and contact
details.
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Person: Includes person details such as name, address, and contact information.
« Group: Includes name, group information, and group members.

Related Topics
« Troubleshoot and Handle Errors

Track Profile History

Profiles and profile attributes of customer entities, such as Groups, Persons, or Organizations, can change over time
because of duplicate identification and resolution activities aimed at consolidating data from several different source
systems.

The Profile History tab provides you with a history of the changes to the profile of a customer entity.

How You Enable Profile History Tracking
You must set the profile option: ZCH_ENABLE_SURVIVORSHIP to Yes to enable profile history tracking.

View Profile History Information

To view the profile history information for a customer entity, navigate to the specific entity record as follows:

1. Signin as a Customer Data Management user, such as Data Steward or Data Steward Manager.

Navigate to the relevant work area, such as Groups, Persons or Organizations as follows: Navigator >
Customer Data Management.

3. Search for the record. You can search by entering criteria such as the name, registry ID, and type. You can also
use the saved searches.

4. Select the record from the Search Results region and click through its name or identifier to navigate to the
relevant Edit page. The Edit Organization (account), Edit Person (contact), or Edit Group (Household) page
appears.

5. Click the Profile History tab.

On the Profile History tab, you can use the From Date and To Date filters to view the profile history in that date range.

A quick way to determine the most recent record when multiple changes are done within a day, is to use the sequence
of changes on a given date along with the effective dates. The profile history information also includes changed
attributes such as name, legal status, and size.

Change Details

The Change Details section includes multiple changes done within a day and also indicate the record that's available
to be used in transactions. The old and new values of different attributes, such as name, legal status, and size, are also
displayed.

You can export both the profile history information and the change details to spreadsheets.

Attribute Details

The Attribute Details section contains the details of the attributes that were updated during the Last Updated Date row
that was selected in the Profile History section. The Changed Attribute and Rejected Attributes columns of the Profile
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History section display the attributes that were changed or rejected during a particular update. The Survivorship Result
column in the Change Details section display the result of survivorship rules that were applied for the update selected in
the Profile History section.

How You Manage Usage Assignments

You can use Usage Assignments to define how entities are used across the application and in different business flows.
Entities can have multiple usage assignments, such as Partner or Customer.

You can manage usage assignments for an entity from the Edit page of the selected entity, such as Edit Group, Edit
Person, or Edit Organization. You can navigate to this page by searching for the required record from the Groups,
Persons, or Organizations work area.

There are two types of usage assignments:

- Conditional usage assignments

Unconditional usage assighments

Conditional Usage Assighments

A conditional usage assignment requires a business event to occur. For example, adding a person as a contact for a
group creates contact usage for the person.

You can assign rules to a conditional usage assignment to define the business event. There are four types of rules:

- Assignment rules: Define how the usage can and can't be assigned.

Exclusivity rules: Restrict usage assignment, so that between a specified date range the usage can be the only
usage allowed to be assigned.

Incompatibility rules: Specify which usages can't be assigned concurrently during a date range.

- Transition rules: Define which usages can transition to the usage you're creating or editing.

Unconditional Usage Assignments

You can update unconditional usage assignments without the need for a business event. For example, you can update
the usage for an organization from a party of interest to a customer.

How You Manage Activities

You can review, create, and edit activities for your organization, a person, or a group. These activities can be
appointments or tasks. You can also record your communication, such as calls, with any resource or contact.
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Manage Appointments

You can use this procedure to manage your appointments with a contact or resource such as a customer or partner.
This activity can help you prioritize your appointments. You can also provide additional notes for a meeting, if required.

1. Signin as a Customer Data Management user, such as Data Steward or Data Steward Manager.

Navigate to the relevant work area, such as Groups, Persons or Organizations as follows: Navigator >
Customer Data Management.

3. Search for the record for which you want to manage appointments. You can search by entering criteria such as
the name, registry ID, and type. You can also use the saved searches.

4. Select the record from the Search Results region and click through its name or identifier to navigate to the
relevant Edit page. The Edit Organization (account), Edit Person (contact), or Edit Group (Household) page
appears.

5. Click the Activities tab.

6. Click Actions > Create Appointment to create an appointment. To edit an appointment, search for the
appointment and click Actions > Edit. To delete an appointment, search for the appointment and click
Actions > Delete. Confirm to delete.

7. Specify or change the details of the appointment such as subject, timings, contact with whom the appointment
is set, and so on. You can set the recurrence of the appointment. You can also create or edit notes for the
appointment. For more information about notes, see How You Manage Notes section in this chapter.

8. Click Save and Close. The appointment is displayed in the list.

Manage Tasks

You can use this procedure to manage tasks, provide a due date, and specify the owner, status, and priority for the task.
You can also provide additional notes, if required.

1.

u

8.

Sign in as a Customer Data Management user, such as Data Steward or Data Steward Manager.

Navigate to the relevant work area, such as Groups, Persons or Organizations as follows: Navigator >
Customer Data Management.

Search for the record for which you want to manage tasks. You can search by entering criteria such as the
name, registry ID, and type. You can also use the saved searches.

Select the record from the Search Results region and click through its name or identifier to navigate to the
relevant Edit page. The Edit Organization (account), Edit Person (contact), or Edit Group (Household) page
appears.

Click the Activities tab.

Click Actions > Create Task to create a task. To edit a task, search for the task and click Actions > Edit. To
delete a task, search for the task and click Actions > Delete. Confirm to delete.

Specify or change the details of the task such as subject, due date, contact with whom the task is to be done,
and so on. You can set the priority of the task, percentage of task completion, and status of the task. You can
also create or edit notes about the task. For more information about notes, see How You Manage Notes section
in this chapter.

Click Save and Close. The task is displayed in the list.

Manage Logging Calls

You can use this procedure to record the details of calls or any communication that you had with a contact or resource.
You can also specify the status and priority for the call.

1.
2.

Sign in as a Customer Data Management user, such as Data Steward or Data Steward Manager.
Navigate to the relevant work area, such as Groups, Persons or Organizations as follows: Navigator >
Customer Data Management.

10
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3. Search for the record for which you want to manage logging calls. You can search by entering criteria such as
the name, registry ID, and type. You can also use the saved searches.

4. Select the record from the Search Results region and click through its name or identifier to navigate to the
relevant Edit page. The Edit Organization (account), Edit Person (contact), or Edit Group (Household) page
appears.

5. Click the Activities tab.

6. Click Actions > Log a Call to details of a call. To edit a call log, search for the note and click Actions > Edit. To
delete a call log, search for the call log and click Actions > Delete. Confirm to delete.

7. Specify or change the details of the call log such as subject, due date, type of contact, the resource contacted,
and so on. You can set the priority of the call log, percentage of task completion, and status of the call log. You
can also create or edit notes about the call log. For more information about notes, see How You Manage Notes
section in this chapter.

8. C(lick Save and Close. The call log is displayed in the list.

How You Manage Notes

You can manage use this procedure to miscellaneous information for an organization, person, or a group in the form of
notes. You can create, edit, or delete notes.

Manage Notes

Perform the following steps:

1

ui

Sign in as a Customer Data Management user, such as Data Steward or Data Steward Manager.

Navigate to the relevant work area, such as Groups, Persons or Organizations as follows: Navigator >
Customer Data Management.

Search for the record for which you want to manage notes. You can search by entering criteria such as the
name, registry ID, and type. You can also use the saved searches.

Select the record from the Search Results region and click through its name or identifier to navigate to the
relevant Edit page. The Edit Organization (account), Edit Person (contact), or Edit Group (Household) page
appears.

Click the Notes tab.

Click Actions > Create to create a note. To edit a note, search for the note and click Actions > Edit. To delete a
note, search for the note and click Actions > Delete. Confirm to delete.

Specify or change the type of note and type or paste the contents of the note. You can also mark the note
private.

Click Save and Close. The note is displayed in the list of notes table.

How You Manage Relationships

You can manage complex real-life relationships among various entities such as employees, employers, contacts, and
organizations in the Edit page of the selected entity, such as, Edit Groups, Person or Organization.

You can navigate to this page by searching for the required record from the Groups, Persons or Organizations work area.
In Oracle Applications Cloud, a relationship is an entity's role in the context of another entity.

1
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Note: You can only view the relationships for the entity in context, unless you have the manage privilege.

You must define the following for each relationship:

- Relation types, such as employment or subsidiaries.

- Relationship role pairs, such as employee and employer.

- Relationship phrase pairs, such as employee of and employer of
In the Edit page for an entity, you can:

- View all relationships for the entity in context.

- Create relationships for an entity by specifying the relationship role, the related party name, and the
relationship start and end dates for each relationship.

- Modify the end date information and any additional information captured using descriptive flexfields for the
relationships.

- Delete a relationship to make it inactive.

Source System References

A source system is any data source from which you can import entity records and other related data.

Source system references are the cross references between the source system unique identifier of a record and the
unique identifier of that record in Oracle Applications Cloud.

Source System References in Oracle Applications Cloud

Companies may use multiple software applications to run their businesses. Often, these applications are supplied by
different vendors and run on different databases, and that can cause these issues:

- Duplication of records and data across systems.
- Logical representation or structure of records may vary.

- Keeping the data in different systems synchronized, generating a consolidated view, and sharing data across
systems becomes highly complex because of the difference in the logical representation.

You can resolve these issues in Oracle Applications Cloud by:

- Defining multiple external systems as source systems. While defining source systems you can specify the type
of the source system. The source system can be a Spoke system, such as a legacy system, or a Purchased
system, such as data from a third party provider. You can also specify which objects, such as parties only or
parties and contacts, are importable from a particular source system.

- Creating records in Oracle Applications Cloud database from one or multiple source systems by:

o Creating master records. Multiple source system references can create one master record by merging or
linking multiple duplicate records imported from multiple source systems.

o Creating records for every source system record. If you don't allow multiple source system references,
then a record will be created for every source system record. This means that you could potentially create
duplicate records in the database.

12
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- Using source system references, also known as cross references, to present a consolidated view. You can
maintain a central register of global identities, links to master data in source systems, lists of transformation
rules, and a minor subset of information that's needed to aid in matching. At runtime, you can access the
source systems' master data and assemble a point-in-time consolidated view.

How You Manage Source Systems

In Oracle Applications Cloud, you can:

- View source systems contributing to the party in the context from the Referenced Source Systems table.

- View source system identifiers information for the child entities of a party for the source selected from the
Referenced Source Systems table.

- Delete source system identifiers to change the status of the source system reference to inactive.

- Add source system identifiers to include a new source system reference.

Note: The source system, source system reference identifier, and the start date can't be updated. To change a source
system reference identifier, delete the current record and add a new source system reference.

13
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5 Import Your Data

About Import Management

How do | import data?

Use Import Management from the Tools work area, to import data from text files. This topic is your guide to importing
data in sales, service, and incentive compensation.

You can create, update, or delete records through import.
The import options and other details differ by the type of data that you're importing. Before importing, understand how
the data in your file maps to the attributes in Oracle Applications Cloud and what values are expected in the import file.

The data records in the CSV source file may not be processed in the listed order. To learn how to monitor the status of
your import, see the topic How You Monitor Your Import Activities in the Related Topics section.

Note: Don't submit duplicate import jobs for the same import object as they create duplicate object records.
To help you get started, you can use the example import object templates described in the related topics.

Import Data from a File
To import data:

1. Click Tools > Import Management.
2. Onthe Manage Imports page, click the Create Import Activity button.
3. On the Enter Import Options page provide values for each field as shown in the following table:

Field Description of the value
Name Name of the import.
Object Object that you're importing.

If you can't find your object, then search for it by clicking the Search link. In the Search and
Select dialog box, enter the object name in the Object text box and click the Search button.
Select your object from the result list and click OK.

You can also use the advanced search option by clicking the Advanced button. Here you can
search based on various filter criteria such as object name, Attachment supported, creation
date, and so on.

If the object you're importing isn't listed then verify if you have the roles and privileges required
to import the object. For information on the roles, see the topic Roles Required for Import and
Export Management referenced in the Related Topics section.
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Field Description of the value
Attachment Object To import an attachment for an existing object record in the database select the Attachments

object from the Object drop-down list. Next select the object from the Attachment Object
drop-down list.

For more details on importing attachments, review the topic Import Attachments.

File Name Browse and select a text file in CSV format. The first row of the source file is treated as the
header row. Provide a file name within 40 characters.

Note:

If your source file has more than 50,000 records, then you must manually split the file into
several smaller files with less than 50,000 records each. The file import page only permits
50,000 records for each import job. Alternatively, you can use the External Cloud Data
Loader Client, which can accept files with more than 50,000 records. See the My Oracle
Support (support.oracle.com) document External Data Loader Client (document ID 23252491)
for more information about this tool.

Import Object Hierarchy To import a hierarchy of objects, such as child and grandchild objects, click on the Import
Object Hierarchy link after you upload the source file for the parent object. Next select the
Enabled check box for the child object you want to import, and select the related source file.

Note: When importing child records for a parent object, ensure that the child records and
the parent records are imported in the same batch (using the same import file). If you import
child records in batches using parallel jobs, then the import job may fail because the parent
object record may be locked during the import process.

4. Optionally, to set additional import configurations, click the Advanced Options section. Here you can configure
settings under Source File, Import Options, or Create Schedule sections.

a. Inthe Source File and Import Options regions, some of the options in the following table might not be
available depending on the object that you're importing:

Option Description

Import Mode You can specify whether you want to create and update records or update them only.

- Update and create records - a new record is created if a matching record isn't
found. This is the default option.

- Create records - all the records in the file are new records which have to be created.
If there are any existing matching records, then they're marked as errors.

- Delete records - all the records in the file are deleted.
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Option

Enable High-Volume Import

Enable Survivorship

Notification email

Enable Custom Business Logic

Delimiter

ORACLE

Chapter 3
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Description

The high-volume import mode is designed to import millions of records at once. This
mode doesn't trigger any custom logic configured through the application composer. For
a list of supported objects, see the topic Data Import Options.

By default, this mode is enabled for the supported objects.

Note:
If ZCA_FILE_IMPORT_ENABLE_CUSTOM_BUSINESS_LOGIC is set to “Yes”, then you
won'’t be able to use High Volume import.

Survivorship on update is available for Account, Organization, Contact, and Person. The
check box is visible if the attribute survivorship is configured on the objects. You can use
high-volume import mode, only when the survivorship configuration uses only Source
Confidence. You can't use the high-volume import mode when Data Quality Rules are
enabled.

The email of the individual who receives import processing notifications. The user
submitting the import receives an email notification automatically. To have more than
one email recipient, separate the email addresses with a semicolon. If you don't want to
receive the notification, then set the profile option ORA_ZCA_IMPEXP_ENABLE_EMAIL _
NOTIFY to 'N' at user level.

If you select this check box, then any custom triggers and validations configured for
the object are enabled. This may affect import performance, because of configurations.
Hence, disable this option for better performance.

To enable this check box by default, set the profile option ZCA_FILE_IMPORT_ENABLE_
CUSTOM_BUSINESS_LOGIC to 'Yes' by navigating to the Manage Administrator Profile
Values task.

Note:
If ZCA_FILE_IMPORT_ENABLE_CUSTOM_BUSINESS_LOGIC is set to “Yes”, then you
won't be able to use High Volume import.

Note:
This selection has no effect on events and object workflows, and is applicable only on
triggers and validations.

If your file doesn't use a comma to separate values, then select the correct delimiter in the
Delimiter drop-down list. Possible values are:
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Option Description
- Caret Symbol
- Closing Curly Bracket

- Closing Parenthesis

- Closing Square Bracket
- Colon

- Comma

- Exclamatory Mark

- Minus

- Opening Curly Bracket
- Opening Parenthesis

- Opening Square Bracket
- Pipe Symbol

- Plus

- Question Mark

- Semi-Colon

- Star Symbol

- Tilde Symbol

Decimal Separator The decimal separator used in your import file.

Date Format The format of the date fields in your file.

Time Stamp Format The format of the time fields in your file.

File Encoding The format in which your source file is encoded. The possible values are:
- Chinese Simplified - GB, CP936
- Chinese Traditional - CP950
- Eastern European - Win, CP1250
- Greek - MS Windows, CP932
- Japanese - Shift- JIS, CP932
- Unicode - UTF-16
- Unicode- UTF-16BE, Mac, Unix
- Unicode - UTF-16LE, MS Windows
- Unicode - UTF-8
- Western European - Win, CP1252
Note: The above mentioned encoding formats are the only ones supported. Importing

file with any other format, such as ANSI, will cause unexpected characters to be
imported.
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b. Inthe Create Schedule region, schedule the import to run immediately or at a future date. If you select a
future date, then provide the date and time to start the import.

You can save the Advanced Options for subsequent reuse by clicking on the Save advance options link in the
Ul. The options are retained until you click the Reset link and reset the options to application defaults.

Note: All fields except Import Mode, Enable Custom business Logic, Enable High-Volume Import, Enable
Survivorship Logic, Schedule Mode, and Schedule Start Time will be saved.

5. Click Next. The Map Fields page shows the first row of the data from your source file. By default, the
application tries to automatically map each of the source file columns to the appropriate target object attribute.
If some of the columns in your file couldn't be mapped, then drag the target attribute onto the Attribute
Display Name column in the Source File region.

The data in unmapped columns aren't imported.

You can save your import map by clicking on Save As in the Create Import Activity page. You can use the saved
map for future imports. You can view your saved maps by clicking on the Import Mapping drop-down list in
the Create Import Activity page.

Also, you can select and then edit your saved maps for the specific objects in the Import Objects page.

6. You select a predefined mapping from the list of available mappings in the Import Mapping drop-down list. If
you're reusing an import mapping, then both the source and target columns are already populated.

Leave the Attribute Display Name field blank for any column that you don't want to import.

Click Validate Data to check the field mapping.

7. Inthe case of hierarchical import, you can see the mapping information for child objects in the subsequent
tabs. Note that data validation isn't done for these objects.

8. C(lick Next. On the Review and Submit page, review the import activity configuration. If you had not run the
prevalidation on the Map Fields page, then you get a notification message to run the validation process. You
can view any unmapped columns of parent or child objects on this page.

9. C(lick Validate Data to check the data in your source file. Validation errors, if any, are displayed on the Mapping
Validation screen. If you get warnings about unmapped columns, then you can ignore these columns, and
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proceed to submit the import job. Validations are for informational purposes and applicable only for low-
volume imports.

Note: Inimport activity with single CSV hierarchical records, explicit validation from the mapping Ul isn't
supported. For example, while importing the sales territory object, if there are matching values for the
attributes ParentUniqueTerritoryNumber and UniqueTerritoryNumber, then validation isn't supported.

Note: During the import validation process on the Mapping page, the following custom triggers aren't
supported:
o  Before InValidate

o Before Remove

o  Before Insert in Database
o Before Update in Database
o Before Delete in Database

o Before Rollback in Database

o  After Changes Posted to Database

10. Click Submit to queue the import.
Note that business events aren't fired when using Import Management.

Automating and Scheduling Import Jobs

You can automate import jobs using the import REST services. The import REST services let you manage import
activities, manage activity maps, and export object metadata. You can use an external scheduler that uses these REST
services to run recurring import jobs, create and run import activities, manage maps, and review object metadata.

You can use the Oracle WebCenter Content Document Transfer Utility to manage the import files used by the scheduler.
You can download the Oracle WebCenter Content Document Transfer Utility by navigating to the My Oracle Support
(support.oracle.com) document Oracle WebCenter Content Document Transfer Utility Readme (document ID 1624063.1).
Once downloaded, you can run the tool by navigating to the ridc folder after extraction.

For detailed instructions on automating and scheduling file import using REST API, see Oracle CX Sales and Fusion
Service: Automating and Scheduling File Import Activity Using REST API (Doc ID 2308691.1) article on My Oracle Support
(support.oracle.com).

Set Up Event Notifications for Resources

In file-based data import, the sendcredentialsEmailFlag attribute allowed the import to specify the notification setting
for each employee resource. You can do this in Import Management using the User Category option but this applies to
all resources in a single import.

To set up notifications for all events:

Navigate to Tools > Security Console on the home page.

Click the User Categories tab.

Click DEFAULT. Click the Notifications tab.

Click the Edit button. To turn on all notifications, then select the Enable Notifications checkbox in the
Notification Preferences heading.

Click the Save button.

PUWNa

ui
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6. Click the Done button.

To set up notifications for a specific event:

XNV AWN

Navigate to Tools > Security Console on the home page.
Click the User Categories tab.

Click DEFAULT. Click the Notifications tab.

Click the Edit button.

To turn on a specific event notifications, click the template for the desired event.
On the Template Information page, select the Enabled checkbox and click Save and Close.

Click the Save button.
Click the Done button.

Import FCLs and DCLs
Setting FCL Field values

You must pass the lookup code in order to set the FCL field using import management.

Setting FCL and DCL Fields to Null

Chapter 3
Import Your Data

You must pass #NULL value for the FCL field in order to nullify a value for an FCL using Import Management.

Here is an example to nullify TargetGlobalPJDetailFlagl_c field:

Partyld TargetGlobalPJDetailFlagl_c
100000001527765 #NULL
Related Topics

How do | import attachments?

How do | monitor import activities?

How do | map import fields?

What are my data import options?

What are the roles required to import or export data?

How do | import attachments?

You can import attachments associated with any supported object.

Supported Objects and File Types

The following objects support importing attachments:

- Account

« Activity

« Asset

ORACLE
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Business Plan

- Contact

- Custom Object
Deal Registration
Household
Message

- Objective

« Opportunity

- Opportunity Revenue
Partner
Partner Program
Product

- Sales Lead

- Sales Lead Product

- Service Request

The following file types are supported for attachment files:

- CSV
DOC
DOCX

- JPG
PDF
PNG
PPTX

- TIF

- TEXT

« XLSX

- XML

- ZIP

How to Create ZIP File

Chapter 3
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To import an attachment, you must create a ZIP file that contains the source data file and optionally one or more
attachment files. Make sure you always name the source file as 'Attachment.csv'. You must mention each of the
attachment file names in the Attachment.csv file. The Attachment.zip file has the structure shown in the following

image:

ORACLE
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Here are the examples for the attachment.csv file shown in purple box in the image above:

Pk1Value

100100004247330

100100004247330

100100004247330

ObjectPuid

CDRM_6493

FileName Url

http://www.yahoo.com

Clouds.jpg

Taxdocs.docx

http://www.google.com

ORACLE
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Pk1Value ObjectPuid FileName Url
CDRM_6493 Holidays.pdf
Note:

Pk1Value and ObjectPuid column values uniquely identify an existing object record. FileName indicates the
name of attachment files. Url indicates the value of URL attachment to import.

- The exact file name must exist in the zip file such as Document.pdf

- The attachment ZIP file name can include characters such as parenthesis (), ampersand (&), dots (.),

and apostrophe (') only. You shouldn't have more than one period (.) in your attachment name. Also, the
rootname.extension shouldn't be more than 80 characters.

- An attachment can only be associated with an existing record of the object. A single record can be associated

with multiple attachments by having multiple rows in the CSV file. You can import any number of attachments
in an import job, but the ZIP file should not exceed 250 MB in size.

- Arecord in the CSV file can't have values for both FileName and Url columns. You can pass either the Primary

key or the PUID for an object record. If you pass both Primary key and PUID values, then Primary key will be
considered and PUID will be ignored.

- The AttachedDocumentld should be left blank.
- The DatabaseTitle shouldn't be higher than 79 character.

How to Import Attachments
To import attachments:

1.
2.
3.

Click Tools > Import Management.

On the Manage Imports page, click Create Import Activity.

On the Enter Import Options page, enter a name for your import. From the Object drop-down list select
Attachments.

In the Attachment Object drop-down list that appears, select the object associated with the attachment.
Select the ZIP file that you created in the previous section.

Click Next. On the Map Fields page, click the Apply button next to the Import Mapping drop-down list to map
the source and target attributes automatically.

Click Next to navigate to the Review and Submit page.
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Review the import activity configuration and click Submit to activate the import. The Manage Imports page shows
the status of the submitted import. The topic Import Data in the related topics section contains more details about the
import process.

Related Topics
« How do | import data?

How You Enable Survivorship During Import

Survivorship on update is available for the following four Import Management objects:

» Account

- Organization
- Contact

- Person

You include the data that you want to import into CX Sales and Fusion Service in a source CSV file. This CSV file
depends upon the object you want to import. Before you start importing, check that the CSV file contains the
SourceSystem value. For more information, see Import Your Account Data, Import Your Contact Data, Import Your
Person Data, and Import Your Organization Data topics in this guide.

Enable Survivorship

After you have the CSV file ready, create an import activity to import the account information and enable survivorship
as follows:

1. Go to Navigator > Tools > Import Management > Import Queue.

2. Click Create Import Activity in the Manage Imports page.

3. Inthe Enter Import Options page, provide a name for the import activity, and select either Account,
Organization, Contact, or Person from the Object drop-down list.

Click to expand Advanced Options section.

5. Select Enable survivorship logic.

P

Note: This option is available only if the selected import object is Account, Organization, Contact, or Person
and attribute survivorship has been already configured. High-Volume import mode is supported, if the
survivorship configuration only uses Source Confidence. If Data Quality Rules are enabled, High-Volume
mode import isn't available.

You can continue to import and review the import results.

You can then import data. For more information on how to import data, see Import Data topic in Related Topics section.

Related Topics
« How do | import account data?

« How do | import contact data?
« How do I import person data?
» How do | import organization data?
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Import Data

How do | import account data?

You can use Import Management to create, update, or delete your account data.

You can import account records using these steps:

1. Map your source account data to Oracle Applications Cloud object attributes. This way the import process
would know where to insert each of the information bits.

2. Create the source CSV file with the account data you want to import.

3. Kick off an import activity.

4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import account data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to
target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

Understand your options for uniquely identifying the records.
Ensure parent records exist before importing child records.
Identify the target object attributes that are required in the .csv file for a successful import

Note: You can enable automatic territory-based assignment after sales accounts are imported. You can enable this
feature by turning the profile option ZCA_BATCH_ASSIGN_ON_BULK_IMPORT ON. If the profile option is disabled,
then you must manually run a batch assignment or assign each sales account individually.

To better manage your account information, the account object has the following child objects:

- Address

- Classification
Relationship

- Sales Team Member

Note: You can't set an attribute value to NULL in high-volume import (import management with the option Enable
High-Volume Import selected). However, when updating a record, you can change an attribute value from NOT NULL
to NULL

If you're importing account records with attributes specific to the parent account object or along with single child record
details (like phone, email, address, and so on), then you can include the child record details in the same .csv file for
account object. However, if you're importing multiple records of any child object, then you must create multiple .csv
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files to import- one for each child which has multiple records that you're importing. For example, if you're importing 5
emails, 5 phones, and 5 addresses for an account, then you must create three import files - one for Account object, one
for Contact Point object (phone and email), and one for Address object. There are separate help topics describing how
to import each of these child objects. For more information, see the related topics section.

I Note: High-volume import for accounts now supports hierarchy management and generation.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data. For example, when
using source system reference information to identify your account records, the source system of the account
object should be enabled for parties using the Manage Trading Community Source Systems task.

- You have all parent records in place before importing child records. For example, when importing the address of
an account, ensure the account exists.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with ‘Number' and visible in the business object's Ul. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For account object, the attribute is PartyNumber and shows up
in the Ul as Party Number. For more information about public unique identifiers, see the topic "How You Use
Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new accounts or are
updating accounts that have source system reference data, then provide the source system and source system
reference values. For account object, these are SourceSystem and SourceSystemReferenceValue and show up
as Party Source System and Party Source System Reference Value in the UL.

Review Required Attributes and Validations for Account Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure
that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for account records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Creating an Account  Updating an Existing Deleting an Existing
Tasks or Import Record Account Record Account Record
Validations

SourceSystem The source system for ~ Know the source Conditionally Required Conditionally Required Conditionally Required
the sales account. system.
To identify an account = To identify an account = To identify an account
To view source record, use one of record, use one of record, use one of
systems, use the these: these: these:

Manage Trading
Community Source
System task.
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Attribute Description Prerequisite Setup Creating an Account  Updating an Existing Deleting an Existing
Tasks or Import Record Account Record Account Record
Validations
- SourceSystem - SourceSystem - SourceSystem
and and and
SourceSystemRefe SourceSystemRefe SourceSystemReferenceValt
- PartyNumber - PartyNumber - PartyNumber
SourceSystemReferenci The reference number  Know the source Conditionally Required Conditionally Required Conditionally Required
or text representing system reference
the source system value. To identify an account = To identify an account = To identify an account
unique ID for the party record, use one of record, use one of record, use one of
(account or contact) to  To view the source these: these: these:
which the sales profile  systems reference, use
belongs. the Manage Trading . SourceSystem . SourceSystem - SourceSystem
Community Source and and and
System task. SourceSystemRefe SourceSystemRefe SourceSystemReferenceValt
»  PartyNumber »  PartyNumber »  PartyNumber
PartyNumber The public unique The party must exist. = Conditionally Required Conditionally Required Conditionally Required

identifier of the party.
You get a list of all
party IDs and party
numbers by exporting
the Party object.

OrganizationName The name of the party  Organization names Required Conditionally Required Conditionally Required
of the Organization are listed in the
party type. Resource Directory.

OwnerPartyld The identifier of the This attribute is Required Not Required Not Required
account owner. required only in

import management,
but optional in high-
volume import.

Note: When deleting or updating accounts, you must ensure that the account related to the party number provided
has the Sales Account usage. If you provide the party number of an account that doesn't have the Sales Account
usage, then the relationships for that account are also deleted. For example, if you provide the party number
ORA17292 that doesn't have a Sales Account usage, then the related partners, contacts, and so on are also deleted.

For the extension child objects of account, RecordName field isn't unique. Hence you can't update the records only by
passing RecordName.

You can use the profile option ORA_HZ_IMPORT_MULTI_ADDRESS_TYPE to control how address types are entered. By
default this profile option is set to Yes, so you can enter multiple address types, during high-volume import of Account,
Contact, and Household objects . You can disable this profile option to improve the import performance. When you set
this profile option to No, you can enter only a single address type.
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Note: When importing accounts or legal entities, you can retrieve duplicates using the Customer Data Management
Duplicates LOV only if you have licensed the data quality functionality. Once licensed, you must rebuild the keys for
your matching configuration using the Manage Enterprise Data Quality Matching Configurations task. After the keys
are rebuilt, the matching functionality uses the settings in the match configuration to identify duplicates.

Go to Navigator > Tools > Import Management > Import Objects to see all the attributes of the account object. The
page also lists attribute information like type, length, description, and so on.

Create the Source CSV File

You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects Ul page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Account object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Providing the ZIP and Country Code values in the import CSV file won't automatically populate the State/County/City
fields. Values for these fields should be separately provided in the import file.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the account information. To create an import
activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. C(lick Create Import Activity in the Manage Imports page.

3. Inthe Enter Import Options page, provide a name for the import activity, and select Account from the Object
drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.
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Note: After importing your data successfully, you need to run a couple of post processing jobs for duplicate
identification, duplicate resolution, and account assignment. For more information on import management post
processing jobs, see the topic Import Management Post Processing Jobs

When importing accounts you can now load the account hierarchy data. Use the following attributes to import accounts:

ParentAccountPartyld
ParentAccountPartyNumber
ParentAccountSourceSystem
ParentAccountSourceSystemReferenceValue

You can load account hierarchy data. To load the account hierarchy data:

1. Load the account data without providing values for the parent attributes mentioned above.
2. Load the account hierarchy using the Hierarchy and Hierarchy Member import objects. For more information,
see How do | import hierarchy data? and How do I import hierarchy member data?

Delete an Account

Related Topics
« How do | import data?

« Import Your Address Data

« How do | import contact point data?

« How You Use Alternate Keys to Import Records
 Potential Issues When Opening CSV Files in Excel
» How You Enable Automatic Account Assignment

How do | import contact data?

You can use the Import Management to create, update, or delete contact records.

You can import contact records using these steps:

1. Map your source contact data to Oracle Applications Cloud object attributes. This way the import process would
know where to insert each of the information bits.

2. Create the source CSV file with the contact data you want to import.

3. Kick off an import activity.

4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your contact data into Oracle Applications Cloud, you must populate a .csv file with your source data and map
that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
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Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

Understand your options for uniquely identifying the records.
Ensure parent records exist before importing child records.
Identify the target object attributes that are required in the .csv file for a successful import

To better manage your contact information, the contact object has the following child objects:

- Address

- Classification
Relationship

- Sales Team Member

Note: You can't set an attribute value to NULL in optimized import (standard import with the option Enable High-
Volume Import selected). However, when updating a record, you can change an attribute value from NOT NULL to
NULL

If you want to import only a few records, then you can create a single CSV file for all contact attributes. However if you
want to import a large number of records, then you may decide to create multiple CSV files, one for each of the contact
child objects. Note that you must have imported the CSV file for contact object successfully before trying to import the
CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For
more information, see the related topics section.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique ldentifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with ‘Number' and visible in the business object's Ul. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new contacts or are
updating contacts that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for the Contact Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for contact records, prerequisite setup tasks and specific validations, if any:
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Attribute

SourceSystem

Description

The code representing
the source system for
the contact.

SourceSystemRefere¢ The reference number

PartyNumber

FirstName

LastName

or text representing
the source system
unique ID for the
contact.

The public unique
identifier of the
contact.

First name of a person
party.

Last name of a person
party.

Prerequisite Setup
Task or Import
Validations

Identify the source
system or configure
source systems either
by using the Manage
Trading Community
Source System task,
or by importing

the source system
information into
Oracle Applications
Cloud using the
Source System
Reference import
object.

Identify the source
system or configure
source systems either
by using the Manage
Trading Community
Source System task,
or by importing

the source system
information into
Oracle Applications
Cloud using the
Source System
Reference import
object.

No prerequisite tasks

No prerequisite tasks

No prerequisite tasks

Creating a Contact
Record

Conditionally

Required For uniquely
identifying a contact
record, provide one of
the following reference
information:

- SourceSystem
and
SourceSystemRefe

- PartyNumber

Conditionally

Required For uniquely
identifying a contact
record, provide one of
the following reference
information:

- SourceSystem
and
SourceSystemRefe

- PartyNumber

Updating an Existing
Contact Record

Conditionally

Required For uniquely
identifying a contact
record, provide one of
the following reference
information:

- SourceSystem
and
SourceSystemRefe

- PartyNumber

Conditionally

Required For uniquely
identifying a contact
record, provide one of
the following reference
information:

- SourceSystem
and
SourceSystemRefe

- PartyNumber
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Deleting an Existing
Contact Record

Conditionally

Required For uniquely
identifying a contact
record, provide one of
the following reference
information:

- SourceSystem
and
SourceSystemReferenceValt

- PartyNumber

Conditionally

Required For uniquely
identifying a contact
record, provide one of
the following reference
information:

- SourceSystem
and
SourceSystemReferenceValt

- PartyNumber

Conditionally Required Conditionally Required Conditionally Required

Required

Required

Not required

Not required

Not required

Not required

Note: For the Time Zone import attribute, specify the time zone of the contact to know the preferred time to call or
send e-mail to the contact.

You can use the profile option ORA_HZ_IMPORT_MULTI_ADDRESS_TYPE to control how address types are entered. By
default this profile option is set to Yes, so you can enter multiple address types, during high-volume import of Account,
Contact, and Household objects . You can disable this profile option to improve the import performance. When you set
this profile option to No, you can enter only a single address type.

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the contact object. The
page also lists attribute information like type, length, description, and so on.

ORACLE
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Create the Source CSV File

You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects Ul page to create the source CSV file. To download a template:

1. Goto Navigator > Tools > Import Management > Import Objects.
2. Select the Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Providing the ZIP and Country Code values in the import CSV file won't automatically populate the State/County/City
fields. Values for these fields should be separately provided in the import file.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the contact information. To create an import
activity:

1. Go to Navigator > Tools > Import Management > Import Queue.

2. Click Create Import Activity in the Manage Imports page.

3. Inthe Enter Import Options page, provide a name for the import activity, and select Contact from the Object
drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Goto Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Note: After importing your data successfully, you need to run a couple of post processing jobs for duplicate
identification, duplicate resolution, and account assignment. For more information on import management post
processing jobs, see the topic: Import Management Post Processing for Accounts and Contacts.

Related Topics
- Potential Issues When Opening CSV Files in Excel

« How You Use Alternate Keys to Import Records
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Import Your Country Structure Data

You can use Import Management to create Country Structure records. It is recommended you use Import Management
only if you're importing high-volume third-party data.

If you 're importing licensed data from one of our vendors, then you can create the country structure by navigating to
Setup and Maintenance > Manage Geographies Task page.

To import Country Structure records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.

3. Create the import activity.

4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Country Structure data into Oracle Applications Cloud, you need to populate a CSV file with your source
data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Identify the target object attributes that are required in the CSV file for a successful import.

Required Attributes and Validations for Country Structure Object

To import data successfully into Oracle Applications Cloud, your CSV file must include values for the required attributes.
This table lists the required attributes for importing new Country Structure records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Country Structure import:

Attribute Description Prerequisite Setup Task/ Import Creating a Country Structure
Validations Record
CountryCode The code for the country for which = The GeographyType has to be Yes

the country structure is applicable. = "Country" and the LevelNumber
has to be "1" for a country.

You can't pass different country
codes when importing a record.

GeographyType Geopolitical divisions such as The country has to be present. Yes
Country, State, City, and so on.
For example, for US the different
geography types would be State,
County, City, and Postal Code.
For India, the different geography
types would be State, District,
City, and Postal Code. For Mexico,
it would be State, Municipality,
Locality, and Postal Code.

LevelNumber You need these to create parent- To define a country, you must Yes
child relationships between specify the LevelNumber as 1.
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Attribute Description Prerequisite Setup Task/ Import Creating a Country Structure
Validations Record

geography types for your country.
The values can be 1, 2, 3, and so on.

You can view the Country Structure object and its attributes in the Manage Import Objects page of the Import
Management flow. You can find attribute information like type, length, description, and so on, on the Manage

Import Objects page. You can view the list of valid values for country codes in the Ul by navigating to the Manage
Geographies task and searching with % as the Country Code value. For more information on Geographies, see Overview
of Geographies, Geographic Entities, and Locations in the Related Topics section.

Note: Note the following:
- Theimport job will fail if you try to load any already existing country structure. Delete the existing country
structure in the Ul in Manage Geographies Tasks and import again.

- You can't load additional lower geography structure levels for an existing country structure while importing
geography country structure. You can add additional geography levels in the Ul for an existing country
structure in the Manage Geographies task page.

Create the Source CSV File

You include the data that you want to import into Oracle Applications Cloud in a source CSV file.

You can use the templates available in the Import Objects Ul page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Country Structure object in the table and click Download.

You can now edit the downloaded file and provide values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.

3. Inthe Enter Import Options page, provide a name for the import activity, and select Country Structure from
the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Click Validate Data to check the file for unmapped columns or data format issues. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
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Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.

2. Click All Imports and search for the import activity that you created earlier.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details
of the import activity. Here, you can download and review the successfully imported user data records, the
mapping details used for import activity, and the data file that you provided in CSV format.

Related Topics
« How do | import data?

- Potential Issues When Opening CSV Files in Excel
» Overview of Geographies, Geographic Entities, and Locations
« How do | manage geography validation?

Example of Importing Country Structure Data

You use the country structure of a country to define which geography types are part of the country and how the
geography types are hierarchically related within the country.

For example, you can create geography types called State, City, and Postal Code. Then you can rank the State
geography type as the highest level within the country, the City as the second level, and the Postal Code as the lowest
level within the country structure.

To add a country structure using import management, your source file must contain information about the country to
which the country structure belongs. You can view the list of valid values for country codes in the Ul by navigating to
the Manage Geographies task and searching with % as the Country Code value. You also need to specify the level at
which the geography types need to be placed. By default, all countries are at Level 1. You create the country structure
by increasing the level number as you go down the country structure. You place the geography types such as states,
provinces, and so on at Level 2, districts or counties at Level 3, and so on. To add a country structure, your source file
must include the values that let the import process identify the existing records.

Sample Input CSV File

You include the data that you want to import into CX Sales and Fusion Service in a source CSV file. Here is a sample
input CSV file for country as US.

CountryCode LevelNumber GeographyType
us 1 COUNTRY

usS 2 STATE

us 3 COUNTY

36
ORACLE


https://www.oracle.com/pls/topic/lookup?ctx=fa-latest&id=s20056853
https://www.oracle.com/pls/topic/lookup?ctx=fa-latest&id=s20079766
https://www.oracle.com/pls/topic/lookup?ctx=fa-latest&id=s20032045

Oracle Fusion Cloud Customer Experience Chapter 3

Using Customer Data Management (CDM) Import Your Data
CountryCode LevelNumber GeographyType
us 4 cITy
us 5 POSTAL CODE

Here is another input CSV file for importing the country structure for India.

CountryCode LevelNumber GeographyType
IN 1 COUNTRY

IN 2 STATE

IN 3 DISTRICT

IN 4 Ty

IN 5 POSTAL CODE

In case you want to import the country structure for Mexico, your input CSV file would look like this:

CountryCode LevelNumber GeographyType
MX 1 COUNTRY

MX 2 STATE

MX 3 MUNICIPALITY
MX 4 LOCALITY

MX 5 POSTAL CODE

In this example, we are importing the Country Structure for US. You must create a source file (CSV) file with the
attributes as shown in this table and import it using Import Management.

Attribute Name Value Description

CountryCode us The code for the country for which the country
structure is applicable.
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Attribute Name Value Description
LevelNumber 1 The level number of the geography in the

hierarchy. For example, Country is at Level 1
(Top level) and State (California) is at Level

2. You need these to create parent-child
relationships between geography types for your
country.

GeographyType COUNTRY Geopolitical divisions such as Country, State,
City, and so on. For example, for US the
different geography types would be State,
County, City, and Postal Code. For India, the
different geography types would be State,
District, City, and Postal Code. For Mexico,
it would be State, Municipality, Locality, and
Postal Code.

Create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
. Click Create Import Activity in the Manage Imports page.
3. Inthe Enter Import Options page, provide a name for the import activity, and select Country Structure from
the Object drop-down list.

Note: In the Advanced Options section, the option Enable High-Volume Import is selected by default. This
mode is designed to import millions of records at once.

4. Select the CSV file in the File Name field, and click Next.

5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the
mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit.

How do | import Non-Oracle Licensed geography data?

You can use Import Management to create Geography data. It's recommended to use import management if you're
importing Non-Oracle Licensed geography data or while loading your own geography from other vendors. You can also
add alternate name or code to existing geographies with import. For more information see Can you provide an example
of importing geography data?.

To import Geography data, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.

3. Create the import activity.

4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Geography data into Oracle Applications Cloud, you must populate a .csv file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.
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You need to do the following before creating the CSV file for data import:
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- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

- Create Country Structure before importing Geography data. For information on how to create Country
Structure, see Import Your Country Structure and Example of Importing Country Structure in Related Topics

Section.

- Identify the target object attributes that are required in the CSV file for a successful import as mentioned in the
table Required Attributes and Validations for the Geography Object below.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data such as creating a

country structure.

Required Attributes and Validations for the Geography Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide values for the attributes. The following table lists the required attributes for importing new Geography
records, prerequisite setup tasks for the attributes, and specific validations, if any, for Geography import:

Attribute

CountryCode

PrimaryGeographyName

RecordTypeCode

LevelNumber

ORACLE

Description Prerequisite Setup Task/ Import
Validations

The code of the country to which This is validated against the

the geography belongs. country structure to check if
the structure is defined for this
country.
The primary name of the This is validated against the name
geography. of country if geography type is

'‘Country' or LevelNumber is 1.

The record type code that No Validation
represents the intent of the import
data. The values are:

0 - indicates the geography
that already exists in the base
table.

1- indicates the intent to
create a new geography.

2 - indicates the intent to
add an alternate identifying
name or code to an existing
geography.

The level number of the geography The level should exist in the
in the hierarchy. For example, country structure.

Country is at Level 1and State

(California) is at Level 2.

Creating a Geography Record

Required

Required

Required

Required
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Attribute Description Prerequisite Setup Task/ Import Creating a Geography Record
Validations
SourcelD The source ID for the geography, None Required

along with the parent source ID
is used to identify the geography
parent and child relationship
within the source file data and the
interface table data.

ParentSourcelD The parent source ID for the None Required
geography, along with the
source ID is used to identify the
geography's parent and child
relationship with records within the
source file data. This should be null
for the country record, as Country
is at the top of the hierarchy.

You can view the Geography object and attributes in the Manage Import Objects page of the Import Management flow.
You can find attribute information like type, length, description, and so on, on this Manage Import Objects page.

Note: Keep a note of the following:

- You can't update geographies using import.
- You can't add alternate names or alternate code of country via import. You can do so only via Ul.

- Before adding a new alternate name, make sure that the alternate name does not exist with the same value
for any other geography name.

- You can enable high-volume import for the Geography import object in the Manage Import Objects page.

- PrimaryGeographyCodeType and PrimaryGeographyCode can't be added after PrimaryGeographyName is
created via import. You must create them together. Alternatively, you can add primaryGeographyCodeType
and PrimaryGeographyCode from the Ul after the import is complete.

Create the Source CSV File | S
You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects Ul page to create the source CSV file. To download a template:

1. Goto Navigator > Tools > Import Management > Import Objects.
2. Select the Geography object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.

2. Click Create Import Activity in the Manage Imports page.

3. Inthe Enter Import Options page, provide a name for the import activity, and select Geography from the
Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the
mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.

2. Click All Imports and search for the import activity that you created earlier.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Note: Geography names aren't translatable and are always displayed in the same language in which they were loaded
irrespective of the language of the signed in user. If you need different options of display, you can use the alternative
names option.

Related Topics
« Import Your Country Structure Data

» How do | import data?

 Potential Issues When Opening CSV Files in Excel

« Example of Importing Country Structure Data

« Canyou provide an example of importing geography data?

Can you provide an example of importing geography data?

This example demonstrates how to import third party geography reference data using Import Management.

In this example, you have a source file containing geography data that you want to import into the application to
make the geography data available for real time address validation and tax purposes. A geography is any region with a
boundary around it, regardless of its size. It might be a state, a country, a city, a county, or a ward.

Summary of the Tasks
You perform the following steps to create an import activity and activate the import:

1. Determine what information is in the source file.
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2. Create and schedule the import activity.

Before You Start

1. You use the country structure of a country to define which geography types are part of the country. For more
information about an example of importing a country structure, see the topic "Example of Importing Country
Structure Data".

2. Ensure that Source ID values are unique for each row of data within a single import.

3. Ensure that all the parents of a child geography are included in your data file so that the child geography can be
added. For example, if you originally imported US, CA, and San Francisco, and now you want to import the city
of San Jose in CA, then your data file must include US, CA, and San Jose.

4. Check that your source data file has the correct values for the geography data that you have already loaded. For
example, if your initial import included the value US for country and CA as state, and in a subsequent import
you have California as a state, then your geography import creates two state records (CA and California) in the
application data, with the US as the country parent.

Determine the Information in the Source File

The source geography data files must include a unique Source ID value for each row of data and Parent Source ID value
for the parent of that row of data. You include the data that you want to import into CX Sales and Fusion Service in a
source CSV file. A sample input CSV file for country as US is shown in this table.

RecordTypeCode PrimaryGeography CountryCode LevelNumber Sourceld ParentSourceld LanguageCode
0 United States us 1 1 <blank> us
1 California us 2 n 1 us
1 San Mateo us 3 m 1 us
1 Redwood City us 4 m m us
1 94065 us 5 mm m us

Here is a sample CSV file to import geographies with alternate name and code for country India:

RecordType  PrimaryGeogr. CountryCode LevelNumber Sourceld ParentSOurcel IdentifierType IdentifierSubT IdentifierValue
0 India IN 1 1
1 Karnataka IN 2 2 1
1 Bengaluru IN 3 3 2
2 Bengaluru IN 3 3 2 NAME Standard_ Bangalore
Name
1 Whitefield |IN 4 4 3
42
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RecordType PrimaryGeogr. CountryCode LevelNumber Sourceld
1 560066 IN 5 5
2 560066 IN 5 5

Note: Keep a note of the following:

Country Record (level Number 1) is always null.

You can't update geographies via import.

Geographies task page under Hierarchy Defined.

Chapter 3
Import Your Data

ParentSOurcel IdentifierType IdentifierSubT IdentifierValue

4
4 CODE ISO_ N
COUNTRY_
CODE

- The hierarchy is modeled in the CSV file using the Sourceld and ParentSourceld. The ParentSourceld for the

If defining an alternate name (recordTypecode = 2) for any level below the country (LevelNumber >1), ensure that
the Sourceld and ParentSourceld columns match the values for the original record respectively.

You can't add alternate names or alternate code of country via import. You can do so only via Ul.

Before adding a new alternate name, make sure that the alternate name doesn't exist with the same value
for any other geography name. You can check the existing values for alternate names in the Manage

- You can find the list of IdentifierSubTypes in Manage Geography Lookups page in the UL.

- PrimaryGeographyCodeType and PrimaryGeographyCode can't be added after PrimaryGeographyName is

You must arested stuiphld.(Tow s iteatiec betmbogetbad Alporetivedingahpottacid Raeatyesgshoiwm tdeligpe
table. and PrimaryGeographyCode from the Ul after the import is complete.

Attribute Name Value
RecordTypeCode 1
PrimaryGeographyName India

ORACLE

Description

The record type code that represents the intent
of the import data. The values are:

- 0 -indicates the geography that already
exists in the base table.

- 1-indicates the intent to create a new
geography.

- 2 -indicates the intent to add an alternate
identifying name or code to an existing
geography.

This is the primary geography name. This
will be marked as the primary name for the
Geography and also displayed in the Manage
Geographies Page.
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Attribute Name Value Description
CountryCode IN This indicates the Country Code for the country

for which you're importing data.

LevelNumber 2 The level number of the geography in the
hierarchy. For example, Country is at Level 1and
State (California) is at Level 2.

Sourceld 2 The source ID for the geography, along with
the parent source ID is used to identify the
geography parent and child relationship within
the source file data and the interface table data.

ParentSourceld 1 The parent source ID for the geography, along
with the source ID is used to identify the
geography's parent and child relationship with
records within the source file data. This should
be null for the country record, as Country is at
the top of the hierarchy.

IdentifierType Name The type of the identifier. It can be either Name
or Code.
IdentifierSubtype Standard_Name or Standard_Code The IdentifierSubtype can be Standard_Name

or Secondary_Name. The default value is
Standard_Name.

The valid Sub Types for Type "CODE" are FIPS_
CODE, GEO_CODE, ISO_COUNTRY_CODE,
PRIMARY_CITY, or UNKNOWN

IdentifierValue Bangalore The value of the identifier.

You can create an import activity, enter the import details, and schedule the import.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. C(lick Create Import Activity in the Manage Imports page.

3. Inthe Enter Import Options page, provide a name for the import activity, and select Geography from the
Object drop-down list.

Note: In the Advanced Options section, the option Enable High-Volume Import is selected by default. This
mode is designed to import millions of records at once.

4. Select the CSV file in the File Name field, and click Next.

5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the
mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit.

44
ORACLE



Oracle Fusion Cloud Customer Experience Chapter 3
Using Customer Data Management (CDM) Import Your Data

How do | import hierarchy data?

You can use the import management to create Hierarchy data.

The hierarchies supported are:

- Customer hierarchy
Dun and Bradstreet hierarchy
- Trading Community Party hierarchy
To import Hierarchy records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.

3. Create the import activity.

4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Hierarchy data into Oracle Applications Cloud, you need to populate a CSV file with your source data and
map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

Understand your options for uniquely identifying the records.
Ensure parent records exist before importing child records.

Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.

- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identifying an object record is the Internal ID. If you're identifying a record that

already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique
identifier Attributes with "ID" in the attribute name are typically internal IDs. Use this option only if you're updating
Hierarchies. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by
doing a transactional database query. Using an internal ID typically provides better performance and reduces the import
duration. For the Hierarchy object, the attributes are TreeStructureCode, TreeCode, TreeName, and TreeVersionName.
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Required Attributes and Validations for Hierarchy Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Hierarchy records, prerequisite setup tasks for the
attributes, and specific validations, if any, for Hierarchy import:

Attribute Description Data Type Data Length Prerequisite Setup Creating a Hierarchy
Task/ Import Record
Validations
TreeStructureCode Unique identifier fora = Varchar2 30 Seeded data needsto = Required
tree structure. be present.
TreeCode User defined Identifier Varchar2 30 No validation Required

for the tree code.

TreeName Name of the tree Varchar2 80 No validation Required

TreeVersionName Version Name of the Varchar2 80 No validation Required
tree

LangCode Indicates the code Varchar2 4 No validation Required

of the language

into which the
contents of the
translatable columns
are translated.

AsofDate The date that's used Date No validation Optional
to determine the
tree version when
you're updating a tree
version.

You can view the Hierarchy object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Note: You can find TreeStructureCode values from the lookup type PARTY_HIERARCHY_TYPE. FND_TREE_NODE
table holds the nodes of trees. Navigate to Setup and Maintenance > Search Task > Manage Standard Lookups
and search lookup type as PARTY_HIERARCHY_TYPE.

Create the Source CSV File

The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data
you want to import into Oracle Applications Cloud.
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You can either create a CSV file on your own or use templates available in preexisting mappings. To download a
template, do the following:

1. Goto Navigator > Tools > Import Management > Import Objects.
2. Select the Hierarchy object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input
to the activity.

To create an import activity, do the following:

1. Inthe Navigator, under Tools, click Import Management.

2. Inthe Manage Imports page, click Create Import Activity.

3. Inthe Create Import Activity: Enter Import Options page, provide a name for the import activity, and select
Hierarchy from the Object drop-down list.

In File Name, browse and upload the required .CSV file, and click Next.

In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note: Click Validate Data to validate the mapping of the source file for unmapped columns and to check for
data format issues.

v oA

6. Inthe Create Import Activity: Review and Submit page, click Submit.
Note: Initiate the Tree Flattening Service manually. Do one of the following:
o From the navigator, select Scheduled Processes. In the Schedule New Process dialog, search for
Party Hierarchy Generation and click OK.
o From Setup and Maintenance, search and run the Trading Community Party Hierarchy
Generation task.

Review the Import Results

You can review the import results by checking for the import activity in the Manage Import Activity page. A file import
activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as
follows:

1. In the Navigator, under Tools, click Import Management.

2. Onthe Manage Imports page, search for the import activity that you created using one of the search criteria,
such as status, name, object, and so on.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
The other valid values for the import activity status are Queued for import, Preparing data for import,
Importing data, Completed with errors, and Unsuccessful.

Note: On this page you can also quickly view the number and status of all active imports, completed imports, and
unsuccessful imports that have been submitted.
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Related Topics
« How do | import data?

 Potential Issues When Opening CSV Files in Excel

Import Your Household Data

You can use Import Management to create or update Household records.

To import Household records, perform the following tasks:

Map your source data to Oracle Applications Cloud object attributes.
Create source Comma Separated Values (.csv) file for import.

Create the import activity.

Review the import results.

PUWNA

How You Map Your Source Data to Target Object Attributes

To import your Household data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your
objects.

Understand your options for uniquely identifying the records.
Ensure parent records exist before importing child records.

Identify the target object attributes that are required in the .CSV file for a successful import.

Note: You can't set an attribute value to NULL in optimized import (standard import with the option Enable High-
Volume Import selected). However, when updating a record, you can change an attribute value from NOT NULL to
NULL

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.

- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the
import process to uniquely identify the records. The file import process uses the attribute values to automatically map
your source data to the target object attributes in Oracle Applications Cloud.
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- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the
internal ID of the record, a system-generated unique identifier Attributes with "ID" in the attribute name are
typically internal IDs. Use this option only if you're updating Households. You can determine the internal ID of
a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using
an internal ID typically provides better performance and reduces the import duration. For the Household object,
the attributes are OwnerPartyld and Partyld.

- Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique
identifier (attributes denoted with 'Number' and usually visible in the business object's Ul). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object's Ul, you can use the Number attribute to identify the record. For the Household object, the attribute
is PartyNumber.

Required Attributes and Validations for Household Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Household records, required attributes for updating
Household records, prerequisite setup tasks for the attributes, and specific validations, if any, for Household import:

Attribute

SourceSystem

SourceSystemRefert

ORACLE

Description Data Type

The code String 30
representing the

source system for

the household

The reference String 240

number or text
representing the
source system
unique ID for the
household

Data Length

Prerequisite Creating a
Setup Task/

Import

Validations

Identify the Optional

source system or
configure source
systems either

by using the
Manage Trading
Community Source
System task, or

by importing the
source system
information into
Oracle Applications
Cloud using the
Source System
Reference import
object.

Identify the Optional
source system or
configure source
systems either

by using the
Manage Trading
Community Source
System task, or

by importing the
source system
information into
Oracle Applications
Cloud using the
Source System

Updating

Household Record an Existing

Household Record

Required

Required
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Attribute Description Data Type Data Length Prerequisite Creating a Updating
Setup Task/ Household Record an Existing
Import Household Record
Validations

Reference import

object.
PartyNumber The public unique = String 30 Identify the party = Optional Required
identifier of the number value
party. by exporting the

Household object.

Partyld The public unique = Long 18 Identify the party ~ Optional Required
identifier of the number value
party by exporting the

Household object.

Name The name of the String 360 Identify the Required. Conditionally
household organization name required
of the resource by
navigating to the
Resource Directory.

OwnerPartyld Indicates the party = Long 18 None. Conditionally Conditionally
ID of the resource required. required
who's designated
as the owner of the
household

You can use the profile option ORA_HZ_IMPORT_MULTI_ADDRESS_TYPE to control how address types are entered. By
default this profile option is set to Yes, so you can enter multiple address types, during high-volume import of Account,
Contact, and Household objects . You can disable this profile option to improve the import performance. When you set
this profile option to No, you can enter only a single address type.

You can view the Household object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.
You can use the templates available in the Import Objects Ul page to create the source CSV file. To download a template:

1. Goto Navigator > Tools > Import Management > Import Objects.
2. Select the Household object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.
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Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Goto Navigator > Tools > Import Management > Import Queue.

2. Click Create Import Activity in the Manage Imports page.

3. Inthe Enter Import Options page, provide a name for the import activity, and select Household from the
Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.

2. Click All Imports and search for the import activity that you created earlier.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
« How do | import data?

- Potential Issues When Opening CSV Files in Excel

Import Your Hub Source System Reference Data

You can use Import Management to create or update Hub Source System Reference records.

To import Hub Source System Reference records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.

3. Create the import activity.

4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Hub Source System Reference data into Oracle Applications Cloud, you need to populate a CSV file with
your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:
Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.

Ensure prerequisite setups are done, if applicable.

Understand your options for uniquely identifying the records.
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- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

- Ensure that you don't insert duplicate addresses while importing, to avoid redundant data.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.

- You have all parent records in place before importing child records.

Select a Unique ldentifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's Ul. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new hub source system
reference records or are updating hub source system reference records that have source system reference data,
then provide the source system and source system reference values.

Required Attributes and Validations for Hub Source System Reference Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Hub Source
System Reference records, required attributes for updating Hub Source System Reference records, prerequisite setup
tasks for the attributes, and specific validations, if any, for Hub Source System Reference import:

Attribute Description Prerequisite Setup Task/ Creating a Hub Source Updating an Existing Hub
Import Validations System Reference Record Source System Reference
Record
OwnerEntityld Internal identifier or If provided, it has to be If you export data from Not required
primary key of a record that an active primary key the OSC table provided for
exists in the OSC table value from the table the OwnerEntityObject,
name provided for the provide the primary key
OwnerEntityObject. data to this attribute. If

you can't provide this

data, provide valid values
for the combination of
ExistingSourceSystem and
ExistingSourceSystemRefere

StartDateActive The date on which the hub  If provided, this date should Optional Optional
source system reference be earlier than the end
becomes valid. date. If you don't specify

a date, this defaults to the
current date.
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Attribute

EndDateActive

SourceSystem

Description

The date on which the hub
source system reference is
no longer valid.

Specifies the original
source system name

SourceSystemReferenceValu Specifies the original

OwnerEntityObject

SourceSystemReferenceld

ORACLE

source system reference
text or number in the
original source system

Specifies the OSC table in
which the record exists

Specifies the source system
reference identifier. This is
a primary key.

Prerequisite Setup Task/
Import Validations

Creating a Hub Source
System Reference Record

If provided, this date should Optional

be later than the start date.
If you don't specify a date,
this defaults to 12/31/4712.

This has to be present in
the HZ_ORIG_SYSTEMS_B
table with the status "A".

No validation

This has to be a valid
lookup code in the lookup
type ORA_ZCH_OWNER_
ENTITY_OBJECT.

If provided, this has to be

an active primary key value

from the table HZ_ORIG_
SYS_REFERENCES.

Provide a valid value.

Provide a valid value.

Provide a valid value.

Not required
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Updating an Existing Hub
Source System Reference
Record

Optional

Conditionally required.

Provide one of the
following:

- SourceSystemReferenceld

- A combination of
SourceSystem,
SourceSystemReference
and
OwnerEntityObject

Conditionally required.

Provide one of the
following:

- SourceSystemReferenceld

- A combination of
SourceSystem,
SourceSystemReference
and
OwnerEntityObject

Conditionally required.

Provide one of the
following:

- SourceSystemReferenceld

- A combination of
SourceSystem,
SourceSystemReference
and
OwnerEntityObject

Conditionally required.

Provide one of the
following:

- SourceSystemReferenceld

- A combination of
SourceSystem,
SourceSystemReference
and
OwnerEntityObject
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Attribute Description Prerequisite Setup Task/

Import Validations

ExistingSourceSystem Specifies the original
source system name of
data that exists in Oracle

Engagement Cloud

This has to be present in
the HZ_ORIG_SYSTEMS_B
table with status "A".

ExistingSourceSystemRefere Specifies the original No validation
source system reference of
data that exists in Oracle

Engagement Cloud

Creating a Hub Source
System Reference Record

If you can't provide

the OwnerEntitylID,

provide a combination of
ExistingSourceSystem and
ExistingSourceSystemRefere
values. Export the

Source System Reference
repository to obtain this
value.

If you can't provide

the OwnerEntityID,

provide a combination of
ExistingSourceSystem and
ExistingSourceSystemRefere
values. Export the

Source System Reference
repository to obtain this
value.
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Updating an Existing Hub
Source System Reference
Record

Not required

Not required

You can view the Hub Source System Reference object along with all its child objects and attributes in the Manage
Import Objects page of the Import Management flow. You can find attribute information like type, length, description,

and so on, on this page.

Note: Alookup type ORA_ZCH_OWNER_ENTITY_OBJECT is now available. You can now use this lookup without
specifying the underlying physical tables, when providing input data in the CSV import file. When you migrate from
File-Based Data Import to Optimized or Import Management, the underlying physical tables are secured to external

parties.

Create the Source CSV File

You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects Ul page to create the source CSV file. To download a template:

1. Goto Navigator > Tools > Import Management > Import Objects.
2. Select the Hub Source System Reference object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues

When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Goto Navigator > Tools > Import Management > Import Queue.

2. C(lick Create Import Activity in the Manage Imports page.

ORACLE
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3. Inthe Enter Import Options page, provide a name for the import activity, and select Hub Source System
Reference from the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Goto Navigator > Tools > Import Management > Import Queue.

2. Click All Imports and search for the import activity that you created earlier.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
« How do | import data?

- Potential Issues When Opening CSV Files in Excel
» How You Use Alternate Keys to Import Records

How do | import organization data?

You can use Import Management to create or update Organization records.

To import Organization records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.

3. Create the import activity.

4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Organization data into Oracle Applications Cloud, you need to populate a CSV file with your source data
and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
Ensure prerequisite setups are done, if applicable.

Understand your options for uniquely identifying the records.

Ensure parent records exist before importing child records.

Identify the target object attributes that are required in the CSV file for a successful import.

Ensure that you don't insert duplicate addresses while importing, to avoid redundant data.
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Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.

- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public
unique identifier. These are, usually, denoted with 'Number' and visible in the business object's Ul. PUID
attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic
"How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new organizations or are
updating organizations that have source system reference data, then provide the source system and source
system reference values.

Required Attributes and Validations for Organization Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure
that you provide valid values for the attributes. This table lists the required attributes for importing new Organization
records, required attributes for updating Organization records, prerequisite setup tasks for the attributes, and specific
validations, if any, for Organization import:

Attribute Description Prerequisite Setup Task/ Creating an Organization = Updating an Existing
Import Validations Record Organization Record
SourceSystem The original source system = Know the source system. Conditionally Required Conditionally Required
name
To view source systems, To identify an organization = To identify an organization
use the Manage Trading record, use one of these: record, use one of these:
Community Source System
task. - Combination of - Combination of
SourceSystem and SourceSystem and
SourceSystemReferenc SourceSystemReferenceValue
- PartyNumber - PartyNumber
SourceSystemReferenceValu The identifier in the original Know the source system Conditionally Required Conditionally Required
source system reference value.
To identify an organization = To identify an organization
To view the source systems = record, use one of these: record, use one of these:
reference, use the Manage
Trading Community Source . Combination of . Combination of
System task. SourceSystem and SourceSystem and
SourceSystemReferenc SourceSystemReferenceValue
- PartyNumber - PartyNumber
PartyNumber The public unique identifier Know party number. Conditionally Required Conditionally Required
of the party.
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Attribute

OrganizationName

PartyUsageCode

CleanlinessScore

CompletenessScore

DataConfidenceScore

Duplicatelndicator

DuplicateScore

EnquiryDuns

ORACLE

Description

The name of the party of
the Organization party

type.

Specifies the party
usage code to which the
organization is associated

The overall score for
the account or contact
record for the category
Cleanliness

The overall score for
the account or contact
record for the category
Completeness

The overall data confidence
score that indicates the
level of data quality for a
record

Signifies the duplicate
status of the record that's
determined as follows:

- Anull value indicates
that the record isn't
a duplicate or hasn't
been evaluated.

- Therecord can also
have one of 2 other
values - DUPE (record
is a duplicate) or LINK
(record is linked to
another record).

The overall score for the
account or contact record
for the category Duplicate

A unique identifier used
to query the Dun and
Bradstreet data. If the
location is a branch,

in some countries the
"DUNS" number of the
headquarters is used to
run the query. Otherwise,

Prerequisite Setup Task/
Import Validations

To obtain a list of all party
IDs and party numbers,
export the Party object.

The organization names
are listed in the Resource
Directory.

This should be an active
value in the HZ_PARTY_
USAGES_B table.

No validation

No validation

No validation

No validation

No validation

No validation

Creating an Organization
Record

Required

Required

Optional

Optional

Optional

Optional

Optional

Optional
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Updating an Existing
Organization Record

Conditionally Required

Not required

Optional

Optional

Optional

Optional

Optional

Optional
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Attribute

EnrichmentScore

LastScoreUpdateDate

RecencyScore

ThirdPartyFlag

ValidatedFlag

ValidityScore

Description

the "DUNS" number is
considered.

The overall score for
the account or contact
record for the category
Enrichment

The date and time at which
this record was updated by
the source system in the
last update source system
column

The overall score for the
account or contact record
for the category Recency

Prerequisite Setup Task/
Import Validations

No validation

No validation

No validation

This option tracks if a party  No validation

has a direct relationship
with the organization
using Oracle receivables
or through a third party
supplier. The value Y
denotes third party
relationship, while the
value N denotes direct
relationship. If Oracle
Service is installed, the
Third Party field in the
Customers window is
mandatory.

Indicates if the party was
validated. The value Y
denotes a validated party,

while the value N denotes a

party that's not validated.

The overall score for the
account or contact record
for the category Validity

No validation

No validation

Creating an Organization
Record

Optional

Optional

Optional

Optional

Optional

Optional
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Updating an Existing
Organization Record

Optional

Optional

Optional

Optional

Optional

Optional

You can view the Organization object along with all its child objects and attributes in the Manage Import Objects page of
the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects Ul page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.

ORACLE
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2. Select the Organization object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Goto Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.

3. Inthe Enter Import Options page, provide a name for the import activity, and select Organization from the
Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Goto Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
« How do | import data?

- Potential Issues When Opening CSV Files in Excel
« How You Use Alternate Keys to Import Records

How do | import person data?

You can use import management to create or update Person data.

You can import Person records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know
where to insert each of the information bits.

2. Create the source CSV file with the Person data you want to import.
Kick off an import activity.
4. Check the import results to know if the import went well.

W
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How You Map Your Source Data to Target Object Attributes
You import Person data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to
target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match
each column from the source file to an attribute in the Person import object.

Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
Know how you can uniquely identify the records.

- Check the target object attributes required in the CSV file for a successful import.
Ensure that you don't insert duplicate Person while importing, to avoid redundant data.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

Public unique identifiers: You can pass the PUID when creating Person records. If the PUID isn't passed, it

will be auto generated. You can optionally provide the PUID when creating Person records. If you're updating
records, then you can provide an easily understandable public unique identifier. These are, usually, denoted
with 'Number' and visible in the business object's Ul. PUID attributes are usually named <object> Number. If
you're updating a record with a Number attribute, then use the Number attribute to identify the record. For
more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records"
in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source
system reference is a unique identifier within the external system. If you're importing new Persons or are
updating Persons that have source system reference data, then provide the source system and source system
reference values.

Required Attributes and Validations for Person Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

This table lists the required attributes for Person records, prerequisite setup tasks and specific validations, if any:

Attribute Description Prerequisite Setup Task/ Creating a Personrecord  Updating an Existing
Import Validations Person record
Partyld The internal ID for the When updating the record, =~ Not required Conditionally required.
Person type party this should already exist.

To identify a person record,
use one of these:
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Attribute

Country

AddressNumber

OrganizationPartyNumber

DeceasedFlag

PartyNumber

FirstName

MiddleName

LastName

ORACLE

Description

The country code of the
postal address

The internal unique
identifier that's internally
generated when creating an
address

The party number of the
organization to which the
person is related

The option that indicates
whether the person
imported is deceased

The unique identifier of the
party

The first name of the
person

The middle name of the
person

The last name of the
person

Prerequisite Setup Task/
Import Validations

Identify valid country
codes using the Setup and
Maintenance, Manage
Territories task.

No validation

This should already exist.

YorN

The default value is N.

Know the party number. To
obtain a list of all party IDs
and party numbers, export
the Person object.

No validation

No validation

No validation

Creating a Person record

Conditionally required

A value is required only
when you're creating an
address for the Person
record.

This is a PUID for Address.

If a value is passed, it will be

imported. Otherwise, it will
be auto-generated.

Not required

Not required

This is a PUID for Person. If
a value is passed, it will be
imported. Otherwise, it will
be auto-generated.

Required. A value is
required for the FirstName,

MiddleName, or LastName.

Required. A value is
required for the FirstName,

MiddleName, or LastName.

Required. A value is
required for the FirstName,

MiddleName, or LastName.
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Updating an Existing
Person record

- Combination of

SourceSystem and
SourceSystemReferenceValue

- PartyNumber
- Partyld

The attribute is neither
required nor conditionally
required.

Pass the AddressNumber.

Not required

Not required

Conditionally required

To identify a person record,
use one of these:

- Combination of
SourceSystem and
SourceSystemReferenceValue

- PartyNumber
- Partyld

Not required

Not required

Not required
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Attribute Description

PartyUsageCode Specifies the party usage
code to which the person is
associated

SourceSystem The original source system
name

SourceSystemReferenceValu The identifier in the original
source system

Prerequisite Setup Task/
Import Validations

Select one of the following
values:

- EXTERNAL_PAYEE
- CONTACT

- PAYMENT_ISSUING_
AUTHORITY

- PARTY_OF_INTEREST
- VIRTUAL_ASSISTANT
- FS_TECH

You can assign a limited
set of unrestricted party
usages through the Person
import object. To create
persons of other types, use
the specific import objects
created for those purposes.

Know the source system.
To view source systems,
use the Manage Trading
Community Source System
task.

Know the source system
reference value. To view
source system reference,
use the Manage Trading
Community Source System
task.

Chapter 3
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Creating a Personrecord  Updating an Existing
Person record

Required Not required

Conditionally required Conditionally required

To identify a person record, To identify a person record,

use one of these: use one of these:

- Combination of - Combination of
SourceSystem and SourceSystem and
SourceSystemReferenc SourceSystemReferenceValue

- PartyNumber - PartyNumber

- Partyld
Conditionally required Conditionally required

To identify a person record, To identify a person record,

use one of these: use one of these:

- Combination of - Combination of
SourceSystem and SourceSystem and
SourceSystemReferenc SourceSystemReferenceValue

- PartyNumber - PartyNumber

- Partyld

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Person object. The
page also lists attribute information like type, length, description, and so on.

Create the Source CSV File

You include the data that you want to import into CX Sales and Fusion Service in a source CSV file.

You can use the templates available in the Import Objects Ul page to create the source CSV file. To download a template:

1. Goto Navigator > Tools > Import Management > Import Objects.
2. Select the Person object in the table and click Download.

ORACLE
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You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues
When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the Person information. To create an import
activity:

1. Goto Navigator > Tools > Import Management > Import Queue.
2. Onthe Manage Imports page, click Create Import Activity.

3. Inthe Create Import Activity: Enter Import Options page, provide a name for the import activity, and select
Person from the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review
and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and
unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
You can drill down on the import activity to go to the Import Status page which provides the status details of
the import activity.

Related Topics
« How You Use Alternate Keys to Import Records

 Potential Issues When Opening CSV Files in Excel
« Why can't | see the people | just imported?
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4 Export Your Data

About Export Management

You can use Export Management to move data out of Oracle Applications Cloud in the form of CSV files.

To export data, you start by creating an export activity. As part of the export activity, you select a parent object and its
relevant child objects. You also must define filters on these objects to specify the records you want to export.

Scenarios for Export

You may want to export data in the following scenarios:

- You might want to move data out of Oracle Applications Cloud into another application. To perform this activity
you have to export the data into a ZIP file and import the exported data into the target application.

« You might want to format the data as per your requirements.

- You may want to identify the unique identifiers of an object such as Party ID or Party Number. You can use this
information to update an object record.

You can schedule an export either immediately or at a future date. If you schedule it for a future date, then provide the
start date and time while defining the export activity.

Note: Currently recurring export isn't supported. You can however use the Export REST resource to schedule
recurring export activities through REST API. For more information see REST API for CX Sales and Fusion Service.

Using Export Filters

You can define the conditions for the records to export in the export filter. The exported data sets contain only those
records that match the specified filter criteria on the parent/child object. It is recommended that you use multiple filters
to reduce the number of records to export.

You can create a filter by navigating to Tools > Export Management > Export Objects and clicking on the Display
Name link for the export object. On the Manage Filters page, click the Create Filter button to create a filter. On the
Script Edit page, enter the filter name, filter parameters, and the order by clause if required. You can reuse an existing
filter by selecting a value from the Existing Filters drop-down list. Once you're done with your changes, click Validate
Script and then click Save and Close to save your new filter. You can also create a filter while creating an export activity,
on the Map Fields page.

You can delete a filter on the Manage Filters page, by clicking the delete icon for your filter under the Delete Filter
column. Note that you can delete only the filters created by you and those that aren't used in an active export job.

Split Export Data

There are no limits to file size for exporting data. However, you can split the exported data set based on a split size.
You can enable split from the Ul by checking the Enable Split check box in the set up page and select the split size. The
default is 100k. You can specify the split size in multiples of 100k records, ranging from 100k to 1000k. Each CSV file can
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contain a maximum of 50k records. Hence, the exported data will be split into two CSV files after 50k records. The CSV
files will then be zipped together and exported.

For example, if an export job fetches 300k records and split is enabled with a split size of 200k, then 2 export ZIP files
will be generated. The first one will contain a total of 200k records which will be divided into 4 CSV files each with 50k
records. The second ZIP file will contain a total of 100k records which will be divided into 2 CSV files each with 50k
records.

Related Topics
- Export Data

« How You Monitor Export Activity

Export Data

You can export your object data using the Export Management option from the Tools work area. This topic is your guide
to exporting data.

You can find the list of objects supported in Export Management in Manage Export Objects
To export data:
1. Click Tools > Export Management.

2. Onthe Manage Exports page, click the Create Export Activity button.
3. Onthe Enter Export Options page, enter values for each of the following fields:

Field Description of the value
Name The name of the export activity.
Object The object to export. You must select the parent or child object from the drop-down list.

If you can't find an object in the drop-down list, then click the Search link. In the Search and
Select dialog box, enter the object name in the Object text box and click the Search button.
Select your object from the result list and click OK.

You can also use the advanced search option by clicking the Advanced button. Here you can
search based on various filter criteria such as object name, attachment supported, creation
date, and so on.
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Field Description of the value

Note:

If the object you're exporting isn't listed then verify if you have the roles and privileges
required to export the object. For information on the roles, see the topic Roles Required for
Import and Export Management referenced in the Related Topics section.

The object must not include any field with display name length greater than 120 characters.
Your export job may fail if it includes a field with display name length greater than 120

characters.
Description The optional description of the export activity.
File Name The name of the export file to generate in ZIP format. This field is populated based on the

object and date time stamp.

Export Attachments Select to export the attachments related to the object. This option is enabled only if the
selected object supports attachments.

4. Optionally to set additional export configurations, click the Advanced Options section. Here you can configure
settings in the Output File, Export Options, or Create Schedule sections.

o Following are the options in the Output File and Export Options regions:

Option Description Default Value

Delimiter If your file doesn't use a comma to Comma
separate values, then select the correct
delimiter in the Delimiter drop-down list.
Possible values are:

- Caret Symbol

- Closing Curly Bracket

- Closing Parenthesis

- Closing Square Bracket
- Colon

- Comma

- Exclamatory Mark

- Minus

- Opening Curly Bracket
- Opening Parenthesis

- Opening Square Bracket
- Pipe Symbol

- Plus
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Option Description Default Value

- Question Mark
- Semi-Colon

- Star Symbol

- Tilde Symbol

Escape Special Characters If selected, then RFC4180 format is used, = Deselected
and quotes are escaped with another set
of quotes.

Decimal Separator The decimal separator used in your Period
export file. Possible values are Comma
and Period.

Date Format The format of the date fields in your file. = US - MM/DD/YYYY
Possible values are:

- EU-YYYY/MM/DD

- 1SO 8601- YYYY-MM-DD
- UK/Canada - DD/MM/YYYY
- US-MM/DD/YYYY

Time Stamp Format The format of time fields in your file. US - MM/DD/YYYY hh:mm:ss PM
Possible values are:

- Canada - DD/MM/YYYY hh:mm:ss
PM

- EU-YYYY/MM/DD 24:mm: ss

- 1SO 8601-YYYY-MM-
DDThh:mm:ss sss+/-hh:mm

- UK-DD/MM/YYYY 24:mm:ss
- US-MM/DD/YYYY hh:mm:ss PM

File Encoding The format in which the characters within  Unicode - UTF - 8
your source file are encoded. Possible
values are:

- Chinese Simplified - GB, CP936

- Chinese Traditional - CP950

- Eastern European - Win, CP1250

- Greek - MS Windows, CP1253

- Japanese - Shift-JIS, CP932

- Unicode - UTF -8

- Unicode - UTF - 16

- Unicode - UTF - 16BE, Mac, Unix

- Unicode - UTF - 16LE, MS Windows
- Western European - Win, CP1252
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Option

End of Line

Quote Character

Language Independent Header

Notification Email

Enable Split

ORACLE

Description

The character used to indicate end of line
in the export file. Possible values are:

- Carriage Return
- Carriage Return and Line Feed

- Line Feed

The character used to indicate a quote.
This field is read-only.

Select to export column headers. If you're
modifying the exported data manually,
then exporting column headers help in
automatic mapping during the reimport
process.

The email to send export-processing
notifications. The user submitting the
export receives an email notification
automatically. You use this field to specify
any additional recipients. If you want

to have more than one email recipient,
separate the email addresses with a
comma or semicolon. You can also
specify a mailing list address so that

a large number of recipients can be
notified. If you don't want to receive the
notification, then set the profile option

ORA_ZCA_IMPEXP_ENABLE_EMAIL_NOTI

to 'N' at user level.

Select to split the export data set based
on a specified record count. On selecting
this check box, you can see the Split Size
drop-down list, with a default value of
100k. You can specify the split size in
multiples of 100k records, ranging from
100k to 1000k.

The exported data is split into multiple
CSV files, and each file has a maximum
of 50K records. You can further split the
exported data into multiple ZIP files,
based on the specified split size. For
example, if your export job retrieves 300k
records and split is enabled with a split
size of 200k, then 2 export ZIP files are

Chapter 4
Export Your Data

Default Value

Line Feed

N/A

N/A

N/A

N/A
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Option Description Default Value

generated. The first ZIP file contains 200k
records which is divided into 4 CSV files
each with 50k records. The second ZIP
file contains 100k records which is then
divided into 2 CSV files each with 50k
records.

o Inthe Create Schedule region, you can schedule the export to run either immediately or at a future date.
If you select a future date, then provide the date and time to start the export.

You can save the Advanced Options for subsequent reuse by clicking on the Save advance options link in the UL.
The options will be retained till you click on the Reset link and reset the options to application defaults.

Note: All fields except Schedule Mode and Schedule start time will be saved.

5. Click Next. On the Map Fields page you can see the exportable object, its child objects, and the associated
attributes. The Export Mapping drop-down list shows the maps that were used in earlier export jobs. You can
select an existing mapping from the drop-down list and click Apply.

You can save your export maps for future use by clicking on the pencil icon (Save As) in the Create Export
Activity page. You can also mark your maps as private by checking the Private Map check box. Private maps
can only be viewed and reused by the user who created and saved the map. Maps marked as private won't get
purged by the daily purge job.

Note: Your maps will only be saved once the job is completed.

To select and apply your saved maps, check the My Maps check box, select the required map from the Export
Mapping drop down and click Apply in the Create Export Activity page.

6. You can select the child objects to export by selecting the Enabled check box. Selecting the Enabled check box
for a child object displays the associated attributes in the Available Fields section. You can select the attributes
to export by double-clicking the attribute in the Available Fields list. Alternatively, you can move the attribute
from Available Fields list to the Selected Fields list. If you select any formula fields for export, it might impact
your export performance.

7. You must provide a filter criterion for at least the top-level object. To filter the records to export using
conditions, click the Filter Name icon. On the Filter Name dialog box, you can create the filter for the export
attributes using the operators AND, OR, >, <, =, and !=. On the Fields tab select the attribute and click the Insert
button. In the Script Edit window, provide the filter conditions for the selected attribute. After creating the filter
criteria script, click Validate Script. Click Save and Close to save the filter.

Note: You must use GeographyCode="TM' filter to export the Zone Hierarchies. To export both Zone
Hierarchy information and Geography Country Information, you need to use filter GeographyCode="TM' Or
CountryCode="DE'. For more information see How to Use Export Management to Export Territory Geography
Zone Hierarchies?

8. C(lick Next. On the Review and Submit page, review the export activity configuration. If you want to change
any configuration, then click the Back button. Submit to activate the export activity. After the export activity
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completes, clicking the My Completed Exports infotile shows your export status. Click the ZIP file link in the
Exported Data File column to download the exported file.

You can cancel the export by clicking the Cancel icon in the Manage Exports page when the job status is
Paused, Queued for Export, Preparing data to Export, or Exporting Data.

Note: The cancel job option is available for the logged in user and the hierarchy user only when the profile
option ORA_ZCA_IMPEXP_RESTRICT_USERACCESS is enabled.

Note: CSV String Escape: By default, the escape character is a " (double quote) for CSV-formatted files. If a value
contains a comma, a newline character, or a double quote then the string must be enclosed in double quotes. For
example: "Newline char in this field \n". A double quote must be escaped with another double quote. For example:
"The double quote character

nn

is offensive.".

Note: By default, you can't view the Personally Identifiable Information(PIl) such as mobile numbers in the exported

data. To view this information, follow these steps:

1. Navigate to Tools > Security Console.

2. Search for the role ORA_MOT_QUOTA_EXPORT_MANAGEMENT_DUTY.

3. Edit role and click the Data Security Policies link.

4. C(lick the Create Data Security Policy button, and add a new data security policy on the database resource

Trading Community Contact Point with the following details.

o Policy Name: Custom Grant on Person Contact and Mobile Phone Data (you can provide any name)
o Database Resource: HZ_CONTACT_POINTS
o Data Set: All Values
o Actions: View Trading Community Person Contact, View Trading Community Mobile Phone Number

5. Click OK to save and navigate to Summary step to review and save changes.

Related Topics

« How You Monitor Export Activity

Export Queues

« What are the roles required to import or export data?

Export Queues

This topic describes the different infotiles displayed on the Manage Exports page of the Export Queue tab.
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Export Queue
The following infotiles are displayed on the Manage Exports page:

- All Exports: This infotile displays the count of active, completed, and unsuccessful exports submitted by all
users. Click to see the exports created by all the users and in all possible statuses.

- Active Exports: This infotile displays the count of exports submitted by all users that are either in progress or in
queued status. Click to see the active exports created by all the users.

- My Completed Exports: This infotile displays the count of exports submitted by the current user that are either
successful or failed with warnings or errors. Click to see the completed exports created by the current user.

- Unsuccessful Exports: This infotile displays the count of unsuccessful exports submitted by all users. Click to
see the unsuccessful exports created by all users.

Note: The export activity records appear in the queue for thirty days, after which they're removed. The exported ZIP
files and diagnostic files are removed from the server on the 7th day of the export.

Export Details

You can view more details about the exports on clicking the infotiles. The following details about the export are
displayed:

Column Description

Name The name of the export job. Click to go to the Export Status page.

Object The object exported.

Status The status of the export job. For more information about the statuses, see the topic How You Monitor

Export Activity in the related topics section.

Start Time The start date and time of the export.

End Time The end date and time of the export.

Submitted By The user who submitted the export.

Exported data file The link to download the exported data file in ZIP format.

You can filter the export using any of the columns in the preceding table. You must select the filter value from the
Search drop-down list and enter the criteria in the adjacent text box.

Related Topics
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Manage Export Objects

Export objects correlate with tables in Oracle Applications Cloud. Understand export objects and their attributes to
manage the data that you want to export.

Supported Objects

You can export these objects and their child objects using Export Management:

- Access Groups
« Account
- Action
- Action Plan
- Activity
+ Asset
- Assignment Rule Candidate
« Assignment Rule Condition
- Assignment Rule
- Assignment Rule Set
Billing Contract Milestone
Business Plan
Business Plan Goals
Business Plan Initiatives
- Campaign
- Case
- Compensation Plan
- Compensation Plan Component
- Compensation Plans Flex
- Competitor
- Condition Attachment
- Condition of Approval Comment
- Condition of Approval Transaction
- Condition Comply Period
- Contact
- Contract
- Contests
Deal Registration
Duplicate Resolution Request
- Geographies*
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- Geography Zones

- Goals

- Household

- HRHelpDeskRequest

- Hub Source System Reference

- Inbound Message

- Incentive Compensation Performance Measure
- Incentive Participant

- Incentive Participant Goal

- Incentive Participant Role Assignments
- Interaction

- Interaction Data

- Interaction Participant

- KPI

- Linked Party

- MDF Budget

- MDF Claim

- MDF Request

- Nonduplicate

- Note

- Objective

- Opportunity

- Organization

- Partner

- Partner Programs

- Partner Rollups

- Performance Measure Flex

- Performance Measure Rate Dimensional Input
- Performance Measure Score Card

« Plan Component

- Plan Component Flex

- Plan Component Performance Measure
« Plan Component Rate Dimensional Input
« Plan Component Rate Table

- Price Book Header

« Product

« Product Group

« Program Enroliments

« Promotion
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+ Queue
Relationship
Resolution Link
Resolution Request
Resource
Resource Capacity

- Sales Forecast Quota

- Sales Lead

- Sales Orders

- Sales Territory

- Sales Territory Quota

- Self-Service Role

- Service Profile
Service Profile Contact

- Service Request

- Standard Lookups

- Standard Text

- Standard Text Folder

- Standard Text User Variable

« Subscription

- Template

- Territory Geographies. For more information see Export Territory Geography Zone Hierarchies? (Doc ID
2853475.1) on My Oracle Support.

- Transaction
- Trees
- Wrap Up

Note: Legal Note: By exporting the Geographies data from the Oracle environment to Your environment, You agree
that (a) Oracle is granting You only a restricted right to download the exported Geographies data specifically for Your
use with the Oracle Fusion services; (b) the Geographies data may not be used, transferred, or uploaded for any other
purposes; and (c) except for the restricted right granted in (a), all provisions of the Oracle Cloud Services Agreement
(CSA) or Schedule C, as applicable to You, remain in full force and effect, including specifically section 3.4 thereof.

Export Object Details

Click Tools > Export Management > Export Objects. To see the details of an export object, select it on the Export
Object Details page. Here are the details that you see about each exportable object:

Column Description

Display Name The object as it's called in the user interface.
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Column Description
Language Independent Code The internal name of the object.
Parent Object The parent object of the selected object. If there are multiple parents for an object, they're shown

separated by commas.

View Hierarchy Clicking on the View Hierarchy icon shows the hierarchy between the parent and child objects in a
graphical format.

User Key The attribute or the group of attributes that's used to uniquely identify a record.

Required Attributes The attribute or the group of attributes for which values are required to create a record. These can't be
NULL when updating a record.

Target Attributes

Here are the details that you see for each target attribute.

Column Description

Display Name Name of the target attribute in the user interface.
Attribute Name Internal or field name of the attribute.

Required Indicates whether the attribute is mandatory or not.
Default Value The default value for the attribute, if any.

Type Data type of the target attribute.

Length Maximum allowed length for the target attribute values.
Description A short description of the target attribute.

Export Inactive and Merged Data

You can export inactive and merged accounts, contacts, households, organizations, and persons using export
management. You don't need to rely on data model queries to fetch the deleted or merged records.

Note: To export inactive records, you need to explicitly add the condition to the criteria, or else only the active records
will be exported. For example, | for Inactive and M for merged. All associated child records (active or inactive) will be
exported irrespective of their status, if no criteria is added.
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How You Monitor Export Activity

This topic explains how to monitor export activities and view their statuses.

View the Export Status

On the Manage Exports page, click the export activity name link to see additional information about the export activity.
The Export Status page contains the following sections:
- Status Bar
Details

Export Attachments

The Export Status Bar

The status bar shows the progress of the export activity in a graphical format. It shows the following stages during the
export process:

1. Queued for Export: The export request is queued for processing, and is waiting to begin execution.

2. Preparing data for Export: The data are loaded in the temporary staging table for further processing.

3. Exporting data: The data from the target objects are loaded into the export files (CSV).

4. Completing export activity: The export data have been loaded in the source files, and cleanup tasks, such as the
generation of log files, are in progress.

5. Completed with errors: The export activity has completed with errors.

6. Completed with warnings: The export activity has completed with warnings.

7. Unsuccessful: The export activity was unsuccessful.

Activity and Record Details

The Activity Details section shows the name of the export activity, export job identifier, object exported, and the name
of user who submitted the export. The section on date and time displays the start and end times, and the time taken to
complete the export activity.

The Record Details section displays the number of records estimated, number of records exported, and the number of
records with errors.

The object must not include any field with display name length greater than 120 characters. Your export job may fail if it
includes a field with display name length greater than 120 characters.

Export Attachments

You can generate the diagnostics and log files from the Action menu. The Export Attachments section displays the
list of files associated with this export activity in tabular format. The Actions column in this section lets you either
download the file or view more details. These files include the diagnostics and log files generated.

Note: The export data is stored on the UCM server for some time before it's purged. The duration after which export
data should be purged is set in the profile option ZCA_EXPORT_UCM_PURGE_DURATION. The default value is 30.
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How You Monitor Export Activities Using REST APIs

This topic explains how to receive completion notification through REST resource and also avoid the need to constantly
keep checking the export status.

To receive export completion notification through REST service, you must define the REST service endpoint in
Application Composer. You can configure and register your REST endpoint to receive notifications whenever your
export job completes.

Register an External REST Endpoint in Application Composer

To register an endpoint for notification:

1. Create and enter into a sandbox by navigating to Configuration > Sandboxes > Create Sandbox.
Navigate to Configuration > Application Composer > Web Services. Note that this option is available only
when you're inside the sand box.

3. You can edit the existing endpoints, or create a new endpoint such as Externalkndpointl, by clicking the Create
icon.

4. Enter the name of the endpoint and the URL, and select the authentication scheme. For example, your URL can
be in the format https://servername/ic/api/integration/v1/connections/cbveTest.

5. Select and configure the POST method by clicking the check box for POST. Currently only POST method is
supported for the Export Notification feature.

6. Select and provide the code samples for the request and response payloads. Following is the sample for
request and response payloads:

{

"items": [],
"count": O,
"hasMore": false,

"limit": 25,

"offset": 0,

"links": [{

"rel": "self",

"href": "https://servername/ic/api/integration/vl/connections/cbveTest",
"name": "ExternalEndPointl",

"kind": "collection"

H
}
7. Click Save and Close.
8. After making the changes, publish the sandbox to commit your changes.

Validate the Endpoint

You can validate the REST endpoint to ensure that your REST web service configuration in Web Services in Application
Composer is correct and the export process can call the endpoint successfully. To validate your REST endpoint and set
an endpoint as default:

1. Navigate to Tools > Export Management > Export Configuration > REST Notification.
Here, select REST Notification as the notification type, and select the endpoint you registered from the
Notification Endpoint drop-down list. In our example, select ExternalEndPointl.

3. To make this connection as the default one while creating export jobs, select the Set as default check box.
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4. To validate, click the Payload Details section, and click the Validate REST Endpoint button. If your endpoint is
valid, then you see one of the following response statuses in the Response text box:
o 200
o 201
o 202
o 204

Any other response status indicates that the endpoint is invalid.

Create the Export Activity and Monitor the Status

1. Navigate to Tools > Export Management > Create Export Activity.

2. Create the export activity, enter the name, and select the object to export.

3. Click the Advanced Options section and select the notification endpoint ExternalEndpoint1 from the
Notification Endpoint drop-down list. If you don't want to receive the notification, then select a blank value in
the drop-down list.

4. Click Next and select the attributes to export on the Map Fields page. Create a filter for at least the top-level
object, and click Next. For more information on creating an export activity, see the topic Export Data.

5. Review your export configurations and submit the export job. Once you submit the export, you can monitor the
status by accessing the configured endpoint.

6. Alternatively, you can verify whether the notification is submitted by downloading the log files. The last entry in
the file indicates the status of notification.

Export Notification in REST

You can use the RestNotification attribute to specify your notification endpoint while creating your export activity using
REST. For example, you can use the following sample payload to create your export activity:

{

"Name": "Account_Export",

"ExportObject": "Account",

"ExportFilterCriteria": "OrganizationName IS NOT NULL",
"ExportFileName": "Account.zip",

"Activate": "YES",

"RestNotification": "ExternalEndPointl"

}}

The following table describes the behavior when you don't provide the REST notification endpoint.

REST Notification Value Endpoint Used for Export Job

null Default endpoint is selected
REST notification not passed

Default endpoint is selected

No REST endpoint is selected

ORACLE

REST Notification Behavior

REST notification is sent to the default REST
endpoint.

REST notification is sent to the default REST
endpoint.

No REST notification is sent.
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This topic explains how to export and download the object attachments to your local directory. Here is a list of objects

that support exporting of attachments:

You can export the attachments in two steps:

1.

Export the Object Records and the Attachment Information

To export the object records and the attachment information:

1

- Account

- Activity

» Assets

- Competitor
- Contact

- ConversationMessage

DealRegistration
Household
HRHelpDeskRequest

InternalServiceRequest

« Opportunity

Partner
PartnerContact
Product
ProductGroup

- ServiceRequest

- WrapUp

Export the object records and the attachment information based on the selected search criteria of the object.
2. Download the attachment files from the content management server using the External Data Loader Client tool.

Click Tools > Export Management.
. On the Manage Exports page, click the Create Export Activity button.

On the Enter Export Options page, enter the export activity information such as export name, export object,

and the file name. For more information on exporting data, see the topic Export Data.

Select the Export attachment check box to enable exporting the object attachments. You can optionally enter

the advanced configuration options. Click Next.

ORACLE
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5.

On the Map Fields page, you can select the attributes to export by dragging them from the Available Fields
section to the Selected Fields section. The Export Mapping drop-down list shows the maps used in earlier
export jobs. You can select an existing mapping from the drop-down list and click Apply. You can select the
Enabled check box to export the child object attributes.

You must provide a filter criterion for at least the top-level object. To filter the records to export using
conditions, click the Filter Name icon and enter the filter criteria for your object records. Click Next. On the
Review and Submit page, review the export activity configuration and click Submit.

After the export activity completes, clicking the My Completed Exports infotile shows your export status. Click
the ZIP file link in the Exported Data File column to download the exported file.

Download the Attachment Files

The ZIP file you downloaded in the previous step contains the following files:

You can

The attachment information CSV file - this file contains information about the attachment records such as
content ID, REST resource URL, attachment file name, and so on.

Attachment download instructions file - this HTML file contains the export details, and the sample EDLC
command to download the attachments.

use the export command of EDLC to download the attachment files from the content management server to

your directory. For example, use the following command to download your attachments exported from the previous

step:

java -jar oscdataloader.jar export -object Attachments -export-id {export-id} -username {username} -target-

url

{environment-url} -output-path {output-directory-path}

Following are the parameters used in the command:

Parameter Description

-objects

Indicates the object type exported. Currently this parameter supports only the value Attachments.

-export -id Job ID of the export job.

-username User name of the user submitting the export command. This must be the same user who submitted
the export activity.

-target-url URL of the environment.

-output-path Directory path of the folder where the attachment files and reports are downloaded. The reports folder

You can

Related

contains details about the attachment files exported, such as their status and error details if any This
should be an existing directory with read and write permissions for the user performing the export.

view the details of all available parameters and their descriptions using the command export -help.

Topics
Export Data
Overview of External Data Loader Client

Command-Line Parameters
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5 Round-Trip Export-Import

Round-Trip Feature

This topic gets you started on the round-trip feature of Import and Export Management.
It explains how to

Export the data from one instance of CX Sales and Fusion Service
Makes any changes in the exported CSV files as required
Reimport the updated CSV files either into the same instance or another instance

You can do this task without manually mapping the source file and the object attributes.

Export Data

You can use Export Management to export the data fields of an object. You can select the fields that you want to export.
If you're importing the data into another instance of CX Sales and Fusion Service, then select the Enable Round Trip
check box in the Advanced Options section of the Create Export page. This generates the header row in the exported
CSV file that enables the round-trip feature. Don't modify the header row values in the CSV file.

You can export a single object and its child objects with attributes for each export activity. If the exported ZIP file
contains the parent and child record files, then import the parent CSV file followed by the child CSV file.

You can either schedule the export process at a future date or run it immediately. The export activity generates a ZIP file
that you can download.

Import Data
You can import the exported data into either the same instance or another instance of CX Sales and Fusion Service. You
must use the CSV file extracted from the downloaded ZIP file. Don't edit the header row in the CSV file.

You import the data using the Import Management feature in the User Interface. During the import, the automatic
mapping feature automatically maps the columns in your source file to the application attributes.

Note: While doing round trip import, you need to remove the attributes FileNameSystaskld and FileRecordNum from
the CSV.

Related Topics
e Export Data

« How do | import data?
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Export and Import Account Data between CX Sales and
Fusion Service Instances Using the Round-Trip Feature

This example shows how to export the Account object from one instance of CX Sales and Fusion Service and import the
exported data into another instance of CX Sales and Fusion Service using the round-trip feature.

You can do this without manually mapping the source file and the application attributes.

Export Data from CX Sales and Fusion Service Using Export Management

You can export Account object records from CX Sales and Fusion Service using Export Management as follows:

1. Create an export activity for the Account object as explained in the topic Export Data.

2. Click the Advanced Options section. Select the Enable Round Trip check box. This enables the round-
trip support for your export activity. This option generates the header row in the exported CSV file and is
responsible for automatic mapping during the import. So don't modify any of the header row values. Review
and submit the export activity.

3. Onthe Manage Exports page, you can see the status of your export. Once the export activity completes, click
the My Completed Exports infotile to see the status of your export.

4. C(lick the link under the Exported Data File column to download your exported ZIP file. Save the ZIP file, and
extract the CSV file.

Import Data from CX Sales and Fusion Service Using Import Management

You can import data into CX Sales and Fusion Service instance using the following steps:

1. Create an import activity for the Account object as explained in the topic Import Data. Browse and select the
CSV file that you had exported in the last section.

2. Click Next to get the Map Fields page. On the Map Fields page, the round-trip feature automatically maps the
source file attributes for you.

3. Click Next to review the import configurations and Submit.

4. Onthe Manage Imports page, you can see the status of your import. Once the import activity completes click
the My Completed Imports infotile to see the status of your import.

Related Topics
« Round-Trip Feature

- Export Data
« How do | import data?
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6 Enrich Data

Overview of Data Enrichment

You can use Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B) to enrich your sales account and
contact data. Oracle Account and Contact Enrichment by Dun and Bradstreet (D&B) has the most up-to-date data for
over 300 million companies and over 100 million contacts worldwide.

Data enrichment improves the quality of your existing sales account and contact data, and it also enriches the data
with additional information. Sales Representative can enrich sales accounts and contacts in real-time in Sales, and
data stewards can enrich data in bulk in CDM, using either batch data enrichment in the Data Enrichment work area
or manually using bulk import and export. Additionally, you can download new account and contact data from Oracle
Account and Contact Enrichment by Dun & Bradstreet (D&B).

Batch Data Enrichment

The batch data enrichment option lets you enrich data in bulk by creating and submitting batch-processing jobs in the
Data Enrichment work area. This enrichment process flow comprises the following steps:

1. Create a Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B) user and assign appropriate
privileges

2. Configure CX Sales and Fusion Service to Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B)
integration

3. Create and submit batch-processing jobs

4. Monitor batch status and take appropriate follow-up action

You can do the following two batch data enrichment types:

Enrich Existing Records: Use this option to submit the existing records in the application for a bulk data
enrichment.

- Synchronize D&B Updates: Use this option to synchronize your D&B updates, including your previously
enriched sales organization and person records as well as new records imported from Oracle Account and
Contact Enrichment by Dun & Bradstreet (D&B), to uptake the latest updated information from D&B.

Manual Data Enrichment

CX Sales and Fusion Service comes with preconfigured mappings of data attributes to import sales account and contact
data from Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B). If you require additional attributes not in
these mappings, you must create a custom mapping and manually import the data using that mapping.

1. Export data to a CSV file.

2. Enrich the data using Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B).

3. Download the enriched data file from Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B).
4. Import the enriched data file into the application.

Here's a figure to show the available data enrichment process flows.
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It illustrates the process flows for Customer Data Management.
4 Manual Enrichment j‘\f Batch Data Enrichment

Create a Oracle Account and
Contact Enrichment by Dun &
Bradstreet (D&B) user and

Export Data from Oracle CX

Sales to a CSV file d " »
assign appropriate privileges
: Manage Oracle CX Sales and
Enrich the data using Oracle Oracle Account and Contact
Account and Contact Enrichment Enrichment by Dun & Bradstreet
by Dun & Bradstreet (D&B) (D&B) integration

r Y
Download the enriched data file

from Oracle Account and Contact Create and submit batch
Enrichment by Dun & Bradstreet processing jobs
(DEB)
r
Import the enriched data file into Monitor batch status and take
Oracle CX Sales appropriate follow-up action

Batch Data Enrichment

Batch Data Enrichment Using Oracle Account and Contact
Enrichment by Dun & Bradstreet (D&B)

You can use the batch data enrichment functionality to enrich your sales account and contact (Fusion Service contact)
data in bulk with additional information using D&B data.

You must complete the following prerequisites before you can enrich data in bulk:

1. Purchase a subscription to Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B).

2. The service administrator must create a new user with the Data Service Client APl AppID role. This user is used
by the application to securely communicate with the REST API for Oracle Account and Contact Enrichment by

Dun & Bradstreet (D&B).
3. The service administrator must set up CX Sales and Fusion Service and Data Cloud integration.

Types of Batch Data Enrichment

You can do the following two batch data enrichment types:

Enrich Existing Records: Use this option to submit the existing records in the application for a bulk data
enrichment.
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- Synchronize D&B Updates: Use this option to synchronize your D&B updates, including your previously
enriched Sales Organization and person records as well as new records imported from Oracle Account and
Contact Enrichment by Dun & Bradstreet (D&B), to uptake the latest updated information from D&B.

How You Enrich Existing Data

You can enrich both organization (sales account) and person (contact) records by creating and submitting batch-
processing jobs in the Data Enrichment work area. These batches, in the background, export the records to Oracle
Account and Contact Enrichment by Dun & Bradstreet (D&B). The exported records are enriched in Oracle Account and
Contact Enrichment by Dun & Bradstreet (D&B) by the REST API. Finally, the enriched records are imported back. You
can review the status of the scheduled and processed batches on the Data Enrichment work area.

Note: Before enriching contacts using the batch data enrichment process, you must enrich the associated sales
accounts.

Data Enrichment Processing Options
To enrich your existing records, you can select one of the following two processing options:

Review Batch: Select this processing option to review the results of data enrichment in the matched candidate
records in the batch before importing the enriched data. Note that the review batch option shows only the first
100 records from the data enrichment batch.

Process Batch mode: Select this processing option to submit the data enrichment batch for processing without
a review.

How You Synchronize D&B Updates

You can periodically synchronize your D&B updates, including your previously enriched Sales organization and person
records as well as new records imported from Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B),

to uptake the latest updated information from D&B. You can synchronize these records from the Data Enrichment
work area, using the Synchronize D&B Updates Oracle Enterprise Scheduler Service job. For more information, see:
Synchronizing Previously Enriched Data: Procedure.

Data Enrichment Results

You can search for the status of scheduled and processed batches on the Data Enrichment work area. The batch ID
contains the link to the Batch Details page. You can download the details of the processed records by clicking on the
linked number on the Batch Details table. Batches submitted with the Review Batch processing option appear on the
Data Enrichment work area in the status Review when completed. After reviewing the results of data enrichment in the
matched candidate records in the batch, you must click Import to uptake the enriched data.

Create a Data Enrichment Batch

Use this procedure to create a data enrichment batch to enrich existing customer data in bulk with additional
information using D&B data. Before you proceed with batch data enrichment, verify that the data enrichment
configurations are complete including any custom import mappings.

For more information, see the Overview of Configuring Oracle Account and Contact Enrichment by Dun & Bradstreet
(D&B) for Data Enrichment topic in the Related Topics section.
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To create a data enrichment batch:

1. Navigate to the Data Enrichment work area as follows: Navigator > Customer Data Management > Data
Enrichment

2. (lick the Create action menu option or button to run the data enrichment batch definition process train.

3. Enter the following basic information in the Create Data Enrichment Batch page. Enter the following sample
data:

o Batch Name: Data_Enrichment_Batch_1
o Confidence Score: You can leave it at default 90 or specify a new score.
o Party Type: Select Organization to enrich a sales account record or Person to enrich a contact record.

o Processing Option:

- Review Batch: Select this processing option to review the results of data enrichment in the
matched candidate records in the batch before importing the enriched data. Note that the review
batch option shows only the first 100 records from the data enrichment batch.

- Process Batch: Select this option if you want to submit your data enrichment batch for processing
without a review. This is the default batch data enrichment option.

Click Next

Enter the record selection criteria on the Enrich Organizations: Selection Criteria page.
Click Preview to verify that the selection criteria yielded records in the batch.

Review the batch and click Next. Create Data Enrichment Batch: Review page appears.
Click Submit to send the records for batch data enrichment.

You can search for the status of scheduled and processed batches on the Data Enrichment work area. The batch ID
contains the link to the Batch Details page. You can download the details of the processed records by clicking on the
linked number on the Batch Details table.

03O uh

Batches submitted with the Review Batch processing option appear on the Data Enrichment work area in the status
Review when completed. After reviewing the results of data enrichment in the matched candidate records in the batch,
you must click Import to uptake the enriched data.

Related Topics
« Manual Data Enrichment

« Overview of Configuring Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B) for Data
Enrichment

Synchronize D&B Updates

You can periodically synchronize your D&B updates, including your previously enriched organization (sales account)
and person (contact) records as well as new records imported from Oracle Account and Contact Enrichment by Dun &
Bradstreet (D&B), to uptake the latest updated information from D&B.

You can synchronize these records from the Data Enrichment work area, using the Synchronize D&B Updates Oracle
Enterprise Scheduler Service job. You can update or synchronize records only if they have a Oracle Account and Contact
Enrichment by Dun & Bradstreet (D&B) ID assigned to them. In case some records were originally excluded from
synchronization in the Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B) Administrator Ul, these
records can't be synchronized and updated.
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Before you proceed with the synchronization process, verify that the data enrichment configurations are complete
including any custom import mappings. For more information, see the Related Topics section.

Note: Note that a synchronization job updates one million records at a time. If you have more than one million
records to update, you must submit the synchronization batch a second time.

Perform the following steps to synchronize your D&B updates:

1. Navigate to the Data Enrichment work area.

2. Click Actions.

3. Select Synchronize Organizations or Synchronize Persons. The Schedule Updates for Person or Schedule
Updates for Organization page appears.

4. Click Advanced to select batch run options such as As soon as possible or Using a schedule. By default, the
batch run is scheduled for As soon as possible.

In the Advanced Option section of the Schedule Updates for Persons or Schedule Updates for Organizations
page, you can update the frequency in which you want the batch to run. You can also set a start and end date to
the batch schedule.

5. Click Submit.

6. Click OK in response to the confirmation message.

You can search for the status of scheduled synchronization batches on the Data Enrichment work area. The batch ID
contains the link to the Batch Details page. You can download the details of imported (synchronized) and not imported
(not synchronized) records by clicking the linked number on the Batch Details table.

Note: You can't see the list of records that were excluded from synchronization in the Imported or Not Imported
record list.

Related Topics
« Overview of Configuring Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B) for Data
Enrichment

Manual Data Enrichment

Manual Data Enrichment

You can manually enrich sales account and Fusion Service contact data using the Oracle Account and Contact
Enrichment by Dun & Bradstreet service.

For detailed steps, see the topics About Matching Records and Enrich Data in CX Sales in the Using Account and
Contact Enrichment by Dun & Bradstreet guide.

Related Topics
« Manual Data Enrichment
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How You Import New Records from Oracle Account and Contact
Enrichment by Dun & Bradstreet (D&B)

You can import sales accounts or contacts from Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B) into
your application instance.

To import data from Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B):

1. Export the sales accounts or contacts from Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B).
2. Import the CSV file into the application.

Before importing Fusion Service contacts, you must ensure that the sales accounts related to the contacts you want to
import exist in your application instance.

Export Accounts or Contacts from Oracle Account and Contact Enrichment by Dun &
Bradstreet (D&B)

You can either export a set of sales account or contact data or export all available sales accounts and account contacts
from Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B).

You can search for sales accounts and contacts you want to import from the Search window. After searching for the
records you want to export, click Export . You must select Use CRM Template as the export template so that the
exported file can be later imported into the application.

For more information, see Using Oracle Account and Contact Enrichment by Dun & Bradstreet (D&B) guide.

Import Accounts or Contacts

You can import the sales account or contact data exported from Oracle Account and Contact Enrichment by Dun &
Bradstreet (D&B) into CX Sales and Fusion Service using Import Management.

To import data using Import Management:

1. Navigate to Tools > Import Management
2. Onthe Manage Imports page, click the Create Import Activity button to create an import activity.

3. Enter the appropriate import details. While specifying the import object, select Account to import sales account
data and Contact to import contact data.

4. Browse and select your source data file in CSV format.

The application provides predefined mappings to import sales account or contact data from Oracle Account
and Contact Enrichment by Dun & Bradstreet (D&B). The application tries to automatically map each of the
source file columns to the appropriate target object attribute. However, you must map the columns that aren't
mapped. The data in unmapped columns isn't imported.

5. Click Validate Data to check the field mapping.
Submit the import process.
7. Verify the imported data.

o

Related Topics
« Enrich Data in CX Sales
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7 Verify Data

Verify Customer Information

Considerations for Scheduling a Data Verification Process

You may find data verification processes to be time consuming, depending on the batch sizes.

Therefore, you must consider the following before scheduling a data verification process:

Process Completion Time
- System resources

Process dependencies

Process Completion Time

The time required to complete the data verification process depends on the number of records, cleansing complexity,
and hardware characteristics. You must calculate the estimated completion time taking into account these three factors
and the available benchmark.

System Resources

You must estimate system performance based on recent data, by reviewing the batch and environment statistics. You
can also review various object lists to know the time when most system resources are available for the data verification
process.

Process Dependencies

You must understand process dependencies before scheduling the data verification process. For example, you must
consider whether other processes are waiting for the results of the data verification process.

Related Topics
- Best Practices for Accepting Data Verification Results

« Create Data Verification Batches

Considerations for Creating Data Verification Batches

You create a data verification batch to cleanse and validate data.
Consider the following before creating a data verification batch that best suits your address cleansing needs:

- Create new or use a copy of an existing data verification batch

- Create a data verification batch for a single or periodic run
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Create New or Use a Copy of an Existing Data Verification Batch

You can quickly create a data verification batch by copying an existing verification batch. You can edit the batch details
such as batch selection criteria, address cleansing mode, and scheduling before you submit the batch.

Note: You can search for existing data verification batches using the Saved Searches.

You create a new data verification batch, instead of copying an existing verification batch, if your data verification batch
details are unique.

Create a Data Verification Batch for a Single or Periodic Run

You can create a data verification batch for a single run or a periodic run. You can run data verification batches
periodically for tasks that are mostly ongoing and repetitive, such as the execution of registry address cleansing or
phone number verification.

You can schedule the batch to run at a specific time or at a specific interval. For example, you can schedule the batch to
run daily, every night at 9 PM, weekly, or every Sunday at 10 PM.

Create Data Verification Batches

You can use data verification cleansing to verify addresses, phone numbers, and email addresses data that already
exists in the registry.

This process updates and completes the addresses, phone numbers, email addresses in your database using the
verified address from Oracle Address, Email, and Phone Verification. For example, it can add a missing postal code in an
address.

You can create an data verification batch and specify selection criteria on the Create Data Verification Batch page. You
specify selection criteria, also known as filter criteria, to narrow down the list of candidate records for data verification.

You can use this procedure to create a data verification batch and specify the selection criteria:

1. Navigate to the Create Address Cleansing Batch page as follows: Navigator > Customer Data Management >
Data Verification.

2. Click Create from the Actions menu.
Enter a Batch Name.

4. Select an appropriate batch mode. Select Simulated mode to review and accept the verified data before
committing the data verification job. Select Automated mode to verify the data and save it automatically.

5. Provide a batch description, if required.

W
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6. Specify the following Cleansing Configuration Parameters to override the configuration that was specified using
the Manage Address Cleansing Configurations task:

o

Minimum Verification Level: Used to specify the level of verification to which the input data matches the
available reference data during the verification process.

Minimum Verification Score: Used to specify the similarity between the address entry and closest
reference data match as a percentage between 0 (no match) and 100 (perfect match).

Default Country: Used to specify the country to cleanse the address, if no identifiable country can be
found in an input address.

Output Casing: Used to specify the letter case for an output address. For example, the Output Casing

is set to Mixed, this 411 THEODORE FREMD AVE # 300 RYE NY 10580 input address is displayed as 411
Theodore Fremd Ave # 300 Rye NY 10580.

Correct Partially Verified Addresses: Determines if you want to correct the addresses entry that are
partially verified.

Correct Ambiguous Addresses: Determines if you want to correct the unclear addresses entry and resolve
it to the correct address.

Return Verified Address in Native Script: Displays verified addresses in the native script of the country
selected in the Default Country field. This is supported for a native (local) language to Latin (English)
output or from Latin to a native output. Note that requests in a non-Latin language can't have a verified
output in another non-Latin language. When this option Return Verified Address in Native Script is
selected, addresses are cleansed in the native script of the input address when possible. When this option
isn't selected, DaaS automatically decides whether the data has to be cleansed in the native script based
on the input address.

Note: The configuration settings that you set in the Manage Address Cleansing Configurations setup task
are displayed as the default values on this page. The values that you specified on this page are applicable only
to this address cleansing batch request. For more information about the configuration parameters, see the
Address Cleaning Setup chapter of the Implementing Customer Data Management guide.

7. Click Create on the Action menu in the section Address Cleansing Batch: Selection Criteria.

8. Enter the Selection Criteria. We highly recommend that each time you submit a batch request, you ensure
that the batch size and the number of results of the selection criteria do not exceed the data verification usage
quota. Tightly knit the conditions in the selection criteria to narrow down the number of records that will be
submitted for the data verification cleansing process.The following table contains sample selection criteria.

Object Attribute Operator Value
Location Country Equal to us
Location State Equal to CA
Location Creation Date Before 7/18/19
Location Creation Date After 1/1/19
Phone Phone Number Contains 90

9. Click Schedule to specify process options. The Schedule Address Cleansing Batch page appears.
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10. Click Submit.
11. Click OK to confirm the batch submission.

Related Topics
- Best Practices for Accepting Data Verification Results

Best Practices for Accepting Data Verification Results

You can accept or reject the results of a batch data verification process run in simulated mode.
You have the following options:
- Accept or reject results for the entire batch

- Accept or reject results by country

- Accept or reject results by record

Note: All verified addresses displayed with Cleansed status are counted against the Oracle Address, Email, and Phone
Verification quota irrespective of their accept or reject status.

Note: If you submit a batch for verifying in the automated mode, then you can't accept or reject the process results.
The verified data is automatically saved to the database. All verified data are counted as verified against the Oracle
Address, Email, and Phone Verification quota.

Accept or Reject Results for the Entire Batch

Accept the results for the entire batch only if you're sure that the data verification results are accurate. Reject the results
if you're not sure about the reliability or accuracy of the batch results, or if the process results may reduce the data
quality.

Accept or Reject Results by Country
The data verification process results depend on the data quality, coverage, and the geography information of the
country or region.

Consider the following before accepting or rejecting address cleansing process results by country:

If the percentage of errors is high and the results for all countries aren't acceptable, then Accept results only for
countries with acceptable cleansing results.

Reject results for countries with very high percentage of errors.

Accept or Reject Results by Record

Accept or reject cleansing results of each individual record. You can click Exclude to exclude verified records from

the current and subsequent data verification batches. You can also select more than one record at a time using the
check boxes and then click Accept, Reject, or Exclude. Be cautious of using the select all check box on the table header
because the changes apply to all the records. We recommend that you review all the records before you use the select all
check box.
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Interpret Data Verification Results

You can drill down the data verification batch results and click View Details to see the statistics of the data verification
results. You can also see the visual representation of these statuses.

To view the results:

1. Navigate to the Create Address Cleansing Batch page as follows: Navigator > Customer Data Management >
Data Verification.
2. Search for a batch and click its status.
Similarly, you can click the data verification results of each country to view the statistics and visual representation of the
statuses of cleansed records by country.

Here are the statuses of verified records:

- Processed: Indicates the total number of records that were processed.
- Failed: Indicates the number of records that couldn't be processed. This can happen due to unexpected errors.

- Cleansed: Indicates the number of records that were verified. That is, the input data and a record from the
available Loqgate reference data were matched.

- Skipped: Indicates the number of records that weren't cleansed. A record is skipped when the record couldn't
be verified to the minimum acceptable level specified during the cleansing configuration. The following data
verification configuration criteria impact the number of skipped records:

o Minimum Verification Score

o Minimum Verification Level

o Correct Partially Verified Addresses

o Correct Ambiguous Addresses
For example, the Minimum Verification Level was set to 5 and the input address belongs to United Arab
Emirates. Logate supports verification level of L4 for United Arab Emirates. This address record is skipped.

In batch cleansing, failed and skipped aren't counted against the quota usage. In real-time and while importing data, all
records are counted regardless of the record's cleansing status.

Further, verified records can be in the following states:

- Accepted: The number of verified records accepted by the data steward.
- Rejected: The number of verified records rejected by the data steward.

- Error: The number of records that weren't updated in the application database.
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FAQs for Data Verification

What's an Address Cleansing Batch?

You use an address cleansing batch to select and submit a set of records for address cleansing. Batch cleansing
validates and cleanses address data in the registry. This resolves existing errors as well as updates the addresses with
the changes in the geography reference data such as postal code.

Can | resubmit an address cleansing batch?

No. However, if you update or edit the addresses you can resubmit the modified addresses as a new batch.

What's the difference between Automated Cleansing mode and
Simulated Cleansing mode?

Automated Cleansing mode doesn't require any user action. You use this mode to automatically save cleansed
addresses to the database. All cleansed addresses are counted as cleansed by Oracle Address, Email, and Phone
Verification.

Simulated Cleansing mode lets you review the addresses verified using Oracle Address, Email, and Phone Verification.
You can accept or reject cleansed data in its entirety, by country, or by individual address. All cleansed addresses,
irrespective of their accept or reject status, are counted as verified by Oracle Address, Email, and Phone Verification.
For example, 100 addresses go through the batch verification and 60 addresses are returned as cleansed. These 60
addresses are counted in Oracle Address, Email, and Phone Verification irrespective of you accepting or rejecting them.

Related Topics
 Best Practices for Accepting Data Verification Results

Why did the batch cleansing process skip some records?

Batch cleansing skips a record if the record is already cleansed and validated. For example, an address that already
follows the formats, norms, and standards of the related postal directory.
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Why did some records fail the batch cleansing process?

Records can fail the batch cleansing process because of Oracle Address, Email, and Phone Verification connection or
Oracle Address, Email, and Phone Verification configuration issues. Exceeding the address verification usage quota can
also cause records to fail the batch cleansing process.

How can | view the Oracle Address, Email, and Phone Verification
usage information?

You could be using Oracle Address, Email, and Phone Verification in various applications like Oracle Customer Data
Management, Oracle CX Sales, Oracle Procurement Cloud, or even in your test environment. Oracle Address, Email,
and Phone Verification doesn't distinguish between a production environment or a test environment. When you
purchase Oracle Address, Email, and Phone Verification, you purchase one instance of Oracle Address, Email, and
Phone Verification. This instance could be used initially for testing and later in the production environment. You can
view the address record usage on the Oracle Address, Email, and Phone Verification home page. For more information
about the usage dashboard, see the Related Topics section.

Related Topics
« About Address Verification
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8 Identify Duplicates

|dentify Duplicate Customer Information

How You Manage Duplicates

You can identify potential duplicates in your database by creating and running duplicate identification batches. These
batches, when complete, contain sets of two or more potential duplicate records, which are identified by the application
for your review.

You can analyze each of these duplicate sets and determine whether you want to resolve them by creating a merge or
link resolution request.

While managing duplicate sets you can:

Use the Test Merge duplicate resolution request type to test your merge configurations, such as survivorship
rules and agreement rules, without any impact your application data.

Resolve duplicates within each identified duplicate set through a merge or link request. A merge request
combines duplicate records and a link request joins duplicate records. You can also create a generic request to
select the resolution later.

Remove records that you don't want to include in the duplicate resolution request. You can also restore the
previously removed records back to the set from the removed records table.

Mark a pair of records as nonduplicate, so that these records aren't identified as potential matches. You can
remove the pair from the nonduplicate list by changing the end date.

- Change the master record.

- Submit the duplicate sets as merge or link requests for resolution.

Related Topics
« Create and Submit Resolution Requests in Duplicate Identification Work Area

« Create Duplicate Identification Batches and Define Subset Rules

Considerations for Creating Duplicate Identification Batches

You can create a duplicate identification batch using the following options:
- Create the duplicate identification batch from scratch for a single or periodic run.
- Create the duplicate identification batch from a copy of an existing duplicate identification batch.

You can choose between two of the following batch match modes while creating a duplicate identification batch:
- Within the batch: Runs the duplicate identification process within the batch.

- Against the registry: Runs the duplicate identification process against the registry.
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Batch Creation for Single or Periodic Run
You can create duplicate identification batches for a single or periodic run. You are likely to run a batch periodically for
an ongoing or a repetitive task, such as the execution of registry duplicate identification.

You can schedule the periodic batch to run at a specific time or at a specific interval. For example, you can schedule the
batch to run daily, every night at 9 PM, weekly, or every Sunday at 10 PM.

Create New or Use a Copy of an Existing Duplicate Identification Batch

You can use a copy of an existing duplicate identification batch to quickly create a new one. . You can edit the batch
details, such as subset rules or batch selection criteria rules, duplicate identification rules, and schedule of the batch
process before you submit the batch.

But, if your duplicate identification requirements are unique, you should create a new batch instead of copying an
existing one.

|dentify Duplicates within the Batch

You can look for duplicates in a batch by using the Within the Batch Match mode. In this mode, the application
includes records in a batch based on configured subset rule conditions or the batch selection criteria rules and checks
for duplicates only among the records within that batch.

|dentify Duplicates Against the Registry

You can identify duplicates across the database by using the Against the Registry Batch Match mode. In this mode,
the records that meet the subset rule conditions are included in the duplicate identification batch. The application
matches these records against one another as well as against other records in the database.

Add Additional Attributes to Define Subset Rules

You define subset rules as a part of creating a duplicate identification batch.

These rules, also known as batch selection criteria rules, retrieve a subset of records from the database in the duplicate
identification batch for matching them against one another as well as against other records in the database. You

can define these rules on the Create Duplicate Identification Batch page using the available objects, attributes, and
operators, followed by an AND or OR condition.

In case the attributes available out of the box on this Ul don't meet your business requirements you can add additional
standard or custom account (organization) or contact (person) attributes.

To add new attributes to the batch selection criteria, you must add the required attributes to the lookup types
ZCH _MATCH OBJ PERSON and zCH MATCH OBJ ORGANIZATION, as lookup codes. Before you update the lookup types, you must
identify the display name and API (internal) name for each attribute that you want to add.

|dentify Display Name and APl Name for an Attribute

You must identify the display name and the API (internal) name of the attributes that you want to add as subset rule
selection criteria.

You can find the list of standard attributes for accounts and contacts, along with their lookup code, display name
(meaning), and API name (tag), from the topic "List of Additional Attributes for Subset Rule ". Use the following steps to
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identify the display name and the APl name of the custom attributes of an account (organization) or contact (person)
using Application Composer.

Note: You can view and update objects in Application Composer only if you're in an active sandbox.

1. Signin as a setup user, such as Master Data Management Application Administrator, and navigate to
Application Composer.

Expand the Standard Objects list and navigate to Account or Contact.

Click Fields under Account or Contact. The Fields page appears.

Select the Custom tab to see the list of available attributes.

Click the Display Label link that you want to add. The Edit Custom Field page appears.

Copy the Display Name and the API Name.

cUuhAWN

Update Attribute Lookups with New Attributes

You can add new attributes to the subset selection criteria, by adding the required attributes to the attribute
lookup types for person (contact) object zcu_matcu_oBs_person or to the organization (account) object,
ZCH_MATCH OBJ_ ORGANIZATION, respectively.

You can follow these steps to add the required attributes to the attribute lookup types as lookup codes:

1. Signin as a setup user, such as Master Data Management Application Administrator. In the Setup and
Maintenance work area, go to the following:

o Offering: Sales
o Functional Area: Sales Foundation
o Task: Manage Standard Lookups

2. Search for and navigate to the task Manage Standard Lookups.
3. Enter the required Lookup Type.

o Use the lookup type zcu_maTcH oBJ_oreanizaTion to add new custom or standard attributes to the subset
rule selection criteria of the organization (account) object.
o Use the lookup type zcu_maTcu oBJ_person to add new attributes to the subset rule selection criteria of the
person (contact) object.
Click Search.
Click New on the Lookup Codes section of the Manage Standard Lookups page.
Add a Lookup Code for each attribute.
o Lookup Code: An internal name for the attribute. This field is case-sensitive. The value should be in all

capital letters and the space should be replaced with an underscore. For example, CUSTOM_ATTR can be
a lookup code for custom attribute.

oup

Note: For date fields, you must suffix the lookup code with _DATE. This enables the application to
identify the attribute value as date and display the date picker.
o Display Sequence: The order in which the lookup code must be displayed. This isn't a mandatory field.
o Meaning: The display name of the attribute. This field is mandatory and case-sensitive.
o Description: The description of attribute that you see on the duplicate identification work area.
o Tag: The API (Internal) Name of the attribute. This field is mandatory and case-sensitive.
7. Click Save and close.
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Note: You must publish the sandbox to activate the newly added attributes. Only after you publish the sandbox,
the newly added attributes appears in the Subset Rules for Identifying Duplicates section of the Create Duplicate
Identification Batch page. If the sandbox isn't published, the tag value with the attribute name is considered invalid.

List of Additional Attributes for Subset Rule

You can find a detailed description of the standard account and contact attributes available for use in Subset Rule

Selection Criteria in this topic.

I Note: For date related attributes, you must suffix the lookup code with _DATE. Standard Attributes for Accounts.

Standard Attributes for Accounts

This table lists the standard attributes for account (organization) along with their lookup code, display name (meaning),
and APl name (tag) that you can add as subset rule selection criteria for identifying duplicates:

Lookup Code

ANALYSIS_FY

BANK_CODE

BANK_OR_BRANCH_NUMBER

BRANCH_CODE

BRANCH_FLAG

BUSINESS_SCOPE

CEO_NAME

CEO_TITLE

CERTIFICATION_LEVEL

CERTREASON_CODE

CLEANLINESS_SCORE

ORACLE

Meaning (Attribute Display Name)

Analysis Year

Bank Code

Bank or Branch Number

Branch Code

Branch Indicator

Business Scope

Chief Executive Name

Chief Executive Title

Certification Level

Certification Reason

Cleanliness

Tag (APl Name)

AnalysisFy

BankCode

BankOrBranchNumber

BranchCode

BranchFlag

BusinessScope

CeoName

CeoTitle

CertificationLevel

CertReasonCode

CleanlinessScore
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Lookup Code

COMMENTS

COMPLETENESS_SCORE

CONG_DIST_CODE

CONTROL_YR

CORPORATION_CLASS

CREATION_DATE

CURRENT_FY_POTENTIAL_REV

DATA_CLOUD_STATUS

DATA_CONFIDENCE_SCORE

DB_RATING

DIS_ADV_IND

DOM_ULTIMATE_DUNSNUM_C

DO_NOT_CONFUSE_WITH

DUNS_NUMBER_C

DUPLICATE_INDICATOR

DUPLICATE_SCORE

EmailAddress

EMPS_AT_PRIMARY_ADDRESS

EMPS_AT_PRIMARY_ADDR_EST

EMPS_AT_PRIMARY_ADDR_MIN

EMPLOYEES_TOTAL

ORACLE

Meaning (Attribute Display Name)

Comments

Completeness

Congressional District

Organization Control Year

Corporation Class

Creation Date

Current Fiscal Year's Potential Revenue

Enrichment Status

Data Confidence

D&B Credit Rating

Disadvantaged Indicator

Domestic D-U-N-S number

Do Not Confuse With

D-U-N-S number

Duplicate Type

Duplication

Email Address

Number of Employees at Identifying Address

Number of Employees at Identifying Address
Estimated Quialifier

Number of Employees at Identifying Address
Minimum Qualifier

Number of Employees
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Tag (APl Name)

Comments

CompletenessScore

CongDistCode

ControlYr

CorporationClass

CreationDate

CurrFyPotentialRevenue

DataCloudStatus

DataConfidenceScore

DbRating

DisadvantagedIndicator

DomesticUltimateDunsNumC

DoNotConfuseWith

DunsNumberC

Duplicatelndicator

DuplicateScore

EmailAddress

EmpAtPrimaryAdr

EmpAtPrimaryAdrEstind

EmpAtPrimaryAdrMinind

EmployeesTotal
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Lookup Code

ENQUIRY_DUNS

ENRICHMENT_SCORE

EXPORT_IND

FISCAL_YEAREND_MONTH

GLOBAL_ULTIMATE_DUNSNUM_C

GROWTH_STRATEGY_DESC

GSA_INDICATOR_FLAG

HOME_COUNTRY

HQ_BRANCH_INDICATOR

IMPORT_IND

INCORP_YEAR

INTERNAL_FLAG

JGZZ_FISCAL_CODE

LABOR_SURPLUS_IND

LAST_ASSIGNMENT_DATE

LAST_ENRICHMENT_DATE

LAST_SCORE_UPDATE_DATE

LAST_SOURCE_UPDATE_DATE

LAST_UPDATE_DATE

LAST_UPDATED_BY

LAST_UPDATE_SOURCE_SYSTEM

ORACLE

Meaning (Attribute Display Name)

ENQUIRY_DUNS

Enrichment

Exporter Indicator

Fiscal Year End Month

Global Ultimate D-U-N-S Number

Growth Strategy Description

GSA Indicator

Home Country

HQ branch indicator

Importer Indicator

Year Incorporated

Internal

Taxpayer identification number

Labor Surplus Indicator

Last Assigned Date

Last Enrichment Date

Last Score Date

Last Source Update Date

Last modified date

Last modified by

Last Update Source System
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Tag (APl Name)

EnquiryDuns

EnrichmentScore

Exportind

FiscalYearendMonth

GlobalUltimateDunsNumC

GrowthStrategyDesc

GsalndicatorFlag

HomeCountry

HgBranchind

Importind

IncorpYear

InternalFlag

JgzzFiscalCode

LaborSurplusind

LastAssignedDate

LastEnrichmentDate

LastScoreUpdateDate

LastSourceUpdateDate

LastUpdateDate

LastUpdatedBy

LastUpdateSourceSystem
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LEGAL_STATUS

LINE_OF_BUSINESS

LOCAL_ACTIVITY_CODE

LOCAL_ACTIVITY_CODE_TYPE

LOCAL_BUS_IDENTIFIER

LOCAL_BUS_IDEN_TYPE

MINORITY_OWNED_IND

MINORITY_OWNED_TYPE

MISSION_STATEMENT

NAMED_FLAG

NEXT_FY_POTENTIAL_REVENUE

OOB_IND

ORGANIZATION_NAME

OWNER_PARTY_ID

PARENT_DUNS_NUMBER_C

PARENT_SUB_IND

PARTY_ID

PARTY_NUMBER

PREF_CONTACT_METHOD

PREF_CONTACT_PERSON_ID

PREF_FUNCTIONAL_CUR

ORACLE

Meaning (Attribute Display Name)

Legal Status

Line of Business

Local Activity Code

Local Activity Code Type

Common Business Identifier

Common Business Identifier Type

Minority-Owned Indicator

Type of Minority-Owned Organization

Mission Statement

Named Account

Next Fiscal Year's Potential Revenue

Out of Business Indicator

Name

Owner ID

Parent D-U-N-S Number

Subsidiary Indicator

Party Id

Registry ID

Preferred Contact Method

Preferred Contact Person Id

Preferred Functional Currency
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Tag (APl Name)

LegalStatus

LineOfBusiness

LocalActivityCode

LocalActivityCodeType

LocalBusldentifier

LocalBusldenType

MinorityOwnedInd

MinorityOwnedType

MissionStatement

NamedFlag

NextFyPotentialRevenue

Oobind

OrganizationName

OwnerPartyld

ParentDunsNumC

ParentSublind

Partyld

PartyNumber

PreferredContactMethod

PreferredContactPersonld

PrefFunctionalCurrency
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Lookup Code

PrimaryPhoneNumber

PRINCIPAL_NAME

PRINCIPAL_TITLE

PUBLIC_PRIVATE_OWNER_FLAG

RECENCY_SCORE

REGISTRATION_TYPE

RENT_OWN_IND

SALES_PROFILE_STATUS

SALES_PROFILE_TYPE

SMALL_BUS_IND

STOCK_SYMBOL

TOTAL_EMP_EST_IND

TOTAL_EMPLOYEES_IND

TOTAL_EMP_MIN_IND

TOTAL_EMP_TEXT

TOTAL_PAYMENT_AMOUNT

UNIQUE_NAME_ALIAS

UNIQUE_NAME_SUFFIX

VALIDITY_SCORE

WOMAN_OWNED_IND

YEAR_ESTABLISHED

ORACLE

Meaning (Attribute Display Name)

Primary Phone

Principal Name

Principal Title

Private Ownership

Recency

Registration Type

Rent or Own Indicator

Sales Profile Status

Type

Small Business Indicator

Stock Symbol

Number of Employees Estimated Qualifier

Number of Employees Includes Subsidiaries

Number of Employees Minimum Quialifier

Total Number of Employees

Total Payments

Organization Name

Name Suffix

Validity

Woman-Owned Indicator

Year Established
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Tag (APl Name)

PrimaryPhoneNumber

PrincipalName

PrincipalTitle

PublicPrivateOwnershipFlag

RecencyScore

RegistrationType

RentOwnind

SalesProfileStatus

SalesProfileType

SmallBusind

StockSymbol

TotalEmpEstind

TotalEmployeesind

TotalEmpMinind

TotalEmployeesText

TotalPayments

UniqueNameAlias

UniqueNameSuffix

ValidityScore

WomanOwnedind

YearEstablished
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Lookup Code

Meaning (Attribute Display Name)

Standard Attributes for Contact

This table lists the standard attributes for contact (person) along with their lookup code, display name (meaning), and
APl name (tag) that you can add as subset rule selection criteria for identifying duplicates:

Lookup Code

CERTIFICATION_LEVEL

CERT_REASON_CODE

CLEANLINESS_SCORE

COMMENTS

COMPLETENESS_SCORE

CREATED_BY

CREATION_DATE

DATA_CLOUD_STATUS

DATA_CONFIDENCE_SCORE

DATE_OF_BIRTH_DATE

DATE_OF_DEATH_DATE

DECEASED_FLAG

DECLARED_ETHNICITY

DEPARTMENT

DEPARTMENT_CODE

DO_NOT_CALL_FLAG

DO_NOT_CONTACT_FLAG

ORACLE

Meaning (Attribute Display Name)

Certification Level

Certification Reason

Cleanliness

Comments

Completeness

Created by

Creation date

Enrichment Status

Data Confidence

Date of Birth

Date of Death

Person Deceased

Declared Ethnicity

Department

Department Code

Do not call

Do not contact
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Tag (APl Name)

Tag (APl Name)

CertificationLevel

CertReasonCode

CleanlinessScore

Comments

CompletenessScore

CreatedBy

CreationDate

DataCloudStatus

DataConfidenceScore

DateOfBirth

DateOfDeath

DeceasedFlag

DeclaredEthnicity

Department

DepartmentCode

DoNotCallFlag

DoNotContactFlag
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DO_NOT_EMAIL_FLAG

DO_NOT_MAIL_FLAG

DUPLICATE_INDICATOR

DUPLICATE_SCORE

EmailAddress

ENRICHMENT_SCORE

GENDER

INTERNAL_FLAG

JGZZFISCAL_CODE

JOB_TITLE

JOB_TITLE_CODE

LAST_ASSIGNMENT_DATE

LAST_CONTACT_DATE

LAST_ENRICHMENT_DATE

LAST_KNOWN_GPS

LAST_SCORE_UPDATE_DATE

LAST_SOURCE_UPDATE_DATE

LAST_UPDATE_DATE

LAST_UPDATED_BY

LAST_UPDATE_SOURCE_SYS

MARITAL_STATUS

ORACLE

Meaning (Attribute Display Name)

Do not e-mail

Do not mail

Duplicate Type

Duplication

Email Address

Enrichment

Gender

Internal

Taxpayer identification number

Job Title

Job Title Code

Last Assigned Date

Last Contact Date

Last Enrichment Date

Last Known Location

Last Score Date

Last Source Update Date

Last modified date

Last modified by

LastUpdateSourceSystem

Marital Status

Chapter 8
Identify Duplicates

Tag (APl Name)

DoNotEmailFlag

DoNotMailFlag

Duplicatelndicator

DuplicateScore

EmailAddress

EnrichmentScore

Gender

InternalFlag

JgzzFiscalCode

JobTitle

JobTitleCode

LastAssignedDate

LastContactDate

LastEnrichmentDate

LastknownGPS

LastScoreUpdateDate

LastSourceUpdateDate

LastUpdateDate

LastUpdatedBy

LastUpdateSourceSystem

MaritalStatus
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Lookup Code

MARITAL_STATUS_EFF_DATE

NAMED_FLAG

OWNER_PARTY_ID

PARTY_ID

PARTY_NUMBER

PERSON_ACADEMIC_TITLE

PERSONAL_INCOME

PERSON_FIRST_NAME

PERSON_INITIALS

PERSON_LAST_NAME

PERSON_LAST_NAME_PREFIX

PERSON_MIDDLE_NAME

PERSON_NAME_SUFFIX

PERSON_PRENAME_ADJUNCT

PERSON_PREV_LASTNAME

PERSON_SECOND_LASTNAME

PERSON_TITLE

PLACE_OF_BIRTH

PREF_CONTACT_METHOD

PREF_FUNCTIONAL_CUR

PrimaryPhoneNumber

ORACLE

Meaning (Attribute Display Name)

Marital Status Effective Date

Named Contact

Owner ID

Partyld

Registry ID

Academic Title

Annual Income

First name

Initials

Last name

Last Name Prefix

Middle Name

Suffix

Prefix

Previous Last Name

Second Last Name

Title

Place of Birth

Preferred Contact Method

Preferred Functional Currency

Primary Phone

Chapter 8
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Tag (APl Name)

MaritalStatusEffectiveDate

NamedFlag

OwnerPartyld

Partyld

PartyNumber

PersonAcademicTitle

Personallncome

PersonFirstName

Personlnitials

PersonLastName

PersonLastNamePrefix

PersonMiddleName

PersonNameSuffix

PersonPreNameAdjunct

PersonPreviousLastName

PersonSecondLastName

PersonTitle

PlaceOfBirth

PreferredContactMethod

PrefFunctionalCurrency

PrimaryPhoneNumber
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Lookup Code Meaning (Attribute Display Name) Tag (APl Name)
RECENCY_SCORE Recency RecencyScore
RENT_OWN_IND Rent or Own Indicator RentOwnind
SALES_AFFINITY_CODE Affinity SalesAffinityCode
SALES_BUYING_ROLE_CODE Buying Role SalesBuyingRoleCode
SALES_PROFILE_STATUS Sales Profile Status SalesProfileStatus
SALES_PROFILE_TYPE Type SalesProfileType
SALUTATION Salutation Salutation
UNIQUE_NAME_SUFFIX Name Suffix UniqueNameSuffix
VALIDITY_SCORE Validity ValidityScore

Create Duplicate Identification Batches and Define Subset Rules

You can create a duplicate identification batch and define subset rules to retrieve a subset of the records to identify
duplicates within the batch or in the database.

Subset rules, also known as batch selection criteria rules, specify the criteria for retrieving a subset of records in the
duplicate identification batch. The data quality engine identifies potential duplicates from this subset of records based
on one of these rules:

- Match all keywords: Select this option to perform an AND operation.

- Match any keyword: Select this option to perform an OR operation.

Now that you have an overview of the task, let's first create a duplicate identification batch to identify duplicate persons
in the registry, and then create a rule to retrieve a subset of records where the person name contains John and the
address contains Redwood. Note that you can use predefined or custom attributes.

1. Navigate to the Duplicate Identification work area as follows: Navigator > Customer Data Management >
Duplicate Identification .

2. Click Create menu option or button. The Create Duplicate Identification Batch page appears.

3. Enter a batch name and description.

Note: Another way is to copy an existing duplicate identification batch and quickly create a new batch from
it. You can modify the details for this batch before submitting it.

4. Specify the Batch Match Mode such as Against the Registry or Within the Batch.

10
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In the Within the Batch Match mode, the duplicate identification is limited to the records in a batch that meet
the subset rule conditions. In the Against the Registry Batch Match mode, the process aggregates the records
that meet the subset rule conditions in a batch, and these records are matched against one another as well as
against other records in the database.

5. Specify the Party Type as Person.

Specify the Automatic Processing option as Create Merge Request to merge the duplicate persons.

7. Provide the Batch Options. The batch options available depends upon the selected Automatic Processing
Option. The following options are available when Create Merge Request is selected as the Automatic
Processing Option:

o

o Select an appropriate value for Cluster Key Level such as Typical.
o Enter a value between 1and 101, such as 70 for Match Threshold.

o Enter a value between 1and 101, such as 75 for Automerge Threshold.

Note: You need to keep in mind that the Automerge Threshold and Autolink Threshold values that
you provide in the Batch Options area override the values set in the Manage Customer Hub Profile
Options page.

o Select Send Notifications to notify the status of the duplicate identification batch to all interested

parties such as initiator or submitter. For more information about these statuses, see How You Merge
Duplicate Records in the Related Topics section. The default value for the Send Notifications field is
set using the Merge Request Notifications option in the Manage Customer Data Management Options
Setup and Maintenance task. You can't set the value of the Send Notifications field if the Merge Request
Notifications option is set to disable all notifications. For more information about Merge Request
Notifications, see Duplicate Resolution Simplified Profile Options topic in the Related Topics section.

8. Click Add menu option or button under Duplicate Identification Batch: Selection Criteria.

9. Specify the Apply Rules options as Match any keyword.

10. Enter the following sample information in the Duplicate Identification Batch: Selection Criteria table:

Object Attribute Operator Value
Person Name Starts with John
Address Address Line 1 Contains Redwood

11. Click Save and Close or Schedule per your requirement.

Related Topics
« Automerge

« How do | merge duplicate records?
» Customer Hub Profile Options

m
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Create and Submit Resolution Requests in Duplicate Identification
Work Area

After you have identified potential duplicates in your database through a duplicate identification batch, you can resolve
these duplicate sets by creating and submitting a duplicate resolution request.

Each duplicate set contains two or more potential duplicate records, which are identified by the application for your
review. You can analyze each of these duplicate sets and modify them. For example, you can

- View the match rule names to understand why a duplicate set was formed and which match rule drove the

duplicate identification score. To display the Match Rule column, click View > Columns > Match Rule. The
ability to view match rules also simplifies the validation of the match configuration. Implementors can fine-tune
match rules and test the effects of rule changes on the duplicate identification result sets.

Remove records that you don't want to include in the duplicate resolution request. You can also restore the
previously removed records back to the set from the removed records table.

Mark a pair of records as nonduplicate, so that these records aren't identified as potential matches. You can
remove the pair from the nonduplicate list by changing the end date.

- Change the master record.

To create and submit a resolution request:

1.

w

Navigate to the Duplicate Identification work area as follows: Navigator > Customer Data Management >
Duplicate Identification.

Click on the Batch ID of the batch for which that you want to review and resolve duplicate sets. The application
displays a list of sets containing duplicate records.

Click on the Duplicate ID of the set that you want to review for resolution.

Review the duplicate records in the selected set and determine whether you want to merge or link these
records. You can view the Match Rule column to understand the match rule that drove the duplicate
identification score of each record. To display the Match Rule column, click View > Columns > Match Rule.
Note that the match rule for the master record is blank.

Click Create Request and specify an appropriate duplicate resolution request type, such as Merge (to combine
duplicate records), Link (to join duplicate records), Test Merge (to test the merge configuration without
impacting the application data) or Generic (to select the resolution later). Once the request is submitted, the
application generates a Request ID, which you can use to track the status of the duplicate resolution process.

Note: The approval for processing this request is controlled by the ORA_ZCH_DS_MERGE_REQUESTS
profile option. This profile option can be set using the Data Steward Merge Handling Setting in the Manage
Customer Data Management Options setup task.

Note: The master record designation within the duplicate set is a preliminary value and the final
determination of the master record occurs within the duplicate resolution process based on the duplicate

resolution Master Record Selection Setting option.

12
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View Nonduplicate Mapping

Manage Nonduplicate Records

You mark a pair of records as nonduplicate, so that this pair isn't identified as a potential match.
You can view such nonduplicate records on the Manage Nonduplicate Records, Ul page using these steps:

1. Navigate to the Duplicate Identification work area.

2. Click Tasks.

3. Click Manage Nonduplicate records. The Manage Nonduplicate Records page appears.
4. Search for the nonduplicate records.

You can modify the period for which a record is a nonduplicate by changing the end date. You can also delete the
nonduplicate status of a record by changing the end date.

FAQs for Duplicate Identification

Why am | unable to assign or reject duplicate identification
batches?

Your ability to assign or reject a duplicate identification batch is dependent on your role in the application. If you're a
Data Steward Manager, you can assign batches to data stewards and also reject any batch. However, as a Data Steward,
you won't be able to assign batches to others. Also, you can only reject the batches that are assigned to you. As a

Data Steward Manager, you can assign a duplicate identification batch by using the Assign button on the Duplicate
Identification Batch page. You can choose the assignees from the 'Assign To' list on the Assign Duplicate Identification
Batch page, but, keep in mind that only the users who are assigned with the role of Data Steward will be visible in this
list.

How can | cancel a batch process?

You can cancel a batch process in the Scheduled Processes Overview page. You can navigate to this page as follows:
Navigator > Tools > Scheduled Processes. You must search for the batch process by its process ID, and then cancel the
batch process request.

How can | schedule a saved duplicate identification batch?

You can schedule a saved duplicate identification batch by searching for it on the Duplicate Identification work area and
editing its processing options.

13
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When do | select the Create Single Request option?

You use the Create Single Request option on an individual duplicate set in a batch to specify duplicate processing
options at a set level. You typically use this option to specify duplicate processing options at individual duplicate set
level that are different from the duplicate processing options selected at the batch level. You can specify different
duplicate processing options for different duplicate sets, using this option.
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9 Resolve Duplicates

How do | create duplicate resolution requests?
You create a duplicate resolution request to resolve potential duplicates in the database.

Depending on your business scenarios, you may create duplicate resolution requests using one of the following options:

- Create Duplicate Resolution Requests Manually.

- Create Duplicate Resolution Requests during the Duplicate Identification Flow.

Create and Process Generic Resolution Requests

You can choose to create a generic duplicate resolution request when not clear whether you want to merge or link the
duplicate parties. Specifying a generic resolution request lets you make the merge or link decision later. You have the
option of creating generic duplicate resolution requests while:

- Creating duplicate identification batches by selecting the None as the Automatic Processing option on the
Create Duplicate Identification Batch page.

Reviewing duplicate sets and creating single requests for each duplicate set on the Duplicate Identification
Batch details page.

- Creating a duplicate resolution request manually for confirmed duplicates on the Create Resolution Request Ul
page.

You can review these resolution requests on the Duplicate Resolution work area and complete processing them by
creating duplicate resolution requests of the type merge or link. For more information, see the How You Process
Duplicate Resolution Requests topic.

Create Duplicate Resolution Requests Manually

When you're sure that two or more records are confirmed duplicates, you can decide to create a duplicate resolution
request manually using the following steps:

1. Navigate to the Duplicate Resolution work area as follows: Navigator > Customer Data Management >
Duplicate Resolution.
2. Click Tasks and then click Create Resolution Request.

3. Search for the records that you want to merge, link, or test merge. For example, select the Party Type as Person
and enter the Name as John, and click Search.

Note: You can only search on standard fields using the Advanced Search option. Custom fields of the
Accounts or Contacts objects aren't available.

Select two or more duplicate records using the Shift or Control key.

Click Actions > Create Request.

Enter a name for the request in the Create Request: Select Type dialog.

Select the request type as Merge, Link, or Test Merge. You can also select the Master Record, if needed.
Click OK.

0o vk
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You can also submit request dispatch jobs directly from the Duplicate Resolution work area by clicking the
Dispatch button, which will submit the job for immediate processing.

Create Duplicate Resolution Requests during the Duplicate Identification
Flow

You create a duplicate identification batch in the Duplicate Identification work area to identify potential duplicates in the
database.

As part of the duplicate identification batch creation flow, you have the option of specifying a duplicate resolution
request of an appropriate type, such as merge, link or none, to resolve the identified duplicates. You can also create

a duplicate resolution request of type Test Merge to test the merge request configuration without changing your
application data. This test option helps you fine-tune your merge request configurations such as survivorship rules and
agreement rules.

Considerations for Selecting the Duplicate Resolution
Request Type

You can resolve duplicates by creating a duplicate resolution request to either merge or link the potential duplicate
records. The type of request that you select determines how these duplicate records are handled after resolution.

Test Merge

You can create a duplicate resolution request of type Test Merge to test your merge request configuration, such as
survivorship rules and agreement rules, without:

- Changing the application data

Depending upon Run Request Dispatcher Job task to review merge results

This helps you to get immediate feedback on the behavior of your merge configuration. After the test merge request is
complete, you can drill down into the test resolution request to examine the results of the merge. You can also choose
the override flow for the merge request to inspect the merge behavior in complete detail.

Merge Request

You create a merge duplicate resolution request to combine duplicate records into one new master record. After the
merge request is completed, all duplicate records are deleted from the data registry and you can update only the master
record. The duplicate records that are deleted are also called non-master records. Note that merge supports transfer of
attachments from duplicate records to master record.

Link Request

You create a link request to associate the duplicate records. The linked records are treated as unique records in the data
registry, and have their own unique identifiers.

While creating the request, you define one of the records as the master record. The resolution process marks and links
the other records to the master record, and marks them as duplicates.

16
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Related Topics
« Why You Link Duplicate Records

Process Duplicate Resolution Requests

You can review and process duplicate resolution requests in new status in the Duplicate Resolution work area.
As part of processing these requests, you can:

- Choose to submit or reject them.

- Decide the duplicate resolution request type, merge or link, based on whether you want to merge or link the
duplicate records.

You can create duplicate resolution requests while:

- Create duplicate identification batches by selecting the Create Merge Request as the Automatic Processing
option on the Create Duplicate Identification Batch page. Review duplicate sets and creating single requests for
each duplicate set on the Duplicate Identification Batch details page.

- Create a duplicate resolution request manually for confirmed duplicates on the Create Resolution Request Ul
page.
A request dispatcher is run periodically for pending requests, and it sets the status of pending requests to New. You can

also request your administrator to run the Run Request Dispatch Job from the Setup and Maintenance area to set the
status of the pending requests to New.

Note: A setup user can access the Run Request Dispatch Job task in the Setup and Maintenance work area, using the
following:

- Offering: Customer Data Management
- Functional Area: Customer Hub

« Task: Run Request Dispatch Job

You can also submit request dispatch jobs directly from the Duplicate Resolution work area by clicking the Dispatch
button, which will submit the job for immediate processing. You can process a duplicate resolution request using
these steps:

- Select the duplicate resolution request to process.

- Select the duplicate resolution request type.

- Manage the duplicate set.

17
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Note: Use the Purge Duplicate Resolution Data scheduled process to purge the duplicate resolution data such

as resolution logs and to delete duplicate resolution batches and requests. You can schedule this process from the
Scheduled Processes work area. You can access this work area as follows: Navigator > Tools > Scheduled Processes.
Similarly, you can purge merged records using the Manage Party Purge Activities scheduled process. If you purge
merged records, the non-master records of the merge request are purged too.

Select Duplicate Resolution Request

1. Navigate to the Duplicate Resolution work area.
2. Select a new duplicate resolution request.

Select Duplicate Resolution Request Type

1. Click the Process option on the Actions menu on the Duplicate Resolution work area.
2. Onthe Select Type of Request page, select the duplicate resolution request type as:

o Merge - to combine duplicate records

o Link - to join duplicate records with the master record

o Test Merge - to test the merge request configuration without modifying your application data

Manage Duplicate Sets

1. As appropriate, mark a record as nonduplicate, set as master a record other than the default master record,
remove records that you don't want to include in the resolution request.

2. Submit the duplicate set, as appropriate, as merge or link requests for resolution.

Related Topics
- Considerations for Selecting the Duplicate Resolution Request Type

- How You Manage Duplicates

Duplicate Resolution Request Statuses

You can get detailed reasons for the rejection or failure of a duplicate resolution request from it's status.

You can use the status to correct data or system errors, and resubmit a resolution request with the updated data for
processing. For more information, see Configuring the Diagnostic Testing Framework for Normal Operation, Oracle
Fusion Applications Administrator's Guide 11g Release 1 (11.1.1.5).

The request status check uses the resolution request ID of the duplicated resolution request as an input parameter to
check the request status. The duplicate resolution request status can be Rejected, Error, Completed, or Pending. The
check result also includes the reasons for the status.

You can select one or more merge requests that are in new, error, or rejected statuses and change their status to
pending by clicking Action > Reset on the Duplicate Resolution page. However, you can't change the status of a merge
request that's in completed status.

18
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How do | merge duplicate records?

Let's have a look at the process to merge records for resolving duplicates.

Suppose you have created a merge request. Your request may undergo some or all of the following processing stages
before the merge is performed. In this process flow, we assume that notifications are turned on. For more information
about turning on notifications for merge requests, see the Related Topics section.

- First the survivorship rules are used to determine the master record for the merge.

- After this, the agreement rule check is performed to verify if the merge request is violating any veto conditions.
If the agreement rule check succeeds then a check is performed to determine if system mapping must
be overridden or not. If the agreement rule check fails, then the merge request is rejected and a rejection
notification is sent to the initiator.

- However, a rejected merge request can also be restored in which case a new merge request is created.

- If system mapping is overridden then the new mapping is stored before the merge request can be submitted.
After the merge request is submitted, the actual merge is performed.

- If the merge completes successfully then a completion notification is sent to the initiator and the submitter. If
the merge fails then an error notification is sent to the initiator and the submitter.

Note: Check if you have the Master Customer Data Management Administrator role to perform merge. Use the Purge
Duplicate Resolution Data scheduled process to purge the duplicate resolution data such as resolution logs and to
delete duplicate resolution batches and requests. You can schedule this process from the Scheduled Processes work
area. You can access this work area as follows: Navigator > Tools > Scheduled Processes.
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Let's look at the following figure that illustrates the merge process flow.
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Merge Request Creation Options

A merge request is created as a result of one of the following:
- The batch duplicate identification process creates a duplicate resolution request automatically for each
identified duplicate set.

- A data steward or another user creates a merge request and submits the request through the Create Resolution
Request Ul page or through the Accounts or Contact Ul page.

- A data steward or another user creates a merge request for processing a generic resolution request on the
Duplicate Resolution work area.
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- You can create a test merge request, examine the results, modify the test merge configuration multiple times
until you're satisfied with the merge results, and then create a merge request as per your requirements.

- A bulk or file-based import process creates a merge request.

I Note: You can also use the duplicate resolution request web service to create merge requests.

List of Merge Request Statuses

Your merge request may be in different statuses depending on its stage of processing.

This table lists the possible statuses of a merge request.

Status Description

Pending All merge requests, and generic duplicate resolution requests, are created with the status as Pending.
The requests with pending status require review by a data steward.

New The request dispatcher is run periodically for pending requests, and sets status of pending requests
to New. When the request dispatcher is run, the application selects the master record and attributes
based on the survivorship rules, and runs the agreement rule check for the request.

Submitted This status indicates that the merge request has been submitted for processing. You can also create
merge requests with the status as Submitted to process the request without data steward intervention.

Rejected This status indicates that the merge request is rejected by the data steward or by the process for
agreement rule violations. You can restore a rejected merge request.

Error This status indicates the request has failed because one or more records can't be processed.

Completed This status indicates that the request has been processed successfully.

How You Select Master and Records to Merge

You can review new merge requests to:

- Select the master record
- Mark records as nonduplicates

- Remove records from the duplicate set to avoid merging them

The merge process selects the master record based on set master rules, if survivorship rules are active. However, you
can select to review and override system settings.

When to Override System Mapping

You can override system mappings, during the merge request review, if the system mapping of the request doesn't
meet your requirements. You can select the accounts, account addresses, and the relationships that should be merged,
transferred, or removed.
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Merge Request Related Notifications

You can enable or disable notifications to notify the status of merge requests to interested parties. You can choose

to enable notifications while you're creating a duplicate identification batch or while processing individual duplicate
resolution requests. For more information about creating a duplicate identification batch, see Create Duplicate
Identification Batches and Define Subset Rules Related Topics section. To receive notifications for individual duplicate
resolution requests, select the request and click Actions > Notify in the Duplicate Resolution work area.

The merge process sends the following related notifications:

- Rejection: This notification is sent to the merge request's initiator, such as a business user, salesperson, or
administrator. You can restore and resubmit a rejected merge request, by selecting a different master record or
by removing some records from the batch.

- Error: This notification is sent to the merge request's initiator and submitter. The notification indicates that the
merge request has errors and can't be processed.

- Completion: This notification is sent to the initiator and the assignee of the merge process. The process merges
duplicate records and updates the record hierarchies. The notifications include information such as the master
and duplicate records.

After receiving the completion notification, the request initiator and assignee can:

- Verify if the updated hierarchies are correct in the Manage Hierarchies work area.

- Optionally, make the necessary edits to the updated hierarchies.

Related Topics
- How do | override system mapping?

 Create Duplicate Identification Batches and Define Subset Rules

How do | override system mapping?

You can override system mapping for merge requests by manually modifying it. To manually modify system mapping,
you must select the master record and its associated attributes, and then specify the resolution for the child entity
conflicts and errors.

You can resolve child entity conflicts and errors by merging, transferring, or removing the record attributes.
You can override system mapping using these steps:

1. Navigate to the Duplicate Resolution work area as follows: Navigator > Customer Data Management >
Duplicate Resolution.
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2. Select the duplicate resolution request for which you want to override system mappings and drill down through
the request ID to the Review Merge Request page.

Note: You can override system mappings only for those merge requests that are in New status, which
indicates that the request is open for review and processing. The status depends on the following:

o The merge request isn't an auto-merge request and the profile option
ZCH_USER_MERGE_REQUESTS is set to Process Subject to Approval. For more information
about this profile option, see Customer Hub Profile Options topic listed in the Related Links
section.

o Your administrator has run the Run Request Dispatch Job from the Setup and Maintenance
area to change the merge request status from Pending to New. A request dispatcher is run
periodically for pending merge requests, and sets the status of pending requests to New. You
can also request your administrator to run the Run Request Dispatch Job from the Setup and
Maintenance area to set the status of the pending requests to new. A setup user can access this
task in the Setup and Maintenance work area, using the following:

- Offering: Customer Data Management
- Functional Area: Customer Hub
- Task: Run Request Dispatch Job

3. Click Override on the Review Merge Request page to view the Override System Mapping: Select Master
Record page.
4. Inthe duplicate set on the page, select the record that you want to make the master and click Set Master.

Optionally, you can also remove records from the duplicate set to prevent them from being merged. You can
also mark the removed record as a nonduplicate to exclude it from all the subsequent merge requests.

5. Click Next to navigate to the Override System Mapping: Map Profile Attributes page.
6. Select a value from any of the duplicate records for each profile attribute to be retained in the master record.

If the number of duplicate records is five or less than five, you can select the value from the record columns. If
the number of duplicate records is greater than five, you can select the value from the value choice list. In the
profile attribute value choice list, you can hover over the value to see the attribute value's record. This helps you
associate the correct value with the master record. You can also manually enter a new value in the Final Value
column for an attribute.

7. On the Override System Mapping: Map Entities page, you can merge two or more entities into a single entity.
You can also remove merge entities, such as addresses, from the merge processes by clicking the Remove icon.
If the Remove icon isn't available, you must enable the ORA_ZCH_ALLOW_REMOVE_FEATURE profile option.
For more information about creating this profile option, see the Enable the Remove Option on the Override
System Mapping Ul section in this topic. Child entities associated with the entities that are removed using the
Remove icon won't be transferred to the master record.

8. C(lick Next to view the Override System Mapping: Review page. Now you can review the mapping settings
and click Submit to override the default system mappings. In case there are edits, click Back to make updates to
the mapping settings before submission.
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Enable the Remove Option on the Override System Mapping Ul

You can enable the Remove icon on the Override System Mapping Ul by enabling the profile option
ORA_ZCH_ALLOW_REMOVE_FEATURE by setting its value to Yes as follows:

1. Signin as a setup user such as, Sales Administrator, Master Data Management Application Administrator, or
Application Implementation Consultant.

Click Navigator > Setup and Maintenance work area.

Click the Tasks menu and click Search. Search for Manage Administrator Profile Values task and open it.
Search for the Profile Option ORA_ZCH_ALLOW_REMOVE_FEATURE.

Click Actions, New in the ORA_ZCH_ALLOW_REMOVE_FEATURE: Profile Values area.

Select Site as the profile level and Y as the profile value.

Click Save and Close.

NOouUuhWN

How do | remove a party from duplicate resolution request?

Removing a party from a duplicate resolution request doesn't automatically modify attribute level mappings of the
request. If you want to manually remove parties from a merge request, you must either manually select the values that
have to be removed from the 'Map Profile Attributes' page, or reprocess the merge request after removing the party
using the following steps:

1. Remove a party from a duplicate resolution request as described in the beginning of this topic and click Save
and Close.

2. Select the merge request and click Reset.

3. Select the merge request and click Dispatch to run the dispatch job once again.

Related Topics
« Customer Hub Profile Options

Automerge

The automerge functionality merges duplicate records without any approval or intervention from the data steward.
Automatic processing of merge requests is critical when processing large volumes of customer data as automerge can
expedite the resolution of duplicate records without manual review.

During automerge, the child entities of the duplicate records, such as contact points, relationships, classifications, and
cross references, become the child entities of the master record. Note that groovy scripts on relationship objects don't
run during merges. If they're critical, you can re-implement the scripts on the parent account or contact.

How Records are Selected for Automerge

Records are selected for automerge based on the following criteria:

- Score threshold: The score threshold is defined in the Match Configuration and determines if a record is
included in a duplicate set.

- Automerge threshold: The automerge threshold is defined by the ZCH_AUTO_MERGE_THRESHOLD profile
option and determines if the merge request for a duplicate set is processed automatically or if it must be
reviewed manually.
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Three possible outcomes for each record with regard to duplicate identification and merging are as follows:

Low score below score threshold: The record isn't included in duplicate set and in the merge request for that
duplicate set.

Medium score above score threshold and below automerge threshold: The record is included in duplicate set
but merge request for that duplicate set must be reviewed manually.

High score above score threshold and above automerge threshold: The record is included in duplicate set and
merge request is processed automatically.

The score for all the records in a duplicate set must be above the automerge threshold for automated processing. If one
record in the duplicate set is below automerge threshold, and the other records are above the automerge threshold, the
merge request must be reviewed manually.

Note: When you merge two or more records with exactly same children information under phone, email, or address
the children information is merged and rolled up to the master record.

How You Configure Automerge

Enabling Automerge involves several implementation steps that must be completed by an implementor using the
following tasks from the Customer Data Management offering in the Setup and Maintenance work area:

Manage Customer Hub Profile Options: Use this task from the Customer Hub functional area to perform the
following implementation steps:

o Set Auto Merge Threshold profile option (ZCH_AUTO_MERGE_THRESHOLD) to the required value.
This profile option specifies the threshold for auto merge. Merge requests with lower scores need data
steward review. An exact match is 100.

o Review the Record Size Limit of Duplicate Set (ZCH_DI_MERGEREQ_REC_SIZE). This profile option
determines the maximum number of records in the duplicate set that can be merged automatically. By
default, the maximum number is set to 10 records.

o Set the Survivorship Enabled profile option (ZCH_ENABLE_SURVIVORSHIP) to Yes. This profile option
enables the survivorship rules to select the master record and retain the attributes during a merge
operation.

Manage Survivorship Rules: Use this task from the Customer Hub functional area to create Set Master
survivorship rules to choose the master record for merge requests created from the duplicate identification
batch and set the rule to active.

If there are no active Set Master rules or if the Set Master rules didn't trigger, the merge request must be
reviewed manually, even if the ZCH_AUTO_MERGE_THRESHOLD profile option is set, the score for all records is
above the threshold value, and the number of records is below the record size limit.

Note: You can use the Set Attribute rules with Set Master rules to determine the Golden Master record. For
automerge, Set Master rule is mandatory.

Manage Enterprise Data Quality Matching Configurations: Use this task from the Data Quality Foundation
functional area to perform the following implementation steps:

o Create an active Match Configuration in Manage Enterprise Data Quality Matching Configurations task or
use a predefined Match Configuration. Rebuild the keys if necessary.
o Enable EDQ Real Time and Batch Basic Match Server in Manage Server Configurations task.
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Run Automerge

This task involves the following two steps:

1. Create a duplicate identification batch and select Create Merge Request as the Automatic Processing Option.
2. Perform the task Run Request Dispatch Job to disposition the duplicate resolution sets.

The Dispatch Job processes any resolution request in Pending or Submitted status. You can run this job in two modes:

« On demand: Run Request Dispatch Job > Submit

Per a specific schedule: Do the following steps to set up a recurring job:

a. Click Advanced on the Run Request Dispatch Jobtask.
b. Click Schedule tab and select the Using a Schedule radio button.
c. Select the frequency you want and click Submit.

To see the list of dispatch jobs, and their statuses, navigate to Scheduled Processes under Tools.

Troubleshoot Automerge Issues
After you create your Duplicate Identification Batch, drill down into the completed batch to see the results. If duplicate
sets have been found, and automerge is enabled, resolution requests are automatically submitted for merge.

If the resolution request wasn't submitted automatically, you can drill down to the duplicate set and compare the score
for each record with the threshold in the ZCH_AUTO_MERGE_THRESHOLD profile option and the number of records
with the limit in the ZCH_DI_MERGEREQ_REC_SIZE profile option. If all scores are above the threshold and the number
of records is below the limit, verify that the following are true:

- Set Master rules are active and triggered to choose a master for the records in the duplicate set.
« ZCH_ENABLE_SURVIVORSHIP is set to yes.

Perform Automerge Using a SOAP Web Service

This topic describes how to automatically merge confirmed potential duplicates based on duplicate resolution requests
using the DuplicateResolutionRequestService Web service.

Performing automerge involves the following tasks:

Enabling automerge.

Using the puplicateResolutionRequestService Web Service to create an automatic merge request.
Running automerge.

Finding out the merge result.

Enable Automerge

1. Set the User Merge Requests profile option to Allow Processing Without Approval. When the User Merge
Requests profile option is set to this value, user merge requests are processed immediately without requiring
any approval from Data Steward.

2. Set the Merge Request Enabled (ZCA_MERGE_REQUEST) profile option to Yes.
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3. Enable the User Merge Requests (ZCH_USER_MERGE_REQUESTS) profile option. This profile option controls
the behavior after the merge request is entered. See the section Customer Hub Profile Options.

Use the Web Service to Create an Automatic Merge Request

1. To create an automatic merge request using the Web service, use the following URL:
https://servername/crmService/DuplicateResolutionRequestService?WSDL

For more information on DuplicateResolutionRequestService, see the Trading Community Real Time Data
Quiality section in the SOAP Web Services for CX Sales and Fusion Service guide.

2. You can use your proprietary, or a third party, SOAP Web services client to use the
DuplicateResolutionRequestService Web service to create an automatic merge request. Enter the URL and run
the createMergeRequest operation with the appropriate payload.

For more information on Invoking SOAP Web Services, see the Invoking SOAP Web Services chapter in the
SOAP Web Services for CX Sales and Fusion Service guide.

Run Automerge

Request your administrator to perform the task Run Request Dispatch Job to disposition the duplicate resolution sets.
The Dispatch Job processes any resolution request in Pending or Submitted status. You can run this job in two modes:

On demand:

1. Navigate to the Run Request Dispatch Job task.
2. Click Submit.

Per a specific schedule:

1. Click Advanced on the Run Request Dispatch Job task.
2. Click Schedule tab and select the Using a Schedule radio button.
3. Select the frequency you want and click Submit.

Find Merge Result

1. Use the getMergeResult operation of the DuplicateResolutionRequestService Web service to find the merge
result.
2. Use the operation with appropriate payload to view the result.

How You Manage Rejected Merge Requests

Merge requests are rejected either manually by a data steward or automatically by the application if the agreement rules
are violated. You must login as a data steward to review or restore rejected merge requests in the Duplicate Resolution
work area.

As a data steward, you can:

Review rejected requests: You review the rejected requests by drilling down through their request ID to the
Review Merge Request page to find out the rejection reasons.
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- Refresh merge request details: You can refresh the merge request so that it has the latest details. For example,
one of the records that must be merged could have been deleted after the merge request was created and
before the data steward reviewed the merge request. Drill down the merge request, click Actions > Reprocess
Merge on the Review Merge Request page to refresh the details of the merge request. Note that this option
refreshes the details of the current merge request and does not trigger another merge request. Also, if this
merge request is created from duplicate identification batch, it doesn't trigger duplicate identification process
to recreate the merge request.

- Restore rejected requests: After reviewing rejected requests, you can correct the rejection reason and then
restore rejected requests by clicking Restore on the Review Merge Request page. You can either select a
different master record or remove certain records from the merge request and submit the merge request for
reprocessing.

How you Consolidate Confirmed Duplicate Records

If you know for sure that two or more records are confirmed duplicates, you can create a request to consolidate them
from the Create Resolution Request Ul page.

Consolidating confirmed duplicate records involves the following tasks:
- Identify duplicate records
- Select duplicate resolution request type such as merge or link

- Create and submit the resolution request

Note: Groovy scripts on relationship objects don't run during merges. If they're critical, you can re-implement the
scripts on the parent account or account.

Merge Confirmed Duplicate Records

You can merge confirmed duplicate records by creating and submitting a merge request from the Create Resolution
Request Ul page as follows.

Note: In this procedure you select the duplicates, which is quite unlike system merge in which the matching
configuration selects duplicates.

1. Navigate to the Duplicate Resolution work area as follows: Navigator > Customer Date Management >
Duplicate Resolution.

2. Click the Tasks menu and then click Create Resolution Request.

3. Provide the search criteria to search for the records that you want to merge. For example, select the Party Type
as Person and type the Name as John.

4. C(lick Search.

5. From the search results, using the Shift or Control keys, select the records that you want to merge.

6. Click Actions > Create Request.

7. Provide a name for the request in the Create Request: Select Type dialog box.

8. Select the request type as Merge (Request to physically merge records into one record.).

I Note: You can select the request type as Link, if you want to link the records.
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9. Optionally, select a master record.
10. Click OK.

You can see a message that the duplicate resolution request was submitted. The merge happens immediately
if the data governance profile: User merge requests is set to Allow Processing Without Approval. If the profile is
set to Process Subject to Approval, the merge is reviewed and processed later by a data steward.

11. Click Done.

Why You Link Duplicate Records

You use linking to associate two or more duplicate records while resolving duplicate records. This association only
creates a link between the records and doesn't affect the records. You use this association, which has a unique ID, to
refer to the member records of a link.

You can also create links for normal records even if they aren't duplicate records. In a link, you designate one of the
records as the master and the others as duplicates. This helps users identify the master records for use in transactions.

During merge, duplicate records are combined into a single master record. However, some parties can't be merged
because of functional or legal reasons. For example, for certain bank operations, you can't merge duplicate records from
different business units or geographical regions. In these scenarios, we create a link between duplicate records instead
of merging them.

Alink doesn't change the party and the associated child entities such as addresses, contact points, and relationships. A
link doesn't affect the transactional processing of the record. The link is a separate record in the data model, and has its
own registry ID.

Related Topics
- Manage Links

« How do | create duplicate resolution requests?

Manage Links

You can manage links that are created either by duplicate resolution requests or by a data steward in the Manage Links
page. Data stewards create links to resolve duplicate parties by manually linking them without a duplicate resolution
request on the Create Link page.

You can access the managing links functionality by clicking on Manage Links on the Duplicate Resolution work area or
by clicking Linked Parties on the Organization, Persons, or Groups work area.

Create Links

To create links:

1. Navigate to the Manage Links page as follows: Navigator > Customer Data Management > Duplicate
Resolution > Tasks.

2. Select Create from the Actions menu.
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3. Inthe Create Link page, enter the details about the link.

4. Inthe Link Members area, select and add two or more parties that you want to link by selecting Add from the
Actions menu. You must select one of the parties as the master.

5. Click Save and Close.

Update Links

To update links:

1. Navigate to the Manage Links page as follows: Navigator > Customer Data Management > Duplicate
Resolution > Tasks

2. Search for the link that you want to update. You can search by entering criteria such as link identification
number, status, description, or the names of member record. You must select the Master Party Type to search
for links.

3. Select the link you want to update from the Search Results region and click Edit.

Optionally, you can also delete a link by selecting the link and clicking Delete.

4. Inthe Edit Link page, you can add link members, remove link members, and change the master record of the
link.

Note: If you remove the members of a link, you can't restore them. To restore a link member, you must add it
again to the link.

5. Click Save and Close.

Related Topics
» Why You Link Duplicate Records

How do you automatically link duplicate records?

You can create a duplicate identification batch and define subset rules to retrieve a subset of the records to identify
duplicates within the batch or in the database.

The auto linking task involves the following two steps:

1. Create a duplicate identification batch and select Create link request for all records as the automatic processing
option.
2. Perform the task Run Request Dispatch Job to disposition the duplicate resolution sets.

Create a duplicate identification batch and a subset rule

We first proceed to creating a duplicate identification batch. To do this, you can specify the criteria for retrieving a
subset of records in the duplicate identification batch. This is known as defining Subset rules, which are also known as
Batch Selection Criteria rules. The data quality engine identifies potential duplicates from this subset of records based
on one of these rules:

Match all keywords: Select this option to perform an AND operation.

Match any keyword: Select this option to perform an OR operation.
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Now that you have an overview of the task, let's first create a duplicate identification batch to identify duplicate
organizations in the registry, and then create a rule to retrieve a subset of records where the organization was created
after 6 June 2024. Note that you can use predefined or custom attributes.

1. Click Navigator > Customer Data Management > Duplicate Identification.
2. Click the Create button.

The Create Duplicate Identification Batch page appears.
3. Enter a batch name and description.

Note: Another way is to copy an existing duplicate identification batch and quickly create a new batch from
it. You can modify the details for this batch before submitting it.

4. Specify the Batch Match Mode such as Against the Registry or Within the Batch.

In the Within the Batch Match mode, the duplicate identification is limited to the records in a batch that meet
the subset rule conditions. In the Against the Registry Batch Match mode, the process aggregates the records
that meet the subset rule conditions in a batch, and these records are matched against one another as well as
against other records in the database.

5. Select the Party Type as Organization.

Select the Automatic Processing Option as Create link request for all records.

7. Provide the Batch Options. The batch options available depends upon the selected Automatic Processing
Option. The following options are available when Create link request for all records is selected as the Automatic
Processing Option:

o Select an appropriate value for Cluster Key Level such as Typical.

o

o Enter a value between 1and 101, such as 70 for Match Threshold.
o Enter a value between 1and 101, such as 75 for Autolink Threshold.

Note: You need to keep in mind that the Autolink Threshold values that you provide in the Batch
Options area override the values set in the Manage Customer Hub Profile Options page.

8. C(Click Add menu option or button under Duplicate Identification Batch: Selection Criteria.
9. Specify the Apply Rules option as Match any keyword.
10. Enter the following sample information in the Duplicate Identification Batch: Selection Criteria table:

Duplicate Identification Batch: Selection Criteria

Object Attribute Operator Value

Organization Creation date After 6 June 2024

11. Click Save and Close or Schedule per your requirement.

Run Request Dispatch Job

We will now proceed to running the request to disposition the duplicate resolution sets.

The dispatch job processes any resolution request in Pending or Submitted status. You can run this job in two modes:

- On demand: Submit request dispatch jobs directly from the Duplicate Resolution work area by selecting the
batch and clicking the Dispatch button. This submits the job for immediate processing.

Per a specific schedule: Do the following steps to set up a recurring job using the Run Request Dispatch Job. A
setup user can access the Run Request Dispatch Job task in the Setup and Maintenance work area.
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a. Click the Advanced button on the Run Request Dispatch Job page.
b. Click Schedule tab and select the Using a Schedule radio button.
c. Select the frequency you want and click Submit.

To see the list of dispatch jobs, and their statuses, navigate to Tools > Scheduled Processes.

Create Duplicate Identification Batches and Define Subset Rules

You can create a duplicate identification batch and define subset rules to retrieve a subset of the records to identify
duplicates within the batch or in the database.

Subset rules, also known as batch selection criteria rules, specify the criteria for retrieving a subset of records in the
duplicate identification batch. The data quality engine identifies potential duplicates from this subset of records based
on one of these rules:

Match all keywords: Select this option to perform an AND operation.

Match any keyword: Select this option to perform an OR operation.

Now that you have an overview of the task, let's first create a duplicate identification batch to identify duplicate persons
in the registry, and then create a rule to retrieve a subset of records where the person name contains John and the
address contains Redwood. Note that you can use predefined or custom attributes.

1. Navigate to the Duplicate Identification work area as follows: Navigator > Customer Data Management >
Duplicate Identification .

2. Click Create menu option or button. The Create Duplicate Identification Batch page appears.

3. Enter a batch name and description.

Note: Another way is to copy an existing duplicate identification batch and quickly create a new batch from
it. You can modify the details for this batch before submitting it.

4. Specify the Batch Match Mode such as Against the Registry or Within the Batch.

In the Within the Batch Match mode, the duplicate identification is limited to the records in a batch that meet
the subset rule conditions. In the Against the Registry Batch Match mode, the process aggregates the records
that meet the subset rule conditions in a batch, and these records are matched against one another as well as
against other records in the database.

5. Specify the Party Type as Person.

Specify the Automatic Processing option as Create Merge Request to merge the duplicate persons.

7. Provide the Batch Options. The batch options available depends upon the selected Automatic Processing
Option. The following options are available when Create Merge Request is selected as the Automatic
Processing Option:

o

o Select an appropriate value for Cluster Key Level such as Typical.
o Enter a value between 1and 101, such as 70 for Match Threshold.
o Enter a value between 1and 101, such as 75 for Automerge Threshold.
Note: You need to keep in mind that the Automerge Threshold and Autolink Threshold values that

you provide in the Batch Options area override the values set in the Manage Customer Hub Profile
Options page.
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o Select Send Notifications to notify the status of the duplicate identification batch to all interested

parties such as initiator or submitter. For more information about these statuses, see How You Merge
Duplicate Records in the Related Topics section. The default value for the Send Notifications field is
set using the Merge Request Notifications option in the Manage Customer Data Management Options
Setup and Maintenance task. You can't set the value of the Send Notifications field if the Merge Request
Notifications option is set to disable all notifications. For more information about Merge Request
Notifications, see Duplicate Resolution Simplified Profile Options topic in the Related Topics section.

8. C(lick Add menu option or button under Duplicate Identification Batch: Selection Criteria.

9. Specify the Apply Rules options as Match any keyword.

10. Enter the following sample information in the Duplicate Identification Batch: Selection Criteria table:

Object Attribute Operator Value
Person Name Starts with John
Address Address Line 1 Contains Redwood

11. Click Save and Close or Schedule per your requirement.

Related Topics
« Automerge
- How do | merge duplicate records?
» Customer Hub Profile Options

Run the Request Dispatch Job

The Dispatch Job processes duplicate resolution requests in Pending or Submitted status. Run this process to manage
and monitor resolution requests. Running the Dispatch Process You can run this job in two modes:

- On demand. Complete the following steps to run the job on an ad-hoc basis:

a. Open the Run Request Dispatch Job task from the implementation project. Alternatively, in the Setup and
Maintenance work area, go to the following:
- Offering: Customer Data Management
- Functional Area: Customer Hub
- Task: Run Request Dispatch Job
b. Click Submit and make a note of the Process ID.

- Per a specific schedule. Do the following steps to set up a recurring job:

a. Open the Run Request Dispatch Job task from the implementation project. Alternatively, in the Setup and
Maintenance work area, go to the following:
- Offering: Customer Data Management
- Functional Area: Customer Hub
- Task: Run Request Dispatch Job
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b. Click Advanced on the Run Request Dispatch Job task.
c. Click Schedule tab and select the Using a Schedule radio button.
d. Select the frequency and start date that you want and click Submit and make a note of the Process ID.

Review the Status of the Process
To see the list of dispatch jobs, and their statuses:

1. Go to the Tools section on the Navigator.
2. Click the Scheduled Processes link under Tools.

3. Use the Process ID that you noted earlier to search and view the status of the Schedule Duplicate Resolution
Requests process.

Manage Links in Redwood Sales

How do you manually link duplicate records?

As a sales administrator, you can resolve duplicate accounts by manually linking the individual account records that you
have determined as duplicates.

Here's how you manually link duplicate records:

Go to Navigator > Redwood Sales > Accounts.

Drill down to any account.

Search for Add Duplicate Account using the action bar.

Select a record from the picker on the Add Duplicate Account popup.

P WNa

Note: Filter the accounts list by using the ellipses (...) beside the picker.

5. Click Add.

View the list of duplicate accounts on the sales accounts page

An account can link to one or more duplicate accounts.

You can view the list of duplicate accounts by following these steps:

1. Go to Navigator > Redwood Sales > Accounts
2. Drill down to any account.

The main record and up to five duplicates are displayed.
3. Click View All Duplicate Accounts on the Duplicate Accounts panel.

All the duplicates of the selected account are displayed.
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View the consolidated list of sales transactions on the Sales
Accounts page

An account is associated with other transactions, such as opportunities, lead, asset, sales order, and so on.
Here's how you view the consolidated list of sales transactions of a sales accounts:

1. Go to Navigator > Redwood Sales > Accounts.
2. Search and select an account.

All the transactions that belong to the selected account such as opportunities, lead, asset, sales order, and so
on are displayed.
3. Drill down on the account to view details.

How do you remove a sales account from the duplicate set?

You may have wrongly added an account to a list of duplicate sets. You have the choice to remove it from the duplicate
set.

Here's how you remove a sales account from a list of duplicate records:

1. Go to Navigator > Redwood Sales > Accounts.

Drill down to any account.

Click View All Duplicate Accounts on the Duplicate Accounts panel.
Scroll down to the required account.

Click the ellipses (...) under the Actions column and click Remove.

v hUN

The selected account is removed from the list of duplicates.

How do you promote a different sales account to be the main
account?

A particular account may be the main account in the list of duplicate accounts. Later, you may want to change the main
account for some business reason.

Here's how you promote an account as the main account:

Go to Navigator > Redwood Sales > Accounts.

Drill down to any account.

Click View All Duplicate Accounts on the Duplicate Accounts panel.
Scroll down to the required account.

Click the ellipses (...) under the Actions column and click Promote to Main.

A WND

The selected account is now the main account.
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How You Purge Duplicate Resolution Data

Legacy duplicate resolution data, such as resolution logs and legacy duplicate resolution batches and requests can
clutter the duplicate resolution work area and affect the performance of the application.

Use the Purge Duplicate Resolution Data scheduled process to purge the duplicate resolution data, such as resolution
logs and to delete duplicate resolution batches and requests. You can schedule this process from the Scheduled
Processes work area. You can navigate to this work area as follows:Navigator > Tools > Scheduled Processes .

This scheduled process lets you purge duplicate resolution data based on status and date range. You can specify the
status of the duplicate resolution requests to be purged, such as duplicate resolution requests in Completed, Error,
Pending, New, or Rejected status. You can also specify a date range by specifying the start and an end date to select
duplicate resolution requests to be purged. For more information, see: Submitting Scheduled Processes and Process
Sets: Procedure

Related Topics
« Submit Scheduled Processes and Process Sets

« Process Sets
« View Status and Other Details for Scheduled Processes

FAQs for Duplicate Resolution

Can | undo a merge of records after a merge has been completed?

Merges can't be reversed after they're completed. The merge process can be configured to require a review and explicit
submission before merge requests are processed to completion. Agreement rules can also be created to prevent the
completion of merge requests based on configurable logic.

Can linclude a member party in more than one link?

No. A member party can only participate in one link.

What happens if | include a record in a link?

Records participating in a link remain intact. Only an association is created between members of a link.
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Can | create a link without a duplicate resolution request?

Yes. Use the managing link functionality to create a link directly. You can access the managing links functionality by
clicking on Manage Links on the Duplicate Resolution Work Area.

Can |l include members of different party types in a link?

No. A link must contain members of the same party type.

Can | override system mapping for all types of duplicate resolution
request?

No. You can override system mapping only for duplicate resolution request of the type merge.

How can | access link information?

Use the managing links functionality to access link information. You can access the managing links functionality by
clicking on Manage Links on the Duplicate Resolution Work Area or by clicking Linked Parties in the Party Center.

How can | cancel a batch process?

You can cancel a batch process in the Scheduled Processes Overview page. You can navigate to this page as follows:
Navigator > Tools > Scheduled Processes. You must search for the batch process by its process ID, and then cancel the
batch process request.

How can | make sure that a merge request contains the latest
merge details?

Drill down the merge request, click Actions > Reprocess Merge on the Review Merge Request page to refresh the
details of the merge request. You can refresh the details of a merge request only when the merge request is in error,
rejected, or new statuses. Note that this option refreshes the details of the current merge request and doesn't trigger
another merge request. Also, if this merge request is created from a duplicate identification batch, it doesn't trigger
duplicate identification process to recreate the merge request.
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Why am | unable to assign duplicate resolution requests?

You must be logged in as a Data Steward Manager to assign duplicate resolutions requests. Data Steward Managers
assign requests in the Duplicate Resolution work area.

Why am | unable to reject duplicate resolution requests?

You must be logged in as a Data Steward or a Data Steward Manager to reject a request. Data Steward Managers can
reject any request. Data Stewards can reject only those requests that are assigned to them.

Why am | unable to process a particular duplicate resolution
request?

You can process duplicate resolution requests only if their status is New, and if the request type isn't link or merge. In
short, you can only process generic duplicate resolution requests that are in New status.
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10 Manage Hierarchy Information

Manage Hierarchy Information

How You Manage Hierarchies

A hierarchy captures the hierarchical relationships a party, such as a customer, has with other parties. This capability is
frequently used to capture your customer's corporate hierarchy and to show how headquarters, branches, subsidiaries,
and so on are related.

It can be used to capture the hierarchy of any entity, such as a prospect, supplier, or partner, and not just of customers.
Organizing customer data as hierarchies offers the following advantages:

- Enables you to understand and get a better view of your customer's organization.
- Enables you to better analyze customer-related data.
- Application modules using the hierarchy can use hierarchies to roll up transactions, and apply business rules.

You can leverage the hierarchy of your customers in many business processes. For example, the territory management
functionality uses customer hierarchy information to define account dimensions. Financial applications use customer
hierarchy information to process payments from one customer and apply them to another customer in the same
hierarchy. The revenue roll-up report uses customer hierarchy information to roll up revenue numbers from
opportunities across all customers in a hierarchy.

Oracle Cloud Applications have a common framework to manage various hierarchies called the Tree framework. The
party hierarchy uses this common framework.

Here are the predefined hierarchy types:

- HZ_CUSTOMER_HIERARCHY: This predefined tree structure is used to maintain a hierarchy among sales
prospects, sales accounts, legal entities, and customers.

- HZ_DNB_HIERARCHY: This predefined tree structure is used for maintaining the Dun & Bradstreet corporate
hierarchy.

- HZ_PARTY_HIERARCHY: This predefined tree structure is used for maintaining party hierarchies such as the
organization and person hierarchies.

You can create or modify hierarchies, using the Manage Hierarchies Ul. You can access the Manage Hierarchies Ul as
follows:

Navigator > Customer Data Management > Hierarchies

Create Hierarchies
To create hierarchies:

1. Navigate to the Manage Hierarchies Ul.
2. C(lick the Create option or button on the Actions menu. The Create Hierarchy: Enter Basic Information page
appears.
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3.

7.

8.

Complete the mandatory fields. You can use the following sample data:
o Hierarchy Name: Green Corp.
o Hierarchy Type: Customer Hierarchy
o Hierarchy Status: Active
o Effective Start Date: Enter appropriate date and time.

Click Next. The Create Hierarchy: Add Parties page appears.
Click the Add option or button on the Actions menu. The Add Tree Node pop-up appears.
Select one of the following as the Tree Node Type:

o Specific value
o Values from referenced hierarchy

Click Next. The Create Hierarchy: Review page appears. Verify the hierarchy information and click Back to make
any modifications.

Click Finish to complete creating the new hierarchy.

Edit Hierarchies
To edit hierarchies:

WN=

v oA

Navigate to the Manage Hierarchies Ul.
Search and select the hierarchy you want to edit.
On the Actions menu, select one of the following options:

o Edit Hierarchy Version: Lets you make the changes to the hierarchy available immediately.
o Create New Version: Lets you make the changes to the hierarchy available at a later point in time.

Click Add or Remove option or button on the Actions menu as required to update the tree nodes.
Click Save and Close to complete editing the hierarchy.

Hierarchy Validation Rules

Hierarchy validation rules ensure that newly created or updated hierarchies are properly structured. These rules are run
each time you create or modify hierarchies.

All hierarchy types, including the predefined hierarchy types: Party Hierarchy, Dun and Bradstreet Hierarchy, and
Customer Hierarchy, enforce the following validation rules in active versions of customer hierarchies.

- A hierarchy can't contain a merged party.

- A hierarchy can contain parties with only certain party usages such as sales account, sales prospect, (internal)

legal entity, external legal entity, and buying customer. A buying customer is also considered as an external
legal entity.

If a party is an external legal entity, its parent can only be an external legal entity.
If a party is an (internal) legal entity, its parent can only be a (internal) legal entity.

If a party isn't an external legal entity or (internal) legal entity, its parent can only be an eligible customer. For
example, a sales prospect, sales account, external legal entity, (internal) legal entity or a buying customer.

- A party can be present in only one active tree across all trees in the customer hierarchy.
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If there are sales accounts organized in a customer hierarchy, all nodes in that hierarchy must be sales accounts.
Sales accounts that appear within larger sales accounts are called in-between sales account nodes.

- A Named Sales Account can only have named sales accounts as ancestors.

Note: 'Named'is a sales account attribute stored in the Sales Account Profile entity.

These validation rules are enforced in the Hierarchy Ul as much as possible while users select nodes to add to the
hierarchy. Also, a background audit job implements these rules to ensure that all hierarchies that don't pass the
validation are marked inactive.

Guidelines for Creating Hierarchies and Hierarchy Versions

While creating hierarchies, you have to decide whether you want to create a new hierarchy or use a new version of an
existing hierarchy.

When to Create a New Hierarchy
You can create a new hierarchy when any of the following is true:

- You have a new customer, and a new hierarchy is required to represent the corporate structure of the new
customer.

- Your existing customer has changed the structure of its organization radically. It is quicker and more efficient to
create a new version rather than edit the existing one.

When to Create a New Hierarchy Version
You can create a new version of a hierarchy when any of the following is true:

- You have minor changes to make to an existing version of a hierarchy, such as adding a new customer, or
removing or repositioning an existing customer in the hierarchy.

- You must make extensive changes to an active hierarchy, but want to render the changes active only when
they're all incorporated into the hierarchy. Then, create a new version of the hierarchy and set it to become
active after a reasonable window period. You can make all the required changes and have the new version
ready for activation by the scheduled date.

Guidelines for Editing Hierarchies and Hierarchy Versions

While editing a hierarchy, you must decide whether you want to edit the existing version of the hierarchy or create a new
one.

The changes you make to the existing version become active immediately, but the new versions of a hierarchy become
active only on the date on which the hierarchy becomes active.

Edit Active Hierarchies

When you edit the existing version of a hierarchy, the changes are saved instantly and are available to users even as you
edit them. However, you can't cancel any changes while editing existing hierarchy versions.
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Two ways to deal with the changes while editing active hierarchies are:

- You can render hierarchies inactive before you edit them. Once you have made your changes, you can change
their status to active again.

Note: The hierarchy isn't available to users while it's inactive.

- You can create a new hierarchy version and set it to be active the next day. Thus, while the existing version is
active, you can make your changes to the new version and activate it the next day.

Edit Merged Hierarchies

The merge process consolidates the duplicate parties and updates the hierarchies to which these parties belong. If
the updates to the hierarchies done by the merge process aren't as expected, then edit the updated hierarchies in the
Manage Hierarchy Types task.

Related Topics
« How do | merge duplicate records?

FAQs for Manage Hierarchy Information

How can | create a new hierarchy type?

You can create a new hierarchy type using the Manage Tree Structures task. Select Trading Community Model as the
application, an existing data source or new custom data source, and any labeling scheme you want. The next step is to,
enter the other required details, such as the appropriate usage of the new hierarchy type. Note that tree structures don't
support the Date Range, Allow Multiple Root Nodes, or the Reference Data Set options for the Restrict Tree Node List of
Values Based on field. Tree structure only support fixed values. Finally, add the newly created hierarchy type under the
Party Hierarchy Type lookup to include the new hierarchy type in the lookups for hierarchy types.

Can | create multiple versions of the same hierarchy?

Yes. You must ensure that the date on which the new version is active doesn't overlap with the date of any existing
active version of the same hierarchy.

How can | respond to a merge completion notification if | don't
have the privileges to edit hierarchies?

If you don't have the privileges to edit hierarchies, reassign the merge completion notification to a user with the
appropriate privileges. So, if you're a sales person you can reassign a merge completion notification to the Sales
Administrator.
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Why is the hierarchy type | created not visible in the Manage
Hierarchy UI?

When you create a hierarchy type, you must also update the list of hierarchy lookups. You can't use the new hierarchy
type, unless you have updated the hierarchy lookup list.

You can update the list of hierarchy types using the Manage Hierarchy Lookups task. Select Party Hierarchy Type
(PARTY_HIERARCHY_TYPE) lookup type to edit. Add the new hierarchy type to the Party Hierarchy Type lookup type.
After updating the list of hierarchy type lookups and saving your changes, you can view the new hierarchy type under
the list of hierarchy types.

Why is an active hierarchy version that has been saved recently
sometimes set automatically to inactive?

The newly edited hierarchy is saved as an auto-commit process, even before you save and close it. The application
triggers the tree flattening service and the audit job, when you save and close your changes. It doesn't wait for the job
to complete, and notifies you to revisit the version after the audit job is complete, to check the version status of the
hierarchy.

If the audit job identifies any errors at the time of hierarchy validation, then the status of the hierarchy is set to Inactive.
However, the application doesn't notify you of this. You must revisit the hierarchy management interface and rectify
issues in the previously saved version, if the status is inactive.

What's the table name and the column name where Hierarchy
Name of customer or party hierarchies is stored?

You must refer to the TREE_NAME column of the FND_TREE_VL table for hierarchy names.
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11 Information Protection

How You Work with Protected Information

In Oracle Cloud applications, your access to protected information depends on your job role. In case you don't have
access to the information you need to work with, contact the IT security manager for the necessary privileges.

Securing and protecting customer information against data breaches, data theft, or unauthorized access is an
increasing concern in any enterprise. To address this issue, Oracle Applications Cloud provides restricted access to
information that's considered private to an individual, also known as Personally Identifiable Information (PII).

Pl is any information that uniquely identifies an individual, such as personal phone number, personal email address,
personal address, citizenship number, or Social Security Number (SSN). You can use Pl data to uniquely identify,
contact, or locate an individual, or you can use it with other sources to uniquely identify a person. For example, a SSN
uniquely and directly identifies an individual, whereas a telephone area code identifies a set of people.

The attributes that are identified as PIl are as follows:

Home Address
Home Phone Number
Personal Email Address
- Taxpayer Identification Number (Social Security Number)

In Oracle Applications Cloud, access to the Pll data is restricted to a set of job roles. If you need to work with PIl data for
business purposes, then contact the IT security manager for the necessary privileges.

Related Topics
« Export Data
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12 View Audit Histories

Audit Reports

You can use the Audit Reports work area to view changes to the application data, such as the business objects that were
created, updated, and deleted.

To view the history or to create a report, you must have a role with the View Audit History
(FND_VIEW_AUDIT_HISTORY_PRIV) privilege assigned to it. For appropriate assignment of roles and privileges, check
with your security administrator.

Audit Events

Transactional events in the application trigger the audit process based on the create, update, and delete operations. For
events to trigger the audit process for the business objects, you must first enable the objects for auditing.

These are the events that trigger the audit process.

Transactional Event When the Audit Activity is Triggered Audit Report Content
Create Whenever business object data is created and + Name of the created object
stored in the database - Name of the user who created the object

Time of creation

Update Whenever the existing business object data is + Both old and updated values of the object
updated - Name of the user who updated the object

Time of updating

Delete Whenever the existing business object data is + Thelast value that the object attributes
removed from the database contained
Name of the user who deleted the object

The event details are stored in the audit table. The attributes of the audited object data can be used in lookups
and foreign keys to display values in the audit history. The application supports displaying the audited information
according to the language settings configured.

For Oracle Fusion Middleware products, events such as failed sign-in attempts are used as triggers. In absence of an
audit table, the information is stored in the sandbox and presented only in English.

Note: This topic focuses on the create, update, and delete event types available in Fusion Applications. For details on
events used in the Oracle Fusion Middleware products, refer to the Oracle Fusion Middleware documentation. See:
Introduction to Oracle Fusion Middleware Audit Framework

147
ORACLE


https://docs.oracle.com/en/middleware/fusion-middleware/12.2.1.5/faorg/introduction-oracle-fusion-middleware-audit-framework.html

Oracle Fusion Cloud Customer Experience Chapter 12
Using Customer Data Management (CDM) View Audit Histories

Related Topics
« View Audit Reports
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