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Overview
This document explains how to install or upgrade the Oracle Workflow and Oracle XML 
Gateway client components available with Oracle E-Business Suite. Oracle Workflow and 
Oracle XML Gateway provide the following client components that are installed using the 
Oracle Universal Installer from the Start Here disk:

• Oracle Workflow Builder

• Oracle Workflow Common Files

• Oracle Workflow HTML help

• Oracle XML Gateway Message Designer

• Oracle XML Gateway Message Designer HTML help

The Oracle Universal Installer and this installation guide are included on the Start Here disk. 
The disk includes the following directory structure and files: 

• Oracle Universal Installer - 
<drive_letter>:\WFEMB\wfclnt26\install\win32\setup.exe

• Installation Guide - <drive_letter>:\WFEMB\wfclnt26\wfinstcl.pdf, 
<drive_letter>:\WFEMB\wfclnt26\wfinstcl\toc.htm

Oracle Workflow Builder and Oracle XML Gateway Message Designer 
Hardware and Software Requirements

Oracle recommends that all components requiring direct connection to the Oracle E-Business 
Suite database be deployed on servers rather than on end user desktop clients. For the Oracle 
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Workflow and Oracle XML Gateway client components, Oracle recommends that they be 
deployed in a remote server environment using either Windows Server Terminal Services, 
Citrix, or Tarantella. For more information, see: Recommended Set Up for Client/Server Products 
with Oracle E-Business Suite 11i & R12 (My Oracle Support Document 277535.1).

Oracle Workflow Builder and Oracle XML Gateway Message Designer must be installed into 
an Oracle9i Release 2 (9.2) client Oracle Home directory. They require the following hardware
and software configurations.

Oracle Workflow Builder
Oracle Workflow Builder is a GUI tool that allows you to create and edit workflow definitions
on a PC running Microsoft Windows. A workflow definition can be saved to a flat file or to 
your Oracle E-Business Suite database through Oracle Net. Oracle Workflow Builder requires 
the following:

• Oracle Net Client Version 9.2.0.1 or higher (included in the Oracle Workflow Builder 
installation)

• Required Support Files Version 9.2.0.1 or higher (included in the Oracle Workflow 
Builder installation)

• Microsoft Windows Vista or Windows 7

• At least 65 Mb of available disk space to install Oracle Workflow Builder, Oracle Net, and 
Required Support Files

• At least 32 Mb of memory, 64 Mb recommended

Note: The Oracle TCP/IP Protocol Adapter requires and only supports the use
of Microsoft's TCP/IP drivers.

Oracle XML Gateway Message Designer
Oracle XML Gateway Message Designer is a wizard-guided, GUI-oriented, repository-based 
tool that allows you to create XML message maps on a PC running Microsoft Windows. 
Oracle XML Gateway Message Designer requires the following:

• Either JDK 1.1.8 or JRE 1.1.8 or higher (JRE 1.1.8 is included in the Message Designer 
installation)

• Microsoft Windows Vista or Windows 7

• At least 15 Mb of available disk space to install Oracle XML Gateway Message Designer, 
HTML help, and JRE 1.1.8



3

Installation Steps
Use Oracle Universal Installer to install Oracle Workflow Builder or Oracle XML Gateway 
Message Designer.

• To install on Microsoft Windows Vista or Windows 7, you must run the Oracle Universal 
Installer executable in Windows XP compatibility mode. You can either set the 
compatibility mode manually before running the installer, or let Windows set the 
compatibility mode when you begin running the installer, as described below. For more 
information, see: Recommended Set Up for Client/Server Products with Oracle E-Business Suite 
11i & R12 (My Oracle Support Document 277535.1).

• If you are installing products onto Windows Terminal Server and you are not using 
Remote Administration mode, you may first need to place the system into the Windows 
Terminal Server install mode. For more information, refer to your Windows Terminal 
Server documentation or see: Recommended Set Up for Client/Server Products with Oracle 
E-Business Suite 11i & R12 (My Oracle Support Document 277535.1).

Note: Any variable input in the following commands is enclosed in brackets 
and is italicized. Replace these variables with the appropriate information 
specific to your environment.

Step 1. Install Oracle Workflow Builder or Oracle XML Gateway Message 
Designer using the Oracle Universal Installer:
1. If you are installing on Microsoft Windows Vista or Windows 7 and you want to set 

Windows XP compatibility mode manually, perform these steps. Otherwise, skip to step 
2.

• Insert the Start Here disk in the DVD-ROM drive of your PC.

• Navigate to the Oracle Universal Installer executable in Windows Explorer and 
right-click the executable.
<drive_letter>:\WFEMB\wfclnt26\install\win32\setup.exe

• Select 'Troubleshoot Compatibility'.

• In the Program Compatibility window, choose the 'Try recommended settings' 
option.

• Ensure that the Windows compatibility mode is set to 'Windows XP (Service 
Pack 2)' or 'Windows XP (Service Pack 3)'.

• Choose 'Start the program...'.

• If the User Account Control window appears with the message 'Do you want to 
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allow the following program from an unknown publisher to make 
changes to this computer?', select 'Yes'. 

• Skip to step 3.

2. Insert the Start Here disk in the DVD-ROM drive of your PC. Choose Run from the 
taskbar Start button and enter the following command to run the Oracle Universal 
Installer:
<drive_letter>:\WFEMB\wfclnt26\install\win32\setup.exe

If you are installing on Microsoft Windows Vista or Windows 7 and you have not yet set 
Windows XP compatibility mode, perform these additional steps.

• If the User Account Control window appears with the message 'Do you want to 
allow the following program from an unknown publisher to make 
changes to this computer?', select 'Yes'. 

• When the Oracle Universal Installer window begins to open, an Error window 
appears with the following message:
OUI cannot determine the platform of this system. This may occur if 
OUI is running on a system that is not supported or there is a bug in 
OUI. Please confirm that the system is a supported configuration; and 
if it is supported, then please contact Oracle Support.

Choose 'OK'.

• In the Program Compatibility Assistant window, select the 'Reinstall using 
recommended settings' option.

• If the User Account Control window appears with the message 'Do you want to 
allow the following program from an unknown publisher to make 
changes to this computer?', select 'Yes'. 

3. When the Oracle Universal Installer is started, the Welcome window appears. Choose 
Next.

Note: Choose Help in any Oracle Universal Installer window for more 
information about that window.

4. The File Locations window appears. Review the stage location of the Oracle Workflow 
Builder and Oracle XML Gateway Message Designer files, and enter the Oracle Home 
location where you want to install client components. Then choose Next.

5. The Available Products window appears. Select whether you want to install Oracle 
Workflow Builder or Oracle XML Gateway Message Designer . Then choose Next.

Note: When you install Oracle Workflow Builder, the Oracle Workflow 
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Common Files and the Oracle Workflow HTML help are automatically 
installed as well.

When you install Oracle XML Gateway Message Designer, its HTML help
is automatically installed as well. 

6. If you are installing Oracle Workflow components and you are installing Java Runtime 
Environment for the first time, the Component Locations window appears. Enter the 
destination location where you want to install Java Runtime Environment. Then choose 
Next.

7. The Summary window appears. Review the summary information to ensure you have 
enough disk space. When you are ready to begin the installation, choose Install.

8. The Install window appears, displaying the progress of the installation.

9. If you are installing Oracle Workflow components and you are installing Oracle Net 
Client for the first time, the Configuration Tools window appears when the installation is 
complete, and the Oracle Net Configuration Assistant automatically starts.

In the Oracle Net Configuration Assistant window, select a method by which to configure
client access to your Oracle database. The Oracle Net Configuration Assistant helps you 
configure your client access.

Note: Refer to the Oracle9i Client Installation Guide for more information 
about running the Oracle Net Configuration Assistant.

10. The End of Installation window appears. Choose Exit to exit the Oracle Universal 
Installer. You can also choose Next Install to return to the File Locations window and 
install another component.

Step 2. Set up the Oracle Workflow HTML help (optional):
When you install Oracle Workflow Builder, the Oracle Universal Installer copies a zip file 
containing the HTML help to the Oracle Workflow directory in your Oracle Home. The zip 
file is <ORACLE_HOME>\wf\wfdoc.zip. Before you can view the HTML help, you must 
extract the doc directory tree from the zip file to your file system.

1. Use an unzip utility to extract the doc directory tree from the zip file within the Workflow
directory. You need at least 7 Mb of free disk space to extract the zip file.

The doc directory tree that is created includes the Oracle Workflow documentation area, 
<ORACLE_HOME>\wf\doc, and the following subdirectories:

• <ORACLE_HOME>\wf\doc\<lang>\wf - Oracle Workflow online help. 

• <ORACLE_HOME>\wf\doc\<lang>\wfcust - Custom help. You can optionally add 
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your own customized Workflow help in this directory.

Note: You can also install the doc directory tree in a directory that you 
choose on your PC file system. Create a directory for the HTML help. 
Then transfer the HTML help zip file, wfdoc.zip, from the Workflow 
subdirectory within your Oracle Home to the new directory. Use an 
unzip utility to extract the doc directory tree from the zip file in that 
directory.

2. After extracting the doc directory tree, you can optionally remove the zip file.

3. You can now view the HTML help using a Web browser. 

The path for the contents page of the Oracle Workflow documentation is:
\<ORACLE_HOME>\wf\doc\<lang>\wf\toc.htm

The path for the contents page of your Oracle Workflow custom help is:
\<ORACLE_HOME>\wf\doc\<lang>\wfcust\wfcust.htm

You can also view context-sensitive help for Oracle Workflow Builder in Winhelp format 
by choosing Contents from the Help menu within Oracle Workflow Builder.

4. If you want to add custom help, you can replace the placeholder file in the wfcust 
directory, wfcust.htm, with your own help material. The HTM file that is the main entry
point for your custom help must be named wfcust.htm and must contain an anchor 
named contents. Your custom help will be accessible through the Custom Help link on 
the contents page of the Oracle Workflow online help.

Step 3. Modify fonts in Oracle Workflow Builder (optional):
If you are installing Oracle Workflow Builder in another language such as Japanese, you can 
modify the font used by the windows in Oracle Workflow Builder to a font that is appropriate
for your language. Any change you make applies to all windows within the program.

1. Choose Font from the View menu to display the Fonts properties page.

2. Choose Font from the View menu to display the Fonts properties page.

3. Select the font style: Regular, Bold, Italic, or Bold Italic. Some fonts have a limited 
selection of font styles.

4. Select the font size to use. Some fonts have a limited selection of font sizes.

5. Select the Underline or Strikeout check boxes to apply those effects.

6. Choose OK when you are finished.

7. Close and restart Oracle Workflow Builder. The new font settings should then take effect.
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Step 4. View the Oracle XML Gateway Message Designer HTML help (optional):
When you install Oracle XML Gateway Message Designer, the Oracle Universal Installer 
automatically installs the Message Designer HTML help as well. The HTML help is located in 
the ecx\help subdirectory within your Oracle Home. You can view the help by choosing 
Help Topics from the Help menu within Oracle XML Gateway Message Designer, or you can 
access the help directly using a Web browser. The path for the contents page of the Message 
Designer help is:
\<ORACLE_HOME>\ecx\help\ecxmdtoc.htm

Step 5. Deploy Oracle Workflow Builder or Oracle XML Gateway Message 
Designer on a server:
Oracle recommends that you deploy Oracle Workflow Builder and Oracle XML Gateway 
Message Designer in a remote server environment using either Windows Server Terminal 
Services, Citrix, or Tarantella. To help ensure a secure environment, you should allow users to
access the required client component only through a 'dumb' window, rather than allowing 
desktop access.

• When using Citrix or Tarantella, specify the startup program for Oracle Workflow Builder
or Oracle XML Gateway Message Designer within the object or published application file.

• When using Windows Server Terminal Services, specify the startup program for Oracle 
Workflow Builder or Oracle XML Gateway Message Designer in the user properties on 
the Windows server where the client software is installed.

The startup programs for Oracle Workflow Builder and Oracle XML Gateway Message 
Designer are located in the following subdirectories in your Oracle Home:

• Oracle Workflow Builder - <ORACLE_HOME>\bin\WFBLDR.EXE

• Oracle XML Gateway Message Designer - <ORACLE_HOME>
\ecx\MessageDesigner.bat

The following sections provide some steps to specify a startup program for a user on a 
Windows server. For more information about deploying on Windows Server Terminal 
Services, Citrix, or Tarantella, consult your server documentation.

To specify a startup program for a user on Windows Terminal Server 2003
1. Sign on to Windows Terminal Server as a user with administrative privileges.

2. Navigate to Start > All Programs > Administrative Tasks > Computer Management > 
System Tools > Local Users and Groups > Users.

3. From the Action menu, select New User.

4. Enter the user name and any other details as required, and choose the Create button.

5. Double-click the newly created user.
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6. In the User Properties window, select the Environment tab, and select the 'Start the 
Following Program at Login' option. 

7. In the Program File Name field, enter the path to the appropriate startup program, either 
Oracle Workflow Builder or Oracle XML Gateway Message Designer, as listed above.

8. In the User Properties window, select the Member Of tab, and add the group 'Remote 
Desktop Users'. You can optionally remove the default 'Users' group.

To specify a startup program for a user on Windows Terminal Server 2000
1. Sign on to Windows Terminal Server as a user with administrative privileges.

2. Navigate to Start > Programs > Administrative Tasks > Computer Management > System 
Tools > Local Users and Groups > Users.

3. From the Action menu, select New User.

4. Enter the user name and any other details as required, and choose the Create button.

5. Double-click the newly created user.

6. In the User Properties window, select the Environment tab, and select the 'Start the 
Following Program at Login' option. 

7. In the Program File Name field, enter the path to the appropriate startup program, either 
Oracle Workflow Builder or Oracle XML Gateway Message Designer, as listed above.

To specify a startup program for a user on Windows NT Server
1. Sign on to Windows NT Server as a user with administrative privileges.

2. Navigate to Start > Programs > Administrative Tools > Administrative Wizards > Add 
User Account.

3. Select the appropriate domain name and choose Next.

4. Enter the user name and choose Next.

5. Enter the password and choose Next.

6. In the Add User Account Wizard, select the Users group and choose the Add button. 
Then choose Next.

7. Add any configuration options as required, and choose Next. 

8. Add any restrictions as required, and choose Next.

9. Choose Finish to complete the process of adding a new user.
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10. Navigate to Start > Programs > Administrative Tools and open the User Manager 
window. 

11. Select the user name, and choose User > Properties from the menu.

12. In the User Properties window, select the Config button.

13. In the Initial Program region of the User Configuration window, deselect the 'Inherit 
client config' option.

14. In the Command Line field, enter the path to the appropriate startup program, either 
Oracle Workflow Builder or Oracle XML Gateway Message Designer, as listed above.

Step 6. Assign user privileges:
To help ensure a secure environment, Oracle recommends that you assign users only User 
privileges on the server where Oracle Workflow Builder or Oracle XML Gateway Message 
Designer is installed, rather than Administrator privileges.

However, if you deploy Oracle Workflow Builder on a Windows Terminal Server 2003 or 
Windows Terminal Server 2000 platform, you can assign users Power User privileges to grant 
them full access to Oracle Workflow Builder. On these platforms, users with only User 
privileges cannot access Developer Mode or the online help within Oracle Workflow Builder. 
Additionally, to enable the Oracle Workflow Builder templates and icons for those users, you 
must copy the template files from the <ORACLE_HOME>\wf\DATA\US directory and the icon 
files from the <ORACLE_HOME>\wf\ICON directory to the root directory of the drive where 
you installed Oracle Workflow Builder. For example, the root directory may be C:\. 

Known Issues
This section lists known issues for the Oracle Workflow Builder installation and possible 
workarounds for those issues.

In some cases you may see the following error message during the installation: "Error 
encountered when registering <filename>, please run regsvr32.exe 
manually to register this file after the installation completes." For 
example, you may see this error for the wfnvg.ocx file.

If you encounter this error, close the error message and proceed with the installation. After 
the installation is complete, register the specified file manually by running the following 
command from a DOS prompt:
regsvr32 <path>\<filename>

Replace <path> with the path to the file and <filename> with the name of the file to 
register. The wfnvg.ocx file is normally located in the <ORACLE_HOME>\bin directory.

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility 
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Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc. 

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired. 

Legal Notices
This software and related documentation are provided under a license agreement containing 
restrictions on use and disclosure and are protected by intellectual property laws. Except as 
expressly permitted in your license agreement or allowed by law, you may not use, copy, 
reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish,
or display any part, in any form, or by any means. Reverse engineering, disassembly, or 
decompilation of this software, unless required by law for interoperability, is prohibited. 

The information contained herein is subject to change without notice and is not warranted to 
be error-free. If you find any errors, please report them to us in writing. 

If this is software or related documentation that is delivered to the U.S. Government or 
anyone licensing it on behalf of the U.S. Government, the following notice is applicable: 

U.S. GOVERNMENT END USERS: Oracle programs, including any operating system, 
integrated software, any programs installed on the hardware, and/or documentation, 
delivered to U.S. Government end users are "commercial computer software" pursuant to the 
applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As 
such, use, duplication, disclosure, modification, and adaptation of the programs, including 
any operating system, integrated software, any programs installed on the hardware, and/or 
documentation, shall be subject to license terms and license restrictions applicable to the 
programs. No other rights are granted to the U.S. Government. 

This software or hardware is developed for general use in a variety of information 
management applications. It is not developed or intended for use in any inherently dangerous
applications, including applications that may create a risk of personal injury. If you use this 
software or hardware in dangerous applications, then you shall be responsible to take all 
appropriate fail-safe, backup, redundancy, and other measures to ensure its safe use. Oracle 
Corporation and its affiliates disclaim any liability for any damages caused by use of this 
software or hardware in dangerous applications. 

This software or hardware and documentation may provide access to or information on 
content, products, and services from third parties. Oracle Corporation and its affiliates are not
responsible for and expressly disclaim all warranties of any kind with respect to third-party 
content, products, and services. Oracle Corporation and its affiliates will not be responsible 
for any loss, costs, or damages incurred due to your access to or use of third-party content, 
products, or services. 
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