4Configuring Financial Reporting

This chapter contains the following:

Configuring Financial Reporting: Overview

Configure the following financial tools to report and analyze your accounting data: Financial Reporting Center, Smart View, Financial Reporting Studio, and Workspace.

Financial Reporting Center: How It Works

The Financial Reporting Center is intended to be the primary user interface for financials end users to access all seven report types.

Financial Reporting Center Overview

The main components in the Financial Reporting
Center are Financial Reporting Studio Reports, Account Groups and
Sunburst, Smart View Reports, Oracle Transactional Business Intelligence
Analyses, Oracle Transactional Business Intelligence Dashboards, Oracle
Business Intelligence Publisher Reports, and BI Mobile Apps.

Reports can be accessed through various methods. However, the Financial Reporting Center provides access to every type of report, is intended to be the primary user interface for financials end users, and is tablet and smartphone friendly.

Financial Reports are read from the Shared > Custom > Financials and My Folders directories. All other report types can be saved anywhere in the BI Catalog however, any custom content should be in the Shared > Custom folder. Subfolders can be created within the Shared > Custom folder.

Seven types of reports can be run from the Financial Reporting Center and from the other reporting tools.

  • Financial Reports: These reports are built off of the Oracle Financial Reporting Studio using data in the Oracle Fusion General Ledger balances cube. For example, company income statements and balance sheets. These reports are mainly run by users in General Ledger.

  • Account Groups and Sunburst: Account groups are used to monitor key accounts in General Ledger. When a user creates an account group, it becomes visible in the Financial Reporting Center with the Sunburst visualization tool. The Sunburst visualization tool lets you interact with your account balances across various business dimensions to view balances from different perspectives. Account groups are used only in General Ledger.

  • Smart View Reports: Smart View is a multidimensional pivot analysis tool combined with full Excel functionality. Smart View enables you to interactively analyze your balances and define reports using a familiar spreadsheet environment. These queries are mainly for users in General Ledger. To share Smart View queries, users can e-mail them to other users, or they can upload the queries to the Financial Reporting Center where users can download them to a local drive for use. The Financial Reporting Center is only a place for users to upload and download Smart View queries.

    Note: To upload a Smart View report to the Financial Reporting Center: select the Open Workspace for Financial Reports task, navigate to the BI Catalog, and select Upload from the Tasks section in the left-hand pane. Be sure to upload the Excel file to one of the folder locations mentioned previously.
  • Oracle Transactional Business Intelligence Analyses: These analyses and reports are built off of transactional tables using subject areas. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • Oracle Transactional Business Intelligence Dashboards: Dashboards put all the information, functions, and actions that a business user must have to do their job in one place. Dashboards are built off of Oracle Transactional Business Intelligence objects like analyses and reports. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • Oracle Business Intelligence Publisher Reports: Most of these reports are predefined and must first be submitted and resubmitted to see the latest data by the Oracle Enterprise Scheduler system through the Scheduled Processes navigation. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • BI Mobile Apps: Oracle Business Intelligence Mobile App Designer is an application that enables you to create multitouch information-driven applications with rich interaction, rich visualization, and rich media, for mobile devices such as iPhone, iPad, Android phone, tablet, and more. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

Other Reporting Tools Overview

Six other tools are available for reporting in Financials.

The following table lists the tools and report types.

Other Reporting Tools Report Type

General Accounting Dashboard and Account Inspector

Account Groups

Reports and Analytics

Oracle Transactional Business Intelligence Objects

BI Catalog

All Report Types, Except Oracle Business Intelligence Publisher Reports

Enterprise Performance Management Workspace

Reports, Books, Snapshot Reports, Snapshot Books, Financial Reporting Batches, and Batch Scheduler

Enterprise Scheduler System

Oracle Business Intelligence Publisher Reports

Even though the Financial Reporting Center is designed to be the main user interface for a financial end user's reporting needs, some users may choose to use any of the six other tools for reporting in financials, such as:

  • General Accounting Dashboard, which provides access to Account Groups: Uses the Account Monitor to efficiently monitor and track key account balances in real time.

  • Account Inspector: Perform ad hoc queries from account groups and financial reports through drill down to underlying journals and subledger transactions.

  • Reports and Analytics: This reporting tool has a panel that reflects the folder structure of the BI Catalog. Users can access and run any Oracle Transactional Business Intelligence analysis, report or dashboard. Users can't run Financial Reports or Oracle Business Intelligence Publisher reports from this interface. This interface can be used by all financials users.

  • BI Catalog: A component of the Enterprise Performance Management Workspace where you can run all report types, except for Oracle Business Intelligence Publisher reports.

  • Enterprise Performance Management Workspace: Create reports, books, snapshot reports, snapshot books, Financial Reporting batches, and batch scheduler, and schedule batches to automatically run and burst to e-mail.

  • Enterprise Scheduler System: Only Oracle Business Intelligence Publisher reports can be submitted from this interface. Users access this interface by navigating to Tools > Scheduled Processes. Most financial users have access to this interface to run standard reports for General Ledger, Payables, Receivables, and so on.

Define Financial Reporting Center

Oracle Fusion Financial Reporting Center is a powerful tool for accessing, designing, and presenting financial reports and analytic data.

Configure Financial Reporting Center

You have access to the reports through the folder structure in the Financial Reporting Center and Workspace installed with Oracle Fusion Financials. Your Oracle Fusion Business Intelligence (BI) administrator defines the folder structure in Workspace taking into consideration your company's security requirements for folders and reports, as well as report distribution requirements for financial reporting batches.

Security can be set on folders and reports from Workspace. BI Catalog stores both the Financial Reports and the BI Publisher Reports. You are granted access to the folders and reports you need to view by your BI administrator.

Create and Secure Folder Structure

To create a folder or sub-folder:

  1. Navigator > Financial Reporting Center.

  2. From the Financial Reporting Center task panel, select Open Workspace for Financial Reporting.

  3. From within Workspace select the Navigator > Applications > BI Catalog.

  4. On the Oracle BI Catalog page, go to the desired location in the Folders panel.

  5. In the Oracle BI Catalog tool bar, click New and select Folder.

    Select the Folder option to create a new folder.
  6. The New Folder dialog is displayed. Enter the folder name.

    Enter the name of your folder.
  7. OK.

To assign permissions to a folder:

  1. Navigator > Financial Reporting Center.

  2. From the Financial Reporting Center task panel, select Launch Workspace.

  3. From within Workspace select the Navigator menu > Applications > BI Catalog.

  4. Search for the folder to which you want to assign permissions.

  5. Go to the Tasks panel and click Permissions. The Permission dialog is displayed.

    The Permissions dialog box list the current permissions
and provides icons to add or delete permissions.
  6. Click the Add users/roles button.

  7. In the Add Application Roles, Catalog Groups and Users dialog box, query the roles and select those desired. In this example, select General Ledger Functional Administration Duty and General Ledger and Profitability Managerial Duty.

    Select General Ledger Functional Administration Duly
and General Ledger and Profitability Managerial Duty.
  8. Click the Move button.

  9. Set Permission to the level desired. In this example, select Full Control.

  10. OK.

Configure Smart View Client for Users

Smart View is a multidimensional pivot analysis tool combined with full Excel functionality. Smart View enables you to interactively analyze your balances and define report using a familiar spreadsheet environment.

Load Smart View, an Excel add-in, to each client computer. To download the installation files from Workspace:

  1. Navigator > Financial Reporting Center > Open Workspace for Financial Reports.

  2. In Workspace: Tools > Install > Smart View.

  3. Alternatively, download Smart View from http://www.oracle.com/technetwork/middleware/epm/downloads/smart-view-1112x-1594693.html.

Note: Since Smart View is an add-in to Microsoft Office products, you can install Smart View only on a Windows operating system.

Once Smart View is installed, it must be configured to connect to Oracle Fusion Applications. Use the Smart View Shared Connections URL. You can derive the Shared Connections URL by following the following steps.

  1. Open Workspace for Financial Reports from the Financial Reporting Center.

  2. Edit the Workspace URL, for example, if the Workspace URL is https://fusionsystemtest-p-external-bi.us.oracle.com/workspace/index.jsp. Remove index.jsp and add SmartViewProviders at the end of the URL.

    If the Workspace URL is https://efops-rel5st4-cdrm-external-bi.us.oracle.com:10622/workspace/index.jsp, the Shared Connections URL is https://efops-rel5st4-cdrm-external-bi.us.oracle.com:10622/workspace/SmartViewProviders.

  3. Copy the URL.

  4. Launch Excel.

  5. Navigate to the Smart View menu >Options

    Smart View Ribbon added to Excel.
  6. Select the Advanced option.

    Smart View options window used to configure spreadsheets.
  7. Paste the URL in the Shared Connections URL field.

  8. Click the OK button.

For more information on configuring the Smart View client for users, see Oracle Hyperion Smart View for Office User's Guide for Oracle Hyperion Smart View.

To connect Oracle Fusion General Ledger Balances cubes in Smart View:

  1. Open Smart View from your Start menu > Programs > Microsoft Office > Microsoft Excel 2007.

  2. Go to the Smart View menu > Open, in the Start on the ribbon > click on Smart View Panel that appears in the drop down box under the ribbon. This launches a task pane.

  3. Click the Shared Connections button on the task pane.

  4. Sign in with your user name and password.

    Sign in to establish the connection to the database.
  5. Click the Select Server list icon to proceed.

    Note: If the Essbase Server is not there, then it has to be added. Use the following steps:
    1. Click the Add Essbase Server link on the bottom of the spreadsheet.

    2. Specify the Essbase Server login and password.

    3. Expand the Essbase server and locate its cube.

  6. Select Oracle Essbase from the list of shared connections.

  7. Click the Expand to expand the list of cubes.

  8. Expand your cube that has the name of your chart of accounts.

    Select your cube, which is named for your chart of accounts.
  9. Click db. A list of functions appears on the bottom of the panel.

  10. Click the Ad hoc analysis.

Note: You must perform the steps above only once for a new server and database.

To set how the name and alias of the Essbase database appears:

  1. Click the Options on the ribbon > select the Member Options > select Member Name Display.

  2. Set one of these three options:

  • Distinct Member Name: Only shows the full Essbase distinct path.

  • Member Name and Alias: Shows both the member name and the alias.

  • Member Name Only: Shows only the member name.

Note: The Smart Slice feature is not supported in Oracle Fusion General Ledger. For all other documentation, refer to the Oracle Hyperion Smart View for Office User's Guide.

Configure Financial Reporting Studio Client for Users

Oracle Hyperion Financial Reporting Studio is client-based software tool used for authoring financial reports. Prerequisites needed for installing the Financial Reporting Studio are:

  1. Financial Reporting Studio Client Certifications found at: http://www.oracle.com/technetwork/middleware/bi-foundation/hyperion-supported-platforms-085957.html.

  2. The end user's computer requires Microsoft Office installations.

You connect to the Financial Reporting Studio by downloading the installation files to your computer from Workspace. Follow this path:

  1. Navigator > Financial Reporting Center > Open Workspace for Financial Reports.

  2. In Workspace: Tools > Install > Financial Reporting Studio.

After performing the prerequisites and completing the installation, launch the Financial Reporting Studio. You must provide your user ID, password, and the Server URL. Derive the Server URL information by following the steps:

  1. Open Navigator > Financial Reporting Center > Open Workspace for Financial Reports.

  2. Edit the Workspace URL and remove workspace/index.jsp.

  3. Two examples of Server URLs are:

    • If the Workspace URL is https://fusionsystemtest-p-external-bi.us.oracle.com/workspace/index.jsp, the Financial Reporting Server URL is https://fusionsystemtest-p-external-bi.us.oracle.com.

    • If the Workspace URL is https://fusionsystemtest-p-external-bi.us.oracle.com:10622/workspace/index.jsp, the Financial Reporting Server URL is https://fusionsystemtest-p-external-bi.us.oracle.com:10622.

  4. Copy the modified URL to the Server URL field.

Note: For end users installing the Oracle Fusion Financials Reporting Studio, the installer launches a separate console window that continues to run for a brief time after the installation completes the setup tasks. The process is normal, expected, and applies to Oracle Hyperion Reporting Studio installations in both the Oracle Fusion Applications and Enterprise Performance Manager modes.

You must save a new report before attempting to preview it with Web Preview.

For more information, see:

  • Oracle Enterprise Performance Management System Installation and Configuration Guide.

  • Oracle Hyperion Enterprise Performance Management System EPM System Standard Deployment Guide.

Define Essbase Database Connections in Workspace

You need to create database connections from Workspace so you can access the cubes from Workspace and Financial Reporting Studio.

Note: Ledger setup has to be completed before the database connection can be created. Oracle Fusion General Ledger balances cubes are created as part of ledger setup. There is a separate cube for each combination of chart of accounts and accounting calendar. A database connection is needed for each cube.

Steps to define a database connection are:

  1. Navigator > Financial Reporting Center.

  2. From the Financial Reporting Center task panel, select Open Workspace for Financial Reporting.

  3. From within Workspace select the Navigator menu > Applications > BI Catalog.

  4. Tools menu > Database Connection Manager.

  5. Click New.

  6. Enter a user friendly name for the Database Connection Name.

  7. Enter Essbase as the Type, your server, user name, and password.

  8. Select Application (cube) and Database from the list of values.

  9. Expand the Application name to see the related database, for example, db.

    Complete the fields in the Database Connection Properties
window.
  10. OK twice to save your selections.

  11. Close to save your connection.

For more information on configuring Essbase database connections in Workspace see: Oracle Essbase Database Administrator's Guide.

Note: The database connection is available in both Workspace and Financial Reporting Studio. Optionally, the database connection can be setup in Financial Reporting Studio while entering the grids on a report.

Create Financial Statements: Explained

In Oracle Hyperion Financial Reporting Studio, you can design traditional financial report formats such as balance sheets, profit and loss statements, and cash flow reports. You can also design nontraditional reports for financial or analytic data that include text and graphics. Use Financial Reporting Studio that is a client-based application and is launched from your desktop to create your reports. Perform the following basic tasks to begin defining this report.

The figure shows a rolling 12-month income statement
that is created by using the steps in this topic.
  1. Access the Financial Reporting Studio on your desktop.

    The figure shows signing in with your User ID, Password,
and Server URL.
    Tip: The first time you sign in, you must set the Server URL in this format: https://<servername>-bi-ext.us.oracle.com:port.
  2. New Report (1st icon on the toolbar) or File menu > New > Report.

  3. Use the Report Pallet page as the container to build your report.

  4. New Grid. (First icon in second set on the toolbar.)

  5. Press the left mouse button and drag the mouse to select a large area of the grid in which to create your report.

  6. Click the Database Connection list.

  7. Select your database. A unique cube exists for each combination of chart of accounts and accounting calendar.

    The figure shows the database connection selection list
and your User ID and Password.
  8. OK.

Tip: Best practice is to always turn suppression on in financial reports. This should be done at the Database Connection Server. You can verify this by doing the following: (highlight grid > Menu > Task > Data Query Optimization Settings). The normal best practice for most reports is to turn suppression on for the entire grid, and then turn it off for certain columns and rows that must always display.

For more information about suppression settings, see Using the Basic Option in Conditional Suppression in the Designing with Financial Reporting Studio for Oracle Planning and Budgeting Cloud guide at http://docs.oracle.com/cloud/latest/epm-common/CSFSU/ch09s04s02.html#BEGIN.

Set the Row, Column, and Page Points of View

Set the point of view dimensions and accounts for the rows, columns, and page levels.

  1. Use the Dimension Layout window that opens to arrange your dimensions.

  2. Drag and drop:

    • Accounting Period to Columns.

    • Account to Rows.

    • Company to Pages.

    Tip: Click the icon in front of the name to select the dimension to drag to the designed area.
    The figure shows Company dimension in the Pages section,
AccountingPeriod in the Columns section, and Account in the Rows section
of the Dimension Layout window.
  3. OK.

  4. Double-click Account to open the Select Members dialog box to select the data to use in your report.

  5. Click the Account list item in the Selected box on the right.

  6. Remove in the center to remove the default Account.

  7. Expand for Account node.

  8. Expand:

    • Accounts

    • [Account]@[T]

    • 95001

  9. Select 95011 Revenue.

  10. Add.

    The figure shows expanding all levels to select the 95001
Revenue value.
  11. OK.

  12. File > Save As...

  13. Select My Folders.

  14. Enter the name for the report: XXInFusion Income Statement.

  15. Save.

  16. Select the last row in the grid. Click the row header (row with the account in it).

  17. Insert > Row > Text to add a blank row.

  18. Right-click the row header.

  19. Insert Row > Data to add another blank row.

  20. Add expense accounts by double-clicking account 95011 in line 3.

  21. Remove the Selected account 95011.

  22. Expand: > Accounts - V1 > [Account]@[T] > 95001 > 95021 - Expenses

  23. Select all three accounts: 50000, 60000, and 70000.

  24. Add.

  25. Check the Place selections into separate rows check box on the bottom right.

    The figure shows the expanded tree for the Account dimension.
  26. OK > Save. Leave the report open for the next activity.

Add a Formula

Add a formula to calculate total expenses.

  1. Right-click the row header of the row below row 5.

  2. Insert > Row > Formula.

  3. Click in the blank cell on row 6.

  4. Click the Custom Heading option in the panel on the right-hand side of the window.

  5. Add a custom heading: Total Expenses.

  6. Click the formula cell at row 6 and column A.

  7. Sum(). The formula Sum() is entered into the Edit box.

  8. Enter [3], [4], [5].

  9. After entering the formula, validate the syntax by clicking the blue check mark.

    The figure shows the formula Sum [3], [4], [5] and the
blue check mark.

    (I) Save. Leave the report open for the next activity.

Define Columns Using a Range Function

Define the columns using a range function to create a rolling 12 period column type report.

  1. In the first column on the grid, double-click the AccountingPeriod cell.

  2. Remove the default selection to assign a custom period selection.

  3. Click the AccountingPeriod in the Selected window.

  4. Click Remove.

  5. Select Functions.

  6. Click the Range list item.

  7. Add.

    The figure shows the Range function in the Functions
tab selected.
  8. OK.

  9. Use the Edit Range Function window to add the range function start and end members or to select a hierarchy to use to select your report data.

  10. Select the StartMember row.

  11. Click in the Value field.

  12. Select Lookup > Functions.

  13. Click the RelativeMember list item.

  14. Add.

  15. Select the Member row.

  16. Click in the Value field > Lookup

  17. Click the Current Point of View list item.

  18. Add > OK.

  19. The Offset value determines periods to include from the current point of view. Since this is a rolling 12-month report, enter -12.

    The figure shows entering -12 as the Offset value.
  20. OK twice.

  21. Click the EndMember list item > Lookup

  22. Click the Current Point of View list item.

  23. Add.

  24. OK three times until you return to your report.

  25. Save. Leave the report open for the next activity.

Define User Points of View

Define the user points of view for the dimensions and specify values for those dimensions.

  1. Select the Grid object (The intersection of rows and columns on the left margin.)

  2. Right-click the Grid object.

  3. Grid Point of View. The points of view appear across the top of the window.

  4. Ledger: User Point of View for Ledger.

  5. Expand:

    • Ledger

    • All Ledgers

  6. Highlight the Ledger item to include in the report: InFusion USA PL.

    The figure shows expanding all the Ledger dimension levels
to select the InFusion USA PL.
  7. Select Scenario.

  8. Expand Scenario.

  9. Select Actual as the Scenario member to determine what should be included in the columns.

  10. Select Balance Amount.

  11. Expand the Balance Amount.

  12. Select Period Activity as the balance amount to include in the report.

  13. Select Currency.

  14. Expand Currency.

  15. Search for and select USD from the list.

  16. Click the USD list item.

  17. OK.

    The figure shows the Select Members window with the USD
currency selected.
  18. Right-click the Grid object.

  19. Click the Grid Point of View Setup.

  20. Scroll down and click the Balance Amount list button.

  21. Select the Nothing, Lock Member Selection option.

  22. OK.

  23. Double-click the Pages object.

  24. Remove.

  25. Select the Prompt for Company list item.

  26. Add.

    This figure shows selecting Prompt for Company option
and adding it to the Selected window.
  27. OK.

  28. Select Lookup.

  29. Click the Default Member list icon.

  30. Remove.

  31. Expand.

    • Company.

    • All Company Values.

  32. Select the required companies: 101 - US 1 LE 1 BU 1 and 102 - US 1 LE 2 BU 2.

  33. Add.

  34. OK.

  35. Click the Member Labels in Prompt Selection Dialog list button.

  36. Select the Alias list item.

    The figure shows the prompt parameters set for the Enter
Company prompt.
  37. OK.

  38. Open the Page Properties dialog box on the right side of the window. If it does not open, click View menu > Property Sheet.

  39. Double-click the Pages object.

  40. Click the Alias: Default option.

    This figure shows the Page Properties and selecting the
Alias: Default.
  41. Click the first cell in Row 1.

  42. Open the Heading Row Properties dialog box on the right-hand side of the window.

  43. Click the Alias: Default option.

    The figure shows the Heading Row Properties and selecting
Alias: Default.
  44. Click the Grid object.

  45. Open the Grid Properties dialog box.

  46. Click the Suppression list item.

  47. Enter 0 in the Zero Values field.

    This figure shows entering a 0 in the Zero Values in
the Grid Properties window.
  48. Open the Heading Row Properties dialog box.

  49. Click an entry in the row.

  50. Click the Allow Expansion option.

  51. Click the Grid object.

  52. Open the Grid Properties dialog box.

  53. Click the Drill Through option. (On the very bottom of the window.)

  54. Save. Leave the report open for the next activity.

Add Company Logo and Title

Insert your company's logo and add a title to the report.

  1. Click Image. (Third icon in the second set of icons on the toolbar.)

  2. Find your company's logo in your file system.

  3. Click Open.

  4. Drag and drop the cursor over the report pallet to determine the length and width of the image.

  5. Save.

  6. Click Text. (Second icon in the second set of icons on the toolbar).

  7. Drag and drop the cursor over the report pallet to determine the length and width of the title.

  8. Enter Rolling 12 Month Income Statement.

  9. Format > Font.

  10. Select Bold and 14 as the Font Size.

  11. Center Text.

  12. File > Page Setup option.

  13. Click Landscape.

  14. Click Workspace Size. If needed, you can adjust the Width and Height with the up and down arrows.

    The figure shows the final image in the gird.
  15. OK > Save.

Preview Report

Preview the report both in the Financial Reporting Studio and the Financial Reporting Center.

In Financial Reporting Studio

  1. File > Print Preview.

  2. Accept the default selections.

  3. OK.

    This figure shows the preview of the report without the
periods expanded.
  4. Use the Next Page to see all the columns.

  5. Edit the report definition as needed.

In Financial Reporting Center

  1. Sign in the Oracle Fusion Applications.

  2. Navigator > General Accounting: Financial Reporting Center > My Folders > XXInFusion Income Statement.

  3. View as HTML.

  4. OK to the Respond to Prompts window to keep the default companies.

  5. Click the AccountingPeriod.

    The figure shows the report without the periods expanded.
  6. Expand:

    1. AccountingPeriod

    2. 2012

    3. Qtr2-12

      The figure shows the point of view selection window for
the accounting period.
  7. Select 02-12.

  8. OK.

    The figure shows the final report.