Banking
should not be relied upon in making purchasing decisions. The development, release, and timing of any
features or functionality described in this document remains at the sole discretion of Oracle.

This document in any form, software or printed matter, contains proprietary information that is the
exclusive property of Oracle. Your access to and use of this confidential material is subject to the terms
and conditions of your Oracle Master Agreement, Oracle License and Services Agreement, Oracle
PartnerNetwork Agreement, Oracle distribution agreement, or other license agreement which has
been executed by you and Oracle and with which you agree to comply. This document and information
contained herein may not be disclosed, copied, reproduced, or distributed to anyone outside Oracle
without prior written consent of Oracle. This document is not part of your license agreement nor can it be
incorporated into any contractual agreement with Oracle or its subsidiaries or affiliates.

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website

Oracle customers that have purchased support have access to electronic support through My Oracle
Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://
www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

Sample Code

Oracle may provide sample code in SuiteAnswers, the Help Center, User Guides, or elsewhere through
help links. All such sample code is provided "as is" and "as available", for use only with an authorized
NetSuite Service account, and is made available as a SuiteCloud Technology subject to the SuiteCloud
Terms of Service at www.netsuite.com/tos.

Oracle may modify or remove sample code at any time without notice.

No Excessive Use of the Service

As the Service is a multi-tenant service offering on shared databases, Customer may not use the Service
in excess of limits or thresholds that Oracle considers commercially reasonable for the Service. If Oracle
reasonably concludes that a Customer's use is excessive and/or will cause immediate or ongoing
performance issues for one or more of Oracle's other customers, Oracle may slow down or throttle
Customer's excess use until such time that Customer's use stays within reasonable limits. If Customer's
particular usage pattern requires a higher limit or threshold, then the Customer should procure a
subscription to the Service that accommodates a higher limit and/or threshold that more effectively aligns
with the Customer's actual usage pattern.

Beta Features

Oracle may make available to Customer certain features that are labeled "beta" that are not yet generally
available. To use such features, Customer acknowledges and agrees that such beta features are subject
to the terms and conditions accepted by Customer upon activation of the feature, or in the absence of
such terms, subject to the limitations for the feature described in the User Guide and as follows: The beta
feature is a prototype or beta version only and is not error or bug free and Customer agrees that it will
use the beta feature carefully and will not use it in any way which might result in any loss, corruption or
unauthorized access of or to its or any third party's property or information. Customer must promptly
report to Oracle any defects, errors or other problems in beta features to support@netsuite.com or
other designated contact for the specific beta feature. Oracle cannot guarantee the continued availability
of such beta features and may substantially modify or cease providing such beta features without
entitling Customer to any refund, credit, or other compensation. Oracle makes no representations or
warranties regarding functionality or use of beta features and Oracle shall have no liability for any lost
data, incomplete data, re-run time, inaccurate input, work delay, lost profits or adverse effect on the
performance of the Service resulting from the use of beta features. Oracle's standard service levels,
warranties and related commitments regarding the Service shall not apply to beta features and they may
not be fully supported by Oracle's customer support. These limitations and exclusions shall apply until the
date that Oracle at its sole option makes a beta feature generally available to its customers and partners
as part of the Service without a "beta" label.
Send Us Your Feedback

We'd like to hear your feedback on this document.

Answering the following questions will help us improve our help content:

- Did you find the information you needed? If not, what was missing?
- Did you find any errors?
- Is the information clear?
- Are the examples correct?
- Do you need more examples?
- What did you like most about this document?

Click here to send us your comments. If possible, please provide a page number or section title to identify the content you're describing.

To report software issues, contact NetSuite Customer Support.
Banking

NetSuite banking offers several processing options to accurately track your income. You can record deposits to your bank accounts to capture customer payments and other monies received in the course of doing business. For a deposit, you can select payments received for existing transactions, add funds not related to transaction payments, and record any cash received back from the bank. You can remove undeposited funds from deposits, record cash back from a deposit, manage returned/NSF checks, and more. For more information, see Deposits.

NetSuite enables you to use the Write Checks transaction to issue a check to pay an expense or record a non-check transaction. For more information, see Checking.

To create a transaction that changes the balance in a NetSuite general ledger account, create a Journal Entry. See the help topic Journal Entries.

You can move funds from one bank account to another bank account. You can also move funds into non-bank accounts. For more information, see Transferring Funds.

You can add company credit card accounts, enter company credit card charges, pay the company credit card bill, and then reconcile the credit card statement. For more information, see Company Credit Cards.

You can create and save a record for a financial institution, and then add multiple format profiles to it. Format profiles let you set up configuration details to import banking data, including how the data gets into the system and how the system parses the data. For more information, see Financial Institution Records.

If you use Online Banking, you can import transaction data automatically or manually. Provided that the administrator has set up automatic imports, financial users can receive new data from their financial institution daily on the Match Bank Data page. Alternatively, financial users can download transaction data from their financial institution or credit card company and then manually import the statement into their NetSuite account. When data is imported into NetSuite, NetSuite automatically matches transactions and enables you to manually match any remaining unmatched transactions. For more information, see Bank Data Import.

When bank data is imported into NetSuite, you can match and reconcile transactions without the use of Excel or third-party tools. You can match transactions, review and exclude matches you do not want, and submit matched transactions for reconciliation on the Match Bank Data page. This page displays side-by-side lists of Imported Bank Data and Account Transactions currently in NetSuite for the selected account. To reconcile an account statement, you can go to the Reconcile Account Statement page, which displays matched and submitted account transactions in NetSuite. You can include or exclude transactions from the statement to be reconciled. For details, see Bank Data Matching and Reconciliation.

The original reconciliation pages are still available. You can reconcile bank statements, enter transactions during the reconciliation process, hold a reconciliation, and delete a reconciliation. See Reconciling Bank Statements and Reconciling Credit Card Statements.

For information about adding and deleting bank accounts, see the help topics Creating Accounts and Deleting Accounts and Making Accounts Inactive.
# Permissions for Banking Features

You need to enable certain permissions to use banking features in NetSuite. The following table provides the permissions required to use financial institution records, as well as the Statement File Import, Intelligent Transaction Matching, and Account Reconciliation features:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Permission</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Financial institution records</td>
<td>Financial Institution Records</td>
<td>Create and save financial institution records and associated format profiles where you can configure account mappings and bank transaction codes. This permission requires a full access level. For more information, see Financial Institution Records.</td>
</tr>
</tbody>
</table>
| Statement File Import                        | Import Online Banking File        | Access the Statement File Import page and Imported Statement List page. Access levels include:  
  - **Full** – Access the Statement File Import and Imported Statement List pages, import files, view import details, delete imported files, and edit duplicate flags.  
  - **Edit** – Access the Statement File Import and Imported Statement List pages, view import details, and edit duplicate flags.  
  - **View or Create** – Access the Imported Statement List page and view import details. For more information, see Manual Bank Data Import. |
| Intelligent Transaction Matching and Account Reconciliation | Accounts                         | Enables you to view and select accounts on the Match Bank Data and Reconcile Account Statement pages. If you want to use these pages for an account, check the Use Match Bank Data and Reconcile Account Statement Pages box on the Account page.  
  If you are using NetSuite's default BAI2 or CAMT.053 parsers, you need to set up account mappings on the Account page.  
  Your user role must have view-level access at a minimum. |
| Import Online Banking File                   |                                  | See the previous description for the Statement File Import feature. |
| Matching Rules for Online Banking            |                                  | Enables you to access the Reconciliation Matching Rules page. Access levels include:  
  - **Full, Edit, or Create** – Access the Reconciliation Matching Rules page. Create, edit, and delete matching rules, and change the order of the custom rules.  
  - **View** – No access. |
| Reconcile                                     |                                  | Enables you to access the Match Bank Data and Reconcile Account Statement pages and match transactions. Some roles may have the Edit or only the View access level.  
  - **Edit** – Ability to access the Match Bank Data and Reconcile Account Statement pages, match transactions, and close a reconciliation. |

Banking
### Permissions for Banking Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Permission</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Ability to access the Reconcile Account Statement page and transaction details.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>The Account Reconciliation Summary portlet is also on your dashboard by default.</td>
</tr>
</tbody>
</table>

Other possible restrictions may impact the list of accounts and details that you can see:

- **Subsidiary Restrictions** – For example, an employee of Subsidiary A can only access Subsidiary A’s account list, by default. However, if the user role has the **Allow Cross-Subsidiary Record Viewing** setting enabled, the account list contains all the available accounts for the user to reconcile.

- **Department, Class, or Location Restrictions** – For example, if your role has the Department Restriction set to** own, subordinate, and unassigned**, and has access to department A, you can only see accounts in department A, as well as its children or unassigned accounts. You cannot access an account from department B.

For more information, see **Bank Data Matching and Reconciliation**.
Deposits

In NetSuite, record deposits to your bank accounts to capture customer payments and other monies received in the course of doing business. By recording funds deposited, you can accurately track income. Typically organizations post customer payments received in the form of cash, checks, and credit card payments to the Undeposited Funds ledger account rather than to a specific bank account. This prevents a time lag between the amount shown on your books for a bank account and the bank balance. When you record a deposit, NetSuite moves funds out of the Undeposited Funds account to the ledger account for the bank account, to accurately reflect bank account balances.

If you record customer payments directly to a bank account rather than to Undeposited Funds, you do not need to create deposits for those amounts.

To record deposits you make to your bank accounts, go to Transactions > Bank > Make Deposits.

You can edit a saved deposit in the Deposits list. You can also delete a recorded deposit from the Deposits list. For more information, see Making Deposits.

Information on using deposits in this topic includes:

- Making Deposits
- Viewing the Deposits List
- Printing Deposit Slips
- Recording Cash Back from a Deposit

Making Deposits

Make a deposit in NetSuite to record funds you deposit into your bank account. For a deposit, you can select payments received for existing transactions, add funds not related to transaction payments, and record any cash received back from the bank.

**Note:** Many organizations post customer payments to the Undeposited Funds ledger account rather than to a specific bank account. This Undeposited Funds posting prevents a time lag between the amount shown on your books for a bank account and the bank balance. When you record a deposit, NetSuite moves funds out of the Undeposited Funds account to the ledger account for the bank account to accurately reflect bank account balances. If you record customer payments directly to a bank account rather than to Undeposited Funds, you are not required to create deposits for those amounts.

**Warning:** During the creation of a deposit, if another user deletes any payment or cash sale that is currently marked for deposit, NetSuite displays a message indicating that the record has been changed. You cannot save the deposit because the expected data is no longer present.

When making a deposit, in addition to standard options for saving the deposit, you can perform the following from the header:

- **Reset** – clears all input on all subtabs, and clears header input
- On the **Payments** subtab, you can check and clear the box beneath the **Customize** button. Checking the box selects all of the payment items for the deposit. Clearing the box removes the selected payment items from the deposit.

You can add items to a deposit with payment methods other than Check or Cash. For example, you can add a custom payment method or a credit card. If you want to print the deposit slip, NetSuite displays a message warning you that the deposit has items other than Check or Cash. You can continue with the deposit if this is correct, or make changes as needed.
The system does not track tax periods on deposits.

**To make a deposit:**

1. Go to Transactions > Bank > Make Deposits.
2. In the Primary Information section:
   a. Select the custom form for this deposit.
      The system generated deposit number appears.
   b. Select the bank account for the deposit.
      The currency and exchange rate display for the account. For information on exchange rates, see the help topic Currency Exchange Rates.
      If the bank account's currency is the same as the subsidiary's base currency, the exchange rate is a read-only field
      
      Note: If you use NetSuite OneWorld, the bank account determines the subsidiary and the selectable payments at the line level in step 4a. For other deposits, the bank account determines the subsidiary and the currency. If you change the bank account, the class, department, and location and all of the line items are cleared.
   c. The Amount field shows the total amount of payments, other deposits, and cash back selected or entered on the Deposits subtab.
   d. Accept today’s date, or enter the date of the deposit.
   e. Select a posting period, if you use the Accounting Periods feature.
   f. Optionally, enter a memo.
   g. Check the To Be Printed box if you want to enter multiple deposits before printing the deposit slips for your records. See Printing Multiple Deposit Slips.
3. In the Classification section, select a department, class, and location for this deposit, if needed.
   If you use NetSuite OneWorld, the subsidiary defaults to that associated with the selected bank account.
4. On the Deposits subtab, enter the items for the deposit.
   a. The Payments subtab lists all payments posted to the Undeposited Funds account. Check the box next to each item to include in this deposit.
      You can filter the items by date, date range, or payment processing profile.
      The Amount column shows the payment amount in the currency of the bank account, which was entered when received for a cash sale, invoice, or other transaction. If you must change the amount, click the link in the Date column to go to the source transaction.
      If the field is empty, you must manually enter the amount. NetSuite does not populate the field if the payment currency is different from the bank account's currency, and the bank and subsidiary currencies are also different.
      If the payment currency is different from the bank's currency, and the bank and subsidiary currencies are the same, NetSuite uses the stored exchange rate to calculate the amount.
      
      Note: You cannot modify a zero payment amount.
   b. On the Other Deposits subtab, enter items not received as payments recorded to the Undeposited Funds account.
Enter the name, amount (positive number), account, payment method, and payment number for each item. Optionally enter a classification and memo. Click Add.

**Note:** You can select an entity in the Name field. The available entities are filtered by the selected bank account.

If you use NetSuite OneWorld and have shared vendor and customer records with multiple subsidiaries, all of the vendors and customers assigned to the subsidiary associated with the selected bank account appear in this field. For more information about shared records, see the help topics [Assigning Subsidiaries to a Vendor](#) and [Assigning Subsidiaries to a Customer](#).

- **c.** On the Cash Back subtab, enter the amount of cash back you received from this deposit. Enter the amount of cash you received, account, classification, and memo. Click Add.

5. On the Communication subtab, you can attach files and notes to this transaction.
   - **a.** On the User Notes subtab, enter a title and note for any comments you want to add to this transaction. Click Add after each note.
   - **b.** On the Files subtab, select and attach files from the File Cabinet related to this transaction. To upload a new file to the File Cabinet, select New from the dropdown list in the Attach Files column.
   - **c.** Use the Events, Tasks, and Phone Calls subtabs to add to attach activities, such as events, phone calls, and tasks to this transaction. For more information, see the help topic [Attaching Events, Tasks, and Calls to Records and Transactions](#).

6. If you use NetSuite OneWorld and the Multi-Book Accounting feature is provisioned in your account, the Accounting Books subtab appears. This subtab shows the secondary books associated with the selected deposit, if any, and their respective base currencies and exchange rates. For information about Multi-Book Accounting, see the help topic [Using Multi-Book Accounting](#).

7. After you enter all the items for the deposit, verify the deposit total amount is correct and click Save.

**To edit a saved deposit in the Deposits list:**

1. Go to Transactions > Bank > Make Deposits > List.
2. From the Deposits list, click Edit next to the deposit you want to modify.
3. On the Deposit page, modify the saved deposit as required.
4. Click Save.
5. At the prompt to unreconcile the transaction, click OK.

**To delete an existing deposit from the Deposits list:**

1. Go to Transactions > Bank > Make Deposits > List.
2. From the Deposits list, click Edit next to the deposit you want to delete.
3. On the Deposit page, under Actions, click Delete.
4. At the prompt to confirm the action, click OK.

**Viewing the Deposits List**

The Deposits page provides a list of deposits recorded in NetSuite and an overview of information about the deposits made. From the list you can access individual deposit records or print the deposit slip.
To view the deposits list, go to Transactions > Bank > Make Deposits > List.

By default, the Deposits page shows the following information about each deposit:

- Date of the deposit
- Document number associated with the deposit
- Bank account for the deposit
- Memo
- Currency of the bank account
- Amount (Foreign Currency)
- Amount of deposit
- Whether the deposit was posted

Depending on the features enabled in your account, this page also shows feature specific columns.

Filtering the Deposits List

To limit the deposits that show in the list, select one or more filters on the Deposits page. In addition to standard filters, you can add custom ones, such as Account, by customizing. You can also delete existing deposits from the list.

To add custom filters to the Deposits list:

1. From the Deposits list, click Customize View.
2. On the Saved Transaction Search page, click the Available Filters subtab.
3. Select a filter in the dropdown list.
4. The Show in Footer box is automatically checked. Clear this box if you do not want to display a dropdown list of filter values on the Deposits list.
5. Click Add.
6. Click Save.

Removing Undeposited Funds Lines from Deposits

If you post a payment from a customer to the Undeposited Funds account, it appears in the list of items on the Payments subtab of the Deposit page. You can include it in a deposit at any time by selecting the payment when making a deposit. In some cases, you may need to remove undeposited payments if you have otherwise accounted for them.

To clear the Deposit page of unnecessary Undeposited Funds lines:

1. Go to Transactions > Bank > Make Deposits.
2. On the Payments subtab of the Deposits subtab, check the box in the Deposit column next to the journal lines you want to remove.
3. Make a note of the total amount of the lines you check on the Payments subtab.
4. Click the Cash Back subtab.
5. In the Amount field, enter the total amount of all of the lines you checked on the Payments subtab.
For example, if the total amount of the lines you checked on the Payments subtab is 500.00, enter 500.00 in the Amount field.

6. In the Account field for this line, select Undeposited Funds.

7. Click Save.

Printing Deposit Slips

You can print slips for cash and check deposits. You can print a deposit slip for an individual deposit, or you can queue multiple deposit slips and print them at the same time.

You can print deposit slips in HTML or PDF format from your local or network printer. Deposit slips are printed on printer paper and do not require special forms. To print deposit slips in PDF format you need Adobe Reader. Visit the Adobe Web site to download the latest version at no charge.

To customize the fields on your deposit slips, go to Customization > Forms > Transaction Forms. Click the name of the deposit slip you want to customize and then complete the fields as required. For more information, see the help topic Creating Custom Entry and Transaction Forms.

Note: At present, you cannot customize the layout of the printed deposit slip.

Printing a Single Deposit Slip

Print a single deposit slip when you enter a deposit at Transactions > Bank > Make Deposits. After you enter all the information for the deposit, click Save & Print, and then click Print in the Adobe application.

You can also print deposit slips you entered previously. To print a past deposit slip, go to Transactions > Bank > Make Deposits > List. Click Print next to the deposit slip you want to print.

Printing Multiple Deposit Slips

If you enter multiple deposits before printing, you can print all the slips at one time. To do this, check the To Be Printed box on the Deposits page for each deposit you enter.

To print multiple deposit slips:

1. Go to Transactions > Management > Print Checks and Forms.
2. Click Deposits.
3. On the Deposits page, select the Account for which you want to print deposit slips.
4. Check the box beside each deposit you want to print, or click Mark All to print all deposits listed.
5. Click Print.
   - If you did not enable the Download PDF Files preference on the Set Preferences page, a preview of your deposits opens in Adobe Reader.
   - If you enabled the Download PDF Files preference, you must first save your deposits and then open them with Adobe Reader.
6. Click the Print button in Adobe Reader.
7. If you want to print multiple copies, specify the number on the print message that appears.
8. Click OK.
Recording Cash Back from a Deposit

You can record cash received back from a deposit when you create the deposit slip in NetSuite. Enter the amount received on the Cash Back subtab on the Deposit page.

If you want to balance your bank account, you can create new deposits or charges during the reconciliation process. For details, see Reconciling Bank Statements.

To record cash back from a deposit:

1. Go to Transactions > Bank > Make Deposits.
2. Create a deposit. For more information, see Making Deposits.
3. Click the Cash Back subtab.
   a. In the Amount field, enter the amount of cash you got back.
   b. Select the account the deposit comes from.
   c. Select a department, class or location.
   d. Enter an optional memo.
4. Click Add.
   Repeat the steps above for any other cash items you received from deposits.
5. Click Save.
Checking

In NetSuite, use the Write Checks transaction to issue a check to pay an expense or record a non-check transaction. For example, you can:

- reimburse employees for expenses if you do not use Direct Deposit or Accounts Payable
- pay vendors if you do not use Accounts Payable
- record cash transactions
- enter other non-check debits, such as debit card transactions

If you use Accounts Payable, pay vendors at Transactions > Payables > Pay Bills.

Information on using company credit cards in this topic includes:

- Writing Checks
- Resetting Check Numbers
- Printing Checks
- Entering Non-Check Debits
- Recording Cash Transactions Using Checks
- Tracking Petty Cash

Writing Checks

Note: The Write Checks option is not available for Japan Edition.

In NetSuite, use the Write Checks transaction to issue a check to pay an expense or record a non-check transaction. For example, you can:

- reimburse employees for expenses if you do not use Direct Deposit or Accounts Payable
- pay vendors if you do not use Accounts Payable
- record cash transactions
- enter other non-check debits, such as debit card transactions

If you use Accounts Payable, pay vendors at Transactions > Payables > Pay Bills. For more information, see the help topic Vendor Bill.

Note: If you must stop payment on a check, the preferred method is to void the check in the system. Voiding a check sets its amount to zero but does not remove it from the system, ensuring that you maintain the proper audit trail. For information about voiding a check, see Voiding a Check and Voiding Transactions.

Saving a check transaction records the expense directly to your books by debiting the expense account specified in the transaction detail, and crediting the bank account selected for the check.

When you save a check transaction, you have three options:

- To process the information and return to the Transactions page, click Save.
  
  If you select To be Printed for the transaction, it is available for printing on the Print Checks page. For more information, see Printing Checks.
To write a check:

1. Go to Transactions > Bank > Write Checks.

   **Note:** The Write Checks option is not available for Japan Edition.

2. In the Primary Information section:
   a. From the **Account** list, select the bank account from which to withdraw the funds for this check.
      The **Balance** field is read-only.
   b. Select the **Payee** for this check.
   c. In the **Amount** field, enter the amount for which you want to write the check.
      You can also leave this field blank and enter amounts from the expenses and items added for the check. **Auto Fill** displays the amount from the previous transaction for this payee.
      The currency and its exchange rate are populated in the **Currency** and **Exchange Rate** fields based on the currency selected on the **Financial** subtab of the payee's record.
   d. Accept today's date or enter a new date for this transaction.
   e. If you use accounting periods, select a posting period for this check.
   f. Select **To Be Printed** to save this check in your print queue to print later.
      If you do not check this box, you can click **Save & Print** to print this check immediately.
   g. The **Check #** field is populated with one of the following:
      - If you checked **To Be Printed**, this box is populated with **To Print**.
         You choose starting numbers when you print those checks.
      - If you are immediately printing this check when you save the transaction, NetSuite increases the largest check number by one. You can enter another number, but the next number reverts to the standard pattern.

   **Note:** You can also use this field to record ACH, ATM, or other reference numbers or text.

   h. Enter a memo for the check (optional).

3. In the Classification section:
   a. If you use NetSuite OneWorld, the **Subsidiary** field defaults to the primary subsidiary associated with the **Payee**.

   **Note:** If you share vendor and customer records with multiple subsidiaries, you can change the subsidiary from the primary subsidiary to a secondary subsidiary. Changing the subsidiary updates the bank account to that of the selected subsidiary, updates the currency to that of the new bank, and clears the lines on the **Expenses** and **Items** subtabs. For more information about shared vendor and customer records, see the help topics Assigning Subsidiaries to a Vendor and Assigning Subsidiaries to a Customer.

   b. If you use departments or classes, select a department or class with which to associate this check.
4. On the Expenses & Items subtab, click the Expenses subtab and select any expenses associated with this transaction. For more information, see Adding Expenses to a Check.

5. On the Expenses & Items subtab, click the Items subtab and select any items associated with this transaction. For more information, see Adding Items to a Check.

6. If you use the Landed Cost feature, on the Landed Cost subtab, select the method by which the cost is allocated. Enter any shipping and duty costs and select the sources of these costs. For more information, see the help topic Landed Cost.

7. On the Payee Address subtab, the address information from the payee record appears. If the Auto Fill preference is enabled, the address information from the latest transaction for the payee appears. If you have not sent any invoices to customers or if the Auto Fill preference is disabled, the Default Billing address information appears.

   Note: The Auto Fill preference takes precedence over the Default Billing address.

   To enable or disable the Auto Fill preference, go to Home > Set Preferences. On the Transactions subtab, in the Basics section, check or clear the Auto Fill Transactions box.

   To enable or disable the Default Billing box, go to Lists > Relationships > Customers and click Edit next to a customer. On the customer record, in the Address subtab, check or clear the Default Billing box next to an address.

8. On the Relationships subtab, the primary contact for the customer automatically appears. You can edit, add, or delete contact information for the transaction on this subtab.

9. On the Communication subtab, you can attach files and notes to this transaction.
   a. On the User Notes subtab, enter a title and note for any comments you want to add to this transaction. Click Add after each note
   b. On the Files subtab, select and attach files from the File Cabinet related to this transaction. To upload a new file to the File Cabinet, select New from the dropdown list in the Attach Files column.
   c. Use the Events, Tasks, and Phone Calls subtabs to add to attach activities, such as events, phone calls, and tasks to this transaction. For more information, see the help topic Attaching Events, Tasks, and Calls to Records and Transactions.

10. If you use NetSuite OneWorld and the Multi-Book Accounting feature is provisioned in your account, the Accounting Books subtab appears. This subtab lists the secondary books associated with the selected check, if any, and their respective base currencies and exchange rates. For information about Multi-Book Accounting, see the help topic Using Multi-Book Accounting.

11. If you use the International Tax Reports SuiteApp, on the Tax Reporting subtab, select the delivery terms, region of origin, nature of transaction code, and mode of transport. Check the Non-deductible Tax Adjusted box if this check includes a nondeductible tax. For more information, see the help topic EU Intrastat Report.

12. Click Save.

Adding Expenses to a Check

Add expenses to a check to directly account for expenses related to your organization.

A common use of this is to pay for an internal company expense, such as petty cash, or to pay bills for which you don’t receive a vendor invoice.

To add expenses to a check:
   1. Go to Transactions > Bank > Write Checks.
2. On the top of the Check page, enter information about the payee, dates, and other information about the payment. You can enter the amount here or when you enter the detail lines. For more information, see Writing Checks.

If the Auto Fill preference is turned off, you can click Auto Fill to fill information from the last transaction for this payee.

To enable or disable the Auto Fill preference, go to Home > Set Preferences. On the Transactions subtab, in the Basics section, check or clear the Auto Fill Transactions box.

3. On the Expenses & Items subtab, click the Expenses subtab to enter the expenses.
   a. In the Account field, select the appropriate ledger account.
   
   **Note:** You must have the Expand Account Lists preference enabled to select a credit card account in this field. For more information, see the help topic Accounting Preferences.

   b. Enter an amount for the expense item. Amounts entered here update the Amount field in the header.
   c. Optionally enter a memo.
   d. Select an expense category if you use internal expense categories and have customized the Check page to display this field.
   e. Select a department, class, or location to associate with this transaction, if used.
   f. Enter the Customer or Project associated with this expense.
   g. If this expense is billable, check the Billable box.
   h. Click Add.

4. Repeat step 3 for any additional expenses.

5. Save the transaction.

**Note:** If you use voucher checks, you can print a maximum of 19 line items on each check. If you have more than 19 line items for a single check, the items do not appear on the voucher.

---

**Adding Items to a Check**

Items are goods and services that you acquire. When you write a check, you can add items from the list of items you set up.

**To add items to a check:**

1. Go to Transactions > Bank > Write Checks.
2. On the top of the Check page, enter information about the payee, dates, the amount of the payment, and other information about the payment. For more information, see Writing Checks.

   If the Auto Fill preference is turned off, click Auto Fill to fill information from the last transaction for this payee.

3. On the Expenses & Items subtab, click the Items subtab.
   a. Select an item from the list and then fill in the quantity.
      NetSuite fills in the description, rate, and amount.
   b. Enter the serial or lot numbers, if necessary.
   c. Enter an expiration date for the item, if appropriate.
d. In the **Bin Numbers** field, the preferred bin for the item is selected. If items with this transaction are to be stocked in other bins associated with this item, click the bin number. Click the **Bins** icon, edit quantities added to each bin, and click **Done**.

e. Select a **Tax Code** to populate the **Tax Rate** field.

f. Set **Options**, if required.

g. Enter the customer or project associated with this item.

h. Select a department, class, and location to associate with this transaction, if used.

i. If this is billable, check the **Billable** box.

j. Check the **Update Item Price** box to change the purchase price for this item.

4. Click **Add**.

5. Repeat step 3, add items.

6. Save the transaction.

**Note:** If you use voucher checks, you can print a maximum of 19 line items on each check. If you have more than 19 line items for a single check, the items do not appear on the voucher.

---

### Adding Check Register Shortcuts

You can add shortcuts on your dashboard for easy access to the checking register for each of your bank accounts.

To use shortcuts, you must first enable the Shortcuts portlet on your dashboard at Home > Dashboard. Click Personalize to expand the Personalize Dashboard panel. Under Standard Content, click or drag the Shortcuts item.

**To create a shortcut to a check register:**

1. Go to **Transactions > Bank > Write Checks**.
2. In the **Account** field, select a bank account.
3. Under **Actions**, select **Go to Register**.
4. When the register opens, click **Add To Shortcuts**, available in the Shortcuts menu.
5. In the Add Shortcut page, accept the name of the account as listed in the your chart of accounts, or change it to the name you'd like to appear on your NetSuite Home page. Check **Open in New Window** to have the register open in a new window.
6. Click **Save**.

Repeat these steps for each of your bank accounts. You can also add a shortcut to any ledger account.

To access a check register, click the link in your Shortcuts portlet.

---

### Voiding a Check

In NetSuite, the Write Checks transaction issues a check to pay an expense or record a non-check transaction such as a vendor payment if you do not use Accounts Payable. For information about writing checks in NetSuite, see [Writing Checks](#).

When you write a check, the check amount posts into the journal account affected by the payment. When you void the check, the selected journal account is impacted by the voiding journal entry. For information
about the GL impact from writing a check, see the Writing Checks subtopic on the Bank Transaction GL Impact help topic.

To void a check from a closed period, you must reopen the period.

**Note:** After voiding a check, reconcile the voiding journal entry. For details pertaining to the original reconciliation feature, see Reconciling Bank Statements. For details on dealing with voided transactions in the redesigned Reconcile Account Statement page, see Matching Bank Data.

**To void a check:**

1. Go to Transactions > Bank > Write Checks > List.
2. Click the **Edit** link for the check to be voided.
3. Click **Void**.
4. Create the voiding journal entry and then click **Save**.
   
   For more information on creating a journal entry, see the help topic Making Journal Entries.

For information about voiding transactions, see the help topic Voiding Transactions.

**Resetting Check Numbers**

By default, NetSuite sets the Check # field to the largest existing check number increased by one. If you have appropriate permission, you can reset numbering at a lower or higher number than the current number.

**To reset check numbering:**

1. Go to Lists > Accounting > Accounts, or Setup > Accounting > Chart of Accounts.
2. In the list of accounts, click **Edit** next to the bank account for which you want to reset check numbering.
3. In the **Next Check Number** field, enter the check number to use for the next check written from this account.
4. Click **Save**.

If your NetSuite account uses auto-generated numbering for check numbers, you can reset the initial numbering for the check transaction type. For information about auto-generated numbers, see the help topic Set Auto-Generated Numbers.

**Printing Checks**

To save a check in your print queue to print later, check the **To Be Printed** box. For details, see Writing Checks. To remove the check from the print queue, edit the check and then clear the **To Be Printed** box.

Print checks using the Print Checks page at Transactions > Management > Print Checks and Forms > Checks. You can also print a single check immediately after writing a check transaction.

Your administrator can customize the layout of your printed forms using Advanced PDF/HTML templates. For information, see the help topic Advanced PDF/HTML Templates.
Checks print in PDF format using Adobe Reader. Visit the Adobe website to download the latest version at no charge.

Select the account on which the checks are to be drawn. Select the type of check, and specify the check number. Determine whether the check should print from back to front.

**Note:** For information on reprinting a check, see Reprinting a Check.

To print checks:

- Set your preferences for check printing. For more information, see Setting Check Printing Preferences.
- Ensure that Adobe Reader is available.
- Order check printing forms from the Forms Fulfillment Center, a NetSuite partner at www.netsuiteforms.com. For more information, see Forms Available for Check Printing.
- Print single checks or multiple checks. For more information, see Printing a Single Check and Printing Checks for Multiple Transactions.
- For reprinting checks and trouble shooting, see Handling Check Printing Problems.

To clear the printer queue, refer to Devices and Printers on your Start menu.

**Setting Check Printing Preferences**

You set check printing preferences on the Printing & Fax Preferences page.

**To set check printing preferences:**

1. Go to Setup > Company > Preferences > Printing & Fax.
2. Click the **Printing** subtab.
3. Under Check Printing, in the **Default Check Type** field, choose from two types of checks:
   - **Standard** – printed without a voucher, three checks per 8.5 x 11 inch sheet.
   - **Voucher** – printed at the top of an 8.5 x 11 inch sheet with voucher information printed at the bottom, one check per sheet.
     
     If you use voucher checks, you can print a maximum of 19 line items on each check. If you have more than 19 line items for a single check, the items do not appear on the voucher.
     
     You must print the check at the top. NetSuite does not support printing checks in the middle of the page.

   **Note:** You can customize check forms, but you must print forms as Standard (3 to a sheet) or Voucher (check at the top only.) When you customize a check layout, you see only the check, no vouchers, regardless of your check type preference. Even if you change the page size, the elements you can select to add or edit are only the standard check elements.

   Your administrator can customize the layout of your printed forms using Advanced PDF/HTML templates. For information on customizing forms, see the help topic Advanced PDF/HTML Templates.

4. Select a font style in the **Check Font** field.

   **Note:** The preferences in steps 3 and 4 do not affect the layout of elements on the check form.

5. Select a font size in the **Check Font Size** field.
6. Click Save.

If your organization uses basic printing, you can configure a different check template for each subsidiary. For information, see the help topic Specifying Check Layout by Subsidiary.

### Adjusting Check Printing Position

If you need to adjust the printing position for the text on the check form, go to Home > Set Preferences. On the Transaction subtab in the Printing sections, adjust the values in the **Horizontal** and **Vertical Print Offset** fields. Adjusting the values on the Set Preferences page affects all checks you print.

Automatic scaling, set in the Page Handling section of the Print window, can also cause difficulties when printing checks. Make sure that **Page Scaling** is set to **None**, and the boxes beneath it are not checked in the Print window.

### Forms Available for Check Printing

You can use NetSuite to print two types of checks:

- **Standard** – printed without a voucher, three checks per 8.5 x 11 inch sheet.
- **Voucher** – printed at the top of an 8.5 x 11 inch sheet with voucher information printed at the bottom, one check per sheet.

You must print the check at the top. NetSuite does not support printing checks in the middle of the page.

**Note:** You can customize check forms, but you must print forms as Standard (3 to a sheet) or Voucher (check at the top only). When you customize a check layout, you see only the check, no vouchers, regardless of your check type preference. Even if you change the page size, the elements you can select to add or edit are only the standard check elements.

For information on customizing forms, see the help topic Customizing Transaction Form PDF Layouts. For information about the Advanced PDF/HTML Templates feature, see the help topic Advanced PDF/HTML Templates.

If your organization uses basic printing, you can configure a different check template for each subsidiary. For information, see the help topic Specifying Check Layout by Subsidiary.

For more information on setting up check printing and aligning check forms, see Setting Check Printing Preferences.

NetSuite checks can be purchased from the Forms Fulfillment Center, a NetSuite partner at www.netsuiteforms.com. The following checks are compatible with NetSuite:

- Laser Top Multipurpose Check (DNL208)
- Laser Top Multipurpose Check - Unlined (DNL200)
- Laser 3-Up Multipurpose Check - Unlined (DNL201)
- Laser 3-Up Multipurpose Checks w/Lines Product (DNL202)

### Printing a Check at the Form Bottom

Some locales require printing a check at the bottom of the form instead of the top. For example, some U.K. accounts require stock that prints at the bottom of the form. If you have such a requirement, please
acquire check stock from www.access-plus.co.uk. You must use the reference number INF01SL on your order.

Printing a Single Check

You can print a single check immediately after writing a check transaction by clicking Save & Print when saving the transaction.

Alternately, you can print one or more checks from a queue of saved check transactions. For more information, see Printing Checks for Multiple Transactions.

Note: For information on reprinting a check, see Reprinting a Check.

To print a single check:

1. Go to Transactions > Bank > Write Checks.
2. On the Check page, complete the information as appropriate. For more information, see Writing Checks.
3. When finished, click Save & Print.
   NetSuite displays the printout for your check in PDF format.
4. Place a blank check in your printer tray, starting with the check number that matches the number on the Check page.
   When you print checks, the check number assigned to the check by NetSuite is printed in the upper right corner in a small font. It should not overlap the check number on preprinted check stock.
   When you view your checks in the Adobe application before printing them, verify that the number NetSuite assigned to the check is the same as the number on your preprinted checks. To reset the check number, see Resetting Check Numbers.
5. Click the printer button in the Adobe application.
6. To print multiple copies, specify the number on the print message that appears, then load the appropriate number of pages of blank paper after the blank check in your printer.
7. In the Page Handling section of the Print window, verify that Page Scaling is set to None and the boxes beneath it are not checked. Automatic scaling can cause difficulties printing checks.
8. Click OK.

Your administrator can customize the layout of your printed forms using Advanced PDF/HTML templates. For information, see the help topic Advanced PDF/HTML Templates.

Printing Checks for Multiple Transactions

Follow these steps to print checks for more than one transaction.

To save a check in your print queue to print later, check the To Be Printed box. For details, see Writing Checks. To remove the check from the print queue, edit the check and then clear the To Be Printed box.

Note: For information on reprinting a check, see Reprinting a Check.

To print checks for multiple transactions:

1. Go to Transactions > Management > Print Checks and Forms and then click Checks.
NetSuite displays the Print Checks page.

2. To determine the order in which NetSuite prints the checks, click on a column header to sort by that column.

   **Note:** In order to print the checks in a specific order, choose the order before choosing the account. If you want to print checks in a different order after choosing an account, sort the checks according to your preference, then reload the page and select the account.

3. Select the bank account from which you want to print checks.

   **Note:** Only those bank accounts that include transactions where the To Be Printed box is checked on the transaction record appears in the Account dropdown list.

4. NetSuite displays the next available check number to be printed.
   You can enter the starting check number for your preprinted checks, if different.
   To reset the check number sequence, see Reseting Check Numbers.

5. If higher-number checks go into your printer before lower-number checks, click **Print Back to Front**.

6. Choose the type of preprinted check.
   - Choose **Standard** to print a check without a payment voucher attached.
   - Choose **Voucher** to print a check with a payment voucher attached.

7. If you enabled the preference to use auto-generated numbers for vendors, you can sort the list of checks by the vendor names instead of by ID numbers. Click the header of the Payee column to sort checks by the payee name.
   Set your preferences for autogenerated numbers at Setup > Company > Auto-Generated Numbers.

8. Check the box in the **Print** column next to each check you want to print.

9. Click **Print**.

**To preview your checks:**

1. Preview your checks using the following methods:
   - If you enabled the Download PDF Files preference, select **Print** to save your checks and then open them with the Adobe application.
   - If you did not enable the Download PDF Files preference, a preview of your checks automatically opens in the Adobe application.

2. To specify the Download PDF Files preference, go to Defaults section of the **General** subtab at Home > Set Preferences.

3. Place your checks in your printer tray, starting with the check number that matches the value in the **First Check Number** field.

4. Click the printer button in the Adobe application window.

5. If you want to print multiple copies, specify the number on the Print window that appears and load the appropriate number of pages of blank paper after each blank check in your printer.

6. In the Page Handling section of the Print window, verify that **Page Scaling** is set to **None** and the boxes beneath it are not checked. Automatic scaling can cause difficulties printing checks.

7. Click **OK**.

Your administrator can customize the layout of your printed forms using Advanced PDF/HTML templates. For information, see the help topic Advanced PDF/HTML Templates.
Handling Check Printing Problems

For more information on setting up check printing and aligning check forms, see Setting Check Printing Preferences.

Reprinting a Check

Follow these steps when a check does not correctly print due to printing error or other problems.

**To reprint a check:**

1. Go to Transactions > Bank > Write Checks and then click List or Search to find the check.
2. Click the View link for the check.
3. Click Void.
4. On the Voiding Journal page, click Save.
5. Reopen the original bill transaction, refund transaction, or employee transaction in NetSuite.
6. Check the To Be Printed box.
7. Change the check number so that it matches your next blank check.
8. Repeat the printing process.

For detailed printing steps, see Printing Checks for Multiple Transactions.

Print Scaling

Print scaling on your printer can cause problems when printing checks. When the PDF opens and you click the Print button, the Print window opens. In the Page Handling section of the Print window, verify that Page Scaling is set to None, and the boxes beneath it are not checked.

Forgetting to Print a Check

If you click Save rather than Save & Print when saving a check transaction you intend to immediately print, follow the steps below to print the check from the Print Check page.

**To print a check at a later time:**

1. Go to Transactions > Bank > Write Checks > List.
2. Find the check transaction you want to print and then click Edit.
3. Check the To Be Printed box and click Save.
4. Go to Transactions > Management > Print Checks and Forms.
5. Click Checks.
6. On the Checks page, select the bank account from which you want to print checks.
7. Check the box in the Print column next to each check you want to print.
8. Complete the rest of the required information and then click Save to print the check.

For detailed printing instructions, see Printing Checks for Multiple Transactions.

Your administrator can customize the layout of your printed forms using Advanced PDF/HTML templates. For information, see the help topic Advanced PDF/HTML Templates.
Entering Non-Check Debits

You can enter non-check debit transactions on an account using the Write Checks transaction. Non-check debit transactions include debit card transactions, ATM (automated teller machine) transactions, and EFT (electronic funds transfer) payments.

**To enter non-check debit transactions:**

1. Go to Transactions > Bank > Write Checks.
2. On the Check page, verify that the correct bank account appears in the Account field.
3. Enter the payment information in the appropriate fields.
4. In the Check Number field, enter Debit or other text to indicate that the payment is not made by a check.
5. Click Save.
   This debit appears on the register for the account.

Best practice is to use the Write Checks transaction to enter non-check debits. You can, however, record debits while reconciling your bank statement.

**To enter non-cash debit transactions while reconciling a bank statement:**

1. Go to Transactions > Bank > Reconcile Bank Statement.
2. Click the New Charges subtab.
   a. Fill in the appropriate information for the charge.
   b. Click Add.
3. Complete the rest of the reconciliation.
   For complete reconciliation instructions, see Reconciling Bank Statements.
   When you have cleared all the transactions listed on the statement and entered any additional transactions, the statement balance and cleared balance should match. Use the Difference field to track your progress.
4. When finished, you can:
   - Click Save to reconcile your bank statement.
   - Click Save & Print to save and print your reconciliation.
   - Click Hold to hold your reconciliation until you return to save or print it.

Recording Cash Transactions Using Checks

In NetSuite, you can record detailed cash transactions that you do not enter as bills on the Write Checks page.

For example, while serving at a party Christy's Catering runs out of soda. The owner must immediately purchase more soda with cash and bring it back to the party. Because this cost is associated with a project, Christy's Catering can record the transaction for the cash spent using the Write Checks function and capture the expense without first creating a vendor bill.

**To record a cash transaction:**

1. Go to Transactions > Bank > Write Checks.
2. On the Check page, select the ledger account you want to use to record the cash expenditure.

3. Enter the name of the payee, who received cash.

4. In the **Check #** field, type **CASH**.
   
   You can include a tracking number if you wish.

5. Enter the amount you spent.

6. On the **Expenses & Items** subtab, enter line items for the expenses or items associated with this cash transaction.
   
   For example, on the **Expenses** subtab, you might select a Beverage expense account, enter the customer, and select **Billable** to charge the expense to your customer.

7. Click **Save**.

To view the transaction, go to Transactions > Bank > Write Checks > List. Click **View** next to the item you created.

---

**Tracking Petty Cash**

**Important:** Before making any changes, **ask your accountant** to advise you whether writing journal entries or changing the account type is the right method for your business to track petty cash.

---

### Tracking Petty Cash Using Journal Entries

Most companies follow the standard accounting practice of using journal entries to track petty cash transactions. When you establish a Petty Cash account, you write a check for the amount of cash to keep on hand, and cash it. Make a journal entry that debits the Petty Cash asset account and credits the journal account for the bank.

Every time you spend cash from the Petty Cash account, keep a receipt to explain how the cash was used. At the end of a period, referring to the receipts you have kept, make journal entries that debit the expense accounts for each receipt and credit the Petty Cash asset account for the cash spent. Write and cash a check to replenish the petty cash funds as needed.

For information about journal entries, see the help topic **Making Journal Entries**.

---

### Tracking Petty Cash Using the Write Checks Function

To use the Write Checks function to account for petty cash expenditures, you must set up your Petty Cash account as a Bank account. As a Bank account, your Petty Cash account appears as a choice on the Check page at Transactions > Bank > Write Checks. You then use the Write Checks transaction to record expenses.

Write and cash a check to fund your petty cash. Then write a check against the Petty Cash Bank account to record expenditures made with petty cash.

You can also enter a Bill for the purchases you have paid through Petty Cash and then pay the bill from the Petty Cash account.
Transferring Funds

A transfer is a movement of funds from one bank account to another bank account. In NetSuite, bank accounts include accounts for petty cash.

NetSuite enables you to perform two types of bank transfers. You can transfer funds between two bank accounts if they share the same currency, and you can transfer funds between a base currency bank account to any foreign currency bank account.

Information on transferring funds in this topic includes:

- Transferring Funds Between Bank Accounts
- Transferring Funds to Non-Bank Accounts

Transferring Funds Between Bank Accounts

NetSuite enables you to perform two types of bank transfers. You can transfer funds between two bank accounts if they share the same currency, and you can transfer funds between a base currency bank account to any foreign currency bank account.

- **Two bank accounts with shared currency** – You can transfer funds between two bank accounts if they share the same currency. In this transfer, the exchange rate is always one. The G/L impact of this transfer, however, is denominated by the subsidiary's base currency. NetSuite performs the base currency translation using the transfer amount, based on the default system rate. For example, you transfer 100 EURO from an Australian bank account into another Australian bank account that uses EURO currency. The Australian subsidiary's base currency is AUD. The exchange rate is one, but the 100 EURO is translated to an AUD amount, based on the default system rate.

  
  **Note:** The default system rate is not visible on the user interface.

- **Base currency bank account to foreign currency bank account** – You can transfer funds between a base currency bank account to any foreign currency bank account. In this transfer, the exchange rate is the rate between the subsidiary's base currency and that of the selected foreign currency. When you select the From and To bank accounts, NetSuite displays the default system exchange rate between the two currencies.

  When you enter a value in the From Amount field, NetSuite translates the value and displays it in the To Amount field. NetSuite does not round the amount.

  NetSuite automatically updates the exchange rate if:

  - The translated From Amount field value multiplied by the exchange rate does not equal the To Amount field value after rounding.
  - You change the translated value in the From Amount field.

  For example, you want to transfer 100 USD from a U.S. bank account to a bank account in the U.K. that uses GBP currency. NetSuite displays the default system exchange rate, which is 1.6. When you enter 100 in the From Amount field, NetSuite translates the value and displays 62.50 in the To Amount field. If you enter 130 in the To Amount field, NetSuite updates the exchange rate field to 0.7692307692307693 (= 100/130). In this case, the G/L impact is in base currency, USD 100.

  **Important:** If you have a NetSuite OneWorld account, one of the two bank accounts must be in the base currency.

To enter a funds transfer:

1. Go to Transactions > Bank > Transfer Funds.
2. In the **From Account** field, select the source account containing the funds that you want to transfer. The balance of this account and its currency denomination appear next to the **From Account** field.

3. In the **To Account** field, select the target account to receive the funds. The balance of this account and its currency denomination appear next to the **To Account** field. The **Exchange Rate** between the currencies in the two accounts displays below the two currency denominations.

4. Select the posting period for this transfer. The period must be an open period.

5. Accept or select the date in the **Date** field.

6. In the top **Amount** field, enter the amount of funds, in the account's currency, to be transferred from the account identified in the **From Account** field.

   The second **Amount** field displays the amount to be transferred into the account identified in the **To Account** field, after currency translation.

7. Enter an optional memo.

8. Enter a department, class, or location if appropriate.

9. Click **Save**.

The transfer is complete and the balances for the bank accounts automatically update.

### Transferring Funds to Non-Bank Accounts

In NetSuite, funds transfers are specifically transfers between bank accounts. Transfers between bank accounts and non-bank accounts are typically achieved with checks or deposits. For example, if you pay off a loan with a check, instead of transferring funds from the checking account to the loan payable account, you write a check and choose the loan payable account for the expense.

**Note:** When your bank account and loan are with the same bank, you can also use the bank’s online system to transfer between operating accounts and loan accounts.

For transferring funds to non-bank accounts, you can make general journal entries. For information about journal entries, see the help topics Journal Entries, Journal Entries Overview, and Journal Entry Preferences.

**To make a general journal entry:**


2. On the Journal page, enter the appropriate information as directed by instructions in the topic Making Journal Entries.
Company Credit Cards

After you set up company credit card accounts, you can enter company credit card charges, pay the credit card bill, and reconcile the credit card statement.

Information on using company credit cards in this topic includes:

- Creating Company Credit Card Accounts
- Entering Company Credit Card Charges
- Paying the Company Credit Card Bill
- Reconciling Credit Card Statements

Creating Company Credit Card Accounts

At any time you can add a company credit card to your list of accounts. After you set up the account, you can enter company credit card charges, pay the credit card bill, and reconcile the credit card statement.

To add a new company credit card account:

1. Go to Setup > Accounting > Manage G/L > Chart of Accounts > New.
2. In the Type list, select Credit Card.
3. Enter the number to identify this account.
4. Enter a name for the account.
5. Complete other fields as needed.
6. If you use NetSuite OneWorld, choose the subsidiary to which this credit card should be assigned. Credit card accounts can be assigned to only one subsidiary.
7. Click Save.

To modify an existing company credit card account:

1. Go to Setup > Accounting > Manage G/L > Chart of Accounts.
2. From the Chart of Accounts, click Edit next to the credit card account you want to modify.
3. Modify the fields as needed.
   - You cannot change the currency associated with the account because transactions in this currency exist in the system.
   - From the Actions menu you can delete the company credit card account or merge the account into another company credit card account.
4. Click Save.

Entering Company Credit Card Charges

To manage charges and payments for your company credit card, you should first enter each individual transaction. Transactions are posted immediately.

If you want to import credit card charges, see the help topic Credit Card Charge Import.

If you want to import bank or credit card statements, see Bank Data Import.
To enter credit card transactions:

1. Go to Transactions > Bank > Use Credit Card.
2. Select the type of transaction you want to enter:
   - Charge to record a purchase
   - Credit to record a credit to your account

   **Note:** For credit type transactions such as returned items, the tax is posted to GST or VAT on Purchases.

3. Under Primary Information, enter a reference number from the credit card transaction, if required.
4. In the Vendor field, select the entity you are paying (or the entity who is crediting you for a previous purchase).
   The currency field defaults from the entity record.
   In NetSuite OneWorld, the subsidiary displays under Classification.

   **Note:** If you share vendor and customer records with multiple subsidiaries, you can select any of the secondary subsidiaries assigned to the selected entity in the Vendor field. If you enter line items and then change the subsidiary, all line item data is cleared. For more information about shared records, see the help topics Assigning Subsidiaries to a Vendor and Assigning Subsidiaries to a Customer.

5. In the Account field, select the credit card account for this transaction.
   The current balance of the credit card account displays in the Balance field.
   In a NetSuite OneWorld, the list displays only credit card accounts with the same currency as the vendor currency.

   **Note:** The currency associated with a credit card account is always the currency of the subsidiary when the account was created. If you change the subsidiary of a credit card account to a subsidiary with a different currency, the credit card account retains the currency of the original subsidiary. It is available in the Account list for only those transactions based in that currency.

6. In the Amount field, enter the amount of the transaction.
7. If needed, enter a different exchange rate.
8. The Date field displays the current date.
   Enter a different date if needed.
9. If you use the Accounting Period feature, select a posting period.
   You can enter transactions only to open periods.
10. Optionally, enter a memo.

**Expenses**

1. Under Expenses & Items, on the Expenses subtab, select the expense ledger account.
   The expenses available are filtered by the selected vendor and subsidiary.

   **Important:** The Unbilled Receivable account appears in the account list when the Expand Account Lists accounting preference is enabled. Do not select this account. All debits and credits to this account must be system-generated.

2. Enter the amount for the specific expense.
3. Enter an optional memo.
4. Enter class, department, or location information.
5. If the expense is billable to a customer, select the customer, and check the Billable box.
6. Click Add.
7. Repeat these steps for each expense you want to put on this credit card charge.

**Items**

1. To add items, on the Items subtab, select the name of an item, or click Add Multiple to quickly add several items.
   
   The items available are filtered by the selected vendor and subsidiary.

2. Enter the information for the item.
   
   For information about entering detail information about items, see the help topic Creating Item Records.

   **Note:** If you use NetSuite OneWorld and have shared the selected vendor with multiple subsidiaries, the item price is based on the item definition between the vendor and the selected subsidiary. Therefore, changing the subsidiary could change the item price.

3. Click Add.
4. Repeat these steps for each item you want to put on this credit card.

**Tax Details**

If VAT/GST nexuses and tax preferences have been set in your NetSuite account, click the Tax Details subtab to select the vendor's nexus and tax registration number. Check the Override box to override vendor defaults, then complete the tax lines.

**Relationships**

Click the Relationships subtab to add information about contacts. The primary contact for the customer is selected automatically. To edit information for this contact, click the contact's name. You can also add contacts to this order by entering the contact's information and clicking Add.

**Communication**

- Use the Phone Calls, Events, and Tasks subtabs to attach activities to this transaction. For more information, see the help topic Attaching Events, Tasks, and Calls to Records and Transactions.
- On the Files subtab, you can select and attach files related to this transaction. For more information, see the help topic Attaching Files to Records.
- On the User Notes subtab, you can enter a title, memo date, time, type, and direction for any comments you want to add to this transaction. Click Add after each note. For more information, see the help topic Attaching Events, Tasks, and Calls to Records and Transactions.

The Balance field displays the current balance for the credit card account. After you have entered each individual transaction, the balance for the account chosen should match the balance on your credit card statement, assuming you have not made additional charges since the credit card statement was printed.
Accounting Books

If you use NetSuite OneWorld and the Multi-Book Accounting feature is provisioned in your account, the **Accounting Books** subtab appears. This subtab displays the secondary books associated with the selected vendor, if any, and their respective base currencies and exchange rates. For information about Multi-Book Accounting, see the help topic Using Multi-Book Accounting.

Tax Reporting

If you use the International Tax Reports SuiteApp, on the **Tax Reporting** subtab, select the delivery terms, region of origin, nature of transaction code, and mode of transport. Check the **Non-deductible Tax Adjusted** box if this check includes a nondeductible tax. For more information, see the help topic EU Intrastat Report.

Save the credit card transaction.

Paying the Company Credit Card Bill

**To make a payment for the company credit card:**

1. Go to Transactions > Bank > Write Checks.
   For general information about checks, see Writing Checks.
2. In the **Account** field, select the account containing the funds to cover this check.
3. Select the credit card company in the **Payee** field.
   To set up a new payee, click the plus icon. For the payee type, choose Vendor or Other Name.
4. In the **Amount** field, enter the amount of the payment being made on the credit card balance.
5. Click the **Expenses** subtab.
6. Select the credit card ledger account in the **Account** field.
7. In the **Amount** field, enter the amount you are paying.
8. Click Add.
9. Click Save.

When you save the check transaction, the payment posts in NetSuite. If you paid the balance in full, the credit card account balance becomes zero.

To process a credit refunded by the credit card company, see Reconciling Credit Card Statements.

Reconciling Credit Card Statements

**Note:** This is the original reconciliation feature. A redesigned version of transaction matching and statement reconciliation is now available, which enables you to efficiently match and reconcile transactions on the same page, without requiring Excel or third-party tools. For details, see Bank Data Matching and Reconciliation.

As with your bank statements, you should reconcile your credit card statement against your credit card register to keep your NetSuite accounts accurate.
If you use online banking, you can import credit card statement data. For more information, see Bank Data Import.

The reconciliation process includes verifying transactions on your credit card account and your ledger account:

- Payments and credits (such as for returned merchandise)
- Charge and cash advances
- Fees and chargebacks

You can mark a credit card transaction as cleared from the chart of accounts if it has gone through, but does not yet appear on the statement. Go to Reports > Financial > Chart of Accounts. Click the name of the account linked to the credit card. Check the box in the Clr column if a transaction is cleared, but not yet reconciled.

When you reconcile a transaction, it is automatically marked cleared. Transactions must be both cleared and reconciled before closing a period.

Tip: You can un-clear a cleared transaction through the register for the credit card account. Click Actions, then click Go To Register. On the account register, locate the transaction and clear the Clr box. This makes the transaction unreconciled again.

If a previously-reconciled transaction is edited, the transaction becomes unreconciled again. Open the correct statement period for the transaction and reconcile the transaction again.

You can begin a credit card account reconciliation and then resume at a later time. NetSuite preserves the reconciliation until you return to save it or save and print it. For more information, see Completing a Reconciliation at a Later Time.

To reconcile a credit card statement:

1. Go to Transactions > Bank > Reconcile Credit Card Statement. You can also access this page by clicking the Reconcile link for a transaction on the credit card’s ledger account register.
2. In the Account field, select the credit card you are balancing. If you use NetSuite OneWorld, the subsidiary associated with this account displays in the Subsidiary field.
   - The Last Reconciled Balance field displays the balance of this account from the last time you reconciled your credit card statement. If it is incorrect, ensure that all previous reconciliations are complete and accurate.
3. In the Statement Date field, enter or pick the date of the statement.
4. In the Start Date field, enter the beginning of the reconciliation period.
5. In the Ending Statement Balance field, enter the closing balance on the statement.
   - The Reconciled This Statement field updates as you check off transactions.
   - The Difference field keeps track of the difference between the Ending Statement Balance and the combined total of the Last Reconciled Balance and Reconciled This Statement fields.

Tip: You can specify the number of items that display on the page at Home > Set Preferences > General > Number of Rows in List Segments.

Payments and Credits

1. Click the Payments and Credits subtab. This subtab displays payments and credits to be reconciled.
If you make a general journal entry against a credit card account, the entry on the Payments and Credits subtab displays in the Credit column in the register for the account. A Yes displays in the Cleared column for all transactions that have been marked as cleared on the account register. Transactions must be both cleared and reconciled before closing a period.

The Date column displays the date of the transaction. Click the link to view the original transaction.

The Type column displays the transaction type.

The Tran No. column displays the check number reference. Click the link to view the original transaction.

The Payor column displays to whom payments were made. Click the link to view the entity record.

The Memo column displays a brief description or information about the nature of the transaction. The Amount column displays the total amount of the transaction.

If you use NetSuite OneWorld, note that only transactions for the subsidiary associated with the credit card account are listed.

Note: When you mark a transaction as reconciled, a transaction not marked cleared automatically clears.

2. Check the boxes next to the transactions you want to reconcile.

   As you check transactions, the Last Reconciled Balance field is updated, and the total of those transactions displays on the subtab.
   - To reconcile all payments and credits, click Mark All.
   - If you mark credit card transactions as Cleared on an ongoing basis, when you open a reconciliation you can click Mark All Cleared to Reconcile. This button updates all transactions that are already cleared to be marked for reconciliation. Then, each transaction does not need to be marked individually.

3. If you want to select and reconcile all transactions, click Mark All.

Charges and Cash Advances

1. Click the Charges and Cash Advances subtab.

   This subtab displays charges and cash advances made to this credit card account that need to be reconciled.

   If you make a general journal entry against a credit card account, the entry on the Charges and Cash Advances subtab displays in the Charge column in the register for the account.

   A Yes displays in the Cleared column for all transactions that have been marked as cleared on the account register. Transactions must be both cleared and reconciled to close out a period.

   The Date column displays the date of the transaction. Click the link to view the original transaction.

   The Type column displays the transaction type.

   The Check No. column displays the check number of the transaction, reference number of credit card transactions, and so on. Click the link to view the original transaction.

   The Payee column displays to whom payments were made. Click the link to view the entity record.
The **Memo** column displays a brief description or information about the nature of the transaction. The **Amount** column displays the total amount of the transaction.

If you use NetSuite OneWorld, note that only transactions for the subsidiary associated with the credit card account are listed.

---

**Note:** When you mark a transaction as reconciled, a transaction not marked cleared automatically clears.

---

2. Check the boxes next to the transactions you want to reconcile.

As you check transactions, the **Last Reconciled Balance** field is updated, and the total of those transactions displays on the subtab.

- To reconcile all deposits and credits, click **Mark All**.
- If you mark credit card transactions as **Cleared** on an ongoing basis, when you open a reconciliation you can click **Mark All Cleared to Reconcile**. This button updates all transactions that are already cleared to be marked for reconciliation. Then, each transaction does not need to be marked individually.

3. If you want to select and reconcile all transactions, click **Mark All**.

### New Charges

1. Click the **New Charges** subtab.
2. Fill in the appropriate information for each charge, and then click **Add**.

   If you use NetSuite OneWorld, note the following:

   - **Payor** (vendor or other entity) must be associated with the same subsidiary as the credit card account.

   **Note:** If you have shared vendors and customers with multiple subsidiaries and this subsidiary is a secondary subsidiary to one or more shared entities, the **Payor** field lists all of the entities to which this subsidiary is assigned. Selecting a shared entity payor enables you to enter charges for the entity as well as this subsidiary. For more information about shared records, see the help topics Assigning Subsidiaries to a Vendor and Assigning Subsidiaries to a Customer.

   - **Accounts** are restricted to non-bank accounts to which the subsidiary associated with the credit card account has access.
   - Only classes, departments, and locations associated with the same subsidiary as the credit card account are available.

   As you add transactions, the **Reconciled This Statement** field is updated, and the total of all the other charges is shown on the subtab.

   **Note:** Charges you enter here are submitted if you click **Complete Later**, **Save**, or **Save & Print**.

### New Credits

1. Click the **New Credits** subtab.
2. Fill in the appropriate information for the credit, and then click **Add**.

   If you use NetSuite OneWorld, note the following:

   - **Payee** (vendor, customer, or other entity) must be associated with the same subsidiary as the credit card account account.
Note: If you have shared vendors and customers with multiple subsidiaries and this subsidiary is a secondary subsidiary to one or more shared entities, the Payee field lists all of the entities to which this subsidiary is assigned. Selecting a shared entity payee enables you to enter credits for the entity as well as this subsidiary.

- Accounts are restricted to non-bank accounts to which the subsidiary associated with the credit card account has access.
- Only classes, departments, and locations associated with the same subsidiary as the credit card account are available.

As you add transactions, the Reconciled This Statement field is updated, and the total of all the other charges is shown on the subtab.

Note: Credits you enter here are submitted if you click Complete Later, Save, or Save & Print.

3. Repeat for each credit.

When you have reconciled all the transactions listed on the statement and entered any additional credits or charges, the statement balance should equal the sum of the last reconciled balance and the transactions reconciled this statement.

Use a balance adjustment journal entry to manage any difference.

Use the Difference field to track your progress in matching these balances.

When you have finished, choose one of three options:

- Click Save to reconcile your credit card statement.
- Click Save & Print to save and print your reconciliation.
- Click Complete Later to save your reconciliation until you return to submit or print it.

Note: When you click Complete Later, only the reconciliation is reserved. Credits and charges entered on the New Credits and New Charges tabs are submitted as new transactions.

Your credit card account is reconciled. To view your three previous reconciliations, go to Transactions > Bank > Reconcile Credit Card Statement. Click History.
Financial Institution Records

NetSuite contains financial institution records, which represent banks and credit card companies from which you want to retrieve banking data. Financial institution records contain format profiles, which let you configure various settings necessary for importing bank data. You can configure a format profile for either manual import or for direct connectivity to a financial institution:

- **Manual import** – Use the settings configured in your format profile to manually import your data on the File Statement Import page. To manually import your data, see Manual Bank Data Import.

- **Financial institution connectivity** – Use a Financial Institution Connectivity Plug-in in your format profile to directly connect to a financial institution, which eliminates the need for manual import. After you set up your format profile and save, the plug-in is invoked. NetSuite then initiates an import and creates a daily import schedule. Imported data, along with the current bank balance and bank balance date, appears on the Match Bank Data page. To manually update your bank feeds, see Updating Imported Bank Data.

If you are connecting to financial institutions in the United States or Canada, you should use the standard plug-in available through the Bank Feeds SuiteApp. The Bank Feeds SuiteApp is targeted for release in February 2020.

If you are outside of the United States or Canada, or you do not want to use the SuiteApp, you can create a custom Financial Institution Connectivity Plug-in. For details, see the help topic Financial Institution Connectivity Plug-in Interface Overview.

A Financial institution record and associated format profile can either be created by administrators or auto provisioned through the Bank Feeds SuiteApp.

When you add a format profile to a financial institution record you have created, you need to select a connectivity method and a transaction parser.

When a format profile is auto provisioned through the Bank Feeds SuiteApp, it is already configured with a Financial Institution Connectivity and Parser Plug-in.

**Note:** You can only use the Bank Feeds Connectivity Plug-in in a format profile provisioned by the Bank Feeds SuiteApp.

If your role has the Financial Institution Records permission with a full access level, you can:

- Create financial institution records
- Create format profiles
- Associate a custom Financial Institution Connectivity Plug-in with a format profile
- Associate a standard or custom Parser Plug-in with a format profile
- Configure a connection to a financial institution, if you are using a Financial Institution Connectivity Plug-in
- Map financial institution accounts to corresponding accounts in NetSuite
- Map custom bank transaction codes to corresponding bank data types
- Configure your Parser Plug-in, if needed

For details on the Financial Institution Records permission, see Permissions for Banking Features.

Information on financial institution records in this section includes:

- Creating Financial Institution Records
Creating Financial Institution Records

You can create and save a record for a financial institution. Financial institution records are for storing format profiles, which enable you to configure various settings necessary for importing bank data. For details, see Creating Format Profiles.

In addition to creating your own records, you can use the Bank Feeds SuiteApp to automatically create a financial institution record and an associated format profile configured with a connectivity plug-in and parser. Together, these SuiteApp components enable you to directly connect to your financial institutions and retrieve data.

To create a financial institution record:

2. In the Financial Institution field, enter a financial institution name.
3. In the Description field, enter a description to help you identify this financial institution.
   
   **Important:** To configure format profiles for this financial institution, you must save the financial institution record first.

4. To inactivate the financial institution record, check the Inactive check box. The box is cleared by default.
5. Click Save.

Creating Format Profiles

After you save a financial institution record, you can add one or more format profiles to it.

Format profiles configured for manual import let you configure a file format by using a Parser Plug-in.

Format profiles configured for financial institution connectivity let you use a Financial Institution Connectivity Plug-in and Parser Plug-in to configure a direct connection to a financial institution.

Both configurations allow you to do the following:

- Map your financial institution accounts to corresponding accounts in NetSuite
- Map custom bank codes to corresponding bank data types
- If possible, configure the Parser Plug-in selected

A format profile can only be associated with one financial institution record.
If you delete a financial institution record, NetSuite deletes the associated format profile as well.

**Note:** You cannot delete a format profile that has any imports associated with it.

**To create a format profile:**

1. Go to Setup > Accounting > Financial Institution > List.
   NetSuite displays the Financial Institutions page.
2. Next to the financial institution record for which you want to add a format profile, click **View**.
   NetSuite displays the Financial Institution page.
3. Click **Add**.
   
   **Important:** You must be in View mode to enable the Add button. The button is not available in Edit mode.

   NetSuite displays the Format Profile page.
4. In the **Format Profile** field, enter a name for your format profile. For example, BAI2.
5. In the **Description** field, enter a description to help you identify this format profile.
6. From the **Connectivity Method** dropdown list, select a custom Financial Institution Connectivity plug-in or select the **Manual Import** option.
   
   **Note:** For a Financial Institution Connectivity Plug-in to be available, you must create and upload one to NetSuite. For details, see the help topic [Financial Institution Connectivity Plug-in Interface Overview](#).

   **Important:** Even if the Bank Feeds Connectivity Plug-in provided by the SuiteApp is available in the list, do not select it. Using this standard plug-in in a custom format profile results in an error when you attempt to save.

7. To associate a transaction parser with the format profile, select a parser from the **Transaction Parser** list.
   
   There are two types of transaction parsers NetSuite can use to import transactions: standard parsers and custom parsers. For details, see [Transaction Parser Configuration](#).

   **Note:** The **Transaction Parser** field is required. After you save a format profile record, you cannot change your Parser Plug-in selection.

8. If you are using a Financial Institution Connectivity Plug-in, configure a connection to a financial institution. For details, see [Financial Institution Connectivity Configuration](#).

9. Map financial institution accounts to corresponding accounts in NetSuite. For details, see [Bank Account Mapping](#).
   
   **Important:** For a successful import, you need at least one active account mapping.

10. Optionally, map custom bank codes to corresponding bank data types. For details, see [Mapping Custom Bank Codes](#).

11. Click **Save**.

    If the format profile is configured to connect to a financial institution and the save is successful, NetSuite displays a progress message that an import process has started. To view the progressing status of your import, click **Track your status**.
Creating Format Profiles

NetSuite imports any new data from your existing accounts since the last successful import. For any new accounts mapped, NetSuite imports the last 60 calendar days of data. For more information, see Automatic Bank Data Import.

If you have configured the format profile for manual import, your users must go to the File Statement Import page to import their data. For details, see Manual Bank Data Import.

12. Repeat these steps for each format profile configuration.

Tip: You can click on the hyperlinked financial institution name to go back to the financial institution record.

Financial Institution Connectivity Configuration

Configure a connection to a financial institution.

Note: To do this procedure, you need to select a Financial Institution Connectivity Plug-in from the Connectivity Method dropdown list. See Creating Format Profiles.

The configuration steps required depend on the configuration of each individual connectivity plug-in selected.

If you are using the Bank Feeds Connectivity plug-in available through the Bank Feeds SuiteApp, follow these steps on the Connectivity Configuration subtab:

1. Select a financial institution.
2. Enter your credentials.
3. Choose which accounts you want to link.

If you are using a custom plug-in, the configuration steps required depend on the plug-in’s initial implementation.

After you configure a connection to your financial institution or financial institutions, the Account Mapping subtab is populated with information. Map the financial institution accounts to corresponding accounts in NetSuite. For details, see Mapping Accounts for Financial Institution Connectivity.

Bank Account Mapping

Map bank data from your financial institutions to corresponding accounts in NetSuite.

Important: For a successful import, you need at least one active account mapping. To manually import a bank statement file successfully, you must map all the bank accounts in the file to corresponding NetSuite accounts. Also, ensure that the currency of the bank accounts is the same as the corresponding accounts in NetSuite.

The procedure required depends on whether the format profile is configured for direct connectivity to a financial institution or configured for manual import. If you are directly connected to a financial institution, the Account Mapping subtab is populated with information according to the financial institution accounts for which you have a configured connection. However, if you are setting up a format profile that uses the manual import method, you must manually enter each account mapping.

For information on these procedures, see the following topics:
Creating Format Profiles

- Mapping Accounts for Financial Institution Connectivity
- Mapping Accounts for Manual Import

Mapping Accounts for Financial Institution Connectivity

Map data from your financial institutions to corresponding accounts in NetSuite.

Note: To do this procedure, you need to configure a direct connection to a financial institution. For details, see Financial Institution Connectivity Configuration

The Account Mapping subtab is populated with information according to the financial institution accounts for which you have a configured connection.

To map bank accounts for financial institution connectivity:

1. Go to the appropriate format profile page for the appropriate financial institution record:
   a. Go to Setup > Accounting > Financial Institution > List.
      NetSuite displays the Financial Institutions page.
   b. Next to the appropriate financial institution record, click View.
      NetSuite displays the Financial Institution page.
   c. In the Format Profile subtab, click on the appropriate format Profile.
      NetSuite displays the Format Profile page.

2. In the Account Mapping subtab, from the Mapped Account dropdown list, select the bank or credit card account in NetSuite to which you want to map to your financial institution account.

   Note: The accounts available in the list are not restricted by any classifications, including subsidiaries, departments, locations, and classes. Any restriction preferences do not apply to the dropdown list.

3. Click Save to save the format profile or Save & New to save the current format profile and create a new one.

   NetSuite automatically initiates an import of the last 60 days of data. NetSuite displays a progress message. To view the progressing status of your import, click Track your status. NetSuite also creates a daily import schedule. For details, see Automatic Bank Data Import.

Mapping Accounts for Manual Import

Map accounts in the imported bank statements to corresponding accounts in NetSuite.

To map bank accounts for manual import:

1. Go to the appropriate format profile page for the appropriate financial institution record:
   a. Go to Setup > Accounting > Financial Institution > List.
      NetSuite displays the Financial Institutions page.
   b. Next to the appropriate financial institution record, click View.
      NetSuite displays the Financial Institution page.
   c. In the Format Profile subtab, click on the appropriate format Profile.
Creating Format Profiles

2. In the **Account Mapping** subtab, add one or more account mappings (one per row):
   a. In the **Account Mapping Key** column, enter an account mapping key from the statement file for this format profile.

   **Important:** For compliance reasons, you cannot enter a credit card number. For details on how NetSuite checks for a credit card number and what conditions are used, see the accountMappingKey input parameter description in addAccount.

   There is a limit of 80 characters.

   b. In the **Description** column, enter a description to help you identify this mapping key.

   c. From the **Mapped NetSuite Account** dropdown list, select the bank or credit card account in NetSuite to which you want to map the account key from the statement.

   **Note:** The accounts available in the list are not restricted by any classifications, including subsidiaries, departments, locations, and classes. Any restriction preferences do not apply to the dropdown list.

   d. To inactivate the Account Mapping Key, check the **Inactive** box. The box is cleared by default.

3. Click **Save** to save the format profile or **Save & New** to save the current format profile and create a new one.

Mapping Custom Bank Codes

Map custom bank transaction codes to corresponding bank data types in format profiles.

**To map bank transaction codes:**

1. Go to the appropriate Format Profile page for the appropriate financial institution record:
   a. Go to Setup > Accounting > Financial Institution > List.
   NetSuite displays the Financial Institutions page.

   b. Next to the appropriate financial institution record, click **View**.
   NetSuite displays the Financial Institution page.

   c. In the Format Profile subtab, click on the appropriate format profile.
   NetSuite displays the Format Profile page.

2. Click the **Transaction Code Mapping** subtab.

3. In the **Bank Transaction Code** column, enter a custom bank transaction code from your financial institution.
   For a list of custom bank transaction codes, contact your financial institution.
   There is a limit of 80 characters for the code.

4. In the **Description** column, enter a description to help you identify this bank transaction code.

5. From the **Bank Data Type** dropdown list, select the bank data type to which you want to map the bank transaction code.

6. From the **Debit/Credit** dropdown list, select **Debit** or **Credit** for the bank transaction code if you are using a parser that has unsigned amount values (for example, BAI2 or MT940 file format). Otherwise, select **N/A**.
Creating Format Profiles

Note: The Debit or Credit value you set in a format profile overrides the value in the bank data to be imported. For example, if the bank code type is a credit value but you select a debit value in your format profile, the data is imported as a debit.

7. To exclude the bank transaction code from transaction processing, check the Exclude box. The box is cleared by default.

NetSuite excludes and ignores any transactions with an excluded code. These excluded transactions do not count toward the number of imported transactions and do not appear in the Import Details page.

Some formats contain codes you want to exclude. For example, in the BAI2 format, the bank transaction code “890” does not contain useful monetary information for imported transactions. However, the “890” code is already excluded from the core parsers and parser plug-ins for BAI2.

8. To inactivate the bank transaction code, check the Inactive box. The box is cleared by default.

9. Click Save to save the format profile or Save & New to save the current format profile and create a new one.

Transaction Parser Configuration

If the Bank Statement Parsers SuiteApp is installed in your account, the Parser Configuration subtab appears on the Format Profile page. After you save, any parser configuration information (if available) is populated in this subtab.

There are two types of transaction parsers you can configure to import transactions:

- Standard parser – Available through the Bank Statement Parsers SuiteApp, which includes OFX or QFX, BAI2, and MT940 file format. After you save the format profile, configuration settings for the BAI2 or MT940 parser are populated in the Parser Configuration subtab. For details on modifying the parser-specific default settings, see Configuring Standard Bank Transaction Parsers. For details on the SuiteApp, see Bank Statement Parsers SuiteApp.

- Custom parser – Created by an administrator with the Parser Plug-in. For a custom (non-standard) parser to be available in the Transaction Parser list, you must install and activate one. For details, see the help topic Parser Plug-in.

Unlike some standard parsers, configuration settings are not automatically populated in the Parser Configuration subtab (if available) after you save the format profile. To use the subtab, contact the plug-in author and see the getFormatProfileId method in BankStatementParserInput. When configuration fields are available, enter settings as required.

Modifying Financial Institutions

You can modify fields and add additional format profiles to existing financial institution records.

Note: If you are using the pre-installed financial institution record available through the Bank Feeds SuiteApp, you cannot modify any fields. However, although the record comes with a pre-installed format profile, you can add additional format profiles, if you want.

To modify financial institution records:

1. Go to Setup > Accounting > Financial Institution > List.
NetSuite displays the Financial Institutions page.

2. Next to the financial institution record you want to modify, click **Edit**. NetSuite opens the Financial Institution page for editing.

3. For a financial institution record you have created, you can modify the following:
   - Financial Institution field
   - Description field
   - Inactive box for the financial institution record

   **Note:** To modify or add format profiles, the financial institution record must be in View mode.

4. Click **Save**.

---

### Modifying Format Profiles

To modify or add format profiles, the Financial Institution page must be in View mode.

**To modify format profiles:**

1. Go to Setup > Accounting > Financial Institution > List.
   NetSuite displays the Financial Institutions page.

2. Next to the financial institution record that contains the format profile you want to modify, click **View**.
   NetSuite displays the Financial Institution page.

3. In the Format Profile subtab, click on the appropriate format profile.
   NetSuite displays the Format Profile page.
   - To configure a connection to a financial institution, see Financial Institution Connectivity Configuration.
   - To map custom transaction codes, see Mapping Custom Bank Codes.
   - To map import accounts, see Bank Account Mapping.
   - For details on configuring your Parser Plug-in, see Transaction Parser Configuration.

4. Click **Edit**.
   You can modify the following on a format profile record that you create:
   - Format Profile field
   - Description field
   - Inactive box
   For more details on format profiles, see Creating Format Profiles.

5. Click **Save**.
   If the format profile is configured to connect to a financial institution and the save is successful, NetSuite displays a progress message that an import process has started. To view the progressing status of your import, click **Track your status**.
   NetSuite imports any new data from your existing accounts since the last successful import. For any new accounts mapped, NetSuite imports the last 60 calendar days of data. For more information, see Automatic Bank Data Import.
Modifying Format Profiles

If you have configured the format profile for manual import, your users must go to the File Statement Import page to import their data. For details, see Manual Bank Data Import.

Deleting Financial Institution Records

You can delete a financial institution record. However, if you delete one, NetSuite deletes the associated format profile as well provided it does not have any associated imports.

Tip: You can inactivate a financial institution record, instead of deleting it. See Modifying Financial Institutions.

To delete a financial institution record:

1. Go to Setup > Accounting > Financial Institution > List.
2. Next to the profile you want to delete, click Edit.
3. Click Delete.
   - NetSuite displays a confirmation message.
   - Click OK.

Deleting a Format Profile

You can delete a format profile from a financial institution record.

Tip: You can inactivate a format profile, instead of deleting it. See Modifying Format Profiles.

To delete a format profile record:

1. Go to Setup > Accounting > Financial Institution > List.
2. Next to the financial institution record that contains the format profile you want to delete, click View.
3. Click on the format profile you want to delete.
4. Click Edit.
5. Click Delete.
   - NetSuite displays a confirmation message.
6. Click OK.

Viewing the List of Financial Institution Records

You can view the list of financial institution records. If a record is not complete or requires updates, you can click Edit or View next to the record in the list.

For more information on modifications you can make, see Modifying Financial Institutions.

To view financial institution records:

1. Go to Setup > Accounting > Financial Institutions > List.
NetSuite displays the Financial Institutions page.

2. To filter the list of financial institutions:
   - To view a list that includes inactive record, click **Show Inactives**.
   - To sort by the Name column, click the column header.

3. You can do the following:
   - To inactivate the financial institution record, check the **Inactive** box. You do not need to open the record to inactivate it.
   - Click **Edit** next to an existing financial institution record to modify the fields on the record. For details, see **Modifying Financial Institutions**.
   - To modify or add format profiles, go to the financial institution record in View mode.
   - Click **View** next to an existing financial institution record to view the individual record and modify or add format profiles.
   - Click **New Financial Institution** to add a new financial institution record.

NetSuite displays the Financial Institution page. For more details, see **Creating Financial Institution Records**.
Bank Data Import

Manage bank and credit card accounts online in NetSuite. In NetSuite 2020.1, there are two ways to import bank data – automatically or manually.

- **Automatic import** – Set up by your administrator and eliminates the need for you to manually import data, yourself. On the Format Profile page, administrators can directly connect to financial institutions and automate your bank data imports on a daily schedule. See Automatic Bank Data Import.

- **Manual import** – On the Statement File Import page, download a bank statement file from your financial institution and then import it into NetSuite. You can import a file using settings in a format profile record configured by your administrator, or use NetSuite’s default parser functionality. See Manual Bank Data Import.

To ensure your bank statement files comply with the requirements for the supported file formats, see Supported File Formats for Bank Data Import.

To use the Statement File Import feature, enable the Import Online Banking File permission on your user role. For details, see Permissions for Banking Features.

When your data is imported into NetSuite, NetSuite automatically matches your data to account transactions in NetSuite on the Match Bank Data page (previously Confirm Transaction Matches).

**Note:** Imported Bank Data must be matched to existing transactions in NetSuite. Importing bank data does not automatically create transactions in NetSuite.

After the bank data import process is complete, match any unmatched transactions on the Match Bank Data page. After submitting the transactions for reconciliation, reconcile transactions on the Reconcile Account Statement page. For details, see Bank Data Matching and Reconciliation.

**Note:** If you want to use the Match Bank Data and Reconcile Account Statement page for an account, check the Use Match Bank Data and Reconcile Account Statement Pages box in the Edit Account page. For details, see Editing an Account.

Information on importing bank data in this topic includes:

- Automatic Bank Data Import
- Manual Bank Data Import
- Viewing Imported Account Statements
- Correcting Misidentified Duplicate Transactions
- Deleting Imported Statements

**Automatic Bank Data Import**

In NetSuite 2020.1, your administrator can automate bank data imports by configuring a format profile record that uses a Financial Institution Connectivity Plug-in. This plug-in enables them to create a direct connection to your financial institution and to initiate daily imports from your accounts. For details, see Automating Imports with the Financial Institution Connectivity Plug-in.

If this is the first time the format profile has ever been saved:

- NetSuite requests to download the last 60 calendar days of available bank data from your financial institution into NetSuite.
- A schedule is created to import your data automatically. Every day, NetSuite imports any new data from your financial institution into your accounts on the Match Bank Data page. If the data import fails, NetSuite requests data for up to seven calendar days back.
If this is not the first time the format profile has ever been saved, NetSuite imports any new data from your existing accounts you have mapped. For any new accounts mapped, NetSuite imports the last 60 calendar days of data.

To verify that your imports are successful, you can do the following:

- Go to the Imported Statement List page. This contains a list of imported bank statements, and includes import status, number of transactions imported and automatically matched by the Intelligent Transaction Matching feature, and so on. For details, see Viewing Imported Account Statements.
- Go to the Match Bank Data page. In NetSuite 2020.1, this page displays newly imported bank data, along with the current bank balance and bank balance date, for the selected account. For details, see Bank Data Matching and Reconciliation.

If the selected account does not contain the latest data, or if there was an import error, you can initiate a manual update on the Match Bank Data page. For details, see Updating Imported Bank Data.

Automating Imports with the Financial Institution Connectivity Plug-in

**Note:** This procedure is directed at administrators.

Use a Financial Institution Connectivity Plug-in to automate bank data imports for accountants and general financial users. You can use either the standard plug-in available through the Bank Feeds SuiteApp or develop a custom plug-in, yourself. This topic provides instructions on automating imports using a custom plug-in.

The Bank Feeds SuiteApp is targeted for release in February 2020.

**To automate imports using a custom plug-in**

1. Develop and upload a custom Financial Institution Connectivity Plug-in. For details, see the help topic Financial Institution Connectivity Plug-in.
2. Develop and upload a custom Parser Plug-in. For details, see the help topic Parser Plug-in.
4. Add a format profile to the financial institution record. See Creating Format Profiles.
5. Configure the format profile for direct connectivity to a financial institution.
   a. From the Connectivity Method dropdown list, select a custom Financial Institution Connectivity Plug-in.
   b. From the Transaction Parser dropdown list, select a custom Parser Plug-in.
   c. From the Connectivity Configuration subtab, configure a connection to a financial institution. See Financial Institution Connectivity Configuration.
   d. From the Account Mapping subtab, map your financial institution accounts to corresponding accounts in NetSuite. See Mapping Accounts for Financial Institution Connectivity.
   e. Optionally, map custom bank codes to corresponding bank data types. See Mapping Custom Bank Codes.
6. Click Save.
If the save is successful, NetSuite displays a progress message to notify you that a bank data import process has begun.

To view the processing status of your import, click Track your status. To match and reconcile data, go to the Match Bank Data page (Transactions > Bank > Match Bank Data).

**Note:** If you want to use the Match Bank Data and Reconcile Account Statement page for an account, check the Use Match Bank Data and Reconcile Account Statement Pages box in the Edit Account page. For details, see the help topic Editing an Account.

### Manual Bank Data Import

**Note:** This section is directed at accountants and general financial users.

On the Statement File Import page, you can download a bank statement file from your financial institution and then import it into NetSuite. NetSuite encrypts bank data files during processing. Files are removed and not stored after processing.

**Note:** For compliance reasons, NetSuite does not store bank statement files starting in 2020.1. After the file is parsed, it is removed from the database and cannot be accessed or downloaded.

On the Manual Import subtab, you must manually upload a file to import. You can then import the file using the settings configured in a format profile of a financial institution record, or otherwise use NetSuite's default parser functionality. NetSuite's default parser functionality is only compatible with certain file formats. For details, see Supported File Formats for Bank Data Import.

On the Connectivity Plug-in subtab, you can forgo a manual file upload by using a Bank Connectivity Plug-in. You can then use the settings configured in a format profile of a financial institution record to import your file.

For details on financial institution records, see Financial Institution Records.

For details on the different manual import methods, see the following topics in this section:

- Importing Using a Financial Institution Record
- Importing Using Default Parsers
- Importing Using the Bank Connectivity Plug-in

### Supported File Formats for Bank Data Import

**Important:** This section contains the supported file formats that you can use with default parsers.

**Note:** If you want to use the Match Bank Data and Reconcile Account Statement page for an account, check the Use Match Bank Data and Reconcile Account Statement Pages box in the Edit Account page.

Download the account statement from your financial institution or credit card company in one of the supported file formats. To ensure successful file import, do not modify the downloaded statement file.

**Important:** There is a limit of 50 characters for the file name length, including extension.

You can import account statements that are in the following formats:
Important: If you attempt to import a CAMT.053.001.06–formatted XML or BAI2-formatted TXT file, and the bank mapping fields in the relevant account are not set, the import will fail. For instructions, see the help topic Editing an Account. BAI2, CAMT, and CSV files must have UTF-8 encoding.

- BAI2 (Bank Administrative Institute Version 2) TXT with UTF-8 encoding – common format developed by Bank Administrative Institute for exchanging data. This data describes account activities, including securities transactions and lockbox deposits. NetSuite supports BAI2 Prior-Day Reporting for Bank Reconciliation. The statement can contain multiple bank accounts.

Note: If you are using default parsers, NetSuite supports the BAI2 format with UTF-8 encoding for the following banks: TD, Wells Fargo, US Bank, JP Morgan Chase, and Bank of America Merrill Lynch. If you are using Parser Plug-ins, NetSuite supports any format.

- CAMT.053.001.06 XML with UTF-8 encoding – file format in compliance with ISO 20022 and used by SWIFT. This statement file can contain end-of-day bank transactions for multiple bank accounts.
- CSV with UTF-8 encoding – files with the .csv extension. This statement file must also adhere to the provided CSV template and constraints. See Preparing CSV Files for Import.
- OFX (Open Financial Exchange) – file format sponsored by Intuit, Microsoft, and Fiserv (CheckFree). It is commonly used with Microsoft Money. When importing, select the method of character encoding associated with the file. If you are not sure which encoding the file has, check with your financial institution.
- QFX (Quicken Financial Exchange) – file format developed by Intuit and is used with their Quicken software. It is a variant of the OFX file format. When importing, select the method of character encoding associated with the file. If you are not sure which encoding the file has, check with your financial institution.

Note: The QIF file format is no longer supported. We recommend switching to one of the new supported formats. As of 2018.2, the QIF format has been deprecated.

If your financial institution provides banking data in another format, use a third-party conversion tool to convert the data file to a supported format and then import.

Preparing CSV Files for Import

Statement files in CSV format must adhere to the provided CSV template and constraints. The file must be UTF-8 encoded.

Download the CSV template from Transactions > Bank > Import Online Banking Data, or create the file with the required columns and specifications.

If you are using Excel, ensure the file is UTF-8 encoded. Go to File > Save As, and then select CSV UTF-8 (Comma delimited) (*.csv) from the file format list.

Important: The CSV file can only contain transactions that belong to a single account.

To ensure successful import, the column headings must be in the first row in the specified order as follows: Date (MM/DD/YYYY), Payer/Payee Name, Transaction ID, Transaction Type, Amount, Memo, NS Internal Customer ID, NS Customer Name, Invoice Number(s).

The following column data is required:

- Date (MM/DD/YYYY) – The transaction date. Content must be in the format of MM/DD/YYYY. If you are using Excel, ensure that the date does not get reformatted.
- Payer/Payee Name – Payer or Payee name. There is a limit of 70 characters.
Manual Bank Data Import

- **Transaction ID** – Unique Bank Transaction or Reference ID. This can also be populated with the check number. There is a limit of 90 characters.
- **Transaction Type** – Values in this column must be one of the following transaction types, all uppercase: CREDIT, DEBIT, CHECK, PAYMENT, ACH, INTEREST, DEPOSIT, TRANSFER, FEE, OTHER.
- **Amount** – The amount column must be a single column. If your file contains CREDIT and DEBIT columns, combine them into a single amount column. Positive amounts are CREDITS. Negative amounts are DEBITS, and must begin with a minus sign or be in parentheses.
  
  The amount column must not contain currency symbols or commas instead of decimal places. The amount currency should be in the same currency as the selected account.
- **Memo** – There is a limit of 4000 characters for the memo. The Memo field must not include any commas, semicolons or underscores.
- **NS Internal Customer ID** - (Optional) The NetSuite internal customer ID. Content must be numeric. There is a limit of 12 characters.
- **NS Customer Name** - (Optional) If the specified customer ID does not match any data, NetSuite uses the value to look up the customer ID. Content is free-form text. There is a limit of 512 characters.
- **Invoice Number(s)** - (Optional) A comma-separated list of invoice numbers in a single field, with no spaces between numbers (for example, 132,133,134). If you use a script or comma-separated file instead of the CSV template in a spreadsheet, put quotation marks around multiple invoice numbers (for example, “132,133,134”). For each invoice number in the list, there is a limit of 128 characters. If the imported file specifies multiple invoices for a transaction, they must all belong to same customer and AR account.

**Important:** If you exceed the character limit for any field, the import will fail. If you use multibyte characters, the character limit may become less.

If present, remove the following:

- Empty columns (containing no data) between other filled columns.
- Empty rows (containing no data) between other filled rows.
- Columns containing opening and closing balances.
- Any columns not specified by the template.
- Multiple accounts.
- Bank account number.

**Importing Using a Financial Institution Record**

Follow this procedure if you want to import using a financial institution record, which includes account and transaction code mapping.

**Important:** You must have financial institution records set up to choose this option. For details on creating and managing financial institution records, see Financial Institution Records.

If you do not have financial institution records set up, see Importing Using Default Parsers.

**To import a statement using a financial institution record:**

1. Go to your financial institution website and download your bank or credit card statement in the appropriate file format.
   
   Choose the file format based on whatever format profiles and transaction parsers you have configured. For details, see the following help topics:
When you import manually, you must create format profiles, parser plug-ins, and set up financial institution records.

### Important: To ensure successful file import, do not modify the downloaded statement file.

1. Give the statement file a name. There is a limit of 50 characters for the file name length, including extension.
2. Go to Transactions > Bank > Import Online Banking Data.
   - NetSuite displays the Statement File Import page. The Manual Import subtab is open by default.
3. Click **Choose File**, or use the drag-and-drop functionality.
   - **Important:** There is a limit of 50 characters for the file name length, including extension.
4. Select the name of the file you want to import.
5. Under Import Options, choose **Select a Financial Institution**.
6. From the **Financial Institution** list, select a financial institution record.
7. From the **Format Profile** list, select a format profile record. Only format profiles configured for manual import appear in this list. If the selected financial institution record only has one format profile, NetSuite selects it by default.
   - **Note:** Depending on your NetSuite role, you may be able to create a new financial institution or format profile record by clicking each plus icon.
8. Click **Import**.
   - **Note:** You do not have to wait on the page until the import is done. You can perform other actions such as a new import. The number of bulk imports you can perform at the same time is determined by your NetSuite Service Tier. For details, see the help topic [NetSuite Tiers of Service](#).

#### Importing Using Default Parsers

If you do not have financial institution records set up, import with NetSuite's default parser functionality.

- **Note:** NetSuite's default parsers are not customizable. Therefore, unless you have no financial institution records configured, you should use the standard parsers available through the Bank Statement Parsers SuiteApp. For details, see [Bank Statement Parsers SuiteApp](#).

#### To import a statement using default parsers:

1. Go to your financial institution website and download your bank or credit card statement in one of the accepted file formats. See [Supported File Formats for Bank Data Import](#).
2. Give the statement file a name. There is a limit of 50 characters for the file name length, including extension.


4. Click **Choose File**, or use the drag-and-drop functionality.

5. Select the name of the file you want to import.

6. Under Import Options, choose **Import with default parser (CSV, OFX, QFX, BAI2, or CAMT.053)**.

   **Note:** When you choose this option, NetSuite displays the link to download the CSV template. For details, see **Preparing CSV Files for Import**.

7. In the **Account** field, select the bank or credit card account for this import.

8. If required, in the **Character Encoding** field, select the method of character encoding associated with the file.

   If character encoding is not required for the file format (CAMT.053.001.06–formatted XML, BAI2–formatted TXT, or CSV), NetSuite does not display this field.

   - **(Unicode) UTF-8 encoding**  – UTF-8 character encoding is a variable-width encoding that can represent every character in the Unicode character set and has become the dominant character encoding.
     
     If you intend to use this format, ensure your file contains valid UTF-8 characters. You may have to use a third party editor to convert your file to UTF-8 prior to the import into NetSuite. Some editors append the BOM (Byte Order Marker) to the beginning of the file indicating that it is UTF-8 encoded.

   **Note:** If you are using the BAI2 format with UTF-8 encoding, you can use the following banks: TD, Wells Fargo, US Bank, JP Morgan Chase, and Bank of America Merrill Lynch.

   - **Western (Windows 1252) encoding**  – Windows 1252 encoding is a character encoding of the Latin alphabet, used by default in the legacy components of Windows in English and some other Western languages.

   - **Western (ISO-8859-1) encoding**  – ISO-8859-1 encodes what is commonly referred to as “Latin alphabet no. 1,” consisting of 191 characters from the Latin script. This character encoding is used throughout the Americas, Western Europe, Oceania, and much of Africa. It is also commonly used in most standard romanizations of East Asian languages.

   - **Chinese Simplified (GB18030)**  – GB18030 is the registered Internet name for the official character set of the People’s Republic of China (PRC), superseding GB2312. This character set is formally called “Chinese National Standard GB 18030-2005: Information technology -- Chinese coded character set.” GB abbreviates Guójìa Biàozhùn, which means national standard in Chinese. (This description is cited from Wikipedia.) This option is the default when the Chinese language preference has been selected.

   - **Japanese (Shift-JIS) encoding**  – Shift-JIS character encoding is the most widely used format for supporting the Japanese language. This option is the default for the Japanese edition and when the Japanese language preference has been selected.
Manual Bank Data Import

- **(Western) MacRoman** – MacRoman encoding is the basis for most popular 8-bit character sets including Windows-1252 and the first block of characters in Unicode.

9. If you are uploading a QIF file, select a date from the Date Format field.

   **Note:** The QIF file format is no longer supported. Switch to one of the new supported formats.

10. Click Import.

   **Note:** You do not have to wait on the page until the import is done. You can perform other actions such as a new import. The number of bulk imports you can perform at the same time is determined by your NetSuite Service Tier. For details, see the help topic NetSuite Tiers of Service.

NetSuite displays a progress message. To view the processing status of your import, click Track your status.

NetSuite displays the Imported Statement List page.


### Importing Using the Bank Connectivity Plug-in

Follow this procedure if you want to forgo the process of uploading bank statement files and download files locally from a secure sever. Provided that your financial institution can generate a file to a specific location, like a Secure File Transfer Protocol (sFTP) server, the Bank Connectivity Plug-in can get the file and upload it to NetSuite.

**Note:** Although you do not need to manually upload a file, you still need to manually initiate the plug-in to retrieve your data.

**Important:** You must have a Bank Connectivity Plug-in to do this procedure. You can use either a standard plug-in made available through the Bank Connectivity SuiteApp or a custom plug-in installed and activated by an administrator. The standard plug-in uses an sFTP connection to ensure a secure electronic connection to a financial institution, for inbound transmissions, through NetSuite. For details on the SuiteApp and the standard sFTP plug-in, see the help topic Bank Connectivity SuiteApp. For details on creating a plug-in outside of NetSuite, see the help topic Bank Connectivity Plug-in.

To import bank data using the Bank Connectivity Plug-in:

1. Go to Transactions > Bank > Import Online Banking Data.
   NetSuite displays the Statement File Import page. The Manual Import subtab is open by default.

2. Click the Connectivity Plug-in subtab.

3. From the Connectivity Plug-in list, select a Bank Connectivity Plug-in. Only Bank Connectivity Plug-ins appear in this list.

4. From the Financial Institution list, select a financial institution record.

5. From the Format Profile list, select a format profile record. Only format profiles configured for manual import appear in this list. If the selected financial institution only has one format profile, NetSuite selects it by default.
6. Click **Import** to initiate the import process.

The Bank Connectivity Plug-in retrieves the file and uploads it to NetSuite.

NetSuite displays a progress message. To view the processing status of your import, click **Track your status**.

NetSuite displays the Imported Statement List page.

7. (Optional) When the import process completes, on the Imported Statement List page, click **Match Bank Data** in the Next Steps column. NetSuite redirects you to the Match Bank Data page.

### Viewing Imported Account Statements

You can view the details of each imported bank statement on the Imported Statement List page. You can sort the items in the list by clicking the column header.

To import a bank or credit card statement, see **Bank Data Import**.

**Note:** Depending on your NetSuite role, you may be able to create a new financial institution or format profile record, as well as a new connectivity plug-in, by clicking each plus icon.

**Note:** If you want to use the Match Bank Data and Reconcile Account Statement page for an account, check the **Use Match Bank Data and Reconcile Account Statement Pages** box in the Edit Account page.

#### To view the imported statement:

1. Go to Transactions > Bank > Import Online Banking Data > List.

NetSuite displays the Imported Statement List page.

**Tip:** You can create a saved search to quickly locate a specific set of imported transactions. Click **Search** to define your saved search. For information about saved searches, see the help topics **Saved Searches** and **Defining a Saved Search**.

**Tip:** If you do not want to see failed and deleted imports in the list, you can modify the Bank Import Status filter to only show Completed imports in the list. You should view the details associated with an imported statement to ensure that each transaction properly imported and to troubleshoot any transaction that may impact reconciliation.

The information provided on this page includes the following:

- **Edit and View** – Clicking these links provides the details associated with the specific imported statement. You can view or delete a successfully imported statement record. Clicking Edit enables you to clear the Duplicate box or delete the statement. You only have the option to view a statement that failed to import or was deleted.

- **File Name** – The name of the imported statement file or the name of the Financial Institution Connectivity plug-in used to import data directly from a financial institution. This name is provided regardless of whether the import completed, failed, or succeeded but was deleted.

- **Status** – The status of the bank import. To filter the status, you can select one or more options from the Bank Import Status list in the filter region. The default value is All.

- **Submitted** – The system date and time at which the statement was submitted for import.
### Viewing Imported Account Statements

- **Completed** – The system date and time at which the import process finished, whether it failed or completed successfully.
- **Imported By** – This value represents the user who imported the file.
- **NetSuite Accounts** – The list of NetSuite accounts to which the transactions belong.
- **Imported** – The total number of transactions in the imported statement.
- **Automatched** – The number of transactions matched by the Intelligent Transaction Matching feature for this statement.
- **Duplicates** – The number of duplicate transactions from the imported statement.
- **Next Steps** – If the import was successful, the **Match Bank Data** link appears in this column, which takes you to the Match Bank Data page. If all the transactions are cleared but not all are reconciled, the **Reconcile Account Statement** link appears. If the import failed, click **View** to see the error message and next steps.

**Tip:** To refresh the information for the imported statements, click the refresh icon above the table. Next to the icon, you can see the Last Refreshed date and time.

2. To view the details of an imported statement, including any error messages, click **View**.

   The following details are provided on the Import Details record:
   - **Bank Statement Number** – The internal ID of the import record. You can enable internal IDs on the Set Preferences page (Home > Set Preferences). Disabled by default.
   - **Date Created** – The date and time when the import record was created.
   - **Date Completed** – The date and time when the import process completed.
   - **Statement Date** – The statement date in the import file. NetSuite only displays this value if it is available and the import is successful.
   - **Import Status** – The values could be Completed, Failed, or Deleted. If the import failed, the page also displays the error message and next steps.
   - **File Name** – The name of the imported statement file or the name of the Financial Institution Connectivity plug-in used to import data directly from a financial institution. This name is provided regardless of whether the import completed, failed, or succeeded but was deleted.
   - **Imported By** – This value represents the user who imported the file. If you view a deleted statement, this value represents the user who deleted the imported statement.
   - **Format Profile** – If you have a financial institution record configured, this value specifies the format profile selected for the import, which stores the file format information. The format profile determines which parser reads the data, as well as the account mapping and transaction code mapping. For details, see Creating Format Profiles.
   - **Character Encoding** – If applicable, this value represents the character encoding used for the imported file. For information about the available encoding methods, see the help topic Choose Import Character Encoding.
   - **Date Format** – If applicable, this value represents the date format selected for the import.
   - **Transactions** – Under this heading, NetSuite displays the number of transactions imported, matched by the Intelligent Transaction Matching feature, and detected as duplicates.
   - **Next Steps** – If the import was successful, the **Match Bank Data** link appears under this heading, which takes you to the Match Bank Data page. If all the transactions are cleared but not all are reconciled, the **Reconcile Account Statement** link appears.

The Import Details page also provides a list of the individual transactions in the imported statement. Review the following information to validate the integrity of your imported statement:
- **Transaction Date** – This is the date on which the transaction occurred.
Viewing Imported Account Statements

- **Payer/Payee Name** – This is the name of the merchant or payee.
- **Transaction ID** – This is the transaction ID, if available.
- **Memo** – This is the memo for the transaction, if available.
- **Amount** – This is the transaction amount.
- **NetSuite Accounts** – This value represents the NetSuite account to which the transaction belongs. One statement can contain transactions from multiple accounts.
- **Customer ID** – The NetSuite internal customer ID number, if available. When you import the statement, NetSuite checks for this data before Customer Name or Invoice Number. If the Customer ID is missing, NetSuite checks for the Customer Name.
- **Customer Name** – The NetSuite customer name, if available. When you import the statement, if the Customer ID is missing, NetSuite checks for the Customer Name. If the Customer Name is missing, NetSuite checks for the Invoice Numbers.
- **Invoice Numbers** – The NetSuite invoice numbers, if available. When you import the statement, if the Customer Name and Customer ID are missing, NetSuite checks for the invoice numbers. The invoices must be in the same currency as the bank account's currency. If the imported file specifies multiple invoices for a transaction, they must all belong to same customer and AR account. If there are more than five invoices associated with the transaction, this column only displays a count of the invoices.
- **Duplicate** – This value can be Yes or No. If Yes, the system detected that a transaction with these values already exists in the system from a previous import. If the transaction is not a duplicate, see Correcting Misidentified Duplicate Transactions.

**Note:** When you delete a bank statement, NetSuite deletes all of the transactions for that statement. If you delete an imported transaction, then import the same transaction again, NetSuite does not mark the transaction as a duplicate. For more information, see Deleting Imported Statements.

**Correcting Misidentified Duplicate Transactions**

If a transaction is incorrectly identified as a duplicate, you can fix this by clearing the Duplicate box for the transaction on the Import Details page.

**To clear a Duplicate box:**

2. Next to the imported statement that is incorrectly identified as a duplicate, click **Edit**.
3. On the Import Details page, clear the **Duplicate** box.
   
   You only have the ability to clear the box. You cannot manually mark duplicate transactions.

**Deleting Imported Statements**

If you feel there is a problem, you can delete an unreconciled bank or credit card statement.

**Important:** Once you reconcile a statement, you cannot delete or change the imported file.

The Delete option enables you to delete any successfully imported, unreconciled account statement. You may want to delete an imported statement to remove the imported bank details from your system. If you delete a statement that still contains matched transactions, NetSuite will undo the matches.
Deleting Imported Statements

Note: When you delete a bank statement, NetSuite deletes all of the transactions for that statement. If you delete an imported transaction, then import the same transaction again, NetSuite does not mark the transaction as a duplicate.

To delete an imported statement:

1. Go to Transactions > Bank > Import Online Banking Data > List.
2. For the statement you want to delete, click Edit.
3. Under Actions, click Delete.
4. In the confirmation popup message, click OK.
   NetSuite deletes the statement, including all of its transactions.
Bank Account Reconciliation and Reporting

Reconcile your bank statement against your bank account register to keep your NetSuite account accurate. You can also enter new transactions while reconciling. If you begin but want to finish your reconciliation later, NetSuite preserves the reconciliation until you resume at a later time.

**Note:** This is the original reconciliation feature. A redesigned version of transaction matching and statement reconciliation is now available, which enables you to efficiently match and reconcile transactions on the same page, without requiring Excel or third-party tools. For details, see Bank Data Matching and Reconciliation.

Information on bank account reconciliation in this topic includes:

- Reconciling Bank Statements
- Entering Transactions While Reconciling
- Completing a Reconciliation at a Later Time
- Deleting a Reconciliation
- Printing Reconciliation Reports
- Bank Register Report
- Reconciliation Summary Report
- Reconciliation Detail Report
- Reconciliation History Report

### Reconciling Bank Statements

**Note:** This is the original reconciliation feature. A redesigned version of transaction matching and statement reconciliation is now available, which enables you to efficiently match and reconcile transactions on the same page, without requiring Excel or third-party tools. For details, see Bank Data Matching and Reconciliation.

Reconcile your bank statement against your bank account register to keep your NetSuite account accurate.

If the items have cleared the bank, but do not yet appear on a statement, you can manually mark transactions as cleared in the check register. Go to Reports > Financial > Chart of Accounts. Click the name of the account. Check the box in the Clr column if a transaction is cleared, but not yet reconciled. A manually cleared transaction is not associated with a statement date and does not appear on a Bank Reconciliation Report. The account register shows if a cleared transaction is reconciled and identifies the reconciliation date. Transactions that require reconciliation have a Reconcile link in the Reconcile column.

**Note:** If the Clr column contains YES or NO instead of a check box, the account is using the redesigned version of transaction matching and statement reconciliation. To clear transactions, you must go to the Match Bank Data page. For details, see Bank Data Matching and Reconciliation and Reconciling Bank & Credit Card Statements.

Checks written in a previous month that are not cleared display on the Reconcile Bank Statement page on the Deposits and Credits subtab. Until these checks are cleared they do not appear on a Bank Reconciliation Report.
Reconciling Bank Statements

For information about reconciling transactions that were previously reconciled and subsequently canceled, see Troubleshooting Reconciliation History Reports.

If you void a check, reconcile the voiding journal entry. For details on voiding checks, see Voiding a Check.

If a previously-reconciled transaction is edited, the transaction becomes unreconciled again. Open the correct statement period for the transaction and reconcile the transaction again.

Transfers to and from bank accounts appear on your bank statement as other transactions and are reconciled in the same method. Enter deposits and credits, and checks and payments as required.

When you reconcile a bank account, all reconciled transactions are automatically marked cleared. To close a period, not all transactions have to be reconciled.

Tip: You can unclear a cleared transaction through the register for the bank account. Click Actions, then click Go To Register. On the account register, locate the transaction and clear the Clr box.

If the Clr column contains YES or NO instead of a check box, the account is using the redesigned version of transaction matching and statement reconciliation. To clear transactions, you must go to the Match Bank Data page. For details, see Bank Data Matching and Reconciliation and Reconciling Bank & Credit Card Statements.

Note: International users may be required to use alternative methods for reconciling bank statements. For example, you might be required to make adjustments to accommodate special taxes on new transactions such as the Goods and Services Tax (GST) in Australia. For more information, see the help topic Tax Accounting Overview.

You can begin an account reconciliation and then resume at a later time. NetSuite preserves the reconciliation until you return to save it or save and print it. For more information, see Completing a Reconciliation at a Later Time.

For permissions to reconcile bank statements, see the help topic Standard Roles Permissions Table.

To reconcile custom transactions, go to Accounting Preferences and then check the Show All Transaction Types In Reconciliation box. See the help topic General Accounting Preferences.

To reconcile your bank statement:

1. Go to Transactions > Bank > Reconcile Bank Statement.
2. In the Account field, select the bank account you are reconciling.
   The selected bank account determines the default subsidiary and currency. This filters the open transactions at the line level.

   Note: If you enter transactions and then change bank accounts, NetSuite changes the currency and subsidiary and clears all line item transactions.

3. In the Statement Date field, enter or pick the date of the statement.
4. In the Start Date field, enter the beginning of the reconciliation period. Unreconciled transactions before this date do not display on the subtabs.
5. In the Ending Statement Balance field, enter the closing balance on the statement.
Reconciling Bank Statements

The **Reconciled This Statement** and **Difference** fields update as you check the reconcile box next to transactions.

The **Difference** field displays the amount that you must reconcile; when the difference is zero, reconciliation is complete.

NetSuite calculates the **Difference** field amount by subtracting the combined amounts of the **Last Reconciled Balance** and **Reconciled This Statement** from the **Ending Statement Balance**.

**Tip:** You can specify the number of items that display on the page at Home > Set Preferences > General > Number of Rows in List Segments.

 Deposits and Credits

1. Click the **Deposits and Credits** subtab.

   This subtab shows deposits and credits to be reconciled.

   A **Yes** shows in the **Cleared** column for all transactions that have been marked as cleared through the bank on the account register.

   If you use NetSuite OneWorld, note that only transactions for the subsidiary associated with the bank account are listed.

2. Check the boxes next to the transactions you want to reconcile.

   As you check transactions, the **Reconciled This Statement** field is updated, and the total of those transactions shows on the **Deposits and Credits** subtab.

   - To reconcile all deposits and credits, click **Mark All**.
   - If you mark bank transactions as **Cleared** on an ongoing basis, when you open a reconciliation you can click **Mark All Cleared to Reconcile**, which updates all transactions already cleared to be marked for reconciliation. Then, each transaction does not need to be marked individually.

**Note:** Click the **Date** or **Tran No.** links to view the original transaction. Click the **Payor** link to view the entity record.

 Checks and Payments

1. Click the **Checks and Payments** subtab.

   This subtab shows checks and payments that need to be reconciled. Credit card refund transactions also show on this subtab.

   A **Yes** shows in the **Cleared** column for all transactions that have been marked as cleared through the bank on the account register. Transactions must be both cleared and reconciled to close out a period.

   If you use NetSuite OneWorld, note that only transactions for the subsidiary associated with the bank account are listed.

2. Check the boxes next to the transactions you want to reconcile.

   As you check transactions, the **Reconciled This Statement** field is updated, and the total of those transactions shows on the subtab.

   - To reconcile all checks and payments, click **Mark All**.
   - If you mark bank transactions as **Cleared** on an ongoing basis, when you open a reconciliation you can click **Mark All Cleared to Reconcile**, which updates all transactions that are already cleared to be marked for reconciliation. Then, each transaction does not need to be marked individually.
Reconciling Bank Statements

New Charges

1. Click the **New Charges** subtab.
2. Fill in the appropriate information for a reconciled charge, and then click **Add**.
   
   You can enter a charge with a date after the statement date for the reconciliation, and the charge remains reconciled with this statement.

   If you use NetSuite OneWorld, note the following:
   - **Payee** (vendor or other entity) must be associated with the same subsidiary as the bank account.

   **Note:** If you have shared vendors and customers with multiple subsidiaries and this subsidiary is a secondary subsidiary to one or more shared entities, the **Payee** field lists all of the entities to which this subsidiary is assigned. Selecting a shared entity payee enables you to enter line items for all of the entity's open transactions as well as the open transactions belonging to this subsidiary. For more information about shared records, see the help topics Assigning Subsidiaries to a Vendor and Assigning Subsidiaries to a Customer.

   - **Payee** (vendor or other entity) must be associated with the same subsidiary as the bank account.
   - **Accounts** are restricted to non-bank accounts associated with the same subsidiary and currency as the selected bank account.
   - Only classes, departments, and locations associated with the same subsidiary as the bank account are available.

3. Repeat this process for each reconciled charge.

   An example of an other charge is your bank service charge.

   As you add transactions, the Reconciled This Statement field is updated, and the total of all the other charges is shown on the subtab.

New Deposits

1. Click the **New Deposits** subtab.
2. Fill in the appropriate information for the deposit, and then click **Add**.
   
   You can enter a deposit with a date after the statement date for the reconciliation, and the deposit remains reconciled with this statement.

   An example of an other income is the interest your bank pays you.

   If you use NetSuite OneWorld, note the following:
   - **Payor** (vendor, customer, or other entity) must be associated with the same subsidiary as the bank account.

   **Note:** If you have shared vendors and customers with multiple subsidiaries and this subsidiary is a secondary subsidiary to one or more shared entities, the **Payor** field lists all of the entities to which this subsidiary is assigned. Selecting a shared entity payor enables you to enter deposits for the entity as well as this subsidiary.

   - **Accounts** are restricted to non-bank accounts associated with the same subsidiary and currency as the selected bank account.
Reconciling Bank Statements

- Only classes, departments, and locations associated with the same subsidiary as the bank account are available.

As you add transactions, the **Reconciled This Statement** field is updated, and the total of all the other charges is shown on the subtab.

3. Repeat this process for each reconciled deposit.

**Note:** When you have cleared all the transactions listed on the statement and entered any additional charges or deposits, the **Ending Statement Balance** should equal the **Reconciled This Statement** balance plus the **Last Reconciled Balance**. Use the **Difference** field to track your progress in matching these balances.

When finished, choose one of three options:

- Click **Save** to reconcile your bank statement.
- Click **Save & Print** to save and print your reconciliation.
- Click **Complete Later** to save your reconciliation until you return to submit or print it.

To view your previous reconciliations, go to Transactions > Bank > Reconcile Bank Statement. Click **History**.

### Entering Transactions While Reconciling

When reconciling your bank or credit card statement, you can enter new transactions that are not previously recorded. For example, enter bank service charges and then reconcile your bank statement for that transaction.

**Note:** You can enter new charges and credits that have dates later than the statement date you are using for the reconciliation. These charges and credits remain reconciled to the statement.

**To enter new transactions while reconciling a bank statement:**

1. Go to Transactions > Bank > Reconcile Bank Statement.
2. Select the transactions you want to reconcile on the **Deposits and Credits** or **Checks and Payments** subtabs.
3. Click the **New Charges** subtab.
4. Fill in the appropriate information for the new charge transaction, and click **Add**.
5. Click the **New Deposits** subtab.
6. Fill in the appropriate information for the new deposit transaction, and click **Add**.
7. When you have finished, choose one of three options:
   - Click **Save & Print** to save and print your reconciliation.
   - Click **Save** to reconcile your bank statement.
   - Click **Complete Later** to save your reconciliation until you return to submit or print it.

For more information, see **Bank Account Reconciliation and Reporting**.

**To enter new transactions while reconciling a credit card statement:**

1. Go to Transactions > Bank > Reconcile Credit Card Statement.
2. Select the transactions you want to reconcile on the **Payments and Credits** or **Charges and Cash Advances** subtabs.
3. Click the **New Charges** subtab.
4. Fill in the appropriate information for the new charge transaction, and click **Add**.
5. Click the **New Credits** subtab.
6. Fill in the appropriate information for the new credit transaction, and click **Add**.
7. When you have finished, choose one of three options:
   - Click **Save & Print** to save and print your reconciliation.
   - Click **Save** to reconcile your bank statement.
   - Click **Complete Later** to save your reconciliation until you return to submit or print it.

For more information, see *Reconciling Credit Card Statements*.

### Completing a Reconciliation at a Later Time

You can begin an account reconciliation and then resume at a later time. NetSuite preserves the reconciliation until you return to save it or save and print it.

To preserve a reconciliation for completion at a later time, make note of the date in the Statement Date field, then click Complete Later on the Reconcile Bank Statement or Reconcile Credit Card Statement page. When you resume the reconciliation for the bank or credit card account, enter the noted date in the Statement Date field, if necessary. The transactions that were originally marked reconciled are also marked cleared. In the Reconcile column, continue reconciling transactions. When you complete the reconciliation, click Save or Save & Print. You can also click Complete Later if you must again resume reconciliation at a later time.

**Important:** You can preserve only one reconciliation for completion at a later time. When you go back to Transactions > Bank > Reconcile Bank Statement or Transactions > Bank > Reconcile Credit Card Statement, the preserved reconciliation reappears. If you make changes to the preserved reconciliation including changes to dates and then click Complete Later again, NetSuite deletes the previously preserved reconciliation and replaces it with the updated reconciliation. If you change the account from that of the preserved account reconciliation, NetSuite displays a message indicating that the preserved reconciliation is erased and all work is lost.

Be aware that transactions marked reconciled are not reconciled until you save the reconciliation, even though the cleared transactions in the account register show the Reconciled Date as the noted date from the Statement Date field on the Reconcile Account Statement page.

### Deleting a Reconciliation

**Important:** This is the original reconciliation feature. If you are using the Account Reconciliation feature, and you want to delete a reconciled statement, see *Deleting Reconciled Statements*.

For more information on the Reconcile Account Statement page, see *Bank Data Matching and Reconciliation*.

After completing a bank or credit card statement reconciliation, you can delete the reconciliation. For example, if you discover that a statement contains an error such as an incorrect date, you can delete the reconciliation and then enter a new one.
To delete a statement reconciliation:

1. Depending on the type of statement you need to delete, do one of the following:
   - For bank statements, go to Transactions > Bank > Reconcile Bank Statement.
   - For credit card statements, go to Transactions > Bank > Reconcile Credit Card Statement.
2. Enter the date of the reconciled statement.
   This is the date from the Statement Date field.
3. From the Actions menu, click Delete.
   You are prompted to confirm deletion of the reconciliation.
4. Click OK to confirm the deletion.

   **Note:** Previously cleared transactions remain Cleared on the Find Matching Transactions page even if the reconciliation is deleted.

To verify that a reconciliation was deleted, go to Reports > Banking/Budgeting > Reconciliation. Confirm that the statement date is no longer available in the report.

Printing Reconciliation Reports

In NetSuite, you can print your current and previous bank and credit card statement reconciliation reports.

To change the width of one column, drag the boundary on the right side of the column heading until the column is the preferred width.

To print a bank statement reconciliation report:

1. Go to Transactions > Bank > Reconcile Bank Statement.
2. To print your current statement, reconcile your statement.
   Click Save & Print to submit and print the report.
3. To print a previous statement, click History.
   Select a bank statement reconciliation. Change the date range, if needed, to find the reconciliation.
   Click the print icon to print the report.

To print a credit card statement reconciliation report:

1. To print your credit card statement reconciliation, go to Transactions > Bank > Reconcile Credit Card Statement.
2. To print your current statement, reconcile your statement.
   Click Save & Print to submit and print the report.
3. To print a previous statement, click History.
   Select a credit card reconciliation. Change the date range, if needed, to find the reconciliation.
   Click the print icon to print the report.

Bank Register Report

The Bank Register report lists all transactions for a particular bank account such as a checking account, a savings account, and a petty cash account. Use the bank register report to view existing transactions.
From the report you can click on a row to navigate to the source transaction. The bank register report contains view-only data.

All cash accounts are treated as bank accounts in NetSuite, even if you do not keep money for that account in a bank. For example, you create a bank account to track petty cash and record any petty cash transactions on the Write Checks page. Withdrawals or payments taken from petty cash appear as line items on the petty cash account register so that you can track your transactions.

**To view the Bank Register report:**

Go to Reports > Banking/Budgeting > Bank Register.

A message appears indicating that your report is loading. The status bar in the footer of the report indicates the progress as your report loads. You can click Cancel Report next to the status bar to stop the report from loading.

The report includes the following:

- **Account** - bank account number and name
- **Number** - transaction number or reference
- **Payee** - person or company
- **Account** - financial account affected by transaction
- **Deposit** - amount of deposit
- **Payment** - amount of withdrawal or payment
- **Balance** - previous balance amount plus or minus the transaction amount

Customize the report to add fields or change the report layout. You cannot customize the check register.

To print the report, click the print icon at the bottom of the page. For details on exporting, see the help topic Exporting Reports, Searches, and Lists.

**To change the bank account for the Bank Register report:**

1. Go to Home > Set Preferences.
2. In the Reporting section of the Analytics subtab, select the bank account you want to view in the Default Bank Account field.

**Reconciliation Summary Report**

The Reconciliation reports show cleared and outstanding transactions for the account on which you choose to report.

The Reconciliation Summary report provides a summary of your reconciliation for a bank account and provides balances for each item. In addition to reconciled and unreconciled items, included are:

- balances for transactions with no prior reconciliation history
- totals of your cleared and outstanding transactions during the time period
- difference between all reconciled balances and the unreconciled balance
- previous bank balances
- ending bank balance
- current reconciled balance
- reconciled balance as of a specific date
You can view this report only after you have reconciled the bank account in NetSuite. This report is critical for companies who require a paper trail to show that current and historical data is accurate and complete.

**Note:** Transactions cleared on a register, but not reconciled, appear on Reconciliation Summary reports under the appropriate heading.

We recommend that you print your Reconciliation report before you reconcile another account because you cannot recapture the same information.

To print the report, click the print icon at the bottom of the page. For details on exporting, see the help topic *Exporting Reports, Searches, and Lists.*

**To view the Reconciliation Summary report:**

Go to Reports > Banking/Budgeting > Reconciliation.

A message appears indicating that your report is loading. The status bar in the footer of the report indicates the progress as your report loads. You can click Cancel Report next to the status bar to stop the report from loading.

**Note:** This report does not support reporting by period even when the Report by Period preference is set to All Reports. The Report by Period preference can be configured at Home > Set Preferences, the Analytics subtab.

**Reconciliation Detail Report**

The Reconciliation Detail report displays a list of the reconciled, both cleared and uncleared items for a bank account for the statement period designated by the statement date.

**Note:** You can customize the report to remove columns that you prefer to not view in printed format. Removing columns is useful if your page orientation preference displays the report in a crowded format.

For the statement period, the report categorizes, then itemizes the transactions, providing the transaction types, dates, associated document numbers, entity names, any memos, and transaction balances. The Reconciliation Detail report categorizes transactions using the following data, which corresponds to field data from Reconcile Bank Statement and Reconcile Credit Card Statement:

- **Reconciled** - lists all the cleared and reconciled transactions, grouped into subcategories (Deposits and Other Credits, Checks and Payments), along with category totals.
- **No Previous Reconciled Balance** - only appears if there is no previous reconciled balance for the selected account and statement date, instead of Last Reconciled Balance, and displays a zero balance total.
- **Last Reconciled Statement Balance - <date>** - the balance of the last reconciled statement for this account. This field is only available if this is not your first reconciled statement.
- **Current Reconciled Balance** - the difference between Last Reconciled Statement Balance and Total - Reconciled.
- **Reconcile Statement Balance - <date>** - the closing balance for the statement.
- **Difference** - the difference between Current Reconciled Balance and Reconcile Statement Balance.
- **Unreconciled** - list of all transactions that are in the system but are not reconciled or reflected in your statement.
You can see this report only after you have reconciled that bank account in NetSuite. This report is critical for companies who require a paper trail to show that current and historical data is accurate and complete.

For details on reconciling, see Reconciling Bank Statements.

**Note:** Transactions cleared on a register, but not reconciled, appear on Reconciliation Detail reports under the appropriate heading.

You should print your Reconciliation report before you reconcile another account because you cannot recapture the same information.

To print the report, click the print icon at the bottom of the page. For details on exporting, see the help topic Exporting Reports, Searches, and Lists.

**To see a Reconciliation Detail report:**

1. Go to Reports > Banking/Budgeting > Reconciliation > Detail.
2. From the Account dropdown list, select the account for which you want to see a report.
3. From the Statement Date dropdown list, select the statement date for which you want to see a report.
4. Click Refresh.
   
   NetSuite loads and displays your report.

**Note:** This report does not support reporting by period even when the Report by Period preference is set to All Reports. The Report by Period preference can be configured at Home > Set Preferences, the Analytics subtab.

**Reconciliation History Report**

The Reconciliation History report lists the completed reconciliations for a bank account in the date range specified. Use this report to view statement balances, link to the detail report for each reconciliation, and track historical reconciliation data for auditing purposes. This report is critical for companies who require a paper trail to show that current and historical data is accurate and complete.

For each reconciliation, the report shows the statement date, bank account, statement balance, amount reconciled for this statement, previous reconciled balance, and any differences between.

**Note:** Transactions cleared on a register do not appear on Reconciliation History reports. Reconciliation History reports only display reconciled items.

This report shows only completed and saved bank reconciliations and is not available from the Reports menu.

**To view the Reconciliation History report:**

1. Go to Transactions > Bank > Reconcile Bank Statement.
   
   A message appears indicating that your report is loading. The status bar in the footer of the report indicates the progress as your report loads. You can click Cancel Report next to the status bar to stop the report from loading.
3. To print the report, click the print icon at the bottom of the page. For details on exporting, see the help topic Exporting Reports, Searches, and Lists.
Troubleshooting Reconciliation History Reports

Reconciliation History reports only display reconciled items.

Transactions cleared through a register, but not reconciled, appear on Reconciliation Summary and Reconciliation Detail reports, under the appropriate heading; however, they do not appear in Reconciliation History reports.

The register lets you manually mark a transaction as cleared, but it does not associate a statement date with the transaction. These manually cleared transactions with no statement date do not appear in the report, since the Reconciliation reports track transactions by statement date.
Bank Data Matching and Reconciliation

**Note:** To use the Match Bank Data and Reconcile Account Statement pages, you must have the proper permissions assigned to your role. For details, see Permissions for Banking Features. If you want to use the pages for an account, check the Use Match Bank Data and Reconcile Account Statement Pages box in the Edit Account page. For details, see the help topic Editing an Account.

When bank data is imported into NetSuite, you can efficiently match and reconcile transactions, without requiring spreadsheets or third-party tools.

**Note:** If your administrator has set up automatic bank data imports for your financial institution, NetSuite imports new bank data daily from your accounts. The Match Bank Data page displays the latest imported bank data, as well as daily bank balances of the account and the bank balance date. If your account data is outdated, you can initiate a manual update directly from the Match Bank Data page. For details, see Updating Imported Bank Data.

On the Match Bank Data page, you can match transactions, review matches, and exclude transactions do you not want to match. The Match Bank Data page shows side-by-side lists of imported bank data and account transactions in NetSuite.

After you complete matching and submit your matches for reconciliation, reconcile the transactions. Go to the Reconcile Account Statement page to review the matches, include or exclude transactions from the reconciliation, and then reconcile the statement.

To reconcile custom transactions, go to Accounting Preferences and then check the Show All Transaction Types In Reconciliation box. See the help topic General Accounting Preferences.

Information on bank data matching and reconciliation in this topic includes:

- Intelligent Transaction Matching for Bank Data
- Reconciling Bank & Credit Card Statements
- Account Reconciliation Reports

### Updating Imported Bank Data

On the Match Bank Data page, you can initiate a request to NetSuite to manually update your bank data for a financial institution account. You should only do this if your account in NetSuite does not contain the latest data from your financial institution or if there was an import error. Otherwise, wait for the next scheduled bank data import. For details on automatic importing, see Automatic Bank Data Import.

**Note:** To do this procedure, your administrator must set up bank feeds for your financial institution. For details, see Creating Financial Institution Records.

**To update imported bank data:**

1. Go to Transactions > Bank > Match Bank Data.
2. From the Account list, select the bank or credit card account for which you want to update your data.

**Note:** If you want an account to be available in this list, check the Use Match Bank Data and Reconcile Account Statement Pages box in the Edit Account page.

The name of the subsidiary to which the account belongs is populated in the Subsidiary field next to the Account list.
NetSuite displays the current bank balance and bank balance date at the top of the page. In the Imported Bank Data and Account Transactions grids, NetSuite displays the imported bank data and account transactions currently in NetSuite for the selected account.

3. At the top of the page, click the **Update Imported Bank Data** button. This initiates a request to NetSuite to retrieve the latest data from your financial institution account. If the request is accepted, NetSuite displays a message saying that an import is in process. To view the processing status of your import, click **Track your status**. If the request is denied, NetSuite will update your imported bank data at the next scheduled import.

4. To see the latest data from your financial institution account, refresh the page or refresh the Imported Bank Data grid. To refresh the Imported Bank Data grid, click the Refresh icon above it. If the import is completed, the Imported Bank Data grid displays the latest data from your account. The Intelligent Transaction Matching feature automatically matches any data that NetSuite creates after the last successful import. To match and reconcile your data, see Reconciling Bank & Credit Card Statements.

### Intelligent Transaction Matching for Bank Data

When bank data is imported into NetSuite, the Intelligent Transaction Matching feature automatically matches imported bank data with the existing account transactions in NetSuite. For details on importing bank data, see Bank Data Import.

Intelligent Transaction Matching identifies a match for an imported transaction if an account transaction in NetSuite meets the criteria from the active system default or custom matching rules.

**Note:** To make rules that run on the transaction number, match the Transaction ID from the imported transaction with the NetSuite Check Number. The NetSuite Check Number in the Custom Matching Rule window corresponds to the:

- Check # on Bill Payments, Checks, and Customer Payments.
- Deposit # on Deposits.
- Transfer # on Transfers.
- Entry No. on Journal Entries.
- Reference # on Credit Card Charges and Credit Card Refunds.

For details, see Transaction Types in Matching Rules.

For details on how NetSuite groups transactions, see Grouping Multiple Transactions.

**Note:** Intelligent Transaction Matching runs matching rules against newly imported transactions. It does not run matching rules against account transactions. Any account transactions that are currently matched cannot be matched again, regardless of their reconciliation state.

To view automatically-matched transactions, go to Transactions > Bank > Match Bank Data and then click Matches to Submit.

On the Matches to Submit subtab, each line item is a group of matched transactions. By default, all line items are collapsed. To view the individual transactions in the group, expand the line item.

Intelligent Transaction Matching prioritizes the default rules in the following order:

- **Match on Transaction Number and Amount**
- Match on Amount and Transaction Number without Prefixes and Leading Zeros
- Match on Amount when Date is within 90 Previous Days

**Match on Transaction Number and Amount**

Using this rule, Intelligent Transaction Matching attempts to find transaction matches on imported transaction ID and (general ledger) account transaction check number. Intelligent Transaction Matching also attempts to find matches for groups of transactions with the same transaction number.

The date of the account transaction must also be the same as or before the date of the imported transaction.

Therefore, Intelligent Transaction Matching successfully matches the transactions if the transaction number and amount are exact matches, and the date of the account transaction is the same as or before the imported transaction date.

For a Many-to-One Transaction Matches or Many-to-Many Transaction Matches match, Intelligent Transaction Matching successfully matches the transactions if the sum of all imported transaction amounts is equal to the sum of the account transaction amounts.

If these criteria are not met, Intelligent Transaction Matching runs the next active default rule.

**Match on Amount and Transaction Number without Prefixes and Leading Zeros**

Using this rule, Intelligent Transaction Matching attempts to find transaction matches on the numeric value of the transaction number. Intelligent Transaction Matching also attempts to find matches for groups of transactions with the same numeric value.

The date of the account transaction in NetSuite must also be the same as or before the imported transaction date.

Intelligent Transaction Matching successfully matches the transactions if:

- The transaction number differs only by alphabetical prefix (for example, N123 and 123), amount is an exact match, and the account transaction date is the same as or before the imported transaction date.
- The transaction number differs only by leading spaces (for example, ‘123’ and ‘ 123’), amount is an exact match, and the account transaction date is the same as or before the imported transaction date.
- The transaction number differs only by leading zeros (for example, 000123 and 123), amount is an exact match, and the account transaction date is the same as or before the imported transaction date.

If these criteria are not met, Intelligent Transaction Matching runs the next active default rule.

**Match on Amount when Date is within 90 Previous Days**

Using this rule, Intelligent Transaction Matching attempts to find transaction matches if:

- The account transaction date is the same as or up to 90 days before the imported transaction date.
- The imported amount is equal to the amount of the account transaction in NetSuite.

Intelligent Transaction Matching successfully matches the transactions if:

- The amount and transaction date are both exact matches.
- The amount is an exact match, and the date of the account transaction in NetSuite is up to 90 days before the imported transaction date.
Because this rule does not have a condition for matching on the transaction number, NetSuite does not group transactions on this rule. For details, see Grouping Multiple Transactions.

If these criteria are not met, Intelligent Transaction Matching runs the first active custom rule, if applicable. For details, see Creating Custom Transaction Matching Rules.

Viewing Default and Custom Transaction Matching Rules

NetSuite includes default transaction matching rules to automatically match imported transactions with account transactions in NetSuite. The default matching rules run on all transactions. For descriptions of the default rules, see Intelligent Transaction Matching for Bank Data.

You can add your own custom matching rules, and assign the order in which NetSuite runs them to find matches. Each custom rule can include multiple conditions.

To view the default and custom rules:

1. Go to Transactions > Bank > Reconciliation Matching Rules.
   The Reconciliation Matching Rules page displays two sections: Default Rules and Custom Rules. The default rules are in a list that you cannot reorder, but you can inactivate them.
2. To create custom rules, see Creating Custom Transaction Matching Rules.
3. To assign the order in which NetSuite runs the custom rules, click and hold the icon to drag and drop the custom rules into the desired order.
4. To edit a custom rule, click the rule. For details on setting up conditions, see Creating Custom Transaction Matching Rules.
5. To delete a custom rule, click the Delete icon.

Creating Custom Transaction Matching Rules

NetSuite includes default transaction matching rules, which the system uses to automatically match imported transactions with account transactions in NetSuite. For details, see Intelligent Transaction Matching for Bank Data.

You can add your own custom matching rules, and assign the order in which NetSuite runs them to find matches. Each custom rule can include multiple conditions.

The next time bank data is imported into NetSuite, the Intelligent Transaction Matching feature runs and includes your new custom rules. You must specify one or more accounts on which the custom rule should run. NetSuite only runs the custom rule against transactions for selected accounts.

View the Custom Transaction Matching Rule video for 18.1.

For an example of a custom rule, see Custom Matching Rule Example.

For information about transaction types and matching types, see Transaction Types in Matching Rules and Bank Transaction Matching Types.

To create a new matching rule:

1. Go to Transactions > Bank > Reconciliation Matching Rules.
   The Custom Matching Rule window pops up. The Accounts subtab is open by default.
3. In the Custom Rule Name field, type a name for your new matching rule. This is a required field.
4. Filter the accounts in the list:
To switch from a list of all accounts to only the included accounts, click **Show Included Only**.

To filter by type, from the **Account Type** list, select an account type.

To search for an account, in the **Search** field, enter an account type, account name, description, or currency for which to search.

**Note:** The permissions on your user role determines the accounts that you can view and edit. If you do not have the permissions to see a particular account, it does not appear in the list. For details, see Permissions for Banking Features.

5. To include an account for your custom rule, check the box for the account.

**Tip:** To include all accounts, check the box in the column header.

You must include at least one account.

NetSuite only runs the custom rule against transactions for the selected accounts.

6. To specify the rule conditions, click the **Rule Conditions** subtab.

7. From the **Transaction Type** list, select the first transaction type for this rule condition.

The list contains imported transactions and account transactions in NetSuite. Your selection determines which options are available in the Primary Field and the other Transaction Type list. For example, if you choose an imported type, the other Transaction Type list displays only NetSuite types. The first selected Transaction Type for the first condition line restricts the available options for the subsequent condition rows. For information on choosing the appropriate transactions types, see Transaction Types in Matching Rules.

8. From the **Primary Field** list, select the first field on which the system runs this matching rule condition.

The options available in the list depend on the selected Transaction Type.

**Note:** If you select the Memo option, the system creates matches based on the Memo field value in the Journal Entry or Check for the account transaction in NetSuite. The rule does not run against the Memo field in the transaction line. The memos that appear in the Account Transactions list on the Match Bank Data page are the Memo field values from the Journal Entry or Check headers. Transactions cannot be grouped by the value in the memo.

9. From the **Operator** list, select an operator for the matching rule.

The selected Transaction Type and Primary Field determine which options are available in the list. Operators include:

- **Equals** – Specifies that the selected fields must be equal. For example, the NetSuite date must equal the imported date.

- **Equals (Ignore Prefix)** – Specifies that the selected fields must be equal, but ignores any alphabetic prefix or leading zeros on each transaction. For example, the Transaction ID 2134 still matches N2134.

- **Before** – Specifies that the selected transaction type date can be before the other selected transaction type date. For example, the NetSuite date can be before the imported date.

- **After** – Specifies that the selected transaction type date can be after the other selected transaction type date. For example, the NetSuite date can be after the imported date.

- **Within x Previous Days of** – Specifies the number of days by which a date match can vary. A matching date can be the same as or up to the specified number of days before the other date.

10. If you need to enter a value input (and the selected operator is Equals, Equals (Ignore Prefix), or Within x Previous Days of), in the **Value** field, enter the appropriate alphanumeric value.
11. From the second **Transaction Type** list, select the second transaction type for this rule condition, if it is not already selected by default.

The previously selected Transaction Type determines which options are available in the list. For example, if you chose an imported type first, this Transaction Type list displays only NetSuite types. For information on choosing the appropriate transactions types, see **Transaction Types in Matching Rules**.

12. From the **Compare Field** list, select the other field on which the system runs this matching rule condition, if it is not already selected by default.

The selection must be the same data type as the primary field.

**Note:** If you select the Memo option, the system creates matches based on the Memo field value in the Journal Entry or Check for the account transaction in NetSuite. The rule does not run against the Memo field in the transaction line. The memos that appear in the Accounts Transactions list on the Match Bank Data page are the Memo field values from the Journal Entry or Check headers. Transactions cannot be grouped by the value in the memo.

As you make selections, NetSuite updates the Description at the top of the window.

13. To add an extra condition, click the add icon.

**Note:** To remove a condition, click the delete icon.

14. To save and create your new custom rule, click **Save**.

The new rule appears under the Custom Rules heading.

15. To assign the order in which NetSuite runs the rules, drag and drop the rules into the desired order.

The next time bank data is imported into NetSuite, the Intelligent Transaction Matching feature runs and includes your new custom rules. To rerun the matching rules, you can delete the imported bank data and then re-import it. To manually import a bank statement file, see **Manual Bank Data Import**. If your administrator has set up automatic imports for your financial institution, you can initiate a manual import directly from the Match Bank Data page. For details, see **Updating Imported Bank Data**.

### Transaction Types in Matching Rules

When creating custom matching rules or matching transactions manually, keep the transaction types in the context of whether the transactions are from the imported bank data or general ledger account in NetSuite.

The imported bank data is from the perspective of the financial institution, but account transactions are from your perspective. This means that debits in the bank statement are recorded as credits in the general ledger account, and the reverse is also true.

For example, a customer payment that you deposit into the bank appears as a credit type on the bank statement, but appears as a debit type in the general ledger bank account.

Some transaction types are not available as matching rule sub-types. If you want a rule to run for transactions of the following types, choose **All Imported** and **All NetSuite** from the Transaction Type lists:

- Cash Sale
- Customer Refund (not supported for the Check Number field)
- Customer Credit (not supported for the Check Number field)
- Cash Refund (not supported for the Check Number field)
**Note:** To make rules that run on the transaction number, match the Transaction ID from the imported transaction with the NetSuite Check Number. The NetSuite Check Number in the Custom Matching Rule window corresponds to the:
- Check # on Bill Payments, Checks, and Customer Payments.
- Deposit # on Deposits.
- Transfer # on Transfers.
- Entry No. on Journal Entries.
- Reference # on Credit Card Charges and Credit Card Refunds.

The following table demonstrates how you can map transaction types.

<table>
<thead>
<tr>
<th>Imported Bank Data Types</th>
<th>G/L Account Transaction Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACH</td>
<td>Bill Payments</td>
</tr>
<tr>
<td></td>
<td>Checks</td>
</tr>
<tr>
<td></td>
<td>Customer Payments</td>
</tr>
<tr>
<td></td>
<td>Deposits</td>
</tr>
<tr>
<td></td>
<td>Journal Entries</td>
</tr>
<tr>
<td></td>
<td>Transfers</td>
</tr>
<tr>
<td>Checks</td>
<td>Bill Payments</td>
</tr>
<tr>
<td></td>
<td>Checks</td>
</tr>
<tr>
<td></td>
<td>Customer Payments</td>
</tr>
<tr>
<td></td>
<td>Deposits</td>
</tr>
<tr>
<td></td>
<td>Journal Entries</td>
</tr>
<tr>
<td></td>
<td>Transfers</td>
</tr>
<tr>
<td>Credits</td>
<td>Credit Card Refunds</td>
</tr>
<tr>
<td></td>
<td>Customer Payments</td>
</tr>
<tr>
<td></td>
<td>Deposits</td>
</tr>
<tr>
<td></td>
<td>Journal Entries</td>
</tr>
<tr>
<td></td>
<td>Transfers</td>
</tr>
<tr>
<td></td>
<td>Credit Card Refunds</td>
</tr>
<tr>
<td>Debits</td>
<td>Bill Payments</td>
</tr>
<tr>
<td></td>
<td>Checks</td>
</tr>
<tr>
<td></td>
<td>Journal Entries</td>
</tr>
<tr>
<td></td>
<td>Transfers</td>
</tr>
<tr>
<td></td>
<td>Credit Card Charges</td>
</tr>
<tr>
<td>Deposits</td>
<td>Checks</td>
</tr>
<tr>
<td>Imported Bank Data Types</td>
<td>G/L Account Transaction Types</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>Imports</td>
<td>G/L Account Transaction Types</td>
</tr>
<tr>
<td>Credit Card Refunds</td>
<td>Checks</td>
</tr>
<tr>
<td>Customer Payments</td>
<td>Credit Card Charges</td>
</tr>
<tr>
<td>Deposits</td>
<td>Deposits</td>
</tr>
<tr>
<td>Journal Entries</td>
<td>Journal Entries</td>
</tr>
<tr>
<td>Transfers</td>
<td></td>
</tr>
<tr>
<td>Fees</td>
<td>Checks</td>
</tr>
<tr>
<td>Credit Card Charges</td>
<td>Deposits</td>
</tr>
<tr>
<td>Deposits</td>
<td>Journal Entries</td>
</tr>
<tr>
<td>Interest</td>
<td>Checks</td>
</tr>
<tr>
<td>Credit Card Charges</td>
<td>Deposits</td>
</tr>
<tr>
<td>Deposits</td>
<td>Journal Entries</td>
</tr>
<tr>
<td>Others</td>
<td>Bill Payments</td>
</tr>
<tr>
<td>Customer Payments</td>
<td>Checks</td>
</tr>
<tr>
<td>Journal Entries</td>
<td>Checks</td>
</tr>
<tr>
<td>Transfers</td>
<td>Deposits</td>
</tr>
<tr>
<td></td>
<td>Credit Card Charges</td>
</tr>
<tr>
<td></td>
<td>Credit Card Refunds</td>
</tr>
<tr>
<td>Payments</td>
<td>Bill Payments</td>
</tr>
<tr>
<td>Checks</td>
<td>Credit Card Refunds</td>
</tr>
<tr>
<td>Credit Card Charges</td>
<td>Deposits</td>
</tr>
<tr>
<td>Deposits</td>
<td>Journal Entries</td>
</tr>
<tr>
<td>Journal Entries</td>
<td>Transfers</td>
</tr>
<tr>
<td>Transfers</td>
<td>Bill Payments</td>
</tr>
<tr>
<td>Checks</td>
<td>Checks</td>
</tr>
<tr>
<td>Credit Card Refunds</td>
<td>Deposits</td>
</tr>
<tr>
<td>Journal Entries</td>
<td>Transfers</td>
</tr>
</tbody>
</table>
Custom Matching Rule Example

After observing the system rules running automatically and manually matching the remaining transactions, you may notice some patterns and wish to create some custom matching rules. This section provides an example of a custom matching rule.

**Match on Memo when Date is within Two Days**

In this scenario, you want a rule that matches a transaction ID with an ID in the memo field of the Journal Entry header and the transaction date within two previous days. You want this rule to run on all accounts.

1. In the Custom Rule Name field, type Match on Memo and Date within Two Previous Days.
2. To include all accounts, check the box in the column header.
3. To specify the rule conditions, click Rule Conditions.
4. From the Transaction Type list, select All Imported.
   The system will select All NetSuite in the second Transaction Type list by default.
5. From the Primary Field list, select Transaction ID.
6. From the Operator list, select Equals (Ignore Prefix).
7. From the Compare Field list, select Memo.
8. To add the next condition, click the add icon.
9. From the Transaction Type list, select All Imported.
   The system will select All NetSuite in the second Transaction Type list by default.
10. From the Primary Field list, select Date.
11. From the Operator list, select Within x Previous Days of.
12. In the Value field, enter 2.
   NetSuite automatically selects the correct Transaction Type and Compare Field.
13. Click Save.

Inactivating Transaction Matching Rules

Instead of deleting transaction matching rules, you can temporarily make them inactive.

You cannot delete default rules, but you can inactivate them.
To inactivate custom matching rules:

1. Go to Transactions > Bank > Reconciliation Matching Rules.
2. Under the Active column, in the row for the rule you want to inactivate, clear the box.
   NetSuite stops running the rule for subsequent imports, but the rule is still in the list.
3. To activate the rule again, check the box.

Bank Transaction Matching Types

The Intelligent Transaction Matching feature automatically creates matches through the system or custom matching rules. For any remaining unmatched transactions, you can manually create matches.

NetSuite supports the following types of matches:

- One-to-One Transaction Matches
- Many-to-One Transaction Matches
- One-to-Many Transaction Matches
- Many-to-Many Transaction Matches

One-to-One Transaction Matches

The Intelligent Transaction Matching feature automatically creates matches through the system or custom matching rules. For any remaining unmatched transactions, you can manually create matches.

There are two types of one-to-one matching.

Unique Reference

For most matches, the transaction ID in the set of imported transactions clearly matches the check number in the set of account transactions.

Unique Reference by Combination

For other transactions, there might not be one unique number for a transaction. In this scenario, combine different properties to uniquely identify an imported transaction to its matching general ledger account register transaction.

Such unique references can be made up of different combinations. For example, combining the date with a memo value.

Many-to-One Transaction Matches

The Intelligent Transaction Matching feature automatically creates matches through the system or custom matching rules. For any remaining unmatched transactions, you can manually create matches.

There can be situations where a unique reference is not found between the two sets of transactions. The reference may be found in multiple transactions in the imported statement. For example, the financial clerk might combine several bank transfers on the bank statement into a single journal in NetSuite.

The system default rule Match on Transaction Number and Amount can group multiple imported transactions by transaction number and then match them with a single account transaction in NetSuite with the same transaction number.

For details on how NetSuite groups transactions, see Grouping Multiple Transactions.
One-to-Many Transaction Matches

The Intelligent Transaction Matching feature automatically creates matches through the system or custom matching rules. For any remaining unmatched transactions, you can manually create matches.

In some situations, you can only match one transaction in the imported statement with multiple transactions in the NetSuite general ledger account.

There may be no easily-matched reference, but it is still possible to make a match.

For example, you can group two accounts transactions in NetSuite that have several matching fields. Compare the group against the sum of a transaction in the imported statement. Ensure that no other match is possible, even if the transaction date is two business days earlier or later, because there is no other unique reference between the two sides.

For details on how NetSuite groups transactions, see Grouping Multiple Transactions.

Many-to-Many Transaction Matches

The Intelligent Transaction Matching feature automatically creates matches through the system or custom matching rules. For any remaining unmatched transactions, you can manually create matches.

The most complex type of data matching involves matching multiple transactions in the imported statement with multiple transactions in the NetSuite general ledger account.

In these situations, different key elements (including transaction numbers) in both sets can provide a unique reference for your match.

For example, the system default rule Match on Transaction Number and Amount can group multiple imported transactions by transaction number and then match them with a group of account transactions in NetSuite with the same transaction number.

For matching and grouping criteria, you might also use codes for cost centers, projects, and other items in the memo.

For details on how NetSuite groups transactions, see Grouping Multiple Transactions.

Grouping Multiple Transactions

The Intelligent Transaction Matching feature automatically creates match groups through the system or custom matching rules. For any remaining unmatched transactions, you can manually create match groups.

NetSuite attempts to first group imported transactions, then account transactions in NetSuite, and then matches the two groups.

NetSuite only groups multiple transactions on matches of transaction number (imported transaction ID and general ledger check number). Intelligent Transaction Matching does not group multiple transactions if:

- The transaction number is missing.
- The relevant value is in the memo field.

Reconciling Bank & Credit Card Statements

To reconcile your account statement, from beginning to end:

- Import your bank statement files. See Bank Data Import.
- Match Imported Bank Data with Account Transactions. See Matching Bank Data.
- Submit the transaction matches. See Submitting Transaction Matches.
Reconciling Bank & Credit Card Statements

Reconcile the transactions. See Reconciling Transactions.

Note: If you want to use the Match Bank Data and Reconcile Account Statement page for an account, check the Use Match Bank Data and Reconcile Account Statement Pages box in the Edit Account page.

Matching Bank Data

On the Match Bank Data page, when you select an account, the following is displayed:

- The name of the associated subsidiary
- The bank balance and bank balance date
- The imported bank data and account transactions currently in NetSuite for the selected account. These are unreconciled transactions.

Note: If your administrator has set up automatic bank data imports for your financial institution, NetSuite imports new bank data daily from your accounts. The Match Bank Data page displays the latest imported bank data, as well as daily bank balances of the account and the bank balance date. If your account data is outdated, you can initiate a manual update directly from the Match Bank Data page. For details, see Updating Imported Bank Data.

When bank data is imported into NetSuite (see Bank Data Import), the Intelligent Transaction Matching feature attempts to match the imported transactions with the existing account transactions in NetSuite. For details on the Intelligent Transaction Matching feature, see Intelligent Transaction Matching for Bank Data.

For any remaining unmatched transactions, filter the lists and manually select one or more transactions from each list to match.

As you match, NetSuite saves the work for the account as you go, so you can choose to complete it at a later time. When you come back to the page and select the account, the page shows the work in progress.

If you void a check, check the boxes for both the check and voiding journal entry in the Account Transactions list. There is a difference of zero, because the check and journal entry cancel each other out. In order to reconcile the items, include another match set in the group, and then click Match. For details on voiding checks, see Voiding a Check.

Important: NetSuite will undo the match and remove any cleared status if you edit the amount of a matched transaction, delete a transaction, or void an account transaction. If you void or reverse an account transaction, create a new match for the imported statement transaction with another account transaction.

To match and reconcile custom transactions, go to Accounting Preferences and then check the Show All Transaction Types In Reconciliation box. See the help topic General Accounting Preferences.

To match imported bank data with account transactions in NetSuite:

1. If you have not already done so, import your bank data (see Bank Data Import).
   When the import is initiated, NetSuite displays a progress message to notify you that a bank data import process has begun. To view the processing status of your import, click Track your status.
   NetSuite displays the Imported Statement List page. When the import process completes, click Match Bank Data in the Next Steps column. NetSuite redirects you to the Match Bank Data page with the account selected.
2. If you have already imported bank data, go to Transactions > Bank > Match Bank Data.
3. From the **Account** list, select the bank or credit card account for which you want to perform matching.

**Note:** If you want an account to be available in this list, check the **Use Match Bank Data and Reconcile Account Statement Pages** box in the Edit Account page.

The name of the subsidiary to which the account belongs is populated in the **Subsidiary** field next to the **Account** list.

NetSuite displays the current bank balance and bank balance date at the top of the page. In the Imported Bank Data and Account Transactions grids, NetSuite displays the imported bank data and account transactions currently in NetSuite for the selected account.

If you have just imported a CAMT.053.001.06–formatted XML or BAI2-formatted TXT file containing multiple accounts, the accounts appear in the Account list with dots beside them. The dots indicate that the accounts require reconciliation. The indicators only appear immediately following import.

NetSuite displays the Imported Bank Data and Account Transactions for the selected account.

In the Account Transactions list, identify in-transit payments by looking for the 🟢 icon in the row. One or more in-transit payments must be matched with only one imported transaction. To enable the In-Transit Payments feature, see the help topic **Enabling the In-Transit Payments Feature**.

4. To filter the Imported Bank Data or the Account Transactions list:
   - To set the date range for transactions in the lists, enter or select the dates in the **From** and **To** fields at the top of the panes.
   - In the **Search** field, start typing the text or number value on which to search. As you type, NetSuite narrows the search results in the list.
     
     When entering a date, use a date format consistent with the displayed format in the page (as set in the User Preferences). For example, if you use a long date format (May 1, 2018), enter *May* to search for a date in May. When entering a year, use four digits (for example, 2018). If you use a short date format, always use two digits for the month or day (for example, 05/01/2018).
   - From the **Type** list, select a transaction type.
   - To sort by column, click the column header.
   
   You can reorder columns by clicking and dragging a column to a new location in the list.

   If the number of transactions in the lists exceed the page limit, click the arrows to see the next or previous page of results.

5. If you require more information on the account transactions during the matching process, click the links in the Account Transactions list:
   - To view the record of an account transaction in NetSuite, click **Date** or **Tran No.** in the row.
     
     NetSuite opens the transaction record in a new window.
   - To view the record of the payer or payee on an account transaction in NetSuite, click **Name** in the row.
   - To view the full information that is too long to fit in a column, hover over the field or expand the column width. To resize the column width, click and drag the column’s right border. You can also resize the column width of the Imported Bank Data grid.

   **Note:** The memos that appear in the Account Transactions list are the Memo field values from the Journal Entry or Check headers, not the transaction line-level memos. Transactions cannot be grouped by the value in the memo.

6. On the **To Be Matched** subtab, match transaction items:
a. Check the box for one item (or multiple items) from the Imported Bank Data list and then select one item (or multiple items) from the Account Transactions list. You can make one-to-one, one-to-many, many-to-one, and many-to-many matches. For example, you may have a single imported transaction that matches two account transactions, which might include an adjustment item. For more information, see Bank Transaction Matching Types.

As you select transactions, NetSuite displays the transactions in the bottom drawer and updates the amount difference in the Match Difference field.

Tip: If a corresponding Account Transaction is missing, you can quickly add and match it from this page. Select the Imported Bank Data item, and then click New Charge or New Deposit (or New Credit for credit card accounts). Some of the fields will be populated for you. After you click Add, NetSuite displays the selected and newly created transactions in the bottom match drawer.

b. When the difference between the selected Imported Bank Data items and Account Transactions is zero (in the Match Difference field), click Match. NetSuite removes the matched transactions from the To Me Matched lists.

Note: If you have items for a voided check, check the boxes for both the check and voiding journal entry in the Account Transactions list. There is a difference of zero, because the check and journal entry cancel each other out. In order to reconcile the items, include another match set in the group, and then click Match. For details on voiding checks, see Voiding a Check.

7. On the To Be Matched subtab, exclude Imported Bank Data items from the matching process:

Tip: Exclude imported bank data to reduce clutter and hide transactions you do not want to match or that you no longer need because they are old or duplicates.

a. Select items in the Imported Bank Data grid.
This activates the Exclude button.

b. Click Exclude.
The items you selected move to the Excluded subtab and are excluded from the matching process.

Note: You can only exclude imported transactions. If you select an account transaction, the Exclude button is inactivated and the Match button is activated. When account transactions are only selected, the Match button is activated when the match difference is zero.

To restore the excluded transactions so they are included in the matching process, on the Excluded subtab, select the transactions and click the Restore button. The items you selected move back to the To Be Matched subtab.

8. To complete matching at a later time, you can navigate to another page. NetSuite automatically saves the work for the account as you go. When you come back to the page and select the account, the page shows the work in progress.

9. To create a journal entry during the matching process:

a. Click New Journal Entry.
NetSuite opens your preferred Journal Entry in a new window, and sets a default Date:
If there are one or more imported transactions in the bottom matching drawer, the default is the date of the earliest imported transaction in the drawer.

If there are no imported transactions in the drawer, the default is the current date.

**Note:** The memos that appear in the Account Transactions list on the Match Bank Data page are the Memo field values from the Journal Entry headers, not the transaction line-level memos.

b. Enter the details. If one or more imported transactions were selected, some fields are populated for you.

c. When you finish making changes, click **Save**.

   NetSuite saves the journal entry.

d. To refresh the Account Transactions list, click the refresh icon above the pane on the right-hand side.

   The new Journal Entry appears in the list.

For details on creating journal entries, see the help topic **Journal Entries**.

10. For bank accounts, you can create a new deposit during the matching process:

**Note:** Tax codes are not available on the popup window. If tax codes are mandatory for your deposits, go to the Deposits page.

1. Click **New Deposit**.

   NetSuite displays the New Deposit popup window.

2. Enter the details. If an Imported Bank Data item was selected, some fields are populated for you.

3. Click **Add**.

4. To refresh the Account Transactions list, click the refresh icon above the pane on the right-hand side.

   The new transaction appears in the list.

For details on adding deposits, see **Making Deposits**.

11. For credit card accounts, you can create a new credit card refund during the matching process:

**Note:** Tax codes are not available on the popup window. If tax codes are mandatory for your credits, go to the Credit Card Transaction page.

1. Click **New Credit**.

   NetSuite displays the Add New Credit popup window.

2. Enter the details. If an imported statement transaction was selected, some fields are populated for you.

3. Click **Add**.

4. To refresh the Account Transactions list, click the refresh icon above the pane on the right-hand side.

   The new transaction appears in the list.

For details on adding credits (or charges), see **Entering Company Credit Card Charges**.

12. For bank or credit card accounts, you can create a new charge during the matching process:
1. Click **New Charge**.
   NetSuite displays the New Charge popup window.
   If the selected account is a credit card account, a charge would be a debit.

2. Enter the details for the charge. If an imported statement transaction was selected, some fields are populated for you.

3. Click **Add**.

4. To refresh the Account Transactions list, click the refresh icon above the pane on the right-hand side.
   The new charge appears in the list.
   For details on adding charges, see Writing Checks or Entering Company Credit Card Charges.

13. When you finish matching transactions, submit the matches for reconciliation. See Submitting Transaction Matches.

**Note:** Tax codes are not available on the New Charge popup window. If tax codes are mandatory for your charges, go to the Check or Credit Card Transaction page.

**Note:** To view the matched transactions, click the Matches to Submit subtab.

### Reviewing Matches to Submit

When you open the Match Bank Data page, the page displays the To Be Matched subtab. You can view matched or unmatched transactions by switching between the Matches to Submit and To Be Matched subtabs.

The Matches to Submit subtab shows all the automatically-matched and manually-matched transactions, which have not been submitted for reconciliation yet. When a match is submitted, the account transaction is cleared in the system.

To reconcile all the matched transactions, you must submit matches, and then reconcile the statement on the Reconcile Account Statement page.

On the Reconcile Account Statement page, you can view the submitted matches on the Matched subtab.

**Important:** NetSuite will undo the match and remove any cleared status if you edit the amount of a matched transaction, delete a transaction, or void an account transaction. If you void or reverse an account transaction in NetSuite, create a new match for the imported bank data item with another account transaction.

To manually match the transactions again, see Matching Bank Data.

**To view matched transactions ready to submit for reconciliation:**

1. Go to Transactions > Bank > Match Bank Data.
2. From the **Account** list, select the bank or credit card account.

**Note:** If you want to have an account available in this list, check the Use Match Bank Data and Reconcile Account Statement Pages box in the Edit Account page.

The name of the subsidiary to which the account belongs is populated in the **Subsidiary** field next to the **Account** list.
NetSuite displays the current bank balance and bank balance date for the selected account at the top of the page. In the Imported Bank Data and Account Transactions grids, NetSuite displays the imported bank data and account transactions currently in NetSuite for the selected account.

3. Click the Matches to Submit subtab.
   NetSuite displays the list of matched account transactions. These transactions have not been submitted yet.

4. To filter the transactions list by date, enter or select the dates in the From and To fields above the pane.

5. To search for transactions, in the Search field, start typing the text or number value on which to search. As you type, NetSuite narrows the search results in the list.
   When entering a date, use a date format consistent with the displayed format in the page (as set in the User Preferences). For example, if you use a long date format (May 1, 2018), enter May to search for a date in May. When entering a year, use four digits (for example, 2018). If you use a short date format, always use two digits for the month or day (for example, 05/01/2018).

6. To view all the transactions in a match, click the View link in the Match Details column.
   The Match Details popup window displays the individual transactions that are part of the match group. Details include date, type, transaction number, name, and amount.
   If you want to undo the match, you can click Undo Match. NetSuite moves the transactions back to the To Be Matched subtab.

7. To close the popup window, click Cancel, or close the window.

8. To go back to unmatched transactions, click the To Be Matched subtab.

To reconcile all the matched transactions, you must submit the matches and then reconcile the statement. For details, see Submitting Transaction Matches and Reconciling Transactions.

To view unmatched transactions:

1. Go to Transactions > Bank > Match Bank Data.
2. From the Account list, select the bank or credit card account.

   **Note:** If you want to have an account available in this list, check the Use Match Bank Data and Reconcile Account Statement Pages box in the Edit Account page.

The name of the subsidiary to which the account belongs is populated in the Subsidiary field next to the Account list.

NetSuite displays the current bank balance and bank balance date for the selected account at the top of the page. In the Imported Bank Data and Account Transactions grids, NetSuite displays the imported bank data and account transactions currently in NetSuite for the selected account.

3. Click the To Be Matched subtab.
   NetSuite displays the list of unmatched transactions for the selected account.

4. To filter the Imported Bank Data and Account Transactions lists by date, enter or select the dates in the From and To fields above the panes.

5. To search for transactions, in the Search field, start typing the text or number value on which to search. As you type, NetSuite narrows the search results in the list.
   When entering a date, use a date format consistent with the displayed format in the page (as set in the User Preferences). For example, if you use a long date format (May 1, 2018), enter May to search for a date in May. When entering a year, use four digits (for example, 2018). If you use a short date format, always use two digits for the month or day (for example, 05/01/2018).
NetSuite displays the search results.

6. To go to matched transactions, click the **Matches to Submit** subtab.

### Undoing Matched Transactions

After matching transactions, you can still undo matches if the transactions have not yet been submitted for reconciliation or reconciled.

After transaction matches are submitted, you can still undo the matches from the **Matched** subtab on the Reconcile Account Statement page.

**Important:** NetSuite will undo the match if you edit the amount of a matched transaction, delete a transaction, or void an account transaction. If you void or reverse an account transaction, create a new match for the imported bank data item with another account transaction.

To manually match the transactions again, see Matching Bank Data.

**To undo matches:**

1. Go to Transactions > Bank > Match Bank Data.
2. From the **Account** list, select the bank or credit card account.
3. Click the **Matches To Submit** subtab.
   
   NetSuite displays the list of matches that have not been submitted for reconciliation.
4. For the match you want to undo, click **View** in the Match Details column.
   
   The Match Details popup window displays the individual transactions that are part of the match group.
5. Click **Undo Match**.
   
   NetSuite moves the transactions back to the unmatched list on the **To Be Matched** subtab.

### Submitting Transaction Matches

When you finish matching transactions, submit the matches and continue to the reconciliation process.

If you use the In-Transit Payments feature, NetSuite also converts the in-transit payments to confirmed payments. For details, see the help topic Enabling the In-Transit Payments Feature.

**Important:** NetSuite will undo the match and remove any cleared status if you edit the amount of a matched transaction, delete a transaction, or void an account transaction. If you void or reverse an account transaction, create a new match for the imported bank data item with another account transaction.

**To submit transaction matches:**

1. Go to Transactions > Bank > Match Bank Data.
2. If not already selected, from the **Account** list, select the bank or credit card account for which you want to submit matches.
3. To ensure that the list contains all the transactions you want to submit for reconciliation, click the **Matches To Submit** subtab. For details, see Reviewing Matches to Submit.
4. After reviewing the transaction matches, click **Submit**.
NetSuite begins processing the transactions, which includes clearing the transactions. If you use the In-Transit Payments feature, NetSuite also converts the in-transit payments to confirmed payments. This may take some time.

To view the processing status of your batch of transactions, go to Transactions > Bank > Match Bank Data > Status.

5. When processing completes, go to Transactions > Bank > Reconcile Account Statement.

Checking the Process Status for Submitted Transactions

After you submit a batch of matched transactions, you can view the processing status of your batch on the Process Status page. Transactions are processed asynchronously, so you can continue to work in NetSuite and check back on the processing status at intervals.

Go to Transactions > Bank > Match Bank Data > Status.

The Process Status page shows the following information:

- **Submission ID** – A unique identifier of the batch processing job.
- **Process Type** – When submitting matches to clear account transactions, the process type is Confirm Transactions.
- **Submission Status:**
  - Not Started – The batch job has been submitted but has not yet started.
  - In Progress – Transactions in the batch are currently being processed. The Percent Complete column indicates progress.
  - Complete – All transactions in the batch have been processed. If errors occurred, the Message column displays the number of errors.
- **Percent Complete** – The percentage of records processed.
- **Message** – Indicates the number of errors that occurred during the processing.
- **Date Created** – The date and time the bulk processing was started.
- **Created By** – The user that submitted the bulk process job.

These columns are also filters so that you can narrow the list to display the batches you want to view.

You can also filter the list by creation date.

After the batch is complete, you can view the results on the Processed Records page. Information on the Processed Records page includes the submission ID, line number, transaction, line status, result, and an error message if an error occurred. The submitted (confirmed) transactions are now available on the Reconcile Account Statement page.

To check the processing status of transactions:

1. Go to Transactions > Bank > Match Bank Data > Status.
2. To choose the time period for which you want to view bulk fulfillment jobs, click Filters. NetSuite uses the current date by default.
3. To view the details of a batch, click the status link in the Submission Status column. NetSuite displays the Processed Records page.
4. If errors occurred during the processing, the Message column displays the number of errors. Click the link to open the Bulk Processing Errors page and view the errors.
   For more information on errors, see Resolving Bulk Processing Errors.
5. To view the latest status of the bulk processing jobs, click Refresh.
Resolving Bulk Processing Errors

You may receive one of the following errors:

<table>
<thead>
<tr>
<th>Error Message</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>The match group is no longer valid. One or more NetSuite transactions in the group have been deleted or modified. NetSuite has unmatched the other transactions.</td>
<td>These errors may occur because one transaction in a match got deleted or modified, causing NetSuite to undo the match group.</td>
<td>Create new transaction match groups for the transactions, and confirm the matches again.</td>
</tr>
<tr>
<td>A system error has occurred. Not all transactions were confirmed or cleared. Confirm the match again.</td>
<td>A vendor payment in the match group was already confirmed on the vendor payment record, while the bulk processing picked it up.</td>
<td>The transaction remains in the match group. You can view the transactions on the Review Matches subtab, but you only need to confirm the matches again.</td>
</tr>
</tbody>
</table>

To correct the errors:

1. Go to Transactions > Bank > Match Bank Data.
2. If not already selected, from the Account list, select the bank or credit card account.
3. To filter the transactions by date, enter or select the dates in the From and To fields above the panes.
4. On the To Be Matched subtab, rematch the transactions that were not submitted on the Process Status page.
5. If required, you can view the transaction matches on the Matches To Submit subtab. Some transactions may fail processing but remain in match groups.
6. After reviewing the transaction matches, click Submit.
7. To view the processing status of the new batch, go back to Transactions > Bank > Match Bank Data > Status.

Viewing Matched and Submitted Transactions

In the Reconcile Account Statement page, you can view or undo the submitted transaction matches on the Matched subtab.

If you undo submitted matches, NetSuite removes the cleared flag and moves the transactions back to the To Be Matched list on the Match Bank Data page.

**Important:** NetSuite will undo the match and remove any cleared status if you edit the amount of a matched transaction, delete a transaction, or void an account transaction. If you void or reverse an account transaction, create a new match for the imported bank statement item with another account transaction.

To manually match the transactions again, see Matching Bank Data.

To view transaction matches that have not been submitted yet, see Reviewing Matches to Submit.

**To view matched and submitted transactions:**

1. Go to Transactions > Bank > Reconcile Account Statement.
2. From the Account list, select the bank or credit card account.
3. Click the **Matched** subtab.

NetSuite displays the list of matched account transactions in NetSuite that you submitted. These transactions are cleared and ready for reconciliation.

4. To filter the transactions list by date, enter or select the dates in the **From** and **To** fields above the pane.

5. To search for transactions, in the **Search** field, start typing the text or number value on which to search. As you type, NetSuite narrows the search results in the list.

When entering a date, use a date format consistent with the displayed format in the page (as set in the User Preferences). For example, if you use a long date format (May 1, 2018), enter **May** to search for a date in May. When entering a year, use four digits (for example, 2018). If you use a short date format, always use two digits for the month or day (for example, 05/01/2018).

6. To view all the transactions in a match, click **View** in the Match Details column.

The Match Details popup window displays the individual transactions that are part of the match group. Details include date, type, transaction number, name, and amount.

If you want to undo the match, you can click **Undo Match**. NetSuite moves the transactions back to the **To Be Matched** subtab on the Match Bank Data page.

7. To close the popup window, click **Cancel**, or close the window.

### Undoing Matched and Submitted Transactions

After matching and submitting transactions, you can still undo matches.

If you undo submitted matches, NetSuite removes the cleared flag and moves the transactions back to the **To Be Matched** subtab on the Match Bank Data page.

**Important:** NetSuite will undo the match if you edit the amount of a matched transaction, delete a transaction, or void an account transaction. If you void or reverse an account transaction, create a new match for the imported bank data item with another account transaction.

To manually match the transactions again, see Matching Bank Data.

**To undo submitted matches:**

1. Go to Transactions > Bank > Reconcile Account Statement.
2. From the **Account** list, select the bank or credit card account.
3. Click the **Matched** subtab.

   NetSuite displays the list of matched and submitted account transactions in NetSuite. These transactions are cleared and ready for reconciliation.

4. For the match you want to undo, click **View** in the Match Details column.

   The Match Details popup window displays the individual transactions that are part of the match group.

5. Click **Undo Match**.

   NetSuite moves the transactions back to the **To Be Matched** subtab on the Match Bank Data page.

In addition to undoing submitted transaction matches, you can also undo a reconciled statement. For details, see Deleting Reconciled Statements.
Reconciling Transactions

After submitting transaction matches, you can reconcile your account statement. For details, see Matching Bank Data and Submitting Transaction Matches.

If you include or exclude transactions on the Reconcile subtab, NetSuite saves your work for the account as you go. You can choose to leave the page and complete the work at a later time. When you come back to the page and select the account, the page shows the work in progress.

If a previously-reconciled transaction is edited, the transaction becomes unreconciled again.

To reconcile a statement:

1. Go to Transactions > Bank > Reconcile Account Statement.
2. If not already selected, from the Account list, select the bank or credit card account.
   NetSuite displays the currency for the selected account.
3. If not already selected, in the Statement End Date field, enter or select the end date.
   Note: If you receive more transactions for a reconciled date range, and you want to include them, delete the reconciled statement and create a new reconciliation. To delete the reconciled statement, see Deleting Reconciled Statements. We recommend choosing a Statement End Date in the past (for example, the day before the current date).
4. In the Ending Statement Balance field, enter or edit the closing balance on the statement, if required.
   The field is populated with the ending balance from the imported statement, if available.
   The Last Reconciled Balance field provides the balance of this account from the last reconciled statement.
   NetSuite updates the Reconciled This Statement field as you include or exclude transactions in the Reconcile subtab.
5. If not already open, click the Reconcile subtab.
   NetSuite displays the list of matched and submitted account transactions in NetSuite. These transactions are cleared and ready for reconciliation.
   Note: To manually clear an individual transaction, switch back to the original reconciliation pages. To use the original pages, clear the Use Match Bank Data and Reconcile Account Statement Pages box on the Edit Account page.
6. To filter the list of transactions:
   - To set the date range for transactions in the list, enter or select the dates in the From and To fields at the top of the pane.
   - From the Type list, select a transaction type.
   - To switch from a list of all transactions to only the included transactions, click Show Included Only.
   - In the Search field, start typing the text or number value on which to search. As you type, NetSuite narrows the search results in the list.
   When entering a date, use a date format consistent with the displayed format in the page (as set in the User Preferences). For example, if you use a long date format (May 1, 2018), enter May to search for a date in May. When entering a year, use four digits (for example, 2018). If you use a short date format, always use two digits for the month or day (for example, 05/01/2018).
- To sort by column, click the column header.
  If the number of transactions in the list exceeds the page limit, click the arrows to see the next or previous page of results.

7. To include or exclude all of the transactions, check or clear the box in the column header.
  If filters are active, checking the box selects all the filtered transactions on all pages. If one of the filtered and selected transactions are part of a match group, all transactions in the group are included as well.
  For example, if you filtered the list by a date range and type, the filtered transactions and their match groups are selected on all the pages.

8. To include or exclude a transaction from the statement, check or clear the box next to the transaction.

   **Note:** If a transaction is part of a match group that contains multiple NetSuite transactions (a one-to-many or many-to-many match), you cannot exclude it. The check box is unavailable.

   Excluded transactions retain their matches and cleared status, but NetSuite excludes them from the reconciliation.

   NetSuite only reconciles the included transactions.

   **Tip:** To switch from a list of all transactions to only the included transactions, click **Show Included Only**.

9. Ensure that all the transactions you want to reconcile are selected, and then click **Reconcile**. You can reconcile a statement, even if there is an amount difference.

   NetSuite displays the Close Statement popup window.

   **Warning:** You cannot change the Statement End Date later. This date becomes the Close Date, which NetSuite uses to run the Reconciliation report and Reconciliation History report.

   If you reconcile a statement with the end date as the current date, and then receive more transactions later that day, you cannot choose these transactions for the next reconciliation statement. To avoid this situation, choose a Statement End Date in the past (for example, the day before the current date).

10. Click **OK**.

    NetSuite redirects you to the Reconciled Statements list page.

### Viewing the List of Reconciled Statements

You can view the list of reconciled statements. These statements only contain the reconciled transactions. For details on reconciling a statement, see Reconciling Bank & Credit Card Statements.

To view unmatched transactions or matched transactions not yet submitted for reconciliation, go to Transactions > Bank > Match Bank Data. For details, see Matching Bank Data.

To view unreconciled transactions, go to Transactions > Bank > Reconcile Account Statement.

**To view reconciled statements:**

1. Go to Transactions > Bank > Reconcile Account Statement > List
2. To filter the list on the Reconciled Statements page:
Reconciling Bank & Credit Card Statements

- From the Filter By Account dropdown list, select the appropriate account.
- To sort by column, click the column header.

Deleting Reconciled Statements

If you reconcile a statement but then receive more transactions that you want to include in that statement, you can delete the reconciled statement for that period and start over.

When you delete a statement, the transactions become unreconciled but remain matched and submitted. You can no longer generate reconciliation reports for that statement period.

You can only delete the last statement, regardless of whether the statements are re-opened or closed. To delete an earlier statement, you must delete the most recent statements first.

To delete a statement:

1. Go to Transactions > Bank > Reconcile Account Statement > List
2. To filter the list on the Reconciled Statements page:
   - From the Filter By Account dropdown list, select the appropriate account.
   - To sort by the date column, click the Date column header.

   Tip: Because you can only delete the latest statement, sort the date column by descending order, to see the latest statement row at the top of the page.

3. In the row of the statement you want to delete, click Delete.
   NetSuite displays the confirmation popup window.
4. Click OK.
   In the Reconciled Statements page, the statement is no longer in the list.
   The transactions from the deleted statement are now unreconciled but are still matched.
   To create a new reconciliation, see Reconciling Bank & Credit Card Statements.

Account Reconciliation Reports

As with the original reconciliation pages, you can view the Bank Register, Reconciled Summary, and Reconciled Details report for reconciled statements.

- To view the Reconciled Summary report for an account, go to Reports > Banking/Budgeting > Reconciliation. For details, see Reconciliation Summary Report.
- To view the Reconciled Details report for an account, go to Reports > Banking/Budgeting > Reconciliation > Detail. For details, see Reconciliation Detail Report.
- To view the Bank Register report for an account, go to Reports > Banking/Budgeting > Bank Register. For details, see Bank Register Report.

We recommend that you print your reconciliation report before you reconcile another account because you cannot recapture the same information.

To print the report, click the print icon at the bottom of the page. For details on exporting, see the help topic Exporting Reports, Searches, and Lists.
Bank Statement Parsers SuiteApp

The Bank Statement Parsers SuiteApp delivers standard parser plug-ins that can read bank and credit card statement files and import the data in NetSuite to aid with bank reconciliation. If the Financial Institution and Format Profiles are set up correctly, the SuiteApp can identify multiple bank accounts within a single file. For more information, see Creating Financial Institution Records and Creating Format Profiles.

The SuiteApp also comes with sample scripts that you can download and use as a reference when you create custom parsers. For more information, see Downloading Sample Bank Statement Parsers Scripts.

Note: The SuiteApp will not create NetSuite transactions from the imported bank statement files.

The Bank Statement Parsers SuiteApp includes parser plug-ins for the following file formats in UTF-8 (Unicode) and UTF-8 BOM encoding:

- **BAI2** — The BAI2 parser plug-in can recognize default and standard BAI2 bank transaction codes and supports account total and number of records import validation. The SuiteApp also lets you configure the decimal precision of the BAI2 parser plug-in.

  For more information about the BAI2 format, see https://www.bai.org.

- **OFX/QFX** — The OFX/QFX parser plug-in can parse bank and credit card statement files that uses OFX/QFX versions 102, 103, 211, and 220. The parser can recognize default and standard OFX/QFX bank transaction codes and supports the use of a period (.) and comma (,) as a decimal separator.

  For more information about the OFX/QFX format, see https://www.ofx.net.

- **MT940** — The MT940 parser plug-in can recognize standard SWIFT transaction bank codes and supports the use of a period (.) and comma (,) as a decimal separator. The plug-in can also decode remittance information from the bank and display it in a more readable format.

  For more information about the MT940 format, see https://www.swift.com

- **CAMT.053** — The CAMT.053 parser plug-in can parse bank statement files that use the CAMT.053.001.02 version and can recognize standard ISO bank transaction codes. The plug-in includes default mappings for XML elements to NetSuite fields. Users can also create new mappings or override the default mappings.

  Note: The CAMT.053 parser plug-in only supports UTF-8 (Unicode) encoding.

  For more information about the CAMT.053 format, see https://www.iso20022.org

Read the following topics to learn more about the Bank Statement Parsers SuiteApp:

- Installing the Bank Statement Parsers SuiteApp
- Setting Up Standard Bank Statement Parsers
- Supported Transaction Codes for Bank Statement Parsers SuiteApp
- File Import Error Messages for Bank Statement Parsers

Installing the Bank Statement Parsers SuiteApp

Prerequisites

Before you install the Bank Statement Parsers SuiteApp, go to Setup > Company > Setup Tasks > Enable Features, and then click the SuiteCloud tab. Make sure that the following features are enabled on your account:
Installing the Bank Statement Parsers SuiteApp

- Custom Records
- Client SuiteScript
- Server SuiteScript

Installation

To install the Bank Statement Parsers SuiteApp, go to Customization > SuiteBundler > Search & Install Bundles, and then click Advanced.

Use the following information to search for the SuiteApp:

- **Bundle Name:** Bank Statement Parsers
- **Bundle ID:** 293699

For information on installing SuiteApps, see Installing a Bundle.

Roles and Permissions for Bank Statement Parsers

By default, the following standard roles can use the Bank Statement Parsers when importing statement files:

- Administrator
- CEO
- CFO

To access the Statement File Import page using custom roles, you must set the **Import Online Banking File** permission to Full or Edit.

For a list of permissions required to access the necessary records and forms to use Bank Statement Parsers, see Permissions for Banking Features.

Setting Up Standard Bank Statement Parsers

To set up standard bank statement parsers for your account, perform the following tasks:

- **Step 1:** Creating Financial Institution Records
- **Step 2:** Creating Format Profiles

**Note:** Format profiles that are associated to a bank statement parser cannot be deleted. You can set the format profile to inactive if you no longer want to use it.

- **Step 3:** Bank Account Mapping

**Note:** For information on the mapping keys to use for bank statement parsers, see Identifying Account Mapping Keys for Standard Bank Statement Parsers

- **Step 4:** Mapping Custom Bank Codes

Banking
Setting Up Standard Bank Statement Parsers

Note: Standard transaction codes are already mapped to the parsers. For MT940, for example, standard SWIFT codes are included in the parser. You must perform this step only if your bank is using custom transaction codes or if you want to override the standard transaction code mapping.

Note: To override standard bank transaction codes for CAMT.053 files, enter a combination of the Domain, Family and Sub-Family codes separated by a comma and a space.

- **Step 5: Configuring Standard Bank Transaction Parsers**

Identifying Account Mapping Keys for Standard Bank Statement Parsers

The account mapping key is required when you are mapping bank accounts in the format profile record. If you are using parsers in the Bank Statement Parsers SuiteApp, you can use the following methods to identify the account mapping keys:

**BAI2 Account Mapping Key**

For BAI2–formatted files, use the **Customer Account Number** field in the Account Identifies record (Record 03, field 2).

**Sample:**

01,121140399,9999999999,171013,0533,1,80,1,2/
02,9999999999,1211403999,1,171012,0533,USD,2/
03,8505874910,,015,262595881,,100,147865183,,400,147180270,,/
16,575,119595,,6,0,/

**OFX/QFX Mapping Key**

For OFX or QFX-formatted files, use the following mapping keys:

- For bank accounts, the mapping key is the **Account Number** in the Bank Statement section.

  **Sample:**

  ```xml
  <BANKACCTFROM>
  <BANKID>0341
  <ACCTID>0872314012
  <ACCTTYPE>CHECKING
  </BANKACCTFROM>
  ```

- For credit card accounts, the mapping key is comprised of the last 4 digits of the Account Identification tag, followed by an underscore, and then the Currency Code. In the following example, the account mapping key would be: **6008_USD**.

  **Sample:**

  ```xml
  ```

Banking
MT940 Mapping Key

For MT940–formatted files, use the Account Identification in Tag 25.

Sample:

```xml
<CCSTMTRS>
<CURDEF>USD</CURDEF>
<CCACCTRNM>
<ACCTID>76008</ACCTID>
</CCACCTRNM>
</CCSTMTRS>
```

CAMT.053 Mapping Key

For CAMT.053 formatted files, the mapping key is the account number found in either the IBAN or the Other tag, under the Account Identifier.

Sample (IBAN):

```xml
<BkToCstmrStmt>
<GrpHdr>
<Stmt>
<Id>059018800</Id>
<ElecmtcSeqNb>0000000000000000093</ElecmtcSeqNb>
<CreDtTm>2019-05-04T00:50:57.47+02:00</CreDtTm>
<Acct>
<Id>
<IBAN>NL444123458977</IBAN>
</Id>
</stmt>
</GrpHdr>
</BkToCstmrStmt>
```

Sample (Other Identifier):

```xml
<BkToCstmrStmt>
<GrpHdr>
<Stmt>
<Id>AAAASESS-FP-STAT001</Id>
<CreDtTm>2010-10-18T17:00:00+01:00</CreDtTm>
<FrToDt>
<Acct>
<Id>
<Other>
<Id>00807599099123</Id>
</Other>
</Id>
</stmt>
</GrpHdr>
</BkToCstmrStmt>
```
Setting Up Standard Bank Statement Parsers

Configuring Standard Bank Transaction Parsers

Additional options will be available on the Parser Configuration subtab when you choose a standard BAI2 or MT940 transaction parser. The Parser Configuration subtab will be populated with the appropriate fields after you save the format profile.

**Note:** You can configure additional options for BAI2 and MT940 only if the Bank Statement Parsers SuiteApp is installed in your account.

Configuring the Decimal Precision for the BAI2 Parser

You can set the decimal precision for the different currencies if you use the standard BAI2 parser.

**To configure the decimal precision:**

1. Go to Setup > Accounting > Financial Institution > List.
2. Click View next to the financial institution record where you want to add or edit a format profile. For more information, see Creating Format Profiles.
3. On the Financial Institution page, click the format profile you want to edit.
4. On the Format Profile page, click Edit.
5. Under the Parser Configuration subtab, in the Precision field, enter a value from 0-9.
   - The decimal precision of the currency associated to your bank account has changed.
   - The bank has updated their system to generate bank statement files with a new decimal precision setting.
6. Click Save.

Configuring Bank Keywords for the MT940 Parser

The MT940 parser can read bank keywords and display them in a more readable format in the Memo field of the transaction record. If you select a standard MT940 transaction parser, you can define more keywords or edit existing ones. By default, the MT940 parser includes common keywords and descriptions used for SEPA transactions.

**To configure the bank keywords:**

1. Go to Setup > Accounting > Financial Institution > List.
2. Click View next to the financial institution record where you want to add or edit a format profile. For more information, see Creating Format Profiles.
3. On the Financial Institution page, click the format profile you want to edit.
4. On the Format Profile page, click Edit.
5. Under the Parser Configuration subtab, enter new keywords or edit the existing ones:
   - **Remittance Code** – Enter the keyword used in the bank statement file.
     - Each keyword must start and end with a forward slash “/”. If there is no beginning and ending forward slash, the keywords cannot be converted properly. If the keywords appear in succession, a double forward slash must be present between the keywords. For example, /BENM//:NAME/.
Setting Up Standard Bank Statement Parsers

- **Description** – Enter a description for the remittance code. This will be displayed in place of the remittance in the Memo field of the transaction record.
- **Transaction Field Mapping** – Select the field where you want to map the remittance code.

**Note:** If the bank file contains keywords that are mapped to the same field, the parser will map the field to the first keyword in the file.

Example:

<table>
<thead>
<tr>
<th>Bank File</th>
<th>Memo Field</th>
</tr>
</thead>
<tbody>
<tr>
<td>:86:/EREF/1234567890ABCD/BENM//NAME/XYZ Corporation</td>
<td></td>
</tr>
<tr>
<td>:86:/REMI/PURCHASE OF GOODS/ISDT/2012-12-30:86:/CSID/4500900868</td>
<td></td>
</tr>
</tbody>
</table>

6. Click **Save**.

Configuring the Transaction Field Mappings for the CAMT.053 Parser

To accommodate the different versions and information included in the bank files, you can create new field mappings or override the existing ones. This option enables you to import all the information in the statement file that is relevant to you.

**To add a new or update field mappings:**

1. Go to Setup > Accounting > Financial Statements > Financial Institution > List.
2. Click **View** next to the financial institution record where you want to add or edit a format profile. For more information, see Creating Format Profiles.
3. On the Financial Institution page, click the CAMT format profile that you want to edit.
4. On the Format Profile page, click **Edit**.
5. Under the Parser Configuration subtab, do any of the following:
   - **To add a new mapping:**
     1. Scroll to the bottom of the list, and select the NetSuite field.
     2. In the Field Mapping, enter the corresponding XML path element to source the information from the file. Each element must be separated by a space.
     3. Click **Add**.
   - **Note:** If the payment file contains elements that are mapped to the same NetSuite field, the parser will map the field to the first tag present in the file. This scenario does not apply to the memo field. If several tags are mapped to the memo field, the parser will map all the information in the memo field, separated by a space. If the information exceeds 4k, the text will be automatically truncated.
   - **To update an existing mapping:**
     1. Click the field mapping that you want to update.
     2. Enter the XML path of the new mapping in the File Mapping field.
     3. Click **OK**.
To delete a field mapping:
1. Click the field mapping that you want to delete.
2. Click Remove.

**Note:** There should be at least one mapping for each NetSuite transaction field. If all the mappings for a specific field are removed, you can either restore the default file mapping, or enter a new one.

6. Click **Save**.

### Enabling Validations on the CAMT.053 Sample Script

You can create a custom CAMT parser using the downloadable sample script, available from the File Cabinet. The CAMT script file, however, does not include any form of validation by default. If you want to enable this feature, you must provide your own XSD validation file for CAMT.053.001.02.

**To enable validation on the CAMT.053 script:**

1. Download the `bsp_lite_parser_camt053` script from the File Cabinet. For more information, see [Downloading Sample Bank Statement Parsers Scripts](#).
2. On your computer, open the CAMT.053 parser script file and search for `module.parseBankStatement`.
3. In the `module.parseBankStatement` code block, do the following:
   - Remove the `/ *` and `* /` characters to enable the validations on the script.
   - Replace `{placeholderText}` with the path to your uploaded XSD file validation. For more information, see the help topic `xml.validate(options)`.

   ```javascript
   module.parseBankStatement = function(context){
     module.fileContents = context.Input.file.getContents();
     var xmlDoc = xml.Parser.fromString({text: module.fileContents});

     /*
     try{
       xml.validate({
         xml : xmlDoc,
         xsdFilePathId : '{placeholderText}'
       });
     }catch(e){
       if(e.name === 'SSS_XML_DOES_NOT_CONFORM_TO_SCHEMA')
         throw 'The file upload failed because it does not conform with the valid CAMT053.001.02 XML Format. Contact your bank to correct the error, and re-upload the file again.';
       throw e.message || e;
     }
   } /*
   }
   ```

4. Save your file.
5. Deploy the modified script files as a plug-in implementation. For more information, see the help topic [Adding the Plug-in Implementation](#).
Setting Up Standard Bank Statement Parsers

A copy of the scripts that are used in the Bank Statement Parsers SuiteApp are available in the file cabinet. The scripts show how the data in the statement files are mapped into NetSuite fields. You can download these scripts and use them as a reference, if you want to create your own parser.

To download the Bank Statement Parsers scripts:

1. Go to Documents > Files > File Cabinet.
2. On the left navigation pane of the File Cabinet page, click SuiteApps > com.netsuite.bsp > lite.
3. Click the Download link for the parser scripts that you want to customize.

To create your custom parsers, see the help topic Parser Plug-in.

Supported Transaction Codes for Bank Statement Parsers SuiteApp

The Bank Statement Parsers SuiteApp provides native support for the following standard transaction codes for each file format.

BAI2 Transaction Codes

For BAI2 formatted files, the transaction code can be found in the second field of Record 16. See the following example:

```
03,54367988899,,015,262595881,,100,147865183,,400,147180270,,/
16,575,119595,,6,0,/
88,scrubbed MEMO/
16,575,5755187,,6,0,/
88,scrubbed MEMO/
```

The following table lists the supported transaction codes for the BAI2 parser:

<table>
<thead>
<tr>
<th>100</th>
<th>187</th>
<th>241</th>
<th>342</th>
<th>383</th>
<th>468</th>
<th>526</th>
<th>578</th>
<th>674</th>
</tr>
</thead>
<tbody>
<tr>
<td>108</td>
<td>189</td>
<td>242</td>
<td>344</td>
<td>384</td>
<td>469</td>
<td>527</td>
<td>581</td>
<td>676</td>
</tr>
<tr>
<td>115</td>
<td>191</td>
<td>243</td>
<td>345</td>
<td>386</td>
<td>472</td>
<td>529</td>
<td>595</td>
<td>677</td>
</tr>
<tr>
<td>116</td>
<td>195</td>
<td>244</td>
<td>346</td>
<td>387</td>
<td>474</td>
<td>531</td>
<td>597</td>
<td>678</td>
</tr>
<tr>
<td>118</td>
<td>196</td>
<td>246</td>
<td>347</td>
<td>388</td>
<td>475</td>
<td>533</td>
<td>616</td>
<td>679</td>
</tr>
<tr>
<td>121</td>
<td>198</td>
<td>247</td>
<td>348</td>
<td>391</td>
<td>476</td>
<td>535</td>
<td>622</td>
<td>681</td>
</tr>
<tr>
<td>122</td>
<td>201</td>
<td>248</td>
<td>349</td>
<td>392</td>
<td>477</td>
<td>540</td>
<td>627</td>
<td>682</td>
</tr>
<tr>
<td>123</td>
<td>202</td>
<td>249</td>
<td>351</td>
<td>393</td>
<td>479</td>
<td>541</td>
<td>629</td>
<td>683</td>
</tr>
<tr>
<td>135</td>
<td>206</td>
<td>252</td>
<td>353</td>
<td>394</td>
<td>481</td>
<td>542</td>
<td>631</td>
<td>684</td>
</tr>
<tr>
<td>136</td>
<td>208</td>
<td>254</td>
<td>354</td>
<td>395</td>
<td>484</td>
<td>543</td>
<td>633</td>
<td>686</td>
</tr>
<tr>
<td>142</td>
<td>212</td>
<td>255</td>
<td>357</td>
<td>397</td>
<td>485</td>
<td>544</td>
<td>634</td>
<td>687</td>
</tr>
</tbody>
</table>
Supported Transaction Codes for Bank Statement Parsers SuiteApp

<table>
<thead>
<tr>
<th>143</th>
<th>213</th>
<th>257</th>
<th>358</th>
<th>398</th>
<th>487</th>
<th>546</th>
<th>641</th>
<th>688</th>
</tr>
</thead>
<tbody>
<tr>
<td>145</td>
<td>214</td>
<td>258</td>
<td>359</td>
<td>399</td>
<td>489</td>
<td>547</td>
<td>644</td>
<td>691</td>
</tr>
<tr>
<td>147</td>
<td>216</td>
<td>261</td>
<td>362</td>
<td>400</td>
<td>491</td>
<td>548</td>
<td>651</td>
<td>692</td>
</tr>
<tr>
<td>155</td>
<td>218</td>
<td>263</td>
<td>363</td>
<td>408</td>
<td>493</td>
<td>549</td>
<td>654</td>
<td>693</td>
</tr>
<tr>
<td>156</td>
<td>221</td>
<td>266</td>
<td>364</td>
<td>409</td>
<td>495</td>
<td>552</td>
<td>656</td>
<td>694</td>
</tr>
<tr>
<td>164</td>
<td>222</td>
<td>268</td>
<td>366</td>
<td>415</td>
<td>496</td>
<td>554</td>
<td>657</td>
<td>695</td>
</tr>
<tr>
<td>165</td>
<td>224</td>
<td>274</td>
<td>367</td>
<td>421</td>
<td>498</td>
<td>555</td>
<td>658</td>
<td>696</td>
</tr>
<tr>
<td>166</td>
<td>226</td>
<td>275</td>
<td>368</td>
<td>422</td>
<td>501</td>
<td>557</td>
<td>659</td>
<td>697</td>
</tr>
<tr>
<td>168</td>
<td>227</td>
<td>276</td>
<td>369</td>
<td>423</td>
<td>502</td>
<td>558</td>
<td>661</td>
<td>698</td>
</tr>
<tr>
<td>169</td>
<td>229</td>
<td>277</td>
<td>372</td>
<td>435</td>
<td>506</td>
<td>561</td>
<td>662</td>
<td>699</td>
</tr>
<tr>
<td>171</td>
<td>232</td>
<td>278</td>
<td>373</td>
<td>445</td>
<td>508</td>
<td>563</td>
<td>663</td>
<td>721</td>
</tr>
<tr>
<td>172</td>
<td>233</td>
<td>281</td>
<td>374</td>
<td>447</td>
<td>512</td>
<td>564</td>
<td>664</td>
<td>722</td>
</tr>
<tr>
<td>173</td>
<td>234</td>
<td>286</td>
<td>376</td>
<td>451</td>
<td>513</td>
<td>566</td>
<td>666</td>
<td>723</td>
</tr>
<tr>
<td>174</td>
<td>235</td>
<td>295</td>
<td>377</td>
<td>452</td>
<td>514</td>
<td>567</td>
<td>667</td>
<td>724</td>
</tr>
<tr>
<td>175</td>
<td>236</td>
<td>301</td>
<td>378</td>
<td>455</td>
<td>516</td>
<td>568</td>
<td>668</td>
<td>725</td>
</tr>
<tr>
<td>176</td>
<td>237</td>
<td>306</td>
<td>379</td>
<td>462</td>
<td>518</td>
<td>574</td>
<td>669</td>
<td>726</td>
</tr>
<tr>
<td>176</td>
<td>238</td>
<td>308</td>
<td>381</td>
<td>464</td>
<td>522</td>
<td>575</td>
<td>672</td>
<td>727</td>
</tr>
<tr>
<td>184</td>
<td>240</td>
<td>331</td>
<td>382</td>
<td>466</td>
<td>524</td>
<td>577</td>
<td>673</td>
<td>728</td>
</tr>
</tbody>
</table>

**OFX/QFX Transaction Codes**

For OFX/QFX formatted files, the transaction code is enclosed within the TRNTYPE tag for every transaction. See the following example:

```xml
<STMTTRN>
<TRNTYPE>CREDIT</TRNTYPE>
<TRNAMT>185.29</TRNAMT>
<FITID>320191970533635843</FITID>
<REFNUM>320191970533635843</REFNUM>
<NAME>POINTS FOR AMEX TRVL</NAME>
</STMTTRN>
```

The following table lists the supported transaction codes for the OFX/QFX parser:

<table>
<thead>
<tr>
<th>CREDIT</th>
<th>DEP</th>
<th>CASH</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEBIT</td>
<td>ATM</td>
<td>DIRECTDEP</td>
</tr>
<tr>
<td>INT</td>
<td>POS</td>
<td>DIRECTDEBIT</td>
</tr>
<tr>
<td>DIV</td>
<td>XFER</td>
<td>REPEATPMT</td>
</tr>
</tbody>
</table>
MT940 Transaction Codes

For MT940 formatted files, the transaction code starts with F,S, or N, and followed by a 3-character SWIFT code or proprietary bank code. See the following example:

:20:STATEMENT
:25:3300907685
:28C:242
:60F:C181231USD596416,02
:61:1812311231C11,55NMSCNONREF//INT TRANSFER FRO
:86:INT TRANSFER FROM 3302038958

The following table lists the supported transaction codes for the MT940 parser:

<table>
<thead>
<tr>
<th>BNK</th>
<th>CMP</th>
<th>DIV</th>
<th>MSC</th>
<th>RTI</th>
<th>TCM</th>
</tr>
</thead>
<tbody>
<tr>
<td>BOE</td>
<td>CMS</td>
<td>EQA</td>
<td>NWI</td>
<td>SAL</td>
<td>TRA</td>
</tr>
<tr>
<td>BRF</td>
<td>CMT</td>
<td>EXT</td>
<td>ODC</td>
<td>SEC</td>
<td>TRF</td>
</tr>
<tr>
<td>CAR</td>
<td>CMZ</td>
<td>FEX</td>
<td>OPT</td>
<td>SLE</td>
<td>TRN</td>
</tr>
<tr>
<td>CAS</td>
<td>COL</td>
<td>INT</td>
<td>PCH</td>
<td>STO</td>
<td>UWC</td>
</tr>
<tr>
<td>CHG</td>
<td>COM</td>
<td>LBX</td>
<td>POP</td>
<td>STP</td>
<td>VDA</td>
</tr>
<tr>
<td>CHK</td>
<td>CPN</td>
<td>LDP</td>
<td>PRN</td>
<td>SUB</td>
<td>WAR</td>
</tr>
<tr>
<td>CLR</td>
<td>DCR</td>
<td>MAR</td>
<td>REC</td>
<td>SWP</td>
<td></td>
</tr>
<tr>
<td>CMI</td>
<td>DDT</td>
<td>MAT</td>
<td>RED</td>
<td>TAX</td>
<td></td>
</tr>
<tr>
<td>CMN</td>
<td>DIS</td>
<td>MGT</td>
<td>RIG</td>
<td>TCK</td>
<td></td>
</tr>
</tbody>
</table>

CAMT.053 Transaction Codes

The CAMT.053 parser will include, by default, standard ISO Bank Transaction Codes. These codes are a combination of the Domain, Family, and Sub-family codes. The transaction codes can be found within the following tags in a CAMT.053 file:

- ISO bank transaction code:
- Custom or proprietary code:

```xml
<BkTxCd> - <Prtry>
< Cd > NCSH </ Cd >
< Issr > SWIFT </ Issr >
</ Prtry >
</ BkTxCd >
```

- Combination of ISO transaction code and custom bank codes

```xml
<BkTxCd> - <Domn>
< Cd > PMNT </ Cd >
- < Fmly >
< Cd > RCDT </ Cd >
< SubFmlyCd > ESCT </ SubFmlyCd >
</ Fmly >
</ Domn >
- < Prtry >
< Cd > N658 </ Cd >
< Issr > ABNAMRO </ Issr >
</ Prtry >
</ BkTxCd >
```

**Note:** If both ISO and proprietary bank transaction codes are present in the file, the parser will use the proprietary transaction code to identify the transaction.

For a list of the supported CAMT.053 transaction codes, click [here](#).

**Note:** To override standard bank transaction codes for CAMT.053 files, enter a combination of the Domain, Family and Sub-Family codes separated by a comma and a space.

**File Import Error Messages for Bank Statement Parsers**

**OFX/QFX File Import Error Messages**

<table>
<thead>
<tr>
<th>Cause/Scenario</th>
<th>Error Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>The bank statement account currency is not equal to currency in the NetSuite's account record</td>
<td>The file cannot be imported because the currency code [XYZ] in the file does not match the currency code for the same account in NetSuite. Check your format profile record or contact your bank to correct the error and re-upload the file again.</td>
</tr>
<tr>
<td>Invalid date format</td>
<td>The file upload failed because the file contains an incorrect date format. OFX Statement files use &lt;YYYY-MM-DD&gt; date format. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>No account match</td>
<td>The file cannot be imported because the account [1234567890] in the file does not match an account in NetSuite. Check the Account Mapping in the format profile record or contact your bank to correct the error and re-upload the file again.</td>
</tr>
</tbody>
</table>
### MT940 File Import Error Messages

<table>
<thead>
<tr>
<th>Cause/Scenario</th>
<th>Error Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>The sum of the opening balance amount (Tag 60) and the sum of the statements amount (Tag 61) within the transaction is not equal to the closing balance amount (Tag 62)</td>
<td>The file upload failed because the calculated Closing Balance does not match the Closing Amount in the file. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The currency sub-field in the transaction is not available in the account's list of currencies</td>
<td>The file could not be imported because the currency code [XYZ] for an account does not match the currency code for the same account in NetSuite.</td>
</tr>
<tr>
<td>The bank statement account currency is not equal to currency in the account's account record</td>
<td></td>
</tr>
<tr>
<td>Multiple commas are parsed in any amount sub-field</td>
<td>The file upload failed because the file contains an incorrect data at line X for tag :Y:. Amounts must include only one comma or period as a decimal separator. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The Transaction Account (Tag 25) value in MT940 file is not found in Format Profile &gt; Import Account Mapping</td>
<td>The file could not be imported, because the account [XYZ] in the file does not match an account in NetSuite.</td>
</tr>
<tr>
<td>A D/C mark sub-field value is not C, RD, D, or RC</td>
<td>The file upload failed because the file contains an incorrect Amount Indicator. Expected Amount Indicator values are C, D, RC, or RD. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The date in the Statement line (Tag 61) is not in YYMMDD format.</td>
<td>The file upload failed because the file contains an incorrect date format. MT940 statement files use the &lt;YYMMDD&gt; date format. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>An entry/booking date in the Statement line (Tag 61) is not in MMDD format.</td>
<td>The file upload failed because the file contains an incorrect booking date format. MT940 statement files use the &lt;MMDD&gt; date format in the Booking Date field. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The transaction code is unrecognizable.</td>
<td>The file upload failed because it contains an unknown transaction code [XYZ]. Update you format profile to add non-Swift transactions codes and re-upload the file again.</td>
</tr>
</tbody>
</table>

### BAI2 File Import Error Messages

<table>
<thead>
<tr>
<th>Cause/Scenario</th>
<th>Error Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>Invalid date format</td>
<td>The file upload failed because the file contains an incorrect date format. BAI2 Statement files use the &lt;YYMMDD&gt; date format. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>Cause/Scenario</td>
<td>Error Message</td>
</tr>
<tr>
<td>-----------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>The Funds Type value is unknown.</td>
<td>The file upload failed because the file contains an incorrect Funds Type. Expected Funds Type values are 0, 1, 2, S, V, D, or Z. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The file contains multiple file header (01) records.</td>
<td>The file upload failed because it contains multiple file header records. The file must only have one File Header. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The Account Control Total in the Account Trailer (49) record is incorrect.</td>
<td>The file upload failed because the total sum of transactions imported per account does not match the Account Control Total amount in the file. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The Number of Records in the Account Trailer record is incorrect.</td>
<td>The file upload failed because the total number of records per account does not match with the Account Trailer Control in the file. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The Group Control Total in the Group Trailer record is incorrect.</td>
<td>The file upload failed because the total sum of transactions per group does not match the Group Control Total in the file. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The Number of Accounts value in the Group Trailer record is incorrect.</td>
<td>The file upload failed because the total number of Account Records per group does not match the Number of Accounts in the Group Account Trailer record in the file. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The Number of Records in the Group Trailer record is incorrect.</td>
<td>The file upload failed because the total number of records per group does not match with the Group Trailer Control in the file. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The File Control Total is incorrect.</td>
<td>The file upload failed because the total sum of transactions imported does not match the File Control Total amount in the file. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The Number of Groups value in the File Trailer is incorrect.</td>
<td>The file upload failed because the total number of Group Headers in the file does not match the Number of Groups in the File Trailer record. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The Number of Records in the File Trailer is incorrect.</td>
<td>The file upload failed because the total number of records in the file does not match the total number of records in the File Trailer record. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The Continuation (88) record does not have a preceding record type.</td>
<td>The file upload failed because it contains an extra Record 88 with no preceding record. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The record contains additional fields.</td>
<td>The file upload failed because the file contains extra fields in one or more records. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
</tbody>
</table>

Example: For a 49 record, 3 fields are expected but the file has additional fields:

```
49,139037,3,1/
```
<table>
<thead>
<tr>
<th>Cause/Scenario</th>
<th>Error Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>The records or lines in the file does not end with a forward slash.</td>
<td>The file upload failed because it contains one or more incorrectly formatted record. Every record in the file must end with a forward slash. Contact your bank to correct the error and re-upload the file again.</td>
</tr>
<tr>
<td>A required field is blank.</td>
<td>The file upload failed because the Customer Account Number field is missing. A complete BAI2 file must contain Records 01, 02, 03, 16, 88, 49, 98, or 99 including all the mandatory fields. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>An invalid data is encountered for a field. Example: Amount field expects a numeric value but another data type is encountered.</td>
<td>The file upload failed because the Amount field has an invalid field data: &quot;100.00&quot;. Contact your bank to correct the file, and re-upload it again.</td>
</tr>
<tr>
<td>The record code is unknown.</td>
<td>The file upload failed because the record code is invalid. Expected record code values for BAI2 files are 01, 02, 03, 16, 88, 49, 98, or 99. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>One of the records in the file has does not have a record code.</td>
<td>The file upload failed because the record code is missing. A complete BAI2 file must contain Records 01, 02, 03, 16, 88, 49, 98, or 99. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The file is blank.</td>
<td>The file upload failed because the file is blank. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>An unexpected record was found.</td>
<td>The file upload failed because file format is incorrect. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The parser has reached the end of file but one or a few records are missing.</td>
<td>The file upload failed because the file is incomplete. A complete BAI2 file must contain Records 01, 02, 03, 16, 88, 49, 98, or 99. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>An internal or unexpected error is encountered.</td>
<td>The file upload failed because of an internal error. Please contact support if the problem persists.</td>
</tr>
<tr>
<td>An error that is not documented in the translation XML file is encountered. The parser is unable to recognize the content of the file's message property.</td>
<td>The file upload failed because of &lt;unrecognized error message&gt; error at line number &lt;line number&gt;. If you have repeatedly received this error message, contact customer support.</td>
</tr>
<tr>
<td>One of the records in the file has missing fields.</td>
<td>The file upload failed because one of the records in the file has missing fields. Contact your bank to correct the file, and re-upload it again.</td>
</tr>
<tr>
<td>There was an error in processing the previous record causing it to be unfinished.</td>
<td>The file upload failed because the parser has not completed processing a previous record due to an error. A new record cannot be processed. Contact customer support.</td>
</tr>
<tr>
<td>A NetSuite Account Statement for the current record cannot be created because there is no Group Header and Account Identifier in the bank statement.</td>
<td>The file upload failed because the Group Header and Account Identifier are missing. A complete BAI2 file must contain Records 01, 02, 03, 16, 88, 49, 98, or 99. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>A NetSuite Account Statement for the current record cannot be created because there is no Group Header, Account Identifier, and Transaction Detail are missing. A complete BAI2 file must contain Records 01, 02, 03, 16, 88, 49, 98, or 99.</td>
<td>The file upload failed because the Group Header, Account Identifier, and Transaction Detail are missing. A complete BAI2 file must contain Records 01, 02, 03, 16, 88, 49, 98, or 99.</td>
</tr>
<tr>
<td>Cause/Scenario</td>
<td>Error Message</td>
</tr>
<tr>
<td>-------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Header, Account Identifier, and Transaction Detail in the bank statement.</td>
<td>Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
</tbody>
</table>

### CAMT.053 File Import Error Messages

<table>
<thead>
<tr>
<th>Cause / Scenario</th>
<th>Error Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>The uploaded XML failed the CAMT.053.001.02 XSD validation</td>
<td>The file upload failed because it does not conform with the valid CAMT.053.001.02 XML Format. Contact your bank to correct the error, and re-upload the file again.</td>
</tr>
<tr>
<td>The file mapping entered in the Parser Configuration subtab does not start with <code>&lt;BkToCstmrStmt&gt; &lt;Stmt&gt;</code></td>
<td>The file mapping must begin with <code>&quot;&lt;BkToCstmrStmt&gt; &lt;Stmt&gt;&quot;</code> to import the transactions from the file to NetSuite.</td>
</tr>
<tr>
<td>The file mapping entered in the Parser Configuration subtab does not follow the tag format</td>
<td>Each tag used in the file mapping must be enclosed in <code>&quot;&lt;&quot; and &quot;&gt;&quot;, and must be separated by a space. For example, </code>&lt;BkToCstmrStmt&gt; &lt;Stmt&gt; &lt;Acct&gt; &lt;Id&gt; &lt;IBAN&gt;`.</td>
</tr>
<tr>
<td>All mappings for a specific field in the Parser Configuration subtab are deleted.</td>
<td>The configurations for the following field(s) will be removed: <code>&lt;NetSuite field names&gt;</code></td>
</tr>
<tr>
<td></td>
<td>Click OK to restore the default file mapping or click Cancel to manually configure the file mapping for the affected fields.</td>
</tr>
<tr>
<td>The Credit/Debit field in the Transaction Code Mapping subtab is set to a value other than N/A.</td>
<td>The Credit/Debit value is sourced from the statement file to determine the GL Impact of the transaction. Click OK to set the value to N/A and use the indicator in the file or click Cancel to override the amount indicator in the file.</td>
</tr>
<tr>
<td>The imported transaction is not marked with a “BOOK” status.</td>
<td>The bank statement file contains {1} transactions that are not yet posted or booked in your bank account. Only booked or posted transactions are imported.</td>
</tr>
<tr>
<td>A duplicate file mapping is entered in the Parser Configuration subtab.</td>
<td>The file mapping {1} for NetSuite Field {2} already exists. Please enter a unique file mapping path.</td>
</tr>
</tbody>
</table>