should not be relied upon in making purchasing decisions. The development, release, and timing of any features or functionality described in this document remains at the sole discretion of Oracle.

This document in any form, software or printed matter, contains proprietary information that is the exclusive property of Oracle. Your access to and use of this confidential material is subject to the terms and conditions of your Oracle Master Agreement, Oracle License and Services Agreement, Oracle PartnerNetwork Agreement, Oracle distribution agreement, or other license agreement which has been executed by you and Oracle and with which you agree to comply. This document and information contained herein may not be disclosed, copied, reproduced, or distributed to anyone outside Oracle without prior written consent of Oracle. This document is not part of your license agreement nor can it be incorporated into any contractual agreement with Oracle or its subsidiaries or affiliates.

For information about Oracle’s commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

Sample Code

Oracle may provide sample code in SuiteAnswers, the Help Center, User Guides, or elsewhere through help links. All such sample code is provided “as is” and “as available”, for use only with an authorized NetSuite Service account, and is made available as a SuiteCloud Technology subject to the SuiteCloud Terms of Service at www.netsuite.com/tos.

Oracle may modify or remove sample code at any time without notice.

No Excessive Use of the Service

As the Service is a multi-tenant service offering on shared databases, Customer may not use the Service in excess of limits or thresholds that Oracle considers commercially reasonable for the Service. If Oracle reasonably concludes that a Customer’s use is excessive and/or will cause immediate or ongoing performance issues for one or more of Oracle’s other customers, Oracle may slow down or throttle Customer’s excess use until such time that Customer’s use stays within reasonable limits. If Customer’s particular usage pattern requires a higher limit or threshold, then the Customer should procure a subscription to the Service that accommodates a higher limit and/or threshold that more effectively aligns with the Customer’s actual usage pattern.

Beta Features

Oracle may make available to Customer certain features that are labeled “beta” that are not yet generally available. To use such features, Customer acknowledges and agrees that such beta features are subject to the terms and conditions accepted by Customer upon activation of the feature, or in the absence of such terms, subject to the limitations for the feature described in the User Guide and as follows: The beta feature is a prototype or beta version only and is not error or bug free and Customer agrees that it will use the beta feature carefully and will not use it in any way which might result in any loss, corruption or unauthorized access of or to its or any third party’s property or information. Customer must promptly report to Oracle any defects, errors or other problems in beta features to support@netsuite.com or other designated contact for the specific beta feature. Oracle cannot guarantee the continued availability of such beta features and may substantially modify or cease providing such beta features without entitling Customer to any refund, credit, or other compensation. Oracle makes no representations or warranties regarding functionality or use of beta features and Oracle shall have no liability for any lost data, incomplete data, re-run time, inaccurate input, work delay, lost profits or adverse effect on the performance of the Service resulting from the use of beta features. Oracle’s standard service levels, warranties and related commitments regarding the Service shall not apply to beta features and they may not be fully supported by Oracle’s customer support. These limitations and exclusions shall apply until the date that Oracle at its sole option makes a beta feature generally available to its customers and partners as part of the Service without a “beta” label.
Send Us Your Feedback

We'd like to hear your feedback on this document.

Answering the following questions will help us improve our help content:

- Did you find the information you needed? If not, what was missing?
- Did you find any errors?
- Is the information clear?
- Are the examples correct?
- Do you need more examples?
- What did you like most about this document?

Click here to send us your comments. If possible, please provide a page number or section title to identify the content you're describing.

To report software issues, contact NetSuite Customer Support.
# Table of Contents

**Employee Management** .................................................................................................................. 1
**SuitePeople Overview** ..................................................................................................................... 2
**SuitePeople Permission Requirements** .......................................................................................... 3
  - Advanced and Basic Government-Issued ID Tracking Permission Requirements ......................... 3
  - Compensation Tracking Permission Requirements ........................................................................... 4
**Effective Dating Permission Requirements** .................................................................................. 6
**Employee Center Publishing Permission Requirements** .............................................................. 7
**Employee Change Requests Permission Requirements** ............................................................... 7
**Job Management and Job Requisitions Permission Requirements** ............................................... 8
**Kudos Permission Requirements** .................................................................................................. 9
**News Items Permission Requirements** .......................................................................................... 10
**Termination Reason Tracking Permission Requirements** ............................................................ 10
**Time-Off Management Permission Requirements** ....................................................................... 11
**Workforce Analytics Permission Requirements** ............................................................................ 12

**Employee Information Management** .......................................................................................... 13
**Adding an Employee Record** .......................................................................................................... 13
  - Adding Information to the Subtabs ................................................................................................. 15
**Entering Communication Information on the Employee Record** ................................................. 17
**Entering Address Information for an Employee** .......................................................................... 17
**Human Resources Information for an Employee** .......................................................................... 18
**Giving an Employee Access to NetSuite** ..................................................................................... 22
  - Assigning Roles to an Employee .................................................................................................... 24
**Assigning a Supervisor to an Employee** ....................................................................................... 25
**Updating an Employee’s Supervisor** ............................................................................................. 25
**Viewing and Editing an Employee Record with Effective Dating** .................................................. 26
**Searching for Effective-Dated Changes to the Employee Record** ................................................. 28
**Viewing an Employee’s Timeline** .................................................................................................. 28
**Kudos** ............................................................................................................................................ 29
  - Renaming Kudos ............................................................................................................................ 29
  - Managing Kudos ............................................................................................................................ 30
  - Giving Kudos to Coworkers using Employee Center .................................................................... 31
**Employee Locations** ..................................................................................................................... 32
**Creating an Employee Template** .................................................................................................... 33
**Working with Employee Social Security Numbers** ....................................................................... 34
**Printing Mailing Labels for Employees** ........................................................................................ 35

**Effective Dating for Employee Information** ................................................................................ 36
**Using Effective Dating with the Employee Record** ...................................................................... 36
**Managing Employee Change Reasons** ....................................................................................... 38
**Using Effective Dating with Other NetSuite Features** .................................................................. 39
**Using Effective Dating with Employee Workflows and SuiteScripts** ......................................... 40

**Employee Change Requests** ........................................................................................................ 42
**Prerequisites for Employee Change Requests** ............................................................................. 42
  - Enabling the Employee Change Requests Feature ....................................................................... 42
  - Setting Up Employee Change Request Types ............................................................................... 42
  - Advanced Employee Permissions for Employee Change Requests ............................................. 44
  - Setting Up an Approval Workflow for Employee Change Requests ........................................... 45
**Employee Change Requests Management** ................................................................................. 51
  - Creating an Employee Change Request from the Employee Record ........................................... 52
  - Editing or Inactivating an Employee Change Request ............................................................... 52
  - Deleting an Employee Change Request ....................................................................................... 53
**Employee Change Requests in the Employee Center** .................................................................. 53
  - Creating an Employee Change Request from the Employee Center ........................................... 53
  - Approving or Declining an Employee Change Request .............................................................. 54
# Table of Contents

- **Time Tracking** ................................................................. 174
  - Understanding Time Tracking ........................................ 174
  - Setting Up Time Tracking Preferences .............................. 177
  - Giving an Employee Access to Time Tracking .................. 177
  - Restricting Employee Time Tracking Entries .................... 180
  - Entering a Time Transaction ............................................ 181
  - Weekly Time Tracking ..................................................... 184
  - Weekly Timesheets .......................................................... 186
  - Using the Timer to Track Time ........................................ 191
  - Calculating Total Time Worked ..................................... 192
  - Entering Time for a Payroll Item ................................. 192
  - Custom Fields in Time Tracking Pages ......................... 194
  - Approving or Rejecting a Time Transaction .................... 196
  - Custom Workflow-based Approvals for Time Tracking ........ 199
  - Updating Time Entries .................................................. 200

- **Expense Reports and Purchase Requests** .......................... 203
  - Understanding Expense Reports ................................... 203
  - Giving an Employee Access to Expense Reporting ........... 206
  - Entering an Expense Report .......................................... 207
  - Approving an Expense Report ....................................... 213
  - Editing an Expense Report from the Expense Reports List ... 217
  - Deleting an Expense Report from the Expense Reports List ... 217
  - Rejecting an Expense Report from the Expense Reports List ... 218
  - Corporate Card Expenses ............................................. 218
  - Reviewing Expense Reports ......................................... 220
  - Giving Accounting Approval for Expense Reports ............ 221
  - Understanding Expense Categories ................................ 223
  - Paying Expenses on Employee Paychecks with Payroll ... 223
  - Giving an Employee Access to Purchase Requests .......... 225
  - Notifying a Supervisor or Approver About Required Approvals 226

- **Analytics and Reporting** .................................................. 228
  - Workforce Analytics Overview ....................................... 229
  - Working with Headcount Analysis ................................. 229
  - Headcount Analysis Trends ......................................... 230
  - Headcount Analysis Snapshots ..................................... 231
  - Working with Turnover Analysis .................................. 232
  - Turnover Analysis Trends .......................................... 232
  - Turnover Analysis Snapshots ....................................... 234
  - Employee Reports and Workbooks ................................ 236
  - Time and Billables Reports .......................................... 236
  - Time-Off Management Reports and Workbooks .............. 236
    - Available Time-Off Report ....................................... 237
    - Time-Off Balance Summary Report ............................. 238
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compliance</td>
<td>254</td>
</tr>
<tr>
<td>Benefits Tracking</td>
<td>287</td>
</tr>
<tr>
<td>Government-Issued ID Tracking</td>
<td>282</td>
</tr>
<tr>
<td>Affordable Care Act (ACA) Reporting</td>
<td>267</td>
</tr>
<tr>
<td>Time-Off Balance Details Report</td>
<td>239</td>
</tr>
<tr>
<td>Time-Off Analysis Workbook</td>
<td>240</td>
</tr>
<tr>
<td>Time-Off Tracking Reports</td>
<td>241</td>
</tr>
<tr>
<td>Recruiting Reports</td>
<td>244</td>
</tr>
<tr>
<td>Customizing Recruiting Reports</td>
<td>245</td>
</tr>
<tr>
<td>Employee Change History Report</td>
<td>246</td>
</tr>
<tr>
<td>Employee Saved Search Reports</td>
<td>246</td>
</tr>
<tr>
<td>Customizing Employee Reports</td>
<td>250</td>
</tr>
<tr>
<td>Employee Bonus History and Current Compensation Workbook</td>
<td>252</td>
</tr>
<tr>
<td>Employee Bonus History Compensation Overview Dataset Template</td>
<td>252</td>
</tr>
<tr>
<td>Compliance</td>
<td>254</td>
</tr>
<tr>
<td>Compliance</td>
<td>254</td>
</tr>
<tr>
<td>Workplace Incident Tracking</td>
<td>255</td>
</tr>
<tr>
<td>Setting Up the Health and Safety SuiteApp</td>
<td>255</td>
</tr>
<tr>
<td>Working with Workplace Incidents</td>
<td>257</td>
</tr>
<tr>
<td>Adding a Workplace Incident</td>
<td>258</td>
</tr>
<tr>
<td>Adding a General Workplace Incident</td>
<td>258</td>
</tr>
<tr>
<td>OSHA 301 Workplace Incidents</td>
<td>260</td>
</tr>
<tr>
<td>RIDDOR Workplace Incidents</td>
<td>262</td>
</tr>
<tr>
<td>Generating OSHA Workplace Incident Logs and Summaries</td>
<td>265</td>
</tr>
<tr>
<td>Affordable Care Act (ACA) Reporting</td>
<td>267</td>
</tr>
<tr>
<td>Setting Up the ACA Reporting SuiteApp</td>
<td>268</td>
</tr>
<tr>
<td>ACA Pre-Filing</td>
<td>270</td>
</tr>
<tr>
<td>Identifying Part-Time Employees</td>
<td>270</td>
</tr>
<tr>
<td>Creating an ACA Offer of Coverage Plan</td>
<td>271</td>
</tr>
<tr>
<td>Assigning an ACA Offer of Coverage Plan to Multiple Employees</td>
<td>273</td>
</tr>
<tr>
<td>Setting Up Employer Information</td>
<td>273</td>
</tr>
<tr>
<td>ACA Filing</td>
<td>274</td>
</tr>
<tr>
<td>Updating Employee Records for ACA</td>
<td>276</td>
</tr>
<tr>
<td>Assigning an ACA Offer of Coverage Plan to an Employee</td>
<td>276</td>
</tr>
<tr>
<td>Adding Covered Individuals to an Employee</td>
<td>277</td>
</tr>
<tr>
<td>Adding Safe Harbor Codes to an Employee</td>
<td>278</td>
</tr>
<tr>
<td>Excluding an Employee from ACA Reporting</td>
<td>279</td>
</tr>
<tr>
<td>State-Specific ACA Reporting for DC and NJ</td>
<td>279</td>
</tr>
<tr>
<td>Viewing ACA Filing History</td>
<td>281</td>
</tr>
<tr>
<td>Government-Issued ID Tracking</td>
<td>282</td>
</tr>
<tr>
<td>Government-Issued ID Tracking Overview</td>
<td>282</td>
</tr>
<tr>
<td>Managing Government-Issued ID Types</td>
<td>283</td>
</tr>
<tr>
<td>Managing Basic Government-Issued ID for Employees</td>
<td>284</td>
</tr>
<tr>
<td>Managing Advanced Government-Issued ID for Employees</td>
<td>285</td>
</tr>
<tr>
<td>Benefits Tracking</td>
<td>287</td>
</tr>
<tr>
<td>Setting Up the Benefits Tracking SuiteApp</td>
<td>287</td>
</tr>
<tr>
<td>Configuring Benefits Tracking</td>
<td>288</td>
</tr>
<tr>
<td>Creating Benefit Carriers</td>
<td>288</td>
</tr>
<tr>
<td>Creating Benefit Types</td>
<td>289</td>
</tr>
<tr>
<td>Creating Benefits</td>
<td>289</td>
</tr>
<tr>
<td>Assigning Benefits to an Employee</td>
<td>290</td>
</tr>
<tr>
<td>Benefits Tracking Reports</td>
<td>291</td>
</tr>
<tr>
<td>Importing Benefits Information from Carriers</td>
<td>292</td>
</tr>
</tbody>
</table>
Employee Management

NetSuite provides you with the tools that you need to manage your employees. You can:

- Add employee records to NetSuite. For more information, see Employee Information Management.
- Give employees access to NetSuite. For more information, see Giving an Employee Access to NetSuite.
- Log employee expenses and purchase requests. For more information, see Expense Reports and Purchase Requests.
- Track employees’ time with the Time Tracking feature. For more information, see Managing Time Tracking.

NetSuite also offers SuitePeople, a comprehensive and integrated Human Capital Management (HCM) solution. SuitePeople enables Human Resources professionals to manage employees within NetSuite, thus eliminating repetitive and manual processes with one source of where employee data is kept.

For more information, see SuitePeople Overview. For more information about SuitePeople, contact your NetSuite account manager.

- SuitePeople Overview
- Employee Information Management
- Effective Dating for Employee Information
- Employee Change Requests
- Employee Directory and Org Browser
- Employee Center Management
- Employee Onboarding and Offboarding Plans
- Employee Offboarding
- Time-Off Management
- Compensation Tracking
- Job Management
- Advanced Employee Permissions
- Time Tracking
- Expense Reports and Purchase Requests
- Analytics and Reporting
- Compliance
SuitePeople Overview

SuitePeople is a comprehensive and integrated Human Capital Management (HCM) solution. SuitePeople eliminates repetitive and manual processes by providing one source for employee data. This enables Human Resources (HR) and Payroll professionals to efficiently manage employees within NetSuite.

SuitePeople consists of two main modules:

- **SuitePeople HR**, which empowers employees and managers with self-service functionality to complete most everyday tasks. SuitePeople HR leverages NetSuite to provide customizable workflows tailored for how you do business. This module includes:
  - **Time-Off Management** – Create and manage time-off plans, and assign them to employees. Employees can request time off and view the status of their requests in the Employee Center. Managers can review and approve time-off requests either from an email message or from the Employee Center.
  - **Effective Dating for Employee Information** – Edit the employee record as of a certain date, whether in the past, present, or future.
  - **Employee Change Requests** - Manage change approvals for the employee record.
  - **Job Management** – Track different job types within your organization.
  - **Kudos** - Recognize the achievements of your coworkers.
  - **Employee Directory and Org Browser** - Browse your organization’s structure, and search for employees, filtering by location, department, and other parameters.
  - **Employee Center Dashboard Publishing** - Create a standard Employee Center dashboard for your organization. This includes a dashboard specifically designed for supervisors and managers.
  - **News Items** - Create and share company news with your employees. News items appear on the Company News portlet in the Employee Center.
  - **Compensation Tracking** - Track base pay and bonus information on the employee record, and, if applicable, integrate compensation with SuitePeople U.S. Payroll.
  - **Advanced Employee Permissions** - Use employee permissions that give you more control and flexibility over which fields and sublists on the employee record are available to NetSuite roles.
  - **Workforce Analytics** - Measure and analyze headcount and turnover trends in your company.
  - **Employee Reports and Workbooks** - Use reports to keep you up to date with time-off balances, payroll, employee change history, and more.
  - **Employee Onboarding and Offboarding Plans** – Manage the onboarding and offboarding process for various employees by using plans, templates, reminders, and email notifications.
  - **Employee Offboarding** - Manage the offboarding of employees, including the creation of custom termination reasons.
  - **Employee Timeline** — View an employee’s key career milestones and career changes in chronological order.
  - **Compliance** - Ensure that your organization is compliant with government regulations, such as the Affordable Care Act.

- **SuitePeople U.S. Payroll**, which is a full-service payroll solution that is fully integrated with SuitePeople HR and Accounting modules. For more information, see .

For more information about SuitePeople HR or SuitePeople U.S. Payroll, contact your NetSuite account manager.
SuitePeople Permission Requirements

Note: If you want more control over what employee information is accessible by different NetSuite users you can use the Advanced Employee Permissions feature. You can use the employee permissions that come with this feature to give you more control over what employee information certain roles can access. You can also customize employee permissions to include all or set of standard fields and sublists from the employee record. For more information, see Advanced Employee Permissions.

The following section contains information about the permission requirements you need when working with the various SuitePeople features.

NetSuite includes four different types of permissions; Lists, Reports, Setup, and Transactions. Generally, permissions have four possible access levels; View, Create, Edit, and Full.

You can control what a role can do based on the level of access you set for a permission. In general, each successive level (view, create, edit, full) of a permission provides increased usage of the related record type, task, or page, but the usage of some permissions does not fit exactly into this model. Generally, any user with at least View access to a record type has the ability to print records of that type. For some permissions, not all access levels are supported. All SuitePeople features require some level of employee access to view employee information. For more information, see the help topic Permissions Documentation.

- Advanced and Basic Government-Issued ID Tracking Permission Requirements
- Compensation Tracking Permission Requirements
- Effective Dating Permission Requirements
- Employee Center Publishing Permission Requirements
- Employee Change Requests Permission Requirements
- Job Management and Job Requisitions Permission Requirements
- Kudos Permission Requirements
- News Items Permission Requirements
- Termination Reason Tracking Permission Requirements
- Time-Off Management Permission Requirements
- Workforce Analytics Permission Requirements

Advanced and Basic Government-Issued ID Tracking Permission Requirements

If you have the Advanced and Basic Government-Issued ID Tracking features enabled in your NetSuite account, the Advanced Government-Issued IDs permission must be assigned to roles who need to track a variety of government-issued identifications for your employees.

In addition, if users need to add or edit government-issued IDs on the employee record, the Government-Issued ID Types permission should be assigned at access level Create or Edit.

These permissions are located on the Lists subtab of the Role page. For a list of the standard roles assigned to this permission, see the help topic Standard Roles Permissions Table. You can create custom roles that include this permission. For more information, see the help topic Customizing or Creating NetSuite Roles.

The following table lists the permission level a user must have to perform certain tasks related to the Advanced and Basic Government-Issued ID Tracking features.
### SuitePeople Permission Requirements

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced Government-Issued IDs</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allows users to view and search for employee government-issued ID information. Users cannot create, edit, or delete government-issued ID information.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create</td>
<td>Allows users to create driver's license, passport and other IDs through entry forms. Users cannot edit or delete government-issued IDs.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit government-issued IDs. Users cannot delete government-issued IDs.</td>
</tr>
<tr>
<td>Government-Issued ID Types</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allows users to view and search for government-issued ID types. Users cannot create, edit, or delete government-issued ID types.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create</td>
<td>Allows users to create and view government-issued ID types for employees. Users cannot edit or delete government-issued ID types.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit government-issued ID types. Users cannot delete government-issued ID types.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full</td>
<td>Allows users to create, view, edit, and delete government-issued IDs.</td>
</tr>
</tbody>
</table>

**Note:** IDs are always masked unless the Full access level is used.

For more information about these features, see [Government-Issued ID Tracking](#).

### Compensation Tracking Permission Requirements

If you have the Compensation Tracking feature enabled in your account, any standard roles that have the Employees permission can access base pay and bonus target information. To access information on the bonus record, roles require the Bonus permission. To access bonus types, roles require the Bonus Type permission. These permissions are located on the Lists subtab of the Role page. For a list of the standard roles assigned to these permissions, see the help topic [Standard Roles Permissions Table](#). To learn how to create custom roles that include these permissions, see the help topic [Customizing or Creating NetSuite Roles](#).

For more information about the Compensation Tracking feature, see [Compensation Tracking](#).

The following table lists the permission level a user must have to perform certain tasks related to compensation tracking.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employees</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allows users to view and search for base pay and bonus target information on the employee record.</td>
</tr>
<tr>
<td>Permission</td>
<td>Subtab</td>
<td>Permission Access Level</td>
<td>Supported Functionality</td>
</tr>
<tr>
<td>------------</td>
<td>--------</td>
<td>-------------------------</td>
<td>-------------------------</td>
</tr>
<tr>
<td>Create</td>
<td></td>
<td>Access Level</td>
<td></td>
</tr>
<tr>
<td>Edit</td>
<td></td>
<td>Access Level</td>
<td></td>
</tr>
<tr>
<td>Full</td>
<td></td>
<td>Access Level</td>
<td></td>
</tr>
<tr>
<td>Bonus Type</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allows users to view and search for bonus type records.</td>
</tr>
<tr>
<td>Create</td>
<td>Permissions &gt; Lists</td>
<td>Create</td>
<td>Allows users to view, search for, and create bonus type records.</td>
</tr>
<tr>
<td>Edit</td>
<td>Permissions &gt; Lists</td>
<td>Edit</td>
<td>Allows users to view, search for, edit, and create bonus type records. Users can also inactivate bonus type records, if the records have not been assigned to a bonus.</td>
</tr>
<tr>
<td>Full</td>
<td>Permissions &gt; Lists</td>
<td>Full</td>
<td>Allows users to view, search for, edit, and create bonus type records. Users can also inactivate or delete bonus type records.</td>
</tr>
<tr>
<td>Bonus</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allows users to view and search for a list of awarded bonuses on the employee record. Users can also see the Award Bonus button.</td>
</tr>
<tr>
<td>Create</td>
<td>Permissions &gt; Lists</td>
<td>Create</td>
<td>Allows users to view and search for a list of awarded bonuses on the employee record. Users can award bonuses using the Award Bonus form.</td>
</tr>
<tr>
<td>Edit</td>
<td>Permissions &gt; Lists</td>
<td>Edit</td>
<td>Allows users to view and search for a list of awarded bonuses on the employee record. Users can award bonuses using the Award Bonus form, and, if bonuses are not paid using SuitePeople U.S. Payroll, users can edit bonuses.</td>
</tr>
<tr>
<td>Full</td>
<td>Permissions &gt; Lists</td>
<td>Full</td>
<td>Allows users to view and search for a list of awarded bonuses on the employee record. Users can award bonuses using the Award Bonus form. If bonuses are not paid using SuitePeople U.S. Payroll, users can edit bonuses. Users can also delete bonuses. If bonuses are paid using SuitePeople U.S. Payroll, users can delete only bonuses that are not included on a payroll batch.</td>
</tr>
</tbody>
</table>

**Advanced Employee Permissions and Bonuses**

With the Advanced Employee Permissions feature, you can apply additional restrictions to fields on the employee record. For more information, see Advanced Employee Permissions. However, you cannot use the Advanced Employee Permissions feature to control access to fields on the bonus record. Access to bonus record fields is determined by your role, and specifically by the employee restrictions defined on a role. For more information about employee restrictions, see the help topics Customizing or Creating NetSuite Roles and Set Employee Restrictions.

The Advanced Employee Permissions feature includes a permission called Employee Compensation. This permission provides access to:

- Compensation fields on the employee record
- The Bonus sublist
The image below details the fields that the Employee Compensation permission provides access to, and it also shows the fields that the Advanced Employee Permissions feature can restrict.

**Important:** The ability to create or edit bonuses is restricted to roles that include the bonus permission. You might want managers to be able to create bonuses for their direct reports. However, if managers can create bonuses for their direct reports, then managers can also create bonuses for themselves.

**Effective Dating Permission Requirements**

If you have the Effective Dating feature enabled in your account, the Employee Effective Dating permission must be assigned to roles to use the feature. In addition, if users need to add to or edit the change reasons record, the Employee Change Reason permission should be assigned at access level Create or Edit. The Employee Effective Dating permission also gives users access to the employee timeline. For details, see View an Employee’s Timeline. These permissions are located on the Lists subtab of the Role page.

For a list of the standard roles assigned to these permissions, see the help topic Standard Roles Permissions Table. You can create custom roles that include this permission. For more information, see the help topic Customizing or Creating NetSuite Roles.

The following table lists the permission level a user must have to perform certain tasks related to effective dating.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Effective Dating (Access levels Create and Full are not supported)</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allows users to view and search for effective dated changes. Users cannot create, edit, or delete effective dated changes. Allows users to view the employee timeline from the employee record. For details, see Employee Timeline.</td>
</tr>
</tbody>
</table>
### SuitePeople Permission Requirements

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit</td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit effective dated changes. Users cannot create or delete effective dated changes.</td>
</tr>
<tr>
<td>Employee Change Reason Permission</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allows users to view and search change reasons records. Users cannot create, edit, or delete change reason records.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create</td>
<td>Allows users to create and view change reasons records. Users cannot edit or delete change reason records.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit change reasons records. Users cannot delete change reasons records.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full</td>
<td>Allows users to create, view, edit, and delete change reasons records.</td>
</tr>
</tbody>
</table>

For more information about this feature, see [Effective Dating for Employee Information](#).

### Employee Center Publishing Permission Requirements

If you have the Employee Center Dashboard Publishing feature enabled, you must assign the Employee Center Publishing global permission to any users who are responsible for publishing a standard Employee Center dashboard for your company. The permission is assigned to users on their employee record.

For more information about the Global Permissions feature, see the help topic [Using the Global Permissions Feature](#). For more information about the Employee Center Publishing feature, see [Employee Center Dashboard Publishing](#).

### Employee Change Requests Permission Requirements

**Important:** This topic describes a feature that is currently available only in some customer accounts. For information on the availability of this feature for your account, please contact your NetSuite account manager.

If you have the Employee Change Requests feature enabled, you must assign Employee Change Requests permissions to any users who are responsible for managing Employee Change Requests for your company. After you enable the feature, Administrator, HR Generalist, and Chief People Officer roles are automatically assigned Full permission for Employee Change Requests and Employee Change Request Types. For a list of the standard roles assigned to these permissions, see the help topic [Standard Roles Permissions Table](#). You can create custom roles that include this permission. For more information, see the help topic [Customizing or Creating NetSuite Roles](#).

**Note:** To create, view, approve, and decline Employee Change Requests in the Employee Center, you do not need to assign Employee Change Requests permissions to Employee Center roles. Instead, you must assign Advanced Employee Permissions to requesters and approvers in a custom Employee Center role. For more information, see [Advanced Employee Permissions for Employee Change Requests](#).

The following table lists the permission level a user must have to perform certain tasks related to Employee Change Requests.
### SuitePeople Permission Requirements

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Change Requests</td>
<td>Permission &gt; Lists</td>
<td>View</td>
<td>Allows users to view employee change requests. Users cannot create, edit, or delete employee change requests.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create</td>
<td>Allows users to create and view employee change requests. Users cannot edit or delete employee change requests.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit employee change requests. Users cannot delete employee change requests.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full</td>
<td>Allows users to create, view, edit, and delete employee change requests.</td>
</tr>
<tr>
<td>Employee Change Request Types</td>
<td>Permission &gt; Lists</td>
<td>View</td>
<td>Allows users to view employee change request types. Users cannot create, edit, or delete employee change request types.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create</td>
<td>Allows users to create and view employee change request types. Users cannot edit or delete employee change request types.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit employee change request types. Users cannot delete employee change request types.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full</td>
<td>Allows users to create, view, edit, and delete employee change request types.</td>
</tr>
</tbody>
</table>

For more information about this feature, see [Employee Change Requests](#).

### Job Management and Job Requisitions Permission Requirements

If you have either the Job Management or the Job Requisitions feature enabled, the Job Management and Job Requisitions permissions must be assigned to roles to use these features. Additionally, if users need to assign jobs, the Employees permission should be assigned at access level Edit.

These permissions are located on the Lists subtab of the Role page. For a list of the standard roles assigned to these permissions, see the help topic [Standard Roles Permissions Table](#).

The following table lists the permission levels that a user must have to perform certain tasks related to these features.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employees</td>
<td>Permissions &gt; Lists</td>
<td>Edit</td>
<td>Allows users to assign jobs on the employee record.</td>
</tr>
<tr>
<td>Job Management</td>
<td>Permissions &gt; Lists</td>
<td>Create</td>
<td>Allow users to create and view job records. Users cannot edit or delete job records.</td>
</tr>
<tr>
<td>(Access level View is not supported)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Permission</td>
<td>Subtab</td>
<td>Permission Access Level</td>
<td>Supported Functionality</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------</td>
<td>-------------------------</td>
<td>-------------------------------------------------------------</td>
</tr>
<tr>
<td>Edit</td>
<td></td>
<td></td>
<td>Allows users to create, view, and edit job records. Users cannot delete job records.</td>
</tr>
<tr>
<td>Full</td>
<td></td>
<td></td>
<td>Allows users to create, view, edit, and delete job records.</td>
</tr>
<tr>
<td>Job Requisitions</td>
<td>Permissions &gt; Lists</td>
<td>Create</td>
<td>Allow users to create and view job requisition records. Users cannot edit or delete job requisition records.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit job requisition records. Users cannot delete job requisition records.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full</td>
<td>Allows users to create, view, edit, and delete job requisition records.</td>
</tr>
</tbody>
</table>

Job Requisitions (Access level View is not supported)

For more information about these features, see Managing Jobs and Job Requisitions.

Kudos Permission Requirements

If you have the Kudos feature enabled in your account, the Kudos permission must be assigned to roles to use this feature. Additionally, if users need to create or edit existing values, the Organizational Values permission should be assigned at access level Create or Edit.

These permissions are located on the Lists tab of the Role page. For a list of the standard roles assigned to this permission, see the help topic Standard Roles Permissions Table.

The following table lists the permission level a user must have to perform certain tasks related to these features.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kudos</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allow users to receive and view Kudos. Users cannot create new, edit, or delete Kudos.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create</td>
<td>Allows users to give Kudos. Users cannot edit or delete Kudos.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to edit the Inactive field. Users cannot delete Kudos.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full</td>
<td>Allows users to edit the Inactive field and delete Kudos.</td>
</tr>
<tr>
<td>Organization Value</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allow users to view company organizational values. Users cannot create, edit, or delete organizational values.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create</td>
<td>Allow users to create and view organizational values. Users cannot edit or delete organizational values.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit organizational values.</td>
</tr>
</tbody>
</table>
SuitePeople Permission Requirements

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Users cannot delete organizational values.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Full</td>
<td>Allows users to create, view, edit, and delete organizational values.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For more information about this feature, see Managing Kudos.

News Items Permission Requirements

If the Employee Center Dashboard Publishing feature is enabled in your account, the News Items permission allows you to create news items that appear on the Company News portlet of the Employee Center.

This permission is located on the Lists tab of the Role page. For a list of the standard roles assigned this permission, see the help topic Standard Roles Permissions Table.

The following table lists the permission access level a user must have to perform certain tasks related to this feature.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Allows users to view and search for news items. Users cannot create, edit, or delete news items.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Create</td>
<td>Allows users to view and create news items. Users cannot edit or delete new items.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit</td>
<td>Allows users to create, view, and edit news items. Users cannot delete news items.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Full</td>
<td>Allows users to create, view, edit, and delete news items.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Termination Reason Tracking Permission Requirements

If you have the Termination Reason Tracking feature enabled in your account, the Termination Reasons permission must be assigned to roles to use this feature.

This permission is located on the Lists tab of the Role page. For a list of the standard roles assigned to this permission, see the help topic Standard Roles Permissions Table.

The following table lists the permission access level a user must have to perform certain tasks related to this feature.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Allows users to view and search for termination reasons. Users cannot create, edit, or delete termination reasons.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Create</td>
<td>Allows users to view and create termination reasons. Users cannot edit or delete termination reasons.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Permission</td>
<td>Subtab</td>
<td>Permission Access Level</td>
<td>Supported Functionality</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>----------------------------</td>
<td>-------------------------</td>
<td>----------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit termination reasons. Users cannot delete termination reasons.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full</td>
<td>Allows users to create, view, edit, and delete termination reasons.</td>
</tr>
</tbody>
</table>

For more information about this feature, see [Termination Reason Tracking](#).

### Time-Off Management Permission Requirements

If you have the Time-Off Management feature enabled in your account, the Time-Off Administration permission and the Documents and Files permission must be assigned to roles to use this feature. These permissions are located on the Lists subtab of the Role page. For a list of the standard roles assigned to these permissions, see the help topic [Standard Roles Permissions Table](#).

You can also create custom roles that include these permissions. For more information, see the help topic [Customizing or Creating NetSuite Roles](#).

The following table lists the permission level a user must have to perform certain tasks related to this feature.

**Note:** The Time-Off Tracking SuiteApp must be installed when you are using the Time-Off Management feature. The Time-Off Tracking SuiteApp enables users to request or approve time-off from the Employee Center.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time-Off Administration</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allows users to view and search for time-off plans, time-off types, and time-off rules. Users cannot create, edit, or delete time-off information.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create</td>
<td>Allows users to create time-off plans, time-off types, and time-off rules. Users cannot edit or delete time-off information.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit time-off plans, time-off types, and time-off rules. Also, users can change the time-off plan assigned on the employee record. Users cannot delete time-off plans, time-off types, or time-off rules.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full</td>
<td>Allows users to create, view, edit, and delete time-off plans, time-off types, and time-off rules.</td>
</tr>
<tr>
<td>Documents and Files</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allows users to view and search for files in File Cabinet. The Time-Off Tracking SuiteApp requires access to files that are stored in File Cabinet.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create</td>
<td>Allows users to view and create files in File Cabinet. The Time-Off Tracking SuiteApp requires access to files that are stored in File Cabinet.</td>
</tr>
</tbody>
</table>
## SuitePeople Permission Requirements

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Level</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit</td>
<td></td>
<td></td>
<td>Allows users to create, view, and edit files in File Cabinet. Users cannot delete files. The Time-Off Tracking SuiteApp requires access to files that are stored in File Cabinet.</td>
</tr>
<tr>
<td>Full</td>
<td></td>
<td></td>
<td>Allows users to create, view, edit, and delete files in File Cabinet. The Time-Off Tracking SuiteApp requires access to files that are stored in File Cabinet.</td>
</tr>
</tbody>
</table>

For more information about this feature, see Time-Off Management.

## Workforce Analytics Permission Requirements

If you have the Workforce Analytics feature enabled in your account, any standard roles that have the Workforce Analytics permission can use this feature. This permission is located on the Reports tab of the Role page. For a list of the standard roles assigned to this permission, see the help topic Standard Roles Permissions Table. You can create custom roles that include this permission. For more information, see the help topic Customizing or Creating NetSuite Roles.

The following table lists the permission level a user must have to perform certain tasks related to this feature.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Subtab</th>
<th>Permission Access Levels</th>
<th>Supported Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workforce Analytics</td>
<td>Permissions &gt; Reports</td>
<td>View</td>
<td>Allows users to access and view the headcount and turnover trends under Reports &gt; Employees/HR.</td>
</tr>
<tr>
<td>Employees</td>
<td>Permissions &gt; Lists</td>
<td>View</td>
<td>Allows users to view and search for headcount, hire, and turnover trends in your company. Users cannot create, edit or delete information.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Create</td>
<td>Allows users to create hire and termination details on the employee record. Users cannot edit or delete hire or termination details on the employee record.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
<td>Allows users to create, view, and edit hire and termination details on the employee record. Users cannot delete hire and termination details on the employee record.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Full</td>
<td>Allows users to create, view, edit, and delete hire and termination details on the employee record.</td>
</tr>
</tbody>
</table>

For more information about this feature, see Workforce Analytics.
Employee Information Management

- Adding an Employee Record
- Giving an Employee Access to NetSuite
- Assigning a Supervisor to an Employee
- Updating an Employee's Supervisor
- Viewing and Editing an Employee Record with Effective Dating
- Searching for Effective-Dated Changes to the Employee Record
- Viewing an Employee's Timeline
- Kudos
- Employee Locations
- Creating an Employee Template
- Working with Employee Social Security Numbers
- Printing Mailing Labels for Employees

Adding an Employee Record

Employee records enable you to maintain information about your employees including contact details, payroll, human resources data, and access permissions.

You can also grant an employee login access to your NetSuite account by entering an email address, password, and assigning a role.

For more information about adding an employee, see the following topics:

- Adding Information to the Subtabs
- Entering Communication Information on the Employee Record
- Entering Address Information for an Employee
- Human Resources Information for an Employee

Adding an employee

To add an employee:

1. Go to Lists > Employees > Employees > New.
2. To modify an employee record, go to Lists > Employees > Employees and click Edit next to the employee's name.

Note: If you have Editing enabled, you can edit employee records from the Employees list. Click the information you want to change and make your changes. These are automatically saved on the record.

Primary Information

To add Primary Information

1. If you use a custom form for employee records, select it from the Custom Form dropdown list.
To create a custom form for employee records, select **Customize Form** from the **Customize** list.

2. If you use templates to enter data for employees, select the template from the **Template** dropdown list.
   
   To set up employee record templates, go to Lists > Employees > Employees and click **New Template**. For more information, see Creating an Employee Template.

3. In the **Employee ID** field, enter the ID for this employee.

4. Enter a salutation for this employee.

5. Enter the employee's name.

6. Verify the employee's initials.
   
   The Initials field fills in automatically based on the name you entered in the **Name** field.

7. In the **Job Title** field, enter this employee's title.

8. In the **Supervisor** field, select the employee's supervisor.
   
   For more information, read Assigning a Supervisor to an Employee and Updating an Employee's Supervisor.

9. Verify the selected currency for the employee.
   
   The currency defaults to the base currency of the associated subsidiary or company. This currency must be used for transactions with this employee.

10. Enter any comments in the **Notes** field.

11. In the **Image** field, select a picture for this employee.
    
    Select **New** to upload an image to your NetSuite file cabinet.

### Email | Phone | Address

**To add Email | Phone | Address:**

1. Enter an email address for this employee.
2. Enter the employee's phone number.
3. Enter this employee's office, home, and mobile phone numbers.
4. Enter the employee's fax number.

For more information, see Entering Address Information for an Employee.

### Classification

**To add a Classification:**

1. **NetSuite OneWorld accounts:** Select the subsidiary to associate with this employee.
   
   You cannot enter transactions for this employee unless a subsidiary is assigned.

   If you select this employee on time transactions, the transaction is associated with this subsidiary.
   
   The employee is able to access only information associated with this subsidiary.

   After a transaction has posted for the employee, you cannot change the selected subsidiary on the employee record.

   You can grant an employee access to data for additional subsidiaries by customizing the **Subsidiaries** field for the employee's assigned role at Setup > Users/Roles > Manage Roles. See the help topic Control Employee Access to Subsidiaries.
2. If required, select a department to associate with this employee. Track departments, classes or locations, select the appropriate information for those fields.
3. If required, select a class to associate with this employee.
4. If required, select a location to associate with this employee. If you use the Payroll feature, a location must be selected for each employee that is paid using SuitePeople U.S. Payroll.
5. If you use billing classes, select one to associate with this employee.

Adding Information to the Subtabs

Maintaining information in subtabs allows employee information to be accurately recorded. Subtabs listed on this page may vary depending on the features enabled in your account. Subtabs can include the following:

⚠️ **Important:** After you have finished entering information on all areas of the record, click Save.

### Access

See Giving an Employee Access to NetSuite and Assigning Roles to an Employee.

### ACH/Direct Deposit

You can set up employees to be paid by direct deposit. For more information, see the help topic Setting Up Direct Deposit for an Employee.

ℹ️ **Note:** You can use NetSuite to pay only those employees who reside in the United States.

### Address

See Entering Address Information for an Employee.

### Affordable Care Act (ACA)

This subtab appears if you have the ACA SuiteApp installed. It contains information that you must enter to setup and track the benefits coverage for full-time employees. For more information, see Affordable Care Act (ACA) Reporting.

### Campaigns

This subtab lists all campaigns that have been sent to this employee's email address. It appears only if you use NetSuite or NetCRM and have the Marketing Automation feature enabled. For more information, see the help topic Managing Campaigns.

### Commission

Mark an employee as eligible for commission and select the method of paying commission. For more information, see the help topic Commission Preferences.
### Communication

This subtab lists all emails sent or received by this employee’s email. If you have the Mail Merge feature enabled, this subtab also lists letters, faxes, and PDF files sent by this person.

You can also send emails and attach messages received by this employee, send a letter, fax, or PDF to this employee through mail merge from this subtab.

For more information, see [Entering Communication Information on the Employee Record](#).

### Compensation Tracking

See [Recording Base Pay Compensation for an Employee](#).

### Human Resources

See [Human Resources Information for an Employee](#).

### Jurisdictions

Review the information on the **Jurisdictions** subtab and resolve any conflicts. This subtab appears only if you use NetSuite to pay your employees.

For details on jurisdictions, read the help topic [Payroll Setup for Employees](#).

### Payroll

If you use SuitePeople U.S. Payroll, this subtab is added to your employee records. It contains information that you must enter to use NetSuite to pay your employees.

For information, see the help topics [Payroll Setup for Employees](#) and [Payroll Setup](#).

**Note:** You can use NetSuite to pay only those employees who reside in the United States.

### Subscriptions

This subtab sets the global subscription status for this employee and view any subscriptions. For more information, see the help topic [Managing Subscriptions](#).

### System Information

This subtab shows the date that the record was created. You can mark the record **Inactive** to prevent it from showing in lists.

It also lists system-generated entered notes about this employee or employee record. Because a contact record is created for each employee, these notes also appear on the corresponding contact record. For more information, see the help topic [System Notes Overview](#).

To prevent specific user roles from viewing notes on contact records that refer to the employee record, ensure that the role has **Self Only** or **Self and Subordinates Only** selected in the **Employee Restrictions** field at Setup > Users/Roles > Manage Roles.
Time-Off

See Assigning a Time-Off Plan to an Employee.

Time Tracking

In the Time Approver field, select who approves the employee's time transactions. If no time approver is selected, then the employee's supervisor approves time entries. If both a supervisor and a time approver are selected, then only the time approver can approve time entries using their Employee Center role.

For more information, see Managing Time Tracking.

Entering Communication Information on the Employee Record

On the Communication subtab of employee records, view and enter information on the following additional subtabs.

1. Files — This subtab lists files that you want to associate with this employee. To add another file, select the file from the file cabinet, and click Attach. Select New if the file you want to attach has not yet been uploaded to the file cabinet.

2. User Notes — This subtab lists manually entered notes about this employee or employee record. Because a contact record is created for each employee, these notes also appear on the corresponding contact record.

   To prevent specific user roles from viewing notes on contact records that refer to the employee record, ensure that the role has Self Only or Self and Subordinates Only selected in the Employee Restrictions field at Setup > Users/Roles > Manage Roles.

3. Click Save.

Entering Address Information for an Employee

On the Address subtab of the employee record, you can enter multiple addresses for an employee. The address might be mandatory.

If you use SuitePeople U.S. Payroll, the home address you enter for an employee is used to calculate state and local taxes.

To enter an address for an employee:

1. Go to Lists > Employees > Employees.
2. Beside an employee name, click Edit.
3. On the employee record, click the Address subtab.
4. To indicate that this address is the default shipping address for the employee, check the Default Shipping box.
5. To indicate that this address is the employee's home address, check the Home box. If the employee has only one address, this box is checked by default. If you add other addresses for this employee, you can clear the Home box and check the box beside the home address.

   Note: Make sure that the Home box is checked for one address. The address that is marked as the home address can be used in customized employee reports.

6. In the Label field, enter a descriptive title to appear for this address in dropdown lists.
For example, you could enter a label of Home or Mailing Address.

7. To add or edit values for other address fields, click the pencil icon in the Edit column.

An address popup displays address fields.

Note: The following steps list the address fields included in the default address form. The address form shown for each employee may vary according to the country where the employee is located, and depends on the custom address forms defined in your account. For more information, see the help topic Customizing Address Forms.

a. Ensure the value for Country is correct.

Note: If you use SuitePeople U.S. Payroll to pay your employees, you can pay only employees who reside in the United States.

b. In the Attention field, enter the person at this address who should be notified of receipt of documents or goods.

The value you enter autofills on forms if this address is marked as default for Shipping or Billing.

c. In the Addressee field, enter the company name that should show on the shipping label.

This name appears under the name entered in the Attention field.

d. Enter a phone number for your employee.

This number appears on the Employee List report.

e. Enter the employee's street address.

If you enter the zip code first, city and state populate automatically.

f. By default, the information entered for the employee's address in the Attention, Addressee, Address 1, Address 2, City, State, Zip, and Country fields appears in read-only format in the Address free-form text box.

Note: To edit the read-only text, check the Override box.

g. Click OK.

8. To enter additional addresses, click Add.

9. Repeat steps 4-7 for each additional address.

10. Click Save.

Human Resources Information for an Employee

Entering Human Resources Information for an Employee

On the Human Resources subtab of the employee record, enter the employee's social security number, supervisor, hire date, and other information.

To enter Human Resources information for an employee:

1. Go to Lists > Employees > Employees.
2. Click Edit beside the employee's name.
3. Click the Human Resources subtab.
4. In the **Social Security** field, enter the employee's social security number. For information regarding social security number masking and encrypting, see [Working with Employee Social Security Numbers](#).

5. Enter this employee's birth date.

### Job Information

**Entering Job Information for an Employee**

1. From the **Type** dropdown list, select the type category that applies to this employee. For more information, see the help topic [Setting Up Employee Related Lists](#).
   
   ‘Types’ determine whether their data is included in employee-related key performance indicators.
   
   To create new **Types**, go to Setup > Accounting > Employee Related Lists > New.

2. Select the status of this employee's employment with your company.

   To create new selections for this field, go to Setup > Accounting > Employee Related Lists > New.

   For more information, see the help topic [Setting Up Employee Related Lists](#).

3. Enter a job description for this employee.

   **Note:** If you have the Effective Dating feature enabled in your account and are assigned to a role with the Employee Effective Dating permission you can see historical changes to an employee's status and type on their timeline. For details, see [Viewing an Employee's Timeline](#).

### Job Information for Sales Reps

**Entering Job Information for Sales Reps**

1. For sales reps, choose one of the following:
   - If you do not use **Team Selling**, check the **Sales Rep** box to assign sales territories to the employee or select them in the **Sales Rep** field on customer records and sales transactions.
   - If you do use **Team Selling**, select a field in **Sales Role** if the employee is a part of sales teams.
     
     For more information, see the help topic [Team Selling](#).
   - When an employee has the **Sales Rep** box checked or a **Sales Role** is selected on this subtab, NetSuite creates a customer record and that employee is selected as the default sales rep.

2. Check the **Support Rep** box if you want to assign cases or territories to the employee.

3. Check the **Project Resource** box to assign the employee to manage projects and project tasks.

   If the employee is a project resource, it is possible to check the **Project Manager** field if you want to designate a project manager to an employee.

   If the employee is a project resource, select a role in the **Default Projects Resource Role** field.

   When the employee is assigned to a project, the selected role is automatically assigned.

4. When an employee is marked as a Project Resource, the **Target Utilization** field is available.

5. Select a work calendar for the employee.

6. In the **Labor Cost** field, enter the hourly overhead labor cost rate for this employee to calculate project costs and profitability.

7. In the **Hire Date** field, enter the date the employee was hired.

8. In the **Last Review Date** field, enter the date of the employee's last review.
9. In the **Next Review Date** field, enter the date of the employee's next review.
10. In the **Termination/Release Date** field, enter the person's last date of employment.

**Supervisor Change Hist.**

1. This subtab shows system notes about changes to the employee's supervisor. For more information, see [Updating an Employee's Supervisor](#).

**Work Status**

1. Select the Employee's resident status.
   - This information is located in Section 1 of the employee's completed I-9 form.
   - To create new selections for this field, go to Setup > Accounting > Employee Related Lists > New.
2. Select the employee's **Visa Type**.
   - To create new selections for this field, go to Setup > Accounting > Employee Related Lists > New.
3. Enter the Visa's expiration date.
4. Enter the **Alien Number**.
   - This information is located in Section 1 of the employee's completed I-9 form.
   - This step is required only if the employee's work status is **Alien authorized to work**.
5. Enter the date through which the employee is authorized to work.
   - This information is located in Section 1 of the employee's completed I-9 form.
   - This step is required only if the employee's work status is **Alien authorized to work**.
6. On the **Work Status** subtab, check **I-9 Verified** if the employee has completed an I-9 form.

**Expense and Purchasing**

**Entering Expense and Purchasing Information**

1. In the **Expense Limit** field, enter the amount the employee can expense without approval.
   - This field defaults to $0, which requires all expenses to be approved.
2. In the **Expense Approver** field, select the person that approves the employee's expense reports.
   - If no approver is selected, the supervisor approves expense reports. If a supervisor and an expense approver are selected, either can approve expense reports. For more information on approvers and approval limits, see the help topic [Approval Routing](#).
3. In the **Expense Approval Limit** field, enter the maximum amount an employee is allowed to approve on an expense report when specified as an approver.
4. In the **Purchase Limit** field, enter the amount the employee can purchase without approval.
   - This field defaults to $0, which requires all purchases to be approved.
5. In the **Purchase Approver** field, select the person that approves the employee's purchase requests.
   - If no approver is selected, the supervisor approves purchase requests. If both a supervisor and a purchase approver are selected, either can approve the purchase request.
6. In the **Purchase Approval Limit** field, enter the maximum amount an employee can approve on a purchase request when specified as an approver.
7. In the **Account** field, enter this employee’s account number if needed.

**Subordinates**

**Entering Subordinate Information**

1. If this employee is a supervisor, a list of subordinates is shown on the **Subordinates** subtab.
   - In the **View** field, select a custom list view to apply to the list shown on this subtab.
   - Click **Customize View** if you want to create a new list view for the list shown on this subtab.
   - Click **Edit** next to the name of a subordinate to edit their employee record.

**Personal**

**Entering Personal Information**

1. Select the employee's marital status.
   To create new selections for this field, go to Setup > Accounting > Employee Related Lists > New.
2. Select the employee's ethnicity.
   To create new selections for this field, go to Setup > Accounting > Employee Related Lists > New.
3. On the **Personal** subtab, select the employee's gender.
4. Use the following information to enter or verify information on the additional subtabs on the **Human Resources** subtab.
   After you have entered all necessary information, click **Save**.

**Emergency Contacts**

**Entering Emergency Contacts**

1. Enter the name of the employee's emergency contact.
2. Enter the relationship between the contact and employee.
3. Enter the address of the emergency contact.
4. Enter the phone number for the emergency contact.
5. Click **Add/Edit**.

**Education**

**Entering Education Information**

1. On the **Education** subtab, select the employee's level of education.
   To create new selections for this field, go to Setup > Accounting > Employee Related Lists > New.
2. Enter the **Degree** received.
3. Enter the date the degree was conferred.
4. Click **Add/Edit**.
Giving an Employee Access to NetSuite

To give an employee access to your NetSuite account, you must ensure the employee record includes an email address, which serves as the user ID, and then complete the necessary information on the Access tab of the employee record. This setup includes the following:

- Enabling the Give Access option
- Assigning roles and/or permissions

**Note:** If you have the Effective Dating feature enabled, the Give Access box and the Email address field on the employee record are not effective-dated. If you grant access to an employee or change the employee's email address, as part of an effective-dated change, those two changes are immediate.

**Note:** When the Advanced Employee Permissions feature is enabled, the Employee Access permission must be assigned to a role to give access and assign roles to employees. For more information, see Employee System Access Permission Overview.

To secure the user login process:

- Two-Factor Authentication is the preferred alternative to restricting access by IP Address. See the help topic Two-Factor Authentication (2FA).
- If the IP Address Rules feature is enabled in your account, you also can set up IP address restrictions to limit where employees can log in to NetSuite. For information about setting IP address rules, see the help topic Enabling and Creating IP Address Rules.

**Note:** Only active users with access count against the Full User Count purchased for your account. Inactive users that have access do not count. For details about making users inactive, see Inactivating Employee Records.

Give NetSuite Access to an Employee

As of 2018.2, you should follow this procedure and let employees set up a NetSuite password for themselves. However, if you prefer to assign passwords yourself, see Assign an Employee Password Manually instead.

**To give an existing employee access to NetSuite:**

1. Go to Lists > Employees > Employees.
2. Click Edit next to the name of the employee for whom you want to set up access.
3. Under Email | Phone | Address, enter the employee's email address.
   - The email address is required for login.
4. Click the Access tab.
5. Check the Give Access box.
6. Check the Send New Access Notification Email box to inform the user how to access your NetSuite account. The standard user access notification includes the email address to use for logging in to NetSuite, and also contains a URL so that the user can set up a NetSuite password.
7. On the Roles subtab, assign one or more roles to this employee.
   - Each role includes a set of associated permissions that determine the data assigned users can see and the tasks they can perform. For more information, see Assigning Roles to an Employee.
8. If the Global Permissions feature has been enabled on the Employees subtab at Setup > Company > Enable Features, a Global Permissions subtab is available where you can assign permissions directly on the employee record.

These permissions apply for all of the employee's assigned roles. For more information, see the help topic Using the Global Permissions Feature.

9. Click Save.

Assign an Employee Password Manually

You should use the procedure in Give NetSuite Access to an Employee that lets users set up a NetSuite password for themselves. However, if you prefer to assign a user's password yourself, use the following procedure.

**To give an employee access to NetSuite and assign a password:**

1. Go to Lists > Employees > Employees.
2. Click Edit next to the name of the employee for whom you want to set up access.
3. Under Email|Phone|Address, enter the employee's email address.
   The email address is required for login.
4. Click the Access tab.
5. Check the Give Access box.
6. Do not check the Send New Access Notification Email box.
7. Check the Manually Assign or Change Password box.
8. Enter a password for the employee. As you type, the characters are validated against the password policy criteria, and the results displayed.

   **Note:** For employees who can view unencrypted credit card numbers, the password must be at least 10 characters or the minimum length required for your account, whichever is greater. This is required to comply with Payment Card Industry (PCI) Data Security Standard. If you need more information, see the help topic NetSuite Password Requirements.

9. In the Confirm Password field, re-enter the password.
10. Check the Require Password Change on Next Login box to require this employee to change their password on their next login to NetSuite.

    When the employee next logs in, the Change Password page appears and the user cannot access other NetSuite pages until a new password is created and saved.
    Requiring this action protects your account from unauthorized access using generic passwords and prepares your account for an audit.

    **Important:** The Require Password Change on Next Login box never appears as checked. When you check this box and save the record, an internal flag is set. When the password change occurs, the flag is cleared. If you later check the box again and resave the record, the internal flag is reset to require another password change.

11. When you have finished entering information, click Save.
12. Next, tell your user the appropriate login page to go to, the email address to use for login, and the password you assigned. For security reasons, do not send the password by email.

    For details, see the help topic Types of Login Pages for Your NetSuite Account.
Assigning Roles to an Employee

You must assign one or more roles to each employee to whom you want to provide access to NetSuite. Each role is a set of associated permissions that determine the data assigned users can see and the tasks they can perform.

You assign roles to an employee on the Roles subtab of the Employee record’s Access tab.

**Note:** If you have the Effective Dating feature enabled, the Role field is not effective-dated. If you change an employee’s role settings, as part of an effective-dated change, this change is immediate.

- For general information about roles and NetSuite access, see the help topic NetSuite Access Overview.
- NetSuite provides many standard roles with predefined permissions. To view a list of the standard roles and permissions, click Standard Roles Permissions Table.
- You can customize the standard roles to fit the unique needs of your business. To learn how to customize a role, see the help topic Customizing or Creating NetSuite Roles.
- If the Global Permissions feature is enabled, in addition to assigning roles to employees, you can assign permissions directly on each employee record. Please note that usage of the Global Permissions feature is not recommended. For more information, see the help topic Using the Global Permissions Feature.
- You can restrict employee access to data by location. For information, see Employee Locations.
- For information regarding employee roles and social security data, read Working with Employee Social Security Numbers.

Employees can have multiple roles in your company.

**To assign one or more roles to an employee:**

1. Go to Lists > Employees > Employees.
2. Click **Edit** next to the name of the employee you want to assign a role to.
3. Under Email | Phone | Address, enter an email address in the **Email** field if one has not been entered already.
4. Click the Access subtab.
5. Complete the necessary access-related fields, if you have not already.
   For details, see Giving an Employee Access to NetSuite.
6. In the **Role** field, select a role for this employee.
7. Click **Add**.
8. Repeat steps 6-7 for any other roles you want to assign to this employee.
9. Click **Save**.

Your employee now has a role and can access your NetSuite account. When the employee logs in, the employee sees only the links that the role gives permission to see.

If you need to remove a role for an employee, open the record, click the name of the role on the Access tab. Click **Remove**, and then click **Save**.

**Note:** To see a list of all the users assigned to a particular role, go to , and select the role from the Role dropdown list. You can also run an employee search to find out which roles have been assigned to employees. For more information, see the help topic Running Searches.

To see a list of
Assigning a Supervisor to an Employee

In NetSuite, supervisors can approve the following for their supervised employees:

- Expense reports, if no expense approver is assigned
- Purchase orders, if no purchase approver is assigned
- Time-off requests, if the Time-Off Management feature is enabled

If you enable the Employee Change Requests feature, supervisors can create employee change requests for their supervised employees. For more information, see Employee Change Requests.

For someone to be considered a supervisor in NetSuite, that person must be selected as the supervisor of another employee on that employee's record. The supervisor then receives an email when one of his employees enters a new time-off request, a new expense report, or a new purchase request that needs approval. For more information, see Approving or Rejecting Time-Off Requests and Approval Routing.

To assign supervisors on employee records:

1. Create employee records for your supervisors at Lists > Employees > Employees > New. After you have added employee records for all of your supervisors, select the supervisors' names on the other employee records you need to add.

2. If you have already set up employee records and want to assign supervisors, go to Lists > Employees > Employees. Click Edit next to the name of the person to whom you want to assign a supervisor.

3. Under Primary Information, in the Supervisor field, select the employee that supervises the employee whose record you are creating.

4. When you have finished editing the employee's record, click Save.

Updating an Employee's Supervisor

When a supervisory change is being made, an employee may transfer from one supervisor to another earlier or later than the date on which that employee's record is updated. To accurately maintain records, employee records must be able to reflect an effective date for supervisory changes. For example, to calculate commissions correctly after a supervisory change, the effective date of the change can be edited to a future or past date, providing more accurate commission calculations for manager schedules.

Jack, a sales rep, began reporting to his new supervisor, Mary, on April 1st. The Human Resources department is not notified of the change until April 15th, and the employee record is updated on that date. Unless the effective date of the supervisory change is modified, Mary's commissions related to Jack for the first part of April are understated and are incorrectly credited to Jack's former supervisor, Jim. Jack's employee record can be updated to reflect the correct effective date of April 1st, even after that date has passed. After a commission recalculation is performed, the commission based on the activity from April 1 to April 15 is credited to Mary.

Note: A change to a supervisor effective date does not cause a commission recalculation, which may be necessary to correct the commission amount.

Supervisor changes are entered on the Human Resources subtab of employee records.

Existing expense or time approvals already queued remain in the same supervisor's queue, despite effective date changes. New approvals, however, are routed to the new manager.
To update a supervisor assignment:

1. Go to Lists > Employees > Employees.
2. Click **Edit** next to the employee.
3. Under Primary Information, in the **Supervisor** field, select the supervisor’s name.
4. Click **Save**.

After a new supervisor is selected and the record is saved, the change is recorded on the Human Resources subtab under the Supervisor Change Hist. subtab, in addition to the system date on which the field was changed.

On the Supervisor Change Hist. subtab, click **Edit** on a change line to do the following:

- Modify the effective date when an employee reports to a supervisor to a later or earlier date
- Modify the supervisor assignment

In the Valid Range field, limitations to changes are governed by the reporting relationships of an employee’s superior and subordinates.

For example, employees may have the following hierarchy:

- President
- Vice President
  - effective reporting date: 5/1/13
  - cannot change date after 10/1/13
- Manager
  - effective reporting date: 10/1/13
  - cannot change date before 5/1 or after 2/1
- Sales Rep
  - effective reporting date: 2/1/14
  - cannot change date to before 10/1

The manager, who reported to the Vice President on 10/1/13, could have an effective date change between 5/1/13 or 2/1/14.

You have more flexibility, however, if you change the dates of the superior or subordinates. For example, if you change the reporting date of the manager to the Vice President from 10/1 to 5/1, the Rep’s Valid Range for date changes becomes from 5/1 through any date.

### Viewing and Editing an Employee Record with Effective Dating

The Effective Dating feature enables you to make changes to the employee record that are back-dated or future-dated to a specific date. These changes represent when a particular piece of information became effective or true, regardless of when you made the change. To use the Effective Dating feature, you must...
be logged into NetSuite using a role that has the Employee Effective Dating permission. By default, this
permission is automatically assigned to the standard Administrator, Chief People Officer (CPO), and HR
Generalist roles. This permission also gives you access to the employee timeline from the employee
record. For details, see Viewing an Employee's Timeline.

Many fields on the employee record are supported by effective dating, but others are not. When you view
an employee record, fields that are not supported are labeled Not Effective-Dated. For more information,
see Effective Dating for Employee Information.

View the Using Effective Dating with the Employee Record video.

Viewing an Employee’s Record as of a Date

If you are using the Effective Dating feature, you can view many of the fields on an employee's record as
of a specified date.

To view an employee record as of a date:

1. Go to List > Employees > Employees.
2. Click View next to the name of the appropriate employee.
3. On the employee record page, from the Actions list, select View As Of Date.
4. In the Select Effective Date Information window, enter or select a date and click OK.

The employee record page is refreshed showing the Viewing As Of banner to indicate that you are
viewing an effective-dated view of the employee record. Note that the fields that are not effective-
dated are labeled.

Note: You can also click the Effective Date Log subtab to view all effective-dated changes
made to the employee's record. Use the Field and Change Reason filters to find specific
changes.

Note: If you use CSV import or the Mass Updates functionality to edit multiple employee records,
the changes affect the current day version of the employee records. You cannot use these features
to make past-dated or future-dated changes to employee records. For more information, see the
help topics Employees Import Type and Mass Changes or Updates.

Editing an Employee's Record as of a Date

If you are using the Effective Dating feature, you can edit many of the fields on an employee's record as
of a specified date. This allows you to back-date a change to employee information and specify when a
particular piece of information was valid or true.

To edit an employee record as of a date:

1. Go to List > Employees > Employees.
2. Click Edit next to the name of the appropriate employee. You can also click Edit from a view of an
employee record.
3. In the Select Effective Date Information window, enter or select the date as of which you would like
to edit the employee record.
4. Select a change reason from the Change Reason dropdown list. Optionally, enter details of the
change to further describe it. Click OK.
The employee record page appears showing the Editing As Of banner to indicate that you are editing an effective-dated view of the employee record. Note that the fields that are not effective-dated are labeled.

5. Make the required changes to the employee record.

6. Click **Save**. The changes you made will appear in the **Effective Date Log** subtab.

### Searching for Effective-Dated Changes to the Employee Record

**Important:** This feature requires SuitePeople HR. For more information, see [SuitePeople Overview](#).

After you have used the Effective Dating feature to make back- or future-dated changes to employee information, you can use the NetSuite search features to determine when particular aspects of the employee record were true or valid. You use the Valid Date option on the Employee Change Search page to do this.

*View the Using Effective Dating with the Employee Record video.*

**To search for effective-dated changes to the employee record:**

1. Go to Reports > New Search.
2. Click **Employee Change**.
3. On the Employee Change Search page, under **Valid Date**, specify the date or date range that you want to search.
4. Specify any other search parameters you want to include. For example, you can look for employees who have effective-dated changes with a particular change reason by selecting one or more reason from the **Change Reason** list.
5. Click **Submit**.

The Employee Change Search: Results page shows the results of your search.

**Note:** You can also search for effective-dated changes for a specific employee by going to Lists > Employees > Employees and clicking **View** next to the name of the employee. Click the **Effective Date Log** subtab to view all effective-dated changes made to the employee’s record. Use the **Field** and **Change Reason** filters to find specific changes.

### Viewing an Employee’s Timeline

If you are using the Effective Dating feature, and you are logged into NetSuite using a role that has the Employee Effective Dating permission you can view the employee timeline from the employee record. The employee timeline displays an employee’s key milestones and career changes in chronological order.

**Note:** Users assigned to a role that does not have the Employee Effective Dating permission can still navigate to the employee timeline, however, they will see only hire date and termination date.

**To view an employee’s timeline:**

1. Go to Lists > Employees > Employees.
2. Beside an employee, click **View**.
3. From the **Actions** list, select **View Timeline**.
4. The employee timeline displays changes to the following information:
   - employee name
   - hire date*
   - termination date*
   - employee status changes
   - employee type changes
   - job title
   - compensation (type, currency, and base wage)
   - the name of the person who modified the information

When viewing an employee's timeline, the hire date and termination date are always shown as of the current date, even when you are viewing the employee record as of a specified date.

**Kudos**

The Kudos feature enables your employees to give social-based recognition to each other for accomplishments, achievements, and milestones. When they give Kudos to a coworker, they include a short message explaining the recognition and optionally indicate any of the organizational values at your company that the employee's actions support. These Kudos then appear in a newsfeed portlet on the Employee Center, where other employees can indicate support. Kudos can be filtered by department and location.

When you first enable the Kudos feature, NetSuite provides you with a list of sample organizational values. You can use these as they are, delete or edit ones that you want to repurpose, or create new ones that match your organizational culture.

For more information about Kudos, see the following topics:

- Renaming Kudos
- Managing Kudos
- Working with Kudos in Employee Center

**Renaming Kudos**

Kudos are used to recognize coworkers for a job well done. They are given to someone for making an outstanding contribution, providing a great idea, or for helping out on a project. If required, Kudos can be renamed in your NetSuite account to better match your company culture.

**Prerequisites**

To rename Kudos, the Kudos feature must be enabled in your account and you must be assigned to a role that includes the Kudos permission.

To rename Kudos:

1. Go to Setup > Company > Rename Records/Transactions.
2. On the Rename Records/Transactions page, the default names for records are autofilled in the fields.
3. In the Name For Kudos field, enter the name you want to use.
4. Click Save.

Managing Kudos

The Kudos feature enables your employees to give social-based recognition to each other for accomplishments, achievements, and milestones. When they give Kudos to a coworker, they include a short message explaining the recognition and optionally indicate any of the organizational values at your company that the employee's actions support. These Kudos then appear in a newsfeed portlet on the Employee Center, where other employees can indicate support. Kudos can be filtered by department and location.

When you first enable the Kudos feature, NetSuite provides you with a list of sample organizational values. You can use these as they are, delete or edit ones that you want to repurpose, or create new ones that match your organizational culture.

Roles and Permissions

For details about the permission requirements for Kudos, see Kudos Permission Requirements.

Managing Organizational Values

When you first enable the Kudos feature, NetSuite provides you with a list of sample organizational values. You can use these as they are, delete or edit ones that you want to repurpose, or create new ones that match your organizational culture.

**To manage organizational values:**

1. Go to Setup > Performance Management > Organization Values. The Organization Values list page shows the values that employees can assign to Kudos.
2. To add a new organization value, click New Organization Value.
3. Enter a unique name for the value in the Name field.
4. Optionally, enter a description of what the value means in the Description field.
5. Optionally, select an image to show with the value from Image dropdown list.
6. Click Save.

Giving Kudos to Employees

Most employees within your organization will give Kudos to their coworkers using the Kudos portlet in their Employee Center role. However, if you are an Administrator, an HR Generalist, or a Chief People Officer, you can give Kudos, view Kudos, and delete Kudos that have been given from a list page.

**To give Kudos to an employee through list page:**

1. Go to Setup > Performance Management > Kudos. The Kudos list page shows all Kudos that have been given in your organization.
2. To add a new Kudos, click New Kudos.
3. On the Kudos page, begin typing an employee’s name in the **Recipients** field. As you type, suggested names appear that match what you have typed. If you want to give Kudos to more than one employee at once, then keep adding names.

4. In the **Description** field, type a description for the Kudos that explains why you want to recognize your coworker(s).

5. In the **Organization Values** list, click one or more organizational values that this Kudos demonstrates.

6. Click **Save**.

**Implications of Deleting Employees**

When an employee leaves your company, you would usually inactivate or terminate them, but not delete their employee record. If you decide to delete an employee record from your NetSuite account, this has the following effects on Kudos:

- If the employee was the only recipient of any Kudos, those Kudos are deleted from the system.
- If the employee was one of several recipients of Kudos, their name is removed from the Kudos, but the Kudos is not deleted.
- If the employee gave Kudos to coworkers, you cannot delete their employee record until you delete all of those Kudos.

**Giving Kudos to Coworkers using Employee Center**

You use Kudos to recognize your coworkers for a job well done. You could give Kudos to someone for making an outstanding contribution, providing a great idea, or giving you help on a project. You can give Kudos to more than one coworker. You describe why you are giving them Kudos, and then choose some organizational values that your coworker demonstrated. To give Kudos, you must be using your Employee Center role.

**To give Kudos to coworkers:**

1. From the Employee Center, in the Kudos portlet, click in the **Give Kudos to...** box. If your Kudos portlet is in the narrow configuration, click **Give Kudos**.
2. Begin typing a coworker’s name. As you type, suggested names appear that match what you have typed.
3. If you want to give Kudos to more than one coworker at once, then keep adding names.
4. In the text field, type a description for the Kudos that explains why you want to recognize your coworker(s).
5. Under Supported Values, click one or more organizational values that this Kudos demonstrates. When you hover over a values icon, a description of that value appears.
6. Click **Give Kudos**.

Your kudos appears in the Kudos portlet.

**Working with Kudos in Employee Center**

The Kudos portlet shows a newsfeed-style display of the Kudos that have been given in your company. Here are some ways you can interact with the Kudos feed:

- To show support for a Kudos that someone else has given, click the Support button beside the Kudos. The button shows how many people have shown their support for the Kudos.
By default, the Kudos portlet shows Kudos given across your entire company. To filter the Kudos to just one department, click the Dropdown button beside My Company and select a department.

To search for a person's name or a word or phrase in Kudos descriptions, enter a term in the search field and click the Search button.

Employee Locations

Associating an Employee with a Location

You can associate employees with a specific location to ensure that employees have access to only the information associated with that location. For example, you can restrict access for warehouse personnel who handle item receipts or fulfillments at a single location. You can also refine employee reports and searches by location.

**To associate an employee with a location:**

1. Go to Lists > Employees > Employees.
2. Click Edit next to the employee to whom you want to assign a location.
3. Under Classification in the Location field, select the location of this employee.
   For more information, read the help topic Creating Locations.
4. Click Save.

To search for employee records based on location, go to Lists > Employees > Employees > Search. In the Location field, choose the company location whose employee records you want to access, and click Submit. A list of employee records for that location appears.

Restricting Employee Access by Location

**To restrict employee access by location:**

1. Go to Setup > Users/Roles > User Management > Manage Roles.
2. Click Customize next to the role you would like to restrict.
3. Click the Restrictions subtab.
4. Click the blank line in the list and select Location from the Segment column.
5. From the Restrictions column, choose a level of access for the location field on transactions and records.
6. In the Location Restrictions field, choose a level of access for the location field on transactions and records.
   - **None - default to own** - There is no restriction on what can be selected and the default selection is the location set on the user's record.
     All transactions and records are accessible.
   - **Own, subordinate, and unassigned** - Users can select their own location, sublocations of their location, locations and sublocations of their subordinates, or leave the Location field blank.
     Users can access only those transactions and records with one of these selections in the location field.
- **Own and subordinates only** - Users can select only their location and sublocations of their location, or locations and sublocations of their subordinates in the Location field. Users can access only those transactions and records with their location or sublocations selected in the Location field.

7. Check the Allow Viewing box to allow users logged in with this role to see, but not edit, data for employees to which the role does not have access.

**Important:** This setting does not allow viewing of employee payroll or commissions data. Also, users cannot view non-subordinate employee records other than their own record when the Restrictions column is set to own and subordinates only.

8. Check the Apply to Items box to apply the department restrictions defined here to item records, in addition to transaction, employee, or partner records.

9. Click Save.

### Creating an Employee Template

You can create a template for employee records to speed up the process of adding employees to NetSuite.

On the template record, you select default values for fields on the employee record. When creating an employee record, you select your template, and the default values automatically fill in the employee record. For example, you can create a template for customer support reps that are paid hourly. On the template, you select your support department and class, the location of this support team, payroll earnings, withholdings, and deductions, and designate the employee as a support rep.

When you go to Lists > Employees > Employees > New to add a support rep employee, you can select your template to fill in all the appropriate information. All you must do is enter the employee’s name and contact information and set up access to NetSuite, if necessary.

#### To create an employee template:

1. Go to Lists > Employees > Employees.
2. In the Employees list, click New Template.
3. In the Employee ID Template field, enter a name for this template. You will select this name in the Template field when creating new employee records.
4. Under Classifications, you can:
   - Select a default department, class, and location for employees. Click the plus sign next to any of these fields to create a new department, class, or location.
   - If you use NetSuite OneWorld, you can select a default subsidiary for employees.
   - If the Project Management feature has been enabled, you can select a default billing class for employees. An employee’s billing class sets the rate billed for that employee’s time.
5. On the Human Resources subtab, you can define defaults for the following:
   - **Type** - Select an employee type from those defined at Setup > Accounting > Employee Related Lists.
   - **Sales Role** - If this template is for sales reps, select a sales role from those defined at Setup > Sales > CRM Lists. If you select from this field, sales territories can be assigned to employees whose records are entered with this template. These employees can be selected in the Sales Rep field on customer records.
Creating an Employee Template

■ **Support Rep** - If this template is for support reps, check this box. If you check this box, case territories can be assigned to employees whose records are entered with this template. These employees can be selected in the **Assigned To** field on case records.

6. On the **Payroll** subtab, you can define defaults for the following:

■ **Include in Payroll** - whether or not employees created with this template are included in SuitePeople U.S. Payroll

■ **Compensation Type** - Wage or Salary

■ **Pay Frequency** - how often employees created with this template are paid

■ **Workplace** - select an existing workplace or click the plus sign to create a new one

■ Payroll items to be used for taxes, earnings, deductions, contributions, accrued time, and any or all combinations

  □ For steps on setting up deductions, see the help topic Setting Up Deductions for an Employee.

  □ For steps on setting up company contributions, see the help topic Setting Up Company Contributions for an Employee.

  □ For steps on setting up accrued time such as vacation and sick time, see the help topic Setting Up Accrued Time for an Employee.

  □ You can create new payroll items of any of these types at Lists > Employees > Payroll Items > New.

7. Click **Save** to make your template available on employee records.

---

Working with Employee Social Security Numbers

**Warning:** If you are running scripts as an administrator that has access to employee records, be aware that these scripts may expose social security numbers to any user. For example, a user that it assigned to a role that has permission to run and deploy scripts, but does not have permission to view the employee record will still be able to view social security numbers when they attempt to access parts of the employee record. To prevent unintended access to this information, only run your script using an appropriate role that masks social security numbers.

Social security numbers are masked and encrypted by default when displayed on the screen or when records or transactions are printed. Only administrators or users with permission to access social security number data can view the numbers unmasked.

Users permission to access social security number data is based on the level of the Employee Social Security Numbers permission that is associated with their assigned roles. This permission can be at one of the following two levels:

■ **Masked** – Social security numbers appear in masked form such as (********** or ***********). If 11 characters are displayed, it indicates that hyphens were used when the social security number was entered.

■ **Full** – The complete social security numbers is displayed such as (123-11-1234).

Users assigned standard roles can access social security number data as follows:

<table>
<thead>
<tr>
<th>Role</th>
<th>Permission Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator</td>
<td>Full</td>
</tr>
</tbody>
</table>
Working with Employee Social Security Numbers

<table>
<thead>
<tr>
<th>Role</th>
<th>Permission Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Center</td>
<td>Masked</td>
</tr>
<tr>
<td>Payroll Manager</td>
<td>Full</td>
</tr>
<tr>
<td>Payroll Setup</td>
<td>Full</td>
</tr>
<tr>
<td>System Administrator</td>
<td>Full</td>
</tr>
</tbody>
</table>

Social security number data is masked or displayed based on role access level when a user does any of the following:

- Views the employee list
- Views or edits HTML or PDF formats of forms
- Views reports
- Customizes reports
- Saves or views saved reports

Printing Mailing Labels for Employees

You can print mailing or shipping labels for employees without using mail merge or data export. For more information on printing mailing labels, see the help topic Printing Mailing and Shipping Labels.

To print mailing or shipping labels, go to Transactions > Management > Print Checks and Forms. Click the Mailing Labels link.
Effective Dating for Employee Information

The Effective Dating feature enables you to make changes to the employee record that are back-dated or future-dated to a specific date. These changes represent when a particular piece of information became effective or true, regardless of when you made the change. To use the effective dating feature, you must be logged into NetSuite as an Administrator, a Chief People Officer (CPO), or an HR Generalist.

When you make an effective-dated change, you specify a change reason to document why the change was made. This enables you to track and distinguish changes by reason. When you enable the Effective Dating feature, several default change reasons become available, but you can create new ones that match your company's policies.

View the Using Effective Dating with the Employee Record video

View the Managing Employee Change Reasons for Effective Dating video

For more information about this feature, see these topics:
- Using Effective Dating with the Employee Record
- Managing Employee Change Reasons
- Searching for Effective-Dated Changes to the Employee Record
- Using Effective Dating with Other NetSuite Features
- Using Effective Dating with Employee Workflows and SuiteScripts

Using Effective Dating with the Employee Record

The SuitePeople Effective Dating feature enables you to make changes to the employee record that are effective as of a past, current, or future date. These changes represent when a particular piece of information became effective or true, regardless of when you made the change. To use the Effective Dating feature, you must be logged into NetSuite using a role that has the Employee Effective Dating permission. By default, this permission is automatically assigned to the standard Administrator, Chief People Officer (CPO), and HR Generalist roles. This permission also gives you access to the employee timeline from the employee record. For details, see Viewing an Employee's Timeline.

View the Using Effective Dating with the Employee Record video

With the Effective Dating feature enabled, you can view, edit, and search for effective-dated changes. For more information, see Viewing an Employee's Record as of a Date, Editing an Employee's Record as of a Date, and Searching for Effective-Dated Changes to the Employee Record.

Many fields on the employee record are supported by effective dating, but others are not. When you view an employee record, fields that are not supported are labeled Not Effective-Dated.

Important: If you decide to disable this feature after using it to make effective-dated changes to employee records, any back-dated or future-dated changes you make will be lost and only the current state of the employee records will be kept.

Note: Inline editing is disabled when the Effective Dating feature is enabled.

Roles and Permissions

For details about the permission requirements for effective dating, see Effective Dating Permission Requirements.
Viewing an Employee's Record as of a Date

If you are using the Effective Dating feature, you can view many of the fields on an employee's record as of a specified date.

To view an employee record as of a date:

1. Go to Lists > Employees > Employees.
2. Click View next to the name of the appropriate employee.
3. On the employee record page, under Actions, click View As Of Date.
4. In the Select Effective Date Information window, enter or select a date and click OK.

The employee record page is refreshed showing the Viewing As Of banner to indicate that you are viewing an effective-dated view of the employee record. Note that the fields that are not effective-dated are labeled.

Note: You can also click the Effective Date Log subtab to view all effective-dated changes made to the employee's record. Use the Field and Change Reason filters to find specific changes.

Editing an Employee's Record as of a Date

If you are using the Effective Dating feature, you can edit many of the fields on an employee's record as of a specified date. This allows you to back-date a change to employee information and specify when a particular piece of information was valid or true.

To edit an employee record as of a date:

1. Go to Lists > Employees > Employees.
2. Click Edit next to the name of the appropriate employee. You can also click Edit from a view of an employee record.
3. In the Select Effective Date Information window, enter or select the date as of which you would like to edit the employee record.
4. Select a change reason from the Change Reason dropdown list. Optionally, enter details of the change to further describe it. Click OK.

The employee record page appears showing the Editing As Of banner to indicate that you are editing an effective-dated view of the employee record. Note that the fields that are not effective-dated are labeled.

5. Make the required changes to the employee record.
6. Click Save. The changes you made will appear in the Effective Date Log subtab.
7. If there are any conflicts between the changes you want to make and previously made effective-dated changes, they appear in the Field Conflicts Found window. To resolve the conflicts, do the following:
   1. To keep a previously created change, click Keep beside the change.
   2. To reject a previously created change, click Override beside the change.
   3. When you are finished resolving the conflicts, click Confirm.
Managing Employee Change Reasons

If you have the Effective Dating feature enabled, you must specify an employee change reason when you make an effective-dated change to an employee record. Several default change reasons are provided when the feature is enabled. You can edit or delete these, and create your own.

View the Managing Employee Change Reasons for Effective Dating video

**Note:** You cannot delete an employee change reason that has been used to make an effective-dated change. If you no longer want to use a particular employee change reason, you can make it inactive. This causes it to not be available when an effective-dated change is made.

If you enable the Employee Change Requests feature, you cannot delete an employee change reason that is linked to an employee change request type.

Creating Employee Change Reasons

**To create an employee change reason:**

1. Go to Setup > HR Information System > Employee Change Reasons.
2. Click **New Employee Change Reason**.
3. On the Employee Change Reason page, enter a **Name** and **Description** for the reason.
4. Click **Save**.

Editing or Inactivating Employee Change Reasons

**To edit or inactivate an employee change reason:**

1. Go to Setup > HR Information System > Employee Change Reasons.
2. Click **Edit** next to the change reason you want to edit.
3. On the Employee Change Reason page, enter a **Name** and **Description** for the reason.
4. To inactivate the change reason so that it is no longer available to select when editing an employee record, check the **Inactive** box.
5. Click **Save**.

Searching for Employee Change Reasons

**To search for employee change reasons:**

1. Go to Reports > New Search
2. Click **Employee Change Reason**.
3. Specify any search parameters you want to include.
4. Click **Submit**.

The Employee Change Reasons Search: Results page shows the results of your search.
Using Effective Dating with Other NetSuite Features

When the Effective Dating feature is enabled, some limits to NetSuite functionality exist.

Overriding Future Changes

Any effective-dated change, whether past, present, or future, overrides any future-dated changes relative to the change being made.

Impact of Effective Dating on Employee Workflows and SuiteScripts

With the Effective Dating feature enabled:

- When you make a change to the current version of an employee record, NetSuite executes all workflows and scripts that are triggered by employee record changes.
- When you make a past-dated change to an employee record, NetSuite does not execute workflows and scripts that normally are triggered by employee record changes.
- When you make a future-dated change, the system does not immediately execute workflows and scripts that normally are triggered by employee record changes. These workflows and scripts are run when the date specified in the future-dated change arrives.
- Any change that you make to the employee record will conflict with any future-dated changes that are dated after the change you making now. If you make this change in the user interface, the system displays a window showing the conflicts and prompting you to confirm them. With workflows and scripts, the future-dated change is automatically overridden. For example, if you change an employee's department from Sales to Marketing as of January 1, 2019, then change that employee's department from Sales to HR as of today, the future-dated change from Sales to Marketing is overridden.
- Every effective-dated change requires a change reason. If a workflow or script does not provide a change reason, a default change reason is provided so that the workflow or script will not fail. For information about providing a change reason while scripting, see Using Effective Dating with Employee Workflows and SuiteScripts. Here is a list of the default change reasons provided:
  - CSV Import Change — This employee's information has been changed using CSV import.
  - New Employee Record — This employee is new to the SuitePeople system.
  - Web Service Change — This employee’s information has been changed using SOAP web services.
  - SuiteScript Change — This employee's information has been changed using SuiteScript.

Giving Employees Access and Assigning Roles

When you give an employee access to NetSuite, you check the Give Access box on the Access tab of their employee record, assign a role to the employee, and make sure that the employee's email address is accurate so that NetSuite can contact them. These fields are not effective-dated. If you change any of these settings, the change takes effect immediately, even if you do so as part of an effective-dated change. For more information, see Giving an Employee Access to NetSuite and Assigning Roles to an Employee.
Updating an Employee’s Supervisor

When you change an employee’s supervisor on their employee record, you can then go to the Human Resources > Supervisor Change Hist. subtab and change the effective date for this change. This is not governed by the Effective Dating feature.

Payroll Effective Dates

If you are using SuitePeople U.S. Payroll, note that the Payroll tab on the employee record has several fields that have an Effective Date and an Expiration Date. These values are not governed by the SuitePeople Effective Dating feature. These fields include: Earnings, Deductions, Company Contributions, and Accrued Time.

Advanced Employee Permissions Feature

The following permission requirements are required when you use the Effective Dating feature with the Advanced Employee Permissions feature enabled.

- To view effective dating changes, a role must be assigned the Employee Effective Dating permission, as well as the Employees, Employee Confidential, or Employee Administration permission.
- By default, only the Employee Effective Dating permission gives access to the effective dating logs and the employee change search. However, you can customize any of the employee permissions to include effective dating logs. Users assigned to a role with a customized employee permission that includes effective dating logs see only what they have access to see, based on the permissions assigned to the role. For example, a role with the Employee Confidential permission will see effective dating logs only for their direct reports and below.

For more information about the Advanced Employee Permissions feature, see Advanced Employee Permissions Overview.

Employee Change Requests Feature

Before you enable the Employee Change Requests feature, you must also enable the Effective Dating feature. The Effective Dating feature impacts employee change requests in the following ways:

- When you create an employee change request type, you must select an employee change reason. This is the employee change reason that will be used to make approved future-dated changes to an employee’s record.
- When you create an employee change request, you must select a proposed future-date. This is the date the approved changes will be applied to an employee’s record. Fields that are approved to change appear on the Effective Date Log subtab on the employee’s record.

For more information about the Employee Change Requests feature, see Employee Change Requests.

Using Effective Dating with Employee Workflows and SuiteScripts

If the Effective Dating feature is enabled, you can make past, future, or current-day changes to the employee record using the user interface and using workflows and SuiteScripts. When you make an
effective-dated change to the employee record, you specify a change reason. When you make past or future effective-dated changes, you also specify the effective date for the change.

Current Day Changes

Here is a sample of how you make changes to today's version of the employee record:

```javascript
var rec = nlapiLoadRecord('employee', '659')
rec.setFieldValue('initials', 'CC');
rec.setFieldValue('employeechangereason', '4')
nlapiSubmitRecord(rec, true)
```

Future or Past Effective-Dated Changes

Here is a sample of how you make changes to the employee record on a future or past date:

```javascript
var rec = nlapiLoadRecord('employee', '659', {'effectivedate':'2017-10-31'})
rec.setFieldValue('phone', '(111)-111-1111');
rec.setFieldValue('employeechangereason', '4')
nlapiSubmitRecord(rec, true)
```

**Note:** Prior to NetSuite 18.2, you specified the effectivedate field in YYYY-MM-DD format. In NetSuite 18.2, the effectivedate field syntax must match the format you have chosen in your company settings. Go to Setup > Company > Preferences > General Preferences to configure your Date Format. Confirm that any SuiteScripts or workflows that reference the effectivedate field are using the same format.
Employee Change Requests

The Employee Change Requests feature enables managers to initiate requests for changes to their
direct reports in NetSuite. Managers can initiate an employee change request for their subordinates
in the Employee Center and have it go through an approval process which you can define in SuiteFlow.
Approvers can approve or decline employee change requests, and approved requests are reflected in the
employee’s record on a proposed future date.

For more information about the Employee Change Requests feature, see the following topics:

- Prerequisites for Employee Change Requests
- Employee Change Requests Management
- Employee Change Requests in the Employee Center
- Employee Change Request Statuses

Prerequisites for Employee Change Requests

To use the Employee Change Requests feature, you must enable dependent features, set up employee
change request types, assign Advanced Employee Permissions to requesters and approvers, and set up
an approval workflow. For more information, see the following topics:

- Enabling the Employee Change Requests Feature
- Setting Up Employee Change Request Types
- Advanced Employee Permissions for Employee Change Requests
- Setting Up an Approval Workflow for Employee Change Requests

Enabling the Employee Change Requests Feature

The Employee Change Requests feature is dependent on Advanced Employee Permissions and Effective
Dating. These two features are automatically enabled in your account when you enable Employee Change
Requests. To create an approval workflow for employee change requests, you must enable SuiteFlow. To
allow managers to create employee change requests in the Employee Center, you must enable Employee
Center Dashboard Publishing.

To enable the Employee Change Requests feature:

1. Go to Setup > Company > Enable Features.
2. On the Employees subtab, check the Employee Change Requests box.
3. If you want managers to create employee change requests in the Employee Center, on the
   Employees subtab, check the Employee Center Dashboard Publishing box.
5. Click Save.

Setting Up Employee Change Request Types

Before managers can create employee change requests, an HR Administrator or other user with
appropriate permission must set up employee change request types. Employee change request types
provide managers with the types of changes they can initiate for their direct reports. When you create
an employee change request type, choose the fields you want to appear on the employee change
request and assign an employee change reason. The employee change reason you select for each
employee change request type is used to make a future effective-dated change to employees’ records.
Prerequisites for Employee Change Requests

After an employee change request is approved by all approvers, the requested changes to fields on the employee's record are applied on a future date. The change appears in the Effective Date Log subtab on the employee's record as an effective-dated change.

Creating New Employee Change Request Types

You can add a new employee change request type if you have the Employee Change Request Types permission at access level Create, Edit, or Full. For more information, see Employee Change Requests Permission Requirements.

To create a new employee change request type:

1. Go to Setup > HR Information System > Employee Change Request Types.
2. Click New Employee Change Request Type.
3. On the Employee Change Request Type page, enter a Name and Description for the employee change request type.
4. From the Change Reason dropdown list, select a change reason. This is the employee change reason that is used to apply the requested changes on the employee's record after the employee change request is approved by all approvers. For more information on employee change reasons, see Managing Employee Change Reasons.
5. In the Guidelines for Request field, enter any information that will assist employees when initiating this change request type. The guidelines that you enter here will be displayed to any employee who chooses to initiate a change request using this employee change request type.
6. In the Related Fields subtab, select the fields you want to include in the employee change request. The fields you choose here appear on the employee change request when you select this employee change request type. After all the approvers approve the request, these fields on the employee's record are changed on the proposed future date.
   a. To add a field, select a field from the dropdown list, then click Add. For example, if you are creating a transfer change request, you can select the following related fields:
      - Location
      - Department
      - Supervisor
   You can add related links next to each Related Field to give the manager creating the request useful information about each field.
7. Under the Insights tab, check the insights that you want to appear for managers and approvers. The following insights are available:
   - Job Duration — The range of time past employees have been in this employee's current role.
   - Salary Increase — The range of salary increases for other employees within the organization in the same proposed position and location.
   These insights are based on two years of organizational data.
8. Click Save.

Editing or Inactivating Employee Change Request Types

You can edit an employee change request type if you have the Employee Change Request Types permission access level at Edit, or Full. For more information, see Employee Change Requests Permission Requirements.

Employee Management
To edit or inactivate an employee change request type:

1. Go to Setup > HR Information System > Employee Change Request Types.
2. Click Edit beside the employee change request type you want to edit.
3. In the Related Fields subtab, add, delete, or move fields that you want to appear on the employee change request form.
   The fields you choose here are changed on the employee record after all the approvers approve the request.
4. From the Change Reason dropdown, select a change reason.
   This is the change reason that is used to apply the requested changes as an effective-dated change on the employee's record. For more information on employee change reasons, see Managing Employee Change Reasons.
5. To inactivate an employee change request type, to make it unavailable for selection when creating employee change requests, check the Inactive box.
6. When you are finished, click Save.

Deleting Employee Change Request Types

You can delete an employee change request type only if it is not in use and if you have the Employee Change Request Types permission access level at Full. For more information, see Employee Change Requests Permission Requirements.

If you no longer want to use an employee change request type, you can make it inactive. For more information, see Editing or Inactivating Employee Change Request Types.

To delete an employee change request type:

1. Go to Setup > HR Information System > Employee Change Request Types.
2. Click Edit beside the employee change request type you want to delete.
3. Point to Actions, and click Delete.

Advanced Employee Permissions for Employee Change Requests

Before you use the Employee Change Requests feature, you must assign Advanced Employee Permissions to employees' roles. Requesters and approvers must have the correct Advanced Employee Permissions assigned to their role to successfully create, view, approve, and apply employee change requests. Human Resources Generalist, Chief People Office, and Administrator roles all have Employee Change Request permissions by default.

⚠️ Important: Each requester and approver must have permission to view the fields in an employee change request. If you do not have permission to view a field, you cannot view the employee change request. The final approver must have permission to edit the fields in an employee change request to apply the requested changes. For more information, see Advanced Employee Permissions Overview.

For example, for a manager to create an employee change request to promote a direct report, their role must have permission to:
Prerequisites for Employee Change Requests

- View their subordinate’s salary, which requires the Employee Compensation permission. For more information, see Employee Compensation Permission Overview.
- View their direct report’s job, which requires the Employee Confidential permission. For more information, see Employee Confidential Permission Overview.

**Note:** If you want requesters to create employee change requests from the Employee Center, you must enable the Employee Dashboard Publishing feature. Alternatively, requesters can create employee change requests from employee records if their role has the Employee Record permission access level at View, Edit, or Full along with Advanced Employee Permissions in some capacity.

For more information about the Advanced Employee Permissions feature, see Advanced Employee Permissions. For more information on how to set up specific employees using Advanced Employee Permissions, see Advanced Employee Permissions Use Cases.

Setting Up an Approval Workflow for Employee Change Requests

You must set up an approval workflow before your company can begin creating employee change requests. This workflow defines and automates the approval process to approve changes to employees in your company.

In your workflow, you should set approvers according to your company’s needs. For example, the next approver in your workflow could be set by the following:

- **Employee name.** For example, if you want approvals to go through a set group of HR managers, you can set each approver as each HR manager.
- **Relationship to the employee.** For example, you can set the next approver to be the supervisor of the employee for whom you are creating the request.
- **Relationship to the requester.** For example, you can set the next approver to be the supervisor of the requester.
- **Relationship to the approver.** For example, you can set the next approver to be the supervisor of the current approver.

**Note:** You should set the final approver in your workflow to be an HR personnel so they can check the employee change request for accuracy.

For a sample employee change request workflow, see Sample Employee Change Request Workflow.

For more information, see the help topic SuiteFlow (Workflow).

**Sample Employee Change Request Workflow**

This sample workflow demonstrates how to create a workflow for employee change requests that includes two approvers. A specific employee is set as each approver.
The following table describes the required states, actions, and transactions for this workflow.

<table>
<thead>
<tr>
<th>State</th>
<th>Actions</th>
<th>Transitions</th>
</tr>
</thead>
<tbody>
<tr>
<td>State 1: Entry</td>
<td>There are no actions for this state.</td>
<td>Transitions to <strong>State 2: Next Approver</strong> after an employee change request is created by a manager.</td>
</tr>
<tr>
<td>State 2: Next Approver</td>
<td>Set an employee to be the next approver.</td>
<td>Transitions to <strong>State 3: Final Approver</strong> after the employee set in State 2: Next Approver has approved the employee change request.</td>
</tr>
<tr>
<td>State 3: Final Approver</td>
<td>Set an employee to be the next approver and set this employee as the final approver.</td>
<td>Transitions to <strong>State 4: Complete</strong> after the final approver approves the employee change request.</td>
</tr>
<tr>
<td>State 4: Complete</td>
<td>Set the status of the employee change request to Complete and set the final approver to false.</td>
<td>There are no transitions for this state.</td>
</tr>
</tbody>
</table>

When you build your own employee change request workflow, if needed, you can include additional approver states between **State 2: Next Approver** and **State 3: Final Approver**. To do this, use the same action and transition that you use for **State 2: Next Approver** for the additional states.

You must use the actions for **State 3: Final Approver** for the final approver in your workflow. For example, if you create a workflow with three approvers, follow the instructions for **Setting Up State 2: Next Approver** for your first and second approver states, and follow the instructions for **Setting Up State 3: Final Approver** for the third approver.

To begin building the Employee Change Request Workflow, go to Building the Employee Change Request Workflow.

**Building the Employee Change Request Workflow**

Create the workflow definition and define the basic workflow properties and the workflow initiation properties. The workflow initiates after a manager creates an employee change request.
To create the workflow definition and define when the workflow initiates:

1. Go to Customization > Workflow > Workflows.
2. Click New Workflow.
3. Set the following in the Basic Information field group:
   a. In the Name field, enter a name for your workflow, such as Employee Change Request Workflow.
   b. In the Record Type dropdown list, select Employee Change Request.
   c. In the Release Status dropdown list, select Testing.
   d. In the Keep Instance and History dropdown list, select Only When Testing.
   e. Check the Enable Logging box.
4. In the Initiation field group, choose Event Based.
5. In the Event Definition field group, check the On Create box.
6. Click Save.
7. To continue with the Employee Change Request workflow, go to Creating States for the Employee Change Request Workflow.

Creating States for the Employee Change Request Workflow

After you create the workflow definition, create workflow states for each of the following events:

- Entry
- Next Approver
- Final Approver
- Completed

This procedure uses only two approvers, however, you can include additional approver states as needed.

Important: Each approver must have permission to view the fields in an employee change request. The final approver must have permission to edit the fields in an employee change request to apply the changes requested to the employee's record. For more information, see Advanced Employee Permissions for Employee Change Requests.

To create states for each event:

1. If your Employee Change Request Workflow is not already built, go to Building the Employee Change Request Workflow.
2. In the workflow diagrammer, click New State.
   A new state appears in the diagrammer.
3. Double-click the state you want to rename in the diagrammer.
   Alternatively, you can do the following:
   a. In the diagrammer, click the state you want to rename.
   b. In the context panel in the State tab, click the Edit icon.
4. Repeat the above steps to create states for the following events in the workflow:
   - State 1: Entry
   - State 2: Next Approver
   - State 3: Final Approver
   - State 4: Complete

   **Note:** If you want more than two approvers in your workflow, create additional states between State 2: Next Approver and State 3: Final Approver as needed.

5. To continue with the Employee Change Request Workflow, go to Setting Up State 1: Entry.

### Setting Up State 1: Entry

After you create the states, you can set up the transition from State 1: Entry to State 2: Next Approver. If a manager creates an employee change request, this transition triggers the next approver state.

**To set up the transition to State 2: Next Approver:**

1. If you have not created states for your Employee Change Request Workflow, go to Creating States for the Employee Change Request Workflow.
2. In the diagrammer, point to the bottom of State 1: Entry. The icon becomes a filled half-circle.
3. Drag the icon to State 2: Next Approver.
4. In the diagrammer, double-click the transition arrow from State 1: Entry to State 2: Next Approver.
5. In the Workflow Transition window, set the following:
   a. In the To dropdown list, select State 2: Next Approver.
   b. In the Transition On dropdown list, select After Record Submit.
6. Click Save to save your changes to the transition.
7. To continue with the Employee Change Request Workflow, go to Setting Up State 2: Next Approver.

### Setting Up State 2: Next Approver

After you set up State 1: Entry, you can set up State 2: Next Approver. If a manager creates an employee change request, this state sets a specified employee as the next approver.

**Note:** If you want to include additional approvers in your own workflow, repeat these steps for each approver state that is not the final approver.

### State 2: Next Approver

**To set up State 2: Next Approver:**

1. If you have not set up State 1, go to Setting Up State 1: Entry.
2. In the diagrammer, click State 2: Next Approver.
3. In the context panel on the State subtab, click New Action.
4. In the New Action window, click Set Field Value.
5. In the Parameters field group, in Field dropdown list, select Next Approver.
6. In the Value field group, choose Static Value.
7. In the Selection list, select the name of the employee you want to be the next approver.
8. Click Save.

Transition to Step 3: Final Approver

To set up the transition to Step 3: Final Approver:

1. In the diagrammer, hover over the bottom of State 2: Next Approver. The icon becomes a filled half-circle.
2. Drag the icon to State 3: Final Approver.
3. In the workflow diagrammer, double-click the transition arrow from State 2: Next Approver to State 3: Final Approver.
4. In the To dropdown list, select State 3: Final Approver.
5. In the Transition On dropdown list, select After Record Submit.
6. In the Event Types list, click Approve.
7. In the Condition field group, select Visual Builder.
8. Next to the Condition field, click the Open icon to open the Condition Builder.
9. Enter the following:
   a. In the Field dropdown list, select Next Approver.
   b. In the Compare Type dropdown list, select Any Of.
   c. In the Selection list, select Current User.
10. Click Add to add the condition, and then click Save to save the condition.
11. Click Save to save your changes to the transition.
12. To continue with the Employee Change Request Workflow, go to Setting Up State 3: Final Approver.

Setting Up State 3: Final Approver

After you set up State 2: Next Approver, set up State 3: Final Approver. If the employee you assigned in State 2 approves the employee change request, this state sends the employee change request to the employee that is set as the final approver.

Important: The final approver must have permission to make changes to the employee’s record for the fields specified in the employee change request. For more information, see Advanced Employee Permissions for Employee Change Requests.

Note: You should set the final approver in your workflow to be an HR personnel so they can check the employee change request for accuracy.

State 3: Final Approver

To set up State 3: Final Approver:

1. If you have not set up State 2, go to Setting Up State 2: Next Approver.
2. In the diagrammer, click State 3: Final Approver.
3. To set the next approver:
Prerequisites for Employee Change Requests

a. In the context panel on the State subtab, click New Action.
b. In the New Action window, click Set Field Value.
c. In the Field dropdown list, select Next Approver.
d. In the Value field group, choose Static Value.
e. In the Selection list, select the name of the employee you want to be the final approver.

4. To set the final approver to true:
   a. In the context panel on the State tab, click New Action.
   b. In the New Action window, click Set Field Value.
   c. In the Field dropdown list, select Final Approver.
   d. In the Value field group, choose Static Value.
   e. Check the Checked box.
   f. Click Save to save the action.

Transition to State 4: Complete

To set up the transition to State 4: Complete:

1. In the diagrammer, hover over the bottom of State 3: Final Approver. The icon becomes a filled half-circle.
2. Drag the icon to State 4: Complete.
3. In the workflow diagrammer, double-click the transition arrow from State 3: Final Approver to State 4: Complete.
4. In the To dropdown list, select State 4: Complete.
5. In the Transition On dropdown list, select After Record Submit.
6. In the Event Types list, click Approve.
7. In the Condition field group, select Visual Builder.
8. Next to the Condition field, click the Open icon to open the Condition Builder.
9. Enter the following:
   a. In the Field dropdown list, select Next Approver.
   b. In the Compare Type dropdown list, select Any Of.
   c. In the Selection list, select Current User.
10. Click Add to add the condition, and then click Save to save the condition.
11. Click Save to save your changes to the transition.
12. To continue with the Employee Change Request Workflow, go to Setting Up State 4: Complete.

Setting Up State 4: Complete

After you set up State 3: Final Approver, set up State 4: Complete. If the final approver you assigned in State 3 approves the employee change request, this state sets the status of the request to Complete.

To set up State 4: Complete:

1. If you have not set up Step 3: Final Approver, go to Setting Up State 3: Final Approver.
2. In the diagrammer, Select State 4: Complete.
3. To set the request status to complete:
   a. In the context panel on the **State** subtab, click **New Action**.
   b. In the **New Action** Window, click **Set Field Value**.
   c. In the **Field** dropdown list, select **Request Status**.
   d. In the **Value** field group, choose **Static Value**.
   e. In the **Selection** list, select **Completed**.
   f. Click **Save**.

4. To set the final approver to false:
   a. In the context panel on the **State** tab, click **New Action**.
   b. In the **New Action** window, click **Set Field Value**.
   c. In the **Field** dropdown list, select **Final Approver**.
   d. In the **Value** field group, choose **Static Value**.
   e. Leave the **Checked** box unchecked.
   f. Click **Save** to save the action.

5. Now that the workflow setup is complete, test and then release the workflow. To continue with the Employee Change Request Workflow, go to Testing the Employee Change Request Workflow.

**Testing the Employee Change Request Workflow**

Before releasing your workflow, test the workflow to make sure it functions as designed.

After setting your workflow release status to *Testing*, test the following functionality:

- Test workflow initiation. Make sure the workflow initiates when an employee change request is created. To create an employee change request, see Creating an Employee Change Request from the Employee Record and Creating an Employee Change Request from the Employee Center.
- Test conditions. Set up a testing scenario where you can verify that the conditions in each state can evaluate to both true and false. For more information, see the help topic Testing Workflow Conditions.
- Test actions and transitions. Make sure that the actions and transitions in each step appear in the workflow execution log and complete successfully. For more information, see the help topic Testing Actions and Transitions.

After you have tested the Employee Change Request Workflow, change the release status to *Released*. For more information, see the help topic Release Status.

**Employee Change Requests Management**

HR Administrators or other users with appropriate permission can create new employee change requests from the employee record. They can also edit, delete, or inactivate existing employee change requests.

Before you create an employee change request, ensure you have completed Prerequisites for Employee Change Requests.

For more information about managing employee change requests, see the following topics:

- Creating an Employee Change Request from the Employee Record
- Editing or Inactivating an Employee Change Request
Deleting an Employee Change Request

Creating an Employee Change Request from the Employee Record

Requesters can create employee change requests from employee records if their role has the Employee Record permission access level at View, Edit or Full. For more information, see the help topics Set Permissions and Advanced Employee Permissions for Employee Change Requests.

Managers can also create Employee Change Requests for their direct employees from the Employee Center. For more information, see Creating an Employee Change Request from the Employee Center.

To create an employee change request from the employee record:
1. Go to Lists > Employees > Employees.
2. Click View next to the employee you want to create a request for.
3. Point to Actions and click Create Employee Change Request.
4. From the Change Request Type dropdown list, select a change request type.
5. On the request form, complete the following:
   - Request Changes - The employee’s current information appears on the left. Select new values from the fields on the right.
   - Proposed Date - Enter a future date in the date panel. This date is used to apply the change as an effective-dated change.
   - Justification - Explain your reason for requesting this change.
6. Click Submit.

Editing or Inactivating an Employee Change Request

After employee change requests are created, you can edit the request status, next approver, and justification. You can only edit an employee change request if you have the Employee Change Request permission access level at Edit, or Full. For more information, see Employee Change Requests Permission Requirements.

To edit or inactivate an employee change request:
1. Go to Setup > HR Information System > Employee Change Requests.
2. Click Edit next to the employee change request you want to edit.
3. On the request form, you can modify Request Status, Next Approver, and Justification.
   - **Note:** You must add an explanation in the Reason field if you set the Request Status to Declined.
4. To inactivate an employee change request, to make it unavailable, check the Inactive box.
5. When you are finished, click Save.
Deleting an Employee Change Request

You can delete existing employee change requests if you have the Employee Change Request permission access level at Full. For more information, see Employee Change Requests Permission Requirements.

**Note:** When you delete an employee record, employee change requests for that employee are also deleted. For more information, see Deleting Employee Records.

If you want to make an employee change request unavailable, you can make it inactive. For more information, see Editing or Inactivating an Employee Change Request

**To delete an employee change request:**

1. Go to Setup > HR Information System > Employee Change Requests.
2. Click **Edit** next to the employee change request you want to delete.
3. On the request form, point to **Actions**, and click **Delete**.

Employee Change Requests in the Employee Center

The Employee Center is the primary workspace for processing approvals. You must have a custom Employee Center role to access employee change requests in the Employee Center. An administrator can add a custom Employee Center role to your account. For more information, see Adding an Employee Record.

To use employee change requests in the Employee Center, see the following topics:

- Creating an Employee Change Request from the Employee Center
- Approving or Declining an Employee Change Request
- Viewing an Employee Change Request

Creating an Employee Change Request from the Employee Center

Managers can create employee change requests from a custom Employee Center role. They can create employee change requests on the Manager tab in the My Team portlet. To create an employee change request in the Employee Center, you must enable the Employee Center Dashboard Publishing feature. For more information, see Employee Center Dashboard Publishing.

**To create an employee change request:**

1. On the **Manager** tab, go to the My Team portlet.
2. Point to the **Actions** menu next to the employee you want to request a change for, and select the type of change you want to make.
3. On the request form, complete the following:
   - **Request Changes** - The employee's current information appears on the left. Select new values from the fields on the right.
   - **Proposed Date** - Enter a future date in the date panel. This date is used to apply the change as an effective-dated change.

   **Note:** The proposed date must be in the future. If this change is required now, contact your HR Administrator.

   - **Justification** - Explain your reason for requesting this change.

4. Click **Submit**.

### Approving or Declining an Employee Change Request

After an employee change request is created, each approver set by your company's defined workflow must approve the request. Approvers receive an email when it is their turn to approve or decline the request.

**To approve or decline an employee change request:**

1. On the **Employee** tab, go to the Home Links portlet.
2. Expand **Employee Change Requests** and click **Approve Pending Requests**.
3. Click **View** next to the request you want to approve.
4. Review the request, and then click **Approve** to approve the request, or click **Decline** to decline the request.
5. In the **Reason** field, enter an explanation for why you approve or decline the request. You must give a reason if you decline the request.
   - If you approve the request, one of the following occurs:
     - If you are not the final approver, an email notification is sent to the next approver to approve or decline the request.
     - If you are the final approver, the changes are applied to the employee's record on the proposed date.
   - If you decline the request, the next approvers can no longer approve the request. An email with your declining reason is sent to the manager who requested the employee change request.

### Viewing an Employee Change Request

You can view employee change requests that you have created and employee change requests that require your approval.

**Note:** The Approvals subtab at the bottom of the employee change request shows who has approved or declined the employee change request.

### Viewing an Employee Change Request that You Created

After you create an employee change request, you can view the request to keep track of its status.
To view employee change requests that you created:

1. On the Manager tab, go to the Home Links portlet.
2. Expand Employee Change Requests and click My Requests.
3. Click View next to the request you want to view.

Viewing an Employee Change Request that Requires Your Approval

You can view an employee change request that requires your approval. You must be the next approver to view the request.

To view employee change requests that require your approval:

1. On the Employee tab, go to the Home Links portlet.
2. Expand Employee Change Requests and click Approve Pending Requests.
3. Click View next to the request you want to view.

Employee Change Request Statuses

The following table describes each possible status for an employee change request.

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pending Approval</td>
<td>The employee change request is in progress and requires attention from the next approver.</td>
</tr>
<tr>
<td>Completed</td>
<td>The employee change request has been approved by all approvers. NetSuite applies the requested changes to the employee's record on the proposed date.</td>
</tr>
<tr>
<td>Declined</td>
<td>The employee change request has been declined and can no longer be approved. No changes are made to the employee's record.</td>
</tr>
</tbody>
</table>

**Note:** If the request was declined because it requires a correction, create a new employee change request.

| Expired           | The employee change request has passed the proposed date and can no longer be approved. Create a new employee change request with a future proposed date. If a change is required now, contact HR. |
| Failed to Apply   | The employee change request has been approved by all approvers but could not be applied to the employee's record. To have the changes applied, contact HR. |
Employee Directory and Org Browser

The Employee Directory SuiteApp enables your employees to quickly and easily search for their colleagues by name, location, department, and job title. If you use NetSuite OneWorld, employees can also search by subsidiary. This SuiteApp also provides an Org Browser that your employees can use to quickly browse through the organizational chart for your company, viewing the supervisors and direct reports of fellow employees.

If SuitePeople HR is provisioned on your account and the Kudos feature is enabled, your employees can give Kudos to colleagues directly from the employee directory. For more information on the Kudos feature, see Kudos.

For more information on this SuiteApp, see the following topics:

- Setting Up the Employee Directory SuiteApp
- Using the Employee Directory
- Using the Org Browser

Setting Up the Employee Directory SuiteApp

The following table describes the steps needed to set up the Employee Directory and Org Browser SuiteApp.

<table>
<thead>
<tr>
<th>Step</th>
<th>Related Help Topic</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Log in as a NetSuite Administrator.</td>
<td>Switching Between Roles</td>
</tr>
<tr>
<td>2. Complete the prerequisites.</td>
<td>Prerequisites for the Employee Directory SuiteApp</td>
</tr>
<tr>
<td>3. Install the SuiteApp.</td>
<td>Installing the Employee Directory SuiteApp</td>
</tr>
<tr>
<td>5. Update the required scripts to work with custom roles.</td>
<td>Updating Required Scripts for the Employee Directory and Org Browser</td>
</tr>
</tbody>
</table>

Prerequisites for the Employee Directory SuiteApp

To install the Employee Directory SuiteApp, Employee Center provisioned for your account. Ensure these features are enabled in your NetSuite account before installation (if they are not on the Enable Features page, contact your NetSuite account manager):

- Custom Records
- Server SuiteScript

If you want to give Kudos from the SuiteApp, you must enable the Kudos feature in the Performance Management section of the Enable Features page.

Installing the Employee Directory SuiteApp

Bundle Name: Employee Directory
Bundle ID: 112469
This is a managed bundle and is automatically updated. These issue fixes and enhancements are available after the SuiteApp is updated in your account.

For more information, see the help topic Installing a Bundle.

Configuring the Employee Directory and Org Browser

After installing the Employee Directory SuiteApp, configure the Employee Directory and Org Browser:

- Choose to use the Employee Directory, the Org Browser, or both.
- Choose four fields that will be on the Employee Directory for all employees.
- Choose three fields that will be on the Org Browser for all employees.
- Apply a filter to include or exclude employees based upon a NetSuite saved search.
- Specify a list of top-level employees in the Org Browser. They will be on the top of the org chart.

The Employee Directory SuiteApp includes a default saved search which filters out inactive and terminated users. To create a saved search to filter employees differently, select it on the Employee Directory Configuration page.

The directory listing for an employee shows the following information:

- Employee Name
- Office Phone Number
- Mobile Phone Number
- Email Address
- Action Button

Four additional fields appear in the directory listing for each employee. Configurable Field 1 follows the employee’s name. As an administrator, you can choose which fields appear from the following table:

<table>
<thead>
<tr>
<th>Configurable Fields 1</th>
<th>Standard Fields</th>
<th>Custom Field Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configurable Field 1</td>
<td>Job Title</td>
<td>Free-Form Text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>List/Record</td>
</tr>
<tr>
<td>Configurable Field 2</td>
<td>Subsidiary</td>
<td>Free-Form Text</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>List/Record</td>
</tr>
<tr>
<td></td>
<td>Department</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Sales Role</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Type</td>
<td></td>
</tr>
<tr>
<td>Configurable Fields 3</td>
<td>Department</td>
<td>Free-Form Text</td>
</tr>
<tr>
<td>&amp; 4</td>
<td>Location</td>
<td>List/Record</td>
</tr>
<tr>
<td></td>
<td>Fax</td>
<td>Date</td>
</tr>
<tr>
<td></td>
<td>Hire Date</td>
<td>Date/Time</td>
</tr>
<tr>
<td></td>
<td>Home Phone</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Phone</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Sales Role</td>
<td></td>
</tr>
</tbody>
</table>
Setting Up the Employee Directory SuiteApp

Configurable Fields | Standard Fields | Custom Field Types
--- | --- | ---
| Subsidiary | Free-Form Text | List/Record
| Supervisor | | |
| Type | | |

**Important:** The auto suggest feature and filter panel on the Employee Directory SuiteApp rely on the configurable fields you select. The SuiteApp suggests or filter employees based on four standard fields: **Job Title, Subsidiary, Location, and Department.** If you select **Job Title** as one of your configurable fields and select custom fields for the three other configurable fields, the SuiteApp can only suggest and filter according to job title.

Three additional fields appear in the org browser listing. **Configurable Field 1** follows the employee name and has a larger font size than the other configurable fields. **Configurable Field 1** has its own line above **Configurable Field 2** and **Configurable Field 3**. The following tables shows which fields can be chosen:

<table>
<thead>
<tr>
<th>Configurable Fields</th>
<th>Standard Fields</th>
<th>Custom Field Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configurable Field 1</td>
<td>Job Title</td>
<td>Free-Form Text</td>
</tr>
<tr>
<td>Configurable Fields 2 &amp; 3</td>
<td>Subsidiary</td>
<td>Free-Form Text</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>List/Record</td>
</tr>
<tr>
<td></td>
<td>Department</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Sales Role</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Type</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** For standard fields such as Subsidiary and Sales Role to appear, enable the appropriate features.

**To configure the employee directory and org chart:**

1. Go to Setup > Employee Directory/Org Browser > Preferences.
2. To use the Employee Directory, check the **Enable Employee Directory** box.
   a. The Directory Layout section shows visible fields in the Employee Directory. Select the field you want to appear under the employee name and title from the **Configurable Field 1** and **Configurable Field 2** lists.
   b. Select the fields you want to appear on the right-hand side of the directory listing from the **Configurable Field 3** and **Configurable Field 4** lists.
3. To use the Org Browser, check the **Enable Org Browser (Org Chart)** box.
   a. The Org Browser Layout sections shows visible fields in the Org Browser. Select the three additional fields you want to display from the **Configurable Field 1**, **Configurable Field 2**, and **Configurable Field 3** lists.
   b. Under Org Browser Top-Level Employees, click the dropdown arrow in the **Employee** field. On the list, select the names of one or more employees who you want to show at the top of the Org Browser.
4. Under Directory and Org Browser Filters, select the saved search you want to use to filter employees out of the directory and org browser from the **Saved Search** list. To revert to the
saved search that was included by default with the Employee Directory SuiteApp, select Employee Directory (Default) from the Saved Search list. For more information, see the help topic Saved Searches.

⚠️ Important: To avoid errors in showing the Employee Directory and Org Browser, ensure that the saved search you select do not filter standard criteria according to the information on the user’s record. Specifically, avoid filtering standard criteria such as Class, Department, Location, Subsidiary, and others and according to - Mine - or - Mine and Descendants -. These restrictions also apply to User Field... criteria that you can filter according to Class, Department, Location, Subsidiary, and others.

5. Click Save.

Updating Required Scripts for the Employee Directory and Org Browser

You must update the Employee Directory and Org Browser scripts to work with the custom roles that will use the SuiteApp.

<table>
<thead>
<tr>
<th>Script ID</th>
<th>Script</th>
</tr>
</thead>
<tbody>
<tr>
<td>customdeploy_ed_emp_dir_su</td>
<td>Employee Directory</td>
</tr>
<tr>
<td>customdeploy_ed_emp_search_backend_su</td>
<td>ED Employee Search Backend Su</td>
</tr>
<tr>
<td>customdeploy_ob_org_browser_su</td>
<td>Org Browser UI Su</td>
</tr>
<tr>
<td>customdeploy_ob_org_browser_backend_su</td>
<td>Org Browser Backend Su</td>
</tr>
</tbody>
</table>

To update the required scripts for the Employee Directory and Org Browser:

1. Go to Customization > Scripting > Script Deployments.
2. Locate a required script based on the table on this page. Click Edit.
3. On the Audience subtab, navigate to the Roles field.
4. Select the roles that will use the SuiteApp. To select all roles, check the Select All box.
5. Click Save.
6. Repeat steps 2 to 5 for each required script.

Using the Employee Directory

You use the employee directory to search for employees by name, location, department, job title, or (with NetSuite OneWorld accounts) subsidiaries. After performing the search, you can filter your results further by all of these categories.

Employee Directory

To use the employee directory:

1. From your Employee Center role, go to My Company > Employee Directory.
2. On the Employee Directory page, start typing the string that you want to search for. As you type, the search field shows employees who match your search term in their name, location, department, job title, or (with NetSuite OneWorld accounts) subsidiary. The more characters you type, the more narrowed the search becomes.

3. To search for employees who have your search string in their location, department, job title, or subsidiary, click the appropriate link in the search field.

4. If you see the person you are searching for in search field, click their name.

5. To perform a full search, press Enter or click the **Search** button.

6. The Employee Directory page shows a list of employees who match your search term.

7. To view an employee in the org browser, click the **View In Org Browser** button on the righthand side of the employee entry.

For more information about the org browser, see Using the Org Browser.

### Filter Search Results

**To filter your search results:**

1. If the search returned a large number of results and you want to narrow the results, click **Filters** to open the filter pane.

2. To apply a filter (that is, view only employees with particular characteristics), check the appropriate box under **Locations**, **Departments**, **Job Titles**, and/or **Subsidiaries**.

3. By default, the filters pane lists up to five entries for each category, ranked by the number of employees that match in each entry. To add another filter under a category, click **Add** and begin typing until you see the entry you want to use.

4. Below the filter area, the filters that you have applied appear. To remove a filter, clear the appropriate box or click the close button on the applied filter.

> **Important:** The Kudos feature requires SuitePeople HR, and an Administrator must enable it for your account. For more information, read Kudos.

### Give Kudos from the Employee Directory

**To give Kudos from the employee directory:**

1. On the Employee Directory page, search for the person you want to give Kudos to.

2. Click the **Give Kudos** button on the righthand side of the employee entry.

3. Optionally, you can add names to give Kudos to more than one coworker at once. Begin by typing another coworker's name. As you type, suggested names appear that match what you have typed. Click the name to add the person.

4. In the text field, type a description for the Kudos that explains why you want to recognize your coworker(s).

5. Under Supported Values, click one or more organizational values that this Kudos demonstrates. When you hover over a values icon, a description of that value appears.

6. Click **Give Kudos**.
Using the Org Browser

The Org Browser provides an intuitive, interactive, and graphic method of viewing the organizational chart for your company, viewing the supervisors and direct reports of fellow employees. You can also use the employee directory to locate employees. For more information, see Using the Employee Directory.

To begin, from your Employee Center role, under My Company, click Org Browser. The Org Browser page appears showing a tree structure graphic depicting your organization's hierarchy, centered on the person at the top of your organization, such as your president or chief executive officer. On each person's card, below their name, their job title and other configurable information appears.

You can navigate around the org browser in the following ways:

- To center the org browser on any person, click that person's card.
- Underneath that person's card, you see the people who report directly to them.
- You can also center on a person by typing their name in the search field.
- To zoom in or out on the org browser, use the scroll button on your mouse or click the zooming tool on the left side.
- To move around the org browser, click and drag in the direction that you want to move.
- For employees who are not centered in your view, a number below their cards shows the number of people they have reporting directly to them.
- If you are viewing an employee lower down in your company's hierarchy, their direct manager is replaced on the org browser by a number that shows the number of levels of management above them. When you hover over that number, the reporting relationship up to the top of your organization appears.
To download a copy of your current view of the org browser, click the Download button beside the search field.

To find a person by name, start typing their name in the **Find people by name** field.

**Important:** The Kudos feature requires SuitePeople HR, and an Administrator must enable it for your account. For more information, read [Kudos](#).

**To give Kudos from the Org Browser:**

1. On the Org Browser page, locate the person you want to give Kudos to, and click their card to center them.
2. Click **Give Kudos** on their card.
3. Begin typing a coworker’s name. As you type, suggested names appear that match what you have typed.
4. If you want to give Kudos to more than one coworker at once, then keep adding names.
5. In the text field, type a description for the Kudos that explains why you want to recognize your coworker(s).
6. Under Supported Values, click one or more organizational values that this Kudos demonstrates. When you hover over a values icon, a description of that value appears.
7. Click **Give Kudos**.
Employee Center Management

The Employee Center is a role designed for regular employees in your organization. In the Employee Center, your employees can access their information, submit requests (such as time-off requests and purchase orders) for approval, submit timesheets, and so on. You can manage the Employee Center to ensure that employees have access to the tools and information they need.

About the Employee Center Role

When you add the Employee Center role on an employee's record, you grant the employee access to the Employee Center. From the Employee Center, employees can do the following:

- View their paycheck history, employee profile, and W-4
- Enter and view time entries. Supervisors can review and approve time entries for direct reports.
- Enter and view expense reports. Depending on how you set up approvals for expense reports, expense approvers (often managers or supervisors) can review and approve expense reports in the Employee Center.
- Enter and view purchase requests or requisitions. Depending on how you set up approvals for purchase requests or requisitions, purchase approvers (often managers or supervisors) can review and approve purchase requests or requisitions in the Employee Center.
- Enter and view activities such as tasks and phone calls
- Access their calendar
- Access documents and relationship records

With SuitePeople HR, your employees can complete additional tasks in the Employee Center:

- Request time off and view their time-off balances. Supervisors can view and approve time-off requests for their direct reports.
- Recognize the achievements of their peers with Kudos
- Browse the Org Chart and search the Employee Directory

For more information about SuitePeople, see SuitePeople Overview.

The Employee Center dashboard can be customized by employees to show the information that they most need. Click Personalize in the upper right of the dashboard, or in the Settings portlet, click Personalize Dashboard. For more information about personalizing your dashboard, see the help topic Dashboard Personalization.
Understanding Restrictions for Employee Center Data

The standard Employee Center role is set up to filter the purchase orders, expense reports, and time reports that employees with this role are permitted to view. Employees logging in with this role can see purchase orders, expense reports, and time reports that they own. If they supervise other employees and are listed as an approver, they can also see purchase orders, expense reports, and time reports that their employees own.

In OneWorld accounts, subsidiary restrictions are not enforced to filter time and expense report records that users with this role can see. In OneWorld accounts, subsidiary restrictions are enforced to filter the records that users with this role can see, except for times reports, purchase orders, and expense reports. Subsidiary restrictions for the role are checked first, then subsidiary restrictions for the individual users. Customized Employee Center roles built from the standard Employee Center role filter viewable records in this same manner by default.

Purchase Approvals and Currencies

If you use the Multiple Currencies feature, when you view purchase requests and purchase orders that require approval, how currency fields are displayed depends on whether you customize the view.

Non-customized View

- **Amount** – shows amount in base currency
- **Base Currency** – shows currency in base amount

Customized View

- **Amount (Foreign Currency)** – shows amount in foreign currency
- **Currency** – shows foreign currency
Employee Center Portlets

NetSuite provides portlets that employees can add to their Employee Center dashboards. Some portlets are available regardless of the features that are enabled in your organization’s NetSuite account, and some portlets are feature dependent.

Standard Portlets

The following standard portlets are included in the Employee Center regardless of the features that are enabled in your account. Some of these portlets appear the first time that you log in to the Employee Center, and other portlets are accessible from the Personalize Dashboard palette.

<table>
<thead>
<tr>
<th>Portlet</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calendar</td>
<td>Lists activities for a selected period ordered by date and time, with links to drill down into individual activity records. In the portlet, you can select between a daily, weekly, monthly, or agenda view. You can choose to display your own calendar or a public calendar for another entity within the organization. You can click the Set Up menu option for the portlet to display a popup where you can define the types of activities to display in the calendar.</td>
</tr>
<tr>
<td>Custom Search</td>
<td>(Can display up to six on the Home page.) Shows results from a saved search. In the portlet, click Set Up to select the saved search, specify a custom title for the portlet, the number of results to display, whether to drill down into search results in the portlet or on a new page, and, if the Inline Editing feature is enabled, whether to enable inline editing of search results. Note: When placed in the right or left columns of a dashboard, custom search portlets display only the first four results columns of the saved search. When placed in the center column, they display the first nine results columns. Custom search portlets also include New, Edit, and View columns with links for each result record.</td>
</tr>
<tr>
<td>Employee Center — Home Links</td>
<td>Provides links to different records within your Employee Center, such as documents, contacts, and timesheets.</td>
</tr>
<tr>
<td>List</td>
<td>Shows a list of records of a selected type, with links to view, and, if you have permission, to edit individual records. Shows nine columns when placed in the center column of the dashboard; shows four columns when placed in the right or left column. In the portlet, click Set Up to select a type of record and the number of records shown. Note: On some tabs, the available List portlets are configured to show predefined types of records. For example, the Activities page offers Tasks and Phone Calls list portlets.</td>
</tr>
<tr>
<td>Quick Search</td>
<td>Shows a form where you can quickly search for records of a selected type, using one selected filter field and entered keywords. In the portlet, click Set Up to define the type of records to search, then enter keywords in the portlet’s text box and select a field name from the Search For dropdown.</td>
</tr>
<tr>
<td>RSS/Atom Feed</td>
<td>(Can display up to two.) Shows RSS or Atom feed URL content, from an external website or HTML document.</td>
</tr>
<tr>
<td>Portlet</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Recent Records</td>
<td>Shows a list of records that you have recently created, modified, or viewed. In the portlet, click the record to view it. If you have permission, an Edit link is also available. You can click it to open the record in edit mode.</td>
</tr>
<tr>
<td>Recent Reports</td>
<td>(Available on the Reports tabbed page.) Shows a list of reports that you have recently created, modified, or viewed. In the portlet, click the report name to view the individual report.</td>
</tr>
<tr>
<td>Reminders</td>
<td>Shows important tasks of selected types, usually that are past due or soon due to be completed. In the portlet, click Set Up to select types of reminders and to define the number of days in advance that reminders should be shown. Click on a reminder to go to the page where you need to take an action.</td>
</tr>
<tr>
<td>Report Snapshots</td>
<td>(Can display up to 10.) Each added portlet provides a graphical or list summary of a selected standard or custom report's data, with a link to view the underlying report. In the portlet, you can select a date range for data and click thumbnails to choose among chart types for graphical data. You can click Set Up to select the type of display and other layout options, including chart themes. You also can click menu options to print the report snapshot chart, download it to a PNG, JPG, PDF, or SVG file, or view the underlying report results. When the report snapshot portlet is in the left or right dashboard column, the list text truncates at 25 characters. To avoid this truncation, place the portlet in the middle column. Report snapshot list amounts are rounded to the nearest whole number and do not display decimal places.</td>
</tr>
<tr>
<td>Search Form</td>
<td>Shows a form to search for records of a selected type. Filter fields are based on system-defined defaults or a custom search form that you defined as preferred. In the portlet, click Set Up to select the search form to be used. Click Full Search to switch to the default search page for the selected record type. Click Edit to open the definitions page for the selected search form and make edits.</td>
</tr>
<tr>
<td>Settings</td>
<td>Shows links to user-level setup tasks. <strong>Important:</strong> The contents of this portlet are system-defined. This portlet cannot be removed or modified.</td>
</tr>
<tr>
<td>Shortcuts</td>
<td>Shows links to selected pages, so you can navigate quickly to frequently used pages. In the portlet, click Set Up to reorder the listing of existing shortcut links or click New Shortcut to add a shortcut, if you know the URL of the page. If you do not know the URL, go to that page and click More &gt; Add to Shortcuts in the upper right corner of that page.</td>
</tr>
<tr>
<td>Tasks</td>
<td>Shows a list of upcoming CRM tasks assigned to you, with links to view, and if you have permission, to edit, individual records. In the portlet, select a view and a sorting method, and click Set Up to define the number of tasks shown.</td>
</tr>
<tr>
<td>Trend Graphs</td>
<td>(Can display up to five.) Shows a chart of key performance indicator (KPI) data with a time-based X axis.</td>
</tr>
</tbody>
</table>
Employee Center Portlets

In the portlet, click thumbnails to choose among different chart types. You also can change the graph's X axis scale by selecting different time intervals from the dropdown list. Click Set Up to select a KPI to be graphed and layout options, including chart themes. You also can click menu options to print the trend graph chart or download it as a PNG, JPG, PDF, or SVG file.

Feature-Dependent Portlets

The following portlets are available for the Employee Center dashboard only if certain features are enabled in your account.

<table>
<thead>
<tr>
<th>Portlet</th>
<th>Description</th>
<th>Required Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expense Reports</td>
<td>Shows you the status of up to five of your latest submitted expense reports.</td>
<td>Expense Reports</td>
</tr>
<tr>
<td></td>
<td>You can also click the Enter Expense Report button to enter new expense reports. Links to your expense reports are not available from the Home Links portlet.</td>
<td></td>
</tr>
<tr>
<td>Kudos</td>
<td>Enables you to give Kudos to your coworkers to recognize a job well done.</td>
<td>Kudos</td>
</tr>
<tr>
<td></td>
<td>You can also view the other Kudos given in your company.</td>
<td></td>
</tr>
<tr>
<td>My Team</td>
<td>Displays a list of your direct reports, if you are a manager. This portlet appears on the Manager view of your Employee Center dashboard.</td>
<td>Employee Center Dashboard Publishing</td>
</tr>
<tr>
<td></td>
<td>If you enable the Employee Change Requests feature, managers can create employee change requests for their direct reports from the My Team portlet. For more information, see Employee Change Requests in the Employee Center.</td>
<td></td>
</tr>
<tr>
<td>News Items</td>
<td>Enables you to share company news with your employees.</td>
<td>Employee Center Dashboard Publishing</td>
</tr>
<tr>
<td>Payroll</td>
<td>Shows you the status of your last five paychecks, and allows you to view your Form W-4 information. Paycheck amounts are hidden by default; you can view paycheck amounts by clicking the eye icon. You can not access your paycheck history and Form W-4 information from the Home Links portlet.</td>
<td>Payroll</td>
</tr>
<tr>
<td>Purchases</td>
<td>Shows you the status of up to five of your latest submitted purchase requests or requisitions. You can click the Enter Purchase Request button or the Enter Requisition button to enter new purchase requests or requisition. Links to your purchase requests or requisitions are not available from the Home Links portlet.</td>
<td>Purchases or Requisitions</td>
</tr>
<tr>
<td>Time-Off</td>
<td>Provides you with a quick view of the time off you have for the rest of the year, along with the time off that you have taken and the time off that you have booked. You can also click Book Time-Off to schedule more time off.</td>
<td>Time-Off Management</td>
</tr>
</tbody>
</table>

Granting Access to the Employee Center

To assign the Employee Center role to an employee:

1. Go to Lists > Employees > Employees.
2. Next to the name of the employee to whom you want to assign the Employee Center role, click Edit.
3. Under Email|Phone|Address, enter an email address, if one has not already been entered.
4. Click the **Access** subtab.
5. Complete all access-related fields. For details, see *Giving an Employee Access to NetSuite*.
6. In the **Role** field, select **Employee Center**.
7. Click **Add**.
8. Click **Save**.

**Note:** Employees with Administrator roles in addition to Employee Center access do not count against your Employee Center licenses. If you remove an employee's Administrator role, the employee counts against your Employee Center licenses. To purchase additional licenses, contact your account representative.

### Employee Center Dashboard Publishing

The Employee Center Dashboard Publishing feature includes the following:

- **Employee Center Publishing global permission** – Users with this global permission can publish a standard Employee Center dashboard for all Employee Center users in your organization. All Employee Center users see the same layout and the same portlets when they log in to NetSuite with their Employee Center role.

- **News Item record and permission** – Users who are assigned roles that include the News Items permission can create News Item records. News items appear on the Company News portlet on the Employee Center dashboard. For more information, see *News Items*.

- **Manager dashboards in the Employee Center** – Employee Center users who are supervisors or managers have two dashboards in the Employee Center:
  - An Employee dashboard, where they can book time off for themselves, enter their own expense reports, keep track of contacts, and so on.
  - A Manager dashboard, where they can see information about and approve requests from their direct reports.

More information about the Manager dashboard is available in the Employee Center help.

For information on enabling the Employee Center Dashboard Publishing feature, see the help topic *Enabling Features*.

**Important:** After you enable the Employee Center Dashboard Publishing feature, any Employee Center dashboards that individual employees previously customized are replaced with a default dashboard. This dashboard can be edited only by users with the Employee Center Publishing global permission. If you disable the Employee Center Dashboard Publishing feature, previous versions of the Employee Center dashboard are restored.

### The Employee Center Publishing Permission

When you enable the Employee Center Dashboard Publishing feature, the Global Permissions feature is also enabled, if not already enabled (see the help topic *Using the Global Permissions Feature*). To use the publishing tool, which lets you create a standard Employee Center dashboard for all Employee Center users, you must assign the Employee Center Publishing global permission to a user. This user can then publish the Employee Center dashboard from the Employee Center role. Other users cannot customize their own dashboards, and a lock icon (🔒) appears on the dashboard. For more information about publishing the Employee Center dashboard, in the Employee Center help, see the section “Customizing the Employee Center for Your Organization”.

---

*Employee Management*
To assign the Employee Center Publishing permission to a user:

1. Go to Lists > Employees > Employees.
2. Beside the employee who is responsible for publishing the Employee Center dashboard, click Edit.
3. Click the Access subtab.
4. On the Roles subtab, verify that the employee is assigned the Employee Center role.
5. On the Global Permissions subtab, from the Permission list, select Employee Center Publishing, and then click Add.
6. Click Save.

**Note:** We highly recommend users not to use the Global Permissions Feature. Only use the Global Permissions Feature to assign permissions to employees if needed.

When this employee uses the Employee Center role, the Edit Dashboard button appears on the Employee Center home page.

**News Items**

To share company news with your employees, you can create news items that appear on the Company News portlet in the Employee Center. If you have multiple locations set up for your company, you can create news items that appear for employees in specific locations. You can also create news items that appear for only managers. Managers can find manager-specific news on the Manager dashboard in the Employee Center.

**Prerequisites**

To create news items, the Employee Center Dashboard Publishing feature must be enabled in your NetSuite account. For more information about the Employee Center Publishing feature, see Employee Center Dashboard Publishing.

As well, you must be assigned a role that includes the News Item permission. By default, the News Item permission is included in the following NetSuite roles, with the full access level (view, create, edit, and delete access):

- Chief People Officer (CPO)
- Human Resources Generalist
For more information about permissions, see the help topic NetSuite Permissions Overview.

Adding News Items to the Company News Portlet

The five most recent news items appear on the Company News portlet in the Employee Center. Older news items do not appear.

The following image shows what a news item looks like in the Company News portlet:

1. The headline of the news item.
2. The body of the news item. You can format this text with different fonts, colors, and basic formatting (bold, italics, underline, numbered and ordered lists).
3. The Call to Action button. You can specify the text that should appear on the button and a link for the button. For example, you might want to link to a page on your company’s intranet site.
4. Users can view headlines for other news items and click the headlines to read other news.

To add news items to the Company News portlet:

2. In the Headline field, enter a headline for the news item.
3. In the Body field, enter the text that makes up the body of the news item.
4. Additionally, you can set the following:
   - To include a button that users can click to learn more or perform a certain action, in the Call to Action field, enter the text that should appear on the button. In the Call to Action Link field, enter the link that opens when the user clicks the button.
   - To show this news item to only employees in a specific location, first, clear the Available in All Locations box. Then, in the Locations list, select one or more locations.
   
   **Important:** Employees who are not associated with a location can see news items for any location. To learn how to associate an employee with a location, see Employee Locations.
   - To show this news item to only managers, check the Managers Only box.
5. Click Save.
Editing News Items

To edit news items:
1. Go to Lists > Web Site > News Items.
2. Beside the news item that you want to edit, click Edit.
3. Make your changes.
4. Click Save.

Deleting News Items

To delete news items:
1. Go to Lists > Web Site > News Items.
2. Beside the news item that you want to delete, click Edit.
3. In the Actions menu, click Delete.
Employee Onboarding

The Onboarding Checklist SuiteApp is designed to organize tasks that help newly hired employees and transferred employees start their new jobs.

The SuiteApp enables HR professionals to manage the onboarding process for various employees by using checklists, templates, and reminders. It lets new hires and other employees track and complete their onboarding tasks.

For more information about this SuiteApp, see the following help topics:

- Onboarding Checklist Overview
- Setting Up the Onboarding Checklist SuiteApp
- Using the Onboarding Checklist SuiteApp
- Onboarding Checklist Best Practices
- Frequently Asked Questions: Onboarding Checklist

Onboarding Checklist Overview

The Onboarding Checklist SuiteApp is a comprehensive tool for creating templates and checklists that will simplify the onboarding process for newly hired or transferred employees.

The SuiteApp enables HR professionals to coordinate onboarding tasks among other HR professionals, new hires, transferred employees, and other employees. Onboarding templates and checklists created with the SuiteApp can be designed to reflect existing onboarding processes in your company.

Note: The Onboarding Checklist SuiteApp is available to accounts that have SuitePeople installed. For more information about SuitePeople, see SuitePeople Overview.

With the Onboarding Checklist SuiteApp, you can:

- Save time by creating checklist templates that you can reuse for different new hire scenarios.
- Promote a positive onboarding and first-day experience for newly hired and internally transferred employees by linking each task to the employees who can help.
- Ensure that newly hired and internally transferred employees can complete their tasks with the help of a clean and simple interface.
- Keep track of the status of tasks that are required to comply with labor standards, such as the completion of government forms.
- Identify common roadblocks when completing tasks to help refine the onboarding process.

To install and set up the SuiteApp as an administrator, read Setting Up the Onboarding Checklist SuiteApp.

To start using the SuiteApp for your onboarding tasks, read Getting Started with Onboarding Checklists.

To know how to maximize your use of the SuiteApp, read Onboarding Checklist Best Practices.

To find answers to common inquiries about the SuiteApp, read Frequently Asked Questions: Onboarding Checklist.
Setting Up the Onboarding Checklist SuiteApp

You need to be an administrator to install the Onboarding Checklist SuiteApp and grant access to custom roles.

To set up the Onboarding Checklist SuiteApp:

1. Log in as a NetSuite administrator.
2. Complete the prerequisites. For more information, read Prerequisites for the Onboarding Checklist SuiteApp.
3. Install the Onboarding Checklist SuiteApp. For more information, read Installing the Onboarding Checklist SuiteApp.
4. Create custom roles or grant Onboarding Checklist permissions to existing custom roles. For more information, read Setting Onboarding Checklist Roles and Permissions.
5. For each custom role, define the preferred onboarding checklist form. For more information, read Onboarding Checklist Form Preferences.

Prerequisites for the Onboarding Checklist SuiteApp

To install the Onboarding Checklist SuiteApp, you need to enable the following features:

- Custom Records
- Client SuiteScript
- Server SuiteScript

To enable Onboarding Checklist SuiteApp features:

1. Go to Setup > Company > Enable Features.
2. Click the SuiteCloud subtab.
3. In the SuiteBuilder section, check the Custom Records box.
4. In the SuiteScript section, check the Client SuiteScript and Server SuiteScript boxes.
5. Click Save.

Installing the Onboarding Checklist SuiteApp

As an administrator, you can install the Onboarding Checklist SuiteApp by using the following:

- Bundle Name: Onboarding Checklist
- Bundle ID: 244690

For more information on how to install a bundle in your account, read the help topic Installing a Bundle.

Setting Onboarding Checklist Roles and Permissions

By default, standard Chief People Officer (CPO) and HR Generalist (HRG) roles are updated with the complete set of permissions to use the SuiteApp. You can create custom instances of these roles and assign them to employees to give them access to the SuiteApp.

Employee Management
Onboarding Checklist Roles and Permissions

If you want to grant access to custom roles that were not created from standard CPO or HRG roles, you need to manually add the following onboarding checklist permissions:

<table>
<thead>
<tr>
<th>Custom Record</th>
<th>Level</th>
<th>Restrict</th>
</tr>
</thead>
<tbody>
<tr>
<td>Onboarding Checklist</td>
<td>Full</td>
<td>–</td>
</tr>
<tr>
<td>Onboarding Checklist Task</td>
<td>Full</td>
<td>–</td>
</tr>
<tr>
<td>Onboarding Checklist Template</td>
<td>Full</td>
<td>–</td>
</tr>
<tr>
<td>Onboarding Checklist Template Task</td>
<td>Full</td>
<td>–</td>
</tr>
<tr>
<td>Onboarding Task</td>
<td>Edit</td>
<td>Viewing and Editing</td>
</tr>
</tbody>
</table>

To grant Onboarding Checklist permissions to a role:

1. Log in as an Administrator.
2. Go to Setup > Users/Roles > User Management > Manage Roles.
3. On the Manage Roles page, choose a role.
   ■ Click Edit to add permissions to a custom role.
   ■ Click Customize to create a custom role from a standard role.
4. On the Role page, look for the Permissions subtab. Click the Custom Record subtab.
5. Select an onboarding checklist permission from the dropdown list.
6. Select the level of access and restrictions for the permission.
7. Click Add.
8. Repeat Step 5 to 7 for each onboarding checklist permission that you need to add.
9. Click Save.

The following are the custom roles that are assigned when users create a checklist:

<table>
<thead>
<tr>
<th>Onboarding Checklist Role</th>
<th>NetSuite Role Requirement</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinator</td>
<td>Chief People Officer</td>
<td>This role lets an employee manage an onboarding checklist.</td>
</tr>
<tr>
<td></td>
<td>Human Resource Generalist</td>
<td></td>
</tr>
<tr>
<td></td>
<td>HR roles with Onboarding Checklist permissions</td>
<td></td>
</tr>
<tr>
<td>Assignee</td>
<td>Any NetSuite role</td>
<td>This role lets employees view and update the status of onboarding tasks assigned to them.</td>
</tr>
</tbody>
</table>

For more information, read Creating an Onboarding Checklist.
Onboarding Checklist Form Preferences

You need to set the preferred Onboarding Checklist form for each custom role that you assign to users.

To set Onboarding Checklist form preferences:

1. Go to Setup > Users/Roles > Manage Roles.
2. Locate the custom role on the list. Click Edit.
3. On the Role page, click the Forms subtab.
4. Click the Custom Record subtab.
5. In the Preferred column, check the box next to Custom Onboarding Task Form.
6. In the Restricted column, check the box corresponding to Custom Onboarding Task Form.
7. Click Save.

Using the Onboarding Checklist SuiteApp

This section is intended for HR professionals, new hires, transferred employees, and other employees who are part of onboarding activities. It is separated in four general topics that each contain step-by-step procedures on how to use the Onboarding Checklist SuiteApp.

If you are an HR professional who is new to the Onboarding Checklist SuiteApp, read Getting Started with Onboarding Checklists.

If you are an HR professional who needs to create and maintain onboarding checklist templates, read Managing Onboarding Checklist Templates.

If you are a Coordinator or Assignee on an onboarding checklist, read Managing Onboarding Checklists.

If you need to monitor task updates, read Tracking Onboarding Updates.

Getting Started with Onboarding Checklists

The Onboarding Checklist SuiteApp lets you build an efficient onboarding system for your organization. With the SuiteApp, you can create templates that reflect the existing onboarding process in your organization. You can create onboarding checklists by using your templates or the premade onboarding checklist template.

To start, see:

- Using the Premade Onboarding Checklist Template
- Creating an Onboarding Checklist Template
- Creating an Onboarding Checklist

Using the Premade Onboarding Checklist Template

You can use the premade onboarding checklist template to start creating checklists. The template includes tasks typically done during the onboarding of a new or transferred employee.

To use the premade onboarding checklist template:

1. Go to Payroll and HR > Lists > Onboarding Checklist Template.
2. On the Onboarding Checklist Template List page, locate Onboarding Checklist Template. Click Edit.
3. You may retain the template name or enter a new name with a maximum of 300 characters.
4. On the **Tasks** subtab, you may retain or update the existing values for each task.

<table>
<thead>
<tr>
<th>Column</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task Name</td>
<td>Retain the name of the task or enter a new name with a maximum of 300 characters.</td>
</tr>
<tr>
<td>Required</td>
<td>Check the box if you require your assignees to complete the task.</td>
</tr>
<tr>
<td>Calculate Due Date From</td>
<td>Select <strong>Employee Start Date +</strong> if you need the assignees to complete the task after the employee start date. Select <strong>Employee Start Date -</strong> if you need the assignees to complete it before the start date. This column works in conjunction with the <strong>Days</strong> column.</td>
</tr>
<tr>
<td>Days</td>
<td>Determine how long before or after the employee start date should assignees complete the task. Retain or update the number of days in the field.</td>
</tr>
<tr>
<td>Assigned To</td>
<td>If you want the task to be assigned to specific employees for each checklist created using this template, select assignees. Otherwise, leave it blank. It can be filled out later when you create a checklist for the new employee. To select assignees, click the double arrows. On the popup window, select assignees from employee lists or search for their names.</td>
</tr>
<tr>
<td>Task URL</td>
<td>If a task requires the employee to access a site, append a URL with a maximum of 999 characters on this field. The task name will appear as a link in the assignee's checklist. This is especially helpful if the onboarding task involves other pages in the NetSuite application.</td>
</tr>
<tr>
<td>Include Supervisor as Assignee?</td>
<td>Check the box if you want the Supervisor to be included as an assignee. When you use the template to create a checklist, the task assignees will automatically include the employee selected in the <strong>Supervisor</strong> field.</td>
</tr>
<tr>
<td>Include New Hire as Assignee?</td>
<td>When you use the template to create a checklist, the task assignees will automatically include the employee selected in the <strong>Employee Record</strong> field.</td>
</tr>
</tbody>
</table>

5. To add tasks, navigate to the bottom of the task list. On the blank field, enter the task details. Click **Add**.
6. Click **Save**.

### Creating an Onboarding Checklist Template

Apart from using the premade onboarding checklist template, you can also create your own templates. By using templates, you can reduce duplicate efforts when onboarding several employees who need to complete the same tasks.

**To create an onboarding checklist template:**

1. Go to Payroll and HR > Lists > Onboarding Checklist Template > New.
2. On the Onboarding Checklist Template page, enter a name in the required **Template Name** field. Choose descriptive or specific keywords. You can enter a maximum of 300 characters in this field.
3. On the **Tasks** subtab, enter the details of your task.

<table>
<thead>
<tr>
<th>Column</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task Name</td>
<td>Enter a maximum of 300 characters for the name of your onboarding task.</td>
</tr>
<tr>
<td>Required</td>
<td>Check the box if you require your assignees to complete the task.</td>
</tr>
</tbody>
</table>
### Using the Onboarding Checklist SuiteApp

<table>
<thead>
<tr>
<th>Column</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculate Due Date From</td>
<td>Select <strong>Employee Start Date +</strong> if you need the assignees to complete the task after the employee start date. Select <strong>Employee Start Date -</strong> if you need the assignees to complete it before the start date. This column works in conjunction with the <strong>Days</strong> column.</td>
</tr>
<tr>
<td>Days</td>
<td>Determine how long before or after the employee start date should assignees complete the task. Enter the number of days in the field.</td>
</tr>
<tr>
<td>Assigned To</td>
<td>If you want the task to be assigned to specific employees for each checklist created using this template, select assignees. Otherwise, leave it blank. It can be filled out later when you create a checklist for the new employee. To select assignees, click the double arrows. On the popup window, select assignees from employee lists or search for their names.</td>
</tr>
<tr>
<td>Task URL</td>
<td>If a task requires the employee to access a site, append a URL with a maximum of 999 characters on this field. The task name will appear as a link in the assignee's checklist. This is especially helpful if the onboarding task involves other pages in the Netsuite application.</td>
</tr>
<tr>
<td>Include Supervisor as Assignee?</td>
<td>Check the box if you want the Supervisor to be included as an assignee. When you use the template to create a checklist, the task assignees will automatically include the employee selected in the <strong>Supervisor</strong> field.</td>
</tr>
<tr>
<td>Include New Hire as Assignee?</td>
<td>When you use the template to create a checklist, the task assignees will automatically include the employee selected in the <strong>Employee Record</strong> field.</td>
</tr>
</tbody>
</table>

4. After you complete the task details, click **Add**.
5. Repeat step 3 for each task you need to add.
6. Click **Save**.

### Creating an Onboarding Checklist

You can create an onboarding checklist by using the premade template or a custom template.

**To create an onboarding checklist:**

1. Go to Payroll and HR > Lists > Onboarding Checklist > New.
2. On the Onboarding Checklist page, enter the employee name in the appropriate field.
   - If the new hire has no employee record, enter their name in the **Employee Name** field.

   **Note:** After the employee record of the new hire becomes available in the system, the Coordinator can edit the checklist to associate it with the employee record. For more information, read Managing Onboarding Checklists as a Coordinator.

   - If the new hire or transferred employee has an employee record, enter or select their name in the **Employee Record** popup list field.
     
     When you select an employee record, the **Employee Name, Hire Date, Supervisor**, and **Location** fields are automatically populated with data from the record. These fields become read-only fields.

3. If the new hire has no employee record, manually enter information in the following fields:
   
   - In the **Hire Date** field, select the date when the new hire will start work. You are required to set this date before you can choose an onboarding checklist template. The SuiteApp uses the hire date to compute for the due date of each task.

---

Employee Management
Using the Onboarding Checklist SuiteApp

- In the **Supervisor** field, select the employee to whom the new hire reports. If the supervisor is not known, you may complete this field later.
- In the **Location** field, select the place where the new hire will work. If the location is not known, you may complete this field later.

4. From the **Status** dropdown list, select the status of the checklist.

5. In the **Onboarding Checklist Template** field, select a premade or custom template from the dropdown list. The SuiteApp displays the tasks included with the template.

6. In the **Coordinator** field, select the name of the employee who will manage the onboarding checklist. The Coordinator can view, edit, and create tasks on the checklist. For more information about managing checklists as a Coordinator, read Managing Onboarding Checklists as a Coordinator.

7. On the **Tasks** subtab, you can see the tasks that the template generated. If you did not select a template or if you want to add more tasks on the checklist, read Adding Tasks on an Onboarding Checklist.

8. Click **Save**.

### Adding Tasks on an Onboarding Checklist

**To add new tasks on an onboarding checklist:**

1. On the Onboarding Checklist page, navigate to the task table.
2. Enter the details of your task.

<table>
<thead>
<tr>
<th>Column</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task Name</td>
<td>Enter a maximum of 300 characters for the name of your onboarding task</td>
</tr>
<tr>
<td>From Template</td>
<td>This field is set to read-only for tasks that you add.</td>
</tr>
<tr>
<td>Required</td>
<td>Check the box if you need your assignees to complete the task.</td>
</tr>
<tr>
<td>Due Date</td>
<td>Set the date when the task is due.</td>
</tr>
<tr>
<td>Assigned To</td>
<td>Click the double arrows. On the popup window, select assignees from employee lists or search for their names.</td>
</tr>
<tr>
<td>Status</td>
<td>Select the status of the checklist. This field is set to Not Started by default.</td>
</tr>
<tr>
<td>Marked Complete By</td>
<td>Leave this field blank. It will automatically populate with the name of the employee who changes the status to Completed.</td>
</tr>
<tr>
<td>Notes</td>
<td>Enter a maximum of 300 characters for information that are relevant to the task.</td>
</tr>
<tr>
<td>Task URL</td>
<td>If a task requires the employee to access a site, append a URL with a maximum of 999 characters on this field. The task name will appear as a link in the assignee's checklist. This is especially helpful if the onboarding task involves other pages in the NetSuite application.</td>
</tr>
</tbody>
</table>

3. Click **Add**.
4. Repeat step 2 for each task you need to add.
5. Click **Save**.

### Managing Onboarding Checklist Templates

As an HR professional with access to the Onboarding Checklist SuiteApp, you can perform the following:
Using the Onboarding Checklist SuiteApp

- Create a template
- Edit a template
- Inactivate a template
- Delete a template

Review the following guidelines to better work with onboarding checklist templates:

- When you change a template after it was associated with a checklist, your changes will apply only to future checklists that will be created with that template.
- You can not delete a template if it is being used by an onboarding checklist. You need to delete the checklist that is using the template before you can delete the template.
- If you want to avoid using a specific template but are unable to delete all checklists associated with it, you can mark the template as inactive. After a template is marked as inactive, it can no longer be associated with future checklists.

To create an onboarding checklist template, read Creating an Onboarding Checklist Template.

Editing an Onboarding Checklist Template

To edit an onboarding checklist template:
1. Go to Payroll and HR > Lists > Onboarding Checklist Template.
2. On the Onboarding Checklist Template List page, locate the template name. Click Edit.
3. On the Onboarding Checklist Template page, edit the fields and columns.
4. Click Save.

Inactivating an Onboarding Checklist Template

To inactivate an onboarding checklist template:
1. Go to Payroll and HR > Lists > Onboarding Checklist Template.
2. On the Onboarding Checklist Template List page, locate the template name. Click Edit.
3. Check the Inactive box

Deleting an Onboarding Checklist Template

To delete an onboarding checklist template:
1. Go to Payroll and HR > Lists > Onboarding Checklist Template.
2. On the Onboarding Checklist Template List page, locate the template name. Click Edit.
3. Select Actions > Delete.

Managing Onboarding Checklists

You can manage onboarding checklists if you are the Coordinator or Assignee on the checklist.
To start, see:
- Managing Onboarding Checklists as a Coordinator
- Managing Onboarding Checklists as an Assignee
Managing Onboarding Checklists as a Coordinator

As the Coordinator of an onboarding checklist, you can:

- View or edit the checklist
- Delete the checklist

You can also keep track of the overall status of the onboarding checklist by viewing the Status field. By default, this field is set to Not Started. The status automatically changes to In Progress after an assignee updates the status of a task to In Progress or Completed.

The checklist status will automatically update to Completed only after all the required and optional tasks are marked complete. As the Coordinator, you can manually update the status of the checklist to Completed even if the tasks have not been marked complete.

Viewing or Editing an Onboarding Checklist

To view or edit an onboarding checklist:

1. Log in as a Chief People Officer, HR Generalist, or a role with Onboarding Checklist permissions.
2. Go to Payroll and HR > Lists > Onboarding Checklist.
3. On the Onboarding Checklist List page, locate the employee's name. Choose whether to click View or Edit.
4. If you click Edit, update the information on the checklist.

**Note:** If the checklist is already associated with a template, you can no longer associate it with another template. You can only select the template when you first create the checklist. After you save the checklist for the first time, you can no longer edit the Onboarding Checklist Template field.

5. Click Save.

Deleting an Onboarding Checklist

To delete an onboarding checklist:

1. Log in as a Chief People Officer, HR Generalist, or a role with Onboarding Checklist permissions.
2. Go to Payroll and HR > Lists > Onboarding Checklist.
3. On the Onboarding Checklist List page, locate the employee's name. Click Edit.
4. Select Actions > Delete.

Managing Onboarding Checklists as an Assignee

As an Assignee to an onboarding task, you can:

- View your tasks on the checklist
- Update the status of your tasks
- View and enter notes about your tasks

Viewing Assigned Onboarding Tasks

Assignees can view onboarding tasks either through the Reminders portlet or email notifications.
By using the Reminders portlet, assignees can benefit from receiving notifications right on the NetSuite application. They can see the latest count of onboarding tasks assigned to them that have not been started or are currently in progress.

**To view assigned tasks on the reminders portlet:**

1. Go to your Home page.
2. On the Reminders portlet, click **Onboarding Tasks**.

**Note:** You need to add **Onboarding Tasks** on the Reminders portlet to receive onboarding checklist notifications. For more information, read the help topic Setting Up Reminders.

3. On the Onboarding Tasks Results page, locate the onboarding task you want to view. Click **Edit** or **View** to open the checklist.

New employees and assignees automatically receive email notifications, which contain links to onboarding checklists. To better understand the notifications, read **Onboarding Checklist Email Notifications**.

**Updating the Task Status on the Checklist Page**

You can update the status of your onboarding tasks by using either the checklist page or the Reminders portlet results page.

**To update the task status on the checklist page:**

1. On the Onboarding Checklist page, locate the task.
2. In the **Status** column, select a status from the dropdown list.
3. Click **Save**.

**Updating the Task Status from the Reminders Portlet**

**To update the task status from the Reminders portlet:**

1. On the Reminders portlet, click **Onboarding Tasks**.
2. On the Onboarding Tasks Results page, click the Edit button on top of the list.
3. Locate the onboarding task on the list. Click the status of the task to select a new status.

**Note:** All onboarding tasks, including required and optional tasks, need to be marked complete for the onboarding checklist status to automatically set itself as **Completed**. Otherwise, the Coordinator needs to manually update the checklist status. For more information, read Managing Onboarding Checklists as a Coordinator.

**Adding Notes on Assigned Onboarding Tasks**

**To add notes on assigned onboarding tasks**

**Note:** If you are the new hire or transferred employee for whom the checklist was created, you can only view the notes entered by the other assignees.

1. On the Onboarding Checklist page, locate the task.
2. In the Notes column, enter your comments about the task. You can enter a maximum of 300 characters in this field.

⚠️ **Important:** The Notes field is shared among all the assignees of the task. Any changes you make to the text will affect the text already entered by other assignees.

3. Click OK.
4. Repeat Steps 2 and 3 to add notes to other tasks on the checklist.
5. Click Save.

### Tracking Onboarding Updates

As an HR professional or an employee with access to the Onboarding Checklist SuiteApp, you can receive notifications about the onboarding progress of an employee by using the following:

- **Onboarding Checklist Reminders**
- **Onboarding Checklist Email Notifications**

### Onboarding Checklist Reminders

You can set up reminders for incoming onboarding tasks by using the reminders portlet. You need to be assigned to a task for the reminders to appear on the portlet. To set up reminders, read the help topic **Setting Up Reminders**.

### Onboarding Checklist Email Notifications

The Onboarding Checklist SuiteApp sends email notifications to the following users defined on the onboarding checklist:

- Newly hired or transferred employee
- Coordinator
- Assignee

⚠️ **Important:** Email notifications sent to the newly hired or transferred employees and assignees are sent by using the email address of the Coordinator. The Coordinators should verify that they have an email address on their record, so that the SuiteApp can use it to send email notifications.

The following table shows the events that trigger email notifications for each type of user:

<table>
<thead>
<tr>
<th>Email Notification Trigger</th>
<th>New/Transferred Employee</th>
<th>Assignee</th>
<th>Coordinator</th>
</tr>
</thead>
<tbody>
<tr>
<td>New tasks were assigned to you</td>
<td>X</td>
<td>X</td>
<td>–</td>
</tr>
<tr>
<td>Tasks are no longer assigned to you because of any of the following:</td>
<td>X</td>
<td>X</td>
<td>–</td>
</tr>
<tr>
<td>- You were removed as an assignee</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Tasks were deleted</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Checklist was deleted</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Due dates for your tasks were changed</td>
<td>X</td>
<td>X</td>
<td>–</td>
</tr>
</tbody>
</table>
### Using the Onboarding Checklist SuiteApp

#### Email Notification Trigger

<table>
<thead>
<tr>
<th>Email Notification Trigger</th>
<th>New/Transferred Employee</th>
<th>Assignee</th>
<th>Coordinator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Daily update of your onboarding tasks</td>
<td>X</td>
<td>X</td>
<td>–</td>
</tr>
<tr>
<td>Daily update of all tasks related to a new/transferred employee's onboarding</td>
<td>–</td>
<td>–</td>
<td>X</td>
</tr>
</tbody>
</table>

**Note:** Email notifications are triggered every time that you or another employee updates and clicks **Save** on an onboarding checklist.

### Guidelines for Working with Onboarding Checklist Email Notifications

The following guidelines helps you work better with the SuiteApp's email notifications:

- The SuiteApp can only send email notifications to employees who have employee records.
- When email notifications contain multiple tasks, the tasks are arranged first according to their due date and then according to their name.
- Dates on email notifications are displayed in the format that the administrator set for all users in the company or account. Administrators can change the date format for all users on the General Preferences page at Setup > Company > Preferences > General Preferences.

### Onboarding Checklist Best Practices

Follow these guidelines to maximize your use of the Onboarding Checklist SuiteApp:

- If you can, create an employee record before you create an onboarding checklist. Some of the features of the SuiteApp, such as receiving email notifications and automatically including new hires and supervisors as assignees, need an employee record to work. For more information, read Adding an Employee Record.
- If you need to create an onboarding checklist for a new hire who has no employee record, remember to edit the checklist when the record becomes available.
- When setting up the SuiteApp, remember to set the preferred Onboarding Checklist form, so the checklists and templates will behave properly. For more information, read Onboarding Checklist Form Preferences.
- When creating an onboarding checklist, remember that the onboarding checklist template field can no longer be changed after you click **Save**. Ensure that you are selecting the appropriate checklist template before saving.
- For best practices about email notifications, read Guidelines for Working with Onboarding Checklist Email Notifications.

### Frequently Asked Questions: Onboarding Checklist

Read the answers to the following questions to know more about the Onboarding Checklist SuiteApp.

**How many checklists and templates can I create using the Onboarding Checklist SuiteApp?**

There is no limit to the number of checklists and templates you are allowed to create.
Can I assign a task to multiple assignees?
Yes, you may assign a task to multiple assignees, and there is no limit to the number of assignees.

Why can't I see the count changing on the Reminders portlet even after I completed a task?
Click the Refresh icon on the Reminders portlet to see the most recent onboarding task count.

Does the SuiteApp account for business days and holidays when computing due dates?
This feature is not available at this time.

What is the time zone used in the Onboarding Checklist SuiteApp?
The SuiteApp adapts the time zone indicated in the company preferences of the account.
Employee Offboarding

When an employee leaves your company, you should update the employee's information in NetSuite. NetSuite provides tools to terminate employees, track termination reasons, and inactivate or remove employee records.

For more information, see the following help topics:

- Terminating an Employee
- Termination Reason Tracking
- Deleting Employee Records
- Inactivating Employee Records

Terminating an Employee

When an employee leaves your company, you should modify the person's record to reflect the termination date and remove any granted user roles and access permissions. You can also inactivate the employee record if you want to prevent it from appearing in lists or as choices anywhere in your account. For instructions, see Inactivating Employee Records.

You must also specify a termination date. If you use the Termination Reason Tracking feature, you must specify a termination category, termination reason, termination details, and if the termination is regretted. For more information, see Termination Reason Tracking.

If you use SuitePeople U.S. Payroll to pay this employee, you can create an individual paycheck to complete any financial obligation you have to them. For more information, see the help topics Viewing Individual Paychecks and Creating an Off-Cycle Payroll Batch.

Modifying a Terminated Employee’s Record

To modify a terminated employee’s record:

1. Go to Lists > Employees > Employees.
2. On the Employees list, click Edit next to the terminated employee's name.
3. Click the Human Resources subtab.
4. In the Termination/Release Date field, enter this person's last date of employment.
   If you use Termination Reason Tracking, you must enter the following:
   a. Termination Category — Select whether the termination is voluntary or involuntary. Voluntary indicates the employee ended their employment and involuntary indicates the company ended the employment.
   b. Termination Reason — Select the reason for the termination. For details, see Managing Termination Reasons.
   c. Termination Regretted — Select if the termination is regretted. A regretted termination indicates that the company regards the termination as a loss. A non-regretted termination indicates that the company does not see the termination as a loss. Select Unspecified from the list to untrack this information.
   d. Termination Details — Enter details of the termination.
5. Modify any other fields as required. For more information, see Human Resources Information for an Employee.
6. Click the Access subtab.
7. Remove all access permissions and assigned user roles.
8. Click the System Information subtab and check the Inactive box if you do not want this employee's record to appear in lists or as choices anywhere in your account.
   To view inactivated employee records or reactivate them, go to Lists > Employees > Employees, and check the Show Inactives box.
9. Click Save.

Note: You cannot delete an employee record that has any associated transactions.

Completing Financial Obligations to a Former Employee

To complete financial obligations to a former employee:

You must follow the laws set by your jurisdiction to complete financial obligations to a terminated employee. Depending on the state an employee works in, you might need to pay them on the same day that employment is terminated. Otherwise, you can process the employee's final paycheck in your regular payroll batch.

If you use SuitePeople U.S. Payroll, follow these steps for compensating a terminated employee:

1. Update payroll information. This ensures the employee's new status is updated with the payroll tax engine. See the help topic Updating Payroll Information.
2. If you need to process payroll on the same day that employment is terminated, create a one time payroll that includes only the terminated employee. See the help topic Creating an Off-Cycle Payroll Batch.

Important: For same-day payroll batches, a fee applies. Direct deposits take at least two business days to process. To pay the employee with a check, check the No Direct Deposits box on the Payroll Batch page.

The terminated employee is paid during the first regular payroll cycle that includes the termination date if a one-time payroll batch is not processed for them.

Mass Deleting an Employee's Events

When an employee leaves your company, an administrator can delete the events they have scheduled. This is the only way to delete another employee's events that are marked Private or Show as Busy.

Roles other than administrator cannot delete events that do not belong to them. During the mass update, administrators may see public events they cannot delete.

To perform the delete events mass update:

2. Click Activities, and then click Delete Events.
3. On the Criteria subtab in the Filter column, select Calendar.
4. In the window that appears, select the employee whose calendar you want to delete.
5. Click Set.
6. Click Preview.
7. On the Mass Update Preview Results page, click Perform Update.
Termination Reason Tracking

When you terminate an employee, you must specify a termination/release date. If you have the Termination Reason Tracking feature enabled, you must also select a termination category and a termination reason from a list of options, as well as specify termination details, and whether or not the termination is regretted.

If you view the employee record of an employee who was terminated before this feature was enabled, these fields are populated by the string “Unspecified”.

NetSuite has several default termination reasons, but you can change them or create your own. For more information, see Default Termination Reasons.

The Termination Reasons page shows all of the termination reasons in your account. If you no longer want to use a reason, but it has been used in the past, then you can make it inactive. To view inactivated termination reasons, select the Show Inactives box.

If the Workforce Analytics feature is also enabled, you can see a high-level snapshot and synopsis of the employees who are leaving your company and the reasons why they are leaving on the Turnover Analysis page (Reports > Employees/HR > Turnover Analysis). For more information, see Workforce Analytics.

Note: When this feature is enabled mass update is not available, instead use NetSuite's Import Assistant to update data through import of a CSV file. For information, see the help topic Importing CSV Files with the Import Assistant. Also, when this feature is enabled inline editing is disabled.

For more information about the Termination Reason Tracking feature, see the following help topics:

- Managing Termination Reasons
- Default Termination Reasons

View the Using the Termination Reason Tracking Feature video.

Termination Reason Tracking Roles and Permissions Requirements

For details about the permission requirements for termination reason tracking, see Termination Reason Tracking Permission Requirements.

Note: If you want more control over what employee information is accessible by different NetSuite users, you can use the Advanced Employee Permissions feature. When this feature is enabled, you can use the employee permissions that come with this feature, which give you more control over what employee information certain roles can access. You can also customize employee permission that include all or set of standard fields and sublists from the employee record. For more information, see Advanced Employee Permissions.

Managing Termination Reasons

When you enable the Termination Reason Tracking feature, NetSuite provides several default termination reasons, but you can change them or create your own. For more information, see Default Termination Reasons.

The Termination Reasons page shows all of the termination reasons in your account. If you no longer want to use a reason, but it has been used in the past, then you can make it inactive. Select the Show Inactives box to show all reasons.
Adding Termination Reasons

To add a termination reason:

2. Enter a Name for the reason. Select a Termination Reason Category (Voluntary, Involuntary) from the list.
3. To make the reason inactive, check the Termination Reason is Inactive box.
4. To save and return to the Termination Reasons page, click Save. To save and create another new termination reason, click the down arrow, and click Save & New.

Editing Termination Reasons

To edit a termination reason:

1. Go to Setup > HR Information System > Termination Reasons.
2. Click Edit beside the termination reason you want to edit.
3. Enter a Name for the reason. Select a Termination Reason Category (Voluntary, Involuntary) from the list.
4. To make the reason inactive, check the Termination Reason is Inactive box.
5. Click Save.

Default Termination Reasons

If you are using the Termination Reason Tracking feature, you must specify a termination reason when you terminate an employee. NetSuite has a set of default termination reasons. You can change these or create your own. For more information, see Managing Termination Reasons. For each termination reason, you also specify a termination category: Voluntary or Involuntary.

This is the list of default termination reasons that are available when you start using this feature.

<table>
<thead>
<tr>
<th>Termination Reason Name</th>
<th>Termination Category</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attendance</td>
<td>Involuntary</td>
</tr>
<tr>
<td>Another Job</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Disability</td>
<td>Involuntary</td>
</tr>
<tr>
<td>Dissatisfaction with Compensation</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Dissatisfaction with Co-Worker</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Dissatisfaction with Supervisor</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Enlisted in Armed Forces</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Family Reasons</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Health Reasons</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Insubordination</td>
<td>Involuntary</td>
</tr>
<tr>
<td>Termination Reason</td>
<td>Involuntary/Voluntary</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>Involuntary Other</td>
<td>Involuntary</td>
</tr>
<tr>
<td>Involuntary Retirement</td>
<td>Involuntary</td>
</tr>
<tr>
<td>Job Abandonment</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Job Position Eliminated or Changed</td>
<td>Involuntary</td>
</tr>
<tr>
<td>Leave of Absence and Did Not Return to Work</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Marriage</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Personal Reasons</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Refusal to Follow Instruction</td>
<td>Involuntary</td>
</tr>
<tr>
<td>Refused Suitable Work</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Relocation</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Return to School</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Unsatisfactory Performance</td>
<td>Involuntary</td>
</tr>
<tr>
<td>Violation of Rules</td>
<td>Involuntary</td>
</tr>
<tr>
<td>Voluntary Other</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Voluntary Retirement</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Without Notice or Reason</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Working Conditions</td>
<td>Voluntary</td>
</tr>
<tr>
<td>Work Schedule</td>
<td>Voluntary</td>
</tr>
</tbody>
</table>

Deleting Employee Records

You can delete an employee record, but normally only in an unusual situation, such as creating the employee record in error. If an employee record has any transactions associated with it, it cannot be deleted.

If an employee is no longer actively working for your company, you should inactivate the employee record instead. For more information, see Inactivating Employee Records and Terminating an Employee.

To delete an employee record:

1. Go to Lists > Employees > Employees.
2. On the Employees list, click Edit next to the name of the employee record you want to delete.
3. On the Actions menu, click Delete.
4. When prompted to confirm, click OK.

Inactivating Employee Records

You can inactivate employee records for employees who no longer actively work for your company. This enables you to remove their access to NetSuite, while retaining the history of their employment with your company.
When you inactivate an employee record, you can no longer select it in employee fields in NetSuite.

You can also delete an employee record, but you normally would only do that if the record was created in error or if you had some other reason to recreate the employee record. For more information, see Deleting Employee Records.

Here are some cases in which you would want to inactivate an employee record:

- You are terminating the employee. In this case, you do not want to delete the employee record because it contains information that you might need in the future for record-keeping or auditing purposes. Also, you might rehire the employee and could make their record active again. For more information, see Terminating an Employee.
- The employee is taking a leave of absence, so you want to temporarily remove their access to NetSuite and restore it later.

When you inactivate an employee record:

- The employee’s login credentials and role assignments remain intact. If they return to your company and you make their record active again, they can access NetSuite as they did before being inactivated.
- If the employee has scheduled reports, then the report schedules are automatically deleted.
- If the employee is the owner of calendar events, those events remain in the calendar.
- If the employee is the owner of saved searches, they remain in the list of saved searches.

To inactivate an employee record:

1. Go to Lists > Employees > Employees.
2. Check the Show Inactives box at the top of the list.
3. In the Inactive column, check the box next to the employee you want to inactivate.
4. Click Submit.
Time-Off Management

- Time-Off Management Overview
- Prerequisites for Using Time-Off Management
- Time-Off Management Setup
- Time-Off Management Integration with SuitePeople U.S. Payroll
- Viewing Time-Off Changes
- Viewing an Employee's Time-Off Balance
- Creating a Time-Off Change
- Approving or Rejecting a Time-Off Request as an Administrator
- Time-Off Management for Employees or Managers
- Time-Off Reports

Time-Off Management Overview

NetSuite's Time-Off Management feature enables Human Resources to define and manage time-off plans according to company policies and assign them to employees based on location, department, class, or (with NetSuite OneWorld) subsidiary.

This includes the ability to:

- Create a set of time-off types for the different categories of time off that your employees can take.
- Define the time-off rules that accommodate the different policies at your company.
- Configure how NetSuite handles changes to these rules at specific employee milestones.
- Set up eligibility and entitlement.
- Set up accruals based on a fixed amount per period or hours worked.
- Set up balance and carryover limits.
- Review and make adjustments to employees’ time-off balances.

Employees assigned to a time-off plan must have access to the Employee Center to submit time-off requests. Managers can review and approve time-off requests either from an email message or from the Employee Center. For more information, see Time-Off Management for Employees or Managers.

The Time-Off Management feature can be integrated with other features in NetSuite, including Time Tracking, SuitePeople U.S. Payroll, Projects, and Resource Allocations.

Time Tracking and Time-Off Management

The Time Tracking feature must be enabled to use Time-Off Management. If you are using time transactions to track employee time and to bill time to projects, NetSuite generates time entry records when a time-off request is approved. If you are using SuitePeople U.S. Payroll, time usage is reflected in Payroll. You can view generated time entry records under the Time Tracking subtab of the employee record. For more information, see the help topic Time Tracking.
Payroll and Time-Off Management

Time-Off Management and SuitePeople U.S. Payroll can work together to ensure that your employees receive the time off that they are entitled to and that they are paid correctly. For more information about how to set up Payroll and Time-Off Management to work together, see Time-Off Management Integration with SuitePeople U.S. Payroll.

Projects and Time-Off Management

Different types of time off can be associated with projects and project tasks. When a time-off request is approved for a time-off type that is associated with a project and project task, the project information appears on the Time Details subtab on the Time Tracking record.

Project Management, Resource Allocations, and Time-Off Management

When the Project Management and Resource Allocations features are both enabled, they work with Time-Off Management in the following ways:

- If a project manager allocates a resource to a project, but the resource has approved time off that conflicts with the project dates, a warning appears on the resource allocation record. The conflict also appears on the Time-Off Conflicts subtab of the Resources subtab on the project record.
- If a resource who is already allocated to a project requests time off that conflicts with the project dates, and the time-off request is approved, the project manager receives an email notification with the details of the conflict.

For more information, see the help topic Resource Allocations and Time-Off Management.

To get started with managing time off for employees, see the following topics:

- Prerequisites for Using Time-Off Management
- Time-Off Management Setup
- Time-Off Management Integration with SuitePeople U.S. Payroll
- Assigning Work Calendars to Employees
- Time-Off Types
- Creating a Time-Off Plan
- Time-Off Rules
- Assigning a Time-Off Plan to an Employee

Prerequisites for Using Time-Off Management

This section outlines the prerequisites for using the Time-Off Management feature:

- Installing the Time-Off Tracking SuiteApp
Prerequisites for Using Time-Off Management

- Assigning Work Calendars to Employees
- Time-Off Management Roles and Permissions Requirements

Installing the Time-Off Tracking SuiteApp

**Important:** To install the Time-Off Tracking SuiteApp, you must have the Time-Off Management feature enabled (Setup > Company > Enable Features > Employees > HR Information System > Time-Off Management). If you do not see this feature on the Enable Features page, you need SuitePeople HR provisioned on your account. For more information, see SuitePeople Overview.

With the Time-Off Tracking SuiteApp, employees can make time-off requests using their Employee Center role. The workflow included in the SuiteApp ensures that requests are routed for approval to an employee's supervisor. The Time-Off Tracking SuiteApp also includes a set of saved searches that you can use as reports. For more information, see Time-Off Tracking Reports.

For more information about installing SuiteApps, see the help topic Installing a Bundle. You can search for the Time-Off Tracking Suite App using the following information:

- **Bundle Name:** Time-Off Tracking
- **Bundle ID:** 112449

The Time-Off Tracking SuiteApp is a managed bundle and is automatically updated whenever fixes and enhancements are available.

**Note:** The Time-Off Tracking SuiteApp uses the time-off request record. Custom fields on the time-off request record do not appear when employees create time-off requests. If you add custom fields to the time-off request record, make sure that the fields are not mandatory. If they must be mandatory, include default values for the fields.

Assigning Work Calendars to Employees

When you are using the Time-Off Management feature, you must assign a work calendar to employees on the employee record so that the system can determine which days are working days for the employee. The system uses the work calendar to calculate the number of hours to deduct from an employee's balance when a time-off request is submitted. For more information, see the help topics Setting Up a Work Calendar and Assigning a Time-Off Plan to an Employee.

Time-Off Management Roles and Permissions Requirements

The Time-Off Administration permission is required to set up the Time-Off Management feature. The standard roles that come with this permission are HR Generalist, Administrator, and Chief People Officer (CPO). For details, see Time-Off Management Permission Requirements.

You can also create custom roles that include this permission. For more information, see the help topic Customizing or Creating NetSuite Roles.

If your role has the appropriate permission, as many manager roles do, you can review time-off requests before employees take the time off, and approve or reject them as needed.

Employees in your company who are assigned a time-off plan must have access to the Employee Center role so that they can submit time-off requests and view their time-off balances.
Managers can review requests from an email message or from the Employee Center.

**Time-Off Management Setup**

**Important:** If you are using SuitePeople U.S. Payroll, refer to the section **Time-Off Management Integration with SuitePeople U.S. Payroll.**

Before setting up the Time-Off Management feature, consider how your company's time-off policies are applied to employees. Think about the differences between employees, such as the amount of time-off they are entitled to, how unused time off is dealt with at the end of the year, and how time off is accrued. You can create multiple time-off plans to accommodate these differences.

Time-off plans contain the time-off types and time-off rules that reflect your company's time-off policies. Create the time-off types so that they match the specific leave types at your company, such as vacation time and sick leave. The time-off rules define how to handle time-off eligibility, entitlements, accruals, and carryover during an employee's tenure with the company.

Complete the following steps to set up the Time-Off Management feature:

- Creating a Time-Off Type
- Creating a Time-Off Plan
- Creating a Time-Off Rule
- Assigning a Time-Off Plan to an Employee

The process for setting up Time-Off Management looks like this:

1. **Enable the Time-Off Management feature.**
2. **Create Time-Off Types** for the different categories of time off employees can take.
3. **Create Time-Off Plans**.
5. **Select a Time-Off Type** for each Time-Off Rule.
6. **Assign Time-Off Plans** to employees.

**Time-Off Types**

With time-off types, you can define the different categories of time off that employees at your company are entitled to take.

---

**Employee Management**
For example, you can create a time-off type for vacation and another time-off type for sick leave. These time-off types should be consistent with your company time-off policies.

You can create unlimited time-off types to reflect the various time-off policies at your company. You can add multiple rules to the same time-off type to specify the different rules to apply during an employee's tenure. For more information, see Time-Off Rules.

View the Creating Time-Off Types video.

Creating a Time-Off Type

To create a time-off type:

1. Go to Setup > HR Information System > Time-Off Type > New.
2. In the Name field, enter a unique name for the type. The name specified here appears in time-off lists for time-off requests, time-off plans, and time-off changes.
3. In the Display Name field, enter how you want the time-off type name to appear to employees. For instance, you might have different time-off types for different subsidiaries, departments, or locations, but you want the type to appear the same to all employees.
4. To track only the usage of this time-off type, without having an entitlement and accruing a positive balance, check the Track Only box. For example, you might want to check the Track Only box if your company offers unlimited sick days. When you change an existing time-off type to track only, future accruals are not calculated. All balance entries prior to the change are saved and displayed in the time-off changes record. For more information, see Viewing an Employee's Time-Off Balance.
5. If you are using SuitePeople U.S. Payroll, select a Payroll Item. For more information, see Time-Off Management Integration with SuitePeople U.S. Payroll.
6. In the Minimum Increment and Increment Unit fields, specify the minimum increment of time off that is required for this type. Time-off requests cannot be for less than this amount and must be multiples of this amount. Leave the field value at zero or blank to allow employees to enter any value.

For example, if employees must take time off in half-day increments, set the Minimum Increment field to 0.5, and, from the Increment Unit list, select Days.

7. To associate this time-off type with a specific project, select the project from the Project list. When you create a project to associate with a time-off type, consider the following:
   - If you select Limit Time and Expenses to Resources on the Preferences subtab, employees who need to track time against the project must have Project Resource selected on their employee record.
   - If you select Allow Time Entry and Classify Time as Exempt on the Preferences subtab, any employee is able to track time against the project even if Project Resource is not checked on their employee record.

8. To associate this time-off type with a specific task on the project, select it from the Project Task list. When you create a project task that you plan to associate with a time-off type, you must enter a value in the Estimated Work field on the Project Task/Milestone page. If you do not enter anything
in this field the project task is saved as a milestone and it will not appear in the **Project Task** list on the time-off type record. For more information, see the help topic **Project Tasks**.

When a time-off type is associated with a project and project task, any reports that are run for tracked time will include time entries generated from time-off requests.

9. From the color picker, select the color that you want to associate with this time-off type.

10. Click **Save**.

Next, create the time-off plan and add the types you created to it. For more information, see **Creating a Time-Off Plan**.

**Editing a Time-Off Type**

You can edit a time-off type at any time. However, if you need to make a change that affects accruals for a large number of employees, you should make the change at the end of a business day. This gives the system enough time to implement the changes. You should also avoid making any changes that affect accruals on an actual accrual day.

**To edit a time-off type:**

1. Go to Setup > HR Information System > Time-Off Type.
2. Click **Edit** next to the time-off type you want to change.
3. When you are finished editing, click **Save**.

**Inactivating or Deleting a Time-Off Type**

**Inactivating a Time-Off Type**

When you inactivate a time-off type, it no longer appears in lists.

**To inactivate a time-off type:**

1. Go to Setup > HR Information System > Time-Off Type.
2. Next to the time-off type you want to make inactive, click **Edit**.
3. Check the **Inactive** box.
4. Click **Save**.

If the type-off type is assigned to a time-off plan, you must remove it from the plan before you inactivate it. To view a list of inactive types, go to the list page view and check the **Show Inactives** box.

**Note:** When a time-off type is inactivated, any time-off rules associated with it are hidden, all future accruals are deleted, and any unused time off expires at the end of the year without a carryover. Any manual changes and approved time-off requests for a future date must be manually removed, if required.

**Deleting a Time-Off Type**

You cannot delete time-off types if they are assigned to a time-off plan, or if a balance change or time-off request was made against it. Before you delete a time-off type, remove it from the time-off plan, and then delete all time-off changes and requests that use the time-off type.
To delete a time-off type:

1. Go to Setup > HR Information System > Time-Off Type.
2. Next to the time-off type you want to delete, click **Edit**.
3. Select **Delete** from the **Actions** menu.
4. When prompted to confirm the deletion, click **OK**.

Time-Off Plans

A time-off plan contains the time-off types and rules that dictate how each time-off type is applied. Rules define how eligibility, accruals, entitlements, and carryover work for employees in the plan, and how they evolve over each employee's tenure with the company.

Creating a Time-Off Plan

Before you create a time-off plan, make sure you have set up and defined time-off types. For more information, see Creating a Time-Off Type.

View the Creating Time-Off Plans video.

To create a time-off plan:

1. Go to Setup > HR Information System > Time-Off Plan > New.
2. In the **Name** field, enter a name for the time-off plan. This name appears wherever you are required to select a time-off plan, such as the employee record. Name the plan so that you or someone else in HR can easily pick the right plan to assign to each employee.
3. To include forecasted accruals through to the end of the year in the number of days available to an employee, check the **Days Available Includes Future Accruals for the Year** box. To include only time off that employees have accrued to date, clear the box.
4. From the **Start of Entitlement Period** list, select when the entitlement period starts. For example, if employees are entitled to 15 days, and if April is selected, the entitlement period starts April 1st.
5. If necessary, select a **Subsidiary**, **Class**, **Department**, or **Location**. You can assign this plan only to employees who are associated with the department, class, location, and subsidiary you set here. If you do not set a specific department, class, location, or subsidiary, this plan can be assigned to anyone.
6. Click **Save**.

After you save the plan, you can define time-off rules. For more information, see Creating a Time-Off Rule.

Editing a Time-Off Plan

You can make changes to a time-off plan at any time. After the plan is saved, the system updates any future time-off changes to reflect the new settings.

To edit a time-off plan:

1. Go to Setup > HR Information System > Time-Off Plan.
2. Click **Edit** next to the time-off plan you want to change.
3. When you are finished editing, click **Save**.

**Note:** If you are removing rules from a plan, you cannot delete the last rule if the time-off plan is assigned to employees. You must either add another rule or unassign the plan from all employees before you can delete the rule.

---

### Inactivating or Deleting a Time-Off Plan

#### Inactivating a Time-Off Plan

When you inactivate a time-off plan, it no longer appears in lists. To inactivate a time-off plan that is already assigned to an employee, first remove the time-off plan from the employee record. To view a list of inactive plans, go to the list page view and check the **Show Inactives** box.

**To inactivate a time-off plan:**

1. Go to Setup > HR Information System > Time-Off Plan.
2. Next to the time-off plan that you want to make inactive, click **Edit**.
3. Check the **Inactive** box.
4. Click **Save**.

#### Deleting a Time-Off Plan

**To delete a time-off plan:**

1. Go to Setup > HR Information System > Time-Off Plan.
2. Next to the time-off plan that you want to delete, click **Edit**.
3. From the **Actions** menu, select **Delete**.
4. When prompted to confirm the deletion, click **OK**.

If you attempt to delete a time-off plan that has employees assigned to it, a popup window appears. Click the link in the window to view a list of all the employees that are assigned to the plan. Before you can delete the time-off plan, you must remove the time-off plan from each employee record.

---

### Time-Off Rules

After you create a time-off plan, you must define and apply rules to the time-off plan. Time-off rules allow you to specify how time off accumulates (i.e., how time off accrues) within the time-off plan by time-off type. In a time-off rule, you can also set up how to manage time-off balance and carryover limits.

**Important:** If you use SuitePeople U.S. Payroll in your NetSuite account, you must follow the setup instructions in **Time-Off Management Integration with SuitePeople U.S. Payroll**.

View the Creating Time-Off Rules video.
Creating a Time-Off Rule

Important: If you use SuitePeople U.S. Payroll in your NetSuite account, follow the setup instructions in Time-Off Management Integration with SuitePeople U.S. Payroll.

To create a time-off rule:

1. Go to Setup > HR Information System > Time-Off Plan.
2. Beside the plan that you want to define rules for, click Edit.
4. In the Time-Off Type field, select a time-off type to apply to the plan.

\[Tip: \] To create a new time-off type for this plan, in the Time-Off Type field, click New.

5. Specify the minimum tenure for this time-off type and whether the tenure is in months or years. Typically, minimum tenure is used to increase the amount of time off that employees are entitled to over a specific period of time, but it can also be used to adjust an accrual or carryover rule at an employment milestone.

For example, you might want employees to start with 10 vacation days and then set an increase after five years of employment to 15 vacation days. To do this, add two time-off rules to the plan using the same time-off type. One rule has a minimum tenure of zero with an entitlement of 10 vacation days, and the second rule has a minimum tenure of five years with an entitlement of 15 vacation days.

8. Click Save.

Repeat these steps for each rule that you want to apply to this time-off plan. Within a plan, you can create multiple rules for one time-off type, but the time-off type must accrue in the same way, by either a fixed amount or by hours worked, in each rule where it appears.

Time-Off Accruals

Time-off types can automatically accrue within a time-off plan in one of two ways: by a fixed amount per period, or by hours worked. For more information, see Accruals Based on a Fixed Amount Per Period and Accruals Based on Hours Worked.

\[Note: \] If you select a track only time-off type in the time-off rule, accrual options do not appear in the time-off rule.

The following diagram illustrates the process for setting up time-off accruals in a time-off rule:
Important: Within a time-off plan, if two or more rules use the same time-off type, both types must accrue in the same way, either by a fixed amount or by hours worked.

Accruals Based on a Fixed Amount Per Period

Accruals based on a fixed amount are always set up in time-off rules. When time-off types accrue by a fixed amount per period:

- Time off accrues after a fixed amount of time: weekly, biweekly, semi-monthly, monthly, or annually.
You set an annual entitlement for the time-off type. For example, employees might be entitled to two personal days in a year.

Accruals are calculated based on the annual entitlement divided by the number of accrual periods in a year.

For example, if time off accrues semi-monthly (or 24 times a year), and the annual entitlement is 15 days, the accrual amount per period = 15 ÷ 24.

Time off can accrue proactively (employees accrue time off for the period they are about to work) or retroactively (employees accrue time off for the period they have already worked).

Setting Up an Accrual Based on a Fixed Amount

To set up an accrual based on a fixed amount:

1. In the time-off rule, under Accrual Method, check the Automatically Accrue box.
2. From the Accrues Based On list, select Fixed Amount Per Period.
3. From the Accrual Type list, select whether time off accrues proactively or retroactively:

   - If employees accrue time off for the period they are about to work, select Proactive. Next, set the Minimum Tenure. If minimum tenure is set to zero, in the Opening Balance for New Employees field, choose one of the following:
     - Full Amount for Accrual Period — Employees' first accrual is the full amount specified for the accrual period, applied either on their start date or the first day they are eligible to accrue based on the rules defined in their plan.
     - Prorated Amount for Accrual Period — Employees' first accrual is a prorated amount based on the number of working days remaining in the accrual period, applied either on their start date or the first day they are eligible to accrue based on the rules defined in their plan.
     - Zero — Employees' first accrual takes place on the next regularly scheduled accrual date.

   - If employees accrue time off for the period they have already worked, select Retroactive.
4. In the Accrual Frequency field, choose when time off accrues.
   If you select Biweekly or Weekly as the accrual frequency, set the day of the next accrual. This determines the calendar day on which the accrual is applied.

   Note: Annual and monthly accruals occur on the first day of the year/month for proactive accruals and on the last day of the year/month for retroactive accruals. Semi-monthly accruals occur on the first and the 15th day of each month for proactive accruals, and on the 15th and the last day of each month for retroactive accruals.
5. In the Entitlement field, enter the number of days or hours that employees earn each year.
6. In the Entitlement Unit field, specify whether the entitlement is in days or hours.
   The Accrual Amount and Accrual Amount Unit fields display the accrual rate based on your selections.
7. To enable an accrual limit, check the Set Accrual Limit box, and then do the following:
   - In the Accrual Limit field, enter the maximum number of days that employees can accrue. For example, if you enter 15 days, your employees stop accruing time when they reach this limit. Employees start accruing time again when they use some of their accrued time.
   - The Accrual Limit Unit field displays the accrual limit rate based on your selections.
8. Click Save, or continue to Setting Up Balance and Carryover Limits in a Time-Off Rule.
Accruals Based on Hours Worked

Accruals based on hours worked can be set up in one of two ways, depending on whether you use SuitePeople U.S. Payroll in your account:

- If the Payroll feature is enabled and set up in your NetSuite account, you set up accruals on the Payroll > Accrued Time subtab of the employee record. For more information, see Time-Off Management Integration with SuitePeople U.S. Payroll.

**Note:** If you are setting up Time-Off Management for a subsidiary that does not use Payroll, accruals based on hours worked are not available.

- If the Payroll feature is not enabled in your account, you set up accruals in time-off rules. The rest of this topic describes this method.

When time-off types accrue by hours worked:

- The Time Tracking feature must be enabled.
- Accruals are calculated based on the hours that an employee works on approved time entries multiplied by an accrual rate.

For example, if the accrual rate is 0.04, and the approved time entry shows 20 hours worked, the accrual amount for the time entry = 20 x 0.04.

The following diagram shows how the Time Tracking feature and the Time-Off Management feature work together to calculate hourly accruals for an employee:

Setting Up an Accrual Based on Hours Worked

**To set up an accrual based on hours worked:**

1. In the time-off rule, under Accrual Method, check the Automatically Accrue box.
2. From the Accrues Based On list, select Hours Worked.
3. In the Hourly Accrual Rate field, enter the accrual rate.
4. To enable an accrual limit, check the **Set Accrual Limit** box, and then do the following:
   - In the **Maximum Accrual Limit** field, enter the maximum number of hours that employees can accrue. For example, if you enter 80 hours, employees stop accruing time when they reach this limit. Employees start accruing time again when they use some of their accrued time.
   
   The **Maximum Accrual Unit** field displays the accrual limit rate based on your selections.

5. Click **Save**, or continue to **Setting Up Balance and Carryover Limits in a Time-Off Rule**.

**Setting Up Balance and Carryover Limits in a Time-Off Rule**

The following diagram illustrates the process for setting up balance and carryover limits:
To set up balance and carryover limits:

1. In the time-off rule, set up how you want to manage carryover balances:
   - To deduct unused time off from an employee's balance so that it is not carried over into the next year, under Balance and Carryover Limits, clear the Allow Employees to Carry Over Unused Time-Off box.
   - To allow carryover, check the Allow Employees to Carry Over Unused Time-Off box. This is the default setting. Next, do the following:
     - To restrict how much unused time off can be added to next year's balance, check the Limit the Amount of Time-Off Employees Carry Over box, and then do the following:
       1. In the Maximum Carryover field, enter the maximum amount of time each employee is entitled to carry over.
       2. In the Maximum Carryover Unit field, select the unit of time for the maximum carryover field.

       For example, if employees are entitled to carry over 5 days, enter 5 in the Maximum Carryover field, and select Days in the Maximum Carryover Unit field.

     - To expire carried over time off after a specific period of time, check the Expire Unused Carryover box, and select which month the carried over time off should expire.

       For example, if you select March, employees have until the end of March to take this type of time off. If they do not book the time off before it expires, it is removed from their accrual and they can no longer use it.

       Note: If you select a date in the past, the expiry does not occur until the following year. Also, if you change a carryover expiry month from a future date to a past date (or vice versa), the change does not occur until the following year. The change takes effect in the current calendar year only if the expiry month is in the future.

     - To prevent employees from carrying over negative balances at the end of the year for this time-off type, check the Reset Negative Balances to Zero at Year End box.

     - To display expiry notification messages to employees in the Employee Center, check the Show Balance Expiry box. Notifications appear in the Employee Center when employees have time off that expires within the current or the next calendar month.

2. Click Save.

Deleting a Time-Off Rule

To delete a time-off rule:

1. Go to Setup > HR Information System > Time-Off Plan.
2. Beside the plan that contains the rule you want to delete, click Edit.
3. From the Time-Off Rule subtab, select Edit beside the time-off type from the rule you want to delete.
4. From the Actions menu, select Delete.
5. When prompted to confirm the deletion, click OK.
Assigning a Time-Off Plan to an Employee

When the Time-Off Management feature is enabled, a Time-Off subtab is added to your employee records. From here you can assign a time-off plan to your employees and look up their current time-off balances. Employees assigned to a time-off plan can submit time-off requests and look up their balances from the Employee Center for the time-off types they are eligible for, based on the rules defined in their plan. For more information about setting up the Time-Off Management feature, see Time-Off Management.

Before assigning a time-off plan to an employee:

- If you have not done so already, create an employee record for employees that you want to give access to time-off management. For more information on creating employee records, see Adding an Employee Record.
- Make sure employees have access to time-off management from the Employee Center. For more information, see About the Employee Center Role.

Important: If you use SuitePeople U.S. Payroll in your NetSuite account, see Updating the Employee Record for Time-Off Management and Payroll.

To assign a time-off plan to an employee:

1. Go to List > Employees > Employees.
2. On the Employees list, click Edit next to the employee you want to set up for time-off management.
3. In the Supervisor field, select the employee's supervisor. The supervisor receives any time-off requests that the employee submits.
4. Click the Time-Off subtab.
5. In the Time-Off Plan field, select the plan to assign to the employee. If the time-off plan does not appear, check that rules are assigned to the plan. For more information, see Time-Off Rules.
6. In the Start Date for Time-Off Calculations field, enter the date when you want to start time-off calculations for this employee. The date entered here is used to determine which time-off rule currently applies to the employee based on how long that employee has been with the company. This is different from the hire date on the employee record so that HR can manage when time-off milestones are reached for each employee.
   
   For example, if your company acquires another company, you might want to use the date that the acquired company's employees started working for the acquired company instead of the date of the acquisition.

   Note: If you change an employee's start date after the employee has been assigned to a time-off plan, all future accruals, carry over, and expiry are updated based on the new date.

7. Click the Human Resources subtab.
8. In the Work Calendar field, select a work calendar for the employee.
   
   When a work calendar is selected for time-off management, it:

   - tells the system which days are working days for the employee
   - blocks out the days that are not considered working days when an employee fills out a time-off request
• calculates the number of hours to deduct from the employee's balance when a day is taken off.
  
If no work calendar is selected, the system assumes that the employee works eight hours a day, Monday to Friday, with no holidays. For more information, see the help topic Setting Up a Work Calendar.

9. Click Save.

Time-Off Management Integration with SuitePeople U.S. Payroll

**Important:** This topic applies to you if you have SuitePeople U.S. Payroll in your account. If you are not using Payroll, follow the steps in Time-Off Management Setup to set up the Time-Off Management feature.

If SuitePeople U.S. Payroll is set up in your account, follow the steps in this section to set up the Time-Off Management feature. Time-Off Management and Payroll are interconnected features. They must work together so that time-off accruals and time-off balances are properly tracked. When accruals and balances are correct, your employees are paid correctly and they receive the time off that they are entitled to.

To make sure that accruals and balances are correct, the Time Tracking feature must also be enabled in your account. The diagram below illustrates how the Payroll, Time-Off Management, and Time Tracking features interact:

![Diagram showing the interaction between Payroll, Time-Off Management, and Time Tracking features.]

When an employee books time off, approved time off appears on the employee's timesheet. Approved time entries enter Payroll. Time-off types are associated with payroll items, which are shared with the Time-Off Management system. The employee's accruals are calculated in one of two ways:

- If time off accrues by a fixed amount in a period of time, the time-off system calculates accruals. The Time-Off Management system shares accruals with the payroll system so that proper amounts appear on employees' pay statements.
- If time off accrues on an hourly basis, Payroll calculates accruals. Payroll shares accruals with the Time-Off Management system so that time-off balances are accurate.

The process for setting up Time-Off Management with Payroll looks like this:
Time-Off Management Integration with SuitePeople U.S. Payroll

The following topics detail each step in the diagram:

1. Setting Up Payroll Items to Work with Time-Off Management
2. Associating a Time-Off Type with a Payroll Item
3. Creating a Time-Off Plan with Payroll
4. Setting Up a Time-Off Rule with Payroll
5. Updating the Employee Record for Time-Off Management and Payroll

View the following videos to see an example of how to set up Time-Off Management with Payroll:

- Integrating NetSuite Payroll with Time-Off Management – Part 1: Overview
- Integrating NetSuite Payroll with Time-Off Management – Part 4: Updating the Employee Record

Prerequisites for Integrating Time-Off Management with Payroll

**Important:** Be prepared to set up the Time-Off Management feature as soon as you enable it so that accruals in payroll can be calculated correctly.

Before you can set up the Time-Off Management feature with SuitePeople U.S. Payroll, the following must be completed:

- SuitePeople U.S. Payroll must be set up in your NetSuite account. If it is not set up in your account, contact NetSuite Customer Support. For more information, see the help topic Payroll Setup.
The Time Tracking feature must be enabled in your account. For more information, see Managing Time Tracking.

The Time-Off Management feature must be enabled.

**Important:** Be prepared to set up the Time-Off Management feature as soon as you enable it so that accruals in Payroll can be calculated correctly.

Work calendars must be assigned to your employees. For more information see Assigning Work Calendars to Employees.

Setting Up Payroll Items to Work with Time-Off Management

If you are using SuitePeople U.S. Payroll, then you already have payroll items set up in your NetSuite account. If you have payroll items set up for time off, view the payroll items, and make sure that the Item Type is set to Earning:Sick or Earning:Vacation.

If you do not already have payroll items set up for time off, use the following steps:

**To create a payroll item for time off:**

1. Go to Lists > Employees > Payroll Items > New.
2. For NetSuite OneWorld accounts, from the Subsidiary list, select a subsidiary.
3. From the Item Type list, select either Earning:Sick or Earning:Vacation.
4. In the Item Name field, enter a name for the payroll item. For example, "Personal Days" or "Vacation Time".
5. If necessary, select a Pay Code.
6. Click Save.

This payroll item will be associated with a time-off type in the step Associating a Time-Off Type with a Payroll Item.

Associating a Time-Off Type with a Payroll Item

When you are using SuitePeople U.S. Payroll and setting up Time-Off Management, you must associate time-off types with the payroll items that you created or updated in the step Setting Up Payroll Items to Work with Time-Off Management. Associating time-off types with payroll items ensures that:

- The system associates time entries with the correct payroll item. Time entries are used to track time-off usage against each payroll item, and employees who track time can see their booked time off on their timesheet.
- Accruals can be calculated based on hours worked. For more information on calculating accruals on an hourly basis, see Accruals Based on Fixed Amounts and Accruals Based on Hours Worked.

If you use Payroll for multiple subsidiaries in your NetSuite account, you must create separate time-off types for each subsidiary. You cannot use the same time-off type with multiple subsidiaries. Also, you must associate time-off types with payroll items that are associated with the same subsidiary.

For example, the subsidiaries Acme X and Acme Y both use Payroll. When you set up time-off types, you set up a type called Vacation X for Acme X and a type called Vacation Y for Acme Y. You also have a payroll item for Acme X called Vacation Pay X, and another payroll item for Acme Y called Vacation Pay Y. To make sure that your time-off types work with payroll, you should associate the time-off type Vacation X with the payroll item Vacation Pay X, and the time-off type Vacation Y with the payroll item Vacation Pay Y.
To create a time-off type that is associated with a payroll item:

1. Go to Setup > HR Information System > Time-Off Type > New.
2. In the Name field, enter a unique name for the type. The name specified here appears in time-off lists for time-off requests, time-off plans, and time-off changes.
   
   As a best practice, if you use Payroll for multiple subsidiaries, you should include the subsidiary name in the time-off type name. For example, for a subsidiary called Acme X, you might want to name the time-off type Vacation X.

3. In the Display Name field, enter how you want the time-off type name to appear to employees. For instance, you might have different time-off types for different subsidiaries, departments, or locations, but you want the type to appear the same to all employees.

4. To record usage without having an entitlement and accruing a positive balance, check the Track Only box.

   Note: When you change an existing time-off type to track-only, future accruals are not calculated. All balance entries prior to the change are saved and displayed in the time-off changes record. For more information, see Viewing an Employee’s Time-Off Balance.

5. Select a Payroll Item. This payroll item should be one that you created or updated in the step Setting Up Payroll Items to Work with Time-Off Management.
   
   If you use Payroll for multiple subsidiaries, make sure that you select a payroll item that applies to the subsidiary for this time-off type.

   Important: A time-off type can be associated with only one payroll item.

6. In the Minimum Increment and Increment Unit fields, specify the minimum increment of time-off required for this type. Time-off requests cannot be for less than this amount and must be multiples of this amount. Leave the field value at zero or blank to allow employees to enter any value.

7. From the color picker, select the color that you want to associate with this time-off type.

8. Click Save.

Creating a Time-Off Plan with Payroll

After you create time-off types and associate them with payroll items, you can create time-off plans. A time-off plan contains different time-off types and rules that you can assign to an employee. For example, a time-off plan could include vacation time, personal time, sick days, and bereavement days, with rules that specify how these types of time off accrue. You might have different plans for part-time employees than for full-time employees, or different plans for employees who are paid hourly and employees who are paid a salary. You can create as many plans as you need to fulfill the time-off policies of your organization. Each time-off plan contains time-off rules, which define entitlement for a time-off type and how that time-off type accrues within the plan. Before you proceed with creating a time-off plan, it is important to understand the difference between accruals based on fixed amounts and accruals based on hours worked.

Accruals Based on Fixed Amounts and Accruals Based on Hours Worked

When Time-Off Management and Payroll are integrated, time-off accruals can be automatically calculated in one of two ways:
Time-Off Management Integration with SuitePeople U.S. Payroll

<table>
<thead>
<tr>
<th>Fixed Amount Per Period</th>
<th>Hours Worked (NetSuite U.S. Payroll)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accruals are calculated based on a fixed amount (weekly, bi-weekly, monthly, semi-monthly, or annually).</td>
<td>Accruals are calculated based on the hours an employee works. This type of accrual might be appropriate for users who are paid hourly.</td>
</tr>
<tr>
<td>Time-Off Management calculates the accruals. You add the payroll items associated with each time-off type to the employee record in the Payroll &gt; Accrued Time subtab.</td>
<td>Payroll calculates the accruals.</td>
</tr>
<tr>
<td>When the payroll batch is calculated, accrual amounts and balances from Time-Off Management are included on employees’ pay statements, as of the period ending date. Time-off balances are also accurately represented in the Time-Off portlet in the Employee Center.</td>
<td>When the payroll batch is calculated, accrual amounts and balances from Payroll are included on employees’ pay statements, as of the period ending date. Time-off balances are also accurately represented in the Time-Off portlet in the Employee Center.</td>
</tr>
<tr>
<td>Payroll items for accruals with this option must be added to the employee record in the Payroll &gt; Accrued Time subtab. This ensures that the payroll items appear on employees’ pay statements.</td>
<td>Payroll items for accruals with this option must be set up on the employee record in the Payroll &gt; Accrued Time subtab. For more information, see Setting Up Accruals Based on Hours Worked on the Employee Record for Payroll.</td>
</tr>
<tr>
<td>Annual entitlement can reset at the beginning of any month</td>
<td>Annual entitlement must reset at the beginning of January.</td>
</tr>
<tr>
<td>Employees can carry over unused time-off, and you can set carryover expiry limits.</td>
<td>You can use the Accrued Time subtab on the employee record to specify whether employees can carry over unused time off. You cannot set carryover expiry limits.</td>
</tr>
</tbody>
</table>

For each time-off type that you are planning to use (that is, for each time-off type you created in Associating a Time-Off Type with a Payroll Item), decide which type of accrual works best with your time-off policies.

To create a time-off plan:

1. Go to Setup > HR Information System > Time-Off Plan > New.
2. In the Name field, enter a name for the time-off plan. This name appears wherever you are required to select a time-off plan, such as the employee record. Name the plan so that you or someone else in HR can easily pick the right plan to assign to each employee.
3. To included forecasted accruals through to the end of the year in the number of days available to an employee, check the Days Available Includes Future Accruals for the Year box. To include only time off that employees have accrued to date, clear the box.
4. From the Reset Annual Entitlement At the Start Of list, select the month when the entitlement period starts. The default setting is January.

**Important:** If you plan to add a time-off rule that includes a time-off type that will accrue based on hours worked, the Reset Annual Entitlement At the Start Of field must be set to January. For more information, see Accruals Based on Fixed Amounts and Accruals Based on Hours Worked.

5. If necessary, select a Subsidiary, Class, Department, or Location. You can assign this plan only to employees who are associated with the department, class, location, and subsidiary you set here. If you do not set a these fields, you can assign this plan to anyone.
6. Click Save.

After you save the plan, define the time-off rules. For more information, see Setting Up a Time-Off Rule with Payroll.
Setting Up a Time-Off Rule with Payroll

After you create a time-off plan, you must define and apply rules to the time-off plan. Time-off rules allow you to specify how you want employees to accumulate time off over a period of time. The image below depicts the process for setting up accruals in a time-off rule:

Creating a Time-Off Rule with Payroll

To create a time-off rule:

1. Go to Setup > HR Information System > Time-Off Plan.
2. Next to the plan that you want to define rules for, click **Edit**.
3. Click **New Time-Off Rule**.
4. In the **Time-Off Type** field, select the type of time off to apply to the plan. To integrate with Payroll, choose a time-off type that you created in **Associating a Time-Off Type with a Payroll Item**.
5. Specify the minimum tenure for this time-off type and whether the tenure is in months or years. Typically, minimum tenure is used to increase the amount of time off employees are entitled to over a specific period of time, but it can also be used to adjust an accrual or carryover rule at an employment milestone.

For example, you might want employees to start with 10 vacation days and then set an increase after five years of employment to 15 vacation days. To do this, you would add two time-off rules to the plan using the same time-off type. One rule would have a minimum tenure of zero with an entitlement of 10 vacation days, and the second rule would have a minimum tenure of five years with an entitlement of 15 vacation days.

**Note:** If you set a minimum tenure on a time-off rule, the associated payroll item appears on employee pay statements only after an employee has met the minimum tenure.

Next, set up accruals for the time-off rule, keeping in mind whether you want time-off types to accrue by a fixed amount or by hours worked:

- Setting Up an Accrual Based on a Fixed Amount with Payroll
- Setting Up an Accrual Based on Hours Worked with Payroll

For more information, see **Accruals Based on Fixed Amounts and Accruals Based on Hours Worked**.

### Setting Up an Accrual Based on a Fixed Amount with Payroll

These steps are continued from **Creating a Time-Off Rule with Payroll**.

**To set up an accrual based on a fixed amount:**

1. In the time-off rule, under **Accrual Method**, check the **Automatically Accrue** box.
2. From the **Accrues Based On** list, select **Fixed Amount Per Period**.
3. From the **Accrual Type** list, select whether you want to accrue time proactively or retroactively:
   - If employees accrue time off for the period they are about to work, select **Proactive**. Next, set the **Minimum Tenure**. If minimum tenure is set to zero, in the **Opening Balance for New Employees** field, choose one of the following:
     - **Full Amount for Accrual Period** — Employees' first accrual is the full amount specified for the accrual period, applied either on their start date or the first day they are eligible to accrue based on the rules defined in their plan.
     - **Prorated Amount for Accrual Period** — Employees' first accrual is a prorated amount based on the number of working days remaining in the accrual period, applied either on their start date or the first day they are eligible to accrue based on the rules defined in their plan.
     - **Zero** — Employees' first accrual takes place on the next regularly scheduled accrual date.
   - If employees accrue time off for the period they have already worked, select **Retroactive**.
4. In the **Accrual Frequency** field, choose when time off accrues.
   - If you select **Biweekly** or **Weekly** as the accrual frequency, set the day of the next accrual. This determines the calendar day on which the accrual is applied.
5. In the Entitlement field, enter the number of days or hours that employees earn each year.

6. In the Entitlement Unit list, select whether the entitlement is in days or hours.

   The Accrual Amount and Accrual Amount Unit fields display the accrual rate based on your selections.

7. To enable an accrual limit, check the Set Accrual Limit box, and then do the following:
   a. In the Accrual Limit field, enter the maximum number of days that employees can accrue. For example, if you enter 15 days, your employees stop accruing time when they reach this limit. Employees start accruing time again when they use some of their accrued time.

   The Accrual Limit Unit field displays the accrual limit rate based on your selections.

8. Set up how you want to manage carryover balances:
   ■ To deduct unused time off from an employee's balance so that it is not carried over into the next year, clear the Allow Employees to Carry Over Unused Time-Off box.
   ■ To allow carryover, check the Allow Employees to Carry Over Unused Time-Off box. Then do the following:
     □ To restrict how much unused time off can be added to the next year's balance, check the Limit the Amount of Time-Off Employees Carry Over box, and then do the following:
       1. In the Maximum Carryover field, enter the maximum amount of time off that each employee is entitled to carry over.
       2. In the Maximum Carryover Unit field, select the unit of time for the maximum carryover field.

       For example, if employees are entitled to carry over 5 days, enter 5 in the Maximum Carryover field, and select Days in the Maximum Carryover Unit field.

     □ To expire carried over time off after a specific period of time, check the Expire Unused Carryover box, and select which month the carried over time off should expire.

       For example, if you select March, employees have up until the end of March to take this type of time off. If they do not book the time before it expires, it is removed from their plan and they are no longer able to use it.

9. Click Save.

Continue to Updating the Employee Record for Time-Off Management and Payroll.
Setting Up an Accrual Based on Hours Worked with Payroll

These steps are continued from Creating a Time-Off Rule with Payroll.

To set up an accrual based on hours worked:

1. In the time-off rule, under Accrual Method, check the Automatically Accrue box.
2. From the Accrues Based On list, select Hours Worked (NetSuite U.S. Payroll).
3. Click Save.

Continue to Updating the Employee Record for Time-Off Management and Payroll.

Updating the Employee Record for Time-Off Management and Payroll

After you create time-off rules in your time-off plans, you must assign a time-off plan to each of your employees. If some of your time-off plans include accruals based on hours worked, then you must set up those accruals on the employee record.

Assigning a Time-Off Plan to an Employee

To assign a time-off plan to an employee:

1. Go to Lists > Employees > Employees.
2. Beside an employee, click Edit.
3. In the Time-Off subtab, select a plan from the Time-Off Plan list.
4. In the Start Date for Time-Off Calculations field, enter the start date for the purpose of time-off calculations. The date entered here is used to calculate the number of days that this employee is entitled to time off based on the minimum and maximum tenures set within the time-off plan. If there is no value specified in this field, this employee cannot be assigned to a time-off plan.
5. Click Save.

Adding Payroll Items to the Employee Record

To ensure that payroll items that are associated with a time-off type appear on employees' pay statements, you must add the payroll items to each applicable employee record.

Important: Payroll items that accrue based on hours worked require additional setup. For more information, see Setting Up Accruals Based on Hours Worked on the Employee Record for Payroll.

To add payroll items to the employee record:

1. Go to Lists > Employees > Employees.
2. Beside an employee, click Edit.
3. Click the Payroll subtab, and then click the Accrued Time subtab.
4. In the Sick/Vacation Time list, select a payroll item.
5. Click Save.
When a payroll item is associated with a time-off type that, according to the rules defined in the time-off plan, accrues based on a fixed amount, the accrual appears on the employee's pay statement, but not in the Accrued Hours field on the Accrued Time subtab.

Setting Up Accruals Based on Hours Worked on the Employee Record for Payroll

You must set up accrual rates for payroll items that accrue based on hours worked on each applicable employee record.

To set up accruals based on hours worked for an employee:

1. Go to Lists > Employees > Employees.
2. Beside an employee, click Edit.
3. Click the Payroll subtab, and then click the Accrued Time subtab.
4. In the Sick/Vacation Time list, select a payroll item that accrues by hours worked (in the associated time-off rule for the payroll item, the Accrues Based On field is set to Hours Worked (NetSuite U.S. Payroll)).
   For example, you might have associated a time-off type with a payroll item called PTO — Vacation.
5. In the Accrued Hours field, enter a beginning balance if the employee has accrued time that is not in the system.
   After the beginning balance is set, the system keeps track of this total.
6. In the Accrue As list, select Per Hour Worked.
   Warning: Selecting an option other than Per Hour Worked in the Accrue As list could result in inaccurate accrual balances on the employee's pay statement.
7. In the Accrual Rate field, enter the number of hours this employee accrues for each hour worked (for example, 0.04).
8. In the Monetary Rate field, enter the cost per hour of the accrued time.
9. Depending on whether your time-off policy allows carryover, do one of the following:
   - If you do not allow employees to carry over unused time off, check the Reset at Year End box.
     At the end of each calendar year, NetSuite sets the total accruals to zero and begins calculations again.
   - If you allow employees to carry over unused time off, do not check the Reset at Year End box.
10. If your company sets a limit for accrued time, in the Maximum Hours field, enter the maximum number of hours that can be accrued.
11. Click Save.

When a payroll item is associated with a time-off type that, according to the rules defined in a time-off plan, accrues based on hours worked, the employee's accrual appears on both the Accrued Hours field and the pay statement.

Viewing an Employee’s Time-Off Balance

To view an employee's time-off balance, go to Lists > Employees > Employees. On the Employees list, click View next to the employee whose time-off balance you want to check. Click the Time-Off subtab to view a summary of an employee's time-off balance for the entire year.
The **Available Now** subtab displays how much time off an employee has left, and how much they have used and scheduled for the current year.

The Available Now subtab includes:

- **Available This Year** — When the Days Available Includes Future Accruals box on the Time-Off Plan page is checked, includes all future accruals and manual increases and decreases for the current year. For more information, see Time-Off Plans.
- **Used This Year** — The amount of time off that has been used as of the current date.
- **Scheduled This Year** — The amount of time off that has been requested and approved, but not yet taken.
- **Available Now** — Total remaining time off for the current year.

The **Balances** subtab displays an employee's available balance as of the current date, based on the accruals and carry over rules defined in the time-off plan.

The Balances subtab includes:

- **Carried Over** — The amount of time off that has carried over as of the current date.
- **Accrued** — The amount of time off that has accrued as of the current date.
- **Used** — The amount of used time off.
- **Expired Carryover** — The amount of time off that has expired as of the current date.
- **Balance** — Displays the balance as of the current date based on the amount of time carried over, accrued, used, and any expired carry over.

### Time-Off Changes

When an employee accrues time off, when an employee uses time off, or when time-off expires or is carried over, NetSuite creates a time-off change record. If you need to make a change to an employee's time-off balance, you can create or adjust a time-off change record.

Learn more in the following topics:

- Viewing Time-Off Changes
- Creating a Time-Off Change

### Viewing Time-Off Changes

The Time-Off Changes page displays a list view of all the time-off change records for the employees at your company. Time-off changes are created when time-off requests are approved, when manual adjustments are made, when carryover is applied, when time off expires, and when automatic accruals are calculated. Each of these changes are individually recorded so that you can distinguish between different types.

**To view time-off changes:**

1. Go to Setup > HR Information System > Time-Off Change.
   The Time-Off Change page displays a list of all time-off changes, sorted by most recent changes.

2. To filter the list of time-off changes, expand the Filters section, and try the following:
   - To find time-off changes for a specific employee, from the Employee list, select the employee.
   - To make multiple selections, hold down the Ctrl key.
Creating a Time-Off Change

You can manually adjust an employee's time-off balance for any of the time-off types that are part of the employee's plan. If needed, you can correct mistakes to time-off balances by either deleting the existing time-off change and submitting a new one, or submitting a new time-off change with the required adjustment. You often need to create or edit a time-off change if an approved time entry is edited.

You cannot create a time-off change for yourself or makes adjustments to your own time-off balance.

To adjust an employee's time-off balance:

1. Go to Setup > HR Information System > Time-Off Change > New.
2. Select the employee and the time-off type that you want to make the adjustments to.
3. In the Amount field, enter either a negative or positive value.
4. In the Amount Specified In field, specify if this amount is in hours or days.
   Note that even when days is selected the amount is saved and displayed in hours on the time-off change record. For example, if you enter two days, it appears as 16 hours on the record when the employee's work calendar is set to an eight-hour work day. For more information, see the help topic Setting Up a Work Calendar.
5. Enter the date when you want to apply this change.
6. If required, enter a description.
7. Click Save.

To delete a time-off change, go to Setup > HR Information System > Time-Off Change to see the list page of all the time-off change records. Click Edit next to the time-off change record you want to delete. Choose Actions > Delete. At the prompt, click OK to confirm the action.

Approving or Rejecting a Time-Off Request as an Administrator

To approve or reject a time-off request:

1. Go to Setup > HR Information System > Time-Off Request.
2. Select View beside the time-off request that you want to approve or reject.
3. To approve the request, click Approve.
4. To reject the request, click Reject. Optionally, enter a reason for the rejection, and then click OK.

Rejecting an Approved Time-Off Request

Employees might submit a time-off request that is approved by their manager or an administrator, and then later decide to work during that time or part of that time. In many cases, you can reject the time-off request to accurately update the employee's available time-off balance. If you are using SuitePeople U.S. Payroll, however, rejecting an approved time-off request might require that you complete additional steps.

The image below depicts the different scenarios for rejecting an approved time-off request when you are using Payroll.

```
As indicated in the image above, if the time-off type is not associated with a payroll item or if the payroll batch that the time entry appears on has not yet been calculated, you can reject the time-off request. However, if the time entry for the time-off request appears on a calculated or a committed payroll batch, you must complete other tasks to accurately reject the time-off request.
```

Time-Off Requests that Appear on a Calculated Payroll Batch

**To reject an approved time-off request that appears on a calculated payroll batch:**

1. Remove the employee's paycheck from the payroll batch. See the help topic Removing Paychecks from a Batch.
2. Reject the time-off request. See Approving or Rejecting a Time-Off Request as an Administrator.
3. Add the employee back to the payroll batch. See the help topic Adding Employees to a Payroll Batch.

Employee Management
Approving or Rejecting a Time-Off Request as an Administrator

4. Calculate the payroll batch again. See the help topic Calculating a Payroll Batch.

Time-Off Requests that Appear on a Committed Payroll Batch

To reject an approved time-off request that appears on a committed payroll batch:

1. Reject the time-off request. See Approving or Rejecting a Time-Off Request as an Administrator.
2. If the employee took time off for a portion of the original time-off request, do the following:
   a. Ask the employee to create a new time-off request that includes only the actual time off that the employee took.
   b. Approve the time-off request.
3. Set the associated time entry for the original time-off request to zero (0):
   a. Do one of the following:
      ■ If you are using the Time Tracking feature, go to Transactions > Employees > Track Time > Lists.
      ■ If you are using the Weekly Timesheet feature, go to Transactions > Employees > Weekly Timesheet > List.
   b. Beside the time entry or time sheet that needs to be updated, click Edit.
   c. Do one of the following:
      ■ If you are using the Time Tracking feature, in the Duration field, enter 0.
      ■ If you are using the Weekly Timesheet feature, find the entry for the time-off request, and set it to 0.
4. If applicable, add the employee's actual hours worked to the time entry. For example, if the employee worked the full day, you might add 8 hours for the payroll item "Regular Earnings". Save the time entry.

   For more information about creating time entries, see Weekly Time Tracking or Weekly Timesheets.
5. When you create the next payroll batch, you might need to perform a payroll adjustment to make sure that the monetary value associated with the time-off type is accurately updated on the pay statement. For more information, see the help topic Creating Payroll Adjustments.

Time-Off Management for Employees or Managers

With the NetSuite Time-Off Management feature, you can get approval for time off before you take it. You can create and submit time-off requests from the Book Time Off button on the Time-Off portlet on the Employee Center home page. The types of time off and the rules that apply to your time-off plan are based on your company policies, and are set up by your HR administrator. After you submit a time-off request, an email notification is sent to the approver.

Note: To use time-off management as an employee or manager, you must use your Employee Center role.

Submitting Time-Off Requests

View the Requesting Time-Off video.
To submit a time-off request:

1. From the home page of your Employee Center, in the Time-Off portlet, click Home.
2. Click Request Time-Off.
3. On the Request Time-Off page, specify the start and end dates for your time-off request.
   You cannot enter time off for days that are not a part of your work week. Non-working days and approved whole day requests are grayed out and cannot be selected.
   After you specify the date range using the calendar, each day is displayed in chronological order.

4. For each date in your request, select the type of time off you are requesting. If the time-off type you select has multiple days available, the corresponding date entries in the list are automatically filled for you.
   For example, if you select Vacation with three days available, the first three days in the list are tagged as vacation days.
   You can also use a combination of time-off types for a time-off request. For example, you can specify that you want to use a combination of vacation days and floating holidays.
   The displayed days available takes into account time off that has already been approved for the year, but that you have not taken.
If the time-off type is tagged as track only, no time off is accumulated, and your usage is only tracked. For example, if you have no limit to the number of sick days that you can take, the sick day time-off type is tagged as track only.

**Note:** If your company allows you to carry over unused time and you are booking time off for next year, you do not see your carryover balance in the forecasted balance. Your carryover days are calculated at the end of the year to ensure you do not overbook your time off for next year.

5. To change a time-off type or to adjust the duration of the time off, click the **Edit** icon beside the entry that you want to change. Make any required changes in the popup window that appears, and click **Done**.

If your request exceeds the days you have available, a warning icon appears beside the request. If your request overlaps with another employee's request, a notification icon appears beside the request. Neither of these icons prevent you from submitting your request. For more information, hover over the icon, and make any necessary changes.
6. Optionally, you can include a message to your approver.

7. Review the summary box for a breakdown of your request, and then click Submit.

A request is sent by email to your approver. To view the status of your time-off request, in the Time-Off portlet, click Requests. For more information, see Viewing Time-Off Requests.

Viewing Time-Off Requests

To view time-off requests:

1. From the home page of your Employee Center, in the Time-Off portlet, click Requests.
2. To see more time-off requests, in the portlet, click View All Requests.
3. On the Time-Off Request page, you can:
   - See the current status of the request, as well as who submitted it, the date range, and the time-off types used for the request.
   - Use the Filters section to find a specific time-off request, or view a history of requests for a specific employee, or a specific status. To make multiple selections, hold down the Ctrl key.
   - Click View beside a time-off request to see the original request.
4. To export the information, in the header row above the list, click one of the following icons:
   - the CSV Export icon
5. To print the list of time-off requests, click the Printer icon.

Viewing Time-Off Balances

From the Time–Off portlet in the Employee Center, you can see a summary of time-off balances, pending requests, and any upcoming booked time-off for yourself. If your role has the appropriate permission, you can also view time-off information for your subordinates.

Note: Your time-off balances are view only and cannot be edited. If you see something that is incorrect, contact your HR administrator.

To view time-off balances:

1. From the home page of your Employee Center, in the Time-Off portlet, click Balances. By default, your balance is displayed in days.

   Tip: To view time-off balances in hours instead of days, click Switch to Hours.

2. To see a list of pending requests, upcoming time-off, and past time-off, or to view your balance in hours, click View Balance Details.

Approving or Rejecting Time-Off Requests

If your role has the appropriate permission, you receive an email notification when you have time-off requests that require approval. Using links in the body of the email, you can directly approve or reject the request.

View the Reviewing Time-Off Requests video.

Quickly Approving or Rejecting Time-Off Requests

To quickly approve or reject a time-off request:

1. Do one of the following:
From the home page of your Employee Center, in the Home Links portlet, under Time-Off, click Approve Time-Off Requests.

From the email notification, use the links to take action on the request:

- To approve the request, click Approve.
- To reject the request, click Reject. Optionally, enter a reason for the rejection, and then click OK.

A specific day in a multiple day time-off request cannot be rejected. The entire request will have to be rejected.

Rejected time-off requests cannot be resubmitted.

### Reviewing Details of a Specific Request

**To review details of a specific request before you approve it:**

You can view more details of a specific request, such as whether the employee has enough time-off balance for the request, by viewing a detailed summary of the request.

1. From the email notification, click View Record.
2. On the Request Time-Off page, review the details of the request.

**Tip:** On the Review Time-Off Requests page, if the request exceeds the employee's available days or conflicts with a holiday, a warning icon (⚠️) appears beside the request. If the request overlaps with another employee's time-off request, a notification icon appears beside the request. For more information, hover over the icon.

3. Click Approve, Reject, or Cancel.
   
   If you click Reject, you are prompted to enter a comment, which is sent to the employee.
Viewing all Time-Off Requests Waiting for Approval

To view all time-off requests waiting for approval:

1. From the home page of your Employee Center, in the Home Links portlet, under Time-Off, click Approve Time-Off Requests.

   Tip: On the Review Time-Off Requests page, if the request exceeds the employee's available days or conflicts with a holiday, a warning icon (▲) appears beside the request. If the request overlaps with another employee's time-off request, a notification icon appears beside the request. For more information, hover over the icon.

2. Do one of the following:
   - To approve a request, click Approve.
   - To reject a request, click View Request, and then click Reject. You are prompted to enter a comment, which is sent to the employee.

   Note: A rejected request cannot be resubmitted.

Canceling Time-Off Requests

After you submit a time-off request, you can cancel future dated pending and approved time-off requests.
To cancel a time-off request:

1. From the home page of your Employee Center, in the **Time-Off** portlet, click **Requests**.
2. Select the time-off request that you want to cancel.
3. Click **Cancel Request**.

### Time-Off Reports

The Time-Off Management feature includes a variety of reporting capabilities and saved searches that you can use to retrieve, present, and analyze your time-off data:

- Available Time-Off Report
- Time-Off Balance Summary Report
- Time-Off Balance Details Report
- Time-Off Tracking Reports
- Time-Off Management Ad Hoc Reports

For more information, see the help topic **Reporting Overview**.

### Time-Off Management Ad Hoc Reports

You can create ad hoc reports to fit the specific needs of your company. For an ad hoc report, you select the type of data you want to report on, the format of the report, and how you want to subtotal and group the information displayed on the report.

To create a report, go to , and then choose the data metric to include in your report. For Time-Off Management, the two available metrics are Available Time-Off and Time-Off Balance Adjustments.

For more information, see the help topics **Ad Hoc Reports** and **Choices for Ad Hoc Reports**.

---

**Note:** Approved time-off requests that are associated with a locked timesheet cannot be canceled.
Compensation Tracking

With the Compensation Tracking feature, you can track employees' base pay and bonuses. When this feature is enabled, the Compensation Tracking tab appears on the employee record.

If you use SuitePeople U.S. Payroll, the wage and salary information that you enter in the Compensation Tracking tab can be copied to Payroll. This way, when an employee's compensation information changes, you update the information in only one place. As well, bonuses that you enter in the Compensation Tracking tab can be included in payroll batches for the appropriate pay periods. For more information, see Integrating Employees' Base Pay Information with Payroll and Integrating Bonuses with Payroll.

For information about the permissions required to use the Compensation Tracking feature, see Compensation Tracking Permission Requirements.

Compensation Tracking Setup

To set up the Compensation Tracking feature, you need to enable the feature, integrate the feature with SuitePeople U.S. Payroll (if applicable), and create bonus types.

Enabling the Compensation Tracking Feature

The Compensation Tracking feature requires SuitePeople HR. For more information about SuitePeople, see SuitePeople Overview. If your account is set up for SuitePeople HR, you can enable the Compensation Tracking feature.

To enable the Compensation Tracking feature:

1. Go to Setup > Company > Enable Features.
2. Click the Employees subtab.
3. Check the Compensation Tracking box.
4. Click Save.

Integrating Employees' Base Pay Information with Payroll

When both the Payroll and the Compensation Tracking features are enabled, compensation integration options appear on the Set Up Payroll (Setup > Payroll > Set Up Payroll) page. With these options, you can synchronize employees' base pay information with SuitePeople U.S. Payroll. After you update an employee's salary or wage on the Compensation Tracking Subtab of the employee record, the base wage type and amount are copied to the Payroll subtab.

To use Payroll with Compensation Tracking, make sure you do the following:

- Assign a primary payroll item to each employee who is already included in Payroll. If more than one payroll item is associated with an employee, the Compensation Tracking feature updates the primary payroll item with base compensation information. You can set the primary payroll item in the Earnings subtab of the Payroll subtab on the employee record. For more information, see the help topic Setting Up Earnings for an Employee.
- Set a default salary payroll item and a default wage payroll item. Default payroll items are used for one of two reasons:
  - When an employee's pay type is changed from salary to wage or from wage to salary in Compensation Tracking
  - When a wage or salary payroll item is not already associated with the employee
If default payroll items are not set up, your employees might not be paid correctly.

**To integrate employees’ base pay information with Payroll:**

1. Go to .
2. On the **Compensation Integration** subtab, check the **Copy Compensation Tracking Data to Payroll** box.
3. In the **Default Salary Payroll Item** list, select a default salary payroll item.
4. In the **Default Wage Payroll Item** list, select a default wage payroll item.
5. Click **Save**.

**Integrating Bonuses with Payroll**

If you use SuitePeople U.S. Payroll, you can pay bonuses to employees when you create payroll batches. To ensure that bonuses that you track with the Compensation Tracking feature are included in payroll batches, you need to:

- Create bonus payroll items
- Assign the payroll items to employees
- Create bonus types and associate bonus payroll items with bonus types
- Include bonuses in payroll batches

Throughout these steps, you also need to update payroll information.

**To integrate bonuses with payroll:**

1. Create a bonus payroll item using the payroll item type **Earning:Addition**. For more information, see the help topics **Payroll Item Types** and **Creating Payroll Items**.
2. Create a bonus type that you associate with the bonus payroll item. For more information, see **Creating Bonus Types**.
3. To commit your updates to the Payroll server, update payroll information. For more information, see the help topic **Updating Payroll Information**.
4. Assign the bonus payroll item to the appropriate employees.
   a. Go to Lists > Employees > Payroll Items.
   b. In the list, beside the bonus payroll item that you created, click **Edit**.
   c. In the **Employees** table, beside each employee who should have the payroll item, check the **Apply** box.
      
      **Note:** Each of these employees must be included in Payroll. For more information, see the help topic **Including an Employee in Payroll**.
   d. Enter an **Effective Date** and an **Expiration Date** for each applicable employee.
   e. Leave the **Rate** fields blank.
   f. Click **Save**.
5. To commit your updates to the Payroll server, update payroll information again. For more information, see the help topic **Updating Payroll Information**.
6. To make sure that Bonuses are included in payroll batches, on a payroll batch, check the **Pay Bonuses** box. For more information, see the help topic **Selecting Payment Options for a Payroll Batch**.
Creating Bonus Types

Before you can create bonuses, you need to define the bonus types that your organization uses. For example, you might have merit bonuses, spot bonuses, sign-on bonuses, or holiday bonuses.

If you want to use SuitePeople U.S. Payroll to pay bonuses to employees, you need to associate a bonus type with a payroll item. If some of your employees are included in SuitePeople U.S. Payroll and other employees are not, you should create separate bonus types for Payroll. For example, you might create one bonus type called Spot Bonus - Payroll and another called Spot Bonus.

To create a bonus type:

1. Go to Setup > HR Information System > Bonus Type > New.
2. In the Name field, enter a name for the bonus type. Each bonus type must have a unique name.
3. In the Subsidiary field, select the subsidiary that can use this bonus type.
4. If applicable, in the Payroll Item list, select a payroll item to associate with this bonus type.

Note: You add a payroll item only to bonus types that apply to employees who are included in SuitePeople U.S. Payroll. If some of your employees are included in Payroll, and others are paid with a separate payroll solution, then you should create separate bonus types.

5. Click Save.

Note: If you are using SuitePeople U.S. Payroll, the payroll item that is associated with the bonus type must be assigned to employees who are eligible for the bonus type. For more information, see Integrating Bonuses with Payroll.

Recording Base Pay Compensation for an Employee

Base pay compensation includes an employee's regular salary or wage earnings.

Important: If base pay information is integrated with SuitePeople U.S. Payroll, before you make updates to base pay fields, make sure that you have permission to edit the fields in the Payroll > Earnings subtab on the employee record. If you do not have permission to edit the fields in the Payroll > Earnings subtab, changes that you make to the Compensation Tracking fields are not copied to Payroll. This could result in incorrect payments to employees.

To track an employee's base pay compensation:

1. Go to Lists > Employees > Employees.
2. Beside an employee, click Edit.
3. Click the Compensation Tracking subtab.
4. Enter the employee's base pay information. You must enter values into all base pay fields:
Recording Base Pay Compensation for an Employee

1. From the **Base Wage Type** list, select the base wage type. Selections include annual salary, hourly, and monthly salary.

   - **Note:** If base pay information is integrated with SuitePeople U.S. Payroll, and if the employee is included in payroll, the value in the **Base Wage Type** list is copied to the **Compensation Type** field on the Payroll subtab. This value cannot be edited.

2. From the **Compensation Currency** list, select the currency to use.

   - **Note:** If base pay information is integrated with SuitePeople U.S. Payroll, and if the employee is included in payroll, the currency is set to U.S. Dollars (USD) and cannot be edited.

3. In the **Base Wage** field, enter the employee’s base wage.

   5. Click **Save**.

Entering a Bonus Target for an Employee

With bonus targets, you can track employees’ bonus eligibility. For example, some employees might be eligible for a bonus that is 10 percent of their annual salary, one time a year, so their bonus target is 10 percent, and their target frequency is annually.

Bonus targets are for tracking purposes. Bonus targets do not impact the amount that you award in an actual bonus or bonuses that are paid using SuitePeople U.S. Payroll.

**To enter bonus targets for an employee:**

1. Go to Lists > Employees > Employees.
2. Beside an employee, click **Edit**.
3. Click the **Compensation Tracking** subtab.
4. In the **Bonus Target** field, enter a numeric value for the bonus target.
   
   For example, if the bonus target is 10 percent, enter 10. If the bonus target is $10,000, enter 10,000.

5. In the **Target Type** list, select **Percentage** or **Amount**.

   For example, if the bonus target is 10 percent, enter 10 in the Bonus Target field and select Percentage from the Target Type list. If the bonus target is a specific amount, enter the amount in the Bonus Target field and select Amount from the Target Type list.

6. In the **Target Frequency** list, select how often this bonus could be awarded to the employee. You can choose from one time, annually, monthly, or quarterly.

7. To include additional relevant information about the employee’s bonus target, enter comments in the **Comments** field.

8. Click **Save**.

Awarding a Bonus to an Employee

When you award a bonus to an employee, you either track the bonus in NetSuite and pay the bonus using another system, or pay the bonus using SuitePeople U.S. Payroll.
To award a bonus to an employee:

1. Go to Lists > Employees > Employees.
2. Click an employee.
3. Click the Compensation Tracking subtab.
4. Click Award Bonus.
5. From the Bonus Type list, select a bonus type.

   **Note:** To pay the bonus using SuitePeople U.S. Payroll, select a bonus type that is associated with a payroll item. For more information, see Creating Bonus Types.

6. Enter the bonus amount either as a Percentage of the employee's base wage or as a specific Amount.

   The currency is set to the employee's current compensation currency. The percentage is based on the employee's current base wage. If the employee's base wage changes before the award date, the bonus amount does not change.

   **Note:** If the employee's base wage type is hourly, the Percentage option is not available.

7. In the Award Date field, enter the date when the employee should receive the bonus.

   If you are using SuitePeople U.S. Payroll to pay this bonus, the bonus is included on a payroll batch when the award date is within the payroll batch's pay period.

   **Note:** If an employee is terminated before than the award date, the bonus is not included in the corresponding payroll batch, even if other payments are made to the employee.

8. If applicable, from the Payment Status list, select a payment status that applies to the bonus:
   - **None** – This is the default status. Use this status if you do not track payment statuses.
   - **Ready to Pay** – You are ready to pay this bonus to the employee.
   - **Processing Payment** – Your payroll system is processing the bonus payment.
   - **Paid** – The employee has received the bonus payment.
   - **Canceled** – The bonus has been canceled and will not be paid.

   Payment statuses are not available for bonuses that will be paid with SuitePeople U.S. Payroll.

9. To include additional relevant information about the employee's bonus, enter comments in the Comments field.
10. Click Save.

### Editing a Bonus

If a bonus is not paid using using SuitePeople U.S. Payroll, you can edit the bonus percentage, amount, award date, payment status, or comments. You cannot edit the employee or the bonus type.

If a bonus is paid using SuitePeople U.S. Payroll, you cannot edit the bonus. If you included a bonus in a payroll batch in error, then you might need to revert the payroll batch and then cancel the bonus. For more information, see the help topics Creating a Payroll Reversal and Canceling a Bonus that is in a Reversed Payroll Batch.

To edit a bonus:

1. Go to Lists > Employees > Employees.
2. Beside an employee, click **Edit**.
3. Click the **Compensation Tracking** subtab.
4. In the Bonuses section, click the number beside a bonus.
5. Make any changes.
6. Click **Save**.

### Deleting a Bonus

If you are using SuitePeople U.S. Payroll to pay a bonus, you can delete a bonus only if it is **not** included in a payroll batch.

If you are not using SuitePeople U.S. Payroll to pay a bonus, you can delete the bonus at any time.

**To delete a bonus:**

1. Go to Lists > Employees > Employees.
2. Beside an employee, click **Edit**.
3. Click the **Compensation Tracking** subtab.
4. In the Bonuses section, click the number beside a bonus.
5. From the Actions menu, click **Delete**.

### Canceling a Bonus that is in a Reversed Payroll Batch

If a bonus is included in a reversed payroll batch, by default, SuitePeople U.S. Payroll includes the bonus in the next payroll batch. If you do not want to include the bonus in the next payroll batch, you can cancel the bonus. You cannot undo this action.

**To cancel a bonus from a reversed payroll batch:**

1. Go to Lists > Employees > Employees.
2. Beside an employee, click **Edit**.
3. Click the **Compensation Tracking** subtab.
4. In the Bonuses section, click the number beside a bonus.
5. From the Actions menu, click **Exclude From Payroll**.
6. Read the confirmation dialog. If you still want to cancel the bonus, click **OK**.
Job Management

The Job Management feature enables you to organize your employees according to the jobs that they perform.

There are two features that make up job management:

- **Job Management** — Enables you to create jobs with job descriptions and assign employees to them. For details, see Managing Jobs.
- **Job Requisitions** — Enables you to create job requisitions for recruiting, associate them with jobs that you have defined, and track their status through the hiring process. For details, see Job Requisitions.

A job is a description of what work and responsibilities an employee could have. A job can exist in several departments, locations, and subsidiaries. You can assign several employees to one job.

Depending upon the level of complexity your organization requires, you can choose to use the Job Management feature alone, or couple it with Job Requisitions.

Here are some notes highlighting how these features interact:

- The Job Requisition feature requires that the Job Management feature be enabled.
- When you enable the Job Management feature, any job names that exist in the **Job Title** fields on the employees' records are converted to job records. If you later decide to disable the Job Management feature, job names in the job records are converted back to text in the employees' **Job Title** fields.

Job Management and Job Requisitions Prerequisites

To use the Job Management and Job Requisitions features the following permissions are required:

- The List > Employees permission is required at a minimum level of Edit for both Job Management and Job Requisitions.
- To use Job Management the List > Job Management permission is required at a minimum level of Create.
- To use Job Requisitions the List > Job Requisitions permission is required at a minimum level of Create.

For details about the permission requirements, see Job Management and Job Requisitions Permission Requirements.

The standard roles that come with these permissions are HR Generalist, Administrator, and Chief People Officer (CPO).

You can also create custom roles that include this permission. For more information, see the help topic Customizing or Creating NetSuite Roles.
Managing Jobs

Job records enable you to store and maintain information about each of the jobs in your organization. A job is a description of what work and responsibilities an employee could have. A job can exist in several departments, locations, and subsidiaries. If you are using the Job Management feature alone, you assign jobs to employees.

Adding or Editing Jobs

To add or edit a job:

1. Go to Setup > HR Information System > Jobs > New, or click New Job on the Jobs list page. To modify the details of an existing job record, go to Setup > HR Information System > Jobs and click Edit next to the name of the job.
2. In the Title field, enter a name for the job.
3. In the Description field, enter a short unique description for the job.
4. Select the category (Full-time, Part-time) from the Employment Category list.
5. If this is a OneWorld account, select the subsidiary in which this job will exist from the Subsidiary list.
6. If you want this job to be inactive, check the Job is Inactive box. This affects how the job appears on the Jobs list.
7. Click Save.

Viewing the List of Jobs

To view the list of jobs:

1. Go to Setup > HR Information System > Jobs.
2. To see all inactive job records, check the Show Inactives box.
3. To view an individual job record, click View beside the job.

Deleting a Job

To delete a job:

1. Go to Setup > HR Information System > Jobs.
2. Click Edit beside the job you want to delete.
3. Select **Delete** from the **Actions** menu.
4. When prompted to confirm the deletion, click **OK**.

When you attempt to delete a job with one or more employees assigned to it you are redirected to the dependent records page, which lists all the employees currently assigned to the job. Each employee must be unassigned from the job before it can be deleted.

**Assigning Employees to Jobs**

If you are using the Job Management feature, you can assign employees to jobs. A job is a description of what work and responsibilities an employee could have. A job can exist in several departments, locations, and subsidiaries.

**To assign an employee to a job:**

1. Go to Lists > Employees > Employees.
2. Click **Edit** beside the employee you want to assign a job to.
3. Select a job from the **Job** list found in the primary information section of the employee record page.
4. If you are using both the Job Management and Position Management features, click the **Human Resources > Job** subtab, select **Job** under Work Assignment, and select a job from the **Job** list. To create a new job from this page, click **New**. For more information about creating a job, see Adding or Editing Jobs.

   **Note:** When an employee is assigned a job you can directly access the associated record by clicking the **Job Title** field from the employee record.

5. Click **Save**.

**Job Requisitions**

If you are using the Job Management feature, you can also enable the Job Requisition feature to create job requisitions and associate them with jobs.

**Creating a Job Requisition**

**To create a job requisition:**

1. Go to Setup > HR Information System > Job Requisitions > New, or click **New Job Requisition** on the Job Requisition list page. To modify the details of an existing job requisition, go to Setup > HR Information System > Job Requisition, and click **Edit** beside the name of the job requisition.
2. Select the job associated with this job requisition from the **Job** list. The **Title**, **Job Description**, and **Posting Description** fields are populated from the job description for the selected job. The **Job Description** field is read-only, but you can edit the **Title** and the **Posting Description**. The **Posting Description** is the description used for external job postings.

   **Note:** The **Posting Description** is the description used for external job postings.

3. Select a status for the job requisition from the **Status** list: **Pending Approval**, **Draft**, **On-Hold**, **Open**, **Closed**, or **Filled**.
4. In the **Headcount** field, enter the number of employees you need in order to fill this job requisition.
5. Select whether the job requisition posting is internal, external, or both from the **Posting Type** list.
6. If you have a OneWorld account, select the **Subsidiary** from the list.
7. Select the **Department, Location, and Class** for the job requisition from the lists.
8. Select the date when this job requisition becomes open from the **Open Date** field.
9. Select the date when this job requisition expires from the **Close Date** field. This must be after the open date.
10. Select the anticipated target date by which this job requisition should be filled from the **Target Hire Date** field. This date must either be between the open date and close date, or on either of these dates.
11. Select the appropriate employees from the **Hiring Manager, Recruiter, and Approved By** lists.
12. If you want this job requisition to be inactive, check the **Inactive** box. This affects how the job requisition appears on the Job Requisition list.
13. Click **Save**.

**Viewing Job Requisitions**

**To view the list of job requisitions:**

1. Go to Setup > HR Information System > Job Requisitions.
2. To see all inactive job requisitions, check the **Show Inactives** box.
3. To view an individual job requisition record, click **View** beside the job.

**Deleting Job Requisitions**

**To delete a job requisition:**

1. Go to Setup > HR Information System > Job Requisitions.
2. Click **Edit** beside the job requisition you want to delete.
3. Select **Delete** from the Actions menu.
4. When prompted to complete the deletion, click **OK**.

To access job requisition saved searches, see Recruiting Reports.
Advanced Employee Permissions

This chapter includes the following help topics:

- Advanced Employee Permissions Overview
- Before Enabling the Advanced Employee Permissions Feature
- Advanced Employee Permissions and Standard NetSuite Roles
- Employee Self Permission Overview
- Employee Public Permission Overview
- Employee Confidential Permission Overview
- Employee Compensation Permission Overview
- Employee System Access Permission Overview
- Employee Administration Permission Overview
- Employee Record Full Permission Overview
- Advanced Employee Permissions Use Cases
- Setting Employee Access for Advanced Employee Permissions
- Custom Advanced Employee Permissions
- Custom Restrictions for Advanced Employee Permissions

Advanced Employee Permissions Overview

The Advanced Employee Permissions feature gives administrators more flexibility and control over which fields and sublists on the employee record are available to the role, based on the assigned employee permissions.

This feature includes the following permissions, which are automatically assigned to a set of standard NetSuite roles, except where otherwise noted. For details, see Advanced Employee Permissions and Standard NetSuite Roles.

- **Employee Self** – Roles with this permission have access to basic personal information about themselves on their employee record and through their Employee Center role by clicking My Profile under My Information. For details, see Employee Self Permission Overview.
- **Employee Public** – Roles with this permission have access to basic employee information, such as job title. For details, see Employee Public Permission Overview.
- **Employee Confidential** – Roles with this permission have access to a set of fields and sublists, such as the Billing Class field, and the Time-Off subtab. For details, see Employee Confidential Permission Overview.
- **Employee Compensation** – Roles with this permission have access to compensation information, such as base wage and base wage type. For details, see Employee Compensation Permission Overview.
- **Employee Administration** – Roles with this permission have access to basic employee information, plus a limited set of fields and sublists based on Class, Department, Location, and Subsidiary (CDLS). The Employee Administration permission is not automatically assigned to any roles when the feature is enabled. For details, see Employee Administration Permission Overview.
- **Employee System Access** – Roles with this permission can give users access to NetSuite and assign roles to users. The Employee System Access permission is not automatically assigned to any roles when the feature is enabled. For details, see Employee System Access Permission Overview.

- **Employee Record Full** – Roles with this permission have access to all employee information. For details, see Employee Record Full Permission Overview.

If your role has the appropriate permission, you can create custom employee permissions to include all or a set of standard fields and sublists from the employee record. You can also add custom fields and sublists to custom employee permissions. For more information, see Custom Advanced Employee Permissions.

If your role has the appropriate permission, you can also customize restrictions for Advanced Employee Permissions. For details, see Custom Restrictions for Advanced Employee Permissions.

**Note:** Inline editing is available only with the Lists > Employees permission at access level Edit or higher.

**Note:** When Advanced Employee Permissions is enabled, users who have access to effective dating logs only see content based on the permissions and restrictions assigned to their role. For example, roles with the Employee Confidential permission see effective dating logs only for their direct reports and below. For details, see Effective Dating for Employee Information.

### Advanced Employee Permissions Videos

Watch the following help videos for information about using the Advanced Employee Permissions feature. When you click a link, you are redirected to the Oracle Learning Library to view the video.

- View Advanced Employee Permissions Feature: Part 1 — Overview
- View Advanced Employee Permissions Feature: Part 2 — Creating Custom Advanced Employee Permissions
- View Advanced Employee Permissions Feature: Part 3 — Customizing a Role Using Advanced Employee Permissions
- View Advanced Employee Permissions Feature: Part 4 — Using Advanced Employee Permissions
Before Enabling the Advanced Employee Permissions Feature

**Warning:** The Advanced Employee Permissions feature changes the way employee information is exposed to users. This feature should only be enabled by an administrator who has a thorough understanding of NetSuite. Because these changes extend to all parts of NetSuite, test this feature in a sandbox account before enabling it in a production account.

This section describes how access to the employee record, using different contexts, changes when the Advanced Employee Permissions feature is enabled. You should go through the following list before you enable the feature. If required, complete any of the recommended actions. For more information, contact NetSuite Customer Support.

- Advanced Employee Permissions and Employee Searches
- Advanced Employee Permissions and Saved Searches
- Advanced Employee Permissions and Employee List View Results
- Advanced Employee Permissions and NetSuite Reports
- Advanced Employee Permissions and Employee Templates
- Advanced Employee Permissions and Contact Records
- Advanced Employee Permissions and Subrecords
- Advanced Employee Permissions and SuiteScript
- Advanced Employee Permissions and SuiteFlow
- Advanced Employee Permissions and SuiteAnalytics Connect
- Advanced Employee Permissions and CSV Import
- Advanced Employee Permissions and SOAP Web Services
- Advanced Employee Permissions and Customizations

### Advanced Employee Permissions and Employee Searches

**Important:** To avoid confusion, before you enable the Advanced Employee Permissions feature, review existing saved employee searches, and limit access to any searches that are not relevant to some users.

When Advanced Employee Permissions is not enabled, employees can only perform employee searches if they have the following permissions:

- Lists > Employees
- Lists > Employee Record
- Lists > Perform Search

However, when Advanced Employee Permissions is enabled, many standard NetSuite roles automatically have the Employee Public permission, and the Lists > Employee Record permission. These permissions give them the ability to perform employee searches. Therefore, it is important that you review existing saved employee searches, and limit access to any searches that are not relevant to some users.

### Advanced Employee Permissions and Saved Searches

Based on the employee permissions assigned to the role, users see different results when viewing the same employee saved search. Some columns in the search results are hidden, depending on what the
Before Enabling the Advanced Employee Permissions Feature

role has access to. When the filter criteria of a saved search uses a field not available to the employee permissions assigned to the role, the filter is not applied.

The following examples outline what information is exposed to a role, using different Advanced Employee Permissions, when a saved search is run using the same filter criteria, as outlined in the tables.

Example 1 – Saved Search Results with Employee Public Permission

<table>
<thead>
<tr>
<th>Advanced Employee Permissions</th>
<th>Filter Criteria</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Public</td>
<td>Location – Toronto</td>
<td>Employee Public Permission Overview.</td>
</tr>
<tr>
<td></td>
<td>Base Wage – Greater than $100,000</td>
<td></td>
</tr>
</tbody>
</table>

**Saved Search Results** – When a role using the Employee Public permission runs the saved search the results are filtered only by Location because this permission does not have access to Base Wage.

Example 2 – Saved Search Results with Employee Administration Permission

<table>
<thead>
<tr>
<th>Advanced Employee Permissions</th>
<th>Filter Criteria</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Administration</td>
<td>Location – Toronto</td>
<td>Employee Administration Permission Overview</td>
</tr>
<tr>
<td></td>
<td>Base Wage – Greater than $100,000</td>
<td></td>
</tr>
</tbody>
</table>

**Saved Search Results** – When a role using the Employee Administration permission runs the same saved search different results are shown. Only the employees who are located in Toronto and who have a base wage greater than $100,000.00 are shown in the saved search results. In the image below, you can see that four employees meet this search criteria.

Employee Management
Advanced Employee Permissions and Employee List View Results

The Employees List page generates the available columns, based on the fields the role has access to. The employees displayed on this page are dependent on which employees the role has permission to view all the fields for, and that meet the set restrictions. Seeing different employees with a different combination of permissions and restrictions is expected behavior.

The following section gives examples of how the displayed information changes when using Advanced Employee Permissions.

**Important:** When using Advanced Employee Permissions you should view the Employees List page using the Basic view, instead of the default All view. With the Basic view, you see a more extensive list of employees because the basic field set is contained in most standard employee permissions. With the All view, there are more columns displayed, however, it may restrict the number of employees you see. For more information, see Example 3 – Employee List Page Results with Employee Confidential and Employee Self Permissions.

Example 1 – Employees List Page Results with Employee Confidential Permission

<table>
<thead>
<tr>
<th>Advanced Employee Permissions</th>
<th>Default Access Level and Restriction?</th>
<th>Default Restriction</th>
<th>Fields Exposed</th>
<th>View</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
<td>First Name</td>
<td>All</td>
<td>Employee Confidential Permission Overview</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Last Name</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Email</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Gender</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Job Title</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Employee List Page Results** – The employees that directly report to the user are shown in the list. In this example, the user has one direct report and each of the fields that are part of the Employee Confidential permission are shown (First Name, Last Name, Email, Job Title, and Gender). This is because the Employee Confidential permission has the default restriction of Subordinates.
Example 2 – Employees List Page Results with Employee Self Permission

<table>
<thead>
<tr>
<th>Advanced Employee Permissions</th>
<th>Default Access Level</th>
<th>Default Restriction</th>
<th>Fields Exposed</th>
<th>View</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Self</td>
<td>View</td>
<td>Own Only</td>
<td>First Name</td>
<td>All</td>
<td>Employee Self Permission Overview</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Last Name</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Email</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Job Title</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Birth Date</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Employee List Page Results** – The user sees the fields exposed with the Employee Self permission only for themselves. This is because the Employee Self permission has the default restriction of Own Only, meaning the user only has access to this information for themselves on their employee record.

Example 3 – Employee List Page Results with Employee Confidential and Employee Self Permissions

<table>
<thead>
<tr>
<th>Advanced Employee Permissions</th>
<th>Default Access Level</th>
<th>Default Restrictions</th>
<th>Fields Exposed</th>
<th>Views</th>
<th>References</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
<td>Employee Confidential Permission</td>
<td>All and Basic</td>
<td>Employee Confidential Permission Overview</td>
</tr>
<tr>
<td>Employee Self</td>
<td>View</td>
<td>Own Only</td>
<td>First Name</td>
<td>All</td>
<td>Employee Self Permission Overview</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Last Name</td>
<td></td>
<td>Employee Self Permission Overview</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Email</td>
<td></td>
<td>Employee Self Permission Overview</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Gender</td>
<td></td>
<td>Employee Self Permission Overview</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Job Title</td>
<td></td>
<td>Employee Self Permission Overview</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Employee Self Permission</td>
<td></td>
<td>Employee Self Permission Overview</td>
</tr>
</tbody>
</table>
Before Enabling the Advanced Employee Permissions Feature

<table>
<thead>
<tr>
<th>Advanced Employee Permissions</th>
<th>Default Access Level</th>
<th>Default Restrictions</th>
<th>Fields Exposed</th>
<th>Views</th>
<th>References</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>□ First Name</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>□ Last Name</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>□ Email</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>□ Job Title</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>□ Birth Date</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Employee List Page Results (All View)** – With the Employee Confidential and Employee Self permission combination, the user sees an empty list. This is because the All view on the Employees List page generates the available columns, based on the fields the role has access to, across all roles, and displays all the employees that match all the fields that the user has access to. When fields are removed from the view, you will see a generated information message.

**Employee List Page Results (Basic View)** – With the Employee Confidential and Employee Self permission combination, when the user selects **Basic** from the **View** dropdown list on the Employees List page, the user sees their name in the list and all their direct reports. This is because the field set contained in the Basic view is contained in most standard employee permissions.
Advanced Employee Permissions and NetSuite Reports

Information in NetSuite reports is not governed by Advanced Employee Permissions. This means that it could be possible to accidentally disclose more information than an employee should have access to through a report. Use caution when giving employees access to reports. For details, see the help topic Access to Reports.

Advanced Employee Permissions and Employee Templates

When Advanced Employee Permissions is enabled you can view employee templates, however you cannot create or edit employee templates. Editing or creating employee templates is supported only with the Lists > Employees permission. For more information about employee templates, see Creating an Employee Template.

Advanced Employee Permissions and Contact Records

When Advanced Employee Permissions is enabled, the Show Employees as Contacts field on the General Preferences page is not available. Any employees saved to a contact record do not appear on the Contacts list page, and any information specific to an employee's contact record is no longer accessible.

If required, move any custom fields from the contact record to the employee record before enabling Advanced Employee Permissions.

Advanced Employee Permissions and Subrecords

Subrecords are supported only with the Lists > Employees permission.

Advanced Employee Permissions and SuiteScript

- In NetSuite, account administrators have access to all the information on all record types, including the employee record. This can create issues in the following situations:
  - When a user is assigned a role that has permission to create scripts.
  - When a user sets a script to run as administrator.
- A user could write or deploy a script that gains access to employee information that they would normally not have access to. This could potentially be used to compromise employee information.

When Advanced Employee Permissions is enabled, carefully track which roles have permission to create or alter scripts. In addition, track which scripts execute as administrator, and what they do to make sure employee information is not unintentionally leaked.

- Assigning any of the Advanced Employee Permissions to a role gives partial access to the employee record. Some scripts (including third-party scripts) may fail when they attempt to access parts of the employee record that they are not permitted to access, with the role they are assigned. For more information, see Advanced Employee Permissions Overview.

  If needed, consider running these scripts as administrator, or revise the scripts to handle cases where some fields and sublists are not accessible.

- If you have any scripts that add buttons to the employee record, ensure that they appear only when appropriate. Configure scripts so that the action being added respects the restrictions on the employee record.
Script Access

The following section outlines how script access changes when Advanced Employee Permissions is enabled.

The fields and sublists a user has access to can change depending on which employee record is being viewed or edited. This is different from other records in NetSuite, where permissions granted to a role determine just the instances of the record the role can see.

The search columns available to users are also dependent on the permissions assigned to the role.

In general, scripts should always check to see if the role has access to a field or sublist before trying to do something with it. Simply calling functions and methods that interact with fields and sublists before checking whether the role has access may result in inconsistent behavior.

For example, when the Department field is permitted on the employee record, and you find that you do not have access, a null value is returned. If the field is empty, an empty string is returned.

Script Access Examples

When you run the following script, errors are generated because the script does not check if the field exists, or whether you have access to the field.

```javascript
var employeeRecord = nlapiLoadRecord('employee', '115');
employeeRecord.setFieldValue('department', '2');
nlapiSubmitRecord(employeeRecord);
```

To check if your role has access to a field for a specific employee, load the employee record object and call `getAllFields().includes()` if the field exists and you do have access, a `true` value is returned. In the following example, the user has access to the Department field for the employee with ID: 115.

```javascript
var accessToDepartment = nlapiLoadRecord('employee', '115').getAllFields().includes('department');
```

Taking the previous two script examples into consideration, you should use the following example to make sure your scripts do not fail.

```javascript
var employeeRecord = nlapiLoadRecord('employee', '115');
var hasAccessToDepartment = employeeRecord.getAllFields().includes('department');
if (hasAccessToDepartment)
{
    employeeRecord.setFieldvalue('department', '2');
}
nlapiSubmitRecord(employeeRecord);
```

For more information about working with SuiteScript, see the help topics Suitelets and UI Object Best Practices and Client Script Best Practices.

Advanced Employee Permissions and SuiteFlow

- In NetSuite, account administrators have access to all the information on all record types, including the employee record. This can create issues in the following situations:
  - When a user is assigned a role that has permission to create workflows.
  - When a user sets a workflow to run as administrator.
- A user could write or deploy a workflow that gains access to employee information that they would normally not have access to. This could potentially be used to compromise employee information.
When Advanced Employee Permissions is enabled, carefully track which roles have permission to create or alter workflows. In addition, track which workflows execute as administrator, and what they do to make sure employee information is not unintentionally leaked.

- It is not possible to know what fields or sublists are present on any employee record when Advanced Employee Permissions is enabled. This means that workflows cannot safely perform operations, such as setting a default value on a field. To avoid this, utilize an After Submit workflow as administrator, which gives access to the complete set of fields and sublists on the employee record.
- If you have any workflows that add buttons to the employee record, make sure that they appear only when appropriate. Configure scripts so that the action being added respects the restrictions on the employee record.

For more information about workflows, see the help topic Working with Workflows.

Advanced Employee Permissions and SuiteAnalytics Connect

SuiteAnalytics Connect access to the employee record, meaning access through ODBC, JDBC, or ADO.NET drivers, is supported only with the Lists > Employees permission. SuiteAnalytics Connect access is not supported for roles with other employee permissions.

Advanced Employee Permissions and CSV Import

CSV import is supported only with the Lists > Employees permission.

Advanced Employee Permissions and SOAP Web Services

Access to the employee record through SOAP web services respects the permissions that are assigned to a role. However, be aware of the following:

- When a value for a field is set on the employee record in a SOAP web services program, and the current role does not have access to that field, the program completes without errors, but the field is not set or updated.
- For SOAP web services in accounts with Advanced Employee Permissions enabled, fields and sublists to which the current role does not have access are not returned through search or filtering.

Advanced Employee Permissions and Customizations

The following section outlines how customizations change when Advanced Employee Permissions is enabled.

Custom Roles

Custom roles created in your NetSuite account are not automatically updated with the employee permissions introduced by Advanced Employee Permissions. You must manually update custom roles to include any of the required employee permissions. For details, see Setting Employee Access for Advanced Employee Permissions.

Roles Using the SuiteScript Permission

Roles that have the Setup > SuiteScript permission can configure scripts to run as administrator, which bypasses the Advanced Employee Permissions feature. Before creating custom roles with this permission, make sure that the role should have access to the information that is being exposed.
SuiteBuilder

By default, when Advanced Employee Permissions is enabled, any customization created with NetSuite SuiteBuilder that are included with the standard Lists > Employees permission are preserved. If you customize the permission, the customizations created with SuiteBuilder are not preserved. If required, you need to manually add customizations to the custom Lists > Employees permission. For more information, see Custom Advanced Employee Permissions.

Advanced Employee Permissions and Standard NetSuite Roles

The following table highlights which Advanced Employee Permissions are automatically assigned to standard NetSuite roles, as well as the default access levels and restrictions for each. The Employee Administration and Employee System Access permissions are not automatically assigned to any standard roles. If required, you can manually add these permissions to a role.

- If you change the access level of the Employee Self permission to Edit, be aware that this gives employees the ability to make changes to the fields exposed with this permission, which includes their compensation information. It is recommended that you use the default access level View, however, if required, you can create a custom permission. For more information, see Custom Advanced Employee Permissions.

- If you change the access level of the Employee Public, Employee Confidential, Employee Compensation, Employee Record Full, or Employee Administration permissions to Edit, be aware that this gives users the ability to also create employees in NetSuite.

Important: The standard NetSuite Lists > Employees permission takes precedence over any of the employee permissions that are part of the Advanced Employee Permissions feature. This change is a step in separating the legacy permission model from the Advanced Employee Permissions feature. The Lists > Employees permission gives full-record access to employee records. You should review the standard and custom roles in your account that include the Lists > Employees permission. Make sure that all users with these roles should have full access to employee records. For any users who should not have full access to employee records, you can assign them to a different role that does not include the Lists > Employees permission. If you have the Administrator role, you can create alternate custom roles for these users. For details, see Setting Employee Access for Advanced Employee Permissions, Creating Custom Advanced Employee Permissions, and Custom Restrictions for Advanced Employee Permissions.

<table>
<thead>
<tr>
<th>Standard Role</th>
<th>Employee Permissions</th>
<th>Level of Access</th>
<th>Restriction</th>
</tr>
</thead>
<tbody>
<tr>
<td>A/P Clerk</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Record</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td>A/R Clerk</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Record</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td>Accountant</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Record</td>
<td>Full</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Employees</td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>Accountant (Reviewer)</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td>Standard Role</td>
<td>Employee Permissions</td>
<td>Level of Access</td>
<td>Restriction</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>----------------------</td>
<td>----------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>Employee Record</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employees</td>
<td>View</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bookkeeper</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employees</td>
<td>Edit</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Buyer</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CEO</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employees</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CEO (hands off)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employees</td>
<td>View</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CFO</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employees</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Chief People Officer (CPO)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employees</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Center</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td></td>
</tr>
<tr>
<td>Employee Self</td>
<td>View</td>
<td>Own Only</td>
<td></td>
</tr>
<tr>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
<td></td>
</tr>
<tr>
<td>Employee Compensation</td>
<td>View</td>
<td>Subordinates</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>Edit</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Engineer</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>View</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
<td></td>
</tr>
<tr>
<td>Employee Compensation</td>
<td>View</td>
<td>Subordinates</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>View</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Engineering Manager</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>View</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
<td></td>
</tr>
<tr>
<td>Employee Compensation</td>
<td>View</td>
<td>Subordinates</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>View</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Human Resources Generalist</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Standard Role</td>
<td>Employee Permissions</td>
<td>Level of Access</td>
<td>Restriction</td>
</tr>
<tr>
<td>------------------------</td>
<td>----------------------</td>
<td>-----------------</td>
<td>---------------------------------</td>
</tr>
<tr>
<td>Employees</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Intranet Manager</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
</tr>
<tr>
<td></td>
<td>Employee Compensation</td>
<td>View</td>
<td>Subordinates</td>
</tr>
<tr>
<td>Issue Administrator</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Record</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td>Marketing Manager</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
</tr>
<tr>
<td></td>
<td>Employee Compensation</td>
<td>View</td>
<td>Subordinates</td>
</tr>
<tr>
<td></td>
<td>Employee Record</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td>Payroll Manager</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
</tr>
<tr>
<td>Payroll Setup</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Record</td>
<td>Full</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Employees</td>
<td>Full</td>
<td></td>
</tr>
<tr>
<td>PM Manager</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
</tr>
<tr>
<td>Product Manager</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Record</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td>Support Manager</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
</tr>
<tr>
<td></td>
<td>Employee Compensation</td>
<td>View</td>
<td>Subordinates</td>
</tr>
<tr>
<td></td>
<td>Employee Record</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td>QA Engineer</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Record</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td>QA Manager</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
</tbody>
</table>

Employee Management
<table>
<thead>
<tr>
<th>Standard Role</th>
<th>Employee Permissions</th>
<th>Level of Access</th>
<th>Restriction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
<td></td>
</tr>
<tr>
<td>Employee Compensation</td>
<td>View</td>
<td>Subordinates</td>
<td></td>
</tr>
<tr>
<td>Employee Record</td>
<td>View</td>
<td>–</td>
<td></td>
</tr>
<tr>
<td>Resource Manager</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Retail Clerk</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td>Retail Clerk (Web Services Only)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sales Administrator</td>
<td>Employee Public</td>
<td>View</td>
<td>–</td>
</tr>
<tr>
<td>Sales Manager</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sales Person</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td>Sales Vice President</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Store Manager</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td>System Administrator</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Warehouse Manager</td>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
</tr>
<tr>
<td></td>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
</tr>
<tr>
<td></td>
<td>Employee Compensation</td>
<td>View</td>
<td>Subordinates</td>
</tr>
<tr>
<td></td>
<td>Employee Record</td>
<td>View</td>
<td>–</td>
</tr>
<tr>
<td></td>
<td>Employees</td>
<td>View</td>
<td>–</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Employee Self Permission Overview

The Employee Self permission is intended for all employees. Roles that have this permission can view basic personal information on their employee record. Basic personal information includes things such as home address, and passport information. When you enable the Advanced Employee Permissions feature, NetSuite automatically assigns this permission to the Employee Center role. By default, the access level for this permission is set to View, and the restriction is set to Own Only, but you can make changes. For details, see Setting Employee Access for Advanced Employee Permissions.

**Note:** Users are not able to view or edit future or past-dated changes to their employee information if they have an assigned role with this permission.

Employee Self Permission Fields

This section outlines the default employee record fields that are exposed with the Employee Self permission. If required, you can customize this permission. For more information, see Custom Advanced Employee Permissions.

### Employee Self Permission Fields

#### Primary Information
- Employee ID
- Mr/Ms
- Name
- Initials
- Job
- Supervisor
- Image

#### Email | Phone | Address
- Email
- Phone
- Office Phone
- Mobile Phone
- Home Phone
- Fax
- Address

#### Classification
- Subsidiary
- Department
- Class
### Employee Self Permission Overview

#### Employee Self Permission Fields
- Location

#### Employee Self Permission Sublists

This section outlines the default employee record sublists, and the fields associated with them that are exposed with the Employee Self Permission. If required, you can customize this permission. For more information, see [Custom Advanced Employee Permissions](#).

<table>
<thead>
<tr>
<th>Employee Self Permission Sublists</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Address</strong></td>
</tr>
<tr>
<td>- Default Shipping</td>
</tr>
<tr>
<td>- Home</td>
</tr>
<tr>
<td>- Label</td>
</tr>
<tr>
<td>- Address</td>
</tr>
<tr>
<td>- Edit</td>
</tr>
<tr>
<td><strong>Human Resources</strong></td>
</tr>
<tr>
<td>- Social Security</td>
</tr>
<tr>
<td>- Birth Date</td>
</tr>
<tr>
<td><strong>Job Information</strong></td>
</tr>
<tr>
<td>- Job Description</td>
</tr>
<tr>
<td><strong>Subordinates</strong></td>
</tr>
<tr>
<td>- Image</td>
</tr>
<tr>
<td>- Name</td>
</tr>
<tr>
<td>- Job Title</td>
</tr>
<tr>
<td>- Location</td>
</tr>
<tr>
<td>- Department</td>
</tr>
<tr>
<td>- Subsidiary</td>
</tr>
<tr>
<td>- Contact Info</td>
</tr>
<tr>
<td><strong>Education</strong></td>
</tr>
<tr>
<td>- Level of Education</td>
</tr>
<tr>
<td>- Degree</td>
</tr>
<tr>
<td>- Date Conferred</td>
</tr>
<tr>
<td><strong>Personal</strong></td>
</tr>
<tr>
<td>- Marital Status</td>
</tr>
<tr>
<td>- Ethnicity</td>
</tr>
<tr>
<td>- Gender</td>
</tr>
<tr>
<td><strong>Time-Off</strong></td>
</tr>
<tr>
<td>- Available Now</td>
</tr>
<tr>
<td>- Type</td>
</tr>
<tr>
<td>- Available this Year</td>
</tr>
<tr>
<td>- Used this Year</td>
</tr>
<tr>
<td>- Schedules this Year</td>
</tr>
<tr>
<td>- Available Now</td>
</tr>
</tbody>
</table>
Employee Self Permission Overview

Employee Self Permission Sublists

- **Balances**
  - Type
  - Carried Over
  - Accrued
  - Used
  - Expired Carryover
  - Balance

Compensation Tracking

- Compensation Currency
- Base Wage Type
- Base Wage
- Bonus Target
- Target Type
- Target Frequency
- Target Comments
- Bonus Type*
- Percentage*
- Amount*
- Award Date*
- Comments*

*These fields are a part of the bonus record. The Employee Self Permission allows access to these fields, but Advanced Employee Permissions cannot further restrict access to these fields.

Employee Public Permission Overview

The Employee Public permission is intended for all employees. Roles that have this permission can view basic employee information. Basic information includes non-sensitive information, such as job title and reporting relationships. When you enable the Advanced Employee Permissions feature, NetSuite automatically assigns this permission to a set of standard roles. By default, the access level for this permission is set to View, and the restriction is set to Active and Non-Terminated, but you can makes changes. For details, see Setting Employee Access for Advanced Employee Permissions.

Employee Public Permission Fields

This section outlines the default employee record fields that are exposed with the Employee Public Permission. If required, you can customize this permission. For more information, see Custom Advanced Employee Permissions.

Primary Information

- Employee ID
- Name
- Initials
- Supervisor
Employee Public Permission Overview

<table>
<thead>
<tr>
<th>Employee Public Permission Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>■ Image</td>
</tr>
</tbody>
</table>

**Email | Phone | Address**

- ■ Email
- ■ Phone
- ■ Office Phone
- ■ Mobile Phone
- ■ Fax

**Classification**

- ■ Subsidiary
- ■ Department
- ■ Class
- ■ Location

Employee Public Permission Sublist

This section outlines the default employee record sublist, and the fields associated with it that are exposed with the Employee Public Permission. If required, you can customize this permission. For more information, see Custom Advanced Employee Permissions

<table>
<thead>
<tr>
<th>Employee Public Permission Sublist</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Subordinates</strong></td>
</tr>
<tr>
<td>■ Image</td>
</tr>
<tr>
<td>■ Name</td>
</tr>
<tr>
<td>■ Job Title</td>
</tr>
<tr>
<td>■ Location</td>
</tr>
<tr>
<td>■ Department</td>
</tr>
<tr>
<td>■ Subsidiary</td>
</tr>
<tr>
<td>■ Contact Info</td>
</tr>
</tbody>
</table>

Employee Confidential Permission Overview

The Employee Confidential permission is intended for manager roles. In addition to the employee public fields and sublists, roles with this permission can also access confidential employee information. Confidential information includes job and education information. This permission is automatically added to a set of standard roles when the Advanced Employee Permissions feature is enabled. For details, see Advanced Employee Permissions and Standard NetSuite Roles. By default, the access level for this permission is set to View, and the restriction is set to Subordinates, but you can make changes. For details, see Setting Employee Access for Advanced Employee Permissions.

Employee Confidential Permission Fields

This section outlines the default employee record fields that are exposed with the Employee Confidential Permission. If required, you can customize this permission. For more information, see Custom Advanced Employee Permissions.
Employee Confidential Permission Overview

Employee Confidential Permission Fields

Primary Information
- Employee ID
- Name
- Initials
- Supervisor
- Job
- Image

Email | Phone | Address
- Email
- Phone
- Office Phone
- Mobile Phone
- Fax

Classification
- Subsidiary
- Department
- Class
- Location
- Billing Class

Employee Confidential Permission Sublists

This section outlines the default employee record sublists, and the fields associated with them that are exposed with the Employee Confidential Permission. If required, you can customize this permission. For more information, see Custom Advanced Employee Permissions.

Employee Confidential Permission Sublists

Human Resources
- Job Information
  - Type
  - Employee Status
  - Job Description
  - Sales Rep
  - Support Rep
  - Project Resource
  - Project Manager
  - Default Project Resource Role
  - Work Calendar
  - Labor Cost
  - Hourly Rate
  - Hire Date
  - Last Review Date
### Employee Confidential Permission Sublists

- Next Review Date

#### Expenses and Purchasing
- Expense Limit
- Expense Approver
- Expense Approval Limit
- Purchase Limit
- Purchase Approver
- Purchase Approval Limit
- Account

#### Subordinates
- Image
- Name
- Job Title
- Location
- Department
- Subsidiary
- Contact Info

#### Education
- Level of Education
- Degree
- Date Conferred

### Time-Off

- Time-Off Plan
- Start Date for Time-Off Calculations
- Available Now:
  - Type
  - Available this Year (HRS)
  - Used this Year (HRS)
  - Scheduled this Year (HRS)
  - Available Now (HRS)
- Balances:
  - Type
  - Carried Over (HRS)
  - Accrued (HRS)
  - Used (HRS)
  - Expired Carryover (HRS)
  - Balance (HRS)

### Time Tracking

- Time Approver

### Commission
Employee Confidential Permission Overview

The Employee Compensation permission is intended for managers. Roles that have this permission can access compensation information. This permission is automatically added to a set of standard roles when the Advanced Employee Permissions feature is enabled. For details, see Advanced Employee Permissions and Standard NetSuite Roles. By default, the access level for this permission it set to View, and the restriction is set to Subordinates, but you can make changes. For details, see Setting Employee Access for Advanced Employee Permissions.

Employee Compensation Permission Sublists

This section outlines the default employee record sublists, and the fields associated with them that are exposed with the Employee Compensation Permission. If required, you can customize this permission. For more information, see Custom Advanced Employee Permissions.

<table>
<thead>
<tr>
<th>Employee Compensation Permission Sublists</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Compensation Tracking</strong></td>
</tr>
<tr>
<td>- Base Wage</td>
</tr>
<tr>
<td>- Base Wage Type</td>
</tr>
<tr>
<td>- Bonus Target</td>
</tr>
<tr>
<td>- Target Comments</td>
</tr>
<tr>
<td>- Target Frequency</td>
</tr>
<tr>
<td>- Target Type</td>
</tr>
<tr>
<td>- Compensation Currency</td>
</tr>
<tr>
<td>- Bonus Type*</td>
</tr>
<tr>
<td>- Percentage*</td>
</tr>
<tr>
<td>- Amount*</td>
</tr>
<tr>
<td>- Award Date*</td>
</tr>
<tr>
<td>- Comments*</td>
</tr>
<tr>
<td>*These fields are a part of the bonus record. The Employee Compensation Permission allows access to these fields, but Advanced Employee Permissions cannot further restrict access to these fields.</td>
</tr>
</tbody>
</table>

| **Payroll**                              |
| - Compensation Type                      |

The Base Wage, Base Wage Type, Bonus Target, Target Comments, Target Frequency, Target Type, Compensation Currency, and Compensation Type fields are a part of the Compensation Tracking feature. The Compensation Type field is a part of SuitePeople U.S. Payroll. For details, see Recording Base Pay Compensation for an Employee and Including an Employee in Payroll.
Employee System Access Permission Overview

The Employee System Access permission is intended for IT administrators. Roles with this permission can give users access to NetSuite and assign roles to users who fall into the restriction policy defined on the Role page. For example, when restricted by location, a role with the Employee System Access permission can give access and assign roles to employees in their location only.

**Note:** When the Advanced Employee Permissions feature is enabled, the Employee System Access permission is not automatically assigned to any standard roles.

Employee System Access Permission Fields

This section outlines the default employee record fields that are exposed with the Employee System Access Permission. If required, you can customize this permission. For more information, see [Custom Advanced Employee Permissions](#).

**Employee System Access Permission Fields**

**Primary Information**
- Employee ID
- Name

**Email | Phone | Address**
- Email

Employee System Access Permission Sublist

This section outlines the default employee record sublist, and the fields associated with this permission that are exposed with the Employee System Access Permission. If required, you can customize this permission. For more information, see [Custom Advanced Employee Permissions](#).

**Employee System Access Permission Sublist**

**Access**
- Give Access
- IP Address Restriction
- Inherit IP Rules from Company

**Roles:**
- Role

**Global Permissions:**
- Permission
- Level

**History:**
- Date/Time
Employee System Access Permission Overview

1. **Employee System Access Permission Sublist**
   - User
   - Change

Employee Administration Permission Overview

The Employee Administration permission is intended for Human Resources Generalists and Human Resources Administrators. In addition to the Employee Public fields and sublists, users that have this permission have access to a limited set of fields and sublists, based on the restrictions defined on the Role page.

**Note:** When the Advanced Employee Permissions feature is enabled, the Employee Administration permission is not automatically assigned to any standard roles.

Employee Administration Permission Fields

This section outlines the default employee record fields that are exposed with the Employee Administration Permission. If required, you can customize this permission. For more information, see Custom Advanced Employee Permissions.

<table>
<thead>
<tr>
<th>Employee Administration Permission Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Primary Information</strong></td>
</tr>
<tr>
<td>- Employee ID</td>
</tr>
<tr>
<td>- Initials</td>
</tr>
<tr>
<td>- Supervisor</td>
</tr>
<tr>
<td>- Mr/Ms</td>
</tr>
<tr>
<td>- Job</td>
</tr>
<tr>
<td>- Image</td>
</tr>
<tr>
<td>- Name</td>
</tr>
<tr>
<td>**Email</td>
</tr>
<tr>
<td>- Email</td>
</tr>
<tr>
<td>- Mobile Phone</td>
</tr>
<tr>
<td>- Address</td>
</tr>
<tr>
<td>- Phone</td>
</tr>
<tr>
<td>- Home Phone</td>
</tr>
<tr>
<td>- Office Phone</td>
</tr>
<tr>
<td>- Fax</td>
</tr>
<tr>
<td><strong>Classification</strong></td>
</tr>
<tr>
<td>- Subsidiary</td>
</tr>
<tr>
<td>- Class</td>
</tr>
<tr>
<td>- Location</td>
</tr>
<tr>
<td>- Department</td>
</tr>
</tbody>
</table>
Employee Administration Permission Overview

This section outlines the default employee record sublists, and the fields associated with them that are exposed with the Employee Administration Permission. If required, you can customize this permission. For more information, see Custom Advanced Employee Permissions.

### Employee Administration Permission Sublists

<table>
<thead>
<tr>
<th>Address</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Shipping</td>
<td></td>
</tr>
<tr>
<td>Home</td>
<td></td>
</tr>
<tr>
<td>Label</td>
<td></td>
</tr>
<tr>
<td>Address</td>
<td></td>
</tr>
<tr>
<td>Edit</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Human Resources</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Birth Date</td>
<td></td>
</tr>
<tr>
<td>Job Information:</td>
<td></td>
</tr>
<tr>
<td>□ Type</td>
<td></td>
</tr>
<tr>
<td>□ Termination/Release Date</td>
<td></td>
</tr>
<tr>
<td>□ Employee Status</td>
<td></td>
</tr>
<tr>
<td>□ Job Description</td>
<td></td>
</tr>
<tr>
<td>□ Work Calendar</td>
<td></td>
</tr>
<tr>
<td>□ Hire Date</td>
<td></td>
</tr>
<tr>
<td>□ Last Review Date</td>
<td></td>
</tr>
<tr>
<td>□ Next Review Date</td>
<td></td>
</tr>
<tr>
<td>□ Expense and Purchasing:</td>
<td></td>
</tr>
<tr>
<td>▪ Expense Limit</td>
<td></td>
</tr>
<tr>
<td>▪ Expense Approver</td>
<td></td>
</tr>
<tr>
<td>▪ Expense Approval Limit</td>
<td></td>
</tr>
<tr>
<td>▪ Purchase Limit</td>
<td></td>
</tr>
<tr>
<td>▪ Purchase Approver</td>
<td></td>
</tr>
<tr>
<td>▪ Purchase Approval Limit</td>
<td></td>
</tr>
<tr>
<td>□ Account</td>
<td></td>
</tr>
<tr>
<td>▪ Default Account for Corporate Card Expenses</td>
<td></td>
</tr>
<tr>
<td>Subordinates:</td>
<td></td>
</tr>
<tr>
<td>▪ Image</td>
<td></td>
</tr>
<tr>
<td>▪ Name</td>
<td></td>
</tr>
<tr>
<td>▪ Job Title</td>
<td></td>
</tr>
<tr>
<td>▪ Location</td>
<td></td>
</tr>
<tr>
<td>▪ Department</td>
<td></td>
</tr>
<tr>
<td>▪ Subsidiary</td>
<td></td>
</tr>
<tr>
<td>▪ Contact Info</td>
<td></td>
</tr>
<tr>
<td>Education:</td>
<td></td>
</tr>
<tr>
<td>▪ Level of Education</td>
<td></td>
</tr>
<tr>
<td>▪ Degree</td>
<td></td>
</tr>
<tr>
<td>▪ Date Conferred</td>
<td></td>
</tr>
</tbody>
</table>
Employee Administration Permission Overview

Employee Administration Permission Sublists
- Personal:
  - Marital Status
  - Ethnicity
  - Gender

Employee Record Full Permission Overview

The Employee Record Full permission is intended for Human Resources Business Partners, Chief People Officers (CPOs), and Human Resources Directors. Users that have this permission have access to all the information on the employee record, except for the fields and sublists exposed by the Employee System Access permission. Roles with the Employee System Access permission can give users access to NetSuite and assign roles to users who fall into the restriction policy defined on the Role page. For details, see Employee System Access Permission Overview.

Advanced Employee Permissions Use Cases

The following section provides examples of how to use standard NetSuite permissions and Advanced Employee Permissions to expose only the information that a particular type of employee requires access to. For a complete list of the fields and sublists exposed with each advanced employee permission, see the following help topics:

- Employee Self Permission Overview
- Employee Public Permission Overview
- Employee Confidential Permission Overview
- Employee Compensation Permission Overview
- Employee System Access Permission Overview
- Employee Administration Permission Overview
- Employee Record Full Permission Overview

Important: The Lists > Employee Record and Lists > Perform Search permissions are standard NetSuite permissions, and are not part of Advanced Employee Permissions. However, these permissions are required to use Advanced Employee Permissions. For more information about the standard permissions, see the help topic NetSuite Permissions Overview.

Note: These examples use the default Advanced Employee Permissions and the default restrictions, but you can customize both. For details, see Custom Advanced Employee Permissions and Custom Restrictions for Advanced Employee Permissions.

Example 1: Employee Access for All Employees

<table>
<thead>
<tr>
<th>Permission</th>
<th>Access Level</th>
<th>Restriction</th>
<th>Gives Employees Access To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lists &gt; Employee Record*</td>
<td>Edit</td>
<td>–</td>
<td>Access employee menus. For example, List &gt; Employees.</td>
</tr>
<tr>
<td>Lists &gt; Perform Search*</td>
<td>Full</td>
<td>–</td>
<td>Search for employees.</td>
</tr>
</tbody>
</table>
### Advanced Employee Permissions Use Cases

<table>
<thead>
<tr>
<th>Permission</th>
<th>Access Level</th>
<th>Restriction</th>
<th>Gives Employees Access To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td>View and search basic employee information, such as email address and supervisor, for all active, non-terminated employees.</td>
</tr>
<tr>
<td>Employee Self</td>
<td>View</td>
<td>Own Only</td>
<td>View relevant information about themselves on their employee record, such as job description and compensation.</td>
</tr>
</tbody>
</table>

The Lists > Employee Record and Lists > Perform Search permissions are standard NetSuite permissions, and are not part of Advanced Employee Permissions. However, these permissions are required to use Advanced Employee Permissions. For more information about the standard permissions, see the help topic [NetSuite Permissions Overview](#).

### Example 2: Employee Access for Managers

<table>
<thead>
<tr>
<th>Permission</th>
<th>Access Level</th>
<th>Restriction</th>
<th>Gives Managers Access To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lists &gt; Employee Record*</td>
<td>View</td>
<td>–</td>
<td>Access employee menus, for example List &gt; Employees.</td>
</tr>
<tr>
<td>Lists &gt; Perform Search*</td>
<td>Full</td>
<td>–</td>
<td>Search for employees.</td>
</tr>
<tr>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
<td>View and search confidential employee information, such as hire date and expense limit, for direct reports and below.</td>
</tr>
<tr>
<td>Employee Compensation</td>
<td>View</td>
<td>Subordinates</td>
<td>View compensation information for direct reports and below.</td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td>View and search basic employee information, such as email address and supervisor, for all active, non-terminated employees.</td>
</tr>
<tr>
<td>Employee Self</td>
<td>View</td>
<td>Own Only</td>
<td>View relevant information about themselves on their employee record, such as job description and address.</td>
</tr>
</tbody>
</table>

The Lists > Employee Record and Lists > Perform Search permissions are standard NetSuite permissions, and are not part of Advanced Employee Permissions. However, these permissions are required to use Advanced Employee Permissions. For more information about the standard permissions, see the help topic [NetSuite Permissions Overview](#).

### Example 3: Employee Access for Human Resources Generalists

<table>
<thead>
<tr>
<th>Permission</th>
<th>Access Level</th>
<th>Restriction</th>
<th>Gives Human Resources Generalists Access To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lists &gt; Employee Record*</td>
<td>Full</td>
<td>–</td>
<td>Access employee menus, for example List &gt; Employees.</td>
</tr>
<tr>
<td>Lists &gt; Perform Search*</td>
<td>Full</td>
<td>–</td>
<td>Search for employees.</td>
</tr>
</tbody>
</table>
### Advanced Employee Permissions Use Cases

<table>
<thead>
<tr>
<th>Permission</th>
<th>Access Level</th>
<th>Restriction</th>
<th>Gives Human Resources Generalists Access To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Administration</td>
<td>Full</td>
<td>Inherit from Role</td>
<td>View, create, edit, and search for personal information, such as home phone and marital status, for employees who match the restrictions defined on the Role page. If no restrictions are defined, this information is available for all employees.</td>
</tr>
<tr>
<td>Employee Confidential</td>
<td>View</td>
<td>Subordinates</td>
<td>View and search confidential employee information, such as hire date and expense limit, for direct reports and below.</td>
</tr>
<tr>
<td>Employee Compensation</td>
<td>View</td>
<td>Subordinates</td>
<td>View compensation information for direct reports and below.</td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td>View and search basic employee information, such as email address and supervisor, for all active, non-terminated employees.</td>
</tr>
</tbody>
</table>

The Lists > Employee Record and Lists > Perform Search permissions are standard NetSuite permissions, and are not part of Advanced Employee Permissions. However, these permissions are required to use Advanced Employee Permissions. For more information about the standard permissions, see the help topic NetSuite Permissions Overview.

### Example 4: Employee Access for Human Resources Directors and Above

<table>
<thead>
<tr>
<th>Permission</th>
<th>Access Level</th>
<th>Restriction</th>
<th>Gives Human Resources Directors and Above Access To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lists &gt; Employee Record*</td>
<td>Full</td>
<td>–</td>
<td>Access employee menus, for example List &gt; Employees.</td>
</tr>
<tr>
<td>Lists &gt; Perform Search*</td>
<td>Full</td>
<td>–</td>
<td>Search for employees.</td>
</tr>
<tr>
<td>Employee Record Full</td>
<td>Full</td>
<td>Inherit from Role</td>
<td>View, create, edit, and search all employee record information for employees who match the restrictions defined on the Role page. If no restrictions are defined, this information is available for all employees.</td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td>View and search basic employee information, such as email address and supervisor, for all active, non-terminated employees.</td>
</tr>
</tbody>
</table>

The Lists > Employee Record and Lists > Perform Search permissions are standard NetSuite permissions, and are not part of Advanced Employee Permissions. However, these permissions are required to use Advanced Employee Permissions. For more information about the standard permissions, see the help topic NetSuite Permissions Overview.

### Example 5: Employee Access for IT Administrators

<table>
<thead>
<tr>
<th>Permission</th>
<th>Access Level</th>
<th>Restriction</th>
<th>Gives IT Administrators Access To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lists &gt; Employee Record*</td>
<td>View</td>
<td>–</td>
<td>Access employee menus, for example List &gt; Employees.</td>
</tr>
</tbody>
</table>
## Advanced Employee Permissions Use Cases

<table>
<thead>
<tr>
<th>Permission</th>
<th>Access Level</th>
<th>Restriction</th>
<th>Gives IT Administrators Access To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lists &gt; Perform Search*</td>
<td>Full</td>
<td>-</td>
<td>Search for employees.</td>
</tr>
<tr>
<td>Employee System Access</td>
<td>Full</td>
<td>Inherit from Role</td>
<td>Give access and assign roles to employees who match the restrictions defined on the Role page.</td>
</tr>
<tr>
<td>Employee Public</td>
<td>View</td>
<td>Active and Non-Terminated</td>
<td>View and search basic employee information, such as email address and supervisor, for all active, non-terminated employees.</td>
</tr>
</tbody>
</table>

The Lists > Employee Record and Lists > Perform Search permissions are standard NetSuite permissions, and are not part of Advanced Employee Permissions. However, these permissions are required to use Advanced Employee Permissions. For more information about the standard permissions, see the help topic NetSuite Permissions Overview.

### Setting Employee Access for Advanced Employee Permissions

You can specify additional levels of restrictions and access to employee information on the **Employee Access** subtab of the Role page.

**To set employee access:**

1. Go to Setup > Users/Roles > Manage Roles.
2. From the Manage Roles list page, you can either create a custom or new role that you want to customize employee access for:
   - To create a custom role, click Customize or Edit beside the role. All of the permissions associated with the parent role are inherited. You can make changes as necessary.
   - Important: The Lists > Employees permission takes precedence over any of the employee permissions that are part of the Advanced Employee Permissions feature. This change is a step in separating the legacy permission model from the Advanced Employee Permissions feature. The Lists > Employees permission gives full-record access to employee records. Therefore, when customizing employee access to an existing role remove the Lists > Employees permission.
   - To create a new role that does not contain a list of associated permissions, click New Role.
     - Important: When creating a new role using Advanced Employee Permissions you must add the Lists > Employee Record permission to the role. This permission is required to access the employee record.
3. Click the **Employee Access** subtab.
4. From the **Permission** list, select the employee access you want to add to the role. Select from the following:
   - **Employee Administration** – This permission is intended for Human Resources Generalists and Human Resources Administrators. Users assigned to a role with this permission have access to HR-related fields on the employee record. For details, see Employee Administration Permission Overview.
Setting Employee Access for Advanced Employee Permissions

- **Employee Compensation** – This permission is intended for managers. Users assigned to a role with this permission have access to compensation information on the employee record. For details, see Employee Compensation Permission Overview.

- **Employee Confidential** – This permission is intended for managers. Users assigned to a role with this permission have access to public and confidential information on the employee record. For details, see Employee Confidential Permission Overview.

- **Employee Public** – This permission is intended for employees. Users assigned to a role with this permission have access to basic employee information on the employee record. For details, see Employee Public Permission Overview.

- **Employee Record Full** – This permission is intended for Human Resources Business Partners, Chief People Officers (CPOs), and Human Resources Directors. Users assigned to a role with this permission have access to all information on the employee record. For details, see Employee Record Full Permission Overview.

- **Employee Self** – This permission is intended for employees. Users assigned to a role with this permission have access to basic personal information on the employee record. For details, see Employee Self Permission Overview.

- **Employee System Access** – This permission is intended for IT Administrators. Users assigned to a role with this permission can give access and assign roles to employees. For details, see Employee System Access Permission Overview.

**Note:** When you select a permission, the default access level and restriction are applied, but you can change these.

5. If required, change the access level for the selected restriction from the **Level** list. For details, see the help topic Access Levels for Permissions.

**Note:** When two employee permissions are included with a role, one at level View and another at level Edit, users assigned to the role see a combination of the fields and sublists they are permitted to view on the employee record. In edit mode, only the fields and sublists that the user can edit are visible on the employee record.

- If you change the access level of the Employee Self permission to Edit, be aware that this gives employees the ability to make changes to the fields exposed with this permission, which includes their compensation information. It is recommended that you use the default access level View, however, if required, you can create a custom permission. For more information, see Custom Advanced Employee Permissions.

- If you change the access level of the Employee Public, Employee Confidential, Employee Compensation, or Employee Administration permissions to Edit, be aware that this gives users the ability to also create employees in NetSuite.

- The Employee Record Full permission gives roles access to all information on the employee record. This permission is intended for Human Resources Business Partners, Chief People Officers (CPO), and Human Resources Directors. To restrict these roles to see only employee administration information, remove the Employee Record Full permission, and add the Employee Administration permission. For details, see Employee Administration Permission Overview.

6. If required, from the **Restrictions** list, select a new restriction level. Select from the following:

- **Active and Non-Terminated** – Select this when you want to restrict the permission to active and non-terminated employees. For example, you could add this restriction to the Employee Public permission, so that users assigned to this role would have access to basic employee information for all active and non-terminated employees only.
Setting Employee Access for Advanced Employee Permissions

- **Inherit from Role** – Select this when you want the permission to inherit the restrictions set on the Role page. For more information about setting restrictions on the Role page, see the help topic Customizing or Creating NetSuite Roles.

- **Own Only** – Select this when you want to restrict the permission to the employee's own record only. Users assigned to this role have access to the fields and sublists exposed with the permission for only themselves. For example, you could add this restriction to the Employee Self permission, so that users assigned to this role would only have access to basic personal employee information for themselves.

- **Subordinates** – Select this when you want to restrict the permission by subordinates. For example, you could add this restriction to the Employee Confidential permission, so that users assigned to this role would have access to public and confidential employee information only for their subordinates.

**Note:** You can also create custom restrictions. For details, see Custom Restrictions for Advanced Employee Permissions.

7. Click Add.
8. Repeat steps 4 to 7 for each permission you want to assign to the role.
9. To finish, click Save.

**Note:** If you change access to a role that a user who is currently logged in to NetSuite is using, that user must log out and log back in to see the newly-assigned access.

Custom Advanced Employee Permissions

This section describes how to create custom Advanced Employee Permissions.

For more information, see the following topics:

- **Before Creating Custom Advanced Employee Permissions**
- **Prerequisites for Creating Custom Advanced Employee Permissions**
- **Creating Custom Advanced Employee Permissions**

Before Creating Custom Advanced Employee Permissions

Both inline editing and inactivating employees from the Employees List page are disabled for users assigned to a role that has a custom employee permission.

Before deploying client or server side scripts that gain access to employee information, make sure:

- The employee field or sublist is available to the role.
- The role has the correct employee permission to see the employee field or sublist for the types of employees being viewed or edited.
- Some scripts (including third-party scripts) may fail if they attempt to access parts of the employee record that they are not permitted to access, with the role and permissions they are assigned.

For more information, see Before Enabling the Advanced Employee Permissions Feature.
Prerequisites for Creating Custom Advanced Employee Permissions

To create custom Advanced Employee Permissions, you need the Setup > Manage Custom Permissions permission at access Level Full. The standard role that comes with this permission is the Administrator role. You can also create custom roles that include this permission. For more information, see the help topic Customizing or Creating NetSuite Roles.

Creating Custom Advanced Employee Permissions

You have two choices when creating custom Advanced Employee Permissions:

- You can create a new permission using a custom set of fields and sublists from the employee record.
- You can customize a standard employee permission to only include a subset of the fields and sublists that are exposed, or customize it to include additional fields and sublists.

Standard employee permissions cannot be modified. Use these permissions as templates to create your own custom employee permissions.

⚠️ **Important:** Some fields on the employee record have dependencies on other fields. Do not add or remove these fields individually. For example, when you customize the Employee System Access permission, having only a partial set of the standard fields that come with this permission prevents the employee record from loading. The employee record only loads when it has either all or none of the access fields.

**To create custom Advanced Employee Permissions:**

1. Go to Setup > Users/Roles > Manage Permissions.
2. From the Manage Permissions page, you can either create a custom or new employee permission.
   - To create a custom employee permission, click **Customize** beside the employee permission you want to customize. All of the standard fields and sublists associated with the parent permission are inherited. You can make changes as necessary.
   - To create a new employee permission that does not start with a list of associated fields and sublists, click **New Permission** from the Manage Permissions page.
3. If required, you can add standard and custom fields to the permission. For more information, see the following help topics:
   - Adding Standard Fields to Custom Advanced Employee Permissions
   - Adding Standard Sublists to Custom Advanced Employee Permissions
   - Creating Custom Fields for Advanced Employee Permissions
   - Adding Custom Fields to Advanced Employee Permission
   - Creating Custom Sublists for Advanced Employee Permissions
   - Adding Custom Sublists to Advanced Employee Permission
4. To finish, click **Save**.
Adding Standard Fields to Custom Advanced Employee Permissions

When you create a custom Advanced Employee Permissions you can include all or a set of standard employee record fields to the permission.

**To add standard fields to custom Advanced Employee Permissions:**
1. Go to Setup > Users/Roles > Manage Permissions.
2. From the Manage Permissions page, click Customize beside the employee permission you want to customize. All of the standard fields and sublists associated with the parent permission are inherited. You can make changes as necessary.
3. To add a standard field, select the Fields subtab, and then the Standard Fields subtab.
4. Click a line in the list.
5. From the Record Type list, select Employee.
6. From the Field list, select the field to add to the permission.
7. Click Add.
8. Repeat steps 4 to 7 for each field you want to include.
9. To finish, click Save.

Adding Standard Sublists to Custom Advanced Employee Permissions

When you create a custom Advanced Employee Permissions you can include all or a set of standard employee record sublists to the permission.

**Important:** When you add a sublist to a custom permission that is associated with another feature in NetSuite, the specific permission for the feature also needs to be added to the role. If the role does not have the required permission for the feature, users do not see any information in the sublist. For example, the Accrued Time and Available Now sublists are associated with the Time-Off Management feature. If you add these sublists to a custom Advanced Employee Permission, you need to make sure that the Time-Off Administration permission is included. For more information, see SuitePeople Permission Requirements and Permissions Documentation.

**To add standard sublists to custom Advanced Employee Permissions:**
1. Go to Setup > Users/Roles > Manage Permissions.
2. From the Manage Permissions page, click Customize beside the employee permission you want to customize. All of the standard fields and sublists associated with the parent permission are inherited. You can make changes as necessary.
3. To add a standard sublist, select the Sublists subtab, and then the Standard Sublists subtab.
4. Click a line in the list.
5. From the Record Type list, select Employee.
6. From the Sublist list, select the sublist to add to the permission.
7. Click Add.
8. Repeat steps 4 to 7 for each sublist you want to include.
9. To finish, click Save.

Creating Custom Fields for Advanced Employee Permissions

You can create custom employee fields, which you can then add to custom Advanced Employee Permissions.

**Important:** When an Advanced Employee Permission is assigned to a role, the permission access level is set on the Role page. Not on the custom entity record. For example, when an Advanced Employee Permission is assigned to a role at access level View, any custom fields that are added to the permission respect that access level.

To create custom fields for Advanced Employee Permissions:

2. In the **Label** field, enter a name or description for the custom field. You can enter up to 200 characters for the label.
3. On the **Applies To** subtab, check the **Employee** box.
4. Click the **Employee Access** subtab.
5. Click a line in the list.
6. From the **Permission** list, select the custom permission with which you want to associate this custom field. This list displays each of the custom Advanced Employee Permissions that have been created.
7. Click **Add**. Alternatively, click **+Insert**, select the permission, and click **Add**.

**Tip:** To remove a permission, select it from the list, and click **Remove**.

8. Repeat steps 5 to 7 for each custom permission you want to associate this custom field with.
9. To finish, click **Save**.

The custom field is automatically added to the custom permission. To see a list of the custom fields associated with a permission, select the **Fields** subtab, and then the **Custom Fields** subtab on the Permission page.

**Note:** The Show In List box on the custom entity field record is not supported with Advanced Employee Permissions. This means that custom fields are not shown on the Employees List page when this box is checked. To display custom fields with Advanced Employee Permissions, you need to create a custom view that contains the custom fields. To do this, click Edit from the Employees List page and manually add the custom fields.

Adding Custom Fields to Advanced Employee Permission

**To add custom fields Advanced Employee Permissions:**

1. Go to Setup > Users/Roles > Manage Permissions.
Creating Custom Fields for Advanced Employee Permissions

2. Click **Customize** or **Edit** beside the permission to which you want to add a custom sublist to.
3. Select the **Fields** subtab.
4. Select the **Custom Fields** subtab.
5. Click a line in the list.
6. From the **Record Type** list, select **Employee**.
7. From the **Field** list, select the custom field to add to the permission.
8. Click **Add**. Alternatively, click **+Insert**, select the record type and sublist, and click **Add**.
9. Repeat steps 5 to 8 for each custom field you want to add to the permission.
10. To finish, click **Save**.

Creating Custom Sublists for Advanced Employee Permissions

You can create a custom employee sublist, which you can then add to Advanced Employee Permissions.

**Important:** When an Advanced Employee Permission is assigned to a role, the permission access level is set on the Role page. Not on the custom entity record. For example, when an advanced employee permission is assigned to a role at access level View, any custom sublists that are added to the permission respect that access level.

To create custom sublists for Advanced Employee Permissions:

1. Go to Customization > Forms > Sublists > New.
2. From the **Type** list, select **Entity**.
3. Check the **Employee** box.
4. From the **Search** list, select the saved search that returns the results you want to appear on the record. If the saved search does not appear in the list, check the saved search settings. The first item listed on the **Available Filters** subtab must be a List/Record type. Otherwise, the saved search is not available to assign as a sublist. For more information, see the help topic Saved Searches for Custom Sublists.
5. In the **Label** field, enter a label for this sublist.
6. From the **Tab** list, select the subtab under which you want the sublist to appear.
7. Repeat these steps for each custom sublist you want to create.
8. To finish, click **Save**.

The custom sublist you created automatically appears in the **Custom Sublists** subtab on the Permission page. For details, see Adding Custom Sublists to Advanced Employee Permission.

Adding Custom Sublists to Advanced Employee Permission

**To add custom sublists to Advanced Employee Permissions:**

1. Go to Setup > Users/Roles > Manage Permissions.
2. Click **Customize** or **Edit** beside the permission to which you want to add a custom sublist to.
3. Select the **Sublists** subtab.
4. Select the **Custom Sublists** subtab.
5. Click a line in the list.
6. From the **Record Type** list, select **Employee**.
7. From the **Sublist** list, select the custom sublist to add to the permission.
8. Click **Add**. Alternatively, click **+Insert**, select the record type and sublist, and click **Add**.
9. Repeat steps 5 to 8 for each custom sublist you want to add to the permission.
10. To finish, click **Save**.

## Custom Restrictions for Advanced Employee Permissions

By default, when Advanced Employee Permissions is enabled there are four pre-defined restrictions. This includes Own Only, Active and Non-Terminated, Subordinates, and Inherit from Role. This section describes how to create custom restrictions for Advanced Employee Permissions and how to assign custom restrictions to a role.

For more information, see the following topics:

- Prerequisites for Creating Custom Restrictions for Advanced Employee Permissions
- Creating Custom Restrictions for Advanced Employee Permissions
- Assigning Custom Restrictions to Advanced Employee Permissions

### Prerequisites for Creating Custom Restrictions for Advanced Employee Permissions

To create custom restrictions for Advanced Employee Permissions, the Setup > Manage Custom Restrictions Permission is required at access Level Full. The standard role that comes with this permission is the Administrator role. You can also create custom roles that include this permission. For more information, see the help topic Customizing or Creating NetSuite Roles.

### Creating Custom Restrictions for Advanced Employee Permissions

You can create custom restrictions to restrict the instances that a role has access to the employee record by location and subsidiary. For example, you may have a Human Resources department that is physically located in one location, but who support staff located in a different location. You can create custom Advanced Employee Permissions’ restrictions to give this department access to sensitive employee data for the staff they support, but limit them to less sensitive information for the employees in their location that they do not support.

**Note:** You cannot make changes to the standard restrictions that come with the Advanced Employee Permissions feature. This includes: Active and Non-Terminated, Inherit from Role, Own Only, and Subordinates.

**To create custom restrictions for Advanced Employee Permissions:**

1. Go to Setup > Users/Roles > Manage Restrictions > New.
2. In the **Name** field, enter a unique name for the restriction. The name entered here appears on the Role page, under the **Employee Access** subtab, in the **Restrictions** list.

3. If required, enter a description for the restriction.

4. From the **Locations** list, select the locations that you want to include with the restriction. The locations selected from this list determine the locations this restriction is limited to. This means that roles that have a permission with this restriction can only access employee information for employees in the selected locations. Hold down the Ctrl key to select multiple locations or to deselect a location from the list.

5. From the **Subsidiaries** list, select the subsidiaries that you want to include with the restriction. The subsidiaries selected from this list determine the subsidiaries this restriction is limited to. This means that roles that have a permission with this restriction can only access employee information for employees in the selected subsidiaries. Hold down the Ctrl key to select multiple subsidiaries or to deselect a subsidiary from the list.

6. Click **Save**.

**Tip:** To remove the restriction, from the **Actions** list, select **Delete**. When the restriction is assigned to a role you need to remove it from the role before you can delete it.

Assigning Custom Restrictions to Advanced Employee Permissions

You can assign a custom restriction to Advanced Employee Permissions on the Role page.

**To assign a custom restriction:**

1. Go to Setup > Users/Roles > Manage Roles.
2. From the list, click **Customize** or **Edit** beside the role to which you want to assign the custom restriction to.
3. Select the **Employee Access** subtab.
4. From the **Permission** list, select the permission you want to add to the role. Select from the following:
   - **Employee Administration** – This permission is intended for Human Resources Generalists and Human Resources Administrators. Users assigned to a role with this permission have access to HR-related fields on the employee record. For details, see Employee Administration Permission Overview.
   - **Employee Compensation** – This permission is intended for managers. Users assigned to a role with this permission have access to compensation information on the employee record. For details, see Employee Compensation Permission Overview.
   - **Employee Confidential** – This permission is intended for managers. Users assigned to a role with this permission have access to public and confidential information on the employee record. For details, see Employee Confidential Permission Overview.
   - **Employee Public** – This permission is intended for employees. Users assigned to a role with this permission have access to basic employee information on the employee record. For details, see Employee Public Permission Overview.
   - **Employee Record Full** – This permission is intended for Human Resources Business Partners, Chief People Officers (CPOs), and Human Resources Directors. Users assigned to a role with this permission have access to all information on the employee record. For details, see Employee Record Full Permission Overview.
- **Employee Self** – This permission is intended for employees. Users assigned to a role with this permission have access to basic personal information on the employee record. For details, see Employee Self Permission Overview.

- **Employee System Access** – This permission is intended for IT Administrators. Users assigned to a role with this permission can give access and assign roles to employees. For details, see Employee System Access Permission Overview.

5. If required, change the access level for the selected restriction from the Level list. For details, see Setting Employee Access for Advanced Employee Permissions.

6. From the Restrictions list, select the custom restriction to apply to the permission.

7. Click Add.

8. Repeat steps 4 to 7 for each custom restriction you want to assign to the role.

9. To finish, click Save.

**Note:** If you add a custom restriction to a role that a user who is currently logged in to NetSuite is using, that user must log out and log back in to see the newly-assigned restriction.
Time Tracking

Managing Time Tracking

A user with the Enable Features permission can enable the Time Tracking feature at Setup > Company > Enable Features, on the Employees subtab. This feature enables employees with access to time tracking to record the hours they work.

**Note:** If you currently use the Timesheets feature, see Timesheets for additional information.

If you are migrating your time features from Timesheets to Time Tracking, the conversion process can take some time depending on the number of time entries and customizations to be converted. When enabling Time Tracking from Timesheets, administrators will receive an email notification that the process has begun. The message will include a link to a status page that details the progress of the migration.

Users of products other than NetSuite CRM+ can record time for payroll items and billable time. Recording billable time enables the invoicing of customers for these hours.

**Warning:** NetSuite CRM+ users cannot record billable time, invoice customers for billable time, or record time for payroll items.

For information about time tracking, see the following:

- Understanding Time Tracking
- Setting Up Time Tracking Preferences
- Giving an Employee Access to Time Tracking
- Entering a Time Transaction
- Weekly Time Tracking
- Using the Timer to Track Time
- Calculating Total Time Worked
- Entering Time for a Payroll Item
- Custom Fields in Time Tracking Pages
- Approving or Rejecting a Time Transaction

Understanding Time Tracking

Use time tracking to record the hours worked by employees.

You can record billable hours and invoice your customers for them. If you use Projects or Project Management, you can also record how many hours are spent on each project and use time reports to plan for future projects and hiring needs. For more information on Time Tracking and Projects, see the help topic Using Project Management, Working with Resources in Project Management, and Managing Time and Expenses for Project Resources.

With the appropriate role access, you can track time for employee payroll items like hourly wages. Employees who have the Restrict Time and Expenses box checked and the Track Time permission enabled can enter time for themselves using their default roles. This eliminates the need for them to change to
the Employee Center role to track their time. For more information, see the topics under NetSuite Users & Roles.

**Warning:** NetSuite CRM+ users cannot record billable time, invoice customers for billable time, or record time for payroll items.

If your role has the Track Time permission, customer records include a Time Tracking subtab that shows associated time records and enables you to enter new ones. If you use Projects or Project Management, project records also include a Time Tracking subtab.

A user with the Enable Features permission must enable the Time Tracking feature at Setup > Company > Enable Features, on the Employees subtab.

To set preferences for tracking time, go to Setup > Accounting > Preferences > Accounting Preferences and click the Time & Expenses subtab. For more information, see Setting Up Time Tracking Preferences.

**Note:** If you use NetSuite OneWorld, the Intercompany Time and Expense feature and the related Intercompany Time accounting preference affect users' ability to enter time worked for customers or projects with subsidiaries other than their own. If the feature is not enabled, or if the preference is set to Disallow, users cannot enter intercompany time transactions. Instead, they can only select customers or projects with the same subsidiary to which they are assigned. For more information, see the help topic Enabling Intercompany Time and Expenses.

**Time Thresholds**

You can set time thresholds to limit how employees and vendors enter time. Time threshold preferences enable you to specify the minimum and maximum number of hours permitted per day and week. You can set one or all of these preferences to limit the number of hours permitted to be tracked on a weekly basis. You can opt to set the limits manually, or you can have the limits set automatically based on the work calendar. You can also choose to permit time transactions to be submitted outside the limits you set. You can choose whether or not to apply your time thresholds to vendor time.

**Note:** Time thresholds are not available when using SuiteScript, SuiteFlow, or custom approval routing.

Daily time threshold preferences account for holidays and non-working days based on the selected work calendar. NetSuite does not verify non-working days, holidays, or entries on a timesheet that have not yet been filled.

For employees without a selected work calendar, time thresholds use the system default work calendar to determine holidays and non-working days. Zero time entries are considered filled entries and are verified according to set limits. Regardless of work calendars, employees can still track time on non-working days and holidays and time threshold limits are applied accordingly.

If you also use advanced approvals, you can choose to require that a time entry be entered for each working day.

**Important:** NetSuite validates set time thresholds within the browser. When an entry is made for the duration of a time transaction, NetSuite validates that the entry fits within the set limits. If an entry is left blank, NetSuite will not validate for that entry. This can create a situation where time transactions are saved that do not meet set threshold limits.

If you use Weekly Timesheets, thresholds are validated on both individual time entries and each timesheet. It is possible for a single time entry to satisfy a daily limit but violate a weekly limit. In this situation the time entry would generate a warning because of the timesheet the entry is a part of. You can choose to allow time to be submitted after warnings are displayed.
Time thresholds are checked upon submission of the time entries. You can also choose to have the time entries validated again when they are approved.

To set time thresholds, go to Setup > Accounting > Accounting Preferences and make selections for time thresholds at the bottom of the Time Tracking section.

For more information about time thresholds, see the help topic Time & Expenses Accounting Preferences.

### Enabling Time Tracking for CRM

With Time Tracking for CRM, users can track time on tasks, phone calls, events and cases. Tracking time on these activities can help you manage your company by being aware of how much time is spent on certain activities.

⚠️ **Important:** The Time Tracking feature and the associated permissions are required to use Time Tracking for CRM.

An administrator must enable the feature before users can track time.

**To enable Time Tracking for CRM:**

1. Go to Setup > Company > Enable Features
2. Click the Employees subtab, and check the Time Tracking for CRM box.
3. Click Save.

⚠️ **Important:** If you also use the Projects feature and want to track time for customers, you must disable the Show Projects Only for Time and Expense Entry preference located on the Time & Expenses subtab at Setup > Accounting > Accounting Preferences. When this preference is enabled, time can only be tracked for CRM Tasks associated with a project record.

### Enabling Weekly Timesheets

The Weekly Timesheets feature works in conjunction with the existing Time Tracking feature to offer a customizable method of capturing time entries in a weekly format.

⚠️ **Important:** The Time Tracking feature and the associated permissions are required to use Weekly Timesheets.

An administrator must enable the feature before users can track time using the weekly timesheet.

**To enable Weekly Timesheets:**

1. Go to Setup > Company > Enable Features
2. Click the Employees subtab, and check the Weekly Timesheets box.
3. Click Save.

**Note:** Weekly Timesheets is an additional feature that offers a customizable method for entering time on a weekly basis. The Time Tracking feature includes a Weekly Time Tracking page which can be used to track time on a weekly basis without any additional customizations. If enabled, Weekly Timesheets will take the place of the included Weekly Time Tracking.

For more information on using weekly timesheets, see Weekly Timesheets.
Setting Up Time Tracking Preferences

Time tracking lets you track the hours you and other employees work. You can record billable hours and invoice your customers for them.

**Warning:** NetSuite CRM+ users cannot record billable time, invoice customers for billable time, or record time for payroll items.

Set time tracking preferences to determine how you process time that you track.

**Note:** Preferences that appear vary depending on the features you have enabled. If you use NetSuite OneWorld and the Intercompany Time and Expense feature is enabled in your account, review the Intercompany Time preference available on the General subtab of the Accounting Preferences page. This preference indicates whether users can enter time transactions for customers and projects with subsidiaries other than their own. For more information, see the help topic Enabling Intercompany Time and Expenses.

To set time tracking preferences:

1. Go to Setup > Accounting > Preferences > Accounting Preferences.
2. Click the Time & Expenses subtab and enable or disable preferences as desired.
   - Available preferences may include the ability to override rates on time records, to automatically round time entries, to require approvals on time records, to make time billable by default, to copy time memos to invoices, to show planned time on time tracking records and weekly timesheets, to lock timesheet periods, and to set time thresholds.
   - For more information, see the help topic Time & Expenses Accounting Preferences.
3. Click Save.
4. Go to Setup > Company > Preferences > General Preferences.
   - Select the day of the week your company uses as the first day of the business week. The day you select is reflected on time tracking forms and on reports.

Next, you can give your employees limited access to your account so they can enter time transactions. To do this, go to Lists > Employees > Employees. Make sure the appropriate employee records are granted access to the Employee Center.

Giving an Employee Access to Time Tracking

Giving employees access to time tracking enables them to enter the hours they spend working for a particular customer or on a project.

There are three steps you must complete to give employees access to time tracking:

1. An administrator must enable the Time Tracking features and set time tracking preferences.
2. You must either set up access on employee records to the Employee Center or assign a custom role with the Track Time permission.
3. You must provide access information to the employee.

After you have enabled time tracking, you can set preferences for how you want to use the feature.

Next, if you have not already, create an employee record for employees that you want to give access to time tracking.
For more information on creating employee records, see the following:

- Adding an Employee Record
- Giving an Employee Access to NetSuite
- Assigning Roles to an Employee

**Give Access to the Employee Center**

As of 2018.2, you should use the following procedure and let users set up a NetSuite password for themselves. However, if you prefer to assign user passwords yourself, see Assign a Password Manually instead.

**To give an employee access to the Employee Center:**

1. Go to Lists > Employees > Employees.
2. Click Edit next to the employee to whom you want to give access.
3. Under Email | Phone | Address, ensure the employee’s email address is entered.
4. Click the Access subtab.
5. Check the Give Access box.
6. If this is a new employee, check the Send New Access Notification Email box to inform the user how to access your NetSuite account. The standard user access notification includes the email address to use for logging in to NetSuite, and also contains a URL so that the user can set up a NetSuite password.
7. On the Roles tab, select Employee Center from the list.
8. Click Add.
9. Click Save.

**Assign a Password Manually**

You should use the procedure in Give Access to the Employee Center that lets users set up a NetSuite password for themselves. However, if you prefer to assign a user’s password yourself, use the following procedure.

**To manually assign a password:**

1. Do one of the following:
   - If the user is an employee, go to Lists > Employees > Employees.
   - If the user is not an employee, go to List > Relationships, and then select Customers, Partners, or Vendors.
2. Click Edit next to the user that you want to assign a role to.
3. In the Email field, enter the user’s email address.
   - This is the email address used to log in to NetSuite.
4. Click the Access tab.
5. Check the Give Access box.
6. On the Roles tab, select Employee Center from the list.
7. Do not check the Send New Access Notification Email box.
8. Check the Manually Assign or Change Password box.
9. Enter a password for your user. As you type, the characters are validated against the password policy criteria, and the results displayed.

**Note:** If you need more information, see the help topic NetSuite Password Requirements.

10. Enter the password again for verification.
11. Check the Require Password Change on Next Login box to require the user to change the password on the next login to NetSuite.

On the next login, they see the Change Password page and cannot access other NetSuite pages until a new password is created and saved.

Requiring this action protects your account from unauthorized access using generic passwords and prepares your account for an audit.

**Important:** The Require Password Change on Next Login box never displays as checked. When you check this box and save the record, an internal flag is set. When the password change occurs, the flag is cleared. If you later check the box again and save the record, the internal flag is reset to require another password change.

12. When you have finished entering information, click Save.
13. Next, tell your user the appropriate login page to go to, the email address to use for login, and the password you assigned. For security reasons, do not send the password by email.

For details, see the help topic Types of Login Pages for Your NetSuite Account.

After employees log in to NetSuite, they can enter time and view their time reports.

If you enabled the Require Approvals on Time Records preference, supervisors can also approve time reports entered by the employees they supervise. You can also create custom approval routing workflows to enable more customization of your approval process. With custom approval routing on time entries, employees can approve or reject the entries where they are set as the Next Approver from the Employee Center.

### Assigning Custom Roles with Access to Time Tracking

**To assign an employee a custom role with access to time tracking:**

1. Go to Setup > Users/Roles > Manage Roles.
2. Click Customize next to the role you want to assign with time tracking permission.
3. Enter a name for this custom role.
4. Check the Restrict Time and Expenses box to permit employees to enter time for only themselves.
5. On the Transactions subtab, select Track Time in the Permission column.
6. In the Level column, select Full.
7. Click Add.
8. Click Save.
9. On employee records, select this role on the Access tab to assign this role and give access to time tracking.
Restricting Employee Time Tracking Entries

Account administrators can control which names display for certain roles in the time entry list by editing user roles. Limits on this list restrict the ability of employees to enter time for other employees.

To restrict employees to enter time for only themselves or their subordinates:

1. Go to Setup > Users/Roles > User Management > Manage Roles.
2. Click the Customize link next to the role you want to restrict.
3. Enter a new name for the restricted role.
4. On the Role page, in the Employee Restrictions field, select self and subordinates only.
5. Click Save.
6. Repeat steps 2 through 5 for each role you want to restrict from being able to enter time for every employee.

You must update your employee records to assign the restricted roles. For more information, see Assigning Roles to an Employee.

For the roles that you customize, additional areas of NetSuite are restricted based on the selection you’ve made. For more information, see the help topic Set Employee Restrictions.

Locking Timesheet Periods

Account administrators can disable the ability for employees to submit, edit, or add a time entry within a specific time period. You can choose to lock timesheets by closed fiscal periods, weekly, or monthly.

**Note:** The Weekly Timesheets feature is required to enable locking timesheet periods. For more information, see Weekly Timesheets.

You can allow other roles to manage locked timesheet periods by adding the Unlock Time Period permission to a custom role. For more information, see the help topic Customizing or Creating NetSuite Roles.

To set up a timesheet lock:

1. Go to Setup > Accounting > Accounting Preferences. Click Time & Expenses.
2. Under Time Tracking, in the Lock Timesheet Period field, select the time period after which you want time entries to be locked.
   - None - time entries are always allowed.
   - Closed Fiscal Period - time entries are no longer allowed after the accounting period is closed.
   - Weekly - time entries are no longer allowed after the current week has past.
   - Monthly - time entries are no longer allowed after the current month has past.
3. If you select Weekly or Monthly, in the Grace Period field, enter the number of days time entries will remain open after the selected period. The grace period is dependent on which day your timesheets begin. For example, if you choose to close timesheets every week and you enter two in the Grace Period field, if your timesheets begin on Monday, they are locked on Wednesday each week.
4. When you have finished, click Save.
A single timesheet can contain both locked and unlocked time entries if the timesheet spans a locked and unlocked period. Administrators can unlock previously locked timesheets for a specific employee. Administrators can also edit or create time entries for a locked timesheet.

Unlocking Timesheet Periods

You may find it necessary to unlock a time period after it has been locked for employees to update or enter time that may have been forgotten. Administrators can unlock previously locked time periods for individual employees.

**To unlock a time period:**

1. Go to Transactions > Employees > Unlock Time Period. You can also click Unlock on the specific timesheet you want to unlock. To view a specific timesheet, go to Transactions > Employees > Weekly Timesheets > List. Click View next to the timesheet you want to unlock.
2. On the Unlock Time Period page, in the Employee field, select the employee you want to unlock the time period for. If you have clicked Unlock directly from the timesheet, the employee field is populated with the employee’s name.
3. In the Valid Until field, select the date you want the lock to be reinstated.
4. In the Start Date field, select the start date for the period you want unlocked. If you clicked Unlock on a timesheet, the start date for that timesheet is automatically populated in this field.
5. In the End Date field, select the end date for the time period you are unlocking. For example, if you want to unlock a two week period of timesheets, select a date that is two weeks after the selected start date.
6. When you have finished, click Save.

Unlocking timesheet periods is only available for administrators and permission for unlocking timesheet periods is not available for custom roles.

Entering a Time Transaction

Enter time transactions to track the hours you and other employees work.

**To enter a time transaction:**

1. Go to Transactions > Employees > Track Time.
2. Select a form for this transaction.
3. Select the employee whose time you are recording.
4. NetSuite inserts the current date as the posting date of this entry. Accept or select the date for this time transaction.
5. In the Duration field, enter the amount of time worked for the day.

   When you enter time, minutes that total more than 59 are automatically converted to hours to be added to the total time. Time entries can have minutes entered and saved in a range of 0 to 59.

   For example, if you enter :125, it is interpreted as 125 minutes and is converted to display as 2:05.
   Likewise, these time entries are converted as follows:
   - 0:125 is converted to 2:05 (2 hours and 5 minutes)
   - 1:80 is converted to 2:20 (2 hours and 20 minutes)
1:120 is converted to 3:00 (3 hours and zero minutes)

If you want to time yourself as you work or time the length of your break, click the **Timer icon** next to the **Duration** field. The elapsed time in the timer fills in the **Duration** field when you click **Submit**.

6. **Select a customer or project if the time worked is for a customer or project.**

   If you use NetSuite OneWorld, the **Intercompany Time and Expense** feature and the related **Intercompany Time** accounting preference determine whether you can select a customer or project with a subsidiary different from yours. If the feature is not enabled, or if the preference is set to **Disallow**, you cannot enter intercompany time transactions. Instead, you can only select customers or projects with the same subsidiary to which you are assigned. For more information, see the help topic **Enabling Intercompany Time and Expenses**.

7. **If you use the Project Management feature and selected a project in the Customer field with which this time is associated, you can select a related case, event, or task for the project.**

8. **Select the service that was provided if you track time spent on services.**

   If you selected a customer or project, you must select a service item.

   **Note:** The service item description is automatically copied to the memo field for the time transaction. You may turn off this preference at Setup > Accounting > Accounting Preferences on the Time & Expenses subtab.

   If you use NetSuite OneWorld, it is recommended that you set up service items that are available to all subsidiaries, for use in intercompany time transactions. In these transactions, users cannot save lines unless they contain service items available to both the employee subsidiary and customer subsidiary. See the help topic **Enabling Intercompany Time and Expenses**.

9. **Check the Billable box if this time is billable to a customer or project.**

   **Warning:** In NetSuite CRM+, the **Billable** box is not available. NetSuite CRM+ users cannot record billable time, invoice customers for billable time, or record time for payroll items.

10. **If your company supports Multi-State Calculations for payroll, select the Payroll Item Workplace for this time entry.**

11. **Select a payroll item if you are tracking time for payroll.**

12. **Check the Paid Externally box if time has been or will be paid outside of NetSuite. This removes the time from payroll transactions. You cannot check this box if this time record is already associated with a paycheck in NetSuite.**

13. ** Optionally enter a memo. You can search for the text you enter here to find this transaction later.**

   If you are billing this time back to a customer or project, this memo appears as a description for this line item on the customer invoice.

   **Note:** Always select an activity in the **Case/Task/Event** or **Service Item** fields before entering a memo. When you select a case, task, event, or service item, the memo field is automatically populated with information from these records. Anything you entered in the memo field prior to selecting one of these records will be deleted. Changing your selection in either of these fields will update the memo field with any information from the newly selected record.

14. **If your company does not use Advanced Approvals for Time, check the Supervisor Approval box if you are a supervisor entering time for an employee.**

   If your company does use Advanced Approvals for Time and you are a supervisor or time approver, select a status for this time entry in the **Approval Status** field. If you use Approval Routing, you can
also select another approver in the Next Approver field. For more information, see Approving or Rejecting a Time Transaction.

15. Under Classification, select a department, class, or location if your company tracks this information.

**Important:** If you use NetSuite OneWorld and you are entering intercompany time transactions, you must determine a strategy for using classifications on these transactions. Best practice is to omit them. For more information, see the help topic Enabling Intercompany Time and Expenses.

16. If the Override Rates on Time Records preference has been enabled on the Time & Expenses subtab at Setup > Accounting > Accounting Preferences, the following fields display:

- **Price Level** - Select a price level. You can use different price levels by going to Setup > Enable Features > Customers/Sales, and checking the Use Multiple Prices box.
- **Rate** - If you selected a price in the Price Level field, it automatically appears here. If you do not use multiple prices or if you selected Custom in the Price Level field, enter a rate for this time transaction. If you are entering time for a payroll item like vacation time, leave this field blank.
- **Lock this Rate** - If you are billing this time back to a customer, check this box to lock the rate you enter so it's not affected by rate changes that happen before the customer is billed. If you are entering time for a payroll item like vacation time, leave this field blank.

17. Click Save.

If your company uses Approval Routing or Advanced Approvals for Time, the employee's supervisor or time approver receives an email notification when time is entered or edited.

You can also enter a time transaction on a customer or project record. To do so, go to Transactions > Employees > Track Time. Click Edit next to the customer.

If you billed time back to a customer or project, it appears when you click Billable Time on the corresponding invoice page.

If you tracked time for hourly wage payroll items and did not check the Paid Externally box, the time appears in the Hours column for this employee on the Payroll Run page.

### Deleting or Editing Time Entries

You can delete or edit time entries that you have created for yourself or other employees as long as they have not been approved by a supervisor or time approver. Administrators can delete approved time entries as long as they have not been billed.

**To delete or edit an unapproved time entry:**

1. Go to Transactions > Employees > Track Time > List.
2. On the Time Entries page, click Edit next to time entry you want to edit or delete.
   You can filter the entries shown by clicking Filters to expand the available list filters.
3. On the Time Tracking page, do one of the following:
   - To edit the time entry, enter a new amount of time in the Duration field. Change any other information about the time entry as needed.
   - To delete the time entry, choose Actions > Delete.
4. Click Save.

If your company uses Approval Routing or Advanced Approvals for Time, the employee's supervisor or time approver receives an email notification each time a time entry is edited.
Weekly Time Tracking

With weekly time tracking, you can track the hours you and other employees work for a week at a time.

To track time, an administrator should go to Setup > Enable Features > Employees, check the Time Tracking box, and click Save.

**Note:** If your company uses weekly timesheets, see Weekly Timesheets.

Using Weekly Time Tracking

To use weekly time tracking:

1. Go to Transactions > Employees > Weekly Time Tracking.
2. Select the employee whose time you are recording.
3. In the Date field, enter the first day of the week you want to track time for, or click the Pick link to choose a date.
   NetSuite inserts the date that the current week begins as the posting date of this week's time.
   You can set the day your company's business week starts by going to Setup > Accounting > Preferences > Accounting Preferences. Click the General subtab.
4. If you use Project Management, you can import any planned time entries for the selected employee and week. Click Import Planned Time to automatically import the project time entries for the current week.
5. If you do not use the Advanced Approvals preference, check the Supervisor Approval box if you are a supervisor entering time for an employee.
6. On the Enter Time subtab, in the Customer column, select a customer or project if the time worked is for a customer or project.
   If you use NetSuite OneWorld, the Intercompany Time and Expense feature and the related Intercompany Time accounting preference determine whether you can select a customer or project with a subsidiary different from yours. If the feature is not enabled, or if the preference is set to Disallow, you cannot enter intercompany time transactions. Instead, you can select only those customers or projects with the same subsidiary to which you are assigned. For more information, see the help topic Enabling Intercompany Time and Expenses.
7. If you use the Project Management feature and selected a project in the Customer field, use the Case/Task/Event column to select an activity associated with the project and time.
8. If your company uses multi-state calculations for payroll, select a Payroll Item Workplace.
9. Check the Billable box if this time is billable to a customer or project.

**Warning:** In NetSuite CRM+, the Billable box is not available. NetSuite CRM+ users cannot record billable time, invoice customers for billable time, or record time for payroll items.

10. Select a payroll item if you are tracking time for payroll.
11. Select the service that was provided if you track time spent on services.
   If you selected a customer or project, you must select a service item.
   If you use NetSuite OneWorld, it is recommended that you set up service items that are available to all subsidiaries, for use in intercompany time transactions. In these transactions, users cannot save lines unless they contain service items available to both the employee subsidiary and customer subsidiary. See the help topic Enabling Intercompany Time and Expenses.
12. Select a department, class, or location if you track this information.

**Important**: If you use NetSuite OneWorld and you are entering intercompany time transactions, you must determine a strategy for using classifications on these transactions. Best practice is to omit them. For more information, see the help topic Enabling Intercompany Time and Expenses.

13. If the **Override Rates on Time Records** preference has been enabled on the **Time & Expenses** subtab at Setup > Accounting > Accounting Preferences, the following fields display:

- **Price Level** - Select a price level. You can use different price levels by going to Setup > Enable Features > Customers/Sales, and checking the **Use Multiple Prices** box.
- **Rate** - If you selected a price in the **Price Level** field, it automatically appears here. If you do not use multiple prices or if you selected **Custom** in the **Price Level** field, enter a rate for this time transaction. If you are entering time for a payroll item like vacation time, leave this field blank.
- **Lock this Rate** - If you are billing this time back to a customer, check this box to lock the rate you enter so it’s not affected by rate changes that happen before the customer is billed. If you are entering time for a payroll item like vacation time, leave this field blank.

14. Enter a memo.

If you are billing this time back to a customer or project, this memo appears as a description for this line item on the customer invoice.

**Note**: Always select an activity in the **Case/Task/Event** or **Service Item** fields before entering a memo. When you select a case, task, event, or service item, the memo field is automatically populated with information from these records. Anything you entered in the memo field prior to selecting one of these records will be deleted. Changing your selection in either of these fields will update the memo field with any information from the newly selected record.

15. Enter the hours for each day in this week.

16. Click **Add**.

17. Repeat steps above for each customer or project you need to enter time against.

18. Click **Save** to save the entries. If you use Advanced Approvals, you can also click **Submit** to save and submit the entries.

When time is saved, the time then appears on the Time Details subtab of the time tracking for that week. If you billed time back to a customer or project, it appears when you click Billable Time on the corresponding invoice page. If you tracked time for hourly wage payroll items, it appears in the Hours column for this employee on the Payroll Run page.

In addition to entering new time each week, you can also copy the time entries from a previous week onto to the current week.

**Copying a Previous Week for Weekly Time Tracking**

**To copy a previous week for weekly time tracking:**

1. Go to Transactions > Employees > Weekly Time Tracking.
2. Click **Copy from Week**. A window opens with the start date of the previous week's time automatically populated.
3. In the Date field, you can accept the date automatically entered or use the date selector to select a different date.

4. If your company enables employees to choose to copy hours and memos, clear the Copy Hours and Memos box if you do not want hours and memos from the selected week to be copied to the current week.

5. Click Copy. Time entries within the selected week are copied to the weekly time tracking page currently being edited. Depending on your company’s preferences, copied time entries may include hours and memos.

6. Continue to fill in required information for this time. When you have finished, click Save.

To view a list of all weekly time tracking entries you have permission to view, go to Transactions > Employees > Weekly Time Tracking > List. This list displays the employee, date, hours, and approval status of each week.

Advanced Approvals

If your company uses the Advanced Approvals on Time preference, after time is saved on your Weekly Time Tracking page, the background of each entry reflects that entry’s approval status.

- Open — white
- Approved — green
- Rejected — red
- Pending — blue

Advanced approvals enables your employees to know the status of their time entries within a single week just by looking at the Weekly Time Tracking page. When rejecting transactions, advanced approvals enables you to add a rejection note. For more information on Advanced Approvals, see Approving or Rejecting a Time Transaction.

Weekly Timesheets

Weekly timesheets works in conjunction with the existing Time Tracking feature to offer a customizable method of capturing time entries in a weekly format.

To track time with weekly timesheets, an administrator should go to Setup > Company > Enable Features and select the Employee subtab. In Time & Expenses check the Time Tracking and Weekly Timesheets boxes, and click Save.

**Note:** If your company uses weekly time tracking, see Weekly Time Tracking.

**Important:** If your company has enabled the Weekly Timesheet Interface, the user interface will differ slightly from the steps described below. For more information on the changes, see Weekly Timesheets Interface.

Using Weekly Timesheets

**To use weekly timesheets:**

1. Go to Transactions > Employees > Weekly Timesheet.
2. Select the employee whose time you are recording. If a timesheet for the selected employee and week already exists, NetSuite loads the existing timesheet.

3. In the **Week of** field, enter the first day of the week you want to track time for, or click the **icon to choose a date.** NetSuite loads a new or existing timesheet.

   NetSuite inserts the date that the current week begins as the posting date of this week's time.

   You can set the day your company's business week starts by going to Setup > Company > General Preferences. Select the day from the **First Day of Week** list.

   **Note:** If you change the first day of the week preference for your company, the newly selected first day of the week will be used for any new timesheets. Any existing timesheets will remain unchanged. New timesheets may be shorter to accommodate the new first day of the week. The first day of the week preference can be set at the company, subsidiary (for OneWorld accounts), and user level. Weekly Timesheets is only affected by the company and subsidiary preference. The user level preference has no effect on the first day of the week for weekly timesheets.

4. If you use Project Management, you can import any planned time entries for the selected employee and week. Click **Import Planned Time** to automatically import the project time entries for the current week.

5. On the **Enter Time** subtab, in the **Customer** column, select a customer or project if the time worked is for a customer or project.

   If you use NetSuite OneWorld, the **Intercompany Time and Expense feature** and the related **Intercompany Time accounting preference** determine whether you can select a customer or project with a subsidiary different from yours. If the feature is not enabled, or if the preference is set to **Disallow**, you cannot enter intercompany time transactions. Instead, you can select only those customers or projects with the same subsidiary to which you are assigned. For more information, see the help topic **Enabling Intercompany Time and Expenses**.

6. If you use the **Project Management feature** and selected a project in the **Customer** field, use the **Case/Task/Event** column to select an activity associated with the project and time.

7. If your company uses multi-state calculations for payroll, select a **Payroll Item Workplace**.

8. Check the **Billable** box if this time is billable to a customer or project.

   **Warning:** In NetSuite CRM+, the **Billable** box is not available. NetSuite CRM+ users cannot record billable time, invoice customers for billable time, or record time for payroll items.

9. Select a payroll item if you are tracking time for payroll.

10. Select the service that was provided if you track time spent on services.

    If you selected a customer or project, you must select a service item.

    If you use NetSuite OneWorld, it is recommended that you set up service items that are available to all subsidiaries, for use in intercompany time transactions. In these transactions, users cannot save lines unless they contain service items available to both the employee subsidiary and customer subsidiary. See the help topic **Enabling Intercompany Time and Expenses**.

11. Select a department, class, or location if you track this information.

    **Important:** If you use NetSuite OneWorld and you are entering intercompany time transactions, you must determine a strategy for using classifications on these transactions. Best practice is to omit them. For more information, see the help topic **Enabling Intercompany Time and Expenses**.

12. If the **Override Rates on Time Records** preference has been enabled on the **Time & Expenses** subtab at Setup > Accounting > Accounting Preferences, the following fields display:
Managing Time Tracking

- **Price Level** - Select a price level. You can use different price levels by going to Setup > Enable Features > Customers/Sales, and checking the **Use Multiple Prices** box.

- **Rate** - If you selected a price in the **Price Level** field, it automatically appears here. If you do not use multiple prices or if you selected **Custom** in the **Price Level** field, enter a rate for this time transaction. If you are entering time for a payroll item like vacation time, leave this field blank.

- **Lock this Rate** - If you are billing this time back to a customer, check this box to lock the rate you enter so it’s not affected by rate changes that happen before the customer is billed. If you are entering time for a payroll item like vacation time, leave this field blank.

13. Enter a memo.
   
   If you are billing this time back to a customer or project, this memo appears as a description for this line item on the customer invoice.

**Note:** Always select an activity in the **Case/Task/Event** or **Service Item** fields before entering a memo. When you select a case, task, event, or service item, the memo field is automatically populated with information from these records. Anything you entered in the memo field prior to selecting one of these records will be deleted. Changing your selection in either of these fields will update the memo field with any information from the newly selected record.

14. Enter the hours for each day in this week.

15. Click **Add**.

16. Repeat steps above for each customer or project you need to enter time against.

17. Click **Save** to save the entries. If you use Advanced Approvals, you can also click **Save & Submit** to save and submit the entries.

When a timesheet is saved, the time then appears on the Time Details subtab of the timesheet for that week.

If you billed time back to a customer or project, it appears when you click Billable Time on the corresponding invoice page.

If you tracked time for hourly wage payroll items, it appears in the Hours column for this employee on the Payroll Run page.

Weekly timesheets can be edited even if some or all of the time entries have been approved. Individual time entries with a status of approved or pending approval are locked and cannot be edited. You can add new time entries to weekly timesheets that have been fully approved. Any submitted weekly timesheet that has been edited must be resubmitted for approval.

In addition to entering new time each week, you can also copy the time entries from a previous week on to the current week.

**Copying a Previous Week for a Weekly Timesheet**

**To copy a previous week for a weekly timesheet:**

1. Go to Transactions > Employees > Weekly Timesheet.
2. Click **Copy from Week**. A window opens with the start date of the previous week’s time automatically populated.
3. In the **Date** field, you can accept the date automatically entered or use the date selector to select a different date.
4. If your company enables employees to choose to copy hours and memos, clear the **Copy Hours and Memos** box if you do not want hours and memos from the selected week to be copied to the current week.

5. Click **Copy**. Time entries within the selected week are copied to the weekly timesheet currently being edited. Depending on your company's preferences, copied time entries may include hours and memos.

6. Continue to fill in required information for this time. When you have finished, click **Save**.

To view a list of all the weekly timesheets you have permission to view, go to Transactions > Employees > Weekly Timesheet > List. This list displays the employee, date, hours, and approval status of each week.

### Customizing Weekly Timesheets

When you customize your weekly timesheet you must create two custom forms. First, you create a custom time bill form for your time entries. Then, you create a custom timesheet form and select the custom time entry form as the basis for the time entry grid on your timesheet.

**To customize a weekly timesheet:**

1. Go to Transactions > Employees > Weekly Timesheet.
2. Click **Customize Time Bill Form** in the Customize menu on the upper right corner of the page. A Custom Entry Form page opens.
3. Enter a name for your custom time bill form.
4. Make any changes you'd like to the form. For more information on customizing entry forms, see the help topic **Creating Custom Entry and Transaction Forms**.

   **Note:** The changes you make to the custom time bill form will change how the time entry grid appears on your weekly timesheets.

5. When you have finished, click **Save**.
6. Go to Transactions > Employees > Weekly Timesheet.
7. Click **Customize Form** in the Customize menu on the upper right corner of the page. A Custom Entry Form page opens.
8. Enter a name for your custom timesheet form.
9. In the **Time Entry Custom Form** field, select the name of your custom time bill form.
10. Make any additional changes you'd like to the form.
11. When you have finished, click **Save**.

Your custom form is now available for weekly timesheets.

### Missing Weekly Timesheets

You can use hidden fields to create saved searches and add dashboard reminders to track incomplete timesheets. Missing timesheets are automatically created for the current week and the previous five weeks on the first day of the week for active employees and project resources.

The following fields are hidden on the Weekly Timesheet:

- Submitted hours – Sum of pending and approved hours.
- Rejected hours – Sum of hours with rejected status.
- Planned hours – Sum of planned hours. This field is only available when Project Management and Show Planned Time in Time Entry preference are enabled.
- Allocated hours – Sum of allocated hours. This field is only available when Resource Allocations is enabled.
- Work Calendar hours – Sum of expected hours based on the employee work calendar.

All of these fields are automatically calculated and hidden by default. You must customize your weekly timesheet entry form to show these fields in the user interface. However, the fields do not need to be showing to use reminders and searches for missing timesheets.

For more information, see Customizing Weekly Timesheets, Setting Up Reminders, and Defining a Saved Search.

Weekly Timesheets Interface

If your company has enabled the New Weekly Timesheet Interface, the Weekly Timesheet page has been updated to include several enhancements to the user interface. Column headers are now fixed at the top of the line-items so that they are visible at all times. Time entries are also now fixed on the screen. You can side scroll to see other information about each line but the time entries will remain visible. The top of each column will display the total hours for each day.

You can now add a memo to a single time entry with a pop-up window that is saved automatically when you click away from the window. You can use form customization to add fields to the pop-up window. For saved time, the pop-up window also includes a Time Details link that opens the individual time entry in a new window. A memo icon appears in the corner of each time entry that has a memo. Approvers can now approve or reject single time entries from the pop-up window on the weekly timesheet.

The Copy From Week and Import Planned Time buttons have been relocated to the Enter Time subtab. The Time Details subtab has been replaced by a Planned Time subtab. The Planned Time subtab shows any upcoming planned project time entries. You can now scroll through timesheets more easily by clicking the arrows on either side of the Week Of field.

**Note:** Copying an individual line is not currently available with the New Weekly Timesheet Interface.

Weekly Timesheets supports Time-Off Management. When time-off is approved, the Time-off field on time transactions is populated with a link to the time-off record. The Time-off Type field on time transactions displays the type of time-off. These fields are hidden by default but can be added by customizing your time tracking form. For more information, see Time-Off Management.

To enable the new interface for Weekly Timesheets, go to Setup > Company > Enable Features > Employees. Check the New Weekly Timesheets Interface box, and click Save. After the feature is enabled, all users with timesheet permissions will use the new user interface.

Advanced Approvals

If your company uses the Advanced Approvals on Time preference, after time is saved on your Weekly Timesheet page, the background of each entry reflects that entry's approval status.

- Open — white
- Approved — green
- Rejected — red
- Pending — blue
Advanced approvals enables your employees to know the status of their time entries within a single week just by looking at the Weekly Timesheet page. When rejecting transactions, advanced approvals enables you to add a rejection note. For more information on Advanced Approvals, see Approving or Rejecting a Time Transaction.

Using the Timer to Track Time

Time tracking lets you track the hours you and other employees work. You can enter the hours worked manually, use NetSuite's time calculator, or use NetSuite's Timer.

You can use the Timer to time your break or to time your entire day's work.

If you use the Timer, you cannot navigate away from the Time Tracking page and the Timer popup window. If you do, the Timer is stopped and NetSuite does not save the elapsed time.

Using the Timer for your Break

To use the Timer for your break:

1. Go to Transactions > Employees > Track Time.
2. Enter the time tracking details as appropriate.
3. Next to the Duration field, click the Timer icon.
4. When the Timer popup window appears, click Start when your break begins.
5. Click Stop when your break is over.
6. Click Submit.

   The elapsed time automatically appears in the Break field. NetSuite rounds down to the nearest minute. For example, if the Elapsed Time field says 0:03:55, 0:03 appears in the Duration field.
7. Fill in any additional information, and then click Save.

   You can also use the Timer to time your entire day's work, rather than your break.

Using the Timer for an Entire Day's Work

To use the Timer for an entire day's work:

1. Go to Transactions > Employees > Track Time.
2. Enter the time tracking details as appropriate.
3. Next to the Duration field, click the Timer icon.
4. When the Timer popup window appears, click Start when you begin working.
5. Click Pause when you take a break.
6. Click Start again when you come back from your break.
7. Click Stop when you finish working.
8. Click Submit.

   The elapsed time automatically appears in the Duration field. NetSuite rounds down to the nearest minute. For example, if the Elapsed Time field says 0:03:55, 0:03 appears in the Duration field.
9. Fill in any additional information, and then click Save.

Using the Timer, NetSuite tracks your hours for you so you do not have to enter them manually.
Calculating Total Time Worked

Time tracking lets you track the hours you and other employees work. You can enter the hours worked manually, use NetSuite's Timer, or use NetSuite's time calculator.

**To calculate your total time:**

1. Go to Transactions > Employees > Track Time.
2. Enter the time tracking details as appropriate.
3. Next to the **Duration** field, click the **Calculate** link.
4. In the **Start Time** field, enter the time that the employee started working.
   Enter the time in hours and minutes and include AM or PM, otherwise NetSuite automatically uses AM.
5. In the **End Time** field, enter the time the employee stopped working.
6. In the **Break** field, enter the length time of the employee's break.
   NetSuite automatically calculates the total time for you.
7. Click **Save**.
   The total time appears in the **Duration** field of the Time Tracking page.
8. Fill in any additional information, and then click **Save**.

Using NetSuite's time calculator, you can calculate your total time so you do not have to enter them manually.

Entering Time for a Payroll Item

Time tracking lets you track the hours you and other employees work. If you are in the U.S. and you have the appropriate privileges, you can track time for employee payroll items like hourly wages.

**Warning:** NetSuite CRM+ users cannot record time for payroll items.

If you track time for employee payroll items and want these hours to be included in the payroll period, you must enable this feature on the appropriate employee records.

**Note:** If an employee enters PTO after payroll cut-off date, the PTO is processed and recorded in the following regular payroll.

Setting up Employees' Records

**To set up employees' records so that their time transactions are included in payroll:**

1. Go to Lists > Employees > Employees.
2. Click **Edit** next to the name of the appropriate employee.
3. When the employee's record appears, click the **Payroll** subtab.
4. In the **Compensation Type** field, select **Wage** to pay this employee based on an hourly wage and hours worked.
5. Click **Save**.
6. Repeat steps 2 through 5 for any other employees you want to set up.
Entering Time for a Payroll Item

To enter time for a payroll item:

1. Go to Transactions > Employees > Track Time.
2. Choose an entry form to use.
3. Select the employee whose time you are recording.
4. NetSuite inserts the current date as the posting date of this time transaction.
5. In the **Duration** field, enter the amount of time worked for the day.
   - Click the timer icon next to the **Duration** field to time yourself as you work or time the length of your break. When you click **Submit**, the elapsed time in the timer fills in the **Duration** field of the Time Tracking page.
6. If applicable, select the **Customer or Project** associated with the tracked time.
   - If you use NetSuite OneWorld, the **Intercompany Time and Expense** feature and the related **Intercompany Time** accounting preference determine whether you can select a customer or project with a subsidiary different from yours. If the feature is not enabled, or if the preference is set to **Disallow**, you cannot enter intercompany time transactions. Instead, you can select only those customers or projects with the same subsidiary to which you are assigned. For more information, see the help topic **Enabling Intercompany Time and Expenses**.
7. Select a case, task, event or call for the customer or project you selected, to associate this time with an activity. This time entry is added to the record you select.
8. If applicable, select the service item that was provided. If you select a service item, you must also select a customer or project. Click **New** to set up a new service item.
   - If you use NetSuite OneWorld, it is recommended that you set up service items that are available to all subsidiaries, for use in intercompany time transactions. In these transactions, users cannot save lines unless they contain service items available to both the employee subsidiary and customer subsidiary. See the help topic **Enabling Intercompany Time and Expenses**.
9. Check **Billable** if you want to bill the time entered to a customer or project.
   - **Warning:** In NetSuite CRM+, the **Billable** box is not available. NetSuite CRM+ users cannot record billable time, invoice customers for billable time.
10. If your company using multi-state calculations for payroll, select a **Payroll Item Workplace**.
11. Select a payroll item in the **Payroll Item** field.
12. Check the **Paid Externally** box if this time has been or will be paid outside of NetSuite. This removes this time from payroll transactions. You cannot check this box if this time is already associated with a paycheck in NetSuite.
13. Optionally enter a memo.
14. If you are a supervisor entering time for an employee, check the **Supervisor Approval** box.
15. Select a department, class, or location if you track this information.
   - **Important:** If you use NetSuite OneWorld and you are entering intercompany time transactions, you must determine a strategy for using classifications on these transactions. Best practice is to omit them. For more information, see the help topic **Enabling Intercompany Time and Expenses**.
16. If you selected a **Customer or Project**, NetSuite inserts the price level for that customer or project in the **Price Level** field.
   - The **Rate** field autofills with the amount associated with the price level.
17. If you are billing this time back to a customer, check **Lock the Rate** to lock the present rate so it's not affected by any rate changes made before the customer is billed.

18. Click **Save**.

If you tracked time for hourly wage payroll items, it appears in the Hours column for this employee on the Payroll Run page.

Custom Fields in Time Tracking Pages

You can create a custom field that appears on time tracking pages. This gives you additional flexibility in tracking information that's important to your business.

You can add a custom field to the column area on time tracking pages.

**Adding a Custom Column Field to Time Transactions**

**To add a custom column field to time transactions:**

2. In the **Label** field, enter a name or description for this field. The name appears as a column heading on transactions.
3. If you use custom code, enter a unique ID for this custom field.
   NetSuite enables you to enter custom JavaScript files to perform functions specific to your business. If you do not enter an ID now, NetSuite automatically assigns one. This ID cannot be edited after it has been created.
4. Select the owner of this field. Only the owner can edit this record.
5. Enter a description for your custom field.
   This description appears next to the field on time tracking pages.
6. Select the type of custom field you want to add.
7. If you entered a custom list and you want to attach it to your transaction custom field, select the appropriate list in the **List/Record** field.
8. The **Store Value** box is checked by default. This means that information entered in this custom field is stored in your NetSuite account.
   Clear this box to indicate that the information stored in this custom field is for display only. The information is not stored in your account.
9. On the **Applies To** subtab, check the **Time** box.
10. On the **Validation & Defaulting** subtab, check the **Mandatory** box to make this a required field on the transactions you select.
11. Enter a **Default Value** for this field.
12. If you selected **List/Record** in the type field and you want to assign a default value, assign the appropriate selection in the **Default Selection** field.
13. Check **Default Checked** if you want this box to default to a checked state on the transactions pages you select.
14. On the **Sourcing & Filtering** subtab, if you have entered an item custom field and want to attach it to your transaction custom field, select it in the **Source** field.
15. Click **Save**.
Your custom field automatically appears on the Time Tracking page. When tracking weekly time, your custom field appears in the columns of Weekly Time Tracking or Weekly Timesheet pages.

If your company does not use the Combine Time Items on Invoices preference and you bill the cost of a time transaction back to a customer, you can choose to include your custom field on all custom invoices except finance charge invoices.

⚠️ **Warning:** NetSuite CRM+ users cannot record billable time or invoice customers for billable time.

### Including your Transaction Custom Field on a Custom Invoice

**To include your transaction custom field on a custom invoice:**

1. Go to Customization > Forms > Transaction Forms.
2. In the **Edit** column, choose one of two options:
   - Click **Customize** next to the appropriate form name to create a new custom form.
   - Click **Edit** next to the appropriate form name to include your custom field on an existing custom form.
3. When the Custom Form page appears, enter a name for your form so it is recognizable when selecting it on the Invoice page.
4. Click the **Printing Fields** subtab.
5. Click the **Columns** subtab.
6. Locate the name of your transaction custom field in the **Description** column.
7. Check the corresponding **Screen** and **Print/Email** boxes.
8. Click **Save**.

The information you enter in your transaction custom field on the Time Tracking page now appears on the corresponding invoice you create.

If your company uses the Combine Time Items on Invoices preference, you cannot include transaction custom fields on invoices because the information you enter in these fields may be different for each time record.

If your company uses Weekly Timesheets, you can also add custom body fields to the top of timesheets.

### Adding a Custom Body Field to Weekly Timesheets

**To add a custom body field to weekly timesheets:**

1. Go to Customization > Lists, Records, & Fields > Other Custom Fields > New.
2. In the **Record Type** field, select **Timesheet**.
3. In the **Label** field, enter a name or description for this field.
4. If you use custom code, enter a unique ID for this custom field.
   - NetSuite enables you to enter custom JavaScript files to perform functions specific to your business. If you do not enter an ID now, NetSuite automatically assigns one. This ID cannot be edited after it has been created.
5. Select the owner of this field. Only the owner can edit this record.
6. Enter a description for your custom field.
Managing Time Tracking

7. Select the type of custom field you want to add.
8. If you entered a custom list and you want to attach it to your custom field, select the appropriate list in the List/Record field.
9. The Store Value box is checked by default. This means that information entered in this custom field is stored in your NetSuite account.
   Clear this box to indicate that the information stored in this custom field is for display only. The information is not stored in your account.
10. On the Validation & Defaulting subtab, check the Mandatory box to make this a required field on the transactions you select.
11. Enter a Default Value for this field.
12. If you selected List/Record in the type field and you want to assign a default value, assign the appropriate selection in the Default Selection field.
13. Check Default Checked if you want this box to default to a checked state on the transactions pages you select.
14. On the Sourcing & Filtering subtab, if you have entered an item custom field and want to attach it to your transaction custom field, select it in the Source field.
15. Click Save.

You new custom field automatically appears in the top portion of weekly timesheets.

Approving or Rejecting a Time Transaction

Time approval is restricted to the Employee Center and the user role. You can either have your users track and approve time in the Employee Center or you can edit the user role and set employee restrictions. If you do not set employee restrictions on the user role, users can approve all time entries rather than only those of their subordinates.

You can select either a time approver or supervisor.

- The Time Approver field appears on the Human Resources subtab of an employee record.
- The Supervisor field shows under Primary Information on an employee record.

After you assign a time approver or supervisor to an employee record, that user has the authority to approve time for the employee. Time approvers cannot edit or delete existing time entries. If no time approver is selected, then the employee’s supervisor approves time entries. If both a supervisor and a time approver are selected, then only the time approver can approve time entries using their Employee Center role. For more information, see Adding an Employee Record.

With Customize View you can specify details that you want to appear on timesheets. For example, Allocated Hours or Approval Status.

The employee’s supervisor or time approver receives an email notification when time is entered or edited.

If you also use Project Management, you have additional options for approving project time. For more information, see the help topic Approving Time and Expenses for Projects.

Advanced Approvals

The Advanced Approvals preference offers additional statuses, a color–coded display when viewing weekly time tracking and weekly timesheets, and the ability to reject time entries and add a rejection note.
After you have enabled the preference, the Supervisor Approval field on time entries and weekly time tracking and timesheets is replaced by an Approval Status field.

This field is editable by administrators and any role without time and expense restrictions. This field enables you to set the status of time entries to Open, Pending Approval, Approved, or Rejected. When viewing weekly time tracking or timesheets, approved entries are displayed with a green background, open entries have a white background, rejected entries have a red background, and pending entries have a blue background.

**Setting Approval Preferences**

**To set approval preferences:**

1. Go to Setup > Accounting > Accounting Preferences.
2. Click the Time & Expenses subtab.
3. Check the Require Approvals on Time Records box.
4. If you'd like to use Advanced Approvals, check the Advanced Approvals on Time Records box.
5. Click Save.

**Warning:** If you decide at a later date to disable the Advanced Approvals preference, you must first adjust any time transactions with an Open or Rejected status to a Pending Approval status. Making these adjustments will prevent any further complications when the preference is turned off.

If you choose to enable Advanced Approvals on Time Records, you can also use SuiteFlow and Approval Routing to create custom approval workflows for your time entries. When using custom approval workflows, the Approve Time page is only available for time entry records. The Approve Timesheets pages is not available for custom approval workflows. For more information, see the help topics SuiteFlow Overview and Approval Routing.

For more help setting up the time tracking feature and related preferences, see Setting Up Time Tracking Preferences.

With Time Tracking, you can approve individual time entries from the Approve Time page.

**Approving or Rejecting Time with Time Tracking**

**To approve or reject time with Time Tracking:**

1. Go to Transactions > Employees > Approve Time.

   **Note:** If you also use Weekly Timesheets, approving time defaults to the Approve Timesheets view. For more information see below. You can click Switch to Time Entry view to proceed with approving or rejecting time entries individually.

2. On the Approve Time page, select the name of the employee whose time you want to approve or reject.

   You can also identify a specific pay period for that employee by selecting a date in the Week Of field.

   For this employee, each time record displays the following information by default:
   - Employee name
   - Date of the time record
   - Case/Task/Event
Managing Time Tracking

- Customer
- Service Item
- Payroll Item
- Number of hours entered
- Memo

The Billable column indicates if the time entered can be billed back to the customer.

3. Optionally, click Customize to add filters or to select the columns to display on the Approve Time page. On the Customize page:
   1. Click the Criteria, Results, or Available Filters subtabs.
   2. Add or remove fields on the Criteria subtab to filter the results by other fields. Add or remove fields on the Results subtab to change the columns displayed. Add or remove fields on the Additional Filters to add filters to the page.

4. In the Select column, check the boxes next to the time records you want to approve or reject.

   **Important:** You cannot approve and reject entries together. All the entries you select will either be all approved or all rejected. If you have multiple entries to both approve and reject, you must repeat this process for approval and again for rejection.

   **Note:** You can approve or reject multiple time entries at one time, but each individual record must be selected. You cannot select time entries on a weekly basis from the Approve Time page.

5. Click Approve to approve the selected time entries.
   Click Reject to reject the selected time entries without a rejection note.
   Click Reject with Note to reject the selected time entries and add a rejection note to each selected entry. You can only add a single rejection note. The note you enter is copied to all the selected time entries.

   **Warning:** Employees with appropriate permissions can modify previously approved time.

If you use Weekly Timesheets, you can approve or reject multiple entries at once.

### Approving or Rejecting Time with Weekly Timesheets

**To approve or reject time with Weekly Timesheets:**

1. Go to Transactions > Employees > Approve Time.
2. On the Approve Timesheets page, select the name of the employee whose time you want to approve.
   You can also identify a specific pay period for that employee by selecting a date in the Week Of field.
   For this employee, each time record displays the following information by default:
   - Employee
   - Period
   - Approvable Hours
     You can click the link in the Approvable Hours column to open a popup that displays the individual time entries.
Optionally, you can click **Switch to Time Entry view** to display each individual time entry.

3. Optionally, click **Customize** to add filters or to select the columns to display on the Approve Timesheets page. On the Customize page:
   1. Click the **Criteria**, **Results**, or **Available Filters** subtabs.
   2. Add or remove fields on the **Criteria** subtab to filter the results by other fields. Add or remove fields on the **Results** subtab to change the columns displayed. Add or remove fields on the **Additional Filters** to add filters to the page.

4. In the **Select** column, check the boxes next to the timesheets you want to approve or reject.

   **Important:** You cannot approve and reject timesheets together. All the timesheets you select will either be all approved or all rejected. If you have multiple timesheets to both approve and reject, you must repeat this process for approval and again for rejection.

   **Note:** When approving or rejecting time entries from the timesheet view, checking the box next to a timesheet will approve or reject all entries listed on the timesheet. When approving or rejecting time entries from the time entry view, each box approves or rejects only the individual time entry.

5. Click **Approve** to approve the selected timesheets. Click **Reject** to reject the selected timesheets without a rejection note. Click **Reject with Note** to reject the selected timesheets and add a rejection note to each selected entry. You can only add a single rejection note. The note you enter is copied to all the selected time entries.

   **Warning:** Employees with appropriate permissions can modify previously approved time.

Approved time can be used to bill customers and process payroll.

If you bill time back to a customer or project, the time shows on the Billable Time subtab on the invoice.

If you track time for hourly wage payroll items, the time shows in the Hours column for each employee on the Payroll Run page.

   **Warning:** NetSuite CRM+ users cannot record billable time, invoice customers for billable time, or record time for payroll items.

### Approving or Rejecting Time from the Time Transaction List

You can use inline editing and the time transactions list to approve or reject time. If you use the Require Approvals on Time Records preference, you can check the box in the Approved column to update the approval status of individual time transactions with inline editing. The Approval Status field is not available for inline editing with only the approvals preference. If you also use the Advanced Approvals on Time Records preference, you can update the Approval Status field using inline editing.

For more information on Advanced Approvals, see [Advanced Approvals](#).

### Custom Workflow-based Approvals for Time Tracking

You can choose to use SuiteFlow to create your own custom workflows to process approvals for time tracking. Using SuiteFlow for time tracking allows greater control over the approval process.
Approval Status Field

When using SuiteFlow for time tracking approvals, an Approval Status field is added to the approvals page. The Approval Status field reflects where the time report is in the approval process.

Time reports can have one of the following statuses:

- **Open** – No action has been taken with the report yet.
- **Pending Approval** – The report has been sent to the Next Approver and is in the approval queue.
- **Approved** – The report has been given approval for processing.
- **Rejected** – The report has not been approved and will not be processed.

The approval statuses listed above are standard. No additional statuses can be specified. The possibility to change the Approval Status field depends on your SuiteFlow setup. A typical approval workflow is illustrated below:

Next Approver Field

When using SuiteFlow for time tracking approvals, a Next Approver field is added to the approval page. This field is populated according to the corresponding workflow.

The Next Approver must be defined on the timebill. The next approver can be the employee's supervisor, a project approver, or anyone else with permission to approve time for the employee.

**Note:** Supervisors who used to be a Next Approver are able to look up timesheets of former employees retrospectively using an appropriate role. They do not appear in the Employee center role, this is reserved for current approvals only.

Updating Time Entries

You can update and transfer multiple time entries between projects at Transactions > Employees > Update Time Entries.

To update time entries in bulk, you must enable the Time Tracking and Project Management features. Administrators can use time modification to change the customer, project, or task. You can update the service item, location, department, class, or if the entry is billable. You can transfer some or all of the hours on a time entry to a different project. This enables administrators to correct time entries or change how time is billed to their customers.
If you want to enable project managers to update time entries submitted for their assigned projects, you must give full access to the Bulk Time Entry Modification permission for the project manager’s assigned role. For more information, see the help topic Customizing or Creating NetSuite Roles.

To update time entries:

1. Go to Transactions > Employees > Update Time Entries.
2. Use the filters at the top of the page to narrow down the listed time entries. Depending on the features your company uses, you can filter by customer, project, task, employee, department, class, location, subsidiary, service item, date, and if the time is billable. When you filter time entries, only time entries you have permission to edit appear in the list for selection.
3. Check the box next to each time entry you want to update. Click Next.
4. For fields you want to change, select the new values. When you have finished, click Next.

   **Note:** To update the project field, you must first select the customer. To update the task field, you must first select the customer and project. If you want to transfer time, see Transferring Time Between Projects for additional information.

5. The next page shows a preview of the updated fields with the new information. Any errors are highlighted in red. You must correct errors before you can submit the changes.
6. When you have verified the changes are correct, click Submit.

After you submit your changes, a message appears at the top of the page confirming your submission. Click View Status to go to the Processed Records page to see the progress of your changes. Click Refresh to update the status.

### Transferring Time Between Projects

There are additional considerations for transferring time between projects to avoid any errors before submitting your changes.

If you do not use Resource Allocations, the following are required to transfer time between projects:

- The employee must be listed as a resource on the new project.
- If you want to update the task, the employee must be assigned to the new task.

If you use Resource Allocations, the following are required to transfer time between projects:

- The employee must be allocated to the new project.
- If you want to update the task and the Allow Allocated Resources to Enter Time to All Tasks project preference is not enabled, the employee must be assigned to the new task. To remove this requirement, when creating project records, on the Preferences subtab, check Allow Allocated Resources to Enter Time to All Tasks. For more information, see the help topic Setting Up Project Record Preferences.

If you want to partially transfer time between projects, on the review page, update the transfer hours field with the number of hours you want transferred to the new project before submitting the changes. NetSuite updates the existing time entry to reflect the reduced hours and creates a new time entry for the transfer hours on the updated project.
Timesheets

We are no longer initiating new installations of the Timesheets feature. We are currently in the process of making improvements to NetSuite's time tracking capabilities. These improvements will be available in future releases.

Existing Timesheets users may continue to use the feature. The guide below contains all the currently available help documentation on the Timesheets feature.

Timesheets Guide

If you have any further questions, please contact your Account Manager to discuss your time tracking needs so that we may find a solution that best fits your company.

Note: The Timesheets feature is a separate feature from Time Tracking. For more information, see Managing Time Tracking.
Expense Reports and Purchase Requests

- Expense Reporting
- Giving an Employee Access to Purchase Requests
- Notifying a Supervisor or Approver About Required Approvals

Expense Reporting

The Expense Reports feature enables users to enter expense reports and convert them into bills. An expense report records employees' expenditures to track information about the expense such as the following:

- what was purchased
- how much was spent
- reason for the purchase
- whether it can be billed to a customer or project

The expense total remains in an unapproved expense account and has no accounting impact until the expense is approved by someone with accounting authority. After an expense report is approved, a bill is created and the expense amount is reflected on your books. The posting period for an expense report is determined after accounting approval occurs. If the posting period for the expense report date is closed, the expense report is posted to the first open period.

For information about expense reporting, see the following:

- Understanding Expense Reports
- Giving an Employee Access to Expense Reporting
- Notifying a Supervisor or Approver About Required Approvals
- Entering an Expense Report
- Deleting an Expense Report from the Expense Reports List
- Rejecting an Expense Report from the Expense Reports List
- Corporate Card Expenses
- Reviewing Expense Reports
- Approving an Expense Report
- Giving Accounting Approval for ExpenseReports
- Understanding Expense Categories
- Paying Expenses on Employee Paychecks with Payroll

**Note:** If the Multiple Currencies feature is enabled, be aware that expense line item amounts are always in the base currency of the employee. If the Use Multi Currency box is checked on an expense report, line item amounts can be entered in foreign currency, and these foreign amounts are translated into base currency amounts. Exchange rates and converted amounts displayed on expense lines are provided as approximations only. Actual reimbursement amounts will be based on rates at the time of reimbursement.

Understanding Expense Reports

See the following to get an understanding of how expense reports work in NetSuite:
Expense Reports Features and Preferences

A user with the Enable Features permission can enable the Expense Reports feature at Setup > Company > Enable Features, on the Employees subtab. When the Expense Reports feature is enabled, NetSuite automatically creates an Other Current Asset type account for advances paid and a non-posting account for unapproved expense reports.

The Approval Routing feature provides the setup of an approval hierarchy required to process expense reports, time transactions, and purchase requests. When this feature is enabled, after an employee enters an expense report or purchase request, additional processing of the transaction depends on the employee's expense limit or purchase limit, the employee's designated supervisor or approver, and the approval limit of the supervisor or approver.

**Important:** When changes are made in the approval hierarchy for an employee, any expense reports not already approved are reset and must start the approval process over. For example, if an employee is assigned a new supervisor, any existing approvals of open expense reports are removed. The report is rerouted through the approval process based on the employee's new approval hierarchy.

If this feature is not enabled, each expense report or purchase request is automatically routed to the employee's immediate supervisor and then to accounting. For more information, see the help topic Approval Routing.

To set preferences for entering expenses, go to Setup > Accounting > Accounting Preferences, and click the Time & Expenses subtab. For more information, see the help topic Time & Expenses Accounting Preferences.

The fields that display on an expense report include the date the expense report was entered into the system, expense report number, employee filing the expense report, date range of the expenses included in the expense report, purpose of the expense, expense category, date of the expense, expense of each item, any advance toward expenses, and the sum of all the expenses. Expense reports include a summary box in the upper corner of the entry form to display totals for the transaction. The expense report also includes both the employee and approver signature and date. Expense reports can be customized to display additional fields. For more information, see the help topic Report Customization.

**Note:** If you use NetSuite OneWorld, the Intercompany Time and Expense feature and the related Intercompany Expenses accounting preference affect users' ability to enter expenses worked for customers with subsidiaries other than their own. If the feature is not enabled, or if the preference is set to Disallow, users cannot enter intercompany expenses transactions; they can only select customers with the same subsidiary to which they are assigned. If the preference is set to Allow, intercompany expenses are permitted and all subsidiaries are available to expense lines. If the preference is set to Allow and Adjust, you can generate automatic adjustments for intercompany expenses. For more information, see the help topic Enabling Intercompany Time and Expenses.

You can select a default payable account for expense reports at Setup > Accounting > Accounting Preferences. For OneWorld accounts, you must set a default payable account on your subsidiary records. For more information, see the help topic Set Subsidiary Preferences.
Foreign Currency Expense Reports

If you use multiple currencies, employees can create expense reports in currencies other than your default currency. The Multiple Currencies feature is required to create foreign currency expense reports.

You must define employee currencies for expense reports on the employee record. Only currencies available for your company can be added to an employee's expense report currencies.

**Note:** Expenses can be paid through SuitePeople U.S. Payroll only if the reimbursement currency is set to United States Dollars.

**To add currencies to the employee record:**

1. Go to Lists > Employees.
2. Click **Edit** next to the employee record you want to update.
3. Click **Human Resources**.
4. Click **Expense Report Currencies**.
5. In the **Currency** field, select a currency for this employee. Click **Add**.
6. Continue to add any currencies you want this employee to be able to use for expense reports.
7. In the **Default Currency** field, select the default currency for this employee's expense reports.
8. Click **Save**.

Currency and Exchange Rate fields are added to the expense report form. An employee's default currency is automatically selected. You can select a different currency based on the currencies defined on the employee's record.

**Important:** If you change the currency on a new expense report after entering expense lines, the existing lines are not automatically updated. You must update the existing lines manually.

When creating a bill payment for an expense report, in the currency field, you can select a currency from the employee's list of defined currencies.

Employee Entry of Expense Reports

For an employee to be able to enter an expense report, the employee must have access to the Employee Center. An administrator can give Employee Center access to an employee by editing that employee's record, available at Lists > Employees > Employees. For more information, see Giving an Employee Access to Expense Reporting.

Usually, employees enter expense reports when logged in with the Employee Center role. Some employees may have other assigned roles with the Expense Reports permission, and may be able to enter expenses when logged in with a role other than Employee Center. If approval routing is set up, however, all expense reports must be entered through the Employee Center to maintain the hierarchy of approval routing. For more information, see Entering an Expense Report.

Supervisor Approval of Expense Reports

If the Approval Routing feature is not enabled, an employee's immediate supervisor must approve an expense report after it is completed. If Approval Routing is enabled and set up, one or more supervisors or approvers may need to approve an expense report before it is sent to accounting for approval.
Important: When changes are made in the approval hierarchy for an employee, any expense reports not already approved are reset and must start the approval process over. For example, if an employee is assigned a new supervisor, any existing approvals of open expense reports are removed. The report is rerouted through the approval process based on the employee's new approval hierarchy.

A preference can be set so supervisors/approvers can be notified automatically by email when expense reports have been submitted for their approval. See Notifying a Supervisor or Approver About Required Approvals.

Supervisors or other approvers normally approve expense reports in the Employee Center. For information, see Approving an Expense Report.

Accounting Approval of Expense Reports

After an expense report has received supervisory approval, it has a status of Pending Accounting Approval, and requires this accounting approval for its amounts to be posted. See Giving Accounting Approval for Expense Reports.

The posting period for an expense report is determined after the expense report is approved by accounting. If this approval occurs after the expense report date's posting period has closed, the expense report is posted to the first open period.

Voiding Expense Reports

Expense reports can be voided by administrators and employees during any stage of approval. Voiding an expense report after it has been approved by accounting creates an accounting impact. Expense reports have no accounting impact prior to accounting approval. When an expense report is voided, the status is changed to Void and the expense report is removed from approval lists.

Note: Rarely, a previously voided expense report with no accounting impact may show a status of Paid in Full and still appear in approval lists. Opening such an expense report for editing and re-saving without making changes will automatically update the status to Void and remove the expense report from approval lists.

Giving an Employee Access to Expense Reporting

To permit an employee access to expense reports, the Expense Reports feature must be enabled. A user with the Enable Features permission can enable the Expense Reports feature at Setup > Company > Enable Features, on the Employees subtab.

Next, create an employee record for the person, and assign them the Employee Center role. For more information on adding employee records, see the following topics:

- Adding an Employee Record
- Giving an Employee Access to NetSuite
- Assigning Roles to an Employee

When an employee is given access to NetSuite, they can access Expense Reporting feature after it is enabled.

For expense reports, Employee Center access enables employees to:

- Enter their own expense reports
- View and edit their own unapproved expense reports
View their own approved expense reports
Approve expense reports of their subordinates

Employees who are designated as a supervisor or expense approver for other employees also have access to expense reports for these employees.

For more information on the Employee Center, see About the Employee Center Role.

Entering an Expense Report

You can enter an expense report to record expenditures and track information about the expense. Expense reports are available only for active employees.

Usually, employees enter expense reports when logged in with the Employee Center role. Employees can enter expenses when logged in with a role other than Employee Center if they have the Create level of the Expense Reports permission. However, when approval routing is set up, all expense reports must be entered through the Employee Center to maintain the hierarchy of approval routing.

For step-by-step procedures for entering an expense report, see the following:

- Entering an Expense Report in the Employee Center
- Entering an Expense Report with a Role other than Employee Center

**Important:** If you use NetSuite OneWorld and you are entering intercompany expenses, and you use classes, departments, or locations to classify transactions, you must determine a strategy for using classifications on intercompany expense transactions. Best practice is to omit them. For more information, see the help topic Enabling Intercompany Time and Expenses.

Entering an Expense Report in the Employee Center

To enter an expense report when logged in with the Employee Center role:

1. On the Employee Center Home page, in the Home Links portlet, click the Enter Expense Reports link.
   If you use NetSuite OneWorld, notice that the Subsidiary field is automatically populated with your subsidiary.

2. NetSuite inserts today’s date as the date of this expense report. You can optionally enter another date.
   The Expenses Total and Amount field values are calculated based on the amounts entered for expense line items.
   A summary box in the upper corner of the entry form displays totals for the transaction. The summary box includes real-time totals for expenses, non-reimbursable expenses, reimbursable expenses, any advances to apply, and the total reimbursable amount.

3. Enter an advance that should be applied to any reimbursement for these expenses.

4. Enter the purpose of these expenses.

5. If your company uses foreign currency expense reports, in the Currency field, select the currency in which you want your reimbursement to be paid.

   **Note:** Currencies must first be set up on the employee record. Only currencies defined on the employee record are available for selection in this field.

6. For accounts with the Multiple Currencies feature enabled, check the Use Multi Currency box to show the Foreign Amount, Currency, and Exchange Rate fields for each line item. These fields
enable the entry of expenses in foreign currencies to be reimbursed in the base currency unless an alternate currency is selected in the **Currency** field above.

This box is checked by default if you have enabled the **Use Multicurrency Expense Reports** preference on the General subtab at Home > Set Preferences. You can clear the box to hide Multi Currency fields on individual expense reports. Any expenses entered when Multi Currency fields are hidden are automatically saved in the base currency.

**Important:** The rates and converted amounts displayed on expense lines are provided as approximations only. Actual reimbursement amounts will be based on rates at the time of reimbursement.

7. If your company tracks them, review the default values entered for **Department**, **Class**, and **Location** to edit as necessary.

**Note:** Any department, class, or location selected in the body of the expense report does not automatically transfer to the line item fields for each expense. For this information to appear on the GL Impact for each line item you must select the appropriate information for each line item. You can also customize your forms with a custom script to automate this process. For more information, see the help topic **Enhancing NetSuite Forms with User Event Scripts**.

If you are entering intercompany expenses and you select a department, class, or location that is not available to the subsidiary associated with the selected customer, an attempt to generate intercompany adjustments for the expenses will result in errors.

8. On the **Expenses** subtab, complete line items for expenses:

   a. The **Ref No.** field is automatically populated with 1 for the first line item on this expense report. You may update this number and each new line item will use the next successive number. Line item reference numbers are helpful when referencing receipts and individual expenses.

   **Note:** If the Combine Detail Items on Expense Reports preference is enabled at Setup > Accounting > Accounting Preferences > Time & Expenses, line items on expense reports are not always listed in the order they are entered. They are regrouped by category. Line items may be listed out of order depending on the assigned category. For more information, see the help topic **Expenses**.

   b. In the **Date** column, enter the actual date the expense was incurred.

   c. Select an expense category.

      If you use NetSuite OneWorld, it is recommended that you set up expense categories linked to expense accounts that are available to all subsidiaries, for use in intercompany expense transactions. Users cannot save expense lines unless they contain expense categories available to both the employee subsidiary and customer subsidiary. See the help topic **Enabling Intercompany Time and Expenses**.

   d. If you selected a category that requires a rate, quantity and rate fields appear. Enter the quantity for this expense.

   e. If a rate is not automatically populated, enter the rate for this expense category. The amount is automatically calculated from the rate and quantity.

   **Note:** If you use multi-currencies, the foreign amount field is used to calculate expense report totals.

   f. If this expense was incurred in a foreign currency, select the currency, and enter the foreign currency amount.
If you intend to do system-generated adjustments for intercompany expenses, be aware that the currency used for those adjustments is always the base currency of the employee's subsidiary and may not match the currency recorded here. For more information, see the help topic Creating Intercompany Adjustments for Time and Expenses.

g. If it is not automatically calculated, enter the exchange rate applicable for this expense. (Be aware that any automatically calculated rate is provided as an approximation. The rate at the time of reimbursement is used to calculate the actual reimbursement amount.)

h. In the Amount column, enter the amount of the expense.

Note that if you entered a foreign currency amount for this expense, the expense is automatically converted to your base currency amount in the Amount column. This amount is provided as an approximation and may not match the actual reimbursement amount that will be calculated based on the exchange rate at the time of reimbursement.

If this expense required a rate, the amount is calculated after a quantity and rate are entered.

i. Optionally, you can enter a memo, department, class, or location to apply only to this line item.

If you are entering an intercompany expense and you select a department, class, or location that is not available to the subsidiary associated with the selected customer, an attempt to generate an intercompany adjustment for the expense will result in an error.

j. If this item is billable to a customer or project, select it from the Customer list and check the Billable box.

**Warning:** Checking the Billable box without selecting a customer will generate an error. You must select a customer if the Billable box is checked.

If you use NetSuite OneWorld, the Intercompany Time and Expense feature and the related Intercompany Expenses accounting preference determine whether you can select a customer or project with a subsidiary different from yours. If the feature is not enabled, or if the preference is set to Disallow, you cannot enter intercompany expenses. Instead, you can select only those customers or projects with the same subsidiary to which you are assigned. For more information, see the help topic Enabling Intercompany Time and Expenses.

k. You can attach a receipt to each line item. In the Attach File column, select List to select your receipt from the File Cabinet or New to upload a new receipt. You can attach the same receipt to multiple line items.

l. If the receipt for this item is being provided, check the Receipt box.

m. If your company uses non-reimbursable expenses, and this item is not reimbursable, check the Non-reimbursable box. For details about this setting, see Non-Reimbursable Expenses.

n. Click Add.

9. Continue adding expense line items.

**Note:** Similar line items on expense reports may be combined if your company has enabled the Combine Detail Items on Expense Reports preference. For more information, see the help topic Projects Accounting Preferences.

10. When you have finished, save the expense report.

You have the following choices:

- Submit, Submit & New, or Submit & Print – to save the report and identify it as complete after you have entered all information.
After an expense report is marked complete, you can no longer make changes to it.

- **Complete Later** – to save an incomplete form without submitting it. Information on the form is saved, but the form is not submitted for approval.

⚠️ **Important:** Only expense reports that are submitted as complete enter the queue for supervisor or accounting approval.

## Entering an Expense Report with a Role other than Employee Center

Expense reports can be entered by employees when logged in with roles other than the Employee Center. This gives employees the ease of using a single role to handle all of their business tasks. It also enables employees to enter expense reports on behalf on another employee if they have the necessary permissions.

**To enter an expense report when logged in with a role other than Employee Center:**

1. Go to Transactions > Employees > Enter Expense Reports.
2. Select a form to use.
3. In the **Exp. Rept. #** field, NetSuite increases the largest expense report number by one.
   - If you wish, you can type another number. The next expense number will revert to the standard pattern. You can enter a maximum of 45 characters in this field.
4. Select the employee who incurred these expenses.
   - If you use NetSuite OneWorld, notice that the **Subsidiary** field is automatically populated with the subsidiary associated with the employee.
5. Select an account for this expense. This field is only available if you have checked the **Accounting Approval** box on this form or you are editing a previously approved expense report.
   - The **Expenses and Total Amount** field values are calculated based on the amounts entered for expense line items.
   - A summary box in the upper corner of the entry form displays totals for the transaction. The summary box includes real-time totals for expenses, non-reimbursable expenses, reimbursable expenses, any advances to apply, and the total reimbursable amount.
6. If your company uses foreign currency expense reports, in the **Currency** field, select the currency in which you want the reimbursement to be paid. The Exchange Rate field automatically shows the current exchange rate for your selected currency.
   - **Note:** Currencies must first be set up on the employee record. Only currencies defined on the employee record are available for selection in this field.
7. Enter any advance that should be applied to any reimbursement for these expenses.
8. Enter the purpose of this expense.
9. NetSuite inserts today's date as the date of this expense report. You can optionally enter another date.
   - **Note:** A posting period based on the current date is displayed. This period is subject to change until accounting approval of the expense report. If approval occurs after this displayed period has closed, the expense report is posted to the first open period.
10. If available, enter the due date of the expense report.

11. Review the setting for the Complete box, and clear it if you intend to make changes to this expense report later.

Only complete reports are submitted for approval and processing. Be aware that after an expense report is marked complete, you can no longer make changes to it.

12. If you have the appropriate authority, check the Supervisor Approval, Accounting Approval, or both boxes.

**Note:** If you have multiple payable accounts, after the Account Approval box has been checked the Account field automatically populates with the default payable account. You may change this account if necessary. For more information, see the help topic Time & Expenses Accounting Preferences. For OneWorld accounts, see the help topic Set Subsidiary Preferences.

13. On the Expenses subtab, for accounts with the Multiple Currencies feature enabled, check the Use Multi Currency box to show the Foreign Amount, Currency, and Exchange Rate fields for each line item. These fields enable the entry of expenses in foreign currencies to be reimbursed in the base currency unless an alternate currency is selected in the Currency field above.

This box is checked by default if you have enabled the Use Multicurrency Expense Reports preference on the General subtab at Home > Set Preferences. You can clear the box to hide Multi Currency fields on individual expense reports. Any expenses entered when Multi Currency fields are hidden are automatically saved in the base currency.

**Important:** The rates and converted amounts displayed on expense lines are provided as approximations only. Actual reimbursement amounts will be based on rates at the time of reimbursement.

14. On the Expenses subtab, complete line items for expenses:

   a. The Ref No. field is automatically populated with 1 for the first line item on this expense report. You may update this number and each new line item will use the next successive number. Line item reference numbers are helpful when referencing receipts and individual expenses.

   **Note:** If the Combine Detail Items on Expense Reports preference is enabled at Setup > Accounting > Accounting Preferences > Time & Expenses, line items on expense reports are not always listed in the order they are entered. They are regrouped by category. Line items may be listed out of order depending on the assigned category. For more information, see the help topic Expenses.

   b. In the Date column, enter the actual date the expense was incurred.

   c. Select an expense category.

      If you use NetSuite OneWorld, it is recommended that you set up expense categories linked to expense accounts that are available to all subsidiaries, for use in intercompany expense transactions. Users cannot save expense lines unless they contain expense categories available to both the employee subsidiary and customer subsidiary. See the help topic Enabling Intercompany Time and Expenses.

   d. If you selected a category that requires a rate, quantity and rate fields appear. Enter the quantity for this expense.

   e. If a rate is not automatically populated, enter the rate for this expense category. The amount is automatically calculated from the rate and quantity.
f. If this expense was incurred in a foreign currency, select the currency, and enter the foreign currency amount.

If you intend to do system-generated adjustments for intercompany expenses, be aware that the currency used for those adjustments is always the base currency of the employee's subsidiary and may not match the currency recorded here. For more information, see the help topic Creating Intercompany Adjustments for Time and Expenses.

g. If it is not automatically calculated, enter the exchange rate applicable for this expense. (Be aware that any automatically calculated rate is provided as an approximation. The rate at the time of reimbursement is used to calculate the actual reimbursement amount.)

h. In the **Amount** column, enter the amount of the expense.

Note that if you entered a foreign currency amount for this expense, the expense is automatically converted to your base currency amount in the **Amount** column. This amount is provided as an approximation and may not match the actual reimbursement amount that will be calculated based on the exchange rate at the time of reimbursement.

If this expense required a rate, the amount is calculated a quantity and rate are entered.

i. Optionally, you can enter a memo, department, class, or location to apply only to this line item.

If you are entering an intercompany expense and you select a department, class, or location that is not available to the subsidiary associated with the selected customer, an attempt to generate an intercompany adjustment for the expense will result in an error.

j. If this item is billable to a customer or project, select it from the **Customer** list and check the **Billable** box.

**Warning:** Checking the **Billable** box without selecting a customer will generate an error. You must select a customer if the **Billable** box is checked.

Note: If you use NetSuite OneWorld and you have shared customer records with multiple subsidiaries, you can choose any customer that is assigned to the default subsidiary. For information about sharing customer records with multiple subsidiaries, see the help topic Assigning Subsidiaries to a Customer.

If you use NetSuite OneWorld, the **Intercompany Time and Expense** feature and the related **Intercompany Expenses** accounting preference determine whether you can select a customer or project with a subsidiary different from yours. If the feature is not enabled, or if the preference is set to **Disallow**, you cannot enter intercompany expenses. Instead, you can select only those customers or projects with the same subsidiary to which you are assigned. For more information, see the help topic Enabling Intercompany Time and Expenses.

k. You can attach a receipt to each line item. In the **Attach File** column, select **List** to select your receipt from the **File Cabinet** or **New** to upload a new receipt. You can attach the same receipt to multiple line items.

l. If the receipt for this item is being provided, check the **Receipt** box.

m. If your company uses non-reimbursable expenses, and this item is not reimbursable, check the **Non-reimbursable** box. For details about this setting, see Non-Reimbursable Expenses.

n. Click **Add**.
15. Continue adding expense line items.

**Note:** Similar line items on expense reports may be combined if your company has enabled the Combine Detail Items on Expense Reports preference. For more information, see the help topic [Projects Accounting Preferences](#).

16. When you have finished, save the expense report.

**Important:** Only expense reports that are submitted as complete enter the queue for supervisor or accounting approval.

### Approving an Expense Report

If you use the Approval Routing feature for expenses, they must be approved before they can be processed.

Expenses are generally processed through the Employee Center. You must have the Employee Center role to access the Employee Center. An administrator can add the Employee Center role on your employee record. For more information, read [Adding an Employee Record](#).

**Note:** In OneWorld accounts, when a user who is a supervisor or approver logs in to the Employee Center, approval queues will display purchase requests, expense reports and requisitions entered by employees associated with all subsidiaries. Role-level subsidiary restrictions that apply to other records and transactions do not apply to approvals of purchase requests, expense reports and requisitions.

### Approving Expenses Using the Approval Routing Feature

To approve an expense report, you must first log in to the Employee Center. You must have the Employee Center role to access the Employee Center. An administrator can add the Employee Center role on your employee record. For more information, read [Adding an Employee Record](#).

**To approve an expense report:**

1. Log in to the Employee Center.
2. Go to Transactions > Employees > Enter Expense Reports > List.
3. Under Expense Reports, click Approve Expense Reports.
4. Select the name of the employee who submitted the report.
5. Check the box next to the expense report you want to approve.
6. Click Save.

Expense reports have no accounting impact until they are approved by someone with accounting authority. When expense reports are approved by a supervisor or approver their totals remain in an unapproved non-posting account until approved by accounting. For more information, read [Giving Accounting Approval for Expense Reports](#).

If your company does not use Approval Routing, the report is automatically routed to the employee's immediate supervisor and then to accounting.

If your company uses Approval Routing, the expense report must be approved by a supervisor or approver with an expense approval limit that is greater than or equal to the amount of the report. If the amount is greater than the expense approval limit of the supervisor or approver, then the report is sent to the next level of management until it is approved by an authorized supervisor or approver.

If an expense approver is specified for an employee, the supervisor is not part of the approval hierarchy.
Supervisors can automatically be notified when they have reports to approve. Only an administrator can enable supervisor notification. To enable this feature, go to Setup > Accounting > Preferences > Accounting Preferences. Check the Automatically Notify Supervisor box.

In the Employee Center, your employees can view the status and approval history of their expense reports by clicking View & Edit Unapproved Expense Reports or View Approved Expense Reports.

### Approving Expenses Using SuiteFlow

If you use SuiteFlow for expense approvals, the steps to approve an expense are dependent on the way the workflow is set up. For more information, read the help topics Using Custom SuiteFlow Workflows for Approval Routing and Custom Workflow-based Approvals for Expense Reports.

### Custom Workflow-based Approvals for Expense Reports

You can choose to use SuiteFlow to create your own custom workflow to process approvals for expense reports. Using SuiteFlow for expenses allows more flexible processes for approvals.

For example, using workflows to process expenses allows for using a non-sequential approval process or conditionalized routing. You can set up a workflow that requires action from specific employees, shows buttons on forms at certain stages, sends email based on actions taken, and much more.

**Note:** If you have previously used the Approval Routing feature for purchase approvals, you must read Switching from the Approval Routing Feature to SuiteFlow for Expenses before you proceed.

### To use SuiteFlow to process expense reports:

1. To enable features, go to Setup > Accounting > Preferences > Accounting Preferences.
   a. On the **Transactions** subtab, enable the **Expense Reports** feature.
   b. On the **SuiteCloud** subtab, check the **SuiteFlow** box.
   c. Click **Save**
   d. On the **Employees** subtab, check the **Approval Routing** box.
   e. Click **Save**

   **This feature must be enabled to use these fields on employee records:**
   - Purchase Limit
   - Purchase Approver

   These fields are required for use with the workflow.

2. To enable Approval Routing for expense reports, go to Setup > Accounting > Preferences > Accounting Preferences.
   a. To use SuiteFlow for expense approvals, on the **Approval Routing** subtab, check the **Expense Reports** box.

3. Set up an approval workflow. You must use SuiteFlow to create a workflow to apply to your expense reports.
   To learn more, see the help topic Creating Your First Workflow.

   You can incorporate the following options into your expense approvals workflow:
   - Hierarchical or custom routing rules
   - Email notifications that include links to drill down to records for approval
   - Approve and Reject buttons
Respecting approval limits
- Updating the Approval Status and Next Approver field on records
- Preventing records that are pending approval from being edited
- Designating an alternate approver

**Note:** When using approval workflows, if the record is processed through multiple levels of approval by different users in a routing loop, you should use a custom workflow field that refers specifically to the current approver's approval status. This enables you to track the current approver's approval status separately from the overall approval status of the record.

**Employee Center**

When you use SuiteFlow for expense approvals, the Employee Center is the primary workspace for processing expense approvals.

- The Employee Center shows the Expense Reports to Approve reminder and Approve Expense Reports queue.
- Employees are shown all expenses for which they are the next approver.
- Users are not required to have the Full permission for the Employee Center to approve and reject expenses through the Employee Center. They can do so with only the View permission.
- Reminders that show in the Employee Center drill down to the approval queue page for expense reports. You can still click through notification email and use the buttons on the expense form (such as Approve, Reject, etc.)
- An approver that is associated with one subsidiary is able to see only records that are associated with the same subsidiary to make approvals.

**To approve an expense using SuiteFlow:**

1. Log in to the Employee Center.
2. Click **Approve Expense Requests**.
3. Select a process in the **Action** field.
   - The Action field lists the available actions of all expense workflows. For example, you can select the workflow action of Approve, or alternately select the action Reject.
   - Actions available in the field are shown as follows:
     - Workflow name : Workflow state : Workflow action
       - This is an example of a workflow action selection:
         - Expense Approval Routing : Pending Approval : Approve
       - The third section shows the action that will be implemented for the selected purchases. In the case above, that action is to Approve.
       - The selection you make in the Action field filters the list of purchases that are displayed.
       - For example, select the action "Expense Approval Routing : Pending Approval : Approve" then the list of expenses that show are only ones that meet the following conditions:
         - Uses the workflow named Expense Approval Routing
         - Has a status of Pending Approval
       - You can select All in the Action field to show expenses associated with all workflows and actions.
4. After you have selected the workflow and action, check the **Select** box next to each expense you wish to process using the action you have selected.
5. Click Submit.

You also have the option of manually selecting a status in the Approval Status field on an expense.

**Switching from the Approval Routing Feature to SuiteFlow for Expenses**

If you already use the Approval Routing feature for expense reports, consider the following before you enable the preference to use SuiteFlow.

When the Expense Reports preference is enabled for approval routing, basic functions of the Approval Routing feature are immediately disabled for expense reports.

- Email notifications are no longer automatically sent when expense reports are awaiting an approval, are approved, or are rejected. To send such email, you must incorporate these steps into the approval workflow that you create.
- Expense transactions do not automatically show Approve and Reject buttons to process forms for approval in Employee Center. To show buttons on forms, you must incorporate them into the approval workflow that you create.
- There is no longer Supervisor or Approver hierarchy-based approval routing.
- The Supervisor Approval and Accounting Approval boxes no longer show in non-Employee Center roles.
- Expense reports that are unapproved or partially approved revert to a status of Pending Approval. You must use the Initiate Workflow Mass Update to start over in approval workflow.
- You can later disable the preference and go back to using the Approval Routing feature.

To replace these former functions, you must incorporate them into an approval routing workflow you create. Now, you use SuiteFlow to process approvals for expense reports instead of the previous method associated with the Approval Routing feature.

Before you enable the preference, first set up your approval routing workflow. Then, set the workflow to Released when you enable the preference.

For details about setting up approval workflows, read the help topic Creating Your First Workflow.

After you enable the preference, the following changes take place in your account with regard to expense report approvals:

**Initiate Workflow Mass Update**

Expense reports existing in your account prior to using SuiteFlow that are unapproved or are partially approved will have their status set to Pending Approval. They must then be processed using workflow-based approval from the beginning.

In other words, approval steps you entered previously may need to be re-entered using SuiteFlow. You must run an Initiate Workflow mass update after you have set up your workflow.

When you run the mass update, the existing transactions that require additional approval steps are incorporated into the workflow at the appropriate stages and are ready for remaining processing within the workflow.

For details about running the Initiate Workflow mass update, read the help topic Mass Initiating Workflow Instances.

**Approval Status Field**

When you use SuiteFlow for expense report approvals, the forms now include an Approval Status field. The Approval Status field reflects the state of the transaction in the approval process.
Expense reports may have one of the following statuses:

- Pending Approval – The expense is in the approval queue.
- Approved – The expense has been given approval for processing.
- Rejected – The expense has not been approved and will not be processed.

Existing expense reports show the following in the new Approval Status field based on the transaction status:

<table>
<thead>
<tr>
<th>Previous Status</th>
<th>New Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pending Supervisor Approval</td>
<td>Pending Approval</td>
</tr>
<tr>
<td>Pending Receipt</td>
<td>Approved</td>
</tr>
<tr>
<td>Partially Received</td>
<td>Approved</td>
</tr>
<tr>
<td>Pending Bill</td>
<td>Approved</td>
</tr>
<tr>
<td>Pending Billing/Partially Received</td>
<td>Approved</td>
</tr>
<tr>
<td>Fully Billed</td>
<td>Approved</td>
</tr>
<tr>
<td>Closed</td>
<td>Approved</td>
</tr>
<tr>
<td>Rejected by Supervisor</td>
<td>Rejected</td>
</tr>
</tbody>
</table>

**Next Approver Field**

When you use SuiteFlow for expense approvals, expense reports include a Next Approver field. This field is populated based on the associated workflow.

For example, in your workflow you may create a state of Pending Approval. In that state you create a formula to set the Next Approver as the employee’s supervisor.

**Editing an Expense Report from the Expense Reports List**

You can use the list of expense reports to edit an individual expense report record.

**To edit an expense report from the list:**

1. Go to Transactions > Employees > Enter Expense Reports > List.
2. Click Edit next to an expense report you want to edit.
3. On the Edit Expense Report page, edit the fields you want to change. You can edit a line item on the Expenses subtab by clicking on a field in the table, then clicking Ok in the line item row.
4. When you are finished, click Save.

**Deleting an Expense Report from the Expense Reports List**

You can use the list of expense reports to delete an individual expense report record.

**To delete an expense report from the list:**

1. Go to Transactions > Employees > Enter Expense Reports > List.
2. Click Edit next to an expense report you want to delete.
4. At the prompt to confirm the action, click OK.

For more information, see Voiding Expense Reports.

Rejecting an Expense Report from the Expense Reports List

You can use the list of expense reports to reject an individual expense report record.

**To reject an expense report from the list:**

1. Go to Transactions > Employees > Enter Expense Reports > List.
2. Click Edit next to an expense report you want to reject.
4. On the Expense Report Rejection Notice page, enter a reason for the rejection in the Your Message field, and then click Save.

On the Expense Report page, under Actions, you can create a new expense report, show any expense activity, and view the GL impact of this expense.

After an expense report has been rejected, it can be edited and resubmitted.

Corporate Card Expenses

You can designate expense lines as paid by a corporate credit card on expense reports. If you have more than one credit card account defined in NetSuite, you can select the default account in Accounting Preferences, on the employee record, and on individual expense reports. In Accounting Preferences, you can also select a default account for personal expenses paid with a corporate card. For more information, see the help topic Time & Expenses Accounting Preferences. For OneWorld accounts, see the help topic Set Subsidiary Preferences.

**Note:** If you only have a single credit card account, the Default Account for Corporate Card Expenses preference field does not appear.

To use corporate card expenses, you must first customize your expense report form to include the relevant fields. For more information on customizing forms, see the help topics Creating Custom Entry and Transaction Forms and Configuring Sublist Fields.

There are two optional fields you can add to the body of your expense reports and one required field for expense line items:

- Account for Corporate Card Expense – optional field to enable the default account to be overridden at the expense report level
- Corporate Card by Default – optional field to enable all entered expenses to automatically be marked as corporate card expenses
- Corporate Card – required field to enable expenses to be marked as corporate card expenses on your expense reports

Corporate card expenses can also be marked as billable. If you use non-reimbursable expenses, when expense lines are marked as corporate card expenses they can no longer be marked as a non-reimbursable expense. You can disable non-reimbursable expenses by going to Setup > Accounting.
> Accounting Preferences, on the Time & Expenses subtab, under Expenses, clear the Allow Non-
reimbursable expenses box.

Expense reports including corporate card expenses debit the Expense account while crediting the
selected credit card account. When reconciling a credit card statement in NetSuite, corporate card
expenses show up automatically as a journal entry.

Employees whose companies pay corporate credit card bills directly can differentiate personal expenses
charged to a corporate card using expense categories.

To use personal corporate card expenses, check the Personal Corporate Card Expense box on expense
category records. When employees enter expense reports, they can select any personal corporate card
expense category to indicate that the line item is not a company expense. Only one personal expense
category may be used on a single expense report.

Note: Corporate card expense categories can only use other asset accounts. If your company
does not use expanded account lists, the corporate card field on expense categories is disabled.
Any expense category attached to an other asset account is automatically designated a corporate
card expense. To enable the expanded account list preference, go to Setup > Accounting >
Preferences > Accounting Preferences > General Ledger.

For more information, see Understanding Expense Categories.

Non-Reimbursable Expenses

When entering an expense report, you can choose to mark a line item as Non-reimbursable. This function
may be useful when an employee is required to enter an expense receipt but should not be reimbursed
for the amount. This may be necessary if employee expenses are paid using a third party or should not be
reimbursed by the company.

For example, an employee may be required to enter an expense report with a receipt for a meal to bill the
amount to a client. Because the employee used a company credit card to pay for the meal, the expensed
amount should not be reimbursed to the employee. Expenses that are paid for with a corporate credit
card would be marked as non-reimbursable if the credit card bill is to be paid directly by the company.

Important: If you did not use non-reimbursable expenses prior to NetSuite 18.2, they are no
longer available. If you used non-reimbursable expenses prior to NetSuite 18.2, you can choose
disable the availability when entering expense reports. See Corporate Card Expenses for more
information on tracking non-reimbursable expenses paid by a corporate credit card.

To mark an expense as non-reimbursable, on the Expenses subtab of the expense report, check the box
in the Non-reimbursable column.

The employee can enter one line on the expense report for the meal and mark it as both Billable and
Non-reimbursable. For any line marked Non-reimbursable, the employee will not be reimbursed for the
amount on that line.
Expenses marked as non-reimbursable are shown on expense reports and expense report receipts, but they are not payable to the employee and are not included in the amount due on expense reports.

A non-reimbursable expense has no general ledger impact. An expense marked as non-reimbursable will have both a debit and credit entry for the associated account canceling out any impact to your ledger accounts.

When the expense report is printed, amounts are categorized as Reimbursable or Non-reimbursable and subtotaled for each.

The Non-reimbursable box can be hidden by customizing the form. The box is set to show on the form by default.

**Reviewing Expense Reports**

You can use the list of expense reports to review status, print, or export expense report data, or to access individual expense report records for viewing and editing.
To review expense reports:

1. To get to the list of expense reports:
   - In the Employee Center Home Links portlet, click the View & Edit Expense Reports link.
   - If you are logged in with a role that has the Expense Reports permission, go to Transactions > Employees > Enter Expense Reports > List.

2. You can do the following from the Expense Reports list:
   - Click a View link to view an expense report record.
   - Click an Edit link to make changes to or delete an expense report record.
   - Click a Print link to print a single expense report record.
   - Click an Account link to view the account register.
   - Select from the dropdowns to filter the expense report records that are displayed in the list.
   - Click New to create a new expense report.
   - Click Print to print the entire list of expense reports.
   - Click Export to export expense report list data to a CSV, Excel, or PDF file.
   - Click Customize View to change the columns displayed in the list. See the help topic Customizing List Views.

**Note:** If you customize the expense report list view to include a Currency column, be aware that the listed currency values correspond to base currencies for employees and may not match the actual currencies in the expense reports.

Giving Accounting Approval for Expense Reports

Expense reports have no accounting impact until they are approved by someone with accounting authority. When reports are entered, their totals remain in an unapproved non-posting account.

By default, an expense report requires approval by the employee's immediate supervisor before being sent for accounting approval. If approval routing is enabled and set up, a more complex approval hierarchy is followed. See the help topic Approval Routing.

When an expense report receives accounting approval, a bill is automatically created and its amount is reflected on your books. The expense report is posted in the earliest open period, which may not be the same as the period when the expense report was entered.

The following three conditions must be met for a role to be able to give accounting approval of an expense report:

- Use one of the following centers:
  - Executive Center
  - E-Commerce Management Center
  - Marketing Center
  - Classic Center
  - Support Center
  - Shipping Center
  - Sales Center
  - Project Center
  - Accounting Center
Expense Reporting

222

Engineering Center
- Expense Report permission set to Edit or Full
- Restrict Time and Expense preference is set to False

You can customize an existing role or create a new role to give access to accounting approval permissions. For more information, see the help topic Customizing or Creating NetSuite Roles.

If an expense report is rejected by accounting, it can be edited by the employee and resubmitted for approval by the employee’s immediate supervisor before being routed to accounting for approval.

Expense reports that require accounting approval can be accessed in two different places:
- Unapproved Expense Reports Register - See Approving Expense Reports from the Register.
- Expense Reports List - See Approving Expense Reports from the Expense Reports List.

Setting Default Payable Accounts for non-OneWorld Account

Companies with multiple payable accounts can set a company-wide default payable account for expense reports. Setting a default account enables more consistent expense reporting across your company.

To set a default payable account non-OneWorld account:

1. Go to Setup > Accounting > Accounting Preferences.
2. Click the Time & Expenses subtab.
3. In the Default Payable Account for Expense Reports field, select a payable account.

   **Note:** The Default Payable Account for Expense Reports field is only available when you have more than one payable account.

4. Click Save.

In OneWorld accounts, the default payable account preference is set by subsidiary.

Setting Default Payable Accounts for OneWorld Account

To set a default payable account (OneWorld account):

1. Go to Setup > Company > Subsidiaries.
2. Next to the subsidiary you want to update, click Edit.
3. Click the Preferences subtab.
4. In the Default Payable Account for Expense Reports field, select a payable account.
5. Click Save.

   **Note:** If you want to see the general ledger impact of an expense report before you approve it, view the expense report record, and then click Actions > GL Impact.

Approving Expense Reports from the Register

To approve expense reports from the Unapproved Expense Reports Register:

1. Go to Transactions > Employees > Enter Expense Reports.
2. In the More menu, click the Approve Expense Reports link.
3. Click the date next to the expense report you want to approve.
4. If the report is complete, click Approve in the middle of the form.
   If you want to reject the report, click Reject. When the email form appears, you can send a message to your employee about the expense report. Complete the email message, and then click Save.
   If multiple payable accounts exist and a default account is not selected at Setup > Accounting > Accounting Preferences > Time & Expenses, you cannot automatically approve the expense report from the register. You must edit the expense report and manually select a payable account.

Approving Expense Reports from the Expense Reports List

To approve expense reports from the list:
1. Go to Transactions > Employees > Enter Expense Reports > List.
2. Click Edit next to an expense report with a status of Pending Accounting Approval.
3. On the expense report, check the Accounting Approval box.
4. If multiple accounts payable accounts are available and a default account has not been set, select a payable account in the Account field. (This field does not display if there is only one accounts payable account.)
5. Click Save.

**Note:** If you customize the expense report list view to include a Currency column, be aware that the listed currency values correspond to base currencies for employees and may not match the actual currencies in the expense reports.

Understanding Expense Categories

Expense categories are used to group expenses. Popular categories include transportation, lodging, mileage, and entertainment. Each expense category is linked to an account. When an employee enters an expense report, he or she selects a category for each expense, and the expense automatically posts to the associated expense account. Note that new expense categories cannot be created at the time an expense report is entered.

If you use NetSuite OneWorld, be aware that an expense category is available to only those subsidiaries assigned to the account linked with the expense category. If you want to enable intercompany expense transactions, it is recommended that you set up expense categories linked to expense accounts that are available to all subsidiaries, for use in these transactions. For intercompany expense transactions, users cannot save expense lines unless they contain expense categories available to both the employee subsidiary and customer subsidiary.

To enter expense categories, go to Setup > Accounting > Expense Categories > New. For more information, see the help topic Creating an Expense Category.

Paying Expenses on Employee Paychecks with Payroll

If you use SuitePeople U.S. Payroll, you can choose to pay employees’ expenses on their regular paychecks instead of paying them through accounts payable. When you use SuitePeople U.S. Payroll to pay expenses, you pay the full amount of the expense report. If you want to partially pay an expense...
report, or pay an expense report on a date other than the regular pay date, you must pay expenses by accounts payable. To pay expenses by accounts payable, go to Transactions > Pay Bills.

To pay expenses on an employee's paychecks, you must complete the following tasks:

1. Enabling the Pay Expenses on Paychecks Preference
2. Creating an Earning:Expense Payroll Item
3. Adding an Expense Payroll Item to an Employee Record
4. Updating Payroll Information
5. Creating a Payroll Batch that Uses the Pay Expenses Option

**Note:** When you pay expenses on employee paychecks, in the general ledger, the default payable account for expense reports is debited, and the payroll funding account is credited. For more information about default payable accounts, see Setting Default Payable Accounts for non-OneWorld Account.

### Enabling the Pay Expenses on Paychecks Preference

**To enable the Pay Expenses On Paychecks preference:**

1. Go to Setup > Payroll > Set Up Payroll.
2. Check the **Pay Expenses on Paychecks** box.
3. Click **Save**.

After you enable the preference, you need to create a new payroll item.

### Creating an Earning:Expense Payroll Item

**To create or edit an Earning:Expense payroll item:**

1. Go to Lists > Employees > Payroll Items.
   - To create a new payroll item, click New.
   - To edit an existing payroll item, click **Edit** next to the payroll item you want to edit.
2. If you have a NetSuite OneWorld account, select a subsidiary from the **Subsidiary** list.
3. From the **Item Type** list, select **Earning:Expense**.
4. In the **Item Name** field, enter a name for the earning item.
5. From the **Expense Account** list, select the expense account to associate with the payroll item.
6. If necessary, select a **Pay Code** and a **Report Section**.
7. Click **Save**.

Earning:Expense items do not affect an employee's gross pay. They are added to the net pay. In addition, expense items do not appear on the employee's W-2.

Next, you need to add the expense payroll item to the employee record.

### Adding an Expense Payroll Item to an Employee Record

**To add an expense payroll item to an employee record:**

1. Go to Lists > Employees > Employees.
2. Click **Edit** next to the employee name.
3. On the employee record click the **Payroll** subtab.
4. Click the **Earnings** subtab.
5. From the **Earnings** list, select the expense payroll item.
6. Click **Add**.
7. Click **Save**.

Add the expense payroll item to all employee records. For more information, see the help topic *Including an Employee in Payroll*.

When an employee submits an expense report and it is approved, you can now pay the expense report when you process payroll.

**Updating Payroll Information**

After you create the Earning:Expense payroll item and add the item to employee records, you must update payroll information. For more information, see the help topic *Updating Payroll Information*.

**Creating a Payroll Batch that Uses the Pay Expenses Option**

**To pay expenses on checks in a payroll batch:**

1. Go to Transactions > Employees > Create Payroll.
2. Create the payroll batch. For more information, see the help topic *Creating a Payroll Batch*.
3. On the Payroll Run page, verify that the **Pay Expenses** box is checked.
4. Verify that the employees you want to pay are included in the payroll.
5. Click **Calculate**.
6. When the calculation is complete, on the **Complete** subtab, click **View** next to a paycheck.
7. Click the **Expenses** subtab.
8. Verify that the expense appears on the paycheck.

After you have verified the information for the payroll batch, you can commit it. For more information, see the help topic *Committing a Payroll Batch*.

**Giving an Employee Access to Purchase Requests**

Employees with access to purchase requests can enter requests to purchase items, material or services from vendors. After requests are approved, they turn into purchase orders.

To give an employee access to purchase requests, first, someone with permission to access the Enable Features page must enable the Purchase Requests feature. Next, the employee record must be set up to give the employee access to the Employee Center.

**To enable the Purchase Requests feature:**

1. Go to Setup > Company > Enable Features.
2. Click the **Employees** subtab.
3. Check the Purchase Requests box.
4. If you want purchase requests to be approved by a supervisor, also check the Approval Routing box.
5. Click Save.

Then, you must give your employees access to the Employee Center in your account. If you have not already set up employee records, see the following topics:

- Adding an Employee Record
- Giving an Employee Access to NetSuite
- Assigning Roles to an Employee

After employees log in to NetSuite, they can enter purchase requests and view and edit their purchase requests and purchase orders.

If you designate a particular employee as a supervisor or purchase approver for other employees, this person can approve or reject these employees' purchase requests.

### Notifying a Supervisor or Approver About Required Approvals

You can notify supervisors or approvers by email when they need to approve expense reports, time entries, or purchase requests.

**To notify supervisors of required approvals:**

1. Go to Setup > Accounting > Accounting Preferences and click the Time & Expenses subtab.
2. Check the Automatically Notify Supervisor box.
3. Click Save.

Now, whenever employees submit expense reports, time entries, or purchase requests, NetSuite notifies their supervisors or approvers by email. Supervisors also receive an email notification if any changes are made to an expense report prior to approval.

If the Approval Routing feature is not enabled, the employee's immediate supervisor approves an expense report, time entry, or purchase request.

**Note:** If you use custom approvals for time entries, the Automatically Notify Supervisor preference does not apply.

### Using the Approval Routing Feature

When this Approval Routing feature is enabled, an approval hierarchy can be set up with a series of designated approvers. For more information, see the help topic Approval Routing.

After approval routing is set up, all expense reports, time entries, and purchase requests must be entered through the Employee Center to maintain the hierarchy of approval routing. Employees with additional assigned roles should log in with their Employee Center role to enter expense reports, time entries, or purchase requests.
Using SuiteFlow for Purchase Approvals

If you use SuiteFlow to process purchases using custom workflows, notifying supervisors or approvers must be part of the workflow that you create. For more information, see the help topic Using Custom SuiteFlow Workflows for Approval Routing.
Analytics and Reporting

NetSuite provides analytics, which enable you to measure and analyze company headcount, hiring, and turnover trends, as well as various employee-related reports:

- Workforce Analytics
- Employee Reports and Workbooks
- HR Dashboard Components
Workforce Analytics

This chapter includes the following help topics:

- Workforce Analytics Overview
- Working with Headcount Analysis
- Working with Turnover Analysis

Workforce Analytics Overview

**Warning:** This feature exposes personal information about employees. This feature should only be enabled for users who are authorized to access all employee data.

The Workforce Analytics feature gives Human Resources the tools to measure and analyze company headcount, hiring, and turnover trends. This feature compiles your data, and converts it into rich HR metrics that are available through the Headcount Analysis and Turnover Analysis pages.

The Workforce Analytics feature is available to roles that have the Workforce Analytics permission. By default, this permission is automatically added to NetSuite's standard Chief People Officer (CPO) and Human Resources Generalist roles, at access level View.

You can create custom roles that include this permission. For more information, see the help topics Customizing or Creating NetSuite Roles and Workforce Analytics Permission Requirements.

View the Working with Workforce Analytics video.

The Workforce Analytics feature enables you to:

- View headcount, hire, and turnover trends in your company. For more information, see Headcount Analysis Trends.
- Get a high-level synopsis of the employees who are leaving your company, and the reasons they are leaving. For more information, see Turnover Analysis Trends.
- Filter and segment data by gender, employee type categories, department, location, or (with NetSuite OneWorld) subsidiary. Data can be further filtered to include subdepartment and sublocation.
- View custom snapshot views of headcount and turnover trends, for a specific quarter. For more information, see Headcount Analysis Snapshots and Turnover Analysis Snapshots.

**Note:** The Workforce Analytics feature supports standard fields, such as hire date and termination/release date. Custom fields are not referenced.

Working with Headcount Analysis

Headcount analysis is used to analyze headcount, hire, and turnover trends in your company. This includes all active and inactive employees, on or after their hire dates. Employees who have been terminated are excluded after their termination dates. To access the Headcount Analysis page, go to Reports > Employees/HR > Headcount Analysis.
Headcount Analysis Trends

There are two headcount analysis trends: headcount trend, and hires and turnover trend. These trends analyze year-to-date headcount, hire, and turnover trends for employees in your company for each month of the selected year. The headcount includes all active and inactive employees who have a hire date. This also includes employees who have a termination/release date that was before their hire date.

To access the headcount analysis trends, go to Reports > Employees/HR > Headcount Analysis. At the top of the page, click the year that you want to view.

1. Select the year that you want to view.
2. Segment data by department, location, gender, or (with NetSuite OneWorld) subsidiary. If applicable, department and location can be further segmented by subdepartment and sublocation.
3. Choose how you want to filter the data.
The Headcount Trend includes all non-terminated employees to the end of each calendar month of the selected year, for the selected segments.

Hover over each bar to see the total headcount in a particular month.

The Hires and Turnovers Trend includes all employees with hire and termination dates during each calendar month of the selected year, for the selected segments. Hover over each bar to see the total headcount for hires and terminations in a particular month.

This table reflects the data from the trends.

The left side shows the total employee headcount at the end of each month for the selected year, and the number and percentage of hires and terminations.

The right side shows the headcount data for the selected segments and filters. For example, if Location (All) is selected, the total headcount for each location is shown.

To copy and paste the data into other analysis tools, click **Copy to Clipboard**.

Headcount Analysis Snapshots

There are two headcount analysis snapshots: hires and turnovers, and gender. These snapshots allow you to analyze quarterly headcount trends.

To access the headcount analysis snapshots, go to Reports > Employees/HR > Headcount Analysis. At the top of the page, click the quarter that you want to view.

**Note:** Each quarter represents a completed quarter, and not a quarter-to-date.
Working with Headcount Analysis

1. Select the quarter that you want to view.

2. Segment data by department, location, gender, tenure, or (with NetSuite OneWorld) subsidiary. If applicable, department and location can be further segmented by subdepartment and sublocation.

   **Note:** When segmenting by tenure, the start of an employee's tenure is their Hire Date set on their employee record. However, when the Time-Off Management feature is enabled, the date set in Start Date for Time-Off Calculations is used.

3. Choose how you want to filter the data.

4. The Hires and Turnovers Snapshot lets you compare the hiring and turnover rates between the different segments in your company.
   - The left side shows the employee headcount, as of the last day in the period, for the selected segments.
   - The right side shows the number of employees hired and terminated from the start of the period to the end of the period, for the selected segments.

5. Switch between the different snapshots.

6. This table reflects the data from the snapshots. To copy and paste the data into other analysis tools, click **Copy to Clipboard**.

7. The Gender Snapshot shows the numbers and percentages of employee gender distribution as of the last day in the period, for the selected segments.
   - The left side shows the total headcount, and the right side shows male and female headcount percentages.

Working with Turnover Analysis

Turnover analysis is used to analyze the employees who are leaving your company and the reasons they are leaving. This can help you to identify challenges, and use that information to improve employee experience and plan strategies. Turnover analysis includes all active and inactive employees with a termination/release date for each month of the current and previous year. Employees who do not have a hire date entered on their employee record are not included.

To access the Turnover Analysis page, go to Reports > Employees/HR > Turnover Analysis.

**Note:** To use turnover analysis, make sure your account has the Termination Reasons Tracking feature enabled. For more information, see Termination Reason Tracking.

Turnover Analysis Trends

There are two turnover analysis trends: turnover trend and turnover reasons trend. These trends analyze year-to-date headcount, hire, and turnover trends for employees in your company, for each month of the selected year.

To access the turnover analysis trends, go to Reports > Employees/HR > Turnover Analysis. At the top of the page, click the year that you want to view.
1. Select the year that you want to view.

2. Segment data by department, location, gender, termination type, or (with NetSuite OneWorld) subsidiary. If applicable, department and location can be further segmented by subdepartment and sublocation.

3. Choose how you want to filter the data.

4. The Turnover Trend includes all employees with termination/release dates during each calendar month of the selected year, for the selected segments.

   Employees with a termination/release date within a calendar month contribute to the turnover count for that month.

   Hover over each bar to see the total turnover in a particular month.
5 The Turnover Reasons Trend analyzes all the termination reasons for each selected termination type, that contains at least one terminated employee. The data is broken down for each calendar month of the selected year, for the selected segments. Rows appear in descending order with the highest turnover reason at the top.

6 This table reflects the data from the trends. The left side shows the total employee headcount at the end of each month for the selected year, and the number and percentage of hires and terminations. The right side shows the headcount data for the selected segments and filters. For example, if Location (All) is selected, the total headcount for each location is shown.

To copy and paste the data into other analysis tools, click Copy to Clipboard.

Turnover Analysis Snapshots

There are three turnover analysis snapshots: hires and turnovers, gender, and turnover types (voluntary, involuntary). The turnover analysis snapshots allow you to analyze quarterly turnover trends.

To access the turnover analysis snapshots, go to Reports > Employees/HR > Turnover Analysis. At the top of the page, click the quarter that you want to view.

Note: Each quarter represents a completed quarter, and not a quarter-to-date.
1 Select the quarter that you want to view.

2 Segment data by department, location, gender, tenure, or (with NetSuite OneWorld) subsidiary. If applicable, department, and location can be further segmented by subdepartment and sublocation.

**Note:** When segmenting by tenure, the start of an employee’s tenure is the **Hire Date** set on the employee record. However, when the Time-Off Management feature is enabled, the date set in **Start Date for Time-Off Calculations** is used.

3 Choose how you want to filter the data.

4 The Hires and Turnovers Snapshot for turnover analysis lets you view employee changes for a specific period. The left side shows the employee headcount as of the last day in the period, for the selected segments. This data is compared to the right side of the graph, which shows the number of employees hired and terminated from the start of the period to the end of the period, for the selected segments.

5 Toggle between the different snapshots.

6 This table reflects the data from the snapshots. To copy and paste the data into other analysis tools, click **Copy to Clipboard**.

7 The Gender Snapshot for turnover analysis, analyzes the turnovers in your company by gender. By comparing the gender distribution of employees in your company to the gender distribution of terminated employees, you can spot any disproportional terminations in a gender group, for the selected segments.

8 The Turnover Types Snapshot analyzes the turnovers in your company by type, such as voluntary-regretted and involuntary-unregretted.

   It shows the employee headcount as of the end of the period, and compares it to the types of turnovers from the start to the end date, for the selected segments.
Employee Reports and Workbooks

NetSuite provides many different kinds of employee-related reports and workbooks:

- Time and Billables Reports
- Time-Off Management Reports and Workbooks
- Time-Off Tracking Reports
- Recruiting Reports
- Employee Change History Report
- Employee Saved Search Reports
- Customizing Employee Reports
- Employee Bonus History and Current Compensation Workbook

Time and Billables Reports

The following standard time and billables reports are available in NetSuite. Some reports are available only if you use Project Management.

- Earned Value by Project Report
- Time Entry Exceptions Report
- Time by Employee/Item/Customer Reports
  - Time by Employee Summary Report
  - Time by Employee Detail Report
  - Time by Customer Summary Report
  - Time by Customer Detail Report
  - Time by Item Summary Report
  - Time by Item Detail Report
- Current Backlog By Resource Report
- Estimated Profitability by Project Report
- Unbilled Cost by Customer Summary Report
- Unbilled Cost by Customer Detail Report
- Unbilled Time by Customer Summary Report
- Unbilled Time by Customer Detail Report

Time-Off Management Reports and Workbooks

The Time-Off Management feature includes a variety of reporting capabilities that you can use to retrieve, present, and analyze your time-off data.

The following reports are included with the Time-Off Management feature:

- Available Time-Off Report
- Time-Off Balance Summary Report
- Time-Off Balance Details Report
Time-Off Management Reports and Workbooks

- Time-Off Analysis Workbook
- Time-Off Tracking Reports

If no standard report fits your needs, you can create an ad hoc report. For more information, see Time-Off Management Ad Hoc Reports.

You can also customize these standard reports in the Report Builder by clicking Customize on the results page. For more information, see the help topics Report Builder Interface and Report Customization.

Available Time-Off Report

The standard Available Time-Off report summarizes the total number of used and scheduled time-off, the available time-off based on usage, and the time-off for the entire year across all classes, departments, locations, and subsidiaries. You can use this report to quickly see an employee's available time-off balance as of the current date.

To view the Available Time-Off report, go to Reports > Employees/HR > Available Time-Off.

This report displays the following for each employee:

- **Time-Off Type**
  - **Annual Entitlement** - The total available time-off for the current year. Includes all future accruals for the current year when the Days Available Includes Future Accruals box on the Time-Off Plan page is selected. For more information, see Creating a Time-Off Plan.
  - **Used** - The amount of time-off that has been used as of the current date.
  - **Scheduled** - The amount of time-off that has been requested and approved, but not yet taken.
  - **Available Now** - Total remaining time-off for the current year.

To customize this report and display it in the Report Builder, click Customize. For more information, see the help topic Report Customization.

The following selections are included for customization on the Available Time-Off report:

- **Available Time-Off:**
  - Annual Entitlement - The employee's total time-off for the current year. This is based on the number of days or hours the employee is entitled to for the particular time-off type.
  - Available Now - The employee's remaining time-off for the current year.
  - Scheduled - The amount of time-off, in hours, that has been requested and approved, but not yet taken.
  - Used - The amount of time-off, in hours, that has been used for the current year.

- **Time-Off Change Type:**
  - Name - The name of the time-off change type. For example, approved time-off request, manual adjustment, or automatic accrual.

- **Time-Off Type:**
  - Display Name - The time-off type display name.
  - Inactive - Indicates when a time-off type is inactive.
  - Increment Unit - Indicates whether the minimum increment of time-off is in days or hours.
  - Minimum Increment - The minimum increment of time-off required.
  - Name - The name of the time-off type.
  - Track Only - Indicates when a time-off type is track only.
Time-Off Balance Summary Report

The Time-Off Balance Summary report displays the amount of time-off employees have earned up to the current date based on the rules defined in the plan assigned to them. This report is useful for accounting purposes when you need to determine an employee's available time-off balance on a specific date.

To view the Time-Off Balance Summary report, go to Reports > Employees/HR > Time-Off Balance Summary.

This report displays the following for each employee:

- **Time-Off Type** - The employee's name and the time-off types that are available to them.
- **Carried Over** - If an employee is entitled to carry over unused time from the previous year, it appears in this column.
- **Earned** - The number of hours that have been accrued as of the current date, for each time-off type.
- **Used** - The amount of used time-off for each time-off type in the plan.
- **Carryover Expiry** - If any carryover has expired it appears in this column.
- **Balance** - Displays the balance as of the current date.

**Note:** If you need to search for a balance summary between a specific date range, it is important to note that the standard report does not display year-end expiry values. To get an accurate balance summary, set the start date to January 1st and the end date to whatever date you want to view the balance to. If required, you can customize the report to include year end expiry.

To customize this report and display it in the Report Builder, click **Customize**. For more information, see the help topic **Report Customization**.

The following selections are included for customization on the Time-Off Balance Summary report:

- **Time-Off Balance Adjustments**:
  - **Amount (Excluding year end expiry)** - Displays the balance without taking year-end expiry into account. Use this when running a report within a single year.
  - **Amount (Including year end expiry)** - The balance calculated includes the year-end expiry. Any positive balances at the end of the year are automatically adjusted to zero. Use this when running a report across multiple years. Also, use this in conjunction with Expired so you can see the full balance expiry at the end of the plan period and the carryover amount credit at the beginning of the plan period.
  - **Carried Over** - If an employee is entitled to carry over unused time from the previous year, it appears in this column.
  - **Carryover Expiry** - If any carryover expired it appears in this column.
  - **Date Applied** - The date the change was applied. Add this if you are looking to display each time off change individually.
  - **Earned** - The number of hours that have been accrued for the specified date range.
  - **Expired** - The amount of time-off that has expired at year end for the specified date range.
  - **Used** - The amount of used time-off for each time-off type for the specified date range.

- **Time-Off Change Type**:
  - **Name** - The name of the time-off change type. For example, approved time-off request, manual adjustment, or automatic accrual.

- **Time-Off Type**:
  - **Display Name** - The time-off type display name.
Time-Off Management Reports and Workbooks

- Inactive - Indicates when a time-off type is inactive.
- Increment Unit - Indicates whether the minimum increment of time-off is in days or hours.
- Minimum Increment - The minimum increment of time-off required for the time-off type.
- Name - The name of the time-off type.
- Track Only - Indicates when a time-off type is track only.

Time-Off Balance Details Report

The Time-Off Balance Details report contains a complete breakdown of each employee's time-off changes. This report is useful when you need more information than what is available on the Time-Off Balance Summary report. It contains an entry for each adjustment that was made to an employee's time-off. This includes the date of the change, the type of adjustment (for example, manual increase or usage) and the type of time-off the adjustment was made to (for example, vacation time or sick leave).

To view the Time-Off Balance Details report, go to Reports > Employees/HR > Time-Off Balance Details.

This report displays the following for each employee:

- **Time-Off Type** - Displays the employee's name and the time-off types that are available to them.
- **Date** - The date the change was applied.
- **Adjustment Type** - Distinguishes whether the adjustment was due to regular usage or whether a manual increase or decrease was made.
- **Amount** - The amount of time-off that was debited or credited.
- **Balance** - Displays the current balance.
- **Accrual Rate** - If the time-off change is an accrual based on hours worked, displays the accrual rate.
- **Hours Worked** - If the time-off change is an accrual based on hours worked, displays the hours worked as reported on the employee's approved time entry.

**Note:** If you need to search for a balance summary between a specific date range it is important to note that the standard report does not display year-end expiry values. To get an accurate balance summary the search dates must be in complete years and start on January 1st. If required, you can customize the report to include year-end expiry.

To customize this report and display it in the Report Builder, click Customize. For more information, see the help topic Report Customization.

The following selections are included for customization on the Time-Off Balance Details report:

- **Time-Off Balance Adjustments**:
  - Amount (Including year end expiry) - The balance calculated includes the year end expiry. Any positive balances are automatically adjusted to zero on December 31st and carry over is credited back to the employee on January 1st.
  - Amount (Excluding year end expiry) - Calculates the balance without taking year end expiry into account. Use this when running a report within a single year.
  - Amount - Displays a running total of an employee's balance.
  - Carried Over - If an employee has carried over unused time-off from the previous year it appears in this column.
  - Carryover Expiry - If any carryover expired it appears in this column.
  - Date Applied - The date the change was applied.
- Earned - The number of hours that have been accrued as of the current date.
- Expired - The amount of time-off that has expired at year end.
- Used - The amount of used time-off for each time-off type.

- **Time-Off Change Type:**
  - Name - The name of the time-off change type. For example, manual adjustment or automatic accrual.

- **Time-Off Type:**
  - Display Name - The time-off type display name.
  - Inactive - Indicates when a time-off type is inactive.
  - Increment Unit - Indicates whether the minimum increment of time-off is in days or hours.
  - Minimum Increment - The minimum increment of time-off required for the time-off type.
  - Name - The name of the time-off type.
  - Track Only - Indicates when a time-off type is track only.

### Time-Off Analysis Workbook

SuiteAnalytics Workbook offers many workbook and dataset templates, each with predefined source data, criteria, pivot tables, and charts.

This section contains the information for the SuiteAnalytics Actual Time Analysis workbook in NetSuite. For more information about SuiteAnalytics Workbook, see [Workbook and Dataset Templates](#).

- **Time-Off Analysis Dataset Template**
- **Time-Off Analysis Workbook**

### Time-Off Analysis Dataset Template

This dataset combines fields from the Time-Off Change and Employee record types to form formulas so you can assess time-off related information for your organization. It forms the source data for the Time-Off Analysis Workbook.

#### Dataset Configuration

The Time-Off Analysis combines fields from two record types and multiple criteria filters. To edit the dataset, see the help topic [Defining a Dataset](#).

<table>
<thead>
<tr>
<th>Root Record Type</th>
<th>Joined Record Type</th>
<th>Custom Formula Fields</th>
<th>Data Grid</th>
<th>Criteria Filters</th>
</tr>
</thead>
</table>
| Time-Off Change  | Employee           | (none)                | The following fields are included in the dataset. Time-Off Change:  
  - Accrual Rate  
  - Amount  
  - Date Applied  
  - Description  
  - Employee   | (none)             |
Time-Off Analysis Workbook

With the Time-Off Analysis workbook, you can assess time-off related information for your organization. The workbook complements the Time-Off Balance Details and Time-Off Balance Summary reports by consolidating balance totals in two ready-to-use pivot tables. The pivot tables show time-off balances by employee and time-off type, and time-off activities by employee, year, and time-off type. Also, you can use the data in the workbook to create your own charts and pivots to analyze data and identify potential issues.

The following Pivot Tables and Charts are predefined in the Time-Off Analysis workbook:

- **Time-Off Balance** — Details employees' time-off balances by time-off type.
- **Time-Off Activity** — Shows a summary of employees' time-off activity by time-off type, with totals broken down into year-end expiry, carryovers, accruals, usage, and manual adjustments.

For more information about SuiteAnalytics Workbooks, see the help topic SuiteAnalytics Workbook Overview.

Time-Off Tracking Reports

The Time-Off Tracking SuiteApp includes a set of saved searches that you can use as reports.

**Important:** The saved searches installed with the SuiteApp are not public. A user with the Administrator role must first customize the saved searches to define the roles that can access each saved search and their location in the Reports menu. For more information, see Customizing Time-Off Tracking Reports.

You can access the following saved searches through their own menu options at Reports > Time-Off:

- Approved Time-Off Requests Saved Search
- Employees without Time-Off Plans Saved Search
- Pending Time-Off Requests Saved Search
- Rejected Time-Off Requests
- Time-Off Plan Assignment Saved Search
- Upcoming Approved Time-Off (1 Month) Saved Search
- Work Calendars Saved Search

You can print and export the Time-Off Tracking saved search results, permitting the information to be shared as reports. Exporting is available to Excel, CSV, and PDF. You can find the print and export icon buttons at the top of the results list. You can also use saved search email to share complete search results with other users. To use saved search email, see the help topic Saved Search Email.
For more information about saved searches, see the help topic Saved Searches.

**Approved Time-Off Requests Saved Search**

The Approved Time-Off Requests saved search lists active employees with approved time-off requests. By default, the results are sorted alphabetically by employee name, and then by start date and time-off type.

**Employees without Time-Off Plans Saved Search**

The Employees without Time-Off Plans saved search lists any active employees who are not assigned a time-off plan. By default, the results are sorted alphabetically by employee name. In the results list, you can click the **Edit** link for each employee record to assign the employee a time-off plan.

**Pending Time-Off Requests Saved Search**

The Pending Time-Off Requests saved search lists active employees with time-off requests that are pending approval. By default, the results are sorted alphabetically by employee name, and then by start date and time-off type.

**Rejected Time-Off Requests**

The Rejected Time-Off Requests saved search lists active employees with rejected time-off requests. By default, the results are sorted alphabetically by employee name, and then by start date and time-off type.

**Time-Off Plan Assignment Saved Search**

The Time-Off Plan Assignment saved search lists the time-off plan assigned to each active employee. By default, the results are sorted alphabetically by time-off plan, job, and employee name. In the results list, you can click the **Edit** link for each employee record to update the employee's time-off plan.

**Upcoming Approved Time-Off (1 Month) Saved Search**

The Upcoming Approved (1 Month) Time-Off saved search lists active employees with approved time-off requests that have start dates within the next month. By default, the results are sorted alphabetically by employee name, and then by start date and time-off type.

**Work Calendars Saved Search**

The Work Calendars saved search lists work calendar assignments of active employees. By default, the results are sorted alphabetically by work calendar and employee name. In the results list, you can click the **Edit** link for each employee record to update the employee's time-off plan.

**Customizing Time-Off Tracking Reports**

You can customize the following Time-Off Tracking Reports Templates to create unique saved searches:

- TEMPLATE Approved Time-Off Requests
- TEMPLATE Pending Time-Off Requests
Customizing a Time-Off Tracking Report Template

To customize a time-off tracking report template:

1. Go to Lists > Search > Saved Searches.
2. Beside the template that you want to customize, click Edit.
3. In the Search Title field, remove “TEMPLATE” from the name of the search, and enter a new name for the search if necessary.
4. In the Audience tab, from the Roles list, select the roles that should have access to the saved search.
5. If necessary, update the settings in any of the other tabs (for example, you can update search criteria in the Criteria tab).
6. Click Save As.

Creating a Center Category for the Saved Search

To create a center category for the saved search:

Create a center category so that you can access the time-off tracking reports from menu links.

1. Go to Customization > Centers and Tabs > Center Categories > New.
2. Set the following values:
   - Set the Label field to Time-Off.
   - In the Center Type list, select Classic Center.
   - In the Center Tab list, select Reports.
3. In the table, depending on the report that was used to create the saved search, set the following values:

<table>
<thead>
<tr>
<th>For each of the following reports:</th>
<th>Set the Link column to:</th>
<th>Set the Label column to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Approved Time-Off Requests</td>
<td>Approved Time-Off Requests Results</td>
<td>Approved Time-Off Requests</td>
</tr>
<tr>
<td>Pending Time-Off Requests</td>
<td>Pending Time-Off Requests Results</td>
<td>Pending Time-Off Requests</td>
</tr>
<tr>
<td>Rejected Time-Off Requests</td>
<td>Rejected Time-Off Requests Results</td>
<td>Rejected Time-Off Requests</td>
</tr>
<tr>
<td>Upcoming Approved Time-Off (1 Month)</td>
<td>Upcoming Approved Time-Off (1 Month) Results</td>
<td>Upcoming Approved Time-Off (1 Month)</td>
</tr>
<tr>
<td>Time-Off Plan Assignment</td>
<td>Time-Off Plan Assignment Results</td>
<td>Time-Off Plan Assignment</td>
</tr>
<tr>
<td>Employees without Time-Off Plans</td>
<td>Employees without Time-Off Plans Results</td>
<td>Employees without Time-Off Plans</td>
</tr>
<tr>
<td>Work Calendars</td>
<td>Work Calendars Results</td>
<td>Work Calendars</td>
</tr>
</tbody>
</table>

4. Click Save.
You can now access the reports at Reports > Time-Off.

Recruiting Reports

The Recruiting Reports SuiteApp provides job requisition reports that are available as NetSuite saved searches. When customized, the saved searches can be accessed from a unique Reports menu location.

Prerequisite

Before you install the Recruiting Reports SuiteApp, go to Setup > Company > Enable Features. Click the Employees subtab and check the Job Requisitions box, under HR Information System.

Installation

To install Recruiting Reports, go to Customization > SuiteBundler > Search & Install Bundles.

Use the following information to search for the SuiteApp:

- Bundle Name — Recruiting Reports
- Bundle ID — 167235

Recruiting Reports is a managed bundle and is automatically updated whenever there are updates. These issue fixes and enhancements are available after the SuiteApp is updated in your account.

For more information about installing SuiteApps, see the help topic Installing a Bundle.

Recruiting Reports Saved Searches

**Important:** The saved searches installed with the SuiteApp are not public. A user with the Administrator role must first customize the saved searches to define the roles that can access each saved search and their location in the Reports menu. For more information, see Customizing Recruiting Reports.

You can access the following saved searches through their own menu options at Reports > Recruiting:

- **Open Job Requisitions** — This saved search lists active job requisition records that have no close dates and with Status set to Open. By default, the results are sorted by target hire date and job.
- **Pending Job Requisitions** — This saved search lists active job requisition records that have no close dates and with Status set to Pending Approval. By default, the results are sorted by target hire date and job.
- **Closed Job Requisitions** — This saved search lists active job requisition records that have close dates and with Status set to Closed. By default, the results are sorted by close date and job.
- **Filled Job Requisitions** — This saved search lists active job requisition records that have Status set to Filled. By default, the results are sorted by target hire date and job.
- **On-Hold Job Requisitions** — This saved search lists active job requisition records that have no close dates and with Status set to On-Hold. By default, the results are sorted by target hire date and job.
- **Overdue Job Requisitions** — This saved search lists active job requisition records that have no close dates and with Status set to Open, Pending Approval, or On-Hold. By default, the results are sorted by target hire date, close date, and job.
Customizing Recruiting Reports

You can customize the following Recruiting Reports Templates to create unique saved searches:

- TEMPLATE Open Job Requisitions
- TEMPLATE Pending Job Requisitions
- TEMPLATE Closed Job Requisitions
- TEMPLATE Filled Job Requisitions
- TEMPLATE On-Hold Job Requisitions
- TEMPLATE Overdue Job Requisitions

Customizing a Recruiting Report Template

To customize a recruiting report template:

1. Go to .
2. Beside the template that you want to customize, click Edit.
3. In the Search Title field, remove “TEMPLATE” from the name of the search, and enter a new name for the search if necessary.
4. In the Audience tab, from the Roles list, select the roles that should have access to the saved search.
5. If necessary, update the settings in any of the other tabs (for example, you can update search criteria in the Criteria tab).
6. Check the Show in Menu box.
7. Click Save As.

Creating a Center Category for the Saved Search

To create a center category for the saved search:

Create a center category so that you can access the recruiting reports from menu links.

1. Go to Customization > Centers and Tabs > Center Categories > New.
2. Set the following values:
   - Set the Label field to Recruiting.
   - In the Center Type list, select Classic Center.
   - In the Center Tab list, select Reports.
3. In the table, depending on the report that was used to create the saved search, set the following values:

<table>
<thead>
<tr>
<th>For each of the following reports:</th>
<th>Set the Link column to:</th>
<th>Set the Label column to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Job Requisitions</td>
<td>Open Job Requisitions Results</td>
<td>Open Job Requisitions</td>
</tr>
<tr>
<td>Pending Job Requisitions</td>
<td>Pending Job Requisition Results</td>
<td>Pending Job Requisitions</td>
</tr>
<tr>
<td>Closed Job Requisitions</td>
<td>Closed Job Requisition Results</td>
<td>Closed Job Requisitions</td>
</tr>
<tr>
<td>Filled Job Requisitions</td>
<td>Filled Job Requisition Results</td>
<td>Filled Job Requisitions</td>
</tr>
<tr>
<td>On-Hold Job Requisitions</td>
<td>On-Hold Job Requisition Results</td>
<td>On-Hold Job Requisitions</td>
</tr>
<tr>
<td>Overdue Job Requisitions</td>
<td>Overdue Job Requisitions Results</td>
<td>Overdue Job Requisitions</td>
</tr>
</tbody>
</table>

4. Click **Save**.

You can now access the reports at Reports > Recruiting.

**Employee Change History Report**

The Employee Change History report provides an efficient way to audit changes to employee data. You can use this report to audit changes across many employees within a specific date range or for specific fields. For example, HR and Payroll personnel can use the Employee Change History report to access the following information:

- An HR Administrator wants to see all changes to employee data to determine what information was changed and when.
- A Payroll Administrator wants to see the changes made to employee payroll settings between the first and last day of the year. This information helps to answer questions from employees and tax agencies related to payroll processing and tax filing.

To access the report, go to Reports > Employees/HR > Employee Change History.

You can customize this report in the Report Builder by clicking Customize on the results page. For more information, see the help topics Filtering Data on Reports and Adding, Removing, or Reordering Report Columns.

**Note:** This report does not support reporting by period even when the Report by Period preference is set to All Reports. The Report by Period preference can be configured at Home > Set Preferences, the Analytics subtab.

**Employee Saved Search Reports**

The Employee Reports SuiteApp requires SuitePeople HR. It allows access to employee reports that appear as NetSuite saved searches. When customized, the saved searches can be found in a unique Reports menu location. For more information, see SuitePeople Overview.

**Prerequisites**

Ensure the required features are enabled to install the Employee Reports SuiteApp (bundle ID 167330). Go to Setup > Company > Setup Tasks > Enable Features.
On the Employees subtab, under HR Information System, check each of the boxes for Compensation Tracking, Job Management, and Termination Reason Tracking.

On the SuiteCloud subtab, under SuiteScript, check the Server SuiteScript box.

Installation

To install Employee Reports, go to Customization > SuiteBundler > Search & Install Bundles.

Use the following information to search for the SuiteApp:

- Bundle Name — Employee Reports
- Bundle ID — 167330

Employee Reports is a managed bundle and is automatically updated. See the help topic Installing a Bundle for more information.

Accessing Employee Saved Search Reports

Important: The saved searches installed with the SuiteApp are private. An Administrator must customize the saved searches to define the roles that can access saved searches and their location in the Reports menu. For more information, see Customizing Employee Reports.

Access the following saved searches through their own menu options at Reports > Employees/HR:

<table>
<thead>
<tr>
<th>Saved Search</th>
<th>Required Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Salary by Ethnicity Saved Search</td>
<td>Compensation Tracking</td>
</tr>
<tr>
<td>Average Salary by Gender Saved Search</td>
<td>Compensation Tracking</td>
</tr>
<tr>
<td>Average Salary by Job Saved Search</td>
<td>Job Management</td>
</tr>
<tr>
<td>Employee Birthday Report Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>Employee Birthdays by Month Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>Employee Roster Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>Employees by Age Range Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>Employees by Base Wage Type Saved Search</td>
<td>Compensation Tracking</td>
</tr>
<tr>
<td>Employees by Ethnicity Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>Employees by Gender Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>Employees by Hire Date Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>Employees by Job Saved Search</td>
<td>Job Management</td>
</tr>
<tr>
<td>Employees with Incomplete Compensation Data Saved Search</td>
<td>Compensation Tracking</td>
</tr>
<tr>
<td>Employees without Supervisors Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>New Hires (Last 90 Days) Saved Search</td>
<td>–</td>
</tr>
</tbody>
</table>
### Saved Search Reports

<table>
<thead>
<tr>
<th>Saved Search</th>
<th>Required Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Hires by Ethnicity (last 12 months) Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>New Hires by Gender (last 12 months) Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>Termination Reasons (Trends) Saved Search</td>
<td>Termination Reason Tracking</td>
</tr>
<tr>
<td>Upcoming New Hires Saved Search</td>
<td>–</td>
</tr>
<tr>
<td>Upcoming Terminations Saved Search</td>
<td>–</td>
</tr>
</tbody>
</table>

Print and export the saved search results. Exporting is available to Excel, CSV, and PDF. The print and export buttons are at the top of the results list. For more information, see the help topic Exporting Search Results.

Use saved search email to share complete search results with other users. See the help topics Saved Search Email and Saved Searches for more information.

**Note:** When any of the Employee Reports saved search returns a single result, NetSuite opens the record if the user has permission to view it. To return search results as a list with only one record in the results, check the Show List When Only One Result box in Set Preferences > Analytics > Search.

### Average Salary by Ethnicity Saved Search

This search lists the average annual base wages of active employees by ethnic group. Results are sorted by ethnic group, average base wage, and employee count. In the results list, click each of the ethnicity name to view more details.

### Average Salary by Gender Saved Search

This search lists the average annual base wages of active employees by gender group. Results are sorted by gender group, average base wage, and employee count. In the results list, click each of the gender name to view more details.

### Average Salary by Job Saved Search

This search lists the average annual base wages of active employees by job group. Results are sorted by job group, average base wage, and employee count. In the results list, click each of the job name to view more details.

### Employee Birthday Report Saved Search

This search lists all active employees with their birth date, age, and other employee details. Results are sorted by birth date and then alphabetically by employee name.

### Employee Birthdays by Month Saved Search

This search lists the number of active employees born in each calendar month. In the results list, click the name of each calendar month to view more details.
Employee Roster Saved Search

This search lists all active employees in ascending alphabetical order by last name. Results includes job, supervisor, class, department, location, subsidiary, and country details for each employee. The employee name is linked to the employee record.

Employees by Age Range Saved Search

This search lists the number of active employees by age range. In the results list, click the name of each age range group to view more details.

Employees by Base Wage Type Saved Search

This search lists the number of active employees by base wage type. In the results list, click the name of each base wage type to view more details.

Employees by Ethnicity Saved Search

This search lists the number of active employees by ethnic group. In the results list, click the name of each ethnic group to view more details.

Employees by Gender Saved Search

This search lists all active employees sorted by gender and hire date.

Employees by Hire Date Saved Search

This search lists all active employees by hire date, from the most recent to the least recent date of hire.

Employees by Job Saved Search

This search lists the number of active employees by job. In the results list, click the name of each job to view more details.

Employees with Incomplete Compensation Data Saved Search

This search lists active employees who are missing at least one of the following information in their employee record: base wage, base wage type, and compensation currency. In the results list, the employee name is linked to the employee record.

Employees without Supervisors Saved Search

This search lists active employees without a supervisor on record. In the results list, the employee name is linked to the employee record.
New Hires (Last 90 Days) Saved Search
This search lists active employees hired within the last 90 days. Results are sorted by hire date, from the most recent to the least recent date of hire. Results are sorted by hire date, from the most recent to the least recent date of hire.

New Hires by Ethnicity (last 12 months) Saved Search
This search lists the number of active employees from each ethnic group who have been hired within the last 12 months. In the results list, click the name of each ethnic group to view more details. In the detailed report, results are sorted by hire date, from the most recent to the least recent date of hire.

New Hires by Gender (last 12 months) Saved Search
This search lists the number of active employees from each gender group who have been hired within the last 12 months. In the results list, click the name of each gender group to view more details. In the detailed report, results are sorted by hire date, from the most recent to the least recent date of hire.

Termination Reasons (Trends) Saved Search
This search lists reasons cited by inactive employees for terminating their employment, and the number of times each reason is cited. In the results list, click the name of each termination reason to view more details.

Upcoming New Hires Saved Search
This search lists employees with hire dates that after the current date. Results are sorted by hire date, job, and location.

Upcoming Terminations Saved Search
This search lists active employees with termination or release dates that are after the current date. Results are sorted by termination date, job, and location.

Customizing Employee Reports
You can customize the following Employee Reports Templates to create unique saved searches:

- TEMPLATE Average Salary by Ethnicity
- TEMPLATE Average Salary by Gender
- TEMPLATE Average Salary by Job
- TEMPLATE Employee Birthday Report
- TEMPLATE Employee Birthdays by Month
- TEMPLATE Employee Roster
- TEMPLATE Employees by Age Range
- TEMPLATE Employees by Base Wage Type
Customizing an Employee Report Template

To customize an employee report template:

1. Go to .
2. Beside the template that you want to customize, click Edit.
3. In the Search Title field, remove “TEMPLATE” from the name of the search, and enter a new name for the search if necessary.
4. In the Audience tab, from the Roles list, select the roles that should have access to the saved search.
5. If necessary, update the settings in any of the other tabs (for example, you can update search criteria in the Criteria tab).
6. Click Save As.

Tip: To make it easier to complete the next set of steps, after you create your new saved search, copy its ID. On the Saved Searches page, the ID appears in the ID column, beside the name of the saved search.

Adding a Menu Link for a Saved Search

To add a menu link for a saved search:

After you customize a template and create a new saved search, you can add a menu link to access the saved search.

1. Go to Customization > Scripting > Scripts.
2. Beside ER Redirect Su, click View.
3. Click the Deployments tab. For each of the deployments that correspond to the employee report templates that you customized, do the following:
   a. Click the deployment. For example, if you created a customized saved search based off of the Employee Birthday Report, click the Employee Birthday deployment.
   b. Click Edit.
c. Click the Parameters tab. In the View field, enter the ID for the corresponding saved search that you customized earlier (for example, the ID for the customized Employee Birthday Report might be `customsearch_er_employee_bday_2`).

Note: To find the ID for the saved search, go to Lists > Search > Saved Searches. The ID appears beside the saved search in the ID column.

d. In the Audience tab, from the Roles list, select the roles that should have access to the saved search.

4. Check the Deployed box.
5. Click Save.

You can now find the customized saved search by going to Reports > Employees/HR.

Employee Bonus History and Current Compensation Workbook

SuiteAnalytics Workbook offers many workbook and dataset templates, each with predefined source data, criteria, pivot tables, and charts.

This section contains the information for the SuiteAnalytics Employee Bonus History and Current Compensation Workbook in NetSuite. For more information about SuiteAnalytics Workbooks, see the help topic Workbook and Dataset Templates.

- Employee Bonus History Compensation Overview Dataset Template
- Employee Bonus History and Current Compensation Workbook Template

Employee Bonus History Compensation Overview Dataset Template

This dataset combines fields from the Employee and Bonus record types so that you can view a summary of employees' current base compensation and a history of employees' bonuses. It forms the source data for the Employee Bonus History and Current Compensation Workbook.

Dataset Configuration

While you work with the Employee Bonus History and Current Compensation workbook template, consider that the Advanced Employee Permissions feature can impact the employee record fields that you have access to. The Advanced Employee Permissions feature does not affect fields on the bonus record. Rather, employee and subsidiary restrictions that are applied to your role can affect your access to bonus record information. For more information, see Employee Bonus History Compensation Overview Workbook.

<table>
<thead>
<tr>
<th>Root Record Type</th>
<th>Joined Record Type</th>
<th>Custom Formula Field</th>
<th>Data Grid</th>
<th>Criteria Filters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee</td>
<td>Bonus</td>
<td>(none)</td>
<td>The following fields are included in the dataset.</td>
<td>(none)</td>
</tr>
<tr>
<td>Root Record Type</td>
<td>Joined Record Type</td>
<td>Custom Formula Field</td>
<td>Data Grid</td>
<td>Criteria Filters</td>
</tr>
<tr>
<td>------------------</td>
<td>--------------------</td>
<td>---------------------</td>
<td>-----------</td>
<td>------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>Employee:</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>▪ Base Wage</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>▪ Base Wage Type</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>▪ Compensation Currency</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>▪ Entity ID</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>Bonus:</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>▪ Amount</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>▪ Award Date</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>▪ Bonus Type</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>▪ Currency</td>
</tr>
</tbody>
</table>
Compliance

NetSuite provides the following features and SuiteApps that enable you to comply with government and industry requirements:

- Workplace Incident Tracking
- Affordable Care Act (ACA) Reporting
- Government-Issued ID Tracking
- Benefits Tracking
Workplace Incident Tracking

Important: This feature requires SuitePeople. For more information, see SuitePeople Overview.

The Health and Safety SuiteApp enables you to record and report on health and safety incidents in the workplace. Using this SuiteApp's reporting features, you can generate any reports that are required to document your compliance with regulatory requirements in your jurisdiction. This SuiteApp provides three versions of the workplace incident form:

- Occupational Safety and Health Administration (OSHA) 301 form for companies in the United States
- Reporting of Injuries, Diseases and Dangerous Occurrences Regulations (RIDDOR) form for companies in the United Kingdom
- General incident reporting form for other jurisdictions

For more information on this SuiteApp, see the following topics:

- Setting Up the Health and Safety SuiteApp
- Working with Workplace Incidents
- Adding a Workplace Incident
- Generating OSHA Workplace Incident Logs and Summaries

Setting Up the Health and Safety SuiteApp

Prerequisites for the Health and Safety SuiteApp

To install the Health and Safety SuiteApp, you must have NetSuite 2016.2 or later (with SuiteScript 2.0). Before installing this SuiteApp, make sure that the following features are enabled in your NetSuite account (if you do not see all of these features on the Enable Features page, contact your NetSuite account manager):

- Custom Records
- Server SuiteScript

Installing the Health and Safety SuiteApp

Install the Health and Safety SuiteApp:

- Bundle Name: Health and Safety
- Bundle ID: 109485

This is a managed bundle and is automatically updated whenever there are updates. These issue fixes and enhancements are available after the SuiteApp is updated in your account.

For more information about installing SuiteApps, see Installing a Bundle in the NetSuite Help Center.

Enabling the Workplace Incident Forms

The Healthy and Safety SuiteApp comes with three workplace incident reporting forms:
Setting Up the Health and Safety SuiteApp

- Accident Record: For Reporting of Injuries, Diseases and Dangerous Occurrences Regulations (RIDDOR) compliance. Use this form for workplaces in the United Kingdom.
- OSHA 301: For Occupational Safety and Health Administration (OSHA) compliance. Use this form for workplaces in the United States.
- General: For all other jurisdictions.

You can choose to enable one or more of these forms.

**To enable workplace incident forms:**

1. Go to Setup > Health and Safety > Preferences.
2. On the Health and Safety Preferences page, click **Edit**.
3. Click the form you want to enable. To select more than one form, hold down the CTRL button and click the forms.
4. Click **Save**.

Setting the Default Folder for Attachments

With the Health and Safety SuiteApp, you can attach files with supporting information when you complete workplace incident forms. You can select the default folder where these attachments are saved.

**To set the default folder for attachments:**

1. Go to Setup > Health and Safety > Preferences.
2. On the Health and Safety Preferences page, click **Edit**.
3. From the Default Folder dropdown list, select the folder where you want to save the attachments.
4. Click **Save**.

Configuring Your Company Settings for Incident Tracking

Before you can use the Health and Safety SuiteApp in NetSuite, you must make sure that your industry information is included in your company settings.

If you have a NetSuite OneWorld account with multiple subsidiaries, the industry information that you enter on the Company Information page are the values that NetSuite uses for your top-level or root subsidiary.

If your company has subsidiaries, this information must be accurate for each subsidiary. When you first configure your industry information in your subsidiaries, the company-level industry information appears in the subsidiary information by default, but you can customize this information.

**Adding Industry Information for your Company**

**To add industry information for your company:**

1. Go to Setup > Company > Company Information.
2. In the **Industry Description** field, enter a description of your industry. This can be any text, but should be as informative as possible for incident report logging compliance.
3. Select a type from the **Industry Classification Type** dropdown list: SIC – Standard Industrial Classification or NAICS – North American Industry Classification System. Based upon your industry standards, you should know which type your company should use.
4. Enter the appropriate number in the **Industry Classification Number** field. Based upon your industry standards, you should know which classification number your company should use.

5. Click **Save**.

**Adding Industry Information for your Subsidiaries**

**To add industry information for your subsidiaries (OneWorld only):**

1. Go to Setup > Company > Subsidiaries.
2. Click **Edit** beside the subsidiary for which you want to change industry information. If you have already set these fields in your company settings, these fields are filled with those values by default. You can keep those values or change them as needed.
3. If you want to change this information, in the **Industry Description** field, enter a description of your industry. This can be any text, but should be as informative as possible for incident report logging compliance.
4. Select a type from the **Industry Classification Type** dropdown list: SIC – Standard Industrial Classification or NAICS – North American Industry Classification System. Based upon your industry standards, you should know which type your company should use.
5. Enter the appropriate number in the **Industry Classification Number** field. Based upon your industry standards, you should know which classification number your company should use.
6. Click **Save**.
7. Add industry information for any other subsidiaries.

**Working with Workplace Incidents**

**To view the list of incidents:**

1. Using the Classic Center, go to Lists > Workplace Incidents > Workplace Incident List. The Workplace Incident List page shows all of the incidents that your company has logged.
   
   If you are using the Accounting Center, go to Payroll and HR > Lists > Workplace Incidents > Workplace Incident List.
2. To see all inactive incident records, check the **Show Inactives** box.
3. To view an individual incident record, click **View** beside it.

**Deleting a Workplace Incident**

As an account administrator, you can delete an incident record, but in most cases, we recommend you make the record inactive instead. Only account administrators can delete an incident.

Only delete an incident record if you are absolutely certain that it is not required. For example, if you created an incident record more than once for the same incident or decided that an incident does not meet regulatory reporting requirements, you might delete the incident record.

**To delete an incident:**

1. Go to Lists > Employees > Workplace Incidents.
2. Click **Edit** beside the incident you want to delete.
3. Select **Delete** from the **Actions** menu.
4. When prompted to confirmation the deletion, click **OK**.
Adding a Workplace Incident

You add a workplace incident when an incident occurs that meets your regulatory requirements. You can add an incident from the Workplace Incident List page or from the employee record of the employee to whom the incident occurred. You can also add a new incident with information copied from an existing incident. You do this while viewing the existing incident.

When you are finished filling out all of the information about the incident, click **Save**. The information entered on this page is not saved until you do so. If you are uncertain about some of the information, you can save an incomplete incident record and edit it later.

Adding an Incident

**To add an incident:**

1. Using the Classic Center, go to Lists > Workplace Incidents (or from the Accounting Center, go to Payroll and HR > Lists > Workplace Incidents) and click **New Workplace Incident**. On the **Select a form type** page, click one of the form types: **Accident Report (RIDDOR)**, **OSHA 301**, or **General**.

   OR

   Go to Lists > Employees > Employees. Click **Edit** or **View** beside the employee involved in the incident. On the **Human Resources** subtab, on the **Workplace Incidents** subtab, click **New Workplace Incident**.

2. To modify the details of an existing incident record, go to Lists > Workplace Incidents > Workplace Incident List and click **Edit** next to the name of the incident.

Adding an Incident from an Existing Incident

**To add an incident from an existing incident:**

1. Using the Classic Center, go to Lists > Workplace Incidents > Workplace Incident List. If you are using the Accounting Center, go to Payroll and HR > Lists > Workplace Incidents > Workplace Incident List.

2. Click **View** beside the incident whose details you want to copy.

3. On the **Actions** menu, click **Make Copy**.

For more information about adding a workplace incident, see the following topics:

- Adding a General Workplace Incident
- OSHA 301 Workplace Incidents
- RIDDOR Workplace Incidents

Adding a General Workplace Incident

Adding a General Workplace Incident

**To add a general workplace incident:**

1. Using the Classic Center, go to Lists > Workplace Incidents (or from the Accounting Center, go to Payroll and HR > Lists > Workplace Incidents) and click **New Workplace Incident**. On the **Select a form type** page, click **General**.
OR

Go to Lists > Employees > Employees. Click Edit or View beside the employee involved in the incident. On the Human Resources subtab, on the Workplace Incidents subtab, click New Workplace Incident.

From the Form Type dropdown list, select General. The Workplace Incident page displays the General form fields.

2. Enter a Case Number. Note that the Workplace Incident ID is a unique number generated by NetSuite when you create the incident.

3. Select a location from the Location dropdown list. This is the list of locations defined in your company information.

4. If you want this incident to be inactive, select the Workplace Incident is Inactive box. This affects how the incident appears on the Incidents list.

5. Enter the date when this form is being completed in the Date of Form Completion field. This defaults to today, but you can change it. For instance, if you are entering information from a paper form that has already been filled out, you might specify the date shown on that form.

6. Enter the date when this incident was first reported in the Date Incident Was First Reported field.

Follow Up Contact Information and Witnesses

To add follow-up contact information and witnesses:

1. Select the employee filling out this form in the Form Completed By dropdown list. This defaults to your name, but you can select another employee. The person's email address and phone number are sourced from the employee record, but you can edit them.

2. Enter the name of the person first reporting the incident in the Incident Was First Reported By field. Enter that person's email address and phone number.

3. Select the person the Incident Was First Reported To from the dropdown list. This person must be an employee. The person's email address and phone number are sourced from the employee record, but you can edit them.

4. Select a contact person from the Contact This Person For More Information On The Incident dropdown list. This person must be an employee. The person's email address and phone number are sourced from the employee record, but you can edit them.

5. Enter Name, Email address, and Phone number for up to two witnesses to the incident.

Incident Details

To add incident details:

1. Enter the Date of Workplace Incident.

2. Enter the Time of Workplace Incident or check the Time Cannot Be Determined box.

3. Enter the Time Employee Began Work on Day Incident Occurred.

4. Select the Severity of the incident from the dropdown list. If you are an administrator, you can change severity options. For more information, see Configuring Incident Severity Options.

5. Select the Impact to Property of the incident from the dropdown list. If you are an administrator, you can change impact to property options. For more information, see Configuring Impact to Property Options.
6. Describe as many aspects of the incident as you can, using the categories shown:
   - Describe in Detail What Happened
   - Describe the Events Leading Up to the Injury
   - Describe the Injury
   - Describe Where the Incident Occurred
   - Address Where Incident Occurred
   - Additional Comments

Employee Information

To add employee information:

1. Select the employee from the Full Name dropdown list. Most of the fields in this section are automatically sourced from the employee record.
2. If values in those sourced fields are not correct, edit them as needed.
3. Enter the employee’s Medical Insurance Number.

Work Impact

To enter work impact:

1. If the employee missed work because of the incident, check the Incident Resulted in Days Away From Work box.
2. If you checked this box, enter the Number of Days away from work and the Date Returned to Work.

Medical Care

To add medical care:

1. Enter the Name of Physician or Other Health Care Professional.
2. If the employee received treatment at a hospital or any location other than the worksite, check the Treatment Was Given Away From Worksite box. Enter information in the Date of First Visit to Facility, Name of Facility, and Facility Address.
3. If the Employee Was Treated in an Emergency Room, check the box.
4. If the Employee Was Hospitalized Overnight as an In-Patient, check the box.

Note: When you are finished filling out all of the information about the incident, click Save.

OSHA 301 Workplace Incidents

OSHA 301 forms are used to report workplace incidents and injuries for companies in the United States. A workplace incident is added any time an incident occurs that meets your regulatory requirements. You can add an incident from the Workplace Incident List page or directly from the employee record.
Adding an OSHA 301 Workplace Incident

To add an OSHA 301 workplace incident:

1. Go to Lists > Workplace Incidents > New.
2. On the Select a form type page, click OSHA 301.
3. Note that the Workplace Incident ID is a unique number generated when the incident is created.
4. Select a location from the Location dropdown list.
5. Enter the date in the Date of Form Completion field. This defaults to today, but you can change it. For instance, if you are entering information from a paper form that has already been filled out, you might specify the date shown on the form.

Primary Information

Adding primary information:

1. Select the name of the employee filling out this incident form from the Completed By dropdown list.
2. Enter the phone number and job title of the employee completing this form in the Phone and Title fields.

Employee Information

To add employee information:

1. Select the employee's name from the Full Name dropdown list. The fields in this section are automatically sourced from the employee record, but you can edit them.
2. To hide the name of the employee in the OSHA 301 log, check the This is a Private Case box. When this box is checked, the words “Privacy Case” will appear in the log instead of the employee’s name. After reading the notification popup, click OK.

Physician of Other Health Care Professional Information

To add physician or other health care professional information:

1. Enter the appropriate name in the Name of Physician or Other Health Care Professional field.
2. If the employee was treated at a facility away from the workplace, check the Treatment was Given Away from Worksite box, and enter the name and address of the facility.
3. If required, check the appropriate box if the employee was treated in an emergency room or if they were hospitalized as an in-patient.

Case Information

To add case information:

1. In the Case Number field, enter any other tracking number that your organization has assigned to this incident.
2. Enter the time the employee started work on the day the incident occurred in the **Time Employee Began Work on Day Incident Occurred** field.

3. Select the **Date of the Injury or Illness**. The current date is selected by default, but you can select a different date.

4. In the **Time of Incident** field, enter the time when the incident occurred. If this is not known, check the **Time Cannot Be Determined** box.

5. Select the type of injury caused by the incident from the **Injury or Illness Type** dropdown list.

6. Select the classification from the **Case Classification** dropdown list.

7. If required, enter the number of days that the employee was away from work in the **Number of Days** field.

   **Note:** If this workplace incident has caused an employee death, read and follow the instructions in the information box that appears.

8. Describe as many aspects of the incident as you can, using the following categories:
   - What was the injury or illness?
   - What happened?
   - What was the employee doing just before the incident occurred?
   - What object or substance directly harmed the employee?
   - Where did the event occur?

**Attachments**

**To add attachments:**

1. If you have any files with supporting information, such as pictures, click the **Attachments** tab.
2. Select a file from the **Attach File** dropdown list. To upload a file to attach, click New.
3. Click Add.

**Notes**

**To add notes:**

1. To add a note to the incident form, click the **Notes** tab.
2. Enter the note information and click Save.

**RIDDOR Workplace Incidents**

You add a workplace incident when an incident occurs to an employee that meets your regulatory requirements. If your workplace is in the United Kingdom, you are governed by the Reporting of Injuries, Diseases and Dangerous Occurrences Regulations (RIDDOR). You can add an incident from the Workplace Incident List page or from the employee record of the employee to whom the incident occurred. You can also add a new incident with information copied from an existing incident. You do this while viewing the existing incident.

When you are finished filling the information about the incident, click Save. This will save all information currently entered. If you are uncertain about some of the information, you can save an incomplete incident record and edit it later.
For information on adding a RIDDOR Workplace Incident, see RIDDOR Workplace Incidents.

**RIDDOR Workplace Incidents**

**Adding a RIDDOR Workplace Incident**

**To add a RIDDOR workplace incident:**

1. Using the Classic Center, go to Lists > Workplace Incidents (or from the Accounting Center, go to Payroll and HR > Lists > Workplace Incidents) and click New Workplace Incident. On the Select a form type page, click Accident Record.

   OR

   Go to Lists > Employees > Employees. Click Edit or View beside the employee involved in the incident. On the Human Resources subtab, on the Workplace Incidents subtab, click New Workplace Incident.

   From the Form Type dropdown list, select Accident Record. The Workplace Incident page displays the form fields for a RIDDOR Accident Report.

2. Enter the Accident Book Number and the Accident Record Report Number. You can find these numbers in the hard-copy Accident Book you would have used to first record the incident. Note that the Workplace Incident ID is a unique number generated by NetSuite when you create the incident.

3. Select a location from the Location dropdown list. This is the list of locations defined in your company information.

4. Enter the date when this form is being completed in the Date of Accident Record Completion field. This defaults to today’s date, but should be set to the date when the incident was recorded in the hard-copy Accident Book.

5. Enter the date when this incident was first reported in the Date When Incident Was First Reported to the Organisation field.

6. If you want this incident to be inactive, select the Workplace Incident is Inactive box. This affects how the incident appears on the Incidents list.

**RIDDOR Reporting**

**To add RIDDOR reporting details:**

1. If the type of incident fits the criteria set by RIDDOR, check the Incident is Reportable Under RIDDOR box.

2. If you checked this box, enter the Person Who Reported the incident and the Date Reported to HSE. Select the Method of Reporting from the dropdown list.

**Incident Details**

**To add incident details:**

1. Enter the date on which the incident occurred in the Date of Incident field. Note that this is not necessarily the date on which you are entering this incident in the Accident Book or NetSuite.

2. Enter the time at which the incident occurred in the Time of Incident field.

3. Select the type of incident from the Incident Type dropdown list. Note that an incident does not necessarily have resulted in an injury to be reportable.
4. Enter the immediate cause in the **Cause of the Incident** field.

5. Enter where in your workplace (such as the physical area, department, or room) the incident occurred in the **Location of the Incident** field.

6. If the incident resulted in an injury, enter information in the **If An Injury Occurred, Describe the Injury** field.

**Work Impact**

**To add work impact:**

1. If the affected person missed days of work as a result of the incident, check the **Incident Resulted in Days Away from Work** box. Note: if you selected Death as the Type of Incident, this setting is not available.

2. If you checked this box, enter the **Number of Days** the person missed from work and the **Date Returned to Work**.

**Attachments**

**To add attachments:**

1. If you have any files with supporting information, such as pictures, click the **Attachments** tab.

2. Select a file from the **Attach File** dropdown list. To upload a file to attach, click **New**.

3. Click **Add**.

**Affected Person Information**

**To add affected person information:**

1. To give your organization's safety representative access to the affected person's personal information, check the **Affected Person Has Given Consent to Disclose Their Personal Information to Safety Representative** box. Only check this box if the affected person has given consent.

2. Enter the name of the affected person in one of the following ways:
   - If the affected person is an employee, select their name from the **Full Name** dropdown list. The person's **Occupation**, **Email**, **Phone**, **Address**, and **Postcode** are sourced from the employee record.
   - If the person is not an employee, check the **Affected Person is not an Employee** box. Enter their name in the **Full Name** field and complete the rest of the fields in this section.

**Follow-Up Contact Information**

**To add follow-up contact information:**

1. In the **Accident Report Completed By** field, enter the name of the person completing this form.

2. Enter the **Occupation**, **Address**, **Email**, **Phone**, and **Postcode** for this person.

3. Select a contact person from the **Contact This Person For More Information on the Incident** dropdown list. This person must be an employee of your organization.

4. The **Email** and **Phone** fields for this contact person are sourced from the employee record.
Medical Care

To add medical care information:

1. If the affected person had to be treated in a hospital, check the Affected Person Was Treated in Hospital box.
2. If you checked this box, enter:
   - Name of Physician or Other Health Care Professional
   - Date of First Visit to Facility
   - Name of Facility
   - Facility Address

 Witnesses

To add witnesses:

1. Enter the Name of up to two witnesses to the incident.
2. Enter the Email and Phone number of the witness(es).

Notes

To add notes:

1. To add a note to the incident form, click the Notes tab.
2. Click New Note. Enter the note information and click Save.

Saving the Incident Form

When you are satisfied with the information you have provided in the form, click Save.

Generating OSHA Workplace Incident Logs and Summaries

If your workplace is located in the United States, you must periodically generate logs and summaries for Occupational Safety and Health Administration (OSHA) compliance. An OSHA 300 log is a list of all of your incidents that match your filter criteria, while an OSHA 300 summary is a compilation of statistics and information about your incident history. If you are located in the United Kingdom or another non-U.S. jurisdiction, these reports are not available.

Generating an OSHA 300 Log

To generate an OSHA 300 log:

1. Go to Reports > Workplace Incidents > OSHA 300 Log. The OSHA’s Form 300 Log of Work-Related Injuries and Illnesses page appears.
2. From the Location dropdown list, select a location.
3. From the Generate Report For dropdown list, select the year to include in the report.
4. From the Generate As dropdown list, select the output format you want to generate: PDF or XML Spreadsheet.
5. Enter the information you want to appear on the log:
   ▪ Establishment Name
   ▪ City
   ▪ State
6. Click Generate.

NetSuite generates the log and saves it to the specified file format.

Generating an OSHA 300A Summary

To generate an OSHA 300A summary:
1. Go to Reports > Workplace Incidents > OSHA 300A Summary. The OSHA's Form 300A Summary of Work-Related Injuries and Illnesses page appears.
2. From the Location dropdown list, select a location. The establishment name, address, and industry fields are populated from your company and subsidiary information, but you can edit these fields.
3. From the Generate Report For dropdown list, select the year to include in the report.
4. From the Generate As dropdown list, select the output format you want to generate: PDF or XML Spreadsheet.
5. In the Annual Average Number of Employees field, enter the annual average number of employees at your company, for the calendar year you have selected, rounded to the nearest whole number. To calculate this value, add the total number of employees your establishment paid in all pay periods during the relevant year (full-time, part-time, temporary, seasonal, salaried and hourly) and divide that by the number of pay periods during that year. For more information about calculating this, refer to your OSHA documentation.
6. In the Annual Hours Worked by All Employees field, enter the annual sum of hours worked by all employees at your company. This should include all full-time, part-time, temporary, seasonal salaried and hourly employees for the specified calendar year, rounded to the nearest whole number. For more information about calculating this, refer to your OSHA documentation.
7. Click Generate.
Affordable Care Act (ACA) Reporting

If you are an Applicable Large Employer (ALE) in the United States, you must comply with Affordable Care Act (ACA) reporting requirements. The ACA Reporting SuiteApp enables you to set up and track the health coverage offered to full-time employees, and electronically file the required health care coverage forms (1094–C and 1095–C) to the Internal Revenue Service (IRS).

ACA reporting is required for ALEs, which are employers that have 50 or more full-time or full-time-equivalent employees. Employees are considered full-time if they work on average at least 30 hours per week, or 130 hours per month.

With the ACA Reporting SuiteApp, you record and track employee health care information throughout the year as employees are hired, pass probation periods, and are offered coverage. Then, at year end, you can review and adjust the information as needed, before printing and distributing forms to employees and filing forms electronically with the IRS.

For more information about ACA reporting requirements, go to https://www.irs.gov/instructions/i109495c.

⚠️ Important: For the 2019 reporting year, the deadline for filing is January 17, 2020.

ACA Reporting SuiteApp Features

The ACA Reporting SuiteApp enables you to do the following:

- View average hours of employment by employees for the specified measurement periods to assist in determining full-time equivalent status.
- Specify health coverage plans offered to groups of full-time employees at once, or to individuals as they become eligible.
- Review the information that will be submitted to the IRS on the 1094–C and 1095–C forms, with individual previews for each form, and a detailed report.
- Transmit the ACA information to process the electronic IRS filing, and print and distribute the forms to employees.

The following topics provide details about the ACA filing process:

- Identifying Part-Time Employees
- Creating an ACA Offer of Coverage Plan
- Assigning an ACA Offer of Coverage Plan to Multiple Employees
- Setting Up Employer Information
- ACA Filing
- Updating Employee Records for ACA
- Assigning an ACA Offer of Coverage Plan to an Employee
- Adding Covered Individuals to an Employee
- Adding Safe Harbor Codes to an Employee
- Excluding an Employee from ACA Reporting
- State-Specific ACA Reporting for DC and NJ
- Viewing ACA Filing History
Setting Up the ACA Reporting SuiteApp

This section includes the requirements and procedures for installing the ACA Reporting SuiteApp.

Prerequisites for Installing the ACA Reporting SuiteApp

**Important:** To use the ACA Reporting SuiteApp, SuitePeople U.S. Payroll must be actively used during the filing year.

Before installing the ACA Reporting SuiteApp, the following features must be enabled:

- Payroll — Setup > Company > Setup Tasks > Enable Features > Employees
- Custom Records — Setup > Company > Setup Tasks > Enable Features > SuiteCloud
- Client SuiteScript — Setup > Company > Setup Tasks > Enable Features > SuiteCloud
- Server SuiteScript — Setup > Company > Setup Tasks > Enable Features > SuiteCloud

Applicable Large Employer (ALE) Member Information

To use the ACA Reporting SuiteApp, you must enter the legal name as it should appear on tax forms and an employer identification number (EIN) for at least one subsidiary. For more information, see the help topic Creating Subsidiary Records. Subsidiaries should also have at least one payroll earning item type. For more information, see the help topic Creating Payroll Items.

Installing the ACA Reporting SuiteApp

Only users with the Administrator role can install the ACA Reporting SuiteApp. This is a managed bundle and is automatically updated whenever there are updates.

After the ACA Reporting SuiteApp is installed, the Affordable Care Act (ACA) subtab is added to the employee record and access to the ACA landing page is available. For more information, see Updating Employee Records for ACA and Viewing the ACA Landing Page.

The ACA Reporting SuiteApp can be disabled at any time. After it is disabled, billing stops and information for the current year is deleted. All filing data for prior years is retained for at least 7 years.

To install the ACA Reporting SuiteApp, go to Customization > SuiteBundler > Search & Install Bundles, and then click Advanced.

Use the following information to search for the SuiteApp:

- **Bundle Name** — Affordable Care Act (ACA) Reporting
- **Bundle ID** — 147355

For more information about installing SuiteApps, see the help topic Installing a Bundle.

**Note:** If the Install button is not available or if you cannot find this SuiteApp, this SuiteApp might not have been shared with your account. To get access to the SuiteApp, contact Customer Support.

After the ACA Reporting SuiteApp is installed

Before using the ACA Reporting SuiteApp, the following must be completed:
Setting Up the ACA Reporting SuiteApp

- Specify the day of the month to use for determining the monthly employee count that will appear on the 1094-C form. For details, see Setting Up Employer Information.
- Provide a default recipient for ACA-related email. For details, see Setting Up a Default Recipient for ACA Notifications.
- Set up roles and permissions. For details, see Roles and Permissions.

Roles and Permissions

Each role that requires access to the ACA Reporting SuiteApp must be specified on the ACA Grant Permissions page. To assign roles, go to Setup > Customization > ACA Grant Permission (Administrator).

Roles assigned to this permission can perform the following tasks:

- Assigning an ACA Offer of Coverage Plan to an Employee
- Adding Covered Individuals to an Employee
- Adding Safe Harbor Codes to an Employee
- Excluding an Employee from ACA Reporting
- Identifying Part-Time Employees
- Creating an ACA Offer of Coverage Plan
- Assigning an ACA Offer of Coverage Plan to Multiple Employees
- Setting Up Employer Information
- ACA Filing
- Viewing ACA Filing History

Setting Up a Default Recipient for ACA Notifications

You should set up a default recipient for ACA notifications. The default recipient receives an email message whenever changes applied to multiple employees for ACA reporting purposes have completed. This includes when an ACA offer of coverage plan has been assigned to multiple employees, and when multiple employees have been identified as part-time.

**To set up a default recipient for ACA notifications:**

1. Go to Setup > Company > Preferences > General Preferences (Administrator).
2. Click the Custom Preferences subtab.
3. From the Email Notification Recipient list, select the default recipient. The recipient must be an employee.
4. Click Save.

Viewing the ACA Landing Page

To access the ACA landing page, go to Transactions > Employees > Affordable Care Act (Administrator) or Payroll and HR > Payroll > Affordable Care Act (Payroll Manager). Here you will find the steps you need to complete for pre-filing and filing.

For more information, see the following help topics:
ACA Pre-Filing

Before filing, there are a number of pre-filing tasks to perform. Pre-filing involves identifying part-time employees, setting up and assigning an offer of coverage to employees, and entering employer ACA information. The information entered during pre-filing is used to file the 1094-C and 1095-C forms that are required for ACA reporting at year-end.

The ACA landing page guides you through each of the required pre-filing steps. To make filing at year-end manageable, this information can be easily tracked and updated on a monthly basis.

For information about the 1094-C and 1095-C forms, go to https://www.irs.gov/instructions/i109495c. For information on filing, see ACA Filing.

ACA pre-filing includes:

- Identifying Part-Time Employees
- Creating an ACA Offer of Coverage Plan
- Assigning an ACA Offer of Coverage Plan to Multiple Employees
- Setting Up Employer Information

Identifying Part-Time Employees

The first step for ACA pre-filing is identifying employees that do not meet the minimum number of hours to be considered full-time for a specified period.

To identify part-time employees:

1. Go to Payroll and HR > Payroll > Affordable Care Act (Payroll Manager).
2. If applicable, select the specific employer from the View list.
3. Click Set Up Hours.
4. Select the payroll items that are considered eligible hours of service, and that will be used for determining an employee’s full-time status, as defined under Section 4980H. ACA-eligible payroll items include:
   - Earning: Wage
   - Earning: Salary
   - Earning: Vacation
   - Earning: Sick

   The payroll items are automatically selected, but the list can be modified, if necessary. For more information about payroll items, see the help topic Payroll Items Setup. For more information about eligible hours of service, go to https://www.irs.gov/instructions/i109495c.
5. Click Done to save the changes and return to the ACA landing page.
6. To identify employees that do not meet the minimum number of hours to be considered full-time, click Set Part-Time.
7. Select one or more employees, and click Set to Part-Time.
8. Specify the date range during which the employee will be considered part-time.

Employee Management
For example, an employee that had an average of less than 30 hours per week, from January 1 to December 31, 2018, may be set to part-time from January 1 to December 31, 2019 for the purposes of ACA. For more details, see https://www.irs.gov/instructions/i109495c.

9. Click OK.

10. Verify that the date range that the specified employees will be set to part-time status is correct in the 2019 Part-Time Status column.

11. Click OK.

The contact set up as the default recipient for ACA notifications receives an email message after the changes have been applied. For more information, see Setting Up a Default Recipient for ACA Notifications.

To make changes, click Edit Hours from the ACA landing page.

Creating an ACA Offer of Coverage Plan

An offer of coverage plan contains information about the health coverage for employees. Assign them to employees from the employee record, or to multiple employees from the pre-filing section of the ACA landing page. For more information, see Assigning an ACA Offer of Coverage Plan to an Employee and Assigning an ACA Offer of Coverage Plan to Multiple Employees.

To create an ACA offer of coverage plan:

1. Go to Payroll and HR > Payroll > Affordable Care Act (Payroll Manager).
2. If you have a NetSuite OneWorld account, select the subsidiary from the View list.
3. Click Add Coverage.
4. In the Name field, enter the name of the plan.
5. If a carrier provides coverage, enter the name in the Carrier field.
6. If the plan is self-insured, check the Self-Insured box.

Note: Enter the covered individuals for a self-insured plan. For instructions, see Adding Covered Individuals to an Employee.

7. Select the offer of coverage code from the Code list. Codes specify the type of coverage available to the employee, their spouse, and dependents. For more information about coverage codes, visit https://www.irs.gov/instructions/i109495c.

The list of coverage codes includes:

- 1A — Qualifying Offer: Minimum essential coverage providing minimum value offered to full-time employee with employee contribution for self-only coverage equal to or less than 9.5% mainland single federal poverty line and at least minimum essential coverage offered to spouse and dependent(s).
- 1B — Minimum essential coverage providing minimum value offered to employee only.
- 1C — Minimum essential coverage providing minimum value offered to employee and at least minimum essential coverage offered to dependent(s) (not spouse).
- 1D — Minimum essential coverage providing minimum value offered to employee and at least minimum essential coverage offered to spouse [not dependent(s)].
- 1E — Minimum essential coverage providing minimum value offered to employee and at least minimum essential coverage offered to dependent(s) and spouse.
ACA Pre-Filing

- **1F** — Minimum essential coverage NOT providing minimum value offered to employee; employee and spouse or dependent(s); or employee, spouse and dependents.

- **1G** — Offer of coverage to employee who was not a full-time employee for any month of the calendar year (which may include one or more months in which the individual was not an employee) and who enrolled in self-insured coverage for one or more months of the calendar year.

- **1H** — No offer of coverage (employee not offered any health coverage or employee offered coverage that is not minimum essential coverage, which may include one or more months in which the individual was not an employee).

- **1J** — Minimum essential coverage providing minimum value offered to employee and at least minimum essential coverage conditionally offered to spouse; minimum essential coverage not offered to dependent(s).

- **1K** — Minimum essential coverage providing minimum value offered to employee; at least minimum essential coverage offered to dependents; and at least minimum essential coverage conditionally offered to spouse.

8. If 1B, 1C, 1D, 1E, 1J, or 1K is selected, enter the employee's lowest monthly premium for self-only minimum essential coverage in the **Lowest Cost of Employee Coverage** field, a **Start Month**, and a **Start Year**.

9. Click Add.

10. If the premium changed throughout the reporting year, add additional lines. Dates cannot overlap.

11. Click Save.

**Making an ACA Offer of Coverage Plan Inactive**

Make plans inactive to prevent them from appearing in lists. A plan is still assigned to an employee when it is inactive. For instructions, see Making an ACA Offer of Coverage Plan Inactive

**To make an ACA offer of coverage inactive:**

1. Go to Payroll and HR > Payroll > Affordable Care Act (Payroll Manager).
2. Click the **Coverages** link beside **Set Up & Assign Coverage**.
3. Click **Edit** next to the plan to inactivate.
4. Check the **Offer of Coverage Inactive** box.
5. Click **Save**.

**Deleting an ACA Offer of Coverage Plan**

Delete a plan when it is unassigned and not needed.

**To delete an ACA offer of coverage plan:**

1. Go to Payroll and HR > Payroll > Affordable Care Act (Payroll Manager).
2. Click the **Coverages** link beside **Set Up & Assign Coverage**.
3. Click **Edit** next to the plan to delete.
4. Select **Delete** from the **Actions** menu.
5. Click **OK**.
Assigning an ACA Offer of Coverage Plan to Multiple Employees

After an offer of coverage plan has been set up, it can be assigned to a group of employees from the ACA landing page. The information entered here is used to generate the 1095–C forms to be filed for each employee. For more information, go to https://www.irs.gov/instructions/i109495c.

To assign an ACA offer of coverage plan to multiple employees:

1. Go to Payroll and HR > Payroll > Affordable Care Act (Payroll Manager).
2. If you have a NetSuite OneWorld account, select the specific subsidiary from the View list.
3. Click Assign Coverage.
4. By default, employees who were not full-time or not employed for the entire reporting year are excluded. The list of employees that are displayed in the list can be controlled using the filters.
5. From the list, select the employees to assign this coverage to.
6. Click Assign Coverage.
7. Select the offer of coverage plan, from the Plan list.
8. Enter a start date when the coverage plan is offered to the selected employees.
9. To record that coverage was offered after the employee’s limited non-assessment period, instead of the specified start date, check the Override start date with employees eligibility date box. This will only be implemented when the eligibility date is later than the specified start date.
10. Check the Auto-assign Safe Harbor Code 2C box if each employee that was offered health coverage was enrolled in the coverage offered.
11. Click Assign.
12. Make sure the information displayed in the Plan column, and the Coverage column are correct.
13. If you have multiple plans that are assigned to different groups of employees, repeat the above steps.
14. Click Save.

The contact set up as the default recipient for ACA notifications receives an email message after the changes have been applied. For more information, see Setting Up a Default Recipient for ACA Notifications.

Setting Up Employer Information

You use the Employer Information page to enter information about the ALE member, which is used to file the 1094–C form at year end. ACA employer setup includes entering information for all ALE members of an aggregated group.

For example, company A is the parent of company B and company C. Combined, these companies have 100 full-time employees. Each separate employer in an ALE aggregated group is subject to the employer shared responsibility provisions, and each is subject to the associated information reporting requirements. Each separate employer must file its own 1094–C form, using its own Employer Identification Number (EIN).

To set up employer information:

1. Go to Payroll and HR > Payroll > Affordable Care Act (Payroll Manager).
2. If you have a NetSuite OneWorld account, select the specific subsidiary from the View list.

3. Click Set Up Employer.

4. NetSuite automatically inserts information from the company or subsidiary record. To make changes, you can edit the information here.

5. Enter the name and contact number of the person who is responsible for answering questions from the IRS regarding the filing.

6. If there is a parent company, each separate employer is subject to the employer shared responsibility provisions, and must be entered under the Other ALE Members subtab. Select the months that the company was a member of the same ALE group, enter the company names, and unique EIN numbers of each affiliated ALE member.

7. Click Add.

8. If your employer is eligible for transition relief, select the certifications that apply from the Certifications of Eligibility subtab:
   - Qualifying Offer Method — If a qualifying offer was offered to one or more full-time employees, for every month during the year that the employees were considered full-time.
   - 98% Offer Method — If affordable health coverage, providing minimum value to at least 98% of your employees, and minimum essential coverage to those employees’ dependents was offered.

9. On the Preferences subtab, from the Employee Count Based On list, select the day of the month to use for determining the monthly employee count on the 1094-C form.

For example, when you select First Day of Each Month, and an employee leaves the company in the middle of the month, they are still included in the monthly count.

10. In the Limited Non-Assessment Period Override field, enter the number of days (0-90) for which the Limited Non-Assessment Period can be overridden. This number is added to the employee's hire date or date of exclusion from ACA to determine the Limited Non-Assessment Period End Date, unless you have chosen to set this date manually.

    If you want to apply this new override value to all existing employees, then click OK in the confirmation popup that appears. To only apply this change to future employees, click Cancel.

11. Click Save.

### ACA Filing

When the reporting year is done (for 2018, January 1, 2019; for 2019, January 1, 2020), the required health coverage forms (1094-C and 1095-C) can be electronically filed to the IRS. When you file your company's ACA files, the data is examined by Ceridian, your payroll partner. If it passes validation, Ceridian forwards your files to the IRS.

⚠️ **Important:** For the 2019 reporting year, the deadline for filing is January 17, 2020.

### Filing for ACA

**To file for ACA:**

1. Go to Payroll and HR > Payroll > Affordable Care Act (Payroll Manager).
2. Click Generate from the Ready to File section of the ACA landing page.
To preview the 1094–C and 1095–C forms, click **Preview**, or click the **View Audit Log** link to open a file that can be viewed in Microsoft Excel.

When you are ready to transmit, click **File**. The File section shows the filings you have sent, with a filing number and date and time.

**Checking for ACA Filing Errors and Refiling**

**To check for ACA filing errors and refile:**

1. Go to Payroll and HR > Payroll > Affordable Care Act (Payroll Manager).
2. On the ACA landing page, the Ready to File section shows the status of your filings, along with the filing number and date and time of your transmission. If your filing did not pass the Ceridian validation, an Errors button appears beside the filing. Click the **Errors** button to view the errors returned by Ceridian. A popup window appears showing the errors that occurred.
3. Correct the errors as indicated in the popup window. For assistance resolving these errors, contact NetSuite Customer Support.
4. For any employees who had errors in the filing, edit the employee record and clear the errors.
5. When you have corrected the errors, return to the ACA landing page and click **Re-Generate**.
6. Click **Preview** and **View Audit Log** to confirm that your data is ready to be sent.
7. Click **Refile**.

**Removing Ineligible Employees from ACA Reporting**

After you have already transmitted your ACA filing to the IRS, you can remove employees from ACA reporting. For example, you would remove an employee from reporting if they become ineligible or if you added them in error. To do this, you void their 1095–C form on their employee record and then refile. If you have not filed your ACA information with the IRS and you want to remove an employee from reporting before filing, you can exclude them. For more information, see **Excluding an Employee from ACA Reporting**.

**To remove ineligible employees from ACA reporting:**

1. Go to Payroll and HR > Lists > Employees (Payroll Manager).
2. On the Employees list, click **Edit** next to the employee you want to remove from reporting.
3. Click the **Affordable Care Act (ACA)** subtab.
4. Check the **Void 1095–C Form** box.
5. Click **Save**.
6. Refile your ACA data. For more information, see **Checking for ACA Filing Errors and Refiling**.

**Tracking Minimum Essential Coverage**

Before making your ACA filing, you can see whether or not you are complying with ACA rules regarding minimum essential coverage. You can view the Minimum Essential Coverage Offer Indicator in two ways:

- From the ACA landing page, click Preview. The Preview 1094C page appears, showing the Minimum Essential Coverage Offer Indicator for the whole filing year and for each month. If you are compliant for a given period, then Yes is checked for that period.
From the ACA landing page, click View Audit Log. Open the XML file that is downloaded in Microsoft Excel. Click the 1095-C Part III tab. Under Part III: ALE Member Information — Monthly, a Minimum Essential Coverage Indicator row appears for the entire year and for each month with a Yes or No in the Data column.

The ACA SuiteApp determines the minimum essential coverage offer indicator value in the following way:

- The value is Yes if at least 95 percent or all but five of your employees are assigned an offer of coverage. For example, if you have 50 employees and 48 have an offer of coverage, you are compliant because you have 96 percent of employees covered. As another example, if you have 50 employees and five of them do not have an offer of coverage, you are compliant even though you only have 90 percent covered.
- The value is No if less than 95 percent of your employees are covered and fewer than five of your employees are covered.


**Updating Employee Records for ACA**

When the ACA Reporting SuiteApp is installed, the Affordable Care Act (ACA) subtab appears on the employee record. From this subtab, you can assign an offer of coverage plan, add any covered individuals who are included in the plan, and apply a safe harbor code.

These topics detail the ACA setup tasks you can complete on the employee record:

- Assigning an ACA Offer of Coverage Plan to an Employee
- Adding Covered Individuals to an Employee
- Adding Safe Harbor Codes to an Employee
- Excluding an Employee from ACA Reporting

**Assigning an ACA Offer of Coverage Plan to an Employee**

Before an ACA offer of coverage plan can be assigned, one must be created first. For details on how to create a plan, see Creating an ACA Offer of Coverage Plan.

To assign a plan to multiple employees at one time, go to the ACA landing page. For more information, see Assigning an ACA Offer of Coverage Plan to Multiple Employees.

The Limited Non-Assessment Period End Date is calculated as the end of the employee’s third full calendar month of full-time employment, based on the employee’s hire date, or the end of their exclusion from ACA. It is used to report when the employee is considered full-time for the purpose of ACA reporting. We recommend that you use the calculated Limited Non-Assessment Period End Date, but you can override it. For example, if your employees are eligible for benefits after 30 days of employment, you could choose to set this date manually to 30 days after the hire date for each employee.

**To assign an ACA Offer of Coverage Plan to an employee:**

1. Go to Payroll and HR > Lists > Employees (Payroll Manager).
2. On the Employees list, click Edit next to the employee who was offered coverage.
3. Click the Affordable Care Act (ACA) subtab.
Assigning an ACA Offer of Coverage Plan to an Employee

4. Click the Offer of Coverage subtab.
5. From the Plan list, select the offer of coverage plan. If there is no offer of coverage plan shown, check to make sure one was created. For more information, see Creating an ACA Offer of Coverage Plan.
6. Enter the Start Month and Start Year for this offer of coverage plan. Only enter an End Month and End Year when the employee has left the company, or if they changed to another offer of coverage plan.
7. Click Add.
8. Add additional lines if the employee was offered more than one coverage plan during the reporting year.
9. To set a different Limited Non-Assessment Period End Date, check the Override Limited Non-Assessment Date box and enter a different date.
10. Click Save.

Adding Covered Individuals to an Employee

On the Covered Individuals subtab, in the Affordable Care Act (ACA) subtab on the employee record, you add the employee after you have assigned an offer of coverage plan to the employee. The employee's name and date of birth (if included on the employee record) are sourced from the employee record automatically, since this information is an IRS requirement. You also add the employee's spouse, dependents, or both, who are covered under the offer of coverage plan. Covered individuals are only required when the offer of coverage plan is self-insured. When a coverage plan is self-insured, it indicates that the employer assumes the financial risk of providing health care benefits to its employees. The individuals entered on the Covered Individuals subtab should meet the criteria of the coverage that is set up on the plan.

For example, if the coverage plan code is 1C, be sure to only add dependents to the list, not the employee's spouse. For more information on the types of coverage, see Creating an ACA Offer of Coverage Plan.

**Note:** On the Covered Individuals subtab, you must list the employee first and then list the spouse, dependents, or both as applicable.

**To add covered individuals to an employee:**

1. Go to Payroll and HR > Lists > Employees (Payroll Manager).
2. On the Employees list, click Edit next to the employee to add covered individuals to.
3. Click the Affordable Care Act (ACA) subtab.
4. Click the Covered Individuals subtab.
5. If you have not added the employee to the covered individuals list, then click Add Employee. The employee's name and date of birth (if included on the employee record) are populated. Confirm or enter the employee's Date of Birth and the Start Month and Start Year for the coverage. Optionally, enter the End Month and End Year. Click Add.
6. For each of the employee's spouse, dependents, or both, enter the First Name and Last Name, Date of Birth, and the Start Month and Start Year for the coverage. Optionally, enter the End Month and End Year. Click Add.
7. Add additional lines for each individual that is covered under the plan.
8. Click Save.
Adding Safe Harbor Codes to an Employee

Safe harbor codes apply when an employee qualifies for an exemption from the assessable payment. Manual entry is not required for employees that were not full-time, terminated, excluded from ACA, or in a limited non-assessment period. Instead, the applicable safe harbor code is automatically added when generating the ACA filing. Manual entry is required when safe harbor codes 2E, 2F, 2G, or 2H are applicable or if an existing code must be overridden.

For more information about safe harbor codes, see https://www.irs.gov/instructions/i109495c and Automatically Applied Safe Harbor Codes.

Automatically Applied Safe Harbor Codes

This includes:

- **2A** — Automatically added for any months that an employee was not employed on any day of the calendar month. This includes employees who were not yet hired, excluded from ACA, or terminated before the first day of the reporting month.
- **2B** — Automatically added for any months that an employee was not considered full-time, including employees who were excluded from ACA or terminated during the reporting month.
- **2C** — Can be applied automatically when assigning an ACA offer of coverage plan to multiple employees. For details, see Assigning an ACA Offer of Coverage Plan to Multiple Employees.
- **2D** — Automatically added for any months that an employee was in a limited non-assessment period.

To add safe harbor codes to an employee:

1. Go to Payroll and HR > Lists > Employees (Payroll Manager).
2. On the Employees list, click **Edit** next to the employee you want to add a safe harbor code to.
3. Click the **Affordable Care Act (ACA)** subtab.
4. Click the **Safe Harbor Codes** subtab.
5. From the **Code** list, select the safe harbor code.

The safe harbor codes include:

- **2A**. Employee not employed during the month — This safe harbor code is automatically applied during filing.
- **2B**. Employee not full–time — This safe harbor code is automatically applied during filing.
- **2C**. Employee enrolled in coverage offered — Use this code for any month the employee enrolled for each day of the month in health coverage offered by the ALE member, regardless of if any other code in Code Series 2 might also apply.

Do not use this code:

- For any month in which the multi-employer interim rule relief applies. Instead, enter code 2E.
- If code 1G is entered in the **Code** list on the ACA offer of coverage plan. For more information, see Creating an ACA Offer of Coverage Plan.
- For any month that an employee is enrolled in COBRA continuation coverage or other post-employment coverage. Instead, enter code 2A.
- For any month that the employee enrolled in coverage that was not minimum essential coverage.
- **2D**. Employee in a Section 4980H (b) limited non-assessment period — This safe harbor code is automatically applied during filing.
■ 2E. Multi-employer interim rule relief — Use this code for any month for which the multi-employer arrangement interim guidance applies for that employee, regardless of whether any other code in Code Series 2 (including code 2C) might also apply.

■ 2F. Section 4980H affordability from W-2 safe harbor — Use this code if the ALE member used Section 4980H Form W-2 safe harbor to determine affordability for purposes of Section 4980H(b) for this employee for the year. If an ALE member uses this safe harbor for an employee, it must be used for each month of the calendar year for which the employee is offered health coverage.

■ 2G. Section 4980H affordability federal poverty line safe harbor — Use this code if the ALE member used Section 4980H federal poverty line safe harbor to determine affordability for purposes of section 4980H(b) for this employee for any month(s).

■ 2H. Section 4980H affordability rate of pay safe harbor — Use this code if the ALE member used Section 4980H rate of pay safe harbor to determine affordability for purposes of Section 4980H(b) for this employee for any month(s).

6. Enter the Start Month and Start Year of the period when the exemption applied for the employee. Enter the End Month and End Year if this code applied for a short period of time. Note that this date cannot be before the employee's hire date.

7. Click Add.

8. Click Save.

Excluding an Employee from ACA Reporting

Unless otherwise specified, all employees are included in ACA reporting. They can be excluded from the Exclude from ACA subtab on the employee record for all or part of the reporting year, if they were not considered full-time, as defined under Section 4980H, or are not considered an employee for the purpose of ACA reporting. For example, a contractor, a sole proprietor, or a partner may not be an employee for the purposes of ACA reporting.

To exclude an employee from ACA reporting:

1. Go to Payroll and HR > Lists > Employees (Payroll Manager).
2. On the Employees list, click Edit next to the employee to exclude from ACA reporting.
3. Click the Affordable Care Act (ACA) subtab.
4. Click the Exclude from ACA subtab.
5. From the Reason list, select why the employee is excluded from ACA reporting.
6. Enter the Start Month and Start Year for the exclusion.
7. Optionally, enter the End Month and End Year for the exclusion.
8. Click Add.
9. Click Save.

State-Specific ACA Reporting for DC and NJ

If you have employees who reside in the District of Columbia (DC) or the state of New Jersey (NJ), then you have additional state-specific reporting requirements under the Affordable Care Act. You must report any employees who resided in either or both of these two jurisdictions during a particular reporting year. You must also report the specific months when those employees resided in either or both jurisdictions.
Before filing your ACA reporting with state-specific information, ensure that you have done the following:

- Define your workplaces for all jurisdictions where you have a tax ID and maintain paid employees. For more information, go to Entering Workplace Records for Payroll.
- Confirm your tax information for each jurisdiction, specifically the State ID for each of the two mandated states. For more information, go to Setting Preferences for Jurisdictions.

**Confirming your State ID**

When filing state-specific reporting, the relevant State ID is required. By default, the State ID reported will be defined in the jurisdiction settings.

**To confirm your State IDs:**

1. Go to Setup > Payroll > Setup Tasks > Set Up Payroll.
2. Click the **Jurisdictions** subtab.
3. Click the subtab for the two mandated states:
   a. For the District of Columbia, the State ID is sourced from the OTR Account Number.
   b. For New Jersey, the State ID is sourced from the Taxpayer Identification Number.

   If the states are not configured in the jurisdiction settings, then the Employer Identification Number (EIN) in the Company and Subsidiary settings is used.

**Viewing and Editing an Employee’s State History**

The state history records an employee’s residence in the two mandated states (DC and NJ). If the employee moved into or out of a mandated state partway through a month, they are considered to have resided in that state during that month.

When you install or update the ACA SuiteApp, the employees’ state histories are generated from the system notes on the employee record. Subsequently, when you edit an employee’s address on the employee record, their state history will be updated.

**To view or edit an employee’s state history:**

1. Go to Payroll and HR > Lists > Employees (Payroll Manager).
2. On the Employees list, click **Edit** next to the employee whose state history you want to view.
3. Click the **Affordable Care Act (ACA)** subtab.
4. Click the **State History** subtab.
5. If you need to correct information in the state history, click the row of the field you want to edit.
6. For each period of time in 2019 when the employee resided in a mandated state, enter the **State**, **Start Month**, **Start Year**, **End Month**, and **End Year**. To indicate that you have manually edited the state history, check the **Is Manually Added** box.
7. Click **Save**.

**Verifying Employee State History Information**

When you are ready to file your ACA compliance, you can view the state history information in the audit log to confirm that it is correct.
To verify employee state history:

1. Go to Payroll and HR > Payroll > Affordable Care Act (Payroll Manager).
2. Click Generate from the Ready to File section of the ACA landing page.
3. Click the View Audit Log link to open a file that can be viewed in Microsoft Excel.
4. Click the DC State Info or NJ State Info tabs to view the months of the year, the full-time employee count, and overall employee count for employees residing in those states. Each tab also shows the appropriate State ID.

Viewing ACA Filing History

If you have the used the ACA Reporting SuiteApp to report compliance for the previous year, you can view your filing history on the ACA landing page.

To view ACA filing history:

1. Go to Payroll and HR > Payroll > Affordable Care Act (Payroll Manager).
2. On the ACA landing page, in the Filing History section, click View to view the previous year’s filing.
Government-Issued ID Tracking

The Government-Issued ID Tracking feature enables you to track a variety of government-issued identification information about your employees so that you can ensure that you have accurate documentation for your employees’ travel, driving qualifications, and tax compliance.

For more information on this feature, see the following topics:

- Government-Issued ID Tracking Overview
- Managing Government-Issued ID Types
- Managing Basic Government-Issued ID for Employees
- Managing Advanced Government-Issued ID for Employees

Government-Issued ID Tracking Overview

You can use the Government-Issued ID Tracking feature to track a variety of government-issued identification information about your employees so that you can ensure that you have accurate documentation for your employees’ travel, driving qualifications, and tax compliance.

For each employee, you can enter information about their passport(s), driver’s license(s), and several other government-issued IDs, such as tax identification numbers.

Many other government-issued IDs are only relevant in particular jurisdictions, so you can make some ID types inactive if you are not going to use them. When you make them inactive, they do not appear in the list of available types when you are adding IDs to an employee's record.

Before using Government-Issued ID Tracking, enable one of the two features: Basic or Advanced.

**Note:** If you have one of these features enabled and you enable the other one, NetSuite warns you that any custom scripting you have created will no longer function and will have to be changed.

Basic Government-Issued ID Tracking

The Basic Government-Issued ID Tracking feature enables you to track:

- Passport Number
- Driver’s License Number

Advanced Government-Issued ID Tracking

The Advanced Government-Issued ID feature provides several ID types by default. It also allows you to create, edit, and delete your own custom types of ID to match your company’s employee identification policies. By default, the feature includes:

- Passport Number
- Driver’s License Number
- Individual Taxpayer Identification Number (ITIN)
- Inland Revenue Department Number (IRD)
- National Insurance Number (NINO)
- Social Insurance Number (SIN)
- Social Security Number (SSN)
- Tax File Number (TFN)

You cannot delete the standard government-issued ID types that are included in NetSuite by default. However, you can make them inactive (except for passport and driver's license) so that they do not appear in the list of available types when you are adding IDs to an employee's record.

Roles and Permissions

For details about the permission requirements for Government-Issued ID Tracking, see Advanced and Basic Government-Issued ID Tracking Permission Requirements.

Managing Government-Issued ID Types

If you are using the Advanced Government-Issued ID Tracking feature, NetSuite has several ID types included by default, such as driver's license, passport, and tax identification numbers. If you need additional government-issued ID types, you can create custom ones to match your company's employee identification policies.

You cannot delete the standard government-issued ID types that are included in NetSuite by default. However, you can make them inactive (except for passport and driver's license) so that they do not appear in the list of available types when you are adding IDs to an employee's record.

**Note:** This is only available if you are using Advanced Government-Issued ID Tracking.

Adding a Custom ID Type

**To add a custom ID type:**

1. Go to Setup > HR Information System > Government-Issued ID Types > New or click New Government-Issued ID Type on the Government-Issued ID Types page.
   - To modify the details of an existing custom type, go to Setup > HR Information System > Government-Issued ID Types and click Edit next to the name of the type.

2. In the Name field, enter a name for the type.

3. In the Description field, enter a short unique description for the type.

4. If you want to be able to record more than one instance of this type for a particular employee, check the Multiple Instances Allowed box.

5. If you want this type to be inactive, select the Inactive box. This affects how the type appears on the Government-Issued ID Types list.

6. Click Save.

Viewing the List of Government-Issued ID Types

**To view the list of government-issued ID types:**

1. Go to Setup > HR Information System > Government-Issued ID Types.
2. To see all inactive types, select the **Show Inactives** box.
3. To view an individual type, click **View** next to the name of the type.

### Deleting a Custom ID Type

**To delete a custom ID type:**

1. Go to Setup > HR Information System > Government-Issued ID Types.
2. Click **Edit** beside the custom type you want to delete.
3. On the **Actions** menu, select **Delete**. Note that you cannot delete any standard ID types included by default with NetSuite.
4. When prompted to confirm the deletion, click **OK**.

### Managing Basic Government-Issued ID for Employees

If you have the Basic Government-Issued ID Tracking feature enabled, you can enter information for employees about these types of ID:

- Passport Number
- Driver's License Number

You enter only the numbers for these two types of ID. To enter more detailed information, you must enable the Advanced Government-Issued ID Tracking feature. You enter this information in two ways: from the employee record or from list page for the type of ID you are entering.

Make sure that you enter information exactly as it appears on the original documents.

### Adding or Editing Passport Information

**To add or edit passport information:**

1. Go to Lists > Employees > Employees and click **Edit** beside the employee whose information you want to add or edit.
2. On the **Human Resources** subtab, enter the employee's passport number in the **Passport Number** field.
3. Click **Save**.

### Adding or Editing Driver's License Information

**To add or edit driver's license information:**

1. Go to Lists > Employees > Employees and click **Edit** beside the employee whose information you want to add or edit.
2. On the **Government-Issued ID** subtab, enter the employee's driver's license number in the **Driver's License Number** field.
3. Click **Save**.
Managing Advanced Government-Issued ID for Employees

If you have the Advanced Government-Issued ID Tracking feature enabled, you can enter information for employees about these types of ID:

- Passport Number
- Driver's License Number
- Individual Taxpayer Identification Number (ITIN)
- Inland Revenue Department Number (IRD)
- National Insurance Number (NINO)
- Social Insurance Number (SIN)
- Social Security Number (SSN)
- Tax File Number (TFN)

With the Advanced feature, you can also add information for custom types that you have created. Make sure that you enter information exactly as it appears on the original documents.

You enter this information in two ways: from the employee record or from list page for the type of ID you are entering.

Adding or Editing Passport Information

To add or edit passport information:

1. Go to Lists > Employees > Employees and click Edit beside the employee whose information you want to add or edit.
3. In the Passport window, enter the Nationality.
4. Enter the Date of Issue.
5. Optionally, enter a Description, especially if you are entering more than one passport for this employee.
6. Enter the employee's Name As It Appears On Document.
7. Enter the Date of Expiration.
8. Enter the Issuing Authority/Region.
9. Enter the Passport Number.
10. Click Save.

Adding or Editing Driver’s License Information

To add or edit driver’s license information:

1. Go to Lists > Employees > Employees and click Edit beside the employee whose information you want to add or edit.
2. On the Government-Issued ID subtab, under Driver's License, click New Driver's License.
3. In the Driver’s License window, enter the Date of Issue.
4. Optionally, enter a Description, especially if you are entering more than one driver’s license for this employee.
5. Enter the employee’s Name As It Appears On Document.
6. Enter the Date of Expiration.
7. Enter the Class/Level of the license.
8. Enter the Issuing Authority/Region.
9. Enter the Driver’s License Number.
10. Click Save.

Adding or Editing Other ID Information

To add or edit other ID information:

1. Go to Lists > Employees > Employees and click Edit beside the employee whose information you want to add or edit.
2. On the Government-Issued ID subtab, under Other Government-Issued IDs, click New Government-Issued ID.
3. In the Other Government-Issued ID window, select an ID type from the Government-Issued ID Type dropdown list. If the ID type you want to add is not shown in the dropdown list, you can add custom ID types. For more information, see Managing Government-Issued ID Types.
4. Click the Number field and enter the ID number.
5. Click the Name As It Appears On Document field and enter the employee’s name. Make sure that you are entering the name exactly as it appears on the document.
6. Optionally, click the Description field and enter a description for this ID.
7. Optionally, enter the Date of Expiration.
8. Add any more IDs for this employee.
9. Click Save.
Benefits Tracking

The Benefits Tracking SuiteApp enables you to track your company's benefits plans so that both Human Resources and employees can access the details of plans within NetSuite instead of using the benefits carriers’ websites. This SuiteApp also enables you to track and report on the costs paid by your company and your employees. This SuiteApp provides the following features:

- HR administrators can view the benefit plans of individual employees.
- HR administrators can view the costs of benefits plans that they can track the financial impact.
- Employees can view their own benefits plans through a Benefits Tracking portlet that they add to their dashboard.
- HR administrators can import benefit plan information directly from carriers into NetSuite instead of entering it manually.

For more information about Benefits Tracking, see the following topics:

- Setting Up the Benefits Tracking SuiteApp
- Configuring Benefits Tracking
  - Assigning the Benefits Administrator Role
  - Confirming that Benefits Tracking Scripts Are Running
  - Creating Benefit Carriers
  - Creating Benefit Types
  - Creating Benefits
  - Assigning Benefits to an Employee
- Benefits Tracking Reports
- Importing Benefits Information from Carriers

Setting Up the Benefits Tracking SuiteApp

Prerequisites for the Benefits Tracking SuiteApp

To install the Benefits Tracking SuiteApp, you must have the following features enabled:

- Custom Records
- Server SuiteScript
- Client SuiteScript

Installing the Benefits Tracking SuiteApp

Install the Benefits Tracking SuiteApp:

- Bundle Name: Benefits Tracking
- Bundle ID: 181105

This is a managed bundle and is automatically updated whenever there are updates. These issue fixes and enhancements are available after the SuiteApp is updated in your account.
For more information about installing SuiteApps, see the help topic Installing a Bundle.

Configuring Benefits Tracking

After you install the Benefits Tracking SuiteApp, you have a series of steps to perform to configure benefits tracking:

- Assigning the Benefits Administrator Role
- Confirming that Benefits Tracking Scripts Are Running
- Creating Benefit Carriers
- Creating Benefit Types
- Creating Benefits
- Assigning Benefits to an Employee

Assigning the Benefits Administrator Role

When you install the Benefits Tracking SuiteApp, a Benefits Administrator role is created in your account. You should assign the Benefits Administrator role to employees who oversee your benefits programs. For more information, see Assigning Roles to an Employee.

Confirming that Benefits Tracking Scripts Are Running

To confirm that scripts are running:

1. Go to Customization > Scripting > Scripted Records.
2. On the Scripted Records page, click Edit beside Employee.
3. On the User Event Scripts tab, make sure that the Deployed box beside the Benefits - Employee UE script is checked.
4. On the Client Scripts tab, make sure that the Deployed box beside the Benefits - Employee Client script is checked.
5. Click Save.

Creating Benefit Carriers

A benefit carrier is a third-party company that provides benefits to your employees, for which your company or your employees, or both, pay premiums. For each benefit that you create using the Benefits Tracking SuiteApp, you can specify a carrier to track these benefit providers.

To create a benefit carrier:

1. Go to Setup > Benefits > Benefit Carriers > New.
2. On the Benefits Tracking — Carrier page, in the Name field, enter a unique name for the carrier.
3. Optionally, enter the following additional information for the carrier:
   - Address
   - Contact Email
Creating Benefit Types

A benefit type is a category of benefit provided to an employee by a carrier, such as medical, dental, disability, or life insurance. When you install the Benefits Tracking SuiteApp, several default benefit types are populated for you:

- Life Insurance
- Accidental Death & Dismemberment (AD&D)
- Medical
- Dental
- Vision
- Long-Term Disability (LTD)
- Short-Term Disability (STD)
- Health Spending Account (HSA)

You can edit or delete these types or create your own to match your organization's situation.

To create a benefit type:

1. Go to Setup > Benefits > Benefit Types > New.
2. In the Name field, enter a unique name for the type.
3. Click Save.

Creating Benefits

A benefit is a specific, non-wage compensation item provided to an employee. When you create a benefit, you associate it with a benefit type, carrier, and coverage. You also specify the monthly employer and employee costs for the benefit so that you can track these figures for your company.

If you are using SuitePeople US Payroll, you can also associate the benefit with a payroll deduction and employer contribution so that the appropriate deductions and contributions are reflected on employees’ paychecks. In this case, before you create benefits, you should create the deduction payroll items and the employer contribution payroll items that you plan to associate with those benefits. For more information, see the help topic Creating Payroll Items.

Note: You should create new payroll items for use with benefits only, and not use those payroll items for other uses. If you add a benefits-related payroll item to an employee from the Payroll tab for another reason, the payroll item will be added to the employee's benefits. This could produce inaccurate results. Also, you should not associate a benefit with a payroll item which is derived from another payroll item.

To create a benefit:

1. Go to Setup > Benefits > Benefits > New.
2. In the Name field, enter a unique name for the benefit.
3. Optionally, enter a description in the Description field to help distinguish this benefit from others.

4. Select a type from the Type dropdown list. To add a new type here, click the Add button. For more information about adding a benefit type, see Creating Benefit Types.

5. Optionally, select a carrier from the Carrier dropdown list. To add a new carrier here, click the Add button. For more information about adding a carrier, see Creating Benefit Carriers.

6. On the Coverage tab, add a coverage with the following steps:
   a. Enter a name for the coverage in the Benefit Coverage Name field.
   b. In the Monthly Employer Cost field, enter the amount that your company will pay for the benefit per employee every month.
   c. In the Monthly Employee Cost field, enter the amount that the employee will pay for the benefit every month.

   Note that the Monthly Total Cost field is updated with the sum of the two monthly cost fields.

   **Note:** If you change either of the monthly cost fields after you have assigned this benefit to an employee, you are prompted to choose whether or not to apply this change to the affected employees.

7. If you use SuitePeople US Payroll, on the Deduction tab, select the payroll item to associate with this benefit. This represents the deduction that will be applied to employees’ paychecks. You can only add one payroll deduction item to a benefit. Before setting up benefits, you should create the required deduction payroll items. For more information, see the help topic Creating Payroll Items.

8. If you use SuitePeople US Payroll, on the Employer Contribution tab, select the payroll item to associate with this benefit. This represents the employer contribution that will be applied to employees’ paychecks. You can only add one payroll employer contribution item to a benefit. Before setting up benefits, you should create the required employer contribution payroll items. For more information, Creating Payroll Items.

9. Click Save.

Assigning Benefits to an Employee

A benefit is a specific, non-wage compensation item provided to an employee. When you create a benefit, you associate it with a benefit type, carrier, and coverage. You also specify the monthly employer and employee costs for the benefit so that you can track these figures for your company. After you have defined the benefits that employees in your organization can have, you assign them to employees.

To assign a benefit to an employee:

1. Go to Lists > Employees > Employees.
2. Click Edit beside the employee you want to assign a benefit to.
3. Click the Benefits tab.
4. Select a benefit from the Benefit dropdown list.
5. Select a type of coverage from the Coverage dropdown list. The items here are the ones associated with the selected benefit.
6. When you select a coverage, the Monthly Employer Cost and Monthly Employee Cost fields are automatically populated with the values from the selected coverage. To override those values, click one or both of the fields and enter new values. When you change those fields, the Monthly Total Cost field is updated automatically.
7. Click Add.
Benefits Tracking Reports

The Benefit Tracking SuiteApp includes three reports that you can use to retrieve, present, and analyze your benefits data:

- Employee Benefit Coverage Report
- Employee Benefit Cost Report
- Employees Without Benefits Report

You can also customize these standard reports in the Report Builder by clicking Customize on the results page. For more information, see the help topics Report Builder Interface and Report Customization.

Employee Benefit Coverage Report

The standard Employee Benefit Coverage report shows the benefit type, benefit, carrier, and coverage for each employee across all classes, departments, locations, and subsidiaries. You can use this report to quickly see an employee's benefits coverage.

To view the Employee Benefit Coverage report, go to Reports > Benefits > Employee Benefit Coverage.

The standard Employee Benefit Coverage report shows the following columns:

- Name (sorted ascending by default)
- Job (if you are using the Job Management feature)
- Supervisor
- Class
- Department
- Location
- Subsidiary
- Country
- Benefit Type
- Benefit
- Carrier
- Coverage

To customize this report and display it in the Report Builder, click Customize. For more information, see the help topic Report Customization.

Employee Benefit Cost Report

The standard Employee Benefit Cost report shows the benefit type, benefit, carrier, employee cost, employer cost, and total cost for each employee across all classes, departments, locations, and subsidiaries. You can use this report to quickly see how much an employee's benefits are costing both the company and the employee.

To view the Employee Benefit Cost report, go to Reports > Benefits > Employee Benefit Cost.

The standard Employee Benefit Cost report shows the following columns:
Benefits Tracking Reports

- Name (sorted ascending by default)
- Job (if you are using the Job Management feature)
- Supervisor
- Class
- Department
- Location
- Subsidiary
- Country
- Benefit Type
- Benefit
- Carrier
- Employee Cost
- Employer Cost
- Total Cost

To customize this report and display it in the Report Builder, click Customize. For more information, see the help topic Report Customization.

Employees Without Benefits Report

The standard Employees Without Benefits report shows the employees who do not have benefits assigned to them. To appear in this report, employees must:

- Be Active
- Have a Termination/Release Date in the future or blank
- Have no benefits assigned

To view the Employees Without Benefits report, go to Reports > Benefits > Employees Without Benefits.

The standard Employee Benefit Cost report shows the following columns:

- Name (sorted ascending by default)
- Job Title
- Supervisor
- Class
- Department
- Location
- Subsidiary
- Country (from Subsidiary)

To customize this report and display it in the Report Builder, click Customize. For more information, see the help topic Report Customization.

Importing Benefits Information from Carriers

You can import benefits information from benefits carriers using the CSV Import feature. For more information, see the help topic Importing CSV Files with the Import Assistant.
To import benefits information from a carrier:

1. Go to Setup > Import/Export > Import CSV Records.
2. On the Import Assistant page, select Custom Records from the Import Type dropdown list.
3. Select the benefits-related record you want to import from the Record Type dropdown list. Select one of:
   - Benefit
   - Benefit Carrier
   - Benefit Coverage
   - Benefit Deduction
   - Benefit Employee Contribution
   - Benefit Type
   - Employee Benefit
   - Staging
   - System Propagate Cost
4. Select the One File to Upload radial button.
5. Click Select and locate the file you want to upload.
6. Click Next.
7. On the Import Options page, select Add or Update.
8. Expand the Advanced Options and check the Run Server Suitescript and Trigger Workflows box.
9. Click Next.
10. On the Field Mapping page, confirm that the fields in your CSV file are mapped to the correct fields in the custom record. Click Next.
11. On the Save mapping & Start Import page, you can optionally enter a a map name, description, or script ID. To save the mapping, enter a least a map name and click Save & Run. To run the import without saving, click Run.
12. On the Job Status page, click CSV Response to view the results of the CSV Import, including any errors.