1.36 COMPATIBLE


Property Description

Parameter type

String

Syntax

COMPATIBLE = release_number

Default value

12.0.0

Modifiable

No

Modifiable in a PDB

No

Range of values

11.0.0 to default release

Basic

Yes

Oracle RAC

Multiple instances must have the same value.


COMPATIBLE enables you to use a new release of Oracle, while at the same time guaranteeing backward compatibility with an earlier release. This is helpful if it becomes necessary to revert to the earlier release.

This parameter specifies the release with which Oracle must maintain compatibility. It enables you to take advantage of the maintenance improvements of a new release immediately in your production systems without testing the new functionality in your environment. Some features of the release may be restricted.

When using a standby database, this parameter must have the same value on both the primary and standby databases.

See Also:

Oracle Database Upgrade Guide for more information on setting this parameter