Contents

Preface

Audience iv
Documentation Accessibility iv
Conventions iv

1 SQL Developer Accessibility Information

1.1 About Oracle SQL Developer Accessibility 1-1
1.2 Using a Screen Reader and Java Access Bridge with Oracle SQL Developer 1-1
1.3 Oracle SQL Developer Features that Support Accessibility 1-1
  1.3.1 Keyboard Access 1-2
  1.3.2 Screen Reader Readability 1-2
  1.3.3 Flexibility in Font and Color Choices 1-3
  1.3.4 No Audio-only Feedback 1-3
  1.3.5 No Dependency on Blinking Cursor and Animation 1-3
  1.3.6 Screen Magnifier Usability 1-3
  1.3.7 How to Change the Editor or Tabbed View of a File 1-4
  1.3.8 How to Read Text in a Multiline Edit Field 1-4
  1.3.9 How to Read the Line Number in the Source Editor 1-4
  1.3.10 How to Access Exception Stack HTML Links and Generated Javadoc Links in the Log Window 1-4
1.4 Recommendations for Customizing Oracle SQL Developer 1-4
  1.4.1 How to Customize the Accelerators Keys 1-4
  1.4.2 How to Pass a Conflicting Accelerator Key to Oracle SQL Developer 1-5
  1.4.3 How to Change the Look and Feel of SQL Developer 1-5
  1.4.4 How to Customize the Fonts in Code Editors 1-5
  1.4.5 How to Customize Syntax Highlighting 1-5
  1.4.6 How to Display Line Numbers in Code Editors 1-5
  1.4.7 How to Change the Timing for Completion Insight 1-5
  1.4.8 How to Specify the Columns in the Debugger 1-5
1.5 Highly Visual Features of Oracle SQL Developer 1-5
Preface

This guide provides information on the accessibility features for Oracle SQL Developer.

Audience

This guide is intended for those using the accessibility features of Oracle SQL Developer.

Documentation Accessibility

For information about Oracle’s commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

Conventions

The following text conventions are used in this document:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>boldface</strong></td>
<td>Boldface type indicates graphical user interface elements associated with an action, or terms defined in text or the glossary.</td>
</tr>
<tr>
<td><em>italic</em></td>
<td>Italic type indicates book titles, emphasis, or placeholder variables for which you supply particular values.</td>
</tr>
<tr>
<td><code>monospace</code></td>
<td>Monospace type indicates commands within a paragraph, URLs, code in examples, text that appears on the screen, or text that you enter.</td>
</tr>
</tbody>
</table>
1

SQL Developer Accessibility Information

Note:

Unless otherwise indicated, the SQL Developer accessibility information presented here also applies to Data Modeler and Data Miner.

This topic provides information on the accessibility features for Oracle SQL Developer. It includes the following:

• About Oracle SQL Developer Accessibility (page 1-1)
• Using a Screen Reader and Java Access Bridge with Oracle SQL Developer (page 1-1)
• Oracle SQL Developer Features that Support Accessibility (page 1-1)
• Recommendations for Customizing Oracle SQL Developer (page 1-4)
• Highly Visual Features of Oracle SQL Developer (page 1-5)

1.1 About Oracle SQL Developer Accessibility

It is our goal to make Oracle Products, Services, and supporting documentation accessible to the disabled community. Oracle SQL Developer supports accessibility features. For additional accessibility information for Oracle products, see the Oracle Accessibility Program page at:

http://www.oracle.com/accessibility/

1.2 Using a Screen Reader and Java Access Bridge with Oracle SQL Developer

In order for assistive technologies, like screen readers, to work with Java-based applications and applets, the Windows-based computer must also have Sun's Java Access Bridge installed. See Oracle SQL Developer Installation Guide for the screen reader setup procedure, and for the recommended minimum technology stack.

1.3 Oracle SQL Developer Features that Support Accessibility

Oracle SQL Developer provides features that are designed to support accessibility.
1.3.1 Keyboard Access

Oracle SQL Developer features support keyboard access to SQL Developer functionality; a summary is provided in this section. The following menu and toolbar functionality is provided through keyboard access:

- Users can navigate to and invoke all menu items.
- All toolbar functions are accessible through menu items.
- All menus and menu items have unique and functioning mnemonic keys.
- All context menus within the navigators and source editor can be invoked.
- Frequently used menu items have unique accelerator keys.

The following functionality is available in SQL Developer windows:

- Navigate between all open windows, to all nodes within a window or pane, and between tabs in a window.
- Set focus in a window or pane.
- Invoke all controls within a window or pane, and perform basic operations.
- Navigate and update properties in the Property Inspector.
- Use Completion Insight and Code Templates in the source editor.
- Invoke context sensitive help topics, navigate to and open all help topics, and navigate between the navigation and viewer tabs.
- Open, close, dock, undock, minimize, restore, and maximize the applicable SQL Developer window.

Tips:

- You can press Escape to move the focus from the current dockable window to the last active editor. Press Shift+Escape to move the focus and also close the current window.
- You can press Shift+F10 to open the context menu for any window. Use the Down Arrow and Up arrow keys to select a command and press Enter, or use the accelerators to invoke a command on the context menu.

The following functionality is available in Oracle SQL Developer dialogs and wizards:

- Users can navigate to and invoke all controls within all wizards and dialogs.
- The order in which the Tab key causes focus to flow is consistent and logical.
- Mnemonic keys are provided for controls where appropriate.

1.3.2 Screen Reader Readability

Here is a summary of screen readability in SQL Developer, when it is used with a screen reader.
When used with menus and toolbars:
• All menus and menu items are read.
• All toolbar items, including the Navigator toolbar items, are read.
• The hint text on all toolbar items is read.

When used with SQL Developer windows:
• All open windows are read.
• All components within each window, including tabs, are read.
• Status text at the bottom of the IDE, and within the source editor, is read.

When used with dialogs and wizards:
• All controls within all wizards and dialogs are read.
• Hint text is read.

1.3.3 Flexibility in Font and Color Choices

The user interface in SQL Developer improves usability for people who are visually impaired by offering flexibility in color and font choices. The following font and color features are included:
• Users can specify both the font and the size in which the font displays for code editors.
• All features of the product have black text on a white or gray background.
• Colored text, underlining, or images are never used as the only method of conveying information.

1.3.4 No Audio-only Feedback

In SQL Developer, there is no situation in which the only feedback a user receives is audible feedback. All audible feedback is accompanied by a visual indicator. For example, a prompt accompanies the bell sound that occurs when an error or illegal action has taken place.

1.3.5 No Dependency on Blinking Cursor and Animation

SQL Developer makes minimal use of a blinking cursor and animation:
• No features in SQL Developer use blinking indicators, with the exception of the cursor in the source editor.
• No features rely on animated sequences.

1.3.6 Screen Magnifier Usability

The SQL Developer user interface works well with screen magnifiers. All features of the product can be magnified by a screen magnifier.
1.3.7 How to Change the Editor or Tabbed View of a File

When you press Enter on a node in the Connections Navigator, you open the default editor for that file. To switch to the different editors and views available for a document; you can use the Alt+Page Up and Alt+Page Down accelerators to invoke the Navigate > Go to Window > Right Editor and Navigate > Go to Window > Left Editor menu commands, respectively.

1.3.8 How to Read Text in a Multiline Edit Field

To have the text in a multiline edit field read by a screen reader, you can select text by holding down the Shift key while moving the cursor either up or down with the Arrow keys, depending on the initial cursor position.

1.3.9 How to Read the Line Number in the Source Editor

To have the line number read by a screen reader while you are editing a file in the source editor, you can press Ctrl+G.

1.3.10 How to Access Exception Stack HTML Links and Generated Javadoc Links in the Log Window

After generating exception stack HTML links or Javadoc links in the Log window, they will not be recognized as links, but read as plain text by a screen reader. To access the links, set the cursor focus to the Log window. Right-click or press Shift+F1 and select Save As from the context menu. Save the contents of the Log window as an HTML file. Add the saved HTML file to a project or application workspace as a resource.

1.4 Recommendations for Customizing Oracle SQL Developer

SQL Developer provides a number of customization features that enable users to specify their requirements for keyboard usage, display attributes of SQL Developer, and timing where appropriate. All customization features are organized within the Preferences dialog. For maximum usability and to accommodate your needs, you should consider changing any of the following from the defaults to a more usable customized setting.

1.4.1 How to Customize the Accelerators Keys

You can add and change the default accelerator keys for Oracle SQL Developer in the Tools > Preferences > Shortcut Keys page. You can also load preset keymaps that you are accustomed to using.
1.4.2 How to Pass a Conflicting Accelerator Key to Oracle SQL Developer

In addition to changing the mapped accelerator keys, you can pass a conflicting accelerator key to JAWS by preceding the accelerator key combination with Insert+F3.

1.4.3 How to Change the Look and Feel of SQL Developer

You can change the default look and feel for Oracle SQL Developer in the Tools > Preferences > Environment page. The look and feel determines the display colors and shapes of objects like menus and buttons.

1.4.4 How to Customize the Fonts in Code Editors

You can change the font and font size that display in editors in the Tools > Preferences > Code Editor > Fonts page.

1.4.5 How to Customize Syntax Highlighting

You can change the font style, as well as the foreground and background colors used in syntax highlighting within the source editor in the Tools > Preferences > Code Editor > PL/SQL Syntax Colors page.

1.4.6 How to Display Line Numbers in Code Editors

You can display or hide line numbers in the source editor in the Tools > Preferences > Code Editor > Line Gutter page.

1.4.7 How to Change the Timing for Completion Insight

You can specify the number of seconds that Completion Insight is delayed, or disable Completion Insight, in the Tools > Preferences > Code Editor > Completion Insight page.

1.4.8 How to Specify the Columns in the Debugger

You can choose the columns and types of information that display in the Debugger in the Tools > Preferences > Debugger pages.

1.5 Highly Visual Features of Oracle SQL Developer

Oracle SQL Developer includes features that are highly visual, and these features have equivalent functionality that is available to people who are blind or visually impaired:

- The UI and visual editors. The source editor provides equivalent functionality, as pages and UI elements can be completely designed and coded in the source editor.
The Component Palette. The source editor provides equivalent functionality, as elements and tags that can be selected from the Component Palette can also be entered in the source editor.

You can add a component from the Component Palette to the UI or visual editor using keystrokes.

In Data Modeler and in the Data Miner Workflow Editor, it is possible to create, edit, and move elements on a diagram using only keystrokes.