2Menu Options

Adding a New Configuration

Caution: You must be within the My Configurations folder in order to add a new configuration.

This section discusses:

Accessing Configuration Properties

To add (create) a new configuration, you must access Configuration Properties by using one of the following three methods, which are functionally equivalent:

  1. From the Configuration Assistant toolbar, select File > Add > Configuration.

  2. Click the Add button and select Configuration from the drop-down list.

    This image is described in surrounding text.
  3. In the tree node view in the left pane, highlight and right-click the My Configurations node, and select Add Configuration.

    This image is described in surrounding text.

Using any of the preceding three methods, Configuration Assistant displays the Configuration Properties dialog box, which enables you to specify the properties for the configuration that you are adding.

Configuration Properties - General Tab

Add Configuration - General tab.

On Configuration Properties, with the General tab selected, complete these fields

  • Name

    Enter a name for your configuration.

    Caution:

    This field is restricted to a maximum of 10 characters, and all characters must be in upper case. You must not use any of these special characters in this field:

    /~`!@#$%^&()+=[]{}|\":;,?\\><*.'";

    Additionally, if you plan on extracting a configuration to a RDB, the name cannot start with a number due to RDB restrictions.

  • Description

    Enter a description for your configuration.

    Caution: This field can contain a maximum of 30 characters.
  • Documentation

    Optionally, you can attach documentation to be delivered with your configuration. For example, you may want to include some special installation instructions for your configuration in the form of an HTML file. Documentation that is attached using this field will be displayed in the Task Assistant, which should be associated with each task in the load schedule.

    There is no restriction on the file types that you can attach as documentation.

    You can only attach a single physical file from this field.

    Tip:

    If you want to include multiple files as documentation, you can compress them into a single file and attach the compressed file. Alternately, you can include the documentation (or any other files) that you want to include in an extracted configuration by placing them in this directory:

    <Solution Directory>/<solution name>/

    All contents of the <solution name> directory are automatically included in the .par file created by Configuration Assistant when it performs an Extract. However, even though the files are delivered to a source location using this method, they are not associated with a task as they would be if you used the Documentation field.

    This directory is defined in Using Preferences.

  • Deploy To:

    Note: Use this option to limit the configuration consumer's deployment options when the extracted configuration is deploying using Change Assistant. Use of this option does not limit the users of Configuration Assistant.

    Use the drop-down list to select the environments to which to deploy:

    • Selected Environment(s)

      Using this selection you can deploy to any selected environment, which can include local environments as well.

    • Local Environment Only

      Using this section you can only deploy to local environment, regardless of whether the environment is explicitly selected or not. When you select this option, all other selected environments are ignored.

    • Local and Selected Environment

      Using this selection you can deploy to all selected environments, including any local environment regardless of whether local environment is explicitly selected or not.

Configuration Properties - Advanced Tab

You should use the Advanced tab to make selections from preconfigured solutions, if you already have predefined OMW Projects or Tasks Views, or if you are using languages.

JD Edwards Tools Release 8.97

Configuration Properties - Advanced tab.

JD Edwards Tools Release 8.98 or greater

Configuration Properties - Advanced tab.

On Configuration Properties, with the Advanced tab selected, complete the fields in these two sections:

Industry/Region

In the Industry/Region section of the Advanced tab, complete these fields:

  • Region

    The drop-down list is populated based on the UDC Description01 field for the region (01RS/RC).

    For example:

    ANZ - Australia/New Zealand

  • Industry

    The drop-down list is populated based on the UDC Description01 field for the industry (01RS/RI).

    For example:

    MD - Manufacturing and Distributing

    Caution:

    The first time you define an industry or region in a configuration, the data is retrieved based on the combination of the region and industry UDC values specified. If you subsequently change the industry or region UDC, your changed configuration will still contain the original data because Configuration Assistant only changes the definition of the data within the configuration, and not the data itself. When you extract the configuration, Configuration Assistant assigns any Versions with the changed value.

    For example, if you first design a configuration based on the ANZ region, Configuration Assistant pulls in all record types associated with that UDC. If you subsequently change the region to Singapore, then the previously retrieved data remains the same, while in the configuration the identifier for the records is changed from ANZ to SIN. When you extract the configuration, Configuration Assistant changes the identifier for Versions from ANZ to SIN. As a result,when the configuration is loaded into a target environment, there are no artifacts from the ANZ region.

    Caution: For UDC values of the 01RS/RC and 01RS/RI tables other than the defaults provided by JD Ed-wards EnterpriseOne:
    • Customers should use values in the range of 900 to 999 for their configuration.

    • Business partners should contact Oracle to obtain a unique code.

  • Default Task View

    The Default Task View is based on the values you select for region and industry. The field is populated automatically after an industry and region are selected.

Additional Configuration

In the Additional Configuration region of the Advanced tab, complete these fields:

  • OMW Projects (not displayed with JD Edwards Tools Release 8.98 or greater)

    Click the browse button to select from existing OMW Project Names. This enables you to bring all configuration information such as UDCs and Versions into your definition.

    Note: Configuration information does not include code or objects. For more information about product packaging, see JD Edwards EnterpriseOne Tools Package Management Guide.
  • Task Views

    Click the browse button to select from an existing Task Master for tasks of type 00 (Task Views).

  • Language

    Configuration Assistant populates a drop-down list of languages based on the values of UDC 01/LP. When you select a language from this drop-down list, the translation table (that is, "D" table) records for UDCs and Task Views are included in your configuration.

    For example, a language selection on the drop-down list might be:

    P - Portuguese

    Note: Specifying a language pulls language records into your configuration for UDCs and Task Views only. If you want to include the entire translation table for these, or any other data, you must specifically include translation tables in the Tables section of your configuration definition.

Extracting a Configuration

After you create a configuration, you can extract it to a portable database. The output of the extraction depends on the JD Edwards EnterpriseOne Tools release, JD Edwards EnterpriseOne Applications Release, and the machine on which the extraction is performed. This topic describes how to extract a configuration.

Tip:

On Web Development Clients (Fat Clients), the Extract function allows you to extract local specifications and Central Objects.

On Standalone Clients and the Deployment Server, the Extract function only allows you to extract local specifications.

Extraction Output Matrix

Tools Release

Output

Applications Release 8.12 or prior

Application Release 9.00

8.98

XML

XML -- with these extraction machine variables:

MSDE

Standalone:

Extract Local > XML

SSE

Deployment Server:

Extract Local > XML

Web Development Client:

Extract Central > XML

Extract Local > XML

8.97

8.96

Depends on installed database on extraction machine which can be either of the following:

  • MSDE

  • SSE

MSDE

To extract a configuration, highlight the configuration to be extracted in the tree node display in the left pane:

  1. From the Configuration Assistant toolbar, select File > Extract.

    Note: As an alternate method, you can either:
    • Click the Extract button.

      Extract button (Tools Release 8.97)

      This image is described in surrounding text.

      Extract button (Tools Release 8.98)

      This image is described in surrounding text.
    • Use the keyboard shortcut: Ctrl+T

    Caution: If you accidentally click Extract, or if you want to stop the Extract process after it has begun, click the Cancel button in the Extract Status dialog box.
    This image is described in surrounding text.

    The status of the extraction process is displayed in the node_name-Extract Status panel.

    If the Extract completes successfully, each extracted category will be flagged with a green check mark and the bottom of the Extract Status panel will indicate Completed Successfully in the bottom left of the dialog box.

  2. When the extraction is complete, select either Report to view the Extract Report or Close to close the Extract Status window.

    For details about the Extract Report, refer to Extract Report.

    Tip: The portable archive (.par file) of the configuration that you extract is placed into the directory you have specified in Using Preferences. The prefix of the .par file (that you specified in Name field during the task Adding a New Configuration) identifies each custom configuration you create in My Configurations.

Troubleshooting Extract

If you have not previously extracted a report for the selected configuration, and you attempt to view the Extract Report, this error message is displayed:

This image is described in surrounding text.

If you have previous extracted a configuration, this error message is displayed:

This image is described in surrounding text.
Caution: If the Extract does not complete normally, each unsuccessful category will be flagged with a red X and the bottom of the of the Extract Status panel will indicate Errors Occurred. Click the Report button to view the exception report, which contains information useful in troubleshooting the error conditions.
This image is described in surrounding text.
Click Yes to view the Exception Report. For details about the Extract Report, see Extract Report.
Tip: You can also use OMW logs to help in troubleshooting. In OMW, find the project named CFG _your_configuration_name, click the project, and use the form exit to view the logs.

Packaging and Loading an Extracted File onto a Target Machine

Configuration Assistant. This tool is used to create configurations and to extract them into a portable archive. Typically the machine on which the tool is running must use a Microsoft Windows operating system. Also typically, such a machine would be either a JD Edwards EnterpriseOne Standalone Client or a JD Edwards EnterpriseOne Web Development Client (also known as a Fat Client).

The output of the extraction depends on the JD Edwards EnterpriseOne Tools release, JD Edwards EnterpriseOne Applications release, and the machine on which the extraction is performed. For details, see the Extraction Output table in the section entitled: Extracting a Configuration.

Change Assistant. This tool is used to load an extraction onto a target machine, which must be a JD Edwards EnterpriseOne Deployment Server or Standalone Client. By definition, the Deployment Server must also be running a Microsoft Windows operating system. By default, Configuration Assistant creates the .par file in the directory you specified in Using Preferences.

To summarize the Change Assistant steps:

  1. To avoid having Change Assistant inadvertently locate test extractions or perhaps other extractions that you might not be ready to share, copy the .par file to an appropriate folder under the Change Assistant downloads directory on the Deployment Server or Standalone Client.

  2. Navigate to the specified source directory containing the .par file and select the .par file from the Change Assistant display.

  3. Click the Deploy button.

    Change Assistant displays a list of available JD Edwards EnterpriseOne installed environments on this machine (which is either a Deployment Server or Standalone Client).

  4. Select the target JD Edwards EnterpriseOne environment into which you want to load the contents of the configuration.

Caution: Always beware of data integrity concerns, especially in production data environments. See Backing Up Your Target Database Environment.

Tables Involved when Extracting a Configuration Definition with Configuration Assistant

This section lists the tables involved when extracting a configuration definition with Configuration Assistant.

  1. OMW Projects and OMW Objects

    These tables and objects will have records extracted corresponding to the OMW projects and OMW Objects specified in the advanced options:

    Table

    Description or Object Type

    F98220

    OMW Project Header

    F98222

    OMW Project Objects

    F9860

    TBLE -- Object Librarian Master Table

    F9861

    TBLE -- Object Librarian Status Detail

    F98710, F98711, F98712, F98713

    TBLE

    F98720

    BSFN

    F98740, F98741

    ER

    F98743

    DSTR

    F98750, F98751

    APPL

    F98760, F98761

    UBE

  2. Versions

    These tables will have records extracted corresponding to the Versions specified in the configuration definition:

    • F983051 - Versions List

    • F983052 - Versions List Tag Table

    • F98740 - Event Rules - Link Table

    • F98741 - Event Rules - Spec Table

    • F98760 - Report Design Aid Text Information

    • F98761 - Report Design Aid Specification Information

  3. User Defined Codes

    These tables will have records extracted corresponding to the UDC codes and values specified in the configuration definition:

    • F0004 - User Defined Code Types

    • F0005 - User Defined Code Values

    Note: If language is specified, these tables will also be extracted.
    • F0004D - User Defined Code - Alternate Language

    • F0005D - User Defined Code - Alternate Language Description

  4. Task Views

    These tables will have records extracted corresponding to the Task Views specified in the configuration definition:

    • F9000 - Task Master

    • F9001 - Task Relationships

    • F9005 - Variant Description

    • F9006 - Variant Detail

    Note: If language is specified, these tables will also be extracted.
    • F9002 - Task Alternate Description

    • F9005D - Variant Description Alternate Description

    • F9006D - Variant Detail Alternate Description

  5. Security

    These tables will have records extracted corresponding to the users and roles specified in the configuration definition, and the address book information associated with these users will also be extracted:

    • F0092 - Library List - Users

    • F00921 - User Display Preferences

    • F00922 - User Display Preferences Tag File

    • F00924 - User Install Packages

    • F00925 - User Access Definition

    • F00926 - Anonymous User Access Table

    • F00927 - E1 Users PIM Information

    • F0093 - Library List Control

    • F00950 - Security Workbench Table

    • F95921 - Role Relationships Table

    • F95922 - Permissions List Relationship Table

    • F98OWSEC - One World Security

    • F0101 - Address Book Master

    • F0111 - Address Book - Who's Who

Saving a Configuration

Caution: You must be within the My Configurations folder in order to save a configuration.

To save a configuration that you have created (or modified), select Save Definition:

  1. Highlight the node for the definition you want to save.

  2. From the Configuration Assistant toolbar, select File > Save Definition.

    Note: As an alternate method, perform either of the following actions:
    • Click the Save Definition button.

      This image is described in surrounding text.
    • Use the keyboard shortcut: Ctrl+S

Saving All Configurations

Caution: You must be within the My Configurations folder in order to save all configurations.

To save all configurations that you have created (or modified), select Save All:

  1. Highlight the node for the definition you want to save.

  2. From the Configuration Assistant toolbar, select File > Save All.

    Note: As an alternate method, you can perform either of the following actions:
    • Click the Save All button.

      This image is described in surrounding text.
    • Use the keyboard shortcut: Ctrl+Shift+S

Edit

From the Edit menu, you can perform functions as described in these sections:

Using Standard Editing Functions (Cut, Copy, Paste, Delete, Rename)

Caution:

All configurations within the JD Edwards Configurations node are read-only. Configuration Assistant logically enables and disables certain standard editing functions as applicable, depending on which tree node you select and the context of the
configuration.

If you select Delete, there is no direct recovery (or "undo") from within the Configuration Assistant program. However, if you do not perform Save or Save All subsequent to an inadvertent Delete action, you can effectively recover by not saving, then exiting from Configuration Assistant, and then re-entering with the previously saved state.

This section describes these standard editing functions:

Tip:

The functionality of the standard editing functions is also duplicated with Drag and Drop.

For example, if you want to copy the security roles from JD Edwards Configuration to My Configurations, you can either:

  • In the source JD Edwards Configuration, highlight the Roles node and choose the standard editing function Copy (either from the Edit menu or with a right-click).

    In the target My Configuration, highlight either the Roles node (if it exists), or the Security node (if the Roles node does not exist) and choose the standard editing function Paste.

  • In the source JD Edwards Configuration, highlight the Roles node and drag it.

    In the target My Configuration, drop the Roles node that you are dragging either to the Roles node (if it exists) or the Security node (if the Roles node does not exist).

See also:

Cut

If you use the standard editing function Cut from either the Edit menu or with the keyboard shortcut Ctrl+C key, the currently selected node is deleted and its contents are copied to the clipboard.

Copy

If you use the standard editing function Copy from either the Edit menu or with the keyboard shortcut Ctrl+C, the contents of the selected node are copied to the clipboard and can be pasted into a new location by using the Paste command.

If you right-click and select Copy, this dialog box prompts you to enter the new name of the selected node:

This image is described in surrounding text.
Tip: Use the browse button or enter a fully qualified path to the target directory to which you want to copy the selected node. For example: c:\Change Assistant\Packages\Configurator\My Configurations\ copied_configuration_name

Paste

If you use the standard editing function Paste from either the Edit menu or with the keyboard shortcut Ctrl+V key, the current contents of the clipboard are pasted into the currently selected node.

Delete

If you use the standard editing function Delete from either the Edit menu or with the keyboard shortcut Delete key, you are prompted to confirm the deletion:

This image is described in surrounding text.

Rename

If you use the standard editing function Rename from either the Edit menu or with the keyboard shortcut F2, you are prompted to enter the new name for the selected node:

This image is described in surrounding text.

Using Preferences

From Edit > Preferences you can select preferences from the tabs described in these sections:

Using the Authentication Tab

Preferences - Authentication tab.

If you want to use the optional Configuration Assistant Update Center Authentication functionality, complete these fields:

  • User ID

  • Password

  • User Name

  • E-mail

  • Phone

If you want to disable the automatic connection to the Update Center, select this check box:

Disable Update Center Connection

If you want Configuration Assistant to always prompt for authentication credentials during startup, you can select this check box:

Always Prompt at Startup?

Using the Advanced Tab

Preference - Advanced tab.

If you want to use the optional Configuration Assistant advanced functionality for connections to the Update Center and for proxy server authentication, complete these fields:

Update Center Connection

  • Timeout (milliseconds)

    The default value is 300,000 milliseconds.

  • Number of Retries

    The default value is 5 retries.

Proxy Server Authentication

  • User ID

  • Password

  • Domain

If you want to be prompted for any advanced functionality on this tab during the startup of Configuration Assistant, you can select this check box:

Always Prompt at Startup?

Using the My Configurations Tab

Use the My Configurations tab to define the default working directory for your Configuration Assistant. This is the working folder for all configurations that you create.

Preferences - My Configurations tab.

On Preferences, with the My Configurations tab selected, complete this field:

Enter the Configuration Directory

Enter the directory path or use the browse button to enter the directory for your configurations, which the Configuration Assistant displays under the My Configurations node.

Caution: If you plan to extract RDB configurations this path cannot lead to a mapped drive.

View

The View menu enables you to generate HTML versions of these reports:

Summary Report

Note: As a design aid, you can view a Summary Report for any new or existing configuration regardless of whether it has been extracted using the Extract function of Configuration Assistant.

The Summary Report provides a listing of all the information contained in the configuration. The report provides links so that you can easily navigate to each section, including:

  • Definition

  • OMW Projects and OMW Objects

  • Tables

  • UDCs

    Note: The system generates UDCs in this report if you specify one UDC value at a time. If you specify an entire table, the system generates UDCs in the Tables section of this report.
  • Versions

  • Security

  • Task View

The report only displays a link if information exists for the section. That is, if you do not include a Task View in the configuration, the Summary Report does not create a link to Task View.

In addition, if any documentation is attached to the report, the system provide an active link to it. The generated source HTML file for the Summary Report is located in the directory of the node name. For example, if you generate a Summary Report for RSMDGR, then the file is located here:

x:\Change Assistant\Packages\your_configuration_name

In this location, x: is the drive on which your configurations reside, and

Also, your_configuration_name is the name of the node that defines your configuration.

To generate a Summary Report:

  1. Highlight any node in an existing configuration.

  2. From the View menu, select Summary Report.

    The following status panel is displayed to indicate the report is generating as requested:

    This image is described in surrounding text.

    After the report is generated, the HTML output is displayed by your default browser as shown in this example:

    HTML output.

Extract Report

The Extract Report provides a listing of all the information about the extraction process and the resulting .par file. The report provides links so that you can easily navigate to each section, including:

  • Definition

  • Action

  • Activity

You can only view an Extract Report for configurations that you have previously extracted. To verify if a configuration has already been extracted, check the directory of the node to verify if a <node_name>_EXTRACT.html file exists. If this file exists, an Extraction has previously been attempted for the selected configuration. To verify that the Extract process is valid, open the Extract Report file and verify that the extraction completed with no errors.

To view an Extract Report:

  1. Highlight a configuration for which you have previously performed an Extract.

  2. From View, select Extract Report.

    Extract Report.

Compare Report

If you want to compare the contents of one configuration against another, you can view the Compare Report, which presents a side-by-side comparison of the components for the two configurations that you choose. The Compare Report provides two groups of links, which you can use to review the configurations differently:

  • All

    The links in this grouping provide a listing of the components for the first configuration and a second column that describes whether the component exists in the second configuration. For example, All Tables provides a listing of all the tables in the first configuration and a Yes/No value in the column for the second configuration to indicate whether the second configuration table is included there.

  • Added and Removed

    The links in this grouping provide the differences noted in the All comparisons categories. For example, if you clicked the Added Tables link, the system displays the additional business units in the first configuration that are not in the second. If there are more tables in the second configuration than the first, a link for Removed Tables lists the tables in the second configuration.

To compare configurations:

  1. Highlight an existing configuration and from the View menu select Compare Report.

    The system displays this window:

    This image is described in surrounding text.
  2. Use the browse button or enter the path to locate the configuration that you want to use for the comparison.

  3. Click Open.

    Configuration Assistant generates the Compare report and opens it in your default browser. For example:

    This image is described in surrounding text.
  4. Use the links at the top of the report to navigate through the different sections of the report. Each topic contains a comparison of items (by names, numbers, and descriptions) that exist in one configuration, but not the other.

    Note: In this context, the term “removed" indicates that no add or append action occurred resulting in a difference between the compared configuration, where the source configuration contains an item while the target configuration does not.

Refresh

From the View menu, if you select Refresh (or use the keyboard shortcut F5), the Configuration Assistant refreshes the screen and returns the tree node display in the left-hand pane to a fully collapsed state. The contents display in the right pane is not affected.

This image is described in surrounding text.
Caution: When you make changes (which the system indicates by bold portions of a configuration and affected nodes), clicking Refresh will cause the system to disregard any changes that you made but did not save.

Help

When you select Help from the menu selections, you can choose from:

See also:

Show Log

The Configuration Assistant creates a new log file every time you start Configuration Assistant. If a log file exists from a prior startup, it is overwritten.

The type of errors written to this log are typically those for which Configuration Assistant has specific knowledge, such as Java exceptions, or if Configuration Assistant detects that Update Center is down.

The log file is written to the Configuration Directory specified on the My Configurations tab of Preferences, as described in Using Preferences of this guide. The name of the log file is ConfigurationAssistantLog.txt

This an example of the contents of a Configuration Assistant log file:

Configuration Assistant log
Tip: The logging levels cannot be selectable by the end user.

About Configuration Assistant

About Configuration Assistant.

If you choose About Configuration Assistant from the Help menu, a dialog box is displayed that contains this information about Configuration Assistant:

  • Version

  • Build date

  • Install date

Click OK to close the dialog box and return to Configuration Assistant.