5Data and Files

This chapter contains the following:

How can I print the data in the page I am on?

Click your user name or image in the global header and select Print Me, if available, from the Settings and Actions menu. You get a view of the page, which you can then print using your browser's standard print feature. This view includes any field, table, or other UI element on the page that has data. If the page has tabs, then only the currently open tab is included.

If you want just the data in specific tables, you can also use the Export to Excel button or menu option on the table, if available. You get a Microsoft Excel file containing data from the table, which you can then print.

Tables

How You Use Tables

You can find tables on many pages. Some tables are simple, while others give you several options to view and manage the data. Many of these options are described here, and they may or may not be available on the particular table you're using. You can find most of the options in the table toolbar, which usually has menus such as Actions, View, or Format.

Select Data

To select a row or column:

  • Row: Click anywhere within the row. Or, hover over the small cell beside first column, and click when your cursor becomes an arrow.

  • Column: Hover over the column heading and click when your cursor becomes an arrow. In tables that allow multiselect, you can use the Shift or Control key to select multiple rows at once.

Note: Some items in the table menus or toolbar are disabled until you select a row or column. For example, only after selecting a row can you then select About This Record from the View menu, to see who created and last updated the record, and when.

View Data

To help you view the data in the table, you can:

  • Use filters in the toolbar or Query By Example to narrow down the data. Query By Example is the row of fields that precedes the column headings.

  • Click Refresh in the toolbar, or select Refresh from the Actions menu. You reload the table with the latest available data.

  • Click Detach in the toolbar, or select Detach from the View menu. You can see more of the table in the detached view.

  • Select a column and click Wrap in the toolbar, or select Wrap from the View menu. You can see all the text in each cell within the column.

  • Click Export to Excel in the toolbar, or select Export to Excel from the Actions menu. You get a Microsoft Excel file with the data in the table.

Sort Data

To sort the data in the table:

  • Hover over the column heading of the column you want to sort by, and click the Sort Ascending or Sort Descending icon.

  • Select Sort from the View menu.

Edit Data

To edit data in a table, you can:

  • Select a row and click Edit in the toolbar to open a dialog box or another page.

  • Click a link in the row to open a dialog box or another page.

  • Click a row to make that row editable within the table.

Manage Columns

To determine which columns to see and how they appear, you can:

  • Hide or show: Select Columns from the View menu.

  • Resize: Hover between column headings and move the divider. Or, select the column, and then select Resize Columns from the Format menu.

  • Reorder:

    • To move a column, click the column heading and, when your cursor becomes two double-pointed arrows, move the column to a new position.

    • To reorder multiple columns, select Reorder Columns from the View menu.

  • Freeze: Select the column that you want to freeze, and then either click Freeze in the toolbar or select Freeze from the View menu.

Query By Example

Use Query By Example

Query By Example is the row of fields that precedes the table column headers, used for filtering the data in the table.

Applying the Query By Example Filter

Follow these steps:

  1. Click Query By Example on the table toolbar if the row of fields isn't displayed.

  2. Enter filter values in any or all of the Query By Example fields.

  3. Press Enter.

The table now shows only the records that meet the criteria you entered in all Query By Example fields.

Refreshing the Filtered Results

Do any of the following:

  • Press Enter again with your cursor in any of the Query By Example fields.

  • Click Search or Refresh on the toolbar, if available.

  • Select Refresh from the View menu, if available.

Note: The filter applies even if the Query By Example fields are hidden.
Removing the Query By Example Filter

Click the Clear All icon at the beginning of the Query By Example row, if available.

If not, then:

  1. Delete what you entered in each Query By Example field.

  2. Refresh the table.

To clear not just Query By Example but any other table filters:

  1. Select Clear from the View menu or click Clear on the table toolbar, if available.

  2. Refresh the table.

Operators and Wildcards for Query By Example

You can use operators and wildcards in Query By Example fields. Operators and wildcards work in alphanumeric fields only, not date fields.

Operators

This table describes the operators that you can enter in Query By Example fields.

Operator Description

None (you enter only a value)

  • Character field: Starts with

  • Number or date field: Equals

>

Greater than

<

Less than

>=

Great than or equal to

<=

Less than or equal to

and

And

Note: You can use this operator only in conjunction with other operators, for example: >0 and <=1000.

or

Or

For the >, <, >=, and <= operators:

  • Results are based on alphanumeric sort, in alphanumeric fields. For example, if you enter >=ABC, then ABC, ABD, ABCA, ACB, and BAC are matches, but not AB5 or AB.

  • A space is considered part of the filter value. For example, if you enter >= ABC, then ABC and ABD are matches only if they're preceded with a space.

Wildcards

This table describes the Query By Example wildcards that you can use at the beginning, middle, or end of your entered value. All other symbols are ignored.

Wildcard Description Examples

*

Multiple characters

Entered Value: add*

Matches: The word add and words beginning with add, such as address

?

Single character

Entered Value: exp?nse

Matches: Words such as expense or expanse

Export to Excel

What's the difference between Export to Excel and desktop integration for Excel?

You use the Export to Excel button or menu option to download data from your table as a Microsoft Excel file. You can then use this file to view or analyze your data.

You use desktop integration for Excel to create or edit records in Excel workbooks, and then upload them back into the application. This comes in handy when you have to work offline or make mass updates. In most cases, you download the desktop integrated workbook from a link in a panel tab or your table.

What's included in the file I get when I export a table?

You get the rows you select in the table. If row selection is disabled or you don't select anything, then you get all rows, including any that are not visible on the page.

In any case, some data might not be included if:

  • Any search criteria, filters, and Query By Example values apply to the table.

  • The table has any hidden columns.

  • You're working with a table that shows a certain number of rows per page or view. Try going to subsequent pages or views to export.

Translation Editor

Enter or Edit Translated Text

For a row in a table or for a field in a form, you can use the Translation Editor icon (when available) to view, edit, or enter the translated text for the supported languages. You don't need to sign out of your current session to do this task.

  1. Click the Translation Editor icon on the table toolbar or in the form.

  2. On the Edit Translations dialog box, select the row of your preferred language and enter or edit the translated text in the editable fields. You can enter translation text for multiple languages.

  3. Click OK.

If the translated text is in a language that's the same as that of your current session, you can see the translation apply to the UI immediately.

What's the difference between Language and Source Language?

Language refers to the language setting that is active for the application when the user signs in.

Source language refers to the language in which the text value is created. If multiple languages are active, the same text value, in whichever language is it created, is the default text in all translations because the actual translation isn't yet available.

When other values are entered for the translated values in different languages, the source language for each row is overridden with the language of translation.

Desktop Integration for Excel

Set Up Desktop Integration for Excel

You can create or edit records that you can upload to the application using integrated Excel workbooks. To use these workbooks, you must install an Excel add-in.

Note: Every release of Oracle Fusion Applications is likely to have a new version of the Oracle ADF Desktop Integration add-in. When prompted, install the latest version of the add-in. For more information, see Add-In Upgrade Policy for ADF Desktop Integration (2242879.1) on My Oracle Support at https://support.oracle.com.

Before You Start

  • Make sure you have an Excel and Windows version that's listed in Supported Platforms for ADF Desktop Integration (2242428.1) on My Oracle Support at https://support.oracle.com.

  • If you're reinstalling the Excel add-in and currently have a version older than 11.1.1.7.3 (4.0.0), then uninstall the existing Oracle ADF Desktop Integration Add-In for Excel the same way you uninstall any program on your computer.

    Tip: You can find the version in the control panel where you uninstall programs.
  • Optionally install the following from the Microsoft website.

    • Microsoft .NET Framework 4.5.2

    • Microsoft Visual Studio 2010 Tools for Office Runtime (VSTO Runtime)

    The add-in installer does check if you have these already, and would download and install them if needed. But, you can manually install them first, especially if you run into issues installing them as part of installing the Excel add-in.

Install the Desktop Add-In

To install the Oracle ADF 11g Desktop Integration Add-In for Excel:

  1. Make sure you are signed in to your computer with your account. For example, you can't have someone else sign in as an administrator and make the installation available for everyone using your computer.

  2. In the application, look for the client installer in Navigator > Tools.

  3. Run the installer (adfdi-excel-addin-installer.exe) as you would any program that you install on your computer.

Guidelines for Using Desktop Integrated Excel Workbooks

Where available, you can download a desktop-integrated Microsoft Excel workbook and use it to create or edit records. Your edits in the workbook don't affect the application until you upload the records back into the application.

What You Must Not Do

To ensure that you successfully upload to the application, don't:

  • Rename text from the integrated workbook, for example the worksheet or tab names.

  • Add columns.

  • Delete any part of the template, for example columns.

  • Hide required columns and status columns or headers.

Caution: Avoid using the Windows Task Manager and clicking End Task to close Excel. Doing so might disable the add-in.

Conventions

Some column headers in the integrated workbook might include [..]. This means that you can double-click or right-click within any cell in the column to open a dialog box, which lets you select a value to insert into that cell.

Statuses

To use the Status Viewer:

  1. Open the tab for your task in the Ribbon, if available. For example, if you downloaded a workbook to create expense items, the tab is called Create Expense Items.

  2. Click Status Viewer.

  3. In the worksheet, click any table row to see the status of the row, including messages for any errors. The Status Viewer always shows the status of the entire worksheet.

Searches

Some integrated workbooks have searches. To search within the workbook, you must be signed in to the application. When you click the search button, the application prompts you to login if you haven't already logged in.

Refreshes After Upload

If your changes aren't reflected after an upload, try the following to refresh the table in the application:

  • Use the refresh option for the table

  • Apply a filter or search on the table

Troubleshoot Desktop Integration for Excel

The application is integrated with Microsoft Excel so that, where available, you can work with records in a desktop integrated workbook. You might run into issues with the integration, for example, if you can't open the workbook that you downloaded or the workbook doesn't look right. You can use the Client Health Check Tool. For more information see Information Center: Troubleshooting Oracle ADF Desktop Integration (2012600.2) on My Oracle Support at https://support.oracle.com.

Use the Client Health Check Tool

Use the health check tool to find out what integration issues you might have and how to resolve them. Ask your help desk if you are unable to find or use the tool.

  1. Download the latest version of the health check tool from How to use ADF Desktop Integration Client Health Check Tool (2010222.1) on My Oracle Support at https://support.oracle.com.

  2. Run ClientHealthCheck.exe as you would other programs on your computer, and review the result for each checked item.

  3. Select any item that has a problem, and read the help text.

  4. Fix some of the problems by clicking the Fix Problems button. Otherwise, follow the instructions in the help text.

  5. If you need more assistance, click the Save Report As button to prepare information for your help desk.

  6. Review the report and remove any sensitive information.

  7. Contact your help desk and provide your report.

Attachments

How can I delete attachments?

Use the Delete icon button. Alternatively, you can use the Manage Attachments icon button to open the Attachments dialog box and delete specific attachments.

Can I view attachments in a different format?

Attachments, by default, appear in the table view. You can also view them in two other ways, list view and cards view, if the options are enabled.

To switch between the different views, click the toggle buttons on the toolbar.

How can I filter attachments?

Use the filtering options, if enabled, on the toolbar of the attachments window to display only those attachments that are specific to your search. You can filter attachments by Type, Title, Description, Category, and so on.

If you filter the attachments by Type, you get additional options to search for a specific file, folder, text, or a URL.

What happens if I update an existing attachment?

If an attachment of the same type and name is uploaded again for the record, the attachment gets stored as a new version. The previous attachment remains available, displaying the time stamp to indicate how old that version is. To view the version of an attachment for a record, click Actions > File Revision History.

By default, always the latest attachment appears for a particular record. However, if the option is enabled, you can pick any other version of that attachment and set it to default. Anyone viewing the attachment for that record will see the default version that you set, even if that's not the latest one.

Audit

Using audit history you can view changes to the application data such as the business objects that were created, updated, and deleted. To view the history or to create a report, you must have a role with the assigned privilege View Audit History (FND_VIEW_AUDIT_HISTORY_PRIV). For appropriate assignment of roles and privileges, check with your security administrator.

To open the Audit History work area, click Navigator > Audit Reports.

The default search displays a summary of the audit history in the search results table. It includes key data such as date, user, product, event type, business object type, and description. For a detailed report, search again with modified search criteria. You can export the report summary to Microsoft Excel.

The following table lists the search parameters used and the outcome of their selection in the detailed report.

Search Parameter Result of Selection

Business Object Type

Note: This parameter is applicable only for the business objects that belong to Oracle Applications Cloud.
  • Narrows the search results to that specific business object within the selected product.

  • Enables the Show Attribute Details check box.

Include Child Objects

Displays all the child objects that were listed for that business object when audit was set up. For example, a sales order object that contains several items as child objects.

Note: Displays the objects at the immediate parent-child level only. To view the children at subsequent levels, select the child object as the business object type and search again.

Show Impersonator

Displays the details of the impersonator who modified the objects during an impersonation session.

Show Attribute Details

Enables the attribute list so that users can select either all attributes or a specific attribute to view the changes. Based on the selection, the search results indicate whether the attribute is created, updated or deleted, and the corresponding old and replaced values.

Show Additional Object Identifier Columns

Displays the instances (contexts) in which the business object was used. The context values identify the objects and the transactions in which they were used. Each context is unique and assigns a unique description to the business object.

Note: The default report displays a standard set of columns that contain prominent details of the audit history. To view additional details, you can change the display of columns.

Types of Audit Events

Events trigger the audit process and the event details are stored in the audit table. Along with audit history, you can view which events triggered the changes to the object data within a given period of time. However, for events to trigger the audit process for the business objects, the objects must be enabled for auditing.

For Oracle Applications Cloud, transactional events trigger the audit process based on the create, update, and delete operations. The attributes of the audited object data can be used in lookups and foreign keys to display values in the audit history. Oracle Applications Cloud supports displaying the audited information as per the application's language settings.

For Oracle Fusion Middleware products, events such as failed sign in attempts are used as triggers. In absence of an audit table, the information is stored in the sandbox and presented only in English.

Note: This topic focuses on the create, update, and delete event types available in Oracle Applications Cloud. For details on events used in the Oracle Fusion Middleware products, refer to the Oracle Fusion Middleware documentation.
  • Create Operation - This event triggers audit activity whenever business object data is created and stored in the database. The audit report displays the name of the created object, the name of the user who created the object, and the time stamp.

  • Update Operation - This event triggers audit activity whenever the existing business object data is updated. The audit report displays both the old and updated values of the object, the name of the user who updated it, and the time stamp.

  • Delete Operation - This event triggers audit activity whenever the existing business object data is removed from the database. The audit report displays the last value that the object attributes contained and the name of the user who deleted the object.