Oracle Fusion Cloud Applications

Using Functional Setup Manager

22C
This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish, or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

If this is software, software documentation, data (as defined in the Federal Acquisition Regulation), or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, then the following notice is applicable:

U.S. GOVERNMENT END USERS: Oracle programs (including any operating system, integrated software, any programs embedded, installed, or activated on delivered hardware, and modifications of such programs) and Oracle computer documentation or other Oracle data delivered to or accessed by U.S. Government end users are "commercial computer software," "commercial computer software documentation," or "limited rights data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, the use, reproduction, duplication, release, display, disclosure, modification, preparation of derivative works, and/or adaptation of i) Oracle programs (including any operating system, integrated software, any programs embedded, installed, or activated on delivered hardware, and modifications of such programs), ii) Oracle computer documentation and/or iii) other Oracle data, is subject to the rights and limitations specified in the license contained in the applicable contract. The terms governing the U.S. Government's use of Oracle cloud services are defined by the applicable contract for such services. No other rights are granted to the U.S. Government.

This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software or hardware in dangerous applications.

Oracle®, Java, and MySQL are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.

Intel and Intel Inside are trademarks or registered trademarks of Intel Corporation. All SPARC trademarks are used under license and are trademarks or registered trademarks of SPARC International, Inc. AMD, Epyc, and the AMD logo are trademarks or registered trademarks of Advanced Micro Devices. UNIX is a registered trademark of The Open Group.

This software or hardware and documentation may provide access to or information about content, products, and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services unless otherwise set forth in an applicable agreement between you and Oracle. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services, except as set forth in an applicable agreement between you and Oracle.
# Contents

## Get Help

### 1 Overview

- Overview of Functional Setup Manager
- Who Uses the Functional Setup Manager
- How Functional Setup Manager Components Work Together
- Functional Setup Manager Work Areas
- Implementation Process

### 2 Application Implementation Planning

- Plan Your Implementation
- Use Promotion Codes

### 3 Offering Configuration

- Overview of Configuring Offerings
- Configure Offerings
- Opt In To New Features After Update
- Review Feature Updates
- Review Opt-In History
- FAQs for Offering Configuration

### 4 Manage Setup Using Functional Areas

- How You Use Functional Areas to Manage Setup
- Set Up an Offering
- Set Up an Offering with Scope
- Update Existing Setup Data
- FAQs for Manage Setup Using Functional Areas

### 5 Manage Setup Using Implementation Projects

- How You Use Implementation Projects to Manage Setup
8 Setup Security 73

Security Requirements 73
Mapping of Setup Activities and Required Roles 73
Why do I have access to more setup tasks than my granted access? 77

9 Additional Functionality 79

How Copying Setup Configuration Helps 79
Copy Setup Configuration 80
Search for a Task 81
Manage Integration of Additional Applications 82
Get Help

There are a number of ways to learn more about your product and interact with Oracle and other users.

Get Help in the Applications

Use help icons 📘 to access help in the application. If you don't see any help icons on your page, click your user image or name in the global header and select Show Help Icons.

Get Support

You can get support at My Oracle Support. For accessible support, visit Oracle Accessibility Learning and Support.

Get Training

Increase your knowledge of Oracle Cloud by taking courses at Oracle University.

Join Our Community

Use Cloud Customer Connect to get information from industry experts at Oracle and in the partner community. You can join forums to connect with other customers, post questions, suggest ideas for product enhancements, and watch events.

Learn About Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program. Videos included in this guide are provided as a media alternative for text-based topics also available in this guide.

Share Your Feedback

We welcome your feedback about Oracle Applications user assistance. If you need clarification, find an error, or just want to tell us what you found helpful, we'd like to hear from you.

You can email your feedback to oracle_fusion_applications_help_ww_grp@oracle.com.

Thanks for helping us improve our user assistance!
1 Overview

Overview of Functional Setup Manager

Oracle Functional Setup Manager provides an integrated, end-to-end process for functional administrators to manage the implementation and maintenance of Oracle Fusion Cloud Applications.

Functional Setup Manager offers the following:

- Standardized application configuration and setup experience
- Feature opt-in for a best fit configuration
- Guided task list for end-to-end setup requirements
- Export and import services for setup data migration between environments
- Comprehensive reporting on setup data

Who Uses the Functional Setup Manager

Business users who are responsible for configuring feature opt-in and managing setup data are the primary users of Functional Setup Manager.

Security Access

The Application Implementation Consultant job role has full access to perform all Functional Setup Manager-related activities. Other user must include the Functional Setups User role in addition to other roles or privileges needed to perform specific setup activities.

For more detailed information about security requirements for Functional Setup Manager, refer to the Oracle Fusion Cloud Applications Security Reference for Common Features guide on the Oracle Help Center (docs.oracle.com).

How Functional Setup Manager Components Work Together

Offerings, functional areas, features, and setup tasks work together in your implementation.

Offerings

An offering represents a collection of business processes that are supported by Fusion Applications. Each subscription of Oracle Cloud provides license to use one or more offerings and they're the starting point of all implementations. An offering consists of multiple functional areas and features.
Functional Areas

A functional area represents one or more business sub-processes and activities within its parent offering. It may represent a core operation of the offering or may represent an optional activity which may or may not be applicable to your business. When you start to implement an offering by enabling it, core functional areas are enabled automatically. You have a choice to opt in to and enable an optional functional area or to opt out of it. A functional area may be divided into smaller functional areas creating a hierarchy to help you to decide what to opt in to one step at a time. Some of the functional areas may be applicable to more than one offering. Once you set up a shared functional area, you don’t have to set it up again when implementing another parent offering. However, Oracle recommends that during successive implementation of the other parents you verify if there are any offering-specific tasks that may still require your attention.

Features

Features are optional business practices or methods applicable to the functional areas. Like functional areas, you can decide to opt in to or opt out of features depending on the requirements of your business processes. Features can be one of three different types:

- Yes or No: These features allow you either to opt in to or to opt out of them and are represented by a single check box. You select them to opt in to or deselect them to opt out.
- Single Choice: These features offer multiple choices but allow you to select only one option. Select the option applicable to your business processes.
- Multi-Choice: These features offer multiple choices but allow you to select more than one of the choices. Each choice is presented with a check box. Select all that apply to your business processes by checking the appropriate choices.

Setup Tasks

Setup tasks represent the work necessary to set up an offering and the business processes and activities that the offering represents to make them ready for transaction processing. Perform these tasks to enter setup data when you implement an offering.

Tasks representing setup requirements of the offerings and the functional areas are grouped into task lists and are organized in a hierarchy. For example, all setup tasks of an offering are grouped into a task list which includes subtask lists that represent setup of functional areas within the offering. This helps you gain visibility into setup data that are related to each other, helping you to manage setup.

Functional Setup Manager Work Areas

Use the My Enterprise work areas to manage feature opt-in and setup of your subscribed offerings. To view the work areas, click Navigator My Enterprise.

My Enterprise Work Area Group

The following work areas are part of the My Enterprise work area group:

- Offerings
- New Features
Offerings
Use this work area to view all the offerings available for implementation. To start with, review the description of the offerings and their related documents. Then, determine what to opt in to and what to exclude. And when you’re ready to implement, opt in to the offerings based on your enterprise requirements. You can start using Fusion Applications only after opting in to the relevant offerings and their related features.

New Features
In this work area, you can review what’s available in the latest version of Fusion Applications and decide whether to opt in to any new feature or not.

Feature Updates
Go to this work area to learn about the features whose behavior is planned to change in the future.

Enterprise
Use this work area to manage environment-level settings applicable to your enterprise.

Setup and Maintenance
In this work area, you can set up an offering or the functional areas in an offering. Using this work area, you can also update setup data for existing offerings and add or remove tasks to modify an implementation project.

Implementation Process
A functional implementation of Fusion Applications typically includes the following steps.

- Plan
- Configure
- Setup
- Deploy
- Maintain

Plan
Identify the offerings you want to implement. Evaluate what functional areas and features to opt in to and prepare accordingly for their setup requirements.

For more detailed information, refer to the Application Implementation Planning chapter in the Using Functional Setup Manager guide.
Configure
Opt in to the offerings, functional areas, and features that best fit your business requirements by enabling them.
For more detailed information, refer to the Offering Configuration chapter in the Using Functional Setup Manager guide.

Setup
Use setup tasks to enter setup data necessary for your enabled offerings and functional areas. Typically, you set up and verify your transaction processes in a test environment before starting to transact in a production environment.
For more detailed information, refer to the following chapters in the Using Functional Setup Manager guide:
  - Manage Setup Using Functional Areas
  - Manage Setup Using Implementation Projects
  - Manage Setup Using CSV File Packages

Deploy
Move your verified setup data from the test environment to a production environment and deploy to all users to start transaction processing.
For more detailed information, refer to the Setup Data Export and Import chapter in the Using Functional Setup Manager guide.

Maintain
Update setup data or opt in to configuration of the functional areas and features as necessary when your business requirements change over time.
# Chapter 2
## Application Implementation Planning

### Plan Your Implementation

Use the Offerings page to learn about the opt-in configuration and the setup requirements of an offering. To view the page, you must have the Review Applications Offering privilege (ASM_REVIEW_APPLICATIONS_OFFERINGS_PRIV).

1. Click **Navigator > My Enterprise > Offerings**.
2. On the Offerings page, explore the list and select the offering you want to implement. For the selected offering, you can read the offering description.
3. Click **Related Documents** and review the following reports to learn more about the offering.

<table>
<thead>
<tr>
<th>Document</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Associated Features Report</strong></td>
<td>Lists the functional areas and features associated with the offering.</td>
</tr>
<tr>
<td><strong>Setup Task Lists and Tasks Report</strong></td>
<td>Shows the list of task lists and tasks required for implementing the offering. You can also find information about export and import, and the business objects that each task handles. Use this document to identify these implementation requirements:</td>
</tr>
<tr>
<td></td>
<td>o If a task is optional or required</td>
</tr>
<tr>
<td></td>
<td>o Whether export and import functionality is supported</td>
</tr>
<tr>
<td></td>
<td>o If you can export or import the setup data into a CSV file</td>
</tr>
<tr>
<td></td>
<td>o The business objects or setup data that the task handles</td>
</tr>
<tr>
<td></td>
<td>o If scope or setup data filtering is supported, and view the business objects available for use in filtering</td>
</tr>
<tr>
<td><strong>Related Business Objects Report</strong></td>
<td>Shows all setup data required for implementing the offering. The report lists all business objects associated with the setup tasks belonging to the offering. You can also find information about export and import and scope filtering for each business object. Use this document to identify these implementation requirements:</td>
</tr>
<tr>
<td></td>
<td>o Whether export and import functionality is supported</td>
</tr>
<tr>
<td></td>
<td>o If you can export or import the business objects into a CSV file</td>
</tr>
<tr>
<td></td>
<td>o If the business object supports scope or setup data filtering</td>
</tr>
<tr>
<td></td>
<td>o The task to be used for filtering scope or setup data for the business object</td>
</tr>
</tbody>
</table>
Use Promotion Codes

If you received a promotion code to activate a functional area or feature of an offering, follow these steps to use it. You need the Configure Oracle Fusion Applications Offering privilege (ASM_CONFIGURE_OFFERING_PRIV) to enter the promotion code in the application.

1. Click Navigator > My Enterprise > Enterprise work area.
2. On the Enterprise Information page, click Manage Promotion Code.
3. On the Manage Promotion Codes page, click Enter Promotion Code.
4. On the Enter Promotion Code dialog box, enter the promotion code and click Save and Close.

The promotion code you entered appears in the Part Number column on the Manage Promotion Codes page.
3 Offering Configuration

Overview of Configuring Offerings

To configure an offering for implementation, you opt in to its functional areas and features that are applicable to your business operations.

You start your opt-in configuration by enabling the offering. The offering and its functional areas are shown in a hierarchy to help you decide, step-by-step, what to opt in to. When an offering is enabled, all functional areas and features representing core functionality of the offering are also automatically enabled. You decide which of the optional functional areas and features to opt in to by specifically enabling them.

After the initial implementation of the offering, if you must change the opt-in configuration to enable additional functional areas or features at a later time, use the same procedure to enable them as well.

You can also use the procedure for reviewing and opting in to new features that are introduced for your enabled offerings in each update of Fusion Applications.

In some cases, opt-in selection of a functional area or a feature may be locked once enabled due to the business operation it represents and its selection can't be changed.

Related Topics
- Configure Offerings

Configure Offerings

You can configure offerings to modify functionality so that it matches the services you plan to implement.

Watch video

You can review the current functional areas and features within an offering and make changes. To perform these tasks, you need the Configure Oracle Fusion Applications Offering privilege (ASM_CONFIGURE_OFFERING_PRIV).

To configure offerings, follow these steps:

1. Click Navigator > My Enterprise > Offerings work area.
2. On the Offerings page, select the offering you want to implement.
3. Click the Opt In Features button.
4. On the Opt In page, review the functional hierarchy. Select the check box in the Enable column to opt in to the offerings and functional areas as applicable to your business operation.
5. Click the Features icon in the Features column for the enabled offering to enable features at the offering level. Or, click the Features icon for functional areas to enable applicable features.
6. On the Edit Features page, enable a feature using these options:
   - To enable a Yes or No feature, select the check box in the Enable column.
To enable a Single Choice or a Multi-Choice feature, click the **Features** icon in the **Enable** column and make the required selection.

To enable a feature using an opt-in task because the **Enable** check box isn't available for selection, click the icon in the **Opt In Task** column. To save the changes, click **Done**.

7. On the Opt In page, click **Done** to save the changes and return to the Offerings page.

Repeat these steps for each offering you want to implement. You can use this procedure to change the opt-in configuration of any functional areas or features of an enabled offering.

---

**Opt In To New Features After Update**

New functional areas and features for an offering you have implemented are often introduced in the later updates of Fusion Applications. You can use the New Features work area to explore and decide whether to opt in to them.

**Watch video**

You need the following privileges to opt in to:

- Review Applications Offering (ASM_REVIEW_APPLICATIONS_OFFERINGS_PRIV)
- Configure Oracle Fusion Applications Offering (ASM_CONFIGURE_OFFERING_PRIV)

To opt in to new functional areas and features, follow these steps.

1. Click **Navigator > My Enterprise > New Features**.
2. On the Features Overview page:
   - Use the New Features tab to review and opt in to new functional areas and features that were introduced in the last update of the offerings.
   - Use the Available Features tab if you would like to review a comprehensive list of new functional areas and features that are currently available for use, but were introduced through several previous updates.
3. Leave the Feature Overview value to its default selection of **All Enabled Offerings** so that you can review features related to all your enabled offerings. Or, select a specific offering from the menu to review features specific to that offering.
4. On the New Features and Available Features tabs, for each new functional area or feature, review the information in these columns:
   - **Functional Area**: To determine the related functional module or business process. You can use the filter to limit the list of the features to specific functional areas.
     
     **Note**: Features that are directly associated with the offering will show offering name followed by the word **Common**.
   - **Learn More**: To find additional help topics.
     
     **Tip**: If the **Learn More** column isn't visible, go to the global header, click your user image or name, and select **Show Help Icons**.
   - **Enabled**: To view the opt-in status. You will see a check mark if it's already enabled. Otherwise, you will see an icon to enable it.
o **Allows Opt-In**: To find out whether you have a choice to opt in to a feature or not. A check mark indicates that you can opt in to or out of that feature. If the column shows nothing, it means that once the feature is enabled, it remains always enabled and you can't opt out of it.

o **Requires Setup**: To learn whether setup is required, and to plan accordingly.

o **Changes To and Changes In**: To find out whether the feature's behavior will change in the future, and if yes, in which update.

A feature that allows opt-in may change to always enabled or obsolete in the future. Similarly, an always-enabled feature may become obsolete in the future.

5. If you decide to opt in to any functional area or feature, here are the next steps.

   o To enable a new functional area, click the icon in the **Enabled** column. On the Opt In page, select the **Enable** check box for the specific functional area and click **Done**.

   o To enable a new feature, click the icon in the **Enabled** column. On the Edit Features page, select the **Enable** check box for the specific feature. For features with multiple choices, select the applicable choices. After all selections are complete, click **Done**.

   If the **Enable** check box isn't available for selection, click the icon in the **Opt In Task** column to enable a feature using an opt-in task.

### Review Feature Updates

Some features may change their behavior in a future update. You can use the Feature Updates work area to review the features whose behavior will change in the future and prepare accordingly.

![Watch video](image)

For example, a feature that was available for opting in to could change to being always enabled, thereby preventing you from opting in to or opting out of it. Or, the feature could become obsolete and therefore, is no longer applicable. Likewise, a feature that's set to remain always enabled could become obsolete in the future.

You need the following privileges to review feature updates:

- Review Applications Offering (ASM_REVIEW_APPLICATIONS_OFFERINGS_PRIV)
- Configure Oracle Fusion Applications Offering (ASM_CONFIGURE_OFFERING_PRIV)

Here's how you can review feature updates:

1. Click **Navigator > My Enterprise > Feature Updates**.
2. Leave the Feature Overview value to its default selection of **All Enabled Offerings** so that you can review features related to all your enabled offerings. Or, select an offering from the menu to review features specific to that offering.
3. On the Features Updates tab, for each updated feature, review the information in these columns:

   o **Functional Area**: To determine the related functional module or business process. You can use the filter to limit the list of the features to specific functional areas.

   ![Note:](image)} Features that are directly associated with the offering will show offering name followed by the word **Common**.
Available In: To know when the feature was introduced. Use the filter to limit the feature list to a specific update.

Learn More: To find additional help topics.

Tip: If the Learn More column isn't visible, go to the global header, click your user image or name, and select Show Help Icons.

Enabled: To view the opt-in status. You will see a check mark if it's already enabled. Otherwise, you will see an icon to enable it.

Changes From, Changes To, and Changes In: To find out whether the feature's behavior will change in the future, and if yes, in which update. A feature may change:

- From Allows Opt-In to Always Enabled
- From Always Enabled to Obsolete
- From Allows Opt-In to Obsolete

For features whose behavior will change in the next update, the Change In value is highlighted to draw your attention. You can also use the filters for these columns to focus on changes from one specific behavior to another, or on all upcoming changes in a specific update.

Review Opt-In History

Since opt-in configuration directly influences the behavior of setup and transactional processes, a history of all such changes is maintained on the Opt-In History page.

If you experience an unexpected change in the behavior of the application, you can review the opt-in history to find out these details:

- Who made the changes
- When the changes were made
- How the opt-in selections changed

To review the change history of the opt-in configuration, you need the Configure Oracle Fusion Applications Offering (ASM_CONFIGURE_OFFERING_PRIV) privilege.

To review the change history, follow these steps:

1. Click Navigator > My Enterprise > Offerings work area.
2. In the Offerings page, select the offering whose opt in history you want to review.
3. Click the Opt In Features button.
4. In the Opt In page, click the View All History button to open the Opt In History page to view changes made to all functional areas and features of an offering.

Note: Alternatively, click the View History icon corresponding to a specific functional area or feature from the Opt In page or the Edit Features page. This displays the change history of that specific functional area or feature respectively.
Review the change history. Changes made to the opt-in configuration are shown from most recent to least recent. The change history includes the following information:

- Name of the offering, functional area or feature whose opt in selection changed.
- Type, that indicates whether it's an offering, functional area, or a feature.
- Old value, refers to the opt-in selection before the change was made.
- New value, refers to the new opt in selection.
- User ID of the user who made the change.
- Date and time of the change.

You can also download the change history in CSV format. Click Actions > Download and save the file.

FAQs for Offering Configuration

Why can't I enable a feature?

A feature can be enabled only when its parent is also enabled. You must enable the parent before you enable the feature.

Why is the opt-in setting of an enabled functional area or feature read-only?

The opt-in setting of a functional area or feature is shown as read-only due to one of the following two reasons:

- If a functional area or feature represents a core functionality of the offering, it automatically inherits the enabled or disabled status of its parent.
- The opt-in setting of the functional area or feature may be locked once enabled due to the business operation it represents.

Why is a functional area or feature enabled when its parent isn't yet enabled?

If a functional area or feature is shared by multiple offerings, and if you have enabled any one of those offerings, then that functional area or feature is shown as enabled for all of those offerings.

However, you can manage setup data of the functional area only by using the offerings that are enabled.
Why is the Setup icon not displayed for a functional area or feature?

If the Setup icon isn’t displayed, then the functional area or feature doesn’t require any setup before you can start to use the related transactions.

Why is the Setup icon disabled for a functional area or feature?

Unless a functional area or feature is enabled, you can’t manage its setup data. Therefore, the Setup icon is enabled only after you enable the functional area or feature.

Why does the icon in the Requires Setup column show read-only?

If you don’t have permission to perform a setup task, then the Requires Setup column shows read-only to inform you that a functional area or feature requires setup before the related transactions can be performed.

However, you can’t use the icon to go to the Setup page to manage setup data since you don’t have permission. Contact the person with permission to set up the functional area or feature before you start processing the related transactions.

Why doesn't a feature allow opt-in when it's not enabled? How do I enable it?

An always-enabled feature won’t be enabled until the parent of the feature is also enabled.

Therefore, even though the Allows Opt-In column of that feature doesn’t show a check mark indicating that it’s always enabled, its Enabled column may not show a check mark. In such cases, use the Go to icon in the Enabled column to enable the parent feature. Once the parent is enabled, a check mark automatically appears in the Enabled column, for that feature.

Why do some values in the Changes In column show an exclamation mark?

If the behavior of a feature is planned to change in the next update, an exclamation mark is shown to draw your attention to them.
Chapter 4

Managing Setup Using Functional Areas

How You Use Functional Areas to Manage Setup

After you enable an offering and configure the opt-in selection of its functional areas and features, you can set up the offering by using its functional areas as a guide.

An "adopt-as-you-go" approach to functional setup gives you the flexibility to set up different functional areas of the offering at different times.

For example, you can begin with setup of the functional areas you require immediately to start transactions. You can then set up other functional areas as you adopt additional offering functionality over time. This setup process is ideal for an enterprise looking for a simpler implementation approach that follows setup best practices.

Functional Areas

When using this method, you start by selecting one of the offerings you enabled. Based on your opt-in configuration, all its enabled functional areas, which include core and optional functional areas, are automatically displayed in a list to guide you through the setup tasks. The display order reflects the sequence in which the functional areas should be set up because setup data of the functional areas listed higher up in the list are usually prerequisite for those shown lower in the list. Any functional area for which setup is mandatory is marked with an asterisk.

Functional areas that are applicable to more than one of your enabled offerings are marked as shared to allow you to evaluate whether they were previously set up during the implementation of another offering. Even if a shared functional area was set up previously, you may still need to evaluate if it requires additional setup data for the offering you're presently implementing.

For some functional areas, Quick Setup may be available to implement its basic functionality quickly. A Quick Setup icon next to a functional area indicates if Quick Setup is available. You can use this task instead of the setup task list to set up those functional areas.

Setup Tasks

For each functional area, a sequenced list of tasks representing the setup best practices according to your opt-in configuration of the features is shown to guide you through optimal implementation requirements. Use the tasks to enter the setup data they represent. Like functional areas, the display order of the tasks always reflects the sequence in which they should be performed to address setup data dependencies.

Required Tasks

Only the required setup tasks are shown by default to minimize your setup effort and to make the offering ready for transactions sooner. However, you can also review the rest of the tasks in the list, which are typically optional or have predefined default values based on common use cases, and decide whether your implementation must change their default setup data.

Tasks with Scope

If any setup data is segmented by a specific attribute or scope, you may need to perform the task iteratively. If so, you must select a qualifying scope value prior to performing the task. You can pick a scope value that was previously
selected, select a new scope value, or create a new scope value and then select it. The selected value is a qualifying attribute of the setup data and therefore, different setup data can be entered for the different scope values.

**Note:** You can't perform a task if you don't have the proper security privileges.

## Set Up an Offering

Use the Setup and Maintenance work area to directly implement an entire offering or the functional areas within an offering.

### Watch video

You need the Functional Setups User role (ORA_ASM_FUNCTIONAL_SETUPS_USER_ABSTRACT) to set up an offering, and a role with task-specific privileges to enter and modify setup data. Refer to the Oracle Fusion Cloud Applications Security Reference for Common Features guide for more information about task-specific privileges.

To set up an offering using its functional areas, follow these steps.

1. Click **Navigator > My Enterprise > Setup and Maintenance**.
2. In the Setup and Maintenance work area, select the offering you want to implement.
3. Review the list of functional areas. If a functional area isn't listed, then it's not enabled. To enable the functional area, follow the steps in the Configure Offerings topic.
4. If you're setting up this offering for the first time, select the functional areas one at a time in the order they're listed. If you're making changes to existing setup data, select the applicable functional area.
5. If Quick Setup is available for the functional area, then you can use Quick Setup to enter data instead of using the related setup tasks. Click the icon and proceed.
6. Enter setup data for a functional area by selecting its tasks in the order they're listed. Select a task to open the page where you enter setup data for that task. To modify existing setup data, just select the relevant task directly.

   **Note:** If the functional area requires any mandatory setup, then only the tasks for entering the required setup data are shown by default. If all setup data is optional for the functional area, then all tasks are shown by default. To see the full list of required and optional tasks for the functional area, select **All Tasks** from the **Show** list.

7. Enter setup data. When you finish, close the page, which returns you to the setup task list.
8. Continue to select other tasks from the list as needed and enter setup data for them.

### Related Topics

- Configure Offerings

## Set Up an Offering with Scope

You can use the Setup and Maintenance work area to directly implement an entire offering or the functional areas within an offering.
You need the Functional Setups User role (ORA_ASM_FUNCTIONAL_SETUPS_USER_ABSTRACT) to set up an offering, and a role with task-specific privileges to enter and modify setup data. For more information about task-specific privileges, refer to the Oracle Fusion Cloud Applications Security Reference for Common Features guide.

To set up an offering using its functional areas, follow these steps.

1. Click **Navigator > My Enterprise > Setup and Maintenance**.
2. In the Setup and Maintenance work area, select the offering you want to implement.
3. Review the list of functional areas. If a functional area isn't listed, then it's not enabled. To enable the functional area, follow the steps in the Configure Offerings topic.
4. If you're setting up this offering for the first time, select the functional areas one at a time in the order they're listed. If you're making changes to existing setup data, select the applicable functional area.
5. If Quick Setup is available for the functional area, then you can use Quick Setup to enter data instead of using the related setup tasks. Click the icon and proceed.
6. Enter setup data for a functional area by selecting its tasks in the order they're listed. Select a task to open the page where you enter setup data for that task. To modify existing setup data, just select the relevant task directly.

   **Note:** If the functional area requires any mandatory setup, then only the tasks for entering the required setup data are shown by default. If all setup data is optional for the functional area, then all tasks are shown by default. To see the full list of required and optional tasks for the functional area, select **All Tasks** from the **Show** list.

7. If the task requires a scope, select a scope value before you proceed. If you previously selected a scope value, then that value is listed in the Scope column. Ensure it's the correct value and if needed, select a different value. You can create a new value, select and add an existing value, or select one from the list of previously selected values. Click **Apply and Go to Task** when you finished your selection. Unless you change it, the selected scope value is used for all tasks that use the same scope.
8. Enter setup data. When you finish, close the page, which returns you to the setup task list.
9. Continue to select other tasks from the list as needed and enter setup data for them.

**Related Topics**

- Configure Offerings

### Update Existing Setup Data

Use the Setup and Maintenance work area to update the existing setup data within an offering.

To update the existing setup data, follow these steps.

1. Click **Navigator > My Enterprise > Setup and Maintenance**.
2. In the Setup and Maintenance work area, select an offering.
3. Select the functional area, and from the list of tasks, select the setup task that you want to update. If you don't find the task in the default list of required tasks, select **All Tasks** from the **Show** list to display all tasks.

   **Tip:** If Quick Setup is available for the functional area, click the icon and proceed to update data instead of using the related setup tasks.
4. Do one of the following:
   - For tasks that require a scope, if you previously selected a scope value, the existing value appears in the **Scope** column. You may retain the same value or update a new scope value. If no value was set, ensure that you set a correct scope value and click **Apply and Go to Task**. The selected scope value is used for all tasks that use the same scope.
   - If the task doesn't require a scope, click the task and proceed.

5. Update the setup data on the corresponding task page.
6. Save the changes and close the page to return to the task list.

---

**Related Topics**
- Configure Offerings

---

**FAQs for Manage Setup Using Functional Areas**

**Why can't I find the offering I want to set up in page header menu?**

You can't set up an offering that you haven't enabled yet. First, follow the steps for configuring offerings and enable the offering you want to set up.

If you don't have permission to configure offerings, then contact someone in your organization who configures the offerings and ask them to enable the offering. Once it's configured and enabled, return to the Setup page and you can find the offering added to the menu.

**Why can't I find a functional area I want to set up for my offering in the list of the functional areas shown on the Setup page?**

For a functional area to appear in the list, it needs to be enabled as part of the feature opt-in configuration.

If you have permissions to configure offerings, select Change Feature Opt In to open the offering Opt In page and enable the functional area. If you don't have permission to configure offerings, contact someone in your organization who configures the offerings and ask them to enable the functional area. Once it's enabled, return to the Setup page and you can find the functional area in the list.

**How can I find a task when I don't know which functional area it's related to?**

Enter the full or partial name of the task in the **Search Tasks** field then click the **Search** icon. The search results are shown in a window. All tasks that meet the search criteria, along with their related functional areas, are shown.

Select the appropriate task name from the search results to go to the task in the **Task** table.
5 Manage Setup Using Implementation Projects

How You Use Implementation Projects to Manage Setup

An implementation project is a list of setup tasks you use to implement your Fusion Applications.

Using this method, you create an implementation project to generate a list of setup tasks, assign tasks to various users who are responsible for managing setup data, and monitor progress of the completion of the setup tasks.

This method is best suited to modify the default setup best practices, or manage setup as a project by assigning responsibility of managing setup data to a broad group of users while monitoring their progress.

Generating a Task List

When you create an implementation project, typically you generate its initial list of tasks by selecting one of your enabled offerings. If you plan to use more than one offering, create a separate implementation project for each one of them. In addition to selecting an offering, which automatically selects its core functional areas, you may also select none, some, or all of the optional functional areas of the offering that are also enabled.

| Note: | If you create an implementation project with more than one offering, you can't use it to export and import setup data. The export and import process fails. |

Using your selection of the offering and the functional areas as a template, a task list hierarchy is generated for the implementation project. The task list hierarchy includes the tasks that are associated at the time with your selected offering and functional areas, and their dependent features that are enabled.

Within the task list hierarchy, the tasks are organized according to prerequisite and dependency requirements of the setup data that they represent. Oracle recommends that you enter setup data in the same sequence as the tasks to avoid errors due to missing prerequisite data.

Modifying a Task List

You can modify the task list hierarchy of an implementation project if needed, by adding, removing, or reordering its tasks. If you modify the task list hierarchy, you must consider and maintain data dependency requirements. Otherwise your users encounter errors when using the implementation project either to enter setup data or to export and import setup data to a different environment.

| Note: | Once an implementation project is created, it no longer has any relationship with the offering and functional areas you used to create it. Therefore, after you create an implementation project, you can't modify its task list hierarchy by changing the opt-in configuration of those offering functional areas, or by changing the task list associated with them. |

Any modification you make to an implementation project's task list is strictly applicable to that implementation project only and doesn't affect any other projects with similar lists of tasks.
Modifications to the task list don’t affect setup data represented by the tasks in the list. Once setup data is entered you can’t identify its source, such as which implementation project or any other method was used to enter or update the data. Likewise, if you remove a task from an implementation project, any setup data entered using the task continues to exist in the environment unless you explicitly delete the data using an appropriate user interface.

Assigning Setup Tasks

You can assign the tasks of an implementation project to the users who are responsible for managing setup data represented by those tasks. Typically, each setup task is assigned to a single individual. However, you can also assign multiple individuals to the same task if your implementation project requires such assignment. Each of the individuals has the flexibility to perform the task and manage setup data independently of the other users assigned to the same task.

If you specify due dates for completing the assigned tasks, it helps you monitor the progress of the task assignments and monitor the progress of the overall implementation project. If you assign multiple people to a task, you can assign the same due date to each person or you can assign a different due date to each assigned individual.

You can reassign tasks to a different user, or specify a new due date at any time.

| Note: | If you assign a task list to a user, then all the tasks included in the task list are assigned to that user. |

Manage Setup Using Implementation Projects

Before creating an implementation project, make sure that you configured the offerings and opted into their functional areas and features you plan to use. You need the Manage Implementation Project privilege (ASM_MANAGE_IMPLEMENTATION_PROJECT_PRIV) to create and manage implementation projects.

Watch video

Create an Implementation Project

To create an implementation project, follow these steps:

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select Manage Implementation Projects from the Tasks panel tab.
3. On the Manage Implementation Projects page, select Create from the Actions menu, or click the Create icon.
4. On the Create Implementation Project: Basic Information page, enter a meaningful name and a brief description to describe your project.
5. Optionally, assign the project to a user and specify a start date.
6. Click Next. All enabled offerings and functional areas are listed on the Create Implementation Project: Select Offerings to Implement page.
7. Select the offering and its functional areas you want to use to generate the task list for this project.
8. Click Save and Open Project when you complete your selection.
9. A page with the name you specified for your implementation project opens, displaying its task list. The default task list is generated based on your offering and functional area selection in the previous step. You can modify the task list if needed, and begin to assign the tasks to the appropriate users.
Modify an Implementation Project

The default task list generated for an implementation project is always organized in the proper sequence to address data dependency requirements of the setup data they represent. The best practice is to not modify the task list unless it's unavoidable for your business requirements.

You can add, remove or reorder tasks within an implementation project. Before you make any such modifications to your implementation projects, ensure that data dependency requirements aren't compromised.

Add Tasks

To add setup tasks to an implementation project, follow these steps:

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select Manage Implementation Projects from the Tasks panel tab.
3. On the Manage Implementation Projects page, open the implementation project you want to modify to view its task list hierarchy.
4. Select the task or task list you want to add the new task after, and click the Add icon.
5. In the Add Task Lists and Tasks page, search for the task or task list you want to add, select it, and click Apply. Your selection is added after the task or task list you selected in the previous step.
6. Repeat search select and apply to add additional tasks or task lists, as required. Click Done when you finished to return to your implementation project.

Reorder Tasks

To reorder setup tasks of an implementation project, follow these steps.

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select Manage Implementation Projects from the Tasks panel tab.
3. On the Manage Implementation Projects page, open the implementation project you want to modify to view its task list hierarchy.
4. Select the task you want to move.
5. Click Actions > Reorder.

Follow the same steps to move a task list.

Remove Tasks

To remove setup tasks from an implementation project, follow these steps.

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select Manage Implementation Projects from the Tasks panel tab.
3. On the Manage Implementation Projects page, open the implementation project you want to modify to view its task list hierarchy.
4. Select the task or task list you want to remove.
5. Click the Remove icon.

| Note: | When you remove a task, any setup data you entered using the task isn't removed. |
Assign Setup Tasks

If users with various functional responsibilities within your organization are entering setup data related to their functional expertise, then assign the appropriate setup tasks to those users. Assign due dates to monitor their progress. If needed, you can also reassign tasks from one user to another.

Initial Assignment

To assign setup tasks to functional users for the first time, follow these steps:

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select Manage Implementation Projects from the Tasks panel tab.
3. On the Manage Implementation Projects page, open the implementation projects whose tasks you want to assign to users.
4. Select one or more tasks or task lists from the task list hierarchy.
5. Click Assign Tasks to go to the Assign Tasks window.
6. Search and select one or more users to whom you want to assign your selected tasks or task lists and click Apply. Selected users are added to the Assigned Users table in the Assign Tasks window.
7. Repeat search, select and apply to add additional users if needed. Click Done when you finish adding to return to the Assign Tasks window.
8. To assign the same due date to all the assigned users, select the Assign same date check box.
9. To assign a different due date to each assigned user, click the Due Date column in the Assigned Users table and select a due date for each assigned user.
10. Add notes for your assigned users, if necessary. Click Save and Close to return to the implementation project.

Reassignment

To reassign setup tasks from one user to another, follow these steps:

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select Manage Implementation Projects from the Tasks panel tab.
3. Click Overview.
4. On the Implementation Projects: Overview page, from the Assigned Users table, search and select the implementation project whose assignment you want to change.
5. Click the Assignment Details tab in the Implementation Project Details region.
6. Search and select the task whose assignment you want to change and click Reassign Tasks.
7. In the Reassign Tasks window, select the user to whom you want to reassign the task from the New User menu.
8. Select a new due date if necessary.
9. Click Save and Close.
10. Repeat the steps to reassign more tasks if necessary.
How You Use Assigned Tasks to Enter Setup Data

If you're assigned setup tasks from an implementation project, then a consolidated list is presented with all tasks assigned to you. Use each task from the list to enter setup data that the task represents.

If you have a long list of assigned tasks, you can filter the list by due date, task status, or implementation project name to find a task more easily. In addition, you can search for a specific task in the list by the task name.

Note: You must have the proper security privileges to perform a task.

Tasks with Scope

If any setup data is segmented by a specific attribute or scope, you may need to perform the task iteratively. If so, you must select a qualifying scope value prior to performing the task. You can pick a scope value that was previously selected, select a new scope value, or create a new scope value and then select it. The selected value is a qualifying attribute of the setup data and therefore, different setup data can be entered for the different scope values.

Predecessor Tasks

Some setup tasks may represent setup data that are a prerequisite for other setup data. These setup tasks are known as the predecessor tasks.

Your assigned task list will indicate if any of the tasks has dependency on a predecessor task and will provide the following information:

- Which tasks are the predecessors of a given task.
- What are the present statuses of the predecessor tasks.
- What statuses are recommended for each of the predecessor task before entering setup data.

Setting Task Status

By default the status of all assigned tasks are set to Not Started. When you start to enter data for a task, you can change the task status to In Progress and when you finish entering data you can change it to Completed. Although status of a task doesn’t determine whether or not you can continue to enter setup data for the task or whether you can export and import the data, it helps the implementation manager monitor the progress of the assignments.

Adding Notes

You can add a file, URL, or free-format text as notes to your assigned tasks. These notes are accessible not only to you, but also to the implementation manager and other assignees if multiple users are assigned to the same task. This helps you communicate and collaborate with others assignees.
Enter Setup Data Using Assigned Tasks

You can enter setup data using assigned tasks from the Assigned Implementation Tasks page.

Watch video

To enter setup data using assigned tasks, follow these steps:

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select Assigned Implementation Tasks from the Tasks panel tab.
3. On the Assigned Implementation Tasks page, find the task for which you want to enter data. Use filters if necessary to help you find the task.
4. Check if the task has dependencies on predecessor tasks. If so, check the statuses and recommended statuses for the predecessor tasks.
5. Click Go to Task to go to the page for entering setup data for the task. You need task-specific privileges to perform this step. Refer to the Oracle Fusion Cloud Applications Security Reference for Common Features guide for more details on task-specific privilege requirements.
6. If the task requires a scope, then select a scope value. If you previously selected a scope value then that value is listed in the Scope column. Verify that the correct scope value is selected and if needed, select a different value by clicking it. You can Create a new value, Select and Add an existing value, or select one from the list of previously selected values. Click Apply and Go to Task when you finish your selection. The selected scope value is used for all tasks that use the same scope unless you change it.
7. Enter the setup data. When you finish, close the page to return to the setup task list.
8. Click the icon in the Status column to change status.
9. Click the number in the Notes column to add a note if necessary.
10. Select other tasks from the list and repeat the steps to enter setup data for them.

How You Monitor Progress of Implementation Projects

Several graphical reports are available to monitor and analyze the progress of the assigned tasks in your implementation project.

You can drill down on the graphs on the Overview page to get all the information to track the progress of your project.

Assignment by Status

This pie chart shows the statuses of the assigned tasks as percentages of the total number of tasks in the implementation project. The pie chart also shows the actual number of tasks with the specific status. The task statuses are predefined and used to indicate the progress. The available statuses are as follows:

- Not Started
- In Progress
- Completed
- Execution Frozen
- Submitted
Assignment by Due Dates
This stacked column graph shows the number of assignments with due dates in various predefined time periods, broken down by different task statuses. Time periods are represented by columns while task statuses are represented by stacks within each column. The report compares due dates of the assigned tasks with the current date to determine which time period a task belongs to. The predefined due date periods are as follows:

- Past Due (one week or more)
- This Week
- Next Week
- In 3 Weeks
- In 4 Weeks
- After 4 Weeks
- None (no due date)

Task Status by Task List
This stacked column graph shows the total number of tasks for each of the task lists in an implementation project as columns. The total number includes tasks from all subsequent levels of the task list. Each column is further broken down by task statuses, which are represented by stacks within a column. Since the task lists are organized in a hierarchy in an implementation project, the graph displays only the root nodes of an implementation project at first. You can drill down on each graph to view the next level of details.

Top 5 Assigned Users with Incomplete Tasks by Due Dates
This stacked column graph shows the top five users who have the most number of incomplete tasks, such as tasks with a status anything other than Completed, as columns. Each column is further broken down by due date periods, which are represented by stacks within a column.

Top 5 Task Allocations
This stacked column graph shows the top five users with the most assignments and is filtered by due date periods. Each user’s allocation is further broken down by task statuses, which are represented by stacks within a column. The default filtering is set to This Week.

Related Topics
- Monitor Progress of an Implementation Project

Monitor Progress of an Implementation Project
Use the Implementation Projects: Overview page to monitor the progress of an implementation project. You need the Review Implementation Project Overview privilege (ASM_REVIEW_IP_OVERVIEW_PAGE_PRIV) to perform this procedure.
Monitor Implementation Progress

To monitor the progress of an implementation project, follow these steps:

1. Click **Navigator > My Enterprise > Setup and Maintenance**.
2. In the Setup and Maintenance work area, select **Manage Implementation Projects** from the Tasks panel tab.
3. On the Manage Implementation Projects page, click **Overview**.
4. On the Implementation Projects: Overview page, search and select the implementation project you want to monitor from list of projects.
5. In the Implementation Project Details region:
   - Click the Assignment Status tab to view the Assignment by Status and the Assignment by Due Date reports.
   - Click the Assignment Status by Task Lists tab to view the Assignment Status by Task List report.
   - Click the Resource Status tab to view the Top 5 Assigned Users with Incomplete Tasks by Due Dates and the Top 5 Task Allocations reports.

FAQs for Manage Setup Using Implementation Projects

Why doesn't my implementation project show the tasks for a functional area or feature I recently enabled?

If you enabled a functional area or feature after creating the implementation project, then the implementation project won't show the tasks related to the newly enabled functional area or feature.

The task list for an implementation project is created based on the enabled status of the functional areas and features at the time you created the implementation project. Once the task list is generated, it doesn't change if the opt-in configuration changes at a later time.

Why do my implementation projects include some common tasks regardless of which offering I use to create it?

Every offering is self-contained, for example, its default setup task list contains all tasks, including the prerequisites, to complete its end-to-end implementation. If there are setup tasks that are needed by multiple offerings, then each of them include those tasks.

Does a common task duplicate setup data if I use it in multiple implementation projects?

No, a task used in multiple implementation projects doesn't create duplicate data. Setup data isn't segmented by an implementation project or any other method you use to enter it.
Each task points to the same setup data irrespective of the implementation project from which you perform it. Therefore, when you use a task from a different implementation project, you can also review the existing data and update it if necessary.

**How can I see what types of setup data I enter using an implementation project?**

An implementation project shows the hierarchy of setup tasks by default. You can toggle to view the business object hierarchy instead.

Each business object represents a type of setup data. The sequence of the business objects in the hierarchy indicates the order in which the setup data is exported and imported when the implementation project is used for export or import processes.

**Why didn't the task show as completed when I returned to my assigned task list after entering data?**

After entering setup data, when you return to the assigned task list, it doesn't necessarily mean that you have completed entering data. You may need to return to the task to enter additional information. Therefore, a task is never marked as completed automatically.

When you know that you finished entering all data necessary for the task, you can set the task status to completed.

**Why did a common task I already performed and set to completed not show as completed in every instance of the task across multiple implementation projects?**

You must set the task status individually for each task in each implementation project. The setup data for a task might need a different set of data for a different implementation.

The status of a task doesn't update based on its status in a previous implementation. For example, you implement Financial Control and Reporting and complete the currency setup. Later, when you implement Procurement, you want a few additional currencies for paying suppliers but not for financial reporting.

**What happens if I change the task list of an implementation project after I start entering data?**

You can modify an implementation project’s task list at any time. Your changes become effective immediately. If you add a new task, it becomes immediately available for assignment, status reporting, and execution.
If you remove any task, it doesn't remain a part of the task list any longer. However, any data entered using the task isn't removed.

How can I view implementation-specific reports?

You can download and print a set of reports at each level of the implementation task list hierarchy. These reports show the relevant information for the task list and all dependent task lists and tasks.

The available reports are the Setup Task Lists and Tasks report, the Related Business Objects report, and the Related Enterprise Applications report.
6 Manage Setup Using CSV File Packages

Export and Import of CSV File Packages

When you enter or update a large volume of setup data, using the setup task UI to manage them individually may not be the most efficient method.

To create or update setup data in bulk, use the export and import of CSV file packages. Use CSV file packages to manage setup data of a specific task or a group of tasks associated with a functional area or offering.

Export and Import CSV File Packages

Watch video

To export and import CSV file packages, you must have the Application Implementation Consultant role. You also require additional roles as specified in the Additional Access Required for Exporting and Importing Setup Data topic if you're exporting tasks related to specific business objects.

Alternatively, you can export and import CSV file packages if you have these privileges:

- Submit Export Setup Data Process (ASM_SUBMIT_EXPORT_SETUP_DATA_PROCESS_PRIV)
- Submit Import Setup Data Process (ASM_SUBMIT_IMPORT_SETUP_DATA_PROCESS_PRIV)
- Task-specific privileges

For detailed information about task-specific privileges, refer to the Oracle Applications Cloud Security Reference for Common Features guide.

Note: You can't export or import seeded data because it's created and updated when an environment is created or updated.

Export Setup Data to a CSV File

To export setup data to a CSV file, follow these steps:

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select the offering whose task requires setup data entry using CSV file.
3. Identify the setup data as appropriate:
   - For all tasks associated with the offering, click Actions > Export to CSV File.
   - For all tasks associated with a functional area, select the functional area and click Actions > Export to CSV File.
   - For specific tasks:
1. Select the appropriate functional area and go to the Tasks table.

2. Select Columns > View > Actions to make the applicable task actions visible.

3. Select the task, and from the corresponding Actions menu, select Export to CSV File.

   **Note:** The Export to CSV file option is disabled if the task doesn't support export.

4. Select Create New. You can export all existing setup data represented by the task.

   - If Scope is supported for any of the selected setup tasks, you can select appropriate scope values to filter the setup data you want to export.
   - You can also download the template for managing setup data without exporting the existing setup data in the environment. To do so, select the Export only template files check box.

5. Click Submit to start the export process.

6. Select Export to CSV file for the offering, or functional area, or task as appropriate, to see the latest process. Monitor the process at any level until it completes.

7. Select the process after it’s complete and review the results. Verify that the process completed without any error before you download the CSV file package.

   If there are more than one business objects associated with the task, you may find more than one CSV files.

**Modify Setup Data in a CSV File**

To enter or modify setup data before importing it into the target environment, you need to edit the CSV file. While editing, ensure that you maintain the exact format for dates, numbers, and any other value that's present in the original exported CSV file.

**CAUTION:** Never delete any CSV file from the downloaded CSV package. Deleting a CSV file will cause errors during import. If you don’t want to include setup data from a particular CSV file, remove all records (rows) from the CSV file except the heading row. Even if that CSV file is empty, you must include it in the CSV package to be imported.

If your file contains setup data with Date attributes, you must specify the correct date format that appears in the exported setup data file.

1. Open the original exported file using a CSV editor such as WordPad and review the date format attribute (for example, 2015/10/25).
2. Open the CSV file using Microsoft Excel.
3. Select the Date attribute and click **Format Cells.** Change the Category to Custom and provide the same format that appeared in the original file. In the same way, provide the format for all date columns.

   **Note:** Depending on the setup data, you must use the custom format to match the correct data format in columns as suggested in the following table.

<table>
<thead>
<tr>
<th>Columns</th>
<th>Data in CSV</th>
<th>Custom Format Cells</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>2018/03/02</td>
<td>yyyy/mm/dd</td>
</tr>
<tr>
<td>Date and Time</td>
<td>2018/02/28 12:07:48:48</td>
<td>yyyy/mm/dd hh:mm:ss.SSS</td>
</tr>
</tbody>
</table>
### Manage Setup Using CSV File Packages

<table>
<thead>
<tr>
<th>Columns</th>
<th>Data in CSV</th>
<th>Custom Format Cells</th>
</tr>
</thead>
<tbody>
<tr>
<td>Long Number</td>
<td>123456789123</td>
<td>Custom &gt; 0</td>
</tr>
</tbody>
</table>

4. Modify the remaining setup data as per your requirement.
   **Tip:** If you require further information to understand how to fill up the CSV file, refer to the Help associated with the task.

5. Save the file in CSV format and immediately close it to prevent any other change. Ensure that the CSV file size doesn't exceed 10MB. The CSV file is ready for import.

If your file contains setup data with special characters for other languages such as Chinese, you might need to specify **Text** as the column format to represent such information.

1. Open Microsoft Excel and click the Data tab.
2. In the **Get External Data** group, click **From Text**.
3. Navigate to and select the CSV file you downloaded.
4. Select **Delimited as Data Type** and click **Next**.
5. Select **Comma** as delimiter and click **Next**.
6. Select **Text** as column data format for all columns and click **Finish**. You can now edit the file.
7. Open the file again using **Notepad++**:
   a. Find and replace all tab characters with commas.
   b. Change the encoding to **Encode in UTF-8**.
8. Save and close the file.
9. Change the file extension from .txt to .csv.
10. Save the CSV into a .zip file. Ensure that the CSV file size doesn't exceed 10MB. You can now import the file.

### Import Setup Data from a CSV File

To upload the new or modified setup data, follow these steps:

1. Select **Import from CSV file** from the Actions menu of an offering, a functional area, or a task as appropriate.
2. Select **Create New**.
3. Select the appropriate .zip file. The application validates that the file corresponds to the selected offering, functional area, or task before you can submit the process.
4. Click **Submit**.
5. Select **Import from CSV file** to see the latest processes. Monitor the process until it completes.
6. Select the process once it completes to review the results. If any error occurs, review the details listed in **Status Details** in the **Business Objects** section. Fix the issues and import again, if necessary.
7. After you import the setup data successfully, you can verify the loaded data by selecting the task from the Setup page.

### Import Offering Setup Data from a CSV File

This procedure shows you how to import offering setup data from a CSV file. You must have the Application Implementation Consultant (ORA_ASM_APPLICATIONIMPLEMENTATION_CONSULTANT_JOB) role to do this task.
To import offering setup data from a CSV file, follow these steps.

1. In the Setup and Maintenance work area, select the offering into which you want to import the setup data.
2. Click Actions and select Import from CSV File > Create New to begin the import process.
3. On the Import Setup Data from CSV File page, click Browse.
4. Select the CSV file package containing the exported setup data and click Open. The details of the package appear.
5. Verify the details to make sure you selected the correct CSV file. If the details appear to be from another CSV file, click Update and select the correct file.
6. Expand the Import Options section.
   - The Pause process each time an error occurs option is selected by default. If an error occurs, the import process pauses so that you can take corrective action and resume the import. If you don’t want the import process to be interrupted even if there are errors, deselect the option. However, note that if any prerequisite data fails, additional dependent data might not be imported correctly.
   - The Pause process each time manual import setup data is required option is selected by default. The import process pauses each time there’s some data that you must manually import. You can deselect this option if the data to be imported manually already exists in your target environment.
7. Click Submit. The import process begins.
8. To review the import summary after the process completes, go to Actions > Import from CSV File and click the process that you submitted. The Import Setup Data from CSV File Results page appears with details.
9. In the Post-Import Tasks section, check and complete if any task is listed.

**CAUTION:** If post-import tasks are listed and you don’t complete them, the imported data won’t be ready for use.

10. In the Business Objects section, review the status of the imported business objects and take suggested action if any errors are reported.

### Compare Task Setup Data

As a best practice, you can compare the exported setup data of a task before you import it into an environment.

**Watch video**

For example, you have made some changes to the setup data in a test environment and exported it. Now, you want to import the same data into a production environment. But before you import, you can compare the exported data of the test environment with the existing production data or another configuration package. You can preview how the setup data in production will change after the import. To do the comparison, you must have the Application Implementation Consultant role (ORA_ASM_APPLICATION_IMPLEMENTATION_CONSULTANT_JOB).

To compare task setup data, follow these steps.

1. In the production environment, go to the Setup and Maintenance work area.
2. In your offering, navigate to the setup task for which you want to compare the setup data.

   **Tip:** If you can’t see your task, click **Show > All Tasks**. If you don’t see the Actions column, click **View > Columns > Actions** to enable it.

3. Select the task and click **Actions > Compare Setup Data > Create New**. The compare setup data process begins.

4. On the Compare Setup Data page, for Configuration 1, click the CSV File Package list and select **Upload New**.

5. On the Upload Setup Data page, browse and select the CSV file package containing the exported task setup data and click **Open**.

6. In the CSV File Package Details section, verify the details to be sure of selecting the correct exported file. If it’s not the correct file, click **Update** to browse and select the correct file.

7. For Configuration 2, the option **Data in this environment** is selected by default to compare with the existing data in the environment. But if you want to compare with another configuration package, click **Source** and upload another configuration package file.

8. Enter a name in the **Process Name** field.

9. Click **Submit**. The comparison process starts.

10. To review the comparison summary after the process completes, go to **Actions > Compare Setup Data** and click the process that you submitted. The latest process appears at the top of the list. The Comparison Process Results page appears with details.

11. Review the details in each section. The details from the CSV file package and the production environment are separately displayed so that you can compare the results.

12. Examine the contents and check for discrepancies, if any.

   **Note:** Configuration 1 refers to the contents of the CSV file package, and Configuration 2 refers to the data in the production environment. For detailed description of the comparison results, see topic Setup Data Comparison Results.

13. Click the value in the relevant column. A spreadsheet appears listing the discrepant details.

14. Scroll through the listed entries to examine the details. If you need to correct any data before the import, make sure that the modifications are included in the exported files you selected for comparison.

   **Note:** Importing the CSV file doesn’t delete data records in the production environment. Therefore, if you want to remove anything from the production data, you must manually delete the specific records.

15. Import the CSV file package once you’re satisfied with the comparison results and have made the necessary changes in the CSV file package and the production environment.

---

**Automate Export and Import of CSV File Packages**

You can use the SOAP web services or the REST APIs if you want to export and import CSV file packages outside of the Setup and Maintenance work area.

To submit export and import processes using web services or APIs, you need the Application Implementation Consultant role. Even if you don't have the Application Implementation Consultant role, you can submit the processes if you have these privileges:

- Submit Export Setup Data Process privilege
- Submit Import Setup Data Process privilege
- Task-specific privileges
Refer to the *Additional Access Required for Exporting and Importing Setup Data* topic to know if you need access to any additional roles. For detailed information about task-specific privileges, refer to the *Oracle Fusion Cloud Applications Security Reference for Common Features* guide.

The following graphic represents a high-level overview of the process to be followed for automating the export and import of CSV file packages.

**SOAP Web Services and REST APIs**

Refer to the following documents for detailed information about using web services and REST APIs to export and import CSV file packages.

- In the *Oracle Fusion Cloud Applications SOAP Web Services for Common Features* guide, go to *Business Object Services > Setup Data Export and Import.*
• In the *REST API for Common Features in Oracle Fusion Cloud Applications* guide, go to the Tasks section and refer to these topics:
  - Setup Offering CSV Exports
  - Setup Offering CSV Imports
  - Setup Offering CSV Template Exports
  - Setup Task CSV Exports
  - Setup Task CSV Imports
  - Setup Task CSV Template Exports

**Offering, Functional Area, or Task Code**

To initiate the export or import process using an API, you must provide the code of the offering, functional area, or task. You must also have the Application Implementation Consultant role.

To find the relevant code, follow these steps:

1. Click **Navigator > My Enterprise > Setup and Maintenance**.
2. In the Setup and Maintenance work area, click **Manage Setup Content** from the Tasks panel tab.
3. Follow these instructions to obtain the required code:

<table>
<thead>
<tr>
<th>To search for the code of an offering or a functional area</th>
<th>To search for the code of a task</th>
</tr>
</thead>
<tbody>
<tr>
<td>a. On the Manage Setup Content page, click <strong>Manage Offerings and Functional Area</strong>.</td>
<td>a. On the Manage Setup Content page, click <strong>Manage Task Lists and Tasks</strong>.</td>
</tr>
<tr>
<td>b. In the Search field, select <strong>Offerings or Functional Area</strong> depending upon the code you’re searching for, and click Search.</td>
<td>b. In the Search field, select <strong>Tasks</strong> and click Search.</td>
</tr>
<tr>
<td>c. In the search results, click the name of the offering or the functional area.</td>
<td>c. In the search results, click the name of the task.</td>
</tr>
<tr>
<td>d. On the Enter Basic Information page, look for value that appears against <strong>Code</strong>.</td>
<td>d. On the Task page, look for value that appears against <strong>Code</strong>.</td>
</tr>
<tr>
<td>e. Copy the code and use it where necessary.</td>
<td>e. Copy the code and use it where necessary.</td>
</tr>
</tbody>
</table>

**Apply Scope to Filter Exported Setup Data**

When you export setup data using web services or APIs, you can optionally apply scope to filter the data. To apply scope, you must provide values to the following parameter attributes.

- **BusinessObjectCode** - Code of the business object whose attribute is used as the scope
- **AttributeName** - Name of the attribute of the business object used as the scope
- **AttributeValue** - Value of the named attribute that defines the filter criteria
Follow these steps to find values for required parameters.

1. Follow the procedure in the Export and Import CSV File Packages topic and select these options.
   - The same offering, functional area or task for which you want to automate the export process.
   - The same scope-enabled business objects and their values to be used as the filter criteria in the automation process. Also note the names of the selected business objects.
2. Complete the export and save the downloaded CSV file package. The attribute values from the downloaded files are used in the filter criteria when running the APIs.
3. Complete these steps to find the code of the business object whose attribute is used as scope.
   a. In the Setup and Maintenance work area, select Manage Setup Content from the Tasks panel tab.
   b. On the Manage Setup Content page, click Manage Business Objects.
   c. Search for the business object that you identified in step 1 to set the scope and click that business object from the search results.
   d. Note down the code of the business object so that you can use it as the value for the BusinessObjectCode parameter in the API.
4. Find the list of attributes that you want to use as filters and note down their values.
   a. From the CSV file packages exported and saved as instructed in step 2, find and open the file that has the same name as the business object used as scope.
   b. Note the column names and their values you want to use as filters. Use the column names as values for the AttributeName parameter and the column values as values for the AttributeValue parameter in the API.

Modify Setup Data in a CSV File
To enter or modify the setup data in the CSV file, follow these steps:

1. Extract files from the downloaded CSV file package to a local folder.
2. Open Microsoft Excel and click the Data tab.
3. In the Get External Data group, click From Text.
4. Navigate to and select the CSV file you downloaded.
5. Select Delimited as Data Type and click Next.
6. Select Comma as delimiter and click Next.
7. Select Text as column data format for all columns and click Finish. You can now edit the file.
8. Make the necessary changes and save the CSV into a .zip file. Make sure that the CSV file size doesn't exceed 10MB. You can now import the file.
7 Setup Data Export and Import

Overview of Setup Data Export and Import

Any implementation of Fusion Applications usually requires migrating setup data from one environment to another at various points in the subscription lifecycle.

For example, a subscribed offering is typically set up in the test environment first, and is moved to the production environment only after proper testing and verification. Setup export and import processes help you migrate setup data from test to production.

Two distinct methods are available for migrating setup data:

- Export and import an entire offering or any of its functional areas. In this method, setup data of the business objects associated with the offering or the selected functional area is migrated.
- Export and import an implementation project. In this method, setup data of the business objects associated with the implementation project is migrated.

Note: You can't combine the export and import processes of these different methods. When an offering or functional area is exported, that setup data can only be imported using the same offering or functional area. Similarly, when an implementation project is exported, that setup data can only be imported using implementation project-based import.

Key Information About Setup Data Export and Import Processes

Use the information in this topic to effectively manage the setup data export and import processes.

Here are the key components of the setup data export and import process.

- Setup Business Objects
- Configuration Packages
- Scope to Filter Exported Setup Data
- Importing Feature Opt-In
- Setup Data Update Rules During Import
- Import Sequence of Setup Data
- Export and Import Process Results

Setup Business Objects

Setup business objects are the logical representations of setup data. The export and import processes use these business objects and their associated web services to read and write the appropriate set of setup data from source to the target environments respectively.
Configuration Packages
A configuration package is the medium used to move setup data from one environment to another. When you export setup, a configuration package is created which includes the following:

- A list of setup tasks based on the offering, functional area or implementation project you used for the export process.
- The business objects associated with those tasks.
- Exported setup data of those business objects

After an export process runs successfully, you can download the configuration package as a .zip file. You can then move this configuration package to the environment where you plan to import the same setup, upload the file, and run the import.

Scope to Filter Exported Setup Data
When a business object is exported, all its setup data (except the ready to use data that’s not yet modified) is exported by default. You may optionally select one or more Scope values to filter setup data of the business objects and limit the exported data. The resulting configuration package from that export process contains only the setup data that matches the Scope criteria you specified. However, if you include the ready to use setup data in scope, it doesn't get exported unless it was previously modified. This condition applies to the following ready to use setup data:

- Application Taxonomy
- Application Reference Data Set
- Application Reference Data Set Assignment
- Application Lookup
- Data Security Policy
- Application Tree Structure
- Application Tree Label
- Application Tree
- Application Flex Value Set
- Application Descriptive Flexfield
- Application Extensible Flexfield
• Application Key Flexfield

Additionally, make sure that you deploy the ready to use setup data for the following business objects:

• Application Descriptive Flexfield
• Application Extensible Flexfield
• Application Key Flexfield

Note:
• You can't migrate the translation data for these business objects using the Export to CSV File or Import from CSV File functionality. Instead, use the standard export or import functionality that uses XML files. For details, see Export Setup Data Using Offering or Functional Area.
• You can never export user level profile values.

Importing Feature Opt-In

When you export an offering or a functional area, the configuration package includes the opt-in configuration of all their dependent functional areas and features as they were set in the source environment at the time of export. However, the import of the same configuration package doesn't automatically import the opt-in configurations to the target environment.

You may choose to import the opt-in configuration from the source to the target when you import the configuration package. The import process enables the dependent functional areas and features that were enabled in the source but aren't enabled in the target. The opt-in configuration of any other dependents in the target remains unchanged.

Note: This option isn’t available when you use an implementation project to export and import setup data.

Setup Data Update Rules During Import

When you import a configuration package to the target environment, setup data in the target is modified as follows:

• If a record exists in the configuration package but doesn't exist in the target, then import creates the record.
• If a record doesn't exist in the configuration package but exists in the target, then import doesn't modify the record in the target.

Note: Import doesn't delete the records in the target that don't exist in the configuration package. You must delete these records or make them obsolete manually, if necessary.

• If a record exists both in the configuration package and in the target, then:
  o If all attribute values are the same, import doesn't modify the record in the target.
  o If values of any attributes of the record are different, then import updates the record in the target with the values in the configuration package.

Import Sequence of Setup Data

Some setups are prerequisites for other setups and thus, have data dependencies. Therefore, the sequence in which setup data is imported from a configuration package is important to prevent any failure due to data dependency.
The sequence of the tasks within the offering, functional area or implementation project, which you used during export to create the configuration package, determines the sequence in which their related business objects, and consequently, the setup data are imported. The following business objects, on the other hand, are exceptions to the default task-based sequence rule. They're always exported and imported before any other business objects in the sequence specified in this table:

<table>
<thead>
<tr>
<th>Business Object Name</th>
<th>Business Object ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Taxonomy</td>
<td>FND_APP_TAXONOMY</td>
</tr>
<tr>
<td>Application Reference Data Set</td>
<td>FND_APP_REFERENCE_DATA_SET</td>
</tr>
<tr>
<td>Application Reference Data Set Assignment</td>
<td>FND_APP_REFERENCE_DATA_SET_ASSIGNMENT</td>
</tr>
<tr>
<td>Application Lookup</td>
<td>FND_APP_SET_ENABLED_LOOKUP</td>
</tr>
<tr>
<td>Data Security Policy</td>
<td>FND_APP_DATA_SECURITY_POLICY</td>
</tr>
<tr>
<td>Application Tree Structure</td>
<td>FND_APP_TREE_STRUCTURE</td>
</tr>
<tr>
<td>Application Tree Label</td>
<td>FND_APP_TREE_LABEL</td>
</tr>
<tr>
<td>Application Tree</td>
<td>FND_APP_TREE</td>
</tr>
<tr>
<td>Application Flex Value Set</td>
<td>FND_APP_FLEX_VALUE_SET</td>
</tr>
<tr>
<td>Application Descriptive Flexfield</td>
<td>FND_APP_EXTENSIBLE_FLEXFIELD</td>
</tr>
<tr>
<td>Application Extensible Flexfield</td>
<td>FND_APP__FLEXFIELD</td>
</tr>
<tr>
<td>Application Key Flexfield</td>
<td>FND_APP_KEY_FLEXFIELD</td>
</tr>
</tbody>
</table>

Export and Import Process Results
You can review and analyze results of setup export and import processes. The results show what setup data was exported or imported, and are listed in the order in which the business objects were processed. The results also include information about any errors encountered during the export or import process to help you analyze and resolve those errors. You can download the information about the process results in a file to review them offline.
Review of Setup Data

You can review setup data prior to or after the export or import process using the Setup Data Reports and Comparison Reports.

Setup Data Report
After an export process completes successfully, you can download the setup data reports to review and analyze the data that was exported. You can also save the reports for future reference.

A separate report is generated for each business object processed during export, which shows the data that was exported from that business object. If you specified Scope values to filter exported data, the report shows only the data that matches those Scope values.

Comparison Report
You can use the comparison report to review the differences between setup data in two different environments, such as test and production. For example, before running an import process on your production environment, you may want to compare the setup data in your exported configuration package with that in your production environment to avoid any unwanted override.

The comparison report shows you the following:

- Which data exists in the source only.
- Which data exists in the target only.
- Which data exists in both but is identical.
- Which data exists in both but has differences, and what the differences are.

You can then determine how the production data changes after the import by applying the rules as stated in the section Setup Data Update Rules during Import in the Key Information About Setup Data Export and Import Processes topic.

Related Topics
- Key Information About Setup Data Export and Import Processes

Best Practices for Migrating Setup Data from Test to Production

The following best practices help you optimize setup data migration between your test and production environments.

Prepare Environments for Migration
When exporting and importing, the Oracle Cloud Applications revision of both source and target environments must be the same. Ensure that your test and production environments are at the same revision level before your export and import.
Some setup data may not be supported for automatic migration through export and import. Review the Setup Task Lists and Tasks report from the Offerings page to identify the setup tasks that don’t have associated setup services. Setup data of these tasks require you to migrate them manually to production using an alternative method.

Manage Setup Data in Gold Environment

If you use a Gold environment to manage your setup data, follow these steps.

1. Enter setup data in the Gold environment.
2. When ready to verify, export the setup data from the Gold environment and import into test.
3. Verify setup data in the test environment.
4. If the setup data requires update, repeat the previous steps with the updates.

**Note:** Always maintain setup data in the Gold environment, because this environment is used to record and manage your setup data. Never update data directly in the test environment. Otherwise, the Gold environment no longer remains the source of truth for your setup data.

5. After setup data passes verification, export from the Gold and import into the production environment.
6. In the next testing cycle, if the test environment requires a refresh from the production environment, use production to test (P2T) refresh cloud service.
7. If the Gold environment requires refreshing setup data from the production environment, you can use production to test (P2T) refresh, and synchronize your Gold environment with your production environment.

**Note:** If you follow the best practices, you may never require to refresh the Gold environment with the setup data in the production environment.
Manage Setup Data in Test Environment

If you don't use a Gold environment, but use the test environment for both maintaining and verifying setup data, follow these steps.

1. Enter and verify setup data in the test environment.
2. After setup data passes verification, export from the test and import into the production environment.
3. If the test environment requires refreshing with setup data from the production environment, use production to test (P2T) refresh cloud service.

Additional Points to Consider

Here are some additional points to consider while exporting and importing setup data.

1. Ensure that all setup data is thoroughly tested and verified before you import into the production environment. Similarly, if export and import processes aren't available for any setup data and you enter it manually into the production environment, ensure that you created and verified the same data in your gold and test environments first before entering it into the production environment.
2. If you enter any setup data manually into the source environment (Gold or Test as applicable), as well as into the target environment (Test or Production as applicable), and later use the export and import processes to migrate the same data, the import process might fail. This happens because those records are rarely an exact duplicate of each other in both the environments. As a result, row key validation of those records fail during import.
3. When exporting setup data using an implementation project, export only one offering at a time. For more details, refer to the topic Setup Data Export and Import Using Implementation Project.
4. Use the scope value to limit the volume of exported setup data. Scope is particularly useful when you're migrating only the incremental changes to setup data after you completed the initial deployment of an offering to the production environment.
5. Source control the exported configuration package files to keep a history of setup changes that were applied to the production environment.
6. Consider running comparison of the setup data in the configuration package file with that in the production environment before starting the import process. This lets you review how import changes the production data and help you to avoid making unwanted changes in production. For more details, refer to the topic Setup Data Comparison Results.
7. Don't ignore the tasks you must perform before and after import. You must migrate their data manually. Otherwise, setup data in production remains incomplete, causing errors during transaction processing.
8. If you're implementing multiple offerings at the same time and importing their setup data into production concurrently, then you must import those offerings in the same sequence as specified in the following section to avoid errors related to data dependencies.

**Offering Import Sequence When Migrated Concurrently**

This table lists the sequence in which you must import offerings when you implement multiple offerings at the same time and import their setup data into production concurrently:

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Family</th>
<th>Offering</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>HCM</td>
<td>Workforce Deployment</td>
</tr>
<tr>
<td>2</td>
<td>HCM</td>
<td>Compensation Management</td>
</tr>
<tr>
<td>3</td>
<td>HCM</td>
<td>Workforce Development</td>
</tr>
<tr>
<td>4</td>
<td>Financials</td>
<td>Financials</td>
</tr>
<tr>
<td>5</td>
<td>Financials</td>
<td>Oracle Fusion Accounting Hub</td>
</tr>
<tr>
<td>6</td>
<td>HCM</td>
<td>Incentive Compensation</td>
</tr>
<tr>
<td>7</td>
<td>CRM</td>
<td>Customer Data Management</td>
</tr>
<tr>
<td>8</td>
<td>CRM</td>
<td>Enterprise Contracts</td>
</tr>
<tr>
<td>9</td>
<td>CRM</td>
<td>Marketing</td>
</tr>
<tr>
<td>10</td>
<td>CRM</td>
<td>Sales</td>
</tr>
<tr>
<td>11</td>
<td>Procurement</td>
<td>Procurement</td>
</tr>
<tr>
<td>12</td>
<td>Projects</td>
<td>Project Financial Management</td>
</tr>
<tr>
<td>13</td>
<td>Projects</td>
<td>Project Execution Management</td>
</tr>
<tr>
<td>14</td>
<td>Projects</td>
<td>Grants Management</td>
</tr>
<tr>
<td>15</td>
<td>SCM</td>
<td>Materials Management and Logistics</td>
</tr>
<tr>
<td>16</td>
<td>SCM</td>
<td>Manufacturing and Supply Chain Materials Management</td>
</tr>
<tr>
<td>17</td>
<td>SCM</td>
<td>Order Management</td>
</tr>
</tbody>
</table>
## Setup Data Export and Import Using an Offering or a Functional Area

You may choose to export and import setup data of an entire offering, or limit the processes to one of its functional areas.

This method is a simplified export and import process, which doesn't require understanding complexities of data dependencies and setup tasks.

### By Offering

You typically export and import an entire offering when you migrate setup data of the offering to the target environment for the first time. Setup data related to all enabled functional areas and features of the offering is exported and imported.

### By Functional Area

When setup data specific to a functional area changes over time, you might decide to export and import only the affected functional area. This helps to limit export and import of setup data to a smaller range and therefore, migration processes take less time to complete than that of the entire offering.

If you select a specific functional area to export, only the setup data related to that functional area and its enabled features is exported and imported.

---

### Related Topics
- Setup Data Export and Import Using Implementation Project
- Setup Data Comparison Results

### Table of Functional Areas

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Family</th>
<th>Offering</th>
</tr>
</thead>
<tbody>
<tr>
<td>18</td>
<td>SCM</td>
<td>Price Management</td>
</tr>
<tr>
<td>19</td>
<td>SCM</td>
<td>Product Management</td>
</tr>
<tr>
<td>20</td>
<td>SCM</td>
<td>Supply Chain Financial Orchestration</td>
</tr>
<tr>
<td>21</td>
<td>SCM</td>
<td>Supply Chain Managerial Accounting</td>
</tr>
<tr>
<td>22</td>
<td>SCM</td>
<td>Value Chain Planning</td>
</tr>
<tr>
<td>23</td>
<td>GRC</td>
<td>Risk and Controls</td>
</tr>
</tbody>
</table>
Note: You must ensure that all prerequisite setup data needed by the setup data of the exported functional area is available in the target environment before you start import. Otherwise, the import process might fail.

Same Levels of Export and Import
You must start the import process from the same offering or the functional area that was used to create the configuration package file you want to import. Otherwise, you receive an error message until you upload the correct configuration package file. All setup data in the configuration package file is imported irrespective of whether or not the corresponding functional areas or features are enabled in the target environment.

Setup Data Comparison
You can compare setup data of an offering or functional area in an exported configuration package file with that of the same offering or functional area in an environment. Setup data comparison is integrated with the import process as an option to compare and analyze which setup data is imported. Alternatively, you can also use setup data comparison independent of an import process. For example, to compare how the setup data of an environment has changed over a certain period, you can start the comparison outside of an import process.

Export Setup Data Using Offering or Functional Area
This procedure shows you how to export setup data using offering or functional area. You need the Application Implementation Consultant role (ORA_ASM_APPLICATION_IMPLEMENTATIONCONSULTANT_JOB) to do this task.

Watch video
You also need access to additional roles if you're exporting certain business objects. For more information about these additional roles, refer to the topic Additional Access Required for Exporting and Importing Setup Data.

To export setup data using offering or functional area, follow these steps.

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select the offering you want to export from the Offering menu.
3. To export setup data:
   o For an entire offering, select and open the Actions menu in the page header, and then select Export.
   o For a specific functional area, select and open the Actions menu corresponding to the functional area, and then select Export.
4. Select Create New to create a new export process.
5. Optionally, specify appropriate scope values to filter exported setup data. By default, all existing setup data is exported for each business object processed during export. However, if scope is supported by any of those business objects, you can select scope values to filter the exported setup data. To specify scope values for one or more of the business objects:
   a. Select the applicable business object from the Business Objects table and then click Add. If no related business object supports scope, then the table remains empty.
   b. Search and select the value you want to use as scope for the business object and click Apply.
   c. Repeat the previous step to add more scope values if needed. Click Done when finished.
6. Click Submit to start the export process.
7. Monitor the status of the export process until it completes by selecting **Export** from the **Actions** menu. Up to three most recent processes are listed, and are ordered from newest to oldest. Each process indicates its status at the time, and if it was completed already, then the time stamp when it was processed.

8. While the process is still in progress, you may select the status to view how much progress the process has made at the time. A message shows you how many business objects were already processed out of the total number of objects to be processed. Click **View Progress** to review the details on the business objects that were already processed. Click the **Refresh** button to get the most recent information. Refer to the topic Review of Export and Import Process Results for detailed description of the process results.

9. When the export process completes, select the status link to go to the Export Offering Data Results page. 
   - If the process completes successfully, the status is set to Ready to download.
     - i. Click **Download File** to download the configuration package .zip file and save it at an appropriate location. Use this file to import setup data in the target environment.
     - ii. In addition, review the list of post export tasks. If any tasks are listed, then those tasks aren’t migrated by export and import process. You must migrate that data manually in the target environment.
   - On the other hand, if the process completes with errors, the status displays Ready for error review.
     - i. The Business Objects table shows all business objects that had errors during processing. Refer to the topic Review of Export and Import Process Results for detailed description of the process results.
     - ii. Click **Download Log File** from the page header, which includes the error log of all business objects that experienced error. Alternatively, you can also click **Actions > Download Log File** corresponding to a specific business object to download error log specific to that business object.
     - iii. After correcting the cause of the errors, create a new export process.

**Related Topics**
- Additional Access Required for Exporting and Importing Setup Data
- Review of Export and Import Process Results

**Export a Subset of an Offering or Functional Area Setup Data**

If there were changes to the setup data since the previous export, you don’t have to export the entire setup data for an offering or a functional area. You can select and export only the specific setup data that changed.

*Watch video*

However, to prevent any errors during import, make sure that the prerequisite data is already migrated. To do this task, you need the Application Implementation Consultant role (ORA_ASM_APPLICATION_IMPLEMENTATION_CONSULTANT_JOB). You also need access to additional roles if you’re exporting certain business objects. For more information about these additional roles, refer to the topic Additional Access Required for Exporting and Importing Setup Data.

To export a subset of setup data using an offering or a functional area, follow these steps.

1. Click **Navigator > My Enterprise > Setup and Maintenance.**
2. In the Setup and Maintenance work area, select the offering you want to export from the Offering menu.
3. To export setup data:
   - For an entire offering, select and open the Actions menu in the page header, and then select Export.
   - For a specific functional area, select and open the Actions menu corresponding to the functional area, and then select Export.
4. Select Create New to create a new export process.
5. On the Export Offering Setup Data page, in the Business Objects section, click the Show drop-down list and select All.
6. In the Export column, deselect the check boxes of business objects that you want to exclude from the export. Business objects with a check mark remain selected for export.

   **CAUTION:**
   - If the setup data in any of the excluded business objects is a prerequisite for the imported setup data in the target environment, then the import might fail. Therefore, exclude or include business objects after assessing the dependencies, if any.
   - If the export service used by the selected business objects is also associated with any business object that you excluded, you’re prompted to either export all related business objects or none of them.

7. Optionally, specify appropriate scope values to filter exported setup data. By default, all existing setup data is exported for each selected business object processed during export. However, if scope is supported by any of those business objects, you can select scope values to filter the exported setup data. To specify scope values for one or more of the business objects:
   a. Select the applicable business object from the Business Objects table and then click Add. If no related business object supports scope, then the table remains empty.
   b. Search and select the value you want to use as scope for the business object and click Apply.
   c. Repeat the previous step to add more scope values if needed. Click Done when finished.
   You can also remove a scope value if it’s no longer required.
8. Click Submit to start the export process.
9. Monitor the status of the export process until it completes by selecting Export from the Actions menu. Up to three most recent processes are listed, and are ordered from newest to oldest. Each process indicates its status at the time, and if it was completed already, then the time stamp when it was processed.
10. While the process is still in progress, you may select the status to view how much progress the process has made at the time. A message shows you how many business objects were already processed out of the total number of objects to be processed. Click View Progress to review the details on the business objects that were already processed. Click the Refresh button to get the most recent information. Refer to the topic Review of Export and Import Process Results for detailed description of the process results.
11. When the export process completes, select the status link to go to the Export Offering Data Results page.
   - If the process completes successfully, the status is set to Ready to download.
     i. Click Download File to download the configuration package .zip file and save it at an appropriate location. Use this file to import setup data in the target environment.
     ii. In addition, review the list of post export tasks. If any tasks are listed, then those tasks aren’t migrated by export and import process. You must migrate that data manually in the target environment. For instance, the excluded business objects are listed in the Manual Tasks section. You can download the Manual Tasks Report from the Actions menu.
   - On the other hand, if the process completes with errors, the status displays Ready for error review.
i. The Business Objects table shows all business objects that had errors during processing. Refer to the topic Review of Export and Import Process Results for detailed description of the process results.

ii. Click Download Log File from the page header, which includes the error log of all business objects that experienced error. Alternatively, you can also click Actions > Download Log File corresponding to a specific business object to download error log specific to that business object.

iii. After correcting the cause of the errors, create a new export process.

Related Topics

- Additional Access Required for Exporting and Importing Setup Data
- Review of Export and Import Process Results

Import Setup Data Using Offering or Functional Area

You can import setup data for an offering or functional area. You need the Application Implementation Consultant role (ORA_ASM_APPLICATION_IMPLEMENTATIONCONSULTANT_JOB) to do this task.

Watch video

You also need access to additional roles if you’re importing certain business objects. For more information about additional roles to import these business objects, see topic Additional Access Required for Exporting and Importing Setup Data.

To import setup data for an offering or functional area, follow these steps.

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select the offering you want to import from the Offering menu.
3. If the configuration package you want to import was created by exporting:
   - An offering, select Import from the Actions menu in the page header.
   - A functional area, select Import from the Actions menu corresponding to that functional area.
4. Select Create New to create a new import process.
5. Browse and select the configuration package file that contains the setup data you want to import. View the Configuration Package Details to verify that you selected the correct file.
   - If the offering or functional area selected during export doesn’t match the offering or functional area you chose for the import process, an error message appears. Click the Update button to browse and select the correct file.
6. Expand the **Import Options** section.

   - Best practice is to select the **Compare setup data prior to import** option. If you select this option, the import process automatically runs a comparison of the setup data in the configuration package file with that in the target environment before importing the setup data.

   **Note:** Comparing setup data prior to import requires additional time. You may skip this step by not selecting the **Compare setup data prior to import** option. However, if you skip this step, you can't review how the setup data is similar or different in the source and target, and how the import process changes setup data in the target environment.

   - Optionally, select the **Import feature selection** option to import the opt-in configuration of the offering or functional area you're importing. This imports the enabled dependent functional areas and features of the offering or functional area.

   - The **Pause process each time an error occurs** option is selected by default. If an error occurs, the import process pauses so that you can take corrective action and resume the import. If you don't want the import process to be interrupted even if there are errors, deselect the option. However, note that if any prerequisite data fails, additional dependent data might not be imported correctly.

   - The **Pause process each time manual import setup data is required** option is selected by default. The import process pauses each time there's some data that you must manually import. You can deselect this option if the data to be imported manually already exists in your target environment.

7. Click **Submit** to start the import process.

8. If any setup data requires manual entry before the import can start, a warning message appears. This message shows you the tasks you must perform before submitting the process.

   - If you verified that the setup data for those tasks are already entered in the target environment, click **Submit**.
   - Otherwise, click **Cancel**. Create a new import process after you ensure that the setup data is entered in the target environment.

9. Monitor the import process by clicking **Actions > Import**. Up to three most recent processes are listed and ordered from newest to oldest. Each process indicates its status at the time and, if the process is completed, the time stamp when it was processed.

10. While the process is in progress, you can select the status to view how much progress the process made at the time. A message shows you how many business objects were already processed out of the total number of the objects to be processed. Click **View Progress** to review the details of the business objects that finished processing. Click the **Refresh** button to view the most recent information. Refer to the topic Review of Export and Import Process Results for detailed information about the process results.

11. If you selected the **Compare setup data prior to import** option, once the comparison completes, the status reads **Waiting for comparison review**. Select the status to go to the Import Offering Data Results page to review the comparison results. Refer to the topic Compare Setup Data Using Offering or Functional Area for a detailed description of the comparison results.

12. Click **Continue to Import** from the Import Offering Data Results page to start the import process if you're satisfied with the comparison results.

13. Alternatively, if you didn't select the **Compare setup data prior to import** option, the import process starts automatically.

14. Monitor the process as before, until it completes.
15. If any setup data requires manual data entry during import, the process pauses, and the status reads **Waiting for manual import**.
   a. Select the status to go to the Import Offering Data Results page and review the details.
   b. A list displays the business objects that require manual data entry before import.
   c. For each of the listed business objects, click **Go to task**. This displays a list of related tasks. Select each task to enter the required data.
   d. After you enter the setup data for all the listed business objects, click **Resume** from the Import Offering Data Results page to restart the import process.
   e. Click **Confirm** in the confirmation message that appears to resume the import process.

16. Continue to monitor the process until it completes.

17. If the import process completes successfully:
   a. Review the results to verify successful completion.
   b. If any post import tasks are listed, ensure that their setup data is entered. Otherwise, the setup data remains incomplete, and you experience errors when processing transactions.

18. If the import process completes with errors:
   a. The Business Objects table displays all business objects which encountered errors while processing. Refer to the topic Review of Export and Import Process Results for a detailed description of the process results.
   b. Click the **Download Log File** from the page header level. This includes the error log of all business objects that encountered errors. Alternatively, click **Actions > Download Log File** corresponding to a specific business object to download the error log specific to that business object.
   c. Create a new import process after correcting the errors.

**Related Topics**
- Review of Export and Import Process Results
- Additional Access Required for Exporting and Importing Setup Data
- Compare Setup Data Using Offering or Functional Area

**Compare Offering Setup Data During Import**

You can compare setup data for an offering or functional area during the import process.

[Watch video](#)

You need the Application Implementation Consultant role (ORA_ASMAPPLICATIONIMPLEMENTATIONCONSULTANT_JOB) to import setup data. You also need access to additional roles if you’re importing certain business objects. For more information about additional roles to import these business objects, see topic Additional Access Required for Exporting and Importing Setup Data.

To compare setup data for an offering or functional area during an import process, follow these steps.

1. Click **Navigator > My Enterprise > Setup and Maintenance**.
2. In the Setup and Maintenance work area, select the offering you want to import from the **Offering** menu.
3. If the configuration package you want to import was created by exporting:
   - An offering, select **Import** from the **Actions** menu in the page header.
4. Select Create New to create a new import process.

5. Browse and select the configuration package file that contains the setup data you want to import. View the Configuration Package Details to verify that you selected the correct file.

6. Expand the Import option.

7. Click Submit to start the import process.

8. If any setup data requires manual entry before the import can start, a warning message appears. This message shows you the tasks you must perform before submitting the process.

   a. If you verified that the setup data for those tasks are already entered in the target environment, click Submit.
   b. Otherwise, click Cancel. Create a new import process after you ensure that the setup data is entered in the target environment.

9. Monitor the import process by clicking Actions > Import. Up to three most recent processes are listed and ordered from newest to oldest. Each process indicates its status at the time and, if the process is completed, the time stamp when it was processed.

10. While the process is in progress, you can select the status to view how much progress the process made at the time. A message shows you how many business objects were already processed out of the total number of the objects to be processed. Click View Progress to review the details of the business objects that finished processing. Click the Refresh button to view the most recent information. Refer to the topic Review of Export and Import Process Results for detailed information about the process results.

11. If you selected the Compare setup data prior to import option, once the comparison completes, the status reads Waiting for comparison review. Select the status to go to the Import Offering Data Results page to review the comparison results. Refer to the topic Compare Setup Data Using Offering or Functional Area for a detailed description of the comparison results.

12. Click Continue to Import from the Import Offering Data Results page to start the import process if you're satisfied with the comparison results.

13. Alternatively, if you didn't select the Compare setup data prior to import option, the import process starts automatically.

14. Monitor the process as before, until it completes.

15. If any setup data requires manual data entry during import, the process pauses, and the status reads Waiting for manual import.

   a. Select the status to go to the Import Offering Data Results page and review the details.
   b. A list displays the business objects that require manual data entry before import.
c. For each of the listed business objects, click **Go to task**. This displays a list of related tasks. Select each task to enter the required data.

d. After you enter the setup data for all the listed business objects, click **Resume** from the Import Offering Data Results page to restart the import process.

e. Click **Confirm** in the confirmation message that appears to resume the import process.

16. Continue to monitor the process until it completes.

17. If the import process completes successfully:

   a. Review the results to verify successful completion.
   
   b. If any post import tasks are listed, ensure that their setup data is entered. Otherwise, the setup data remains incomplete, and you experience errors when processing transactions.

18. If the import process completes with errors:

   a. The Business Objects table displays all business objects which encountered errors while processing. Refer to the topic Review of Export and Import Process Results for a detailed description of the process results.
   
   b. Click the **Download Log File** from the page header level. This includes the error log of all business objects that encountered errors. Alternatively, click **Actions > Download Log File** corresponding to a specific business object to download the error log specific to that business object.
   
   c. Create a new import process after correcting the errors.

**Related Topics**
- Additional Access Required for Exporting and Importing Setup Data

---

## Compare Setup Data Using Offering or Functional Area

You can compare setup data outside of the import process. To compare setup data during import, see topic *Import Setup Data Using Offering or Functional Area*.

**Watch video**

You need the Application Implementation Consultant role (ORA_ASM_APPLICATION_IMPLEMENTATION_CONSULTANT_JOB) to do this task. You also need access to additional roles to compare certain business objects. For more information about access to additional roles, see topic *Additional Access Required for Exporting and Importing Setup Data*.

You can compare setup data using offering or functional area, in either of these ways:

- Compare setup data in one configuration package with another configuration package
- Compare setup data in one configuration package with the setup data in the environment

To start the comparison, follow these steps.

1. Click **Navigator > My Enterprise > Setup and Maintenance**.
2. In the Setup and Maintenance work area, select the offering whose setup data you want to compare.
3. If the configuration package you intend to compare was created by exporting:
   - An offering, then select and open the Actions menu in the page header, and then select Compare Setup Data > Create New.
   - A functional area, then select and open the Actions menu corresponding to the functional area, and then select Compare Setup Data > Create New.
4. For Configuration 1, upload the base configuration package file whose data you want to compare with that in the environment or with another configuration file. To upload the configuration package file, follow these steps.
   a. Click the Configuration Package list and select Upload new.
   b. Browse to find the configuration package file, select it and click Open.
   c. Optionally, open Configuration Package Details to verify that you have selected the correct file. If it’s not the correct file, then click Update to browse and select the correct file.
   d. Click Submit to upload the configuration package.
5. For Configuration 2, the option Data in this environment is selected by default to compare with the existing data in the environment. But if you want to compare with another configuration package, click Source and upload another configuration package file.
6. Once the sources are ready, the process for setup data comparison is ready to be submitted. Optionally, you can change the default process name that’s automatically assigned.
7. Click Submit to start the comparison process.
8. Monitor the status of the process by selecting Action > Compare Setup Data. Up to three most recent processes are listed and are ordered from the newest to oldest. Each process indicates its status at the time and, if the process has completed, then the time stamp when it was processed.
9. When the process completes, the status shows Ready for comparison review. Select the status to go to Comparison Process Results to review the details of the results. Refer to the topic Setup Data Comparison Results for detailed descriptions of the comparison results.

Related Topics
- Additional Access Required for Exporting and Importing Setup Data
- Import Setup Data Using Offering or Functional Area
- Setup Data Comparison Results

Setup Data Export and Import Using Implementation Project

If you used an implementation project to enter setup data, then you can use your implementation project to export and import setup data.

In this alternative method, the tasks in your implementation project and their sequence determine the list of setup business objects whose data is exported and imported, and in which order.

**Note:** Even if you used an implementation project to enter setup data, you can still use an offering or a functional area to export and import the same setup data, to ensure that all data dependencies are migrated properly.

Select your implementation project, and create a configuration package to generate the ordered list of business objects for export and import.
Exporting One Offering at a Time

The implementation project you use to create a configuration package must contain only one offering. The import process fails otherwise.

If you included multiple offerings in an implementation project to enter setup data, don’t use it to create a configuration package for setup data export and import. Instead, create new implementation projects with only one offering in each, and use these to create separate configuration packages.

Partial Data Migration

Although best practice is to select an offering and its functional areas to create an implementation project, you may have created an implementation project by selecting specific tasks and task lists instead. Such implementation projects are often created to update and maintain a small set of setup data after the initial migration of an offering to a target environment has completed.

When using such implementation projects to create configuration packages for setup data export and import, consider the following requirements carefully to ensure the success of the process:

- If any setup data in the configuration package has a dependency on any other setup data, then that prerequisite data must be available in your target environment before you start the import process using the configuration package. Otherwise, consider including the prerequisite task in the implementation project before you create the configuration package.
- The sequence of the task list and tasks, and therefore the business objects, in your implementation project must align with the setup data dependency requirements. The import process may fail if you don’t ensure the correct order of the task lists and tasks in the implementation project.

Comparing Setup Data Before Import

When using an implementation project to migrate setup data, the comparison report isn’t integrated with the import process. However, best practice is still to compare the setup data in the exported configuration page with the data existing in the target environment before starting the import process.

Export Setup Data Using Implementation Project

You can export setup data for an implementation project that you already completed setting up. You need the Application Implementation Consultant role (ORA_ASM_APPLICATION_IMPLEMENTATION_CONSULTANT_JOB) to do this task.

Watch video

You also need access to additional roles if you’re exporting certain business objects. For more information about access to the additional roles, see topic Additional Access Required for Exporting and Importing Setup Data.

To export setup data using an implementation project, follow these steps.

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select Manage Configuration Packages from the Tasks panel tab.
3. On the Manage Configuration Packages page, select **Create** from the **Actions** menu, or click the **Create** icon from the Search Results table in the Manage Configuration Packages page to go to the Create Configuration Package: Enter Basic Information page.

4. In the Source Implementation Project:
   a. Select the implementation project you want to use for the setup data export from the **Name** menu.
   b. Leave the default selection for Export, **Setup task list and setup data**, unchanged.

5. In Configuration Package Details, you can use the default field values for **Name**, **Code** and **Description**, or assign unique values.

6. Click **Next** to go to the Create Configuration Packages: Select Objects for Export page.

7. The first table displays the list of business objects whose setup data is exported. The implementation project you selected as the source of this configuration package in the previous step determines the business object list.
   - The **Type** column indicates the export and import behavior of the business object as follows:
     i. If export and import services are available for a business object then the type is **business object service**.
     ii. If the type is specified as **Scope**, then the business object can be used to select a scope value to filter the exported data. However, the setup data of the business object itself is not exported.
     iii. If the setup data of any business object must be migrated manually using alternative methods that are external to setup export and import processes, the type is **Manual data loading**.
   - All business objects whose type is **Business object service** have their **Export** column checked by default. You typically keep this selection unchanged.
   - **Note:** If a business object has identical setup data in both source and target environments, then you can optionally exclude it from export, and consequently, from import, to reduce processing time. However, if any excluded setup data is a prerequisite to import any other setup data in this configuration package, then your import process fails. Therefore, you should use this option cautiously and only when you're certain that the target environment contains the prerequisite data before you start your import process.

8. When you select a business object in the first table, if it supports scope to filter exported setup data, you can select appropriate scope values in the second table.
   - If the business object you selected has predefined scope values, then scope table lists all of them by default. You could decide to remove one or more of the listed scope values but you can't add other values.
   - If the business object you selected supports scope but doesn't have predefined value, then you can add one or more scope values.
     i. Click the **Create** icon in the scope table.
     ii. Search and select each of the values you want to use as scope to export data for and click **Apply**.
     iii. Click **Done** when you finish selecting all desired scope values.

9. Click **Submit** to submit the setup data export process and confirm when the confirmation message appears.

10. Monitor the process from **Manage Configuration Package** until it completes.

11. While the process is in progress, you may select the status to go to the Export and Import Process Results page to view how much progress the process has made at the time. Click the **Refresh** button to get the most recent information. Refer to the topic Review of Export and Import Process Results for detailed descriptions of the process results.

12. Once the export process completes successfully, click **Download** to download the configuration package. Use this .zip file to import setup data in the target environment. Optionally, select the status to go to the Export and Import Process Results page to view the result details.
13. If the export process completes with errors, then fix the errors according to the following instructions.
   a. Select the status to go to the Export and Import Process Result page to view the error details.
   b. Download the log file for the setup business objects with errors by clicking Actions > Download > Log file.
   c. Fix the errors as needed. To modify or enter any data to fix the error, click Go to Task to open the corresponding setup page.
14. Create a new export process after the errors are corrected.

Related Topics
- Additional Access Required for Exporting and Importing Setup Data
- Review of Export and Import Process Results

Import Setup Data Using Implementation Project

You can import setup data for an implementation project. You need the Application Implementation Consultant role (ORA_ASM_APPLICATION_IMPLEMENTATION_CONSULTANT_JOB) to do this task.

Watch video

You also need access to additional roles if you're importing certain business objects. For more information about additional role to import those business objects, see topic Additional Access Required for Exporting and Importing Setup Data.

To import setup data from a configuration package, follow these steps.

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select Manage Configuration Packages from the Tasks panel tab.
3. On the Manage Configuration Packages page, click the Upload button from the Search Results table to go to the Upload Configuration Package page.
4. Click the Browse button to browse and select the configuration package you want to import.
5. Click the Get Details button and review the information in Configuration Package Details and Implementation Project Details to verify that you uploaded the correct configuration package for import. If you didn't upload the correct configuration package file, click the Update button to upload the correct file and verify again.
6. Click Submit to start the upload process.
7. Your configuration package is listed in the Search Results table in the Manage Configuration Package page.
8. Select the configuration package from the Search Results table to view its process details in the Export and Import Processes table.
9. Monitor the upload process until it completes. Once the upload process completes successfully, your configuration package is ready for import.
10. Select the upload process from the Export and Import Processes table and click Import Setup Data.
11. On the Import Setup Data: Enter Basic Information page, click Submit to start the import process with the default settings.
12. You can also make the following modifications before submitting the import process:
   o On the Import Setup Data: Basic Information page, you can change the default process name and description, to help you identify the process later.
   o On the Import Setup Data: Basic Information page, the Pause process each time an error occurs option is selected by default, to indicate that the import process pauses each time it encounters an error. This
gives you an opportunity to take corrective action. You can deselect this option so that the import process continues despite the errors. A summary of all the errors is displayed after the process finishes.

**Note:** If the import process doesn't pause for each error, it doesn't require your attention throughout the process. However, this also increases the possibility of additional business objects failing import due to dependencies.

- The import process also pauses by default for each task that requires manual data loading. To override this pausing, follow these steps:
  - Click Next to go to the Import Setup Data: Select Pause for External Import page.
  - Select Manual data loading from the Type menu.
  - The Pause column displays a check mark for the tasks that require manual data loading before the import can resume. If manual data loading can be performed before or after the import process, this column doesn't display a check mark.
  - Review the list of tasks and deselect the Pause column corresponding to the tasks for which you don't want the import process to pause.

  **Note:** Use this option only when you're certain that the setup data for these tasks already exists in the target environment. Import of setup data whose prerequisite is the data that requires manual data loading may fail if this prerequisite data doesn't exist when the dependent data is imported.

- The import process runs immediately when submitted. However, you can also schedule the import process to start at a certain time. To schedule a time, click Next to go to the Import Setup Data: Schedule and Notifications page. Select Use a schedule and specify a start time.

13. Monitor the import process until it completes. The process status changes according to the state of the process. Select the status to go to the Export and Import Process Results page, and take the appropriate action as follows.

  - **In Progress:** While the process is still in progress, you may review how much progress the process made at the time. Click the Refresh button to get the most recent information.
  - **Completed Successfully:** Review the process results to determine if any setup tasks must be performed manually after the import to properly complete migration of the setup data. If yes, perform those tasks.
  - **Waiting for Manual Import:** If a setup task requires manual data entry before the import process can continue, the status reads Waiting for Manual Import. Click Go to Task for the corresponding business object to open the setup user interface. Alternatively, you can enter the setup data manually. After you enter the required setup data, click Resume from the Export and Import Process Results page, or from the Manage Configuration Packages page to restart the import process.

  - **Waiting to review errors:** If you selected the Pause process each time an error occurs option when you created the import process, this status displays when the import process encounters an error while running. Click Actions > Download log file corresponding to the specific business object to review the error details. Take appropriate corrective action and click Resume from the Export and Import Process Results page, or from the Manage Configuration Package page.

    Optionally, you may skip the business object that generated the error, and continue from the next object. However, skip these business objects only if you’re certain that the error was fixed in the environment, and that the import process doesn’t require reprocessing the business object.

  - **Completed with errors:** When the process completes with errors, click Actions > Download log file corresponding to the business objects with errors, to review the error details.

14. Create a new import process after you correct the errors.
Related Topics
- Additional Access Required for Exporting and Importing Setup Data
- Review of Export and Import Process Results

Compare Setup Data Using Implementation Project

You can compare setup data using an implementation project. You need the Application Implementation Consultant role (ORA_ASM_APPLICATION_IMPLEMENTATION_CONSULTANT_JOB) to do this task.

Watch video

You also need access to additional roles if you're comparing certain business objects. For more information about additional roles for these business objects, see topic Additional Access Required for Exporting and Importing Setup Data.

To compare setup data using an implementation project, follow these steps:

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, run an export process at the target environment to prepare for setup data comparison. Create an implementation project in the target environment that matches exactly the same task lists and tasks as the implementation project you used at your source environment to create the configuration package file you want to import. Use this implementation project to run the export process at the target environment.
3. Once the export process completes, upload the configuration package file from your source environment into the target environment. Follow the same process as needed, to upload a configuration package for import. However, don’t run the import process.
4. Once the upload process completes successfully, select Manage Export and Import Processes from the Tasks panel tab.
5. On the Manage Export and Import Processes page, click Compare.
6. On the Comparison Processes page, select the Create new icon to create a new comparison process.
   a. Select the configuration package you uploaded from your source environment as Source 1. If you have multiple versions of the same configuration package available, then select the correct process date to identify the correct version of the file.
   b. Select the configuration package you created by running the export process at the target environment to prepare for comparison, as Source 2. Like Source 1, if the configuration package you selected for Source 2 has multiple versions available in the target environment, select the correct process date to identify the correct version.
   c. Change the default process name, if required and click Submit.
7. Once the comparison process is submitted, the new process is listed on the Comparison Processes page.
8. The Status column displays the status of the process. Monitor the status until the process completes.
9. When the Status column reads Completed successfully, select the process name to go to the Configuration Package Comparison page to review the details of the results.
10. If the comparison process doesn't complete successfully, select the status to go to the Comparison Process Results page and review the error details.
Setup Data Comparison Results

Setup data comparison results are listed in three sections:

- Comparison Summary
- Comparison Details
- Failed Objects

Comparison Summary

This section provides an overview of the results from comparing the setup data, which includes:

- Total number of business objects compared.
- How many of them processed successfully.
- How many of them failed, if any.
- How many of them have records that exist only in the configuration package created from the source environment.
- How many of them have records that exist only in the target environment.
- How many of them have records that exist in both the configuration package and the target environment, but have some data mismatch.

Comparison Details

This section lists each of the business objects that were compared successfully between the source and target environments. For each business object, details of the records that have data mismatch between the source and target environments are displayed. By default, the list includes only the business objects that have data discrepancies. However, you can select All from the Show filter to also include the business objects that have identical setup data in both the source and target environments.

For each business object, a summary table displays the number of records it has in the following categories. The numbers which aren't zero are displayed as links. Select the numbers to open a detailed report.

- **Only in Configuration 1** displays the records that exist only in the exported configuration package file, but not in the target environment. Therefore, when you import this configuration package, these records are created in the target environment.
- **In Both with Mismatch** displays the records that exist in both the source and target environments. but have different values in one or more of the attributes. Consequently, these records are updated in the target environment with their values in the configuration package when you import. The detailed report displays two rows for each record, with one row each representing the source and target environments.
- **Only in Configuration 2** displays the records that exist only in the target environment and not in the configuration package file. These records therefore, remain unchanged when the configuration package is imported in the target environment. You must use the manual process to remove these records from the target.
• **Identical in Both** displays the records that exist in both the source and target environments, and have identical values in all of their attributes. This column is displayed only when the Show filter is set to All. In addition, this category doesn’t provide any detailed reports on the records and therefore, the number in the summary table is always read-only.

**Failed Objects**

In case the comparison report failed to process any business objects due to errors, this section displays a list of those objects. For each object, you can use the Feature Details icon to view or save its error log file.

**Downloading Reports**

Optionally, click the Download button from the Comparison Details section to download and save the reports.

- The Comparison Report provides .zip files that contain comparison reports for each of the business objects that were processed. For each business object, a report each for Only in Configuration 1, In Both With Mismatch, and Only In Configuration 2, as applicable is provided.
- The Comparison Results report provides a summary of the comparison process and represents the table shown in the Comparison Details section of the user interface.
- The Comparison Process Results Summary provides a summary of the process results, which displays a list of all the processed business objects, and whether their processing completed successfully, or with errors.
- The Comparison Log File provides a detailed log of the entire comparison process.

**Setup Data Reports**

Setup data reports are generated automatically every time you run an export process by using an offering, functional area or implementation project.

You can also generate setup data reports for an offering or functional area without running an export process. However, this option isn’t available for implementation projects.

You can download and use these reports to verify the setup data as it exists in the environment. You can also save the reports as documents of the state of your setup data at the time of export, for future reference.

**Generate Setup Data Reports**

You can generate setup data reports and download them for reviewing. You can download a consolidated report for all exported business objects or a report for a specific business object.

Watch video

To download and review setup data reports, follow these steps.

1. If you ran an export process already and want to use the setup data reports that were generated as a result, then select the export process status to go to process results page once the process completes successfully.
2. To generate setup data reports for an offering or a functional area without running an export process, follow these steps.
   a. Click **Actions > Setup Data Reports > Create New** for an offering or a functional area as applicable.
   b. Accept the confirmation message.
   c. Continue to monitor the process until it completes successfully.
   d. Select the status to go to the Export and Import Process Results page.
3. Use **Download Setup Data Reports**:
   - At the page level to download a consolidated report of setup data from all exported business objects.
   - Or, at the individual business object level to download the report for that specific business object.
4. Save and open the .zip file to review the details. If you download the consolidated report, then the .zip file contains one .zip file for each of the exported business object.

### Review of Export and Import Process Results

Export and import process results help you monitor the progress of setup data export or import processes while they're running, and to review their results after the processes complete.

The results are shown in three sections:

- **Summary**
  - Business Objects
  - Manual Tasks.

**Summary**

This section shows a summary of the export or import process, which includes:

- The date and time of the export or import process, and its completion status.
- Total number of business objects processed.
- How many business objects were processed successfully.
- How many business objects completed processing with errors.
- How many business objects completed processing with warnings.
- How many setup objects require manual export or import.

**Business Objects**

This section lists the business objects whose setup data was exported and imported. The sequence of the results is the same sequence in which the business objects were processed.

If the process completes successfully, all business objects are listed. If the process completes with errors or warnings, the list includes only those business objects that encountered errors or warnings.

Review the status details for each business object, which shows you how many records were processed. If the status details of a business object indicate that the object was already processed and references another object in the message, then locate the referenced object to review its status details.
If the business object encountered errors, the status details also include detailed information about the errors, and refer to the product which supports the business object. When you log bugs on this business object, use the referenced product and attach the corresponding log file with the bug.

**Manual Tasks**

Some of the setup data for a configuration can't be automatically exported and imported since export or import services may not be available for them. You must manually export or import this setup data to ensure that all the relevant setup data is migrated. To best plan your implementation, this section shows you which setup data you must manually export after the export process completes and recommends when (before, during, or after the import process) you should manually import your setup data. Oracle recommends that you follow the same method you used to enter the setup data for each of these tasks.

Additionally, if user intentionally excluded some data during export, the impacted tasks appear listed as Manual Tasks that require manually importing the corresponding data. These tasks are labeled as “Excluded by user”.

**Note:** When reviewing the results of export and import processes based on implementation projects, the Manual Tasks are available from the Export and Import Process Results page. Click the **Review Tasks for External Import** button from the Object Details table to access the Manual Tasks.

**Export and Import Process Reports**

Each time you run an export or import setup data process, a **Process Results Summary**, a **Process Results** report, **Manual Tasks**, and a **Log File** generate automatically.

- **Process Results Summary** report is a text file that displays summary information and the status details of each setup business object processed by the export or import process.
- **Process Results** report is a text file that displays the status of an export or import process, and detailed information about encountered during the process. These reports show the same information as the export and import results seen directly in the application.
- **Manual Tasks** is a text file that provides information about data for tasks that you need to manually export and import. It also recommends when such data is required during import process.
- **Log File** is a text file that displays detailed information for about each setup object processed by the export or import process.

You can download the export and import process results report from the **Actions** menu. Alternatively, you click the **Download** button from the Export and Import Process Results page, and select the report you want to download.

**Additional Access Required for Exporting and Importing Setup Data**

You must have the Application Implementation Consultant role (ORA_ASM_APPLICATION_IMPLEMENTATION_CONSULTANT_JOB) to export or import setup data. However, you require additional roles to export and import certain business objects.

This table lists the business objects for which additional roles are required, and the role required for each business object.
<table>
<thead>
<tr>
<th>Business Object Name</th>
<th>Required Role Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corporate Card Expense Type Mapping Rule</td>
<td>Corporate Card Administrator</td>
</tr>
<tr>
<td>Corporate Card Company Account</td>
<td>Corporate Card Administrator</td>
</tr>
<tr>
<td>Corporate Card Program</td>
<td>Corporate Card Administrator</td>
</tr>
<tr>
<td>Corporate Card Transaction Download Parameter</td>
<td>Corporate Card Administrator</td>
</tr>
<tr>
<td>Corporate Card Transaction Upload Rule</td>
<td>Corporate Card Administrator</td>
</tr>
<tr>
<td>Corporate Card Usage Limit Rule</td>
<td>Corporate Card Administrator</td>
</tr>
<tr>
<td>Bank Statement Reconciliation Tolerance</td>
<td>Cash Manager</td>
</tr>
<tr>
<td>Bank Statement Automatic Reconciliation Matching Rule Set</td>
<td>Cash Manager</td>
</tr>
<tr>
<td>Bank Statement Automatic Reconciliation Matching Rule</td>
<td>Cash Manager</td>
</tr>
<tr>
<td>Bank Statement Transaction Creation Rule</td>
<td>Cash Manager</td>
</tr>
<tr>
<td>Cash Transaction Type</td>
<td>Cash Manager</td>
</tr>
<tr>
<td>Bank Transaction Code</td>
<td>Cash Manager</td>
</tr>
<tr>
<td>Bank Statement Parsing Rule</td>
<td>Cash Manager</td>
</tr>
<tr>
<td>Bank Account</td>
<td>Cash Manager</td>
</tr>
<tr>
<td>Bank Branch</td>
<td>Cash Manager</td>
</tr>
<tr>
<td>Bank</td>
<td>Cash Manager</td>
</tr>
<tr>
<td>Collections Aging Bucket</td>
<td>Collections Manager</td>
</tr>
<tr>
<td>Collections Dunning Configuration</td>
<td>Collections Manager</td>
</tr>
<tr>
<td>Collections Preference</td>
<td>Collections Manager</td>
</tr>
<tr>
<td>Collector</td>
<td>Collections Manager</td>
</tr>
<tr>
<td>Business Object Name</td>
<td>Required Role Name</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>Expense Audit Rule</td>
<td>Expense Manager</td>
</tr>
<tr>
<td>Expense Audit List Rule</td>
<td>Expense Manager</td>
</tr>
<tr>
<td>Expense Receipt Management Rule</td>
<td>Expense Manager</td>
</tr>
<tr>
<td>Incentive Compensation Participant</td>
<td>Incentive Compensation Application Administrator</td>
</tr>
<tr>
<td>Department</td>
<td>Human Capital Management Application Administrator</td>
</tr>
<tr>
<td>Legal Employer</td>
<td>Human Capital Management Application Administrator</td>
</tr>
<tr>
<td>Payroll Statutory Unit</td>
<td>Human Capital Management Application Administrator</td>
</tr>
<tr>
<td>Division</td>
<td>Human Capital Management Application Administrator</td>
</tr>
<tr>
<td>Job</td>
<td>Human Capital Management Application Administrator</td>
</tr>
<tr>
<td>Location</td>
<td>Human Capital Management Application Administrator</td>
</tr>
<tr>
<td>Enterprise Information</td>
<td>Human Capital Management Application Administrator</td>
</tr>
<tr>
<td>Legislative Data Group</td>
<td>Human Capital Management Application Administrator</td>
</tr>
<tr>
<td>Spreadsheet Business Object Security</td>
<td>Human Capital Management Integration Specialist</td>
</tr>
<tr>
<td>Mapping</td>
<td></td>
</tr>
<tr>
<td>Performance Goal Plan</td>
<td>Human Resource Specialist or the Manage Performance Goal by HR privilege</td>
</tr>
<tr>
<td>Payment Process Request Templates</td>
<td>Manage Payables Payment Process Request Template privilege</td>
</tr>
<tr>
<td>Role Provisioning Associated Role List</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Role Provisioning Rule</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Country Security Profile Country List</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Country Security Profile</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>HR Document Type Security Profile List</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Business Object Name</td>
<td>Required Role Name</td>
</tr>
<tr>
<td>---------------------------------------------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>HR Document Type Security Profile</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Legislative Data Group Security Profile List</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Legislative Data Group Security Profile</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Organization Security Profile Classification List</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Organization Security Profile</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Organization Security Profile Organization List</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Payroll Security Profile Pay</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Payroll Security Profile</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Payroll Flow Security Profile Pay</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Payroll Flow Security Profile</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Person Security Profile Manager Type</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Person Security Profile Person Type</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Person Security Profile</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Person Security Profile Area of Responsibility Scope</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Position Security Profile Position List</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Position Security Profile</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Position Security Profile Area of Responsibility Scope</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Transaction Security Profile</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Transaction Security Profile Entries</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>Business Object Name</td>
<td>Required Role Name</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>-------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Transaction Security Profile Sub Categories</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>HCM Data Role Security Profile</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>HCM Data Role</td>
<td>IT Security Manager</td>
</tr>
<tr>
<td>China Ledger Option</td>
<td>Enterprise Financial Data Export Options Management for China</td>
</tr>
<tr>
<td>China Depreciation Method Formula</td>
<td>Enterprise Financial Data Export Options Management for China</td>
</tr>
<tr>
<td>China Financial Information Option</td>
<td>Enterprise Financial Data Export Options Management for China</td>
</tr>
<tr>
<td>China Golden Tax Miscellaneous Option</td>
<td>Golden Tax Administration for China</td>
</tr>
<tr>
<td>China Value Added Tax Invoice Option</td>
<td>Golden Tax Administration for China</td>
</tr>
<tr>
<td>China Golden Tax Transfer Rule</td>
<td>Golden Tax Management for China Duty</td>
</tr>
<tr>
<td>China Golden Tax Transfer Rule Line</td>
<td>Golden Tax Management for China Duty</td>
</tr>
<tr>
<td>China Golden Tax Transfer Rule Line Transaction Type</td>
<td>Golden Tax Management for China Duty</td>
</tr>
<tr>
<td>China Golden Tax Miscellaneous Option</td>
<td>Golden Tax Management for China Duty</td>
</tr>
<tr>
<td>China Value Added Tax Invoice Assignment</td>
<td>Golden Tax Management for China Duty</td>
</tr>
<tr>
<td>China Golden VAT Limit</td>
<td>Golden Tax Management for China Duty</td>
</tr>
<tr>
<td>China Golden VAT Type</td>
<td>Golden Tax Management for China Duty</td>
</tr>
<tr>
<td>Italian VAT Letter of Intent Limit Setup</td>
<td>EMEA Financial Reporting Duty</td>
</tr>
<tr>
<td>Spreadsheet Business Object Security Mapping</td>
<td>Human Capital Management Integration Specialist</td>
</tr>
<tr>
<td>HCM Spreadsheet Data Loader Template</td>
<td>Human Capital Management Integration Specialist</td>
</tr>
</tbody>
</table>
Additional Settings for Setup Data Export and Import Processes

In general, you won't need these additional settings for your export and import processes. To know whether you need them, review the special requirements explained in this topic.

Manage Import-only Setup Mode

You may have to operate one of your environments, such as your production environment, in import-only setup mode. Then, you can manage the setup data in that environment through the setup import process.

When an environment is in import-only setup mode, users won’t be able to use any of the setup user interfaces to manage setup data. If anyone wants to use import processes to manage setup data, they must have the Manage Setup Migration Settings (ASM_MANAGE_SETUP_MIG_SETTINGS_PRIV) privilege to run setup data import. This privilege isn’t included in any roles delivered by Oracle and must be granted explicitly to you.

To specify your environment as import-only, follow these steps.

1. Click Navigator > My Enterprise > Enterprise.
2. On the Enterprise Information page, go to the Functional Setup Settings section and enable Import-only Setup Mode.

Mange Export of Externally Mastered Setup Data

You may have some of your setup data sourced from an external master system. If you want to exclude those externally mastered data from the setup export process, follow the instructions and make the required changes. You need the Manage Setup Migration Settings (ASM_MANAGE_SETUP_MIG_SETTINGS_PRIV) privilege for this task. This privilege isn't included in any roles delivered by Oracle and must be granted explicitly to you.

1. Click Navigator > My Enterprise > Enterprise.
2. On the Enterprise Information page, go to the Functional Setup Settings section and click Manage Export of Externally Mastered Setup Data. The Manage Export of Externally Mastered Setup Data page lists all business objects sourced from an external master system.
3. Select the Include in Export check box to include a business object in the export process. If you want to exclude a business object, deselect the check box.
4. Click Save and Close.

Change Export File Size

The default size of setup data export files is usually sufficient for most export requirements. If you’re exporting large volumes of setup data for any tasks, you might need to increase the export file size. That would also address the size-related warning message that you might see during the export process.

Note: The file size limit applies to each business object. Based on the existing file size limit, the application allocates resources to process all the business objects. If there’s burden on the processing capacity, it could impact the application's performance. Therefore, to prevent unexpected performance issues, change the file size, but only if absolutely necessary. You may temporarily increase the file size to handle the large volume of data and reset it to the default value after the process is complete.
For this task, you need the Application Implementation Consultant (ORA_ASM_APPLICATION_IMPLEMENTATION_CONSULTANT_JOB) role and the Manage Setup Migration Settings (ASM_MANAGE_SETUP_MIG_SETTINGS) privilege. To change the export file size, follow these steps.

1. Click Navigator > My Enterprise > Enterprise.
2. On the Enterprise Information page, go to the Functional Setup Settings section and click Manage Setup Data File Sizes.
3. Select the file type and change its value as per the recommendation from Oracle Support. If you want to set a larger file size, consider the available memory in your environment before changing the value.
4. Click Save and Close.

Guidelines for Troubleshooting Errors from Setup Data Export and Import Processes

Use the information in this topic to troubleshoot warning or error messages that you might receive when you run setup data export and import related processes. You might receive errors when you:

- Export or import XML based configuration packages
- Export or import CSV file packages
- Compare setup data

If there are any exceptions, the process completes with the status: Completed with warnings, or Completed with errors. Click Status to view the exception details on the process results page.

Review Process Results

The process results page lists all business objects whose setup data couldn’t be processed successfully. You could also download a summary report of the process results from the Actions > Download > Process Results Summary Report. Download the summary and review log files of each failed business object to identify what type of error occurred, and take appropriate corrective actions.

Download Log Files

Click Download Log File button on the Process Results page to download the file that includes error details of all failed business objects when running a process for an offering, a functional area or a task. Alternatively, use the Business Objects table to select a specific business object and then go to Action > Download Log File to download error details of a specific business object.

For export and import of implementation project-based configuration packages, click the Status Details link on the Process Results page and download the error log. The log file includes information about all the business objects that failed.

For the comparison of two configuration packages, click the Status link on the Process Results page and download the error log. The log file includes information about all the failed business objects. Alternatively, you can use the Business Objects table to select a specific business object and then use Status Details column to download error details of a specific business object.
Examine Log Files

The text in a log file begins with general information about the process. All business objects are listed in the same order as they were processed. For each business object, you will find a summary of the total number of records processed and how many of those records failed processing. If any record or a business object fails, then its status details shows the relevant error message along with the name of the product that owns the business object. Detailed information about the cause of failure for each record appears in the Row Identifier.

Setup data of certain business objects are processed in batches. In those cases, detailed information for the failed record will also include the batch file name in which the record is created.

**Note:** Review detailed information provided for the failed objects and determine if you can fix the cause of the error. Resubmit the export or import process once you have fixed the issue. If, on the other hand, you determine that you can't fix the cause of the error, report it to the product shown in the status detail of the business object. Include the log file in your service request so that the product owner has relevant details to analyze the error.

Common Error Types

Here are some of the common errors seen at the time of running setup data export and import related processes.

<table>
<thead>
<tr>
<th>Error Type</th>
<th>Example Error Message</th>
<th>Description</th>
<th>Suggested Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access Related</td>
<td>Access Denied</td>
<td>The user doesn't have the necessary permissions to export or import setup data of the business object.</td>
<td>Refer to the Using Functional Setup Manager guide to find out which role is needed besides the Application Implementation Consultant role. Grant that role to the user before the user runs the process again.</td>
</tr>
<tr>
<td>Setup Data Processing Related</td>
<td>• Review and report the errors for this business object to product &lt;product name&gt;</td>
<td>One or more records of a business object caused an exception when the setup data is processed. An error can also occur if the record of a dependent business object can't find the reference to its parent record.</td>
<td>• Download and review the log file for detailed information and take the necessary action. If the error indicates invalid attribute values, find the missing dependent business object and fix the reference between the parent and child business objects. If nothing is reported in the log file, report the error to the product shown in the status details.</td>
</tr>
<tr>
<td></td>
<td>• The values &lt;reference key&gt; aren't valid for the attribute &lt;attribute name&gt;.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Multiple Business Objects Sharing the Export or Import Service</td>
<td>This object was already processed. The import or export details were listed along with &lt;name of the business object processed previously&gt;</td>
<td>If multiple business objects are processed by the same export or import service and an error occurs during the process, error details are reported on the first business object processed by the export or import service, while the status details of the remaining business objects sharing the service displays the error message.</td>
<td>Fix the error reported on the first business object.</td>
</tr>
</tbody>
</table>
### Error Type
<table>
<thead>
<tr>
<th>Description</th>
<th>Suggested Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Invalid File Format</td>
<td>Download the log file and report the error to the product specified in the error message.</td>
</tr>
<tr>
<td>Export or Import Service Invocation</td>
<td>Download the log file and report the error to the product specified in the error message.</td>
</tr>
<tr>
<td>Data File Size Related</td>
<td>Consider processing a small set of data using scope if applicable to filter data and reduce the data file size. If you can't reduce the data file size, you may temporarily increase the file size limit in the environment to process the file as is. Remember to reset the file size limit to the default value after the process is complete. For instructions about changing the export file size, see topic <a href="#">Additional Settings for Setup Data Export and Import Processes</a>.</td>
</tr>
</tbody>
</table>

#### FAQs for Setup Data Export and Import

**How can I view and print any errors generated while importing or exporting offering setup data?**

Follow the steps to open export or import process results as specified in the procedure topics for exporting and importing setup data. Download the log file for either the entire process, or for a specific business object.

**Why is an import process stuck with User Action Required status?**

An import process is set to User Action Required status when the process paused because certain dependent data must be imported.

This occurs when the standard service to automate the setup data export and import for a business object which is marked as required for other data isn't available. You must migrate or enter the data manually using another application or process external to the Setup and Maintenance work area. Review the process results to identify the business object and resume the process after you take appropriate action to externally import the required setup data.
How can I exclude a business object from exporting?

You can exclude a business object from exporting by deselecting the Export column while creating the configuration package.

However, business objects that are exported might have data dependencies on the excluded business objects, which may cause the setup data import of those business objects to fail. Therefore, be cautious when deciding to exclude business objects from the export process.

Why does the configuration package show preselected scope values for some business objects?

For a business object, scope values are selected by default if you selected any scope value when you performed a task to enter setup data.

Scope values are also selected by default if the task is one of the application's core tasks. For example, the task for defining profile options that have predefined parameters to filter setup data. For export purposes, you can remove any of the preselected values from the configuration package, if appropriate. Similarly, you can also add more scope values to the configuration package, if they're relevant for your export process.

How can I cancel an export or import process that I submitted?

You can cancel an export or import process from the Manage Export and Import Processes page.

On the Manage Export and Import Processes page, click Actions > Cancel Process. After you confirm the process cancelation, the application completes processing the business object that's in progress, but doesn't process the remaining business objects. You can resume the process only after the process status changes to Canceled.

Why can't I modify a configuration package I recently created?

You can modify a configuration package while it's in the Definition in progress status. Once you submit the configuration package for export or upload it for import, its status changes to Locked.

You can't modify a configuration package that's in the Locked status.

Why aren't all ready to use setup data exported?

By default, the export process includes only ready to use setup data that's modified. You can't export ready to use setup data for the following business objects unless it's modified:

- Application Taxonomy
- Application Reference Data Set
• Application Reference Data Set Assignment
• Application Lookup
• Data Security Policy
• Application Tree Structure
• Application Tree Label
• Application Tree
• Application Flex Value Set
• Application Descriptive Flexfield
• Application Extensible Flexfield
• Application Key Flexfield

Additionally, make sure that you deploy the ready to use setup data for the following business objects:

• Application Descriptive Flexfield
• Application Extensible Flexfield
• Application Key Flexfield

Note: You can never export user level profile values.
8 Setup Security

Security Requirements

The Application Implementation Consultant job role has full access to perform all offering opt-in and setup related activities. However, not all activities require this role. Other roles are available with limited access to a subset of activities.

Review the requirements and grant users roles that are required to complete a specific activity. For more details, see the Oracle Fusion Cloud Applications Security Reference for Common Features guide on the Oracle Help Center.

Limit Access to Specific Setup Tasks

To limit a user’s access to specific setup tasks, grant both these roles to the user:

- Functional Setups User Role (ORA_ASM_FUNCTIONAL_SETUPS_USER_ABSTRACT)
- A role with the task-specific privilege

If you also want to allow the same user to export and import task-related setup data, additionally grant the Export Import Functional Setups User (ORA_ASM_EXPORT_IMPORT_FUNCTIONAL_SETUPS_USER) role.

For details about setup tasks and task-specific privileges, refer to the product-specific Security Reference guides.

Related Topics

Mapping of Setup Activities and Required Roles

Review a summary of opt-in and setup activities, and the roles that can perform those activities. For full details about roles and privileges related to the Functional Setup Manager, see the Oracle Fusion Cloud Applications Security Reference for Common Features guide.

Details about how roles and activities are mapped are presented in two sections. The first section introduces the opt-in and setup activities, and indicates which roles are required to complete those activities. The second section introduces the roles, and highlights the activities that each role is entitled to perform.

Setup Activities and the Required Roles

In this table, review the opt-in and setup activities, and the roles that are required to perform those activities. The first column lists all the setup activities and the second one lists the roles.

<table>
<thead>
<tr>
<th>Opt-In and Setup Activity</th>
<th>Roles and Privileges</th>
</tr>
</thead>
<tbody>
<tr>
<td>Review offering features:</td>
<td>One of these roles is required:</td>
</tr>
<tr>
<td>• Review offerings</td>
<td>• Application Implementation Consultant (Job)</td>
</tr>
</tbody>
</table>
### Opt-In and Setup Activity

<table>
<thead>
<tr>
<th>Opt-In and Setup Activity</th>
<th>Roles and Privileges</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Review new and available features</td>
<td>• Application Implementation Manager (Job)</td>
</tr>
<tr>
<td>• Review upcoming feature updates</td>
<td>• Functional Setups User (Abstract)</td>
</tr>
<tr>
<td><strong>Configure offering features:</strong></td>
<td><strong>Either of these roles is required:</strong></td>
</tr>
<tr>
<td>• Opt in offerings and edit feature selections</td>
<td>• Application Implementation Consultant (Job)</td>
</tr>
<tr>
<td>• Review new and available features</td>
<td>• Application Implementation Manager (Job)</td>
</tr>
<tr>
<td>• Review upcoming feature updates</td>
<td></td>
</tr>
<tr>
<td>• Enter Promotion Codes (when applicable)</td>
<td></td>
</tr>
<tr>
<td><strong>Manage implementation projects:</strong></td>
<td><strong>Either of these roles is required:</strong></td>
</tr>
<tr>
<td>• Create, view, edit, or remove implementation projects</td>
<td>• Application Implementation Consultant (Job)</td>
</tr>
<tr>
<td>• Modify task list</td>
<td>• Application Implementation Manager (Job)</td>
</tr>
<tr>
<td>• Assign tasks to users</td>
<td></td>
</tr>
<tr>
<td>• Monitor progress of the projects</td>
<td></td>
</tr>
<tr>
<td><strong>Perform all setup tasks and manage setup data using:</strong></td>
<td>Application Implementation Consultant (Job)</td>
</tr>
<tr>
<td>• Offerings and functional areas</td>
<td>Certain data may require additional roles. For additional information, see topic</td>
</tr>
<tr>
<td>• Implementation projects</td>
<td>Additional Access Required for Exporting and Importing Setup Data.</td>
</tr>
<tr>
<td><strong>Perform specific setup tasks and manage setup data</strong></td>
<td>Both these roles are required:</td>
</tr>
<tr>
<td><strong>Export and import setup data using:</strong></td>
<td>• Functional Setups User (Abstract)</td>
</tr>
<tr>
<td>• Offerings and functional areas</td>
<td>• A role with the task-specific privilege</td>
</tr>
<tr>
<td>• Configuration packages for implementation projects</td>
<td></td>
</tr>
<tr>
<td>• CSV file packages for offerings, functional areas, or tasks</td>
<td></td>
</tr>
<tr>
<td><strong>Compare setup data</strong></td>
<td><strong>Either of these roles is required:</strong></td>
</tr>
<tr>
<td><strong>Generate setup data reports</strong></td>
<td>• Application Implementation Consultant</td>
</tr>
<tr>
<td></td>
<td>• Export Import Functional Setups User (Abstract) and additional roles with the task-</td>
</tr>
<tr>
<td></td>
<td>specific setup data privileges</td>
</tr>
<tr>
<td></td>
<td>If you have the Application Implementation Consultant role, note that certain data</td>
</tr>
<tr>
<td></td>
<td>may require additional roles. For additional information, see topic Additional</td>
</tr>
<tr>
<td></td>
<td>Access Required for Exporting and Importing Setup Data.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Opt-In and Setup Activity | Roles and Privileges
---|---
| | • Application Implementation Consultant  
• Export Import Functional Setups User (Abstract) and additional roles with the task-specific setup data privileges  
If you have the Application Implementation Consultant role, note that certain data may require additional roles. For additional information, see topic Additional Access Required for Exporting and Importing Setup Data.

| Monitor export/import processes | One of these roles is required:  
| | • Application Implementation Consultant (Job)  
• Application Implementation Manager (Job)  
• Export Import Functional Setups User (Abstract) and additional roles with the task-specific setup data privileges  
| Additional settings for setup data export/import | Manage Setup Migration Settings (Privilege)  
| | • Import-only setup mode  
• Export of externally mastered setup data  
• Export file size change  
| Manage integration of additional applications | Either of these roles is required:  
| | • Application Implementation Consultant (Job)  
• Manage Third Party Applications (Privilege)  

### Roles and the Allowed Activities

In this table, review the roles and the various activities that each role can perform. The first column lists all the roles and the second one lists the activities.

<table>
<thead>
<tr>
<th>Role</th>
<th>Allowed Activities</th>
</tr>
</thead>
</table>
| Application Implementation Consultant (Job) | • Review offering features:  
  o Review offerings  
  o Review new and available features  
  o Review upcoming feature updates  
• Configure offering features:  
  o Opt in to offerings and edit feature selections  
  o Enter promotion codes (when applicable) |
## Setup Security

<table>
<thead>
<tr>
<th>Role</th>
<th>Allowed Activities</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Role</strong></td>
<td><strong>Allowed Activities</strong></td>
</tr>
<tr>
<td></td>
<td>• Perform all setup tasks and manage setup data using:</td>
</tr>
<tr>
<td></td>
<td>o Offerings and functional areas</td>
</tr>
<tr>
<td></td>
<td>o Implementation projects</td>
</tr>
<tr>
<td></td>
<td>• Export and import all setup data using:</td>
</tr>
<tr>
<td></td>
<td>o Offerings and functional areas</td>
</tr>
<tr>
<td></td>
<td>o Configuration packages for implementation projects</td>
</tr>
<tr>
<td></td>
<td>o CSV file packages for offerings, functional areas, or tasks</td>
</tr>
<tr>
<td></td>
<td>• Compare setup data</td>
</tr>
<tr>
<td></td>
<td>• Generate setup data reports</td>
</tr>
<tr>
<td></td>
<td>• Create, submit, and monitor export/import and comparison processes</td>
</tr>
<tr>
<td></td>
<td>• Manage implementation projects</td>
</tr>
<tr>
<td></td>
<td>o Create, view, edit, or remove implementation projects</td>
</tr>
<tr>
<td></td>
<td>o Modify task list</td>
</tr>
<tr>
<td></td>
<td>o Assign tasks to users</td>
</tr>
<tr>
<td></td>
<td>o Monitor progress of the projects</td>
</tr>
<tr>
<td></td>
<td>• Manage integration of additional applications</td>
</tr>
<tr>
<td></td>
<td>Certain data may require additional roles. For additional information, see topic Additional Access Required for Exporting and Importing Setup Data.</td>
</tr>
<tr>
<td><strong>Application Implementation Manager (Job)</strong></td>
<td>• Review offering features:</td>
</tr>
<tr>
<td></td>
<td>o Review offerings</td>
</tr>
<tr>
<td></td>
<td>o Review new and available features</td>
</tr>
<tr>
<td></td>
<td>o Review upcoming feature updates</td>
</tr>
<tr>
<td></td>
<td>• Configure offering features:</td>
</tr>
<tr>
<td></td>
<td>o Opt in to offerings and edit feature selections</td>
</tr>
<tr>
<td></td>
<td>o Enter promotion codes (when applicable)</td>
</tr>
<tr>
<td></td>
<td>• Manage implementation projects:</td>
</tr>
<tr>
<td></td>
<td>o Create, view, edit, or remove implementation projects</td>
</tr>
<tr>
<td></td>
<td>o Modify task list</td>
</tr>
<tr>
<td></td>
<td>o Assign tasks to users</td>
</tr>
<tr>
<td></td>
<td>o Monitor progress of the projects</td>
</tr>
<tr>
<td></td>
<td>• Create, submit, and monitor export/import and comparison processes</td>
</tr>
</tbody>
</table>
### Setup Security

<table>
<thead>
<tr>
<th>Role</th>
<th>Allowed Activities</th>
</tr>
</thead>
<tbody>
<tr>
<td>Functional Setups User (Abstract)</td>
<td>• Review offering features:&lt;br&gt;◦ Review offerings&lt;br&gt;◦ Review new and available features&lt;br&gt;◦ Review upcoming feature updates&lt;br&gt;• Review assigned tasks from implementation projects (when applicable)&lt;br&gt;• Perform setup tasks and manage setup data using:&lt;br&gt;◦ Offerings and functional areas&lt;br&gt;◦ Implementation projects&lt;br&gt;<strong>Note:</strong> A user performing a setup task must also be granted access to the corresponding task. For details about setup tasks and task-specific privileges, refer to the product-specific Security Reference guides.</td>
</tr>
<tr>
<td>Export Import Functional Setups User (Abstract)</td>
<td>• Export and import setup data using:&lt;br&gt;◦ Offerings and functional areas&lt;br&gt;◦ Configuration packages for implementation projects&lt;br&gt;◦ CSV file packages for offerings, functional areas, or tasks&lt;br&gt;• Compare setup data&lt;br&gt;• Generate setup data&lt;br&gt;• Create, submit, and monitor export/import and comparison processes&lt;br&gt;<strong>Note:</strong> This role must be granted to users having the Functional Setups User (Abstract) role so that they can also export and import setup data of the tasks for which they already have access.</td>
</tr>
</tbody>
</table>

### Related Topics

- Additional Access Required for Exporting and Importing Setup Data

### Why do I have access to more setup tasks than my granted access?

If you find that you have access to more setup tasks than your granted roles permit, then the additional tasks aren’t secured. As a result, all users have access to them.

To limit users from accessing those tasks, contact the concerned product team and request them to secure those tasks.
9 Additional Functionality

How Copying Setup Configuration Helps

You can copy an interdependent setup data configuration to create a new set of interdependent setup data similar to the original one. This process helps to create data faster, especially for setup requirements that are complex but similar.

For example, create a business unit structure and then copy its setup to create a new business unit structure whose setup data requirements are similar to the original business unit, except for a few exceptions specific to the new business unit.

How Copy Configuration Works

Start the copy process by selecting an existing setup configuration, whose setup data is then copied to a staging area. Next, modify the setup data in the staging area according to the requirements of the new setup configuration you want to create. Since the purpose of copying setup is to create a new set of setup data quickly and easily, only those attributes that are minimally required to be set up are available for edit.

After you complete making modification to the staged setup data, submit an import process which creates the new setup configuration by copying setup data from the original and changing the data where applicable based on the modifications you made.

Once the import process completes, Oracle recommends that you review your new setup configuration to ensure it meets your requirements. You can also make additional changes to the data of the new setup if needed.

The following figure illustrates the steps in the copy configuration process.

Related Topics
- Copy Setup Configuration
Copy Setup Configuration

You can copy an existing setup configuration so that you can use it for any other setup with requirements.

You need the following privileges to copy a setup configuration:

- Submit Export Setup Data Process (ASM_SUBMIT_EXPORT_SETUP_DATA_PROCESS_PRIV)
- Submit Import Setup Data Process (ASM_SUBMIT_IMPORT_SETUP_DATA_PROCESS_PRIV)
- Task-specific privileges

Refer to the Oracle Fusion Cloud Applications Security Reference for Common Features guide for detailed information about task-specific privileges.

To copy a setup configuration, follow these steps:

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, select Copy Configuration from the Tasks panel tab.
3. To create Copy Configuration Request:
   a. In the Copy Configuration Requests region, select Create from the Actions menu. Alternatively, you can also click the Create icon.
   b. On the Create Configuration Request page, select the setup configuration you want to copy from Copy Configuration menu.
   c. Select the scope of your copy. For example, if you copy setup configuration of business units, then you must select one of the existing business units to copy its setup.
   d. You can change the default request name if necessary.
   e. Click Submit.
4. To edit the staged configuration:
   a. Monitor the Status column of the request in the Copy Configuration Requests table. Click Ready to Edit when the status updates.
   b. Enter or update the values for the displayed attributes, which represent the minimum set of setup data required for the new setup configuration to function.
   c. Click Save and Close when you complete making changes.
5. To import the staged configuration:
   a. Click Ready to import in the Status column in the Copy Configuration Requests table when the status updates.
   b. The same set of attributes shown in the previous step is displayed for your final review. You can compare the values of the source setup with the values of the new setup. Select Edit to make modifications if necessary.
   c. Click Import.
   d. The Status column of Copy Configuration Requests table now shows Import in progress. Click the link to monitor the import process. To get updated information click the Refresh icon.
6. To fix copy setup configuration errors:
a. Click **Ready to fix errors** in the **Status** column in the **Copy Configuration Requests** table.
b. Review the report and identify where the error occurred. The report lists all business objects in the order they were processed.
   - If the error is due to data conflicts such as attempting to create an object that already exists, use **Edit Staged Configuration** to fix the error and resubmit the import process.
   - Otherwise, report the issue to your help desk indicating the owning product as indicated in the error. Download and attach the process status details report when reporting the issue.

7. To review the copied setup configuration, click **Ready to review** in the Status column of the Copy Configuration Requests column. You can select the **Go to Task** icon for each setup task displayed to verify accuracy of the setup data.

**Search for a Task**

To search for a specific task and manage the data it represents, you must have task-specific privileges. Refer to the Oracle Fusion Cloud Applications Security Reference for Common Features guide for detailed information about task-specific privileges.

To search for a specific task, follow these steps:

1. Click **Navigator > My Enterprise > Setup and Maintenance**.
2. In the Setup and Maintenance work area, select **Search** from the Tasks panel tab.
3. In the Search page, enter a string that matches the complete or partial name of the task and click **Search**.

   The string is matched with the names of tasks, lists and business objects by default.

4. Click the **Tasks, Task Lists, Business Objects** link to change the matching criteria. Select the criteria from the available options and click **Done**.
5. From the search results:
   - If you matched with task, click the link in the **Name** column to go to the page for entering the setup data it represents.
   - If you matched with task list or business object name, click the link in the **Name** column to go to a list of tasks that are associated with the task list or business object. Follow the previous step to manage the setup data of each task in the list.
   - If you matched with functional area, click the link in the **Name** column to go to a list of the parent offerings of the functional area. Select the applicable offering to find the list of tasks in the task region. Follow the previous step to manage the setup data of each task in the list.
   - If you matched with offering name, click the link in the **Name** column to go to the offering. Follow the steps in the topic Update Existing Setup Data to manage the setup data of the offering.

**Related Topics**

- Update Existing Setup Data
Manage Integration of Additional Applications

If you need to reference and use data that's available in another application, you must integrate that application with your application. Thereafter, you can configure how to keep the reference up-to-date so that you can always access the latest content.

Follow these steps to create the application integration.

1. Click Navigator > My Enterprise > Setup and Maintenance.
2. In the Setup and Maintenance work area, click Manage Setup Content from the Tasks panel tab.
3. On the Manage Setup Content page, click Manage Integration of Additional Applications.
4. On the Manage Integration of Additional Applications page, click Actions > Create.
5. Enter the application details in the relevant fields. Ensure that the information you provide is complete and accurate. For example,
   - Begin the URL with http:// or https://.
   - Provide correct access credentials for the selected security policy.

   **Note:** You can’t edit the Application Name and Partner Name once you save the details.
6. Click Save and Close.