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Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility
Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My
Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info
or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.
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1
Creating and Running an EPM Center of
Excellence

A best practice for EPM is to create a CoE (Center of Excellence).

An EPM CoE is a unified effort to ensure adoption and best practices. It drives transformation
in business processes related to performance management and the use of technology-enabled
solutions.

Cloud adoption can empower your organization to improve business agility and promote
innovative solutions. An EPM CoE oversees your cloud initiative, and it can help protect and
maintain your investment and promote effective use.

The EPM CoE team:

• Ensures cloud adoption, helping your organization get the most out of your Oracle Fusion
Cloud EPM investment

• Serves as a steering committee for best practices

• Leads EPM-related change management initiatives and drives transformation

All customers can benefit from an EPM CoE, including customers who have already
implemented EPM.

How Do I Get Started?

Click to get best practices, guidance, and strategies for your own EPM CoE: Introduction to
EPM Center of Excellence.

Learn More

• Watch the Cloud Customer Connect webinar: Creating and Running a Center of
Excellence (CoE) for Cloud EPM

• Watch the videos: Overview: EPM Center of Excellence and Creating a Center of
Excellence.

• See the business benefits and value proposition of an EPM CoE in Creating and Running
an EPM Center of Excellence.
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2
Welcome to Working with Oracle Smart View
for Google Workspace

This guide explains Oracle Smart View for Google Workspace features and options including
concepts, processes, and examples.

Where to find Smart View documentation

The Smart View for Google Workspace documentation is available on the Oracle Help Center
on the Oracle Cloud Enterprise Performance Management (EPM) page in the Books tab for
your Oracle Fusion Cloud Enterprise Performance Management business process.

• To read this guide online in a browser, click the guide name link.

• To download a PDF file of this guide, click the PDF icon

next to the guide name. You can also download it from the online version by clicking

in the left panel next to the Table of Contents.

How to find information in this guide

To find information:

• From the online help, in the left frame of the browser window, use the Table of Contents to
navigate to topics, or click the Search icon and enter a search term in the text box.

• From the PDF, navigate to topics from the table of contents, or use your reader's search
functionality.

About this guide

This guide covers features and tasks related to multiple data sources that are supported in
Smart View for Google Workspace. It may happen that some topics apply to all data sources
and some apply only to specific data sources. The following document conventions are used to
indicate the applicability of a topic to a data source.

• If a topic is applicable to a specific data provider only, then the provider name is mentioned
at the start of the topic in the Applies to: section. For example: If a topic is applicable only
for Planning: Applies to: Planning

• If a topic applies to all supported data providers listed in the Supported Data Source
Providers topic, then the Applies to: section is not added to the topic.

Working with Oracle Smart View for Google Workspace
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3
Introduction to Smart View for Google
Workspace

Related Topics

• Overview of Smart View for Google Workspace
Oracle Smart View for Google Workspace provides a common Google Workspace
interface designed specifically for Oracle Fusion Cloud Enterprise Performance
Management business processes.

• Supported Data Source Providers
Oracle Smart View for Google Workspace currently supports Oracle Fusion Cloud
Enterprise Performance Management data source providers.

• Smart View for Google Workspace Components
Learn about the basic components of Oracle Smart View for Google Workspace such as
menus and panels that help you navigate and perform various tasks.

• Installing Smart View for Google Workspace Extension
Oracle Smart View for Google Workspace is available as an add-on extension on the
Google Workspace Marketplace for users to install in their Google Workspace.

• Access to Smart View Functionality

• Localization in Smart View for Google Workspace
Oracle Smart View for Google Workspace supports localized versions of the user interface.

Overview of Smart View for Google Workspace
Oracle Smart View for Google Workspace provides a common Google Workspace interface
designed specifically for Oracle Fusion Cloud Enterprise Performance Management business
processes.

Smart View enables users of Google Workspace to access Cloud EPM data, work on forms,
and perform ad hoc analysis in Google Sheets. Using Smart View, you can view, import,
manipulate, distribute and share data in Google Sheets.

To use Smart View in Google Sheets, you need to install the Smart View add-on extension
from Google Workspace Marketplace. The Smart View add-on extension enables Google
Workspace users to take advantage of Smart View functionality in Google Sheets.

Video

Your Goal Watch This Video

Learn how Smart View for Google Workspace
enables Cloud EPM users to access Cloud EPM
data, work on forms, and perform ad hoc
analysis in Google Sheets.

 
Introducing Smart View for Google Workspace

Supported Features

The following features are supported:
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• Form operations such as Open and Refresh Forms, Submit Data from Forms, Copy
Versions, and View Instructions

• Ad hoc analysis operations such as Zoom, Pivot, Keep/Remove Only, Insert Attribute,
Cascade, and Save Ad Hoc Grids

• Multiple connections in one spreadsheet

• Smart View Options and Favorites Menu

• Cell Styles

• Member Selection

• Drill Through in Web Browser only

• Adjust, Grid Spread, and Mass Allocate

• Multiple-Grid Ad Hoc Sheet

• Flex Form

• User Variables

• Business Rules

• Functions: HsGetValue, HsSetValue, HsAlias, and HsGetSheetInfo

• Member Formulas

• Task List

• Approvals

• Job Console

• Accessibility

Note

Because Oracle Smart View for Google Workspace requires that additional processing
takes place on Google’s servers, you may observe slower than expected performance
times for some operations.

Unsupported Features

The following features are currently not supported in Oracle Smart View for Google
Workspace:

• Dashboards, Reports, and Books

• Operations like Spreading data for time periods, Drill through in new sheet, Undo and
Redo, Copy and Paste, Save and Clear formatting, and Calc on the Fly

• Web launch

• Query Designer

• Google Docs and Google Slides

• Scripts

• Composite Forms: No future plans for support.

• Dimension Headers: No future plans for support.

• Save as Smart Form (Native mode): No future plans for support.

Chapter 3
Overview of Smart View for Google Workspace
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• Native mode for ad hoc operations: No future plans for support.
Native mode is being phased out in favor of Standard mode, which offers enhanced
features and is recommended for all users. To utilize Smart View effectively, Oracle
advises you to configure your Cloud EPM applications to use the Standard mode option
for the Smart View Ad Hoc Behavior setting. This ensures compatibility and access to the
latest functionalities.

Supported Data Source Providers
Oracle Smart View for Google Workspace currently supports Oracle Fusion Cloud Enterprise
Performance Management data source providers.

The following business processes of Cloud EPM are supported:

• Enterprise Profitability and Cost Management

• Financial Consolidation and Close

• FreeForm

• Planning

• Tax Reporting

Smart View for Google Workspace Components
Learn about the basic components of Oracle Smart View for Google Workspace such as
menus and panels that help you navigate and perform various tasks.

The basic components are as follows:

• Smart View Menu

• Smart View Home Panel

• Search Box

• Favorites Menu

• Actions Menu

• Right-Click Menu

Smart View Menu

Smart View is an extension add-in to work on Oracle Fusion Cloud Enterprise Performance
Management data in Google Sheets. So, the commands for launching Smart View-specific
operations are located under the Extensions menu. The Smart View menu provides access to
various Smart View operations required for connecting to data sources and working on forms
and ad hoc grids.

To access Smart View-specific menu options, click Extensions and then click Smart View for
Google Workspace.

• Common Smart View operations include creating connections, launching the Smart View
Home panel, setting Smart View options, viewing sheet information, importing metadata,
refreshing and submitting data, and launching forms and ad hoc grid operations.

• The Form menu provides all the operations that can be performed on forms. This includes
launching POV, viewing instructions and member formula, running business rules and
calculations, adjusting values, managing supporting details, adding cell comments and

Chapter 3
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attachments, copying versions, managing approvals, monitoring the job console, and so
on.

• The Ad Hoc menu provides all the operations that can be performed on ad hoc grids. This
includes zooming in and out, pivoting, viewing cell information, changing alias, inserting
attributes, saving ad hoc grids, viewing comments, and so on.

 

 

Note

• The user interface components of Oracle Smart View for Google Workspace, such
as menu labels, messages, dialog boxes, panels and so on, are currently available
only in the English language, irrespective of the language selected in the
Language Settings of your Google Workspace account.

• The menus in Oracle Smart View for Google Workspace always appear enabled in
the Smart View Menu and the Favorites Menu, even if they are not relevant or
supported for the form or ad hoc grid that you are working with. For such
unsupported menus, you are alerted with a message stating that the operation is
not supported. For example, you are working on an ad hoc grid and you click
Analyze either from the Smart View Menu or the Favorites Menu, then an error
message alerts you that "This operation is not supported for an ad hoc sheet",
since an ad hoc grid is already in the analyze mode.

Smart View Home Panel

The Smart View Home panel provides a tree view of the library of plans, forms, ad hoc grids,
cubes, and other artifacts present in your data source. You can expand the folders and click an
artifact name to open it.

Chapter 3
Smart View for Google Workspace Components
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When you first connect to Smart View, you can launch the Home panel directly from the
Connect dialog by clicking Launch Home. You can also launch it from the menu. In the
Extensions menu, select Smart View for Google Workspace, and then select Home.

 

 
Using the Smart View Home panel, you can:

• Search for specific forms or grids.

• Open forms and ad hoc grids by clicking their names.

• Select forms and ad hoc grids without opening them by clicking their icon or the area next
to their names.

• Open a form directly in ad hoc analysis mode by selecting it, right-clicking the form name,
and then selecting Ad Hoc Analysis.

• Open an ad hoc grid directly as a form by selecting it, right-clicking the ad hoc grid name,
and then selecting Open Form.

• Launch various actions and processes from the Actions menu. You can also select a form
or ad hoc grid and right-click on its name to access these actions.

• Launch the Favorites menu by clicking the Favorites icon.

In addition to the Home panel, there are other panels such as Business Rules, Task List,
Approvals, User Preferences, POV, and Favorites that open as overlays on the Home panel.
You can close these panels to return back to the Home panel.

Search Box

The search box, located on the top in the Smart View Home panel, helps you find and access
forms and other artifacts you need faster. As you start typing in the search box, the list of items
in the Home panel gets filtered to show the names with the highlighted search term. For

Chapter 3
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example, if you search for "plan", then only the forms and artifacts with the letters "plan" in their
names are displayed in the Home panel.

The search box supports case-insensitive search: For example, searching for "plan", "Plan", or
"PLAN" fetches the same list of items which have this term in their names, irrespective of their
case.

You can click an item's name to open it directly from the search results. You can also select
and right-click an item in the search results to view the Right-Click menu options specific to the
selected item.

If there are no matching items for the searched term, the panel appears blank. You can clear
the search box by clicking the Close icon.

Favorites Menu

An easy way to access Smart View commands is by marking them as favorite. You can select
the commands that you use frequently and they appears pinned at the top of the Favorites
panel. When you want to use a command, simply open the Favorites panel by clicking

in the Smart View Home panel, and click a command, instead of navigating the Extensions,
Smart View for Google Workspace menu to reach the command.

To add your favorite commands, see Adding Favorites.

 

Chapter 3
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Actions Menu

The Actions menu is located in the Smart View Home panel and is launched by clicking

. This menu gives you access to various features such as Job Console, Copy Version,
Business Rules, Task List, Approvals, User Preferences, Favorites, and Disconnect.
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Right-Click Menu

You can right-click on forms, ad hoc grids, and other artifacts in the Smart View Home panel to
open the selected forms and ad hoc grids and to launch features such as Job Console, Copy
Version, Business Rules, Task List, Approvals, User Preferences, and Disconnect. These
options are additionally available under the Action menu in the Smart View Home panel.

In the following example, when you select the Actual vs. Plan form and right-click on it, you
can use the Ad Hoc Analysis option to open the form directly in ad hoc analysis mode.
Similarly, if you right-click on an ad hoc grid, you can use the Open Form option to open it as a
form.

 

Chapter 3
Smart View for Google Workspace Components

Working with Oracle Smart View for Google Workspace
F56457-09
Copyright © 2025, Oracle and/or its affiliates.

August 1, 2025
Page 8 of 11



 

Installing Smart View for Google Workspace Extension
Oracle Smart View for Google Workspace is available as an add-on extension on the Google
Workspace Marketplace for users to install in their Google Workspace.

For more information on Smart View extension and installation prerequisites, see Getting
Started with Oracle Smart View for Google Workspace.

Video

Your Goal Watch This Video

Learn how to set up Smart View for Google
Workspace and enable Oracle Fusion Cloud
Enterprise Performance Management users to
access Cloud EPM data, work on forms, and
perform ad hoc analysis in Google Sheets.

 
Setting Up Smart View for Google Workspace

Access to Smart View Functionality
Access to Smart View functionality depends on the access that Service Administrators set up
for users in the business process.

Service Administrators: For more information, see Administering Access Control.

Chapter 3
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Localization in Smart View for Google Workspace
Oracle Smart View for Google Workspace supports localized versions of the user interface.

The localized versions of Smart View provide you with an improved non-English experience
where you can switch to your desired language to work with the user interface, as required.

Supported languages are: Arabic, Chinese (Simplified and Traditional), Czech, Danish, Dutch,
English, Finnish, French, French Canadian, German, Greek, Hebrew, Hungarian, Italian,
Japanese, Korean, Norwegian, Polish, Portuguese, Portuguese (Brazilian), Romanian,
Russian, Slovak, Spanish, Swedish, Thai, and Turkish

To use a localized version of Smart View, you can set the preferred language from your Google
Workspace account settings.

Setting Preferred Language for Smart View

1. In the Google Sheets home page, open the main menu, click Settings, and view the
currently set language in the Language section.
For example, if English is your current language, then you see an English link in the
Language section.

2. Click the language link to open the Language settings for your Google Workspace
account.
Alternatively, you can click Manage your Google Account, go to Personal Information,
and click Language under Other info and preferences for Google services.

3. In the Language section, click Edit in the Preferred Language section.

4. Search and select your preferred language, and click Save.
The content starts appearing in the selected language immediately.

5. If you use multiple languages, click Add another language, select the required language,
and click Save.

a. Click Add another language.

b. Select the required language, and click Save. The language is added in the Other
Languages section.

c. Click the Up arrow next to the newly added language to move it from Other
Languages to Preferred Language.
The content starts appearing in the selected language immediately.

6. Open Google Sheets and refresh the page.
When you navigate through the menus, open panels, launch dialog boxes, and receive
confirmation messages, you can now read all the content in the selected language. For
more information, see Google’s documentation on Change your language on the web.

Guidelines on Supported Languages

Consider the following guidelines for using supported languages.

• Whenever you change the preferred language, always refresh the browser on which
Google Sheets is opened to display the user interface content in the selected language.

• If you select a preferred language that is supported by Google Sheets but not by Smart
View, the user interface for Smart View is displayed in the English language by default.

• If you are already connected to your business process in a particular language, and then
you change the preferred language, the user interface content fetched from the business
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process continues to appear in the previously connected language. For example, if you
were connected to your business process in English, and changed the preferred language
to French, the Library label in the Smart View Home panel continues to display in English,
instead of French. To refresh such content and display it in the selected language, clear
the current session and connect to your business process again using the Connect dialog.
See Clearing Session.
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4
Connecting to Data Sources

Connect to your business process through Oracle Smart View for Google Workspace using a
Google Workspace-compatible browser like Chrome.

After installing the Smart View extension, you can connect to your business process from using
your Google Workspace account in Smart View in the following ways:

• Connecting Using Basic Authentication

• Connecting Using Company Sign In Credentials

Note

Ensure that the Smart View Extension for Google Sheets has been enabled in the web
application settings for every business process that you want to connect through
Smart View in Google Sheets. If not enabled, you cannot open the Smart View Home
panel and submit or refresh data in saved sheets. For more information, see Enabling
the Smart View Extension for Google Sheets in Getting Started with Oracle Smart
View for Google Workspace.

Connecting Using Basic Authentication
You can use basic authentication such as your user name and password to connect to your
business process from Oracle Smart View for Google Workspace.

1. Sign in to Google Sheets using your Google Workspace credentials and open a new
spreadsheet

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Connect under Start.
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3. In the Connect dialog, enter the Server URL of your business process and then enter your
user name and password in the User and Password fields.
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4. Click Connect.
Once connected, the Launch Home button appears in the Connect dialog. You are now
connected to your business process from Google Sheets.

• If you want to only establish the connection to your data source, you can click Close to
close the Connect dialog. This is helpful when you are working with multiple data
sources and want to keep active connections ready before setting a specific one for
your sheet.

• If you want to launch the Smart View Home panel and access the library of you data
source, proceed with step 5.

5. Click Launch Home to open the Smart View Home panel.
 

 
In the Smart View Home panel, you can view the library and work on forms and ad hoc
grids present in the business application.
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Note

When trying to open the Home panel, if you get an error message stating
"Administrator has not enabled Google Sheets support for this instance", then you
cannot use Smart View in Google Sheets, even though you have installed the
extension and connected to your business process.

As a prerequisite, your Service Administrator needs to enable the Smart View
Extension for Google Sheets in the web application settings for every business
process that you want to connect through Smart View in Google Sheets. For more
information, see Enabling the Smart View Extension for Google Sheets in Getting
Started with Oracle Smart View for Google Workspace.

Connecting Using Company Sign In Credentials
You can sign in to your business processes from Oracle Smart View for Google Workspace
using your organisation's sign in credentials.

Before you start, ensure that you have the connection credentials provided by your Service
Administrator for Client ID and IDCS URL. For more information, see Creating an Oracle
Identity Cloud Service (IDCS) Application in Getting Started with Oracle Smart View for Google
Workspace.

1. Sign in to Google Sheets using your Google Workspace credentials and open a new
spreadsheet.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Connect under Start.
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3. In the Connect dialog box, select the Company Sign In check box.

4. Enter your connection credentials. Contact your Service Administrator for these details.

• Server URL: This refers to the web application link of your Oracle Fusion Cloud
Enterprise Performance Management business process. Modify the web application
link to remove "/epmcloud" and add "/HyperionPlanning" towards the end of the link.

• Client ID: This is generated as part of the IDCS application creation process. To find
the Client ID in the IDCS Console, go to Identity domains and click Integrated
applications. Click your IDCS application link and, in the General Information
section, see the value in the Client ID field.

• IDCS URL: This is the URL that you get on the Sign In page when you open your
Cloud EPM web application. Modify the link to retain it till "identity.oraclecloud.com"
and remove the characters after this part. For example, https://idcs-
<instanceID>.identity.oraclecloud.com.
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5. Click Connect.

6. In the Device Log In dialog box, copy the displayed code to clipboard. You will need to
enter this code in the next step.
 

 

7. Click the Click Here link, and after you authenticate using your cloud credentials, enter the
copied code in the Code field on the Device Log In page.
 

 

8. Click Submit. Once you get a confirmation message stating you have access to your
application, you can close the tab and return to the tab where Google Sheets is open.
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9. In Google Sheets, click OK in the Device Log In dialog box. A toast message appears
stating that you have got the access token. You are now connected to your business
process from Google Sheets.

10. In the Extensions menu, select Smart View for Google Workspace, and then select
Home.
In the Smart View Home panel, you can view the library and work on forms and ad hoc
grids present in the business application.

 

 

Note

When trying to open the Home panel, if you get an error message stating
"Administrator has not enabled Google Sheets support for this instance", then you
cannot use Smart View in Google Sheets, even though you have installed the
extension and connected to your business process.

As a prerequisite, your Service Administrator needs to enable the Smart View
Extension for Google Sheets in the web application settings for every business
process that you want to connect through Smart View in Google Sheets. For more
information, see Enabling the Smart View Extension for Google Sheets in Getting
Started with Oracle Smart View for Google Workspace.

Connecting to Multiple Data Sources
You can connect to multiple data sources from the same spreadsheet.

Using multiple connections, you can do the following:

• Connect to different data sources from different sheets within the same spreadsheet.
For example, you can connect to a form from Planning in one sheet and to an ad hoc grid
from Financial Consolidation and Close in another sheet in the same spreadsheet.

• Place multiple grids from multiple connections in the same sheet.
You can work with multiple ad hoc grids from different data sources in the same sheet by
establishing connections to multiple data sources. For more information, see Creating
Multiple-Grid Sheets.
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• Create and work on multiple functions from different data sources in the same sheet.
You can create a function sheet by adding functions from different cubes and data sources.
For more information, see Creating Functions from Multiple Connections.

To connect to multiple connections:

1. Sign in to Google Sheets using your Google Workspace credentials and open a new
spreadsheet. Sheet 1 opens by default.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Connect under Start.

3. Connect to your first data source and open the Smart View Home panel.
In the Smart View Home panel, you can view the library and open the required form or ad
hoc grid present in the business application.

4. At the bottom of the sheet next to the Sheet1, click

to open a new sheet, say Sheet2, to connect to a different data source.

5. In the Extensions menu, select Smart View for Google Workspace, and then select
Connect under Start.

6. Connect to your second data source and open the Smart View Home panel.
In the Smart View Home panel, you can now view the library of the second data source
and open any form or ad hoc grid present in the business application.

Note

After connecting to the second data source, the Smart View Home panel, if open,
continues to display the library from the previously open sheet, that is the Home
panel of the data source connected in Sheet1. You need to close the Home panel
and launch it again to view the library for the second data source.

7. Optional: Use Active Connections to view a list of servers that you have already
connected to in the Server URL list and select the required one to set as an active
connection for a sheet. For more information, see Setting Active Connection for a Sheet
This option is also useful while placing grids from multiple connections on the same sheet.
For more information, see Creating Multiple-Grid Sheets.

8. Optional: Use Locate Sheet Connection to open the Home panel for the connection that
is set on the currently active sheet. In the Extensions menu, select Smart View for
Google Workspace, and then select Locate Sheet Connection under Start.

Guidelines on Working with Multiple Connections

Consider the following guidelines when working with multiple connections.

• Every time you switch between sheets connected to different data sources, the Smart
View Home panel and the Smart View for Google Workspace menu works in the
following ways:

– Smart View Home panel: The Smart View Home panel does not reload automatically.
If you switch sheets or open a new sheet, the last opened Smart View Home panel
continues to display in the new sheet. You must launch the Home panel again from the
Smart View for Google Workspace menu to view the library contents relevant to the
sheet's connected data source.
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– Smart View for Google Workspace menu: Unlike the Home panel, the Smart View
for Google Workspace menu is always in sync with the active sheet. The operations
you perform using this menu are performed on the active sheet in context.

• The actions in the Smart View for Google Workspace menu apply only to the active
sheet that is currently open.

For example, if you are submitting or refreshing data, only the data from the currently
active sheet is submitted or refreshed. If you want to submit or refresh the data from
another sheet having the same or a different connection, open that sheet and use the
Submit or Refresh option from the Smart View for Google Workspace menu to submit
or refresh data on that sheet.

• To know about the connection for a particular sheet, you can open Sheet Info and view the
server and URL details. For more information, see Sheet Information.

Setting Active Connection for a Sheet
You can connect to different data source providers on the different sheets within the same
spreadsheet by setting the active connection for each sheet.

The Active Connections dialog displays the list of connections that are active in the session.
Using active connections, you can select the required connection and take the following
actions:

• Launch Home: Establish a connection for a new sheet and launch the Home panel for
exploring and viewing its artifacts. See Setting Active Connection for a New Sheet.

• Set Connection for Sheet: Change the current connection on a existing sheet to a new
connection for performing grid-related operations. See Setting Active Connection for an
Existing Sheet.

Note

• Before you begin, establish connections to all the data sources that you want to
work with in the spreadsheet so that they appear in the Active Connections list.

• If you clear a session by clicking Clear Session in the Connect dialog, the list of
connections active in that session and seen in the Active Connections list also
get cleared.

Setting Active Connection for a New Sheet

You can establish a connection on a new sheet by selecting one from the list of already active
connections. The Launch Home option helps you set the active connection and launch the
Home panel to view its library contents.

To set active connection for a new sheet:

1. Open a new sheet.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Active Connections under Start.

3. In the Active Connections dialog box, click the Server URL list to view the list of active
connections and select the required one.
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4. In the Application field and the Cube field, select the required application and cube that
you want to connect to.

5. Click Launch Home.
The connection is established and the Smart View Home panel opens to display the library
contents of the connected data source.

Setting Active Connection for an Existing Sheet

You can change the current connection on an existing sheet by setting a different connection
from the already active connections and continue grid operations on the grid data fetched from
the new connection.

For example, your sales data for different regions is located in different data sources. You are
already connected to the North and South region's data sources in the current session. On
Sheet 1, you are reviewing the Actual Monthly Sales form containing the sales data for the
North region and are connected to the North region's data source. Now you want to see the
same data for the South region. Instead of opening a new sheet and opening the relevant form
again from the library, you can switch the connection on the existing sheet to display the data
from the South region's data source in the same form.

The Set Connection for Sheet option helps you set active connection for performing grid
operations. This option is also useful while placing grids from multiple connections on the same
sheet. For more information, see Creating Multiple-Grid Sheets.

To set active connection for an existing sheet:

1. Open the existing sheet containing the form or ad hoc grid for which you want to change
the connection to one of the active connections.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Active Connections under Start.

3. In the Active Connections dialog box, click the Server URL list to view the list of active
connections and select the required one.
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4. Optional: If you are setting the active connection for a form, then the application name that
you are connecting to is displayed in the Application field. You can select the required
application in the Application field.

5. Optional: If you are setting the active connection for an ad hoc grid, the application name
and the cube name that you are connecting to are displayed in the Application field and
the Cube field respectively. You can select the required application and cube that you want
to connect to in the Application field and the Cube field.
 

 

6. Click Set Connection for Sheet.
A message appears stating "You have applied a new connection to a grid that was
associated with a different connection. Do you want to continue?".

Click Yes in the message. The sheet is now connected to the selected active connection.

7. In the Extensions menu, select Smart View for Google Workspace, and then select
Refresh to refresh the form or grid on the existing sheet with data from the selected active
connection.
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Disconnecting from Data Sources
Use the Disconnect command in the Actions menu or Right-Click menu to disconnect from
the connected data source on a sheet.

To disconnect from a connected data source:

1. Open the sheet for which you want to disconnect the data source connection.
In case you have multiple sheets in the spreadsheet connected to different data sources,
ensure that you open the correct sheet and have its corresponding Smart View Home
panel open in context.

Tip

Use Locate Sheet Connection to open the Smart View Home panel for the
connection that is set on the currently active sheet.

2. In the Smart View Home panel, click the Actions menu.
Alternatively, you can right-click on any item in the library to launch the right-click menu.

3. Click Disconnect.
This action disconnects the connected data source from the sheet.

Clearing Session
When you connect to data source provider, Smart View stores the connection credentials and
other cached details. You can clear such cached information by clearing the session.

By clearing session, you can start with new connections afresh, without any unwanted stored
details.

Note

When you clear a session, the list of connections active in that session and seen in the
Active Connections list also get cleared.

To clear session:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Connect under Start.

2. In the Connect dialog, click Clear Session.
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Any stored cache about previously connected data sources and user sessions gets
cleared.

3. To connect to a data source provider, enter the credentials and click Connect.
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5
Smart View Options

Related Topics

• Setting Smart View Options
Set options for displaying data, members, formatting, and advanced settings using the
Smart View Options.

• Advanced Options
Set Advanced Options for administrative and other advanced tasks.

• Data Options
Set Data options to control the display of data cells.

• Member Options
Set Member options to define how members are displayed in forms and ad hoc grids.

• Formatting Options
Set Formatting options to control the textual display of members and data.

• Cell Styles
Set Cell Styles to control the display of members and data with respect to cell background
color and precedence.

Setting Smart View Options
Set options for displaying data, members, formatting, and advanced settings using the Smart
View Options.

In the Options dialog, you can set global options in the Advanced tab. You can set sheets
options, including display and formatting options, in the Data, Members, and Formatting tabs.

To summarize:

• Global options apply to the entire current spreadsheet, including any new sheets added
to the current spreadsheet, and to spreadsheets that are created later. Changes to global
options also affect existing sheets and spreadsheets. The options that appear on the
Advanced tab of the Options dialog are generally global options.

• Sheet options are specific to the sheet for which they are set. The options that appear on
the Data, Members, and Formatting tabs of the Options dialog are generally sheet
options.

You can also save sheet options as the default for any new content that you import from a
data source by using the Save Current Options as Default command in the Advanced
tab of the Options dialog.

Advanced Options
Set Advanced Options for administrative and other advanced tasks.

Options in the Advanced tab are global options that apply to the entire current spreadsheet,
including new sheets added to the current spreadsheet, and become the default for all existing
and new spreadsheets.
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The Advanced tab of the Options dialog is always available. You can access the Advanced
tab before performing operations, such as performing ad hoc, opening a form, setting the
active connection for the sheet, or setting the connection for functions.

To set advanced options:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Options.

2. In the Options dialog, select the Advanced tab.

3. Make selections in the Advanced tab as described in Advanced Options.

4. Optional: Continue making changes to options in the Data, Members, or Formatting
tabs.

5. Click OK to save the changes.

Advanced Options

Table 5-1    Advanced Options

Option Description

General General
Save Current Options
as Default

Select to save your modified option selections in the Data, Member, and
Formatting tabs. After saving, your options selections become the default
for any new content that you import from a data source.

Note

Changes made in the Advanced tab
automatically become the default settings. You
do not need to select the Save Current Options
as Default command to save the Advanced
options.

Logging Logging
Enable diagnostics Select to enable diagnostics.
Enable client logging Select to enable client logging.
Show Log Click to display the Smart View log in a separate window. You can view

the log in the window or download it to a file.
Clear Storage Click to clear the storage cache. The storage cache include any previously-

selected options on the Advanced tab, as well as on the Data, Members,
and Formatting tabs.

User-Defined
Function

User-Defined Function

Missing Label Specify a value for missing data in user-defined functions.

Data Options
Set Data options to control the display of data cells.

To set data options:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Options.

Chapter 5
Data Options

Working with Oracle Smart View for Google Workspace
F56457-09
Copyright © 2025, Oracle and/or its affiliates.

August 1, 2025
Page 2 of 10



2. In the Options dialog, select the Data tab.

3. Make selections in the Data tab as described in Data Options.

4. Optional: To save your Data tab selections as the default selections for any new content
that you import from a data source, select the Advanced tab, and then click Save Current
Options as Default.

5. Click OK to save the changes.

Data Options

Table 5-2    Data Options

Option Description

Row Suppression To streamline the grid, you can suppress rows that contain types of data that
you do not need to view.

Zero Suppress rows that contain only zeroes.
Invalid Suppress rows that contain only invalid values.
Missing Suppress rows that contain only cells for which no data exists in the

database. No data is not the same as zero. Zero is a data value.
Underscore Suppress rows that contain underscore characters in member names.
Column
Suppression

To streamline the grid, you can suppress columns that contain types of data
that you do not need to view.

Zero Suppress columns that contain only zeroes.
Invalid Display actual data even if it is invalid, rather than #Invalid/Meaningless or

other replacement text. If no data exists, the cell is left blank.
Missing Suppress columns that contain cells for which no data exists in the database

No data is not the same as zero. Zero is a data value.
If you later clear No Data/Missing, suppressed values are returned only
from that point on. You must zoom out and then zoom in on a member to
retrieve values that were suppressed while this option was selected.

Underscore Suppress columns that contain underscore characters in member names.
Block
Suppression

Block Suppression

Suppress Missing
Blocks

Suppress blocks of cells for which no data exists in the database.

Replacement Replacement
Missing/No Data
Label
No Access Label

Data cells may contain missing data or data that you do not have permission
to view. In such cells, by default, Smart View displays #Missing or #No Access,
respectively, but you can change these labels.
The #Missing replacement label enables you to clear data values from cell
intersections. For example, to clear the sales data for New York, manually
type #Missing in the cell where Sales and New York intersect, and click
Submit. This clears the data value from the database. Subsequent queries on
that database will show #Missing at the intersection of Sales and New York.
To change the labels, in any of these fields, enter the text of your choice (or
leave the default). Text labels have the advantage of being descriptive, but
they cause Google Sheets functions to fail.
In the #Missing field, you can enter #NumericZero to specify numeric zero (0)
replacement labels. With #NumericZero, you can use functions, but you cannot
submit zeroes to the database (even if the zeroes are actual zeroes and not
replacement labels) unless you select the Submit Zero check box.
Calculations that are dependent on a cell with a numeric zero label compute
correctly and take the value of the cell as zero.
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Table 5-2    (Cont.) Data Options

Option Description

Submit Zero If you chose #NumericZero for the #Missing label above, select this option if
you want to be able to submit zeroes to the database.

Ad Hoc Mode Ad Hoc Mode
Navigate Without
Data

Speeds up operations such as Pivot, Zoom, Keep Only, and Remove Only by
preventing the calculation of source data while you are navigating. When
you are ready to retrieve data, clear Navigate Without Data.

Member Options
Set Member options to define how members are displayed in forms and ad hoc grids.

To set member options:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Options.

2. In the Options dialog, select the Members tab.

3. Make selections in the Members tab as described in Member Options.

4. Optional: To save your Members tab selections as the default selections for any new
content that you import from a data source, select the Advanced tab, and then click Save
Current Options as Default.

5. Click OK to save the changes.

Member Options

Table 5-3    Member Options

Option Description

General General
Ancestor Placement Select one of the following to specify ancestor position in hierarchies:

• Top to display hierarchies in order from highest to lowest level
• Bottom to display hierarchies in order from lowest to highest level

Indentation Apples to ad hoc only.
Select one of the following to specify how hierarchy levels are to be
indented:
• None
• Subitems to indent descendants. Ancestors are left-justified in the

column.
Member Name
Display

Select one of the following to specify how to display member names in
cells:
• Member Name or Alias to display member names only or, if an alias

table is being used, alias names only.
• Member Name and Alias to display member names and their

aliases.
• Distinct Member Name Only to display fully qualified names.

Format Members as
Text

Select one of the following to specify how to format members as text:
• Single Quote
• None
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Table 5-3    (Cont.) Member Options

Option Description

Member Retention Member Retention
For ad hoc grids only.

Include Selection Display the selected member and the members retrieved as a result of the
operation.

Within Selected
Group

Perform ad hoc operations only on the selected group of cells, leaving
unselected cells as is. This setting is meaningful only when there are two
or more dimensions down the grid as rows or across the grid as columns
for Zoom, Keep Only, and Remove Only.

Remove Unselected
Groups

For Zoom In or Zoom Out, remove all dimensions and members except
the selected member and the members retrieved as a result of zooming.

Comments and
Formula

Comments and Formula

Preserve Formulas
and Comments in Ad
Hoc

Preserves formulas and comments in ad hoc grids.
If you clear this option, the formulas and comments are removed from
the grid.

Note

Only Refresh operations are supported when
Preserve Formulas and Comments in Ad Hoc
is selected. Other ad hoc operations, such as
Zoom In or Keep Only, are not supported.

Preserve Comments
and Unknown
Members

Preserves comments and unknown members in ad hoc grids.

Note

Only Refresh operations are supported when
Preserve Comments and Unknown Members
is selected. Other ad hoc operations, such as
Zoom In or Keep Only, are not supported.

Flex Forms: Preserve
Grid on POV and User
Variable Change

Retains modified members on a flex form after a POV or user variable
change.
If this option is not selected, any added rows or columns in the flex form
will be removed upon a POV or user variable change. For more
information, see Retaining Modified Members on Flex Forms After POV or
User Variable Change.

Formatting Options
Set Formatting options to control the textual display of members and data.
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Note

• Most formatting options apply to both forms and ad hoc grids. Exceptions are
noted in Table 1.

• Formatting options are sheet-level options that are specific to the sheet for which
they are set. Formatting options can also be saved for any new content that you
import from a data source using the Save Current Options as Default command.

• Formatting options are saved when a spreadsheet is saved. You will see the
saved formatting options when you reopen the spreadsheet.

To set formatting options:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Options.

2. In the Options dialog, select the Formatting tab.

3. Make selections in the Formatting tab as described in Formatting Options.

4. To set cell styles, see Cell Styles.

5. Optional: To save your Formatting tab selections as the default selections for any new
content that you import from a data source, select the Advanced tab, and then click Save
Current Options as Default.

6. Click OK to save the changes.

Formatting Options

Table 5-4    Formatting Options

Option Description

Dimension
Headers

For ad hoc grids only.
Print headers above row dimensions in the grid.
For example, with Dimensions Headers not selected:
 

 
With Dimension Headers selected:
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Table 5-4    (Cont.) Formatting Options

Option Description

Repeat Member
Labels

For forms only.
Facilitates the readability of forms by allowing member names to appear on
each row of data.
In forms where repeated members are merged into one cell, member names
may be out of the screen view, necessitating much back and forth scrolling
between the member names and the row data. Selecting Repeat Member
Labels helps make forms easier to read and use.

Use Thousands
Separator

Use a comma or other thousands separator in numerical data.

Number of
Decimal Places

Applies to ad hoc and forms. Overrides the setting defined in the form
definition.
Specify a decimal scale for the data values.
For example, in Smart View, assume the decimal option selected is "1". All
values will change one decimal place to the right. If the original value is
50.56, then after refresh the value will be displayed as 50.6. Similarly, if the
option selected is "3", then the displayed value will be 50.560.

Adjust Column
Width

Adjusts the column width to fit cell contents automatically.

Note

Sometimes, even after selecting this option, full
content may not be visible in the column due to a
limitation in Google Sheets. To view the full
content, you can double click the divider of the
column header to expand the column's width.

Use Cell Styles For ad hoc grids only.
Use background color formatting that you define for member styles, data
styles, and miscellaneous styles (where applicable). Overrides any user or
Google Sheets formatting.
You can set different cell styles for forms and ad hoc grids. For example, in
forms, you can set the member background color to green, and in ad hoc
grids, you can set the member background color to blue.

Note

By default, when you start ad hoc analysis, Use
Cell Styles is not enabled. So a form may display
styles, but the same may seem to disappear if you
open it as an ad hoc grid. See Using Smart View
Formatting (Cell Styles) for working with cell styles
in ad hoc grids.
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Table 5-4    (Cont.) Formatting Options

Option Description

Apply Styles For forms only.
Once a form is rendered within Smart View, select an option to view the
formatting on the sheet:
• None—Applies no styles (Google Sheets formatting or Smart View cell

styles) to the sheet. Though cell styles or custom styles may exist on the
sheet, neither are shown when selecting this option. They are preserved,
however, if you want to display them later using the Cell styles, Custom
styles, or Custom and cell styles options.

• Cell styles—Applies only Smart View cell styles to the sheet, as
described in this table.

• Custom styles—Applies only custom user-defined native Google Sheets
formatting to the sheet.

• Custom and cell styles—Applies both Google Sheets formatting and
Smart View cell styles to the sheet.
Note that when you select Custom and cell styles, cell styles take
precedent over custom Google Sheets formatting.

After making a selection, refresh the sheet.

Cell Styles Cell Styles
Member Styles Set the background color for the following member styles:

• Member
• Formula (forms only)

Data Styles Set the background color for the following data styles:
• Dirty
• Locked (forms only)
• Cell Text (these are cell comments in Oracle Fusion Cloud Enterprise

Performance Management)
• Attachment
• Drill-through
• Supporting Details
• Read-only
• Data

Miscellaneous
Styles

Set the background color for the following miscellaneous styles:
• Dimension Header (ad hoc only)
• Comment (these are comments placed outside the grid)
• Custom Label
• Excel Formula in Form (forms only)

Cell Styles
Set Cell Styles to control the display of members and data with respect to cell background
color and precedence.

Cell Styles control the Smart View formatting for forms and ad hoc grids.

• For forms, you can directly set the cell styles as explained in this topic.

• For ad hoc grids, you need to first enable cell styles. See Using Smart View Formatting
(Cell Styles) for enabling cell styles in ad hoc grids.

To set cell styles:
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1. In the Extensions menu, select Smart View for Google Workspace, and then select
Options.

2. In the Options dialog, select the Formatting tab.

3. In the Formatting tab, click Cell Styles.

4. Set the desired cell styles:

a. Expand a cell style group.

Note the three groupings of cell styles: Member Styles, Data Styles, and
Miscellaneous Styles. In this example, the Data Styles group is expanded to show the
available data types to which you can apply styles or change them. The example show
these available cell styles: Dirty, Cell Text, Attachment, Drill-through, Supporting
Details, Read-only, and Data.

 

 

b. Click a cell style to change.

A color picker control opens

c. Drag the color controls (the circles in the top left corner of each color block) till you
arrive at the color you want.

Following is the default color control. Move the bottom circle to choose a color
category and move the top circle to choose a color shade within that category:
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Following is an example of changing the color to a category and shade of blue:

 

 

d. When finished, click the X in the top right corner to close the pane and return to the
Cell Styles dialog.

5. In the Cell Styles dialog, click Done to return to the Options dialog.

6. To re-order precedence of cell styles, use the Move Up and Move Down buttons

or drag and drop the cell styles at the desired position.

Note

• If a cell belongs to multiple member or data types, then the order of
precedence determines the style that is applied to the cell. For example, a cell
is an editable data cell and also contains supporting details. The Data cell
style color is set as Orange, whereas the Supporting Details cell style color is
set as Blue. If the Supporting Detail style appears above the Data style in the
Cell Style dialog, then the Supporting Data style takes precedence and the
cell appears in Blue color. Conversely, if you move the Data style up and place
it above the Supporting Details style, then the Data style takes precedence
and the cell appears in Orange color.

• The Move Up and Move Down buttons appear on hovering over a cell style.

7. Click OK to save the changes.
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6
Dimensions and Members

Related Topics

• About Dimensions and Members
Dimensions are data categories used to organize business data for retrieval and
preservation of values.

• Displaying Point of View Dimensions
Using the POV panel, you can display POV dimensions, select members from a POV
dimension, and move them to and from the grid.

• Selecting Members
In Smart View, you select members to use in ad hoc grids and Oracle Fusion Cloud
Enterprise Performance Management forms.

• Working with Aliases and Alias Tables
Aliases are alternate names for database members.

• Viewing Qualified Member Names
You can view the qualified member names of members having non unique or identical
names for better understanding and identification.

About Dimensions and Members
Dimensions are data categories used to organize business data for retrieval and preservation
of values.

Dimensions usually contain hierarchies of related members grouped within them. For example,
a Year dimension often includes members for each time period, such as quarters and months.

Displaying Point of View Dimensions
Using the POV panel, you can display POV dimensions, select members from a POV
dimension, and move them to and from the grid.

The Point of View (POV) is the default starting point for dimensions in a data source
connection. You can select members and filters for the dimensions that you want to include in
the grid and move members to and from the grid.

Note

For non-unique or shared members, the POV displays the qualified name, instead of
the display name or member alias.

Displaying POV for Forms

To display point of view dimensions in forms:

1. Open a form.
To open a form, see Opening Forms in Google Sheets
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2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Data, and then select POV.
The POV panel opens on top of the Smart View Home panel. It displays the sheet name
and the POV dimensions related to the form. To close the POV panel, click the

.

Displaying POV for Ad Hoc Grids

To display point of view dimensions in ad hoc grid:

1. Display a grid in ad hoc mode.
To open a grid, see Starting Ad Hoc Analysis.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Data, and then select POV.
The POV panel opens on top of the Smart View Home panel. It displays the sheet name
and the POV dimensions related to the ad hoc grid. To close the POV panel, click the

.

Launching the POV Panel from Favorites

In addition to launching the POV panel from the menu navigation as explained in the above
sections, you can open the POV panel faster from the Favorites menu in Oracle Smart View
for Google Workspace. In the Smart View Home panel, click

, expand the Data section and click POV. You can mark it as favorite so that it appear in the
Favorites section at the top of the list.

When you launch the POV panel from the Favorites menu, the panel opens within the Smart
View Home panel. You can click

to close the panel and return to the Smart View Home panel.
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Syncing the POV Panel with the Active Sheet

In Smart View, you can work on multiple forms and ad hoc grids across sheets in the same
spreadsheet. The Sync and Refresh buttons in the POV panel help you maintain the context
of the POV panel to the active sheet.

These buttons are useful in the following scenarios:

• Switching between sheets: When you are working on a form or a grid and open the POV
panel, it displays the sheet name and the POV for the currently open form or grid. If you
switch to another form or grid in another sheet tab, the POV panel does not sync
automatically to display the POV dimensions as per the contents of the new sheet. It
continues to display the sheet name and POV of the previous sheet.

– To display the respective POV dimensions for the active form or grid, click Sync. The
POV panel now displays the name of the active sheet and the POV dimensions related
to the form or grid.

– To refresh the data on the active sheet and sync the POV panel with the sheet, click
Refresh. The sheet is refreshed and the POV panel now displays the name of the
active sheet and the POV dimensions related to the form or grid.

• Inserting attributes: While inserting attributes, when you select an attribute from the
Member Selector and click Insert, the attribute dimension is not automatically listed in the
POV panel. Click Sync to display the newly added attribute dimension in the POV panel.
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Note

Refreshing a form or ad hoc grid from the POV panel refreshes the sheet but not the
cell value that has been edited and kept in edit mode.

For example, in a form or ad hoc grid, you edit a data value, keep the cell in edit
mode, and then change the POV from the POV panel. When you click Refresh in the
POV panel, the sheet refreshes to display the data as per the changed POV, but the
cell in edit mode does not refresh. It continues to display the value as per the earlier
POV.

Related Topics:

• To select members from a POV dimension, see Selecting Members from a Point of View
Dimension.

• To pivot dimensions and members back and forth between the grid and the POV, see 
Pivoting Dimensions or Members between the Grid and the POV.

Selecting Members
In Smart View, you select members to use in ad hoc grids and Oracle Fusion Cloud Enterprise
Performance Management forms.

Related Topics

• Selecting Members from the Member Selector
You can use the Member Selector dialog to select members for a variety of purposes:
working on ad hoc grids, selecting and adding members to functions, displaying and
changing dimensions in POV, and so on.

• Selecting Members from a Point of View Dimension
You can select members and filters for the dimensions that you want to include in the grid
and move members to and from the grid.

• Entering Members in Free-Form Mode
If you are familiar with the dimensions and members of your database, you can enter their
names directly into cells using the free-form mode.

Selecting Members from the Member Selector
You can use the Member Selector dialog to select members for a variety of purposes: working
on ad hoc grids, selecting and adding members to functions, displaying and changing
dimensions in POV, and so on.

There are multiple ways to launch the Member Selector dialog. For example:

• From an ad hoc grid:
In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc. Select Analysis, and then select Member Selection.

• From the POV panel:
In the Extensions menu, select Smart View for Google Workspace, and then select Ad

Hoc. Select Data, and then select POV. Click  next to a POV dimension, and select
Member Selector from the drop-down list.

For more information, see Selecting Members from a Point of View Dimension.
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To select members:

1. Launch the Member Selector dialog.
The Members List is displayed in the left and the Selection List is displayed on the right. In
the below example, the Selection List appears empty as no member has been selected
yet.

 

 

2. In the Member Selector dialog, click the dimension selector drop-down,  (at the top left
of the dialog box above the Members list), and select a dimension. The members
belonging to the selected dimension are displayed in the Members list. In the below
example, the Members List displays all the member belonging to the Account dimension.
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If you accessed the Member Selector from a POV dimension in the POV panel, then the
dimension next to which you clicked

is automatically displayed in the drop-down, and you are not able to select another
dimension. In the below example, the Entity dimension is disabled for selection.
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3. Optional. To retrieve a specific set of members, use the Hierarchy drop-down, 

(accessed from the ellipsis button, , next to the dimension selector at the top left of
the dialog).

The member set filter will be applied to the highlighted member. To highlight a member,
click on the member name so that the name is highlighted. If no member is highlighted, the
filter will be applied to the dimension selected in the dimension selector drop-down.

Filter options, which may vary by data source type, are:

• Hierarchy to select all the members in the hierarchy

• Descendants to select all descendants of the selected member

• Descendants Inclusive to include the selected member and all descendants of the
selected member

• Children to select only the children of the selected member

• Children Inclusive to include the selected member and the children of the selected
member

• Siblings to select all siblings of the selected member

• Siblings Inclusive to include the selected member and all siblings of the selected
member

• LSiblings to include only the members that appear before the selected member with
the same parent
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• LSiblings Inclusive to include the selected member and its left siblings

• RSiblings to include only the members that appear after the selected member with the
same parent

• RSiblings Inclusive to include the selected member and its right siblings

• Parent to select only the parent of the selected member

• Parent Inclusive to include the selected member and the parent of the selected
member

• Ancestors to select all the ancestors of the selected member

• Ancestors Inclusive to include the selected member and all the ancestors of the
selected member

• Level 0 Descendants to display all descendants of the selected member that have no
children

• Level to display the Filter Argument dialog box, where you select one level in the
hierarchy of members

• Generation to display the Filter Argument dialog box, where you select one
generation in the hierarchy of members

• UDA to display the Filter Argument dialog box, where you select a user-defined
attribute (available only if defined by the administrator)

• Attribute to display the Filter Argument dialog box, where you select an attribute
name and attribute value (available only if defined by the administrator)

4. Optional. To search for members in the Members List, type the required word or letters in
the Search box.
The search results are displayed in the actual member hierarchy. You can take the
following actions on the search results using the menu next to the search icon.

• Find Next and Find Previous: Navigate to the next search result and previous search
result. You can also keep clicking the search icon to navigate to the next search result.

• Check All Found: Select all the search results in a single action for moving it across to
the Selection list.

In the below example, the term "Sales" is searched and the search results are displayed in
the Members list. Further, the Check All Found option is selected so that a check mark
appears next to all the search results
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5. Optional. To filter the retrieved list of members in the Members List, start typing in the
Filter box, present below the Members List. As you type, the list of members is filtered
simultaneously, and the typed letters are highlighted in yellow color for easy identification.
In the below example, members containing letters "cha" entered in the filter are highlighted
and displayed in the Members list.

 

 

6. To choose members for selection, hover directly to the left of a member name and click the
check box.

Note

The check box next to member names is hidden until the mouse hovers over it.

The figure below shows that for the "Cash Flow" member, the check box is blue, meaning
the member has been chosen for selection. For the "All Accounts" member, the check box
is gray, meaning the member has not yet been chosen but the cursor is hovering next to it.
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You can also:

• Click directly on a member name to choose a single member for selection.

• Use the mouse to drag a rectangle over a group of members to choose multiple
members for selection.

7. Optional. In the Members List, select the Actions drop-down menu, , to perform
these action:

• Check Children, Check Descendants, and Check Base Members to place a check
in the check box next to the applicable members, that is children, descendants, or
base members of a selected member.

• Clear Checks to clear all check marks.

• Expand All and Collapse All to view the member hierarchy in expanded or collapsed
form.

• Member Information to view information about a selected member from the Members
list.

• Alias Table to view alias table information, if available, and change the alias table

8. Click the Add button, , to move the checked members to the Selection list at the
right of the dialog.
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Conversely, use the Remove button, , to move members from the Selection list back
to the Members list (the list on the left in the dialog).

9. Optional. In the Selections list, use the Move Up, Move to Top, Move Down, or Move to
Bottom buttons to arrange the selected members in the order you want to them to appear
on the sheet.
The buttons that are enabled depend on the member you select in the Selections list. In
the following example, five members appear in the Selections list and the middle member
is selected. Therefore, all buttons are enabled since the middle member could be moved
up or down..

 

 

10. Optional. Toggle the arrows above the Selection list to select how to insert the members in
the grid:

inserts the selected members horizontally in a column

inserts the selected members vertically in a row

11. Optional. In the Selection list, select the Actions drop-down menu, , to perform
these actions:

• Select Dimension to add the dimension you selected in the dimension selector drop-
down (the first drop-down in the dialog box) to the Selection list.

• Remove All to remove all the selected members

• Check All and Clear Checks to add or remove checks from all the members in the
Selection list.

12. Click Done to close the dialog box and add the selected members to the grid, or click
Cancel to close the dialog box without saving any changes.

13. In the Extensions menu, select Smart View for Google Workspace, and then select
Refresh to update the data to correspond to the selected members.

Selecting Members from a Point of View Dimension
You can select members and filters for the dimensions that you want to include in the grid and
move members to and from the grid.
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Each connection is associated with only one POV; however, the same connection to different
sheets within a spreadsheet may have different POVs.

To select a member to add to the POV drop-down list:

1. Open an ad hoc grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Data, and then select POV.

4. In the POV panel, click the ellipsis button  next to a POV dimension, and from the
drop-down menu, choose Member Selector.

5. Select members in the Member Selector, and move them from the left to the right side of
the dialog. For more information, see Selecting Members from the Member Selector.

The selected members will appear in the drop-down menu for the dimension in the POV.
For example, in the Vision application, if we select every member in the Product
dimension, this would be a partial view of the resulting drop-down list:

Related Topics:

• To select members from the Member Selector, see Selecting Members from the Member
Selector.

• To pivot a member or dimension from the POV to the grid, see Pivoting Dimensions or
Members between the Grid and the POV.

Entering Members in Free-Form Mode
If you are familiar with the dimensions and members of your database, you can enter their
names directly into cells using the free-form mode.

You can use aliases from the alias table associated with the current grid in free-form mode. In
ad hoc grid, if you enter an alias from a different alias table, it will revert to the alias from the
current alias table

After connecting to a data source, you can enter member names as follows:

• By entering a member name in a blank cell

• By replacing a member name in a cell with a different member from the same dimension

You can still use the POV, member selection, and other ad hoc operations in free-form grids.

Working with Aliases and Alias Tables
Aliases are alternate names for database members.
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Related Topics

• About Aliases

• Selecting Alias Tables

About Aliases
Database member names are often stock numbers or product codes; their aliases can be more
descriptive.

For example, in the PBCS Vision Plan1 cube, the alias name for the "P_TP1" member in the
"Product" dimension is "Computer Equipment". Aliases are stored in alias tables as part of a
database. Dimensions can be associated with multiple alias tables.

Selecting Alias Tables
If an administrator has created alias tables in the database, you can select an alias table for
the current worksheet. The alias table selected applies only to the current worksheet and not to
future connections.

To select an alias table for the current worksheet:

1. Select a member in an ad hoc grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis, and then select Change Alias.

4. In the dialog box that is displayed, select an alias table, and then click OK.

Note

If you enter a name from an alias table that is not associated with the current grid, its
corresponding alias from the alias table that is associated with the current grid is
displayed after you refresh. For example, if you enter QTR1 into a grid that is
associated with the Long Names alias, the after you refresh, Quarter1 is displayed.

Viewing Qualified Member Names
You can view the qualified member names of members having non unique or identical names
for better understanding and identification.

Different members or member aliases may have identical names. For example, a database
may have two members named "New York," one for New York City and one for New York
State. Both members can appear as "New York" in the grid, but if you want to distinguish
between them, you can display their qualified names instead. Qualified names include the
member name and the names of its ancestors to the level that uniquely defines the member.
For example, [Market].[New York].

Following are the ways in which you can view the qualified names of identical members:
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Viewing Qualified Names in Cell Information

You can view qualified names of identical members in the Cell Information dialog. For more
information, see Viewing Member Cell Information.

To view the qualified names:

1. Select a member cell in the grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis, and then select Cell Information.

4. In the Member Information dialog, select the Alias tab to view the qualified name of the
selected member.

Displaying Qualified Names on the Sheet

You can display the qualified names on the sheet using Smart View Options.

To display the qualified names of identical members on the sheet:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Options.

2. In the Options dialog, select the Members tab.

3. From the Member Name Display drop-down menu, select Distinct Member Name Only.

4. In the Extensions menu, select Smart View for Google Workspace, and then select
Refresh.
The grid on the sheet is refreshed with the qualified names.

Viewing Qualified Names in Cell Notes

In Google Sheets, the qualified names appear in cell notes for the relevant members, when the
Distinct Member Name Only option is not selected in the Member Name Display drop-down
menu in Smart View Options. Cell notes are indicated with a triangle in the corner of a cell. You
can hover on the cell to view the qualified name. When a member cell with cell note is cut or
copied and pasted elsewhere on the sheet, or sorted within the grid, the note is also carried
along with the member to its new cell location.

Note

• It is strongly recommended not to add, delete, or change the text in the note, even
though it appears editable. Any change in the note text may result in loss of
metadata and may affect the context of the member on the sheet.

• Cell notes added manually by users using Google Sheet's Insert Note option are
not preserved on refreshing the grid.

• Qualified member names can be viewed in cell notes only in single ad hoc grid
sheets. These are not currently supported in multiple ad hoc grid sheets.

• In flex forms, cell notes displaying qualified member names appear only for
members with alias names present.

To view the qualified names of identical members:

Chapter 6
Viewing Qualified Member Names

Working with Oracle Smart View for Google Workspace
F56457-09
Copyright © 2025, Oracle and/or its affiliates.

August 1, 2025
Page 14 of 15



1. On the sheet, locate the member cell for which you want to see the qualified member
name.

Note

Cells with qualified member names appear with a triangle in the corner indicating
the presence of a note.

2. Hover on the cell to view the qualified name in a note that appear as a tooltip.
 

 

The first line displays the qualified name. For example, [Ops Metrics].[BPO Contacts].

The second line displays the name that appears on the sheet. For example, BPO Contacts.
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7
Data and Data Cells

Related Topics

• Refreshing Data
You can retrieve and refresh data for the current sheet in the spreadsheet.

• Submitting Data
You can update any type of data in the data source by submitting changed data from forms
and ad hoc grids.

• Calculating Data
After you submit new or changed data, you need to calculate the data in the database to
reflect your changes.

• Working with Cell Actions
Expand and collapse cells, view underlying member formulas, view detailed member
information, attach files and URLs, and review comments and cell history.

• Working with Supporting Details
You can enter supporting details for ad hoc grids and for writable cells in forms.

• Adjusting Values in Data Cells
You can adjust the value of one or more data cells by a specified number or percentage if
the cells contain numerical data.

• Spreading Values using Mass Allocation
Using mass allocation, you can spread data to all descendants of a source cell and across
all dimensions.

• Spreading Values using Grid Spread
If your administrator has enabled Grid Spread, you can specify an amount or percentage to
increase or decrease values across multiple dimensions on the grid, based on the existing
values in the target cells.

• Viewing Member Cell Information
You can view detailed information about any member cell on the grid.

• Working with Drill-Through Reports
Predefined by administrators, drill-through reports are available to users from specified
individual data cells.

• Working with Smart Lists
You can enter data using custom drop-down selection lists called Smart Lists, which are
accessed from data cells in forms and ad hoc grids.

• Resolving Data Validation Errors
If Service Administrators have set up any data validation rules, then users can view the
outcomes of these rules in Smart View and fix errors directly in the form.

Refreshing Data
You can retrieve and refresh data for the current sheet in the spreadsheet.

Refreshing applies to entire current sheet, and includes data in forms, ad hoc grids, and
functions.
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In the Extensions menu, select Smart View for Google Workspace, and then select Refresh
to refresh the current sheet.

Alternatively, you can also use the Refresh option available in the Favorites menu. Refreshing
is also part of some specific actions, such as the Refresh button in the POV panel that is used
to refresh the sheet after changing the POV.

Notes about Refreshing

• If you have multiple sheets in your spreadsheet, open each sheet and click Refresh to
refresh them separately. Refreshing all sheets in a spreadsheet at the same time is not
supported.

• On ad hoc sheets, Google Sheets filters are retained after refreshing.

• Selected POV members are reverted to dimension members after deleting some columns
and refreshing a sheet. To avoid this, click the POV button to hide the POV dimensions,
and ensure that you do not delete the column that contains the Page members.

• When working with multiple grids from multiple data sources in the same sheet, you can
refresh grid data for all connections at the same time.
For example, you are working on a sheet with Grid 1 and Grid 2 connected to Planning and
Grid 3 connected to Tax Reporting. When you click Refresh from the Smart View for
Google Workspace menu, all grids—Grid 1, Grid 2, and Grid 3—are refreshed at the
same time in a single operation.

– To refresh all grids together, select any cell outside the ranges of the grids and click
Refresh.

– To refresh only a particular grid, select any cell within the range of the grid and click
Refresh. This is saves the time taken to refresh data, especially when the sheet
contains a lot of grids.

• If support for Google Sheets is not enabled and, after connecting to a data source from
Smart View, you reopen a saved sheet and try to refresh or submit the saved sheet,
update and submit data in grids, or refresh functions in the sheet, a message appears
stating "This operation is not supported by the provider. Contact your Administrator to
enable support for Google Sheets". You cannot proceed further with submitting or
refreshing data, unless the support for Google Sheets is enabled by your Service
Administrator.

• Refreshing a form or ad hoc grid from the POV panel or the Favorites panel refreshes the
sheet but not the cell value that has been edited and kept in edit mode.

For example, in a form or ad hoc grid, you edit a data value, keep the cell in edit mode,
and then change the POV from the POV panel. When you click Refresh in the POV panel,
the sheet refreshes to display the data as per the changed POV, but the cell in edit mode
does not refresh. It continues to display the value as per the earlier POV.

Submitting Data
You can update any type of data in the data source by submitting changed data from forms and
ad hoc grids.

To submit data:

1. Connect to the data source and open a plan or a form in the grid.

2. Modify the data as needed.

3. In the Extensions menu, select Smart View for Google Workspace, and then select
Submit.
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Ensure that your cursor is somewhere in the grid when you submit data. All dirty cells on
the sheet are submitted. When the submit operation is complete, a toast message appears
stating "Done".

Submitting Data without Refreshing
This option allows users to submit all data from the sheet.

Submit Without Refresh includes all data cells that you have explicitly modified (made dirty)
and those that were not modified. All data cells are marked dirty and submitted.

Note

To help you identify modified cells, set a cell style for dirty cells.

To submit data without first refreshing:

1. Connect to the data source and open an ad hoc grid.

2. Modify the data as needed.

3. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

4. Select Data, Submit, and then select Submit Without Refresh.
Data for all cells on the sheet is submitted, whether or not the cells are dirty.

Calculating Data
After you submit new or changed data, you need to calculate the data in the database to reflect
your changes.

To calculate data, you must have security access rights to the data.

There are two methods that you can use to calculate data on Oracle Fusion Cloud Enterprise
Performance Management forms in Google Sheets:

• Business Rules allows you to select a business rule to apply to the form.

See Applying a Business Rule to a Cloud EPM Form.

• Rules on Form is created for each form to calculate subtotals.

See Calculating Subtotals on a Cloud EPM Form.

You can also run business rules on forms designed to calculate rules after submitting data. See 
Applying a Business Rule On Forms Defined to Run Rules When Submitting Data.

Applying a Business Rule to a Cloud EPM Form

To apply a business rule to a form:

1. Open a form.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Calculate, and then select Business Rules.

The business rules associated with the form are displayed in the Smart View panel.
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4. Optional: Click the Filter button at the bottom of the Business Rules panel to filter rules by
cube and rule type. All cubes and rule type options are selected by default. To narrow the
search, clear the check boxes for cubes and rule types that you do not need to see, and
then click Apply. The list is filtered according to your selections. In this example, we would
see business rules of all types that apply to only the Plan1 cube.

Figure 7-1    Business Rule Filtering Options

5. Select a business rule to launch it.

6. Enter any applicable runtime prompts, and then click Run.

7. A dialog box is displayed to let you know whether the business rule completed
successfully; click Close to close the dialog box.

If the calculation is successful, the values in the database reflect the results of the
calculation.

Calculating Subtotals on a Cloud EPM Form

To calculate the subtotals on a form:

1. Open a form.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Calculate, and then select Rules on Form.

Note

Click the Filter button at the bottom of the Business Rules panel to filter rules by
cube and rule type. All cubes and rule type options are selected by default. To
narrow the search, clear the check boxes for cubes and rule types that you do not
need to see, and then click Apply. The list is filtered according to your selections.

4. In the Smart View panel, select the rule to calculate the subtotals.

Any data that is not saved on the spreadsheet is lost when you launch the business rule.

5. A dialog box is displayed to let you know whether the business rule completed
successfully; click Close to close the dialog box.

If the calculation is successful, the values in the database reflect the results of the
calculation.
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Applying a Business Rule On Forms Defined to Run Rules When Submitting Data

Some forms are designed to run business rules when you submit data. In the web application,
this is referred to as "Run After Save."

To run business rules on a form designed to run rules when you submit data (also referred to
as Run After Save):

1. Open a form.

2. Make the changes you require in the form.

3. Click Submit.

The business rules associated with the form are displayed in a dialog page.

4. Enter any applicable runtime prompts, and then click Save.

Working with Cell Actions
Expand and collapse cells, view underlying member formulas, view detailed member
information, attach files and URLs, and review comments and cell history.

Adding Cell Comments
You can add one or more comments per data cell.

Each data cell can contain comments from multiple users. You can also add the same
comment in a range of contiguous data cells. Cells that contain comments can be associated
with a cell style.

The character limit set in Oracle Fusion Cloud Enterprise Performance Management is applied.

Depending on the permission level assigned to you by the administrator, you may be able to do
any of the following in a data cell:

• Add comments

• Add same comment to contiguous or adjacent cell ranges at the same time.

• View the comments that you and other users have added

• Delete comments that you have entered.

Note

You cannot delete comments entered by other users.

When you delete a comment, a dialog box asking you to confirm the deletion is not
displayed.

To add comments to a data cell:

1. In an ad hoc grid or a form, select a data cell or a range of data cells.

Use the Shift key to select a range of data cells. Do not use the Ctrl key to select cell
ranges.
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2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form or Ad Hoc.

3. Select Data, Cell Actions, and then select Cell Actions.

4. In the Cell Actions dialog box, select Text, and enter your comment.

5. If you have selected a range of cells, you can either enter comments for one cell at a time
or apply the comment to all selected cells.

• To enter a comment for one cell, select the cell from the drop-down menu and enter
the comment.

• To enter a comment for all selected cells, select Apply to all selected cells.

6. Click Post to save the comment.

7. Click Close to close the dialog box.

Adding Attachments
Documents can be attached to individual data cells by way of URLs or files.

Each data cell can contain multiple documents attached by one or more users. Depending on
the permission level assigned to you by the administrator, you may be able to do any of the
following in a data cell:

• Attach documents by way of URLs or files.

• Attach same document as a URL to contiguous or adjacent cell ranges at the same time.

Note

You cannot attach same document as a file to cell ranges at the same time. You
can attach files to one cell at a time.

• View the documents that you and other users have attached.

• Edit and delete documents that you have attached. You cannot edit or delete documents
attached by other users.

Cells that contain attachments can be associated with a cell style.

To attach documents to a data cell:

1. In an ad hoc grid or a form, select a data cell or a range of data cells.

Use the Shift key to select a range of data cells. Do not use the Ctrl key to select cell
ranges.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form or Ad Hoc.

3. Select Data, Cell Actions, and then select Cell Actions.

4. In the Cell Actions dialog box, select Attachments and do any of the following:

• To attach a URL, enter the title and URL for the document that you want to attach.
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Note

If you have selected a range of cells, you can either attach URLs to one cell at
a time or attach the same URL to all selected cells.

– To attach a URL to one cell in the range, select the cell from the drop-
down menu and attach the URL.

– To attach the same URL to all selected cells in the range, select Apply to
all selected cells.

• To attach a file, click , navigate to the file that you want to attach, select it, and click
Open.

5. Click Post to save your attachment selections.

6. Click Close to close the dialog box.

Note

To define a background color for cells that have attachments, in Smart View Options,
click Formatting and then click Cell Styles. Expand Data Styles and select
Attachment to set the color.

Expanding and Collapsing Cells
As you are working in forms, you can expand and collapse parent cells on the grid.

To expand or collapse a parent cell in a form:

1. Select a cell in a form.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form or Ad Hoc.

3. Select Data, Cell Actions, and then select Expand/Collapse.

Working with Supporting Details
You can enter supporting details for ad hoc grids and for writable cells in forms.

Supporting details serve as a built-in calculator for developing data that is not in the member
outline. Supporting details can include text, values, and operators that define how data
aggregates.
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Adding Supporting Details
You can enter supporting details for ad hoc grids cells and in writable cells in forms.

Note

• Supporting details cannot be added to non-level zero period, to read-only cells,
and to locked cells.

• When submitting supporting details,if the form is associated with rules set to Run
on Save, the Business Rules dialog appears.

To add supporting details:

1. In a form or ad hoc grid, select the cells in which you want to add the supporting details.

You can select one cell or a range of contiguous cells in a row or column. The selection
cannot include a combination of rows and columns. Select cells that are in the local
currency so that you can write to them.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form or Ad Hoc.

3. Select Data, Cell Actions, and then select Supporting Details.

The Supporting Details dialog reflects your cell selection.

4. Enter a description over the initial "untitled" text.

The text and its associated operator must be unique among children of the same parent.
By default, you can enter up to 1,500 characters.

5. Use the buttons to set or change the indented hierarchy to reflect the desired structure and
calculations.

For example, click Add Child to add a line item directly below the selected item.

For more information, see Setting Hierarchy in Supporting Details.

6. Set the mathematical relationships among the line items by selecting an operator for each
of them.

Select from these operators:

Operator Function

+ Add
- Subtract
* Multiple
/ Divide
~ Ignore

7. Enter data to set or calculate.

Enter numbers using the same scaling that was set up for the form.

8. Click Submit.

Values are dynamically calculated and aggregated before the data is submitted. Data on
the form is also submitted.
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Setting Hierarchy in Supporting Details
The supporting details hierarchy should reflect the type of information that supports the cell
values and the mathematical operators that create the relationships. You can set and change
this hierarchy.

To set hierarchy in supporting details:

1. In a form or ad hoc grid, select the cells with supporting details.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form or Ad Hoc.

3. Select Data, Cell Actions, and then select Supporting Details.

The Supporting Details dialog reflects your cell selection.

4. Set or change the rows that provide the details in the required hierarchy by putting the
cursor on an item and clicking the options in this table:

Table 7-1    Supporting Details options and their results

Option Result

Add Child Adds an item one level below the selected
cell. You can add an unlimited number of
children, but consider its potential
performance impact.

Add Sibling Adds an item at the same level as the selected
cell. You can add an unlimited number of
siblings, but consider its potential
performance impact.

Delete Removes the selected item

Delete All Simultaneously removes all supporting
details

Promote Moves the selected item to the next-higher
level

Demote Moves the selected item to the next-lower
level

Move Up Moves the selected item to before its sibling
predecessor

Move Down Moves the selected item to after its sibling
successor

Duplicate Row Adds a row below the selected item,
duplicating its structure (text, operator, and
values)

Fill For rows, copies the data from the current
cell to the cells to its right

Refresh Gets the latest stored database values,
restoring the previously saved values, and
possibly overwriting changes you just made.

5. Click Submit.
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Viewing and Changing Supporting Details
You can view and change the supporting details added in a cell.

Cells with supporting details can be indicated using cell styles so that they can be easily
identified in a grid. To define a background color for cells with supporting details, in Smart View
Options, click Formatting, and then click Cell Styles. Expand Data Styles and select
Supporting Details to set the color.

To view or change supporting details:

1. In a form or ad hoc grid, select the cells for which to view or add supporting details.

You can select one cell or a range of contiguous cells in a row or column. The selection
cannot include a combination of rows and columns. Select cells that are in the local
currency so that you can write to them.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form or Ad Hoc.

3. Select Data, Cell Actions, and then select Supporting Details.

The Supporting Details dialog reflects your cell selection.

4. View the details or change the line items or calculations that aggregate the data in the
selected cells.

Note

Supporting details must be edited only in the Supporting Details dialog box, and
not in the grid. If you try to edit the cells with supporting details in the grid itself,
then an error message appears stating "Data entry is not allowed for cells with
supporting details".

In Google Sheets, if you edit a cell containing supporting details in the grid, and
submit the cell while in edit mode, the error message is correctly displayed.
However, the edited value still gets submitted. This results in a mismatch of values
appearing in the grid and in the Supporting Details dialog box. To avoid this
erroneous scenario, always edit supporting details value from the Supporting
Details dialog box

Adjusting Values in Data Cells
You can adjust the value of one or more data cells by a specified number or percentage if the
cells contain numerical data.

To adjust values, you can select a single cell or a range of multiple cells, including continuous
or discontinuous cell ranges. However, while selecting a range, if you select a read-only cell, a
cell with supporting details, a cell with string or non-numeric values, or a cell outside the grid,
then relevant error messages inform you that the adjust operation cannot be performed and
prompt you to modify your selection.
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Note

Data cannot be adjusted over time periods, as spreading data for time periods is not
supported. For example, adjusting data in a Quarterly data cell does not adjust the
values in the corresponding Monthly data cells.

To adjust data values:

1. In a form or ad hoc grid, click the data cell that contains the value to adjust.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form or Ad Hoc.

3. Select Data, Adjust, and then select Adjust.

4. In Adjust Data, select an option and then enter the number or percentage by which you
want to adjust the value of the cell.

Available options are:

• Add fixed value to selected cell(s)

• Subtract fixed value from selected cell(s)

• Multiply selected cell(s) by a fixed value

• Divide selected cell(s) by a fixed value

• Increase selected cell(s) by a fixed percentage

• Decrease selected cell(s) by a fixed percentage

5. Click Adjust Data.

Spreading Values using Mass Allocation
Using mass allocation, you can spread data to all descendants of a source cell and across all
dimensions.

Spreading by mass allocation spreads data to cells not displayed on the grid and does not
require that you have access to the target cells.

When using mass allocation, keep in mind the following points:

• Mass allocation is available only for forms, which must be enabled for mass allocation by
the administrator.

• You must be provisioned with the Mass Allocate role to use mass allocation.

• Mass allocation cannot be undone.

To spread values by mass allocation:

1. Open a form.

2. Position the cursor in the Total or Subtotal cell whose value you want to spread.

3. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

4. Select Data, Adjust, and then select Mass Allocate.

5. Enter a new value in Spread Value to replace the current value, or from the drop-down
menu, select one of the following options:
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• Value to increase or decrease values by a specified amount

• Percentage to increase or decrease values by a percentage

6. Select Increase By or Decrease By and enter a value or percentage.

7. In Spread Value, enter the actual spread value that you want.

For example, if the Current Value is 100 and you want the spread value to be 125, enter
125 directly in Spread Value and do nothing with the Increase By and Decrease By
options.

Alternatively, you can enter 25 in Increase By, and 125 will be displayed in Spread Value.

Entering a value in Spread Value has no effect on the Increase By and Decrease By text
box. But when you enter a value in Increase By and Decrease By, the spread value is
reflected in the Spread Value text box.

8. Select the Spread Type for allocating the specified value or percentage across the target
cells:

• Proportional Spread to spread the value proportionally, based on the existing values
in the target cells (the default)

• Evenly Split to spread the value evenly among the target cells

• Fill to replace the value in all target cells

• Relational Spread to spread into the selected cells based on values that exist in a
different source location. Selecting this option displays the currently selected member
for each dimension in both the Current Relation and Choose Relation columns.
Double-clicking on any row opens Member-Selection You can now select any one
member for that dimension, which appears afterwards in the Choose Relation
column.

Your administrator can add other spreading patterns.

9. Click Spread.

The new values are automatically saved.

Spreading Values using Grid Spread
If your administrator has enabled Grid Spread, you can specify an amount or percentage to
increase or decrease values across multiple dimensions on the grid, based on the existing
values in the target cells.

When calculating the spread data, read-only and locked cells and cells having supporting detail
are ignored. Data integrity is ensured because values can be spread only to cells to which you
have access.
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Note

• Grid spreading is supported in flex forms only in cases where the Period
dimension is not flex enabled. If the Period dimension is in a column, then flex
form should not be enabled on columns. Similarly, if the Period dimension is in a
row, then flex form should not be enabled on rows.

• If the Show invalid members for flex form option is enabled in a form where flex
form is enabled only on rows, the rows contain any dimension other than Period,
and the Period dimension in columns is not flex enabled, then grid spreading may
work once, but does not work for subsequent spreading operations. While
designing such forms, ensure that the Show invalid members for flex form
check box, under Smart View Options in the Layout tab, is not selected so that
grid spreading works in flex forms.

To spread values using Grid Spread:

1. Open a form or an ad hoc grid.

2. Position the cursor in the Subtotal or Total source cell whose value you want to spread to
target cells.

3. In the Extensions menu, select Smart View for Google Workspace, and then select
Form or Ad Hoc.

4. Select Data, Adjust, and then select Grid Spread.

5. From the drop-down menu, select one of these options:

• Value to increase or decrease values by a specified amount

• Percentage to increase or decrease values by a percentage

6. Select Increase By or Decrease By and enter a value or percentage.

7. In Spread Value, enter the actual spread value that you want.

For example, if the Current Value is 100 and you want the spread value to be 125, enter
125 directly in Spread Value and do nothing with the Increase By/Decrease By options or
text box in the previous step.

Alternatively, you can enter 25 in Increase By, and 125 will be displayed in Spread Value.

Note

Entering a value in Spread Value has no effect on the Increase By/Decrease By
text box. But when you enter a value in Increase By/Decrease By, the spread
value is reflected in the Spread Value text box.

8. Select a spreading pattern:

• Proportional Spread to spread the value proportionally, based on the existing values
in the target cells (the default)

• Evenly Split to spread the value evenly among the target cells

• Fill to replace the value in all target cells

Your administrator can add other spreading patterns.
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9. Click Spread. The specified value or percentage is spread across the target cells,
replacing former values with new ones.

10. To save the new values, submit the sheet.

Viewing Member Cell Information
You can view detailed information about any member cell on the grid.

The information displayed depends on the data source type to which you are connected.

To view cell information:

1. Select a member cell in the grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis, and then select Cell Information.

4. View the information displayed in the following tabs. Only the tabs that are applicable to
the member and connection are displayed.

• Information: A list of general information about the member such as dimension, level,
generation, parent member name, and so on. These properties may vary based on the
selected member and dimension type.

• Aliases: A list of alias tables and corresponding aliases associated with the member

• Attributes: A table of the dimensions, members, and types of attributes associated
with the member

• Formula: The formula associated with the member

• Comments: A list of comments associated with the member

• User Defined Attributes: A list of user defined attributes (attributes of the member
defined by the administrator)

5. Click OK to return to the grid.

Working with Drill-Through Reports
Predefined by administrators, drill-through reports are available to users from specified
individual data cells.

Using drill-through reports, you can drill through to the detailed data in a database from Smart
View. Drill-through helps you to understand the source of a data value and get a granular level
of detail for a value. For example, when you drill down on the Period dimension member Q4,
you may see values for Jan, Feb and Mar.

Drill-through reports can be launched in a web browser from Smart View. Support for launching
drill-through reports in a new sheet will be made available in a future release.

Guidelines for Working with Drill-Through Reports

Consider these guidelines when working with drill-through reports:

• Cells that contain drill-through reports can be indicated on the grid by a cell style. For more
information on setting cell styles, see Formatting Options.

• The data displayed in a drill-through report is dynamic.
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• You cannot use alias names for drill-through; you must use member names.

Accessing Drill-Through Reports

To access a drill-through report:

1. Select a data cell associated with a drill-through report.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form or Ad Hoc.

3. Select Data and then select Drill-Through.

4. If there are multiple drill-through reports associated with the cell, select a report from the
list and click Launch.

If only one drill-through report is associated with the cell, the drill-through report launches
directly.

Enabling Pop-ups in Chrome for Using Drill-Through

To enable pop-ups in Chrome for using the drill-through feature, follow these steps:

1. Click the Chrome menu (the three dots icon

) on the browser toolbar, and select Settings.

2. Scroll down the page and click the arrow next to Advanced to see more settings.

3. In the Privacy and Security section, select Content Settings.

4. Select Pop-ups and Redirects.

5. In Allow, click Add.

6. In the Add Site dialog box, enter the URL for your environment, up to the port number; for
example:

https://<serviceURL>.oraclecloud.com

7. Click Add.

The URL should appear in the list under Allow.

Working with Smart Lists
You can enter data using custom drop-down selection lists called Smart Lists, which are
accessed from data cells in forms and ad hoc grids.

A Smart List is a drop-down selection list displayed in a form or ad hoc grid cell as an
alphanumeric text description, but stored in the database as a number. For example, an integer
Smart List for a reporting cycle may have the values 1-5, for Yearly (1), Quarterly (2), Monthly
(3), Daily (4), and Hourly (5). The values that are displayed on the form or ad hoc grid are
Yearly, Quarterly, Monthly, Daily, and Hourly. When you select one of these values on the form
or ad hoc grid, and submit the data, the number associated with it is stored in the database.
This means that you do not have to remember the numeric values associated with each time
period in the reporting cycle.

In Smart View, you access Smart Lists from custom drop-down lists in form or ad hoc grid
cells. When clicking into cells whose members are associated with a Smart List, you click the
down arrow that appears directly to the right of the cell, then select a drop-down list option
instead of typing data; in fact, you cannot type in a cell that contains a Smart List.
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For example, a data form may contain a Smart List called Justification that provides selections
for Research, Customer Feedback, and Expansion. When you click into Account cells named
Reason (whose members are associated with the Justification Smart List), a down arrow is
displayed. When you click the down arrow, it expands into a drop-down list with the following
selections:

• Research

• Customer Feedback

• Expansion

You then select one of the Smart List options as the value for the cell.

To enter a Smart List value in a form or ad hoc grid cell:

1. Open a form or ad hoc grid.

2. In the form or ad hoc grid, click into the data cell for which you want to select a Smart List
option.

A down arrow is displayed to the right of the cell.

Note

Only cells whose members are associated with Smart Lists contain Smart List
drop-down lists.

3. Click the down arrow for the cell.

The down arrow expands into a Smart List drop-down list with options from which you can
choose.

4. From the Smart List, select an option.

The option you select is entered into the data cell.

After selecting a value, the cell becomes "dirty" and the data is ready to submit.

Guidelines for Working with Smart Lists

• You can hand-type a Smart List value in cells that contain Smart Lists and perform a
Submit for both forms and ad hoc grids. However, if you type in an incorrect Smart List
value, then you will see this error message, "The value you entered is not valid."

• In forms containing Smart Lists, after deleting all values in a row in order to enter and
submit new data, the Smart Lists in that row are empty.

Workaround: Remove row values, and then perform a Submit (that is, you submit #Missing
values) or a Refresh. The Smart List drop-down arrows are then displayed properly. Now,
you can enter new values for the same row.

• Smart Lists are supported with the HsGetValue and HsSetValue functions. However, with
functions, you will not see the Smart List drop-down options. Instead:

– HsGetValue - Simply retrieves the Smart List value as a string value.

– HsSetValue - Submits the value as a string value.

• While working on Smart Lists in forms and ad hoc grids, if you press the Delete key in a
Smart List cell, then the cell value is cleared but the Smart List is retained in the cell.
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Note

If you are working on an ad hoc sheet in free-form state, then the Smart List
values are not retained on pressing the Delete key. As a workaround, you have to
refresh the sheet to get the Smart List values back in the drop-down list.

• Smart Lists must be set up and enabled by an administrator before you can use them in
Smart View. For more information on enabling Smart Lists for forms and ad hoc grids, see
the information Smart Lists in the relevant administration guide; for example see 
Administering Smart Lists in Administering Planning.

Resolving Data Validation Errors
If Service Administrators have set up any data validation rules, then users can view the
outcomes of these rules in Smart View and fix errors directly in the form.

Administrators can set up data validation rules to ensure that data meets company guidelines.
While setting the rules, they can set:

• Criteria for the data you enter

• Background colors to call your attention to data validation errors

• Messages that tell you what the criteria is

For more information on how to set up data validation rule, see the Administration Guide for
your business process.

If the data in a form does not meet the criteria in the data validation rules, the cells with errors
are displayed with the assigned background color. Smart View users can also use the Data
Validation panel, which lists the cells containing validation errors, grouped by validation rule.
When you click a cell from this list, it gets highlighted in the form and the message associated
with the rule appears in a tool tip.

To resolve data validation errors:

1. Open a form with errors and hover your cursor over the cell having a non-default colored
background to view the validation message.

Your administrator typically calls your attention to cells having data validation rule errors by
displaying them with a colored background.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Click Data and then click Data Validation.

4. In the Data Validation panel, expand the validation rule and review the list of cells with
errors.

5. Click each data cell that has validation errors and resolve each error based on the
instructions in the data validation message.

As you resolve errors, those cells are removed the list.

6. When you have resolved all errors, submit the data.

The background color and validation messages are cleared from the cells. If you open the
Data Validation panel now, it too appears blank.
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8
Data Forms

You can work with Oracle Fusion Cloud Enterprise Performance Management forms to view
and modify data.

Related Topics

• Working with Forms in Google Sheets
Forms are grid displays in which you can enter data into the database from Google Sheets
and view and analyze data or related text. Certain dimension member values are fixed,
giving you a specific view into the data.

• Opening Forms in Google Sheets
You can open Oracle Fusion Cloud Enterprise Performance Management forms in Google
Sheets.

• Copying Versions
You can copy data from one bottom-up or target version of a selected scenario to another
bottom-up or target version within the same scenario.

• Viewing Member Formulas
You can view the underlying formula in dimension member cells that contain a formula.

• Google Sheets Formulas in Forms
Consider the guidelines in this topic while using Google Sheets formulas in forms.

• Working with Flex Forms
Flex forms are a form type that provides flexible row management in Smart View.

Working with Forms in Google Sheets
Forms are grid displays in which you can enter data into the database from Google Sheets and
view and analyze data or related text. Certain dimension member values are fixed, giving you a
specific view into the data.

Using Oracle Smart View for Google Workspace, you can work with Oracle Fusion Cloud
Enterprise Performance Management forms in Google Sheets.

Guidelines for Forms Opened in Smart View

Consider the following guidelines for forms opened in Smart View:

• You can modify data values but not the form structure in forms.

• If you try to edit something on the sheet that is not allowed, then Google Sheets displays a
Heads Up warning message and asks if you want to proceed editing anyways. It is
recommended to click Cancel in the warning message to avoid editing and causing any
undesirable impact on the sheet.

• Values submitted to the database from Google Sheets must be non-formatted data.

• If a form is currently loaded in Google Sheets and the administrator changes the form
definition on the server, you should close the form and reload it. This action ensures that
the newest form definitions are displayed.
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• Customizations made to forms are preserved when you save or refresh only if they are
made outside the grid or if they are made to thousands and decimal separators.

• If you collapse a form on the web, and then open the form in Smart View, the form will be
displayed as fully expanded.

• If you remove a value in a cell, either by pressing backspace or by typing over the existing
cell value, and enter the same value again, the cell is not marked as dirty and you will not
be able to submit the same value again. However, if you press the Delete key for removing
the value, then it is marked as dirty and you will be able to submit the value.

• Composite forms are not supported. Starting in 21.05, Cloud EPM no longer officially
supports composite forms.

Guidelines for Smart Forms

You can open an existing Smart Form in Smart View; however, note the following:

• You cannot change the view type. Currently, whatever view is set through the web
application is used for display.

• User-defined functions (UDFs) are not supported.

• You cannot create a new Smart Form.

• When a Smart Form is opened as an ad hoc grid in a multiple-grid sheet, the formula cells
appear blank since the layout changes and formula references are not retained.

Opening Forms in Google Sheets
You can open Oracle Fusion Cloud Enterprise Performance Management forms in Google
Sheets.

To open a form:

1. Connect to a data source.

2. In the Smart View Home panel, expand the library tree list.
Depending on the data source provider, you may see different artifacts indicated by the
following icons:

•
— Form

•
— Flex Form

•
— Smart Form

•
— Saved Ad Hoc Grid

3. Do any of the following:

• To select a form without opening it, click its icon or the area next to its name.

• To open a form, click the form's name.

• To open a form directly in ad hoc analysis mode, that is as an ad hoc grid, first select it,
right-click on it, and then select the Ad Hoc Analysis option in the menu.
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• To open an ad hoc grid as a form, first select it, right-click on it, and then select the
Open Form option in the menu.

• To open a flex form, click the flex form's name.

• To open a flex form as a simple form or ad hoc grid, right-click the flex form icon, or the
space after the flex form name and select the Open Form or Ad Hoc Analysis option.

4. Optional: View instructions associated with the form.

a. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

b. Select Data, More, and then select Instructions.

Copying Versions
You can copy data from one bottom-up or target version of a selected scenario to another
bottom-up or target version within the same scenario.

For example, you can create a Best Case version and copy some or all the data in that version
to a Worst Case version to quickly create a starting point for the new version.

You can copy between bottom-up and target versions.

• When you copy to a bottom-up version, only the selected level 0 members are copied.

• When you copy to a target version, all selected members are copied.

• To protect data in approved planning units, copying a version does not copy to approved
planning units.

Note

• To successfully copy data, when specifying the copy data criteria, you must select
at least one member for the Scenario, Account, Entity, Period, and Version
dimensions.

• The Copy Version action is available based on role for authorized users like
Service Administrators.

To copy a version at application level:

1. From the Actions Menu in the Smart View Home panel, click Copy Version.

Alternatively, you can right-click in the Smart View Home panel and click Copy Version.

2. In Scenario, select the scenario to copy.

3. In Copy From, select the source version.

4. In Copy To, select the destination version.

5. Click Go to display the available entities (planning units) for the selected source version.

6. Use the arrow keys to move entities from Available Entities to Selected Entities.

You can copy entities with a process status of not started or first pass.

7. Optional: To copy associated information, select these options:

• Copy Account Annotations
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Only annotations for selected entities are copied. If you are copying to a bottom-up
version, only level 0 entities (and their annotations) are copied.

• Copy Cell Comments and Annotations

• Copy Supporting Details

8. Click Copy Data.

Note

Wait for the message indicating that the copy data operations was successful before
loading another Web page.

Viewing Member Formulas
You can view the underlying formula in dimension member cells that contain a formula.

To view member formulas:

1. Open a form.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Data, More, and then select Member Formula.

The list of members containing formulas for the selected dimension are displayed in the
Member Formula dialog.

4. Select a member from the displayed list to view its formula in the Member Formula dialog.

Google Sheets Formulas in Forms
Consider the guidelines in this topic while using Google Sheets formulas in forms.

• You can create Google Sheets formulas in form cells inside or outside the grid if the cells
are not read-only or locked.

• Cells that contain cell text can contain Google Sheets formulas, but cells containing
supporting detail (such as Oracle Fusion Cloud Enterprise Performance Management
cells) cannot.

• Formulas are preserved in forms when you refresh the form even without saving the data.

• If you move a referential formula, its cell references are updated to reflect the new location.

• A cell with formula displays the dirty cell style if the value in the cell reference, present
either in the same sheet or another sheet, is updated. On submitting, the updated value in
the formula cell also gets submitted.

• In forms, you are prompted to save the spreadsheet as an Google Sheets file if you do any
of the following (but you temporarily lose access to the form):

– Change the current page

– Select a different form

– Connect to a different data source

Chapter 8
Viewing Member Formulas

Working with Oracle Smart View for Google Workspace
F56457-09
Copyright © 2025, Oracle and/or its affiliates.

August 1, 2025
Page 4 of 19



Working with Flex Forms
Flex forms are a form type that provides flexible row management in Smart View.

Related Topics

• About Flex Forms
Flex forms are a form type that provides flexible row and column management in Smart
View.

• Best Practices for Working with Flex Forms
Contains best practices and guidelines for working with flex forms.

• Working with Flex Forms in Smart View
With flex forms, you can rearrange row and column dimensions, and insert valid members
or aliases from corresponding dimensions.

• Opening a Flex Form in Ad Hoc Mode and Submitting Data
You can open a flex form in ad hoc mode, just like any regular form, use ad hoc analysis to
modify the grid layout, and submit data.

About Flex Forms
Flex forms are a form type that provides flexible row and column management in Smart View.

Flex forms retain all regular form properties and features, such as running business rules
attached to the flex form. However, using flex forms, and depending on the flex form design,
you can rearrange row and column members. Modified row or column order is maintained on
refresh and during submit.

In the web application, during form definition, Service Administrators select Enable flex form
on rows, Enable flex form on columns, or both options, under Smart View Options in the
Layout tab to enable flex form-specific features. Depending on those selections, dimension
and member row cells and all data cells in a flex form are unprotected. For example, if only
Enable flex form on rows is enabled, then column members are protected. If only Enable
flex form on columns, then row members are protected. If both are enabled, then only the top
left blank cells are protected.

In Smart View, the Sheet Info dialog displays the Sheet Type for flex forms as "Flex form".
Flex forms can be part of task lists and you can open them as flex forms from a task list.

Note

Flex forms are used only in Smart View and not in the web application.

Best Practices for Working with Flex Forms
Contains best practices and guidelines for working with flex forms.

Related Topics

• General Guidelines for Flex Forms

• Selecting Members in Flex Forms

• Sorting in Flex Forms
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• Using Suppression Options in Flex Forms

• Working with Shared Members and Suppression Options in Flex Forms

• Flexing Beyond the Form Definition

• Retaining Invalid Members on Flex Forms

• Retaining Formula, Label, and Comment Rows and Columns on Flex Forms

• Retaining Modified Members on Flex Forms After POV or User Variable Change

• Unsupported Features on Flex Forms

General Guidelines for Flex Forms
• You can modify both row and column members in flex forms.

• Any modification to a flex form will not be persisted between sessions.
When a user modifies a flex form, the modified grid layout will only be persisted in the
context of the current session. Reopening a flex form reverts the flex form layout to its
original state.

• You may insert and delete member rows and columns in a flex form using the Insert and
Delete actions using the right-click menu of Google Sheets.
Depending on whether the options Enable flex form for rows. Enable flex form for
columns, or both, are enabled, you can insert or delete rows or columns within and
outside of the flex form grid.

Service Administrators: In the form definition, choose either or both of the following
options:

– To allow users to insert or delete rows, select Enable flex form for rows

– To allow users to insert or delete columns, select Enable flex form for columns

• It is not recommended to insert new rows above column dimensions as this impacts the
structure of the grid. Similarly, new columns should not be inserted to the left of row
dimensions.

• Access permission settings are honored in flex forms.

• Valid intersections are honored in flex forms.

• Business rules may be run on flex forms.

• When a flex form with a business rule or Groovy rule to add a new dimension member
(member on-the-fly) is executed from the form, the new member will not appear on the flex
form after a refresh. To see the new member on the flex form, you must reopen the flex
form.

• There is limited support for grid spreading in flex forms.

– Grid spreading is supported in flex forms only in cases where the Period dimension is
not flex enabled. If the Period dimension is in a column, then flex form should not be
enabled on columns. Similarly, if the Period dimension is in a row, then flex form
should not be enabled on rows.

– If the Show invalid members for flex form option is enabled in a form where flex
form is enabled only on rows, the rows contain any dimension other than Period, and
the Period dimension in columns is not flex enabled, then grid spreading may work
once, but does not work for subsequent grid spreading operations. While designing
such forms, ensure that the Show invalid members for flex form check box, under
Smart View Options in the Layout tab, is not selected so that grid spreading works in
flex forms.
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• You may delete rows and columns using the Delete key. However, when deleting rows or
columns containing multiple dimensions, be sure to select all the dimension members in
the row or column before pressing Delete.
In the following example, there are three row dimensions on a flex form, Accounts, Market,
and Year:

D-Acc US Market FY18

D-Acc US Market FY19

D-Acc US Market FY20

To remove the row for FY18 using the Delete key, be sure to select all three dimension
members, D-Acc, US Market, and FY18 using the Ctrl key or Shift key, then press Delete.

• Under the Dimension Properties, if Flex beyond form definition is not selected for the
flex form, then copy and paste is limited to the scope of the form definition. Flex forms
must adhere to the hierarchies as defined in the form. Therefore, you cannot have any flex
form members that are not part of the defined row or column members of the form.
To allow adding members outside of the form definition, either by hand-typing or using
copy and paste, the Flex beyond form definition option must be selected. For more
information, see Flexing Beyond the Form Definition.

• Subtotaling calculation scripts and currency conversion calculation scripts will be
generated and executed based on the original form definition.

• In the form definition, if Enable flex form for rows, Enable flex form for columns, or
both, are selected, a flex form opened as a simple form can preserve comments in cells
outside the form after refresh.
However, when opened as a flex form:

– If both the Enable flex form for rows and Enable flex form for columns options are
selected, then comments are not preserved.

– If only the Enable flex form for rows option is selected, then comments entered to
the right of the form are preserved after refresh. Comments are not preserved if they
are entered directly below the form.

– If only the Enable flex form for columns option is selected, then comments entered
below the form are preserved after refresh. Comments are not preserved if they are
entered to the right of the form.

• Both member and alias display is not supported for flex forms:

– In the Application Settings for the business process, in Display Member Label as,
neither the Member Name:Alias or the Alias:Member Name option is supported.

– During form definition, in Dimension Properties, selecting both the Member name
and Alias options is not supported for flex forms. Select either Member name or
Alias.

• When working with flex forms with multiple dimensions on rows or columns (where two or
more dimensions with multiple members are placed on a row or columns):

– Rows and columns appear expanded by default.

– During form definition, to place dimensions members on separate rows or columns, in
Member Selection on the flex form, choose Place selection in separate rows or
Place Selection in Separate Columns. See the documentation on selecting
members for forms in your business process administration guide; for example, for
Planning, see Selecting Members for Forms in Administering Planning.

• When entering numeric member names or shared members on a flex form, enter a single
quotation mark ( ' ) before the member name.
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For example, for a numeric member name, such as 4077, enter:

'4077

For shared members, enter member names in the format:

'[Parent].[Shared Member]

For example:

'[Sales Director 2].[410]

'[Default_Sales Director 2].[Default_International Sales]

• User variables, dynamic user variables, dynamic user variables with attributes, and
substitution variables are supported on flex form rows and columns. Users should change
variables on the POV and perform a refresh for the rows and columns to update them to
the new members.

• Excluded members may be entered on flex form rows or columns. Members that are
excluded in the form definition can be entered on flex form rows and users are able to
enter values and submit.

• In the form definition, when Enable flex form for rows, Enable flex form for columns or
both are enabled, then the Segment properties Hide and Read-only are not supported for
either rows or columns. Hide and Read-only are supported only in simple forms.

• In flex forms, cell notes displaying qualified member names appear only for members with
alias names present.

Selecting Members in Flex Forms
You can select row or column members to add to a flex form using the Member Selection
dialog box. The Member Selection option is available only on flex forms, and not on simple
forms.

To launch the Member Selection dialog:

1. Select the member cell.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Analysis and then select Member Selection.

Use the Member Selection dialog to add row or column members to a flex form, similar to
adding members to an ad hoc grid. The members you can add depend on the underlying form
definition for the row or column dimensions:

• If the Dimension Properties setting, Flex beyond form definition, is selected, users may
select members outside those specified in the form definition. For example, suppose a
form includes only the Computer Accessories members from the Product dimension. If
Flex beyond form definition is selected for the Product dimension, then users may add
other members from Product, such as Notebooks or Tablets, to the flex form. These
members will be retained upon refresh. For more information, see Flexing Beyond the
Form Definition.

• In the form definition of a flex form, if specific members are not part of a dimension, then,
even though you may be able to select and add those members in the Member Selection
dialog, those members will be removed upon refresh.
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Note

To add members outside the form definition, enable Flex beyond form definition
on the applicable dimensions.

Member Selection uses the default alias table defined at the application level. When members
are inserted on the grid, the members are displayed as member names until a Refresh is
performed, and then aliases are displayed corresponding to the application setting.

Sorting in Flex Forms
• Sorting disables submitting of data as it changes member order in the column. After sorting

you must refresh to submit data.

• Sorting can sometimes change the position of the column header member if the grid
structure is not correct. Users need to ensure that sorting such a grid does not impact the
integrity of the grid.

To avoid undesirable sorting results, do not apply sorting to an entire column. Instead,
select the grid members to sort, and then use Sort commands, Sort A to Z or Sort Z to A,
or perform a custom sort.

Using Suppression Options in Flex Forms
• In the form designer, the Use database suppression option is not supported; however,

the Suppress missing blocks, Suppress missing data - Rows, and Suppress missing
data - Columns options are supported.

Note

Groovy rules are not supported in flex forms when suppression options are
enabled.

• The Suppress missing blocks, Suppress missing data - Rows, and Suppress missing
data - Columns options defined in the web for a flex form are applied only when first
opening the flex form in Smart View. Depending on the form definition, flex form users can
enter members on columns or rows even though the suppression options are enabled in
web form. Users can also enter data and submit data for the suppressed members.
If the suppression options in Smart View Options, Data Options tab, for Suppress
Missing Blocks, Suppress Missing Rows, and Suppress Missing Columns are
selected, they are applied to the flex form. Users can uncheck these options and then add
members (by typing them on the sheet or using Member Selection), enter data, submit
data, and refresh the flex form.

Working with Shared Members and Suppression Options in Flex Forms
Consider the following scenario in form design, where:

1. Shared members are on the row, column, or both

2. Drill on shared members is enabled

3. Suppress missing blocks and Suppress missing data are enabled

When opening the form, shared members are converted to base member, and query is based
on the base members.
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When opened as a flex form (Enable flex form for rows, Enable flex form for columns, or
both are selected), since the base member is beyond the form definition, if it is the only
member in the flex form row or column, this error is shown: "Flex form cannot be refreshed or
saved without valid members on Account dimension."

If there are other valid members on the row or column, and the Show invalid members for
flex form option is enabled, then the base members will become comments.

Workarounds: To avoid this error, use one or both of the following workarounds:

• Enable the Flex beyond form definition option.

• Clear the Drill on shared members option.

Flexing Beyond the Form Definition
During form definition, when the Flex beyond form definition property is applied to row or
column dimensions in flex forms, Smart View users may enter members outside the form
definition for dimensions within the row or column axis of the form. This allows flex form users
to enter data for members that are not displayed on the flex form. Users must have access to
the valid members that they enter.

For example, using the Vision application, suppose the Product dimension is placed as a row
dimension in a flex form. During form definition, only the Sentinal Standard Notebook and
Sentinal Custom Notebook members in the Product dimension have been selected for display
on the form. By enabling the Flex beyond form definition option for the Product dimension,
Smart View users may enter other products from the Product dimension, such as Mouse or
Keyboard, in the rows in the flex form. As long as they have access to those members, users
can either add rows for additional members to the existing flex form or replace existing Product
members with the Product members they require. To illustrate, note the following hierarchy:

Product
   Notebooks  <<this hierarchy is displayed in flex form)
      Sentinal Standard Notebook
      Sentinal Custom Notebook
   Computer Accessories  <<this hierarchy is not displayed in flex form)
      Keyboard
      Mouse

In a flex form with Flex beyond form definition disabled (not selected), users cannot add
Computer Accessories or its descendants. Users can add Notebooks and its descendants.

In a flex form with Flex beyond form definition enabled (selected), users can add Computer
Accessories and its descendants as well as Notebooks and its descendants.

During form definition, note the following when enabling the Flex beyond form definition
property:

• In Dimension Properties, the Flex beyond form definition option will only be visible if
either the Enable flex form for rows or Enable flex form for columns option, or both, is
selected in Smart View Options.

• When there are multiple dimensions on the form rows, Oracle recommends that you select
the Flex beyond form definition property for each applicable row or column dimension
individually. You may use the Dimension Properties option, Apply to all row | column |
page dimensions, to apply the Flex beyond form definition property to all dimensions;
however, use with care as all other dimension property selections will also be applied to all
other dimensions.
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See Designing Flex Forms in Administering Planning.

Retaining Invalid Members on Flex Forms
In flex forms, you can retain invalid members on the sheet after a refresh.

When entering member names in a flex form, errors may occur; for example, you may:

• Mistype or misspell a name, creating an invalid member in the cell

• Make an error when copying and pasting member names from one sheet to another, or
within the same sheet, resulting in invalid members

• Enter a member name that is beyond the form definition, resulting in an invalid member

If Show invalid members for flex form is not enabled, then when the above situations occur,
the rows or columns with invalid members are removed from the sheet upon refresh, making it
difficult to know what the issue is, and forcing you to reenter member names.

The flex form can retain any invalid members on the form after refresh if the Oracle Fusion
Cloud Enterprise Performance Management Service Administrator enables the Show invalid
members for flex form check box under Smart View Options in the Layout tab of the form
definition, described in Enabling the Invalid Member Option.

Related Topics:

Retaining and Resolving Invalid Members

Example of Misspelled Member Name

Example of Missing Member Name on Multi-Dimension Row

Example of Member Name Entered that is Outside of Form Definition

Enabling the Invalid Member Option

Retaining and Resolving Invalid Members

To retain and resolve invalid members:

1. In the flex form, add the rows, columns, or both, as you require.

2. Type or copy member names into the new rows, columns, or both.

3. Perform a refresh.
Any invalid member cells are highlighted and #InvalidMember is displayed in the
corresponding data cells.

4. Review the invalid member cells and correct any mistyped or missing members, and then
refresh.

5. Repeat the previous step until all invalid members are corrected.

Chapter 8
Working with Flex Forms

Working with Oracle Smart View for Google Workspace
F56457-09
Copyright © 2025, Oracle and/or its affiliates.

August 1, 2025
Page 11 of 19



Note

• In rows and columns containing multiple dimensions, if even a single member is
invalid, all members on the row or column are highlighted as invalid. For example,
if a row contains the Tablet and Current members, and you type Tablet correctly,
but type Currnt in error, both the Tablet and Currnt members will be highlighted as
invalid. You should examine all the highlighted member names and correct those
that are typed incorrectly.

• After inserting a blank row or column into the flex form and performing a refresh, if
no member names were entered, then the inserted row or column is highlighted as
an invalid member row or column and remains on the flex form as a blank row or
column.

• Attempting to delete an entire row or column by selecting the invalid member cells
of a row or column and pressing the Delete key will result in invalid members in
the member cells upon refresh. To delete entire rows or columns on a flex form,
use the delete entire row or delete entire column operations in Google Sheets.

Following are some example scenarios that show you how to work with invalid members on the
sheet.

Example of Misspelled Member Name

For example, based on the Vision application form, HR Expenses, you open the form as a flex
form. The Service Administrator has enabled the Smart View options, "Enable flex form for
rows" and "Show invalid members for flex form."

Figure 8-1    Flex Form Containing No "7690: Meals" Member

You notice that the "7690: Meals" member is not present on the form so you set out to add it.
You insert a row on the grid and begin typing, but make a spelling error. After refreshing, Smart
View calls out the row for you with the member cells highlighted and the data cells displaying
#InvalidMember.
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Figure 8-2    Flex Form with Invalid Member Row Highlighted

After fixing the spelling error, perform a refresh and note that the flex form is displayed
correctly, with the valid member names and data.

Figure 8-3    Flex Form with Error Corrected and Valid Members Displayed

Example of Missing Member Name on Multi-Dimension Row

#InvalidMember is displayed on the flex form in Smart View when a row or column has multiple
members and you miss entering a member on a member cell in that row or column. In the
following example, there are two dimensions on the rows. You added two rows after row 14.
The members from the Product dimension in Column A, rows 15 and 16, were typed correctly.
But you did not type any entries in the same rows in Column B. Those cells are missing the
member name from the Entity dimension. This is the result after performing a refresh.
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Figure 8-4    Flex Form with Missing Member Names in Column B, Rows 15 and 16

To correct this issue, add the correct members, "Sales East" and "International Sales". in
Column B, rows 15 and 16, and then perform a refresh.

Example of Member Name Entered that is Outside of Form Definition

#Invalidmember is displayed on the flex form in Smart View when you enter a member that is
beyond the form definition.

For example, suppose that in the form, the Year dimension is limited to FY16. But in the
application outline, the dimension contains many more members, such as FY17, FY18, and
FY19.

When designing a flex form, if the Service Administrator has selected the "Flex beyond form
definition" option for the Year dimension, then you may add members that are outside of the
form definition, such as FY17. If the "Flex beyond form definition" option is not selected, then
adding a member that is outside of the form definition will result in invalid members, even
though the members exist in the outline.

In the following case, the "Flex beyond form definition" option was not selected for the Year
dimension on the column. You add four columns and enter FY17 in the first row, and Jan, Feb,
Mar, and Q1 in the second row, and then refresh. Note below that columns F through I now
contains invalid members.

Figure 8-5    "Flex beyond form definition" Is Not Selected and Member Is Outside of
Form Definition
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To remedy this, your Service Administrator should select the Flex beyond form definition
option for the Year dimension. With this option selected for the form, you may enter the
members that are outside of the form definition, perform a refresh, and retain the members on
the flex form.

Enabling the Invalid Member Option

Service Administrators: Enabling the new Show invalid members for flex form check box
lets users easily see, understand, and correct any error they may have made in entering
member names in flex forms.

To retain invalid members on a flex form, a Service Administrator performs these steps from
the Cloud EPM web interface:

1. From the Navigator, under Create and Manage, select Forms.

2. Select an existing form to edit or, in the Form and Ad Hoc Grid Management page, click
the Actions drop-down menu and select Create Simple form.

3. In the form definition page, under Smart View Options in the Layout tab, select the
Enable flex form for rows and Enable flex form for columns check boxes, as you
require. You may select one or both of these options.

4. Select the Show invalid members for flex form check box.

Tip

The Show invalid members for flex form check box is enabled only when
Enable flex form for rows or Enable flex form for columns, or both, are
selected, as described in the previous step.

5. Optional: For individual rows or columns, in Dimension Properties, enable the Flex
beyond form definition option, as you require.

6. Save the form.

For more information on setting this option, see:

• Administering FreeForm

– Designing Flex Forms

– Setting Smart View Form Options

– Setting Dimension Properties

• Administering Planning

– Designing Flex Forms

– Setting Smart View Form Options

– Setting Dimension Properties

Retaining Formula, Label, and Comment Rows and Columns on Flex Forms
You can retain formula rows and columns on flex forms by enabling the "Show invalid members
for flex form" option during form definition. When a Service Administrator enables this option,
formula rows and columns are retained on the flex form after a refresh or a submit.
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Note

Formula rows and columns are also referred to as label or comment rows and
columns.

After a refresh or submit operation, all members and data on a formula row or column are
highlighted using the same cell style as used for invalid members, described in Retaining
Invalid Members on Flex Forms.

Note

Attempting to delete an entire row or column by using the Delete key to delete only the
member cells of a row or column will result in invalid members in the member cells
upon refresh. To delete entire rows or columns on a flex form, select the entire row or
column, right-click, and then select Delete from the Google Sheets context menu.

Enabling the Show invalid members for flex form option gives users the versatility of flex
forms when working with forms containing formula rows and columns.

Retaining Modified Members on Flex Forms After POV or User Variable Change
To retain modified members on a flex form after a POV or user variable change, you enable
Flex Forms: Preserve Grid on POV and User Variable Changes in the Options dialog,
Members tab.

If this option is not selected, any added rows or columns in the flex form will be removed upon
a POV or user variable change.

To retain added members on a flex form after a POV or user variable change:

1. Follow the procedure in Member Options to launch the Options dialog, Members tab.

2. Select the Flex Forms: Preserve Grid on POV and User Variable Changes check box.

3. Save your selection and close the Options dialog.
Use the procedure in Member Options to choose an option for saving your selection.

4. Optional: Add or delete members in the flex form, and click Refresh.

5. Perform these tasks as you require:

• Change a POV member and click Refresh

• Change a user variable; the flex form refreshes automatically.

Your modified members are retained. You can now enter and submit data against the
modified POV and user variables in any of the members in the flex form, including any
newly-added members.

6. Optional: Change the POV or any user variable again and refresh, and then continue
entering data against the updated POV and user variables.

See also:

• Working with Flex Forms in Smart View

• Member Options
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Unsupported Features on Flex Forms
The following form features are not supported for flex forms:

• Using Segment Properties: Hide, Read-only, Enable drop-down for dimensions (row
dimension drop-down member selectors), Suppress Hierarchy

Note

After rows are rearranged or sorted, segment properties are not retained.

• Spreading data for time periods

• Filtering data in columns

• Using formulas in rows or columns

• Using the Member Name and Alias option

• Using flex forms inside composite forms

• Enabling Show Currency for the Entity dimension.

• Data validation rules within forms are not supported when using flex forms. Instead,
convert data validation rules to Groovy rules.

Flex forms are not supported for:

• Dashboards

• Smart Forms

• Task Manager extension

Working with Flex Forms in Smart View
With flex forms, you can rearrange row and column dimensions, and insert valid members or
aliases from corresponding dimensions.

Perform a refresh prior to submitting data in the modified form in Smart View. Upon refresh,
invalid members, comments, and empty rows or columns are removed and submitting of data
is enabled.

To work with a flex form:

1. Connect to a data source.

2. In the Smart View Home panel, click a flex form name to open it.

By default, when you click the flex form name, it opens as a flex form.

Flex forms are indicated by the

icon.

You can choose to open the flex form as a simple form or ad hoc grid by right-clicking the
flex form and selecting the Open Form or Ad Hoc Analysis option.

3. Modify the data as per your requirements.

For example, some actions you may perform are:

• Rearrange or move row and column members
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• Insert rows and columns

• Delete rows and columns

• Add members. You can add members using Member Selection or hand-typing
member names.

• Run a business rule

Note

• Submitting of data is disabled when you edit row members.

• In the Smart View Options dialog, Formatting tab, the Repeat Member
Labels check box is required to be enabled for flex forms. You may attempt to
clear the check box, but upon refresh, the check box will again be selected
and the Repeat Member Labels option will be enabled.

• The operations you can perform on rows and columns depend on the
selections made by your Service Administrator or form designer during form
definition. To perform operations on rows, the Enable flex form on rows
option must be selected. To perform actions on columns, the Enable flex
form on columns option must be selected. These options are described in 
Setting Smart View Form Options in Administering Planning.

4. Optional: To retain added members on a flex form after a POV or user variable change,
select the Flex Forms: Preserve Grid on POV and User Variable Changes check box in
the Options dialog, Members tab.

For more information, see Retaining Modified Members on Flex Forms After POV or User
Variable Change.

5. Optional: If your Service Administrator has enabled the Show invalid members for flex
form option when designing the form, you may enter member names and then click
Refresh to view and correct any invalid member names.

For more information, see Retaining Invalid Members on Flex Forms.

6. Optional: To run a business rule, select a cell in the form. In the Extensions menu, select
Smart View for Google Workspace, and then select Form. Select Data,Calculate, and
then select Business Rules. Select a business rule to launch it.

7. Click Refresh.

On refresh, Smart View maintains modifications you have made to the form.

If Show invalid members for flex form is enabled for the form, the invalid members are
retained; if this option is not enabled, then the Refresh action removes invalid members.

Note

Data can be submitted only after refreshing it. However, the modified form layout
is not stored on the server; it is maintained only in the context of the current
session.

8. To submit the changed data, click Submit.

Data can be submitted only after it is refreshed first.

9. To revert to the original flex form layout, reopen the flex form.
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The modified form is not stored on the server; it is maintained only in the context of the
current session. Reopening the flex form reverts the flex form layout to its original state.

Opening a Flex Form in Ad Hoc Mode and Submitting Data
You can open a flex form in ad hoc mode, just like any regular form, use ad hoc analysis to
modify the grid layout, and submit data.

To open a flex form in ad hoc mode and submit data:

1. Connect to a data source.

2. In the Smart View panel, expand the tree list and locate the flex form to open in ad hoc
mode.

3. Right-click the selected flex form and select Ad Hoc Analysis.

4. Modify data and grid layout per your requirements.

5. Click Submit.

6. Go back to the sheet with the flex form.

7. Click Refresh.

The original layout and modified data appears in the flex form.
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9
Ad Hoc Analysis

Related Topics

• Starting Ad Hoc Analysis
You can start ad hoc analysis from a cube and from an Oracle Fusion Cloud Enterprise
Performance Management form.

• Formatting Ad Hoc Grids
You can use either Smart View (cell styles) or Google Sheets to control grid formatting.

• Zooming In and Out
Zoom in on members in the grid to display data for their children and descendants and
zoom out for a high level view.

• Pivoting
Pivoting changes the orientation of the data on the worksheet. You can move dimensions
between rows and columns and between the grid and the POV.

• Inserting Attribute Dimensions
When performing ad hoc analysis, you can insert attribute dimensions or members into a
worksheet.

• Keeping and Removing Members from Ad Hoc Grids
You can keep or remove members and their associated data from ad hoc grids.

• Cascading Reports
You can create separate reports for any or all of the members of one or more dimensions
in a report based on an ad hoc grid.

• Saving Ad Hoc Grids
You can save ad hoc grids as forms.

• Preserving Google Sheets Formulas in Ad Hoc Operations
You can associate Google Sheets formulas and comments with members and data cells in
ad hoc grids and set cell styles to identify such cells. By default, formulas are preserved
when you perform ad hoc operations with the exception of Pivot.

• Running a Query Report
You can display all member combinations across dimensions by running a query sheet as
a report.

• Working with Comments and Unknown Members
You can easily access and edit comments and unknown members in an ad hoc grid using
the Comment Edit dialog that opens from the View Comments ribbon command.

• Working with Multiple-Grid Sheets
In Smart View, you can retrieve multiple ad hoc grids on one sheet. The grids can all be
connected either to the same data source or to different data sources.

Starting Ad Hoc Analysis
You can start ad hoc analysis from a cube and from an Oracle Fusion Cloud Enterprise
Performance Management form.

To start an ad hoc analysis grid, use either of the following methods:
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• Starting Ad Hoc Analysis from a Cube

• Starting Ad Hoc Analysis from a Cloud EPM Form

Note

When you start ad hoc analysis, cell styles are not enabled by default. See Using
Smart View Formatting (Cell Styles) for information on the Use Cell Styles setting.

Starting Ad Hoc Analysis from a Cube

To start ad hoc analysis from a cube, select a cube from the Smart View Home panel.

In the following example for Cloud EPM, there are five cubes from which you can select
(Plan1, Plan2, Plan3, VisASO, and Vis1ASO).

 

 

When you select a cube, the data is placed on the grid in ad hoc mode, and you can
immediately start ad hoc analysis.

Starting Ad Hoc Analysis from a Cloud EPM Form

If you have been assigned the ad hoc user role by an administrator, you can perform ad hoc
analysis on Cloud EPM forms that have been enabled for ad hoc by the administrator.

To start ad hoc analysis for a Cloud EPM form:

1. From the Smart View Home panel, select a Cloud EPM form.

For example, in the following Smart View panel:

a. Select Library.
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b. Select Plan to display all the Cloud EPM forms saved under the Plan folder.

 

 

c. Select a Cloud EPM form; for example, you could select the Actual vs Plan Cloud
EPM form.
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When you select a Cloud EPM form, the data for that form is placed on the grid; however, it
is not initially in ad hoc mode.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Ad Hoc and then select Analyze to open a second sheet that contains the ad hoc
grid created from the form.

4. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc. The Ad Hoc menu provides various options to perform ad hoc analysis.

Tip

To open a form directly in ad hoc analysis mode, that is as an ad hoc grid, first select
it, right-click on it, and then select the Ad Hoc Analysis option in the menu.

Formatting Ad Hoc Grids
You can use either Smart View (cell styles) or Google Sheets to control grid formatting.

Related Topics

• Using Smart View Formatting (Cell Styles)

• Using Google Sheets Formatting

Using Smart View Formatting (Cell Styles)
Smart View formatting, or cell styles, consists of formatting selections made in the Formatting
tab in the Smart View Options dialog. If you do not enable cell styles for ad hoc grids, then
Google Sheets formatting is applied (see Using Google Sheets Formatting).

To set Smart View formatting options:
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1. In the Extensions menu, select Smart View for Google Workspace, and then select
Options.

2. In the Options dialog, select the Formatting tab.

3. In the Formatting tab, select the Use Cell Styles check box.

4. Click Cell Styles and set the desired cell styles and precedence order. For more
information on setting cell styles and precedence order, see Cell Styles.

Using Google Sheets Formatting
When you use Google Sheets formatting, your formatting selections, including conditional
formatting, are applied and retained on the grid when you refresh or perform ad hoc
operations.

When you use Google Sheets formatting, Smart View does not reformat cells based on your
grid operations, and it does not mark cells as dirty when you change data values. Smart View
does preserve the formatting on the worksheet between operations.

Using Google Sheets formatting is generally preferable for highly formatted reports, and you
must use Google Sheets formatting for data sources whose application-specific colors are not
supported by the Google Sheets color palate.

Google Sheets formatting is used by default, unless you select the Use Cell Styles option in
the Formatting tab in the Options dialog. See Using Smart View Formatting (Cell Styles) for
more information.

Zooming In and Out
Zoom in on members in the grid to display data for their children and descendants and zoom
out for a high level view.

Related Topics

• Zooming In
You can zoom in on members in the grid to display data for their children and descendants.

• Zooming Out
You can zoom out to collapse the view to the next upper level or top level.

• Selecting Members to Display when Zooming
You can set options to specify which members are retained and displayed as you zoom in
and out.

Zooming In
You can zoom in on members in the grid to display data for their children and descendants.

To zoom in on a member:

1. Select a member in the grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis and then select Zoom In.

4. From the Zoom In option, select the required option:

• Next Level to retrieve data for the children of the selected members
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• All Levels to retrieve data for all descendants of the selected members

• Bottom Level to retrieve data for the lowest level of members in a dimension

Zooming Out
You can zoom out to collapse the view to the next upper level or top level.

To zoom out:

1. Select a member in the grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis and then select Zoom Out.

4. From the Zoom Out options, select the required option:

• Next Level to zoom out to the next level of data

• Top Levels to zoom out to the top level of data

Selecting Members to Display when Zooming
You can set options to specify which members are retained and displayed as you zoom in and
out.

To set member display options for zooming:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Options.

2. In the Options dialog, select the Members tab.

3. Under Member Retention, select the required option:

• Include Selection to display both the selected member and the members retrieved as
a result of zooming.

For example, zooming in on the selected member Qtr1 retrieves data for Jan, Feb, Mar,
and Qtr1. If not selected, only the members retrieved as a result of the zoom are
displayed; in this example, Jan, Feb, and Mar.

• Within Selected Group to zoom in only on the selected group of cells, leaving the
unselected cells as is.

This setting is meaningful only when there are two or more dimensions down the grid
as rows or across the grid as columns. This setting also applies to Keep Only and
Remove Only.

Pivoting
Pivoting changes the orientation of the data on the worksheet. You can move dimensions
between rows and columns and between the grid and the POV.

Related Topics

• Pivoting Dimensions between Rows and Columns
You can pivot a dimension or members between rows and columns.
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• Pivoting Dimensions or Members between the Grid and the POV
You can select to pivot a dimension out of the ad hoc grid to the Point of View (POV), or
out of the POV to the grid. You can also pivot a member. When you pivot a member, the
other members in its dimension are also pivoted.

• Rearranging Dimensions on the Grid
You can rearrange dimensions on the grid by moving dimensions up or down, and to the
right or the left.

Pivoting Dimensions between Rows and Columns
You can pivot a dimension or members between rows and columns.

There must be two or more dimensions, or members from two or more dimensions in the row
or column that contains the dimension that you want to pivot. That is, you cannot pivot the last
row dimension or the last column dimension on a grid.

When you pivot a member, the other members in its dimension are also pivoted.

When you pivot between rows and columns, Smart View moves the selected dimension to the
outermost row or column on the opposite axis. For example, when you select to pivot a
dimension to a row, the system moves the dimension to the top of the grid.

To pivot a dimension or member from a row to a column or from a column to a row:

1. Select a dimension or member in the grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis, Pivot, and then select Pivot.

4. Observe the change in the grid.

• Row dimensions are pivoted to the top most column dimension.

• Column dimensions are pivoted to the left most row dimension.

Note

When you use Google Sheets formatting, member and numeric formats may
unexpectedly change after pivot operations. For example, member names may be
centered and numeric values may be left-justified. You can reset the grid to the proper
format using the Google Sheets formatting options. See Formatting Ad Hoc Grids.

Pivoting Dimensions or Members between the Grid and the POV
You can select to pivot a dimension out of the ad hoc grid to the Point of View (POV), or out of
the POV to the grid. You can also pivot a member. When you pivot a member, the other
members in its dimension are also pivoted.

Pivoting a Dimension from the Grid to the POV

To pivot a dimension from the grid to the POV:

1. Select the dimension in the grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.
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3. Select Analysis, Pivot, and then select Pivot to POV.

4. Open the POV panel.

a. In the Extensions menu, select Smart View for Google Workspace, and then select
Ad Hoc.

b. Select Data, and then select POV.

The dimension is displayed in the POV panel.

Pivoting a Dimension from the POV to the Grid

To pivot a dimension from the POV to the grid:

1. Open the POV panel.

a. In the Extensions menu, select Smart View for Google Workspace, and then select
Ad Hoc.

b. Select Data, and then select POV.

2. To pivot a dimension from the POV to a column in the grid:

In the POV panel, click the ellipsis button

to the right of the dimension, and then select Pivot to Column.

3. To pivot a dimension from the POV to a row in the grid:

In the POV panel, click the ellipsis button

to the right of the dimension, and then select Pivot to Row.

Pivoting a Member from the POV to the Grid

To pivot a member from the POV to the grid:

1. Open the POV panel.

a. In the Extensions menu, select Smart View for Google Workspace, and then select
Ad Hoc.

b. Select Data, and then select POV.

2. Ensure that you have added members to the drop-down list by completing the procedure in 
Selecting Members from a Point of View Dimension.

3. Click the drop-down arrow for the dimension to view the list of available members, and
select a member from the list.

For long member lists, you can filter members by typing part of the member name in the
dimension text box. For example, using the Vision Product dimension, begin typing
Computer. The drop-down list filters on members with Computer in the name:

Chapter 9
Pivoting

Working with Oracle Smart View for Google Workspace
F56457-09
Copyright © 2025, Oracle and/or its affiliates.

August 1, 2025
Page 8 of 31



4. To pivot the selected member from the POV to a column in the grid:

In the POV panel, click the ellipsis button

to the right of the dimension, and then select Pivot to Column.

5. To pivot the selected member from the POV to a row in the grid:

In the POV panel, click the ellipsis button

to the right of the dimension, and then select Pivot to Row.

Guidelines on Pivoting Dimensions and Members

Consider the following guidelines while pivoting:

• You can leave any number of dimensions in the POV.

• After pivoting the last dimension from the POV to the grid, the POV panel is hidden. You
can always reopen the POV panel to display it again.

• The grid must always contain at least two dimensions: one row dimension, and one column
dimension. When there is only one row dimension and one column dimension on a grid,
you must first pivot the replacement dimension on to the grid before you can pivot a
dimension out of the grid.

For example, if you want to pivot the row dimension off of the grid, then you must first pivot
the replacement row dimension on to the grid, and then pivot the unwanted row dimension
off of the grid.

• When you pivot a member from the grid to the POV, the member selected on the grid
becomes the POV for that dimension. For example, if you pivot Qtr2 of the Year dimension
from the grid to the POV, then Qtr2 becomes the POV for the Year dimension.

• You can manually type a dimension or member name to replace a dimension or member
name in the grid or the POV.

Similarly, you can delete a dimension or member from the grid, refresh the grid, and the
deleted dimension or member is moved from the grid and will display on the POV.

• You can pivot members by selecting them from the POV, as described in Selecting
Members from a Point of View Dimension.

• While switching between multiple sheets, you can use Sync or Refresh to sync the POV
dimensions specific to the currently active sheet. For more information, see Syncing the
POV Panel with the Active Sheet.
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Rearranging Dimensions on the Grid
You can rearrange dimensions on the grid by moving dimensions up or down, and to the right
or the left.

To rearrange the dimensions on an ad hoc grid:

1. Select a dimension or member on the grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis, and then select Pivot.

4. Select one of the following options:

• Move Up

• Move Down

• Move Left

• Move Right

Inserting Attribute Dimensions
When performing ad hoc analysis, you can insert attribute dimensions or members into a
worksheet.

To insert attribute dimensions or members:

1. Open an ad hoc grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis, and then select Insert Attribute.

4. In the Insert Attribute dialog box, select the attribute dimensions to add to the sheet.

5. Optional: To further define an attribute member, click  next to the attribute to open
the Member Selector and select the required member.

For example, click  next to Market Size.

Select Large Market, Medium Market, or Small Market.
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6. Select Insert to add the selected attribute dimensions to the grid.

7. To view the selected attribute dimension in the POV panel, click Reload POV.

Guidelines for Inserting Attribute Dimensions
When inserting attributes, consider the following guidelines:

• If an attribute is already present on the grid, then it will not be available for selection in the
Insert Attributes dialog box.

• The grid must be in a refreshed state. If the grid is in free-form state prior to refresh, then
you are prompted to refresh manually.

• When the attributes are inserted on the grid, the grid is automatically refreshed.

• In the Insert Attributes dialog box:

– You can select to insert the entire attribute dimension, or one attribute member from a
dimension.

– If a member name is left blank in the attribute text box, then that dimension is in a
deselected state and will not be inserted.

• If you have inserted a single attribute member using the Insert Attributes command and
dialog box, you can use Member Selection to add other members from the same attribute
dimension to the grid.

• When filtering on attributes at the Generation 3 level in an attribute dimension, Smart View
only displays members up to the Generation 2 level.

• An attribute dimension must be present in the grid before it can be deleted. For more
information, see Pivoting Dimensions or Members between the Grid and the POV.

Keeping and Removing Members from Ad Hoc Grids
You can keep or remove members and their associated data from ad hoc grids.

Selecting Members to Keep

To select members on the grid to keep:

1. On an ad hoc grid, select the members cells you want to keep.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis and then select Keep Only.
All other members in the grid are removed.
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Selecting Members to Remove

To select members on the grid to remove:

1. On an ad hoc grid, select the members cells you want to remove.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis and then select Remove Only.
All selected members in the grid are removed.

Examples on Keep and Remove

The results of Keep Only and Remove Only depend on how the selected group is evaluated
within the grid. A group consists of two or more dimensions down the grid as rows or across
the grid as columns.

To use the Keep Only or Remove Only command, the selected member must have a group of
members associated with it. Members do not have to be from the same dimension to be
considered a group. The selected member shouldn’t be the lowest or last member of the
group.

For example, you could think of New York, Florida, Connecticut, and New Hampshire as
individual groups that all contain the January member. We want to keep the data for January
for those four states. Yet, when we select Jan, and then click Keep Only, the grid doesn’t
change. This is because Jan is not its own group; it’s actually a member of a group originating
with the Market dimension, and also belongs to the New York, Florida, Connecticut, and New
Hampshire groups.

Figure 9-1    Grid with Market Members in Column A, Year Members in Column B

Move Jan to reposition it so that Jan is now a group, and the members New York, Florida,
Connecticut, and New Hampshire belong to the Jan group.
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Figure 9-2    Grid with Year Members in Column A, Market Members in Column B

Now select a Jan cell and click Keep Only. The resulting layout shows only the Market
dimension members grouped under Jan.
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Figure 9-3    Grid with Only Jan Group Members

You can further refine the report to show only the New York, Florida, Connecticut, and New
Hampshire members. Select those members in the grid.

Figure 9-4    Members Selected for Keep Only

And then click Keep Only.

Figure 9-5    Grid with Only Jan Group Members New York, Florida, Connecticut, and
New Hampshire
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You can achieve the result in another way. Select the West, South and Central members, and
the Market dimension.

Figure 9-6    Members Selected for Remove Only

And then click Remove Only.

Figure 9-7    Grid with Only Jan Group Members New York, Florida, Connecticut, and
New Hampshire

Remember that the Keep Only and Remove Only commands are always performed on the
selected groups, evaluated within the grid.

Cascading Reports
You can create separate reports for any or all of the members of one or more dimensions in a
report based on an ad hoc grid.

You can then cascade these reports separately across individual sheets. Each sheet tab is
named according to the dimensions and members of the report it contains.

Note

The names on the sheets created as a result of cascading have a 30 character limit.
Any characters over 30 are truncated.
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To cascade a report from an ad hoc grid:

1. Open an ad hoc grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis and then select Cascade.

4. Under Cascade, select the required option:

• Cascade - Same Spreadsheet to cascade all reports in the current spreadsheet

• Cascade - New Spreadsheet to cascade all reports in a new spreadsheet

• Cascade - Different Spreadsheets to cascade all reports in different spreadsheets

The Cascade panel opens.

5. In the Cascade panel, click

next to each dimension to launch the Member Selector dialog.

6. Select the members for the dimension for which you want to create reports, and then click
Done.

One report will be generated for each member you select. Based on your selection, the
number of cascaded sheets is displayed at the bottom of the Cascade panel.

7. Click Done to begin cascading.

You will see temporary sheets getting created until all the reports are cascaded. The
resulting reports are created on separate sheets in either the current spreadsheet, a new
spreadsheet, or different spreadsheets based on your selection. Each sheet tab is named
according to the dimensions and members of the report it contains. Click a sheet tab to
view a report.

Note

After the temporary sheets are created, if you do not see the final cascaded
reports, check the pop-up blocker settings on your browser and make sure you
allow pop-up windows to be launched for cascading reports.

Saving Ad Hoc Grids
You can save ad hoc grids as forms.

To save an ad hoc grid as a form:

1. Open the ad hoc grid.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis, and then select Save Ad Hoc Grid

4. In Save Grid As, enter a name and description for the form, and then browse to the
location where you want to save the grid.

5. Click OK.

The saved grid is displayed in the Smart View Home panel tree list in the selected location.
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Preserving Google Sheets Formulas in Ad Hoc Operations
You can associate Google Sheets formulas and comments with members and data cells in ad
hoc grids and set cell styles to identify such cells. By default, formulas are preserved when you
perform ad hoc operations with the exception of Pivot.

To specify whether to preserve formulas and comments in ad hoc operations:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Options.

2. Select the Member tab, then scroll down to Comments and Formula, and then do one of
the following:

• To preserve formulas and comments in ad hoc grids, select the Preserve Formulas
and Comments in Ad Hoc check box.

• To disable preservation of formulas and comments, clear the Preserve Formulas and
Comments in Ad Hoc check box. Do this only if you do not need to preserve formulas
and comments, and you want faster execution of queries.

• To preserve comments and unknown members in ad hoc grids, select the Preserve
Formulas and Comments in Ad Hoc and Preserve Comments and Unknown
Members check boxes. The Preserve Formulas and Comments in Ad Hoc check
box must be selected first to enable the Preserve Comments and Unknown
Members check box

• To disable preservation of comments and unknown members, clear Preserve
Comments and Unknown Members. Do this only if you do not need to preserve
comments and unknown members, and you want faster execution of queries.

The selection you make applies to formulas in both member and data cells.

Running a Query Report
You can display all member combinations across dimensions by running a query sheet as a
report.

You can fetch these combinations for all the members on the sheet using the Run as Report
or for specific row or column members using the Cross Join on Rows or Cross Join on
Columns option.

Run As Report

You can run an ad hoc query sheet as a report to fetch the cross joins between all members in
row and column dimensions and to display all member combinations across the dimensions in
a separate sheet. The Run as Report option enables you to perform a cross join to display all
member combinations across the dimensions.

Any regular ad hoc sheet can be treated as a query sheet. You can either type the dimensions
and members directly in the sheet or select them using the Member Selector. For example,
let's create the following freeform grid in which:

• Scenario and Time in the columns, where you want to see Actual data for the month of
January and Plan data for the month of February.

• Account and Entity in the rows, where you want to see specific data for specific Account
and specific Sales Entity.
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You can optionally click Refresh to see the data values in the grid before running the report.

 

 
In the grid, every member combination for rows and columns is different. For example, cell C4
displays the value for Hardware revenue from Sales East for Jan for the Actual scenario,
where as cell D5 displays the value for Support revenue from Sales South for Feb for the Plan
scenario.

To run this ad hoc query sheet as a report, use the Run as Report option. In the Extensions
menu, select Smart View for Google Workspace, and then select Ad Hoc. Click Query and
then click Run as Report.

A combination of all row and column members available on the sheet is displayed in a
separate report sheet. The report sheet is named as <Sheet name> - Report. In this example,
the query sheet is named as Revenue, so the report sheet gets created with the name
Revenue - Report.
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The report sheet displays a grid consisting of combinations of all existing row and column
members on the sheet, along with their data values. In the above example, the report sheet
displays Actual and Plan columns for both Jan and Feb months, and Hardware and Support
values in rows for both Sales East and Sales South entities.

Cross Join on Rows

If you want to perform cross join for only specific members in rows, use the Cross Join on
Rows option.

To display combinations for specific members, select the required row members.

 

 
In the Extensions menu, select Smart View for Google Workspace, and then select Ad Hoc.
Click Query and then click Cross Join on Rows.
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Note that the cross joins or combinations for the selected members are displayed in the same
ad hoc sheet in new rows at the end of the original grid. For example, new rows 5 and 6
appear in the Revenue sheet tab itself.

Click Refresh to display the data values for the different row combinations.

 

 

Cross Join on Columns

If you want to perform cross join for only specific members in columns to display their
combinations, use the Cross Join on Columns option.

To display combinations for specific members, select the required column members.
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In the Extensions menu, select Smart View for Google Workspace, and then select Ad Hoc.
Click Query and then click Cross Join on Columns.

 

 
Note that the cross joins or combinations for the selected members are displayed in the same
ad hoc sheet in new columns after the existing columns. For example, new columns D and E
appear in the Revenue sheet tab itself.

Click Refresh to display the data values for the different column combinations.
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Working with Comments and Unknown Members
You can easily access and edit comments and unknown members in an ad hoc grid using the
Comment Edit dialog that opens from the View Comments ribbon command.

Related Topics

• About Comments and Unknown Members
Set options to highlight comments and unknown members on an ad hoc sheet, then use
the Comment Edit dialog to modify or delete comments and unknown members as you
require.

• Enabling Comment Display in the Sheet
You can set options in Smart View to detect comments and unknown members on an ad
hoc sheet.

• Displaying the Comment Edit Dialog on Refresh
You can configure an option to display the Comment Edit dialog each time you refresh the
sheet.

• Viewing Comments in the Sheet
You can view comments in an ad hoc sheet.

• Editing and Deleting Comments and Unknown Members
You can edit comments and unknown members using the Comment Edit dialog.

About Comments and Unknown Members
Set options to highlight comments and unknown members on an ad hoc sheet, then use the
Comment Edit dialog to modify or delete comments and unknown members as you require.

When you are connected to a provider, you can enable options in Smart View that allow you to
quickly detect:

• Unknown members on a grid

• Text typed outside the grid; for example, your own notes on a sheet

In Smart View, cells containing these types of text are referred to as comments.

You can set options in Smart View that allow you quickly and easily spot comment cells,
including invalid, or unknown, members in the grid or pertinent notes you may have made on a
sheet outside of the grid.
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For example, in the Vision database, a member named "Total Entities" is renamed "Total
Entity." Smart View tracks this change and shows it to you in the sheet if you define a cell style
to call out comments. Then, you can quickly note the change and correct it either directly in the
grid or by clicking View Comments in the Smart View ribbon and modifying the cell in the
Comment Edit dialog.

To call out comments on an ad hoc sheet, open an ad hoc grid and in the Options dialog,
Formatting tab:

• Select the Use Cell Styles check box

• Set a cell style for Comments

You can then easily identify comment cells on the ad hoc sheet, and further select and work
with them in the Comment Edit dialog box.

You can also select the Always show on refresh check box in the Comment Edit dialog box
to launch it on each refresh.

Enabling Comment Display in the Sheet
You can set options in Smart View to detect comments and unknown members on an ad hoc
sheet.

To enable comment display in an ad hoc sheet:

1. In the Options dialog, perform these tasks:

a. In Members tab, select the Preserve Formulas and Comments in Ad Hoc and
Preserve Comments and Unknown Members check boxes.

b. In the Formatting tab, select the Use Cell Styles check box.

c. Click the Cell Styles button, expand Miscellaneous Styles, and then click on
Comment. Drag the color controls (the circles in the top left corner of each color block)
till you arrive at the color you want.
 

 

2. Click X in the top right corner to close the Options panel.

You are now ready for the steps in Viewing Comments in the Sheet.

Optionally, to view the Comment Edit dialog with every refresh, complete the steps in 
Displaying the Comment Edit Dialog on Refresh.
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Displaying the Comment Edit Dialog on Refresh
You can configure an option to display the Comment Edit dialog each time you refresh the
sheet.

Note

This procedure is optional.

To enable comment display in the sheet upon refresh:

1. Place an ad hoc grid on the sheet.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Data, More, and then select View Comments.

4. In the Comment Edit dialog, select the Always show on refresh check box.

Figure 9-8    Comment Edit Dialog

5. Click Apply Changes.

The Comment Edit dialog will display each time you refresh the grid.

The Always show on refresh check box applies not just for the current worksheet but for
any new worksheets you open subsequently. You do not have to set it on a per-sheet
basis.

6. Optional: To disable the Comment Edit dialog display on refresh, clear the Always show
on refresh check box.
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Viewing Comments in the Sheet
You can view comments in an ad hoc sheet.

To view comment cells in an ad hoc sheet:

1. Be sure to complete the steps in Enabling Comment Display in the Sheet

2. Start an ad hoc grid or open a spreadsheet containing a grid and click Refresh.

3. On the sheet, note the cells containing comments and unknown members.

In the example shown below, cell B5 is an unknown member and Smart View marked the
cell as a comment. The member name was probably changed in the underlying cube. The
comment style indicates to us that this member needs attention.

Figure 9-9    Grid Showing Cells Marked with Comment Style

Additionally, a comment outside of the grid (G2), provides general instructions about the
grid. Similarly, comments can be provided by users to highlight incorrect details, ask for
additional information, or provide clarification.

4. Continue with Editing and Deleting Comments and Unknown Members.

Editing and Deleting Comments and Unknown Members
You can edit comments and unknown members using the Comment Edit dialog.

Before you begin, complete the steps in Enabling Comment Display in the Sheet.

Note

The procedure in this topic shows you how to edit comments on an ad hoc sheet using
the View Comments command and the Comment Edit dialog box in Smart View. You
can also edit comments directly in the grid, without using the Smart View interface
elements in this topic.

To edit and delete comments on an ad hoc grid:

1. Open an ad hoc grid containing comments, and click Refresh.

In the example shown below, the grid displays some comments in the sheet.
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Figure 9-10    Grid Showing Cells Marked with Comment Style

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Data, More, and then select View Comments.

The Comment Edit dialog box is launched.

Based on the grid in the above example, the Comment Edit dialog shows the comments
present in the sheet which can be edited.

Figure 9-11    Comment Edit Dialog

4. To edit the text in a comment cell, in the Comment Edit dialog, click in the comment cell
text box to edit; and then modify the text as required.

Using the example Comment Edit dialog, click in the "Total Entities" comment cell text
box, and then change "Total Entities" to "Total Entity".

5. Click Apply Changes and note the change in the grid.

Cells that were edited are now marked in the dirty cell style.

6. Click Refresh; the dirty cell style is cleared in the cells you edited and the appropriate cell
style is applied.

7. To delete comments:

a. Launch the Comment Edit dialog, click in the comment cell text box to highlight the
editable text; and press the Delete key.
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b. Click Apply Changes in the Comment Edit dialog to return to the ad hoc grid sheet.

c. Click Refresh.

Working with Multiple-Grid Sheets
In Smart View, you can retrieve multiple ad hoc grids on one sheet. The grids can all be
connected either to the same data source or to different data sources.

Related Topics

• About Multiple Ad Hoc Grids on a Sheet
When connected to supported Smart View data sources, you can create multiple grids on
one sheet.

• Creating Multiple-Grid Sheets
You can create a multiple-grid sheet by placing ad hoc grids from the same data source or
different data sources.

• Renaming Grid Ranges
You can rename grid ranges in multiple-grid sheets to identify them using a friendly and
meaningful name.

About Multiple Ad Hoc Grids on a Sheet
When connected to supported Smart View data sources, you can create multiple grids on one
sheet.

These grids can be connected to the same data source or to different data sources. For
example, one grid can be connected to Planning and another can be connected to Tax
Reporting. They can also be sourced from cubes. You can retrieve data in these grids and shift
them on the sheet.

Note

Administrators: To enable multiple-grid ad hoc for Smart View users, set the Smart
View Ad Hoc Behavior option to Standard in the service application settings. See the
administration documentation for your service for more information.

Guidelines for Working with Multiple-Grid Sheets

Note the following guidelines while working with sheets that contain multiple ad hoc grids:

• While inserting multiple ad hoc grids, always insert them on a new sheet which does not
have any previous grid in it. If you have already opened a form or an ad hoc grid on a
sheet and then select a cell range for adding another grid on the same sheet, a message
prompts you stating, "Multiple grids cannot be added to a single-grid sheets. Add a new
sheet to add multiple grids".

• When working with multiple ad hoc grids, select at least one cell within a grid before
performing any grid-specific operation. This helps Smart View identify the grid on which
you want to take the action. If your selection is on a cell outside the grid, a message
prompts you stating, "Select at least one cell in the grid on which you want to perform this
operation".

• You can submit data for only one grid at a time in a multiple-grid sheet.
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If you try to submit data for more than one grid at a time—that is, if you have selected cell
ranges in more than one grid—the first range returned by Google Sheets is used to
determine the selected grid and the data on only that grid is submitted.

• You can refresh grid data in a sheet for all connections at the same time.

For example, you are working on a sheet with Grid 1 and Grid 2 connected to Planning and
Grid 3 connected to Tax Reporting. When you click Refresh from the Smart View for
Google Workspace menu, all grids—Grid 1, Grid 2, and Grid 3—are refreshed at the
same time in a single operation.

– To refresh all grids together, select any cell outside the ranges of the grids and click
Refresh.

– To refresh only a particular grid, select any cell within the range of the grid and click
Refresh. This is saves the time taken to refresh data, especially when the sheet
contains a lot of grids.

For more information, see Refreshing Data.

• The settings in the Options dialog box apply only to the selected grid on the sheet. This
means that you can set different Option settings for each grid in a multiple-grid sheet.

For example, you want to apply Blue as the background color for Member cells for Grid 1
and Green for Grid 2. First, click anywhere in Grid 1, open the Options dialog box, and
then set the Blue cell style under Formatting, Cell Styles. Click Done and then OK to
apply the change and close the dialog box. Now, repeat the same for Grid 2, by clicking
anywhere in Grid 2 and opening the dialog. After setting the styles, click Refresh. The
Member cells appear in Blue and Green background colors respectively for Grid 1 and Grid
2.

• When you zoom in on a grid and it expands to display data on more rows and columns, the
placement of the other grids is automatically adjusted such that the expanded grid does
not overlap the contents of the other grids on the sheet.

For example, if you have two grids one below the other separated by two blank rows of
space and you zoom in on the top grid, the bottom grid is pushed down in the sheet, and
you can scroll down till the top grid ends to view the other grid.

• While viewing sheet information for a multiple-grid sheet, the Sheet Info dialog box
displays a separate Connection section for each grid. For example, Connection (Grid 1),
Connection (Grid 2), and so on. Each section displays details such as Server, Application,
URL, Provider, Alias Table, and Associated Ranges. For more information, see Sheet
Information.

• Functions can be inserted in a multiple-grid sheet by typing them manually or using the
Function Builder..

However, in case the multiple-grid sheet contains grids from multiple connections, the
HsGetSheetInfo function retrieves the sheet properties only for the first connection,
irrespective of the connection that is currently active on the sheet. This is a limitation.

• Creating a connection for functions is not supported on a multiple-grid sheet.

• On a Functions-only sheet, multiple grids cannot be inserted.

• If a particular operation from the Smart View for Google Workspace menu is not
supported in a multiple-grid sheet, a message appears to indicate that you cannot perform
the operation on the current sheet.

• When a Smart Form is opened as an ad hoc grid in a multiple-grid sheet, the formula cells
appear blank since the layout changes and formula references are not retained.
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Creating Multiple-Grid Sheets
You can create a multiple-grid sheet by placing ad hoc grids from the same data source or
different data sources.

For placing multiple grids from multiple data source connections, you can connect to the
required data sources before you start creating multiple grid sheet or even during the process.

To create a multiple-grid sheet:

1. Open a new sheet.

Ensure that the sheet is blank and does not contain any existing data.

2. Select a range of cells from any location in the sheet.

You must select a range of cells, instead of only one cell.

3. From the Smart View Home panel, perform an action:

• Select a cube.

• Select a form, right-click on it, and then select Ad Hoc Analysis.

4. Select Yes in the prompt asking to change the sheet to support multiple grids.

The ad hoc grid is added in the position of the selected range.

5. To add another grid from the same data source on the sheet:
a. Select a different range of cells.

b. From the Smart View Home panel, select a cube, or select a form, right-click on it, and
then select Ad Hoc Analysis.

The ad hoc grid is added in the position of the selected range.

6. To add a grid from another data source on the same sheet:
a. Connect to the other data source, if not already connected. In the Extensions menu,

select Smart View for Google Workspace, and then select Connect under Start.

For more information, see Connecting to Data Sources.

b. Select a range of blank cells.

c. In the Extensions menu, select Smart View for Google Workspace, and then select
Active Connections under Start.

d. In the Active Connections dialog, click the Server URL list to view the list of active
connections, select the required connection, and click Launch Home.

The Smart View Home panel opens to display the library contents of the connected
data source.

e. From the Smart View Home panel, select a cube, or select a form, right-click on it, and
then select Ad Hoc Analysis.

The ad hoc grid is added in the position of the selected range.

Renaming Grid Ranges
You can rename grid ranges in multiple-grid sheets to identify them using a friendly and
meaningful name.

When you place ranges on a multiple-grid sheet, Google Sheets assigns each range a name
by default. The strings used in the name ranges may not be particularly user friendly. For
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example, a range based on the Vision Plan1 cube might look like this: Vision_Plan1_88CA3264. A
more user-friendly name, for example Business Drivers, helps users identify and understand the ad
hoc grids in the multiple-grid sheet.

Using Smart View's Rename Grid Range option, you can rename the grid ranges while
retaining their metadata and connection.

Related Topics:

• Renaming Grids on a Multiple-Grid Sheet

• Guidelines for Renaming Grids on a Multiple-Grid Sheet

Renaming Grids on a Multiple-Grid Sheet

To rename grids in a multiple-grid sheet:

1. In the multiple-grid sheet, select any cell in the grid that you want to rename.

2. In the Extensions menu, select Smart View for Google Workspace, and then select Ad
Hoc.

3. Select Analysis and then select Rename Grid Range.

4. Review the grid's current name and enter a new name.

5. Click OK.

6. To view the new name, you can check the following:

• Sheet Information: In the Sheet Information dialog, the new name appears in the
Associated Range field.

• Name Box At the top of the sheet, click the down arrow in the Name Box next to the
Formula Bar. The new grid name appears in the list along with the cell ranges of the
grid.

Guidelines for Renaming Grids on a Multiple-Grid Sheet

While renaming the grids, consider the following guidelines:

• Only alphanumeric characters are allowed in grid names. Special characters are not
allowed.

• The name cannot start with a number.

• The name must be limited to 255 characters.

• The name must be unique for each grid. Multiple grids cannot have the same name. For
example, grids having names as Sales and SALES are not considered unique, and so not
allowed.

• Only one grid can be renamed at a time. Select at least on cell in the specific grid to
rename it.
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Note

It is not recommended to use Google's Named Ranges to rename a grid range. It
could cause a loss of metadata. When you rename a grid range outside Smart View:

• The grid's connection is broken, preventing Smart View from identifying it.

• You cannot perform any grid operations on such a grid.

• You cannot view the grid's details in the Sheet Information dialog as it is
considered invalid.
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10
General Operations

Related Topics

• Sheet Information
You can view connection and other details for the current worksheet.

• Monitoring Job Status
Use the Job Console to view the execution status of ongoing and completed Oracle Fusion
Cloud Enterprise Performance Management jobs and delete them if needed.

• Sharing Spreadsheets
You can share spreadsheets using the Share feature available in Google Sheets.

• Setting User Preferences
Set preferences for application settings, display settings, and user variables.

• Adding Favorites
An easy way to access Oracle Smart View for Google Workspace operations is by marking
them as favorite.

Sheet Information
You can view connection and other details for the current worksheet.

Related Topics

• Guidelines on Sheet Information
Consider the guidelines in this topic when using sheet information.

• Viewing Sheet Information
You can view useful information about the sheet such as connection details, connection
status, sheet type, and last connected date and time. You can also save this information to
an html file or delete the sheet's metadata, if not required.

• Support for Sheet Information in Cloud EPM

Guidelines on Sheet Information
Consider the guidelines in this topic when using sheet information.

• You can see separate Connection sections in the Sheet Info dialog box for each valid grid
present on the sheet. For example, Connection (Grid 1), Connection (Grid 2), and so on.

• In a multiple-grid sheet, if you rename a grid range or delete its original name using
Google's Named Ranges, instead of Smart View's Rename Grid Range option, then
Smart View considers such a grid as invalid. This is because the grid's connection is
broken, thus preventing Smart View from identifying it. You cannot view details of such a
grid in the Sheet Info dialog box and cannot perform any grid operations on such a grid.
It is recommended to always use Smart View's Rename Grid Range option for giving
friendly or understandable names to your grids. For more information, see Renaming Grid
Ranges.

• For a Function sheet, the Sheet Info dialog box only displays the Sheet Type as Function.
No other description is available for display for a Function sheet.
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Viewing Sheet Information
You can view useful information about the sheet such as connection details, connection status,
sheet type, and last connected date and time. You can also save this information to an html file
or delete the sheet's metadata, if not required.

To view sheet information:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Sheet Info.

2. Depending on the data on the sheet, view the following information displayed in the Sheet
Info dialog box:

• Connection

– Server: Name of the server to which the sheet is connected

– Application: Application to which the sheet is connected

– Cube: Cube, model, or database to which the sheet is connected

– URL: URL string of the data source provider to which the sheet is connected

– Provider: Data source type to which the sheet is connected.

– Alias Table: Current alias table

– Form Name: Name of the form to which the sheet is connected. This property
applies when connected to forms in Oracle Fusion Cloud Enterprise Performance
Management applications.

– Associated Range: Name of the cell range associated with the grid. If you have
renamed the grid range using Smart View's Rename Grid Range option, then you
can view the new name here.

Note

For multiple-grid sheets, you can see separate Connection sections for each
valid grid present on the sheet. For example, Connection (Grid 1), Connection
(Grid 2), and so on.

• General

– Sheet Type: Form, Ad hoc, Multiple grid ad hoc, or Function

Note

For a Function sheet, the Sheet Info dialog box only displays the Sheet
Type as Function. No other details are available for display for a Function
sheet.

– Last Retrieved: Date and time when the sheet was last refreshed

3. Select the following options as needed:

• Delete: Provides these options for deleting Smart View metadata:

– Delete worksheet metadata deletes all Smart View metadata in the active sheet.
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– Delete spreadsheet metadata deletes all Smart View metadata in the active
spreadsheet.

Note

The Delete operation cannot be undone.

• Save: Saves the sheet information content to an HTML file.

4. Click Close to close the Sheet Info dialog box.

Support for Sheet Information in Cloud EPM
Without connecting to a data source, if you open a new blank sheet or a saved sheet and
launch the Sheet Info dialog, it displays the Sheet Type information as Empty. No other details
are available for display without establishing a connection for the sheet.

Once connected to a data source, the Sheet Information is supported as follows for various
artifacts as per different connection scenarios.

Note

For a Function sheet, the Sheet Info dialog only displays the Sheet Type as Function.
No other details are available for display for a Function sheet.

Table 10-1    Sheet Information Supported by in Cloud EPM

Connection Status Form Ad Hoc Functions

Set Active Connection for
this Worksheet

Yes Yes No

Set as Default Connection,
before associating with
active connection

N/A N/A N/A

Set as Default Connection,
after associating with
active connection

Yes Yes No

Last Retrieved Yes Yes No

Monitoring Job Status
Use the Job Console to view the execution status of ongoing and completed Oracle Fusion
Cloud Enterprise Performance Management jobs and delete them if needed.

To check the execution status of jobs:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

2. Select Data, More, and then select Job Console.
Alternatively, you can click the Actions menu in the Smart View Home panel and select
Job Console.

3. View the list of jobs.
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By default, all jobs are displayed. You can filter the list of jobs using any of the following job
criteria:

• Job Type

• Status

• Job Name

• User Name

• Start Date

• End Date

If you enter criteria to filter the jobs, click Go to display the jobs matching your selections.

4. Optional: To view the application name and the plan type of a job, select the job and click
Show Details.
To see details for all jobs in the list, click Select All, and then click Show Details..

5. Optional: To delete a job, select the job and click Delete.
To delete all jobs in the list, click Select All, and then click Delete.

Note

Deleting a job only deletes it from the list in the Job Console. It does not cancel a
job.

6. When you are finished viewing jobs, click OK to close the Job Console.

Sharing Spreadsheets
You can share spreadsheets using the Share feature available in Google Sheets.

Google Sheets provides a Share feature using which you can share your spreadsheets with
your team. The Share button is located at the top right corner, next to your user profile icon.
When you share a spreadsheet, all its contents and sheets are shared. You can set editing
access and share the spreadsheet either through email or by copying and sending its link to
the recipients. For more information on how to share a spreadsheet, see Google's
documentation on Share files from Google Drive.

When recipients access the shared spreadsheet, they can view the sheet contents but need
the Smart View add-on extension installed to work on it. If the recipients do not have the Smart
View add-on extension installed in their Google Sheets, they can install it from Google
Workspace Marketplace. In the Extensions menu, select Smart View for Google
Workspace, and then select Install. For more information on installing the Smart View add-on
extension, see Getting Started with Oracle Smart View for Google Workspace.

In the shared spreadsheet, the recipients can initially view the full contents, irrespective of their
access to dimensions and members. However, when they try to perform an operation such as
refresh or submit, they are prompted to log in and start a new session. After logging in, the
recipients can refresh the spreadsheet to view data as per their access privileges and preform
further operations. Multiple users can continue working on the same spreadsheet
simultaneously.
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Setting User Preferences
Set preferences for application settings, display settings, and user variables.

To set user preferences for an Oracle Fusion Cloud Enterprise Performance Management
application:

1. From the tree list in the Smart View Home panel, select a cube or open a form or ad hoc
grid.

2. From the Smart View Home panel, click the Actions menu and then click User
Preferences.

User Preferences appears as a panel with three tabs: Settings, Display, and Variables.

3. From the User Preferences panel, click a tab and perform an action:

• Settings tab—Manage email options, specify alias settings, set workflow options for
approvals, and specify out of office settings for planning units.

– Select a check box on the right to use the default application setting for an option.

– Select a check box on the left to override the default application settings.

– For Alias Table, select an alias table from the drop-down list on the left to override
the default application settings, and then select the check box on the left.

Note

Changes to the alias table require you to restart Smart View and
reconnect to take effect.

• Display—Set number formatting for thousand separator, decimal separator, negative
sign, and negative color; Set page options to remember selected page members, allow
a search if the number of pages exceeds a number you specify, and set member
indentation; Set other options to display consolidation operators, specify number of
members on each page and record, and set date format.

– Select a check box on the right to use the default application settings.

– For each available property on the left, select an option from the drop-down list or
type directly into the text box to override the default application settings.

• Variables—Variables set up by the administrator to help you navigate large forms and
grids.

The left column displays the user variable name. The associated dimension is
displayed below user variable name. Click the ellipses icon to launch the Member
Selection dialog. Then select a member to use as the default for the user variable.

Note

User preferences for locale, date format, and decimal/numeric format set on forms
from within the web application are not honored on forms in Smart View.

4. After making changes in a tab, click Save,

at the top of the User Preferences panel before selecting another tab.
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5. When you're finished setting user preferences, click

in the panel to close.

 

 

Adding Favorites
An easy way to access Oracle Smart View for Google Workspace operations is by marking
them as favorite.

You can select the operations that you use frequently and they appears pinned at the top of the
Favorites panel. When you want to use an operation, simply open the Favorites panel and
click the operation link, instead of navigating the Extensions, Smart View for Google
Workspace menu to reach the operation.

To launch the Favorites panel and add your favorite operations:

1. In the Smart View Home panel, click the Actions menu, and then click Favorites.
You can also click

in the Smart View Home panel to open the Favorites panel.

A list of operations appear categorized under different groups, similar to the grouping seen
in the main menu, in the Favorites panel.

2. Expand a group and click

for the required operation.
The Favorites icon appears highlighted

and the selected operation gets added in the Favorites group on top of the list.
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3. The next time you want to use the operation, simply launch the Favorites panel and click
the operation from the favorites list.

4. To remove an operation from the Favorites list, click the Favorites icon

to clear the selection.
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11
Task Lists

Related Topics

• About Task Lists
Open and manage tasks from the Smart View panel in Google Sheets.

• Opening a Task List
Open a task list to view its details and take actions.

• Viewing the Task List
View the details of individual tasks in the task list, take action on them, and track the
overall completion status of the task list.

• Executing a Task
Execute incomplete tasks as per their requirements.

• Completing a Task
Mark a task complete after completing its requirements.

• Creating Task List Reports
Create and download a task list report on the task-wise and overall completion status of
the task list.

About Task Lists
Open and manage tasks from the Smart View panel in Google Sheets.

Applies to: Planning

You can open and manage tasks from the Smart View panel in Google Sheets.

Task lists help you organize, track, and prioritize your workload. For example, a task might help
you complete forms, launch business rules, or promote approval units. Through tasks, you can
also launch a website or internal company page.

You can open and view task lists, execute and complete tasks, and create task list reports from
the Task List panel. Service Administrators manage and assign access permissions for task
lists. For more information, see the administration documentation for your data source.

Opening a Task List
Open a task list to view its details and take actions.

To open a task list from Smart View:

1. Connect to your data provider.

2. Open a form or ad hoc grid.

You must have a form or ad hoc grid open on the sheet before you begin working with task
lists.

3. From the Actions Menu in the Smart View Home panel, click Task List.

This opens the Task List panel:
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In the Task List panel, use the Show/Hide toggle button to display or hide the Task Details
pane.

Available commands for tasks appear in the Action Panel, just below the task list tree view
pane and above the Task Details pane.

4. From the Task List panel, select a task list, and then click Open Task List on the Action
Panel.

5. Continue with Viewing the Task List.

Viewing the Task List
View the details of individual tasks in the task list, take action on them, and track the overall
completion status of the task list.

A task list in the Task List panel displays the following:

• The individual tasks in the task list. These may contain subordinate tasks. The status of the
task – complete, incomplete, or overdue – is indicated by color-coding.

For example:
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• Task Details gives you details for the selected task in the task list, including the task
status.

For example:

 

 

Use the Show/Hide toggle button to display or hide the Task Details pane.

• A status bar gives you a high-level view of the status of your task list. The status bar,
located at the bottom of the Task List panel, shows you the number of tasks in the task list,
the number of completed tasks along with a percentage of completed tasks for the task list,
and the number of tasks to complete; for example:

 

 

• The Action Panel displays the actions that are available for the selected task

In the example above, the Open Form and Mark Complete commands are available,

along with the .
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Similarly, for tasks with business rules, the Launch Rule command appears for selecting
and running business rules from the task list itself, while the Open URL or File command
appears for tasks that launch links or open files.

• The More items button,  lets you access a drop-down menu with more commands for
the selected task:

 

 

These actions are available:

– View Instructions: To view instructions for a task, click the More items button, ,
and then select View Instructions. A dialog with information specific to the task is
displayed; for example:

 

 

– Create Report: See Creating Task List Reports.
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– Refresh Task List: Click to refresh the task list, incorporating any new tasks added to
the list, and updating the status bar.

– Task Filter: Click to view the submenu. Select Incomplete to view only incomplete
tasks in the task list. Select All to view the entire task list.

• A drop-down menu at the top in the Task List panel lets you select other task lists
associated with the current application; for example, click the arrow:

 

 

View the other task lists available for application. Task lists with overdue tasks display the
number of overdue tasks in red color next to their name.

 

 

Executing a Task
Execute incomplete tasks as per their requirements.

To execute a task:

1. Open the task list that contains the task to execute.

2. From the Action Panel, click Execute Task.

Task execution varies with the task and data source.

Completing a Task
Mark a task complete after completing its requirements.

To complete a task:

1. Complete the requirements of the task.

2. Open the task list that contains the task to complete.

3. Ensure that any dependent tasks are completed.

4. Select the task to mark complete.

5. From the Action Panel, click Mark Complete.
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Creating Task List Reports
Create and download a task list report on the task-wise and overall completion status of the
task list.

To create a task list report:

1. Open a task list.

2. Select a task, then click , and then select Create Report.

3. In the Report Wizard, use the right and left arrow keys to move all task lists to be included
in the report from Available Task Lists to Selected Task Lists.

In the following example, the Operating Plan task list is selected for a report.

 

 

4. Click Next.

5. Use the right and left arrow keys to move the users whose status you want to include in the
report from Available Users to Selected Users.

6. Click Next.

7. Select options to create your report.

Available options are:

• Group Results By—Group the report output by Task List or by Users.

• Display Columns—Use the check boxes to select the columns to display in the report.
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• Report Details—Use the check boxes to select the details to include in the report. All
report details are selected by default.

Select specific columns by first clearing the Show Details Task Columns in Report
option and then clearing the individual report options that you do not require.

• Report Type—Output type for the report: Excel or PDF.

Selecting the report type as Excel downloads the report in an HTML file.

Note

The support for creating PDF task list reports will be made available in a future
release.

In the following default example, results are groups by Task List, all display columns are
selected, all report details are selected, and the report output type is Excel.
 

 

8. Click Finish, and then click Close.

The report is created in the selected report type.
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12
Planning Approvals

Related Topics

• About Planning Approvals
Planning approvals is the submission, review, and approval process of a planning unit.

• Viewing Planning Units
You can view the list of planning units in the Manage Approvals panel.

• Finding Planning Units
In the Manage Approval panel, you can locate planning units easily by searching or by
applying a filter to the list of planning units. You can use an auto filter or select members as
filter criteria.

• Changing Status of Planning Units
You can change the status of one or more planning units at a time.

• Viewing Promotional Path for Planning Units
You can view the promotional path of a planning unit in graphical form.

• Adding Annotations for Planning Units
You can add or view comments about data in a planning unit that is started. Annotations
can vary by combinations of scenario, version, and entity members

• Setting up an Out of Office Assistant
You can set up the Out of Office Assistant to reassign planning units that arrive while you
are out of the office.

About Planning Approvals
Planning approvals is the submission, review, and approval process of a planning unit.

Applies to: Planning

The approvals process structures the workflow and formalize authority levels as you prepare
budget data.

Approvals enable you to:

• Review and approve planning data

• Track the progress of the budget

• Identify issues in the review process

• View reviewers' remarks through annotations

• View the promotional path of planning data

• Ensure that the plan data meets data validation rules

Viewing Planning Units
You can view the list of planning units in the Manage Approvals panel.

To open the Manage Approvals panel and view the planning units:
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1. Open the appropriate form.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Workflow, and then select Approvals to open the Manage Approvals panel.
Alternatively, you can also click the Actions menu in the Smart View Home panel and
select Approvals.

Figure 12-1    Approvals panel

4. In the Manage Approvals panel, select a Scenario and Version.

5. Click  to display the list of planning units to which you have access.

6. Select the planning unit that you want to view or work on.
If the list is too long to locate the planning unit easily, you can search or apply filters to the
list as described in Finding Planning Units.

7. To view details for the selected planning unit, click Planning Unit Details.

• In the Approval Status tab, you can view a history of the process status, owner,
actions taken, and the dates and times the status changed.

• In the Annotations tab, you can view any comments that were entered for the
planning unit. See Adding Annotations for Planning Units.

8. Click Close to return to the Manage Approvals panel.

9. Perform actions on the planning units using the toolbar on top of the list. Click the ellipsis
button to see more actions.
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Figure 12-2    Toolbar to perform various actions on planning units

•  — Exclude planning units from the approval process and remove them from the
list.

•  — Validate planning units to run any data validation rules set by administrators.

•  — View promotional path for planning units.

•  — Add annotations or comments for planning units.

•  — Filter the list of planning units using different criteria.

•  — Cancel any filters applied on the planning units list.

•  — Change the status of planning units.

•  — Set actions to manage planning units when you are out of office.

10. Click  to close the Manage Approvals panel and return to the Smart View Home panel.
If you opened the Manage Approvals panel from the Actions menu, then use the Close
button, which appears next to the Planning Unit Details button, to close the Manage
Approvals panel and return to the Smart View Home panel.

Finding Planning Units
In the Manage Approval panel, you can locate planning units easily by searching or by
applying a filter to the list of planning units. You can use an auto filter or select members as
filter criteria.

To filter the list of planning units:

1. Open the appropriate form.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Workflow, and then select Approvals to open the Manage Approvals panel.
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Alternatively, you can also click the Actions menu in the Smart View Home panel and
select Approvals.

4. In the Manage Approvals panel, select a Scenario and Version.

5. Click  to display the list of planning units to which you have access.

6. Click  to enable filtering.

If this option is not seen in the toolbar, click the ellipses menu to locate the option.

The filter options, which contains filtering tools, are displayed just above the planning unit
list; for example:

 

 

7. Perform one of the following procedures:

• Search

To search for a specific planning unit, enter its name in the Planning Unit field.

• Use the Auto filters

From the Approvals Status, Sub-Status, and Current Owner lists, select the
required filter values.

• Filter by member selection

a. Click , next to the Planning Units field or the Location field, and then select
members for the planning unit list or location list.

b. In the Member Selector dialog, select the required members and click Done.
You can further filter on planning units or location by making selections in
Approvals Status, Sub-Status, and Current Owner lists.

8. Click  to apply the filters.

The list of planning units is reloaded with the filtered units.

Note

To cancel the applied filters, click .

Changing Status of Planning Units
You can change the status of one or more planning units at a time.

To view or change the status of a planning unit:

1. Open the appropriate form.
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2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Workflow, and then select Approvals to open the Manage Approvals panel.

Alternatively, you can also click the Actions menu in the Smart View Home panel and
select Approvals.

4. In the Manage Approvals panel, select a Scenario and Version.

5. Click  to display the list of planning units to which you have access.

6. Select a planning unit for which you want to change the status.

7. Click the ellipsis button, and then select Change Status, .

Note

If you change the status of a parent entity, all of its children change, too, unless
they were excluded during the First Pass state or were approved.

8. In the Change Status dialog, select an action and the next owner for the planning unit.

9. Optional: In the Enter Annotation field, enter an annotation for the planning unit.

This annotation is seen in the Planning Unit Details section under the Annotations tab.

10. Click Submit.

The status is updated and you can see it in the Planning Unit Details section under the
Approvals Status tab.

11. Optional: To validate the changed planning unit, click . You can validate only one
planning unit at a time.

Viewing Promotional Path for Planning Units
You can view the promotional path of a planning unit in graphical form.

Planning units move from person to person and department to department based on the
following:

• The owners and reviewers assigned to the planning unit

• The planning unit place in the hierarchy

To view the promotional path of a planning unit in graphical form:

1. Open the appropriate form.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Workflow, and then select Approvals to open the Manage Approvals panel.

Alternatively, you can also click the Actions menu in the Smart View Home panel and
select Approvals.

4. In the Manage Approvals panel, select a Scenario and Version.

5. Click  to display the list of planning units to which you have access.

Chapter 12
Viewing Promotional Path for Planning Units

Working with Oracle Smart View for Google Workspace
F56457-09
Copyright © 2025, Oracle and/or its affiliates.

August 1, 2025
Page 5 of 7



6. Select a planning unit for which you want to view the promotional path.

7. Click .

The promotional path is displayed in graphical format. In Chrome, the promotional path is
displayed in a separate tab; for example:

 

 

Adding Annotations for Planning Units
You can add or view comments about data in a planning unit that is started. Annotations can
vary by combinations of scenario, version, and entity members

To add a planning unit annotation:

1. Open the appropriate form.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Workflow, and then select Approvals to open the Manage Approvals panel.

Alternatively, you can also click the Actions menu in the Smart View Home panel and
select Approvals.

4. In the Manage Approvals panel, select a Scenario and Version.

5. Click  to display the list of planning units to which you have access.

6. Select the planning unit for which you want to add an annotation.

7. Optional: To view existing annotations for the selected planning unit, click Planning Unit
Details and then click the Annotations tab.

8. Click .

If this option is not seen in the toolbar, click the ellipses menu to locate the option.

9. In Approvals - Add Annotation, enter a title and annotations.
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In the Enter Annotation text box, you can enter up to 1500 characters. On multibyte
systems, Oracle recommends limiting annotations to 750 characters. You can enter URLs
and links along with text.

10. Click Submit.

Setting up an Out of Office Assistant
You can set up the Out of Office Assistant to reassign planning units that arrive while you are
out of the office.

With the Out of Office Assistant, you can set the following actions that can be automatically
taken on planning units assigned to you while you are away.

• Promote: The planning units are promoted to the next owner or level in the promotional
path.

• Reject: The planning units are rejected and returned to the previous owner.

• Delegate: The planning units are delegated to a user of your choice.

• Submit: The planning units are submitted.

To set up the Out of Office Assistant:

1. Open the appropriate form.

2. In the Extensions menu, select Smart View for Google Workspace, and then select
Form.

3. Select Workflow, and then select Approvals to open the Manage Approvals panel.

Alternatively, you can also click the Actions menu in the Smart View Home panel and
select Approvals.

4. In the Manage Approvals panel, click Out of Office Assistant, .

5. In the Out of Office Assistant dialog, select the I am currently out of office check box.

6. Select an action and the next owner to manage the planning units that arrive while you are
out of the office.

For example, if you select the Delegate option, select the owner to whom the planning
units must be delegated from the Select Next Owner list.

7. Optional: In the Enter Annotation field, enter an annotation for the planning units.

This annotation is seen in the Planning Unit Details section under the Annotations tab.

8. Click Submit.
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13
Functions

Related Topics

• About Functions
You can use supported functions in Smart View to retrieve and send data in specific cells in
Google Sheets sheet.

• Creating Functions
You can create functions manually or by using the Function Builder.

• Function Descriptions
Smart View supports the functions listed here. Click a function name to access description,
syntax, and examples.

• Running Functions
You can run most Smart View functions automatically using Refresh commands.

• Specifying a Label for Missing Data in Functions
Set a value for missing data in user-defined functions, such as HsGetValue or HsSetValue,
using the Missing Label option in the Options dialog.

• Updating Unresolved Functions
You can update the functions that remain unresolved after a sheet refresh.

• Common Function Error Codes
These are some common error codes displayed in functions.

About Functions
You can use supported functions in Smart View to retrieve and send data in specific cells in
Google Sheets sheet.

If you are familiar with the contents of your database, you can use Smart View functions to
perform operations on specific data in Google Sheets cells.

In Smart View, you can use the Function Builder panel to add functions to cells on a sheet, or
enter functions manually into cells on the sheet, providing a connection name and the POV,
and then retrieve data upon refresh.

The following functions are supported in Smart View.

Table 13-1    Smart View Functions and Supported Providers

Function Description Supported Providers

HsGetValue Used to create static reports
which can then be formatted as
required by retrieving
application data into specific
cells.

• Planning
• Planning Modules
• Financial Consolidation and

Close
• Tax Reporting
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Table 13-1    (Cont.) Smart View Functions and Supported Providers

Function Description Supported Providers

HsSetValue Used to send a data value from a
worksheet to a data source based
on selected members of
dimensions.

• Planning
• Planning Modules
• Financial Consolidation and

Close
• Tax Reporting

HsAlias Used to display the alias of the
specified dimension member.

• Planning
• Planning Modules
• Financial Consolidation and

Close
• Tax Reporting

HsGetSheetInfo Used to retrieves detailed
information about the current
sheet, one sheet property at a
time.

• Planning
• Planning Modules
• Financial Consolidation and

Close
• Tax Reporting

Guidelines for Using Functions

Consider the following guidelines while using functions in Smart View:

• Functions are validated only upon refresh.

• If any function is invalid, then all functions on the sheet, including valid functions, will
display #Error. For example, an invalid dimension or member name will result in an invalid
function. Review functions for errors and correct them, and then refresh the sheet again.

• If a function sheet contains functions from different data source connections, then
refreshing the sheet refreshes all the functions from all the connected data sources.

• On a Functions-only sheet, ad hoc analysis cannot be performed and multiple grids cannot
be inserted.

Creating Functions
You can create functions manually or by using the Function Builder.

Related Topics:

• Creating Functions in the Function Builder

• Creating Functions Manually

Creating Functions in the Function Builder
In the Function Builder, you select a function and specify the connection and members that you
want the function to use.

The Function Builder then creates the function using the proper syntax and enters it into the
selected cell. You can edit these functions.

The selections available to you in a given Function Builder field are limited by your selections
in other fields of the Function Builder. For example, only the connections supported by the
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selected function are displayed, and only the dimensions supported by the function you select
are displayed.

A cell reference can be selected for each function argument. Type-in functionality is available
for each argument.

To create functions using the Function Builder:

1. Connect to a data source.

2. Select a cube and, in the connection dialog that displays, select Set as Connection for
Functions, then type a name for the connection, and then click OK.

In the below example, the connection name is MyVision.

Note

You must create a connection name for each new spreadsheet.

The connection name is saved with the spreadsheet. When you reopen the saved
spreadsheet, you will not be prompted to enter a connection name.

Figure 13-1    Connection Option and Name

3. In the sheet, select the cell in to which you want to enter the function.

4. In the Extensions menu, select Smart View for Google Workspace, and then select
Build Function under Functions.

5. In the Function Builder panel, choose a function from the list and then click Select.
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Note

Currently, Smart View supports these functions:

• HsGetValue

• HsSetValue

• HsAlias

• HsGetSheetInfo

For detailed explanation of these functions, see Function Descriptions.

In the below example, the HsGetValue function is selected.

Figure 13-2    Function Builder Panel, Supported Functions List

After clicking Select, the selected function's panel is displayed in the Function Builder.
The following example displays the fields for HsGetValue in the Function Builder. These
fields vary based on the selected function.
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Figure 13-3    Function Builder Panel, Member List

6. For HsGetValue:

a. In Connection, enter the connection name you specified in step 2.

b. In Member List, add an argument for each dimension in the cube using any of the
following methods:

• Click the Select Member button, , next to the argument text box, and in the
Member Selector, select a dimension and member. Repeat for each dimension in
the cube.

• Enter the argument manually by typing the dimension and member pair in the text
boxes using the format: dimension#member. For example, Year#Qtr1 or Year#Jan.
Repeat for each dimension in the cube.

• To use cell references, follow the procedure in Using Cell References.

The following example displays a completed Member List for the HsGetValue function.
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Figure 13-4    Function Builder panel for HsGetValue based on the Planning
Vision Sample Database

c. Optional: To add more rows in the Member List, click Add.

7. For HsSetValue:

a. In Value, enter the value that you want to set.

b. In Connection, enter the connection name you specified in step 2.

c. In Member List, add an argument for each dimension in the cube.

d. Optional: To add more rows in the Member List, click Add.

8. For HsAlias:

a. In Connection, enter the connection name you specified in step 2.

b. Enter the values in the Member Name, Destination Alias, Source Alias, and
Distinct Name fields.

9. For HsGetSheetInfo: Select a property from the Sheet Property list.

10. Click Validate and correct any errors.

Errors are noted in the Function Builder panel, next to the problem areas.

Some of the errors that you may see are:

• Connection offline or invalid

• Invalid selection

• Member name is invalid or not matching selected alias
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• Dimension name is invalid or not matching selected alias

• Incomplete Dimension#Member combination

• Generic "Error" in cases of missing quotation marks or other minor syntax errors

For example, Function Builder Validation Errors shows simple spelling errors that resulted
in an invalid Connection name, an invalid dimension name in one argument, and an invalid
member name in another argument.

Figure 13-5    Function Builder Validation Errors

Note

Validate only works with dimension#member combinations that are hand-typed
into the text boxes and does not apply to those dimension#members that are
added using the Member Selector dialog. If all dimension#member combinations
are entered using the Member Selector, then no validation messages regarding
those combinations are displayed. You may still see an error regarding the
connection name if it is misspelled.

• If the connection name is correct and all the other dimension#member
combinations were added using the Member Selector dialog, then a
"Validation successful" message will not display.

• If the connection name is correct and one or more dimension#member
combinations were hand-typed correctly, then a "Validation successful"
message will display.

11. Resolve the errors and click Validate again.

When the function validates correctly, a message appears stating that validation is
successful.

12. Click Apply.

13. To execute the function, follow the procedure in Running Functions.

Using Cell References
You can enter references to single cells for connection, label, data/text, or variable arguments.

To use cell references:
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1. Follow the steps in Creating Functions in the Function Builder to open the Function
Builder panel.

2. In the Function Builder panel, for each argument in the selected function, select the cell
in the sheet to reference, and then click the Cell Reference button, .

You can also hand type the cell reference using the following syntax:

""&<column letter><row number>&""

For example:

""&A3&""

Notes:

• If the member name that you selected in this step is displayed as dimension#member
in the grid, then the argument selection is complete. For example, if the member is
displayed in the grid as Year#Qtr 2 in cell A3, then ""&A3&"" is complete.

If only the member name is displayed in the grid, then you must manually enter the
dimension name followed by # between the first two sets of double quotation marks.
For example, if the member is displayed as Qtr2 in cell A3, then you must enter Year#
between the quotation marks: "Year#"&A3&""

• If an argument text field contains text before you select a reference cell, the cell
reference text is appended to this text. Therefore, delete any unwanted text in the field
before selecting a cell for reference.

• If a date cell is directly referred as input, then convert the input to the proper text
format using a Text function as follows; in this example, cell B3 contains a proper date:

=HsSetValue(TEXT(B3,"dd/mm/yyyy"),"ConnectionName", "dim#member"…)

3. When you have finished entering cell references, click Apply.

4. Refresh the sheet.

Creating Functions Manually
You can create functions manually in Smart View.

To create a function manually in Smart View:

1. Connect to a data source.

2. Select a cube and, in the connection dialog that displays, select Set as Connection for
Functions, and then type a name for the connection, and then click OK.

In the below example, the connection name is MyVision.

Note

You must create a connection name for each new spreadsheet.

The connection name is saved with the spreadsheet. When you reopen the saved
spreadsheet, you will not be prompted to enter a connection name.
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Figure 13-6    Connection Option and Name

3. In the sheet, click the cell in which you want to enter the function.

4. Enter an equals sign and then type the function name; for example:

=HsSetValue

5. Enter parameters for the function according to rules described in Syntax Guidelines, using
the information specific to each function in Function Descriptions.

6. To add functions to other cells in the sheet, repeat steps 4 through 6

7. To run the functions, refresh the sheet.

Functions are validated only upon refresh.

If any function is invalid, then all functions on the sheet, including valid functions, will
display #Error. For example, an invalid dimension or member name will result in an invalid
function.

Review the functions for errors and refresh the sheet again.

Syntax Guidelines
Use the following guidelines to enter parameters for functions.

See Function Descriptions for the syntax of individual functions.

• The connection parameter is the user-defined name for a connection.

The connection parameter must precede the POV.
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• The POV is composed of dimension#member pairs, for example:

Entity#Connecticut

• Parent-child relationships are designated by a period, (.); for example:

Entity#UnitedStates.Maine

• The connection and each POV dimension#member pair can be split into separate function
parameters, each parameter enclosed in quotation marks, ("), and separated by a comma,
(,); for example:

"MyVision","Entity#UnitedStates","Account#Sales"

The use of semicolons (;) as the dimension#member parameter separator is not supported.

• If a POV dimension#member is not specified, then Smart View adds the top level member
of that dimension to the function. For example, in the following HsGetValue function, there
is no Period dimension and member specified:

=HsGetValue("MyVision","Account#Amount","Years#2017","Scenario#Annual, 
Contract","Version#Final","Entity#AR02-
Argentina-,IS_Adjustments","Package#Depreciation","Currency#Local Currency")

In this case, Smart View will add the top-level Period member, which is Period, to the
function, Period#Period. For example:

=HsGetValue("MyVision","Account#Amount","Period#Period","Years#2017","Scenario#Annual 
Contract","Version#Final","Entity#AR02-Argentina-
IS_Adjustments","Package#Depreciation","Currency#Local Currency")

• Do not mix a dimension name and its aliases in functions. However, for members, you can
either use the member name or its alias from the selected alias table.

• Enclose text values in quotation marks, (") when using them in HsSetValue function. For
example:

HsSetValue("Enter Some Text", "MyVision","Account#7110: 
Advertising","Period#Jun","HSP_View#BaseData","Year#FY16","Scenario#Plan","Version#Commentary","Enti
ty#International Sales","Product#No Product")

Creating Functions from Multiple Connections
You can create a function sheet by adding functions from different cubes and data sources.

For adding functions from multiple data source connections, you can connect to the required
data sources before you start creating the function sheet or even during the process.

To add functions from multiple data source connection on the same sheet:

1. Open a new sheet and connect to a data source.

2. Select a cube and, in the connection dialog that displays, select Set as Connection for
Functions, then type a name for the connection, and then click OK.

3. In the sheet, select the cell in to which you want to enter the function.
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4. Add a function either by creating it manually or by using the Function Builder.
See Creating Functions Manually and Creating Functions in the Function Builder.

5. To add a function from another cube on the same sheet, repeat the above steps from step
2 to step 5.

6. To add a function from another data source on the same sheet:

a. Connect to the other data source, if not already connected. In the Extensions menu,
select Smart View for Google Workspace, and then select Connect under Start.
For more information, see Connecting to Data Sources.

b. Once connected, set it as an active connection in the sheet. In the Extensions menu,
select Smart View for Google Workspace, and then select Active Connections
under Start.
For more information, see Setting Active Connection for a Sheet.

c. In the sheet, select the cell in to which you want to enter the function.

d. Add a function either by creating it manually or by using the Function Builder.

Note

In case of multiple-grid ad hoc sheets having grids from multiple connections,
the HsGetSheetInfo function retrieves the sheet properties only for the first
connection, irrespective of the connection that is currently active on the sheet.
This is a limitation.

7. To run the functions and view the values, refresh the sheet.
All functions from all the connected data sources are refreshed at once.

Review the functions for errors and refresh the sheet again.

Function Descriptions
Smart View supports the functions listed here. Click a function name to access description,
syntax, and examples.

• HsGetValue: Retrieves data from the data source for selected dimension members of a
Point of View.

• HsSetValue: Sends a value to the data source for selected dimension members of a Point
of View.

• HsAlias: Displays the alias of the specified dimension member.

• HsGetSheetInfo: Retrieves detailed information about the current sheet, one property at a
time.

HsGetValue
Applies to: Planning, Planning Modules, Financial Consolidation and Close, Tax Reporting

Description

HsGetValue retrieves data from the data source for selected dimension members of a Point of
View (POV).

Chapter 13
Function Descriptions

Working with Oracle Smart View for Google Workspace
F56457-09
Copyright © 2025, Oracle and/or its affiliates.

August 1, 2025
Page 11 of 17



When HsGetValue retrieves no data, the value specified for the Missing/No Data Label
replacement option is used (see Data Options).

When HsGetValue and HsSetValue are on the same sheet, and you select Refresh, only
HsGetValue is called. If you select Submit, HsSetValue is called. If HsSetValue returns
successfully, then you must then select Refresh to call HsGetValue.

HsGetValue supports the use of one attribute dimension and member with Planning, Planning
Modules, Financial Consolidation and Close, Tax Reporting data sources (see Example with
Attribute).

Syntax

HsGetValue("ConnectionName","POV")

For detailed syntax information, see Syntax Guidelines.

Example 13-1    Example without Attribute

In this example, HsGetValue returns the value from the Vision application, Plan1 cube
(represented by the MyVision connection name), for the specified POV.

=HsGetValue("MyVision","Account#Amount","Period#Jan","Years#2017","Scenario#Annual 
Contract","Version#Final","Entity#AR02-Argentina-IS_Adjustments","Package#Depreciation","Currency#Local 
Currency")

Example 13-2    Example with Attribute

In this example, HsGetValue returns the value from the Vision application, Plan1 cube
(represented by the MyVision connection name), and the POV includes an attribute dimension
and member, Entity_Regions#NA_Reg.

Note

HsGetValue supports only one attribute dimension and member per function.

=HsGetValue("MyVision","Account#Amount","Period#Jan","Years#2017","Scenario#Annual 
Contract","Version#Final","Entity#AR02-Argentina-IS_Adjustments","Package#Depreciation","Currency#Local 
Currency","Entity_Regions#NA_Reg")

HsSetValue
Applies to: Planning, Planning Modules, Financial Consolidation and Close, Tax Reporting

Description

HsSetValue sends a data value from a worksheet to the data source for selected dimension
members of a Point of View (POV). Attribute dimensions and members are not supported in
HsSetValue.

To send data to a data source, you must have the appropriate load rule and have write access
for the data source.
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HsSetValue can also be used to send enumerated data types, such as Smart List, text, and
dates.

Note

HsSetValue function should not be used to set value for a data cell containing
supporting details. If used, the HsSetValue function cannot identify if a cell contains
supporting details or not, and proceeds to update and submit the cell value with the
new function-fetched value. This leads to an incorrect behavior. The original value
continues to appear in the Supporting Details dialog box for the cell. So it is
recommended not to use HsSetValue function to set value in cells with supporting
details.

Syntax

HsSetValue (value,"ConnectionName","POV")

For detailed syntax information, see Syntax Guidelines.

Example 13-3    Basic Example

In this example, HsSetValue sends the value 123 to the Vision application (represented by the
MyVision connection name).

=HSSETVALUE(123, "MyVision","Account#7110: Advertising","Period#x---------
x","HSP_View#BaseData","Year#FY19","Scenario#Forecast","Version#Driver","Entity#International 
Sales","Product#No Product")

Example 13-4    Example with Text

Quotation marks are required when text is used for the value parameter in HsSetValue.

HsSetValue("Enter Some Text", "MyVision","Account#7110: 
Advertising","Period#Jun","HSP_View#BaseData","Year#FY16","Scenario#Plan","Version#Commentary","Entity#In
ternational Sales","Product#No Product")

HsAlias
Applies to: Planning, Planning Modules, Financial Consolidation and Close, Tax Reporting

Description

HsAlias displays the alias of the specified dimension member.

Note

Function nesting is not supported for HsAlias. That is, HsAlias output cannot be
referenced in another HsAlias function.
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Syntax

HsAlias("PrivateConnectionName","Dimension#Member", "OutputAliasTable", "MemberNameFromAliasTable", 
"FlagToReturnDistinctName")

Note

For detailed syntax information, see Syntax Guidelines.

Example 13-5    Basic Example

HsAlias("MyVision","Scenario#Actual", "German", "Default", "True")

Notes

• The connection and Dimension#Member parameters are required.

• The OutputAliasTable parameter is optional. If OutputAliasTable is empty, then the
connection level alias will be used for OutputAliasTable.

• It is optional to specify which alias table the member is from. If
MemberNameFromAliasTable is empty, then the original member name from the outline
will be used.

• If the member name is not found in the alias table specified in
MemberNameFromAliasTable, then the original member name from the outline will be
used.

• The HsActive keyword within the HsAlias function can only be used on a sheet with an ad
hoc grid.

• Copy and Paste either from Smart View or Google Sheets is not supported. Only static text
will be pasted.

• The Boolean argument, FlagToReturnDistinctName, determines if the alias output is a
short name or fully qualified name. The default is False.

HsGetSheetInfo
Applies to: Planning, Planning Modules, Financial Consolidation and Close, Tax Reporting

Description

HsGetSheetInfo retrieves information about the current sheet, one property at a time. The
following sheet properties can be retrieved and displayed in the sheet.

Table 13-2    HsGetSheetInfo Details

String Equivalent Sheet Information

Last Retrieved The date and time that the last refresh was
performed on the sheet

Sheet Type Form, Ad hoc, Multiple grid ad hoc, Function, or
Smart Form

Server The server to which the sheet is connected
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Table 13-2    (Cont.) HsGetSheetInfo Details

String Equivalent Sheet Information

Application The application to which the sheet is connected

Cube The cube to which the sheet is connected

URL The URL to which the sheet is connected

Alias Table The current alias table

Provider The data source type to which the sheet is
connected

Display of the following sheet properties is not supported:

• User

• Friendly Name

• Description

• Provider URL

Syntax

HsGetSheetInfo("<string equivalent>")

For detailed syntax information, see Syntax Guidelines.

Example 13-6    Basic Example

In this example, HsGetSheetInfo tells you whether the sheet contains a Form, Ad hoc, Multiple
grid ad hoc, Function, or Smart Form.

HsGetSheetInfo("Sheet Type")

Notes

• If you enter an invalid sheet property, the function returns a "Not Applicable" value.

• In a multiple-grid ad hoc sheet, HsGetSheetInfo always displays information related to the
first inserted grid. If you use the Last Retrieved property to find the date and time when the
last refresh was performed on the sheet, the HsGetSheetInfo function displays the time
when the first grid was retrieved, even though the second grid was the one that was last
retrieved on the sheet. However, you can launch the Sheet Information dialog to see the
correct last retrieved time or refresh the sheet one more time to get the consistent time.

• In case of multiple-grid ad hoc sheets having grids from multiple connections, the
HsGetSheetInfo function retrieves sheet property only for the first connection, irrespective
of the connection that is currently active on the sheet.
For example, if you have two ad hoc grids from two different connections on a multiple-grid
ad hoc sheet and you use the URL property, the HsGetSheetInfo function displays the
connection URL only for the grid that was first connected on the sheet.

• With cell styles enabled for an ad hoc grid, if you change a sheet property that you have
added using the HsGetSheetInfo function, the function cell appears dirty. For example, if
you change the URL sheet property added on the sheet to Cube, the function cell
refreshes to display the cube name, but it appears dirty. In such case, click Refresh to
remove the dirty background color.
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Running Functions
You can run most Smart View functions automatically using Refresh commands.

For HsGetValue, use the Submit command.

To run functions and retrieve values:

1. Connect to a data source.

2. Open the sheet that contains the functions you want to run.

3. Do one of the following:

• For HsSetValue, click Submit.

• To run functions and update all the sheets in the spreadsheet, click Refresh.

Specifying a Label for Missing Data in Functions
Set a value for missing data in user-defined functions, such as HsGetValue or HsSetValue,
using the Missing Label option in the Options dialog.

You can enter a value in the Missing Label field before performing any operations on the
sheet, such as specifying a blank sheet for ad hoc analysis or for functions. This option is
available immediately after connection when you open Options. You can also specify a value
for the Missing Label option at any time.

To set the a value for the Missing Label option:

1. Connect to a data source.

2. Optional: Open a sheet that already contains functions.

3. In the Extensions menu, select Smart View for Google Workspace, and then select
Options.

4. In the Advanced tab of the Options dialog, under User-Defined Functions, enter a value
in the Missing Label text box.

The default value is #Missing; however, you may specify a custom value and include special
characters or capitalization, as you require.

5. Close the panel or, optionally, save this value for future use by clicking the Save Current
Options as Default link, and then close the panel.

6. Proceed by adding functions to the sheet manually or using the Function Builder; or,
proceed with operations in the sheet containing functions that you opened earlier.

Updating Unresolved Functions
You can update the functions that remain unresolved after a sheet refresh.

Google Sheets typically supports refreshing of up to 1500 functions in a spreadsheet. While
refreshing functions in a Smart View sheet, some functions may remain unresolved. This may
happen if the sheet contains a large number of functions or if the refresh operation crosses
Google Sheets' timeout threshold of 30 seconds. Cells with unresolved functions display the
#Error code.
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Instead of refreshing the whole sheet again, you can use the Update Unresolved Functions
option to refresh only the cells with #Error and resolve the functions correctly.

To update unresolved functions:

1. In the Extensions menu, select Smart View for Google Workspace, and then select
Functions.

2. Select Update Unresolved Functions.
The cells with #Error are refreshed to resolve the function and display the values.

Common Function Error Codes
These are some common error codes displayed in functions.

#NO CONNECTION - You are not connected or logged on to a data source.

#INVALID - Invalid metadata. Invalid cells that contain a value display the value as zero.

#LOCKED - The cell is locked.

#NO ACCESS - You do not have access to this cell.

#NO DATA - The cell contains NoData. You can select to display zeros instead of NoData.
Cells use the Replacement text that you specify in the Options dialog.

#INVALID INPUT - The HsSetValue data value is not valid, for example, a text string.

#READ ONLY - This is for the HsSetValue function only when the cell is read-only.

#NEEDS REFRESH - Data needs to be refreshed.

#INVALID DIMENSION - An invalid dimension is specified in the function.

#INVALID MEMBER - An invalid dimension member name is specified in the function.

#NAME - Google Sheets does not recognize text in a formula. When you forward a sheet that
contains functions to a user who does not have Smart View, they can view the same data as
the functions on the sheet. When the user edits or refreshes the function, it changes to #Name.
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14
Free-Form Mode

Related Topics

• About Free-Form Mode
In ad hoc analysis, if you are familiar with the dimensions and members of your database,
you can use free-form mode by typing dimension and member names directly into cells.

• Guidelines for Working in Free-Form Mode
Consider these guidelines when working in free-form mode.

• Creating Free-Form Grids
You can create a free-form grid by typing dimension and member names directly into cells
in a sheet.

• Actions that may cause Unexpected Behavior
Smart View tries to preserve all comments, formulas, and customized report layouts.

About Free-Form Mode
In ad hoc analysis, if you are familiar with the dimensions and members of your database, you
can use free-form mode by typing dimension and member names directly into cells.

You can still use the POV, member selection, and other ad hoc operations in free-form grids.

Table 14-1    Smart View Grid Components

Grid Component Description

Row Dimension A dimension or member placed down one column across one or more
rows in a worksheet

Column Dimension A dimension or member placed on a row across one or more columns in
a worksheet

Comments Text added by the user

Data Region Areas of the grid that contain data for dimensions or members

Blank Region Areas of the worksheet that contain no entries

Guidelines for Working in Free-Form Mode
Consider these guidelines when working in free-form mode.

• Grids do not need to start in cell A1.

• A grid must have at least one row dimension and one column dimension.

• Each row dimension can contain members of only one dimension. Each column dimension
can contain members of only one dimension.

• Members of one dimension can be entered only in one of the following regions:

– In the same row

– In the same column
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• The replacement labels specified in the Data tab in the Smart View panel when you click
Options apply in free-form mode.

• Numerical entries are identified as data in the data region, and as comments outside the
data region. If you want to use a number as a member name, precede it with a single
quotation mark; for example, '100.

• Precede member names that contain spaces between words with a single quotation mark.

• When connected to a database that supports duplicate member names, select Distinct
Member Name Only in the Member Name Display field in the Members tab in Smart
View Options to display fully qualified member names in the worksheet. To enter duplicate
members, use this syntax for qualified member names:

[Income].[Other]
[Expenses].[Other]

• Aliases from the current alias table are permitted in free-form grids, but aliases from other
alias tables are treated as comments.

• In an ad hoc grid, if you insert a column and type a member name in the new column, and
want to change the alias table for the sheet, you must first refresh the sheet before
changing the alias table.

• Consider the exceptions listed in Actions that may cause Unexpected Behavior while
working in free-form mode.

Creating Free-Form Grids
You can create a free-form grid by typing dimension and member names directly into cells in a
sheet.

To create a free-form grid:

1. Open a new sheet and connect to a data source.
If you already connected to any data sources on other sheets and want to apply the same
connection, open the Active Connections dialog box, select the server URL, and click Set
Connection for Sheet. For more information, see the Setting Active Connection for an
Existing Sheet section in Setting Active Connection for a Sheet.

2. In the sheet, create a grid by typing the member names in rows and columns in free-form
mode.
Follow the guidelines specified in Guidelines for Working in Free-Form Mode.

3. In the Extensions menu, select Smart View for Google Workspace, and then select
Refresh.

4. Select the plan type to which you want to connect and retrieve data for the grid.
The sheet refreshes and displays the values in the grid.

Actions that may cause Unexpected Behavior
Smart View tries to preserve all comments, formulas, and customized report layouts.

Some exceptions that may result in unexpected behavior when the following actions are
performed:

• Zoom in on a page dimension

• Pivot a dimension from the POV to a row or column
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• Drag and drop a dimension from the POV to the worksheet

• Pivot a row dimension to a column dimension

• Switch the location of a row dimension to another row

• Switch the location of a column dimension to another column

• Change member aliases using the Change Alias Table command
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