15Financial Reporting

This chapter contains the following:

The Financial Reporting Center is intended to be the primary user interface for financials end users to access all seven report types.

Financial Reporting Center

The Financial Reporting Center includes these report types: Financial Reporting Studio Reports, Account Groups and Sunburst, Smart View Reports, Oracle Transactional Business Intelligence Analyses, Oracle Transactional Business Intelligence Dashboards, Oracle Business Intelligence Publisher Reports, and Business Intelligence Mobile Apps. Other reporting tools are also available to run the same seven report types.

The following figure illustrates the report types that are available in the Financial Reporting Center.

This figure shows the report types that are available
in the Financial Reporting Center. In the Enterprise Performance Management
Workspace, reports can be created from General Ledger balances cubes
and Oracle transaction tables.

Reports can be accessed through various methods. However, the Financial Reporting Center provides access to every type of report, is intended to be the primary user interface for financials end users, and is tablet and smartphone friendly. In addition to accessing reports, you can add favorites, define tags, and view report details, such as type and last updated date.

Financial Reports are read from the Shared > Custom > Financials and My Folders directories. All other report types can be saved anywhere in the BI Catalog however, any user-defined content should be in the Shared > Custom folder. Subfolders can be created within the Shared > Custom folder.

Seven types of reports can be run from the Financial Reporting Center and from the other reporting tools.

  • Financial Reports: These reports are built off of the Oracle Financial Reporting Studio using data in the Oracle Fusion General Ledger balances cube. For example, company income statements and balance sheets. These reports are mainly run by users in General Ledger.

  • Account Groups and Sunburst: Account groups are used to monitor key accounts in General Ledger. When a user creates an account group, it becomes visible in the Financial Reporting Center with the Sunburst visualization tool. The Sunburst visualization tool lets you interact with your account balances across various business dimensions to view balances from different perspectives. Account groups are used only in General Ledger.

  • Smart View Reports: Smart View is a multidimensional pivot analysis tool combined with full Excel functionality. Smart View enables you to interactively analyze your balances and define reports using a familiar spreadsheet environment. These queries are mainly for users in General Ledger. To share Smart View queries, users can email them to other users, or they can upload the queries to the Financial Reporting Center where users can download them to a local drive for use. The Financial Reporting Center is only a place for users to upload and download Smart View queries.

    Note: To upload a Smart View report to the Financial Reporting Center: select the Open Workspace for Financial Reports task, navigate to the BI Catalog, and select Upload from the Tasks section. Be sure to upload the Excel file to one of the folder locations mentioned previously.
  • Oracle Transactional Business Intelligence Analyses: These analyses and reports are built off of transactional tables using subject areas. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • Oracle Transactional Business Intelligence Dashboards: Dashboards put all the information, functions, and actions that a business user must have to do their job in one place. Dashboards are built off of Oracle Transactional Business Intelligence objects like analyses and reports. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • Oracle Business Intelligence Publisher Reports: Most of these reports are predefined and must first be submitted and resubmitted to see the latest data by the Oracle Enterprise Scheduler through the Scheduled Processes navigation. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • BI Mobile Apps: Oracle Business Intelligence Mobile App Designer is an application that enables you to create multitouch information-driven applications with rich interaction, rich visualization, and rich media, for mobile devices such as iPhone, iPad, Android phone, tablet, and more. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

Other Reporting Tools

Six other tools are available for reporting in Financials.

The following table lists the other reporting tools and the types of reports they support.

Other Reporting Tools Report Type

General Accounting Dashboard and Account Inspector

Account Groups

Reports and Analytics

Oracle Transactional Business Intelligence Objects

BI Catalog

All Report Types, Except Oracle Business Intelligence Publisher Reports

Enterprise Performance Management Workspace

Reports, Books, Snapshot Reports, Snapshot Books, Financial Reporting Batches, and Batch Scheduler

Enterprise Scheduler System

Oracle Business Intelligence Publisher Reports

Even though the Financial Reporting Center is designed to be the main user interface for a financial end user's reporting needs, some users may choose to use any of the six other tools for reporting in financials, such as:

  • General Accounting Dashboard, which provides access to Account Groups: Uses the Account Monitor to efficiently monitor and track key account balances in real time.

  • Account Inspector: Perform ad hoc queries from account groups and financial reports through drill down to underlying journals and subledger transactions.

  • Reports and Analytics: This reporting tool has a panel that reflects the folder structure of the BI Catalog. Users can access and run any Oracle Transactional Business Intelligence analysis, report or dashboard. Users can't run Financial Reports or Oracle Business Intelligence Publisher reports from this interface. This interface can be used by all financials users.

  • BI Catalog: A component of the Enterprise Performance Management Workspace where you can run all report types, except for Oracle Business Intelligence Publisher reports.

  • Enterprise Performance Management Workspace: Create reports, books, snapshot reports, snapshot books, Financial Reporting batches, and batch scheduler, and schedule batches to automatically run and burst to email.

  • Enterprise Scheduler System: Only Oracle Business Intelligence Publisher reports can be submitted from this interface. Users access this interface by navigating to Tools > Scheduled Processes. Most financial users have access to this interface to run standard reports for General Ledger, Payables, Receivables, and so on.

Oracle Fusion Financial Reporting Center is a powerful tool for reviewing, designing, and presenting financial reports and analytic data. The critical choices required to configure and install the components in Financial Reporting Center consist of:

  • Configuring the Financial Reporting Center

  • Installing and configuring Financial Reporting Studio, performed by your end users

  • Installing Smart View, performed by your end users

  • Configuring Workspace Database Connection, performed by your administrator

Configuring Financial Reporting Center

You have access to the reports in the Financial Reporting Center and Workspace installed with Oracle Fusion Financial Applications. Your Oracle Fusion Business Intelligence (BI) administrator defines the folder structure in Workspace. The administrator considers your company's security requirements for folders and reports, as well as report distribution requirements for financial reporting batches.

  • Security can be set on folders and reports from Workspace.

  • You are granted access to the folders and reports you want to view by your BI administrator.

Installing and Configuring Financial Reporting Studio

Oracle Financial Reporting Studio is client-based software. If you open Oracle Fusion Applications from Oracle Cloud, you connect to the Financial Reporting Studio through a Windows Remote Desktop Connection. Report authors download installation files for Financial Reporting Studio from Workspace by clicking Navigator > Financial Reporting Center > Tasks panel drawer > Open Workspace for Financial Reporting. Once Workspace is started, click Tools > Install > Financial Reporting Studio. After performing the prerequisites and completing the installation, start the Financial Reporting Studio. Provide your user ID, password, and the Server URL. Derive the Server URL information by following the steps:

  1. Open Navigator > Financial Reporting Center > Tasks panel drawer > Open Workspace for Financial Reporting.

  2. Edit the Workspace URL and remove workspace/index.jsp.

  3. Following are two examples of Server URLs:

    • If the Workspace URL is https://fusionsystemtest-p-external-bi.visioncorporation.com/workspace/index.jsp, the Server URL is https://fusionsystemtest-p-external-bi.visioncorporation.com.

    • If the Workspace URL is https://fusionsystemtest-p-external-bi.visioncorporation.com:10622/workspace/index.jsp, the Server URL is https://fusionsystemtest-p-external-bi.visioncorporation.com:10622.

  4. Copy the modified URL to the Server URL field.

Note: For end users installing the Oracle Fusion Financials Reporting Studio, the installer starts a separate console window. The installer continues to run for a brief time after the installation completes the setup tasks. The process is normal, expected, and applies to Oracle Reporting Studio installations in both the Oracle Fusion Applications and Enterprise Performance Manager modes.

Wait for the console window to close, which happens automatically, before clicking the Finish button on the Financial Reporting Studio Installation dialog box. If you click the Finish button before the console window closes, the Financial Reporting Studio installation may not complete.

Note: You must save a new report before attempting to preview it with Web Preview.

Prerequisites needed for installing the Financial Reporting Studio are:

  1. Financial Reporting Studio Client Certifications that are found at: http://www.oracle.com/technetwork/middleware/bi-foundation/hyperion-supported-platforms-085957.html.

  2. Microsoft Office installed on your users' computers.

Installing Smart View

Smart View is an Excel add-in that must be loaded on each client. To download Smart View, click Navigator > Financial Reporting Center > Tasks panel drawer > Open Workspace for Financial Reports. Once the workspace is started, click Tools > Install > Smart View.

Note: Since Smart View is an add-in to Microsoft Office products, you can install Smart View only on a Windows operating system.

Once Smart View is installed, you must configure the connection using the Smart View Shared Connections URL. You can derive the Shared Connections URL by following these steps:

  1. From the Financial Reporting Center task panel, select Open Workspace for Financial Reporting.

  2. Edit the workspace URL by removing index.jsp and adding SmartViewProviders at the end.

    Note: The following URL is an example for a Cloud-based environment. If the workspace URL is https://efops-rel5st4-cdrm-external-bi.visioncorporation.com:10622/workspace/index.jsp, the Shared Connections URL is https://efops-rel5st4-cdrm-external-bi.visioncorporation.com:10622/workspace/SmartViewProviders.
  3. Copy the URL.

  4. Open Excel.

  5. From the Smart View menu, click Options > Advanced.

  6. Paste the URL in the Shared Connections URL field.

  7. Click OK.

To connect Oracle Fusion General Ledger Balances cubes in Smart View:

  1. Open Smart View from your Start menu > Programs > Microsoft Office > Microsoft Excel 2007.

  2. Navigate to the Smart View menu > Open. On the Start on the ribbon, click Smart View Panel that appears in the list of values from the ribbon. The task pane opens.

  3. Click Shared Connections on the task pane.

  4. Sign in with your user name and password.

  5. Click the Select Server to proceed list of values.

    Note: If the Essbase Server is not there, then it has to be added. Use the following steps:
    1. Click the Add Essbase Server link.

    2. Specify the Essbase Server login and password.

    3. Expand the Essbase server and locate the cube in it.

  6. Select Oracle Essbase from the list of shared connections.

  7. Click the Expand to expand the list of cubes.

  8. Expand your cube (name of your chart of accounts).

  9. Click db.

  10. Click the analysis link.

Note: You must perform these steps only once for a new server and database.

To set how the name and alias of the Essbase database appears:

  1. Click Options on the ribbon > select the Member Options > select Member Name Display.

  2. Set one of these three options:

    • Distinct Member Name. Only shows the full Essbase distinct path.

    • Member Name and Alias: Shows both the member name and the alias.

    • Member Name Only. Shows only the member name.

Note: The Smart Slice feature is not supported in Oracle Fusion General Ledger. For all other documentation, refer to the Oracle Smart View for Office User's Guide.

Configuring Workspace Database Connections

Administrators must create database connections from Workspace so users can access the cubes from Workspace and Financial Reporting Studio.

Note: Ledger setup has to be completed before the database connection can be created. Oracle Fusion General Ledger balances cubes are created as part of ledger setup. A separate cube is created for each combination of chart of accounts and accounting calendar. A database connection is needed for each cube.

Steps to define a database connection are:

  1. Start at the Navigator by selecting Financial Reporting Center.

  2. From the Financial Reporting Center task panel, select Open Workspace for Financial Reporting.

  3. From within Workspace select the Navigator menu > Applications >BI Catalog.

  4. Select Tools menu > Database Connection Manager.

  5. Select New button.

  6. Enter a user-friendly name for the Database Connection Name.

  7. Enter Essbase as the Type, your server, user name, and password.

  8. Select Application (cube) and Database from the list of values. Expand the Application name to see the related Database.

  9. Click the OK button twice to save your selections.

  10. Click Close button in the Database Connection Manager window to save your connection.

Note: The database connection is available in both Workspace and Financial Reporting Studio. Optionally, it can be set up in Financial Reporting Studio when putting grids on a report. This should only be done by an administrator.

For more detailed information about Smart View and Financial Reporting Studio, refer to the Using EPM with Oracle Financials Cloud link on the Books for Oracle Financials Cloud page of the Oracle Help Center at https://docs.oracle.com.

Considerations for Implementing Financial Reporting Center

The Financial Reporting Center adds self-service functionality for the Oracle Fusion Applications and the Oracle Fusion Accounting Hub. The financial reports are available immediately on both computers and mobile devices, which leads to quicker decision making.

Note: To access the reports in Financial Reporting Center, store the reports in the My Folder or Shared Custom directories.

Job Roles and Duty Roles

The following table shows the predefined job roles and their associated duty roles.

Predefined Job Role Duty Roles

General Accountant

  • Financial Reporting Management

  • Account Balances Review

General Accounting Manager

  • Financial Reporting Management

  • Account Balances Review

Financial Analyst

  • Financial Reporting Management

  • Account Balances Review

Business Process Model Information

The features are part of the Manage Financial Reporting and Analysis detailed business process.

The following table shows the activities and tasks for that business process.

Activity Task

Prepare Financial Reports

Generate Financial Statements

Analyze Financial Performance

Inquire and Analyze Balances

Oracle Hyperion Financial Reporting Studio enables you to use an object-oriented graphical report layout with report objects, such as text boxes, grids, images, and charts.

Financial Reporting Studio supports the following functionality:

  • Client-based report definition tool.

  • Object based reporting. Objects are reusable across multiple reports

  • Drag and drop report grids

  • Insert additional report objects such as text boxes, images, and charts

  • Drag and drop dimensions to the report grid. Each dimension can only be in one location on report: row, column, page, or point of view.

  • Insert rows and columns including data, formula, and text

  • Select dimension member using member selection or functions

  • Add calculations or mathematical functions

For more information about Financial Reporting Studio, refer to the Using EPM with Oracle Financials Cloud link on the Books for Oracle Financials Cloud page of the Oracle Help Center at https://docs.oracle.com.

Overview of Reporting Web Studio

Reporting Web Studio is a web-based report authoring solution with a similar look and feel to Windows-based Financial Reporting Studio. Report definitions remain the same for both reporting solutions, so you can edit existing reports using the Windows or web version of Financial Reporting Studio.

You can open Reporting Web Studio from the Enterprise Performance Management System workspace. To get there, start from the Financial Reporting Center work area and click the Open Workspace for Financial Reports task. Then click the Launch Reporting Web Studio menu item from the Tools menu.

Here's an image of the menu items under the Tools menu.

This image shows the Tools menu in the Enterprise
Performance Management System workspace. One of the menu items is
Launch Reporting Web Studio.

This table describes the sections in the Reporting Web Studio interface.

Callout Section in Interface What's in It?

1

Repository

Folders, reports, and a Search toolbar.

2

Summary

Information about an opened report, such as report name and description.

3

Report

Object browser, report objects, design canvas, and report object properties panel. Report objects include grids, text, images, and charts.

4

Design Canvas

Layout for a report.

5

Properties

Attributes for a selected report or report object.

Here's an image of the Reporting Web Studio interface highlighting the key sections described in the table.

This image shows the main interface for Reporting
Web Studio.

For more information about Reporting Web Studio, go to the Oracle Financials Cloud books page on the Oracle Help Center at https://docs.oracle.com. Select the Using EPM with Oracle Financials Cloud link.

How to Manage Financial Reporting Studio Versions

You could run into issues with Financial Reporting Studio reports if the Financial Reporting Studio version on your client is different from the Financial Reporting server version in the application. You must therefore manage the Financial Reporting Studio client version during the course of the regular Oracle Fusion Applications Cloud updates.

Using Financial Reporting Studio Between Test and Production Updates

Your test environment is always updated before your production environment.

During this period, the version of the Financial Reporting server on your test environment may be different than the version on your production environment. When this happens, the existing Financial Reporting Studio client currently installed on your computer may not work with your test environment due to the version mismatch between its server and client. Thus, during this period, you must uninstall and reinstall the Financial Reporting Studio client from the test or production environment accordingly, depending on which environment you work on, to ensure the client version matches the server version.

Using Financial Reporting Studio After the Production Update

After the production environment is updated, the Financial Reporting Studio versions for the test and production environments will be the same.

If you already installed Financial Reporting Studio from the test environment, you won't have to make any changes. Otherwise, you should immediately uninstall, download, and reinstall Financial Reporting Studio from the financial reporting workspace in the production environment.

Comparing the Client and Server Versions

To compare the Financial Reporting Studio client version with the Financial Reporting server version, perform the following steps:

  1. Launch Financial Reporting Studio.

  2. From the Help menu, select About Reporting Studio.

  3. Compare the Oracle Hyperion Financial Reporting version with the Report Server Version to confirm that they match.

The following figure shows an example of the Financial Reporting Studio window with matching client and server versions. The Oracle Hyperion Financial Reporting version is 11.1.2.4.505 and the Report Server Version is 11.1.2.4.560.0505.

This figure shows the page that displays when you
select About Reporting Studio from the Financial Reporting Studio
Help menu.

You can also check the server version from the Help menu of the financial reporting workspace.

  1. From the Financial Reporting Center, select the Open Workspace for Financial Reports task.

  2. From the Help menu, select About Oracle Enterprise Performance Management System Workspace.

  3. Click Show Details.

The following figure shows an example of the Enterprise Performance Management System Workspace window with the report server version.

This figure shows the page that displays when you
select About Oracle Enterprise Performance Management System Workspace
from the Help menu in the financial reporting workspace.

Installing Financial Reporting Studio

Perform the following prerequisite steps:

  1. Uninstall the previous version, if any, using the Windows Control Panel.

  2. Delete the existing directory structure. For example, C:\Oracle\Middleware\EPMSystem11R1\products\FinancialReportingStudio.

  3. Restart your computer.

Download the version of the Financial Reporting Studio from that environment's workspace:

  1. Navigate to the Financial Reporting Center and select the Open the Financial Reporting Workspace task.

  2. From the menu, select Tools > Install > Financial Reporting Studio and save the file.

  3. Right-click the executable file and select Run as administrator.

    Caution: Don't close the command window that appears near completion. It will automatically close itself.

    The following figure shows an example of the command window that appears while the executable file is running.

    This figure shows the command window, which automatically
closes.
  4. Click Finish on the install window after the command window closes.

Lastly, when designing reports, you can't design a Financial Reporting Studio report using a client version that's higher than the report server version, and then export or import the report to a lower client version level. The report may not work.

How Financial Reporting Reports and Account Groups Are Generated

Use the Generate Financial Reports and Account Groups process to create Financial Reporting reports and account groups for each general ledger balances cube for a specified chart of accounts and accounting calendar.

You can submit the process at any time.

How the Reports and Account Groups Are Generated

Submit the Generate Financial Reports and Account Groups process from the Scheduled Processes work area. Select the chart of accounts and accounting calendar, which identify the balances cube and ledgers for which to generate the Financial Reporting reports and account groups.

Specify values for the top parent revenue and expenses account:

  • Top Revenue Account

  • Top Operating Expenses Account

  • Top Cost of Sales Account (optional)

The top parent accounts are used as the basis for deriving the accounts referenced in the reports. The immediate descendants of the top parent accounts are used to define the rows on the Financial Reporting income statement reports. Depending on whether both the top operating expenses and top cost of sales accounts are selected, different variations of the Financial Reporting income statements are generated. If the optional top cost of sales account is provided, the income statements Financial Reporting income statement reports also include a gross margin section.

Tip: You can pick a specific tree and tree version for each parent. All three parent account values can be from different trees and tree versions. Ideally, you would choose a common tree and tree version for all of the parent accounts. The hierarchy basis for all of the rows in the generated reports is then consistent.

For the balances cube identified by the chart of accounts and calendar in the request submission, the process creates an individual set of the following Financial Reporting reports:

  1. Income Statement

  2. Consolidated Income Statement

  3. Rolling Quarterly Income Statement

  4. Rolling Monthly Income Statement

  5. Trial Balances by Ledger Currency

  6. Trial Balances by Entered Currency

Note: To prevent the unnecessary proliferation of such Financial Reporting reports, unless the original reports created were renamed or deleted, resubmitting the process doesn't generate new Financial Reporting reports.

The process also generates the following three account groups for the balances cube, to be shared among all of the ledgers that are part of that balances cube:

  • Revenues: Defined to display in the Revenues infolet. Automatically set as the default for the General Accounting Infolets home page unless an existing account group is already set as the default.

  • Expenses: Defined to display in the Expenses infolet. Automatically set as the default for the General Accounting Infolets home page unless an existing account group is already set as the default.

  • Close Monitor Summary Income Statement: Defined to display in the Close Monitor. Can be assigned to your ledger sets when you complete the Close Monitor setup.

Note: A new set of account groups is generated for a balances cube with each submission of the process.

Create a Financial Report

In Oracle Hyperion Financial Reporting Studio, you can design traditional financial report formats such as balance sheets, profit and loss statements, and cash flow reports. You can also design nontraditional reports for financial or analytic data that include text and graphics. Use Financial Reporting Studio, a client-based application launched from your desktop, to create your reports.

In this example, you define a basic income statement. This is the first in a series of six tasks on creating a financial report.

  1. Open Financial Reporting Studio on your desktop and sign in with your user name, password, and server URL.

    Tip: The first time you sign in, copy the Financial Reports Workspace URL into the Server URL field and remove workspace/index.jsp from the end of the URL.

    The following figure shows an example of the Financial Reporting Studio sign-in window, with the user name, password, and server URL fields populated.

    This figure shows the sign-in window for Financial
Reporting Studio with an example of sign-in information.
  2. On the Standard toolbar, click the New Report icon. The report designer opens.

  3. On the Designer toolbar, click the Insert Grid icon. Grids are tables that contain data from external database connections.

  4. Drag to select the area for the grid. The Select a Database Connection window opens.

    Tip: When creating a grid, best practice is to leave space in the designer area for other objects, such as a company logo and report title.
  5. On the Select a Database Connection window, click the Database Connection list and select your database. A unique cube exists for each combination of chart of accounts and accounting calendar.

    The following figure shows an example of the Select a Database Connection window, with the connection, user name, and password fields populated.

    This figure shows the database connection window
with example values for the fields.
    Tip: Best practice is to always turn on suppression in financial reports. This should be done at the Database Connection Server level. You can verify the setting by doing the following: highlight the grid, and from the menu, select Task > Data Query Optimization Settings. The normal best practice for most reports is to turn suppression on for the entire grid, and then turn suppression off for certain columns and rows that must always display.

    For more information about suppression settings, refer to the Using the Basic Option in Conditional Suppression section in the Designing with Financial Reporting Studio for Oracle Planning and Budgeting Cloud guide at http://docs.oracle.com/cloud/latest/epm-common/CSFSU/ch09s04s02.html#BEGIN.

  6. Click OK. The Dimension Layout window opens.

Arrange Dimensions and Define Rows

Use the Dimension Layout window to arrange the dimensions on the report. Use the Select Members window to select the revenue and expense accounts to include on the report.

  1. On the Dimension Layout window, drag the dimensions from the Point of View frame as follows:

    1. Accounting Period dimension to the Columns frame.

    2. Account dimension to the Rows frame.

    3. Company dimension to the Pages frame.

    The following figure shows the Dimension Layout window. The Company dimension is in the Pages frame, the Accounting Period dimension is in the Columns frame, and the Account dimension is in the Rows frame.

    This figure shows the Dimension Layout window for
the report.
  2. Click OK. The Dimension Layout window closes. The grid is inserted with the specified layout.

  3. Select the revenues account.

    1. Double-click the Account cell on the grid. The Select Members window opens.

    2. Click the Remove All icon to deselect the default account member.

    3. In the Available area, expand the Account member, and continue expanding until you reach the revenue account for the report. You can also use the search to find your account.

    4. Select the account and click the Add icon to move the account to the Selected area.

      The following figure shows the Select Members window for the Account dimension. The Account member is expanded and the revenues account for the report, which is 40000, appears in the Selected area of the window.

      This figure shows the Select Members window with
the Account dimension member expanded to the revenues account, which
has been selected.
  4. Click OK. The Select Members window closes.

  5. Save the report.

    1. From the File menu, select Save As.

    2. Select the My Folders directory and enter a report name.

    3. Click Save.

  6. Insert a blank row to add space between the revenue and expense accounts.

    1. Select the row after the revenues account and right-click the row header.

    2. From the Insert Row menu, select Text.

  7. Insert a row for the expense accounts.

    1. Select the row after the new blank row and right-click the row header.

    2. From the Insert Row menu, select Data. The default value for the new row contains the revenue account.

  8. Select the expense accounts.

    1. Double-click the new expense account cell in row 3. The Select Members window opens.

    2. Click the Remove All icon to deselect the default revenues account.

    3. In the Available area, expand the Account member, and continue expanding until you reach the expense accounts.

    4. Select the accounts and click the Add icon to move the accounts to the Selected area.

    5. Select the Place selections into separate rows option to create a separate row in the grid for each account.

      The following figure shows the Select Members window for the Account dimension. The Account member is expanded and the expense accounts for the report appear in the Selected area of the window. The selected accounts are 50000, 60000, and 70000. The option called Place selections into separate rows is selected.

      This figure shows the Select Members window with
the Account dimension member expanded to the expense accounts, which
have been selected.
  9. Click OK. The grid now includes the expense accounts.

  10. Save the report and leave it open for the next task, which is adding a formula to financial report.

  11. You can preview the report in HTML or PDF format using the File menu or toolbar.

Add a Formula to a Financial Report

In this example, you define a formula to summarize expense account balances on a financial report. This task is the second in a series of six tasks on creating a financial report.

Before you start, do the steps described in the Define a Basic Financial Report topic, then follow these steps.

  1. Select the row after the last expense account row and right-click the row header.

  2. From the Insert Row menu, select Formula.

  3. Click in the empty cell in the new row. The cell properties sheet opens.

  4. On the cell properties sheet, select the Custom Heading option and enter Total Expenses.

  5. Select the row header for the formula row, which in this example is row 6.

  6. In the Formula bar, click the Sum(0) button to enter the formula into the formula text box.

  7. Enter the cell references for the expense accounts into the formula, between the parentheses. In this example, the completed formula is Sum([3], [4], [5]).

    This image shows the Financial Reporting Studio window with the formula entered in the formula text box.

    This image shows the Financial Reporting Studio
window with a formula to sum the three expense rows.
  8. Validate the formula syntax by clicking the check mark icon in the toolbar. Validation checks the validity of the formula, not if data is available.

    This image shows an example of the grid with the revenue account in row 1, expense accounts in rows 3 through 5, and total expenses in row 6.

    This image shows the grid after defining the formula
for total expenses.
  9. Save the report and leave it open for the next task, which is defining a range function. Optionally preview the report.

Define a Range Function for a Financial Report

In this example, you define a range function to report across periods and create rolling period columns on a financial report. This task is the third in a series of six tasks on creating a financial report.

Before you start, do the steps described in these topics.

  1. Define a Basic Financial Report

  2. Add a Formula to a Financial Report

Now follow these steps.

  1. Double-click the Accounting Period cell. The Select Members window opens.

  2. Click the Remove All icon to deselect the default accounting period member.

  3. Click the Functions tab.

  4. Click the Range list item.

  5. Click the Add icon to move the Range list item to the Selected area. The Edit Range Function window opens.

    1. Click in the Value field on the Start Member row.

    2. Click the Lookup icon. The Edit Start Member Parameter Value window opens.

    3. Click the Functions tab.

    4. Click the Relative Member list item. With the relative member parameter, you can define the periods that display on the report relative to the period you specify at runtime.

    5. Click the Add icon to move the Relative Member list item to the Selected area. The Edit Relative Member Function Window opens.

    6. Click in the Value field on the Member row.

    7. Click the Lookup icon. The Edit Parameter Value window opens.

    8. Click the Current Point of View list item, so you can enter the starting period for the report.

      This image shows the Edit Member Parameter Value window for the Accounting Period member. The Current Point of View row is selected.

      This image shows the Edit Member Parameter Value
window for the Accounting Period member.
    9. Click the Add icon to move the selected value to the Selected area.

    10. Click OK. The Edit Member Parameter Value window closes.

    11. On the Edit Relative Member Function window, select the Offset parameter, and enter -11 in the Value field. The offset value determines the number of periods to include from the current point of view.

      This image shows the Edit Relative Member Function window. The Offset parameter is selected and the value entered is -11.

      This image shows the Offset parameter on the Edit
Relative Member Function window.
    12. Click OK. The Edit Relative Member Function window closes.

    13. Click OK. The Edit Start Member Parameter Value window closes.

  6. On the Edit Range Function window, click the End Member list item.

  7. Click in the Value field and click the Lookup icon. The Edit End Member Parameter Value window opens.

    1. Click the Current Point of View list item.

    2. Click the Add icon to move the value to the Selected area.

    3. Click OK. The Edit End Member Parameter Value window closes.

  8. Click OK. The Edit Range Function window closes.

  9. Click OK. The Select Members window closes.

  10. Save the report and leave it open for the next task, which is defining a grid point of view. Optionally preview the report.

Define a Grid Point of View for a Financial Report

In this example, you define dimensions for the grid point of view on a financial report. The grid point of view ensures the same initial default value every time for every user. This task is the fourth in a series of six tasks on creating a financial report.

Before you start, do the steps described in these topics.

  1. Define a Basic Financial Report

  2. Add a Formula to a Financial Report

  3. Define a Range Function for a Financial Report

Now follow these steps.

  1. Select the grid.

  2. Right-click and select Grid Point of View from the list.

  3. On the grid, click the Ledger: User Point of View for Ledger tab. The Select Members window opens.

    1. Expand the Ledger member and continue to expand until you find the ledger to include on the report. Select the ledger.

    2. Click the Scenario tab to select the type of balance to use on the report.

    3. Expand the Scenario member and select the Actual list item.

    4. Click the Balance Amount tab.

    5. Expand the Balance Amount member and select the Period Activity list item as the balance amount to include on the report.

    6. Click the Currency tab.

    7. Expand the Currency member and select USD from the list.

    8. Click the Currency Type tab.

    9. Expand the Currency Type member and select the Entered list item.

    10. Click OK. The Select Members window closes.

      This image shows the grid after defining the grid point of view. The grid is selected and the Ledger dimension is set to the US Primary Ledger. The Accounting Period dimension is set to User Point of View. Column A is defined as a range, row 1 represents revenue, rows 3 through 5 represent expense accounts, and row 6 represents total expenses.

      This image shows the grid with the grid point of
view set for the Ledger dimension.
  4. Save the report and leave it open for the next task, which is setting page and grid properties.

Set Page and Grid Properties for a Financial Report

In this example, you set the page and grid properties for a financial report. This task is the fifth in a series of six tasks on creating a financial report.

Before you start, do the tasks described in these topics.

  1. Define a Basic Financial Report

  2. Add a Formula to a Financial Report

  3. Define a Range Function for a Financial Report

  4. Define a Grid Point of View for a Financial Report

Now follow these steps.

  1. Select the grid.

  2. Right-click and select Grid Point of View Setup. The Setup Grid Point of View window opens.

    1. For the Balance Amount dimension, set the Report Viewers May Select option to Nothing, Lock Member Selection. This step prevents the Balance Amount type from being changed at runtime.

    2. Click OK. The Setup Grid Point of View window closes.

  3. Set a runtime prompt for the Company dimension to provide the flexibility of selecting any company or combination of companies at runtime.

    1. On the grid, double-click the Pages label. The Select Members window opens.

    2. Click the Remove All icon to deselect the default Company member.

    3. Select the Prompt for Company list item.

    4. Click the Add icon to move the selection to the Selected area.

    5. Click OK. The Define Prompt window opens.

    6. Click the Lookup icon in the Default Member field. The Select Members window opens.

    7. Click the Remove All icon to deselect the default Company member.

    8. Expand the Company member, and continue expanding until you find and select the default companies to display in the prompt.

    9. Click the Add icon to move the companies to the Selected area.

    10. Click OK. The Select Members window closes.

    11. Click the Member Labels in Prompt Selection Dialog list and select the Alias list item. The actual company label displays in the prompt list of values instead of a numeric company value, making the prompt more user-friendly.

      This image shows the Define Prompts window for the Company dimension. The default members are companies 101 and 102, and the prompt for member labels is set to Alias.

      This image shows the Define Prompts window.
    12. Click OK. The Define Prompts window closes.

  4. On the Grid Properties sheet:

    1. Click the Drill Through option to enable drill through from the report to the detail balances represented on the report.

    2. Click the Suppression list item to view the suppression settings.

    3. Enter 0 in the Zero Values field to suppress the display of zero dollar rows on the report.

      This image shows the Grid Properties sheet with the Zero Values text option set to 0.

      This image shows the suppression settings on the
Grid Properties sheet.
  5. Click the Pages label on the grid. If the Page Properties sheet doesn't open, select Property Sheet from the View menu.

    1. On the Page Properties sheet, click the Alias: Default option.

  6. Click the first cell in row 1. The Heading Row Properties sheet opens.

    1. Click the Alias: Default option to show the name of the account rather than the account value.

    2. Click the Allow Expansion option to enable the expand functionality on the report.

    3. Select the cells for the expense accounts on the grid, and on the Heading Row Properties sheet, select the Alias: Default and Allow Expansion options.

  7. Save the report and leave it open for the next task, which is formatting your financial report and adding a graph. Optionally, preview the report.

Format a Financial Report and Add a Graph

In this example, you insert a company logo and add a title and chart to a financial report. Then you run the report. This task is the sixth and final task in a series on creating a financial report.

Before you start, do the steps described in these topics.

  1. Define a Basic Financial Report

  2. Add a Formula to a Financial Report

  3. Define a Range Function for a Financial Report

  4. Define a Grid Point of View for a Financial Report

  5. Set Page and Grid Properties for a Financial Report

Now follow these steps.

  1. On the Designer toolbar, click the Insert Image icon.

    1. Drag and drop the cursor over the report to determine the length and width of the image. You can adjust the header height setting on the Report Properties sheet and the grid object, as needed. Keeping the report header narrow improves the PDF output.

    2. Find the company logo in your file system and select it.

  2. On the Designer toolbar, click the Insert Text icon.

    1. Drag the cursor over the report to determine the length and width of the report title.

    2. Enter a report title.

    3. Select the text, and from the Format menu, select Cell. The Format window opens.

    4. Set the font style to Bold and the size to 14.

    5. Click OK.

    6. On the Designer toolbar, select the Center Justify icon to center the text.

  3. From the File, menu, select Page Setup. Click the Page tab and set the orientation to Landscape.

  4. Click OK.

    This image shows the Financial Reporting Studio designer window with a company logo, a report title of Income Statement by Period, and a grid with account rows and an accounting period column.

    This image shows an example of an income statement
report in the Financial Reporting Studio designer.
  5. On the Designer toolbar, click the Insert Chart icon.

    1. Drag and drop the cursor over the area to determine the length and width of the chart.

    2. On the Chart Properties sheet, select the Line chart type and select the expense account rows in the Data Range section.

    3. Click the Format Chart button. The Format Chart window opens.

    4. On the Appearance tab, enter a title for the chart.

    5. Click the Legend tab and enter a title for the legend.

    6. Click the Axes tab and enter a title for the primary axis.

    7. Click the Element Style tab and set the attributes for the data sets, as needed.

    8. Click the Refresh icon to preview the chart on the Format Chart window.

      This image shows the Element Style tab on the Format Chart window. The title of the chart is Expenses by Month. The legend is titled Type of Expense. The primary axis is titled Dollars.

      This image shows the Element Style tab on the Format
Chart window.
    9. Click OK. The Format Chart window closes.

  6. Save the report.

You can preview the report in Financial Reporting Studio using the File menu or toolbar, and you can run your report from the Financial Reporting Center.

This image shows an example of an income statement report run from the Financial Reporting Center. The report has a logo and title. The grid point of view includes the ledger, scenario, balance amount, currency, and currency type dimensions. The company dimension is at the page level. Twelve accounting periods appear as columns and the revenue and expense accounts appear as rows. The chart displays expenses by month.

This image shows an example income statement by
period.

For more information about Financial Reporting Studio, refer to the Using EPM with Oracle Financials Cloud link on the Books for Oracle Financials Cloud page of the Oracle Help Center at https://docs.oracle.com.

Configuration of an account group enables you to create self-monitoring accounts that help you eliminate the surprise of account anomalies during your close process.

Scenario

You have been given the task to set up account groups. Follow these steps to define account groups that track key account balances by purpose, category, and comparison criteria.

  1. Navigate to the General Accounting Dashboard page.

  2. In the Account Monitor section, select View > Account Group > Create. Other Account Group options include:

    • Manage to create, edit, or delete account groups. You can also enable sharing of account groups with other users.

    • Edit to change an existing account group or to make a copy of an existing account group to which you have access, whether it's an account group that you own, that's shared with you, or that's public. You're marked as the owner of the copied account group, which is automatically set to private access, but can be changed to the access setting that you like.

  3. Enter the account group name and description. The name is used by default on the infolet that the account group displays in, but can be changed using the infolet Actions menu.

  4. Select a value for the Display In option to determine if the account group appears in one of the infolets (Allocations, Expenses, Revenues), the Account Monitor, or the Close Monitor. The display option that you select can affect the other account group settings. For example, account groups that display in the Close Monitor must have public access, and account groups that display in infolets must have the option to dynamically derive the ledger enabled.

    Note: Regardless of its display setting, any account group can be viewed from within the Account Monitor and Financial Reporting Center.
  5. For each infolet and Account Monitor display setting, you can specify a default account group by selecting the Set as default option. The default account group setting is user-specific, determining which account groups appear to you when you view the infolets and the Account Monitor.

    Note: The default setting doesn't affect account groups that are set to display in the Close Monitor. The account group that displays in the Close Monitor is determined by the ledger set definition.
  6. Select the Dynamically derive ledger option to apply the account group to any ledger in the same balances cube. The ledger derived is based on your given data access set selection. You must enable this option for account groups that display in the Revenues, Expenses, and Allocations infolets.

    Note: If you don't select this option, enter a ledger on each account row.
  7. Select a Time Option and Comparison Option as shown in the following table.

    Time Option Comparison Option

    Accounting Period

    • Budget PTD

    • Budget QTD

    • Budget YTD

    • Prior period PTD

    • Prior year PTD

    • Prior year QTD

    • Prior year YTD

    Quarter

    • Budget QTD

    • Budget YTD

    • Prior quarter QTD

    • Prior year QTD

    • Prior year YTD

    Year

    • Budget YTD

    • Prior year YTD

    Tip: If you're using a budget comparison option, select the budget name in the Scenario field.
  8. Set the access.

    Note: Regardless of the access setting, only the person who owns the account group can modify it. However, for account groups that you have access to, you can share with others even if you're not the owner.
    • Private: For your use only.

    • Public: For use by all users who have access to the same balance cube of that account group. Account groups that display in the Close Monitor must be set to Public.

    • Shared: For use by users you specify and who have access to the same balance cube of that account group.

      Note: To set shared access, navigate to the Manage Account Group page.
  9. In the Accounts section, enter the accounts to monitor. The accounts must be defined to be consistent with the particular infolets targeted to track revenues, expenses, or allocations pools.

    • Accounts included in an account group for display in the Expenses infolet must be of the account type Expense.

    • Accounts included in an account group for display in the Revenues infolet must be of the account type Revenue.

    • Close Monitor account groups must only have two account rows. The first row must represent total revenues and the second row must represent total expenses.

    1. Give each account a short name that's easily recognizable. The name displays in infolets and in the Name column of the Account Monitor. For account groups that display in infolets, you must provide a name for each account.

    2. If the Dynamically Derive Ledger option isn't enabled, you must enter a ledger.

    3. Enter either parent or child values for each segment of the account.

    4. Select when to display the account in the Change field.

      • Always Display

      • Decrease by Less than Amount

      • Decrease by Less than Percentage

      • Decrease by More than Amount

      • Increase by More than Amount

      • Increase by Less than Amount

      • Increase by Less than Percentage

      • Increase by More than Percentage

      • Decrease by More than Percentage

      • Not Equal

      • Equal

    5. Enter a value in the Threshold field, which is the criteria that's being measured against. The threshold is used in conjunction with the Change field selection.

  10. Click Save and Close or Save and Create Another.

General Ledger Subject Areas, Folders, and Attributes

To create real-time analyses for General Ledger, you should be familiar with subject areas, folders, and attributes.

Subject Areas

To create an analysis, you begin by selecting a subject area from which you select columns of information to include in the analysis. For example, to create an analysis of journal information, you begin by selecting a General Ledger - Journals Real Time subject area. Subject areas are based around a business object or fact. In this example, the subject area is based on the columns in the journal tables.

General Ledger has four general ledger-specific subject areas:

  • General Ledger - Balances Real Time

  • General Ledger - Journals Real Time

  • General Ledger - Period Status Real Time

  • General Ledger - Transactional Balances Real Time

Tip: To create a report that queries balances and allows drill down to journals, use the General Ledger - Transactional Balances Real Time and the General Ledger - Journals Real Time subject areas. Other than that, it's advised that you don't create reports that cross subject areas. Such reports may result in less than optimal performance and are hard to maintain.

Folders

Each subject area has one fact folder and a number of dimension folders. Fact folders contain attributes that can be measured, meaning that they're numeric values like journal debit and credit amounts. Fact folders are usually listed after dimension folders and are usually named after the subject area. Dimension folders contain attribute and hierarchical columns like journal name and accounting period.

Some folders appear in more than one subject area, such as Time. These are referred to as common folders or common dimensions.

Each folder within a subject area may have a different level of granularity. For example:

  • Journal Approval has approval attributes.

  • Journal Batches has subfolders with attributes.

Attributes

Finally, each dimension folder contains attributes (columns), such as balance type and posting date. This figure illustrates the structure of subject areas, folders, and attributes.

The following figure shows the General Ledger - Journals Real Time subject area. The subject area contains these folders: Approval Status, Journal Batches, Journal Headers, Journal Lines, Posting Status, Time.

The Approval Status folder is a Dimension - Presentation folder and contains these dimension attributes: Approval Status Code, Approval Status Description, Approval Status Meaning. The Lines folder is a Fact - Presentation folder and contains these measures: Accounted Credit, Accounted Debit, Entered Credit, Entered Debit, Statistical Quantity.

This figure shows the General Ledger - Journals
Real Time subject area and its folders.

FAQs for Financial Reporting

How can I apply permissions to objects from Financial Reporting in Workspace?

Open the Permission dialog box from the Tasks list to set permissions for a catalog object. Permissions determine which user, group, or role can view, open, or modify the object. If you display this dialog box while working in the catalog in Workspace, any permission changes that you specify are applied immediately. If you display this dialog box as part of the Batch Scheduler wizard, then the permission changes are not applied until you run the batch.

How can I store and edit Financial Reporting objects?

First installed Oracle BI EE as part of Oracle Fusion Applications. Then store and edit new objects that you create for Oracle Hyperion Financial Reporting in Workspace in the Oracle BI Presentation Catalog. Perform operations on those objects in the catalog similarly to how you work with other objects, such as copying and modifying properties. See the documentation for Hyperion Financial Reporting for complete information on working with objects. Financial Reporting report designers can also access the Financial Reporting objects in the Financial Reporting Studio.

You can export your financial reports from a source environment and import them to a target environment using implementation projects.

Only the financial reports in the /shared/Custom/Financials folder are exported, so make sure to copy all the financial reports, or the folders containing them, to this folder. In the Setup and Maintenance work area, create an implementation project that includes only the Create Financial Statements task. Then use the Manage Configuration Packages task to export and import the reports.

Note: For the Financial Reporting report definition migration service, from a source to a target environment, references to version IDs of dimension members hierarchies are synchronized to their version IDs in the target environment.