4Financial Reporting

This chapter contains the following:

Overview of Financial Reporting Configuration

Configure the following financial tools to report and analyze your accounting data: Financial Reporting Center, Smart View, Financial Reporting Studio, and Workspace.

The Financial Reporting Center is intended to be the primary user interface for financials end users to access all seven report types.

Financial Reporting Center

The Financial Reporting Center includes these report types: Financial Reporting Studio Reports, Account Groups and Sunburst, Smart View Reports, Oracle Transactional Business Intelligence Analyses, Oracle Transactional Business Intelligence Dashboards, Oracle Business Intelligence Publisher Reports, and Business Intelligence Mobile Apps. Other reporting tools are also available to run the same seven report types.

The following figure illustrates the report types that are available in the Financial Reporting Center.

This figure shows the report types that are available
in the Financial Reporting Center. In the Enterprise Performance Management
Workspace, reports can be created from General Ledger balances cubes
and Oracle transaction tables.

Reports can be accessed through various methods. However, the Financial Reporting Center provides access to every type of report, is intended to be the primary user interface for financials end users, and is tablet and smartphone friendly. In addition to accessing reports, you can add favorites, define tags, and view report details, such as type and last updated date.

Financial Reports are read from the Shared > Custom > Financials and My Folders directories. All other report types can be saved anywhere in the BI Catalog however, any user-defined content should be in the Shared > Custom folder. Subfolders can be created within the Shared > Custom folder.

Seven types of reports can be run from the Financial Reporting Center and from the other reporting tools.

  • Financial Reports: These reports are built off of the Oracle Financial Reporting Studio using data in the Oracle Fusion General Ledger balances cube. For example, company income statements and balance sheets. These reports are mainly run by users in General Ledger.

  • Account Groups and Sunburst: Account groups are used to monitor key accounts in General Ledger. When a user creates an account group, it becomes visible in the Financial Reporting Center with the Sunburst visualization tool. The Sunburst visualization tool lets you interact with your account balances across various business dimensions to view balances from different perspectives. Account groups are used only in General Ledger.

  • Smart View Reports: Smart View is a multidimensional pivot analysis tool combined with full Excel functionality. Smart View enables you to interactively analyze your balances and define reports using a familiar spreadsheet environment. These queries are mainly for users in General Ledger. To share Smart View queries, users can email them to other users, or they can upload the queries to the Financial Reporting Center where users can download them to a local drive for use. The Financial Reporting Center is only a place for users to upload and download Smart View queries.

    Note: To upload a Smart View report to the Financial Reporting Center: select the Open Workspace for Financial Reports task, navigate to the BI Catalog, and select Upload from the Tasks section. Be sure to upload the Excel file to one of the folder locations mentioned previously.
  • Oracle Transactional Business Intelligence Analyses: These analyses and reports are built off of transactional tables using subject areas. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • Oracle Transactional Business Intelligence Dashboards: Dashboards put all the information, functions, and actions that a business user must have to do their job in one place. Dashboards are built off of Oracle Transactional Business Intelligence objects like analyses and reports. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • Oracle Business Intelligence Publisher Reports: Most of these reports are predefined and must first be submitted and resubmitted to see the latest data by the Oracle Enterprise Scheduler through the Scheduled Processes navigation. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • BI Mobile Apps: Oracle Business Intelligence Mobile App Designer is an application that enables you to create multitouch information-driven applications with rich interaction, rich visualization, and rich media, for mobile devices such as iPhone, iPad, Android phone, tablet, and more. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

Other Reporting Tools

Six other tools are available for reporting in Financials.

The following table lists the other reporting tools and the types of reports they support.

Other Reporting Tools Report Type

General Accounting Dashboard and Account Inspector

Account Groups

Reports and Analytics

Oracle Transactional Business Intelligence Objects

BI Catalog

All Report Types, Except Oracle Business Intelligence Publisher Reports

Enterprise Performance Management Workspace

Reports, Books, Snapshot Reports, Snapshot Books, Financial Reporting Batches, and Batch Scheduler

Enterprise Scheduler System

Oracle Business Intelligence Publisher Reports

Even though the Financial Reporting Center is designed to be the main user interface for a financial end user's reporting needs, some users may choose to use any of the six other tools for reporting in financials, such as:

  • General Accounting Dashboard, which provides access to Account Groups: Uses the Account Monitor to efficiently monitor and track key account balances in real time.

  • Account Inspector: Perform ad hoc queries from account groups and financial reports through drill down to underlying journals and subledger transactions.

  • Reports and Analytics: This reporting tool has a panel that reflects the folder structure of the BI Catalog. Users can access and run any Oracle Transactional Business Intelligence analysis, report or dashboard. Users can't run Financial Reports or Oracle Business Intelligence Publisher reports from this interface. This interface can be used by all financials users.

  • BI Catalog: A component of the Enterprise Performance Management Workspace where you can run all report types, except for Oracle Business Intelligence Publisher reports.

  • Enterprise Performance Management Workspace: Create reports, books, snapshot reports, snapshot books, Financial Reporting batches, and batch scheduler, and schedule batches to automatically run and burst to email.

  • Enterprise Scheduler System: Only Oracle Business Intelligence Publisher reports can be submitted from this interface. Users access this interface by navigating to Tools > Scheduled Processes. Most financial users have access to this interface to run standard reports for General Ledger, Payables, Receivables, and so on.

Create a Folder from the Financial Reporting Center

The Financial Reporting Center is a tool for accessing, designing, and presenting financial reports and analytic data.

Configure Financial Reporting Center

You have access to reports through the folder structure in the Financial Reporting Center and Workspace that's installed with Oracle Fusion Financials. Your Oracle Fusion Business Intelligence (BI) administrator defines the folder structure in Workspace your company's security requirements for folders and reports, as well as report distribution requirements for financial reporting batches.

Security can be set on folders and reports from Workspace. The BI Catalog stores both the Financial Reports and the BI Publisher Reports. Your BI administrator grants access to the folders and reports that you need.

Create and Secure a Folder Structure

To create a folder or subfolder:

  1. From the Financial Reporting Center, open the Tasks pane and click the Open Workspace for Financial Reports task.

  2. From the Navigate menu, select Applications, then BI Catalog.

  3. On the Oracle BI Catalog page, go to the location in the Folders panel where you want to create the folder.

  4. In the Oracle BI Catalog toolbar, click New and select Folder.

  5. On the New Folder window, enter the folder name.

  6. Click OK.

To assign permissions to a folder:

  1. From the Financial Reporting Center, open the Tasks pane and click the Open Workspace for Financial Reports task.

  2. From the Navigate menu, select Applications, then BI Catalog.

  3. Search for the folder to which you want to assign permissions.

  4. Go to the Tasks panel and click Permissions.

  5. On the Permissions window, click the Add user or roles icon.

  6. On the Add Application Roles, Catalog Groups and Users window, query the roles and select the ones you want to add.

  7. Click the Move button.

  8. Set the permission to the intended level, for example, Full Control.

  9. Click OK.

Configure Smart View Client for Users

Smart View is a multidimensional pivot analysis tool combined with full Excel functionality. Smart View enables you to interactively analyze your balances and define report using a familiar spreadsheet environment.

Install Smart View, an add-in to Excel, to each client computer. To download the installation files:

  1. Navigate to the Financial Reporting Center and select the Open Workspace for Financial Reports task.

  2. In the Enterprise Performance Management System Workspace, select Tools > Install > Smart View.

Note: Since Smart View is an add-in to Microsoft Office products, you can install Smart View only on a Windows operating system.

Once Smart View is installed, you must configure the connection using the Smart View Shared Connections URL. You can derive the Shared Connections URL by following these steps:

  1. From the Financial Reporting Center task panel, select Open Workspace for Financial Reporting.

  2. Edit the workspace URL by removing index.jsp and adding SmartViewProviders at the end.

    Note: The following URL is an example for a Cloud-based environment. If the workspace URL is https://efops-rel5st4-cdrm-external-bi.visioncorporation.com:10622/workspace/index.jsp, the Shared Connections URL is https://efops-rel5st4-cdrm-external-bi.visioncorporation.com:10622/workspace/SmartViewProviders.
  3. Copy the URL.

  4. Open Excel.

  5. Navigate to the Smart View menu > Options

    The following figure shows the Smart View ribbon on the Excel spreadsheet. The task lists include Panel, Connections, and Options.

    This figure shows the Smart View ribbon and task lists.
  6. Click the Options button and select the Advanced option.

    The following figure shows the Options window with the Advanced option selected. The shared connections URL appears in the General section.

    This figure shows the Advanced options window.
  7. Paste the URL in the Shared Connections URL field.

  8. Click OK.

For more information about configuring the Smart View client for users, see the Oracle Smart View for Office User's Guide.

To connect to Oracle Fusion General Ledger Balances cubes in Smart View:

  1. Start Smart View.

  2. Click the Smart View tab and select the Panel icon. The Smart View pane opens.

  3. Click the Shared Connections button on the task pane.

  4. Sign in with your user name and password.

    The following image shows the Sign In window for connecting to the database.

    This image shows the Sign In window.
  5. Click the Select Server list icon to proceed.

    The following figure shows the Shared Connections section on the Smart View panel. The Select Server to proceed field is selected and two values appear in the drop-down list: Oracle Essbase, Oracle Hyperion Financial Reporting.

    This figure shows the Shared Connections section on the
Smart View panel.
    Note: If the Essbase Server isn't there, then it has to be added. Use the following steps:
    1. Click the Add Essbase Server link.

    2. Specify the Essbase Server login and password.

    3. Expand the Essbase server and locate its cube.

  6. Select Oracle Essbase from the list of shared connections.

  7. Click the Expand to expand the list of cubes.

  8. Expand your cube that has the name of your chart of accounts.

    The following figure shows the Shared Connections section on the Smart View panel. The Oracle Essbase server is expanded, showing several cubes.

    This figure shows the Smart View panel and the expanded
Oracle Essbase server.
  9. Click db. A list of functions appears.

  10. Click the analysis link.

Note: You must perform these steps only once for a new server and database.

To set how the name and alias of the Essbase database appears:

  1. On the Smart View ribbon, click the Options button.

  2. Select Member Options from the list and select the Member Name Display list.

  3. You can select from among the following options:

  • Distinct Member Name: Only shows the full Essbase distinct path.

  • Member Name and Alias: Shows both the member name and the alias.

  • Member Name Only: Shows only the member name.

Note: The Smart Slice feature isn't supported in General Ledger. For all other documentation, refer to the Oracle Smart View for Office User's Guide.

Configure Financial Reporting Studio Client for Users

Oracle Hyperion Financial Reporting Studio is client-based software tool used for authoring financial reports. Prerequisites needed for installing the Financial Reporting Studio are:

  1. Financial Reporting Studio Client Certifications found at: http://www.oracle.com/technetwork/middleware/bi-foundation/hyperion-supported-platforms-085957.html.

  2. The end user's computer requires Microsoft Office installations.

You connect to the Financial Reporting Studio by downloading the installation files to your computer from Workspace. Follow this path:

  1. Navigator > Financial Reporting Center > Open Workspace for Financial Reports.

  2. In Workspace: Tools > Install > Financial Reporting Studio.

After performing the prerequisites and completing the installation, launch the Financial Reporting Studio. You must provide your user ID, password, and the Server URL. Derive the Server URL information by following the steps:

  1. Open Navigator > Financial Reporting Center > Open Workspace for Financial Reports.

  2. Edit the Workspace URL and remove workspace/index.jsp.

  3. Two examples of Server URLs are:

    • If the Workspace URL is https://fusionsystemtest-p-external-bi.visioncorporation.com/workspace/index.jsp, the Financial Reporting Server URL is https://fusionsystemtest-p-external-bi.visioncorporation.com.

    • If the Workspace URL is https://fusionsystemtest-p-external-bi.visioncorporation.com:10622/workspace/index.jsp, the Financial Reporting Server URL is https://fusionsystemtest-p-external-bi.visioncorporation.com:10622.

  4. Copy the modified URL to the Server URL field.

Note: For end users installing the Oracle Fusion Financials Reporting Studio, the installer launches a separate console window that continues to run for a brief time after the installation completes the setup tasks. The process is normal, expected, and applies to Oracle Hyperion Reporting Studio installations in both the Oracle Fusion Applications and Enterprise Performance Manager modes.

You must save a new report before attempting to preview it with Web Preview.

For more information, see:

  • Oracle Enterprise Performance Management System Installation and Configuration Guide.

  • Oracle Hyperion Enterprise Performance Management System EPM System Standard Deployment Guide.

Define Database Connections in Workspace for Financial Reports

You must create database connections so you can access the cubes from Workspace and Financial Reporting Studio.

Note: Ledger setup has to be completed before the database connection can be created. Oracle Fusion General Ledger balances cubes are created as part of ledger setup. Each combination of chart of accounts and accounting calendar has a separate cube. Each cube needs database connection.

Steps to define a database connection are:

  1. From the Financial Reporting Center work area, open the Tasks panel and select the Open Workspace for Financial Reports task.

  2. From within the workspace, select the Navigate menu > Applications > BI Catalog.

  3. From the Tools menu, select Database Connection Manager.

  4. On the Database Connection Manager window, click New.

  5. Enter a user-friendly name for the database connection name.

  6. Enter Essbase as the Type, your server, user name, and password.

  7. Select Application (cube) and Database from the list of values.

  8. Expand the Application name to see the related database, for example, db.

    The following figure shows the Database Connection Properties window with the completed fields from steps 6 through 9.

    This figure shows the Database Connection Properties
window with field values from the listed steps.
  9. Click OK twice to save your selections.

  10. Click Close to save the connection.

For more information about configuring Essbase database connections in Workspace see: Oracle Essbase Database Administrator's Guide.

Note: The database connection is available in both Workspace and Financial Reporting Studio. Optionally, the database connection can be set up in Financial Reporting Studio while entering the grids on a report.

You can use Financial Reporting Studio to design traditional financial report formats such as balance sheets, profit and loss statements, and cash flow reports. You can also design nontraditional reports for financial or analytic data that include text and graphics.

In this example, you're designing a basic financial report. This topic is the first in a series of six topics on designing a financial report with Financial Reporting Web Studio. Because Financial Reporting Web Studio is web-based, you don't have to download and install an application.

  1. From the Financial Reporting Center work area, select the Tasks panel tab and click Open Workspace for Financial Reports.

  2. On the Tools menu, select Launch Financial Reporting Web Studio.

  3. On the File menu, select New, Report.

  4. On the toolbar, click the Grid icon. Grids are tables that contain data from external database connections.

  5. In the design canvas, draw a box to create the grid. The Database Connection Properties dialog box opens.

    Tip: When creating a grid, best practice is to leave space in the design canvas for other objects, such as a company logo and report title.
  6. Select the Data Sources list and select the data source for the chart of accounts that the report is based on. A unique cube exists for each combination of chart of accounts and accounting calendar.

    Tip: Best practice is to always turn on suppression in financial reports at the Database Connection Server level. You can verify the setting by highlighting the grid, and then selecting Data Query Optimization Settings on the Task menu. For most reports, best practice is to turn on suppression for the entire grid. Then turn suppression off for columns and rows that must always display.

    For more information about suppression settings, refer to the Defining Basic Conditional Suppression section in the Financial Reporting Web Studio User's guide.

  7. Click OK. The Dimension Layout dialog box opens.

Arrange the Dimensions

Use the Dimension Layout dialog box to arrange the dimensions on your report. For this report, the accounting periods display on the columns and the revenue and expense account information displays on the rows. The company appears on each page and can be selected at runtime.

  1. Drag the Accounting Period dimension to the Columns axis.

  2. Drag the Account dimension to the Rows axis.

  3. Drag the Company dimension to the Page axis.

  4. Click OK to close the Dimension Layout dialog box.

Define the Rows

Use the Select Members dialog box to define the revenue and expense account rows.

  1. Select the revenue parent account.

    1. Double-click the Account cell. The Select Members dialog box opens with a default member selected.

    2. Remove the default Account selection from the Selected area by clicking it to select it and then clicking the Remove from Selected icon.

    3. In the Search field, enter the value for the account that represents total revenue and click the Search icon.

    4. Select the account from the search results and click OK. The account moves to the Selected area.

    5. Click OK. The Select Members dialog box closes.

  2. Now insert a text row to add space between the revenue and expense accounts.

    1. Select the last row in the grid by clicking the row header.

    2. On the Insert menu, select Row, then Text.

  3. Insert a row for the expense accounts.

    1. Right-click the last row header.

    2. On the Insert Row menu, select Data. Notice the default value for the new row is the revenue parent account.

  4. Select the expense parent accounts.

    1. Double-click the account value in the new expense account row. The Select Members dialog box opens with the revenue parent account selected.

    2. Remove the revenue parent account selection from the Selected area by clicking to select it and then clicking the Remove from Selected icon.

    3. In the Available area, expand the Account member, and continue expanding until you find the expense parent accounts for the report.

    4. Select the accounts and click the Add to Selected icon to move them to the Selected area.

    5. Select the Place selections into separate rows option so each account appears in its own row on the report.

    6. Click OK. The Select Members dialog box closes.

Save and Preview the Report

Save the report and leave it open for the next topic, which is adding a formula to a financial report.

  1. Click the Save icon.

  2. Select the folder with your name and enter the report name and description.

  3. Click Save.

  4. Optionally preview the report in HTML or PDF format using the File menu or toolbar.