15Financial Reporting

This chapter contains the following:

The Financial Reporting Center is intended to be the primary user interface for financials end users to access all seven report types.

Financial Reporting Center

The Financial Reporting Center includes these report types: Financial Reporting Studio Reports, Account Groups and Sunburst, Smart View Reports, Oracle Transactional Business Intelligence Analyses, Oracle Transactional Business Intelligence Dashboards, Oracle Business Intelligence Publisher Reports, and Business Intelligence Mobile Apps. Other reporting tools are also available to run the same seven report types.

The following figure illustrates the report types that are available in the Financial Reporting Center.

This figure shows the report types that are available
in the Financial Reporting Center. In the Enterprise Performance Management
Workspace, reports can be created from General Ledger balances cubes
and Oracle transaction tables.

Reports can be accessed through various methods. However, the Financial Reporting Center provides access to every type of report, is intended to be the primary user interface for financials end users, and is tablet and smartphone friendly. In addition to accessing reports, you can add favorites, define tags, and view report details, such as type and last updated date.

Financial Reports are read from the Shared > Custom > Financials and My Folders directories. All other report types can be saved anywhere in the BI Catalog however, any user-defined content should be in the Shared > Custom folder. Subfolders can be created within the Shared > Custom folder.

Seven types of reports can be run from the Financial Reporting Center and from the other reporting tools.

  • Financial Reports: These reports are built off of the Oracle Financial Reporting Studio using data in the Oracle Fusion General Ledger balances cube. For example, company income statements and balance sheets. These reports are mainly run by users in General Ledger.

  • Account Groups and Sunburst: Account groups are used to monitor key accounts in General Ledger. When a user creates an account group, it becomes visible in the Financial Reporting Center with the Sunburst visualization tool. The Sunburst visualization tool lets you interact with your account balances across various business dimensions to view balances from different perspectives. Account groups are used only in General Ledger.

  • Smart View Reports: Smart View is a multidimensional pivot analysis tool combined with full Excel functionality. Smart View enables you to interactively analyze your balances and define reports using a familiar spreadsheet environment. These queries are mainly for users in General Ledger. To share Smart View queries, users can email them to other users, or they can upload the queries to the Financial Reporting Center where users can download them to a local drive for use. The Financial Reporting Center is only a place for users to upload and download Smart View queries.

    Note: To upload a Smart View report to the Financial Reporting Center: select the Open Workspace for Financial Reports task, navigate to the BI Catalog, and select Upload from the Tasks section. Be sure to upload the Excel file to one of the folder locations mentioned previously.
  • Oracle Transactional Business Intelligence Analyses: These analyses and reports are built off of transactional tables using subject areas. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • Oracle Transactional Business Intelligence Dashboards: Dashboards put all the information, functions, and actions that a business user must have to do their job in one place. Dashboards are built off of Oracle Transactional Business Intelligence objects like analyses and reports. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • Oracle Business Intelligence Publisher Reports: Most of these reports are predefined and must first be submitted and resubmitted to see the latest data by the Oracle Enterprise Scheduler through the Scheduled Processes navigation. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

  • BI Mobile Apps: Oracle Business Intelligence Mobile App Designer is an application that enables you to create multitouch information-driven applications with rich interaction, rich visualization, and rich media, for mobile devices such as iPhone, iPad, Android phone, tablet, and more. These reports can be run by users in General Ledger, Payables, Receivables, Cash Management, Intercompany, and so on.

Other Reporting Tools

Six other tools are available for reporting in Financials.

The following table lists the other reporting tools and the types of reports they support.

Other Reporting Tools Report Type

General Accounting Dashboard and Account Inspector

Account Groups

Reports and Analytics

Oracle Transactional Business Intelligence Objects

BI Catalog

All Report Types, Except Oracle Business Intelligence Publisher Reports

Enterprise Performance Management Workspace

Reports, Books, Snapshot Reports, Snapshot Books, Financial Reporting Batches, and Batch Scheduler

Enterprise Scheduler System

Oracle Business Intelligence Publisher Reports

Even though the Financial Reporting Center is designed to be the main user interface for a financial end user's reporting needs, some users may choose to use any of the six other tools for reporting in financials, such as:

  • General Accounting Dashboard, which provides access to Account Groups: Uses the Account Monitor to efficiently monitor and track key account balances in real time.

  • Account Inspector: Perform ad hoc queries from account groups and financial reports through drill down to underlying journals and subledger transactions.

  • Reports and Analytics: This reporting tool has a panel that reflects the folder structure of the BI Catalog. Users can access and run any Oracle Transactional Business Intelligence analysis, report or dashboard. Users can't run Financial Reports or Oracle Business Intelligence Publisher reports from this interface. This interface can be used by all financials users.

  • BI Catalog: A component of the Enterprise Performance Management Workspace where you can run all report types, except for Oracle Business Intelligence Publisher reports.

  • Enterprise Performance Management Workspace: Create reports, books, snapshot reports, snapshot books, Financial Reporting batches, and batch scheduler, and schedule batches to automatically run and burst to email.

  • Enterprise Scheduler System: Only Oracle Business Intelligence Publisher reports can be submitted from this interface. Users access this interface by navigating to Tools > Scheduled Processes. Most financial users have access to this interface to run standard reports for General Ledger, Payables, Receivables, and so on.

Oracle Fusion Financial Reporting Center is a powerful tool for reviewing, designing, and presenting financial reports and analytic data. The critical choices required to configure and install the components in Financial Reporting Center consist of:

  • Configuring the Financial Reporting Center

  • Installing and configuring Financial Reporting Studio, performed by your end users

  • Installing Smart View, performed by your end users

  • Configuring Workspace Database Connection, performed by your administrator

Configuring Financial Reporting Center

You have access to the reports in the Financial Reporting Center and Workspace installed with Oracle Fusion Financial Applications. Your Oracle Fusion Business Intelligence (BI) administrator defines the folder structure in Workspace. The administrator considers your company's security requirements for folders and reports, as well as report distribution requirements for financial reporting batches.

  • Security can be set on folders and reports from Workspace.

  • You are granted access to the folders and reports you want to view by your BI administrator.

Installing and Configuring Financial Reporting Studio

Oracle Financial Reporting Studio is client-based software. If you open Oracle Fusion Applications from Oracle Cloud, you connect to the Financial Reporting Studio through a Windows Remote Desktop Connection. Report authors download installation files for Financial Reporting Studio from Workspace by clicking Navigator > Financial Reporting Center > Tasks panel drawer > Open Workspace for Financial Reporting. Once Workspace is started, click Tools > Install > Financial Reporting Studio. After performing the prerequisites and completing the installation, start the Financial Reporting Studio. Provide your user ID, password, and the Server URL. Derive the Server URL information by following the steps:

  1. Open Navigator > Financial Reporting Center > Tasks panel drawer > Open Workspace for Financial Reporting.

  2. Edit the Workspace URL and remove workspace/index.jsp.

  3. Following are two examples of Server URLs:

    • If the Workspace URL is https://fusionsystemtest-p-external-bi.visioncorporation.com/workspace/index.jsp, the Server URL is https://fusionsystemtest-p-external-bi.visioncorporation.com.

    • If the Workspace URL is https://fusionsystemtest-p-external-bi.visioncorporation.com:10622/workspace/index.jsp, the Server URL is https://fusionsystemtest-p-external-bi.visioncorporation.com:10622.

  4. Copy the modified URL to the Server URL field.

Note: For end users installing the Oracle Fusion Financials Reporting Studio, the installer starts a separate console window. The installer continues to run for a brief time after the installation completes the setup tasks. The process is normal, expected, and applies to Oracle Reporting Studio installations in both the Oracle Fusion Applications and Enterprise Performance Manager modes.

Wait for the console window to close, which happens automatically, before clicking the Finish button on the Financial Reporting Studio Installation dialog box. If you click the Finish button before the console window closes, the Financial Reporting Studio installation may not complete.

Note: You must save a new report before attempting to preview it with Web Preview.

Prerequisites needed for installing the Financial Reporting Studio are:

  1. Financial Reporting Studio Client Certifications that are found at: http://www.oracle.com/technetwork/middleware/bi-foundation/hyperion-supported-platforms-085957.html.

  2. Microsoft Office installed on your users' computers.

Installing Smart View

Smart View is an Excel add-in that must be loaded on each client. To download Smart View, click Navigator > Financial Reporting Center > Tasks panel drawer > Open Workspace for Financial Reports. Once the workspace is started, click Tools > Install > Smart View.

Note: Since Smart View is an add-in to Microsoft Office products, you can install Smart View only on a Windows operating system.

Once Smart View is installed, you must configure the connection using the Smart View Shared Connections URL. You can derive the Shared Connections URL by following these steps:

  1. From the Financial Reporting Center task panel, select Open Workspace for Financial Reporting.

  2. Edit the workspace URL by removing index.jsp and adding SmartViewProviders at the end.

    Note: The following URL is an example for a Cloud-based environment. If the workspace URL is https://efops-rel5st4-cdrm-external-bi.visioncorporation.com:10622/workspace/index.jsp, the Shared Connections URL is https://efops-rel5st4-cdrm-external-bi.visioncorporation.com:10622/workspace/SmartViewProviders.
  3. Copy the URL.

  4. Open Excel.

  5. From the Smart View menu, click Options > Advanced.

  6. Paste the URL in the Shared Connections URL field.

  7. Click OK.

To connect Oracle Fusion General Ledger Balances cubes in Smart View:

  1. Open Smart View from your Start menu > Programs > Microsoft Office > Microsoft Excel 2007.

  2. Navigate to the Smart View menu > Open. On the Start on the ribbon, click Smart View Panel that appears in the list of values from the ribbon. The task pane opens.

  3. Click Shared Connections on the task pane.

  4. Sign in with your user name and password.

  5. Click the Select Server to proceed list of values.

    Note: If the Essbase Server is not there, then it has to be added. Use the following steps:
    1. Click the Add Essbase Server link.

    2. Specify the Essbase Server login and password.

    3. Expand the Essbase server and locate the cube in it.

  6. Select Oracle Essbase from the list of shared connections.

  7. Click the Expand to expand the list of cubes.

  8. Expand your cube (name of your chart of accounts).

  9. Click db.

  10. Click the analysis link.

Note: You must perform these steps only once for a new server and database.

To set how the name and alias of the Essbase database appears:

  1. Click Options on the ribbon > select the Member Options > select Member Name Display.

  2. Set one of these three options:

    • Distinct Member Name. Only shows the full Essbase distinct path.

    • Member Name and Alias: Shows both the member name and the alias.

    • Member Name Only. Shows only the member name.

Note: The Smart Slice feature is not supported in Oracle Fusion General Ledger. For all other documentation, refer to the Oracle Smart View for Office User's Guide.

Configuring Workspace Database Connections

Administrators must create database connections from Workspace so users can access the cubes from Workspace and Financial Reporting Studio.

Note: Ledger setup has to be completed before the database connection can be created. Oracle Fusion General Ledger balances cubes are created as part of ledger setup. A separate cube is created for each combination of chart of accounts and accounting calendar. A database connection is needed for each cube.

Steps to define a database connection are:

  1. Start at the Navigator by selecting Financial Reporting Center.

  2. From the Financial Reporting Center task panel, select Open Workspace for Financial Reporting.

  3. From within Workspace select the Navigator menu > Applications >BI Catalog.

  4. Select Tools menu > Database Connection Manager.

  5. Select New button.

  6. Enter a user-friendly name for the Database Connection Name.

  7. Enter Essbase as the Type, your server, user name, and password.

  8. Select Application (cube) and Database from the list of values. Expand the Application name to see the related Database.

  9. Click the OK button twice to save your selections.

  10. Click Close button in the Database Connection Manager window to save your connection.

Note: The database connection is available in both Workspace and Financial Reporting Studio. Optionally, it can be set up in Financial Reporting Studio when putting grids on a report. This should only be done by an administrator.

For more detailed information about Smart View and Financial Reporting Studio, refer to the Using EPM with Oracle Financials Cloud link on the Books for Oracle Financials Cloud page of the Oracle Help Center at https://docs.oracle.com.

Considerations for Implementing Financial Reporting Center

The Financial Reporting Center adds self-service functionality for the Oracle Fusion Applications and the Oracle Fusion Accounting Hub. The financial reports are available immediately on both computers and mobile devices, which leads to quicker decision making.

Note: To access the reports in Financial Reporting Center, store the reports in the My Folder or Shared Custom directories.

Job Roles and Duty Roles

The following table shows the predefined job roles and their associated duty roles.

Predefined Job Role Duty Roles

General Accountant

  • Financial Reporting Management

  • Account Balances Review

General Accounting Manager

  • Financial Reporting Management

  • Account Balances Review

Financial Analyst

  • Financial Reporting Management

  • Account Balances Review

Business Process Model Information

The features are part of the Manage Financial Reporting and Analysis detailed business process.

The following table shows the activities and tasks for that business process.

Activity Task

Prepare Financial Reports

Generate Financial Statements

Analyze Financial Performance

Inquire and Analyze Balances

Oracle Hyperion Financial Reporting Studio enables you to use an object-oriented graphical report layout with report objects, such as text boxes, grids, images, and charts.

Financial Reporting Studio supports the following functionality:

  • Client-based report definition tool.

  • Object based reporting. Objects are reusable across multiple reports

  • Drag and drop report grids

  • Insert additional report objects such as text boxes, images, and charts

  • Drag and drop dimensions to the report grid. Each dimension can only be in one location on report: row, column, page, or point of view.

  • Insert rows and columns including data, formula, and text

  • Select dimension member using member selection or functions

  • Add calculations or mathematical functions

For more information about Financial Reporting Studio, refer to the Using EPM with Oracle Financials Cloud link on the Books for Oracle Financials Cloud page of the Oracle Help Center at https://docs.oracle.com.

Overview of Reporting Web Studio

Reporting Web Studio is a web-based report authoring solution with a similar look and feel to Windows-based Financial Reporting Studio. Report definitions remain the same for both reporting solutions, so you can edit existing reports using the Windows or web version of Financial Reporting Studio.

You can open Reporting Web Studio from the Enterprise Performance Management System workspace. To get there, start from the Financial Reporting Center work area and click the Open Workspace for Financial Reports task. Then click the Launch Reporting Web Studio menu item from the Tools menu.

Here's an image of the menu items under the Tools menu.

This image shows the Tools menu in the Enterprise
Performance Management System workspace. One of the menu items is
Launch Reporting Web Studio.

This table describes the sections in the Reporting Web Studio interface.

Callout Section in Interface What's in It?

1

Repository

Folders, reports, and a Search toolbar.

2

Summary

Information about an opened report, such as report name and description.

3

Report

Object browser, report objects, design canvas, and report object properties panel. Report objects include grids, text, images, and charts.

4

Design Canvas

Layout for a report.

5

Properties

Attributes for a selected report or report object.

Here's an image of the Reporting Web Studio interface highlighting the key sections described in the table.

This image shows the main interface for Reporting
Web Studio.

For more information about Reporting Web Studio, go to the Oracle Financials Cloud books page on the Oracle Help Center at https://docs.oracle.com. Select the Using EPM with Oracle Financials Cloud link.

How to Manage Financial Reporting Studio Versions

You could run into issues with Financial Reporting Studio reports if the Financial Reporting Studio version on your client is different from the Financial Reporting server version in the application. You must therefore manage the Financial Reporting Studio client version during the course of the regular Oracle Fusion Applications Cloud updates.

Using Financial Reporting Studio Between Test and Production Updates

Your test environment is always updated before your production environment.

During this period, the version of the Financial Reporting server on your test environment may be different than the version on your production environment. When this happens, the existing Financial Reporting Studio client currently installed on your computer may not work with your test environment due to the version mismatch between its server and client. Thus, during this period, you must uninstall and reinstall the Financial Reporting Studio client from the test or production environment accordingly, depending on which environment you work on, to ensure the client version matches the server version.

Using Financial Reporting Studio After the Production Update

After the production environment is updated, the Financial Reporting Studio versions for the test and production environments will be the same.

If you already installed Financial Reporting Studio from the test environment, you won't have to make any changes. Otherwise, you should immediately uninstall, download, and reinstall Financial Reporting Studio from the financial reporting workspace in the production environment.

Comparing the Client and Server Versions

To compare the Financial Reporting Studio client version with the Financial Reporting server version, perform the following steps:

  1. Launch Financial Reporting Studio.

  2. From the Help menu, select About Reporting Studio.

  3. Compare the Oracle Hyperion Financial Reporting version with the Report Server Version to confirm that they match.

The following figure shows an example of the Financial Reporting Studio window with matching client and server versions. The Oracle Hyperion Financial Reporting version is 11.1.2.4.505 and the Report Server Version is 11.1.2.4.560.0505.

This figure shows the page that displays when you
select About Reporting Studio from the Financial Reporting Studio
Help menu.

You can also check the server version from the Help menu of the financial reporting workspace.

  1. From the Financial Reporting Center, select the Open Workspace for Financial Reports task.

  2. From the Help menu, select About Oracle Enterprise Performance Management System Workspace.

  3. Click Show Details.

The following figure shows an example of the Enterprise Performance Management System Workspace window with the report server version.

This figure shows the page that displays when you
select About Oracle Enterprise Performance Management System Workspace
from the Help menu in the financial reporting workspace.

Installing Financial Reporting Studio

Perform the following prerequisite steps:

  1. Uninstall the previous version, if any, using the Windows Control Panel.

  2. Delete the existing directory structure. For example, C:\Oracle\Middleware\EPMSystem11R1\products\FinancialReportingStudio.

  3. Restart your computer.

Download the version of the Financial Reporting Studio from that environment's workspace:

  1. Navigate to the Financial Reporting Center and select the Open the Financial Reporting Workspace task.

  2. From the menu, select Tools > Install > Financial Reporting Studio and save the file.

  3. Right-click the executable file and select Run as administrator.

    Caution: Don't close the command window that appears near completion. It will automatically close itself.

    The following figure shows an example of the command window that appears while the executable file is running.

    This figure shows the command window, which automatically
closes.
  4. Click Finish on the install window after the command window closes.

Lastly, when designing reports, you can't design a Financial Reporting Studio report using a client version that's higher than the report server version, and then export or import the report to a lower client version level. The report may not work.

How Financial Reporting Reports and Account Groups Are Generated

Use the Generate Financial Reports and Account Groups process to create Financial Reporting reports and account groups for each general ledger balances cube for a specified chart of accounts and accounting calendar.

You can submit the process at any time.

How the Reports and Account Groups Are Generated

Submit the Generate Financial Reports and Account Groups process from the Scheduled Processes work area. Select the chart of accounts and accounting calendar, which identify the balances cube and ledgers for which to generate the Financial Reporting reports and account groups.

Specify values for the top parent revenue and expenses account:

  • Top Revenue Account

  • Top Operating Expenses Account

  • Top Cost of Sales Account (optional)

The top parent accounts are used as the basis for deriving the accounts referenced in the reports. The immediate descendants of the top parent accounts are used to define the rows on the Financial Reporting income statement reports. Depending on whether both the top operating expenses and top cost of sales accounts are selected, different variations of the Financial Reporting income statements are generated. If the optional top cost of sales account is provided, the income statements Financial Reporting income statement reports also include a gross margin section.

Tip: You can pick a specific tree and tree version for each parent. All three parent account values can be from different trees and tree versions. Ideally, you would choose a common tree and tree version for all of the parent accounts. The hierarchy basis for all of the rows in the generated reports is then consistent.

For the balances cube identified by the chart of accounts and calendar in the request submission, the process creates an individual set of the following Financial Reporting reports:

  1. Income Statement

  2. Consolidated Income Statement

  3. Rolling Quarterly Income Statement

  4. Rolling Monthly Income Statement

  5. Trial Balances by Ledger Currency

  6. Trial Balances by Entered Currency

Note: To prevent the unnecessary proliferation of such Financial Reporting reports, unless the original reports created were renamed or deleted, resubmitting the process doesn't generate new Financial Reporting reports.

The process also generates the following three account groups for the balances cube, to be shared among all of the ledgers that are part of that balances cube:

  • Revenues: Defined to display in the Revenues infolet. Automatically set as the default for the General Accounting Infolets home page unless an existing account group is already set as the default.

  • Expenses: Defined to display in the Expenses infolet. Automatically set as the default for the General Accounting Infolets home page unless an existing account group is already set as the default.

  • Close Monitor Summary Income Statement: Defined to display in the Close Monitor. Can be assigned to your ledger sets when you complete the Close Monitor setup.

Note: A new set of account groups is generated for a balances cube with each submission of the process.

Create a Financial Report

You can use Financial Reporting Studio to design traditional financial report formats such as balance sheets, profit and loss statements, and cash flow reports. You can also design nontraditional reports for financial or analytic data that include text and graphics.

In this example, you're designing a basic financial report. This is the first of six topics on designing a financial report with Financial Reporting Web Studio. Because Financial Reporting Web Studio is web-based, you don't have to download and install an application.

  1. From the Financial Reporting Center work area, select the Tasks panel tab and click Open Workspace for Financial Reports.

  2. On the Tools menu, select Launch Financial Reporting Web Studio.

  3. On the File menu, select New, Report.

  4. On the toolbar, click the Grid icon. Grids are tables that contain data from external database connections.

  5. In the design canvas, draw a box to create the grid. The Database Connection Properties dialog box opens.

    Tip: When creating a grid, best practice is to leave space in the design canvas for other objects, such as a company logo and report title.
  6. Select the Data Sources list and select the data source for the chart of accounts that the report is based on. A unique cube exists for each combination of chart of accounts and accounting calendar.

    Tip: Best practice is to always turn on suppression in financial reports at the Database Connection Server level. You can verify the setting by highlighting the grid, and then selecting Data Query Optimization Settings on the Task menu. For most reports, best practice is to turn on suppression for the entire grid. Then turn suppression off for columns and rows that must always display.

    For more information about suppression settings, refer to the Defining Basic Conditional Suppression section in the Financial Reporting Web Studio User's guide.

  7. Click OK. The Dimension Layout dialog box opens.

Arrange the Dimensions

Use the Dimension Layout dialog box to arrange the dimensions on your report. For this report, the accounting periods display on the columns and the revenue and expense account information displays on the rows. The company appears on each page and can be selected at runtime.

  1. Drag the Accounting Period dimension to the Columns axis.

  2. Drag the Account dimension to the Rows axis.

  3. Drag the Company dimension to the Page axis.

  4. Click OK to close the Dimension Layout dialog box.

Define the Rows

Use the Select Members dialog box to define the revenue and expense account rows.

  1. Select the revenue parent account.

    1. Double-click the Account cell. The Select Members dialog box opens with a default member selected.

    2. Remove the default Account selection from the Selected area by clicking it to select it and then clicking the Remove from Selected icon.

    3. In the Search field, enter the value for the account that represents total revenue and click the Search icon.

    4. Select the account from the search results and click OK. The account moves to the Selected area.

    5. Click OK. The Select Members dialog box closes.

  2. Now insert a text row to add space between the revenue and expense accounts.

    1. Select the last row in the grid by clicking the row header.

    2. On the Insert menu, select Row, then Text.

  3. Insert a row for the expense accounts.

    1. Right-click the last row header.

    2. On the Insert Row menu, select Data. Notice the default value for the new row is the revenue parent account.

  4. Select the expense parent accounts.

    1. Double-click the account value in the new expense account row. The Select Members dialog box opens with the revenue parent account selected.

    2. Remove the revenue parent account selection from the Selected area by clicking to select it and then clicking the Remove from Selected icon.

    3. In the Available area, expand the Account member, and continue expanding until you find the expense parent accounts for the report.

    4. Select the accounts and click the Add to Selected icon to move them to the Selected area.

    5. Select the Place selections into separate rows option so each account appears in its own row on the report.

    6. Click OK. The Select Members dialog box closes.

Save and Preview the Report

Save the report and leave it open for the next topic, which is adding a formula to a financial report.

  1. Click the Save icon.

  2. Select the folder with your name and enter the report name and description.

  3. Click Save.

  4. Optionally preview the report in HTML or PDF format using the File menu or toolbar.

Add Formulas to a Financial Reporting Report

In this example, you define a formula to summarize the expense account balances on your financial report. This is the second of six topics on designing a financial report with Financial Reporting Web Studio.

Before you start, do the steps described in the Define a Basic Financial Report Using the Reporting Web Studio topic, then follow these steps.

  1. Right-click the last row header, select Insert Row and select Formula.

  2. Click in the empty cell in the new row.

  3. In the Heading Row Properties pane, select the Custom Heading option, enter Total Expenses and click the Update icon. The new heading appears in the report.

  4. Select the row header for the formula row. The SUM function appears in the design canvas.

  5. In the Formula bar, click the Sum(0) button and enter the formula and cell references in the formula text box.

    Because the expense rows appear one after the other, you can use the first row number and the last row number with a colon in between. For example, Sum([3:5]). If the rows weren't contiguous, you could put brackets around each row number and separate them with commas. For example, Sum([3], [5], [6]).

  6. Validate the formula syntax by clicking the check mark icon in the toolbar. Validation checks the validity of the formula, not if the data is available.

  7. Save the report and leave it open for the next topic, which is defining a range function. Optionally preview the report.

Define Range Functions for a Financial Reporting Report

In this example, you define a range function to report across multiple accounting periods. You configure the range to present balances for the last 12 months from the period selected at runtime. This is the third of six topics on designing a financial report with Financial Reporting Web Studio.

Before you start, do the steps described in these topics.

  1. Define a Basic Financial Report Using the Reporting Web Studio

  2. Add Formulas to a Financial Reporting Report

Now follow these steps.

  1. Double-click the Accounting Period cell. The Select Members dialog box opens.

  2. Remove the default accounting period from the Selected area by clicking it to select it and then clicking the Remove from Selected icon.

  3. Click the Functions tab.

  4. Select Range from the list.

  5. Click the Add to Selected icon. The Range dialog box opens.

  6. Define the starting member for the range.

    1. On the Start Member row, click the Lookup Selection icon in the Value column.

    2. Click the Functions tab.

    3. Select the Relative Member function to define the periods that display on the report relative to the period specified at runtime.

    4. Click OK. The Relative Member dialog box opens.

    5. On the Member row, click the Lookup Selection icon in the Value column.

    6. Select Current Point of View for Accounting Period so you can enter the starting period for the report.

    7. Click OK.

    8. On the Offset row, enter -11 in the Value field.

      The offset determines the first period of the range. The starting period in the range function is always the oldest period. Because this is a rolling 12 period report, enter -11 to include the 11 periods prior to the period you enter at runtime. The member selection for the End Member parameter determines period 12.

    9. Click OK.

  7. Define the ending member for the range.

    1. On the End Member row, click the Lookup Selection icon in the Value column.

    2. Select Current Point of View for Accounting Period.

    3. Click OK.

    4. Click OK to close the Range dialog box.

    5. Click OK to close the Select Members dialog box.

  8. Save the report and leave it open for the next topic, which is defining a grid point of view. Optionally preview the report.

Set User and Grid Points of View for a Financial Reporting Report

In this example, you set a user point of view and a grid point of view for a financial report. This is the fourth of six topics on designing a financial report with Financial Reporting Web Studio.

All financial reporting reports have a user point of view and a grid point of view. Best practice is to use a combination of both.

If you want users to select certain dimension members at runtime, then those dimensions should be set in the user point of view. Selections for user point of view members are global for a user and data source. This means the application saves and applies them to any other report that has the same dimensions set to the user point of view. By default, all dimensions are set to the user point of view and must be selected at runtime. If you want your report to always use certain dimension selections, then select the specific members in the grid point of view.

Note: Members of a grid point of view only display in HTML.

In this example you set the Ledger, Scenario, Balance Amount and Currency dimensions to use the grid point of view.

Before you start, do the steps described in these topics.

  1. Define a Basic Financial Report Using the Reporting Web Studio

  2. Add Formulas to a Financial Reporting Report

  3. Define Range Functions for a Financial Reporting Report

Now follow these steps.

  1. Select the cell in the grid that represents the intersection of the rows and columns. The Grid Properties pane opens.

  2. In the Grid Properties pane, click the Grid Point of View check box.

  3. In the design canvas, click the Ledger: User Point of View for Ledger button. The Select Members dialog box opens.

  4. Expand the Ledger member and continue to expand until you find the ledger to include on the report. Select the ledger.

  5. Click Apply Selection.

  6. Select Scenario from the Dimension list to select the type of balance to use on the report.

  7. Expand the Scenario member and select Actual.

  8. Click Apply Selection.

  9. Select Balance Amount from the Dimension list.

  10. Expand the Balance Amount member and select Period Activity.

  11. Click Apply Selection.

  12. Select Currency from the Dimension list.

  13. Search for USD.

  14. Click OK to accept the search result.

  15. Click Apply Selection.

  16. Click OK to close the Select Members dialog box.

  17. Save the report and leave it open for the next topic, which is setting page and grid properties. Optionally, preview the report.

Work with Grid Point of View Setup and Page Axis for a Financial Reporting Report

In this example, you change the grid point of view setup and set the page member selection to a prompt on your financial report. This is the fifth of six topics on designing a financial report with Financial Reporting Web Studio.

Before you start, do the tasks described in these topics.

  1. Define a Basic Financial Report Using the Reporting Web Studio

  2. Add Formulas to a Financial Reporting Report

  3. Define Range Functions for a Financial Reporting Report

  4. Set User and Grid Points of View for a Financial Reporting Report

Now follow these steps.

  1. Click the first cell in the grid to select all of the rows and columns.

  2. Right-click and select Grid Point of View Setup from the list. The Setup Grid Point of View dialog box opens.

    1. To prevent the Balance Amount dimension from being changed at runtime, select the Lock Member Selection option.

    2. Click OK. The Setup Grid Point of View window closes.

  3. In the Grid Properties pane:

    1. Click the Drill Through option to allow drilling from the report to the General Ledger transaction data.

    2. Click the Suppression section to view the suppression settings.

    3. Enter 0 in the Zero Values field to set the text option for rows with zero values. If necessary, you could also suppress the display of rows with zero values, rows with missing data, and rows with errors.

  4. Set a runtime prompt for the Company dimension so you have the flexibility of selecting any company or combination of companies at runtime. In this example, you want to restrict the valid list of companies that can be selected at runtime.

    1. On the grid, click the Pages label. The Company dimension appears in the design canvas.

    2. Click the Company button. The Select Members dialog box opens.

    3. Remove the default Company selection from the Selected area by clicking it to select it and then clicking the Remove from Selected icon.

    4. Select Prompt for Company.

    5. Click the Add to Selected icon to move the selection to the Selected area.

    6. Click OK. The Define Prompts dialog box opens.

    7. Click the Lookup icon in the Choices List field. The Select Members dialog box opens.

    8. Remove the default Company selection from the Selected area by clicking it to select it and then clicking the Remove from Selected icon.

    9. Expand the Company member, and continue expanding until you find and select the default companies you want to display in the prompt.

    10. Click the Add to Selected icon to move the companies to the Selected area.

    11. Click OK. The Select Members window closes.

    12. On the Define Prompts dialog box, click in the Member Name field and select Alias. The actual company label displays in the prompt list of values instead of a numeric company value, making the prompt more user-friendly.

    13. Click OK. The Define Prompts window closes.

  5. Click the Pages label on the grid. The Page Properties pane opens.

    1. In the Page Properties pane, select the Alias: Default option so each page of the report shows the name of the company instead of the number.

  6. Select the four data rows in the grid so all of the rows have the same settings.

    1. In the Heading Row Properties pane, select the Alias: Default option in the Heading Row Properties pane to display the revenue and expense account names instead of the accounts.

    2. In the Heading Row Properties pane, select the Allow Expansion option so you can expand the parent account values to view the detail child values.

  7. Save the report and leave it open for the next topic, which is formatting your financial report and adding a graph. Optionally, preview the report.

Add Formats and Graphs to a Financial Reporting Report

In this example, you add formats and graphs to a financial report. This is the sixth and final topic in a series of topics on designing a financial report with Financial Reporting Web Studio.

Before you start, do the steps described in these topics.

  1. Define a Basic Financial Report Using the Reporting Web Studio

  2. Add Formulas to a Financial Reporting Report

  3. Define Range Functions for a Financial Reporting Report

  4. Set User and Grid Points of View for a Financial Reporting Report

  5. Work with Grid Point of View Setup and Page Axis for a Financial Reporting Report

Now follow these steps.

  1. In the report object browser, select the name of the report, which is the first object.

  2. Add a logo.

    1. In the report layout, drag the header line to make space for the logo and title.

    2. In the Header section, click the Add Report Object icon and select Image.

    3. In the Image Properties pane, click Browse and select your company logo.

  3. Add a title.

    1. Select the name of the report in the report object browser.

    2. In the Header section, click the Add Report Object and select Text. As an alternative, you can click the Text icon in the toolbar and draw the text box. The text box opens.

    3. Enter the report title.

    4. Select the title text and use the format toolbar to adjust the font size, center the text, and change the font style to bold.

  4. Change the page orientation.

    1. Select the name of the report in the report object browser.

    2. On the File, menu, select Page Setup.

    3. In the Page Setup dialog box, select the Landscape option.

    4. Click OK.

  5. Add a chart.

    1. In the Body section, click the Add Report Object icon and select Chart.

    2. In the Chart Properties pane, select the Line chart type.

    3. To show only the expense account rows, deselect row 1, and select rows 3, 4, and 5 in the Data Range section.

    4. Click the Format Chart button. The Format Chart dialog box opens.

    5. In the Appearance tab, enter the title for the chart. For example, Expenses by Period.

    6. Click the Legend tab and enter a title for the legend. For example, Type of Expenses.

    7. Click the Axes tab and enter a title for the Metadata axis. For example, Period. Enter a title for the Primary Axis. For example, Dollars.

    8. Click the Refresh Chart button to preview the chart on the Format Chart dialog box.

    9. Click OK. The Format Chart dialog box closes.

  6. Save the report and optionally, preview it.

For more information about Financial Reporting Web Studio, select the Using EPM with Oracle Financials Cloud link from the All Books for Oracle Financials Cloud page of the Oracle Help Center at https://docs.oracle.com.

Configuration of an account group enables you to create self-monitoring accounts that help you eliminate the surprise of account anomalies during your close process.

Scenario

You have been given the task to set up account groups. Follow these steps to define account groups that track key account balances by purpose, category, and comparison criteria.

  1. Navigate to the General Accounting Dashboard page.

  2. In the Account Monitor section, select View > Account Group > Create. Other Account Group options include:

    • Manage to create, edit, or delete account groups. You can also enable sharing of account groups with other users.

    • Edit to change an existing account group or to make a copy of an existing account group to which you have access, whether it's an account group that you own, that's shared with you, or that's public. You're marked as the owner of the copied account group, which is automatically set to private access, but can be changed to the access setting that you like.

  3. Enter the account group name and description. The name is used by default on the infolet that the account group displays in, but can be changed using the infolet Actions menu.

  4. Select a value for the Display In option to determine if the account group appears in one of the infolets (Allocations, Expenses, Revenues), the Account Monitor, or the Close Monitor. The display option that you select can affect the other account group settings. For example, account groups that display in the Close Monitor must have public access, and account groups that display in infolets must have the option to dynamically derive the ledger enabled.

    Note: Regardless of its display setting, any account group can be viewed from within the Account Monitor and Financial Reporting Center.
  5. For each infolet and Account Monitor display setting, you can specify a default account group by selecting the Set as default option. The default account group setting is user-specific, determining which account groups appear to you when you view the infolets and the Account Monitor.

    Note: The default setting doesn't affect account groups that are set to display in the Close Monitor. The account group that displays in the Close Monitor is determined by the ledger set definition.
  6. Select the Dynamically derive ledger option to apply the account group to any ledger in the same balances cube. The ledger derived is based on your given data access set selection. You must enable this option for account groups that display in the Revenues, Expenses, and Allocations infolets.

    Note: If you don't select this option, enter a ledger on each account row.
  7. Select a Time Option and Comparison Option as shown in the following table.

    Time Option Comparison Option

    Accounting Period

    • Budget PTD

    • Budget QTD

    • Budget YTD

    • Prior period PTD

    • Prior year PTD

    • Prior year QTD

    • Prior year YTD

    Quarter

    • Budget QTD

    • Budget YTD

    • Prior quarter QTD

    • Prior year QTD

    • Prior year YTD

    Year

    • Budget YTD

    • Prior year YTD

    Tip: If you're using a budget comparison option, select the budget name in the Scenario field.
  8. Set the access.

    Note: Regardless of the access setting, only the person who owns the account group can modify it. However, for account groups that you have access to, you can share with others even if you're not the owner.
    • Private: For your use only.

    • Public: For use by all users who have access to the same balance cube of that account group. Account groups that display in the Close Monitor must be set to Public.

    • Shared: For use by users you specify and who have access to the same balance cube of that account group.

      Note: To set shared access, navigate to the Manage Account Group page.
  9. In the Accounts section, enter the accounts to monitor. The accounts must be defined to be consistent with the particular infolets targeted to track revenues, expenses, or allocations pools.

    • Accounts included in an account group for display in the Expenses infolet must be of the account type Expense.

    • Accounts included in an account group for display in the Revenues infolet must be of the account type Revenue.

    • Close Monitor account groups must only have two account rows. The first row must represent total revenues and the second row must represent total expenses.

    1. Give each account a short name that's easily recognizable. The name displays in infolets and in the Name column of the Account Monitor. For account groups that display in infolets, you must provide a name for each account.

    2. If the Dynamically Derive Ledger option isn't enabled, you must enter a ledger.

    3. Enter either parent or child values for each segment of the account.

    4. Select when to display the account in the Change field.

      • Always Display

      • Decrease by Less than Amount

      • Decrease by Less than Percentage

      • Decrease by More than Amount

      • Increase by More than Amount

      • Increase by Less than Amount

      • Increase by Less than Percentage

      • Increase by More than Percentage

      • Decrease by More than Percentage

      • Not Equal

      • Equal

    5. Enter a value in the Threshold field, which is the criteria that's being measured against. The threshold is used in conjunction with the Change field selection.

  10. Click Save and Close or Save and Create Another.

General Ledger Subject Areas, Folders, and Attributes

To create real-time analyses for General Ledger, you should be familiar with subject areas, folders, and attributes.

Subject Areas

To create an analysis, you begin by selecting a subject area from which you select columns of information to include in the analysis. For example, to create an analysis of journal information, you begin by selecting a General Ledger - Journals Real Time subject area. Subject areas are based around a business object or fact. In this example, the subject area is based on the columns in the journal tables.

General Ledger has four general ledger-specific subject areas:

  • General Ledger - Balances Real Time

  • General Ledger - Journals Real Time

  • General Ledger - Period Status Real Time

  • General Ledger - Transactional Balances Real Time

Tip: To create a report that queries balances and allows drill down to journals, use the General Ledger - Transactional Balances Real Time and the General Ledger - Journals Real Time subject areas. Other than that, it's advised that you don't create reports that cross subject areas. Such reports may result in less than optimal performance and are hard to maintain.

Folders

Each subject area has one fact folder and a number of dimension folders. Fact folders contain attributes that can be measured, meaning that they're numeric values like journal debit and credit amounts. Fact folders are usually listed after dimension folders and are usually named after the subject area. Dimension folders contain attribute and hierarchical columns like journal name and accounting period.

Some folders appear in more than one subject area, such as Time. These are referred to as common folders or common dimensions.

Each folder within a subject area may have a different level of granularity. For example:

  • Journal Approval has approval attributes.

  • Journal Batches has subfolders with attributes.

Attributes

Finally, each dimension folder contains attributes (columns), such as balance type and posting date. This figure illustrates the structure of subject areas, folders, and attributes.

The following figure shows the General Ledger - Journals Real Time subject area. The subject area contains these folders: Approval Status, Journal Batches, Journal Headers, Journal Lines, Posting Status, Time.

The Approval Status folder is a Dimension - Presentation folder and contains these dimension attributes: Approval Status Code, Approval Status Description, Approval Status Meaning. The Lines folder is a Fact - Presentation folder and contains these measures: Accounted Credit, Accounted Debit, Entered Credit, Entered Debit, Statistical Quantity.

This figure shows the General Ledger - Journals
Real Time subject area and its folders.

FAQs for Financial Reporting

How can I apply permissions to objects from Financial Reporting in Workspace?

Open the Permission dialog box from the Tasks list to set permissions for a catalog object. Permissions determine which user, group, or role can view, open, or modify the object. If you display this dialog box while working in the catalog in Workspace, any permission changes that you specify are applied immediately. If you display this dialog box as part of the Batch Scheduler wizard, then the permission changes are not applied until you run the batch.

How can I store and edit Financial Reporting objects?

First installed Oracle BI EE as part of Oracle Fusion Applications. Then store and edit new objects that you create for Oracle Hyperion Financial Reporting in Workspace in the Oracle BI Presentation Catalog. Perform operations on those objects in the catalog similarly to how you work with other objects, such as copying and modifying properties. See the documentation for Hyperion Financial Reporting for complete information on working with objects. Financial Reporting report designers can also access the Financial Reporting objects in the Financial Reporting Studio.

You can export your financial reports from a source environment and import them to a target environment using implementation projects.

Only the financial reports in the /shared/Custom/Financials folder are exported, so make sure to copy all the financial reports, or the folders containing them, to this folder. In the Setup and Maintenance work area, create an implementation project that includes only the Create Financial Statements task. Then use the Manage Configuration Packages task to export and import the reports.

Note: For the Financial Reporting report definition migration service, from a source to a target environment, references to version IDs of dimension members hierarchies are synchronized to their version IDs in the target environment.