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Get Help

Get Help
There are a number of ways to learn more about your product and interact with Oracle and other users.

Get Help in the Applications
Use help icons    to access help in the application. If you don't see any help icons on your page, click your user image
or name in the global header and select Show Help Icons.

Get Support
You can get support at My Oracle Support. For accessible support, visit Oracle Accessibility Learning and Support.

Get Training
Increase your knowledge of Oracle Cloud by taking courses at Oracle University.

Join Our Community
Use Cloud Customer Connect to get information from industry experts at Oracle and in the partner community. You
can join forums to connect with other customers, post questions, suggest ideas for product enhancements, and watch
events.

Learn About Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program. Videos included in
this guide are provided as a media alternative for text-based topics also available in this guide.

Share Your Feedback
We welcome your feedback about Oracle Applications user assistance. If you need clarification, find an error, or just
want to tell us what you found helpful, we'd like to hear from you.

You can email your feedback to oracle_fusion_applications_help_ww_grp@oracle.com.

Thanks for helping us improve our user assistance!

i

https://support.oracle.com/portal/
https://www.oracle.com/corporate/accessibility/learning-support.html#support-tab
https://www.oracle.com/education/
https://cloudcustomerconnect.oracle.com/pages/home
https://community.oracle.com/customerconnect/categories/idealab-guidelines
https://www.oracle.com/corporate/accessibility/
mailto:oracle_fusion_applications_help_ww_grp@oracle.com
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1  The Sandbox, Page-Specific Expressions,
and Additional Attributes

Create a Sandbox and Make It Active  
To configure and extend an environment, you need to create a sandbox and make it active.

1. Click Navigator > Configuration > Sandboxes.
2. On the Sandboxes page, click Create Sandbox.
3. On the Create Sandbox page, enter a descriptive name for the sandbox.
4. In the Structure row, select the Active check box.
5. If you plan to change predefined text, in the User Interface Text row, select the Active check box. You can always

make the User Interface Text tool active in your sandbox later, as needed.
6. In the Page Composer row, select the Active check box. The default supported context is Site.

If you plan to make country-specific changes, you need to create a separate sandbox with only the Page Composer
tool active. You also need to change the supported context in that sandbox.

a. In the Page Composer row, click the Edit icon.
b. On the Edit Sandbox Context dialog box, in the Category field, select Human Capital Management.
c. Select HcmCountry and the specific country you want the changes to apply to.
d. Click OK.

7. To create the sandbox and make it active, click Create and Enter.

Expressions to Show Components on Specific Benefits
Pages  
You can include these expressions in your Show Component expressions, to identify the specific pages that should
show (eq) or hide (ne) the component.

Expressions for Where to Show a Component

Where to Show the Additional Text Show Component Expression

Only on the People to Cover page #{pageFlowScope.pEnrollmentFlow eq "EMPCONTACT"}

Only on the Report a Life Event page #{pageFlowScope.pTarget eq "EMPEVENT"}

Only on the Pending Actions page #{pageFlowScope.pTarget eq "EMPPNDGACTN"}

1
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Where to Show the Additional Text Show Component Expression

Only on the Review Employee Resources
page

#{pageFlowScope.pTarget eq "EMPRESOURCE"}

Only on the Need Help? Contact Us page #{pageFlowScope.pTarget eq "EMPHELP"}

Only on the Primary Care Physicians page #{pageFlowScope.pTarget eq "EMPPCP"}

As part of the Information message
banner at the top of the Report a Life
Event page

#{attrs.type eq ‘inlineInformation’ and pageFlowScope.pTarget eq ‘EMPEVENT’}

Attributes You Can Add on Benefits Pages  
You can include various attributes on Benefits pages using these expressions.

Expressions to Add Attributes to Specific Benefits Pages

Attribute Expression to Use Page Where Expression Returns Expected
Value

Person Name #{pageFlowScope.configurationMap.PersonName}All self-service and Benefits Service Center
pages except Billing and detail pages opened
from the Document and Certification section

#{pageFlowScope.DocsCtfnMap.PersonName}On detail pages opened from the Document
and Certification section, such as approve,
 reject, view, and create documents and
certifications

#{sessionScope.configurationMap.PersonName}All Billing pages

Person Number #{pageFlowScope.configurationMap.PersonNumber}All self-service and Benefits Service Center
pages except Billing and detail pages opened
from the Document and Certification section

#{pageFlowScope.DocsCtfnMap.PersonNumber}On detail pages opened from the Document
and Certification section, such as approve,
 reject, view, and create documents and
certifications

#{sessionScope.configurationMap.PersonNumber}All Billing pages

#{sessionScope.Ben_PersonNumber} All self-service and Benefits Service Center
pages

Legal Entity ID #{sessionScope.BEN_LegalEntityId} All self-service and Benefits Service Center
pages

Legislation Code #{sessionScope.BEN_LegislationCode} All self-service and Benefits Service Center
pages
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Country Code #{sessionScope.BEN_CountryCode} All self-service and Benefits Service Center
pages

Life Event #{pageFlowScope.LifeEventName} Overview, enrollment flow, and confirmation
pages

PgmOrPlanName #{pageFlowScope.pgmName} Overview, enrollment flow, and confirmation
pages

Person Id #{sessionScope.Ben_PersonId} All self-service and Benefits Service Center
pages

3
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2  Add Components

Add a Background Image on a Landing Page  
To make a landing page more engaging, you can add a background image.

1. Click My Client Groups.
2. In the Quick Actions area, click HCM Experience Design Studio. The action creates a sandbox and activates it before

opening the studio.
3. On the HCM Experience Design Studio page, click the Landing Page Background Images tab.
4. Click the landing page you want to add the image to, such as Benefits.
5. In the Photo section, browse for and open the image you want to use.
6. Follow the instructions to adjust the image, as appropriate.
7. Click Save and Close.
8. On the HCM Experience Design Studio page, click Done.
9. Open the changed landing page and verify that it looks the way you want.
10.To publish your changes, on the DESIGN_STUDIO_AUTO_CREATED_SB menu, select Publish.

Add a Video on a Page  
To share pertinent information, you can include videos on a page.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page that you want to add video to, such as Me > Benefits > Review Employee Resources.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Add an HTML markup component.

a. Click the area where you want to add the video, such as under the Announcement header.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. On the Source pane toolbar, click the Add content into the selected component icon.
d. On the Add Content dialog box, in the Components row, click Open.
e. In the HTML Markup row, click +Add.
f. Click Close.

5
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8. Configure the HTML markup component.
a. Expand the Source pane and search for and select outputText: New HTML Markup.
b. On the Source pane toolbar, click the Show the properties of New HTML Markup icon.
c. On the Component Properties: New HTML Markup dialog box, in the Value field, select Expression

Builder.
d. On the Expression Editor dialog box, in the Type a value or expression field, enter the HTML to embed the

video. Here's a partial example:
frameborder="0" allowfullscreen
 style="position:absolute; top:0; left:0;
width:100%; height:100%;">
 </iframe>
</div>

e. Click OK.
f. On the Component Properties: New HTML Markup dialog box, click Apply.

g. Click OK.
9. To render your changes, on the page, click Close.
10.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
11. To publish your changes, on the <YourSandboxName> menu, select Publish.

Add a Hyperlink on a Page  
To share pertinent information, you can include external links as images or as text.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page that you want to add external links to, such as Me > Benefits > Review Employee

Resources.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Click the area where you want to add the external link, such as under the Announcement header.
8. On the Confirm Shared Component Edit dialog box, click Edit.

6



Oracle Fusion Cloud Human Resources
Configuring and Extending Benefits

Chapter 2
Add Components

9. Add the external link.
Here's how you can add it using an image:

a. On the Source pane toolbar, click the Add content into the selected component icon.
b. On the Add Content dialog box, in the Components row, click Open.
c. In the Image row, click +Add.
d. Click Close.
e. On the page, click the Image component.
f. On the Source pane toolbar, click the Show the properties of Image icon.

g. On the Component Properties: Image dialog box, complete the appropriate fields, such as selecting the icon
and setting a destination URL.

h. Click Apply.
i. Click OK.

Here's how you can add it without an image:

a. On the Source pane toolbar, click the Add content into the selected component icon.
b. On the Add Content dialog box, in the Components row, click Open.
c. In the Hyperlink row, click +Add.
d. Click Close.
e. On the page, click the Click edit icon to define hyperlink text.
f. On the Source pane toolbar, click the Show the properties of Hyperlink icon.

g. On the Component Properties: Hyperlink dialog box, complete the appropriate fields, such as setting the
destination URL and the text.

h. Click Apply.
i. Click OK.

10.To render your changes, on the page, click Close.
11. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
12. To publish your changes, on the <YourSandboxName> menu, select Publish.

Add a Hyperlink to a Monthly Bill Report on the Billing
Page  
To let benefits administrators more easily access the relevant monthly bill report, you can include hyperlinks to the
report on the Billing page.

Before you start

1. On the Oracle Business Intelligence server, create the billing data model. Make sure it accepts Person_Id and
Bill_Charge_Id.

7
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2. Create the monthly bill report and layout using the new billing data model.

Use these parameters:

◦ PersonId: #{sessionScope.configuratoinMap.pPersonId}

◦ BillChargeId: #{row.BillChargeId}

◦ Condition for Bill Status (Where Bill Status not equal to Open)JJ: #{rowStatus ne 'ORA_OPEN'

Here's a sample report link:
../../analytics/saw.dll?bipublisherEntry&Action=open&itemType=.xdo&
bipPath=%2FCustom%2FHuman%20Capital%20Management%2FPerson%20Monthly%20Bill
%20Report.xdo&bipParams={%22_xmode%22:%224%22,%22_xiasynch%22:
%22%22,%22_xpf%22:%22%22,%22_xpt%22:%220%22,%22_dFlag%22:%22false%22,%22_edIndex%22:%220%22,%22_dIndex
%22:%220%22,%22_rToken%22:
%22%22,%22_ranDiag%22:%22false%22,%22_xdo%22:
%22%2FCustom%2FHuman%20Capital%20Management%2FPerson%20Monthly%20Bill%20Report.xdo%22,
%22_paramspBillChargeId%22:%22#
{row.BillChargeId}%22,%22_paramspPersonId%22:%22#
{sessionScope.configurationMap.pPersonId}%22,%22_xt%22:%22Person%20Monthly%20Bill%20Report%20Layout%22,
%22_xf%22:%22pdf%22,%22_xautorun%22:%22true%22}&
_linkToReport=true

3. Test the report. Make sure to keep the Open Report link handy.
4. Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the benefits administration Billing page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Add the hyperlink.

a. In the Benefit Coverage Charges section, click the Benefits Coverage Charges field label.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. On the Source pane toolbar, click the Add content into the selected component icon.
d. On the Add Content dialog box, in the Components row, click Open.
e. In the Hyperlink row, click +Add.
f. Click Close.

8
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8. Configure the hyperlink.
a. On the page, click the Click edit icon to define hyperlink text.
b. On the Source pane toolbar, click the Show the properties of Hyperlink icon.
c. On the Component Properties: Hyperlink dialog box, in the Destination field, enter the URL to the monthly

billing report.
d. To open the report in a new tab, in the Target Frame field, enter _blank.
e. In the Text field, enter the link text, such as Open monthly bill report.
f. Select the Visible check box.

g. In the Visible field, select Expression Builder.
h. On the Expression Editor dialog box, in the Type a value or expression field, enter this expression:

#{row.Status ne 'ORA_OPEN'}

i. Click OK.
j. On the Component Properties: Hyperlink dialog box, click Apply.

k. Click OK.
9. To render your changes, on the page, click Close.
10.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
11. To publish your changes, on the <YourSandboxName> menu, select Publish.

Add an Image on a Page  
To make a page more engaging, you can add an image.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page that you want to add external links to, such as Me > Benefits > Review Employee

Resources.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. Add the image component.

a. Click the area where you want to add the image, such as the area below the Announcement header.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. On the Source pane toolbar, click the Add content into the selected component icon.
d. On the Add Content dialog box, in the Components row, click Open.
e. In the Image row, click +Add.
f. Click Close.

9



Oracle Fusion Cloud Human Resources
Configuring and Extending Benefits

Chapter 2
Add Components

7. Configure the image component.
a. On the Source pane toolbar, click the Show the properties of Image icon.
b. On the Component Properties: Image dialog box, in the Icon field, search for and select the image you want

to add.
c. Click Apply.
d. Click OK.

8. To render your changes, on the page, click Close.
9. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
10.To publish your changes, on the <YourSandboxName> menu, select Publish.

10
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3  Add and Show Legal Disclaimers

Add a Legal Disclaimer Analysis Link on the Benefits
Summary Page  
To provide important legal information, you can add a legal disclaimer analysis link on the summary page in the
Benefits Service Center. For example, you created a Participant Enrollment Authorization report that you want to link to
above the Evaluated Life Event section.

Before you start

1. Create the legal disclaimer analysis that accepts Person_Number and Person_Id using Benefits > Action
Items Real Time Subject Area.

Use this parameter:
PersonNumber : #{sessionScope.Ben_PersonNumber}

Here's a sample report link:
../../analytics/saw.dll?Go&path=%2Fshared%2FCustom%2FHuman%20Capital%20Management%2FParticipant
%20Enrollment%20Authorization%20Information&Action=Navigate&P0=2&P1=eq&P2=Worker.%22Person%20
Number%22&P3=#{sessionScope.Ben_PersonNumber}

2. Test the analysis. Make sure to keep the link handy.
3. Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the benefits administration summary page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Expand the Source pane.
8. Add the hyperlink.

a. Click the Evaluated Life Event section.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. In the Source pane, click the <>panelGroupLayout component that's the parent of the section.
d. On the Source pane toolbar, click the Add content into the selected component icon.
e. On the Add Content dialog box, in the Components row, click Open.
f. In the Hyperlink row, click +Add.

g. Click Close.
9. Configure the hyperlink.

a. On the page, click the Click edit icon to define hyperlink text.
b. On the Source pane toolbar, click the Show the properties of Hyperlink icon.

11
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c. On the Component Properties: Hyperlink dialog box, in the Destination field, enter the URL to the legal
disclaimer analysis.

d. To open the report in a new tab, in the Target Frame field, enter _blank.
e. In the Text field, enter the link text, such as Participant Enrollment Authorization report.
f. Select the Visible check box.

g. Click OK.
h. On the Component Properties: Hyperlink dialog box, click Apply.
i. Click OK.

10.To render your changes, on the page, click Close.
11. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
12. To publish your changes, on the <YourSandboxName> menu, select Publish.

Add a Legal Disclaimer Analysis on the Benefits
Summary Page  
To provide important legal information, you can add a legal disclaimer analysis link on the summary page in the
Benefits Service Center. For example, you created a Participant Enrollment Authorization report that you want to link to
above the Evaluated Life Event section.

Before you start

1. Create and test the legal disclaimer analysis that accepts Person_Number and Person_Id using Benefits >
Action Items Real Time Subject Area.

Use this parameter:
PersonNumber : #{sessionScope.Ben_PersonNumber}

2. Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the benefits administration summary page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Expand the Source pane.
8. Click the top section containing the effective as-of date.
9. On the Confirm Shared Component Edit dialog box, click Edit.
10. In the Source pane, click the <>panelGroupLayout component that's the parent of the section.
11. On the Source pane toolbar, click the Add content into the selected component icon.
12. On the Add Content dialog box, in the Reports and Analytics row, click Open.
13. Go to the legal disclaimer analysis and click Add.
14.Click Parameters.
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15. In the Person Number row, Value 1 field, enter this expression:
#{sessionScope.Ben_PersonNumber}

16.Click Save.
17. To render your changes, on the page, click Close.
18.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
19. To publish your changes, on the <YourSandboxName> menu, select Publish.
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4  Add Life Event and Person Details

Add the Life Event as a Subheader on the Elections
Overview Page Header  
To provide additional context in the header of the elections overview page, you can add the life event name.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page the elections overview page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Expand the Source pane.
8. Click the page header.
9. On the Confirm Shared Component Edit dialog box, click Edit.
10. In the Source pane, scroll up to <>simplePanel and click Close.
11. Click <>universalPanel.
12. On the Source pane toolbar, click the Show the properties of universalPanel icon.
13. On the Component Properties: universalPanel dialog box, in the Sub Header field, select Expression Builder.
14.On the Expression Editor dialog box, in the Type a value or expression field, enter this expression:

#{pageFlowScope.LifeEventName}

15. Click OK.
16.On the Component Properties: universalPanel dialog box, click Apply.
17. Click OK.
18.To render your changes, on the page, click Close.
19. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
20.To publish your changes, on the <YourSandboxName> menu, select Publish.

Add the Life Event on the Top Section of the Elections
Overview Page  
To provide context for the top section of the elections overview page, you can add the life event name.
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Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page the elections overview page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Add the text component.

a. Click the top, currency section
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. On the Source pane toolbar, click the Add content into the selected component icon.
d. On the Add Content dialog box, in the Components row, click Open.
e. In the Text row, click +Add.
f. Click Close.

8. Configure the text component.
a. On the page View menu, select Design.
b. In the new text component, click Edit Text.
c. On the Component Properties: Text dialog box, in the Display Header field, select Expression Builder.
d. On the Expression Editor dialog box, in the Type a value or expression field, enter this expression:

Life Event: #{pageFlowScope.LifeEventName}

e. Click OK.
f. On the Component Properties: Text dialog box, click Apply.

g. Click OK.
9. To render your changes, on the page, click Close.
10.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
11. To publish your changes, on the <YourSandboxName> menu, select Publish.

Add the Program or Plan Not in Program Name and Life
Event as a Subheader on the Enrollments Page Header  
To provide additional context in the header of the enrollment page, you can add the program or plan not in program
name and life event.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
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3. Go to and open the page the enrollment page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Expand the Source pane.
8. Click the page header.
9. On the Confirm Shared Component Edit dialog box, click Edit.
10. In the Source pane, scroll up to <>simplePanel and click Close.
11. Click <>universalPanel.
12. On the Source pane toolbar, click the Show the properties of universalPanel icon.
13. On the Component Properties: universalPanel dialog box, in the Sub Header field, select Expression Builder.
14.On the Expression Editor dialog box, in the Type a value or expression field, enter this expression:

#{pageFlowScope.pgmName} - #{pageFlowScope.LifeEventName}

15. Click OK.
16.On the Component Properties: universalPanel dialog box, click Apply.
17. Click OK.
18.To render your changes, on the page, click Close.
19. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
20.To publish your changes, on the <YourSandboxName> menu, select Publish.

Add the Life Event after the Program or Plan Not in
Program Name on the Enrollment Confirmation Page
Subheader  
To provide additional context in the subheader of the enrollment confirmation page, you can add the life event after the
program or plan not in program name.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page the enrollment confirmation page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Expand the Source pane.
8. Click the program or plan not in program name in the page header.
9. On the Confirm Shared Component Edit dialog box, click Edit.
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10. In the Source pane, scroll up to <>simplePanel and click Close.
11. Click <>universalPanel.
12. On the Source pane toolbar, click the Show the properties of universalPanel icon.
13. On the Component Properties: universalPanel dialog box, in the Sub Header field, select Expression Builder.
14.On the Expression Editor dialog box, in the Type a value or expression field, append this expression:

 - #{pageFlowScope.LifeEventName}

15. Click OK.
16.On the Component Properties: universalPanel dialog box, click Apply.
17. Click OK.
18.To render your changes, on the page, click Close.
19. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
20.To publish your changes, on the <YourSandboxName> menu, select Publish.

Add the Person Number after Person Name on the
Benefits Summary Page Subheader  
To help benefits administrators identify the correct person, you can add the person number after the person name in
the Benefits Summary page subheader.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page the Benefits Summary page in the Benefits Service Center.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Expand the Source pane.
8. Click the person name in the page header.
9. On the Confirm Shared Component Edit dialog box, click Edit.
10. In the Source pane, scroll up to <>simplePanel and click Close.
11. Click <>universalPanel.
12. On the Source pane toolbar, click the Show the properties of universalPanel icon.
13. On the Component Properties: universalPanel dialog box, in the Sub Header field, select Expression Builder.
14.On the Expression Editor dialog box, in the Type a value or expression field, append this expression:

 - #{pageFlowScope.configurationMap.PersonNumber}

The full expression should be:
#{pageFlowScope.configurationMap.PersonName} - #{pageFlowScope.configurationMap.PersonNumber}

18



Oracle Fusion Cloud Human Resources
Configuring and Extending Benefits

Chapter 4
Add Life Event and Person Details

15. Click OK.
16.On the Component Properties: universalPanel dialog box, click Apply.
17. Click OK.
18.To render your changes, on the page, click Close.
19. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
20.To publish your changes, on the <YourSandboxName> menu, select Publish.
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Add Text on the Before You Enroll Page  
To give people more information about an area of a page, such as the entire page or a specific section, you can add text.
You can't directly add the text component in the space between sections, so you start by adding it to the top component
on the page. Then you reposition and configure the component.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open Me > Benefits > Before You Enroll.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Add the text component.

a. Click the information component.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. In the Source pane, click <>panelGroupLayout, if it's not already selected.
d. On the Source pane toolbar, click the Add content into the selected component icon.
e. On the Add Content dialog box, in the Components row, click Open.
f. In the Text row, click +Add.

g. Click Close.
At this point, the text component should be added inside the information component.

8. Reposition the text component.
a. Click the new text component.
b. On the Source pane toolbar, click the Cut this component icon.
c. In the Source pane, click <>panelCollectionEdit.
d. On the toolbar, click the Paste the cut component > Paste Before icon.
e. Confirm that the new text component is now outside the information component and just above the People

to Cover section.
9. Configure the text component to show on only the People to Cover page.

a. Click the new text component.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. On the Source pane toolbar, click the Show the properties of Text icon.
d. On the Component Properties: Text dialog box, in the Show Component field, select Expression Builder.
e. On the Expression Editor dialog box, in the Type a value or expression field, enter this expression:

#{pageFlowScope.pEnrollmentFlow eq "EMPCONTACT"}

f. Click OK.
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g. On the Component Properties: Text dialog box, click Apply.
h. Click OK.

10.Configure the text of the new component.
a. On the page View menu, select Design.
b. In the new text component, click Edit Text.
c. On the Component Properties: Text dialog box, complete the required edits.
d. Click Done Editing.

11. To render your changes, on the page, click Close.
12. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
13. To publish your changes, on the <YourSandboxName> menu, select Publish.

Add Text for FSA Plans on the Enrollment Page  
To provide important context, you can add text that applies to FSA plans on the Benefits enrollment page. For example,
let people know that the amounts need to be monthly and not annual. You can't directly add the text component in the
final destination, so you start by adding it to the Coverage section. Then you reposition and configure the component.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the self-service enrollment page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Add the text component.

a. Click Coverage section
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. In the Source pane, click <>panelFormLayout, if it's not already selected.
d. On the Source pane toolbar, click the Add content into the selected component icon.
e. On the Add Content dialog box, in the Components row, click Open.
f. In the Text row, click +Add.

g. Click Close.
At this point, the text component should be added inside the information component.

8. Reposition the text component.
a. Click the new text component.
b. On the Source pane toolbar, click the Cut this component icon.
c. In the Source pane, click <>panelFormLayout.
d. On the toolbar, click the Paste the cut component > Paste Before icon.
e. Confirm that the new text component is now just above the Coverage section.
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9. Configure the text component to show for only the appropriate FSA plans.
a. Click the new text component.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. On the Source pane toolbar, click the Show the properties of Text icon.
d. On the Component Properties: Text dialog box, in the Show Component field, select Expression Builder.
e. On the Expression Editor dialog box, in the Type a value or expression field, enter the appropriate

expression. Here's an expression that shows the new text for only these two made up plans: Parking FSA
and Transportation FSA. Replace those plan names with your names.
#{epe.PlanName == 'Parking FSA' || epe.PlanName == 'Transportation FSA'}

f. Click OK.
g. On the Component Properties: Text dialog box, click Apply.
h. Click OK.

10.Configure the text of the new component.
a. On the page View menu, select Design.
b. In the new text component, click Edit Text.
c. On the Component Properties: Text dialog box, complete the required edits.
d. Click Done Editing.

11. To render your changes, on the page, click Close.
12. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
13. To publish your changes, on the <YourSandboxName> menu, select Publish.

Add Text on the Enrollment Confirmation Page  
To show additional important information, you can add text on the enrollment confirmation page. You can't directly
add the text component in the space between sections, so you start by adding it to the total cost section. Then you
reposition and configure the component.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the self-service enrollment confirmation page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
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7. Add the text component.
a. Click the total cost section.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. In the Source pane, click <>panelGroupLayout, if it's not already selected.
d. On the Source pane toolbar, click the Add content into the selected component icon.
e. On the Add Content dialog box, in the Components row, click Open.
f. In the Text row, click +Add.

g. Click Close.
At this point, the text component should be added inside the total cost section.

8. Reposition the text component.
a. Click the new text component.
b. On the Source pane toolbar, click the Cut this component icon.
c. In the Source pane, click <>panelGroupLayout.
d. On the toolbar, click the Paste the cut component > Paste Before icon.
e. Confirm that the new text component is now just above the Coverage section.

9. Configure the text of the new component.
a. On the page View menu, select Design.
b. In the new text component, click Edit Text.
c. On the Component Properties: Text dialog box, complete the required edits.
d. Click Done Editing.

10.To render your changes, on the page, click Close.
11. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
12. To publish your changes, on the <YourSandboxName> menu, select Publish.

Add Text on the Report Life Event Page  
To show additional important information in the message at the top of the page, you can add text on the Report a Life
Event page.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open Me > Benefits > Report a Life Event.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
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7. Add the text component.
a. Click the information component.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. In the Source pane, click <>panelGroupLayout, if it's not already selected.
d. On the Source pane toolbar, click the Add content into the selected component icon.
e. On the Add Content dialog box, in the Components row, click Open.
f. In the Text row, click +Add.

g. Click Close.
At this point, the text component should be added inside the information component between the predefined
header and text.

8. Configure the text component to show only in that component of the Report a Life Event page.
a. Click the new text component.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. On the Source pane toolbar, click the Show the properties of Text icon.
d. On the Component Properties: Text dialog box, in the Show Component field, select Expression Builder.
e. On the Expression Editor dialog box, in the Type a value or expression field, enter this expression:

#{attrs.type eq 'inlineInformation' and pageFlowScope.pTarget eq 'EMPEVENT'}

f. Click OK.
g. On the Component Properties: Text dialog box, click Apply.
h. Click OK.

9. Configure the text of the new component.
a. On the page View menu, select Design.
b. In the new text component, click Edit Text.
c. On the Component Properties: Text dialog box, complete the required edits.
d. Click Done Editing.

10.To render your changes, on the page, click Close.
11. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
12. To publish your changes, on the <YourSandboxName> menu, select Publish.

Add Text for Only People in a Specific Legislation, on the
Report Life Event Page  
To show additional information for only people in a specific legislation, you can enter additional message text on the
Report a Life Event page.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open Me > Benefits > Report a Life Event.
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4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Expand the Source pane.
8. Click the information component.
9. On the Confirm Shared Component Edit dialog box, click Edit.
10. In the Source pane, click <>HcmMessage, if it's not already selected.
11. On the Source pane toolbar, click the Show the properties of HcmMessage icon.
12. On the Component Properties: HcmMessage dialog box, Display Options tab, in the Additional Text field, select

Expression Builder.
13. On the Expression Editor dialog box, in the Type a value or expression field, enter the appropriate expression.

Here's an expression that tells people in the GB legislation that they can't report a future-dated event.
#{sessionScope.BEN_LegislationCode eq 'GB' ? 'You can't report an event with a future date. For more info,
 read all of your benefits policies or contact your benefits administrator.' : ''}

14.Click OK.
15. On the Component Properties: HcmMessage dialog box, click Apply.
16.Click OK.
17. To render your changes, on the page, click Close.
18.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
19. To publish your changes, on the <YourSandboxName> menu, select Publish.
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6  Change Text, Task Names, and Icons

Change the Business Intelligence Publisher Template for
the Enrollment Summary Report  
To make the enrollment summary report more meaningful, you can change the delivered RTF template.

Use this link to learn how to change the delivered Oracle Business Intelligence Publisher template for the Enrollment
Summary report: http://docs.oracle.com/cd/E29505_01/fusionapps.1111/e16691/ext_bip.htm#CHDEDACG

Change Predefined Text  
To use text that's more meaningful to your people, you can change a delivered text.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Click Navigator > Configuration > User Interface Text.
4. On the User Interface Text page, in the Find field, enter the text you want to change, such as Make Changes.
5. In the Replace field, enter the text you want to use instead, such as Make Enrollments.
6. Select the applicable types with the text you want to replace, such as User Interface Text or Multipart Validation

Messages. Be sure to clear any types you don't want to replace because that reduces your work in step 8.
7. To see all replacements, click Search.
8. Review all of the search results and select Exclude for all user interface text, messages, and global menu label text

that you don't want to replace.
9. Click Replace Strings.
10.To publish your changes, on the <YourSandboxName> menu, select Publish.

Change Help Text for a Task Button  
To show hover or tooltip text that's more meaningful to your people, you can change delivered text for task buttons.

Before you start
Create a Sandbox and Make It Active

Here's what to do
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1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Click Navigator > Configuration > User Interface Text.
4. On the User Interface Text page, in the Find field, enter the text you want to change, such as Address your open

items.
5. In the Replace field, enter the text you want to use instead, such as Pending actions exist for your enrollments.
6. Select the applicable types with the text you want to replace, such as User Interface Text or Multipart Validation

Messages. Be sure to clear any types you don't want to replace because that reduces your work in step 8.
7. To see all replacements, click Search.
8. Review all of the search results and select Exclude for all user interface text, messages, and global menu label text

that you don't want to replace.
9. Click Replace Strings.
10.To publish your changes, on the <YourSandboxName> menu, select Publish.

Change a Task Name and Icon on the Home Page  
To make a task link more meaningful, you can change the icon and name on the home page.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to Navigator > Configuration > Structure.
4. On the Search page, click the task you want to change, for example, under Me, click Benefits.
5. On the Page tab, replace the current name, such as Benefits, with the more meaningful name, such as Employee

Benefits.
6. Optionally, replace the current icon.

a. Next to the Icon field, click the Search icon.
b. Select a replacement icon.
c. Click OK.

7. On the Search page, click Save and Close.
8. To publish your changes, on the <YourSandboxName> menu, select Publish.
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Plans, and Pages

Change Page Text for Specific Benefits Groupings  
To use text that's more meaningful, you can change page text for specific benefits groupings and leave it unchanged for
all other groupings.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page with the label you want to customization, such as My Benefits.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the Select tab, click the text you want to customize, such as Primary.
7. On the menu that appears above the text you clicked, click Edit Component.
8. On the Component Properties dialog box, in the Value field, select Expression Builder.
9. On the Expression Editor dialog box, in the Type a value or expression field, enter the expression. For example, this

expression changes the Primary label to Employee Rate for the Medical and Dental groupings. All other groupings
still show Primary.
#{(bindings.GroupName.inputValue == 'Medical' || bindings.GroupName.inputValue == 'Dental' ? 'Employee
 Rate' : bindings.PrmryRtLabel.inputValue)}

Benefits service center and self-service pages both include the Enrollment section. You can use an expression similar
to the preceding expression if you want the changes to apply to the Enrollment section of all pages. Or you can
include an equals (eq) or not equal to (ne) restriction. Here's the same example expression, but restricted to only the
benefits service center pages:

#{(bindings.GroupName.inputValue == 'Medical' || bindings.GroupName.inputValue == 'Dental' &&
 pageFlowScope.pCalledFrom eq 'BSC') ? 'Employee Rate' : bindings.PrmryRtLabel.inputValue)}

And here's the same example expression, but restricted to only benefits self-service pages:

#{(bindings.GroupName.inputValue == 'Medical' || bindings.GroupName.inputValue == 'Dental' &&
 pageFlowScope.pCalledFrom ne 'BSC') ? 'Employee Rate' : bindings.PrmryRtLabel.inputValue)}

10.Click OK.
11. On the Component Properties dialog box, click Apply.
12. Click OK.
13. To render your changes, on the page, click Close.
14.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
15. To publish your changes, on the <YourSandboxName> menu, select Publish.
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Change Page Text for Specific Benefits Plans  
To use text that's more meaningful, you can change page text for specific benefits plans and leave it unchanged for all
other plans.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page with the label you want to customization, such as My Benefits.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the Select tab, click the text you want to customize, such as Primary.
7. On the menu that appears above the text you clicked, click Edit Component.
8. On the Component Properties dialog box, in the Value field, select Expression Builder.
9. On the Expression Editor dialog box, in the Type a value or expression field, enter the expression. For example,

this expression changes the Primary label to Employee Rate for the FLXU Vision plan. All other plans still show
Primary.
#{epe.PlanName == 'FLXU Vision' ? 'Employee Rate' : (bindings.PrmryRtLabel.inputValue)}

Benefits service center and self-service pages both include the Enrollment section. You can use an expression similar
to the preceding expression if you want the changes to apply to the Enrollment section of all pages. Or you can
include an equals (eq) or not equal to (ne) restriction. Here's the same example expression, but restricted to only the
benefits service center pages:

#{epe.PlanName == 'FLXU Vision' and pageFlowScope.pCalledFrom eq 'BSC'? 'Employee Rate' :
 (bindings.PrmryRtLabel.inputValue)}

And here's the same example expression, but restricted to only benefits self-service pages:

#{epe.PlanName == 'FLXU Vision' and pageFlowScope.pCalledFrom ne 'BSC'? 'Employee Rate' :
 (bindings.PrmryRtLabel.inputValue)}

10.Click OK.
11. On the Component Properties dialog box, click Apply.
12. Click OK.
13. To render your changes, on the page, click Close.
14.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
15. To publish your changes, on the <YourSandboxName> menu, select Publish.
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Change Enrollment Page Text Below Enterable Coverage
for a Specific Plan  
To make the Enrollment page text below enterable coverage for a specific plan more meaningful, you can change the
text.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the Enrollments page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Expand the Source pane.
8. Let yourself select and change components in the Source pane <>panelGroupLayout set.

a. On the Enrollments page, click the Coverage section.
b. On the Confirm Shared Component Edit dialog box, click Edit.
c. In the Source pane, above <>panelGroupLayout, click the <>panelFormLayout component.
d. On the Source pane toolbar, click the Show the properties of panelFormLayout icon.
e. On the Component Properties: panelFormLayout dialog box, Child Components tab, in the first row, select

the vertical check box.
f. Click Apply.

g. Click OK.
9. Hide the existing text for the specific plan.

a. In the <>panelGroupLayout component, click <>outputFormatted.
b. On the Source pane toolbar, click the Show the properties for outputFormatted icon.
c. On the Component Properties: outputFormatted dialog box, in the Show Component field, select

Expression Builder.
d. On the Expression Editor dialog box, in the Type a value or expression field, append the expression to hide

the text component for a specific plan. Here's an expression that hides the text for the PAN_BNFC_PL plan:
(epe.PlanName!=PAN_BNFC_PL)

e. Click OK.
f. On the Component Properties dialog box, click Apply.

g. Click OK.
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10.Add a text component for the plan-specific text.

a. In the Source pane, click the <>panelGroupLayout component.
b. On the Source pane toolbar, click the Add content into the selected component icon.
c. On the Add Content dialog box, in the Components row, click Open.
d. In the Text row, click +Add.
e. Click Close.
f. On the Source pane toolbar, use the cut and paste icons to position the new text component under the

<>outputFormatted component with the revised expression.
11. Make the text component visible for the specific plan.

a. In the Source pane, select the new text component.
b. On the toolbar, Show the properties for text icon.
c. On the Component Properties: Text dialog box, in the Show Component field, select Expression Builder.
d. On the Expression Editor dialog box, in the Type a value or expression field, append the expression to

make the text component visible for a specific plan. Here's an expression that makes the text visible for the
PAN_BNFC_PL plan:
#(epe.PlanName==PAN_BNFC_PL*?true:false)

e. Click OK.
f. On the Component Properties dialog box, click Apply.

g. Click OK.
12. Enter the text to show for the specific plan.

a. On the View menu, select Design.
b. On the Add Content tab, click the newly added text component.
c. Click Edit Text.
d. Enter the plan-specific text.
e. Click OK.

13. To render your changes, on the page, click Close.
14.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
15. To publish your changes, on the <YourSandboxName> menu, select Publish.

Change the Text at the Top of the Benefits Page  
You can show different messages at the top of the Benefits page for specific audiences, such as a special message for
new hires and the unaltered message for everyone else.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to Me > Benefits.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
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6. On the View menu, select Source.
7. Select the message at the top of the page.
8. On the Confirm Shared Component Edit dialog box, click Edit.
9. On the Source pane toolbar, click the Show the properties of Review your benefits package and relevant info

before you enroll icon.
10.On the Component Properties dialog box, in the Value field, select Expression Builder.
11. On the Expression Editor dialog box, in the Type a value or expression field, enter the expression. For example,

this expression shows new hires the message New Hire Benefits Enrollment. Everyone else sees the unaltered
message.
#{pageFlowScope.configurationMap.newHireFlag eq 'N' ?
 HcmBenefitsTopGenBundle['OText.Reviewyourbenefitspackageandrelevantinfo'] : 'New Hire Benefits Enrollment'}

Here's how you can append text to the message, rather than showing an entirely different message to new hires:

#{HcmBenefitsTopGenBundle['OText.Reviewyourbenefitspackageandrelevantinfo']}
 #{pageFlowScope.configurationMap.newHireFlag ne 'N'? 'New Hire Benefits Enrollment':''}

12. Click OK.
13. On the Component Properties dialog box, click Apply.
14.Click OK.
15. To render your changes, on the page, click Close.
16.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
17. To publish your changes, on the <YourSandboxName> menu, select Publish.

Change the Time Zone Text on the Benefits
Confirmation Page  
To make it more meaningful, you can change the time zone message on the Benefits self-service Confirmation page.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the self-service Benefits enrollment Confirmation page.
4. On the Settings and Actions menu, click Edit Pages.
5. On the Edit Pages dialog box, in the Site row, select Edit.
6. Confirm that the edit page header has Edit Layer: Site - SITE.
7. On the View menu, select Source.
8. Click the time zone text.
9. On the Confirm Shared Component Edit dialog box, click Edit.
10.On the Source pane toolbar, click the Show the properties of outputFormatted.
11. On the Component Properties: outputFormatted dialog box, in the Value field, select Select Text Resource.
12. On the Select Text Resource dialog box, click +Create.
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13. Enter a Key for the replacement text.
14.Enter the replacement text in the Display Value field.
15. Click Use.
16.Click OK.
17. On the Component Properties dialog box, click Apply.
18.Click OK.
19. To render your changes, on the page, click Close.
20.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
21. To publish your changes, on the <YourSandboxName> menu, select Publish.
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8  Hide UI Elements

Disable the Edit Button for Plan Type Grouping on Self-
Service Benefits Pages  
Benefits administrators also have the Employee role. They need to be able to edit a plan type grouping, such as Health
and Welfare, in the Benefits Service Center. But they shouldn't be able to edit the groupings from their self-service
Benefits pages. To limit this editing, you can disable the Edit button on the self-service pages.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to Me > Benefits > Enrollment.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Click a plan type grouping Edit button.
8. On the Confirm Shared Component Edit dialog box, click Edit.
9. On the Source pane toolbar, click the Show the properties for Edit icon.
10.On the Component Properties: Edit dialog box, in the Disabled field, select Expression Builder.
11. On the Expression Editor dialog box, in the Type a value or expression field, enter this expression:

#{securityContext.userInRole['ORA_BEN_BENEFITS_ENROLLMENT_MAINTENANCE_DUTY'] and
 (pageFlowScope.configurationMap.pCalledFrom ne 'BSC')}

12. Click OK.
13. On the Component Properties dialog box, click Apply.
14.Click OK.
15. To render your changes, on the page, click Close.
16.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
17. To publish your changes, on the <YourSandboxName> menu, select Publish.

Hide a Field  
To keep a page clean and help people focus on important information, you can hide fields that people don't use.

1. Click My Client Groups.
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2. In the Quick Actions area, click HCM Experience Design Studio. The action creates a sandbox and activates it before
opening the studio.

3. On the HCM Experience Design Studio page, click the Transaction Design Studio tab.
4. In the Actions field, select the page with the field you want to hide. For example, you want to hide fields on the New

Contact page, so you select Family and Emergency Contacts.
5. To add a rule for the page, click Add
6. In the Available Attributes section, Data Source field, select the section with the fields you want to hide, such as

Additional Info on Create page.
7. In the row with the field you want to hide, such as Plan and Covered by another plan?, change Visible to Not

visible.
8. Click Save and Close.
9. On the HCM Experience Design Studio page, click Done.
10.Open the changed page, such as New Contact, and verify that it looks correct.
11. To publish your changes, on the DESIGN_STUDIO_AUTO_CREATED_SB menu, select Publish.

Hide a Quick Action  
To keep the Home page clean and help people find relevant quick actions, you can hide quick actions that people don't
use.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to Navigator > Configuration > Structure.
4. On the Structure page, click the appropriate node, such as Me.
5. On the Edit Group page, click the Quick Actions tab.
6. Expand the appropriate node, such as Benefits.
7. Click the quick action you want to hide, such as Need Help? Contact Us.
8. On the Edit Quick Action dialog box, in the Visibile field, select No.
9. Click Save and Close.
10.On the Structure page, click Save and Close.
11. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
12. To publish your changes, on the <YourSandboxName> menu, select Publish.

Hide a Quick Action for People with a Specific Role  
To prevent some benefits administrators from completing certain actions, you can hide the quick action from them.
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Before you start

1. Create a custom job role.
2. Create a data role for the new job role.
3. Attach the new data role to the person you'll be signing in as.
4. Sign in as the person with the new data role.
5. Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to Navigator > Configuration > Structure.
4. On the Structure page, click the appropriate node, such as My Client Groups.
5. On the Edit Group page, click the Quick Actions tab.
6. Expand the appropriate node, such as Benefits.
7. Click the quick action you want to hide, such as People to Cover.
8. On the Edit Quick Action dialog box, in the Visibile field, select Expression Builder.
9. On the Expression Editor dialog box, in the Type a value or expression field, enter the appropriate expression. This

example expression hide the quick action from the fictious SS_BEN_DATA_ROLE_DATA data role:
#{Profile.values.BEN_ADMINISTRATIVE_ENROLLMENT_RESPONSIVE_ENABLED eq 'Y' and
 Profile.values.HCM_RESPONSIVE_PAGES_ENABLED eq 'Y' and securityContext.userInRole['SS_BEN_DATA_ROLE_DATA']}

10.Click OK.
11. Click Save and Close.
12. On the Structure page, click Save and Close.
13. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
14.To publish your changes, on the <YourSandboxName> menu, select Publish.

Hide a Page Section  
When a certain section of a page isn't relevant for the people who use the page, you can hide the section.

1. Click My Client Groups.
2. In the Quick Actions area, click HCM Experience Design Studio. The action creates a sandbox and activates it before

opening the studio.
3. On the HCM Experience Design Studio page, click the Transaction Design Studio tab.
4. In the Actions field, select the page with the section you want to hide. For example:

◦ To hide the dashboard on the Benefits Service Center landing page, select Benefits Service Center

◦ To hide the Beneficiary Organizations section on the Before You Enroll page, select Before You Enroll.

5. To add a rule for the page, click Add
6. In the appropriate Page Attributes section, Visibility field for the section you want to hide, such as My Dashboard or

Beneficiary Organizations, select Not Visible.
7. Click Save and Close.
8. On the HCM Experience Design Studio page, click Done.
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9. Open the changed page, such as Benefits Service Center or People to Cover, and verify that it looks correct.
10.To publish your changes, on the DESIGN_STUDIO_AUTO_CREATED_SB menu, select Publish.

Hide the Authorization Section on the Benefits
Enrollment Confirmation Page  
If your policies don't require people electronically authorization their enrollment confirmation, you can hide the
Authorization section on the confirmation page.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the self-service enrollment Confirmation page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Click the section with the Authorization header.
8. On the Confirm Shared Component Edit dialog box, click Edit.
9. On the Source pane toolbar, click the Show the properties of sectionHeader icon.
10.On the Component Properties: sectionHeader dialog box, in the Show Component field, select Expression Builder.
11. On the Expression Editor dialog box, in the Type a value or expression field, enter false.
12. Click OK.
13. On the Component Properties: New HTML Markup dialog box, click Apply.
14.Click OK.
15. To render your changes, on the page, click Close.
16.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
17. To publish your changes, on the <YourSandboxName> menu, select Publish.

Hide Buttons for People with a Specific Role  
To let some benefits administrators only view a page, you can hide the buttons from them. You can also hide the
buttons on some section headers of a page and leave them on other section headers.

Before you start

1. Create a custom job role.
2. Create a data role for the new job role.
3. Attach the new data role to the person you'll be signing in as.
4. Sign in as the person with the new data role.
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5. Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page with the buttons you want to hide. For example, you go to the Benefits Summary page to

hide the +Add button on the Potential Life Events section.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Hide a button.

a. On the Structure tab, click the button you want to hide, such as the +Add button on the Potential Life
Events section header.

b. On the Confirm Shared Component Edit dialog box, click Edit.
c. On the Source pane toolbar, click the Show the properties of... icon, such as Show the properties of Add.
d. On the Component Properties dialog box, in the Show Component field, select Expression Builder.
e. On the Expression Editor dialog box, in the Type a value or expression field, append the expression to hide

the button from people with the specified role. Here's the expression that hides the button from people with
the SS_BEN_BENEFITS_ADMINISTRATOR_JOB role.
 !securityContext.userInRole['SS_BEN_BENEFITS_ADMINISTRATOR_JOB']

Here's an example of what the complete expression would be to hide the +Add button on the Potential Life
Events section header of the Benefits Summary page:

#{bindings.BenefitRelSystemCd=='BEN_OAB' and | !
securityContext.userInRole['SS_BEN_BENEFITS_ADMINISTRATOR_JOB']

f. Click OK.
g. On the Component Properties dialog box, click Apply.
h. Click OK.

8. Optionally remove extra space under the section header that you removed the button from, for the same set of
benefits administrators.

a. On the Structure tab, click the space you want to hide, such as the space below the Potential Life Events
section header on the Benefits Summary page.

b. On the Confirm Shared Component Edit dialog box, click Edit.
c. On the Source pane toolbar, click the Show the properties of... icon, such as Show the properties of

toolbar.
d. On the Component Properties dialog box, in the Show Component field, select Expression Builder.
e. On the Expression Editor dialog box, in the Type a value or expression field, append the same expression

you used to hide the button.
f. Click OK.

g. On the Component Properties dialog box, click Apply.
h. Click OK.
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9. Optionally remove the line separator below the section header that you removed the button from, for the same set of
benefits administrators.

a. On the Structure tab, click the line separator you want to hide, such as the line below the Potential Life
Events section header on the Benefits Summary page.

b. On the Confirm Shared Component Edit dialog box, click Edit.
c. On the Source pane toolbar, click the Show the properties of... icon, such as Show the properties of

separator.
d. On the Component Properties dialog box, in the Show Component field, select Expression Builder.
e. On the Expression Editor dialog box, in the Type a value or expression field, append the same expression

you used to hide the button.
f. Click OK.

g. On the Component Properties dialog box, click Apply.
h. Click OK.

10.To render your changes, on the page, click Close.
11. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
12. To publish your changes, on the <YourSandboxName> menu, select Publish.

Hide the Delete Button  
To preserve objects, such as contacts, you can hide the Delete button on a page.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page with the Delete button you want to hide, such as the Edit Contact page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. Click the page Delete button.
8. On the Confirm Shared Component Edit dialog box, click Edit.
9. On the Source pane toolbar, click the Show the properties for Delete icon.
10.On the Component Properties: Delete dialog box, in the Show Component field, select Expression Builder.
11. On the Expression Editor dialog box, in the Type a value or expression field, enter False.
12. Click OK.
13. On the Component Properties dialog box, click Apply.
14.Click OK.
15. To render your changes, on the page, click Close.
16.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
17. To publish your changes, on the <YourSandboxName> menu, select Publish.
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Hide the Time Stamp and Zone on a Page  
To make show only dates on a page, you can remove the corresponding time stamp and zone.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page where you want to show the date without the corresponding time stamp and zone, such as

the self-service enrollment page.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. On the Structure tab, click the time stamp.
8. On the Confirm Shared Component Edit dialog box, click Edit.
9. On the Source pane toolbar, click the Show the properties of... icon, such as Show the properties of outputText.
10.On the Component Properties dialog box, unselect the Visible check box.
11. Click Apply.
12. Click OK.
13. To render the changed page, in the customization window, click Close.
14.To render your changes, on the page, click Close.
15. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
16.To publish your changes, on the <YourSandboxName> menu, select Publish.
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9  Control Display of Fields

Make a Field Visible  
To show important information on a page, you can make hidden fields visible. For example, people need to see who
created enrollment results and when, or who last updated the results and when. Or they might need to see the legal
employer.

1. Click My Client Groups.
2. In the Quick Actions area, click HCM Experience Design Studio. The action creates a sandbox and activates it before

opening the studio.
3. On the HCM Experience Design Studio page, click the Transaction Design Studio tab.
4. In the Actions field, select the page with the field you want to make visible. For example, you want to show general

information fields on the Enrollment Results page, so you select Benefits Service Center.
5. To add a rule for the page, click Add
6. In the Available Attributes section, Data Source field, select the page with the fields you want to show, such as

Enrollment Results.
7. In the row with the field you want to show, such as Created By and Creation Date, change Not visible to Visible.
8. Click Save and Close.
9. On the HCM Experience Design Studio page, click Done.
10.Open the changed page, such as Enrollment Results, and verify that you can see the appropriate fields.
11. To publish your changes, on the DESIGN_STUDIO_AUTO_CREATED_SB menu, select Publish.

Make an Optional Field Required and a Required Field
Optional  
To support your policies that contradict the implemented field state, you can change optional fields to make them
required. You can also change required fields to make them optional.

1. Click My Client Groups.
2. In the Quick Actions area, click HCM Experience Design Studio. The action creates a sandbox and activates it before

opening the studio.
3. On the HCM Experience Design Studio page, click the Transaction Design Studio tab.
4. In the Actions field, select the page with the field you want to hide. For example, you want to make optional fields on

the New Contact page required, so you select Family and Emergency Contacts.
5. To add a rule for the page, click Add
6. In the Available Attributes section, Data Source field, select the section with the fields you want to make required or

optional, such as Additional Info on Create page.
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7. In the row with the optional field you want to make required, such as Student Status and Disability Type, change
Not required to Required.
In the row with the required field you want to make optional, change Required to Not required

8. Click Save and Close.
9. On the HCM Experience Design Studio page, click Done.
10.Open the changed page, such as New Contact, and verify that the fields correctly indicate whether they're required.
11. To publish your changes, on the DESIGN_STUDIO_AUTO_CREATED_SB menu, select Publish.
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10  Make Country-Specific Changes

Make a Field Required for a Specific Country by Editing
the Country Layer  
To make changes that apply to everyone in a specific country, you can make country-level customizations. For example,
you want to make the Date of Birth field required for anyone in the US adding or editing a contact. For all other
countries, the field remains optional. Here's how you can make those changes using a country-specific sandbox.

Before you start
Create a Sandbox and Make It Active. Be sure to follow the steps to set up the sandbox for the appropriate country.

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox with the Page Composer tool active for the appropriate country.
3. Go to and open the page where you want to make the country-level change. For example, to change the New Contact

page, go to Me > Benefits > Before You Enroll. Then in the People to Cover section, click +Add.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: HCMCountry - <Country Code>.
6. On the Select tab, complete any required fields.
7. Right-click the field you want to customize, such as Date of Birth, and select Edit Component.
8. On the Component Properties dialog box, for the appropriate field, such as Required, select Expression Builder.
9. On the Expression Editor dialog box, in the Type a value or expression field, enter the appropriate expression, such

as #{true}.
10.Click OK.
11. On the Component Properties dialog box, click Apply.
12. Click OK.
13. To render your changes, on the page, click Close.
14.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
15. To publish your changes, on the <YourSandboxName> menu, select Publish.

Make a Field Required for a Specific Country by Using
Country Codes in the Expression  
To make changes that apply to everyone in a specific country, you can make country-level customizations. For example,
you want to make the Date of Birth field required for anyone in the UK adding or editing a contact. For all other
countries, the field remains optional. Here's how you can make those changes using a country code in the expression.

Before you start
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Create a Sandbox and Make It Active. Be sure to follow the steps to set up the sandbox for site-level changes and not
country-specific changes.

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page where you want to make the country-level change. For example, to change the New Contact

page, go to Me > Benefits > Before You Enroll. Then in the People to Cover section, click +Add.
4. On the Settings and Actions menu, click Edit Pages.
5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the Structure tab, select the field that you want to customize, such as Date of Birth.
7. On the Confirm Shared Component Edit dialog box, click Edit.
8. On the Source pane, click the Show the properties of... icon, such as Show the properties of inputDate or Show

the properties of inputText.
9. On the Component Properties dialog box, for the appropriate field, such as Required, select Expression Builder.
10.On the Expression Editor dialog box, in the Type a value or expression field, enter the appropriate expression.

Here's the expression to make the field required for people in the UK:
#{row.bindings.DateOfBirth.hints.mandatory or (sessionScope.BEN_CountryCode eq 'UK' ? true : false)}

11. Click OK.
12. On the Component Properties dialog box, click Apply.
13. Click OK.
14.To render your changes, on the page, click Close.
15. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
16.To publish your changes, on the <YourSandboxName> menu, select Publish.

Change a Task Tile Name for a Specific Country by Using
Country Codes in the Expression  
To change the name of a task tile for everyone in a specific country, you can make country-level customizations. For
example, you want to change the Before You Enroll task tile name on the My Benefits page to Your Contacts and
Beneficiary Organizations for anyone in the US. For all other countries, the name remains Before You Enroll. Here's how
you can change the name using a country code in the expression.

Before you start
Create a Sandbox and Make It Active. Be sure to follow the steps to set up the sandbox for site-level changes and not
country-specific changes.

Here's what to do

1. Go to Navigator > Configuration > Sandboxes.
2. Enter your sandbox.
3. Go to and open the page where you want to make the country-level change. For example, to change the New Contact

page, go to Me > Benefits.
4. On the Settings and Actions menu, click Edit Pages.
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5. Confirm that the edit page header has Edit Layer: Site - SITE.
6. On the View menu, select Source.
7. On the Structure tab, select the task tile name that you want to change, such as Before You Enroll.
8. On the Confirm Shared Component Edit dialog box, click Edit.
9. To make the Show the properties of taskButton icon available, expand the Source pane and select

<>taskButton[Close]. Initially, only the Close part of the row is selected and you can't click the icon.
10.On the Source pane, click the Show the properties of taskButton icon.
11. On the Component Properties: taskButton dialog box, in Text field, select Expression Builder.
12. On the Expression Editor dialog box, in the Type a value or expression field, enter the appropriate expression.

Here's the expression to change the name Before You Enroll to Your Contacts and Beneficiary Organizations for
people in the US:
#{pageFlowScope.pageTitle eq 'Benefits' and row.label eq 'Before You Enroll' and
 sessionScope.BEN_LegislationCode eq 'US' ? 'Your Contacts and Beneficiary Organizations.' : row.label}

13. Click OK.
14.On the Component Properties dialog box, click Apply.
15. Click OK.
16.To render your changes, on the page, click Close.
17. To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
18.To publish your changes, on the <YourSandboxName> menu, select Publish.

47



Oracle Fusion Cloud Human Resources
Configuring and Extending Benefits

Chapter 10
Make Country-Specific Changes

48



Oracle Fusion Cloud Human Resources
Configuring and Extending Benefits

Chapter 11
Troubleshooting

11  Troubleshooting

Remove UI Configuration Changes from a Page  
To remove all of the configurations and extensions that you published, you can reset a page.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Go to and open the page with the customizations you want to remove, such as Me > Benefits > Review Employee
Resources.

2. On the Settings and Actions menu, click Edit Pages.
3. Confirm that the edit page header has Edit Layer: Site - SITE.
4. On the View menu, select Source.
5. On the Structure tab, select any component on the page.
6. On the Source pane toolbar, click Reset Task Flow.
7. After the reset completes, click Close.
8. To publish your changes, on the <YourSandboxName> menu, select Publish.

Delete Erroneous UI Configuration Changes That Prevent
the Page from Rendering  
To fix customized pages that aren't rendering, you can remove configurations and extensions with syntactical errors
that were accidentally published.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. On the Settings and Actions menu, click Manage Configurations.
2. On the Manage Configurations dialog box, in the Search field, search for the appropriate /oracle/apps/hcm/

benefits/ file. For example, the Enrollment Summary page file is /oracle/apps/hcm/benefits/selfService/ui/
page/EnrollmentSummary.jsff. The My Benefits page file is /oracle/apps/hcm/homePage/fuse/PublicUi/
commonMenu/page/HcmCommonLandingPage.jsff.

3. Optionally backup the file to keep a copy of valid UI configuration changes by downloading the current file.
4. Click Delete.
5. Click Close.
6. To publish your changes, on the <YourSandboxName> menu, select Publish.
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Delete User-Level UI Configuration Changes Affecting
Visibility of Customizations  
If not everyone can see published customizations, there might be unintentional personalization. To make published
configurations and extensions available to everyone, you need to remove unwanted user-level personalization.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. On the Settings and Actions menu, click Manage Configurations.
2. On the Manage Configurations dialog box, in the Search field, search for the relevant /oracle/apps/hcm/benefits/

page. For example, only some people can see the customizations on the Enrollment Summary page, so you search
for /oracle/apps/hcm/benefits/selfService/ui/page/EnrollmentSummary.jsff

3. In the Layer Name field, select User.
4. Click Delete.
5. Click Close.
6. To publish your changes, on the <YourSandboxName> menu, select Publish.

Fix Benefits Navigation Issue After Upgrading from
Release 12 to Release 13  
After upgrading from Release 12 to Release 13, the Benefits icon might not render. And, you might get an invalid web
app exception that prevents you from changing the node when you click the Benefits link in your sandbox. Your UI
configuration changes are upgrade safe. So any changes done in Release 12 to control visibility of the Benefits card
might prevent the upgrade of the root_menu.xml file in Release 13. The prevention can cause navigation failure. Here's
how you can fix this issue.

Before you start
Create a Sandbox and Make It Active

Here's what to do

1. Enter your sandbox.
2. Go to Navigator > Configuration > Sandboxes.
3. On the Settings and Actions menu, click Manage Configurations.
4. On the Manage Configurations dialog box, in the Search field, enter /oracle/apps/menu/root_menu.xml.
5. In the /oracle/apps/menu/root_menu.xml row, Current Context Site column, click Download.
6. In the downloaded file, search for this string:

itemNode_my_information_benefits
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7. Replace the file values with these values wherever there's a discrepancy:
secureResourceName="/WEB-INF/oracle/apps/hcm/benefits/elections/ui/flow/SsbenLauncher.xml#SsbenLauncher"
focusViewId="/FndOverview"
webApp="ORA_HCM_UI"
applicationStripe="hcm"
mobileEnabled="true"

8. Upload your modified /oracle/apps/menu/root_menu.xml. Here's what to do if you don't see an Upload link for
the file:

a. Ask Oracle Support to run the scripts that update the FND_ALLOW_MANUAL_METADATA_UPDATES
profile option value.

b. After Oracle Support finishes, on the Settings and Actions menu, click Setup and Maintenance.
c. On the Tasks panel tab, click Search.
d. On the Search page search for and go to the Manage Administrator Profile Value task.
e. On the Manage Administrator Profile Values page, search for the

FND_ALLOW_MANUAL_METADATA_UPDATES profile option code.
f. In the Site row, Profile Value field, select Yes.

g. Click Save and Close.
h. Try uploading your modified file again using steps 1 – 4 and 8.

9. To render your changes, on the page, click Close.
10.To verify your changes, on the Sandbox Mode: Edit menu, select Preview as if Published (Context: All).
11. To publish your changes, on the <YourSandboxName> menu, select Publish.

Troubleshoot Issues with Benefits UI Configuration
Changes  
Here are some Benefits UI configuration issues that you may encounter and solutions to help you fix them.

Solutions for Possible UI Configuration Issues

Issue Solution

Can't create a sandbox. Make sure you have the Application Implementation Consultant (ORA_ASM_APPLICATION_
IMPLEMENTATION_CONSULTANT_JOB) job role

Can't edit any Structure menu items. Make sure you've entered an active sandbox.

Expression language for the FSCM URL
not working as expected to hide the
Enrollment task for specific benefits
administrators. It works fine when the URL
changes to HCM.

Create another job role in the HCM stripe and use this expression language:
{!securityContext.userInRole['ORA_BEN_BENEFITS_ADMINISTRATOR_JOB,ORA_BEN_
BENEFITS_ADMINISTRATOR_JOB_HCM']}

Bind variable '${PERSONID}' isn't getting
passed to the inline query or Exist clause
in the benefitEnrollmentOpportunities
resource.

In the Resource alerts filter expressions use qrslt.PersonId instead of ${PersonId}.

My Benefits landing page doesn't have any
task tiles.

Check whether the Benefits group node visibility is set to No by following these steps:
1. Go to Navigator > Structure.
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Issue Solution

2. Click Me.
3. On the Quick Actions tab, click Benefits.
4. Check the Visibility setting. If it isn't already, set it to Yes.

Benefits task isn't visible on the Person
spotlight menu.

If you're using a custom role, create and attach a data security policy where you grant access for PER_
REPORT_PERSON_DATA on PER_ALL_PEOPLE_F.

Automatically rendered page buttons,
 such as Continue,Save, andSubmit aren't
visible.

Delete the UI configuration changes made to /oracle/apps/fnd/applcore/patterns/ui/
components/SimplePanel.jspx using the steps in the Delete Erroneous UI Configuration Changes
That Prevent the Page from Rendering topic of this chapter.

Can I configure the Continue button to
show for only started life events?

The Continue button is enable when a life event is evaluated and has theses statuses: Started,
 Detected, and Unprocessed. The button can't be changed to show any other text for the started life
events. Also, simplePanel changes made to both the Continue and Cancel buttons appear on other
pages too. For more information, see bug 20626162.

Enroll button isn't visible on the Benefits
Summary page of the Benefits Service
Center.

Delete the UI configuration changes made to /oracle/apps/hcm/hcmHomePage/publicUi/page/
HcmMessageDC.jspx using the steps in the Delete Erroneous UI Configuration Changes That Prevent
the Page from Rendering topic of this chapter.

Scoreboard isn't visible in Benefits Service
Center.

Delete the UI configuration changes made to /oracle/apps/hcm/hcmHomePage/publicUi/page/
ScoreBoard.jspx using the steps in the Delete Erroneous UI Configuration Changes That Prevent the
Page from Rendering topic of this chapter.

Add Contact or Edit Contact page displays
an error.

If you're using a custom role, be sure to add the Access Family and Emergency Contacts by Worker
(ORA_PER_PERSON_CONTACT_DETAILS_VIEW_DUTY) duty role. The duty role code is .

Add Contact or Edit Contact page, National
ID section isn't visible for someone with a
custom employee job role.

• Check that no UI page configuration is hiding the section.

• Check if the National ID section is visible through HCM Experience Design Studio.

• Check if the Manage Person National Identifier and View Person National Identifier roles are
attached to the custom employee role. If not, add them, regenerate the data role, and retest.

Can I make the Date of Birth and Gender
fields required on the Add Contact and
Edit Contact pages a depending on the
relationship value?

You can't conditionally mark the fields as required because of various issues, such as the page can't be
refreshed when a value changes, related to using expression language.

Notes section of responsive Benefits
Service Center pages isn't visible for some
administrators. The section is visible to
them on the classic pages.

Make sure that the administrators have an associated personId. Also make sure that any custom
administrator roles have the ORA_HRT_MANAGE_HCM_PERSON_NOTE and ORA_HRT_VIEW_HCM_
PERSON_NOTE privileges.

Getting duplicate alerts for life events. Edit the Open Enrollment Reminder alert to this condition to the existing filter:
EXISTS (select 'x' from per_email_addresses padd where padd.person_id =
 qrslt.PersonId AND
 padd.email_type='W1' AND padd.email_address not in (select null from
 fusion.hrc_alert_run_recipients
 hrrep where hrrep.run_message_id in (select hrmsg.run_message_id from
 fusion.hrc_alert_run_messages
 hrmsg where hrmsg.run_id in (select hruns.run_id from fusion.hrc_alert_runs
 hruns where hruns.alert_id
 in (select distinct alert_id from fusion.hrc_alerts_tl where name like 'Open
 Enrollment Reminder'))))).

Then save your changes.
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