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Profiler

Profiler is one of Oracle Eloqua's Sales Tools. It presents valuable information about

contacts in an easily accessible and data-rich format that can be viewed on desktop

computers, tablets, and mobile devices.

With Profiler, you're able to view the contact details for a potential customer, their

activities, lead score, and so on. It is designed specifically for use with iOS and Android

devices, giving marketers and sales reps the option to access Oracle Eloqua's Profiler

functionality from their mobile devices when they are on-the-go.

See examples of Profiler's responsive design on desktop:

Learn more by watching this video: https://www.youtube.com/playlist?list=PLw7GyH-

Hj8cPP6TQfGeDGUYv4Py9k_EwQ

ëNote: Before you can access Profiler, an Eloqua administrator must install the app

in your Oracle Eloqua instance. Once installed, the customer administrator can

https://docs.oracle.com/cloud/latest/marketingcs_gs/OMCAA/index.html#CSHID=SalesTools
https://www.youtube.com/playlist?list=PLw7GyH-Hj8cPP6TQfGeDGUYv4Py9k_EwQ
https://www.youtube.com/playlist?list=PLw7GyH-Hj8cPP6TQfGeDGUYv4Py9k_EwQ
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customize the options that Profiler provides. Learn more about installing and

configuring Profiler.
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Installing Profiler

Before you can use Profiler a user with client administrator rights must install the app and

configure the settings for your Eloqua instance.

ZImportant: Because deleting or deactivating the installer user account will impact

installed apps, we recommend installing apps using a user account that is not tied

to a specific person. The user account must have customer administrator rights.

To install the Profiler app:

1. Follow the Profiler installation URL provided:

https://login.eloqua.com/?ReturnUrl=Apps/Cloud/Admin/Catalog/Add/512cc250-bf75-4b64-

98c2-9ce3858a18e1/D3-01-E2-AB-6C-23-36-17-7C-B1-44-49-89-11-D0-C3

2. Log in with your Eloqua credentials, if required.

3. Click Accept and Install to add the app to your Apps list.

4. Confirm your credentials and click Sign In.

https://login.eloqua.com/?ReturnUrl=Apps/Cloud/Admin/Catalog/Add/512cc250-bf75-4b64-98c2-9ce3858a18e1/D3-01-E2-AB-6C-23-36-17-7C-B1-44-49-89-11-D0-C3
https://login.eloqua.com/?ReturnUrl=Apps/Cloud/Admin/Catalog/Add/512cc250-bf75-4b64-98c2-9ce3858a18e1/D3-01-E2-AB-6C-23-36-17-7C-B1-44-49-89-11-D0-C3
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5. Configure Profiler:

Settings

a. Email alerts: Allow users to create email notifications for contact web visits.

b. Thumbnail previews: Allows users to see a thumbnail preview of marketing assets associated to a

contact's activity.
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c. Search: Allows users to search for contacts in Profiler by contact fields (name, email address, domain,

etc.). Otherwise, users can only search by email address.

d. Subscriptions: Allows users to view the email address of contacts that have globally unsubscribed.

Users cannot email these contacts and a visual indicator indicates the contact's global subscription

status. Otherwise, users cannot view the email address of such contacts.

e. External activity: Allows users to see external activities in Profiler. Choose the external activity assets

that should be visible to users.

Social Field Mappings

a. The Social Field Mapping section allows you to specify the social network account links available in

Profiler as part of the contact summary. Profiler will build the links to the social network site using the

mapped contact field. To link to social network sites, choose the contact field that should be used for

each social network.

Apps

a. View and search installed Profiler apps.
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App Access

a. Select the security groups which should have access to the Profiler app.

ëNote: Users must log out of Eloqua for Eloqua security group changes to take effect.

Allowed Domains

a. Identify which domains are allowed to host Sales Tools pages. For example, if you embed Sales

Tools in an iframe hosted by your CRM, add the domain of the page hosting the iframe to your

allowlist. You can allow a domain and its sub-domains using a wildcard (*).

To avoid broken iframes, add your CRMs to the Profiler allowlist and Engage allowlist, and update the

Sales Tools URLs you have embedded in an iframe to the new URLs. Here is a list of suggested

domains for the allowlist based on CRMs:

l Salesforce: *.force.com, *.salesforce.com, *.my.salesforce.com, *.lightning.force.com, and

*.visualforce.com

l Oracle CX Sales: *.oraclecloud.com

l Oracle CRM On Demand: *.crmondemand.com

l Microsoft Dynamics: *.dynamics.com

To learn more about embedding Profiler in different CRMs, see Profiler integration.

6. Click Accept or switch users.

SecurityGroups.htm
https://docs.oracle.com/en/cloud/saas/marketing/eloqua-user/index.html#cshid=ReconfiguringProfiler
https://docs.oracle.com/en/cloud/saas/marketing/eloqua-user/index.html#cshid=EngageReconfiguring
https://community.oracle.com/topliners/discussion/4476431/eloqua-product-notice-sales-tools-crm-embed-changes-nov-2020-feb-2021
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The app is now installed and can be viewed in your Apps list (Settings > Apps, under

the Platform Extensions section). Select an app to view a description, modify the

configuration settings, reinstall, or uninstall it. You can also check its status and

dependencies.

You can change these configuration settings at any time. Learn more about reconfiguring

Profiler.

https://docs.oracle.com/cloud/latest/marketingcs_gs/OMCAA/index.html#CSHID=Apps
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Configuring Profiler

You can manage how users can use Profiler. For example, manage the ability to create

email alerts, what external activity assets are available for viewing, and so on. You can

also manage who has access to Profiler apps that have been installed.

ZImportant: The configuration process must be done by a user with customer

admin rights.

To configure Profiler:

1. Log in to Oracle Eloqua.

2. Click Settings .

3. Click Apps in the Platform Extensions section.

4. Select the Profiler app.

5. Click Configure .

6. Reconfigure Profiler using the following tabs as needed.

Settings

a. Email alerts: Allow users to create email notifications for contact web visits.

b. Thumbnail previews: Allows users to see a thumbnail preview of marketing assets associated to a

contact's activity.

c. Search: Allows users to search for contacts in Profiler by contact fields (name, email address, domain,

etc.). Otherwise, users can only search by email address.
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d. Subscriptions: Allows users to view the email address of contacts that have globally unsubscribed.

Users cannot email these contacts and a visual indicator indicates the contact's global subscription

status. Otherwise, users cannot view the email address of such contacts.

e. External activity: Allows users to see external activities in Profiler. Choose the external activity assets

that should be visible to users.

Social Field Mappings

a. The Social Field Mapping section allows you to specify the social network account links available in

Profiler as part of the contact summary. Profiler will build the links to the social network site using the

mapped contact field. To link to social network sites, choose the contact field that should be used for

each social network.

Apps

a. View and search installed Profiler apps.

App Access
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a. Select the security groups which should have access to the Profiler app.

ëNote: Users must log out of Eloqua for Eloqua security group changes to take effect.

Allowed Domains

a. Identify which domains are allowed to host Sales Tools pages. For example, if you embed Sales

Tools in an iframe hosted by your CRM, add the domain of the page hosting the iframe to your

allowlist. You can allow a domain and its sub-domains using a wildcard (*).

To avoid broken iframes, add your CRMs to the Profiler allowlist and Engage allowlist, and update the

Sales Tools URLs you have embedded in an iframe to the new URLs. Here is a list of suggested

domains for the allowlist based on CRMs:

l Salesforce: *.force.com, *.salesforce.com, *.my.salesforce.com, *.lightning.force.com, and

*.visualforce.com

l Oracle CX Sales: *.oraclecloud.com

l Oracle CRM On Demand: *.crmondemand.com

l Microsoft Dynamics: *.dynamics.com

To learn more about embedding Profiler in different CRMs, see Profiler integration.

7. Click Save to save your settings.

Your configuration settings have been updated. You can modify them at any time.

SecurityGroups.htm
https://docs.oracle.com/en/cloud/saas/marketing/eloqua-user/index.html#cshid=ReconfiguringProfiler
https://docs.oracle.com/en/cloud/saas/marketing/eloqua-user/index.html#cshid=EngageReconfiguring
https://community.oracle.com/topliners/discussion/4476431/eloqua-product-notice-sales-tools-crm-embed-changes-nov-2020-feb-2021
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Accessing Profiler

Work with your sales organization to determine the best method for accessing Oracle

Profiler. You can use any of the following methods:

l Integrate Profiler with your CRM

This would allow sales users to access Profiler directly from the CRM. You can embed Profiler

as a tab, link to it as a button, etc. Learn more.

l Direct link

This is a customizable link you can use to launch Profiler directly.

l Use the Oracle Eloqua Sales Tools for Microsoft Outlook add-in

This is an add-in that your users can install on their own or your IT department can deploy to an

entire organization. See Oracle Eloqua Sales Tools for Microsoft Outlook.

l Oracle Eloqua Sales Tools for Google Chrome

The Google Chrome extension allows sales representatives to access Profiler from their

Google Chrome browser. For example, while browsing prospect websites, the sales rep can

open the extension to review Eloqua contacts at that company. Reps can also access Engage

directly from the extension. Learn more.

ëNote: Before you can access Profiler, an Eloqua administrator must install the app

in your Oracle Eloqua instance. Once installed, the customer administrator can

customize the options that Profiler provides. Learn more about installing and

configuring Profiler.

Profiler URLs

To access Profiler , you can use one of the following types of URLs: 

https://docs.oracle.com/cloud/latest/marketingcs_gs/OMCAA/index.html#CSHID=SalesToolsMicrosoftOutlook
SalesToolsForGoogleChrome.htm
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l A simplified login URL that will handle all login flows based on the user logging in and your

Oracle Eloqua configuration. Using this URL, if you have SSO configured for the instance and

user, then the user will be redirected to your default identity provider login screens. If you don't

have SSO, the user will be prompted for their user name and password. Learn more.

l A legacy login URL that is specific to the desired login flow and security model at your

organization. There is a separate login URL for auto-login, SAML login, or CVP login. Auto-login

and SAML are options that support Single Sign-On (SSO). Salesforce IDP is an option for

Salesforce SSO logins. Direct login is for logging in directly through Eloqua. Learn more.

Simplified login URL

To access the Profileremail composer using the simplified login URL:

https://login.eloqua.com/siteLogin?SiteName=

{CompanyName}&ReturnUrl=/apps/salesTools/profiler

If you are embedding Profiler pages into an iframe, use the following URL. Learn more.

https://login.eloqua.com/siteLogin?SiteName=

{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler

The following table describes the supported URL parameters you can use to further

customize the login experience. In addition, you can also add additional Profiler URL

parameters to customize the compose experience. Learn more about Profiler

URL parameters.

Parameter Description
SiteName=
{company
Name}

Optional

Your instance company name. When provided, users are not prompted to

provide a company name. If the user has an existing session, they will then

#Embeddin
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Parameter Description

be logged in automatically.

Example:

https://login.eloqua.com/siteLogin?SiteName=ExampleSi

teName

ReturnUrl=
{Url}

Optional

The Oracle Eloqua URL to redirect to after logging in.

You must provide the SiteName parameter if you want to use this parameter.

Example:

Redirect to the Engage email compose page:

https://login.eloqua.com/siteLogin?SiteName=ExampleSi

teName&ReturnUrl=/apps/salesTools/engage/compose

Checkfram
e={true or
false}

Optional

Checks if the login page is being accessed from within an iframe and create

a popup window if it is.

l true checks for the frame.

l false does not check for the frame. If the result is a displayable page that cannot

be viewed in an iframe, then the user will get a block from their browser. Use only

if it can be guaranteed the current user is already authenticated with the default

SSO used by Oracle Eloqua to skip the popup.

Example:
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Parameter Description

Checkframe while logging into Engage:

https://login.eloqua.com/siteLogin?SiteName=ExampleSi

teName&CheckFrame=true&ReturnUrl=/apps/salesTools/eng

age/compose

UseDefault
SSO={true
or false}

Optional

Specifies whether or not to use the default identity provider configured for

your instance. Use this parameter if you have multiple identity providers and

want to ensure the default identity provider is used.

l true to use the default SSO

l false to prompt the user to choose the identity provider

Example:

Checkframe while logging into Engage:

https://login.eloqua.com/siteLogin?UseDefaultSSO=true

Idp=
{IdentityPr
oviderId}

Optional

The ID for the identity provider you want to use. Use this parameter if you

have multiple identity providers configured for your Oracle Eloqua instance

and you want to use a non-default identity provider. You can retrieve the

identity provider ID from the SSO identity provider screens.

You must provide the SiteName parameter if you want to use this parameter.

Example:
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Parameter Description

https://login.eloqua.com/siteLogin?SiteName=ExampleSi

teName&Idp=69627DAC73E04DE79CDFC90D132B65EA

Username
=
{username
}&Passwor
d=
{encrypted
Password}

The user name and encrypted password. The password parameter is

encrypted. To retrieve the encrypted version of the user password, you must

open a Service Request with Oracle Support.

You must provide the SiteName parameter if you want to use the user name

and password parameters.

Legacy login URLs

The following lists the legacy login URLs to access to Profiler based on the desired login

methods. These URLs continue to be supported. The URL you use depends on the

security model implemented at your organization. Auto-login and SAML are options that

support Single Sign-On (SSO). Salesforce IDP is an option for Salesforce SSO logins.

Direct login is for logging in directly through Eloqua.

The following lists the URLs to access the Profiler search page based on these login

methods:

l Direct: https://login.eloqua.com/apps/salesTools/profiler

l Embedded: https://login.eloqua.com/apps/embed/salesTools/profiler

l Autologin: https://login.eloqua.com/autoLogin?LoginPrefix={Login_

Prefix}&Url=/apps/salesTools/profiler
l Embedded: https://login.eloqua.com/autoLogin?LoginPrefix={Login_

Prefix}&Url=/apps/embed/salesTools/profiler

l SAML: https://login.eloqua.com/auth/saml2/autologin?LoginPrefix={Login_

Prefix}&ReturnUrl=/apps/salesTools/profiler
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l Embedded: https://login.eloqua.com/auth/saml2/autologin?LoginPrefix={Login_

Prefix}&ReturnUrl=/apps/embed/salesTools/profiler

l SFDC IDP: https://{podURL}/sso/sfdc/v1/svp.aspx?LP={Login_

Prefix}&RU=/apps/salesTools/profiler
l Embedded: https://{podURL}/sso/sfdc/v1/svp.aspx?LP={Login_

Prefix}&RU=/apps/embed/salesTools/profiler

Replace {podURL} with the URL in your browser after you have logged in successfully to

Eloqua (for example, secure.p01.eloqua.com). Click here for additional information about how

to determine your pod.

LoginPrefix values are a unique four-character code for your Eloqua instance. To add this

parameter to your URL, enter LoginPrefix={prefix} where {prefix} is replaced with the four-

character company name. You can obtain your company's login prefix in Eloqua by

navigating to Settings > Display Preferences > Company Defaults.

¤Tip: If you are using Microsoft Edge or Sales Tools for Microsoft Outlook to access

the Oracle Eloqua sign in page in an iframe, an addition should be made to trusted

sites. Add https://*.eloqua.com and the URL of the site where the login page

(Oracle Eloqua and/or Sales Tools) is being iframed. The browser must be closed

fully and restarted before the change is recognized. For additional information, see

this Topliners post about Oracle Eloqua login enhancements.

Embedding Profiler pages

You can embed Profiler pages into an iframe, allowing your users to access Profiler

directly from other apps at your organization. For example, embed Profiler directly into

your CRM.

https://community.oracle.com/docs/DOC-897330
https://community.oracle.com/docs/DOC-1020186
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To embed Profiler into an iframe:

1. Update the Profiler app with an allowlist of domains that will host Profiler pages. Learn more.

2. Adjust the URLs listed above to include /embed/ in the URL: 

/apps/embed/salesTools/profiler.

Learn more about Profiler integration.

Profiler URL parameters

The URLs above open Profiler to the search page. You can also directly access a

contact's record in Profiler using their email address. Simply add the following to the

URLs above, and insert the contact's email address where needed:

?emailAddress={emailAddress}

Your CRM integration can provide the email address to this URL. Learn more about

Profiler integration.
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Apps for Profiler

Apps that are available for Oracle Eloqua Profiler are built on Oracle CX Apps, which is

the extension framework that partners and customers can use to build apps that are

available for multiple applications within Oracle CX Marketing. For more information on

Oracle CX Apps, visit the Oracle CX Marketing App Manager Help Center.

In this topic, you'll learn about:

l Installing apps for Profiler

l Managing Profiler app extensions

l Restricting access to a Profiler app using Oracle Eloqua Security Groups

Installing apps for Profiler

Apps available for Profiler can be found in the Oracle Cloud Marketplace

(https://cloudmarketplace.oracle.com/marketplace/en_US/homePage.jspx). Once the

app is installed in Profiler, you'll be able to manage and configure it from within Oracle

Eloqua.

ZImportant: The configuration process must be done by a user with client

administrator rights.

Installation is a straight forward guided experience that will generally follow these

steps:

https://docs.oracle.com/cloud/latest/marketingcs_gs/OMCIA/index.htm
https://cloudmarketplace.oracle.com/marketplace/en_US/homePage.jspx
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1. Start in the Oracle Cloud Marketplace (https://cloudmarketplace.oracle.com/marketplace/en_

US/homePage.jspx) and search for the app you want to install.

2. Click on the app listing, then click the Get App button.

3. You will be prompted where you want to install the app, if it was built to be used with multiple

Oracle CX Marketing products i.e. Eloqua Sales Tools, Responsys or Maxymizer. In this case

you will be installing into one of the Sales Tools products. Pick the product where you want to

install the app.

4. Log in with your Eloqua credentials, if required.

5. Click Confirm to confirm the installation of the app into Oracle Eloqua Profiler.

Although there may be slight variances in the flow, these are generally the steps you will

experience when installing an app. After you’ve installed the app, you can review its

configuration and control its usage based on your individual needs.

Managing Profiler app extensions

Apps installed for Profiler are accessible from within Profiler’s app configuration. This is a

bit different from other apps in Oracle Eloqua because apps installed for Profiler do not

display in the main AppCloud Catalog. You must go into the settings for Profiler itself to

locate the apps that you’ve installed just for Profiler.

To manage Profiler app extensions from within Oracle Eloqua:

1. Click Settings in the global header.

2. Click Apps in the Platform Extensions section.

https://cloudmarketplace.oracle.com/marketplace/en_US/homePage.jspx
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3. Find and open the Profiler app.

4. Click Configure .

qWarning: Selecting the Reinstall option for an app will force you to go through the

entire installation process again. The app will be unavailable for all users during the

reinstall.

5. Click the Apps tab.

6. Click on the app to open the configuration options for that app.

7. You can perform the following actions:

l Get Dependencies : View any assets that are using the app's services and would be affected if the

app was uninstalled.

l Configure : Allows Marketing Administrators to set up the extension directly from Oracle Eloqua.

l Uninstall : Uninstall and remove the app from your Profiler instance.

l Services: View the kinds of services you currently have under the app.

Restricting access to a Profiler app using Oracle Eloqua
Security Groups

There are certain circumstances where you may want to restrict who can access an app

installed in Profiler. A couple of use cases to consider:

l You are running an app pilot with a select set of trusted power users within the sales team.

https://docs.oracle.com/cloud/latest/marketingcs_gs/OMCIA/Developers/salestools/tasks/creating-profiler-services.htm
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l The app is provided by a third party and requires a paid license that is not available to all sales

users i.e. an account based application where licenses are only available for strategic account

managers and not inside sales.

l The App Access section within Profiler’s global settings will allow you to control who has access

to an app you’ve installed.

1. Click Configure in the Profiler page of the AppCloud Catalog.

2. Open the App Access tab.

3. Check the box beside Allow access only to these to security group(s).

ëNote: When an app is installed, it is available to all users by default. If the box beside

Allow access to security groups is checked but no security groups are selected, then all

security groups are granted access.

4. From the Select a security group drop-down, select the Oracle Eloqua security groups

containing users that should be granted access to the Profiler app.

ZImportant: The listed security groups have been configured in Eloqua. Additionally,
modifying access settings will immediately change access for users, including deletion of

user settings.

5. Click Save.
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Uninstalling apps within Profiler

Apps installed for Profiler can be uninstalled from within Profiler’s app configuration. This

is a bit different from other apps in Oracle Eloqua because apps installed for Profiler do

not display in the main AppCloud Catalog. You must go into the settings for Profiler itself

to locate the apps that you’ve installed just for Profiler.

To delete Profiler app extensions from within Oracle Eloqua:

1. Click Settings in the global header.

2. Click Apps in the Platform Extensions section.

3. Find and open the Profiler app.

4. Click Configure .

5. Click the Apps tab.

6. Click on the app to open the configuration options for that app.

7. Click Uninstall to uninstall and remove the app from your Profiler instance.
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Searching for contacts in Profiler

Profiler allows you to view contact information and Oracle Eloqua marketing activities

using a convenient and device friendly interface.

You can search for contacts by:

l First name

l Last name

l Email address

l Title

After you have search results, you can further filter the results by:

l Title

l Account

l City

l Email domain

To search for a contact in Profiler:

1. Select the icon in the upper right-hand corner of the Profiler screen.

ëNote: You can also use the Search Contacts field that appears on the search page
when you open the app.
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2. Type your search words in the Search bar. You can search by a contact's First Name, Last

Name, Email Address, or Title . The search is not case-sensitive. The results display a list of all

contacts who have a matching contact field that starts with your search criteria.

-Example: A search for Alex displays users such as Alex, Alexandra, and Alexander.

3. (Optional) Filter your search results by clicking Filter . The filter panel displays on the right.

l Filter by title, account, city, or domain, and click Apply. Filtering shows users that match all of your

filtering criteria (using an AND operator).

l Click the X next to a filter to remove it. To remove all filters, click Clear.

The example below shows filtering by domain of example.com and title of CEO. The results display all

users who match both of these criteria. Users who have CEO as the title, but a different domain will

not appear.

4. Select the name of the correct contact from the list. Their contact record opens displaying their

details and activities. Learn more about the information provided in Profiler.

After your first visit to Profiler, a recently-viewed contacts list is displayed on the

homepage. This convenient list makes it easier to locate the contacts that you may be

dealing with on a regular basis, or with whom you are attempting to establish a
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connection. From this recently viewed list you can select the contact's name and you are

taken directly to their contact record.
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Viewing a contact in Profiler

When you open a contact record in Profiler, you can view details about the contact as well

as valuable information about the contact's interactions with your organization's

marketing materials and website.

Good to know

Note the following:

l Profiler shows marketing related activity, such as email opens, clicks, form submissions, and so

on. The following lists the activities available in Profiler:

l Emails Sends: The number of emails sent to this contact.

l Emails Opens: The number of times emails were opened by the contact.

l Emails Clicks: The number of times that links in an email were clicked.

l Web Page Visits: The number of visits to tracked web pages.

l Form Submissions: The number of forms that were submitted by the contact.

l External Activities: The number of non-Eloqua (external) activities, such as attending a webinar,

trade show, and so on. Your administrator decides what external activities are available in Profiler.
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l If you see activities repeated within minutes of each other, this could be the result of anti-virus

software scanning email links and images.

l Email thumbnails provide a view of the email as it was sent to the contact. You can use the

preview link to view the full email. Since content in an email can be dynamic and personalized,

the preview of the email may be different than the thumbnail.

l An email preview link is available for 120 days after the send date.

l By default, you can view 1 year of activities for the contact. You can view older activities by

using the date filter on the Activities tab. For more details, see the Activities tab details below.

Contact details

Use the left panel to learn about the contact and how to reach them. Profiler provides you

with a number of ways of reach out to the contact.
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l
Call the contact. If you are using your mobile device, you click to call the contact.

l
Reach out to the contact via email. Clicking the email address opens a new message in

Engage or your default email client.

l Locate the contact using Google Maps. If there is an address for the contact, use this

feature to map to the contact's location.

l Reach out to the contact via LinkedIn. Clicking this icon opens the contact's LinkedIn

profile. Your administrator manages whether this and other social links are available. Learn

more about enabling these fields.

ëNote: Bounced back or unsubscribed. This icon indicates that you cannot

send a message to this contact, because the email address bounced back or the

contact is globally unsubscribed.

Before reaching out to a contact, arm yourself with information about the contact's

interaction with your organization by reviewing the details on the tabs in Profiler.

To review more details about the contact from the Oracle Eloqua contact record, open the

Details tab.
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Lead score

A lead score is displayed for each contact in Profiler. This value is based on the lead

scoring models configured for Oracle Eloqua. Your administrator manages which models

are available to you. Learn more about lead scoring and changing the lead score model.

To change the lead score model displayed, click the lead score and choose from the

models available to you. After you make a choice, Profiler displays this model for all

contacts.

Summary tab

This tab presents the contact's activities in the following ways:
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l Activities: This chart shows all the contact's activities within a specific date range. You can use

the calendar icon in the upper right-hand corner of the graph to change the date range, select

30 days, 6 months, or 1 year as needed. By default, all activity types are shown, tap or click the

activity type label below the graph to hide the corresponding data. To view the full activity

details for each bar on the graph, simply click an individual bar and the Activities tab opens

displaying the included activities in detail.

l Latest Activities: This section shows the contact's activities from the last year. Expand the

activity to view more details about the activity, such as a preview of the email or web page. This

can give you a good idea about the contact's interests.

l Activity Breakdown: This section provides a breakdown of the contact's activities over the last

year, these are the same categories that are represented in the activities chart. The activities

are grouped based on type. Click or tap any activity type to view more details in the Activities

tab.

Activities tab

This tab shows you all of the contact's activities by date and time. You can expand an

activity to view more details about it, such as a thumbnail view of an email or web page, or
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links that were clicked. Emails can also be previewed fully for up to 120 days after the

send date.

You can search for activities on or before a specific date. Click Filter and

choose a date. This returns activities on or before this date up to the last 25 months of

activities.

Details tab

This tab provides you with more information about the contact. The fields that you can

see depend on the contact views that your administrator has made available to you. To

change the contact view, use the View list. Learn more about contact views in Profiler.

If messages to this contact have bounced back or the contact is globally unsubscribed,

the following icon is displayed next to the email address. These contacts can no longer be

reached by email.

https://docs.oracle.com/en/cloud/saas/marketing/eloqua-user/index.html#cshid=ContactViewsSalesTools
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About contact engagement fields

ëNote: Important: Effective June 12, 2025, Oracle Eloqua's Advanced Intelligence

(AI) features are available for all customers. To enable Eloqua's classic and

Generative AI (Gen AI) functionality, open a service request with Oracle Support.

Please review our product notice for more information.

If your organization has the Eloqua Advanced Intelligence Cloud Service, use the fields to

understand additional engagement information about the contact.

https://docs.oracle.com/en/cloud/saas/marketing/eloqua-user/Help/AdvancedIntelligence/AdvancedIntelligenceOverview.htm
https://docs.oracle.com/en/cloud/saas/marketing/eloqua-user/Help/AdvancedIntelligence/AdvancedIntelligenceOverview.htm
https://support.oracle.com/
https://community.oracle.com/customerconnect/discussion/881211
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Email engagement

Using email send and open data, this rates the contact's email engagement on a scale of

Low to High.

l Low - Based on email sends and opens, this contact has poor levels of engagement. Consider

a highly personalized message or another way of reaching this contact.

l Medium - Based on email sends and opens, this contact's engagement is declining. Consider a

personalized message to try to help with engagement.

l High - Based on email sends and opens, this contact has ideal engagement.

l Uncategorized - Based on email sends and opens, there just isn't enough information to

categorize the engagement for this contact.

If no score available, there is no email engagement level for this contact yet.
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Account engagement

For contacts that are linked to an account in Oracle Eloqua, this score rates the overall

account activity. The scoring takes into consideration email opens, clickthroughs and

form submissions. The higher the score, the more engaged the account. To find other

contacts at this account, use the Profiler search feature to search by Account name.

Learn more about searching for contacts in Profiler.
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Adjusting the lead score model displayed in
Profiler

A lead score is displayed for each contact in Profiler. This value is based on the lead

scoring models configured in your Oracle Eloqua instance. Your administrator manages

which models are available to you. Learn more about lead scoring.

https://docs.oracle.com/cloud/latest/marketingcs_gs/OMCAA/index.html#CSHID=LeadScoring
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How Oracle Eloqua evaluates leads

Oracle Eloqua uses two sets of criteria to evaluate a

lead:

l Profile criteria: This is explicit data about the lead,

such as title, industry, or company revenues. This type

of demographic data helps identify who the prospect is

and the prospect's fit. Based on the profile criteria, the

lead is given a profile score of A, B, C, or D.

l Engagement criteria: This is implicit data, such as

visits to your website and responsiveness to

promotions. This type of data helps determine a lead's online behavior and can indicate how

interested the lead is. Based on the engagement criteria, the lead is given an engagement

score of 1, 2, 3, or 4.

Once Oracle Eloqua evaluates a lead against the profile and engagement criteria, it

combines the profile score and the engagement score and assigns the lead a lead score.

A1 is the most qualified lead and a D4 is the least qualified.

To change the lead scoring model displayed in Profiler:

1. With a contact profile open, click the lead score icon to the right of the contact's name. A list

opens displaying the available lead scoring models.
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2. Select a new lead scoring model from the list. The new model is applied to the record and the

lead score icon is updated to reflect the change.

ZImportant: When you change the lead scoring model for a contact, the selected

model is saved as your default model. All subsequent profiles that you view use the

selected lead scoring model.
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Setting up activity notifications

The Profiler alerts allow you to set up alerts that will inform you each time a contact, or

anyone from the same domain, visits your website. As a Profiler user, you can set up

alerts when you view a contact. The alerts provide near real-time notifications whenever

a contact has visited your website.

ëNote: Profiler alerts must be enabled by your administrator. Learn more about

configuring the app.

To set up alerts in Profiler:

1. Open the profile for the contact for whom you wish to set up notifications.

2. Click the +Alert button below the contact's name. The Setup Alerts dialog opens.

3. Select or clear the check boxes to specify in which cases you want to be notified.

4. Click Save. The dialog closes and your web alert preferences are saved for this contact. You

will be sent a notification email informing you of the contact's activities, according to the settings
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you configured. When you receive a notification, click This Contact's Activity in the notification

email to open Profiler and view more details about the contact.

To find and remove alerts:

1. From the Sales Tools menu, go to Settings > Profiler > Email Alerts.

2. Open the profile for the contact for whom you wish to set up notifications.

3. Click the Alert button below the contact's name. The Setup Alerts dialog opens. The button

shows + to create a new one for the contact, or checkmark when you have one setup for the

contact.

4. Click View all Alerts. You will be redirected to the page where you can see Settings

> Profiler > Email Alerts.
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Viewing email alerts

Using Engageand Profiler, you can view a list of the email alerts you are subscribed to.

ëNote: Email alerts are displayed if you have a Profiler license.

To view email alerts:

https://docs.oracle.com/cloud/latest/marketingcs_gs/OMCAA/index.html#CSHID=Engage
https://docs.oracle.com/cloud/latest/marketingcs_gs/OMCAA/index.html#CSHID=Profiler
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1. Click Settings .
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2. Select the Email Alerts tab.
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Your existing email alerts are displayed. You can remove any email alerts you no longer

want to receive by clicking X.



©2025 Oracle Corporation. All rights reserved 48 of 98

Profiler integration

Profiler can be embedded in several customer relationship management (CRM) systems,

including Oracle Sales (formerly Oracle Sales Cloud), CRM onDemand, and Salesforce.

This integration makes it easier and more convenient for you to access the sales tool

from within your chosen system.

ëNote: If you already have an older version of Profiler embedded in a CRM, you

must replace the login URL.

Embedding Profiler as a subtab in Oracle Sales

ZImportant: Oracle Sales was formerly known as Oracle Sales Cloud. All instances

of Oracle Sales Cloud have been changed to Oracle Sales across the app user

interface.

To enrich the user experience when working in Oracle Sales, you can embed a Profiler

subtab into standard objects, such as Contacts and Sales Leads. This way, you can view

the contact details for a potential client, their activities, lead score, and so on without

needing to leave that Contact or Sales Lead object.
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Prerequisites:

l In Oracle Eloqua, build an allowlist of the domains that will be hosting embedded Profiler pages.

Learn how to configure Profiler.

l Determine the Oracle Eloqua login URL you want to use. You can use the simplified login URL

or a specific legacy URL based on the desired login method. Learn more. The steps below

assume you are using the simplified login URL.

There are five steps to creating a Profiler subtab in Oracle Sales:

1. Creating a sandbox

2. Creating mashup content

3. Adding the mashup content to a standard object in Oracle Sales

4. Publishing your sandbox

AccesingEngage.htm#Engage2
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Step 1: Creating a sandbox

To create a sandbox:

1. Log in to Oracle Sales with your Administrator credentials.

2. Click Navigator at the top of the page, and under Configuration click Sandboxes.

3. Click Create Sandbox.

4. Ensure Application Composer is checked as Active, give your sandbox a name, and ensure

that Publishable is set to Yes.

5. Click Create and Enter.

You'll be redirected to the Available Sandboxes page.

Step 2: Creating mashup content

To create mashup content:
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1. At the top of the page, click Tools > Application Composer.

2. In the Overview section, click Mashup Content > Register Web Application. Alternatively, you

can click Mashup Content in the left-side panel under Common Setup.

3. Configure the following options:

l Give your web application a name. For example, Eloqua Profiler.

l Select Groovy expression.

4. Click Save and Close.
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Step 3: Adding the mashup content to a standard object

To add the mashup content to a Contact or Sales Lead object:

1. Still in the Application Composer, navigate to the left-side panel under Objects, expand

Standard Objects, then expand the object, either Sales Lead or Contact, that you want to add

the subtab to.

In our example, we'll be using the the Sales Lead object.
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2. Click Pages.

3. In the Application Pages tab, scroll down to the Details Page Layouts section, and click Default

Custom Layout.

ëNote: If you do not see the Default Custom Layout you can add it by duplicating an

existing layout. For example, duplicate the Standard layout, then edit the duplicate

layout.
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4. Scroll down and click Add .

5. Select Mashup Content, then click Next.

6. Select your Mashup Content from the Web Applications list, then click Insert.

7. Configure the following options:

l Give your subtab a name. In this case, you would give it a name related to Profiler. For example, you

could name the subtab Eloqua Profiler.

l (Optional) Click Change Icon to change your subtab's Display Icon.

8. In the Edit Script area, insert the following script:

if (PrimaryContactEmailAddress != null) {

return "https://login.eloqua.com/siteLogin?SiteName=

{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddress=" +

PrimaryContactEmailAddress;

}

else {

return "https://login.eloqua.com/siteLogin?SiteName=

{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler";
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}

¤Tip: If you're adding Profiler to the Contacts object, replace
PrimaryContactEmailAddress in the above code samples with

PrimaryEmailAddress. Since in this topic we're adding Profiler to the Sales Leads

object, we'll keep PrimaryContactEmailAddress in our code.

9. (Optional) Click Next. The Next option only appears if there are other details page layouts

available to add the subtab to.

10. Click Save and Close.

11. Done.

Step 5: Publishing your sandbox

1. Click Sandboxes, then click on your sandbox's name.

2. Click Publish.

After following these steps for Profiler, you can now view the subtab when you navigate to the

standard object's page. For example, since in this topic we created a subtab for the Sales Lead

object, we'll navigate to Navigator > Leads under Sales. Once you open a lead, you see the

Profiler subtab.
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Troubleshooting

l For Firefox users, if you’re using Autologin or SAML access methods, and you cannot progress

past the Oracle Eloqua authenticate now login screen, you may have to disable Firefox

enhance tracking protection. To do this, in Firefox, navigate to Options in the Firefox browser >

Privacy & Security > Enhanced Tracking Protection > select Custom > uncheck the box for

Cookies.

l If you see a content security policy directive message in the iframe, check that your Profiler

allowlist includes the required URLs for embedding in Oracle Sales. Make sure to also confirm

that the URL you are using is correct.
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l If you have several IDPs setup with your SSO configuration, adjust the URL to use the specific

IDP you want. Otherwise, the default IDP will be used.

Here is an example URL with the IDP parameter:

https://login.eloqua.com/siteLogin?SiteName=ExampleSiteName&Idp=696

27DAC73E04DE79CDFC90D132B65EA&ReturnUrl=/apps/embed/salesTools/prof

iler

Add Profiler to Oracle Sales Redwood User Experience

To add Oracle Eloqua Profiler in Oracle Sales Redwood User Experience, you can create

custom smart actions that navigate users to Eloqua Profiler.

There are three steps to launching Profiler in Oracle Sales Redwood User Experience:

1. Create a sandbox

2. Create a smart action

3. Publish a sandbox

Step 1: Create a Sandbox

1. Log in to Oracle Sales with your Administrator credentials.

2. Click Navigator at the top of the page, and under Configuration click Sandboxes.

3. Click Create Sandbox.

4. Ensure Application Composer is checked as Active, give your sandbox a name, and ensure

that Publishable is set to Yes.

5. Click Create and Enter.

You'll be redirected to the Available Sandboxes page.
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Step 2: Create a smart action

1. In Application Composer, click Smart Actions, available under Common Setup.

2. On the Smart Actions page, click Create. Application Composer displays the Create Smart

Action guided process in a new browser tab.

3. On the Kind of Action page:

a. Click UI-based action.

b. Click Continue.

4. On the Basic Details page:

a. In the Name field, enter a display name: Eloqua Profiler for the action.

b. In the Object field, select the Contact object for which you're creating the action. If you are embedding

for Leads, then select the Sales Lead. object

c. In the Action ID field, accept the automatically generated value or enter a unique value. This value

must be unique across all smart actions.

d. Click Continue.

5. On the Availability page:

a. In the Application field, select the Sales application where the action will display.

b. In the UI Availability field, select the List Page where the action will display in addition to the Action

Bar.

c. Optional - In the Role Filter field, optionally select the custom roles that can view the action. (If you

don't select a role, then the action will be available to all roles). For details see Create UI-Based Smart

Actions.

d. Optional - In the Condition region, optionally set conditions for the action to appear, such as only if a

certain field's value is set to a particular value. For example, show a smart action only if a lead's status

is Hot. For details see Create UI-Based Smart Actions.

6. On the Action Type Page:

https://docs.oracle.com/en/cloud/saas/applications-common/25a/oacex/create-ui-based-smart-actions.html
https://docs.oracle.com/en/cloud/saas/applications-common/25a/oacex/create-ui-based-smart-actions.html
https://docs.oracle.com/en/cloud/saas/applications-common/25a/oacex/create-ui-based-smart-actions.html
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a. In the Type field, specify the type of action, Navigate to URL.

b. In the URL field, insert the following URL:

https://login.eloqua.com/siteLogin?SiteName=

{EloquaCompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddress=${EmailAddres

s}.

c. If you are adding Eloqua Profiler to Contacts:

In the Value column for EmailAddress in the Field Mapping section, select Email (EmailAddress).

d. If you are adding Eloqua Profiler to Sales Leads:

In the Value column for EmailAddress in the Field Mapping section, select ContactEmail

(PrimaryContactEmailAddress).

e. In the Browser Window Target field, specify New tab.

7. On the Action Details page, leave it blank and click Continue.

8. On the Confirmation Message page, leave it blank and click Continue.

9. On the Review and Submit page, review the action's configuration and click Submit when

ready.

Step 3: Publish a Sandbox

1. Click Sandboxes, then click on your sandbox's name.

2. Click Publish.

After following these steps for Profiler, you will now be able to see Profiler from object list. For

example, if you we created a Smart Action for the Sales Lead object, then you will be able to

see Profiler for a Sales Lead from the action menu when a specific lead is selected.

After Completion, you should find the smart Action available for selection.
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Additionally the Smart Actions would be available to launch from a contact record.

Embedding Profiler into Oracle B2C Service

With Profiler, you're able to view the contact details for a potential customer, their

activities, lead score, and so on. By embedding Profiler into your Oracle B2C Service

workspace, you can get activity and lead score context for a customer or prospect—

before, while, or after you speak with them. In this way, Profiler can assist in preparing

yourself for customer communications.

Prerequisites:
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l In Oracle Eloqua, build an allowlist of the domains that will be hosting embedded Profiler pages.

Learn how to configure Profiler.

l Determine the Oracle Eloqua login URL you want to use. You can use the simplified login URL

or a specific legacy URL based on the desired login method. Learn more. The steps below

assume you are using the simplified login URL.

To embed Profiler into Oracle B2C Service:

1. Log in to your B2C Service service console with your Administrator credentials.

2. Click Navigation > Configuration.

3. Click Application Appearance then double-click Workspaces / Workflows.

4. Create a new workspace or open an existing one.

¤Tip: Ensure that the workspace you create or select has a relationship with contacts, for
example, a contact workspace or incident workspace.

5. (Optional) Right-click on a tab, and click Add Tab After or Add Tab Before.

AccesingEngage.htm#Engage2
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6. (Optional) Double-click on the new tab, and click Text in the Design tab.

7. (Optional) Rename your tab to Profiler.

8. Open the Insert Control tab at the top of the page, then click Browser and drag it to the design

space for your tab.

9. Click the browser control to select it.

10. Open the Design tab at the top of the page.

11. In the Options section of the Design tab, click URL , and enter the simplified login URL:

https://login.eloqua.com/siteLogin?SiteName=
{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddress=$conta
ct.email.addr



©2025 Oracle Corporation. All rights reserved 63 of 98

To use the legacy URLs, replace the URL value above with the Legacy login URLs

12. Check the Send URL as Post Data and Open Pop-ups in New Browser Control check boxes.

13. Click Save.

Profiler is now embedded within the context of your workspace in an iframe.

Adding a Profiler link to Oracle Sales

ZImportant: Oracle Sales was formerly known as Oracle Sales Cloud. All instances

of Oracle Sales Cloud have been changed to Oracle Sales across the app user

interface.

There are two main steps that you must follow to add a Profiler link to your Oracle Sales

(formerly Oracle Sales Cloud) account:

1. Create a Profiler link

2. Add the link to a layout

Step 1: Creating a Profiler link.

To create a Profiler link:

1. Log in with your Administrator credentials.

2. Click the Navigator icon, then under Configuration click Application Composer.

3. In the left-side pane, select Marketing from the Application drop-down list.
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4. In the left-side pane under Objects, expand Standard Objects > Sales Lead > Sales Lead

Contacts, then select Actions and Links .

5. Click Create to create a link, then enter the following information:

l Display Label: Profiler

l Name: Eloqua_Profiler

l Type: Select Link

l URL Definition: Enter the simplified login URL:

def URL="https://login.eloqua.com/siteLogin?SiteName=
{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddress=" + nvl
(PrimaryEmailAddress,"")

To use the legacy URLs, replace the URL value above with the Legacy login URLs.

6. Click Validate to validate the script.

7. Click Save.

Step 2: Adding the Profiler link to layouts

To add the Profiler link to a layout:

1. In the Application Composer left-side menu, navigate to Standard Objects > Sales Lead, then

click Pages.

2. Under Simplified Pages, locate the Details Page Layouts section, then click on the name of the

layout to which you want to add the link.

3. In the Subtabs Region section, open the Contacts tab.

4. Click Edit next to Contacts.

5. Under the Available Fields column, select the Profiler link that you created then click to

move the link to the Selected Fields column.
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6. Adjust the link's location in the Selected Fields list using the up and down arrows next to the list,

then click Save and Close.

When you open to a customer you will see the Profiler link.

Embedding Profiler in CRM onDemand

When embedding Profiler in CRM onDemand, there are two main steps that you must

follow:

1. Create a web applet

2. Add the web applet to a page layout

ëNote: You will need to create two applets– one for leads and one for contacts. The

instructions below are for Contacts but you can follow the same procedure for

Leads.

Step 1: Creating a web applet for contact and leads

Prerequisites:
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l In Oracle Eloqua, build an allowlist of the domains that will be hosting embedded Profiler pages.

Learn how to configure Profiler.

To create a web applet:

1. Login to CRM onDemand with your Administrator credentials.

2. Navigate to User > Configure > Admin.

3. Click Application Customization.

4. Under Record Type Setup, click Contact.

5. Under Pay Layout Management, click Contact Web Applet, then enter the information below:

l Name: Enter a name. ( Example: Eloqua Profiler)

l Location: Select Detail Page

l Type: Select URL

l URL: and enter the simplified login URL:

https://login.eloqua.com/siteLogin?SiteName=
{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddress%3D%%%Email_
Address%%%

To use the legacy URLs, replace the URL value above with the Legacy login URLs.

l Height: Enter 800
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6. Click Save.

Step 2: Adding webs applet to page layouts

To add an applet to a page layout

1. Navigate to User > Configure > Admin.

2. Click Application Customization.

3. Under Page Layout Management, click Contact Page Layout.

4. Choose the page layout that you want to modify

5. It is not necessary to configure Steps 2 or 3. Click Step 4 (Related Information) to continue.

6. In the Not Available Information column, locate the web applet that you created, then highlight it

(single left-click) and click the > arrow to move it to the Available Information column.

7. Select the applet in the Available Information column, then click the > arrow to move it to the

Displayed Information column.

8. Click Finish.

ZImportant: Repeat the above steps for Leads
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Embedding Profiler in Microsoft Dynamics 2016

Profiler can be embedded in Microsoft Dynamics.

Prerequisites:

l In Oracle Eloqua, build an allowlist of the domains that will be hosting embedded Profiler pages.

Learn how to configure Profiler.

l Determine the Oracle Eloqua login URL you want to use. You can use the simplified login URL

or a specific legacy URL based on the desired login method. Learn more. The steps below

assume you are using the simplified login URL.

To install Profiler in Dynamics:

1. Navigate to Menu > Settings > Customization > Customizations > Customize the System.

2. Under Components, select Entities > Contact > Forms.

3. Click New, then select the form to which you want to add Profiler.

4. Click the Insert tab in the top menu.

5. Add a one-column tab.

6. Add an iframe to this tab.

l Name: IFRAME_Profiler

l URL: http://about:blank

AccesingEngage.htm#Engage2
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l Label: Eloqua Profiler

l Ensure that Restrict cross-frame scripting is unchecked

7. On the Formatting tab, modify the height by setting the number of rows, such as 20.

8. On the Dependencies tab, add email as a dependent field.

9. Click OK to close the IFRAME window.

10. On the Home tab, click Form Properties in the Form section.

11. Under Form Libraries, click Add, then click New.
l Name: new_EPPOnLoad

l Type: Script (JScript)

12. Click the text editor button that appears.

13. In the text editor, copy and paste the following string: function loadProfiler() {

14. Copy and paste one of the simplified login URL code snippet below. To use the legacy URLs,

replace the URL value above with the Legacy login URLs.

var newUrl = https://login.eloqua.com/siteLogin?SiteName=

{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddres

s=" + document.getElementById

("emailaddress1").title;Xrm.Page.ui.controls.get("IFRAME_

Profiler").setSrc(newUrl);

15. Be sure to close everything with a final }. If you chose auto-login, your code should look

something like this:

function loadProfiler() {var newUrl =

"https://login.eloqua.com/siteLogin?SiteName=

{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddres

s="+ document.getElementById
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("emailaddress1").title;Xrm.Page.ui.controls.get("IFRAME_

Profiler").setSrc(newUrl);}

16. Click OK to close the text editor.

17. Click Save, then click Publish, and close the window.

18. Close the Look Up Record window.

19. Under Event Handlers, click Add.

20. Select the new function you created from the list and then name it.

21. Click OK.

22. Click OK in the Form Properties window.
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23. Click Save, then click Publish on your form.

24. Repeat for the Leads entity if needed.

ZImportant: If the IFRAME window appears blank, navigate to Settings >

Administration > System Settings > General, and change the setting for Use

legacy form rendering to Yes. Microsoft Dynamics will then correctly render the

Profiler iframe.

Embedding Profiler in Microsoft Dynamics 365

You can add Profiler to your Microsoft Dynamics 365 instance.

Prerequisites

l If you are using version 9 and above of Microsoft Dynamics 365, see Version 9 and above.

l A Microsoft Dynamics 365 instance and the permissions needed to customize it.

l In Oracle Eloqua, build an allowlist of the domains that will be hosting embedded Profiler pages.

Learn how to configure Profiler.

l Determine the Oracle Eloqua login URL you want to use. You can use the simplified login URL

or a specific legacy URL based on the desired login method. Learn more. The steps below

assume you are using the simplified login URL.

Version 9 and above

If you are using version 9 and above of Microsoft Dynamics 365, you will need to perform

some steps differently:

AccesingEngage.htm#Engage2
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l If Profiler is already embedded in your Microsoft Dynamics 365, you'll need to make the below

changes, save them, then publish them.

l For step 13 in the Handler Properties window, make sure Pass execution context as first

parameter is enabled.

l You'll need to use the simplified login URL code snippet for step 18:

loadProfiler(executionContext){

var newUrl = "https://login.eloqua.com/siteLogin?SiteName=

{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddres

s=" + executionContext.getFormContext().getAttribute

("emailaddress1").getValue();Xrm.Page.ui.controls.get("IFRAME_

Profiler").setSrc(newUrl);

}

To embed Profiler in Microsoft Dynamics 365:

1. Log in to Microsoft Dynamics 365 and navigate to Settings.

2. In the Customization section, click Customizations.
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3. On the Customization page, click Customize the System.

4. On the PowerApps page, under Components, select Entities > Contact > Forms.

5. Click New, then select the form you want to add Profiler to, such as Main Form.

6. Click the Insert tab in the top menu.
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7. Add a One Column Tab select the new tab and click IFRAME to add an iframe to it.

The Add an IFRAME window is displayed.
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8. Enter the following iframe values.

a. Name: IFRAME_Profiler

b. URL: http://about:blank

c. Label: Eloqua Profiler

d. In the Security section, clear the Restrict cross-frame scripting option.
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9. (Recommended) In the Row Layout section of the Formatting tab, increase the height by setting

the number of rows to 20 so that Profiler will have enough room to display its information.

10. On the Dependencies tab, add email as a dependent field.

11. Click OK to close the Add an IFRAME window.

12. On the Home tab, click Form Properties.

The Form Properties window is displayed.

13. Click Add. The Handler Properties window is displayed.

ZImportant: If you are using Microsoft Dynamics 365 version 9 and above, see Version 9
and above for additional steps in the Handler Properties window.
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14. From the Library list, select new_EPPOnLoad.

15. In the Function box, enter loadProfiler and click OK.

16. Double-click your new iframe. The IFRAME Properties window is displayed.

17. On the Events tab, expand Form Libraries and double-click new_EPPOnLoad. The Edit

Content window is displayed.

18. Depending on your login type, copy and paste one of the following code snippets into the code

editor:

ZImportant: If you are using Microsoft Dynamics 365 version 9 and above, see Version 9
and above for the code snippets. Ignore the below code snippets for step 18.

function loadProfiler() {

var newUrl = https://login.eloqua.com/siteLogin?SiteName=
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{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddres

s=" + document.getElementById("

{emailaddress1}").title;Xrm.Page.ui.controls.get("IFRAME_

Profiler").setSrc(newUrl);

}

19. Replace the {emailaddress1} with the value in your Microsoft Dynamics 365 instance. For

example, it can be emailaddress1, emailaddress1_d, or emailaddress1_i. To determine

what is used in your Microsoft Dynamics 365 data, inspect an existing contact's email address

with your browser's developer tools. For example, to find your value using Google Chrome:

i. Go to Sales > Contacts and click an existing contact.

ii. Pressing Ctrl+Shift+I to open developer tools.

iii. On the Elements tab, press Ctrl+F and search for emailaddress1.

iv. The value associated with the contact's email address field that is followed by title="

{emailAddress}" indicates the value you need to include. In the following example, the needed value

is emailaddress1_d.
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-Example: If you chose autologin, your {LoginPrefix} is ELQA, and your {emailaddress1}
value is emailaddress1_d, your code should look something like this:

function loadProfiler(){

var newUrl =

"https://login.eloqua.com/autoLogin?LoginPrefix=ELQA&Url=/apps/em

bed/salesTools/profiler?emailAddress="+ document.getElementById

("emailaddress1_d").title;Xrm.Page.ui.controls.get("IFRAME_

Profiler").setSrc(newUrl);

}

20. Click OK to close the text editor.

21. On the Home tab, click Save, click Publish, and then close the PowerApps window.

22. Go to Contacts and open a contact that is known to exist in both Oracle Eloqua Profiler and

Microsoft Dynamics 365 to test that your new Eloqua Profiler iframe is working. If you are

prompted to authenticate, enter your Eloqua credentials. If there is a match based on the email

address, the Profiler iframe should display information for the contact.
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ZImportant: If the IFRAME window appears blank, navigate to Settings >

Administration > System Settings > General, and change the setting for Use

legacy form rendering to Yes. Microsoft Dynamics will then correctly render the

Profiler iframe.

Embedding Profiler in Salesforce Classic

ëNote: If you are using Salesforce Lightning, see Embedding Profiler in Salesforce

Lightning.

The users that can see Eloqua Profiler in your CRM system are dependent on the

views/layouts you have set up in your CRM system and on which of those views/layouts

you insert the Eloqua Profiler component.
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ëNote: If you want to test Eloqua Profiler without making it available to your entire

sales or marketing team, you should assign yourself a contact/lead view to which

nobody else has access and then add Eloqua Profiler to that view.

Prerequisites:

l In Oracle Eloqua, build an allowlist of the domains that will be hosting embedded Profiler pages.

Learn how to configure Profiler.

l Determine the Oracle Eloqua login URL you want to use. You can use the simplified login URL

or a specific legacy URL based on the desired login method. Learn more.

There are three main steps you must follow when installing Profiler using Visualforce:
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1. Create a Visualforce page for contacts and leads

2. Adjust security for Visualforce pages

3. Add Visualforce pages to contact and lead layouts

¤Tip: If you encounter any issues, see Troubleshooting.

Step 1: Creating a Visualforce page for contacts and leads

You will need to create two (2) Visualforce pages – one for leads and one for contacts.

Then you will be editing your existing Contact and Lead views by inserting the

appropriate Visualforce pages into their corresponding views. Below, we will cover the

installation for a Lead view, however, the steps required for a Contact view are mostly the

same but for a few minor text items noted below.

To create a Visualforce page:

1. Log into your Salesforce account using your administrator credentials, then navigate to Setup

in the upper right-hand corner of the screen.

2. Navigate to Develop (under Build section) > Visualforce Pages > New.
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3. Provide a Label and a Name for the Visualforce page.

ëNote: These two fields will only be used when managing layouts and sections and will
not be visible to users simply reviewing a lead record. The name can be whatever you

want but it must contain only alpha-numeric characters and must not have any spaces.
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4. In the Visualforce Markup tab, enter the URL depending on your login method:
l Simplified login: <apex:page standardController="Lead"><apex:iframe scrolling="true"

src="https://login.eloqua.com/siteLogin?SiteName=
{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddress=
{!lead.email}"/> </apex:page>

l To use the legacy URLs, replace the URL value above with the Legacy login URLs.

5. If you wish to enable this on the salesforce1 mobile app, select the check box next to Available

for Salesforce mobile apps.

6. Click Save.

7. Repeat for the contact object.

¤Tip: For your contacts Visualforce page, replace {!lead.email} with
{!contact.email}.

Step 2: Adjusting security for Visualforce pages

Salesforce has default security that prevents certain users from viewing Visualforce

pages unless the security on those individual pages is customized.

To adjust the security for a Visualforce page:
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1. Navigate to Develop (under Build section) > Visualforce Pages.

2. Click Security next to the pages you created.

3. Add the user types that should be able to view Eloqua Profiler to the Enabled Profiles list.

4. Click Save.

Step 3: Adding Visualforce pages to contact and lead layouts

The steps below describe the procedure for adding the Leads Visualforce page to a

layout. The same steps can be followed for the Visualforce Contacts page you created.

To add a Visualforce page to layouts:

1. Navigate to Setup in the upper right-hand corner of the screen.

2. Navigate to Customize (under Build section) > Leads > Page Layouts.
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3. Select Edit next to the layout in which you would like to insert Eloqua Profiler (either the one you

are testing or the one that your sales team uses to review Lead records).

4. Drag the button located near the top of your screen to create a new section in your

layout to contain Eloqua Profiler.
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5. Place the new section into the area of the layout in which you would like Eloqua Profiler

displayed.

6. Name the section. Ensure that the two check boxes are selected, and select a 1-Column

Layout.

ëNote: The section name is what will be displayed above the section within the Lead
view. Ensure that the name is something that will be relevant and intuitive to your sales

users.

7. Go back to the top area (the area from which you dragged and dropped the new section) and

scroll down if necessary to select Visualforce Pages (in the area just to the left of the buttons

area).

8. Drag the button for the new Visualforce page you made into the new section you just created.

You have now included Eloqua Profiler in your layout. Now let's adjust the settings for this new

section.

9. Hover over the top right corner of the Visualforce page (inside the Section) until a wrench icon

appears. Make sure it is the one for the Visualforce page and not the entire section.

10. Click on the wrench icon. In the VisualForce Page Properties, ensure that the width is set to

100% and the height is set to 610.

11. Click Save to save this layout.

ZImportant: Repeat the above steps for the layout of your Contact object.

12. When you return to the Leads tab in Salesforce and click on a lead, the new Visualforce page

containing Profiler is displayed in the new section you added.
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Troubleshooting

l If the iframe is not connecting, copy the URL you were trying to use in the Visualforce Markup

tab (this will be the text between src=" and the next "), and enter it into a browser to test that it

works on its own. Depending on the URL type, you might need to already be logged into

Profiler.

l If you see a content security policy directive message in the iframe, check that your Profiler

allowlist includes the required URLs for embedding in Salesforce. Make sure to also confirm

that the URL you are using is correct and includes /embed/.

l If you're experiencing trouble with your SSO, see Testing single sign-on with Salesforce for

other troubleshooting tips.

l If you have several IDPs setup with your SSO configuration, adjust the URL to use the specific

IDP you want. Otherwise, the default IDP will be used.

Here is an example URL with the IDP parameter:

https://login.eloqua.com/siteLogin?SiteName=ExampleSiteName&Idp=696

27DAC73E04DE79CDFC90D132B65EA&ReturnUrl=/apps/embed/salesTools/prof

iler

l If the Profiler iframe is trying to open a contact whose email address includes a + symbol, you'll

encounter a Whitelabel Error Page error. To fix this, add URLENCODE to the URL in the

Visualforce Markup tab: ...profiler?emailAddress={!URLENCODE(lead.email)}.

Make sure to remove the ! from !lead.email and place one before URLENCODE, and to add
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parentheses around lead.email.

l For Firefox users, if you’re using the legacy Autologin or SAML access methods, and you

cannot progress past the Eloqua authenticate now login screen, you may have to disable

Firefox enhance tracking protection. To do this, in Firefox, navigate to Options in the Firefox

browser > Privacy & Security > Enhanced Tracking Protection > select Custom > uncheck the

box for Cookies.

l If none of the above troubleshooting tips have solved your issue, please log in to My Oracle

Support (https://support.oracle.com) and create a service request.

Embedding Profiler in Salesforce Lightning

ëNote: If you are using Salesforce Classic, see Embedding Profiler in Salesforce

Classic.

The users that can see Eloqua Profiler in your CRM system are dependent on the

views/layouts you have set up in your CRM system and on which of those views/layouts

you insert the Eloqua Profiler component.

https://support.oracle.com/
https://support.oracle.com/
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ëNote: If you want to test Eloqua Profiler without making it available to your entire

sales or marketing team, you should assign yourself a contact/lead view to which

nobody else has access and then add Eloqua Profiler to that view.

Prerequisites:

l In Oracle Eloqua, build an allowlist of the domains that will be hosting embedded Profiler pages.

Learn how to configure Profiler.

l Determine the Oracle Eloqua login URL you want to use. You can use the simplified login URL

or a specific legacy URL based on the desired login method. Learn more.

There are three main steps you must follow when installing Profiler using Visualforce:

1. Create a Visualforce page for contacts and leads

2. Adjust security for Visualforce pages

3. Add Visualforce pages to contact and lead layouts
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¤Tip: If you encounter any issues, see Troubleshooting.

Step 1: Creating a Visualforce page for contacts and leads

You will need to create two (2) Visualforce pages – one for leads and one for contacts.

Then you will be editing your existing Contact and Lead views by inserting the

appropriate Visualforce pages into their corresponding views. Below, we will cover the

installation for a Lead view, however, the steps required for a Contact view are mostly the

same but for a few minor text items noted below.

To create a Visualforce page:

1. Log into your Salesforce account using your administrator credentials, then navigate to Setup

in the upper right-hand corner of the screen.

2. Locate the Quick Find search box, and search for Visualforce Pages

Alternatively, you can click Custom Code > Visualforce Pages.

3. Click New.

4. Provide a Label and a Name for the Visualforce page.

ëNote: These two fields will only be used when managing layouts and sections and will
not be visible to users simply reviewing a lead record. The name can be whatever you

want but it must contain only alpha-numeric characters and must not have any spaces.
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5. In the Visualforce Markup tab, enter the URL depending on your login method:
l Simplified login: <apex:page standardController="Lead"><apex:iframe scrolling="true"

src="https://login.eloqua.com/siteLogin?SiteName=
{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler?emailAddress=
{!lead.email}"/> </apex:page>

l To use the legacy URLs, replace the URL value above with the Legacy login URLs.

6. If you wish to enable this on the mobile app, select the check box next to Available for

Salesforce mobile apps.

7. Click Save.

8. Repeat for the contact object.

¤Tip: For your contacts Visualforce page, replace {!lead.email} with
{!contact.email}.

Step 2: Adjusting security for Visualforce pages

Salesforce has default security that prevents certain users from viewing Visualforce

pages unless the security on those individual pages is customized.

To adjust the security for a Visualforce page:

1. Locate the Quick Find search box, and search for Visualforce Pages

Alternatively, you can click Custom Code > Visualforce Pages.
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2. Click Security next to the pages you created.

3. Add the user types that should be able to view Eloqua Profiler to the Enabled Profiles list.

4. Click Save.

Step 3: Adding Visualforce pages to contact and lead layouts

The steps below describe the procedure for adding the Leads Visualforce page to a

layout. The same steps can be followed for the Visualforce Contacts page you created.

To add a Visualforce page to layouts:
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1. Locate the Quick Find search box, and search for Object Manager.

Alternatively, you can click Objects and Fields > Object Manager.

2. Click Lead > Page Layouts.

3. Click on the layout in which you would like to insert Eloqua Profiler (either the one you are

testing or the one that your sales team uses to review Lead records).

4. Drag the button near the top of your screen to create a new section in your layout to

contain Eloqua Profiler.

5. Place the new section into the area of the layout in which you would like Eloqua Profiler

displayed.

6. Name the section. Ensure that the two check boxes are selected, and select a 1-Column

Layout.

ëNote: The section name is what will be displayed above the section within the Lead
view. Ensure that the name is something that will be relevant and intuitive to your sales

users.

7. Go back to the Contact Layout section at the top of the page, and click on Visualforce Pages in

the list of options.

8. Drag the button for the new Visualforce page you made into the new section you just created.

You have now included Eloqua Profiler in your layout. Now let's adjust the settings for this new

section.

9. Hover over the top right corner of the Visualforce page (inside the Section) until a wrench icon

appears. Make sure it is the one for the Visualforce page and not the entire section.
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10. Click on the wrench icon. In the Visualforce Page Properties dialog, ensure that the width is set

to 100% and the height is set to 610.

11. Click OK.

12. Click Save to save this layout.

ZImportant: Repeat the above steps for the layout of your Contact object.

13. When you return to the Leads tab in Salesforce and click on a lead, the new Visualforce page

containing Profiler is displayed in the new section you added.

Troubleshooting

l If the iframe is not connecting, copy the URL you were trying to use in the Visualforce Markup

tab (this will be the text between src=" and the next "), and enter it into a browser to test that it

works on its own. Depending on the URL type, you might need to already be logged into

Profiler.

l If you see a content security policy directive message in the iframe, check that your Profiler

allowlist includes the required URLs for embedding in Salesforce. Make sure to also confirm

that the URL you are using is correct and includes /embed/.

l If you're experiencing trouble with your SSO, see Testing single sign-on with Salesforce for

other troubleshooting tips.
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l If you have several IDPs setup with your SSO configuration, adjust the URL to use the specific

IDP you want. Otherwise, the default IDP will be used.

Here is an example URL with the IDP parameter:

https://login.eloqua.com/siteLogin?SiteName=ExampleSiteName&Idp=696

27DAC73E04DE79CDFC90D132B65EA&ReturnUrl=/apps/embed/salesTools/prof

iler

l If the Profiler iframe is trying to open a contact whose email address includes a + symbol, you'll

encounter a Whitelabel Error Page error. To fix this, add URLENCODE to the URL in the

Visualforce Markup tab: ...profiler?emailAddress={!URLENCODE(lead.email)}.

Make sure to remove the ! from !lead.email and place one before URLENCODE, and to add

parentheses around lead.email.

l For Firefox users, if you’re using the legacy Autologin or SAML access methods, and you

cannot progress past the Eloqua authenticate now login screen, you may have to disable

Firefox enhance tracking protection. To do this, in Firefox, navigate to Options in the Firefox

browser > Privacy & Security > Enhanced Tracking Protection > select Custom > uncheck the

box for Cookies.

l If none of the above troubleshooting tips have solved your issue, please log in to My Oracle

Support (https://support.oracle.com) and create a service request.

https://support.oracle.com/
https://support.oracle.com/
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Embedding Profiler in Okta with SSO

Learn how to access Profiler if your are using Okta SSO.

Overview

The high level configuration steps are as follows:

1. Ensure you have setup single sign-on in Oracle Eloqua. Learn more.

2. If you will be embedding Profiler within a CRM or other apps, create the allowlist of domains that

will host Profiler pages. Learn more.

3. Understand how to access Profiler:

l Accessing Profiler with Okta SSO

l Accessing Profiler as an Okta app

Accessing Profiler with Okta SSO

Profiler is an app you can access via a URL from any location. It could be launched

standalone in a browser but is most commonly embedded inside a CRM system.

To access Profiler with Okta SSO:

1. Enter the following URL:

l To launch Profiler standalone in a browser: https://login.eloqua.com/siteLogin?SiteName=
{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler

l To embed Profiler in a CRM or other app: https://login.eloqua.com/siteLogin?SiteName=
{CompanyName}&ReturnUrl=/apps/embed/salesTools/profiler

OverviewSSOwithIdPConfiguration.htm
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Once you have this properly formatted URL, as long as a user has an Okta session active

in their browser, they can access Profiler.

Accessing Profiler as an Okta app

To allow users direct access to Profiler from apps in Okta:

1. In Okta, create a new Okta app for Profiler.

2. While creating the SAML2 template, add the following to the Default Relay State field:

ReturnURL=%2Fapps%2FsalesTools%2Fprofiler

¤Tip: You can append additional parameters to this URL. For example, to open Profiler
to a specific contact. Learn more.
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