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Preface

This preface introduces information sources that can help you use the application and this guide.

Using Oracle Applications

This topic explains the text conventions used in this guide and points you to where you can find more information about using
Oracle applications.

Conventions

The following table explains the text conventions used in this guide.

Convention Meaning

boldface Boldface type indicates user interface elements, navigation paths, or values you enter or select.
monospace Monospace type indicates file, folder, and directory names, code examples, commands, and URLs.
> Greater than symbol separates elements in a navigation path.

Additional Resources

e  Community: Use Oracle Cloud Customer Connect to get information from experts at Oracle, the partner
community, and other users.

e Guides and Videos: Go to the Oracle Help Center to find guides and videos.
e Training: Take courses on Oracle Cloud from Oracle University.

Documentation Accessibility

This topic covers accessibility concepts for this guide.
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website.

Videos included in this guide are provided as a media alternative for text-based help topics also available in this guide.

Contacting Oracle

This topic explains how to contact Oracle for support and to provide feedback.
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Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For
information, visit My Oracle Support or visit Accessible Oracle Support if you are hearing impaired.

Comments and Suggestions

Please give us feedback about Oracle Public Sector Compliance and Regulation applications help and guides! You can send
an e-mail to: PSCR_US@oracle.com.
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1 Implementing Community Development
Using Functional Setup Manager

Using Functional Setup Manager

This topic discusses how to use the Functional Setup Manager.

Oracle Functional Setup Manager provides an integrated, end-to-end process for functional administrators to manage the
implementation and maintenance of Oracle Public Sector Compliance and Regulation services.

Business users configure features and manage setup data using the Functional Setup Manager. Subscription to offerings,
enabling functional areas, opting in features, and setting up guided end-to-end tasks pertaining to the offerings are all driven
through the Functional Setup Manager.

For a detailed understanding of the Functional Setup Manager, see the documentation on Using Functional Setup Manager.

Setting Up Transactions Using Functional Setup Manager

This topic provides the list of required tasks for the implementation of Public Sector Compliance and Regulation offerings,
which are organized under the functional areas in the Functional Setup Manager (FSM).

You must complete the tasks in these task lists to add the required setup data, configuration settings, and processes that
your agency will use across all Oracle Public Sector Compliance and Regulation services.

Functional Area Task List Description

Initial Users Define Initial Users for Public Sector Prepare the groundwork for defining access
through roles and privileges for the users
who will access your service. Tasks include
running the user and role synchronization
process, creating implementation users,
setting the next URL target for new users and
SO on.

Agency Profile Define Foundation Data Set up general foundational data that will
be used by the agency when conducting
transactions for the community. Tasks
include setting up address formats,
city information, county information,
country information, currencies, units of
measurements, and so on.

Define Calendars for Public Sector Set up the Holiday calendar for your agency
to define when your agency is available for
conducting business.
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Functional Area Task List Description

Define Schedules Work schedules establish the days of
the week and daily hours of operation for
agency employees. For example, defining a
work schedule for an inspector establishes
when an inspector can be scheduled for an
appointment.

Define Agency Define fundamental information for an
agency, including the agency ID, agency
name, country, currency, time zone, and so
on.

Fees and Payments Set Up Billing Set up your agency’s billing system. Tasks
include defining invoice forms, setting the
auto-numbering scheme, and selecting bill
types.

Set Up Payments Configure how payments will be processed
within your agency. Tasks include setting up
the payment gateway, configuring the cash
drawer, defining department and agency
payment processing options, and so on.

Inspections Define Inspections Configure the information required for your
inspection system to enable you to define,
organize, and schedule inspections. Tasks
include setting up assessment types, defining
rating methods and passing requirements,
configuring inspection calendars, and so on.

Plan Review Define Plan Review Set up the required information for your
agency to review plans associated with
permit applications. Tasks include defining
plan review statuses and setting up the
resulting plan review decision types, such as
approved, rejected, revision required and so
on.

Permit Types Define Permits Create and configure the types of permits
your agency will offer. Tasks include setting
up permit categories, defining permit
statuses, setting up workflows and fee
models, creating permit types, designing
permit application forms, and so on.

Accounting Define Accounting Set up the processing system to be used by
your accounting department. Tasks include
setting up accounts, funds, and ledgers as
well as defining accounting events and rules.

Agency Staff Define Agency Staff Set up the service to accommodate the
information used to define and support
your agency staff. Tasks include setting up
business units, setting up legal addresses,
creating job titles, configuring staff access,
and so on.
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Functional Area Task List

Description

Public Users Define Public Users

Configure how public users will interact with
the implementation of your service. Tasks
include defining terms of use, selecting public
user options, assigning roles to define public
user access, and so on.

Analytics and Reporting Define Reporting for Public Sector

Add or modify parameters associated with
delivered reports to filter data per your
requirements.

GIS Define GIS

Configure the integration between your
service and the GIS application. Tasks
include managing map profiles and mapping
GIS attributes.

System Administration Define Attachments for Public Sector

Define categories and subcategories for files,
such as plans and images that are attached
to pages as part of the permit application
process.

Define Comments for Public Sector

Configure the comments feature that will

be used throughout the permit application
process. Tasks include setting up comment
categories, adding and modifying standard
comments, and so on.

Define Communication for Public Sector

Delivered communication events are
triggered by transactions and processes
within the application. For example,
scheduling an inspection triggers the
"Inspection Scheduled" communication
event. You can define the content and
recipients of the communication events using
communication templates.

System Administration Define Lookup Values for Public Sector

Add and change values that appear in lookup
lists. Lookup lists are referenced by various
fields in the application and display a static
set of values from which the end user can
select a value when entering information.

Define Conditions for Public Sector

Add, modify, or remove a dependency

or contingency for completing the permit
process. Conditions are defined with a
severities that can affect the permit process
when applied.

Branding Define and Assign Themes

Create custom branding themes for your
agency to reflect your desired look and feel.
Tasks include adding logo images, modifying
header and footer colors, designing your
welcome banner, and so on. Once a
branding them is created, you then assign it
to apply its attributes.
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Functional Area Task List

Define Tiles

Description

Tiles are the icons that appear on the Agency
Springboard and public landing pages. Users
click tiles to access selected pages and
transactions. You can configure which tiles
appear, hide tiles, modify tile labels, and so
on

Define Summary Details

Define the summary section that appears

on the public landing pages. The summary
section includes a summary title, summary
text, and a Read More button that links either
to a more detailed message that you define
or to an external URL.

Define Alerts

Add, modify, and enable alert messages that
will appear on the Agency Springboard and
public landing pages to notify users of timely
information.

Planning and Zoning Application Types Define Planning and Zoning Application
Types

Define application groups, categories,
subcategories, record statuses, fee
schedules, document categories, and
planning and zoning application types for
agency.

Public Hearing Define Public Hearings

Define public hearing calendars and
escalation path for agency.

Digital Assistant Set up and configure Digital Assistant

Create and configure digital assistants and
their parameters to suit your agency.

#" Note: In addition to the above, there are optional task lists and tasks available under the functional areas in

FSM.

Migrating Data From Your Test Environment to Your

Production Environment

This topic describes the utilities used to migrate setup data from your test environment to your production environment.

In your pod you have these environments:

Environment Description

Test The test environment is where you learn about the product, enter your setup and configuration data,
and test your changes. For example, this is where you add the data for setting up your agency,
create your permits, specify branding modifications for your site, and so on.
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Environment Description

Production

The production environment is the environment your agency employees and your end users access
to complete transactions. The production environment reflects the “finished product” of what was
configured and tested in the test environment.

After you have made changes and tested them in the test environment, you then migrate any changed metadata and setup

data from your test environment to your production environment. You use the Functional Setup Manager export and import
utilities to complete these tasks.

For more information on the Functional Setup Manager export and import utilities, see Using Functional Setup Manager:
“Exporting and Importing Setup Data”.

For more information on managing transaction type data, see Managing Transaction Type Configurations.

5
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Setting Up District Types

You add, modify, and delete district types on the District Type page.

Adding a District Type

1. Select Common Setup > District Type .
2. On the District Type page, click Add.
3. On the District Type Details page, enter values for the following fields:

Page Element Description

District Type Enter a unique identifier for the district type.
Description Enter a description of the district type.
District Type Category Select a category for the district type from the system-defined values:

o Inspection

o [Economic Development
o Council

o Zoning

o General

4. Turn the Enabled switch on to make the row available as a lookup value on other pages.
5. Click Save.
Modifying a District Type

1. Select Common Setup > District Type .
2. Click a row on the District Type page.
3. On the District Type Details page you can:

o Update the district type field values.

#" Note: You cannot edit the District Type field.

o Enable or disable the district type using the Enabled switch. Only enabled district types are available to select
as values on other pages.
o Delete the district type. You will be prompted to confirm the permanent deletion.
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#" Note: You cannot delete a district type that is already associated with a district or an inspection
type.

4. Click Save.

Deleting District Types

Select Common Setup > District Type .

Click Edit.

Select the check boxes next to the district types you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

pPODNS

#" Note: You cannot delete a district type that is already associated with a district or an inspection type.

Setting Up Districts

You add, modify, and delete districts on the District page.

Adding a District

1. Select Common Setup > District .
2. On the District page, click Add.
3. On the District Details page, enter values for the following fields:

Page Element Description

District Enter a unique identifier for the district.
Description Enter a description of the district.
District Type Select a district type from the agency-defined values.

See Setting Up District Types.

4. Click Save.

Modifying a District

1. Select Common Setup > District .
2. Click a row on the District page.
3. On the District Details page you can:

o Update the district field values.

#" Note: You cannot edit the District field.
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o Delete the district. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Districts

Select Common Setup > District .

Click Edit.

Select the check boxes next to the districts you want to delete.

Click Delete. You will be prompted to confirm the permanent deletion.

PODMS

Setting Up Parcels

A parcel of real estate is a tract or plot of land.

A parcel that is held by an owner is a property. A parcel location can be found on a map and is associated with a physical
address. An owner or a contracted business can apply for a permit to develop or modify a structure on a parcel, or create a
planning application for planning and zoning requests.

You add and modify parcels on the Parcel page.

Adding a Parcel

1. Select Parcel on the Agency Springboard.
2. On the Parcel page, click Add.
3. In the Basic Information section of the Parcel Details modal page, enter information in the following fields:

Page Element Description

Parcel Number Enter the assessor’s parcel number (APN) for the parcel.

The APN is a number assigned to parcels of real property by the tax assessor of a particular
jurisdiction for identification and record-keeping purposes. The APN is unique within the
jurisdiction, and may conform to certain formatting standards that convey basic identifying
information such as the property type or the location on a map.

Parcel Type Enter a parcel type such as Condo or Single Family Home.

Enabled Turn the Enabled switch on to make the parcel available as a lookup value on other pages.

4. Inthe Land Information section of the Parcel Details modal page, enter details about the land associated with the
parcel using the following fields:

o Jurisdiction

o Property Description
o Primary Zoning ID
o Zoning Description
o Subdivision
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o Boundary Description
o Land Use Code
5. In the Location Information section of the Parcel Details modal page, enter details about the parcel’s location using
the following fields:
o Block Number
o Unit Number
o Lot Number
o Section Number
6. Inthe Map Information section of the Parcel Details modal page, enter mapping details for the parcel using the
following fields:
o Map Name
o Map Book Page
o Book Number
o Latitude
o Longitude
o X Coordinate
o Y Coordinate
7. Click Save.

Modifying a Parcel

1. Select Select Parcel on the Agency Springboard..
2. Select a parcel on the Parcel page.
3. On the Parcel Details page you can:

o Update the parcel field values.
o Enable or disable the parcel using the Enabled switch. Only enabled parcels are available as lookup values on
other pages.
4. Click Save.

Deleting Parcels

Select Select Parcel on the Agency Springboard..

On the Parcel page, click Edit.

Select the check boxes next to the parcels that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PN~

#" Note: Agency staff and applicants cannot delete parcels. Only system administrators can delete parcels.
Additionally, only parcels that have not yet been associated with a permit can be deleted.

10
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Related Topics
® Setting Up Parcel Addresses

® Setting Up Parcel Owners
¢ Working with Parcel Attachments

*  Applying Conditions to Parcels

Setting Up Parcel Addresses

You add, maodify, and delete parcel addresses on the Parcel Address page.

Adding a Parcel Address

1. Select Property Information > Parcel .
Select a parcel on the Parcel page.
Click Parcel Address in the navigation bar.
2. On the Parcel Address page, click Add.
3. In the Basic Information section of the Parcel Address Details page, you can:
o Turn the Enabled switch on to make the row available as a lookup value on other pages.
o Turn the Primary switch on to indicate that this is the primary address associated with the parcel. A parcel
may have only one primary address.
4. In the Address Information section of the Parcel Address Details page, enter the following information:

Page Element Description

Zip Code If you know the zip code for the address, enter it here. The system automatically populates
the City and State based on the zip code you enter.

If you don’t know the zip code, click the don’t know link to narrow down your choice of zip
codes by entering a city and state.

Address Line 1 and Address Line Enter the street number or post office box number, along with any additional address

2 information such as apartment or suite number.

City and State Enter the city and state for the address.

Postal Code Enter the postal code for the address. The available values for this field are filtered based on

the city and state that you select.

5. In the Building and Location Information section of the Parcel Address Details page, enter the building and location
details for the parcel address using the following fields:

o Building Type

11
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o

o

o

Floor

Unit Number
Street Number
Street Name
Street Direction
Street Type
Longitude
Latitude

X Coordinate

Y Coordinate

Chapter 2

Setting Up Property Information

6. Inthe Contact Information section of the Parcel Address Details page, enter the contact information details for the
parcel address using the following fields:

o

o

[e]

o

o

[e]

Name 1 and Name 2
Email Address

Home Phone Number
Work Phone Number
Cell Phone Number
Fax Number

7. Click Save.

Modifying a Parcel Address

1. Select Property Information > Parcel .

Select a parcel on the Parcel page.

Click Parcel Address in the navigation bar.

Select an address associated with the parcel.

" Note: Select Property Information > Property Address to select a parcel address to modify from a

list of all parcel addresses.

2. On the Parcel Address Details page you can:

o

o

o

Update the parcel address field values.

Enable or disable the parcel address using the Enabled switch. Only enabled parcel addresses are available

as lookup values on other pages.
Indicate whether this is the primary address associated with the parcel using the Primary switch.

3. Click Save.

Deleting Parcel Addresses

1. Select Property Information > Parcel .

ORACLE
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w N

Select a parcel on the Parcel page.

Click Parcel Address in the navigation bar.

On the Parcel Address page, click Edit.

Select the check boxes next to the parcel addresses that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Parcel Owners

You add, modify, and delete parcel owners on the Parcel Owner page.

Adding a Parcel Owner

1.

N

4,

Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.
On the Parcel Owner page, click Add.
In the Basic Information section of the Parcel Owner Details page, enter information in the following fields:

Page Element Description
Enabled Turn the Enabled switch on to make the row available as a lookup value on other pages.
Primary Turn the Primary switch on to indicate that this is the primary owner associated with the

parcel. A parcel may have only one primary owner.

Owner and Secondary Owner Enter the names of the owner and secondary owner of the parcel.

Owner Type Enter the type of owner for the parcel such as Personal or Town.

In the Location Information section of the Parcel Owner page, enter details about the location associated with the
parcel owner using the following fields:

Page Element Description

Zip Code If you know the zip code of the owner’s address, enter it here. The system automatically
populates the City and State based on the zip code you enter.

If you don’t know the zip code, click the don’t know link to narrow down your choice of zip
codes by entering a city and state.

Address Line 1 and Address Line Enter the street number or post office box number, along with any additional address
2 information such as apartment or suite number.
City and State Enter the city and state of the owner’s address.
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Page Element Description

Postal Code Enter the postal code for the owner’s address. The available values for this field are filtered
based on the city and state that you select.

Street Number, Street Direction, Enter the street information for the parcel owner.
Street Name, and Street Type

Building Type Enter the type of building associated with the parcel owner.
Floor Enter the floor of the building for the parcel owner.
Unit Number Enter the unit number for the parcel owner.

5. Inthe Contact Information section of the Parcel Owner Details page, enter the contact information details for the
parcel owner using the following fields:

o

o

o

[e]

[e]

Email Address

Home Phone Country Code
Home Phone Number
Work Phone Country Code
Work Phone Number

Cell Phone Country Code
Cell Phone Number

Fax Country Code

Fax Number

6. Inthe Transfer Information section of the Parcel Owner Details page, enter transfer details for the parcel owner using
the following fields:

[e]

[e]

Last Transfer Type
Document Number

7. Click Save.

Modifying a Parcel Owner

1. Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.

Select an owner associated with the parcel.

#" Note: Select Property Owneron the Agency Springboard to select a parcel owner to modify from a list of

all parcel owners.

2. On the Parcel Owner Details page you can:

14
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3.

o Update the parcel owner field values.

o Enable or disable the parcel owner using the Enabled switch. Only enabled parcel owners are available as
lookup values on other pages.

o Indicate whether this is the primary owner associated with the parcel using the Primary switch.
Click Save.

Deleting Parcel Owners

1.

@ N

Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.

On the Parcel Owner page, click Edit.

Select the check boxes next to the parcel owners that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

Associating Parcels with Districts

You add, modify, and delete relationships between parcels and districts on the Parcel District page.

The association of parcels with districts is required setup for inspection scheduling. For more information, see Setting Up
Inspection Scheduling.

Adding a Parcel District Relationship

1.

@n

Select Property Information > Parcel .
Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.

On the Parcel District page, click Add.

On the Parcel District Details page, enter the district you want to associate with the parcel in the District field.
Click Save.

Modifying a Parcel District Relationship

1.

Select Property Information > Parcel .
Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.
Select a district on the Parcel District page.
On the Parcel District Details page you can:

o Select a different district to associate with the parcel.

o Delete the parcel district relationship. You will be prompted to confirm the permanent deletion.

15
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4. Click Save.

Deleting Parcel District Relationships
1. Select Property Information > Parcel .
Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.
2. Click Edit.
Select the check boxes next to the parcel district relationships you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

©

Setting Up Parcel Values

You add, maodify, and delete parcel values on the Parcel Value page.

Adding a Parcel Value

1. Select Common Setup > Parcel Value .
2. On the Parcel Value page, click Add.
3. On the Parcel Value Details page, enter information in the following fields:

Page Element Description

Parcel ID Enter the ID of the parcel for which you are defining an address.

For more information on parcels, see Setting Up Parcels.

Effective Start Date and Effective Enter the date range for which the parcel value is valid.

End Date
# Note:
You can leave the Effective End Date field blank to give the parcel an open end
date.
Parcel Size 1 and Parcel Size 1 Enter a numeric value and a unit of measure to define the size of the parcel.
UOM (parcel size 1 unit of measure)
Parcel Size 2 and Parcel Size 2 Enter a numeric value and a unit of measure to define an additional size for the parcel.
UOM (parcel size 2 unit of measure)
Land Value Enter the monetary value of the land associated with the parcel.
Improvement Value Enter the monetary value of any improvements made to the parcel.
Personal Property Value Enter the monetary value of any personal property associated with the parcel.
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Page Element Description
Fixtures Enter the monetary value of any fixtures associated with the parcel.
Owner Exemption, Fixture Enter the monetary value of any exemptions associated with the parcel.

Exemption, and Other Exemption

Net Assessed Value Enter the assessed monetary value of the parcel.

Currency Code Enter the currency that applies to the parcel value.

Property Use Code Enter the property use code associated with the parcel.

Parcel Number Displays the parcel number associated with the Parcel ID that you selected.
4. Click Save.

Modifying a Parcel Value

1. Select Common Setup > Parcel Value .
2. Click a row on the Parcel Value page.
3. On the Parcel Value Details page you can:

o Update the parcel value field values.

" Note: You cannot edit the Parcel ID and Effective End Date fields.

o Delete the parcel value. You will be prompted to confirm the permanent deletion.
4. Click Save.
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3 Setting Up Transactions

Setting Up Transaction Groups

Transaction groups are the first level of categorization that you can select when you define your permit and planning
application types.

If desired, you can set up transaction groups. This setup is not required.

Adding Transaction Groups

You add transaction groups for permits and planning applications on the Transaction Group page.

1. Select Common Setup > Transaction Group .
2. On the Transaction Group page, click Add to add a new group.
3. On the Transaction Group Details page, enter a values for the group.

Page Element Description

Group Enter a group name for the permit or planning application types.
Description Enter a description of the group.
Applicable Classification Select a product area from these options:

o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new transaction group.
5. Click Save.

Modifying Transaction Groups

You can modify transaction groups for permits and planning applications on the Transaction Group page.

1. Select Common Setup > Transaction Group .
2. On the Transaction Group page, select the row for the group that you want to modify.
3. On the Transaction Group Details page you can:

o Edit the description. You cannot change the group name.
o Select the Applicable Classification check box for permits or planning and zoning.
o Click the Enabled switch to enable or disable the transaction group.

4. Click Save to save any changes.
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Deleting Transaction Groups

You can delete transaction groups for permits and planning applications on the Transaction Group page.

Select Common Setup > Transaction Group .

On the Transaction Group page, select the row for the group that you want to delete.

If you want to delete the group, click the Delete button.

If you want to delete multiple groups, you can delete them from the grid on the Transaction Group page:

a. Click the Edit icon.
b. Select the check boxes for the transaction group rows to delete.
c. Click the Delete icon.

pPODM

Setting Up Transaction Categories

Transaction categories are the second level of categorization that you can select when you define your permit and planning
application types.

If desired, you can set up permit and planning application transaction categories. This setup is not required.

Adding Transaction Categories

You can add transaction categories for permits and planning and applications on the Transaction Category page.

1. Select Common Setup > Transaction Category .
2. On the Transaction Category page, click Add to add a new transaction category.
3. On the Transaction Category Details page, enter a values for the transaction category.

Page Element Description

Category Enter a category name for the permit or planning application type.
Description Enter a description of the category.
Applicable Classification Select an offering from these options:

o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new category.
5. Click Save.

Modifying Transaction Categories
You can modify transaction categories for permits and planning applications on the Transaction Category page.

1. Select Common Setup > Transaction Category .
2. On the Transaction Category page, select the row for the category that you want to modify.
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3. On the Transaction Category Details page you can:
o Edit the description. You cannot change the category name.
o Select the Applicable Classification check box for permits or planning and zoning.
o Click the Enabled switch to enable or disable the transaction category.

4. Click Save to save any changes.

Deleting Transaction Categories

You can modify transaction categories for permits and planning applications on the Transaction Category page.

Select Common Setup > Transaction Category .

On the Transaction Category page, select the row for the category that you want to delete.

If you want to delete the category, click the Delete button.

If you want to delete multiple categories, you can delete them from the grid on the Transaction Category page:
a. Click the Edit icon.
b. Select the check boxes for the transaction category rows to delete.
c. Click the Delete icon.

pON2

Setting Up Transaction Subcategories

Transaction subcategories are the third level of categorization that you can select when you define your permit and planning
application types.

If desired, you can set up permit and planning application type subcategories. This setup is not required.

Adding Transaction Subcategories

You can add transaction subcategories for permit and planning application types on the Transaction Subcategory page.

1. Select Common Setup > Transaction Subcategory .
2. On the Transaction Subcategory page, click Add to add a new transaction subcategory.
3. On the Transaction Subcategory Details page, enter values for the transaction subcategory.

Page Element Description

Subcategory Enter a subcategory name for the permit or planning application type.
Description Enter a description of the subcategory.
Applicable Classification Select a product area from these options:

o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new subcategory.
5. Click Save.
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Modifying Transaction Subcategories

You can modify transaction subcategories for permit and planning application types on the Transaction Subcategory page.

1. Select Common Setup > Transaction Subcategory .
2. On the Transaction Subcategory page, select the row for the subcategory that you want to modify.
3. On the Transaction Subcategory Details page you can:

o Edit the description. You cannot change the subcategory name.

o Select the Applicable Classification check box for permits or planning and zoning.
o Click the Enabled switch to enable or disable the transaction subcategory.
4. Click Save to save any changes.

Deleting Transaction Subcategories

You can modify transaction subcategories for permit and planning application types on the Transaction Subcategory page.

Select Common Setup > Transaction Subcategory .
On the Transaction Subcategory page, select the row for the subcategory that you want to delete.
If you want to delete the subcategory, click the Delete button.
If you want to delete multiple subcategories, you can delete them from the grid on the Transaction Subcategory
page:
a. Click the Edit icon.
b. Select the check boxes for the transaction subcategory rows to delete.
c. Click the Delete icon.

PN

Setting Up Transaction Statuses

Oracle provides a set of statuses for transactions to control system events. Some system statuses can be mapped to a user-
defined transaction status.

Your agency assigns statuses for permit and planning applications. You cannot delete the system-delivered transaction
statuses, but you can modify the description. You can also define additional transaction statuses, but you must associate any
new transaction status with one of the system-delivered statuses to ensure correct processing.

For information about permit inspection statuses, see Setting Up Inspection Statuses.

For information about permit plan review statuses and decision statuses, see Setting Up Plan Review Statuses.

Using Delivered Transaction Statuses

This table lists the system-delivered transaction statuses and indicates whether they can be associated with a user-defined
status.

Transaction Status System Status Code Type of Transaction Can be mapped to a user-

defined record status?

About to Expire ATE Both No
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Transaction Status System Status Code Type of Transaction Can be mapped to a user-

defined record status?

Certificate of Occupancy CO0O Permit Application Yes

Completed CMP Both Yes
Delinquent DLQ Both No
Denied DNI Both Yes
Expired EXP Both No
Hearing HER Planning Application Yes
In Process IPC Both Yes
Inspection INS Permit Application Yes
Payment Pending PAY Both No
Pending PND Both No
Pending Submittal PDS Both No
Permit Issued PTI Permit Application Yes
Plan Review PLR Permit Application Yes
Submitted SUB Both No
Voided VOD Both Yes
Withdrawn WTH Both No

When a guest submits a permit application or a planning application, the transaction status is updated as follows:

Record and System Status Description

Pending (PND) Applied when the guest saves an application.

Pending Submittal (PDS) Applied when the guest submits the application and workflow can’t be started.
Payment Pending (PAY) Applied when fees are due.

Submitted (SUB) ¢ Applied when no fees are due.
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Record and System Status Description

e Applied after successful payment.

Adding Transaction Statuses

Define any additional statuses that your agency will use for permit and planning applications on the Transaction Status page.
You must associate a new transaction status with a system status.

Select Common Setup > Transaction Status .
You can select from these transaction statuses:

N =

o Permit Status

o Planning Status

For information about inspection statuses, see Setting Up Inspection Statuses.

For information about plan review statuses and decision statuses, see Setting Up Plan Review Statuses.
3. Click Add to define a new transaction status.
4. On the respective transaction details page, enter values for these fields:

Page Element Description

Status Enter a transaction status name.

Description Enter a description for the transaction status.

System Status for Permit Select the permit transaction status that you want to use from the drop-down list:
Applications

o Completed

o Certificate of Occupancy
o Denied

o Voided

o InProcess

o Permit Issued

o Plan Review

System Status for Planning Select the planning transaction status that you want to use from the drop-down list:
Applications

o Completed

o Hearing

o Denied

o Voided

o InProcess

o Permit Issued

5. Verify that the Enabled switch is turned on. The switch is turned on by default for a new record status.
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6. Click Save.

Modifying Transaction Statuses

You can modify the transaction statuses that you have defined for your agency’s permits and planning applications on the
Permit Status Details or Planning Status Details page, respectively.

1. Select Common Setup > Transaction Status .
2. You can select from these transaction statuses:

o Permit Status

o Planning Status

For information about permit inspection statuses, see Setting Up Inspection Statuses.

For information about permit plan review statuses and decision statuses, see Setting Up Plan Review Statuses.
3. Select the row for the transaction status that you want to modify.
4. On the Details page you can:

o For user-defined statuses, edit the description or the system status that you want to set on a record with this
record status. You cannot edit the Status field.
o For system-delivered statuses, you can only edit the description. You cannot edit the Status field.

o Turn on the Enabled switch to enable a user-defined record status. You cannot disable system-delivered
statuses.

5. Click Save to save any changes.

Deleting Transaction Statuses

You can delete the statuses that you have defined for your agency on the Permit Status Details or Planning Status Details
page.

#" Note: You cannot delete most of the system-delivered statuses; you can only modify their descriptions. Oracle
recommends that you disable statuses instead of deleting them.

1. Select Common Setup > Transaction Status .
2. You can select from these transaction statuses:
o Permit Status

o Planning Status

For information about permit inspection statuses, see Setting Up Inspection Statuses.

For information about permit plan review statuses and decision statuses, see Setting Up Plan Review Statuses.
3. Select the row for the transaction status that you want to delete.
On the Details page, click Delete, if the button is available.
5. If you want to delete multiple record statuses, you can delete them from the grid on the Transaction Status page:

P

a. Click the Edit icon.
b. Select the check boxes for the status rows to delete.
c. Click the Delete icon.
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4 Setting Up Permits

Setting Up Plan Review Statuses

Use delivered plan review statuses to identify the progression through a plan review cycle. You can review the statuses on the
status definition pages.

You review the plan review statuses on the Plan Review Status and Decision Status pages. You cannot delete the system-
defined statuses or add new statuses, but you can modify the descriptions. The descriptions allow you to enter a different
status name to be displayed to agency staff.

The system derives the overall plan review status from the individual plan reviewer decisions, and updates the overall plan
review with the most severe decision status. The system-defined decision statuses are listed here from most to least severe:
Rejected, Revision Required, Approved with Comments, Approved, and Not Required. If plans have one or more rejections,
or revisions are required, the applicant must correct the plans and resubmit them for another review cycle.

Modifying Plan Review Cycle Statuses

You can edit only the Description field on the Plan Review Status Details page. The agency-defined description is exposed
to agency staff and public users on the plan review pages in the permit record detail.

1. Select Common Setup > Transaction Status .
. Select the Plan Review Status tab.
3. You can review the delivered review cycle statuses in the Review Status column:

o In Progress
o Canceled
o Completed

4. Select the row for the review status that you want to modify.
5. On the Plan Review Status Details page you can edit only the description.
6. Click Save to save any changes.

Modifying Plan Review Decision Statuses

You can edit only the Description field on the Decision Status Details page. The agency-defined description is exposed to
agency staff and public users on the plan review pages in the permit record detail.

1. Select Common Setup > Transaction Status .
2. Select the Plan Review Decision tab.
3. You can review the delivered plan review decision statuses in the Decision Status column:

o Approved

o Approved with comments
o Revision required

o Rejected

o Not required
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The plan review decision statuses are delivered as enabled. The only review decision status that you can disable is
Approved with comments.

4. Select the row for the decision status that you want to modify.

5. On the Decision Status Details page you can edit only the description.

6. Click Save to save any changes.

Setting Up Permit Types

Define the types of permits supported by an agency. You add a permit type and associate workflow process definitions on
the Permit Type definition page.

Before you can create an application form, you must first create a permit type on the permit type definition page.

This example illustrates the Permit Type definition page, which is described in the following sections.

Permit Type

Form Cancel Save

Classification
Subclassification

* Permit Type

* Permit Type ID
Status

* Autonumber Rule
* Valid from Date
Valid to Date

Public User Enabled

4 Workflow Setup
* Workflow Space Name

* Workflow Application ID

Permits
Not Applicable

Roof

Roof

Ready
PERMIT_1545711559974
01/24/2019

Open valid to date

Enabled for all users

FA Silver 2

Permits Silver2

B8 e,

Application Group
Category
Subcategory
Document Group
Inspection Group
Fee Schedule

* Bill Type

* Department

Terms of Use ID

* Workflow Version

* Workflow Process Definition

E2E_Fee_Schedule_ID
CK_Bill_Type

‘CON_RESIDENTIAL_DEPT

Building

L P PP

yel

yel

p L P

Adding Permit Type Definitions

1. Select Permit Setup > Permit Type > Permits .
2. On the Transaction Type — Permit Types page, click the Add button.
3. On the Permit Type page, enter values for the following fields:

Page Element Description

Classification Displays the type of application. The classification for this page indicates this is a permit
application.

Subclassification For use with planning applications. Accept the default value, Not Applicable.

Permit Type Enter a name for the type of permit type.

Permit Type ID Enter a unique alphanumeric code or short name for the permit type. Do not use special

characters, including symbols or punctuation, or spaces.

Status Select from the following to indicate the permit type status:
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Page Element Description

o Preliminary: The permit type is being defined but is not available for use.

o Ready: The permit type is enabled for immediate use.

# Note:
The permit design must be published in the Intake Form Designer prior to setting the
permit type status to Ready.

o Void: The permit type is no longer available.

Autonumber Rule Select the autonumbering rule to increment numbers for permits.

For more information, see Setting Up Autonumbering.

Valid from Date and Valid to Date Enter a range of dates when this permit type is valid. The default from date is the current
date. The default end date is Open. You can update these dates as needed.

Public User Enabled Select from the following to indicate whether this permit type is enabled for public users:

o Enabled for all users
o Enabled for registered users

o Not enabled for public users (default)

Initially, for a newly created permit this is always set to Not enabled for public users. When
you are ready to publish the new permit, update this value. See Publishing Intake Forms.

Application Group Select a permit application group that you want to associate with the permit type.

For more information, see Setting Up Transaction Groups.

Category Select a category that you want to associate with the permit type.

For more information, see Setting Up Transaction Categories.

Subcategory Select a subcategory that you want to associate with the permit type.

For more information, see Setting Up Transaction Subcategories.

Document Group Select a document group to manage attachments for the planning application type.

For more information, see Setting Up Document Groups.

Inspection Group Select an inspection group to associate with the permit type. The inspection group identifies
all inspections necessary for the permit.

For more information, see Setting Up Inspection Groups.

Fee Schedule Select a fee schedule that you want to associate with the permit type. A department is
required if the permit type has a fee schedule ID.

For more information, see Setting Up Fee Schedules.
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Page Element Description
Bill Type Select a bill type to associate with the permit type.

The billing type identifies the type of invoice that can be generated from the record. The bill
type is required.

For more information, see Setting Up Bill Types.

Department Select a department that you want to associate with the permit type. A department is
required if you add a Fee Schedule ID to the permit type.

If a department is specified on the Fee ltem setup page, the fee item department overrides
the department specified here on the permit type.

For more information, see Setting Up Departments.

Terms of Use ID Select a terms of use definition to associate with the permit type. When you set up terms of
use, you can make the terms available to the public user registration process, to the permit
application process, or to both. The user must accept the terms and conditions for using
online permits.

For more information, see Setting Up Terms of Use.

Setting Up Workflow for a Permit Type

You set up workflow using the Oracle Autonomous Integration Cloud (OIC) before associating the workflow with the permit
type.

For more information, see Setting Up Process Definitions for Workflow.

1. Select Permit Setup > Permit Type > Permits .
2. On the Transaction Type — Permits page, click the Add button.
3. Inthe Workflow Setup section on Permit Type page, enter values for the following fields:

Page Element Description

Workflow Space Name Enter the space where the workflow process application is stored. You can group related
applications in a space as well as enable users to collaborate when developing applications.

Workflow Application ID Enter the name of the workflow process application in OIC. For more information, see
Creating and Managing Applications.

Workflow Version Enter the version of the workflow process application.

Workflow Process Definition Enter the name of the workflow process definition that applies to this particular permit.

# Note: Different permit types can utilize the same workflow definition.
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Saving a Transaction Type

When you first save a transaction type definition, it may take a few moments to complete. On the first save, the system:

e saves all the transaction type attributes.

e creates the custom database objects (such as view objects).

e creates the REST endpoint for that transaction type.

e creates the Fusion Application sandbox needed for developing the application form layout.

Cloning Permit Types

Click the Clone button to create a clone of the current permit type, which you can then use to create a different permit or to
create a different version of the current permit.

For more information on cloning permits, see Cloning Transaction Type Definitions.

Designing Intake Forms

After you have entered the appropriate initial information for a permit, you can then begin to design the intake form that end
users will use to submit an online application. You create an application form using the Intake Form Designer. To access the
designer, click Design Form.

For more information on designing intake forms, see Using the Intake Form Designer.

Setting Up Permit Display Groups

Use the Display Group setup pages to add permit display groups that appear on your agency’s landing page, where a user
starts an application.

A permit display group identifies a meaningful grouping of permit and planning application types displayed as a list on the
Apply page. The list appears as the permits or planning applications that agency staff or a guest user can select to initiate the
application process.

Before setting up permit display groups, you must set up transaction types for your agency. See Setting Up Permit Types.

This example illustrates the Permit Display Group Details page which is described in the following text.

Permit Display Group Details Gancel | Delete

* Display Group Display Group 1 * Applicable Classification v Permits

Planning and Zoning

* Description  Display Group 1

Display Group Lines
=| |+ X Search QY
Display Order Transaction Type ID Transaction Type Classification

1 E2ESolarPermit E2ESolarPermit PMT >

Adding Permit Display Groups

1. Select Permit Setup > Permit Display Group .
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2. On the Permit Display Group page, click Add to add a new group.
3. On the Permit Display Group Details page, enter values for the following:

Page Element Description

Display Group Enter a permit display group name.
Description Enter a description of the display group.
Applicable Classification Select the check box for the applications to which this display group applies. Choose from

these options:

o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The switch is turned on by default for new permit display groups.

5. In the Display Group Lines section, click Add to set up a line on the Display Group Line Details page. The display
group lines make up the list of permit types in the new display group.

Page Element Description

Display Order Enter a numerical value in this field to specify the order in which you want the permit type
to be displayed, if desired. The default value is O and upon saving, the system automatically
assigns the next value.

Transaction Type ID Select an existing transaction type ID.

The description for the ID you enter here will appear in the Transaction Type field.

Transaction Type Review the transaction type description, classification, application group, category, and
subcategory for the permit type to verify you have selected the correct transaction type ID.

Classification

Application Group

Category

Subcategory

6. On the Permit Display Group Details page, click Save.

Modifying Permit Display Groups and Lines

You can modify permit display groups and lines on the Permit Display Group Details and Display Group Line Details pages,
respectively.

1. Select Permit Setup > Permit Display Group .
2. On the Permit Display Group page, select the row for the permit group that you want to modify.
3. On the Permit Display Group Details page, you can:

o Modify the description. You cannot change the group name.

o Turn the Enabled switch on or off to enable or disable the display group.
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4.
5.

8.

If you made any changes, click Save.

To modify the display group lines (the list of permits in a display group), select the row for the permit group that you
want to modify on the Permit Display Group page.

On the Permit Display Group Details page, select a display group line in the Display Group Lines grid.
On the Display Group Line Details page, you can change the values in these fields:

a. Update the Display Order field to change the order in which the lines appear.
b. Update the Transaction Type ID field with another existing permit type ID.
If you made any changes, click Save.

Deleting Permit Display Groups and Lines

pPODd

Select Permit Setup > Permit Display Group .

On the Permit Display Group page, select the row for the permit group that you want to delete.

If you want to delete the display group, click Delete on the Permit Display Group Details page.

If you want to delete multiple display groups, you can delete them from the Permit Display Group page:

a. Click Edit.
b. Select the check boxes for the display groups to delete.
c. Click Delete.
To delete a display group line, go to the Permit Display Group Details page and select a display group line in the
Display Group Lines grid.
On the Display Group Line Details page, click Delete.
If you want to delete multiple display group lines, you can delete them from the Permit Display Group Details page:

a. Click Edit.
b. Select the check boxes for the display group line rows to delete.
c. Click Delete.

Importing Solution Packages

Public Sector Compliance and Regulation system administrators and implementation consultants use the Oracle Cloud
Customer Connect to access the Public Sector Compliance and Regulation Solution Library — a collection of configurations
that address common community development functionality with industry best practices, provided in the form of Solution
Packages.

A solution package contains all the necessary configuration files in a compressed file format along with a metadata file.

Review the solution package contents online, download specific solutions that contain the corresponding setup data, review
them and deploy those solutions to your pre-production environment for your understanding. Each solution package provides
a link that allows you to download and review a white paper describing the contents of the particular solution package. You
can review the white paper before you decide to download the solution package.

To access the Solution Library, follow this link Public Sector Compliance and Regulation Solution Library.
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5 Setting Up Planning Applications

Setting Up Planning Application Types
Define the types of planning applications supported by an agency, including pre-applications. You add a planning application
type and associate workflow process definitions on the Planning Application Type definition page.

Before you can create an application form, you must first create a planning application type on the Planning Application Type
definition page. The type defines attributes that will be available on the planning application.

This example illustrates the Planning Application Type definition page, which is described in the following sections.

Planning Application Type

o Dsignfom Gl

Classification Planning and Zonin Hearing  Applicable v
Subclassification Not Applicable v Application Group o
* Planning Application Type FRecord12108 Category o,
* Planning Application Type ID  FRecord1210B Subcategory o
Status Ready v Document Group o
* Autonumber Rule  E2EPZRule a Fee Schedule  FeeSchedule001 o,
* Valid from Date 12/1/18 = " Bill Type  ZPER-BillType o
Valid to Date 12/25/18 = * Department 1001 o
Public User Enabled Enabled for all users v Terms of Use ID RS
4 Workflow Setup
* Workflow Space Name  FA Bronze3 v * Workflow Version 1 v
* Workflow Application ID  Permits_Bronze3 v * Workflow Process Definition  Building v

Adding Planning Application Type Definitions

1. Select Planning and Zoning Setup > Planning Application Type > Planning Applications .
2. On the Transaction Type — Planning Applications page, click the Add button.
3. On the Planning Type Applications page, enter values for the following fields:

Page Element Description

Classification Displays the type of application. The classification for this page indicates this is a planning
application.
Subclassification Displays the type of application.

If you would like to create a pre-application type, select Pre-Application from the drop-down
list. The default value is Not Applicable, which indicates a standard planning application.

Planning Application Type Enter a name for the type of planning application.

Planning Application Type ID Enter a unique alphanumeric code or short name for the planning application type. Do not
use special characters, including symbols or punctuation, or spaces.

Status Select from the following to indicate the planning application type status:
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Page Element Description

o Preliminary: The planning application type is being defined but is not available for use.

o Ready: The planning application type is enabled for immediate use.

# Note:
The application setup must be published in the form designer prior to setting the
planning application status to Ready.

o Void: The planning application type is no longer available.

Autonumber Rule Select the autonumbering rule to increment numbers for planning applications.

For more information, see Setting Up Autonumbering.

Valid from Date and Valid to Date Enter a range of dates when this planning application type is valid. The default from date is
the current date. The default end date is Open. You can update these dates as needed.

Public User Enabled Select from the following to indicate whether this planning application type is enabled for
public users:
o Enabled for all users
o Enabled for registered users
o Not enabled for public users (default)

For a newly created application type, this is always set to Not enabled for public users.
When you are ready to publish the new application form, update this value. See Publishing
Intake Forms.

Hearing Select whether public hearings are applicable or not applicable to this planning application
type.

For more information, see Setting Up Hearing Bodies, Setting Up Hearing Hierarchies, and
Setting Up Hearing Decisions.

Application Group Select an application transaction group that you want to associate with the planning
application type.

For more information, see Setting Up Transaction Groups.

Category Select a transaction category that you want to associate with the planning application type.

For more information, see Setting Up Transaction Categories.

Subcategory Select a transaction subcategory that you want to associate with the planning application
type.

For more information, see Setting Up Transaction Subcategories.

Document Group Select a document group to manage attachments for the planning application type. For
more information, see Setting Up Document Groups.
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Page Element Description
Fee Schedule Select a fee schedule that you want to associate with the planning application type. A

department is required when you enter a fee schedule ID.

For more information, see Setting Up Fee Schedules.

Bill Type Select a bill type to associate with the planning application type.

The billing type identifies the type of invoice that can be generated from the record. The bill
type is required.

For more information, see Setting Up Bill Types.

Department Select a department that you want to associate with the planning application type. A
department is required if you add a Fee Schedule ID to the planning application type.

If a department is specified on the Fee ltem setup page, the fee item department overrides
the department specified here on the planning application type.

For more information, see Setting Up Departments.

Terms of Use ID Select a terms of use definition to associate with the planning application type. The available
values for planning applications are determined by the usage on the terms of use ID.

For more information, see Setting Up Terms of Use.

Setting Up Workflow for a Planning Application

You set up workflow using the Oracle Autonomous Integration Cloud (OIC) before associating the workflow with the planning
application type.

For more information, see Setting Up Process Definitions for Workflow.

1. Select Planning and Zoning Setup > Planning Application Type > Planning Applications .
2. On the Transaction Type — Planning Applications page, click the Add button.
3. In the Workflow Setup section on Planning Application Type page, enter values for the following fields:

Page Element Description

Workflow Space Name Enter the space where the workflow process application is stored. You can group related
applications in a space as well as enable users to collaborate when developing applications.

Workflow Application ID Enter the name of the workflow process application in OIC. For more information, see
Creating and Managing Applications.

Workflow Version Enter the version of the workflow process application.
Workflow Process Definition Enter the name of the workflow process definition that applies to this particular planning
application.

" Note: Different planning application types can utilize the same workflow definition.
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Saving a Transaction Type

When you first save a transaction type definition, it may take a few moments to complete. On the first save, the system:

e Saves all the transaction type attributes.
e Creates the custom database objects (such as view objects).
e Creates the REST endpoint for that transaction type.

e Creates the Fusion Application sandbox needed for developing the application form layout.

Cloning Planning Application Types
Click the Clone button to create a clone of the current planning application type, which you can then use to create a different
planning application or to create a different version of the current planning application.

For more information on cloning permits and planning applications, see Cloning Transaction Type Definitions.

Designing Planning Application Forms

After you have entered the appropriate initial information for the planning and zoning type, you can then begin to design the
intake form that end users will use to submit an online application for a permit. You create an intake form using the designer.
You access the designer by clicking the Design Form button.

For more information on designing intake forms, see Using the Intake Form Designer.

Setting Up Planning Application Display Groups

Use the Display Group setup pages to add planning application display groups that appear on your agency’s landing page,
where a user starts an application.

A planning application display group identifies a meaningful grouping of permit and planning application types displayed as a
list on the Apply page. The list appears as the permits and planning applications that agency staff or guest users can select to
initiate the application process.

Before setting up planning application display groups, you must set up planning application types for your agency. See
Setting Up Planning Application Types.

This example illustrates the Planning Application Display Group Details page, which is described in the following text.

Planning Application Display Group Details Gancel || Delete

* Display Group PreAppGroup * Applicable Classification  Permits

¥ Planning and Zoning

* Description PreAppGroup
Display Group Lines
=| 4 | Search CU 4

Display Order Transaction Type ID Transaction Type Classification

1 PreAppType PreAppType (74 >
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Adding Planning Application Display Groups

1. Select Planning and Zoning Setup > Planning Display Group .
2. On the Planning Application Display Group page, click Add to add a new grouping.
3. On the Planning Application Display Group Details page, enter values for the following:

Page Element Description

Display Group Enter a planning application display group name.
Description Enter a description of the display group.
Applicable Classification Select the check box for the applications to which this display group applies. Choose from

these options:

o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The switch is turned on by default for new planning application display
groups.

5. In the Display Group Lines section, click Add to set up a line on the Display Group Line Details page. The display
group lines make up the list of planning application types in the new display group.

#" Note: Both permit transaction types and planning application transaction types can be added to a display
group. For example, you can add a permit transaction type to a planning application display group and the
other way around.

Page Element Description

Display Order Enter a numerical value in this field to specify the order in which you want the planning
application type to be displayed, if desired. The default value is 0 and upon saving, the
system automatically assigns the next value.

Transaction Type ID Select an existing transaction type ID.

The description for the ID you enter here will appear in the Transaction Type field.

Transaction Type Review the transaction type description, classification, application group, category, and
subcategory for the planning application type to verify you have selected the correct
Classification transaction type ID.

Application Group
Category

Subcategory

6. On the Planning Application Display Group Details page, click Save.
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Modifying Planning Application Display Groups and Lines

You can modify planning application display groups and lines on the Planning Application Display Group Details and Display
Group Line Details pages, respectively.

1. Select Planning and Zoning Setup > Planning Display Group .

2. On the Planning Application Display Group page, select the row for the planning application group that you want to
modify.

3. On the Planning Application Display Group Details page, you can:

o Modify the description. You cannot change the group name.
o Turn the Enabled switch on or off to enable or disable the display group.

4. If you made any changes, click Save.

5. To modify the display group lines (the list of planning applications in a display group), select the row for the planning
application group that you want to modify on the Planning Application Display Group page.

6. On the Planning Application Display Group Details page, select a display group line in the Display Group Lines grid.
7. On the Display Group Line Details page, you can change the values in these fields:

a. Update the Display Order field to change the order in which the lines appear.
b. Update the Transaction Type ID field with another existing planning application type ID.
8. If you made any changes, click Save.

Deleting Planning Application Display Groups and Lines

1. Select Planning and Zoning Setup > Planning Display Group .

2. On the Planning Application Display Group page, select the row for the planning application group that you want to
delete.

3. If you want to delete the display group, click Delete on the Planning Application Display Group Details page.
4. If you want to delete multiple display groups, you can delete them from the Planning Application Display Group page:

a. Click Edit.
b. Select the check boxes for the display groups to delete.
c. Click Delete.
5. To delete a display group line, go to the Planning Application Display Group Details page and select a display group
line in the Display Group Lines grid.
6. On the Display Group Line Details page, click Delete.

7. If you want to delete multiple display group lines, you can delete them from the Planning Application Display Group
Details page:

a. Click Edit.
b. Select the check boxes for the display group line rows to delete.
c. Click Delete.

Managing Pre-Application Meeting Configuration

Pre-applications are the initial step in the planning and zoning process, and are used to allow the property owner or developer
to work with agency planners to receive feedback prior to submitting planning applications. A pre-application meeting is
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scheduled between the property owner or developers and agency planners to determine the necessary applications and
approvals for the project.

Configuring the Pre-Application Meeting

Administrators set up and manage the pre-application meeting configuration on the Manage Pre-Application Meeting
Configuration page.

1. Select Pre-Application Setup > Pre-Application Meeting Setup . Or, Select Setup and Maintenance tile
on the Agency Springboard > Select Public Sector Planning and Zoning > Planning Application Types
functional area > Manage Pre-Application Meeting Configuration task.

2. On the Manage Pre-Application Meeting Configuration page, the Pre-Application Meeting section allows you to set
up applicant privileges. Enter values for the following fields:

Page Element Description

Applicant can request Select to allow an applicant to request a pre-application meeting. Applicants can access the
Pre-Application Meeting Request page. See Working with Pre-Application Meetings. and
schedule a meeting based on the availability of the agency staff.

Applicant can reschedule Select to allow an applicant to reschedule their meeting.

3. The Meeting Availability section allows you to set up the parameters for scheduling meetings, determined by:

a. Planner meeting schedule or
b. Agency meeting schedule

Planner meeting schedule: Select to allow users to schedule meetings based on the availability of their assigned
planner.

#" Note: You also need to ensure that all the Planners are assigned a Pre-Application meeting work
schedule on the Agency Staff Profile. Enter values for the following fields:

Page Element Description

Meeting Duration in Hours Select a value to set the maximum amount of time the meeting can be scheduled for. Users
will see this value as the duration of the meeting, and they are not allowed to edit the field.
See the section Scheduling a Pre-Application Meeting under Working with Pre-Application
Meetings.

Schedule up to Number of Days Select a value to set the number of days that will be available for the users to select a date
on the calendar for scheduling the meeting. For example, if you select a value of 90, the
calendar on the Pre-Application Meeting Request page displays 90 calendar days starting
from the date the user is making the selection.

See the section Scheduling a Pre-Application Meeting under Working with Pre-Application
Meetings.

Agency meeting schedule: Select to allow users to schedule meetings based on the schedule of the agency. In
addition to the fields described above, enter values for the following fields:
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" Note: If you select this option, then you need not assign Pre-Application meeting schedule to the planners
as the Pre-Application meeting schedule will not be considered while determining the availability.

Page Element Description

Pre-Application Work Schedule Select the Agency level work schedule that needs to be considered while determining the
availability for the pre-application meeting.

Maximum Concurrent Meetings Select a value to determine the maximum number of meetings that can be scheduled at a
time.

Setting Up Hearing Bodies

With Oracle Public Sector Compliance and Regulation Cloud, you will use the Public Hearing feature to configure hearing
bodies and hearing hierarchies, schedule hearings, and record decisions.

Setting Up Public Hearing

A public hearing is an official meeting where members of the public, the hearing body, and the applicant of the planning and
zoning application come together to discuss the facts about the application submitted by the applicants.

The following topics apply to administrators for setting up and maintaining the Public Hearing process:
e Setting up Hearing Body

e Setting up Hearing Hierarchy
e Setting up Hearing Decision

Setting Up Hearing Body

A hearing body is a group of individuals formed to evaluate the testimony presented by applicants and to provide feedback.

Adding a Hearing Body

To add a hearing body:

1. Select Hearing Setup > Set Up Hearing Body .
2. Click Add on the Hearing Body page and enter values for the following fields:

Page Element Description

Hearing Body Code Enter a unique identifier of the hearing body.
Name Enter a name for the hearing body.
Additional Information Enter any text as details about the hearing body.
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Page Element Description

Enabled Turn on the switch to make the hearing body available for use.
Appeal Period Select the number of days after the public hearing, when an appeal is allowed.
Maximum Agenda ltems Select a value from the options. As an agency user you can configure the maximum number

of agenda items that can be heard on a day.

Address fields Enter the address of the hearing. Enter the ZIP code, or click the Don’t Knowlink to enter
values for the following fields:

o Country: U.S (Default value)
o ZIP Code

o Address Line 1

o Address Line 2

o City

o State

o Postal Code

3. Select a pattern of recurrence of the meeting from these fields:

Page Element Description

Recurrence Pattern Select the pattern for the recurrence of the public hearing:
o Weekly
o Monthly

4. Select the Weekly recurrence if you want to schedule the meeting every week. Enter values for the following fields:

Page Element Description

Weeks between Occurrences Select the number of weeks between one meeting occurrence and the next.
Days of the Week Select the days of the week on which you want the meeting to recur.
Recurrence Start Date Time Select a date and time from which the meeting recurrence should be effective.

5. Select the Monthly recurrence if you want to schedule the meeting every month. Enter values for the following fields:

Page Element Description

Months between Occurrences Select the number of months between one meeting occurrence and the next.
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Page Element Description

Days of the Week Select the check box if you want to schedule the meeting on particular days of the week.
Click Add to open the Days of the Week page and select the days of the week, for example

First Monday:

o Occurrence: Select — First, Second, Third, Fourth, or Last the day of week

o Weekday: Select the day of the week from Monday, Tuesday, and so on.

Turn on the Enable switch to make the setting available for use and click Save. Use the

Add button to include multiple rows.

\J
# Note:

You can modify or delete the entry. Click the row and use the Days of the Week

page to make the change.

Dates Select the check box if you want to schedule the meeting on particular dates of the week.

Click Add to open the Dates page and select from all the available dates.

Turn on the Enable switch to make the setting available for use and click Save. Use the

Add button to include multiple rows.

g
# Note:

You can modify or delete the entry. Click the row and use the Dates page to make

the change.

Recurrence Start Date Time Select a date and time from which the meeting recurrence should be effective.

Click Save to save the new hearing body and return to the Hearing Body page.

Modifying a Hearing Body

To modify a hearing body:

1.
2.
3.

4.

Select Hearing Setup > Set Up Hearing Body .
On the Hearing Body page, click the record of the hearing body you want to edit.
On the Hearing Body details page you can make changes to the fields and click Save.

" Note: You can make changes to all the fields except the Hearing Code.

The Hearing Body page now lists the updated record.

Deleting a Hearing Body

To delete a hearing body:

PN

Select Hearing Setup > Set Up Hearing Body .

On the Hearing Body page, click the record of the hearing body you want to delete.

On the Hearing Body details page you can click the Delete button. Click OK on the confirmation message.
The Hearing Body page lists only the existing records.
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Setting Up Hearing Hierarchies

Hearing Hierarchy defines the levels of hearing bodies that an application can be escalated through. In an agency, a planning
and zoning application can be escalated to a higher body in cases of appeal, where the highest hearing body decision is
considered final.

Agencies set up their hearing hierarchy to address events such as an appeal. For example, a hearing begins with the Planning
Committee and then an appeal escalates the application to the Planning Commission. If appealed again, the application
moves to the City Council.

Adding a Hearing Hierarchy

To add a hearing hierarchy:

1. Select Hearing Setup > Set Up Hearing Hierarchy .
2. Click Add on the Hearing Hierarchy page and enter values for the following fields:

Hierarchy Code Enter a unique identifier of the hearing body.

Hierarchy Enter a name for the hearing hierarchy.

Enabled Turn on the switch to make the hearing hierarchy available for use.
Description Enter any text to describe the hierarchy.

3. Click Add and enter values for the following fields:

Page Element Description

Hearing Body Code Select a hearing body code to associate with the new hearing hierarchy.

Sequence Select a number to determine the escalation level of the selected hearing body within the
hierarchy. For example, if the value 2 is selected, the selected hearing body will be the
second in the hierarchy for the public hearing.

Appeal Allowed Turn on the switch if you want to allow the agency to appeal after the hearing body places
its decision. The agency will not be allowed to appeal the hearing to the next body in the
hierarchy, if the switch is turned off.

Enabled Turn on the switch if you want to allow the hearing body to be available for use.

Click to add a new row and add a new hearing body in the hierarchy.

m Click to delete the row. The hearing body will be removed from the hierarchy.
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4. Click Save to save the newly created hierarchy and return to the Hearing Hierarchy page, where the new hierarchy
you created is listed.

Modifying a Hearing Hierarchy

To modify a hearing hierarchy:

1. Select Hearing Setup > Set Up Hearing Hierarchy .
2. On the Hearing Hierarchy page, click the hearing hierarchy row you want to edit.
3. On the Hearing Hierarchy details page make changes to the fields and click Save.

" Note: You can make changes to all the fields except the Hierarchy Code.

Deleting a Hearing Hierarchy

To delete a hearing hierarchy:

1. Select Hearing Setup > Set Up Hearing Hierarchy

2. On the Hearing Hierarchy page, click the hearing hierarchy row you want to delete.

3. On the Hearing Hierarchy details page, click Delete and click OK on the confirmation page to delete the hearing
hierarchy.

4. Click Save and return to the Hearing Hierarchy page. The page lists the updated hierarchy rows.

Setting Up Hearing Decisions

The outcome of a public hearing is referred to as hearing decision. Agency staff such as assigned planners update the
decision from the hearing body into the system.

System-defined Public Hearing Decisions

Oracle delivers hearing decisions for use during the hearing process. System administrators can configure the decisions
specific to their agency, which are mapped to one of the system-defined decisions listed below:

e Approved
e None

e Denied
e Continue

Adding a Hearing Decision

1. Select Hearing Setup > Set Up Hearing Decision .
2. The Hearing Decision page lists all the decisions you have configured. Click Add.
3. One the Hearing Decision Status detail page, enter values for the following fields:

Page Element Description

Code Enter a unique identifier of the hearing decision.
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4. Click Save to save the new hearing decision and return to the Hearing Decision page, which lists the newly created
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Name Enter a name to identify the decision. Example, Approved with Conditions, Not Result, and
SO on.

Description Enter any text to describe the decision.

Decision Select one of the system-defined decisions to map to the new decision you are creating:

o Approved:
o None
o Denied

o Continue

Enabled Turn on the switch to make the decision available to use.

decision.

Modify a Hearing Decision

To modify a hearing decision:

1.

Select Hearing Setup > Set Up Hearing Decision .

2. The Hearing Decision page lists all the decisions you have configured. Click the row of the decision you want to

modify.
On the Hearing Decision detail page, make changes to the fields and click Save.

#" Note: You can make changes to all the fields except the Code.

4. The Hearing Decision page lists the updated row.

Deleting a Hearing Decision

To delete a hearing decision:

1.

Select Hearing Setup > Set Up Hearing Decision .

2. The Hearing Decision page lists all the decisions you have configured. Click the row of the decision you want to

delete.
On the Hearing Decision detail page, click Delete and confirm deletion by selecting OK.
Click Save and return to the Hearing Decision page. The page lists the updated decision rows.

ORrRACLE



Oracle Public Sector Compliance and Regulation Chapter 5
Implementing Community Development Setting Up Planning Applications

48
ORACLE



Oracle Public Sector Compliance and Regulation Chapter 6
Implementing Community Development Creating Intake Forms

O Creating Intake Forms

Intake Form Designer Topics

The following topics apply to using the Intake Form Designer to create and publish intake forms, which registered users
access online to initiate transactions, such submitting a permit application.

® Using the Intake Form Designer

e Working with Sandboxes

e Working with Pages

e Working with Predefined Form Elements

® Using Predefined Form Elements

e Working with Group Boxes

e Working with Fields

e Adding Rich Text Areas

e Defining Fields Displaying a List of Values
e Displaying Form Elements Conditionally

* Adding Logic

e Adding Contextual Help to Forms

e Setting Form Options

e Mapping Form Fields to Decision Model Attributes
e Considering User Experience

e Testing Intake Forms

e Publishing Intake Forms

e Cloning Transaction Type Definitions

e Managing Transaction Type Configurations

Using the Intake Form Designer

This topic describes the purpose of the Intake Form Designer, lists the prerequisites that must be completed prior to creating
a form, and introduces you to the designer interface.

" Note: For the 19.04 release, it is not recommended to use the Intake Form Designer with Internet Explorer.
Preferred browsers include Chrome or Firefox.

For any municipality that grants permits to citizens and handles planning and zoning applications, an intake form needs to be
submitted by the citizen or registered user that captures the information required as prerequisites to initiating the process.
The intake form can be a paper form or an online web page. With Oracle Public Sector Community Development, you use the
Intake Form Designer to create application forms your citizens can access online and submit and monitor through the cloud.
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Oracle does not deliver a predefined form for each type of transaction because for each form and for each municipality, the
information required will be unique.

For example, for a fence permit, the City of San Diego may require only basic information about the material to be used and
the measurements. On the other hand, the City of Sacramento may require the same information as San Diego, but also
require the contact information of the contractor building the fence, the exact location of the fence, the area enclosed by the
fence, and so on. Each municipality has its own set of requirements so you need to be able to tailor the forms to reflect your
agency's requirements.

The Intake Form Designer enables you to create unique online application forms for each transaction your municipality offers.
The Intake Form Designer provides modular sets of common fields, called predefined form elements, which you can use like
building blocks to assemble the online application form. If a predefined form element does not contain fields you require, you
can add user-defined form elements (custom fields) to meet your requirements.

Once you have created, configured, and tested your form, you can publish the form for end users to access, complete, and
submit for review and approval.

# Note: For simplicity, in documentation, the Intake Form Designer is often referred to as “the designer,” and an
intake form is often referred to as a “form.”

Completing Prerequisites
Before creating an online form, you need to:
e Create a transaction type.

For more information on creating a transaction type, see Setting Up Permit Types.

e Set up any fees associated with the form.

For more information on fees, see Setting Up Fee ltemsand Setting Up Fee Schedules.

Accessing the Designer

Before you can create an application form, you must first create a transaction type on the Transaction Type page.

From the Transaction Type Definition page, select the Design Form button.

Working with the Designer Interface

This example illustrates the interface of the designer when you begin creating an application form. The elements of the user
interface are described below the image.
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Page Element Description

Status Indicates the status of the current design.
e Draft: the form is in sandbox mode, which means only the implementation team can access,
view, and change the form design.

e Published: the form is available to end users on the landing page.

For more information on form status, see Working with Sandboxes.

Manage Sandbox Click to access the Oracle Fusion Applications Sandboxes page where you can view the status of
your sandbox and refresh your sandbox if needed.
For more information on sandboxes, see Working with Sandboxes.

Preview Enables you to preview your form to test layout, design, and data entry.

Save Saves changes made to the form design.

Publish Publishes the completed form design so that end users can access it from the landing page and
submit applications.

Next Takes you to the Fee Mapping page.

For more information on mapping fees, see Mapping Form Fields to Decision Model Attributes.

Form Options Click to display the Form Options dialog box where you can set options that apply to the entire form.

For more information on form options, see Setting Form Options.

Contains lists of all pre-defined and user-defined elements you can add to your form design. The
Elements panel contains all of the items that you use to build an intake form.

Elements panel
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Add Tab Adds additional pages to your form. You navigate between the pages by using the page tab for
each page.
Workspace The area where you drag and drop form elements from the Elements panel and configure them. This

is the main area used for creating and configuring your forms.

Attributes panel Displays the available attributes that you can configure for the currently selected form element. For
example, if you have a field selected, the attributes panel reads "Field Attributes,” and it contains
attributes specific to fields. If you have a group box selected, the attributes panel reads "Group Box
Attributes,” and it contains attributes specific to group boxes.

Viewing the Tasks for Creating Forms

This section provides the core set of tasks to complete when creating an intake form. The remaining topics in this chapter
discuss the details of each task.

Step Link

Add page tabs. Working with Pages

Add predefined form elements. Working with Predefined Form Elements
Modify field attributes. Working with Fields

Add group boxes. Working with Group Boxes

Add user-defined form elements. Working with Fields

Making Changes to Labels for Application Form Elements

When making changes to the labels for elements within your application form, you need to consider what type of element it is.
Changing the label of some elements is a global change, while changing the label of other elements is a local change.

e Global: A global label change means that a change to the label affects every intake form definition using that field or
element.

e | ocal: Alocal label change means that a change to the label affects only the current intake form definition where the
field or element appears.

When you select a form element or field and a label change would have global effects, a warning icon appears above the
Label field in the attributes panel.

When selecting an item in the workspace, if changing the label for that item has global effect on all application forms using the
item, the system displays a warning icon.

52
ORrRACLE



Oracle Public Sector Compliance and Regulation Chapter 6
Implementing Community Development Creating Intake Forms

- - = B

Changing this label affects all application forms
using this field. It is a global change. Field Attributes

* A

_I:}

Demolition Reason

Label

" Note: If you change the label of a field after a form has been published and used in the production system, keep
in mind this can affect reporting and the storage of historical data. You may have multiple labels representing the
same data.

Form Element Scope of Label Change Label Change Considerations

Predefined Elements Global The label of a predefined element is the
heading used to describe the grouping of the
fields it contains.

Changing the label of a predefined element is
a global change.

For example, if you change the label in the
Applicant predefined element used in the
fence permit intake form, that change will
be reflected in the Applicant predefined
element used in the electrical permit intake
form (and any other application form using
the Applicant predefined element).

Predefined Element: Parent Field Local Some fields appearing in predefined form
elements are part of the parent record within
the data structure storing the transaction
data.

You know a predefined element field is part
of the parent record when the warning icon
does not appear above the Label field in the
elements panel.

For example, the Description field in the
Application predefined element does not
display the warning icon. Changing this label
affects only the current intake form definition.
It is a local change.

Predefined Element: Child Field Global Some fields appearing in predefined form
elements are part of a child record within the
data structure storing the transaction data.

You know a predefined element field is
part of a child record when the waming
icon appears next to the Label field in the
elements panel.

For example, the Demolition Reason field in
the Demolition predefined element displays
the warning icon. Changing this label affects
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Label Change Considerations

predefined element. It is a global change.

all intake form definitions using the Demolition

User-Defined Elements Local

You can change the labels for the fields that
you add to your application forms, such as
text fields, number fields, drop-down lists,
and so on. Because you add these fields
manually to your application form, you can
change the default labels as needed to suit
your business requirements.

The scope of any changes to the label for
user-defined fields apply only to the current
intake form.

HTML Constructs Local

A general HTML construct refers to elements
such as group boxes and page tabs.

You can change the labels for general HTML
constructs as needed to suit your business
requirements. The scope of the construct
and any changes to the label apply only to
the current intake form definition.

For example, changing the label of the default
label for HTML constructs such as Group
box or Field O to your desired label affects
only the current intake form definition.

#" Note:
If you change a label for a page tab
or a group box used in an application
form after the form has been published
and used in the production system,
make sure to update any instructions
or documentation that may reference
the previous label.

#" Note: For HTML constructs, such as pages and group boxes, and for user-defined fields the labels display
using the language used to create or modify the application form layout. There is no automatic translation of
these elements. For example, if you created the form in English, but then signed in using Korean for testing,
you will see the English labels for those constructs, unless you have provided translated values using the Fusion
Applications User Interface Text tool. For more information on the User Interface Text tool, see: User Interface

Text Modlification.

Working with Sandboxes

This topic provides an overview of the concept of sandboxes and how they are used within the Intake Form Designer, and it

describes sandbox usage and behavior.

ORrRACLE
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Most modern development environments typically require several different individuals to work simultaneously on application
changes while sharing the same data model and configuration starting point. The Intake Form Designer utilizes the Oracle
Fusion Applications technology referred to as sandboxes to enable form developers to work on projects simultaneously, and
save and test their work without affecting other developers or the production environment..

The sandbox acts as the development and test mode of your application form. During sandbox mode, the form design can
be viewed only internally by application developers or business analysts. In sandbox mode you can create your form, add
required form elements, add Ul elements, and test your changes. When you have completed all of your design, development,
and test work, you can then publish the form so it can be accessed by end users.

" Note: Creating and modifying transaction types and intake forms should be completed on your test system.
After making changes, publishing, and testing transaction types and intake forms on your test system, you would
then migrate the new and modified definitions to your production system. Refer to the Functional Setup Manager
documentation for information on migrating data from the test system to the production system, as well as
Managing Transaction Type Configurations.

Starting a Sandbox Instance for a New Application Form

Before you can create an application form in Intake Form Designer, you must first create the transaction type. For example,
for the permit service, the transaction type is a permit. When you save a permit type, the application creates a sand box
instance. From that point, the transaction type and the associated form design exist within the newly created sandbox
instance.

Each form your implementation team is currently developing exists within its own, separate sandbox instance.

Until you publish the form, the transaction type and the form design remain in the sandbox instance. When you publish a
transaction type, the system eliminates its sandbox instance, and the form is available to users outside the sandbox.

Starting a Sandbox Instance for a Published Intake Form

After an application form has been published, you can initiate sandbox instances to make any required changes discovered
after the initial publication.

To initiate a sandbox for a published form:

Open the transaction type for the form.
Select Design Form.

Begin making the desired changes.
Click Save.

poODN =

By clicking Save, the Intake Form Designer creates a new sandbox instance to store the current changes.

Viewing the Sandbox Status

You can determine if a form is in sandbox mode using the Status indicator located in the top left-hand corner of the Intake
Form Designer. The Status indicator appears when you are creating the form or previewing the form. The sandbox status
does not appear on the published version of the form.

Status Description

draft The form is in sandbox mode. All changes exist in the sandbox instance only.
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Status Description
published The form is not in sandbox mode. The form is available to the runtime environment, where you can

access the form from the landing page.

Refreshing a Sandbox

Each application form is assigned to its own sandbox. Because transaction types share underlying metadata resources,

if during the development of a transaction type or intake form some of the shared metadata resources get updated by
another member of the implementation team, each transaction type also using the shared metadata resources needs to be
synchronized with the most recent metadata updates.

To synchronize the metadata between permits, you need to refresh the sandbox for unpublished transaction types.

You will know that your sandbox is not synchronized with the current metadata resources when you see this message when
you attempt to publish the transaction type:

The application was unable to publish the permit. Click the Manage Sandbox button to access the page where you can
refresh the sandbox.

To refresh a sandbox:

1. In Intake Form Designer, click Manage Sandbox.

This takes you to the Sandboxes page in Oracle Fusion Applications.
2. On the Sandboxes page locate the sandbox for your transaction type.

The sandbox naming convention is: <Transaction Type Code>__sb_<number of publications>.

For example, if for a permit, the Type Code value is REMODEL, and the sandbox has been published once
previously, the sandbox for that permit is named REMODEL__sb_1.

3. Click on the sandbox you need to refresh.
4. On the Sandbox Detail page review the messages related to the status of your sandbox.

You may notice the Current Status reads Refresh needed and the following note:

This sandbox is not synchronized with the mainline environment. You can refresh the sandbox before making any
further changes.

5. On the Sandbox Detail page, click Refresh.

6. Click Yes on the prompt indicating you are about to refresh your sandbox and that you can’t make changes to the
sandbox during the refresh.

This returns you to the Sandboxes page.
View the Status column on the Sandboxes page, which indicates your sandbox is refreshing.

8. Click on the sandbox again to access the Sandbox Detail page to confirm your sandbox Current Status is Up to
date.

N

You may need to review the merge log and accept changes manually if needed.
9. Once your sandbox is refreshed, close the Sandboxes page, and return to the designer.
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Working with Pages

This topic describes how to add pages to your application form and how to modify page attributes.

An application form can include one or more pages to contain the form elements and fields that you want to add to your form.

Adding Pages
When you create a form, by default, the application includes one page for your form. To add additional pages to your form,
click the Add Tab button at the top of the workspace.

Setting Page Attributes

Page Element Description

Label The name of the page that appears on the page tab. The default name is Page1, Page2, and so on.
Change the name to your desired label, and tab out of the field.

Hide From Public User Hides the page tab and all the elements on the page from the public user at runtime. Only agency
staff can view and update information for a page with Hide From Public User turned on. In addition
to hiding the Ul element from the public user in the interface, the application also secures the back
end for that specific Ul element, such as preventing any unauthorized access to the fields within the
Ul element using a REST API, for example.

Help Click to launch the Contextual Help page, which you can use to add help information to aid end
users in completing the application form.

Page-level help should provide information pertaining to the overall page content. If the information
applies to a specific Ul element on the page, such as a component, group box, or field, consider
adding help directly to that Ul element.

For more information on adding contextual help, see Adding Contextual Help to Forms.

Deleting Pages

If you delete a page from your form, keep in mind that any Ul elements you have added to the page, such as predefined form
elements, group boxes, and fields will also be removed from your form.

To delete a page from your form:
1. Click the Remove button on the tab (the ‘x’ on the right side of the page tab.

2. On the Confirm dialog box, click OK.
3. Save your changes.

# Note: If using keyboard keys: use the tab key to get to the tab bar, select a tab element using right/left arrows,
use the Delete key to delete the tab element, and press OK to confirm.
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Working with Predefined Form Elements

This topic provides an overview of form elements and how you use them to build your application forms.

Oracle provides a set of predefined form elements to help you build application forms easily. Each predefined form element
contains a collection of fields commonly used to describe a particular facet of the transaction type. Using predefined form
elements, you can assemble simple online application forms in a matter of minutes.

Predefined form elements are:

* Pre-mapped to attributes in the application view object (VO), which ultimately are mapped to fields in the SQL tables
in the application database.

e Grouped logically to provide descriptive metadata for a particular element of an intake form, such as Applicant,
Electrical Equipment, Pool Information, and so on.

You drag the desired predefined element from the Elements panel onto the workspace. You use various combinations of
predefined and user-defined form elements to assemble your application forms.

For example, assume that you need to create a form for citizens to apply for a roofing permit. In this case, you can drag the
Applicant element and the Re-roof Information element onto the workspace to build your form.

Page Section Example Page Section Fields

Applicant Name
Address
Phone

Re-roof Information Roof Size
Roof Type

Roof Material

Pitch

For more information on the delivered predefined elements, see Using Predefined Form Elements.

Adding Predefined Elements

To add a predefined form element to your form:

Make sure the page to which you want to add the predefined form element is the active page.
Expand the Predefined Elements list in the Form Elements panel to the left of the workspace.
Click on the desired element to activate.

Select the element to drag and drop the it in the workspace.

pPODd

" Note: Intake Form Designer places the predefined elements in the workspace in the same order in which they
are dropped, in sequence, from top to bottom.
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" Note: The Applicant predefined form element is required to be added to your application forms. The internal
save logic checks for a valid applicant address when an end user attempts to save or submit an application
form. It is recommended to include also the Application Information predefined element, which displays useful
information, including the transaction ID, status, description, important dates related to the application, and so
on. If the transaction type requires fees, then the Fee Summary predefined element should also be added to your
application form.

Deleting Predefined Elements

To delete a predefined element, click the Remove button (the X’) in the upper, right-hand comer.

Setting Predefined Element Attributes

Page Element Description

Label The name of the predefined form element. Initially displays an internal reference for the default label.
When modified, the new label displays.

¢ Note:

»
Changing the label for predefined form elements can cause unexpected results if you don’t
consider whether the change will be local to the transaction type or global, affecting all
transaction types.

Show Label Control whether to show the label. By default, the system shows labels for predefined form elements
(Show Label is on).

To hide the label, turn off Show Label. When turned off, the system hides the label at both design-
time and runtime.

Typically, you’'d want the label to be visible to describe the logical grouping of the fields in the form
element.

In some cases, the page tab name and the predefined element label might be redundant, in which
case you may opt to hide the label.

You may also want to group multiple predefined form elements within a single group box. In this
case, you can hide the individual predefined element labels within the group box container, using the
group box label to represent the combined set of fields.

‘l‘ Note:
When you turn off Show Label, the system disables the collapsible feature for a predefined
form element.

¢ Note:

»
If the predefined element is delivered without a label, the Show Label attribute does not
appear when you select that form element.

Hide From Public User Hides the predefined form element and all the fields and controls it contains from the public user at
runtime. Only agency staff can view and update information for a predefined form element with Hide
From Public User turned on.
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Page Element Description

In addition to hiding the Ul element from the public user in the interface, the application also secures
the back end for that specific Ul element, such as preventing any unauthorized access to fields
contained within the Ul element using a REST AP, for example.

Help Click to launch the Contextual Help dialog box, which you can use to add help text to a predefined
form element for assisting users with interacting with your intake form. When adding help for a
predefined form element, the help text should apply to the overall contents of the predefined form
element. You can add help also at the page level and the field level, depending on the scope of the
help text.

For more information on adding contextual help to your intake form, see Adding Contextual Help to
Forms.

Adding a Predefined Form Element Multiple Times to the Same Form

The same predefined form element can be dragged into your form multiple times. This is referred to as a multiple-instance
element. How you adjust the Multi-Instance Options attribute determines how the application stores the data for that
predefined element.

" Note: The Multi-Instance Options attribute appears only for the Comments and the Attachments elements.

If you make no changes to the Multi-Instance Options attribute, the data entered within that predefined element corresponds
to one row of data only. In this case, the system duplicates the display of the data in each area of the form it is displayed. This
option enables you to show the same data on a different tab within the form, if necessary. Updating the data in one instance
of the predefined element updates the data displayed in the other instances as well.

For example, assume you want the same comment text to appear on multiple pages in your form. You can do this by adding
the Comments element to the desired pages without making any updates to the Value field in the Multi-Instance Options
attribute.

If you make changes to the Multi-Instance Options attribute, the application considers each instance of the predefined
element unique, and then each individual occurrence of the predefined element is associated with its own row of data.

For example, assume you wanted to incorporate multiple comment sections in your form. In this case, you can add the
Comments element to multiple locations of your form, and then you set the Multi-Instance Options attribute to different
values. One might relate to fencing comments while another might relate to contractor comments. Another example would be
to enable the end user to upload multiple attachments that apply to separate documents. One attachment might be photos of
a property while another attachment might be blueprint or design documents.

Using the Keyboard to Drag and Drop Elements

You can use keyboard hot keys to drag and drop elements.

Key Description

Enter Use to:

e Expand or collapse the Predefined Element or User-Defined element lists.

¢ Drop a selected element onto the selected drop zone
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Key Description
Tab Use the tab key to select either the first element in the list or the last selected item in the list if a

previous visit was made to the list.

Up and Down Arrows Use to:

e Select an item in the Predefined Element or User-Defined element lists.

e Select a location from the drop zone list. The selected drop zone is highlighted.

Space When an element is selected, the space key highlights the selected element and displays available
drop zones for the current page on the Select a Drop Zone dialog box. The drop zones can be
the page or group boxes contained by the page. For user-defined fields, the drop zones are group
boxes.

Using Predefined Form Elements

This topic lists and describes the set of predefined form elements delivered to help you build forms quickly and consistently.

Predefined form elements are prebuilt user interface modules that you can use as building blocks for assembling forms. Each
element contains a set of fields and functionality specific to various sections of an application form.

Common Predefined Elements

Form Element Description

Applicant Identification and contact information for the citizen filling out the form, including name, address,
phone, and email.

Application Displays information about the form itself, such as status, relevant dates, and descriptions.

Attachments Enables you to attach and download files, such as documents or images. You determine document
properties displayed in the list of attachments and during upload.

Contains multiple instance options to create unique instances of the attachment element.

Comment Enables you to enter additional comments or descriptions pertaining to information on the form.

Contains multiple instance options to create unique instances of the comments element.

Contact Details Enables you to add information for individuals or organizations that are contacts for an application.
Fee Summary Lists the items selected, the cost for each item, and the total amount to be paid when submitting
the form.
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Form Element Description
,f Note:

This does not include additional inspection or other fees which may be assessed at a later

time.
Property Describes the parcel as it is registered with the municipality, such as the parcel ID, parcel type, and

SO on.

Site and Zoning Describes features of the property related to acreage, flood preparedness, as well as zoning and

land usage information.

Terms of Use Provides access to the terms and conditions regulating the usage of the online form, and provides a
way for the user to accept the terms. This element does not identify which Terms of Use definition to
use, so if you add this element to an application intake form, you need to also add a Terms of Use
definition on the Permit Type or Planning Application Type page.

The Display Mode property has these options:

e Link: the form displays a Terms and Conditions link that the user clicks to open a window
with the full terms and the check box for accepting the terms.

e Embedded: the full text of the terms appears directly on the form.
If the display mode is Link, these two additional properties are available:

¢ Help Text: Enter informational text that appears on the form along with the Terms and
Conditions link.

¢ Display Label: Enable this option to display the description of the Terms of Use definition on
the form along with the Terms and Conditions link.

¢ Note:

»
This element is not used to set up public user registration terms and conditions. The Public
User Setup page includes all registration-related configuration.

Attachments Element

You can configure the attachments element and add it into your form multiple times. Attachments provide supporting
documentation needed by agency staff to determine if a permit can be issued.

Configurable Features Description

Component Attributes You can name the attachments component title in the Label field.

Component Multi-Instance Options Use these multiple instance options to create unique instances of the attachment element:
e ID
e Value

For more information about multiple instance options, see Working with Predefined Form
Elements.
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Configurable Features Description
Attachment Columns: You can configure these attachment properties in the attachments list:

¢ File Name: Display the file name of the uploaded file.
e Description: Display the user-entered description.

¢ File Size: Display the size of the uploaded file.

Business Columns: Agency-defined document categories and document subcategories enable you to organize
the various types of attachments. You can configure these fields for document categories and
* DocumentCategory document subcategories:

* DocumentSubcategory e Label: Change the field name.

e Show in List: Display the field in the attachments grid.

e Show in Detail: Display the field in the attachment detail information.

e Show in Upload: Display the field on the modal page for uploading an attachment.

e Searchable: Enable search on the document category or document subcategory field.

e Sortable: Enable sorting for the document category or document subcategory field.

Predefined Permit Elements

Form Element Description

Business Information Captures information to help describe the business, such as name, description, number of
employees, industry, and so on.

Construction Information Captures information regarding the current construction site and the proposed construction project.

Demolition If demolition is required as part of the job, this element captures information related to the scope of
the demoalition and if hazardous materials or utilities need to be considered, such as electricity, gas,
water, and so on.

Electrical Equipment Describes a structures electrical features, such as outlet types, amps, voltage, and electric
appliances.

Fence Information Describes the proposed fence attributes, such as type, material, dimensions, location, and so on.

Grading Information Describes the scope of grading work, such as the acreage affected, materials to be used and the

amount of material.

Insurance Provides a contractor’s insurance type and policy information.
License Qualification Enables a contractor to add any state licences they have.
Mechanical Equipment Describes features of the job site related to ventilation, heating, cooling, fire safety, and so on.
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Form Element Description
Photovoltaic Information Describes attributes of a site’s solar energy configuration, such as roof area, coverage area, inverter

information, and so on.

Plumbing Equipment Describes attributes of a site’s plumbing configuration.
Pool Information Describes attributes of a pool, such as type, depth, location, surrounding fencing, and so on.
Regulated Business Activity Enables you to specify any regulated activity or controlled substances allowed on the premises,

such as alcohol, carnival rides, casino games, and so on.

Right of Way Use Enables you to provide any details related to the use of a right-of-way on the property or to gain
access to the property, such as traffic, parking, or pedestrian impact.

Roof Information Describes features of a structure’s roof, such as existing roof type, proposed roof type, number of
layers, and so on.

Special Event Enables you to specify information about an event, including the safety plan, concessions, facilities,
potential impacts, and traffic plans.

Yard Sale Enables you to specify yard sale information, such as the start time, end time, and the number of
days.

Working with Group Boxes

This topic describes how to add group boxes to your form and discusses group box layout options and attributes.

Use group boxes as containers to indicate the items contained within a group box are grouped logically. Once you add a
group box to a page, you can drag these items into the group box:

e Predefined elements
e User-Defined elements

e Other group boxes (nested group boxes)

Adding Group Boxes

To add a group box:

1. Select the Ul Elements tab in the Form Elements panel.
2. Click and hold on the Group Box option.
3. Drag and drop the group box into the workspace.

Deleting Group Boxes

To delete a group box, click the Remove button in the upper right-hand corner of the group box.
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" Note: If you remove a group box from a page, the system removes all of the contents of that group box also.

Setting Group Box Attributes

Select a group box to view the Group Box Attributes panel.

%
Group Box Attributes
Label
Group box

Collapsible O
Flexible Box Layout (:)

Show Label (:)
Hide Border O

Hide from public user

Add Help

Page Element Description

Label Add a name for the group box, describing the collection of items within it.

Collapsible Turn on to enable the group box to be collapsed when an end user clicks it, hiding items it contains.
If not turned on, the group box is always expanded and its items are always visible.

Flexbox Layout With Flexbox Layout enabled, the system displays as many controls within the group box in one line
until all of the space is utilized, then the system wraps the row, beginning a new line.

With Flexbox Layout disabled, the controls within the group box display as stacked items, with each
additional control displaying directly beneath the previous control.
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Page Element Description
Show Label Select to hide the group box label (specified in the Label field).
f Note:

You can add help only to group boxes with Show Label turned on. If Show Label is turned
off, the Help button does not appear on the attributes panel and any help icons associated
with any previously added help no longer appear.

Hide Border Hides the group box border. When turned on, the border is not visible.

Hide From Public User Hides the group box and all the elements in the group box container from the public user at runtime.
Only agency staff can view and update information within a group box with Hide From Public User
turned on. In addition to hiding the Ul element from the public user in the interface, the application
also secures the back end for that specific Ul element, such as preventing any unauthorized access
to the fields contained within that Ul element using a REST API, for example.

Help Click to launch the Contextual Help page, which you can use to add help information to aid citizens
in completing the intake form. The Help button appears only if Show Label is turned on. Help text
added for group boxes should apply to the overall group box content. Help can be added also at
the page level, predefined element level, and user-defined element level depending on the scope of
the help text.

For more information on adding Contextual Help, see Adding Contextual Help to Forms.

Nesting Group Boxes

The following example illustrates nested group boxes, which you achieve by dropping group boxes within group boxes.
Nested group boxes can be used to represent subcategories of information and to enhance layout options, such as creating

columns for form elements.
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4 Group Box - Level 1 X
4 Nested Group Box - Level 2 %
Field A *,
Field B >,
4 Nested Group Box - Level 2 .
Field C x,
Field D x

" Note: The system does not impose a limit to the depth of nested group boxes you can insert. For more
complicated pages, for example, you may find that group boxes could be nested to 4-5 levels deep. Make sure
to consider how a page with multiple levels of nested group boxes will render on all the devices you intend to
support for your user base.

Using the Flexbox Layout Attribute

Use the Flexbox Layout attribute to establish a group box container based on the CSS flexible box layout model. In the
flexible box layout model, the items contained within the parent container assume a layout position automatically, based on
space in the container. As the available unused space grows or shrinks, the items in the container grow to fill the unused
space or shrink to avoid overflowing the parent.

With Flexbox Layout on, the system displays as many controls within the group box in one line until all of the space is utilized,
then the system wraps the row, beginning a new line.

With Flexbox Layout off, the controls within the group box display as stacked items, with each additional control displaying
directly beneath the previous control.

Example: Using Group Boxes to Combine Predefined Elements

In some cases you may want to give the appearance of multiple predefined elements being combined. You can do this using
a group box to act as the outer container for the set of predefined elements. When using a group box to contain predefined
elements, consider the following items:

e The collapsible attribute of the group box container controls the visibility of the contained predefined elements. If the
group box container is set to be collapsible, when the user collapses that group box, all of the elements (predefined
and user-defined) within that group box will be hidden.
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e |f you want the predefined elements within the group box to be categorized under just the label of the group box,
turn off the Show Label attribute of the contained predefined elements.

In the following example, assume you want to combine the Fence Information and Comment predefined elements, giving the
appearance that Fence Information element contains a Comment field.

To combine predefined elements within a group box container:

1. From the user-defined elements list, drag and drop a group box into the workspace.
2. Select the group box and make these changes on the Group Box Attributes panel:

Group Box Attribute Sample Value

Label Fence Information

Flexible Box Layout Off

3. From the predefined elements list, drag and drop the Fence Information element into the group box
4. Select the Fence Information element, and turn off Show Label on the Attributes panel.
5. From the predefined elements list, drag and drop the Comment element into the group box.

4 Fence Information X
! x
Type of Work Front Fence Height
Type of Use Rear Fence Height
Pool Enclosure Left Fence Height
Fence Type Right Fence Height
Other Fence Type Location
Foundation Type Corner Lot
Automatic Closing Material
Gate
Other Material
Lock
x
Comment
Comment

6. Select the Comment element, and turn off Show Label on the Attributes panel.
7. Save your changes.

At runtime, the example steps above produce a single, collapsible section in the form that includes both the Fence
Information and the Comment predefined elements.

This example illustrates the collapsed Fence Information group box.
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» Fence Information
This example illustrates the expanded Fence Information group box containing multiple predefined elements.

4 Fence Information

Type of Work Front Fence Height
Type of Use Rear Fence Height

Pool Enclosure ] Left Fence Height
Fence Type Right Fence Height

Other Fence Type Location
Foundation Type Corner Lot
Automatic Closing Material

Gate
Other Material

Lock

Comment

Example: Using Group Boxes to Combine a Predefined Elements and User
Defined Elements

Similar to combining predefined elements within a single group box container, you can also combine predefined elements
and user-defined elements within a single group box container creating the appearance of user-defined fields being part of a
delivered predefined element.

In the following example, assume you need to associate a field with the Fence Information element to capture the color of a
proposed fence.

To combine predefined elements and user-defined elements with group boxes:

1. From the user-defined elements list, drag and drop a group box into the workspace.
Select the group box and make these changes on the Group Box Attributes panel:

Group Box Attribute Sample Value

Label Fence Information

Flexible Box Layout Off

From the predefined elements list, drag and drop the Fence Information element into the group box
Select the Fence Information element, and turn off Show Label on the Attributes panel.

From the user-defined elements list, drag and drop a text field into the Fence Information group box.
Select the text field, and enter Color for the Label in the Field Attributes panel.

L
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4 Fence Information x
X
Type of Work Front Fence
Height
Type of Use

Rear Fence Height

Pool Enclosure
o Left Fence Height

Fence Type
Right Fence
Other Fence Type Height
i Location
Foundation Type
Automatic Corner Lot B
Closing Gate - .
Material
Lock

— Other Material

Color x

7. Save your changes.

The following example illustrates how at runtime, the group box containing the predefined element and the user-defined
element create the appearance of the manually created field being part of the delivered predefined element.

4 Fence Information

Type of Work
Type of Use

Pool Enclosure
Fence Type
Other Fence Type
Foundation Type

Automatic Closing
Gate

Lock

Calor

Front Fence Height
Rear Fence Height
Left Fence Height
Right Fence Height
Location

Corner Lot
Material

Other Material
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Working with Fields

This topic describes how add fields to your forms, modify field attributes, and hide fields.

When end users are completing an application for a permit, they enter the required information in fields. Fields can be added
to forms by:

e Adding predefined elements to your form. Each predefined element is delivered with a set of fields.
e Adding user-defined elements (fields) to your form.

The fields that come with a delivered predefined elements are referred to as predefined element fields, while the individual
fields you add manually to your form are referred to as user-defined element fields.

#" Note: The user-defined fields that you create cannot be used across multiple permits. Currently, a user-defined
field can be used only within the local permit.

Setting Field Attributes

Predefined and user-defined element fields typically have the same set of attributes, however, in some cases the type of field
you select determines the attributes appearing in the Field Attributes panel. Select a field to view the Field Attributes panel.

This example illustrates how the Field Attributes panel looks after selecting a field.
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»

Field Attributes
Label *

Fence Type

Placehaolder

Default Value

Reguired ()

Hidden
Open Additional Attnbutes

Add Help

Page Element Description

Label

Add a custom label to the field.

¢ Note:

»
In the case of a custom field, the system forces the Map Field value to match the Label
value, but removes any spaces. The map field represents how the field appears in
the underlying data model. For example, a custom field with the label Additional

Requests, will have a Map Field value of AdditionalRequests.

Placeholder

Add descriptive text to aid the user in entering data. For example, the placeholder text could read:
Enter date in this format” MM/DD/YY.

Default Value

Enter any default value required for the field.

Required

Enabile if this is a required field.

Hidden

Hides the field from the user. If a predefined element contains fields that you do not need, select this
option so the user does not have access to the field.

ORrRACLE
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Page Element Description
Open Additional Attributes Used to add values for fields containing a list of values.

For more information, see Defining Fields Displaying a List of Values.

Add Help Click to launch the Contextual Help page, which you can use to add help information to aid citizens
in completing the intake form. Help text added at the field level should apply specifically to that field.
You can also add help to predefined elements, group boxes, and pages, depending on the scope of
the help text.

For more information on adding Contextual Help, see Adding Contextual Help to Forms.

Add Logic Click to add scripting logic using the Groovy programming language.

For more information on adding logic to your forms, see Adding Logic.

Edit Click to display the Rich Text Editor dialog box for entering formatted text to the application form.
Appears only for rich text areas.

For more information on rich text areas, see Adding Rich Text Areas.

Adding User-Defined Fields

" Note: You can add user-defined fields to group boxes only. You can’t add user-defined fields directly to a page
or a predefined element.

To add a user-defined field:

Add a group box to the current page.

Click the Ul Elements tab in the Form Elements panel to display the types of fields to add to your form.
Select the type of field you want to add to the page.

Once the field type is selected, drag it to the page and drop the field into the desired group box.

pPODN 2

#" Note: User-defined fields must be contained by a group box.

5. Select the user-defined field you added to the page, and use the Field Attributes panel to configure your field.

#" Note: User-defined fields and component fields use the same set of attributes.
6. Save your changes.

Once saved, the system applies your user-defined field to the application data model so field data can be captured,
stored, and retrieved.

Choosing User-Defined Field Types

Expand the User-Defined Elements list to view the user-defined elements you can add to your form.
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" Note: You must first add a group box to your form, and then you can drop one or more user-defined elements
into the group box container.

Field Type Description

Text field Adds a character field to hold text values.

Number field Number field used to contain integer values.

Date time field Stores date and time values, such as 09-26-2018 11:25 AM.

Switch On-off field, such as an “active” field indicating whether an item is active or not, which would be

either on or off (yes or no).

Text area A long character field enabling the user to enter longer descriptions.

Rich text area A long character field enabling the user to enter longer descriptions or instructional information that
can be formatted using a rich text editor.

Single-item check box Displays a single option for the end user to select, such as, "I have read the terms and conditions,
and | agree to the terms and conditions." This is different from a check box set, which displays a list
of multiple items for an end user to select.

In the case of a single-item check box, the label of the field acts as the text the end user reads and
responds to on the application form.

Check box set A set of check boxes, from which the end user can make multiple selections. For example, the label
for the check box set might be Heating Source(s), with values such as Oil, Gas, Wood, Solar, and so
on.

Radio button set A set of radio buttons, from which the end user can make a single selection. For example, the label

for the check box set might be Fence Type, with values such as Stone, Wood, Vinyl, and so on.

Drop-down List A drop-down list allowing the user to select a single item.

Multi-select List A drop-down list allowing the user to select multiple items.

Hiding Fields
In some cases, you may not want to display all of the fields associated with the predefined element you've added to a form.
You can hide unneeded fields so they do not appear to the user at runtime.

To hide fields:

1. Place your cursor in the field to select it.
2. Turn on the Hidden switch on the Field Attributes panel.

Once you have hidden a field, the design-time interface continues to display the field, but places a darkened background
around the field to indicate it is a hidden field. The application does not display the field at runtime.
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Location
Corner Lot
Material
Other Material

In this example of the design-time interface, Location and Material are not set to be hidden, but Corner Lot and Other Material
are. Notice that the hidden fields display with the darkened background.

The following example of the runtime illustrates that the hidden fields do not display when an end user access the form. Only
Location and Material render on the form at runtime, while Corner Lot and Other Material are not rendered.

Location

Material

" Note: At runtime, the system applies this style to the hidden field:style="display: none;”. This style prevents
the field from being visible on the page.

#" Note: Required fields can’t be hidden fields. If you set a field to be required, the Hidden switch becomes
disabled. If a field is set to be hidden, and you set it to be required, the system sets the Hidden switch to off
automatically and disables the Hidden switch.

Adding Rich Text Areas

This topic describes how to add rich text areas to your intake forms so that you can display formatted text in application
intake forms.

Rich Text Area Overview

In some cases, you may need to add rich text areas to your application forms so that you can display formatted text for users
filling out the application. For example, if you needed to provide additional information, such as instructions or reference
material, you can provide that within a rich text area.

" Note: The rich text area provides a way for the agency to provide read-only formatted text for end users. A rich
text area does not enable the end user to be able to insert formatted text into the form.

When you add a rich text area element to your form, and Edit button appears in the Field Attributes panel when you select the
rich text area element. The Edit button launches the Rich Text Editor dialog box.
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The Rich Text Editor dialog box provides these formatting options:

Font size

Bold, italic, underline

Copy formatting

Text color

Text background color

Numbered and bulleted lists

Undo and redo

Increase and decrease indentation
Horizontal line

View and edit HTML source

Adding a Rich Text Area to a Form

To add arich text area:

°

Insert a group box into your form where you want to place the rich text area.
From the list of user-defined elements, drag and drop a rich text element into the group box.
Select the rich text area element.

This example illustrates the rich text area element being selected prior to rich text being added.

Group box *

Field O

This is a rich text area. To add or edit content, select this element, then
open the rich text editor,

In the Field Attributes panel, click Edit to open the Rich Text Editor dialog box.

" Note: If needed, you can use the Description field to enter a description of the contents of the rich text
area for other implementation team members. The description you enter only appears in the designer; it is
not be displayed at run time.

Add text and use the desired formatting options.
Click OK.
Save your form layout.

76

ORACLE



Oracle Public Sector Compliance and Regulation Chapter 6
Implementing Community Development Creating Intake Forms

Defining Fields Displaying a List of Values

This topic describes how to add a list-of-values to user-defined fields you add to your application forms manually.

Some of the user—defined fields that you can add to your form are considered “list-of-value” fields. List-of-value fields enable
end users to select field values from a predefined set of values (a list) to populate the field when entering data on the form. For
example, radio sets and drop-down lists are list-of-value fields.

You can only add and modify the list of values associated with user-defined fields, which are the specific fields you have
added to your application form manually. You can’t add or modify a list of values for a field contained within a predefined
element, such as the Fence Information element.

A a list of values is a set of fixed field values defined within the field attributes.

* |s not expected to change over time. Removing items from the list, for example, would make previously saved data
invalid.

e Should consist of reasonable number of items. Lists with larger numbers of items should be addressed with a
dynamic list.

An example of a field with a list of values could be the Property Zone Type field, where the pre-defined values for a user to
select are: Business, Residential, and Agricultural.

List of Value Type Fields

You associate a list of values with these field types:

e Radio button set
e (Check box set
e Drop-down list

e Multi-select list

The following example illustrates a radio set, which is a set of radio buttons allowing a user to select a single value from the
list of values.

Fence @ “wWood

M aterial Ctone

Chairn Link

The following example illustrates a check box set, which is a list of multiple items allowing a user to select multiple values from
the list of values.
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Katerials Reguired Cement
Crushed Rock
v Loam
v Sand

Stone

The following example illustrates a drop-down list, which is a list allowing a user to select a single value from the list of values.

Furnace b

Manufacturer
Armana

Armerican Standard
Bryant
Rinnai

Trane

The following example illustrates a multi-select list, which is a drop-down list allowing a user to select multiple values from the
list of values.

Heating Sourceis) Propane ¥  Solar %

Electricity
il

Pellet
Wood

Adding a List of Values

Select the user—defined field.
Click the Open Additional Attributes button in the Field Attributes panel.

In the Field Option Values grid, select the default row (the row with the Default Label and Default Value).
With the row selected, enable the row for editing by:

o Double-clicking.

pPONS

o Pressing F2.
o Pressing ENTER.
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5. For Label, enter the value that the end user will see in the list of values in the user interface.

For example, if the field is Fence Materials the list of value labels could be: Wood, Stone, Metal, and so on.

#" Note: Each label must be unique and must not be Default Label.
6. For Value, enter a numeric value or an abbreviated character value representing the label value.

The brevity of the value can make it easier when referring to a specific value when executing business logic or
specifying the default value of the field. The end user will not see this value.

For example, if the field is Fence Materials, and the list of value labels are: Wood, Stone, and Metal, the abbreviated
values could be WD, ST, and ML.

" Note: Each value must be unique and must not be Default.

7. Press TAB or click outside the current row to display the Add button and Delete button for that row.

#" Note: While editing the row, the Add and Delete buttons are hidden.

8. Click the Add button in the current row to add a new row beneath it.
9. Repeat these steps until you’ve entered all the items in your list of values.
10. When you have added all of the items of the list of values, click Done.
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Additional Attributes

Option Value List

Lakel

il
Propane
Electric
solar
Wood

Pellet

11. Save your form design.

Updating a List of Values

Walue

aL

PP

EL

aL

WD

PL

+ + + + + +
2 & &8 & & =

Done

Chapter 6
Creating Intake Forms

#" Note: After a form has been published and accessed by end users, you should not update items in a static list.
Doing so can invalidate historical data.

Select the user—defined field.

pPON~

o Double-clicking.
o Pressing F2.
o Pressing ENTER.

ORACLE

Click the Open Additional Attributes button in the Field Attributes panel.
In the Option Value List grid, select the item in the list you want to update.
With the row selected, enable the row for editing by:
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5. Enter the required changes in the Label or Value columns.
6. Click Done.
7. Save your form.

Deleting an Item from a List of Values

#" Note: After a form has been published and accessed by end users, you should not delete items from a static
list. Doing so can invalidate historical data.

1. Select the user—defined field.
2. Click the Open Additional Attributes button in the Field Attributes panel.
3. Inthe Option Value List grid, locate the item in the list of values that you want to delete.
4. Click the Delete button in the row for that item.
#" Note: The Option Value List grid must contain at least one row. You can’t delete the last remaining item in
the grid, leaving no rows.
5. Click Done.

6. Save your form.

Displaying Form Elements Conditionally

This topic describes how you can show or hide elements on your forms depending on selections users make on other form
elements.

You can configure some form elements to be either displayed or hidden, depending on the value of other fields in the form.
Form elements that can control the display of other elements are controlling elements, and form elements that can be shown
or hidden based on the value of controlling elements are controlled elements. The following table describes the elements
involved in conditional display.

Display Type Element Types Description
Controlling Element e Single-ltem Check Box Form elements that determine whether another form element is
. Switch displayed, depending on the value selected by the user.

Controlled Element e Predefined Form Element Form elements that can be displayed conditionally, depending on the
value of the associated controlling element.
e Group Box
To control when these elements appear, click the Control Display
button on the Element Attributes tab, which appears only for these
element types.

For example, assume you wanted to hide the Photovoltaic predefined form element only if the user has not selected the
Solar single-item checkbox in a “Building Options” section of a permit application form. In this case, you can set the Solar
single-item check box as the controlling element for the Photovoltaic predefined element, having the Photovoltaic element (the
controlled element) display only when Solar is selected.
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To configure conditional display for a form element:

1.

Add the controlling element to a group box in your application form.
The controlling element can be a user-defined element of these types:
o single-item check box
o switch
Add the predefined form element or group box that you want to display or hide conditionally (the controlled element).
The controlled element can be:
o predefined form element
o group box
Select the predefined element you just added so that it is the active element in the layout.
In the Element Attributes panel, click Control Display.

On the Control Element Display dialog box, click Add, then double-click in the newly added row in the grid, and
make the appropriate selections.

This example illustrates the Control Element Display dialog box set to show a form element of the controlling element
is set to true.

Control Element Display X
+ W
Display Controlling Element Valus
Hide if Building Options - Solar False

Cancel

Element Description

Add Click to add a new row to the grid.

After adding a row, double-click the row to make it active.

# Note:
If you add multiple rows of conditions to the grid, the system assumes an “OR”
operator exists between each row. If any of the conditions are confirmed, that
display option will be enabled.
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Element Description
Delete Click to delete the selected row in the grid.
Display Currently, Hide if is the only display option. You can hide an element based on the value of

the controlling switch or single-item check box.

Controlling Element Select the form element that will control the display of the selected predefined form element
or group box.

The drop-down list displays all user-defined switches and single-item check boxes that exist
on or before the current page in the form. If the selected element is a group box, the drop-
down list does not display any switches or single-item check boxes within that group box.

Typically, you would select a controlling element appearing before the controlled element to
follow the logical sequence a user would take when completing the application form.

Value Select the value of the controlling element that determines when the display option will be
rendered:

o True: selected for a single-item check box or on for a switch.

o False: deselected for single-item check box or off for a switch.

6. Click OK.
7. Save your form.

The controlled element appears with an icon below the element label to indicate it is an item whose display is controlled by
another element in the intake form.

This example illustrates the icon displayed for a controlled element.

4 Solar Installation Information

@]

Type of Use Roof Material
Type of Roof Roof Layers
Service [D Roof Connaction
Type
Meter
Mumber of Roof
Photovoltaic Connections
Modules

Adding Logic

This topic describes how to add validation logic to form elements to validate the values added by end users. The language
used for this logic is Groovy.
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Groovy Overview

You can add validation logic to fields in your application form using the Apache Groovy programming language. Apache
Groovy is an object oriented language that can be used for scripting or programming. Groovy is often referred to as an
extension of the Java programming language and uses similar constructs and syntax. For Java developers, Groovy can
be compared to other programming languages, such as Python or Ruby, that don’t intend to replace Java, but act as a
companion language, extending capabilities and providing additional flexibility.

In the context of designing application forms, in the current release you use Groovy as a scripting language to create validator
scripts to provide data integrity for end user input. A validator script is a logical construct that returns either true or false.

Currently, only simple field validation scripts are supported for your application forms.
For example, assume you
/* Field value for "Number of Rooms" must be greater than zero.*/
newValue > 0
The essential components of a validator script include:

e Groovy logic

® An error message

At runtime, if the field value entered does not meet your validation logic criteria during a save request, the system displays the
error message to the user so they can resolve the issue.

" Note: The Groovy validation executes only when the user either saves or submits the form. If there is any
delivered validation for a field contained within a predefined form element, that delivered validation runs before
any custom Groovy validation. Before adding Groovy logic to a field delivered in a predefined form element, make
sure to test the predefined form element at runtime to become familiar with any delivered, internal validation.

Before adding Groovy validation, you will need to become familiar with the Groovy language and how it is intended to be used
within Oracle applications.

For more information on Groovy usage within Oracle, refer to Oracle Applications Cloud: Groovy Scripting Reference.

For general information on the Groovy language, see Apache Groovy documentation.

Setting the Scope of a Groovy Script

The following table outlines the possible scope of a Groovy script.

Scope Description Where Set

Field You can add Groovy logic to act on a single Select the field to which you want to add
field. The code you add runs only against the validation logic, and click Add Logic in the
selected field. Field Attributes panel for that field.

You can add Groovy to fields in predefined
elements or to user-defined fields you have
added manually.

Object If your script involves more than one field, you ~ When in the designer with the application
need to add that code at the object level. The form open, click the Add Logic button at the
object refers to the current application you top of the form, next to the Preview button.
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Scope Description Where Set

are creating. For example, if you are creating
a fence permit, the logic you add for the
current object applies to fields in that fence
permit definition.

f Note:
To get the field names of each field
you want to reference in your object-
level script, you need to select that
field, click Add Logic, and copy the
field name provided in the comments
in the Groovy Script Editor.

#" Note: For validating at the field level use newValue and oldValue to reference the current field. At the object
level, use the field name, such as NumberofRooms_c to reference fields.

#" Note: Inthe case of multiple field-level validations, each runs independent of the others, however, in the case of
object-level validations, the object-level validation runs only if all field-level validations have passed.

Working with the Groovy Script Editor

To access the Groovy Script Editor, click the Add Logic button at the field or object level.

The following example illustrates adding validation logic to a field using the Groovy Script Editor.

Groovy Script Editor x

Validators

Script Name *

1 /* Field Validator for field NumberofRooms_c NumberofRooms ¢ validator =
2 Custom Object LNP1INFODEV_c */ —
3 newValue > @8 Description

Number of rooms in structure must be

*
Error Message

Number of rooms in the structure
must be greater than 0.

Save Close

Page Element Description

Work Area In the work area, add your validation logic.

The first line in comments (/* <text> */) is automatically generated, and it provides you the field name
and object name as they are referenced internally.
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Page Element Description

For a field contained in a predefined form element, the field name will be similar to the field label,
such as DemOverallHeight.

In the case of a user-defined field, the field name will match the field label you have entered, with a

c” as a suffix to indicate it is a custom field.

For example, if you have a user-defined field named Rooms, the field name appearing in the script
will be Rooms_c.

The custom object name is the type code as defined on the Transaction Type page, with either a
“LNP1” or “PZ1” prefix and a “c” suffix. “LNP1” is the prefix for permits and “PZ1” is the prefix for
planning and zoning applications.

For example, if the Transaction Type Code is Fence, the custom object name in the script will be
LNP1Fence_c.

¢ Note:

»
For validating at the field level use newValue and oldValue to reference the current field. At
the object level, use the field name, such as Rooms_c.

Script Name By default, the script name follows this structure:
field_validator
or
object_validator

You can change the script name if needed.

Description Add text to describe the purpose of the script.

Error Message Provide the message that the system displays the user if the data entered for the field does not pass
the validation logic.

The validator script returns either true or false. If the retumn is false, the system displays the error
message.

Adding Contextual Help to Forms

This topic describes how to add help text to various parts of your intake forms to aid citizens when they are filling out an
application form.

Working with Contextual Help

If you determine that the end user needs additional information to understand a user-interface element (field, page control,
or page) in your intake form, you can add contextual help text to that user-interface element. If you add contextual help to
a user-interface element in your intake form design, the system displays a Help icon next to the label of that user-interface
element.
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You can see the Help icon in both the design and runtime mode. At runtime, end users click the Help icon to display your
help text in a popup, without leaving the page.

#" Note: At design time, the Help icon does not display the help text popup when clicked.
You can add contextual help text to these intake form elements:

e Page tabs

e Components

e Group boxes

e Fields (component fields and custom fields)

" Note: For group boxes and components, you can add help only when with the Show Label attribute turned on.
You can’t add contextual help text to these intake form elements:

¢ Radio sets

e Check box sets
If you need to add help for radio sets or check box sets, use a group box to surround the radio items or check box items and

add the help text to the group box.

Adding Contextual Help

To add contextual help:

1. Select the page element to which you want to add contextual help.

" Note: You cannot add help text directly to radio sets and check box sets. Add help text to a group box
surrounding the radio sets or check box sets.

2. Click the Help button in the attributes panel.
3. On the Contextual Help Setup page, note the Type Code, Page Name, and Page Object values.

These values uniquely identify the page element to which you are associating the contextual help. You can’t change
these values; they are read-only and maintained by the application.

ltem Value

Type Code An automatically generated value consisting of the internal product code and the permit type
code derived from the permit type definition.

Page Name The name of the page tab on which you are adding help. Regardless of what the page label
is on the tab, the application displays each tab using the default name in sequence, such as
tabs1, tabs2, and so on.

For example, the second page tab in an intake form may have the name Fence Information,
however in the Page Name field it will appear as tabs2.
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10.
11.
12.

ltem Value

Page Object Identifies the page element for which you are adding help. Regardless of the page element’s
label, the application displays the internal naming convention as the field value, which is the
page element type code + sequence added.

For example, for the second field added to the form the field value is fields2, which indicates
the element is a field and it is the second field added to the form.

The page element type codes are:

o Components: ccas
o Group Boxes: widgets
o Component Fields: <component>_<internal field name> (such as ccas2_ReleaseDate)

o Custom Fields: fields

In the Description field, add text to describe the purpose of the help text so other implementation team members can
understand the content.

Click the Add New button in the Contextual Help Details grid to display the Add Context Help Details dialog box.
Select Agency Defined from the Type drop-down list.

#" Note: Help topics of type System Defined are provided by Oracle and should not be altered or
removed. Customers should use the Agency Defined help topic type to add help topics specific to your
implementation. If you want your custom help text to display instead of delivered help text, disable the
System Defined help topic, create your custom topic, and enable it.

Activate the Help Content edit box by clicking to the right of the Help Content field label.

In the Help Content edit box, enter your help text.

The system provides rich-text editing features, which enables you to implement limited formatting options, as
needed.

When you’ve added the content, and you are ready for it to be viewed by end users, turn on the Enabled switch.

" Note: To prevent the help content from displaying at run time, turn off the Enabled switch.

Click Save on the Contextual Help Details page.
Click Save on the Contextual Help page.
Confirm that the help icon appears on the page tab or next to the page control label in your intake form design.

For more information on contextual help, see Setting Up Contextual Help.

Setting Form Options

This topic describes the options you can set for the entire form to control the ways citizens interact with the form.

Enabling the Review Page

The review page presents all the fields of a multi-tab form on a single, scrollable page for efficient review of the entered data
prior to submitting the form.
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By default, the review page displays:
e Form fields as read-only, but the end user can click the Edit button to modify the fields per predefined element as
needed.
e All predefined elements expanded.
e For multi-page view or single-page view.

e For all forms, unless disabled.

To disable the review page:

1. In the Intake Form Designer, click the Layout Settings link.
2. On the Layout Settings dialog box, turn off Show Review Page.
3. Click OK.

Setting a Confirmation Step

You can enable one of the pages in a form as a confirmation page to display after the end user has filled in the information
and submitted the form. You create the confirmation step in the designer and then set it to be the confirmation step in the
Layout Settings.

When set as the Confirmation Step, the page displays:

e At design time with the page tab filled in grey to indicate it is the confirmation step.

e At runtime as the last page in the train stop drop-down list.

# Note: The confirmation step does not display as part of the single page view.

To enable the review page:

In the designer, click the Form Options link.

On the Form Options dialog box, select the desired page from the Confirmation Step drop-down list.
Click OK.

Click Save.

pPODN =

Mapping Form Fields to Decision Model Attributes

This topic describes how the fields added to an intake form in the designer are mapped to the fee model defined for the
transaction type.

The Fee Mapping page in the designer is used to map attributes in the decision model to the fields added to the intake form.

This image illustrates Step 2 of 2: Fee Mapping in the design of a permit application.
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Desigﬂ Permit Appl ication Add Logic Preview Save Publish

PermitTypefee11  Status: published

< Previous Next

NCeWXei Pl Fee Mapping

Fee Mapping
4 Permit Fees/PermitApplicationFees/1.0/PermitApplication
Model Attribute Attribute Type Record Type Attribute

ProjectValue number Job Cost v

4 Permit Fees/BuildingPermit/1.0/BuildingPermit

Model Attribute Attribute Type Record Type Attribute
ProjectValue number Select a record type attribute v

Submitted By

NewSqFootage number

Classification

ConstructionType Construction

. Type of Work
UseType string

Type of Use

New Floor Area Classification v

» Permit Fees/Electrical/1.0/Electrical

» Permit Fees/PlumbingMechanical/1.0/PlumbingMechanical

You assign a fee schedule to an application type on the Transaction Type page using the Fee Schedule field. You map
attributes from the fee schedule’s underlying decision model created in Oracle Integration Cloud to the fields you have added
to your intake form either through predefined elements or by adding fields manually.

" Note: Not all model attributes need to be mapped. Because a fee schedule can be reused by multiple
transaction types, only the model attributes required for fee calculations for the current application type need to
be mapped. All other model attributes can be left blank.

For more information on setting up fee schedules, see Setting Up Fee Schedules.

For more information on decision models, see Creating Decision Models for Fees.

Mapping Application Fields to the Fee ltem in the Decision Model

To access the Fee Mapping page in the form designer:

1. Navigate to the Transaction Type page:
o Permit Setup > Permit Type

o Planning and Zoning Setup > Planning Application Type

Select the permit type or planning application type that you want to view in the designer.
Click the Design Form button.

Click the Next button while in the application form setup step.

The fields on the Fee Mapping page are as follows:

Page Elements Description

Model Attribute The name of the attribute as it appears in the decision model in Oracle Autonomous
Integration Cloud.

akrobd

Not all model attributes must be mapped. Because fee schedules can be reused by multiple
transaction types, only the model attributes required for fee calculations for the current
transaction type need to be mapped. All other model attributes can be left blank.
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Attribute Type The data type of the model attribute, such as string, number, boolean, and so on.
Record Type Attribute The field added to the intake form layout either contained in a predefined form element or a

user-defined element you have added manually.

6. Select the record type attribute from the drop-down list that you want to map to the decision model attribute.
7. Click Save.

Considering User Experience

This topic describes concepts related to using forms that implementation teams need to consider when designing forms.

Required Fields

The system validates that required fields contain values prior to a save request.

If a required field is empty the system displays the following error message on the page.

at least 3 alphanumeric characters

€ Value is required.
You must enter a value.

In addition to the message, the system disables the Save button until the required field values have been provided.

Runtime Application Form Save Behavior

When an end user navigates to another page in the application form using either the train stop drop-down list or the Next
button, the system automatically:
e Saves the currently entered data.

e Performs data validation on the current page.

If the end user attempts to navigate away from the application form page using, for example, the back button, entering a
different URL, or reloading the page, the system checks for any unsaved changes or new data. If the changes or new data
have not been saved, the system displays a message to the user indicating that if they continue, unsaved changes and new
data will be lost. The user can elect to leave the page or remain on the page to save.

Runtime Train Stop Drop-Down Behavior

The train stop drop-down list, appears in the center of the application form header to provide:
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Feature Description
Context The system automatically prepends the appropriate step number to the application form page
name. The step numbers are assigned in the order the pages appear in the designer (from left-to-
right).

For example, assume you have three pages in your form: Application Details, Fence Details,
Property Details. The train-stop drop-down list displays the pages as:

e Step 1: Applicant Details

e Step 2: Fence Details

e Step 3: Property Details

Current Page To show the current page the user is viewing, the system displays a single, right-pointing, chevron
character (>) to the left of page label in the drop-down list.

Navigation Select any page in the application form, including the review page, to access it immediately.

Switch to Single/Multi-page view Toggle between the multi-page view or the single-page view.

Using the Single-Page View
When accessing the single-page view in review or advanced-edit mode, end users will notice these characteristics of the
page elements.

Page Element Behavior

Edit button Enables the end user to activate the form fields for editing. Initially, the system displays them in read-
only mode. Once clicked, the system toggles the Edit button to the Done button.

Done button Once the end user completes any changes, clicking Done:
1. Performs any configured data validation.
2. Saves changes to the database.
3. Returns the form fields to read-only.
4. Toggles the button back to read Edit.

Group Boxes If a group box contains multiple group boxes, only the outer (parent) group box displays an Edit/
Done button.

Predefined elements If there are multiple predefined elements in a group box, they will appear to be a single page section,
with one Edit/Done button controlling all the predefined elements within the parent group box.

Otherwise, if the predefined elements are on the page tab separately (not within the same parent
group box container), then the system displays an Edit/Done button for each predefined element.

Expand All/Collapse All Expands or collapses all the elements on the page, including group boxes and predefined elements
within parent group boxes.
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" Note: The Edit button and the Done button do not appear on a page rendered in advanced edit mode if the
form is displayed in a read-only context. For example, if the user viewing the form does not have sufficient
privileges or if the user has already submitted the form, the fields in the form will be disabled and the Edit button
and Done button will not be rendered on the page.

Advanced-Edit Mode

If needed, agency staff members can update a form after a citizen has submitted the form. Agency staff members access the
submitted form using the Permit Details page in the Permit List or by deep linking. Editing a form after a citizen has submitted
it is referred to as advanced-edit mode.

When in advanced-edit mode, the system:

e Displays only the predefined elements enabled for advanced-edit mode.

e Presents the form in the single-page view.

Agency staff members click the Edit button to activate fields and update data, and they click Done to save changes.

" Note: Customers cannot configure whether a predefined element appears in advanced-edit mode. Predefined
elements enabled for advanced-edit mode are controlled and delivered by Oracle development. Only the
predefined elements that are appropriate for agency staff members to update are enabled for advanced-edit
mode.

Testing Intake Forms

This topic describes the methods and considerations involved with testing your application forms.

You design, create, and test application forms on your test database. You can test forms both inside and outside sandbox
mode.

Once your forms have been created and thoroughly tested on your test database, you then migrate the newly created forms
to your production system for public access.

Testing Forms Inside the Sandbox

You can test draft application forms in the sandbox using the application designer’s preview mode. To enter preview, click the
Preview button.

In preview mode, you can test the layout of the user interface and the tab flow in a simulated runtime scenario, however, the
preview mode does not enable you to enter data and save it. To test the full functionality and data validation of your permit or
planning application, you must first publish the form in your test database, as described in the following section.

#" Note: The application designer does not activate the Save button in preview mode.

93
ORACLE



Oracle Public Sector Compliance and Regulation Chapter 6
Implementing Community Development Creating Intake Forms

Testing Forms Outside the Sandbox

Once you are done testing the configuration of your form and the layout of the user interface using preview mode, you can
begin testing your form in scenarios that end users will encounter when they apply for permits or create planning applications.
To do this, you need to publish your form on the test database.

For more information on publishing forms, see Publishing Intake Forms.

#" Note: The testing data you enter and save during testing in preview mode remains in the underlying database
tables after the form is migrated to the production system.

Migrating Application Forms from the Test Database to the Production
Database

After you have completed your testing of the application form on the test database, follow the procedure in Functional Setup
Manager for migrating transaction type metadata and intake form layout metadata from the test database to the production
database.

For more information on test-to-production data migration, see Managing Transaction Type Configurations.

Publishing Intake Forms

This topic describes the steps to complete to publish intake forms.
To make your application forms available on public landing pages, you need to publish your form.
To publish a form:

1. Confirm that you have saved and tested all changes made to your form.
2. Inthe Intake Form Designer, click Publish.
3. Navigate to the Transaction Type page:

To navigate to the Transaction Type page you can either click Back in the global header, or select Permit Setup >
Permit Type.

4. On the Transaction Type page, open the appropriate transaction type, and set these values:
o Transaction Type Status: Ready

o Public User Enabled: Enabled for all users or Enabled for registered users.
5. Click Save.

# Note: After publishing a transaction type, if you attempt to access the application from a landing page and the
application displays an error, make sure the Transaction Type Status and Public User Enabled attributes are set
correctly.

Note: After publishing a transaction type application, the application may not be accessible immediately. It can
take several minutes to apply the most recent changes and transfer the application from the sandbox to the live
runtime system.
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Related Topics
® Setting Up Permit Types

Cloning Transaction Type Definitions

This topic describes how to clone transaction type definitions and the associated form design. It also covers the attributes
that will be shared between the source and clone definition and the attributes you will need to modify on the cloned definition.

You can clone a transaction type to:

e Save time when creating a similar transaction type, rather than creating a new transaction type for each situation
from scratch.

e Create a new version of a currently published transaction type after making a significant correction or addition to the
transaction definition.

In some cases, it may be more efficient to create a new transaction type and form, while in other cases, it may be more
efficient to clone an existing transaction type and form.

When you clone a transaction type, you make a cloned copy of:

e Most of the transaction type metadata, such as the specified Classification, Auto Number Rule, Department, Fee
Schedule, and so on. Some of the metadata is not cloned, such as Transaction Type, Transaction Type Code,
Transaction Type Status, Help Text and so on, as you’ll need to modify those values for the cloned copy.

e All of the intake form layout in the Intake Form Designer, including pages, group boxes, predefined form elements,
and user-defined fields you have added to your application form.

When deciding to clone a transaction type, you may consider:
e The number of fields and pages within the existing application form layout that you’d need to change.
e Similarity between the existing transaction type and new transaction type.

e Number of shared attributes.

< Note: In general, if you intend to make numerous modifications to the cloned copy, it may be more efficient to
start a new transaction type from scratch.

When cloning to make a new transaction type, you will want to make sure you are aware of:

e The attributes that will be shared between the source definition and the clone.

e The attributes you need to modify to create unique values between the source definition and the clone.

#" Note: All modifications you make to a should be done in your test environment and not on your production
environment. After you have thoroughly tested your changes in the test environment, your modifications should
be migrated using the Functional Setup Manager task flows.

Transaction Type Metadata Considerations

All of the field values on the Transaction Type page will appear in the cloned transaction type, except for selected field values
listed in the following table.
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Make sure to update any of the copied information on the Transaction Type page to reflect the requirements of the new
transaction type. For example, if the Department, Fee Schedule, or Workflow information, should be different, make sure to
update it for the new transaction type definition so it is associated with the correct items.

Page Element Description

Type The type name doesn’t have to be unique. You can create a new transaction type by using a unique
value or enter the same value as the source transaction type, if you are creating a new transaction
definition with the same transaction type.

Type Code The type code must be unique. Enter a transaction type code that identifies this version of the
transaction type definition.

Status Initially, for a newly created transaction type the status on the Transaction Type page is always set
to Preliminary. After you publish the form, change the status to Ready for Use.

Valid From Date The application inserts the current date for the cloned transaction type.
Valid To Date Update to reflect your business requirements.
Public User Enabled Initially, for a newly created transaction type this is always set to Not enabled for public users. When

you are ready to publish the new transaction type, update this value.

For more information on the fields on the Transaction Type page, see Setting Up Permit Types.

Intake Form Layout Attribute Considerations

The following table addresses specific considerations for Ul elements in your form layout with respect to cloned transaction
types and application forms and how any changes you make to the cloned definition may affect the source definition.

Element Description

Predefined Elements The cloned copy of the transaction type contains the same layout as the source definition.

If the intake form utilized any of the delivered, predefined elements, the application copies the
predefined elements into the cloned copy of the definition, using the same layout as the source
definition. For example, if you added the Fence Information predefined element to the source permit
definition to the second page tab, the Fence Information element would appear in the cloned copy
of the transaction type on the same page tab.

Labels The labels for fields and Ul elements, such as pages, group boxes, predefined elements, and so on,
are the same between the source and cloned definition.

User-defined fields Any fields you have added manually to the source will be copied, as is, to the cloned definition.

For any fields that you have defined a list of values, make sure it applies to your new transaction
type.

Security The cloned definition will have the same security configuration as the source definition for:

e Data security for column authorization and data redaction.
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Element Description
e (Cases where Hide from public user has been implemented.

Help If any help has been added to the form for a page, predefined element, group box, or field, for the
source definition, the application does not copy help references into the cloned definition.

¢ Note:

»
You can remove the help references from the cloned form, but do not delete the help text
from the Contextual Help page if other forms are still using that help text.

You are also cloning the fee mapping, which is defined in the second step of the Intake Form Designer.

Cloning a Transaction Type to Create a New Transaction Type

When you clone a transaction type, you also clone the associated form design. You can clone just the transaction type
definition without cloning the application form design; however, you can’t clone just the form design by itself.

#" Note: When you clone a transaction type, the type status defaults to Preliminary on the new transaction type,
and the status of the new application form defaults to Draft in the Intake Form Designer.

This example illustrates the Clone Permit Type page, which is described in the steps for cloning a permit type.

Clone Permit Type

Original Permit Type Solar Permit

Original Permit Type Code LLSolar0918a
*

New Permit Type

* Mew Permit Type Code

Use Original Workflow Setup 0
Clone Form Design O

To clone a transaction type:

Select Permit Setup > Permit Type.

Open the desired transaction type.

Click the Clone button.

On the Clone Type page, enter the following values:

poODN =
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8.

Page Element Description

New Transaction Type Enter a transaction type name.

The transaction type name can be the same as an existing transaction type name so that
you can have different versions of the same transaction type. For example, if the original
transaction type name is Fences, you can reuse the name for the new transaction type
definition, but you must enter a unique type code to distinguish the two.

New Transaction Type Code Enter a unique transaction type code.

Oracle recommends manually adding a version number to the source transaction type code
if you want different versions of the same transaction type definition. For example, if the
original type code is Solar-001, you can enter a new code, Solar-001-v2

Use Original Workflow Setup Turn on the switch to use the original workflow setup as defined in the original transaction
type. Turn off the switch to leave the workflow setup fields blank on the new transaction
type. You must enter a workflow setup values.

Clone Form Design Turn on the switch on to clone the application form design associated with the original
transaction type. Turn off the switch to create a completely new application form using the
Intake Form Designer.

#" Note: Providing a unique type code is required to make the transaction type definition unique.
Click the Create button.

The cloning process opens the cloned copy of the transaction type.

" Note: When saving the cloned definition, the application places the cloned definition within a sandbox.
Make any other required changes to the cloned transaction type definition and form design.

See the previous sections for more information regarding what items to check.

# Note: If there are numerous custom fields in the application form, when you have the layout open in
Intake Form Designer, it can take several minutes to perform the initial save. While saving, the application is
creating all of the custom fields, creating the other elements, and running validation.

Publish the application form in the Intake Form Designer.

For more information on publishing a transaction type, see Publishing Intake Forms.
Return to the Transaction Type page to change the status to Ready for Use.

Considerations for Creating a New Version of a Transaction Type Using
Cloning

In some cases, you may want create a new version of an existing, published transaction type to correct an error or make a

change.
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If the change made is insignificant, as in it does not change the meaning of a field or page element, then in most cases
cloning is not required, and you can simply make the change directly to the transaction type definition. For example, assume
you have a field for an email address on your form, and it had been requested to change the label from E-mail to Email
(removing the hyphen). In this case, the change can be made directly to the form and republishing it.

However, in other situations, the change may be significant, in that it affects reporting associated with transaction type, alters
historical data, makes future data out of sync with historical data, and so on.

Significant changes where cloning a transaction type is recommended include:

Transaction Type Element Examples of Significant Changes

Predefined form elements e Changing the label of a predefined form element.
e Adding
* Removing
e Updating the security (Hide from public user)

e Changing the label, hidden, or required setting of a field within a predefined form element.

User-defined form elements * Adding
* Removing
e Setting to required
e Updating a default value

e Updating the security (Hide from public user)

HTML Ul constructs e Adding page tabs
* Removing page tabs
¢ Adding group boxes

* Removing group boxes

Creating a New Version of a Transaction Type Using Cloning

Creating a new version of a transaction type using the cloning feature involves:

e Deactivating the published version of the transaction type.
e Cloning the published version of the transaction type.
e Activating the cloned copy of the transaction type.

To deactivate a published transaction type:

1. Select Permit Setup > Permit Type.

2. Open the definition for the published transaction type.
3. Setthe Transaction Type Status field to Void.

4. Click Save.

To clone the published transaction type:
1. With the transaction still open from the previous steps, click Clone.

2. Enter the same Transaction Type value as used for the recently deactivated transaction type.
3. Enter a unigue Transaction Type Code.
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" Note: Providing a unique transaction type code makes the transaction type definition unique. To keep
track of versions, you can add v2, v3, v4 to the code, for example.

4. Save the cloned definition.

#" Note: When saving the cloned definition, the application places the cloned definition within a sandbox.
5. Make any other required changes to the cloned definition transaction type and form design.

See the previous sections for more information regarding what items to check.
6. Click Publish in the Intake Form Designer to publish the cloned definition.

For more information on publish a transaction type, see Publishing Intake Forms.
To activate the new transaction type:

1. Select Permit Setup > Permit Type or press Back from the Intake Form Designer interface.
2. Open the definition for the published transaction type.
3. On the Transaction Type page, set these values:
o Transaction Type Status: Ready for Use.
o Public User Enabled: Enabled for all users or Enabled for registered users.
4. Click Save.

Managing Transaction Type Configurations

This topic describes the considerations and steps related to migrating transaction type definitions, such as permits or
planning and zoning applications, from your test environment to your production environment.

Transaction Type Lifecycle Overview

Any implementation of Oracle Applications Cloud usually requires migrating setup data from one environment to another at
various points in the subscription lifecycle.

For example, you set up your initial configuration of the Public Sector Community Development services in the test
environment, which is your source system. Then, after thorough testing and verification, you move the setup and
configuration data from your test environment to the target environment, which is your production system.

You use the Fusion Applications Functional Setup Manager to perform these migration tasks.

This example illustrates that you use Functional Setup Manager to migrate data between your test and your production
environment.
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Functional Setup
Manager

|

Source: Test System Target Production
System

You access Functional Setup Manager from within Public Sector Community Development by selecting Navigator > Setup
and Maintenance or by clicking the Setup and Maintenance tile on the springboard. To access Functional Setup Manager,
you need to have the System Administrator role associated with your user account.

The functional areas in Functional Setup Manager that apply to your transaction type definitions and application form
definitions are:

Offering Functional Area
Public Sector Permits Permit Types
Public Sector Planning and Zoning Planning Application Types

For more information on using Functional Setup Manager, see Using Functional Setup Manager.

# Note: All configuration changes should be completed and tested in your test environment and then migrated to
the production environment. Changes made directly to the production environment might be overridden during
subsequent test-to-production migration activity.

Set the Target Instance URL

On the source system (your test environment), you need to define the URL target system (your production environment) so
that setup data and configuration data can be sent to the target.

To set the target instance URL:

Sign on to the test environment.

Click the Setup and Maintenance tile on the springboard to access Functional Setup Manager.

On the right side of the Functional Manager Setup interface, click the Tasks tab to open the Tasks drawer.
Click Search, and search for Manage Configuration Set Migration Target Security Policy.

Eal o
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5. On the Manage Configuration Set Migration Target Security Policy page, enter the URL for your target environment,
and the appropriate security credentials for the System Administrator role.

#" Note: It is recommended to include the port number when you specify the URL value. For example:
https://server.example.com:443 You can get the target port value by accessing the Manage Configuration
Set Migration Target Security Policy page on your production system (your target).

6. Save.

Disabling Unified Sandboxes on Target Production System

For migrating transaction types from your test system to your production system, make sure to disable the Unified Sandboxes
feature on your target, production system. Because you should be completing all configuration tasks on your source

test system, sandboxes shouldn’t be required on the production system. Having the Unified Sandboxes enabled on the
production system can cause the Configuration Set Migration utility not to render or function properly.

To disable Unified Sandboxes:

1. Sign on to your target, production system.
2. Navigate to Functional Setup Manager.
3. Select your solution, such as Public Sector Permits or Public Sector Planning and Zoning.

# Note: Disable Unified Sandboxes in all solutions you have licensed for Public Sector Compliance and
Regulation.

4. Click the Change Feature Opt In link.
5. Locate the Application Extensions feature, and click the pencil icon in the Features column.
6. Make sure the Unified Sandboxes feature is disabled.

/" Note: If there are any open sandboxes, they need to be deleted or published before you can disable this
feature.

7. Click Done.

Migrating Transaction Type Foundational Metadata

Before you use Functional Setup Manager to export transaction type configuration data, you need to create and migrate a
configuration set, which includes the underlying metadata required to be in place as a prerequisite prior to migrating other
transaction type setup data.

Because the Public Sector Compliance and Regulation solutions are metadata-driven, you need to migrate the metadata that
is the foundation of the transaction definitions. This is the data stored in the Oracle Medata Services (MDS) layer. You do this

by creating a configuration migration set. Once that is complete, you can then begin using Functional Setup Manager export

and import features to transfer the rest of required definitions between test and production systems.

#" Note: Before you migrate transaction type metadata from your test system, ensure that the transaction type
definitions and associated intake forms are complete, tested, and published.

These steps must be completed before you use the Functional Setup Manager export and import
options.
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To migrate transaction type metadata:

pPODd 2

6.

Sign on to the test system, which is the source system.

Click the Setup and Maintenance tile on the springboard to access Functional Setup Manager.

Select the appropriate offering (Permits or Planning and Zoning).

Expand the Permit Types or the Planning Application Types functional area (depending on your offering).

#" Note: These steps for creating a migration set apply only to the Permit Types and the Planning
Application Types functional areas.

Click the Manage Permit Configuration task or the Manage Planning Application (depending on your offering).

This example illustrates selecting the option Manage Permit Configuration, which you select to set up and migrate a
configuration set.

Permit Types

View v Format » im ' Detach Show Required Tasks v
Task
Manage Custom Role for Permit Access
Create Process Cloud Service Proxy User
Manage 'Workflow in Process Cloud Service
Map Swim Lane Roles to Process Cloud Service Groups

Manage Workflow Communication Events

Manage Permit Configuration

E 2 = T
LLEE= L e gy L o gy e

Update Workflow Integration Connector

Manage Permit Type Display Groups

" Note: This link takes you to the Manage Configuration Set Migration Target Security Policy. You can also
access this page in Fusion Application by selecting Navigator > Configuration > Migration .

If you have not already specified your target instance URL, you must do that prior to the next step.

See the previous section for more information.
Select the Outgoing tile and create an outgoing migration set to export to your production environment.

When creating a configuration set, the utility compares differences between source and target, and determines the
metadata that needs to be exported to the target system. When the process is complete, the resulting migration set
is downloaded in the form of a downloadable jar file.
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8. After finishing the creation and migration of the outgoing migration set, sign on to the production system (the target
system), and complete the steps for applying the incoming migration set.

For more information on these steps, refer to Oracle Applications Cloud documentation: Configuring and Extending
Applications.

Exporting and Importing Remaining Transaction Type Data

After you have completed migrating the configuration set on the source system, you then export the remaining transaction
type data using the Functional Setup Manager options for the functional area or the entire offering.

#" Note: You can export and import at the functional area-level by selecting the Actions button for the functional
area or at the entire offering level by selecting the Actions button at the top right.

This example illustrates using the functional area export options.

Manage Waorkflow Con

* Permit Types
View Documents 3
* Accounting Shared
Edit Implementation Status :
* OPA Questionnaire Shared Setup Data Report (3
* Digital Assistant Shared +C
Import »
* Agency Staff Shared
Expart to TS5V File »
Fublic Users Shared Import from CSV File C
* Analytics and Reporting — Compare Setup Data 2

After exporting from the test system, you then sign on to the production system and import the corresponding business
object data.

When you export business object data, you have the option to select only those business objects that you utilize. For
example, if you are not using application groups, you could deselect Manage Application Groups from the Business Objects
list.

The objects you export will be in the form of a downloadable jar file.

For more information on these Functional Setup Manager export and import features, see:
Using Functional Setup Manager: Managing Setup Using CSV File Packages

Using Functional Setup Manager: Exporting and Importing Setup Data
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[/ Setting Up Inspections

Setting Up Inspection Statuses

Oracle delivers inspection statuses for use during the inspection process. You review the statuses on the Inspection Status
page.

You review inspection statuses during permit setup on the Inspection Status page. You cannot delete the system-defined
statuses or add new statuses, but you can modify the associated inspection status names and descriptions.

Modifying Inspection Statuses

1. Select Common Setup > Transaction Status .
2. Select the Inspections tab.
3. You can review the delivered inspection statuses in the System Status column:
o Pending
o Requested
o Scheduled
o Completed
o Canceled
o Deleted

Select the row for the inspection status that you want to modify.
5. On the Inspection Status Details page you can edit the inspection status name and description.

E

The status name is used as the display status for the inspection in the permit application.
6. Click Save to save any changes.

Inspection Evaluation Overview

The inspector evaluates a building site for adherence to codes and regulations required for a permit. The example here
provides information about an inspection set up to use automatic score calculation with the bottom up scoring method.

A permit might require one or more inspections, each inspection might have one or more checklists, and each checklist might
have checklist items or not, depending on the inspection configuration. The inspector performs an inspection by assessing
the checklist items, if any, then checklists, and up to the inspection level. The evaluation results that the inspector enters are
rolled up to the next level until a final inspection score is calculated if scoring is used.

Scoring is not required. The score is the rolled up to the next level automatically only if scoring used. Otherwise, you specify
the result manually on each level.

The following example describes the setup and results of performing an inspection using the bottom up method of scoring.
Scoring bottom to top indicates that the inspector starts with a zero score and adds points for each criterion that is met.
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Example: Using the Bottom Up Scoring Method

Before you begin, set up the assessment type, rating method, passing rule, scoring method, and checklist, which includes
the checklist items. In this case, you don’t need to set up the checklist group, because checklist and checklist group are
mutually exclusive of each other.

This example illustrates setup for an inspection on the Inspection Type Details page. Details are in the surrounding text.

Inspection Type Details

* Inspection Type  CK_SCHDINSP_FNC Enabled C
* Description  FNC Scheduling Inspections * Estimated Duration in Hours 5
Scheduling Method = Schedule v
[ Assessment Type _passFai o | Passing Rule  PR-123 Q
| Rating Method GRADE Q | Scoring Method  Bottom up v
* Autonumber Rule CK_FNC_Insp o Maximum Score
Checklist Group o} Checklist CK-FNC-0100 o
Billable Bill Type o
Policy Name Policy Version
Inspector Signature Required v Owner Signature  Optional v
Contractor Signature  Optional v Schedule Cutoff Time
Inspection District Type CK_DISTRICT_TYPE_FNC_INSP o Schedule Change Policy 3

Hide Inspector Comments

Cancel Delete

The setup includes the following:

1. Assessment Method

The assessment method is defined on the assessment type page and used in the inspection type definition. During
the inspection, the inspector selects an available assessment which is associated with a system result. The system
result determines the scoring calculation as follows:

Displayed Assessment System Result Scoring Calculation
Pass Pass Score = All Points
Corrected on Site Corrected Score = All Points
Fail Fail Score = No Points
NA (not applicable) Other Score = No Points

" Note: Only the displayed assessment value is configurable by the agency. The available system results
are Pass, Fail, Corrected, and Other. You must have one assessment with a system result of Pass and
one assessment with a system result of Fail. You can define multiple assessments with system results of
Corrected and Other.

See Setting Up Inspection Assessment Types.
2. Inspection Scoring Method
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The scoring method is defined on the inspection type. In this example, the scoring method is Bottom Up.

See Setting Up Inspection Types.
3. Rating Method

When you use a scoring method, you also must set up a rating method. The rating method defines the range of
scores used at the inspection type level.

See Setting Up Rating Methods.
4. Checklist

The checklist used in the inspection is defined on the inspection type. For example, the checklist could be Electrical
for a residential addition. For multiple checklists, you enter a checklist group name. A checklist group can have
different inspection checklists, such as both Electrical and Plumbing for a residential addition.

See Setting Up Inspection Checkilists.
5. Checklist Item

The inspection score is defined in the inspection checklist details. In this example, each checklist item is set up with
a possible score of 25. The inspector’s assessment determines how many points are applied to the checklist. When
the inspection result is Pass, the item receives the complete score.

See checklist details in Setting Up Inspection Checklists.
Based on the setup, an example inspection evaluation might look like this:

Checklist Iltem Possible Score Inspector’s Assessment System Calculated Score Checklist Total

Checklist Item Status Score
Result (Assessment)

1 25 Pass Pass 25 tem 1 =25

2 25 Pass Pass 25 ftem 1 + ltem 2 =50

3 25 Corrected on Site Corrected 25 ltem 1 + ltem 2 +
ltem 3 =75

4 25 Fail Fail 0 Item 1 + ltem 2 +

tem 3 + Item 4 =75

For multiple checklists, the sum of the checklist scores determines the inspection score.

Setting Up Inspection Assessment Types

Assessment types identify the results available for assessing an inspection, for example, Pass and Fail. You add, modify, or
delete assessment types and codes for inspections on the Assessment Type pages.

An assessment type includes one or more assessment codes, which identify the possible results for the inspection type.
Assessment types are also used for inspection checklist and checklist item results.
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Assessment types function independently of the scoring method, maximum score, and minimum score, for example:

e [f the system result is Pass or Corrected, the full score is assigned.
e |f the system result is Other or Fail, the score is 0.

Scoring for each system result is predefined in the system for inspections.

This example illustrates the Assessment Type Details page containing the field values described in the following table.

Assessment Type Details

* Assessment Type * Description Result is either Pass or Fail

Assessment Details

Assessment Description System Result
Fail Fail

Pass Pass

Adding Inspection Assessment Types

Select Inspection Setup > Assessment Type .

apobdA

Enter values in the fields of the assessment code row:

On the Assessment Type page, click Add to add an assessment type.
On the Assessment Type Details page, enter an assessment type name and description.
In the Assessment Details section, click Add in the assessment code row.

Cancel

Actions
v+ 0
v L]

Page Element Description

Assessment Enter a code name.

Description Enter descriptive text for the code.

System Result Select the system-defined result value that you want to set for this assessment code:
o Other
o Pass
o Falil

o Corrected

You must map each assessment code to a system result value. Each assessment type must
include a system result of Pass and a system result of Fail. The default value is Other.

g
# Note:

You must assign Fail to only one code. Likewise, you must assign Pass to only one

code.

The system result is used in the inspection result processing. If scoring is used, the system
result of Pass and Corrected receive the maximum score. The system results Other and Fail

receive no score.

The system result is also used to determine whether an inspection result is pass (system
result Pass) or fail (system result Fail). For example, the Inspection Summary report includes
violation information when a checklist or checklist item result is associated with the system

result Fail.

ORrRACLE
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Page Element Description

6. Click the Add icon at the end of the row to add another assessment code row.
7. Click Save.

Modifying Inspection Assessment Type Details

1. Select Inspection Setup > Assessment Type .
Select the row for the assessment type you want to modify.

3. Inthe header fields on the Assessment Type Details page, you can only modify the assessment type description.
You cannot change the name.

4. Inthe Assessment Details section, you can:

o Change the description of an assessment code. You cannot change the code name.

o Select a new value in the System Result column. Available values are Pass, Fail, Corrected, or Other. Each
assessment code must be mapped to a system-defined result value. The default value is Other. You can only
use Pass and Fail once.

5. If you made any changes, click Save.

Deleting Inspection Assessment Types

1. Select Inspection Setup > Assessment Type .
2. On the Assessment Type page, click the Edit icon.
3. Select one or more check boxes for the assessment type rows you would like to delete.

#" Note: When you delete an assessment type, you also delete the associated details.

4. Click the Delete icon.

Deleting Inspection Assessment Type Details

1. Select Inspection Setup > Assessment Type .
On the Assessment Type page, select the row for the assessment type you are working with.

3. On the Assessment Type Details page, click the Delete icon at the end of the assessment code row you would like
to delete. You delete details one row at a time.

4. Click the Save button.

Setting Up Rating Methods

A inspection rating method may have one or more rating ranges, which an inspector uses to evaluate the object of an
inspection. You add, modify, or delete rating methods and rating details for inspections on the Rating Method page.

If you are using scoring for inspections, you must also set up rating methods. Rating methods are used at the inspection type
level and are not required at the checklist or checklist item levels.
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Adding Rating Methods

You add an inspection rating method by setting up the rating method code with a description and rating details. For example,
an agency might use GRADES as the rating method code, with a description of Standard Grades. The rating details might
include grades such as A (high) to F (low), and provide a range of scores to each rating. If the rating for an A grade is defined
by 90-100 points, an inspection score of 95 would receive an A.

1. Select Inspection Setup > Rating Method .
2. On the Rating Method page, click Add to add a rating method.
3. On the Rating Method Details page, enter a rating method name and description. The description is a user-friendly
name for the inspection rating method.
4. To add rating method values, click the Add button for the first row in the detail grid, and the Add icon for the next
rows.
5. Enter values for the rating method:
Rating Enter a short name for the rating.
Minimum Score and Maximum Enter minimum and maximum numerical values to specify the range for this rating. Do not
Score use decimals.
The range for this rating cannot overlap the range for another rating.
6. Click Save.

For example, if your rating method uses grades A through F, you specify the rating range for each grade in the Rating
Method Values table. The range for each rating cannot overlap the range for another rating.

Rating Minimum Score Maximum Score
A 91 100

B 81 90

C 71 80

D 61 70

F 0 60

Modifying Rating Methods

1.
3.

4.

Select Inspection Setup > Rating Method .
On the Rating Method page, select the row for the rating method you want to modify.

In the header fields on the Rating Method Details page, you can only modify the rating method description. You
cannot change the name of the rating method.

Click Save.
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Modifying Rating Method Values

You can change the minimum and maximum scores for a rating on the Rating Method Details page.

pPODd

5.

Select Inspection Setup > Rating Method .

On the Rating Method page, select the row for the rating method you want to modify.

On the Rating Method Details page, select the rating row in the values grid that you want to modify.

Change the values in the Minimum Score or Maximum Score fields for this rating on the Rating Method Value
Details page. You can use the arrow icons to increase or decrease the score values. The range for this rating cannot
overlap the range for another rating. You cannot change the name of the rating.

Click Save.

Deleting Rating Methods

1.

3.

o A

7.

Select Inspection Setup > Rating Method .
On the Rating Method page, select the row for the rating method you want to delete.
On the Rating Method Details page, click Delete.

" Note: When you delete a rating method, all associated rating details are also deleted.

To delete multiple rating methods, click the Edit icon on the Rating Method page.
Select the check boxes for the rating methods you want to delete.
Click the Delete icon.

" Note: When you delete multiple rating methods, all associated rating details are also deleted.

Click Save.

Deleting Rating Method Values

ONOoO RN

Select Inspection Setup > Rating Method .

On the Rating Method page, select the row for the rating method you want to modify.

On the Rating Method Details page, select the ratings row in the value grid that you want to delete.
On the detail page for the individual rating, click Delete.

To delete multiple rating method values, click the Edit icon in the Rating Method Values section.
Select the check boxes for the rating method values you want to delete.

Click the Delete icon.

Click Save.

Setting Up Passing Rules

A passing rule identifies the different ways an inspection can be scored. You add, modify, and delete passing rules for
inspections on the Passing Rule page.

Passing rule definitions provide the criteria for determining whether an inspection passes or fails. If the scoring method is not
used in the inspection type definition, a passing rule is not required.
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Adding Passing Rules

A passing rule may have one or more scoring ranges that you specify in the passing rule details.

akroN 2

6.

Select Inspection Setup > Passing Rule .

On the Passing Rule page, click Add to add a new passing rule.

On the Passing Rule Details page, enter a unique code for the passing rule and a description.
To add scoring ranges, click Add in the Passing Rule Criteria section.

Enter values in the fields on the rule details page:

Page Element Description

Description Enter a description for the scoring range.

Minimum Score and Maximum Enter minimum and maximum numerical values to specify the scoring range. You cannot use
Score decimals.

Number of Major Violations Enter a value for the maximum number of major violations allowed.

Pass Turn on the Pass switch if the specified scoring range combined with the number of

violations results in a passing inspection. If the specified range and violations do not result in
a passing inspection, leave the option disabled.

# Note:
For passing inspections that are based on a passing rule with the Pass switch on,
the inspection result displays the assessment name that is defined with the system
status Pass. If the Pass switch is off, the inspection result displays the assessment
name that is defined with the system status Fail. The system uses the assessment
type that is associated with the inspection type.

Click Save.

Modifying Passing Rules

1.
3.

4,

Select Inspection Setup > Passing Rule .
On the Passing Rule page, select the row for the passing rule you want to modify.

In the header fields on the Passing Rule Details page, you can only modify the passing rule description. You cannot
modify the passing rule code.

Click Save.

Modifying Passing Rule Details

You can change the scoring range for a passing rule on the Passing Rule Details page.

pPODdM
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Select Inspection Setup > Passing Rule .

On the Passing Rule page, select the row for the passing rule you want to modify.

On the Passing Rule Details page, select the scoring row in the details grid that you want to modify.
You can change the following scoring details:

a. Description of the scoring range.
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b. Minimum and maximum scores to update the scoring range. Use the arrow icons to increase or decrease the
score values.

c. Number of major violations allowed.
You can also indicate that the specified scoring range combined with the numiber of violations can result in a passing
inspection, by clicking the Pass slider. Turn off the option using the slider if the scoring range combined with the
violations does not result in passing an inspection,
5. Click Save.

Deleting Passing Rules

When you delete a passing rule, all associated passing rule criteria are also deleted.

Select Inspection Setup > Passing Rule .

On the Passing Rule page, select the row for the passing rule you want to delete.

On the Passing Rule Details page, click Delete.

If you want to delete multiple passing rules, you can delete them from the Passing Rule page:
a. Click the Edit icon.
b. Select the check boxes for the passing rule rows to delete.
c. Click the Delete icon.

pPODS

Deleting Passing Rule Criteria

Select Inspection Setup > Passing Rule .
On the Passing Rule page, select the row for the passing rule with the passing rule criteria you want to delete.
In the Passing Rule Criteria section, select the row for the passing rule criteria you want to delete.
On the Passing Rule Criteria Details page, click the Delete button.
If you want to delete multiple scoring ranges, you can delete them from the Passing Rule Details page:
a. Click the Edit icon.
b. Select the check boxes for the passing rule criteria rows to delete.
c. Click the Delete icon.

agkroDN=

Setting Up Inspection Checklist Categories

Use checklist categories and subcategories organize the various types of checklists items for inspections.
You set up inspection checklist categories and subcategories on the Inspection Checklist Category page.

Use the checklist categories and subcategories for categorizing checklist items when you set up inspection checklists on the
Inspection Checklist ltem Details page. See Setting Up Inspection Checklists.

Adding Checklist ltem Categories

Select Inspection Setup > Checklist Category .
On the Checklist Category page, click Add to add a checklist category.
On the Checklist Category Details page, enter a category ID and description.

If you want to add a subcategory, click the Add button to add the first subcategory in the Checklist Subcategory
section. Click the Add icon for additional subcategories.

pPODS
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5. On the Checklist Subcategory Details page, enter a subcategory ID and a description.
6. Click Save.

Modifying Checklist ltem Categories

1. Select Inspection Setup > Checklist Category .
2. On the Checklist Category page, select the row for the category that you want to modify.
3

On the Checklist Category Details page, you can only modify the category description. You cannot change the
category ID.
4. Click Save.

Modifying Checklist ltem Subcategories

Select Inspection Setup > Checklist Category .

On the Checklist Category page, select the row for the category with the subcategory that you want to modify.
Select the subcategory that you want to modify in the Checklist Subcategory section.

You can only change the description on the Checklist Subcategory Details page.

Click Save.

apON~

Deleting Checklist Iltem Categories

When you delete a checklist category, all associated subcategories are also deleted.

Select Inspection Setup > Checklist Category .

On the Checklist Category page, select the row for the category that you want to delete.

On the Checklist Category Details page, click Delete.

If you want to delete multiple checklist categories, you can delete them on the Checklist Category page:
o Click the Edit icon.
o Select the check boxes for the category rows to delete.

o Click the Delete icon.

pPODNS

Deleting Checklist Subcategories

Select Inspection Setup > Checklist Category .
On the Checklist Category page, select the row for the category with the subcategory that you want to delete.
On the Checklist Category Details page, select the row for the subcategory that you want to delete.
Click the Delete button on the Checklist Subcategory Details page.
If you want to delete multiple subcategories, you can delete them on the Checklist Category Details page:
o Click the Edit icon.
o Select the check boxes for the subcategory rows to delete.

o Click the Delete icon.

aprpON

Setting Up Inspection Checklists

Inspection checklists identify all the items that the inspector must assess during an inspection. You set up inspection
checklists and checklist items on the Inspection Checklist pages.
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Before adding inspection checklists, you set up:
e Inspection assessment types for your agency, if you want to associate a checklist with an assessment type.

See Setting Up Inspection Assessment Types.

e Inspection checklist categories and subcategories, if you want to categorize your checklist items.

See Setting Up Inspection Checklist Categories.

You add, maodify, and delete checklists and checklist items in the inspection setup pages. The checklist and checklist items
are copied to the inspection when the inspection schedule is created, and appear on the Inspection Checklist page, the
Checklist Items page, and the Checklist ltem Result page.

#" Note: When you modify an inspection checklist or checklist item, the updated checklist is applied to new
inspections using the checklist. Existing inspections use the version of the checklist definition in use when the
inspection was scheduled.

You identify the checklist or checklist group to use for an inspection on the Inspection Type page. To set up a checklist group
after setting up checklists, see Setting Up Inspection Checklist Groups.

This example illustrates the Inspection Checklist Details page containing the field values described in the preceding table.

Inspection Checklist Details Concel  Delete

* Checklist CK-FN
* Description  FNC_Checklist

Maximum Score 100 Minim

Scoring Method  Not used v

Checklist ltems
= [ (= Search. aQy
Checklist Item Description Required Score Major Violation
Fence-Height Fence-Height Yes No
Fence-Material Fence-| Material Yes No
Fence-Type Fence-Type Yes No

Footings Footings Yes No

v v v v v

Gate Gate Yes No

Show 8 items v

Adding Inspection Checklists

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, click Add to add a checklist.

On the Inspection Checklist Details page, enter a checklist ID and description.

Verify that the Enabled switch is turned on. The switch is turned on by default for new checklists.
You can also enter values for these fields:

Page Element Description

Assessment Type Enter an assessment type.

apopA

The system determines a passing result based on the assessment type defined for the
checklist. The assessment that is defined with system status Pass is used for the passing
result. Otherwise, the assessment that is defined with the system status Fail is used.
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Page Element

Description

Assessment types function independently of the scoring method, maximum score, and

minimum score.

See Setting Up Inspection Assessment Types.

Maximum Score

Enter the maximum score possible for the checklist. This value is required if the scoring
method is Top down, which will be available in a future release.

Minimum Passing Score

Enter a minimum score for a passing grade. This value is required for the scoring method
Bottom up.

If the total score for the checklist is equal to or greater than the minimum passing score, the
checklist receives a passing result.

Scoring Method

Select a scoring method to be used for the checklist:

o Bottom up: Scoring from the bottom up indicates that the scoring starts with zero and
the inspector adds points for the criteria that are met.

o Not used: This is the default value and indicates that no scoring method is used for
this checklist. You must specify the result manually for each level: checklist item,
checklist, and inspection.

If you don’t use the scoring method you can’t use the passing rule and rating method.
This also means that results are not automatically calculated starting with the checklist
items to the checklist to the inspection level.

# Note:
The scoring method specified for the checklist should match the scoring method in
the Inspection Type definition.

Comment

Enter any additional information.

6. Click Save.

Adding Inspection Checklist ltems

1. Select Inspection Setup > Inspection Checklist .

2. On the Inspection Checklist page, select the row for the checklist to which you want to add checklist items.

3. On the Inspection Checklist Details page, click the Add button in the Checklist Items section to add the first
checklist item. Click the Add icon for additional checklists.

4. Enter values for fields on the Checklist ltem Details page. Required fields include the checklist item ID and

description.

Page Element Description

Checklist Item and Description

Enter an ID and description for the checklist item.

Score

Enter the score the item receives if it passes the inspection.

Major Violation

Turn on the switch to indicate that this checklist item is considered a major violation if it does
not pass inspection.
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Page Element Description
Category and Subcategory Enter a category and subcategory for the checklist item. See Setting Up Inspection
Checklist Categories.
Instructions Click the Add button in the Instructions section to add instructions for inspecting the

checklist item.

Add instructions on the Instruction Details page, including an instructions ID and the
instructional text.

5. The Required switch is turned on by default to indicate that the inspection of the item is required. The inspector
can’t submit the inspection result until all required checklist item and checklist results are complete.

If the checklist item is not required, you can turn off the switch.
6. Click Save.

Modifying or Deleting Checklists

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the row for the checklist you want to modify.

On the Inspection Checklist Details page, you can change the values for all fields except for the checklist ID.
If you made any changes, click Save.

If you want to delete the checkilist, click Delete.

apron 2

" Note: When you delete a checklist, all associated checklist items are also deleted.

6. If you want to delete multiple checklists, you can delete them from the Inspection Checklist page:

a. Click the Edit icon.
b. Select the check boxes for the checklist rows to delete.
c. Click the Delete icon.

Modifying or Deleting Checklist [tems

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the checklist row associated with the checklist item.

On the Inspection Checklist Details page, select the row for the checklist item in the Checklist ltems section.
On the Checklist Item Details page, you can change the values for all fields except for the checklist item ID.

If you made any changes, click Save.

If you want to delete the checklist item, click Delete.

If you want to delete multiple checklist items, you can delete them from the Inspection Checklist Details page using
the Edit and Delete icons.

8. Click Save.

NoogkroN

Modifying or Deleting Checklist Item Instructions

1. Select Inspection Setup > Inspection Checklist .
2. On the Inspection Checklist page, select the checklist row.
3. On the Inspection Checklist Details page, select the row for the checklist item that contains the instructions.
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On the Checklist Item Details page, select the row for the instructions that you want to modify or delete.

Change the instructional text on the Instruction Details page. You can’t change the instructions ID.

If you made any changes, click Save.

If you want to delete the instructions, click Delete.

If you want to delete multiple instructions, you can delete them from the Checklist Item Details page using the Edit
and Delete icons.

Click Save.

Setting Up Inspection Checklist Groups

A checklist group comprises inspection checklists that you can associate with a permit. You define a checklist group by
selecting one or more inspection checklists.

You set up inspection checklist groups on the Checklist Group page.

Before setting up inspection checklist groups, you must set up your checklists on the Inspection Checklist page. See Setting
Up Inspection Checklists.

Adding Inspection Checklist Groups

7.

BN S

Select Inspection Setup > Checklist Group .

On the Checklist Group page, click Add to add a checklist group.

On the Checklist Group Details page, enter a name and a description for the group of inspection checklists.
Click Save.

To add an inspection checklist to the group, click Add in the Checklists section.

On the Checklist Details page, enter the ID for an existing checklist in the Checklist field.

The description for the checklist ID you entered appears in the Description field.
Click Save.

Modifying Inspection Checklist Groups

You can modify or delete checklist groups and lines on the Inspection Checklist Group page.

1.
3.

4,

Select Inspection Setup > Checklist Group .
On the Checklist Group page, select the row for the checklist group that you want to modify.

On the Checklist Group Details page, you can only modify the checklist group description. You cannot change the
group name.

Click Save to save any changes.

Deleting Inspection Checklist Groups

PN~

Select Inspection Setup > Checklist Group .

On the Checklist Group page, select the row for the checklist group that you want to delete.

On the Checklist Group Details page, click Delete.

If you want to delete multiple checklist groups, you can delete them from the Checklist Group page:

a. Click the Edit icon.
b. Select the check boxes for the checklist group rows to delete.
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c. Click the Delete icon.
Removing Inspection Checklist from an Inspection Checklist Group

#" Note: You cannot modify inspection checklists on the Inspection Checklist Group pages; you can only remove
them from the group.

1. Select Inspection Setup > Checklist Group .
2. On the Inspection Checklist Group page, select the row for the checklist group from which you want to remove one
or more inspection checkilists.
3. On the Inspection Checklist Group Details page, select the row for the inspection checklist that you want to remove
from the group.
4. On the Inspection Checklist Details page, click Delete.
5. If you want to remove multiple inspection checklists from the group, you can delete them from the Inspection
Checklist Group Details page:
a. Click Edit in the Inspection Checklists section.
b. Select the check boxes for the inspection checklist rows to delete.
c. Click Bulk Delete.
d. Click Save.

Setting Up Inspection Types

Define inspection types used by your agency to identify the requirements and options for different types of inspections. You
set up information such as scheduling, assessments, checklists, billing, signatures required, and comments on the Inspection
Type pages.

The inspection type is associated with the permit for the scheduled inspection and defines the different attributes for
performing the inspection.

This example illustrates the Inspection Type Details page containing the field values described in the following table.

Inspection Type Details
* Inspection Type Enabled c
* Description  Final Fence Inspection * Estimated Duration in Hours 0.5
Scheduling Method  Schedule v
Assessment Type  PassFail o Passing Rule o
Rating Method o, Scoring Method  Not used v
* Autonumber Rule  PF_Fence_Inspection o Maximum Score
Checklist Group o Checklist CL-1234 o
Billable Bill Type [°§
Policy Name Policy Version
Inspector Signature Required v Owner Signature Optional v
Contractor Signature Optional v Schedule Cutoff Time
Inspection District Type E2E_District o Schedule Change Policy
Hide Inspector Comments
Cancel | Delete
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" Note: When you modify an inspection type, the updated values are applied to new inspections using the
inspection type. Existing inspections use the original inspection type definition.

Adding Inspection Types

You add inspection types for your agency on the Inspection Type page. You must set up the attributes for the inspection type

before you begin.

1. Select Inspection Setup > Inspection Type .
On the Inspection Type page, click Add New to add a new inspection type.

3. Enter values for fields on the Inspection Type Details page. Required fields include Inspection Type and
Description, Estimated Duration in Hours, and Autonumber Rule.

Page Element Description

Inspection Type and Description

Enter a unique ID and description for the inspection type.

Estimated Duration in Hours

Enter the estimated number of hours this type of inspection will take.

This field is required for scheduling. For more information, see Setting Up Inspection
Scheduling.

Scheduling Method

Select the scheduling method for inspections associated with this inspection type.
Select Schedule to enable users to select a date and time when requesting inspections.

Select Request to require requested inspections to be scheduled and assigned by
inspection supervisors.

For more information, see Setting Up Inspection Scheduling.

Assessment Type

Enter an assessment type, which is used in the inspection result processing.

For more information, see Setting Up Inspection Assessment Types.

Passing Rule

Enter a passing rule, which defines the criteria for determining whether an inspection passes
or fails.

For more information, see Setting Up Passing Rules.

Rating Method

Enter a rating method, which defines the scoring ranges used by the passing rule to
determine whether an inspection passes or fails.

You must set up a rating method if you are using scoring. For more information, see Setting
Up Rating Methods.

Scoring Method

ORACLE

Select a scoring method from these options:

o Bottom up: Scoring bottom to top indicates that the inspector starts with zero and
adds points for each criterion that is met. You must set up a passing rule for bottom
up scoring.

o Not used: This is the default value and indicates that no scoring method is used for
this inspection. You must specify the result manually for each level: checklist item,
checklist, and inspection.
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Page Element Description
If you don’t use the scoring method you can’t use the passing rule and rating method.

This also means that results are not automatically calculated starting with the checklist
items to the checklist to the inspection level.

¢#" Note:

»
The scoring method specified for the checklist should match the scoring method in
the Inspection Type definition.

Maximum Score Enter the maximum number of points. The maximum score applies to all the checklist items
assigned to a checklist.

This field is not being used currently, because the it’s required only if the scoring method is
Top down, which will be available in a future release.

Autonumber Rule Enter the ID for the automatic numbering rule to use for generating the inspection
transaction key.

For more information, see Setting Up Autonumbering.

Checklist Group You can enter a checklist group. If you enter a checklist group, you cannot also enter a
checklist ID.

For more information, see Setting Up Inspection Checklist Groups.

Checklist You can enter the ID for a single checklist. You cannot enter both a checklist group and a
checklist ID.

For more information, see Setting Up Inspection Checklists.

Billable Click this slider if this inspection type is billable. When you turn on this switch, the Bill Type
field becomes required.

Bill Type Enter a bill type. This field is required if the Billable switch is turned on.

For more information, see Setting Up Bill Types.

Policy Name and Policy Version Enter the name of the template and version number the OPA (Oracle Policy Automation)
policy.

For more information, see Overview of Oracle Policy Automation Configuration.

Inspector Signature Select a signature option for the inspector, owner, and contractor associated with the
inspection type:
Owner Signature

o Required: The signature field appears on the Inspection Results page.
Contractor Signature

# Note:
Inspectors can’t submit a completed inspection if required signatures are missing.

o Not Required: The signature field does not appear on the Inspection Results page.
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Page Element Description

o Optional: A signature is optional for this inspection type.

The default value for the Inspector Signature is Required.

The default value for the Owner Signature and Contractor Signature is Optional.

Schedule Cutoff Time Enter the time when scheduling requests for the following day end. For example, if the cut
off is 3:00 PM and current time is 4:30 PM, the agency or permit applicant can’t select an
inspection time for tomorrow.

This field is required for scheduling. For more information, see Setting Up Inspection
Scheduling.

Inspection District Type Enter the inspection district type for this inspection, for example a building, electrical, or
plumbing inspection district. When the inspection with this inspection type is scheduled, the
system finds the inspector who is assigned to a district belonging to the inspection district
type defined on the inspection type.

This field is required for scheduling. For more information, see Setting Up Inspection
Scheduling.

Schedule Change Policy Enter the acceptable number of hours prior to the inspection that the user can change the
schedule.

For more information, see Setting Up Inspection Scheduling.

Hide Inspector Comments Turn on this switch if you want to hide inspector comments from public users. The default
value for this switch is off so that inspector comments are visible.

4. Verify that the Enabled switch is turned on if you want to enable this inspection type when you save it. The switch is

turned on by default for a new inspection type.

5. Click Save.

Modifying or Deleting Inspection Types

You can modify or delete inspection types on the Inspection Type page.

oakrwbd

Select Inspection Setup > Inspection Type .

On the Inspection Type page, select the row for the inspection type you want to modify.

On the Inspection Type Details page, you can change the values for all fields except for the inspection type code.
If you made any changes, click Save.

To delete the inspection type, click Delete.

If you want to delete multiple inspection types, you can delete them from the Inspection Type page:

a. Click the Edit icon.
b. Select the check boxes for the inspection type rows to delete.
c. Click the Delete icon.
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Setting Up Inspection Groups

An inspection group identifies a group of inspection types associated with a permit. You can set up inspection groups on the
Inspection Group page.

The inspection group includes one or more inspection types. You can define inspection groups separately from permit type
definitions.

Before setting up inspection groups, you must set up inspection types for your agency on the Inspection Type page. See
Setting Up Inspection Types.

Adding Inspection Groups

Select Inspection Setup > Inspection Group .
On the Inspection Group page, click Add to add a new inspection group.
On the Inspection Group Details page, enter a name and a description for the inspection group.
Click the Enabled switch to enable the new inspection group.
To add inspection types to include in the group, click Add in the Inspection Types section.
Enter values in the columns of the inspection type row:

a. Inspection Type: Enter an existing inspection type.

The description for the inspection type you entered will appear in the Description field.
b. Required: Click the switch if the inspection type is required for the inspection group.

oaprN

#" Note: Even if an inspection type is not required, it may become required based on business rules
during processing.

c. Final Inspection: Click the switch if this inspection type is the final inspection. One and only one row must be
set as the final inspection.

d. Click the Add icon to add another type; otherwise, click Save.
7. On the Inspection Group Details page, click Save.

Modifying or Deleting Inspection Groups

You can modify or delete inspection groups on the Inspection Group page.

Select Inspection Setup > Inspection Group .
On the Inspection Group page, select the inspection group that you want to modify.

On the Inspection Group Details page, you can only modify the inspection group description. You cannot change the
group name.

Click the Enabled switch to enable or disable the inspection group.

If you want to delete the inspection group, click Delete on the Inspection Group Details page.

Click Save to save any changes.

If you want to delete multiple inspection groups, you can delete them from the Inspection Group page:
a. Click Edit.
b. Select the check boxes for the inspection group rows to delete.
c. Click Delete.

N~
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8.

10.
11.

In the inspection types grid, you can:

oo

e o

Click the Required switch to enable or disable an inspection type.

Click the Final Inspection switch to set an inspection type as the final inspection. One and only one row
must be set as the final inspection.

Click Add to add a new inspection type row.
Click the Delete icon at the end of the row to remove an inspection type from the group.

" Note: You cannot change the inspection type ID or description, but you can remove an inspection type

and add another.

Click Save to save any changes.
If you want to remove an inspection type from the group, click Delete.

If you want to remove multiple inspection types from the group, you can delete the rows from the Inspection Group
Details page:

eooTo

Click Edit.

Select the check boxes for the inspection type rows to delete.
Click Delete.

Click Save.

Setting Up Inspection Calendars

Inspection calendars establish the days of the week and daily hours that are available for scheduling specific types of
inspections.

Administrators add, modify, and delete inspection calendars on the Inspection Calendar page.

Adding an Inspection Calendar

1.

Select Inspection Setup > Inspection Calendar .
2. On the Inspection Calendar page, click Add.
3. On the Inspection Calendar Details page, enter values for the following fields:

Page Element Description

Calendar ID Enter a unique ID for the calendar.

Inspection Type Select the type of inspection to which this calendar applies.

For more information on inspections types, see Setting Up Inspection Types.

Inspection District Select the district to which this calendar applies.
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Page Element Description

# Note:
A small municipality may have only one defined district ID that includes its entire
inspection area. A large municipality may have multiple defined district ID. This
enables you to create inspection calendars for different areas to optimize your
distribution of resources.

For more information on districts, see Setting Up Districts.

Description Enter a description for the calendar. For example, you might enter Final fence inspection
calendar.

Start Date Enter the first day of the calendar.

End Date Enter the last date of the calendar. You can leave this field blank to give the calendar an

open end date.

Start Time and End Time

Enter the start and end time for the calendar. For example, you might enter a start time of
09:00 and an end time of 16:00.

Recurrence

Select whether the calendar reoccurs weekly. If you select Weekly recurrence, enter the
number of weeks between occurrence in the Weeks Between Occurrences field.

Weeks Between Occurrences

Enter how many weeks are between each occurrence. For example, if you select a
recurrence of Weekly with 1 week between occurrences, the calendar repeats every week.

# Note:
When the recurrence frequency for an inspection calendar is greater than 1, the
first week of scheduling is the week that contains the start date, where Sunday is
considered the first day of the week. Therefore, it is recommended that you set the
start date to the Sunday of the first week in which you want to schedule inspections.

For example, you create an inspection calendar for Mondays and Fridays where
the recurrence frequency is 2, alternating weeks. Setting the calendar start date

to January 1, 2019 causes January 4, 2018 to be available for scheduling but not
December 31, because it is before the start date. Also, January 7 and 11 are in
the alternate week, so the next days available for scheduling are January 14 and
18. If you set the start date to January 5, which is still part of the first week that the
calendar is active, the system considers this same week as the start week, but no
days are available until January 14 and 18.

Inspection Days

Select the days of the week that are available for inspection scheduling.

4. Click Save.

ORrRACLE
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#" Note: For overnight inspection calendars that go past 12 a.m. (midnight), you must create two calendars:
one for the time period up until midnight, and one for the time period after midnight. For example, to create a
weekday overnight calendar that starts at 09:00 p.m. and ends at 05:00 a.m. the following day, the first calendar
would have a start time of 09:00 p.m. and an end time of 12:00 a.m. on Monday, Wednesday, and Friday. The
second calendar would have a start time of 12:00 a.m. and an end time of 05:00 a.m. on Tuesday, Thursday,
and Saturday.

Modifying an Inspection Calendar

1. Select Inspection Setup > Inspection Calendar .
2. Click a row on the Inspection Calendar page.
3. On the Inspection Calendar Details page you can:

o Update the inspection calendar field values.

# Note: You cannot edit the Calendar ID.

o Delete the calendar. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Inspection Calendars

Select Inspection Setup > Inspection Calendar .

Click Edit.

Select the check boxes next to all the inspection calendars you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PN~

Setting Up Inspection Scheduling

When agency users and registered public users schedule an inspection, the system is actually determining which inspectors
are available and qualified to perform the inspection. Therefore, to schedule inspections, it is necessary to define all of the
appropriate employee data for inspectors.

Inspectors are considered qualified if they have been assigned the inspection type and district associated with the inspection.
The availability of inspectors is based on their work schedules and whether they have been assigned to other inspections
previously.

In addition, the time slots that are available for scheduling are impacted by inspection calendars and holiday calendars, which
define when inspections can and can’t be performed, respectively.

The system determines which inspectors can be scheduled to perform an inspection based on two sets of criteria.

1. Qualifications: To be qualified to perform an inspection, agency staff must be defined as inspectors, and assigned to
inspection types, districts and work schedules.
2. Availability: Agency holidays and inspection calendars, inspector work schedules, and existing inspector assignments
determine the availability of inspectors.
The following table lists the different types of data that need to be defined so that the system can determine inspector
qualifications and availability. The Frequency column lists how many instances of the data type can be defined. The Required
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column lists whether a data type is required for time slots to appear on the Scheduling modal page during inspection

scheduling.

For more information on inspection requests see Requesting Inspections.

Criteria Type Data Type Frequency Required Impact of Missing Data
Quialification Inspection Type One per inspection Yes Only defined inspection
types are available to
select when requesting
inspections. The Select
a Time button is not
available if the inspection
type’s scheduling
method is not Schedule.
Quialification District One per inspection Yes No scheduling times
are available on the
Note that the address Scheduling modal page.
selected for the
inspection needs to be Note that the inspection
associated to a parcel type and a parcel
for which there is an associated with the
assigned inspection permit must have the
district. same district type. If they
don’t, the Select a Time
button is unavailable for
the inspection request.
Quialification Inspectors One per employee who Yes No scheduling times
performs inspections are available on the
Scheduling modal page.
Quialification Assigned Inspection Type One or more per Yes No scheduling times
inspector are available on the
Scheduling modal page.
Qualification Assigned Inspection One or more per Yes No scheduling times
District inspector are available on the
Scheduling modal page.
Note that the assigned
inspection district and the
parcel associated with
the permit must have the
same district type. If they
don’t, the Select a Time
button is unavailable for
the inspection request.
Availability Work Schedule One or more for each Yes No scheduling times
period of the day are available on the
inspectors work; may Scheduling modal page.
include one break
Availability Assigned Work Schedule One or more per Yes No scheduling times

inspector

are available on the
Scheduling modal page.

ORrRACLE

127


http://www.oracle.com/pls/topic/lookup?ctx=pscr19b&id=task_RequestingInspections

Oracle Public Sector Compliance and Regulation Chapter 7

Implementing Community Development Setting Up Inspections
Criteria Type Data Type Frequency Required Impact of Missing Data
Availability Inspection Calendar One or more for each No The inspection can be

combination of inspection scheduled at any time
type and district of day (or whenever

inspectors are available).

Availability Assigned Inspection Automatically created No No time slots are
when an inspection is unavailable for scheduling
assigned due to previously

assigned inspections.

Availability Holiday Calendar On per agency No No days are unavailable
for scheduling due to
holidays or other agency
non-working days.

Inspection Types

You define inspection types using the Inspection Type page. The system uses the estimated duration to determine whether
an inspector is available for the entire time required to complete an inspection. The inspection district type is a pre-defined
district type with the category of Inspection.

For more information on inspection types, see Setting Up Inspection Types.

Inspection Districts

You must create an inspection district and assign it to inspectors to enable qualified inspectors and make time slots available
when scheduling inspections. The district for the inspection is based on the district type assigned to the inspection type.

The system uses this district type to determine the district ID associated with the parcel for which an inspection is being
scheduled. A parcel may have more than one district type associated with it, but only one of them has a district type category
of Inspection.

The system determines the parcel for the inspection based on the inspection address. The address for a new inspection
defaults to the primary address of the primary parcel associated with the permit for which you are scheduling an inspection.
You may select other addresses that are associated with the permit. If no address is associated with an inspection, the
system can’t determine the district for the inspection so the Select a Time and Select a Different Time buttons are disabled.

For more information on district types, districts, parcels, and addresses see:
e Setting Up District Types
e Setting Up Districts
e Associating Parcels with Districts

e Setting Up Parcel Addresses

Work Schedules

You must create work schedules and assign them to inspectors to make the inspectors available for inspection scheduling.

#" Note: If the recurrence for a work schedule is Weekly, and the weeks between occurrences is greater than 1,
the system uses the week of the valid from date as the starting point for scheduling.
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For more information on work schedules, see Setting Up Work Schedules.

Inspectors

To make inspectors available for inspection scheduling, you must perform the following steps on the Agency Staff page:

e Assign the ORA_BUILDING_INSPECTOR job function to the inspector.

e Assign inspection types to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job function.

e Assign inspection districts to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job function.
e Assign work schedules to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job function.

For more information on assigning job functions and job attributes to agency staff, see Setting Up Agency Staff.

Inspection Calendars

Setting up inspection calendars is optional for scheduling inspections. Without inspection calendars, however, the system can
potentially allow inspections to be scheduled for any time during a 24 hour period, if there are work schedules that comprise
all 24 hours.

You define inspection calendars for a specific combination of inspection type and district. You can define more than one
calendar for the same inspection type and district.

For more information on inspection calendars, see Setting Up Inspection Calendars.

Holiday Calendar

Setting up holiday calendars is optional for scheduling inspections. Holiday calendars establish the days that agency offices
are closed and no field service operations are offered. The dates established as events on the holiday calendar are not
available for inspection scheduling regardless of how the inspection calendars or work schedules are defined.

For more information on holiday calendars, see Setting Up Holiday Calendars.
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8 Setting Up Comments

Managing Comments

This topic provides an overview about Standard Comments and discusses how to manage Comments.

Standard Comments: Overview

Standard comments are pre-defined comments that users can easily and quickly use, instead of manually entering the text.
Standard comments are generic and complete, which make them reusable.

Users can use Standard Comments across all Public Sector Compliance and Regulation offerings. You can use Standard
Comments while updating your applications.

System Administrators set up application categories and subcategories using the Application Category page, based on the
type of comments you wish to have. Standard Comments are set up using the Standard Comments page.

Managing Comments

You manage the Comments by setting up how you want the comments to be available for the agency staff members.

1. Select Comments > Manage Comments .
2. On the Manage Comments page, you add values to all these fields:

Page Element Description

Number of days comment is Enter a numeric value or use the increment/decrement buttons. The number of days a
recent comment is listed as Recent is based on the value in this field.

Rich Text Editor Use the switch to enable or disable Rich Text Editor formatting for comments.
Comment Summary Length Enter a numeric value or use the increment/decrement buttons. This value determines the

maximum number of characters that can be displayed in the Comment Summary field.

# Note:
The system allows a maximum length of two hundred (200) characters in the
comment summary.

3. Click Save to save the changes.
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Setting Up Standard Comment Categories and
Subcategories

This topic discusses how to set up Standard Comment Categories and Subcategories.

Setting Up Standard Comment Categories and Subcategories

You set up the comments categories and subcategories on the Application Category page.

1. Select Comments Setup > Comment Categories .

On the Application Category page, click Add to add a new category.
2. On the Application Category Details page, you add values to all these fields:

Field Name Description

Application Category Enter a category.

Description Enter a description for the category. This description displays detailed information about the
category when searching for categories.

3. Turn on the Enabled switch if you want to enable this category when you save it. The switch is turned off by default
for a new category.

In the Application Groups section, you can include application groups that you want this category to be available for.
Click Add to open the Application Group Details page, select the application group.

Turn on the Enabled switch if you want to enable the selected group when you save the page.

Click Save to save the newly added application group and return to the Application Category Details page.

To add an application subcategory, select the Application Subcategories section and click Add.

On the Application Subcategory Details page, you add values to all these fields:

&
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Field Name Description

Application Subcategory Enter a subcategory

Description Enter a description for the subcategory. This description displays detailed information about
the subcategory when searching for subcategories.

9. Turn on the Enabled switch if you want to enable this subcategory when you save it. The switch is turned off by
default for a new subcategory.
10. Click Save to save the newly added application subcategory and return to the Application Category Details page.
11. Click Save to save the record and return to the Application Category page.

Modifying Standard Comment Categories and Subcategories

You modify the comments categories and subcategories on the Application Category Details page.

1. Select Comments Setup > Comment Categories .
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On the Application Category page, click the chevron on a category line to select and modify the category.

On the Application Category Details page, enter new values in the Application Category and Description fields.
Verify that the Enabled switch is turned on if you want to enable this category when you save it.

Use the Application Groups section to select the application group that you want this category to be available for.
In the Application Subcategories section, you can edit the application subcategories.

Click Save to save the changes. You can use the Delete button to delete the category.

NookroDd

Viewing, Adding, Modifying, and Deleting Standard
Comments

This topic discusses how to view, add, modify, and delete Standard comments.

Viewing Standard Comments

You search and view Standard Comments on the Standard Comments page.

1. Select Comments Setup > Standard Comments .
2. Use the application category or application subcategory fields to filter comments on the Standard Comments page.

Adding Standard Comments

You add comments using the Add button on the Standard Comment page.

1. Select Comments Setup > Standard Comment

On the Standard Comments page, click Add to open the Standard Comment Details page and add a new
comment.

3. On the Standard Comment Details page, enter values for these fields:

Page Element Description

Comment Code Enter a comment code.
Application Category Enter an application category
Application Subcategory Enter an application subcategory
Description Enter a comment.

4. Verify that the Enabled switch is turned on if you want to enable this comment when you save.
5. Click the Save button to save the new comment and return to the Standard Comment page.

Modifying Standard Comments

You modify comments on the Standard Comment Details page.
1. On the Standard Comments page, click the chevron on a comment line to select and modify the comment.

133
ORACLE



Oracle Public Sector Compliance and Regulation

Chapter 8
Implementing Community Development

Setting Up Comments

2. To modify the comment, you can change the values entered in the Application Category and Application
Subcategory fields, and edit the description.

3. Verify that the Enabled switch is turned on if you want to enable this modified comment when you save.
4. Click Save.

Deleting Standard Comments

You delete comments on the Standard Comment Details page.

1. On the Standard Comments page, click the chevron on the comment line which you want to delete.
2. On the Standard Comment Details page, click the Delete button to delete the comment.
3. Click Yes on the confirmation page to delete the comment and return to the Standard Comments page.
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