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Preface

This preface introduces information sources that can help you use the application and this guide.

Using Oracle Applications

This topic explains the text conventions used in this guide and points you to where you can find more information about using
Oracle applications.

Conventions

The following table explains the text conventions used in this guide.

Convention Meaning

boldface Boldface type indicates user interface elements, navigation paths, or values you enter or select.
monospace Monospace type indicates file, folder, and directory names, code examples, commands, and URLs.
> Greater than symbol separates elements in a navigation path.

Additional Resources

e  Community: Use Oracle Cloud Customer Connect to get information from experts at Oracle, the partner
community, and other users.

e Guides and Videos: Go to the Oracle Help Center to find guides and videos.
e Training: Take courses on Oracle Cloud from Oracle University.

Documentation Accessibility

This topic covers accessibility concepts for this guide.
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website.

Videos included in this guide are provided as a media alternative for text-based help topics also available in this guide.

Contacting Oracle

This topic explains how to contact Oracle for support and to provide feedback.
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Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For
information, visit My Oracle Support or visit Accessible Oracle Support if you are hearing impaired.

Comments and Suggestions

Please give us feedback about Oracle Public Sector Compliance and Regulation applications help and guides! You can send
an e-mail to: PSCR_US@oracle.com.
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1 Implementing Compliance and Regulation
Using Functional Setup Manager

Using Functional Setup Manager

This topic discusses how to use the Functional Setup Manager.

Oracle Functional Setup Manager provides an integrated, end-to-end process for functional administrators to manage the
implementation and maintenance of Oracle Public Sector Compliance and Regulation services.

Business users configure features and manage setup data using the Functional Setup Manager. Subscription to offerings,
enabling functional areas, opting in features, and setting up guided end-to-end tasks pertaining to the offerings are all driven
through the Functional Setup Manager.

" Note: When configuring your offering using Functional Setup Manager, configure the functional areas in
the order they appear in Functional Setup Manager from top-to-bottom. Functional areas depend on the
configuration data for the functional areas appearing before them in the list.

For a detailed understanding of the Functional Setup Manager, see the documentation Using Functional Setup Manager.

Setting Up Transactions Using Functional Setup Manager

This topic provides the list of required tasks for the implementation of Public Sector Compliance and Regulation offerings,
which are organized under the functional areas in the Functional Setup Manager (FSM).

You must complete the tasks in these task lists to add the required setup data, configuration settings, and processes that
your agency will use across all Oracle Public Sector Compliance and Regulation services.

Functional Area Task List Description

Initial Users Define Initial Users for Public Sector Prepare the groundwork for defining access
through roles and privileges for the users
who will access your service. Tasks include
running the user and role synchronization
process, creating implementation users,
setting the next URL target for new users and
SO on.

Agency Profile Define Foundation Data Set up general foundational data that will
be used by the agency when conducting
transactions for the community. Tasks
include setting up address formats,
city information, county information,
country information, currencies, units of
measurements, and so on.
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Functional Area Task List Description

Define Calendars for Public Sector Set up the Holiday calendar for your agency
to define when your agency is available for
conducting business.

Define Schedules Work schedules establish the days of
the week and daily hours of operation for
agency employees. For example, defining a
work schedule for an inspector establishes
when an inspector can be scheduled for an
appointment.

Define Agency Define fundamental information for an
agency, including the agency ID, agency
name, country, currency, time zone, and so
on.

Fees and Payments Set Up Billing Set up your agency’s billing system. Tasks
include defining invoice forms, setting the
auto-numbering scheme, and selecting bill
types.

Set Up Payments Configure how payments will be processed
within your agency. Tasks include setting up
the payment gateway, configuring the cash
drawer, defining department and agency
payment processing options, and so on.

Inspections Define Inspections Configure the information required for your
inspection system to enable you to define,
organize, and schedule inspections. Tasks
include setting up assessment types, defining
rating methods and passing requirements,
configuring inspection calendars, and so on.

Plan Review Define Plan Review Set up the required information for your
agency to review plans associated with
permit applications. Tasks include defining
plan review statuses and setting up the
resulting plan review decision types, such as
approved, rejected, revision required and so
on.

Permit Types Define Permits Create and configure the types of permits
your agency will offer. Tasks include setting
up permit categories, defining permit
statuses, setting up workflows and fee
models, creating permit types, designing
permit application forms, and so on.

Accounting Define Accounting Set up the processing system to be used by
your accounting department. Tasks include
setting up accounts, funds, and ledgers as
well as defining accounting events and rules.
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Functional Area Task List Description

Agency Staff Define Agency Staff Set up the service to accommodate the
information used to define and support
your agency staff. Tasks include setting up
business units, setting up legal addresses,
creating job titles, configuring staff access,
and so on.

Public Users Define Public Users Configure how public users will interact with
the implementation of your service. Tasks
include defining terms of use, selecting public
user options, assigning roles to define public
user access, and so on.

Analytics and Reporting Define Reporting for Public Sector Add or modify parameters associated with
delivered reports to filter data per your
requirements.

GIS Define GIS Configure the integration between your
service and the GIS application. Tasks
include managing map profiles and mapping
GIS attributes.

System Administration Define Attachments for Public Sector Define categories and subcategories for files,
such as plans and images that are attached
to pages as part of the permit application
process.

Define Comments for Public Sector Configure the comments feature that will
be used throughout the permit application
process. Tasks include setting up comment
categories, adding and modifying standard
comments, and so on.

Define Communication for Public Sector Delivered communication events are
triggered by transactions and processes
within the application. For example,
scheduling an inspection triggers the
"Inspection Scheduled" communication
event. You can define the content and
recipients of the communication events using
communication templates.

System Administration Define Lookup Values for Public Sector Add and change values that appear in lookup
lists. Lookup lists are referenced by various
fields in the application and display a static
set of values from which the end user can
select a value when entering information.

Define Conditions for Public Sector Add, modify, or remove a dependency
or contingency for completing the permit
process. Conditions are defined with a
severities that can affect the permit process
when applied.
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Functional Area

Branding

Task List

Define and Assign Themes

Description

Create custom branding themes for your
agency to reflect your desired look and feel.
Tasks include adding logo images, modifying
header and footer colors, designing your
welcome banner, and so on. Once a
branding them is created, you then assign it
to apply its attributes.

Define Tiles

Tiles are the icons that appear on the Agency
Springboard and public landing pages. Users
click tiles to access selected pages and
transactions. You can configure which tiles
appear, hide tiles, modify tile labels, and so
on

Define Summary Details

Define the summary section that appears

on the public landing pages. The summary
section includes a summary title, summary
text, and a Read More button that links either
to a more detailed message that you define
or to an external URL.

Define Alerts

Add, modify, and enable alert messages that
will appear on the Agency Springboard and
public landing pages to notify users of timely
information.

Planning and Zoning Application Types

Define Planning and Zoning Application

Types

Define application groups, categories,
subcategories, record statuses, fee
schedules, document categories, and
planning and zoning application types for
agency.

Public Hearing

Define Public Hearings

Define public hearing calendars and
escalation path for agency.

Digital Assistant

Set up and configure Digital Assistant

Create and configure digital assistants and
their parameters to suit your agency.

#" Note: In addition to the above, there are optional task lists and tasks available under the functional areas in

FSM.

Migrating Data From Your Test Environment to Your
Production Environment

This topic describes the utilities used to migrate setup data from your test environment to your production environment.

In your pod you have these environments:
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Environment Description

Test The test environment is where you learn about the product, enter your setup and configuration data,
and test your changes. For example, this is where you add the data for setting up your agency,
create your permits, specify branding modifications for your site, and so on.

Production The production environment is the environment your agency employees and your end users access
to complete transactions. The production environment reflects the “finished product” of what was
configured and tested in the test environment.

After you have made changes and tested them in the test environment, you then migrate any changed metadata and setup

data from your test environment to your production environment. You use the Functional Setup Manager export and import
utilities to complete these tasks.

For more information on the Functional Setup Manager export and import utilities, see Using Functional Setup Manager:
“Exporting and Importing Setup Data”.

For more information on managing transaction type data, see:
e Managing Transaction Type Configurations.

e Oracle Public Sector Community Development: Test to Production (Doc ID 2551940.1) on My Oracle Support.

ORrRACLE


http://www.oracle.com/pls/topic/lookup?ctx=en/cloud/saas/applications-common/19a&id=OAFSM1166430
http://www.oracle.com/pls/topic/lookup?ctx=en/cloud/saas/applications-common/19a&id=OAFSM1166430
http://www.oracle.com/pls/topic/lookup?ctx=pscr19c&id=task_ManagingTransactionTypeConfigurations

Oracle Public Sector Compliance and Regulation Cloud Chapter 1
Implementing Your Agency Implementing Compliance and Regulation Using Functional
Setup Manager

ORACLE



Oracle Public Sector Compliance and Regulation Cloud
Implementing Your Agency

Chapter 2
Setting Up Your Agency

2 Setting Up Your Agency

Setting Up Agencies

An agency is an organization that offers a range of services to its constituents, including issuing permits and licenses.

Administrators add and modify agency information using the Agency page.

Set up exactly one agency, with agency ID 1. Oracle does not currently support multiple agencies.

Adding an Agency

1. Select Common Setup > Agency .

2. On the Agency Information tab, click Add.
3. On the Agency Information - Details page, enter values for the following fields:

Page Elements Definition

Agency ID

Enter the number 1 as the ID for your agency.

Name and Description

Enter a name and a short description for the agency.

Country

Enter the country in which the agency is located.

This value is informational only. Address fields throughout the system support only USA
addresses.

Currency

Enter the currency that the agency uses for financial transactions.

This value is informational only. It does not affect the currencies for fees, cash drawers, or
payment adaptors.

Time Zone

Select your agency’s local time zone. All times displayed in Oracle Public Sector Compliance
and Regulation use this time zone.

Parcel Owner Format

This field is reserved for future functionality. Currently, regardless of your selection, parcels
have one field to identify the parcel owner and an additional field to identify a secondary
owner.

Time Format, Date Format, and
Number Format

Select the default formats that the agency uses to display times, dates, and numbers for
anonymous USers.

Hide property owners from public
users

Turn on this switch to hide property owner information from public users.

# Note:
This check box is reserved for future use and has not yet been implemented.
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Page Elements Definition

Property Information Access Select the level of access that agency staff have to property information on applications and
permits. Options are:

o Read Only: Agency staff can only view property information.

o Edit: Agency staff can view and edit property information, but they cannot add new
property information.

o Add New: Agency staff can view, edit, and add new property information.

Oracle Policy Automation ID Enter the unique identifier for an agency-wide Oracle Policy Automation (OPA) policy model.

OPA is a separate Oracle product. OPA policy models provide logic models for
questionnaires that help public users determine which applications they need to complete.

The policy model that you enter here is used by offerings that do not have an offering-
specific policy model. To specify an offering-level policy definition, select the Features tab on
the Agency Information page, then click the Options link for the offering.

For more information on Oracle Policy Automation, see Overview of Oracle Policy
Automation Configuration.

4. Click Save.

Modifying an Agency

poODN =

Select Common Setup > Agency .

Click a row on the Agency Information tab.
Update the agency information field values.
Click Save.

Adding an Agency Address

poODN =

Select Common Setup > Agency .

Click a row on the Agency Information page.

Select the Addresses tab, and click Add.

On the Addresses - Details page, enter values for the following fields:

Page Elements Definition

Address ID Enter a unique ID for the address.

Primary Select to indicate that this is the primary address for the agency. An agency may have only
one primary address.

From Date and To Date Enter the date range for which the address is valid.

Zip Code If you know the zip code for the address, enter it here. The system automatically populates
the City and State based on the zip code you enter.

If you don’t know the zip code, click the don’t know link to narrow down your choice of zip
codes by entering a city and state.
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Page Elements Definition

Address Line 1 and Address Line Enter the street number or post office box number, along with any additional address

2 information such as apartment or suite number.
City and State Enter the city and state for the address.
Postal Code Enter the postal code for the address. The available values for this field are filtered based on

the city and state that you select.

5. Click Save.

Modifying an Agency Address

Select Common Setup > Agency .

Click a row on the Agency Information tab.
Select the Addresses tab.

Click a row on the Addresses tab. You can:

poODN =

o Update the agency address field values.

" Note: You cannot change a primary address row to non-primary. Instead, when you update a non-
primary row to primary, all other address rows are saved as non-primary.

o Delete the address. You will be prompted to confirm the permanent deletion.

#" Note: You cannot delete primary address rows.

5. Click Save.

Deleting an Agency Address

Select Common Setup > Agency .

Click a row on the Agency Information tab.

Select the Address tab.

Click Edit.

Select the check boxes next to all the agency addresses that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

o0 kroNd

# Note: You cannot delete primary address rows. To delete an address row that is designated as primary, you
must first designate a different address row as primary. This changes the previously primary row to non-primary,
allowing it to be deleted.

Adding an Agency Language

Agency languages are reserved for future functionality. At this time, you do not need to add languages to your agency.
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Modifying Permit Options

Select Common Setup > Agency .
Click a row on the Agency Information tab.
3. Select the Features tab.

Oracle provides seed data for the list of offerings on the Features tab. At this time, the only available offering is
Permits, which also encompasses Planning and Zoning functionality.
Disregard the Enabled column in the list of offerings. The offering is enabled in the Functional Setup Manager (FSM).
4. Click Options for the Permits offering.
5. On the Permit Options page, you can update values for the following fields:

Page Elements Definition

Oracle Policy Automation ID Enter the unique identifier for the Oracle Policy Automation policy model to be used for this
offering.

N =

The offering-specific policy model that you specify here takes priority over any agency-wide
policy definition that you enter on the main Agency Information page.

Message Title Enter a short text version of the landing page message in a title format. If you leave this
field blank, the value in the Label field on the Link Details page for the menu navigation link
Online Permits is displayed.

Message Summary Enter a longer version of the landing page message title in a sentence format. If you leave
this field blank, the value in the Description field on the Link Details page for the menu
navigation link Online Permits is displayed.

Button Content URL Enter a content URL for the Read More button. Public users click this button to access the
agency’s own permit information page, outside of Oracle Public Sector Permits. If you leave
this field blank, the Read More button opens a dialog box that displays the Landing Page
Message.

# Note:
If you want to link to a page outside of Oracle Public Sector Permits, you must enter
a URL here.

Landing Page Message Enter a welcome message in rich text to appear in a dialog box on the landing page, if a
URL to access the agency’s page is nhot defined.

For more information on Oracle Policy Automation, see Overview of Oracle Policy Automation Configuration.
For more information on the Landing Page Message Definition, see Defining Summary Details.

Setting Up Countries

A country definition includes the country name and various identifying codes.

10
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You add, maodify, and delete countries on the Country page.

Adding a Country

1. Select Common Setup > Country .
2. On the Country page, click Add.
3. On the Country Details page, enter values for the following fields:

Page Element Description

Country Code Enter a the unique code that your system uses for the country. For example, you might enter
FRA for France.

ISO Alpha 2 Code Enter the two-letter International Organization of Standardization (ISO) code for the country.
For example, you would enter FR as the code for France.

ISO Numeric 3 Code Enter the three-digit United Nations (UN) M.49 code for the country. For example, you would
enter 250 as the code for France.

Country Name Enter the name of the country as it appears in your system.

4. Click Save.

Modifying a Country

1. Select Common Setup > Country .
2. Click a row on the Country page.
3. On the Country Details page you can:

o Update the country field values.

" Note: You cannot edit the Country Code.

o Delete the country. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Countries

Select Common Setup > Country .

Click Edit.

Select the check boxes next to all the countries you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

pPODN

Setting Up States

A state definition includes information such as the state name, country, and various ID codes.

11
ORrRACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 2
Implementing Your Agency Setting Up Your Agency

You add, modify, and delete states on the State page.

Adding a State

1. Select Common Setup > State .
2. On the State page, click Add.
3. On the State Details page, enter values for the following fields:

Page Element Description

Country Enter the code for the country that the state is in.

State Code ISO Enter the International Organization of Standardization (ISO) code for the state.

Code Enter the unique code that your system uses for the state.

State Name Enter the name of the state.

Type Enter the subdivision type.

GNIS ID Enter the Geographic Names Information System (GNIS) ID for the state’s location.
4. Click Save.

Modifying a State

1. Select Common Setup > State .
2. Click arow on the State page.
3. On the State Details page you can:

o Update the state field values.

#" Note: You cannot edit the Country or State Code ISO fields.

o Delete the state. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting States

Select Common Setup > State .

Click Edit.

Select the check boxes next to all the states you want to delete.

Click Delete. You will be prompted to confirm the permanent deletion.

poODN =
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Setting Up Cities

A city definition includes information such as the city name, country, state, and certain ID codes.

You add, modify, and delete cities on the City page.

Adding a City

1. Select Common Setup > City .
2. On the City page, click Add.
3. On the City Details page, enter values for the following fields:

Page Element Description

Country Code and State Code Enter the codes for the country and state in which the city is located.

County Enter the five-digit International Committee for Information Technology Standards (INCITS)
code for the county in which the city is located.

FIPS Code Enter the seven-digit Federal Information Processing Standard (FIPS) code for the city.
City Name Enter the name of the city.
GNIS ID Enter the Geographic Names Information System (GNIS) ID for the city’s location.

4. Click Save.

Modifying a City

1. Select Common Setup > City .
2. Click a row on the City page.
3. On the City Details page you can:

o Update the city field values.

#" Note: You cannot edit the Country Code, State Code, or County fields.

o Delete the city. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Cities

Select Common Setup > City .

Click Edit.

Select the check boxes next to all the cities you want to delete.

Click Delete. You will be prompted to confirm the permanent deletion.

pPONS
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Setting Up Counties

A county definition includes information such as the county name, country, state, and certain ID codes.

You add, maodify, and delete counties on the County page.

Adding a County

1. Select Common Setup > County .
2. On the County page, click Add.
3. On the County Details page, enter values for the following fields:

Page Element Description

Country and State Enter the codes for the country and state that the county is in.

INCITS Code Enter the five-digit International Committee for Information Technology Standards (INCITS)
code for the county.

County Name Enter the name of the county.
FIPS Code Enter the seven-digit Federal Information Processing Standard (FIPS) code for the county.
GNIS ID Enter the Geographic Names Information System (GNIS) ID for the county’s location.

4. Click Save.

Modifying a County

1. Select Common Setup > County .
2. Click a row on the County page.
3. On the County Details page you can:

o Update the county field values.

#" Note: You cannot edit the Country, State, or INCITS Code fields.

o Delete the county. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Counties

Select Common Setup > County .

Click Edit.

Select the check boxes next to all the counties you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

pPONS
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Setting Up Currencies

A currency definition includes currency codes, a description, and the number of decimals that can be used to represent an
amount in the currency.

You add, modify, and delete currencies on the Currency page.

Adding a Currency

1. Select Common Setup > Currency .
2. On the Currency page, click Add.
3. On the Currency Details page, enter values for the following fields:

Page Element Description

Currency Code Enter a the unique code that your system uses for the currency.

ISO Code Enter the three-digit International Organization of Standardization (ISO) 4217 numeric code
for the currency. For example, you would enter 840 for the US dollar.

Description Enter a short description of the currency.

Decimal Position Enter the number of decimal places that can be used to represent an amount for the
currency. For example, the United States dollar uses two decimal positions.

4. Click Save.

Modifying a Currency

1. Select Common Setup > Currency .
2. Click a row on the Currency page.
3. On the Currency Details page you can:

o Update the currency field values.

#" Note: You cannot edit the Currency Code field.

o Delete the currency. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Currencies

Select Common Setup > Currency .

Click Edit.

Select the check boxes next to all the currencies you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PN
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Setting Up Holiday Calendars

Holiday calendars establish the days that agency offices are closed and no field service operations are offered.

These days appear as unavailable, non-working days in calendar views throughout the system such as for public user
and inspector calendars. Non-working days in holiday calendars apply to all employees and do not need to be defined for
employee profiles.

Each holiday calendar spans a date range that you define. Within that date range, you define individual events for each non-
working holiday.

Administrators add, modify, and delete holiday schedules and events on the Holiday Calendar page.

Adding a Holiday Calendar

1. Select Common Setup > Holiday Calendar .
2. On the Holiday Calendar page, click Add.
3. On the Holiday Calendar Details page, enter values for the following fields:

Page Element Description

Calendar ID and Description Enter a unique ID and description for the calendar. For example, you might enter an ID of
2019 and a description of Holiday Calendar 2019.

Valid from Date and Valid to Date Enter the date range for the holiday calendar. For example, you might enter a Valid from
Date of 2019-01-01 and a Valid to Date of 2019-12-31 to represent a calendar that
spans the entire 2019 calendar year.

4. Add an event.

#" Note: You must have values defined for all required holiday calendar fields before you can add an event.

5. Click Save.

" Note: When you click Save, the Holiday Calendar page closes.

Adding an Event

Select Common Setup > Holiday Calendar .
Click a row on the Holiday Calendar page.
On the Holiday Schedule Details page, click Add.

On the Event Details page, enter an Event ID, an Event Date, and a Description for the event. For example, you
might enter an ID of MD, a date of May 29, 2017, and a description of Memorial Day.

5. Click Save.

pPODdN
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Modifying a Holiday Calendar

1. Select Common Setup > Holiday Calendar .
2. Click a row on the Holiday Calendar page.
3. On the Holiday Calendar Details page you can:

o Update the holiday schedule field values.

# Note: You cannot edit the Calendar ID.

o Delete the holiday calendar. You will be prompted to confirm the permanent deletion.
o Add, modify, or delete events.
4. Click Save.

#" Note: When you click Save, the Holiday Calendar page closes.

Modifying an Event

1. Click a row on the Holiday Calendar Details page.
2. On the Event Details page you can:

o Update the event date or description.

o Delete the event. You will be prompted to confirm the permanent deletion.
3. Click Save.

Deleting Holiday Calendars

Select Common Setup > Holiday Calendar .

Click Edit.

Select the check boxes next to all the holiday schedules you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

pPON=

Deleting Events

1. Click Edit on the Holiday Calendar Details page.
2. Select the check boxes next to all the events you want to delete.
3. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Work Schedules

Work schedules establish the days of the week and daily hours of operation for agency employees.

Create schedules based on the type of employee and work location. Calendar views, such as inspector calendars, reference
work schedules to determine the time slots that are displayed on the calendar as available for scheduling. Algorithms for

17
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assigning resources also use work schedules to determine availability. You assign work schedules to employee profiles using
the Agency Staff page. See Setting Up Agency Staff.

Administrators and business analysts add, modify, and delete work schedules on the Work Schedule page.

Adding a Work Schedule

1. Select Common > Work Schedule .
2. On the Work Schedule page, click Add.
3. On the Work Schedule Details page, enter values for the following fields:

Page Element Description

Schedule ID and Description Enter a unique ID and description for the schedule. For example, you might enter an ID of
OFFICESAT and a description of Saturday Office Schedule.

Start Date Enter the first day of the schedule.

End Date Enter the last date of the schedule. You can leave this field blank to give the schedule an
open end date.

Work Start Time and Work End Enter the start and end time for the schedule. For example, you might enter a work start time
Time of 09:00 AM and a work end time of 05:00 PM.
Break Start Time and Break End Enter the start and end time for a break within the schedule. For example, you might enter a
Time break start time of 12:00 PM and a break end time of 01:00 PM.
g
# Note:

These fields are optional, but if you enter a break start time, you must also enter a
break end time.

Recurrence and Weeks Between Select whether the schedule reoccurs weekly and how many weeks are between each
Occurrences occurrence. For example, if you select a recurrence of Weekly with 1 week between
occurrences, the schedule repeats every week.

Work Days Select the days of the weeks to which the schedule applies.

4. Click Save.

" Note: For overnight work shifts that go past 12 am (midnight), you must create two schedules: one for the time
period up until midnight, and one for the time period after midnight. For example, to create a weekday overnight
shift that starts at 09:00 pm and ends at 06:00 am the following day, the first schedule would have a start time
of 09:00 pm and an end time of 12:00 am on Monday through Friday. The second schedule would have a start
time of 12:00 am and an end time of 06:00 am on Tuesday through Saturday.

Modifying a Work Schedule

1. Select Common > Work Schedule .
2. Click a row on the Work Schedule page.
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3. On the Work Schedule Details page you can:
o Update the work schedule field values.

# Note: You cannot edit the Schedule ID field.

o Delete the schedule. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Work Schedules

Select Common > Work Schedule .

Click Edit.

Select the check boxes next to all the work schedules you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

pPODA

Setting Up Ownership Types

Ownership type indicates how a business was established; for example, a corporation or a nonprofit. You set up ownership
types for your agency on the Ownership Type page.

Adding an Ownership Type

Select Common Setup > Ownership Type .

On the Ownership Type page, click Add New to add an ownership type.

On the Ownership Type Details page, enter a name for the ownership type.

Enter a description.

Verify that the Enabled switch is turned on. The switch is turned on by default for a new ownership type.
Click Save.

RN

Modifying an Ownership Type

1. Select Common Setup > Ownership Type €.
2. On the Ownership Type page, click the row for the ownership type that you want to modify.
3. On the Ownership Type Details page you can:

o Modify the ownership type description. You cannot change the name.

o Click the Enabled switch to enable or disable the ownership type.

4. If you made any changes, click Save.

Deleting an Ownership Type

Select Common Setup > Ownership Type €.

On the Ownership Type page, click the row for the ownership type that you want to delete.

On the Ownership Type Details page, click Delete.

If you want to delete multiple ownership types, you can delete them from the Ownership Type page:
a. Click Edit.

pODS
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b. Select the check boxes for the ownership type rows to delete.
c. Click the Delete icon.

Setting Up Property Types

Property type categorize properties according to criteria such as how the property is used or the type of dwelling.

You add, modify, and delete property types on the Property Type page.

Adding a Property Type

1. Select Common Setup > Property Type.
2. On the Property Type page, click Add.
3. On the Property Type Detail page, enter values for the following fields:

Page Element Description

Property Type Enter the type of property, such as Residential or Commercial.

Description Enter a property type description.

4. Verify that the Enabled switch is turned on.
The switch is on by default for a new property type.
5. Click Save.

Modifying a Property Type

1. Select Common Setup > Property Type.
2. Click a row on the Property Type page.
3. On the Property Type Detail page you can:
o Update the property type description.
o Turn off the Enabled switch to deactivate the property type.

4. Click Save.

Deleting Property Types

1. Select Common Setup > Property Type.
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Property Type

Details page.
3. To delete one or more definitions without viewing details:
a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.
You will be prompted to confirm the permanent deletion.
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Setting Up Property Conditions

A property condition identifies the general condition of the property. This value is used to indicate the general age of a
property, a property’s physical condition, or other condition.

You add, modify, and delete property conditions on the Property Condition page.

Adding a Property Condition

1. Select Common Setup > Property Condition.
2. On the Property Condition page, click Add.
3. On the Property Condition Detail page, enter values for the following fields:

Page Element Description

Property Condition Enter the property condition, such as Poor or Good.

Description Enter a description of the property condition.

4. Verify that the Enabled switch is turned on.

The switch is on by default for a new property condition.
5. Click Save.

Modifying a Property Condition

1. Select Common Setup > Property Condition.
2. Click a row on the Property Condition page.
3. On the Property Condition Detail page you can:

o Update the property condition description.

o Turn off the Enabled switch to deactivate the property type.
4. Click Save.

Deleting Property Conditions

1. Select Common Setup > Property Condition.

2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Property
Condition Details page.

3. To delete one or more definitions without viewing details:

a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.
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Setting Up Units of Measure

Units of measure are used to express measurements such as quantity or duration. Each unit of measure must have a unit
type such as Length, Area, or Time.

You add, maodify, and delete units of measure on the Unit of Measure page.

Adding a Unit of Measure

1. Select Common Setup > UOM.
2. On the Unit of Measure page, click Add.
3. On the Unit of Measure Details page, enter values for the following fields:

Page Element Description

Unit of Measure Enter a unique unit of measure ID.

Description Enter a description of the unit of measure.

Unit Type Select the type of measurement. The delivered unit types are Area, Length, Time, and
Volume.

You can define additional values on the Lookup Type Details page. Add new values to the
ORA_PSC_CC_UOM_TYPE lookup type.

ISO Code Enter the ISO unit of measure code.

4. Click Save.

Modifying a Unit of Measure

1. Select Common Setup > UOM.

2. Click a row on the Unit of Measure page.

3. On the Unit of Measure Details page, make the necessary modifications.
4. Click Save.

Deleting Units of Measure

1. Select Common Setup > UOM.
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Unit of
Measure Details page.
3. To delete one or more definitions without viewing details:
a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.
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Setting Up Unit of Measure Conversions

A unit of measure (UOM) conversion definition specifies the factor for converting a unit of measure to an equivalent amount of
a different unit of measure.

You add, modify, and delete unit of measure conversions on the UOM Conversion page.

Adding a UOM Conversion

1. Select Common Setup > UOM Conversion.
2. On the UOM Conversion page, click Add.
3. On the UOM Conversion Detail page, enter values for the following fields:

Page Element Description

UoM Select the unit of measure that is the starting unit for the conversion.

UOM To Enter the target unit of measure. This unit of measure must be the same type as the original
unit of measure. For example, you can convert a unit of length to another unit of length, but
you can’t convert a unit of length to a unit of weight.

Conversion Rate Enter the conversion factor used to convert the original unit of measure to the target unit of
measure. For example, to convert minutes to hours, enter a conversion rate of 60.

4. Verify that the Enabled switch is turned on.

The switch is on by default for a new UOM conversion.
5. Click Save.

Modifying a UOM Conversion

1. Select Common Setup > UOM Conversion.
2. Click a row on the UOM Conversion page.
3. On the UOM Conversion Detail page you can:

o Update the UOM conversion field values.
o Disable the UOM conversion by turning the Enabled switch off.
4. Click Save.

Deleting UOM Conversions

1. Select Common Setup > UOM Conversion.
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Unit of
Measure Conversion Details page.
3. To delete one or more definitions without viewing details:
a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
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c. Click Delete.
You will be prompted to confirm the permanent deletion.

Setting Up Conditions

A condition indicates a dependency or contingency for completing the application process. You set up conditions on the
Conditions page.

You add, maodify, and delete conditions on the Conditions page.

Condition Overview

A condition indicates a status, criterion, or action that can apply to an object in the system, such as a permit or a planning
application.

Conditions are defined with a severity that might affect operations when applied. Condition rules with a Hold severity prevent
one or more of the operations that are selected at the time of applying the condition. Condition rules with a Lock severity
prevent all operations as described in the table here.

Rule Applicable Objects Usage

Prevent New Parcel Agency staff applies a condition to a parcel
record that prevents an applicant from
submitting any new permit or planning
application that contains a parcel object.

Prevent Workflow Advancing Permit and planning application Agency staff applies a condition to a permit
or planning application record that prevents
workflow from advancing. The permit or
planning application workflow tasks cannot
be completed until the condition is resolved.

Prevent Issue or Final Permit and planning application Agency staff applies a condition to a
permit or a planning application record that
prevents the permit or application cycle from
completing its final step until the condition is
resolved.

Your workflow process definition must
explicitly identify the final human task
that is blocked by this condition. Use the
PSC_FINAL_ACTIVITY custom property
to identify this task. See Using Custom
Properties.

Restrict Payment Permit and planning application Agency staff applies a condition to a permit
or a planning application record that prevents
a user from processing a payment.

Prevent Inspection Schedule Permit This condition rule prevents agency staff from
scheduling a new inspection. It does not
affect existing inspections that have already
been scheduled.
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Rule Applicable Objects Usage
Prevent Inspection Result Permit This condition rule prevents agency staff from

finalizing the inspection results.

Adding Conditions

1. Select Common Setup > Condition .
2. On the Condition page, click the Add New button.
3. On the Condition Details page, enter values for the following fields:

Page Element Description

Condition Name Enter a unique condition name.
Object Type Select an object type to categorize the condition, based on the object type to which it is
applied:
o Parcel

o Transaction (includes permit and planning applications)

Display Message Enter a message that will be displayed to external users, up to 150 characters.
Severity Select a severity level for each condition from these options:
o Lock

At the most severe level, the Lock condition suspends all operations, including
workflow advancing, payment processing, inspection scheduling, and inspection
results.

o Hold

Agency staff can select which rules to apply to conditions with the Hold level of
severity.

o Notice

The Notice level functions as an alert and has no effect on operations.
For more information, see Applying Conditions to Applications.

Description Enter a description.

Inherit Select to enable the condition to be applied automatically to any existing transactions
belonging to the parcel. This field appears only if you have selected the Parcel object type.

4. Verify that the Enabled switch is turned on. New conditions are active by default.
5. Click Save.

Modifying Conditions

1. Select Common Setup > Condition .
2. Click a row on the Condition page.
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3. On the Condition Details page you can update the display message, severity, description, and the Enable switch.
4. Click Save.
Deleting Conditions

1. Select Common > Condition
2. Click a row on the Condition page.
3. On the Condition Details page, click Delete to delete the condition.

" Note: You can delete a condition only if it is not applied to any object such as a parcel, permit, or a planning
application. If you try to delete a condition that is applied to a permit, you will see an error message stating that
you cannot remove the condition because it has already been applied.

For more information, see the documentation Applying Conditions to Applications.

Setting Up Autonumbering

Set up autonumber rules to increment identifying numbers for documents such as permits and invoices. The identifying
numbers can include multiple parts, and each part can represent either a sequential number, static text, or a date.

You add, modify, and delete autonumber rules on the Autonumber page.

This example illustrates the Autonumber Details page.
Autonumber Details

Rule Header

*
Rule Name

* Description

Sample Copy Existing Rule

Sample

* Maximum Size 17 v A
* Number Type Permit v
Reset Sequential Number Yearly v

Rule Definition

Number of Parts 3 v

Part 1 Static text v PER

1000000

Part 2 Sequential ¥

Part3 Date ¥ MMMYY

ORACLE

Next Number Preview PER-1000000-JUL18

Separator - v

Zero-

Maximum Length 7 b padding

Separator -

Cancel Save
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Adding an Autonumber Rule

1. Select Common Setup > Autonumber.
2. On the Autonumber page, click Add.
3. On the Autonumber Details page, enter values for the fields in the Rule Header section:

Page Element Description

Rule Name Enter a unique name for the rule.

Copy Existing Rule Click this link to copy the rule definition from an existing autonumber rule. The copy action
copies the number type and the reset frequency as well as the actual rule definition.

Clicking the link opens a a modal window with a list of existing autonumber definitions.
Locate the definition you want to copy, then click the Select button for that definition

Description Enter a description for the autonumber rule.
Maximum Size Indicate the maximum length of the generated number.
\J
# Note:

As you set up your autonumber rule, take care that the maximum size of the
autonumber accommodates the maximum length of each part of the identifier plus
any separators that you define.

Number Type Select the type of object to that can use this autonumber rule:

o Cashier session

# Note:
If you select this number type, make sure that the parts that you define for the rule
have a part type of Sequential only.

o Deposit slip

o Inspection

o Invoice

o Permit

o Planning application
o Project

o Receipt

These values are defined on the Lookup Type Details page for the
ORA_PSC_CC_AUTONUM_TYPE lookup type.

Reset Sequential Number The identifier that an autonumber rule generates can include a mix of static text, a date, and
a sequential number. Select how often the sequential number portion of the identifier is reset
to zero:

o None: Sequential numbers continue to increment as defined without resetting.
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Page Element Description
o Monthly: The sequential number portion of the identifier resets to zero at the beginning
of each month.
o Yearly: The sequential number portion of the identifier resets to zero at the beginning
of each year.

4. In the Rule Definition section of the page, enter the number of parts, or segments, for the rule:

Page Element Description

Number of Parts Select the number of parts, or segments, comprising the rule, up to 5 parts. Segments can
be static text, a date, or a sequential number.

For example, the identifier IVvC-0000010067-0CT10 is made of 3 segments (static text,
then a sequential number, then a date) separated by hyphens. The identifier INVOICE 001
is made of 2 segments (static text and a sequential number) separated by an underscore.

When you select the number of parts, the corresponding number of rows appear in the rule
definition grid. For example, if there are two parts, then rows labeled Part 1 and Part 2
appear.

5. In the rule definition grid, select the part type for each row, then enter the related information in the additional fields
that appear.

Part Type Related Information

Static Text In the unlabeled field that appears next to the part type, enter text that remains the same for
all identifiers. For example, enter IVC or INVOICE.

# Note:
Do not include spaces in the static text.

Cashier session IDs must be numeric, so don't include any static text in an autonumber
definition with the Cashier Session number type.

Sequential a. Inthe unlabeled field that appears next to the part type, enter the next document
number to use. The number must be 1 or greater. The system increases this number
by one each time a new identifier is generated and saved.

b. Inthe Maximum Length field, Enter the maximum number of digits for the sequential
number. Select a number from one to ten.

c. Select the Zero Padding check box to add zeros before the generated number to
make up the number of digits in the definition. For example, if the maximum length of
this part is 5 digits, and the current number is 15, zero padding formats this part as
00015.

Date In the unlabeled field that appears next to the part type, select the date format.

The available date formats are made of these date codes in various combination:

o Years: YYYY represents the year with its full four digits, and YY represents the year by
its last two digits.

o Months: MM represents the month as a two-digit number, and MMM represents the
month as a three-character abbreviation such as JAN for January.

o Days: DD represents days as two-digit numbers. This is the only option for days.

o Quarters: Q represents quarters. For example, the code for the first quarter of the year
is1.
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Part Type Related Information

Cashier session IDs must be numeric, so don't include any dates in an autonumber
definition with the Cashier Session number type.

6. Inthe rule grid, select a Separator to appear after each part except the last.
Select from the following separators:

o (None)

o - (hyphen)

o / (forward slash)
o *(asterisk)

7. Verify the generated number for the selected date format and separators in the Next Number Preview field.
8. Click Save.

An error appears if the overall maximum size of the autonumber doesn’t accommodate the maximum lengths of all of
the parts and separators that you define.

Modifying an Autonumber Rule

Select Common Setup > Autonumber.

On the Autonumber page, click the row you want to modify.

Update the rule header and rule definition fields on the Autonumber Details page.
Click Save.

poODNd =

Deleting an Autonumber Rule

1. Select Common Setup > Autonumber.
2. Click the row you want to modify.
3. On the Autonumber Details page, click Delete.

Setting Up Contact Types

A contact type describes the role or position of a contact person for a permit.

Contact types apply only to permit contacts, not to profile contacts. Permits have contacts if the Contact List element is
included in the permit application.

You add, maodify, and delete contact types on the Contact Type page.

Adding a Contact Type

1. Select Common Setup > Contact Type.
2. On the Contact Type page, click Add.
3. On the Contact Type Detail page, enter values for the following fields:
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Page Element Description
Contact Type Enter the type of contact, such as Business Owner, Individual, or Emergency Contact.
Description Enter a description of the contact type.

4. Verify that the Enabled switch is turned on.

The switch is on by default for a new contact type.
5. Click Save.

Modifying a Contact Type

1. Select Common Setup > Contact Type.

2. Click a row on the Contact Type page.

3. On the Contact Type Detail page you can:
o Update the contact type description. Only the Description field can be changed.
o Turn off the Enabled switch to deactivate the contact type.

4. Click Save.

Deleting Contact Types

1. Select Common Setup > Contact Type.

2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Contact Type
Details page.

3. To delete one or more definitions without viewing details:

a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.

Setting Up Project Types

A project type describes the kind of project that an agency staff can select at the time of creating a project. You add new
project types based on the nature of the project you are adding. Selection of a project type is mandatory while creating a new
project, so, a minimum of one project type is required to be set up.

You add, modify, and delete project types on the Project Type page.

Adding a Project Type

1. Select Common Setup > Project Type .
2. On the Project Type page, click Add.
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3. On the Project Type Detail page, enter values for the following fields:

Page Element Description

Project Type Enter the type of project, such as Commercial Project or Residential Project.

Rule ID Select a rule ID. Rule ID is an autonumbering sequence that you set up for a particular
project type. When you are creating a project with a certain project type, a project ID is
generated based on the sequence defined for the project type.

Rule IDs are created using the Autonumber page. For more information, see Setting Up

Autonumbering.
Description Enter a description of the project type.
Long Description Enter a detailed description of the project type.
Document Group Select a document group to allow your users to organize the various categories of

attachment files into a grouping.

See Setting Up Document Categories and Subcategories and Setting Up Document
Groups.

4. Verify that the Enabled switch is turned on. The switch is turned On by default for a new project type.
5. Click Save.

Modifying a Project Type

1. Select Common Setup > Project Type
2. Click a row on the Project Type page.
3. On the Project Type Detail page you can:

o Update the rule ID, description, and long description.
o Turn off the Enabled switch to deactivate the project type.
4. Click Save.

Deleting a Project Type

1. Select Common Setup > Project Type

2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Project Type
Details page.

3. To delete one or more definitions without viewing details:

a. Click Edit on the Project Type page.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete. You will be prompted to confirm the permanent deletion.

#" Note: You can delete a project type only if it is not used by any project. When you attempt to delete a project
type that is used by a project, the Public Sector Cloud Service displays a message that you cannot delete the
project type as it is already in use by a project.
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Setting Up Code Types

Code types are specific published codes, guidelines, ordinances, and so forth. Examples might include the International
Building Code, published by the International Code Council (ICC), and the National Fire Code, published by the National Fire
Protection Association (NFPA).

You add, modify, and delete code types on the Code Type page.

Adding a Code Type

1. Select Common Setup > Code Type.
2. On the Code Type page, click Add.
3. On the Code Type Detail page, enter values for the following fields:

Page Element Description

Code Type ID Enter a unique code type ID for a specific code type. For example, enter IFC for International
Fire Code.
Name Enter the complete name of the code type.
Description Enter a description of the code type.
4. Click Save.

Modifying a Code Type

1. Select Common Setup > Code Type.

2. Click arow on the Code Type page.

3. On the Code Type Detail page you can update the code name and description.
4. Click Save.

Deleting Code Types

1. Select Common Setup > Code Type.

2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Code Type
Details page.
3. To delete one or more definitions without viewing details:

a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.
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Setting Up Code References

Code references provide detailed specifications that come from a broad range of codes, guidelines, ordinances, and so forth.
Even if the source document does not use the word “code,” use the Code References pages to enter the information into the

system. A code reference maps to a specific section in the source document.
You add, modify, and delete code references on the Code Reference page.

This example illustrates the Code Reference Details page.

Code Reference Details

* Standard Type  Electrical v
* Standard Name  General

* Code Section  2702.1.4

* Effective Start Date  7/25/18 —
Effective End Date  Open i
* Code Type  IBC o,

* Description  Load Duration

o

URL  https://codes.iccsafe.org/public/docum
Content 10 access instructions, place the cursor in the text editor and press Alt + 0.

Font ~ | Size ~B I U /& A-B|Z 1= «

Emergency power systems shall automatically provide secondary power within 10 seconds
after primary power is lost, unless specified otherwise in this code. Standby power systems
shall automatically provide secondary power within 60 seconds after primary power is lost,
unless specified otherwise in this code

-

Cancel Save

Prerequisites

Before you set up code references, you must define:

e Code types, which represent specific published documents that contain codes, guidelines, and so forth.

See Setting Up Code Types.

e Standard types, which describe the different fields or disciplines that codes relate to. Examples might include fire
safety or electrical systems.

Set up standards types by defining values for the ORA_PSC_CC_STD_CODE_TYPE lookup type. Define these
values on the Lookup Type pages. See Setting Up Lookups.

ORACLE
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Adding a Code Reference

1. Select Common Setup > Code Reference.
2. On the Code Reference page, click Add.
3. On the Code Reference Detail page, enter values for the following fields:

Page Element Description

Standard Type Select the type of standard that the code falls under. Standard types represents fields or
disciplines such as Materials, Engineering, or Installation.

Standard Name Enter the title of the section that contains this code reference. This title comes from the
source document.

Code Section Enter the section number for this code reference. The number uniquely identifies this
reference within the source document.

Effective Start Date and Effective Enter the official effective start date of the code reference, and optionally enter an end date.
End Date

Code Type Select a code type from the values that you defined on the Code Type page. The code type
identifies the source document.

See Setting Up Code Types

Description Enter a description of the reference.

URL Enter a URL link to the source document.

Content Enter detailed content copied from the source document.
4. Click Save.

Modifying a Code Reference

Select Common Setup > Code Reference.

Click a row on the Code Reference page.

On the Code Reference Detail page, make any necessary changes.
Click Save.

pPODN =

Deleting a Code Reference

1. Select Common Setup > Code Reference.
2. Click a row on the Code Reference page.
3. On the Code Reference Detail page, click Delete.

You will be prompted to confirm the permanent deletion.
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Setting Up Public Users

Public user setup includes configuration options related to public user registration and account management.

This image illustrates the Public User Setup page.

Public User Setup

Terms of Use

v Require the user to accept the terms of use before registering

Terms of Use ID *

Oracle TNC o,

Contractor and License

v Agency staff verifies when a user's contractor status changes to yes

v Agency staff verifies when a user adds or updates a license

Attachments

v Allow agency staff and registered users to manage documents in account management

Allow registered users to delete documents in account management

Privacy Consideration

v/ Ask if the user wants to hide contact information from public view

Payment account
v Agency staff verifies when a user adds or updates a payment account

User Category

Enter a user category for appropriate notification content and URL redirection parameters for system access.

DEFAULT

To set up public users:

1. Select Common Setup > Public User Setup.
2. Inthe Terms of Use section of the page, configure these options:

ORrRACLE
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Page Element Description
Require the user to accept the Select this check box if public users must accept your terms of use as part of the
terms of use before registering registration process.
Terms of Use ID If you require public users to accept your terms of use during registration, select the terms of

use definition for the registration process.

This field is visible only if the Require the user to accept the terms of use before
registering check box is selected.

# Note:
If you change the Terms of Use ID, users who have already registered are required
to accept the new terms the next time they sign in. In this scenario, a window with
the new terms opens as soon as the public user signs in. The user must select the
agreement check box in order to continue.

3. In the Contractor and License section of the page, configure these options:

Page Element Description

Agency staff verifies when a Select this check box if agency staff must verify the contractor status of a public user who
user’s contractor status changes self-identifies as a contractor.

to yes

Agency staff verifies when a user Select this check box if agency staff must verify all licenses that are added to a user profile.
adds or updates a license Public users can add one license during the registration process. Public users and agency
staff can add additional licenses using account management functionality.

4. In the Attachments section of the page, configure these options:

Page Element Description

Allow agency staff and registered Select this check box to enable attachments in user accounts. When you enable
users to manage documents in attachments, both users and agency staff can add attachments to user accounts and
account management modify information about existing attachments.

Agency staff can also delete attachments, but public users can’t delete attachments unless
you also select the “Allow registered users to delete documents in account management”
check box on this page.

Allow registered users to Select this check box to allow public users to delete attachments that are associated with
delete documents in account their account. This setting does not affect agency staff, who can always delete account
management attachments.

This check box is visible only if you enable attachments by selecting the “Allow agency staff
and registered users to manage documents in account management” check box.

5. In the Privacy Consideration section of the page, configure these options:
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Page Element Description
Ask if the user wants to hide Select this check box to give public users the option to mask their name and contact
contact information from public information when a member of the public views the user’s applications.
view

If this check box is selected, the initial registration page gives users the opportunity to mask
their information. Help text explains that the public can still view the property address even if
the user’s information is masked.

After a user registers, either the user or agency staff can update this preference using
Account Management functionality.

6. Inthe Payment Account section of the page, configure this option:

Page Element Description

Agency staff verifies when a Select this check box if agency staff must verify all payment accounts (also called trust
user adds or updates a payment accounts) that are added to a user profile. Public users and agency staff can add payment
account accounts using account management functionality.

7. Inthe User Category section of the page, configure this option:

Page Element Description

Enter a user category for appropriate Enter the user category to be assigned to registered public users. Typically you should use

notification content and URL the delivered category DEFAULT.
redirection parameters for system
access The user category that you specify will be associated with user accounts that are created by

the public user registration process.

The category controls the templates for account-related notifications such as emails for first-
time registration and for resetting the account password. The category also controls URL
redirection so that when users set or reset their password in the Oracle Applications Cloud,
they are immediately transferred to the public sector system.

For more information about user categories, see Managing Users in Public Sector
Compliance and Regulation and Setting the Next URL for the Default User Category.

8. Click Save.

Setting Up Public User Roles
To ensure that registered public users have appropriate system access, you must define which role is assigned to the user
IDs that are created during the registration process.

When a public user registers, the Oracle system assigns a single role to the new user. Because the user is assigned just one
role, access to different areas of the system is established through a role hierarchy. In this hierarchy, the various roles that
provide access to different areas of the system are all children of a single parent role that you create.

Setting up public user roles involves these steps:

1. Use the Security Console to create a specific set of roles for public user:

W
~
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This step is explained in detail in the topic Creating Custom Roles for Public Sector Community Development. It
consists of these tasks:

a. Create custom roles that provide access to permit-related functionality.
b. Create the single role assigned during user registration, and set up its role hierarchy.

In the hierarchy, the child roles include the delivered PSC Registered Public User role as well as the additional
roles that you created for permit access.

#" Note: Do not use the delivered PSC Registered Public User as your single role for registered public
users. This role does not provide access to permit-related functionality.

2. Use the Public User Roles page to identify the role to be assigned during user registration.

|dentifying the Single Role to be Assigned During Public User Registration

To identify the single role to be assigned during public user registration:

1. Select Common Setup > Public User Roles.
If the Public User Roles page already lists a role, delete it before you add the new role.

The button for adding a role is hidden if a row already exists. You cannot modify the existing row, so you must
instead delete it and then add a new one.

To delete the existing row:

a. Click the row to access the Role Details page.
b. Click Delete.
On the Public User Roles page, click Add.
4. On the Role Details page, use the Role ID field to select the single role to be assigned during the public user
registration process.

®

The Role ID is the only enterable field on the Role Details page. To select a role based on the descriptive role name
rather than the numerical role ID, use the prompt button for the Role ID field, then expand the Search Criteria
section of the lookup page so you can search by role name.

" Note: If you correctly followed the instructions for creating the single role to be assigned to
registered public users, the role name is PSC Custom Registered Public User and the role code is
CUSTOM_PSC_REGISTERED_PUBLIC_USER.

5. Click Save.

Setting Up Terms of Use

The Terms of Use page stores rules and guidelines to which user must agree as a condition of using a service. The terms
act as a legal contract. They are also known as Terms and Conditions or Terms of Service. When you set up a terms of use
definition, you also specify the contexts where the definition is available. For example, you can specify that certain terms can
be used for public user registration but not for permit applications or planning and zoning applications.
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You add, modify, and delete terms of use definitions on the Terms of Use page.
This example illustrates the Terms of Use Details page.
Terms of Use Details

* Terms of Use ID

* Effective Start Date  2019-Jan-23 B Show All Dates
Effective End Date  Open end date i
* Description
i
Usage Permits

Planning and Zoning
Registration

*Content Keyboard users can place the cursor in the text editor and press Alt + 0 to access keyboard shortcut instructions.

Font - | size - B I U & A-BQ-| = =

Cance
Adding Terms of Use

1. Select Common Setup > Terms of Use.
2. On the Terms of Use page, click Add.
3. Onthe Terms of Use Details page, enter values for the following fields.

Page Element Description

Terms of Use ID Enter an identifier for the terms of use definition.

If a definition changes over time, create multiple definitions with the same ID and new
effective dates. The effective dates of the different versions must not have gaps or overlap.

Effective Start Date Enter the first day that the definition is valid.

Effective End Date Enter the date, if any, when the definition will no longer be valid. To keep the definition valid
indefinitely, do not enter a date. If no date is specified, the field displays the text Open end
date.

After a definition is saved, the end date becomes read-only. Although you can’t make
manual changes, the system can still update the end date to accommodate new effective-
dated entries. For example, if the currently effective definition has an open end date, and you
create a new definition with a later start date, the original definition’s end date changes to
the day before the new definition goes into effect.

Show All Dates Click this button to access the effective-dated history of the definition. This button is not
available during the creation of a new definition.
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Page Element Description

On the page that displays this history, use the Add button to add a new effective-dated
entry for the definition. The new entry inherits the same Terms of Use ID. You provide the
new effective start date and other details for the definition.

The system provides logic to prevent gaps or overlaps in the effective-dated history.

Description Enter a description of the terms of use. This is not part of the Terms of Use text that public
users see.
Usage Select the Permits check box to make this terms of use definition available for permits

applications. This option makes the definition available to the Terms of Use ID field on the
Permit Type page. Note that it is also necessary to add the Terms of Use element to the
permit form.

Select the Planning and Zoning check box to make this terms of use definition available
for planning applications. This option makes the definition available to the Terms of Use ID
field on the Planning Application Type page. Note that it is also necessary to add the Terms
of Use element to the planning application form.

Select the Registration check box to make this terms of use available for registration
functionality. This option makes the definition available to the Terms of Use ID field on the
Public User Setup page. See Setting Up Public Users.

You must select at least one check box.

Content Enter and format the detailed content of the terms to which a user must agree. This is the
text that users see when they are asked to agree to the terms.

4. Click Save.

Modifying Terms of Use

Select Common Setup > Terms of Use.

Click a row on the Terms of Use page.

On the Terms of Use Details page, you can update the description, usage and content.
Click Save.

pPODN

Managing Effective-Dated Terms of Use Definitions

This example illustrates the Terms of Use Details modal page that displays the effective-dated history of a terms of use
definition.
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Terms of Use Details %

4 Common Data

Terms of Use ID Reg Terms

4 History Data

+ 0

[

Effective Start Date Effective End Date Description Permits Planning and Zening Registration Content
2/1/19 Open end date Registration terms and conditions updated Feb 2019 N N Y W >

1/1/19 1/31/19 Registration terms and conditions N N Y W >

Page 1 of 1 (1-2 of 2 items)

Select Common Setup > Terms of Use .

Click a row on the Terms of Use page to open the Terms of Use Details page.

Click the Show All Dates button to view the effective-dated history of the definition you opened.
Expand the Common Data section to see the Terms of Use ID.

Expand the History section to see a list of all versions of this terms of use definition.

apronp

Click a history row to open the Terms of Use Details page for the specific row.
6. Click the Add button in the History section to create a new version of the definition.

In the new definition, you can modify any of the data except for the Terms of Use ID. An error message appears if the

new effective dates create gaps or overlaps in the definition history.

Deleting Terms of Use

1. Select Common Setup > Terms of Use.
2. Click arow on the Terms of Use page.
3. On the Terms of Use Details page, click Delete.

You are prompted to confirm the permanent deletion.

Setting Up the Twilio Security Endpoint

This topic discusses how to enable and set up the Twilio security endpoint for text message communications.

Text communications through Twilio is an optional feature provided in Oracle Functional Setup Manager (FSM) . Before
configuring this feature, you must first enable it.

Enabling the Twilio Integration

Access FSM by selecting Setup and Maintenance in the navigator.

Select a PSCR offering such as Public Sector Permits or Public Sector Planning and Zoning.
Click the Change Feature Opt In link.

Click the Features icon for the System Administration functional area.

Click the Enable check box for the Text Communications through Twilio feature.

aprobdA
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#" Note: You can deselect the Enable check box to disable the Text Communications through Twilio
feature.

Configuring the Twilio Security Endpoint

Once the Twilio integration is enabled, you can configure the Twilio security endpoint on the Manage Twilio Security Endpoint
page.

Access FSM by selecting Setup and Maintenance in the navigator.

Select a PSCR offering such as Public Sector Permits or Public Sector Planning and Zoning.
Select the System Administration functional area.

In the Show field, select All Tasks.

Select the Manage Twilio Security Endpoint task.

On the Manage Twilio Security Endpoint page, enter information for the following fields:

Page Element Description

URL Enter the URL to access Twilio’s token endpoint. This should include the host and the
context root information. Use the sandbox endpoint for testing and then use the live URL
when you go live.

oakrobd

Security Policy Select the applicable token from the drop-down list.
Username Enter the API client_id value for your Twilio endpoint account.
Password Enter the Twilio endpoint API secret code for your Twilio endpoint account.

7. Click Save and Close to save the configuration and return to the Setup page.

Delivered Communication Events

Oracle Public Sector Community Development delivers a robust registry of communication events that are triggered by
transactions and processes within the application. You can view a list of communication events in this topic.

Ad Hoc Communication Resource

Event Name Communication Description

Ad Hoc Communication Event An ad hoc email or notification was sent.

For more information on ad hoc communications, see Working with Ad Hoc Communications.
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Communication Record Details

Event Name Communication Description

Web Form Response Notifies agency staff that an applicant responded to a web form questionnaire.

For more information on web form questionnaires, see Working with Application Communications.

Fee Communications

Event Name Communication Description

New Fees Due When agency staff manually adds a new fee, the applicant receives a notification that new fees have
been assessed and are due.

For more information on manually adding a fee item, see Working with Fees and Payments.

Generic Alert Resource

Event Name Communication Description

General Alerts Text was created to appear in the banner of the Agency Springboard or the landing pages for
anonymous and registered users.

For more information about generic alerts, see Defining Alerts.

Inspection Communications

Event Name Communication Description

Final Inspection Passed When an inspector submits the final inspection for a permit with a passing result, the permit
technician or applicant receives a notification.

For more information about performing inspections, see Oracle Inspector Overview.

Inspection Canceled When the applicant or agency staff cancel an inspection, the applicant, inspection contact,
inspector, and inspection supervisor can receive a notification.

For more information, see Managing Inspections for an Agency and Managing Inspections for a
Permit.

Inspection Complete When the inspector completes any inspection and submits the inspection results, the applicant or
agency staff receive a notification that the inspection is complete, regardless of the inspection result.
A notification is also sent when inspections are updated from Scheduled to Completed.

For more information about performing inspections, see Oracle Inspector Overview.
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Event Name Communication Description

Inspection ETA Updated When the inspector updates the estimated time of arrival to an inspection site for a scheduled
inspection, the contact at the inspection location receives a notification.

For more information about performing inspections, see Oracle Inspector Overview.

Inspection Requested The system can automatically create an email notification to the permit technician when an
inspection request has been created.

For more information about requesting inspections, see Requesting Inspections.

Inspection Rescheduled When the applicant or agency staff reschedule an inspection, the applicant, inspection contact,
inspector, and inspection supervisor can receive a notification.

For more information about rescheduling an inspection, see Assigning Inspections Using the
Supervisor Calendar and Requesting Inspections.

Inspection Scheduled The system can automatically create an email notification to the inspector and inspection contact
when the inspection has been scheduled and assigned to the inspector.

For more information about assigning an inspection, see Assigning Inspections Using the
Supervisor Calendar.

Oracle Policy Automation Anonymous Results

Event Name Communication Description

Anonymous Results Save The anonymous public user receives an email with the results of recommended permits after
submitting the permit guide questionnaire.

For more information about the Permit Guide for anonymous public users, see Setting Up the Landing Page for Anonymous
Users.

Payment History Resource

Event Name Communication Description

Payment Received A successful payment triggers a notification configured using an email template.

Permits Workflow Communications

Event Name Communication Description
Workflow 001 These delivered events are not associated with specific actions in the Public Sector system. Instead,
they are generic events that are delivered for use with workflow. For example, you can use these
Workflow 002 events when configuring workflow to send notifications related to permit status changes.
Workflow 003
44
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Event Name Communication Description
Workflow 004 When you set up workflow in the Oracle Integration Cloud, you implement notifications by creating
a workflow event that sends an event name, template name, and permit ID to the communications
Workflow 005 center. The communication center then takes care of sending the notification.

See Setting Up Process Definitions for Workflow.

Planning and Zoning Workflow Communications

Event Name Communication Description

PNZ Workflow 001 These delivered events are not associated with specific actions in the Public Sector system. Instead,
they are generic events that are delivered for use with workflow. For example, you can use these

PNZ Workflow 002 events when configuring workflow to send notifications related to planning application status

changes to applicants and owners.
PNZ Workflow 003

When you set up workflow in the Oracle Integration Cloud, you implement notifications by creating
PNZ Workflow 004 a workflow event that sends an event name, template name, and planning application ID to the

communications center. The communication center then takes care of sending the notification.
PNZ Workflow 005

See Setting Up Process Definitions for Workflow.

Plan Review Communications

The following events are provided for plan reviews:

Event Name Communication Description

Plan Reviewers Completed a Review The plan check coordinator receives a notification when all plan reviewers complete their reviews.
Cycle

Plan Review Completed The applicant receives a notification with the outcome of the plan review plan coordinator cancels

the review cycle or the plan review cycle is closed.

For more information about plan review communications, see Managing Manual Plan Review Cycles and Managing
Electronic Plan Review Cycles.

User Profile Notifications

The User Profile Notifications resource provides the following events.

Event Name Communication Description

User Account Information Changed Notifies a public user when the user's account is updated by agency personnel.
Contractor License Verification Failed Notifies a public user that the contractor's license could not be verified.
Contractor License Verification Pending Notifies a public user that the contractor's license verification is pending.
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Event Name Communication Description
Contractor License Verification Passed Notifies a public user that the contractor's license has been verified.
Law Enforcement Verification Failed Notifies a public user that their status as a member of law enforcement or a judicial agency could

not be verified.

Law Enforcement Verification Pending Notifies a public user that verification for being a member of law enforcement or a judicial agency is
pending.

Law Enforcement Verification Passed Notifies a public user that verification for being a member of law enforcement or a judicial agency is
complete.

License Verification Failed Notifies a public user that the license could not be verified.

License Verification Pending Notifies a public user that the license verification is pending.

License Verification Passed Notifies a public user that the license has been verified.

Welcome Business Profile Sends a welcome notification and instructions to a permit applicant who creates a new business
profile.

User Profile Information Changed Notifies a public user when the user's profile is updated by agency personnel.

Welcome Personal Profile Sends a welcome notification and instructions to a permit applicant who creates a new personal
profile.

User Trust Account Notifications

The User Trust Account Notifications resource provides the following events.

Event Name Communication Description

Trust Account Verification Failed Notifies a public user that the trust account could not be verified.
Trust Account Verification Pending Notifies a public user that the trust account verification is pending.
Trust Account Verification Passed Notifies a public user that the trust account has been verified.

See Verifying Public User Information.
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Setting Up Communication Events

Communication events trigger delivery of different communication types to various users. The agency defines the content and
recipients using communication templates.

Agency users add, modify, and delete communication templates on the Communication Event Details page.

The communication events themselves are delivered with Oracle Public Sector Community Development. For a list of the
available communication events, see Delivered Communication Events.

Adding Communication Templates

Select Communication Center > Events in the navigator.

Click the row on the Communication Event page for which you want to add a template.

On the Communication Event Details page, click Add in the Communication Template grid.
On the Communication Template Details page, enter values for the following fields:

Page Elements Definition

Code Enter a unique identifier code for the communication template.

pODMA

# Note:
To make the code unique, Oracle recommends that you create it using a portion
of the communication event name. For example, you might use SUBO1 for the
email template of the Application Submit communication event. This is because
communication template codes must be unique across all communication events.
If you create a communication template for one event that has the same code as a
template for another event, you will receive an error when you try to save it.

Name Enter a name for the communication template.

Channel Type Specify the type of communication that this template generates. Values are:

o Alert: Generates text that is displayed to users when they log in to the application.
o Email: Generates an email that is sent to users.

o Notification: Generates a notification that appears when users click the notification
icon in the application.

o Text: Generates a short message service (SMS) text message that is sent to users.

# Note:
The fields that are available to define on this page vary depending on the channel
type that you select.

Visibility Select which type of user can see this communication. Values are:

o Account owner

o Public user

a7
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Page Elements Definition

o Agency staff only

# Note:
This field does not appear for the Alert channel type.

Enabled Turn this switch on to activate the communication template. When this switch is turned
off, the application does not generate the communication when the associated event is
triggered.

Start Date Time and End Date Enter the time period for which the alert is displayed.

Time

\J
# Note:

These fields appear only for the Alert channel type.

MIME Type (Multipurpose Internet Select the format of the email that this communication template generates. Values are:
Mail Extensions type)

o HTML

o Text

# Note:

This field appears only for the Email channel type.

Notification Priority Turn this switch on to display notifications generated by this communication template at the
top of the notification list.

# Note:
This field appears only for the Notification channel type.

User Can Delete Turn this switch on to enable users to delete notifications generated by this communication
template from their notification lists.

# Note:
This field appears only for the Notification channel type.

Select and Insert These fields enable you to insert variable attributes into your communications. You select the
field and the attribute that you want to insert in that field, and click Insert to enter a variable
for that attribute.

Select Body ¥  PermitID v Insert

For example, if you select the Body field and the Permit ID attribute, and click Insert,
the ${Permit ID} variable is inserted into the Message Body field of the communication
template.
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Page Elements Definition

To access instructions, place the cursor in the text editor and press Alt + 0.

Normal - | Font - | Size -/B I U|L|A- R

Message Body

=|le = M@

Please send the following additional information for permit ${Pemit 1D}

body p

Whenever the application generates a communication using this template, it inserts the
permit ID that is associated with the triggered communication event into the body text.

Remarks Enter any additional information about the communication template. These remarks are not
included in the generated communication.

From For the Email channel type, enter the email address of the person or organization who is
sending the generated email.

For the Text channel type, select the phone number of the person or organization who is
sending the generated text message.

To Enter the email addresses, user IDs, or phone numbers of the people or organizations that
you want to receive the communication.

# Note:
Enter email addresses for the Email channel type, user IDs for the Alert and
Notification channel types, and phone numbers for the Text channel type.

Cc and Bcc Enter the email addresses of the people or organizations that you want to receive a copy or
blind copy of the communication.

# Note:
These fields appear only for the Email channel type.

Subject Enter a brief description of the purpose and content of the communication.

# Note:
This field appears only for the Email and Notification channel types.

Message Body Enter the main body text of the communication.

You can enter only plain, unformatted text for the Alert channel type, the Text channel type,
and the Email channel type with the Text MIME type.
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Page Elements Definition

You can enter rich text, links, and images for the Notification channel type and the Email
channel type with the HTML MIME type.

5. Click Save.

Modifying Communication Templates

Select Communication Center > Events .

Click the row on the Communication Event page for which you want to modify a template.
Click the row in the Communication Template grid that you want to modify.

On the Communication Template Details page you can:

pPODd S

o Click Clone to create a copy of the communication template.
o Update the communication template field values.

#" Note: You cannot edit the Code or Channel Type fields.

5. Click Save.

Deleting Communication Templates

Select Communication Center > Events .

Click the row on the Communication Event page for which you want to delete templates.
Click Edit in the Communication Template grid.

Select the check boxes next to all of the communication templates that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

apopA

Setting Up Reports
The report parameters that you define on the Report Configuration pages filter the data that is generated for the reports. You
can use delivered or provide customized reports.

Oracle Public Sector Community Development delivers these reports:

Report Name Description Initiated From
Deposit Slip Lists deposit information. e Print Deposit Slip page

See Printing Deposit Slips.

e Bl Catalog ( Shared Folders > Public
Sector > Billing and Payments )

Inspection Summary Displays inspection-related information. e Inspection Detail page of the permit
record details

See Reviewing Inspection Details.
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Initiated From

e Bl Catalog ( Shared Folders > Public
Sector > Inspections )

Report Name Description

Payment Invoice Displays invoice information. e Fees and Payments page of the permit

record details
See Working with Fees and
Payments.

e Bl Catalog ( Shared Folders > Public
Sector > Billing and Payments )

Overview page of the permit record
details

Building Permit Displays permit-related information. o
See Viewing the Permit Summary.

e Bl Catalog ( Shared Folders > Public
Sector > Permits )

Payment Receipt Lists payment receipt information. e Payment Successful page

See Payment Flow Overview.

e Fees and Payments page of the permit
record details
See Working with Fees and

Payments.

e Bl Catalog ( Shared Folders > Public
Sector > Billing and Payments )

Inspection Activity

Displays all inspection activity for an agency
over a specified date range.

Bl Catalog ( Shared Folders > Public
Sector > Inspections )

Planning Application

Displays planning activity over a specified
date range. You select which applications are
included the report. You can generate the
report for one or more specific applications,
or for all applications handled by your
agency.

Bl Catalog ( Shared Folders > Public
Sector > Permits )

For reports initiated from within Public Sector Compliance and Regulation, you add, modify, and delete report parameters on
the Report Configuration Details page.

You can also create your own reports in Oracle Bl Publisher and allow users to access them through the View Reports
buttons in the application pages. For more information on modifying and creating analytics and reports, see Creating and
Administering Analytics and Reports.

Adding Report Parameters

pPODd 2

Select Common Setup > Report Configuration .
Click the report row on the Report Configuration page for which you want to add a parameter.

On the Report Configuration Details page, click Add in the Parameters grid.

Enter values for the following fields:

ORrRACLE
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5.

Page Elements Definition

Parameter ID and Parameter Enter a unique ID and name for the report parameter.
Name
Parameter Data Type Enter the data type for the report parameter.

Control Object and Control Name Enter a field from which the report receives data along with a name for that field.

Click Save.

Modifying Report Parameters

pPODd 2

5.

Select Common Setup > Report Configuration .

Click the report row on the Report Configuration page for which you want to modify a parameter.
Click the row in the Parameters grid that you want to modify.

You can:

o Update the report parameter field values.
o Delete the report parameter. You will be prompted to confirm the permanent deletion.
Click Save.

Deleting Report Parameters

aprpONd~

Select Common Setup > Report Configuration .

Click a row on the Report Configuration page.

Click Edit in the Parameters grid.

Select the check boxes next to all of the report parameters that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

Updating the Report Path

pPoODNd =

Select Common Setup > Report Configuration .

Click the report row on the Report Configuration page for which you want to modify the report path.
On the Report Configuration Details page, enter a path to the desired Bl Publisher report.

Click Save.

Setting Up Document Categories and Subcategories

You set up document categories and subcategories on the Document Category pages to organize the various types of
attachment files.

This example illustrates the Document Category Details page, which is described in the following text.
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* Category ID  Initialization

* Category Project Initialization
* Description  Project Initialization
Enabled c
Document Subcategory
= 4 X Search SUR 4

Subcategory ID Subcategory Description Enabled

Initialization Approved Initialization Approved Project Initialization Approved Yes >

Project Charter Project Charter Project Charter Yes >

Adding Document Categories and Subcategories

1.
2.
3.

No o

Select Common Setup > Document Category .
On the Document Category page, click Add to add a new document category.
Enter values on the Document Category Details page:

Page Element Description

Category ID Enter an identifier for the category.
Category Enter a name for the category.
Description Enter a description of the category.
Enabled Turn the switch on to make the category available for use. The category is disabled by
default.
Click Save.

If you want to add a subcategory, click Add in the Document Subcategory section.
On the Document Subcategory Details page, enter an ID, name, and description for the subcategory.
Click Save.

Modifying Document Categories and Subcategories

1.

&

Select Common Setup > Document Category .
On the Document Category page, select the row for the category that you want to modify.

On the Document Category Details page, you can modify the category name and description, and turn the Enabled
switch on or off.

Click Save to save any changes.
To modify a document subcategory:

a. Select the associated category to open the Document Category Details page.
b. Select the subcategory that you want to modify.

c. On the Document Subcategory Details page, you can change the subcategory name and description, and
turn the Enabled switch on or off.

d. Click Save.
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Deleting Document Categories and Subcategories

1.

3.

o

Select Common Setup > Document Category .
On the Document Category page, select the row for the category that you want to delete.
If you want to delete the document category, click Delete on the Document Category Details page.

" Note: When you delete a document category, all associated subcategories are also deleted.

If you want to delete multiple document categories, you can delete them on the Document Category page:

a. Click Edit.
b. Select the check boxes for the document category rows to delete.
c. Click Delete.
To delete the document subcategory, click Delete on the Document Subcategory Details page.

If you want to delete multiple subcategories, you can delete them from the Document Category Details page using
the Edit and Delete buttons.

Setting Up Document Groups

You set up document groups using the Document Group pages to organize the various categories of attachment files into a
grouping.

This example illustrates the Document Group Details page, which is described in the following text.

Document Group Details Cancel || Delete [N

* Group ID  ZPER-DOCGRPID1 Enabled c

* Group  ZPER-DOCGRP1 * Description  Document Group1

Document Category

Category ID

BLUEPRINT

Forms 1548829255279 Y Blueprints Application form

Document Category

Category Description Enabled Actions

Q BLUEPRINT Drawings blueprints and layouts

+
+

ol

Adding Document Groups

1.
2.
3.

Select Common Setup > Document Group .
On the Document Group page, click Add to add a new document group.
Enter values on the Document Group Details page:

Page Element Description

Group ID Enter an identifier for the group.
Group Enter a name for the group.
Description Enter a description of the group.
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7.

Page Element Description

Enabled Turn the switch on to make the group available for use. The group is disabled by default.

Click Save.
Add document categories that make up the grouping by clicking Add in the Document Category section.
Enter a document category ID or use the lookup prompt to find a category ID.

If desired, you can click the Document Category link to research which category to choose. For more information
about document categories, see Setting Up Document Categories and Subcategories.
Click Save.

Modifying Document Groups

1.

Select Common Setup > Document Group .
On the Document Group page, select the row for the group that you want to modify.

On the Document Group Details page, you can modify the group name and description, and turn the Enabled
switch on or off.

Click Save to save any changes.
You add or remove document categories from the group in the Document Category section.

To modify a document category, you must go to the Document Category definition pages. See Setting Up
Document Categories and Subcategories.

Deleting Document Groups

HPODN S

Select Common Setup > Document Group .

On the Document Group page, select the row for the group that you want to delete.

Click Delete on the Document Group Details page.

If you want to delete multiple document groups, you can delete them on the Document Group page:

a. Click Edit.
b. Select the check boxes for the document group rows to delete.
c. Click Delete.

To delete a document category from the group, click the Delete icon for the document category row in the
Document Category section.

Setting Up Dashboards

You add, modify, and delete dashboard configurations on the Dashboard Configurations page.

Adding a Dashboard Configuration

1.
2.
3.

Select Common Setup > Dashboard Configuration .
On the Dashboard Configuration page, click Add.
On the Dashboard Configuration Details page, enter values for the following fields:
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Dashboard ID Enter a unique name for the dashboard.
Description Enter a description of the dashboard
Path Enter the Oracle Business Intelligence (Bl) Catalog portal path for the dashboard. For

example the portal path for the Permits dashboard is %2Fshared%2FPublic%20Sector
%2F_portal%2FPublic%20Sector&page=Permits.

Enabled Turn on this switch to activate this dashboard.
Default Turn on this switch to make this the default dashboard.
# Note:

Only one dashboard can be designated as the default.

4. Click Save.

Modifying a Dashboard Configuration

1. Select Common Setup > Dashboard Configuration .
2. Click a row on the Dashboard Configuration page.
3. On the Dashboard Configuration Details page you can:

o Update the dashboard configuration field values.

# Note: You cannot edit the Dashboard ID.

o Delete the dashboard configuration. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Dashboard Configurations

Select Common Setup > Dashboard Configuration .

Click Edit.

Select the check boxes next to all the dashboard configurations that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

pPODdM2

Setting Up Lookups

This topic describes how to add and change values that appear in lookup lists. Lookup lists are referenced by various fields in
the application that display a static set of values from which the end user can select a value.
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Lookup Types and Lookup Values Overview

Lookup types in applications are used to represent a set of codes and their translated meanings. To the end users, a lookup
type displays a list of values from which they select values.

You use the Lookup Types page to access lookup types, and you use the Lookup Type Details page to modify lookup types,
add lookup values, and add lookup types, where authorized.

When working with lookups, you deal with lookup types and lookup values.

Lookup Element Description

Lookup Type A lookup type is a static list of values users view to make entries in the application. The application
references a lookup type to display its list of values.

Lookup Value A lookup value is a single item contained within a lookup type. For example, Paid is a lookup value
for the Fee Status lookup type. Lookup types typically contain numerous lookup values.

Lookup types are delivered as seed data for your service. You can only modify selected lookup types, such as Business
Type, UOM Type, Standard Code Type, and so on. Most lookup types are read-only.

Modifying Lookup Types

Lookup Type

+ |+ Search... o T
Lookup Type Meaning Application Module Configuration Level
ORA_PSC_PER_INS_COMNTACT Contact method Permits Permit Inspections Extension >
ORA_PSC_PER_IMS_SIG Inspector Signature Option Permits Permit Inspection Setup System >
ORA_PSC_PER_INS_SYS_STATUS Inspection System Status Permits Permit Inspection Setup System >
ORA_PSC_PER_ORIGINATOR Record Criginator Permits Application Intake System >
ORA_PSC_PER_OWNER_SIG Owner Signature Option Permits Permit Inspection Setup System >
ORA_PSC_PER_PUB_USER_ENABLED Public User Enabled Permits Application Intake System ¥
ORA_PSC_PER_RECORD_STATE Record State Permits Application Intake System >
ORA_PSC_PER_REC_SYS_STATUS Record System Status Permits Permit Setup System >

Page 2 of8 (9-16of62items) K < 1 3 4 5.8 » Show Default A

To modify a lookup type:

1. Select Common Setup > Lookups.
2. On the Lookup Types page use the Search box to filter the lookup types by keyword.

For example, to view the Business Type lookup type, enter business in the Search box.
3. Click on the row for the lookup type you want to view.
4. View the contents of the Lookup Type Details page.

Page Element Description

Lookup Type Identifies the lookup type within the application.
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Page Element Description
Application Identifies the application that uses the lookup type. For example, Permits, Common

Components, and so on.

Meaning The actual Ul display name used to represent the list of values contained in the lookup type.

Configuration Level Indicates at what level the lookup can be modified. Options are:

o System: Only Oracle development teams can modify lookup types at this configuration
level.

o Extension: Customers can perform minimal tasks, such as add lookup values.

o User: Customers can add lookup values, delete lookup values, update the meaning,
and update the description.

Module The internal application module using the lookup type, such as Billing Entry, Billing Setup,
and so on.
Description Identifies the purpose and use of the lookup type.

5. If you need to add lookup values, refer to the following section for steps for that task.
6. Click Cancel to close the lookup type, or click Save if you made any changes.
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Adding Lookup Values

Lookup Value Details

* Lookup Code  Public

Display Sequence 2 v A
Enabled B
Start Date  2018-08-17 =
End Date 2020-08-17 =

* Meaning Public Sector

Description

Tag

Cancel Save

You can add lookup values to lookup types with a configuration level set to User or Extension.

To add lookup values:

1. Select Common Setup > Lookups.

2. On the Lookup Types page use the Search box to filter the lookup types by keyword.
For example, to view the Business Type lookup type, enter business in the Search box.

3. Click on the row for the lookup type you want to view.

4. On the Lookup Type Details page, click Add under Lookup Value Type.

5. On the Lookup Value Details page, enter these values:

Page Element Description

Lookup Code An internal application code for each lookup value that is not visible to users. It is typically
a shorter, less user-friendly representation of the item. For example, ORA_DRIVER_LIC for
State Driver’s License, or LEN for Length, if listing units of measurement.

Display Sequence Control in what sequence the lookup value appears in the list displayed to users, where 2
appears above 3. If you do not specify a sequence, the application displays the items in the
order they were entered.
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Page Element Description

Enabled Turn on to make a lookup value active. If a lookup value is not enabled, then the application
does not display it to the end user in the list of values for that lookup type.

Start Date Set a start date for the lookup value to become active. Even if the lookup value is enabled,
if a start date is set, the application does not display the lookup value until the start date is
reached.

End Date Set an end date for a lookup value to no longer be displayed in a list of values.

Meaning The display name for the lookup value. End users see this value in the list of values displayed
at run time. They do not see the Lookup Code value.

Description Provide any additional information to help identify the purpose of the lookup value or
clarification regarding what it represents.

Tag Tags allow you to add a label to your lookup codes. A tag can be used to categorize
lookups based on facilitating searches or guiding how a lookup should be used.

6. Click Save.

Working with Configuration Levels

The configuration level attribute determines who can modify a lookup type and what can be modified. The configuration levels

are:

e System: Only Oracle development teams can modify lookup types at this configuration level.

e Extension: Customers can perform minimal tasks, such as add lookup values.

e User: Customers can add lookup values, delete lookup values, update the meaning, and update the description.

Task User Extension System
Add a lookup type Yes No No
Delete a lookup type Yes No No
Modify lookup type meaning Yes No No
Modify lookup type description Yes No No
Add lookup values Yes Yes No
Delete lookup values Yes (if you created it) Yes (if you created it) No
Modify lookup value attrioutes Yes (except for Lookup Code) Yes (if you created it, and except No

for Lookup Code)

ORrRACLE
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Adding Lookup Types

To add a lookup type:

1. Select Common Setup > Lookups.
On the Lookup Types page click Add for the Lookup Type grid.
3. On the Lookup Type Details page, enter these values:

o Lookup Type (The value you enter must be uppercase and cannot begin with the prefix ORA_, which is used
to distinguish your custom lookup types from delivered lookup types.)

o Meaning
o Module
o Description

4. Click Add for the Lookup Value grid for each lookup value you need to add to the lookup type.
5. Click Save.

Setting Up Data Format Exchange Maps

The Data Format Exchange utility is a data-mapping utility that enables you to map fields between source and target
locations.

# Note: This utility is useful in situations where data must be exported from or imported to Public Sector
Compliance and Regulation. Currently, this utility is only used by the Export Journals to ERP process.

Business analysts create and modify Data Format Exchange maps on the Data Format Exchange page.

Adding a Data Format Exchange Map

1. Select Common Setup > Data Format Exchange .
2. On the Data Format Exchange page, click Add.
3. For the Definition step, enter values for the following fields:

Page Element Description

Mapping Name and Description Enter a name and description for the data mapping.
Source Type Select the type of source format to be included in the data mapping.
g
# Note:

Currently, VO is the only valid value for this field.

Target Type Select the type of target format to be included in the data mapping.
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Page Element Description

# Note:
Currently, CSV is the only valid value for this field.

Enabled Turn this switch on to make the data mapping available to select in the Mapping Name
field on the Export Journals to ERP page. For more information on exporting journals, see
Exporting Journal Entries.

&

Click Next.
5. For the Source step, enter values for the following fields:

Page Element Description

Source Name Selects the source view to be included in the data mapping, such as Journals to Export.
6. Click Next.
7. For the Target step, click Upload to select a file that will be updated with the results of the field mapping.
8. Click Next.
9. For the Mapping step, enter values for the following fields:

Page Element Description

Target Field Displays each field in the target format.

Source Field Select the source field that you want to map to each target field.

Transform Select an option to modify the value for the target field.

# Note:

Currently, Constant is the only valid value for this field.

Transform Parameter Specify the parameter used to determine the value for the target field. For example, if
the target field is Effective Date and the Transform value is Constant, the Transform
Parameter might be 01/01/2018.

10. Click Submit to save the Data Format Exchange map.

< Note: At any point during the process, you can click Previous to go back one step. You can also click
Cancel to exit the data mapping setup process and discard your changes.

Modifying a Data Format Exchange Map

1. Select Common Setup > Data Format Exchange .
2. Select a mapping on the Data Format Exchange page.
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For the Definition step, you can enable or disable the data mapping.

Click Next.

You can’t update any fields in the Source step.

Click Next.

For the Target step, you can click the file link to download a copy of the file.

Click Next.

For the Mapping step, you can update the values of the Source Field, Transform, and Transform Parameter
fields.

10. Click Submit to save your changes to the Data Format Exchange map.

©o NSO,

" Note: At any point during the process, you can click Previous to go back one step. You can also click
Cancel to exit the data mapping update process and discard your changes.
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3 Setting Up Your Agency Staff

Setting Up a Fusion Business Unit and Legal Entity

This topic discusses the one-time setup for Public Sector Compliance and Regulation administrators who are not using
Fusion Human Capital Management (HCM), Enterprise Resource Planning (ERP), and Sales Cloud.

If you have implemented both Fusion Financials and Public Sector Compliance and Regulation (PSCR) services, then you
must ensure that you migrate Financials Business Unit related tasks before any PSCR migrations. Migrate any changes
you have made to the business unit configurations in the Financials offering before the Public Sector offering or the
implementation projects are migrated from a non-production environment to your production environment.

The following setup steps are prerequisites for creating an agency staff in the system.

" Note: For Fusion HCM, ERP, and Sales Cloud customers, these steps are not required as the business unit and
legal entity are already set up.

Configure the following tasks in the order mentioned here:

1. Set up reference data sets (to create a Set ID)
Create a business unit

Create a legal address

Create a Legislative Data Group

Create a Legal Entity

Register a Legal Entity

Create Legal Entity HCM Information

Nooakrobd

Setting up Reference Data Sets

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering: Public
Sector Permits or Public Sector Planning and Zoning and then select the Agency Staff functional area.

2. On the right panel locate the Manage Reference Data Sets task and click the row to open the Manage Reference
Data Sets page.

3. On the Manage Reference Data Sets page, click the New button and include values for the fields:

Page Element Description

Set Code Enter a code value that represents your agency.
Set Name Enter a name that represents your agency.
Description Enter a description about your agency.

4. Click Save and Close to save the newly created SetID.
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Creating a Business Unit

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering: Public
Sector Permits or Public Sector Planning and Zoning and then select the Agency Staff functional area.

2. On the right panel locate the Manage Business Units task and click the row to open the Manage Business Units
page.
3. On the Manage Business Unit page, click the New button and include values for the fields:

Page Element Description

Name Enter a name for the business unit.

Default Set Select the SetlD you created in the previous section

4. Click Save and Close to save the newly created business unit.

Creating a Legal Address

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering: Public
Sector Permits or Public Sector Planning and Zoning and then select the Agency Staff functional area.

2. On the right panel, locate the Manage Legal Addresses task and click the row to open the Manage Legal Addresses
page.

3. On the Manage Legal Addresses page, click the New button and enter the agency address in the Agency Line 1
field. The other fields are optional.

4. Click OK to return to the Manage Legal Addresses page and click Save and Close to save the newly created
address.

Creating a Legislative Data Group

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering: Public
Sector Permits or Public Sector Planning and Zoning and then select the Agency Staff functional area.

2. On the right panel, select the task named Manage Legislative Data Group and click Select to open the Manage
Legislative Data Groups page.

On the Manage Legislative Data Groups page, click Create to enter the new legislative data group details.
Enter your legislative data group name in the Name field. Search and select your country from the Country field.
Click Submit to save and return to the Manage Legislative Data Group page.

Click Done.

L S

Creating a Legal Entity

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering: Public
Sector Permits or Public Sector Planning and Zoning and then select the Agency Staff functional area.

2. On the right panel, locate the task named Manage Legal Entity and click to open the Select Scope page.

On the Select Scope page select the Manage Legal Entity task radio button.

4. Click the Legal Entity drop-down and select Create New. Click Apply and Go to Task button to open the manage
Legal Entities page.

5. On the Manage Legal Entities page, click the New button to open the Create Legal Entity page and enter values for
the fields:

©
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Country Select the country (United States is the default selection)
Name Enter the name of your agency
Legal Entity Identifier Enter a code for your agency
Payroll Statutory Unit Select the checkbox
Legal Employer Select the checkbox
Legal Address Select the legal address (created in the previous section) using the Search and Select page.
EIN or TIN Enter your agency’s EIN or TIN value. You can enter a value of your choice if you do not

have EIN or TIN for your agency.

# Note:
If you are using Fusion HCM or Fusion ERP, the value you enter here must be
legitimate. It is recommended that you refer to Fusion documentation to know about
the required value for entry in the field.

Legal Reporting Unit Registration Enter your agency’s legal reporting unit registration number. You can enter a value of your
Number choice if you do not have a registered number for your agency.

# Note:
If you are using Fusion HCM or Fusion ERP, the value you enter here must be
legitimate. It is recommended that you refer to Fusion documentation to know about
the required value for entry in the field.

6. Click Save and Close to save the newly created legal entity.

Registering a Legal Entity

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering: Public
Sector Permits or Public Sector Planning and Zoning and then select the Agency Staff functional area.

2. On theright panel, select the task named Manage Legal Entity Registration and click Select to open the Select
Scope page.

3. On the Select Scope page select the Manage Legal Entity Registrations task radio button.

4. Click the Legal Entity drop-down and choose Select and Add. Select Click Apply and Go to Task button to open the
Manage Legal Entities page.

5. On the Manage Legal Entities page expand the Search section and enter the legal entity name you created in the
previous section. Click Search.

6. Select the row from the search results and click Save and Close, to save the entity and open the Manage
Registrations page.

7. View your values on the new Manage Registrations page and click Done to confirm and complete the registration
process.
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Creating Legal Entity HCM Information

1.

9.
10.

11.

Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering: Public
Sector Permits or Public Sector Planning and Zoning and then select the Agency Staff functional area.

On the right panel, select the task named Manage Legal Entity HCM Information and click Select to open the Select
Scope page.

On the Select Scope page select the Manage Legal Entity HCM Information task radio button.

Click the Legal Entity drop-down and choose Select and Add. Click Apply and Go to Task button to open the
Manage Legal Entities page.

On the Manage Legal Entities page expand the Search section and enter the legislative data group you created in
the previous section. Click Search.

Select the row from the search results and click Save and Close, to save the entity and open the Legal Entity page.

On the Legal Entity page, click Edit and then click Update to open the Update Legal Entity page to enter an action
reason.

On the Update Legal Entity page, select Action Reason drop-down button and select the option Reorganization.
Click OK to save and return to the Legal Entity page.

On the Legal Entity page, select the Payroll Statutory tab to associate the data group to the HCM legal entity.

Under the Payroll Statutory Information section select the Associated Legislative Data Group drop-down. Search and
select the legislative data group you created using the previous section.

Click OK to return to the Edit Legal Entity page. Click Submit and then click Done to complete the creation of a
Legal Entity HCM Information.

For information on creating an employee record, refer to the documentation Managing Agency Staff Profiles.

Defining Job Titles

This topic discusses how to define job titles for agency staff.

Defining Job Titles

Administrators define new job titles using the Job Titles page:

apronp

Select Agency Staff > Job Title .

The Job Title page lists all the job titles defined.

Click Details for a row to open the Job Title Detail page and view and edit the details of the job title.
Click Add to open the Job Title Detail page and define a new job title.

Enter various details and click Save to save the new job title and return to the Job Title page.

Setting Up Agency Staff

This topic provides an overview of job functions along with a list of delivered Job Functions, and discusses the how to set up
Fusion Business Units and Legal Entities for Public Sector Compliance and Regulation services.
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Job functions are assignments made to staff members using the Manage Agency Staff page. Job Function helps you in
assigning job specific attributes to an agency staff member. For example, you can assign the job function of a Building
Inspector to an agency staff member and set up attributes such as Inspector District and Schedule.

Job Function Section and Usage

Building Inspector

Work Schedule — Inspections: Determine the work schedule of the Inspector.
Inspection Districts — Inspections: Determine the districts an inspector is assigned to.

Inspection Types — Inspections: Determine if the inspector can be assigned to a given type
of inspection.

Permit Types

Business Analyst

Inspection Districts
Inspection Types

Permit Types

Chief Building Officer

Inspection Districts
Inspection Types

Permit Types

Inspector Supervisor

Work Schedule — Inspections: Determine the work schedule of an Inspector supervisor.
Inspection Districts — Inspections : Determine the districts an inspector is assigned to.
Inspection Types

Permit Types

Economic Development Officer

Permit Types

Finance Administrator

Inspection Districts
Inspection Types

Permit Types

Permit Technician

Inspection Districts
Inspection Types

Permit Types

Plan Coordinator

Permit Types

Plan Reviewer

Permit Types— Determine the permit types that this plan reviewer can be assigned to.

Plan Reviewer Department— Determine the plan reviewer department that this plan
reviewer belongs to. This grouping by plan review departments appears as an option in the
drop-down menu that can be used while assigning a plan reviewer to a plan review.

Principal Planner

Permit Types

Cashier

Permit Types

Cashier ID — Cashiering: Determine Cashier ID of the Cashier
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Planner ¢ Planning Application Types— Determine the application types that this Planner can be
assigned to.

¢ Pre-application Meeting Schedule — Determine the availability of the planner for
scheduling pre-application meetings.

Setting Up Fusion HCM Business Units and Legal Entities for Public Sector
Compliance and Regulation Services

If you are an existing Fusion customer and if you have already set up business units and legal entity, then you can assign the
same for your Agency Staff. However, if you are a new Public Sector Compliance and Regulation-only customer then as a
prerequisite for entering Agency Staff data, you need to create one business unit and one legal entity that can be used for
your agency staff.

See Setting Up a Fusion Business Unit and Legal Entity.

Configuring Agency Job Groups

This topic provides an overview of the Agency Staff Group Configuration and discuss the procedure to configure agency job
groups.

You can use the Agency Staff Groups for identifying a common set of Job attributes that can be applied to a group of
Employees.

Groups provide the flexibility to assign attributes at various levels. You can define a group for a given department, division, or
for specific districts based on the commonalities of the job attributes.

Examples of Groups are:

1. Inspectors working in District A
2. Permit Technicians responsible for Fence Permits
You can configure a group with default Job Functions and their attribute values for your users.

Users entering their employee profile information can select a group job function, which results in loading default job functions
and their attribute values automatically populated.

" Note: Users cannot edit the job function attribute values on the Agency Staff page when using the Job Group
function.

Configuring Agency Job Groups

Administrators set up and configure the agency staff group on the Job Group page. Agency users can select a group on the
Agency Staff Profile page, and a default set of job functions and attribute values are assigned to the employee. To set up the
job functions and attributes for a group:

1. Select Agency Staff > Job Group .
2. On the Job Group page, click Add to add a new group or Edit to change the group attributes. Click Add.
3. Enter the details of the job group on the Job Group Details page.
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4. Verify that the Enabled switch is turned on if you want to enable this group when you save. This switch is turned on
by default for a new group.

5. Under the Job Function section, click Add to select job functions and include their attributes.

6. Click Save to return to the Job Group page.

" Note: Agency users select the group from a list on the Agency Staff page. The job functions and their
corresponding attributes cannot be changed by users.

Managing Agency Staff Profiles

This topic discusses how to manage agency staff profiles.

Managing Agency Staff Profile

Administrators set up the agency staff profile on the Agency Staff page. Select Agency Staff.

1. Select Agency Staff

2. On the Agency Staff page, click Add to add a new agency staff member — employee.

3. On the Agency Staff Profile page, you add values to the various fields. For the Business Unit and the Legal Entity,
see the documentation Setting Up a Fusion Business Unit and Legal Entity .

Page Element Description

Select Existing Fusion Worker Turn on the switch to allow the search and selection of an existing Fusion employee. The
following fields are display only, populating details from Fusion information:

o PersonID

o Person Number

o Hire Date

o Business Unit

o Legal Entity

o Generated User Account
o Send Credential Email

o Username

Worker ID Enter an ID or click the prompt to open the Look Up page and search for the Fusion
employees. You can sort the search results by any of these:

o Worker ID

o First Name

o LastName

o Email Address
o Hire Date

o Phone Number

o Business Unit Name
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Page Element Description

o Legal Employer
o Manager Person ID

Select an employee row from the search result on the Look Up page and the details are
populated on the Agency Staff page.

Person Type Select a type of staff member from the options: Employee
Enabled Set a status for the staff member from the options:
o Active
o Inactive
g
«# Note:

You set the status to Inactive when the employee is inactivated in your HR system.
If you are a Fusion HCM/ERP/Sales Cloud customer then the inactivation of
Employees in HCM will not automatically inactivate the Employee data in Public
Sector Cloud. You must manually update this field.

Is a Supervisor Turn on the switch if the employee is a supervisor.

Job Group Select a group to assign a job group section with the relevant job functions. Accordingly, the
system populates the Job Group Assignments section.

# Note:
You cannot make any changes to the values in the job group assignments on this
page. To update the values, navigate to the Job Group page.

4. Click Save to save the agency staff profile and return to the Agency Staff page.

Job Function Assignment without using Agency Job Groups

You can assign job functions to employees directly, without having to use Job Groups.

1. On the Agency Staff page search and select the employee that you want to add job functions to.
2. Under the Job Function section, click Add to select job functions and include their attributes.
3. Click Save and return to the Agency Staff page to view the job function assignments.

To include job functions using Agency Job Groups, see the documentation Configuring Agency Job Groups.

Assigning Agency Security Access

Administrators assign roles to various staff members. The security roles assigned to an employee determine the navigations
and data that the user can access.

1. Select Agency Staff and then select Agency Staff Access. The Agency Staff Access page lists all the agency staff
members.

2. You can click the chevron for a row to view the employee access details. This page lists all the security roles
assigned to the employee user. You can add new security roles to the employee on this page.
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Click the Add New Role button to open the Role Detail page and assign a role for the user.
Click Save to save your changes and return to the Agency Staff Access page.

Click Save to save the changes you made to the Agency Role details of the staff member.
You can add or delete the security roles assigned to the user on this page.

o0 ko

# Note: All Agency users must be assigned the PSC Agency Staff role. Additionally job specific roles can be
assigned to the user. For the complete list of security roles, you can refer to the Security Reference Manual. Also
refer to Using the Security Console.

# Note: For users requiring access to Permits, in addition to the PSC Agency Staff and job specific
roles such as PSC Permit Technician, PSC Plan Reviewer and others, you must assign the
following roles to the users: CUSTOM_MANAGE_PERMITS, CUSTOM_MANAGE_PERMITS, and
CUSTOM_PSC_MANAGE_PERMITS_AGENCY.

Importing Agency Staff Data

This topic explains how to prepare and import agency staff resource data from an external data source into Public Sector
Agency Staff tables using the File-Based Data Import feature.

Agencies with Fusion HCM implementation: File-based data import can be used if your agency has implemented Fusion
HCM. You either enter employee details manually into the Public Sector Agency Staff tables using the PSCR user interface
(Agency Staff page) or run the schedule import process to copy the employee data.

Agencies without Fusion HCM implementation: If your agency has not implemented Fusion HCM and you are using a third-
party application to maintain employee information, you can use the import process to copy data from the third party tables
into the Public Sector Agency Staff tables.

In addition to the removal or inclusion of employee records, data changes can include changes to the details of an employee,
such as the address, email, role, or designation.

Scheduling the Employee Data Import and Export Process

Administrators can set up a schedule to process a batch file that imports employee data from a .CSV file into the Public
Sector Agency Staff tables. The imported data file, which is usually generated from a third-party application, can be used to
set up and periodically update user details within Public Sector Agency Staff.

Using the Predefined Template to Import Data using File-Based Data Import

Public Sector Compliance and Regulation provides a template to help you import data using the File-Based Data Import
tool. The Import template is a spreadsheet that includes the commonly used fields, in addition to the required, along with
instructions to use them.

You can download the template by clicking this link: Agency Staff Import Template spreadsheet file.

Importing Employee Data

1. Access the File Import and Export page from the Fusion application by clicking Navigator > File > Import and
Export .
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2. On the File Import and Export page, in the Search Results section, click the Add button to upload the template zip
file to the Universal Content Management (UCM).

3. On the Upload File modal page, click Browse and select the file for upload. Use the Account field to select the
account for the file you are uploading.

4. Click Save and Close. You will see the file listing on the File Import and Export page with the details of the upload.

Scheduling the Import Export process using File-Based Data Import

1. Access the Scheduled Processes page from the Fusion application Navigator > Tools > Scheduled Processes .

2. On the Scheduled Process page, click the Schedule New Process button and enter values for the fields on the
Schedule New Process modal page:

Page Element Description

Type Ensure that the Job option is selected.

Name Search and select the Load Interface File for Import value from the list of names.
Description Displays a description about the selected process.

3. Click OK. The service now opens the Process Details page for you to select the import process for the process
name you entered in the above step:

Page Element Description

Import Process Click the drop-down menu, search and select the Import Agency Staff value using the
lookup list.
Data File Click the drop-down menu and select the generated ZIP file you uploaded earlier, as

described in the previous section.

4. Click Submit and accept the confirmation message to complete the submission.

" Note: The submission only confirms that the files are sent for processing. To view the details of the completed
process, you must access the log file. The log file lists all the successfully processed records and the records
that are in error, with the details of the error.

Records in Error

# Note: When you fix the errors in the spreadsheet and prepare to resubmit it for processing, you must delete
the records that were processed successfully in the previous run. All the records preceding the ones in error
are created in the Public Sector Agency Staff tables. Resubmitting the template having those records results in
creating duplicate entries of the staff records.

Scenarios for importing employee data from a third-party system to Public
Sector Agency Staff profile

Prerequisite
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The scenarios listed here assume that the following prerequisite has already been set up: Each record in the template should
contain a unique identifier called the Interface ID. The interface ID is used as a key identifier while establishing parent-child
relationships across the pages of the template spreadsheet.

Consider importing the employee details into the tables of Public Sector Agency Staff. You can perform the following actions
using the Import template:

e Add a new staff member

e Assign personal attributes

¢ Assign job functions and attributes
e Assign roles

e Disable an agency profile

The following scenarios detail how you can create a new agency staff record and seamlessly update various parameters of
your existing agency staff.

#" Note: The InsertUpdateFlag field on the Import template is the determining factor as to whether the record
is for a new agency staff or for updating an existing agency staff. Enter the value “I” if you are inserting a new
record, or “U” if you are updating an existing record. Also note that the Person Number field is mandatory if you
are updating a record.

Scenario 1: Adding a new agency staff
Consider creating a new agency staff record staff in your Public Sector Agency Staff.

If your agency is not a Fusion HCM customer, you use the template to enter details in all the pages of the template
spreadsheet and then schedule the import process to import the newly added employee record. You must enter the value “I”
in the InsertUpdateFlag field to qualify the record as a new agency staff entry.

The following example shows the data on the spreadsheet detailed in the above scenario — Adding a new staff member.

Record *Interface ID *InsertUpdateFlag *First Name *Last Name *Business Unit  *Legal Entity

Number

1 467436 John Simmons john.s@example.c Sample Sample
Corporation Corporation

2 467437 Robert James robert.j@example. Sample Sample
Corporation Corporation

" Note: The above example displays a limited number of fields. For a complete list of fields, refer to the Import
template spreadshest.

If your agency has implemented Fusion HCM, you use the HCM loader or enter the necessary employee details manually. In
such cases, the following PSCR specific attributes are required to be updated:

e Job Title

e Agency Department
e Agency ID

e Agency Location
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e Job Group
e |s Supervisor
e Enabled

Scenario 2: Updating personal details of an agency staff

Consider updating changes to the personal details of an agency staff in your Public Sector Agency Staff. You can perform the
following actions:

e Change work phone number
e (Change location

e (Change department

e Change job title

e Assign job group

e Revoke job group

e Change supervisor status

The following example shows the data on the spreadsheet detailed in the above scenario.

Record *Interface ID *Person *Work Phone *Location *Department *Job Title *Is Supervisor
Number Number Number
1 467436 PERNUMS8 16348773 30010016887961 1001 Agency Staff Y
2 467437 PERNUM9 32178939 30010016887961 1001 Building N
Inspector

#" Note: The above example displays a limited number of fields. For a complete list of fields, refer to the Import
template spreadsheet.

Scenario 3: Updating job functions and their attributes

Consider updating changes to job functions and their attributes of an agency staff in your Public Sector Agency Staff. You
can perform the following actions:

e Assign job functions and attributes

e Assign additional job attributes to existing functions
e Remove job attributes

e Remove job functions

The following example shows the data on the spreadsheet detailed in the above scenario.

*Interface ID *Assignment *Person Agency ID Job Function Job Attribute Attribute

Flag Number ID Value
1 467436 I PERNUMS 1 ORA_BUILDING_I ORA_INSPECTIO! Plumbing
2 467437 D PERNUM9 1 ORA_CASHIER ORA_CASHIER_IL 7574343
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Record *Interface ID *Assignment *Person Agency ID Job Function Job Attribute Attribute

Number Flag Number ID Value

Scenario 4: Updating roles

Consider updating roles of an agency staff in your Public Sector Agency Staff. You can perform the following actions:
e Assign additional roles
* Revoke roles

The following example shows the data on the spreadsheet detailed in the above scenario.

Record Number *Interface ID *Role Action *Person Number *Role Name

1 467436 A PERNUMS8 Employee

2 467437 R PERNUM9 Application
Implementation
Consultant

Scenario 5: Disabling agency staff profile

Consider disabling an agency staff profile in your Public Sector Agency Staff. You can perform the update without having to
make any manual entry in your records. The user interface as well as the Import Agency Staff functionality allow you to disable
agency staff profiles.

The following example shows the Enabled field on the spreadsheet, as detailed in the above scenario.

Record *Interface ID *Person *Work Phone *Location *Department *Job Title Enabled

Number Number Number

1 467436 PERNUMS8 16348773 30010016887961 1001 Building Y
Inspector

2 467437 PERNUM9 32178939 30010016887961 1001 Agency Staff N

#" Note: The above example displays a limited number of fields. For a complete list of fields, refer to the Import
template spreadsheet.
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4 Setting Up Property Information

Setting Up District Types

You add, modify, and delete district types on the District Type page.

Adding a District Type

1. Select Common Setup > District Type .
2. On the District Type page, click Add.
3. On the District Type Details page, enter values for the following fields:

Page Element Description

District Type Enter a unique identifier for the district type.
Description Enter a description of the district type.
District Type Category Select a category for the district type from the system-defined values:

o Inspection

o [Economic Development
o Council

o Zoning

o General

4. Turn the Enabled switch on to make the row available as a lookup value on other pages.
5. Click Save.
Modifying a District Type

1. Select Common Setup > District Type .
2. Click a row on the District Type page.
3. On the District Type Details page you can:

o Update the district type field values.

#" Note: You cannot edit the District Type field.

o Enable or disable the district type using the Enabled switch. Only enabled district types are available to select
as values on other pages.
o Delete the district type. You will be prompted to confirm the permanent deletion.
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#" Note: You cannot delete a district type that is already associated with a district or an inspection
type.

4. Click Save.

Deleting District Types

Select Common Setup > District Type .

Click Edit.

Select the check boxes next to the district types you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

pPODNS

#" Note: You cannot delete a district type that is already associated with a district or an inspection type.

Setting Up Districts

You add, modify, and delete districts on the District page.

Adding a District

1. Select Common Setup > District .
2. On the District page, click Add.
3. On the District Details page, enter values for the following fields:

Page Element Description

District Enter a unique identifier for the district.
Description Enter a description of the district.
District Type Select a district type from the agency-defined values.

See Setting Up District Types.

4. Click Save.

Modifying a District

1. Select Common Setup > District .
2. Click a row on the District page.
3. On the District Details page you can:

o Update the district field values.

#" Note: You cannot edit the District field.
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o Delete the district. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Districts

Select Common Setup > District .

Click Edit.

Select the check boxes next to the districts you want to delete.

Click Delete. You will be prompted to confirm the permanent deletion.

PODMS

Setting Up Parcels

A parcel of real estate is a tract or plot of land.

A parcel that is held by an owner is a property. A parcel location can be found on a map and is associated with a physical
address. An owner or a contracted business can apply for a permit to develop or modify a structure on a parcel, or create a
planning application for planning and zoning requests.

You add and modify parcels on the Parcel page.

Adding a Parcel

1. Select Parcel on the Agency Springboard.
2. On the Parcel page, click Add.
3. In the Basic Information section of the Parcel Details modal page, enter information in the following fields:

Page Element Description

Parcel Number Enter the assessor’s parcel number (APN) for the parcel.

The APN is a number assigned to parcels of real property by the tax assessor of a particular
jurisdiction for identification and record-keeping purposes. The APN is unique within the
jurisdiction, and may conform to certain formatting standards that convey basic identifying
information such as the property type or the location on a map.

Parcel Type Enter a parcel type such as Condo or Single Family Home.

Enabled Turn the Enabled switch on to make the parcel available as a lookup value on other pages.

4. Inthe Land Information section of the Parcel Details modal page, enter details about the land associated with the
parcel using the following fields:

o Jurisdiction

o Property Description
o Primary Zoning ID
o Zoning Description
o Subdivision
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o

Boundary Description

Land Use Code

Parcel Size 1

Parcel Size 1 UOM (parcel size 1 unit of measure)
Parcel Size 2

Parcel Size 2 UOM (parcel size 2 unit of measure)
Structure Size 1

Structure Size 1 UOM (structure size 1 unit of measure)
Structure Size 2

Structure Size 2UOM (structure size 1 unit of measure)

Chapter 4
Setting Up Property Information

5. Inthe Location Information section of the Parcel Details modal page, enter details about the parcel’s location using
the following fields:

o

[e]

(e}

o

Block Number
Unit Number
Lot Number
Section Number

6. Inthe Map Information section of the Parcel Details modal page, enter mapping details for the parcel using the
following fields:

[e]

o

o

[e]

o

o

[e]

Map Name
Map Book Page
Book Number
Latitude
Longitude

X Coordinate

Y Coordinate

7. Click Save.

Modifying a Parcel

1. Select Select Parcel on the Agency Springboard..
2. Select a parcel on the Parcel page.
3. On the Parcel Details page you can:

o

[e]

Update the parcel field values.

Enable or disable the parcel using the Enabled switch. Only enabled parcels are available as lookup values on

other pages.

4. Click Save.

Deleting Parcels

1. Select Select Parcel on the Agency Springboard..
2. On the Parcel page, click Edit.
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3. Select the check boxes next to the parcels that you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

< Note: Agency staff and applicants cannot delete parcels. Only system administrators can delete parcels.
Additionally, only parcels that have not yet been associated with a permit can be deleted.

Related Topics
® Setting Up Parcel Addresses

® Setting Up Parcel Owners
* Working with Parcel Attachments

* Applying Conditions to Parcels

Setting Up Parcel Addresses

A parcel address is the physical address associated with a parcel.
Oracle Public Sector Compliance and Regulation enables you to define parcel addresses by:

1. Adding addresses to existing parcels. You can add multiple addresses to one parcel.

2. Defining addresses that are independent of an existing parcel. After defining these addresses, you can associate
them with one or more parcels.

Adding an Address to an Existing Parcel
You add addresses to parcels on the Parcel Address page.
1. Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Address in the navigation bar.
On the Parcel Address page, click Add.
3. In the Basic Information section of the Parcel Address Details page, you can:

N

o Turn the Enabled switch on to make the row available as a lookup value on other pages.

o Turn the Primary switch on to indicate that this is the primary address associated with the parcel. A parcel
may have only one primary address.

4. In the Address Information section of the Parcel Address Details page, enter the following information:

Page Element Description

Zip Code If you know the zip code for the address, enter it here. The system automatically populates
the City and State based on the zip code you enter.

If you don’t know the zip code, click the don’t know link to narrow down your choice of zip
codes by entering a city and state.
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Page Element Description

Address Line 1 and Address Line Enter the street number or post office box number, along with any additional address

2 information such as apartment or suite number.
City and State Enter the city and state for the address.
Postal Code Enter the postal code for the address. The available values for this field are filtered based on

the city and state that you select.

5. In the Building and Location Information section of the Parcel Address Details page, enter the building and location
details for the parcel address using the following fields:

o Building Type
o Floor

o Unit Number
o Street Number
o Street Name
o Street Direction
o Street Type

o Longitude

o Latitude

o X Coordinate
o Y Coordinate
o Street Suffix
o Crossroad 1

o Crossroad 2
o Landmark

6. Inthe Contact Information section of the Parcel Address Details page, enter the contact information details for the
parcel address using the following fields:

o Name 1 and Name 2
o Email Address
o Home Phone Number
o Work Phone Number
o Cell Phone Number
o Fax Number

7. Click Save.

Adding an Address

You define addresses that are independent of existing parcels on the Address page.

1. Select Property Address on the Agency Springboard.
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2. On the Address page, click Add.

3. In the Basic Information section of the Address Details page, turn the Enabled switch on to make the row available
as a lookup value on other pages.

4. In the Address Information section of the Parcel Address Details page, enter the following information:

Page Element Description

Zip Code If you know the zip code for the address, enter it here. The system automatically populates
the City and State based on the zip code you enter.

If you don’t know the zip code, click the don’t know link to narrow down your choice of zip
codes by entering a city and state.

Address Line 1 and Address Line Enter the street number or post office box number, along with any additional address

2 information such as apartment or suite number.

City and State Enter the city and state for the address.

Postal Code Enter the postal code for the address. The available values for this field are filtered based on

the city and state that you select.

5. In the Building and Location Information section of the Parcel Address Details page, enter the building and location
details for the parcel address using the following fields:

o

o

Building Type
Floor

Unit Number
Street Number
Street Name
Street Direction
Street Type
Longitude
Latitude

X Coordinate
Y Coordinate
Street Suffix
Crossroad 1
Crossroad 2

Landmark

6. Inthe Contact Information section of the Parcel Address Details page, enter the contact information details for the
parcel address using the following fields:

o

o

o

Name 1 and Name 2
Email Address

Home Phone Number
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o Work Phone Number
o Cell Phone Number
o Fax Number

7. Click Save.

Modifying a Parcel Address

1. You modify parcel addresses on the Address Details page. You can access this page two ways.
o Select Property Address on the Agency Springboard.

Select the address you want to modify.
o Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.
Click Parcel Address in the navigation bar.

Select an address associated with the parcel.
2. On the Address Details page you can:

o Update the address field values.

o Enable or disable the address using the Enabled switch. Only enabled parcel addresses are available as
lookup values on other pages.

o Indicate whether this is the primary address associated with a parcel using the Primary switch.
3. Click Save.

Associating Parcels with an Address
1. You associate parcels with addresses on the Parcel page. You can access this page two ways.
o Select Property Address on the Agency Springboard.
On the Address page, select the address for which you want to associate parcels.

Select Parcel in the navigation bar.
o Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.
Click Parcel Address in the navigation bar.
Select an address associated with the parcel.

Select Parcel in the navigation bar.
2. On the Parcel page, click Add.
3. On the Parcel Address Details page, select the parcel that you want to associate with the address in the Parcel ID
field.
4. (Optional) If you want this address to be the primary address for the parcel, turn on the Primary switch.
5. Click Save.
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Deleting Parcel Addresses

1. You can delete parcel addresses from the Addresses and Parcel Addresses pages.
o Access the Addresses page by selecting Property Address on the Agency Springboard.
o Access the Parcel Addresses page by selecting Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Address in the navigation bar.
2. Click Edit.
3. Select the check boxes next to the parcel addresses that you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Parcel Owners

You add, modify, and delete parcel owners on the Parcel Owner page.

Adding a Parcel Owner

1. Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.
2. On the Parcel Owner page, click Add.
3. In the Basic Information section of the Parcel Owner Details page, enter information in the following fields:

Page Element Description
Enabled Turn the Enabled switch on to make the row available as a lookup value on other pages.
Primary Turn the Primary switch on to indicate that this is the primary owner associated with the

parcel. A parcel may have only one primary owner.

Owner and Secondary Owner Enter the names of the owner and secondary owner of the parcel.

Owner Type Enter the type of owner for the parcel such as Personal or Town.

4. Inthe Location Information section of the Parcel Owner page, enter details about the location associated with the
parcel owner using the following fields:

Page Element Description

Zip Code If you know the zip code of the owner’s address, enter it here. The system automatically
populates the City and State based on the zip code you enter.

If you don’t know the zip code, click the don’t know link to narrow down your choice of zip
codes by entering a city and state.
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Address Line 1 and Address Line Enter the street number or post office box number, along with any additional address
2 information such as apartment or suite number.
City and State Enter the city and state of the owner’s address.
Postal Code Enter the postal code for the owner’s address. The available values for this field are filtered

based on the city and state that you select.

Street Number, Street Direction, Enter the street information for the parcel owner.
Street Name, and Street Type

Building Type Enter the type of building associated with the parcel owner.
Floor Enter the floor of the building for the parcel owner.
Unit Number Enter the unit number for the parcel owner.

5. In the Contact Information section of the Parcel Owner Details page, enter the contact information details for the
parcel owner using the following fields:
o Email Address
o Home Phone Country Code
o Home Phone Number
o Work Phone Country Code
o Work Phone Number
o Cell Phone Country Code
o Cell Phone Number
o Fax Country Code
o Fax Number
6. In the Transfer Information section of the Parcel Owner Details page, enter transfer details for the parcel owner using
the following fields:
o Last Transfer Type
o Document Number
7. Click Save.

Modifying a Parcel Owner
1. Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.
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Select an owner associated with the parcel.

" Note: Select Property Owneron the Agency Springboard to select a parcel owner to modify from a list of
all parcel owners.

2. On the Parcel Owner Details page you can:

o Update the parcel owner field values.

o Enable or disable the parcel owner using the Enabled switch. Only enabled parcel owners are available as
lookup values on other pages.

o Indicate whether this is the primary owner associated with the parcel using the Primary switch.
3. Click Save.

Deleting Parcel Owners
1. Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.

On the Parcel Owner page, click Edit.

Select the check boxes next to the parcel owners that you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

wn

Associating Parcels with Districts

You add, modify, and delete relationships between parcels and districts on the Parcel District page.

The association of parcels with districts is required setup for inspection scheduling. For more information, see Setting Up
Inspection Scheduling.

Adding a Parcel District Relationship
1. Select Property Information > Parcel .
Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.
2. On the Parcel District page, click Add.
3. On the Parcel District Details page, enter the district you want to associate with the parcel in the District field.
4. Click Save.

Modifying a Parcel District Relationship
1. Select Property Information > Parcel .

Select a parcel on the Parcel page.
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Click Parcel District in the navigation bar.
2. Select a district on the Parcel District page.
3. On the Parcel District Details page you can:

o Select a different district to associate with the parcel.

o Delete the parcel district relationship. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Parcel District Relationships

1. Select Property Information > Parcel .

Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.

N

Click Edit.

i

Select the check boxes next to the parcel district relationships you want to delete.

4. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Parcel Values

You add, maodify, and delete parcel values on the Parcel Value page.

Adding a Parcel Value

1. Select Common Setup > Parcel Value .

2. On the Parcel Value page, click Add.

3. On the Parcel Value Details page, enter information in the following fields:

Page Element Description

Parcel ID

Enter the ID of the parcel for which you are defining an address.

For more information on parcels, see Setting Up Parcels.

Effective Start Date and Effective
End Date

Enter the date range for which the parcel value is valid.

# Note:
You can leave the Effective End Date field blank to give the parcel an open end
date.

Parcel Size 1 and Parcel Size 1
UOM (parcel size 1 unit of measure)

Enter a numeric value and a unit of measure to define the size of the parcel.

Parcel Size 2 and Parcel Size 2
UOM (parcel size 2 unit of measure)

ORrRACLE

Enter a numeric value and a unit of measure to define an additional size for the parcel.
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Land Value Enter the monetary value of the land associated with the parcel.
Improvement Value Enter the monetary value of any improvements made to the parcel.
Personal Property Value Enter the monetary value of any personal property associated with the parcel.
Fixtures Enter the monetary value of any fixtures associated with the parcel.
Owner Exemption, Fixture Enter the monetary value of any exemptions associated with the parcel.

Exemption, and Other Exemption

Net Assessed Value Enter the assessed monetary value of the parcel.

Currency Code Enter the currency that applies to the parcel value.

Property Use Code Enter the property use code associated with the parcel.

Parcel Number Displays the parcel number associated with the Parcel ID that you selected.
4. Click Save.

Modifying a Parcel Value

1. Select Common Setup > Parcel Value .
2. Click a row on the Parcel Value page.
3. On the Parcel Value Details page you can:

o Update the parcel value field values.

" Note: You cannot edit the Parcel ID and Effective End Date fields.

o Delete the parcel value. You will be prompted to confirm the permanent deletion.
4. Click Save.
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O Setting Up Custom Subject Areas

Custom Subject Areas

Oracle Public Sector Compliance and Regulation Cloud contains prebuilt subject areas, but you can also create your own
subject area for your unique reporting needs.

The subject areas that you create is called a custom subject areas.

Concepts and Terminology in Custom Subject Areas

Before creating a custom subject area, you should understand the concepts and terminology used with custom subject
areas. These concepts are discussed in their related topics in detail.

e Objects: Objects within Oracle Public Sector Compliance and Regulation Cloud represent an entity; for example, a
contact list. When you create entities such as permit types within Oracle Public Sector Compliance and Regulations,
you create custom objects.

¢ Fields or attributes: A field, also called an attribute, is where entity information is stored. A contact type is stored in
a field under the contact list entity or object.

e Measures: Measures are a set of functions that you can apply on date, numeric, or currency type fields of the
selected primary or child objects while defining a custom subject area.

e Date Leveling: Date leveling is a date hierarchy representation between dates and their associated measures. For
example, total actual annual gross revenue by month.

Creating Custom Subject Areas

This topic covers how you create and edit custom subject areas, and how you can activate or inactivate a custom subject
area while editing.

You cannot modify a predefined report subject area, however, you can create custom subject areas to meet your reporting
needs.

#" Note: Before you create a custom subject area, review all the included subject areas to see if the one you want
is already available.

Adding a Custom Subject Area

You add custom subject areas using train stops that appear at the top of the page. These train stops enable you to move
back and forth during the configuration process. You can also save your configuration at a logical point and then continue to
create later.

#" Note: You can only create custom subject areas when you are not in an active sandbox.
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To create a custom subject area using train stops:

1.

Navigate to Application Composer.

2. Click Custom Subject Areas on the Overview page of Application Composer.
3. Select Create from the Actions menu.

These are the steps in the train stops that you can use for configuring your custom subject area:

1.

Define Custom Subject Area

In this step, you provide the name for your subject area and select the primary object that is the basis for the reports
you create later using the custom subject area. Subject areas usually have names or labels that correspond to the
type of information they contain. Display labels have the Custom: prefix added automatically.

Select Child Objects

In this step, you select the child objects whose data you want to use in your reports. You can add child objects only
if the primary object has child objects. Otherwise, the add icon is disabled. You can only add one child object per
level. The parent-child-grandchild-grand grandchild hierarchy supports adding up to three levels of child objects with
one child object at each level, for example, parent-child1-child1.1-child1.1.1.

Configure Fields

In this step, you select the fields that you want to display on your reports. You typically add at least one field from
each of the objects that you have selected for your custom subject area.

Select the desired measures to generate for number, date, or currency fields from all the available objects so that the
subject area includes only those measures that you want to analyze. Also, define at least one measure.

In the Measure Aggregations column, select an option from the list of predefined formulas that you can apply to
the Measure field. When you select the formula, the application applies the selected formulas to the selected field
and measures.

" Note: You can choose measures only for the lowest child. For example, if only a primary object exists with
no children, you can select measures for the primary object. Otherwise, if any child objects exist, you can
select measures only at the lowest child object level, not for the parent object.

You can change the display labels of the fields that you select in this step. Additionally, you can use the Select Fields
dialog to remove fields that belong to the primary object. The Select Fields dialog appears when you click Select
Fields when configuring fields for your custom subject area.

After you publish your custom subject area, the fields you have selected for your subject area are automatically
added to their owning object's folder. If you have also defined measures, those fields are automatically added to the
Facts folder. If you did not define a measure, then one is automatically created for the custom subject area.

For more information on measures, see Measures.
Configure Date Leveling

If required, select the Date columns for date leveling. For more information on date leveling, see Date Leveling.
Configure Security

Select the required security level for the Everyone Role Name, which is added by default, or add additional Role
Names by clicking in the + icon and define the security level for each one of them.
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The security definition here only controls who can access the custom subject area definition to create reports. It
doesn't control data visibility which is automatically controlled based on the user running the reports.

For more information on securing custom subject areas, see Custom Subject Area Security.
Review and Submit

Review the custom subject area configuration for all added objects, attributes, and measures, and if satisfied, click
Submit. If changes are required click Back to navigate back to the required screen.

After you submit, the custom subject area configuration is prepared for publishing. You can create and submit a
custom subject area either immediately or save and close the custom subject area at any point and submit it later.
You must first submit a custom subject area for publishing before you can select it from within Oracle Bl Composer.
After you save or submit a custom subject area, you cannot modify its primary object.

To access the published custom subject area in Bl:

o From the Navigator menu, select Tools > Reports and Analytics .
o Inthe Contents pane, click Create.
o Select the published custom subject area and start creating your report.

Editing Custom Subject Areas

You can edit a published or saved custom subject area and then republish it when your changes are done. Modifying a
custom subject area does not affect the reports that you had created using that custom subject area before making the
changes. You can use the modified custom subject area if you need to enhance existing reports.

To edit a custom subject area:

1.
2.

3.

On the Overview page of the Application Composer, click Custom Subject Areas.
Locate the custom subject area that you want to edit, and click the Edit icon.

You can filter out inactive custom subject areas in Application Composer by viewing custom subject areas in Active
status. This is safer than deleting them, because the inactive subject areas are still available and can be found by
searching.

Make the desired changes and then click Submit to republish the custom subject area.

While you can edit a custom subject area in any status, there are considerations on what you can or can't do when editing.
When editing a published custom subject area, it is not possible to:

}’“

Change the primary object.
Add or remove child objects.
Remove previously added measures.

Add more aggregation types for measures that are already published.

Note: You cannot modify a predefined report subject area. Instead, you must create separate custom subject
areas to meet your reporting needs. Before you create a custom subject area, be sure to review all the included
subject areas to see if the one you want is already available.
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Activating or Inactivating Custom Subject Areas

When editing custom subject areas, you can activate or inactivate custom subject areas when your reporting or business
requirements change. This step enables you to control what information is displayed on the reports that use the information
from custom subject areas.

You can inactivate only those custom subject areas that are published and have a status of OK, and can activate only
previously inactivated custom subject areas.

To inactivate a custom subject area, select it in the list and then click the Inactivate button. To activate an inactive custom
subject area, select it and click Activate. Note that if no custom subject area is selected in the list, the button doesn't
appear.

When searching for custom subject areas, you can filter out inactive custom subject areas in Application Composer by
viewing only those in Active status. Inactivating a custom subject area is safer than deleting it, because the inactive subject
areas are still available and can be found by searching.

Objects in Custom Subject Areas

This topic covers how you use the various types of objects in the Application Composer to create custom subject areas.
A custom subject area is a set of entities (objects), attributes, and measures that you use to build reports.

Objects can be classified under broad categories of custom objects and standard objects. Every custom subject area has
a primary object, which is the focus of any reports that you create. You can also optionally add child objects to the custom
subject area. Custom subject areas support both custom and standard objects. The objects that you create are called
custom objects.

Before designing your custom subject area, use Intake Form Designer to identify or create the objects and fields that you
want to use.

Primary Objects

A primary object is any top-level object. You create a custom subject area based on the primary object. Additionally, the
primary object is the focus of the report that you create based on the custom subject area.

The list of available primary objects includes all objects, which are either top-level custom objects, or standard objects that
are configured by the owning application. After you save your custom subject area, you can't change its primary object; but
you can create another custom subject area using a different primary object.

Based on how you want to configure your custom subject area, you can add one child to an object.

Child Objects

A child object is an object that has a one-to-many relationship with a parent object and can be a parent object of another
child object. Add a child object to a custom subject area if you want your report to include data from both the primary object
and its children. If an object's parent object is already a child object (of another parent object) then the object is a grandchild
object. For example, if object Y is a child of object X, and object Z is a child of object Y, then object Z is a grandchild of object
X. Custom subject areas support parent-child-grandchild-great-grandchild objects.

You can only add one child object to the primary object per level, as long as there are child objects available. If there are no
child objects for the chosen primary object, the list that enables selecting child objects does not appear.
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The parent-child-grandchild-great-grandchild hierarchy supports adding up to three levels of child objects with one child
object at each level; for example, parent-child1-child1.1-child1.1.1.

" Note: Once you publish a custom subject area, you can't add or remove child objects.

Fields or Attributes in Custom Subject Areas

This topic explains the various types of fields or attributes that you use for configuring your custom subject area.

Fields or attributes store entity information in the application. Fields can be standard or custom.

Types of Reporting Fields

The fields you can use to create reports are as follows:

e Text

e Number

e Date

e Percentage

e Date time

e Currency

e Check box

e Fixed choice list

e Dynamic choice list
e Long text

# Note: You cannot create reports using the Rich text area field.
When you create a custom field, you can create reports for the following data types:

e Boolean

#" Note: Note: If you are using the Boolean data type for fields other than check boxes, those fields are
displayed as either O or 1 on your custom reports.

e Number

e Currency
e Date

e String

e Percentage
* Phone

e Date time
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e Long text

Measures

Measures are a set of functions. Examples include a SUM of the actual gross revenue in USD, or a COUNT of the number of
building permits worth over $500,000.

The designer defines the aggregation function (SUM, COUNT, and so on) for custom measures, so end users don't need to
do so themselves when they create an analysis. You can apply these functions on fields of type Date, Numeric, or Currency.

Measures available to a particular type of field may differ depending on the field type. After you define the measures for the
required fields and publish the custom subject area, you can select these fields and the applied measures when creating your
report in the Oracle Bl Composer. You can only specify aggregate formulas to apply to a measure when creating a custom
subject area. It is not possible to edit a measure in an already published custom subject area.

Here are some measures you can apply to fields of type Numeric, Currency, or Date.

e For Numeric and Currency fields, a measure can be:

o All

# Note: Allis not a measure, but an option in the Ul that selects all of the measures.

o Sum: Calculates the sum of the values.
o Average: Calculates the mean value.
o Count: Calculates the number of rows that are not null.

o Count Distinct: Calculates the number of rows that are not null. Each distinct occurrence of a row is counted
only once.

#" Note: Although Count Distinct is usually used in cases requiring a count on a foreign key (because

a count of distinct rows is what's wanted), it is not required. If your requirements allow multiple
instances of the same foreign key value to be counted multiple times, you can use Count rather than
Count Distinct.

o Maximum: Calculates the highest numeric value.

o Minimum: Calculates the lowest numeric value.

o First: Selects the first occurrence of the item.

o Last: Selects the last occurrence of the item.

o Median: Calculates the middle value.

o Standard Deviation: Calculates the standard deviation to show the level of variation from the average.

o Standard Deviation Population: Calculates the standard deviation using the formula for population variance
and standard deviation.

e For Date fields, a measure can be:

o All
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o Maximum
o Minimum

You can select measures based on your reporting needs. For example, you can use measures to view product sales per
store, state, or country. Or, to view the number of support tickets opened or closed per day, week, or month, and so on.

If you do not define a measure, then one will be automatically created for the subject area when you submit the custom
subject area for publication.

Date Leveling

Date leveling is a hierarchy representation of dates and associated measures, which enables you to view the data over
different periods of time.

To use this hierarchy, create a report that shows the total Actual Gross Revenue amount for each year. Drill down from year
to show gross revenue per quarter, sales per month, gross revenue per week and gross revenue per day, and then drill back
up to gross revenue per year. The date hierarchy aggregates the measures by the required hierarchy or leveling period.

To configure date leveling when defining a custom subject area, use the Configure Date Leveling step of the train stop to
either allow or disallow leveling. You may need to expand the field list in the Date field to select or clear the Date Leveling
check box, as applicable.

For more information on where the Configure Date Leveling step appears in the train stop, see Creating Custom Subject
Areas.

Custom Subject Area Security

You can secure a custom subject area by granting or revoking access rights from the role names that access the custom
subject area. This topic covers how you can add or delete role names, or grant or revoke access rights from those role
names.

You can also add role names from a predefined list and assign or revoke permissions.

Managing Role Names and Access Rights

While defining a custom subject area using the train stops, you can use the Actions list in the Configure Security step to
manage role names and access rights as follows:

e Select and add role names for a custom subject area from a predefined list of role names. This predefined list also
provides the description for each role name. You can also select and add multiple role names from this predefined
list using either the Shift or Ctrl keys. Once you add a new role name, you can select appropriate access for that
role name.

e Select and delete role names listed for a custom subject area. You can also select and delete multiple role names
using either the Shift or Ctrl keys.

#" Note: You cannot delete the role name listed as Everyone.
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e Read access is granted by default to each role name you add. If you want to revoke Read access from a listed role
name, select No access for that role name.

" Note: You can create custom subject areas even for the objects in which you do not have access to the data,
which allows you to build custom subject areas without compromising data security.

Publication Statuses of Custom Subject Areas

This topic covers what happens when you submit a custom subject area for publishing, and what the submission statuses
indicate.

After you successfully publish your custom subject area, you can start building reports using Oracle Business Intelligence (Bl)
Composer based on your published subject area.

What Happens When You Submit for Publishing

When you submit a custom subject area for publishing, two processes occur in the background. The first process is
synchronous and creates Oracle Applications Development Framework (Oracle ADF) artifacts. You must wait until this first
process is over. The second process is asynchronous and creates centralized metadata repository (RPD) fragments and
submits them to the Oracle Bl server.

" Note: You must refresh the status to know whether the custom subject area is submitted successfully. You
may have to refresh the status multiple times, because the creation of Oracle ADF and RPD artifacts may require
some time.

A custom subject area can have one of the following statuses:

e Pending: This status indicates either of the following:

o You saved and closed the configuration process for a custom subject area before submitting it for publishing.

o A failure occurred in the background processes when creating Oracle ADF and RPD artifacts.
¢ In Process: This status indicates that the data is in the process of being published to Oracle BI.

Note: If the in-process status doesn't change to OK, even after multiple refresh attempts, then there could be
an error in publishing. If an error occurs, then the details are displayed, as well as information about how to fix
problems, where applicable. These error status details allow you to pinpoint and fix problems quickly.

e OK: This status indicates that the custom subject area has been published successfully. You can use Oracle Bl
Composer to create reports using the objects, attributes, and measures that you have configured in the subject area.

Including Custom Fields on Reports

This topic discusses how to create a custom subject area using an attribute and create a report.
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Creating a Custom Subject Area

In this example, you create a custom subject area using the LNP1KitchenRemodel object.

1.
2.
3

ok

—
cooN©O

11.
12.
13.
14.
15.

16.
17.

18.
19.
20.

21.
22.
23.
24,
25.

26.

If you are working in a sandbox, exit the sandbox.
Click the Navigator menu at the top.
Click the Application Composer link.

#" Note: You might need to click the more >> link first.

You are on the main page of Application Composer, where you create a custom subject area using the
LNP1KitchenRemodel object.

Change the Application from CRM Cloud to ERP and SCM Cloud.

In the Overview region, click the Custom Subject Areas link.

You are on the Custom Subject Areas page. You can use this page to search or create custom subject areas.
In the Search Results region, click the Create button.

Enter a name for the custom subject area that you are creating. Enter Kitchen Remodel in the Label field.

In the Primary Object region, click the Primary Object list.

Click the LNP1KitchenRemodel list item.

In the upper-right region of the page, click the Next button.

In the upper-right region of the page, click the Add Child Object button.

In the Add Child Object dialog box, click the Child Object list.

Click the ContactList list item.

Click OK.

In the upper-right region of the page, click Next.

You now define the fields for the LNP1KitchenRemodel primary object.

Ensure that the selected value in the Fields Fromlist is LNP1KitchenRemodel. Click the Select Fields button.
On the Select Fields modal page, select the fields that you want to include for the LNP1KitchenRemodel primary
object.

Repeat steps 16 and 17 for the ContactList child object.

In the upper-right region of the page, click Next.

You now select fields to apply date leveling. In the Date Field Leveling table, click the Expand button of the
LNP1KitchenRemodel object.

Select the Allow Leveling option for the Business Start Date field.

In the upper-right region of the page, click Next.

Leave the default role access of Read for Everyone. In the upper-right region of the page, click Next.

Review your custom subject area. In the upper-right region of the page, click Save.

In the upper-right region of the page, click Submit.

A confirmation message appears.

Click OK.

You successfully created a custom subject area.

Creating a Report Using a Subject Area

In this example, you create a report in Oracle Business Intelligence Composer (Bl Composer) using the Kitchen Remodel
subject area.

1.

Click the Navigator menu at the top.
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2. Click the Reports and Analytics link under Tools.
Note: You might need to click themore >> link first.

The Reports and Analytics page appears.
3. Inthe left pane, click Create and select Analysis.

From the Select Subject Area dialog box that appears, you must first select a subject area to build your report. In this
activity, you are building a report using the Kitchen Remodel subject area.
4. In the Select Subject Area dialog, select the check box next to Custom:Kitchen Remodel and click Continue.

Tip: You can add more than one subject area to a report by selecting the check box next to additional subject areas.
5. You are in the Select Columns step of Oracle Business Intelligence Composer (Bl Composer) wizard. In the left box,
click the Expand button of the Custom:Kitchen Remodel tree.
6. Add the following fields to the Selected Columns box on the right:

RecordNumber under LNP1KitchenRemodel tree.
Submission Date under LNP1KitchenRemodel tree.
Status under LNP1KitchenRemodel tree.
Expiration Date under LNP1KitchenRemodel tree.
Female Owned under LNP1KitchenRemodel tree.
First Name under ContactList tree.
Last Name under ContactList tree.
Gender under ContactlList tree.
Phone Number under ContactList tree.

j- State under ContactList tree.
7. Inthe upper-right region of the page, click Next.

~TQ@~0Q20T0D

You are in the Select Views step of the wizard.
8. Enter Kitchen Remodel Permits in the Title field.
9. Click the Table list.
10. Click the Table (recommended) list item.
11. Click the Preview option on the right of the Title field to view a preview of the table. Click OK.
12. In the upper-right region of the page, click the Next button.

You are in the Edit Graph step of the wizard.
13. In the upper right region of the page, click Next.
14. You are in the Sort and Filter step of the wizard.
15. In the upper right region of the page, click Next.

You are in the Highlight step of the wizard.
16. In the upper right region of the page, click Next.

You are in the Save step of the wizard.
17. Enter Kitchen Remodel Permits in the Analysis Name field.
18. In this activity, you will save your report in only My Folders. In the Save In areg, click the My Folders tree.
19. In the upper right region of the page, click Submit.

A confirmation message appears.
20. Click OK.
21. You can now view the report you just created. Click the Expand button of the My Folders tree.
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22. |ocate the report you just created.

You successfully created a report in Bl Composer using the Kitchen Remodel subject area.

Custom Subject Areas: Frequently Asked Questions

This topic provides answers to some frequently asked questions regarding custom subject areas.

Can | change a custom subject area's primary object?

No. Once you save a custom subject area, you cannot change its primary object; however, you can create a new custom
subject area with a different primary object.

What happens if | change a custom subject area after it is published?

You can edit a published custom subject area and then republish it after your changes are done. Modifying a custom subject
area does not affect the reports that you created using that custom subject area before making the changes. You can use the
modified custom subject area should you need to enhance existing reports.

#" Note: You cannot edit a primary object when you modify a custom subject area. Should you need to do so,
create a new custom subject area using a different (new) primary object.
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O Setting Up Comments

Managing Comments

This topic provides an overview about Standard Comments and discusses how to manage Comments.

Standard Comments: Overview

Standard comments are pre-defined comments that users can easily and quickly use, instead of manually entering the text.
Standard comments are generic and complete, which make them reusable.

Users can use Standard Comments across all Public Sector Compliance and Regulation offerings. You can use Standard
Comments while updating your applications.

System Administrators set up application categories and subcategories using the Application Category page, based on the
type of comments you wish to have. Standard Comments are set up using the Standard Comments page.

Managing Comments

You manage the Comments by setting up how you want the comments to be available for the agency staff members.

1. Select Comments > Manage Comments .
2. On the Manage Comments page, you add values to all these fields:

Page Element Description

Number of days comment is Enter a numeric value or use the increment/decrement buttons. The number of days a
recent comment is listed as Recent is based on the value in this field.

Rich Text Editor Use the switch to enable or disable Rich Text Editor formatting for comments.
Comment Summary Length Enter a numeric value or use the increment/decrement buttons. This value determines the

maximum number of characters that can be displayed in the Comment Summary field.

# Note:
The system allows a maximum length of two hundred (200) characters in the
comment summary.

3. Click Save to save the changes.
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Setting Up Standard Comment Categories and
Subcategories

This topic discusses how to set up Standard Comment Categories and Subcategories.

Setting Up Standard Comment Categories and Subcategories

You set up the comments categories and subcategories on the Application Category page.

1. Select Comments Setup > Comment Categories .

On the Application Category page, click Add to add a new category.
2. On the Application Category Details page, you add values to all these fields:

Field Name Description

Application Category Enter a category.

Description Enter a description for the category. This description displays detailed information about the
category when searching for categories.

3. Turn on the Enabled switch if you want to enable this category when you save it. The switch is turned off by default
for a new category.

In the Application Groups section, you can include application groups that you want this category to be available for.
Click Add to open the Application Group Details page, select the application group.

Turn on the Enabled switch if you want to enable the selected group when you save the page.

Click Save to save the newly added application group and return to the Application Category Details page.

To add an application subcategory, select the Application Subcategories section and click Add.

On the Application Subcategory Details page, you add values to all these fields:

&

O NOo O

Field Name Description

Application Subcategory Enter a subcategory

Description Enter a description for the subcategory. This description displays detailed information about
the subcategory when searching for subcategories.

9. Turn on the Enabled switch if you want to enable this subcategory when you save it. The switch is turned off by
default for a new subcategory.
10. Click Save to save the newly added application subcategory and return to the Application Category Details page.
11. Click Save to save the record and return to the Application Category page.

Modifying Standard Comment Categories and Subcategories

You modify the comments categories and subcategories on the Application Category Details page.

1. Select Comments Setup > Comment Categories .
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On the Application Category page, click the chevron on a category line to select and modify the category.

On the Application Category Details page, enter new values in the Application Category and Description fields.
Verify that the Enabled switch is turned on if you want to enable this category when you save it.

Use the Application Groups section to select the application group that you want this category to be available for.
In the Application Subcategories section, you can edit the application subcategories.

Click Save to save the changes. You can use the Delete button to delete the category.

NookroDd

Viewing, Adding, Modifying, and Deleting Standard
Comments

This topic discusses how to view, add, modify, and delete Standard comments.

Viewing Standard Comments

You search and view Standard Comments on the Standard Comments page.

1. Select Comments Setup > Standard Comments .
2. Use the application category or application subcategory fields to filter comments on the Standard Comments page.

Adding Standard Comments

You add comments using the Add button on the Standard Comment page.

1. Select Comments Setup > Standard Comment

On the Standard Comments page, click Add to open the Standard Comment Details page and add a new
comment.

3. On the Standard Comment Details page, enter values for these fields:

Page Element Description

Comment Code Enter a comment code.
Application Category Enter an application category
Application Subcategory Enter an application subcategory
Description Enter a comment.

4. Verify that the Enabled switch is turned on if you want to enable this comment when you save.
5. Click the Save button to save the new comment and return to the Standard Comment page.

Modifying Standard Comments

You modify comments on the Standard Comment Details page.
1. On the Standard Comments page, click the chevron on a comment line to select and modify the comment.
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2. To modify the comment, you can change the values entered in the Application Category and Application
Subcategory fields, and edit the description.

3. Verify that the Enabled switch is turned on if you want to enable this modified comment when you save.
4. Click Save.

Deleting Standard Comments

You delete comments on the Standard Comment Details page.

1. On the Standard Comments page, click the chevron on the comment line which you want to delete.
2. On the Standard Comment Details page, click the Delete button to delete the comment.
3. Click Yes on the confirmation page to delete the comment and return to the Standard Comments page.
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