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Preface

This preface introduces information sources that can help you use the application and this guide.

Using Oracle Applications

This topic explains the text conventions used in this guide and points you to where you can find more information about using
Oracle applications.

Conventions

The following table explains the text conventions used in this guide.

Convention Meaning

boldface Boldface type indicates user interface elements, navigation paths, or values you enter or select.
monospace Monospace type indicates file, folder, and directory names, code examples, commands, and URLs.
> Greater than symbol separates elements in a navigation path.

Additional Resources

e  Community: Use Oracle Cloud Customer Connect to get information from experts at Oracle, the partner
community, and other users.

e Guides and Videos: Go to the Oracle Help Center to find guides and videos.
e Training: Take courses on Oracle Cloud from Oracle University.

Documentation Accessibility

This topic covers accessibility concepts for this guide.
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website.

Videos included in this guide are provided as a media alternative for text-based help topics also available in this guide.

Contacting Oracle

This topic explains how to contact Oracle for support and to provide feedback.

ORrRACLE


https://appsconnect.custhelp.com/
http://docs.oracle.com/
http://education.oracle.com/pls/web_prod-plq-dad/db_pages.getpage?page_id=906
https://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc

Oracle Public Sector Compliance and Regulation Cloud

Preface
Implementing Community Development

Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For
information, visit My Oracle Support or visit Accessible Oracle Support if you are hearing impaired.

Comments and Suggestions

Please give us feedback about Oracle Public Sector Compliance and Regulation applications help and guides! You can send
an e-mail to: PSCR_US@oracle.com.
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1 Setting Up Transactions

Setting Up Transaction Groups

Transaction groups are the first level of categorization that you can select when you define your permit and planning
application types.

If desired, you can set up transaction groups. This setup is not required.

Adding Transaction Groups

You add transaction groups for permits and planning applications on the Transaction Group page.

1. Select Common Setup > Transaction Group .
2. On the Transaction Group page, click Add to add a new group.
3. On the Transaction Group Details page, enter a values for the group.

Page Element Description

Group Enter a group name for the permit or planning application types.
Description Enter a description of the group.
Applicable Classification Select a product area from these options:

o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new transaction group.
5. Click Save.

Modifying Transaction Groups

You can modify transaction groups for permits and planning applications on the Transaction Group page.

1. Select Common Setup > Transaction Group .

2. On the Transaction Group page, select the row for the group that you want to modify.

3. On the Transaction Group Details page you can:
o Edit the description. You cannot change the group name.
o Select the Applicable Classification check box for permits or planning and zoning.
o Click the Enabled switch to enable or disable the transaction group.

4. Click Save to save any changes.
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Deleting Transaction Groups

You can delete transaction groups for permits and planning applications on the Transaction Group page.

Select Common Setup > Transaction Group .

On the Transaction Group page, select the row for the group that you want to delete.

If you want to delete the group, click the Delete button.

If you want to delete multiple groups, you can delete them from the grid on the Transaction Group page:

a. Click the Edit icon.
b. Select the check boxes for the transaction group rows to delete.
c. Click the Delete icon.

pPODM

Setting Up Transaction Categories

Transaction categories are the second level of categorization that you can select when you define your permit and planning
application types.

If desired, you can set up permit and planning application transaction categories. This setup is not required.

Adding Transaction Categories

You can add transaction categories for permits and planning and applications on the Transaction Category page.

1. Select Common Setup > Transaction Category .
2. On the Transaction Category page, click Add to add a new transaction category.
3. On the Transaction Category Details page, enter a values for the transaction category.

Page Element Description

Category Enter a category name for the permit or planning application type.
Description Enter a description of the category.
Applicable Classification Select an offering from these options:

o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new category.
5. Click Save.

Modifying Transaction Categories

You can modify transaction categories for permits and planning applications on the Transaction Category page.

1. Select Common Setup > Transaction Category .
2. On the Transaction Category page, select the row for the category that you want to modify.
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3. On the Transaction Category Details page you can:
o Edit the description. You cannot change the category name.
o Select the Applicable Classification check box for permits or planning and zoning.
o Click the Enabled switch to enable or disable the transaction category.

4. Click Save to save any changes.

Deleting Transaction Categories

You can modify transaction categories for permits and planning applications on the Transaction Category page.

Select Common Setup > Transaction Category .

On the Transaction Category page, select the row for the category that you want to delete.

If you want to delete the category, click the Delete button.

If you want to delete multiple categories, you can delete them from the grid on the Transaction Category page:
a. Click the Edit icon.
b. Select the check boxes for the transaction category rows to delete.
c. Click the Delete icon.

pON2

Setting Up Transaction Subcategories

Transaction subcategories are the third level of categorization that you can select when you define your permit and planning
application types.

If desired, you can set up permit and planning application type subcategories. This setup is not required.

Adding Transaction Subcategories

You can add transaction subcategories for permit and planning application types on the Transaction Subcategory page.

1. Select Common Setup > Transaction Subcategory .
2. On the Transaction Subcategory page, click Add to add a new transaction subcategory.
3. On the Transaction Subcategory Details page, enter values for the transaction subcategory.

Page Element Description

Subcategory Enter a subcategory name for the permit or planning application type.
Description Enter a description of the subcategory.
Applicable Classification Select a product area from these options:

o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new subcategory.
5. Click Save.

ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 1
Implementing Community Development Setting Up Transactions

Modifying Transaction Subcategories

You can modify transaction subcategories for permit and planning application types on the Transaction Subcategory page.

1. Select Common Setup > Transaction Subcategory .
2. On the Transaction Subcategory page, select the row for the subcategory that you want to modify.
3. On the Transaction Subcategory Details page you can:

o Edit the description. You cannot change the subcategory name.

o Select the Applicable Classification check box for permits or planning and zoning.
o Click the Enabled switch to enable or disable the transaction subcategory.
4. Click Save to save any changes.

Deleting Transaction Subcategories

You can modify transaction subcategories for permit and planning application types on the Transaction Subcategory page.

Select Common Setup > Transaction Subcategory .
On the Transaction Subcategory page, select the row for the subcategory that you want to delete.
If you want to delete the subcategory, click the Delete button.
If you want to delete multiple subcategories, you can delete them from the grid on the Transaction Subcategory
page:
a. Click the Edit icon.
b. Select the check boxes for the transaction subcategory rows to delete.
c. Click the Delete icon.

PN

Setting Up Transaction Statuses

Oracle provides a set of statuses for transactions to control system events. Some system statuses can be mapped to a user-
defined transaction status.

Your agency assigns statuses for permit and planning applications. You cannot delete the system-delivered transaction
statuses, but you can modify the description. You can also define additional transaction statuses, but you must associate any
new transaction status with one of the system-delivered statuses to ensure correct processing.

For information about permit inspection statuses, see Setting Up Inspection Statuses.

For information about permit plan review statuses and decision statuses, see Setting Up Plan Review Statuses.

Using Delivered Transaction Statuses

This table lists the system-delivered transaction statuses and indicates whether they can be associated with a user-defined
status.

Transaction Status System Status Code Type of Transaction Can be mapped to a user-

defined record status?

About to Expire ATE Both No
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Transaction Status System Status Code Type of Transaction Can be mapped to a user-

defined record status?

Certificate of Occupancy CO0O Permit Application Yes

Completed CMP Both Yes
Delinquent DLQ Both No
Denied DNI Both Yes
Expired EXP Both No
Hearing HER Planning Application Yes
In Process IPC Both Yes
Inspection INS Permit Application Yes
Payment Pending PAY Both No
Pending PND Both No
Pending Submittal PDS Both No
Permit Issued PTI Permit Application Yes
Plan Review PLR Permit Application Yes
Submitted SUB Both No
Voided VOD Both Yes
Withdrawn WTH Both No

When a guest submits a permit application or a planning application, the transaction status is updated as follows:

Record and System Status Description

Pending (PND) Applied when the guest saves an application.

Pending Submittal (PDS) Applied when the guest submits the application and workflow can’t be started.
Payment Pending (PAY) Applied when fees are due.

Submitted (SUB) ¢ Applied when no fees are due.
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Record and System Status Description

e Applied after successful payment.

Adding Transaction Statuses

Define any additional statuses that your agency will use for permit and planning applications on the Transaction Status page.
You must associate a new transaction status with a system status.

Select Common Setup > Transaction Status .
You can select from these transaction statuses:

N =

o Permit Status

o Planning Status

For information about inspection statuses, see Setting Up Inspection Statuses.

For information about plan review statuses and decision statuses, see Setting Up Plan Review Statuses.
3. Click Add to define a new transaction status.
4. On the respective transaction details page, enter values for these fields:

Page Element Description

Status Enter a transaction status name.

Description Enter a description for the transaction status.

System Status for Permit Select the permit transaction status that you want to use from the drop-down list:
Applications

o Completed

o Certificate of Occupancy
o Denied

o Voided

o InProcess

o Permit Issued

o Plan Review

System Status for Planning Select the planning transaction status that you want to use from the drop-down list:
Applications

o Completed

o Hearing

o Denied

o Voided

o InProcess

o Permit Issued

5. Verify that the Enabled switch is turned on. The switch is turned on by default for a new record status.
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6.

Click Save.

Modifying Transaction Statuses

You can modify the transaction statuses that you have defined for your agency’s permits and planning applications on the
Permit Status Details or Planning Status Details page, respectively.

1.
2.

5.

Select Common Setup > Transaction Status .
You can select from these transaction statuses:

o Permit Status

o Planning Status

For information about permit inspection statuses, see Setting Up Inspection Statuses.

For information about permit plan review statuses and decision statuses, see Setting Up Plan Review Statuses.
Select the row for the transaction status that you want to modify.
On the Details page you can:

o For user-defined statuses, edit the description or the system status that you want to set on a record with this
record status. You cannot edit the Status field.
o For system-delivered statuses, you can only edit the description. You cannot edit the Status field.

o Turn on the Enabled switch to enable a user-defined record status. You cannot disable system-delivered
statuses.

Click Save to save any changes.

Deleting Transaction Statuses

You can delete the statuses that you have defined for your agency on the Permit Status Details or Planning Status Details

page.

#" Note: You cannot delete most of the system-delivered statuses; you can only modify their descriptions. Oracle

P

recommends that you disable statuses instead of deleting them.

Select Common Setup > Transaction Status .
You can select from these transaction statuses:

o Permit Status

o Planning Status

For information about permit inspection statuses, see Setting Up Inspection Statuses.

For information about permit plan review statuses and decision statuses, see Setting Up Plan Review Statuses.
Select the row for the transaction status that you want to delete.

On the Details page, click Delete, if the button is available.

If you want to delete multiple record statuses, you can delete them from the grid on the Transaction Status page:

a. Click the Edit icon.
b. Select the check boxes for the status rows to delete.
c. Click the Delete icon.
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2 Setting Up Permits

Setting Up Plan Reviewer Departments

A plan review department represents an area of expertise for reviewers of plan documents.

For example, a plan review department of Building is associated with experts in building-related codes and regulations
whereas a plan reviewer department of Fire is associated with experts in fire-related codes and regulations.

You select a plan review department for a plan reviewer when you add a department job attribute for your plan reviewer job
function during agency staff setup. For more information on adding job functions and job attributes, see Managing Agency
Staff Profiles.

System administrators add, modify, and delete plan reviewer departments on the Plan Reviewer Department page.

Adding Plan Reviewer Departments

Select Common Setup > Plan Reviewer Department .

On the Plan Reviewer Department page, click Add.

On the Plan Reviewer Department Details page, enter an ID, name, and description for the department.
Turn on the Enabled switch to make the plan reviewer department available as a value on other pages.
Click Save.

aprop

Modifying Plan Reviewer Departments

—

Select Common Setup > Plan Reviewer Department .
On the Plan Reviewer Department page, select the plan reviewer department that you want to modify.
On the Plan Reviewer Department Details page you can:

w0 N

o Edit the description. You cannot change the values of the Department ID and Department fields.
o Enable or disable the plan reviewer department using the Enabled switch.
o Delete the plan reviewer department. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Plan Reviewer Departments

Select Common Setup > Plan Reviewer Department .

Click Edit.

Select the check boxes next to all the plan reviewer departments you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

pPODN =

" Note: You can’t delete a plan reviewer department that is already in use as part of a plan reviewer’s job
attribute. In this case, to prevent the plan reviewer department from being used in the future, turn off the
Enabled switch to disable it.
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Setting Up Plan Review Statuses

Use delivered plan review statuses to identify the progression through a plan review cycle. You can review the statuses on the
status definition pages.

You review the plan review statuses on the Plan Review Status and Decision Status pages. You cannot delete the system-
defined statuses or add new statuses, but you can modify the descriptions. The descriptions allow you to enter a different
status name to be displayed to agency staff.

The system derives the overall plan review status from the individual plan reviewer decisions, and updates the overall plan
review with the most severe decision status. The system-defined decision statuses are listed here from most to least severe:
Rejected, Revision Required, Approved with Comments, Approved, and Not Required. If plans have one or more rejections,
or revisions are required, the applicant must correct the plans and resubmit them for another review cycle.

Modifying Plan Review Cycle Statuses

You can edit only the Description field on the Plan Review Status Details page. The agency-defined description is exposed
to agency staff and public users on the plan review pages in the permit record detail.

1. Select Common Setup > Transaction Status .
Select the Plan Review Status tab.
3. You can review the delivered review cycle statuses in the Review Status column:
o InProgress
o Canceled
o Completed

4. Select the row for the review status that you want to modify.
5. On the Plan Review Status Details page you can edit only the description.
6. Click Save to save any changes.

Modifying Plan Review Decision Statuses

You can edit only the Description field on the Decision Status Details page. The agency-defined description is exposed to
agency staff and public users on the plan review pages in the permit record detail.

1. Select Common Setup > Transaction Status .
Select the Plan Review Decision tab.
3. You can review the delivered plan review decision statuses in the Decision Status column:
o Approved
o Approved with comments
o Revision required
o Rejected
o Not required

The plan review decision statuses are delivered as enabled. The only review decision status that you can disable is
Approved with comments.

10
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4. Select the row for the decision status that you want to modify.
5. On the Decision Status Details page you can edit only the description.
6. Click Save to save any changes.

Setting Up Permit Types

Define the types of permits supported by an agency. You add a permit type and associate workflow process definitions on
the Permit Type definition page.

Before you can create an application form, you must first create a permit type on the permit type definition page.

This example illustrates the Permit Type definition page, which is described in the following sections.

Permit Type

« PP L0

rmit Type ID E2EResPermit123

s Ready

e E2E_AutoNum_Permit o

1/16 ]

p P00 0p

4 Workflow Setup

leinternalpcs~Permits_Silver... v

Adding Permit Type Definitions

1. Select Permit Setup > Permit Type > Permits .
2. On the Transaction Type — Permit Types page, click the Add button.
3. On the Permit Type page, enter values for the following fields:

Page Element Description

Classification Displays the type of application. The classification for this page indicates this is a permit
application.

Subclassification For use with planning applications. Accept the default value, Not Applicable.

Permit Type Enter a name for the type of permit type.

Permit Type ID Enter a unique alphanumeric code or short name for the permit type. Do not use special

characters, including symbols or punctuation, or spaces.

Status Select from the following to indicate the permit type status:

o Preliminary: The permit type is being defined but is not available for use.

o Ready: The permit type is enabled for immediate use.

11
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Page Element Description

¢ Note:

»
The permit design must be published in the Intake Form Designer prior to setting the
permit type status to Ready.

o Void: The permit type is no longer available.

Autonumber Rule

Select the autonumbering rule to increment numbers for permits.

For more information, see Setting Up Autonumbering.

Valid from Date and Valid to Date

Enter a range of dates when this permit type is valid. The default from date is the current
date. The default end date is Open. You can update these dates as needed.

Public User Enabled

Select from the following to indicate whether this permit type is enabled for public users:

o Enabled for all users
o Enabled for registered users

o Not enabled for public users (default)

Initially, for a newly created permit this is always set to Not enabled for public users. When
you are ready to publish the new permit, update this value. See Publishing Intake Forms.

Application Group

Select a permit application group that you want to associate with the permit type.

For more information, see Setting Up Transaction Groups.

Category Select an application category that you want to associate with the permit type.
For more information, see Setting Up Transaction Categories.
Subcategory Select an application subcategory that you want to associate with the permit type.

For more information, see Setting Up Transaction Subcategories.

Document Group

Select a document group to manage attachments for the application type.

When you specify a document group, document attachments can be classified into
categories and subcategories during the application process and when you upload files.
Then you can see the category for a document on the attachments page in the application
details.

For more information, see Setting Up Document Groups.

Plan Review Type

ORrRACLE

Select the method used for reviewing plans for permits associated with the permit type.

o Manual: Plan reviews are tracked as part of permitting workflow, but are performed
without the use of integrated electronic document review software.

o Not Used: Plan reviews are not tracked as part of permitting workflow.

o Electronic: Plan reviews are tracked as part of permitting workflow, and are performed
through integration with electronic document review software.
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Description

For more information on plan reviews, see Managing Manual Plan Review Cycles and
Managing Electronic Plan Review Cycles.

Inspection Group

Select an inspection group to associate with the permit type. The inspection group identifies
all inspections necessary for the permit.

For more information, see Setting Up Inspection Groups.

Fee Schedule

Select a fee schedule that you want to associate with the permit type. A department is
required if the permit type has a fee schedule ID.

For more information, see Setting Up Fee Schedules.

Bill Type Select a bill type to associate with the permit type.
The billing type identifies the type of invoice that can be generated from the record. The bill
type is required.
For more information, see Setting Up Bill Types.

Department Select a department that you want to associate with the permit type. A department is

required if you add a Fee Schedule ID to the permit type.

If a department is specified on the Fee ltem setup page, the fee item department overrides
the department specified here on the permit type.

For more information, see Setting Up Departments.

Terms of Use ID

Select a terms of use definition to associate with the permit type. When you set up terms of
use, you can make the terms available to the public user registration process, to the permit
application process, or to both. The user must accept the terms and conditions for using
online permits.

For more information, see Setting Up Terms of Use.

Description Enter a user-facing description of the permit type. On the Apply page, this description
appears under the permit type name.
The description helps public users understand the purpose of the permit type.

URL Enter a URL for a web page that gives public users more information about the permit type.

If you enter a URL, then a Learn More link appears at the end of the permit type description
on the Apply page. The user clicks this link to open the specified URL.

If you leave this field blank, the Learn More link is not visible on the Apply page.

Setting Up Workflow for a Permit Type

You set up workflow using the Oracle Autonomous Integration Cloud (OIC) before associating the workflow with the permit

type.

ORrRACLE
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For more information, see Setting Up Process Definitions for Workflow.

1. Select Permit Setup > Permit Type > Permits .
2. On the Transaction Type — Permits page, click the Add button.
3. Inthe Workflow Setup section on Permit Type page, enter values for the following fields:

Page Element Description

Workflow Space Name Enter the space where the workflow process application is stored. You can group related
applications in a space as well as enable users to collaborate when developing applications.

Workflow Application ID Enter the name of the workflow process application in OIC. For more information, see
Creating and Managing Applications.

Workflow Version Enter the version of the workflow process application.

Workflow Process Definition Enter the name of the workflow process definition that applies to this particular permit.

# Note: Different permit types can utilize the same workflow definition.

Saving a Transaction Type

When you first save a transaction type definition, it may take a few moments to complete. On the first save, the system:

e saves all the transaction type attributes.
e creates the custom database objects (such as view objects).
e creates the REST endpoint for that transaction type.

e creates the Fusion Application sandbox needed for developing the application form layout.

Cloning Permit Types

Click the Clone button to create a clone of the current permit type, which you can then use to create a different permit or to
create a different version of the current permit.

For more information on cloning permits, see Cloning Transaction Type Definitions.

Designing Intake Forms

After you have entered the appropriate initial information for a permit, you can then begin to design the intake form that end
users will use to submit an online application. You create an application form using the Intake Form Designer. To access the
designer, click Design Form.

For more information on designing intake forms, see Using the Intake Form Designer.
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Setting Up Permit Display Groups
Use the Display Group setup pages to add permit display groups that appear on your agency’s landing page, where a user

starts an application.

A permit display group identifies a meaningful grouping of permit and planning application types displayed as a list on the
Apply page. The list appears as the permits or planning applications that agency staff or a guest user can select to initiate the
application process.

For more information about how the Apply page looks and is used, see Starting an Application.
Before setting up permit display groups, you must set up transaction types for your agency. See Setting Up Permit Types.

This example illustrates the Permit Display Group Details page which is described in the following text.

Permit Display Group Details Concel'| [Dskete

* Display Group 1D PermitApplicationGroup * Applicable v Permits

Classification Planning and Zoning

Enabled (:)

* Display Group  Solar Roof Permits

Description  The permit application group for solar roof.

URL = http://www.oracle.com

Display Group Lines

=N . Search QY
Display Order Transaction Type ID Transaction Type Classification
1 IJME3 JME3 Permits >

Adding Permit Display Groups

1. Select Permit Setup > Permit Display Group .
2. On the Permit Display Group page, click Add to add a new group.
3. On the Permit Display Group Details page, enter values for the following:

Page Element Description

Display Group Enter a permit display group name.

Description Enter a description of the display group that appears on the Apply page for guests.

URL Enter a URL used to access additional information about a transaction type.

Applicable Classification Select the check box for the applications to which this display group applies. Choose from

these options:
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o Permits

o Planning and Zoning

This option determines whether a display group type is shown on the Apply page for public
users. A display group can be included with both the Permit Applications and the Planning
Applications.

4. Verify that the Enabled switch is turned on. The switch is turned on by default for new permit display groups.
5. Inthe Display Group Lines section, click Add to set up a line on the Display Group Line Details page. The display
group lines are transaction types that make up the list in the new display group.

#" Note: Both permit transaction types and planning application transaction types can be added to a display
group. For example, you can add a planning application transaction type to a permit application display
group and the other way around.

Page Element Description

Display Order Enter a numerical value in this field to specify the order in which you want the permit type
to be displayed, if desired. The default value is O and upon saving, the system automatically
assigns the next value.

Transaction Type ID Select an existing transaction type ID.

The description for the ID you enter here will appear in the Transaction Type field.

Transaction type information Review the attribute information for the permit type to verify you have selected the correct
transaction type ID:

o Transaction Type
o Classification

o Application Group
o Category

o Subcategory

For more information about transaction type attributes, see Setting Up Permit Types.

6. On the Permit Display Group Details page, click Save.

Modifying Permit Display Groups and Lines

You can modify permit display groups and lines on the Permit Display Group Details and Display Group Line Details pages,
respectively.

1. Select Permit Setup > Permit Display Group .
2. On the Permit Display Group page, select the row for the permit group that you want to modify.
3. On the Permit Display Group Details page, you can:

o Modify the description. You cannot change the group name.
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8.

o Turn the Enabled switch on or off to enable or disable the display group.

If you made any changes, click Save.

To modify the display group lines (the list of permits in a display group), select the row for the permit group that you
want to modify on the Permit Display Group page.

On the Permit Display Group Details page, select a display group line in the Display Group Lines grid.
On the Display Group Line Details page, you can change the values in these fields:

a. Update the Display Order field to change the order in which the lines appear.
b. Update the Transaction Type ID field with another existing permit type ID.
If you made any changes, click Save.

Deleting Permit Display Groups and Lines

pPODN =

Select Permit Setup > Permit Display Group .

On the Permit Display Group page, select the row for the permit group that you want to delete.

If you want to delete the display group, click Delete on the Permit Display Group Details page.

If you want to delete multiple display groups, you can delete them from the Permit Display Group page:

a. Click Edit.
b. Select the check boxes for the display groups to delete.
c. Click Delete.
To delete a display group line, go to the Permit Display Group Details page and select a display group line in the
Display Group Lines grid.
On the Display Group Line Details page, click Delete.
If you want to delete multiple display group lines, you can delete them from the Permit Display Group Details page:

a. Click Edit.
b. Select the check boxes for the display group line rows to delete.
c. Click Delete.

Importing Solution Packages

Public Sector Compliance and Regulation system administrators and implementation consultants use the Oracle Cloud
Customer Connect to access the Public Sector Compliance and Regulation Solution Library — a collection of configurations
that address common community development functionality with industry best practices, provided in the form of Solution
Packages.

A solution package contains all the necessary configuration files in a compressed file format along with a metadata file.

Review the solution package contents online, download specific solutions that contain the corresponding setup data, review
them and deploy those solutions to your pre-production environment for your understanding. Each solution package provides
a link that allows you to download and review a white paper describing the contents of the particular solution package. You
can review the white paper before you decide to download the solution package.

To access the Solution Library, follow this link Public Sector Compliance and Regulation Solution Library.
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3 Setting Up Planning Applications

Setting Up Planning Application Types
Define the types of planning applications supported by an agency, including pre-applications. You add a planning application
type and associate workflow process definitions on the Planning Application Type definition page.

Before you can create an application form, you must first create a planning application type on the Planning Application Type
definition page. The type defines attributes that will be available on the planning application.

This example illustrates the Planning Application Type definition page, which is described in the following sections.

Planning Application Type

Classification Planning and Zoning Hearing Applicable v

Subclassification  Not Applicable v Application Group Q
* Planning Application Type  Accessory Dwelling Unit Application Category o
Subcategory o
* Planning Application Type ID  FRecord0327A Document Group O,
Status Ready v Fee Schedule  PlanningFees Q
* Autonumber Rule  E2EPZRule a " Bil Type  E2E Bill Type RS
* Valid from Date 3/1/19 o * Department 1001 o
Valid to Date  Open valid to date 2] Terms of Use ID o
Public User Enabled ~ Enabled for all users v
Description
URL
4 Workflow Setup
* Workflow Space Name  FA Bronze3 v * Workflow Version 1 -
* Workflow Application ID Permits Bronze3 v * Workflow Process Definition  Building v

Adding Planning Application Type Definitions

1. Select Planning and Zoning Setup > Planning Application Type > Planning Applications .
2. On the Transaction Type — Planning Applications page, click the Add button.
3. On the Planning Type Applications page, enter values for the following fields:

Page Element Description

Classification Displays the type of application. The classification for this page indicates this is a planning
application.
Subclassification Displays the type of application.

If you would like to create a pre-application type, select Pre-Application from the drop-down
list. The default value is Not Applicable, which indicates a standard planning application.

Planning Application Type Enter a name for the type of planning application.
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Page Element Description
Planning Application Type ID Enter a unique alphanumeric code or short name for the planning application type. Do not

use special characters, including symbols or punctuation, or spaces.

Status Select from the following to indicate the planning application type status:

o Preliminary: The planning application type is being defined but is not available for use.

o Ready: The planning application type is enabled for immediate use.

# Note:
The application setup must be published in the form designer prior to setting the
planning application status to Ready.

o Void: The planning application type is no longer available.

Autonumber Rule Select the autonumbering rule to increment numbers for planning applications.

For more information, see Setting Up Autonumbering.

Valid from Date and Valid to Date Enter a range of dates when this planning application type is valid. The default from date is
the current date. The default end date is Open. You can update these dates as needed.

Public User Enabled Select from the following to indicate whether this planning application type is enabled for
public users:
o Enabled for all users
o Enabled for registered users
o Not enabled for public users (default)

For a newly created application type, this is always set to Not enabled for public users.
When you are ready to publish the new application form, update this value. See Publishing
Intake Forms.

Hearing Select whether public hearings are applicable or not applicable to this planning application
type.

For more information, see Setting Up Hearing Bodies, Setting Up Hearing Hierarchies, and
Setting Up Hearing Decisions.

Application Group Select an application transaction group that you want to associate with the planning
application type.

For more information, see Setting Up Transaction Groups.

Category Select a transaction category that you want to associate with the planning application type.

For more information, see Setting Up Transaction Categories.

Subcategory Select a transaction subcategory that you want to associate with the planning application
type.

For more information, see Setting Up Transaction Subcategories.
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Page Element Description
Document Group Select a document group to manage attachments for the planning application type.

When you specify a document group, document attachments can be classified into
categories and subcategories during the application process and when you upload files.
Then you can see the category for a document on the attachments page in the application
details.

For more information, see Setting Up Document Groups.

Fee Schedule Select a fee schedule that you want to associate with the planning application type. A
department is required when you enter a fee schedule ID.

For more information, see Setting Up Fee Schedules.

Bill Type Select a bill type to associate with the planning application type.

The billing type identifies the type of invoice that can be generated from the record. The bill
type is required.

For more information, see Setting Up Bill Types.

Department Select a department that you want to associate with the planning application type. A
department is required if you add a Fee Schedule ID to the planning application type.

If a department is specified on the Fee ltem setup page, the fee item department overrides
the department specified here on the planning application type.

For more information, see Setting Up Departments.

Terms of Use ID Select a terms of use definition to associate with the planning application type. The available
values for planning applications are determined by the usage on the terms of use ID.

For more information, see Setting Up Terms of Use.

Description Enter a user-facing description of the planning application type. On the Apply page, this
description appears under the application type name.

The description helps public users understand the purpose of the application type.

URL Enter a URL for a web page that gives public users more information about the planning
application type.

If you enter a URL, then a Learn More link appears at the end of the application type
description on the Apply page. The user clicks this link to open the specified URL.

If you leave this field blank, the Learn More link is not visible on the Apply page.

Setting Up Workflow for a Planning Application

You set up workflow using the Oracle Autonomous Integration Cloud (OIC) before associating the workflow with the planning
application type.
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For more information, see Setting Up Process Definitions for Workflow.

1. Select Planning and Zoning Setup > Planning Application Type > Planning Applications .
2. On the Transaction Type — Planning Applications page, click the Add button.
3. Inthe Workflow Setup section on Planning Application Type page, enter values for the following fields:

Page Element Description

Workflow Space Name Enter the space where the workflow process application is stored. You can group related
applications in a space as well as enable users to collaborate when developing applications.

Workflow Application ID Enter the name of the workflow process application in OIC. For more information, see
Creating and Managing Applications.

Workflow Version Enter the version of the workflow process application.
Workflow Process Definition Enter the name of the workflow process definition that applies to this particular planning
application.

" Note: Different planning application types can utilize the same workflow definition.

Saving a Transaction Type

When you first save a transaction type definition, it may take a few moments to complete. On the first save, the system:

e Saves all the transaction type attributes.
e Creates the custom database objects (such as view objects).
e Creates the REST endpoint for that transaction type.

e Creates the Fusion Application sandbox needed for developing the application form layout.

Cloning Planning Application Types

Click the Clone button to create a clone of the current planning application type, which you can then use to create a different
planning application or to create a different version of the current planning application.

For more information on cloning permits and planning applications, see Cloning Transaction Type Definitions.

Designing Planning Application Forms

After you have entered the appropriate initial information for the planning and zoning type, you can then begin to design the
intake form that end users will use to submit an online application for a permit. You create an intake form using the designer.
You access the designer by clicking the Design Form button.

For more information on designing intake forms, see Using the Intake Form Designer.
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Setting Up Planning Application Display Groups
Use the Display Group setup pages to add planning application display groups that appear on your agency’s landing page,

where a user starts an application.

A planning application display group identifies a meaningful grouping of permit and planning application types displayed as a
list on the Apply page. The list appears as the permits and planning applications that agency staff or guest users can select to
initiate the application process.

For more information about how the Apply page looks and is used, see Starting an Application.

Before setting up planning application display groups, you must set up planning application types for your agency. See
Setting Up Planning Application Types.

This example illustrates the Planning Application Display Group Details page, which is described in the following text.

Planning Application Display Group Details Caneel | | Delete

* Display Group ID PreAppGROUP * Applicable Classification Permits
+ Planning and Zoning

Enabled (:)

* Display Group  PreAppGROUP

Description PreAppGROUP

URL

Display Group Lines

= X Search Qlr
Display Order Transaction Type ID Transaction Type Classification

1 PNZAUT PNZAUT Planning and Zoning >

2 PlanningAppln PlanningAppln Planning and Zoning >

Adding Planning Application Display Groups

1. Select Planning and Zoning Setup > Planning Display Group .
2. On the Planning Application Display Group page, click Add to add a new grouping.
3. On the Planning Application Display Group Details page, enter values for the following:

Page Element Description

Display Group Enter a planning application display group name.

Description Enter a description of the display group that appears on the Apply page for guests.

URL Enter a URL used to access additional information about a transaction type.

Applicable Classification Select the check box for the applications to which this display group applies. Choose from

these options:
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o Permits

o Planning and Zoning

This option determines whether a display group type is shown on the Apply page for public
users. A display group can be included with both the Permit Applications and the Planning
Applications.

4. Verify that the Enabled switch is turned on. The switch is turned on by default for new planning application display
groups.

5. In the Display Group Lines section, click Add to set up a line on the Display Group Line Details page. The display
group lines make up the list of planning application types in the new display group.

#" Note: Both permit transaction types and planning application transaction types can be added to a display
group. For example, you can add a permit transaction type to a planning application display group and the
other way around.

Page Element Description

Display Order Enter a numerical value in this field to specify the order in which you want the planning
application type to be displayed, if desired. The default value is 0 and upon saving, the
system automatically assigns the next value.

Transaction Type ID Select an existing transaction type ID.

The description for the ID you enter here will appear in the Transaction Type field.

Transaction type information Review the attribute information for the planning application type to verify you have selected
the correct transaction type ID:

o Transaction Type
o Classification

o Application Group
o Category

o Subcategory

For more information about transaction type attributes, see Setting Up Planning Application
Types.

6. On the Planning Application Display Group Details page, click Save.

Modifying Planning Application Display Groups and Lines

You can modify planning application display groups and lines on the Planning Application Display Group Details and Display
Group Line Details pages, respectively.

1. Select Planning and Zoning Setup > Planning Display Group .

2. On the Planning Application Display Group page, select the row for the planning application group that you want to
modify.
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3. On the Planning Application Display Group Details page, you can:

o Modify the description. You cannot change the group name.
o Turn the Enabled switch on or off to enable or disable the display group.

4. If you made any changes, click Save.

5. To modify the display group lines (the list of planning applications in a display group), select the row for the planning
application group that you want to modify on the Planning Application Display Group page.

6. On the Planning Application Display Group Details page, select a display group line in the Display Group Lines grid.
7. On the Display Group Line Details page, you can change the values in these fields:

a. Update the Display Order field to change the order in which the lines appear.
b. Update the Transaction Type ID field with another existing planning application type ID.
8. If you made any changes, click Save.

Deleting Planning Application Display Groups and Lines

1. Select Planning and Zoning Setup > Planning Display Group .

2. On the Planning Application Display Group page, select the row for the planning application group that you want to
delete.

3. If you want to delete the display group, click Delete on the Planning Application Display Group Details page.
4. If you want to delete multiple display groups, you can delete them from the Planning Application Display Group page:

a. Click Edit.
b. Select the check boxes for the display groups to delete.
c. Click Delete.

5. To delete a display group line, go to the Planning Application Display Group Details page and select a display group
line in the Display Group Lines grid.
6. On the Display Group Line Details page, click Delete.

7. If you want to delete multiple display group lines, you can delete them from the Planning Application Display Group
Details page:

a. Click Edit.
b. Select the check boxes for the display group line rows to delete.
c. Click Delete.

Managing Pre-Application Meeting Configuration

Pre-applications are the initial step in the planning and zoning process, and are used to allow the property owner or developer
to work with agency planners to receive feedback prior to submitting planning applications. A pre-application meeting is
scheduled between the property owner or developers and agency planners to determine the necessary applications and
approvals for the project.
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Configuring the Pre-Application Meeting

Administrators set up and manage the pre-application meeting configuration on the Manage Pre-Application Meeting
Configuration page.

1.

Select Pre-Application Setup > Pre-Application Meeting Setup . Or, Select Setup and Maintenance tile
on the Agency Springboard > Select Public Sector Planning and Zoning > Planning Application Types
functional area > Manage Pre-Application Meeting Configuration task.

On the Manage Pre-Application Meeting Configuration page, the Pre-Application Meeting section allows you to set
up applicant privileges. Enter values for the following fields:

Chapter 3
Setting Up Planning Applications

Page Element Description

Applicant can request Select to allow an applicant to request a pre-application mesting. Applicants can access the

Pre-Application Meeting Request page. See Working with Pre-Application Meetings. and
schedule a meeting based on the availability of the agency staff.

Applicant can reschedule Select to allow an applicant to reschedule their meeting.

3. The Meeting Availability section allows you to set up the parameters for scheduling meetings, determined by:

a. Planner meeting schedule or
b. Agency meeting schedule

" Note: You also need to ensure that all the Planners are assigned a Pre-Application meeting work

schedule on the Agency Staff Profile. Enter values for the following fields:

Planner meeting schedule: Select to allow users to schedule meetings based on the availability of their assigned
planner.

Page Element Description

Meeting Duration in Hours Select a value to set the maximum amount of time the meeting can be scheduled for. Users
will see this value as the duration of the meeting, and they are not allowed to edit the field.
See the section Scheduling a Pre-Application Meeting under Working with Pre-Application
Meetings.

Schedule after Number of Days Select a value to set the number of days from the current date, so that users can schedule
a meeting on a date available after the number of days specified here. For example, if you
select a value 5 on the 10th day of this month, the calendar on the Pre-Application Meeting
Request page displays the dates that are available after the 15th day of the month.

Schedule up to Number of Days Select a value to set the number of days that will be available for the users to select a date
on the calendar for scheduling the meeting. For example, if you select a value of 90, the
calendar on the Pre-Application Meeting Request page displays 90 calendar days starting
from the date the user is making the selection.

See the section Scheduling a Pre-Application Meeting under Working with Pre-Application
Meetings.
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Agency meeting schedule: Select to allow users to schedule meetings based on the schedule of the agency. In
addition to the fields described above, enter values for the following fields:

#" Note: If you select this option, then you need not assign Pre-Application meeting schedule to the planners
as the Pre-Application meeting schedule will not be considered while determining the availability.

Page Element Description

Pre-Application Work Schedule Select the Agency level work schedule that needs to be considered while determining the
availability for the pre-application meeting.

Maximum Concurrent Meetings Select a value to determine the maximum number of meetings that can be scheduled at a
time.

4. The Meeting Agenda and Location section allows you to set up the agenda and the location for the pre-
application meeting.

Page Element Description

Include Agenda Select the check box and enter the agenda in the Meeting Agenda field.

Include Location Select the check box and search for the desired location of your agency using the Agency
Information look up. The address of the location you select is displayed in the Meeting
Location field.

#" Note: Users can edit the entries for the agenda and location fields while scheduling the meeting on the
Pre-application Request page.

Setting Up Hearing Bodies

With Oracle Public Sector Compliance and Regulation Cloud, you will use the Public Hearing feature to configure hearing
bodies and hearing hierarchies, schedule hearings, and record decisions.

Setting Up Public Hearing

A public hearing is an official meeting where members of the public, the hearing body, and the applicant of the planning and
zoning application come together to discuss the facts about the application submitted by the applicants.

The following topics apply to administrators for setting up and maintaining the Public Hearing process:
e Setting up Hearing Body

e Setting up Hearing Hierarchy

e Setting up Hearing Decision
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Setting Up Hearing Body

A hearing body is a group of individuals formed to evaluate the testimony presented by applicants and to provide feedback.
Adding a Hearing Body
To add a hearing body:

1. Select Hearing Setup > Set Up Hearing Body .
2. Click Add on the Hearing Body page and enter values for the following fields:

Page Element Description

Hearing Body Code Enter a unique identifier of the hearing body.

Name Enter a name for the hearing body.

Additional Information Enter any text as details about the hearing body.

Enabled Turn on the switch to make the hearing body available for use.

Appeal Period Select the number of days after the public hearing, when an appeal is allowed.

Maximum Agenda ltems Select a value from the options. As an agency user you can configure the maximum number

of agenda items that can be heard on a day.

Address fields Enter the address of the hearing. Enter the ZIP code, or click the Don’t Know link to enter
values for the following fields:

o Country: U.S (Default value)
o ZIP Code

o Address Line 1

o Address Line 2

o City

o State

o Postal Code

3. Select a pattern of recurrence of the meeting from these fields:

Page Element Description

Recurrence Pattern Select the pattern for the recurrence of the public hearing:

o Weekly
o Monthly

4. Select the Weekly recurrence if you want to schedule the meeting every week. Enter values for the following fields:
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Weeks between Occurrences Select the number of weeks between one meeting occurrence and the next.
Days of the Week Select the days of the week on which you want the meeting to recur.
Recurrence Start Date Time Select a date and time from which the meeting recurrence should be effective.

5. Select the Monthly recurrence if you want to schedule the meeting every month. Enter values for the following fields:

Page Element Description

Months between Occurrences Select the number of months between one meeting occurrence and the next.

Days of the Week Select the check box if you want to schedule the meeting on particular days of the week.

Click Add to open the Days of the Week page and select the days of the week, for example
First Monday:

o Occurrence: Select — First, Second, Third, Fourth, or Last the day of week

o Weekday: Select the day of the week from Monday, Tuesday, and so on.

Turn on the Enable switch to make the setting available for use and click Save. Use the
Add button to include multiple rows.

# Note:
You can modify or delete the entry. Click the row and use the Days of the Week
page to make the change.

Dates Select the check box if you want to schedule the meeting on particular dates of the week.
Click Add to open the Dates page and select from all the available dates.

Turn on the Enable switch to make the setting available for use and click Save. Use the
Add button to include multiple rows.

¢ Note:

»
You can modify or delete the entry. Click the row and use the Dates page to make
the change.

Recurrence Start Date Time Select a date and time from which the meeting recurrence should be effective.

6. Click Save to save the new hearing body and return to the Hearing Body page.

Modifying a Hearing Body
To modify a hearing body:
1. Select Hearing Setup > Set Up Hearing Body .

2. On the Hearing Body page, click the record of the hearing body you want to edit.
3. On the Hearing Body details page you can make changes to the fields and click Save.
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" Note: You can make changes to all the fields except the Hearing Code.

4. The Hearing Body page now lists the updated record.

Deleting a Hearing Body

To delete a hearing body:

1. Select Hearing Setup > Set Up Hearing Body .

2. On the Hearing Body page, click the record of the hearing body you want to delete.

3. On the Hearing Body details page you can click the Delete button. Click OK on the confirmation message.
4. The Hearing Body page lists only the existing records.

Setting Up Hearing Hierarchies

Hearing Hierarchy defines the levels of hearing bodies that an application can be escalated through. In an agency, a planning
and zoning application can be escalated to a higher body in cases of appeal, where the highest hearing body decision is
considered final.

Agencies set up their hearing hierarchy to address events such as an appeal. For example, a hearing begins with the Planning
Committee and then an appeal escalates the application to the Planning Commission. If appealed again, the application
moves to the City Council.

Adding a Hearing Hierarchy
To add a hearing hierarchy:

1. Select Hearing Setup > Set Up Hearing Hierarchy .
2. Click Add on the Hearing Hierarchy page and enter values for the following fields:

Hierarchy Code Enter a unique identifier of the hearing body.

Hierarchy Enter a name for the hearing hierarchy.

Enabled Turn on the switch to make the hearing hierarchy available for use.
Description Enter any text to describe the hierarchy.

3. Click Add and enter values for the following fields:

Page Element Description

Hearing Body Code Select a hearing body code to associate with the new hearing hierarchy.
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Page Element Description
Sequence Select a number to determine the escalation level of the selected hearing body within the

hierarchy. For example, if the value 2 is selected, the selected hearing body will be the
second in the hierarchy for the public hearing.

Appeal Allowed Turn on the switch if you want to allow the agency to appeal after the hearing body places
its decision. The agency will not be allowed to appeal the hearing to the next body in the
hierarchy, if the switch is turned off.

Enabled Turn on the switch if you want to allow the hearing body to be available for use.

Click to add a new row and add a new hearing body in the hierarchy.

m Click to delete the row. The hearing body will be removed from the hierarchy.

4. Click Save to save the newly created hierarchy and return to the Hearing Hierarchy page, where the new hierarchy
you created is listed.

Modifying a Hearing Hierarchy

To modify a hearing hierarchy:

1. Select Hearing Setup > Set Up Hearing Hierarchy .
2. On the Hearing Hierarchy page, click the hearing hierarchy row you want to edit.
3. On the Hearing Hierarchy details page make changes to the fields and click Save.

" Note: You can make changes to all the fields except the Hierarchy Code.

Deleting a Hearing Hierarchy

To delete a hearing hierarchy:

1. Select Hearing Setup > Set Up Hearing Hierarchy
On the Hearing Hierarchy page, click the hearing hierarchy row you want to delete.

3. On the Hearing Hierarchy details page, click Delete and click OK on the confirmation page to delete the hearing
hierarchy.

4. Click Save and return to the Hearing Hierarchy page. The page lists the updated hierarchy rows.

Setting Up Hearing Decisions

The outcome of a public hearing is referred to as hearing decision. Agency staff such as assigned planners update the
decision from the hearing body into the system.
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System-defined Public Hearing Decisions
Oracle delivers hearing decisions for use during the hearing process. System administrators can configure the decisions
specific to their agency, which are mapped to one of the system-defined decisions listed below:

e Approved

e None

e Denied

e Continue

Adding a Hearing Decision

1. Select Hearing Setup > Set Up Hearing Decision .
2. The Hearing Decision page lists all the decisions you have configured. Click Add.
3. One the Hearing Decision Status detail page, enter values for the following fields:

Page Element Description

Code Enter a unique identifier of the hearing decision.
Name Enter a name to identify the decision. Example, Approved with Conditions, Not Result, and
SO on.
Description Enter any text to describe the decision.
Decision Select one of the system-defined decisions to map to the new decision you are creating:
o Approved:
o None
o Denied
o Continue
Enabled Turn on the switch to make the decision available to use.

4. Click Save to save the new hearing decision and return to the Hearing Decision page, which lists the newly created
decision.

Modify a Hearing Decision

To modify a hearing decision:

1. Select Hearing Setup > Set Up Hearing Decision .

2. The Hearing Decision page lists all the decisions you have configured. Click the row of the decision you want to
modify.

3. On the Hearing Decision detail page, make changes to the fields and click Save.

#" Note: You can make changes to all the fields except the Code.

32
ORrRACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 3
Implementing Community Development Setting Up Planning Applications

4. The Hearing Decision page lists the updated row.

Deleting a Hearing Decision

To delete a hearing decision:

1. Select Hearing Setup > Set Up Hearing Decision .

2. The Hearing Decision page lists all the decisions you have configured. Click the row of the decision you want to
delete.

3. On the Hearing Decision detail page, click Delete and confirm deletion by selecting OK.
4. Click Save and return to the Hearing Decision page. The page lists the updated decision rows.
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Intake Form Designer Topics

Chapter 4
Creating Intake Forms

The following topics apply to using the Intake Form Designer to create and publish intake forms, which registered users

access online to initiate transactions, such submitting a permit application.

Using the Intake Form Designer

Using the Intake Form Designer

Working with Sandboxes

Working with Pages

Working with Predefined Field Groups
Using Predefined Field Groups

Working with Group Boxes

Working with Fields

Adding Rich Text Areas

Defining Fields Displaying a List of Values
Displaying Form Elements Conditionally
Adding Logic

Adding Contextual Help to Forms

Setting Form Options

Mapping Form Fields to Decision Model Attributes
Considering User Experience

Testing Intake Forms

Publishing Intake Forms

Cloning Transaction Type Definitions
Managing Transaction Type Configurations

This topic describes the purpose of the Intake Form Designer, lists the prerequisites that must be completed prior to creating
a form, and introduces you to the designer interface.

To initiate a transaction within Oracle Public Sector Community Development, an intake form needs to be submitted by

the citizen or registered user that captures the information required as prerequisites to initiating the process. Examples of
transactions include permit applications, planning and zoning applications, and so on. With Oracle Public Sector Community
Development, you use the Intake Form Designer to create application forms your citizens can access online, fill out, submit,
and monitor the transaction all through the cloud.

Oracle does not deliver a predefined form for each type of transaction because for each form and for each municipality, the
information required will be unique. For example, for a fence permit, the City of San Diego may require only basic information
about the material to be used and the measurements. On the other hand, the City of Sacramento may require the same
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information as San Diego, but also require the contact information of the contractor building the fence, the exact location of
the fence, the area enclosed by the fence, and so on. Each municipality has its own set of requirements, and the Intake Form
Designer enables you to tailor the forms to reflect your agency's requirements.

With the Intake Form Designer, you can create unique online application forms for each transaction your municipality offers.
The Intake Form Designer provides modular sets of common fields, called predefined field groups, which are ready-to-use
form elements you can use like building blocks to assemble the online application form. If a predefined field group does not
contain fields you require, you can add user-defined form elements (custom fields) to meet your requirements.

Once you have created, configured, and tested your form, you can publish the form for end users to access, complete, and
submit for review and approval.

#" Note: For simplicity in this documentation, the Intake Form Designer is often referred to as “the designer,” and
an intake form is often referred to as a “form.”

Completing Prerequisites

Before creating an online form, you need to:

e Create a transaction type.

For more information on creating a transaction type, see Setting Up Permit Types.

e Set up any fees associated with the form.

For more information on fees, see Setting Up Fee ltemsand Setting Up Fee Schedules.

Accessing the Designer

Before you can create an application form, you must first create a transaction type on the Transaction Type page.

From the Transaction Type Definition page, select the Design Form button.

Working with the Designer Interface

This example illustrates the interface of the designer when you begin creating an application form.

This example illustrates the Intake Form Designer interface. The controls in the image are described in the text surrounding
the image.
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Design Permit Application

Solar Infodev | Status: draft

Elements « Applicant X | Application Options X Add Tab

4 Ready to Use
4 Feld Groups 4 Application

Applicant Record ID NEXT

Application Submission Date

Attachments
Issue Date
Business Information

Status Pending

Submitted By

Description
Comment

Construction

Contact Details

Demolition

4 Applicant
Electrical

Fee Summary
Fence Select Applicant
Grading
Insurance First Name

License Qualification
Middle Name

Elements Panel

Add Logic

Form Options

Salutation

Suffix |

Workspace

Preview Save Publish

»

Page Attributes

Label *

Applicant ‘

<
Hide from public user ) )

Add Help

Control Display

Attributes Panel

Page Element Description

Status

Indicates the status of the current design.

Draft: the form is in sandbox mode, which means only the implementation team can access,
view, and change the form design.

Published: the form is available for testing or end users on the landing page, depending on
your environment. In the development or testing environment, a published form is available for
form developers and testers to access and test. In the production environment, a published

form is available for end users to access.

For more information on form status, see Working with Sandboxes.

Manage Sandbox

Click to access the Oracle Fusion Applications Sandboxes page where you can view the status of

your sandbox and refresh your sandbox if needed.

¢ Note:
»

The Manage Sandbox button appears only if the sandbox associated with your form layout
becomes out of sync, requiring a refresh.

For more information on sandboxes, see Working with Sandboxes.

Add Logic Enables you to add programming logic scripts using the Groovy programming language.
For more information on Groovy, see Adding Logic.

Preview Enables you to preview your form to test layout, design, and data entry.

Save Saves changes made to the form design.

Publish Publishes the completed form design so that it can be accessed from the landing page.
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Page Element Description
Next Takes you to the Fee Mapping page.

For more information on mapping fees, see Mapping Form Fields to Decision Model Attributes.

Form Options Click to display the Form Options dialog box where you can set options that apply to the entire form.

For more information on form options, see Setting Form Options.

Elements panel Contains lists of all pre-defined field groups and user-defined elements you can add to your form
design. The Elements panel contains all of the items that you use to build an intake form.

Add Tab Adds additional pages to your form. You navigate between the pages by using the page tab for
each page.
Workspace The area where you drag and drop form elements from the Elements panel and configure them. This

is the main area used for creating and configuring your forms.

Attributes panel Displays the available attributes that you can configure for the currently selected form element. For
example, if you have a field selected, the attributes panel reads "Field Attributes,” and it contains
attributes specific to fields. If you have a group box selected, the attributes panel reads "Group Box
Attributes,” and it contains attributes specific to group boxes.

Viewing the Tasks for Creating Forms

This section provides the core set of tasks to complete when creating an intake form. The remaining topics in this chapter
discuss the details of each task.

Step Link

Add page tabs. Working with Pages

Add predefined field groups. Working with Predefined Field Groups
Modify field attributes. Working with Fields

Add group boxes. Working with Group Boxes

Add user-defined fields. Working with Fields

Working with Sandboxes

This topic provides an overview of the concept of sandboxes and how they are used within the Intake Form Designer, and it
describes sandbox usage and behavior.
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Most modern development environments typically require several different individuals to work simultaneously on application
changes while sharing the same data model and configuration starting point. The Intake Form Designer utilizes the Oracle
Fusion Applications technology referred to as sandboxes to enable form developers to work on projects simultaneously, and
save and test their work without affecting other developers or the production environment.

The sandbox acts as the development and test mode of your application form. During sandbox mode, the form design can
be viewed only internally by application developers or business analysts. In sandbox mode you can create your form, add
required form elements, add Ul elements, and test your changes. When you have completed all of your design, development,
and test work, you can then publish the form so it can be accessed by end users.

#" Note: Creating and modifying transaction types and intake forms should be completed on your development
environment or your test environment. After making changes, publishing, and testing transaction types and
intake forms on your development or test system, you would then migrate the new and modified definitions to
your production system. Refer to the Functional Setup Manager documentation for information on migrating data
from the test system to the production system, as well as Managing Transaction Type Configurations.

Types of Sandboxes

Oracle Fusion Applications provides these types of sandboxes:

e (lassic sandboxes

e Unified sandboxes

Classic sandboxes are the default sandboxes that are enabled out-of-the-box and always stay enabled.

# Note: To create intake forms, the unified sandboxes feature must be enabled.

For Public Sector Compliance and Regulation offerings, unified sandboxes are an opt in feature that you enable in Functional
Setup Manager. It is required to have unified sandboxes on your development and/or test environment (depending on the
number of pods you have licensed). Do not enable unified sandboxes on your production environment. Unified sandboxes are
utilized during development and configuration work, which should not be taking place on your production environment. If the
unified sandboxes feature is enabled on your production environment, it can lead to unexpected results, especially during the
migration of data from a source environment to the target production environment.

For more information on sandboxes, see https://docs.oracle.com/en/cloud/saas/applications-common/19c/oaext/
configuration-life-cycle.htmI#OAEXT1189604.

Starting a Sandbox Instance for a New Application Form

Before you can create an application form in Intake Form Designer, you must first create the transaction type. For example,
for the permit service, the transaction type is a permit. When you save a permit type, the application creates a sand box
instance. From that point, the transaction type and the associated form design exist within the newly created sandbox
instance.

Each form your implementation team is currently developing exists within its own, separate sandbox instance.

Until you publish the form, the transaction type and the form design remain in the sandbox instance. When you publish a
transaction type, the system eliminates its sandbox instance, and the form is available to users outside the sandbox.
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Starting a Sandbox Instance for a Published Intake Form
After an application form has been published, you can initiate sandbox instances to make any required changes discovered
after the initial publication.

To initiate a sandbox for a published form:

Open the transaction type for the form.
Select Design Form.

Begin making the desired changes.
Click Save.

By clicking Save, the Intake Form Designer creates a new sandbox instance to store the current changes.

pPODdMS

Viewing the Sandbox Status

You can determine if a form is in sandbox mode using the Status indicator located in the top left-hand corner of the Intake
Form Designer. The Status indicator appears when you are creating the form or previewing the form. The sandbox status
does not appear on the published version of the form.

Status Description

draft The form is in sandbox mode. All changes exist in the sandbox instance only.

published The form is not in sandbox mode. The form is available to the runtime environment, where you can
access the form from the landing page.

The draft status is not intended to be used for an extended period of time. It is a temporary mode
for For example, at the end of every day your development work on a particular form layout should be published.
You can prevent the published form that you are still designing from appearing on the landing page by keeping
the Status value set to Preliminary and the Public User Enabled value set to Not enabled for public users. You set
these values on the Transaction Type page. If an upgrade occurs while a transaction type is in draft mode, the
sandbox will be deleted and all changes will be lost.

Refreshing a Sandbox

Each application form is assigned to its own sandbox. Because transaction types share underlying metadata resources,

if during the development of a transaction type or intake form some of the shared metadata resources get updated by
another member of the implementation team, each transaction type also using the shared metadata resources needs to be
synchronized with the most recent metadata updates.

To synchronize the metadata between permits, you need to refresh the sandbox for unpublished transaction types.

You will know that your sandbox is not synchronized with the current metadata resources when you see this message when
you attempt to publish the transaction type:

The application was unable to publish the permit. Click the Manage Sandbox button to access the page where you can
refresh the sandbox.

To refresh a sandbox:

1. InIntake Form Designer, click Manage Sandbox.
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This takes you to the Sandboxes page in Oracle Fusion Applications.
2. On the Sandboxes page locate the sandbox for your transaction type.

The sandbox naming convention is: <Transaction Type Code>__sb_<number of publications>.

For example, if for a permit, the Type Code value is REMODEL, and the sandbox has been published once
previously, the sandbox for that permit is named REMODEL__sb_1.

3. Click on the sandbox you need to refresh.
4. On the Sandbox Detail page review the messages related to the status of your sandbox.

You may notice the Current Status reads Refresh needed and the following note:

This sandbox is not synchronized with the mainline environment. You can refresh the sandbox before making any
further changes.

5. On the Sandbox Detail page, click Refresh.

6. Click Yes on the prompt indicating you are about to refresh your sandbox and that you can’t make changes to the
sandbox during the refresh.

This returns you to the Sandboxes page.
View the Status column on the Sandboxes page, which indicates your sandbox is refreshing.

8. Click on the sandbox again to access the Sandbox Detail page to confirm your sandbox Current Status is Up to
date.

N

You may need to review the merge log and accept changes manually if needed.
9. Once your sandbox is refreshed, close the Sandboxes page, and return to the designer.

Managing Labels for Application Form Elements

This topic describes how to manage changes made to labels for delivered and user-defined application form elements.

When making changes to the labels for elements within your application form, you need to consider what type of element it is.
Changing the label of some elements is a global change, while changing the label of other elements is a local change.

e Global: A global label change means that a change to the label affects every intake form definition using that field or
element.

e | ocal: Alocal label change means that a change to the label affects only the current intake form definition where the
field or element appears.

When you select a form element or field and a label change would have global effects, a warning icon appears above the
Label field in the attributes panel.

When selecting an item in the workspace, if changing the label for that item has global effect on all application forms using the
item, the system displays a warning icon.
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- - = B

Changing this label affects all application forms
using this field. It is a global change. Field Attributes

* A

_I:}

Demolition Reason

Label

" Note: If you change the label of a field after a form has been published and used in the production system, keep
in mind this can affect reporting and the storage of historical data. You may have multiple labels representing the
same data.

Form Element Scope of Label Change Label Change Considerations

Predefined Elements Global The label of a predefined element is the
heading used to describe the grouping of the
fields it contains.

Changing the label of a predefined element is
a global change.

For example, if you change the label in the
Applicant predefined element used in the
fence permit intake form, that change will
be reflected in the Applicant predefined
element used in the electrical permit intake
form (and any other application form using
the Applicant predefined element).

Predefined Element: Parent Field Local Some fields appearing in predefined form
elements are part of the parent record within
the data structure storing the transaction
data.

You know a predefined element field is part
of the parent record when the warning icon
does not appear above the Label field in the
elements panel.

For example, the Description field in the
Application predefined element does not
display the warning icon. Changing this label
affects only the current intake form definition.
It is a local change.

Predefined Element: Child Field Global Some fields appearing in predefined form
elements are part of a child record within the
data structure storing the transaction data.

You know a predefined element field is
part of a child record when the waming
icon appears next to the Label field in the
elements panel.

For example, the Demolition Reason field in
the Demolition predefined element displays
the warning icon. Changing this label affects
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Form Element Scope of Label Change Label Change Considerations

all intake form definitions using the Demolition
predefined element. It is a global change.

User-Defined Elements Local You can change the labels for the fields that
you add to your application forms, such as
text fields, number fields, drop-down lists,
and so on. Because you add these fields
manually to your application form, you can
change the default labels as needed to suit
your business requirements.

The scope of any changes to the label for
user-defined fields apply only to the current
intake form.

HTML Constructs Local A general HTML construct refers to elements
such as group boxes and page tabs.

You can change the labels for general HTML
constructs as needed to suit your business
requirements. The scope of the construct
and any changes to the label apply only to
the current intake form definition.

For example, changing the label of the default
label for HTML constructs such as Group
box or Field O to your desired label affects
only the current intake form definition.

#" Note:
If you change a label for a page tab
or a group box used in an application
form after the form has been published
and used in the production system,
make sure to update any instructions
or documentation that may reference
the previous label.

#" Note: For HTML constructs, such as pages and group boxes, and for user-defined fields the labels display
using the language used to create or modify the application form layout. There is no automatic translation of
these elements. For example, if you created the form in English, but then signed in using Korean for testing,
you will see the English labels for those constructs, unless you have provided translated values using the Fusion
Applications User Interface Text tool. For more information on the User Interface Text tool, see: User Interface
Text Modification.

Working with Pages

This topic describes how to add pages to your application form and how to modify page attributes.

An application form can include one or more pages to contain the field groups and fields that you want to add to your form.
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Adding Pages

When you create a form, by default, the application includes one page for your form. To add additional pages to your form,
click the Add Tab button at the top of the workspace.

Setting Page Attributes

Page Element Description

Label The name of the page that appears on the page tab. The default name is Page 1, Page 2, and so
on. Change the name to your desired label, and tab out of the field.

Hide from public user Hides the page tab and all the elements on the page from the public user at runtime. Only agency
staff can view and update information for a page with Hide from public user turned on.

In addition to hiding the Ul element from the public user in the interface, the application also secures
the back end for that specific Ul element, such as preventing any unauthorized access to the fields
within the Ul element using a REST AP, for example.

¢ Note:

»
An application intake form must have at least one page that is viewable to the public user.
That is, Hide from public user must not be enabled for at least one page tab in the form.

Add Help Click to launch the Contextual Help page, which you can use to add help information to aid end
users in completing the application form.

Page-level help should provide information pertaining to the overall page content. If the information
applies to a specific Ul element on the page, such as a component, group box, or field, consider
adding help directly to that Ul element.

For more information on adding contextual help, see Adding Contextual Help to Forms.

Deleting Pages

If you delete a page from your form, keep in mind that any Ul elements you have added to the page, such as predefined form
elements, group boxes, and fields will also be removed from your form.

To delete a page from your form:

1. Click the Remove button on the tab (the ‘X’ on the right side of the page tab.
2. On the Confirm dialog box, click OK.
3. Save your changes.

Working with Predefined Field Groups

This topic provides an overview of predefined field groups and how you use them to build your application forms.

Oracle provides a set of predefined field groups to help you build application forms easily. Each predefined field group
contains a collection of fields commonly used to capture information for a particular facet of the transaction type. For
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example, the Applicant field group captures information about the person applying for a permit, and the Electrical field group
captures information about the scope of electrical work for a project. Using predefined field groups, you can assemble simple
online application forms in a matter of minutes.

Predefined field groups are:

e Pre-mapped to attributes in the application view object (VO), which ultimately are mapped to fields in the SQL tables
in the application database.

e Grouped logically to provide descriptive metadata for a particular element of an intake form, such as Applicant,
Electrical Equipment, Pool Information, and so on.

You drag the desired predefined field group from the Elements panel onto the workspace. You use various combinations of
predefined and user-defined form elements to assemble your application forms.

For example, assume that you need to create a form for citizens to apply for a roofing permit. In this case, you can drag the
Applicant element and the Re-roof Information element onto the workspace to build your form.

Page Section Example Page Section Fields

Applicant Name
Address
Phone

Re-roof Information Roof Size
Roof Type

Roof Material

Pitch

For more information on the delivered predefined field groups, see Using Predefined Field Groups.

Adding Predefined Field Groups

To add a predefined field group to your form:

1. Make sure the page to which you want to add the predefined field group is the active page.
2. Expand the Ready to Use list in the Elements panel to the left of the workspace.

3. Click on the desired field group to activate it.

4. Select the field group to drag and drop it in the workspace.

This example illustrates dragging and dropping a field group onto the workspace.
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Design Permit Application

Solar Infodev | Status: draft

Elements {C Applicant X  Application Options ¥ | Construction Details % Add Tab

4 Ready to Use
A Field Groups
Applicant
Application
Attachments

Business Information

Constructio
Comment /-—" P%B

Contact Details
Demolition Drag and drop form elements into the workspace.

Electrical

" Note: Intake Form Designer places the predefined field groups in the workspace in the same order in which they
are dropped, in sequence, from top to bottom.

" Note: The Applicant predefined field group is required to be added to your application forms. The internal save
logic checks for a valid applicant address when an end user attempts to save or submit an application form.
It is recommended to include also the Application Information predefined field group, which displays useful
information, including the transaction ID, status, description, important dates related to the application, and so
on. If the transaction type requires fees, then the Fee Summary predefined field group should also be added to
your application form.

Deleting Predefined Field Groups from a Form

To delete a predefined field group, click the Remove button in the Attributes panel.

Setting Predefined Field Group Attributes

Page Element Description

Remove Click to remove the field group from the page.

Label The name of the predefined field group. Initially displays an internal reference for the default label.
Modify the label for your preferred label to display.

¢ Note:

»
Changing the label for predefined field groups can cause unexpected results if you don’t
consider whether the change will be local to the transaction type or global, affecting all
transaction types.

Show Label Control whether to show the label. By default, the system shows labels for predefined field groups
(Show Label is on).
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Page Element Description

To hide the label, turn off Show Label. When turned off, the system hides the label at both design-
time and runtime.

Typically, you’'d want the label to be visible to describe the logical grouping of the fields in the form
element.

In some cases, the page tab name and the predefined field group label might be redundant, in
which case you may opt to hide the label.

You may also want to group multiple predefined field groups within a single group box. In this case,
you can hide the individual predefined field group labels within the group box container, using the
group box label to represent the combined set of fields.

/‘ Note:
When you turn off Show Label, the system disables the collapsible feature for a predefined
field group.

¢ Note:

»
If the predefined field group is delivered without a label, the Show Label attribute does not
appear when you select that form element.

Hide From Public User Hides the predefined field group and all the fields and controls it contains from the public user at
runtime. Only agency staff can view and update information for a predefined field group with Hide
From Public User turned on.

In addition to hiding the Ul element from the public user in the interface, the application also secures
the back end for that specific Ul element, such as preventing any unauthorized access to fields
contained within the Ul element using a REST AP, for example.

Add Help Click to launch the Contextual Help dialog box, which you can use to add help text to a predefined
field group for assisting users with interacting with your intake form. When adding help for a
predefined field group, the help text should apply to the overall contents of the predefined field
group. You can add help also at the page level and the field level, depending on the scope of the
help text.

For more information on adding contextual help to your intake form, see Adding Contextual Help to
Forms.

Control Display Click to define other elements in the form to control wether the field group displays.

For more information on controlling the display of form elements, see Displaying Form Elements
Conditionally .

Adding a Predefined Field Group Multiple Times to the Same Form

The same predefined field group can be dragged into your form multiple times. This is referred to as a multiple-instance
element. How you adjust the Multi-Instance Options attribute determines how the application stores the data for that
predefined field group.

" Note: The Multi-Instance Options attribute appears only for the Comments and the Attachments field groups.
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If you make no changes to the Multi-Instance Options attribute, the data entered within that predefined field group
corresponds to one row of data only. In this case, the system duplicates the display of the data in each area of the form it is
displayed. This option enables you to show the same data on a different tab within the form, if necessary. Updating the data
in one instance of the predefined field group updates the data displayed in the other instances as well.

For example, assume you want the same comment text to appear on multiple pages in your form. You can do this by adding
the Comments element to the desired pages without making any updates to the Value field in the Multi-Instance Options
attribute.

If you make changes to the Multi-Instance Options attribute, the application considers each instance of the predefined field
group unique, and then each individual occurrence of the predefined field group is associated with its own row of data.

For example, assume you wanted to incorporate multiple comment sections in your form. In this case, you can add the
Comments element to multiple locations of your form, and then you set the Multi-Instance Options attribute to different
values. One might relate to fencing comments while another might relate to contractor comments. Another example would be
to enable the end user to upload multiple attachments that apply to separate documents. One attachment might be photos of
a property while another attachment might be blueprint or design documents.

Using the Keyboard to Drag and Drop Elements

You can use keyboard hot keys to drag and drop elements.

Key Description

Enter Use to:

e Expand or collapse the Ready to Use or Add New element lists.

e Drop a selected element onto the selected drop zone

Tab Use the tab key to select either the first element in the list or the last selected item in the list if a
previous visit was made to the list.

Up and Down Arrows Use to:

e Select an item in the Ready to Use or Add New element lists.

e Select a location from the drop zone list. The selected drop zone is highlighted.

Space When an element is selected, the space key highlights the selected element and displays available
drop zones for the current page on the Select a Drop Zone dialog box. The drop zones can be
the page or group boxes contained by the page. For user-defined fields, the drop zones are group
boxes.

Using Predefined Field Groups

This topic lists and describes the set of predefined field groups delivered to help you build forms quickly and consistently.

Predefined field groups are prebuilt user interface modules that you can use as building blocks for assembling forms. Field
groups provide a set of fields and functionality to capture information for various sections of an application form.
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Common Predefined Field Groups

Field Group Description

Applicant Identification and contact information for the citizen filling out the form, including name, address,
phone, and email.

Application Displays information about the form itself, such as status, relevant dates, and descriptions.

Attachments Enables you to attach and download files, such as documents or images. You determine document
properties displayed in the list of attachments and during upload.

Contains multiple instance options to create unique instances of the attachment field group.

Comment Enables you to enter additional comments or descriptions pertaining to information on the form.

Contains multiple instance options to create unique instances of the comments field group.

Contact Details Enables you to add information for individuals or organizations that are contacts for an application.

When users enter contact information in an application, they can create new contacts or choose
existing profile contacts. When creating a new application contact, the user can indicate whether the
new contact should also be added as a profile contact. When choosing an existing profile contact,
the user can modify contact details and indicate whether the original profile contact record should
be updated as well.

Demolition If demolition is required as part of the job, this field group captures information related to the scope
of the demolition and if hazardous materials or utilities need to be considered, such as electricity,
gas, water, and so on.

Fee Summary Lists the items selected, the cost for each item, and the total amount to be paid when submitting
the form.
,f Note:
This does not include additional inspection or other fees which may be assessed at a later
time.
Property Describes the parcel as it is registered with the municipality, such as the parcel ID, parcel type, and
SO on.
Site and Zoning Describes features of the property related to acreage, flood preparedness, as well as zoning and

land usage information.

Terms of Use Provides access to the terms and conditions regulating the usage of the online form, and provides a
way for the user to accept the terms. This field group does not identify which Terms of Use definition
to use, so if you add this field group to an application intake form, you need to also add a Terms of
Use definition on the Permit Type or Planning Application Type page.

The Display Mode property has these options:

e Link: the form displays a Terms and Conditions link that the user clicks to open a window
with the full terms and the check box for accepting the terms.
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Field Group Description
e Embedded: the full text of the terms appears directly on the form.

If the display mode is Link, these two additional properties are available:

¢ Help Text: Enter informational text that appears on the form along with the Terms and
Conditions link.

¢ Display Label: Enable this option to display the description of the Terms of Use definition on
the form along with the Terms and Conditions link.

,f Note:
This field group is not used to set up public user registration terms and conditions. The
Public User Setup page includes all registration-related configuration.

Attachments Field Group

You can configure the attachments field group and add it into your form multiple times. Attachments provide supporting
documentation needed by agency staff when processing a transaction.

Configurable Features Description

Component Attributes You can name the attachments component title in the Label field.

Component Multi-Instance Options Use these multiple instance options to create unique instances of the attachment field group:
e ID
e Value

For more information about multiple instance options, see Working with Predefined Field Groups.

Attachment Columns: You can configure these attachment properties in the attachments list:

¢ File Name: Display the file name of the uploaded file.
e Description: Display the user-entered description.

¢ File Size: Display the size of the uploaded file.

Business Columns: Agency-defined document categories and document subcategories enable you to organize
the various types of attachments. You can configure these fields for document categories and
e DocumentCategory document subcategories:
* DocumentSubcategory e Label: Change the field name.

e Show in List: Display the field in the attachments grid.

¢ Show in Detail: Display the field in the attachment detail information.

e Show in Upload: Display the field on the modal page for uploading an attachment.

e Searchable: Enable search on the document category or document subcategory field.

e Sortable: Enable sorting for the document category or document subcategory field.
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Predefined Permit Field Groups

Field Group Description

Business Information Captures information to help describe the business, such as name, description, number of
employees, industry, and so on.

Construction Information Captures information regarding the current construction site and the proposed construction project.

Electrical EQuipment Describes a structures electrical features, such as outlet types, amps, voltage, and electric
appliances.

Fence Information Describes the proposed fence attributes, such as type, material, dimensions, location, and so on.

Grading Information Describes the scope of grading work, such as the acreage affected, materials to be used and the

amount of material.

Insurance Provides a contractor’s insurance type and policy information.

License Qualification Enables a contractor to add any state licences they have.

Mechanical Equipment Describes features of the job site related to ventilation, heating, cooling, fire safety, and so on.
Photovoltaic Information Describes attributes of a site’s solar energy configuration, such as roof area, coverage area, inverter

information, and so on.

Plumbing Equipment Describes attributes of a site’s plumbing configuration.
Pool Information Describes attributes of a pool, such as type, depth, location, surrounding fencing, and so on.
Regulated Business Activity Enables you to specify any regulated activity or controlled substances allowed on the premises,

such as alcohol, carnival rides, casino games, and so on.

Right of Way Use Enables you to provide any details related to the use of a right-of-way on the property or to gain
access to the property, such as traffic, parking, or pedestrian impact.

Roof Information Describes features of a structure’s roof, such as existing roof type, proposed roof type, number of
layers, and so on.

Signage Describes features of signage, such as the sign’s dimensions, use, whether permanent or
temporary, and illumination.

Special Event Enables you to specify information about an event, including the safety plan, concessions, facilities,
potential impacts, and traffic plans.

Water Heater Describes features of water heaters, such as quantity of new or replaced, type, fuel type, and tank
capacity.
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Field Group Description
Yard Sale Enables you to specify yard sale information, such as the start time, end time, and the number of
days.

Predefined Planning and Zoning Field Groups

Field Groups Description

Dwellings Describes features of housing such as number of units, floor area information, density bonus, rent-
controlled units, and so on.

Impervious Surface Describes features of areas covered by impervious materials, such as concrete or asphalt, including
exemptions from certain requirements, existing and proposed impervious surface areas, and the
property lot area.

Planning Describes features included in planning and zoning, such as proposed number of units, change to
the number of units, assessed value of the current building, development type, commercial building
area, existing land use, lot areas, setbacks, and so on.

Working with Group Boxes

This topic describes how to add group boxes to your form and discusses group box layout options and attributes.

Use group boxes as containers to indicate the items contained within a group box are grouped logically. Once you add a
group box to a page, you can drag these items into the group box:

e Predefined field groups
e User-defined fields

e Other group boxes (nested group boxes)

Adding Group Boxes

To add a group box:

Open the Add New list in the Elements panel.
Open the Layout list.

Click and hold on the Group box option.

Drag and drop the group box into the workspace.

pPODA

Deleting Group Boxes

To delete a group box, click the Remove button in the Attributes panel.

" Note: If you remove a group box from a page, the system removes all of the contents of that group box also.
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Setting Group Box Attributes

Select a group box to view the Group Box Attributes panel.

This example illustrates the attributes for a group box. Details are provided in the surrounding text.

2

Group Box Attributes
Remove

Label

Group box
Collapsible

Flexible Box Layout

Hide Barder

ARAA

Hide from puklic user

Add Help

Control Display

Page Element Description

Remove Click to remove the group box from the page.
Label Add a name for the group box, describing the collection of items within it.
Collapsible Turn on to enable the group box to be collapsed when an end user clicks it, hiding items it contains.

If not turned on, the group box is always expanded and its items are always visible.

Flexible Box Layout Use the Flexible Box Layout attribute to establish a group box container based on the CSS flexible
box layout model. In the flexible box layout model, the items contained within the parent container
assume a layout position automatically, based on space in the container. As the available unused
space grows or shrinks, the items in the container grow to fill the unused space or shrink to avoid
overflowing the parent.
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Description

line until all of the space is utilized, then the system wraps the row, beginning a new line.

When disabled, the controls within the group box display as stacked items, with each additional
control displaying directly beneath the previous control.

With Flexible Box Layout enabled, the system displays as many controls within the group box in one

Show Label

Select to hide the group box label (specified in the Label field).

¢ Note:

»
You can add help only to group boxes with Show Label turned on. If Show Label is turned
off, the Add Help button does not appear on the attributes panel and any help icons
associated with any previously added help no longer appear.

Hide Border

Hides the group box border. When turned on, the border is not visible.

Hide from public user

Hides the group box and all the elements in the group box container from the public user at runtime.
Only agency staff can view and update information within a group box with Hide from public user
turned on. In addition to hiding the Ul element from the public user in the interface, the application
also secures the back end for that specific Ul element, such as preventing any unauthorized access
to the fields contained within that Ul element using a REST API, for example.

Add Help

Click to launch the Contextual Help page, which you can use to add help information to aid citizens
in completing the intake form. The Add Help button appears only if Show Label is turned on. Help

text added for group boxes should apply to the overall group box content. Help can be added also
at the page level, field group level, and field level depending on the scope of the help text.

For more information on adding Contextual Help, see Adding Contextual Help to Forms.

Control Display

Click to select an element in the form that controls the display of the group box.

For more information, see Displaying Form Elements Conditionally.

Example: Nesting Group Boxes

Nested group boxes can be used to represent subcategories of information and to enhance layout options, such as creating

columns for form elements.

The following example illustrates nested group boxes, which you achieve by dropping group boxes within group boxes.

This example illustrates an outer group box container with two inner group boxes nested within to logically divide page

content.
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4 Group Box - Level 1 X
4 Nested Group Box - Level 2 %
Field A *,
Field B >,
4 Nested Group Box - Level 2 .
Field C x,
Field D x

" Note: The system does not impose a limit to the depth of nested group boxes you can insert. For more
complicated pages, for example, you may find that group boxes could be nested to 4-5 levels deep. Make sure
to consider how a page with multiple levels of nested group boxes will render on all the devices you intend to
support for your user base.

Example: Using Group Boxes to Combine Predefined Elements

In some cases you may want to give the appearance of multiple field groups being combined. You can do this using a group
box to act as the outer container for the set of field groups. When using a group box to contain field groups, consider the
following items:

e The collapsible attribute of the group box container controls the visibility of the contained field groups. If the group
box container is set to be collapsible, when the user collapses that group box, all of the elements within that group
box will be hidden.

e |f you want the field groups within the group box to be categorized under just the label of the group box, turn off the
Show Label attribute of the contained field groups.

In the following example, assume you want to combine the Fence Information and Comment field groups, giving the
appearance that Fence Information field group also contains a Comment field.

To combine field groups within a group box container:

Open the Add New list in the Elements panel.

Open the Layout list.

Drag and drop a Group box into the workspace.

Select the group box and make these changes on the Group Box Attributes panel:

pPODd 2
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Group Box Attribute Sample Value
Label Fence Information
Flexible Box Layout Off
5. Open the Ready to Use list.
6. Open the Field Groups list.
7. Drag and drop the Fence field group into the group box
8. Select the Fence field group, and turn off Show Label on the Attributes panel.
9. Drag and drop the Comment field group into the group box.
4 Fence Information x
. x
Type of Work Front Fence Height
Type of Use Rear Fence Height
Pool Enclosure Left Fence Height
Fence Type Right Fence Height
Other Fence Type Location
Foundation Type Corner Lot
Automatic Closing Material
Gate
Other Material
Lock
Comment *
Comment

10. Select the Comment field group, and turn off Show Label on the Attributes panel.
11. Save your changes.

At runtime, the example steps above produce a single, collapsible section in the form that includes both the Fence
Information and the Comment predefined elements.

This example illustrates the collapsed Fence Information group box.

» Fence Information

This example illustrates the expanded Fence Information group box containing multiple field groups.
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4 Fence Information

Type of Work Front Fence Height
Type of Use Rear Fence Height

Pool Enclosure ) Left Fence Height
Fence Type Right Fence Height

Other Fence Type Location
Foundation Type Corner Lot
Automatic Closing Material

Gate
Other Material

Lock

Comment

Example: Using Group Boxes to Combine Field Groups and User-Defined
Fields

Similar to combining field groups within a single group box container, you can also combine field groups and user-defined
fields within a single group box container creating the appearance of user-defined fields being part of a delivered field group.

In the following example, assume you need to associate a field with the Fence Information element to capture the color of a
proposed fence.

To combine predefined elements and user-defined elements with group boxes:
Open the Add New list in the Elements panel.
Open the Layout list.

Drag and drop a group box into the workspace.
Select the group box and make these changes on the Group Box Attributes panel:

Group Box Attribute Sample Value

Label Fence Information

poON =

Flexible Box Layout Off

From the Ready to Use > Field Groups, drag and drop the Fence field group into the group box.
Select the Fence field group, and turn off Show Label on the Attributes panel.

From the Add New > General, drag and drop a text field into the Fence Information group box.
Select the text field, and enter Color for the Label in the Field Attributes panel.

© N o
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4 Fence Information

Type of Work
Type of Use

Pool Enclosure
Fence Type

Other Fence Type
Foundation Type

Automatic

Closing Gate

Lock

Front Fence

Height

Rear Fence Height

Left Fence Height

Right Fence

Height

Location

Corner Lot

Material

Other Material

Color

9. Save your changes.

The following example illustrates how at runtime, the group box containing the field group and the user-defined field create

the appearance of the manually created field being part of the delivered field group.

4 Fence Information

Type of Work
Type of Use

Pool Enclosure
Fence Type
Other Fence Type
Foundation Type

Automatic Closing
Gate

Lock

Calor

Front Fence Height
Rear Fence Height
Left Fence Height
Right Fence Height
Location

Corner Lot
Material

Other Material
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Working with Fields

This topic describes how modify field attributes and add fields to your forms.

When end users are completing an application for a transaction, such as a permit, they enter the required information in fields.
Fields can be added to forms by:

e Adding predefined field groups to your form. Each field group is delivered with a set of fields.

e Adding user-defined elements (fields) to your form.

" Note: The user-defined fields that you create cannot be used (shared) across multiple intake form layouts.

Setting Field Attributes

Select a field to view the Field Attributes panel. Fields in predefined field groups and user-defined fields typically have the
same set of attributes. Not all attributes apply to each field type.

The type of field you select determines the attributes appearing in the Field Attributes panel. For example, for a number field,
you can set a default value and a placeholder value, but for a single-item check box, neither of these attributes apply and
therefore do not appear.

This example illustrates how the Field Attributes panel looks after selecting a field.
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>

Field Attributes
Remaowve

e
Label

Mumber of Floors

Placehaolder

Default Valus

1

Required (:)

Hidden
Add Logic

Add Help

The following table describes the field attributes you can set. Note that not all attributes apply to every field type. Only the
attributes that apply to the currently selected field appear.

Page Element Description

Remove Click to remove the selected field from the layout.

The Remove button appears only for user-defined fields you added manually. You can’t remove
fields from a delivered field group.

Label Add a custom label to the field.

[‘ Note:
In the case of a custom field, the system forces the Map Field value to match the Label
value, but removes any spaces. The map field represents how the field appears in the
underlying data model. For example, a custom field with the label Additional Requests, will

have a Map Field value of AdditionalRequests.

Placeholder Add descriptive text to provide hints for entering data. For example, the placeholder text could read:
Enter date in this format” MM/DD/YY.
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Page Element Description

The placeholder value does not get saved at runtime.

Default Value

Enter a default value required for the field.

The default value gets saved at runtime if the user does not change it.

¢ Note:

»
In cases where both the Placeholder and Default Value attributes appear for a field type and
you have provided values for both, the default value supersedes the placeholder value. That
is, at runtime, the user sees the default value, not the placeholder value, but if they delete
the default value, the placeholder value appears to help users enter a valid value.

Required

Enable if this is a required field for which a user must enter a value.

¢ Note:

»
You can’t delete a field that has been set to be required. You must first turn off the Required
attribute, save the form layout, and then delete the field. Deleting a required field from an
intake form that has already been published may affect forms submitted previously.

Hidden

Hides the field from the user. If a predefined element contains fields that you do not need, select this
option so the user does not have access to the field.

Open Additional Attributes

Add values for fields containing a list of values, such as check boxes, lists, and so on.

For more information, see Defining Fields Displaying a List of Values.

Add Help

Click to launch the Contextual Help page, which you can use to add help information to aid citizens
in completing the intake form. Help text added at the field level should apply specifically to that field.
You can also add help to predefined elements, group boxes, and pages, depending on the scope of
the help text.

For more information on adding Contextual Help, see Adding Contextual Help to Forms.

Add Logic

Click to add scripting logic using the Groovy programming language.

‘l‘ Note:
For user-defined fields that you have added to your intake form manually, the Add Logic
button appears only after you have saved your form.

For more information on adding logic to your forms, see Adding Logic.

Edit

Click to display the Rich Text Editor dialog box for entering formatted text to the application form.
Appears only for rich text areas.

For more information on rich text areas, see Adding Rich Text Areas.
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Adding User-Defined Fields

" Note: You can add user-defined fields to group boxes only. You can’t add user-defined fields directly to a page

or a delivered field group.

To add a user-defined field:

akronNS

Expand the Add New section of the Elements panel.

Open the Layout list.

Add a group box to the current page.

Open the General list in the Add New section.

Select a field type, and drag and drop it in the desired group box.

#" Note: User-defined fields must be contained by a group box.

Select the user-defined field you added, and use the Field Attributes panel to configure your field.

#" Note: User-defined fields and fields provided in predefined field groups use the same set of attributes.

Save your changes.

Once saved, the system applies your user-defined field to the application data model so field data can be captured,
stored, and retrieved.

Choosing User-Defined Field Types

Expand the Add New section in the Elements panel and open the General list to view the field types you can add to your

forms.

#" Note: You must first add a group box to your form, and then you can drop one or more user-defined field types

into the group box container.

Field Type Description

Text field Adds a character field to hold text values.

A text field is limited to a length of 200 characters. If you need to provide a field that enables users
to enter more characters, consider a text area field.

Number field Number field used to contain integer values.

Date field Stores date values, such as 09-26-2018.

Date time field Stores date and time values, such as 09-26-2018 11:25 AM.

Switch On-off field, such as an “active” field indicating whether an item is active or not, which would be

either on or off (yes or no).

Text area A long character field enabling the user to enter longer descriptions.
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Field Type Description

A text area field is limited to a length of 1500 characters.

Rich text area A long character field enabling the user to enter longer descriptions or instructional information that
can be formatted using a rich text editor.

Single-item check box Displays a single option for the end user to select, such as, "I have read the terms and conditions,
and | agree to the terms and conditions." This is different from a check box set, which displays a list
of multiple items for an end user to select.

In the case of a single-item check box, the label of the field acts as the text the end user reads and
responds to on the application form.

Check box set A set of check boxes from which the end user can make multiple selections. For example, the label
for the check box set might be Heating Source(s), with values such as Qil, Gas, Wood, Solar, and so
on.

Radio button set A set of radio buttons from which the end user can make a single selection. For example, the label

for the check box set might be Fence Type, with values such as Stone, Wood, Vinyl, and so on.

Drop-down List A drop-down list allowing the user to select a single item.

Multi-select List A drop-down list allowing the user to select multiple items.

Hiding Fields
In some cases, you may not want to display all of the fields associated with a delivered field group you've added to a form.
You can hide unneeded fields so they do not appear to the user at runtime.

To hide fields:

1. Place your cursor in the field to select it.
2. Turn on the Hidden switch on the Field Attributes panel.

Once you have hidden a field, the design-time interface continues to display the field, but places a darkened background
around the field to indicate it is a hidden field. The application does not display the field at runtime.

This example illustrates the shading around a field to indicate that is hidden during design time.
Location
Corner Lot
Material

Other Material

In this example of the design-time interface, Location and Material are not set to be hidden, but Corner Lot and Other Material
are. Notice that the hidden fields display with the darkened background.
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The following example of the runtime illustrates that the hidden fields do not display when an end user access the form. Only
Location and Material render on the form at runtime, while Corner Lot and Other Material are not rendered.

This example illustrates the fields indicated as hidden in the previous example in design time do not appear on the form at
runtime.

Location

Material

#" Note: At runtime, the system applies this style to the hidden field:style="display: none;”. This style prevents
the field from being visible on the page.

< Note: Required fields can’t be hidden fields. If you set a field to be required, the Hidden switch becomes
disabled. If a field is set to be hidden, and you set it to be required, the system sets the Hidden switch to off
automatically and disables the Hidden switch.

Adding Rich Text Areas

This topic describes how to add rich text areas to your intake forms so that you can display formatted text in application
intake forms.

Rich Text Area Overview

In some cases, you may need to add rich text areas to your application forms so that you can display formatted text for users
filing out the application. For example, if you needed to provide additional information, such as instructions or reference
material, you can provide that within a rich text area.

#" Note: The rich text area provides a way for your agency to provide read-only formatted text for end users. A rich
text area does not enable the end user to be able to insert formatted text into the form.

When you add a rich text area element to your form, an Edit button appears in the Field Attributes panel when you select the
rich text area element. The Edit button launches the Rich Text Editor dialog box.

This example illustrates the Rich Text Editor dialog box displaying bold, colored, and italicized text; normal text; and text
within a numbered list.
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Rich Text Editor X

Keyboard users can place the cursor in the text editor and press Alt + 0 to access keyboard shortcut instructions.

Font - | size B I U|& A Bz 2] |«

Adding Rich Text

To add formatted text to your forms:

1. Add a group box to your form.

2. Drag and drop a rich text area field onto the group box.

3. Select the rich text area element, and click Edit in the Field Attributes panel.
4. Add your text using the Rich Text Editor dialog box.

5. Click OK.

body ol i

The Rich Text Editor dialog box provides these formatting options:

e Font size

e Bold, italic, underline

e Copy formatting

e Text color

e Text background color

e Numbered and bulleted lists

e Undo and redo

* Increase and decrease indentation

e Horizontal line

Adding a Rich Text Area to a Form

To add arich text area:

Insert a group box into your form where you want to place the rich text area.
From the Add New > General list, drag and drop a rich text element into the group box.
3. Select the rich text area element.

N =

This example illustrates the rich text area element being selected prior to rich text being added.
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X
Field O

This is a rich text area. To add or edit content, select this element, then
open the rich text editor.

4. In the Field Attributes panel, click Edit to open the Rich Text Editor dialog box.

" Note: If needed, you can use the Description field to enter a description of the contents of the rich text
area for other implementation team members. The description you enter only appears in the designer; it is
not be displayed at run time.

5. Add text and use the desired formatting options.
Click OK.
7. Save your form layout.

°

Defining Fields Displaying a List of Values

This topic describes how to add a list-of-values to user-defined fields you add to your application forms manually.

Some of the user—defined fields that you can add to your form are considered “list-of-value” fields. List-of-value fields enable
end users to select field values from a predefined set of values (a lookup list) to populate the field when entering data on the
form. For example, radio sets and drop-down lists are list-of-value fields.

The list of values is a lookup type, and the individual items in the lookup list are lookup values.

When adding a list-of-value field type to your application form, you first add the field to the form, just as you would any other
field. You then select an existing lookup type to associate with the field, or you can create a new lookup type if needed. To
manage lookup types you use the Custom Lookups page.

This example illustrates the Custom Lookups page.
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Custom Lookups x

Lookup Type

+

Lookup Type Meaning Actions

PSC_FLOOR_TYPE Flooring Select >
PSC_HAZARD Hazardeous Data Select >
PSC_ROOF_TYPE Type of Roof Select >
PSC_TYPES_OF_WORK Types of Work Select b
PSC_ZONE Zoning Select >

A list of values is a set of fixed field values defined for a specific purpose that is not expected to change over time. Removing
items from the list, for example, could make previously saved data invalid.

An example of a field with a list of values could be the Property Zone Type field, where the values for a user to select are:
Business, Residential, and Agricultural.

|dentifying List of Value Type Fields

You associate a list of values with these field types:

e Radio button set
e Check box set
e Drop-down list

e Multi-select list

The following example illustrates a radio set, which is a set of radio buttons allowing a user to select a single value from the
list of values.

Text surrounding the image describes it.

Ferce @ “Wood

K aterial Stone

Chain Link

The following example illustrates a check box set, which is a list of multiple items allowing a user to select multiple values from
the list of values.

Text surrounding the image describes it.
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The following example illustrates a drop-down list, which is a list allowing a user to select a single value from the list of values.

Text surrounding the image describes it.

Furnace b

Manufacturer
Armana

Armerican Standard
Bryant
Rinmai

Trane

The following example illustrates a multi-select list, which is a drop-down list allowing a user to select multiple values from the

list of values.

Text surrounding the image describes it.

Heating Sourcels) Propane X Salar %

Electricity
il

Pellet
Wood

Selecting an Existing Lookup Type for a Field

To select an existing lookup type:

1. Add the list-of-value type field to your form layout.
2. Select the new field.

3. Click Open Additional Attributes in the Field Attributes panel.
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This opens the Custom Lookups page.

4. On the Custom Lookups page, identify the lookup type to associate with the list-of-value field you added.
Use the Meaning column to identify the appropriate list, or you can click View More Details to view the description
and the actual lookup values in the lookup type.

5. Click Select in the Actions column to associate the desired lookup type with your field.

6. Close the Custom Lookups page.

7. Save the form layout.

Adding a New Lookup Type for a Field

1. Add the list-of-value type field to your form layout.

2. Select the new field.

3. Click Open Additional Attributes in the Field Attributes panel.
This opens the Custom Lookups page.

4. On the Custom Lookups page, click Add.

5. On the Lookup Type Details page, enter these values.

Page Element Description

Lookup Type The system name, beginning with PSC, using uppercase letters, numbers, or underscores.

For example, PSC_ROOF_TYPE.

# Note:
All lookup types created and used within the Intake Form Designer must begin with
PSC.

Meaning The value that appears in the Meaning column of the list of lookup types, which can help to
identify the contents of the list.

For example, Roof Type.

Description Provide any additional information to help identify the purpose and intended usage of the
lookup type.

6. Add lookup values to the lookup type.
a. Under Look Up Valug, click Add.
b. Modify these values:

Page Element Description

Lookup Code A short code used to identify the lookup value to the system, like a key value.

Display Sequence If required, you can set the sequence in which lookup values display in the lookup list,
using a numeric sequence.

Enabled By default, a new lookup value is enabled. To disable a lookup value, turn off this
switch.
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Start Date Date on which a lookup value becomes valid.
End Date Date on which a lookup value is no longer valid.
Meaning The value that displays to the end user at runtime to select from the list.
Description Any additional information to describe the content or purpose of a lookup value.

c. Click Save.
d. Repeat for additional lookup values in the lookup type.

Example:

This example illustrates a completed lookup type with lookup values.

Custom Lookups x
Lookup Type Details ez
* Lookup Type PSC_ROOF_TYPE Description  Types of roofs used for housing and
buildings.
b Meaning = Roof Type
Lookup Value

+ h 4

Loockup Code Display Sequence Enabled Start Date End Date Meaning

AL Yes Aluminum >

SH Yes Shingle >

TL Yes Tile >

AS Yes Asphalt >

7. Close the Custom Lookups page.
8. Save the form layout.

Understanding the Scope of Lookup Types Created in the Intake Form
Designer

The items in the following table describe the scope of the list of value fields that you can create and use in the Intake Form
Designer.

Scope Item Description

User-defined fields You only can add to and modify the list of values associated with user-defined fields, which are the
specific fields you have added to your application form manually. You can’t add or modify a list of
values for a field contained within a delivered field group, such as the delivered Fence field group.
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Scope Item Description
Intake Form Designer-only The lookup types that you create within the Intake Form Designer can be used only within the Intake

Form Designer, and only in specific circumstances can you associate a field in your form layout with
lookup types created outside the Intake Form Designer.

The interface used to create and select lookup types for use in your intake forms looks identical to
the Lookups page (Navigator > Common Setup > Lookups), which is the interface used to manage
lookups for Public Sector Community Development offering pages, such as the permit offering or
the planning and zoning offering. However, the lookup types created on the Lookup pages can not
be used for your intake forms nor visa versa. For example, you can’t use the UOM Type lookup type
(ORA_PSC_CC_UOM_TYPE) from the Lookup Type page for your intake form fields.

Other licensed offering(s) in the same In select cases, if you are an existing Fusion Application Cloud customer, and you have other
database licensed offerings in the same database as the Public Sector Compliance and Regulation offerings,
you can utilize lookup types not beginning with PSC for your intake form fields.

For example, if you are a Fusion Application Cloud for Financials, which shares the same database
as the Public Sector Compliance and Regulation offerings, you can select lookup types using the
Intake Form Designer interface, assuming you are aware of the values it displays and how it is
maintained.

To access these lookup types, you need to modify the filtering on the Lookups page. Refer to the
following example for more information.

Example: This example illustrates modifying the default filtering for the Intake Form Designer lookups.
To modify the filtering on the Lookup Type page:
1. Click the Filter By button.

2. Clear PSC from the filter field.
3. Click Apply.

This example illustrates using the Filter By button on the Lookup Type page to display more than just lookup types beginning
with PSC.

Custom Lookups x

Lookup Type

g

@ Filter By x
| Lookup Type ¥ | | Starts with | E

YTVl Clear  SaveAs  Add Criteria .

Displaying Form Elements Conditionally

This topic describes how you can show or hide elements on your forms depending on selections users make on other form
elements.

You can configure some form elements to be either displayed or hidden, depending on the value of other fields in the form.
Form elements that can control the display of other elements are controlling elements, and form elements that can be shown
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or hidden based on the value of controlling elements are controlled elements. The following table describes the elements
involved in conditional display.

For example, assume you wanted to display the Photovoltaic field group only if the user has selected the Solar single-item
check box in a “Building Options” section of a permit application form. In this case, you can set the Solar single-item check
box as the controlling element for the Photovoltaic field group, having the Photovoltaic element (the controlled element)
display only when the Solar single-item check box is selected.

Display Type Element Types Description
Controlling Element e Single-item check box Form elements that determine whether another form element is
) displayed, depending on the value selected by the user.
e Switch
# Note:

Only single-item check boxes and switches can be controlling
elements.

Controlled Element e Field group Form elements that can be displayed conditionally, depending on the

value of the associated controlling element.

e Group box
To control when these elements appear, click the Control Display
button on the Attributes tab, which appears only for these element
types.

Procedure: Configuring Conditional Display

To configure conditional display for a form element:

1. Add the controlling element to a group box in your application form.
The controlling element can be a user-defined element of these types:
o single-item check box
o Switch

" Note: The controlling element must appear before the controlled element that references it.

2. Add the form element that you want to display or hide conditionally (the controlled element).
The controlled element can be:
o field group
o group box

®

Select the controlled element you just added so that it is the active element in the layout.

4. In the Attributes panel, click Control Display.

5. On the Control Element Display dialog box, click Add to add a row to the grid, then double-click in the newly added
row, and make the appropriate selections.

This example illustrates the Control Element Display dialog box set to show a condition of a controlling element, such
as hide this element if a switch element in the form is false.
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Control Element Display x

If you add multiple rows of display conditions in the grid, and any display condition evaluates to true, the element will be

hidden.
+ @
Display A Controlling Element Value
Hide if Application Options - Plumbing False

Cancel “
Element Description

Add Click to add a new row to the grid.

After adding a row, double-click the row to make it active.

# Note:
If you add multiple rows of conditions to the grid, the system assumes an “OR”
operator exists between each row. If any of the conditions are confirmed, that
display option will be enabled.

Delete Click to delete the selected row in the grid.

Display Currently, Hide if is the only display option. You hide an element based on the value of the
controlling switch or single-item check box, otherwise, the element is displayed.

Controlling Element Select the form element that will control the display of the selected predefined form element
or group box.

The drop-down list displays all user-defined switches and single-item check boxes that exist
on or before the current page in the form.

Selecting the controlling element appearing before the controlled element adheres to the
logical sequence a user would take when completing the application form.

# Note:
If the selected element is a group box, the drop-down list does not display any
switches or single-item check boxes within that group box.

Value Select the value of the controlling element that determines when the display option will be
rendered:

o True: A condition is true if a single-item check box is selected or a switch is on.

o False: A condition is false if a single-item check box is deselected or a switch is off.
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6. Click OK.
7. Save your form.

The controlled element appears with an icon below the element label to indicate it is an item whose display is controlled by
another element in the intake form.

This example illustrates the icon displayed for a controlled element.

4 Solar Installation Information

Type of Use Roof Materia

Type of Roof Roof Layers

Service [D Roof Connaction
lete

MNumber of Roof

Photovoltaic Connections
fodules

Adding Logic

This topic describes how to add validation logic to form elements to validate the values added by end users. The language
used for this logic is Groovy.

Groovy Overview

You can add validation logic to fields in your application form using the Apache Groovy programming language. Apache
Groovy is an object oriented language that can be used for scripting or programming. Groovy is often referred to as an
extension of the Java programming language and uses similar constructs and syntax. For Java developers, Groovy can
be compared to other programming languages, such as Python or Ruby, that don’t intend to replace Java, but act as a
companion language, extending capabilities and providing additional flexibility.

In the context of designing application forms, in the current release you use Groovy as a scripting language to create validator
scripts to provide data integrity for end user input. A validator script is a logical construct that returns either true or false.

Currently, only simple field validation scripts are supported for your application forms.

For example, assume you have a form with the field, Number of Rooms, to indicate the number rooms in a structure, and you
need to confirm that zero isn’t entered by the applicant. You could add the following simple validation script.

/* Field value for "Number of Rooms" must be greater than zero.*/
newValue > 0

The essential components of a validator script include:

e Groovy logic

e An error message
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At runtime, if the field value entered does not meet your validation logic criteria during a save request, the system displays the
error message to the user so they can resolve the issue.

#" Note: The Groovy validation executes only when the user either saves or submits the form. If there is any
delivered validation for a field contained within a delivered field group, that delivered validation runs before any
custom Groovy validation you have added. Before adding Groovy logic to a field delivered in a predefined field
group, make sure to test the field group at runtime to become familiar with any delivered, internal validation.

Before adding Groovy validation, you will need to become familiar with the Groovy language and how it is intended to be used
within Oracle applications.

For more information on Groovy usage within Oracle, refer to Oracle Applications Cloud: Groovy Scripting Reference.

For general information on the Groovy language, see Apache Groovy documentation.

Setting the Scope of a Groovy Script

The following table outlines the possible scope of a Groovy script.

Scope Description Where Set

Field You can add Groovy logic to act on a single Select the field to which you want to add
field. The code you add runs only against the validation logic, and click Add Logic in the
selected field. Field Attributes panel for that field.
You can add Groovy to fields in delivered
field group or to user-defined fields you have
added manually.

Object If your script involves more than one field, When in the designer with the application

you need to add that code at the object level.
The object refers to the current application
form you are creating. For example, if you
are creating a fence permit, the logic you add
for the current object applies to fields in that
fence permit definition.

f Note:
To get the field names of each field
you want to reference in your object-
level script, you need to select that
field, click Add Logic, and copy the
field name provided in the comments
in the Groovy Script Editor.

form open, click the Add Logic button at the
top of the form, next to the Preview button.

#" Note: For validating at the field level use newValue and oldValue to reference the current field. At the object

level, use the field name, such as NumberofRooms_c to reference fields.

# Note: In the case of multiple field-level validations, each runs independently. However, in the case of object-level
validations, the object-level validation runs only if all field-level validations have passed.
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Working with the Groovy Script Editor

To access the Groovy Script Editor:

1. Save the intake form you are creating.

The field(s) you reference in your logic at the field level or the object level must exist in the underlying database
object, which occurs when you save the form after adding any new elements.

2. Click the Add Logic button in the Field Attributes panel or in the intake form header.

When clicking Add Logic in the Field Attributes panel, your code operates at the field level. When you click Add
Logic in the intake form header, your code operates at the object level.

The following example illustrates adding validation logic to a field using the Groovy Script Editor.

Groovy Script Editor x

Walidators

Script Name *

1 /* Field validator for field NumberofRooms_c MumberofRooms_c_validator -
2 Custom Object LNP1INFODEV_c */
3 newValue > @ Description

Number of rooms in structure must be

*
Error Message

Number of rooms in the structure
must be greater than 0.

Save Close

Page Element Description

Work Area In the work area, add your validation logic.

The first line in comments (/* <text> */) is automatically generated, and it provides you the field name
and object name as they are referenced internally.

For a field contained in a delivered field group, the field name will be similar to the field label, such as
DemOverallHeight.

In the case of a user-defined field, the field name will match the field label you have entered, with a
“c” as a suffix to indicate it is a custom field.

For example, if you have a user-defined field named Rooms, the field name appearing in the script
will be Rooms_c.

The custom object name is the type code as defined on the Transaction Type page, with either a
“LNP1” or “PZ1” prefix and a “c” suffix. “LNP1” is the prefix for permits and “PZ1” is the prefix for
planning and zoning applications.

For example, if the Transaction Type Code is Fence, the custom object name in the script will be
LNP1Fence_c.
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Page Element Description
,f Note:

For validating at the field level use newValue and oldValue to reference the current field. At
the object level, use the field name, such as Rooms_c.

Script Name By default, the script name follows this structure:
field_validator
or
object_validator

You can change the script name if needed.

Description Add text to describe the purpose of the script.

Error Message Provide the message that the system displays the user if the data entered for the field does not pass
the validation logic.

The validator script returns either true or false. If the return is false, the system displays the error
message.

#" Note: While you can delete fields with Groovy logic associated with them, make sure the Groovy logic evaluates
to True prior to deleting the field, otherwise you risk making the entire transaction type invalid.

Adding Contextual Help to Forms

This topic describes how to add help text to various parts of your intake forms to aid citizens when they are filling out an
application form.

Working with Contextual Help

If you determine that the end user needs additional information to understand a user-interface element in your intake form,
you can add contextual help text to that user-interface element. If you add contextual help to a user-interface element in your
intake form design, the system displays a Help icon next to the label of that user-interface element.

You can see the Help icon in both the design and runtime mode. At runtime, end users click the Help icon to display your
help text in a popup, without leaving the page.

#" Note: At design time, the Help icon does not display the help text popup when clicked.

You can add contextual help text to these intake form elements:

e Page tabs
e Field groups
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e Group boxes

e Fields (applies to fields in field groups and to custom fields)

< Note: For group boxes and field groups, you can add help only when with the Show Label attribute turned on.

You can’t add contextual help text to these intake form elements:

e Radio sets
e (Check box sets

If you need to add help for radio sets or check box sets, use a group box to contain the control and add the help text to the
group box container.

Adding Contextual Help

To add contextual help:

1. Select the page element to which you want to add contextual help.

" Note: You cannot add help text directly to radio sets and check box sets. Add help text to a group box
surrounding the radio sets or check box sets.

2. Click the Help button in the attributes panel.
3. On the Contextual Help Setup page, note the Type Code, Page Name, and Page Object values.

These values uniquely identify the page element to which you are associating the contextual help. You can’t change
these values. They are read-only and maintained by the application.

[tem Value

Type Code An automatically generated value consisting of the internal product code and the permit type
code derived from the permit type definition.

Page Name The name of the page tab on which you are adding help. Regardless of what the page label
is on the tab, the application displays each tab using the default name in sequence, such as
tabs1, tabs2, and so on.

For example, the second page tab in an intake form may have the name Fence Information,
however in the Page Name field it will appear as tabs2.

Page Object Identifies the page element for which you are adding help. Regardless of the page element’s
label, the application displays the internal naming convention as the field value, which is the
page element type code + sequence added.

For example, for the second field added to the form the field value is fields2, which indicates
the element is a field and it is the second field added to the form.

The page element type codes are:
o Field groups: ccas

o Group boxes: widgets

o Fields in field groups: <field group>_<internal field name> (such as
ccas2_ReleaseDate)
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10.
11.
12.

ltem Value

o Custom Fields: fields

In the Description field, add text to describe the purpose of the help text so other implementation team members can
understand the content.

Click the Add New button in the Contextual Help Details grid to display the Add Context Help Details dialog box.
Select Agency Defined from the Type drop-down list.

#" Note: Help topics of type System Defined are provided by Oracle and should not be altered or
removed. Customers should use the Agency Defined help topic type to add help topics specific to your
implementation. If you want your custom help text to display instead of delivered help text, disable the
System Defined help topic, create your custom topic, and enable it.

Activate the Help Content edit box by clicking to the right of the Help Content field label.

In the Help Content edit box, enter your help text.

The system provides rich-text editing features, which enables you to implement limited formatting options, as
needed.

When you’ve added the content, and you are ready for it to be viewed by end users, turn on the Enabled switch.

" Note: To prevent the help content from displaying at run time, turn off the Enabled switch.

Click Save on the Contextual Help Details page.
Click Save on the Contextual Help page.
Confirm that the help icon appears on the page tab or next to the page control label in your intake form design.

For more information on contextual help, see Setting Up Contextual Help.

Setting Form Options

This topic describes the options you can set for the entire form to control the ways citizens interact with the form.

Enabling the Review Page

The review page presents all the fields of a multi-tab form on a single, scrollable page for efficient review of the entered data
prior to submitting the form.

By default, the review page displays:

Form fields as read-only, but the end user can click the Edit button for each field group to modify the fields as
needed.

All field groups expanded.
For multi-page view or single-page view.
For all forms, unless disabled.

To disable the review page:

1.

In the Intake Form Designer, click the Form Options link.
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2. On the Form Options dialog box, turn off Review Page.
3. Click OK.
4. Click Save.

Setting a Confirmation Step

You can enable one of the pages in a form as a confirmation page to display after the end user has filled in the information
and submitted the form. You create the confirmation step in the designer and then set it to be the confirmation step in the
Form Options.

When set as the Confirmation Step, the page displays:

e At design time with the page tab filled in grey to indicate it is the confirmation step.

e At runtime as the last page in the train stop drop-down list.

" Note: The confirmation step does not display as part of the single page view.

To enable the review page:

In the designer, click the Form Options link.

On the Form Options dialog box, select the desired page from the Confirmation Step drop-down list.
Click OK.

Click Save.

pPoODNd =

Mapping Form Fields to Decision Model Attributes

This topic describes how the fields added to an intake form in the designer are mapped to the fee model defined for the
transaction type.

The Fee Mapping page in the designer is used to map attributes in the decision model to the fields added to the intake form.
The Fee Mapping page is step 2 in the Intake Form Designer, where designing the layout is step 1.

This image illustrates Step 2 of 2: Fee Mapping in the design of a permit application.
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Desigﬂ Permit Appl ication Add Logic Preview Save Publish

PermitTypefee11  Status: published

< Previous Next

NCeWXei Pl Fee Mapping

Fee Mapping
4 Permit Fees/PermitApplicationFees/1.0/PermitApplication
Model Attribute Attribute Type Record Type Attribute

ProjectValue number Job Cost v

4 Permit Fees/BuildingPermit/1.0/BuildingPermit

Model Attribute Attribute Type Record Type Attribute
ProjectValue number Select a record type attribute v

Submitted By

NewSqFootage number

Classification

ConstructionType Construction

. Type of Work
UseType string

Type of Use

New Floor Area Classification v

» Permit Fees/Electrical/1.0/Electrical

» Permit Fees/PlumbingMechanical/1.0/PlumbingMechanical

You assign a fee schedule to an application type on the Transaction Type page using the Fee Schedule field. You map
attributes from the fee schedule’s underlying decision model created in Oracle Integration Cloud to the fields you have added
to your intake form either through delivered field groups or by adding fields manually.

" Note: Not all model attributes need to be mapped. Because a fee schedule can be reused by multiple
transaction types, only the model attributes required for fee calculations for the current application type need to
be mapped. All other model attributes can be left blank.

For more information on setting up fee schedules, see Setting Up Fee Schedules.

For more information on decision models, see Creating Decision Models for Fees.

Mapping Application Fields to the Fee ltem in the Decision Model

To access the Fee Mapping page in the form designer:

1. Navigate to the Transaction Type page:
o Permit Setup > Permit Type

o Planning and Zoning Setup > Planning Application Type

Select the transaction type that you want to view in the designer.
Click the Design Form button.

Click the Next button while in the application form setup step.
The fields on the Fee Mapping page are as follows:

Page Elements Description

Model Attribute The name of the attribute as it appears in the decision model in Oracle Autonomous
Integration Cloud.

akrobd

Not all model attributes must be mapped. Because fee schedules can be reused by multiple
transaction types, only the model attributes required for fee calculations for the current
transaction type need to be mapped. All other model attributes can be left blank.

81
ORrRACLE


http://www.oracle.com/pls/topic/lookup?ctx=pscr19d&id=task_SettingUpFeeSchedules
http://www.oracle.com/pls/topic/lookup?ctx=pscr19d&id=concept_CreatingDecisionModelsForFees

Oracle Public Sector Compliance and Regulation Cloud Chapter 4

Implementing Community Development Creating Intake Forms
Attribute Type The data type of the model attribute, such as string, number, boolean, and so on.
Record Type Attribute The field added to the intake form layout either contained in a predefined form element or a

user-defined element you have added manually.

6. Select the record type attribute from the drop-down list that you want to map to the decision model attribute.
7. Click Save.

Considering User Experience

This topic describes concepts related to using forms that implementation teams need to consider when designing forms.

Required Fields

The system validates that required fields contain values prior to a save request at runtime.
If a required field is empty the system displays the following error message on the page.

This example illustrates how the system displays messages to indicate what is required for a field.

at least 3 alphanumeric characters

€ Value is required.
You must enter a value.

In addition to the message, the system disables the Save button until the required field values have been provided.

The system also displays an itemized list at the top of the form when clicking Save so that in the case of multiple pages, the
user can navigate quickly to the item and provide an acceptable value. The error message lists the error and the location to
which the end user must navigate to correct the error. The list if errors can be expanded and collapsed as needed.

This example illustrates an error message appearing at the top of the form, displaying in the list the error, and the location of
the offending field.

4 O Correct the Following Errors and Try Again

* You must select an applicant.
(Step 1: Applicant)
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Runtime Application Form Save Behavior

When an end user navigates to another page in the application form using either the train stop drop-down list or the Next
button, the system automatically:

e Saves the currently entered data.

e Performs data validation on the current page.

If the end user attempts to navigate away from the application form page using, for example, the back button, entering a
different URL, or reloading the page, the system checks for any unsaved changes or new data. If the changes or new data
have not been saved, the system displays a message to the user indicating that if they continue, unsaved changes and new
data will be lost. The user can elect to leave the page or remain on the page to save.

Runtime Train Stop Drop-Down Behavior

The train stop drop-down list, appears in the center of the application form header to provide:

Feature Description

Context The system automatically prepends the appropriate step number to the application form page
name. The step numbers are assigned in the order the pages appear in the designer (from left-to-
right).

For example, assume you have three pages in your form: Application Details, Fence Details,
Property Details. The train-stop drop-down list displays the pages as:

e Step 1: Applicant Details

e Step 2: Fence Details

e Step 3: Property Details

Current Page To show the current page the user is viewing, the system displays a single, right-pointing, chevron
character (>) to the left of page label in the drop-down list.

Navigation Select any page in the application form, including the review page, to access it immediately.

Switch to Single/Multi-page view Toggle between the multi-page view or the single-page view.

Using the Single-Page View
When accessing the single-page view in review or advanced-edit mode, end users will notice these characteristics of the
page elements.

Page Element Behavior

Edit button Enables the end user to activate the form fields for editing. Initially, the system displays them in read-
only mode. Once clicked, the system toggles the Edit button to the Done button.

Done button Once the end user completes any changes, clicking Done:

1. Performs any configured data validation.
2. Saves changes to the database.
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Page Element Behavior

3. Retumns the form fields to read-only.
4. Toggles the button back to read Edit.

Group boxes If a group box contains multiple group boxes, only the outer (parent) group box displays an Edit/
Done button.

Field groups If there are multiple field groups in a group box, they will appear to be a single page section, with
one Edit/Done button controlling all the field groups within the parent group box.

Otherwise, if the field groups are on the page tab separately (not within the same parent group box
container), then the system displays an Edit/Done button for each field group.

Expand All/Collapse All Expands or collapses all the elements on the page, including group boxes and field groups within
parent group boxes.

" Note: The Edit button and the Done button do not appear on a page rendered in advanced edit mode if the
form is displayed in a read-only context. For example, if the user viewing the form does not have sufficient
privileges or if the user has already submitted the form, the fields in the form will be disabled and the Edit button
and Done button will not be rendered on the page.

Advanced-Edit Mode

If needed, agency staff members can update a form after a citizen has submitted the form. Agency staff members access the
submitted form using the Permit Details page in the Permit List or by deep linking. Editing a form after a citizen has submitted
it is referred to as advanced-edit mode.

When in advanced-edit mode, the system:
e Displays only the field groups enabled for advanced-edit mode.
e Presents the form in the single-page view.

Agency staff members click the Edit button to activate fields and update data, and they click Done to save changes.

#" Note: Customers cannot configure whether a delivered field group appears in advanced-edit mode. Field
groups enabled for advanced-edit mode are controlled and delivered by Oracle development. Only the field
groups that are appropriate for agency staff members to update are enabled for advanced-edit mode.

Testing Intake Forms

This topic describes the methods and considerations involved with testing your application forms.

You design, create, and test application forms on your development or test environment. Depending on what you have
licensed, you may have a combined development and test environment, or you may have a separate development and test
environment. You can test forms both inside and outside sandbox mode.

Once your forms have been created and thoroughly tested, you then migrate the newly created forms to your production
system for public access.
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Testing Forms Inside the Sandbox

You can test draft application forms in the sandbox using the Intake Form Designer preview mode. To enter preview, click the
Preview button.

In preview mode, you can test the layout of the user interface and the tab flow in a simulated runtime scenario. The preview
mode does not enable you to enter data and save it. To test the full functionality and data validation of your intake form, you
must first publish the form in your test system, as described in the following section.

#" Note: The Intake Form Designer does not activate the Save button in preview mode.

Testing Forms Outside the Sandbox

Once you are done testing the configuration of your form and the layout of the user interface using preview mode, you can
begin testing your form in scenarios that end users will encounter when they interact with your intake form. To do this, you
need to publish your form on the test environment.

For more information on publishing forms, see Publishing Intake Forms.

" Note: The testing data you enter and save during testing remains in the underlying database tables after the
form is migrated to the production system.

Migrating Application Forms Between Environments

After you have completed your testing of the application form on the test environment, follow the procedure in Functional
Setup Manager for migrating transaction type metadata and intake form layout metadata from the test database to the
production database.

For more information on test-to-production data migration, see Managing Transaction Type Configurations.

Publishing Intake Forms

This topic describes the steps to complete to publish intake forms.
To make your application forms available on public landing pages, you need to publish your form.
To publish a form:

1. Confirm that you have saved and tested all changes made to your form.
2. In the Intake Form Designer, click Publish.
3. Navigate to the Transaction Type page:

To navigate to the Transaction Type page you can either click Back in the global header, or select Permit Setup >
Permit Type.
4. On the Transaction Type page, open the appropriate transaction type, and set these values:
o Transaction Type Status: Ready
o Public User Enabled: Enabled for all users or Enabled for registered users.

5. Click Save.
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" Note: After publishing a transaction type, if you attempt to access the application from a landing page and the
application displays an error, make sure the Transaction Type Status and Public User Enabled attributes are set
correctly.

" Note: After publishing a transaction type application, the application may not be accessible immediately. It can
take several minutes to apply the most recent changes and transfer the application from the sandbox to the live
runtime system.

Related Topics
® Setting Up Permit Types

Cloning Transaction Type Definitions

This topic describes how to clone transaction type definitions and the associated form design. It also covers the attributes
that will be shared between the source and clone definition and the attributes you will need to modify on the cloned definition.

You can clone a transaction type to:

e Save time when creating a similar transaction type, rather than creating a new transaction type for each situation
from scratch.

e Create a new version of a currently published transaction type after making a significant correction or addition to the
transaction definition.

In some cases, it may be more efficient to create a new transaction type and form, while in other cases, it may be more
efficient to clone an existing transaction type and form.

When you clone a transaction type, you make a cloned copy of:

e Most of the transaction type metadata, such as the specified Classification, Auto Number Rule, Department, Fee
Schedule, and so on. Some of the metadata is not cloned, such as Transaction Type, Transaction Type Code,
Transaction Type Status, Help Text and so on, as you'll need to modify those values for the cloned copy.

e All of the intake form layout in the Intake Form Designer, including pages, group boxes, field groups, and user-
defined fields you have added to your application form.

When deciding to clone a transaction type, you may consider:
e The number of fields and pages within the existing application form layout that you’d need to change.
e Similarity between the existing transaction type and new transaction type.

e Number of shared attributes.
# Note: In general, if you intend to make numerous modifications to the cloned copy, it may be more efficient to
start a new transaction type from scratch.

When cloning to make a new transaction type, you will want to make sure you are aware of:

e The attributes that will be shared between the source definition and the clone.

e The attributes you need to modify to create unique values between the source definition and the clone.
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" Note: All modifications you make to a should be done in your test environment and not on your production
environment. After you have thoroughly tested your changes in the test environment, your modifications should
be migrated using the Functional Setup Manager task flows.

Transaction Type Metadata Considerations

All of the field values on the Transaction Type page will appear in the cloned transaction type, except for selected field values
listed in the following table.

Make sure to update any of the copied information on the Transaction Type page to reflect the requirements of the new
transaction type. For example, if the Department, Fee Schedule, or Workflow information, should be different, make sure to
update it for the new transaction type definition so it is associated with the correct items.

Page Element Description

Type The type name doesn’t have to be unique. You can create a new transaction type by using a unique
value or enter the same value as the source transaction type, if you are creating a new transaction
definition with the same transaction type.

Type Code The type code must be unique. Enter a transaction type code that identifies this version of the
transaction type definition.

Status Initially, for a newly created transaction type the status on the Transaction Type page is always set
to Preliminary. After you publish the form, change the status to Ready for Use.

Valid From Date The application inserts the current date for the cloned transaction type.
Valid To Date Update to reflect your business requirements.
Public User Enabled Initially, for a newly created transaction type this is always set to Not enabled for public users. When

you are ready to publish the new transaction type, update this value.

For more information on the fields on the Transaction Type page, see Setting Up Permit Types.

Intake Form Layout Attribute Considerations

The following table addresses specific considerations for Ul elements in your form layout with respect to cloned transaction
types and application forms and how any changes you make to the cloned definition may affect the source definition.

Element Description

Field groups The cloned copy of the transaction type contains the same layout as the source definition.

If the intake form utilized any of the delivered field groups, the application copies the field groups into
the cloned copy of the definition, using the same layout as the source definition. For example, if you
added the Fence field group to the source permit definition to the second page tab, the Fence field
group would appear in the cloned copy of the transaction type on the same page tab.

Labels The labels for fields and Ul elements, such as pages, group boxes, field groups, and so on, are the
same between the source and cloned definition.
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Element Description
User-defined fields Any fields you have added manually to the source will be copied, as is, to the cloned definition.

For any fields that you have defined a list of values, make sure it applies to your new transaction
type.

Security The cloned definition will have the same security configuration as the source definition for:

e Data security for column authorization and data redaction.

e (Cases where Hide from public user has been implemented.

Help If any help has been added to the form for a page, field group, group box, or field, for the source
definition, the application does not copy help references into the cloned definition.

¢ Note:

»
You can remove the help references from the cloned form, but do not delete the help text
from the Contextual Help page if other forms are still using that help text.

You are also cloning the fee mapping, which is defined in the second step of the Intake Form Designer.

Cloning a Transaction Type to Create a New Transaction Type

When you clone a transaction type, you also clone the associated form design. You can clone just the transaction type
definition without cloning the application form design; however, you can’t clone just the form design by itself.

#" Note: When you clone a transaction type, the type status defaults to Preliminary on the new transaction type,
and the status of the new application form defaults to Draft in the Intake Form Designer.

This example illustrates the Clone Permit Type page, which is described in the steps for cloning a permit type.
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Clone Permit Type

Original Permit Type Solar Permit

Original Permit Type Code LLSolar0918a

* New Permit Type

*

MNew Permit Type Code

Use Original Workflow Setup o
Clone Form Design ()

To clone a transaction type:

1. Select Permit Setup > Permit Type.

2. Open the desired transaction type.
3. Click the Clone button.

4. On the Clone Type page, enter the following values:

Page Element Description

New Transaction Type

Enter a transaction type name.

The transaction type name can be the same as an existing transaction type name so that
you can have different versions of the same transaction type. For example, if the original
transaction type name is Fences, you can reuse the name for the new transaction type
definition, but you must enter a unique type code to distinguish the two.

New Transaction Type Code

Enter a unique transaction type code.

Oracle recommends manually adding a version number to the source transaction type code
if you want different versions of the same transaction type definition. For example, if the
original type code is Solar-001, you can enter a new code, Solar-001-v2

Use Original Workflow Setup

Turn on the switch to use the original workflow setup as defined in the original transaction
type. Turn off the switch to leave the workflow setup fields blank on the new transaction
type. You must enter a workflow setup values.

Clone Form Design

Turn on the switch on to clone the application form design associated with the original
transaction type. Turn off the switch to create a completely new application form using the
Intake Form Designer.

" Note: Providing a unique type code is required to make the transaction type definition unique.

ORrRACLE

89



Oracle Public Sector Compliance and Regulation Cloud Chapter 4
Implementing Community Development Creating Intake Forms

5. Click the Create button.
The cloning process opens the cloned copy of the transaction type.

#" Note: When saving the cloned definition, the application places the cloned definition within a sandbox.

6. Make any other required changes to the cloned transaction type definition and form design.
See the previous sections for more information regarding what items to check.

" Note: If there are numerous custom fields in the application form, when you have the layout open in
Intake Form Designer, it can take several minutes to perform the initial save. While saving, the application is
creating all of the custom fields, creating the other elements, and running validation.

7. Publish the application form in the Intake Form Designer.

For more information on publishing a transaction type, see Publishing Intake Forms.
8. Return to the Transaction Type page to change the status to Ready for Use.

Considerations for Creating a New Version of a Transaction Type Using
Cloning

In some cases, you may want create a new version of an existing, published transaction type to correct an error or make a
change.

If the change made is insignificant, as in it does not change the meaning of a field or page element, then in most cases
cloning is not required, and you can simply make the change directly to the transaction type definition. For example, assume
you have a field for an email address on your form, and it had been requested to change the label from E-mail to Email
(removing the hyphen). In this case, the change can be made directly to the form and republishing it.

However, in other situations, the change may be significant, in that it affects reporting associated with transaction type, alters
historical data, makes future data out of sync with historical data, and so on.

Significant changes where cloning a transaction type is recommended include:

Transaction Type Element Examples of Significant Changes

Field groups e Changing the label of a field group.
* Adding
* Removing
e Updating the security (Hide from public user)
e Changing the label, hidden, or required setting of a field within a field group.

User-defined form elements * Adding
* Removing
e Setting to required
e Updating a default value

e Updating the security (Hide from public user)

HTML Ul constructs e Adding page tabs
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Transaction Type Element Examples of Significant Changes
* Removing page tabs

e Adding group boxes

* Removing group boxes

Creating a New Version of a Transaction Type Using Cloning

Creating a new version of a transaction type using the cloning feature involves:

e Deactivating the published version of the transaction type.
e Cloning the published version of the transaction type.

e Activating the cloned copy of the transaction type.

To deactivate a published transaction type:

1. Select Permit Setup > Permit Type.

2. Open the definition for the published transaction type.
3. Setthe Transaction Type Status field to Void.

4. Click Save.

To clone the published transaction type:

1. With the transaction still open from the previous steps, click Clone.
Enter the same Transaction Type value as used for the recently deactivated transaction type.
3. Enter a unique Transaction Type Code.

# Note: Providing a unique transaction type code makes the transaction type definition unique. To keep
track of versions, you can add v2, v3, v4 to the code, for example.

4. Save the cloned definition.

" Note: When saving the cloned definition, the application places the cloned definition within a sandbox.

5. Make any other required changes to the cloned definition transaction type and form design.

See the previous sections for more information regarding what items to check.
6. Click Publish in the Intake Form Designer to publish the cloned definition.

For more information on publish a transaction type, see Publishing Intake Forms.
To activate the new transaction type:

1. Select Permit Setup > Permit Type or press Back from the Intake Form Designer interface.
Open the definition for the published transaction type.
3. On the Transaction Type page, set these values:

o Transaction Type Status: Ready for Use.
o Public User Enabled: Enabled for all users or Enabled for registered users.
4. Click Save.
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Managing Transaction Type Configurations

This topic describes the considerations and steps related to migrating transaction type definitions, such as permits or
planning and zoning applications, from your test environment to your production environment.

Transaction Type Lifecycle Overview

Any implementation of Oracle Applications Cloud usually requires migrating setup data from one environment to another at
various points in the subscription lifecycle.

For example, you set up your initial configuration of the Public Sector Community Development services in the test
environment, which is your source system. Then, after thorough testing and verification, you move the setup and
configuration data from your test environment to the target environment, which is your production system.

You use the Fusion Applications Functional Setup Manager to perform these migration tasks.

This example illustrates that you use Functional Setup Manager to migrate data between your test and your production
environment.

Functional Setup
Manager

Source: Test System Target Production
System

You access Functional Setup Manager from within Public Sector Community Development by selecting Navigator > Setup
and Maintenance or by clicking the Setup and Maintenance tile on the springboard. To access Functional Setup Manager,
you need to have the System Administrator role associated with your user account.

The functional areas in Functional Setup Manager that apply to your transaction type definitions and application form
definitions are:

Offering Functional Area
Public Sector Permits Permit Types
Public Sector Planning and Zoning Planning Application Types
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Offering Functional Area

Like using Functional Setup Manager to setup your configuration, when migrating data, you use a top-down approach. That
is, if you are not exporting the entire configured offering, and you are exporting by functional area, you need to export the
functional areas in the order they appear.

For more information on using Functional Setup Manager, see Using Functional Setup Manager.

#" Note: All configuration changes should be completed and tested in your test environment and then migrated to
the production environment. Changes made directly to the production environment might be overridden during
subsequent test-to-production migration activity.

For additional information related to migrating configuration data from your test environment to your production environment
for the Public Sector Compliance and Regulation offerings, see Oracle Public Sector Community Development: Test to
Production (Doc ID 2551940.1) on My Oracle Support.

Set the Target Instance URL

On the source system (your test environment), you need to define the URL target system (your production environment) so
that setup data and configuration data can be sent to the target.

To set the target instance URL:

Sign on to the test environment.

Click the Setup and Maintenance tile on the springboard to access Functional Setup Manager.

On the right side of the Functional Manager Setup interface, click the Tasks tab to open the Tasks drawer.

Click Search, and search for Manage Configuration Set Migration Target Security Policy.

On the Manage Configuration Set Migration Target Security Policy page, enter the URL for your target environment,
and the appropriate security credentials for the System Administrator role.

aprpODdS

" Note: Itis recommended to include the port number when you specify the URL value. For example:
https://server.example.com:443 You can get the target port value by accessing the Manage Configuration
Set Migration Target Security Policy page on your production system (your target).

6. Save.

Managing Unified Sandboxes on the Source and Target System

Public Sector Compliance and Regulation requires the Unified Sandboxes feature to be enabled on your test environment,
where you are actively designing and configuring your implementation. It is recommended that you disable the Unified
Sandboxes feature on your production system.

For migrating transaction types from your test system to your production system, especially, make sure to disable the Unified
Sandboxes feature on your target, production system. Because you should be completing all configuration tasks on your
source test system, sandboxes shouldn’t be required on the production system. Having the Unified Sandboxes enabled on
the production system can cause the Configuration Set Migration utility not to render or function properly.

To disable Unified Sandboxes:

1. Sign on to your target, production system.
2. Navigate to Functional Setup Manager.
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3. Select your solution, such as Public Sector Permits or Public Sector Planning and Zoning.

# Note: Disable Unified Sandboxes in all solutions you have licensed for Public Sector Compliance and
Regulation.

4. Click the Change Feature Opt In link.
5. Locate the Application Extensions feature, and click the pencil icon in the Features column.
6. Make sure the Unified Sandboxes feature is disabled.

" Note: If there are any open sandboxes, they need to be deleted or published before you can disable this
feature.

7. Click Done.

Migrating Transaction Type Foundational Metadata

Before you use Functional Setup Manager to export transaction type configuration data, you need to create and migrate a
configuration set, which includes the underlying metadata required to be in place as a prerequisite prior to migrating other
transaction type setup data.

Because the Public Sector Compliance and Regulation solutions are metadata-driven, you need to migrate the metadata that
is the foundation of the transaction definitions. This is the data stored in the Oracle Medata Services (MDS) layer. You do this
by creating a configuration migration set. Once that is complete, you can then begin using Functional Setup Manager export

and import features to transfer the rest of required definitions between test and production systems.

#" Note: Before you migrate transaction type metadata from your test system, ensure that the transaction type
definitions and associated intake forms are complete, tested, and published.

These steps must be completed before you use the Functional Setup Manager export and import
options.

To migrate transaction type metadata:

Sign on to the test system, which is the source system.

Click the Setup and Maintenance tile on the springboard to access Functional Setup Manager.

Select the appropriate offering (Permits or Planning and Zoning).

Expand the Permit Types or the Planning Application Types functional area (depending on your offering).

poODN =

" Note: These steps for creating a migration set apply only to the Permit Types and the Planning
Application Types functional areas.

5. Click the Manage Permit Configuration task or the Manage Planning Application (depending on your offering).

This example illustrates selecting the option Manage Permit Configuration, which you select to set up and migrate a
configuration set.
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Permit Types

Yiew v Format - :@_’] Detach Show Required Tasks

Task

Manage Custom Role for Permit Access

Create Process Cloud Service Proxy User

Manage ‘Warkflow in Process Cloud Sernvice

Map Swim Lane Roles to Process Cloud Service Groups

Manage Workflow Communication Events

Manage Permit Configuration

E 2 = T
LLEE= L e gy L o gy e

Lpdate Workflow Integration Connector

Manage Permit Type Display Groups

#" Note: This link takes you to the Manage Configuration Set Migration Target Security Policy. You can also
access this page in Fusion Application by selecting Navigator > Configuration > Migration .

6. If you have not already specified your target instance URL, you must do that prior to the next step.

See the previous section for more information.
7. Select the Outgoing tile and create an outgoing migration set to export to your production environment.

When creating a configuration set, the utility compares differences between source and target, and determines the
metadata that needs to be exported to the target system. When the process is complete, the resulting migration set
is downloaded in the form of a downloadable jar file.

8. After finishing the creation and migration of the outgoing migration set, sign on to the production system (the target
system), and complete the steps for applying the incoming migration set.

This example illustrates an incoming configuration set.
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For more information on these steps, refer to Oracle Applications Cloud documentation: Configuring and Extending
Applications.

Exporting and Importing Remaining Transaction Type Data

After you have completed migrating the configuration set on the source system, you then export the remaining transaction
type data using the Functional Setup Manager options for the functional area or the entire offering.

" Note: You can export and import at the functional area-level by selecting the Actions button for the functional
area or at the entire offering level by selecting the Actions button at the top right.

This example illustrates using the functional area export options.

= parmit T Manage Waorkflow Con
ermit Types t

* Accounting Shared

View Documents 3

Edit Implementation Status i

* OPA Questionnaire

Sharad Setup Data Report (3]
* Digital Assistant S »C
Import »
* Agency Staff Shared
Expart to T35V File »
Public Users Shared Import from CSV File >
* Analytics and Reporting hared Compare Setup Data 2

After exporting from the test system, you then sign on to the production system and import the corresponding business
object data.

When you export business object data, you have the option to select only those business objects that you utilize. For

example, if you are not using application groups, you could deselect Manage Application Groups from the Business Objects
list.

The objects you export will be in the form of a downloadable jar file.
For more information on these Functional Setup Manager export and import features, see:

Using Functional Setup Manager: Managing Setup Using CSV File Packages
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Using Functional Setup Manager: Exporting and Importing Setup Data
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5 Setting Up Inspections

Setting Up Inspection Statuses

Oracle delivers inspection statuses for use during the inspection process. You review the statuses on the Inspection Status
page.

You review inspection statuses during permit setup on the Inspection Status page. You cannot delete the system-defined
statuses or add new statuses, but you can modify the associated inspection status names and descriptions.

Modifying Inspection Statuses

1. Select Common Setup > Transaction Status .
2. Select the Inspections tab.
3. You can review the delivered inspection statuses in the System Status column:
o Pending
o Requested
o Scheduled
o Completed
o Canceled
o Deleted

Select the row for the inspection status that you want to modify.
5. On the Inspection Status Details page you can edit the inspection status name and description.

E

The status name is used as the display status for the inspection in the permit application.
6. Click Save to save any changes.

Inspection Evaluation Overview

The inspector evaluates a building site for adherence to codes and regulations required for a permit. The example here
provides information about an inspection set up to use automatic score calculation with the bottom up scoring method.

A permit might require one or more inspections, each inspection might have one or more checklists, and each checklist might
have checklist items or not, depending on the inspection configuration. The inspector performs an inspection by assessing
the checklist items, if any, then checklists, and up to the inspection level. The evaluation results that the inspector enters are
rolled up to the next level until a final inspection score is calculated if scoring is used.

Scoring is not required. The score is the rolled up to the next level automatically only if scoring used. Otherwise, you specify
the result manually on each level.

The following example describes the setup and results of performing an inspection using the bottom up method of scoring.
Scoring bottom to top indicates that the inspector starts with a zero score and adds points for each criterion that is met.
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Example: Using the Bottom Up Scoring Method

Before you begin, set up the assessment type, rating method, passing rule, scoring method, and checklist, which includes
the checklist items. In this case, you don’t need to set up the checklist group, because checklist and checklist group are
mutually exclusive of each other.

This example illustrates setup for an inspection on the Inspection Type Details page. Details are in the surrounding text.

Inspection Type Details

* Inspection Type  CK_SCHDINSP_FNC Enabled C
* Description  FNC Scheduling Inspections * Estimated Duration in Hours 5
Scheduling Method = Schedule v
[ Assessment Type _passFai o | Passing Rule  PR-123 Q
| Rating Method GRADE Q | Scoring Method  Bottom up v
* Autonumber Rule CK_FNC_Insp o Maximum Score
Checklist Group o} Checklist CK-FNC-0100 o
Billable Bill Type o
Policy Name Policy Version
Inspector Signature Required v Owner Signature  Optional v
Contractor Signature  Optional v Schedule Cutoff Time
Inspection District Type CK_DISTRICT_TYPE_FNC_INSP o Schedule Change Policy 3

Hide Inspector Comments

Cancel Delete

The setup includes the following:

1. Assessment Method

The assessment method is defined on the assessment type page and used in the inspection type definition. During
the inspection, the inspector selects an available assessment which is associated with a system result. The system
result determines the scoring calculation as follows:

Displayed Assessment System Result Scoring Calculation
Pass Pass Score = All Points
Corrected on Site Corrected Score = All Points
Fail Fail Score = No Points
NA (not applicable) Other Score = No Points

" Note: Only the displayed assessment value is configurable by the agency. The available system results
are Pass, Fail, Corrected, and Other. You must have one assessment with a system result of Pass and
one assessment with a system result of Fail. You can define multiple assessments with system results of
Corrected and Other.

See Setting Up Inspection Assessment Types.
2. Inspection Scoring Method
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The scoring method is defined on the inspection type. In this example, the scoring method is Bottom Up.

See Setting Up Inspection Types.
3. Rating Method

When you use a scoring method, you also must set up a rating method. The rating method defines the range of
scores used at the inspection type level.

See Setting Up Rating Methods.
4. Checklist

The checklist used in the inspection is defined on the inspection type. For example, the checklist could be Electrical
for a residential addition. For multiple checklists, you enter a checklist group name. A checklist group can have
different inspection checklists, such as both Electrical and Plumbing for a residential addition.

See Setting Up Inspection Checkilists.
5. Checklist Item

The inspection score is defined in the inspection checklist details. In this example, each checklist item is set up with
a possible score of 25. The inspector’s assessment determines how many points are applied to the checklist. When
the inspection result is Pass, the item receives the complete score.

See checklist details in Setting Up Inspection Checklists.
Based on the setup, an example inspection evaluation might look like this:

Checklist Iltem Possible Score Inspector’s Assessment System Calculated Score Checklist Total

Checklist Item Status Score
Result (Assessment)

1 25 Pass Pass 25 tem 1 =25

2 25 Pass Pass 25 ftem 1 + ltem 2 =50

3 25 Corrected on Site Corrected 25 ltem 1 + ltem 2 +
ltem 3 =75

4 25 Fail Fail 0 Item 1 + ltem 2 +

tem 3 + Item 4 =75

For multiple checklists, the sum of the checklist scores determines the inspection score.

Setting Up Inspection Assessment Types

Assessment types identify the results available for assessing an inspection, for example, Pass and Fail. You add, modify, or
delete assessment types and codes for inspections on the Assessment Type pages.

An assessment type includes one or more assessment codes, which identify the possible results for the inspection type.
Assessment types are also used for inspection checklist and checklist item results.
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Assessment types function independently of the scoring method, maximum score, and minimum score, for example:

e [f the system result is Pass or Corrected, the full score is assigned.
e |f the system result is Other or Fail, the score is 0.

Scoring for each system result is predefined in the system for inspections.

This example illustrates the Assessment Type Details page containing the field values described in the following table.

Assessment Type Details

* Assessment Type * Description Result is either Pass or Fail

Assessment Details

Assessment Description System Result
Fail Fail

Pass Pass

Adding Inspection Assessment Types

Select Inspection Setup > Assessment Type .

apobdA

Enter values in the fields of the assessment code row:

On the Assessment Type page, click Add to add an assessment type.
On the Assessment Type Details page, enter an assessment type name and description.
In the Assessment Details section, click Add in the assessment code row.

Cancel

Actions
v+ 0
v L]

Page Element Description

Assessment Enter a code name.

Description Enter descriptive text for the code.

System Result Select the system-defined result value that you want to set for this assessment code:
o Other
o Pass
o Falil

o Corrected

You must map each assessment code to a system result value. Each assessment type must
include a system result of Pass and a system result of Fail. The default value is Other.

g
# Note:

You must assign Fail to only one code. Likewise, you must assign Pass to only one

code.

The system result is used in the inspection result processing. If scoring is used, the system
result of Pass and Corrected receive the maximum score. The system results Other and Fail

receive no score.

The system result is also used to determine whether an inspection result is pass (system
result Pass) or fail (system result Fail). For example, the Inspection Summary report includes
violation information when a checklist or checklist item result is associated with the system

result Fail.

ORrRACLE
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Page Element Description

6. Click the Add icon at the end of the row to add another assessment code row.
7. Click Save.

Modifying Inspection Assessment Type Details

1. Select Inspection Setup > Assessment Type .
Select the row for the assessment type you want to modify.

3. Inthe header fields on the Assessment Type Details page, you can only modify the assessment type description.
You cannot change the name.

4. Inthe Assessment Details section, you can:

o Change the description of an assessment code. You cannot change the code name.

o Select a new value in the System Result column. Available values are Pass, Fail, Corrected, or Other. Each
assessment code must be mapped to a system-defined result value. The default value is Other. You can only
use Pass and Fail once.

5. If you made any changes, click Save.

Deleting Inspection Assessment Types

1. Select Inspection Setup > Assessment Type .
2. On the Assessment Type page, click the Edit icon.
3. Select one or more check boxes for the assessment type rows you would like to delete.

#" Note: When you delete an assessment type, you also delete the associated details.

4. Click the Delete icon.

Deleting Inspection Assessment Type Details

1. Select Inspection Setup > Assessment Type .
On the Assessment Type page, select the row for the assessment type you are working with.

3. On the Assessment Type Details page, click the Delete icon at the end of the assessment code row you would like
to delete. You delete details one row at a time.

4. Click the Save button.

Setting Up Rating Methods

A inspection rating method may have one or more rating ranges, which an inspector uses to evaluate the object of an
inspection. You add, modify, or delete rating methods and rating details for inspections on the Rating Method page.

If you are using scoring for inspections, you must also set up rating methods. Rating methods are used at the inspection type
level and are not required at the checklist or checklist item levels.
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Adding Rating Methods

You add an inspection rating method by setting up the rating method code with a description and rating details. For example,
an agency might use GRADES as the rating method code, with a description of Standard Grades. The rating details might
include grades such as A (high) to F (low), and provide a range of scores to each rating. If the rating for an A grade is defined
by 90-100 points, an inspection score of 95 would receive an A.

1. Select Inspection Setup > Rating Method .
2. On the Rating Method page, click Add to add a rating method.
3. On the Rating Method Details page, enter a rating method name and description. The description is a user-friendly
name for the inspection rating method.
4. To add rating method values, click the Add button for the first row in the detail grid, and the Add icon for the next
rows.
5. Enter values for the rating method:
Rating Enter a short name for the rating.
Minimum Score and Maximum Enter minimum and maximum numerical values to specify the range for this rating. Do not
Score use decimals.
The range for this rating cannot overlap the range for another rating.
6. Click Save.

For example, if your rating method uses grades A through F, you specify the rating range for each grade in the Rating
Method Values table. The range for each rating cannot overlap the range for another rating.

Rating Minimum Score Maximum Score
A 91 100

B 81 90

C 71 80

D 61 70

F 0 60

Modifying Rating Methods

1.
3.

4.

Select Inspection Setup > Rating Method .
On the Rating Method page, select the row for the rating method you want to modify.

In the header fields on the Rating Method Details page, you can only modify the rating method description. You
cannot change the name of the rating method.

Click Save.
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Modifying Rating Method Values

You can change the minimum and maximum scores for a rating on the Rating Method Details page.

pPODd

5.

Select Inspection Setup > Rating Method .

On the Rating Method page, select the row for the rating method you want to modify.

On the Rating Method Details page, select the rating row in the values grid that you want to modify.

Change the values in the Minimum Score or Maximum Score fields for this rating on the Rating Method Value
Details page. You can use the arrow icons to increase or decrease the score values. The range for this rating cannot
overlap the range for another rating. You cannot change the name of the rating.

Click Save.

Deleting Rating Methods

1.

3.

o A

7.

Select Inspection Setup > Rating Method .
On the Rating Method page, select the row for the rating method you want to delete.
On the Rating Method Details page, click Delete.

" Note: When you delete a rating method, all associated rating details are also deleted.

To delete multiple rating methods, click the Edit icon on the Rating Method page.
Select the check boxes for the rating methods you want to delete.
Click the Delete icon.

" Note: When you delete multiple rating methods, all associated rating details are also deleted.

Click Save.

Deleting Rating Method Values

ONOoO RN

Select Inspection Setup > Rating Method .

On the Rating Method page, select the row for the rating method you want to modify.

On the Rating Method Details page, select the ratings row in the value grid that you want to delete.
On the detail page for the individual rating, click Delete.

To delete multiple rating method values, click the Edit icon in the Rating Method Values section.
Select the check boxes for the rating method values you want to delete.

Click the Delete icon.

Click Save.

Setting Up Passing Rules

A passing rule identifies the different ways an inspection can be scored. You add, modify, and delete passing rules for
inspections on the Passing Rule page.

Passing rule definitions provide the criteria for determining whether an inspection passes or fails. If the scoring method is not
used in the inspection type definition, a passing rule is not required.
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Adding Passing Rules

A passing rule may have one or more scoring ranges that you specify in the passing rule details.

akroN 2

6.

Select Inspection Setup > Passing Rule .

On the Passing Rule page, click Add to add a new passing rule.

On the Passing Rule Details page, enter a unique code for the passing rule and a description.
To add scoring ranges, click Add in the Passing Rule Criteria section.

Enter values in the fields on the rule details page:

Page Element Description

Description Enter a description for the scoring range.

Minimum Score and Maximum Enter minimum and maximum numerical values to specify the scoring range. You cannot use
Score decimals.

Number of Major Violations Enter a value for the maximum number of major violations allowed.

Pass Turn on the Pass switch if the specified scoring range combined with the number of

violations results in a passing inspection. If the specified range and violations do not result in
a passing inspection, leave the option disabled.

# Note:
For passing inspections that are based on a passing rule with the Pass switch on,
the inspection result displays the assessment name that is defined with the system
status Pass. If the Pass switch is off, the inspection result displays the assessment
name that is defined with the system status Fail. The system uses the assessment
type that is associated with the inspection type.

Click Save.

Modifying Passing Rules

1.
3.

4,

Select Inspection Setup > Passing Rule .
On the Passing Rule page, select the row for the passing rule you want to modify.

In the header fields on the Passing Rule Details page, you can only modify the passing rule description. You cannot
modify the passing rule code.

Click Save.

Modifying Passing Rule Details

You can change the scoring range for a passing rule on the Passing Rule Details page.

pPODdM
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Select Inspection Setup > Passing Rule .

On the Passing Rule page, select the row for the passing rule you want to modify.

On the Passing Rule Details page, select the scoring row in the details grid that you want to modify.
You can change the following scoring details:

a. Description of the scoring range.
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b. Minimum and maximum scores to update the scoring range. Use the arrow icons to increase or decrease the
score values.

c. Number of major violations allowed.
You can also indicate that the specified scoring range combined with the numiber of violations can result in a passing
inspection, by clicking the Pass slider. Turn off the option using the slider if the scoring range combined with the
violations does not result in passing an inspection,
5. Click Save.

Deleting Passing Rules

When you delete a passing rule, all associated passing rule criteria are also deleted.

Select Inspection Setup > Passing Rule .

On the Passing Rule page, select the row for the passing rule you want to delete.

On the Passing Rule Details page, click Delete.

If you want to delete multiple passing rules, you can delete them from the Passing Rule page:
a. Click the Edit icon.
b. Select the check boxes for the passing rule rows to delete.
c. Click the Delete icon.

pPODS

Deleting Passing Rule Criteria

Select Inspection Setup > Passing Rule .
On the Passing Rule page, select the row for the passing rule with the passing rule criteria you want to delete.
In the Passing Rule Criteria section, select the row for the passing rule criteria you want to delete.
On the Passing Rule Criteria Details page, click the Delete button.
If you want to delete multiple scoring ranges, you can delete them from the Passing Rule Details page:
a. Click the Edit icon.
b. Select the check boxes for the passing rule criteria rows to delete.
c. Click the Delete icon.

agkroDN=

Setting Up Inspection Checklist Categories

Use checklist categories and subcategories organize the various types of checklists items for inspections.
You set up inspection checklist categories and subcategories on the Inspection Checklist Category page.

Use the checklist categories and subcategories for categorizing checklist items when you set up inspection checklists on the
Inspection Checklist ltem Details page. See Setting Up Inspection Checklists.

Adding Checklist ltem Categories

Select Inspection Setup > Checklist Category .
On the Checklist Category page, click Add to add a checklist category.
On the Checklist Category Details page, enter a category ID and description.

If you want to add a subcategory, click the Add button to add the first subcategory in the Checklist Subcategory
section. Click the Add icon for additional subcategories.

pPODS
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5. On the Checklist Subcategory Details page, enter a subcategory ID and a description.
6. Click Save.

Modifying Checklist ltem Categories

1. Select Inspection Setup > Checklist Category .
2. On the Checklist Category page, select the row for the category that you want to modify.
3

On the Checklist Category Details page, you can only modify the category description. You cannot change the
category ID.
4. Click Save.

Modifying Checklist ltem Subcategories

Select Inspection Setup > Checklist Category .

On the Checklist Category page, select the row for the category with the subcategory that you want to modify.
Select the subcategory that you want to modify in the Checklist Subcategory section.

You can only change the description on the Checklist Subcategory Details page.

Click Save.

apON~

Deleting Checklist Iltem Categories

When you delete a checklist category, all associated subcategories are also deleted.

Select Inspection Setup > Checklist Category .

On the Checklist Category page, select the row for the category that you want to delete.

On the Checklist Category Details page, click Delete.

If you want to delete multiple checklist categories, you can delete them on the Checklist Category page:
o Click the Edit icon.
o Select the check boxes for the category rows to delete.

o Click the Delete icon.

pPODNS

Deleting Checklist Subcategories

Select Inspection Setup > Checklist Category .
On the Checklist Category page, select the row for the category with the subcategory that you want to delete.
On the Checklist Category Details page, select the row for the subcategory that you want to delete.
Click the Delete button on the Checklist Subcategory Details page.
If you want to delete multiple subcategories, you can delete them on the Checklist Category Details page:
o Click the Edit icon.
o Select the check boxes for the subcategory rows to delete.

o Click the Delete icon.

aprpON

Setting Up Inspection Checklists

Inspection checklists identify all the items that the inspector must assess during an inspection. You set up inspection
checklists and checklist items on the Inspection Checklist pages.
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Before adding inspection checklists, you set up:
e Inspection assessment types for your agency, if you want to associate a checklist with an assessment type.

See Setting Up Inspection Assessment Types.

e Inspection checklist categories and subcategories, if you want to categorize your checklist items.

See Setting Up Inspection Checklist Categories.

You add, maodify, and delete checklists and checklist items in the inspection setup pages. The checklist and checklist items
are copied to the inspection when the inspection schedule is created, and appear on the Inspection Checklist page, the
Checklist Items page, and the Checklist ltem Result page.

#" Note: When you modify an inspection checklist or checklist item, the updated checklist is applied to new
inspections using the checklist. Existing inspections use the version of the checklist definition in use when the
inspection was scheduled.

You identify the checklist or checklist group to use for an inspection on the Inspection Type page. To set up a checklist group
after setting up checklists, see Setting Up Inspection Checklist Groups.

This example illustrates the Inspection Checklist Details page containing the field values described in the preceding table.

Inspection Checklist Details Concel  Delete

* Checklist CK-FN
* Description  FNC_Checklist

Maximum Score 100 Minim

Scoring Method  Not used v

Checklist ltems
= [ (= Search. aQy
Checklist Item Description Required Score Major Violation
Fence-Height Fence-Height Yes No
Fence-Material Fence-| Material Yes No
Fence-Type Fence-Type Yes No

Footings Footings Yes No

v v v v v

Gate Gate Yes No

Show 8 items v

Adding Inspection Checklists

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, click Add to add a checklist.

On the Inspection Checklist Details page, enter a checklist ID and description.

Verify that the Enabled switch is turned on. The switch is turned on by default for new checklists.
You can also enter values for these fields:

Page Element Description

Assessment Type Enter an assessment type.

apopA

The system determines a passing result based on the assessment type defined for the
checklist. The assessment that is defined with system status Pass is used for the passing
result. Otherwise, the assessment that is defined with the system status Fail is used.
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Page Element

Description

Assessment types function independently of the scoring method, maximum score, and

minimum score.

See Setting Up Inspection Assessment Types.

Maximum Score

Enter the maximum score possible for the checklist. This value is required if the scoring
method is Top down, which will be available in a future release.

Minimum Passing Score

Enter a minimum score for a passing grade. This value is required for the scoring method
Bottom up.

If the total score for the checklist is equal to or greater than the minimum passing score, the
checklist receives a passing result.

Scoring Method

Select a scoring method to be used for the checklist:

o Bottom up: Scoring from the bottom up indicates that the scoring starts with zero and
the inspector adds points for the criteria that are met.

o Not used: This is the default value and indicates that no scoring method is used for
this checklist. You must specify the result manually for each level: checklist item,
checklist, and inspection.

If you don’t use the scoring method you can’t use the passing rule and rating method.
This also means that results are not automatically calculated starting with the checklist
items to the checklist to the inspection level.

# Note:
The scoring method specified for the checklist should match the scoring method in
the Inspection Type definition.

Comment

Enter any additional information.

6. Click Save.

Adding Inspection Checklist ltems

1. Select Inspection Setup > Inspection Checklist .

2. On the Inspection Checklist page, select the row for the checklist to which you want to add checklist items.

3. On the Inspection Checklist Details page, click the Add button in the Checklist Items section to add the first
checklist item. Click the Add icon for additional checklists.

4. Enter values for fields on the Checklist ltem Details page. Required fields include the checklist item ID and

description.

Page Element Description

Checklist Item and Description

Enter an ID and description for the checklist item.

Score

Enter the score the item receives if it passes the inspection.

Major Violation

Turn on the switch to indicate that this checklist item is considered a major violation if it does
not pass inspection.
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Page Element Description
Category and Subcategory Enter a category and subcategory for the checklist item. See Setting Up Inspection
Checklist Categories.
Instructions Click the Add button in the Instructions section to add instructions for inspecting the

checklist item.

Add instructions on the Instruction Details page, including an instructions ID and the
instructional text.

5. The Required switch is turned on by default to indicate that the inspection of the item is required. The inspector
can’t submit the inspection result until all required checklist item and checklist results are complete.

If the checklist item is not required, you can turn off the switch.
6. Click Save.

Modifying or Deleting Checklists

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the row for the checklist you want to modify.

On the Inspection Checklist Details page, you can change the values for all fields except for the checklist ID.
If you made any changes, click Save.

If you want to delete the checkilist, click Delete.

apron 2

" Note: When you delete a checklist, all associated checklist items are also deleted.

6. If you want to delete multiple checklists, you can delete them from the Inspection Checklist page:

a. Click the Edit icon.
b. Select the check boxes for the checklist rows to delete.
c. Click the Delete icon.

Modifying or Deleting Checklist [tems

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the checklist row associated with the checklist item.

On the Inspection Checklist Details page, select the row for the checklist item in the Checklist ltems section.
On the Checklist Item Details page, you can change the values for all fields except for the checklist item ID.

If you made any changes, click Save.

If you want to delete the checklist item, click Delete.

If you want to delete multiple checklist items, you can delete them from the Inspection Checklist Details page using
the Edit and Delete icons.

8. Click Save.

NoogkroN

Modifying or Deleting Checklist Item Instructions

1. Select Inspection Setup > Inspection Checklist .
2. On the Inspection Checklist page, select the checklist row.
3. On the Inspection Checklist Details page, select the row for the checklist item that contains the instructions.
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On the Checklist Item Details page, select the row for the instructions that you want to modify or delete.

Change the instructional text on the Instruction Details page. You can’t change the instructions ID.

If you made any changes, click Save.

If you want to delete the instructions, click Delete.

If you want to delete multiple instructions, you can delete them from the Checklist Item Details page using the Edit
and Delete icons.

Click Save.

Setting Up Inspection Checklist Groups

A checklist group comprises inspection checklists that you can associate with a permit. You define a checklist group by
selecting one or more inspection checklists.

You set up inspection checklist groups on the Checklist Group page.

Before setting up inspection checklist groups, you must set up your checklists on the Inspection Checklist page. See Setting
Up Inspection Checklists.

Adding Inspection Checklist Groups

7.

BN S

Select Inspection Setup > Checklist Group .

On the Checklist Group page, click Add to add a checklist group.

On the Checklist Group Details page, enter a name and a description for the group of inspection checklists.
Click Save.

To add an inspection checklist to the group, click Add in the Checklists section.

On the Checklist Details page, enter the ID for an existing checklist in the Checklist field.

The description for the checklist ID you entered appears in the Description field.
Click Save.

Modifying Inspection Checklist Groups

You can modify or delete checklist groups and lines on the Inspection Checklist Group page.

1.
3.

4,

Select Inspection Setup > Checklist Group .
On the Checklist Group page, select the row for the checklist group that you want to modify.

On the Checklist Group Details page, you can only modify the checklist group description. You cannot change the
group name.

Click Save to save any changes.

Deleting Inspection Checklist Groups

PN~

Select Inspection Setup > Checklist Group .

On the Checklist Group page, select the row for the checklist group that you want to delete.

On the Checklist Group Details page, click Delete.

If you want to delete multiple checklist groups, you can delete them from the Checklist Group page:

a. Click the Edit icon.
b. Select the check boxes for the checklist group rows to delete.
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Removing Inspection Checklist from an Inspection Checklist Group

#" Note: You cannot modify inspection checklists on the Inspection Checklist Group pages; you can only remove

them from the group.

1. Select Inspection Setup > Checklist Group .
On the Inspection Checklist Group page, select the row for the checklist group from which you want to remove one

or more inspection checklists.

3. On the Inspection Checklist Group Details page, select the row for the inspection checklist that you want to remove
from the group.

&

On the Inspection Checklist Details page, click Delete.

5. If you want to remove multiple inspection checklists from the group, you can delete them from the Inspection

Checklist Group Details page:

a. Click Edit in the Inspection Checklists section.

b. Select the check boxes for the inspection checklist rows to delete.
c. Click Bulk Delete.
d. Click Save.

Setting Up Inspection Types

Define inspection types used by your agency to identify the requirements and options for different types of inspections. You
set up information such as scheduling, assessments, checklists, billing, signatures required, and comments on the Inspection

Type pages.

The inspection type is associated with the permit for the scheduled inspection and defines the different attributes for
performing the inspection.

This example illustrates the Inspection Type Details page containing the field values described in the following table.

Inspection Type Details

* Inspection Type

* Description

Scheduling Method
Rating Method
Checklist Group
Billable

Policy Name

Inspector Signature
Contractor Signature
Inspection District Type

Hide Inspector Comments

BV InsBuilding

Building Inspection

Schedule

E2E_INSP_CHKLST

Optional

Optional

BV_DISTRICTTYPE

e

* Estimated Duration in Hours 4
* Autonumber Rule  BVTEST
Scoring Method  Not used
Passing Rule
Checklist
Bill Type
Assessment Type  E2E_PassFail
Policy Version
Owner Signature  Optional
Schedule Cutoff Time 6:00 PM

Schedule Change Policy 1

Cancel

Delete

ORACLE
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" Note: When you modify an inspection type, the updated values are applied to new inspections using the
inspection type. Existing inspections use the original inspection type definition. This does not apply to the
Schedule Cutoff Time and Schedule Change Policy fields, which are referenced when the inspection is
scheduled and not stored on the inspection itself.

Adding Inspection Types

You add inspection types for your agency on the Inspection Type page. You must set up the attributes for the inspection type
before you begin.

1. Select Inspection Setup > Inspection Type .
2. On the Inspection Type page, click Add New to add a new inspection type.

3. Enter values for fields on the Inspection Type Details page. Required fields include Inspection Type and
Description, Estimated Duration in Hours, and Autonumber Rule.

Page Element Description

Inspection Type and Description Enter a unique ID and description for the inspection type.

Estimated Duration in Hours Enter the estimated number of hours this type of inspection will take.

This field is required for scheduling. For more information, see Setting Up Inspection
Scheduling.

Scheduling Method Select the scheduling method for inspections associated with this inspection type.
Select Schedule to enable users to select a date and time when requesting inspections.

Select Request to require requested inspections to be scheduled and assigned by
inspection supervisors.

For more information, see Setting Up Inspection Scheduling.

Assessment Type Enter an assessment type, which is used in the inspection result processing.

For more information, see Setting Up Inspection Assessment Types.

Passing Rule Enter a passing rule, which defines the criteria for determining whether an inspection passes
or fails.

For more information, see Setting Up Passing Rules.

Rating Method Enter a rating method, which defines the scoring ranges used by the passing rule to
determine whether an inspection passes or fails.

You must set up a rating method if you are using scoring. For more information, see Setting
Up Rating Methods.

Scoring Method Select a scoring method from these options:

o Bottom up: Scoring bottom to top indicates that the inspector starts with zero and
adds points for each criterion that is met. You must set up a passing rule for bottom
up scoring.
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Description

o Not used: This is the default value and indicates that no scoring method is used for
this inspection. You must specify the result manually for each level: checklist item,
checklist, and inspection.

If you don’t use the scoring method you can’t use the passing rule and rating method.
This also means that results are not automatically calculated starting with the checklist
items to the checklist to the inspection level.

# Note:
The scoring method specified for the checklist should match the scoring method in
the Inspection Type definition.

Autonumber Rule

Enter the ID for the automatic numbering rule to use for generating the inspection
transaction key.

For more information, see Setting Up Autonumbering.

Checklist Group

You can enter a checklist group. If you enter a checklist group, you cannot also enter a
checklist ID.

For more information, see Setting Up Inspection Checklist Groups.

Checklist You can enter the ID for a single checklist. You cannot enter both a checklist group and a
checklist ID.
For more information, see Setting Up Inspection Checklists.

Billable Click this slider if this inspection type is billable. When you turn on this switch, the Bill Type
field becomes required.

Bill Type Enter a bill type. This field is required if the Billable switch is turned on.

For more information, see Setting Up Bill Types.

Policy Name and Policy Version

Enter the name of the template and version number the OPA (Oracle Policy Automation)
policy.

For more information, see Overview of Oracle Policy Automation Configuration.

Inspector Signature
Owner Signature

Contractor Signature

ORrRACLE

Select a signature option for the inspector, owner, and contractor associated with the
inspection type:

o Required: The signature field appears on the Inspection Results page.

& Note:
Inspectors can’t submit a completed inspection if required signatures are missing.

o Not Required: The signature field does not appear on the Inspection Results page.

o Optional: A signature is optional for this inspection type.

The default value for the Inspector Signature is Required.

The default value for the Owner Signature and Contractor Signature is Optional.
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Page Element Description
Schedule Cutoff Time Enter the time after which applicants and non-supervisor agency staff can no longer

schedule inspections for the current day or the next day using the Scheduling modal page.
For example, if the cut off is 3:00 PM and the current time is 4:30 PM, the inspection can’t
be scheduled for today or tomorrow. The inspection must be scheduled for the day after
tomorrow.

# Note:
This field does not affect an inspection supervisor’s ability to override inspection
assignment times through the Scheduling modal page. It also does not affect
automatic batch assignment.

Inspection District Type Enter the inspection district type for this inspection, for example a building, electrical, or
plumbing inspection district. When the inspection with this inspection type is scheduled, the
system finds the inspector who is assigned to a district belonging to the inspection district
type defined on the inspection type.

This field is required for scheduling. For more information, see Setting Up Inspection
Scheduling.

Schedule Change Policy Enter the acceptable number of hours prior to the inspection that the user can change the
schedule or cancel an inspection.

For more information, see Setting Up Inspection Scheduling.

Hide Inspector Comments Turn on this switch if you want to hide inspector comments from public users. The default
value for this switch is off so that inspector comments are visible.

4. Verify that the Enabled switch is turned on if you want to enable this inspection type when you save it. The switch is
turned on by default for a new inspection type.

5. Click Save.

Modifying or Deleting Inspection Types

You can modify or delete inspection types on the Inspection Type page.

Select Inspection Setup > Inspection Type .

On the Inspection Type page, select the row for the inspection type you want to modify.

On the Inspection Type Details page, you can change the values for all fields except for the inspection type code.
If you made any changes, click Save.

To delete the inspection type, click Delete.

If you want to delete multiple inspection types, you can delete them from the Inspection Type page:

o0 krON

a. Click the Edit icon.
b. Select the check boxes for the inspection type rows to delete.
c. Click the Delete icon.
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Setting Up Inspection Groups

An inspection group identifies a group of inspection types associated with a permit. You can set up inspection groups on the
Inspection Group page.

The inspection group includes one or more inspection types. You can define inspection groups separately from permit type
definitions.

Before setting up inspection groups, you must set up inspection types for your agency on the Inspection Type page. See
Setting Up Inspection Types.

Adding Inspection Groups

Select Inspection Setup > Inspection Group .
On the Inspection Group page, click Add to add a new inspection group.
On the Inspection Group Details page, enter a name and a description for the inspection group.
Click the Enabled switch to enable the new inspection group.
To add inspection types to include in the group, click Add in the Inspection Types section.
Enter values in the columns of the inspection type row:

a. Inspection Type: Enter an existing inspection type.

The description for the inspection type you entered will appear in the Description field.
b. Required: Click the switch if the inspection type is required for the inspection group.

oaprN

#" Note: Even if an inspection type is not required, it may become required based on business rules
during processing.

c. Final Inspection: Click the switch if this inspection type is the final inspection. One and only one row must be
set as the final inspection.

d. Click the Add icon to add another type; otherwise, click Save.
7. On the Inspection Group Details page, click Save.

Modifying or Deleting Inspection Groups

You can modify or delete inspection groups on the Inspection Group page.

Select Inspection Setup > Inspection Group .
On the Inspection Group page, select the inspection group that you want to modify.

On the Inspection Group Details page, you can only modify the inspection group description. You cannot change the
group name.

Click the Enabled switch to enable or disable the inspection group.

If you want to delete the inspection group, click Delete on the Inspection Group Details page.

Click Save to save any changes.

If you want to delete multiple inspection groups, you can delete them from the Inspection Group page:
a. Click Edit.
b. Select the check boxes for the inspection group rows to delete.
c. Click Delete.

N~
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8.

10.
11.

In the inspection types grid, you can:

oo

e o

Click the Required switch to enable or disable an inspection type.

Click the Final Inspection switch to set an inspection type as the final inspection. One and only one row
must be set as the final inspection.

Click Add to add a new inspection type row.
Click the Delete icon at the end of the row to remove an inspection type from the group.

" Note: You cannot change the inspection type ID or description, but you can remove an inspection type

and add another.

Click Save to save any changes.
If you want to remove an inspection type from the group, click Delete.

If you want to remove multiple inspection types from the group, you can delete the rows from the Inspection Group
Details page:

eooTo

Click Edit.

Select the check boxes for the inspection type rows to delete.
Click Delete.

Click Save.

Setting Up Inspection Calendars

Inspection calendars establish the days of the week and daily hours that are available for scheduling specific types of
inspections.

Administrators add, modify, and delete inspection calendars on the Inspection Calendar page.

Adding an Inspection Calendar

1.

Select Inspection Setup > Inspection Calendar .
2. On the Inspection Calendar page, click Add.
3. On the Inspection Calendar Details page, enter values for the following fields:

Page Element Description

Calendar ID Enter a unique ID for the calendar.

Inspection Type Select the type of inspection to which this calendar applies.

For more information on inspections types, see Setting Up Inspection Types.

Inspection District Select the district to which this calendar applies.
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# Note:

A small municipality may have only one defined district ID that includes its entire
inspection area. A large municipality may have multiple defined district ID. This
enables you to create inspection calendars for different areas to optimize your
distribution of resources.

For more information on districts, see Setting Up Districts.

Description Enter a description for the calendar. For example, you might enter Final fence inspection
calendar.

Start Date Enter the first day of the calendar.

End Date Enter the last date of the calendar. You can leave this field blank to give the calendar an

open end date.

Start Time and End Time Enter the start and end time for the calendar. For example, you might enter a start time of
09:00 and an end time of 16:00.

Recurrence Select whether the calendar reoccurs weekly. If you select Weekly recurrence, enter the
number of weeks between occurrence in the Weeks Between Occurrences field.

Weeks Between Occurrences Enter how many weeks are between each occurrence. For example, if you select a
recurrence of Weekly with 1 week between occurrences, the calendar repeats every week.

# Note:
When the recurrence frequency for an inspection calendar is greater than 1, the
first week of scheduling is the week that contains the start date, where Sunday is
considered the first day of the week. Therefore, it is recommended that you set the
start date to the Sunday of the first week in which you want to schedule inspections.

For example, you create an inspection calendar for Mondays and Fridays where
the recurrence frequency is 2, alternating weeks. Setting the calendar start date

to January 1, 2019 causes January 4, 2018 to be available for scheduling but not
December 31, because it is before the start date. Also, January 7 and 11 are in
the alternate week, so the next days available for scheduling are January 14 and
18. If you set the start date to January 5, which is still part of the first week that the
calendar is active, the system considers this same week as the start week, but no
days are available until January 14 and 18.

Inspection Days Select the days of the week that are available for inspection scheduling.

4. Click Save.
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#" Note: For overnight inspection calendars that go past 12 a.m. (midnight), you must create two calendars:
one for the time period up until midnight, and one for the time period after midnight. For example, to create a
weekday overnight calendar that starts at 09:00 p.m. and ends at 05:00 a.m. the following day, the first calendar
would have a start time of 09:00 p.m. and an end time of 12:00 a.m. on Monday, Wednesday, and Friday. The
second calendar would have a start time of 12:00 a.m. and an end time of 05:00 a.m. on Tuesday, Thursday,
and Saturday.

Modifying an Inspection Calendar

1. Select Inspection Setup > Inspection Calendar .
2. Click a row on the Inspection Calendar page.
3. On the Inspection Calendar Details page you can:

o Update the inspection calendar field values.

# Note: You cannot edit the Calendar ID.

o Delete the calendar. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Inspection Calendars

Select Inspection Setup > Inspection Calendar .

Click Edit.

Select the check boxes next to all the inspection calendars you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PN~

Setting Up Inspection Scheduling

When agency users and registered public users schedule an inspection, the system is actually determining which inspectors
are available and qualified to perform the inspection. Therefore, to schedule inspections, it is necessary to define all of the
appropriate employee data for inspectors.

Inspectors are considered qualified if they have been assigned the inspection type and district associated with the inspection.
The availability of inspectors is based on their work schedules and whether they have been assigned to other inspections
previously.

In addition, the time slots that are available for scheduling are impacted by inspection calendars and holiday calendars, which
define when inspections can and can’t be performed, respectively.

The system determines which inspectors can be scheduled to perform an inspection based on two sets of criteria.

1. Qualifications: To be qualified to perform an inspection, agency staff must be defined as inspectors, and assigned to
inspection types, districts and work schedules.
2. Availability: Agency holidays and inspection calendars, inspector work schedules, and existing inspector assignments
determine the availability of inspectors.
The following table lists the different types of data that need to be defined so that the system can determine inspector
qualifications and availability. The Frequency column lists how many instances of the data type can be defined. The Required
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column lists whether a data type is required for time slots to appear on the Scheduling modal page during inspection

scheduling.

For more information on inspection requests see Requesting Inspections.

Criteria Type Data Type Frequency Required Impact of Missing Data
Quialification Inspection Type One per inspection Yes Only defined inspection
types are available to
select when requesting
inspections. The Select
a Time button is not
available if the inspection
type’s scheduling
method is not Schedule.
Quialification District One per inspection Yes No scheduling times
are available on the
Note that the address Scheduling modal page.
selected for the
inspection needs to be Note that the inspection
associated to a parcel type and a parcel
for which there is an associated with the
assigned inspection permit must have the
district. same district type. If they
don’t, the Select a Time
button is unavailable for
the inspection request.
Quialification Inspectors One per employee who Yes No scheduling times
performs inspections are available on the
Scheduling modal page.
Quialification Assigned Inspection Type One or more per Yes No scheduling times
inspector are available on the
Scheduling modal page.
Qualification Assigned Inspection One or more per Yes No scheduling times
District inspector are available on the
Scheduling modal page.
Note that the assigned
inspection district and the
parcel associated with
the permit must have the
same district type. If they
don’t, the Select a Time
button is unavailable for
the inspection request.
Availability Work Schedule One or more for each Yes No scheduling times
period of the day are available on the
inspectors work; may Scheduling modal page.
include one break
Availability Assigned Work Schedule One or more per Yes No scheduling times

inspector

are available on the
Scheduling modal page.

ORrRACLE
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Criteria Type Data Type Frequency Required Impact of Missing Data
Availability Inspection Calendar One or more for each No The inspection can be

combination of inspection scheduled at any time
type and district of day (or whenever

inspectors are available).

Availability Assigned Inspection Automatically created No No time slots are
when an inspection is unavailable for scheduling
assigned due to previously

assigned inspections.

Availability Holiday Calendar One per agency No No days are unavailable
for scheduling due to
holidays or other agency
non-working days.

Inspection Types

You define inspection types using the Inspection Type page. The system uses the estimated duration to determine whether
an inspector is available for the entire time required to complete an inspection. The inspection district type is a pre-defined
district type with the category of Inspection.

For more information on inspection types, see Setting Up Inspection Types.

Inspection Districts

You must create an inspection district and assign it to inspectors to enable qualified inspectors and make time slots available
when scheduling inspections. The district for the inspection is based on the district type assigned to the inspection type.

The system uses this district type to determine the district ID associated with the parcel for which an inspection is being
scheduled. A parcel may have more than one district type associated with it, but only one of them has a district type category
of Inspection.

The system determines the parcel for the inspection based on the inspection address. The address for a new inspection
defaults to the primary address of the primary parcel associated with the permit for which you are scheduling an inspection.
You may select other addresses that are associated with the permit. If no address is associated with an inspection, the
system can’t determine the district for the inspection so the Select a Time and Select a Different Time buttons are disabled.

For more information on district types, districts, parcels, and addresses see:
e Setting Up District Types
e Setting Up Districts
e Associating Parcels with Districts

e Setting Up Parcel Addresses

Work Schedules

You must create work schedules and assign them to inspectors to make the inspectors available for inspection scheduling.

#" Note: If the recurrence for a work schedule is Weekly, and the weeks between occurrences is greater than 1,
the system uses the week of the valid from date as the starting point for scheduling.
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For more information on work schedules, see Setting Up Work Schedules.

Inspectors

To make inspectors available for inspection scheduling, you must perform the following steps on the Agency Staff page:

e Assign the ORA_BUILDING_INSPECTOR job function to the inspector.

e Assign inspection types to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job function.

e Assign inspection districts to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job function.
e Assign work schedules to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job function.

For more information on assigning job functions and job attributes to agency staff, see Setting Up Agency Staff.

Inspection Calendars

Setting up inspection calendars is optional for scheduling inspections. Without inspection calendars, however, the system can
potentially allow inspections to be scheduled for any time during a 24 hour period, if there are work schedules that comprise
all 24 hours.

You define inspection calendars for a specific combination of inspection type and district. You can define more than one
calendar for the same inspection type and district.

For more information on inspection calendars, see Setting Up Inspection Calendars.

Holiday Calendar

Setting up holiday calendars is optional for scheduling inspections. Holiday calendars establish the days that agency offices
are closed and no field service operations are offered. The dates established as events on the holiday calendar are not
available for inspection scheduling regardless of how the inspection calendars or work schedules are defined.

For more information on holiday calendars, see Setting Up Holiday Calendars.
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O Managing Audit Policies

Implementation Concepts for Audit Policies

This topic discusses audit configuration for business object attributes.

Audit enables tracking the change history of particular attributes of a business object. However, those objects and their
attributes must be selected for audit and auditing must be enabled for that application. Your configuration settings determine
which attributes to audit for a given object, and when the audit starts and ends. Auditing takes into account all the operations
performed on an object and its attributes, such as create, update, and delete. To configure audit business object attributes,
use the Manage Audit Policies task in the Setup and Maintenance work area.

Selecting an Application

To set up auditing, you must select a web application that contains the required business objects that can be audited. From
the list of business objects, select those business objects that you want to audit. Selecting a business object also displays its
attributes that are enabled for auditing.

Selecting Attributes

For each selected business object to be audited, select the corresponding attributes to include in the audit. All attributes
that belong to that object are by default selected for audit and appear on the user interface. However, you can add or
remove attributes from the list. When you remove an attribute from the list, you stop auditing it even when the parent object
is selected for audit. So, if you want an attribute to be audited, you must add it to the list. If the object selected in an audit
hierarchy is also a part of several other audit hierarchies, the attribute configuration for that object is applicable to all the
hierarchies in that application.

(' Tip: For business objects based on flexfields, select the Flexfields (Additional Attributes) check box to view and
add or remove flexfield attributes, to include or exclude them from the audit.

Starting and Stopping Audit

The business object is ready for audit after you select its attributes and save the configuration changes. However, to start
auditing, the audit level for Oracle Applications Cloud must be set to Auditing on the Manage Audit Policies page.

To stop auditing an object, you can deselect the entire object and save the configuration. As a result, all its selected attributes
are automatically deselected and are not audited. To continue to audit the business object with select attributes, deselect
those attributes that are not to be audited. When users view the audit history for an application, they can specify the period
for which they want the results. Therefore, make a note of when you start and stop auditing an application.

For example, users intend to view the audit history of an object for the previous week, but auditing for that object was
stopped last month. They wouldn't get any audit results for that week, because during the entire month that object wasn't
audited. Even if you enable audit for that object today, users can't get the wanted results because audit data until today isn't
available.
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Audit Configuration for Oracle Fusion Middleware Products

To set up auditing for Oracle Applications Cloud, select the Manage Audit Policies task from the Setup and Maintenance
work area within your offering. To set up auditing for Oracle Fusion Middleware products, select the level of auditing mapped
to a predefined set of metadata and the events that have to be audited. Information about configuring audit for Oracle Fusion
Middleware products is provided in Oracle Fusion Middleware guides.

You can also create a configuration file and deploy it to audit a specific Oracle Fusion Middleware product. The configuration
details for Oracle Fusion Middleware products are available as audit-specific assets that you can use to create the config.xml
configuration file. To get a list of audit-specific assets, see Audit Events for Oracle Applications Cloud Middleware (Doc ID
2114143.1) on My Oracle Support at https://support.oracle.com.

e Oracle Fusion Middleware Products
Configure business objects to enable auditing in Oracle Fusion Middleware products. Refer to the Oracle Fusion
Middleware Security and Administrator's Guide for Web Services.

e QOracle Fusion Security Products

Configure business objects to enable auditing in Oracle Fusion security products. Refer to Oracle Fusion Middleware
Application Security Guide.

Using Auditing to Monitor Changes

You can enable business objects to allow auditing, recording, and retrieving information about when the objects were
created, modified, and removed.

Audit Policies Overview

Auditing is used to monitor user activity and all configuration, security, and data changes that have been made to an
application. Auditing involves recording and retrieving information pertaining to the creation, modification, and removal
of business objects. All actions performed on the business objects and the modified values are also recorded. The audit
information is stored without any intervention of the user or any explicit user action.

Use audit policies to select specific business objects and attributes to be audited. The decision to create policies usually
depends on the type of information to be audited and to the level of detail required for reporting.

Enabling Audit Functionality

For Oracle Applications Cloud, you must configure the business objects and select the attributes before enabling audit. If
you enable audit without configuring the business objects, auditing remains inactive. By default, auditing is disabled for all
applications. To enable and manage audit, ensure that you have a role with the assigned privilege Manage Audit Policies
(FND_MANAGE_AUDIT_POLICIES_PRIV). For appropriate assignment of roles and privileges, check with your security
administrator.

If you don't want an object to be audited, you can stop the audit process by setting the Audit Level option to None.

Business Objects for Auditing

The following table shows the business objects you can enable for auditing.
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Area
Permits

Planning and Zoning

Parent Objects

Fee Schedule

Child Objects
Default Fee Item
Effective End Date
Effective Start Date
Fee Schedule

Refund Fee Item

Permits

Planning and Zoning

Fee Line

Model Name
Service Name
Space ID

Space Name
Version

Effective End Date
Effective Start Date
Fee Schedule

Fee Items

Pay Now
UseAmend
UseOrig

UseRenew

Auditing Community Development Data

You use auditing to monitor data changes that have been made to fee schedules.

To enable auditing for Community Development Data:

1.
2.

A

Sign in as a setup user.
Select Setup and Maintenance and go to the following:

o Offering: Public Sector Permits

o Functional Area: Application Extensions

o Task: Manage Audit Policies

In the Manage Audit Policies page, click Oracle Fusion Applications, to configure the required audits.
Click Configure Business Object Attributes.
On the Configure Business Object Attributes page, select Permits from the drop-down list of products.

Select from the list of objects in the Audit Name column.
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Objects Category Parent Object Child Object
Fee Schedule Fee Schedule Fee ltems

7. In the Audited Attributes area, click the Add icon.

The Select and Add Audit Attributes dialog box opens.
Select the desired attributes.
9. Click OK.

®

The selected attributes are displayed in the Audited Attributes area.
10. Click Save.

Related Topics
* |mplementation Concepts for Audit Policies

Viewing Audit History

You use audit history to view changes to the application data such as the business objects that were created, updated, and
deleted.

Before you begin, you must have a role with the assigned privilege View Audit History (FND_VIEW_AUDIT_HISTORY_PRIV).
For appropriate assignment of roles and privileges, check with your security administrator.

To view the Fee Schedule audit history or to create a report:

1. To open the Audit History work area, select Setup and Maintenance > Navigator > Audit Reports
2. Enter the following search values:

Audit Reports Search Field Value

Date Enter the date for the audit results you want to see.
Product Select Permits.

Business Object Type Select Fee Schedule.

3. Select the option Include child objects. Fee Items is the child object for the Fee Schedule business object type.

The default search displays a summary of the audit history in the search results table. It includes key data such as date, user,
product, event type, business object type, and description. For a detailed report, search again with modified search criteria.
You can export the report summary to Microsoft Excel.

Search Parameter Result of Selection

Business Object Type e Narrows the search results to that specific business object within the selected product.

e Enables the Show Attribute Details check box.
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Search Parameter Result of Selection
# Note:

This parameter is applicable only
for the business objects that
belong to Oracle Applications

Cloud.
Include Child Objects Displays all the child objects that were listed for that business object when audit was set up. For
example, a sales order object that contains several items as child objects.
# Note:
Displays the objects at the immediate parent-child level only. To view the children at
subsequent levels, select the child object as the business object type and search again.
Show Impersonator Displays the details of the impersonator who modified the objects during an impersonation session.
Show Attribute Details Enables the attribute list so that users can select either all attributes or a specific attribute to view
the changes. Based on the selection, the search results indicate whether the attribute is created,
updated, or deleted, and the corresponding old and replaced values.
Show Additional Object Identifier Displays the instances (contexts) in which the business object was used. The context values identify
Columns the objects and the transactions in which they were used. Each context is unique and assigns a

unique description to the business object.

#" Note: The default report displays a standard set of columns that contain prominent details of the audit history.
To view additional details, you can change the display of columns.
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