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Preface

This preface introduces information sources that can help you use the application and this guide.

Using Oracle Applications

This topic explains the text conventions used in this guide and points you to where you can find more information about
using Oracle applications.

Conventions

The following table explains the text conventions used in this guide.

Convention Meaning

boldface Boldface type indicates user interface elements, navigation paths, or values you enter or select.
monospace Monospace type indicates file, folder, and directory names, code examples, commands, and URLs.
> Greater than symbol separates elements in a navigation path.

Additional Resources

- Community: Use Oracle Cloud Customer Connect to get information from experts at Oracle, the partner
community, and other users.

- Guides and Videos: Go to the Oracle Help Center to find guides and videos.

- Training: Take courses on Oracle Cloud from Oracle University.

Documentation Accessibility

This topic covers accessibility concepts for this guide.
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website.

Videos included in this guide are provided as a media alternative for text-based help topics also available in this guide.
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Contacting Oracle

This topic explains how to contact Oracle for support and to provide feedback.

Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For
information, visit My Oracle Support or visit Accessible Oracle Support if you are hearing impaired.

Comments and Suggestions

Please give us feedback about Oracle Public Sector Compliance and Regulation applications help and guides! You can
send an e-mail to: PSCR_US@oracle.com.
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1 Setting Up Transactions

Setting Up Transaction Groups

Transaction groups are the first level of categorization that you can select when you define your permit and planning
application types.

If desired, you can set up transaction groups. This setup is not required.

Adding Transaction Groups

You add transaction groups for permits and planning applications on the Transaction Group page.

1. Select Common Setup > Transaction Group .
2. Onthe Transaction Group page, click Add to add a new group.
3. On the Transaction Group Details page, enter a values for the group.

Page Element Description
Group Enter a group name for the permit or planning application types.
Description Enter a description of the group.
Applicable Classification Select a product area from these options:
o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new transaction group.
5. Click Save.

Modifying Transaction Groups

You can modify transaction groups for permits and planning applications on the Transaction Group page.

1. Select Common Setup > Transaction Group .

2. On the Transaction Group page, select the row for the group that you want to modify.

3. Onthe Transaction Group Details page you can:
o Edit the description. You cannot change the group name.
o Select the Applicable Classification check box for permits or planning and zoning.
o Click the Enabled switch to enable or disable the transaction group.

4. C(lick Save to save any changes.
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Deleting Transaction Groups

You can delete transaction groups for permits and planning applications on the Transaction Group page.

Select Common Setup > Transaction Group .

On the Transaction Group page, select the row for the group that you want to delete.

If you want to delete the group, click the Delete button.

If you want to delete multiple groups, you can delete them from the grid on the Transaction Group page:
a. Click the Edit icon.
b. Select the check boxes for the transaction group rows to delete.
c. Click the Delete icon.

PUOUNa

Setting Up Transaction Categories

Transaction categories are the second level of categorization that you can select when you define your permit and
planning application types.

If desired, you can set up permit and planning application transaction categories. This setup is not required.

Adding Transaction Categories

You can add transaction categories for permits and planning and applications on the Transaction Category page.

1. Select Common Setup > Transaction Category .
2. Onthe Transaction Category page, click Add to add a new transaction category.
3. On the Transaction Category Details page, enter a values for the transaction category.

Page Element Description
Category Enter a category name for the permit or planning application type.
Description Enter a description of the category.
Applicable Classification Select an offering from these options:
o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new category.
5. Click Save.

Modifying Transaction Categories

You can modify transaction categories for permits and planning applications on the Transaction Category page.

1. Select Common Setup > Transaction Category .
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2. Onthe Transaction Category page, select the row for the category that you want to modify.
3. On the Transaction Category Details page you can:
o Edit the description. You cannot change the category name.

o Select the Applicable Classification check box for permits or planning and zoning.
o Click the Enabled switch to enable or disable the transaction category.
4. C(lick Save to save any changes.

Deleting Transaction Categories

You can modify transaction categories for permits and planning applications on the Transaction Category page.

Select Common Setup > Transaction Category .

On the Transaction Category page, select the row for the category that you want to delete.

If you want to delete the category, click the Delete button.

If you want to delete multiple categories, you can delete them from the grid on the Transaction Category page:
a. Click the Edit icon.
b. Select the check boxes for the transaction category rows to delete.
c. Click the Delete icon.

PUWNA

Setting Up Transaction Subcategories

Transaction subcategories are the third level of categorization that you can select when you define your permit and
planning application types.

If desired, you can set up permit and planning application type subcategories. This setup is not required.

Adding Transaction Subcategories

You can add transaction subcategories for permit and planning application types on the Transaction Subcategory page.

1. Select Common Setup > Transaction Subcategory .
2. Onthe Transaction Subcategory page, click Add to add a new transaction subcategory.
3. Onthe Transaction Subcategory Details page, enter values for the transaction subcategory.

Page Element Description
Subcategory Enter a subcategory name for the permit or planning application type.
Description Enter a description of the subcategory.
Applicable Classification Select a product area from these options:
o Permits

o Planning and Zoning
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4. Verify that the Enabled switch is turned on. The option is active by default for a new subcategory.
5. Click Save.

Modifying Transaction Subcategories
You can modify transaction subcategories for permit and planning application types on the Transaction Subcategory
page.

1. Select Common Setup > Transaction Subcategory .
2. Onthe Transaction Subcategory page, select the row for the subcategory that you want to modify.
3. On the Transaction Subcategory Details page you can:

o Edit the description. You cannot change the subcategory name.
o Select the Applicable Classification check box for permits or planning and zoning.
o Click the Enabled switch to enable or disable the transaction subcategory.

4. Click Save to save any changes.

Deleting Transaction Subcategories
You can modify transaction subcategories for permit and planning application types on the Transaction Subcategory
page.

Select Common Setup > Transaction Subcategory .
On the Transaction Subcategory page, select the row for the subcategory that you want to delete.
If you want to delete the subcategory, click the Delete button.
If you want to delete multiple subcategories, you can delete them from the grid on the Transaction Subcategory
page:
a. Click the Edit icon.
b. Select the check boxes for the transaction subcategory rows to delete.
c. Click the Delete icon.

PWN

Setting Up Transaction Statuses

Oracle provides a set of statuses for transactions to control system events. Some system statuses can be mapped to a
user-defined transaction status.

Your agency assigns statuses for permit and planning applications. You cannot delete the system-delivered transaction
statuses, but you can modify the description. You can also define additional transaction statuses, but you must
associate any new transaction status with one of the system-delivered statuses to ensure correct processing.

For information about permit inspection statuses, see Setting Up Inspection Statuses.

For information about permit plan review statuses and decision statuses, see Setting Up Plan Review Statuses.

Using Delivered Transaction Statuses

This table lists the system-delivered transaction statuses and indicates whether they can be associated with a user-
defined status.
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Transaction Status

About to Expire

Accepted

Certificate of Occupancy

Completed

Delinquent

Denied

Expired

Hearing

In Process

Inspection

Payment Pending

Pending

Pending Submittal

Permit Issued

Plan Review

Submitted

Voided

Withdrawn

System Status Code

ATE

ACP

CoOo

CMP

DLQ

DNI

EXP

HER

IPC

INS

PAY

PND

PDS

PTI

PLR

SUB

VoD

WTH

Type of Transaction

Both

Both

Permit Application

Both

Both

Both

Both

Planning Application

Both

Permit Application

Both

Both

Both

Permit Application

Permit Application

Both

Both

Both

Chapter 1
Setting Up Transactions

Can be mapped to a user-defined
record status?

No

Yes

Yes

Yes

No

Yes

No

Yes

Yes

Yes

No

No

No

Yes

Yes

No

Yes

No

When a guest submits a permit application or a planning application, the transaction status is updated as follows:
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Record and System Status Description
Pending (PND) Applied when the guest saves an application.
Pending Submittal (PDS) Applied when the guest submits the application and workflow can’t be started.
Payment Pending (PAY) Applied when fees are due.
Submitted (SUB) - Applied when no fees are due.

- Applied after successful payment.

Adding Transaction Statuses

Define any additional statuses that your agency will use for permit and planning applications on the Transaction Status
page. You must associate a new transaction status with a system status.

1. Select Common Setup > Transaction Status .
You can select from these transaction statuses:

o Permit Status
o Planning Status

For information about inspection statuses, see Setting Up Inspection Statuses.

For information about plan review statuses and decision statuses, see Setting Up Plan Review Statuses.
3. Click Add to define a new transaction status.
4. On the respective transaction details page, enter values for these fields:

Page Element Description

Status Enter a transaction status name.

Description Enter a description for the transaction status.

System Status for Permit Select the permit transaction status that you want to use from the drop-down list:
Applications

o Application Accepted

o Completed

o Certificate of Occupancy
o Denied

o Voided

o InProcess

o Permit Issued

o Plan Review
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Page Element Description
System Status for Planning Select the planning transaction status that you want to use from the drop-down list:
Applications

o Application Accepted
o Completed

o Hearing

o Denied

o Voided

o InProcess

o Permit Issued

5. Verify that the Enabled switch is turned on. The switch is turned on by default for a new record status.
6. Click Save.

Modifying Transaction Statuses

You can modify the transaction statuses that you have defined for your agency’s permits and planning applications on
the Permit Status Details or Planning Status Details page, respectively.

1. Select Common Setup > Transaction Status .
2. You can select from these transaction statuses:

o Permit Status
o Planning Status

For information about permit inspection statuses, see Setting Up Inspection Statuses.

For information about permit plan review statuses and decision statuses, see Setting Up Plan Review Statuses.
3. Select the row for the transaction status that you want to modify.
4. On the Details page you can:
o For user-defined statuses, edit the description or the system status that you want to set on a record with
this record status. You cannot edit the Status field.
o For system-delivered statuses, you can only edit the description. You cannot edit the Status field.

o Turn on the Enabled switch to enable a user-defined record status. You cannot disable system-delivered
statuses.
5. Click Save to save any changes.

Deleting Transaction Statuses

You can delete the statuses that you have defined for your agency on the Permit Status Details or Planning Status
Details page.

f Note: You cannot delete most of the system-delivered statuses; you can only modify their descriptions.
Oracle recommends that you disable statuses instead of deleting them.

1. Select Common Setup > Transaction Status .
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2. You can select from these transaction statuses:

o Permit Status

o Planning Status

For information about permit inspection statuses, see Setting Up Inspection Statuses.

For information about permit plan review statuses and decision statuses, see Setting Up Plan Review Statuses.
3. Select the row for the transaction status that you want to delete.
On the Details page, click Delete, if the button is available.
5. If you want to delete multiple record statuses, you can delete them from the grid on the Transaction Status
page:

P

a. Click the Edit icon.
b. Select the check boxes for the status rows to delete.
c. Click the Delete icon.
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2 Setting Up Permits

Setting Up Agency-Level Options

You set up the Oracle Intelligent Advisor for Permits and Planning and Zoning on the Permit Options page during
agency setup. You can also configure the summary title and text for the Anonymous User Landing Page and the
Registered User Landing page.

To configure agency-level options for permits and planning applications:

1.
2
3.

Select Common Setup > Agency .
Click a row on the Agency Information tab.
Select the Features tab.

Oracle delivers the list of offerings on the Features tab. The Permits offering encompasses both Permits and
Planning and Zoning.

Disregard the Enabled column for the Permit offering. The offering is enabled in the Functional Setup Manager
(FSM).

Click Options for the Permits offering.

On the Permit Options page, you can update values for the following fields:

Page Elements Definition
Oracle Policy Automation ID Enter the unique identifier for the Oracle Policy Automation policy model to be used for
this offering.

The offering-specific policy model that you specify here takes priority over any agency-
wide policy definition that you enter on the main Agency Information page.

Message Title Enter a short text version of the landing page message in a title format. If you leave this
field blank, the value in the Label field on the Link Details page for the menu navigation
link Online Permits is displayed.

Message Summary Enter a longer version of the landing page message title in a sentence format. If you
leave this field blank, the value in the Description field on the Link Details page for the
menu navigation link Online Permits is displayed.

Button Content URL Enter a content URL for the Read More button. Public users click this button to access
the agency’s own permit information page, outside of Oracle Public Sector Permits. If
you leave this field blank, the Read More button opens a dialog box that displays the
Landing Page Message.
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Page Elements Definition

Note:
f If you want to link to a page outside of Oracle Public Sector Permits, you must
enter a URL here.

Landing Page Message Enter a welcome message in rich text to appear in a dialog box on the landing page, if a
URL to access the agency'’s page is not defined.

For more information on Oracle Intelligent Advisor, see Overview of Oracle Intelligent Advisor Configuration.

For more information on the Landing Page Message Definition, see Defining Summary Details.

Related Topics
- Managing Oracle Intelligent Advisor Policies for your Agency

- Setting Up the Landing Page for Anonymous Users
- Setting Up the Landing Page for Registered Users

Setting Up Plan Reviewer Departments

A plan review department represents an area of expertise for reviewers of plan documents.

For example, a plan review department of Building is associated with experts in building-related codes and regulations
whereas a plan reviewer department of Fire is associated with experts in fire-related codes and regulations.

You select a plan review department for a plan reviewer when you add a department job attribute for your plan reviewer
job function during agency staff setup. For more information on adding job functions and job attributes, see Managing
Agency Staff Profiles.

System administrators add, modify, and delete plan reviewer departments on the Plan Reviewer Department page.

Adding Plan Reviewer Departments

Select Common Setup > Plan Reviewer Department .

On the Plan Reviewer Department page, click Add.

On the Plan Reviewer Department Details page, enter an ID, name, and description for the department.
Turn on the Enabled switch to make the plan reviewer department available as a value on other pages.
Click Save.

ihWNA

Modifying Plan Reviewer Departments

1. Select Common Setup > Plan Reviewer Department .
2. Onthe Plan Reviewer Department page, select the plan reviewer department that you want to modify.
3. On the Plan Reviewer Department Details page you can:

10
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o Edit the description. You cannot change the values of the Department ID and Department fields.
o Enable or disable the plan reviewer department using the Enabled switch.

f Note: When you disable a plan reviewer department that is already associated with a plan
review the department remains associated with that plan review.

o Delete the plan reviewer department. You will be prompted to confirm the permanent deletion.
4. C(lick Save.

Deleting Plan Reviewer Departments

1. Select Common Setup > Plan Reviewer Department .

2. C(lick Edit.

3. Select the check boxes next to all the plan reviewer departments you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Note: You can't delete a plan reviewer department that is already in use as part of a plan reviewer’s job
attribute. In this case, to prevent the plan reviewer department from being used in the future, turn off the
Enabled switch to disable it.

X

Setting Up Plan Review Statuses

Use delivered plan review statuses to identify the progression through a plan review cycle. You can review the statuses
on the status definition pages.

You review the plan review statuses on the Plan Review Status and Decision Status pages. You cannot delete the
system-defined statuses or add new statuses, but you can modify the descriptions. The descriptions allow you to enter
a different status name to be displayed to agency staff.

The system derives the overall plan review status from the individual plan reviewer decisions, and updates the overall
plan review with the most severe decision status. The system-defined decision statuses are listed here from most to
least severe: Rejected, Revision Required, Approved with Comments, Approved, and Not Required. If plans have one or
more rejections, or revisions are required, the applicant must correct the plans and resubmit them for another review
cycle.

Modifying Plan Review Cycle Statuses

You can edit only the Description field on the Plan Review Status Details page. The agency-defined description is
exposed to agency staff and public users on the plan review pages in the permit record detail.

1. Select Common Setup > Transaction Status .
2. Select the Plan Review Status tab.
3. You can review the delivered review cycle statuses in the Review Status column:

o InProgress
o Canceled
o Completed

n
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4. Select the row for the review status that you want to modify.
5. On the Plan Review Status Details page you can edit only the description.
6. Click Save to save any changes.

Modifying Plan Review Decision Statuses

You can edit only the Description field on the Decision Status Details page. The agency-defined description is exposed
to agency staff and public users on the plan review pages in the permit record detail.

1. Select Common Setup > Transaction Status .
2. Select the Plan Review Decision tab.
3. You can review the delivered plan review decision statuses in the Decision Status column:

o Approved

o Approved with comments
o Revision required

o Rejected

o Not required

The plan review decision statuses are delivered as enabled. The only review decision status that you can disable
is Approved with comments.

Select the row for the decision status that you want to modify.

On the Decision Status Details page you can edit only the description.

Click Save to save any changes.

ounsp

Setting Up Permit Types
Define the types of permits supported by an agency. You add a permit type and associate workflow process definitions
on the Permit Type definition page.

Before you can create an application form, you must first create a permit type on the permit type definition page.

Adding Permit Type Definitions

1. Select Permit Setup > Permit Type > Permits .
2. Onthe Transaction Type — Permit Types page, click the Add button.
3. Onthe Permit Type page, enter values for the following fields:

Page Element Description

Classification Displays the type of application. The classification for this page indicates this is a permit
application.

Subclassification For use with planning applications. Accept the default value, Not Applicable.

Permit Type Enter a name for the type of permit type.

12
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Page Element

Permit Type ID

Status

Autonumber Rule

Valid from Date and Valid to Date

Public User Enabled

Expiration Group

Application Group

Category

ORACLE
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Description

Enter a unique alphanumeric code or short name for the permit type. Do not use special
characters, including symbols or punctuation, or spaces.

Select from the following to indicate the permit type status:

o Preliminary: The permit type is being defined but is not available for use.

o Ready: The permit type is enabled for immediate use.

Note:
f The permit design must be published in the Intake Form Designer prior to
setting the permit type status to Ready.

o Void: The permit type is no longer available.

Select the autonumbering rule to increment numbers for permits.

For more information, see Setting Up Autonumbering.

Enter a range of dates when this permit type is valid. The default from date is the
current date. The default end date is Open. You can update these dates as needed.

Select from the following to indicate whether this permit type is enabled for public users:

o Enabled for all users
o Enabled for registered users
o Not enabled for public users (default)

Initially, for a newly created permit this is always set to Not enabled for public users.
When you are ready to publish the new permit, update this value. See Publishing Intake
Forms.

Enter the expiration group that defines the expiration rules for permits with this permit
type. Expiration rules determine the expiration dates for different phases of the permit
lifecycle. For more information about permit expiration, see Setting Up Permit Expiration
Rules.

Select a permit application group that you want to associate with the permit type.

For more information, see Setting Up Transaction Groups.

Select an application category that you want to associate with the permit type.
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Document Group

Inspection Group
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Bill Type
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Terms of Use ID
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Description

For more information, see Setting Up Transaction Categories.

Select an application subcategory that you want to associate with the permit type.

For more information, see Setting Up Transaction Subcategories.

Select a document group to manage attachments for the application type.

When you specify a document group, document attachments can be classified into
categories and subcategories during the application process and when you upload
files. Then you can see the category for a document on the attachments page in the

application details.

For more information, see Setting Up Document Groups.

Select an inspection group to associate with the permit type. The inspection group
identifies all inspections necessary for the permit.

For more information, see Setting Up Inspection Groups.

Select a fee schedule that you want to associate with the permit type. A department is
required if the permit type has a fee schedule ID.

For more information, see Setting Up Fee Schedules.

Select a bill type to associate with the permit type.

The billing type identifies the type of invoice that can be generated from the record. The
bill type is required.

For more information, see Setting Up Bill Types.

Select a department that you want to associate with the permit type. A department is
required if you add a Fee Schedule ID to the permit type.

If a department is specified on the Fee Item setup page, the fee item department
overrides the department specified here on the permit type.

For more information, see Setting Up Departments.

Select a terms of use definition to associate with the permit type. When you set up
terms of use, you can make the terms available to the public user registration process,
to the permit application process, or to both. The user must accept the terms and
conditions for using online permits.
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Page Element Description
For more information, see Setting Up Terms of Use.

Description Enter a user-facing description of the permit type. On the Apply page, this description
appears under the permit type name.

The description helps public users understand the purpose of the permit type.

URL Enter a URL for a web page that gives public users more information about the permit
type.

If you enter a URL, then a Learn More link appears at the end of the permit type
description on the Apply page. The user clicks this link to open the specified URL.

If you leave this field blank, the Learn More link is not visible on the Apply page.

Setting Up Workflow for a Permit Type

You set up workflow using the Oracle Autonomous Integration Cloud (OIC) before associating the workflow with the
permit type.

For more information, see Setting Up Process Definitions for Workflow.
1. Select Permit Setup > Permit Type > Permits .

2. Onthe Transaction Type - Permits page, click the Add button.
3. Inthe Workflow Setup section on Permit Type page, enter values for the following fields:

Page Element Description

Workflow Space Name Enter the space where the workflow process application is stored. You can group
related applications in a space as well as enable users to collaborate when developing
applications.

Workflow Application ID Enter the name of the workflow process application in OIC. For more information, see

Creating and Managing Applications.

Workflow Version Enter the version of the workflow process application.

Workflow Process Definition Enter the name of the workflow process definition that applies to this particular permit.
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?’ Note: Different permit types can utilize the same workflow definition.

Setting Up Plan Reviews for a Permit Type

Define how plan reviews are conducted for permits associated with the permit type.

1. Select Permit Setup > Permit Type > Permits .
2. On the Transaction Type — Permits page, click the Add button.
3. Inthe Plan Reviews section on Permit Type page, enter values for the following fields:

Page Element Description

Plan Review Type Select the method used for reviewing plans for permits associated with the permit type.

o Manual: Plan reviews are tracked as part of permitting workflow, but are performed
without the use of integrated electronic document review software.

o Not Used: Plan reviews are not tracked as part of permitting workflow.

o Electronic: Plan reviews are tracked as part of permitting workflow, and are
performed through integration with electronic document review software.

For more information on plan reviews, see Managing Manual Plan Review Cycles and
Managing Electronic Plan Review Cycles.

Plan Reviewer Departments Select the departments that should be included in any plan reviews associated with
this permit type. Plan coordinators should add a reviewer from each of the required
departments. The Reviewers grid of the Plan Review page displays the required
departments that you select here.

For more information about plan reviewer departments, see Setting Up Plan Reviewer
Departments.

For more information about plan reviews, see Electronic Plan Review Process Flow and
Manual Plan Review Process Flow.

Saving a Transaction Type

When you first save a transaction type definition, it may take a few moments to complete. On the first save, the system:

- saves all the transaction type attributes.

- creates the custom database objects (such as view objects).

- creates the REST endpoint for that transaction type.

- creates the Fusion Application sandbox needed for developing the application form layout.

Cloning Permit Types

Click the Clone button to create a clone of the current permit type, which you can then use to create a different permit or
to create a different version of the current permit.
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For more information on cloning permits, see Cloning Transaction Type Definitions.

Designing Intake Forms

After you have entered the appropriate initial information for a permit, you can then begin to design the intake form
that end users will use to submit an online application. You create an application form using the Intake Form Designer.
To access the designer, click Design Form.

For more information on designing intake forms, see Using the Intake Form Designer.

Setting Up Permit Display Groups
Use the Display Group setup pages to add permit display groups that appear on your agency’s landing page, where a

user starts an application.

A permit display group identifies a meaningful grouping of permit and planning application types displayed as a list on
the Apply page. The list appears as the permits or planning applications that agency staff or a guest user can select to
initiate the application process.

For more information about how the Apply page looks and is used, see Choosing an Application Type.

Before setting up permit display groups, you must set up transaction types for your agency. See Setting Up Permit
Types.

This example illustrates the Permit Display Group Details page which is described in the following text.
Permit Display Group Details Concel| [Deete

* Display Group 1D PermitApplicationGroup * Applicable v Permits

Classification Planning and Zoning

Enabled ()

* Display Group  Solar Roof Permits

Description  The permit application group for solar roof.

URL = http://www.oracle.com

Display Group Lines

=R R Search QAT
Display Order Transaction Type ID Transaction Type Classification
1 IJME3 JME3 Permits >

Adding Permit Display Groups

1. Select Permit Setup > Permit Display Group .
2. On the Permit Display Group page, click Add to add a new group.
3. On the Permit Display Group Details page, enter values for the following:
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Page Element

Display Group

Description

URL

Applicable Classification

Setting Up Permits

Description

Enter a permit display group name.

Enter a description of the display group that appears on the Apply page for guests.

Enter a URL used to access additional information about a transaction type.

Select the check box for the applications to which this display group applies. Choose
from these options:

o Permits
o Planning and Zoning

This option determines whether a display group type is shown on the Apply page for
public users. A display group can be included with both the Permit Applications and the
Planning Applications.

4. Verify that the Enabled switch is turned on. The switch is turned on by default for new permit display groups.
5. Inthe Display Group Lines section, click Add to set up a line on the Display Group Line Details page. The
display group lines are transaction types that make up the list in the new display group.

o Note: Both permit transaction types and planning application transaction types can be added
# toadisplay group. For example, you can add a planning application transaction type to a permit
application display group and the other way around.

Page Element

Display Order

Transaction Type ID

Transaction type information

ORACLE

Description

Enter a numerical value in this field to specify the order in which you want the permit
type to be displayed, if desired. The default value is 0 and upon saving, the system
automatically assigns the next value.

Select an existing transaction type ID.

The description for the ID you enter here will appear in the Transaction Type field.

Review the attribute information for the permit type to verify you have selected the
correct transaction type ID:

o Transaction Type
o Classification

o Application Group
o Category
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Page Element Description

o Subcategory

For more information about transaction type attributes, see Setting Up Permit Types.

6. On the Permit Display Group Details page, click Save.

Modifying Permit Display Groups and Lines

You can modify permit display groups and lines on the Permit Display Group Details and Display Group Line Details
pages, respectively.

1. Select Permit Setup > Permit Display Group .
2. On the Permit Display Group page, select the row for the permit group that you want to modify.
3. On the Permit Display Group Details page, you can:

o Modify the description. You cannot change the group name.
o Turn the Enabled switch on or off to enable or disable the display group.

4. If you made any changes, click Save.

5. To modify the display group lines (the list of permits in a display group), select the row for the permit group that
you want to modify on the Permit Display Group page.

6. On the Permit Display Group Details page, select a display group line in the Display Group Lines grid.
7. On the Display Group Line Details page, you can change the values in these fields:

a. Update the Display Order field to change the order in which the lines appear.
b. Update the Transaction Type ID field with another existing permit type ID.
8. If you made any changes, click Save.

Deleting Permit Display Groups and Lines

Select Permit Setup > Permit Display Group .

On the Permit Display Group page, select the row for the permit group that you want to delete.

If you want to delete the display group, click Delete on the Permit Display Group Details page.

If you want to delete multiple display groups, you can delete them from the Permit Display Group page:

PN

a. Click Edit.
b. Select the check boxes for the display groups to delete.
c. Click Delete.
5. To delete a display group line, go to the Permit Display Group Details page and select a display group line in the
Display Group Lines grid.
6. On the Display Group Line Details page, click Delete.
7. If you want to delete multiple display group lines, you can delete them from the Permit Display Group Details
page:

a. Click Edit.
b. Select the check boxes for the display group line rows to delete.
c. Click Delete.
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Setting Up Permit Expiration Rules

You can set up expiration rules for the different phases of the permit application lifecycle.

You set up expiration rules for permit applications to define:

- When an inactive pending application expires.
- When the application expires.
- When the permit expires.

First, you define the rules in an effective-dated group. After setting up the expiration rules, you add the rules group ID to
the application type definition and periodically run batch rules processing to update permit expiration statuses.

Setting Up Expiration Rule Groups
Here's how to set up the rule group:
1. Select Permit Setup > Permit Expiration Group > Permits or Navigator > Permit Expiration Group >

Permits .
2. On the Permit Expiration Group page, enter values for these fields:

Page Element Description

Expiration Group ID, Expiration Enter an ID for the expiration group, a group name, and description.
Group Name, and Description

Effective Start Date and Effective = Enter the range of dates when the group is effective. If you want to leave the effective
End Date dates open-ended, don't enter a date for the end date.

To see the effective date history for an expiration group, click Show All Dates. On the
History Data page, you can search history by effective start date or click Add to add new
effective-dated rules for an expiration group.

Show All Dates Click to access the effective-dated history of the rules definition. This button is available
after you create the first rule.
You can also search history by effective start date. Click Add to create a new effective-

dated row for an expiration group.

3. Verify that the Enabled switch is turned on. The option is active by default for a new expiration group.
4. Create expiration rules in the Expiration Rules section.

Defining Expiration Rules
Here’s how to set up the details about the expiration rules in the group:

1. Select Permit Setup > Expiration Group > Permits .
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2. Click Add in the Expiration Rules section.
3. Enter these values to create each rule:

Page Element

Expiration Basis

Expiration Duration

About to Expire

Grace Period

Number of Extensions

ORACLE

Description

Select the type of expiration for the rule, based on the status of the application:

o Inactive pending application — When the application is in a pending status, users
must submit the application before the expiration date.

The expiration timeframe begins when the user saves an application and ends with
application submission.

o Application expiration — Users must complete permit requirements such as the
plan review before the permit can be issued. If the permit is not issued by the
expiration date, the application and all tasks are canceled.

The expiration timeframe begins when the agency accepts application and ends
when the permit is issued.

o Permit expiration — Users must complete the final inspection before the permit
expires.

The expiration timeframe begins when the agency issues the permit and ends
when the Certificate of Occupancy is issued or the permit is completed.

Note:
o Because start and end dates require specific statuses, workflow processes
f must include status update tasks for Application Accepted (Accepted) and
Certificate of Occupancy (Certificate) or Completed (Completed).

Enter the amount of time that the user has before the expiration date.

Enter when you would like a notification to appear on the application that shows the
user how long until the application expires. For example, you can enter 2 days to show
that a pending application expires in 2 days.

You can manually extend a permit on the Overview page in the transaction details
during the about to expire period. For example, if the about to expire period is 15 days,
the permit can be manually extended starting at 15 days before the expiration date.

Enter the amount of time the application is valid beyond the expiration date. For
example, if a pending application expires in 30 days, you may want to provide a grace
period of an additional 3 days.

You can also manually extend a permit on the Overview page in the transaction details
during the grace period.

Enter the number of allowed extensions beyond the expiration date. For example, to
allow up to 2 extensions you would enter 2.

21



Oracle Public Sector Compliance and Regulation Cloud Chapter 2
Implementing Community Development Setting Up Permits

Page Element Description

You can manually extend the expiration during the About to Expire and Grace Period
timeframes, when the Extend link is available on the Overview page in the application
details. This link is available only for agency staff with appropriate permissions. You
can’t manually extend the expiration for applications in a pending status.

Communication Select an option to send out communications when the permit is about to expire or
expired, and the recurrence of the communication. Agency staff and the contact listed
on the application receive the notifications.

You must set up the About to Expire Permit and Expired Permit events to send out
communications. For more information about configuring the communication
templates for the email or notification you want to send, see Setting Up Communication
Events.

CAUTION:

After setting up communication rules, you must periodically run batch

expiration rule processing to update the about to expire and expired statuses.
A The system updates the statuses and sends out the communications

according to the setup. Oracle recommends that you schedule expiration rule

processing to run daily.

4. Verify that the Enabled switch is turned on for each rule. The option is active by default for a new expiration
rule.

5. C(lick Save.

Setting Up Automatic Permit Extensions

After you add a permit expiration rule, you have the option to automatically extend a permit’s validity based on

inspection activity. This is how it works: You define whether the extension occurs only when the inspection is completed

with a pass result or any result, and specify the duration of the extension in number of days. Automatic extensions
are counted toward the number of available extensions defined in the rule. Agency staff with system administrator
permissions can still manually extend the expiration.

Here’s how to automatically extend a permit:

1. Select the option to automatically push out the permit expiration date.
2. Inthe Result field, select one of the options:

o Any Result: Extend the expiration date when an inspection is completed regardless of the inspection
result.

o Pass Only: Extend the expiration date only when an inspection is complete with a passing result.
3. Inthe Extension Duration fields, select the number of days, months, or weeks to extend the permit.

You might have multiple inspections for a permit, in which case the system extends the permit with each completed
inspection.

ORACLE
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If you have communications set up, notifications are sent when the extended permit is about to expire or when it
expires.

CAUTION: You must periodically run batch expiration rule processing to update the about to expire and
expired statuses for permits that have been extended. The system updates the statuses and sends out the
communications according to the setup.

Associating Expiration Rules with Permit Types

After you create an expiration group, you associate the group of rules with a permit type.

1. Select Permit Setup > Permit Type > Transaction Type > Permits .
2. Click the row for the permit type.

3. On the selected Permit Type page, enter the expiration group ID. You can look up the expiration group by
expiration group name and description.

4. Click Save.

For more information about assigning rules to a permit type, see Setting Up Permit Types.

Running the Expiration Rule Process

After setting up expiration rules and adding an expiration rule group ID to the permit type definition, you must set up
expiration rule processing to periodically update the expiration statuses.

Run the process that updates permit and planning application expiration statuses on the Process Expiration Rules page,
which you access by selecting Common > Process Expiration Rules . Oracle recommends that you schedule expiration
rules processing to run daily.

For information about setting up expiration rules processing, see Updating Application Expiration Status.

Related Topics
- Application Expiration Overview

Importing Solution Packages

Public Sector Compliance and Regulation system administrators and implementation consultants use the Oracle
Cloud Customer Connect to access the Public Sector Compliance and Regulation Solution Library — a collection of
configurations that address common community development functionality with industry best practices, provided in
the form of Solution Packages.

A solution package contains all the necessary configuration files in a compressed file format along with a metadata file.

Review the solution package contents online, download specific solutions that contain the corresponding setup data,
review them and deploy those solutions to your pre-production environment for your understanding. Each solution
package provides a link that allows you to download and review a white paper describing the contents of the particular
solution package. You can review the white paper before you decide to download the solution package.

To access the Solution Library, follow this link Public Sector Compliance and Regulation Solution Library.
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5 Setting Up Planning Applications

Setting Up Agency-Level Options

You set up the Oracle Intelligent Advisor for Permits and Planning and Zoning on the Permit Options page during
agency setup. You can also configure the summary title and text for the Anonymous User Landing Page and the
Registered User Landing page.

To configure agency-level options for permits and planning applications:

1.
2
3.

Select Common Setup > Agency .
Click a row on the Agency Information tab.
Select the Features tab.

Oracle delivers the list of offerings on the Features tab. The Permits offering encompasses both Permits and
Planning and Zoning.

Disregard the Enabled column for the Permit offering. The offering is enabled in the Functional Setup Manager
(FSM).

Click Options for the Permits offering.

On the Permit Options page, you can update values for the following fields:

Page Elements Definition
Oracle Policy Automation ID Enter the unique identifier for the Oracle Policy Automation policy model to be used for
this offering.

The offering-specific policy model that you specify here takes priority over any agency-
wide policy definition that you enter on the main Agency Information page.

Message Title Enter a short text version of the landing page message in a title format. If you leave this
field blank, the value in the Label field on the Link Details page for the menu navigation
link Online Permits is displayed.

Message Summary Enter a longer version of the landing page message title in a sentence format. If you
leave this field blank, the value in the Description field on the Link Details page for the
menu navigation link Online Permits is displayed.

Button Content URL Enter a content URL for the Read More button. Public users click this button to access
the agency’s own permit information page, outside of Oracle Public Sector Permits. If
you leave this field blank, the Read More button opens a dialog box that displays the
Landing Page Message.
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Page Elements Definition

Note:
f If you want to link to a page outside of Oracle Public Sector Permits, you must
enter a URL here.

Landing Page Message Enter a welcome message in rich text to appear in a dialog box on the landing page, if a
URL to access the agency'’s page is not defined.

For more information on Oracle Intelligent Advisor, see Overview of Oracle Intelligent Advisor Configuration.

For more information on the Landing Page Message Definition, see Defining Summary Details.

Related Topics
- Managing Oracle Intelligent Advisor Policies for your Agency

- Setting Up the Landing Page for Anonymous Users
- Setting Up the Landing Page for Registered Users

Setting Up Planning Application Types

Define the types of planning applications supported by an agency, including pre-applications. You add a planning
application type and associate workflow process definitions on the Planning Application Type definition page.

Before you can create an application form, you must first create a planning application type on the Planning Application

Type definition page. The type defines attributes that will be available on the planning application.

This example illustrates the Planning Application Type definition page, which is described in the following sections.

ORACLE
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Planning Application Type

Classification
Subclassification ' Not Applicable v

* Planning Application Type Accessory Dwelling Unit Application

* Planning Application Type ID  FRecord0327A
Status Ready v
* Autonumber Rule  E2EPZRule

[e}
* Valid from Date  3/1/19 ]
o

Valid to Date  Oper > date
Public User Enabled Enabled for all users v

Description

URL

4 Workflow Setup

* Workflow Space Name  FA Bronze3 v

* Workflow Application ID  Permits_Bronze3 v

oud

Chapter 3

Setting Up Planning Applications

doe oosonfom  conc

Hearing Applicable v
Application Group o
Category o
Subcategory o
Document Group o
Fee Schedule  PlanningFees o

* Bill Type  E2E_Bill_Type Q

* Department 1001 o,
Terms of Use ID o,

* Workflow Version 1 v
* Workflow Process Definition Building v

Adding Planning Application Type Definitions

1. Select Planning and Zoning Setup > Planning Application Type > Planning Applications .
2. Onthe Transaction Type — Planning Applications page, click the Add button.

3. On the Planning Type Applicatio

Page Element

Classification

Subclassification

Planning Application Type

Planning Application Type ID

Status

ORACLE

ns page, enter values for the following fields:

Description

Displays the type of application. The classification for this page indicates this is a
planning application.

Displays the type of application.
If you would like to create a pre-application type, select Pre-Application from the drop-

down list. The default value is Not Applicable, which indicates a standard planning
application.

Enter a name for the type of planning application.

Enter a unique alphanumeric code or short name for the planning application type. Do
not use special characters, including symbols or punctuation, or spaces.

Select from the following to indicate the planning application type status:

o Preliminary: The planning application type is being defined but is not available for
use.

o Ready: The planning application type is enabled for immediate use.
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Page Element Description

Note:
f The application setup must be published in the form designer prior to setting
the planning application status to Ready.

o Void: The planning application type is no longer available.

Autonumber Rule Select the autonumbering rule to increment numbers for planning applications.

For more information, see Setting Up Autonumbering.

Valid from Date and Valid to Date  Enter a range of dates when this planning application type is valid. The default from
date is the current date. The default end date is Open. You can update these dates as
needed.

Public User Enabled Select from the following to indicate whether this planning application type is enabled
for public users:

o Enabled for all users
o Enabled for registered users
o Not enabled for public users (default)

For a newly created application type, this is always set to Not enabled for public users.
When you are ready to publish the new application form, update this value. See
Publishing Intake Forms.

Expiration Group Enter the expiration group that defines the expiration rules for planning applications
with this application type. Expiration rules determine the expiration dates for different
phases of the application lifecycle. For more information about planning application
expiration, see Setting Up Planning Application Expiration Rules.

Hearing Select whether public hearings are applicable or not applicable to this planning
application type.

For more information, see Setting Up Hearing Bodies, Setting Up Hearing Hierarchies,
and Setting Up Hearing Decisions.

Application Group Select an application transaction group that you want to associate with the planning
application type.

For more information, see Setting Up Transaction Groups.

Category Select a transaction category that you want to associate with the planning application
type.
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Page Element

Subcategory

Document Group

Fee Schedule

Bill Type

Department

Terms of Use ID

ORACLE

Setting Up Planning Applications

Description

For more information, see Setting Up Transaction Categories.

Select a transaction subcategory that you want to associate with the planning
application type.

For more information, see Setting Up Transaction Subcategories.

Select a document group to manage attachments for the planning application type.
When you specify a document group, document attachments can be classified into
categories and subcategories during the application process and when you upload
files. Then you can see the category for a document on the attachments page in the

application details.

For more information, see Setting Up Document Groups.

Select a fee schedule that you want to associate with the planning application type. A
department is required when you enter a fee schedule ID.

For more information, see Setting Up Fee Schedules.

Select a bill type to associate with the planning application type.

The billing type identifies the type of invoice that can be generated from the record. The
bill type is required.

For more information, see Setting Up Bill Types.

Select a department that you want to associate with the planning application type. A
department is required if you add a Fee Schedule ID to the planning application type.

If a department is specified on the Fee Item setup page, the fee item department
overrides the department specified here on the planning application type.

For more information, see Setting Up Departments.

Select a terms of use definition to associate with the planning application type. The
available values for planning applications are determined by the usage on the terms of
use ID.

For more information, see Setting Up Terms of Use.
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Page Element Description
Description Enter a user-facing description of the planning application type. On the Apply page, this

description appears under the application type name.

The description helps public users understand the purpose of the application type.

URL Enter a URL for a web page that gives public users more information about the planning
application type.

If you enter a URL, then a Learn More link appears at the end of the application type
description on the Apply page. The user clicks this link to open the specified URL.

If you leave this field blank, the Learn More link is not visible on the Apply page.

Setting Up Workflow for a Planning Application

You set up workflow using the Oracle Autonomous Integration Cloud (OIC) before associating the workflow with the
planning application type.

For more information, see Setting Up Process Definitions for Workflow.
1. Select Planning and Zoning Setup > Planning Application Type > Planning Applications .

2. Onthe Transaction Type — Planning Applications page, click the Add button.
3. Inthe Workflow Setup section on Planning Application Type page, enter values for the following fields:

Page Element Description

Workflow Space Name Enter the space where the workflow process application is stored. You can group
related applications in a space as well as enable users to collaborate when developing
applications.

Workflow Application ID Enter the name of the workflow process application in OIC. For more information, see

Creating and Managing Applications.
Workflow Version Enter the version of the workflow process application.

Workflow Process Definition Enter the name of the workflow process definition that applies to this particular
planning application.

?’ Note: Different planning application types can utilize the same workflow definition.
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Saving a Transaction Type

When you first save a transaction type definition, it may take a few moments to complete. On the first save, the system:

- Saves all the transaction type attributes.
- Creates the custom database objects (such as view objects).
- Creates the REST endpoint for that transaction type.

- Creates the Fusion Application sandbox needed for developing the application form layout.

Cloning Planning Application Types

Click the Clone button to create a clone of the current planning application type, which you can then use to create a
different planning application or to create a different version of the current planning application.

For more information on cloning permits and planning applications, see Cloning Transaction Type Definitions.

Designing Planning Application Forms

After you have entered the appropriate initial information for the planning and zoning type, you can then begin to
design the intake form that end users will use to submit an online application for a permit. You create an intake form
using the designer. You access the designer by clicking the Design Form button.

For more information on designing intake forms, see Using the Intake Form Designer.

Setting Up Planning Application Display Groups
Use the Display Group setup pages to add planning application display groups that appear on your agency’s landing
page, where a user starts an application.

A planning application display group identifies a meaningful grouping of permit and planning application types
displayed as a list on the Apply page. The list appears as the permits and planning applications that agency staff or
guest users can select to initiate the application process.

For more information about how the Apply page looks and is used, see Choosing an Application Type.

Before setting up planning application display groups, you must set up planning application types for your agency. See
Setting Up Planning Application Types.

This example illustrates the Planning Application Display Group Details page, which is described in the following text.
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Planning Application Display Group Details Ganeel | | Delete

* Display Group ID  PreAppGROUP * Applicable Classification Permits

+ Planning and Zoning

Enabled ()

* Display Group PreAppGROUP

Description  PreAppGROUP

URL

Display Group Lines

=+ X Search QY
Display Order Transaction Type ID Transaction Type Classification

1 PNZAUT PNZAUT Planning and Zoning >

2 PlanningAppln PlanningAppln Planning and Zoning >

Adding Planning Application Display Groups

1. Select Planning and Zoning Setup > Planning Display Group .
2. On the Planning Application Display Group page, click Add to add a new grouping.
3. On the Planning Application Display Group Details page, enter values for the following:

Page Element Description

Display Group Enter a planning application display group name.

Description Enter a description of the display group that appears on the Apply page for guests.
URL Enter a URL used to access additional information about a transaction type.
Applicable Classification Select the check box for the applications to which this display group applies. Choose

from these options:

o Permits
o Planning and Zoning
This option determines whether a display group type is shown on the Apply page for

public users. A display group can be included with both the Permit Applications and the
Planning Applications.

4. Verify that the Enabled switch is turned on. The switch is turned on by default for new planning application
display groups.

5. Inthe Display Group Lines section, click Add to set up a line on the Display Group Line Details page. The
display group lines make up the list of planning application types in the new display group.
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Note: Both permit transaction types and planning application transaction types can be added to a
#  display group. For example, you can add a permit transaction type to a planning application display
group and the other way around.

Page Element Description

Display Order Enter a numerical value in this field to specify the order in which you want the planning
application type to be displayed, if desired. The default value is 0 and upon saving, the
system automatically assigns the next value.

Transaction Type ID Select an existing transaction type ID.

The description for the ID you enter here will appear in the Transaction Type field.

Transaction type information Review the attribute information for the planning application type to verify you have
selected the correct transaction type ID:

o Transaction Type
o Classification

o Application Group
o Category

o Subcategory

For more information about transaction type attributes, see Setting Up Planning
Application Types.

6. On the Planning Application Display Group Details page, click Save.

Modifying Planning Application Display Groups and Lines
You can modify planning application display groups and lines on the Planning Application Display Group Details and
Display Group Line Details pages, respectively.

1. Select Planning and Zoning Setup > Planning Display Group .
On the Planning Application Display Group page, select the row for the planning application group that you
want to modify.

3. On the Planning Application Display Group Details page, you can:

o Modify the description. You cannot change the group name.
o Turn the Enabled switch on or off to enable or disable the display group.

4. If you made any changes, click Save.

5. To modify the display group lines (the list of planning applications in a display group), select the row for the
planning application group that you want to modify on the Planning Application Display Group page.

6. On the Planning Application Display Group Details page, select a display group line in the Display Group Lines
grid.

7. On the Display Group Line Details page, you can change the values in these fields:
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a. Update the Display Order field to change the order in which the lines appear.
b. Update the Transaction Type ID field with another existing planning application type ID.
8. If you made any changes, click Save.

Deleting Planning Application Display Groups and Lines

1. Select Planning and Zoning Setup > Planning Display Group .
2. On the Planning Application Display Group page, select the row for the planning application group that you
want to delete.
3. If you want to delete the display group, click Delete on the Planning Application Display Group Details page.
4. If you want to delete multiple display groups, you can delete them from the Planning Application Display Group
page:
a. Click Edit.
b. Select the check boxes for the display groups to delete.
c. Click Delete.
5. To delete a display group line, go to the Planning Application Display Group Details page and select a display
group line in the Display Group Lines grid.
On the Display Group Line Details page, click Delete.
If you want to delete multiple display group lines, you can delete them from the Planning Application Display
Group Details page:
a. Click Edit.
b. Select the check boxes for the display group line rows to delete.
c. Click Delete.

N o

Setting Up Planning Application Expiration Rules

You can set up expiration rules for the different phases of the planning application lifecycle.

You set up expiration rules for planning applications to define:

- When an inactive pending application expires.
- When the entitlement expires.

First, you define the rules in an effective-dated group. After setting up the expiration rules, you add the rules group ID to
the application type definition and periodically run batch rules processing to update permit expiration statuses.

Setting Up Expiration Rule Groups

Here's how to set up the rule group:

1. Select Planning and Zoning Setup > Expiration Group > Planning Applications .
2. On the Planning Expiration Group page, enter values for these fields:

Page Element Description

Expiration Group ID, Expiration Enter an ID for the expiration group, a group name, and description.
Group Name, and Description
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Page Element Description
Subclassification Select Not Applicable for a planning application or Pre-Application. Use Pre-Application

if you are applying this group of rules to a pre-application transaction type.

Effective Start Date and Effective = Enter the range of dates when the group is effective. If you want to leave the effective
End Date dates open-ended, don't enter a date for the end date.

To see the effective date history for an expiration group, click Show All Dates. On the
History Data page, you can search history by effective start date or click Add to add new
effective-dated rules for an expiration group.

Show All Dates Click to access the effective-dated history of the rules definition. This button is available
after you create the first rule.

You can also search history by effective start date. Click Add to create a new effective-
dated row for an expiration group.

3. Verify that the Enabled switch is turned on. The option is active by default for a new expiration group.
4. Create expiration rules in the Expiration Rules section.

Defining Expiration Rules

Here’s how to set up the details about the expiration rules in the group:

1. Select Planning and Zoning Setup > Expiration Group > Planning Applications .
2. C(lick Add in the Expiration Rules section.
3. Enter values to create each rule:

Page Element Description

Expiration Basis Select the type of expiration for the rule, based on the status of the application:

o Pre-application expiration — Applies only to pre-applications. Users must complete
the pre-application within the specified period of time.

The expiration timeframe begins when the user saves the pre-application and ends
when the user starts the planning application.

o Inactive pending application - When the planning application is in a pending
status, the user must submit the application before the expiration date.

The expiration timeframe begins when the user saves a planning application and
ends with application submission.

o Entitlement expiration — Applies only to entitlements for planning applications.
Users must submit a permit application after the entitlement is issued and before
the expiration date.

The expiration timeframe begins when the agency issues the completed
entitlement and ends when the user submits the permit application.
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Expiration Duration

About to Expire

Grace Period

Number of Extensions

Communications

ORACLE

oud

Chapter 3

Setting Up Planning Applications

Description

Note:
o Because start and end dates require specific statuses, workflow processes
? must include status update tasks for Application Accepted (Accepted) and
Certificate of Occupancy (Certificate) or Completed (Completed).

Enter the amount of time that the user has before the expiration date.

Enter when you would like a notification to appear on the application that shows the
user how long until the application expires. For example, you can enter 2 days to show
that a pending application expires in 2 days.

Enter the amount of time the application is valid beyond the expiration date. For
example, if a pending application expires in 30 days, you may provide a grace period of
an additional 3 days.

Enter the number of allowed extensions beyond the expiration date. For example, to
allow up to 2 extensions you would enter 2.

You can manually extend the expiration during the About to Expire and Grace Period
timeframes, when the Extend link is available on the Overview page in the application
details. This link is available only for agency staff with appropriate permissions. You
can’t manually extend the expiration for applications in a pending status.

Both manual extensions and extensions that occur automatically due to inspection
activity count toward the number of available extensions.

Select an option to send out communications when the pre-application or planning
application is about to expire or expired, and the recurrence of the communication.
Agency staff and the contact listed on the application receive the notifications.

You must set up planning events to send out communications:

o About to Expire Pre-application

o Expired Pre-Application

o About to Expire Planning and Zoning Application
o Expired Planning and Zoning Application

For more information about configuring the communication templates for the email or
notification you want to send, see Setting Up Communication Events.
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Page Element Description

CAUTION:

After setting up communication rules, you must periodically run batch

expiration rule processing to update the about to expire and expired statuses.
A The system updates the statuses and sends out the communications

according to the setup. Oracle recommends that you schedule expiration rule

processing to run daily.

4. Verify that the Enabled switch is turned on for each rule. The option is active by default for a new expiration
rule.

5. Click Save.

Associating Expiration Groups with Application Types

After you create an expiration group, you associate the group of rules with a planning application type.

1. Select Planning and Zoning Setup > Planning Application Type > Transaction Type > Planning
Applications .
2. Click the row for the planning application type.

3. On the selected Planning Application Type page, enter the expiration group ID. You can look up the expiration
group by expiration group name and description.

4. Click Save.
For more information see Setting Up Planning Application Types.

Running the Expiration Rule Process

After setting up expiration rules and adding an expiration rule group ID to the planning application type definition, you
must set up expiration rule processing to periodically update the expiration statuses.

Run the process that updates permit and planning application expiration statuses on the Process Expiration Rules page,
which you access by selecting Common > Process Expiration Rules . Oracle recommends that you schedule expiration
rules processing to run daily.

For information about setting up expiration rules processing, see Updating Application Expiration Status.

Related Topics
« Application Expiration Overview

Managing Pre-Application Meeting Configuration

Pre-applications are the initial step in the planning and zoning process, and are used to allow the property owner or
developer to work with agency planners to receive feedback prior to submitting planning applications. A pre-application
meeting is scheduled between the property owner or developers and agency planners to determine the necessary
applications and approvals for the project.
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Configuring the Pre-Application Meeting

Administrators set up and manage the pre-application meeting configuration on the Manage Pre-Application Meeting

Configuration page.

1. Select Pre-Application Setup > Pre-Application Meeting Setup . Or, Select Setup and Maintenance tile
on the Agency Springboard > Select Public Sector Planning and Zoning > Planning Application Types
functional area > Manage Pre-Application Meeting Configuration task.

2. Onthe Manage Pre-Application Meeting Configuration page, the Pre-Application Meeting section allows you to
set up applicant privileges. Enter values for the following fields:

Page Element

Applicant can request

Applicant can reschedule

Description

Select to allow an applicant to request a pre-application meeting. Applicants can access
the Pre-Application Meeting Request page. See Working with Pre-Application Meetings.
and schedule a meeting based on the availability of the agency staff.

Select to allow an applicant to reschedule their meeting.

3. The Meeting Availability section allows you to set up the parameters for scheduling meetings, determined by:
a. Planner meeting schedule or

b. Agency meeting schedule

Planner meeting schedule: Select to allow users to schedule meetings based on the availability of their

assigned planner.

f Note: You also need to ensure that all the Planners are assigned a Pre-Application meeting work
schedule on the Agency Staff Profile. Enter values for the following fields:

Page Element

Meeting Duration in Hours

Schedule after Number of Days

Schedule up to Number of Days

ORACLE

Description

Select a value to set the maximum amount of time the meeting can be scheduled for.
Users will see this value as the duration of the meeting, and they are not allowed to edit
the field. See the section Scheduling a Pre-Application Meeting under Working with Pre-
Application Meetings.

Select a value to set the number of days from the current date, so that users can
schedule a meeting on a date available after the number of days specified here. For
example, if you select a value 5 on the 10th day of this month, the calendar on the Pre-
Application Meeting Request page displays the dates that are available after the 15th
day of the month.

Select a value to set the number of days that will be available for the users to select a
date on the calendar for scheduling the meeting. For example, if you select a value of
90, the calendar on the Pre-Application Meeting Request page displays 90 calendar
days starting from the date the user is making the selection.
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Page Element Description

See the section Scheduling a Pre-Application Meeting under Working with Pre-
Application Meetings.

Agency meeting schedule: Select to allow users to schedule meetings based on the schedule of the agency. In
addition to the fields described above, enter values for the following fields:

o Note: If you select this option, then you need not assign Pre-Application meeting schedule to the
# planners as the Pre-Application meeting schedule will not be considered while determining the

availability.
Page Element Description
Pre-Application Work Schedule Select the Agency level work schedule that needs to be considered while determining

the availability for the pre-application meeting.

Maximum Concurrent Meetings Select a value to determine the maximum number of meetings that can be scheduled at
atime.

4. The Meeting Agenda and Location section allows you to set up the agenda and the location for the pre-
application meeting.

Page Element Description
Include Agenda Select the check box and enter the agenda in the Meeting Agenda field.
Include Location Select the check box and search for the desired location of your agency using the

Agency Information look up. The address of the location you select is displayed in the
Meeting Location field.

f Note: Users can edit the entries for the agenda and location fields while scheduling the meeting on
the Pre-application Request page.

Setting Up Hearing Bodies

With Oracle Public Sector Compliance and Regulation Cloud, you will use the Public Hearing feature to configure hearing
bodies and hearing hierarchies, schedule hearings, and record decisions.
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Setting Up Public Hearing

A public hearing is an official meeting where members of the public, the hearing body, and the applicant of the planning
and zoning application come together to discuss the facts about the application submitted by the applicants.

The following topics apply to administrators for setting up and maintaining the Public Hearing process:

- Setting up Hearing Body
- Setting up Hearing Hierarchy

- Setting up Hearing Decision

Setting Up Hearing Body
A hearing body is a group of individuals formed to evaluate the testimony presented by applicants and to provide
feedback.

Adding a Hearing Body
To add a hearing body:

1. Select Hearing Setup > Hearing Body .
2. Click Add on the Hearing Body page and enter values for the following fields:

Page Element Description

Hearing Body Code Enter a unique identifier of the hearing body.

Name Enter a name for the hearing body.

Additional Information Enter any text as details about the hearing body.

Enabled Turn on the switch to make the hearing body available for use.

Appeal Period Select the number of days after the public hearing, when an appeal is allowed.
Maximum Agenda Items Select a value from the options. As an agency user you can configure the maximum

number of agenda items that can be heard on a day.

Address fields Enter the address of the hearing. Enter the ZIP code, or click the Don’t Know link to
enter values for the following fields:

o Country: U.S (Default value)
o ZIP Code
o Address Line1
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Page Element Description
o Address Line 2
o City
o State

o Postal Code

3. Select a pattern of recurrence of the meeting from these fields:

Page Element Description

Recurrence Pattern Select the pattern for the recurrence of the public hearing:
o Weekly
o Monthly

4. Select the Weekly recurrence if you want to schedule the meeting every week. Enter values for the following

fields:
Page Element Description
Weeks between Occurrences Select the number of weeks between one meeting occurrence and the next.
Days of the Week Select the days of the week on which you want the meeting to recur.
Recurrence Start Date Time Select a date and time from which the meeting recurrence should be effective.

5. Select the Monthly recurrence if you want to schedule the meeting every month. Enter values for the following

fields:
Page Element Description
Months between Occurrences Select the number of months between one meeting occurrence and the next.
Days of the Week Select the check box if you want to schedule the meeting on particular days of the

week. Click Add to open the Days of the Week page and select the days of the week, for
example First Monday:

o Occurrence: Select - First, Second, Third, Fourth, or Last the day of week
o Weekday: Select the day of the week from Monday, Tuesday, and so on.

Turn on the Enable switch to make the setting available for use and click Save. Use the
Add button to include multiple rows.
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Page Element Description
Note:
f You can modify or delete the entry. Click the row and use the Days of the Week

page to make the change.

Dates Select the check box if you want to schedule the meeting on particular dates of the
week. Click Add to open the Dates page and select from all the available dates.

Turn on the Enable switch to make the setting available for use and click Save. Use the
Add button to include multiple rows.

Note:
You can modify or delete the entry. Click the row and use the Dates page to
make the change.

4

Recurrence Start Date Time Select a date and time from which the meeting recurrence should be effective.

6. Click Save to save the new hearing body and return to the Hearing Body page.

Modifying a Hearing Body
To modify a hearing body:
1. Select Hearing Setup > Hearing Body .

2. Onthe Hearing Body page, click the record of the hearing body you want to edit.
3. Onthe Hearing Body details page you can make changes to the fields and click Save.

?’ Note: You can make changes to all the fields except the Hearing Code.

4. The Hearing Body page now lists the updated record.

Deleting a Hearing Body

To delete a hearing body:

Select Hearing Setup > Hearing Body .
On the Hearing Body page, click the record of the hearing body you want to delete.
On the Hearing Body details page you can click the Delete button. Click OK on the confirmation message.

The Hearing Body page lists only the existing records.

P UWNA
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Setting Up Hearing Hierarchies

Hearing Hierarchy defines the levels of hearing bodies that an application can be escalated through. In an agency, a
planning and zoning application can be escalated to a higher body in cases of appeal, where the highest hearing body
decision is considered final.

Agencies set up their hearing hierarchy to address events such as an appeal. For example, a hearing begins with the
Planning Committee and then an appeal escalates the application to the Planning Commission. If appealed again, the
application moves to the City Council.

Adding a Hearing Hierarchy
To add a hearing hierarchy:

1. Select Hearing Setup > Hearing Hierarchy .
2. Click Add on the Hearing Hierarchy page and enter values for the following fields:

Page Element Description

Hierarchy Code Enter a unique identifier of the hearing body.

Hierarchy Enter a name for the hearing hierarchy.

Enabled Turn on the switch to make the hearing hierarchy available for use.
Description Enter any text to describe the hierarchy.

3. Click Add and enter values for the following fields:

Page Element Description
Hearing Body Code Select a hearing body code to associate with the new hearing hierarchy.
Sequence Select a number to determine the escalation level of the selected hearing body within

the hierarchy. For example, if the value 2 is selected, the selected hearing body will be
the second in the hierarchy for the public hearing.

Appeal Allowed Turn on the switch if you want to allow the agency to appeal after the hearing body
places its decision. The agency will not be allowed to appeal the hearing to the next
body in the hierarchy, if the switch is turned off.

Enabled Turn on the switch if you want to allow the hearing body to be available for use.
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Page Element Description
+ Click to add a new row and add a new hearing body in the hierarchy.
= Click to delete the row. The hearing body will be removed from the hierarchy.

4. Click Save to save the newly created hierarchy and return to the Hearing Hierarchy page, where the new
hierarchy you created is listed.

Modifying a Hearing Hierarchy

To modify a hearing hierarchy:

1. Select Hearing Setup > Hearing Hierarchy .
2. On the Hearing Hierarchy page, click the hearing hierarchy row you want to edit.
3. Onthe Hearing Hierarchy details page make changes to the fields and click Save.

?’ Note: You can make changes to all the fields except the Hierarchy Code.

Deleting a Hearing Hierarchy

To delete a hearing hierarchy:

1. Select Hearing Setup > Hearing Hierarchy

2. Onthe Hearing Hierarchy page, click the hearing hierarchy row you want to delete.

3. Onthe Hearing Hierarchy details page, click Delete and click OK on the confirmation page to delete the hearing
hierarchy.

4. C(lick Save and return to the Hearing Hierarchy page. The page lists the updated hierarchy rows.

Setting Up Hearing Decisions

The outcome of a public hearing is referred to as hearing decision. Agency staff such as assigned planners update the
decision from the hearing body into the system.

System-defined Public Hearing Decisions

Oracle delivers hearing decisions for use during the hearing process. System administrators can configure the decisions
specific to their agency, which are mapped to one of the system-defined decisions listed below:

- Approved
None
Denied

- Continue
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Adding a Hearing Decision

1. Select Hearing Setup > Hearing Decision .
2. The Hearing Decision page lists all the decisions you have configured. Click Add.
3. One the Hearing Decision Status detail page, enter values for the following fields:

Page Element Description
Code Enter a unique identifier of the hearing decision.
Name Enter a name to identify the decision. Example, Approved with Conditions, Not Result,
and so on.
Description Enter any text to describe the decision.
Decision Select one of the system-defined decisions to map to the new decision you are creating:
o Approved:
o None
o Denied
o Continue
Enabled Turn on the switch to make the decision available to use.

4. C(lick Save to save the new hearing decision and return to the Hearing Decision page, which lists the newly
created decision.

Modify a Hearing Decision
To modify a hearing decision:
1. Select Hearing Setup > Hearing Decision .
2. The Hearing Decision page lists all the decisions you have configured. Click the row of the decision you want to
modify.
3. On the Hearing Decision detail page, make changes to the fields and click Save.

f Note: You can make changes to all the fields except the Code.

4. The Hearing Decision page lists the updated row.

Deleting a Hearing Decision

To delete a hearing decision:

1. Select Hearing Setup > Hearing Decision .
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2. The Hearing Decision page lists all the decisions you have configured. Click the row of the decision you want to
delete.

3. Onthe Hearing Decision detail page, click Delete and confirm deletion by selecting OK.
4. Click Save and return to the Hearing Decision page. The page lists the updated decision rows.
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4 Setting Up Code Enforcement

Setting Up Corrective Actions

Define the various corrective actions that can be applied to resolve code violations identified by an agency.

A corrective action can resolve more than one code violations. You add a corrective action using the Corrective Action
page and assign the action to one or more code references on the code configuration page.

Adding Corrective Actions

1. Select Code Enforcement Setup > Corrective Action.
2. Click Add on the Corrective Action page to add a new corrective action.
3. Onthe Corrective Action Details page, enter values for the corrective action.

Page Element Description

Corrective Action ID Enter a unique identifier for the corrective action.

Summary Enter a summary about the action that is to be taken to resolve the violation.

Description Enter longer descriptions or instructional information that can be formatted using a rich
text editor.

4. Verify that the Enabled switch is turned on. The option is active by default for a new corrective action.
5. Click Save.

Modifying Corrective Actions

You can modify corrective actions for the code violations on the Corrective Action page.

1. Select Code Enforcement Setup > Corrective Action .
. Onthe Corrective Action page, select the row for the corrective action that you want to modify.
3. On the Corrective Action Details page, you can edit the summary and description. Click the Enabled switch to
enable or disable the corrective action.
4. C(lick Save to save the changes.

Deleting Corrective Actions

You can delete corrective actions for the code violations on the Corrective Action page.

1. Select Code Enforcement Setup > Corrective Action.
2. On the Corrective Action page, select the row for the corrective action that you want to delete.
3. Onthe Corrective Action Details page, click the Delete button.
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Setting Up Code References for Code Enforcement

Code references are pointers to the documentation for a specific code used on a violation. These references instruct
readers to refer to documentation for the specific item. Set up the Public Sector Community Development system to
point the user to a specific documentation regarding that code violation.

Adding Code References

1.
2
3.

4.
5.

Select Code Enforcement Setup > Code Reference .
Click Add on the Code Reference page to add a new code reference.
On the Code Reference Details page, enter values for the code reference.

Page Element Description

Code Reference ID Enter a unique identifier of the code reference.

Summary Enter a summary about the violation that is related to the incident.

Description Enter longer descriptions or instructional information that can be formatted using a rich
text editor.

Corrective Action Select the corrective action that can be applied to resolve the violation.

Summary Displays information about the corrective action that will be taken to resolve the
violation.

Verify that the Enabled switch is turned on. The option is active by default for a new code reference.
Click Save.

Modifying Code References

You can modify code references on the Code Reference page.

1.
2,
3.

Select Code Enforcement Setup > Code Reference .
On the Code Reference page, select the row for the code reference that you want to modify.
On the Code Reference Details page, you can:

o Change the values for the summary, description, and corrective action fields.

o Click the Enabled switch to enable or disable the corrective action.

Click Save to save changes.
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Deleting Code References

You can delete code references on the Code Reference page.

1. Select Code Enforcement Setup > Code Reference .
2. Onthe Code Reference page, select the row for the code reference that you want to delete.
3. Onthe Code Reference Details page, click the Delete button.

Setting Up Code Reference Groups

A code reference group is a set of code references grouped together on the basis of the nature of violations. You set up
code reference groups on the Code Reference Group page.

Adding Code Reference Groups

1. Select Code Enforcement Setup > Code Reference Group .
2. The Code Reference Group page lists all the code reference groups. Click Add to add a new group.
3. Onthe Code Reference Group Details page, enter values for the code reference group.

Page Element Description
Code Reference Group ID Enter a unique identifier for the code reference group.
Name Enter a name for the code reference group.

4. Verify that the Enabled switch is turned on. The option is active by default for a new code reference group.

5. Inthe Code References section, click Add to search and include one or more code references to the group. Use
the Add and Delete action icons for adding and deleting code reference records.

6. Click Save.

Modifying Code Reference Groups

You can modify code references groups on the Code Reference Group page.

1. Select Code Enforcement Setup > Code Reference Group .
2. On the Code Reference Group page, select the row for the code reference group that you want to modify.
3. On the Code Reference Group Details page, you can:
o Change the name of the group.
o Use the Code References section to add new or delete existing code references.
o Click the Enabled switch to enable or disable the code reference group.
4. Click Save to save changes.
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Deleting Code Reference Groups

You can delete code reference groups on the Code Reference Group page.

1. Select Code Enforcement Setup > Code Reference Group .
2. On the Code Reference Group page, select the row for the code reference group that you want to delete.
3. Onthe Code Reference Group Details page, click the Delete button.

Setting Up Notices

A notice is a document issued by a code enforcement authority to the party that has violated a code. You set up code
enforcement notices that are used to generate and send reports to the concerned responsible parties.

Adding Notices

1. Select Code Enforcement Setup > Notice .
2. The Notice page lists all the notices. Click Add to add a new notice.
3. On the Notice Details page, enter values for the notice.

Page Element Description

Notice ID Enter a unique identifier of the notice.

Name Enter a name for the notice.

Report ID Select a report to be sent as part of the notice. This report is set up on the Report

Configuration page.

4. Verify that the Enabled switch is turned on. The option is active by default for a new notice.
5. Click Save.

Modifying Notices

You can modify notices on the Notice page.

1. Select Code Enforcement Setup > Notice .
2. Onthe Notice page, select the row for the notice that you want to modify.
3. On the Notice Details page, you can:

o Change the notice name.
o Select a new report ID.
o Click the Enabled switch to enable or disable the notice.

4. Click Save to save changes.
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Deleting Notices

You can delete notices on the Notice page.

1. Select Code Enforcement Setup > Notice.
2. On the Notice page, select the row for the notice that you want to delete.
3. On the Notice Details page, click the Delete button.

Setting Up Notice Groups

A notice group is a set of notices grouped together on the basis of the status of the case. The notices within a group
follow a sequence that you configure, to send to the concerned parties as and when required.

Adding Notice Groups

1. Select Code Enforcement Setup > Notice Group .
2. The Notice Group page lists all the notice groups. Click Add to add a new notice group.
3. On the Notice Group Details page, enter values for the notice group.

Page Element Description
Notice Group ID Enter a unique identifier of the notice group.
Name Enter a name for the notice group.

4. Verify that the Enabled switch is turned on. The option is active by default for a new notice group.

5. Inthe Notice Associations section, you can configure the notices that are to be sent for a particular case status
and in a particular sequence.

Page Element Description
Case Status Select a case status to associate with the new notice group.
Sequence Select a value to determine the sequence of the selected notice within the hierarchy. For

example, if the value 2 is selected, the selected notice will be the second notice for the
selected case status.

Notice ID Select a notice that is specific to the case status and the sequence value.

Use the Add and Delete action icons for adding and deleting notice association records.
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Note: You must ensure that valid notices are configured for the case status before you associate a
# notice group with an issue subtype. Use ORA_VIO status to create a case. Use ORA_CIT status to issue
a citation.

6. Click Save.

Modifying Notice Groups

You can modify notice groups on the Notice Group page.

1. Select Code Enforcement Setup > Notice Group .
2. On the Notice Group page, select the row for the notice group that you want to modify.
3. On the Notice Group Details page, you can:

o Change the name of the notice group.

o Delete notice associations and create new ones.

o Click the Enabled switch to enable or disable the notice group.
4. Click Save to save changes.

Deleting Notice Groups

You can delete notice groups on the Notice Group page.

1. Select Code Enforcement Setup > Notice Group .
2. Onthe Notice Group page, select the row for the notice group that you want to delete.
3. On the Notice Group Details page, click the Delete button.

Setting Up Inspection Counts

Define the number of inspections that are carried out to assess code violations reported at the agency. You use the
Inspection Count page to set up the inspection count value and its description.

Adding Inspection Counts

1. Select Code Enforcement Setup > Inspection Count .
2. Click Add on the Inspection Count page to add a new inspection count.
3. Inthe new row, enter the count value in the Inspection Count field and a description in the Description field.

» Note: The inspection count values must follow an incremental sequence of numbering, such as 1, 2, 3,
4 and so on.

4. Verify that the Enabled switch is turned on. The option is active by default for a new inspection count.
5. Click Save.
Deleting Inspection Counts

1. Select Code Enforcement Setup > Inspection Count .
2. On the Inspection Count page, click the Delete icon for the row of the inspection count you want to delete.
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| f Note: You must ensure that the sequencing of numbers in the inspection count is maintained.

Setting Up Referral Bodies

Referral bodies are those departments that an agency can refer to in cases of code violations that are not in the scope of
the agency. The agency can assign the issue to the referral body based on the referral type.

Adding Referral Bodies

1. Select Code Enforcement Setup > Referral Body .

The Referral Body page lists all the referral bodies that are configured by the agency.
2. Click Add on the Referral Body page to add a new referral body and enter values for the following fields:

Page Element Description

Referral Code Enter an identifier of the referral body.

Name Enter a name for the referral body.

Description Enter a description about the referral body on the basis of which, an incident or case can

be referred to the body.

Referral Type Select the type of referral, which can be a department within the agency or an external
agency:

o Agency Department.

o External Agency.

3. Verify that the Enabled switch is turned on. The option is active by default for a new referral body.
4. Click Save.

Modifying Referral Bodies

1. Select Code Enforcement Setup > Referral Body .
2. On the Referral Body page select the row for the corrective action that you want to modify.
3. On the referral body details page, you can:

o Change the name, description, and referral type values.
o Click the Enabled switch to enable or disable the referral body.
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| f Note: You cannot delete a referral body.

4. C(lick Save to save changes.

Setting Up Time Rules

Chapter 4

Setting Up Code Enforcement

Time rules are a set of policies that uses the input code enforcement inspection parameters — due date type, trigger
date, priority, and occurrence to calculate due dates.

The following logic is used to calculate due date:

Due Date = Trigger date + Dates based on the time rule

If the number of transactions created exceed the policy count, then the time rule that is defined for the highest policy
occurrence will be triggered.

Time rules are assigned to the issue subtype of the incident, the values of which are sourced from the Code
Enforcement Options page. See Setting Up Agency-Level Options for Code Enforcement.

Note: Important!: Agency administrators add and modify time rules and assign them to issue subtypes so
f that appropriate rules are applied for each subtype. Every issue subtype must have a time rule assigned for

every system-defined due date type. See Setting Up Issue Subtypes. The following table shows the various

delivered due date types and their details.

Due Date Type

ORA_INC_REV_DUEDT

ORA_INIT_INS_DUEDT

ORA_RE_INS_DUEDT

ORA_VIOL_CMPL_PRD_
DUEDT

ORACLE

Description

Incident review date

Initial inspection date

Re-inspection date

Due date for compliance

Events that calculate the
due date

Incident creation

Initial inspection creation

Re-inspection creation

Case creation

Trigger Date

Incident report date

Inspection schedule date

Inspection schedule date

Case creation date

Usage

The incident in the worklist
is marked with a status

of Overdue when the
calculated review due date
is less than the current
date.

The Inspection due date
is updated with this date
when the initial inspection
is scheduled.

The Inspection due date
is updated with this date
when the re-inspection is
scheduled.

The date is displayed as
the compliance date on the
Case page.
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Due Date Type

ORA_VIOL_APPL_PRD_
DUEDT

ORA_CITATN_CMPL_PRD_
DUEDT

ORA_CITATN_DUEDT

ORA_CITATN_APPL_PRD_
DUEDT

ORA_ABTMT_DUEDT

Description

Violation appeal period

Due date for citation
compliance

Due date for citation
payment

Citation appeal period

Abatement of violation due
date

Adding Time Rules

You configure the time rules and policies using the Time Rule page.

Events that calculate the
due date

Case status change to
Violation.

Citation issuance

Payment initiation

Case status change to
Citation.

Trigger Date

Case creation date

Citation issue date

Citation issue date

Citation Issue Date

Chapter 4
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Usage

The value for the policy
occurrence count is zero (0)
at the time of case creation.

Ensures that the Request

Appeal option is available
only during the calculated
appeal period.

Updates the compliance
date displayed on the Case
detail page.

Late fee is added after the
citation payment due date.

Ensures that the Request

Appeal option is available
only during the calculated
appeal period.

At present this due date
type is not active.

1. Select Code Enforcement Setup > Time Rule . The Time Rule page lists all the time rules that are configured

by the agency.

2. Click Add on the Time Rule page to add a new time rule.

3. Onthe Time Rule Detail page, add values to the following fields:

Page Element

Time Rule

Description

Due Date Type

Description

Enter a name for the time rule.

Enter a description about the time rule.

Select the type of due date, which determines the time period or due date for a
transaction.

4. Verify that the Enabled switch is turned on. The option is active by default for a new time rule.
5. Inthe Time Policy section, click the Add button to define a time policy.

6. On the Time Policy Details page, select values for the time policy:

ORACLE
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Page Element Description
Priority Select the priority for the time policy:
o High
o Normal
Unit of Measure Select a unit for the measurement of time:
o Hours
o Days
Unit of Measure Value Select a number value for the unit of measure of time you selected above.
Policy Occurrence Count Select an occurrence count value for the event, such as an inspection.

Modifying Time Rules

Select Code Enforcement Setup > Time Rule.

Select the time rule row you want to modify.

On the Time Rule Detail page you can change the time rule description, due date type, and the time policy.
Click the Enabled switch to enable or disable the time rule.

Click Save to save changes.

VAWNA

Deleting Time Rules

1. Select Code Enforcement Setup > Time Rule .
2. Select the time rule row you want to delete.
3. Onthe Time Rule Detail page, click the Delete button.

Modifying Time Policies

1. Select Code Enforcement Setup > Time Rule .

2. Onthe Time Rule page, select the time policy row to open the Time Policy Detail page. You can change values
for priority, unit of measure, unit of measure value, and policy occurrence count.

3. Click Save to save any changes.

Deleting Time Policies

1. Select Code Enforcement Setup > Time Rule .

2. Onthe Time Rule page, select the time rule row for which you want to change the time policy.

3. On the Time Rule Detail page, click the time policy row to open the Time Policy Detail page.

4. C(lick the Delete button.

5. To delete multiple time policies from the Time Rule Detail page, click the Edit button in the Time Policy section
and select the check boxes for the rows you want to delete.

6. Click Delete.
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Setting Up Agency-Level Options for Code Enforcement

Agency-level options for code enforcement include several settings related to the public user experience as well as
autonumbering rules and certain default settings for newly created issue types.

Agency-level options for code enforcement include:

Whether public users can report issues anonymously.

Configuration for the public user landing page.

The time period used for displaying recent issues on the public user map.
Autonumbering rules for notices, citations, and inspections.

Default code reference groups for issues types.

Default time-based processing rules for issue types.

For more information about agency setup, see Setting Up Agencies.

To configure agency level options for code enforcement:

PUWUNA

6.

Select Common Setup > Agency.

Click a row on the Agency Information tab.
Select the Features tab.

Click Options for the Code Enforcement offering.

The Code Enforcement Options window opens.

Configure the setting in the Intake Form section.

Page Element Description

Contact Information Required Enable this switch to require contact information from users who submit issue reports.

If the switch is not enabled, then the page where users supply contact information
includes a Hide my contact information switch. When users hide their contact
information, name and contact information is no longer required, and any data currently
in those fields gets cleared.

Even if you don't require contact information, users must be registered and signed in to
report an issue.

Configure the settings in the Recent Cases section.

Public users can view a map with markers identifying recent issues. These settings define which issues appear
on the map.

57

ORACLE


http://www.oracle.com/pls/topic/lookup?ctx=pscr20b&id=task_SettingUpAgencies

Oracle Public Sector Compliance and Regulation Cloud Chapter 4

Implementing Community Development Setting Up Code Enforcement
Page Element Description
Period Choose how far back to look for issues by entering number of days or months, and then

selecting Days or Months. Issues that were created within the specified time period
appear on the map.

Status Select All to display all recent issues, regardless of status.

Select Active to display only issues that haven't been closed yet.

7. Configure the settings in the Inspection section:

Page Element Description
Autoassignment Indicate whether to enable automatic scheduling and assignment of incident and case
inspections.

Maximum Inspections per Day per Enter the maximum number of inspections per day for code officers. The
Code Officer autoassignment process will not assign inspections to officers who are at the maximum,
but users can manually exceed this maximum.

If you don’t enter a maximum, inspections will not be autoassigned.

8. Configure the settings in the Autonumber Rules section:

Page Element Description

Notice Autonumber Rule Select the autonumbering rule to increment numbers for notices.
Citation Autonumber Rule Select the autonumbering rule to increment numbers for citations.
Inspection Autonumber Rule Select the autonumbering rule to increment numbers for inspections.

f Note: For more information, see Setting Up Autonumbering.

9. Expand the Landing Page Message Definition section and enter these settings for the code enforcement
landing page:

58
ORACLE


http://www.oracle.com/pls/topic/lookup?ctx=pscr20b&id=task_SettingUpAutoNumbering

Oracle Public Sector Compliance and Regulation Cloud Chapter 4

Implementing Community Development Setting Up Code Enforcement
Page Element Description
Message Title Enter a short title or welcome statement for the code enforcement landing page. For

example, Welcome or <City Name> Code Enforcement.

This appears message appears as a title, in large text.

Message Summary Enter a subtitle for the code enforcement landing page. For example, Keeping our city
safe and healthy.

This text appears is medium-sized text under the larger main title for the page.

Content URL Enter a content URL for the Read More link that appears on the landing page next to
the Message Summary text. Public users click this link to access a code enforcement
information page that your agency maintains.

If you leave this field blank, the Read More link opens a dialog box that displays the
Landing Page Message.

Note:
f If you want to link to a page outside of Oracle Public Sector Code Enforcement,
you must enter a URL here.

Landing Page Message If you do not provide a Content URL that points to an agency-maintained information
page, enter the text that will appear in the Read More dialog box. Rich text formatting
tools are available for this message.

10. Expand the Code Reference Group section and define the default code reference groups for new issue types.

Enter the first code reference group in the blank row that appears. Use the Add button to add additional rows.
Each row has the following elements:

Page Element Description

Group ID Select a code reference group that will be added by default to all newly created issue
types.

Enabled Turn this switch on to have the code group added by default to newly created issue
types.

If the switch is off, the code group is not added to newly created issue types.

Delete Click to remove the row from the list of default code reference groups.
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Page Element Description

11. Expand the Time-Based Rules section and define the default time-based rules to be entered automatically into
newly created issue types.
This section displays rows for all of the due date types that require time rules. You can’t add or remove rows.
Instead, you must supply a time rule for each due date.
For more information about time rules, see Setting Up Time Rules.

Page Element Description

Due Date Type ID Displays the unique identifier for the type of due date.

Due Date Type Displays the description of the type of due date — for example, Incident review date
Time Rule ID Select the time rule ID that specifies how the due date is calculated. The time rule ID

includes a time policy that states how many days or hours until the due date.

Time rules IDs are available for selection if they have the specified due day type and
they are enabled.

12. Click Save, then close the window.

Setting Up Issue Types

Issue types are broad categories that are used to report code enforcement issues.

Adding an Issue Type

To create a new issue type:

1. Select Code Enforcement Setup > Issue Type.
2. Onthe Issue Type page, click Add.
3. Onthe Issue Type Details page, enter the following general information about the issue type:

Page Element Description

Issue Type ID Enter a unique alphanumeric code for the issue subtype. Do not use special characters,
including symbols or punctuation, or spaces.

Issue Type Enter a short name for the issue type.
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Page Element Description
Valid From Date Enter the first date that the issue type is available for issue reporting.
Valid To Date Enter the last date that the issue type is available for issue reporting. The default value is

Open, indicating that the issue type will remain available indefinitely.

Status Select Active or Inactive.

Inactive issue types are not available for issue reporting. They also are not available to
add to an issue subtype definition.

Icon Select an icon for the tile that public users click when reporting this type of issue .

Description Enter a description of the issue type. This description appears on the back of the tile
that users click when reporting this type of issue.

4. C(lick Save.

When the issue is saved, three additional sections appear: Issue Subtypes, Code Reference Group, and Time-
Based Rules.

You don't need to enter information in the Issue Subtypes section. The relationship between issue types and
issue subtypes is established when you set up the issue subtype. After you create the related subtypes, you can
return to the Issue Type Details page to view a complete list of subtypes for the issue type.

5. Configure the list in the Code Reference Group section.
a. Expand the section and review your agency’s default values, if any.

The default values come from the Code Enforcement Options page. For more information, see Setting Up
Agency-Level Options for Code Enforcement.

If your agency does not have default code reference groups, a blank row appears.

b. For each code reference group, review or enter the following settings:

Page Element Definition

Group ID Select a code reference group that will be added by default to all newly
created issue subtypes.

Enabled Turn this switch on to have the code reference group added by default to new
issue subtypes for this issue type.

If the switch is off, the code group is not added to new issue subtypes for this
issue type.
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c. To add additional code reference groups to this issue type, click the Add icon and enter information in the
new row.

d. Toremove code reference groups from the issue type, click the Delete icon.
6. Configure the list in the Time-Based Rules section:

This section displays rows for all of the due date types that require time rules. You can’t add or remove rows
from this list. Instead, you must supply a time rule for each due date.

For more information about time rules, see Setting Up Time Rules.
To set up time rules for the issue type:
a. Expand the section and review your agency’s default values.

These default values also come from the Code Enforcement Options page.
b. For each rule, review or enter the following settings:

Page Element Definition

Due Date Type ID Displays the unique identifier for the type of due date.

Due Date Type Displays the description of the type of due date — for example, Incident
review date.

Time Rule ID Select the time rule ID that specifies how the due date is calculated. The time

rule ID includes a time policy that states how many days or hours from the
trigger date until the due date.

Time rules IDs are available for selection if they have the specified due date
type and they are enabled.

7. Click Save again if you made any changes in the sections for code reference groups and time-based rules.

Viewing or Modifying an Issue Type

To view or modify an issue type:

1. Select Code Enforcement Setup > Issue Type.
2. Click the row for the issue type you want to view or modify.

The Issue Type Detail page appears. Because the issue type has already been saved, the page displays all fields,
including the sections for Issue Subtype Details, Code Reference Group, and Time-Based Rules.

3. Make any necessary updates.
4. C(lick Save if you made any updates.

Inactivating an Issue Type

You cannot delete issue types, but you can make them unavailable for use by changing the status to Inactive.
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To inactivate an issue type:

Setting Up Code Enforcement

1. Select Code Enforcement Setup > Issue Type.
2. Click the row for the issue type you want to modify.

The Issue Type Detail page appears.

3. Change the Status to Inactive.

4. Click Save.

Setting Up Issue Subtypes

Code enforcement issue subtypes are the lowest level of categorization for code enforcement issues. When you set up
an issue subtype, you also create the intake form and define processing rules for issues that are reported under this

subtype.

Adding an Issue Subtype

To create a new issue subtype:

1. Select Code Enforcement Setup > Issue Subtype.
2. Onthe Issue Subtype page, click Add.
3. Onthe Issue Subtype Details page, enter the following general information about the issue subtype:

Page Element

Issue Subtype ID

Issue Subtype

Issue Type ID

Status

ORACLE

Description

Enter a unique alphanumeric code for the issue subtype. Do not use special characters,
including symbols or punctuation, or spaces.

Enter a short name for the issue subtype.

Select the issue type that represents the broad category under which this issue subtype
falls.

Only active issue types are available for selection. If an issue type is later inactivated, the
issue type and all of its associated issue subtypes become unavailable to public users.
Select from the following to indicate the issue subtype status:

o Preliminary: The issue subtype is being defined but is not available for use.

o Ready: The issue subtype is enabled for immediate use.

Note:
?’ The issue subtype intake form must be published in the Intake Form Designer
before you can set the status to Ready.
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Page Element

Valid From Date

Valid To Date

Public User Enabled

Case Autonumber Rule

Incident Autonumber Rule

Fee Schedule

Notice Group ID

District Type

ORACLE
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Description

o Void: The issue subtype is no longer available.

Enter the first date that the issue subtype is available.

Enter the last date that the issue subtype is available. The default value is Open,
indicating that the issue subtype will remain available indefinitely.

Select from the following to indicate whether this issue subtype is enabled for public
users:

o Enabled for all users
o Enabled for registered users
o Not enabled for public users (default)

Initially, for a newly created issue subtype, this is always set to Not enabled for public
users. When you are ready to publish the new issue subtype, update this value.

For more information, see Publishing Intake Forms.

Select the autonumbering rule to increment numbers for cases based on this issue
subtype.

For information, see Setting Up Autonumbering.

Select the autonumbering rule to increment numbers for incidents based on this issue
subtype.

Select the fee schedule to use for citations based on this issue subtype.

For more information, see Creating Decision Models for Fees.

Select the notice group to use when generating notices for a case based on this issue
subtype.

For more information see Setting Up Notice Groups.

Select the code enforcement district type to be used for incidents with this issue
subtype.

For example, if issues with this subtype are handled by the fire department and

inspected based on fire prevention districts, then the district type might be your fire
prevention district type.
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Page Element Description
Icon Select an icon for the tile that public users click when reporting issues with this subtype.
Description Enter a description of the issue subtype. This description appears on the back of the tile

that users click when reporting issues with this subtype.

4. Click Save.

When the issue is saved, the Code Reference Group and Time-Based Rules sections appear, and the Design
Form button is activated.

5. Configure the list in the Code Reference Group section.
a. Expand the section and review the default values, if any.

The default values come from the associated issue type. For more information, see Setting Up Issue
Types.

If your agency does not have default code reference groups, a blank row appears.
b. For each code reference group, review or enter the following settings:

Page Element Definition

Group ID Select the code reference group with the code references to be included
by default in notices of violation that are based on this issue subtype. The
person who generates the notice can remove specific code references from
the notice.

Enabled Turn this switch on to make the code reference group available for issues with
this subtype.

c. To add additional code reference groups to this issue subtype, click the Add icon and enter information in
the new row.

d. Toremove code reference groups from the issue subtype, click the Delete icon.
6. Configure the list in the Time-Based Rules section.

This section displays rows for all of the due date types that are defined in the issue type. You can't add or
remove rows. Instead, you must supply a time rule for each due date.

For more information about time rules, see Setting Up Time Rules.
To set up time rules for the issue subtype:
a. Expand the section and review the default values.

The default values come from the issue type that you entered when creating the subtype. Changing the
issue type does not update these values.

b. For each rule, review or enter the following settings:
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Page Element Definition
Due Date Type ID Displays the unique identifier for the type of due date.
Due Date Type Displays the description of the type of due date — for example, Incident
review date.
Time Rule ID Select the time rule ID that specifies how the due date is calculated. The time
rule ID includes a time policy that states how many days or hours until the
due date.

7.
8.

9.

Time rules IDs are available for selection if they have the specified due day
type and they are enabled.

Click Save if you made any changes in the sections for code reference groups and time-based rules.
Create the issue intake form for this issue subtype.

o Note: Oracle provides a template for code enforcement intake forms. Even if you plan to use the
#  delivered form as-is, you still need to go through the process of creating the form based on the
delivered template.

a. Click the Design Form button.

b. Review the default issue intake form and add any user-defined fields to the drop zone on the Just a Few
More Questions page tab.

c. Save the form, and when you're done designing the form, publish it.

For detailed instructions on creating the issue intake form, see Using the Intake Form Designer for Code
Enforcement.
To make the issue subtype available to end users:

Return to the Issue Subtype Detail page.

Confirm that the Public User Enabled field is either Enabled for all users or Enabled for registered users.
Change the Status to Ready.

Click Save.

angoo

Modifying an Issue Subtype

To modify an issue subtype:

1.
2.

>

Select Code Enforcement Setup > Issue Subtype.
Click the row for the issue subtype you want to modify.

The Issue Subtype Detail page appears. Because the issue subtype has already been saved, the page displays all
fields, including the sections for Code Reference Group and Time-Based Rules.

Make any necessary updates to the issue subtype.
Click Save.
Use the Design Form button to access the form designer if you need to make changes to the intake form.
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Deactivating an Issue Subtype

You cannot delete issue subtypes, but you can mark them as void.

To deactivate an issue subtype:

1
2

3.
4.

Select Code Enforcement Setup > Issue Subtype.
Click the row for the issue subtype you want to modify.

The Issue Subtype Detail page appears.

Change the Status to Void.
Click Save.

Cloning Issue Subtypes

Note: When you clone an issue subtype, the intake form from the original subtype is not copied to the newly
created subtype. If you added user-defined fields to the standard code enforcement intake form, you will need
to recreate any necessary fields for the new subtype.

4

To clone an issue subtype:

POUNa

Select Code Enforcement Setup > Issue Subtype.

Click the row for the issue subtype you want to clone.

On the Issue Subtype Detail page, click the Clone button.

On the Clone Issue Subtype page, review or enter the following information:

Page Element

Original Issue Subtype and
Original Issue Subtype ID

New Issue Subtype and New Issue
Subtype ID

Clone Code Reference Groups

Clone Time-Based Rules

5. Click Create.

ORACLE

Description

These fields display identifying information about the issue subtype that you're cloning.

Enter a new identifier and short description for the issue subtype that you're creating.

When this switch is on, code reference groups in the original issue subtype are copied
over to the newly created issue subtype.

When this switch is off, the newly created issue subtype does not have any code
reference groups (not even the default ones from the issue type).

When this switch is on, time-based rules in the original issue subtype are copied over to
the newly created issue subtype.

When this switch is off, the newly created issue subtype does not have any time-based
rules. A single blank row appears, but there is no way to add additional rows. Therefore,
you should always leave this switch enabled.
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A new issue subtype is created. The information on the Issue Subtype Details page is identical to the cloned
subtype, except that the Status is always Preliminary.

6. Make any necessary modifications to the issue subtype and save.
7. Click the Design Form button.

f Note: The newly created clone does not include a copy of the original intake form. You must create
the intake form from scratch.

8. Design and publish the intake form.

9. Return to the Issue Subtype Detail page and make the subtype available to end users by updating the Status
and, if necessary, the Public User Enabled setting.
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Intake Form Designer Topics

Chapter 5
Creating Intake Forms

The following topics apply to using the Intake Form Designer to create and publish intake forms, which registered users
access online to initiate transactions, such submitting a permit application, reporting an issue, and so on.

Using the Intake Form Designer

Using the Intake Form Designer for Code Enforcement

Working with Sandboxes
Working with Pages
Working with Predefined Field Groups
Using Predefined Field Groups
Working with Group Boxes
Working with Fields
« Adding Rich Text Areas
- Defining Fields Displaying a List of Values
« Displaying Form Elements Conditionally
« Adding Logic
« Adding Contextual Help to Forms
« Setting Form Options
« Mapping Form Fields to Decision Model Attributes
Considering User Experience
Testing Intake Forms
« Publishing Intake Forms
Cloning Transaction Type Definitions

- Managing Transaction Type Configurations

Using the Intake Form Designer

This topic describes the purpose of the Intake Form Designer, lists the prerequisites that must be completed prior to

creating a form, and introduces you to the designer interface.

To initiate a transaction within Oracle Public Sector Community Development, an intake form needs to be submitted by
the citizen or registered user that captures the information required as prerequisites to initiating the process. Examples
of transactions include permit applications, planning and zoning applications, and so on. With Oracle Public Sector
Community Development, you use the Intake Form Designer to create application forms your citizens can access online,

fill out, submit, and monitor the transaction all through the cloud.
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Oracle does not deliver a predefined form for each type of transaction because for each form and for each municipality,
the information required will be unique. For example, for a fence permit, the City of San Diego may require only basic
information about the material to be used and the measurements. On the other hand, the City of Sacramento may
require the same information as San Diego, but also require the contact information of the contractor building the
fence, the exact location of the fence, the area enclosed by the fence, and so on. Each municipality has its own set of
requirements, and the Intake Form Designer enables you to tailor the forms to reflect your agency's requirements.

With the Intake Form Designer, you can create unique online application forms for each transaction your municipality
offers. The Intake Form Designer provides modular sets of common fields, called predefined field groups, which are
ready-to-use form elements you can use like building blocks to assemble the online application form. If a predefined
field group does not contain fields you require, you can add user-defined form elements (custom fields) to meet your
requirements.

Once you have created, configured, and tested your form, you can publish the form for end users to access, complete,
and submit for review and approval.

?’ Note: For simplicity in this documentation, the Intake Form Designer is often referred to as “the designer,”
and an intake form is often referred to as a “form.”

Completing Prerequisites

Before creating an online form, you need to:

- Create a transaction type.

For more information on creating a transaction type, see Setting Up Permit Types.

- Set up any fees associated with the form.

For more information on fees, see Setting Up Fee Itemsand Setting Up Fee Schedules.

Accessing the Designer

Before you can create an application form, you must first create a transaction type on the Transaction Type page.

From the Transaction Type Definition page, select the Design Form button.

Working with the Designer Interface

This example illustrates the interface of the designer when you begin creating an application form.

This example illustrates the Intake Form Designer interface. The controls in the image are described in the text
surrounding the image.
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Design Permit Application

Solar Infodev | Status: draft
Elements «
4 Ready to Use
4 Field Groups

Applicant
Application
Attachments
Business Information
Comment
Construction
Contact Details
Demolition
Electrical
Fee Summary
Fence
Grading
nsurance

License Qualification

Elements Panel

Page Element

Status

Manage Sandbox

Add Logic

Preview

Save
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escription

Select Applicant

First Name

Middle Name
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Add Logic Preview Save Publish

Application Options X Add Tab Form Options ¥
Page Attributes
pplication
Label *
Record ID NE Status Pendin
lecord 1D NEXT Status Pending Applicant
Submission Date Submitted By TN
de from publicuser k) )
ssue Date
Add Help

Control Display

Salutation | ‘

Suffix | ‘

Workspace Attributes Panel

Description

Indicates the status of the current design.

- Draft: the form is in sandbox mode, which means only the implementation team can access, view,
and change the form design.

« Published: the form is available for testing or end users on the landing page, depending on your
environment. In the development or testing environment, a published form is available for form
developers and testers to access and test. In the production environment, a published form is
available for end users to access.

For more information on form status, see Working with Sandboxes.

Click to access the Oracle Fusion Applications Sandboxes page where you can view the status of your
sandbox and refresh your sandbox if needed.

Note:
The Manage Sandbox button appears only if the sandbox associated with your form layout

? becomes out of sync, requiring a refresh. This is determined when you attempt to publish an
intake form.

For more information on sandboxes, see Working with Sandboxes.

Enables you to add programming logic scripts using the Groovy programming language.

For more information on Groovy, see Adding Logic.

Enables you to preview your form to test layout, design, and data entry.

For more information, see Testing Intake Forms.

Saves changes made to the form design.
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Page Element Description
Publish Publishes the completed form design so that it can be accessed from the landing page.

For more information, see Publishing Intake Forms.

Next Takes you to the Fee Mapping page.

For more information on mapping fees, see Mapping Form Fields to Decision Model Attributes.

Form Options Click to display the Form Options dialog box where you can set options that apply to the entire form.

For more information on form options, see Setting Form Options.

Elements panel Displays lists of all pre-defined field groups and user-defined elements you can add to your form
design. The Elements panel contains all of the items that you use to build an intake form.

The Ready to Use section contains:

- Field Groups: predefined sets of fields.

- Fields: user-defined fields you have created and set to be included in multiple intake forms
(reusable fields).

The Add New section contains:

- General: the list of all the field types for user-defined fields you add manually to intake forms.

« Layout: HTML constructs, such as group box containers, that you add to your intake forms.

For more information see, Working with Pages and Working with Fields.

Add Tab Adds additional pages to your form. You navigate between the pages by using the page tab for each
page.

For more information, see Working with Pages.

Workspace The area where you drag and drop form elements from the Elements panel and configure them. This is
the main area used for creating and configuring your forms.

Attributes panel Displays the available attributes that you can configure for the currently selected form element. For
example, if you have a field selected, the attributes panel reads "Field Attributes,” and it contains
attributes specific to fields. If you have a group box selected, the attributes panel reads "Group Box
Attributes,” and it contains attributes specific to group boxes.

Viewing the Tasks for Creating Forms

This section provides the core set of tasks to complete when creating an intake form. The remaining topics in this
chapter discuss the details of each task.

Step Link

Add page tabs. Working with Pages
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Step Link
Add predefined field groups. Working with Predefined Field Groups

Modify field attributes in predefined field Working with Fields

groups.
Add group boxes. Working with Group Boxes
Add user-defined fields. Working with Fields

Using the Intake Form Designer for Code Enforcement

This topic describes how to use the Intake Form Designer for the Code Enforcement offering.

Public users access an online form, fill out it out, and submit it to report issues. You use the Intake Form Designer to
create intake forms for Oracle Public Sector Community Development offerings, including Permits, Planing and Zoning,
and Code Enforcement.

Using the Intake Form Designer to create intake forms for the Code Enforcement offering is similar to creating intake
forms for the other Public Sector Compliance and Regulation offerings. However, in the case of Code Enforcement,
creating intake forms relies on a delivered template that has all the pages and fields already in place for a working

form right from the start. You can add user-defined fields to capture additional information if needed. This underlying
template both simplifies and streamlines the form design process, requiring you to create little, if anything, from scratch.

This topic describes the concepts and steps you'll need to understand to create intake forms specifically for the Code
Enforcement offering. For concepts that apply to all Oracle Public Sector Community Development offerings, you will be
linked to that common topic in the “Creating Intake Forms” chapter of this documentation set.

Prerequisites

Before creating an intake form for a Code Enforcement issue subtype, these items must exist:

Issue type

Issue subtype

For more information see Setting Up Issue Types and Setting Up Issue Subtypes.

Accessing the Intake Form Designer for Code Enforcement

An intake form for a Code Enforcement incident is associated with an issue subtype.
To access the Intake Form Designer, click Design Form from the Issue Subtype page.

For more information on creating issue subtypes, see Setting Up Issue Subtypes.
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Working with the Intake Form Designer

After you have created an issue subtype, you use the Intake Form Designer to create the form public users will access to
report issues to your agency.

This example illustrates the general user interface of the Intake Form Designer used to create issue intake forms for
Code Enforcement.

Design Code Enforcement Application Addlogic | Preview | Save | Pubiish
Neighborhood Issue | Status: publishe:
Elements <C Pprovide the location of the issue Tell us what is going on Just few more questions 2" Provide your contact information Form Options 77
P Ready to Use Field Attributes
4 Add New Priority Q ::‘ Remove

4 General

Label *
Check box set

Select your level of annoyance.

Date field

Date time field 4 How annoying is this issue? Default Drives me. ‘ v
Drop-down list alue
ti-select lis s (D))
e ‘, et Select your level of annoyance. Required )
Number field —
Radio button set Higden ( ;‘ J
Drives me crazy <
Rich textarea Manage List | Add Logic
Single-item check box
Switch Add Help
Text area
Text field
4 layout
Group box
Page Element Description
Status Indicates the status of the current design.

- draft: the form is in sandbox mode, which means only the implementation team can access, view,
and change the form design.

- published: the form is available for testing or end users on the landing page, depending on your
environment. In the development or testing environment, a published form is available for form
developers and testers to access and test. In the production environment, a published form is
available for public users to access.

For more information on form status, see Working with Sandboxes.

Manage Sandbox Click to access the Oracle Fusion Applications Sandboxes page where you can view the status of your
sandbox and refresh your sandbox if needed.

Note:

o The Manage Sandbox button appears only if the sandbox associated with your form layout
becomes out of sync, requiring a refresh. This is determined when you attempt to publish an
intake form.

For more information on sandboxes, see Working with Sandboxes.

Add Logic Enables you to add programming logic scripts using the Groovy programming language.

For more information on Groovy, see Adding Logic.

Preview Enables you to preview your form to test layout, design, and data entry.

For more information, see Testing Intake Forms.
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Page Element

Save

Publish

Form Options

Elements panel

Workspace

Attributes panel

Description

Saves changes made to the form design.

Publishes the completed form design so that it can be accessed from the landing page.

For more information, see Publishing Intake Forms.

Click to display the Form Options dialog box where you can set options that apply to the entire form.

For more information on form options, see Setting Form Options.

Displays the list of user-defined elements you can add to your form design, such as the fields you can
add to your form by dragging and dropping into the drop zone on selected pages.

Note:
The elements within the Ready to Use node are not intended to be added to your intake

f forms manually. They have already been added by way of the underlying template. For Code
Enforcement, the Ready to Use node is intended to be used by internal Oracle development
teams.

This is the main area displaying page tabs and drop zones used for configuring your forms.

Displays the available attributes that you can configure for the currently selected form element. For
example, if you have a field selected, the attributes panel reads "Field Attributes,” and it contains
attributes specific to fields. If you have a group box selected, the attributes panel reads "Group Box
Attributes,” and it contains attributes specific to group boxes.

Working with Page Tabs

Page tabs appear across the top of the work area.

This example illustrates the page tabs spanning the top of the work area in the Intake Form Designer.

Provide the location of the issue Tell us what is going on Just few more questions & Provide your contact information

Each page tab represents a separate page that the public user will access at runtime to provide the necessary
information when reporting an issue. The majority of the intake form for Code Enforcement is defined by the underlying
template, which you can’t modify. Because the page tabs are defined in the underlying template, you can’t add or
remove page tabs that appear in the default Code Enforcement intake form.

f Note: You can't add or remove page tabs from the default intake form template. You can only modify page
tabs containing a drop zone.

The page tab containing the pencil icon indicates where the drop zone resides. The drop zone is the area of the intake
form where you can add user-defined fields and group boxes to configure the intake form to include any additional

requirements for that issue subtype.
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For example, if you want to add a field to capture the length of the overgrown grass being reported, you can drag and
drop a Number field type into the drop zone.

The following table provides descriptions of the default page tabs provided by the template. The page tabs derived from

the template are:

Page Tab

Provide the Location of the Issue

Tell us what'’s going on

Just A Few More Questions

Provide Contact Information

Description

Used for specifying the location of an issue that’s being reported.

This tab includes a map with a crosshair marker for identifying a location. A search field enables user
to easily find a location and place it in the crosshairs. A separate text field captures additional location
information such as an apartment number or a description of where to find the issue at the given
address.

Used to describe the issue that’s being reported.

This tab includes a freeform text field for describing the issue. The tab also supports attachments so
that users can upload photos, videos, or other documentation.

Used to collect additional information about the issue that’s being reported.

In the delivered template, the only field on this page is a switch for indicating if the issue is a health
hazard or public safety risk. This tab also has a drop zone where you can your own fields for collecting
other information.

Used to collect the name and contact information for the person who is reporting the issue.

The template includes a switch for hiding the user’s information, but this switch is visible to the

end user only if the agency allows anonymous reporting. This option is configured on the Code
Enforcement Options page. See Setting Up Agency-Level Options for Code Enforcement.

Working with the Drop Zone

The drop zone is the area of the issue subtype intake form where you can add user-defined fields and group boxes. You
can locate drop zones by selecting the page tabs with the pencil icon.

This example illustrates the pencil icon on a page tab, which indicates which tab(s) a drop zone resides where you can

add custom fields.

Just a Few More Questions &'

?’ Note: The drop zone is the only area on the form that you can add and configure group boxes and fields.

You can drag and drop these form elements into a drop zone:

- user-defined fields

- group boxes

This example illustrates dragging and dropping a user-defined field type from the Elements panel into the drop zone.
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Elements « Provide the location of the issue Tell us what is going on

Just few more questions £ >
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Form Options

~

P Ready to Use
Priority j.}

4 Add New

A General

A

Check box set -.______________-.

Date field " Check br%ri_s‘e:
Date time field

Drag and drop form elements into the
group box.

Drop-down list

Multi-select list w

W

The drop zone itself is a group box into which you can drag user-defined fields and other group boxes if needed.

f Note: While the drop zone is technically a group box, you can’t modify its attributes or remove it from the

page.

Working with User-Defined Fields

You can drag and drop user-defined fields directly into the drop zone, or you can add group boxes to the drop zone and

drag and drop user-defined fields into the group boxes.

This example illustrates selecting a user-defined field in the drop zone which displays the attributes for that field in the

Field Attributes panel.

Design Code Enforcement Application

Trees | Status: published
Elements € Provide the location of the issue  Tell us what is going on Just few more questions £ Provide your centact information
» Ready to Use
4 Add New .. hY
y Priority D) )
( ; J
4 General
Check box set
Date field

Date time field
Select all the items that apply to this tree.

Drop-down list

Add Logic Preview Save Publish

Form Optiens %
Field Attributes
Remove

Label *

In danger of falling

Default

Mutki-select list | In danger of falling

Number field

ey

Radio button set Diseased or dying

Rich text area

Limbs have or are about to fall
Single-item check box

Switch Blocks traffic or sidewalk
Text area

Text field

P Layout

To add a user defined field to the drop zone:

Expand the Add New list.

Expand the General list.

Select the desired field type by clicking and holding.
4. Drag and drop the field type onto the drop zone.

WhN ==

To modify field attributes:

1. Select the field in the drop zone.
2. Use the Field Attributes panel to configure the field.
3. Click Save.

For more information on working with fields, see Working with Fields.
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Working with Group Boxes

You can use group boxes to organize user-defined fields you add to the drop zone. User-defined field can be added only
to the drop zone or to group boxes.

For more information on group boxes, see Working with Group Boxes.

Displaying Form Elements Conditionally

In some cases, you may want to display or hide certain elements in the drop zone only if the public user has made
specific selections on previous fields also in the drop zone.

Note: The fields that you want to display conditionally must be within a group box container, as well as the
# fields that control the display. You can display group boxes conditionally, but not a field on its own. You can’t
control the display of the drop zone. This feature applies only to elements contained within the drop zone.

For more information on conditional display, see Displaying Form Elements Conditionally.

Setting Form Options

Form options enable you to configure features that apply to the entire form. For example, for the Code Enforcement
issue intake form, you can control whether a review page displays to show the public user all their selections before
submitting.

For more information on form options, see Setting Form Options.

Working with Sandboxes

When developing intake forms, you design and modify the form layout within a sandbox. A sandbox is an Oracle Fusion
Applications technology that enables intake form developers to work on projects simultaneously, save, and test their
work without affecting other developers or testers in the environment.

For more information on sandboxes, see Working with Sandboxes.

Testing Intake Forms

After creating an issue intake form, you can test it by:
- Viewing it in preview mode
Publishing the form and accessing it from the landing page.

For more information on testing, see Testing Intake Forms.

Publishing Intake Forms

While you are actively designing or modifying an intake form, the intake form resides in draft mode in a development
sandbox. To make the intake form available on the landing page for a wider audience, such as testers or public users, the
intake form needs to be published

For more information on publishing forms, see Publishing Intake Forms.
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Cloning Transaction Type Definitions

You can clone issue subtype definitions and the associated intake form layout to:

- Avoid duplicating work while creating similar issue subtypes and intake forms.
- Create a new version of an existing issue subtype and intake form.
To clone an issue subtype and its associated intake form, click Clone on the Issue Subtype page.

For more information on cloning, see Cloning Transaction Type Definitions.

Managing Transaction Type Configurations

After developing your intake forms on your development and/or test environment, you need to migrate the setup data
and configuration data from the source development/test environment to the target production environment.

For more information on migrating setup data and configuration data from one environment to another, see Managing
Transaction Type Configurations.

Example: Adding User-Defined Fields to an Intake Form for an Issue
Subtype

While the default intake form based on the underlying template is ready to be used without any changes, this section
illustrates how you can add user-defined fields to the drop zone if you need to capture additional information.

This example creates an intake form for an issue subtype that enables public users to report an issue for an abandoned
vehicle. Assume that the code enforcement organization wants to capture all of the information in the default intake
form and also a user-defined field to indicate if there are multiple vehicles on the property.

To create an intake form for an issue subtype:
1. Ensure a valid issue and issue subtype exist.
You create issue types and issue subtypes separately.

For more information see Setting Up Issue Types and Setting Up Issue Subtypes.
2. While on the Issue Subtype page, make sure your issue subtype is saved and click Design Form.
3. Inthe Intake Form Designer, locate the page tab with the drop zone.

This example illustrates the pencil icon on a page tab, which indicates which tab(s) a drop zone resides where
you can add custom fields.

Just a Few More Questions 2

4. Expand the Add New list in the Elements panel.
5. Inthe General list, select Switch, and drag and drop it in the drop zone.

This example illustrates dragging and dropping a field type into the drop zone.
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6. Select the switch, and observe the attributes you can configure for that field in the Field Attributes panel on the
right.

7. Update the Label value.
For example Are there multiple abandoned vehicles on the property?

This example illustrates setting the label attribute.
»

Field Attributes
Remove
Label *
Are there multiple abandoned vehit

Default

Value —

Hidden
Add Help

8. C(Click Save.
Resuit:

This example illustrates a user-defined field added to the drop zone of an issue subtype form layout.

Provide the Location of the Issue Tell Us What is Going On Just a Few More Questions & > Form Options

Does this issue pose a health hazard or public safety risk?

Are there multiple abandoned vehicles on the property? |
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Working with Sandboxes

This topic provides an overview of the concept of sandboxes and how they are used within the Intake Form Designer,
and it describes sandbox usage and behavior.

Most modern development environments typically require several different individuals to work simultaneously on
application changes while sharing the same data model and configuration starting point. The Intake Form Designer
utilizes the Oracle Fusion Applications technology referred to as sandboxes to enable form developers to work on
projects simultaneously, and save and test their work without affecting other developers or testers in the environment.

The sandbox acts as the development and test mode of your application form. During sandbox mode, the form design
can be viewed only internally by application developers or business analysts. In sandbox mode you can create your
form, add required form elements, add Ul elements, and test your changes. When you have completed all of your
design, development, and test work, you can then publish the form so it can be accessed by end users.

Note: Creating and modifying transaction types and intake forms should be completed on your development
o environment or your test environment. After making changes, publishing, and testing transaction types and
#  intake forms on your development or test system, you would then migrate the new and modified definitions to
your production system. Refer to the Functional Setup Manager documentation for information on migrating
data from the test system to the production system, as well as Managing Transaction Type Configurations.

Types of Sandboxes

Oracle Fusion Applications provides these types of sandboxes:

- Classic sandboxes

- Unified sandboxes

Classic sandboxes are the default sandboxes that are enabled out-of-the-box and always stay enabled.

f Note: To create intake forms, the unified sandboxes feature must be enabled.

For Public Sector Compliance and Regulation offerings, unified sandboxes are an opt in feature that you enable in
Functional Setup Manager. It is required to have unified sandboxes on your development and/or test environment
(depending on the number of pods you have licensed). Do not enable unified sandboxes on your production
environment. Unified sandboxes are utilized during development and configuration work, which should not be taking
place on your production environment. If the unified sandboxes feature is enabled on your production environment,
it can lead to unexpected results, especially during the migration of data from a source environment to the target
production environment.

For more information on sandboxes, see https://docs.oracle.com/en/cloud/saas/applications-common/19c/oaext/
configuration-life-cycle.htmI#OAEXT1189604.

Starting a Sandbox Instance for a New Application Form

Before you can create an application form in Intake Form Designer, you must first create the transaction type. For
example, for the permit service, the transaction type is a permit. When you save a permit type, the application creates a
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sand box instance. From that point, the transaction type and the associated form design exist within the newly created
sandbox instance.
Each form your implementation team is currently developing exists within its own, separate sandbox instance.

Until you publish the form, the transaction type and the form design remain in the sandbox instance. When you publish
a transaction type, the system eliminates its sandbox instance, and the form is available to users outside the sandbox.

Starting a Sandbox Instance for a Published Intake Form

After an application form has been published, you can initiate sandbox instances to make any required changes
discovered after the initial publication.

To initiate a sandbox for a published form:

Open the transaction type for the form.
Select Design Form.

Begin making the desired changes.
Click Save.

PUWUNA

By clicking Save, the Intake Form Designer creates a new sandbox instance to store the current changes.

Viewing the Sandbox Status

You can determine if a form is in sandbox mode using the Status indicator located in the top left-hand corner of the
Intake Form Designer. The Status indicator appears when you are creating the form or previewing the form. The
sandbox status does not appear on the published version of the form.

Status Description
draft The form is in sandbox mode. All changes exist in the sandbox instance only.
published The form is not in sandbox mode. The form is available to the runtime environment, where you can

access the form from the landing page.

CAUTION: The draft status is not intended to be used for an extended period of time. It is a temporary

mode for For example, at the end of every day your development work on a particular form layout should be
A published. You can prevent the published form that you are still designing from appearing on the landing page

by keeping the Status value set to Preliminary and the Public User Enabled value set to Not enabled for public

users. You set these values on the Transaction Type page. If an upgrade occurs while a transaction type is in

draft mode, the sandbox will be deleted and all changes will be lost.

Refreshing a Sandbox

Each application form is assigned to its own sandbox. Because transaction types share underlying metadata resources,
if during the development of a transaction type or intake form some of the shared metadata resources get updated by
another member of the implementation team, each transaction type also using the shared metadata resources needs to
be synchronized with the most recent metadata updates.

To synchronize the metadata between permits, you need to refresh the sandbox for unpublished transaction types.
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You will know that your sandbox is not synchronized with the current metadata resources when you see this message
when you attempt to publish the transaction type:

The application was unable to publish the permit. Click the Manage Sandbox button to access the page where you can
refresh the sandbox.

To refresh a sandbox:

1. In Intake Form Designer, click Manage Sandbox.

This takes you to the Sandboxes page in Oracle Fusion Applications.
2. Onthe Sandboxes page locate the sandbox for your transaction type.

The sandbox naming convention is: <Transaction Type Code>__sb_<number of publications>.

For example, if for a permit, the Type Code value is REMODEL, and the sandbox has been published once
previously, the sandbox for that permit is named REMODEL__sb_1.

3. Click on the sandbox you need to refresh.
4. Onthe Sandbox Detail page review the messages related to the status of your sandbox.

You may notice the Current Status reads Refresh needed and the following note:

This sandbox is not synchronized with the mainline environment. You can refresh the sandbox before making
any further changes.

5. On the Sandbox Detail page, click Refresh.

6. Click Yes on the prompt indicating you are about to refresh your sandbox and that you can’t make changes to
the sandbox during the refresh.

This returns you to the Sandboxes page.
7. View the Status column on the Sandboxes page, which indicates your sandbox is refreshing.

8. Click on the sandbox again to access the Sandbox Detail page to confirm your sandbox Current Status is Up to
date.

You may need to review the merge log and accept changes manually if needed.
9. Once your sandbox is refreshed, close the Sandboxes page, and return to the designer.

Managing Labels for Application Form Elements

This topic describes how to manage changes made to labels for delivered and user-defined intake form elements.

When making changes to the labels for elements within your application form, you need to consider what type of
element it is. Changing the label of some elements is a global change, while changing the label of other elements is a
local change.

- Global: A global label change means that a change to the label affects every intake form definition using that
field or element.

Local: A local label change means that a change to the label affects only the current intake form definition
where the field or element appears.

When you select a form element or field and a label change would have global effects, a warning icon appears above the
Label field in the attributes panel.
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When selecting an item in the workspace, if changing the label for that item has global effect on all application forms
using the item, the system displays a warning icon.

— - - T

Changing this label affects all application forms
using this field. It is a global change Field Attributes

Label *
s

Demolition Reason

Note: If you change the label of a field after a form has been published and used in the production system,
#  keepin mind this can affect reporting and the storage of historical data. You may have multiple labels
representing the same data.

Form Element Scope of Label Change Label Change Considerations

Predefined Field Group Global The label of a predefined field group is the
heading used to describe the grouping of the
fields it contains.

Changing the label of a predefined field group
is a global change.

For example, if you change the label in the
Applicant predefined element used in the fence
permit intake form, that change will be reflected
in the Applicant predefined element used in

the electrical permit intake form (and any other
application form using the Applicant predefined
field group).

Predefined Field Group: Parent Field Local Some fields appearing in predefined form
elements are part of the parent record within
the data structure storing the transaction data.

You know a field in a predefined field group is
part of the parent record when the warning icon
does not appear above the Label field in the
attrbributes panel.

For example, the Description field in the
Application predefined field group does not
display the warning icon. Changing this label
affects only the current intake form definition. It
is a local change.

Predefined Field Group: Child Field Global Some fields appearing in predefined field
groups are part of a child record within the data
structure storing the transaction data.

You know a field in a predefined field group is
part of a child record when the warning icon
appears next to the Label field in the attributes
panel.
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User-Defined Fields Local
HTML Constructs Local

Chapter 5
Creating Intake Forms

Label Change Considerations

For example, the Demolition Reason field in
the Demolition predefined field group displays
the warning icon. Changing this label affects
all intake form definitions using the Demolition
predefined element. It is a global change.

You can change the labels for the fields that
you add to your application forms, such as text
fields, number fields, drop-down lists, and so
on. Because you add these fields manually

to your application form, you can change the
default labels as needed to suit your business
requirements.

The scope of any changes to the label for user-
defined fields apply only to the current intake
form.

A general HTML construct refers to elements
such as group boxes and page tabs.

You can change the labels for general HTML
constructs as needed to suit your business
requirements. The scope of the construct and
any changes to the label apply only to the
current intake form definition.

For example, changing the label of the default
label for HTML constructs such as Group box
or Field O to your desired label affects only the
current intake form definition.

Note:
If you change a label for a page tab
or a group box used in an application
o form after the form has been

? published and used in the production
system, make sure to update any
instructions or documentation that
may reference the previous label.

Note: For HTML constructs, such as pages and group boxes, and for user-defined fields the labels display
using the language used to create or modify the application form layout. There is no automatic translation of
f these elements. For example, if you created the intake form in English, but then signed in using Korean for
testing, you will see the English labels for those constructs, unless you have provided translated values using
the Fusion Applications User Interface Text tool. For more information on the User Interface Text tool, see:

Considerations for Selecting a Tool to Change Text.

ORACLE

85


http://www.oracle.com/pls/topic/lookup?ctx=en/cloud/saas/applications-common/20b&id=OAEXT1162338

Oracle Public Sector Compliance and Regulation Cloud Chapter 5
Implementing Community Development Creating Intake Forms

Working with Pages

This topic describes how to add page tabs to your intake form and how to modify page attributes.

An intake form can include one or more page tabs to contain the field groups and fields that you want to add to your
form.

Adding Pages
When you create an intake form, by default, the application includes one page tab for your form. To add additional page
tabs to your intake form, click the Add Tab button at the top of the workspace.

Setting Page Attributes

Page Element Description

Label The name of the page that appears on the page tab. The default name is Page 1, Page 2, and so on.
Change the name to your desired label, and tab out of the field.

Hide from public user Hides the page tab and all the elements on the page from the public user at runtime. Only agency staff
can view and update information for a page with Hide from public user turned on.

In addition to hiding the Ul element from the public user in the interface, the application also secures
the back end for that specific Ul element, such as preventing any unauthorized access to the fields
within the Ul element using a REST API, for example.

Note:
?’ An application intake form must have at least one page that is viewable to the public user.
That is, Hide from public user must not be enabled for at least one page tab in the form.

Add Help Click to launch the Contextual Help page, which you can use to add help information to aid end users in
completing the application form.

Page-level help should provide information pertaining to the overall page content. If the information
applies to a specific Ul element on the page, such as a component, group box, or field, consider adding
help directly to that Ul element.

For more information on adding contextual help, see Adding Contextual Help to Forms.
Control Display Determine if the page displays or is hidden based on the value of a previous element in the form, such

as a single-item check box or a switch. For more information on controlling page display, see Displaying
Form Elements Conditionally.

Deleting Pages

If you delete a page from your form, keep in mind that any Ul elements you have added to the page, such as predefined
form elements, group boxes, and fields will also be removed from your form.
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To delete a page from your form:

1. Click the Remove button on the tab.
2. On the Confirm dialog box, click OK.
3. Save your changes.

Working with Predefined Field Groups

This topic provides an overview of predefined field groups and how you use them to build your application forms.

Oracle provides a set of predefined field groups to help you build application forms easily. Each predefined field group
contains a collection of fields commonly used to capture information for a particular facet of the transaction type. For
example, the Applicant field group captures information about the person applying for a permit, and the Electrical field
group captures information about the scope of electrical work for a project. Using predefined field groups, you can
assemble simple online application forms in a matter of minutes.

Predefined field groups are:

Pre-mapped to attributes in the application view object (VO), which ultimately are mapped to fields in the SQL
tables in the application database.

- Grouped logically to provide descriptive metadata for a particular element of an intake form, such as Applicant,
Electrical Equipment, Pool Information, and so on.

You drag the desired predefined field group from the Elements panel onto the workspace. You use various combinations
of predefined and user-defined form elements to assemble your application forms.

For example, assume that you need to create a form for citizens to apply for a roofing permit. In this case, you can drag
the Applicant element and the Re-roof Information element onto the workspace to build your form.

Page Section Example Page Section Fields
Applicant Name

Address

Phone
Re-roof Information Roof Size

Roof Type

Roof Material

Pitch

For more information on the delivered predefined field groups, see Using Predefined Field Groups.
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Adding Predefined Field Groups

To add a predefined field group to your form:

1. Make sure the page to which you want to add the predefined field group is the active page.
2. Expand the Ready to Use list in the Elements panel to the left of the workspace.
3. Click on the desired field group to activate it.

4. Select the field group to drag and drop it in the workspace.

This example illustrates dragging and dropping a field group onto the workspace.

Design Permit Application

Solar Infodev | Status: draft

Elements < ppplicant X Application Options X | Construction Details X Add Tab

4 Ready to Use
A Field Groups
Applicant
Application
Attachments

Business Information

Comment / structic %}

Contact Details

Demolition Drag and drop form elements into the workspace.

Electrical

?s Note: Intake Form Designer places the predefined field groups in the workspace in the same order in which
they are dropped, in sequence, from top to bottom.

Note: The Applicant predefined field group is required to be added to your application forms. The internal
save logic checks for a valid applicant address when an end user attempts to save or submit an application

f form. It is recommended to include also the Application Information predefined field group, which displays
useful information, including the transaction ID, status, description, important dates related to the application,
and so on. If the transaction type requires fees, then the Fee Summary predefined field group should also be
added to your application form.

Note: When adding the Terms of Use predefined field group, it is recommended to add the field group to a

f page tab that also includes at least one other form element. Otherwise, the page may appear blank to agency
staff when accessed at runtime because the Terms of Use field group is displayed only to public users, not to
agency staff.

Deleting Predefined Field Groups from a Form
To delete a predefined field group, click the Remove button in the Attributes panel.
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Setting Predefined Field Group Attributes

Select the field group to view its attributes in the Attributes pane. To select the field group, click around the border or
within empty space within the field group. If you click near a field, the field will become selected.

Page Element

Remove

Label

Show Label

Hide From Public User

ORACLE

Description

Click to remove the field group from the page.

The name of the predefined field group that describes the set of fields in the field group. For example,
the fields in the Photovoltaic field group apply to solar projects. Modify the label to suit your
requirements. For example, you may want to change the delivered field group named Photovoltaic to
Solar.

Note:
Changing the label for predefined field groups is a global change, affecting other intake forms
o using the field group. After changing the label, note that the label of the field group in the left
f panel’s field group list is updated to reflect your custom label. The change you make will be
available globally only after you publish the current intake form. Make sure future intake form
developers on your implementation team are aware of the change to avoid confusion.

Control whether to show the label. By default, the system shows labels for predefined field groups
(Show Label is on).

To hide the label, turn off Show Label. When turned off, the system hides the label at both design-time
and runtime.

Typically, you'd want the label to be visible to describe the logical grouping of the fields in the form
element.

In some cases, the page tab name and the predefined field group label might be redundant, in which
case you may opt to hide the label.

You may also want to group multiple predefined field groups within a single group box. In this case, you
can hide the individual predefined field group labels within the group box container, using the group
box label to represent the combined set of fields.

Note:
?’ When you turn off Show Label, the system disables the collapsible feature for a predefined
field group.

Note:
j If the predefined field group is delivered without a label, the Show Label attribute does not
appear when you select that form element.

Hides the predefined field group and all the fields and controls it contains from the public user at
runtime. Only agency staff can view and update information for a predefined field group with Hide
From Public User turned on.

In addition to hiding the Ul element from the public user in the interface, the application also secures

the back end for that specific Ul element, such as preventing any unauthorized access to fields
contained within the Ul element using a REST API, for example.
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Page Element Description
Add Help Click to launch the Contextual Help dialog box, which you can use to add help text to a predefined field

group for assisting users with interacting with your intake form. When adding help for a predefined
field group, the help text should apply to the overall contents of the predefined field group. You can
add help also at the page level and the field level, depending on the scope of the help text.

For more information on adding contextual help to your intake form, see Adding Contextual Help to
Forms.

Control Display Click to define other elements in the form to control wether the field group displays.

For more information on controlling the display of form elements, see Displaying Form Elements
Conditionally.

Adding a Predefined Field Group Multiple Times to the Same Form

The same predefined field group can be dragged into your form multiple times. This is referred to as a multiple-instance
element. How you adjust the Multi-Instance Options attribute determines how the application stores the data for that
predefined field group.

f Note: The Multi-Instance Options attribute appears only for the Comments and the Attachments field groups.

If you make no changes to the Multi-Instance Options attribute, the data entered within that predefined field group
corresponds to one row of data only. In this case, the system duplicates the display of the data in each area of the form
it is displayed. This option enables you to show the same data on a different tab within the form, if necessary. Updating
the data in one instance of the predefined field group updates the data displayed in the other instances as well.

For example, assume you want the same comment text to appear on multiple pages in your form. You can do this by
adding the Comments element to the desired pages without making any updates to the Value field in the Multi-Instance
Options attribute.

If you make changes to the Multi-Instance Options attribute, the application considers each instance of the predefined
field group unique, and then each individual occurrence of the predefined field group is associated with its own row of
data.

For example, assume you wanted to incorporate multiple comment sections in your form. In this case, you can add the
Comments element to multiple locations of your form, and then you set the Multi-Instance Options attribute to different
values. One might relate to fencing comments while another might relate to contractor comments. Another example
would be to enable the end user to upload multiple attachments that apply to separate documents. One attachment
might be photos of a property while another attachment might be blueprint or design documents.

Using the Keyboard to Drag and Drop Elements

You can use keyboard hot keys to drag and drop elements.

Key Description

Enter Use to:
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Key Description
- Expand or collapse the Ready to Use or Add New element lists.

- Drop a selected element onto the selected drop zone

Tab Use the tab key to select either the first element in the list or the last selected item in the list if a
previous visit was made to the list.

Up and Down Arrows Use to:
- Select an item in the Ready to Use or Add New element lists.

- Select a location from the drop zone list. The selected drop zone is highlighted.

Space When an element is selected, the space key highlights the selected element and displays available drop
zones for the current page on the Select a Drop Zone dialog box. The drop zones can be the page or
group boxes contained by the page. For user-defined fields, the drop zones are group boxes.

Using Predefined Field Groups

This topic lists and describes the set of predefined field groups delivered to help you build forms quickly and
consistently.

Predefined field groups are prebuilt user interface modules that you can use as building blocks for assembling forms.
Field groups provide a set of fields and functionality to capture information for various sections of an application form.

Common Predefined Field Groups

Field Group Description

Applicant Identification and contact information for the citizen filling out the form, including name, address,
phone, and email.

Application Displays information about the form itself, such as status, relevant dates, and descriptions.
Attachments Enables you to attach and download files, such as documents or images. You determine document

properties displayed in the list of attachments and during upload.

Contains multiple instance options to create unique instances of the attachment field group.

Comment Enables you to enter additional comments or descriptions pertaining to information on the form.

Contains multiple instance options to create unique instances of the comments field group.

Contact Details Enables you to add information for individuals or organizations that are contacts for an application.

When users enter contact information in an application, they can create new contacts or choose
existing profile contacts. When creating a new application contact, the user can indicate whether the
new contact should also be added as a profile contact. When choosing an existing profile contact, the
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Field Group

Demolition

Fee Summary

Property

Site and Zoning

Terms of Use

ORACLE

Description

user can modify contact details and indicate whether the original profile contact record should be
updated as well.

If demolition is required as part of the job, this field group captures information related to the scope
of the demolition and if hazardous materials or utilities need to be considered, such as electricity, gas,
water, and so on.

Lists the items selected, the cost for each item, and the total amount to be paid when submitting the
form.

Note:
?’ This does not include additional inspection or other fees which may be assessed at a later
time.

Describes the parcel as it is registered with the municipality, such as the parcel ID, parcel type, and so
on.

Describes features of the property related to acreage, flood preparedness, as well as zoning and land
usage information.

Provides access to the terms and conditions regulating the usage of the online form, and provides a
way for the user to accept the terms. This field group does not identify which Terms of Use definition
to use, so if you add this field group to an application intake form, you need to also add a Terms of Use
definition on the Permit Type or Planning Application Type page.

The Display Mode property has these options:

- Link: the form displays a Terms and Conditions link that the user clicks to open a window with
the full terms and the check box for accepting the terms.

- Embedded: the full text of the terms appears directly on the form.
If the display mode is Link, these two additional properties are available:

- Help Text: Enter informational text that appears on the form along with the Terms and
Conditions link.

- Display Label: Enable this option to display the description of the Terms of Use definition on the
form along with the Terms and Conditions link.

Note:
?’ This field group is not used to set up public user registration terms and conditions. The Public
User Setup page includes all registration-related configuration.

Note:

When adding the Terms of Use predefined field group to an intake form, it is recommended
?’ to add the field group to a page tab that also includes at least one other form element.

Otherwise, the page may appear blank to agency staff when accessed at runtime because the

Terms of Use field group is displayed only to public users, not to agency staff.
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Attachments Field Group

You can configure the attachments field group and add it into your form multiple times. Attachments provide
supporting documentation needed by agency staff when processing a transaction.

Configurable Features

Component Attributes

Component Multi-Instance Options

Attachment Columns:

Business Columns:

- DocumentCategory

- DocumentSubcategory

Description

You can name the attachments component title in the Label field.

Use these multiple instance options to create unique instances of the attachment field group:

- ID

- Value

For more information about multiple instance options, see Working with Predefined Field Groups.

You can configure these attachment properties in the attachments list:

- File Name: Display the file name of the uploaded file.

- Description: Display the user-entered description.

- File Size: Display the size of the uploaded file.
Agency-defined document categories and document subcategories enable you to organize the
various types of attachments. You can configure these fields for document categories and document
subcategories:

- Label: Change the field name.

- Show in List: Display the field in the attachments grid.

- Show in Detail: Display the field in the attachment detail information.

- Show in Upload: Display the field on the modal page for uploading an attachment.

- Searchable: Enable search on the document category or document subcategory field.

- Sortable: Enable sorting for the document category or document subcategory field.

Predefined Permit Field Groups

Field Group

Business Information

Construction Information

Electrical Equipment

Fence Information

ORACLE

Description

Captures information to help describe the business, such as name, description, number of employees,
industry, and so on.

Captures information regarding the current construction site and the proposed construction project.

Describes a structures electrical features, such as outlet types, amps, voltage, and electric appliances.

Describes the proposed fence attributes, such as type, material, dimensions, location, and so on.
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Field Group

Grading Information

Insurance

License Qualification

Mechanical Equipment

Photovoltaic Information

Plumbing Equipment

Pool Information

Regulated Business Activity

Right of Way Use

Roof Information

Signage

Special Event

Water Heater

Yard Sale

Description

Describes the scope of grading work, such as the acreage affected, materials to be used and the
amount of material.

Provides a contractor’s insurance type and policy information.

Enables a contractor to add any state licences they have.

Describes features of the job site related to ventilation, heating, cooling, fire safety, and so on.

Describes attributes of a site’s solar energy configuration, such as roof area, coverage area, inverter
information, and so on.

Describes attributes of a site’s plumbing configuration.

Describes attributes of a pool, such as type, depth, location, surrounding fencing, and so on.

Enables you to specify any regulated activity or controlled substances allowed on the premises, such as
alcohol, carnival rides, casino games, and so on.

Enables you to provide any details related to the use of a right-of-way on the property or to gain access
to the property, such as traffic, parking, or pedestrian impact.

Describes features of a structure’s roof, such as existing roof type, proposed roof type, number of
layers, and so on.

Describes features of signage, such as the sign’s dimensions, use, whether permanent or temporary,
and illumination.

Enables you to specify information about an event, including the safety plan, concessions, facilities,
potential impacts, and traffic plans.

Describes features of water heaters, such as quantity of new or replaced, type, fuel type, and tank
capacity.

Enables you to specify yard sale information, such as the start time, end time, and the number of days.

Predefined Planning and Zoning Field Groups

Field Groups

Dwellings

ORACLE

Description

Describes features of housing such as number of units, floor area information, density bonus, rent-
controlled units, and so on.
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Field Groups Description
Impervious Surface Describes features of areas covered by impervious materials, such as concrete or asphalt, including

exemptions from certain requirements, existing and proposed impervious surface areas, and the
property lot area.

Planning Describes features included in planning and zoning, such as proposed number of units, change to the
number of units, assessed value of the current building, development type, commercial building area,
existing land use, lot areas, setbacks, and so on.

Working with Group Boxes

This topic describes how to add group boxes to your form and discusses group box layout options and attributes.

Use group boxes as containers to indicate the items contained within a group box are grouped logically. Once you add a
group box to a page, you can drag these items into the group box:

- Predefined field groups
- User-defined fields

« Other group boxes (nested group boxes)

Adding Group Boxes

To add a group box:

Open the Add New list in the Elements panel.
Open the Layout list.

Click and hold on the Group box option.

Drag and drop the group box into the workspace.

P WNa

Deleting Group Boxes

To delete a group box, click the Remove button in the Attributes panel.

f Note: If you remove a group box from a page, the system removes all of the contents of that group box also.

Setting Group Box Attributes

Select a group box to view the Group Box Attributes panel.

This example illustrates the attributes for a group box. Details are provided in the surrounding text.
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Hide from public user

Add Help

Control Display

Page Element

Remove

Label

Collapsible

Flexible Box Layout

ORACLE
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Description

Click to remove the group box from the page.

Add a name for the group box, describing the collection of items within it.

Turn on to enable the group box to be collapsed when an end user clicks it, hiding items it contains. If
not turned on, the group box is always expanded and its items are always visible.

Use the Flexible Box Layout attribute to establish a group box container based on the CSS flexible box
layout model. In the flexible box layout model, the items contained within the parent container assume
a layout position automatically, based on space in the container. As the available unused space grows
or shrinks, the items in the container grow to fill the unused space or shrink to avoid overflowing the
parent.

With Flexible Box Layout enabled, the system displays as many controls within the group box in one
line until all of the space is utilized, then the system wraps the row, beginning a new line.

When disabled, the controls within the group box display as stacked items, with each additional control
displaying directly beneath the previous control.
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Page Element

Show Label

Hide Border

Hide from public user

Add Help

Control Display

Description

Select to hide the group box label (specified in the Label field).

Note:
¢ Youcan add help only to group boxes with Show Label turned on. If Show Label is turned off,
f the Add Help button does not appear on the attributes panel and any help icons associated
with any previously added help no longer appear.

Hides the group box border. When turned on, the border is not visible.

Hides the group box and all the elements in the group box container from the public user at runtime.
Only agency staff can view and update information within a group box with Hide from public user
turned on. In addition to hiding the Ul element from the public user in the interface, the application
also secures the back end for that specific Ul element, such as preventing any unauthorized access to
the fields contained within that Ul element using a REST API, for example.

Click to launch the Contextual Help page, which you can use to add help information to aid citizens in
completing the intake form. The Add Help button appears only if Show Label is turned on. Help text
added for group boxes should apply to the overall group box content. Help can be added also at the
page level, field group level, and field level depending on the scope of the help text.

For more information on adding Contextual Help, see Adding Contextual Help to Forms.

Click to select an element in the form that controls the display of the group box.

For more information, see Displaying Form Elements Conditionally.

Example: Nesting Group Boxes

Nested group boxes can be used to represent subcategories of information and to enhance layout options, such as

creating columns for form elements.

The following example illustrates nested group boxes, which you achieve by dropping group boxes within group boxes.

This example illustrates an outer group box container with two inner group boxes nested within to logically divide page

content.

ORACLE
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4 Group Box - Level 1 X
4 Nested Group Box - Level 2 %
Field A »
Field B X
4 Nested Group Box - Level 2 .
Field C »
Field D x

Note: The system does not impose a limit to the depth of nested group boxes you can insert. For more

f complicated pages, for example, you may find that group boxes could be nested to 4-5 levels deep. Make sure
to consider how a page with multiple levels of nested group boxes will render on all the devices you intend to
support for your user base.

Example: Using Group Boxes to Combine Predefined Elements

In some cases you may want to give the appearance of multiple field groups being combined. You can do this using
a group box to act as the outer container for the set of field groups. When using a group box to contain field groups,
consider the following items:

- The collapsible attribute of the group box container controls the visibility of the contained field groups. If the
group box container is set to be collapsible, when the user collapses that group box, all of the elements within
that group box will be hidden.

If you want the field groups within the group box to be categorized under just the label of the group box, turn
off the Show Label attribute of the contained field groups.

In the following example, assume you want to combine the Fence Information and Comment field groups, giving the
appearance that Fence Information field group also contains a Comment field.

To combine field groups within a group box container:

Open the Add New list in the Elements panel.

Open the Layout list.

Drag and drop a Group box into the workspace.

Select the group box and make these changes on the Group Box Attributes panel:

P UWNa
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Group Box Attribute Sample Value
Label Fence Information
Flexible Box Layout Off

5. Open the Ready to Use list.
6. Open the Field Groups list.
7. Drag and drop the Fence field group into the group box
8. Select the Fence field group, and turn off Show Label on the Attributes panel.
9. Drag and drop the Comment field group into the group box.
4 Fence Information *
. ! X
Type of Work Front Fence Height
Type of Use Rear Fence Height
Pool Enclosure Left Fence Height
Fence Type Right Fence Height
Other Fence Type Location
Foundation Type Corner Lot
Automatic Closing Material
Gate
Other Material
Lock
~ X
_omment
Comment

10. Select the Comment field group, and turn off Show Label on the Attributes panel.
11. Save your changes.

At runtime, the example steps above produce a single, collapsible section in the form that includes both the Fence
Information and the Comment predefined elements.

This example illustrates the collapsed Fence Information group box.

» Fence Information

This example illustrates the expanded Fence Information group box containing multiple field groups.
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4 Fence Information

Type of Work Front Fence Height
Type of Use Rear Fence Height
Pool Enclosure Left Fence Height
Fence Type Right Fence Height
Other Fence Type Location
Foundation Type Corner Lot
Automatic Closing Material
Gate
Other Material
Lock
Comment

Example: Using Group Boxes to Combine Field Groups and User-Defined
Fields

Similar to combining field groups within a single group box container, you can also combine field groups and user-
defined fields within a single group box container creating the appearance of user-defined fields being part of a
delivered field group.

In the following example, assume you need to associate a field with the Fence Information element to capture the color
of a proposed fence.

To combine predefined elements and user-defined elements with group boxes:

P UWN

©Now

Open the Add New list in the Elements panel.

Open the Layout list.

Drag and drop a group box into the workspace.

Select the group box and make these changes on the Group Box Attributes panel:

Group Box Attribute Sample Value
Label Fence Information
Flexible Box Layout Off

From the Ready to Use > Field Groups, drag and drop the Fence field group into the group box.
Select the Fence field group, and turn off Show Label on the Attributes panel.

From the Add New > General, drag and drop a text field into the Fence Information group box.
Select the text field, and enter Color for the Label in the Field Attributes panel.
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4 Fence Information

Type of Work
Type of Use

Pool Enclosure
Fence Type

Other Fence Type
Foundation Type

Automatic

Closing Gate

Lock

Front Fence
Height

Rear Fence Height
Left Fence Height

Right Fence
Height

Location

Corner Lot

Material

Other Material

Color

9. Save your changes.

The following example illustrates how at runtime, the group box containing the field group and the user-defined field

create the appearance of the manually created field being part of the delivered field group.

4 Fence Information

Type of Work
Type of Use

Poal Enclosure
Fence Type
Other Fence Type
Foundation Type

Automatic Closing
Gate

Lock

Color

Front Fence Height
Rear Fence Height
Left Fence Height
Right Fence Height
Location

Corner Lot
Material

Other Material

ORACLE
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Working with Fields

This topic describes how to modify field attributes and add user-defined fields to your intake forms.

When end users are completing an application for a transaction, such as a permit, they enter the required information in
fields. Fields can be added to intake forms by:

- Adding predefined field groups to your form. Each field group is delivered with a set of fields.

- Adding user-defined elements (fields) to your form.

f Note: The user-defined fields that you create cannot be used (shared) across multiple intake form layouts.

Setting Field Attributes

Select a field to view the Field Attributes panel. Fields in predefined field groups and user-defined fields typically have
the same set of attributes. Not all attributes apply to each field type.

The type of field you select determines the attributes appearing in the Field Attributes panel. For example, for a number
field, you can set a default value and a placeholder value, but for a single-item check box, neither of these attributes
apply and therefore do not appear.

This example illustrates how the Field Attributes panel may look after selecting a field, depending on the field type.
Field Attributes
Remove

Label *

Materials Viendor

Placeholder

Default

Value

Rizzo's Lumber

Add Help
The following table describes the field attributes you can set.

f Note: Not all attributes apply to every field type. Only the attributes that apply to the currently selected field
appear.
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Page Element

Remove

Label

Placeholder

Default Value

Reusable

Required

ORACLE

Description

Click to remove the selected field from the layout.
The Remove button appears only for user-defined fields you added manually. You can’t remove fields

from a delivered field group.

Add a custom label to the field.

Note:
In the case of a custom field, the system forces the Map Field value to match the Label value,
® but removes any spaces. The map field represents how the field appears in the underlying
? data model. For example, a custom field with the label Additional Requests, will have a Map

Field value of AdditionalRequests.

Add descriptive text to provide hints for entering data. For example, the placeholder text could read:
Enter date in this format” MM/DD/VYY.

The placeholder value does not get saved at runtime.

Enter a default value required for the field.
The default value gets saved at runtime if the user does not change it.
The control you use to set the default value is consistent with the field type you added to the intake

form. For example, for the date field you use a date picker control, for a switch field you use a switch,
and so on.

Note:

In cases where both the Placeholder and Default Value attributes appear for a field type and
?’ you have provided values for both, the default value supersedes the placeholder value. That

is, at runtime, users sees the default value, not the placeholder value, but if they delete the

default value, the placeholder value appears to help users enter a valid value.

Enable if you want to reuse a user-defined field on other intake forms. When you save the intake form,
fields that are set to be reusable appear within the Ready to Use > Fields section in the Elements panel.

Note:
A reusable field can’t be set to be required or hidden.

For more information, see the “Reusing Fields” section below.

Enable if this is a required field for which a user must enter a value.

o Note:
? A required field can’t be hidden or reusable.
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Page Element Description

Note:

You can't delete a field that has been set to be required. You must first turn off the Required
attribute, save the form layout, and then delete the field. Deleting a required field from an
intake form that has already been published may affect forms submitted previously.

Hidden Hides the field from the user. If a predefined element contains fields that you do not need, select this
option so the user does not have access to the field.

o Note:
&  Ahidden field can't be required or reusable.

Manage List Add values for fields containing a list of values, such as check boxes, lists, and so on.
For more information, see Defining Fields Displaying a List of Values.

Add Help Click to launch the Contextual Help page, which you can use to add help information to aid citizens in
completing the intake form. Help text added at the field level should apply specifically to that field. You
can also add help to predefined elements, group boxes, and pages, depending on the scope of the help

text.

For more information on adding Contextual Help, see Adding Contextual Help to Forms.

Add Logic Click to add scripting logic using the Groovy programming language.

Note:
?’ For user-defined fields that you have added to your intake form manually, the Add Logic
button appears only after you have saved your form.

For more information on adding logic to your forms, see Adding Logic.

Edit Click to display the Rich Text Editor dialog box for entering formatted text to the application form.
Appears only for rich text areas.

For more information on rich text areas, see Adding Rich Text Areas.

Adding User-Defined Fields

f Note: You can add user-defined fields to group boxes only. You can't add user-defined fields directly to a page
or a delivered field group.

To add a user-defined field:

1. Expand the Add New section of the Elements panel.
2. Open the Layout list.
3. Add a group box to the current page.
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4. Open the General list in the Add New section.
5. Select a field type, and drag and drop it in the desired group box.

?’ Note: User-defined fields must be contained by a group box.

6. Select the user-defined field you added, and use the Field Attributes panel to configure your field.

7. Save your changes.

f Note: User-defined fields and fields provided in predefined field groups use the same set of attributes.

Once saved, the system applies your user-defined field to the application data model so field data can be
captured, stored, and retrieved.

Choosing User-Defined Field Types

Expand the Add New section in the Elements panel and open the General list to view the field types you can add to your

forms.

f Note: You must first add a group box to your form, and then you can drop one or more user-defined field
types into the group box container.

Field Type

Text field

Number field

Date field

Date time field

Switch

Text area

Rich text area

ORACLE

Description

Adds a character field to hold text values.

A text field is limited to a length of 200 characters. If you need to provide a field that enables users to
enter more characters, consider a text area field.

Number field used to contain integer values.

Stores date values, such as 09-26-2018.

Stores date and time values, such as 09-26-2018 11:25 AM.

On-off field, such as an “active” field indicating whether an item is active or not, which would be either
on or off (yes or no).

Along character field enabling the user to enter longer descriptions.

A text area field is limited to a length of 1500 characters.

Along character field enabling the user to enter longer descriptions or instructional information that
can be formatted using a rich text editor.

For more information on rich text area fields, see Adding Rich Text Areas.
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Field Type

Single-item check box

Check box set

Radio button set

Drop-down List

Multi-select List

Reusing Fields

Description

Displays a single option for the end user to select, such as, "I have read the terms and conditions, and
| agree to the terms and conditions." This is different from a check box set, which displays a list of
multiple items for an end user to select.

In the case of a single-item check box, the label of the field acts as the text the end user reads and
responds to on the application form.

A set of check boxes from which the end user can make multiple selections. For example, the label for
the check box set might be Heating Source(s), with values such as Oil, Gas, Wood, Solar, and so on.
This fields needs to be associated with a list of lookup values.

For more information, see Defining Fields Displaying a List of Values.

A set of radio buttons from which the end user can make a single selection. For example, the label for
the check box set might be Fence Type, with values such as Stone, Wood, Vinyl, and so on.

This fields needs to be associated with a list of lookup values.

For more information, see Defining Fields Displaying a List of Values.

A drop-down list allowing the user to select a single item.
This fields needs to be associated with a list of lookup values.

For more information, see Defining Fields Displaying a List of Values.

A drop-down list allowing the user to select multiple items.
This fields needs to be associated with a list of lookup values.

For more information, see Defining Fields Displaying a List of Values.

You may want to include some user-defined fields on multiple intake forms. Rather than recreating the same field
multiple times for each intake form, you can create the field on one intake form and set it to be reusable, which enables
that field to be available to include on other intake forms for your agency.

o Note: Fields set as reusable can be used on intake forms within the same offering. For example, if you create
#  areusable field in the Permits offering, and you have also licensed the Planning and Zoning offering, that
reusable field will not be available to use for Planning and Zoning intake forms.

f Note: Reusable fields are not supported for the Planning and Zoning offering.

Prior to setting a user-defined field to be reusable, consider these items:

ORACLE
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Consideration Description
Fees Reusable fields can't be incorporated in the fee calculations executed by decision models defined in

Oracle Integration Cloud.

Deletion Currently, you can’t delete reusable fields from the Fields list in the Elements panel. You can remove
unnecessary fields from the intake form.

Limited quantity You can define up to 625 fields as being reusable.

Required fields Required fields can’t be set to be reusable.

Hidden fields Hidden fields can’t be set to be reusable.

Groovy You can add logic to reusable fields, however, the logic should be specific to that field only. If the

logic applies to the transaction type level, such as a specific permit type, then add the logic at the
transaction type level using the Add Logic button in the toolbar.

Creation The reusable field is created, when you click Save.

Once the field is saved with the Reusable switch turned on, the field is reusable. You can’'t convert a
reusable field to a non-reusable field. Likewise, you can’t convert a non-reusable field to a reusable
field, once the field has been saved.

Updating Changing the label, placeholder, or default value on any reusable field will update those values for all
transaction types using the field.

Cloning When you clone a transaction type, reusable fields are also cloned.

To make a user-defined field reusable:

Review the guidelines above and carefully determine if the field should be reusable.

Select the user-defined field.

Turn on the Reusable switch in the Field Attributes panel.

Click Save.

Confirm that the label for the reusable field appears in the Ready to Use > Fields section in the Elements panel.

Hiding Fields
In some cases, you may not want to display all of the fields associated with a delivered field group you've added to a
form. You can hide unneeded fields so they do not appear to the user at runtime.

VuhWNA

To hide fields:

1. Place your cursor in the field to select it.
2. Turn on the Hidden switch on the Field Attributes panel.

Once you have hidden a field, the design-time interface continues to display the field, but places a darkened
background around the field to indicate it is a hidden field. The application does not display the field at runtime.

This example illustrates the shading around a field to indicate that is hidden during design time.
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Location
Corner Lot
Material
Other Material

In this example of the design-time interface, Location and Material are not set to be hidden, but Corner Lot and Other
Material are. Notice that the hidden fields display with the darkened background.

The following example of the runtime illustrates that the hidden fields do not display when an end user access the form.
Only Location and Material render on the form at runtime, while Corner Lot and Other Material are not rendered.

This example illustrates the fields indicated as hidden in the previous example in design time do not appear on the form
at runtime.

Location

Material

?s Note: At runtime, the system applies this style to the hidden field:style="display: none;”. This style prevents
the field from being visible on the page.

. Note: Required fields can’t be hidden fields. If you set a field to be required, the Hidden switch becomes
#  disabled. If a field is set to be hidden, and you set it to be required, the system sets the Hidden switch to off
automatically and disables the Hidden switch.

Adding Rich Text Areas

This topic describes how to add rich text areas to your intake forms so that you can display formatted text in application
intake forms.

Rich Text Area Overview

In some cases, you may need to add rich text areas to your application forms so that you can display formatted text for
users filling out the application. For example, if you needed to provide additional information, such as instructions or
reference material, you can provide that within a rich text area.

?s Note: The rich text area provides a way for your agency to provide read-only formatted text for end users. A
rich text area does not enable the end user to be able to insert formatted text into the form.
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When you add a rich text area element to your form, an Edit button appears in the Field Attributes panel when you
select the rich text area element. The Edit button launches the Rich Text Editor dialog box.

This example illustrates the Rich Text Editor dialog box displaying bold, colored, and italicized text; normal text; and text
within a numbered list.

Rich Text Editor X

Keyboard users can place the cursor in the text editor and press Alt + 0 to access keyboard shortcut instructions.

Font - | size -/B I U|&|A- Bz 2 |«

Adding Rich Text
To add formatted text to your forms:

1. Add a group box to your form.

2. Drag and drop a rich text area field onto the group box.

3. Select the rich text area element, and click Edit in the Field Attributes panel.
4. Add your text using the Rich Text Editor dialog box.

5. Click OK.

body ol i

The Rich Text Editor dialog box provides these formatting options:

- Font size

- Bold, italic, underline

- Copy formatting

- Text color

- Text background color

« Numbered and bulleted lists

- Undo and redo

+ Increase and decrease indentation

- Horizontal line

Adding a Rich Text Area to a Form

To add a rich text area:

1. Insert a group box into your form where you want to place the rich text area.
2. From the Add New > General list, drag and drop a rich text element into the group box.
3. Select the rich text area element.

This example illustrates the rich text area element being selected prior to rich text being added.
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4 Group box X

Field O

This is a rich text area. To add or edit content, select this element, then
open the rich text editor.

4. Inthe Field Attributes panel, click Edit to open the Rich Text Editor dialog box.

Note: If needed, you can use the Description field to enter a description of the contents of the rich
#  text area for other implementation team members. The description you enter only appears in the
designer; it is not be displayed at run time.

ui

Add text and use the desired formatting options.
Click OK.

7. Save your form layout.

o

Defining Fields Displaying a List of Values

This topic describes how to add a list-of-values (LOV) to user-defined fields you add to your application forms manually.

Some of the user-defined fields that you can add to your form are considered “list-of-value” fields, or LOV fields. List-
of-value fields enable end users to select field values from a predefined set of values (a lookup list) to populate the field
when entering data on the form. For example, radio sets and drop-down lists are list-of-value fields.

The list of values is a lookup type, and the individual items in the lookup list are lookup values.

When adding a list-of-value field type to your application form, you first add the field to the form, just as you would any
other field. You then select an existing lookup type to associate with the field, or you can create a new lookup type if
needed. To manage lookup types you use the Custom Lookups page.

This example illustrates the Lookup Type page.

Custom Lookups

Lookup Type flz
+
Lookup Type Meaning Actions
PSC_ID_FENCE_TYPE Fence Type Select >
v PSC_ID_HEAT SRC Heat Source Select >

PSC_ID_ROOF_TYPE Roof Type Select
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Alist of values is a set of fixed field values defined for a specific purpose that is not expected to change over time.
Removing items from the list, for example, could make previously saved data invalid.

An example of a field with a list of values could be the Property Zone Type field, where the values for a user to select are:
Business, Residential, and Agricultural.

Once you have clicked the Select button, for a lookup type row, a check mark appears next to that lookup type to
indicate it is the lookup type associated with the current LOV field.

This example illustrates the check mark that appears to the left of the lookup type to indicate lookup type selected for
the current field.

Custom Lookups

Lookup Type
+

Lookup Type

v PSC

Identifying List of Value Type Fields

You associate a list of values with these field types:

Radio button set
- Check box set
Drop-down list

Multi-select list

The following example illustrates a radio set, which is a set of radio buttons allowing a user to select a single value from
the list of values.

Text surrounding the image describes it.

Fernce '@ ‘“wWood

kA aterial Ctone

Chain Link

The following example illustrates a check box set, which is a list of multiple items allowing a user to select multiple
values from the list of values.

Text surrounding the image describes it.

m
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v Loam
v Sand

Stone
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The following example illustrates a drop-down list, which is a list allowing a user to select a single value from the list of

values.

Text surrounding the image describes it.

Furnace b

b anufacturer
Armana

American Standard
Bryant
Rinmai

Trane

The following example illustrates a multi-select list, which is a drop-down list allowing a user to select multiple values

from the list of values.

Text surrounding the image describes it.

Heating Source(s) Propane ®  Solar %

Electricity
il

Pellet
Wood

Selecting an Existing Lookup Type for a Field

To select an existing lookup type:
1. Add the list-of-value type field to your form layout.

2. Select the new field.
3. Click Manage List in the Field Attributes panel.

ORACLE

12



Oracle Public Sector Compliance and Regulation Cloud Chapter 5
Implementing Community Development Creating Intake Forms

This opens the Lookup Type page.
4. On the Custom Lookups page, identify the lookup type to associate with the list-of-value field you added.

Use the Meaning column to identify the appropriate list, or you can click View More Details to view the
description and the actual lookup values in the lookup type.

5. Click Select in the Actions column to associate the desired lookup type with your field.

f Note: Once you select a lookup type, the Lookup Type page closes automatically. You can click
Manage List to confirm your selecting if needed.

6. Save the form layout.

Adding a New Lookup Type for a Field

1. Add the list-of-value type field to your form layout.
2. Select the new field.
3. Click Manage List in the Field Attributes panel.

This opens the Lookup Type page.
4. On the Custom Lookups page, click Add.
5. On the Lookup Type Details page, enter these values.

Page Element Description
Lookup Type The system name, beginning with PSC, using uppercase letters, numbers, or
underscores.

For example, PSC_ROOF_TYPE.

Note:
f All lookup types created and used within the Intake Form Designer must begin
with PSC.

Meaning Add a short, user-friendly description. This value appears in the Meaning column of the
list of lookup types, which can help to identify the contents of the list.

For example, Roof Type.

Description Provide any additional information to help identify the purpose and intended usage of
the lookup type.

6. Add lookup values to the lookup type.

a. Inthe Look Up Values grid, click Add.
b. Modify these values:
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ORACLE



Oracle Public Sector Compliance and Regulation Cloud

Implementing Community Development

Page Element

Lookup Code

Display Sequence

Enabled

Start Date

End Date

Meaning

Description

c. Click Save.

Chapter 5

Creating Intake Forms

Description

A short code used to identify the lookup value to the system, like a key value.

If required, you can set the sequence in which lookup values display in the
lookup list, using a numeric sequence.

By default, a new lookup value is enabled. To disable a lookup value, turn off
this switch.

Date on which a lookup value becomes valid.

Date on which a lookup value is no longer valid.

The value that displays to the end user at runtime to select from the list.

Any additional information to describe the content or purpose of a lookup
value.

d. Repeat for additional lookup values in the lookup type.

Example:

This example illustrates the Lookup Type Details page, showing a completed lookup type with a set of lookup

values.

ORACLE
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Custom Lookups
Lookup Type Details Concel |
* Looku p Type PSC_ID_HEAT_SRC Description | This list contains the types of heat
used for structures in this -
* Meaning | Heat Source - -
Lookup Values
+ 4
Lookup Code Display Sequence Enabled Start Date End Date Meaning
WD 1 Yes 8/27/19 Wood >
5 Yes 9/27/19 Electricity >
PR 2 Yes 9/27/19 Propane >
NG Yes 10/21/19 Natural Gas >
sL 4 Yes 11/1/19 Solar >

7. On the Lookup Types page click Select to associate the new lookup type with the field.

Or, click Close to associate the lookup type with another field later.

8. Save the form layout.

Understanding the Scope of Lookup Types Created in the Intake Form

Designer

The items in the following table describe the scope of the list of value fields that you can create and use in the Intake

Form Designer.

Scope Item

User-defined fields

Intake Form Designer-only

Other licensed offering(s) in the same
database

ORACLE

Description

You only can add to and modify the list of values associated with user-defined fields, which are the
specific fields you have added to your application form manually. You can’t add or modify a list of
values for a field contained within a delivered field group, such as the delivered Fence field group.

The lookup types that you create within the Intake Form Designer can be used only within the Intake
Form Designer. Only in specific circumstances can you associate a field in your form layout with lookup
types created outside the Intake Form Designer.

The interface used to create and select lookup types for use in your intake forms looks identical to the
Lookups page (Navigator > Common Setup > Lookups), which is the interface used to manage lookups
for Public Sector Community Development offering pages, such as the permit offering or the planning
and zoning offering. However, the lookup types created on the Lookup pages can not be used for your
intake forms nor visa versa. For example, you can't use the UOM Type lookup type (ORA_PSC_CC_
UOM_TYPE) from the Lookup Type page for your intake form fields.

In select cases, if you are an existing Fusion Application Cloud customer, and you have other licensed
offerings in the same database as the Public Sector Compliance and Regulation offerings, you can
utilize lookup types not beginning with PSC for your intake form fields if required.
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For example, if you also license Fusion Application Cloud for Financials, which shares the same
database as the Public Sector Compliance and Regulation offerings, you can select lookup types using
the Intake Form Designer interface, assuming you are aware of the values it displays and how it is

maintained.

To access these lookup types, you need to modify the filtering on the Lookups page. By default, the
Intake Form Designer filters on PSC or the exact name of the selected lookup.

Refer to the following example for more information on modifying the filtering option.

Example: This example illustrates modifying the default filtering for the Intake Form Designer lookups.

To modify the filtering on the Lookup Type page:

Click the Filter By button.

POUN

Click Apply.

Select how you want to filter, as in by Lookup Type or by Meaning.
Select the operator to use for your filtering, such as Starts with, Contains, and so on.

Displaying Form Elements Conditionally

This topic describes how you can show or hide elements on your forms depending on selections users make on other

form elements.

You can configure some form elements to be either displayed or hidden, depending on the value of other fields in
the form. Form elements that can control the display of other elements are controlling elements, and form elements
that can be shown or hidden based on the value of controlling elements are controlled elements. The following table

describes the elements involved in conditional display.

For example, assume you wanted to display the Photovoltaic field group only if the user has selected the Solar single-
item check box in a “Building Options” section of a permit application form. In this case, you can set the Solar single-
item check box as the controlling element for the Photovoltaic field group, having the Photovoltaic element (the
controlled element) display only when the Solar single-item check box is selected.

Display Type Element Types

Controlling Element - Single-item check box
- Switch

Controlled Element - Field group

- Group box

- Page

ORACLE

Description

Form elements that determine whether another form element is
displayed, depending on the value selected by the user.

Note:
j Only single-item check boxes and switches can be controlling
elements.

Form elements that can be displayed conditionally, depending on the
value of the associated controlling element.

To control when these elements appear, click the Control Display button
on the Attributes tab, which appears only for these element types.
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Display Type Element Types Description

Procedure: Configuring Conditional Display

To configure conditional display for a form element:

1. Add the controlling element to a group box in your application form.
The controlling element can be a user-defined element of these types:

o single-item check box

o switch

?’ Note: The controlling element must appear before the controlled element that references it.

2. Add the form element that you want to display or hide conditionally (the controlled element).
The controlled element can be:

o field group

o group box

o page
Select the controlled element you just added so that it is the active element in the layout.
In the Attributes panel, click Control Display.

P W

5. On the Control Element Display dialog box, click Add to add a row to the grid, then double-click in the newly

added row, and make the appropriate selections.

f Note: Once you add a row to the grid and activate it by double-clicking, you must enter value before

clicking OK.

This example illustrates the Control Element Display dialog box set to show a condition of a controlling element,

such as hide this element if a switch element in the form is false.

Control Element Display x
f you add multiple rows of display conditions in the grid, and any display condition evaluates to true, the element will be
hidden.
+ w
Display A Controlling Element Value
Hide if Application Options - Plumbing False
Cancel “

ORACLE
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Element Description
Add Click to add a new row to the grid.

After adding a row, double-click the row to make it active.

Note:
. If you add multiple rows of conditions to the grid, the system assumes an “OR”
&  operator exists between each row. If any of the conditions are confirmed, that
display option will be enabled.

Delete Click to delete the selected row in the grid.

Display Currently, Hide if is the only display option. You hide an element based on the value of
the controlling switch or single-item check box, otherwise, the element is displayed.

Controlling Element Select the form element that will control the display of the selected predefined form
element or group box.

The drop-down list displays all user-defined switches and single-item check boxes that
exist on or before the current page in the form.

Selecting the controlling element appearing before the controlled element adheres to
the logical sequence a user would take when completing the application form.

Note:
?’ If the selected element is a group box, the drop-down list does not display any
switches or single-item check boxes within that group box.

Value Select the value of the controlling element that determines when the display option will
be rendered:

o True: A condition is true if a single-item check box is selected or a switch is on.

o False: A condition is false if a single-item check box is deselected or a switch is off.

6. Click OK.
7. Save your form.

The controlled element appears with an icon below the element label to indicate it is an item whose display is controlled
by another element in the intake form.

This example illustrates the icon displayed for a controlled element.
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4 Solar Installation Information

Type of Use Roof Materia

Type of Roof Roof Lay

Service [D

Roof Connaction

Mumber of Roof
hotovoltaic Connections

Modules

Working with the Conditional Display of Pages

This section describes items to consider when using the conditional display feature with pages, which includes:

- Hiding a page based on a controlling element.

- Hiding all elements on a page.

f Note: A page can become hidden if the page itself is a controlled element and also if all items on the page are
controlled elements and all become hidden.

You can control the display of an entire page based on the value of a controlling element in the intake form. Doing so
introduces dynamic display features to your intake form that can streamline the form significantly. Based on the user’s
selection of a single-item check box or a switch can determine whether a page displays or is hidden, providing user’s
an improved experience. Using this feature, only the pages relevant to the user’s transaction would be displayed. As
selections are made, the pages appear or become hidden accordingly.

This example illustrates single-item check boxes controlling the display of the corresponding intake form pages.

Applicant Details X Project Scope X Plumbing * Electrical ¥ Constructrion X Add Tab

4 Select the itemstFaT apply toxoT
Plumbing
Electrical

Construction

f Note: The train stop drop-down list also changes dynamically to reflect the current set of pages as pages
appear or become hidden.

In cases where all of the elements on a particular page are controlled elements and each element’s controlling element’s
display conditions cause all the elements on the page to be hidden, the system will hide the entire page.

In the following example, each element on the page is a controlled element. If each element becomes hidden as a result
of the values selected for the controlling element, the entire page becomes hidden.

This is an example of all elements on a page being controlled elements. Details are in the surrounding text.
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€« Constructrion X | Additional Options X Add Tab Form Options

4 Grading Information

Project Type ‘ Cut Disposal Site ‘
Project Acreage ‘ Export Amount ‘ ‘
Disturbed Acreage ‘ Fill Amount ‘ ‘
MNumber o ‘ ‘ teria ‘ ‘
Cut Amount ‘ ‘ + Amount ‘ ‘

Cut Materia ‘ ‘ Source of Import ‘

4 Demolition

Structure

Descriptio

Demolition Reason

Adding Logic

This topic describes how to add business logic to intake forms using the Groovy programming language.

Groovy Overview

You can add business logic to your intake form using the Apache Groovy programming language.
Groovy is an:

- Object oriented language that can be used for scripting or programming.

- Extension of the Java programming language, using similar constructs and syntax.

For Java developers, Groovy can be compared to other programming languages, such as Python or Ruby, that don’t
intend to replace Java, but act as a companion language, extending capabilities and providing additional flexibility.

When designing intake forms, you can add Groovy scripts to provide:
- Validators
- Triggers

- Object functions

- Global functions

The logic can be added at these levels:

- Field: Field-level logic applies only to the currently selected field.
- Object: Object-level logic can be used within a single intake form design.
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- Global: Global functions can be called from any intake form in your offering.

The types of scripts you can add depends on the level on which you are adding the logic (field or object).

Script Type Level

Validator Field and Object
Trigger Field and Object
Object Function Object

Global Function Object

Before adding Groovy to your intake forms, you will need to become familiar with the Groovy language and how it is
intended to be used within Oracle Fusion applications.

For more information on Groovy usage within Oracle, refer to Oracle Applications Cloud: Groovy Scripting Reference.

For general information on the Groovy language, see Apache Groovy documentation.

Working with the Groovy Script Editor

To access the Groovy Script Editor:

1. Save the intake form you are creating.

The field(s) you reference in your logic at the field level or the object level must exist in the underlying database
object, which occurs when you save the form after adding any new elements.

f Note: For the user-defined fields you added manually to your intake forms, the Add Logic button
doesn’t display in the Field Attributes panel until you have saved your intake form.

2. Click the Add Logic button in the Field Attributes panel or in the intake form header.

o When clicking Add Logic in the Field Attributes panel, your code operates at the field level.
o When you click Add Logic in the intake form header, your code operates at the object level.

This example illustrates the separate field-level and object-level Add Logic buttons.
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Add Logic Preview Save Publish

Obiject Level

Form Options »
Field Attributes

Label ™

License Class Code

)
n
M

Add Logic | Field Level

Add Help

3. Use the Groovy Script Editor to add the logic, script name, error message, and additional options, depending on
the type of script you are writing.

The following example illustrates adding validation logic to a field using the Groovy Script Editor.

Groovy Script Editor

Validators Triggers
Script Name *
1 /* Field Validator for field YearsExperience_c YearsExperience_c_validator v
2 Custom Object LNP1SOLARPERMIT c */ —
3 Description
4 newValue > 8
Value Greater Than 0
Error Message *
The value entered indicating years of
experience must be greater than 0.
Save and Close Remove Close
Page Element Description
Work Area In the work area, add your logic.

The first line in the comments (/* <text> */) is automatically generated, and it provides you the field
name and object name as they are referenced internally.

For a field contained in a delivered field group, the field name will be similar to the field label, such as
DemOverallHeight.
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Page Element

Script Name

Description

Type

Parameters

Return Type

Error Message

Save and Close

Remove

Close

ORACLE

Description

In the case of a user-defined field, the field name will match the field label you have entered, witha "_c"
as a suffix to indicate it is a custom field.

For example, if you have a user-defined field named Rooms, the field name appearing in the script will
be Rooms_c.

The custom object name is the type code as defined on the Transaction Type page, and it is preceded
by the offering code, such as LNP1or PZ1and a “_c” suffix. LNP1is the prefix for permits and PZ1is the
prefix for planning and zoning applications.

For example, if for a permit the Transaction Type Code is Fence, the custom object name in the script

will be LNP1Fence_c.

By default, the script name follows this structure:

field_script type

or

object_script type

For example, the user-defined field Years Experience would have the following default validator script
name: YearsExperience_c_validator.

You can change the script name if needed.

To add multiple scripts of the current type, select New from the drop-down list.

Add text to describe the purpose of the script.

Used only for triggers. Defines when the trigger runs, such as during the Create event. See the "Add
Triggers" section below for more information.

Used only for object functions and global functions. Enables you to define the parameters the function
will accept.

Used only for object functions and global functions. Enables you to set the data type for the return
value of the function.

Provide the message that the system displays the user to correct any issues. For example, in the case
of a validator script, the message appears if the data entered for the field does not pass the validation
logic.

Saves the current code and closes the editor.

Removes the business logic from the associated field or object. This may be required in some cases
prior to removing the field from the intake form.

Closes the editor without first saving.
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f Note: While you can delete fields with Groovy logic associated with them, make sure the Groovy logic
evaluates to True prior to deleting the field, otherwise you risk making the entire transaction type invalid.

Note: When referencing a field for field level logic, use newValue and oldValue to reference the current field
o value. At the object level, use the internal field name, such as YearsExperience_c. You can access the internal
#  name of the field a few ways. You can select the field, and click Add Logic, to see how the field is referenced
in the Groovy Script Editor. You can also review how the field is referenced in the JSON payload from a REST
request, such as a describe request.

Setting the Scope of a Groovy Script

The following table outlines the possible scope of a Groovy script.

Scope Description Where Set

Field You can add Groovy logic to act on a single Select the field to which you want to add
field. The code you add runs only against the validation logic, and click Add Logic in the Field
selected field. Attributes panel for that field.

You can add Groovy to fields in delivered
predefined field groups or to user-defined fields
you have added manually.

Object If your script involves more than one field, you = When in the designer with the intake form
need to add that code at the object level. The open, click the Add Logic button at the top of
object refers to the current intake form you the form, next to the Preview button.

are creating. For example, if you are creating a
fence permit, the logic you add for the current
object applies to fields in that fence permit

definition.

Global You can create global functions that can be When in the designer with a intake form open,
called by any field-level script or object-level click the Add Logic button in the header at
script in your offering. the top of the form. You can access the Global

Functions option only by opening the Groovy
Script Editor at the object level.

This example illustrates the Groovy Script Editor at the field level. Details are in the surrounding text.
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Groovy Script Editor

Validators Triggers

1 /* Field Validator for field SolarInstallerName c
2 Custom Object LNP1IDSclarPermit_c */

Field Level Script Editor

Script Name *
SolarinstallerMName_c_validator

Description

*
Error Message

Remove

When you add logic at the field level, you can add only these types of scripts:

- Validators

- Triggers

Chapter 5
Creating Intake Forms

Close

This example illustrates the Groovy Script Editor at the object level. Details are in the surrounding text.

Groovy Script Editor

Validators Triggers Object Functions

Global Functions

1 /* Object validator for Custom Object LNP1IDSolarPermit_c */

Object Level Script Editor

Script Name *
LNP1IDSolarPermit_c_validator

Description

#*

Error Message

Remaove

When you add logic at the object level, you can add these types of scripts:

- Validators

Triggers
- Object Functions

- Global Functions

Close

f Note: For scripts at the field level use newValue and oldValue to reference the current field. At the object level,
use the field name, such as NumberofRooms_c to reference fields.

When you open the Groovy Script Editor, comments in the script type pages indicate where the logic you write will
apply. The following table provides some examples.

ORACLE
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Comment Description
Field Validator for field GrdTypeProject Logic applies to the field level for the GrdTypeProject field in the selected field group. This field is
stored in the child Field Groups view object, where all other fields appearing in field groups are stored.
Custom Object FieldGroupsVO Logic written at this level for this field will apply to all instances where this field group is used.
Object Validator for Custom Object Logic applies to the Field Groups view object and because Add Logic was selected at the object level
FieldGroupsVO while a field was selcted in a child field group, it can apply to multiple fields. This field is stored in the

child Field Groups view object, where all other fields appearing in field groups are stored. Logic written
at this level for these fields will apply to all instances where the field group is used.

Note:
o Most field groups are considered child objects with the fields being stored in the Field Groups
? view object. Applicant and Application are considered parent objects, with their fields stored
elsewhere.

Field Validator for field YearsExperience_c = The logic applies to the user-defined field Years Experience. If the field is set to be reusable, then the
logic you add applies to all instances where that field is used.

Object Function for Custom Object The logic applies to the current transaction and can be called from all other script types defined within
LNP1IDFencePermit_c the current intake form design.
Global Function The logic applies globally, across transactions and can be called from all other script types.

/* Object Function for Custom Object LNP1IDFencePermit_c */

Add Validation Logic

A validator script provides data integrity for end user input. A validator script is a logical construct that returns either
true or false.

The essential components of a validator script include:

- Groovy logic
- Error message

For example, assume you have a form with the field Years Experience to indicate the number of years experience of a
solar panel installer. To meet permit criteria for your agency policy, you can validate that the applicant doesn’t enter zero
by adding the following validation script to the field.

newValue > 0

At runtime, if the field value entered does not meet your validation logic criteria during a save or submit request. The
validator script returns either true or false. If the return is false, the system displays the error message so the user can
resolve the issue.

This example illustrates the runtime message displayed by a Groovy validation script.
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# Close Application

Solar Permit

A @ Correct the Following Errors and Try Again

* The value you enter to indicate years experience, must be greater than 0.
(Step 3: Solar Project ‘Information)

Validator scripts can be run at the field level and at the object level. Field-level validation is for single-field validation,
and object-level validation involves validation of multiple fields.

Note: The Groovy script executes only when the user either saves or submits the form. If there is any

f delivered validation for a field contained within a delivered field group, that delivered validation runs before
any Groovy validation you have added. Before adding Groovy logic to a field delivered in a predefined field
group, make sure to test the field group at runtime to become familiar with any existing, internal validation.

f Note: In the case of multiple field-level validations, each runs independently. If you have added object-level
validations also, the object-level validation runs only if all field-level validations have passed.

Add Triggers

Triggers enable you to invoke processing logic based on an event.

This example illustrates the Triggers tab. Details are in the text surrounding the image.

Groovy Script Editor

Validators Triggers

Script Name *

1 /* Field Trigger for field CompanyName_c CompanyName_c_trigger v
Custom Object LNP1IDSeolarPermit_c */ —
Description

4 newValue = CompanyName_c.tolUpperCase() | :
c Uppercase value

Type

Create v

Error Message *

Converted| field value to uppercase.

Save and Close Remove Close

In addition to the common attributes, including Script Name, Description, and Error Message, you also set the Type,
which is where you define the event on which the trigger is based.
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Type

Create

Invalidate

Modify

Remove

Before Insert

After Insert

Before Update

After Update

Before Delete

After Delete

Before Commit

After Commit

Before Rollback

After Rollback

After Transaction Posted

ORACLE

Applicable Level(s)

Field

Object

Object

Object

Object

Object

Object

Object

Object

Object

Object

N/A

N/A

N/A

N/A

N/A
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Description

Fires when a new instance of an object is
created. Use to assign programmatic default
values to one or more fields in the object.

Fires on a valid parent object when a child
row is created, removed, or modified, or also
when the first persistent field is changed in an
unmodified row.

Fires when an attempt is made to modify an
object. Returning false stops the row from being
deleted and displays the optional trigger error
message.

Fires when an attempt is made to delete an
object. Returning false stops the row from being
deleted and displays the trigger error message.

Fires before a new object is inserted into the
database.

Fires after a new object is inserted into the
database.

Fires before an existing object is modified in the
database.

Fires after an existing object is modified in the
database.

Fires before an existing object is deleted from
the database.

Fires before an existing object is deleted from
the database.

Not supported.

Not supported.

Not supported.

Not supported.

Not supported.
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Add Functions

You can create functions at the object and the global level.

Level Description

Object Object functions provide business logic to be used within the scope of the current business object,
which is the current transaction type, such as an intake form for a permit.

Global Global functions can be called from any intake form design within the offering.

This example illustrates the interface used for creating object or global functions. Details are in the surrounding text.

Groovy Script Editor

Validators Trigger: Object Functions Global Functions
Script Name *
1 /* Object Function for Custom Object LNP1IDFencePermit_c */ add? A
3 return nl+n2 Description

Adds two field values.

Parameters
Name Type
ni Integer
n2 Integer

Return Type

Integer v

Remaove Close

The interface for creating functions is the same for creating object or global functions, and it contains the same general
options in the editor, such as Script Name, Description, and Error Message, plus the additional items listed below.

Page Element Description

Parameters Define the parameters received by the function when it is called. Add the name of the parameter and
its data type. Refer to the following table for data type descriptions.

Click Add to include multiple parameters in the grid.
Click Delete to remove a row from the grid.

Return Type Define the data type of the value returned by the function. Refer to the following table for data type
descriptions.

129
ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 5
Implementing Community Development Creating Intake Forms

You can apply these data types.

Data Type

void

String

Integer

Boolean

Long

BigInteger

Double

Big Decimal

Date

List

Map

Object

Description

Applies only to return values. Use in situations when the function does not provide a return value to
the caller, such as when the functions performs a task, writes an output line, and so on.

A text value.

A whole number, either positive or negative.

Alogical true or false value.

An integer value in the range of +263-1.

An integer of arbitrary precision.

A floating-point decimal value in the range of +1.79769313486231570 x 10308

A decimal number of arbitrary precision.

A date value with optional time component.

An ordered collection of objects.

An unordered collection of name/value pairs.

An entire business object, which in this case refers to an instance of an intake form.

Once you create the function, you can call it from other scripts.

This example illustrates calling a function in the Groovy Script Editor. Details are in the surround text.

ORACLE
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Groovy Script Editor

Validators Triggers Object Functions Global Functions
Script Name *
1 /* Object Trigger for Custom Object LWP1IDSolarPermit c */ CalculateTotzICost v
3 def nl = EquipmentCosts_c Description

4 def n2 = InstallationCosts c i
= - Add equipment cost and install cost.

6 TotalCosts_c = add2(nl, n2) Type

Create v
Error Message ~

The value for this field is calculated by
calling the object function: add2.

Save and Close Remove Close

For a function defined at the object level, you can call the function using just the function name.

For a function defined at the global level, you need to add as a prefix adz.util. For example, if the global function name
is add2, you call the function using adf.util.add2 (paraml, param2).

In this example, there is an object function named adq, which adds two parameters passed in. On the Triggers page, the
trigger script is set to run on the Create event type, and the values for EquipmentCosts_c and InstallationCosts_c are
passed to the function to calculate the value of the TotalCosts_c field.

Example: Accessing User Security Context

To access information regarding the current user, instantiate the getSecurityContext() object. In this example, the script
checks if the user is assigned a particular role, and if not, displays the error message.

/*Get the security context.*/

def secCtx = adf.context.getSecurityContext ()
/*Check if the user has the desired role.*/
if (secCtx.isUserInRole('PSC_ROLE NAME')) {

/*If user has role, then check if field is not blank. If field is blank,
returns false, showing error message.*/

return newValue != null

}

/*If the user doesn't have the role, returns true, bypassing the error message.*/

return true

Adding Contextual Help to Forms

This topic describes how to add help text to various parts of your intake forms to aid citizens when they are filling out an
application form.
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Working with Contextual Help

If you determine that the end user needs additional information to understand a user-interface element in your intake
form, you can add contextual help text to that user-interface element. If you add contextual help to a user-interface
element in your intake form design, the system displays a Help icon next to the label of that user-interface element.

You can see the Help icon in both the design and runtime mode. At runtime, end users click the Help icon to display
your help text in a popup, without leaving the page.

?’ Note: At design time, the Help icon does not display the help text popup when clicked.

You can add contextual help text to these intake form elements:

Page tabs
Field groups
- Group boxes

Fields (applies to fields in field groups and to custom fields)

f Note: For group boxes and field groups, you can add help only when with the Show Label attribute turned on.

You can't add contextual help text to these intake form elements:

Radio sets
- Check box sets

If you need to add help for radio sets or check box sets, use a group box to contain the control and add the help text to
the group box container.

Adding Contextual Help

To add contextual help:

1. Select the page element to which you want to add contextual help.

f Note: You cannot add help text directly to radio sets and check box sets. Add help text to a group box
surrounding the radio sets or check box sets.

2. Click the Help button in the attributes panel.
3. On the Contextual Help Setup page, note the Type Code, Page Name, and Page Object values.

These values uniquely identify the page element to which you are associating the contextual help. You can’t
change these values. They are read-only and maintained by the application.

Item Value

Type Code An automatically generated value consisting of the internal product code and the permit
type code derived from the permit type definition.
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Item Value
Page Name The name of the page tab on which you are adding help. Regardless of what the page

N

10.
1.
12

label is on the tab, the application displays each tab using the default name in sequence,
such as tabs1, tabs2, and so on.

For example, the second page tab in an intake form may have the name Fence
Information, however in the Page Name field it will appear as tabs2.

Page Object Identifies the page element for which you are adding help. Regardless of the page
element’s label, the application displays the internal naming convention as the field
value, which is the page element type code + sequence added.

For example, for the second field added to the form the field value is fields2, which
indicates the element is a field and it is the second field added to the form.

The page element type codes are:

o Field groups: ccas
o Group boxes: widgets

o Fields in field groups: <field group>_<internal field name> (such as ccas2_
ReleaseDate)

o Custom Fields: fields

In the Description field, add text to describe the purpose of the help text so other implementation team
members can understand the content.

Click the Add New button in the Contextual Help Details grid to display the Add Context Help Details dialog box.
Select Agency Defined from the Type drop-down list.

Note: Help topics of type System Defined are provided by Oracle and should not be altered or

f removed. Customers should use the Agency Defined help topic type to add help topics specific to your
implementation. If you want your custom help text to display instead of delivered help text, disable the
System Defined help topic, create your custom topic, and enable it.

Activate the Help Content edit box by clicking to the right of the Help Content field label.
In the Help Content edit box, enter your help text.

The system provides rich-text editing features, which enables you to implement limited formatting options, as
needed.

When you've added the content, and you are ready for it to be viewed by end users, turn on the Enabled switch.

f Note: To prevent the help content from displaying at run time, turn off the Enabled switch.

Click Save on the Contextual Help Details page.
Click Save on the Contextual Help page.
Confirm that the help icon appears on the page tab or next to the page control label in your intake form design.

For more information on contextual help, see Setting Up Contextual Help.
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Setting Form Options

This topic describes the options you can set for the entire form to control the ways citizens interact with the form.

Enabling the Review Page

The review page presents all the fields of a multi-tab form on a single, scrollable page for efficient review of the entered
data prior to submitting the form.

By default, the review page displays:
Form fields as read-only, but the end user can click the Edit button for each field group to modify the fields as
needed.
- All field groups expanded.
For multi-page view or single-page view.

For all forms, unless disabled.

To disable the review page:

In the Intake Form Designer, click the Form Options link.
On the Form Options dialog box, turn off Review Page.
Click OK.

Click Save.

P WNa

Setting a Confirmation Step

You can enable one of the pages in a form as a confirmation page to display after the end user has filled in the
information and submitted the form. You create the confirmation step in the designer and then set it to be the
confirmation step in the Form Options.

When set as the Confirmation Step, the page displays:

- At design time with the page tab filled in grey to indicate it is the confirmation step.

- At runtime as the last page in the train stop drop-down list.

f Note: The confirmation step does not display as part of the single page view.

To enable the review page:

In the designer, click the Form Options link.

On the Form Options dialog box, select the desired page from the Confirmation Step drop-down list.
Click OK.

Click Save.

P WN
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Mapping Form Fields to Decision Model Attributes

This topic describes how the fields added to an intake form in the designer are mapped to the fee model defined for the
transaction type.

The Fee Mapping page in the designer is used to map attributes in the decision model to the fields added to the intake
form. The Fee Mapping page is step 2 in the Intake Form Designer, where designing the layout is step 1.

This image illustrates Step 2 of 2: Fee Mapping in the design of a permit application.

Design Permit Application Addlogic  Preview  Save | Publish

PermitTypefee11 = Status: published

< Previous
DGRl Fee Mapping !

Fee Mapping
4 Permit Fees/PermitApplicationFees/1.0/PermitApplication
Model Attribute Attribute Type Record Type Attribute

ProjectValue number Job Cost v

4 Permit Fees/BuildingPermit/1.0/BuildingPermit

Model Attribute Attribute Type Record Type Attribute
ProjectValue number Select a record type attribute v

~

Submitted By

NewSqFootage number

Classification

ConstructionType Construction

) Type of Work
UseType string
Type of Use

New Floor Area Classification v

» Permit Fees/Electrical/1.0/Electrical

» Permit Fees/PlumbingMechanical/1.0/PlumbingMechanical

You assign a fee schedule to an application type on the Transaction Type page using the Fee Schedule field. You map
attributes from the fee schedule’s underlying decision model created in Oracle Integration Cloud to the fields you have
added to your intake form either through delivered field groups or by adding fields manually.

Note: Not all model attributes need to be mapped. Because a fee schedule can be reused by multiple
# transaction types, only the model attributes required for fee calculations for the current application type need
to be mapped. All other model attributes can be left blank.

For more information on setting up fee schedules, see Setting Up Fee Schedules.

For more information on decision models, see Creating Decision Models for Fees.
Mapping Application Fields to the Fee Item in the Decision Model
To access the Fee Mapping page in the form designer:

1. Navigate to the Transaction Type page:

o Permit Setup > Permit Type
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o Planning and Zoning Setup > Planning Application Type

Select the transaction type that you want to view in the designer.
Click the Design Form button.

Click the Next button while in the application form setup step.
The fields on the Fee Mapping page are as follows:

v hWN

Page Elements Description

Model Attribute The name of the attribute as it appears in the decision model in Oracle Autonomous
Integration Cloud.

Not all model attributes must be mapped. Because fee schedules can be reused by
multiple transaction types, only the model attributes required for fee calculations for the
current transaction type need to be mapped. All other model attributes can be left blank.

Attribute Type The data type of the model attribute, such as string, number, boolean, and so on.

Record Type Attribute The field added to the intake form layout either contained in a predefined form element
or a user-defined element you have added manually.

Note:
Mapping decision model attributes to fields defined as reusable in your intake
form is not supported.

4

6. Select the record type attribute from the drop-down list that you want to map to the decision model attribute.
7. Click Save.

Considering User Experience

This topic describes concepts related to using forms that implementation teams need to consider when designing
forms.

Required Fields

The system validates that required fields contain values prior to a save request at runtime.
If a required field is empty the system displays the following error message on the page.

This example illustrates how the system displays messages to indicate what is required for a field.
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t least 3 alphanumeric characters

€ Value is required.
You must enter a value.

In addition to the message, the system disables the Save button until the required field values have been provided.

The system also displays an itemized list at the top of the form when clicking Save so that in the case of multiple pages,
the user can navigate quickly to the item and provide an acceptable value. The error message lists the error and the
location to which the end user must navigate to correct the error. The list if errors can be expanded and collapsed as
needed.

This example illustrates an error message appearing at the top of the form, displaying in the list the error, and the
location of the offending field.

4 O Correct the Following Errors and Try Again

* You must select an applicant.
(Step 1: Applicant)

Runtime Application Form Save Behavior

When an end user navigates to another page in the application form using either the train stop drop-down list or the
Next button, the system automatically:
- Saves the currently entered data.

- Performs data validation on the current page.

If the end user attempts to navigate away from the application form page using, for example, the back button, entering
a different URL, or reloading the page, the system checks for any unsaved changes or new data. If the changes or new
data have not been saved, the system displays a message to the user indicating that if they continue, unsaved changes
and new data will be lost. The user can elect to leave the page or remain on the page to save.

Runtime Train Stop Drop-Down Behavior

The train stop drop-down list, appears in the center of the application form header to provide:

Feature Description

Context The system automatically prepends the appropriate step number to the application form page name.
The step numbers are assigned in the order the pages appear in the designer (from left-to-right).

For example, assume you have three pages in your form: Application Details, Fence Details, Property
Details. The train-stop drop-down list displays the pages as:

Step 1: Applicant Details

Step 2: Fence Details

Step 3: Property Details
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Feature

Current Page

Navigation

Switch to Single/Multi-page view

Description

To show the current page the user is viewing, the system displays a single, right-pointing, chevron
character (>) to the left of page label in the drop-down list.

Select any page in the application form, including the review page, to access it immediately.

Toggle between the multi-page view or the single-page view.

Using the Single-Page View

When accessing the single-page view in review or advanced-edit mode, end users will notice these characteristics of the

page elements.

Page Element

Edit button

Done button

Group boxes

Field groups

Expand All/Collapse All

Behavior

Enables the end user to activate the form fields for editing. Initially, the system displays them in read-
only mode. Once clicked, the system toggles the Edit button to the Done button.

Once the end user completes any changes, clicking Done:

Performs any configured data validation.
Saves changes to the database.

Returns the form fields to read-only.
Toggles the button back to read Edit.

PUWNA

If a group box contains multiple group boxes, only the outer (parent) group box displays an Edit/Done
button.

If there are multiple field groups in a group box, they will appear to be a single page section, with one
Edit/Done button controlling all the field groups within the parent group box.
Otherwise, if the field groups are on the page tab separately (not within the same parent group box

container), then the system displays an Edit/Done button for each field group.

Expands or collapses all the elements on the page, including group boxes and field groups within
parent group boxes.

Note: The Edit button and the Done button do not appear on a page rendered in advanced edit mode if the

f form is displayed in a read-only context. For example, if the user viewing the form does not have sufficient
privileges or if the user has already submitted the form, the fields in the form will be disabled and the Edit
button and Done button will not be rendered on the page.

ORACLE
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Advanced-Edit Mode

If needed, agency staff members can update a form after a citizen has submitted the form. Agency staff members
access the submitted form using the Permit Details page in the Permit List or by deep linking. Editing a form after a
citizen has submitted it is referred to as advanced-edit mode.

When in advanced-edit mode, the system:

Displays only the field groups enabled for advanced-edit mode.

Presents the form in the single-page view.

Agency staff members click the Edit button to activate fields and update data, and they click Done to save changes.

Note: Customers cannot configure whether a delivered field group appears in advanced-edit mode. Field
#  groups enabled for advanced-edit mode are controlled and delivered by Oracle development. Only the field
groups that are appropriate for agency staff members to update are enabled for advanced-edit mode.

Testing Intake Forms

This topic describes the methods and considerations involved with testing your application forms.

You design, create, and test application forms on your development or test environment. Depending on what you have
licensed, you may have a combined development and test environment, or you may have a separate development and
test environment. You can test forms both inside and outside sandbox mode.

Once your forms have been created and thoroughly tested, you then migrate the newly created forms to your
production system for public access.

Testing Forms Inside the Sandbox

You can test draft application forms in the sandbox using the Intake Form Designer preview mode. To enter preview,
click the Preview button.

In preview mode, you can test the layout of the user interface and the tab flow in a simulated runtime scenario. The
preview mode does not enable you to enter data and save it. To test the full functionality and data validation of your
intake form, you must first publish the form in your test system, as described in the following section.

The preview mode provides you and accurate view of how your intake form will look and behave in runtime mode.

This example illustrates how an intake form appears in preview mode.
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X Close Application Step 1 of 3: General ¥ Mext 2

> Step 1: General
Preview

Step 2! Project Details

Step 3: Review
© Correct the Following Errors and Try Again

Single-Fage View

» Application
4 Applicant
Select Applicant Clear
First Mame Salutation ‘
Middle Name Suffix ‘ ‘
Last Name Business Name
Title ‘
Country US
Zip Code | Q,

O valueis required.

You must enter a value.

don't know

?’ Note: The Intake Form Designer does not activate the Save button in preview mode.

Testing Forms Outside the Sandbox

Once you are done testing the configuration of your form and the layout of the user interface using preview mode, you
can begin testing your form in scenarios that end users will encounter when they interact with your intake form. To do
this, you need to publish your form on the test environment.

For more information on publishing forms, see Publishing Intake Forms.

f Note: The testing data you enter and save during testing remains in the underlying database tables after the
form is migrated to the production system.

Migrating Application Forms Between Environments

After you have completed your testing of the application form on the test environment, follow the procedure in
Functional Setup Manager for migrating transaction type metadata and intake form layout metadata from the test
database to the production database.

For more information on test-to-production data migration, see Managing Transaction Type Configurations.
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Publishing Intake Forms

This topic describes the steps to complete to publish intake forms.
To make your application forms available on public landing pages, you need to publish your form.
To publish a form:

1. Confirm that you have saved and tested all changes made to your form.
2. Inthe Intake Form Designer, click Publish.
3. Navigate to the Transaction Type page:

To navigate to the Transaction Type page you can either click Back in the global header, or select Permit
Setup > Permit Type.
4. Onthe Transaction Type page, open the appropriate transaction type, and set these values:

o Transaction Type Status: Ready
o Public User Enabled: Enabled for all users or Enabled for registered users.
5. Click Save.
Note: After publishing a transaction type, if you attempt to access the application from a landing page and

f the application displays an error, make sure the Transaction Type Status and Public User Enabled attributes are
set correctly.

o Note: After publishing a transaction type application, the application may not be accessible immediately. It
#  can take several minutes to apply the most recent changes and transfer the application from the sandbox to
the live runtime system.

Related Topics
- Setting Up Permit Types

Cloning Transaction Type Definitions

This topic describes how to clone transaction type definitions and the associated form design. It also covers the
attributes that will be shared between the source and clone definition and the attributes you will need to modify on the
cloned definition.

You can clone a transaction type to:

Save time when creating a similar transaction type, rather than creating a new transaction type for each
situation from scratch.

- Create a new version of a currently published transaction type after making a significant correction or addition
to the transaction definition.
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In some cases, it may be more efficient to create a new transaction type and form, while in other cases, it may be more
efficient to clone an existing transaction type and form.

When you clone a transaction type, you make a cloned copy of:

- Most of the transaction type metadata, such as the specified Classification, Auto Number Rule, Department,
Fee Schedule, and so on. Some of the metadata is not cloned, such as Transaction Type, Transaction Type
Code, Transaction Type Status, Help Text and so on, as you'll need to modify those values for the cloned copy.

- All of the intake form layout in the Intake Form Designer, including pages, group boxes, field groups, and user-
defined fields you have added to your application form.

When deciding to clone a transaction type, you may consider:
- The number of fields and pages within the existing application form layout that you'd need to change.
- Similarity between the existing transaction type and new transaction type.

- Number of shared attributes.

f Note: In general, if you intend to make numerous modifications to the cloned copy, it may be more efficient to
start a new transaction type from scratch.

When cloning to make a new transaction type, you will want to make sure you are aware of:

- The attributes that will be shared between the source definition and the clone.
- The attributes you need to modify to create unique values between the source definition and the clone.

Note: All modifications you make to a should be done in your test environment and not on your production

f environment. After you have thoroughly tested your changes in the test environment, your modifications
should be migrated using the Functional Setup Manager task flows.

Transaction Type Metadata Considerations

All of the field values on the Transaction Type page will appear in the cloned transaction type, except for selected field
values listed in the following table.

Make sure to update any of the copied information on the Transaction Type page to reflect the requirements of the new
transaction type. For example, if the Department, Fee Schedule, or Workflow information, should be different, make sure
to update it for the new transaction type definition so it is associated with the correct items.

Page Element Description

Type The type name doesn’t have to be unique. You can create a new transaction type by using a unique
value or enter the same value as the source transaction type, if you are creating a new transaction
definition with the same transaction type.

Type Code The type code must be unique. Enter a transaction type code that identifies this version of the
transaction type definition.

Status Initially, for a newly created transaction type the status on the Transaction Type page is always set to
Preliminary. After you publish the form, change the status to Ready for Use.

Valid From Date The application inserts the current date for the cloned transaction type.
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Valid To Date

Public User Enabled

Description

Update to reflect your business requirements.

Chapter 5
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Initially, for a newly created transaction type this is always set to Not enabled for public users. When

you are ready to publish the new transaction type, update this value.

For more information on the fields on the Transaction Type page, see Setting Up Permit Types.

Intake Form Layout Attribute Considerations

The following table addresses specific considerations for Ul elements in your form layout with respect to cloned
transaction types and application forms and how any changes you make to the cloned definition may affect the source

definition.

Element

Field groups

Labels

User-defined fields

Security

Help

Groovy scripts

Description

The cloned copy of the transaction type contains the same layout as the source definition.

If the intake form utilized any of the delivered field groups, the application copies the field groups into
the cloned copy of the definition, using the same layout as the source definition. For example, if you

added the Fence field group to the source permit definition to the second page tab, the Fence field
group would appear in the cloned copy of the transaction type on the same page tab.

The labels for fields and Ul elements, such as pages, group boxes, field groups, and so on, are the same

between the source and cloned definition.

Any fields you have added manually to the source will be copied, as is, to the cloned definition.

For any fields that you have defined a list of values, make sure it applies to your new transaction type.

The cloned definition will have the same security configuration as the source definition for:

- Data security for column authorization and data redaction.

- Cases where Hide from public user has been implemented.

If any help has been added to the form for a page, field group, group box, or field, for the source
definition, the application does not copy help references into the cloned definition.

Note:
?’ You can remove the help references from the cloned form, but do not delete the help text
from the Contextual Help page if other forms are still using that help text.

If any Groovy logic has been added to the form for an intake form for the source definition, the
application does not copy the Groovy logic into the cloned definition.

You are also cloning the fee mapping, which is defined in the second step of the Intake Form Designer.

ORACLE
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Cloning a Transaction Type to Create a New Transaction Type

When you clone a transaction type, you also clone the associated form design. You can clone just the transaction type
definition without cloning the application form design; however, you can’t clone just the form design by itself.

f Note: When you clone a transaction type, the type status defaults to Preliminary on the new transaction type,
and the status of the new application form defaults to Draft in the Intake Form Designer.

This example illustrates the Clone Permit Type page, which is described in the steps for cloning a permit type.

Clone Permit Type

Original Permit Type Solar Permit
Original Permit Type Code LLSolar0918a
*

MNew Permit Type

* New Permit Type Code

Use Original Workflow Setup O
Clone Form Design o

To clone a transaction type:

Select Permit Setup > Permit Type.

Open the desired transaction type.

Click the Clone button.

On the Clone Type page, enter the following values:

P UWNa

Page Element Description

New Transaction Type Enter a transaction type name.

The transaction type name can be the same as an existing transaction type name

so that you can have different versions of the same transaction type. For example,

if the original transaction type name is Fences, you can reuse the name for the new
transaction type definition, but you must enter a unique type code to distinguish the
two.

New Transaction Type Code Enter a unique transaction type code.
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Page Element Description

Oracle recommends manually adding a version number to the source transaction type
code if you want different versions of the same transaction type definition. For example,
if the original type code is Solar-001, you can enter a new code, Solar-001-v2

Use Original Workflow Setup Turn on the switch to use the original workflow setup as defined in the original
transaction type. Turn off the switch to leave the workflow setup fields blank on the new
transaction type. You must enter a workflow setup values.

Clone Form Design Turn on the switch on to clone the application form design associated with the original
transaction type. Turn off the switch to create a completely new application form using
the Intake Form Designer.

| f Note: Providing a unique type code is required to make the transaction type definition unique.

5. Click the Create button.

The cloning process opens the cloned copy of the transaction type.

f Note: When saving the cloned definition, the application places the cloned definition within a
sandbox.

6. Make any other required changes to the cloned transaction type definition and form design.

See the previous sections for more information regarding what items to check.

o Note: If there are numerous custom fields in the application form, when you have the layout open
# inintake Form Designer, it can take several minutes to perform the initial save. While saving, the
application is creating all of the custom fields, creating the other elements, and running validation.

7. Publish the application form in the Intake Form Designer.

For more information on publishing a transaction type, see Publishing Intake Forms.
8. Return to the Transaction Type page to change the status to Ready for Use.

Considerations for Creating a New Version of a Transaction Type Using
Cloning

In some cases, you may want create a new version of an existing, published transaction type to correct an error or make
a change.

If the change made is insignificant, as in it does not change the meaning of a field or page element, then in most cases
cloning is not required, and you can simply make the change directly to the transaction type definition. For example,
assume you have a field for an email address on your form, and it had been requested to change the label from E-mail
to Email (removing the hyphen). In this case, the change can be made directly to the form and republishing it.

However, in other situations, the change may be significant, in that it affects reporting associated with transaction type,
alters historical data, makes future data out of sync with historical data, and so on.
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Significant changes where cloning a transaction type is recommended include:

Transaction Type Element Examples of Significant Changes

Field groups - Changing the label of a field group.
Adding
Removing

Updating the security (Hide from public user)
Changing the label, hidden, or required setting of a field within a field group.

User-defined form elements - Adding
Removing
Setting to required
Updating a default value
Updating the security (Hide from public user)

HTML Ul constructs - Adding page tabs
Removing page tabs
Adding group boxes

Removing group boxes

Creating a New Version of a Transaction Type Using Cloning

Creating a new version of a transaction type using the cloning feature involves:

- Deactivating the published version of the transaction type.
« Cloning the published version of the transaction type.

- Activating the cloned copy of the transaction type.

To deactivate a published transaction type:

Select Permit Setup > Permit Type.

Open the definition for the published transaction type.
Set the Transaction Type Status field to Void.

4. Click Save.

To clone the published transaction type:

WN =

1. With the transaction still open from the previous steps, click Clone.
2. Enter the same Transaction Type value as used for the recently deactivated transaction type.
3. Enter a unique Transaction Type Code.
f Note: Providing a unique transaction type code makes the transaction type definition unique. To keep
track of versions, you can add v2, v3, v4 to the code, for example.
4. Save the cloned definition.
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f Note: When saving the cloned definition, the application places the cloned definition within a

sandbox.

5. Make any other required changes to the cloned definition transaction type and form design.

See the previous sections for more information regarding what items to check.
6. Click Publish in the Intake Form Designer to publish the cloned definition.

For more information on publish a transaction type, see Publishing Intake Forms.

To activate the new transaction type:

1. Select Permit Setup > Permit Type or press Back from the Intake Form Designer interface.
2. Open the definition for the published transaction type.
3. Onthe Transaction Type page, set these values:

o Transaction Type Status: Ready for Use.

o Public User Enabled: Enabled for all users or Enabled for registered users.

4. C(lick Save.

Impact of Updating Existing Transaction Types and Republishing

This table describes the impact of various changes when you update and republish a transaction type.

Modification

Update a label for a user-defined field

Add a new user-defined field

Set a field as required

ORACLE

Impact

Submitted transactions: applies to all submitted transactions.
New transactions: available on all new transaction intake forms.
Auditing: No impact. Labels don’'t appear in auditing; the audit goes against the field IDs.

Reporting:
OTBI: no impact to OTBI, which doesn’t incorporate fields.

CSA: New label will not appear in CSA. Manual update of the label in CSA and republish. Once
done this applies to all transactions, old and new.

BIP: if BIP depends on CSA, then the BIP report template needs to have the new label manually
updated.

Submitted transactions: the field will appear on all submitted transactions, which means if an
update is required for a submitted transaction this field will also appear on the page and be part
of the payload.

New transactions: the field appears on all new transactions.

Auditing: available for auditing, but the field needs to be added to the auditing report.
Reporting:

CSA: available after you edit the CSA, include the new field, and republish.

BIP: available after the new field is included in the report template and the CSA is republished.

Submitted transactions: any update to the transaction will require that this field have a value.

New transactions: appear as required for any new transaction.
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Modification

Add or edit Groovy script

Hide a field

Add a user-defined list of values (LOV)
field

Add or edit a list of values (LOV)

Update list of values (LOV) display criteria
(Enabled/Disabled)

(Start Date/End Date)

Add or edit control display settings

Make changes to reusable field

ORACLE

Impact

.

Auditing: no impact.

Reporting: n impact.

Submitted transactions: if modifying, the new logic will fire.
New transactions: applies to all new transactions.
Auditing: no impact.

Reporting: no impact.

Chapter 5
Creating Intake Forms

Submitted transactions: field will be hidden for all submitted transactions.

New transactions: hidden for any new transactions.

Auditing: field would be still part of the audit report until removed.

Reporting:
BIP - remove from template

CSA: manually remove field from CSA and republish,

BIP: manually remove field from template.

Submitted transactions: applies to all submitted transactions.

New transactions: applies to all new transactions.
Auditing: same as adding a user-defined field.

Reporting: same as adding a user-defined field.

Submitted transactions: no impact.
New transactions: applies to all new transactions.
Auditing: no impact.

Reporting: immediately reflected in CSA.

Submitted transactions: applies to all submitted transactions.

New transactions: applies to all new transactions.
Auditing: no impact.

Reporting: immediately reflected in CSA.

Submitted transactions: may impact submitted transactions.
New transactions: applies to all new transactions.
Auditing: no impact.

Reporting: no impact

Submitted transactions: applies to all submitted transactions.

New transactions: applies to all new transactions.

Auditing: available for audits after being incorporated into the audit report.

Reporting: no impact.
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Impact of Cloning the Transaction Type and Retiring the Previous Version

This table describes the impact of various changes when you clone a transaction type to replace the previous version.

When cloning, you are creating a new transaction type, so in general, you should expect these impacts as the standard

update:

- Auditing: any new transaction that is created is available to audit framework, which requires you to enable the
object to be audited and configure the report as needed.

- Reporting: a new CSA needs to be created for each new transaction type.

Modification

Update a label for a user-defined field

Add a new user-defined field

Set a field group field or a user-defined

field as required

Add or edit Groovy script

Hide a field

Add a user-defined list of values (LOV)
field

ORACLE

Modification

Submitted transactions: no impact as there are no submitted transaction yet.
New transactions: appears for all new transactions.
Auditing: standard uptake.

Reporting: standard uptake. You can reuse the same BIP or create a new BIP template.

Submitted transactions: no impact.
New transactions: appears for all new transactions.
Auditing: standard uptake.

Reporting: standard uptake. You can reuse BIP template after editing and republishing or create a
new BIP template.

Submitted transactions: no impact.
New transactions: appears for all new transactions.
Auditing: standard update. Layout changes are not auditable.

Reporting: no impact to BIP.

Submitted transactions: no impact.
New transactions: appears for all new transactions.
Auditing: Groovy changes are not tracked by audits.

Reporting: no impact to BIP. Groovy changes to not affect reporting.

Submitted transactions: no impact.
New transactions: appears for all new transactions.
Auditing: layout changes are not tracked in Audits.

Reporting: no impact to BIP. Layout changes are not reflected in reporting.

Submitted transactions: If the LOV is pointing to an existing list then updates to this list will affect
submitted transactions. If a new list is created for the user-defined field, then there is no impact to
existing fields.

New transactions: appears for all new transactions.
Auditing: same as adding a user-defined field.

Reporting: no impact to BIP.
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Modification Modification

Update a user-defined list of values (LOV) - Submitted transactions: If the LOV is pointing to an existing list then updates to this list will affect
submitted transactions. If a new list is created for the user-defined field, then there is no impact to
existing fields.

- New transactions: appears for all new transactions.
- Auditing: no impact.
- Reporting: LOVs are immediately reflected in CSA.
Update list of values (LOV) display criteria - Submitted transactions: If the LOV is pointing to an existing list then updates to this list will affect

submitted transactions. If a new list is created for the user-defined field, then there is no impact to
(Enabled/Disabled) existing fields.

(Start Date/End Date) - New transactions: appears for all new transactions.
- Auditing: no impact.
- Reporting: may affect reporting on submitted transactions as both values can be incorporated
depending on date settings.
Control display settings - Submitted transactions: no impact.
- New transactions: applies to all new transactions.
- Auditing: no impact.

» Reporting: no impact.

Reusable custom fields - Submitted transactions: applies to all submitted transactions.
- New transactions: applies to all new transactions.
- Auditing: standard uptake.

- Reporting: not currently supported.

Managing Transaction Type Configurations

This topic describes the considerations and steps related to migrating transaction type definitions, such as permits,
planning and zoning applications, and code enforcement, from your test environment to your production environment.

Transaction Type Lifecycle Overview

Any implementation of Oracle Applications Cloud usually requires migrating setup data from one environment to
another at various points in the subscription lifecycle.

For example, you set up your initial configuration of the Public Sector Community Development services in the test
environment, which is your source system. Then, after thorough testing and verification, you move the setup and
configuration data from your test environment to the target environment, which is your production system.

You use the Fusion Applications Functional Setup Manager to perform these migration tasks.

This example illustrates that you use Functional Setup Manager to migrate data between your test and your production
environment.
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Functional Setup
Manager

Source: Test System Target Production
System

You access Functional Setup Manager from within Public Sector Community Development by selecting Navigator >
Setup and Maintenance or by clicking the Setup and Maintenance tile on the springboard. To access Functional Setup
Manager, you need to have the System Administrator role associated with your user account.

The functional areas in Functional Setup Manager that apply to your transaction type definitions and application form
definitions are:

Offering Functional Area

Public Sector Permits Permit Types

Public Sector Planning and Zoning Planning Application Types
Public Sector Code Enforcement Incident and Case Types

Like using Functional Setup Manager to setup your configuration, when migrating data, you use a top-down approach.
That is, if you are not exporting the entire configured offering, and you are exporting by functional area, you need to
export the functional areas in the order they appear.

For more information on using Functional Setup Manager, see Using Functional Setup Manager.

Note: All configuration changes should be completed and tested in your test environment and then migrated
#  tothe production environment. Changes made directly to the production environment might be overridden
during subsequent test-to-production migration activity.

For additional information related to migrating configuration data from your test environment to your production
environment for the Public Sector Compliance and Regulation offerings, see Oracle Public Sector Community
Development: Test to Production (Doc ID 2551940.1) on My Oracle Support.
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Set the Target Instance URL

On the source system (your test environment), you need to define the URL target system (your production environment)
so that setup data and configuration data can be sent to the target.

To set the target instance URL:

Sign on to the test environment.

Click the Setup and Maintenance tile on the springboard to access Functional Setup Manager.

On the right side of the Functional Manager Setup interface, click the Tasks tab to open the Tasks drawer.
Click Search, and search for Manage Configuration Set Migration Target Security Policy.

On the Manage Configuration Set Migration Target Security Policy page, enter the URL for your target
environment, and the appropriate security credentials for the System Administrator role.

vk WNRA

o Note: It is recommended to include the port number when you specify the URL value. For example:
#  https://server.example.com:443 You can get the target port value by accessing the Manage
Configuration Set Migration Target Security Policy page on your production system (your target).

6. Save.

Managing Unified Sandboxes on the Source and Target System

Public Sector Compliance and Regulation requires the Unified Sandboxes feature to be enabled on your test
environment, where you are actively designing and configuring your implementation. It is recommended that you
disable the Unified Sandboxes feature on your production system.

For migrating transaction types from your test system to your production system, especially, make sure to disable the
Unified Sandboxes feature on your target, production system. Because you should be completing all configuration tasks
on your source test system, sandboxes shouldn’t be required on the production system. Having the Unified Sandboxes
enabled on the production system can cause the Configuration Set Migration utility not to render or function properly.

To disable Unified Sandboxes:
1. Sign on to your target, production system.
2. Navigate to Functional Setup Manager.

3. Select your solution, such as Public Sector Permits, Public Sector Planning and Zoning, or Public Sector Code
Enforcement.

?9 Note: Disable Unified Sandboxes in all solutions you have licensed for Public Sector Compliance and
Regulation.

4. C(lick the Change Feature Opt In link.

5. Locate the Application Extensions feature, and click the pencil icon in the Features column.
6. Make sure the Unified Sandboxes feature is disabled.
f Note: If there are any open sandboxes, they need to be deleted or published before you can disable
this feature.
7. Click Done.
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Migrating Transaction Type Foundational Metadata

Before you use Functional Setup Manager to export transaction type configuration data, you need to create and migrate
a configuration set, which includes the underlying metadata required to be in place as a prerequisite prior to migrating
other transaction type setup data.

Because the Public Sector Compliance and Regulation solutions are metadata-driven, you need to migrate the metadata
that is the foundation of the transaction definitions. This is the data stored in the Oracle Metadata Services (MDS) layer.
You do this by creating a configuration migration set. Once that is complete, you can then begin using Functional Setup
Manager export and import features to transfer the rest of required definitions between test and production systems.

f Note: Before you migrate transaction type metadata from your test system, ensure that the transaction type
definitions and associated intake forms are complete, tested, and published.

A CAUTION: These steps must be completed before you use the Functional Setup Manager export and import
options.

Note: Prior to running the configuration set migration process, ensure that all transaction types are published
f and there is no development and design of intake forms underway. Creating transaction types and intake

forms is not supported while the configuration set migration process is running. Once the configuration set

migration process has completed successfully. you may resume development and design of intake forms.

To migrate transaction type metadata:

Sign on to the test system, which is the source system.

Click the Setup and Maintenance tile on the springboard to access Functional Setup Manager.

Select the appropriate offering (Permits, Planning and Zoning, or Code Enforcement).

Expand the Permit Types, Planning Application Types, or the Incident and Case Types functional area
(depending on your offering).

PUWUNA

f Note: These steps for creating a migration set apply only to the Permit Types, the Planning
Application Types, and the Incident and Case Types functional areas.

5. Click the configuration you want (depending on your offering).

This example illustrates selecting the option Manage Permit Configuration, which you select to set up and
migrate a configuration set.
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Permit Types
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Y
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f Note: This link takes you to the Manage Configuration Set Migration Target Security Policy. You can
also access this page in Fusion Application by selecting Navigator > Configuration > Migration .

6. If you have not already specified your target instance URL, you must do that prior to the next step.

See the previous section for more information.

7. Select the Outgoing tile and create an outgoing migration set to export to your production environment.

When creating a configuration set, the utility compares differences between source and target, and determines
the metadata that needs to be exported to the target system. When the process is complete, the resulting
migration set is downloaded in the form of a downloadable jar file.
8. After finishing the creation and migration of the outgoing migration set, sign on to the production system (the
target system), and complete the steps for applying the incoming migration set.

This example illustrates an incoming configuration set.

ORACLE
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For more information on these steps, refer to Oracle Applications Cloud documentation: Configuring and Extending
Applications.

Exporting and Importing Remaining Transaction Type Data

After you have completed migrating the configuration set on the source system, you then export the remaining
transaction type data using the Functional Setup Manager options for the functional area or the entire offering.

f Note: You can export and import at the functional area-level by selecting the Actions button for the
functional area or at the entire offering level by selecting the Actions button at the top right.

This example illustrates using the functional area export options.

~ Permit T Manage Workflow Con
ermit Types E}

View Documents 3
* Accounting Shared
Edit Implementation Status :

* OPA Questionnaire Shared

Setup Data Report (3]
* Digital Assistant Shared »C
Import »
* Agency Staff Shared
Expart to T35V File »
Fublic Users Shared Import from CSV File >
* Analytics and Reporting hared Compare Setup Data 2

After exporting from the test system, you then sign on to the production system and import the corresponding
business object data.

When you export business object data, you have the option to select only those business objects that you utilize. For
example, if you are not using application groups, you could deselect Manage Application Groups from the Business
Objects list.

The objects you export will be in the form of a downloadable jar file.
For more information on these Functional Setup Manager export and import features, see:

Using Functional Setup Manager: Managing Setup Using CSV File Packages
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Using Functional Setup Manager: Exporting and Importing Setup Data
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6 Setting Up Inspections

Setting Up Inspection Statuses

Oracle delivers inspection statuses for use during the inspection process. You review the statuses on the Inspection
Status page.

You review inspection statuses during permit setup on the Inspection Status page. You cannot delete the system-
defined statuses or add new statuses, but you can modify the associated inspection status names and descriptions.

Modifying Inspection Statuses

1. Select Common Setup > Transaction Status .
2. Select the Inspections tab.
3. You can review the delivered inspection statuses in the System Status column:

o Pending
o Requested
o Scheduled
o Completed
o Canceled
o Deleted

Select the row for the inspection status that you want to modify.

On the Inspection Status Details page you can edit the inspection status name and description.
The status name is used as the display status for the inspection in the permit application.

6. Click Save to save any changes.

v oA

Inspection Evaluation Overview

The inspector evaluates a building site for adherence to codes and regulations required for a permit. The example here
provides information about an inspection set up to use automatic score calculation with the bottom up scoring method.

A permit might require one or more inspections, each inspection might have one or more checklists, and each checklist
might have checklist items or not, depending on the inspection configuration. The inspector performs an inspection

by assessing the checklist items, if any, then checklists, and up to the inspection level. The evaluation results that the
inspector enters are rolled up to the next level until a final inspection score is calculated if scoring is used.

Scoring is not required. The score is the rolled up to the next level automatically only if scoring used. Otherwise, you
specify the result manually on each level.

The following example describes the setup and results of performing an inspection using the bottom up method of
scoring. Scoring bottom to top indicates that the inspector starts with a zero score and adds points for each criterion
that is met.
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Example: Using the Bottom Up Scoring Method

Before you begin, set up the assessment type, rating method, passing rule, scoring method, and checklist, which
includes the checklist items. In this case, you don’'t need to set up the checklist group, because checklist and checklist
group are mutually exclusive of each other.

This example illustrates setup for an inspection on the Inspection Type Details page. Details are in the surrounding text.

Inspection Type Details

* Inspection Type CK_SCHDINSP_FNC Enabled c
* Description  FNC Scheduling Inspections * Estimated Duration in Hours 5
Scheduling Method = Schedule v
[ Assessment Type _passail Q] ’ Passing Rule PR-123 o

[ Rating Method GRADE Q

* Autonumber Rule  CK_FNC_Insp
Checklist Group
Billable

Policy Name:

l Scoring Method | Bottom up . I

o, Maximum Score

o, l Checklist - CK-FNC-0100

Bill Type

Policy Version

Inspector Signature Required v Owner Signature Optional v

Contractor Signature  Optional v Schedule Cutoff Time
Inspection District Type CK_DISTRICT_TYPE_FNC_INSP o Schedule Change Policy 3

Hide Inspector Comments

Cancel Delete

The setup includes the following:

1. Assessment Method

The assessment method is defined on the assessment type page and used in the inspection type definition.
During the inspection, the inspector selects an available assessment which is associated with a system result.
The system result determines the scoring calculation as follows:

Displayed Assessment System Result Scoring Calculation

Pass Pass Score = All Points

Corrected on Site Corrected Score = All Points
Fail Fail Score = No Points
NA (not applicable) Other Score = No Points

Note: Only the displayed assessment value is configurable by the agency. The available system results

f are Pass, Fail, Corrected, and Other. You must have one assessment with a system result of Pass and
one assessment with a system result of Fail. You can define multiple assessments with system results
of Corrected and Other.
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See Setting Up Inspection Assessment Types.
2. Inspection Scoring Method

The scoring method is defined on the inspection type. In this example, the scoring method is Bottom Up.

See Setting Up Inspection Types.
3. Rating Method

When you use a scoring method, you also must set up a rating method. The rating method defines the range of
scores used at the inspection type level.

See Setting Up Rating Methods.
4. Checklist

The checklist used in the inspection is defined on the inspection type. For example, the checklist could be
Electrical for a residential addition. For multiple checklists, you enter a checklist group name. A checklist group
can have different inspection checklists, such as both Electrical and Plumbing for a residential addition.

See Setting Up Inspection Checklists.
5. Checklist Item

The inspection score is defined in the inspection checklist details. In this example, each checklist item is set
up with a possible score of 25. The inspector’s assessment determines how many points are applied to the
checklist. When the inspection result is Pass, the item receives the complete score.

See checklist details in Setting Up Inspection Checklists.

Based on the setup, an example inspection evaluation might look like this:

Checklist Item Possible Score Inspector’s Checklist Assessment System  Calculated Score Checklist Total Score
Item Result Status
(Assessment)
1 25 Pass Pass 25 ltem 1=25
2 25 Pass Pass 25 ltem 1+ Item 2 =50
3 25 Corrected on Site Corrected 25 ltem 1+ Item 2 + Item
3=75
4 25 Fail Fail 0 ltem 1+ ltem 2 + Item
3+Item4=75

For multiple checklists, the sum of the checklist scores determines the inspection score.
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Setting Up Inspection Assessment Types

Assessment types identify the results available for assessing an inspection, for example, Pass and Fail. You add, modify,
or delete assessment types and codes for inspections on the Assessment Type pages.

An assessment type includes one or more assessment codes, which identify the possible results for the inspection type.
Assessment types are also used for inspection checklist and checklist item results.

Assessment types function independently of the scoring method, maximum score, and minimum score, for example:

- If the system result is Pass or Corrected, the full score is assigned.
- If the system result is Other or Fail, the score is 0.

Scoring for each system result is predefined in the system for inspections.

This example illustrates the Assessment Type Details page containing the field values described in the following table.

Assessment Type Details Concel | Delete

" Assessment Type * Description ' Result s either Pass or Fail

Assessment Details

Assessment Description System Result Actions

Fail Fail v+

Pass Pass

Adding Inspection Assessment Types

1. Select Inspection Setup > Assessment Type .
2. Onthe Assessment Type page, click Add to add an assessment type.
3. Onthe Assessment Type Details page, enter an assessment type name and description.
4. Inthe Assessment Details section, click Add in the assessment code row.
5. Enter values in the fields of the assessment code row:
Page Element Description
Assessment Enter a code name.
Description Enter descriptive text for the code.
System Result Select the system-defined result value that you want to set for this assessment code:
o Other
o Pass
o Fail

o Corrected
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Page Element Description

You must map each assessment code to a system result value. Each assessment type
must include a system result of Pass and a system result of Fail. The default value is
Other.

Note:
f You must assign Fail to only one code. Likewise, you must assign Pass to only
one code.

The system result is used in the inspection result processing. If scoring is used, the
system result of Pass and Corrected receive the maximum score. The system results
Other and Fail receive no score.

The system result is also used to determine whether an inspection result is pass (system
result Pass) or fail (system result Fail). For example, the Inspection Summary report
includes violation information when a checklist or checklist item result is associated with
the system result Fail.

6. Click the Add icon at the end of the row to add another assessment code row.
7. Click Save.

Modifying Inspection Assessment Type Details

1. Select Inspection Setup > Assessment Type .
2. Select the row for the assessment type you want to modify.

3. Inthe header fields on the Assessment Type Details page, you can only modify the assessment type
description. You cannot change the name.

4. Inthe Assessment Details section, you can:

o Change the description of an assessment code. You cannot change the code name.

o Select a new value in the System Result column. Available values are Pass, Fail, Corrected, or Other.
Each assessment code must be mapped to a system-defined result value. The default value is Other. You
can only use Pass and Fail once.

5. If you made any changes, click Save.

Deleting Inspection Assessment Types

1. Select Inspection Setup > Assessment Type .
2. Onthe Assessment Type page, click the Edit icon.
3. Select one or more check boxes for the assessment type rows you would like to delete.
f Note: When you delete an assessment type, you also delete the associated details.
4. Click the Delete icon.
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Deleting Inspection Assessment Type Details

1. Select Inspection Setup > Assessment Type .

2. Onthe Assessment Type page, select the row for the assessment type you are working with.

3. Onthe Assessment Type Details page, click the Delete icon at the end of the assessment code row you would
like to delete. You delete details one row at a time.

4. C(lick the Save button.

Setting Up Rating Methods

A inspection rating method may have one or more rating ranges, which an inspector uses to evaluate the object of an
inspection. You add, modify, or delete rating methods and rating details for inspections on the Rating Method page.

If you are using scoring for inspections, you must also set up rating methods. Rating methods are used at the inspection
type level and are not required at the checklist or checklist item levels.

Adding Rating Methods

You add an inspection rating method by setting up the rating method code with a description and rating details. For
example, an agency might use GRADES as the rating method code, with a description of Standard Grades. The rating
details might include grades such as A (high) to F (low), and provide a range of scores to each rating. If the rating for an
A grade is defined by 90-100 points, an inspection score of 95 would receive an A.

1. Select Inspection Setup > Rating Method .

2. On the Rating Method page, click Add to add a rating method.

3. On the Rating Method Details page, enter a rating method name and description. The description is a user-
friendly name for the inspection rating method.

4. To add rating method values, click the Add button for the first row in the detail grid, and the Add icon for the
next rows.

5. Enter values for the rating method:

Page Element Description

Rating Enter a short name for the rating.

Minimum Score and Maximum Enter minimum and maximum numerical values to specify the range for this rating. Do
Score not use decimals.

The range for this rating cannot overlap the range for another rating.

6. Click Save.

For example, if your rating method uses grades A through F, you specify the rating range for each grade in the Rating
Method Values table. The range for each rating cannot overlap the range for another rating.
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Rating Minimum Score Maximum Score
A 9N 100
B 81 90
C 7 80
D 61 70
F 0 60

Modifying Rating Methods

1.

Select Inspection Setup > Rating Method .

2. On the Rating Method page, select the row for the rating method you want to modify.

3.

4.

In the header fields on the Rating Method Details page, you can only modify the rating method description. You
cannot change the name of the rating method.
Click Save.

Modifying Rating Method Values

You can change the minimum and maximum scores for a rating on the Rating Method Details page.

PWNA

5.

Select Inspection Setup > Rating Method .

On the Rating Method page, select the row for the rating method you want to modify.

On the Rating Method Details page, select the rating row in the values grid that you want to modify.

Change the values in the Minimum Score or Maximum Score fields for this rating on the Rating Method Value
Details page. You can use the arrow icons to increase or decrease the score values. The range for this rating
cannot overlap the range for another rating. You cannot change the name of the rating.

Click Save.

Deleting Rating Methods

WIN =

ow

Select Inspection Setup > Rating Method .

. On the Rating Method page, select the row for the rating method you want to delete.
. On the Rating Method Details page, click Delete.

| ?’ Note: When you delete a rating method, all associated rating details are also deleted.

To delete multiple rating methods, click the Edit icon on the Rating Method page.

. Select the check boxes for the rating methods you want to delete.

Click the Delete icon.

| ?’ Note: When you delete multiple rating methods, all associated rating details are also deleted.

Click Save.
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Deleting Rating Method Values

Select Inspection Setup > Rating Method .

On the Rating Method page, select the row for the rating method you want to modify.

On the Rating Method Details page, select the ratings row in the value grid that you want to delete.
On the detail page for the individual rating, click Delete.

To delete multiple rating method values, click the Edit icon in the Rating Method Values section.
Select the check boxes for the rating method values you want to delete.

Click the Delete icon.

Click Save.

NS A UN

Setting Up Passing Rules

A passing rule identifies the different ways an inspection can be scored. You add, modify, and delete passing rules for
inspections on the Passing Rule page.

Passing rule definitions provide the criteria for determining whether an inspection passes or fails. If the scoring method
is not used in the inspection type definition, a passing rule is not required.

Adding Passing Rules

A passing rule may have one or more scoring ranges that you specify in the passing rule details.

Select Inspection Setup > Passing Rule .

On the Passing Rule page, click Add to add a new passing rule.

On the Passing Rule Details page, enter a unique code for the passing rule and a description.
To add scoring ranges, click Add in the Passing Rule Criteria section.

Enter values in the fields on the rule details page:

vihOUN

Page Element Description

Description Enter a description for the scoring range.

Minimum Score and Maximum Enter minimum and maximum numerical values to specify the scoring range. You
Score cannot use decimals.

Number of Major Violations Enter a value for the maximum number of major violations allowed.

Pass Turn on the Pass switch if the specified scoring range combined with the number of

violations results in a passing inspection. If the specified range and violations do not
result in a passing inspection, leave the option disabled.
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Page Element Description

Note:

For passing inspections that are based on a passing rule with the Pass switch

on, the inspection result displays the assessment name that is defined with the
f system status Pass. If the Pass switch is off, the inspection result displays the

assessment name that is defined with the system status Fail. The system uses

the assessment type that is associated with the inspection type.

6. Click Save.

Modifying Passing Rules

1. Select Inspection Setup > Passing Rule .
. On the Passing Rule page, select the row for the passing rule you want to modify.
3. Inthe header fields on the Passing Rule Details page, you can only modify the passing rule description. You
cannot modify the passing rule code.
4. C(lick Save.

Modifying Passing Rule Details

You can change the scoring range for a passing rule on the Passing Rule Details page.

Select Inspection Setup > Passing Rule .

On the Passing Rule page, select the row for the passing rule you want to modify.

On the Passing Rule Details page, select the scoring row in the details grid that you want to modify.
You can change the following scoring details:

POAN

a. Description of the scoring range.
b. Minimum and maximum scores to update the scoring range. Use the arrow icons to increase or decrease
the score values.
c. Number of major violations allowed.
You can also indicate that the specified scoring range combined with the number of violations can result
in a passing inspection, by clicking the Pass slider. Turn off the option using the slider if the scoring range
combined with the violations does not result in passing an inspection,
5. Click Save.

Deleting Passing Rules

When you delete a passing rule, all associated passing rule criteria are also deleted.

Select Inspection Setup > Passing Rule .

On the Passing Rule page, select the row for the passing rule you want to delete.

On the Passing Rule Details page, click Delete.

If you want to delete multiple passing rules, you can delete them from the Passing Rule page:

a. Click the Edit icon.
b. Select the check boxes for the passing rule rows to delete.

POAUN
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c. Click the Delete icon.

Deleting Passing Rule Criteria

VAWNRA

Select Inspection Setup > Passing Rule .

On the Passing Rule page, select the row for the passing rule with the passing rule criteria you want to delete.
In the Passing Rule Criteria section, select the row for the passing rule criteria you want to delete.

On the Passing Rule Criteria Details page, click the Delete button.

If you want to delete multiple scoring ranges, you can delete them from the Passing Rule Details page:

a. Click the Edit icon.
b. Select the check boxes for the passing rule criteria rows to delete.
c. Click the Delete icon.

Setting Up Inspection Checklist Categories

Use checklist categories and subcategories organize the various types of checklists items for inspections.

You set up inspection checklist categories and subcategories on the Inspection Checklist Category page.

Use the checklist categories and subcategories for categorizing checklist items when you set up inspection checklists on
the Inspection Checklist Item Details page. See Setting Up Inspection Checklists.

Adding Checklist Item Categories

PUWNA
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Select Inspection Setup > Checklist Category .

On the Checklist Category page, click Add to add a checklist category.

On the Checklist Category Details page, enter a category ID and description.

If you want to add a subcategory, click the Add button to add the first subcategory in the Checklist
Subcategory section. Click the Add icon for additional subcategories.

On the Checklist Subcategory Details page, enter a subcategory ID and a description.

Click Save.

Modifying Checklist Iltem Categories

1.

Select Inspection Setup > Checklist Category .

2. Onthe Checklist Category page, select the row for the category that you want to modify.

3.

4.

On the Checklist Category Details page, you can only modify the category description. You cannot change the
category ID.
Click Save.

Modifying Checklist Item Subcategories

VAWNRA

Select Inspection Setup > Checklist Category .

On the Checklist Category page, select the row for the category with the subcategory that you want to modify.
Select the subcategory that you want to modify in the Checklist Subcategory section.

You can only change the description on the Checklist Subcategory Details page.

Click Save.

166

ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 6
Implementing Community Development Setting Up Inspections

Deleting Checklist Item Categories

When you delete a checklist category, all associated subcategories are also deleted.

Select Inspection Setup > Checklist Category .

On the Checklist Category page, select the row for the category that you want to delete.

On the Checklist Category Details page, click Delete.

If you want to delete multiple checklist categories, you can delete them on the Checklist Category page:

P UWN

o Click the Edit icon.
o Select the check boxes for the category rows to delete.

o Click the Delete icon.

Deleting Checklist Subcategories

Select Inspection Setup > Checklist Category .

On the Checklist Category page, select the row for the category with the subcategory that you want to delete.
On the Checklist Category Details page, select the row for the subcategory that you want to delete.

Click the Delete button on the Checklist Subcategory Details page.

If you want to delete multiple subcategories, you can delete them on the Checklist Category Details page:

R UWUNA

o Click the Edit icon.
o Select the check boxes for the subcategory rows to delete.

o Click the Delete icon.

Setting Up Inspection Checklists

Inspection checklists identify all the items that the inspector must assess during an inspection. You set up inspection
checklists and checklist items on the Inspection Checklist pages.

Before adding inspection checklists, you set up:

Inspection assessment types for your agency, if you want to associate a checklist with an assessment type.

See Setting Up Inspection Assessment Types.

Inspection checklist categories and subcategories, if you want to categorize your checklist items.

See Setting Up Inspection Checklist Categories.

You add, modify, and delete checklists and checklist items in the inspection setup pages. The checklist and checklist
items are copied to the inspection when the inspection schedule is created, and appear on the Inspection Checklist
page, the Checklist Items page, and the Checklist Item Result page.

Note: When you modify an inspection checklist or checklist item, the updated checklist is applied to new
#  inspections using the checklist. Existing inspections use the version of the checklist definition in use when the
inspection was scheduled.
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You identify the checklist or checklist group to use for an inspection on the Inspection Type page. To set up a checklist
group after setting up checklists, see Setting Up Inspection Checklist Groups.

This example illustrates the Inspection Checklist Details page containing the field values described in the preceding

table.

Inspection Checklist Details

* Checklist
* Description  FNC_Checklist
Maximum Score 100

Scoring Method ' Not used

Checklist ltems
=+ 2
Checklist Item Description

Fence-Height Fence-Height

Fence-Materia Fence-Material
Fence-Type Fence-Type

Footings Footings

Gate Gate

] [

Assessment Type  PassFail o
Minimum Passing Score 35

Comment

Required Score Major Violation
Yes No >
Yes No >
Yes No >
Yes No >
Yes No >

Show 8 items v

Adding Inspection Checklists

AR WN

Page Element

Assessment Type

Maximum Score

Minimum Passing Score

ORACLE

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, click Add to add a checklist.

On the Inspection Checklist Details page, enter a checklist ID and description.

Verify that the Enabled switch is turned on. The switch is turned on by default for new checklists.
You can also enter values for these fields:

Description

Enter an assessment type.
The system determines a passing result based on the assessment type defined for the
checklist. The assessment that is defined with system status Pass is used for the passing

result. Otherwise, the assessment that is defined with the system status Fail is used.

Assessment types function independently of the scoring method, maximum score, and
minimum score.

See Setting Up Inspection Assessment Types.

Enter the maximum score possible for the checklist. This value is required if the scoring
method is Top down, which will be available in a future release.

Enter a minimum score for a passing grade. This value is required for the scoring
method Bottom up.
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6.

Page Element Description

If the total score for the checklist is equal to or greater than the minimum passing score,
the checklist receives a passing result.

Scoring Method Select a scoring method to be used for the checklist:

o Bottom up: Scoring from the bottom up indicates that the scoring starts with zero
and the inspector adds points for the criteria that are met.

o Not used: This is the default value and indicates that no scoring method is used for
this checklist. You must specify the result manually for each level: checklist item,
checklist, and inspection.

If you don't use the scoring method you can’t use the passing rule and rating
method. This also means that results are not automatically calculated starting with
the checklist items to the checklist to the inspection level.

Note:
f The scoring method specified for the checklist should match the scoring
method in the Inspection Type definition.

Comment Enter any additional information.

Click Save.

Adding Inspection Checklist Items

1.
2
3.

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the row for the checklist to which you want to add checklist items.
On the Inspection Checklist Details page, click the Add button in the Checklist Items section to add the first
checklist item. Click the Add icon for additional checklists.

Enter values for fields on the Checklist Item Details page. Required fields include the checklist item ID and
description.

Page Element Description

Checklist Item and Description Enter an ID and description for the checklist item.

Score Enter the score the item receives if it passes the inspection.

Major Violation Turn on the switch to indicate that this checklist item is considered a major violation if it

does not pass inspection.

Category and Subcategory Enter a category and subcategory for the checklist item. See Setting Up Inspection
Checklist Categories.
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Page Element Description
Instructions Click the Add button in the Instructions section to add instructions for inspecting the

6.

checklist item.

Add instructions on the Instruction Details page, including an instructions ID and the
instructional text.

The Required switch is turned on by default to indicate that the inspection of the item is required. The
inspector can’t submit the inspection result until all required checklist item and checklist results are complete.

If the checklist item is not required, you can turn off the switch.
Click Save.

Modifying or Deleting Checklists

UubhWNa

o

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the row for the checklist you want to modify.

On the Inspection Checklist Details page, you can change the values for all fields except for the checklist ID.
If you made any changes, click Save.

If you want to delete the checklist, click Delete.

?* Note: When you delete a checklist, all associated checklist items are also deleted.

If you want to delete multiple checklists, you can delete them from the Inspection Checklist page:

a. Click the Edit icon.
b. Select the check boxes for the checklist rows to delete.
c. Click the Delete icon.

Modifying or Deleting Checklist Items

NOoOUuhAWNRA

8.

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the checklist row associated with the checklist item.

On the Inspection Checklist Details page, select the row for the checklist item in the Checklist Items section.
On the Checklist Item Details page, you can change the values for all fields except for the checklist item ID.

If you made any changes, click Save.

If you want to delete the checklist item, click Delete.

If you want to delete multiple checklist items, you can delete them from the Inspection Checklist Details page
using the Edit and Delete icons.

Click Save.

Modifying or Deleting Checklist Item Instructions

P UN

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the checklist row.

On the Inspection Checklist Details page, select the row for the checklist item that contains the instructions.
On the Checklist Item Details page, select the row for the instructions that you want to modify or delete.
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Change the instructional text on the Instruction Details page. You can’t change the instructions ID.
If you made any changes, click Save.
If you want to delete the instructions, click Delete.

If you want to delete multiple instructions, you can delete them from the Checklist tem Details page using the
Edit and Delete icons.

Click Save.

Setting Up Inspection Checklist Groups

A checklist group comprises inspection checklists that you can associate with a permit. You define a checklist group by
selecting one or more inspection checklists.

You set up inspection checklist groups on the Checklist Group page.

Before setting up inspection checklist groups, you must set up your checklists on the Inspection Checklist page. See
Setting Up Inspection ChecKlists.

Adding Inspection Checklist Groups

7.

cCUupUNRR

Select Inspection Setup > Checklist Group .

On the Checklist Group page, click Add to add a checklist group.

On the Checklist Group Details page, enter a name and a description for the group of inspection checklists.
Click Save.

To add an inspection checklist to the group, click Add in the Checklists section.

On the Checklist Details page, enter the ID for an existing checklist in the Checklist field.

The description for the checklist ID you entered appears in the Description field.
Click Save.

Modifying Inspection Checklist Groups

You can modify or delete checklist groups and lines on the Inspection Checklist Group page.

1
2.
3.

4.

Select Inspection Setup > Checklist Group .
On the Checklist Group page, select the row for the checklist group that you want to modify.

On the Checklist Group Details page, you can only modify the checklist group description. You cannot change
the group name.

Click Save to save any changes.

Deleting Inspection Checklist Groups

P UWUN

Select Inspection Setup > Checklist Group .

On the Checklist Group page, select the row for the checklist group that you want to delete.

On the Checklist Group Details page, click Delete.

If you want to delete multiple checklist groups, you can delete them from the Checklist Group page:

a. Click the Edit icon.
b. Select the check boxes for the checklist group rows to delete.
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c. Click the Delete icon.

Removing Inspection Checklist from an Inspection Checklist Group

f Note: You cannot modify inspection checklists on the Inspection Checklist Group pages; you can only remove
them from the group.

1. Select Inspection Setup > Checklist Group .
On the Inspection Checklist Group page, select the row for the checklist group from which you want to remove
one or more inspection checklists.

3. Onthe Inspection Checklist Group Details page, select the row for the inspection checklist that you want to
remove from the group.

4. On the Inspection Checklist Details page, click Delete.

5. If you want to remove multiple inspection checklists from the group, you can delete them from the Inspection
Checklist Group Details page:

a. Click Edit in the Inspection Checklists section.

b. Select the check boxes for the inspection checklist rows to delete.
c. Click Bulk Delete.

d. Click Save.

Setting Up Inspection Types

Define inspection types used by your agency to identify the requirements and options for different types of inspections.
You set up information such as scheduling, assessments, checklists, billing, signatures required, and comments on the
Inspection Type pages.

The inspection type is associated with the permit for the scheduled inspection and defines the different attributes for
performing the inspection.

This example illustrates the Inspection Type Details page containing the field values described in the following table.

Inspection Type Details
* Inspection Type BV_InsBuilding Enabled D
* Description  Building Inspection * Estimated Duration in Hours 4
* Autonumber Rule  BVTEST Q
Scheduling Method  Schedule v Scoring Method  Not used
Rating Method o Passing Rule o
Checklist Group E2E_INSP_CHKLST o Checklist o
Billable Bill Type N
Policy Name Assessment Type  E2E_PassFail SN
Inspector Signature Optional v Policy Version
Contractor Signature Optional v Owner Signature Optional
Inspection District Type  BV_DISTRICTTYPE o Schedule Cutoff Time  6:00 PM ®
Hide Inspector Comments Schedule Change Policy 1
Concel | Dok
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Note: When you modify an inspection type, the updated values are applied to new inspections using the

f inspection type. Existing inspections use the original inspection type definition. This does not apply to the
Schedule Cutoff Time and Schedule Change Policy fields, which are referenced when the inspection is
scheduled and not stored on the inspection itself.

Adding Inspection Types

You add inspection types for your agency on the Inspection Type page. You must set up the attributes for the inspection

type before you begin.

1. Select Inspection Setup > Inspection Type.
2. On the Inspection Type page, click Add New to add a new inspection type.

3. Enter values for fields on the Inspection Type Details page. Required fields include Inspection Type and
Description, Estimated Duration in Hours, and Autonumber Rule.

Page Element

Inspection Type and Description

Estimated Duration in Hours

Scheduling Method

Assessment Type

Passing Rule

ORACLE

Description

Enter a unique ID and description for the inspection type.

Enter the estimated number of hours this type of inspection will take.

This field is required for scheduling. For more information, see Setting Up Inspection
Scheduling.

Select the scheduling method for inspections associated with this inspection type.
Select Ready to enable applicants to indicate the date and time when the site is ready to
be inspected. Inspections with this scheduling method are assigned and scheduled by

inspection supervisors using the supervisor calendar.

Select Schedule to enable applicants to select a date and time when requesting
inspections.

Select Request to enable applicants to select a preferred date and time range for
requested inspections. Inspections with this scheduling method are assigned and

scheduled by inspection supervisors using the supervisor calendar.

For more information on inspection scheduling, see Setting Up Inspection Scheduling
and Assigning Inspections Using the Supervisor Calendar.

Enter an assessment type, which is used in the inspection result processing.

For more information, see Setting Up Inspection Assessment Types.

Enter a passing rule, which defines the criteria for determining whether an inspection
passes or fails.
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Rating Method

Scoring Method

Autonumber Rule

Checklist Group

Checklist

Billable

Bill Type

ORACLE

Chapter 6
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Description

For more information, see Setting Up Passing Rules.

Enter a rating method, which defines the scoring ranges used by the passing rule to
determine whether an inspection passes or fails.

You must set up a rating method if you are using scoring. For more information, see
Setting Up Rating Methods.

Select a scoring method from these options:

o Bottom up: Scoring bottom to top indicates that the inspector starts with zero
and adds points for each criterion that is met. You must set up a passing rule for
bottom up scoring.

o Not used: This is the default value and indicates that no scoring method is used for
this inspection. You must specify the result manually for each level: checklist item,
checklist, and inspection.

If you don'’t use the scoring method you can't use the passing rule and rating

method. This also means that results are not automatically calculated starting with
the checklist items to the checklist to the inspection level.

Note:
f The scoring method specified for the checklist should match the scoring
method in the Inspection Type definition.

Enter the ID for the automatic numbering rule to use for generating the inspection
transaction key.

For more information, see Setting Up Autonumbering.

You can enter a checklist group. If you enter a checklist group, you cannot also enter a
checklist ID.

For more information, see Setting Up Inspection Checklist Groups.

You can enter the ID for a single checklist. You cannot enter both a checklist group and a
checklist ID.

For more information, see Setting Up Inspection Checklists.

Click this slider if this inspection type is billable. When you turn on this switch, the Bill
Type field becomes required.

Enter a bill type. This field is required if the Billable switch is turned on.
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Policy Name and Policy Version

Inspector Signature
Owner Signature

Contractor Signature

Schedule Cutoff Time

Inspection District Type

Schedule Change Policy

ORACLE
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Description

For more information, see Setting Up Bill Types.

Enter the name of the template and version number the Oracle Intelligent Advisor
policy.

For more information, see Overview of Oracle Intelligent Advisor Configuration.

Select a signature option for the inspector, owner, and contractor associated with the
inspection type:

o Required: The signature field appears on the Inspection Results page.

Note:
f Inspectors can't submit a completed inspection if required signatures are
missing.

o Not Required: The signature field does not appear on the Inspection Results page.
o Optional: A signature is optional for this inspection type.

The default value for the Inspector Signature is Required.

The default value for the Owner Signature and Contractor Signature is Optional.

Enter the time after which applicants and non-supervisor agency staff can no longer
schedule inspections for the current day or the next day using the Scheduling modal
page. For example, if the cut off is 3:00 PM and the current time is 4:30 PM, the
inspection can't be scheduled for today or tomorrow. The inspection must be scheduled
for the day after tomorrow.

Note:
. This field does not affect an inspection supervisor’s ability to override
f inspection assignment times through the Scheduling modal page. It also does
not affect automatic batch assignment.

Enter the inspection district type for this inspection, for example a building, electrical,
or plumbing inspection district. When the inspection with this inspection type is
scheduled, the system finds the inspector who is assigned to a district belonging to the
inspection district type defined on the inspection type.

This field is required for scheduling. For more information, see Setting Up Inspection
Scheduling.

Enter the acceptable number of hours prior to the inspection that the user can change
the schedule or cancel an inspection.
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Page Element Description

For more information, see Setting Up Inspection Scheduling.

Hide Inspector Comments Turn on this switch if you want to hide inspector comments from public users. The
default value for this switch is off so that inspector comments are visible.

4. Verify that the Enabled switch is turned on if you want to enable this inspection type when you save it. The
switch is turned on by default for a new inspection type.
5. Click Save.

Modifying or Deleting Inspection Types

You can modify or delete inspection types on the Inspection Type page.

1. Select Inspection Setup > Inspection Type .

2. On the Inspection Type page, select the row for the inspection type you want to modify.

3. Onthe Inspection Type Details page, you can change the values for all fields except for the inspection type
code.

4. If you made any changes, click Save.

5. To delete the inspection type, click Delete.

6. If you want to delete multiple inspection types, you can delete them from the Inspection Type page:

a. Click the Editicon.
b. Select the check boxes for the inspection type rows to delete.
c. Click the Delete icon.

Setting Up Inspection Groups

An inspection group identifies a group of inspection types associated with a permit. You can set up inspection groups
on the Inspection Group page.

The inspection group includes one or more inspection types. You can define inspection groups separately from permit
type definitions.

Before setting up inspection groups, you must set up inspection types for your agency on the Inspection Type page. See
Setting Up Inspection Types.

Adding Inspection Groups

Select Inspection Setup > Inspection Group .

On the Inspection Group page, click Add to add a new inspection group.

On the Inspection Group Details page, enter a name and a description for the inspection group.
Click the Enabled switch to enable the new inspection group.

To add inspection types to include in the group, click Add in the Inspection Types section.
Enter values in the columns of the inspection type row:

cCUuAUWNRA
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a. Inspection Type: Enter an existing inspection type.

The description for the inspection type you entered will appear in the Description field.
b. Required: Click the switch if the inspection type is required for the inspection group.

?9 Note: Even if an inspection type is not required, it may become required based on business
rules during processing.

c. Final Inspection: Click the switch if this inspection type is the final inspection. One and only one row
must be set as the final inspection.

d. Click the Add icon to add another type; otherwise, click Save.
On the Inspection Group Details page, click Save.

Modifying or Deleting Inspection Groups

You can modify or delete inspection groups on the Inspection Group page.

1.
2.

w

NOo U b

10.
1n.

Select Inspection Setup > Inspection Group .
On the Inspection Group page, select the inspection group that you want to modify.

On the Inspection Group Details page, you can only modify the inspection group description. You cannot
change the group name.

Click the Enabled switch to enable or disable the inspection group.

If you want to delete the inspection group, click Delete on the Inspection Group Details page.

Click Save to save any changes.

If you want to delete multiple inspection groups, you can delete them from the Inspection Group page:

a. Click Edit.
b. Select the check boxes for the inspection group rows to delete.
c. Click Delete.

In the inspection types grid, you can:

a. Click the Required switch to enable or disable an inspection type.

b. Click the Final Inspection switch to set an inspection type as the final inspection. One and only one row

must be set as the final inspection.
c. Click Add to add a new inspection type row.
d. Click the Delete icon at the end of the row to remove an inspection type from the group.

f Note: You cannot change the inspection type ID or description, but you can remove an inspection
type and add another.

Click Save to save any changes.
If you want to remove an inspection type from the group, click Delete.

If you want to remove multiple inspection types from the group, you can delete the rows from the Inspection
Group Details page:

Click Edit.

Select the check boxes for the inspection type rows to delete.
Click Delete.

Click Save.
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Setting Up Inspection Calendars

Inspection calendars establish the days of the week and daily hours that are available for scheduling specific types of

inspections.

Administrators add, modify, and delete inspection calendars on the Inspection Calendar page.

Adding an Inspection Calendar

1. Select Inspection Setup > Inspection Calendar.
2. Onthe Inspection Calendar page, click Add.
3. On the Inspection Calendar Details page, enter values for the following fields:

Page Element

Calendar ID

Inspection Type

Inspection District

Description

Start Date

End Date

Start Time and End Time

ORACLE

Description

Enter a unique ID for the calendar.

Select the type of inspection to which this calendar applies.

For more information on inspections types, see Setting Up Inspection Types.

Select the district to which this calendar applies.

Note:
A small municipality may have only one defined district ID that includes its
® entire inspection area. A large municipality may have multiple defined district
? ID. This enables you to create inspection calendars for different areas to
optimize your distribution of resources.

For more information on districts, see Setting Up Districts.

Enter a description for the calendar. For example, you might enter Final fence inspection
calendar.

Enter the first day of the calendar.

Enter the last date of the calendar. You can leave this field blank to give the calendar an
open end date.

Enter the start and end time for the calendar. For example, you might enter a start time
of 09:00 and an end time of 16:00.
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Page Element Description
Recurrence Select whether the calendar reoccurs weekly. If you select Weekly recurrence, enter the

number of weeks between occurrence in the Weeks Between Occurrences field.

Weeks Between Occurrences Enter how many weeks are between each occurrence. For example, if you select a
recurrence of Weekly with 1 week between occurrences, the calendar repeats every
week.

Note:

When the recurrence frequency for an inspection calendar is greater than 1,
the first week of scheduling is the week that contains the start date, where
Sunday is considered the first day of the week. Therefore, it is recommended
that you set the start date to the Sunday of the first week in which you want to
schedule inspections.

For example, you create an inspection calendar for Mondays and Fridays

f where the recurrence frequency is 2, alternating weeks. Setting the calendar
start date to January 1, 2019 causes January 4, 2018 to be available for
scheduling but not December 31, because it is before the start date. Also,
January 7 and 11 are in the alternate week, so the next days available for
scheduling are January 14 and 18. If you set the start date to January 5, which
is still part of the first week that the calendar is active, the system considers
this same week as the start week, but no days are available until January 14
and 18.

Inspection Days Select the days of the week that are available for inspection scheduling.

4. C(lick Save.

Note: For overnight inspection calendars that go past 12 a.m. (midnight), you must create two calendars:
one for the time period up until midnight, and one for the time period after midnight. For example, to create

f a weekday overnight calendar that starts at 09:00 p.m. and ends at 05:00 a.m. the following day, the first
calendar would have a start time of 09:00 p.m. and an end time of 12:00 a.m. on Monday, Wednesday, and
Friday. The second calendar would have a start time of 12:00 a.m. and an end time of 05:00 a.m. on Tuesday,
Thursday, and Saturday.

Modifying an Inspection Calendar

1. Select Inspection Setup > Inspection Calendar.
2. (Click a row on the Inspection Calendar page.
3. On the Inspection Calendar Details page you can:

o Update the inspection calendar field values.
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f Note: You cannot edit the Calendar ID.

o Delete the calendar. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Inspection Calendars

Select Inspection Setup > Inspection Calendar .

Click Edit.

Select the check boxes next to all the inspection calendars you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

P UWN

Setting Up Inspection Scheduling

When agency users and registered public users schedule an inspection, the system is actually determining which
inspectors are available and qualified to perform the inspection. Therefore, to schedule inspections, it is necessary to
define all of the appropriate employee data for inspectors.

Inspectors are considered qualified if they have been assigned the inspection type and district associated with the
inspection. The availability of inspectors is based on their work schedules and whether they have been assigned to
other inspections previously.

In addition, the time slots that are available for scheduling are impacted by inspection calendars and holiday calendars,
which define when inspections can and can’t be performed, respectively.

The system determines which inspectors can be scheduled to perform an inspection based on two sets of criteria.

1. Qualifications: To be qualified to perform an inspection, agency staff must be defined as inspectors, and
assigned to inspection types, districts and work schedules.

2. Availability: Agency holidays and inspection calendars, inspector work schedules, and existing inspector
assignments determine the availability of inspectors.

The following table lists the different types of data that need to be defined so that the system can determine inspector
qualifications and availability. The Frequency column lists how many instances of the data type can be defined. The
Required column lists whether a data type is required for time slots to appear on the Scheduling modal page during
inspection scheduling.

For more information on inspection requests see Requesting Inspections.

Criteria Type Data Type Frequency Required Impact of Missing Data

Quialification Inspection Type One per inspection Yes Only defined inspection
types are available to
select when requesting
inspections. The Select a
Time button is not available
if the inspection type’s
scheduling method is not
Schedule.
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Criteria Type

Qualification

Quialification

Quialification

Qualification

Availability

Availability

Availability

Availability

Availability

ORACLE

Data Type

District

Inspectors

Assigned Inspection Type

Assigned Inspection District

Work Schedule

Assigned Work Schedule

Inspection Calendar

Assigned Inspection

Holiday Calendar

Frequency

One per inspection

Note that the address
selected for the inspection
needs to be associated to
a property for which there
is an assigned inspection
district.

One per employee who
performs inspections

One or more per inspector

One or more per inspector

One or more for each
period of the day inspectors
work; may include one
break

One or more per inspector

One or more for each
combination of inspection
type and district

Automatically created when
an inspection is assigned

One per agency

Required

Yes

Yes

Yes

Yes

Yes

Yes

No

No

No

Chapter 6
Setting Up Inspections

Impact of Missing Data

No scheduling times are
available on the Scheduling
modal page.

Note that the inspection
type and a property
associated with the permit
must have the same
district type. If they don't,
the Select a Time button
is unavailable for the
inspection request.

No scheduling times are
available on the Scheduling
modal page.

No scheduling times are
available on the Scheduling
modal page.

No scheduling times are
available on the Scheduling
modal page.

Note that the assigned
inspection district and the
property associated with
the permit must have the
same district type. If they
don't, the Select a Time
button is unavailable for the
inspection request.

No scheduling times are
available on the Scheduling
modal page.

No scheduling times are
available on the Scheduling
modal page.

The inspection can be
scheduled at any time
of day (or whenever
inspectors are available).

No time slots are
unavailable for scheduling
due to previously assigned
inspections.

No days are unavailable for
scheduling due to holidays
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Criteria Type Data Type Frequency Required Impact of Missing Data

or other agency non-
working days.

Inspection Types

You define inspection types using the Inspection Type page. The system uses the estimated duration to determine
whether an inspector is available for the entire time required to complete an inspection. The inspection district type is a
pre-defined district type with the category of Inspection.

For more information on inspection types, see Setting Up Inspection Types.

Inspection Districts

You must create an inspection district and assign it to inspectors to enable qualified inspectors and make time slots
available when scheduling inspections. The district for the inspection is based on the district type assigned to the
inspection type. The system uses this district type to determine the district ID associated with the property for which an
inspection is being scheduled. A property may have more than one district type associated with it, but only one of them
has a district type category of Inspection.

The system determines the property for the inspection based on the inspection address. The address for a new
inspection defaults to the primary address associated with the permit for which you are scheduling an inspection.
You may select other addresses that are associated with the permit. If no address is associated with an inspection,
the system can’'t determine the district for the inspection so the Select a Time and Select a Different Time buttons are
disabled.

For more information on district types, districts, parcels, and addresses see:
- Setting Up District Types
« Setting Up Districts
« Assigning Districts to Parcels

« Assigning Districts to Addresses

- Setting Up Property Addresses

Work Schedules

You must create work schedules and assign them to inspectors to make the inspectors available for inspection
scheduling.

f Note: If the recurrence for a work schedule is Weekly, and the weeks between occurrences is greater than 1,
the system uses the week of the valid from date as the starting point for scheduling.

For more information on work schedules, see Setting Up Work Schedules.

Inspectors

To make inspectors available for inspection scheduling, you must perform the following steps on the Agency Staff page:

- Assign the ORA_BUILDING_INSPECTOR job function to the inspector.
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- Assign inspection types to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job
function.

- Assign inspection districts to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job
function.

- Assign work schedules to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job
function.

For more information on assigning job functions and job attributes to agency staff, see Setting Up Agency Staff.

Inspection Calendars

Setting up inspection calendars is optional for scheduling inspections. Without inspection calendars, however, the
system can potentially allow inspections to be scheduled for any time during a 24 hour period, if there are work
schedules that comprise all 24 hours.

You define inspection calendars for a specific combination of inspection type and district. You can define more than one
calendar for the same inspection type and district.

For more information on inspection calendars, see Setting Up Inspection Calendars.

Holiday Calendar

Setting up holiday calendars is optional for scheduling inspections. Holiday calendars establish the days that agency
offices are closed and no field service operations are offered. The dates established as events on the holiday calendar
are not available for inspection scheduling regardless of how the inspection calendars or work schedules are defined.

For more information on holiday calendars, see Setting Up Holiday Calendars.
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7 Managing Audit Policies

Implementation Concepts for Audit Policies

This topic discusses audit configuration for business object attributes.

Audit enables tracking the change history of particular attributes of a business object. However, those objects and their
attributes must be selected for audit and auditing must be enabled for that application. Your configuration settings
determine which attributes to audit for a given object, and when the audit starts and ends. Auditing takes into account
all the operations performed on an object and its attributes, such as create, update, and delete. To configure audit
business object attributes, use the Manage Audit Policies task in the Setup and Maintenance work area.

Selecting an Application

To set up auditing, you must select a web application that contains the required business objects that can be audited.
From the list of business objects, select those business objects that you want to audit. Selecting a business object also
displays its attributes that are enabled for auditing.

Selecting Attributes

For each selected business object to be audited, select the corresponding attributes to include in the audit. All attributes
that belong to that object are by default selected for audit and appear on the user interface. However, you can add or
remove attributes from the list. When you remove an attribute from the list, you stop auditing it even when the parent
object is selected for audit. So, if you want an attribute to be audited, you must add it to the list. If the object selected in
an audit hierarchy is also a part of several other audit hierarchies, the attribute configuration for that object is applicable
to all the hierarchies in that application.

7 Tip: For business objects based on flexfields, select the Flexfields (Additional Attributes) check box to view
- and add or remove flexfield attributes, to include or exclude them from the audit.

Starting and Stopping Audit

The business object is ready for audit after you select its attributes and save the configuration changes. However, to
start auditing, the audit level for Oracle Applications Cloud must be set to Auditing on the Manage Audit Policies page.

To stop auditing an object, you can deselect the entire object and save the configuration. As a result, all its selected
attributes are automatically deselected and are not audited. To continue to audit the business object with select
attributes, deselect those attributes that are not to be audited. When users view the audit history for an application, they
can specify the period for which they want the results. Therefore, make a note of when you start and stop auditing an
application.

For example, users intend to view the audit history of an object for the previous week, but auditing for that object was
stopped last month. They wouldn't get any audit results for that week, because during the entire month that object
wasn't audited. Even if you enable audit for that object today, users can't get the wanted results because audit data until
today isn't available.
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Audit Configuration for Oracle Fusion Middleware Products

To set up auditing for Oracle Applications Cloud, select the Manage Audit Policies task from the Setup and
Maintenance work area within your offering. To set up auditing for Oracle Fusion Middleware products, select the
level of auditing mapped to a predefined set of metadata and the events that have to be audited. Information about
configuring audit for Oracle Fusion Middleware products is provided in Oracle Fusion Middleware guides.

You can also create a configuration file and deploy it to audit a specific Oracle Fusion Middleware product. The
configuration details for Oracle Fusion Middleware products are available as audit-specific assets that you can use to
create the config.xml configuration file. To get a list of audit-specific assets, see Audit Events for Oracle Applications
Cloud Middleware (Doc ID 2114143.1) on My Oracle Support at https://support.oracle.com.

- Oracle Fusion Middleware Products
Configure business objects to enable auditing in Oracle Fusion Middleware products. Refer to the Oracle Fusion
Middleware Security and Administrator's Guide for Web Services.

- Oracle Fusion Security Products

Configure business objects to enable auditing in Oracle Fusion security products. Refer to Oracle Fusion
Middleware Application Security Guide.

Using Auditing to Monitor Changes

You can enable business objects to allow auditing, recording, and retrieving information about when the objects were
created, modified, and removed.

Audit Policies Overview

Auditing is used to monitor user activity and all configuration, security, and data changes that have been made to an
application. Auditing involves recording and retrieving information pertaining to the creation, modification, and removal
of business objects. All actions performed on the business objects and the modified values are also recorded. The audit
information is stored without any intervention of the user or any explicit user action.

Use audit policies to select specific business objects and attributes to be audited. The decision to create policies usually
depends on the type of information to be audited and to the level of detail required for reporting.

Enabling Audit Functionality

For Oracle Applications Cloud, you must configure the business objects and select the attributes before enabling audit.
If you enable audit without configuring the business objects, auditing remains inactive. By default, auditing is disabled
for all applications. To enable and manage audit, ensure that you have a role with the assigned privilege Manage Audit
Policies (FND_MANAGE_AUDIT_POLICIES_PRIV). For appropriate assignment of roles and privileges, check with your
security administrator.

If you don't want an object to be audited, you can stop the audit process by setting the Audit Level option to None.

Business Objects for Auditing

The following table shows the business objects you can enable for auditing.
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Area Parent Objects Child Objects
Permits Fee Schedule Default Fee Item
Planning and Zoning Effective End Date

Effective Start Date

Fee Schedule

Refund Fee Item

Permits Fee Line Model Name

Planning and Zoning Service Name
Space ID
Space Name
Version

Effective End Date
Effective Start Date
Fee Schedule

Fee Items

Pay Now
UseAmend
UseOrig

UseRenew

Auditing Community Development Data

You use auditing to monitor data changes that have been made to fee schedules.
To enable auditing for Community Development Data:
1. Signin as a setup user.
Select Setup and Maintenance and go to the following:
o Offering: Public Sector Permits
o Functional Area: Application Extensions
o Task: Manage Audit Policies

In the Manage Audit Policies page, click Oracle Fusion Applications, to configure the required audits.
Click Configure Business Object Attributes.

On the Configure Business Object Attributes page, select Permits from the drop-down list of products.
Select from the list of objects in the Audit Name column.

cuvhuw
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Objects Category Parent Object Child Object
Permits Permits Permit Details
Fee Schedule Fee Schedule Fee Items

7. Inthe Audited Attributes area, click the Add icon.

The Select and Add Audit Attributes dialog box opens.
8. Select the desired attributes.
9. Click OK.

The selected attributes are displayed in the Audited Attributes area.
10. Click Save.

Related Topics
« Implementation Concepts for Audit Policies

Auditing Custom Object Data

You can use Oracle Fusion Applications auditing features to configure auditing for user-defined business object
attributes generated by your intake forms.

This topic describes how to:
- Configure business object attribute auditing for specific transaction types.

Run an audit report for specific transaction types.

You use the Oracle Fusion Applications auditing features to set up auditing for Public Sector Compliance and Regulation
business objects.

Transaction-Specific Auditing Scope

A specific transaction type, such as a permit or a planning application are the business objects you can audit. Each
transaction type, such as a permit, contains a limited set of fields that you can audit, which include:

User-defined fields. These are the fields you added manually to your intake form.

Fields from the base view object for that transaction type. These fields are the same for all transaction types,
and they appear in the attributes list regardless if they appear in the intake form or not.

The transaction types included for custom object auditing are:

Permits

Planning and Zoning
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f Note: You will see Code Enforcement business objects in the list, but these objects are not supported for
auditing at this time. You can select them but the attributes list will be empty.

You can audit other aspects of transaction data, such as changes to fee schedules and fee items, which is discussed in
another topic. For more information, see Auditing Community Development Data.

o Note: The fields added to your intake forms by the field groups you’'ve added are not currently available to be
#  audited. Fields added to the intake form by field groups reside in a child table to the base view object for the
transaction type. Auditing fields in child tables is not currently supported.

To determine what fields in a specific transaction are able to be audited, you can use any REST client to submit a
describe for that transaction type. For example, you can send a GET request using the following URL:

https://servername.fa.us2.oraclecloud.com/fscmRestApi/resources/11.13.18.05/LNPFENCEPERMIT c/describe

Where FENCEPERMT is the name of the transaction type. LNP is prepended and _c is appended automatically by the
Intake Form Designer.

The attributes appearing in the returned payload of the describe that can’t be audited appear within the FieldGroups
section. For example:

“FieldGroups” : {
“discrColumnType” : false,
“title” : “Permit Details”,
“attributes” : [ {

Configuring Business Object Attribute Auditing for a Specific Transaction
Type

?’ Note: Before you can begin setting up auditing for a specific transaction type, the intake form needs to be
published.

To configure auditing for a specific transaction type:

1. Access Functional Setup Manager.

2. Open your licensed offering from the Setup list, such as Public Sector Permits or Public Sector Planning and
Zoning.

3. Select the Application Extensions functional area, and click the Manage Audit Policies task.

f Note: You can use the Search Tasks feature as well to navigate to the Manage Audit Policies task.

On the Manage Audit Policies page, locate the Oracle Fusion Applications group box.
To enable auditing, set Audit Level to Auditing.
Click Configure Business Object Attributes.

On the Configure Business Object Attributes page, select Supply Chain Management Common Components
from the Product drop-down list, and expand the FscmCustomReferenceAuditAM node.

NS vk
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Note: The Public Sector Compliance and Regulation offering resides in the Oracle Fusion Applications
Financials and Supply Chain (FSCM) database. When searching for Public Sector Compliance and

f Regulation custom business objects, you will find them within the Supply Chain Management
Common Components section. If you are also an Oracle FSCM customer, you will see FSCM
business objects mixed with your Public Sector Compliance and Regulation products within the
FscmCustomReferenceAuditAM node.

8. Click the business object for which you want to configure auditing.

The business object name is the same as your transaction type code, such as the Permit Type value on the
Permit Type page.
9. With the business object selected, select Actions > Create in the Attribute column on the right.
10. Inthe Select and Add Audit Attributes dialog box, select the attributes you want to audit.

f Note: The attributes available are limited to the base view object values and the custom fields you
have added to your form.

11. Click OK.
12. Save your changes.

For more information, see the Oracle Fusion documentation on business object auditing.

Running an Audit Report

To run an audit report:

Select Navigator > Tools > Audit Reports.

For Date, specify a date or date range for your audit report.

Select Supply Chain Management Common Components from the Product drop-down list.

From the Business Object Type drop-down list, select the permit type name for which you enabled auditing.
Use the Date, User, and Event Type criteria to refine your search, as needed.

6. Click Search.

For more information see the Oracle Fusion Applications documentation for audit reports.

AR WN

Viewing Audit History
You use audit history to view changes to the application data such as the business objects that were created, updated,
and deleted.

Before you begin, you must have a role with the assigned privilege View Audit History
(FND_VIEW_AUDIT_HISTORY_PRIV). For appropriate assignment of roles and privileges, check with your security
administrator.

To view the Fee Schedule audit history or to create a report:

1. To open the Audit History work area, select Setup and Maintenance > Navigator > Audit Reports
2. Enter the following search values:
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Audit Reports Search Field

Date

Product

Business Object Type

Value

Enter the date for the audit results you want to see.

Select Permits.

Select Fee Schedule.

3. Select the option Include child objects. Fee Items is the child object for the Fee Schedule business object type.
The default search displays a summary of the audit history in the search results table. It includes key data such as date,
user, product, event type, business object type, and description. For a detailed report, search again with modified search
criteria. You can export the report summary to Microsoft Excel.

Search Parameter
Business Object Type

Note:

This parameter is applicable only
?9 for the business objects that

belong to Oracle Applications

Cloud.

Include Child Objects

Show Impersonator

Show Attribute Details

Show Additional Object Identifier
Columns

Result of Selection

- Narrows the search results to that specific business object within the selected product.

- Enables the Show Attribute Details check box.

Displays all the child objects that were listed for that business object when audit was set up. For
example, a sales order object that contains several items as child objects.

Note:
?’ Displays the objects at the immediate parent-child level only. To view the children at
subsequent levels, select the child object as the business object type and search again.

Displays the details of the impersonator who modified the objects during an impersonation session.

Enables the attribute list so that users can select either all attributes or a specific attribute to view the
changes. Based on the selection, the search results indicate whether the attribute is created, updated,
or deleted, and the corresponding old and replaced values.

Displays the instances (contexts) in which the business object was used. The context values identify
the objects and the transactions in which they were used. Each context is unique and assigns a unique
description to the business object.

f Note: The default report displays a standard set of columns that contain prominent details of the audit
history. To view additional details, you can change the display of columns.

ORACLE
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8 Modifying Existing Application Pages

Overview of Existing Page Modification
This topic provides an overview of how you can modify an existing page delivered by Oracle in a Public Sector
Compliance and Regulation offering.

You can use the Configure Page feature to modify specific attributes of an existing page delivered by Oracle in a Public
Sector Compliance and Regulation offering. You can make these modifications:

- Change field labels.
Hide fields.

f Note: In the current release, you can modify only the Parcel Details page.

Examples of page modifications include:

- Suppose the existing page has a field label that doesn’t correspond to the terminology used in your agency.
Suppose the delivered field label is Flood Zone, but your agency uses Flood Zone Code. You can use the
Configure Page option to modify the label.

- Suppose the existing page contains a field tracking information your agency does not track, such as the Patio
field. You can use the Configure Page feature to hide that field.

Access Page Edit Mode

This topic describes how to access edit mode for existing application pages that you can modify.
Before accessing edit mode, make sure you are signed on with a user who is assigned one of the following job roles:

PSC Business Analyst
PSC System Administrator

Also, make sure the existing page supports configuration. Not all existing pages can be modified. Pages that can be
modified display the Configure Page icon in the global header.

| f Note: In the current release, you can modify only the Parcel Details page.

This example illustrates the Configure Page icon, which is described in the surrounding text.

Click the Configure Page icon to launch page edit mode.
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Use the Page Edit Mode Interface

This topic describes the features and controls you can use to modify an existing application page.

To access the page edit mode, click the Configure Page icon in the global header. For more information see Access Page
Edit Mode.

This example illustrates the user interface of the page edit mode. Details are in the surrounding text.

Parcel Details | Status: published Toolbar Save Cancel

Field Attributes

Flood Zone Code

P Field Details

Workspace Soil Type Atiributes Panel

When in page edit mode, the interface consists of these items:
- Toolbar

- Workspace
- Attributes Panel

Using the Toolbar

The toolbar spans the top of the interface below the global header and displays the following information and controls.

Page Element Description
Page Name Displays the name of the page as it appears in the application, such as Parcel Details.
Status Indicates the status of the current page.

- Draft: indicates the page is currently being edited, but the current changes are not available for
general use. Draft mode becomes enabled when you click Save when editing a page.

- Published: the page is available for general use with the most current modifications included. In
the development or testing environment, a published page is available for developers and testers
to access and test. In the production environment, a published form is available for end users to
access.
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Page Element

Save

Publish

Cancel

Close

Manage Sandbox

Using the Workspace

Description

Note:
?’ The status is displayed only if you are modifying the page or you have previously modified
and published the page.

Saves the current changes to the page to store them, without publishing them. Clicking Save puts the
page in draft mode.

Click to create a sandbox and publish the current changes in the sandbox so that the page reflects the
changes for runtime access and use.

o Note:
f The Publish button is available only after your have clicked Save.

Click to exit the edit mode without saving or publishing any changes.

Click to exit edit mode.

The Close button appears when there is no change on the page to be saved or published, such as after
you have just published page modifications.

Click to access the Oracle Fusion Applications Sandboxes page where you can view the status of your
sandbox and refresh your sandbox if needed.

When modifying an existing page, the sandbox exists only during the publishing process request.
While you modify a page and save any changes, the system tracks your changes in an internal

metadata storage object. When you click Publish, the changes are added to the sandbox, and the
sandbox is published.

Note:
?’ The Manage Sandbox button appears only if the sandbox associated with your form layout
becomes out of sync during a publish request, requiring a refresh.

Identify the sandbox for your page modifications according to this naming scheme:
PSCSC_<page name>__sb_<number of publish requests>

For example:

PSCSC_ParcelDetailsinformation__sb_2

For more information on sandboxes, see Working with Sandboxes.

The workspace displays the content of the page that you can modify. Select a field on the page to display its attributes in

the Attributes panel.

ORACLE
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Using the Attributes Panel

The Attributes Panel contains the attributes you can modify for a selected page element, such as a field.

This example illustrates the Field Attributes panel when modifying existing pages. Details are in the surrounding text.

Field Attributes

4 Field Details

ParcelVO

ParcelType

?’ Note: In the current release, only fields can be modified on an existing page.

You can view and set these field attributes:

Page Element

Label

Hidden

Business Object

Field Name

ORACLE

Description

Use to modify the existing label for the page.

Note:
The length limit for modified field labels on existing pages is 100 characters.

Note:

Do not change the meaning of a field label in an attempt to use it to reflect a value different
f from its intended purpose. For example, don’t change “Flood Zone” to “School Zone.” Each

field may have logic behind it, dependencies in workflow, dependencies related to fees, and

so on. The ability to change field labels is intended to support minor changes in terminology.

Use to hide a field on the existing page. When the switch is on, the associated field is hidden.

o Note:
? Fields that are set to be required can’t be hidden.

The name of the database view object associated with the page.

The name of the field as it appears in the REST payload, which you can view using a describe
command for the associated REST resource.
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The Business Object and Field Name values are read-only values provided for informational purposes to help
implementation teams assess any areas affected by a page modification, which affects:
- Sub pages using the same view object field
Reporting
- Auditing

f Note: Changes made to a field on an existing page may affect fields appearing within field groups added to
intake forms if they share the same view object.

Modify Existing Pages

This topic describes the steps in the procedure for modifying an existing page delivered in an Oracle Public Sector
Compliance and Regulation offering.

Change Labels

To change a a label:

Navigate to the page you want to modify.

Click the Configure Page button in the global header.

In the workspace, select the field you want to modify.

In the Field Attributes panel, enter your modified label in the Label field.
Click Save.

Click Publish.

Hide Fields

To hide a field:

cuhAhUNA

Navigate to the page you want to modify.

Click the Configure Page button in the global header.

In the workspace, select the field you want to hide.

In the Field Attributes panel, turn on the Hidden switch.
Click Save.

Click Publish.

CUAWNRA

After you have hidden a field, the layout in page edit mode displays the field within a box with a hidden icon
next to the hidden field to indicate its hidden runtime status.

This example illustrates a field on an existing page that has been hidden.

@, Patio
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Managing Existing Page Modifications

This topic describes concepts necessary to keep in mind when migrating existing page modifications between
environments, such as from the test environment to the production environment.

Similar to migrating transaction types from one environment to another, the data related to page modifications gets
migrated in multiple parts using these features:

- Functional Setup Manager’s export and import feature.

- Configuration Set Migration feature, which you access using the Functional Setup Manager step “Manage
Existing Page Modifications” in the System Administration functional area.

Note: The Configuration Set Migration feature migrates all published sandbox changes, not just the
#  modifications to existing pages. For example, current intake form changes and branding image changes will
also be migrated in the configuration set.

Related Topics
- Managing Transaction Type Configurations
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