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Preface

This preface introduces information sources that can help you use the application and this guide.

Using Oracle Applications

This topic explains the text conventions used in this guide and points you to where you can find more information about
using Oracle applications.

Conventions

The following table explains the text conventions used in this guide.

Convention Meaning

boldface Boldface type indicates user interface elements, navigation paths, or values you enter or select.
monospace Monospace type indicates file, folder, and directory names, code examples, commands, and URLs.
> Greater than symbol separates elements in a navigation path.

Additional Resources

- Community: Use Oracle Cloud Customer Connect to get information from experts at Oracle, the partner
community, and other users.

- Guides and Videos: Go to the Oracle Help Center to find guides and videos.

- Training: Take courses on Oracle Cloud from Oracle University.

Documentation Accessibility

This topic covers accessibility concepts for this guide.
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website.

Videos included in this guide are provided as a media alternative for text-based help topics also available in this guide.

ORACLE
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Contacting Oracle

This topic explains how to contact Oracle for support and to provide feedback.

Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For
information, visit My Oracle Support or visit Accessible Oracle Support if you are hearing impaired.

Comments and Suggestions

Please give us feedback about Oracle Public Sector Compliance and Regulation applications help and guides! You can
send an e-mail to: PSCR_US@oracle.com.
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1 Setting Up Transactions

Setting Up Transaction Groups
Transaction groups are the first level of categorization that you can select when you define your business license,
permit, and planning application types.

If desired, you can set up transaction groups. This setup is not required.

Adding Transaction Groups

1. Select Common Setup > Transaction Group .
2. Onthe Transaction Group page, click Add to add a new group.
3. Onthe Transaction Group Details page, enter a values for the group.

Page Element Description

Group Enter a group name for the transaction types.
Description Enter a description of the group.

Applicable Classification Select a product area from these options:

o Business Licenses
o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new transaction group.
5. Click Save.

Modifying Transaction Groups

1. Select Common Setup > Transaction Group .
2. On the Transaction Group page, select the row for the group that you want to modify.
3. Onthe Transaction Group Details page you can:

o Edit the description. You cannot change the group name.

o Select an Applicable Classification check box.

o Click the Enabled switch to enable or disable the transaction group.

4. Click Save to save any changes.

ORACLE
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Deleting Transaction Groups

Select Common Setup > Transaction Group .

On the Transaction Group page, select the row for the group that you want to delete.

If you want to delete the group, click the Delete button.

If you want to delete multiple groups, you can delete them from the grid on the Transaction Group page:

a. Click the Edit icon.
b. Select the check boxes for the transaction group rows to delete.
c. Click the Delete icon.

PUWNa

Setting Up Transaction Categories

Transaction categories are the second level of categorization that you can select when you define your business license,
permit, and planning application types.

If desired, you can set up categories for the different types of business licenses, permits, and planning applications. This
setup is not required.

Adding Transaction Categories

1. Select Common Setup > Transaction Category .
2. Onthe Transaction Category page, click Add to add a new transaction category.
3. Onthe Transaction Category Details page, enter a values for the transaction category.

Page Element Description

Category Enter a category name for the transaction type.
Description Enter a description of the category.

Applicable Classification Select an offering from these options:

o Business Licenses
o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new category.
5. Click Save.

Modifying Transaction Categories

1. Select Common Setup > Transaction Category .
2. Onthe Transaction Category page, select the row for the category that you want to modify.
3. Onthe Transaction Category Details page you can:

ORACLE
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o Edit the description. You cannot change the category name.

o Select an Applicable Classification.

o Click the Enabled switch to enable or disable the transaction category.
4. C(lick Save to save any changes.

Deleting Transaction Categories

Select Common Setup > Transaction Category .

On the Transaction Category page, select the row for the category that you want to delete.

If you want to delete the category, click the Delete button.

If you want to delete multiple categories, you can delete them from the grid on the Transaction Category page:
a. Click the Edit icon.
b. Select the check boxes for the transaction category rows to delete.
c. Click the Delete icon.

PUOUN

Setting Up Transaction Subcategories

Transaction subcategories are the third level of categorization that you can select when you define your business
license, permit, and planning application types.

If desired, you can set up subcategories for the different types of business licenses, permits, and planning applications.
This setup is not required.

Adding Transaction Subcategories

1. Select Common Setup > Transaction Subcategory .
2. Onthe Transaction Subcategory page, click Add to add a new transaction subcategory.
3. Onthe Transaction Subcategory Details page, enter values for the transaction subcategory.

Page Element Description

Subcategory Enter a subcategory name for the transaction type.
Description Enter a description of the subcategory.

Applicable Classification Select a product area from these options:

o Business Licenses
o Permits

o Planning and Zoning

4. Verify that the Enabled switch is turned on. The option is active by default for a new subcategory.
5. Click Save.

ORACLE
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Modifying Transaction Subcategories

1. Select Common Setup > Transaction Subcategory .
2. Onthe Transaction Subcategory page, select the row for the subcategory that you want to modify.
3. On the Transaction Subcategory Details page you can:

o Edit the description. You cannot change the subcategory name.

o Select an Applicable Classification check box.

o Click the Enabled switch to enable or disable the transaction subcategory.

4. C(lick Save to save any changes.

Deleting Transaction Subcategories

Select Common Setup > Transaction Subcategory .
On the Transaction Subcategory page, select the row for the subcategory that you want to delete.
If you want to delete the subcategory, click the Delete button.
If you want to delete multiple subcategories, you can delete them from the grid on the Transaction Subcategory
page:
a. Click the Edit icon.
b. Select the check boxes for the transaction subcategory rows to delete.
c. Click the Delete icon.

PUNa

Setting Up Transaction Statuses

Oracle provides a set of statuses for transactions to control system events. Some system statuses can be mapped to an
agency-defined transaction status.

Your agency assigns statuses for different transactions in the system. You can’t delete the system-delivered transaction
statuses, but you can modify the description. You can also define additional transaction statuses, but you must
associate any new transaction status with one of the system-delivered statuses to ensure correct processing.

Using Delivered Transaction Statuses

This table lists the system-delivered transaction statuses for business licenses, permits, and planning applications, and
indicates whether they can be associated with a user-defined status.

For information about permit inspection statuses, see Setting Up Inspection Statuses.

For information about permit plan review statuses and decision statuses, see Setting Up Plan Review Statuses.

Transaction Status System Status Code Type of Transaction (Business Can be mapped to a user-defined
Licenses, Permits, or Planning record status?
Applications)

About to Expire ATE All No

Active ACT Business Licenses Yes
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Transaction Status System Status Code Type of Transaction (Business Can be mapped to a user-defined
Licenses, Permits, or Planning record status?
Applications)

Application Accepted ACP All Yes

Certificate of Occupancy (ae]6] Permits Yes

Closed CLS Business Licenses Yes

Completed CMP All Yes

Delinquent DLQ All No

Denied DNI All Yes

Expired EXP All No

Hearing HER Planning Application Yes

In Process IPC All Yes

Inactive INA Business Licenses Yes

Inspection INS Permits Yes

Business Licenses

License Issued LCl Business Licenses Yes
Payment Pending PAY All No
Pending PND All No
Pending Submittal PDS All No
Permit Issued PTI Permit Application Yes
Plan Review PLR Permit Application Yes
Revoked RVK Business Licenses No
Submitted SUB All No

ORACLE
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Transaction Status System Status Code Type of Transaction (Business

Suspended SPD

Unreported URT
Voided VoD
Withdrawn WTH

Licenses, Permits, or Planning
Applications)

Business Licenses

Business Licenses

All

All

Chapter 1
Setting Up Transactions

Can be mapped to a user-defined
record status?

No

No

Yes

No

When a guest submits a business license, permit, or planning application, the transaction status is updated as follows:

Record and System Status Description

Pending (PND) Applied when the guest saves an application.

Pending Submittal (PDS) Applied when the guest submits the application and workflow can’t be started.
Payment Pending (PAY) Applied when fees are due.

Submitted (SUB) Applied when no fees are due.

Applied after successful payment.

Adding Transaction Statuses

Define any additional statuses that your agency will use for permit and planning applications on the Transaction Status
page. You must associate a new transaction status with a system status.

P AWAUNA

Page Element

Status

Description

System Status for Business License
Applications

ORACLE

Select Common Setup > Transaction Status .
Select a transaction statuses tab, such as Business License Status, Permit Status, or Planning Status.
Click Add to define a new transaction status.

On the respective transaction details page, enter values for these fields:

Description

Enter a transaction status name.

Enter a description for the transaction status.

Select the business license transaction status that you want to use from the drop-down

list:
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Page Element Description

o Application accepted
o Active

o Closed

o Completed

o Denied

o Voided

o Inactive

o Inspection

o Inprocess

o Licenseissued

Chapter 1
Setting Up Transactions

System Status for Permit Select the permit transaction status that you want to use from the drop-down list:

Applications
o Application accepted

o Completed

o Certificate of occupancy
o Denied

o Voided

o Inprocess

o Permitissued

o Plan review

o Inspection

System Status for Planning Select the planning transaction status that you want to use from the drop-down list:

Applications
o Application accepted

o Completed
o Denied
o Voided

o Inprocess

o Plan review (This status is for future use.)

o Hearing

5. Verify that the Enabled switch is turned on. The switch is turned off by default for a new transaction status.

6. Click Save.

Modifying Transaction Statuses

You can modify the transaction statuses that you have defined for your agency’s transactions on the details pages.

1. Select Common Setup > Transaction Status .

ORACLE
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2. Select a transaction statuses tab, such as Business License Status, Permit Status, or Planning Status.
3. Select the row for the transaction status that you want to modify.
4. On the Details page you can:

o For user-defined statuses, edit the description or the system status that you want to set on a record with
this record status. You can'’t edit the Status field.
o For system-delivered statuses, you can only edit the description. You can'’t edit the Status field.
o Turn on the Enabled switch to enable a user-defined record status. You cannot disable system-delivered
statuses.
5. Click Save to save any changes.

Deleting Transaction Statuses
You can delete the statuses that you have defined for your agency on the Permit Status Details or Planning Status
Details page.

Note: You cannot delete most of the system-delivered statuses; you can only modify their descriptions. Oracle
recommends that you disable statuses instead of deleting them.

Select Common Setup > Transaction Status .
Select a transaction statuses tab, such as Business License Status, Permit Status, or Planning Status.

Select the row for the transaction status that you want to delete.
On the Details page, click Delete, if the button is available.
If you want to delete multiple record statuses, you can delete them from the grid on the Transaction Status

page:

A UN

a. Click the Edit icon.
b. Select the check boxes for the status rows to delete.

c. Click the Delete icon.

Related Topics
« Using Workflow

ORACLE
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2 Setting Up Permits

Setting Up Agency-Level Options

You set up the Oracle Intelligent Advisor for Permits and Planning and Zoning on the Permit Options page during
agency setup. You can also configure the summary title and text for the Anonymous User Landing Page and the
Registered User Landing page.

To configure agency-level options for permits and planning applications:

1.
2
3.

Select Common Setup > Agency .
Click a row on the Agency Information tab.
Select the Features tab.

Oracle delivers the list of offerings on the Features tab. The Permits offering encompasses both Permits and
Planning and Zoning.

Disregard the Enabled column for the Permit offering. The offering is enabled in the Functional Setup Manager
(FSM).

Click Options for the Permits offering.

On the Permit Options page, you can update values for the following fields:

Page Elements Definition

Oracle Policy Automation ID Enter the unique identifier for the Oracle Policy Automation policy model to be used for
this offering.

The offering-specific policy model that you specify here takes priority over any agency-
wide policy definition that you enter on the main Agency Information page.

Message Title Enter a short text version of the landing page message in a title format. If you leave this
field blank, the value in the Label field on the Link Details page for the menu navigation
link Online Permits is displayed.

Message Summary Enter a longer version of the landing page message title in a sentence format. If you
leave this field blank, the value in the Description field on the Link Details page for the
menu navigation link Online Permits is displayed.

Button Content URL Enter a content URL for the Read More button. Public users click this button to access
the agency’s own permit information page, outside of Oracle Public Sector Permits. If
you leave this field blank, the Read More button opens a dialog box that displays the
Landing Page Message.

ORACLE
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Page Elements Definition
Note:
If you want to link to a page outside of Oracle Public Sector Permits, you must enter a
URL here.
Landing Page Message Enter a welcome message in rich text to appear in a dialog box on the landing page, if a

URL to access the agency'’s page is not defined.

For more information on Oracle Intelligent Advisor, see Overview of Oracle Intelligent Advisor Configuration.

For more information on the Landing Page Message Definition, see Defining Summary Details.

Related Topics
» Managing Oracle Intelligent Advisor Policies for your Agency

» Setting Up the Landing Page for Anonymous Users
- Setting Up the Landing Page for Registered Users

Setting Up Plan Review Statuses

Use delivered plan review statuses to identify the progression through a plan review cycle. You can review the statuses
on the status definition pages.

You review the plan review statuses on the Plan Review Status and Decision Status pages. You cannot delete the
system-defined statuses or add new statuses, but you can modify the descriptions. The descriptions allow you to enter
a different status name to be displayed to agency staff.

The system derives the overall plan review status from the individual plan reviewer decisions, and updates the overall
plan review with the most severe decision status. The system-defined decision statuses are listed here from most to
least severe: Rejected, Revision Required, Approved with Comments, Approved, and Not Required. If plans have one or
more rejections, or revisions are required, the applicant must correct the plans and resubmit them for another review
cycle.

Modifying Plan Review Cycle Statuses

You can edit only the Description field on the Plan Review Status Details page. The agency-defined description is
exposed to agency staff and public users on the plan review pages in the permit record detail.

1. Select Common Setup > Transaction Status .
2. Select the Plan Review Status tab.
3. You can review the delivered review cycle statuses in the Review Status column:

o In Progress

o Canceled

10
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o Completed

4. Select the row for the review status that you want to modify.
5. On the Plan Review Status Details page you can edit only the description.
6. Click Save to save any changes.

Modifying Plan Review Decision Statuses

You can edit only the Description field on the Decision Status Details page. The agency-defined description is exposed
to agency staff and public users on the plan review pages in the permit record detail.

1. Select Common Setup > Transaction Status .
2. Select the Plan Review Decision tab.
3. You can review the delivered plan review decision statuses in the Decision Status column:

o Approved

o Approved with comments
o Revision required

o Rejected

o Not required

The plan review decision statuses are delivered as enabled. The only review decision status that you can disable
is Approved with comments.

Select the row for the decision status that you want to modify.

On the Decision Status Details page you can edit only the description.

Click Save to save any changes.

ounsp

Setting Up Permit Types
Define the types of permits supported by an agency. You add a permit type and associate workflow process definitions
on the Permit Type definition page.

Before you can create an application form, you must first create a permit type on the permit type definition page.

Adding Permit Type Definitions

1. Select Permit Setup > Permit Type > Permits .
2. On the Transaction Type — Permit Types page, click the Add button.
3. Onthe Permit Type page, enter values for the following fields:

Page Element Description

Classification Displays the type of application. The classification for this page indicates this is a permit
application.

Subclassification For use with planning applications. Accept the default value, Not Applicable.

n
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Page Element Description
Permit Type Enter a name for the type of permit type.
Permit Type ID Enter a unique alphanumeric code or short name for the permit type. Do not use special

characters, including symbols or punctuation, or spaces.

Status Select from the following to indicate the permit type status:

o Preliminary: The permit type is being defined but is not available for use.

o Ready: The permit type is ready to be accessed from the landing page for testing
or production use, depending on the environment.

o Void: The transaction type is no longer available.

Note:

The form design can be in published status or draft status and be set to Ready. In
draft status, the form can be accessed from outside the form designer—such as the
Apply page—for testing purposes in the development or test environment.

Form Design Status A read-only field indicating whether the form design is published or currently being
developed.

o Draft: The form design is currently being created or modified. Form designs in
draft status are not migrated to other environments and can’t be cloned.

o Published: The form design is complete. Form designs in published status can be
migrated to other environments and can be cloned.

Autonumber Rule Select the autonumbering rule to increment numbers for permits.
You can delete an autonumbering rule when it isn’t being used by any transaction types.

For more information, see Setting Up Autonumbering.

Valid from Date and Valid to Date =~ Enter a range of dates when this permit type is valid. The default from date is the
current date. The default end date is Open. You can update these dates as needed.

Public User Enabled Select from the following to indicate whether the intake form can be accessed and by
which user types:

o Enabled for all users: Only registered public users and agency users can access the
intake form.

o Enabled for registered users: Only registered public users and agency users can
access the intake form.

o Not enabled for public users (default): Only agency users can access the intake
form.

12
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Page Element

Application Group

Category

Subcategory

Document Group

Inspection Group

Fee Schedule

Bill Type

ORACLE

Description
Note:

Currently, Enabled for all users and Enabled for registered users have equivalent
access.

Select a permit application group that you want to associate with the permit type.

For more information, see Setting Up Transaction Groups.

Select an application category that you want to associate with the permit type.

For more information, see Setting Up Transaction Categories.

Select an application subcategory that you want to associate with the permit type.

For more information, see Setting Up Transaction Subcategories.

Select a document group to manage attachments for the application type.

When you specify a document group, document attachments can be classified into
categories and subcategories during the application process and when you upload
files. Then you can see the category for a document on the attachments page in the

application details.

For more information, see Setting Up Document Groups.

Select an inspection group to associate with the permit type. The inspection group
identifies all inspections necessary for the permit.

For more information, see Setting Up Inspection Groups.

Select a fee schedule that you want to associate with the permit type. A department is
required if the permit type has a fee schedule ID.

For more information, see Setting Up Fee Schedules.

Select a bill type to associate with the permit type.

The billing type identifies the type of invoice that can be generated from the record. The
bill type is required.

For more information, see Setting Up Bill Types.

13
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Page Element Description
Department Select a department that you want to associate with the permit type. A department is

required if you add a Fee Schedule ID to the permit type.

If a department is specified on the Fee Item setup page, the fee item department
overrides the department specified here on the permit type.

For more information, see Setting Up Departments.

Terms of Use ID Select a terms of use definition to associate with the permit type. When you set up
terms of use, you can make the terms available to the public user registration process,
to the permit application process, or to both. The user must accept the terms and
conditions for using online permits.
For more information, see Setting Up Terms of Use.

Description Enter a user-facing description of the permit type. On the Apply page, this description
appears under the permit type name.
The description helps public users understand the purpose of the permit type.

URL Enter a URL for a web page that gives public users more information about the permit
type.

If you enter a URL, then a Learn More link appears at the end of the permit type
description on the Apply page. The user clicks this link to open the specified URL.

If you leave this field blank, the Learn More link is not visible on the Apply page.

Associating a Permit Certificate

First, your agency sets up the certificate template in the reports catalog, then associates the report ID with the permit
type in the Certificate section. When the permit is issued, you can print it from the permit overview page.

Page Element Description

Allow Public User to View Turn on the switch to allow public users to view the issued permit document, which is accessed from
the permit summary on the Overview page.

This option is enabled by default.

Report ID Enter the report ID for the permit template associated with this permit type. Use the delivered permit
report or configure your own. See Setting Up Reports.
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For information about viewing the permit document, see Viewing the Permit Summary.

Setting Up Permit Expiration

In the Expiration section, you can enter the expiration group that defines the expiration rules for permits with this
permit type. Expiration rules determine the expiration dates that correspond to permit activity. For more information
about permit expiration, see Setting Up Permit Expiration Rules.

Setting Up Workflow for a Permit Type

You set up workflow using the Oracle Autonomous Integration Cloud (OIC) before associating the workflow with the
permit type.

For more information, see Setting Up Process Definitions for Workflow.

1. Select Permit Setup > Permit Type > Permits .
2. Onthe Transaction Type — Permits page, click the Add button.
3. Inthe Workflow Setup section on Permit Type page, enter values for the following fields:

Page Element Description

Space Name Enter the space where the workflow process application is stored. You can group
related applications in a space as well as enable users to collaborate when developing
applications.

Application ID Enter the name of the workflow process application in OIC. For more information, see

Creating and Managing Applications.
Version Enter the version of the workflow process application.

Process Definition Enter the name of the workflow process definition that applies to this particular permit.

I Note: Different permit types can utilize the same workflow definition.

Setting Up Plan Reviews for a Permit Type

Define how plan reviews are conducted for permits associated with the permit type.

1. Select Permit Setup > Permit Type > Permits .
2. Onthe Transaction Type — Permits page, click the Add button or select an existing permit type.
3. Inthe Plan Reviews section on Permit Type page, enter values for the following fields:

Page Element Description

Plan Review Type Select the method used for reviewing plans for permits associated with the permit type.
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Enable Auto Assignment

Plan Reviewer Departments

ORACLE

Description

o Manual: Plan reviews are tracked as part of permitting workflow, but are performed
without the use of integrated electronic document review software.

o Not Used: Plan reviews are not tracked as part of permitting workflow.

o Electronic: Plan reviews are tracked as part of permitting workflow, and are
performed through integration with electronic document review software.
For more information on plan reviews, see Managing Manual Plan Review Cycles and

Managing Electronic Plan Review Cycles.

Turn on this switch to enable the automatic assignment of plan reviewers for permits
associated with this permit type.

When this switch is on and a permit technician gives a permit associated with this
permit type a status of Accepted - Plan Review Required, the automatic assignment
process:

a. Adds a reviewer row to the plan review cycle for each plan reviewer department
selected for the permit type. If no plan reviewer departments are selected for
the permit type, the process creates the plan review cycle, but doesn’t add any
reviewer rows.

b. Adds the designated department lead to the Reviewer field for each reviewer row.
If a department doesn’t have a department lead selected, the process still creates a
row for the department, but leaves the Reviewer field blank.

Note:
This switch is available only when the Plan Review Type is Manual.

Select the departments that should be included in any plan reviews associated with
this permit type. Plan coordinators should add a reviewer from each of the required
departments. The Reviewers grid of the Plan Review page displays the required
departments that you select here.

When Enable Auto Assignment is turned on, the process automatically adds a plan
reviewer row to plan review cycles for each of the selected departments.

Note:
A plan reviewer department is available to select only if the Permits classification is
selected for it on the Plan Reviewer Department page.

For more information about plan reviewer departments, see Setting Up Plan Reviewer
Departments.

For more information about plan reviews, see Electronic Plan Review Process Flow and
Manual Plan Review Process Flow.

Chapter 2
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Cloning Permit Types

Click the Clone button to create a clone of the current permit type, which you can then use to create a different permit
or to create a different version of the current permit.

For more information on cloning permits, see Cloning Transaction Type Definitions.

Designing Intake Forms

After you have entered the appropriate initial information for a permit, you can then begin to design the intake form
that end users will use to submit an online application. You create an application form using the Intake Form Designer.
To access the designer, click Design Form.

For more information on designing intake forms, see Using the Intake Form Designer.

Setting Up Permit Display Groups
Use the Display Group setup pages to display groups of permits on your agency’s landing page, where you start an
application.

A permit display group identifies a meaningful grouping of permit and planning application types displayed as a list on
the Apply page. The list appears as the permits or planning applications that agency staff or a guest user can select to
initiate the application process.

For more information about how the Apply page looks and is used, see Choosing an Application Type.

Before setting up permit display groups, you must set up the types of permits your agency offers. See Setting Up Permit
Types.

Adding Permit Display Groups

1. Select Permit Setup > Permit Display Group .
2. On the Permit Display Group page, click Add to add a new group.
3. On the Permit Display Group Details page, enter values for the following:

Page Element Description

Display Group ID Enter a permit display group name.

Display Group Enter a name for the display group that appears on the Apply page for guests and
agency staff.

Description Enter a description of the display group that appears on the Apply page for guests and

agency staff.

URL Enter a URL that agency staff can use to access additional information. This page is the
only place that the URL appears, so it is not available to guests.
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Page Element

Applicable Classification

4. Verify that the Enabled switch is turned on. The switch is turned on by default for new permit display groups.

Description

Select the check box for the applications to which this display group applies. Choose
from these options:

o Business Licenses
o Permits
o Planning and Zoning

This option determines whether a display group type is shown on the Apply page for
public users. A display group can be included with more than one classification.

5. Inthe Display Group Lines section, click Add to set up a line on the Display Group Line Details page. The
display group lines are transaction types that make up the list in the new display group.

Note: A mix of different transaction types can be added to a display group. For example, you can add a
planning application transaction type to a permit application display group and the other way around.

Page Element

Display Order

Transaction Type ID

Transaction type information

Description

Enter a numerical value in this field to specify the order in which you want the permit
type to be displayed, if desired. The default value is O and upon saving, the system
automatically assigns the next value.

Select an existing transaction type ID.

The description for the ID you enter here will appear in the Transaction Type field.

Review the attribute information for the permit type to verify you have selected the
correct transaction type ID:

o Transaction Type
o Classification

o Application Group
o Category

o Subcategory

For more information about transaction type attributes, see Setting Up Permit Types.

6. On the Permit Display Group Details page, click Save.

ORACLE

Chapter 2
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Modifying Permit Display Groups and Lines

You can modify permit display groups and the permits in the list on the Permit Display Group Details and Display Group
Line Details pages, respectively.

1.

Select Permit Setup > Permit Display Group .

2. On the Permit Display Group page, select the row for the permit group that you want to modify.

3.

v »

N©o

8.

On the Permit Display Group Details page, you can:
o Modify the group name and description. You can’t change the Display Group ID.

o Turn the Enabled switch on or off to enable or disable the display group.

If you made any changes, click Save.
To modify the display group lines (the list of permits in a display group), select the row for the permit group that
you want to modify on the Permit Display Group page.
On the Permit Display Group Details page, select a display group line in the Display Group Lines grid.
On the Display Group Line Details page, you can change the values in these fields:
a. Update the Display Order field to change the order in which the lines appear.
b. Update the Transaction Type ID field with another existing permit type ID.
If you made any changes, click Save.

Deleting Permit Display Groups and Lines

PUWN

N©o

Select Permit Setup > Permit Display Group .
On the Permit Display Group page, select the row for the permit group that you want to delete.
If you want to delete the display group, click Delete on the Permit Display Group Details page.
If you want to delete multiple display groups, you can delete them from the Permit Display Group page:
a. Click Edit.
b. Select the check boxes for the display groups to delete.
c. Click Delete.
To delete a display group line, go to the Permit Display Group Details page and select a display group line in the
Display Group Lines grid.
On the Display Group Line Details page, click Delete.
If you want to delete multiple display group lines, you can delete them from the Permit Display Group Details
page:
a. Click Edit.
b. Select the check boxes for the display group line rows to delete.
c. Click Delete.

Setting Up Permit Expiration Rules

You can set up expiration rules for the different phases of the permit application lifecycle.

You set up expiration rules for permit applications to define:

- When an inactive pending application expires.

- When the application expires.
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- When the permit expires.

First, you define the rules in an effective-dated group. After setting up the expiration rules, you add the rules group ID
to the application type definition and periodically run batch rules processing to update permit expiration statuses. You
can track updated application expiration statuses on the transaction list page and the permit’s expiration status on the
Overview page in the permit details.

Note: Because expiration start and end dates require specific statuses, workflow processes must include status
update tasks for Application Accepted (Accepted) and Certificate of Occupancy (Certificate) or Completed
(Completed). See Setting Up Transaction Statuses and Using Workflow.

Setting Up Expiration Rule Groups

Here’s how to set up the rule group:

1. Select Permit Setup > Permit Expiration Group > Permits .
2. Onthe Permit Expiration Group page, enter values for these fields:

Page Element Description

Expiration Group ID, Expiration Enter an ID for the expiration group, a group name, and description.
Group Name, and Description

Effective Start Date and Effective = Enter the range of dates when the group is effective. If you want to leave the effective
End Date dates open-ended, don’t enter a date for the end date.

To see the effective date history for an expiration group, click Show All Dates. On the
History Data page, you can search history by effective start date or click Add to add new
effective-dated rules for an expiration group.

Show All Dates Click to access the effective-dated history of the rules definition. This button is available
after you create the first rule.

You can also search history by effective start date. Click Add to create a new effective-
dated row for an expiration group.

3. Verify that the Enabled switch is turned on. The option is active by default for a new expiration group.
4. Create expiration rules in the Expiration Rules section.

Defining Expiration Rules

Here’s how to set up the details about the expiration rules in the group:

1. Select Permit Setup > Permit Expiration Group > Permits .
2. Click Add in the Expiration Rules section.
3. Enter these values to create each rule:
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Page Element

Expiration Basis

Expiration Duration

About to Expire

Grace Period

Number of Extensions

ORACLE

Description

Select the type of expiration for the rule, based on the status of the application:

o Inactive pending application — When the application is in a pending status, users
must submit the application before the expiration date.

The expiration timeframe begins when the user saves an application and ends with
application submission.

o Application expiration — Users must complete permit requirements such as the
plan review before the permit can be issued. If the permit is not issued by the
expiration date, the application and all tasks are canceled.

The expiration timeframe begins when the agency accepts application and ends
when the permit is issued.

o Permit expiration — Users must complete the final inspection before the permit
expires.

The expiration timeframe begins when the agency issues the permit and ends
when the Certificate of Occupancy is issued or the permit is completed.

Note:

Because expiration start and end dates require specific statuses, workflow processes
must include status update tasks for Application Accepted (Accepted) and Certificate
of Occupancy (Certificate) or Completed (Completed). See Setting Up Transaction
Statuses and Using Workflow.

Enter the amount of time that the user has before the expiration date.

Enter when you would like a notification to appear on the application that shows the
user how long until the application expires. For example, you can enter 2 days to show
that a pending application expires in 2 days.

You can manually extend a permit on the Overview page in the transaction details
during the about to expire period. For example, if the about to expire period is 15 days,
the permit can be manually extended starting at 15 days before the expiration date.

Enter the amount of time the application is valid beyond the expiration date. For
example, if a pending application expires in 30 days, you may want to provide a grace
period of an additional 3 days.

You can also manually extend a permit on the Overview page in the transaction details
during the grace period.
Enter the number of allowed extensions beyond the expiration date. For example, to

allow up to 2 extensions you would enter 2.

You can manually extend the expiration during the About to Expire and Grace Period
timeframes, when the Extend link is available on the Overview page in the application

Chapter 2

Setting Up Permits
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Page Element Description

details. This link is available only for agency staff with appropriate permissions. You
can’t manually extend the expiration for applications in a pending status.

4. Verify that the Enabled switch is turned on for each rule. The option is active by default for a new expiration
rule.

5. Click Save.

Setting Up Communication Rules

You can set up communication rules to send communications when the permit application or permit is about to
expire or expired. Agency staff and the contact listed on the application receive the notifications. Click Add in the
Communication column and select About to Expire, Expired, or both, and the recurrence of the communication.

Depending on the expiration communication rules you define, you must also set up communication templates for these
delivered events:

- About to Expire Permit — The communication event is triggered when the inactive pending application,
application, or permit is about to expire.

- Expired Permit — The communication event is triggered when the inactive pending application, application, or
permit expires.

For more information about configuring the communication templates for the email or notification you want to send
when the event occurs, see Setting Up Communication Templates.

CAUTION: After setting up communication rules, you must periodically run batch expiration rule processing to
update the About to Expire and Expired statuses. The system updates the statuses and sends out the communications
according to the setup. Oracle recommends that you schedule expiration rule processing to run daily.

Setting Up Automatic Permit Extensions

After you add a permit expiration rule, you have the option to automatically extend a permit’s validity based on
inspection activity. This is how it works: You define whether the extension occurs only when the inspection is completed
with a pass result or any result, and specify the duration of the extension in number of days. Automatic extensions

are counted toward the number of available extensions defined in the rule. Agency staff with system administrator
permissions can still manually extend the expiration.

Here’s how to automatically extend a permit:

1. Select the option to automatically push out the permit expiration date.
2. Inthe Result field, select one of the options:

o Any Result: Extend the expiration date when an inspection is completed regardless of the inspection
result.

o Pass Only: Extend the expiration date only when an inspection is complete with a passing result.
3. Inthe Extension Duration fields, select the number of days, months, or weeks to extend the permit.

You might have multiple inspections for a permit, in which case the system extends the permit with each completed
inspection.
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If you have communications set up, notifications are sent when the extended permit is about to expire or when it
expires. You must run expiration rule processing to update the statuses and send communications.

Setting Up Permit Expiration Based on Inspection Activity

When you set up inspection commencement rules, permits will automatically expire due to inactivity if the first
inspection is not scheduled or does not pass within a specified period of time after permit issuance. A notification is
sent out when the permit is about to expire based on the inspection activity.

Here's how to set up a permit to expire based on the inspection commencement:

1. Create a rule for permit expiration.

2. Select Permit expires based on inspection commencement.

3. Select the timeframe the permit is valid after issuance in the Expiration Duration fields, during which the first
inspection must be scheduled or pass.

4. Intheinspection commencement date field, select one of the options:

o Schedule date: The first inspection must be scheduled by this date for the permit to remain active.
o Pass date: The first inspection must pass by this date for the permit to remain active.

Depending on the communications you defined for the permit expiration rule, notifications are sent when the permit is
about to expire or when it expires.

Associating Expiration Rules with Permit Types

After you create an expiration group, you associate the group of rules with a permit type.

1. Select Permit Setup > Permit Type > Transaction Type > Permits .

2. Click the row for the permit type.

3. On the selected Permit Type page, enter the expiration group ID. You can look up the expiration group by
expiration group name and description.

4. C(lick Save.

For more information about assigning rules to a permit type, see Setting Up Permit Types.

Running the Expiration Rule Process

After setting up expiration rules and adding an expiration rule group ID to the permit type definition, you must set up
expiration rule processing to periodically update the expiration statuses.

Run the process that updates permit and planning application expiration statuses on the Process Expiration Rules page,
which you access by selecting Common > Process Expiration Rules . Oracle recommends that you schedule expiration
rules processing to run daily.

CAUTION: You must periodically run batch expiration rule processing to update the about to expire and expired
statuses for permits that have been extended. The system updates the statuses and sends out the communications
according to the setup.

For information about setting up expiration rules processing, see Updating Application Expiration Status.

Related Topics
- Expiration Overview

23
ORACLE


http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_UpdatingApplicationExpirationStatus
http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=concept_ExpirationOverview

Oracle Public Sector Compliance and Regulation Cloud Chapter 2
Implementing Compliance and Regulation Setting Up Permits

Updating Application Expiration Status

You update the application expiration status using a process that runs against predefined rules.

You run the process that updates expiration statuses on the Process Expiration Rules page, which you access by
selecting Common > Process Expiration Rules . Oracle recommends that you schedule expiration rules processing to
run daily.

Note: After setting up expiration rules, you must periodically run batch expiration rule processing to update the
About to Expire and Expired statuses. The system updates the statuses and sends out communications according to
the setup.

Here’'s an example of how the processing works: An agency created a rule for solar permits that indicates application
expires in 30 days. The period of time when a notification appears for applications about to expire is 5 days. During
processing, the system updates the status to Expired when the application expires. That is, when the permit is not
issued within 25 days, the application is about to expire, and at 30 days, the application expires. If the rule includes a
grace period, such as 3 days, the system status changes to Expired after 30 days, but resets if there is activity within
the 3-day grace period. Processing triggers alerts and notifications when the application is about to expire and upon
expiration.

When an application or permit expires, processing changes the system status to Expired and cancels all associated open
tasks.

Entering Parameters to Process Expiration Rules

1. Access the Parameters tab on the Process Expiration Rules page.
2. Select the Classification for which you are updating expiration dates: Planning and Zoning or Permits.

Scheduling the Process

1. Access the Schedule tab.
2. Toimmediately add the process to the queue, select the As soon as possible option.
3. To create a schedule for the process, select the Using a schedule option, and enter values using the following

fields:
Page Element Description
Frequency Select how frequently you want to run the process. Values are:

o Once: Select to run the process one time only.
o Hourly or minute: Select to run the process at regular time intervals.

o Daily: Select to run the process at regular intervals in days.

Note:
Daily is the recommended option for running the expiration status update process.
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Page Element

Start Date

End Date

Hours and Minutes

Days

Weeks

Repeat - By day

ORACLE

Description

o Weekly: Select to run the process at regular intervals in weeks.
o Monthly: Select to run the process on specific days of the month.

o Yearly: Select to run the process during specific months.

Enter the date on which you want to begin your scheduled processing.

Enter the date on which you want to end your scheduling processing.

Enter the time interval between scheduled processes. For example, if you enter 2 in
the Hours field and 30 in the Minutes field, the process will run every 2 hours and 30
minutes beginning on the specified start date.

Note:
These fields are available only if you select a process frequency of Hours or Minutes.

Enter the number of days between scheduled processes. For example, if you enter 3, the
process will run every 3 days beginning on the specified start date.

Note:
This field is available only if you select a process frequency of Daily.

Enter the number of weeks between scheduled processes. For example, if you enter 6,
the process will run every 6 weeks beginning on the specified start date.

Note:
This field is available only if you select a process frequency of Weekly.

Select this option to run the process on specific days of the month irrespective of the
date. For example, if you select the Secondand Wednesday options, the process will run
on the second Wednesday of every month.

You can select more than one week of the month and day of the week option. For
example, you could schedule the process to run on the first and third Monday of every
month.

Chapter 2
Setting Up Permits
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Page Element Description

Note:
This option and its associated fields are available only if you select a process
frequency of Monthly or Yearly.

Repeat - By date Select this option to run the process on specific dates of the month. You can select more
than one date.

Note:
This option and its associated fields are available only if you select a process
frequency of Monthly or Yearly.

Month Select the months in which you want your process to run.

Note:
This option and its associated fields are available only if you select a process
frequency of Yearly.

Setting Up Process Notifications

You can set up the process to send notifications to you and others when it runs.

W

Turn on the Notify Me When This Process Ends switch to send yourself a notification when the process
finishes.

Access Notification tab.
Click Add.
On the Create Notification page, enter the email address of the person you want to receive notifications.

By default, the recipient will receive a notification when the process ends with the following conditions:

o On success
o Onerror

o On warning

You can remove any of these process notification conditions.
Click OK to save the notification recipient.
(Optional) To delete a notification recipient, select the recipient in the Notification tab and click Delete.
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Submitting the Process

Once you've entered your process parameters, scheduling information, and notification recipients, you're ready to
submit the process. Enter any additional information in the Submission Notes field and click Submit. Click Process
Monitor to check the status of your process.

Importing Solution Packages

Public Sector Compliance and Regulation system administrators and implementation consultants use the Oracle

Cloud Customer Connect to access the Public Sector Compliance and Regulation Solution Library — a collection of
configurations that address common community development and licensing functionality with industry best practices,
provided in the form of Solution Packages.

A solution package contains all the necessary configuration files in a compressed file format along with a metadata file.

Review the solution package contents online, download specific solutions that contain the corresponding setup data,
review them and deploy those solutions to your pre-production environment for your understanding. Each solution
package provides a link that allows you to download and review a white paper describing the contents of the particular
solution package. You can review the white paper before you decide to download the solution package.

To access the Solution Library, follow this link Public Sector Compliance and Regulation Solution Library.
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5 Setting Up Planning Applications

Setting Up Agency-Level Options

You set up the Oracle Intelligent Advisor for Permits and Planning and Zoning on the Permit Options page during
agency setup. You can also configure the summary title and text for the Anonymous User Landing Page and the
Registered User Landing page.

To configure agency-level options for permits and planning applications:

1.
2
3.

Select Common Setup > Agency .
Click a row on the Agency Information tab.
Select the Features tab.

Oracle delivers the list of offerings on the Features tab. The Permits offering encompasses both Permits and
Planning and Zoning.

Disregard the Enabled column for the Permit offering. The offering is enabled in the Functional Setup Manager
(FSM).

Click Options for the Permits offering.

On the Permit Options page, you can update values for the following fields:

Page Elements Definition

Oracle Policy Automation ID Enter the unique identifier for the Oracle Policy Automation policy model to be used for
this offering.

The offering-specific policy model that you specify here takes priority over any agency-
wide policy definition that you enter on the main Agency Information page.

Message Title Enter a short text version of the landing page message in a title format. If you leave this
field blank, the value in the Label field on the Link Details page for the menu navigation
link Online Permits is displayed.

Message Summary Enter a longer version of the landing page message title in a sentence format. If you
leave this field blank, the value in the Description field on the Link Details page for the
menu navigation link Online Permits is displayed.

Button Content URL Enter a content URL for the Read More button. Public users click this button to access
the agency’s own permit information page, outside of Oracle Public Sector Permits. If
you leave this field blank, the Read More button opens a dialog box that displays the
Landing Page Message.
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Page Elements Definition
Note:
If you want to link to a page outside of Oracle Public Sector Permits, you must enter a
URL here.
Landing Page Message Enter a welcome message in rich text to appear in a dialog box on the landing page, if a

URL to access the agency'’s page is not defined.

For more information on Oracle Intelligent Advisor, see Overview of Oracle Intelligent Advisor Configuration.
For more information on the Landing Page Message Definition, see Defining Summary Details.

Related Topics
« Managing Oracle Intelligent Advisor Policies for your Agency

 Setting Up the Landing Page for Anonymous Users
- Setting Up the Landing Page for Registered Users

Setting Up Planning Application Types
Define the types of planning applications supported by an agency, including pre-applications. You add a planning
application type and associate workflow process definitions on the Planning Application Type definition page.

Before you can create an application form, you must first create a planning application or pre-application type on the
Planning Application Type definition page. The type defines attributes that will be available for the planning application
or pre-application.

Adding Planning Application Type Definitions

1. Select Planning and Zoning Setup > Planning Application Type > Planning Applications .
2. Onthe Transaction Type - Planning Applications page, click the Add button.
3. On the Planning Type Applications page, enter values for the following fields:

Page Element Description

Classification Displays the type of application. The classification for this page indicates this is a
planning application.

Subclassification Displays the subclassification of the application type.
If you would like to create a pre-application type, select Pre-Application from the drop-

down list. The default value is Not Applicable, which indicates a standard planning
application.
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Page Element Description
Planning Application Type Enter a name for the type of planning application.
Planning Application Type ID Enter a unique alphanumeric code or short name for the planning application type. Do

not use special characters, including symbols or punctuation, or spaces.

Status Select from the following to indicate the planning application type status:

o Preliminary: The planning application type is being defined but is not available for
use.

o Ready: The planning application type is ready to be accessed from the landing
page for testing or production use, depending on the environment.

o Void: The transaction type is no longer available.

Note:

The form design can be in published status or draft status and be set to Ready. In
draft status, the form can be accessed from outside the form designer—such as the
Apply page—for testing purposes in the development or test environment.

Form Design Status A read-only field indicating whether the form design is published or currently being
developed.

o Draft: The form design is currently being created or modified. Form designs in
draft status are not migrated to other environments and can’t be cloned.

o Published: The form design is complete. Form designs in published status can be
migrated to other environments and can be cloned.

Autonumber Rule Select the autonumbering rule to increment numbers for planning applications.

You can delete the autonumbering rule when it isn’t being used by any transaction
types.

For more information, see Setting Up Autonumbering.

Valid from Date and Valid to Date  Enter a range of dates when this planning application type is valid. The default from
date is the current date. The default end date is Open. You can update these dates as
needed.

Public User Enabled Select from the following to indicate whether the intake form can be accessed and by
which user types:

o Enabled for all users: Only registered public users and agency users can access the
intake form.

o Enabled for registered users: Only registered public users and agency users can
access the intake form.
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Page Element

Hearing

Application Group

Category

Subcategory

Activity Group

Document Group

ORACLE

Description

o Not enabled for public users (default): Only agency users can access the intake
form.

Note:
Currently, Enabled for all users and Enabled for registered users have equivalent
access.

Select whether public hearings are applicable or not applicable to this planning
application type.

For more information, see Setting Up Hearing Bodies, Setting Up Hearing Hierarchies,
and Setting Up Hearing Decisions.

Select an application transaction group that you want to associate with the planning
application type.

For more information, see Setting Up Transaction Groups.
Select a transaction category that you want to associate with the planning application
type.

For more information, see Setting Up Transaction Categories.

Select a transaction subcategory that you want to associate with the planning
application type.

For more information, see Setting Up Transaction Subcategories.

Select an activity group with the activities that you want to use for tracking planning
application task due dates. Whenever an application of this application type is
submitted, activities set up and mapped to the transaction type are added to the
planning application’s activity tracking page.

For more information, see Setting Up Activity Tracking.

Select a document group to manage attachments for the planning application type.
When you specify a document group, document attachments can be classified into
categories and subcategories during the application process and when you upload
files. Then you can see the category for a document on the attachments page in the

application details.

For more information, see Setting Up Document Groups.
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Page Element Description
Fee Schedule Select a fee schedule that you want to associate with the planning application type. A

department is required when you enter a fee schedule ID.

For more information, see Setting Up Fee Schedules.

Bill Type Select a bill type to associate with the planning application type.

The billing type identifies the type of invoice that can be generated from the record. The
bill type is required.

For more information, see Setting Up Bill Types.

Department Select a department that you want to associate with the planning application type. A
department is required if you add a Fee Schedule ID to the planning application type.

If a department is specified on the Fee Item setup page, the fee item department
overrides the department specified here on the planning application type.

For more information, see Setting Up Departments.

Terms of Use ID Select a terms of use definition to associate with the planning application type. The
available values for planning applications are determined by the usage on the terms of
use ID.

For more information, see Setting Up Terms of Use.

Description Enter a user-facing description of the planning application type. On the Apply page, this
description appears under the application type name.

The description helps public users understand the purpose of the application type.

URL Enter a URL for a web page that gives public users more information about the planning
application type.

If you enter a URL, then a Learn More link appears at the end of the application type
description on the Apply page. The user clicks this link to open the specified URL.

If you leave this field blank, the Learn More link is not visible on the Apply page.

Setting Up Conditions of Approval

In the Conditions of Approval section, you enter the report ID and template that associate with this planning
application type. The report ID determines the type of report that should be printed to list the conditions of approval
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and the conditions of approval template determines the conditions of approval that will be applied to the planning
application.

For more information about conditions of approval, see Setting Up Conditions of Approval Templates.

Setting Up Planning Application Expiration

In the Expiration section, you can enter the expiration group that defines the expiration rules for this planning
application or pre-application type. Expiration rules determine the expiration dates that correspond to application
activity. For more information about planning application and pre-application expiration, see Setting Up Planning
Application Expiration Rules.

Setting Up Workflow for a Planning Application

You set up workflow using the Oracle Autonomous Integration Cloud (OIC) before associating the workflow with the
planning application type.

For more information, see Setting Up Process Definitions for Workflow.
1. Select Planning and Zoning Setup > Planning Application Type > Planning Applications .

2. Onthe Transaction Type — Planning Applications page, click the Add button.
3. Inthe Workflow Setup section on Planning Application Type page, enter values for the following fields:

Page Element Description

Space Name Enter the space where the workflow process application is stored. You can group
related applications in a space as well as enable users to collaborate when developing
applications.

Application ID Enter the name of the workflow process application in OIC. For more information, see

Creating and Managing Applications.
Version Enter the version of the workflow process application.

Process Definition Enter the name of the workflow process definition that applies to this particular
planning application.

I Note: Different planning application types can utilize the same workflow definition.

Setting Up Plan Reviews for a Planning Application Type

Define how plan reviews are conducted for planning applications associated with the planning application type.

1. Select Planning and Zoning Setup > Planning Application Type > Planning Applications .

2. Onthe Transaction Type - Planning Applications page, click the Add button or select an existing planning
application type.

3. Inthe Plan Reviews section on Planning Application Type page, enter values for the following fields:
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Page Element

Plan Review Type

Enable Auto Assignment

Plan Reviewer Departments

ORACLE

Description

Select the method used for reviewing plans for planning applications associated with
the planning application type.

o Manual: Plan reviews are tracked as part of planning application workflow, but are
performed without the use of integrated electronic document review software.

o Not Used: Plan reviews are not tracked as part of planning application workflow.

o Electronic: Plan reviews are tracked as part of planning application workflow, and
are performed through integration with electronic document review software.
For more information on plan reviews, see Managing Manual Plan Review Cycles and

Managing Electronic Plan Review Cycles.

Turn on this switch to enable the automatic assignment of plan reviewers for planning
applications associated with this planning application type.

When this switch is on and the assigned planner gives a planning application associated
with this planning application type a status of Completed - Plan Review Required, the
automatic assignment process:

a. Adds areviewer row to the plan review cycle for each plan reviewer department
selected for the planning application type. If no plan reviewer departments are
selected for the planning application type, the process creates the plan review
cycle, but doesn’t add any reviewer rows.

b. Adds the designated department lead to the Reviewer field for each reviewer row.
If a department doesn’t have a department lead selected, the process still creates a
row for the department, but leaves the Reviewer field blank.

Note:
This switch is available only when the Plan Review Type is Manual.

Select the departments that should be included in any plan reviews associated with this
planning application type. Plan coordinators should add a reviewer from each of the
required departments. The Reviewers grid of the Plan Review page displays the required
departments that you select here.

When Enable Auto Assignment is turned on, the process automatically adds a plan
reviewer row to plan review cycles for each of the selected departments.

Note:
A plan reviewer department is available to select only if the Planning and Zoning
classification is selected for it on the Plan Reviewer Department page.

For more information about plan reviewer departments, see Setting Up Plan Reviewer
Departments.
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Page Element Description

For more information about plan reviews, see Electronic Plan Review Process Flow and
Manual Plan Review Process Flow.

Cloning Planning Application Types

Click the Clone button to create a clone of the current planning application type, which you can then use to create a
different planning application or to create a different version of the current planning application.

For more information on cloning permits and planning applications, see Cloning Transaction Type Definitions.

Designing Intake Forms

After you've entered the appropriate initial information for the planning and zoning type, you can then begin to design
the intake form that end users will use to submit an online planning application. You create an intake form using the
designer. You access the designer by clicking the Design Form button.

For more information on designing intake forms, see Using the Intake Form Designer.

Setting Up Planning Application Display Groups
Use the Display Group setup pages to display groups of planning applications on your agency’s landing page, where you
start an application.

A display group identifies a meaningful grouping of planning application types displayed as a list on the Apply page.
The list appears as the planning applications that agency staff or a guest can select to initiate the application process.

For more information about how the Apply page looks and is used, see Choosing an Application Type.

Before setting up planning application display groups, you must set up the types of planning applications that your
agency offers. See Setting Up Planning Application Types.

Adding Planning Application Display Groups

1. Select Planning and Zoning Setup > Planning Display Group .
2. On the Planning Application Display Group page, click Add to add a new grouping.
3. On the Planning Application Display Group Details page, enter values for the following:

Page Element Description

Display Group ID Enter a planning application display group name.

Display Group Enter a name for the display group that appears on the Apply page for guests and
agency staff.
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Page Element

Description

URL

Applicable Classification

Description

Enter a description of the display group that appears on the Apply page for guests and
agency staff.

Enter a URL that agency staff can use to access additional information. This page is the
only place that the URL appears, so it is not available to guests.

Select the check box for the applications to which this display group applies. Choose
from these options:

o Business Licenses
o Permits
o Planning and Zoning

This option determines whether a display group type is shown on the Apply page for
public users. A display group can be included with more than one classification.

4. Verify that the Enabled switch is turned on. The switch is turned on by default for new planning application

display groups.

5. Inthe Display Group Lines section, click Add to set up a line on the Display Group Line Details page. The
display group lines make up the list of planning application types in the new display group.

Note: A mix of different transaction types can be added to a display group. For example, you can add a
permit transaction type to a planning application display group and the other way around.

Page Element

Display Order

Transaction Type ID

Transaction type information

ORACLE

Description

Enter a numerical value in this field to specify the order in which you want the planning
application type to be displayed, if desired. The default value is 0 and upon saving, the
system automatically assigns the next value.

Select an existing transaction type ID.

The description for the ID you enter here will appear in the Transaction Type field.

Review the attribute information for the planning application type to verify you have
selected the correct transaction type ID:

o Transaction Type
o Classification

o Application Group
o Category

o Subcategory
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Page Element Description

For more information about transaction type attributes, see Setting Up Planning
Application Types.

6. On the Planning Application Display Group Details page, click Save.

Modifying Planning Application Display Groups and Lines

You can modify planning application display groups and the planning applications in the list on the Planning Application
Display Group Details and Display Group Line Details pages, respectively.

1. Select Planning and Zoning Setup > Planning Display Group .

2. On the Planning Application Display Group page, select the row for the planning application group that you
want to modify.

3. Onthe Planning Application Display Group Details page, you can:

o Modify the group name and description. You can’t change the Display Group ID.
o Turn the Enabled switch on or off to enable or disable the display group.

4. If you made any changes, click Save.
5. To modify the display group lines (the list of planning applications in a display group), select the row for the
planning application group that you want to modify on the Planning Application Display Group page.
6. On the Planning Application Display Group Details page, select a display group line in the Display Group Lines
grid.
7. On the Display Group Line Details page, you can change the values in these fields:
a. Update the Display Order field to change the order in which the lines appear.
b. Update the Transaction Type ID field with another existing planning application type ID.
8. If you made any changes, click Save.

Deleting Planning Application Display Groups and Lines

1. Select Planning and Zoning Setup > Planning Display Group .
2. On the Planning Application Display Group page, select the row for the planning application group that you
want to delete.
3. If you want to delete the display group, click Delete on the Planning Application Display Group Details page.
4. If you want to delete multiple display groups, you can delete them from the Planning Application Display Group
page:
a. Click Edit.
b. Select the check boxes for the display groups to delete.
c. Click Delete.
5. To delete a display group line, go to the Planning Application Display Group Details page and select a display
group line in the Display Group Lines grid.
On the Display Group Line Details page, click Delete.
If you want to delete multiple display group lines, you can delete them from the Planning Application Display
Group Details page:
a. Click Edit.
b. Select the check boxes for the display group line rows to delete.

N o
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c. Click Delete.

Setting Up Planning Application Expiration Rules

You can set up expiration rules for the different phases of the planning application lifecycle.
You set up expiration rules for planning applications to define:
- When an inactive pending application expires.

- When the entitlement expires.

First, you define the rules in an effective-dated group. After setting up the expiration rules, you add the rules group ID
to the application type definition and periodically run batch rules processing to update permit expiration statuses.

Setting Up Expiration Rule Groups
Here’s how to set up the rule group:

1. Select Planning and Zoning Setup > Expiration Group > Planning Applications .
2. On the Planning Expiration Group page, enter values for these fields:

Page Element Description

Expiration Group ID, Expiration Enter an ID for the expiration group, a group name, and description.
Group Name, and Description

Subclassification Select Not Applicable for a planning application or Pre-Application. Use Pre-Application
if you are applying this group of rules to a pre-application transaction type.

Effective Start Date and Effective = Enter the range of dates when the group is effective. If you want to leave the effective
End Date dates open-ended, don’t enter a date for the end date.

To see the effective date history for an expiration group, click Show All Dates. On the
History Data page, you can search history by effective start date or click Add to add new
effective-dated rules for an expiration group.

Show All Dates Click to access the effective-dated history of the rules definition. This button is available
after you create the first rule.

You can also search history by effective start date. Click Add to create a new effective-

dated row for an expiration group.

3. Verify that the Enabled switch is turned on. The option is active by default for a new expiration group.
4. Create expiration rules in the Expiration Rules section.
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Defining Expiration Rules

Here's how to set up the details about the expiration rules in the group:

1. Select Planning and Zoning Setup > Expiration Group > Planning Applications .
2. Click Add in the Expiration Rules section.

3. Enter values to create each rule:

Page Element

Expiration Basis

Expiration Duration

About to Expire

Grace Period

Number of Extensions

ORACLE

Description

Select the type of expiration for the rule, based on the status of the application:

o Pre-application expiration — Applies only to pre-applications. Users must complete
the pre-application within the specified period of time.

The expiration timeframe begins when the user saves the pre-application and ends
when the user starts the planning application.

o Inactive pending application - When the planning application is in a pending
status, the user must submit the application before the expiration date.

The expiration timeframe begins when the user saves a planning application and
ends with application submission.

o Entitlement expiration — Applies only to entitlements for planning applications.
Users must submit a permit application after the entitlement is issued and before
the expiration date.

The expiration timeframe begins when the agency issues the completed
entitlement and ends when the user submits the permit application.

Note:

Because start and end dates require specific statuses, workflow processes must
include status update tasks for Application Accepted (Accepted) and Certificate of
Occupancy (Certificate) or Completed (Completed).

Enter the amount of time that the user has before the expiration date.

Enter when you would like a notification to appear on the application that shows the
user how long until the application expires. For example, you can enter 2 days to show
that a pending application expires in 2 days.

Enter the amount of time the application is valid beyond the expiration date. For
example, if a pending application expires in 30 days, you may provide a grace period of
an additional 3 days.

Enter the number of allowed extensions beyond the expiration date. For example, to
allow up to 2 extensions you would enter 2.

You can manually extend the expiration during the About to Expire and Grace Period
timeframes, when the Extend link is available on the Overview page in the application
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Page Element Description

details. This link is available only for agency staff with appropriate permissions. You
can’t manually extend the expiration for applications in a pending status.

Both manual extensions and extensions that occur automatically due to inspection
activity count toward the number of available extensions.

4. Verify that the Enabled switch is turned on for each rule. The option is active by default for a new expiration
rule.

5. Click Save.

Setting Up Communication Rules

You can set up communication rules to send communications when the pre-application or planning application is about
to expire or expired. Agency staff and the contact listed on the application receive the notifications. Click Add in the
Communication column and select About to Expire, Expired, or both, and the recurrence of the communication.

Depending on the expiration communication rules you define, you must also set up communication templates for these
delivered events:

- About to Expire Pre-application - The communication event is triggered when the inactive pending application
or pre-application is about to expire.

- Expired Pre-Application - The communication event is triggered when the inactive pending application or pre-
application expires.

« About to Expire Planning and Zoning Application — The communication event is triggered when the inactive
pending application or planning application is about to expire.

- Expired Planning and Zoning Application — The communication event is triggered when the inactive pending
application or planning application expires.

For more information about configuring the communication templates for the email or notification you want to send
when the event occurs, see Setting Up Communication Templates.

CAUTION: After setting up communication rules, you must periodically run batch expiration rule processing to
update the About to Expire and Expired statuses. The system updates the statuses and sends out the communications
according to the setup. Oracle recommends that you schedule expiration rule processing to run daily.

Associating Expiration Groups with Application Types

After you create an expiration group, you associate the group of rules with a planning application type.

1. Select Planning and Zoning Setup > Planning Application Type > Transaction Type .
2. C(lick the row for the planning application type.

3. On the selected Planning Application Type page, enter the expiration group ID. You can look up the expiration
group by expiration group name and description.

4. C(lick Save.
For more information see Setting Up Planning Application Types.

A1
ORACLE


http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_SettingUpCommunicationTemplates

Oracle Public Sector Compliance and Regulation Cloud Chapter 3
Implementing Compliance and Regulation Setting Up Planning Applications

Running the Expiration Rule Process

After setting up expiration rules and adding an expiration rule group ID to the planning application type definition, you
must set up expiration rule processing to periodically update the expiration statuses.

Run the process that updates permit and planning application expiration statuses on the Process Expiration Rules page,
which you access by selecting Common > Process Expiration Rules . Oracle recommends that you schedule expiration
rules processing to run daily.

For information about setting up expiration rules processing, see Updating Application Expiration Status.

Related Topics
« Expiration Overview

Managing Pre-Application Meeting Configuration

Pre-applications are the initial step in the planning and zoning process, and are used to allow the property owner or
developer to work with agency planners to receive feedback prior to submitting planning applications. A pre-application
meeting is scheduled between the property owner or developers and agency planners to determine the necessary
applications and approvals for the project.

Configuring the Pre-Application Meeting

Administrators set up and manage the pre-application meeting configuration on the Manage Pre-Application Meeting
Configuration page.

1. Select Pre-Application Setup > Pre-Application Meeting Setup . Or, Select Setup and Maintenance tile
on the Agency Springboard > Select Public Sector Planning and Zoning > Planning Application Types
functional area > Manage Pre-Application Meeting Configuration task.

2. Onthe Manage Pre-Application Meeting Configuration page, the Pre-Application Meeting section allows you to
set up applicant privileges. Enter values for the following fields:

Page Element Description

Applicant can request Select to allow an applicant to request a pre-application meeting. Applicants can access
the Pre-Application Meeting Request page and schedule a meeting based on the
availability of the agency staff. See Working with Pre-Application Meetings.

Applicant can reschedule and Select to allow an applicant to reschedule or cancel their meeting.
cancel

3. The Meeting Availability section allows you to set up the parameters for scheduling meetings, determined by:

a. Planner meeting schedule or
b. Agency meeting schedule
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Planner meeting schedule: Select to allow users to schedule meetings based on the availability of their
assigned planner.

Note: You also need to ensure that all the Planners are assigned a Pre-Application meeting work schedule on
the Agency Staff Profile. Enter values for the following fields:

Page Element Description

Meeting Duration in Hours Select a value to set the maximum amount of time the meeting can be scheduled for.
Users will see this value as the duration of the meeting, and they are not allowed to edit
the field. See the section Scheduling a Pre-Application Meeting under Working with Pre-
Application Meetings.

Schedule after Number of Days Select a value to set the number of days from the current date, so that users can
schedule a meeting on a date available after the number of days specified here. For
example, if you select a value 5 on the 10th day of this month, the calendar on the Pre-
Application Meeting Request page displays the dates that are available after the 15th
day of the month.

Schedule up to Number of Days Select a value to set the number of days that will be available for the users to select a
date on the calendar for scheduling the meeting. For example, if you select a value of
90, the calendar on the Pre-Application Meeting Request page displays 90 calendar
days starting from the date the user is making the selection.

See the section Scheduling a Pre-Application Meeting under Working with Pre-
Application Meetings.

Agency meeting schedule: Select to allow users to schedule meetings based on the schedule of the agency. In
addition to the fields described above, enter values for the following fields:

Note: If you select this option, then you need not assign Pre-Application meeting schedule to the planners as
the Pre-Application meeting schedule will not be considered while determining the availability.

Page Element Description

Pre-Application Work Schedule Select the Agency level work schedule that needs to be considered while determining
the availability for the pre-application meeting.

Maximum Concurrent Meetings Select a value to determine the maximum number of meetings that can be scheduled at
atime.

4. The Meeting Agenda and Location section allows you to set up the agenda and the location for the pre-
application meeting.
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Page Element Description
Include Agenda Select the check box and enter the agenda in the Meeting Agenda field.
Include Location Select the check box and search for the desired location of your agency using the

Agency Information look up. The address of the location you select is displayed in the
Meeting Location field.

Note: Users can edit the entries for the agenda and location fields while scheduling the meeting on the Pre-
application Request page.

Setting Up Hearing Bodies

With Oracle Public Sector Compliance and Regulation Cloud, you will use the Public Hearing feature to configure hearing
bodies and hearing hierarchies, schedule hearings, and record decisions.

Setting Up Public Hearing

A public hearing is an official meeting where members of the public, the hearing body, and the applicant of the planning
and zoning application come together to discuss the facts about the application submitted by the applicants.

The following topics apply to administrators for setting up and maintaining the Public Hearing process:

- Setting up Hearing Body
- Setting up Hearing Hierarchy

- Setting up Hearing Decision

Setting Up Hearing Body
A hearing body is a group of individuals formed to evaluate the testimony presented by applicants and to provide
feedback.

Adding a Hearing Body

To add a hearing body:

1. Select Hearing Setup > Hearing Body .
2. (Click Add on the Hearing Body page and enter values for the following fields:

Page Element Description

Hearing Body Code Enter a unique identifier of the hearing body.
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Page Element Description
Name Enter a name for the hearing body.
Additional Information Enter any text as details about the hearing body.
Enabled Turn on the switch to make the hearing body available for use.
Appeal Period Select the number of days after the public hearing, when an appeal is allowed.
Maximum Agenda Items Select a value from the options. As an agency user you can configure the maximum

number of agenda items that can be heard on a day.

Address fields The agency address. The Country field displays US.
As you enter a Postal Code, the type-ahead list shows values that include appropriate
state and city combinations. After you select a value, the city and state appear as read-

only fields, and two address fields appear so that you can enter the rest of the address.

If you don’t know the postal code, click the Don’t know link to display a full set of
address fields.

3. Select a pattern of recurrence of the meeting from these fields:

Page Element Description

Recurrence Pattern Select the pattern for the recurrence of the public hearing:
o Weekly
o Monthly

4. Select the Weekly recurrence if you want to schedule the meeting every week. Enter values for the following

fields:
Page Element Description
Weeks between Occurrences Select the number of weeks between one meeting occurrence and the next.
Days of the Week Select the days of the week on which you want the meeting to recur.
Recurrence Start Date Time Select a date and time from which the meeting recurrence should be effective.
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5. Select the Monthly recurrence if you want to schedule the meeting every month. Enter values for the following

fields:

Page Element

Months between Occurrences

Days of the Week

Dates

Recurrence Start Date Time

Description

Select the number of months between one meeting occurrence and the next.

Select the check box if you want to schedule the meeting on particular days of the
week. Click Add to open the Days of the Week page and select the days of the week, for
example First Monday:

o Occurrence: Select - First, Second, Third, Fourth, or Last the day of week
o Weekday: Select the day of the week from Monday, Tuesday, and so on.

Turn on the Enable switch to make the setting available for use and click Save. Use the
Add button to include multiple rows.

Note:
You can modify or delete the entry. Click the row and use the Days of the Week page
to make the change.

Select the check box if you want to schedule the meeting on particular dates of the
week. Click Add to open the Dates page and select from all the available dates.

Turn on the Enable switch to make the setting available for use and click Save. Use the
Add button to include multiple rows.

Note:
You can modify or delete the entry. Click the row and use the Dates page to make the
change.

Select a date and time from which the meeting recurrence should be effective.

6. Click Save to save the new hearing body and return to the Hearing Body page.

Modifying a Hearing Body

To modify a hearing body:

1. Select Hearing Setup > Hearing Body .
2. Onthe Hearing Body page, click the record of the hearing body you want to edit.
3. Onthe Hearing Body details page you can make changes to the fields and click Save.

Note: You can make changes to all the fields except the Hearing Code.
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4. The Hearing Body page now lists the updated record.

Deleting a Hearing Body

To delete a hearing body:

Select Hearing Setup > Hearing Body .

On the Hearing Body page, click the record of the hearing body you want to delete.

On the Hearing Body details page you can click the Delete button. Click OK on the confirmation message.
The Hearing Body page lists only the existing records.

P UWN

Setting Up Hearing Hierarchies

Hearing Hierarchy defines the levels of hearing bodies that an application can be escalated through. In an agency, a
planning and zoning application can be escalated to a higher body in cases of appeal, where the highest hearing body
decision is considered final.

Agencies set up their hearing hierarchy to address events such as an appeal. For example, a hearing begins with the
Planning Committee and then an appeal escalates the application to the Planning Commission. If appealed again, the
application moves to the City Council.

Adding a Hearing Hierarchy
To add a hearing hierarchy:

1. Select Hearing Setup > Hearing Hierarchy .
2. Click Add on the Hearing Hierarchy page and enter values for the following fields:

Page Element Description

Hierarchy Code Enter a unique identifier of the hearing body.

Hierarchy Enter a name for the hearing hierarchy.

Enabled Turn on the switch to make the hearing hierarchy available for use.
Description Enter any text to describe the hierarchy.

3. Click Add and enter values for the following fields:
Page Element Description

Hearing Body Code Select a hearing body code to associate with the new hearing hierarchy.
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Page Element Description
Sequence Select a number to determine the escalation level of the selected hearing body within

the hierarchy. For example, if the value 2 is selected, the selected hearing body will be
the second in the hierarchy for the public hearing.

Appeal Allowed Turn on the switch if you want to allow the agency to appeal after the hearing body
places its decision. The agency will not be allowed to appeal the hearing to the next
body in the hierarchy, if the switch is turned off.

Enabled Turn on the switch if you want to allow the hearing body to be available for use.
Click to add a new row and add a new hearing body in the hierarchy.

= Click to delete the row. The hearing body will be removed from the hierarchy.

4. C(Click Save to save the newly created hierarchy and return to the Hearing Hierarchy page, where the new
hierarchy you created is listed.

Modifying a Hearing Hierarchy

To modify a hearing hierarchy:

1. Select Hearing Setup > Hearing Hierarchy .
2. Onthe Hearing Hierarchy page, click the hearing hierarchy row you want to edit.
3. Onthe Hearing Hierarchy details page make changes to the fields and click Save.

I Note: You can make changes to all the fields except the Hierarchy Code.

Deleting a Hearing Hierarchy

To delete a hearing hierarchy:

1. Select Hearing Setup > Hearing Hierarchy
On the Hearing Hierarchy page, click the hearing hierarchy row you want to delete.

3. Onthe Hearing Hierarchy details page, click Delete and click OK on the confirmation page to delete the hearing
hierarchy.
4. C(lick Save and return to the Hearing Hierarchy page. The page lists the updated hierarchy rows.

Setting Up Hearing Decisions

The outcome of a public hearing is referred to as hearing decision. Agency staff such as assigned planners update the
decision from the hearing body into the system.
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System-defined Public Hearing Decisions

Oracle delivers hearing decisions for use during the hearing process. System administrators can configure the decisions
specific to their agency, which are mapped to one of the system-defined decisions listed below:

- Approved

- None

- Denied

- Continue

Adding a Hearing Decision

1. Select Hearing Setup > Hearing Decision .
2. The Hearing Decision page lists all the decisions you have configured. Click Add.
3. One the Hearing Decision Status detail page, enter values for the following fields:

Page Element Description

Code Enter a unique identifier of the hearing decision.

Name Enter a name to identify the decision. Example, Approved with Conditions, Not Result,
and so on.

Description Enter any text to describe the decision.

Applies To Select the decision check box for which the status applies to:

o Hearing Decision (This is the default selection.)

o Staff Decision
Decision Select one of the system-defined decisions to map to the new decision you are creating:

o Approved
o None
o Denied

o Continue

Enabled Turn on the switch to make the decision available to use.

4. Click Save to save the new hearing decision and return to the Hearing Decision page, which lists the newly
created decision.
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Modify a Hearing Decision

To modify a hearing decision:

1. Select Hearing Setup > Hearing Decision .

2. The Hearing Decision page lists all the decisions you have configured. Click the row of the decision you want to
modify.

3. Onthe Hearing Decision detail page, make changes to the fields and click Save.

I Note: You can make changes to all the fields except the Code.

4. The Hearing Decision page lists the updated row.

Deleting a Hearing Decision

To delete a hearing decision:

1. Select Hearing Setup > Hearing Decision .

2. The Hearing Decision page lists all the decisions you have configured. Click the row of the decision you want to
delete.

3. On the Hearing Decision detail page, click Delete and confirm deletion by selecting OK.
4. C(Click Save and return to the Hearing Decision page. The page lists the updated decision rows.
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4 Setting Up Conditions of Approval

Setting Up Conditions of Approval Categories

Use categories to organize the various types of conditions of approval that are applied to planning applications. You set
up conditions of approval categories and subcategories on the Conditions of Approval Category page.

Adding Conditions of Approval Categories and Subcategories

1. Select Conditions of Approval Setup > Conditions of Approval Category .

2. The Conditions of Approval Category page lists all the condition categories that are set up. Click Add to add a
new condition category.

On the Conditions of Approval Category details page, enter a category ID, category name, and a description.
Click the Enabled switch to enable or disable the category.

If you want to add a subcategory, click the Add button to add the subcategory in the Conditions Subcategory
Setup section. Click the Add icon for additional subcategories.

6. On the Conditions of Approval Subcategory details page, enter a subcategory ID, subcategory name, and a
description.

Click the Enabled switch to enable or disable the subcategory.

Click Save.

vk w

0N

Modifying Conditions of Approval Categories

1. Select Conditions of Approval Setup > Conditions of Approval Category .

2. On the Conditions of Approval Category page, select the row for the category that you want to modify.

3. On the Conditions of Approval Category details page, you can only modify the category name and description.
You cannot change the category ID.

4. C(lick Save.

Modifying Conditions of Approval Subcategories

1. Select Conditions of Approval Setup > Conditions of Approval Category .

2. On the Conditions of Approval Category page, select the row for the category with the subcategory that you
want to modify.

3. Select the subcategory that you want to modify in the Condition Subcategory Setup section.

4. On the Conditions Subcategory Setup details page, you can only modify the category name and description.
You cannot change the subcategory ID.

5. Click Save.

Deleting Conditions of Approval Categories

When you delete a condition category, all associated subcategories are also deleted

Select Conditions of Approval Setup > Conditions of Approval Category .

On the Conditions of Approval Category page, select the row for the category that you want to delete.
On the Conditions of Approval Category details page, click Delete.

If you want to delete multiple condition categories, you can delete them on the Conditions of Approval
Category page:

PUWN
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a. Click the Select Multiple icon.
b. Select the check boxes for the category rows to delete.
c. Click the Delete icon.

I Note: You can’t delete a condition category if its conditions are applied to an application.

Deleting Conditions of Approval Subcategories

1. Select Conditions of Approval Setup > Conditions of Approval Category .

2. On the Conditions of Approval Category page, select the row for the category with the subcategory that you
want to delete.

3. On the Conditions of Approval Category Details page, select the row for the subcategory that you want to
delete.

4. C(lick the Delete button on the Condition Subcategory Setup details page

5. If you want to delete multiple condition subcategories, you can delete them on the Conditions of Approval
Category details page:

Click the Select Multiple icon.
Select the check boxes for the subcategory rows to delete.

Click the Delete icon.
Click Saveon the Conditions of Approval Category details page.

e ngoo

Note: You can’t delete a condition subcategory if its conditions are applied to an application.

Setting Up Condition Type Sequences

You set up the sequence in which the condition types are applied to the planning application. All conditions of a
particular type are applied based on the sequence number you configure on the Condition Type Sequence page.

Adding Condition Type Sequences

1. Select Conditions of Approval Setup > Condition Type Sequence .

2. The Condition Type Sequence page lists all the condition type sequences that are set up. Click Add to add a
new condition type sequence.

3. On the Conditions Type Sequence details page, select a condition type and a sequence number. For example,
select 1if you want the condition type to be applied first to the submitted planning application.
4. Click Save to save and return to the Conditions Type Sequence page.

The Conditions of Approval report that can be generated from the planning application lists all the applied conditions
following the sequence you set up here.
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Setting Up Condition Category Sequences

You set up the sequence in which the condition categories are applied to planning applications. All condition types of
a particular category are applied based on the sequence number you configure on the Condition Category Sequence

page.

Adding Condition Category Sequences

1. Select Conditions of Approval Setup > Category Sequence .

2. The Condition Category Sequence page lists all the category sequences that are set up. Click Add to add a new
condition category sequence.

3. Onthe Conditions Category Sequence details page, select values for the following fields:

o Category ID: Select a category ID from the available categories .

o Condition Type: Select a condition type. Select All if you want all the condition types to be selected for the
category sequence.
o Sequence : Select a number to determine the sequence of the selected category among the categories.

4. C(lick Save to save and return to the Category Sequence page.

The Conditions of Approval report that can be generated from the planning application lists all the applied condition
categories following the sequence you set up here.

Setting Up Conditions of Approval

You create and configure your agency’s conditions of approval using the Conditions of Approval page. Categorize
conditions based on the condition type, category, subcategory, and the compliance period. Conditions can be applied
automatically through templates or added manually to a submitted planning application.

Adding Conditions of Approval

1. Select Conditions of Approval Setup > Conditions of Approval .

2. The Conditions of Approval page lists all the conditions that are set up. Click Add to add a new condition of
approval.

3. Onthe Conditions of Approval details page, select values for the following fields:

Page Element Description

Detail Enter a description about the condition of approval. You can use the Rich Text
functionality for formatting options.

Conditions of Approval ID Enter an identifier of the condition of approval.
Condition Type Select a type of condition:
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Page Element Description

o Standard
o Plan

See Setting Up Condition Type Sequences.

Category Select a category for the condition of approval. See Setting Up Conditions of Approval
Categories.

Subcategory Select a subcategory for the condition of approval. See Setting Up Conditions of
Approval Categories.

Compliance Period Select one or more types of compliance period that are applicable to the new condition.

Ensure that the Enabled switch is turned on.
Click Save to save and return to the Category Sequence page.

Use the Save and New button to save this condition and clear the values so that you can enter values for
another condition of approval .

Modifying Conditions of Approval

1
2,
3.

4.

Select Conditions of Approval Setup > Conditions of Approval .

On the Conditions of Approval page, select the row for the condition that you want to modify.

On the Conditions of Approval details page, you can modify all the field values except the conditions of
approval ID.

Click Save.

Deleting Conditions of Approval

P UWNA

Select Conditions of Approval Setup > Conditions of Approval .

On the Conditions of Approval page, select the row for the condition that you want to delete.

On the Conditions of Approval details page, click Delete.

If you want to delete multiple conditions, you can delete them on the Conditions of Approval page:

a. Click the Select Multiple icon.
b. Select the check boxes for the condition rows to delete.
c. Click the Delete icon.

Note: You can’t delete a condition if it is applied to an application.

ORACLE
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Setting Up Conditions of Approval Templates

Conditions of approval are automatically applied to planning applications through templates. As agency administrators,
you create and configure conditions of approval templates by selecting the conditions of your choice.

Conditions of approval templates are associated with planning application types, which determine the type of template
that is applied to a submitted planning application. See the section Setting Up Conditions of Approval in Setting Up
Planning Application Types.

Adding Conditions of Approval Templates

Use the Conditions of Approval Template page to set up conditions of approval templates.

1. Select Conditions of Approval Setup > Conditions of Approval Template .

2. The Conditions of Approval Template page lists all the templates set up in the system. Click Add to add a new
template

3. The Conditions of Approval Template details page lists all the conditions that belong to the template. Enter
values for the following fields:

Page Element Description

Template ID Enter an identifier of the template.

Template Enter a name for the template.

Description Enter a description of the template.

Add Click the button to open the Conditions of Approval Template list page to add one or

more conditions.

4. The Conditions of Approval Template list page lists all the conditions in the system with details of the category,
subcategory, type, and compliance period. Search and select the conditions using the check boxes next to the
condition.

5. Click Save to save and return to the Conditions of Approval Template detail page.
Ensure that the Enabled switch is turned on.
7. Click Save to save and return to the Conditions of Approval Template page.

o
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5 Setting Up Code Enforcement

Setting Up Corrective Actions

Define the various corrective actions that can be applied to resolve code violations identified by an agency.

A corrective action can resolve more than one code violations. You add a corrective action using the Corrective Action
page and assign the action to one or more code references on the code configuration page.

Adding Corrective Actions

1. Select Code Enforcement Setup > Corrective Action.
2. Click Add on the Corrective Action page to add a new corrective action.
3. Onthe Corrective Action Details page, enter values for the corrective action.

Page Element Description

Corrective Action ID Enter a unique identifier for the corrective action.

Summary Enter a summary about the action that is to be taken to resolve the violation.

Description Enter longer descriptions or instructional information that can be formatted using a rich
text editor.

4. Verify that the Enabled switch is turned on. The option is active by default for a new corrective action.
5. Click Save.

Modifying Corrective Actions

You can modify corrective actions for the code violations on the Corrective Action page.

1. Select Code Enforcement Setup > Corrective Action .
On the Corrective Action page, select the row for the corrective action that you want to modify.

3. On the Corrective Action Details page, you can edit the summary and description. Click the Enabled switch to
enable or disable the corrective action.

4. C(lick Save to save the changes.

Deleting Corrective Actions

You can delete corrective actions for the code violations on the Corrective Action page.

1. Select Code Enforcement Setup > Corrective Action.
2. On the Corrective Action page, select the row for the corrective action that you want to delete.
3. Onthe Corrective Action Details page, click the Delete button.
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Setting Up Code References for Code Enforcement

Code references are pointers to the documentation for a specific code used on a violation. These references instruct
readers to refer to documentation for the specific item. Set up the Public Sector Compliance and Regulation system to
point the user to a specific documentation regarding that code violation.

Adding Code References

1.
2
3.

4.
5.

Select Code Enforcement Setup > Code Reference .
Click Add on the Code Reference page to add a new code reference.
On the Code Reference Details page, enter values for the code reference.

Page Element Description

Code Reference ID Enter a unique identifier of the code reference.

Summary Enter a summary about the violation that is related to the incident.

Description Enter longer descriptions or instructional information that can be formatted using a rich
text editor.

Corrective Action Select the corrective action that can be applied to resolve the violation.

Summary Displays information about the corrective action that will be taken to resolve the
violation.

Verify that the Enabled switch is turned on. The option is active by default for a new code reference.
Click Save.

Modifying Code References

You can modify code references on the Code Reference page.

1.
2,
3.

Select Code Enforcement Setup > Code Reference .
On the Code Reference page, select the row for the code reference that you want to modify.
On the Code Reference Details page, you can:

o Change the values for the summary, description, and corrective action fields.

o Click the Enabled switch to enable or disable the corrective action.

Click Save to save changes.
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Deleting Code References

You can delete code references on the Code Reference page.

1. Select Code Enforcement Setup > Code Reference .
2. Onthe Code Reference page, select the row for the code reference that you want to delete.
3. Onthe Code Reference Details page, click the Delete button.

Setting Up Code Reference Groups

A code reference group is a set of code references grouped together on the basis of the nature of violations. You set up
code reference groups on the Code Reference Group page.

Adding Code Reference Groups

1. Select Code Enforcement Setup > Code Reference Group .
2. The Code Reference Group page lists all the code reference groups. Click Add to add a new group.
3. Onthe Code Reference Group Details page, enter values for the code reference group.

Page Element Description
Code Reference Group ID Enter a unique identifier for the code reference group.
Name Enter a name for the code reference group.

4. Verify that the Enabled switch is turned on. The option is active by default for a new code reference group.

5. Inthe Code References section, click Add to search and include one or more code references to the group. Use
the Add and Delete action icons for adding and deleting code reference records.

6. Click Save.

Modifying Code Reference Groups

You can modify code references groups on the Code Reference Group page.

1. Select Code Enforcement Setup > Code Reference Group .
2. On the Code Reference Group page, select the row for the code reference group that you want to modify.
3. Onthe Code Reference Group Details page, you can:

o Change the name of the group.
o Use the Code References section to add new or delete existing code references.

o Click the Enabled switch to enable or disable the code reference group.

4. Click Save to save changes.
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Deleting Code Reference Groups

You can delete code reference groups on the Code Reference Group page.

1. Select Code Enforcement Setup > Code Reference Group .
2. On the Code Reference Group page, select the row for the code reference group that you want to delete.
3. Onthe Code Reference Group Details page, click the Delete button.

Setting Up Notices

A notice is a document issued by a code enforcement authority to the party that has violated a code. You set up code
enforcement notices that are used to generate and send reports to the concerned responsible parties.

Adding Notices

1. Select Code Enforcement Setup > Notice .
2. The Notice page lists all the notices. Click Add to add a new notice.
3. On the Notice Details page, enter values for the notice.

Page Element Description

Notice ID Enter a unique identifier of the notice.

Name Enter a name for the notice.

Report ID Select a report to be sent as part of the notice. This report is set up on the Report

Configuration page.

4. Verify that the Enabled switch is turned on. The option is active by default for a new notice.
5. Click Save.

Modifying Notices

You can modify notices on the Notice page.

1. Select Code Enforcement Setup > Notice .
2. Onthe Notice page, select the row for the notice that you want to modify.
3. On the Notice Details page, you can:

o Change the notice name.
o Select a new report ID.
o Click the Enabled switch to enable or disable the notice.

4. Click Save to save changes.
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Deleting Notices

You can delete notices on the Notice page.

1. Select Code Enforcement Setup > Notice .
2. Onthe Notice page, select the row for the notice that you want to delete.
3. On the Notice Details page, click the Delete button.

Setting Up Notice Groups

A notice group is a set of notices grouped together on the basis of the status of the case. The notices within a group
follow a sequence that you configure, to send to the concerned parties as and when required.

Adding Notice Groups

1. Select Code Enforcement Setup > Notice Group .
2. The Notice Group page lists all the notice groups. Click Add to add a new notice group.
3. Onthe Notice Group Details page, enter values for the notice group.

Page Element Description

Notice Group ID Enter a unique identifier of the notice group.

Name Enter a name for the notice group.

Enabled Verify that the Enabled switch is turned on. The option is active by default for a new

notice group.

4. Inthe Notice Associations section, you can configure the notices that are to be sent for a particular case status
and in a particular sequence.

Page Element Description
Case Status Select a case status to associate with the new notice group.
Sequence Select a value to determine the sequence of the selected notice within the hierarchy. For

example, if the value 2 is selected, the selected notice will be the second notice for the
selected case status.

Notice ID Select a notice that is specific to the case status and the sequence value.
Enabled Verify that the Enabled switch is turned on. The option is active by default for a new
notice.
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Page Element Description

Use the Add and Delete action icons for adding and deleting notice association records.

Note: You must ensure that valid notices are configured for the case status before you associate a notice

group with an issue subtype. Use ORA_VIO status to create a case. Use ORA_CIT status to issue a citation.

5. Inthe Ad Hoc Notice Associations section, you can configure an ad hoc notice that the agency staff can
manually add to a case.

Page Element Description
Notice ID Select a notice that is specific to the case.
Enabled Verify that the Enabled switch is turned on. This switch is off by default.

Use the Add and Delete action icons for adding and deleting ad hoc notice association records.
6. Click Save to save your changes.

Modifying Notice Groups

You can modify notice groups on the Notice Group page.

1. Select Code Enforcement Setup > Notice Group .
2. On the Notice Group page, select the row for the notice group that you want to modify.
3. On the Notice Group Details page, you can:
o Change the name of the notice group.
o Delete notice associations and create new ones.
o Click the Enabled switch to enable or disable the notice group.
4. Click Save to save changes.

Deleting Notice Groups

You can delete notice groups on the Notice Group page.

1. Select Code Enforcement Setup > Notice Group .
2. On the Notice Group page, select the row for the notice group that you want to delete.
3. Onthe Notice Group Details page, click the Delete button.
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Setting Up Inspection Counts

Define the number of inspections that are carried out to assess code violations reported at the agency. You use the
Inspection Count page to set up the inspection count value and its description.

Adding Inspection Counts

1. Select Code Enforcement Setup > Inspection Count .
2. (Click Add on the Inspection Count page to add a new inspection count.
3. Inthe new row, enter the count value in the Inspection Count field and a description in the Description field.

Note: The inspection count values must follow an incremental sequence of numbering, such as 1, 2, 3, and so
on.

4. Verify that the Enabled switch is turned on. The option is active by default for a new inspection count.
5. Click Save.

Deleting Inspection Counts

1. Select Code Enforcement Setup > Inspection Count .
2. On the Inspection Count page, click the Delete icon for the row of the inspection count you want to delete.

Note: You must ensure that the sequencing of numbers in the inspection count is maintained.

Setting Up Referral Bodies

Referral bodies are those departments that an agency can refer to in cases of code violations that are not in the scope of
the agency. The agency can assign the issue to the referral body based on the referral type.

Adding Referral Bodies
1. Select Code Enforcement Setup > Referral Body .

The Referral Body page lists all the referral bodies that are configured by the agency.
2. Click Add on the Referral Body page to add a new referral body and enter values for the following fields:

Page Element Description
Referral Code Enter an identifier of the referral body.
Name Enter a name for the referral body.
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Page Element Description
Description Enter a description about the referral body on the basis of which, an incident or case can

be referred to the body.

Referral Type Select the type of referral, which can be a department within the agency or an external
agency:

o Agency Department.

o External Agency.

3. Verify that the Enabled switch is turned on. The option is active by default for a new referral body.
4. C(lick Save.

Modifying Referral Bodies

1. Select Code Enforcement Setup > Referral Body .
2. On the Referral Body page select the row for the corrective action that you want to modify.
3. On the referral body details page, you can:

o Change the name, description, and referral type values.
o Click the Enabled switch to enable or disable the referral body.

Note: You cannot delete a referral body.

4. Click Save to save changes.

Setting Up Time Rules

Time rules are a set of policies that uses the input code enforcement inspection parameters — due date type, trigger
date, priority, and occurrence to calculate due dates.

The following logic is used to calculate due date:
Due Date = Trigger date + Dates based on the time rule

If the number of transactions created exceed the policy count, then the time rule that is defined for the highest policy
occurrence will be triggered.

Time rules are assigned to the issue subtype of the incident, the values of which are sourced from the Code
Enforcement Options page. See Setting Up Agency-Level Options for Code Enforcement.

Note: Important!: Agency administrators add and modify time rules and assign them to issue subtypes so that
appropriate rules are applied for each subtype. Every issue subtype must have a time rule assigned for every system-
defined due date type. See Setting Up Issue Subtypes. The following table shows the various delivered due date types
and their details.
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Due Date Type

ORA_INC_REV_DUEDT

ORA_INIT_INS_DUEDT

ORA_RE_INS_DUEDT

ORA_VIOL_CMPL_
PRD_DUEDT

ORA_VIOL_APPL_
PRD_DUEDT

ORA_CITATN_CMPL _
PRD_DUEDT

ORA_CITATN_DUEDT

ORA_CITATN_APPL _
PRD_DUEDT

ORA_ABTMT_DUEDT

ORACLE

Description

Incident review date

Initial inspection date

Re-inspection date

Due date for
compliance

Violation appeal
period

Due date for citation
compliance

Due date for citation
payment

Citation appeal period

Abatement of violation
due date

Events that calculate
the due date

Incident creation

Initial inspection
creation

Re-inspection creation

Case creation

Case status change to
Violation.

Citation issuance

Payment initiation

Case status change to
Citation.

Trigger Date

Incident report date

Inspection schedule
date

Inspection schedule
date

Case creation date

Case creation date

Citation issue date

Citation issue date

Citation Issue Date

Usage

The incident in the
worklist is marked with
a status of Overdue
when the calculated
review due date is less
than the current date.

The Inspection due
date is updated with
this date when the
initial inspection is
scheduled.

The Inspection due
date is updated with
this date when the
re-inspection is
scheduled.

The date is displayed
as the compliance date
on the Case page.

The value for the
policy occurrence
count is zero (0) at the
time of case creation.

Ensures that the
Request Appeal option
is available only during
the calculated appeal
period.

Updates the
compliance date
displayed on the Case
detail page.

Late fee is added after
the citation payment
due date.

Ensures that the
Request Appeal option
is available only during
the calculated appeal
period.

At present this due
date type is not active.
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Policy Occurrence
Count value

1

2 or more

o

1or more

1or more

1or more

1or more
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Adding Time Rules

You configure the time rules and policies using the Time Rule page.
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1. Select Code Enforcement Setup > Time Rule . The Time Rule page lists all the time rules that are configured

by the agency.

2. Click Add on the Time Rule page to add a new time rule.
3. Onthe Time Rule Detail page, add values to the following fields:

Page Element

Time Rule

Description

Due Date Type

4. Verify that the Enabled switch is turned on. The option is active by default for a new time rule.

Description

Enter a name for the time rule.

Enter a description about the time rule.

Select the type of due date, which determines the time period or due date for a

transaction.

5. Inthe Time Policy section, click the Add button to define a time policy.
6. On the Time Policy Details page, select values for the time policy:

Page Element

Priority

Unit of Measure

Unit of Measure Value

Policy Occurrence Count

ORACLE

Description

Select the priority for the time policy:

o High

o Normal

Select a unit for the measurement of time:

o Hours

o Days

Note:
The Hours option is not supported at present.

Select a number value for the unit of measure of time you selected above.

Select an occurrence count value for the event, such as an inspection.
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Modifying Time Rules

Select Code Enforcement Setup > Time Rule.

Select the time rule row you want to modify.

On the Time Rule Detail page you can change the time rule description, due date type, and the time policy.
Click the Enabled switch to enable or disable the time rule.

Click Save to save changes.

VAhUWND

Deleting Time Rules

1. Select Code Enforcement Setup > Time Rule .
2. Select the time rule row you want to delete.
3. Onthe Time Rule Detail page, click the Delete button.

Modifying Time Policies

1. Select Code Enforcement Setup > Time Rule .

2. Onthe Time Rule page, select the time policy row to open the Time Policy Detail page. You can change values
for priority, unit of measure, unit of measure value, and policy occurrence count.

3. Click Save to save any changes.

Deleting Time Policies

Select Code Enforcement Setup > Time Rule.

On the Time Rule page, select the time rule row for which you want to change the time policy.

On the Time Rule Detail page, click the time policy row to open the Time Policy Detail page.

Click the Delete button.

To delete multiple time policies from the Time Rule Detail page, click the Edit button in the Time Policy section
and select the check boxes for the rows you want to delete.

Click Delete.

VAhUWND

o

Setting Up Agency-Level Options for Code Enforcement

Agency-level options for code enforcement include several settings related to the public user experience, assignment
and autonumbering rules, and default settings for newly created issue types.

Agency-level options for code enforcement include settings such as:

- Whether public users can report issues anonymously.
- Whether incidents are automatically routed based on the issue type and subtype.
- The work schedule of the agency.
- The time period used for displaying recent issues on the public user map.
- Autonumbering rules for notices, citations, and inspections.
- Configuration for the public user landing page.
Default code reference groups for issues types.
Default time-based processing rules for issue types.

For more information about agency setup, see Setting Up Agencies.
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To configure agency level options for code enforcement:

Select Common Setup > Agency.

Click a row on the Agency Information tab.
Select the Features tab.

Click Options for the Code Enforcement offering.

PN

The Code Enforcement Options window opens.
5. Configure the setting in the Intake Form section.

Page Element Description

Contact Information Required Enable this switch to require contact information from users who submit issue reports.

If the switch is not enabled, then the page where users supply contact information
includes a Hide my contact information switch. When users hide their contact
information, name and contact information is no longer required, and any data currently
in those fields gets cleared.

Even if you don'’t require contact information, users must be registered and signed in to
report an issue.

6. Configure settings in the Issues section.

Page Element Description

Automatically Route Issues Enable this switch to activate issue routing based on the issue type and subtype.

When automatic routing is active, the Incoming Incidents worklist tab displays only
incidents with the issue types and subtypes that are part of the user’s job function.

If there’s only one code enforcement technician responsible for a particular issue type or
subtype, then those issues are assigned to that technician automatically.

Schedule ID Select an agency schedule from a list. This enables inspections to be scheduled based
on the availability of the code officers.

Due date calculations are based on the time rules set up and the schedule you select
here. If the resulting due date is on a non-working day, then the next working day is set
as the due date.

7. Configure the settings in the Recent Cases section.

Public users can view a map with markers identifying recent issues. These settings define which issues appear
on the map.
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Page Element Description
Period Choose how far back to look for issues by entering number of days or months, and then

selecting Days or Months. Issues that were created within the specified time period
appear on the map.

Status Select All to display all recent issues, regardless of status.

Select Active to display only issues that haven't been closed yet.

8. Use the Inspection section to configure inspection autoassignment.

Page Element Description
Autoassignment Indicate whether to enable automatic scheduling and assignment of incident and case
inspections.

Maximum Inspections per Day per Enter the maximum number of inspections per day for code officers. The
Code Officer autoassignment process will not assign inspections to officers who are at the maximum,
but users can manually exceed this maximum.

If you don’t enter a maximum, inspections will not be autoassigned.

9. Use Autonumber Rules section to select the following autonumber rules:

Page Element Description

Notice Autonumber Rule Select the autonumbering rule to increment numbers for notices.
Citation Autonumber Rule Select the autonumbering rule to increment numbers for citations.
Inspection Autonumber Rule Select the autonumbering rule to increment numbers for inspections.

Note: For more information, see Setting Up Autonumbering. These fields are required if the Code
Enforcement offering is enabled for your agency.

10. Use the Agency Features section to optionally enable the Guest Users Can Report Incidents feature.

Use these fields in the Agency Features grid to enable or disable specific code enforcement features:
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Page Element

Feature Code

Name

Enabled

Delete

Description

Enter the code for the feature to be enabled. The only available feature code is ORA_

PSCR_CREATE_INCIDENT, for the Guest Users Can Report Incidents feature. This feature

enables public users to report issues without registering or signing in first.

Displays the name of the selected feature code.

Use this switch to enable or disable the feature.

Click this icon to remove a feature from the grid.
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11. Use the Landing Page Message Definition section to enter these settings for the code enforcement landing

page:

Page Element

Message Title

Message Summary

Content URL

Landing Page Message

ORACLE

Description

Enter a short title or welcome statement for the code enforcement landing page. For
example, Welcome or <City Name> Code Enforcement.

This appears message appears as a title, in large text.

Enter a subtitle for the code enforcement landing page. For example, Keeping our city
safe and healthy.

This text appears is medium-sized text under the larger main title for the page.

Enter a content URL for the Read More link that appears on the landing page next to
the Message Summary text. Public users click this link to access a code enforcement
information page that your agency maintains.

If you leave this field blank, the Read More link opens a dialog box that displays the
Landing Page Message.

Note:
If you want to link to a page outside of Oracle Public Sector Code Enforcement, you
must enter a URL here.

If you do not provide a Content URL that points to an agency-maintained information
page, enter the text that will appear in the Read More dialog box. Rich text formatting
tools are available for this message.
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12. Use the Code Reference Group section to define the default code reference groups for new issue types.

Enter the first code reference group in the blank row that appears. Use the Add button to add additional rows.
Each row has the following elements:

Page Element Description

Group ID Select a code reference group that will be added by default to all newly created issue
types.

Enabled Turn this switch on to have the code group added by default to newly created issue
types.

If the switch is off, the code group is not added to newly created issue types.

Delete Click to remove the row from the list of default code reference groups.

13. Use the Time-Based Rules section to define the default time-based rules to be entered automatically into
newly created issue types.

This section displays rows for all of the due date types that require time rules. You can’t add or remove rows.
Instead, you must supply a time rule for each due date.

For more information about time rules, see Setting Up Time Rules.

Page Element Description

Due Date Type ID Displays the unique identifier for the type of due date.

Due Date Type Displays the description of the type of due date — for example, Incident review date
Time Rule ID Select the time rule ID that specifies how the due date is calculated. The time rule ID

includes a time policy that states how many days or hours until the due date.

Time rules IDs are available for selection if they have the specified due day type and
they are enabled.

14. Click Save, then close the window.

Setting Up Issue Types

Issue types are broad categories that are used to report code enforcement issues.
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Adding an Issue Type

To create a new issue type:

1. Select Code Enforcement Setup > Issue Type.
2. Onthe Issue Type page, click Add.
3. On the Issue Type Details page, enter the following general information about the issue type:

Page Element

Issue Type ID

Issue Type

Valid From Date

Valid To Date

Status

Icon

Description

4. C(lick Save.

Description

Enter a unique alphanumeric code for the issue subtype. Do not use special characters,
including symbols or punctuation, or spaces.

Enter a short name for the issue type.

Enter the first date that the issue type is available for issue reporting.

Enter the last date that the issue type is available for issue reporting. The default value is
Open, indicating that the issue type will remain available indefinitely.

Select Active or Inactive.

Inactive issue types are not available for issue reporting. They also are not available to
add to an issue subtype definition.

Select an icon for the tile that public users click when reporting this type of issue .

Enter a description of the issue type. This description appears on the back of the tile
that users click when reporting this type of issue.

When the issue is saved, three additional sections appear: Issue Subtypes, Code Reference Group, and Time-

Based Rules.

You don't need to enter information in the Issue Subtypes section. The relationship between issue types and
issue subtypes is established when you set up the issue subtype. After you create the related subtypes, you can
return to the Issue Type Details page to view a complete list of subtypes for the issue type.

5. Configure thelist in the Code Reference Group section.

a. Expand the section and review your agency’s default values, if any.

The default values come from the Code Enforcement Options page. For more information, see Setting Up
Agency-Level Options for Code Enforcement.

If your agency does not have default code reference groups, a blank row appears.

ORACLE
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b. For each code reference group, review or enter the following settings:

Page Element Definition

Group ID Select a code reference group that will be added by default to all newly
created issue subtypes.

Enabled Turn this switch on to have the code reference group added by default to new
issue subtypes for this issue type.

If the switch is off, the code group is not added to new issue subtypes for this
issue type.

c. To add additional code reference groups to this issue type, click the Add icon and enter information in the
new row.
d. To remove code reference groups from the issue type, click the Delete icon.
6. Configure the list in the Time-Based Rules section:

This section displays rows for all of the due date types that require time rules. You can’t add or remove rows
from this list. Instead, you must supply a time rule for each due date.

For more information about time rules, see Setting Up Time Rules.
To set up time rules for the issue type:
a. Expand the section and review your agency’s default values.

These default values also come from the Code Enforcement Options page.
b. For each rule, review or enter the following settings:

Page Element Definition

Due Date Type ID Displays the unique identifier for the type of due date.

Due Date Type Displays the description of the type of due date — for example, Incident
review date.

Time Rule ID Select the time rule ID that specifies how the due date is calculated. The time

rule ID includes a time policy that states how many days or hours from the
trigger date until the due date.

Time rules IDs are available for selection if they have the specified due date
type and they are enabled.

7. Click Save again if you made any changes in the sections for code reference groups and time-based rules.
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Viewing or Modifying an Issue Type

To view or modify an issue type:

1. Select Code Enforcement Setup > Issue Type.
2. Click the row for the issue type you want to view or modify.

The Issue Type Detail page appears. Because the issue type has already been saved, the page displays all fields,
including the sections for Issue Subtype Details, Code Reference Group, and Time-Based Rules.

3. Make any necessary updates.

4. C(lick Save if you made any updates.

Inactivating an Issue Type

You cannot delete issue types, but you can make them unavailable for use by changing the status to Inactive.

To inactivate an issue type:

1. Select Code Enforcement Setup > Issue Type.
2. Click the row for the issue type you want to modify.

The Issue Type Detail page appears.
3. Change the Status to Inactive.
4. C(Click Save.

Setting Up Issue Subtypes

Code enforcement issue subtypes are the lowest level of categorization for code enforcement issues. When you set up
an issue subtype, you also create the intake form and define processing rules for issues that are reported under this
subtype.

Adding an Issue Subtype

To create a new issue subtype:

1. Select Code Enforcement Setup > Issue Subtype.
2. Onthe Issue Subtype page, click Add.
3. On the Issue Subtype Details page, enter the following general information about the issue subtype:

Page Element Description

Issue Subtype ID Enter a unique alphanumeric code for the issue subtype. Do not use special characters,
including symbols or punctuation, or spaces.

Issue Subtype Enter a short name for the issue subtype.
Issue Type ID Select the issue type that represents the broad category under which this issue subtype
falls.
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Page Element

Status

Valid From Date

Valid To Date

Public User Enabled

Case Autonumber Rule

Incident Autonumber Rule

Fee Schedule

ORACLE

Description

Only active issue types are available for selection. If an issue type is later inactivated, the
issue type and all of its associated issue subtypes become unavailable to public users.

Select from the following to indicate the issue subtype status:

o Preliminary: The issue subtype is being defined but is not available for use.

o Ready: The issue subtype is ready for testing or production use, depending on the
environment.

o Void: The issue subtype is no longer available.

Note:

The issue subtype can be set to ready regardless of whether the intake form is in
published status or draft status. A form in draft status can be accessed for testing
purposes in the development or test environment.

Enter the first date that the issue subtype is available.

Enter the last date that the issue subtype is available. The default value is Open,
indicating that the issue subtype will remain available indefinitely.

Select from the following to indicate which types of users can access the intake form
outside of the form designer:

o Enabled for all users: Both registered public users and agency users can access the
intake form.

o Enabled for registered users: Both registered public users and agency users can
access the intake form.

o Not enabled for public users (default): Only agency users can access the intake
form.

For more information, see Publishing Intake Forms.

Select the autonumbering rule to increment numbers for cases based on this issue
subtype.

For information, see Setting Up Autonumbering.

Select the autonumbering rule to increment numbers for incidents based on this issue
subtype.

Select the fee schedule to use for citations based on this issue subtype.

For more information, see Creating Decision Models for Fees.
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Page Element Description
Notice Group ID Select the notice group to use when generating notices for a case based on this issue
subtype.

For more information see Setting Up Notice Groups.

District Type Select the code enforcement district type to be used for incidents with this issue
subtype.

For example, if issues with this subtype are handled by the fire department and
inspected based on fire prevention districts, then the district type might be your fire
prevention district type.

Icon Select an icon for the tile that public users click when reporting issues with this subtype.

Description Enter a description of the issue subtype. This description appears on the back of the tile
that users click when reporting issues with this subtype.

4. C(lick Save.
When the issue is saved:

o The Design Form button is activated and the Form Status appears at the top of the page.
o The Code Reference Group and Time-Based Rules sections appear.

5. Review the read-only Form Status, which indicates whether the intake form is published or in development.
These are the status values for the intake form:

o Draft: The form design is incomplete. Form designs in draft status are not migrated to other
environments and can’t be cloned.

o Published: The form design is complete. Form designs in published status can be migrated to other
environments and can be cloned.

6. Configure thelist in the Code Reference Group section.
a. Expand the section and review the default values, if any.

The default values come from the associated issue type. For more information, see Setting Up Issue
Types.

If your agency does not have default code reference groups, a blank row appears.
b. For each code reference group, review or enter the following settings:
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Page Element Definition
Group ID Select the code reference group with the code references to be included

by default in notices of violation that are based on this issue subtype. The
person who generates the notice can remove specific code references from
the notice.

Enabled Turn this switch on to make the code reference group available for issues with
this subtype.

c. To add additional code reference groups to this issue subtype, click the Add icon and enter information in
the new row.

d. Toremove code reference groups from the issue subtype, click the Delete icon.
7. Configure the list in the Time-Based Rules section.

This section displays rows for all of the due date types that are defined in the issue type. You can’t add or
remove rows. Instead, you must supply a time rule for each due date.

For more information about time rules, see Setting Up Time Rules.
To set up time rules for the issue subtype:
a. Expand the section and review the default values.

The default values come from the issue type that you entered when creating the subtype. Changing the
issue type does not update these values.

b. For each rule, review or enter the following settings:

Page Element Definition

Due Date Type ID Displays the unique identifier for the type of due date.

Due Date Type Displays the description of the type of due date — for example, Incident
review date.

Time Rule ID Select the time rule ID that specifies how the due date is calculated. The time
rule ID includes a time policy that states how many days or hours until the
due date.

Time rules IDs are available for selection if they have the specified due day
type and they are enabled.

8. (lick Save if you made any changes in the sections for code reference groups and time-based rules.
9. Create the issue intake form for this issue subtype.
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Note: Oracle provides a template for code enforcement intake forms. Even if you plan to use the delivered
form as-is, you still need to go through the process of creating the form based on the delivered template.

a. Click the Design Form button.

b. Review the default issue intake form and add any user-defined fields to the drop zone on the Just a Few
More Questions page tab.

c. Save the form, and when you’re done designing the form, publish it.

For detailed instructions on creating the issue intake form, see Using the Intake Form Designer for Code
Enforcement.
10. To make the issue subtype available to end users:

Return to the Issue Subtype Detail page.

Confirm that the Public User Enabled field is either Enabled for all users or Enabled for registered users.
Change the Status to Ready.

Click Save.

angoyo

Modifying an Issue Subtype

To modify an issue subtype:

1. Select Code Enforcement Setup > Issue Subtype.
2. Click the row for the issue subtype you want to modify.

The Issue Subtype Detail page appears. Because the issue subtype has already been saved, the page displays all
fields, including the sections for Code Reference Group and Time-Based Rules.

3. Make any necessary updates to the issue subtype.

4. C(Click Save.

5. Use the Design Form button to access the form designer if you need to make changes to the intake form.

Deactivating an Issue Subtype

You cannot delete issue subtypes, but you can mark them as void.

To deactivate an issue subtype:

1. Select Code Enforcement Setup > Issue Subtype.
2. Click the row for the issue subtype you want to modify.

The Issue Subtype Detail page appears.
3. Change the Status to Void.
4. C(Click Save.

Cloning Issue Subtypes

I Note:

To clone an issue subtype:

1. Select Code Enforcement Setup > Issue Subtype.
2. Click the row for the issue subtype you want to clone.
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3. On the Issue Subtype Detail page, click the Clone button.
4. On the Clone Issue Subtype page, review or enter the following information:

Page Element

Original Issue Subtype and
Original Issue Subtype ID

New Issue Subtype and New Issue
Subtype ID

Clone Code Reference Groups

Clone Time-Based Rules

Clone Form Design

5. Click Create.

Description

These fields display identifying information about the issue subtype that you're cloning.

Enter a new identifier and short description for the issue subtype that you're creating.

When this switch is on, the code reference groups in the original issue subtype are
copied over to the newly created issue subtype.

When this switch is off, the new issue subtype will have the default code reference
groups from the issue type.

When this switch is on, the time-based rules in the original issue subtype are copied
over to the newly created issue subtype.

When this switch is off, the new issue subtype will have the default time-based rules
from the issue type.

When this switch is on, the original issue subtype’s form design is copied to the new
issue subtype.

When the switch is off, the new issue subtype does not have an intake form until you
design one.

A new issue subtype is created. The information on the Issue Subtype Details page is identical to the cloned
subtype, except that the Status is always Preliminary.

6. Make any necessary modifications to the issue subtype and save.
7. Make any necessary changes to the intake form (or create the form if you did not copy it from the original issue

subtype).
8. Publish the intake form.

9. Make the subtype available to end users by updating the Status and, if necessary, the Public User Enabled

setting.

ORACLE
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6 Setting Up Business Licenses

Setting Up Business License Types

Define the types of business licenses supported by an agency, including consultations. You add a business license type
and associate workflow process definitions on the Business License Type definition page.

Before you can create an application form, you must first create a business license type on the Business License Type
definition page. The type defines attributes that will be available on the business license application.

Adding Business License Type Definitions

1. Select Business License Setup > Business License Type > Business Licenses .
2. Click Add.
3. Let’s take a look at the fields for defining a business license type:

Page Element Description

Classification Displays the type of business license. The classification for this page indicates that this
type is associated with a business license application.

Subclassification Displays the subclassification.

If you would like to create a consultation type, select Consultation from the drop-down
list. The default value is Not Applicable, which indicates a standard business license

application.
Business License Type Enter a name for the type of business license.
Business License Type ID Enter a unique alphanumeric code or short name for the business license type. Do not

use special characters, including symbols or punctuation, or spaces.

Status Select from the following to indicate the business license type status:

o Preliminary: The business license type is being defined but is not available for use.

o Ready: The business license type is ready to be accessed for testing or production
use, depending on the environment.

o Void: The business license type is no longer available.
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Page Element

Form Design Status

Autonumber Rule

Valid from Date and Valid to Date

Public User Enabled

Application Group

Category

ORACLE

Description

Note:

The form design can be in published status or draft status and be set to Ready. In
draft status, the form can be accessed from outside the form designer — such as the
Apply page — for testing purposes in the development or test environment.

A read-only field indicating whether the form design is published or currently being
developed.

o Draft: The form design is currently being created or modified. Form designs in
draft status are not migrated to other environments and can’t be cloned.

o Published: The form design is complete. Form designs in published status can be
migrated to other environments and can be cloned.

Select the autonumbering rule to increment numbers for business license applications.
You can delete an autonumbering rule when it isn't being used by any transaction types.

For more information, see Setting Up Autonumbering.

Enter a range of dates when this business license type is valid. The default from date is
the current date. The default end date is Open. You can update these dates as needed.

Select from the following to indicate whether the business intake form can be accessed
and by which user types.

o Enabled for all users: Only registered public users and agency users can access the
intake form.

o Enabled for registered users: Only registered public users and agency users can
access the intake form.

o Not enabled for public users (default): Only agency users can access the intake
form.

Note:
Currently, Enabled for all users and Enabled for registered users have equivalent
access.

Select an application transaction group that you want to associate with the business
license type.

For more information, see Setting Up Transaction Groups.

Select a transaction category that you want to associate with the business license type.

For more information, see Setting Up Transaction Categories.
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Page Element

Subcategory

NAICS Group

Tax Class

License Period Format and Period
Format Preview

Document Group

ORACLE

Description

Select a transaction subcategory that you want to associate with the business license
type.

For more information, see Setting Up Transaction Subcategories.

Select a group of North American Industry Classification System (NAICS) codes for the
business license type.

The NAICS group associated with the business license type determines which NAICS
codes are available to select when applying for a business license.

For more information, see Setting Up NAICS Groups.

Note:
If you don't select a value in this field, applicants using this business license type can
select any NAICS code that is added and enabled for any NAICS group.

Select a tax class that should apply to the business license.

A class tax defines the attributes that will apply to the license, its renewal, and on
amendments.

For more information, see Setting Up Business License Tax Classes.

Note:

The predefined field group for Tax Related Details must be included in the intake
form design to ensure that the tax related detail section is included in the intake form
and the license detail.

Select the format for displaying the license period, when the license is valid as defined in
the application.

This value will be displayed on the business license in the format you select, as shown
in the preview field. For example, an annual license period displays the year if you select
yyyy, where yyyy indicates the year. If the license period is quarterly, semi-monthly, or
fiscal year, you might select MMM yyyy, where MMM indicates the first three letters of
the month.

Select a document group to manage attachments for the business license type.

When you specify a document group, document attachments can be classified into
categories and subcategories during the application process and when you upload
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Page Element

Fee Schedule

Bill Type

Department

Terms of Use ID

Description

URL

ORACLE

Description

files. Then you can see the category for a document on the attachments page in the
application details.

For more information, see Setting Up Document Groups.

Select a fee schedule that you want to associate with the business license type. A
department is required when you enter a fee schedule ID.

For more information, see Setting Up Fee Schedules.

Select a bill type to associate with the business license type.

The billing type identifies the type of invoice that can be generated from the record. The
bill type is required.

For more information, see Setting Up Bill Types.

Select a department that you want to associate with the business license type. A
department is required if you add a Fee Schedule ID to the business license type.

If a department is specified on the Fee Item setup page, the fee item department
overrides the department specified here on the business license type.

For more information, see Setting Up Departments.

Select a terms of use definition to associate with the business license type. The available
values for business licenses are determined by the usage on the terms of use ID.

For more information, see Setting Up Terms of Use.

Enter a user-facing description of the business license type. On the Apply page, this
description appears under the application type name.

The description helps public users understand the purpose of the application type.

Enter a URL for a web page that gives public users more information about the business
license type.

If you enter a URL, then a Learn More link appears at the end of the application type
description on the Apply page. The user clicks this link to open the specified URL.

If you leave this field blank, the Learn More link is not visible on the Apply page.
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Associating a Business License Certificate

First, your agency sets up the certificate template in the reports catalog, then associates the report ID with the business
license type in the Certificate section. You can generate the certificate for this type of business license from the
business license overview page when the license is issued.

Page Element Description

Allow Public User to View Turn on the switch to allow public users to view the issued business license certificate, which is
accessed from the business license summary on the Overview page.

Report ID Enter the report ID for the business license certificate template associated with this business license
type. Use the delivered business license certificate report or configure your own. See Setting Up
Reports.

For information about viewing the business license certificate, see Viewing the Business License.

Setting Up License Activity and Expiration Options

Depending on the business license type definition, businesses can renew or amend their licenses online. You also
associate expiration rules with the business license type in the License Activity and Expiration section.

Page Element Description

Allow Amendment Turn on the switch to enable the applicant and agency staff to submit an application for an amended
business license using this business license type.

After you enable amendments, you define the workflow for amendments in the Workflow Setup

section.

Allow Renewal Turn on the switch to enable the applicant and agency staff to submit an application for a license
renewal using this business license type.

After you enable renewals, you define the workflow for renewals in the Workflow Setup section.

Expiration Group Enter the expiration group that defines the expiration rules for this business license type. Expiration
rules determine the expiration dates for the application and business license or consultation. For more
information about business license expiration, see Setting Up Business License Expiration Rules.

Setting Up Workflow for Business Licenses

You set up a workflow for the initial application as well as amendments and renewals, if applicable, when you define
the business license type. Before you begin, you must define a workflow for each type of application using the Oracle
Autonomous Integration Cloud (OIC).

For more information about setting up workflows, see Setting Up Process Definitions for Workflow.
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You'll see the workflow setup fields for applications but also for amendments and renewals, depending on how you've
set up your business license type. The columns will have headers like this:

- Application: Default column when you're creating the business license type.
- Amendment: Additional column when you switch on Allow Amendment.

- Renewal: Additional column when you switch on Allow Renewal.

Page Element Description

Space Name Enter the space where the workflow process application is stored. You can group related applications in
a space as well as enable users to collaborate when developing applications.

Application ID Enter the name of the workflow process application in OIC. For more information, see Creating and
Managing Applications.

Version Enter the version of the workflow process application.

Process Definition Enter the name of the workflow process definition that applies to this particular business license.

I Note: Different business license types can utilize the same workflow definition.

Cloning Business License Types

Click the Clone button to create a clone of the current business license type, which you can then use to create a different
business license or to create a different version of the current business license.

For more information on cloning transaction types, see Cloning Transaction Type Definitions.

Designing Intake Forms

After you've entered the appropriate initial information for the business license type, you can then begin to design the
intake form that end users will use to submit an online application for a business license. You create an intake form
using the designer. You access the designer by clicking the Design Form button.

For more information on designing intake forms, see Using the Intake Form Designer.

Setting Up Business License Display Groups
Use the Display Group setup pages to display groups of business licenses on your agency’s landing page, where you
start an application.

A display group identifies a meaningful grouping of business license types displayed as a list on the Apply page. The list
appears as the business licenses that agency staff or a guest can select to initiate the application process.

For more information about how the Apply page looks and is used, see Choosing an Application Type.
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Before setting up business license display groups, you must set up the types of business licenses your agency offers.
See Setting Up Business License Types.

Adding Business License Display Groups

1. Select Business License Setup > Business License Display Group .
2. On the Business License Display Group page, click Add to add a new group.
3. Onthe Business License Display Group Details page, enter values for the following:

Page Element Description

Display Group ID Enter a business license display group name.

Display Group Enter a name for the display group that appears on the Apply page for guests and
agency staff.

Description Enter a description of the display group that appears on the Apply page for guests and
agency staff.

URL Enter a URL that agency staff can use to access additional information. This page is the

only place that the URL appears, so it is not available to guests.

Applicable Classification Select the check box for the applications to which this display group applies. Choose
from these options:

o Business Licenses
o Permits
o Planning and Zoning

This option determines whether a display group type is shown on the Apply page for
public users. A display group can be included with more than one classification.

4. Verify that the Enabled switch is turned on. The switch is turned on by default for new display groups.
5. Inthe Display Group Lines section, click Add to set up a line on the Display Group Line Details page. The
display group lines are transaction types that make up the list in the new display group.

Note: A mix of different transaction types can be added to a display group. For example, you can add a
planning application transaction type to a permit application display group and the other way around.

Page Element Description

Display Order Enter a numerical value in this field to specify the order in which you want the business
license types to be displayed, if desired. The default value is O and upon saving, the
system automatically assigns the next value.
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Page Element Description
Transaction Type ID Select an existing transaction type ID.

The description for the ID you enter here will appear in the Transaction Type field.

Transaction type information Review the attribute information for the business license type to verify you have
selected the correct transaction type ID:

o Transaction Type
o Classification

o Application Group
o Category

o Subcategory

For more information about transaction type attributes, see Setting Up Business License
Types.

6. On the Business License Display Group Details page, click Save.

Modifying Business License Display Groups and Lines

You can modify the display groups and the business licenses in the list on the Business License Display Group Details
and Display Group Line Details pages, respectively.

1. Select Business License Setup > Business License Display Group .
2. On the Business License Display Group page, select the row for the business license group that you want to
modify.
3. On the Business License Display Group Details page, you can:
o Modify the group name and description. You can’t change the Display Group ID.

o Turn the Enabled switch on or off to enable or disable the display group.

>

If you made any changes, click Save.

5. To modify the display group lines (the list of business licenses in a display group), select the row for the
business license group that you want to modify on the Business License Display Group page.

On the Business License Display Group Details page, select a display group line in the Display Group Lines grid.
7. On the Display Group Line Details page, you can change the values in these fields:

o

a. Update the Display Order field to change the order in which the lines appear.
b. Update the Transaction Type ID field with another existing business license type ID.
8. If you made any changes, click Save.

Deleting Business License Display Groups and Lines

1. Select Business License Setup > Business License Display Group .

2. On the Business License Display Group page, select the row for the business license group that you want to
delete.

3. If you want to delete the display group, click Delete on the Business License Display Group Details page.
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4. If you want to delete multiple display groups, you can delete them from the Business License Display Group
page:

a. Click Edit.
b. Select the check boxes for the display groups to delete.
c. Click Delete.

5. To delete a display group line, go to the Business License Display Group Details page and select a display group
line in the Display Group Lines grid.
6. On the Display Group Line Details page, click Delete.

7. If you want to delete multiple display group lines, you can delete them from the Business License Display Group
Details page:

a. Click Edit.
b. Select the check boxes for the display group line rows to delete.
c. Click Delete.

Setting Up Business License Expiration Rules

You can set up expiration rules for business licenses and consultations that will be associated with the business license
types your agency offers.

You can set up expiration rules for business licenses to define:
- When an inactive pending application expires.
- When the business license expires based on either a fixed date or when the license was issued.

For business license consultations, you can set up rules to define when an inactive pending application expires or when
the consultation recommendations expire. As you set up the expiration rules, keep in mind the type of business license
the rules are for.

First, you define the rules in an effective-dated group. After setting up the expiration rules, you add the rules group ID
to the business license type definition and periodically run batch rules processing to update the expiration statuses.
Oracle recommends that you schedule expiration rule processing to run daily.

Setting Up Expiration Rule Groups
Here’s how to set up the rule group:

1. Select Business License Setup > Business Expiration Group .
2. Select Add on the Expiration Group page.

You enter values for these fields on the Business License Expiration Group page to define the group.

Page Element Description

Expiration Group ID, Expiration Enter an ID for the expiration group, a group name, and description.
Group Name, and Description
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Page Element

Subclassification

Effective Start Date and Effective
End Date

Show All Dates

Description

Select Not Applicable for a business license or Consultation for a business license
consultation. Use Consultation if you are applying this group of rules to a business
license type definition with a consultation subclassification.

Enter the range of dates when the group is effective. If you want to leave the effective
dates open-ended, don’t enter a date for the end date.

To see the effective date history for an expiration group, click Show All Dates. On the
History Data page, you can search history by effective start date or click Add to add new
effective-dated rules for an expiration group.

Click to access the effective-dated history of the rules definition. This button is available
after you create the first rule.

You can also search history by effective start date. Click Add to create a new effective-
dated row for an expiration group.

3. Verify that the Enabled switch is turned on. The option is active by default for a new expiration group.
4. Create expiration rules in the Expiration Rules section.

Defining Expiration Rules

Here’s how to set up the details about the expiration rules in the group:

1. Click Add in the Expiration Rules section on the Business License Expiration Group page.

2. Select the Expiration Basis for your rules. The expiration basis is the type of expiration rule you are defining.
For business licenses, you can create these rules:

o Inactive pending application

When the business license application is in a pending status, the applicant must submit the application
before the expiration date.

The expiration timeframe begins when the applicant saves a business license application and ends when
the application is submitted.
o License expiration - fixed date or License expiration - issued date

You must select whether the license expiration is based on a fixed date or when the license is issued.
For example, if you want to set up the license to expire every year on June 30, you select the fixed date
expiration rule. You must enter the expiration interval for licenses that expire on a fixed date. You define
whether the license expires monthly, quarterly, yearly, and so on. Or you can set up the rules so that the
license is valid for an amount of time, such as 6 months, from the time when the license was issued.

Both fixed date and issued date expiration rules are initiated when the business license has an Active

status.
o Consultation expiration

This rule type is only available when the expiration group subclassification is Consultation.

ORACLE
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The expiration timeframe begins when the business license consultation is complete and
recommendations have been made. The business owner must submit the business license application
before the consultation findings expire, as defined by the rule.

3. For each expiration basis, you enter details to define the rule.

Page Element

Expiration Period

About to Expire

Grace Period

Description

Enter the amount of time that the user has before the expiration date. For example, the
applicant must submit an application within 30 days before the application expires, or a
license is valid for 1 year from when it was issued. For fixed-date expirations, enter the
date the license expires.

Enter when you would like a notification to appear on the application or license that
shows the user how long until the application or license expires. For example, you can
enter 5 days to show that a pending application expires in 5 days.

Enter the amount of time the application, license, or consultation findings are valid
beyond the expiration date defined in the rules.

The grace period for the inactive pending application rule is the amount of time the
business is allowed to submit the application after the pending application expires.

For the consultation expiration rule, the grace period is the amount of additional time
that the consultation findings are valid after the consultation expires.

If the business renews during the grace period defined in the license expiration rule, no
penalties and interest are charged.

4. Verify that the Enabled switch is turned on for each rule. The option is active by default for a new expiration

rule.
5. Click Save.

Setting Up Communication Rules

You can set up communication rules to send communications when the application, license, or consultation is about
to expire or expired. Agency staff and the business owner listed on the application, license, or consultation receive the
notifications. Click Add in the Communication column and select About to Expire, Expired, or both, and the recurrence

of the communication.

Depending on the expiration communication rules you define, you must also set up communication templates for these

delivered events:

- About to expire business license - The communication event will be triggered when the inactive pending
application or license is about to expire.

- Expired business license- The communication event will be triggered when the inactive pending application or

license expires.

- About to expire business license consultation— The communication event will be triggered when the inactive
pending consultation application or license consultation is about to expire.

ORACLE
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- Expired business license consultation— The communication event will be triggered when the inactive pending
consultation application or license consultation expires.

For more information about configuring the communication templates for the email or notification you want to send
when the event occurs, see Setting Up Communication Templates.

CAUTION: After setting up communication rules, you must periodically run batch expiration rule processing to
update the About to Expire and Expired statuses. The system updates the statuses and sends out the communications
according to the setup. Oracle recommends that you schedule expiration rule processing to run daily.

Associating Expiration Groups with Business License Types

After you create an expiration group, you associate the group of rules with a business license type.

1. Select Business License Setup > Business License Type > Transaction Type .
2. Click the row for the business license type.

3. Onthe selected Business License Type page, enter the expiration group. You can look up the expiration group
by expiration group name and description.

4. Click Save.

For more information see Setting Up Business License Types.

Running the Expiration Rule Process

After setting up expiration rules and adding an expiration rule group ID to the business license type definition, you must
set up expiration rule processing to periodically update the expiration statuses.

Run the process that updates transaction expiration statuses on the Process Expiration Rules page, which you access by
selecting Common > Process Expiration Rules . Oracle recommends that you schedule expiration rules processing to
run daily.

For information about setting up expiration rules processing, see Updating Application Expiration Status.

Related Topics
- Expiration Overview

Setting Up Business License Renewals

Agencies generally issue business licenses for a fixed period of time and offer the option to renew the license to
continue business operation. Several setup steps are required for your agency to support business license renewals.

- Define expiration rules for business license expiration, including when the license is about to expire and expires.

Businesses can renew their business licenses starting when the license is about to expire. They can also renew
the license when the license expires and after the license has expired.

Note: You must run expiration rule processing to update the expiration status after you set up the expiration
rules.
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See Setting Up Business License Expiration Rules.

- Set up renewal fee items and fee schedule.

Select the Renewals option and map to the decision model you'll use for calculating the item on the Fee Item
Details page in the fee schedule.

See Setting Up Fee Schedules.

- Identify tax attributes that apply to renewal applications.

Define the tax class and the attributes that are applicable to renewal applications on the Business License Tax
Class setup page.

See Setting Up Business License Tax Classes.

- Set up the business license type to support renewals.

Associate the business license type with an expiration group and select the option to allow renewals. The
Expiration Group code is required when you select Allow Renewal. You also select a tax class, fee schedule,
and workflow that will be used for renewals.

See Setting Up Business License Types.

- Design the intake form for the renewals application.

The License Activity display settings on the predefined elements in the intake form determine what
information can be entered or updated as part of the renewals application process. For example, you can enable
predefined elements such as Business Information and Retail Business Details with fields for the business to fill
out.

See Configuring Activity Filtering for Business Licenses.

Setting Up Business License Amendments

Businesses that want to update business information for their license can apply for an amendment. Several setup steps
are required for your agency to support business license amendments.

- Set up amendment fee items and fee schedule.

Select the Amendment option and map to the decision model you'll use for calculating the item on the Fee
Item Details page in the fee schedule.

See Setting Up Fee Schedules.

- Set up the business license type to support amendments.
Select the option to allow amendments. You also select a workflow that will be used for amendments.

See Setting Up Business License Types.

- Design the intake form for the amendments application.

The License Activity display settings on the predefined elements in the intake form determine what
information can be entered or updated as part of the amendments application process. For example, you
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can enable predefined elements such as Business Information and Retail Business Details with fields for the

business to fill out.

See Configuring Activity Filtering for Business Licenses.

Setting Up Business License Tax Classes

Define the types of taxes that will be used to calculate taxes applicable to business licenses. You add a tax classification
and associate various tax attributes on the Business License Tax Class page.

Tax classes define the tax attributes that will be applied to business licenses. Applicable taxes are calculated based on
the values entered by registered users in their license application.

Adding Business License Tax Class Definitions

1. Select Business License Setup > Business License Tax Class .
2. Onthe Business License Tax Class page, click the Add button.
3. On the Business License Tax Class detail page, enter values for the following fields:

Page Element

ID

Name

Description

Sequence Number

Tax Attribute

Description

Applies To

ORACLE

Description

Enter an identifier of the business class.

Enter a name for the tax class.

Enter any information, such as details about the type of business to which this tax class
can apply.

Select a number to determine where in the list should this attribute appear on the
business license application. For example, if the value 2 is selected, the attribute will be
the second in the list.

Select a tax attribute that should apply to the business license.

Enter a description about the tax attribute, which will be displayed in the business
license application.

The description helps public users understand the purpose of the tax applied.

Select the license type to which the attribute will apply:

o Origination: The attribute will be applicable to the origination license.

o Renewal: The attribute will be applicable to the license when it is being renewed.
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Page Element Description

You choose the attributes that should be displayed in the application according to the
activity status of the business license — Origination and Renewal.

4. Turn on the Enabled switch. The switch is turned off by default for new attributes.
5. Click the Add icon to include a new attribute record. Use the Delete icon to remove the attribute row.
6. Click Save.

Setting Up Business Consultation Meetings

Consultations are the initial step in the business licensing process, and are used to allow the business owner to work
with agency specialists to receive feedback prior to submitting business license applications. A consultation meeting is
scheduled between the business owner and agency specialists to determine the necessary applications and approvals
for the license procurement.

Configuring the Consultation Meeting

Administrators set up and manage the consultation meeting configuration on the Manage Business Consultation
Configuration page.

1. Select Business License Setup > Business License Meeting Setup . Or, Select Setup and Maintenance tile
on the Agency Springboard > Select Public Sector Business Licenses > Business License Application Types
functional area > Manage Business License Meeting Setup task.

2. Onthe Manage Business Consultation Configuration page, the Consultation Meeting section allows you to set
up applicant privileges. Enter values for the following fields:

Page Element Description

Applicant can request Select to allow an applicant to request a consultation meeting. Applicants can access the
business consultation meetings page and schedule a meeting based on the availability
of the agency staff.. See Working with Business Consultation Meetings.

Applicant can reschedule and Select to allow an applicant to reschedule or cancel their meeting.
cancel

3. The Meeting Availability section allows you to set up the parameters for scheduling meetings, determined by:

a. Specialist meeting schedule or
b. Agency meeting schedule

Specialist meeting schedule: Select to allow users to schedule meetings based on the availability of their
assigned specialist.
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Note: You also need to ensure that all the specialists are assigned a consultation meeting work schedule on
the Agency Staff Profile. Enter values for the following fields:

Page Element Description

Meeting Duration in Hours Select a value to set the maximum amount of time the meeting can be scheduled for.
Users will see this value as the duration of the meeting, and they are not allowed to
edit the field. See the section Scheduling a Consultation Meeting under Working with
Business Consultation Meetings.

Schedule after Number of Days Select a value to set the number of days from the current date, so that users can
schedule a meeting on a date available after the number of days specified here. For
example, if you select a value 5 on the 10th day of this month, the calendar on the
Business Consultation Meeting Request page displays the dates that are available after
the 15th day of the month.

Schedule up to Number of Days Select a value to set the number of days that will be available for the users to select
a date on the calendar for scheduling the meeting. For example, if you select a value
of 90, the calendar on the Business Consultation Meeting Request page displays 90
calendar days starting from the date the user is making the selection.

See the section Scheduling a Consultation Meeting under Working with Business
Consultation Meetings.

Agency meeting schedule: Select to allow users to schedule meetings based on the schedule of the agency. In
addition to the fields described above, enter values for the following fields:

Note: If you select this option, then you need not assign Consultation meeting schedule to the specialists as
the Consultation meeting schedule will not be considered while determining the availability.

Page Element Description

Consultation Work Schedule Select the Agency level work schedule that needs to be considered while determining
the availability for the consultation meeting.

4. The Meeting Agenda and Location section allows you to set up the agenda and the location for the
consultation meeting.

Page Element Description

Include Agenda Select the check box and enter the agenda in the Meeting Agenda field.
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Page Element Description
Include Location Select the check box and search for the desired location of your agency using the

Agency Information look up. The address of the location you select is displayed in the
Meeting Location field.

Note: Users can edit the entries for the agenda and location fields while scheduling the meeting on the
Business Consultation Meeting Request page.

Setting Up NAICS Codes

Federal statistical agencies use the North American Industry Classification System (NAICS) to classify business
establishments for the purpose of collecting, analyzing, and publishing statistical data related to the U.S. business
economy.

Understanding NAICS Code Setup

NAICS codes enable an applicant to select an industry standard classification for a business when applying for a license.
To set up NAICS codes for your agency:

1. Add NAICS codes on the NAICS Codes page.
2. Create subsets of NAICS codes on the NAICS Groups page.

For more information, see Setting Up NAICS Groups.
3. Select a NAICS group for each business license type on the Business License Type page.

The NAICS group associated with the business license type determines which NAICS codes are available to
select when applying for a business license.

For more information, see Setting Up Business License Types.

Adding NAICS Codes

1. Select Common Setup > NAICS Code .
2. Onthe NAICS Code page, click Add.
3. On the NAICS Code Details page, enter values for the following:

Page Element Description

NAICS Code Enter the industry classification code.

Industry Title Enter a short descriptive title for the NAICS code.
Description Enter a long description for the NAICS code.
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Page Element Description

4. Verify that the Enabled switch is turned on. The switch is turned on by default for new NAICS codes.
5. Click Save.

Modifying NAICS Codes

1. Select Common Setup > NAICS Code .
2. On the NAICS Code page, select the NAICS code that you want to modify.
3. Onthe NAICS Code Details page you can:

o Edit the industry title and description.
o Enable or disable the NAICS code using the Enabled switch.

If you disable a NAICS code, but it’s still included in the list of enabled codes for a NAICS group, it will
continue to be available to select on business license applications. You can’t add a disabled NAICS code to

a NAICS group.
o Delete the NAICS code. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting NAICS Codes

Select Common Setup > NAICS Code .

Click Select Multiple.

Select the check boxes next to all the NAICS codes that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PUWNa

Setting Up NAICS Groups

North American Industry Classification System (NAICS) groups are subsets of NAICS codes.

The NAICS group associated with a business license type determines which NAICS codes are available to select when
applying for a business license. You add, modify, and delete NAICS groups on the NAICS Group page.

Adding NAICS Groups

1. Select Common Setup > NAICS Group .
2. On the NAICS Group page, click Add.
3. On the NAICS Code Details page, enter values for the following:

Page Element Description

NAICS Group ID Enter the unique identifier for the group.
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Page Element Description
NAICS Group Enter a name for the group.
Description Enter a description for the group.

4. Turn on the Enabled switch to make the group available on other pages. The switch is turned off by default for
new NAICS groups.
5. To add NAICS codes to the group:

a. Inthe NAICS Code grid, click Add.
b. Select the code that you want to add in the NAICS Code column.

If you want to view a list of available NAICS codes, click NAICS Code to access the NAICS Code page.
c. Turn on the Enabled switch to enable the code for the group. The switch is turned off by default for
added codes.
6. Click Save.

Modifying NAICS Groups

1. Select Common Setup > NAICS Group .
2. On the NAICS Group page, select the NAICS group that you want to modify.
3. On the NAICS Group Details page you can:

o Edit the description.
o Enable or disable the NAICS group using the Enabled switch.
Disabled NAICS groups can't be selected in the prompt list for a business license type.

Note: The enabled codes associated with a disabled group continue to be available to select for
business license applications.
o Add, delete, enable, or disable the NAICS codes associated with the group.

A disabled code can no longer be selected for a business license application.
o Delete the NAICS group. You will be prompted to confirm the permanent deletion.

4. C(lick Save.

Deleting NAICS Groups

1. Select Common Setup > NAICS Group .

2. Click Select Multiple.

3. Select the check boxes next to all the NAICS groups that you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Related Topics
- Setting Up NAICS Codes

- Setting Up Business License Types
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7 Creating Intake Forms

Intake Form Designer Topics

The following topics apply to using the Intake Form Designer to create and publish intake forms, which registered users
access online to initiate transactions, such submitting a permit application, reporting an issue, and so on.

Using the Intake Form Designer
« Using the Intake Form Designer for Code Enforcement
Working with Sandboxes
Working with Pages
Working with Predefined Field Groups
Using Predefined Field Groups
« Working with Group Boxes
Working with Fields
« Adding Rich Text Areas
- Defining Fields Displaying a List of Values
« Displaying Form Elements Conditionally
« Adding Logic
- Adding Contextual Help to Forms
« Reorder Intake Form Elements
Configuring Activity Filtering for Business Licenses
« Setting Form Options
« Mapping Form Fields to Decision Model Attributes
Considering User Experience
« Testing Intake Forms
« Publishing Intake Forms
Cloning Transaction Type Definitions

- Managing Transaction Type Configurations

Using the Intake Form Designer

This topic describes the purpose of the Intake Form Designer, lists the prerequisites that must be completed prior to
creating a form, and introduces you to the designer interface.

To initiate a transaction, such as a permit, an intake form needs to be submitted to capture the information required for
the process. Examples of transactions include permit applications, planning and zoning applications, and so on. You use
the Intake Form Designer to create application forms that public users can access online, fill out, submit, and monitor.
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Oracle does not deliver a predefined form for each type of transaction because for each form and for each municipality,
the information required will be unique. For example, for a fence permit, the City of San Diego may require only basic
information about the material to be used and the measurements. On the other hand, the City of Sacramento may
require the same information as San Diego, but also require the contact information of the contractor building the
fence, the exact location of the fence, the area enclosed by the fence, and so on. Each municipality has its own set of
requirements, and the Intake Form Designer enables you to tailor the forms to reflect your agency's requirements.

With the Intake Form Designer, you can create unique application forms for each transaction type offered. The Intake
Form Designer provides modular sets of common fields, called predefined field groups, which are ready-to-use form
elements you can assembile like building blocks to create the intake form. If a predefined field group does not contain all
the fields you require, you can add user-defined fields to capture the additional information.

The type of intake form you create depends on the offering.

Public Sector Compliance and Intake Form Types
Regulation Offering

Permits Permit applications

Planning and Zoning Planning pre-application

Planning application
Code Enforcement Report an issue

Business Licenses Business license:
Consultation
Origination
Amendment

Renewal

Note:
For business licenses, typically the consultation activity uses a separate intake form. You can use a
single form design to address origination, amendment, and renewal license activity.

Once you have created, configured, and tested your form, you can publish the form for public users to access, complete,
and submit for review and approval.

Note: For simplicity in this documentation, the Intake Form Designer is often referred to as “the designer,” and an
intake form is often referred to as a “form.”

Completing Prerequisites

Before creating a form, you need to:

- Create a transaction type.
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A transaction type represents the type of intake form you will create such as a permit application, a business
license application, and so on.

For more information on creating a transaction type, see Setting Up Permit Types, Setting Up Business License
Types, Setting Up Planning Application Types, Setting Up Issue Types.

- Set up any fees associated with the form.

For more information on fees, see Setting Up Fee Itemsand Setting Up Fee Schedules.

- Set up workflow for the transaction.

For more information on workflow, see Setting Up Process Definitions for Workflow.

Accessing the Designer

Before you can create an application form, you must first create a transaction type on the Transaction Type page.

From the Transaction Type page for the appropriate offering, select the Design Form button.

Working with the Designer Interface

This example illustrates the interface of the designer when you begin creating an application form.

This example illustrates the Intake Form Designer interface. The controls in the image are described in the text
surrounding the image.

ORACLE

Design Permit Application Reorder | Addlogic | Preview | Save  Mansge Sandbox

D Fence | Status: draft

SE RN Application Form Setup Previc Next >

Elements | Application Details X~ Applicant Information X Fence Details X  Contractor Information X Fee > Add Tab Form Options ~ >>

P Ready to Use Field Attributes

4 Add New Pl App\itatioﬂ Lsbel *

4 General Record 1D NEXT Status Pending Received Date

Check box set

. Received Date
Date field

Add Logic

Add Help

D e
Elements Panel Work Area %t Atributes Panel

Note: While the Intake Form Designer interface is practically identical for all offerings, using the designer for Code
Enforcement uses only a subset of the designer’s features. For more information on using the designer to create
intake forms for Code Enforcement, see Using the Intake Form Designer for Code Enforcement.
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Page Element

Status

Reorder

Add Logic

Preview

Save

Manage Sandbox

Next

Form Options

Elements panel

ORACLE

Creating Intake Forms

Description

Indicates the status of the current design.

- Draft: the form is in sandbox mode, and currently being designed and tested.

- Published: the form design is complete and it no longer needs to be in sandbox mode. A
published form can be migrated to other environments.

For more information on form status, see Working with Sandboxes and Publishing Intake Forms.
Click to open the Reorder Intake Form window to move form elements to different locations within the
form design.

For more information on reordering intake forms, see Reorder Intake Form Elements.

Enables you to add programming logic scripts using the Groovy programming language.

For more information on Groovy, see Adding Logic.

Enables you to preview your form to get a snapshot of the current layout.

For more information, see Testing Intake Forms.

Saves changes made to the form design.

Enables you to manage the development sandbox associated with the intake form while you are
creating it and to publish it after development and testing is complete.

For more information on sandboxes, see Working with Sandboxes.

For more information on publishing, see Publishing Intake Forms.

Takes you to the Fee Mapping page, which is the next step in the form design process. If the
transaction type is not associated with a fee schedule, the Fee Mapping page is not displayed.

For more information on mapping fees, see Mapping Form Fields to Decision Model Attributes.

Click to display the Form Options dialog box where you can set options that apply to the entire form.
For more information on form options, see Setting Form Options.

The Elements panel contains all of the items that you use to build an intake form. It displays lists of all
pre-defined field groups and user-defined elements you can add to your form design by dragging and
dropping.

The Ready to Use section contains:

- Field Groups: predefined sets of fields.

- Fields: user-defined fields you have created and set to be reusable fields, which can be defined
once and included in multiple intake forms.

The Add New section contains:

- General: the list of all the field types for user-defined fields you add manually to intake forms.

- Layout: HTML constructs, such as group box containers, that you add to your intake forms.
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Page Element

Add Tab

Workspace

Attributes panel

Description

For more information see, Working with Predefined Field Groups, Working with Pages, and Working with
Fields.

Adds additional pages to your form. You navigate between the pages by using the page tab for each
page.

For more information, see Working with Pages.

The area where you drag and drop form elements from the Elements panel and configure them. This is
the main work area used for creating, configuring, and designing the layout out your forms.

Displays the available attributes that you can configure for the currently selected form element. For
example, if you have a field selected, the attributes panel reads "Field Attributes,” and it contains
attributes specific to that field type. If you have a group box selected, the attributes panel reads "Group
Box Attributes,” and it contains attributes specific to group boxes.

Using the Keyboard to Drag and Drop Elements

You can drag and drop form elements manually using your mouse, or you can use keyboard hot keys.

Key

Enter

Tab

Up and Down Arrows

Space

Description

Use to:

- Expand or collapse the Ready to Use or Add New element lists.

- Drop a selected element onto the selected drop zone

Use the tab key to select either the first element in the list or the last selected item in the list if a
previous visit was made to the list.

Use to:

- Select an item in the Ready to Use or Add New element lists.
- Select a location from the drop zone list. The selected drop zone is highlighted.
When an element is selected, the space key highlights the selected element and displays available drop

zones for the current page on the Select a Drop Zone dialog box. The drop zones can be the page or
group boxes contained by the page. For user-defined fields, the drop zones are group boxes.

Organizing the Tasks for Creating Forms

This section provides the core set of tasks to complete when creating an intake form. The remaining topics in this
chapter discuss the details of each task.

Step

Add page tabs.

ORACLE

Link

Working with Pages

105


http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_WorkingWithPredefinedFieldGroups
http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_WorkingWithPages
http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_WorkingWithFields
http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_WorkingWithFields
http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_WorkingWithPages
http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_WorkingWithPages

Oracle Public Sector Compliance and Regulation Cloud Chapter 7

Implementing Compliance and Regulation Creating Intake Forms
Step Link
Add predefined field groups. Working with Predefined Field Groups

Modify field attributes in predefined field = Working with Fields

groups.

Add group boxes. Working with Group Boxes
Add user-defined fields. Working with Fields
Testing intake forms. Testing Intake Forms
Publishing intake forms. Publishing Intake Forms

Using the Intake Form Designer for Code Enforcement

This topic describes how to use the Intake Form Designer for the Code Enforcement offering.

Public users access an online form, fill out it out, and submit it to report issues. You use the Intake Form Designer to
create intake forms for Oracle Public Sector Compliance and Regulation offerings, including Code Enforcement.

Using the Intake Form Designer to create intake forms for the Code Enforcement offering is similar to creating intake
forms for the other Public Sector Compliance and Regulation offerings, such as permits or planning applications.
However, in the case of Code Enforcement, creating intake forms relies on a delivered template that has all the pages
and fields already in place for a working form right from the start. You can add user-defined fields in specific areas to
capture additional information if needed. This underlying template both simplifies and streamlines the form design
process, requiring you to create little, if anything, from scratch.

This topic describes the concepts and steps you'll need to understand to create intake forms specifically for the Code
Enforcement offering. For concepts that apply to all Oracle Public Sector Compliance and Regulation offerings, you will
be linked to that common topic in the “Creating Intake Forms” chapter of this guide.

Prerequisites

Before creating an intake form for a Code Enforcement issue subtype, these items must exist:

Issue type

Issue subtype

For more information see Setting Up Issue Types and Setting Up Issue Subtypes.

Accessing the Intake Form Designer for Code Enforcement

An intake form for a Code Enforcement incident is associated with an issue subtype.
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To access the Intake Form Designer, click Design Form from the Issue Subtype page.

For more information on creating issue subtypes, see Setting Up Issue Subtypes.

Working with the Intake Form Designer

After you have created an issue subtype, you use the Intake Form Designer to create the form public users will access to
report issues to your agency.

This example illustrates the general user interface of the Intake Form Designer used to create issue intake forms for
Code Enforcement.

. . 1 =um
ORAcLE . TE
Design Code Enforcement Application Reorder | Addlogic | Preview = Save | Manage Sandbox v
Pangerous Trees | Status: draft
Elements « Provide the Location of the Issue Tell Us What is Geing On Just a Few More Questions Z° Provide Contact Information Form Optiens >
Ready to Use Field Attributes
Add New . . -
Ada e Does this issue pose a health hazard or public safety risk? Remove
4 General
Label *
Check box set
Types of Trees

Date field

Date time field

Number of Trees
Drop-down list

Multi-select list Revesble
Number field
Radio button set Req
Rich text area Types of Trees -
Single-item check box )
Switeh Manage List | Add Logic
Text area
Text field Add Help
A Layout 4 D:

~ B
Group box

P CE1IDVegetation_¢
Name
TypesofTrees_c

Data
string

List ID
PSC_TREE_TYPES

v

Page Element Description

Status Indicates the status of the current design.

- Draft: the form is in sandbox mode, and currently being designed and tested.

- Published: the form design is complete and it no longer needs to be in sandbox mode. A
published form can be migrated to other environments.

For more information on form status, see Working with Sandboxes.

Reorder Enables you to move form elements from the initial location.

Note:
For Code Enforcement, you can reorder only the group boxes and user-defined fields you have
added to the editable area of the template.

For more information on reordering form elements, see Reorder Intake Form Elements.

Add Logic Enables you to add programming logic scripts using the Groovy programming language.
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Page Element

Preview

Save

Manage Sandbox

Form Options

Elements panel

Workspace

Attributes panel

Description

For more information on Groovy, see Adding Logic.

Enables you to preview your form to get a quick snapshot of the current layout.

For more information, see Testing Intake Forms.

Saves changes made to the form design.

Enables you to manage the development sandbox associated with the intake form while you are
creating it and to publish it after development and testing is complete.

For more information on sandboxes, see Working with Sandboxes.

For more information on publishing, see Publishing Intake Forms.

Click to display the Form Options dialog box where you can set options that apply to the entire form.

For more information on form options, see Setting Form Options.

Displays the list of user-defined elements you can add to your form design, such as the fields you can
add to your form by dragging and dropping into the drop zone on selected pages.

Note:

The elements within the Ready to Use node are not intended to be added to your intake forms
manually. They have already been added by way of the underlying template. For Code Enforcement,
the Ready to Use node is intended to be used by internal Oracle development teams.

This is the main area displaying page tabs and drop zones used for configuring your forms.

Displays the available attributes that you can configure for the currently selected form element. For
example, if you have a field selected, the attributes panel reads "Field Attributes,” and it contains
attributes specific to fields. If you have a group box selected, the attributes panel reads "Group Box
Attributes,” and it contains attributes specific to group boxes.

Working with Page Tabs

Page tabs appear across the top of the work area.

Each page tab represents a separate page that the public user will access at runtime to provide the necessary
information when reporting an issue. The majority of the intake form for Code Enforcement is defined by the underlying
template, which you can’t modify. Because the page tabs are defined in the underlying template, you can’t add or
remove page tabs that appear in the default Code Enforcement intake form.

Note: You can't add or remove page tabs from the default intake form template.

ORACLE
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The page tab containing the pencil icon indicates where the drop zone resides. The drop zone is the area of the intake
form where you can add user-defined fields and group boxes to configure the intake form to include any additional
requirements for that issue subtype.

For example, if you want to add a field to capture the length of the overgrown grass being reported, you can drag and
drop a Number field type into the drop zone.

The following table provides descriptions of the default page tabs provided by the template. The page tabs derived from
the template are:

Page Tab Description

Provide the Location of the Issue Used for specifying the location of an issue that’s being reported.
This tab includes a map with a crosshair marker for identifying a location. A search field enables user
to easily find a location and place it in the crosshairs. A separate text field captures additional location
information such as an apartment number or a description of where to find the issue at the given
address.

Tell us what's going on Used to describe the issue that's being reported.
This tab includes a freeform text field for describing the issue. The tab also supports attachments so
that users can upload photos, videos, or other documentation.

Just A Few More Questions Used to collect additional information about the issue that’s being reported.
In the delivered template, the only field on this page is a switch for indicating if the issue is a health
hazard or public safety risk. This tab also has a drop zone where you can add your own fields for
collecting additional information.

Provide Contact Information Used to collect the name and contact information for the person who is reporting the issue.
The template includes a switch for hiding the user’s information, but this switch is visible to the

end user only if the agency allows anonymous reporting. This option is configured on the Code
Enforcement Options page. See Setting Up Agency-Level Options for Code Enforcement.

Working with the Drop Zone

The drop zone is the area of the issue subtype intake form where you can add user-defined fields and group boxes. You
can locate drop zones by selecting the page tabs with the pencil icon.

This example illustrates the pencil icon on a page tab, which indicates which tab(s) a drop zone resides where you can
add custom fields.

Just a Few More Questions &

Note: The drop zone is the only area on the form that you can add and configure group boxes and fields.

You can drag and drop these form elements into a drop zone:

- User-defined fields
- Group boxes
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This example illustrates dragging and dropping a user-defined field type from the Elements panel into the drop zone.

Elements « Provide the location of the issue Tell us what is going on Just few more questions Z' > Form Options

& A

¥ Ready to Use
Ny
A Add New Prlorlty- -/.I ,..I

4 General

Check box set -_____*______‘.

Date field I Check h[%rg‘,;: Drag and drop form elements into the
group box.

Date time field

Drop-down list

Multi-select list v ©

The drop zone itself is a group box into which you can drag user-defined fields and other group boxes if needed.

I Note: While the drop zone is technically a group box, you can’t modify its attributes or remove it from the page.

Working with User-Defined Fields

You can drag and drop user-defined fields directly into the drop zone, or you can add group boxes to the drop zone and
drag and drop user-defined fields into the group boxes.

To add a user defined field to the drop zone:

1. Expand the Add New list.

2. Expand the General list.

3. Select the desired field type by clicking and holding.
4. Drag and drop the field type onto the drop zone.

To modify field attributes:
1. Select the field in the drop zone.

2. Use the Field Attributes panel to configure the field.
3. Click Save.

For more information on working with fields, see Working with Fields.

Working with Group Boxes

You can use group boxes to organize user-defined fields you add to the drop zone. User-defined fields can be added
only to the drop zone or to group boxes.

For more information on group boxes, see Working with Group Boxes.

Displaying Form Elements Conditionally

In some cases, you may want to display or hide certain elements in the drop zone only if the public user has made
specific selections on previous fields also in the drop zone.

Note: The fields that you want to display conditionally must be within a group box container. You can display group
boxes conditionally, but not a field on its own. You can’t control the display of the drop zone. Conditional display
applies only to elements contained within the drop zone.

For more information on conditional display, see Displaying Form Elements Conditionally.
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Setting Form Options

Form options enable you to configure features that apply to the entire form. For example, for the Code Enforcement
issue intake form, you can control whether a review page displays to show the public user all their selections before
submitting.

For more information on form options, see Setting Form Options.

Working with Sandboxes

When developing intake forms, you design and modify the form layout within a sandbox. A sandbox is an Oracle Fusion
Applications technology that enables intake form developers to work on projects simultaneously, save, and test their
work without affecting other developers or testers in the environment.

For more information on sandboxes, see Working with Sandboxes.

Testing Intake Forms

After creating an issue intake form, you can test it by:

- Viewing it in preview mode.

Making it available from the landing page where you can select Report an Issue, which can be done in draft
mode and published mode.

For more information on testing, see Testing Intake Forms.

Publishing Intake Forms

While you are actively designing or modifying an intake form, the intake form resides in draft mode in a development
sandbox. You can test the intake form in draft mode while it is still in the sandbox. To make the intake form available to
migrate to another environment, the intake form needs to be published.

For more information on publishing forms, see Publishing Intake Forms.

Cloning Transaction Type Definitions

You can clone issue subtype definitions and the associated intake form layout to:

- Avoid duplicating work while creating similar issue subtypes and intake forms.
- Create a new version of an existing issue subtype and intake form.
To clone an issue subtype and its associated intake form, click Clone on the Issue Subtype page.

For more information on cloning, see Cloning Transaction Type Definitions.

Managing Transaction Type Configurations

After developing your intake forms on your development and/or test environment, you need to migrate the setup data
and configuration data from the source development/test environment to the target production environment.

For more information on migrating setup data and configuration data from one environment to another, see Managing
Transaction Type Configurations.
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Example: Adding User-Defined Fields to an Intake Form for an Issue
Subtype

While the default intake form based on the underlying template is ready to be used without any changes, this section
illustrates how you can add user-defined fields to the drop zone if you need to capture additional information.

This example creates an intake form for an issue subtype that enables public users to report an issue for an abandoned
vehicle. Assume that the code enforcement organization wants to capture all of the information in the default intake
form and also a user-defined field to indicate if there are multiple vehicles on the property.

To create an intake form for an issue subtype:
1. Ensure a valid issue and issue subtype exist.
You create issue types and issue subtypes separately.

For more information see Setting Up Issue Types and Setting Up Issue Subtypes.
2. While on the Issue Subtype page, make sure your issue subtype is saved and click Design Form.
3. Inthe Intake Form Designer, locate the page tab with the drop zone.

This example illustrates the pencil icon on a page tab, which indicates which tab(s) a drop zone resides where
you can add custom fields.

Just a Few More Questions 2

4. Expand the Add New list in the Elements panel.
5. Inthe General list, select Switch, and drag and drop it in the drop zone.

This example illustrates dragging and dropping a field type into the drop zone.

6. Select the switch, and observe the attributes you can configure for that field in the Field Attributes panel on the
right.

7. Update the Label value.

For example Are there multiple abandoned vehicles on the property?

This example illustrates setting the label attribute.
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»
Field Attributes

Remove

Label *

Are there multiple abandoned vehit

Cefault

value

Hidden
Add Help

8. C(lick Save.

Result:

This example illustrates a user-defined field added to the drop zone of an issue subtype form layout.

Provide the Location of the Issue Tell Us What is Going On Just a Few More Questions #° > Form Options

Does this issue pose a health hazard or public safety risk?

Are there multiple abandoned vehicles on the property?

Working with Sandboxes

This topic provides an overview of the concept of sandboxes and how they are used within the Intake Form Designer,
and it describes sandbox usage and behavior.

Most modern development environments typically require several different individuals to work simultaneously on
application changes while sharing the same data model and configuration starting point. The Intake Form Designer
utilizes the Oracle Fusion Applications technology referred to as sandboxes to enable form developers to work on
projects simultaneously, save their work, and test their forms without affecting other members of the implementation
team in the environment.

The sandbox acts as the development and test mode of your application form. During sandbox mode, the form design
can be viewed only internally by application developers or business analysts. In sandbox mode you can create your
form, add required form elements, add Ul elements, and test your changes. When you have completed all of your
design, development, and test work, you can then publish the form so it can be migrated to other environments and be
accessed by public users.
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Note: Creating and modifying transaction types and intake forms should be completed on your development
environment or your test environment. After making changes, publishing, and testing transaction types and intake
forms on your development or test system, you would then migrate the new and modified definitions to your
production system. Refer to the Functional Setup Manager documentation for information on migrating data from the
test system to the production system, as well as Managing Transaction Type Configurations.

Types of Sandboxes

Oracle Fusion Applications provides these types of sandboxes:

- (Classic sandboxes

Unified sandboxes

Classic sandboxes are the default sandboxes that are enabled out-of-the-box and always stay enabled. During
implementation, ensure that unified sandboxes are enabled.

Note: To create intake forms, the unified sandboxes feature must be enabled.

For Public Sector Compliance and Regulation offerings, unified sandboxes are an opt in feature that you enable in
Functional Setup Manager. It is required to have unified sandboxes on your development and/or test environment
(depending on the number of pods you have licensed). Do not enable unified sandboxes on your production
environment. Unified sandboxes are utilized during development and configuration work, which should not be taking
place on your production environment. If the unified sandboxes feature is enabled on your production environment,
it can lead to unexpected results, especially during the migration of data from a source environment to the target
production environment.

For more information on sandboxes, see the Fusion Applications Common topic: Sandboxes.

Starting a Sandbox Instance for a New Application Form

Before you can create an application form in Intake Form Designer, you must first create the transaction type. For
example, for the permit offering, the transaction type is a permit. When you save a permit type, the application creates
a sandbox instance. From that point, the transaction type and the associated form design exist within the newly created
sandbox instance.

Each form your implementation team is currently developing exists within its own, separate sandbox instance.

Until you publish the form, the transaction type and the form design remain in the sandbox instance. When you publish
a transaction type, the system eliminates its sandbox instance.

Starting a Sandbox Instance for a Published Intake Form

After an application form has been published, you can initiate sandbox instances to make any required changes
discovered after the initial publication.

To initiate a sandbox for a published form:

Open the transaction type for the form.
Select Design Form.

Begin making the desired changes.
Click Save.

P UWNA
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By clicking Save, the Intake Form Designer creates a new sandbox instance to store the current changes.

Viewing the Sandbox Status

You can determine if a form is in sandbox mode using the Status indicator located in the top left-hand corner of the
Intake Form Designer. The Status indicator appears when you are creating the form or previewing the form. The
sandbox status does not appear on the published version of the form.

Status Description
draft The form is in sandbox mode. All changes exist in the sandbox instance only.
published The form design is complete and is not in sandbox mode. When a form is published it can be migrated

to other environments.

Managing Sandboxes

Use the Manage Sandbox drop-down list to select the actions for the current sandbox.

Page Element Description

Publish Select when your initial testing and design work is complete and you no longer require the use of
the development sandbox. The sandbox is deleted and the form design is set to a state of published.
Form designs in the published state can’t be modified until they are back in the draft state inside of a
different sandbox instance.

A form design that is published can be migrated from the source environment to the target
environment.

Refresh Select to synchronize the current sandbox with current system data. Sandboxes share common
elements, such as field groups, reusable fields, and other system metadata. If those common elements
are updated, sometimes that requires the sandbox to be refreshed so that it is synchronized with
current system metadata to enable successful saving or publishing.

Revert to Last Published Select to remove all current changes and modifications and return the form design to the state of the
most recent successful publish. Use this option when you are making changes that you no longer need
and you'd like to return to the previous published state or you have encountered an issue with the
sandbox.

Manage Sandbox (FA) Select to go to the Sandboxes page in Oracle Fusion Applications to view details about the sandbox or
update it manually.
The sandbox naming convention is:
<Transaction Type Code>__sb_<number of publications>.

For example, if for a permit, the Type Code value is REMODEL, and the sandbox has been published
twice previously, the sandbox for that permit is named REMODEL__sb_2.

For information on managing sandboxes using the Sandboxes page, refer to the Fusion Applications
Common sandbox documentation.
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Managing Labels for Application Form Elements

This topic describes how to manage changes made to labels for existing and user-defined form elements.

When making changes to the labels for elements within your application form, you need to consider what type of
element it is. Changing the label of some elements is a global change, while changing the label of other elements is a
local change.

- Global: A global label change means that a change to the label affects every intake form definition using that
field or element.

- Local: Alocal label change means that a change to the label affects only the current intake form definition
where the field or element appears.

When you select a form element or field and a label change would have global effects, a warning icon appears above the
Label field in the attributes panel.

When selecting an item in the workspace, if changing the label for that item has global effect on all application forms
using the item, the system displays a warning icon.

— - = b

Changing this label affects all application forms
using this field. It is a global change Field Attributes

*

Label
R

Demaolition Reason

Note: If you change the label of a field after a form has been migrated and used in the production system, keep in
mind this can affect reporting and the storage of historical data. You may have multiple labels representing the same
data.

Form Element Scope of Label Change Label Change Considerations

Predefined Field Group Global The label of a predefined field group is the
heading used to describe the grouping of the
fields it contains.

Changing the label of a predefined field group
is a global change.

For example, if you change the label in the
Applicant predefined element used in the fence
permit intake form, that change will be reflected
in the Applicant predefined element used in
the electrical permit intake form (and any other
application form using the Applicant predefined
field group).
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Form Element Scope of Label Change
Predefined Field Group: Parent Field Local

Predefined Field Group: Child Field Global

User-Defined Fields Local

HTML Constructs Local

ORACLE

Chapter 7
Creating Intake Forms

Label Change Considerations

Some fields appearing in predefined form
elements are part of the parent record within
the data structure storing the transaction data.

You know a field in a predefined field group is
part of the parent record when the warning icon
does not appear above the Label field in the
attributes panel.

For example, the Description field in the
Application predefined field group does not
display the warning icon. Changing this label
affects only the current intake form definition. It
is a local change.

Some fields appearing in predefined field
groups are part of a child record within the data
structure storing the transaction data.

You know a field in a predefined field group is
part of a child record when the warning icon
appears next to the Label field in the attributes
panel.

For example, the Demolition Reason field in
the Demolition predefined field group displays
the warning icon. Changing this label affects
all intake form definitions using the Demolition
predefined element. It is a global change.

You can change the labels for the fields that
you add to your application forms, such as text
fields, number fields, drop-down lists, and so
on. Because you add these fields manually

to your application form, you can change the
default labels as needed to suit your business
requirements.

The scope of any changes to the label for user-
defined fields apply only to the current intake
form.

A general HTML construct refers to layout
elements such as group boxes and page tabs.

You can change the labels for general HTML
constructs as needed to suit your business
requirements. The scope of the construct and
any changes to the label apply only to the
current intake form definition.

For example, changing the label of the default
label for HTML constructs such as Group box
or Field O to your desired label affects only the
current intake form definition.
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Form Element Scope of Label Change Label Change Considerations

Note:

If you change a label for a page tab or a
group box used in an intake form after the
form has been migrated and used in the
production system, make sure to update
any instructions or documentation that may
reference the previous label.

Note: For HTML constructs, such as pages and group boxes, and for user-defined fields the labels display using the
language used to create or modify the application form layout. There is no automatic translation of these elements.
For example, if you created the intake form in English, but then signed in using Korean for testing, you will see the
English labels for those constructs, unless you have provided translated values using the Fusion Applications User
Interface Text tool. For more information on the User Interface Text tool, see: Considerations for Selecting a Tool to
Change Text.

Working with Pages

This topic describes how to add page tabs to your intake form and how to modify page attributes.

An intake form can include one or more page tabs to contain the field groups and fields that you want to add to your
form.

Adding Pages
When you create an intake form, by default, the application includes one page tab for your form.

To add additional page tabs to your intake form, click the Add Tab button at the top of the workspace.

Setting Page Attributes

This example illustrates the page attributes. Details are in the surrounding text.
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Page Attributes
Label *

Applicant

Add Help

4 Display
Control Display

A Security

Hide from public

Page Element

Label

Add Help

Control Display

Hide from public user

ORACLE

Description

The name of the page that appears on the page tab. The default name is Page 1, Page 2, and so on.
Change the name to your desired label.

Click to launch the Contextual Help page, which you can use to add help information to aid end users in
completing the application form.

Page-level help should provide information pertaining to the overall page content. If the information
applies to a specific Ul element on the page, such as a field group, group box, or field, consider adding

help directly to that Ul element.

For more information on adding contextual help, see Adding Contextual Help to Forms.

Expand the Display section to view this attribute.

Determine if the page displays or is hidden based on the value of a previous element in the form, such
as a single-item check box or a switch. For more information on controlling page display, see Displaying
Form Elements Conditionally.

Expand the Security section to view this attribute.

Hides the page tab and all the elements on the page from the public user at runtime. Only agency staff
can view and update information for a page with this attribute turned on.

In addition to hiding the Ul element from the public user in the interface, the application also secures
the back end for that specific Ul element, such as preventing any unauthorized access to the fields
within the Ul element using a REST API, for example.

Note:
An intake form must have at least one page that is viewable to the public user. That is, Hide from
public user must not be enabled for at least one page tab in the form.
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Page Element Description
Note:

You can’t add a predefined field group to a page set to be hidden from the public. The Hide from
public user attribute can be set only for pages and group boxes, and it applies only to user-defined
fields within those containers. You can’t apply the Hide from public user attribute to field groups.

Note:
The Hide from public user setting and the Confidential setting are mutually exclusive.

Note:

You can't apply this setting to pages containing fields that have default values or fields that are set
as required.

Confidential Expand the Security section to view this attribute.

Turn this attribute on to specify that the user-defined fields within the page container hold confidential
information.

At run time, fields with confidential information will be hidden to all users except for users without the
appropriate privilege. These users can see the confidential information:

- Agency users directly associated with processing the business license.

- The public user who entered the information.

Note:
The field does appear in the JSON payload for the page, however the field value will be null.

Note:
The Confidential attribute applies only to the Business Licenses offering.

Note:

You can’t add a predefined field group to a page with the Confidential attribute turned on. The
Confidential attribute can be set only for pages and group boxes, and it applies only to user-defined
fields within those containers. You can’t apply the Confidential attribute to field groups.

Note:
The Hide from public user setting and the Confidential setting are mutually exclusive.

Note:
You can't apply this setting to pages containing fields that have default values or fields that are set
as required.
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Deleting Pages

If you delete a page from your form, keep in mind that any Ul elements you have added to the page, such as predefined
form elements, group boxes, and fields will also be removed from your form.

To delete a page from your form:

1. Click the Remove button on the page tab (the “x”).
2. On the Confirm dialog box, click OK.
3. Save your changes.

Working with Predefined Field Groups

This topic provides an overview of predefined field groups and how you use them to build your application forms.

Oracle provides a set of predefined field groups to help you build application forms easily. Each predefined field group
contains a collection of fields commonly used to capture information for a particular facet of the transaction type. For
example, the Applicant field group captures information about the person applying for a permit, and the Electrical field
group captures information about the scope of electrical work for a project. Using predefined field groups, you can
assemble application forms in a matter of minutes.

Predefined field groups are:

Pre-mapped to attributes in the application view object (VO).

- Grouped logically to provide descriptive metadata for a particular element of an intake form, such as Applicant,
Electrical Equipment, Pool Information, and so on.

You drag the desired predefined field group from the Elements panel onto the workspace and use various combinations
of predefined and user-defined form elements to assemble your application forms.

For example, assume that you need to create a form for applying for a fence permit. In this case, you can drag the
Applicant field group, the Fence field group, along with other field groups you need onto the workspace to build your
form.

For more information on the delivered predefined field groups, see Using Predefined Field Groups.

Adding Predefined Field Groups

To add a predefined field group to your form:

Make sure the page to which you want to add the predefined field group is the active page.
Expand the Ready to Use list in the Elements panel to the left of the workspace.

Click on the desired field group to activate it.

4. Select the field group to drag and drop it in the workspace.

WN =

This example illustrates dragging and dropping a field group onto the workspace.
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Design Permit
Solar Infodev s: draft

Elements {«

Application

Applicant X

Application Options X | Construction Details X Add Tab

4 Ready to Use
A Field Groups
Applicant
Application
Attachments

Business Information

Comment /

Contact Details

Demeolition

Electrical

Drag and drop form elements into the workspace.

Note: Intake Form Designer places the predefined field groups in the workspace in the same order in which they are
dropped, in sequence, from top to bottom.

Note: When adding the Terms of Use predefined field group, it is recommended to add the field group to a page
tab that also includes at least one other form element. Otherwise, the page may appear blank to agency staff when
accessed at runtime because the Terms of Use field group is displayed only to public users, not to agency staff.

Adding Required Predefined Field Groups

The field groups you add to your intake form design will vary, depending on the type of form you are creating. While
most field groups are optional to add to your forms, some field groups are required to ensure that specific information is
captured or represented in the underlying data structure. In some cases, it is the offering that requires the data, while in
other cases a field group may have built-in dependencies on another field group.

Offering

Permits

Planning and Zoning

Business Licenses

ORACLE

Required Field Groups

Applicant
Application

Fee Summary (if fees are involved)

Applicant
Application

Fee Summary (if fees are involved)

Applicant
Application

Business Information
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Offering Required Field Groups

Business Owners
Business Locations

Fee Summary (if fees are involved)

Note:

The Business Owners and Business Locations field groups depend on the Business Information field
group. They must appear after the Business Information field group in the sequence, either in a
subsequent page tab or below it on the same page tab.

The Applicant predefined field group is required to be added to your application forms. The internal save logic checks
for a valid applicant address when an end user attempts to save or submit an application form. The Application
predefined field group displays useful information, including the transaction ID, status, description, important dates
related to the application, and so on.

Deleting Predefined Field Groups from a Form
To delete a predefined field group, click the Remove button in the Attributes panel.

Setting Predefined Field Group Attributes

Select the field group to view its attributes in the Attributes pane. To select the field group, click around the border or
within empty space within the field group. If you click near a field, the field will become selected.

Page Element Description
Remove Click to remove the field group from the page.
Label The name of the predefined field group that describes the set of fields in the field group. For

example, the fields in the Photovoltaic field group apply to solar projects. Modify the label to suit your
requirements. For example, you may want to change the delivered field group named Photovoltaic to
Solar.

Note:

Changing the label for predefined field groups is a global change, affecting other intake forms using
the field group. After changing the label, note that the label of the field group in the left panel’s field
group list is updated to reflect the modified label. The change you make will be available globally
only after you publish the current intake form. Make sure future intake form developers on your
implementation team are aware of the change to avoid confusion.

Show Label Control whether to show the label. By default, the system shows labels for predefined field groups
(Show Label is on).

To hide the label, turn off Show Label. When turned off, the system hides the label at both design-time
and runtime.

Typically, you'd want the label to be visible to describe the logical grouping of the fields in the form
element.
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Page Element

Add Help

License Activity

Control Display

Description

In some cases, the page tab name and the predefined field group label might be redundant, in which
case you may opt to hide the label.

You may also want to group multiple predefined field groups within a single group box. In this case, you
can hide the individual predefined field group labels within the group box container, using the group
box label to represent the combined set of fields.

Note:
When you turn off Show Label, the system disables the collapsible feature for a predefined field
group.

Note:
If the predefined field group is delivered without a label, the Show Label attribute does not appear
when you select that form element.

Click to launch the Contextual Help dialog box, which you can use to add help text to a predefined field
group for assisting users with interacting with your intake form. When adding help for a predefined
field group, the help text should apply to the overall contents of the predefined field group. You can
add help also at the page level and the field level, depending on the scope of the help text.

For more information on adding contextual help to your intake form, see Adding Contextual Help to
Forms.

Note:
This attribute applies only to the Business Licenses offering.

Expand the Display section to view this feature.

License activity filtering enables you to control the display of field groups, depending on the current
business license activity selected by the applicant.

For more information on setting display filters, see Configuring Activity Filtering for Business Licenses.

Expand the Display section to view this feature.
Click to define other elements in the form to control wether the field group displays.

For more information on controlling the display of form elements, see Displaying Form Elements
Conditionally.

Adding a Predefined Field Group Multiple Times to the Same Form

The same predefined field group can be dragged into your form multiple times. This is referred to as a multiple-instance
element. How you adjust the Multi-Instance Options attribute determines how the application stores the data for that

predefined field group.

Note: The Multi-Instance Options attribute appears only for the Comments and the Attachments field groups.

ORACLE
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If you make no changes to the Multi-Instance Options attribute, the data entered within that predefined field group
corresponds to one row of data only. In this case, the system duplicates the display of the data in each area of the form
it is displayed. This option enables you to show the same data on a different tab within the form, if necessary. Updating
the data in one instance of the predefined field group updates the data displayed in the other instances as well.

For example, assume you want the same comment text to appear on multiple pages in your form. You can do this by
adding the Comments field group to the desired pages without making any updates to the Value field in the Multi-
Instance Options attribute.

If you make changes to the Multi-Instance Options attribute, the application considers each instance of the predefined
field group unique, and then each individual occurrence of the predefined field group is associated with its own row of
data.

For example, assume you wanted to incorporate multiple comment sections in your form. In this case, you can add
the Comments field group to multiple locations of your form, and then you set the Multi-Instance Options attribute to
different values. One might relate to fencing comments while another might relate to contractor comments. Another
example would be to enable the end user to upload multiple attachments that apply to separate documents. One
attachment might be photos of a property while another attachment might be blueprint or design documents.

Managing Lookups for Predefined Field Groups

Some of the existing field groups contain fields associated with delivered lookup types. For example, the Primary
Industry lookup is associated with the ORA_PSC_CC_INDUSTRY_TYPE lookup type.

This example illustrates a field on a field group associated with an existing lookup. Details are in the surrounding text.

4 Business Information Required

Business Hidden

Doing Business Manage List Add Logic

Add Help

4 Details

Q Business Chject
LNP1IDSclarPermit_c

Mame

Busindustryld
Q Data Type
string

List ID
ORA_PSC_CC_INDUSTRY_TYPE

To manage a lookup for a predefined field group:

1. Identify the lookup fields in a field group, which contain the magnifying glass icon, like the Primary Industry
field on the Business Information field group.

2. Select the field.

Expand the Details section in the Field Attributes panel.

4. Make note of the List ID associated with the field. This is the lookup type that you will access and update on the
Lookups page.

5. Click Manage List to open the Lookups page displaying the associated lookup type.

w

This example illustrates the Lookups page displaying the lookup type associated with a field on a field group.
Details are in the surrounding text.
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Lookups

5

Lookup Type
Lookup Type Meaning Application Module Configuration Level

ORA_PSC_CC_INDUSTRY_TYPE Business Industry Common Components Foundation Setup User >

For more information on managing lookup types, see Setting Up Lookups.

Using Predefined Field Groups

This topic lists and describes the set of predefined field groups delivered to help you build forms quickly and

consistently.

Predefined field groups are prebuilt user interface modules that you can use as building blocks for assembling forms.
Field groups provide a set of fields and functionality to capture information for various sections of an application form.

Common Predefined Field Groups

Field Group

Applicant

Application

Attachments

Authorized Agent

ORACLE

Description

Identification and contact information for the public user who is filling out the form (or on whose
behalf an agent is completing the form). This field group includes the applicant’s name, address,
phone, and email. When updating address, email, and phone information, the user has the option to
save the changes to the user’s account profile.

Displays information about the form itself, such as status, relevant dates, and descriptions.

Enables you to attach and download files, such as documents or images. You determine document
properties displayed in the list of attachments and during upload.

Contains multiple instance options to create unique instances of the attachment field group.
Enables applicants to self-identify as authorized agents acting on behalf of a contractor. This field
group contains a switch for self-identifying as an authorized agent, a field for tracking authorized

agent verification status, and read-only fields that are populated with the applicant’s name and contact
information if the applicant is an authorized agent.
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Field Group

Comment

Contact Details

Contractor

Demolition

Fee Summary

Property

Site and Zoning

Terms and Conditions

ORACLE

Description

This field group should be used in conjunction with the Contractor field group. Typically the Authorized
Agent field group is placed immediately after the Contractor field group on a permit or planning
application intake form page.

Enables you to enter additional comments or descriptions pertaining to information on the form.

Contains multiple instance options to create unique instances of the comments field group.

Enables you to add information for individuals or organizations that are contacts for an application.

When users enter contact information in an application, they can create new contacts or choose
existing profile contacts. When creating a new application contact, the user can indicate whether the
new contact should also be added as a profile contact. When choosing an existing profile contact,

the user can modify contact details and indicate whether the original profile contact record should be
updated as well.

Enables applicants to provide information about one or more licensed contractors who are performing
the work for a permit or planning application. This field group includes an integration option that

is configured as part of your agency-level contractor options. For more information, see Setting Up
Contractor License Options.

If demolition is required as part of the job, this field group captures information related to the scope
of the demolition and if hazardous materials or utilities need to be considered, such as electricity, gas,
water, and so on.

Lists the items selected, the cost for each item, and the total amount to be paid when submitting the
form.

Note:
This does not include additional inspection or other fees which may be assessed at a later time.

Describes the parcel as it is registered with the municipality, such as the parcel ID, parcel type, and so
on.

Describes features of the property related to acreage, flood preparedness, as well as zoning and land
usage information.

Provides access to the terms and conditions regulating the usage of the online form, and provides a
way for the user to accept the terms. This field group is hidden from agency staff who complete a form
on behalf of a public user.

This field group does not identify which Terms of Use definition to use, so if you add this field group
to an application intake form, you need to also add a Terms of Use definition on the Permit Type or
Planning Application Type page.

The Display Mode property has these options:

- Link: the form displays a Terms and Conditions link that the user clicks to open a window with
the full terms and the check box for accepting the terms.

- Embedded: the full text of the terms appears directly on the form.
If the display mode is Link, these two additional properties are available:
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Field Group Description

- Help Text: Enter informational text that appears on the form along with the Terms and
Conditions link.

- Display Label: Enable this option to display the description of the Terms of Use definition on the
form along with the Terms and Conditions link.

Note:
This field group is not used to set up public user registration terms and conditions. The Public User
Setup page includes all registration-related configuration.

Attachments Field Group

You can configure the attachments field group and add it into your form multiple times. Attachments provide
supporting documentation needed by agency staff when processing a transaction.

Configurable Features Description

Component Attributes You can name the attachments component title in the Label field.

Component Multi-Instance Options Use these multiple instance options to create unique instances of the attachment field group:
- ID
- Value

For more information about multiple instance options, see Working with Predefined Field Groups.

Attachment Columns: You can configure these attachment properties in the attachments list:

- File Name: Display the file name of the uploaded file.
- Description: Display the user-entered description.

- File Size: Display the size of the uploaded file.

Business Columns: Agency-defined document categories and document subcategories enable you to organize the
various types of attachments. You can configure these fields for document categories and document
- DocumentCategory subcategories:

- DocumentSubcategory - Label: Change the field name.

- Show in List: Display the field in the attachments grid.

- Show in Detail: Display the field in the attachment detail information.

- Show in Upload: Display the field on the modal page for uploading an attachment.

- Searchable: Enable search on the document category or document subcategory field.

- Sortable: Enable sorting for the document category or document subcategory field.
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Predefined Business License Field Groups

Field Group

Business Detail

Business Information

Business Locations

Business Owners

Days and Hours of Operation

Industry Classification

Restaurant

Retail Business Details

Tax Related Details

ORACLE

Description

Describes the products and services to be sold, and captures additional information through a series of
questions about the business.

Captures information to help describe the business, such as name, ownership type, mailing address,
and so on.

Note:
You must add this field group to all business license intake forms. It must come before the Business
Locations and Business Owners field groups either in a previous tab, or above them in the same tab.

Captures information about the physical location of the business such as address, parcel number, and

phone number.

Note:
You must add this field group to all business license intake forms. It must come after the Business
Information field group either in a subsequent tab, or below it on the same tab.

Captures information about the business owners or corporate officers.

Note:
You must add this field group to all business license intake forms. It must come after the Business
Information field group either in a subsequent tab, or below it on the same tab.

Describes the days and hours of operations for the business.

Captures the North American Industry Classification System (NAICS) code for the business.

Describes restaurant-related information such as seating, square footage, and food and alcohol service
times. Additionally, captures information about activities that may require separate licenses or permits.

Captures information related to retail business including products and services sold, retail space, fire
and safety inspection details, and so on.

Captures measurable attributes used to calculate taxes, such as number of employees, estimated or
actual gross receipts, square footage, number of rental units, and so on.
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Predefined Permit Field Groups

Field Group

Business Information

Construction Information

Electrical Equipment

Fence Information

Grading Information

Insurance

License Qualification

Mechanical Equipment

Photovoltaic Information

Plumbing Equipment

Pool Information

Regulated Business Activity

Right of Way Use

Roof Information

Signage

Special Event

ORACLE

Description

Captures information to help describe the business, such as name, description, number of employees,
industry, and so on.

Captures information regarding the current construction site and the proposed construction project.

Describes a structure’s electrical features, such as outlet types, amps, voltage, and electric appliances.

Describes the proposed fence attributes, such as type, material, dimensions, location, and so on.

Describes the scope of grading work, such as the acreage affected, materials to be used and the
amount of material.

Provides a contractor’s insurance type and policy information.

Enables a contractor to add any state licences they have.

Describes features of the job site related to ventilation, heating, cooling, fire safety, and so on.

Describes attributes of a site’s solar energy configuration, such as roof area, coverage area, inverter
information, and so on.

Describes attributes of a site’s plumbing configuration.

Describes attributes of a pool, such as type, depth, location, surrounding fencing, and so on.

Enables you to specify any regulated activity or controlled substances allowed on the premises, such as
alcohol, carnival rides, casino games, and so on.

Enables you to provide any details related to the use of a right-of-way on the property or to gain access
to the property, such as traffic, parking, or pedestrian impact.

Describes features of a structure’s roof, such as existing roof type, proposed roof type, number of
layers, and so on.

Describes features of signage, such as the sign’s dimensions, use, whether permanent or temporary,
and illumination.

Enables you to specify information about an event, including the safety plan, concessions, facilities,
potential impacts, and traffic plans.
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Field Group Description
Water Heater Describes features of water heaters, such as quantity of new or replaced, type, fuel type, and tank
capacity.
Yard Sale Enables you to specify yard sale information, such as the start time, end time, and the number of days.

Predefined Planning and Zoning Field Groups

Field Groups Description

Dwellings Describes features of housing such as number of units, floor area information, density bonus, rent-
controlled units, and so on.

Impervious Surface Describes features of areas covered by impervious materials, such as concrete or asphalt, including
exemptions from certain requirements, existing and proposed impervious surface areas, and the
property lot area.

Planning Describes features included in planning and zoning, such as proposed number of units, change to the
number of units, assessed value of the current building, development type, commercial building area,
existing land use, lot areas, setbacks, and so on.

Managing Lookup Types Associated with Fields in Predefined Field Groups

Some field groups have fields that are associated with existing lookup types delivered with your offering. To view or
modify the lookup type, you can access the lookup from the Intake Form Designer using the Manage List button.

For more information on managing lookup lists for predefined field groups, see the section “Managing Lookups for
Predefined Field Groups” in Working with Predefined Field Groups and refer to Setting Up Lookups.

Working with Group Boxes

This topic describes how to add group boxes to your form and discusses group box layout options and attributes.

Use group boxes as containers to indicate the items contained within a group box are grouped logically. Once you add a
group box to a page, you can drag these items into the group box:

- Predefined field groups
« User-defined fields

- Other group boxes (nested group boxes)
Adding Group Boxes
To add a group box:

1. Open the Add New list in the Elements panel.
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2. Open the Layout list.

3. Click and hold on the Group box option.
4. Drag and drop the group box into the workspace.

Deleting Group Boxes

To delete a group box:

1. Select the group box.

2. Click the Remove button in the Attributes panel.

I Note: If you remove a group box from a page, the system removes all of the contents of that group box also.

Setting Group Box Attributes

Select a group box to view the Group Box Attributes panel.

Page Element

Remove

Label

Collapsible

Flexible Box Layout

Show Label

Hide Border

Add Help

ORACLE

Description

Click to remove the group box from the page.

Add a name for the group box, describing the collection of items within it.

Turn on to enable the group box to be collapsed when an end user clicks it, hiding items it contains. If
not turned on, the group box is always expanded and its items are always visible.

Use the Flexible Box Layout attribute to establish a group box container based on the CSS flexible box
layout model. In the flexible box layout model, the items contained within the parent container assume
a layout position automatically, based on space in the container. As the available unused space grows
or shrinks, the items in the container grow to fill the unused space or shrink to avoid overflowing the
parent.

With Flexible Box Layout enabled, the system displays as many controls within the group box in one
line until all of the space is utilized, then the system wraps the row, beginning a new line.

When disabled, the controls within the group box display as stacked items, with each additional control
displaying directly beneath the previous control.

Select to hide the group box label (specified in the Label field).

Note:

You can add help only to group boxes with Show Label turned on. If Show Label is turned off, the
Add Help button does not appear on the attributes panel and any help icons associated with any
previously added help no longer appear.

Hides the group box border. When turned on, the border is not visible.

Click to launch the Contextual Help page, which you can use to add help information to aid public users
in completing the intake form. The Add Help button appears only if Show Label is turned on. Help text
added for group boxes should apply to the overall group box content. Help can be added also at the
page level, field group level, and field level depending on the scope of the help text.
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Page Element Description

For more information on adding Contextual Help, see Adding Contextual Help to Forms.

License Activity Note:
This attribute applies only to the Business Licenses offering.

Expand the Display section to view this feature.

License activity filtering enables you to control the display of group boxes, depending on the current
business license activity selected by the applicant.

For more information on setting display filters, see Configuring Activity Filtering for Business Licenses.

Control Display Expand the Display section to the view this attribute.
Click to select an element in the form that controls the display of the group box.

For more information, see Displaying Form Elements Conditionally.

Hide from public user Expand the Security section to view this attribute.

Hides the group box and all the elements in the group box container from the public user at runtime.
Only agency staff can view and update information within a group box with Hide from public user
turned on. In addition to hiding the Ul element from the public user in the interface, the application
also secures the back end for that specific Ul element, such as preventing any unauthorized access to
the fields contained within that Ul element using a REST API, for example.

Note:
The Hide from public user setting and the Confidential setting are mutually exclusive.

Note:
You can't apply this setting to group boxes containing fields that have default values or fields that
are set as required.

Confidential Expand the Security section to view this attribute.

Turn this attribute on to specify that the user-defined fields within the group box container hold
confidential information.

At run time, fields with confidential information will be hidden to all users except for users without the
appropriate privilege. These users can see the confidential information:

- Agency users directly associated with processing the business license.

- The public user who entered the information.

Note:
The field does appear in the JSON payload for the page, however the field value will be null.
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Page Element Description
Note:

The Confidential attribute applies only to the Business Licenses offering.

Note:

You can't add a predefined field group to a group box with the Confidential attribute turned on. The
Confidential attribute can be set only for pages and group boxes, and it applies only to user-defined
fields within those containers. You can’t apply the Confidential attribute to field groups.

Note:
The Hide from public user setting and the Confidential setting are mutually exclusive.

Note:
Don't apply this setting to group boxes containing fields that have default values or fields that are

set as required.

Example: Nesting Group Boxes

Nested group boxes can be used to represent subcategories of information and to enhance layout options, such as
creating columns for form elements.

The following example illustrates nested group boxes, which you achieve by dropping group boxes within group boxes.

This example illustrates an outer group box container with two inner group boxes nested within to logically divide page
content.
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4 Group Box - Level 1 X
4 Nested Group Box - Level 2 %
Field A *,
Field B 4
4 Nested Group Box - Level 2 .
Field C »
Field D ®

Note: The system does not impose a limit to the depth of nested group boxes you can insert. For more complicated
pages, for example, you may find that group boxes could be nested to 4-5 levels deep. Make sure to consider how a
page with multiple levels of nested group boxes will render on all the devices you intend to support for your user base.

Example: Using Group Boxes to Combine Predefined Elements

In some cases you may want to give the appearance of multiple field groups being combined. You can do this using
a group box to act as the outer container for the set of field groups. When using a group box to contain field groups,
consider the following items:

- The collapsible attribute of the group box container controls the visibility of the contained field groups. If the
group box container is set to be collapsible, when the user collapses that group box, all of the elements within
that group box will be hidden.

If you want the field groups within the group box to be categorized under just the label of the group box, turn
off the Show Label attribute of the contained field groups.

In the following example, assume you want to combine the Fence Information and Comment field groups, giving the
appearance that Fence Information field group also contains a Comment field.

To combine field groups within a group box container:

Open the Add New list in the Elements panel.

Open the Layout list.

Drag and drop a Group box into the workspace.

Select the group box and make these changes on the Group Box Attributes panel:

P UWNa
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Group Box Attribute Sample Value
Label Fence Information
Flexible Box Layout Off

5. Open the Ready to Use list.
6. Open the Field Groups list.
7. Drag and drop the Fence field group into the group box
8. Select the Fence field group, and turn off Show Label on the Attributes panel.
9. Drag and drop the Comment field group into the group box.
4 Fence Information *
. ! X
Type of Work Front Fence Height
Type of Use Rear Fence Height
Pool Enclosure Left Fence Height
Fence Type Right Fence Height
Other Fence Type Location
Foundation Type Corner Lot
Automatic Closing Material
Gate
Other Material
Lock
~ X
_omment
Comment

10. Select the Comment field group, and turn off Show Label on the Attributes panel.
11. Save your changes.

At runtime, the example steps above produce a single, collapsible section in the form that includes both the Fence
Information and the Comment predefined elements.

This example illustrates the collapsed Fence Information group box.

» Fence Information

This example illustrates the expanded Fence Information group box containing multiple field groups.
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4 Fence Information

Type of Work Front Fence Height
Type of Use Rear Fence Height
Pool Enclosure Left Fence Height
Fence Type Right Fence Height
Other Fence Type Location
Foundation Type Corner Lot
Automatic Closing Material
Gate
Other Material
Lock
Comment

Example: Using Group Boxes to Combine Field Groups and User-Defined
Fields

Similar to combining field groups within a single group box container, you can also combine field groups and user-
defined fields within a single group box container creating the appearance of user-defined fields being part of a
delivered field group.

In the following example, assume you need to associate a field with the Fence Information element to capture the color
of a proposed fence.

To combine predefined elements and user-defined elements with group boxes:

P UWN

©Now

Open the Add New list in the Elements panel.

Open the Layout list.

Drag and drop a group box into the workspace.

Select the group box and make these changes on the Group Box Attributes panel:

Group Box Attribute Sample Value
Label Fence Information
Flexible Box Layout Off

From the Ready to Use > Field Groups list, drag and drop the Fence field group into the group box.
Select the Fence field group, and turn off Show Label on the Attributes panel.
From the Add New > General list, drag and drop a text field into the Fence Information group box.
Select the text field, and enter Color for the Label in the Field Attributes panel.
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4 Fence Information x
x
Type of Work Front Fence
Height
Type of Use

Rear Fence Height

Pool Enclosure
o Left Fence Height

Fence Type
Right Fence
Other Fence Type Height
i Location
Foundation Type
Automatic Comer Lot )
Closing Gate .
Material
Lock

"" Other Material

Color x

9. Save your changes.

The following example illustrates how at runtime, the group box containing the field group and the user-defined field
create the appearance of the manually created field being part of the delivered field group.

4 Fence Information

Type of Work Front Fence Height

Type of Use Rear Fence Height

Pool Enclosure Left Fence Height

Fence Type Right Fence Height

Other Fence Type Location

Foundation Type Corner Lot

Automatic Closing Material
Gate

Other Material
Lock

Color
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Working with Fields

This topic describes how to modify field attributes and add user-defined fields to your intake forms.

When end users are completing an application for a transaction, such as a permit, they enter the required information in
fields. Fields can be added to intake forms by:

- Adding predefined field groups to your form. Each field group is delivered with a set of fields.
- Adding user-defined elements (fields) to your form.

Setting Field Attributes

Select a field to view the Field Attributes panel. Fields in predefined field groups and user-defined fields typically have
the same set of attributes. Not all attributes apply to each field type.

The type of field you select determines the attributes appearing in the Field Attributes panel. For example, for a number
field, you can set a default value and a placeholder value, but for a single-item check box, neither of these attributes
apply and therefore don't appear.

The following table describes the field attributes.

Note: Not all attributes apply to every field type. Only the attributes that apply to the currently selected field appear.

Page Element Description

Remove Click to remove the selected field from the layout.

The Remove button appears only for user-defined fields you added manually. You can’t remove fields
from a delivered field group.

Note:

If your form has been used in a production environment, rather than removing a field it is
recommended to hide the field. Removing a field that is already storing production data can lead to
unexpected results and data inconsistencies.

Label Add a custom label to the field.

Note:

In the case of a user-defined field, the system forces the field ID value to match the Label value, but
removes any spaces. The field ID represents how the field appears in the underlying data model.
For example, a user-defined field with the label Additional Requests, will have a field ID value of

AdditionalRequests_c.

For more information on working with field labels and field IDs, see the section below named "Working
with Field Labels and Field IDs."

Placeholder Add descriptive text to provide hints for entering data. For example, the placeholder text could read:
Enter date in this format” MM/DD/YY, or simply MM/DD/YY.
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Page Element

Default Value

Decimal Places

Reusable

Required

ORACLE

Description

The placeholder value does not get saved to the database when a form is submitted.

Enter a default value required for the field.
The default value gets saved at runtime if the user does not change it.
The control you use to set the default value is consistent with the field type you added to the intake

form. For example, for the date field you use a date picker control, for a switch field you use a switch,
and so on.

Note:

In cases where both the Placeholder and Default Value attributes appear for a field type and you
have provided values for both, the default value supersedes the placeholder value. That is, at
runtime, users see the default value, not the placeholder value, but if they delete the default value,
the placeholder value appears to help users enter a valid value.

Applies to number fields only.

Set the number of decimal places for number fields, depending on what you are measuring and the
precision you require.

The limit is 10 decimal places.

When adding decimal places to a number field, keep in mind that the number of digits contained
within a number field can’t exceed 16.

The total number of digits is the sum of all integer digits and decimal digits.
For example, if a field has 2 decimal places, that field has 14 integer digits that can be entered without

exceeding any limits. If this limit is reached, this can cause unexpected rounding results.

Enable if you want to reuse a user-defined field on other intake forms. When you save the intake form,
fields that are set to be reusable appear within the Ready to Use > Fields section in the Elements panel.

Note:
A reusable field can’t be set to be required or hidden.

For more information, see the “Reusing Fields” section below.

Enable if this is a required field for which a user must enter a value.

Note:
A required field can’t be hidden or reusable.

Note:

You can't delete a field that has been set to be required. You must first turn off the Required
attribute, save the form layout, and then delete the field. Deleting a required field from an intake
form that has already been published may affect forms submitted previously.
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Page Element Description
Hidden Hides the field from the user. If a predefined element contains fields that you do not need, select this

option so the user does not have access to the field.

Note:
A hidden field can’t be required or reusable.

Manage List Add values for fields containing a list of values, such as check boxes, lists, and so on.

Note:

Depending on the lookup type, the location where you manage the lists differs. For existing lookups
delivered on predefined field groups, you use the Lookups page. For lookups that you associate with
a user-defined field, such as a drop-down list, you use the Custom Lookups page. The Manage List
button takes you to the appropriate page for the lookup type, with the correct list displayed.

For more information, see Defining Fields Displaying a List of Values.

Add Help Click to launch the Contextual Help page, which you can use to add help information to aid public users
in completing the intake form. Help text added at the field level should apply specifically to that field.
You can also add help to predefined elements, group boxes, and pages, depending on the scope of the
help text.

For more information on adding Contextual Help, see Adding Contextual Help to Forms.

Add Logic Click to add scripting logic using the Groovy programming language.

Note:
For user-defined fields that you have added to your intake form manually, the Add Logic button
appears only after you have saved your form.

For more information on adding logic to your forms, see Adding Logic.

Edit Click to display the Rich Text Editor dialog box for entering formatted text to the application form.
Appears only for rich text areas.

For more information on rich text areas, see Adding Rich Text Areas.

Using the Field Details Section

Under the main controls used to configure fields described above is the field details section. It provides additional
information that you may need to know for various tasks such as reporting or writing business logic.

Page Element Description

Business Object The business object to which this instance of a field belongs.
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Page Element Description
Name Also referred to as the field ID. This value is the internal name of the field as it appears in the database

view object, the REST request JSON, or how you’d refer to it in a Groovy script for example.

Data Type The data type of the values the field stores, such as string or number.

List ID

Applies to lookup fields, containing a list of values (LOVs). Knowing this value can make it easier to
confirm the lookup list you need to access if values on the list need to be updated.

Note:

Depending on the lookup type, the location where you manage the lists differs. For existing lookups
delivered with the Fusion offering, you use the Lookups page. For lookups that you associate with a
user-defined field, such as a drop-down list, you use the Custom Lookups page.

Adding User-Defined Fields

Note: You can add user-defined fields to group boxes only. You can't add user-defined fields directly to a page orto a
delivered field group.

To add a user-defined field:

uhWNA

Expand the Add New section of the Elements panel.

Open the Layout list.

Add a group box to the current page.

Open the General list in the Add New section.

Select a field type, and drag and drop it in the desired group box.

I Note: User-defined fields must be contained by a group box.
Select the user-defined field you added, and use the Field Attributes panel to configure your field.
I Note: User-defined fields and fields provided in predefined field groups use the same set of attributes.

Save your changes.

Once saved, the system applies your user-defined field to the application data model so field data can be
captured, stored, and retrieved.

Working with Field Labels and Field IDs

Fields are identified by the label and the field ID. The label is displayed on the user interface for the end users, and the
field ID is used internally at the database level. In some cases, such as when working with reporting or when writing
business logic, you will need to know a field’s label and the associated field ID.

All fields have a field ID whether they are field group fields or user-defined fields. A user-defined field has _c appended
to the field ID to indicate that it is custom. The field IDs for user-defined fields are automatically generated by
concatenating the label when they are first saved. For example, the field ID for the label My Field is MyField_c.
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Use the Field Details section in the Field Attributes panel or the Field ID Search feature in the Groovy Script Editor to find
the field ID for the selected field.

For more information on the Field Details section, see the "Using the Field Details Section” in this topic.
For more information on the Field ID search feature, see Adding Logic.

When adding a user-defined field, a default label and field ID is automatically assigned based on the order in which the
field was added, such as Field 1 (Field1_c), Field 2 (Field2_c), and so on. When you first save a user-defined field, the
field ID gets created at the database level and can’t be changed.

Note: If you save a user-defined field without providing a custom label, the field ID will remain the default field ID
value, even if you provide a custom label later. For example, if you save a user-defined field with the default label of
Field 1and later change it to My Field, the field ID will still be Field1_c.

When you add a field and save it, that field gets created in the database, and remains in place regardless if you remove
it from the form design later. If you remove a field from a form that has already been saved, the string - Retired is
appended to the field ID, which helps you to identify and avoid them when setting up features like reports or audits, for
example. These unused fields are considered orphaned fields because they are no longer mapped to a field in the intake
form.

Because there are a limited number of user-defined fields that can be created for a single intake form (roughly 625),

there is an internal process in place to manage orphaned fields. To conserve database resources, if you later create a
field of the same name and the same data type as an orphaned field, the orphaned field may be assigned to the new
field based on the following criteria:

Unique field IDs, such as lamaContractor_c, are reassigned if the orphaned field ID value and data type the
same.

Default field IDs, such as Field1_c, are reassigned if the orphaned field ID is also default and the data type is the
same.

Choosing User-Defined Field Types

Expand the Add New section in the Elements panel and open the General list to view the field types you can add to your
forms.

Note: You must first add a group box to your form, and then you can drop one or more user-defined field types into
the group box container.

Field Type Description

Text field Adds a character field to hold text values.
A text field is limited to a length of 200 characters. If you need to provide a field that enables users to

enter more characters, consider a text area field.

Number field Stores numeric values. The value can be an integer or it can contain decimals depending on how you
set the Decimal Places attribute.
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Field Type

Date field

Date time field

Switch

Text area

Rich text area

Single-item check box

Check box set

Radio button set

Drop-down List

Multi-select List
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Description

Note:
The total number of digits allowed is 16.

Stores date values, such as 09-26-2020.

Stores date and time values, such as 09-26-2020 11:25 AM.

On-off field, such as an “active” field indicating whether an item is active or not, which would be either
on or off (yes or no).

Along character field enabling the user to enter longer descriptions.

A text area field is limited to a length of 1500 characters.

Along character field enabling the user to enter longer descriptions or instructional information that
can be formatted using a rich text editor.

For more information on rich text area fields, see Adding Rich Text Areas.

Displays a single option for the end user to select, such as, "l have read the terms and conditions, and
| agree to the terms and conditions." This is different from a check box set, which displays a list of
multiple items for an end user to select.

In the case of a single-item check box, the label of the field acts as the text the end user reads and
responds to on the application form.

A set of check boxes from which the end user can make multiple selections. For example, the label for
the check box set might be Heating Source(s), with values such as Oil, Gas, Wood, Solar, and so on.
This field needs to be associated with a list of lookup values.

For more information, see Defining Fields Displaying a List of Values.

A set of radio buttons from which the end user can make a single selection. For example, the label for
the check box set might be Fence Type, with values such as Stone, Wood, Vinyl, and so on.

This fields needs to be associated with a list of lookup values.

For more information, see Defining Fields Displaying a List of Values.

A drop-down list allowing the user to select a single item.
This field needs to be associated with a list of lookup values.

For more information, see Defining Fields Displaying a List of Values.

A drop-down list allowing the user to select multiple items.
This field needs to be associated with a list of lookup values.

For more information, see Defining Fields Displaying a List of Values.
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Field Type Description

Reusing Fields

You may want to include some user-defined fields on multiple intake forms. Rather than recreating the same field
multiple times for each intake form, you can create the field on one intake form and set it to be reusable, which enables
that field to be available to add to other intake forms for your agency.

Note: Fields set as reusable can be used on intake forms within the same offering. For example, if you create a

reusable field in the Permits offering, and you have also licensed the Planning and Zoning offering, that reusable field
will not be available to use for Planning and Zoning intake forms.

Prior to setting a user-defined field to be reusable, consider these items:

Consideration Description

Values If a reusable field is added multiple times to the same form design, it must be intended to reflect the
same purpose and value.

Fees Reusable fields can’t be incorporated in the fee calculations executed by decision models defined in
Oracle Integration Cloud.

Deletion Currently, you can’t delete reusable fields from the Fields list in the Elements panel. You can remove
unnecessary fields from the intake form.

Limited quantity You can define up to 625 fields as being reusable.

Required fields Required fields can’t be set to be reusable.

Hidden fields Hidden fields can’t be set to be reusable.

Groovy You can add logic to reusable fields, however, the logic should be specific to that field only. If the

logic applies to the transaction type level, such as a specific permit type, then add the logic at the
transaction type level using the Add Logic button in the toolbar.

Creation The reusable field is created, when you click Save.

Note:

Once the field is saved with the Reusable switch turned on, the field is reusable, and the Reusable
switch becomes disabled. You can’t convert a reusable field to be a non-reusable field. Likewise, you
can’t convert a non-reusable field to be a reusable field, once the intake form design including the
field(s) has been saved.

Updating Changing the label, placeholder, or default value on any reusable field will update those values for all
transaction types using the field.
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Consideration Description
Cloning When you clone a transaction type, reusable fields are also cloned.
Note:

During the cloning process, the new intake form design is saved. The save process, disables the
Reusable switch for both reusable and non-reusable fields.

To make a user-defined field reusable:

Review the guidelines above and carefully determine if the field should be reusable.
Select the user-defined field.
Turn on the Reusable switch in the Field Attributes panel.

Click Save.
Confirm that the label for the reusable field appears in the Ready to Use > Fields section in the Elements panel.

uvhWNRA

Hiding Fields
In some cases, you may not want to display all of the fields associated with a delivered field group you've added to a
form. You can hide unneeded fields so they do not appear to the user at runtime.

To hide fields:

1. Place your cursor in the field to select it.
2. Turn on the Hidden switch on the Field Attributes panel.

Once you have hidden a field, the design-time interface continues to display the field, but places a darkened
background around the field to indicate it is a hidden field. The application does not display the field at runtime.

This example illustrates the shading around a field to indicate that is hidden during design time.
Location
Corner Lot
Materia

Other Material
In this example of the design-time interface, Location and Material are not set to be hidden, but Corner Lot and Other
Material are. Notice that the hidden fields display with the darkened background.

The following example of the runtime illustrates that the hidden fields do not display when an end user accesses the
form. Only Location and Material render on the form at runtime, while Corner Lot and Other Material are not rendered.

This example illustrates the fields indicated as hidden in the previous example in design time do not appear on the form
at runtime.
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Location

Material

Note: Required fields can’t be hidden fields. If you set a field to be required, the Hidden switch becomes disabled. If
a field is set to be hidden, and you set it to be required, the system sets the Hidden switch to off automatically and
disables the Hidden switch.

Adding Rich Text Areas

This topic describes how to add rich text areas to your intake forms so that you can display formatted text in application
intake forms.

Rich Text Area Overview

In some cases, you may need to add rich text areas to your application forms so that you can display formatted text for
users filling out the application. For example, if you needed to provide additional information, such as instructions or
reference material, you can provide that within a rich text area.

Note: The rich text area provides a way for your agency to provide read-only formatted text for end users. A rich text
area does not enable the end user to be able to insert formatted text into the form.

When you add a rich text area element to your form, an Edit button appears in the Field Attributes panel when you
select the rich text area element. The Edit button launches the Rich Text Editor dialog box.

This example illustrates the Rich Text Editor dialog box displaying bold, colored, and italicized text; normal text; and text
within a numbered list.
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Rich Text Editor x

Keyboard users can place the cursor in the text editor and press Alt + 0 to access keyboard shortcut instructions.

Font - | Size -|B I U & A-RA-|12:

42 HE | 4

Adding Rich Text

To add formatted text to your forms:

1. Add a group box to your form.

2. Drag and drop a rich text area field onto the group box.

3. Select the rich text area element, and click Edit in the Field Attributes panel.
4. Add your text using the Rich Text Editor dialog box.

5. Click OK.

body ol i

The Rich Text Editor dialog box provides these formatting options:

- Fontsize

- Bold, italic, underline

- Copy formatting

- Text color

- Text background color

- Numbered and bulleted lists

- Undo and redo

- Increase and decrease indentation

- Horizontal line

Adding a Rich Text Area to a Form

To add a rich text area:

1. Insert a group box into your form where you want to place the rich text area.
2. From the Add New > General list, drag and drop a rich text element into the group box.
3. Select the rich text area element.

This example illustrates the rich text area element being selected prior to rich text being added.
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4 Group box X

Field O

This is a rich text area. To add or edit content, select this element, then
open the rich text editor.

4. Inthe Field Attributes panel, click Edit to open the Rich Text Editor dialog box.

Note: If needed, you can use the Description field to enter a description of the contents of the rich text area
for other implementation team members. The description you enter only appears in the designer; it is not be
displayed at run time.

ui

Add text and use the desired formatting options.
Click OK.
7. Save your form layout.

o

Defining Fields Displaying a List of Values

This topic describes how to add a list-of-values (LOV) to user-defined fields.

Some of the user-defined fields that you can add to your form are considered “list-of-value” fields, or LOV fields. List-
of-value fields enable end users to select field values from a predefined set of values (a lookup) to populate the field
when entering data on the form. For example, radio sets and drop-down lists are list-of-value fields.

The list of values is a lookup type, and the individual items in the lookup type are lookup values.

When adding a list-of-value field type to your application form, you first add the field to the form, just as you would any
other field. You then either select an existing lookup type to associate with the field, or you can create a new lookup type
if needed. To manage lookup types you use the Custom Lookups page.

This example illustrates the Lookup Type page.

Custom Lookups

Lookup Type flz
+
Lookup Type Meaning Actions
PSC_ID_FENCE_TYPE Fence Type Select >
v PSC_ID_HEAT SRC Heat Source Select >

PSC_ID_ROOF_TYPE Roof Type Select »
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Alist of values is a set of fixed field values defined for a specific purpose that is not expected to change over time.
Removing items from the list, for example, could make previously saved data invalid.

An example of a field with a list of values could be the Property Zone Type field, where the values for a user to select are:
Business, Residential, and Agricultural.

Once you have clicked the Select button, for a lookup type row, a check mark appears next to that lookup type to
indicate it is the lookup type associated with the current LOV field.

This example illustrates the check mark that appears to the left of the lookup type to indicate lookup type selected for
the current field.

Custom Lookups

Lookup Type
+

Lookup Type

v PSC

I Note: A single user-defined lookup type should be used by only one user-defined field.

I Note: Once you have saved a user-defined field with a lookup type selected, its lookup type can’t be changed.

Identifying List of Value Type Fields

You associate a list of values with these field types:

Radio button set
- Check box set
Drop-down list

Multi-select list

The following example illustrates a radio set, which is a set of radio buttons allowing a user to select a single value from
the list of values.

Text surrounding the image describes it.

Fence @ “wWood

M aterial Ctone

Chain Link

The following example illustrates a check box set, which is a list of multiple items allowing a user to select multiple
values from the list of values.
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K aterials Required Cement
Crushed Rock
V| Loam
v Sand

Stone
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The following example illustrates a drop-down list, which is a list allowing a user to select a single value from the list of

values.

Text surrounding the image describes it.

Furnace b

M anufacturer
Armana

Armerican Standard
Bryant
Rinnai

Trane

The following example illustrates a multi-select list, which is a drop-down list allowing a user to select multiple values

from the list of values.

Text surrounding the image describes it.

Heating Source(s) Propane ¥  Solar %

Electricity
il

Pellet
Wood

Selecting an Existing Lookup Type for a Field

To select an existing lookup type:

1. Add the list-of-value type field to your form layout.

ORACLE
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2. Select the new field.
3. Click Manage List in the Field Attributes panel.
This opens the Lookup Type page.
4. On the Custom Lookups page, identify the lookup type to associate with the list-of-value field you added.

Use the Meaning column to identify the appropriate list, or you can click View More Details to view the
description and the actual lookup values in the lookup type.
5. Click Select in the Actions column to associate the desired lookup type with your field.

Note: Once you select a lookup type, the Lookup Type page closes automatically. You can click Manage List
to confirm your selection if needed.

6. Save the form layout.

Adding a New Lookup Type for a Field

1. Add the list-of-value type field to your form layout.
. Select the new field.
3. Click Manage List in the Field Attributes panel.
This opens the Lookup Type page.
On the Custom Lookups page, click Add.
On the Lookup Type Details page, enter these values.

v oA

Page Element Description

Lookup Type The system name, beginning with PSC, using uppercase letters, numbers, or
underscores.

For example, PSC_ROOF_TYPE.

Note:
All lookup types created and used within the Intake Form Designer must begin with
PSC.

Meaning Add a short, user-friendly description. This value appears in the Meaning column of the
list of lookup types, which can help to identify the contents of the list.

For example, Roof Type.

Description Provide any additional information to help identify the purpose and intended usage of
the lookup type.

6. Add lookup values to the lookup type.

a. Inthe Look Up Values grid, click Add.
b. Modify these values:
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Page Element

Lookup Code

Display Sequence

Enabled

Start Date

End Date

Meaning

Description

c. Click Save.

Chapter 7

Creating Intake Forms

Description

A short code used to identify the lookup value to the system, like a key value.

If required, you can set the sequence in which lookup values display in the
lookup list, using a numeric sequence.

By default, a new lookup value is enabled. To disable a lookup value, turn off
this switch.

Date on which a lookup value becomes valid.

Date on which a lookup value is no longer valid.

The value that displays to the end user at runtime to select from the list.

Any additional information to describe the content or purpose of a lookup
value.

d. Repeat for additional lookup values in the lookup type.

Example:

This example illustrates the Lookup Type Details page, showing a completed lookup type with a set of lookup

values.

ORACLE
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Custom Lookups

Lookup Type Details Cancel | [N

* Looku p Type PSC_ID_HEAT_SRC Description | This list contains the types of heat
used for structures in this

Eo
Meaning

Heat Source

Lookup Values

+ 4
Lockup Code Display Sequence Enabled Start Date End Date Meaning
WD 1 Yes 8/27/19 Wood >

5 Yes 9/27/19 Electricity >
PR 2 Yes 9/27/19 Propane >
NG 3 Yes 10/21/19 Natural Gas >
sL 4 Yes 11/1/19 Solar >

7. On the Lookup Types page click Select to associate the new lookup type with the field.

Or, click Close to associate the lookup type with another field later.
8. Save the form layout.

Understanding the Scope of Lookup Types Created in the Intake Form
Designer

The items in the following table describe the scope of the list of value fields that you can create and use in the Intake
Form Designer.

Scope Item Description

User-defined fields You can create a list of values for user-defined fields only.

You can't create a list of values for a field contained within a delivered field group. Some of the list of
value fields in predefined field groups are associated with lookup lists that you can manage using the
Manage List button.

Note:

Once you create a lookup list for a user-defined field and publish the intake form, that lookup

list can also be viewed outside of the designer using the Lookup Type page. However, it is
recommended to manage lookup lists for user-defined fields only in the Intake Form Designer. For
more information on the Lookup Type page, see Setting Up Lookups.

Intake Form Designer-only The lookup types that you create within the Intake Form Designer can be used only within the Intake
Form Designer. Only in specific circumstances can you associate a field in your form layout with lookup
types created outside the Intake Form Designer.

The interface used to create and select lookup types for use in your intake forms looks identical to the
Lookups page (Navigator > Common Setup > Lookups), which is the interface used to manage lookups
for Public Sector Community Development offering pages, such as the permit offering or the planning
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Scope Item

Other licensed offering(s) in the same
database

Description

and zoning offering. However, the lookup types created on the Lookup pages can not be used for your
intake forms nor visa versa. For example, you can’t use the UOM Type lookup type (ORA_PSC_CC_
UOM_TYPE) from the Lookup Type page for your intake form fields.

In select cases, if you are an existing Fusion Application Cloud customer, and you have other licensed
offerings in the same database as the Public Sector Compliance and Regulation offerings, you can
utilize lookup types not beginning with PSC for your intake form fields if required.

For example, if you also license Fusion Application Cloud for Financials, which shares the same
database as the Public Sector Compliance and Regulation offerings, you can select lookup types using
the Intake Form Designer interface, assuming you are aware of the values it displays and how it is
maintained.

To access these lookup types, you need to modify the filtering on the Lookups page. By default, the
Intake Form Designer filters on PSC or the exact name of the selected lookup.

Refer to the following example for more information on modifying the filtering option.

Example: This example illustrates modifying the default filtering for the Intake Form Designer lookups.

To modify the filtering on the Lookup Type page:

P WNa

Click Apply.

Click the Filter By button.
Select how you want to filter, as in by Lookup Type or by Meaning.
Select the operator to use for your filtering, such as Starts with, Contains, and so on.

Displaying Form Elements Conditionally

This topic describes how you can show or hide elements on your forms depending on selections users make on other

form elements.

You can configure some form elements to be either displayed or hidden, depending on the value of other fields in
the form. Form elements that can control the display of other elements are controlling elements, and form elements
that can be shown or hidden based on the value of controlling elements are controlled elements. The following table
describes the elements involved in conditional display.

For example, assume you wanted to display the Photovoltaic field group only if the user has selected the Solar single-
item check box in a “Building Options” section of a permit application form. In this case, you can set the Solar single-
item check box as the controlling element for the Photovoltaic field group, having the Photovoltaic element (the
controlled element) display only when the Solar single-item check box is selected.

Display Type Element Types Description

Controlling Element - Single-item check box Form elements that determine whether another form element is

- Switch

ORACLE

displayed, depending on the value selected by the user.
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Display Type Element Types Description
Note:
Only single-item check boxes and switches can be controlling
elements.
Controlled Element - Field group Form elements that can be displayed conditionally, depending on the
value of the associated controlling element.
Group box
Page To control when these elements appear, click the Control Display button

on the Attributes tab, which appears only for these element types.

Procedure: Configuring Conditional Display

To configure conditional display for a form element:

1.

>

Add the controlling element to a group box in your application form.
The controlling element can be a user-defined element of these types:

o Single-item check box
o Switch

Note: The controlling element must appear before the controlled element that references it.
Add the form element that you want to display or hide conditionally (the controlled element).
The controlled element can be:

o Field group
o Group box
o Page

Select the controlled element you just added so that it is the active element in the layout.
In the Attributes panel, click Control Display.

On the Control Element Display dialog box, click Add to add a row to the grid, then double-click in the newly
added row, and make the appropriate selections.

Note: Once you add a row to the grid and activate it by double-clicking, you must enter value before clicking
OK.

This example illustrates the Control Element Display dialog box set to show a condition of a controlling element,
such as hide this element if a switch element in the form is false.
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Control Element Display X
f you add multiple rows of display conditions in the grid, and any display condition evaluates to true, the element will be
hidden.
+ @
Display A Controlling Element Value
Hide if Application Options - Plumbing False
Cancel “

Element Description

Add Click to add a new row to the grid.

After adding a row, double-click the row to make it active.

Note:

If you add multiple rows of conditions to the grid, the system assumes an “OR”
operator exists between each row. If any of the conditions are confirmed, that display
option will be enabled.

Delete Click to delete the selected row in the grid.

Display Currently, Hide if is the only display option. You hide an element based on the value of
the controlling switch or single-item check box, otherwise, the element is displayed.

Controlling Element Select the form element that will control the display of the selected predefined form
element or group box.

The drop-down list displays all user-defined switches and single-item check boxes that
exist on or before the current page in the form.

Selecting the controlling element appearing before the controlled element adheres to
the logical sequence a user would take when completing the application form.

Note:
If the selected element is a group box, the drop-down list does not display any
switches or single-item check boxes within that group box.
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Element Description

Value Select the value of the controlling element that determines when the display option will

be rendered:

o True: A condition is true if a single-item check box is selected or a switch is on.

o False: A condition is false if a single-item check box is deselected or a switch is off.
6. Click OK.
7. Save your form.

The controlled element appears with an icon below the element label to indicate it is an item whose display is controlled
by another element in the intake form.

This example illustrates the icon displayed for a controlled element.

4 Solar Installation Information

Type of Use Roof Materia

Type of Roof Roof Layers

Service [D Roof Connaction
lete

Mumber of Roof

Ph Connections

Working with the Conditional Display of Pages

This section describes items to consider when using the conditional display feature with pages, which includes:

- Hiding a page based on a controlling element.

- Hiding all elements on a page.

Note: A page can become hidden if the page itself is a controlled element and also if all items on the page are
controlled elements and all become hidden.

You can control the display of an entire page based on the value of a controlling element in the intake form. Doing so
introduces dynamic display features to your intake form that can streamline the form significantly. Based on the user’s
selection of a single-item check box or a switch can determine whether a page displays or is hidden, providing user’s

an improved experience. Using this feature, only the pages relevant to the user’s transaction would be displayed. As
selections are made, the pages appear or become hidden accordingly.

This example illustrates single-item check boxes controlling the display of the corresponding intake form pages.
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Applicant Details X Project Scope X | @ Plumbing X @ Electrical X _ @ Constructrion X Add Tab

4 Select the itemstrat apply tox
Plumbing
Electrical

Construction

Note: The train stop drop-down list also changes dynamically to reflect the current set of pages as pages appear or
become hidden.

In cases where all of the elements on a particular page are controlled elements and each element’s controlling element’s
display conditions cause all the elements on the page to be hidden, the system will hide the entire page.

In the following example, each element on the page is a controlled element. If each element becomes hidden as a result
of the values selected for the controlling element, the entire page becomes hidden.

This is an example of all elements on a page being controlled elements. Details are in the surrounding text.

€ ¢ @& Constructrion X Additional Options % Add Tab Form Options

4 Grading Information

&
Project Type ‘ Cut Disposal Site ‘ ‘
Project Acreage ‘ Export Amoun ‘
Disturbed Acreage ‘ Fill Amount ‘
Mumber of Lots ‘ ‘ Fill Materia ‘
Cut Amount ‘ mport Amount ‘
Cut Materia ‘ Source of Import ‘ ‘

Demolition

4
&

Structure

Description

Demolition Reason

Adding Logic

This topic describes how to add business logic to intake forms using the Groovy programming language.
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Groovy Overview
You can add business logic to your intake form using the Apache Groovy programming language.

Groovy is an:

- Object oriented language that can be used for scripting or programming.

Extension of the Java programming language, using similar constructs and syntax.

For Java developers, Groovy can be compared to other programming languages, such as Python or Ruby, that don’t
intend to replace Java, but act as a companion language, extending capabilities and providing additional flexibility.

When designing intake forms, you can add Groovy scripts to provide:

- Validators
- Triggers
- Object functions

- Global functions
The logic can be added at these levels:
Field: Field-level logic applies only to the currently selected field.

- Object: Object-level logic can be used within a single intake form design.

- Global: Global functions can be called from any intake form in your offering.

The types of scripts you can add depends on the level on which you are adding the logic (field or object).

Script Type Level

Validator Field and Object
Trigger Object

Object Function Object

Global Function Object

Before adding Groovy to your intake forms, you will need to become familiar with the Groovy language and how it is
intended to be used within Oracle Fusion applications.

For more information on Groovy usage within Oracle, refer to Oracle Applications Cloud: Groovy Scripting Reference.
For more information on Groovy usage within Oracle, refer to Oracle Applications Cloud: Groovy Scripting Reference.

For general information on the Groovy language, see Apache Groovy documentation.
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Working with the Groovy Script Editor

To access the Groovy Script Editor:

1. Save the intake form you are creating.

The field(s) you reference in your logic at the field level or the object level must exist in the underlying database
object, which occurs when you save the form after adding any new elements.

Note: For the user-defined fields you added manually to your intake forms, the Add Logic button doesn’t
display in the Field Attributes panel until you have saved your intake form.

2. C(lick the Add Logic button in the Field Attributes panel or in the intake form header.

o When clicking Add Logic in the Field Attributes panel, your code operates at the field level.
o When you click Add Logic in the intake form header, your code operates at the object level.

This example illustrates the separate field-level and object-level Add Logic buttons.

Add Logic Preview Save Publish

Obiject Level

Form Options >

Field Attributes
Label ®

License Class Code

Placeholder

Default

Required

Hidden

Add Logic | Field Level

Add Help

3. Use the Groovy Script Editor to add the logic, script name, error message, and additional options, depending on
the type of script you are writing.

The following example illustrates adding validation logic to a field using the Groovy Script Editor.
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Groovy Script Editor

Validators

This logic is global and will be active anytime this field is in an intake
form. */

S
3 newvalue > @

1 /* Field validator for field LaborCost_c Custom Object LNP1IDFencePermit_c.

Chapter 7

Creating Intake Forms

Script Name *

LaborCost_c_validator v
Description

Walue Greater Than 0

Error Message *

The value entered for Labor Cost must
be greater than zerco.

Field ID Search
Label
v
Field ID
Save Remove Close

Only the page elements that apply to the type of script you are writing appear in the editor.

Page Element Script Type
Work Area All
Script Name All

ORACLE

Description

In the work area, add your logic.

The first line in the comments (/* <text> */) is
automatically generated, and it provides you
the field name and object name as they are

referenced internally.

For a field contained in a delivered field group,
the field name will be similar to the field label,

such as DemOverallHeight.

In the case of a user-defined field, the field
name will match the field label you have
entered, with a "_c" as a suffix to indicate itis a

custom field.

For example, if you have a user-defined field
named Rooms, the field name appearing in the

script will be Rooms_c.

The custom object name is the type code as
defined on the Transaction Type page, and it
is preceded by the offering code, such as LNP1
or PZ1and a “_c” suffix. LNP1is the prefix for
permits and PZ1is the prefix for planning and

zoning applications.

For example, if for a permit the Transaction
Type Code is Fence, the custom object name in

the script will be LNP1Fence_c.

By default, the script name follows this

structure:
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Page Element

Description

Type

Error Message

Field ID Search

Parameters

Return Type

Error Message

Save

Remove

ORACLE

Script Type

All

Triggers

Validators

Triggers

Validators

Triggers

Object Functions

Global Functions

Object Functions

Global Functions

Validators

Triggers

All

All

Chapter 7
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Description
field_script type
or

object_script type

For example, the user-defined field Years
Experience would have the following default
validator script name: YearsExperience_c_
validator.

You can change the script name if needed.

To add multiple scripts of the current type,
select New from the drop-down list.

Add text to describe the purpose of the script.

Used only for triggers. Defines when the trigger
runs, such as during the Create event. See

the "Add Triggers" section below for more
information.

Provide the message that the system displays
the user to correct any issues. For example,

in the case of a validator script, the message
appears if the data entered for the field does
not pass the validation logic.

Use the Label field to search for the Field ID
value, which reflects the name under which the
field is stored in the database and how you'd
refer to it in your script.

Used only for object functions and global
functions. Enables you to define the parameters
the function will accept.

Used only for object functions and global
functions. Enables you to set the data type for
the return value of the function.

Provide the message that the system displays
the user to correct any issues. For example,

in the case of a validator script, the message
appears if the data entered for the field does
not pass the validation logic.

Saves the current code.

Removes the business logic from the associated
field or object.
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Page Element

Close

Script Type

All

Setting the Scope of a Groovy Script

The following table outlines the possible scope of a Groovy script.

Scope

Field

Object

Global

Description

You can add Groovy logic to act on a single
field. The code you add runs only against the
selected field.

You can add Groovy to fields in delivered
predefined field groups or to user-defined
fields you have added manually.

If your script involves more than one field, you
need to add that code at the object level. The
object refers to the current intake form you
are creating. For example, if you are creating a
fence permit, the logic you add for the current
object applies to fields in that fence permit
definition.

You can create global functions that can be
called by any field-level script or object-level
script in your offering.

Chapter 7
Creating Intake Forms

Description
This may be required in some cases prior to
removing the field from the intake form.

Closes the editor without first saving any
changes.

Note: While you can delete fields with Groovy logic associated with them, make sure the Groovy logic evaluates to
True prior to deleting the field, otherwise you risk making the entire transaction type invalid.

Note: When referencing a field for field level logic, use newValue and oldValue to reference the current field value. At
the object level, use the internal field name, such as YearsExperience_c. You can access the internal name of the field
a few ways. You can select the field, and click Add Logic, to see how the field is referenced in the Groovy Script Editor.
You can also review how the field is referenced in the JSON payload from a REST request, such as a describe request.

Where Set

Select the field to which you want to add
validation logic, and click Add Logic in the Field
Attributes panel for that field.

When in the designer with the intake form
open, click the Add Logic button at the top of
the form, next to the Preview button.

When in the designer with a intake form open,
click the Add Logic button in the header at
the top of the form. You can access the Global
Functions option only by opening the Groovy
Script Editor at the object level.

This example illustrates the Groovy Script Editor at the field level. Details are in the surrounding text.

ORACLE
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Groovy Script Editor

Validators
Script Name *
1 /* Field validator for field MaterialsCost_c Custom Object LNP1IDFencePermitl117 c. MaterialsCost ¢ validator v
This logic is global and will be active anytime this field is in an intake form. */
Description

Error Message

Field-Level Script Editor

Field ID Search
Label
04
Field ID
Save Remove Close

| Note: When you add logic at the field level, you can add Validator scripts only.

This example illustrates the Groovy Script Editor at the object level. Details are in the surrounding text.

Groovy Script Editor

Vahdators Triggers Object Functions Global Functions
Script Name *
1 /* Object Validator for Custom Object LNP1IDFencePermitl1l7 c */ LNP1IDFencePermit1117_c_valid... | ¥
Description

Error Message

Object-Level Script Editor

Field ID Search
Label

Labor Cost v
Field ID

LaborCost_c

Save Remove Close
When you add logic at the object level, you can add these types of scripts:

- Validators

Triggers
- Object Functions

- Global Functions
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Note: For scripts at the field level use newValue and oldValue to reference the current field. At the object level, use the
field name, such as NumberofRooms_c to reference fields.

Work With the Transaction Type Data Structure

Accessing data stored within the transaction type business object requires and understanding of the underlying data
structure. To understand the data structure, you need to become familiar with the JSON payload for a transaction intake
form.

Use your REST client utility such as cURL or Postman to access the REST endpoint for an intake form.

You can use a “describe” request to view the data structure of the intake form, using a GET operation. For example:

https://servername.fa.us2.oraclecloud.com/fscmRestApi/resources/11.13.18.05/LNP1lId<transaction_type> c/
describe

This example illustrates the parent-child relationship of the data within a transaction type.

Transaction Type Parent
{
"LnpRecordkey’
"LnpRecordid"”
"VersionType"

“UserDefineda”
“UserDefinedB”
“links":[

Transaction Type Children
{

FieldGroups
LnpGlobalCustom
RecordAuthorizedfgent
RecordCom ment
RecordContractorlicense
RecordParcel

RecordParce lAddressOwner

The describe results show you the metadata for the business object, such as the name, type, and so on, such as
LnpRecordKey, integer, and so on.

You can also submit a request to access data for a specific transaction by including the LnpRecordKey value to the
request. For example:
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https://servername.fa.us2.oraclecloud.com/fscmRestApi/resources/11.13.18.05/LNPlId<transaction_type> c/
<LnpRecordKey>

This example illustrates transaction type JSON returned in a REST client.

"LnpRecordKey™: 3808189185175848,

LT B R TTR R

"1 "Submitted”,
emStatus™: "SUB",
icant": 3@@189178576856,
g "ParsonPrelameAdjunct™: "MR.™,
18 "PersonFirstiam "

11 "PersonMiddleName":
12 "Personlasthame

13 "PersonlameSuffix™: null,
14 "PersonTitle"”
15 "DateCfBirth":

The top portion of the JSON reflects the parent object, and the sections within the “links” block are the child objects.
The parent object contains attributes from the transaction type, some general field groups, such as Application and
Applicant, and any user-defined fields you have added.

The majority of the fields in the field groups reside in a single object, the FieldGroups object (FieldGroupsVO). Reusable
fields reside in LnpGlobalCustom object (LnpGlobalCustomVO).

Note: Lnp refers to the Permits offering. Other offerings, such as Planning and Zoning or Business Licenses, use
other naming conventions, such as PnzGlobalCustomVO.

Knowing the object on which you are writing your logic is essential for achieving the desired scope of your results.
When you write logic at your transaction type level, as in custom Object LNPlFencePermit_c, that logic applies locally, only
for that transaction type. If you write logic at a child object level, as in custom object FieldGroupsvo, that logic is global
and would apply to any instance of that field group or field group field in any transaction type where it appears.

Note: Be very careful when writing logic globally to the FieldGroups child object. Logic that applies in one scenario,
may not apply to all. Logic at the FieldGroups level always fires even if a particular field in that object isn’t used in
the current transaction. If you write logic at the FieldGroups level, consider including code to check if the value(s) of
field(s) is not null prior to running a validation, for example.

When you open the Groovy Script Editor, comments at the top of the work area indicate where the logic you write will
apply. For example:

/* Object Validator for Custom Object LNPlFencePermit_c */

What element you have selected in the workspace and where you click the Add Logic button (in the header or in
the Field Attributes panel) determines where your logic applies, either locally to the current transaction type only, or
globally. The following table provides selected scenarios to illustrate how the comments at the top of the work area
indicate the scope of the logic for that script.

Workspace Selection Comment Logic Scope
1. Select a field in a child field group, such /* Field Validator for field The Logic applies to the Front Fence Height
as Front Fence Height in the Fence field FenHeightFront Custom Object field in the selected field group. This field is
group. FieldGroupsVO */ stored in the child Field Groups view object,
2. Click Add Logic in the Field Attributes where all other fields appearing in field groups
panel. are stored. Logic written at this level for this
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Workspace Selection Comment

1. Select a field in a child field group, such
as Front Fence Height in the Fence field
group.

2. Click Add Logic in the header.

/* Object Validator for Custom
Object FieldGroupsVO */

Field Validator for field
YearsExperience_c

1. Select a user-defined field (in this case
Years Experience).

2. Click Add Logic in the Field Attributes
panel.

1. Select a group box or page tab.
2. Click Add Logic in the header.

Object Function for Custom Object
LNPl1IDFencePermit c

Field Validator for field
ContractorName c Custom Object
LnpGlobalCustomVO

Reusable user-defined field selected.

2. C(lick Add Logic in the Field Attributes
panel.

Chapter 7
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Logic Scope

field will apply globally to all instances where
this field group is used.

The Logic applies to the Field Groups view
object, and logic applies globally to all instances
where this field group is used. Because the
logic is written at the object level it can apply to
multiple fields in the Field Groups view object.

Note:

Most field groups are considered child
objects with the fields being stored in the
Field Groups view object. Applicant and
Application are considered parent objects,
with their fields stored in the transaction type
parent object.

The logic applies to the user-defined field Years
Experience locally for that transaction type.

Note:

If the field is set to be reusable, then the logic
you add applies to all instances where that
field is used.

The logic applies locally to multiple fields to the
current transaction type.

The logic applies globally to that reusable in any
intake form where it is used.

When you are writing logic on a field or object at the child level, such as FieldGroups, you can reference the fields that

reside on that object directly. For example:

/* Object Validator for Custom Object FieldGroupsVO */

FenHeightFront < FenHeightRear

If you are writing logic that is local to your transaction type intake form, and you want to access values in a child object,
such as FieldGroups, for validations and comparisons, you can’t directly reference the field names in your logic. The
FieldGroups view object is a collection, so you need to parse the child record using the hasNext() method. For example:

/* Object Validator for Custom Object LNPlInfoDevResFence0Ol c */

// Identify and assign the object.
def vo = FieldGroups

while (vo.hasNext()) {
// Access the next row in the row iterator.
def currow = vo.next()
// Run validation.
currow.FenHeightFront < currow.FenHeightRear

ORACLE
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}

If you are writing logic that is local to your transaction type intake form, and you want to access values in a child object,
such as LnpGlobalCustom, for validations and comparisons, you need to write code similar to accessing FieldGroups,
but because LnpGlobalCustom isn’t a collection, you don’t need to use the hasNext() iteration method. For example:

First, instantiate the child object:
def vo = LnpGlobalCustom
Then use dot notation to access the desired field:

vo.EstimatedCost_c > 100

I Note: You can also use dot notation to access the field, such as LnpGlobalCustom.EstimatedCost_c.

Using the Field ID Search

When you reference a field in your script, you use the internal field ID, not the label that you see on the form design. For
fields stored in child objects, you also need to know the object name. The Field ID search feature enables you to find the
internal field name and object name.

1. Use the Label drop-down list to select or search for the label of the field as it appears in the form design.

Initially, the drop-down list contains only a subset of the fields stored in the transaction type parent object.
To search for additional fields, you need to enter partial search criteria to begin building a result list matching
possible fields.

2. Select the desired field label from the result list.

3. Use the value displayed for the Field ID in your script.

Fields stored on the transaction intake form object do not list an object, while fields stored in the field groups or
global custom object show the object and field in dot notation, as in ObjectName.FieldName.

The following examples illustrate that depending on where the field is stored, it may or may not include an
object name.

This example illustrates using field ID search on a user-defined field, showing just the field name.

Field ID Search
Label

Materials Cost v
Field ID

MaterialsCost_c

This example illustrates using field ID search on a field group field, showing the object and field.

Field ID Search
Label

Front Fence Height v
Field ID

FieldGroups.FenHeightFront
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This example illustrates using field ID search on a reusable field, showing the object and field.

Field 1D Search
Label

Total Project Cost v
Field ID

LnpGlobalCustom.TotalProjectCost_c

Preventing Logic Executing During a Save

Applicants have the option to save the intake form if they need to step away to gather more information, for example. If
you don’t want your logic to run until the applicant is completely finished and submitting the form, you need to account
for the Pending status in your logic. To enable applicants to save a form without being faced with a list of validation
errors, it is recommended to add the following code to the top of each of your scripts.

if (Status == "Pending") {

return true

}

Note: You can use similar constructs as needed within your logic as needed to allow the form to be saved without
running the business logic.

Add Validation Logic

A validator script provides data integrity for end user input. A validator script is a logical construct that returns either
true or false.

The essential components of a validator script include:
- Groovy logic
- Error message

For example, assume you have a form with the field Years Experience to indicate the number of years experience of a
solar panel installer. To meet permit criteria for your agency policy, you can validate that the applicant doesn’t enter zero
by adding the following validation script to the field.

newValue > 0

At runtime, if the field value entered does not meet your validation logic criteria during a save or submit request. The
validator script returns either true or false. If the return is false, the system displays the error message so the user can
resolve the issue.

This example illustrates the runtime message displayed by a Groovy validation script.

# Close Application

Solar Permit

A @ Correct the Following Errors and Try Again

* The value you enter to indicate years experience, must be greater than 0.
(Step 3: Solar Project ‘Information)
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Validator scripts can be run at the field level and at the object level. Field-level validation is for single-field validation,
and object-level validation involves validation of multiple fields. Use the object level when you reference multiple fields
in the validation, and use the field name, not newValue. For example:

TotalCosts_c <= EstimatedCosts_c

Note: The Groovy script executes only when the user either saves or submits the form. If there is any delivered
validation for a field contained within a delivered field group, that delivered validation runs before any Groovy
validation you have added. Before adding Groovy logic to a field delivered in a predefined field group, make sure to
test the field group at runtime to become familiar with any existing, internal validation.

Note: In the case of multiple field-level validations, each runs independently. If you have added object-level
validations also, the object-level validation runs only if all field-level validations have passed.

Add Triggers

Triggers enable you to invoke processing logic based on an event.

In addition to the common attributes, including Script Name, Description, and Error Message, you also set the Type.
Setting the type is how you define the event on which the trigger is based.

Type Description

Create Fires when a new instance of an object is created. Use to assign programmatic default values to one or
more fields in the object.

Note:
Create events run only when the intake form is saved the first time. It does not run on subsequent
saves or submits.

Invalidate Fires on a valid parent object when a child row is created, removed, or modified, or also when the first
persistent field is changed in an unmodified row.

Modify Fires when an attempt is made to modify an object. Returning false stops the row from being deleted
and displays the optional trigger error message.

Remove Fires when an attempt is made to delete an object. Returning false stops the row from being deleted
and displays the trigger error message.

Before Insert Fires before a new object is inserted into the database.
After Insert Fires after a new object is inserted into the database.
Before Update Fires before an existing object is modified in the database.
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Type

After Update

Before Delete

After Delete

Before Commit

After Commit

Before Rollback

After Rollback

After Transaction Posted

Add Functions

You can create functions at the object and the global level.

Level

Object

Global

Description

Note:

Chapter 7
Creating Intake Forms

If you want the trigger logic to run on each save and submit, not just on the initial Create event, use

the Before Update event.

Fires after an existing object is modified in the database.

Fires before an existing object is deleted from the database.

Fires after an existing object is deleted from the database.

Not supported.

Not supported.

Not supported.

Not supported.

Not supported.

Description

Object functions provide business logic to be used within the scope of the current business object,

which is the current transaction type, such as an intake form for a permit.

Global functions can be called from any intake form design within the offering.

The interface for creating functions is the same for creating object or global functions, and it contains the same general
options in the editor, such as Script Name, Description, and Error Message, plus the additional items listed below.

This example illustrates defining a function, parameters, and return type. Details are in the surrounding text.
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Groovy Script Editor

\Validators Triggers

Object Functions Global Functions

x

1 /* Global Function */
2

3nl + n2

Script Name
add2 v

Description

Page Element

Parameters

Return Type

You can apply these data types.

Data Type

Void

String

Integer

Boolean

Long

Biglnteger

ORACLE

Adds two field values.
Parameters

Name Type

ni nieger + w

né nieger + w

Return Type

nteger v

Save and Close Remove Close

Description

Define the parameters received by the function when it is called. Add the name of the parameter and
its data type. Refer to the following table for data type descriptions.

Click Add to include multiple parameters in the grid.

Click Delete to remove a row from the grid.

Define the data type of the value returned by the function. Refer to the following table for data type
descriptions.

Description

Applies only to return values. Use in situations when the function does not provide a return value to
the caller, such as when the functions performs a task, writes an output line, and so on.

A text value.

A whole number, either positive or negative.
Alogical true or false value.

An integer value in the range of +2%39,

An integer of arbitrary precision.
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Data Type Description
Double A floating-point decimal value in the range of £1.79769313486231570 x 10°08
Big Decimal A decimal number of arbitrary precision.
Date A date value with optional time component.
List An ordered collection of objects.
Map An unordered collection of name/value pairs.
Object An entire business object, which in this case refers to an instance of an intake form.

Once you create the function, you can call it from other scripts. For example:

/* Object Trigger for Custom Object LNPlSolarPermit c */
/* Define variables and explicitly cast the type (Integer).*/

def nl
def n2

(Integer) EquipmentCosts_c
(Integer) LaborCosts_c

/* Call the global function add2 to add total costs, passing in the variables.*/
TotalCosts_c = adf.util.add2(nl, n2)
For a function defined at the object level, you can call the function using just the function name, such as adq2.

For a function defined at the global level, you need to add as a prefix ad£.uti1. For example, if the global function name
is add2, you call the function using adf.util.add2 (paraml, param2).

In this example, there is global function named add2, which adds two parameters passed in. On the Triggers page, the
trigger script is set to run on the Create event type, and the values for EquipmentCosts_c and LaborCosts_c are passed
to the function to calculate the value of the TotalCosts_c field.

Note: When defining variables for number data types, explicitly cast the data type of the parameters you define. So, if
the field is an integer, explicitly specify (Integer), or if the field is a float number, specify (Double). For example: def n1
= (Integer) EquipmentCosts c

Example: Basic Calculations

You can use functions to calculate, but you can also use basic expressions, such as A + B, A - B, and so on. For example:

TotalCost_c = EquipmentCosts_c + LaborCosts_c

Example: Accessing User Security Context

To access information regarding the current user, instantiate the getSecurityContext() object. In this example, the script
checks if the user is assigned a particular role, and if not, displays the error message.

/*Get the security context.*/
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def secCtx = adf.context.getSecurityContext ()
/*Check if the user has the desired role.*/
if (secCtx.isUserInRole('PSC_ROLE NAME')) {

/*1f user has role, then check if field is not blank. If field is blank,
returns false, showing error message.*/

return newValue != null

}
/*If the user doesn't have the role, returns true, bypassing the error message.*/

return true

Example: Validating a Phone Number
To validate the format of a phone number, such as 111-222-3333, you can use a regular expression. For example:

newValue ==~ /~(\d{3}\-\d{3}-\d{4})/

Copying a Field Value to Another Field

To make a field reflect the value of another field (to copy it), you can use a trigger. For example, you may have a field
named Estimated Project Cost that will be reflected in the Final Cost field once the permit has been processed. To do
this:

1. Use the Triggers tab.
2. Enter this code:

FinalCost c = EstimateProjectCost c
3. Select Before Update from the Type drop-down list.
Working with Dates

When working with dates, switches and so on, and you are checking for null values, it is recommended to use the
following construct:

(!ExpirationDate_ c)
Instead of using something like:
(ExpirationDate ¢ == null || ExpirationDate c == "")

This can help to avoid script saving issues and unexpected validation results.

Adding Contextual Help to Forms

This topic describes how to add help text to various parts of your intake forms to aid public users when they are filling
out an application form.
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Working with Contextual Help

If you determine that the end user needs additional information to understand a user-interface element in your intake
form, you can add contextual help text to that user-interface element. If you add contextual help to a user-interface
element in your intake form design, the system displays a Help icon next to the label of that user-interface element.

You can see the Help icon in both the design and runtime mode. At runtime, end users click the Help icon to display
your help text in a popup, without leaving the page.

Note: At design time, the Help icon does not display the help text popup when clicked.

You can add contextual help text to these intake form elements:

Page tabs
Field groups
- Group boxes

Fields (applies to fields in field groups and to user-defined fields)

Note: For group boxes and field groups, you can add help only when the Show Label attribute is turned on.

You can't add contextual help text to these intake form elements:

Radio sets
- Check box sets
If you need to add help for radio sets or check box sets, use a group box to contain the control and add the help text to

the group box container.

Adding Contextual Help

To add contextual help:
1. Select the page element to which you want to add contextual help.

Note: You cannot add help text directly to radio sets and check box sets. Add help text to a group box
surrounding the radio sets or check box sets.

2. Click the Help button in the attributes panel.
3. On the Contextual Help Setup page, note the Type Code, Page Name, and Page Object values.

These values uniquely identify the page element to which you are associating the contextual help. You can’t
change these values. They are read-only and maintained by the application.

Item Value

Type Code An automatically generated value consisting of the internal product code and the permit
type code derived from the permit type definition.
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Item Value
Page Name The name of the page tab on which you are adding help. Regardless of what the page

label is on the tab, the application displays each tab using the default name in sequence,
such as tabs1, tabs2, and so on.

For example, the second page tab in an intake form may have the name Fence
Information, however in the Page Name field it will appear as tabs2.

Page Object Identifies the page element for which you are adding help. Regardless of the page
element’s label, the application displays the internal naming convention as the field
value, which is the page element type code + sequence added.

For example, for the second field added to the form the field value is fields2, which
indicates the element is a field and it is the second field added to the form.

The page element type codes are:

o Field groups: ccas
o Group boxes: widgets

o Fields in field groups: <field group>_<internal field name> (such as ccas2_
ReleaseDate)

o User-defined fields: fields

4. Inthe Description field, add text to describe the purpose of the help text so other implementation team
members can understand the content.

5. Click the Add New button in the Contextual Help Details grid to display the Add Context Help Details dialog
box.

The Type drop-down list will show Agency Defined.

Note: Help topics of type System Defined are provided by Oracle and should not be altered or removed.
Use the Agency Defined help topic type to add help topics specific to your implementation. If you want your
custom help text to display instead of delivered help text, disable the System Defined help topic, create your
custom topic, and enable it.

6. Activate the Help Content edit box by clicking to the right of the Help Content field label.
7. Inthe Help Content edit box, enter your help text.

The system provides rich-text editing features, which enables you to implement limited formatting options, as
needed.

8. When you've added the content, and you are ready for it to be viewed by end users, turn on the Enabled switch.

Note: To prevent the help content from displaying at run time, turn off the Enabled switch.

9. Click Save on the Contextual Help Details page.
10. Click Save on the Contextual Help page.
11. Confirm that the help icon appears on the page tab or next to the page control label in your intake form design.

For more information on contextual help, see Setting Up Contextual Help.
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Reorder Intake Form Elements

This topic describes how you can move form elements, such as pages, field groups, group boxes, and user-defined
fields to different locations within the form design.

As you build intake form designs, you may need to move form elements from one location to another for a variety of
reasons, such as improved logical grouping, control display requirements, end-user feedback, and so on. You use the
Reorder Intake Form modal page to move form elements and reorder the intake form design.

Note: For Code Enforcement intake forms, you can reorder the elements within the drop zone only.

This example illustrates the Reorder Intake Form page. Details are in the surrounding text.

Reorder Intake Form

o Information x

Reordering elements may cause the context of that element to change. Review and confirm help text and
business logic messages after the reorder is finished.

4 EAppI ication Information

EAppIication

4 Ef—\pplicam Information
EAppIicant

4 EDecIarations

» Elndicate Who is Doing the Work
» EHom eowner Declarations Work Area
4 EContractcr Declarations

ELicense Number

HI am licensed

4 ECG ntractor Information

EContractcr

4 ECost Estimates

» ECosts

4 E Project Details

EPhot{:voltaic o

Collapse Layout Cancel Save and Reload

Note: The label of the element appears as it is defined in the form design. Any label that is set to be hidden, such as
the label for a field group or group box, will appear in the element tree.
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Page Elements

Work Area

Collapse Layout

Expand Layout

Cancel

Save and Reload

Description

The work area is where you view the current structure and order of your intake form in the element tree
and perform any required reordering tasks. The work area displays each page tab, field group, group
box, and user-defined field in the form design as a node within a hierarchical element tree.

Collapses element tree view to display only the highest-level node in the hierarchy, the page tabs.

Expands the element tree to display more detail in the hierarchy, exposing field groups, group boxes,
and user-defined fields (if the their group box container was previously expanded). The Expand
Layout button appears only after the element tree has been collapsed.

Note:
By default, user-defined fields are hidden to simplify the initial display. You need to manually
expand the group box node that contains them.

Closes the window and does not save any changes made.

Saves the changes you have made to the order and reloads the form design to display the new order.

You can identify the element nodes in the hierarchical tree using this key.

Page Element

B 0oOA

Description

Indicates a page tab.

Indicates a field group.

Indicates a group box.

Indicates a user-defined field.

Note:
The individual fields contained in a field group are not displayed.

Moving Elements Using Drag and Drop

1. Left-click and hold to select the element you want move.
2. Drag the selected element to the desired location, using the drop indicator as a guide.

The drop indicator shows you whether you are dropping an element before, within, or after another element.

ORACLE
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This example illustrates dragging and dropping form elements in the element tree. Details are in the

surrounding text.

4 ECD ntractor Declarations

Lam licensed .
[%_icense Numuoer :%3
am licensad

3. Release the left mouse button to drop the element in the indicated position.

Moving Elements Using Cut and Paste

1. Cut the element you want to move by selecting it and:

o Pressing Ctrl + X.

o Right-clicking and selecting Cut from the pop-up actions menu.

2. Paste the element to the desired location by selecting the new location and:

o Pressing Ctrl + V and selecting the appropriate action from the pop-up menu.

o Right-clicking and selecting the appropriate action from the pop-up menu.

Menu ltem

Cut

Paste Before

Paste After

Paste Inside

Paste First

Description

Cuts the selected item to the clipboard.

Pastes a cut item before the currently selected element.

Pastes a cut item after the currently selected element.

Pastes a cut item inside the currently selected element, such as a page tab or group box.

Pastes a cut item as the first item within the currently selected container, such as page tab or a group
box.

Moving Elements Using the Keyboard

You can use these keyboard shortcuts when reordering form elements.

Shortcut

Tab

Shift + Tab

Up and Down Arrows

ORACLE

Description

Use to arrive at the first focusable element in the work area, which is the first page element node, and
then to each button in the order they appear.

Use to go the reverse direction of Tab.

Use to move up and down the:
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Shortcut Description

- Element tree

- Popup actions menu

Right Arrow Use to expand an element node to reveal the elements it contains. For example, use Right Arrow to
show the user-defined fields contained within a group box.

Left Arrow Use to collapse an element node.

Shift + F10 Use to display the pop-up menu displaying available actions.

Esc Use to close the actions pop-up menu.

Enter Use to select an item on the actions pop-up menu.

Ctrl + X Cuts the selected element.

Ctrl +V Displays the actions pop-up menu after an element has been cut, enabling you to select a paste option.

Reordering Page Element Considerations

The designer does not allow you to move form elements into invalid positions within the hierarchy, and the same rules
applied when creating the initial form design apply also when reordering the form design. The following table outlines
the rules governing each form element and any items you may need to consider when reordering elements in a form
design.

Form Element Reordering Rules and Considerations
Page tabs Page tabs can’t be dropped into another element. They can only be reordered within the element tree.
Field groups You can:

- Drop into another page tab
- Drop into a group box
- Reorder position within its container

You can't:

- Drop into another field group
- Drop outside of a page tab or group box
- Drop on a user-defined field

- View or move fields contained by field groups

Group boxes You can:

- Drop into another group box
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Form Element Reordering Rules and Considerations
- Dropinto a page tab
Note:
By default, a dropped group box is added as the last element on the containing page or group box.
You can't:

- Drop into a field group or a user-defined field

- Drop outside of a page tab

User-defined fields You can:

- Drop into group boxes only

- Move location within a group box

The following table describes various conditions to consider when reordering form elements.

Condition Description

Security You can'’t drop an element into a page tab or group box that has security settings applied, such as the
Hide from public user or the Confidential attribute enabled.

Note:
The Confidential attribute applies only to the Business License offering. Elements set to contain
confidential information for the Business License offering can’t be reordered.

Control Display A controlled element can’t appear before its controlling element in the form design order. For example,
if a group box’s display is controlled by a single-item check box, you can’t move that group box to a
position above that single-item check box.

Add Logic (Groovy) Groovy logic executes when the form is being submitted, so the order of the form design does not
affect the logic. However, it is recommended that you review the error messages displayed by your
Groovy scripts to make sure the context is still valid after reordering.

Add Help The display of help text does not depend on the order of the form design. However, it is recommended
to review any help you have added to form elements to make sure the context is still valid after
reordering.

Configuring Activity Filtering for Business Licenses

This topic describes how to configure display filtering for business license intake forms so that only applicable form
elements appear in the intake form for the current business license activity.
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Activity Filtering Overview

A business license can be involved in different activities, including:

- Origination: the initial application to be approved to establish and originate the business license.
- Amendment: the license holder makes changes to a submitted application or an existing business license.

- Renewal: the license holder renews the existing license for the next license period.

When creating a business license type, you have the options of enabling the license for renewal and amendment activity
by turning on the Allow Amendment and Allow Renewal switches.

Note: License activity filtering does not apply to intake forms for business license consultations, which are separate
intake form types.

Depending on the activity, it may not be necessary to view and edit all of the information contained in the business
license. However, it would be inefficient to design a separate form for each license activity. Use license activity filtering
so that you can create a single intake form that can be used for all the business license activities.

For example, using license activity filtering you can set some form elements to display only for license origination, or
only for amendments, while others can be set to display for all business license activity.

You can apply license activity filtering to:

- Field groups

- Group boxes

Setting Filtering Display Options

To view the license activity display options:

1. Select the form element.
Expand the Display section in the Attributes panel.

This example illustrates the license activity filtering options. Details are in the surrounding text.

A Display
"

License Activity

v @ Crigination

o Amendment

@ Renewal
Page Element Description
Origination The element is available for origination activity.
Amendment The element is available for amendment activity.
Renewal The element is available for renewal activity.
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Page Element Description

3. Select at least one license activity for the element.

Note: You can select any combination of license activities, but at least one license activity filtering option
must be selected for a field group or group box being added to a business license intake form design.

4. Save your changes.

Viewing the Runtime Display

This table illustrates how the selected license activity filtering options behave at runtime.

Origination Amendment Renewal Behavior
Selected Not Selected Not Selected Form element displays and is
editable only for the origination
activity.
Note:

An element set to display for
only origination will display in
both amendment and renewal

as read-only.

Selected Selected Not Selected Form element displays for the
origination and the amendment
activities.

Selected Selected Selected Form element displays for the

origination, amendment, and the
renewal activities.

Setting Form Options

This topic describes the options you can set for the entire form to control the ways public users interact with the form.

Enabling the Review Page

The review page presents all the fields of a multi-tab form on a single, scrollable page for efficient review of the entered
data prior to submitting the form.
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By default, the review page displays:
Form fields as read-only, but the end user can click the Edit button for each field group to modify the fields as
needed.
- All field groups expanded.
For multi-page view or single-page view.

For all forms, unless disabled.

To disable the review page:

1. Inthe Intake Form Designer, click the Form Options link.
2. Onthe Form Options dialog box, turn off Review Page.
3. Click OK.

4. Click Save.

Setting a Confirmation Step

You can enable one of the pages in a form as a confirmation page to display after the end user has filled in the
information and submitted the form. You create the confirmation step in the designer and then set it to be the
confirmation step in the Form Options.

When set as the Confirmation Step, the page displays:

- At design time with the page tab filled in grey to indicate it is the confirmation step.

- At runtime as the last page in the train stop drop-down list.

Note: The confirmation step does not display as part of the single page view.

To enable the review page:

In the designer, click the Form Options link.

On the Form Options dialog box, select the desired page from the Confirmation Step drop-down list.
Click OK.

Click Save.

P WNa

Mapping Form Fields to Decision Model Attributes

This topic describes how the fields added to an intake form in the designer are mapped to the fee model defined for the
transaction type.

The Fee Mapping page in the designer is used to map attributes in the decision model to the fields added to the intake
form. The Fee Mapping page is the second step in the Intake Form Designer, where designing the layout is the first step.

This image illustrates the Fee Mapping page in the design of a permit application.
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DESIg n Pel’mit Apphcatlon Reorder Add Logic Preview Save Manage Sandbox
PaymentFeeSch | Status: published < Previous
Fee Mapping

ate  9/20/19 v

4 Permit Fees/PlumbingMechanical/1.0/PlumbingMechanical
Applies to Type

Model Attribute Attribute Type Transaction Attribute
GasPiping boolean Select a record type attribute A

PlumbingFixtures boolean Select a record type attribute A

ConstructionType string Plumbing
4 Permit Fees/PermitApplicationFees/1.0/PermitApplication Sewage Connection
Applies to Type Sewer Tap Commercial
Back-flow Device
Model Attribute Attribute Type Transaction At painwater Drain

ProjectValue number Job Cost Drainage Repair

You assign a fee schedule to an application type on the Transaction Type page using the Fee Schedule field. You map
attributes from the fee schedule’s underlying decision model created in Oracle Integration Cloud to the fields you have
added to your intake form either through delivered field groups or by adding fields manually.

Note: Not all model attributes need to be mapped. Because a fee schedule can be reused by multiple transaction
types, only the model attributes required for fee calculations for the current application type need to be mapped. All
other model attributes can be left blank.

For more information on setting up fee schedules, see Setting Up Fee Schedules.

For more information on decision models, see Creating Decision Models for Fees.

Mapping Application Fields to the Fee Item in the Decision Model

To access the Fee Mapping page in the form designer:

1. Navigate to the Transaction Type page:

o Business License Setup > Business License Type
o Permit Setup > Permit Type
o Planning and Zoning Setup > Planning Application Type

Select the transaction type that you want to view in the designer.
Click the Design Form button.

Click the Next button while in the application form setup step.
The fields on the Fee Mapping page are as follows:

v A WN

Page Elements Description

Effective Start Date and Effective = The effective-dated entry for the fee schedule associated with the transaction type. If
End Date multiple effective dates exist, you must map fee items for each effective date.
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Page Elements Description
Applies to Type The type of application that the fee item applies to as defined in the fee schedule:

o Origination - Original applications. This is the default value.
o Amendment - Applications for amendments to business licenses.

o Renewal - Business license renewal applications.

Model Attribute The name of the attribute as it appears in the decision model in Oracle Autonomous
Integration Cloud.

Not all model attributes must be mapped. Because fee schedules can be reused by
multiple transaction types, only the model attributes required for fee calculations for the
current transaction type need to be mapped. All other model attributes can be left blank.

Attribute Type The data type of the model attribute, such as string, number, boolean, and so on.

Record Type Attribute The field added to the intake form layout either contained in a predefined form element
or a user-defined element you have added manually.

6. Select the record type attribute from the drop-down list that you want to map to the decision model attribute.
7. Click Save.

Considering User Experience

This topic describes concepts related to using forms that implementation teams need to consider when designing
forms.

Required Fields

The system validates that required fields contain values prior to a submit request.
If a required field is empty the system displays the following error message on the page.

This example illustrates how the system displays messages to indicate what is required for a field.

']

| at least 3 alphanumeric characters

€ Value is required.
You must enter a value.
The system displays an itemized list at the top of the form when clicking Submit so that in the case of multiple pages,

the user can navigate quickly to the item and provide an acceptable value. The error message lists the error and the
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location to which the end user must navigate to correct the error. The list if errors can be expanded and collapsed as
needed.

This example illustrates an error message appearing at the top of the form, displaying in the list the error, and the
location of the offending field.

4 O Correct the Following Errors and Try Again

* You must select an applicant.
(Step 1: Applicant)

Runtime Application Form Save Behavior

You can save an intake form as a draft prior to submitting it. You may need to save an intake form as a draft for a variety
of reasons, such as needing to gather additional information or the form requiring more time than anticipated. After
saving the form, the user can return to it to provide more information and ultimately submit the form.

Note: Saving a form is not currently an option for the Code Enforcement offering.

When saving a form as a draft, not all of the data validation occurs. However, the user will need to resolve any critical
errors that the application can’t save, such as adding a value with an incompatible data type. For example, the system
can’t save an alphabetic character entered into a field of a number data type.

The complete data validation process and logic runs for user-defined fields and field groups when the form is
submitted.

When users take advantage of saving forms, consider these items:

Consideration Description

Save - Validates user-defined fields.
- lgnores empty required fields.

- Validates field groups fields.

Submit - Validates user-defined fields.
- Flags empty required fields.
- Validates field groups fields.

Groovy To compensate for the ability to bypass Groovy validation during a save, incorporate the "pending"
status in your logic. An intake form is in "pending" status when it has been saved but not submitted.
For example, add the following to the top of applicable Groovy scripts:

if (Status == "Pending") {

return true

}

Upgrade Intake forms from previous releases with fields set as required need to be updated to include the
validation adjustments associated with the ability to ignore required fields during a save.

1. Open the intake form.
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Consideration Description
2. Locate all the fields set as required, and turn off the Required switch.
3. Save and publish the form.
4. Locate all the fields that need to be set as required, and turn on the Required switch.
5. Save and publish the form.

Runtime Train Stop Drop-Down Behavior

The train stop drop-down list, appears in the center of the application form header to provide:

Feature Description

Context The system automatically prepends the appropriate step number to the application form page name.
The step numbers are assigned in the order the pages appear in the designer (from left-to-right).

For example, assume you have three pages in your form: Application Details, Fence Details, Property
Details. The train-stop drop-down list displays the pages as:

- Step 1: Applicant Details
. Step 2: Fence Details
- Step 3: Property Details

Current Page To show the current page the user is viewing, the system displays a single, right-pointing, chevron
character (>) to the left of page label in the drop-down list.

Navigation Select any page in the application form, including the review page, to access it immediately.
Switch to Single/Multi-page view Toggle between the multi-page view or the single-page view.
Using the Single-Page View

When accessing the single-page view in review or advanced-edit mode, end users will notice these characteristics of the
page elements.

Page Element Behavior

Edit button Enables the end user to activate the form fields for editing. Initially, the system displays them in read-
only mode. Once clicked, the system toggles the Edit button to the Done button.

Done button Once the end user completes any changes, clicking Done:
1. Performs any configured data validation.
2. Saves changes to the database.
3. Returns the form fields to read-only.
4. Toggles the button back to read Edit.
Group boxes If a group box contains multiple group boxes, only the outer (parent) group box displays an Edit/Done
button.
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Page Element Behavior
Field groups If there are multiple field groups in a group box, they will appear to be a single page section, with one

Edit/Done button controlling all the field groups within the parent group box.
Otherwise, if the field groups are on the page tab separately (not within the same parent group box

container), then the system displays an Edit/Done button for each field group.

Expand All/Collapse All Expands or collapses all the elements on the page, including group boxes and field groups within
parent group boxes.

Note: The Edit button and the Done button do not appear on a page rendered in advanced edit mode if the form is
displayed in a read-only context. For example, if the user viewing the form does not have sufficient privileges or if the
user has already submitted the form, the fields in the form will be disabled and the Edit button and Done button will
not be rendered on the page.

Advanced-Edit Mode

If needed, agency staff members can update a form after a public user has submitted the form. Agency staff members
access the submitted form using the Permit Details page in the Permit List or by deep linking. Editing a form after a
public user has submitted it is referred to as advanced-edit mode.

When in advanced-edit mode, the system:

- Displays only the field groups enabled for advanced-edit mode.

- Presents the form in the single-page view.

Agency staff members click the Edit button to activate fields and update data, and they click Done to save changes.

Note: Customers cannot configure whether a delivered field group appears in advanced-edit mode. Field groups
enabled for advanced-edit mode are controlled and delivered by Oracle development. Only the field groups that are
appropriate for agency staff members to update are enabled for advanced-edit mode.

Testing Intake Forms

This topic describes the methods and considerations involved with testing your application intake forms.

You design, create, and test application forms on your development or test environment. Depending on what you have
licensed, you may have a combined development and test environment, or you may have a separate development and
test environment.

You can test forms in these modes:

- Preview mode

- Sandbox mode
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Once your forms have been created and thoroughly tested, you then migrate the newly created forms to your
production system for public user access.

Testing Forms in Preview Mode

You can perform initial testing using the Intake Form Designer preview mode.

To enter preview, click the Preview button. In preview mode, you can test the layout of the user interface and the tab
flow in a simulated runtime scenario.

While the preview mode provides you an accurate view of how your intake form will appear in runtime mode, it does
not enable you to enter data and save it. It can be used to get a quick, high-level view of the appearance of your form
layout. To test the full functionality and data validation of your intake form, you need to access and test the form from
the landing page in either sandbox mode or published mode.

I Note: The Intake Form Designer does not activate the Save button in preview mode.

Enabling Sandbox Mode Testing
You can test your intake form thoroughly in scenarios public users will encounter while the form design is still in the
draft state within the sandbox. Testing in sandbox mode enables you to fully test and interact with the intake form
without having to publish it. For example, you can:
- Access the intake form from the landing page in the same way public users will.
Run any data validations or business logic while filling out the form.
Engage OIC definitions associated with the intake form, such as workflow and fee models.

- Test the other processes involved in the entire lifecycle of the permit, such as approvals, inspections, and so on.

To enable sandbox mode testing:

1. Save your intake form.

2. Return to the Transaction Type page for your offering, such as the Permit Type page.

3. Open the transaction type associated with the intake form you want to test.

4. Set Status to Ready.

5. Set the Public User Enabled to either Enabled for all users or Enabled for registered users.

6. Specify any other required definitions related to the intake form, such as workflow process definitions, fee

schedules, and so on.

Note: You need to update your workflow definitions to allow access from a transaction type within a
sandbox. The workflow process definitions need an additional integration implemented called the Sandbox
Connector. For more information on updating workflow definitions for sandbox testing, see Setting Up the
Sandbox Connector.

7. Click Save.

8. Configure security for user IDs you intend to use for sandbox testing.

When testing in sandbox mode, the user IDs you use to access the landing page and the intake forms require
additional security roles.

191
ORACLE


http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_SettingUpTheSandboxConnector
http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_SettingUpTheSandboxConnector

Oracle Public Sector Compliance and Regulation Cloud Chapter 7

Implementing Compliance and Regulation Creating Intake Forms
Role Access Description
PSC Custom Sandbox Access This role gets created automatically during implementation, and it enables access to
(CUSTOM_SANDBOX_ACCESS) definitions that exist within a sandbox. User IDs without this role can access published

transaction types only.

This role should be used only in non-production environments, such as the
development or the test environment.

To implement this role, add this role to any user you intend to use to test intake forms in
sandbox mode.

To configure a sandbox test user, create an agency user and use the Agency Staff
Access page to add:

o Allroles typically applied to the simulated user type.

o PSC Custom Sandbox Access role.

Note: The data you enter and save during testing on your development and/or testing environments remains in the
underlying database tables after the form is migrated to the production system.

Configuring Security for Sandbox Mode Testing

When testing in sandbox mode, the user IDs you use to access the landing page and the intake forms require additional
security roles.

Role Access Description

PSC Custom Sandbox Access (CUSTOM_ This role gets created during implementation.
SANDBOX_ACCESS)
Enables access to definitions that exist within a sandbox only.

This role should be used only in non-production environments, such as the development or the test
environment.

To implement this role, add this role to any user you intend to use to test intake forms in sandbox
mode.

To create a sandbox test user:

1. Create an agency user.
2. Use the Agency Staff Access page to add to the user:

o Allroles typically applied to the simulated user type.

o PSC Custom Sandbox Access role.
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Migrating Application Forms Between Environments

After you have completed your testing of the application form on the development or the test environment, you can
publish the intake form. To migrate an intake form from the current environment to another environment, the intake
form must be published.

Note: Intake forms in draft status are ignored by the migration process.

To migrate data from a source environment to a target environment, follow the procedure in Functional Setup Manager
for migrating transaction type metadata and intake form layout metadata.

For more information on migrating definitions between environments, see Managing Transaction Type Configurations.

Publishing Intake Forms

This topic describes the steps to complete to publish intake forms.
You need to publish intake forms in order to:

- Clone intake forms and transaction types.

- Migrate intake forms from a source environment to a target environment, such as when migrating from the test
environment to the production environment.

Before you publish an intake form, it is highly recommended that you ensure it is thoroughly tested in sandbox mode.

For more information on testing options, see Testing Intake Forms.

Note: Intake forms in draft status can’t be cloned or migrated.

To publish a form:

1. Confirm that you have saved and tested all changes made to your form.
2. Inthe Intake Form Designer, click Publish.
3. Navigate to the Transaction Type page:

To navigate to the Transaction Type page for the offering, such as the Permit Type page for Permits.
4. Onthe Transaction Type page, open the appropriate transaction type, and set these values:

o Transaction Type Status: Ready
o Public User Enabled: Enabled for all users or Enabled for registered users.

o Specify any related definitions required for your transaction type, such as workflow process definitions,
fee schedules, and so on.
5. Click Save.

Note: After publishing a transaction type application, the application may not be accessible immediately. It can take
several minutes to apply the most recent changes and transfer the application from the sandbox to the live runtime
system.

193
ORACLE


http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=task_ManagingTransactionTypeConfigurations
http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=concept_TestingIntakeForms

Oracle Public Sector Compliance and Regulation Cloud Chapter 7
Implementing Compliance and Regulation Creating Intake Forms

Related Topics
« Setting Up Permit Types

- Setting Up Business License Types
- Setting Up Issue Types
- Setting Up Planning Application Types

Cloning Transaction Type Definitions

This topic describes how to clone transaction type definitions and the associated form design. It also covers the
attributes that will be shared between the source and clone definition and the attributes you will need to modify on the
cloned definition.

You can clone a transaction type to:

- Save time when creating a similar transaction type, rather than creating a new transaction type for each
situation from scratch.

- Create a new version of a currently published transaction type after making a significant correction or addition
to the transaction definition.

In some cases, it may be more efficient to create a new transaction type and form, while in other cases, it may be more
efficient to clone an existing transaction type and form.

When you clone a transaction type, you make a cloned copy of:

- Most of the transaction type metadata, such as the specified Classification, Auto Number Rule, Department,
Fee Schedule, and so on. Some of the metadata is not cloned, such as Transaction Type, Transaction Type
Code, Transaction Type Status, Help Text and so on, as you'll need to modify those values for the cloned copy.

- All of the intake form layout in the Intake Form Designer, including pages, group boxes, field groups, and user-
defined fields you have added to your application form.

When deciding to clone a transaction type, you may consider:
- The number of fields and pages within the existing application form layout that you'd need to change.
- Similarity between the existing transaction type and new transaction type.
- Number of shared attributes.

Note: In general, if you intend to make numerous modifications to the cloned copy, it may be more efficient to start a
new transaction type from scratch.

When cloning to make a new transaction type, you will want to make sure you are aware of:

- The attributes that will be shared between the source definition and the clone.

- The attributes you need to modify to create unique values between the source definition and the clone.

Note: All modifications you make to a should be done in your test environment and not on your production
environment. After you have thoroughly tested your changes in the test environment, your modifications should be
migrated using the Functional Setup Manager task flows.
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Transaction Type Metadata Considerations

All of the field values on the Transaction Type page will appear in the cloned transaction type, except for selected field

values listed in the following table.

Make sure to update any of the copied information on the Transaction Type page to reflect the requirements of the new
transaction type. For example, if the Department, Fee Schedule, or Workflow information, should be different, make
sure to update it for the new transaction type definition so it is associated with the correct items.

Page Element

Type

Type Code

Status

Valid From Date

Valid To Date

Public User Enabled

Description

The type name doesn’t have to be unique. You can create a new transaction type by using a unique
value or enter the same value as the source transaction type, if you are creating a new transaction
definition with the same transaction type.

The type code must be unique. Enter a transaction type code that identifies this version of the
transaction type definition.

Initially, for a newly created transaction type the status on the Transaction Type page is always set to
Preliminary.

The application inserts the current date for the cloned transaction type.

Update to reflect your business requirements.

Initially, for a newly created transaction type this is always set to Not enabled for public users.

For more information on the fields on the Transaction Type page, see Setting Up Permit Types.

Intake Form Layout Attribute Considerations

The following table describes specific considerations for Ul elements in your form layout with respect to cloning
transaction types and what gets copied from the initial source intake form to the target clone.

Element

Field groups

Labels

User-defined fields

ORACLE

Description

The cloned copy of the transaction type contains the same layout as the source definition.
If the intake form utilized any of the delivered field groups, the application copies the field groups into
the cloned copy of the definition, using the same layout as the source definition. For example, if you

added the Fence field group to the source permit definition to the second page tab, the Fence field
group would appear in the cloned copy of the transaction type on the same page tab.

The labels for fields and Ul elements, such as pages, group boxes, field groups, and so on, are the same
between the source and cloned definition.

Any fields you have added manually to the source will be copied, as is, to the cloned definition.

For any fields that you have defined a list of values, make sure it applies to your new transaction type.
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Element Description
Security The cloned definition will have the same security configuration as the source definition for:

- Data security for column authorization and data redaction.

- Cases where Hide from public user has been implemented.

Help If any help has been added to the form for a page, field group, group box, or field, for the source
definition, the application does not copy help references into the cloned definition.

Note:
You can remove the help references from the cloned form, but do not delete the help text from the
Contextual Help page if other forms are still using that help text.

Groovy scripts If any Groovy logic has been added to the source intake form, the cloning process does not copy the
Groovy logic into the target clone definition.

Fees Any fee mapping, which is defined in the second step of the Intake Form Designer, is copied to the
target clone definition.

Cloning a Transaction Type to Create a New Transaction Type

When you clone a transaction type, you also clone the associated form design. You can clone just the transaction type
definition without cloning the application form design; however, you can’t clone just the form design by itself.

Note: When you clone a transaction type, the type status defaults to Preliminary on the new transaction type, and the
status of the new application form defaults to Draft in the Intake Form Designer.

This example illustrates the Clone Permit Type page, which is described in the steps for cloning a permit type.
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Clone Permit Type

Original Permit Type Solar Permit

Original Permit Type Code LLSolar0918a

* New Permit Type

* Mew Permit Type Code

Use Original Workflow Setup o
Clone Form Design C

To clone a permit transaction type:

-—

. Select Permit Setup > Permit Type.
2. Open the desired transaction type.

Note: Only transaction types with a status of Published can be cloned.

3. Click the Clone button.
4. On the Clone Type page, enter the following values:

Page Element Description

New Transaction Type Enter a transaction type name.

The transaction type name can be the same as an existing transaction type name

so that you can have different versions of the same transaction type. For example,

if the original transaction type name is Fences, you can reuse the name for the new
transaction type definition, but you must enter a unique type code to distinguish the

two.

New Transaction Type Code Enter a unique transaction type code.

Oracle recommends manually adding a version number to the source transaction type
code if you want different versions of the same transaction type definition. For example,
if the original type code is Solar-0017, you can enter a new code, Solar-007-v2

Use Original Workflow Setup Turn on the switch to use the original workflow setup as defined in the original
transaction type. Turn off the switch to leave the workflow setup fields blank on the new
transaction type. You must enter a workflow setup values.

ORACLE
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Page Element Description
Clone Form Design Turn on the switch on to clone the application form design associated with the original

transaction type. Turn off the switch to create a completely new application form using
the Intake Form Designer.

I Note: Providing a unique type code is required to make the transaction type definition unique.

5. Click the Create button.
The cloning process opens the cloned copy of the transaction type.

I Note: When saving the cloned definition, the application places the cloned definition within a sandbox.

6. Make any other required changes to the cloned transaction type definition and form design.
See the previous sections for more information regarding what items to check.
Note: If there are numerous custom fields in the application form, when you have the layout open in Intake
Form Designer, it can take several minutes to perform the initial save. While saving, the application is creating
all of the custom fields, creating the other elements, and running validation.

7. Publish the application form in the Intake Form Designer.
For more information on publishing a transaction type, see Publishing Intake Forms.
8. Return to the Transaction Type page to change the status to Ready for Use.

Considerations for Creating a New Version of a Transaction Type Using
Cloning

In some cases, you may want create a new version of an existing, published transaction type to correct an error or make
a change.

If the change made is insignificant, as in it does not change the meaning of a field or page element, then in most cases
cloning is not required, and you can simply make the change directly to the transaction type definition. For example,
assume you have a field for an email address on your form, and it had been requested to change the label from E-mail
to Email (removing the hyphen). In this case, the change can be made directly to the form and republishing it.

However, in other situations, the change may be significant, in that it affects reporting associated with transaction type,
alters historical data, makes future data out of sync with historical data, and so on.

Significant changes where cloning a transaction type is recommended include:

Transaction Type Element Examples of Significant Changes

Field groups - Changing the label of a field group.
Adding
Removing

Updating the security (Hide from public user)
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Transaction Type Element Examples of Significant Changes

Changing the label, hidden, or required setting of a field within a field group.

User-defined form elements - Adding
Removing
Setting to required
Updating a default value

Updating the security (Hide from public user)

HTML Ul constructs - Adding page tabs
Removing page tabs
- Adding group boxes

Removing group boxes

Creating a New Version of a Transaction Type Using Cloning

Creating a new version of a transaction type using the cloning feature involves:

- Deactivating the published version of the transaction type.
- Cloning the published version of the transaction type.

- Activating the cloned copy of the transaction type.

To deactivate a published transaction type:

1. Select Permit Setup > Permit Type.

2. Open the definition for the published transaction type.
3. Setthe Transaction Type Status field to Void.

4. Click Save.

To clone the published transaction type:

1. With the transaction still open from the previous steps, click Clone.
2. Enter the same Transaction Type value as used for the recently deactivated transaction type.
3. Enter a unique Transaction Type Code.

Note: Providing a unique transaction type code makes the transaction type definition unique. To keep track
of versions, you can add v2, v3, v4 to the code, for example.

4. Save the cloned definition.
I Note: When saving the cloned definition, the application places the cloned definition within a sandbox.
5. Make any other required changes to the cloned definition transaction type and form design.

See the previous sections for more information regarding what items to check.
6. Click Publish in the Intake Form Designer to publish the cloned definition.

For more information on publish a transaction type, see Publishing Intake Forms.
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To activate the new transaction type:

1. Select Permit Setup > Permit Type or press Back from the Intake Form Designer interface.
2. Open the definition for the published transaction type.
3. On the Transaction Type page, set these values:

o Transaction Type Status: Ready for Use.
o Public User Enabled: Enabled for all users or Enabled for registered users.
4. C(Click Save.

Impact of Updating Existing Transaction Types and Republishing

This table describes the impact of various changes when you update and republish a transaction type.

Modification Impact

Update a label for a user-defined field - Submitted transactions: applies to all submitted transactions.
- New transactions: available on all new transaction intake forms.
- Auditing: No impact. Labels don’t appear in auditing; the audit goes against the field IDs.

- Reporting:
o OTBI: no impact to OTBI, which doesn’t incorporate fields.

o CSA: New label will not appear in CSA. Manual update of the label in CSA and republish. Once
done this applies to all transactions, old and new.

o BIP:if BIP depends on CSA, then the BIP report template needs to have the new label manually
updated.

Add a new user-defined field - Submitted transactions: the field will appear on all submitted transactions, which means if an
update is required for a submitted transaction this field will also appear on the page and be part
of the payload.

- New transactions: the field appears on all new transactions.
- Auditing: available for auditing, but the field needs to be added to the auditing report.
- Reporting:

o CSA: available after you edit the CSA, include the new field, and republish.

o BIP: available after the new field is included in the report template and the CSA is republished.

Set a field as required - Submitted transactions: any update to the transaction will require that this field have a value.
- New transactions: appear as required for any new transaction.
« Auditing: no impact.

- Reporting: nimpact.

Add or edit Groovy script - Submitted transactions: if modifying, the new logic will fire.
- New transactions: applies to all new transactions.
- Auditing: no impact.

« Reporting: no impact.

Hide a field - Submitted transactions: field will be hidden for all submitted transactions.
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Modification

Add a user-defined list of values (LOV)
field

Add or edit a list of values (LOV)

Update list of values (LOV) display criteria
(Enabled/Disabled)

(Start Date/End Date)

Add or edit control display settings

Make changes to reusable field

Impact

New transactions: hidden for any new transactions.

Auditing: field would be still part of the audit report until removed.

Reporting:
BIP - remove from template

CSA: manually remove field from CSA and republish,

BIP: manually remove field from template.

Submitted transactions: applies to all submitted transactions.

New transactions: applies to all new transactions.
Auditing: same as adding a user-defined field.

Reporting: same as adding a user-defined field.

Submitted transactions: no impact.
New transactions: applies to all new transactions.
Auditing: no impact.

Reporting: immediately reflected in CSA.

Submitted transactions: applies to all submitted transactions.

New transactions: applies to all new transactions.
Auditing: no impact.

Reporting: immediately reflected in CSA.

Submitted transactions: may impact submitted transactions.
New transactions: applies to all new transactions.
Auditing: no impact.

Reporting: no impact

Submitted transactions: applies to all submitted transactions.

New transactions: applies to all new transactions.

Chapter 7
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Auditing: available for audits after being incorporated into the audit report.

Reporting: no impact.

Impact of Cloning the Transaction Type and Retiring the Previous Version

This table describes the impact of various changes when you clone a transaction type to replace the previous version.

When cloning, you are creating a new transaction type, so in general, you should expect these impacts as the standard

update:

- Auditing: any new transaction that is created is available to audit framework, which requires you to enable the
object to be audited and configure the report as needed.

- Reporting: a new CSA needs to be created for each new transaction type.

ORACLE
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Modification

Update a label for a user-defined field

Add a new user-defined field

Set a field group field or a user-defined
field as required

Add or edit Groovy script

Hide a field

Add a user-defined list of values (LOV)
field

Update a user-defined list of values (LOV)

Update list of values (LOV) display criteria
(Enabled/Disabled)

(Start Date/End Date)
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Modification

Submitted transactions: no impact as there are no submitted transaction yet.
New transactions: appears for all new transactions.
Auditing: standard uptake.

Reporting: standard uptake. You can reuse the same BIP or create a new BIP template.

Submitted transactions: no impact.
New transactions: appears for all new transactions.
Auditing: standard uptake.

Reporting: standard uptake. You can reuse BIP template after editing and republishing or create a
new BIP template.

Submitted transactions: no impact.
New transactions: appears for all new transactions.
Auditing: standard update. Layout changes are not auditable.

Reporting: no impact to BIP.

Submitted transactions: no impact.
New transactions: appears for all new transactions.
Auditing: Groovy changes are not tracked by audits.

Reporting: no impact to BIP. Groovy changes to not affect reporting.

Submitted transactions: no impact.

New transactions: appears for all new transactions.

Auditing: layout changes are not tracked in Audits.

Reporting: no impact to BIP. Layout changes are not reflected in reporting.

Submitted transactions: If the LOV is pointing to an existing list then updates to this list will affect

submitted transactions. If a new list is created for the user-defined field, then there is no impact
to existing fields.

New transactions: appears for all new transactions.
Auditing: same as adding a user-defined field.

Reporting: no impact to BIP.

Submitted transactions: If the LOV is pointing to an existing list then updates to this list will affect
submitted transactions. If a new list is created for the user-defined field, then there is no impact
to existing fields.

New transactions: appears for all new transactions.
Auditing: no impact.

Reporting: LOVs are immediately reflected in CSA.

Submitted transactions: If the LOV is pointing to an existing list then updates to this list will affect
submitted transactions. If a new list is created for the user-defined field, then there is no impact
to existing fields.

New transactions: appears for all new transactions.

Auditing: no impact.
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Modification Modification

Reporting: may affect reporting on submitted transactions as both values can be incorporated
depending on date settings.
Control display settings - Submitted transactions: no impact.
New transactions: applies to all new transactions.
Auditing: no impact.

Reporting: no impact.

Reusable custom fields - Submitted transactions: applies to all submitted transactions.
New transactions: applies to all new transactions.
Auditing: standard uptake.

Reporting: not currently supported.

Managing Transaction Type Configurations

This topic describes the considerations and steps related to migrating transaction type definitions, such as permits,
planning and zoning applications, and code enforcement, from your test environment to your production environment.

Transaction Type Lifecycle Overview

Any implementation of Oracle Applications Cloud usually requires migrating setup data from one environment to
another at various points in the subscription lifecycle.

For example, you set up your initial configuration of the Public Sector Compliance and Regulations offerings in the
test environment, which is your source system. Then, after thorough testing and verification, you move the setup and
configuration data from your test environment to the target environment, which is your production system.

You use the Fusion Applications Functional Setup Manager to perform these migration tasks.

This example illustrates that you use Functional Setup Manager to migrate data between your test and your production
environment.
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Functional Setup
Manager

Source: Test System Target Production
System

You access Functional Setup Manager by selecting Navigator > Setup and Maintenance or by clicking the Setup and
Maintenance tile on the springboard. To access Functional Setup Manager, you need to have the System Administrator
role associated with your user account.

The functional areas in Functional Setup Manager that apply to your transaction type definitions and application form
definitions are:

Offering Functional Area

Public Sector Permits Permit Types

Public Sector Planning and Zoning Planning Application Types
Public Sector Code Enforcement Incident and Case Types

Like using Functional Setup Manager to setup your configuration, when migrating data, you use a top-down approach.
That is, if you are not exporting the entire configured offering, and you are exporting by functional area, you need to
export the functional areas in the order they appear.

For more information on using Functional Setup Manager, see Using Functional Setup Manager.

Note: All configuration changes should be completed and tested in your test environment and then migrated to
the production environment. Changes made directly to the production environment might be overridden during
subsequent test-to-production migration activity.

For additional information related to migrating configuration data from your test environment to your production
environment for the Public Sector Compliance and Regulation offerings, see Oracle Public Sector Compliance and
Regulation: Test to Production (Doc ID 2551940.1) on My Oracle Support.
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Set the Target Instance URL

On the source system (your test environment), you need to define the URL target system (your production environment)
so that setup data and configuration data can be sent to the target.

To set the target instance URL:

Sign on to the test environment.

Click the Setup and Maintenance tile on the springboard to access Functional Setup Manager.

On the right side of the Functional Manager Setup interface, click the Tasks tab to open the Tasks drawer.
Click Search, and search for Manage Configuration Set Migration Target Security Policy.

On the Manage Configuration Set Migration Target Security Policy page, enter the URL for your target
environment, and the appropriate security credentials for the System Administrator role.

vk WNRA

Note: It is recommended to include the port number when you specify the URL value. For example: https://
server.example.com:443 You can get the target port value by accessing the Manage Configuration Set
Migration Target Security Policy page on your production system (your target).

6. Save.

Managing Unified Sandboxes on the Source and Target System

Public Sector Compliance and Regulation requires the Unified Sandboxes feature to be enabled on your test
environment, where you are actively designing and configuring your implementation. It is recommended that you
disable the Unified Sandboxes feature on your production system.

For migrating transaction types from your test system to your production system, especially, make sure to disable the
Unified Sandboxes feature on your target, production system. Because you should be completing all configuration tasks
on your source test system, sandboxes shouldn’t be required on the production system. Having the Unified Sandboxes
enabled on the production system can cause the Configuration Set Migration utility not to render or function properly.

To disable Unified Sandboxes:

1. Sign on to your target, production system.

2. Navigate to Functional Setup Manager.

3. Select your solution, such as Public Sector Permits, Public Sector Planning and Zoning, or Public Sector Code
Enforcement.

Note: Disable Unified Sandboxes in all solutions you have licensed for Public Sector Compliance and
Regulation.

4. C(lick the Change Feature Opt In link.

5. Locate the Application Extensions feature, and click the pencil icon in the Features column.

6. Make sure the Unified Sandboxes feature is disabled.
Note: If there are any open sandboxes, they need to be deleted or published before you can disable this
feature.

7. Click Done.
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Migrating Transaction Type Foundational Metadata
Before you use Functional Setup Manager to export transaction type configuration data, you need to create and migrate

a configuration set, which includes the underlying metadata required to be in place as a prerequisite prior to migrating
other transaction type setup data.

Because the Public Sector Compliance and Regulation solutions are metadata-driven, you need to migrate the metadata
that is the foundation of the transaction definitions. This is the data stored in the Oracle Metadata Services (MDS) layer.
You do this by creating a configuration migration set. Once that is complete, you can then begin using Functional Setup
Manager export and import features to transfer the rest of required definitions between test and production systems.

Note: Before you migrate transaction type metadata from your test system, ensure that the transaction type
definitions and associated intake forms are complete, tested, and published.

I CAUTION: These steps must be completed before you use the Functional Setup Manager export and import options.

Note: Prior to running the configuration set migration process, ensure that all transaction types are published and
there is no development and design of intake forms underway. Creating transaction types and intake forms is not
supported while the configuration set migration process is running. Once the configuration set migration process has
completed successfully, you may resume development and design of intake forms.

To migrate transaction type metadata:

Sign on to the test system, which is the source system.

Click the Setup and Maintenance tile on the springboard to access Functional Setup Manager.

Select the appropriate offering (Permits, Planning and Zoning, or Code Enforcement).

Expand the Permit Types, Planning Application Types, or the Incident and Case Types functional area
(depending on your offering).

PUWUNA

Note: These steps for creating a migration set apply only to the Permit Types, the Planning Application
Types, and the Incident and Case Types functional areas.

5. Click the configuration you want (depending on your offering). For example for permits, click the Manage
Permit Configuration link.

Note: This link takes you to the Manage Configuration Set Migration Target Security Policy. You can also
access this page in Fusion Application by selecting Navigator > Configuration > Migration .

6. If you have not already specified your target instance URL, you must do that prior to the next step.

See the previous section for more information.
7. Select the Outgoing tile and create an outgoing migration set to export to your production environment.

When creating a configuration set, the utility compares differences between source and target, and determines
the metadata that needs to be exported to the target system. When the process is complete, the resulting
migration set is downloaded in the form of a downloadable jar file.

8. After finishing the creation and migration of the outgoing migration set, sign on to the production system (the
target system), and complete the steps for applying the incoming migration set.

This example illustrates an incoming configuration set.
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For more information on these steps, refer to Oracle Applications Cloud documentation: Configuring and Extending
Applications.

Exporting and Importing Remaining Transaction Type Data

After you have completed migrating the configuration set on the source system, you then export the remaining
transaction type data using the Functional Setup Manager options for the functional area or the entire offering.

Note: You can export and import at the functional area-level by selecting the Actions button for the functional area
or at the entire offering level by selecting the Actions button at the top right.

This example illustrates using the functional area export options.

~ Permit T Manage Workflow Con
ermit Types E}

View Documents 3
* Accounting Shared
Edit Implementation Status :

* OPA Questionnaire Shared

Setup Data Report (3]
* Digital Assistant Shared »C
Import »
* Agency Staff Shared
Expart to T35V File »
Fublic Users Shared Import from CSV File >
* Analytics and Reporting hared Compare Setup Data 2

After exporting from the test system, you then sign on to the production system and import the corresponding
business object data.

When you export business object data, you have the option to select only those business objects that you utilize. For
example, if you are not using application groups, you could deselect Manage Application Groups from the Business
Objects list.

The objects you export will be in the form of a downloadable jar file.
For more information on these Functional Setup Manager export and import features, see:

Using Functional Setup Manager: Managing Setup Using CSV File Packages
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Using Functional Setup Manager: Exporting and Importing Setup Data
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8 Setting Up Inspections

Setting Up Inspection Statuses

Oracle delivers inspection statuses for use during the inspection process. You review the statuses on the Inspection
Status page.

You review inspection statuses during permit setup on the Inspection Status page. You cannot delete the system-
defined statuses or add new statuses, but you can modify the associated inspection status names and descriptions.

Modifying Inspection Statuses

1. Select Common Setup > Transaction Status .
2. Select the Inspections tab.
3. You can review the delivered inspection statuses in the System Status column:

o Pending
o Requested
o Scheduled
o Completed
o Canceled
o Deleted

Select the row for the inspection status that you want to modify.

On the Inspection Status Details page you can edit the inspection status name and description.
The status name is used as the display status for the inspection in the permit application.

6. Click Save to save any changes.

v oA

Inspection Evaluation Overview

The inspector evaluates a building site for adherence to codes and regulations required for a permit. The example here
provides information about an inspection set up to use automatic score calculation with the bottom up scoring method.

A permit might require one or more inspections, each inspection might have one or more checklists, and each checklist
might have checklist items or not, depending on the inspection configuration. The inspector performs an inspection

by assessing the checklist items, if any, then checklists, and up to the inspection level. The evaluation results that the
inspector enters are rolled up to the next level until a final inspection score is calculated if scoring is used.

Scoring is not required. The score is the rolled up to the next level automatically only if scoring used. Otherwise, you
specify the result manually on each level.

The following example describes the setup and results of performing an inspection using the bottom up method of
scoring. Scoring bottom to top indicates that the inspector starts with a zero score and adds points for each criterion
that is met.
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Example: Using the Bottom Up Scoring Method

Before you begin, set up the assessment type, rating method, passing rule, scoring method, and checklist, which
includes the checklist items. In this case, you don’t need to set up the checklist group, because checklist and checklist
group are mutually exclusive of each other.

This example illustrates setup for an inspection on the Inspection Type Details page. Details are in the surrounding text.

Inspection Type Details

* Inspection Type CK_SCHDINSP_FNC Enabled c
* Description  FNC Scheduling Inspections * Estimated Duration in Hours 5
Scheduling Method = Schedule v
[ Assessment Type _passail Q] ’ Passing Rule PR-123 o

[ Rating Method GRADE Q

* Autonumber Rule  CK_FNC_Insp
Checklist Group
Billable

Policy Name:

l Scoring Method | Bottom up . I

o, Maximum Score

o, l Checklist - CK-FNC-0100

Bill Type

Policy Version

Inspector Signature Required v Owner Signature Optional v

Contractor Signature  Optional v Schedule Cutoff Time
Inspection District Type CK_DISTRICT_TYPE_FNC_INSP o Schedule Change Policy 3

Hide Inspector Comments

Cancel Delete

The setup includes the following:

1. Assessment Method

The assessment method is defined on the assessment type page and used in the inspection type definition.
During the inspection, the inspector selects an available assessment which is associated with a system result.
The system result determines the scoring calculation as follows:

Displayed Assessment System Result Scoring Calculation

Pass Pass Score = All Points

Corrected on Site Corrected Score = All Points
Fail Fail Score = No Points
NA (not applicable) Other Score = No Points

Note: Only the displayed assessment value is configurable by the agency. The available system results

are Pass, Fail, Corrected, and Other. You must have one assessment with a system result of Pass and one
assessment with a system result of Fail. You can define multiple assessments with system results of Corrected
and Other.
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See Setting Up Inspection Assessment Types.
2. Inspection Scoring Method

The scoring method is defined on the inspection type. In this example, the scoring method is Bottom Up.

See Setting Up Inspection Types.
3. Rating Method

When you use a scoring method, you also must set up a rating method. The rating method defines the range of
scores used at the inspection type level.

See Setting Up Rating Methods.
4. Checklist

The checklist used in the inspection is defined on the inspection type. For example, the checklist could be
Electrical for a residential addition. For multiple checklists, you enter a checklist group name. A checklist group
can have different inspection checklists, such as both Electrical and Plumbing for a residential addition.

See Setting Up Inspection Checklists.
5. Checklist Item

The inspection score is defined in the inspection checklist details. In this example, each checklist item is set
up with a possible score of 25. The inspector’s assessment determines how many points are applied to the
checklist. When the inspection result is Pass, the item receives the complete score.

See checklist details in Setting Up Inspection Checklists.

Based on the setup, an example inspection evaluation might look like this:

Checklist Item Possible Score Inspector’s Checklist Assessment System  Calculated Score Checklist Total Score
Item Result Status
(Assessment)
1 25 Pass Pass 25 ltem 1=25
2 25 Pass Pass 25 ltem 1+ Item 2 =50
3 25 Corrected on Site Corrected 25 ltem 1+ Item 2 + Item
3=75
4 25 Fail Fail 0 ltem 1+ ltem 2 + Item
3+Item4=75

For multiple checklists, the sum of the checklist scores determines the inspection score.
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Setting Up Inspection Assessment Types

Assessment types identify the results available for assessing an inspection, for example, Pass and Fail. You add, modify,
or delete assessment types and codes for inspections on the Assessment Type pages.

An assessment type includes one or more assessment codes, which identify the possible results for the inspection type.
Assessment types are also used for inspection checklist and checklist item results.

Assessment types function independently of the scoring method, maximum score, and minimum score, for example:

- If the system result is Pass or Corrected, the full score is assigned.
- If the system result is Other or Fail, the score is 0.

Scoring for each system result is predefined in the system for inspections.

This example illustrates the Assessment Type Details page containing the field values described in the following table.

: ol | | Do
Assessment Type Details et SR
" Assessment Type * Description  Result s either Pass or Fail
Assessment Details
Assessment Description System Result Actions
Fail Fail v+ &
Pass Pass (]

Adding Inspection Assessment Types

1. Select Inspection Setup > Assessment Type .
2. Onthe Assessment Type page, click Add to add an assessment type.
3. Onthe Assessment Type Details page, enter an assessment type name and description.
4. Inthe Assessment Details section, click Add in the assessment code row.
5. Enter values in the fields of the assessment code row:
Page Element Description
Assessment Enter a code name.
Description Enter descriptive text for the code.
System Result Select the system-defined result value that you want to set for this assessment code:
o Other
o Pass
o Fail

o Corrected
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Page Element Description

You must map each assessment code to a system result value. Each assessment type
must include a system result of Pass and a system result of Fail. The default value is
Other.

Note:
You must assign Fail to only one code. Likewise, you must assign Pass to only one
code.

The system result is used in the inspection result processing. If scoring is used, the
system result of Pass and Corrected receive the maximum score. The system results
Other and Fail receive no score.

The system result is also used to determine whether an inspection result is pass (system
result Pass) or fail (system result Fail). For example, the Inspection Summary report
includes violation information when a checklist or checklist item result is associated with
the system result Fail.

6. Click the Add icon at the end of the row to add another assessment code row.
7. Click Save.

Modifying Inspection Assessment Type Details

1. Select Inspection Setup > Assessment Type .
Select the row for the assessment type you want to modify.

3. Inthe header fields on the Assessment Type Details page, you can only modify the assessment type
description. You cannot change the name.

4. Inthe Assessment Details section, you can:

o Change the description of an assessment code. You cannot change the code name.

o Select a new value in the System Result column. Available values are Pass, Fail, Corrected, or Other. Each
assessment code must be mapped to a system-defined result value. The default value is Other. You can
only use Pass and Fail once.

5. If you made any changes, click Save.

Deleting Inspection Assessment Types

1. Select Inspection Setup > Assessment Type .
2. Onthe Assessment Type page, click the Edit icon.
3. Select one or more check boxes for the assessment type rows you would like to delete.

I Note: When you delete an assessment type, you also delete the associated details.

4. C(lick the Delete icon.
Deleting Inspection Assessment Type Details

1. Select Inspection Setup > Assessment Type .
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2. Onthe Assessment Type page, select the row for the assessment type you are working with.

3. Onthe Assessment Type Details page, click the Delete icon at the end of the assessment code row you would
like to delete. You delete details one row at a time.

4. C(lick the Save button.

Setting Up Rating Methods

A inspection rating method may have one or more rating ranges, which an inspector uses to evaluate the object of an
inspection. You add, modify, or delete rating methods and rating details for inspections on the Rating Method page.

If you are using scoring for inspections, you must also set up rating methods. Rating methods are used at the inspection
type level and are not required at the checklist or checklist item levels.

Adding Rating Methods

You add an inspection rating method by setting up the rating method code with a description and rating details. For
example, an agency might use GRADES as the rating method code, with a description of Standard Grades. The rating
details might include grades such as A (high) to F (low), and provide a range of scores to each rating. If the rating for an
A grade is defined by 90-100 points, an inspection score of 95 would receive an A.

1. Select Inspection Setup > Rating Method .

2. On the Rating Method page, click Add to add a rating method.

3. On the Rating Method Details page, enter a rating method name and description. The description is a user-
friendly name for the inspection rating method.

4. To add rating method values, click the Add button for the first row in the detail grid, and the Add icon for the
next rows.

5. Enter values for the rating method:

Page Element Description

Rating Enter a short name for the rating.

Minimum Score and Maximum Enter minimum and maximum numerical values to specify the range for this rating. Do
Score not use decimals.

The range for this rating cannot overlap the range for another rating.

6. Click Save.

For example, if your rating method uses grades A through F, you specify the rating range for each grade in the Rating
Method Values table. The range for each rating cannot overlap the range for another rating.

Rating Minimum Score Maximum Score
A 9N 100
B 81 90
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Rating Minimum Score Maximum Score
C 7 80
D 61 70
F 0 60

Modifying Rating Methods

1.
2.
3.

4.

Select Inspection Setup > Rating Method .

On the Rating Method page, select the row for the rating method you want to modify.

In the header fields on the Rating Method Details page, you can only modify the rating method description. You
cannot change the name of the rating method.

Click Save.

Modifying Rating Method Values

You can change the minimum and maximum scores for a rating on the Rating Method Details page.
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5.

Select Inspection Setup > Rating Method .

On the Rating Method page, select the row for the rating method you want to modify.

On the Rating Method Details page, select the rating row in the values grid that you want to modify.

Change the values in the Minimum Score or Maximum Score fields for this rating on the Rating Method Value
Details page. You can use the arrow icons to increase or decrease the score values. The range for this rating
cannot overlap the range for another rating. You cannot change the name of the rating.

Click Save.

Deleting Rating Methods

1. Select Inspection Setup > Rating Method .
2. On the Rating Method page, select the row for the rating method you want to delete.
3. On the Rating Method Details page, click Delete.
Note: When you delete a rating method, all associated rating details are also deleted.

4. To delete multiple rating methods, click the Edit icon on the Rating Method page.
5. Select the check boxes for the rating methods you want to delete.
6. Click the Delete icon.

I Note: When you delete multiple rating methods, all associated rating details are also deleted.
7. Click Save.

Deleting Rating Method Values

1.

Select Inspection Setup > Rating Method .

2. Onthe Rating Method page, select the row for the rating method you want to modify.
3. Onthe Rating Method Details page, select the ratings row in the value grid that you want to delete.

215

ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 8

Implementing Compliance and Regulation Setting Up Inspections
4. On the detail page for the individual rating, click Delete.
5. To delete multiple rating method values, click the Edit icon in the Rating Method Values section.
6. Select the check boxes for the rating method values you want to delete.
7. Click the Delete icon.
8. Click Save.

Setting Up Passing Rules

A passing rule identifies the different ways an inspection can be scored. You add, modify, and delete passing rules for
inspections on the Passing Rule page.

Passing rule definitions provide the criteria for determining whether an inspection passes or fails. If the scoring method
is not used in the inspection type definition, a passing rule is not required.

Adding Passing Rules

A passing rule may have one or more scoring ranges that you specify in the passing rule details.

Select Inspection Setup > Passing Rule .

On the Passing Rule page, click Add to add a new passing rule.

On the Passing Rule Details page, enter a unique code for the passing rule and a description.
To add scoring ranges, click Add in the Passing Rule Criteria section.

Enter values in the fields on the rule details page:

VAhWND

Page Element Description

Description Enter a description for the scoring range.

Minimum Score and Maximum Enter minimum and maximum numerical values to specify the scoring range. You
Score cannot use decimals.

Number of Major Violations Enter a value for the maximum number of major violations allowed.

Pass Turn on the Pass switch if the specified scoring range combined with the number of
violations results in a passing inspection. If the specified range and violations do not
result in a passing inspection, leave the option disabled.

Note:

For passing inspections that are based on a passing rule with the Pass switch on, the
inspection result displays the assessment name that is defined with the system status
Pass. If the Pass switch is off, the inspection result displays the assessment name that
is defined with the system status Fail. The system uses the assessment type that is
associated with the inspection type.
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6. Click Save.

Modifying Passing Rules

1.

Select Inspection Setup > Passing Rule .

2. On the Passing Rule page, select the row for the passing rule you want to modify.

3.

4.

In the header fields on the Passing Rule Details page, you can only modify the passing rule description. You
cannot modify the passing rule code.
Click Save.

Modifying Passing Rule Details

You can change the scoring range for a passing rule on the Passing Rule Details page.
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5.

Select Inspection Setup > Passing Rule .

On the Passing Rule page, select the row for the passing rule you want to modify.

On the Passing Rule Details page, select the scoring row in the details grid that you want to modify.
You can change the following scoring details:

a. Description of the scoring range.
b. Minimum and maximum scores to update the scoring range. Use the arrow icons to increase or decrease
the score values.
c. Number of major violations allowed.
You can also indicate that the specified scoring range combined with the number of violations can result
in a passing inspection, by clicking the Pass slider. Turn off the option using the slider if the scoring range
combined with the violations does not result in passing an inspection,
Click Save.

Deleting Passing Rules

When you delete a passing rule, all associated passing rule criteria are also deleted.

PUWNa

Select Inspection Setup > Passing Rule .

On the Passing Rule page, select the row for the passing rule you want to delete.

On the Passing Rule Details page, click Delete.

If you want to delete multiple passing rules, you can delete them from the Passing Rule page:

a. Click the Edit icon.
b. Select the check boxes for the passing rule rows to delete.
c. Click the Delete icon.

Deleting Passing Rule Criteria

VR WNA

Select Inspection Setup > Passing Rule .

On the Passing Rule page, select the row for the passing rule with the passing rule criteria you want to delete.
In the Passing Rule Criteria section, select the row for the passing rule criteria you want to delete.

On the Passing Rule Criteria Details page, click the Delete button.

If you want to delete multiple scoring ranges, you can delete them from the Passing Rule Details page:

a. Click the Edit icon.
b. Select the check boxes for the passing rule criteria rows to delete.
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c. Click the Delete icon.

Setting Up Inspection Checklist Categories

Use checklist categories and subcategories organize the various types of checklists items for inspections.
You set up inspection checklist categories and subcategories on the Inspection Checklist Category page.

Use the checklist categories and subcategories for categorizing checklist items when you set up inspection checklists on
the Inspection Checklist Item Details page. See Setting Up Inspection Checklists.

Adding Checklist Item Categories

Select Inspection Setup > Checklist Category .

On the Checklist Category page, click Add to add a checklist category.

On the Checklist Category Details page, enter a category ID and description.

If you want to add a subcategory, click the Add button to add the first subcategory in the Checklist
Subcategory section. Click the Add icon for additional subcategories.

On the Checklist Subcategory Details page, enter a subcategory ID and a description.

6. Click Save.
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Modifying Checklist Iltem Categories

1. Select Inspection Setup > Checklist Category .

2. Onthe Checklist Category page, select the row for the category that you want to modify.

3. Onthe Checklist Category Details page, you can only modify the category description. You cannot change the
category ID.

4. C(lick Save.

Modifying Checklist ltem Subcategories

Select Inspection Setup > Checklist Category .

On the Checklist Category page, select the row for the category with the subcategory that you want to modify.
Select the subcategory that you want to modify in the Checklist Subcategory section.

You can only change the description on the Checklist Subcategory Details page.

Click Save.
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Deleting Checklist Item Categories

When you delete a checklist category, all associated subcategories are also deleted.

Select Inspection Setup > Checklist Category .

On the Checklist Category page, select the row for the category that you want to delete.

On the Checklist Category Details page, click Delete.

If you want to delete multiple checklist categories, you can delete them on the Checklist Category page:

o Click the Edit icon.
o Select the check boxes for the category rows to delete.
o Click the Delete icon.

PUWN
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Deleting Checklist Subcategories

Select Inspection Setup > Checklist Category .

On the Checklist Category page, select the row for the category with the subcategory that you want to delete.
On the Checklist Category Details page, select the row for the subcategory that you want to delete.

Click the Delete button on the Checklist Subcategory Details page.

If you want to delete multiple subcategories, you can delete them on the Checklist Category Details page:

A UN

o Click the Edit icon.
o Select the check boxes for the subcategory rows to delete.

o Click the Delete icon.

Setting Up Inspection Checklists

Inspection checklists identify all the items that the inspector must assess during an inspection. You set up inspection
checklists and checklist items on the Inspection Checklist pages.

Before adding inspection checklists, you set up:

Inspection assessment types for your agency, if you want to associate a checklist with an assessment type.

See Setting Up Inspection Assessment Types.

Inspection checklist categories and subcategories, if you want to categorize your checklist items.

See Setting Up Inspection Checklist Categories.

You add, modify, and delete checklists and checklist items in the inspection setup pages. The checklist and checklist
items are copied to the inspection when the inspection schedule is created, and appear on the Inspection Checklist
page, the Checklist Items page, and the Checklist Item Result page.

Note: When you modify an inspection checklist or checklist item, the updated checklist is applied to new inspections
using the checklist. Existing inspections use the version of the checklist definition in use when the inspection was
scheduled.

You identify the checklist or checklist group to use for an inspection on the Inspection Type page. To set up a checklist
group after setting up checklists, see Setting Up Inspection Checklist Groups.

This example illustrates the Inspection Checklist Details page containing the field values described in the preceding
table.
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Inspection Checklist Details

* Checklist
* Description  FNC_Checklist
Maximum Score 100

Scoring Method  Not used

Checklist ltems

= |+ X

Checklist Item Description
Fence-Height Fence-Height
Fence-Material Fence-Material
Fence-Type Fence-Type
Footings Footings

Gate Gate

Assessment Type
Minimum Passing Score

Comment

Required Score

Adding Inspection Checklists

U'l-hSNN_\

Page Element

Assessment Type

Maximum Score

Minimum Passing Score

Scoring Method

ORACLE

Select Inspection Setup > Inspection Checklist .
On the Inspection Checklist page, click Add to add a checklist.
On the Inspection Checklist Details page, enter a checklist ID and description.
Verify that the Enabled switch is turned on. The switch is turned on by default for new checklists.
You can also enter values for these fields:

Description

Enter an assessment type.

PassFail

35

Major Violation

No

No

No

No

No

]| [

Show 8 items

Chapter 8
Setting Up Inspections

The system determines a passing result based on the assessment type defined for the
checklist. The assessment that is defined with system status Pass is used for the passing
result. Otherwise, the assessment that is defined with the system status Fail is used.

Assessment types function independently of the scoring method, maximum score, and

minimum score.

See Setting Up Inspection Assessment Types.

Enter the maximum score possible for the checklist. This value is required if the scoring
method is Top down, which will be available in a future release.

Enter a minimum score for a passing grade. This value is required for the scoring

method Bottom up.

If the total score for the checklist is equal to or greater than the minimum passing score,

the checklist receives a passing result.

Select a scoring method to be used for the checklist:
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6.

Page Element

Comment

Click Save.

Description

o Bottom up: Scoring from the bottom up indicates that the scoring starts with zero
and the inspector adds points for the criteria that are met.

o Not used: This is the default value and indicates that no scoring method is used for
this checklist. You must specify the result manually for each level: checklist item,
checklist, and inspection.

If you don't use the scoring method you can’t use the passing rule and rating
method. This also means that results are not automatically calculated starting with
the checklist items to the checklist to the inspection level.

Note:
The scoring method specified for the checklist should match the scoring method in
the Inspection Type definition.

Enter any additional information.

Adding Inspection Checklist Items

1
2.
3.

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the row for the checklist to which you want to add checklist items.
On the Inspection Checklist Details page, click the Add button in the Checklist Items section to add the first
checklist item. Click the Add icon for additional checklists.

Enter values for fields on the Checklist Item Details page. Required fields include the checklist item ID and

description.

Page Element

Checklist Item and Description

Score

Major Violation

Category and Subcategory

Instructions

ORACLE

Description

Enter an ID and description for the checklist item.

Enter the score the item receives if it passes the inspection.

Turn on the switch to indicate that this checklist item is considered a major violation if it
does not pass inspection.

Enter a category and subcategory for the checklist item. See Setting Up Inspection
Checklist Categories.

Click the Add button in the Instructions section to add instructions for inspecting the
checklist item.

Add instructions on the Instruction Details page, including an instructions ID and the
instructional text.
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5.

6.

The Required switch is turned on by default to indicate that the inspection of the item is required. The
inspector can’t submit the inspection result until all required checklist item and checklist results are complete.

If the checklist item is not required, you can turn off the switch.
Click Save.

Modifying or Deleting Checklists

uvhWNRA

o

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the row for the checklist you want to modify.

On the Inspection Checklist Details page, you can change the values for all fields except for the checklist ID.
If you made any changes, click Save.

If you want to delete the checklist, click Delete.

Note: When you delete a checklist, all associated checklist items are also deleted.
If you want to delete multiple checklists, you can delete them from the Inspection Checklist page:

a. Click the Edit icon.
b. Select the check boxes for the checklist rows to delete.
c. Click the Delete icon.

Modifying or Deleting Checklist Items

NOoOUuhAWNA

8.

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the checklist row associated with the checklist item.

On the Inspection Checklist Details page, select the row for the checklist item in the Checklist Items section.
On the Checklist Item Details page, you can change the values for all fields except for the checklist item ID.

If you made any changes, click Save.

If you want to delete the checklist item, click Delete.

If you want to delete multiple checklist items, you can delete them from the Inspection Checklist Details page
using the Edit and Delete icons.

Click Save.

Modifying or Deleting Checklist Item Instructions

O JgOoOo U A UWNRA

0

Select Inspection Setup > Inspection Checklist .

On the Inspection Checklist page, select the checklist row.

On the Inspection Checklist Details page, select the row for the checklist item that contains the instructions.
On the Checklist Item Details page, select the row for the instructions that you want to modify or delete.
Change the instructional text on the Instruction Details page. You can’t change the instructions ID.

If you made any changes, click Save.

If you want to delete the instructions, click Delete.

If you want to delete multiple instructions, you can delete them from the Checklist Item Details page using the
Edit and Delete icons.

Click Save.
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Setting Up Inspection Checklist Groups

A checklist group comprises inspection checklists that you can associate with a permit. You define a checklist group by
selecting one or more inspection checklists.

You set up inspection checklist groups on the Checklist Group page.

Before setting up inspection checklist groups, you must set up your checklists on the Inspection Checklist page. See
Setting Up Inspection Checklists.

Adding Inspection Checklist Groups

Select Inspection Setup > Checklist Group .

On the Checklist Group page, click Add to add a checklist group.

On the Checklist Group Details page, enter a name and a description for the group of inspection checklists.
Click Save.

To add an inspection checklist to the group, click Add in the Checklists section.

On the Checklist Details page, enter the ID for an existing checklist in the Checklist field.

The description for the checklist ID you entered appears in the Description field.

7. Click Save.

CUuhUNA

Modifying Inspection Checklist Groups

You can modify or delete checklist groups and lines on the Inspection Checklist Group page.

1. Select Inspection Setup > Checklist Group .

2. On the Checklist Group page, select the row for the checklist group that you want to modify.

3. On the Checklist Group Details page, you can only modify the checklist group description. You cannot change
the group name.

4. Click Save to save any changes.

Deleting Inspection Checklist Groups

1. Select Inspection Setup > Checklist Group .

2. On the Checklist Group page, select the row for the checklist group that you want to delete.

3. On the Checklist Group Details page, click Delete.

4. If you want to delete multiple checklist groups, you can delete them from the Checklist Group page:
a. Click the Edit icon.
b. Select the check boxes for the checklist group rows to delete.
c. Click the Delete icon.

Removing Inspection Checklist from an Inspection Checklist Group

Note: You cannot modify inspection checklists on the Inspection Checklist Group pages; you can only remove them
from the group.

1. Select Inspection Setup > Checklist Group .
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2. Onthe Inspection Checklist Group page, select the row for the checklist group from which you want to remove
one or more inspection checklists.

3. Onthe Inspection Checklist Group Details page, select the row for the inspection checklist that you want to
remove from the group.

4. On the Inspection Checklist Details page, click Delete.

5. If you want to remove multiple inspection checklists from the group, you can delete them from the Inspection
Checklist Group Details page:

Click Edit in the Inspection Checklists section.

Select the check boxes for the inspection checklist rows to delete.
Click Bulk Delete.

Click Save.

angoo

Setting Up Inspection Types

Define inspection types used by your agency to identify the requirements and options for different types of inspections.
You set up information such as scheduling, assessments, checklists, billing, signatures required, and comments on the
Inspection Type pages.

The inspection type is associated with the permit for the scheduled inspection and defines the different attributes for
performing the inspection.

This example illustrates the Inspection Type Details page containing the field values described in the following table.

Inspection Type Details
* Inspection Type BV_InsBuilding Enabled C
* Description  Building Inspection * Estimated Duration in Hours 4
* Autonumber Rule BVTEST A
Scheduling Method  Schedule v Scoring Method Not used
Rating Method o Passing Rule o
Checklist Group  E2E_INSP_CHKLST Qo Checklist o
Billable Bill Type RN
Policy Name Assessment Type E2E_PassFail o
Inspector Signature Optional v Policy Version
Contractor Signature  Optional v Owner Signature  Optional
Inspection District Type BV_DISTRICTTYPE Qo Schedule Cutoff Time  6:00 PM (C]
Hide Inspector Comments Schedule Change Policy 1
Cancel Delete

Note: When you modify an inspection type, the updated values are applied to new inspections using the inspection
type. Existing inspections use the original inspection type definition. This does not apply to the Schedule Cutoff
Time and Schedule Change Policy fields, which are referenced when the inspection is scheduled and not stored on
the inspection itself.
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You add inspection types for your agency on the Inspection Type page. You must set up the attributes for the inspection

type before you begin.

1. Select Inspection Setup > Inspection Type.
2. Onthe Inspection Type page, click Add New to add a new inspection type.

3. Enter values for fields on the Inspection Type Details page. Required fields include Inspection Type and

Description, Estimated Duration in Hours, and Autonumber Rule.

Page Element

Inspection Type and Description

Estimated Duration in Hours

Scheduling Method

Assessment Type

Passing Rule

Rating Method

ORACLE

Description

Enter a unique ID and description for the inspection type.

Enter the estimated number of hours this type of inspection will take.

This field is required for scheduling. For more information, see Setting Up Inspection
Scheduling.

Select the scheduling method for inspections associated with this inspection type.

Select Ready to enable applicants to indicate the date and time when the site is ready to

be inspected. Inspections with this scheduling method are assigned and scheduled by
inspection supervisors using the supervisor calendar.

Select Schedule to enable applicants to select a date and time when requesting
inspections.

Select Request to enable applicants to select a preferred date and time range for
requested inspections. Inspections with this scheduling method are assigned and

scheduled by inspection supervisors using the supervisor calendar.

For more information on inspection scheduling, see Setting Up Inspection Scheduling
and Assigning Inspections Using the Supervisor Calendar.

Enter an assessment type, which is used in the inspection result processing.

For more information, see Setting Up Inspection Assessment Types.

Enter a passing rule, which defines the criteria for determining whether an inspection
passes or fails.

For more information, see Setting Up Passing Rules.

Enter a rating method, which defines the scoring ranges used by the passing rule to
determine whether an inspection passes or fails.
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Page Element

Scoring Method

Autonumber Rule

Checklist Group

Checklist

Billable

Bill Type

Policy Name and Policy Version

ORACLE

Description

You must set up a rating method if you are using scoring. For more information, see
Setting Up Rating Methods.

Select a scoring method from these options:

o Bottom up: Scoring bottom to top indicates that the inspector starts with zero
and adds points for each criterion that is met. You must set up a passing rule for
bottom up scoring.

o Not used: This is the default value and indicates that no scoring method is used for
this inspection. You must specify the result manually for each level: checklist item,
checklist, and inspection.
If you don’t use the scoring method you can’t use the passing rule and rating
method. This also means that results are not automatically calculated starting with
the checklist items to the checklist to the inspection level.

Note:
The scoring method specified for the checklist should match the scoring method in
the Inspection Type definition.

Enter the ID for the automatic numbering rule to use for generating the inspection
transaction key.

For more information, see Setting Up Autonumbering.

You can enter a checklist group. If you enter a checklist group, you cannot also enter a
checklist ID.

For more information, see Setting Up Inspection Checklist Groups.

You can enter the ID for a single checklist. You cannot enter both a checklist group and a
checklist ID.

For more information, see Setting Up Inspection Checklists.

Click this slider if this inspection type is billable. When you turn on this switch, the Bill
Type field becomes required.

Enter a bill type. This field is required if the Billable switch is turned on.

For more information, see Setting Up Bill Types.

Enter the name of the template and version number the Oracle Intelligent Advisor
policy.

Chapter 8
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Page Element

Inspector Signature
Owner Signature

Contractor Signature

Schedule Cutoff Time

Inspection District Type

Schedule Change Policy

Hide Inspector Comments

ORACLE

Description

For more information, see Overview of Oracle Intelligent Advisor Configuration.

Select a signature option for the inspector, owner, and contractor associated with the
inspection type:

o Required: The signature field appears on the Inspection Results page.

Note:
Inspectors can’t submit a completed inspection if required signatures are missing.

o Not Required: The signature field does not appear on the Inspection Results page.
o Optional: A signature is optional for this inspection type.

The default value for the Inspector Signature is Required.

The default value for the Owner Signature and Contractor Signature is Optional.

Enter the time after which applicants and non-supervisor agency staff can no longer
schedule inspections for the current day or the next day using the Scheduling modal
page. For example, if the cut off is 3:00 PM and the current time is 4:30 PM, the
inspection can’'t be scheduled for today or tomorrow. The inspection must be scheduled
for the day after tomorrow.

Note:

This field does not affect an inspection supervisor’s ability to override inspection
assignment times through the Scheduling modal page. It also does not affect
automatic batch assignment.

Enter the inspection district type for this inspection, for example a building, electrical,
or plumbing inspection district. When the inspection with this inspection type is
scheduled, the system finds the inspector who is assigned to a district belonging to the
inspection district type defined on the inspection type.

This field is required for scheduling. For more information, see Setting Up Inspection
Scheduling.

Enter the acceptable number of hours prior to the inspection that the user can change
the schedule or cancel an inspection.

For more information, see Setting Up Inspection Scheduling.

Turn on this switch if you want to hide inspector comments from public users. The
default value for this switch is off so that inspector comments are visible.

Chapter 8
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4. Verify that the Enabled switch is turned on if you want to enable this inspection type when you save it. The
switch is turned on by default for a new inspection type.
5. Click Save.

Modifying or Deleting Inspection Types

You can modify or delete inspection types on the Inspection Type page.

1. Select Inspection Setup > Inspection Type.
2. Onthe Inspection Type page, select the row for the inspection type you want to modify.
3. Onthe Inspection Type Details page, you can change the values for all fields except for the inspection type
code.
If you made any changes, click Save.
To delete the inspection type, click Delete.
If you want to delete multiple inspection types, you can delete them from the Inspection Type page:
a. Click the Editicon.
b. Select the check boxes for the inspection type rows to delete.
c. Click the Delete icon.

ounk

Setting Up Inspection Groups

An inspection group identifies a group of inspection types associated with a permit. You can set up inspection groups
on the Inspection Group page.

The inspection group includes one or more inspection types. You can define inspection groups separately from permit
type definitions.

Before setting up inspection groups, you must set up inspection types for your agency on the Inspection Type page. See
Setting Up Inspection Types.

Adding Inspection Groups

Select Inspection Setup > Inspection Group .
On the Inspection Group page, click Add to add a new inspection group.
On the Inspection Group Details page, enter a name and a description for the inspection group.
Click the Enabled switch to enable the new inspection group.
To add inspection types to include in the group, click Add in the Inspection Types section.
Enter values in the columns of the inspection type row:

a. Inspection Type: Enter an existing inspection type.

The description for the inspection type you entered will appear in the Description field.
b. Required: Click the switch if the inspection type is required for the inspection group.

Note: Even if an inspection type is not required, it may become required based on business rules
during processing.

CUuPUNA

c. Final Inspection: Click the switch if this inspection type is the final inspection. One and only one row
must be set as the final inspection.
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d. Click the Add icon to add another type; otherwise, click Save.
7. On the Inspection Group Details page, click Save.

Modifying or Deleting Inspection Groups

You can modify or delete inspection groups on the Inspection Group page.

1. Select Inspection Setup > Inspection Group .
On the Inspection Group page, select the inspection group that you want to modify.
On the Inspection Group Details page, you can only modify the inspection group description. You cannot
change the group name.
Click the Enabled switch to enable or disable the inspection group.
If you want to delete the inspection group, click Delete on the Inspection Group Details page.
Click Save to save any changes.
If you want to delete multiple inspection groups, you can delete them from the Inspection Group page:
a. Click Edit.
b. Select the check boxes for the inspection group rows to delete.
c. Click Delete.
8. Inthe inspection types grid, you can:
a. Click the Required switch to enable or disable an inspection type.
b. Click the Final Inspection switch to set an inspection type as the final inspection. One and only one row
must be set as the final inspection.
c. Click Add to add a new inspection type row.
d. Click the Delete icon at the end of the row to remove an inspection type from the group.

whN
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Note: You cannot change the inspection type ID or description, but you can remove an inspection type and
add another.

9. C(lick Save to save any changes.
10. If you want to remove an inspection type from the group, click Delete.
11. If you want to remove multiple inspection types from the group, you can delete the rows from the Inspection
Group Details page:

a. Click Edit.
b. Select the check boxes for the inspection type rows to delete.
c. Click Delete.
d. Click Save.

Setting Up Inspection Calendars

Inspection calendars establish the days of the week and daily hours that are available for scheduling specific types of
inspections.

Administrators add, modify, and delete inspection calendars on the Inspection Calendar page.

Adding an Inspection Calendar

1. Select Inspection Setup > Inspection Calendar.
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2. Onthe Inspection Calendar page, click Add.
3. On the Inspection Calendar Details page, enter values for the following fields:

Page Element

Calendar ID

Inspection Type

Inspection District

Description

Start Date

End Date

Start Time and End Time

Recurrence

Weeks Between Occurrences

ORACLE

Description

Enter a unique ID for the calendar.

Select the type of inspection to which this calendar applies.

For more information on inspections types, see Setting Up Inspection Types.

Select the district to which this calendar applies.

Note:

A small municipality may have only one defined district ID that includes its entire
inspection area. A large municipality may have multiple defined district ID. This
enables you to create inspection calendars for different areas to optimize your
distribution of resources.

For more information on districts, see Setting Up Districts.

Enter a description for the calendar. For example, you might enter Final fence inspection
calendar.

Enter the first day of the calendar.

Enter the last date of the calendar. You can leave this field blank to give the calendar an
open end date.

Enter the start and end time for the calendar. For example, you might enter a start time
of 09:00 and an end time of 76:00.

Select whether the calendar reoccurs weekly. If you select Weekly recurrence, enter the
number of weeks between occurrence in the Weeks Between Occurrences field.

Enter how many weeks are between each occurrence. For example, if you select a
recurrence of Weekly with 7week between occurrences, the calendar repeats every
week.

Chapter 8
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Page Element Description

Note:

When the recurrence frequency for an inspection calendar is greater than 1, the

first week of scheduling is the week that contains the start date, where Sunday is
considered the first day of the week. Therefore, it is recommended that you set the
start date to the Sunday of the first week in which you want to schedule inspections.

For example, you create an inspection calendar for Mondays and Fridays where

the recurrence frequency is 2, alternating weeks. Setting the calendar start date

to January 1, 2019 causes January 4, 2018 to be available for scheduling but not
December 31, because it is before the start date. Also, January 7 and 11 are in the
alternate week, so the next days available for scheduling are January 14 and 18. If you
set the start date to January 5, which is still part of the first week that the calendar

is active, the system considers this same week as the start week, but no days are
available until January 14 and 18.

Inspection Days Select the days of the week that are available for inspection scheduling.

4. Click Save.

Note: For overnight inspection calendars that go past 12 a.m. (midnight), you must create two calendars: one for the
time period up until midnight, and one for the time period after midnight. For example, to create a weekday overnight
calendar that starts at 09:00 p.m. and ends at 05:00 a.m. the following day, the first calendar would have a start time
of 09:00 p.m. and an end time of 12:00 a.m. on Monday, Wednesday, and Friday. The second calendar would have a
start time of 12:00 a.m. and an end time of 05:00 a.m. on Tuesday, Thursday, and Saturday.

Modifying an Inspection Calendar

1. Select Inspection Setup > Inspection Calendar.
2. Click a row on the Inspection Calendar page.
3. On the Inspection Calendar Details page you can:

o Update the inspection calendar field values.

Note: You cannot edit the Calendar ID.

o Delete the calendar. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Inspection Calendars

Click Edit.

PUWUNA
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Select Inspection Setup > Inspection Calendar .

Select the check boxes next to all the inspection calendars you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.
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Setting Up Inspection Scheduling

When agency users and registered public users schedule an inspection, the system is actually determining which
inspectors are available and qualified to perform the inspection. Therefore, to schedule inspections, it is necessary to
define all of the appropriate employee data for inspectors.

Inspectors are considered qualified if they have been assigned the inspection type and district associated with the
inspection. The availability of inspectors is based on their work schedules and whether they have been assigned to
other inspections previously.

In addition, the time slots that are available for scheduling are impacted by inspection calendars and holiday calendars,
which define when inspections can and can’t be performed, respectively.

The system determines which inspectors can be scheduled to perform an inspection based on two sets of criteria.

1. Quialifications: To be qualified to perform an inspection, agency staff must be defined as inspectors, and
assigned to inspection types, districts and work schedules.
2. Availability: Agency holidays and inspection calendars, inspector work schedules, and existing inspector
assignments determine the availability of inspectors.
The following table lists the different types of data that need to be defined so that the system can determine inspector
qualifications and availability. The Frequency column lists how many instances of the data type can be defined. The
Required column lists whether a data type is required for time slots to appear on the Scheduling modal page during
inspection scheduling.

For more information on inspection requests see Requesting Inspections.

Criteria Type Data Type Frequency Required Impact of Missing Data

Quialification Inspection Type One per inspection Yes Only defined inspection
types are available to
select when requesting
inspections. The Select a
Time button is not available
if the inspection type’s
scheduling method is not

Schedule.
Quialification District One per inspection Yes No scheduling times are
available on the Scheduling
Note that the address modal page.
selected for the inspection
needs to be associated to Note that the inspection
a property for which there type and a property
is an assigned inspection associated with the permit
district. must have the same district
type. If they don't, the
Select a Time button
is unavailable for the
inspection request.
Quialification Inspectors One per employee who Yes No scheduling times are
performs inspections available on the Scheduling

modal page.
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Criteria Type

Quialification

Quialification

Availability

Availability

Availability

Availability

Availability

Data Type

Assigned Inspection Type

Frequency

One or more per inspector

Assigned Inspection District One or more per inspector

Work Schedule

Assigned Work Schedule

Inspection Calendar

Assigned Inspection

Holiday Calendar

Inspection Types

You define inspection types using the Inspection Type page. The system uses the estimated duration to determine
whether an inspector is available for the entire time required to complete an inspection. The inspection district type is a
pre-defined district type with the category of Inspection.

One or more for each
period of the day inspectors
work; may include one
break

One or more per inspector

One or more for each
combination of inspection
type and district

Automatically created when
an inspection is assigned

One per agency

Required

Yes

Yes

Yes

Yes

No

No

No

For more information on inspection types, see Setting Up Inspection Types.

ORACLE
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Impact of Missing Data

No scheduling times are
available on the Scheduling
modal page.

No scheduling times are
available on the Scheduling
modal page.

Note that the assigned
inspection district and the
property associated with
the permit must have the
same district type. If they
don't, the Select a Time
button is unavailable for the
inspection request.

No scheduling times are
available on the Scheduling
modal page.

No scheduling times are
available on the Scheduling
modal page.

The inspection can be
scheduled at any time
of day (or whenever
inspectors are available).

No time slots are
unavailable for scheduling
due to previously assigned
inspections.

No days are unavailable for
scheduling due to holidays
or other agency non-
working days.
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Inspection Districts

You must create an inspection district and assign it to inspectors to enable qualified inspectors and make time slots
available when scheduling inspections. The district for the inspection is based on the district type assigned to the
inspection type. The system uses this district type to determine the district ID associated with the property for which an
inspection is being scheduled. A property may have more than one district type associated with it, but only one of them
has a district type category of Inspection.

The system determines the property for the inspection based on the inspection address. The address for a new
inspection defaults to the primary address associated with the permit for which you are scheduling an inspection.
You may select other addresses that are associated with the permit. If no address is associated with an inspection,
the system can’t determine the district for the inspection so the Select a Time and Select a Different Time buttons are
disabled.

For more information on district types, districts, parcels, and addresses see:

« Setting Up District Types

- Setting Up Districts

« Assigning Districts to Parcels

« Assigning Districts to Addresses

« Setting Up Property Addresses

Work Schedules

You must create work schedules and assign them to inspectors to make the inspectors available for inspection
scheduling.

Note: If the recurrence for a work schedule is Weekly, and the weeks between occurrences is greater than 1, the
system uses the week of the valid from date as the starting point for scheduling.

For more information on work schedules, see Setting Up Work Schedules.

Inspectors

To make inspectors available for inspection scheduling, you must perform the following steps on the Agency Staff page:

- Assign the ORA_BUILDING_INSPECTOR job function to the inspector.

- Assign inspection types to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job
function.

- Assign inspection districts to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job
function.

- Assign work schedules to the inspector by adding job attributes to the ORA_BUILDING_INSPECTOR job
function.

For more information on assigning job functions and job attributes to agency staff, see Setting Up Agency Staff.
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Inspection Calendars

Setting up inspection calendars is optional for scheduling inspections. Without inspection calendars, however, the
system can potentially allow inspections to be scheduled for any time during a 24 hour period, if there are work
schedules that comprise all 24 hours.

You define inspection calendars for a specific combination of inspection type and district. You can define more than one
calendar for the same inspection type and district.

For more information on inspection calendars, see Setting Up Inspection Calendars.

Holiday Calendar

Setting up holiday calendars is optional for scheduling inspections. Holiday calendars establish the days that agency
offices are closed and no field service operations are offered. The dates established as events on the holiday calendar
are not available for inspection scheduling regardless of how the inspection calendars or work schedules are defined.

For more information on holiday calendars, see Setting Up Holiday Calendars.
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9 Setting Up Plan Reviews

Setting Up Plan Reviewer Departments

A plan review department represents an area of expertise for reviewers of plan documents.

For example, a plan review department of Building is associated with experts in building-related codes and regulations
whereas a plan reviewer department of Fire is associated with experts in fire-related codes and regulations.

You select a plan review department for a plan reviewer when you add a department job attribute for your plan reviewer
job function during agency staff setup. For more information on adding job functions and job attributes, see Managing
Agency Staff Profiles.

System administrators add, modify, and delete plan reviewer departments on the Plan Reviewer Department page.

Adding Plan Reviewer Departments

1. Select Common Setup > Plan Reviewer Department .
2. On the Plan Reviewer Department page, click Add.
3. Enter values for the following fields:

Page Element Description

Department ID and Department Enter an ID and name for the department

Description Enter a description for the department.

Applicable Classification Select the types of transactions that the department applies to. You must select at least

one classification. Options are:

o Permits

o Planning and Zoning

Note:
These options are available to select only if you have more than one offering
installed.

Department Lead Select a plan reviewer as the Department Lead. Only agency staff that are assigned the
job attribute for the department are available to select.

The automatic plan reviewer assignment process adds the department lead as
the default plan reviewer for the department. You enable automatic plan review
assignment and select the default plan reviewer departments on the Permit Type and
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Page Element Description

Planning Application Type pages. See Setting Up Permit Types and Setting Up Planning
Application Types.

4. Turn on the Enabled switch to make the plan reviewer department available as a value on other pages.
5. Click Save.

Modifying Plan Reviewer Departments

1. Select Common Setup > Plan Reviewer Department .
2. Onthe Plan Reviewer Department page, select the plan reviewer department that you want to modify.
3. On the Plan Reviewer Department Details page you can:

o Edit the description and department lead. You cannot change the values of the Department ID and
Department fields.

o Update the applicable classifications.
o Enable or disable the plan reviewer department using the Enabled switch.

Note: When you disable a plan reviewer department that is already associated with a plan review the
department remains associated with that plan review.
o Delete the plan reviewer department. You will be prompted to confirm the permanent deletion.
4. C(lick Save.

Deleting Plan Reviewer Departments

Select Common Setup > Plan Reviewer Department .

Click Select Multiple.

Select the check boxes next to all the plan reviewer departments you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

P WN

Note: You can’t delete a plan reviewer department that is already in use as part of a plan reviewer’s job attribute, or
selected for a permit type or planning application type. In this case, to prevent the plan reviewer department from
being used in the future, turn off the Enabled switch to disable it.
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10 Setting Up Activity Tracking

Setting Up Activity Tracking

This topic gives you an overview of the steps involved in setting up activity tracking for the administrative actions that
are required during the application process.

1. Set up activity statuses, if desired, and review system statuses.
See Setting Up Activity Statuses.
2. Set up activities.
See Setting Up Activities.
3. Define activity groups.
See Setting Up Activity Groups.
4. Add activities to the groups, and configure the activity rules that are used to calculate due dates of tasks.
See Defining Planning Application Activity Rules.
5. Assign the activity group to the planning application type.
See Setting Up Planning Application Types.

Setting Up Activity Statuses

Use delivered activity statuses to identify the progression of an activity using activity due dates tracking.

You can review the delivered activity statuses on the Activity Status page:

Canceled

Completed
- In progress

Incomplete
- Not required
- Pending

You can’t delete the system-delivered statuses, but you can modify the descriptions. You can also define additional
activity statuses that are associated with either the In progress or Not required system status.

Adding Activity Statuses

Define any additional statuses that your agency will use for activity tracking on the Activity Status page.

Select Common Setup > Transaction Status .

Select the Activity Status tab.

Click Add to define a new status.

On the Activity Status Details page, enter values for these fields:

PUWN
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Page Element Description
Status Enter a status name.
Description Enter a description for the status. The description is exposed to agency staff for an

activity using activity due dates tracking.

System Status Select the system status that you want to use.

Note:
You must associate the new status with a system status to ensure correct processing.

o Inprocess

o Not required

5. Verify that the Enabled switch is turned on. The switch is turned off by default for a new status.
6. Click Save.

Modifying Activity Statuses

You can modify the activity statuses that you have defined on the Activity Status Details page, but you can only edit the
Description field of system-defined statuses. The description is exposed to agency staff for an activity on the activity
due dates tracking page.

PUWNa

Select Common Setup > Transaction Status .

Select the Activity Status tab.

Select the row for the status that you want to modify.

For user-defined statuses, you can:
o Edit the description.
o Select the system status that you want to use for processing: In progress or Not required.
o Turn on the Enabled switch to enable a user-defined record status.

For system-delivered statuses, you can only edit the description. You can’t edit the Status field or disable the
status.
Click Save to save any changes.

Setting Up Activities

When configuring activity tracking for your agency, you set up the activities that take place during the application

process.

Activities are time-sensitive tasks that help you track due dates related to the progression of a planning application. You
set up activities on the Activities Details page for reuse in the activity groups associated with the planning application
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type. When a planning application is submitted, you manage the activities to complete the application. For example, you
might set up an activity called Administrative Close for completing the hearing decision report.

You can modify or delete an activity, but when an activity is assigned to an activity group, you can’t delete the activity.
Let’s take a look at how to set up application activities:

1. Select Common Setup > Activity .
2. On the Activity page, click Add to add a new activity.
3. Onthe Activity Details page, you'll find these fields:

Page Element Description

Activity ID Enter a unique identifier for the activity. You can’t modify this field after saving the
activity.

Activity Enter a name for the activity.

Description Enter a description of the activity.

Classification Displays Planning and Zoning to indicate the offering this activity will be used for.

4. Turn on the Enabled switch when the activity is ready for use.
5. Click Save.

Setting Up Activity Groups
When configuring activity tracking for your agency and after defining reusable activities, you define the grouping of
activities that apply to a planning application type.

First, define the activity group that will be mapped to one or more planning application types. You can reuse activity
groups for different application types. Then assign the activities that have already been set up to activity groups and set
up the rules for calculating due dates. The groups identify the list of tasks involved in processing a planning application.

You can modify or delete an activity group, but you can’t delete the activity group when it's associated with a planning
application type.

Here's how to define the activity group:

1. Select Common Setup > Activity Group .
2. On the Activity Group page, click Add to add a new group.
3. Onthe Activity Group Details page, enter a values for the group.

Page Element Description

Activity Group ID Enter a unique identifier for the activity group.
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Page Element Description
Activity Group Enter a name for the activity group.
Description Enter a description of the activity group.
Classification Displays Planning and Zoning to indicate the offering this activity group will be used for.

4. Add activities to the group in the Activity section.

You can click the Activity link to see the list of activities available for use in the group.
5. Turn on the Enabled switch when the activity group is ready for use.
6. Click Save.
The next step is to define the rules for each activity that are used to calculate due dates and manage the activity.

Defining Planning Application Activity Rules

You define planning application activity rules for each activity in an activity group to track and manage tasks based on
important due dates.

The rules are based on events that occur during the planning application lifecycle—which include when the application
is received, application acceptance, the hearing schedule, and the hearing decision—and determine how the activity
due dates are calculated.

Activity Rule Example

Let’s take a look at an example. First, the agency sets up a reusable activity City Clerk Publishes Final Packet, which

can be part of multiple agency groups. This activity reminds the planning application staff to publish the final packet
before the public hearing. After the activity is assigned to an activity group, the agency defines the rules for tracking the
activity. In this example, the activity is related to the hearing, based on the City Council hearing date. That is, the City
Council hearing date is the base date and activities may be due before or after. Here the task is due 7 days before the
hearing date, and if the hearing is canceled or rescheduled, agency staff can repeat the activity with a new base date.

The example Activity Group — Activity setup page shown here is described in the surrounding text.
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Activity

* Activity ID 008 o,

Activity City Clerk Publishes Final Packet

Description City Clerk Publishes Final Packet

*
Base Date

* .
Hearing Body

*

Due Date Days before base date ¥

Redo Activity with New Base Date

AR

Enabled

Cancel Delete

When the hearing with the City Council is scheduled, the activity based on the rule is inserted into the activity tracking
list for the planning application as shown here.

The due date for the activity is calculated to be 7 days before the hearing date. The hearing date in this example is
10/21/20 and the activity is due 10/14/20.

Notice how the activity or activities with same base date in the group are activated on the application’s activity tracking
page. In this example, all of the activities associated with the hearing base date appear in the list when the hearing date
is scheduled.

Defining Activity Rules

Here’'s how to define activity rules that are used to determine due dates of tasks:

Select Common Setup > Activity Group .

On the Activity Group page, select the row with the activity group that you want to add activities to.

Click the Add button in the Activity section on the Activity Group Details page.

On the Activity page, select an activity from the reusable activities you set up in the first step of due date
tracking setup. For more information, see Setting Up Activities.

The activity name and description are displayed once you select an activity.
5. Next select the base date for calculating due dates, when the event in the application timeline occurs. Choose
one of the following from the Base Date list:

PWN~

Activity Base Date Event Description

Submission Date The date when the application was submitted in the agency system.
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Activity Base Date Event Description
Acceptance Date The date when the agency accepts the application after submission. The workflow

process populates the acceptance date in the application

Hearing Date The scheduled hearing date for the planning application. The calculated activity due
date is updated when the hearing date changes.

Hearing Decision Date The date when the hearing body makes a decision about the planning application, such
Approved or Denied.

6. For each base date, enter the due date rule in days in the Due Date field. For example, if an activity deadline is
30 days after the application acceptance date, enter 30 in the Due Date field and select Days after base date.
You can also indicate whether the due date is prior to the base date by selecting Days before base date.

7. Then set up the unique rules for each activity based on the event date.

o If you select the Submission Date base date, you provide a due date and also indicate whether the
application can be resubmitted. For example, when an application is submitted, state law provides up to
30 days to review the application and determine its completeness. When an application is resubmitted,
the 30-day allowance begins again. It can only be resubmitted if it's incomplete.

o The Acceptance Date base date selection only requires due date values.

o For the Hearing Date and Hearing Decision Date base dates, enter the due date and values for the
following fields:

Page Element Description

Hearing Body This field applies only to the Hearing Date Hearing Decision Date base
dates. Select from the available hearing bodies that evaluate the application.
Your agency sets up the hearing bodies you can choose from. For more
information, see Setting Up Hearing Bodies.

Hearing Decision This field applies only to the Hearing Decision Date base date. Select one or
more decisions about the planning application: Approved, Continue, Denied,
and None. The calculated activity due date is based on the date the hearing
decision is made with one of the specified outcomes.

Redo Activity with New Base  Indicate whether the activity needs to be redone whenever the base

Date date changes. For example, the activity based on the current due date is
complete, but you want to redo the activity based on a new date. A new row
automatically appears on the activity tracking page with the new base date
and calculated due date.

8. Turn on the Enabled switch when the activity rule is ready for use. You can turn off the switch to disable the
activity rule but you can’t delete it if the activity group is in use.
9. Click Save.
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Setting Up Actions Based on Activities

You can set up business rules in the Business Rules Framework to automatically update a workflow step and send
communications based on an entitlement activity status change in the activity tracking.

The Business Rules Framework is an event-driven, action framework that enables you to execute various actions based
on conditions in the business rules you define. Here the business rules can automate workflow and communications
actions based on the progression of planning application activities. For more information about the Business Rules
Framework, see Business Rules Framework Overview.

Before you begin, set up activity tracking, define the workflow process in Oracle Autonomous Integration Cloud (OIC),
and set up communication templates. For information about workflow, see Setting Up Process Definitions for Workflow.
For information about setting up communication templates, see Setting Up Communication Templates.

The workflow advances and communications are sent when the activity conditions are met. In this example, the
workflow status for the human task Review Application Completeness is automatically set to Complete when the
Completeness Review activity in activity tracking is set to Completed. Also, when the status of the Completeness
Review activity is changed to Completed, the selected communication templates from the Planning Activity Updated
communication event are sent.

Let’s look at setting up the business rule with the conditions to trigger workflow advancement and communication
actions:

Select Common Setup > Business Rules Framework .

Select the Planning and Zoning tile.

In the list of planning and zoning events, select the Planning Activity Updated event.
Click Add to create a business rule.

Define the conditions for the action in the Conditions section.

A WN

o 1. Activity Equals Completeness Review AND
o 2. Activity Status Equals Completed
Example of entitlement activity conditions described in the surrounding text

4 Conditions

Sequence { Field Operator Value ) Grouping Verb Actions

1 v { v Activity v Equals v Completeness Review ) v AND v + ﬁ

2 v { A Activity Status v Equals v Completed ) v v + o

6. Select actions:

o The Update Workflow action that updates a workflow process instance.
o The Send Communication action that sends emails and notifications based on communication templates.

Workflow advancement and communications actions described in the surrounding text
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4 Actions
Action Name Action Description Configure Actions
Update Worlflow v Updates a Workflow Process Instance Configure + ﬁ
Send Communication v Sends a communication Configure + ﬁ

7. Click the Configure link for the Update Workflow action to configure the workflow action values in the Update
Workflow table.

Identify the workflow step and the action that should be used when updating a task. In this example, the values
are Review Application Completeness for the PSC_ACTIVITY_TYPE workflow property and Completed for the
action.

8. C(lick the Configure link for the Send Communication action to select communication templates from the
Planning Activity Updated communication event in the Activity Tracking resource. .

You can select templates by template code or channel type. You can also process all Planning Activity Updated
templates. Click the Edit Templates link to access and update the templates.

When the activity conditions are satisfied, the business rule triggers the workflow and communications actions.

Related Topics
- Setting Up Business Rule Conditions

 Setting Up Business Rule Actions
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11 Managing Audit Policies

Implementation Concepts for Audit Policies

This topic discusses audit configuration for business object attributes.

Audit enables tracking the change history of particular attributes of a business object. However, those objects and their
attributes must be selected for audit and auditing must be enabled for that application. Your configuration settings
determine which attributes to audit for a given object, and when the audit starts and ends. Auditing takes into account
all the operations performed on an object and its attributes, such as create, update, and delete. To configure audit
business object attributes, use the Manage Audit Policies task in the Setup and Maintenance work area.

Selecting an Application

To set up auditing, you must select a web application that contains the required business objects that can be audited.
From the list of business objects, select those business objects that you want to audit. Selecting a business object also
displays its attributes that are enabled for auditing.

Selecting Attributes

For each selected business object to be audited, select the corresponding attributes to include in the audit. All attributes
that belong to that object are by default selected for audit and appear on the user interface. However, you can add or
remove attributes from the list. When you remove an attribute from the list, you stop auditing it even when the parent
object is selected for audit. So, if you want an attribute to be audited, you must add it to the list. If the object selected in
an audit hierarchy is also a part of several other audit hierarchies, the attribute configuration for that object is applicable
to all the hierarchies in that application.

Tip: For business objects based on flexfields, select the Flexfields (Additional Attributes) check box to view and add or
remove flexfield attributes, to include or exclude them from the audit.

Starting and Stopping Audit

The business object is ready for audit after you select its attributes and save the configuration changes. However, to
start auditing, the audit level for Oracle Applications Cloud must be set to Auditing on the Manage Audit Policies page.

To stop auditing an object, you can deselect the entire object and save the configuration. As a result, all its selected
attributes are automatically deselected and are not audited. To continue to audit the business object with select
attributes, deselect those attributes that are not to be audited. When users view the audit history for an application, they
can specify the period for which they want the results. Therefore, make a note of when you start and stop auditing an
application.

For example, users intend to view the audit history of an object for the previous week, but auditing for that object was
stopped last month. They wouldn't get any audit results for that week, because during the entire month that object
wasn't audited. Even if you enable audit for that object today, users can't get the wanted results because audit data until
today isn't available.
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Audit Configuration for Oracle Fusion Middleware Products

To set up auditing for Oracle Applications Cloud, select the Manage Audit Policies task from the Setup and
Maintenance work area within your offering. To set up auditing for Oracle Fusion Middleware products, select the
level of auditing mapped to a predefined set of metadata and the events that have to be audited. Information about
configuring audit for Oracle Fusion Middleware products is provided in Oracle Fusion Middleware guides.

You can also create a configuration file and deploy it to audit a specific Oracle Fusion Middleware product. The
configuration details for Oracle Fusion Middleware products are available as audit-specific assets that you can use to
create the config.xml configuration file. To get a list of audit-specific assets, see Audit Events for Oracle Applications
Cloud Middleware (Doc ID 2114143.1) on My Oracle Support at https://support.oracle.com.

- Oracle Fusion Middleware Products

Configure business objects to enable auditing in Oracle Fusion Middleware products. Refer to the Oracle Fusion
Middleware Security and Administrator's Guide for Web Services.

- Oracle Fusion Security Products

Configure business objects to enable auditing in Oracle Fusion security products. Refer to Oracle Fusion
Middleware Application Security Guide.

Using Auditing to Monitor Changes

You can enable business objects to allow auditing, recording, and retrieving information about when the objects were
created, modified, and removed.

Audit Policies Overview

Auditing is used to monitor user activity and all configuration, security, and data changes that have been made to an
application. Auditing involves recording and retrieving information pertaining to the creation, modification, and removal
of business objects. All actions performed on the business objects and the modified values are also recorded. The audit
information is stored without any intervention of the user or any explicit user action.

Use audit policies to select specific business objects and attributes to be audited. The decision to create policies usually
depends on the type of information to be audited and to the level of detail required for reporting.

Enabling Audit Functionality

For Oracle Applications Cloud, you must configure the business objects and select the attributes before enabling audit.
If you enable audit without configuring the business objects, auditing remains inactive. By default, auditing is disabled
for all applications. To enable and manage audit, ensure that you have a role with the assigned privilege Manage Audit
Policies (FND_MANAGE_AUDIT_POLICIES_PRIV). For appropriate assignment of roles and privileges, check with your
security administrator.

If you don't want an object to be audited, you can stop the audit process by setting the Audit Level option to None.
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Auditing Public Sector Compliance and Regulation Data

You use auditing to monitor data changes that have been made to data within the Public Sector offerings.
To enable auditing for Public Sector Compliance and Regulation data:

1. Signin as a setup user.
2. Select Setup and Maintenance and go to the following:

o Offering: Select any Public Sector offering.
o Functional Area: Application Extensions

o Task: Manage Audit Policies

In the Manage Audit Policies page, click Oracle Fusion Applications, to configure the required audits.

Click Configure Business Object Attributes.

5. On the Configure Business Object Attributes page, select Public Sector Common Components from the drop-
down list of products.

Pouw

Select Public Sector Tech Stack for configuring user-defined business object attributes generated by your intake
forms. See Auditing Custom Object Data.

6. Select from the list of objects in the Audit Name column:

Objects Category Parent Object Child Object

Fees Fee Transactions (None)

Fee Schedule Fee Schedule Fee Items

Permits, Planning and Zoning, and Common Transaction Data o Business Licenses Data
Business Licenses o Business Tax Related Data

o Permits and Planning and Zoning
Data

7. Inthe Audited Attributes area, click the Add icon.

The Select and Add Audit Attributes dialog box opens.
8. Select the desired attributes.
9. Click OK.

The selected attributes are displayed in the Audited Attributes area.
10. Click Save.

Related Topics
« Implementation Concepts for Audit Policies

 Auditing Custom Object Data
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Auditing Custom Object Data

You can use Oracle Fusion Applications auditing features to configure auditing for user-defined business object
attributes generated by your intake forms.

This topic describes how to:
- Configure business object attribute auditing for specific transaction types.
Run an audit report for specific transaction types.

You use the Oracle Fusion Applications auditing features to set up auditing for Public Sector Compliance and Regulation
business objects.

Transaction-Specific Auditing Scope

A specific transaction type, such as a permit or a planning application are the business objects you can audit. Each
transaction type, such as a permit, contains a limited set of fields that you can audit, which include:
User-defined fields. These are the fields you added manually to your intake form.

Fields from the base view object for that transaction type. These fields are the same for all transaction types,
and they appear in the attributes list regardless if they appear in the intake form or not.

The transaction types included for custom object auditing are:

Permits
Planning and Zoning

Business Licenses

Note: You will see Code Enforcement business objects in the list, but these objects are not supported for auditing at
this time. You can select them but the attributes list will be empty.

You can audit other aspects of transaction data, such as changes to fee schedules and fee items, which is discussed in
another topic. For more information, see Auditing Public Sector Compliance and Regulation Data.

Note: The fields added to your intake forms by the field groups you’'ve added are not currently available to be
audited. Fields added to the intake form by field groups reside in a child table to the base view object for the
transaction type. Auditing fields in child tables is not currently supported.

To determine what fields in a specific transaction are able to be audited, you can use any REST client to submit a
describe for that transaction type. For example, you can send a GET request using the following URL:

https://servername.fa.us2.oraclecloud.com/fscmRestApi/resources/11.13.18.05/LNPFENCEPERMIT c/describe

Where FENCEPERMT is the name of the transaction type. LNP is prepended and _c is appended automatically by the
Intake Form Designer.

The attributes appearing in the returned payload of the describe that can’t be audited appear within the FieldGroups
section. For example:
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“FieldGroups” : {
“discrColumnType” : false,
“title” : “Permit Details”,
“attributes” : [ {

Configuring Business Object Attribute Auditing for a Specific Transaction
Type

I Note: Before you can begin setting up auditing for a specific transaction type, the intake form needs to be published.

To configure auditing for a specific transaction type:

1. Access Functional Setup Manager.

2. Open your licensed offering from the Setup list, such as Public Sector Permits or Public Sector Planning and
Zoning.

3. Select the Application Extensions functional area, and click the Manage Audit Policies task.

Note: You can use the Search Tasks feature as well to navigate to the Manage Audit Policies task.

On the Manage Audit Policies page, locate the Oracle Fusion Applications group box.
To enable auditing, set Audit Level to Auditing.
Click Configure Business Object Attributes.

On the Configure Business Object Attributes page, select Supply Chain Management Common Components
from the Product drop-down list, and expand the FscmCustomReferenceAuditAM node.

NOo U b

Note: The Public Sector Compliance and Regulation offering resides in the Oracle Fusion Applications
Financials and Supply Chain (FSCM) database. When searching for Public Sector Compliance and Regulation
custom business objects, you will find them within the Supply Chain Management Common Components
section. If you are also an Oracle FSCM customer, you will see FSCM business objects mixed with your Public
Sector Compliance and Regulation products within the FscmCustomReferenceAuditAM node.

8. Click the business object for which you want to configure auditing.

The business object name is the same as your transaction type code, such as the Permit Type value on the
Permit Type page.
9. With the business object selected, select Actions > Create in the Attribute column on the right.
10. In the Select and Add Audit Attributes dialog box, select the attributes you want to audit.

Note: The attributes available are limited to the base view object values and the custom fields you have
added to your form.

11. Click OK.
12. Save your changes.

For more information, see the Oracle Fusion Applications documentation on business object auditing.
Running an Audit Report
To run an audit report:

1. Select Navigator > Tools > Audit Reports.
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For Date, specify a date or date range for your audit report.

Select Supply Chain Management Common Components from the Product drop-down list.

From the Business Object Type drop-down list, select the permit type name for which you enabled auditing.
Use the Date, User, and Event Type criteria to refine your search, as needed.

6. Click Search.

For more information see the Oracle Fusion Applications documentation for audit reports.

v A WN

Viewing Audit History
You use audit history to view changes to the application data such as the business objects that were created, updated,
and deleted.

Before you begin, you must have a role with the assigned privilege View Audit History
(FND_VIEW_AUDIT_HISTORY_PRIV). For appropriate assignment of roles and privileges, check with your security
administrator.

To view the Fee Schedule audit history or to create a report:

1. To open the Audit History work area, select Setup and Maintenance > Navigator > Tools > Audit Reports .
2. Enter the following search values:

Audit Reports Search Field Value

Date Enter the date for the audit results you want to see.
Product Select Public Sector Common Components.
Business Object Type o Fee Transactions

o Fee Schedule

o Common Transaction Data

3. Select the option to Include child objects.
The default search displays a summary of the audit history in the search results table. It includes key data such as date,
user, product, event type, business object type, and description. For a detailed report, search again with modified search
criteria. You can export the report summary to Microsoft Excel.

Search Parameter Result of Selection

Business Object Type - Narrows the search results to that specific business object within the selected product.

Enables the Show Attribute Details check box.
Note:
This parameter is applicable only for the
business objects that belong to Oracle
Applications Cloud.
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Search Parameter

Include Child Objects

Show Impersonator

Show Attribute Details

Show Additional Object Identifier
Columns

Result of Selection

Displays all the child objects that were listed for that business object when audit was set up. For
example, a sales order object that contains several items as child objects.

Note:
Displays the objects at the immediate parent-child level only. To view the children at subsequent
levels, select the child object as the business object type and search again.

Displays the details of the impersonator who modified the objects during an impersonation session.

Enables the attribute list so that users can select either all attributes or a specific attribute to view the
changes. Based on the selection, the search results indicate whether the attribute is created, updated,
or deleted, and the corresponding old and replaced values.

Displays the instances (contexts) in which the business object was used. The context values identify
the objects and the transactions in which they were used. Each context is unique and assigns a unique
description to the business object.

Note: The default report displays a standard set of columns that contain prominent details of the audit history. To
view additional details, you can change the display of columns.
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12 Modifying Existing Application Pages

Overview of Existing Page Modification
This topic provides an overview of how you can modify an existing page delivered by Oracle in a Public Sector
Compliance and Regulation offering.

You can use the Configure Page feature to modify specific attributes of an existing page delivered by Oracle in a Public
Sector Compliance and Regulation offering. You can make these modifications:

- Change field labels.
Hide fields.

Note: In the current release, you can modify only the Parcel Details page.

Examples of page modifications include:

- Suppose the existing page has a field label that doesn’t correspond to the terminology used in your agency.
Suppose the delivered field label is Flood Zone, but your agency uses Flood Zone Code. You can use the
Configure Page option to modify the label.

- Suppose the existing page contains a field tracking information your agency does not track, such as the Patio
field. You can use the Configure Page feature to hide that field.

Access Page Edit Mode

This topic describes how to access edit mode for existing application pages that you can modify.
Before accessing edit mode, make sure you are signed on with a user who is assigned one of the following job roles:

PSC Business Analyst
PSC System Administrator

Also, make sure the existing page supports configuration. Not all existing pages can be modified. Pages that can be
modified display the Configure Page icon in the global header.

I Note: In the current release, you can modify only the Parcel Details page.

This example illustrates the Configure Page icon, which is described in the surrounding text.

Click the Configure Page icon to launch page edit mode.
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Use the Page Edit Mode Interface

This topic describes the features and controls you can use to modify an existing application page.

To access the page edit mode, click the Configure Page icon in the global header. For more information see Access Page
Edit Mode.

This example illustrates the user interface of the page edit mode. Details are in the surrounding text.

Parcel Details | Status: published Toolbar Save Cancel

Field Attributes

Subdivision Flood Zone Code

P Field Details

Workspace Soil Type Atiributes Panel

When in page edit mode, the interface consists of these items:

- Toolbar
- Workspace

- Attributes Panel

Using the Toolbar

The toolbar spans the top of the interface below the global header and displays the following information and controls.

Page Element Description
Page Name Displays the name of the page as it appears in the application, such as Parcel Details.
Status Indicates the status of the current page.

- Draft: indicates the page is currently being edited, but the current changes are not available for
general use. Draft mode becomes enabled when you click Save when editing a page.

- Published: the page is available for general use with the most current modifications included. In
the development or testing environment, a published page is available for developers and testers
to access and test. In the production environment, a published form is available for end users to
access.
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Page Element

Save

Publish

Cancel

Close

Manage Sandbox

Using the Workspace

Description

Note:
The status is displayed only if you are modifying the page or you have previously modified and
published the page.

Saves the current changes to the page to store them, without publishing them. Clicking Save puts the
page in draft mode.

Click to create a sandbox and publish the current changes in the sandbox so that the page reflects the
changes for runtime access and use.

Note:
The Publish button is available only after your have clicked Save.

Click to exit the edit mode without saving or publishing any changes.

Click to exit edit mode.

The Close button appears when there is no change on the page to be saved or published, such as after
you have just published page modifications.

Click to access the Oracle Fusion Applications Sandboxes page where you can view the status of your
sandbox and refresh your sandbox if needed.

When modifying an existing page, the sandbox exists only during the publishing process request.
While you modify a page and save any changes, the system tracks your changes in an internal

metadata storage object. When you click Publish, the changes are added to the sandbox, and the
sandbox is published.

Note:
The Manage Sandbox button appears only if the sandbox associated with your form layout becomes
out of sync during a publish request, requiring a refresh.

Identify the sandbox for your page modifications according to this naming scheme:
PSCSC_<page name>__sb_<number of publish requests>

For example:

PSCSC_ParcelDetailsInformation__sb_2

For more information on sandboxes, see Working with Sandboxes.

The workspace displays the content of the page that you can modify. Select a field on the page to display its attributes in

the Attributes panel.

ORACLE

257


http://www.oracle.com/pls/topic/lookup?ctx=pscr21a&id=concept_WorkingWithSandboxes

Oracle Public Sector Compliance and Regulation Cloud Chapter 12
Implementing Compliance and Regulation Modifying Existing Application Pages

Using the Attributes Panel

The Attributes Panel contains the attributes you can modify for a selected page element, such as a field.
This example illustrates the Field Attributes panel when modifying existing pages. Details are in the surrounding text.

Field Attributes

4 Field Details

ParcelVO

ParcelType
Note: In the current release, only fields can be modified on an existing page.

You can view and set these field attributes:

Page Element Description
Label Use to modify the existing label for the page.
Note:

The length limit for modified field labels on existing pages is 100 characters.

Note:

Do not change the meaning of a field label in an attempt to use it to reflect a value different from its
intended purpose. For example, don’t change “Flood Zone” to “School Zone.” Each field may have
logic behind it, dependencies in workflow, dependencies related to fees, and so on. The ability to
change field labels is intended to support minor changes in terminology.

Hidden Use to hide a field on the existing page. When the switch is on, the associated field is hidden.

Note:
Fields that are set to be required can’t be hidden.

Business Object The name of the database view object associated with the page.

Field Name The name of the field as it appears in the REST payload, which you can view using a describe
command for the associated REST resource.
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The Business Object and Field Name values are read-only values provided for informational purposes to help
implementation teams assess any areas affected by a page modification, which affects:
- Sub pages using the same view object field
Reporting
- Auditing

Note: Changes made to a field on an existing page may affect fields appearing within field groups added to intake
forms if they share the same view object.

Modify Existing Pages

This topic describes the steps in the procedure for modifying an existing page delivered in an Oracle Public Sector
Compliance and Regulation offering.

Change Labels

To change a a label:

Navigate to the page you want to modify.

Click the Configure Page button in the global header.

In the workspace, select the field you want to modify.

In the Field Attributes panel, enter your modified label in the Label field.
Click Save.

Click Publish.

Hide Fields

To hide a field:

cuhAhUNA

Navigate to the page you want to modify.

Click the Configure Page button in the global header.

In the workspace, select the field you want to hide.

In the Field Attributes panel, turn on the Hidden switch.
Click Save.

Click Publish.

CUAWNRA

After you have hidden a field, the layout in page edit mode displays the field within a box with a hidden icon
next to the hidden field to indicate its hidden runtime status.

This example illustrates a field on an existing page that has been hidden.

@, Patio
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Managing Existing Page Modifications

This topic describes concepts necessary to keep in mind when migrating existing page modifications between
environments, such as from the test environment to the production environment.

Similar to migrating transaction types from one environment to another, the data related to page modifications gets
migrated in multiple parts using these features:

- Functional Setup Manager’s export and import feature.

- Configuration Set Migration feature, which you access using the Functional Setup Manager step “Manage
Existing Page Modifications” in the System Administration functional area.

Note: The Configuration Set Migration feature migrates all published sandbox changes, not just the modifications to
existing pages. For example, current intake form changes and branding image changes will also be migrated in the
configuration set.

Related Topics
» Managing Transaction Type Configurations
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15 Managing Mobile Applications

Managing Mobile Application Offline Settings

This topic describes how to enable and configure offline data caching for the Oracle Inspector mobile application.

You can enable offline data caching for the Oracle Inspector mobile application. When enabled and the mobile
application is online, inspectors can download to the mobile application the data they will need while completing
inspections offline. While offline, the mobile application refers to the cached data to complete the inspection and make
the necessary updates.

The mobile application tracks each update while it is offline, and when the mobile application is back online, the mobile
application automatically synchronizes with the agency data and makes any updates to the agency data.

To enable and configure offline data caching, access the Mobile Offline Configuration page by selecting Common
Setup > Mobile Offline Settings.

Page Element Description

Enable Offline Data Caching Turn on to enable offline data caching for the Oracle Inspector mobile application.

When enabled, the mobile application can download required data for offline tasks.

Note:
By default, offline data caching is enabled for the mobile application. If the inspector doesn’t want to
use offline data, then the option needs to be disabled explicitly.

Check for Updates Set an interval in minutes for the mobile application to check for updates to the cached data. If any
updates are found, the mobile application downloads them automatically.

Days to Cache Before Today Set the number of days of previous inspection data to cache on the device.
Typically, inspectors using the mobile application won’t need all the historical data stored by an agency,
but they will need an optimal window of recent data to have accessible for offline processing or

reference.

For example, if this value is set to 2, then the mobile application caches the inspection-related data for
the current day (Today) and the previous 2 days.

Note:
The current day (today) is always cached.

Days to Cache After Today Set the number of days of scheduled inspections to cache after the current day (today).

For example, if this value is set to 2, then the mobile application caches the inspection-related data for
the current day (today) and inspections scheduled on the next 2 days.
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Page Element Description
Note:

The current day (today) is always cached.

Days to Retain Cache Set the amount of days to retain the cache within the mobile application after download.

Cache Refresh Period in Hours Set the period in hours for the mobile application to refresh the cached data automatically if online.

For example, if the inspector logs into the mobile application at 9:00 AM in the morning, it will
download the data based on the offline settings. On the following day, again at 9:00 AM when the
inspector logs into the application the data will be downloaded.

Note:
Inspectors can refresh the cache manually, as needed, from the Oracle Inspector mobile application.

When you enable mobile offline data caching, consider the following items:

- The amount of free space on the device determines the amount of cache that you want to download to the
mobile device. The amount of space required for a typical amount of inspection-related data for 3-5 days can
be approximately 50-100 MB, however, when attachments are involved the cache consumes more space.

- The mobile application attempts to synchronize the mobile device with the agency data every five minutes,
regardless whether the device is online or not.

- Each inspection is a separate unit of work. If there is a synchronization issue for one inspection, that issue does
not have an impact on the other inspections.
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