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Preface

This preface introduces information sources that can help you use the application and this guide.

Oracle Cloud Applications Guides

To find guides for Oracle Applications, go to the Oracle Help Center at http://docs.oracle.com/

Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at http://
www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For
information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/
lookup?ctx=acc&id=trs if you are hearing impaired.
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1 Implementing Compliance and Regulation
Using Functional Setup Manager

Using Functional Setup Manager

This topic discusses how to use the Functional Setup Manager.

Oracle Functional Setup Manager provides an integrated, end-to-end process for functional administrators to manage
the implementation and maintenance of Oracle Public Sector Compliance and Regulation services.

Business users configure features and manage setup data using the Functional Setup Manager. Subscription to
offerings, enabling functional areas, opting in features, and setting up guided end-to-end tasks pertaining to the
offerings are all driven through the Functional Setup Manager.

To view the Public Sector offerings and their functional areas in Functional Setup Manager:

1. Select Navigator > Setup and Maintenance or select the Setup and Maintenance tile on the springboard.
2. Select a Public Sector offering from the Setup drop-down list.

The page lists all the functional areas on the left and the corresponding tasks on the right.

Note: When configuring your offering using Functional Setup Manager, configure the functional areas in the order
they appear in Functional Setup Manager from top-to-bottom. Functional areas depend on the configuration data for
the functional areas appearing before them in the list.

Documentation Help Links

You enable Help links in Functional Setup Manager during your implementation so that you can directly access related
documentation. To enable Help links:

1. Select Navigator > Setup and Maintenance or select the Setup and Maintenance tile on the springboard.
2. Select a Public Sector offering from the Setup drop-down list.

The page lists all the functional areas on the left and the corresponding tasks on the right.

3. Click View in the Task section and select Columns > Help . This option is turned off by default.

4. To view Help icons in the tasks list, select the Settings and Actions button in the header and click Show Help
Icons.

For a detailed understanding of the Functional Setup Manager, see the documentation Using Functional Setup
Manager.

Setting Up Transactions Using Functional Setup
Manager

This topic provides the list of required tasks for the implementation of Public Sector Compliance and Regulation
offerings, which are organized under the functional areas in the Functional Setup Manager (FSM).
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You must complete the tasks in these task lists to add the required setup data, configuration settings, and processes
that your agency will use across all Oracle Public Sector Compliance and Regulation services.

Functional Area Task List
Initial Users Define Initial Users for Public Sector
Agency Profile Define Foundation Data

Define Calendars for Public Sector

Define Schedules

Define Agency
Solution Packages Import Solution Packages
Fees and Payments Set Up Billing

Set Up Payments

Inspections Define Inspections

ORACLE

Description

Prepare the groundwork for defining access
through roles and privileges for the users who
will access your service. Tasks include running
the user and role synchronization process,
creating implementation users, setting the
next URL target for new users, and running the
Public Sector Security setup process.

Set up general foundational data that will

be used by the agency when conducting
transactions for the community. Tasks include
setting up address formats, city information,
county information, country information,
currencies, units of measurements, and so on.

Set up the Holiday calendar for your agency
to define when your agency is available for
conducting business.

Work schedules establish the days of the

week and daily hours of operation for agency
employees. For example, defining a work
schedule for an inspector establishes when an
inspector can be scheduled for an appointment.

Define fundamental information for an agency,
including the agency ID, agency name, country,
currency, time zone, and so on.

Create a Process Cloud Service Proxy user and
assign the necessary PSCR Proxy user role.

Import Solution Packages from the Solution
Package Library for Permits and Planning and
Zoning applications.

Set up your agency’s billing system. Tasks
include defining invoice forms, setting the auto-
numbering scheme, and selecting bill types.

Configure how payments will be processed
within your agency. Tasks include setting up the
payment gateway, configuring the cash drawer,
defining department and agency payment
processing options, and so on.

Configure the information required for your
inspection system to enable you to define,
organize, and schedule inspections. Tasks
include setting up assessment types, defining
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Functional Area

Plan Review

Permit Types

Accounting

Digital Assistant

Agency Staff

Public Users

Analytics and Reporting

GIS

System Administration

ORACLE
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Task List

Define Plan Review

Define Permits

Define Accounting

Set up and configure Digital Assistant

Define Agency Staff

Define Public Users

Define Reporting for Public Sector

Define GIS

Define Attachments for Public Sector

Define Comments for Public Sector

Setup Manager

Description

rating methods and passing requirements,
configuring inspection calendars, and so on.

Set up the required information for your
agency to review plans associated with permit
applications. Tasks include defining plan
review statuses and setting up the resulting
plan review decision types, such as approved,
rejected, revision required and so on.

Create and configure the types of permits
your agency will offer. Tasks include setting up
permit categories, defining permit statuses,
setting up workflows and fee models, creating
permit types, designing permit application
forms, and so on.

Set up the processing system to be used by
your accounting department. Tasks include
setting up accounts, funds, and ledgers as well
as defining accounting events and rules.

Create and configure digital assistants and their
parameters to suit your agency.

Set up the service to accommodate the
information used to define and support your
agency staff. Tasks include setting up business
units, setting up legal addresses, creating job
titles, configuring staff access, and so on.

Configure how public users will interact with the
implementation of your service. Tasks include
defining terms of use, selecting public user
options, assigning roles to define public user
access, and so on.

Add or modify parameters associated with
delivered reports to filter data per your
requirements.

Configure the integration between your
service and the GIS application. Tasks include
managing map profiles and mapping GIS
attributes.

Define categories and subcategories for files,
such as plans and images that are attached to
pages as part of the permit application process.

Configure the comments feature that will
be used throughout the permit application
process. Tasks include setting up comment
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Functional Area

System Administration

Branding

Planning and Zoning Application Types
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Task List

Define Communication for Public Sector

Define Lookup Values for Public Sector

Define Conditions for Public Sector

Define and Assign Themes

Define Tiles

Define Summary Details

Define Alerts

Define Planning and Zoning Application Types

Setup Manager

Description

categories, adding and modifying standard
comments, and so on.

Delivered communication events are triggered
by transactions and processes within the
application. For example, scheduling an
inspection triggers the "Inspection Scheduled"
communication event. You can define the
content and recipients of the communication
events using communication templates.

Add and change values that appear in lookup
lists. Lookup lists are referenced by various
fields in the application and display a static set
of values from which the end user can select a
value when entering information.

Add, modify, or remove a dependency or
contingency for completing the permit process.
Conditions are defined with a severities that can
affect the permit process when applied.

Create custom branding themes for your
agency to reflect your desired look and feel.
Tasks include adding logo images, modifying
header and footer colors, designing your
welcome banner, and so on. Once a branding
them is created, you then assign it to apply its
attributes.

Tiles are the icons that appear on the Agency
Springboard and public landing pages.

Users click tiles to access selected pages and
transactions. You can configure which tiles
appear, hide tiles, modify tile labels, and so on

Define the summary section that appears on
the public landing pages. The summary section
includes a summary title, summary text, and

a Read More button that links either to a more
detailed message that you define or to an
external URL.

Add, modify, and enable alert messages that
will appear on the Agency Springboard and
public landing pages to notify users of timely
information.

Define application groups, categories,
subcategories, record statuses, fee schedules,
document categories, and planning and zoning
application types for agency.
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Functional Area Task List
Public Hearing Define Public Hearings
Incidents and cases Set up and configure code enforcement

Incidents and cases

Business License Types Define Business License Types

Setup Manager

Description

Define public hearing calendars and escalation
path for agency.

Reported code enforcement incidents are
inspected and violations are processed as
cases.

Define and manage autonumber rules for
incident, case, notice, citation, and inspection.

Manage inspection counts, referral bodies, time
rules, corrective actions, and code references.

Create and configure the types of business
licenses your agency will offer. Tasks include
setting up business license categories, defining
business license statuses, setting up workflows
and fee models, creating business license types,
designing business license application forms,
and so on.

Note: In addition to the above, there are optional task lists and tasks available under the functional areas in FSM.

Migrating Data From Your Test Environment to Your

Production Environment

This topic describes the utilities used to migrate setup data from your test environment to your production

environment.

In your pod you have these environments:

Environment Description

Test The test environment is where you learn about the product, enter your setup and configuration data,
and test your changes. For example, this is where you add the data for setting up your agency, create
your permits, specify branding modifications for your site, and so on.

Production The production environment is the environment your agency employees and your end users access
to complete transactions. The production environment reflects the “finished product” of what was

configured and tested in the test environment.

After you have made changes and tested them in the test environment, you then migrate any changed metadata and
setup data from your test environment to your production environment. You use the Functional Setup Manager export

and import utilities to complete these tasks.
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For more information on the Functional Setup Manager export and import utilities, see Using Functional Setup
Manager: “Exporting and Importing Setup Data”.

For more information on managing transaction type data, see:
- Managing Transaction Type Configurations.

- Oracle Public Sector Community Development: Test to Production (Doc ID 2551940.1) on My Oracle Support.
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2 Setting Up Geographical Information

Importing Geographies

Use the Manage Geographies task to import geographical information.

The Manage Geographies task of the Agency Profile functional area in Oracle Functional Setup Manager enables you to
import geographies into your interface tables. For detailed instructions on importing geographies, see How You Import
Geographies.

Importing geographies automatically populates data for the following tasks:

- Manage Countries (Setting Up Counties)

- Manage States (Setting Up States)

- Manage Counties (Setting Up Counties)

- Manage Cities (Setting Up Cities)

- Manage Public Sector Currencies (Setting Up Currencies)

Setting Up Countries

A country definition includes the country name and various identifying codes.

You add, modify, and delete countries on the Country page.

Adding a Country

1. Select Common Setup > Country .
2. Onthe Country page, click Add.
3. Onthe Country Details page, enter values for the following fields:

Page Element Description

Country Code Enter a the unique code that your system uses for the country. For example, you might
enter FRA for France.

ISO Alpha 2 Code Enter the two-letter International Organization of Standardization (ISO) code for the
country. For example, you would enter FR as the code for France.

ISO Numeric 3 Code Enter the three-digit United Nations (UN) M.49 code for the country. For example, you
would enter 250 as the code for France.

Country Name Enter the name of the country as it appears in your system.
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Page Element Description
4. C(lick Save.

Modifying a Country

1. Select Common Setup > Country .
2. Click a row on the Country page.
3. On the Country Details page you can:

o Update the country field values.
Note: You cannot edit the Country Code.

o Delete the country. You will be prompted to confirm the permanent deletion.

4. C(lick Save.

Deleting Countries

Select Common Setup > Country .

Click Edit.

Select the check boxes next to all the countries you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PUWNA

Setting Up States

A state definition includes information such as the state name, country, and various ID codes.

You add, modify, and delete states on the State page.

Adding a State

1. Select Common Setup > State .
2. On the State page, click Add.
3. On the State Details page, enter values for the following fields:

Page Element Description

Country Enter the code for the country that the state is in.

State Code ISO Enter the International Organization of Standardization (ISO) code for the state.
Code Enter the unique code that your system uses for the state.

ORACLE
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Page Element Description
State Name Enter the name of the state.
Type Enter the subdivision type.
GNIS ID Enter the Geographic Names Information System (GNIS) ID for the state’s location.
4. Click Save.

Modifying a State

1. Select Common Setup > State .
2. Click a row on the State page.
3. On the State Details page you can:

o Update the state field values.
Note: You cannot edit the Country or State Code ISO fields.

o Delete the state. You will be prompted to confirm the permanent deletion.

4. C(lick Save.
Deleting States
1. Select Common Setup > State .
2. C(lick Edit.
3. Select the check boxes next to all the states you want to delete.
4. C(lick Delete. You will be prompted to confirm the permanent deletion.

Setting Up Cities
A city definition includes information such as the city name, country, state, and certain ID codes.

You add, modify, and delete cities on the City page.

Adding a City

1. Select Common Setup > City .
2. On the City page, click Add.
3. On the City Details page, enter values for the following fields:

Page Element Description

Country Code and State Code Enter the codes for the country and state in which the city is located.

ORACLE
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Page Element Description
County Enter the five-digit International Committee for Information Technology Standards

(INCITS) code for the county in which the city is located.

FIPS Code Enter the seven-digit Federal Information Processing Standard (FIPS) code for the city.
City Name Enter the name of the city.
GNIS ID Enter the Geographic Names Information System (GNIS) ID for the city’s location.

4. Click Save.

Modifying a City

1. Select Common Setup > City .
2. C(lick a row on the City page.
3. On the City Details page you can:

o Update the city field values.
Note: You cannot edit the Country Code, State Code, or County fields.

o Delete the city. You will be prompted to confirm the permanent deletion.

4. C(lick Save.
Deleting Cities
1. Select Common Setup > City .
2. Click Edit.
3. Select the check boxes next to all the cities you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Counties

A county definition includes information such as the county name, country, state, and certain ID codes.

You add, modify, and delete counties on the County page.

Adding a County

1. Select Common Setup > County .
2. Onthe County page, click Add.

ORACLE
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3. Onthe County Details page, enter values for the following fields:

Page Element Description
Country and State Enter the codes for the country and state that the county is in.
INCITS Code Enter the five-digit International Committee for Information Technology Standards

(INCITS) code for the county.

County Name Enter the name of the county.
FIPS Code Enter the seven-digit Federal Information Processing Standard (FIPS) code for the
county.
GNISID Enter the Geographic Names Information System (GNIS) ID for the county’s location.
4. C(lick Save.

Modifying a County

1. Select Common Setup > County .
2. Click a row on the County page.
3. On the County Details page you can:

o Update the county field values.

Note: You cannot edit the Country, State, or INCITS Code fields.

o Delete the county. You will be prompted to confirm the permanent deletion.
4. C(lick Save.

Deleting Counties

Select Common Setup > County .

Click Edit.

Select the check boxes next to all the counties you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PUWNa

Setting Up Currencies

A currency definition includes currency codes, a description, and the number of decimals that can be used to represent
an amount in the currency.

You add, modify, and delete currencies on the Currency page.

n
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Adding a Currency

1. Select Common Setup > Currency .
2. Onthe Currency page, click Add.
3. On the Currency Details page, enter values for the following fields:

Page Element Description
Currency Code Enter a the unique code that your system uses for the currency.
ISO Code Enter the three-digit International Organization of Standardization (ISO) 4217 numeric

code for the currency. For example, you would enter 840 for the US dollar.
Description Enter a short description of the currency.

Decimal Position Enter the number of decimal places that can be used to represent an amount for the
currency. For example, the United States dollar uses two decimal positions.

4. C(lick Save.

Modifying a Currency

1. Select Common Setup > Currency .
2. Click a row on the Currency page.
3. Onthe Currency Details page you can:

o Update the currency field values.

Note: You cannot edit the Currency Code field.

o Delete the currency. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Currencies

Select Common Setup > Currency .

Click Edit.

Select the check boxes next to all the currencies you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PUOUNA
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5 Setting Up Your Agency

Setting Up Agencies

An agency is an organization that offers a range of services to its constituents, including issuing permits and licenses.

Administrators add and modify agency information using the Agency page.

Set up exactly one agency, with agency ID 7. Oracle does not currently support multiple agencies.

Adding an Agency

1. Select Common Setup > Agency .
2. Onthe Agency Information page, click Add.
3. Onthe Agency Information - Details page, enter values for the following fields:

Page Elements

Agency ID

Name and Description

Country

Currency

Time Zone

Time Format, Date Format, and

Number Format

Parcel Owner Format

ORACLE

Definition

Enter the number 7 as the ID for your agency.

Enter a name and a short description for the agency.

Enter the country in which the agency is located.

This value is informational only. Address fields throughout the system support only USA
addresses.

Enter the currency that the agency uses for financial transactions.

This value is informational only. It does not affect the currencies for fees, cash drawers,
or payment adaptors.

Select your agency’s local time zone. All times displayed in Oracle Public Sector
Compliance and Regulation use this time zone.

Select the default formats that the agency uses to display times, dates, and numbers for
anonymous users.

This field is reserved for future functionality. Currently, regardless of your selection,
parcels have one field to identify the parcel owner and an additional field to identify a
secondary owner.

13
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Page Elements

Hide property owners from public
users

Oracle Policy Automation ID

Business Number Rule

Location Number Rule

4. Click Save.

Modifying an Agency

P WNa

Click Save.

ORACLE

Setting Up Your Agency

Definition

Turn on this switch to hide property owner information from public users.

Enter the unique identifier for an agency-wide Oracle Intelligent Advisor policy model.

Oracle Intelligent Advisor is a separate Oracle product. Oracle Intelligent Advisor policy
models provide logic models for questionnaires that help public users determine which
applications they need to complete.

The policy model that you enter here is used by offerings that do not have an offering-
specific policy model. To specify an offering-level policy definition, select the Features
tab on the Agency Information page, then click the Options link for the offering.

For more information on Oracle Intelligent Advisor, see Overview of Oracle Intelligent
Advisor Configuration.

Select the autonumbering rule to increment numbers for businesses.

Note:

This field is required if the Business Licenses offering is enabled for your agency.
Autonumber rules need to be defined after you create the agency, so be sure to
return to the agency pages to add the business number autonumber rule that you
define.

Select the autonumbering rule to increment numbers for business locations.

Note:

This field is required if the Business Licenses offering is enabled for your agency.
Autonumber rules need to be defined after you create the agency, so be sure to
return to the agency pages to add the location number autonumber rule that you
define.

Select Common Setup > Agency .
Click a row on the Agency Information tab.
Update the agency information field values.
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Adding an Agency Address

1. Select Common Setup > Agency .
2. Click a row on the Agency Information page.
3. Select the Addresses tab, and click Add.
4. Onthe Addresses - Details page, enter values for the following fields:
Page Elements Definition
Address ID Enter a unique ID for the address.
Primary Select to indicate that this is the primary address for the agency. An agency may have
only one primary address.
From Date and To Date Enter the date range for which the address is valid.
Address Fields The agency address. The Country field displays US.
As you enter a Postal Code, the type-ahead list shows values that include appropriate
city and state combinations. After you select a value, the city and state appear as read-
only fields, and two address fields appear so that you can enter the rest of the address.
If you don’t know the postal code, click the Don’t know link to display a full set of
address fields.
5. Click Save.

Modifying an Agency Address

Select Common Setup > Agency .

Click a row on the Agency Information page.
Select the Addresses tab.

Click a row on the Addresses tab. You can:

PUNa

o Update the agency address field values.

Note: You cannot change a primary address row to non-primary. Instead, when you update a non-
primary row to primary, all other address rows are saved as non-primary.

o Delete the address. You will be prompted to confirm the permanent deletion.

I Note: You cannot delete primary address rows.

5. Click Save.

Deleting an Agency Address

1. Select Common Setup > Agency .
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Click a row on the Agency Information page.

Select the Address tab.

Click Edit.

Select the check boxes next to all the agency addresses that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

ocunpuwN

Note: You cannot delete primary address rows. To delete an address row that is designated as primary, you must first
designate a different address row as primary. This changes the previously primary row to non-primary, allowing it to
be deleted.

Adding Agency Languages

For information on adding languages and establishing language defaults for an agency, see Setting Up Languages.

Configuring Agency-Level Options for Specific Offerings

The Features tab lists offerings that are enabled in Functional Setup Manager (FSM). Because features are enabled
in FSM, you can ignore the Integration Enabled field on this page. Use the Options link to configure offering-specific
settings.

The Permits offering encompasses both Permits and Planning and Zoning. For more information about configuring
Permit and Planning and Zoning options, see Setting Up Agency-Level Options for Permits.

For more information about configuring Code Enforcement options, see Setting Up Agency-Level Options for Code
Enforcement.

Enabling Subledger Accounting

1. Select Common Setup > Agency .
2. Click the row for your agency on the Agency Information page.
3. Select the Oracle Financials tab.

Note: This tab appears only if you select Financials Cloud Subledger Accounting as your accounting
framework option in Functional Setup Manager. For more information, see Selecting an Accounting
Framework.

4. Turn on the Create Subledger Accounting switch.
5. Select your agency’s ledger in the Financials Cloud Ledger field.
6. Click Save.

For more information on Oracle Financials Cloud Subledger Accounting, see Oracle Financials Cloud Implementing
Subledger Accounting and Oracle Financials Cloud Using Subledger Accounting

Setting Up Related Transaction Linking

The Related Transactions tab allows you to set up access for your users to link their applications with other related
transactions. You control the way related transactions are linked with applications based on whether an applicant or a
contact user is working with the application.

Select Common Setup > Agency .

Click the row for your agency on the Agency Information page.

Select the Related Transactions tab.

Select the check boxes for applicants and contacts to allow linking related transactions:

PUWNA
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o Applicants can link transactions to only their own applications

o Applicants can link transactions to any application

o Contacts can link transactions to any application that they manage

o Contacts can link transactions to any other application

Note: If no option is selected, then the Link and Actions options will not be available for applicants and
contacts on the Related Transactions page.

5. Click Save.

See Working with Related Transactions.

Setting Up Languages

Add languages and establish language defaults for your agency.

To enable user language preference and locale support for PSCR you must:

1. Define the supported languages for your agency.
2. Define the default language for anonymous user setup.

Adding Supported Agency Languages

Supported languages are available for users to select as the default language on the My Preferences page accessed
from the profile icon in the global banner. Additionally, you must select one supported language as the default language

for anonymous user setup.

Click Add.

A WN

Page Elements

Language

Primary

From Date and To Date

6. Click Save.

ORACLE

Select Common Setup > Agency .
Click the row for your agency on the Agency Information tab.
Select the Languages tab.

Enter values for the following fields:

Definition

Select the language you want to add.

Select to indicate that this is the primary language for the agency. An agency may have
only one primary language.

Enter the date range for which the language is valid.

17


http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=WorkingWithRelatedTransactions

Oracle Public Sector Compliance and Regulation Cloud Chapter 3
Implementing Your Agency Setting Up Your Agency

Define the Default Language for Anonymous User Setup

PUWNa

Access FSM by selecting Setup and Maintenance in the navigator.

Select a PSCR offering such as Public Sector Permits or Public Sector Planning and Zoning.
Select the Application Extensions functional area.

Select the Manage Applications Core Administrator Profile Values task.

This is an example of the Manage Applications Core Administrator Profile Values page.

Manage Applications Core Administrator Profile Values @ Save | Save and Close || Cancel
4 Search : Profile Option
Profile Option Code | FND_LANGUAGE Appiication

Profile Display Name Hodule v

Category

uuuuuuuuu

Search Results
4 Search Results : Profile Options
Vieww (& Detach
Profile Option Code Profile Display Name Application Module StartDate  EndDate  Description

FND_LANGUAGE Default Language. Oracle Middleware Exten...  Application Common 428109 Speciy the default anguage, which can also be setin preferences

4 FND_LANGUAGE: Profile Values

Adions v Viewv 4 X E 7 Detach

* Profile Level Product Name User Name. a9 Profile Value

ste [menanEngen g

Enter FND_LANGUAGE in the Profile Option Code field and click Search.

Add a profile value with a Profile Level of Site and a Profile Value of the supported language that you want to
establish as the default.

Click Save and Close.

Setting Up Agency Integrations

Add Oracle Integration Cloud (OIC) integrations for your agency.

Adding an Agency Integration

You can define and enable the OIC integrations on the Integrations tab of the Agency Information page. For example,
you can add an integration that publishes your agency's accounting information to OIC where it can be transformed and
imported by third-party applications.

For more information on publishing accounting information to OIC, see Setting Up OIC to Publish Public Sector
Accounting Information (Doc ID 2784020.1) in My Oracle Support.

VRUWUNA

Select Common Setup > Agency .

Click the row for your agency on the Agency Information tab.
Select the Integrations tab.

Click Add.

Enter values for the following fields:

Page Elements Definition

Integration Type Select the type of integration that you want to add.
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Page Elements

Integration Name and Integration
Version

Integration Parameter

Integration Enabled

6. Click Save.

Setting Up Your Agency

Definition

Note:
Currently, the only valid value for this field is Publish Accounting, which enables you
to publish your agency's accounting information to OIC.

Enter the exact name and version number of the OIC integration that you want to add
for your agency.

This field is reserved for future use. It is not used for publishing accounting information.

Turn this switch on to enable the integration.

When a Publish Accounting integration is enabled, the Export Journals to ERP process
publishes accounting information to OIC. For more information on the Export Journal to
ERP process, see Exporting Journal Entries.

Setting Up Conditions

A condition indicates a dependency or contingency for completing the application process. You set up, modify, and
delete condition definitions on the Conditions page.

Conditions Overview

A condition indicates a status, criterion, or action that you can apply to an object in the system, such as an address,

parcel, person, or transaction.

Conditions are defined with a severity that might affect operations when applied. Condition rules with a Hold severity
prevent one or more of the operations that are selected at the time of applying the condition. Condition rules with a
Lock severity prevent all operations as described in the table here.

Rule

Prevent Application Progress

Prevent Workflow Advancement

ORACLE

Applicable Objects Usage

Address, Parcel, and Person Agency staff applies a condition to a record that
prevents an applicant from submitting any new
permit or planning application that contains the
address, parcel, or person.

Address, Parcel, Person, and Transaction Agency staff applies a condition to a permit
or planning application record that prevents
workflow from advancing. The permit or
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Rule Applicable Objects Usage

planning application workflow tasks cannot be
completed until the condition is resolved.

Prevent Issue or Final Address, Parcel, Person, and Transaction Agency staff applies a condition to a permit or
a planning application record that prevents the
permit or application cycle from completing its
final step until the condition is resolved.

Your workflow process definition must explicitly
identify the final human task that is blocked by
this condition. Use the PSC_FINAL_ACTIVITY
custom property to identify this task. See Using
Custom Properties.

Prevent Payment Address, Parcel, Person, and Transaction Agency staff applies a condition to a permit or a
planning application record that prevents a user
from processing a payment.

Prevent Inspection Schedule Address, Parcel, Person, and Transaction This condition rule prevents agency staff from
scheduling a new permit inspection. It does not
affect existing inspections that have already
been scheduled.

Prevent Inspection Result Address, Parcel, Person, and Transaction This condition rule prevents agency staff from
finalizing the permit inspection results.

Prevent Final Inspection Address, Parcel, Person, and Transaction Agency staff applies a condition to a permit
to prevent adding or proceeding with a final
inspection.

Setting Up and Applying Conditions Using Business Rules Framework

The Business Rules Framework enables you to set up conditions that should apply to a permit or planning application
based on the criteria you define in the business rules.

You must configure the Workflow to trigger the Business Rules Framework process, which in turn applies the condition
to the submitted transaction. The submitted applications are listed in the Transactions page with the conditions applied,
ready for further processing.

Note: Ensure that the appropriate workflow definition is set up for the permit or planning application type that will
associate with the condition. See Setting Up Permit Types and Setting Up Planning Application Types.

For more information on adding and configuring events with business rules for conditions, see Setting Up Apply
Condition Actions. For information on viewing the applied conditions and resolving them, see Applying Conditions to
Applications

Viewing Business Rules Information

20
ORACLE


http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=UsingCustomProperties
http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=UsingCustomProperties
http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=SettingUpPermitTypes
http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=SettingUpPlanningApplicationTypes
http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=SettingUpApplyConditionActions
http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=SettingUpApplyConditionActions
http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=ApplyingConditionsToApplications
http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=ApplyingConditionsToApplications

Oracle Public Sector Compliance and Regulation Cloud Chapter 3
Implementing Your Agency Setting Up Your Agency

Apart from the condition information, the condition details page shows the business rules framework information
related to the condition in use:

- Offering: The offering for which the condition is used.
- Event Name: The name of the event that defines the business rules.
- Event Description: The description of the event.

- Rule Name: The name of the rule that defines the criteria and the condition action.
- Enabled: The switch shows if the business rule is enabled for the current condition.

I Note: The Business Rules Framework section is applicable only to conditions with object type Transaction.

Adding Condition Definitions

To add condition definitions:

1. Select Common Setup > Condition .
2. Onthe Condition page, click the Add New button.
3. Onthe Condition Details page, enter values for the following fields:

Page Element Description

Condition Name Enter a unique condition name.

Object Type Select an object type to categorize the condition, based on the object type to which it is
applied:

o Address
o Parcel

o Person

o Transaction

Display Message Enter a message that is displayed to external users, up to 300 characters.
Severity Select a severity level for each condition from these options:
o Lock

At the most severe level, the Lock condition suspends all operations, including
workflow advancing, payment processing, inspection scheduling, and inspection
results.

o Hold

Agency staff can select which rules to apply to conditions with the Hold level of
severity.

o Notice

The Notice level functions as an alert and has no effect on operations.
For more information, see Applying Conditions to Applications.
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Page Element Description

Apply Condition to Transactions Applies the condition automatically to any existing transactions belonging to the
address, parcel, or person. You turn off the switch to disable the condition from
automatically applying to the existing transactions.

Note:
This switch is not available by default for the Transactions object type.

At the time of applying the condition, users can decide to enable or disable the option
on the Condition Details page. See Applying Conditions to Applications.

Condition Rules Select the rules for the condition. Condition rules are applied by default depending on
the severity of the condition:

o Lock severity: All condition rules are automatically applied and no actions can be
taken until the condition is resolved.

o Hold severity: Select one or more default condition rules.
o Notice severity: No condition rules apply.

See the list of available condition rules in the "Conditions Overview" section of this topic.

Priority Select the level of priority for this condition:
o High
o Low
o Medium
Description Enter a description of the condition.
Additional Information Enter any additional information regarding this condition.

4. Verify that the Enabled switch is turned on. New conditions are active by default.

Note: You can't disable or delete the condition if it's being used by the Business Rules Framework to
automatically apply conditions or if the condition is already applied to any object.

5. Click Save.

Modifying Conditions

1. Select Common Setup > Condition .

2. Click a row on the Condition page.

3. On the Condition Details page you can update the display message, severity, description, and the Enable
switch.
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4. Click Save.

Deleting Conditions

You can delete a condition only if it isn't being used. If you try to delete a condition that is applied to a transaction, you
will see an error message stating that you can't remove the condition because it has already been applied.

You also can't delete or disable a condition in the condition setup when the condition is used by the Business Rules
Framework in the Apply Condition action.

1. Select Common Setup > Condition
2. Click a row on the Condition page.
3. On the Condition Details page, click Delete to delete the condition.

Related Topics
- Applying Conditions to Applications

» Applying Conditions to Parcels and Addresses
» Managing Account and Profile Conditions

Setting Up Autonumbering

Set up autonumber rules to increment identifying numbers for documents such as permits and invoices. The identifying
numbers can include multiple parts, and each part can represent either a sequential number, static text, or a date.

You add, modify, and delete autonumber rules on the Autonumber page.

This example illustrates the Autonumber Details page.
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Autonumber Details

Rule Header
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Copy Existing Rule

* Rule Name Sample
* Description Sample
ra
* Maximum Size 17 v A
* Number Type Permit v
Reset Sequential Number Yearly v
Rule Definition
Number of Parts 3 ¥ Next Number Preview PER-1000000-JUL18
Part 1 Statictext ¥ PER Separator - v

Part 2 Sequential ¥ 1000000

Part3  Date ¥ MMMYY

Zero-

) Separator - v
padding

Maximum Length 7

-

Cancel Save

Adding an Autonumber Rule

1. Select Common Setup > Autonumber.
2. On the Autonumber page, click Add.
3. Onthe Autonumber Details page, enter values for the fields in the Rule Header section:

Page Element

Rule Name

Copy Existing Rule

Description

Maximum Size

ORACLE

Description

Enter a unique name for the rule. The name can’t include spaces.

Click this link to copy the rule definition from an existing autonumber rule. The copy
action copies the number type and the reset frequency as well as the actual rule
definition.

Clicking the link opens a a modal window with a list of existing autonumber definitions.

Locate the definition you want to copy, then click the Select button for that definition

Enter a description for the autonumber rule.

Indicate the maximum length of the generated number.
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Page Element

Number Type

Reset Sequential Number

ORACLE
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Description

Note:

As you set up your autonumber rule, take care that the maximum size of the
autonumber accommodates the maximum length of each part of the identifier plus
any separators that you define.

Select the type of object that uses this autonumber rule. When you choose an
autonumber rule for an object, only rules with the appropriate type are available.

These are the available number types:

o Business entity
o Business license
o Case

o Cashier session

Note:
If you select this number type, make sure that the rule uses only Sequential part

types.

o Code inspection

o Deposit slip

o Incident

o Inspection

o Invoice

o Permit

o Planning application
o Project

o Receipt

Note:
You can’t change the number type for a rule that is already in use.

The identifier that an autonumber rule generates can include a mix of static text, a
date, and a sequential number. Select how often the sequential number portion of the
identifier is reset to zero:

o Calendar month: The sequential number resets to zero at the beginning of each
month.

o Calendar year: The sequential number resets to zero on January 1of each year.

o Fiscal year: The sequential number portion resets to zero on the first day of your
fiscal year. When you select this option, the Fiscal Year End Month field appears.
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Page Element Description
o None: Sequential numbers continue to increment as defined without resetting.
Fiscal Year End Month If you reset the sequential number portion of the identifier on the first day of the fiscal

year, select the month when your fiscal year ends. For example, if your fiscal year end
month is June, then the sequential number resets to zero on July 1 of each year.

4. In the Rule Definition section of the page, enter the number of parts, or segments, for the rule:

Page Element Description

Number of Parts Select the number of parts, or segments, comprising the rule, up to 5 parts. Segments
can be static text, a date, or a sequential number.

For example, the identifier IvC-0000010067-0CT10 is made of 3 segments (static text,
then a sequential number, then a date) separated by hyphens. The identifier INVOICE _
001 is made of 2 segments (static text and a sequential number) separated by an
underscore.

When you select the number of parts, the corresponding number of rows appear in the

rule definition grid. For example, if there are two parts, then rows labeled Part 1 and
Part 2 appear.

5. Inthe rule definition grid, select the part type for each row, then enter the related information in the additional

fields that appear.
Part Type Related Information
Static Text In the unlabeled field that appears next to the part type, enter text that remains the
same for all identifiers. For example, enter /VC or INVOICE.
Note:
Do not include spaces in the static text.
Cashier session IDs must be numeric, so don't include any static text in an autonumber
definition with the Cashier Session number type.
Sequential a. Inthe unlabeled field that appears next to the part type, enter the next document

number to use. The number must be 7 or greater. The system increases this
number by one each time a new identifier is generated and saved.

b. Inthe Maximum Length field, Enter the maximum number of digits for the
sequential number. Select a number from one to ten.

c. Select the Zero Padding check box to add zeros before the generated number
to make up the number of digits in the definition. For example, if the maximum
length of this part is 5 digits, and the current number is 15, zero padding formats
this part as 00015.
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Related Information

In the unlabeled field that appears next to the part type, select the date format.

Note:
Don't include dates for Cashier Session autonumbers, which must be numeric only.

The available date formats are made of these date codes in various combination:

o

o

Years: YYYY represents the year with its full four digits, and YY represents the year
by its last two digits.
Month Numbers: MM represents the month as a two-digit number.

Month Abbreviations: MMM represents the month as a three-character
abbreviation in English, such as JAN for January. The values are not translated into
the user’s session language. Formats that include MMM are available only if the
agency'’s language is English.

Days: DD represents days as two-digit numbers. This is the only option for days.

Quarters: Q represents quarters. For example, the code for the first quarter of the
yearis 1.

If you select Fiscal year in the Reset Sequential Number field, all numeric months,
years, and quarters are counted from the beginning of the fiscal year. For example, if
the Fiscal Year End Month is June, then:

]

o]

The MM value for June is 72, for July is 07, and so forth.

The YYYY value is the calendar year when the fiscal year ends. In the year 2025,
January-June are part of the 2024-2025 fiscal year, so YYYY is 2025 during those
months. But July-December of 2025 are part of the 2025-2026 fiscal year, so YYYY
is 2026 during those months.

The Q value for April through June is 4, for July through September is 7, and so
forth.

6. Inthe rule grid, select a Separator to appear after each part except the last.
Select from the following separators:

o (None)

o - (hyphen)

o /(forward slash)
o *(asterisk)

7. Verify the generated number for the selected date format and separators in the Next Number Preview field.

8. C(lick Save.

An error appears if the overall maximum size of the autonumber doesn’t accommodate the maximum lengths
of all of the parts and separators that you define.

Modifying an Autonumber Rule

1. Select Common Setup > Autonumber.
2. Onthe Autonumber page, click the row you want to modify.
3. Update the rule header and rule definition fields on the Autonumber Details page.

ORACLE
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4. Click Save.

Deleting an Autonumber Rule

I Note: You can’t delete autonumber rules that are already in use.

1. Select Common Setup > Autonumber.
2. C(lick the row you want to modify.
3. On the Autonumber Details page, click Delete.

Setting Up Code Types

Code types are specific published codes, guidelines, ordinances, and so forth. Examples might include the International
Building Code, published by the International Code Council (ICC), and the National Fire Code, published by the National
Fire Protection Association (NFPA).

Note: Code types are not currently used in the public sector application.

You add, modify, and delete code types on the Code Type page.

Adding a Code Type

1. Select Common Setup > Code Type.
2. Onthe Code Type page, click Add.
3. Onthe Code Type Detail page, enter values for the following fields:

Page Element Description

Code Type ID Enter a unique code type ID for a specific code type. For example, enter IFC for
International Fire Code.

Name Enter the complete name of the code type.
Description Enter a description of the code type.
4. C(lick Save.

Modifying a Code Type

Select Common Setup > Code Type.

Click a row on the Code Type page.

On the Code Type Detail page you can update the code name and description.
Click Save.

P WUNa
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Deleting Code Types

1. Select Common Setup > Code Type.

2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Code Type

Details page.
3. To delete one or more definitions without viewing details:

a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.

Setting Up Code References

Code references provide detailed specifications that come from a broad range of codes, guidelines, ordinances, and
so forth. Even if the source document does not use the word “code,” use the Code References pages to enter the
information into the system. A code reference maps to a specific section in the source document.

Note: The code references described in this topic are not currently used in the public sector application. To set up
code references for code enforcement, see Setting Up Code References for Code Enforcement.

You add, modify, and delete code references on the Code Reference page.

This example illustrates the Code Reference Details page.

ORACLE
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Code Reference Details

* Standard Type  Electrical v
* Standard Name General

* Code Section  2702.1.4

* Effective Start Date  7/25/18 i
Effective End Date  Open =
* Code Type IBC o}

* Description Load Duration

Ed
URL  https://codes.iccsafe.org/public/docum

Content 10 access instructions, place the cursor in the text editor and press Alt + 0.

Font - | size ~|B I U |« A-B-|Z = «

Emergency power systems shall automatically provide secondary power within 10 seconds
after primary power is lost, unless specified otherwise in this code. Standby power systems
shall automatically provide secondary power within 60 seconds after primary power is lost,
unless specified otherwise in this code.

-

Cancel Save

Prerequisites

Before you set up code references, you must define:

Chapter 3
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- Code types, which represent specific published documents that contain codes, guidelines, and so forth.

See Setting Up Code Types.

- Standard types, which describe the different fields or disciplines that codes relate to. Examples might include

fire safety or electrical systems.

Set up standards types by defining values for the ORA_PSC_CC_STD_CODE_TYPE lookup type. Define these

values on the Lookup Type pages. See Setting Up Lookups.

Adding a Code Reference

1. Select Common Setup > Code Reference.
2. Onthe Code Reference page, click Add.
3. Onthe Code Reference Detail page, enter values for the following fields:

Page Element Description

Standard Type Select the type of standard that the code falls under. Standard types represents fields or

disciplines such as Materials, Engineering, or Installation.

ORACLE
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Page Element

Standard Name

Code Section

Effective Start Date and Effective
End Date

Code Type

Description

URL

Content

4. Click Save.
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Description

Enter the title of the section that contains this code reference. This title comes from the
source document.

Enter the section number for this code reference. The number uniquely identifies this
reference within the source document.

Enter the official effective start date of the code reference, and optionally enter an end
date.

Select a code type from the values that you defined on the Code Type page. The code
type identifies the source document.

See Setting Up Code Types

Enter a description of the reference.

Enter a URL link to the source document.

Enter detailed content copied from the source document.

Modifying a Code Reference

PUWUNA

Click Save.

Select Common Setup > Code Reference.
Click a row on the Code Reference page.
On the Code Reference Detail page, make any necessary changes.

Deleting a Code Reference

-—
.

Select Common Setup > Code Reference.

2. Click a row on the Code Reference page.
3. Onthe Code Reference Detail page, click Delete.

You will be prompted to confirm the permanent deletion.
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Setting Up Project Types

A project type describes the kind of project that an agency staff can select at the time of creating a project. You add new
project types based on the nature of the project you are adding. Selection of a project type is mandatory while creating
a new project, so, a minimum of one project type is required to be set up.

You add, modify, and delete project types on the Project Type page.

Adding a Project Type

1. Select Common Setup > Project Type .
2. On the Project Type page, click Add.
3. On the Project Type Detail page, enter values for the following fields:

Page Element

Project Type

Rule ID

Description

Long Description

Document Group

Description

Enter the type of project, such as Commercial Project or Residential Project.

Select a rule ID. Rule ID is an autonumbering sequence that you set up for a particular
project type. When you are creating a project with a certain project type, a project ID is
generated based on the sequence defined for the project type.

Rule IDs are created using the Autonumber page. For more information, see Setting Up
Autonumbering.

Enter a description of the project type.

Enter a detailed description of the project type.

Select a document group to allow your users to organize the various categories of
attachment files into a grouping.

See Setting Up Document Categories and Subcategories and Setting Up Document
Groups.

4. Verify that the Enabled switch is turned on. The switch is turned On by default for a new project type.

5. Click Save.

Modifying a Project Type

1. Select Common Setup > Project Type
2. Click a row on the Project Type page.
3. On the Project Type Detail page you can:
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o Update the rule ID, description, and long description.

o Turn off the Enabled switch to deactivate the project type.
4. C(lick Save.

Deleting a Project Type

1. Select Common Setup > Project Type

2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Project
Type Details page.

3. To delete one or more definitions without viewing details:

a. Click Edit on the Project Type page.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete. You will be prompted to confirm the permanent deletion.

Note: You can delete a project type only if it is not used by any project. When you attempt to delete a project type
that is used by a project, the Public Sector Cloud Service displays a message that you cannot delete the project type as
it is already in use by a project.

Setting Up Lookups

This topic describes how to add and change values that appear in lookup lists. Lookup lists are referenced by various
fields in the application that display a static set of values from which the end user can select a value.

Lookup Types and Lookup Values Overview

Lookup types in applications are used to represent a set of codes and their translated meanings. To the end users, a
lookup type displays a list of values from which they select values.

You use the Lookup Types page to access lookup types, and you use the Lookup Type Details page to modify lookup
types, add lookup values, and add lookup types, where authorized.

When working with lookups, you deal with lookup types and lookup values.

Lookup Element Description

Lookup Type Alookup type is a static list of values users view to make entries in the application. The application
references a lookup type to display its list of values.

Lookup Value Alookup value is a single item contained within a lookup type. For example, Paid is a lookup value for
the Fee Status lookup type. Lookup types typically contain numerous lookup values.

Lookup types are delivered as seed data for your service. You can only modify selected lookup types, such as Business
Type, UOM Type, Standard Code Type, and so on. Most lookup types are read-only.
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Modifying Lookup Types
Lookup types can be associated with lookup lists on:
- Pages in your offering.

- Predefined field groups added to intake forms.

- User-defined fields added to intake forms.

Note: Lookup lists created for user-defined fields in an intake form can only be viewed from the Lookup Type page
after the form has been published. Managing lookup lists for user-defined fields should be completed only within the
Intake Form Designer.

This example illustrates the Lookup Type page. Details are in the surrounding text.

Lookup Type

+ X Search... o T
Lookup Type Meaning Application Module Configuration Level
ORA_PSC_PER_INS_CONTACT Contact method Permits Permit Inspections Extension >
ORA_PSC_PER_IN5_SIG Inspector Signature Option Permits Permit Inspection Setup System >
ORA_PSC_PER_INS_SYS_STATUS Inspection System Status Permits Permit Inspection Setup System >
ORA_PSC_PER_ORIGINATOR Record Originator Permits Application Intake System >
ORA_PSC_PER_OWNER_SIG Owner Signature Option Permits Permit Inspection Setup System >
ORA_PSC_PER_PUB_USER_ENABLED Public User Enabled Permits Application Intake System >
ORA_PSC_PER_RECORD_STATE Record State Permits Application Intaks System >
ORA_PSC_PER_REC_SYS_STATUS Record System Status Permits Permit Setup System >

Page 2 of8 (9-16 of 62 items) K < 1 3 4 5 .8 > b | Show Default A4

To modify a lookup type:

1. Select Common Setup > Lookups.
On the Lookup Types page use the Search box to filter the lookup types by keyword.

For example, to view the Business Type lookup type, enter business in the Search box.
3. Click on the row for the lookup type you want to view.
4. View the contents of the Lookup Type Details page.

Page Element Description
Lookup Type Identifies the lookup type within the application.
Application Identifies the application that uses the lookup type. For example, Permits, Common

Components, and so on.

Meaning The actual Ul display name used to represent the list of values contained in the lookup
type.
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Configuration Level Indicates at what level the lookup can be modified. Options are:

o System: Only Oracle development teams can modify lookup types at this
configuration level.

o Extension: Customers can perform minimal tasks, such as add lookup values.

o User: Customers can add lookup values, delete lookup values, update the meaning,
and update the description.

Module The internal application module using the lookup type, such as Billing Entry, Billing
Setup, and so on.
Description Identifies the purpose and use of the lookup type.

5. If you need to add lookup values, refer to the following section for steps for that task.
6. Click Cancel to close the lookup type, or click Save if you made any changes.

Adding Lookup Values

This example illustrated the Lookup Value Details page. Details are in the surrounding text.
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Lookup Value Details

* Lookup Code  Public

(%
<
>

Display Sequence

Enabled

Start Date  2018-08-17

End Date 2020-08-17
*

Meaning Public Sector

Description

=,

Cancel Save

You can add lookup values to lookup types with a configuration level set to User or Extension.

To add lookup values:

1.
2.

v AW

Select Common Setup > Lookups.
On the Lookup Types page use the Search box to filter the lookup types by keyword.

For example, to view the Business Type lookup type, enter business in the Search box.
Click on the row for the lookup type you want to view.

On the Lookup Type Details page, click Add under Lookup Value Type.

On the Lookup Value Details page, enter these values:

Page Element Description

Lookup Code An internal application code for each lookup value that is not visible to users. It
is typically a shorter, less user-friendly representation of the item. For example,
ORA_DRIVER_LIC for State Driver’s License, or LEN for Length, if listing units of
measurement.
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Page Element

Display Sequence

Enabled

Start Date

End Date

Meaning

Description

Tag

6. Click Save.

Setting Up Your Agency

Description

Note:
Lookup lists created in the designer for user-defined fields on an intake form begin
with PSC.

Control in what sequence the lookup value appears in the list displayed to users, where
2 appears above 3. If you do not specify a sequence, the application displays the items in
the order they were entered.

Turn on to make a lookup value active. If a lookup value is not enabled, then the
application does not display it to the end user in the list of values for that lookup type.

Note:
It is not recommended to disable lookup values once your implementation is in
production because this can invalidate existing transaction data.

Set a start date for the lookup value to become active. Even if the lookup value is
enabled, if a start date is set, the application does not display the lookup value until the
start date is reached.

Set an end date for a lookup value to no longer be displayed in a list of values.

The display name for the lookup value. End users see this value in the list of values
displayed at run time. They do not see the Lookup Code value.

Provide any additional information to help identify the purpose of the lookup value or
clarification regarding what it represents.

Tags allow you to add a label to your lookup codes. A tag can be used to categorize
lookups based on facilitating searches or guiding how a lookup should be used.

Working with Configuration Levels

The configuration level attribute determines who can modify a lookup type and what can be modified. The

configuration levels are:

- System: Only Oracle development teams can modify lookup types at this configuration level.

- Extension: Customers can perform minimal tasks, such as add lookup values.
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User: Customers can add lookup values, delete lookup values, update the meaning, and update the description.

Task User Extension System
Add a lookup type Yes No No
Delete a lookup type Yes No No
Modify lookup type meaning Yes No No
Modify lookup type description Yes No No
Add lookup values Yes Yes No
Delete lookup values Yes (if you created it) Yes (if you created it) No
Modify lookup value attributes Yes (except for Lookup Code) Yes (if you created it, and except for No
Lookup Code)

Note: You can add values to lists defined in the designer for user-defined fields. Values entered through the Lookup
Type page become available at runtime as soon as they are saved. Values added to lookup lists through the Intake
Form Designer display at runtime only after the intake form is published.

Adding Lookup Types

To add a lookup type:

1. Select Common Setup > Lookups.
2. Onthe Lookup Types page click Add for the Lookup Type grid.
3. On the Lookup Type Details page, enter these values:
o Lookup Type (The value you enter must be uppercase and can’t begin with the prefix ORA_, which is used
to distinguish your custom lookup types from delivered lookup types.)
o Meaning
o Module
o Description
4. C(Click Add for the Lookup Value grid for each lookup value you need to add to the lookup type.
5. Click Save.

Setting Up Units of Measure

Units of measure are used to express measurements such as quantity or duration. Each unit of measure must have a
unit type such as Length, Area, or Time.
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You add, modify, and delete units of measure on the Unit of Measure page.

Adding a Unit of Measure

1. Select Common Setup > UOM.
2. Onthe Unit of Measure page, click Add.
3. Onthe Unit of Measure Details page, enter values for the following fields:

Page Element Description

Unit of Measure Enter a unique unit of measure ID.

Description Enter a description of the unit of measure.

Unit Type Select the type of measurement. The delivered unit types are Area, Length, Time, and
Volume.

You can define additional values on the Lookup Type Details page. Add new values to
the ORA_PSC_CC_UOM_TYPE lookup type.

ISO Code Enter the ISO unit of measure code.

4. Click Save.

Modifying a Unit of Measure

Select Common Setup > UOM.

Click a row on the Unit of Measure page.

On the Unit of Measure Details page, make the necessary modifications.
Click Save.

PUWNA

Deleting Units of Measure

Select Common Setup > UOM.

2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Unit of
Measure Details page.

3. To delete one or more definitions without viewing details:

-—
.

a. Click Edit.
. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.
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Setting Up Unit of Measure Conversions

A unit of measure (UOM) conversion definition specifies the factor for converting a unit of measure to an equivalent
amount of a different unit of measure.

You add, modify, and delete unit of measure conversions on the UOM Conversion page.

Adding a UOM Conversion

1. Select Common Setup > UOM Conversion.
2. Onthe UOM Conversion page, click Add.
3. Onthe UOM Conversion Detail page, enter values for the following fields:

Page Element Description
UOM Select the unit of measure that is the starting unit for the conversion.
UOM To Enter the target unit of measure. This unit of measure must be the same type as the

original unit of measure. For example, you can convert a unit of length to another unit
of length, but you can’t convert a unit of length to a unit of weight.

Conversion Rate Enter the conversion factor used to convert the original unit of measure to the target
unit of measure. For example, to convert minutes to hours, enter a conversion rate of
60.

4. Verify that the Enabled switch is turned on.

The switch is on by default for a new UOM conversion.
5. Click Save.

Modifying a UOM Conversion

1. Select Common Setup > UOM Conversion.
2. Click a row on the UOM Conversion page.
3. Onthe UOM Conversion Detail page you can:

o Update the UOM conversion field values.
o Disable the UOM conversion by turning the Enabled switch off.
4. Click Save.

Deleting UOM Conversions

1. Select Common Setup > UOM Conversion.
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Unit of
Measure Conversion Details page.
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3. To delete one or more definitions without viewing details:

a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.

Setting Up Data Format Exchange Maps

The Data Format Exchange utility is a data-mapping utility that enables you to map fields between source and target
locations.

Note: This utility is useful in situations where data must be exported from or imported to Public Sector Compliance
and Regulation. Currently, this utility is only used by the Export Journals to ERP process.

Business analysts create and modify Data Format Exchange maps on the Data Format Exchange page.

Adding a Data Format Exchange Map

1. Select Common Setup > Data Format Exchange .
On the Data Format Exchange page, click Add.
3. For the Definition step, enter values for the following fields:

Page Element Description

Mapping Name and Description Enter a name and description for the data mapping.

Source Type Select the type of source format to be included in the data mapping.
Note:

Currently, VO is the only valid value for this field.

Target Type Select the type of target format to be included in the data mapping.

Note:
Currently, CSV is the only valid value for this field.

Enabled Turn this switch on to make the data mapping available to select in the Mapping Name
field on the Export Journals to ERP page. For more information on exporting journals,
see Exporting Journal Entries.
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4.
5.
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10.

Click Next.
For the Source step, enter values for the following fields:

Page Element Description
Source Name Selects the source view to be included in the data mapping, such as Journals to Export.
Click Next.

For the Target step, click Upload to select a file that will be updated with the results of the field mapping.
Click Next.
For the Mapping step, enter values for the following fields:

Page Element Description
Target Field Displays each field in the target format.
Source Field Select the source field that you want to map to each target field.
Transform Select an option to modify the value for the target field.
Note:

Currently, Constant is the only valid value for this field.

Transform Parameter Specify the parameter used to determine the value for the target field. For example, if
the target field is Effective Date and the Transform value is Constant, the Transform
Parameter might be 01/01/2018.

Click Submit to save the Data Format Exchange map.

Note: At any point during the process, you can click Previous to go back one step. You can also click Cancel
to exit the data mapping setup process and discard your changes.

Modifying a Data Format Exchange Map

OO U hAhWNRA

Select Common Setup > Data Format Exchange .

Select a mapping on the Data Format Exchange page.

For the Definition step, you can enable or disable the data mapping.

Click Next.

You can’t update any fields in the Source step.

Click Next.

For the Target step, you can click the file link to download a copy of the file.
Click Next.

42

ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 3
Implementing Your Agency Setting Up Your Agency

9. For the Mapping step, you can update the values of the Source Field, Transform, and Transform Parameter
fields.

10. Click Submit to save your changes to the Data Format Exchange map.

Note: At any point during the process, you can click Previous to go back one step. You can also click Cancel
to exit the data mapping update process and discard your changes.
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4 Setting Up Agency Schedules

Setting Up Holiday Calendars

Holiday calendars establish the days that agency offices are closed and no field service operations are offered.

These days appear as unavailable, non-working days in calendar views throughout the system such as for public user
and inspector calendars. Non-working days in holiday calendars apply to all employees and do not need to be defined
for employee profiles.

Each holiday calendar spans a date range that you define. Within that date range, you define individual events for each
non-working holiday.

Administrators add, modify, and delete holiday schedules and events on the Holiday Calendar page.

Adding a Holiday Calendar

1. Select Common Setup > Holiday Calendar .
2. On the Holiday Calendar page, click Add.
3. On the Holiday Calendar Details page, enter values for the following fields:

Page Element Description

Calendar ID and Description Enter a unique ID and description for the calendar. For example, you might enter an ID
of 2079 and a description of Holiday Calendar 2019.

Valid from Date and Valid to Date = Enter the date range for the holiday calendar. For example, you might enter a Valid
from Date of 2079-07-017 and a Valid to Date of 2079-72-37 to represent a calendar that
spans the entire 2019 calendar year.

4. Add an event.
I Note: You must have values defined for all required holiday calendar fields before you can add an event.

5. Click Save.
I Note: When you click Save, the Holiday Calendar page closes.

Adding an Event

Select Common Setup > Holiday Calendar .

Click a row on the Holiday Calendar page.

On the Holiday Schedule Details page, click Add.

On the Event Details page, enter an Event ID, an Event Date, and a Description for the event. For example, you
might enter an ID of MD, a date of May 29, 2017, and a description of Memorial Day.

Click Save.

PUWNA
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Modifying a Holiday Calendar

1. Select Common Setup > Holiday Calendar .

2. C(lick a row on the Holiday Calendar page.

3. On the Holiday Calendar Details page you can:
o Update the holiday schedule field values.

Note: You cannot edit the Calendar ID.

o Delete the holiday calendar. You will be prompted to confirm the permanent deletion.
o Add, modify, or delete events.
4. C(lick Save.
I Note: When you click Save, the Holiday Calendar page closes.

Modifying an Event

1. Click a row on the Holiday Calendar Details page.
2. On the Event Details page you can:
o Update the event date or description.

o Delete the event. You will be prompted to confirm the permanent deletion.
3. Click Save.

Deleting Holiday Calendars

Select Common Setup > Holiday Calendar .

Click Edit.

Select the check boxes next to all the holiday schedules you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PUWN

Deleting Events

1. Click Edit on the Holiday Calendar Details page.
2. Select the check boxes next to all the events you want to delete.
3. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Work Schedules

Work schedules establish the days of the week and daily hours of operation for agency employees.

Create schedules based on the type of employee and work location. Calendar views, such as inspector calendars,

reference work schedules to determine the time slots that are displayed on the calendar as available for scheduling.

Algorithms for assigning resources also use work schedules to determine availability. You assign work schedules to
employee profiles using the Agency Staff page. See Setting Up Agency Staff.

Administrators and business analysts add, modify, and delete work schedules on the Work Schedule page.
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Adding a Work Schedule

1. Select Common > Work Schedule .
2. Onthe Work Schedule page, click Add.
3. Onthe Work Schedule Details page, enter values for the following fields:

Page Element

Schedule ID and Description

Start Date

End Date

Work Start Time and Work End
Time

Break Start Time and Break End
Time

Description

Enter a unique ID and description for the schedule. For example, you might enter an ID
of OFFICESAT and a description of Saturday Office Schedule.

Enter the first day of the schedule.

Enter the last date of the schedule. You can leave this field blank to give the schedule an
open end date.

Enter the start and end time for the schedule. For example, you might enter a work start
time of 09:00 AM and a work end time of 05:00 PM.

Enter the start and end time for a break within the schedule. For example, you might
enter a break start time of 72:00 PM and a break end time of 07:00 PM.

Note:
These fields are optional, but if you enter a break start time, you must also enter a
break end time.

Recurrence and Weeks Between Select whether the schedule reoccurs weekly and how many weeks are between each

Occurrences occurrence. For example, if you select a recurrence of Weekly with 7week between
occurrences, the schedule repeats every week.
Work Days Select the days of the weeks to which the schedule applies.
4. Click Save.

Note: For overnight work shifts that go past 12 am (midnight), you must create two schedules: one for the time period
up until midnight, and one for the time period after midnight. For example, to create a weekday overnight shift that
starts at 09:00 pm and ends at 06:00 am the following day, the first schedule would have a start time of 09:00 pm
and an end time of 12:00 am on Monday through Friday. The second schedule would have a start time of 12:00 am
and an end time of 06:00 am on Tuesday through Saturday.
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Modifying a Work Schedule

1. Select Common > Work Schedule .
2. Click a row on the Work Schedule page.
3. On the Work Schedule Details page you can:

o Update the work schedule field values.

Note: You cannot edit the Schedule ID field.

o Delete the schedule. You will be prompted to confirm the permanent deletion.

4. C(lick Save.

Deleting Work Schedules

Select Common > Work Schedule .

Click Edit.
Select the check boxes next to all the work schedules you want to delete.

Click Delete. You will be prompted to confirm the permanent deletion.
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5 Setting Up Your Agency Staff

Setting Up a Fusion Business Unit and Legal Entity

This topic discusses the one-time setup for Public Sector Compliance and Regulation administrators who are not using
Fusion Human Capital Management (HCM), Enterprise Resource Planning (ERP), and Sales Cloud.

If you have implemented both Fusion Financials and Public Sector Compliance and Regulation (PSCR) services, then you
must ensure that you migrate Financials Business Unit related tasks before any PSCR migrations. Migrate any changes
you have made to the business unit configurations in the Financials offering before the Public Sector offering or the
implementation projects are migrated from a non-production environment to your production environment.

The following setup steps are prerequisites for creating an agency staff in the system.

Note: For Fusion HCM, ERP, and Sales Cloud customers, these steps are not required as the business unit and legal
entity are already set up.

Configure the following tasks in the order mentioned here:

Set up reference data sets (to create a Set ID)
Create a business unit

Create a legal address

Create a Legislative Data Group

Create a Legal Entity

Register a Legal Entity

Create Legal Entity HCM Information

NOURWNA

Setting up Reference Data Sets

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:
Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. Ontheright panel locate the Manage Reference Data Sets task and click the row to open the Manage Reference
Data Sets page.

3. Onthe Manage Reference Data Sets page, click the New button and include values for the fields:

Page Element Description

Set Code Enter a code value that represents your agency.
Set Name Enter a name that represents your agency.
Description Enter a description about your agency.

4. C(Click Save and Close to save the newly created SetID.
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Creating a Business Unit

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:
Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On the right panel locate the Manage Business Units task and click the row to open the Manage Business Units
page.

3. On the Manage Business Unit page, click the New button and include values for the fields:

Page Element Description
Name Enter a name for the business unit.
Default Set Select the SetID you created in the previous section

4. C(lick Save and Close to save the newly created business unit.

Creating a Legal Address

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:
Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On theright panel, locate the Manage Legal Addresses task and click the row to open the Manage Legal
Addresses page.

3. Onthe Manage Legal Addresses page, click the New button and enter the agency address in the Agency Line 1
field. The other fields are optional.

4. Click OK to return to the Manage Legal Addresses page and click Save and Close to save the newly created
address.

Creating a Legislative Data Group

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:
Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On the right panel, select the task named Manage Legislative Data Group and click Select to open the Manage
Legislative Data Groups page.

3. Onthe Manage Legislative Data Groups page, click Create to enter the new legislative data group details.

4. Enter your legislative data group name in the Name field. Search and select your country from the Country

field.
5. Click Submit to save and return to the Manage Legislative Data Group page.
6. Click Done.

Creating a Legal Entity

1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:
Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On the right panel, locate the task named Manage Legal Entity and click to open the Select Scope page.

3. On the Select Scope page select the Manage Legal Entity task radio button.
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4. C(lick the Legal Entity drop-down and select Create New. Click Apply and Go to Task button to open the

manage Legal Entities page.

5. Onthe Manage Legal Entities page, click the New button to open the Create Legal Entity page and enter values

for the fields:

Page Element

Country

Name

Legal Entity Identifier

Payroll Statutory Unit

Legal Employer

Legal Address

EIN or TIN

Legal Reporting Unit Registration
Number

Description

Select the country (United States is the default selection).

Enter the name of your agency.

Enter a code for your agency.

Select the check box.

Select the check box.

Select the legal address (created in the previous section) using the Search and Select
page.

Enter your agency’s EIN or TIN value. You can enter a value of your choice if you do not
have EIN or TIN for your agency.

Note:

If you are using Fusion HCM or Fusion ERP, the value you enter here must be
legitimate. It is recommended that you refer to Fusion documentation to know about
the required value for entry in the field.

Enter your agency’s legal reporting unit registration number. You can enter a value of
your choice if you do not have a registered number for your agency.

Note:

If you are using Fusion HCM or Fusion ERP, the value you enter here must be
legitimate. It is recommended that you refer to Fusion documentation to know about
the required value for entry in the field.

6. Click Save and Close to save the newly created legal entity.
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Registering a Legal Entity

1.

W

Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:
Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

On the right panel, select the task named Manage Legal Entity Registration and click Select to open the Select
Scope page.

On the Select Scope page select the Manage Legal Entity Registrations task radio button.

Click the Legal Entity drop-down and choose Select and Add. Select Click Apply and Go to Task button to open
the Manage Legal Entities page.

On the Manage Legal Entities page expand the Search section and enter the legal entity name you created in
the previous section. Click Search.

Select the row from the search results and click Save and Close, to save the entity and open the Manage
Registrations page.

View your values on the new Manage Registrations page and click Done to confirm and complete the
registration process.

Creating Legal Entity HCM Information

1.

W

9.
10.

n.

Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:
Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

On the right panel, select the task named Manage Legal Entity HCM Information and click Select to open the
Select Scope page.

On the Select Scope page select the Manage Legal Entity HCM Information task radio button.

Click the Legal Entity drop-down and choose Select and Add. Click Apply and Go to Task button to open the
Manage Legal Entities page.

On the Manage Legal Entities page expand the Search section and enter the legislative data group you created
in the previous section. Click Search.

Select the row from the search results and click Save and Close, to save the entity and open the Legal Entity
page.

On the Legal Entity page, click Edit and then click Update to open the Update Legal Entity page to enter an
action reason.

On the Update Legal Entity page, select Action Reason drop-down button and select the option Reorganization.
Click OK to save and return to the Legal Entity page.

On the Legal Entity page, select the Payroll Statutory tab to associate the data group to the HCM legal entity.
Under the Payroll Statutory Information section select the Associated Legislative Data Group drop-down.
Search and select the legislative data group you created using the previous section.

Click OK to return to the Edit Legal Entity page. Click Submit and then click Done to complete the creation of a
Legal Entity HCM Information.

For information on creating an employee record, refer to the documentation Managing Agency Staff Profiles.

Defining Job Titles

This topic discusses how to define job titles for agency staff.
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Defining Job Titles

Administrators define new job titles using the Job Titles page:

Select Agency Staff > Job Title .

The Job Title page lists all the job titles defined.

Click Details for a row to open the Job Title Detail page and view and edit the details of the job title.
Click Add to open the Job Title Detail page and define a new job title.

Enter various details and click Save to save the new job title and return to the Job Title page.

A WN

Setting Up Agency Staff

This topic provides an overview of job functions along with a list of delivered job functions. It also discusses how to set
up Fusion business units and legal entities for Public Sector Compliance and Regulation services.

Job Function Overview

Job functions are assignments made to staff members using the Agency Staff page. Job functions help you in assigning
job specific attributes to an agency staff member. For example, you can assign the job function of a building inspector
to an agency staff member and associate attributes such as Inspection District and Work Schedule.

Job Function and ID Attribute and Usage

Building Inspector - Work Schedule — Inspections: Determine inspector availability for assignment to inspections. A
building inspector can have more than one work schedule.

ORA_BUILDING_INSPECTOR . L . . - - .
- Inspection Districts — Inspections: Determine the districts for which an inspector can be

assigned to inspections.

Note:
You can leave the value of the inspection district job attribute blank to enable a building inspector to
be assigned to inspections from all districts.

- Inspection Types — Inspections: Determine if the inspector can be assigned to a given type of
inspection.

Note:
You can leave the value of the inspection type job attribute blank to enable a building inspector to be
assigned to all inspection types.

- Permit Types — Inspections: Permit types are not used for inspector assignment.

Business Analyst - Inspection Districts

ORA_BUSINESS_ANALYST * Inspection Types

- Permit Types

(Applicable in future releases) . .
(Applicable in future releases)
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Job Function and ID

Business License Manager

ORA_BL_MANAGER

Business License Specialist

ORA_BL_SPECIALIST

Cashier

ORA_CASHIER

Chief Building Officer
ORA_CHIEF_BUILDING_OFFICER

(Applicable in future releases)

Code Enforcement Officer

ORA_CODE_ENFORCEMENT_OFFICER

Code Enforcement Supervisor

ORA_CODE_ENFORCEMENT_
SUPERVISOR

ORACLE
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Attribute and Usage

Note:
No job attributes are currently required for this job function. Business license managers have access
to all consultations and licenses.

- Business License Application Types — Determine the license and consultation types that this
specialist can be assigned to.

- Consultation Meeting Schedule — Determine the availability of the specialist for scheduling
business consultation meetings.

Note:
You can assign only one schedule.

- Permit Types (Applicable in future releases)
- Cashier ID — Cashiering: Determine Cashier ID of the Cashier

Note:
You can assign only one schedule.

- Inspection Districts
- Inspection Types

- Permit Types

(Applicable in future releases)

- Code Enforcement Districts The possible values are districts from code enforcement district
types. Only users who are associated with a code enforcement district can be autoassigned to
issues in that district.

- Code Enforcement District Types — Used at the time of scheduling inspections.

- Code Enforcement Inspection Work Schedule

Note:
You can assign only one schedule.

- Issue Type — The possible values are the issue types that you create. A user who is associated
with an issue type is responsible for all related subtypes, so don’t assign users to both an issue
type and a subtype that belongs to that issue type.

- Issue Subtype — The possible values are the issue subtypes that you create. Only assign a user
to a subtype when the user is not responsible for all of the subtypes that belong to the related
issue type.

These attribute values establish which issue types and subtypes the person is responsible for. This
information is used when routing or assigning incidents and cases.
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Job Function and ID Attribute and Usage

Note:

To give a user responsibility for all types of issues, create an Issue Type attribute row, but leave the
attribute value blank. If you don’t set up any issue type or subtype attributes, and you activate the
system-level setting for automatically routing incidents, incidents will never be routed to the user.

Code Enforcement Technician - Issue Type — The possible values are the issue types that you create. A user who is associated
with an issue type is responsible for all related subtypes, so don’t assign users to both an issue
ORA_CODE_ENFORCEMENT_TECHNICIAN type and a subtype that belongs to that issue type.

- Issue Subtype — The possible values are the issue subtypes that you create. Only assign a user
to a subtype when the user is not responsible for all of the subtypes that belong to the related
issue type.

These attribute values establish which issue types and subtypes the person is responsible for. This
information is used when routing or assigning incidents and cases.

Note:

To give a user responsibility for all types of issues, create an Issue Type attribute row, but leave the
attribute value blank. If you don’t set up any issue type or subtype attributes, and you activate the
system-level setting for automatically routing incidents, incidents will never be routed to the user.

Economic Development Officer Permit Types
ORA_ECONOMIC_DEVELOPMENT_ (Applicable in future releases)
OFFICER

(Applicable in future releases)

Finance Administrator - Inspection Districts

ORA_FINANCE_ADMINISTRATOR * Inspection Types

. . - Permit Types
(Applicable in future releases) . .
(Applicable in future releases)

Inspector Supervisor - Work Schedule — Inspections: Work schedules are not used for inspector supervisors.

ORA_INSPECTOR_SUPERVISOR . Inspectio_n Distr!'cts — Inspections: Determine the districts for which a supervisor can view or

schedule inspections.
You can leave the value of the inspection district job attribute blank to enable an inspector
supervisor to view or schedule inspections for all districts.

- Inspection Types — Inspections: Determine the inspection types that can be viewed or
scheduled by this inspector supervisor.
You can leave the value of the inspection type job attribute blank to enable an inspector
supervisor to view or schedule inspections for all inspection types.

- Permit Types — Inspections: Permit types are not used for inspector supervisor assignment.

Permit Technician - Inspection Districts

ORA_PERMIT_TECHNICIAN + Inspection Types

. . - Permit Types
(Applicable in future releases) . .
(Applicable in future releases)

55
ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 5

Implementing Your Agency Setting Up Your Agency Staff
Job Function and ID Attribute and Usage
Plan Coordinator - Permit Types — Determine the permit types of the plan reviews that this plan coordinator can

view in the Plan Review Console.
ORA_PLAN_COORDINATOR
. . Note:
(Applicable in future releases) You can leave the value of this job attribute blank to enable a plan coordinator to view plan reviews
for all permit types.

- Plan Reviewer Department — Determine the plan reviewer departments of the plan reviews that
this plan coordinator can view in the Plan Review Console.

- Planning Application Types — Determine the planning application types of the plan reviews that
this plan coordinator can view in the Plan Review Console.

Note:
You can leave the value of this job attribute blank to enable a plan coordinator to view plan reviews
for all planning application types.

Plan Reviewer - Permit Types — Determine the permit types that this plan reviewer can be assigned to.
ORA_PLAN_REVIEWER Note:
You can leave the value of this job attribute blank to enable a plan reviewer to be assigned to all
permit types.

- Plan Reviewer Department — Determine the plan reviewer department that this plan reviewer
belongs to. The Add Reviewers modal page displays a list of available reviewers by plan reviewer
department when assigning a plan reviewer to a plan review.

- Planning Application Types — Determine the application types that this plan reviewer can be
assigned to.

Note:
You can leave the value of this attribute blank to enable a plan reviewer to be assigned to all
planning applications types.

- Plan Review Districts — Determine the plan review districts for which a reviewer is available on
the Add Reviewers modal page when assigning reviewers to a plan review.

Note:
You can leave the value of this attribute blank to make a plan reviewer available for all plan review
districts.
Planner - Planning Application Types — Determine the application types that this Planner can be
assigned to.

ORA_PLANNER
- - Pre-application Meeting Schedule — Determine the availability of the planner for scheduling

pre-application and planning meetings.
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Note:
You can assign only one schedule.

Principal Planner - Permit Types — Determine the permit types of the plan reviews that this principal planner can
view in the Plan Review Console.
ORA_PRINCIPAL_PLANNER

. . Note:
(Applicable in future releases) You can leave the value of this job attribute blank to enable a principal planner to view plan reviews
for all permit types.

Plan Reviewer Department — Determine the plan reviewer departments of the plan reviews that
this principal planner can view in the Plan Review Console.

Planning Application Types — Determine the planning application types of the plan reviews that
this principal planner can view in the Plan Review Console.

Note:
You can leave the value of this job attribute blank to enable a principal planner to view plan reviews
for all planning application types.

Setting Up Fusion HCM Business Units and Legal Entities for Public Sector
Compliance and Regulation Services

If you are an existing Fusion customer and if you have already set up business units and legal entity, then you can
assign the same for your Agency Staff. However, if you are a new Public Sector Compliance and Regulation-only
customer then as a prerequisite for entering Agency Staff data, you need to create one business unit and one legal
entity that can be used for your agency staff.

See Setting Up a Fusion Business Unit and Legal Entity.

Configuring Agency Job Groups
This topic provides an overview of the Agency Staff Group Configuration and discuss the procedure to configure agency
job groups.

You can use the Agency Staff Groups for identifying a common set of Job attributes that can be applied to a group of
Employees.

Groups provide the flexibility to assign attributes at various levels. You can define a group for a given department,
division, or for specific districts based on the commonalities of the job attributes.

Examples of Groups are:

1. Inspectors working in District A
2. Permit Technicians responsible for Fence Permits

57
ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 5
Implementing Your Agency Setting Up Your Agency Staff

You can configure a group with default Job Functions and their attribute values for your users.

Users entering their employee profile information can select a group job function, which results in loading default job
functions and their attribute values automatically populated.

Note: Users cannot edit the job function attribute values on the Agency Staff page when using the Job Group
function.

Configuring Agency Job Groups

Administrators set up and configure the agency staff group on the Job Group page. Agency users can select a group on
the Agency Staff Profile page, and a default set of job functions and attribute values are assigned to the employee. To
set up the job functions and attributes for a group:

Select Agency Staff > Job Group .

On the Job Group page, click Add to add a new group or Edit to change the group attributes. Click Add.
Enter the details of the job group on the Job Group Details page.

Verify that the Enabled switch is turned on if you want to enable this group when you save. This switch is
turned on by default for a new group.

Under the Job Function section, click Add to select job functions and include their attributes.

Click Save to return to the Job Group page.

PUOUNa

ow

Note: Agency users select the group from a list on the Agency Staff page. The job functions and their corresponding
attributes cannot be changed by users.

Managing Agency Staff Profiles

This topic discusses how to manage agency staff profiles.

Managing Agency Staff Profile

Administrators set up the agency staff profile on the Agency Staff page.

1. Select Agency Staff.

2. Onthe Agency Staff page, click Add to add a new agency staff member — employee.

3. Onthe Agency Staff Profile page, you add values to the various fields. For the Business Unit and the Legal
Entity, see the documentation Setting Up a Fusion Business Unit and Legal Entity .

Page Element Description

Select Existing Fusion Worker Turn on the switch to allow the search and selection of an existing Fusion employee.
The following fields are display only, populating details from Fusion information:

o PersonID
o Person Number

o Hire Date
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Page Element Description

o Business Unit

o Legal Entity

o Generated User Account
o Send Credential Email

o User name

Worker ID Enter an ID or click the prompt to open the Look Up page and search for the Fusion
employees. You can sort the search results by any of these:

o Worker ID

o First Name

o Last Name

o Email Address

o Hire Date

o Phone Number

o Business Unit Name
o Legal Employer

o Manager Person ID

Select an employee row from the search result on the Look Up page and the details are
populated on the Agency Staff page.

Person Type Select a type of staff member from the options: Employee
Enabled Set a status for the staff member from the options:
o Active
o Inactive
Note:

You set the status to Inactive when the employee is inactivated in your HR system. If
you are a Fusion HCM/ERP/Sales Cloud customer then the inactivation of Employees
in HCM will not automatically inactivate the Employee data in Public Sector Cloud.
You must manually update this field.

Also, turning off the switch on this page will not inactivate the user ID. You need to
use your security console to inactivate the User ID. If Oracle Identity Cloud Service
(IDCS) is your identity provider (IdP), you must inactivate the user ID using your IDCS
console.

Is a Supervisor Turn on the switch if the employee is a supervisor.
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Page Element Description
Job Group Select a group to assign a job group section with the relevant job functions. Accordingly,

the system populates the Job Group Assignments section.

Note:
You cannot make any changes to the values in the job group assignments on this
page. To update the values, navigate to the Job Group page.

4. C(lick Save to save the agency staff profile and return to the Agency Staff page.

Job Function Assignment without using Agency Job Groups

You can assign job functions to employees directly, without having to use Job Groups.

1.
2.
3.

On the Agency Staff page search and select the employee that you want to add job functions to.
Under the Job Function section, click Add to select job functions and include their attributes.
Click Save and return to the Agency Staff page to view the job function assignments.

To include job functions using Agency Job Groups, see the documentation Configuring Agency Job Groups.

Assigning Agency Security Access

Administrators assign roles to various staff members. The security roles assigned to an employee determine the
navigations and data that the user can access.

1.

N

o unhw

Select Agency Staff and then select Agency Staff Access. The Agency Staff Access page lists all the agency staff
members.

You can click the chevron for a row to view the employee access details. This page lists all the security roles
assigned to the employee user. You can add new security roles to the employee on this page.

Click the Add New Role button to open the Role Detail page and assign a role for the user.
Click Save to save your changes and return to the Agency Staff Access page.

Click Save to save the changes you made to the Agency Role details of the staff member.
You can add or delete the security roles assigned to the user on this page.

Note: All Agency users must be assigned the PSC Agency Staff role. Additionally job specific roles can be assigned
to the user. For the complete list of security roles, you can refer to the Security Reference Manual. Also refer to Using
the Security Console.

Note: For users requiring access to Permits, in addition to the PSC Agency Staff and job specific roles such
as PSC Permit Technician, PSC Plan Reviewer and others, you must assign the following roles to the users:
CUSTOM_MANAGE_PERMITS, CUSTOM_MANAGE_PERMITS, and CUSTOM_PSC_MANAGE_PERMITS_AGENCY.
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Managing Mobile Application Activation

As agency administrators, you must enable access to your field officers for using the inspection application on their
mobile devices.

You use the Agency Mobile Setup page to select the field officers and send them the email containing the activation
link. Only the agency staff with the job function of code enforcement officer or building inspector are entitled to install
and use the mobile application. Code officers and building inspectors receiving the email must install and configure the
mobile application on their mobile devices. For more information, see Installing and Configuring Oracle Municipal Code
Officer and Installing and Configuring Oracle Inspector.

Mobile Application Activation

To send the mobile application activation link:

1. Select Agency Staff > Mobile Application Activation.

2. The Agency Mobile Setup page lists all the agency staff that are either building inspectors or code enforcement
officers.
The job function assignments are set up on the Agency Staff page. See Setting Up Agency Staff.

3. Select the staff member you want to send the email notification and click the Send button on the row.

4. Click OK to confirm that the email containing the mobile activation link will be sent to the selected agency staff.
The activation link is for one-time use only.
The notification status for the row changes to Request sent, and the Resend button appears in the Send Mobile
Setup Notification column.

Note: You can select multiple staff members to the email notification at once. Click the Edit icon on the Agency
Mobile Setup page and use the check boxes to select your recipients. Select the Send Mobile Setup Notification
button to send the email to all the selected field officers.

Related Topics
 Setting Up Users for Oracle Mobile Applications

Importing Agency Staff Data

This topic explains how to prepare and import agency staff resource data from an external data source into Public
Sector Agency Staff tables using the File-Based Data Import feature.

Agencies with Fusion HCM implementation: File-based data import can be used if your agency has implemented Fusion
HCM. You either enter employee details manually into the Public Sector Agency Staff tables using the Public Sector user
interface (Agency Staff page) or run the schedule import process to copy the employee data.

Agencies without Fusion HCM implementation: If your agency has not implemented Fusion HCM and you are using a
third-party application to maintain employee information, you can use the import process to copy data from the third
party tables into the Public Sector Agency Staff tables.
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In addition to the removal or inclusion of employee records, data changes can include changes to the details of an
employee, such as the address, email, role, or designation.

Scheduling the Employee Data Import and Export Process

Administrators can set up a schedule to process a batch file that imports employee data from a .CSV file into the Public
Sector Agency Staff tables. The imported data file, which is usually generated from a third-party application, can be
used to set up and periodically update user details within Public Sector Agency Staff.

Using the Predefined Template to Import Data using File-Based Data
Import

Public Sector Compliance and Regulation provides a template to help you import data using the File-Based Data Import
tool. The Import template is a spreadsheet that includes the commonly used fields, in addition to the required, along
with instructions to use them.

You can download the template by clicking this link: Agency Staff Import Template spreadsheet file.

Importing Employee Data

1. Access the File Import and Export page from the Fusion application by clicking Navigator > File > Import and
Export.

2. On the File Import and Export page, in the Search Results section, click the Add button to upload the template
zip file to the Universal Content Management (UCM).

3. On the Upload File modal page, click Browse and select the file for upload. Use the Account field to select the
account for the file you are uploading.

4. Click Save and Close. You will see the file listing on the File Import and Export page with the details of the
upload.

Scheduling the Import Export process using File-Based Data Import

1. Access the Scheduled Processes page from the Fusion application Navigator > Tools > Scheduled Processes .

2. Onthe Scheduled Process page, click the Schedule New Process button and enter values for the fields on the
Schedule New Process modal page:

Page Element Description

Type Ensure that the Job option is selected.

Name Search and select the Load Interface File for Import value from the list of names.
Description Displays a description about the selected process.

3. Click OK. The service now opens the Process Details page for you to select the import process for the process
name you entered in the above step:
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Page Element Description
Import Process Click the drop-down menu, search and select the Import Agency Staff value using the
lookup list.
Data File Click the drop-down menu and select the generated ZIP file you uploaded earlier, as

described in the previous section.

4. C(Click Submit and accept the confirmation message to complete the submission.

Note: The submission only confirms that the files are sent for processing. To view the details of the completed
process, you must access the log file. The log file lists all the successfully processed records and the records that are in
error, with the details of the error.

Records in Error

Note: When you fix the errors in the spreadsheet and prepare to resubmit it for processing, you must delete the
records that were processed successfully in the previous run. All the records preceding the ones in error are created
in the Public Sector Agency Staff tables. Resubmitting the template having those records results in creating duplicate
entries of the staff records.

Scenarios for importing employee data from a third-party system to Public
Sector Agency Staff profile

Prerequisite
The scenarios listed here assume that the following prerequisite has already been set up: Each record in the template

should contain a unique identifier called the Interface ID. The interface ID is used as a key identifier while establishing
parent-child relationships across the pages of the template spreadsheet.

Consider importing the employee details into the tables of Public Sector Agency Staff. You can perform the following
actions using the Import template:

- Add a new staff member
- Assign personal attributes
- Assign job functions and attributes
- Assign roles
Disable an agency profile

The following scenarios detail how you can create a new agency staff record and seamlessly update various parameters
of your existing agency staff.

Note: The InsertUpdateFlag field on the Import template is the determining factor as to whether the record is for a
new agency staff or for updating an existing agency staff. Enter the value “I” if you are inserting a new record, or “U”
if you are updating an existing record. Also note that the Person Number field is mandatory if you are updating a
record.
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Scenario 1: Adding a new agency staff

Consider creating a new agency staff record staff in your Public Sector Agency Staff.

If your agency is not a Fusion HCM customer, you use the template to enter details in all the pages of the template
spreadsheet and then schedule the import process to import the newly added employee record. You must enter the
value “I” in the InsertUpdateFlag field to qualify the record as a new agency staff entry.

The following example shows the data on the spreadsheet detailed in the above scenario — Adding a new staff member.

Record Number *Interface ID *InsertUpdateFl; *First Name *Last Name *Email *Business Unit *Legal Entity

1 467436 John Simmons john.s@example. Sample Sample
Corporation Corporation

2 467437 Robert James robert.j@exampli Sample Sample
Corporation Corporation

Note: The above example displays a limited number of fields. For a complete list of fields, refer to the Import template
spreadsheet.

If your agency has implemented Fusion HCM, you use the HCM loader or enter the necessary employee details
manually. In such cases, the following Public Sector specific attributes are required to be updated:

- Job Title

- Agency Department
- Agency ID

- Agency Location

- Job Group

 |Is Supervisor

- Enabled

Scenario 2: Updating personal details of an agency staff

Consider updating changes to the personal details of an agency staff in your Public Sector Agency Staff. You can
perform the following actions:

- Change work phone number
- Change location

- Change department

- Change job title

- Assign job group

- Revoke job group

- Change supervisor status

The following example shows the data on the spreadsheet detailed in the above scenario.
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Record Number *Interface ID *Person *Work Phone *Location *Department *Job Title *|s Supervisor
Number Number
1 467436 PERNUMS8 16348773 3001001688796 1001 Agency Staff Y
2 467437 PERNUM9 32178939 30010016887961 1001 Building N
Inspector

Note: The above example displays a limited number of fields. For a complete list of fields, refer to the Import template
spreadsheet.

Scenario 3: Updating job functions and their attributes

Consider updating changes to job functions and their attributes of an agency staff in your Public Sector Agency Staff.
You can perform the following actions:

- Assign job functions and attributes

- Assign additional job attributes to existing functions
- Remove job attributes

- Remove job functions

The following example shows the data on the spreadsheet detailed in the above scenario.

Record Number *Interface ID *Assignment *Person Agency ID Job Function ID Job Attribute Attribute Value
Flag Number
1 467436 PERNUMS8 1 ORA_ ORA_ Plumbing
BUILDING_ INSPECTION_
INSPECTOR TYPES
2 467437 D PERNUM9 1 ORA_CASHIER = ORA_CASHIER_ = 7574343
ID

Scenario 4: Updating roles

Consider updating roles of an agency staff in your Public Sector Agency Staff. You can perform the following actions:
- Assign additional roles
- Revoke roles

The following example shows the data on the spreadsheet detailed in the above scenario.

Record Number *Interface ID *Role Action *Person Number *Role Name

1 467436 A PERNUM8 Employee
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Record Number *Interface ID *Role Action *Person Number

2 467437 R PERNUM9

Scenario 5: Disabling agency staff profile

Chapter 5
Setting Up Your Agency Staff

*Role Name

Application Implementation
Consultant

Consider disabling an agency staff profile in your Public Sector Agency Staff. You can perform the update without
having to make any manual entry in your records. The user interface as well as the Import Agency Staff functionality

allow you to disable agency staff profiles.

The following example shows the Enabled field on the spreadsheet, as detailed in the above scenario.

Record Number *Interface ID *Person *Work Phone *Location *Department
Number Number

1 467436 PERNUMS8 16348773 3001001688796 1001

2 467437 PERNUM9 32178939 30010016887961 1001

*Job Title Enabled
Building Y
Inspector

Agency Staff N

Note: The above example displays a limited number of fields. For a complete list of fields, refer to the Import template

spreadsheet.

ORACLE

66



Oracle Public Sector Compliance and Regulation Cloud Chapter 6
Implementing Your Agency Setting Up Public Users

6 Setting Up Public Users

Setting Up Public Users

Public user setup includes configuration options related to public user registration and account management.

This image illustrates the Public User Setup page.
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Public User Setup

Terms of Use

v| Require the user to accept the terms of use before registering

Terms of Use ID *

Oracle_TMC Q,

Contractor and License

v Agency staff verifies when a user's contractor status changes to yes

v Agency staff verifies when a user adds or updates 3 licenss

Attachments
| Allow agency staff and registered users to manage documents in account management

v Allow registered users to delete documents in account management

Document Group ID

DocGroup2

Privacy Consideration

V| Ask if the user wants to hide contact information from public view

Payment account

| Agency staff verifies when a user adds or updates a payment account

IVR Access Code
v Enable IVR Access Code

User Category

Enter a user category for appropriate notification content and URL redirection parameters for system access.

DEFAULT

To set up public users:

1. Select Common Setup > Public User Setup.
2. Inthe Terms of Use section of the page, configure these options:

ORACLE

68



Oracle Public Sector Compliance and Regulation Cloud Chapter 6

Implementing Your Agency

Page Element

Require the user to accept the
terms of use before registering

Terms of Use ID

Setting Up Public Users

Description

Select this check box if public users must accept your terms of use as part of the
registration process.

If you require public users to accept your terms of use during registration, select the
terms of use definition for the registration process.

This field is visible only if the Require the user to accept the terms of use before
registering check box is selected.

Note:

If you change the Terms of Use ID, users who have already registered are required
to accept the new terms the next time they sign in. In this scenario, a window with
the new terms opens as soon as the public user signs in. The user must select the
agreement check box in order to continue.

3. Inthe Contractor and License section of the page, configure these options:

Page Element

Agency staff verifies when a
user’s contractor status changes
to yes

Agency staff verifies when a user
adds or updates a license

Description

Select this check box if agency staff must verify the contractor status of a public user
who self-identifies as a contractor.

Select this check box if agency staff must verify all licenses that are added to a user
profile. Public users can add one license during the registration process. Public users
and agency staff can add additional licenses using account management functionality.

4. Inthe Attachments section of the page, configure these options:

Page Element

Allow agency staff and registered
users to manage documents in
account management

ORACLE

Description

Select this check box to enable attachments in user accounts. When you enable
attachments, both users and agency staff can add attachments to user accounts and
modify information about existing attachments.

Agency staff can also delete attachments, but public users can’t delete attachments

unless you also select the “Allow registered users to delete documents in account
management” check box on this page.
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Allow registered users to
delete documents in account
management

Document Group ID

Chapter 6
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Description

Select this check box to allow public users to delete attachments that are associated with

their account. This setting does not affect agency staff, who can always delete account
attachments.

This check box is visible only if you enable attachments by selecting the “Allow agency
staff and registered users to manage documents in account management” check box.

If you want to enable document categories and subcategories for public user account
and profile attachments, select the document group with the appropriate categories. A
document group consists of a set of related categories.

If you leave this field blank, the public user attachment pages won’t have fields for
identifying attachment categories and subcategories.

This field is visible only if you enable attachments by selecting the “Allow agency staff
and registered users to manage documents in account management” check box.

5. Inthe Privacy Consideration section of the page, configure these options:

Page Element

Ask if the user wants to hide
contact information from public
view

Description

Select this check box to give public users the option to mask their name and contact
information when a member of the public views the user’s applications.

If this check box is selected, the initial registration page gives users the opportunity
to mask their information. Help text explains that the public can still view the property
address even if the user’s information is masked.

After a user registers, either the user or agency staff can update this preference using
Account Management functionality.

6. Inthe Payment Account section of the page, configure this option:

Page Element

Agency staff verifies when a
user adds or updates a payment
account

Description

Select this check box if agency staff must verify all payment accounts (also called
trust accounts) that are added to a user profile. Public users and agency staff can add
payment accounts using account management functionality.

7. Inthe IVR Access Code section of the page, configure this option.

ORACLE
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Enable IVR Access Code (Enable
Interactive Voice Response Access
Code)
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Description

Select this check box to:

o Display the IVR Access Code field for public user accounts.

This field enables public users to maintain their 4-digit PIN.

o Require public users to provide their 4-digit PIN when accessing inspection records
using IVR.
For more information, see The Public User Registration Process and Setting Up a Proxy

Role and User for Interactive Voice Response.

8. Inthe User Category section of the page, configure this option:

Page Element

Enter a user category for
appropriate notification content
and URL redirection parameters for
system access

9. Click Save.

Description

Enter the user category to be assigned to registered public users. Typically you should
use the delivered category DEFAULT.

The user category that you specify will be associated with user accounts that are created
by the public user registration process.

The category controls the templates for account-related notifications such as emails
for first-time registration and for resetting the account password. The category also
controls URL redirection so that when users set or reset their password in the Oracle
Applications Cloud, they are immediately transferred to the public sector system.

For more information about user categories, see Managing Users in Public Sector
Compliance and Regulation and Setting the Next URL for the Default User Category.

Setting Up Public User Roles

To ensure that registered public users have appropriate system access, you must define which role is assigned to the
user IDs that are created during the registration process.

When a public user registers, the Oracle system assigns a single role to the new user. Because the user is assigned just
one role, access to different areas of the system is established through a role hierarchy. In this hierarchy, the various
roles that provide access to different areas of the system are all children of a single parent role that you create.

During implementation, you created all custom roles required for system access, including those for the public user. Use
the Public User Roles page to identify the role to be assigned during user registration.

ORACLE
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ldentifying the Single Role to be Assigned During Public User Registration

To identify the single role to be assigned during public user registration:

1. Select Common Setup > Public User Roles.
If the Public User Roles page already lists a role, delete it before you add the new role.

The button for adding a role is hidden if a row already exists. You cannot modify the existing row, so you must
instead delete it and then add a new one.

To delete the existing row:

a. Click the row to access the Role Details page.
b. Click Delete.
3. On the Public User Roles page, click Add.

4. On the Role Details page, use the Role ID field to select the single role to be assigned during the public user
registration process: PSC Custom Registered Public User (CUSTOM_PSC_REGISTERED_PUBLIC_USER).

The Role ID is the only enterable field on the Role Details page. To select a role based on the descriptive role
name rather than the numerical role ID, use the prompt button for the Role ID field and expand the Search
Criteria section of the lookup page so you can search by role name.

Note: If you can't find the PSC Custom Registered Public User role, you may not have created all of the
necessary custom roles. For more information on setting up custom roles, see Creating Custom Roles for
Public Sector Compliance and Regulation.

5. Click Save.

Related Topics
 Creating Custom Roles for Public Sector Compliance and Regulation

Setting Up Contact Types

A contact type describes the role or position of a contact person for an application. Contact types are used only for
application contacts, not for profile contacts. The contact type that you assign to a contact determines whether the
contact has access to the permit.

Permit Access for Contacts

When you set up contact types, you choose whether contacts have permit access. For example, you might enable
access for business owners and homeowners, but not for organizations.

For a given permit, if a contact’s type allows access and the contact email matches the account email for a registered
user, then that registered user can access the permit after the application is submitted. To access the application, the
contact searches for it using the search field in the global banner. The permit isn't listed in the contact’s own list of
applications.

With permit access, the contact can do the following:

- View complete applicant information, including information that is hidden from the general public.
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- View plan review data.
- View contractor data.

- View comments, including permit, plan review, inspection, and workflow comments on the contact's own
applications.

- View contacts and attachments on the contact's own applications.
- Add contacts, comments, and attachments on the contact's own applications until the permit is closed.
- Update and delete comments and attachments that the contact added.
- View inspections and inspection checklists.
- View fee information.
- View communications that are visible to the applicant.
- Schedule inspections.
« Print the permit, and print payment receipts.
Contacts can also add or delete links to related transactions on the permits they manage. You grant registered public

user access for managing links to related transactions in the agency setup. For more information, see Setting Up
Agencies.

There are, however, things that the applicant can do but the contact can’t do, including:
- View application details.

- Make payments, or make payment cart changes related to the permit.
- Access web forms and web form attachments.

In addition, only applicants can see their permits listed on the Applications page.

Note: Before contacts can manage attachments, comments, and contacts, your agency must add the PSC
Contact User duty role (ORA_PSC_CONTACT_USER_DUTY) to the PSC Custom Registered Public User role
(CUSTOM_PSC_REGISTERED_PUBLIC_USER) and enable permit access for the contact type.

Adding a Contact Type

1. Select Common Setup > Contact Type.
2. On the Contact Type page, click Add.
3. On the Contact Type Detail page, enter values for the following fields:

Page Element Description

Contact Type Enter the type of contact, such as Business Owner, Individual, or Emergency Contact.
Description Enter a description of the contact type.

Permit Access Enabled Indicates whether permit contacts with this contact type are granted access to the

application. To access the permit, the contact must be a registered user, and the contact
email must match the account email.
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4. Verify that the Enabled switch is turned on.

The switch is on by default for a new contact type.
5. Click Save.

Modifying a Contact Type

Select Common Setup > Contact Type.

Click a row on the Contact Type page.

Make the desired changes on the Contact Type Detail page.
Click Save.

P UWNA

Deleting Contact Types

Select Common Setup > Contact Type.

2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Contact
Type Details page.

3. To delete one or more definitions without viewing details:

-—
.

a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.

Related Topics
- Setting Up Agencies

Setting Up Terms of Use

The Terms of Use page stores rules and guidelines to which user must agree as a condition of using a service. The terms
act as a legal contract. They are also known as Terms and Conditions or Terms of Service. When you set up a terms of
use definition, you also specify the contexts where the definition is available. For example, you can specify that certain
terms can be used for public user registration but not for permit applications or planning and zoning applications.

You add, modify, and delete terms of use definitions on the Terms of Use page.

This example illustrates the Terms of Use Details page.
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Terms of Use Details

* Terms of Use ID

* .
Effective Start Date
Effective End Date

* Description

Usage

2019-Jan-23

Open end date

Permits

Chapter 6

Setting Up Public Users

Planning and Zoning

Registration

#Content Keyboard users can place the cursor in the text editor and press Alt + 0 to access keyboard shortcut instructions.

Font

Adding Terms of Use

1. Select Common Setup > Terms of Use.
2. Onthe Terms of Use page, click Add.
3. On the Terms of Use Details page, enter values for the following fields.

Page Element

Terms of Use ID

Effective Start Date

Effective End Date

ORACLE

Size -IB I U & A B

Cancel Save

Description

Enter an identifier for the terms of use definition.

If a definition changes over time, create multiple definitions with the same ID and new
effective dates. The effective dates of the different versions must not have gaps or
overlap.

Enter the first day that the definition is valid.

Enter the date, if any, when the definition will no longer be valid. To keep the definition
valid indefinitely, do not enter a date. If no date is specified, the field displays the text
Open end date.

After a definition is saved, the end date becomes read-only. Although you can’t make
manual changes, the system can still update the end date to accommodate new
effective-dated entries. For example, if the currently effective definition has an open
end date, and you create a new definition with a later start date, the original definition’s
end date changes to the day before the new definition goes into effect.
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Page Element Description
Show All Dates Click this button to access the effective-dated history of the definition. This button is

not available during the creation of a new definition.

On the page that displays this history, use the Add button to add a new effective-dated
entry for the definition. The new entry inherits the same Terms of Use ID. You provide
the new effective start date and other details for the definition.

The system provides logic to prevent gaps or overlaps in the effective-dated history.

Description Enter a description of the terms of use. This is not part of the Terms of Use text that
public users see.

Usage Select the Permits check box to make this terms of use definition available for permits
applications. This option makes the definition available to the Terms of Use ID field on
the Permit Type page. Note that it is also necessary to add the Terms of Use element to
the permit form.

Select the Planning and Zoning check box to make this terms of use definition available
for planning applications. This option makes the definition available to the Terms of Use
ID field on the Planning Application Type page. Note that it is also necessary to add the
Terms of Use element to the planning application form.

Select the Registration check box to make this terms of use available for registration
functionality. This option makes the definition available to the Terms of Use ID field on
the Public User Setup page. See Setting Up Public Users.

You must select at least one check box.

Content Enter and format the detailed content of the terms to which a user must agree. This is
the text that users see when they are asked to agree to the terms.

4. C(lick Save.

Modifying Terms of Use

Select Common Setup > Terms of Use.

Click a row on the Terms of Use page.

On the Terms of Use Details page, you can update the description, usage and content.
Click Save.

P UWNa

Managing Effective-Dated Terms of Use Definitions

This example illustrates the Terms of Use Details modal page that displays the effective-dated history of a terms of use
definition.
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4 Common Data

Terms of Use ID Reg Terms

4 History Data

+ o o
Effective Start Date Effective End Date Description Permits Planning and Zening Registration Content
2/1/19 Open end date Registration terms and conditions updated Feb 2019 N N Y
1/1/19 1/31/19 Registration terms and conditions N N Y

Page 1 of 1 (1-2 of 2 items)

Select Common Setup > Terms of Use .

Expand the Common Data section to see the Terms of Use ID.

A WN

Click a history row to open the Terms of Use Details page for the specific row.
6. Click the Add button in the History section to create a new version of the definition.

Click a row on the Terms of Use page to open the Terms of Use Details page.
Click the Show All Dates button to view the effective-dated history of the definition you opened.

Expand the History section to see a list of all versions of this terms of use definition.

Chapter 6
Setting Up Public Users

In the new definition, you can modify any of the data except for the Terms of Use ID. An error message appears

if the new effective dates create gaps or overlaps in the definition history.

Deleting Terms of Use

1. Select Common Setup > Terms of Use.
2. Click a row on the Terms of Use page.
3. Onthe Terms of Use Details page, click Delete.

You are prompted to confirm the permanent deletion.

ORACLE
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7 Setting Up Property Information

Importing Property Information Using Functional Setup
Manager

You can import property information as CSV file packages using Oracle Functional Setup Manager.

When you enter or update a large volume of property data, using the setup task Ul to manage them individually may
not be the most efficient method. To create or update property data in bulk, use Oracle Functional Setup Manager to
import the data in the form of CSV file packages.

Oracle Public Sector Compliance and Regulation enables you to import data for the following property-related tasks.

Task Key Attributes Manual Setup Instructions
Manage Parcels ParcelldEntered Setting Up Parcels
Manage Parcel Owners OwnerName Setting Up Property Owners
Address1
PostalCode

OwnerCode (represents the ParcelldEntered
which is typically the Assessor’s Parcel Number)

Manage Parcel Addresses Address1 Setting Up Property Addresses
Address2

AddressCode (represents the ParcelldEntered,
which is typically the Assessor’s Parcel Number)

PostalCode

Manage Parcel Values ParcelldEntered Setting Up Parcel Values
EffectiveStartDate

EffectiveEndDate

Manage Districts ParcelldEntered Setting Up Districts

Districtld

Manage Parcel Districts Districtld Assigning Districts to Parcels

Assigning Districts to Addresses
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The import process uses key attributes to determine whether a row of data is new or updated. For example, when
importing parcel address data, the process checks the combination of the Address1, Address2, PostalCode and
AddressCode attributes for each row. If the combination of these attribute values in a row already exists in the
PSC_COM_PARCEL_ADDRESS table, the system updates the values for that row in the table. If the combination of these
attribute values does not exist in the table, the import process inserts a new row in the table.

To import an address with a parcel through FSM, there must be a ParcelNumber value in the AddressCode attribute of
the address import file. To import a parcel owner through FSM, there must be a ParcelNumber value in the OwnerCode
attribute of the address import file.

To import an address with no parcel through FSM, you must enter a value of Oin the Parcelld and ParcelNumber
attributes of the address import file.

CAUTION: While preparing the import file for Parcel Address and Parcel Owner, you must populate the Address Code
and Owner Code columns with the values from the ParcelldEntered column.

Tip: If you want to make any manual modifications to a downloaded CSV file before importing it, it is recommended
that you use a CSV editor. Opening the CSV file using spreadsheet software such as Microsoft Excel can change the
formatting of the fields, which could lead to errors during the import process.

Using Functional Setup Manager: Managing Setup Using CSV File Packages

Setting Up District Types

You add, modify, and delete district types on the District Type page.

Adding a District Type

1. Select Common Setup > District Type .
2. On the District Type page, click Add.
3. On the District Type Details page, enter values for the following fields:

Page Element Description

District Type Enter a unique identifier for the district type.

Description Enter a description of the district type.

District Type Category Select a category for the district type from the system-defined values:

o Code Enforcement
o Council
o Economic Development

o Zoning
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Page Element Description

o Inspection

o Plan review: District types with this value can be used to filter plan reviewers
for assignment to plan reviews. See Managing Manual Plan Review Cycles and
Electronic Plan Review Process Flow.

o General

4. |If the district type category is Code Enforcement, configure these settings:

Page Element Description

GIS Layer Enabled Indicate whether to use GIS to identify the district of an incident or case based on the
issue location.

The issue subtype for an incident or case is associated with a specific district type. If you
enable the GIS layer for the district type, the system can look up the issue location on
the map to determine the district that the incident or case falls in.

District Layer Service URL Enter the URL of the GIS map service that contains district information for the specified
district type.

This field becomes visible when the GIS Layer Enabled switch is active.

District in GIS Select the map service attribute that provides a district identifier.

This field becomes visible when the GIS Layer Enabled switch is active.

5. Turn the Enabled switch on to make the row available as a lookup value on other pages.
6. Click Save.
Modifying a District Type

1. Select Common Setup > District Type .
2. Click a row on the District Type page.
3. On the District Type Details page you can:

o Update the district type field values.
Note: You cannot edit the District Type field.

o Enable or disable the district type using the Enabled switch. Only enabled district types are available to
select as values on other pages.

o Delete the district type. You will be prompted to confirm the permanent deletion.

Note: You cannot delete a district type that is already associated with a district or an inspection type.

4. Click Save.
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Deleting District Types

Select Common Setup > District Type .

Click Edit.

Select the check boxes next to the district types you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PUWN

Note: You cannot delete a district type that is already associated with a district or an inspection type.

Setting Up Districts
You add, modify, and delete districts on the District page.

Adding a District

1. Select Common Setup > District .
2. Onthe District page, click Add.
3. Onthe District Details page, enter values for the following fields:

Page Element Description

District Enter a unique identifier for the district.

Description Enter a description of the district.

District Type Select a district type from the agency-defined values.

See Setting Up District Types.

District from GIS Enter the district’s identifier from the GIS map layer for the district type.

This field is visible only if a GIS map layer is specified in the district type definition. Only
district types that are classified as code enforcement district types have this option.

The system uses this information to populate the District field on code enforcement
issues. Using an issue’s district type and location, the GIS map service identifies the
specific district for the issue. The district identifier from GIS is then used to find the

Oracle district identifier for the issue.

4. C(lick Save.
Modifying a District
1. Select Common Setup > District .
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2. Click a row on the District page.
3. On the District Details page you can:

o Update the district field values.

Note: You cannot edit the District field.

o Delete the district. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Districts

Select Common Setup > District.

Click Edit.

Select the check boxes next to the districts you want to delete.

Click Delete. You will be prompted to confirm the permanent deletion.

PUNa

Setting Up Parcels

A parcel of real estate is a tract or plot of land.

A parcel that is held by an owner is a property. A parcel location can be found on a map and is associated with a physical
address. An owner or a contracted business can apply for a permit to develop or modify a structure on a parcel, or
create a planning application for planning and zoning requests.

You add, modify, and delete parcels on the Parcel page.

Adding a Parcel

1. Select Parcel on the Agency Springboard.
2. On the Parcel page, click Add.
3. Inthe Basic Information section of the Parcel Details modal page, enter information in the following fields:

Page Element Description

Parcel Number Enter the assessor’s parcel number (APN) for the parcel.

The APN is a number assigned to parcels of real property by the tax assessor of a
particular jurisdiction for identification and record-keeping purposes. The APN is unique
within the jurisdiction, and may conform to certain formatting standards that convey
basic identifying information such as the property type or the location on a map.

Parcel Type Enter a parcel type such as Condo or Single Family Home.
Status Select the current status of the parcel. Values are:
o Active
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Page Element Description

o Retired

o Provisional

Enabled Turn the Enabled switch on to make the parcel available as a lookup value on other
pages.
Property Description Enter a description of the parcel.

4. Inthe Land Use section of the Parcel Details modal page, enter details about the land associated with the parcel
using the following fields:
o Zoning Code
o Zoning Code 2
o Zoning Description
o General Plan
o General Plan 2
o Tax Rate Area
o Parcel Size 1
o Parcel Size 2
o Boundary Description
o Jurisdiction
o Census Tract
o Census Block
o Subdivision
o Climate Zone
o Flood Zone
o Flood Insurance Rate Map
o Liquefaction Risk
o Fire Risk
o Landslide Risk
o Soil Type
5. Inthe Building section of the Parcel Details modal page, enter details about the building associated with the
parcel using the following fields:
o Year Built
o Structure Size 1
o Structure Size 2

o Number of Dwelling Units
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o Bedrooms
o Bathrooms
o Pool
o Patio
o Additional Structure
6. Inthe Location and Map Information section of the Parcel Details modal page, enter mapping and location
details for the parcel using the following fields:
o Map Name
o Book Number
o Map Book Page
o Block Number
o Lot Number
o Section Number
o Latitude
o Longitude
o X Coordinate
o Y Coordinate
7. Click Save.

Modifying a Parcel

1. Select Parcel on the Agency Springboard.
2. Select a parcel on the Parcel page.

Note: The search interface for this page uses the typical filter by functionality, or the enhanced search if
Search Cloud Service is enabled. For more information on Search Cloud Service, see Setting Up Oracle Search
Cloud Service.

3. On the Parcel Details page you can:

o Update the parcel field values.
o Change the status of the parcel.

o Enable or disable the parcel using the Enabled switch. Only enabled parcels are available as lookup values
on other pages.
4. C(lick Save.

Deleting Parcels

Select Parcel on the Agency Springboard.

On the Parcel page, click Select Multiple.

Select the check boxes next to the parcels that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PUWNA
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Note: Agency staff and applicants cannot delete parcels. Only system administrators can delete parcels. Additionally,
only parcels that have not yet been associated with a permit can be deleted.

Configuring the Parcel Details Page

1. Select Parcel on the Agency Springboard.
2. Select a parcel on the Parcel page.

3. Click the Configure Page button in the global header to relabel or hide fields on the page. For more
information, see Modify Existing Pages.

Related Topics
- Setting Up Property Addresses

- Setting Up Property Owners
- Working with Property Attachments
- Applying Conditions to Parcels and Addresses

Setting Up Property Addresses

An address is the physical address associated with a property.
Oracle Public Sector Compliance and Regulation enables you to define property addresses by:

1. Adding addresses to existing parcels. You can add multiple addresses to one parcel.

2. Defining addresses that are independent of an existing parcel. After defining these addresses, you can
associate them with one or more parcels.

Adding an Address to an Existing Parcel

You add addresses to parcels on the Parcel Address page.

1. Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Address in the navigation bar.
2. Onthe Parcel Address page, click Add.
3. Inthe Basic Information section of the Parcel Address Details page, you can:
o Turn the Enabled switch on to make the row available as a lookup value on other pages.

o Turn the Primary switch on to indicate that this is the primary address associated with the parcel. A
parcel may have only one primary address.

4. In the Address Information section of the Parcel Address Details page, enter the following information:

Page Element Description

Address Fields The property address. The Country field displays US.
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Page Element

Address Line 1and Address Line 2

City and State

Postal Code
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Description

As you enter a Postal Code, the type-ahead list shows values that include appropriate
city and state combinations. After you select a value, the city and state appear as read-
only fields, and two address fields appear so that you can enter the rest of the address.

If you don’t know the postal code, click the Don’t know link to display a full set of
address fields.

Enter the street number or post office box number, along with any additional address
information such as apartment or suite number.

Enter the city and state for the address.

Enter the postal code for the address. The available values for this field are filtered
based on the city and state that you select.

5. Inthe Building and Location Information section of the Parcel Address Details page, enter the building and
location details for the parcel address using the following fields:

o

o

o

o

Building Type
Floor

Unit Number
Street Number
Street Name
Street Direction
Street Type
Longitude
Latitude

X Coordinate
Y Coordinate
Street Suffix
Crossroad 1
Crossroad 2
Landmark

6. Inthe Contact Information section of the Parcel Address Details page, enter the contact information details for
the parcel address using the following fields:

o

o

o

Name 1and Name 2

Email Address

Home Phone Number

ORACLE
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o Work Phone Number
o Cell Phone Number
o Fax Number

7. Click Save.

Adding an Address

You define addresses that are independent of existing parcels on the Address page.

1. Select Property Address on the Agency Springboard.
. On the Address page, click Add.
3. Inthe Basic Information section of the Address Details page, turn the Enabled switch on to make the row
available as a lookup value on other pages.
4. Inthe Address Information section of the Parcel Address Details page, enter the following information:

Page Element Description

Address Fields The property address. The Country field displays US.

As you enter a Postal Code, the type-ahead list shows values that include appropriate
city and state combinations. After you select a value, the city and state appear as read-
only fields, and two address fields appear so that you can enter the rest of the address.

If you don’t know the postal code, click the Don’t know link to display a full set of
address fields.

5. Inthe Building and Location Information section of the Address Details page, enter the building and location
details for the parcel address using the following fields:
o Building Type
o Floor
o Unit Number
o Street Number
o Street Name
o Street Direction
o Street Type
o Longitude
o Latitude
o X Coordinate
o Y Coordinate
o Street Suffix
o Crossroad1
o Crossroad 2
o Landmark
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6. Inthe Contact Information section of the Address Details page, enter the contact information details for the
parcel address using the following fields:

o Name1and Name 2
o Email Address
o Home Phone Number
o Work Phone Number
o Cell Phone Number
o Fax Number

7. Click Save.

Modifying a Property Address
1. You modify parcel addresses on the Address Details page. You can access this page two ways.
o Select Property Address on the Agency Springboard.

Select the address you want to modify.
o Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.
Click Parcel Address in the navigation bar.

Select an address associated with the parcel.
2. On the Address Details page you can:

o Update the address field values.

o Enable or disable the address using the Enabled switch. Only enabled parcel addresses are available as
lookup values on other pages.

o Indicate whether this is the primary address associated with a parcel using the Primary switch.
3. Click Save.

Associating Parcels with an Address

1. You associate parcels with addresses on the Parcel page. You can access this page two ways.
o Select Property Address on the Agency Springboard.
On the Address page, select the address for which you want to associate parcels.

Select Parcel in the navigation bar.
o Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.
Click Parcel Address in the navigation bar.
Select an address associated with the parcel.

Select Parcel in the navigation bar.
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2. Onthe Parcel page, click Add.

3. On the Parcel Address Details page, select the parcel that you want to associate with the address in the Parcel
ID field.

4. (Optional) If you want this address to be the primary address for the parcel, turn on the Primary switch.

5. Click Save.

Deleting Property Addresses

1. You can delete property addresses from the Addresses and Parcel Addresses pages.
o Access the Addresses page by selecting Property Address on the Agency Springboard.
o Access the Parcel Addresses page by selecting Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Address in the navigation bar.
2. Click Select Multiple.
3. Select the check boxes next to the parcel addresses that you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Property Owners

You add, modify, and delete property owners on the Owner page.

Adding a Property Owner

1. Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.
2. On the Parcel Owner page, click Add.
3. Inthe Basic Information section of the Parcel Owner Details page, enter information in the following fields:

Page Element Description
Enabled Turn the Enabled switch on to make the row available as a lookup value on other pages.
Primary Turn the Primary switch on to indicate that this is the primary owner associated with the

parcel. A parcel may have only one primary owner.

Owner and Secondary Owner Enter the names of the owner and secondary owner of the parcel.

Owner Type Enter the type of owner for the parcel such as Personal or Town.
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4. Inthe Location Information section of the Parcel Owner Details page, enter details about the location
associated with the parcel owner using the following fields:

Page Element

Address Fields

Street Number, Street Direction,
Street Name, and Street Type

Building Type

Floor

Unit Number

Description

The property owner address. The Country field displays US.

As you enter a Postal Code, the type-ahead list shows values that include appropriate
city and state combinations. After you select a value, the city and state appear as read-
only fields, and two address fields appear so that you can enter the rest of the address.

If you don’t know the postal code, click the Don’t know link to display a full set of
address fields.

Enter the street information for the parcel owner.

Enter the type of building associated with the parcel owner.

Enter the floor of the building for the parcel owner.

Enter the unit number for the parcel owner.

5. Inthe Contact Information section of the Parcel Owner Details page, enter the contact information details for
the parcel owner using the following fields:

o Email Address

o Home Phone Country Code

o Home Phone Number

o Work Phone Country Code

o Work Phone Number

o Cell Phone Country Code

o Cell Phone Number
o Fax Country Code

o Fax Number

6. Inthe Transfer Information section of the Parcel Owner Details page, enter transfer details for the parcel owner

using the following fields:

o Last Transfer Type
o Document Number
7. Click Save.
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Modifying a Property Owner
1. Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.
Click Parcel Owner in the navigation bar.

Select an owner associated with the parcel.

Note: Select Property Owneron the Agency Springboard to select a parcel owner to modify from a list of all
parcel owners.

2. On the Parcel Owner Details page you can:

o Update the parcel owner field values.

o Enable or disable the parcel owner using the Enabled switch. Only enabled parcel owners are available as
lookup values on other pages.
o Indicate whether this is the primary owner associated with the parcel using the Primary switch.

3. C(lick Save.

Deleting Property Owners

1. Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.
2. On the Parcel Owner page, click Select Multiple.
3. Select the check boxes next to the parcel owners that you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Assigning Districts to Parcels

You add, modify, and delete parcel district assignments on the Parcel District page.

Assigning districts to parcels is required setup for inspection scheduling. For more information, see Setting Up
Inspection Scheduling.

Assigning a District to a Parcel
1. Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.
2. On the Parcel District page, click Add.
3. On the Parcel District Details page, enter the district you want to associate with the parcel in the District field.
4. Click Save.
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Modifying a Parcel District Assignment

1. Select Parcel on the Agency Springboard.
Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.
2. Select a district on the Parcel District page.
3. On the Parcel District Details page you can:

o Select a different district to assign to the parcel.
o Delete the assigned district. You will be prompted to confirm the permanent deletion.
4. Click Save.

Deleting Parcel District Assignments
1. Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.
2. Click Select Multiple.
3. Select the check boxes next to the parcel district relationships you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Assigning Districts to Addresses

You assign districts to addresses on the Address District page.

Inspections are scheduled and assigned based on the district associated with a property. For properties associated with
a parcel, you assign districts to the parcel on the Parcel District page. See Assigning Districts to Parcels. For properties
with an address, but no parcel, use the Address District page to assign districts to a property.

For more information on inspection scheduling and assignment, see Setting Up Inspection Scheduling.

Assigning a District to an Address
1. Select Property Address on the Agency Springboard.

Select an address on the Address page.

Click Address District in the navigation bar.
Note: The Address District page is available only for addresses with no parcel.

2. On the Address District page, click Add.

3. On the Address District Details page, enter the district you want to associate with the address in the District
field.

4. C(lick Save.
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Deleting an Address District Assignment
1. Select Property Address on the Agency Springboard.

Select an address on the Address page.

Click Address District in the navigation bar.
Note: The Address District page is available only for addresses with no parcel.

2. Select a district on the Address District page.
3. Onthe Address District Details page, click Delete. You will be prompted to confirm the permanent deletion.

Note: If you associate an address that has a district assigned to it to a parcel, the system automatically removes the

district assignment. This is because the district assignment is now defined through the parcel associated with the
address rather than through the address itself.

Setting Up Parcel Values

You add, modify, and delete parcel values on the Parcel Value page.

Adding a Parcel Value

1. Select Common Setup > Parcel Value.
2. On the Parcel Value page, click Add.
3. On the Parcel Value Details page, enter information in the following fields:

Page Element Description

Parcel ID Enter the ID of the parcel for which you are defining an address.

For more information on parcels, see Setting Up Parcels.

Effective Start Date and Effective = Enter the date range for which the parcel value is valid.
End Date

Note:
You can leave the Effective End Date field blank to give the parcel an open end date.

Parcel Size 1 and Parcel Size 1UOM Enter a numeric value and a unit of measure to define the size of the parcel.
(parcel size 1 unit of measure)

Parcel Size 2 and Parcel Size 2 Enter a numeric value and a unit of measure to define an additional size for the parcel.
UOM (parcel size 2 unit of measure)
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Page Element Description
Land Value Enter the monetary value of the land associated with the parcel.
Improvement Value Enter the monetary value of any improvements made to the parcel.
Personal Property Value Enter the monetary value of any personal property associated with the parcel.
Fixtures Enter the monetary value of any fixtures associated with the parcel.
Owner Exemption, Fixture Enter the monetary value of any exemptions associated with the parcel.

Exemption, and Other Exemption

Net Assessed Value Enter the assessed monetary value of the parcel.

Currency Code Enter the currency that applies to the parcel value.

Property Use Code Enter the property use code associated with the parcel.

Parcel Number Displays the parcel number associated with the Parcel ID that you selected.
4. Click Save.

Modifying a Parcel Value

1. Select Common Setup > Parcel Value.

2. Click a row on the Parcel Value page.

3. On the Parcel Value Details page you can:
o Update the parcel value field values.

Note: You cannot edit the Parcel ID and Effective End Date fields.

o Delete the parcel value. You will be prompted to confirm the permanent deletion.
4. Click Save.

Setting Up Ownership Types

Ownership type indicates how a business was established; for example, a corporation or a nonprofit. You set up
ownership types for your agency on the Ownership Type page.

95
ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 7
Implementing Your Agency Setting Up Property Information

Adding an Ownership Type

Select Common Setup > Ownership Type.

On the Ownership Type page, click Add New to add an ownership type.

On the Ownership Type Details page, enter a name for the ownership type.

Enter a description.

Verify that the Enabled switch is turned on. The switch is turned on by default for a new ownership type.
Click Save.

cUupUN

Modifying an Ownership Type

1. Select Common Setup > Ownership Type e.
2. Onthe Ownership Type page, click the row for the ownership type that you want to modify.
3. On the Ownership Type Details page you can:

o Modify the ownership type description. You cannot change the name.

o Click the Enabled switch to enable or disable the ownership type.
4. If you made any changes, click Save.

Deleting an Ownership Type

Select Common Setup > Ownership Type e.

On the Ownership Type page, click the row for the ownership type that you want to delete.

On the Ownership Type Details page, click Delete.

If you want to delete multiple ownership types, you can delete them from the Ownership Type page:
a. Click Edit.
b. Select the check boxes for the ownership type rows to delete.
c. Click the Delete icon.

PUNa

Setting Up Property Types

Property type categorize properties according to criteria such as how the property is used or the type of dwelling.

You add, modify, and delete property types on the Property Type page.

Adding a Property Type

1. Select Common Setup > Property Type.
2. On the Property Type page, click Add.
3. On the Property Type Detail page, enter values for the following fields:

Page Element Description
Property Type Enter the type of property, such as Residential or Commercial.
Description Enter a property type description.

96
ORACLE



Oracle Public Sector Compliance and Regulation Cloud
Implementing Your Agency

Page Element Description

4. Verify that the Enabled switch is turned on.

The switch is on by default for a new property type.

5. Click Save.

Modifying a Property Type

1. Select Common Setup > Property Type.
2. Click a row on the Property Type page.
3. On the Property Type Detail page you can:

o Update the property type description.

o Turn off the Enabled switch to deactivate the property type.

4. C(lick Save.

Deleting Property Types

1. Select Common Setup > Property Type.

Chapter 7
Setting Up Property Information

2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Property

Type Details page.

3. To delete one or more definitions without viewing details:

a. Click Edit.

b. Select the check boxes next to the definitions that you want to delete.

c. Click Delete.

You will be prompted to confirm the permanent deletion.

Setting Up Property Conditions

A property condition identifies the general condition of the property. This value is used to indicate the general age of a

property, a property’s physical condition, or other condition.

You add, modify, and delete property conditions on the Property Condition page.

Adding a Property Condition

1. Select Common Setup > Property Condition.
2. Onthe Property Condition page, click Add.

3. On the Property Condition Detail page, enter values for the following fields:

Page Element Description

Property Condition Enter the property condition, such as Poor or Good.
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Description Enter a description of the property condition.

4. Verify that the Enabled switch is turned on.
The switch is on by default for a new property condition.
5. Click Save.
Modifying a Property Condition

1. Select Common Setup > Property Condition.
2. Click a row on the Property Condition page.
3. On the Property Condition Detail page you can:

o Update the property condition description.
o Turn off the Enabled switch to deactivate the property type.
4. C(Click Save.

Deleting Property Conditions

1. Select Common Setup > Property Condition.
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2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Property

Condition Details page.
3. To delete one or more definitions without viewing details:

a. Click Edit.

b. Select the check boxes next to the definitions that you want to delete.

c. Click Delete.

You will be prompted to confirm the permanent deletion.
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8 Setting Up Contractor Licenses

Setting Up Contractor License Options

Contractor license options are system-wide settings that control contractor license processing and data. You can
maintain multiple sets of options, each with its own identifying code. But only one code at a time can be active.

Use contractor options to control:

- Whether you integrate with an external licensing body to validate license information during application intake.
- Whether to allow users to manually choose classifications for licenses.

- Whether to decline an application based on the status of the license.

- Which sections for supplemental license information are visible to users.

- Which ownership and insurance types the applicant can select in the intake form.

You can also establish an integration with an external licensing body to load license information into your contract
records.

Configuring Contractor License Options

To set up contractor options:

Select Contractor Setup > Contractor License Options.

Click Add to create a new set of options, or click an existing row to modify it.
If you're creating a new set of options, enter a unique Code as an identifier.
Enter a Description for this set of configuration options.

PUWUN

The description should be suitable for end-users because both public users and agency staff see the
description when entering contractor information.

5. Use the Active switch to indicate whether this is your active contractor configuration.

Only one set of configuration options can be active. If another configuration is already active, then an error
message explains that you must turn off this switch for the active configuration first.

6. Use these switches to enable additional configuration options:

Page Element Description

Integrated with External Source When this option is enabled, users can retrieve license information from an external
licensing body in the intake form. Click the Integrations link to identify the Oracle
Autonomous Integration Cloud (OIC) integration that retrieves the information.

When integration is inactive, the Limit to Contractor List option is automatically
enabled and the License Types link appears.

Whether the Integrated with External Source switch is on or off, you can set up an
integration to load license data using batch processing in the Integrations section.

99
ORACLE



Oracle Public Sector Compliance and Regulation Cloud

Implementing Your Agency
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Limit to Contractor List

Document Group
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Description

When this option is enabled:

o Users can only select licenses from the agency’s contractor records in the intake
form, whether or not there’s an active integration.

o The agency can still add licenses to the contractor records from an external source
using an integration.
When this option is off, licenses entered in the intake form are retrieved first from the

contractor records if they exist there, then from the external licensing body.

Select a document group.
When you specify a document group, document attachments can be classified into
categories and subcategories when you upload files. Then you can see the category for

a document on the Attachments page in the contractor license details.

For more information, see Setting Up Document Groups.

Working with Integrations

To enable integration with an external contractor license source:

1. Click the Integrations link to configure integration settings in the Integrations grid.
2. Click the Add action to add an integration. You can only add one of each type of integration.
3. Enter the following for each integration:

Page Element

Type

Integration Name

Integration Parameter

Integration Version

Key

ORACLE

Description

Identifies the process that uses integration:

o Verify license online retrieves information for a specific license that a user enters in

the main contractor page or in the intake form for a permit or planning application.

These pages have a button that the user clicks to initiate information retrieval.

o Batchload license data establishes the integration used to load information for
multiple licenses into your contractor records when batch processing runs.
You can create only one row for each integration type.

Enter the name of the OIC integration that retrieves contractor license information.

Enter the query parameters for the OIC integration end point.

Enter the version number of the OIC integration.

Leave this field blank. The source key is maintained in the OIC integration definition.
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Integration Enabled

Selecting License Types

You must set up license types when the system isn't integrated with an external source. Applicants select a contractor
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Description

Indicate whether the integration type is enabled.

license type when entering contractor information in the intake form.

If the Integrated with External Source switch is turned off, the License Types link becomes visible.

To select license types for this set of license options:

1. Click the License Types link to maintain license types.
2. C(lick the Add action to add a license type.
3. Enter the following information for each license type:

Page Element

License Type

Description

Enabled

Description

Enter the unique identifier for the license type.

Enter the descriptive name of the license type.

Indicate whether the license type is enabled.

Working with License Classifications

To set up license classifications for this set of license options:

1. Click the Classifications link to maintain the license classifications in the Classifications grid.
2. Click the Add action to add a classification.
3. Enter the following information for each license classification:

Page Element

Code

Description

Enabled

ORACLE

Description

Enter the unique identifier for the license classification. The contractor licensing body
sets these codes.

Enter the descriptive name of the license classification.

Indicate whether the license classification is enabled.
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Working with License Statuses

The statuses that the licensing body assigns are called source statuses. When integration is turned on, you map a
source status to an agency’s internal status.

CAUTION: The license status defaults to Other for unmapped source statuses. Applications that include licenses with
an Other status are automatically declined.

To set up license status mapping rules:

1. Click the Status Rules link to maintain a mapping in the Status Rules grid.
2. C(lick the Add action to add a mapping.
3. Enter the following information for each status rule:

Page Element

Status

Source Status

Decline Application

Enabled

Description

Select the agency status for this rule. When a license has this status in the contractor
records, and the Decline Application switch is on, the application can’t be submitted.

If using an integration, select the agency status to assign to licenses that have the
specified source status. If multiple source statuses map to a single agency status, there
will be multiple rows for the agency status.

Enter a license status that’s assigned by the licensing body. This field is only available
when you're integrating with a licensing body. When integration is turned on, you map a
source status to an agency’s internal status.

Enable this switch to prevent applications from being submitted when a contractor
license has this agency status, or this source-to-agency status mapping when
integrated with an external licensing body.

Indicate whether the status rule is enabled.

Displaying Category Sections

Sections are specific categories of supplemental information about licenses. License classifications appear in a section
on the intake form and contractor record. Other sections include information about bonds and insurance such as
Workers' Compensation. You can change section titles that appear on the intake form and contractor record by updating
the section description on Contractor License Sections setup page.

To select the sections you want to display:

1. Click the Sections link to maintain sections in the Sections grid.
2. C(lick the Add action to add a section.
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3. Inthelist of available sections, use the Enabled switch to control section visibility. Turning off the switch hides
the section on the intake form and contractor record from both agency staff and public users.

Selecting Ownership Types

Applicants select an ownership type from the list when providing license information on the intake form. You define
which ownership types are available to choose from.

To select the ownership types you want to display:

1. Click the Ownership Types link to maintain the types of business ownership that can be associated with the
contractor’s license in the application.
2. Click the Add action in the Ownership Types grid.

Using the lookup prompt, you can select from the ownership types that you set up on the Ownership Types
page, for example, Corporation, Partnership, or Sole Proprietorship. For information about setting up ownership
types, see Setting Up Ownership Types. If an ownership type is retrieved from an integration but isn’'t in the
contractor license options, the ownership type is added to the Contractor License Options page.

3. Turn on the Enabled switch to indicate the ownership type is active.

Setting Up Insurance Types

To set up the insurance types you want to display:

Click the Insurance Types link to display the Insurance Types grid.

Click the Add action to add the types of insurance information that can be associated with a license.
Enter values in the Insurance Type and Description fields.

Turn on the Enabled switch to indicate the insurance type is active.

PUWUN

Setting Up Contractor License Sections

Contractor license information can include sections with different types of data such as license classification
information, workers’ compensation information, and contractors’ bonds. To ensure that users see meaningful labels for
these sections, use the Contractor License Sections page to maintain section descriptions.

Note: This page is only for updating descriptions. To hide a section so it is not seen by either agents or public users,
use the Contractor License Options page.

To maintain the descriptions of contractor license sections:

1. Select Contractor Setup > Contractor License Sections.
2. Review the Description for each delivered section, and update the descriptions as needed.

These are the delivered sections:

Section Code Delivered Description

ORA_BQI Other Bonds
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Section Code Delivered Description
ORA_CB Contractor Bond
ORA_CLASS Classification
ORA_WC Workers' Compensation
3. Click Save.

Preparing to Load Contractor Licenses

Oracle provides a prebuilt Oracle Integration Cloud (OIC) integration to load licenses from a manually provided file, or
you can get licenses from a contractor licensing body. Import a package and activate integration settings in OIC before
you load contractor licenses.

Your OIC configuration depends on which batch load method you're using. You can retrieve licenses from:

- A contractor licensing body.

This option is only available with integration to an external service and integration is enabled on the Contractor
License Options setup page. This option applies when you want to update the licenses in your contractor list.

- Afile.

You can manually load a file with contractor licenses regardless of whether an integration with an licensing
body is enabled or not. When an online integration is not available and integration is disabled on the Contractor
License Options setup page, licenses can only be loaded using a file. This option can help you migrate
contractor data from a legacy system.

For information about integration settings on the Contractor License Options page, see Setting Up Contractor License

Options.

To configure OIC to load contractor licenses:

1.

2.

ocunpw

® N

Go to My Oracle Support (MOS) and access Doc ID 27595021, "Configuring Oracle Integration Cloud (OIC) for
Loading Contractor Licenses in Public Sector Compliance and Regulation."
Follow the instructions on the MOS page, and save the .par package file for loading licenses from a contractor
licensing body or a license file.
Access the main console in OIC.
Click Packages in the left frame.
Click the Import button at the top of the Packages page.
Select the package file for loading licenses from an external licensing body or license file, then click the Import
button.
Click Connections in the left frame.
Configure, test, and save these connections in the package:
a. FTP Read Contractor File
b. PSC Rest Connector
c. CSLB Rest Trigger
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d. CSLB REST CONNECTOR
9. C(lick Integrations in the left frame.
10. Configure and activate these integrations in the package:

a. CSLBBATCH LOAD - REST
b. CSLB POST LICENSE - REST

Related Topics
- Loading Contractor Licenses

Loading Contractor Licenses

You can use batch processing to load contractor license records manually from a file or through an integration with a
licensing body. Merge options enable you to load a full file or update licenses matching those in the agency-maintained
contractor list.

Processing can be executed as needed, such as when you want to migrate contractor data from a legacy system, or on a
scheduled basis to refresh license records in the contractor list.

Before You Begin

Oracle provides a prebuilt Oracle Integration Cloud (OIC) integration to load licenses. You import a package and activate
integration settings in OIC before you run batch processing.

For information about OIC configuration for an integration with a licensing body and connections for loading a file with
license records, see Setting Up Contractor Integration and Preparing to Load Contractor Licenses.

Entering Parameters

1. Select Contractors > Load Contractor Licenses .
2. Access the Parameters tab on the Load Contractor Licenses page.
3. Enter the parameters for your batch process.

Page Element Description

Data Source Select an option to indicate the source of the license records that you want to load:

o File—Processing picks up license information from a file to merge with license
records.

o Integration service — Processing connects with a licensing body through an
integration service to get the license file and merge license records.

Merge Option Select how you want to merge the data from the source with your system:
The Entire file option works in two ways:

o Loads any new licenses from the file that do not exist in the contractor list.

o Updates existing licenses in the contractor list from the file.
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Page Element Description

Use the Contractor list option to update licenses that already exist in the contractor list.
The process skips licenses that don't exist in the contractor list.

Period in Which Licenses Were Identify which records you want to merge by when they were last updated. For example,
Last Updated if you want to merge the records from the source that were updated in the last two
weeks, select the number 2 and the unit of time, Weeks.

o Select a number 1or greater.

o Select a unit of time, including None, Days, Weeks, or Months. If you don't want to
load records based on a given period, select None.

Note:

To identify licenses that were updated in the specified period only, the license data
must have a last updated date. If a licensing body doesn't use a last updated date,
select None.

Scheduling the Process

1. Access the Schedule tab.
2. Toimmediately add the process to the queue, select the As soon as possible option.
3. To create a schedule for the process, select the Using a schedule option, and enter values using the following
fields:
Page Element Description
Frequency Select how frequently you want to run the process. Values are:
o Once: Select to run the process one time only.
o Hourly or minute: Select to run the process at regular time intervals.
o Daily: Select to run the process at regular intervals in days.
o Weekly: Select to run the process at regular intervals in weeks.
o Monthly: Select to run the process on specific days of the month.
o Yearly: Select to run the process during specific months.
Start Date Enter the date on which you want to begin your scheduled processing.
End Date Enter the date on which you want to end your scheduling processing.
Hours and Minutes Enter the time interval between scheduled processes. For example, if you enter 2 in

the Hours field and 30 in the Minutes field, the process will run every 2 hours and 30
minutes beginning on the specified start date.
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Description

Note:
These fields are available only if you select a process frequency of Hours or Minutes.

Enter the number of days between scheduled processes. For example, if you enter 3, the
process will run every 3 days beginning on the specified start date.

Note:
This field is available only if you select a process frequency of Daily.

Enter the number of weeks between scheduled processes. For example, if you enter 6,
the process will run every 6 weeks beginning on the specified start date.

Note:
This field is available only if you select a process frequency of Weekly.

Select this option to run the process on specific days of the month irrespective of the
date. For example, if you select the Secondand Wednesday options, the process will run
on the second Wednesday of every month.

You can select more than one week of the month and day of the week option. For
example, you could schedule the process to run on the first and third Monday of every
month.

Note:
This option and its associated fields are available only if you select a process
frequency of Monthly or Yearly.

Select this option to run the process on specific dates of the month. You can select more

than one date.

Note:
This option and its associated fields are available only if you select a process
frequency of Monthly or Yearly.

Select the months in which you want your process to run.
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Page Element Description

Note:
This option and its associated fields are available only if you select a process
frequency of Yearly.

Setting Up Process Notifications

You can set up the process to send notifications to you and others when it runs.

1. Turn on the Notify Me When This Process Ends switch to send yourself a notification when the process
finishes.

2. Access Notification tab.
Click Add.
4. On the Create Notification page, enter the email address of the person you want to receive notifications.

w

By default, the recipient will receive a notification when the process ends with the following conditions:

o On success
o Onerror

o Onwarning

You can remove any of these process notification conditions.
5. Click OK to save the notification recipient.
6. (Optional) To delete a notification recipient, select the recipient in the Notification tab and click Delete.

Submitting the Process

Once you've entered your process parameters, scheduling information, and notification recipients, you're ready to
submit the process. Enter any additional information in the Submission Notes field and click Submit. Click Process
Monitor to check the status of your process.
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9 Setting Up Comments

Managing Comments

This topic provides an overview about Standard Comments and discusses how to manage comments.

Standard Comments Overview

Standard comments are predefined comments that users can easily and quickly use, instead of manually entering the
text. Standard comments are generic and complete, which make them reusable.

Users can use standard comments across all Public Sector Compliance and Regulation offerings. You can use standard
comments while updating your applications.

System administrators set up application categories and subcategories using the Application Category page, based on
the type of comments you wish to have. Standard comments are set up using the Standard Comments page.

Managing Comments

You manage the comments by setting up how you want the comments to be available for the agency staff members.

1. Select Comments > Manage Comments .
2. On the Manage Comments page, you add values to all these fields:

Page Element Description
Number of days comment is Enter a numeric value or use the increment/decrement buttons. The number of days a
recent comment is listed as Recent is based on the value in this field.
Rich Text Editor Use the switch to enable or disable Rich Text Editor formatting for comments.
Comment Summary Length Enter a numeric value or use the increment/decrement buttons. This value determines
the maximum number of characters that can be displayed in the Comment Summary
field.
Note:

The system allows a maximum length of two hundred (200) characters in the
comment summary.

3. Click Save to save the changes.
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Setting Up Standard Comment Categories and
Subcategories

This topic discusses how to set up Standard Comment Categories and Subcategories.

Setting Up Standard Comment Categories and Subcategories

You set up the comments categories and subcategories on the Application Category page.

1. Select Comments Setup > Comment Categories .

On the Application Category page, click Add to add a new category.
2. Onthe Application Category Details page, you add values to all these fields:

Field Name Description
Application Category Enter a category.
Description Enter a description for the category. This description displays detailed information

about the category when searching for categories.

3. Turn on the Enabled switch if you want to enable this category when you save it. The switch is turned off by
default for a new category.

4. Inthe Application Groups section, you can include application groups that you want this category to be
available for. Click Add to open the Application Group Details page, select the application group.

Turn on the Enabled switch if you want to enable the selected group when you save the page.

Click Save to save the newly added application group and return to the Application Category Details page.
To add an application subcategory, select the Application Subcategories section and click Add.

On the Application Subcategory Details page, you add values to all these fields:

@O W

Field Name Description

Application Subcategory Enter a subcategory

Description Enter a description for the subcategory. This description displays detailed information
about the subcategory when searching for subcategories.

9. Turn on the Enabled switch if you want to enable this subcategory when you save it. The switch is turned off by
default for a new subcategory.
10. Click Save to save the newly added application subcategory and return to the Application Category Details
page.
11. Click Save to save the record and return to the Application Category page.
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Modifying Standard Comment Categories and Subcategories

You modify the comments categories and subcategories on the Application Category Details page.

Select Comments Setup > Comment Categories .

On the Application Category page, click the chevron on a category line to select and modify the category.

On the Application Category Details page, enter new values in the Application Category and Description fields.
Verify that the Enabled switch is turned on if you want to enable this category when you save it.

Use the Application Groups section to select the application group that you want this category to be available
for.

In the Application Subcategories section, you can edit the application subcategories.
7. Click Save to save the changes. You can use the Delete button to delete the category.

vihWNA

o

Viewing, Adding, Modifying, and Deleting Standard
Comments

This topic discusses how to view, add, modify, and delete Standard comments.

Viewing Standard Comments

You search and view Standard Comments on the Standard Comments page.

1. Select Comments Setup > Standard Comments .
2. Use the application category or application subcategory fields to filter comments on the Standard Comments
page.

Adding Standard Comments

You add comments using the Add button on the Standard Comment page.

1. Select Comments Setup > Standard Comment

2. Onthe Standard Comments page, click Add to open the Standard Comment Details page and add a new
comment.

3. Onthe Standard Comment Details page, enter values for these fields:

Page Element Description

Comment Code Enter a comment code.
Application Category Enter an application category
Application Subcategory Enter an application subcategory
Description Enter a comment.
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Page Element Description

4. Verify that the Enabled switch is turned on if you want to enable this comment when you save.
5. Click the Save button to save the new comment and return to the Standard Comment page.

Modifying Standard Comments

You modify comments on the Standard Comment Details page.

1. On the Standard Comments page, click the chevron on a comment line to select and modify the comment.

2. To modify the comment, you can change the values entered in the Application Category and Application
Subcategory fields, and edit the description.

3. Verify that the Enabled switch is turned on if you want to enable this modified comment when you save.

4. C(lick Save.

Deleting Standard Comments

You delete comments on the Standard Comment Details page.

1. On the Standard Comments page, click the chevron on the comment line which you want to delete.
2. Onthe Standard Comment Details page, click the Delete button to delete the comment.
3. Click Yes on the confirmation page to delete the comment and return to the Standard Comments page.
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10 Setting Up Documents

Setting Up Document Categories and Subcategories

You set up document categories and subcategories on the Document Category pages to organize the various types of
attachment files.

This example illustrates the Document Category Details page, which is described in the following text.

Document Category Details Cancel  Delete

* Category ID  Initialization
* Category Project Initialization

* Description  Project Initialization

Document Subcategory
=+ X Search oYy
Subcategory ID Subcategory Description Enabled
Initialization Approved Initialization Approved Project Initialization Approved Yes >

Project Charter Project Charter Project Charter Yes >

Adding Document Categories and Subcategories

1. Select Common Setup > Document Category .
2. Onthe Document Category page, click Add to add a new document category.
3. Enter values on the Document Category Details page:

Page Element Description
Category ID Enter an identifier for the category.
Category Enter a name for the category.
Description Enter a description of the category.
Enabled Turn the switch on to make the category available for use. The category is disabled by
default.
Click Save.

If you want to add a subcategory, click Add in the Document Subcategory section.
On the Document Subcategory Details page, enter an ID, name, and description for the subcategory.
Click Save.

No Uk
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Modifying Document Categories and Subcategories

1
2,
3.

Select Common Setup > Document Category .

On the Document Category page, select the row for the category that you want to modify.

On the Document Category Details page, you can modify the category name and description, and turn the
Enabled switch on or off.

Click Save to save any changes.

To modify a document subcategory:

a. Select the associated category to open the Document Category Details page.

b. Select the subcategory that you want to modify.

c. On the Document Subcategory Details page, you can change the subcategory name and description, and
turn the Enabled switch on or off.

d. Click Save.

Deleting Document Categories and Subcategories

1

Select Common Setup > Document Category .

2. Onthe Document Category page, select the row for the category that you want to delete.

If you want to delete the document category, click Delete on the Document Category Details page.

Note: When you delete a document category, all associated subcategories are also deleted.
If you want to delete multiple document categories, you can delete them on the Document Category page:

a. Click Edit.
b. Select the check boxes for the document category rows to delete.
c. Click Delete.
To delete the document subcategory, click Delete on the Document Subcategory Details page.

If you want to delete multiple subcategories, you can delete them from the Document Category Details page
using the Edit and Delete buttons.

Setting Up Document Groups

You set up document groups using the Document Group pages to organize the various categories of attachment files
into a grouping.

When you assign a document group to a transaction type, the categories and subcategories associated with that
document group can be selected for document attachments associated with those transactions.

This example illustrates the Document Group Details page, which is described in the following text.
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Document Group Details Cancel | Delete

* Group ID  ZPER-DOCGRPID1 Enabled c
* Descripti

* Group ZPER-DOCGRP1 Document Group1

Document Category

Category ID

Document Category

Category Description Enabled Actions

BLUEPRINT Q BLUEPRINT Drawings blueprints and layouts (/\ + 0
Forms._1548829255279 Q Blueprints Application form O + 0
Adding Document Groups
1. Select Common Setup > Document Group .
2. On the Document Group page, click Add to add a new document group.
3. Enter values on the Document Group Details page:
Page Element Description
Group ID Enter an identifier for the group.
Group Enter a name for the group.
Description Enter a description of the group.
Enabled Turn the switch on to make the group available for use. The group is disabled by default.
4. C(lick Save.
5. Add document categories that make up the grouping by clicking Add in the Document Category section.
6. Enter a document category ID or use the lookup prompt to find a category ID.

7.

If desired, you can click the Document Category link to research which category to choose. For more
information about document categories, see Setting Up Document Categories and Subcategories.
Click Save.

Modifying Document Groups

N =

Select Common Setup > Document Group .

On the Document Group page, select the row for the group that you want to modify.

On the Document Group Details page, you can modify the group name and description, and turn the Enabled
switch on or off.

Disabled document groups can’t be selected in the prompt list for a transaction type.
Note: Disabling a document group does not affect attachments for existing or new transactions associated
with permit types to which that document group is assigned. The categories and subcategories associated

with a disabled group continue to display for existing attachments, and are still available to select for new
attachments.
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4.
5.

Click Save to save any changes.
You add, remove, disable, and enable document categories for the group in the Document Category section.

When you disable a single category associated with a document group, that category and its subcategories
continue to display for existing attachments, but are unavailable for new attachments.

To modify a document category, you must go to the Document Category definition pages. See Setting Up
Document Categories and Subcategories.

Note: If you disable a category on the Document Category Details page, but it’s still included in the list of
enabled categories for a document group, it will continue to be available in the prompt list for attachments.

Deleting Document Groups

P UWNa

Select Common Setup > Document Group .

On the Document Group page, select the row for the group that you want to delete.

Click Delete on the Document Group Details page.

If you want to delete multiple document groups, you can delete them on the Document Group page:

a. Click Edit.

b. Select the check boxes for the document group rows to delete.

c. Click Delete.
To delete a document category from the group, click the Delete icon for the document category row in the
Document Category section.

Related Topics

- Setting Up Business License Types

- Setting Up Permit Types

 Setting Up Planning Application Types
- Working with Attachments
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11 Setting Up Communications

Setting Up the Twilio Security Endpoint

This topic discusses how to enable and set up the Twilio security endpoint for text message communications.

Text communications through Twilio is an optional feature provided in Oracle Functional Setup Manager (FSM) . Before
configuring this feature, you must first enable it.

Enabling the Twilio Integration

Access FSM by selecting Setup and Maintenance in the navigator.

Select a PSCR offering such as Public Sector Permits or Public Sector Planning and Zoning.
Click the Change Feature Opt In link.

Click the Features icon for the System Administration functional area.

Click the Enable check box for the Text Communications through Twilio feature.

R UWNS

I Note: You can deselect the Enable check box to disable the Text Communications through Twilio feature.

Configuring the Twilio Security Endpoint

Once the Twilio integration is enabled, you can configure the Twilio security endpoint on the Manage Twilio Security
Endpoint page.

1. Access FSM by selecting Setup and Maintenance in the navigator.
2. Select a PSCR offering such as Public Sector Permits or Public Sector Planning and Zoning.
3. Select the System Administration functional area.
4. Inthe Show field, select All Tasks.
5. Select the Manage Twilio Security Endpoint task.
6. On the Manage Twilio Security Endpoint page, enter information for the following fields:
Page Element Description
URL Enter the URL to access Twilio’s token endpoint. This should include the host and the

context root information. Use the sandbox endpoint for testing and then use the live
URL when you go live.

Security Policy Select the applicable token from the drop-down list.
Username Enter the API client_id value for your Twilio endpoint account.
Password Enter the Twilio endpoint APl secret code for your Twilio endpoint account.
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7. Click Save and Close to save the configuration and return to the Setup page.

Delivered Communication Events

Oracle Public Sector Compliance and Regulation delivers a robust registry of communication events that are triggered
by transactions and processes within the application. You can view a partial list of communication events and
descriptions in this topic.

The delivered communication events are found on the Communication Events page. In the Navigator, select
Communication Setup > Communication Events .

Ad Hoc Communication Resource

Communication Event Name Communication Description

Ad Hoc Communication Event An ad hoc email or notification was sent.
For more information on ad hoc communications, see Working with Ad Hoc Communications.
Communication Record Details

Communication Event Name Communication Description

Web Form Response Notifies agency staff that an applicant responded to a web form questionnaire.
For more information on web form questionnaires, see Working with Application Communications.

Expiration Communication Resources

Communication Event Name Communication Description
About to Expire Permit Generates a notification when a permit is about to expire or expired.
Expired Permit For example, when the permit is about to expire or expired, the agency staff and the contact listed on

the application receive a notification.

Permit About to Expire Based on Generates a notification when a permit is about to expire or expired due to inactivity, because the first
Inspection Commencement inspection hasn’t been scheduled or passed.

Permit Expired Based on Inspection For example, when a permit is about to expire or expired due to inactivity because the first inspection
Commencement hasn’t commenced, the agency staff and the contact on the application receive a notification.

About to Expire Planning and Zoning Generates a notification when the planning application is about to expire or expired.

Application

For example, when the planning application is about to expire or expired, the agency staff and the
Expired Planning and Zoning Application = contact listed on the application receive a notification.

18
ORACLE


http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=WorkingWithAdHocCommunications
http://www.oracle.com/pls/topic/lookup?ctx=pscr21c&id=WorkingWithApplicationCommunications

Oracle Public Sector Compliance and Regulation Cloud Chapter 11

Implementing Your Agency Setting Up Communications
Communication Event Name Communication Description
About to Expire Pre-Application Generates a notification when the pre-application is about to expire or expired.
Expired Pre-Application For example, when the pre-application is about to expire or expired, the agency staff and the contact

listed on the application receive a notification.

For more information about permit and planning application expiration, see Expiration Overview and Working with
Application Expiration.

Communication Event Name Communication Description
About to Expire Business License Generates a notification when a business license is about to expire or expired.
Expired Business License For example, when the business license is about to expire or expired, the agency staff and the contact

listed on the application receive a notification.

About to Expire Business License Generates a notification when a business license consultation is about to expire or expired.
Consultation

For example, when the business license consultation is about to expire or expired, the agency staff and
Expired Business License Consultation the contact listed on the application receive a notification.

For more information about business license and business license consultation expiration, see Viewing Business License
Expiration.

Fee Communications

Communication Event Name Communication Description
New Fees Due When agency staff manually adds a new fee, the applicant receives a notification that new fees have
been assessed and are due.
For more information on manually adding a fee item, see Working with Fees and Payments.

Generic Alert Resource

Communication Event Name Communication Description

General Alerts Text was created to appear in the banner of the Agency Springboard or the landing pages for
anonymous and registered users.

For more information about generic alerts, see Defining Alerts.
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Inspection

Setting Up Communications

The following communication events are provided for permit inspections.

Note: This resource and events are registered with the Business Rules Framework. For more information, see
Business Rules Framework Overview and Setting Up Business Rules.

Communication Event Name

Final Inspection Passed

Inspection Canceled

Inspection Complete

Inspection ETA Updated

Inspection Requested

ORACLE

Communication Description

Generates a notification when an inspector submits the final inspection for a permit with a passing
result.

For example, when an inspector submits the final inspection for a permit with a passing result, the
permit technician or applicant receives a notification.

For more information about performing inspections, see Overview of Mobile Oracle Inspector for
Permits.
Generates a notification when the applicant or agency staff cancel an inspection.

For example, when the applicant or agency staff cancel an inspection, the applicant, inspection
contact, inspector, and inspection supervisor can receive a notification.

For more information, see Managing Inspections for an Agency and Managing Inspections for a Permit.

Note:
This event is also triggered when the permit associated with an inspection is withdrawn or expires.

Generates a notification when the inspector completes an inspection and submits the inspection
results or when inspections are updated from Scheduled to Completed status.

For example, when the inspector completes any inspection and submits the inspection results, the
applicant or agency staff receive a notification that the inspection is complete, regardless of the
inspection result.

For more information about performing inspections, see Overview of Mobile Oracle Inspector for
Permits.

Generates a notification when the inspector updates the estimated time of arrival at an inspection site.

For example, when the inspector updates the estimated time of arrival at an inspection site for a
scheduled inspection, the contact at the inspection location receives a notification.

For more information about performing inspections, see Overview of Mobile Oracle Inspector for
Permits.
Generates a notification when an inspection has been requested.

For example, when an inspection request has been created, the permit technician can receive an email
notification.

For more information about requesting inspections, see Requesting Inspections.
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Communication Event Name Communication Description
Inspection Rescheduled Generates a notification when the applicant or agency staff reschedule an inspection.

For example, when the applicant or agency staff reschedule an inspection, the applicant, inspection
contact, inspector, and inspection supervisor can receive a notification.

For more information about rescheduling an inspection, see Assigning Inspections Using the
Supervisor Calendar and Requesting Inspections.

Inspection Scheduled Generates a notification when an inspection has been scheduled and assigned to an inspector.

For example, when the inspection has been scheduled and assigned to the inspector, the inspector and
inspection contact can receive an email notification.

For more information about assigning an inspection, see Assigning Inspections Using the Supervisor
Calendar.

Oracle Intelligent Advisor Anonymous Results

Communication Event Name Communication Description

Anonymous Results Save The anonymous public user receives an email with the results of recommended permits after
submitting the permit guide questionnaire.

For more information about the Permit Guide for anonymous public users, see Setting Up the Landing Page for
Anonymous Users.

Payment History Resource

Communication Event Name Communication Description

Payment Received A successful payment triggers a notification configured using an email template.

Permit Document Attachments

Communication Event Name Communication Description

Permit Document Attached Notifies agency staff when a document is uploaded for a permit when plan review or inspection
information is not relevant.

Permit Document Attached for Inspector Notifies inspectors that a document was uploaded for a permit inspection.

Permit Document Attached for Plan Notifies plan coordinators that a document was uploaded for a permit plan review cycle.
Coordinator
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Communication Event Name

Permit Document Attached for Plan

Reviewers

Permit Document Attached for Inspection

Supervisor

Setting Up Communications

Communication Description

Notifies plan reviewers that a document was uploaded for a permit plan review cycle.

Notifies inspection supervisors that a document was uploaded for a permit inspection.

Permits Workflow Communications

Communication Event Name

Workflow 001

Workflow 002

Workflow 003

Workflow 004

Workflow 005

Communication Description

These delivered events are not associated with specific actions in the Public Sector system. Instead,
they are generic events that are delivered for use with workflow. For example, you can use these events
when configuring workflow to send notifications related to permit status changes.

When you set up workflow in the Oracle Integration Cloud, you implement notifications by creating
a workflow event that sends a communication event name, template name, and permit ID to the
Communication Center. The Communication Center then takes care of sending the notification.

See Setting Up Process Definitions for Workflow.

Planning and Zoning Workflow Communications

Communication Event Name

PNZ Workflow 001
PNZ Workflow 002
PNZ Workflow 003
PNZ Workflow 004

PNZ Workflow 005

Plan Review

Communication Description

These delivered events are not associated with specific actions in the Public Sector system. Instead,
they are generic events that are delivered for use with workflow. For example, you can use these events
when configuring workflow to send notifications related to planning application status changes to
applicants and owners.

When you set up workflow in the Oracle Integration Cloud, you implement notifications by creating a
workflow event that sends an communication event name, template name, and planning application ID
to the Communication Center. The Communication Center then takes care of sending the notification.

See Setting Up Process Definitions for Workflow.

The following communication events are provided for plan reviews.

Note: This resource and events are registered with the Business Rules Framework. For more information, see
Business Rules Framework Overview and Setting Up Business Rules.

Communication Event Name

Plan Review Completed or Canceled

ORACLE

Communication Description

Generates a notification when a plan review is completed or canceled.
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Communication Event Name Communication Description

Note:
This event is also triggered when the permit associated with a plan review is withdrawn.

Plan Review Finalized Generates a notification when a plan review is finalized.

Plan Review Ready To Finalize Generates a notification when a plan review is ready to be finalized.

For more information about plan review communications, see Managing Manual Plan Review Cycles and Managing
Electronic Plan Review Cycles.

User Profile Notifications

The User Profile Notifications resource provides the following communication events.

Communication Event Name Communication Description

User Account Information Changed Notifies a public user when the user's account is updated by agency personnel.

Contractor License Verification Failed Notifies a public user that the contractor's license could not be verified.

Contractor License Verification Pending Notifies a public user that the contractor's license verification is pending.

Contractor License Verification Passed Notifies a public user that the contractor's license has been verified.

Law Enforcement Verification Failed Notifies a public user that their status as a member of law enforcement or a judicial agency could not
be verified.

Law Enforcement Verification Pending Notifies a public user that verification for being a member of law enforcement or a judicial agency is
pending.

Law Enforcement Verification Passed Notifies a public user that verification for being a member of law enforcement or a judicial agency is
complete.

License Verification Failed Notifies a public user that the license could not be verified.

License Verification Pending Notifies a public user that the license verification is pending.

License Verification Passed Notifies a public user that the license has been verified.

Welcome Business Profile Senfglls a welcome notification and instructions to a permit applicant who creates a new business
profile.
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Communication Event Name Communication Description
User Profile Information Changed Notifies a public user when the user's profile is updated by agency personnel.
Welcome Personal Profile Sends a welcome notification and instructions to a permit applicant who creates a new personal profile.

User Trust Account Notifications

The User Trust Account Notifications resource provides the following communication events.

Communication Event Name Communication Description

Trust Account Verification Failed Notifies a public user that the trust account could not be verified.
Trust Account Verification Pending Notifies a public user that the trust account verification is pending.
Trust Account Verification Passed Notifies a public user that the trust account has been verified.

See Verifying Public User Information.

Setting Up Communication Templates

Communication events trigger delivery of different communication types to various users. The agency defines the
content, format, and recipients using communication templates.

Agency users add, modify, and delete communication templates on the Communication Event Details page.

The communication events themselves are delivered with Oracle Public Sector Compliance and Regulation. For a partial
list of the available communication events, see Delivered Communication Events.

Adding Communication Templates

Select Communication Setup > Communication Events in the navigator.
Click the event on the Communication Event page for which you want to add a template.
On the Communication Event Details page, click Add in the Communication Template section.

On the Communication Template Details page, enter a unique identifier code and name for the communication
template.

PUWUNA

To make the code unique, Oracle recommends that you create it using a portion of the communication event
name. For example, you might use SUBOT for the email template of the Application Submit communication
event. This is because communication template codes must be unique across all communication events. If you
create a communication template for one event that has the same code as a template for another event, you
will receive an error when you try to save it.

5. Enter values to set up the template:
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Page Element

Channel Type

Visibility

Enabled

Start Date Time and End Date
Time

MIME Type (Multipurpose Internet
Mail Extensions type)

Priority

ORACLE

Chapter 11

Setting Up Communications

Description

Specify the type of communication that this template generates. Values are:

o Alert: Generates text that is displayed to users when they log in to the application.
o Email: Generates an email that is sent to users.

o Emails and Notifications: Generates both an email and a notification with the same
message.

o Notification: Generates a notification that appears when users click the notification
icon in the application.

o Text: Generates a short message service (SMS) text message that is sent to users.
Currently, the text channel type is available only for ad hoc communications. Text
for events will be supported in the future.

Note:
The fields that are available to define on this page vary depending on the channel
type and MIME type that you select.

Select which type of user can see this communication in the Communications Center. All
communications can be accessed by agency staff. Values are:

o Account owner

o Agency staff only

Turn this switch on to activate the communication template. When this switch is turned
off, the application does not generate the communication when the associated event is
triggered.

Enter the time period for which the alert is displayed. These fields appear only for the
Alert channel type.

Select the format of the email or notification that this communication template
generates. Values are:

o HTML: Displays rich text, links, and images
o Text: Displays plain, unformatted text.

This field appears only for the email or notification channel types.

Turn on this switch to display notifications generated by this communication template at
the top of the notification list.

This field appears only for the Emails and Notifications and Notification channel types.
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Page Element Description
User Can Delete Turn on this switch to enable users to delete notifications generated by this

communication template from their notification lists.

This field appears only for the Emails and Notifications and Notification channel types.

Add Attribute These fields enable you to insert variable attributes into your communications. You
select the field and the attribute that you want to insert in that field, and click Insert to
enter a variable for that attribute.

For more information, see Using Attributes in Communication Templates.

Add Grid Add a grid with attributes from a related resource in the message body.

This button appears only for the email and notification channel types, and the MIME
type must be HTML.

For more information, see Using Attributes in Communication Templates.

To Enter the email addresses, user IDs, or phone numbers of the people or organizations
that you want to send the communication to.

Enter email addresses for the Email and Emails and Notifications channel types; user

IDs for the Alert, Emails and Notifications, and Notification channel types; and phone
numbers for the Text channel type.

Cc and Bcc Enter the email addresses of the people or organizations that you want to receive a copy
or blind copy of the communication.

These fields appear only for the Email and Emails and Notifications channel types.

From Enter the email address, user ID, or phone number of the person or organization who is
sending the generated message.

For texts, select the phone number of the person or organization who is sending the

generated text message from the drop-down list. The numbers are retrieved from
Twilio, a third-party messaging service.

Subject Enter a brief description of the purpose and content of the communication.

This field appears only for email or notification channel types.

Message Body Enter the main body text of the communication.
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Page Element Description

For the Alerts and Text channel types and emails and notifications using the Text MIME
type, you can enter only plain, unformatted text.

For emails and notifications using the HTML MIME type, you can enter rich text, links,
and images.

Remarks Enter any additional information about the communication template. These remarks are
not included in the generated communication.

6. Click Save.

Modifying Communication Templates

Select Communication Setup > Communication Events .

Click the row on the Communication Event page for which you want to modify a template.
Click the row in the Communication Template grid that you want to modify.

On the Communication Template Details page you can:

P UWNA

o Click Clone to create a copy of the communication template.

o Update the communication template field values.

I Note: You cannot edit the Code or Channel Type fields.

5. Click Save.

Deleting Communication Templates

Select Communication Setup > Communication Events .

Click the row on the Communication Event page for which you want to delete templates.
Click Edit in the Communication Template grid.

Select the check boxes next to all of the communication templates that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

A WND

Using Attributes in Communication Templates

You can add attributes to your communication templates when defining the recipients and content.

You insert attributes into your communication templates on the Communication Event Details page, which you access
by selecting an event from the list on the Communication Event page.

The endpoint attributes of communication service REST APIs correspond to the variables you use to set up a
communication template. For a reference document that directs you to the endpoint attributes and their descriptions
in the REST API documentation, see Public Sector Communication Services Endpoints Catalog (Doc ID 27558591) in My

Oracle Support.

127
ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 11
Implementing Your Agency Setting Up Communications

Adding Predefined Variable Attributes

When you create a template, you can insert variable attributes into the message recipients and body. Predefined
variable attributes are available to use for communications associated with any event.

1. On the Communications Event Details page, go to the Add Attributes fields.
2. Select the field and the attribute that you want to add to the field.
3. Click Insert.

For example, if you select Body and the Permit ID attribute, and click Insert, the ${Permit ID} variable is inserted into
the Message Body field of the communication template. When the application generates a communication using the
template with the variable attribute, the permit ID that is associated with the triggered communication event is inserted
into the body text.

Here's an example of a letter template and the output:

Example Expressions with Variable Output
Attributes

Dear ${Payer First Name} ${Payer Last Dear John Smith,
Name},

Thank you for your payment of $835.00 for permit REM-2017-000035, which was received on 15-
Thank you for your payment of AUG-2017.
${CommunicationUtils.formatNumber(${
Amount},’9,999,999.99’)} for permit

${Permit Id}, which was received on If you have any questions please contact the office between 9:00 a.m. and 4:30 p.m., Monday through
${CommunicationUtils.formatDate(${Pay Friday.
Date})}.

If you have any questions please contact
the office between 9:00 a.m. and 4:30
p.m., Monday through Friday.

The communication engine supports the following predefined functions for variable attributes in your templates.

Function Description Variable Attribute Output

Current Date Returns the system date in the ${Current Date} For example, 2016-04-25.
agency time zone without the time.
There is no need to use the format
utility.

Note:

The Current Date is internally
formatted using the
formatDate() function based on
the agency time zone. Using an
additional formatDate() function
causes an error.

Current Date Time Returns the system date in the ${Current Date Time} For example, 2016-04-25
agency time zone with the time. 23:44:52.0.
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Function Description Variable Attribute Output
There is no need to use the format
utility.
Note:

The Current Date Time is
internally formatted using the
formatDate() function based on
the agency time zone. Using an
additional formatDate() function
causes an error.

Format Number Formats the number to the given ${CommunicationUtils.formatNumkt For example, 46,064.
format. The formats supported are = '9,999,999")}
Java Number Formats.

Format Date and Time Formats the date and time in the Example 1: Example 1 output: 2019-11-22
agency time zone with the given 20:04:00.
format. The supported formats use  ${CommunicationUtils.formatDate(¢
Java Simple Date Format. Date},'yyyy-MM-dd HH:mm:ss')} Example 2 output: 11/22/19 8:04
PM.
Example 2:

${CommunicationUtils.formatDate($

Date})}
Format Amount Formats the amount into the ${CommunicationUtils.formatAmou For example, $1,345,667.00.
default local currency format.
Link Provides the hyperlink from the Input is expected to be the link URL  Output is a link in the message
message. and label that you want to display: = body.

${CommunicationUtils.setLink(${Ur]
${Label})}

Inserting Additional Attributes in Templates

Some attributes are available across resources for you to use when creating templates. You can insert a grid in the
message body that contains the additional attributes. This option is available only for events in the Permits Workflow
Communication resource. Formatting is not supported for related resource attributes.

The data for the attributes are displayed in the generated communication as a table. To add the grid to your template:

1. Select Communication Setup > Communication Events in the Navigator.

2. Onthe Communication Event page, select an event in the Permits Workflow Communication resource for which
you want to add a template.

Click Add in the Communication Template grid on the Communication Event Details page.

4. Set up the communication properties as described in Setting Up Communication Templates.

w

You must use the Emails, Emails and Notifications, or Notification channel type, and the MIME type must be
HTML to render the grid in the generated communication.

5. Click Add Grid.
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6. On the Define Grid Attributes page, select up to 5 attributes that you want to appear in the generated table. The
attribute source name appears on the page.

7. Click Insert Grid in Message.

For example, if you select the Fee Description, Fee Item, and Fee Record attributes, and click Insert Grid in Message, the
following is inserted into the Message Body field of the communication template:

${CommunicationUtils.insertGrid('publicSectorFeeCommunications', 'Fee Description,Fee Item, Fee
Record', '${FeeDescription},${Feeltemld}, ${FeeRecordKey}')}

Each attribute name is displayed in the generated email or notification as a column title, and record values populate
each row. If you want to change the order of the columns, you can manually move the attributes around in the template.
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12 Implementing the Business Rules
Framework

Business Rules Framework Overview

This topic describes how your agency can use the Business Rules Framework to define and maintain business rules that
drive system actions.

The Business Rules Framework is an event-driven, action framework that enables you to trigger various actions based
on the business rules you define. A business rule is a collection of logical expressions you construct by evaluating

and comparing business object attributes with common operators, such as equals, not equals, greater than, etc. For
example, a business rule can:

- Trigger automatic system communications.
- Update the underlying workflow process.

- Add fees.

- Apply conditions.

Oracle Public Sector Compliance and Regulation delivers a registry of resources, or business objects, for each offering,
that define the events applicable to that business object. Given the events and data contained by a resource, your
agency can define the rule criteria to drive the desired actions. While the resources and events are system-defined, your
agency defines the rules and select the triggered actions.

The following table describes the main elements in the framework.

Element Defined by System or Agency Description

Offering System Offerings are the set of applications your
agency has licensed. They contain the
resources with the data for business operations.
For example, Permits and Planing and Zoning
are offerings.

Resource System Resources are the business objects in the
application. For example, the Inspection
business object represents the data and activity
related to an inspection for a permit.

Event System Events are categorized by offering and by
business object. They represent specific,
predefined occurrences for a business object in
a particular offering. For example, with Permits,
the Inspection business object contains these
events:

- Inspection Canceled
- Inspection Rescheduled

- Inspection Requested
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Element Defined by System or Agency
Rule Agency
Criteria Agency
Actions Agency

Setting Up Business Rules

Chapter 12

Implementing the Business Rules Framework

Description

- Inspection Scheduled

Common events apply to all offerings.

Rules are based on business requirements and

constrain the actions associated with events. A

rule contains one or more logical statements as
the criteria that drives one or more actions. See
Setting Up Business Rules.

Criteria are logical statements that, if satisfied
or evaluate to be true on the whole, cause an
action to be carried out or stopped. See Setting
Up Business Rule Criteria.

Actions are the activity that gets triggered
as a result of the criteria in your business
rule. Examples of action types include Send
Communication, Update Workflow, Add Fee,
and so on.

For more information on the different action
types, see the topic in this chapter specific to
the action type you want to trigger, such as
"Setting Up Add Fee Actions."

This topic describes how to configure business rules in the Business Rules Framework.

Accessing Business Rules

To access business rules:

N =

Navigate to the Business Rules Framework in the Navigator: Common Setup > Business Rules Framework .
On the Business Rules Framework landing page, select the offering you are implementing, such as Permits.

3. On the offering’s events page, select the event for which you want to manage business rules, such as Inspection

Canceled for the Inspection business object.

4. Use the Event Details page to view, add, or manage the business rules associated with the event.

Working with Default Business Rules

Most events have a predefined default rule, which you can use as is or use as a template to create your user-defined
business rules. Default business rules have no criteria and the only action is Send Communication for All Templates. To
begin generating communications, you need to define the communication templates for the relevant event.

Note: The only modifications you can make on a default rule is to either enable or disable the rule. To make other

changes you need to add a new rule or copy an existing default rule.

ORACLE
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Copying a Default Rule

Except for enabling or disabling a default rule, you can't modify an existing default rule directly; you need to copy it first,
and then make your changes.

To copy a default rule:

Access the default business rule.

On the Event Details page, click Copy in the Actions column in the Business Rules grid.
On the Copy page, enter a new Rule Name and Rule Description (if needed).

Click Save.

P UWNa

Note: After you copy a default rule, it becomes disabled automatically, and the new rule you just created is
enabled.

Adding User-Defined Business Rules

If you do not want to use the existing default rule, or copy it, you can add user-defined business rules.

1. On the Event Details page, click Add to create a new business rule for the event.
2. On the Business Rules Details page, enter these values:

Page Element Description
Rule Name The name of the rule.
Note:

The rule name must be unique and can’t be changed after you save.

Rule Description Enter a description to further identify the rule.

Enabled Turn on the switch to enable the rule to be executed in the system. Turn off the switch to
disable the rule.

3. Add one or more condition.

See Setting Up Business Rule Criteria.
4. Add one or more action.

For more information on the different action types, see the topic in this chapter specific to the action type you
want to trigger, such as "Setting Up Add Fee Actions."
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Setting Up Business Rule Criteria

This topic describes how to create logical expressions as the criteria for rules in the Business Rules Framework.
Criteria are logical statements that consist of a field to evaluate, an operator, and a comparison value. You can:
- Add up to 10 rows of logical expressions per rule.
- Join and group the expressions to indicate an order of operations.
 Include up to three levels of nested rows of criteria.

Let's take a look at the elements used to create an expression statement for criteria in a rule.

This example illustrates the Criteria grid and how logical expressions are configured. Details are in the text surrounding
the image.

4 Criteria
Sequence ( Field Operator Value ) Grouping Verb Actions
1 v v Permit Type v Equals v SM-PLUMBING-02 v OR v (i}
2 v ( v Property City v Equals v San Mateo v AND v o
3 v v Type of Work v Contains v Plumbing ) v v [1]

Element Description

Sequence Select the order in which the statement executes within the business rule. For example, T means
that the statement in that row runs first, 2 runs second, and so on. You can have up to 10 sequential
statements in a business rule.

Note:

Set the order in which each statement should run. Do not leave any gaps between sequence
numbers. For example, the sequence should be 1,2, 3, 4, not 1, 3, 4.

Note:

When you save, the application validates and redraws the grid based on the entered sequence. For
example, if you enter a sequence of 2, 3, 1, the application renders it as 1, 2, 3 in the grid after you
save, assuming the logic is valid.

Opening Grouping Use the opening parentheses to establish the beginning of a grouping of one or more statements
in the business rule expression. You can nest groupings up to three levels using (, ((, and (((. Make
sure to balance (pair) the opening and closing groupings. That is, you need the same amount of left
parentheses as you do right parentheses.

Field Select the predefined source field from the business object.

Operator Select from the available comparison operators to specify how the entered value must relate to the

source field from the business object.
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Element Description

- Equals

- Notequal to

- Greater than

- Less than

- Greater than or equal to
- Less than or equal to

- Starts with

- In

- Notin

- Contains

Note:
Depending on the field’s data type, the list of operators changes to show only those that apply.

Value Enter the comparison value to the source field from the business object.

Closing Grouping Use the closing parentheses to establish the end of a grouping of one or more statements in the
business rule expression. You can nest groupings up to three levels using ), )), and ))). Make sure
to balance (pair) the opening and closing groupings. That is, you need the same amount of left
parentheses as you do right parentheses.

Grouping Verb Select AND or OR to include a logical operator. All rows in the grid require a grouping verb, except for
the last row in the sequence.

Actions Select to add or delete a level (row) in the expression.

Setting Up Send Communication Actions

This topic describes how to automate the sending of communications, such as emails and notifications, based on
defined events.

To trigger send communication actions you must have first set up the applicable communication templates for a
communication event. The Business Rules Framework sends the communication defined by the communication
template, such as a notification or an email.

In many situations, you trigger a send communication action and another action using the same rule. For example,
it's typical to automatically add a fee using the add fee action and send notification of the added fee with a send
communication action.

For more information on the communications framework, including communication events and templates, see
Delivered Communication Events and Setting Up Communication Templates.
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To add a send communication action:

Click Add.

Click Configure.

MPAWNDS

Implementing the Business Rules Framework

Expand the Actions section of Business Rules Details page.
From the Action Name drop-down list, select Send Communication.

On the Configure Action page select the scope of communication for the action.

Note: You can select only one scope option.

Page Element

Template codes

Channel types

Process all templates

Edit Templates

6. Click Done.

Description

Sends a communication only to selected communication templates defined for a
communication event.

Sends a communication to specific channel types defined for a communication event,
such as email, notification and so on.

Sends a communication to all communication templates for all channel types defined
for a communication event.

Click the Edit Templates link to go to the Communication Event page where you can
select a communication event and review the associated communication templates to
verify selections or to manage communication templates.

Setting Up Update Workflow Actions

This topic describes how to configure an action to update the status of the underlying workflow process definition.

Currently, the Update Workflow action type applies only to the Planning and Zoning offering for the Planning Activity

Updated event.

Before you begin configuring an update workflow action, you need to have configured the following definitions:

Definition

Activity Group

ORACLE

Description

An activity group contains a set of activities that represent human tasks within a given workflow
for processing a planning application. Agency staff track and manage the progress of the planning
application using the activities within the activity group.

When creating a planning application type, you select an activity group. You need to know the activities
in the activity group assigned to the current planning application type.

For more information on activities and activity groups, see Setting Up Activity Tracking.
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Definition Description
Workflow Process Application The workflow process application is defined in the Oracle Integration Cloud (OIC). It defines and

automates the system-level order of the tasks to complete through the life cycle of the transaction
type, such as a planning application.

When creating a planning application type, you select the workflow process. You need to be familiar
with the workflow process application assigned to the current planning application type.

Specifically, when configuring the Update Workflow action type, you need to know the following
information for the workflow task you want to update:

- Workflow task name (PSC_ACTIVITY_TYPE value).

- Actions defined for the workflow task.

For more information on workflow process applications, see Setting Up Process Definitions for
Workflow.

For more information on setting up planning application types, see Setting Up Planning Application Types.

To add an Update Workflow action:

1.

2,

NOo U R W

Expand the Criteria section of the Business Rules Details page.
Make sure your criteria statement reference the Activity and the Activity Status as fields required to drive the
update workflow action.

When the status is updated for activity on the Activity Tracking page (and all other criteria are met) the update
workflow action will be triggered.

This example illustrates the activity and activity status fields being included in the business rule criteria. Details
are in the surrounding text.

Field Operator alus
Activity v Equals v Your Activity Name
Activity Status v Equals v Incomplete

For more information on setting up criteria, see Setting Up Business Rule Criteria.

Expand the Actions section of Business Rules Details page.

Click Add.

From the Action Name drop-down list, select Update Workflow.

Click Configure.

Specify the activity type and action to update in the underlying workflow process application.

This example illustrates how to reference the workflow activity type and action to update. Details are in the
surrounding text.
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Configure Action X

Update Workflow

Property Value Description

PSC_ACTIVITY_TYPE Completeness Review Indicatas the task activity type.
Action More Info Needed Indicates the action that should be used when updating a task.

If the value you select for the action is left blank, the PSC_AUTO_UPDATE_ACTION value will be used.

Done Cancel

Page Element Description

PSC_ACTIVITY_TYPE The name used to identity the specific human task in the workflow process definition to
update. For example, Completeness Review, Complete Plan Review, and so on.

This value is a custom property defined in the business properties for the activity type.

Action The value to set as the Action in the workflow task properties. For example, Completed -
Plan Review Not Required, Completed - No Plan Review Required, More Info Needed, and
so on.

These values are stored in the Action field in the General properties of the activity type.

If needed, refer to the workflow process application in OIC for the activity type and action values.

This example illustrates the PSC_ACTIVITY_TYPE property. Details are in the surrounding text.

=
i =
e =
I
. 1]

Complete Plan Review Update Status = Plan  Completaness Review
Review »

E: UsePermit = m Completeness Review

HH
Q 2 General Define Custom Set values for the Custom Properties
# Custom Properties
@ Links Property Value Description
2 Racl -
PSC_ACTIVIT... Completeness Review Indicates the task activity type
Tracking
A 1ssues PSC_AUTO U Indicates the action that should be used when auto-updating a. ..
@ Commenis
PSC_UNREST... Indicates the list of actions that are not subject to restrictions
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This example illustrates the Actions property. Details are in the surrounding text.

I ———
Complete Plan Review Update Status = Plan  Completeness Review
iz

iy UsePermit = m Completeness Review

L
] I= Draft

General
@ Draft ac are not validated.

Reminders .
E Who are the approvers?

Escalation
¥ 4 gdiExpREticn Any Single Assignee T

Motification i . . . .
All assignees receive e [ask ana any a-r.‘g.'s assignee lakes aclion.
* Assignee(s)
customAdtiributes. customAttributeString1,PSC Principal ,I‘

How to display the task information?

Form
o +
= * Action
<= Completed - Plan Review Not Required,Completed - F .‘.

8. C(lick Done.
9. Repeat these steps for all the activities in the activity group you want to automate with the Update Workflow
action type.

Setting Up Add Fee Actions

This topic describes how to add fees automatically based on attribute values in the current business object.

For the Inspections business object, you can use the Add Fee action to append additional fee items to a transaction
based on the values of attributes in the Inspections business object.

For more information on setting up inspections, see Setting Up Inspection Types.
To configure an Add Fee action:

1. Expand the Criteria section of the Business Rules Details page.

For more information on setting up criteria, see Setting Up Business Rule Criteria.

2. Make sure your criteria reference the applicable attributes in the business object, as well as the Assess Fee
attribute value.

Examples of business object attributes to evaluate include Inspection Status, Result, Major Violation Count,
and so on. The Assess Fee attribute resolving to Yes (true) determines if additional fees can be applied for the

inspection.
3. Expand the Actions section of the Business Rules Details page.
4. Click Add.

5. From the Action Name drop-down list, select Add Fee.
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This example illustrates an expression evaluating business object attribute values, including the Assess Fee
attribute, and triggering the Add Fee action if the criteria is met. Details are in the surrounding text.

Business Rule Details

ject Inspection

Name Inspection Complete

* n

Rule Name Notify for Failed Inspection and Apply Additional Fee

Rule Description | Fer an inspection that fails, send a notification to the interested parties, and apply an
additional fee to cover rescheduling and reinspection.

Enabled O

4 Criteria
Sequence ( Field Operator Value ) Grouping Verb Actions
1 A ( v nspection Status A Equals A Failed - Add Fee v AND v + ﬁ
2 v v Assess Fee v Equals v Va5 ) v v + ﬁ
4 Actions
Action Name Action Description Caonfigure Actions
Send Communication v Sends a communication Configura + [1]
Add Fee hd Adds a fee Configure + o

Cancel Delete

6. Click Configure.
7. On the Configure Action page, enter the information for the Add Fee action.

This example illustrates the information that can be set for an Add Fee action. Details are in the surrounding
text.
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Configure Action
Add Fee
* Fee Iltem Processing Fees o,
* Amount (USD)  100.00
Status Pending v
* Department  Building o,
Memao
Cancel Daone
Page Element Description
Fee Item Select the Fee Item for which this added fee applies.
Amount Enter the amount of added fee.
Status Select the fee status.
Department Select the agency department to receive the revenue from the added fee.
Memo Enter any additional information to include with the added fee.
8. Click Done.

Setting Up Stop Process Actions

This topic describes how to prevent processes, such an inspection, from being completed or scheduled based on your
business rule.

You can configure the Stop Process action to prevent the final inspection from being scheduled based on your business
rule.

The Stop Process action is supported for this event:
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Event Attribute Value
Offering Permits
Business Object Inspection
Event Name Before Inspection Saved

To configure a Stop Process action:

1. Expand the Criteria section of the Business Rules Details page.

For more information on setting up criteria, see Setting Up Business Rule Criteria.
2. Make sure your statements reference the applicable attributes in the business object.

This example illustrates how you can set up your criteria sequence to confirm the inspection being scheduled is
the final inspection and that there is no outstanding fee balance.

=

Fees Balance Due v Mot equal to v 0 v AND v +

at

= > Final Inspection - Equals o Y ] - - -+

Expand the Actions section of the Business Rules Details page.

Click Add.

From the Action Name drop-down list, select Stop Process.

Click Configure.

Enter the text to include in the message that displays to the user if the action is triggered.

NS u kW

This example illustrates including custom message text.

Configure Action

Stop Process

Cancel Done

The Stop Process action prevents the final inspection from being scheduled, and it displays a message to alert
the user in the following format:

The process has stopped due to this reason: {CUSTOM_MESSAGE_TEXT}.
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Where {CUSTOM_MESSAGE_TEXT} is the text you enter in the Message Body field.

This example illustrates the error message displayed when you attempt to schedule a final inspection for a
permit. The configured business rule stipulates that the entire fee balance must be paid, and in this case there
is a remaining balance.

O Error

The process has stopped due to this reason: Fee Due for Permit. (PSC_CC-6030630)

oK

Note: The Stop Process action is triggered only during a request for a new inspection. It is not triggered
during import, migration, or when an inspection is canceled or updated. Also, keep in mind that the Stop
Process action isn't triggered by requests sent from the Oracle Inspector mobile app, however requests sent
from a browser running on a mobile device will trigger the Stop Process action.

Setting Up Apply Condition Actions
This topic describes how to apply conditions to transactions and other business objects automatically based on your
business rule.

A condition indicates a dependency or contingency for completing the application process. You can apply conditions
automatically using the Apply Condition action.

For more information on conditions, see Setting Up Conditions and Applying Conditions to Applications.

The Apply Condition action is available for Permits and Planning and Zoning workflow communications.

Offering Business Object Event Name
Permits Permits Workflow Communications Permit Canceled
Permit Withdrawn

Permit Application Updated

Planning and Zoning Planning and Zoning Workflow Planning Application Fees Due Updated
Communications
Planning Application and Pre-Application
Updated
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Note: To enable the workflow communication resources to be triggered, you need to modify your workflow process
definition in Oracle Integration Cloud (OIC) to integrate through a Business Rules Framework REST resource. For more
information on setting up the OIC integration for Business Rules Framework, see "Step 11: Add the POST Operation
for the Business Rules Request " in the following topic: Setting Up the Transactions Connector. You can also refer

to the delivered process definitions provided in solution packages for examples of the Business Rules Framework
integration.

To configure an Apply Condition action:

1. Expand the Criteria section of the Business Rules Details page.

For more information on setting up criteria, see Setting Up Business Rule Criteria.
2. Make sure your statements reference the applicable attributes in the business object.

For example:

This example illustrates sample criteria for the Apply Condition action. Details are in the surrounding text.

Sequence ( Field Operatar Walue ) Grouping Verb Actions

v ( v Permit Type v Equals v SM-PLUMBING-02 v AND v

2 v v Permit Status v Equals v Submitted ) v v

Expand the Actions section of the Business Rules Details page.

Click Add.

From the Action Name drop-down list, select Apply Condition.

Click Configure.

Select the condition you want to apply from the Condition Name search field.

NOo uhWw

This example illustrates selecting the condition you want to be applied. Details are in the surrounding text.

Configure Action

Apply Condition Access Conditions

Condition Name | Rebate Review Hold a,

Cancel Done

Note: The prompt displays only conditions with an object type of Transaction and having at least one valid
condition rule selected.

To view or manage conditions, click the Access Conditions link, which takes you to the Conditions page.
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15 Setting Up Analytics

Setting Up Reports

The report parameters that you define filter the data that is generated for the reports. You can use delivered or provide
customized reports.

For reports initiated from within Oracle Public Sector Compliance and Regulation, you add and modify report IDs and
configuration details, which includes adding, modifying, and deleting report parameters, on the Report Configuration
Details page. This setup doesn't apply to the reports you generate from the Report List.

For a list of delivered reports, their descriptions, and where you can find them, see Public Sector Compliance and
Regulation Analytics.

You can also create your own reports in Oracle Bl Publisher and allow users to access them through the available report
generation buttons. For example, users with appropriate permissions can click the Print button on some application
pages, such as the Print Deposit Slip page or the Inspection Detail page in the permit application details.

For more information on modifying and creating analytics and reports, see Creating and Administering Analytics and
Reports.

Adding Report Configuration Details

You can add a report in addition to the delivered reports.

1. Select Common Setup > Report Configuration .
2. Click the Add button.
3. Enter values for the following fields:

Page Elements Definition
Report ID and Description Enter an identifier and description of the report.
Path Enter a path to the desired report. For example, the path for the Inspection Summary

report in the Oracle Business Intelligence (BI) Catalog is /shared/Public Sector/
Inspections/InspectionSummary.xdo.

Output Format Select PDF or RTF to indicate the format of the generated report.
Report Category Select a product area to classify the report.
4. Click Save.
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Updating Report Configuration Details

1. Select Common Setup > Report Configuration .
2. Click a report row on the Report Configuration page.
3. On the Report Configuration Details page, you can:

o Update the description.
o Enter the Bl Catalog path for the report. For example, the path for the Inspection Summary report is /
shared/Public Sector/Inspections/InspectionSummary.xdo.
If you create your own report, you can point the existing report generation buttons on the application
pages to your custom report using this path.
4. C(lick Save.

Adding Report Parameters

. Select Common Setup > Report Configuration .
Click the report row on the Report Configuration page for which you want to add a parameter.

1
2
3. Onthe Report Configuration Details page, click Add in the Parameters grid.
4. Enter values for the following fields:

Page Elements Definition

Parameter ID and Parameter Name Enter a unique ID and name for the report parameter.

Parameter Data Type Enter the data type for the report parameter.

5. Click Save.

Modifying Report Parameters

Select Common Setup > Report Configuration .
Click the report row on the Report Configuration page for which you want to modify a parameter.

Click the row in the Parameters grid that you want to modify.
On the Parameter Details page, you can:

PUOAUNA

o Update the report parameter field values.
o Delete the report parameter. You will be prompted to confirm the permanent deletion.

5. Click Save.

Deleting Report Parameters

Select Common Setup > Report Configuration .

Click a row on the Report Configuration page.

Click Edit in the Parameters grid.

Select the check boxes next to all of the report parameters that you want to delete.

Click Delete. You will be prompted to confirm the permanent deletion.

UuhUWNRA
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Setting Up Dashboards

You add, modify, and delete dashboard configurations on the Dashboard Configurations page.

Dashboards are a collection of analyses grouped together to return data. A dashboard contains analyses and prompts
which filter information and other objects to present on one or more pages. You can configure dashboards to display an
analysis in Public Sector Compliance and Regulation by clicking the Reports and Analytics button in the global header
on the Agency Springboard, and selecting the dashboard link.

For alist of delivered dashboards and their descriptions, see Public Sector Compliance and Regulation Analytics.

Adding a Dashboard Configuration

1. Select Common Setup > Dashboard Configuration .
2. On the Dashboard Configuration page, click Add.
3. On the Dashboard Configuration Details page, enter values for the following fields:

Page Element Description

Dashboard ID Enter a unique name for the dashboard.

Description Enter a description of the dashboard

Path Enter the Oracle Business Intelligence (Bl) Catalog portal path for the dashboard. For

example, the portal path for the Permits dashboard is %2Fshared%2FPublic%20Sector
%2F_portal%2FPublic%20Sector&page=Permits.

Enabled Turn on this switch to activate this dashboard.
Default Turn on this switch to make this the default dashboard.
Note:

Only one dashboard can be designated as the default.

4. Click Save.

You can access configured dashboards by clicking the Reports and Analytics button and selecting the dashboard link
in the header on the Agency Springboard.

Modifying a Dashboard Configuration

1. Select Common Setup > Dashboard Configuration .
2. Click a row on the Dashboard Configuration page.
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3. On the Dashboard Configuration Details page you can:
o Update the dashboard configuration field values.

Note: You cannot edit the Dashboard ID.

o Delete the dashboard configuration. You will be prompted to confirm the permanent deletion.
4. C(lick Save.

Deleting Dashboard Configurations

Select Common Setup > Dashboard Configuration .

Click Edit.

Select the check boxes next to all the dashboard configurations that you want to delete.
Click Delete. You will be prompted to confirm the permanent deletion.

PWOUNa

Creating and Editing Dashboards

If you are an advanced user and administrator who wants to modify and create analytics and reports and perform
generic setup and maintenance tasks for business intelligence that apply to some or all product families, see
Dashboards in Creating and Administering Analytics and Reports.

Listing of Prebuilt Analytics

This reference points to the list of prebuilt analytics for Oracle Public Sector Compliance and Regulation.

Your Compliance and Regulation applications come with a variety of prebuilt analytics for your users. Use the prebuilt
analytics right out of the box, or make a copy and modify them however you like. See the Related Topics for a link to the
analytics listing in downloadable format.

Related Topics
- Reports and Analyses for Oracle Public Sector Compliance and Regulation

Public Sector Compliance and Regulation Analytics

Analyze your agency and key performance indicators with analyses, reports, and interactive dashboards, which you can
access through transactional pages, the Report List page, or the business intelligence (BI) catalog.

You can find information about the Bl reports and dashboards for Public Sector Compliance and Regulation here.
For a complete list of delivered analytics, see the Listing of Prebuilt Analytics.

There are different ways to view and work with your analytics and reports. You view analyses, dashboards, and reports
in the course of your work on your usual pages. You can also find them on the Report List page or in the Bl catalog. For
information about using the Report List, see Generating Reports.

To access reports on the Report List page, click the Reports and Analytics button in the global banner on the Agency
Springboard and select the Report List link. Select the Bl Catalog link to access reports and dashboards in the catalog.
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For information about hiding access from registered public users, see the security topics for implementation in My

Oracle Support (Doc ID 2730290.1).

This table lists the delivered reports for Public Sector Compliance and Regulation and where you can find them.

Report Name

Building Permit

Business License Certificate

Case Timeline

Cashier Session Reconciliation

Citation Notice

Conditions of Approval

Deposit Slip

ORACLE

Description

Displays permit-related information.

Displays the generated business license
certificate.

Displays all the Code Enforcement events
associated with a particular case in a
chronological order.

Provides details about cashier session
reconciliation activity.

Displays information about the code violation
along with following details:

- Corrective actions

- Compliance date

- Appeal by date

- Citation fees

- Citation fees payment due date.

This report is sent to the party responsible for
the reported violation.

Displays the conditions of approval associated
with a planning application, including a
description of the work, the assigned planner,
and the conditions of approval.

Lists deposit information.

Location

Overview page of the permit record details

See Viewing the Permit Summatry.

Report List or Bl Catalog: Shared
Folders > Public Sector > Permits

Overview page of the issued business
license

See Viewing the Business License.
Report List or Bl Catalog Shared Folders >
Public Sector > Business License

Timeline page

See Working with Case Timeline.

Report List or Bl Catalog: Shared
Folders > Public Sector > Code
Enforcement > Cases )

Reconcile Cashier Session page

See Reconciling Cashier Sessions.

Report List or Bl Catalog: Shared
Folders > Public Sector > Billing and
Payments

Notice of Citation page
See Using the Code Technician Worklist.
Citations page

See Working with Citations.

Report List or Bl Catalog: Shared
Folders > Public Sector > Code
Enforcement > Notices )

Conditions of Approval page

See Working with Conditions of Approval.

Report List or Bl Catalog: Shared
Folders > Public Sector > Planning
Application

Print Deposit Slip page
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Report Name Description

Inspection Activity Displays all inspection activity for an agency
over a specified date range.

Inspection Job Card Displays a record of inspections made by the
inspector, who will make notes on it and sign it
during each visit to your job site.

Inspection Summary Displays inspection-related information for the
permit.

Payment Invoice Displays invoice information.

Payment Receipt Lists payment receipt information.

Permit Activity Displays permit summary information for an

agency over a specified date range.

Permit Valuation and Revenue Displays permit information including valuation
and fees.

Planning Application Displays planning activity over a specified
date range. You select which applications are
included the report. You can generate the
report for one or more specific applications, or
for all applications handled by your agency.

ORACLE
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Location

See Printing Deposit Slips.

- Report List or Bl Catalog: Shared
Folders > Public Sector > Billing and
Payments

Report List or Bl Catalog: Shared Folders >
Public Sector > Inspections

Report List or Bl Catalog: Shared Folders >
Public Sector > Permits

- Inspection Detail page in the Oracle
Inspector mobile application

See Working with Inspection Details.

- Inspection Detail page of the permit
record details

See Reviewing Inspection Details.

- Report List or Bl Catalog: > Shared
Folders > Public Sector > Inspections

- Invoice History page

See Viewing Invoice History.

« Report List or Bl Catalog: > Shared
Folders > Public Sector > Billing and
Payments

- Payment Successful page

See Payment Flow Overview.

- Fees and Payments page of the permit
record details

See Working with Fees and Payments.

- Report List or Bl Catalog: Shared
Folders > Public Sector > Billing and
Payments

Report List or Bl Catalog: Shared Folders >
Public Sector > Permits

Report List or Bl Catalog: Shared Folders >
Public Sector > Permits

- See Working with Reports

- Report List or Bl Catalog: Shared
Folders > Public Sector > Planning
Application
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Report Name

Primary Approved Permit

Public User Information

Refund Receipt

Violation Notice

Welcome Letter

Description

Displays applicant and detailed application
information, as well as a description of the
work, address, parcel, and district.

Lists information about public user accounts.

Lists refund receipt information.

Displays information about the code violation,
corrective actions, and the compliance date.
This report is sent to the party responsible for

the reported violation.

Informs the applicant that the application has
been assigned and is under review. Provides
application and assigned planner information.

Chapter 13
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Location

See Working with Reports

Report List or Bl Catalog: > Shared
Folders > Public Sector > Planning
Application

Report List or Bl Catalog: Shared Folders >
Public Sector > Account Management

Refund Detail page

See Viewing and Processing Refunds.

Report List or Bl Catalog: Shared
Folders > Public Sector > Billing and
Payments

Notice of Violation page

See Using the Code Technician Worklist.

Notices page

See Working with Notices.

Report List or Bl Catalog: Shared
Folders > Public Sector > Code
Enforcement > Notices

See Working with Reports

Report List or Bl Catalog: Shared
Folders > Public Sector > Planning
Application

Dashboards organize analytical content and catalog objects, and present them in a meaningful way. Oracle Public Sector
Compliance and Regulation delivers a selection of prebuilt dashboards.

Access dashboards by clicking the Reports and Analytics button and selecting the Bl Catalog link in the header on the
Agency Springboard. Go to Shared Folders > Public Sector > Dashboards . You can also display links to dashboards
when you click the Reports and Analytics button. For more information, see Setting Up Dashboards.

Dashboard

Case Inspections Dashboard

Code Case Dashboard

Fees and Payments

Planning Applications

ORACLE

Description

Provides information about case inspections for code enforcement, including the number of case
inspections with different statuses and outcomes.

Provides information about incidents, cases, and citations for code enforcement.

Provides information about fees and payments for permits and planning applications.

Provides information about inspections, permits, plan review, and properties information for planning
applications.
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Dashboard Description
Public Sector Provides information about inspections, permits, plan review, and properties information.
Projects Provides information about projects, including total projects, estimated value, active and on-hold

projects, new projects initiated quarterly, and other analytics.

The Public Sector Dashboard contains these pages.

Public Sector Dashboard Page Name Description

Inspections Provides real-time information about inspections associated with permits, such as inspection count,
percentage passed, top 10 permits with major violations, average inspections per permit, and so on.

Permits Provides real-time information about permits, including permit count, fees amount, totals by permit
status, job cost and fees by permit type, permit applications by week, and so on.

Plan Review Provides real-time information about plan reviews, including plan review count, average plan reviews
per permit, plan review decision status, and review status by permit type.

Hiding Catalog Folders

You may want to remove access to predefined catalog folders so that those associated with offerings you don't

use aren't displayed. You can hide the entire predefined catalog or selectively display root catalog folders for

offerings, which are controlled by the Custom Bl Web cat Reporting Duty role and associated roles for each offering.
Administrators with IT Security Manager privileges can hide predefined folders by removing their associated roles from
the duty role.

For more information, see Manage Predefined Catalog Permission in Creating and Administering Analytics and Reports.

Related Topics
 Oracle Public Sector Compliance and Regulation Cloud: Analyze and Report

 Help for Business Intelligence in Oracle Applications Cloud

Creating Deep Links
Create deep links in your analytics that let you navigate from an analytic to specific attributes and objects in your
transaction pages without navigating through the menu structure.

You can use deep links to easily view the transaction details in Oracle Public Sector Compliance and Regulation from
your Oracle Transactional Business Intelligence (OTBI) reports.

Here's how to create deep links:

1. Click the Reports and Analytics header icon on the Agency Springboard, and select Bl Catalog.
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2. Create or edit an analysis. Use a subject area that includes the attribute you want to link to in the transactional
pages. For example, use Public Sector Cloud - Permits Real Time.

In the Selected Columns pane on the Criteria tab, click ﬂ' (Options) for the attribute column on which you
want a deep link.

Select Column Properties.

Open the Interaction tab in the Column Properties dialog box.

In the Primary Interaction list in the Value section, select Action Links to display the Action Links table.
Select the Do not display in a pop-up if only one action link is available at runtime option.

Click Add Action Link.

In the New Action Link dialog box, enter the link text for the navigation.

10. Click the Create New Action icon and select Navigate to a Web Page.

11. Inthe Create New Action dialog box, enter the URL to navigate to, which references parameters you define in
the prompt. For shared analyses, enter a URL with your website host name:

OCwVvoOgouh

http://<hostname>/fscmUI/deeplink?root=@{1l}&context=LnpRecordKey%253DQ{2}

o Replace <hostname> with the host name of your Public Sector Compliance and Regulation instance.
o Replace deeplink with the Public Sector homepage. For example, publicSector.html.

12. Click Define Parameters to add corresponding parameters for the URL.
13. In the Define Parameters section, click Add Parameter to add the following mandatory parameters:

Name Prompt Type of Value  Value Fixed Hidden Optional
1 root Value PSCLNP_ Selected Selected Selected
RECORD_
DETAIL
2 context Column Value "<table.name>"." Selected Selected Selected

For example, the context could be “Construction”.”<LNP Record Key>,” where the LNP Record Key is “Permit
Number.” This creates a deep link on the permit number to navigate to the permit transaction detail page.

14. Click Options to set how the page opens.
15. Inthe Action Options dialog box, select Open in New Window to open the page in a new window.
16. Save your work.

17. If you have provided the Return Application name, a Return icon is available in the transactional page to return
to the analysis.
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14 Setting Up Subject Areas

Subject Areas Overview

This topic describes how subject areas work.

A subject area is a grouping of information pieces pulled from your transactional database that relate to each other in a
particular context. Examples of context are permits, inspections, plan reviews, planning applications, and so on. These
contexts correlate to key aspects of your business transactions, and are designed to provide answers to questions about
how well things are going. Prebuilt subject areas come right out of the box to answer key business questions.

Any information your organization tracks can be grouped into a subject area, then used to build analytics. All you have
to do is drag columns from your subject area to your analytics editor and you have an analytic. You can edit prebuilt
analytics the same way, by adding or removing columns from your subject area. When you edit prebuilt analytics, don't
forget to make a copy and give it your own name.

Subject Areas and Business Questions

This topic describes how business questions form the basis of your subject areas and analytics.

Subject areas are designed around business questions. All analytics are built from subject areas. So whether you're
creating your own analytics, or modifying the analytics that come with your Public Sector applications, you first want to
figure out what questions you want answered.

Here are some examples of subject areas and the business questions they can answer.

Subject Area Name Example Business Questions

Public Sector Cloud - Permits Real Time - What is the busiest time for permit applications?
- When does the agency issue the most permits?

- What is the total permit activity by permit type in a given period?

Public Sector Cloud - Permit Inspection - What is the workload distribution across all inspections?
Activity Real Time

- What are the primary reasons for major inspection violations?
- What is the total demand for inspections in a given period?
Public Sector Cloud - Plan Review Real - How long on average are plan review cycles?
Time
- How many plan review cycles on average are needed for an application?

« How many plan reviews had override decisions?
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Subject Area Context and Analytic Results

This topic discusses the subject area context and the column details of the analysis.

If your analytic doesn't look right, or columns of information aren't showing up, it could be an issue with context. The
context defines what column details the analysis displays. Adding a permit type column doesn't mean all permit type
show up in the analysis. It depends on the context you're using to create the analysis. If you build an analysis, and it
doesn't show what you're expecting, be sure that you're adding your columns and facts in context.

The subject area dimension folders contain the columns and the facts folders define the relationship of the columns. If
you add the permit type column to your analysis, and then add the Fact, Permit Count to the same analysis, then only
the permit types that have one or more permit show on this analysis in this context. There might be hundreds of permit
types that doesn’t have permits associated, so they don't show up on your permit activity analysis.

The following is an example that might help explain this further. In this exercise you will build a permit activity analysis.
To build a simple permit activity analysis from a subject area:

1. Click New and select the Analysis option.
2. Select Public Sector Cloud - Permits Real Time:

o From the dimension Permit Type, add Permit Type.

o From the dimension Permit - Applicant, add Full Name.

o From the dimension Permit, add Permit Application Date.
o From the Permit Amounts (fact) folder, add Permit Count.

3. You can filter Permit Application Date to see a specific date range. Edit the filter by clicking or hovering over the
button next to its name.
4. Select the filter to show only a specific date range and click OK.

This figure illustrates choosing a filtering option to show only records in a specific date range.
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Add More Options +  Clear All
[ ] Protect Filter
[ ] Convert this filter to SQL
OK | Cancel

5. Click Results. The Results tab shows your analysis at this point. Move back and forth from Criteria to Results at
any time to see your analysis.

This figure illustrates the results of a simple permit activity analysis from a subject area:

Compound Layout

[ & X

W m S X

Permit Type  Full Hame Permit Application Date Permit Count
Cw0a23 William B 812319 4
PSCPERMIT2 Elaine W 82219 1

6. Name and save your analysis.

Note: You can't use Direct Database Query in your analysis. Direct Database Query isn't supported in SaaS OTBI. To
create direct database SQL report, you can create a Bl Publisher SQL data model and then create a report.

Multiple Subject Areas in a Single Analytic

This topic discusses how to use multiple subject areas in a single analysis.

157
ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 14
Implementing Your Agency Setting Up Subject Areas

Subject areas can be tricky to master, but once you get familiar with them you can easily mix and match subject area
components for your analytics. The reason you would want to do this is just for flexibility. You might want to look at your
business from different perspectives.

You can create an analysis that combines attributes and metrics from custom permit and standard permit-related
subject areas that share a common dimension. Or, if that isn't enough, you can create an analysis that combines data
from multiple standard subject areas.

To start with, let's learn how to add a subject area to the editing palette. Whether you're creating a new analysis, or
using an existing analysis to add objects from your custom subject area, the steps for adding multiple custom or
standard subject areas to your palette are the same.

To add multiple subject areas to editing palettes:

1. Create your analysis using a single subject area.
2. Inthe Subject Areas section, click the Add / Remove Subject Areas icon.

This shows the Add / Remove Subject Areas icon.

DRAC'_E Transactional Business Intelligence

Untitled

Criteria | Results Prompts Advanced

]

4 SubjectAreas O flv | P> T ¢ BB

k

o | ) . .
| a4 Public Sectar Cloud - Permits Real Tir

4 Selected Columns
Agency

Contact Double click an column n
Fee Schedule

Farcel

Parcel Owner

Permit

Permit Amounts

Permit Application Date J 7

Permit Issue Date Add filters to the analysis

v W v w w wv w w w wv A

Permit Type

3. Select or remove one or more standard or custom subject areas from this analysis by selecting or deselecting
subject area. If you have created custom subject areas, they also appear in this list under the name you
assigned to them.

Cross Subject Area Queries

Each subject area contains a collection of attributes and measures relating to the one-dimensional STAR model and
grouped into individual folders. The term STAR refers to the semantic model where a single fact is joined to multiple
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dimensions. You can create an analysis that combines data from more than one subject area. This type of analysis is
referred to as a cross-subject area query. Cross-subject area queries are classified into three broad categories:

- Combining queries from multiple subject areas.

o Using common (conformed) dimensions.

o Usinglocal and common (conformed) dimensions.

- Using a “set” operation (Union or Union All, for example) to combine more than one result set from different
subject areas.

- Combining Logical SQL using the Advanced tab.

A common dimension is a dimension that exists in all subject areas that are being joined in an analysis. For example, the
Contact dimension is the common dimension for the Public Sector Cloud - Permit Inspection Activity Real Time and
Public Sector Cloud - Permits Real Time subject areas.

Alocal dimension is a dimension that exists only in one subject area. For example, Inspection Type and Inspection
Status are local dimensions for the Public Sector Cloud - Permit Inspection Activity Real Time subject area.

The following are some general guidelines to follow when working with multiple subject areas:

- If all metrics and attributes needed for the analysis are available in a single subject area and fact metrics, use
that subject area only and don't create a cross-subject area query. Such an analysis performs better and is
easier to maintain.

- When joining two subject areas in an analysis, make sure at least one attribute from a common dimension is
used in the analysis.

- When using common dimensions always choose attributes from the common dimension from a single subject
area. For instance if you're using the Contact dimension to build a query between subject area 1and subject
area 2, then select all Contact dimension attributes from either subject area 1 or from subject area 2. (Not
some contact attributes from subject area 1and some from subject area 2.) In some scenarios, the common
dimension may have more attributes in one subject area than the other. In such a situation, you can only use
the subset of common attributes for a cross-subject area query.

- Always include a measure from each subject area that's being used in your analysis. You don't have to display
measures or use them, but you should include them. You can hide a measure if not needed in the analysis.

- When using common and local dimensions use SET VARIABLE ENABLE_DIMENSIONALITY=1; in the Advanced
SQL tab.

Queries from Multiple Subject Areas

The simplest and fastest way to generate an analysis is to use a single subject area. If the dimension attributes and fact
metrics that you're interested in are all available from a single subject area, then you should use that subject area to
build the analysis. Such an analysis results in better performance and is much easier to maintain.

If your analysis requirements can't be met by any single subject area because you need metrics from more than one
subject area, you can build a cross-subject area query using common dimensions. There's a clear advantage to building
a cross-subject area query using only common dimensions, which is recommended.

Keep in mind that if you use three subject areas for an analysis, your common dimensions must exist in all three subject
areas. Joining on common dimensions gives you the benefit of including any metric from any of the subject areas in a
single analysis.

159
ORACLE



Oracle Public Sector Compliance and Regulation Cloud Chapter 14
Implementing Your Agency Setting Up Subject Areas

While you can create an analysis joining any subject area to which you have access, only a cross-subject area query that
uses common dimensions returns data that's at the same dimension grain. This happens so that the data is cleanly
merged and the result is an analysis that returns exactly the data you want to see.

Knowing how cross-subject area queries are executed in Bl helps you understand the importance of using common
dimensions when building such an analysis. When a cross-subject area analysis is generated, separate queries are
executed for each subject area in the analysis and the results are merged to generate the final analysis. The data
that's returned from the different subject areas is merged using the common dimensions. When you use common
dimensions, the result set returned by each subject area query is at the same dimensional grain, so it can be cleanly
merged and rendered in the analysis.

Common Dimensions for an Analysis

Here is an example of combining common dimensions. In this case, we combine the Permit Count, Permit Type,
Inspection Count, and Inspection District Type. The common dimension in both subject areas used for this analysis is
Permit Type and different fact metrics are pulled from each subject area.

The following subject areas are used for this example analysis:

- Subject area 1: “Public Sector Cloud — Permits Real Time”

- Subject area 2: “Public Sector Cloud — Permit Inspection Activity Real Time”

Customer is the common dimension used for this example analysis:

« “Public Sector Cloud - Permits Real Time”.“Permit Type” — Permit Type

- “Public Sector Cloud - Permit Inspection Activity Real Time* — Permit Type

The following are the metric measures for this example analysis:

- “Public Sector Cloud — Permits Real Time“.“Permit Amounts” — Permit Count

- “Public Sector Cloud - Permit Inspection Activity Real Time“.“Inspection Amounts” — Inspection Count

Local and Common Dimensions for an Analysis

This example pulls the Permit Count by Permit Type and Inspection Count by Inspection District Type. Permit Type is

a common dimension in both subject areas used for this query. Inspection District is a local dimension to the Public
Sector Cloud - Permit Inspection Activity Real Time subject area. Different fact metrics are pulled from each subject
area. Note that use of local dimension may impact the grain of the analysis. In such cases the metrics may get repeated
for each of these rows.

The following are the subject areas used for this example analysis:

- Subject area 1: “Public Sector Cloud — Permits Real Time”

- Subject area 2: “Public Sector Cloud — Permit Inspection Activity Real Time”

Permit Type is the common dimension for this example analysis: “Public Sector Cloud — Permits Real Time”.“Permit
Type” - Permit Type.

The following is the local dimensions used for this example analysis: “Public Sector Cloud - Permit Inspection Activity
Real Time".“Inspection District” — Inspection District.
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The following are the metrics (measures) used for this analysis:

+ “Public Sector Cloud — Permits Real Time”.“Permit Amounts” — Permit Count
« “Public Sector Cloud - Permit Inspection Activity Real Time“.“Inspection Amounts” — Inspection Count
The following is the logical SQL used for this analysis:
SET VARIABLE ENABLE DIMENSIONALITY=1;SELECT
0 s_0,
"Public Sector Cloud - Permits Real Time"."Permit Type"."Permit Type" s_1,
"Public Sector Cloud - Permit Inspection Activity Real Time"."Inspection District"."District Type" s_2,
"Public Sector Cloud - Permits Real Time"."Permit Amounts"."Permit Count" s_3,
"Public Sector Cloud - Permit Inspection Activity Real Time"."Inspection Amounts"."Inspection Count" s_4
FROM "Public Sector Cloud - Permits Real Time"

ORDER BY 1, 2 ASC NULLS LAST, 3 ASC NULLS LAST

FETCH FIRST 75001 ROWS ONLY

Set Operations to Combine Result Sets from a Subject Area
This example creates a compound analysis query that's a union of two result subsets from two subject areas, combining
results from:

« Permit Count by Permit Type from the Public Sector Cloud — Permits Real Time subject area (result 1)

- Inspection Count by Inspection District from the Public Sector Cloud - Permit Inspection Activity Real Time
subject area (result 2)

SELECT saw_0, saw_1 FROM ((SELECT 'Permits ~ ' ||"Permit Type"."Permit Type" saw_0, "Permit Amounts"."Permit
Count" saw_1 FROM "Public Sector Cloud - Permits Real Time")

UNION

(SELECT 'Inspection ~ ' ||"Inspection District"."District Id" saw_0, "Inspection Amounts"."Inspection Count"

saw_1 FROM "Public Sector Cloud - Permit Inspection Activity Real Time")) tl1 ORDER BY saw_0

Logical SQL Using the Advanced Tab

If your requirement can't be met by either of the two methods already discussed, then there's another advanced
technique you can try. This technique lets you join multiple logical SQL statements based on common IDs or keys, which
can be written against the same or different subject areas, just as used in normal SQL. Both Outer and Equijoin are
supported.

This example illustrates how you can combine Permits and Fees data in an analysis by combining the logical SQL found
on the Advanced tab.

Step 1: Write a Bl Answers query using the “Public Sector Cloud — Permits Real Time” subject area to show the Fee
amount and Applicant Name. Once the correct results are achieved, go to the Advanced tab and grab the logical SQL
associated with this query.

Logical SQL for Query 1:

SELECT
0 s_0,
"Public Sector Cloud - Permits Real Time"."Applicant"."Applicant Name" s 1,
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"Public Sector Cloud - Permits Real Time"."Permit"."Permit Number" Per_ No,
"Public Sector Cloud - Permits Real Time".'"Permit Amounts".'"Fee Amount" s_3
FROM "Public Sector Cloud - Permits Real Time"

Step 2: Write a second Bl Answers query using the " Public Sector Cloud - Receipts Real Time"."Transactions" subject

area to show fees paid for the permit. Once the correct results are achieved, go to the Advanced tab and grab the logical
SQL associated with this query.

Logical SQL for Query 2:

SELECT
0 s O,
"Public Sector Cloud - Receipts Real Time".'"Transactions"."Application ID" s_1,

"Public Sector Cloud - Receipts Real Time".'"Fact - Receipts"."Amount Received for a given period" s_2
FROM "Public Sector Cloud - Receipts Real Time"

Step 3: Go to the Advanced tab in Bl Answers and copy/paste the following logical SQL which is an OBIEE - Equijoin of

the two previous SQL statements based on Opportunity ID. Use any text editor to combine the logical SQL statements
copied from Steps 1and 2.

SELECT

permit.s_1, permit.Per No, permit.s_3, fees.s_2
FROM

(
SELECT
0 s O,
"Public Sector Cloud - Permits Real Time"."Applicant"."Applicant Name" s 1,
"Public Sector Cloud - Permits Real Time"."Permit"."Permit Number" Per_ No,
"Public Sector Cloud - Permits Real Time"."Permit Amounts"."Fee Amount" s_3
FROM "Public Sector Cloud - Permits Real Time"
) permit,
(
SELECT
0 s_0,
"Public Sector Cloud - Receipts Real Time"."Transactions"."Application ID" s_1,
"Public Sector Cloud - Receipts Real Time".'"Fact - Receipts".'"Amount Received for a given period" s_ 2
FROM "Public Sector Cloud - Receipts Real Time"
) fees
WHERE permit.Per No = fees.s_1

Note: If you create a new analysis using this SQL, any hierarchical columns, member selection, groups or formatting
is stripped out.

Custom and Standard Subject Areas Joins

Analyses can be build using combinations of standard, as well as both custom and standard subject areas. The add
subject area option appears once you have created an analysis from a single subject area. You can delete subject areas
using these same steps. When you create your analysis, you select a single subject area during the creation steps. Once
the analysis is created, you add additional standard or custom subject areas.

Listing of Subject Areas for Public Sector Compliance
and Regulation

This reference points to the list of subject areas for Public Sector Compliance and Regulation.
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Public Sector Compliance and Regulation comes with a variety of standard subject areas for permits and planning
applications. See the Related Information for a link to the subject area list.

Related Topics
« Subject Areas for Transactional Business Intelligence in Public Sector Compliance and Regulation
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15 Setting Up Custom Subject Areas

Custom Subject Areas

Oracle Public Sector Compliance and Regulation Cloud contains prebuilt subject areas, but you can also create your own
subject area for your unique reporting needs.

The subject areas that you create is called a custom subject areas.

Concepts and Terminology in Custom Subject Areas

Before creating a custom subject area, you should understand the concepts and terminology used with custom subject
areas. These concepts are discussed in their related topics in detail.

- Objects: Objects within Oracle Public Sector Compliance and Regulation Cloud represent an entity; for example,
a contact list. When you create entities such as permit types within Oracle Public Sector Compliance and
Regulations, you create custom objects.

Fields or attributes: A field, also called an attribute, is where entity information is stored. A contact type is
stored in a field under the contact list entity or object.

Measures: Measures are a set of functions that you can apply on date, numeric, or currency type fields of the
selected primary or child objects while defining a custom subject area.

Date Leveling: Date leveling is a date hierarchy representation between dates and their associated measures.
For example, total actual annual gross revenue by month.

Creating Custom Subject Areas

This topic covers how you create and edit custom subject areas, and how you can activate or inactivate a custom subject
area while editing.

You cannot modify a predefined report subject area, however, you can create custom subject areas to meet your
reporting needs.

Note: Before you create a custom subject area, review all the included subject areas to see if the one you want is
already available.

Adding a Custom Subject Area

You add custom subject areas using train stops that appear at the top of the page. These train stops enable you to
move back and forth during the configuration process. You can also save your configuration at a logical point and then
continue to create later.

I Note: You can only create custom subject areas when you are not in an active sandbox.
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To create a custom subject area using train stops:

1.

Navigate to Application Composer.

2. C(lick Custom Subject Areas on the Overview page of Application Composer.
3. Select Create from the Actions menu.

These are the steps in the train stops that you can use for configuring your custom subject area:

1.

Define Custom Subject Area

In this step, you provide the name for your subject area and select the primary object that is the basis for

the reports you create later using the custom subject area. Subject areas usually have names or labels that
correspond to the type of information they contain. Display labels have the Custom: prefix added automatically.
Select Child Objects

In this step, you select the child objects whose data you want to use in your reports. You can add child objects
only if the primary object has child objects. Otherwise, the add icon is disabled. You can only add one child
object per level. The parent-child-grandchild-grand grandchild hierarchy supports adding up to three levels of
child objects with one child object at each level, for example, parent-child1-child1.1-child1.1.1.

Configure Fields

In this step, you select the fields that you want to display on your reports. You typically add at least one field
from each of the objects that you have selected for your custom subject area.

Select the desired measures to generate for number, date, or currency fields from all the available objects so
that the subject area includes only those measures that you want to analyze. Also, define at least one measure.

In the Measure Aggregations column, select an option from the list of predefined formulas that you can apply
to the Measure field. When you select the formula, the application applies the selected formulas to the selected
field and measures.

Note: You can choose measures only for the lowest child. For example, if only a primary object exists with no
children, you can select measures for the primary object. Otherwise, if any child objects exist, you can select
measures only at the lowest child object level, not for the parent object.

You can change the display labels of the fields that you select in this step. Additionally, you can use the Select
Fields dialog to remove fields that belong to the primary object. The Select Fields dialog appears when you click
Select Fields when configuring fields for your custom subject area.

After you publish your custom subject area, the fields you have selected for your subject area are automatically
added to their owning object's folder. If you have also defined measures, those fields are automatically added to
the Facts folder. If you did not define a measure, then one is automatically created for the custom subject area.

For more information on measures, see Measures.
Configure Date Leveling

If required, select the Date columns for date leveling. For more information on date leveling, see Date Leveling.
Configure Security

Select the required security level for the Everyone Role Name, which is added by default, or add additional Role
Names by clicking in the + icon and define the security level for each one of them.

The security definition here only controls who can access the custom subject area definition to create reports. It
doesn't control data visibility which is automatically controlled based on the user running the reports.
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For more information on securing custom subject areas, see Custom Subject Area Security.
6. Review and Submit

Review the custom subject area configuration for all added objects, attributes, and measures, and if satisfied,
click Submit. If changes are required click Back to navigate back to the required screen.

After you submit, the custom subject area configuration is prepared for publishing. You can create and submit
a custom subject area either immediately or save and close the custom subject area at any point and submit it
later. You must first submit a custom subject area for publishing before you can select it from within Oracle Bl

Composer. After you save or submit a custom subject area, you cannot modify its primary object.

To access the published custom subject area in Bl:
o From the Navigator menu, select Tools > Reports and Analytics .
o Inthe Contents pane, click Create.
o Select the published custom subject area and start creating your report.

Editing Custom Subject Areas

You can edit a published or saved custom subject area and then republish it when your changes are done. Modifying a
custom subject area does not affect the reports that you had created using that custom subject area before making the
changes. You can use the modified custom subject area if you need to enhance existing reports.

To edit a custom subject area:

1. On the Overview page of the Application Composer, click Custom Subject Areas.
Locate the custom subject area that you want to edit, and click the Edit icon.

You can filter out inactive custom subject areas in Application Composer by viewing custom subject areas in
Active status. This is safer than deleting them, because the inactive subject areas are still available and can be
found by searching.

3. Make the desired changes and then click Submit to republish the custom subject area.

While you can edit a custom subject area in any status, there are considerations on what you can or can't do when
editing. When editing a published custom subject area, it is not possible to:

- Change the primary object.

- Add or remove child objects.

- Remove previously added measures.

- Add more aggregation types for measures that are already published.

Note: You cannot modify a predefined report subject area. Instead, you must create separate custom subject areas to
meet your reporting needs. Before you create a custom subject area, be sure to review all the included subject areas to
see if the one you want is already available.

Activating or Inactivating Custom Subject Areas

When editing custom subject areas, you can activate or inactivate custom subject areas when your reporting or
business requirements change. This step enables you to control what information is displayed on the reports that use
the information from custom subject areas.
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You can inactivate only those custom subject areas that are published and have a status of OK, and can activate only
previously inactivated custom subject areas.

To inactivate a custom subject area, select it in the list and then click the Inactivate button. To activate an inactive
custom subject area, select it and click Activate. Note that if no custom subject area is selected in the list, the button
doesn't appear.

When searching for custom subject areas, you can filter out inactive custom subject areas in Application Composer by
viewing only those in Active status. Inactivating a custom subject area is safer than deleting it, because the inactive
subject areas are still available and can be found by searching.

Objects in Custom Subject Areas

This topic covers how you use the various types of objects in the Application Composer to create custom subject areas.
A custom subject area is a set of entities (objects), attributes, and measures that you use to build reports.

Objects can be classified under broad categories of custom objects and standard objects. Every custom subject area
has a primary object, which is the focus of any reports that you create. You can also optionally add child objects to the
custom subject area. Custom subject areas support both custom and standard objects. The objects that you create are
called custom objects.

Before designing your custom subject area, use Intake Form Designer to identify or create the objects and fields that
you want to use.

Primary Objects

A primary object is any top-level object. You create a custom subject area based on the primary object. Additionally, the
primary object is the focus of the report that you create based on the custom subject area.

The list of available primary objects includes all objects, which are either top-level custom objects, or standard objects
that are configured by the owning application. After you save your custom subject area, you can't change its primary
object; but you can create another custom subject area using a different primary object.

Based on how you want to configure your custom subject area, you can add one child to an object.

Child Objects

A child object is an object that has a one-to-many relationship with a parent object and can be a parent object of
another child object. Add a child object to a custom subject area if you want your report to include data from both the
primary object and its children. If an object's parent object is already a child object (of another parent object) then the
object is a grandchild object. For example, if object Y is a child of object X, and object Z is a child of object Y, then object
Z is a grandchild of object X. Custom subject areas support parent-child-grandchild-great-grandchild objects.

You can only add one child object to the primary object per level, as long as there are child objects available. If there are
no child objects for the chosen primary object, the list that enables selecting child objects does not appear.

The parent-child-grandchild-great-grandchild hierarchy supports adding up to three levels of child objects with one
child object at each level; for example, parent-child1-child1.1-child11.1.

I Note: Once you publish a custom subject area, you can't add or remove child objects.
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Fields or Attributes in Custom Subject Areas

This topic explains the various types of fields or attributes that you use for configuring your custom subject area.

Fields or attributes store entity information in the application. Fields can be standard or custom.

Types of Reporting Fields

The fields you can use to create reports are as follows:

« Text
Number
Date
Percentage
Date time
- Currency
« Check box
Fixed choice list
Dynamic choice list

Long text

Note: You cannot create reports using the Rich text area field.

When you create a custom field, you can create reports for the following data types:
Boolean

Note: Note: If you are using the Boolean data type for fields other than check boxes, those fields are
displayed as either O or 1 on your custom reports.
Number
« Currency
Date
- String
Percentage
Phone
Date time

Long text
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Measures

Measures are a set of functions. Examples include a SUM of the actual gross revenue in USD, or a COUNT of the number
of building permits worth over $500,000.

The designer defines the aggregation function (SUM, COUNT, and so on) for custom measures, so end users don't need
to do so themselves when they create an analysis. You can apply these functions on fields of type Date, Numeric, or
Currency.

Measures available to a particular type of field may differ depending on the field type. After you define the measures
for the required fields and publish the custom subject area, you can select these fields and the applied measures when
creating your report in the Oracle Bl Composer. You can only specify aggregate formulas to apply to a measure when
creating a custom subject area. It is not possible to edit a measure in an already published custom subject area.

Here are some measures you can apply to fields of type Numeric, Currency, or Date.

« For Numeric and Currency fields, a measure can be:

[e]

All

Note: Allis not a measure, but an option in the Ul that selects all of the measures.

Sum: Calculates the sum of the values.

Average: Calculates the mean value.

Count: Calculates the number of rows that are not null.

Count Distinct: Calculates the number of rows that are not null. Each distinct occurrence of a row is
counted only once.

Note: Although Count Distinct is usually used in cases requiring a count on a foreign key (because a
count of distinct rows is what's wanted), it is not required. If your requirements allow multiple instances
of the same foreign key value to be counted multiple times, you can use Count rather than Count
Distinct.

Maximum: Calculates the highest numeric value.

Minimum: Calculates the lowest numeric value.

First: Selects the first occurrence of the item.

Last: Selects the last occurrence of the item.

Median: Calculates the middle value.

Standard Deviation: Calculates the standard deviation to show the level of variation from the average.

Standard Deviation Population: Calculates the standard deviation using the formula for population
variance and standard deviation.

For Date fields, a measure can be:

o

o

o

All
Maximum
Minimum
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You can select measures based on your reporting needs. For example, you can use measures to view product sales per
store, state, or country. Or, to view the number of support tickets opened or closed per day, week, or month, and so on.

If you do not define a measure, then one will be automatically created for the subject area when you submit the custom
subject area for publication.

Date Leveling

Date leveling is a hierarchy representation of dates and associated measures, which enables you to view the data over
different periods of time.

To use this hierarchy, create a report that shows the total Actual Gross Revenue amount for each year. Drill down from
year to show gross revenue per quarter, sales per month, gross revenue per week and gross revenue per day, and
then drill back up to gross revenue per year. The date hierarchy aggregates the measures by the required hierarchy or
leveling period.

To configure date leveling when defining a custom subject area, use the Configure Date Leveling step of the train stop
to either allow or disallow leveling. You may need to expand the field list in the Date field to select or clear the Date
Leveling check box, as applicable.

For more information on where the Configure Date Leveling step appears in the train stop, see Creating Custom Subject
Areas.

Custom Subject Area Security

You can secure a custom subject area by granting or revoking access rights from the role names that access the custom
subject area. This topic covers how you can grant or revoke access rights from those role names.

For information about custom subject area data source security in Bl Publisher, see Public Sector Compliance and
Regulation Custom Subject Area Security Guide for Implementation (Doc ID 2730290.1) in My Oracle Support.

Managing Role Names and Access Rights

While defining a custom subject area using the train stops, you can use the Actions list in the Configure Security step to
manage role names and access rights.

I Note: You cannot delete the role name listed as Everyone.

Read access is granted by default. If you want to revoke Read access from a listed role name, select No access for that
role name.

You can create custom subject areas even for the objects in which you do not have access to the data, which allows you
to build custom subject areas without compromising data security.
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Publication Statuses of Custom Subject Areas

This topic covers what happens when you submit a custom subject area for publishing, and what the submission
statuses indicate.

After you successfully publish your custom subject area, you can start building reports using Oracle Business
Intelligence (Bl) Composer based on your published subject area.

What Happens When You Submit for Publishing

When you submit a custom subject area for publishing, two processes occur in the background. The first process is
synchronous and creates Oracle Applications Development Framework (Oracle ADF) artifacts. You must wait until this
first process is over. The second process is asynchronous and creates centralized metadata repository (RPD) fragments
and submits them to the Oracle Bl server.

Note: You must refresh the status to know whether the custom subject area is submitted successfully. You may have
to refresh the status multiple times, because the creation of Oracle ADF and RPD artifacts may require some time.

A custom subject area can have one of the following statuses:

Pending: This status indicates either of the following:
o You saved and closed the configuration process for a custom subject area before submitting it for
publishing.
o A failure occurred in the background processes when creating Oracle ADF and RPD artifacts.
In Process: This status indicates that the data is in the process of being published to Oracle Bl.

Note: If the in-process status doesn't change to OK, even after multiple refresh attempts, then there could be
an error in publishing. If an error occurs, then the details are displayed, as well as information about how to fix
problems, where applicable. These error status details allow you to pinpoint and fix problems quickly.

- OK: This status indicates that the custom subject area has been published successfully. You can use Oracle Bl
Composer to create reports using the objects, attributes, and measures that you have configured in the subject
area.

Including Custom Fields on Reports

This topic discusses how to create a custom subject area using an attribute and create a report.

Creating a Custom Subject Area

In this example, you create a custom subject area using the LNP1KitchenRemodel object.

1. If you are working in a sandbox, exit the sandbox.
2. Click the Navigator menu at the top.
3. Click the Application Composer link.
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Note: You might need to click the more >> link first.

You are on the main page of Application Composer, where you create a custom subject area using the
LNP1KitchenRemodel object.

Change the Application from CRM Cloud to ERP and SCM Cloud.
In the Overview region, click the Custom Subject Areas link.

You are on the Custom Subject Areas page. You can use this page to search or create custom subject areas.
In the Search Results region, click the Create button.

Enter a name for the custom subject area that you are creating. Enter Kitchen Remodel in the Label field.
In the Primary Object region, click the Primary Object list.

Click the LNP1KitchenRemodel list item.

In the upper-right region of the page, click the Next button.

In the upper-right region of the page, click the Add Child Object button.

In the Add Child Object dialog box, click the Child Object list.

Click the ContactList list item.

Click OK.

In the upper-right region of the page, click Next.

You now define the fields for the LNP1KitchenRemodel primary object.

Chapter 15

eas

Ensure that the selected value in the Fields Fromlist is LNP1KitchenRemodel. Click the Select Fields button.

On the Select Fields modal page, select the fields that you want to include for the LNP1KitchenRemodel
primary object.

Repeat steps 16 and 17 for the ContactList child object.

In the upper-right region of the page, click Next.

You now select fields to apply date leveling. In the Date Field Leveling table, click the Expand button of the
LNP1KitchenRemodel object.

Select the Allow Leveling option for the Business Start Date field.

In the upper-right region of the page, click Next.

Leave the default role access of Read for Everyone. In the upper-right region of the page, click Next.
Review your custom subject area. In the upper-right region of the page, click Save.

In the upper-right region of the page, click Submit.

A confirmation message appears.
Click OK.

You successfully created a custom subject area.

Creating a Report Using a Subject Area

In this example, you create a report in Oracle Business Intelligence Composer (Bl Composer) using the Kitchen Remodel
subject area.

1.

Click the Navigator menu at the top.

2. C(lick the Reports and Analytics link under Tools.

Note: You might need to click themore >> link first.

The Reports and Analytics page appears.
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In the left pane, click Create and select Analysis.

From the Select Subject Area dialog box that appears, you must first select a subject area to build your report.
In this activity, you are building a report using the Kitchen Remodel subject area.

In the Select Subject Area dialog, select the check box next to Custom:Kitchen Remodel and click Continue.

Tip: You can add more than one subject area to a report by selecting the check box next to additional subject
areas.

You are in the Select Columns step of Oracle Business Intelligence Composer (Bl Composer) wizard. In the left
box, click the Expand button of the Custom:Kitchen Remodel tree.

Add the following fields to the Selected Columns box on the right:

RecordNumber under LNP1KitchenRemodel tree.
Submission Date under LNP1KitchenRemodel tree.
Status under LNP1KitchenRemodel tree.
Expiration Date under LNP1KitchenRemodel tree.
Female Owned under LNP1KitchenRemodel tree.
First Name under ContactList tree.
Last Name under ContactList tree.
Gender under ContactList tree.
Phone Number under ContactList tree.

j. State under ContactList tree.
In the upper-right region of the page, click Next.

~ 70 -0 20T

You are in the Select Views step of the wizard.

Enter Kitchen Remodel Permits in the Title field.

Click the Table list.

Click the Table (recommended) list item.

Click the Preview option on the right of the Title field to view a preview of the table. Click OK.
In the upper-right region of the page, click the Next button.

You are in the Edit Graph step of the wizard.

In the upper right region of the page, click Next.
You are in the Sort and Filter step of the wizard.

In the upper right region of the page, click Next.

You are in the Highlight step of the wizard.
In the upper right region of the page, click Next.

You are in the Save step of the wizard.

Enter Kitchen Remodel Permits in the Analysis Name field.

In this activity, you will save your report in only My Folders. In the Save In area, click the My Folders tree.
In the upper right region of the page, click Submit.

A confirmation message appears.

Click OK.

You can now view the report you just created. Click the Expand button of the My Folders tree.
Locate the report you just created.

You successfully created a report in Bl Composer using the Kitchen Remodel subject area.
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Custom Subject Areas: Frequently Asked Questions

This topic provides answers to some frequently asked questions regarding custom subject areas.

Can | change a custom subiject area's primary object?

No. Once you save a custom subject area, you cannot change its primary object; however, you can create a new custom
subject area with a different primary object.

What happens if | change a custom subject area after it is published?

You can edit a published custom subject area and then republish it after your changes are done. Modifying a custom
subject area does not affect the reports that you created using that custom subject area before making the changes.
You can use the modified custom subject area should you need to enhance existing reports.

Note: You cannot edit a primary object when you modify a custom subject area. Should you need to do so, create a
new custom subject area using a different (new) primary object.
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16 Setting Up Time Recording

Time Recording Overview

Time recording enables agencies to track the amount of time their employees spend on various activities.

Agencies can use this recorded time to:

- Bill for time spent.
- Report on key performance indicators.
To set up your agency for time recording, you define:
1. Time recording categories and subcategories.
See Setting Up Time Categories and Subcategories.

Note: This step is not strictly required because you can add time entries without categories or subcategories.
You must define time recording categories and subcategories, however, before associating them with time
entry types.

2. Time entry types.

See Setting Up Time Entry Types.
3. Fee schedules.

See Setting Up Fee Schedules.

Note: This step is required for billing based on time spent.

Once you've setup up your time recording framework, agency staff can enter time and assess fees on the transaction
pages. For more information, see Adding Time Entries and Assessing Fees for Time Entries.

Setting Up Time Categories and Subcategories

Time categories and subcategories enable agencies to classify how their staff is spending their time.

Categories and their subcategories are reusable across transactions and products, and can be used to calculate fees and
generate reporting information.

You add, modify, and delete time categories and subcategories on the Time Category page ( Time Recording Setup >
Time Category ).

This example shows the Time Category page

Time Category

LS eard ALY
Category ID Category Description Enabled

MEETING MEETING VEETING Yes

TRAVEL TRAVEL TRAVEL
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Adding a Time Category

1. Onthe Time Category page, click Add.

2. Onthe Time Category Details page, enter a Category ID, a Category, and a Description for the category.

3. Turn on the Enable switch to make this category available to select for time entry types. This switch is turned
off by default for new time categories.

4. Add a subcategory.
I Note: You must have values defined for all required time category fields before you can add a subcategory.

5. Click Save.

Adding a Time Subcategory

1. Click a row on the Time Calendar page.

2. Onthe Time Category Details page, click Add.

3. On the Time Subcategory Details page, enter a Subcategory ID, a Subcategory, and a Description for the
subcategory.

4. Ensure that the Enable switch is turned on so that the subcategory is available to select for time entry types.
This switch is turned on by default for new time subcategories.

5. Click Save.
Modifying a Time Category

1. Click a row on the Time Calendar page.
2. Onthe Time Category Details page, you can:

o Update the time category fields.

Note: You can't edit the Category ID field.

o Enable or disable the time category.
o Delete the time category. You will be prompted to confirm the permanent deletion.
o Add, modify, or delete time subcategories.

3. Click Save.

Modifying a Time Subcategory

1. Click a Time Subcategory row on the Time Category Details page.
2. On the Time Subcategory Details page, you can:

o Update the time subcategory fields.

Note: You can't edit the Subcategory ID field.

o Enable or disable the time subcategory.
o Delete the time subcategory. You will be prompted to confirm the permanent deletion.

3. Click Save.
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Deleting Time Categories

1. On the Time Category page, click Select Multiple.
2. Select the check boxes next to all the time categories you want to delete.
3. Click Delete. You will be prompted to confirm the permanent deletion.

Deleting Time Subcategories

1. On the Time Category Details page, click Select Multiple.
2. Select the check boxes next to all the time subcategories you want to delete.
3. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Time Entry Types
Time entry types enable you to associate time categories and subcategories with the transactions where they can be
used to record time.

Each time entry type represents a unique, reusable combination of time category, time subcategory, classification, and
transaction. For example, you might create a time entry type for air travel associated with a permit inspection.

You add, modify, and delete time entry types on the Time Entry Type page ( Time Recording Setup > Time Entry Type
)-

This example shows the Time Entry Type page

Time Entry Type

B
se.380 Toave a Fign a O " @) " @) " @) a
PRO TRAVEL Q Q «© ]
Qat21 Q Q . L ]
INSP_O Pe e TRAVEL Q Q C ]
INSP_B MEETING Q Misc MEETING Q C C T
PRB . MEETING aQ Mise MEETING aQ [ @ [ @ [

: raveL a a [ @ O O O ]
e a a O © © @
Adding a Time Entry Type
1. Onthe Time Entry Type page, click Add.
2. For the new time entry type row, enter values for the following fields:
Page Element Description
Time Type Code Enter the code that agency staff members use to enter all the default values associated

with this time entry type when adding time entries.
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Page Element

Classification

Transaction

Category and Subcategory

Billable

Assess Now

Override

Enabled

3. Click Save.

Chapter 16
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Description

Select a product area, such as Permit or Planning and Zoning.

Select a specific transaction, such as Plan Review, Inspection, or Planning Application.

Note:
The transactions that are available to select depend on the Classification you
selected.

Select the time category and subcategory for the time entry type. For more
information on time categories and subcategories, see Setting Up Time Categories and
Subcategories.

Note:
You can leave these fields blank. You can't select a subcategory without first selecting
a category.

Turn this switch on to make entries associated with this time entry type billable by
default.

Turn this switch on to immediately assess fees for entries associated with this time entry
type by default.

Note:

This switch is available only when the Billable switch is turned on.

Turn this switch on to enable agency staff to override the Billable default setting when
adding a time entry.

Turn this switch on to make the time entry type available to select when adding time
entries.

Modifying a Time Entry Type

Once you save a time entry type, you can no longer edit the following fields:

- Time Type Code
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- Classification
- Transaction
- Category
- Subcategory

You can toggle the four switches:
Billable
- Assess Now

- Override
Enabled

Deleting a Time Entry Type

Click the Delete button next to a time entry type row to delete it.

I Note: You can’t delete a time entry type if it is used for any time entries.
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