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Get Help

Get Help
There are a number of ways to learn more about your product and interact with Oracle and other users.

Get Help in the Applications
Use help icons    to access help in the application. If you don't see any help icons on your page, click your user image
or name in the global header and select Show Help Icons.

Get Support
You can get support at My Oracle Support. For accessible support, visit Oracle Accessiblity Learning and Support.

Get Training
Increase your knowledge of Oracle Cloud by taking courses at Oracle University.

Join Our Community
Use Cloud Customer Connect to get information from industry experts at Oracle and in the partner community. You can
join forums to connect with other customers, post questions, and watch events.

Learn About Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program. (if videos) Videos
included in this guide are provided as a media alternative for text-based topics also available in this guide.

Share Your Feedback
We welcome your feedback about Oracle Applications user assistance. If you need clarification, find an error, or just
want to tell us what you found helpful, we'd like to hear from you.

You can email your feedback to oracle_fusion_applications_help_ww_grp@oracle.com.

Thanks for helping us improve our user assistance!

i

https://support.oracle.com/portal/
https://www.oracle.com/corporate/accessibility/learning-support.html#support-tab
https://www.oracle.com/education/
https://cloudcustomerconnect.oracle.com/pages/home
https://www.oracle.com/corporate/accessibility/
mailto:oracle_fusion_applications_help_ww_grp@oracle.com
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Implementing Licensing and Permitting Using Functional

Setup Manager

2  Implementing Licensing and Permitting
Using Functional Setup Manager

Security Details for Implementing Licensing and
Permitting  
This topic describes important security roles, requirements, or considerations specific to implementing Oracle
Permitting and Licensing.

Primary Role Access Description Associated Job Roles and Abstract Roles

Application Implementation Consultant
 

Configure Oracle Permitting and Licensing
offerings.
 

Application Implementation Consultant
 

For more information on creating roles for Oracle Permitting and Licensing, see Creating Custom Roles for Oracle
Permitting and Licensing.

For more information on all the predefined security data such as abstract roles, job roles, privileges and so on, see the
Security Reference for Oracle Permitting and Licensing.

Using Functional Setup Manager  
This topic discusses how to use the Functional Setup Manager.

Oracle Functional Setup Manager provides an integrated, end-to-end process for functional administrators to manage
the implementation and maintenance of Oracle Permitting and Licensing services.

Business users configure features and manage setup data using the Functional Setup Manager. Subscription to
offerings, enabling functional areas, opting in features, and setting up guided end-to-end tasks pertaining to the
offerings are all driven through the Functional Setup Manager.

To view the Public Sector offerings and their functional areas in Functional Setup Manager:

1. Select Navigator > Setup and Maintenance or select the Setup and Maintenance tile on the springboard.
2. Select a Public Sector offering from the Setup drop-down list.

The page lists all the functional areas on the left and the corresponding tasks on the right.

Note:  When configuring your offering using Functional Setup Manager, configure the functional areas in the order
they appear in Functional Setup Manager from top-to-bottom. Functional areas depend on the configuration data for
the functional areas appearing before them in the list.

Documentation Help Links

3

https://docs.oracle.com/pls/topic/lookup?ctx=pscr22d&id=CreatingCustomRolesForPublicSectorComplianceAndRegulation
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You enable Help links in Functional Setup Manager during your implementation so that you can directly access related
documentation. To enable Help links:

1. Select Navigator > Setup and Maintenance or select the Setup and Maintenance tile on the springboard.
2. Select an Oracle Permitting and Licensing offering from the Setup drop-down list.

The page lists all the functional areas on the left and the corresponding tasks on the right.
3. Click View in the Task section and select Columns  > Help. This option is turned off by default.
4. To view Help icons in the tasks list, select the Settings and Actions button in the header and click Show Help

Icons.
For a detailed understanding of the Functional Setup Manager, see the Oracle Fusion Cloud Applications
documentation: Using Functional Setup Manager.

Migrating Data From Your Test Environment to Your
Production Environment  
This topic describes the utilities used to migrate setup data from your test environment to your production
environment.

In your pod you have these environments:

Environment Description

Test
 

The test environment is where you learn about the product, enter your setup and configuration data,
 and test your changes. For example, this is where you add the data for setting up your agency, create
your permits, specify branding modifications for your site, and so on.
 

Production
 

The production environment is the environment your agency employees and your end users access
to complete transactions. The production environment reflects the “finished product” of what was
configured and tested in the test environment.
 

After you have made changes and tested them in the test environment, you then migrate any changed metadata and
setup data from your test environment to your production environment. You use the Functional Setup Manager export
and import utilities to complete these tasks.

For more information on the Functional Setup Manager export and import utilities, see Using Functional Setup
Manager.

For more information on managing transaction type data, see:

• Managing Transaction Type Configurations.

• Oracle Public Sector Community Development: Test to Production  (Doc ID 2551940.1) on My Oracle Support.
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3  Setting Up Geographical Information

Importing Geographies  
Use the Manage Geographies task to import geographical information.

The Manage Geographies task of the Agency Profile functional area in Oracle Functional Setup Manager enables you
to import geographies into your interface tables. For detailed instructions on importing geographies, see the Oracle
Applications Cloud documentation: "How You Import Geographies" in Implementing Global Human Resources.

Importing geographies automatically populates data for the following tasks:

• Manage Countries (Setting Up Counties)

• Manage States (Setting Up States)

• Manage Counties (Setting Up Counties)

• Manage Cities (Setting Up Cities)

• Manage Public Sector Currencies (Setting Up Currencies)

Setting Up Countries  
A country definition includes the country name and various identifying codes.

You add, modify, and delete countries on the Country page.

Adding a Country
1. Select Common Setup > Country.
2. On the Country page, click Add.
3. On the Country Details page, enter values for the following fields:

Page Element Description

Country Code
 

Enter a the unique code that your system uses for the country. For example, you might enter
FRA for France.
 

ISO Alpha 2 Code
 

Enter the two-letter International Organization of Standardization (ISO) code for the country.
For example, you would enter FR as the code for France.
 

ISO Numeric 3 Code
 

Enter the three-digit United Nations (UN) M.49 code for the country. For example, you would
enter 250 as the code for France.
 

Country Name Enter the name of the country as it appears in your system.

5
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Page Element Description

  

4. Click Save.

Modifying a Country
1. Select Common Setup > Country.
2. Click a row on the Country page.
3. On the Country Details page you can:

◦ Update the country field values.

Note:  You cannot edit the Country Code.

◦ Delete the country. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Countries
1. Select Common Setup > Country.
2. Click Edit.
3. Select the check boxes next to all the countries you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up States  
A state definition includes information such as the state name, country, and various ID codes.

You add, modify, and delete states on the State page.

Adding a State
1. Select Common Setup > State.
2. On the State page, click Add.
3. On the State Details page, enter values for the following fields:

Page Element Description

Country
 

Enter the code for the country that the state is in.
 

State Code ISO
 

Enter the International Organization of Standardization (ISO) code for the state.
 

Code
 

Enter the unique code that your system uses for the state.
 

6
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Page Element Description

State Name
 

Enter the name of the state.
 

Type
 

Enter the subdivision type.
 

GNIS ID
 

Enter the Geographic Names Information System (GNIS) ID for the state’s location.
 

4. Click Save.

Modifying a State
1. Select Common Setup > State.
2. Click a row on the State page.
3. On the State Details page you can:

◦ Update the state field values.

Note:  You cannot edit the Country or State Code ISO fields.

◦ Delete the state. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting States
1. Select Common Setup > State.
2. Click Edit.
3. Select the check boxes next to all the states you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Cities  
A city definition includes information such as the city name, country, state, and certain ID codes.

You add, modify, and delete cities on the City page.

Adding a City
1. Select Common Setup > City.
2. On the City page, click Add.
3. On the City Details page, enter values for the following fields:

Page Element Description

Country Code and State Code Enter the codes for the country and state in which the city is located.

7
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Page Element Description

  

County
 

Enter the five-digit International Committee for Information Technology Standards (INCITS)
code for the county in which the city is located.
 

FIPS Code
 

Enter the seven-digit Federal Information Processing Standard (FIPS) code for the city.
 

City Name
 

Enter the name of the city.
 

GNIS ID
 

Enter the Geographic Names Information System (GNIS) ID for the city’s location.
 

4. Click Save.

Modifying a City
1. Select Common Setup > City.
2. Click a row on the City page.
3. On the City Details page you can:

◦ Update the city field values.

Note:  You cannot edit the Country Code, State Code, or County fields.

◦ Delete the city. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Cities
1. Select Common Setup > City.
2. Click Edit.
3. Select the check boxes next to all the cities you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Counties  
A county definition includes information such as the county name, country, state, and certain ID codes.

You add, modify, and delete counties on the County page.

Adding a County
1. Select Common Setup > County.
2. On the County page, click Add.
3. On the County Details page, enter values for the following fields:

8
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Page Element Description

Country and State
 

Enter the codes for the country and state that the county is in.
 

INCITS Code
 

Enter the five-digit International Committee for Information Technology Standards (INCITS)
code for the county.
 

County Name
 

Enter the name of the county.
 

FIPS Code
 

Enter the seven-digit Federal Information Processing Standard (FIPS) code for the county.
 

GNIS ID
 

Enter the Geographic Names Information System (GNIS) ID for the county’s location.
 

4. Click Save.

Modifying a County
1. Select Common Setup > County.
2. Click a row on the County page.
3. On the County Details page you can:

◦ Update the county field values.

Note:  You cannot edit the Country, State, or INCITS Code fields.

◦ Delete the county. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Counties
1. Select Common Setup > County.
2. Click Edit.
3. Select the check boxes next to all the counties you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Currencies  
A currency definition includes currency codes, a description, and the number of decimals that can be used to represent
an amount in the currency.

You add, modify, and delete currencies on the Currency page.

9
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Adding a Currency
1. Select Common Setup > Currency.
2. On the Currency page, click Add.
3. On the Currency Details page, enter values for the following fields:

Page Element Description

Currency Code
 

Enter a the unique code that your system uses for the currency.
 

ISO Code
 

Enter the three-digit International Organization of Standardization (ISO) 4217 numeric code for
the currency. For example, you would enter 840 for the US dollar.
 

Description
 

Enter a short description of the currency.
 

Decimal Position
 

Enter the number of decimal places that can be used to represent an amount for the currency.
For example, the United States dollar uses two decimal positions.
 

4. Click Save.

Modifying a Currency
1. Select Common Setup > Currency.
2. Click a row on the Currency page.
3. On the Currency Details page you can:

◦ Update the currency field values.

Note:  You cannot edit the Currency Code field.

◦ Delete the currency. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Currencies
1. Select Common Setup > Currency.
2. Click Edit.
3. Select the check boxes next to all the currencies you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

10
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4  Setting Up Your Agency

Setting Up Agencies  
An agency is an organization that offers a range of services to its constituents, including issuing permits and licenses.

Administrators add and modify agency information using the Agency page.

Set up exactly one agency, with agency ID 1. Oracle does not currently support multiple agencies.

Adding an Agency
1. Select Common Setup > Agency.
2. On the Agency Information page, click Add.
3. On the Agency Information - Details page, enter values for the following fields:

Page Elements Definition

Agency ID
 

Enter the number 1 as the ID for your agency.
 

Name and Description
 

Enter a name and a short description for the agency.
 

Country
 

Enter the country in which the agency is located.
 
This value is informational only. Address fields throughout the system support only USA
addresses.
 

Currency
 

Enter the currency that the agency uses for financial transactions.
 
This value is informational only. It does not affect the currencies for fees, cash drawers, or
payment adaptors.
 

Time Zone
 

Select your agency’s local time zone. All times displayed in Oracle Permitting and Licensing use
this time zone.
 

Time Format, Date Format, and
Number Format
 

Select the default formats that the agency uses to display times, dates, and numbers for
anonymous users.
 

Parcel Owner Format
 

This field is reserved for future functionality. Currently, regardless of your selection, parcels
have one field to identify the parcel owner and an additional field to identify a secondary owner.
 

11



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 4
Setting Up Your Agency

Page Elements Definition

Hide property owners from public
users
 

Turn on this switch to hide property owner information from public users.
 

Oracle Policy Automation ID
 

Enter the unique identifier for an agency-wide Oracle Intelligent Advisor policy model.
 
Oracle Intelligent Advisor is a separate Oracle product. Oracle Intelligent Advisor policy models
provide logic models for questionnaires that help public users determine which applications
they need to complete.
 
The policy model that you enter here is used by offerings that do not have an offering-specific
policy model. To specify an offering-level policy definition, select the Features tab on the
Agency Information page, then click the Options link for the offering.
 
For more information on Oracle Intelligent Advisor, see Overview of Oracle Intelligent Advisor
Configuration.
 

Business Number Rule
 

Select the autonumbering rule to increment numbers for businesses.
 

Note:
This field is required if the Business Licenses offering is enabled for your agency.
Autonumber rules need to be defined after you create the agency, so be sure to return to the
agency pages to add the business number autonumber rule that you define.
 

Location Number Rule
 

Select the autonumbering rule to increment numbers for business locations.
 

Note:
This field is required if the Business Licenses offering is enabled for your agency.
Autonumber rules need to be defined after you create the agency, so be sure to return to the
agency pages to add the location number autonumber rule that you define.
 

Default Search Filter
 

Select a default search filter. The available search filters are Address, Parcel, and Owner.
 

Default Search Type
 

Select the default search type. The available search types are Starts with and Contains.
 

4. Click Save.

Modifying an Agency
1. Select Common Setup > Agency.
2. Click a row on the Agency Information tab.
3. Update the agency information field values.

12
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4. Click Save.

Adding an Agency Address
1. Select Common Setup > Agency.
2. Click a row on the Agency Information page.
3. Select the Addresses tab, and click Add.
4. On the Addresses - Details page, enter values for the following fields:

Page Elements Definition

Address ID
 

Enter a unique ID for the address.
 

Primary
 

Select to indicate that this is the primary address for the agency. An agency may have only one
primary address.
 

From Date and To Date
 

Enter the date range for which the address is valid.
 

Address Fields
 

The agency address. The Country field displays US.
 
As you enter a Postal Code, the type-ahead list shows values that include appropriate city and
state combinations. After you select a value, the city and state appear as read-only fields, and
two address fields appear so that you can enter the rest of the address.
 
If you don’t know the postal code, click the Don’t know link to display a full set of address
fields.
 

5. Click Save.

Modifying an Agency Address
1. Select Common Setup > Agency.
2. Click a row on the Agency Information page.
3. Select the Addresses tab.
4. Click a row on the Addresses tab. You can:

◦ Update the agency address field values.

Note:  You cannot change a primary address row to non-primary. Instead, when you update a non-
primary row to primary, all other address rows are saved as non-primary.

◦ Delete the address. You will be prompted to confirm the permanent deletion.

Note:  You cannot delete primary address rows.

5. Click Save.

13
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Deleting an Agency Address
1. Select Common Setup > Agency.
2. Click a row on the Agency Information page.
3. Select the Address tab.
4. Click Edit.
5. Select the check boxes next to all the agency addresses that you want to delete.
6. Click Delete. You will be prompted to confirm the permanent deletion.

Note:  You cannot delete primary address rows. To delete an address row that is designated as primary, you must first
designate a different address row as primary. This changes the previously primary row to non-primary, allowing it to
be deleted.

Adding Agency Languages
For information on adding languages and establishing language defaults for an agency, see Setting Up Languages.

Configuring Agency-Level Options for Specific Offerings
The Features tab lists offerings that are enabled in Functional Setup Manager (FSM). Because features are enabled
in FSM, you can ignore the Integration Enabled field on this page. Use the Options link to configure offering-specific
settings.

For more information about configuring these options, see

• Permits: Setting Up Agency-Level Options for Permits

• Planning Applications: Setting Up Agency-Level Options for Planning Applications

• Code Enforcement: Setting Up Agency-Level Options for Code Enforcement

Enabling Subledger Accounting
1. Select Common Setup > Agency.
2. Click the row for your agency on the Agency Information page.
3. Select the Oracle Financials tab.

Note:  This tab appears only if you select Financials Cloud Subledger Accounting as your accounting
framework option in Functional Setup Manager. For more information, see Selecting an Accounting
Framework.

4. Turn on the Create Subledger Accounting switch.
5. Select your agency’s ledger in the Financials Cloud Ledger field.
6. Click Save.

For more information on Oracle Financials Cloud Subledger Accounting, see Oracle Financials Cloud documentation:
Implementing Subledger Accounting and Using Subledger Accounting.

14

https://www.oracle.com/pls/topic/lookup?ctx=fa22d&id=u30206322
https://www.oracle.com/pls/topic/lookup?ctx=fa22d&id=u30206330
https://www.oracle.com/pls/topic/lookup?ctx=fa22d&id=u30206246
https://www.oracle.com/pls/topic/lookup?ctx=fa22d&id=u30206202
https://www.oracle.com/pls/topic/lookup?ctx=fa22d&id=u30206202
https://docs.oracle.com/pls/topic/lookup?ctx=fa-latest&id=FAISL
https://docs.oracle.com/pls/topic/lookup?ctx=fa-latest&id=FAUSL


Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 4
Setting Up Your Agency

Setting Up Related Transaction Linking
The Related Transactions tab allows you to set up access for your users to link their applications with other related
transactions. You control the way related transactions are linked with applications based on whether an applicant or a
contact user is working with the application.

1. Select Common Setup > Agency.
2. Click the row for your agency on the Agency Information page.
3. Select the Related Transactions tab.
4. Select the check boxes for applicants and contacts to allow linking related transactions:

◦ Applicants can link transactions to only their own applications

◦ Applicants can link transactions to any application

◦ Contacts can link transactions to any application that they manage

◦ Contacts can link transactions to any other application

Note:  If no option is selected, then the Link and Actions options will not be available for applicants and
contacts on the Related Transactions page.

5. Click Save.

See Working with Related Transactions.

Enabling Agency Features
Some features are set at the agency level and they can apply to one re more offerings.

1. Select the desired feature from the Feature Code drop-down list.
2. Turn on the Enabled switch.

Feature Code Name Description

ORA_PSCR_CREATE_INCIDENT
 

Guest Users Can Report Incidents
 

Enables guest users (non-registered users) to
report incidents for Code Enforcement.
 
For more information, see Setting Up Agency-
Level Options for Code Enforcement .
 

ORA_PSCR_ESTIMATE_FEE
 

Guest Users Can Estimate Fees
 

Enables guest users (non-registered users) to
estimate fees prior to submitting an application.
 
For more information, see Estimating Fees.
 

Setting Up Languages  
Add languages and establish language defaults for your agency.
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To enable user language preference and locale support you must:

1. Define the supported languages for your agency.
2. Define the default language for anonymous user setup.

Adding Supported Agency Languages
Supported languages are available for users to select as the default language on the My Preferences page accessed
from the profile icon in the global banner. Additionally, you must select one supported language as the default language
for anonymous user setup.

1. Select Common Setup > Agency.
2. Click the row for your agency on the Agency Information tab.
3. Select the Languages tab.
4. Click Add.
5. Enter values for the following fields:

Page Elements Definition

Language
 

Select the language you want to add.
 

Primary
 

Select to indicate that this is the primary language for the agency. An agency may have only
one primary language.
 

From Date and To Date
 

Enter the date range for which the language is valid.
 

6. Click Save.

Define the Default Language for Anonymous User Setup
1. Access FSM by selecting Setup and Maintenance in the navigator.
2. Select an Oracle Permitting and Licensing offering such as Public Sector Permits or Public Sector Planning and

Zoning.
3. Select the Application Extensions functional area.
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4. Select the Manage Applications Core Administrator Profile Values task.

This is an example of the Manage Applications Core Administrator Profile Values page.

5. Enter FND_LANGUAGE in the Profile Option Code field and click Search.
6. Add a profile value with a Profile Level of Site and a Profile Value of the supported language that you want to

establish as the default.
7. Click Save and Close.

Setting Up Agency Integrations  
Add Oracle Integration Cloud (OIC) integrations for your agency.

Adding an Agency Integration
You can define and enable the OIC integrations on the Integrations tab of the Agency Information page. For example,
you can add an integration that publishes your agency's accounting information to OIC where it can be transformed and
imported by third-party applications.

For more information on publishing accounting information to OIC, see Setting Up OIC to Publish Public Sector
Accounting Information (Doc ID 2784020.1) in My Oracle Support.

1. Select Common Setup > Agency.
2. Click the row for your agency on the Agency Information tab.
3. Select the Integrations tab.
4. Click Add.
5. Enter values for the following fields:

Page Elements Definition

Integration Type
 

Select the type of integration that you want to add.
 

Note:
Currently, the only valid value for this field is Publish Accounting, which enables you to
publish your agency's accounting information to OIC.
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Page Elements Definition

Integration Name and Integration
Version
 

Enter the exact name and version number of the OIC integration that you want to add for your
agency.
 

Integration Parameter
 

This field is reserved for future use. It is not used for publishing accounting information.
 

Integration Enabled
 

Turn this switch on to enable the integration.
 
When a Publish Accounting integration is enabled, the Export Journals to ERP process
publishes accounting information to OIC. For more information on the Export Journal to ERP
process, see Exporting Journal Entries.
 

6. Click Save.

Setting Up Conditions  
A condition indicates a dependency or contingency for completing the application process. You set up, modify, and
delete condition definitions on the Conditions page.

Conditions Overview
A condition indicates a status, criterion, or action that you can apply to an object in the system, such as an address,
parcel, person, contractor license, or transaction.

Conditions are defined with a severity that might affect operations when applied. Condition rules with a Hold severity
prevent one or more of the operations that are selected at the time of applying the condition. Condition rules with a
Lock severity prevent all operations as described in the table here.

Rule Applicable Objects Usage

Prevent Application Progress
 

Address, Parcel, Person, and Contractor License
 

Agency staff applies a condition to a record that
prevents an applicant from submitting any new
permit or planning application that contains the
address, parcel, person, or contractor license.
 

Prevent Workflow Advancement
 

Address, Parcel, Person, Contractor License,
 and Transaction
 

Agency staff applies a condition to a permit
or planning application record that prevents
workflow from advancing. The permit or
planning application workflow tasks cannot be
completed until the condition is resolved.
 

Prevent Issue or Final
 

Address, Parcel, Person, Contractor License,
 and Transaction
 

Agency staff applies a condition to a permit or
a planning application record that prevents the
permit or application cycle from completing its
final step until the condition is resolved.
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Rule Applicable Objects Usage

 
Your workflow process definition must explicitly
identify the final human task that is blocked by
this condition. Use the PSC_FINAL_ACTIVITY
custom property to identify this task. See Using
Custom Properties.
 

Prevent Payment
 

Address, Parcel, Person, Contractor License,
 and Transaction
 

Agency staff applies a condition to a
transaction application record that prevents a
user from processing a payment.
 

Prevent Inspection Schedule
 

Address, Parcel, Person, Contractor License,
 and Transaction
 

This condition rule prevents agency staff from
scheduling a new permit inspection. It does not
affect existing inspections that have already
been scheduled.
 

Prevent Inspection Result
 

Address, Parcel, Person, Contractor License,
 and Transaction
 

This condition rule prevents agency staff from
finalizing the permit inspection results.
 

Prevent Final Inspection
 

Address, Parcel, Person, Contractor License,
 and Transaction
 

Agency staff applies a condition to a permit
to prevent adding or proceeding with a final
inspection.
 

Setting Up and Applying Conditions Using Business Rules Framework
The Business Rules Framework enables you to set up conditions that should apply to a permit or planning application
based on the criteria you define in the business rules.

You must configure the Workflow to trigger the Business Rules Framework process, which in turn applies the condition
to the submitted transaction. The submitted applications are listed in the Transactions page with the conditions applied,
ready for further processing.

Note:  Ensure that the appropriate workflow definition is set up for the permit or planning application type that will
associate with the condition. See Setting Up Permit Types and Setting Up Planning Application Types.

For more information on adding and configuring events with business rules for conditions, see Setting Up Apply
Condition Actions. For information on viewing the applied conditions and resolving them, see Applying Conditions to
Applications

Viewing Business Rules Information

Apart from the condition information, the condition details page shows the business rules framework information
related to the condition in use:

• Offering: The offering for which the condition is used.

• Event Name: The name of the event that defines the business rules.

• Event Description: The description of the event.

• Rule Name: The name of the rule that defines the criteria and the condition action.

• Enabled: The switch shows if the business rule is enabled for the current condition.
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Note:  The Business Rules Framework section is applicable only to conditions with object type Transaction.

Adding Condition Definitions
To add condition definitions:

1. Select Common Setup > Condition.
2. On the Condition page, click the Add New button.
3. On the Condition Details page, enter values for the following fields:

Page Element Description

Condition Name
 

Enter a unique condition name.
 

Object Type
 

Select an object type to categorize the condition, based on the object type to which it is applied:
 

◦ Address

◦ Parcel

◦ Person

◦ Contractor License

◦ Transaction

Display Message
 

Enter a message that is displayed to external users, up to 300 characters.
 

Severity
 

Select a severity level for each condition from these options:
 

◦ Lock

At the most severe level, the Lock condition suspends all operations, including workflow
advancing, payment processing, inspection scheduling, and inspection results.

◦ Hold

Agency staff can select which rules to apply to conditions with the Hold level of severity.

◦ Notice

The Notice level functions as an alert and has no effect on operations.
For more information, see Applying Conditions to Applications.
 

Apply Condition to Transactions
 

Applies the condition automatically to any existing transactions belonging to the address,
 parcel, person, or contractor license. You turn off the switch to disable the condition from
automatically applying to the existing transactions.
 

Note:
This switch is not available by default for the Transactions object type.
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Page Element Description

At the time of applying the condition, users can decide to enable or disable the option on the
Condition Details page.
 

Condition Rules
 

Select the rules for the condition. Condition rules are applied by default depending on the
severity of the condition:
 

◦ Lock severity: All condition rules are automatically applied and no actions can be taken
until the condition is resolved.

◦ Hold severity: Select one or more default condition rules.

◦ Notice severity: No condition rules apply.

See the list of available condition rules in the "Conditions Overview" section of this topic.
 

Priority
 

Select the level of priority for this condition:
 

◦ High

◦ Low

◦ Medium

Description
 

Enter a description of the condition.
 

Additional Information
 

Enter any additional information regarding this condition.
 

Allow Updates by Parcel Import
 

Turn on this switch to allow parcel conditions to be automatically resolved by the Parcel Import
process.
 
A condition will be automatically resolved only when the parcel import option is selected to
resolve the parcel or address condition if it's not found in the import file.
 
A condition will also be resolved by the Parcel Import Process when an existing condition is
found in the import file, and the status field for that condition is set to Resolve in the import file.
 

Business Rules Framework
 

This section shows the details of this condition’s association with the events in the Business
Rules Framework.
 

4. Verify that the Enabled switch is turned on. New conditions are active by default.

Note:  You can't disable or delete the condition if it's being used by the Business Rules Framework to
automatically apply conditions or if the condition is already applied to any object.

5. Click Save.

Modifying Conditions
1. Select Common Setup > Condition.
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2. Click a row on the Condition page.
3. On the Condition Details page you can update the display message, severity, description, and the Enable

switch.
4. Click Save.

Deleting Conditions
You can delete a condition only if it isn't being used. If you try to delete a condition that is applied to a transaction, or
contractor license, you will see an error message stating that you can't remove the condition because it has already
been applied.

You also can't delete or disable a condition in the condition setup when the condition is used by the Business Rules
Framework in the Apply Condition action.

1. Select Common Setup > Condition
2. Click a row on the Condition page.
3. On the Condition Details page, click Delete to delete the condition.

Setting Up Autonumbering  
Set up autonumber rules to increment identifying numbers for documents such as permits and invoices. The identifying
numbers can include multiple parts, and each part can represent either a sequential number, static text, or a date.

You add, modify, and delete autonumber rules on the Autonumber page.

This example illustrates the Autonumber Details page.
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Adding an Autonumber Rule
1. Select Common Setup > Autonumber.
2. On the Autonumber page, click Add.
3. On the Autonumber Details page, enter values for the fields in the Rule Header section:

Page Element Description

Rule Name
 

Enter a unique name for the rule. The name can’t include spaces.
 

Copy Existing Rule
 

Click this link to copy the rule definition from an existing autonumber rule. The copy action
copies the number type and the reset frequency as well as the actual rule definition.
 
Clicking the link opens a a modal window with a list of existing autonumber definitions. Locate
the definition you want to copy, then click the Select button for that definition
 

Description
 

Enter a description for the autonumber rule.
 

Maximum Size
 

Indicate the maximum length of the generated number.
 

Note:
As you set up your autonumber rule, take care that the maximum size of the autonumber
accommodates the maximum length of each part of the identifier plus any separators that
you define.
 

Number Type
 

Select the type of object that uses this autonumber rule. When you choose an autonumber rule
for an object, only rules with the appropriate type are available.
 
These are the available number types:
 

◦ Business entity

◦ Business license

◦ Case

◦ Cashier session

Note:
If you select this number type, make sure that the rule uses only Sequential part types.
 

◦ Code inspection

◦ Deposit account

◦ Deposit slip

◦ Incident

23



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 4
Setting Up Your Agency

Page Element Description

◦ Inspection

◦ Invoice

◦ Permit

◦ Planning application

◦ Project

◦ Receipt

Note:
You can’t change the number type for a rule that is already in use.
 

Reset Sequential Number
 

The identifier that an autonumber rule generates can include a mix of static text, a date, and a
sequential number. Select how often the sequential number portion of the identifier is reset to
zero:
 

◦ Calendar month: The sequential number resets to zero at the beginning of each month.

◦ Calendar year: The sequential number resets to zero on January 1 of each year.

◦ Fiscal year: The sequential number portion resets to zero on the first day of your fiscal
year. When you select this option, the Fiscal Year End Month field appears.

◦ None:  Sequential numbers continue to increment as defined without resetting.

Fiscal Year End Month
 

If you reset the sequential number portion of the identifier on the first day of the fiscal year,
 select the month when your fiscal year ends. For example, if your fiscal year end month is June,
 then the sequential number resets to zero on July 1 of each year.
 

4. In the Rule Definition section of the page, enter the number of parts, or segments, for the rule:

CAUTION:  The autonumber rule definition determines the system generated application ID of your
transaction such as permit, planning application, and business license.Therefore, you must define the rule in
a way that generates a unique application ID. Failing to do so can result in duplicate application IDs, which will
cause issues in the application.

Page Element Description

Number of Parts
 

Select the number of parts, or segments, comprising the rule, up to 5 parts. Segments can be
static text, a date, or a sequential number.
 
For example, the identifier IVC-0000010067-OCT10 is made of 3 segments (static text, then a
sequential number, then a date) separated by hyphens. The identifier INVOICE_001 is made of
2 segments (static text and a sequential number) separated by an underscore.
 
When you select the number of parts, the corresponding number of rows appear in the rule
definition grid. For example, if there are two parts, then rows labeled Part 1 and Part 2 appear.
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Page Element Description

 

5. In the rule definition grid, select the part type for each row, then enter the related information in the additional
fields that appear.

Part Type Related Information

Static Text
 

In the unlabeled field that appears next to the part type, enter text that remains the same for all
identifiers. For example, enter IVC or INVOICE.
 

Note:
Do not include spaces in the static text.
 

Cashier session IDs must be numeric, so don't include any static text in an autonumber
definition with the Cashier Session number type.
 

Sequential
 

a. In the unlabeled field that appears next to the part type, enter the next document number
to use. The number must be 1 or greater. The system increases this number by one each
time a new identifier is generated and saved.

b. In the Maximum Length field, Enter the maximum number of digits for the sequential
number. Select a number from one to ten.

c. Select the Zero Padding check box to add zeros before the generated number to make up
the number of digits in the definition. For example, if the maximum length of this part is 5
digits, and the current number is 15, zero padding formats this part as 00015.

Date
 

In the unlabeled field that appears next to the part type, select the date format.
 

Note:
Don't include dates for Cashier Session autonumbers, which must be numeric only.
 

The available date formats are made of these date codes in various combination:
 

◦ Years: YYYY represents the year with its full four digits, and YY represents the year by its
last two digits.

◦ Month Numbers: MM represents the month as a two-digit number.

◦ Month Abbreviations: MMM represents the month as a three-character abbreviation in
English, such as JAN for January. The values are not translated into the user’s session
language. Formats that include MMM are available only if the agency’s language is
English.

◦ Days: DD represents days as two-digit numbers. This is the only option for days.

◦ Quarters: Q represents quarters. For example, the code for the first quarter of the year is 1.

If you select Fiscal year in the Reset Sequential Number field, all numeric months, years, and
quarters are counted from the beginning of the fiscal year. For example, if the Fiscal Year End
Month is June, then:
 

◦ The MM value for June is 12, for July is 01, and so forth.
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Part Type Related Information

◦ The YYYY value is the calendar year when the fiscal year ends. In the year 2025, January-
June are part of the 2024-2025 fiscal year, so YYYY is 2025 during those months. But
July-December of 2025 are part of the 2025-2026 fiscal year, so YYYY is 2026 during
those months.

◦ The Q value for April through June is 4, for July through September is 1, and so forth.

6. In the rule grid, select a Separator to appear after each part except the last.

Select from the following separators:

◦ (None)

◦ - (hyphen)

◦ / (forward slash)

◦ * (asterisk)

7. Verify the generated number for the selected date format and separators in the Next Number Preview field.
8. Click Save.

An error appears if the overall maximum size of the autonumber doesn’t accommodate the maximum lengths
of all of the parts and separators that you define.

Modifying an Autonumber Rule
1. Select Common Setup > Autonumber.
2. On the Autonumber page, click the row you want to modify.
3. Update the rule header and rule definition fields on the Autonumber Details page.
4. Click Save.

Deleting an Autonumber Rule
Note:  You can’t delete autonumber rules that are already in use.

1. Select Common Setup > Autonumber.
2. Click the row you want to modify.
3. On the Autonumber Details page, click Delete.

Setting Up Code Types  
Code types are specific published codes, guidelines, ordinances, and so forth. Examples might include the International
Building Code, published by the International Code Council (ICC), and the National Fire Code, published by the National
Fire Protection Association (NFPA).

Note:  Code types are not currently used in the public sector application.

You add, modify, and delete code types on the Code Type page.
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Adding a Code Type
1. Select Common Setup > Code Type.
2. On the Code Type page, click Add.
3. On the Code Type Detail page, enter values for the following fields:

Page Element Description

Code Type ID
 

Enter a unique code type ID for a specific code type. For example, enter IFC for International Fire
Code.
 

Name
 

Enter the complete name of the code type.
 

Description
 

Enter a description of the code type.
 

4. Click Save.

Modifying a Code Type
1. Select Common Setup > Code Type.
2. Click a row on the Code Type page.
3. On the Code Type Detail page you can update the code name and description.
4. Click Save.

Deleting Code Types
1. Select Common Setup >  Code Type.
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Code Type

Details page.
3. To delete one or more definitions without viewing details:

a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.

Setting Up Code References  
Code references provide detailed specifications that come from a broad range of codes, guidelines, ordinances, and
so forth. Even if the source document does not use the word “code,” use the Code References pages to enter the
information into the system. A code reference maps to a specific section in the source document.

Note:  The code references described in this topic are not currently used in the public sector application. To set up
code references for code enforcement, see Setting Up Code References for Code Enforcement.
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You add, modify, and delete code references on the Code Reference page.

This example illustrates the Code Reference Details page.

Prerequisites
Before you set up code references, you must define:

• Code types, which represent specific published documents that contain codes, guidelines, and so forth.

See Setting Up Code Types.

• Standard types, which describe the different fields or disciplines that codes relate to. Examples might include
fire safety or electrical systems.

Set up standards types by defining values for the ORA_PSC_CC_STD_CODE_TYPE lookup type. Define these
values on the Lookup Type pages. See Setting Up Lookups.

Adding a Code Reference
1. Select Common Setup > Code Reference.
2. On the Code Reference page, click Add.
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3. On the Code Reference Detail page, enter values for the following fields:

Page Element Description

Standard Type
 

Select the type of standard that the code falls under. Standard types represents fields or
disciplines such as Materials,  Engineering, or Installation.
 

Standard Name
 

Enter the title of the section that contains this code reference. This title comes from the source
document.
 

Code Section
 

Enter the section number for this code reference. The number uniquely identifies this reference
within the source document.
 

Effective Start Date and Effective End
Date
 

Enter the official effective start date of the code reference, and optionally enter an end date.
 

Code Type
 

Select a code type from the values that you defined on the Code Type page. The code type
identifies the source document.
 
See Setting Up Code Types
 

Description
 

Enter a description of the reference.
 

URL
 

Enter a URL link to the source document.
 

Content
 

Enter detailed content copied from the source document.
 

4. Click Save.

Modifying a Code Reference
1. Select Common Setup > Code Reference.
2. Click a row on the Code Reference page.
3. On the Code Reference Detail page, make any necessary changes.
4. Click Save.

Deleting a Code Reference
1. Select Common Setup > Code Reference.
2. Click a row on the Code Reference page.
3. On the Code Reference Detail page, click Delete.

You will be prompted to confirm the permanent deletion.
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Setting Up Project Types  
A project type describes the kind of project that an agency staff can select at the time of creating a project. You add new
project types based on the nature of the project you are adding. Selection of a project type is mandatory while creating
a new project, so, a minimum of one project type is required to be set up.

You add, modify, and delete project types on the Project Type page.

Adding a Project Type
1. Select Common Setup > Project Type.
2. On the Project Type page, click Add.
3. On the Project Type Detail page, enter values for the following fields:

Page Element Description

Project Type
 

Enter the type of project, such as Commercial Project or Residential Project.
 

Rule ID
 

Select a rule ID. Rule ID is an autonumbering sequence that you set up for a particular project
type. When you are creating a project with a certain project type, a project ID is generated
based on the sequence defined for the project type.
 
Rule IDs are created using the Autonumber page. For more information, see Setting Up
Autonumbering.
 

Description
 

Enter a description of the project type.
 

Long Description
 

Enter a detailed description of the project type.
 

Document Group
 

Select a document group to allow your users to organize the various categories of attachment
files into a grouping.
 
See Setting Up Document Categories and Subcategories and Setting Up Document Groups.
 

4. Verify that the Enabled switch is turned on. The switch is turned On by default for a new project type.
5. Click Save.

Modifying a Project Type
1. Select Common Setup  > Project Type
2. Click a row on the Project Type page.
3. On the Project Type Detail page you can:

◦ Update the rule ID, description, and long description.
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◦ Turn off the Enabled switch to deactivate the project type.

4. Click Save.

Deleting a Project Type
1. Select Common Setup  > Project Type
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Project

Type Details page.
3. To delete one or more definitions without viewing details:

a. Click Edit on the Project Type page.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete. You will be prompted to confirm the permanent deletion.

Note:  You can delete a project type only if it is not used by any project. When you attempt to delete a project type
that is used by a project, the Public Sector Cloud Service displays a message that you cannot delete the project type as
it is already in use by a project.

Setting Up Lookups  
This topic describes how to add and change values that appear in lookup lists. Lookup lists are referenced by various
fields in the application that display a static set of values from which the end user can select a value.

Lookup Types and Lookup Values Overview
Lookup types in applications are used to represent a set of codes and their translated meanings. To the end users, a
lookup type displays a list of values from which they select values.

You use the Lookup Types page to access lookup types, and you use the Lookup Type Details page to modify lookup
types, add lookup values, and add lookup types, where authorized.

When working with lookups, you deal with lookup types and lookup values.

Lookup Element Description

Lookup Type
 

A lookup type is a static list of values users view to make entries in the application. The application
references a lookup type to display its list of values.
 

Lookup Value
 

A lookup value is a single item contained within a lookup type. For example, Paid is a lookup value for
the Fee Status lookup type. Lookup types typically contain numerous lookup values.
 

Lookup types are delivered as seed data for your service. You can only modify selected lookup types, such as Business
Type, UOM Type, Standard Code Type, and so on. Most lookup types are read-only.

31



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 4
Setting Up Your Agency

Modifying Lookup Types
Lookup types can be associated with lookup lists on:

• Pages in your offering.

• Predefined field groups added to intake forms.

• User-defined fields added to intake forms.

Note:  Lookup lists created for user-defined fields in an intake form can only be viewed from the Lookup Type page
after the form has been published. Managing lookup lists for user-defined fields should be completed only within the
Intake Form Designer.

This example illustrates the Lookup Type page. Details are in the surrounding text.

To modify a lookup type:

1. Select Common Setup > Lookups.
2. On the Lookup Types page use the Search box to filter the lookup types by keyword.

For example, to view the Business Type lookup type, enter business in the Search box.
3. Click on the row for the lookup type you want to view.
4. View the contents of the Lookup Type Details page.

Page Element Description

Lookup Type
 

Identifies the lookup type within the application.
 

Application
 

Identifies the application that uses the lookup type. For example, Permits, Common
Components, and so on.
 

Meaning
 

The actual UI display name used to represent the list of values contained in the lookup type.
 

Configuration Level Indicates at what level the lookup can be modified. Options are:
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Page Element Description

  

◦ System: Only Oracle development teams can modify lookup types at this configuration
level.

◦ Extension: Customers can perform minimal tasks, such as add lookup values.

◦ User: Customers can add lookup values, delete lookup values, update the meaning, and
update the description.

Module
 

The internal application module using the lookup type, such as Billing Entry, Billing Setup, and
so on.
 

Description
 

Identifies the purpose and use of the lookup type.
 

5. If you need to add lookup values, refer to the following section for steps for that task.
6. Click Cancel to close the lookup type, or click Save if you made any changes.

Adding Lookup Values
This example illustrated the Lookup Value Details page. Details are in the surrounding text.
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You can add lookup values to lookup types with a configuration level set to User or Extension.

To add lookup values:

1. Select Common Setup > Lookups.
2. On the Lookup Types page use the Search box to filter the lookup types by keyword.

For example, to view the Business Type lookup type, enter business in the Search box.
3. Click on the row for the lookup type you want to view.
4. On the Lookup Type Details page, click Add under Lookup Value Type.
5. On the Lookup Value Details page, enter these values:

Page Element Description

Lookup Code
 

An internal application code for each lookup value that is not visible to users. It is typically a
shorter, less user-friendly representation of the item. For example, ORA_DRIVER_LIC for State
Driver’s License, or LEN for Length, if listing units of measurement.
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Page Element Description

Note:
Lookup lists created in the designer for user-defined fields on an intake form begin with PSC.
 

Display Sequence
 

Control in what sequence the lookup value appears in the list displayed to users, where 2
appears above 3. If you do not specify a sequence, the application displays the items in the
order they were entered.
 

Enabled
 

Turn on to make a lookup value active. If a lookup value is not enabled, then the application
does not display it to the end user in the list of values for that lookup type.
 

Note:
It is not recommended to disable lookup values once your implementation is in production
because this can invalidate existing transaction data.
 

Start Date
 

Set a start date for the lookup value to become active. Even if the lookup value is enabled, if a
start date is set, the application does not display the lookup value until the start date is reached.
 

End Date
 

Set an end date for a lookup value to no longer be displayed in a list of values.
 

Meaning
 

The display name for the lookup value. End users see this value in the list of values displayed at
run time. They do not see the Lookup Code value.
 

Description
 

Provide any additional information to help identify the purpose of the lookup value or
clarification regarding what it represents.
 

Tag
 

Tags allow you to add a label to your lookup codes. A tag can be used to categorize lookups
based on facilitating searches or guiding how a lookup should be used.
 

6. Click Save.

Working with Configuration Levels
The configuration level attribute determines who can modify a lookup type and what can be modified. The
configuration levels are:

• System: Only Oracle development teams can modify lookup types at this configuration level.

• Extension: Customers can perform minimal tasks, such as add lookup values.

• User: Customers can add lookup values, delete lookup values, update the meaning, and update the description.
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Task User Extension System

Add a lookup type
 

Yes
 

No
 

No
 

Delete a lookup type
 

Yes
 

No
 

No
 

Modify lookup type meaning
 

Yes
 

No
 

No
 

Modify lookup type description
 

Yes
 

No
 

No
 

Add lookup values
 

Yes
 

Yes
 

No
 

Delete lookup values
 

Yes (if you created it)
 

Yes (if you created it)
 

No
 

Modify lookup value attributes
 

Yes (except for Lookup Code)
 

Yes (if you created it, and except for
Lookup Code)
 

No
 

Note:  You can add values to lists defined in the designer for user-defined fields. Values entered through the Lookup
Type page become available at runtime as soon as they are saved. Values added to lookup lists through the Intake
Form Designer display at runtime only after the intake form is published.

Adding Lookup Types
To add a lookup type:

1. Select Common Setup > Lookups.
2. On the Lookup Types page click Add for the Lookup Type grid.
3. On the Lookup Type Details page, enter these values:

◦ Lookup Type (The value you enter must be uppercase and can’t begin with the prefix ORA_, which is used
to distinguish your custom lookup types from delivered lookup types.)

◦ Meaning

◦ Module

◦ Description

4. Click Add for the Lookup Value grid for each lookup value you need to add to the lookup type.
5. Click Save.

Setting Up Units of Measure  
Units of measure are used to express measurements such as quantity or duration. Each unit of measure must have a
unit type such as Length, Area, or Time.

You add, modify, and delete units of measure on the Unit of Measure page.
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Adding a Unit of Measure
1. Select Common Setup > UOM.
2. On the Unit of Measure page, click Add.
3. On the Unit of Measure Details page, enter values for the following fields:

Page Element Description

Unit of Measure
 

Enter a unique unit of measure ID.
 

Description
 

Enter a description of the unit of measure.
 

Unit Type
 

Select the type of measurement. The delivered unit types are Area, Length, Time, and Volume.
 
You can define additional values on the Lookup Type Details page. Add new values to the ORA_
PSC_CC_UOM_TYPE lookup type.
 

ISO Code
 

Enter the ISO unit of measure code.
 

4. Click Save.

Modifying a Unit of Measure
1. Select Common Setup > UOM.
2. Click a row on the Unit of Measure page.
3. On the Unit of Measure Details page, make the necessary modifications.
4. Click Save.

Deleting Units of Measure
1. Select Common Setup > UOM.
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Unit of

Measure Details page.
3. To delete one or more definitions without viewing details:

a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.
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Setting Up Unit of Measure Conversions  
A unit of measure (UOM) conversion definition specifies the factor for converting a unit of measure to an equivalent
amount of a different unit of measure.

You add, modify, and delete unit of measure conversions on the UOM Conversion page.

Adding a UOM Conversion
1. Select Common Setup > UOM Conversion.
2. On the UOM Conversion page, click Add.
3. On the UOM Conversion Detail page, enter values for the following fields:

Page Element Description

UOM
 

Select the unit of measure that is the starting unit for the conversion.
 

UOM To
 

Enter the target unit of measure. This unit of measure must be the same type as the original
unit of measure. For example, you can convert a unit of length to another unit of length, but
you can’t convert a unit of length to a unit of weight.
 

Conversion Rate
 

Enter the conversion factor used to convert the original unit of measure to the target unit of
measure. For example, to convert minutes to hours, enter a conversion rate of 60.
 

4. Verify that the Enabled switch is turned on.

The switch is on by default for a new UOM conversion.
5. Click Save.

Modifying a UOM Conversion
1. Select Common Setup > UOM Conversion.
2. Click a row on the UOM Conversion page.
3. On the UOM Conversion Detail page you can:

◦ Update the UOM conversion field values.

◦ Disable the UOM conversion by turning the Enabled switch off.

4. Click Save.

Deleting UOM Conversions
1. Select Common Setup > UOM Conversion.
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Unit of

Measure Conversion Details page.
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3. To delete one or more definitions without viewing details:
a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.

Setting Up Data Format Exchange Maps  
The Data Format Exchange utility is a data-mapping utility that enables you to map fields between source and target
locations.

Note:  This utility is useful in situations where data must be exported from or imported to Oracle Permitting and
Licensing. Currently, this utility is only used by the Export Journals to ERP process.

Business analysts create and modify Data Format Exchange maps on the Data Format Exchange page.

Adding a Data Format Exchange Map
1. Select Common Setup > Data Format Exchange.
2. On the Data Format Exchange page, click Add.
3. For the Definition step, enter values for the following fields:

Page Element Description

Mapping Name and Description
 

Enter a name and description for the data mapping.
 

Source Type
 

Select the type of source format to be included in the data mapping.
 

Note:
Currently, VO is the only valid value for this field.
 

Target Type
 

Select the type of target format to be included in the data mapping.
 

Note:
Currently, CSV is the only valid value for this field.
 

Enabled
 

Turn this switch on to make the data mapping available to select in the Mapping Name field
on the Export Journals to ERP page. For more information on exporting journals, see Exporting
Journal Entries.
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4. Click Next.
5. For the Source step, enter values for the following fields:

Page Element Description

Source Name
 

Selects the source view to be included in the data mapping, such as Journals to Export.
 

6. Click Next.
7. For the Target step, click Upload to select a file that will be updated with the results of the field mapping.
8. Click Next.
9. For the Mapping step, enter values for the following fields:

Page Element Description

Target Field
 

Displays each field in the target format.
 

Source Field
 

Select the source field that you want to map to each target field.
 

Transform
 

Select an option to modify the value for the target field.
 

Note:
Currently, Constant is the only valid value for this field.
 

Transform Parameter
 

Specify the parameter used to determine the value for the target field. For example, if the target
field is Effective Date and the Transform value is Constant, the Transform Parameter might be
01/01/2018.
 

10. Click Submit to save the Data Format Exchange map.

Note:  At any point during the process, you can click Previous to go back one step. You can also click Cancel
to exit the data mapping setup process and discard your changes.

Modifying a Data Format Exchange Map
1. Select Common Setup > Data Format Exchange.
2. Select a mapping on the Data Format Exchange page.
3. For the Definition step, you can enable or disable the data mapping.
4. Click Next.
5. You can’t update any fields in the Source step.
6. Click Next.
7. For the Target step, you can click the file link to download a copy of the file.
8. Click Next.
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9. For the Mapping step, you can update the values of the Source Field, Transform, and Transform Parameter
fields.

10. Click Submit to save your changes to the Data Format Exchange map.

Note:  At any point during the process, you can click Previous to go back one step. You can also click Cancel
to exit the data mapping update process and discard your changes.
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5  Setting Up Agency Schedules

Setting Up Holiday Calendars  
Holiday calendars establish the days that agency offices are closed and no field service operations are offered.

These days appear as unavailable, non-working days in calendar views throughout the system such as for public user
and inspector calendars. Non-working days in holiday calendars apply to all employees and do not need to be defined
for employee profiles.

Each holiday calendar spans a date range that you define. Within that date range, you define individual events for each
non-working holiday.

Administrators add, modify, and delete holiday schedules and events on the Holiday Calendar page.

Adding a Holiday Calendar
1. Select Common Setup > Holiday Calendar.
2. On the Holiday Calendar page, click Add.
3. On the Holiday Calendar Details page, enter values for the following fields:

Page Element Description

Calendar ID and Description
 

Enter a unique ID and description for the calendar. For example, you might enter an ID of 2019
and a description of Holiday Calendar 2019.
 

Valid from Date and Valid to Date
 

Enter the date range for the holiday calendar. For example, you might enter a Valid from Date
of 2019–01–01 and a Valid to Date of 2019–12–31 to represent a calendar that spans the entire
2019 calendar year.
 

4. Add an event.
Note:  You must have values defined for all required holiday calendar fields before you can add an event.

5. Click Save.
Note:  When you click Save, the Holiday Calendar page closes.

Adding an Event
1. Select Common Setup > Holiday Calendar.
2. Click a row on the Holiday Calendar page.
3. On the Holiday Schedule Details page, click Add.
4. On the Event Details page, enter an Event ID, an Event Date, and a Description for the event. For example, you

might enter an ID of MD, a date of May 29, 2017, and a description of Memorial Day.
5. Click Save.

43



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 5
Setting Up Agency Schedules

Modifying a Holiday Calendar
1. Select Common Setup > Holiday Calendar.
2. Click a row on the Holiday Calendar page.
3. On the Holiday Calendar Details page you can:

◦ Update the holiday schedule field values.
Note:  You cannot edit the Calendar ID.

◦ Delete the holiday calendar. You will be prompted to confirm the permanent deletion.

◦ Add, modify, or delete events.

4. Click Save.
Note:  When you click Save, the Holiday Calendar page closes.

Modifying an Event
1. Click a row on the Holiday Calendar Details page.
2. On the Event Details page you can:

◦ Update the event date or description.

◦ Delete the event. You will be prompted to confirm the permanent deletion.

3. Click Save.

Deleting Holiday Calendars
1. Select Common Setup > Holiday Calendar.
2. Click Edit.
3. Select the check boxes next to all the holiday schedules you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Deleting Events
1. Click Edit on the Holiday Calendar Details page.
2. Select the check boxes next to all the events you want to delete.
3. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Work Schedules  
Work schedules establish the days of the week and daily hours of operation for agency employees.

Create schedules based on the type of employee and work location. Calendar views, such as inspector calendars,
reference work schedules to determine the time slots that are displayed on the calendar as available for scheduling.
Algorithms for assigning resources also use work schedules to determine availability. You assign work schedules to
employee profiles using the Agency Staff page. See Setting Up Agency Staff.

Administrators and business analysts add, modify, and delete work schedules on the Work Schedule page.
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Adding a Work Schedule
1. Select Common > Work Schedule.
2. On the Work Schedule page, click Add.
3. On the Work Schedule Details page, enter values for the following fields:

Page Element Description

Schedule ID and Description
 

Enter a unique ID and description for the schedule. For example, you might enter an ID of
OFFICESAT and a description of Saturday Office Schedule.
 

Start Date
 

Enter the first day of the schedule.
 

End Date
 

Enter the last date of the schedule. You can leave this field blank to give the schedule an open
end date.
 

Work Start Time and Work End Time
 

Enter the start and end time for the schedule. For example, you might enter a work start time of
09:00 AM and a work end time of 05:00 PM.
 

Break Start Time and Break End Time
 

Enter the start and end time for a break within the schedule. For example, you might enter a
break start time of 12:00 PM and a break end time of 01:00 PM.
 

Note:
These fields are optional, but if you enter a break start time, you must also enter a break end
time.
 

Recurrence and Weeks Between
Occurrences
 

Select whether the schedule reoccurs weekly and how many weeks are between each
occurrence. For example, if you select a recurrence of Weekly with 1 week between occurrences,
 the schedule repeats every week.
 

Work Days
 

Select the days of the weeks to which the schedule applies.
 

4. Click Save.

Note:  For overnight work shifts that go past 12 am (midnight), you must create two schedules: one for the time period
up until midnight, and one for the time period after midnight. For example, to create a weekday overnight shift that
starts at 09:00 pm and ends at 06:00 am the following day, the first schedule would have a start time of 09:00 pm
and an end time of 12:00 am on Monday through Friday. The second schedule would have a start time of 12:00 am
and an end time of 06:00 am on Tuesday through Saturday.
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Modifying a Work Schedule
1. Select Common > Work Schedule.
2. Click a row on the Work Schedule page.
3. On the Work Schedule Details page you can:

◦ Update the work schedule field values.

Note:  You cannot edit the Schedule ID field.

◦ Delete the schedule. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Work Schedules
1. Select Common > Work Schedule.
2. Click Edit.
3. Select the check boxes next to all the work schedules you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.
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6  Setting Up Your Agency Staff

Setting Up a Fusion Business Unit and Legal Entity  
This topic discusses the one-time setup for Oracle Permitting and Licensing administrators who are not using Fusion
Human Capital Management (HCM), Enterprise Resource Planning (ERP), and Sales Cloud.

If you have implemented both Fusion Financials and Oracle Permitting and Licensing offerings, then you must ensure
that you migrate Financials Business Unit related tasks before any Licensing and Permitting migrations. Migrate any
changes you have made to the business unit configurations in the Financials offering before the Public Sector offering
or the implementation projects are migrated from a non-production environment to your production environment.

The following setup steps are prerequisites for creating an agency staff in the system.

Note:  For Fusion HCM, ERP, and Sales Cloud customers, these steps are not required as the business unit and legal
entity are already set up.

Configure the following tasks in the order mentioned here:

1. Set up reference data sets (to create a Set ID)
2. Create a business unit
3. Create a legal address
4. Create a Legislative Data Group
5. Create a Legal Entity
6. Register a Legal Entity
7. Create Legal Entity HCM Information

Setting up Reference Data Sets
1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:

Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On the right panel locate the Manage Reference Data Sets task and click the row to open the Manage Reference
Data Sets page.

3. On the Manage Reference Data Sets page, click the New button and include values for the fields:

Page Element Description

Set Code
 

Enter a code value that represents your agency.
 

Set Name
 

Enter a name that represents your agency.
 

Description
 

Enter a description about your agency.
 

4. Click Save and Close to save the newly created SetID.
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Creating a Business Unit
1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:

Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On the right panel locate the Manage Business Units task and click the row to open the Manage Business Units
page.

3. On the Manage Business Unit page, click the New button and include values for the fields:

Page Element Description

Name
 

Enter a name for the business unit.
 

Default Set
 

Select the SetID you created in the previous section
 

4. Click Save and Close to save the newly created business unit.

Creating a Legal Address
1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:

Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On the right panel, locate the Manage Legal Addresses task and click the row to open the Manage Legal
Addresses page.

3. On the Manage Legal Addresses page, click the New button and enter the agency address in the Agency Line 1
field. The other fields are optional.

4. Click OK to return to the Manage Legal Addresses page and click Save and Close to save the newly created
address.

Creating a Legislative Data Group
1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:

Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On the right panel, select the task named Manage Legislative Data Group and click Select to open the Manage
Legislative Data Groups page.

3. On the Manage Legislative Data Groups page, click Create to enter the new legislative data group details.
4. Enter your legislative data group name in the Name field. Search and select your country from the Country

field.
5. Click Submit to save and return to the Manage Legislative Data Group page.
6. Click Done.

Creating a Legal Entity
1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:

Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On the right panel, locate the task named Manage Legal Entity and click to open the Select Scope page.
3. On the Select Scope page select the Manage Legal Entity task radio button.
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4. Click the Legal Entity drop-down and select Create New. Click Apply and Go to Task button to open the
manage Legal Entities page.

5. On the Manage Legal Entities page, click the New button to open the Create Legal Entity page and enter values
for the fields:

Page Element Description

Country
 

Select the country (United States is the default selection).
 

Name
 

Enter the name of your agency.
 

Legal Entity Identifier
 

Enter a code for your agency.
 

Payroll Statutory Unit
 

Select the check box.
 

Legal Employer
 

Select the check box.
 

Legal Address
 

Select the legal address (created in the previous section) using the Search and Select page.
 

EIN or TIN
 

Enter your agency’s EIN or TIN value. You can enter a value of your choice if you do not have
EIN or TIN for your agency.
 

Note:
If you are using Fusion HCM or Fusion ERP, the value you enter here must be legitimate. It is
recommended that you refer to Fusion documentation to know about the required value for
entry in the field.
 

Legal Reporting Unit Registration
Number
 

Enter your agency’s legal reporting unit registration number. You can enter a value of your
choice if you do not have a registered number for your agency.
 

Note:
If you are using Fusion HCM or Fusion ERP, the value you enter here must be legitimate. It is
recommended that you refer to Fusion documentation to know about the required value for
entry in the field.
 

6. Click Save and Close to save the newly created legal entity.
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Registering a Legal Entity
1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:

Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On the right panel, select the task named Manage Legal Entity Registration and click Select to open the Select
Scope page.

3. On the Select Scope page select the Manage Legal Entity Registrations task radio button.
4. Click the Legal Entity drop-down and choose Select and Add. Select Click Apply and Go to Task button to open

the Manage Legal Entities page.
5. On the Manage Legal Entities page expand the Search section and enter the legal entity name you created in

the previous section. Click Search.
6. Select the row from the search results and click Save and Close, to save the entity and open the Manage

Registrations page.
7. View your values on the new Manage Registrations page and click Done to confirm and complete the

registration process.

Creating Legal Entity HCM Information
1. Select the Setup and Maintenance tile on the Agency Springboard. On the Setup page, select the offering:

Public Sector Permits, Public Sector Planning and Zoning, Public Sector Code Enforcement, or Public Sector
Business Licenses. Then select the Agency Staff functional area.

2. On the right panel, select the task named Manage Legal Entity HCM Information and click Select to open the
Select Scope page.

3. On the Select Scope page select the Manage Legal Entity HCM Information task radio button.
4. Click the Legal Entity drop-down and choose Select and Add. Click Apply and Go to Task button to open the

Manage Legal Entities page.
5. On the Manage Legal Entities page expand the Search section and enter the legislative data group you created

in the previous section. Click Search.
6. Select the row from the search results and click Save and Close, to save the entity and open the Legal Entity

page.
7. On the Legal Entity page, click Edit and then click Update to open the Update Legal Entity page to enter an

action reason.
8. On the Update Legal Entity page, select Action Reason drop-down button and select the option Reorganization.

Click OK to save and return to the Legal Entity page.
9. On the Legal Entity page, select the Payroll Statutory tab to associate the data group to the HCM legal entity.

10. Under the Payroll Statutory Information section select the Associated Legislative Data Group drop-down.
Search and select the legislative data group you created using the previous section.

11. Click OK to return to the Edit Legal Entity page. Click Submit and then click Done to complete the creation of a
Legal Entity HCM Information.

For information on creating an employee record, refer to the documentation Managing Agency Staff Profiles.

Defining Job Titles  
This topic discusses how to define job titles for agency staff.
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Defining Job Titles
Administrators define new job titles using the Job Titles page:

1. Select Agency Staff  > Job Title.
2. The Job Title page lists all the job titles defined.
3. Click Details for a row to open the Job Title Detail page and view and edit the details of the job title.
4. Click Add to open the Job Title Detail page and define a new job title.
5. Enter various details and click Save to save the new job title and return to the Job Title page.

Setting Up Agency Staff  
This topic provides an overview of job functions along with a list of delivered job functions. It also discusses how to set
up Fusion business units and legal entities for Oracle Permitting and Licensing services.

Job Function Overview
Job functions are assignments made to staff members using the Agency Staff page. Job functions help you in assigning
job specific attributes to an agency staff member. For example, you can assign the job function of a building inspector
to an agency staff member and associate attributes such as Inspection District and Work Schedule.

For more information about setting up the various job attributes, such as permit, inspection, or issue types, see the
Implementing Permitting and Licensing guide.

Job Function and ID Attribute and Usage

Building Inspector
 
ORA_BUILDING_INSPECTOR
 

• Work Schedule — Inspections: Determine inspector availability for assignment to inspections. A
building inspector can have more than one work schedule.

• Inspection Districts — Inspections: Determine the districts for which an inspector can be
assigned to inspections.

Note:
You can leave the value of the inspection district job attribute blank to enable a building inspector to
be assigned to inspections from all districts.
 

• Inspection Types — Inspections: Determine if the inspector can be assigned to a given type of
inspection.

Note:
You can leave the value of the inspection type job attribute blank to enable a building inspector to be
assigned to all inspection types.
 

• Permit Types — Inspections: Permit types are not used for inspector assignment.

Business Analyst
 
ORA_BUSINESS_ANALYST
 
(Applicable in future releases)

• Inspection Districts

• Inspection Types

• Permit Types
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Job Function and ID Attribute and Usage

 (Applicable in future releases)
 

Business License Manager
 
ORA_BL_MANAGER
 

Note:
No job attributes are currently required for this job function. Business license managers have access
to all consultations and licenses.
 

Business License Specialist
 
ORA_BL_SPECIALIST
 

• Business License Application Types — Determine the license and consultation types that this
specialist can be assigned to.

• Consultation Meeting Schedule — Determine the availability of the specialist for scheduling
business consultation meetings.

Note:
You can assign only one schedule.
 

Cashier
 
ORA_CASHIER
 

• Permit Types (Applicable in future releases)

• Cashier ID — Cashiering: Determine Cashier ID of the Cashier

Note:
You can assign only one schedule.
 

Chief Building Officer
 
ORA_CHIEF_BUILDING_OFFICER
 
(Applicable in future releases)
 

• Inspection Districts

• Inspection Types

• Permit Types

(Applicable in future releases)
 

Code Enforcement Officer
 
ORA_CODE_ENFORCEMENT_OFFICER
 

• Code Enforcement Districts The possible values are districts from code enforcement district
types. Only users who are associated with a code enforcement district can be autoassigned to
issues in that district.

• Code Enforcement District Types — Used at the time of scheduling inspections.

Note:
To give a user responsibility for all district types, create a District Type attribute row, but leave
the attribute value blank. If you assign a district type attribute value to a user, it provides him with
access to all districts within that district type.
 
Warning: If you enable the agency-level option for autoassignment of incidents and cases, but do
not set up any district or district type attributes, the incidents and cases will never be routed to the
user.
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• Code Enforcement Inspection Work Schedule

Note:
You can assign only one schedule.
 

Code Enforcement Supervisor
 
ORA_CODE_ENFORCEMENT_
SUPERVISOR
 

• Issue Type — The possible values are the issue types that you create. A user who is associated
with an issue type is responsible for all related subtypes, so don’t assign users to both an issue
type and a subtype that belongs to that issue type.

• Issue Subtype — The possible values are the issue subtypes that you create. Only assign a user
to a subtype when the user is not responsible for all of the subtypes that belong to the related
issue type.

These attribute values establish which issue types and subtypes the person is responsible for. This
information is used when routing or assigning incidents and cases.
 

Note:
To give a user responsibility for all types of issues, create an Issue Type attribute row, but leave the
attribute value blank. If you assign an issue type attribute value to a user, it provides him with access
to all issue subtypes within that issue type.
 
Warning: If you don’t set up any issue type or subtype attributes, and you activate the system-level
setting for automatically routing incidents, incidents will never be routed to the user.
 

Code Enforcement Technician
 
ORA_CODE_ENFORCEMENT_TECHNICIAN
 

• Issue Type — The possible values are the issue types that you create. A user who is associated
with an issue type is responsible for all related subtypes, so don’t assign users to both an issue
type and a subtype that belongs to that issue type.

• Issue Subtype — The possible values are the issue subtypes that you create. Only assign a user
to a subtype when the user is not responsible for all of the subtypes that belong to the related
issue type.

These attribute values establish which issue types and subtypes the person is responsible for. This
information is used when routing or assigning incidents and cases.
 

Note:
To give a user responsibility for all types of issues, create an Issue Type attribute row, but leave the
attribute value blank. If you assign an issue type attribute value to a user, it provides him with access
to all issue subtypes within that issue type.
 
Warning: If you don’t set up any issue type or subtype attributes, and you activate the system-level
setting for automatically routing incidents, incidents will never be routed to the user.
 

Economic Development Officer
 
ORA_ECONOMIC_DEVELOPMENT_
OFFICER
 
(Applicable in future releases)
 

Permit Types
 
(Applicable in future releases)
 

Finance Administrator
 
ORA_FINANCE_ADMINISTRATOR
 

• Inspection Districts

• Inspection Types

• Permit Types
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(Applicable in future releases)
 

(Applicable in future releases)
 

Inspector Supervisor
 
ORA_INSPECTOR_SUPERVISOR
 

• Work Schedule — Inspections: Work schedules are not used for inspector supervisors.

• Inspection Districts — Inspections: Determine the districts for which a supervisor can view or
schedule inspections.

You can leave the value of the inspection district job attribute blank to enable an inspector
supervisor to view or schedule inspections for all districts.

• Inspection Types — Inspections: Determine the inspection types that can be viewed or
scheduled by this inspector supervisor.

You can leave the value of the inspection type job attribute blank to enable an inspector
supervisor to view or schedule inspections for all inspection types.

• Permit Types — Inspections: Permit types are not used for inspector supervisor assignment.

Permit Technician
 
ORA_PERMIT_TECHNICIAN
 
(Applicable in future releases)
 

• Inspection Districts

• Inspection Types

• Permit Types

(Applicable in future releases)
 

Plan Coordinator
 
ORA_PLAN_COORDINATOR
 

• Permit Types — Determine the permit types of the plan reviews that this plan coordinator can
view in the Plan Review Console.

Note:
You can leave the value of this job attribute blank to enable a plan coordinator to view plan reviews
for all permit types.
 

• Plan Reviewer Department — Determine the plan reviewer departments of the plan reviews
that this plan coordinator can view in the Plan Review Console on the All Reviews and Unassigned
Reviews pages.

• Planning Application Types — Determine the planning application types of the plan reviews that
this plan coordinator can view in the Plan Review Console.

Note:
You can leave the value of this job attribute blank to enable a plan coordinator to view plan reviews
for all planning application types.
 

Plan Reviewer
 
ORA_PLAN_REVIEWER
 

• Permit Types — Determine the permit types that this plan reviewer can be assigned to.

Note:
You can leave the value of this job attribute blank to enable a plan reviewer to be assigned to all
permit types.
 

• Plan Reviewer Department — Determine the plan reviewer department that this plan reviewer
belongs to. The Add Reviewers modal page displays a list of available reviewers by plan reviewer
department when assigning a plan reviewer to a plan review.
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• Planning Application Types — Determine the application types that this plan reviewer can be
assigned to.

Note:
You can leave the value of this attribute blank to enable a plan reviewer to be assigned to all
planning applications types.
 

• Plan Review Districts — Determine the plan review districts for which a reviewer is available on
the Add Reviewers modal page when assigning reviewers to a plan review.

Note:
You can leave the value of this attribute blank to make a plan reviewer available for all plan review
districts.
 

Planner
 
ORA_PLANNER
 

• Planning Application Types — Determine the application types that this Planner can be
assigned to.

• Pre-application Meeting Schedule  — Determine the availability of the planner for scheduling
pre-application and planning meetings.

Note:
You can assign only one schedule.
 

Principal Planner
 
ORA_PRINCIPAL_PLANNER
 

• Permit Types — Determine the permit types of the plan reviews that this principal planner can
view in the Plan Review Console.

Note:
You can leave the value of this job attribute blank to enable a principal planner to view plan reviews
for all permit types.
 

• Plan Reviewer Department — Determine the plan reviewer departments of the plan reviews that
this principal planner can view in the Plan Review Console.

• Planning Application Types — Determine the planning application types of the plan reviews that
this principal planner can view in the Plan Review Console.

Note:
You can leave the value of this job attribute blank to enable a principal planner to view plan reviews
for all planning application types.
 

Setting Up Fusion HCM Business Units and Legal Entities for Public Sector
Compliance and Regulation Services
If you are an existing Fusion customer and if you have already set up business units and legal entity, then you can
assign the same for your Agency Staff. However, if you are a new Oracle Permitting and Licensing-only customer then
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as a prerequisite for entering Agency Staff data, you need to create one business unit and one legal entity that can be
used for your agency staff.

See Setting Up a Fusion Business Unit and Legal Entity.

Configuring Agency Job Groups  
This topic provides an overview of the Agency Staff Group Configuration and discuss the procedure to configure agency
job groups.

You can use the Agency Staff Groups for identifying a common set of Job attributes that can be applied to a group of
Employees.

Groups provide the flexibility to assign attributes at various levels. You can define a group for a given department,
division, or for specific districts based on the commonalities of the job attributes.

Examples of Groups are:

1. Inspectors working in District A
2. Permit Technicians responsible for Fence Permits

You can configure a group with default Job Functions and their attribute values for your users.

Users entering their employee profile information can select a group job function, which results in loading default job
functions and their attribute values automatically populated.

Note:  Users cannot edit the job function attribute values on the Agency Staff page when using the Job Group
function.

Configuring Agency Job Groups
Administrators set up and configure the agency staff group on the Job Group page. Agency users can select a group on
the Agency Staff Profile page, and a default set of job functions and attribute values are assigned to the employee. To
set up the job functions and attributes for a group:

1. Select Agency Staff  >  Job Group.
2. On the Job Group page, click Add to add a new group or Edit to change the group attributes. Click Add.
3. Enter the details of the job group on the Job Group Details page.
4. Verify that the Enabled switch is turned on if you want to enable this group when you save. This switch is

turned on by default for a new group.
5. Under the Job Function section, click Add to select job functions and include their attributes.
6. Click Save to return to the Job Group page.

Note:  Agency users select the group from a list on the Agency Staff page. The job functions and their corresponding
attributes cannot be changed by users.
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Managing Agency Staff Profiles  
Agency administrators create and manage profiles for their agency staff.

Managing Agency Staff Profile
Administrators set up the agency staff profile on the Agency Staff page.

If you have implemented Fusion Human Capital Management (HCM), you must search and select an existing staff
member using their worker ID. If the HCM implementation is disabled, you have the option of creating a new entry for
the staff member by entering the details, or by selecting the staff record from existing workers.

To create an agency staff profile:

1. Select Agency Staff.
2. On the Agency Staff page, click Add to add a new agency staff member – employee.
3. On the Agency Staff Profile page, you add values to the various fields. For the Business Unit and the Legal

Entity, see the documentation Setting Up a Fusion Business Unit and Legal Entity .

Page Element Description

Select Existing Worker
 

Turn on the switch to allow the search and selection of an existing Fusion employee. The
following fields are display only, populating details from Fusion information:
 

◦ Person ID

◦ Person Number

◦ Hire Date

◦ Business Unit

◦ Legal Entity

◦ Generated User Account

◦ Send Credential Email

◦ User Name

If you want to create a new staff profile, enter information in the fields provided.
 

Note:
If your agency has HCM implementation, this switch is turned on by default and is
unavailable for edit. You must select an existing staff member using the Worker ID field.
 
For the selected staff member, you can’t make changes to the name, person number, person
type, user name, email, hire date, and manager fields.
 

Worker ID
 

Enter an ID or click the prompt to open the Look Up page and search for the Fusion employees.
You can sort the search results by any of these:
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Page Element Description

 

◦ Worker ID

◦ First Name

◦ Last Name

◦ Email

◦ Hire Date

◦ Work Phone Number

◦ Business Unit Name

◦ Legal Entity

◦ Manager

◦ Person Number

◦ User Name

Select an employee row from the search result on the Look Up page and the details are
populated on the Agency Staff page.
 

Person Type
 

Shows the type of person, such as Employee.
 

Enabled
 

Set a status for the staff member from the options:
 

◦ Active

◦ Inactive

Note:
You set the status to Inactive when the employee is inactivated in your HR system. If you are
a Fusion HCM/ERP/Sales Cloud customer then the inactivation of Employees in HCM will
not automatically inactivate the Employee data in Public Sector Cloud. You must manually
update this field.
 
Also, turning off the switch on this page will not inactivate the user ID. You need to use your
security console to inactivate the User ID. If Oracle Identity Cloud Service (IDCS) is your
identity provider (IdP), you must inactivate the user ID using your IDCS console.
 

Is a Supervisor
 

Turn on the switch if the employee is a supervisor.
 

Job Group
 

Select a group to assign a job group section with the relevant job functions. Accordingly, the
system populates the Job Group Assignments section.
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Note:
You cannot make any changes to the values in the job group assignments on this page. To
update the values, navigate to the Job Group page.
 

4. Click Save to save the agency staff profile and return to the Agency Staff page.

Job Function Assignment without using Agency Job Groups
You can assign job functions to employees directly, without having to use Job Groups.

1. On the Agency Staff page search and select the employee that you want to add job functions to.
2. Under the Job Function section, click Add to select job functions and include their attributes.
3. Click Save and return to the Agency Staff page to view the job function assignments.

To include job functions using Agency Job Groups, see the documentation Configuring Agency Job Groups.

Assigning Agency Security Access
Administrators assign roles to various staff members. The security roles assigned to an employee determine the
navigations and data that the user can access.

1. Select Agency Staff and then select Agency Staff Access. The Agency Staff Access page lists all the agency staff
members.

2. You can click the chevron for a row to view the employee access details. This page lists all the security roles
assigned to the employee user. You can add new security roles to the employee on this page.

3. Click the Add New Role button to open the Role Detail page and assign a role for the user.
4. Click Save to save your changes and return to the Agency Staff Access page.
5. Click Save to save the changes you made to the Agency Role details of the staff member.
6. You can add or delete the security roles assigned to the user on this page.

Note:  All Agency users must be assigned the PSC Agency Staff role. Additionally job specific roles can be assigned
to the user. For the complete list of security roles, you can refer to the Security Reference Manual. Also refer to Using
the Security Console.

Note:  For users requiring access to Permits, in addition to the PSC Agency Staff and job specific roles such
as PSC Permit Technician, PSC Plan Reviewer and others, you must assign the following roles to the users:
CUSTOM_MANAGE_PERMITS, CUSTOM_MANAGE_PERMITS, and CUSTOM_PSC_MANAGE_PERMITS_AGENCY.

Managing Mobile Application Activation  
As agency administrators, you must enable access to your field officers for using the inspection application on their
mobile devices.
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You use the Agency Mobile Setup page to select the field officers and send them the email containing the activation
link. Only the agency staff with the job function of code enforcement officer or building inspector are entitled to install
and use the mobile application. Code officers and building inspectors receiving the email must install and configure the
mobile application on their mobile devices. For more information, see Installing and Configuring Oracle Municipal Code
Officer and Installing and Configuring Oracle Inspector.

Mobile Application Activation
To send the mobile application activation link:

1. Select Agency Staff > Mobile Application Activation.
2. The Agency Mobile Setup page lists all the agency staff that are either building inspectors or code enforcement

officers.

The job function assignments are set up on the Agency Staff page. See Setting Up Agency Staff.
3. Select the staff member you want to send the email notification and click the Send  button on the row.
4. Click OK to confirm that the email containing the mobile activation link will be sent to the selected agency staff.

The activation link is for one-time use only.

The notification status for the row changes to Request sent, and the Resend button appears in the Send Mobile
Setup Notification column.

Note:  You can select multiple staff members to the email notification at once. Click the Edit icon on the Agency
Mobile Setup page and use the check boxes to select your recipients. Select the Send Mobile Setup Notification
button to send the email to all the selected field officers.

Importing Agency Staff Data  
This topic explains how to prepare and import agency staff resource data from an external data source into Public
Sector Agency Staff tables using the File-Based Data Import feature.

Agencies with Fusion HCM implementation: File-based data import can be used if your agency has implemented Fusion
HCM. You either enter employee details manually into the Public Sector Agency Staff tables using the Public Sector user
interface (Agency Staff page) or run the schedule import process to copy the employee data.

Agencies without Fusion HCM implementation: If your agency has not implemented Fusion HCM and you are using a
third-party application to maintain employee information, you can use the import process to copy data from the third
party tables into the Public Sector Agency Staff tables.

In addition to the removal or inclusion of employee records, data changes can include changes to the details of an
employee, such as the address, email, role, or designation.

Scheduling the Employee Data Import and Export Process
Administrators can set up a schedule to process a batch file that imports employee data from a .CSV file into the Public
Sector Agency Staff tables. The imported data file, which is usually generated from a third-party application, can be
used to set up and periodically update user details within Public Sector Agency Staff.
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Using the Predefined Template to Import Data using File-Based Data
Import
Public Sector Compliance and Regulation provides a template to help you import data using the File-Based Data Import
tool. The Import template is a spreadsheet that includes the commonly used fields, in addition to the required, along
with instructions to use them.

You can download the template by clicking this link: Agency Staff Import Template spreadsheet file.

Importing Employee Data
1. Access the File Import and Export page from the Fusion application by clicking Navigator > File > Import and

Export.
2. On the File Import and Export page, in the Search Results section, click the Add button to upload the template

zip file to the Universal Content Management (UCM).
3. On the Upload File modal page, click Browse and select the file for upload. Use the Account field to select the

account for the file you are uploading.
4. Click Save and Close. You will see the file listing on the File Import and Export page with the details of the

upload.

Scheduling the Import Export process using File-Based Data Import
1. Access the Scheduled Processes page from the Fusion application Navigator > Tools > Scheduled Processes.
2. On the Scheduled Process page, click the Schedule New Process button and enter values for the fields on the

Schedule New Process modal page:

Page Element Description

Type
 

Ensure that the Job option is selected.
 

Name
 

Search and select the Load Interface File for Import value from the list of names.
 

Description
 

Displays a description about the selected process.
 

3. Click OK. The service now opens the Process Details page for you to select the import process for the process
name you entered in the above step:

Page Element Description

Import Process
 

Click the drop-down menu, search and select the Import Agency Staff value using the lookup
list.
 

Data File
 

Click the drop-down menu and select the generated ZIP file you uploaded earlier, as described
in the previous section.
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4. Click Submit and accept the confirmation message to complete the submission.

Note:  The submission only confirms that the files are sent for processing. To view the details of the completed
process, you must access the log file. The log file lists all the successfully processed records and the records that are in
error, with the details of the error.

Records in Error

Note:  When you fix the errors in the spreadsheet and prepare to resubmit it for processing, you must delete the
records that were processed successfully in the previous run. All the records preceding the ones in error are created
in the Public Sector Agency Staff tables. Resubmitting the template having those records results in creating duplicate
entries of the staff records.

Scenarios for importing employee data from a third-party system to Public
Sector Agency Staff profile
Prerequisite

The scenarios listed here assume that the following prerequisite has already been set up: Each record in the template
should contain a unique identifier called the Interface ID. The interface ID is used as a key identifier while establishing
parent-child relationships across the pages of the template spreadsheet.

Consider importing the employee details into the tables of Public Sector Agency Staff. You can perform the following
actions using the Import template:

• Add a new staff member

• Assign personal attributes

• Assign job functions and attributes

• Assign roles

• Disable an agency profile

The following scenarios detail how you can create a new agency staff record and seamlessly update various parameters
of your existing agency staff.

Note:   The InsertUpdateFlag field on the Import template is the determining factor as to whether the record is for a
new agency staff or for updating an existing agency staff. Enter the value “I” if you are inserting a new record, or “U”
if you are updating an existing record. Also note that the Person Number field is mandatory if you are updating a
record.

Scenario 1: Adding a new agency staff

Consider creating a new agency staff record staff in your Public Sector Agency Staff.

If your agency is not a Fusion HCM customer, you use the template to enter details in all the pages of the template
spreadsheet and then schedule the import process to import the newly added employee record. You must enter the
value “I” in the InsertUpdateFlag field to qualify the record as a new agency staff entry.

The following example shows the data on the spreadsheet detailed in the above scenario – Adding a new staff member.
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Record Number *Interface ID *InsertUpdateFlag*First Name *Last Name *Email *Business Unit *Legal Entity

1
 

467436
 

I
 

John
 

Simmons
 

john.s@example.com
 

Sample
Corporation
 

Sample
Corporation
 

2
 

467437
 

I
 

Robert
 

James
 

robert.j@example.com
 

Sample
Corporation
 

Sample
Corporation
 

Note:  The above example displays a limited number of fields. For a complete list of fields, refer to the Import template
spreadsheet.

If your agency has implemented Fusion HCM, you use the HCM loader or enter the necessary employee details
manually. In such cases, the following Public Sector specific attributes are required to be updated:

• Job Title

• Agency Department

• Agency ID

• Agency Location

• Job Group

• Is Supervisor

• Enabled

Scenario 2: Updating personal details of an agency staff

Consider updating changes to the personal details of an agency staff in your Public Sector Agency Staff. You can
perform the following actions:

• Change work phone number

• Change location

• Change department

• Change job title

• Assign job group

• Revoke job group

• Change supervisor status

The following example shows the data on the spreadsheet detailed in the above scenario.

Record Number *Interface ID *Person
Number

*Work Phone
Number

*Location *Department *Job Title *Is Supervisor

1
 

467436
 

PERNUM8
 

16348773
 

300100168879616
 

1001
 

Agency Staff
 

Y
 

2
 

467437
 

PERNUM9
 

32178939
 

300100168879616
 

1001
 

Building
Inspector

N
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Record Number *Interface ID *Person
Number

*Work Phone
Number

*Location *Department *Job Title *Is Supervisor

 

Note:  The above example displays a limited number of fields. For a complete list of fields, refer to the Import template
spreadsheet.

Scenario 3: Updating job functions and their attributes

Consider updating changes to job functions and their attributes of an agency staff in your Public Sector Agency Staff.
You can perform the following actions:

• Assign job functions and attributes

• Assign additional job attributes to existing functions

• Remove job attributes

• Remove job functions

The following example shows the data on the spreadsheet detailed in the above scenario.

Record Number *Interface ID *Assignment
Flag

*Person
Number

Agency ID Job Function ID Job Attribute Attribute Value

1
 

467436
 

I
 

PERNUM8
 

1
 

ORA_
BUILDING_
INSPECTOR
 

ORA_
INSPECTION_
TYPES
 

Plumbing
 

2
 

467437
 

D
 

PERNUM9
 

1
 

ORA_CASHIER
 

ORA_CASHIER_
ID
 

7574343
 

Scenario 4: Updating roles

Consider updating roles of an agency staff in your Public Sector Agency Staff. You can perform the following actions:

• Assign additional roles

• Revoke roles

The following example shows the data on the spreadsheet detailed in the above scenario.

Record Number *Interface ID *Role Action *Person Number *Role Name

1
 

467436
 

A
 

PERNUM8
 

Employee
 

2
 

467437
 

R
 

PERNUM9
 

Application Implementation
Consultant
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Scenario 5: Disabling agency staff profile

Consider disabling an agency staff profile in your Public Sector Agency Staff. You can perform the update without
having to make any manual entry in your records. The user interface as well as the Import Agency Staff functionality
allow you to disable agency staff profiles.

The following example shows the Enabled field on the spreadsheet, as detailed in the above scenario.

Record Number *Interface ID *Person
Number

*Work Phone
Number

*Location *Department *Job Title Enabled

1
 

467436
 

PERNUM8
 

16348773
 

300100168879616
 

1001
 

Building
Inspector
 

Y
 

2
 

467437
 

PERNUM9
 

32178939
 

300100168879616
 

1001
 

Agency Staff
 

N
 

Note:  The above example displays a limited number of fields. For a complete list of fields, refer to the Import template
spreadsheet.
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7  Setting Up Public Users

Setting Up Public Users  
Public user setup includes configuration options related to public user registration and account management.

To set up public users:

1. Select Common Setup > Public User Setup.
2. In the Terms of Use section of the page, configure these options:

Page Element Description

Require the user to accept the terms
of use before registering
 

Select this check box if public users must accept your terms of use as part of the registration
process.
 

Terms of Use ID
 

If you require public users to accept your terms of use during registration, select the terms of
use definition for the registration process.
 
This field is visible only if the Require the user to accept the terms of use before registering
check box is selected.
 

Note:
If you change the Terms of Use ID, users who have already registered are required to accept
the new terms the next time they sign in. In this scenario, a window with the new terms
opens as soon as the public user signs in. The user must select the agreement check box in
order to continue.
 

3. In the Contractor and License section of the page, configure these options:

Page Element Description

Agency staff verifies when a user’s
contractor status changes to yes
 

Select this check box if agency staff must verify the contractor status of a public user who self-
identifies as a contractor.
 

Agency staff verifies when a user
adds or updates a license
 

Select this check box if agency staff must verify licenses that are added to a user profile. Public
users can add one license during the registration process. Public users and agency staff can
add additional licenses using account management functionality.
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Page Element Description

Note:
Oracle recommends clearing pending requests on the Public User Access page before
turning off the license verification option.
 

4. In the Attachments section of the page, configure these options:

Page Element Description

Allow agency staff and registered
users to manage documents in
account management
 

Select this check box to enable attachments in user accounts. When you enable attachments,
 both users and agency staff can add attachments to user accounts and modify information
about existing attachments.
 
Agency staff can also delete attachments, but public users can’t delete attachments unless you
also select the “Allow registered users to delete documents in account management” check box
on this page.
 

Allow registered users to delete
documents in account management
 

Select this check box to allow public users to delete attachments that are associated with their
account. This setting does not affect agency staff, who can always delete account attachments.
 
This check box is visible only if you enable attachments by selecting the “Allow agency staff and
registered users to manage documents in account management” check box.
 

Document Group ID
 

If you want to enable document categories and subcategories for public user account and
profile attachments, select the document group with the appropriate categories. A document
group consists of a set of related categories.
 
If you leave this field blank, the public user attachment pages won’t have fields for identifying
attachment categories and subcategories.
 
This field is visible only if you enable attachments by selecting the “Allow agency staff and
registered users to manage documents in account management” check box.
 

5. In the Privacy Consideration section of the page, you can select only one option. The agency either hides
name and contact information for all registered users from public view or gives the registered user the option
of hiding their information.

Page Element Description

Hide contact information of all
registrants from public view
 

Select this check box to hide the name and contact information of all applicants and contacts
registered in the system from public view on applications. Only the applicant, their contacts
with application access, and agency staff can view the contact information on an application.
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Page Element Description

When you select this option, registered users will not see the option to hide their name and
contact information on the registration page or in account management.
 

Provide option for registrants to hide
their contact information from public
view
 

Select this check box to give public users the option on the Register page to hide their name
and contact information when a member of the public views the user's applications.
 
If this check box is selected, the initial registration page gives users the opportunity to hide
their information. The public can still view the property address even if the user’s information is
hidden.
 
After a user registers, either the user or agency staff can update this preference using Account
Management functionality.
 

6. In the IVR Access Code section of the page, configure this option.

This section is only available when IVR is enabled for permits at the agency level.

Page Element Description

Enable IVR Access Code (Enable
Interactive Voice Response Access
Code)
 

Select this check box to:
 

◦ Display the IVR Access Code field during account registration on the Register page.

◦ Require applicants to provide their 4-digit PIN when accessing inspection records using
IVR.

◦ Enable registered public users to maintain their 4-digit PIN in account management.

When you deselect this check box, the IVR Access Code field is hidden on the Register page
and applicants can use the IVR system without a PIN.
 
For more information, see The Public User Registration Process and Managing Public User
Accounts.
 

Oracle recommends requiring an IVR access code for applicants calling into an IVR system. For more
information about configuring IVR for agencies, see Setting Up Agency-Level Options for Permits and Setting
Up a Proxy Role and User for Interactive Voice Response.

7. In the User Category section of the page, configure this option:

Page Element Description

Enter a user category for appropriate
notification content and URL
redirection parameters for system
access
 

Enter the user category to be assigned to registered public users. Typically you should use the
delivered category DEFAULT.
 
The user category that you specify will be associated with user accounts that are created by the
public user registration process.
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Page Element Description

The category controls the templates for account-related notifications such as emails for first-
time registration and for resetting the account password. The category also controls URL
redirection so that when users set or reset their password in the Oracle Applications Cloud, they
are immediately transferred to the public sector system.
 
For more information about user categories, see Managing Users in Oracle Permitting and
Licensing and Setting the Next URL for the Default User Category.
 

8. Click Save.

Setting Up Public User Roles  
To ensure that registered public users have appropriate system access, you must define which role is assigned to the
user IDs that are created during the registration process.

When a public user registers, the Oracle system assigns a single role to the new user. Because the user is assigned just
one role, access to different areas of the system is established through a role hierarchy. In this hierarchy, the various
roles that provide access to different areas of the system are all children of a single parent role that you create.

During implementation, you created all custom roles required for system access, including those for the public user. Use
the Public User Roles page to identify the role to be assigned during user registration.

Identifying the Single Role to be Assigned During Public User Registration
To identify the single role to be assigned during public user registration:

1. Select Common Setup > Public User Roles.
2. If the Public User Roles page already lists a role, delete it before you add the new role.

The button for adding a role is hidden if a row already exists. You cannot modify the existing row, so you must
instead delete it and then add a new one.

To delete the existing row:

a. Click the row to access the Role Details page.
b. Click Delete.

3. On the Public User Roles page, click Add.
4. On the Role Details page, use the Role ID field to select the single role to be assigned during the public user

registration process: PSC Custom Registered Public User (CUSTOM_PSC_REGISTERED_PUBLIC_USER).

The Role ID is the only enterable field on the Role Details page. To select a role based on the descriptive role
name rather than the numerical role ID, use the prompt button for the Role ID field and expand the Search
Criteria section of the lookup page so you can search by role name.

Note:  If you can't find the PSC Custom Registered Public User role, you may not have created all of the
necessary custom roles. For more information on setting up custom roles, see Creating Custom Roles for
Oracle Permitting and Licensing.
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5. Click Save.

Setting Up Contact Types  
A contact type describes the role or position of a contact person for an application. The contact type that you assign to
a contact determines whether the contact has access to the application. You set up contact types on the Contact Type
page. The only delivered contact type is Applicant.

Contact types are used only for application contacts, not for profile contacts.

Application Access for Contacts
When you set up contact types, you choose whether contacts have application access. For example, you might enable
access for business owners, contractors, and homeowners, but not for organizations.

Note:  The Applicant contact type is delivered with application access and can't be modified. When an applicant
submits an application, they are automatically assigned the Applicant contact type.

The permit or planning application is also listed in the contact’s own list of applications. For a given permit or planning
application, if a contact’s type allows access and the contact email matches the account email for a registered user,
then that registered user can access the permit or planning application after the application is submitted. To access the
application, the contact searches for it using the search field in the global banner.

With permit or planning application access, the contact can do the following:

• View complete applicant information, including information that is hidden from the general public.

• View plan review data.

• Add and update contractors, including activating or inactivating a contractor on a permit or planning
application.

• View comments, including permit, plan review, inspection, and workflow comments on the contact's own
applications.

• View contacts and attachments on the contact's own applications.

• Add and update contacts, comments, and attachments on the contact's own applications until the permit or
planning application is closed.

• Delete comments and attachments that the contact added.

• View inspections and inspection checklists.

• View fee information.

• Make payments related to the permit or planning application.

• View communications that are visible to the applicant. However, only applicants can access web forms and web
form attachments.

• Schedule inspections.

• Print the permit, and print payment receipts.

Contacts can also add or delete links to related transactions on the permits or planning applications they manage.
You grant registered public user access for managing links to related transactions in the agency setup. For more
information, see Setting Up Agencies.
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Note:  Before contacts can manage attachments, comments, and contacts, your agency must add the PSC
Contact User duty role (ORA_PSC_CONTACT_USER_DUTY) to the PSC Custom Registered Public User role
(CUSTOM_PSC_REGISTERED_PUBLIC_USER) and enable permit or planning application access for the contact type.

Adding a Contact Type
1. Select Common Setup > Contact Type.
2. On the Contact Type page, click Add.
3. On the Contact Type Detail page, enter values for the following fields:

Page Element Description

Contact Type Code
 

Enter the contact type code.
 

Contact Type
 

Enter the type of contact, such as Business Owner, Individual, or Emergency Contact.
 

Allow Application Access
 

Indicates whether permit or planning application contacts with this contact type are granted
access to the application. The Applicant contact type will always have access to the application.
 
To access the permit or planning application, the contact must be a registered user, and the
contact email must match the account email.
 

Description
 

Enter a description of the contact type.
 

4. Verify that the Enabled switch is turned on.
The switch is on by default for a new contact type.

5. Click Save.

Modifying a Contact Type
1. Select Common Setup > Contact Type.
2. Click a row on the Contact Type page.
3. Make the desired changes on the Contact Type Detail page.

Note:  You can't modify the Applicant contact type.

4. Click Save.

Deleting Contact Types
1. Select Common Setup > Contact Type.
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Contact

Type Details page.
Note:  You can't delete the Applicant contact type.

3. To delete one or more definitions without viewing details:
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a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.

Setting Up Terms of Use  
The Terms of Use page stores rules and guidelines to which user must agree as a condition of using a service. The terms
act as a legal contract. They are also known as Terms and Conditions or Terms of Service. When you set up a terms of
use definition, you also specify the contexts where the definition is available. For example, you can specify that certain
terms can be used for public user registration but not for permit, planning and zoning, or business license applications.

You add, modify, and delete terms of use definitions on the Terms of Use page. After setting up terms of use for a
specific offering, you associate the terms of use ID with the application type.

Adding Terms of Use
1. Select Common Setup > Terms of Use.
2. On the Terms of Use page, click Add.
3. On the Terms of Use Details page, enter values for the following fields.

Page Element Description

Terms of Use ID
 

Enter an identifier for the terms of use definition.
 
If a definition changes over time, create multiple definitions with the same ID and new effective
dates. The effective dates of the different versions must not have gaps or overlap.
 

Effective Start Date
 

Enter the first day that the definition is valid.
 

Effective End Date
 

Enter the date, if any, when the definition will no longer be valid. To keep the definition valid
indefinitely, do not enter a date. If no date is specified, the field displays the text Open end date.
 
After a definition is saved, the end date becomes read-only. Although you can’t make manual
changes, the system can still update the end date to accommodate new effective-dated entries.
For example, if the currently effective definition has an open end date, and you create a new
definition with a later start date, the original definition’s end date changes to the day before the
new definition goes into effect.
 

Show All Dates
 

Click this button to access the effective-dated history of the definition. This button is not
available during the creation of a new definition.
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Page Element Description

On the page that displays this history, use the Add button to add a new effective-dated entry
for the definition. The new entry inherits the same Terms of Use ID. You provide the new
effective start date and other details for the definition.
 
The system provides logic to prevent gaps or overlaps in the effective-dated history.
 

Description
 

Enter a description of the terms of use. This is not part of the Terms of Use text that public
users see.
 

Usage
 

Select the Business License check box to make this terms of use definition available for
business license applications. This option makes the definition available to the Terms of Use ID
field on the Business License Type page. Note that it is also necessary to add the Terms of Use
element to the business license application form.
 
Select the Permits check box to make this terms of use definition available for permits
applications. This option makes the definition available to the Terms of Use ID field on the
Permit Type page. Note that it is also necessary to add the Terms of Use element to the permit
form.
 
Select the Planning and Zoning check box to make this terms of use definition available for
planning applications. This option makes the definition available to the Terms of Use ID field
on the Planning Application Type page. Note that it is also necessary to add the Terms of Use
element to the planning application form.
 
Select the Registration check box to make this terms of use available for registration
functionality. This option makes the definition available to the Terms of Use ID field on the
Public User Setup page. See Setting Up Public Users.
 
You must select at least one check box.
 

Content
 

Enter and format the detailed content of the terms to which a user must agree. This is the text
that users see when they are asked to agree to the terms.
 

4. Click Save.

Modifying Terms of Use
1. Select Common Setup > Terms of Use.
2. Click a row on the Terms of Use page.
3. On the Terms of Use Details page, you can update the description, usage, and content.
4. Click Save.

Managing Effective-Dated Terms of Use Definitions
1. Select Common Setup > Terms of Use.
2. Click a row on the Terms of Use page to open the Terms of Use Details page.
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3. Click the Show All Dates button to view the effective-dated history of the definition you opened.
4. Expand the Common Data section to see the Terms of Use ID.
5. Expand the History section to see a list of all effective-dated versions of this terms of use definition.

This example illustrates the Terms of Use Details page that displays the effective-dated history of a terms of
use definition.

6. Click in the Search date range to open a calendar and search for an effective-dated row.
7. System administrators can turn on the Correction Mode switch to change start and end dates or delete a

historical row. When the switch is turned off, you can only delete the current effective-dated row and dates are
display only.

8. Click the Add button in the History section to create a new version of the definition or click an effective-dated
row to open the Terms of Use Details page for the specific dates.

In the new definition, you can enter any of the data except for the Terms of Use ID.

Deleting Terms of Use
1. Select Common Setup > Terms of Use.
2. Click a row on the Terms of Use page.
3. On the Terms of Use Details page, click Delete.

You are prompted to confirm the permanent deletion.
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8  Setting Up Property Information

Security Details for Setting Up Property Information  
This topic describes important security roles, requirements, or considerations specific to setting up property
information.

Primary Role Access Description Associated Job Roles and Abstract Roles

PSC Property Setup Inquiry
 

View property setup.
 

PSC Agency Staff - All agency users
 

PSC Property Setup Administration
 

Administer property setup.
 

PSC Geographical Information System
Administrator
 
PSC System Administrator
 
PSC Business Analyst
 

PSC Property Setup Conditions Management
 

Manage property setup conditions.
 

PSC Geographical Information System
Administrator
 
PSC System Administrator
 
PSC Business Analyst
 
PSC Zoning Administrator
 
PSC Planning Assistant
 
PSC Associate Planner
 
PSC Economic Development Officer
 
PSC Business Analyst
 
PSC Building Inspector
 
PSC Principal Planner
 
PSC Plan Reviewer
 
PSC Permits Supervisor
 
PSC Permit Technician
 

PSC Property Setup Attachments Management
 

Add, update, and delete property setup
attachments.
 

PSC Geographical Information System
Administrator
 
PSC System Administrator
 
PSC Business Analyst
 

77



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 8
Setting Up Property Information

Primary Role Access Description Associated Job Roles and Abstract Roles

PSC Add Property Setup Attachments
 

Add property setup attachments.
 

PSC Geographical Information System
Administrator
 
PSC System Administrator
 
PSC Business Analyst
 

PSC Update Property Setup Attachments
Added by Self
 

Update property setup attachments added by
themselves.
 

PSC Geographical Information System
Administrator
 
PSC System Administrator
 
PSC Business Analyst
 

PSC Delete Property Setup Attachments Added
by Self
 

Delete property setup attachments added by
themselves.
 

PSC Geographical Information System
Administrator
 
PSC System Administrator
 
PSC Business Analyst
 

PSC Delete Property Setup Attachments Added
by Others and Self
 

Delete property setup attachments added by
others and themselves.
 

PSC Geographical Information System
Administrator
 
PSC System Administrator
 
PSC Business Analyst
 

For more information on creating roles for Oracle Permitting and Licensing, see Creating Custom Roles for Oracle
Permitting and Licensing.

For more information on all the predefined security data such as abstract roles, job roles, privileges and so on, see the
Security Reference for Oracle Permitting and Licensing.

Importing Property Information Using Functional Setup
Manager  
You can import property information as CSV file packages using Oracle Functional Setup Manager.

When you enter or update a large volume of property data, using the setup task UI to manage them individually may
not be the most efficient method. To create or update property data in bulk, use Oracle Functional Setup Manager to
import the data in the form of CSV file packages.

Oracle Permitting and Licensing enables you to import data for the following property-related tasks.

Task Key Attributes Manual Setup Instructions

Manage Parcels ParcelIdEntered Setting Up Parcels
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Task Key Attributes Manual Setup Instructions

   

Manage Parcel Owners
 

OwnerName
 
Address1
 
PostalCode
 
OwnerCode (represents the ParcelIdEntered
which is typically the Assessor’s Parcel Number)
 

Setting Up Property Owners
 

Manage Parcel Addresses
 

Address1
 
Address2
 
AddressCode (represents the ParcelIdEntered,
which is typically the Assessor’s Parcel Number)
 
PostalCode
 

Setting Up Property Addresses
 

Manage Parcel Values
 

ParcelIdEntered
 
EffectiveStartDate
 
EffectiveEndDate
 

Setting Up Parcel Values
 

Manage Districts
 

ParcelIdEntered
 
DistrictId
 

Setting Up Districts
 

Manage Parcel Districts
 

DistrictId
 

Assigning Districts to Parcels
 
Assigning Districts to Addresses
 

The import process uses key attributes to determine whether a row of data is new or updated. For example, when
importing parcel address data, the process checks the combination of the Address1, Address2, PostalCode and
AddressCode attributes for each row. If the combination of these attribute values in a row already exists in the
PSC_COM_PARCEL_ADDRESS table, the system updates the values for that row in the table. If the combination of these
attribute values does not exist in the table, the import process inserts a new row in the table.

To import an address with a parcel through FSM, there must be a ParcelNumber value in the AddressCode attribute of
the address import file. To import a parcel owner through FSM, there must be a ParcelNumber value in the OwnerCode
attribute of the address import file.

To import an address with no parcel through FSM, you must enter a value of 0 in the ParcelId and ParcelNumber
attributes of the address import file.

CAUTION:  While preparing the import file for Parcel Address and Parcel Owner, you must populate the Address Code
and Owner Code columns with the values from the ParcelIdEntered column.
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Tip:  If you want to make any manual modifications to a downloaded CSV file before importing it, it is recommended
that you use a CSV editor. Opening the CSV file using spreadsheet software such as Microsoft Excel can change the
formatting of the fields, which could lead to errors during the import process.

See the Oracle Applications Cloud documentation: Export and Import CSV File Packages in Using Functional Setup
Manager.

Setting Up District Types  
You add, modify, and delete district types on the District Type page.

Adding a District Type
1. Select Common Setup > District Type.
2. On the District Type page, click Add.
3. On the District Type Details page, enter values for the following fields:

Page Element Description

District Type
 

Enter a unique identifier for the district type.
 

Description
 

Enter a description of the district type.
 

District Type Category
 

Select a category for the district type from the system-defined values:
 

◦ Code Enforcement

◦ Council

◦ Economic Development

◦ Zoning

◦ Inspection

◦ Plan review: District types with this value can be used to filter plan reviewers for
assignment to plan reviews. See Managing Plan Reviewers and Using the Plan Review
Console.

◦ General

Allow Updates by Parcel Import
 

Turn on this switch to allow Parcel Districts and Address Districts to be automatically removed
by the Post Parcel Import Processing.
 

Note:  Parcel Districts and Address Districts which have parcels with inspection in the
Pending, Scheduled or Requested  statuses will not be removed.
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4. If the district type category is Code Enforcement, configure these settings:

Page Element Description

GIS Layer Enabled
 

Indicate whether to use GIS to identify the district of an incident or case based on the issue
location.
 
The issue subtype for an incident or case is associated with a specific district type. If you enable
the GIS layer for the district type, the system can look up the issue location on the map to
determine the district that the incident or case falls in.
 

District Layer Service URL
 

Enter the URL of the GIS map service that contains district information for the specified district
type.
 
This field becomes visible when the GIS Layer Enabled switch is active.
 

District in GIS
 

Select the map service attribute that provides a district identifier.
 
This field becomes visible when the GIS Layer Enabled switch is active.
 

5. Turn the Enabled switch on to make the row available as a lookup value on other pages.
6. Click Save.

Modifying a District Type
1. Select Common Setup > District Type.
2. Click a row on the District Type page.
3. On the District Type Details page you can:

◦ Update the district type field values.

Note:  You cannot edit the District Type field.

◦ Enable or disable the district type using the Enabled switch. Only enabled district types are available to
select as values on other pages.

◦ Delete the district type. You will be prompted to confirm the permanent deletion.

Note:  You cannot delete a district type that is already associated with a district or an inspection type.

4. Click Save.

Deleting District Types
1. Select Common Setup > District Type.
2. Click Edit.
3. Select the check boxes next to the district types you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Note:  You cannot delete a district type that is already associated with a district or an inspection type.
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Setting Up Districts  
You add, modify, and delete districts on the District page.

Adding a District
1. Select Common Setup > District.
2. On the District page, click Add.
3. On the District Details page, enter values for the following fields:

Page Element Description

District
 

Enter a unique identifier for the district.
 

Description
 

Enter a description of the district.
 

District Type
 

Select a district type from the agency-defined values.
 
See Setting Up District Types.
 

District from GIS
 

Enter the district’s identifier from the GIS map layer for the district type.
 
This field is visible only if a GIS map layer is specified in the district type definition. Only district
types that are classified as code enforcement district types have this option.
 
The system uses this information to populate the District field on code enforcement issues.
Using an issue’s district type and location, the GIS map service identifies the specific district for
the issue. The district identifier from GIS is then used to find the Oracle district identifier for the
issue.
 

4. Click Save.

Modifying a District
1. Select Common Setup > District.
2. Click a row on the District page.
3. On the District Details page you can:

◦ Update the district field values.

Note:  You cannot edit the District field.

◦ Delete the district. You will be prompted to confirm the permanent deletion.

4. Click Save.
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Deleting Districts
1. Select Common Setup > District.
2. Click Edit.
3. Select the check boxes next to the districts you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Parcels  
A parcel of real estate is a tract or plot of land.

A parcel that is held by an owner is a property. A parcel location can be found on a map and is associated with a physical
address. An owner or a contracted business can apply for a permit to develop or modify a structure on a parcel, or
create a planning application for planning and zoning requests.

You add, modify, and delete parcels on the Parcel page.

Adding a Parcel
1. Select Parcel on the Agency Springboard.
2. On the Parcel page, click Add.
3. In the Basic Information section of the Parcel Details modal page, enter information in the following fields:

Page Element Description

(Hold)
 
(Lock)
 

(Notice)
 

Indicates that a condition has been placed on the parcel. If multiple conditions are applied,
 then the icon displays the most severe condition. Click the icon to see a list of all applicable
conditions, including the condition name, severity, description, and when the condition was
applied. Click a condition row to open the Parcel Conditions page in a new window.
 

Parcel Number
 

Enter the assessor’s parcel number (APN) for the parcel.
 
The APN is a number assigned to parcels of real property by the tax assessor of a particular
jurisdiction for identification and record-keeping purposes. The APN is unique within the
jurisdiction, and may conform to certain formatting standards that convey basic identifying
information such as the property type or the location on a map.
 

Parcel Type
 

Enter a parcel type such as Condo or Single Family Home.
 

Status
 

Select the current status of the parcel. Values are:
 

◦ Active

◦ Retired

83



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 8
Setting Up Property Information

Page Element Description

◦ Provisional

Enabled
 

Turn the Enabled switch on to make the parcel available as a lookup value on other pages.
 

Property Description
 

Enter a description of the parcel.
 

4. In the Land Use section of the Parcel Details modal page, enter details about the land associated with the parcel
using the following fields:

◦ Zoning Code

◦ Zoning Code 2

◦ Zoning Description

◦ General Plan

◦ General Plan 2

◦ Tax Rate Area

◦ Parcel Size 1

◦ Parcel Size 2

◦ Boundary Description

◦ Jurisdiction

◦ Census Tract

◦ Census Block

◦ Subdivision

◦ Climate Zone

◦ Flood Zone

◦ Flood Insurance Rate Map

◦ Liquefaction Risk

◦ Fire Risk

◦ Landslide Risk

◦ Soil Type
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5. In the Building section of the Parcel Details modal page, enter details about the building associated with the
parcel using the following fields:

◦ Year Built

◦ Structure Size 1

◦ Structure Size 2

◦ Number of Dwelling Units

◦ Bedrooms

◦ Bathrooms

◦ Pool

◦ Patio

◦ Additional Structure

6. In the Location and Map Information section of the Parcel Details modal page, enter mapping and location
details for the parcel using the following fields:

◦ Map Name

◦ Book Number

◦ Map Book Page

◦ Block Number

◦ Lot Number

◦ Section Number

◦ Latitude

◦ Longitude

◦ X Coordinate

◦ Y Coordinate

7. Click Save.

Modifying a Parcel
1. Select Parcel on the Agency Springboard.
2. Select a parcel on the Parcel page.

Note:  The search interface for this page uses the typical filter by functionality, or the enhanced search if
Search Cloud Service is enabled. For more information on Search Cloud Service, see Setting Up Oracle Search
Cloud Service.

3. On the Parcel Details page you can:

◦ Update the parcel field values.

◦ Change the status of the parcel.

◦ Enable or disable the parcel using the Enabled switch. Only enabled parcels are available as lookup values
on other pages.

4. Click Save.
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Deleting Parcels
1. Select Parcel on the Agency Springboard.
2. On the Parcel page, click Select Multiple.
3. Select the check boxes next to the parcels that you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Note:  Agency staff and applicants cannot delete parcels. Only system administrators can delete parcels. Additionally,
only parcels that have not yet been associated with a permit can be deleted.

Configuring the Parcel Details Page
1. Select Parcel on the Agency Springboard.
2. Select a parcel on the Parcel page.
3. Click the Configure Page button in the global header to relabel or hide fields on the page. For more

information, see Modify Existing Pages.

Migrating APO Data  
Migrating APO data to Oracle Permitting and Licensing using Import Management, and an end-to-end process with OCI
– Data Integration for data transformation.

APO Import Process
Most agencies receive the APO-related data from different sources like the geo spatial applications, county, city, tax
departments, etc. This source data needs to be curated to specific formats as prescribed by the Oracle Permitting
and Licensing APO Import Process before it can be loaded into the Oracle Permitting and Licensing application. The
conversion of the raw APO data into this specific format involves a series of transformation and mapping activities
which may get complex depending upon the nature of the source data.

If you already have your APO data in the specific format, then you can use the Import Management tool to import the
data onto the Oracle Permitting and Licensing application.

Reference architecture for APO import process
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If you don’t have your APO data in the prescribed format, you can use an end-to-end APO data import process using the
Oracle Integration Cloud - Data Integration (OCI - Data Integration). With OCI – Data Integration you can easily transform
your raw APO data. This transformed data can now be imported using the Import Management tool onto the Oracle
Permitting and Licensing application.

Reference architecture for Oracle Permitting and Licensing end-to-end APO import process

Note:  You must have the appropriate subscriptions/licenses for Oracle Cloud Infrastructure (OCI) services like Oracle
Data Integration Cloud, Oracle Object Storage Cloud and Oracle Integration Cloud (OIC) services to complete this
process.

APO Import Process Using the Import Management
Use Import Management from the Tools work area, to import all your external APO data from CSV files. The Import
Management job performs the APO data import after validation of the data with a pre-defined set of rules and Import
Options configurations. You can create or update the APO records through import. The import options and other details
differ by the type of data that you are importing.

Notes:

• Before importing, understand how the data in your file maps to the attributes in Oracle Permitting and
Licensing APO objects and what values are expected in the import file.
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• The data records in the CSV source file may not be processed in the listed order.

In Import Management, each of the six types of APO data are in separate source files. If the existing data file
combines either two or more objects data (for e.g. parcel, address and owner data), then you must separate
these into different files before starting the import process. You can either perform a manual transformation/
translations or use any suitable tool to prepare a separate source file for each object in an object's template
format. Or you can use the end-to-end APO import process detailed in this document to help you with data
transformation.

• You can schedule an APO Import Process using the Oracle Permitting and Licensing application, if you already
have your APO data in the prescribed format (that is, transformed data ready for import) and the appropriate
subscription/license for Oracle Integration Cloud (OIC). For more details, see the section on Scheduling an APO
Import Process Using the Import Property Information Process.

Manage APO Import Objects
Import APO Objects correlate with the APO master tables in Oracle Applications. Understand APO import objects and
their attributes to manage the data that you want to import.

Import APO Object Details
Click Tools > Import Management >  Import Objects.

To see the details of APO import objects, select a specific APO object on the Import Object Details page. The table
shows the details about each importable object on the Import Object Details page.

Display Name Language Independent Code User Key

Parcel
 

PublicSectorParcel
 

ParcelIdEntered
 

Parcel Address
 

PublicSectorParcelAddress
 

ParcelIdEntered
 

Parcel Owner
 

PublicSectorParcelOwner
 

ParcelIdEntered
 

Parcel Value
 

PublicSectorParcelValue
 

ParcelIdEntered
 

Parcel District
 

PublicSectorParcelDistrict
 

ParcelIdEntered
 

Address District
 

PublicSectorAddressDistrict
 

DistrictId
 

Display Name Required Validation

Parcel
 

• ParcelIdEntered

• EnabledFlag

• ParcelStatus

• ParcelStatus should be in ('ORA_FIN',
'ORA_RET','ORA_PROV')

• ParcelSizeOneUnit/ParcelSizeTwoUnit/
StructureSizeOneUnit/
StructureSizeTwoUnit value should be
from configured UOM in the system.
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Display Name Required Validation

• EnabledFlag (Y/N) (Value will be updated
as 'N' if no value in the file)

• Cannot modify the status of reconciled
parcels.

Parcel Address
 

• ParcelIdEntered

• EnabledFlag

• InputSource

• Country

• Postal Code

• ParcelIdEntered (should be valid if not
null)

• Mark the row for update as error if it
returns more than one row in the Parcel
Address table for that key combination
(setup in the parcel import option).

• PrimaryFlag (Y/N) (Value will be updated
as 'N' if no value in the file)

• Country should be two character code
setup in the system. Eg. US

• EnabledFlag (Y/N) (Value will be updated
as 'N' if no value in the file)

• InputSource (U/S) (Value will be updated
as 'U' if no value in the file)

• Address1 (Will be derived based on
concatenation of individual street
columns: Street Number, Street Direction,
Street Name, Street Type, Street Suffix and
Unit Number. Ensure that you do not leave
these fields blank in the input file. Street
Name will always be entered by the user.)

Parcel Owner
 

• ParcelIdEntered

• EnabledFlag

• Country

• Address1

• Postal Code

• Mark the row for update as error, if it
returns more than one row in the Parcel
Owner table for that key combination
(setup in the parcel import option).

• ParcelIdEntered should be valid that exists
in the system.

• EnabledFlag (Y/N) (Value will be updated
as 'N' if no value in the file)

• PrimaryFlag (Y/N) (Value will be updated
as 'N' if no value in the file)

• Country should be two character code
setup in the system. Example: US

Parcel Value
 

• ParcelIdEntered

• EffectiveStartDate

• EffectiveEndDate

• ParcelIdEntered should be valid that exists
in the system.

• EffectiveEndDate should be greater than
EffectiveStartDate.

Note:
If EffectiveStartDate is not in the input
import file, then the import job will flag that
row as error.
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Display Name Required Validation

• ParcelSizeOneUnit/ParcelSizeTwoUnit
value should be from configured UOM in
the system.

• Currency Code should be from configured
Currency in the system.

Note:
If the system has the same combination
of EffectiveStartDate, EffectiveEndDate
and ParcelIdEntered values in the import
file, then update is performed. If the
EffectiveStartDate is different, then that row
will be constituted as a new row and the
import job will perform the insert.
 

Parcel District
 

• ParcelIdEntered

• DistrictId

• ParcelIdEntered should be valid that exists
in the system.

• DistrictId should be valid that exists in the
system.

Address District
 

• Address Combination as configured in the
import options for functional key.

• DistrictId

• Address combination should be valid and
not mapped to a parcel.

• DistrictId should be valid that exists in the
system.

Note:
The input import file for Address District will
have all address columns in it for the user
to populate. The Address District import job
checks for matching combination of address
field values in the system. If present, the
address district row is created. If not, the row
is marked as error and address row is not
created.
 

If you enter values for surrogate keys like ParcelId, AddressId and OwnerId in the input file, these will not be considered.
Rather the program generates the surrogate key value for new records.

For creating Address without parcel, you should leave the Parcel number blank in the input import file.

Bulk Insert/Update has been implemented with the APO high volume import jobs. So you would need to complete the
insert first before trying to update the records. For example, within the same input file you cannot have two rows for the
same parcel, first one for insert and the second one for update. As that new parcel is not yet created in the system, the
second row will always be considered as insert and not update.

Import Data Using Templates
Templates make it easy for you to use the auto mapping feature. For auto mapping to work, the column headers in the
source file must match the names of the columns (attributes) of the objects imported. The column headers shown in
the first row of the downloadable templates are the same as the column names of the corresponding objects. Therefore,
building source files from the templates allows the auto mapping process.
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For example, if your source file has a column "ParcelIdEntered" then it's mapped to the Parcel ID Entered column.
However if your source file's column header is "APN", then auto mapping fails and you should map manually.

Download Import Object Templates
1. Click Tools > Import Management > Import Objects.
2. On the Manage Import Objects page, click the Download icon for the object, such as Parcel, for which you want

to download the template.

Populate Import Templates
Extract the contents of the ZIP file to a folder. The extracted folder contains the template text files for each of the parent
and child objects. The read me text file within the folder contains instructions on how to use the template files to create
source file for importing data. Here are the steps to import data using the downloaded template:

1. Open the CSV template file for the object you want to import.

The file for each object contains two rows. The first row contains all the column names in a format that's
compatible with the automatic mapping functionality. The second row contains the display names as shown on
the import mapping user interface.

2. Before populating the CSV template file with the data to be imported, delete the display name values in the
second row, and populate the columns with the data to import.

3. Use the updated file as the source when you're creating an import activity on the import user interface.

The automatic mapping functionality maps all the columns automatically. You can see both the mapped column names
and the corresponding column names in your language on the Map Fields page.

Manage APO Import Mappings
An import mapping lets you quickly map your source object attributes to the object attributes in Oracle Permitting and
Licensing. You must be an administrator or setup user to create import mappings.

You can create an import mapping in one of the following two ways:

1. Create an import mapping manually.
2. Generate import maps from the sample source file.

Create Import Mapping Manually
1. Click Tools > Import Management > Import Objects.
2. Click the Parcel link under the Display Name column to create a mapping for the Parcel object.
3. On the Manage Mapping page, click the Create Import Mapping button.
4. On the Edit Import Mapping page, enter the name of the mapping, and provide a description for the mapping.

The Target Attributes section displays the attributes of the Parcel object that should map to the source file
columns.

Check the Required column to see if the attribute is required or is a user key.
5. In the Source File section, click the Add Column button to insert a column to the mapping file.
6. Click the Save and Close button to save the mapping.

To edit or download the mapping file, click the mapping number link for your mapping on the Manage Mapping
page.
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On the Edit Import Mapping page, click Download Map from the Actions menu.

Generate Import Maps from Source File
1. Click Tools > Import Management > Import Objects.
2. Click the Parcel link under the Display Name column to create a mapping for the Parcel object.
3. On the Manage Mapping page, click the Create Import Mapping button.
4. On the Edit Import Mapping page, enter name of the mapping, select the object such as Parcel, and provide a

description for the mapping.

The Target Attributes section displays the attributes of the Parcel object that should map to the source file
columns. Also, check the Required column to see if the attribute is required or is a user key.

5. From the Actions menu under Source File section, click Select Source File.
6. In the Source File dialog box, choose the CSV file that should be the source for your mapping file. This creates

the mapping file based on the column header and example values in the source file.
7. Click Save and Close button.

Import Data
To import data:

1. Click Tools > Import Management.
2. On the Manage Imports page, click the Create Import Activity button.
3. On the Enter Import Options page, provide values for each field as shown in the following table:

Field Description

Name
 

Name of the import.
 

Object
 

Object that you are importing.
 
Oracle Permitting and Licensing APO objects:
 

a. Parcel
b. Parcel Address
c. Parcel Owner
d. Parcel Value
e. Parcel District
f. Address District

If you can't find your object, then search for it by clicking the Search link. In the Search and
Select dialog box, enter the object name in the Object text box and click the Search button.
Select your object from the result list and click OK.
 
You can also use the Advanced Search option by clicking the Advanced button. Here, you can
search based on various filter criteria such as object name, attachment supported, creation
date, and so on.
 
If the object you're importing isn't listed, then verify if you have the roles and privileges
required to import the object.
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Field Description

File Name
 

Browse and select a text file in CSV format. The first row of the source file is treated as the
header row. Provide a file name within 40 characters.
 

4. Optionally, to set additional import configurations, click the Advanced Options section.

Here, you can configure settings under Source File, Import Options, or Create Schedule sections.
5. In the Source File and Import Options regions, some of the options in the following table might not be available

depending on the object that you are importing:

Option Description

Import Mode
 

The mode of import, that is, whether it should be an update or create, is determined by the data
in the import file.
 

◦ Update and create – A new record is created if a matching record is not found.

◦ Create – All records in the file are new records which have to be created. If there are any
existing matching records, then they are marked as errors.

Enable High-Volume Import
 

The high-volume import mode is designed to import millions of records at once. All the APO
objects are delivered for high volume import. By default, this mode is enabled for the six
objects.
 

Notification email
 

The email of the individual who receives import processing notifications. The user submitting
the import receives an email notification automatically. To have more than one email recipient,
 separate the email addresses with a semicolon.
 

Delimiter
 

If your file doesn't use a comma to separate values, then select the correct delimiter in the
Delimiter drop-down list. Possible values are:
 

◦ Caret Symbol

◦ Closing Curly Bracket

◦ Closing Parenthesis

◦ Closing Square Bracket

◦ Colon

◦ Comma

◦ Exclamatory Mark

◦ Minus

◦ Opening Curly Bracket

◦ Opening Parenthesis

◦ Opening Square Bracket

◦ Pipe Symbol
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Option Description

◦ Plus

◦ Question Mark

◦ Semi-Colon

◦ Star Symbol

◦ Tilde Symbol

Decimal Separator
 

The decimal separator used in your import file.
 

Date Format
 

The format of the date fields in your file.
 

Time Stamp Format
 

The format of the time fields in your file.
 

File Encoding
 

The format in which your source file is encoded.
 

6. In the Create Schedule region, schedule the import to run immediately or at a future date. If you select a future
date, then provide the date and time to start the import. This is a one-off schedule and cannot be used for
recurring scheduling.

7. Click Next.

The Map Fields page shows the first row of the data from your source file. By default, the application tries
to automatically map each of the source file columns to the appropriate target object attribute. The target
attribute cannot be dragged to attribute display name in the import activity.

Note:  The data in the unmapped columns are not imported.

8. You select a predefined mapping from the list of available mappings under the Import Mapping drop-down list.
If you are reusing an import mapping, then both the source and target columns are already populated.

Leave the Attribute Display Name field blank for any column that you don't want to import.
9. In the case of hierarchical import, you can see the mapping information for child objects in the subsequent

tabs. Note that data validation isn't done for these objects.
10. Click Next.

On the Review and Submit page, review the import activity configuration. If you had not run the pre-validation
on the Map Fields page, then you get a notification message to run the validation process. You can view any
unmapped columns of parent or child objects on this page.

Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped
columns, then you can ignore these columns, and proceed to submit the import job.

11. Click Submit to queue the import.

APO Import Options
1. To access Parcel Import Options page, click Property Information > Parcel Import Options.
2. Use the Parcel Import Options to configure the following for the APO high volume import jobs.
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Option Description

Import Files
 

Toggles are provided for all eight jobs.
 
The import process can be initiated for a particular object through orchestration or Import
Management UI, only if the toggle is ON.
 
The user can pre select import mapping for all objects. The Default import mapping is the automatic
mapping based on the input file template.
 

Parcel Options
 

The Retire Parcels Not Found in Import File setting can be used to retire those parcels not included in
the input parcel file. This option should only be used when the parcel input file contains a complete set
of active parcels, including parcels with no changes.
 

Address Options
 

The Disable Addresses Not Found in Import File setting can be used to disable those parcel
addresses not included in the input parcel address file. This option should only be used when the
address input file contains a complete set of addresses for each parcel, including addresses with no
changes.
 
The Select Fields to Identify New Addresses setting can be used to decide the functional key that will
determine Insert vs Update. If the combination of selected address field values in the address import
file also exists in the database for the same parcel, the existing address will be updated. If not, a new
address will be created. An existing address will be updated only if all the field values match.
 

Owner Options
 

The Disable Owners Not Found in Import File setting can be used to disable those parcel owners not
included in the input parcel address file. This option should only be used when the owner input file
contains a complete set of owners for each parcel, including owners with no changes.
 
The Select Fields to Identify New Owners can be used to decide the functional key that will
determine Insert vs Update. If the combination of selected owner field values in the owner import file
also exists in the database for the same parcel, the existing owner will be updated. If not, a new owner
will be created. An existing owner will be updated only if all the field values match.
 

District Options
 

The Delete District Assignments Not Found in Import File setting can be used to delete those Parcel
Districts or Address Districts not included in the input Parcel District or Address District file. This option
should be used only when the district import file contains a complete set of districts for each parcel or
address without parcel.
 

Parcel Condition Options
 

The Resolve Parcel Conditions Options Not Found in Import File setting can be used to resolve the
parcel conditions in your database that are not in the parcel condition import file. This option should
only be used when the parcel condition import file contains a complete set of active parcel conditions.
The import process resolves only those parcel conditions which has the Allow Updates by Parcel
Import option turned on in the Condition Details page.
 
For more information, see Setting Up Conditions.
 

Address Condition Options
 

The Resolve Address Conditions Options Not Found in Import File setting can be used to resolve
those address conditions in your database that are not in the address condition import file. This option
should only be used when the address condition import file contains a complete set of active address
conditions. The import process resolves only those address conditions which has the Allow Updates
by Parcel Import option turned on in the Condition Details page.
 
For more information, see Setting Up Conditions.
 

Processing Options
 

Use the Preview Mode switch to check how many rows will be successfully processed by the import
process. When the import process is run on the preview mode, actual upsert will not be performed on
the base tables.
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Option Description

Additional post processes can be added in the Optional Processes.
 

APO Import Error Review
The Import Wizard captures the following errors:

• Errors that occur during data load into interface table. Common errors like data type mismatch and data length
mismatch errors are trapped here.

• Errors that occur due to validation business logic coded in the pl sql. The data loaded in the interface table from
the input file are validated for all errors.

Rows that fail the validation are flagged with appropriate error codes in the interface table. Import wizard will create a
rejected csv file with the errored rows for the user to correct. The errors would be sorted by the record number from the
input file.

For example, Parcel District input file has three rows, out of which errors are reported on two rows.

End-to-End APO Import Using OCI – Data Integration, OIC AND Import
Management
In the end-to-end APO import process, the OCI – Data Integration helps you transform your raw APO data as received
from different sources and then import the transformed data onto the Oracle Permitting and Licensing application
using Import Management.

Listed here are the various products and services from Oracle that will help you to seamlessly perform this end-to-end
APO import process:

• Oracle Integration Cloud is used to perform orchestration across various components in the import process.

• OCI – Data Integration is used to perform transformation and mapping of raw data into formatted data that can
be loaded into Oracle Permitting and Licensing APO Import Process.

• Object Storage is used to store copy of external data files for processing and to store formatted data after
transformation and mapping.

• APO Import Process is the Import Management job which is designed to perform Oracle Permitting and
Licensing APO data import after validation of the data with pre-defined set of rules and Import Options
configurations.

Note:  You must procure appropriate subscriptions/licenses to OCI services like Oracle Data Integration Cloud, Oracle
Object Storage Cloud and Oracle Integration Cloud services to complete this process.

For detailed steps on how to perform an end-to-end APO import process, refer Migrating APO Data to Oracle Permitting
and Licensing.
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Scheduling an APO Import  
You can schedule a recurring import process and provide default options for ad hoc executions of the APO Import
process.

You can set a schedule for an APO Import Process after an Oracle Integration Cloud (OIC) orchestration has run to
completion. You can schedule this process in the Oracle Permitting and Licensing application even if you have not used
the Oracle Cloud Infrastructure - Data Integration (OCI-Data Integration) for your data transformation.

Note:  If you have not used the OCI-Data Integration for data transformation, ensure that the CSV files are available
and ready in the Oracle Permitting and Licensing application before the import starts.

To schedule an APO import process:

1. 1. Navigate to Property Information > Import Parcel Information.
2. 2. On the Import Property Information page, use the Schedule option to schedule a run.

Field Description

Schedule
 

Displays the schedule option as set in the Schedule tab below. The available options are As
soon as possible and Using a schedule.
 

Notify Me When This Process Ends
 

Enable the switch to receive notification when the process is completed.
 

Parameters Agency ID
 

Enter your agency ID.
 

Schedule
 

Select the schedule for the run. The available options are As soon as possible and Using a
schedule.
 

Notification
 

Use the + button to add recipients and conditions for receiving the notification.
 

Setting Up Property Addresses  
An address is the physical address associated with a property.

Oracle Permitting and Licensing enables you to define property addresses by:

1. Adding addresses to existing parcels. You can add multiple addresses to one parcel.
2. Defining addresses that are independent of an existing parcel. After defining these addresses, you can

associate them with one or more parcels.
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Adding an Address to an Existing Parcel
You add addresses to parcels on the Parcel Address page.

1. Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel Address in the navigation bar.
2. On the Parcel Address page, click Add.
3. In the Basic Information section of the Parcel Address Details page, you can:

◦ Turn the Enabled switch on to make the row available as a lookup value on other pages.

◦ Turn the Primary switch on to indicate that this is the primary address associated with the parcel. A
parcel may have only one primary address.

4. In the Address Information section of the Parcel Address Details page, enter the following information:

Page Element Description

Hold - Hold
 
Lock -
 

Notice -  
 

Indicates that a condition has been placed on the parcel. If multiple conditions are applied,
 then the icon displays the most severe condition. Click the icon to see a list of all applicable
conditions, including the condition name, severity, description, and when the condition was
applied. Click a condition row to open the Parcel Conditions page in a new window.
 

Address Fields
 

The property address. The Country field displays US.
 
As you enter a Postal Code, the type-ahead list shows values that include appropriate city and
state combinations. After you select a value, the city and state appear as read-only fields, and
two address fields appear so that you can enter the rest of the address.
 
If you don’t know the postal code, click the Don’t know link to display a full set of address
fields.
 

Address Line 1 and Address Line 2
 

Enter the street number or post office box number, along with any additional address
information such as apartment or suite number.
 

City and State
 

Enter the city and state for the address.
 

Postal Code
 

Enter the postal code for the address. The available values for this field are filtered based on the
city and state that you select.
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5. In the Building and Location Information section of the Parcel Address Details page, enter the building and
location details for the parcel address using the following fields:

◦ Building Type

◦ Floor

◦ Unit Number

◦ Street Number

◦ Street Name

◦ Street Direction

◦ Street Type

◦ Longitude

◦ Latitude

◦ X Coordinate

◦ Y Coordinate

◦ Street Suffix

◦ Crossroad 1

◦ Crossroad 2

◦ Landmark

6. In the Contact Information section of the Parcel Address Details page, enter the contact information details for
the parcel address using the following fields:

◦ Name 1 and Name 2

◦ Email Address

◦ Home Phone Number

◦ Work Phone Number

◦ Cell Phone Number

◦ Fax Number

7. Click Save.

Adding an Address
You define addresses that are independent of existing parcels on the Address page.

1. Select Property Address on the Agency Springboard.
2. On the Address page, click Add.
3. In the Basic Information section of the Address Details page, turn the Enabled switch on to make the row

available as a lookup value on other pages.
4. In the Address Information section of the Parcel Address Details page, enter the following information:

Page Element Description

Address Fields
 

The property address. The Country field displays US.
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Page Element Description

As you enter a Postal Code, the type-ahead list shows values that include appropriate city and
state combinations. After you select a value, the city and state appear as read-only fields, and
two address fields appear so that you can enter the rest of the address.
 
If you don’t know the postal code, click the Don’t know link to display a full set of address
fields.
 

5. In the Building and Location Information section of the Address Details page, enter the building and location
details for the parcel address using the following fields:

◦ Building Type

◦ Floor

◦ Unit Number

◦ Street Number

◦ Street Name

◦ Street Direction

◦ Street Type

◦ Longitude

◦ Latitude

◦ X Coordinate

◦ Y Coordinate

◦ Street Suffix

◦ Crossroad 1

◦ Crossroad 2

◦ Landmark
6. In the Contact Information section of the Address Details page, enter the contact information details for the

parcel address using the following fields:

◦ Name 1 and Name 2

◦ Email Address

◦ Home Phone Number

◦ Work Phone Number

◦ Cell Phone Number

◦ Fax Number
7. Click Save.

Modifying a Property Address
1. You modify parcel addresses on the Address Details page. You can access this page two ways.

◦ Select Property Address on the Agency Springboard.
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Select the address you want to modify.

◦ Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel Address in the navigation bar.

Select an address associated with the parcel.
2. On the Address Details page you can:

◦ Update the address field values.

◦ Enable or disable the address using the Enabled switch. Only enabled parcel addresses are available as
lookup values on other pages.

◦ Indicate whether this is the primary address associated with a parcel using the Primary switch.

3. Click Save.

Associating Parcels with an Address
1. You associate parcels with addresses on the Parcel page. You can access this page two ways.

◦ Select Property Address on the Agency Springboard.

On the Address page, select the address for which you want to associate parcels.

Select Parcel in the navigation bar.

◦ Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel Address in the navigation bar.

Select an address associated with the parcel.

Select Parcel in the navigation bar.
2. On the Parcel page, click Add.
3. On the Parcel Address Details page, select the parcel that you want to associate with the address in the Parcel

ID field.
4. (Optional) If you want this address to be the primary address for the parcel, turn on the Primary switch.
5. Click Save.

Deleting Property Addresses
1. You can delete property addresses from the Addresses and Parcel Addresses pages.

◦ Access the Addresses page by selecting Property Address on the Agency Springboard.

◦ Access the Parcel Addresses page by selecting Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel Address in the navigation bar.
2. Click Select Multiple.
3. Select the check boxes next to the parcel addresses that you want to delete.
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4. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Property Owners  
You add, modify, and delete property owners on the Owner page.

Adding a Property Owner
1. Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.
2. On the Parcel Owner page, click Add.
3. In the Basic Information section of the Parcel Owner Details page, enter information in the following fields:

Page Element Description

(Hold)
 
(Lock)
 

(Notice)
 

Indicates that a condition has been placed on the parcel. If multiple conditions are applied,
 then the icon displays the most severe condition. Click the icon to see a list of all applicable
conditions, including the condition name, severity, description, and when the condition was
applied.
 

Enabled
 

Turn the Enabled switch on to make the row available as a lookup value on other pages.
 

Primary
 

Turn the Primary switch on to indicate that this is the primary owner associated with the parcel.
A parcel may have only one primary owner.
 

Owner and Secondary Owner
 

Enter the names of the owner and secondary owner of the parcel.
 

Owner Type
 

Enter the type of owner for the parcel such as Personal or Town.
 

4. In the Location Information section of the Parcel Owner Details page, enter details about the location
associated with the parcel owner using the following fields:

Page Element Description

Address Fields
 

The property owner address. The Country field displays US.
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Page Element Description

As you enter a Postal Code, the type-ahead list shows values that include appropriate city and
state combinations. After you select a value, the city and state appear as read-only fields, and
two address fields appear so that you can enter the rest of the address.
 
If you don’t know the postal code, click the Don’t know link to display a full set of address
fields.
 

Street Number, Street Direction,
 Street Name, and Street Type
 

Enter the street information for the parcel owner.
 

Building Type
 

Enter the type of building associated with the parcel owner.
 

Floor
 

Enter the floor of the building for the parcel owner.
 

Unit Number
 

Enter the unit number for the parcel owner.
 

5. In the Contact Information section of the Parcel Owner Details page, enter the contact information details for
the parcel owner using the following fields:

◦ Email Address

◦ Home Phone Country Code

◦ Home Phone Number

◦ Work Phone Country Code

◦ Work Phone Number

◦ Cell Phone Country Code

◦ Cell Phone Number

◦ Fax Country Code

◦ Fax Number

6. In the Transfer Information section of the Parcel Owner Details page, enter transfer details for the parcel owner
using the following fields:

◦ Last Transfer Type

◦ Document Number

7. Click Save.

Modifying a Property Owner
1. Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.

103



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 8
Setting Up Property Information

Select an owner associated with the parcel.

Note:  Select Property Owneron the Agency Springboard to select a parcel owner to modify from a list of all
parcel owners.

2. On the Parcel Owner Details page you can:

◦ Update the parcel owner field values.

◦ Enable or disable the parcel owner using the Enabled switch. Only enabled parcel owners are available as
lookup values on other pages.

◦ Indicate whether this is the primary owner associated with the parcel using the Primary switch.

3. Click Save.

Deleting Property Owners
1. Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel Owner in the navigation bar.
2. On the Parcel Owner page, click Select Multiple.
3. Select the check boxes next to the parcel owners that you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Assigning Districts to Parcels  
You add, modify, and delete parcel district assignments on the Parcel District page.

Assigning districts to parcels is required setup for inspection scheduling. For more information, see Setting Up
Inspection Scheduling.

Also, inspection assignments are based on inspection type and inspection district job attributes that are associated with
job functions, such as Building Inspector. For more information, see Setting Up Agency Staff.

Assigning a District to a Parcel
1. Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.
2. On the Parcel District page, click Add.
3. On the Parcel District Details page, enter the district you want to associate with the parcel in the District field.
4. Click Save.

Modifying a Parcel District Assignment
1. Select Parcel on the Agency Springboard.
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Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.
2. Select a district on the Parcel District page.
3. On the Parcel District Details page you can:

◦ Select a different district to assign to the parcel.

◦ Delete the assigned district. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Parcel District Assignments
1. Select Parcel on the Agency Springboard.

Select a parcel on the Parcel page.

Click Parcel District in the navigation bar.
2. Click Select Multiple.
3. Select the check boxes next to the parcel district relationships you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Assigning Districts to Addresses  
You assign districts to addresses on the Address District page.

Inspections are scheduled and assigned based on the district associated with a property. For properties associated with
a parcel, you assign districts to the parcel on the Parcel District page. See Assigning Districts to Parcels. For properties
with an address, but no parcel, use the Address District page to assign districts to a property.

For more information on inspection scheduling and assignment, see Setting Up Inspection Scheduling.

Assigning a District to an Address
1. Select Property Address on the Agency Springboard.

Select an address on the Address page.

Click Address District in the navigation bar.

Note:  The Address District page is available only for addresses with no parcel.

2. On the Address District page, click Add.
3. On the Address District Details page, enter the district you want to associate with the address in the District

field.
4. Click Save.

Deleting an Address District Assignment
1. Select Property Address on the Agency Springboard.
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Select an address on the Address page.

Click Address District in the navigation bar.

Note:  The Address District page is available only for addresses with no parcel.

2. Select a district on the Address District page.
3. On the Address District Details page, click Delete. You will be prompted to confirm the permanent deletion.

Note:  If you associate an address that has a district assigned to it to a parcel, the system automatically removes the
district assignment. This is because the district assignment is now defined through the parcel associated with the
address rather than through the address itself.

Setting Up Parcel Values  
You add, modify, and delete parcel values on the Parcel Value page.

Adding a Parcel Value
1. Select Common Setup > Parcel Value.
2. On the Parcel Value page, click Add.
3. On the Parcel Value Details page, enter information in the following fields:

Page Element Description

Parcel ID
 

Enter the ID of the parcel for which you are defining an address.
 
For more information on parcels, see Setting Up Parcels.
 

Effective Start Date and Effective End
Date
 

Enter the date range for which the parcel value is valid.
 

Note:
You can leave the Effective End Date field blank to give the parcel an open end date.
 

Parcel Size 1 and Parcel Size 1 UOM
(parcel size 1 unit of measure)
 

Enter a numeric value and a unit of measure to define the size of the parcel.
 

Parcel Size 2 and Parcel Size 2 UOM
(parcel size 2 unit of measure)
 

Enter a numeric value and a unit of measure to define an additional size for the parcel.
 

Land Value
 

Enter the monetary value of the land associated with the parcel.
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Page Element Description

Improvement Value
 

Enter the monetary value of any improvements made to the parcel.
 

Personal Property Value
 

Enter the monetary value of any personal property associated with the parcel.
 

Fixtures
 

Enter the monetary value of any fixtures associated with the parcel.
 

Owner Exemption, Fixture
Exemption, and Other Exemption
 

Enter the monetary value of any exemptions associated with the parcel.
 

Net Assessed Value
 

Enter the assessed monetary value of the parcel.
 

Currency Code
 

Enter the currency that applies to the parcel value.
 

Property Use Code
 

Enter the property use code associated with the parcel.
 

Parcel Number
 

Displays the parcel number associated with the Parcel ID that you selected.
 

4. Click Save.

Modifying a Parcel Value
1. Select Common Setup > Parcel Value.
2. Click a row on the Parcel Value page.
3. On the Parcel Value Details page you can:

◦ Update the parcel value field values.

Note:  You cannot edit the Parcel ID and Effective End Date fields.

◦ Delete the parcel value. You will be prompted to confirm the permanent deletion.

4. Click Save.

Setting Up Ownership Types  
Ownership type indicates how a business was established; for example, a corporation or a nonprofit. You set up
ownership types for your agency on the Ownership Type page.

Adding an Ownership Type
1. Select Common Setup > Ownership Type.
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2. On the Ownership Type page, click Add New to add an ownership type.
3. On the Ownership Type Details page, enter a name for the ownership type.
4. Enter a description.
5. Verify that the Enabled switch is turned on. The switch is turned on by default for a new ownership type.
6. Click Save.

Modifying an Ownership Type
1. Select Common Setup > Ownership Typee.
2. On the Ownership Type page, click the row for the ownership type that you want to modify.
3. On the Ownership Type Details page you can:

◦ Modify the ownership type description. You cannot change the name.

◦ Click the Enabled switch to enable or disable the ownership type.

4. If you made any changes, click Save.

Deleting an Ownership Type
1. Select Common Setup > Ownership Typee.
2. On the Ownership Type page, click the row for the ownership type that you want to delete.
3. On the Ownership Type Details page, click Delete.
4. If you want to delete multiple ownership types, you can delete them from the Ownership Type page:

a. Click Edit.
b. Select the check boxes for the ownership type rows to delete.
c. Click the Delete icon.

Setting Up Property Types  
Property type categorize properties according to criteria such as how the property is used or the type of dwelling.

You add, modify, and delete property types on the Property Type page.

Adding a Property Type
1. Select Common Setup > Property Type.
2. On the Property Type page, click Add.
3. On the Property Type Detail page, enter values for the following fields:

Page Element Description

Property Type
 

Enter the type of property, such as Residential or Commercial.
 

Description
 

Enter a property type description.
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4. Verify that the Enabled switch is turned on.

The switch is on by default for a new property type.
5. Click Save.

Modifying a Property Type
1. Select Common Setup > Property Type.
2. Click a row on the Property Type page.
3. On the Property Type Detail page you can:

◦ Update the property type description.

◦ Turn off the Enabled switch to deactivate the property type.

4. Click Save.

Deleting Property Types
1. Select Common Setup > Property Type.
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Property

Type Details page.
3. To delete one or more definitions without viewing details:

a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.

Setting Up Property Conditions  
A property condition identifies the general condition of the property. This value is used to indicate the general age of a
property, a property’s physical condition, or other condition.

You add, modify, and delete property conditions on the Property Condition page.

Adding a Property Condition
1. Select Common Setup > Property Condition.
2. On the Property Condition page, click Add.
3. On the Property Condition Detail page, enter values for the following fields:

Page Element Description

Property Condition
 

Enter the property condition, such as Poor or Good.
 

Description Enter a description of the property condition.
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Page Element Description

  

4. Verify that the Enabled switch is turned on.

The switch is on by default for a new property condition.
5. Click Save.

Modifying a Property Condition
1. Select Common Setup > Property Condition.
2. Click a row on the Property Condition page.
3. On the Property Condition Detail page you can:

◦ Update the property condition description.

◦ Turn off the Enabled switch to deactivate the property type.

4. Click Save.

Deleting Property Conditions
1. Select Common Setup > Property Condition.
2. To view a definition before deleting it, click the row to be deleted, then click the Delete button on the Property

Condition Details page.
3. To delete one or more definitions without viewing details:

a. Click Edit.
b. Select the check boxes next to the definitions that you want to delete.
c. Click Delete.

You will be prompted to confirm the permanent deletion.
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9  Setting Up Contractor Licenses

Setting Up Contractor License Options  
Contractor license options are system-wide settings that control contractor license processing and data. You can
maintain multiple sets of options, each with its own identifying code. But only one code at a time can be active.

Use contractor options to control:

• Whether you integrate with an external licensing body to validate license information during application intake.

• Whether to allow users to manually choose classifications for licenses.

• Whether to decline an application based on the status of the license.

• Which sections for supplemental license information are visible to users.

• Which ownership and insurance types the applicant can select in the intake form.

You can also establish an integration with an external licensing body to load license information into your contract
records.

Configuring Contractor License Options
Here's how staff with an agency administrator or business analyst role can set up contractor options:

1. Select Contractor Setup > Contractor License Options.
2. Click Add to create a new set of options, or click an existing row to modify it.
3. If you’re creating a new set of options, enter a unique Code as an identifier.
4. Enter a Description for this set of configuration options.

The description should be suitable for end-users because both public users and agency staff see the
description when entering contractor information.

5. Use the Active switch to indicate whether this is your active contractor configuration.

Only one set of configuration options can be active. If another configuration is already active, then an error
message explains that you must turn off this switch for the active configuration first.

6. Use these switches to enable additional configuration options:

Page Element Description

Integrated with External Source
 

When this option is enabled, users can retrieve license information from an external licensing
body in the intake form. Click the Integrations link to identify the Oracle Integration Cloud (OIC)
integration that retrieves the information.
 
When integration is inactive, the Limit to Contractor List option is automatically enabled and
the License Types link appears.
 
Whether the Integrated with External Source switch is on or off, you can set up an integration
to load license data using batch processing in the Integrations section.
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Page Element Description

 

Limit to Contractor List
 

When this option is enabled:
 

◦ Users can only select licenses from the agency’s contractor records in the intake form,
 whether or not there’s an active integration.

◦ The agency can still add licenses to the contractor records from an external source using
an integration.

When this option is off, licenses entered in the intake form are retrieved first from the
contractor records if they exist there, then from the external licensing body.
 

Document Group
 

Select a document group.
 
When you specify a document group, document attachments can be classified into categories
and subcategories when you upload files. Then you can see the category for a document on the
Attachments page in the contractor license details.
 
For more information, see Setting Up Document Groups.
 

Working with Integrations
To enable integration with an external contractor license source:

1. Click the Integrations link to configure integration settings in the Integrations grid.
2. Click the Add action to add an integration. You can only add one of each type of integration.
3. Enter the following for each integration:

Page Element Description

Type
 

Identifies the process that uses integration:
 

◦ Verify license online retrieves information for a specific license that a user enters in the
main contractor page or in the intake form for a permit or planning application. These
pages have a button that the user clicks to initiate information retrieval.

◦ Batch load license data establishes the integration used to load information for multiple
licenses into your contractor records when batch processing runs.

You can create only one row for each integration type.
 

Integration Name and Integration
Parameter
 

Enter the name of the OIC integration that retrieves contractor license and contact information
and the query parameters for the OIC integration end point. Oracle Public Sector calls the PSCR
CONTRACTOR BATCH LOAD integration by using the parameter DataSource,MergeOption,
LastUpdated,DataToLoad.
 

Integration Version
 

Enter the version number of the OIC integration.
 

Key Leave this field blank. The source key is maintained in the OIC integration definition.

112

https://docs.oracle.com/pls/topic/lookup?ctx=pscr22d&id=SettingUpDocumentGroups


Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 9
Setting Up Contractor Licenses

Page Element Description

  

Integration Enabled
 

Indicate whether the integration type is enabled.
 

Selecting License Types
You must set up license types when the system isn't integrated with an external source. Applicants select a contractor
license type when entering contractor information in the intake form.

If the Integrated with External Source switch is turned off, the License Types link becomes visible.

To select license types for this set of license options:

1. Click the License Types link to maintain license types.
2. Click the Add action to add a license type.
3. Enter the following information for each license type:

Page Element Description

License Type
 

Enter the unique identifier for the license type.
 

Description
 

Enter the descriptive name of the license type.
 

Enabled
 

Indicate whether the license type is enabled.
 

Working with License Classifications
To set up license classifications for this set of license options:

1. Click the Classifications link to maintain the license classifications in the Classifications grid.
2. Click the Add action to add a classification.
3. Enter the following information for each license classification:

Page Element Description

Code
 

Enter the unique identifier for the license classification. The contractor licensing body sets
these codes.
 

Description
 

Enter the descriptive name of the license classification.
 

Enabled
 

Indicate whether the license classification is enabled.
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Working with License Statuses
The statuses that the licensing body assigns are called source statuses. When integration is turned on, you map a
source status to an agency’s internal status.

CAUTION:  The license status defaults to Other for unmapped source statuses. Applications that include licenses with
an Other status are automatically declined.

To set up license status mapping rules:

1. Click the Status Rules link to maintain a mapping in the Status Rules grid.
2. Click the Add action to add a mapping.
3. Enter the following information for each status rule:

Page Element Description

Status
 

Select the agency status for this rule. When a license has this status in the contractor records,
 and the Decline Application switch is on, the application can’t be submitted.
 
If using an integration, select the agency status to assign to licenses that have the specified
source status. If multiple source statuses map to a single agency status, there will be multiple
rows for the agency status.
 

Source Status
 

Enter a license status that’s assigned by the licensing body. This field is only available when
you’re integrating with a licensing body. When integration is turned on, you map a source status
to an agency’s internal status.
 

Decline Application
 

Enable this switch to prevent applications from being submitted when a contractor license has
this agency status, or this source-to-agency status mapping when integrated with an external
licensing body. This option also prevents you from adding contractor licenses with the source
status to the permit details.
 

Enabled
 

Indicate whether the status rule is enabled.
 

Displaying Category Sections
Sections are specific categories of supplemental information about licenses. License classifications appear in a section
on the intake form and contractor record. Other sections include information about bonds and insurance such as
Workers' Compensation. You can change section titles that appear on the intake form and contractor record by updating
the section description on Contractor License Sections setup page.

To select the sections you want to display:

1. Click the Sections link to maintain sections in the Sections grid.
2. Click the Add action to add a section.
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3. In the list of available sections, use the Enabled switch to control section visibility. Turning off the switch hides
the section on the intake form and contractor record from both agency staff and public users.

Selecting Ownership Types
Applicants select an ownership type from the list when providing license information on the intake form. You define
which ownership types are available to choose from.

To select the ownership types you want to display:

1. Click the Ownership Types link to maintain the types of business ownership that can be associated with the
contractor’s license in the application.

2. Click the Add action in the Ownership Types grid.

Using the lookup prompt, you can select from the ownership types that you set up on the Ownership Types
page, for example, Corporation, Partnership, or Sole Proprietorship. For information about setting up ownership
types, see Setting Up Ownership Types. If an ownership type is retrieved from an integration but isn’t in the
contractor license options, the ownership type is added to the contractor license option details.

3. Turn on the Enabled switch to indicate the ownership type is active.

Setting Up Insurance Types
To set up the insurance types you want to display:

1. Click the Insurance Types link to display the Insurance Types grid.
2. Click the Add action to add the types of insurance information that can be associated with a license.
3. Enter values in the Insurance Type and Description fields.
4. Turn on the Enabled switch to indicate the insurance type is active.

Setting Up Contractor License Sections  
Contractor license information can include sections with different types of data such as license classification
information, workers’ compensation information, and contractors’ bonds. To ensure that users see meaningful labels for
these sections, use the Contractor License Sections page to maintain section descriptions.

Note:  This page is only for updating descriptions. To hide a section so it is not seen by either agents or public users,
use the Contractor License Option Details page.

To maintain the descriptions of contractor license sections:

1. Select Contractor Setup > Contractor License Sections.
2. Review the Description for each delivered section, and update the descriptions as needed.

These are the delivered sections:

Section Code Delivered Description

ORA_BQI
 

Other Bonds
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Section Code Delivered Description

ORA_CB
 

Contractor Bond
 

ORA_CLASS
 

Classification
 

ORA_WC
 

Workers' Compensation
 

3. Click Save.

Setting Up Contractor Integration  
This topic describes how to import and activate integration settings that enable you to validate contractor information
against data from the contractor licensing body.

Oracle provides pre-built integrations with specific contractor licensing bodies. To set up this integration, download
the integration files from My Oracle Support and then import them into Oracle Integration Cloud (OIC). To use
an integration after you set it up, use the Contractor License Options page. For more information, see Setting Up
Contractor License Options.

To set up contractor integration:

1. Go to My Oracle Support (MOS) and access Doc ID 2672514.1, Public Sector Compliance and Regulation Setting
Up Contractor Integration.

2. Follow the instructions on the MOS page, and save the IAR integration file for your contractor licensing body.
3. Access the main console in OIC.
4. Click Integrations in the left frame.
5. Click the Import button at the top of the Integrations page.
6. Select the integration file for your licensing body, then click the Import button.
7. Click Connections in the left frame.
8. Test the Generic REST Trigger connection:

a. Access the detail page for the Generic REST Trigger connection.
b. Click the Test button.
c. When the test is 100% complete, click Save and then Close.

9. Test the integration for the imported licensing body:

a. Access the detail page for the licensing body connection.
b. Click the Test button.
c. When the test is 100% complete, click Save and then Close.

10. Click Integrations in the left frame to return to the Integrations page.
11. Turn on the activation switch for the new licensing body integration.
12. In the Activate Integration window that appears, click the Activate button.
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Preparing to Load Contractor Licenses  
Oracle provides a prebuilt Oracle Integration Cloud (OIC) integration to load licenses and license contacts  from a
manually provided file, or you can get licenses from a contractor licensing body. Import a package and activate
integration settings in OIC before you load contractor licenses.

Your OIC configuration depends on which batch load method you're using. You can retrieve licenses from:

• A contractor licensing body.

This option is only available with integration to an external service and integration is enabled on the Contractor
License Option Details page. This option applies when you want to update the licenses in your contractor list.

• A file.

You can manually load a file with contractor licenses regardless of whether an integration with a licensing body
is enabled or not. Contractor contact information associated with a license can be manually loaded using a file
only. When an online integration is not available and integration is disabled on the Contractor License Option
Details page, licenses can only be loaded using a file. This option can help you migrate contractor data from a
legacy system.

For information about integration settings, see Setting Up Contractor License Options.

Here's how agencies configure OIC to load contractor licenses:

1. Go to My Oracle Support (MOS) and access Doc ID 2759502.1, Configuring Oracle Integration Cloud (OIC) for
Loading Contractor Licenses in Oracle Permitting and Licensing.

2. Follow the instructions on the MOS page, and save the PAR package file for loading licenses from a contractor
licensing body or a license file.

3. Access the main console in OIC.
4. Click Packages in the left frame.
5. Click the Import button at the top of the Packages page.
6. Select the package file for loading licenses from an external licensing body or license file, then click the Import

button.
7. Click Connections in the left frame.
8. Configure, test, and save these connections in the package:

a. FTP Read Contractor File
b. PSC Rest Connector
c. CSLB Rest Trigger
d. CSLB REST CONNECTOR

9. Click Integrations in the left frame.
10. Configure and activate these integrations in the package:

a. CSLB BATCH LOAD - REST
b. CSLB POST LICENSE - REST
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Loading Contractor Licenses and Contacts  
You can use batch processing to load contractor license records manually from a file or through an integration with a
licensing body. Merge options enable you to load a full file or update licenses matching those in the agency-maintained
contractor list. You also have the option to load license contacts from a file.

Processing can be executed as needed, such as when you want to migrate contractor data from a legacy system, or on a
scheduled basis to refresh license records in the contractor list. Staff with agency administrator or business analyst roles
can configure the system for batch processing.

The batch load process for contacts replaces license contacts already in the license details with the contact information
from the file if there's a matching email, first name, middle name, and last name. If an exact match of email and name
isn't found, the process creates a new license contact.

Before You Begin
Oracle provides a prebuilt Oracle Integration Cloud (OIC) integration to load licenses. You import a package and activate
integration settings in OIC before you run batch processing.

For information about OIC configuration for an integration with a licensing body and connections for loading a file with
license records, see Setting Up Contractor Integration and Preparing to Load Contractor Licenses.

Entering Parameters
1. Select Contractors > Load Contractors.
2. Click the Parameters tab on the Load Contractors page.
3. In the Data to Load field, select the type of data that you want to load:

◦ Licenses

◦ Contacts

◦ Licenses and contacts

Note:  You can add contact information to the batch load layout from a file only. A license must exist to load
the contacts.

4. Enter these parameters for your batch process if your data type is Licenses.

For loading Contacts and Licenses and contacts, the data source is File and the other options are not available.

Page Element Description

Data Source
 

Select an option to indicate the source of the license records that you want to load:
 

◦ File – Processing picks up license information from a file to merge with license records.

◦ Integration service – Processing connects with a licensing body through an integration
service to get the license file and merge license records.

Merge Option
 

Select how you want to merge the data from the source with your system:
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Page Element Description

The Entire file option works in two ways:
 

◦ Loads any new licenses from the file that do not exist in the contractor list.

◦ Updates existing licenses in the contractor list from the file.

Use the Contractor list option to update licenses that already exist in the contractor list. The
process skips licenses that don't exist in the contractor list.
 

Period in Which Licenses Were Last
Updated
 

Identify which records you want to merge by when they were last updated. For example, if you
want to merge the records from the source that were updated in the last two weeks, select the
number 2 and the unit of time, Weeks.
 

◦ Select a number 1 or greater.

◦ Select a unit of time, including None, Days, Weeks, or Months. If you don't want to load
records based on a given period, select None.

Note:
To identify licenses that were updated in the specified period only, the license data must
have a last updated date. If a licensing body doesn't use a last updated date, select None.
 

Scheduling the Process
1. Access the Schedule tab.
2. To immediately add the process to the queue, select the As soon as possible option.
3. To create a schedule for the process, select the Using a schedule option, and enter values using the following

fields:

Page Element Description

Frequency
 

Select how frequently you want to run the process. Values are:
 

◦ Once: Select to run the process one time only.

◦ Hourly or minute: Select to run the process at regular time intervals.

◦ Daily: Select to run the process at regular intervals in days.

◦ Weekly: Select to run the process at regular intervals in weeks.

◦ Monthly: Select to run the process on specific days of the month.

◦ Yearly: Select to run the process during specific months.

Start Date
 

Enter the date on which you want to begin your scheduled processing.
 

End Date
 

Enter the date on which you want to end your scheduling processing.
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Hours and Minutes
 

Enter the time interval between scheduled processes. For example, if you enter 2 in the Hours
field and 30 in the Minutes field, the process will run every 2 hours and 30 minutes beginning
on the specified start date.
 

Note:
These fields are available only if you select a process frequency of Hours or Minutes.
 

Days
 

Enter the number of days between scheduled processes. For example, if you enter 3, the
process will run every 3 days beginning on the specified start date.
 

Note:
This field is available only if you select a process frequency of Daily.
 

Weeks
 

Enter the number of weeks between scheduled processes. For example, if you enter 6, the
process will run every 6 weeks beginning on the specified start date.
 

Note:
This field is available only if you select a process frequency of Weekly.
 

Repeat – By day
 

Select this option to run the process on specific days of the month irrespective of the date. For
example, if you select the Secondand Wednesday options, the process will run on the second
Wednesday of every month.
 
You can select more than one week of the month and day of the week option. For example, you
could schedule the process to run on the first and third Monday of every month.
 

Note:
This option and its associated fields are available only if you select a process frequency of
Monthly or Yearly.
 

Repeat – By date
 

Select this option to run the process on specific dates of the month. You can select more than
one date.
 

Note:
This option and its associated fields are available only if you select a process frequency of
Monthly or Yearly.
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Month
 

Select the months in which you want your process to run.
 

Note:
This option and its associated fields are available only if you select a process frequency of
Yearly.
 

Setting Up Process Notifications
You can set up the process to send notifications to you and others when it runs.

1. Turn on the Notify Me When This Process Ends switch to send yourself a notification when the process
finishes.

2. Access Notification tab.
3. Click Add.
4. On the Create Notification page, enter the email address of the person you want to receive notifications.

By default, the recipient will receive a notification when the process ends with the following conditions:

◦ On success

◦ On error

◦ On warning

You can remove any of these process notification conditions.
5. Click OK to save the notification recipient.
6. (Optional) To delete a notification recipient, select the recipient in the Notification tab and click Delete.

Submitting the Process
Once you’ve entered your process parameters, scheduling information, and notification recipients, you’re ready to
submit the process. Enter any additional information in the Submission Notes field and click Submit. Click Process
Monitor to check the status of your process.
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Managing Comments  
This topic provides an overview about Standard Comments and discusses how to manage comments.

Standard Comments Overview
Standard comments are predefined comments that users can easily and quickly use, instead of manually entering the
text. Standard comments are generic and complete, which make them reusable.

Users can use standard comments across all Oracle Permitting and Licensing offerings. You can use standard
comments while updating your applications.

System administrators set up application categories and subcategories using the Application Category page, based on
the type of comments you wish to have. Standard comments are set up using the Standard Comments page.

Managing Comments
You manage the comments by setting up how you want the comments to be available for the agency staff members.

1. Select Comments > Manage Comments.
2. On the Manage Comments page, you add values to all these fields:

Page Element Description

Number of days comment is recent
 

Enter a numeric value or use the increment/decrement buttons. The number of days a
comment is listed as Recent is based on the value in this field.
 

Rich Text Editor
 

Use the switch to enable or disable Rich Text Editor formatting for comments.
 

Comment Summary Length
 

Enter a numeric value or use the increment/decrement buttons. This value determines the
maximum number of characters that can be displayed in the Comment Summary field.
 

Note:
The system allows a maximum length of two hundred (200) characters in the comment
summary.
 

3. Click Save to save the changes.
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Setting Up Standard Comment Categories and
Subcategories  
This topic discusses how to set up Standard Comment Categories and Subcategories.

Setting Up Standard Comment Categories and Subcategories
You set up the comments categories and subcategories on the Application Category page.

1. Select Comments Setup  > Comment Categories.

On the Application Category page, click Add to add a new category.
2. On the Application Category Details page, you add values to all these fields:

Field Name Description

Application Category
 

Enter a category.
 

Description
 

Enter a description for the category. This description displays detailed information about the
category when searching for categories.
 

3. Turn on the Enabled switch if you want to enable this category when you save it. The switch is turned off by
default for a new category.

4. In the Application Groups section, you can include application groups that you want this category to be
available for. Click Add to open the Application Group Details page, select the application group.

5. Turn on the Enabled switch if you want to enable the selected group when you save the page.
6. Click Save to save the newly added application group and return to the Application Category Details page.
7. To add an application subcategory, select the Application Subcategories section and click Add.
8. On the Application Subcategory Details page, you add values to all these fields:

Field Name Description

Application Subcategory
 

Enter a subcategory
 

Description
 

Enter a description for the subcategory. This description displays detailed information about
the subcategory when searching for subcategories.
 

9. Turn on the Enabled switch if you want to enable this subcategory when you save it. The switch is turned off by
default for a new subcategory.

10. Click Save to save the newly added application subcategory and return to the Application Category Details
page.

11. Click Save to save the record and return to the Application Category page.
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Modifying Standard Comment Categories and Subcategories
You modify the comments categories and subcategories on the Application Category Details page.

1. Select Comments Setup  > Comment Categories.
2. On the Application Category page, click the chevron on a category line to select and modify the category.
3. On the Application Category Details page, enter new values in the Application Category and Description fields.
4. Verify that the Enabled switch is turned on if you want to enable this category when you save it.
5. Use the Application Groups section to select the application group that you want this category to be available

for.
6. In the Application Subcategories section, you can edit the application subcategories.
7. Click Save to save the changes. You can use the Delete button to delete the category.

Viewing, Adding, Modifying, and Deleting Standard
Comments  
This topic discusses how to view, add, modify, and delete Standard comments.

Viewing Standard Comments
You search and view Standard Comments on the Standard Comments page.

1. Select Comments Setup  > Standard Comments.
2. Use the application category or application subcategory fields to filter comments on the Standard Comments

page.

Adding Standard Comments
You add comments using the Add button on the Standard Comment page.

1. Select Comments Setup > Standard Comment
2. On the Standard Comments page, click Add to open the Standard Comment Details page and add a new

comment.
3. On the Standard Comment Details page, enter values for these fields:

Page Element Description

Comment Code
 

Enter a comment code.
 

Application Category
 

Enter an application category
 

Application Subcategory
 

Enter an application subcategory
 

Description Enter a comment.
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4. Verify that the Enabled switch is turned on if you want to enable this comment when you save.
5. Click the Save button to save the new comment and return to the Standard Comment page.

Modifying Standard Comments
You modify comments on the Standard Comment Details page.

1. On the Standard Comments page, click the chevron on a comment line to select and modify the comment.
2. To modify the comment, you can change the values entered in the Application Category and Application

Subcategory fields, and edit the description.
3. Verify that the Enabled switch is turned on if you want to enable this modified comment when you save.
4. Click Save.

Deleting Standard Comments
You delete comments on the Standard Comment Details page.

1. On the Standard Comments page, click the chevron on the comment line which you want to delete.
2. On the Standard Comment Details page, click the Delete button to delete the comment.
3. Click Yes on the confirmation page to delete the comment and return to the Standard Comments page.
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Setting Up Document Categories and Subcategories  
You set up document categories and subcategories on the Document Category pages to organize the various types of
attachment files. Applicants select the document's category or category and subcategory when attaching documents.

After defining the document category, you add the document categories to the document group and then enter the
document group ID on the transaction type for permits, planning applications, and business licenses.

System administrators can configure the categories and subcategories to identify required documents and the stage
in the application process where the documents are required. If you add a document group to the application type and
the document group includes document categories that are configured to identify required documents, the Required
Documents section appears on the application intake form and the Attachments page in the application details. The list
of required documents is informational only.

Adding Document Categories
1. Select Common Setup > Document Category.
2. On the Document Category page, click Add to add a new document category.
3. Enter values on the Document Category Details page:

Page Element Description

Category ID
 

Enter an identifier for the category.
 

Category
 

Enter a name for the category.
 

Description
 

Enter a description of the category.
 

Enabled
 

Turn the switch on to make the category available for use. The category is disabled by default.
 

4. Turn on one or more of the switches in the Required Document Application Step section to indicate when
documents with this category are needed:

◦ Submittal

◦ Issuance

◦ Acceptance

◦ Final inspection

◦ Complete

Any subcategories that you set up for this document category are automatically shown as required at the steps
you selected for the category.
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The document requirements are informational only.
5. Turn on one or more of the switches in the Required Document Application Step section to indicate when

documents with this category are required:

◦ Submittal - Applicants must attach this document before they can submit the application.

◦ Issuance - The permit or business license can't be issued without this document.

◦ Acceptance - Agency staff can't accept this document into the system if this document is missing.

◦ Final inspection - Inspectors can't submit the final inspection results without this document. This switch
is only available if your agency uses the Permits service.

◦ Complete - The application process won't be complete until this document has been attached.

Any subcategories that you set up for this document category are automatically required at the steps you
selected for the category.

6. Click Configure User Assistance to enter rich text to provide information about the requirements for
the specified document. The help (question mark) icon appears in the list of required documents on the
Attachments grid in the application intake form. Click OK to save the information.

7. Click Save.
8. If you want to add a subcategory, click Add in the Document Subcategory section.
9. On the Document Subcategory Details page, enter an ID, name, and description for the subcategory.

10. Click Save.

Adding Document Subcategories
1. Select Common Setup > Document Category.
2. On the Document Category page, click a category row.
3. On the Document Category Details page, click Add in the Document Subcategory section to add a new

document category.
4. Enter values on the Document Subcategory Details page.

Page Element Description

Subcategory ID
 

Enter an identifier for the subcategory.
 

Subcategory
 

Enter a name for the subcategory.
 

Description
 

Enter a description of the subcategory.
 

Enabled
 

Turn the switch on to make the subcategory available for use. The subcategory is disabled by
default.
 

5. Turn on one or more of the switches in the Required Document Application Step section to indicate when
documents with this category are needed:

◦ Submittal

◦ Issuance
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◦ Acceptance

◦ Final inspection

◦ Complete

Any subcategories that you set up for this document category are automatically shown as required at the steps
you selected for the category.

The document requirements are informational only.
6. Turn on one or more of the switches in the Required Document Application Step section to indicate when

documents with this category are required:

◦ Submittal - Applicants must attach this document before they can submit the application.

◦ Issuance - The permit or business license can't be issued without this document.

◦ Acceptance - Agency staff can't accept this document into the system if this document is missing.

◦ Final inspection - Inspectors can't submit the final inspection results without this document. This switch
is only available if your agency uses the Permits service.

◦ Complete - The application process won't be complete until this document has been attached.

Any subcategories that you set up for this document category are automatically required at the steps you
selected for the category.

7. Click Configure User Assistance to enter rich text to provide information about the requirements for the
specified document. This link only appears for the subcategory if the document category is required at the
Submittal step.

The system displays the user assistance configured for the subcategory if provided, but if not, displays the text
for the category, if present. The help (question mark) icon appears in the list of required documents on the
Attachments grid in the application intake form. Click OK to save the information.

8. Click Save.

Modifying Document Categories and Subcategories
1. Select Common Setup > Document Category.
2. On the Document Category page, select the row for the category that you want to modify.
3. On the Document Category Details page, you can modify the category name and description, and turn the

Enabled switch on or off.
4. Click Save to save any changes.
5. To modify a document subcategory:

a. Select the associated category to open the Document Category Details page.
b. Select the subcategory that you want to modify.
c. On the Document Subcategory Details page, you can change the subcategory name and description, and

turn the Enabled switch on or off.
d. Click Save.

Deleting Document Categories and Subcategories
You can't delete categories and subcategories if they are already referenced on an uploaded attachment.

1. Select Common Setup > Document Category.
2. On the Document Category page, select the row for the category that you want to delete.

129



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 11
Setting Up Documents

3. If you want to delete the document category, click Delete on the Document Category Details page.

Note:  When you delete a document category, all associated subcategories are also deleted.

4. If you want to delete multiple document categories, you can delete them on the Document Category page:

a. Click Edit.
b. Select the check boxes for the document category rows to delete.
c. Click Delete.

5. To delete the document subcategory, click Delete on the Document Subcategory Details page.
6. If you want to delete multiple subcategories, you can delete them from the Document Category Details page

using the Edit and Delete buttons.

Setting Up Document Groups  
You set up document groups using the Document Group pages to organize the various categories of attachment files
into a grouping.

When you assign a document group to a transaction type, the categories and subcategories associated with that
document group can be selected for document attachments associated with those transactions. After you set up the
document categories, add them to a group then add the group ID to the transaction type defintion.

If you add a document group to an application type and the document group includes document categories that are
configured to identify required documents, the Required Documents section appears on the application intake form
and the Attachments page in the application details. The list of required documents is informational only. For more
information, see Setting Up Document Categories and Subcategories.

Adding Document Groups
1. Select Common Setup > Document Group.
2. On the Document Group page, click Add to add a new document group.
3. Enter values on the Document Group Details page:

Page Element Description

Group ID
 

Enter an identifier for the group.
 

Group
 

Enter a name for the group.
 

Description
 

Enter a description of the group.
 

Enabled
 

Turn the switch on to make the group available for use. The group is disabled by default.
 

4. Click Save.
5. Add document categories that make up the grouping by clicking Add in the Document Category section.
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6. Enter a document category ID or use the lookup prompt to find a category ID.

If desired, you can click the Document Category link to research which category to choose.

The Required Document Application Step displays the step in the application process at which a document
with that category is needed.

7. Click Save.

Modifying Document Groups
1. Select Common Setup > Document Group.
2. On the Document Group page, select the row for the group that you want to modify.
3. On the Document Group Details page, you can modify the group name and description, and turn the Enabled

switch on or off.

Disabled document groups can’t be selected in the prompt list for a transaction type.

Note:  Disabling a document group does not affect attachments for existing or new transactions associated
with permit types to which that document group is assigned. The categories and subcategories associated
with a disabled group continue to display for existing attachments, and are still available to select for new
attachments.

4. Click Save to save any changes.
5. You add, remove, disable, and enable document categories for the group in the Document Category section.

When you disable a single category associated with a document group, that category and its subcategories
continue to display for existing attachments, but are unavailable for new attachments.

To modify a document category, you must go to the Document Category definition pages. See Setting Up
Document Categories and Subcategories.

Note:  If you disable a category on the Document Category Details page, but it’s still included in the list of
enabled categories for a document group, it will continue to be available in the prompt list for attachments.

Deleting Document Groups
You can't delete categories and subcategories if they are already referenced on an uploaded attachment.

1. Select Common Setup > Document Group.
2. On the Document Group page, select the row for the group that you want to delete.
3. Click Delete on the Document Group Details page.
4. If you want to delete multiple document groups, you can delete them on the Document Group page:

a. Click Edit.
b. Select the check boxes for the document group rows to delete.
c. Click Delete.

5. To delete a document category from the group, click the Delete icon for the document category row in the
Document Category section.
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Setting Up the Twilio Security Endpoint  
This topic discusses how to enable and set up the Twilio security endpoint for text message communications.

Text communications through Twilio is an optional feature provided in Oracle Functional Setup Manager (FSM). Before
configuring this feature, you must first enable it.

Enabling the Twilio Integration
1. Access FSM by selecting Setup and Maintenance in the navigator.
2. Select a Oracle Permitting and Licensing offering such as Public Sector Permits or Public Sector Planning and

Zoning.
3. Click the Change Feature Opt In link.
4. Click the Features icon for the System Administration functional area.
5. Click the Enable check box for the Text Communications through Twilio feature.

Note:  You can deselect the Enable check box to disable the Text Communications through Twilio feature.

Configuring the Twilio Security Endpoint
Once the Twilio integration is enabled, you can configure the Twilio security endpoint on the Manage Twilio Security
Endpoint page.

1. Access FSM by selecting Setup and Maintenance in the navigator.
2. Select a Oracle Permitting and Licensing offering such as Public Sector Permits or Public Sector Planning and

Zoning.
3. Select the System Administration functional area.
4. In the Show field, select All Tasks.
5. Select the Manage Twilio Security Endpoint task.
6. On the Manage Twilio Security Endpoint page, enter information for the following fields:

Page Element Description

URL
 

Enter the URL to access Twilio’s token endpoint. This should include the host and the context
root information. Use the sandbox endpoint for testing and then use the live URL when you go
live.
 

Security Policy
 

Select the applicable token from the drop-down list.
 

Username
 

Enter the API client_id value for your Twilio endpoint account.
 

Password Enter the Twilio endpoint API secret code for your Twilio endpoint account.
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7. Click Save and Close to save the configuration and return to the Setup page.

Delivered Communication Events  
Oracle Permitting and Licensing delivers a robust registry of communication events that are triggered by transactions
and processes within the application. You can view a partial list of communication events and descriptions in this topic.

The delivered communication events are found on the Communication Events page. In the Navigator, select
Communication Setup > Communication Events. Click a communication event row to open the event details and
create a template. For more information, see Setting Up Communication Templates.

Communication Record Details

Communication Event Name Communication Description

Web Form Response
 

Notifies agency staff that an applicant has responded to a web form questionnaire. This
communication event requires template setup.
 

For more information on web form questionnaires, see Working with Communications.

Contacts Communications

Communication Event Name Communication Description

Permit Contact Added to Application
 

Generates a notification that is sent to contacts when a permit application is submitted.
 

Permit Additional Contact Added
 

Generates a notification to contacts added to a permit application after it has been submitted.
 

Planning and Zoning Contact Added to
Application
 

Generates a notification that is sent to contacts when a planning application is submitted.
 

Planning and Zoning Additional Contact
Added
 

Generates a notification to contacts added to a planning application after it has been submitted.
 

These notifications require the Send Communication action for the delivered Business Rules Framework events and the
email template for the Communication Events in this table. For more information, see Setting Up Send Communication
Actions.

In the templates, use the Contact and Contact Type attributes to address the email. For more information, see Using
Attributes in Communication Templates.
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Expiration Communication Resources

Communication Event Name Communication Description

About to Expire Permit
 
Expired Permit
 

Generates a notification when a permit is about to expire or expired.
 
For example, when the permit is about to expire or expired, the agency staff and the contact listed on
the application receive a notification.
 

Permit About to Expire Based on
Inspection Commencement
 
Permit Expired Based on Inspection
Commencement
 

Generates a notification when a permit is about to expire or expired due to inactivity, because the first
inspection hasn’t been scheduled or passed.
 
For example, when a permit is about to expire or expired due to inactivity because the first inspection
hasn’t commenced, the agency staff and the contact on the application receive a notification.
 

About to Expire Planning and Zoning
Application
 
Expired Planning and Zoning Application
 

Generates a notification when the planning application is about to expire or expired.
 
For example, when the planning application is about to expire or expired, the agency staff and the
contact listed on the application receive a notification.
 

About to Expire Pre-Application
 
Expired Pre-Application
 

Generates a notification when the pre-application is about to expire or expired.
 
For example, when the pre-application is about to expire or expired, the agency staff and the contact
listed on the application receive a notification.
 

About to Expire Business License
 
Expired Business License
 

Generates a notification when the business license is about to expire or expired.
 
For example, when the business license is about to expire or expired, the agency staff and the contact
listed on the application receive a notification.
 

For more information about permit and planning application expiration, see Expiration Overview and Working with
Application Expiration.

Communication Event Name Communication Description

About to Expire Business License
 
Expired Business License
 

Generates a notification when a business license is about to expire or expired.
 
For example, when the business license is about to expire or expired, the agency staff and the contact
listed on the application receive a notification.
 

About to Expire Business License
Consultation
 
Expired Business License Consultation
 

Generates a notification when a business license consultation is about to expire or expired.
 
For example, when the business license consultation is about to expire or expired, the agency staff and
the contact listed on the application receive a notification.
 

For more information about business license and business license consultation expiration, see Viewing Business License
Expiration.
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Fee Communications

Communication Event Name Communication Description

New Fees Due
 

When agency staff manually adds a new fee, the applicant receives a notification that new fees have
been assessed and are due.
 

Scheduled Rule: Updated Permit Fees Due
 

Generates a communication when the fees for a permit in a Due status are added or changed, the fee
status is changed to Due, or a fee amount that is due is recalculated or changed.
 
Use this event with scheduled rules to send communications that consolidate the fees for a permit.
 

Scheduled Rule: Updated Planning
Application Fees Due
 

Generates a communication when the fees for a planning application in a Due status are added or
changed, the fee status is changed to Due, or a fee amount that is due is recalculated or changed.
 
Use this event with scheduled rules to send communications that consolidate the fees for a planning
application.
 

For more information on manually adding a fee item, see Working with Fees and Payments.

For more information on sending communications with consolidated fees, see Setting Up Scheduled Rules in the
Business Rules Framework and Setting Up Fee Notices.

Generic Alert Resource

Communication Event Name Communication Description

General Alerts
 

Text was created to appear in the banner of the Agency Springboard or the landing pages for
anonymous and registered users.
 

When setting up the template for the General Alerts communication event, use only the Alert channel type. You don't
use the Alert channel type in a template for any other communication event.

For more information about generic alerts, see Defining Alerts.

Inspections
The following communication events are provided for permit inspections.

Note:  This resource and events are registered with the Business Rules Framework. For more information, see
Business Rules Framework Overview and Setting Up Business Rules.

Communication Event Name Communication Description

Final Inspection Passed
 

Generates a notification when an inspector submits the final inspection for a permit with a passing
result.
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Communication Event Name Communication Description

For example, when an inspector submits the final inspection for a permit with a passing result, the
permit technician or applicant receives a notification.
 
For more information about performing inspections, see Overview of Mobile Oracle Inspector for
Permits.
 

Inspection Canceled
 

Generates a notification when the applicant or agency staff cancel an inspection.
 
For example, when the applicant or agency staff cancel an inspection, the applicant, inspection
contact, inspector, and inspection supervisor can receive a notification.
 
For more information, see Managing Inspections for an Agency and Managing Inspections for a Permit.
 

Note:
This event is also triggered when the permit associated with an inspection is withdrawn or expires.
 

Inspection Complete
 

Generates a notification when the inspector completes an inspection and submits the inspection
results or when inspections are updated from Scheduled to Completed status.
 
For example, when the inspector completes any inspection and submits the inspection results, the
applicant or agency staff receive a notification that the inspection is complete, regardless of the
inspection result.
 
For more information about performing inspections, see Overview of Mobile Oracle Inspector for
Permits.
 

Inspection ETA Updated
 

Generates a notification when the inspector updates the estimated time of arrival at an inspection site.
 
For example, when the inspector updates the estimated time of arrival at an inspection site for a
scheduled inspection, the contact at the inspection location receives a notification.
 
For more information about performing inspections, see Overview of Mobile Oracle Inspector for
Permits.
 

Inspection Requested
 

Generates a notification when an inspection has been requested.
 
For example, when an inspection request has been created, the permit technician can receive an email
notification.
 
For more information about requesting inspections, see Requesting Inspections.
 

Inspection Rescheduled
 

Generates a notification when the applicant or agency staff reschedule an inspection.
 
For example, when the applicant or agency staff reschedule an inspection, the applicant, inspection
contact, inspector, and inspection supervisor can receive a notification.
 
For more information about rescheduling an inspection, see Assigning Inspections Using the
Supervisor Calendar and Requesting Inspections.
 

Inspection Scheduled
 

Generates a notification when an inspection has been scheduled and assigned to an inspector.
 
For example, when the inspection has been scheduled and assigned to the inspector, the inspector and
inspection contact can receive an email notification.
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Communication Event Name Communication Description

For more information about assigning an inspection, see Assigning Inspections Using the Supervisor
Calendar.
 

Oracle Intelligent Advisor Anonymous Results

Communication Event Name Communication Description

Anonymous Results Save
 

The anonymous public user receives an email with the results of recommended permits after
submitting the permit guide questionnaire.
 

For more information about the Permit Guide for anonymous public users, see Setting Up the Landing Page for
Anonymous Users.

Payment History Resource

Communication Event Name Communication Description

Payment Received
 

A successful payment triggers a notification configured using an email template.
 

Permit Document Attachments

Communication Event Name Communication Description

Permit Document Attached
 

Notifies agency staff when a document was uploaded by a contact with permit access for a permit
when plan review or inspection information is not relevant.
 

Permit Document Attached for Inspector
 

Notifies inspectors that a document was uploaded for a permit inspection.
 

Permit Document Attached for Plan
Coordinator
 

Notifies plan coordinators that a document was uploaded for a permit plan review cycle.
 

Permit Document Attached for Plan
Reviewers
 

Notifies plan reviewers that a document was uploaded for a permit plan review cycle.
 

Permit Document Attached for Inspection
Supervisor
 

Notifies inspection supervisors that a document was uploaded for a permit inspection.
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Planning Application Document Attachments
Note:  The Planning Application Document and Planning Application Plan Review Document resources and events
are registered with the Business Rules Framework. For more information, see Business Rules Framework Overview and
Setting Up Business Rules.

Communication Event Name Communication Description

Planning Application Document Attached
 

Notifies agency staff when the applicant uploads a planning application document.
 
The Planning Application Document resource contains planning application header data for
communication template setup including these attributes: Assigned Planner and Created By in
the Email, User Name, and User ID attribute groupings. There are no plan review attributes in the
communication template or in the Business Rules Framework criteria.
 

Planning Application Document Attached
for Plan Reviewers
 

Notifies plan coordinators and plan reviewers when the applicant uploads a planning application
document for plan review.
 
The Planning Application Plan Review Document resource contains planning application plan review
cycle and reviewer data for communication template setup including these attributes: Assigned
Planner and Plan Check Coordinator in the Email, User Name, and User ID attribute groupings; and
Plan Reviewer List in the Email and User ID attribute groupings. The communication template and
Business Rules Framework criteria include plan review cycle attributes.
 

Permits Workflow Communications

Communication Event Name Communication Description

Workflow 001
 
Workflow 002
 
Workflow 003
 
Workflow 004
 
Workflow 005
 

These delivered events are not associated with specific actions in the Public Sector system. Instead,
they are generic events that are delivered for use with workflow. For example, you can use these events
when configuring workflow to send notifications related to permit status changes.
 
When you set up workflow in the Oracle Integration Cloud, you implement notifications by creating
a workflow event that sends a communication event name, template name, and permit ID to the
Communication Center. The Communication Center then takes care of sending the notification.
 
See Setting Up Process Definitions for Workflow.
 

Planning and Zoning Workflow Communications

Communication Event Name Communication Description

PNZ Workflow 001
 
PNZ Workflow 002
 
PNZ Workflow 003
 
PNZ Workflow 004
 

These delivered events are not associated with specific actions in the Public Sector system. Instead,
they are generic events that are delivered for use with workflow. For example, you can use these events
when configuring workflow to send notifications related to planning application status changes to
applicants and owners.
 
When you set up workflow in the Oracle Integration Cloud, you implement notifications by creating a
workflow event that sends an communication event name, template name, and planning application ID
to the Communication Center. The Communication Center then takes care of sending the notification.
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Communication Event Name Communication Description

PNZ Workflow 005
 

 
See Setting Up Process Definitions for Workflow.
 

Plan Review
The following communication events are provided for plan reviews.

Note:  This resource and events are registered with the Business Rules Framework. For more information, see
Business Rules Framework Overview and Setting Up Business Rules.

Communication Event Name Communication Description

Permit Plan Review Finalized
 

Generates a communication when a permit plan review is finalized.
 

Permit Plan Review Ready To Finalize
 

Generates a communication when a permit plan review is ready to be finalized.
 

Permit Plan Review Completed or
Canceled
 

Generates a communication when a permit plan review is completed or canceled.
 

Note:
This event is also triggered when the permit associated with a plan review is withdrawn.
 

Planning Plan Review Finalized
 

Generates a communication when a planning application plan review is finalized.
 

Planning Plan Review Plan Review Ready
To Finalize
 

Generates a communication when a planning application plan review is ready to be finalized.
 

Planning Plan Review Completed or
Canceled
 

Generates a communication when a planning application plan review is completed or canceled.
 

Note:
This event is also triggered when the planning application associated with a plan review is
withdrawn.
 

Permit Plan Review Cycle Due Date
Scheduled Event
 

Generates a communication when the plan review cycle due date approaches for a permit.
 
This communication can be sent to all of the plan reviewers, the person who created the plan review, or
to a manually entered email value.
 

Permit Plan Review Department Due Date
Scheduled Event
 

Generates a communication when the plan reviewer due date approaches for a permit.
 

Planning Plan Review Cycle Due Date
Scheduled Event
 

Generates a communication when the plan review cycle due date approaches for a planning pre-
application or planning application.
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Communication Event Name Communication Description

This communication can be sent to all of the plan reviewers, the person who created the plan review, or
to a manually entered email value.
 

Planning Plan Review Department Due
Date Scheduled Event
 

Generates a communication when the plan reviewer due date approaches for a planning pre-
application or planning application.
 

For more information about plan review communications, see Managing Plan Review Cycles.

Business License
Business license communication events enable agencies to automatically send communication when the business
license status changes. You need to set up Workflow tasks and the communication template to trigger communication
events. The following communication events are provided for business licenses.

Note:  This resource and events are registered with the Business Rules Framework. For more information, see
Business Rules Framework Overview and Setting Up Business Rules.

Communication Event Name Communication Description

Business Consultation Meeting Canceled
 

Notifies that the consultation meeting is canceled.
 

Business Consultation Meeting Scheduled
 

Notifies that the consultation meeting is scheduled on a tentative date.
 

Business Consultation Meeting Updated
 

Notifies when there is a change in the meeting subject, agenda, duration, or location.
 

Business Consultation Meeting Remove
Invitees
 

Notifies that the invitee has been removed from the meeting.
 

Business Consultation Meeting
Rescheduled
 

Notifies that the consultation meeting is rescheduled on a tentative date.
 

Business Consultation Meeting Invitee
Added
 

Notifies that the invitee has been added to the consultation meeting.
 

Business License Canceled
 

Applicant receives email or alert notification when a business license is canceled.
 

Business License Withdrawn
 

Applicant receives email or alert notification when a business license is withdrawn.
 

Business License Application and
Consultation Updated
 

Initiates actions when a business license or consultation application is updated.
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Code Enforcement
The following communication events are provided for code enforcement.

Note:  This resource and events are registered with the Business Rules Framework. For more information, see
Business Rules Framework Overview and Setting Up Business Rules.

Communication Event Name Communication Description

Incident Location Updated
 

The location of the incident is updated.
 

Incident Assigned to Officer
 

The incident is assigned to an officer.
 

Incident Priority Updated
 

The priority of the incident is updated.
 

Incident Status Updated
 

The status of the incident is updated.
 

Incident Assigned to Technician
 

The incident is assigned to a technician.
 

Case Created
 

The case is created.
 

Case Location Updated
 

The location of the case is updated.
 

Case Status Updated
 

The status of the case is updated
 

Responsible Party's Case Access Updated
 

Responsible party's access to case is approved or denied.
 

User Profile Notifications
The User Profile Notifications resource provides the following communication events.

Communication Event Name Communication Description

User Account Information Changed
 

Notifies a public user when the user's account is updated by agency personnel.
 

Contractor License Verification Failed
 

Notifies a public user that the contractor's license could not be verified.
 

Contractor License Verification Pending
 

Notifies a public user that the contractor's license verification is pending.
 

Contractor License Verification Passed
 

Notifies a public user that the contractor's license has been verified.
 

License Verification Failed
 

Notifies a public user that the license could not be verified.
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Communication Event Name Communication Description

License Verification Pending
 

Notifies a public user that the license verification is pending.
 

License Verification Passed
 

Notifies a public user that the license has been verified.
 

User Profile Information Changed
 

Notifies a public user when the user's account profile is updated by agency personnel.
 

Setting Up Communication Templates  
Communication events trigger delivery of different communication types to various users. The agency defines the
content, format, and recipients using communication templates.

Agency users add, modify, and delete communication templates on the Communication Event Details page.

The communication events themselves are delivered with Oracle Permitting and Licensing. For a partial list of the
available communication events, see Delivered Communication Events.

Adding Communication Templates
1. Select Communication Setup > Communication Events in the navigator.
2. Click the event on the Communication Event page for which you want to add a template.
3. On the Communication Event Details page, click Add in the Communication Template section.
4. On the Communication Template Details page, enter a unique identifier code and name for the communication

template.

To make the code unique, Oracle recommends that you create it using a portion of the communication event
name. For example, you might use SUB01 for the email template of the Application Submit communication
event. This is because communication template codes must be unique across all communication events. If you
create a communication template for one event that has the same code as a template for another event, you
will receive an error when you try to save it.

5. Enter values or click Insert (+) and choose from the list to set up the template:

Page Element Description

Channel Type
 

Specify the type of communication that this template generates. Values are:
 

◦ Alert: Generates text that is displayed to users when they log in to the application.

Note:
You only use this channel type when setting up the General Alert (PSC_GENERIC_ALERT)
communication event.
 

◦ Email: Generates an email that is sent to users.

◦ Emails and Notifications: Generates both an email and a notification with the same
message.
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Page Element Description

◦ Notification: Generates a notification that appears when users click the notification icon in
the application.

◦ Text: Generates a short message service (SMS) text message that is sent to users.
Currently, the text channel type is available only for ad hoc communications. Text for
events will be supported in the future.

Note:
The fields that are available to define on this page vary depending on the channel type and
display format that you select.
 

Visibility
 

Select which users can see this communication listed on the application's Communication
Details page. All communications can be accessed by agency staff. Values are:
 

◦ Applicant and contacts: Includes agency staff, the applicant, and contacts added to the
transaction.

◦ Agency staff only: Includes only agency staff.

◦ Applicant: Includes agency staff and the applicant on the transaction.

Enabled
 

Turn this switch on to activate the communication template. When this switch is turned off, the
application does not generate the communication when the associated event is triggered.
 

Start Date Time and End Date Time
 

Enter the time period for which the alert is displayed. These fields appear only for the Alert
channel type.
 

Display Format
 

Select the format of the email or notification that this communication template generates.
Values are:
 

◦ HTML: Displays rich text, links, and images

◦ Text: Displays plain, unformatted text.

This field appears only for the email or notification channel types.
 

Priority
 

Turn on this switch to display notifications generated by this communication template at the
top of the notification list.
 
This field appears only for the Emails and Notifications and Notification channel types.
 

User Can Delete
 

Turn on this switch to enable users to delete notifications generated by this communication
template from their notification lists.
 
This field appears only for the Emails and Notifications and Notification channel types.
 

Add Attribute
 

These fields enable you to insert variables for attributes into your communications. You select
the field and the attribute that you want to insert in that field, and click Insert to enter a variable
for that attribute.
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For more information about inserting variables for attributes, including resource and contact
attributes, see Using Attributes in Communication Templates.
 

Add Grid
 

Add a grid with attributes from a related resource in the message body.
 
This button appears only for the email and notification channel types, and the display format
must be HTML.
 
For more information, see Using Attributes in Communication Templates.
 

To
 

 

Click the Insert button to view a drop-down menu from which you can search for and select
recipients. The display shows the options and the count of values available, which are
determined by the transaction you are working with and the channel type you selected in the
Template Attributes section.
 
For example, when you select a value here for the email channel type, the email ID is inserted
into the field. You can delete the ID using the X icon, but you cannot edit it.
 
Enter or click + and select the email addresses, user IDs, or phone numbers of the people or
organizations that you want to send the communication to.
 
Enter email addresses for the Email and Emails and Notifications channel types; user IDs for
the Alert, Emails and Notifications,  and Notification channel types; and phone numbers for the
Text channel type.
 

Cc and Bcc
 

 

Enter or click + and select the email addresses of the people or organizations that you want to
receive a copy or blind copy of the communication.
 
These fields appear only for the Email and Emails and Notifications channel types.
 

From
 

 

Enter or click + and select the email address, user ID, or phone number of the person or
organization who is sending the generated message.
 
For texts, select the phone number of the person or organization who is sending the generated
text message from the drop-down list. The numbers are retrieved from Twilio, a third-party
messaging service.
 

Subject
 

 

Enter a brief description of the purpose and content of the communication, or click + and select
from the list of transaction attributes.
 
This field appears only for email or notification channel types.
 

Message Body
 

Enter the main body text of the communication.
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For the Alerts and Text channel types and emails and notifications using the Text display
format, you can enter only plain, unformatted text.
 
For emails and notifications using the HTML display format, you can enter rich text, links, and
images, or click + and select from the list of transaction attributes.
 

Remarks
 

Enter any additional information about the communication template. These remarks are not
included in the generated communication.
 

6. Click Save.

Modifying Communication Templates
1. Select Communication Setup > Communication Events.
2. Click the row on the Communication Event page for which you want to modify a template.
3. Click the row in the Communication Template grid that you want to modify.
4. On the Communication Template Details page you can:

◦ Click Clone to create a copy of the communication template.

◦ Update the communication template field values.

Note:  You cannot edit the Code or Channel Type fields.

5. Click Save.

Deleting Communication Templates
1. Select Communication Setup > Communication Events.
2. Click the row on the Communication Event page for which you want to delete templates.
3. Click Edit in the Communication Template grid.
4. Select the check boxes next to all of the communication templates that you want to delete.
5. Click Delete. You will be prompted to confirm the permanent deletion.

Using Attributes in Communication Templates  
You can add attributes to your communication templates when defining the recipients and content.

You insert attributes into your communication templates on the Communication Event Details page, which you access
by selecting an event from the list on the Communication Event page. You can select from attributes in the resource for
the event you're working with, contact type attributes, and additional attributes available from other resources.

Note:  Contact type attributes are not available for ad hoc emails, notifications, and texts in the Communication
Center because the communication must be associated with a transaction to populate contacts. Parent resource
attributes from an event are also not available in the ad hoc communications template in the Communication Center.

146



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 12
Setting Up Communications

The endpoint attributes of communication service REST APIs correspond to the variables you use to set up a
communication template. For a reference document that directs you to the endpoint attributes and their descriptions
in the REST API documentation, see Public Sector Communication Services Endpoints Catalog (Doc ID 2755859.1) in My
Oracle Support.

Adding Predefined Variables for Attributes
When you create a template, you can insert variables for attributes into the message fields. Predefined variables for
attributes are available to use for communications associated with any event. For example, using the contact types in
the communication template, you can send communication to the contacts listed on the application.

You insert attributes listed under Resource attributes to retrieve values you find in fields on applications that are
referenced in the parent resource. Contact type attributes are especially designed to gather contact information from
applications referenced in the resource of the selected event.

1. On the Communications Event Details page, go to the Add Attributes fields.
2. Select the field and the attribute that you want to add to the field.
3. Click Insert.

For example, if you select Body and the Permit ID attribute, and click Insert, the ${Permit ID} variable is inserted into
the Message Body field of the communication template. When the application generates a communication using the
template with the variable attribute, the permit ID that is associated with the triggered communication event is inserted
into the body text.

Here’s an example of a letter template and the output:

Example Expressions with Variable
Attributes

Output

Dear ${Payer First Name} ${Payer Last
Name},
 
 
Thank you for your payment of
${CommunicationUtils.format('amount',
${Payment Amount},'9,999,999.99')} for
permit ${Permit Id}, which was received
on ${CommunicationUtils.format('date’,
${Payment Date})}.
 
 
If you have any questions please contact
the office between 9:00 a.m. and 4:30
p.m., Monday through Friday.
 

Dear John Smith,
 
 
Thank you for your payment of $835.00 for permit REM-2017-000035, which was received on 15-
AUG-2017.
 
 
If you have any questions please contact the office between 9:00 a.m. and 4:30 p.m., Monday through
Friday.
 

The communication engine supports the following predefined functions for variable attributes in your templates.

Function Description Variable Attribute Output

Current Date
 

Returns the system date in the
agency time zone without the time.
There is no need to use the format
utility.
 

${Current Date}
 

For example, 2016-04-25.
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Note:
The Current Date is internally
formatted using the
formatDate() function based on
the agency time zone. Using an
additional formatDate() function
causes an error.
 

Current Date Time
 

Returns the system date in the
agency time zone with the time.
There is no need to use the format
utility.
 

Note:
The Current Date Time is
internally formatted using the
formatDate() function based on
the agency time zone. Using an
additional formatDate() function
causes an error.
 

${Current Date Time}
 

For example, 2016-04-25
23:44:52.0.
 

Format Number
 

Formats the number to the given
format. The formats supported are
Java Number Formats.
 

${CommunicationUtils.format('number',
 ${Fees Total Amount},'###,###,
###')}
 
To support backward compatibility,
 the following format is currently
available:
 
${CommunicationUtils.formatNumber($Amount,
 '9,999,999')}
 

For example, 46,064.
 

Format Date and Time
 

Formats the date and time in the
agency time zone with the given
format. The supported formats use
Java Simple Date Format.
 

Example 1:
${CommunicationUtils.format('datetime',
${Creation Date},'yyyy-MM-dd
HH:mm:ss')}
 
Example 2:
${CommunicationUtils.format('datetime',
${Creation Date})}
 
Example 3:
${CommunicationUtils.format('date',
${Creation Date},'yyyy-MM-dd')}
 
To support backward compatibility,
 the following formats are currently
available:
 
Example 4:
 
${CommunicationUtils.formatDate(${Creation
Date},'yyyy-MM-dd HH:mm:ss')}
 
Example 5:
 

Example 1 output: 2019-11-22
20:04:00.
 
Example 2 output: 11/22/19 8:04
PM.
 
Example 3 output: 2019-11-22
 
Example 4 output: 2019-11-22
20:04:00
 
Example 5 output: 11/22/19
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${CommunicationUtils.formatDate(${Creation
Date})}
 

Format Amount
 

Formats the amount into the
default local currency format.
 

Example 1:
${CommunicationUtils.format('amount',
${Fees Total Amount})}
 
Example
2: ${CommunicationUtils.format('amount',
${Fees Total Amount},'en_US')}
 
To support backward compatibility,
 the following format is currently
available:
 
Example 3:
 
${CommunicationUtils.formatAmount(${Amount})}
 

All the examples produce the
output: $1,345,667.00
 

Link
 

Provides the hyperlink from the
message.
 

Input is expected to be the link
URL and the label that you want to
display:
 
${CommunicationUtils.format('url',
${URL},${Label})}
 
${CommunicationUtils.format('url',
${URL},’Setting Up Communication
Events’)}
 
To support backward compatibility,
 the following format is currently
available:
 
${CommunicationUtils.setLink(${Url},
${Label})}
 

The examples produce the output:
Setting Up Communication
Templates.
 

Add Grid
 

Inserts a table in the message body
 

This applies to specific
communication templates where
the Add Grid functionality is
enabled.
 
${CommunicationUtils.format('grid',
'publicSectorFeeDues',
'Assessed Date, Currency
Code','${AssessedDate},
${FeeCurrencyCode}')}
 
To support backward compatibility,
 the following format is currently
available:
 
${CommunicationUtils.insertGrid('publicSectorFeeDues',
'Assessed Date, Currency
Code','${AssessedDate},
${FeeCurrencyCode}')}
 

Inserts a table inside the
communication message.
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Guidelines for Using Formatting Functions
When you are creating or updating communication templates, follow these guidelines to review and edit the usage of
the formatting functions such as setLink(), formatAmount(), formatDate(), and insertGrid() in the message:

• Creating New Template: You must use only format() functions as defined in the above table.

• Updating Existing Template: Currently, the system supports single references to these formatting functions
for a given communication. The communication will not be triggered if there are multiple usages of these
formatting functions within the communication definition. So, to avoid any errors in the communication
delivery, you must update the templates to ensure the usage of only format() functions.

• Nesting format() functions: Currently not supported.

• Format() to display grid: This is a special format function that handles the date and amount attribute formatting
as per agency setup options. So, there is no additional format() allowed for grid attributes.

• Using the $ symbol in message: To include a ‘$’ character into the message text, you prefix the ‘$’ with the
character ‘\’ (backslash key). This enables the communication processor to read the ‘$’ character as a string,
and not as an attribute.

Using Contact Type Attributes
After your agency sets up contact types, you can insert variables for contact type attributes when composing
communications for contacts by type, as well as for primary contacts or all contacts. For example, you might set up the
system to send contractors a copy of the email sent when a permit or planning application is withdrawn. In this case,
you would create a template for a withdrawn event with an Email or Emails and Notifications channel type, and insert
the email variable for the Contractor contact type attribute in the email Cc field. You can insert variables for contact
attributes into the address fields as well as the subject line and message body.

Here are the available contact type attributes and examples of the variables:

• Email: Inserts a variable for the email address of contacts with the specified contact type. Select this attribute to
send emails. This example shows the variable for email addresses of all contacts:

${CommunicationUtils.format('contact','publicSectorApplicationContactTypes','AllContacts','${ContactEmailAddress}')},

• Phone: Inserts a variable for the phone number of contacts with the specified contact type. Select this attribute
to send texts. This example shows the variable for phone numbers of primary contacts:

${CommunicationUtils.format('contact','publicSectorApplicationContactTypes','Primary

Contact','${ContactPhoneNumber}')},

• User ID: Inserts a variable for the user ID of contacts with the specified contact type. Select this attribute to
send notifications. This example shows the variable for user IDs of contractors:

${CommunicationUtils.format('contact','publicSectorApplicationContactTypes','Contractor','${ContactUserId}')},

• User Name: Inserts a variable for the name of contacts with the specified contact type. You can select this
attribute to insert the user's name in the message body to personalize the communication, such as "Dear
Linda." This example shows the variable for user names of business owners:

${CommunicationUtils.format('contact','publicSectorApplicationContactTypes','Business

Owner','${ContactUserName}')},

For information about setting up contact types, see Setting Up Contact Types.
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Inserting Additional Attributes in Templates
Some attributes are available across resources for you to use when creating templates. You can insert a grid in the
message body that contains the additional attributes. This option is available only for events in the Permits Workflow
Communication resource. Formatting is not supported for related resource attributes.

The data for the attributes are displayed in the generated communication as a table. To add the grid to your template:

1. Select Communication Setup > Communication Events in the Navigator.
2. On the Communication Event page, select an event in the Permits Workflow Communication resource for which

you want to add a template.
3. Click Add in the Communication Template grid on the Communication Event Details page.
4. Set up the communication properties as described in Setting Up Communication Templates.

You must use the Emails, Emails and Notifications, or Notification channel type, and the MIME type must be
HTML to render the grid in the generated communication.

5. Click Add Grid.
6. On the Define Grid Attributes page, select up to 5 attributes that you want to appear in the generated table. The

attribute source name appears on the page.
7. Click Insert Grid in Message.

For example, if you select the Fee Description, Fee Item, and Fee Record attributes, and click Insert Grid in Message, the
following is inserted into the Message Body field of the communication template:

${CommunicationUtils.format('grid','publicSectorFeeDues','Fee Description,Fee Item,Fee

Record','${Feedescription},${FeeItemId},${FeeRecordKey}')}

Each attribute name is displayed in the generated email or notification as a column title, and record values populate
each row. If you want to change the order of the columns, you can manually move the attributes around in the template.

Setting Up Fee Notices  
Agencies can set up fee notices for permit and planning applications containing a combined list of fees due to be sent
on a regular basis.

The automated process sends notices with fees for an application consolidated into a list in each notification. Every time
a fee with a Due status is added or recalculated, the application is identified as updated in the system. The notice with
combined fees is sent out to the designated recipient on the schedule you define.

Fees are added to the notice for an application based on the date when:

• A fee with a Due status is added or changed.

• The fee status is changed to Due.

• The amount of a fee with a Due status is recalculated or changed.

You'll need a communication template with a fees grid for the notice, scheduled rules setup in the Business Rules
Framework, and processing instructions for communication frequency.
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Create a Communication Template
You set up a communication template specifically for the consolidated fees notice using designated communication
events and variables for fee attributes:

1. On the Communication Event page, select the Scheduled Rule: Updated Permit Fees Due or Scheduled Rule:
Updated Planning Application Fees Due communication event to create the template.

For more information, see Setting Up Communication Templates.
2. In the message body, insert variables for fee attributes in a grid format. Click Add Grid and select the fee due

attributes, such as Fee Item, Assessed Date, and Amount.

For more information, see "Inserting Additional Attributes in Templates" in Using Attributes in Communication
Templates.

Set Up a Scheduled Rule
You configure a scheduled rule in the Business Rules Framework that identifies the permit or planning application for
which the fee is updated and specifies the communication template to use. For more information about setting up
scheduled rules, see Setting Up Scheduled Rules.

After you create a communication template, set up the rule:

1. Select the Scheduled Rules tile in the Business Rules Framework and select a business objects, Permits
Workflow Communications or Planning and Zoning Workflow Communications.

2. Add the following criteria in the Criteria section of the rule to identify the permit or planning application for
which the fee is updated in the defined time frame:

◦ Fees Balance Due > 0 (includes only due fees) or

Fees Outstanding Balance > 0 (includes both due and pending fees)

◦ Fees Due Updated Date = ${Current Date} (for daily notices) or

Fees Due Updated Date ≥ ${Current Date} - 7 (for weekly notices)

Note:  You must enter both criteria to avoid notices sent whether fees are updated or not.

For more information, see Setting Up Business Rule Criteria.
3. In the Action section of the rule, select Send Communication and configure the action to use the template you

already created. For more information, see Setting Up Send Communication Actions.

Set Up a Scheduled Process
The Process Monitor uses the scheduled rule set up in the Business Rules Framework to initiate batch processing on a
regular basis. The process checks for any change in fee items with a status of Due for a permit or planning application
and sends the communications on the schedule you define here.

After you configure the communication template and rule, set up processing instructions for the rule:

1. To schedule the rule directly in the Process Monitor from the Business Rules Framework, click the Schedule
Rules link on the Scheduled Rule Details page. You can also use the Process Monitor link to set up a new
Schedule Rules process or see all of the scheduled and running processes.
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2. Enter values on the Schedule Rules page:

Tab Values

Parameters
 

Select the scheduled rule that you set up in Business Rules Framework.
 

Schedule
 

Run: Using a schedule
 
Frequency for daily notices: Daily and Every 1 Day
 
Frequency for weekly notices: Weekly and Every 1 Week
 
Start and End Date: Enter agency-determined values
 

Notification
 

Not applicable
 

3. Click Submit.

For more information about using the Process Monitor, see Using the Process Monitor.

Setting Up Notifications for Plan Review Due Dates  
You can set up communications to notify reviewers and plan coordinators about plan review cycle or department due
dates. Your emails and notifications for planning applications can also include the assigned planner.

Configure a communication template and scheduled rule to send either an in-app notification or email, on or before
the plan review due date. You can also configure the rule to schedule communications after the due date for overdue
reviews. The Business Rules Framework uses scheduled rules based on the plan review cycle due date and reviewer due
dates to determine when a communication is sent.

Communication Templates
Communication events work in conjunction with the scheduled rule in the Business Rules Framework to send the
notifications. Before you configure the scheduled rule, set up the communication templates for the delivered plan
review due date events.

Communication Event Description

Permit Plan Review Cycle Due Date
Scheduled Event
 

Generates a communication when the plan review cycle due date approaches for a permit.
 
This communication can be sent to all of the plan reviewers, the person who created the plan review, or
a manually entered email value.
 

Permit Plan Review Department Due Date
Scheduled Event
 

Generates a communication when the plan reviewer due date approaches for a permit.
 
This communication can be sent to all of the plan reviewers, the person who created the plan review, or
a manually entered email value.
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Communication Event Description

 

Planning Plan Review Cycle Due Date
Scheduled Event
 

Generates a communication when the plan review cycle due date approaches for a planning pre-
application or planning application.
 
This communication can be sent to all of the plan reviewers, the person who created the plan review,
 the assigned planner, or a manually entered email value.
 

Planning Plan Review Department Due
Date Scheduled Event
 

Generates a communication when the plan reviewer due date approaches for a planning pre-
application or planning application.
 
This communication can be sent to all of the plan reviewers, the person who created the plan review,
 the assigned planner, or a manually entered email value.
 

For sending notifications based on plan review cycle due dates, refer to the template attributes for plan check
coordinators and reviewers here:

Template Attribute Name Field

Assigned Planner Email
 

The assigned planner email. Only available for the planning plan review event.
 

Assigned Planner Name
 

The assigned planner name. Only available for the planning plan review event.
 

Assigned Planner User ID
 

The assigned planner user ID. Only available for the planning plan review event.
 

Plan Check Coordinator Email
 

The Created By email.
 

Plan Check Coordinator Name
 

The Created By name.
 

Plan Check Coordinator User ID
 

The Created By user ID.
 

Plan Reviewer Email List
 

The email list of all assigned reviewers.
 

Plan Reviewer User ID List
 

The user ID list of all assigned reviewers.
 

For sending notifications based on reviewer departmental due dates, refer to the template attributes for plan check
coordinators and reviewers here:

Template Attribute Name Field

Assigned Planner Email
 

The assigned planner email. Only available for the planning plan review event.
 

Assigned Planner Name
 

The assigned planner name. Only available for the planning plan review event.
 

Assigned Planner User ID The assigned planner user ID. Only available for the planning plan review event.

154



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 12
Setting Up Communications

Template Attribute Name Field

  

Plan Check Coordinator Email
 

The Created By email.
 

Plan Check Coordinator Name
 

The Created By name.
 

Plan Check Coordinator User ID
 

The Created By user ID.
 

Plan Reviewer Email
 

The email of the reviewer on the department row.
 

Plan Reviewer Name
 

The name of the reviewer on the department row.
 

Plan Reviewer User ID
 

The user ID of the reviewer on the department row.
 

For more detailed information about configuring templates, see Setting Up Communication Templates.

Scheduled Rules
After creating templates, add new scheduled rules in the Business Rules Framework for the business objects that are
used to send plan review due date communications.

1. Select a business object:

◦ Permit Plan Review Cycle Due Date

◦ Permit Plan Reviewer Due Date

◦ Planning Application Plan Review Cycle Due Date

◦ Planning Application Plan Reviewer Due Date

2. Enter criteria.

Configure scheduled rules for each business object to include criteria for sending a notification. For example,
you can enter these criteria for a reviewer due date rule:

Criteria Sequence Field Operator Value Description

1
 

Plan Reviewer Due Date
 

Equals
 

${Current Date}+4
 

The due date is within
four days of the current
date.
 

2
 

Plan Reviewer Review
Status
 

Equals
 

In Progress
 

The review is in progress.
 

To send the communication on the day the plan review is due, enter this value in row 1: ${Current Date}.
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3. Configure the action.

Select the Send Communication action and the communication template that corresponds to the business
object.

4. Schedule the scheduled rule.

Select the rule name in the Parameters tab. On the Schedule tab, select As soon as possible in the Run field to
send the notification once. To send the notification on a regular basis, select Using a schedule in the Run field
and provide a frequency and start date.

For more information about setting up scheduled rules, see Setting Up Scheduled Rules
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13  Setting Up Analytics

Setting Up Reports  
The report parameters that you define filter the data that is generated for the reports. You can use delivered or provide
customized reports.

For reports initiated from within Oracle Permitting and Licensing, you add and modify report IDs and configuration
details, which includes adding, modifying, and deleting report parameters, on the Report Configuration Details page.
This setup doesn't apply to the reports you generate from the Report List.

For a list of delivered reports, their descriptions, and where you can find them, see Public Sector Compliance and
Regulation Analytics.

You can also create your own reports in Oracle BI Publisher and allow users to access them through the available report
generation buttons. For example, users with appropriate permissions can click the Print button on some application
pages, such as the Print Deposit Slip page or the Inspection Detail page in the permit application details.

For more information on modifying and creating analytics and reports, see the Oracle Applications Cloud
documentation: Creating and Administering Analytics and Reports.

Adding Report Configuration Details
You can add a report in addition to the delivered reports.

1. Select Common Setup > Report Configuration.
2. Click the Add button.
3. Enter values for the following fields:

Page Elements Definition

Report ID and Description
 

Enter an identifier and description of the report.
 

Path
 

Enter a path to the desired report. For example, the path for the Inspection Summary
report in the Oracle Business Intelligence (BI) Catalog is /shared/Public Sector/Inspections/
InspectionSummary.xdo.
 

Output Format
 

Select PDF or RTF to indicate the format of the generated report.
 

Report Category
 

Select a product area to classify the report.
 

4. Click Save.
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Updating Report Configuration Details
1. Select Common Setup > Report Configuration.
2. Click a report row on the Report Configuration page.
3. On the Report Configuration Details page, you can:

◦ Update the description.

◦ Enter the BI Catalog path for the report. For example, the path for the Inspection Summary report is /
shared/Public Sector/Inspections/InspectionSummary.xdo.

If you create your own report, you can point the existing report generation buttons on the application
pages to your custom report using this path.

4. Click Save.

Adding Report Parameters
1. Select Common Setup > Report Configuration.
2. Click the report row on the Report Configuration page for which you want to add a parameter.
3. On the Report Configuration Details page, click Add in the Parameters grid.
4. Enter values for the following fields:

Page Elements Definition

Parameter ID and Parameter Name
 

Enter a unique ID and name for the report parameter.
 

Parameter Data Type
 

Enter the data type for the report parameter.
 

5. Click Save.

Modifying Report Parameters
1. Select Common Setup > Report Configuration.
2. Click the report row on the Report Configuration page for which you want to modify a parameter.
3. Click the row in the Parameters grid that you want to modify.
4. On the Parameter Details page, you can:

◦ Update the report parameter field values.

◦ Delete the report parameter. You will be prompted to confirm the permanent deletion.

5. Click Save.

Deleting Report Parameters
1. Select Common Setup > Report Configuration.
2. Click a row on the Report Configuration page.
3. Click Edit in the Parameters grid.
4. Select the check boxes next to all of the report parameters that you want to delete.
5. Click Delete. You will be prompted to confirm the permanent deletion.
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Setting Up Dashboards  
You add, modify, and delete dashboard configurations on the Dashboard Configurations page.

Dashboards are a collection of analyses grouped together to return data. A dashboard contains analyses and prompts
which filter information and other objects to present on one or more pages. You can configure dashboards to display an
analysis in Oracle Permitting and Licensing by clicking the Reports and Analytics button in the global header on the
Agency Springboard, and selecting the dashboard link.

For a list of delivered dashboards and their descriptions, see Public Sector Compliance and Regulation Analytics.

Adding a Dashboard Configuration
1. Select Common Setup > Dashboard Configuration.
2. On the Dashboard Configuration page, click Add.
3. On the Dashboard Configuration Details page, enter values for the following fields:

Page Element Description

Dashboard ID
 

Enter a unique name for the dashboard.
 

Description
 

Enter a description of the dashboard
 

Path
 

Enter the Oracle Business Intelligence (BI) Catalog portal path for the dashboard. For example,
 the portal path for the Permits dashboard is %2Fshared%2FPublic%20Sector%2F_portal
%2FPublic%20Sector&page=Permits.
 

Enabled
 

Turn on this switch to activate this dashboard.
 

Default
 

Turn on this switch to make this the default dashboard.
 

Note:
Only one dashboard can be designated as the default.
 

4. Click Save.

You can access configured dashboards by clicking the Reports and Analytics button and selecting the dashboard link
in the header on the Agency Springboard.

Modifying a Dashboard Configuration
1. Select Common Setup > Dashboard Configuration.
2. Click a row on the Dashboard Configuration page.
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3. On the Dashboard Configuration Details page you can:

◦ Update the dashboard configuration field values.

Note:  You cannot edit the Dashboard ID.

◦ Delete the dashboard configuration. You will be prompted to confirm the permanent deletion.

4. Click Save.

Deleting Dashboard Configurations
1. Select Common Setup > Dashboard Configuration.
2. Click Edit.
3. Select the check boxes next to all the dashboard configurations that you want to delete.
4. Click Delete. You will be prompted to confirm the permanent deletion.

Creating and Editing Dashboards
If you are an advanced user and administrator who wants to modify and create analytics and reports, and perform
generic setup and maintenance tasks for business intelligence that apply to some or all product families, see Oracle
Applications Cloud documentation: "Analyses, Reports, and Dashboards Modification" in Creating and Administering
Analytics and Reports.

Listing of Prebuilt Analytics  
This reference points to the list of prebuilt analytics for Oracle Permitting and Licensing.

Your Permitting and Licensing applications come with a variety of prebuilt analytics for your users. Use the prebuilt
analytics right out of the box, or make a copy and modify them however you like. See the Related Topics for a link to the
analytics listing in downloadable format.

Related Topics
• Oracle Permitting and Licensing Reports and Analyses

Public Sector Compliance and Regulation Analytics  
Analyze your agency and key performance indicators with analytics, reports, and interactive dashboards, which you can
access through transactional pages, the Report List page, or the business intelligence (BI) catalog.

You can find information about the BI reports and dashboards for Oracle Permitting and Licensing here.

For a complete list of delivered analytics, see the Listing of Prebuilt Analytics.

There are different ways to view and work with your analytics and reports. You view analytics, dashboards, and reports
in the course of your work on your usual pages. You can also find them on the Report List page or in the BI catalog. For
information about using the Report List, see Generating Reports.
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To access reports on the Report List page, click the Reports and Analytics button in the global banner on the Agency
Springboard and select the Report List link. Select the BI Catalog link to access reports and dashboards in the catalog.
For information about hiding access from registered public users, see the security topics for implementation in My
Oracle Support (Doc ID 2730290.1).

This table lists the delivered reports for Oracle Permitting and Licensing and where you can find them.

Report Name Description Location

Building Permit
 

Displays permit-related information.
 

• Overview page of the permit record details

See Viewing the Permit Summary.

• Report List or BI Catalog: Shared
Folders > Public Sector > Permits

Business License Certificate
 

Displays the generated business license
certificate.
 

• Overview page of the issued business
license

See Viewing the Business License.

• Report List or BI CatalogShared Folders >
Public Sector > Business License

Case Timeline
 

Displays all the Code Enforcement events
associated with a particular case in a
chronological order.
 

• Timeline page

See Working with Case Timeline.

• Report List or BI Catalog: Shared
Folders > Public Sector > Code
Enforcement > Cases)

Cashier Session Reconciliation
 

Provides details about cashier session
reconciliation activity.
 

• Reconcile Cashier Session page

See Reconciling Cashier Sessions.

• Report List or BI Catalog: Shared
Folders > Public Sector > Billing and
Payments

Citation Notice
 

Displays information about the code violation
along with following details:
 

• Corrective actions

• Compliance date

• Appeal by date

• Citation fees

• Citation fees payment due date.

This report is sent to the party responsible for
the reported violation.
 

• Notice of Citation page

See Using the Code Technician Worklist.

• Citations page

See Working with Citations.

• Report List or BI Catalog: Shared
Folders > Public Sector > Code
Enforcement > Notices)

Conditions of Approval
 

Displays the conditions of approval associated
with a planning application, including a
description of the work, the assigned planner,
 and the conditions of approval.
 

• Conditions of Approval page

See Working with Conditions of Approval.
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Report Name Description Location

• Report List or BI Catalog: Shared
Folders > Public Sector > Planning
Application

Deposit Slip
 

Lists deposit information.
 

• Print Deposit Slip page

See Printing Deposit Slips.

• Report List or BI Catalog: Shared
Folders > Public Sector > Billing and
Payments

Inspection Activity
 

Displays all inspection activity for an agency
over a specified date range.
 

Report List or BI Catalog: Shared Folders >
Public Sector > Inspections
 

Inspection Job Card
 

Displays a record of inspections made by the
inspector, who will make notes on it and sign it
during each visit to your job site.
 

Report List or BI Catalog: Shared Folders >
Public Sector > Permits
 

Inspection Summary
 

Displays inspection-related information for the
permit.
 

• Inspection Detail page in the Oracle
Inspector mobile application

See Working with Inspection Details.

• Inspection Detail page of the permit
record details

See Reviewing Inspection Details.

• Report List or BI Catalog:   > Shared
Folders > Public Sector > Inspections

Payment Invoice
 

Displays invoice information.
 

• Invoice History page

See Viewing Invoice History.

• Report List or BI Catalog:   > Shared
Folders > Public Sector > Billing and
Payments

Payment Receipt
 

Lists payment receipt information.
 

• Payment Successful page

See Payment Flow Overview.

• Fees and Payments page of the permit
record details

See Working with Fees and Payments.

• Report List or BI Catalog: Shared
Folders > Public Sector > Billing and
Payments

Permit Activity
 

Displays permit summary information for an
agency over a specified date range.
 

Report List or BI Catalog: Shared Folders >
Public Sector > Permits
 

Permit Valuation and Revenue
 

Displays permit information including valuation
and fees.
 

Report List or BI Catalog: Shared Folders >
Public Sector > Permits
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Report Name Description Location

Planning Application
 

Displays planning activity over a specified
date range. You select which applications are
included the report. You can generate the
report for one or more specific applications, or
for all applications handled by your agency.
 

• See Working with Reports

• Report List or BI Catalog: Shared
Folders > Public Sector > Planning
Application

Primary Approved Permit
 

Displays applicant and detailed application
information, as well as a description of the
work, address, parcel, and district.
 

• See Working with Reports

• Report List or BI Catalog:   > Shared
Folders > Public Sector > Planning
Application

Public User Information
 

Lists information about public user accounts.
 

Report List or BI Catalog: Shared Folders >
Public Sector > Account Management
 

Refund Receipt
 

Lists refund receipt information.
 

• Refund Detail page

See Viewing and Processing Refunds.

• Report List or BI Catalog: Shared
Folders > Public Sector > Billing and
Payments

Transactions with Reconciled Provisional
Parcels
 

Lists the transactions that refer to the
reconciled provisional parcels.
 
Using this report you can see the provisional
parcels that have been replaced with final
parcels as a result of parcel reconciliation. You
should update the provisional parcel IDs that
are referred in the transactions with the final
parcel IDs.
 

BI Catalog:
 
Shared Folders > Public Sector > Parcels
 
See Reconciling Provisional Parcels.
 

Violation Notice
 

Displays information about the code violation,
 corrective actions, and the compliance date.
This report is sent to the party responsible for
the reported violation.
 

• Notice of Violation page

See Using the Code Technician Worklist.

• Notices page

See Working with Notices.

• Report List or BI Catalog: Shared
Folders > Public Sector > Code
Enforcement > Notices

Violation Notice Detail Report
 

Displays information about the code violation,
 corrective actions, and the compliance date.
This report is sent to the party responsible for
the reported violation. This report retrieves
images (.jpg and .png) from case attachments.
 

• Notice of Violation page

See Using the Code Technician Worklist.

• Notices page

See Working with Notices.

• Report List or BI Catalog: Shared
Folders > Public Sector > Code
Enforcement > Notices

Welcome Letter
 

Informs the applicant that the application has
been assigned and is under review. Provides
application and assigned planner information.

• See Working with Reports
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Report Name Description Location

 • Report List or BI Catalog: Shared
Folders > Public Sector > Planning
Application

Dashboards organize analytical content and catalog objects, and present them in a meaningful way. Oracle Permitting
and Licensing delivers a selection of prebuilt dashboards.

Access dashboards by clicking the Reports and Analytics button and selecting the BI Catalog link in the header on the
Agency Springboard. Go to Shared Folders > Public Sector > Dashboards. You can also display links to dashboards
when you click the Reports and Analytics button. For more information, see Setting Up Dashboards.

Dashboard Description

Case Inspections Dashboard
 

Provides information about case inspections for code enforcement, including the number of case
inspections with different statuses and outcomes.
 

Code Case Dashboard
 

Provides information about incidents, cases, and citations for code enforcement.
 

Fees and Payments
 

Provides information about fees and payments for permits and planning applications.
 

Planning Applications
 

Provides information about inspections, permits, plan review, and properties information for planning
applications.
 

Public Sector
 

Provides information about inspections, permits, plan review, and properties information.
 

Projects
 

Provides information about projects, including total projects, estimated value, active and on-hold
projects, new projects initiated quarterly, and other analytics.
 

The Public Sector Dashboard contains these pages.

Public Sector Dashboard Page Name Description

Inspections
 

Provides real-time information about inspections associated with permits, such as inspection count,
percentage passed, top 10 permits with major violations, average inspections per permit, and so on.
 

Permits
 

Provides real-time information about permits, including permit count, fees amount, totals by permit
status, job cost and fees by permit type, permit applications by week, and so on.
 

Plan Review
 

Provides real-time information about plan reviews, including plan review count, average plan reviews
per permit, plan review decision status, and review status by permit type.
 

Hiding Catalog Folders
You may want to remove access to predefined catalog folders so that those associated with offerings you don't
use aren't displayed. You can hide the entire predefined catalog or selectively display root catalog folders for
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offerings, which are controlled by the Custom BI Web cat Reporting Duty role and associated roles for each offering.
Administrators with IT Security Manager privileges can hide predefined folders by removing their associated roles from
the duty role.

For more information, see Oracle Cloud Applications documentation: Manage Predefined Catalog Permission in Creating
and Administering Analytics and Reports.

Related Topics
• Listing of Prebuilt Analytics

• Help for Transactional Reporting in Oracle Fusion Applications

Creating Deep Links  
Create deep links in your analytics that let you navigate from an analytic to specific attributes and objects in your
transaction pages without navigating through the menu structure.

You can use deep links to easily view the transaction details in Oracle Permitting and Licensing from your Oracle
Transactional Business Intelligence (OTBI) reports.

Here’s how to create deep links:

1. Click the Reports and Analytics header icon on the Agency Springboard, and select BI Catalog.
2. Create or edit an analysis. Use a subject area that includes the attribute you want to link to in the transactional

pages. For example, use Public Sector Cloud - Permits Real Time.
3.

In the Selected Columns pane on the Criteria tab, click   (Options) for the attribute column on which you
want a deep link.

4. Select Column Properties.
5. Open the Interaction tab in the Column Properties dialog box.
6. In the Primary Interaction list in the Value section, select Action Links to display the Action Links table.
7. Select the Do not display in a pop-up if only one action link is available at runtime option.
8. Click Add Action Link.
9. In the New Action Link dialog box, enter the link text for the navigation.

10. Click the Create New Action icon and select Navigate to a Web Page.
11. In the Create New Action dialog box, enter the URL to navigate to, which references parameters you define in

the prompt. For shared analyses, enter a URL with your website host name:

http://<hostname>/fscmUI/deeplink?root=@{1}&context=LnpRecordKey%253D@{2}

◦ Replace <hostname> with the host name of your Oracle Permitting and Licensing instance.

◦ Replace  deeplink with the Public Sector homepage. For example, publicSector.html.

12. Click Define Parameters to add corresponding parameters for the URL.
13. In the Define Parameters section, click Add Parameter to add the following mandatory parameters:

Name Prompt Type of Value Value Fixed Hidden Optional

1
 

root
 

Value
 

PSCLNP_
RECORD_DETAIL

Selected
 

Selected
 

Selected
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Name Prompt Type of Value Value Fixed Hidden Optional

 

2
 

context
 

Column Value
 

"<table.name>"."<column.name>"
 

Selected
 

Selected
 

Selected
 

For example, the context could be “Construction”.”<LNP Record Key>,” where the LNP Record Key is “Permit
Number.” This creates a deep link on the permit number to navigate to the permit transaction detail page.

14. Click Options to set how the page opens.
15. In the Action Options dialog box, select Open in New Window to open the page in a new window.
16. Save your work.
17. If you have provided the Return Application name, a Return icon is available in the transactional page to return

to the analysis.
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14  Setting Up Subject Areas

Subject Areas Overview  
This topic describes how subject areas work.

A subject area is a grouping of information pieces pulled from your transactional database that relate to each other in a
particular context. Examples of context are permits, inspections, plan reviews, planning applications, and so on. These
contexts correlate to key aspects of your business transactions, and are designed to provide answers to questions about
how well things are going. Prebuilt subject areas come right out of the box to answer key business questions.

Any information your organization tracks can be grouped into a subject area, then used to build analytics. All you have
to do is drag columns from your subject area to your analytics editor and you have an analytic. You can edit prebuilt
analytics the same way, by adding or removing columns from your subject area. When you edit prebuilt analytics, don't
forget to make a copy and give it your own name.

Subject Areas and Business Questions  
This topic describes how business questions form the basis of your subject areas and analytics.

Subject areas are designed around business questions. All analytics are built from subject areas. So whether you're
creating your own analytics, or modifying the analytics that come with your Public Sector applications, you first want to
figure out what questions you want answered.

Here are some examples of subject areas and the business questions they can answer.

Subject Area Name Example Business Questions

Public Sector Cloud - Permits Real Time
 

• What is the busiest time for permit applications?

• When does the agency issue the most permits?

• What is the total permit activity by permit type in a given period?

Public Sector Cloud - Permit Inspection
Activity Real Time
 

• What is the workload distribution across all inspections?

• What are the primary reasons for major inspection violations?

• What is the total demand for inspections in a given period?

Public Sector Cloud - Plan Review Real
Time
 

• How long on average are plan review cycles?

• How many plan review cycles on average are needed for an application?

• How many plan reviews had override decisions?
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Subject Area Context and Analytic Results  
This topic discusses the subject area context and the column details of the analysis.

If your analytic doesn't look right, or columns of information aren't showing up, it could be an issue with context. The
context defines what column details the analysis displays. Adding a permit type column doesn't mean all permit type
show up in the analysis. It depends on the context you're using to create the analysis. If you build an analysis, and it
doesn't show what you're expecting, be sure that you're adding your columns and facts in context.

The subject area dimension folders contain the columns and the facts folders define the relationship of the columns. If
you add the permit type column to your analysis, and then add the Fact, Permit Count to the same analysis, then only
the permit types that have one or more permit show on this analysis in this context. There might be hundreds of permit
types that doesn’t have permits associated, so they don't show up on your permit activity analysis.

The following is an example that might help explain this further. In this exercise you will build a permit activity analysis.

To build a simple permit activity analysis from a subject area:

1. Click New and select the Analysis option.
2. Select Public Sector Cloud - Permits Real Time:

◦ From the dimension Permit Type, add Permit Type.

◦ From the dimension Permit - Applicant, add Full Name.

◦ From the dimension Permit, add Permit Application Date.

◦ From the Permit Amounts (fact) folder, add Permit Count.

3. You can filter Permit Application Date to see a specific date range. Edit the filter by clicking or hovering over the
button next to its name.
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4. Select the filter to show only a specific date range and click OK.

This figure illustrates choosing a filtering option to show only records in a specific date range.

5. Click Results. The Results tab shows your analysis at this point. Move back and forth from Criteria to Results at
any time to see your analysis.

This figure illustrates the results of a simple permit activity analysis from a subject area:

6. Name and save your analysis.

Note:  You can't use Direct Database Query in your analysis. Direct Database Query isn't supported in SaaS OTBI. To
create direct database SQL report, you can create a BI Publisher SQL data model and then create a report.

Multiple Subject Areas in a Single Analytic  
This topic discusses how to use multiple subject areas in a single analysis.
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Subject areas can be tricky to master, but once you get familiar with them you can easily mix and match subject area
components for your analytics. The reason you would want to do this is just for flexibility. You might want to look at your
business from different perspectives.

You can create an analysis that combines attributes and metrics from custom permit and standard permit-related
subject areas that share a common dimension. Or, if that isn't enough, you can create an analysis that combines data
from multiple standard subject areas.

To start with, let's learn how to add a subject area to the editing palette. Whether you're creating a new analysis, or
using an existing analysis to add objects from your custom subject area, the steps for adding multiple custom or
standard subject areas to your palette are the same.

To add multiple subject areas to editing palettes:

1. Create your analysis using a single subject area.
2. In the Subject Areas section, click the Add / Remove Subject Areas icon.

This shows the Add / Remove Subject Areas icon.

3. Select or remove one or more standard or custom subject areas from this analysis by selecting or deselecting
subject area. If you have created custom subject areas, they also appear in this list under the name you
assigned to them.

Cross Subject Area Queries
Each subject area contains a collection of attributes and measures relating to the one-dimensional STAR model and
grouped into individual folders. The term STAR refers to the semantic model where a single fact is joined to multiple
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dimensions. You can create an analysis that combines data from more than one subject area. This type of analysis is
referred to as a cross-subject area query. Cross-subject area queries are classified into three broad categories:

• Combining queries from multiple subject areas.

◦ Using common (conformed) dimensions.

◦ Using local and common (conformed) dimensions.

• Using a “set” operation (Union or Union All, for example) to combine more than one result set from different
subject areas.

• Combining Logical SQL using the Advanced tab.

A common dimension is a dimension that exists in all subject areas that are being joined in an analysis. For example, the
Contact dimension is the common dimension for the Public Sector Cloud - Permit Inspection Activity Real Time and
Public Sector Cloud - Permits Real Time subject areas.

A local dimension is a dimension that exists only in one subject area. For example, Inspection Type and Inspection
Status are local dimensions for the Public Sector Cloud - Permit Inspection Activity Real Time subject area.

The following are some general guidelines to follow when working with multiple subject areas:

• If all metrics and attributes needed for the analysis are available in a single subject area and fact metrics, use
that subject area only and don't create a cross-subject area query. Such an analysis performs better and is
easier to maintain.

• When joining two subject areas in an analysis, make sure at least one attribute from a common dimension is
used in the analysis.

• When using common dimensions always choose attributes from the common dimension from a single subject
area. For instance if you're using the Contact dimension to build a query between subject area 1 and subject
area 2, then select all Contact dimension attributes from either subject area 1 or from subject area 2. (Not
some contact attributes from subject area 1 and some from subject area 2.) In some scenarios, the common
dimension may have more attributes in one subject area than the other. In such a situation, you can only use
the subset of common attributes for a cross-subject area query.

• Always include a measure from each subject area that's being used in your analysis. You don't have to display
measures or use them, but you should include them. You can hide a measure if not needed in the analysis.

• When using common and local dimensions use SET VARIABLE ENABLE_DIMENSIONALITY=1; in the Advanced
SQL tab.

Queries from Multiple Subject Areas
The simplest and fastest way to generate an analysis is to use a single subject area. If the dimension attributes and fact
metrics that you're interested in are all available from a single subject area, then you should use that subject area to
build the analysis. Such an analysis results in better performance and is much easier to maintain.

If your analysis requirements can't be met by any single subject area because you need metrics from more than one
subject area, you can build a cross-subject area query using common dimensions. There's a clear advantage to building
a cross-subject area query using only common dimensions, which is recommended.

Keep in mind that if you use three subject areas for an analysis, your common dimensions must exist in all three subject
areas. Joining on common dimensions gives you the benefit of including any metric from any of the subject areas in a
single analysis.
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While you can create an analysis joining any subject area to which you have access, only a cross-subject area query that
uses common dimensions returns data that's at the same dimension grain. This happens so that the data is cleanly
merged and the result is an analysis that returns exactly the data you want to see.

Knowing how cross-subject area queries are executed in BI helps you understand the importance of using common
dimensions when building such an analysis. When a cross-subject area analysis is generated, separate queries are
executed for each subject area in the analysis and the results are merged to generate the final analysis. The data
that's returned from the different subject areas is merged using the common dimensions. When you use common
dimensions, the result set returned by each subject area query is at the same dimensional grain, so it can be cleanly
merged and rendered in the analysis.

Common Dimensions for an Analysis
Here is an example of combining common dimensions. In this case, we combine the Permit Count, Permit Type,
Inspection Count, and Inspection District Type. The common dimension in both subject areas used for this analysis is
Permit Type and different fact metrics are pulled from each subject area.

The following subject areas are used for this example analysis:

• Subject area 1: “Public Sector Cloud – Permits Real Time”

• Subject area 2: “Public Sector Cloud – Permit Inspection Activity Real Time”

Customer is the common dimension used for this example analysis:

• “Public Sector Cloud – Permits Real Time”.“Permit Type” – Permit Type

• “Public Sector Cloud – Permit Inspection Activity Real Time“ – Permit Type

The following are the metric measures for this example analysis:

• “Public Sector Cloud – Permits Real Time“.“Permit Amounts” – Permit Count

• “Public Sector Cloud – Permit Inspection Activity Real Time“.“Inspection Amounts” – Inspection Count

Local and Common Dimensions for an Analysis
This example pulls the Permit Count by Permit Type and Inspection Count by Inspection District Type. Permit Type is
a common dimension in both subject areas used for this query. Inspection District is a local dimension to the Public
Sector Cloud – Permit Inspection Activity Real Time subject area. Different fact metrics are pulled from each subject
area. Note that use of local dimension may impact the grain of the analysis. In such cases the metrics may get repeated
for each of these rows.

The following are the subject areas used for this example analysis:

• Subject area 1: “Public Sector Cloud – Permits Real Time”

• Subject area 2: “Public Sector Cloud – Permit Inspection Activity Real Time”

Permit Type is the common dimension for this example analysis: “Public Sector Cloud – Permits Real Time”.“Permit
Type” – Permit Type.

The following is the local dimensions used for this example analysis: “Public Sector Cloud - Permit Inspection Activity
Real Time”.“Inspection District” – Inspection District.
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The following are the metrics (measures) used for this analysis:

• “Public Sector Cloud – Permits Real Time”.“Permit Amounts” – Permit Count

• “Public Sector Cloud – Permit Inspection Activity Real Time“.“Inspection Amounts” – Inspection Count

The following is the logical SQL used for this analysis:

SET VARIABLE ENABLE_DIMENSIONALITY=1;SELECT

 0 s_0,

 "Public Sector Cloud - Permits Real Time"."Permit Type"."Permit Type" s_1,

 "Public Sector Cloud - Permit Inspection Activity Real Time"."Inspection District"."District Type" s_2,

 "Public Sector Cloud - Permits Real Time"."Permit Amounts"."Permit Count" s_3,

 "Public Sector Cloud - Permit Inspection Activity Real Time"."Inspection Amounts"."Inspection Count" s_4

FROM "Public Sector Cloud - Permits Real Time"

ORDER BY 1, 2 ASC NULLS LAST, 3 ASC NULLS LAST

FETCH FIRST 75001 ROWS ONLY

Set Operations to Combine Result Sets from a Subject Area
This example creates a compound analysis query that's a union of two result subsets from two subject areas, combining
results from:

• Permit Count by Permit Type from the Public Sector Cloud – Permits Real Time subject area (result 1)

• Inspection Count by Inspection District from the Public Sector Cloud - Permit Inspection Activity Real Time
subject area (result 2)

SELECT saw_0, saw_1 FROM ((SELECT 'Permits ~ ' ||"Permit Type"."Permit Type" saw_0, "Permit Amounts"."Permit
 Count" saw_1 FROM "Public Sector Cloud - Permits Real Time")
UNION
(SELECT 'Inspection ~ ' ||"Inspection District"."District Id" saw_0, "Inspection Amounts"."Inspection Count"
 saw_1 FROM "Public Sector Cloud - Permit Inspection Activity Real Time")) t1 ORDER BY saw_0

Logical SQL Using the Advanced Tab
If your requirement can't be met by either of the two methods already discussed, then there's another advanced
technique you can try. This technique lets you join multiple logical SQL statements based on common IDs or keys, which
can be written against the same or different subject areas, just as used in normal SQL. Both Outer and Equijoin are
supported.

This example illustrates how you can combine Permits and Fees data in an analysis by combining the logical SQL found
on the Advanced tab.

Step 1: Write a BI Answers query using the “Public Sector Cloud – Permits Real Time” subject area to show the Fee
amount and Applicant Name. Once the correct results are achieved, go to the Advanced tab and grab the logical SQL
associated with this query.

Logical SQL for Query 1:

SELECT
 0 s_0,
 "Public Sector Cloud - Permits Real Time"."Applicant"."Applicant Name" s_1,
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 "Public Sector Cloud - Permits Real Time"."Permit"."Permit Number" Per_No,
 "Public Sector Cloud - Permits Real Time"."Permit Amounts"."Fee Amount" s_3
FROM "Public Sector Cloud - Permits Real Time" 

Step 2: Write a second BI Answers query using the " Public Sector Cloud - Receipts Real Time"."Transactions" subject
area to show fees paid for the permit. Once the correct results are achieved, go to the Advanced tab and grab the logical
SQL associated with this query.

Logical SQL for Query 2:

SELECT
 0 s_0,
 "Public Sector Cloud - Receipts Real Time"."Transactions"."Application ID" s_1,
 "Public Sector Cloud - Receipts Real Time"."Fact - Receipts"."Amount Received for a given period" s_2
FROM "Public Sector Cloud - Receipts Real Time"

Step 3: Go to the Advanced tab in BI Answers and copy/paste the following logical SQL which is an OBIEE - Equijoin of
the two previous SQL statements based on Opportunity ID. Use any text editor to combine the logical SQL statements
copied from Steps 1 and 2.

SELECT
permit.s_1, permit.Per_No, permit.s_3, fees.s_2
FROM
(
SELECT
 0 s_0,
 "Public Sector Cloud - Permits Real Time"."Applicant"."Applicant Name" s_1,
 "Public Sector Cloud - Permits Real Time"."Permit"."Permit Number" Per_No,
 "Public Sector Cloud - Permits Real Time"."Permit Amounts"."Fee Amount" s_3
FROM "Public Sector Cloud - Permits Real Time"
) permit,
(
SELECT
 0 s_0,
 "Public Sector Cloud - Receipts Real Time"."Transactions"."Application ID" s_1,
 "Public Sector Cloud - Receipts Real Time"."Fact - Receipts"."Amount Received for a given period" s_2
FROM "Public Sector Cloud - Receipts Real Time"
) fees
WHERE permit.Per_No = fees.s_1 

Note:   If you create a new analysis using this SQL, any hierarchical columns, member selection, groups or formatting
is stripped out.

Custom and Standard Subject Areas Joins
Analyses can be build using combinations of standard, as well as both custom and standard subject areas. The add
subject area option appears once you have created an analysis from a single subject area. You can delete subject areas
using these same steps. When you create your analysis, you select a single subject area during the creation steps. Once
the analysis is created, you add additional standard or custom subject areas.

Listing of Subject Areas for Oracle Permitting and
Licensing  
This reference points to the list of subject areas for Oracle Permitting and Licensing.
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Oracle Permitting and Licensing comes with a variety of standard subject areas for permits, planning applications, code
enforcement, and business licenses. See the Related Topics for a link to the subject area list.

Related Topics
• Subject Areas for Transactional Business Intelligence in Oracle Permitting and Licensing
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15  Setting Up Custom Subject Areas

Custom Subject Areas  
Oracle Permitting and Licensing Cloud contains prebuilt subject areas, but you can also create your own subject area for
your unique reporting needs.

The subject areas that you create is called a custom subject areas.

Concepts and Terminology in Custom Subject Areas
Before creating a custom subject area, you should understand the concepts and terminology used with custom subject
areas. These concepts are discussed in their related topics in detail.

• Objects: Objects within Oracle Permitting and Licensing Cloud represent an entity; for example, a contact list.
When you create entities such as permit types within Oracle Permitting and Licensings, you create custom
objects.

• Fields or attributes: A field, also called an attribute, is where entity information is stored. A contact type is
stored in a field under the contact list entity or object.

• Measures: Measures are a set of functions that you can apply on date, numeric, or currency type fields of the
selected primary or child objects while defining a custom subject area.

• Date Leveling: Date leveling is a date hierarchy representation between dates and their associated measures.
For example, total actual annual gross revenue by month.

Creating Custom Subject Areas  
This topic covers how you create and edit custom subject areas, and how you can activate or inactivate a custom subject
area while editing.

You cannot modify a predefined report subject area, however, you can create custom subject areas to meet your
reporting needs.

Note:  Before you create a custom subject area, review all the included subject areas to see if the one you want is
already available.

Adding a Custom Subject Area
You add custom subject areas using train stops that appear at the top of the page. These train stops enable you to
move back and forth during the configuration process. You can also save your configuration at a logical point and then
continue to create later.

Note:  You can only create custom subject areas when you are not in an active sandbox.
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To create a custom subject area using train stops:

1. Navigate to Application Composer.
2. Click Custom Subject Areas on the Overview page of Application Composer.
3. Select Create from the Actions menu.

These are the steps in the train stops that you can use for configuring your custom subject area:

1. Define Custom Subject Area

In this step, you provide the name for your subject area and select the primary object that is the basis for
the reports you create later using the custom subject area. Subject areas usually have names or labels that
correspond to the type of information they contain. Display labels have the Custom: prefix added automatically.

2. Select Child Objects

In this step, you select the child objects whose data you want to use in your reports. You can add child objects
only if the primary object has child objects. Otherwise, the add icon is disabled. You can only add one child
object per level. The parent-child-grandchild-grand grandchild hierarchy supports adding up to three levels of
child objects with one child object at each level, for example, parent-child1-child1.1-child1.1.1.

3. Configure Fields

In this step, you select the fields that you want to display on your reports. You typically add at least one field
from each of the objects that you have selected for your custom subject area.

Select the desired measures to generate for number, date, or currency fields from all the available objects so
that the subject area includes only those measures that you want to analyze. Also, define at least one measure.

In the Measure Aggregations column, select an option from the list of predefined formulas that you can apply
to the Measure field. When you select the formula, the application applies the selected formulas to the selected
field and measures.

Note:  You can choose measures only for the lowest child. For example, if only a primary object exists with no
children, you can select measures for the primary object. Otherwise, if any child objects exist, you can select
measures only at the lowest child object level, not for the parent object.

You can change the display labels of the fields that you select in this step. Additionally, you can use the Select
Fields dialog to remove fields that belong to the primary object. The Select Fields dialog appears when you click
Select Fields when configuring fields for your custom subject area.

After you publish your custom subject area, the fields you have selected for your subject area are automatically
added to their owning object's folder. If you have also defined measures, those fields are automatically added to
the Facts folder. If you did not define a measure, then one is automatically created for the custom subject area.

For more information on measures, see Measures.
4. Configure Date Leveling

If required, select the Date columns for date leveling. For more information on date leveling, see Date Leveling.
5. Configure Security

Select the required security level for the Everyone Role Name, which is added by default, or add additional Role
Names by clicking in the + icon and define the security level for each one of them.

The security definition here only controls who can access the custom subject area definition to create reports. It
doesn't control data visibility which is automatically controlled based on the user running the reports.
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For more information on securing custom subject areas, see Custom Subject Area Security.
6. Review and Submit

Review the custom subject area configuration for all added objects, attributes, and measures, and if satisfied,
click Submit. If changes are required click Back to navigate back to the required screen.

After you submit, the custom subject area configuration is prepared for publishing. You can create and submit
a custom subject area either immediately or save and close the custom subject area at any point and submit it
later. You must first submit a custom subject area for publishing before you can select it from within Oracle BI
Composer. After you save or submit a custom subject area, you cannot modify its primary object.

To access the published custom subject area in BI:

◦ From the Navigator menu, select Tools  > Reports and Analytics.

◦ In the Contents pane, click Create.

◦ Select the published custom subject area and start creating your report.

Editing Custom Subject Areas
You can edit a published or saved custom subject area and then republish it when your changes are done. Modifying a
custom subject area does not affect the reports that you had created using that custom subject area before making the
changes. You can use the modified custom subject area if you need to enhance existing reports.

To edit a custom subject area:

1. On the Overview page of the Application Composer, click Custom Subject Areas.
2. Locate the custom subject area that you want to edit, and click the Edit icon.

You can filter out inactive custom subject areas in Application Composer by viewing custom subject areas in
Active status. This is safer than deleting them, because the inactive subject areas are still available and can be
found by searching.

3. Make the desired changes and then click Submit to republish the custom subject area.

While you can edit a custom subject area in any status, there are considerations on what you can or can't do when
editing. When editing a published custom subject area, it is not possible to:

• Change the primary object.

• Add or remove child objects.

• Remove previously added measures.

• Add more aggregation types for measures that are already published.

Note:  You cannot modify a predefined report subject area. Instead, you must create separate custom subject areas to
meet your reporting needs. Before you create a custom subject area, be sure to review all the included subject areas to
see if the one you want is already available.

Activating or Inactivating Custom Subject Areas
When editing custom subject areas, you can activate or inactivate custom subject areas when your reporting or
business requirements change. This step enables you to control what information is displayed on the reports that use
the information from custom subject areas.

179



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 15
Setting Up Custom Subject Areas

You can inactivate only those custom subject areas that are published and have a status of OK, and can activate only
previously inactivated custom subject areas.

To inactivate a custom subject area, select it in the list and then click the Inactivate button. To activate an inactive
custom subject area, select it and click Activate. Note that if no custom subject area is selected in the list, the button
doesn't appear.

When searching for custom subject areas, you can filter out inactive custom subject areas in Application Composer by
viewing only those in Active status. Inactivating a custom subject area is safer than deleting it, because the inactive
subject areas are still available and can be found by searching.

Objects in Custom Subject Areas  
This topic covers how you use the various types of objects in the Application Composer to create custom subject areas.

A custom subject area is a set of entities (objects), attributes, and measures that you use to build reports.

Objects can be classified under broad categories of custom objects and standard objects. Every custom subject area
has a primary object, which is the focus of any reports that you create. You can also optionally add child objects to the
custom subject area. Custom subject areas support both custom and standard objects. The objects that you create are
called custom objects.

Before designing your custom subject area, use Intake Form Designer to identify or create the objects and fields that
you want to use.

Primary Objects
A primary object is any top-level object. You create a custom subject area based on the primary object. Additionally, the
primary object is the focus of the report that you create based on the custom subject area.

The list of available primary objects includes all objects, which are either top-level custom objects, or standard objects
that are configured by the owning application. After you save your custom subject area, you can't change its primary
object; but you can create another custom subject area using a different primary object.

Based on how you want to configure your custom subject area, you can add one child to an object.

Child Objects
A child object is an object that has a one-to-many relationship with a parent object and can be a parent object of
another child object. Add a child object to a custom subject area if you want your report to include data from both the
primary object and its children. If an object's parent object is already a child object (of another parent object) then the
object is a grandchild object. For example, if object Y is a child of object X, and object Z is a child of object Y, then object
Z is a grandchild of object X. Custom subject areas support parent-child-grandchild-great-grandchild objects.

You can only add one child object to the primary object per level, as long as there are child objects available. If there are
no child objects for the chosen primary object, the list that enables selecting child objects does not appear.

The parent-child-grandchild-great-grandchild hierarchy supports adding up to three levels of child objects with one
child object at each level; for example, parent-child1-child1.1-child1.1.1.

Note:  Once you publish a custom subject area, you can't add or remove child objects.
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Fields or Attributes in Custom Subject Areas  
This topic explains the various types of fields or attributes that you use for configuring your custom subject area.

Fields or attributes store entity information in the application. Fields can be standard or custom.

Types of Reporting Fields
The fields you can use to create reports are as follows:

• Text

• Number

• Date

• Percentage

• Date time

• Currency

• Check box

• Fixed choice list

• Dynamic choice list

• Long text

Note:  You cannot create reports using the Rich text area field.

When you create a custom field, you can create reports for the following data types:

• Boolean

Note:  Note: If you are using the Boolean data type for fields other than check boxes, those fields are
displayed as either 0 or 1 on your custom reports.

• Number

• Currency

• Date

• String

• Percentage

• Phone

• Date time

• Long text
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Measures  
Measures are a set of functions. Examples include a SUM of the actual gross revenue in USD, or a COUNT of the number
of building permits worth over $500,000.

The designer defines the aggregation function (SUM, COUNT, and so on) for custom measures, so end users don't need
to do so themselves when they create an analysis. You can apply these functions on fields of type Date, Numeric, or
Currency.

Measures available to a particular type of field may differ depending on the field type. After you define the measures
for the required fields and publish the custom subject area, you can select these fields and the applied measures when
creating your report in the Oracle BI Composer. You can only specify aggregate formulas to apply to a measure when
creating a custom subject area. It is not possible to edit a measure in an already published custom subject area.

Here are some measures you can apply to fields of type Numeric, Currency, or Date.

• For Numeric and Currency fields, a measure can be:

◦ All

Note:  All is not a measure, but an option in the UI that selects all of the measures.

◦ Sum: Calculates the sum of the values.

◦ Average: Calculates the mean value.

◦ Count: Calculates the number of rows that are not null.

◦ Count Distinct: Calculates the number of rows that are not null. Each distinct occurrence of a row is
counted only once.

Note:  Although Count Distinct is usually used in cases requiring a count on a foreign key (because a
count of distinct rows is what's wanted), it is not required. If your requirements allow multiple instances
of the same foreign key value to be counted multiple times, you can use Count rather than Count
Distinct.

◦ Maximum: Calculates the highest numeric value.

◦ Minimum: Calculates the lowest numeric value.

◦ First: Selects the first occurrence of the item.

◦ Last: Selects the last occurrence of the item.

◦ Median: Calculates the middle value.

◦ Standard Deviation: Calculates the standard deviation to show the level of variation from the average.

◦ Standard Deviation Population: Calculates the standard deviation using the formula for population
variance and standard deviation.

• For Date fields, a measure can be:

◦ All

◦ Maximum

◦ Minimum

182



Oracle Public Sector Permitting and Licensing
Implementing Your Agency

Chapter 15
Setting Up Custom Subject Areas

You can select measures based on your reporting needs. For example, you can use measures to view product sales per
store, state, or country. Or, to view the number of support tickets opened or closed per day, week, or month, and so on.

If you do not define a measure, then one will be automatically created for the subject area when you submit the custom
subject area for publication.

Date Leveling  
Date leveling is a hierarchy representation of dates and associated measures, which enables you to view the data over
different periods of time.

To use this hierarchy, create a report that shows the total Actual Gross Revenue amount for each year. Drill down from
year to show gross revenue per quarter, sales per month, gross revenue per week and gross revenue per day, and
then drill back up to gross revenue per year. The date hierarchy aggregates the measures by the required hierarchy or
leveling period.

To configure date leveling when defining a custom subject area, use the Configure Date Leveling step of the train stop
to either allow or disallow leveling. You may need to expand the field list in the Date field to select or clear the Date
Leveling check box, as applicable.

For more information on where the Configure Date Leveling step appears in the train stop, see Creating Custom Subject
Areas.

Custom Subject Area Security  
You can secure a custom subject area by granting or revoking access rights from the role names that access the custom
subject area. This topic covers how you can grant or revoke access rights from those role names.

For information about custom subject area data source security in Oracle Analytics Publisher, see Public Sector
Compliance and Regulation Custom Subject Area Security Guide for Implementation (Doc ID 2730290.1) in My Oracle
Support.

Managing Role Names and Access Rights
While defining a custom subject area using the train stops, you can use the Actions list in the Configure Security step to
manage role names and access rights.

Note:  You cannot delete the role name listed as Everyone.

Read access is granted by default. If you want to revoke Read access from a listed role name, select No access for that
role name.

You can create custom subject areas even for the objects in which you do not have access to the data, which allows you
to build custom subject areas without compromising data security.
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Publication Statuses of Custom Subject Areas  
This topic covers what happens when you submit a custom subject area for publishing, and what the submission
statuses indicate.

After you successfully publish your custom subject area, you can start building reports using Oracle Business
Intelligence (BI) Composer based on your published subject area.

What Happens When You Submit for Publishing
When you submit a custom subject area for publishing, two processes occur in the background. The first process is
synchronous and creates Oracle Applications Development Framework (Oracle ADF) artifacts. You must wait until this
first process is over. The second process is asynchronous and creates centralized metadata repository (RPD) fragments
and submits them to the Oracle BI server.

Note:  You must refresh the status to know whether the custom subject area is submitted successfully. You may have
to refresh the status multiple times, because the creation of Oracle ADF and RPD artifacts may require some time.

A custom subject area can have one of the following statuses:

• Pending: This status indicates either of the following:

◦ You saved and closed the configuration process for a custom subject area before submitting it for
publishing.

◦ A failure occurred in the background processes when creating Oracle ADF and RPD artifacts.

• In Process: This status indicates that the data is in the process of being published to Oracle BI.

Note: If the in-process status doesn't change to OK, even after multiple refresh attempts, then there could be
an error in publishing. If an error occurs, then the details are displayed, as well as information about how to fix
problems, where applicable. These error status details allow you to pinpoint and fix problems quickly.

• OK: This status indicates that the custom subject area has been published successfully. You can use Oracle BI
Composer to create reports using the objects, attributes, and measures that you have configured in the subject
area.

Including Custom Fields on Reports  
This topic discusses how to create a custom subject area using an attribute and create a report.

Creating a Custom Subject Area
In this example, you create a custom subject area using the LNP1KitchenRemodel object.

1. If you are working in a sandbox, exit the sandbox.
2. Click the Navigator menu at the top.
3. Click the Application Composer link.
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Note:  You might need to click the more >> link first.

You are on the main page of Application Composer, where you create a custom subject area using the
LNP1KitchenRemodel object.

4. Change the Application from CRM Cloud to ERP and SCM Cloud.
5. In the Overview region, click the Custom Subject Areas link.

You are on the Custom Subject Areas page. You can use this page to search or create custom subject areas.
6. In the Search Results region, click the Create button.
7. Enter a name for the custom subject area that you are creating. Enter Kitchen Remodel in the Label field.
8. In the Primary Object region, click the Primary Object list.
9. Click the LNP1KitchenRemodel list item.

10. In the upper-right region of the page, click the Next button.
11. In the upper-right region of the page, click the Add Child Object button.
12. In the Add Child Object dialog box, click the Child Object list.
13. Click the ContactList list item.
14. Click OK.
15. In the upper-right region of the page, click Next.

You now define the fields for the LNP1KitchenRemodel primary object.
16. Ensure that the selected value in the Fields Fromlist is LNP1KitchenRemodel. Click the Select Fields button.
17. On the Select Fields modal page, select the fields that you want to include for the LNP1KitchenRemodel

primary object.
18. Repeat steps 16 and 17 for the ContactList child object.
19. In the upper-right region of the page, click Next.
20. You now select fields to apply date leveling. In the Date Field Leveling table, click the Expand button of the

LNP1KitchenRemodel object.
21. Select the Allow Leveling option for the Business Start Date field.
22. In the upper-right region of the page, click Next.
23. Leave the default role access of Read for Everyone. In the upper-right region of the page, click Next.
24. Review your custom subject area. In the upper-right region of the page, click Save.
25. In the upper-right region of the page, click Submit.

A confirmation message appears.
26. Click OK.

You successfully created a custom subject area.

Creating a Report Using a Subject Area
In this example, you create a report in Oracle Business Intelligence Composer (BI Composer) using the Kitchen Remodel
subject area.

1. Click the Navigator menu at the top.
2. Click the Reports and Analytics link under Tools.

Note: You might need to click themore >> link first.

The Reports and Analytics page appears.
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3. In the left pane, click Create and select Analysis.

From the Select Subject Area dialog box that appears, you must first select a subject area to build your report.
In this activity, you are building a report using the Kitchen Remodel subject area.

4. In the Select Subject Area dialog, select the check box next to Custom:Kitchen Remodel and click Continue.

Tip: You can add more than one subject area to a report by selecting the check box next to additional subject
areas.

5. You are in the Select Columns step of Oracle Business Intelligence Composer (BI Composer) wizard. In the left
box, click the Expand button of the Custom:Kitchen Remodel tree.

6. Add the following fields to the Selected Columns box on the right:

a. RecordNumber under LNP1KitchenRemodel tree.
b. Submission Date under LNP1KitchenRemodel tree.
c. Status under LNP1KitchenRemodel tree.
d. Expiration Date under LNP1KitchenRemodel tree.
e. Female Owned under LNP1KitchenRemodel tree.
f. First Name under ContactList tree.

g. Last Name under ContactList tree.
h. Gender under ContactList tree.
i. Phone Number under ContactList tree.
j. State under ContactList tree.

7. In the upper-right region of the page, click Next.

You are in the Select Views step of the wizard.
8. Enter Kitchen Remodel Permits in the Title field.
9. Click the Table list.

10. Click the Table (recommended) list item.
11. Click the Preview option on the right of the Title field to view a preview of the table. Click OK.
12. In the upper-right region of the page, click the Next button.

You are in the Edit Graph step of the wizard.
13. In the upper right region of the page, click Next.
14. You are in the Sort and Filter step of the wizard.
15. In the upper right region of the page, click Next.

You are in the Highlight step of the wizard.
16. In the upper right region of the page, click Next.

You are in the Save step of the wizard.
17. Enter Kitchen Remodel Permits in the Analysis Name field.
18. In this activity, you will save your report in only My Folders. In the Save In area, click the My Folders tree.
19. In the upper right region of the page, click Submit.

A confirmation message appears.
20. Click OK.
21. You can now view the report you just created. Click the Expand button of the My Folders tree.
22. Locate the report you just created.

You successfully created a report in BI Composer using the Kitchen Remodel subject area.
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Custom Subject Areas: Frequently Asked Questions  
This topic provides answers to some frequently asked questions regarding custom subject areas.

Can I change a custom subject area's primary object?
No. Once you save a custom subject area, you cannot change its primary object; however, you can create a new custom
subject area with a different primary object.

What happens if I change a custom subject area after it is published?
You can edit a published custom subject area and then republish it after your changes are done. Modifying a custom
subject area does not affect the reports that you created using that custom subject area before making the changes.
You can use the modified custom subject area should you need to enhance existing reports.

Note:   You cannot edit a primary object when you modify a custom subject area. Should you need to do so, create a
new custom subject area using a different (new) primary object.
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16  Setting Up Time Recording

Time Recording Overview  
Time recording enables agencies to track the amount of time their employees spend on various activities.

Agencies can use this recorded time to:

• Bill for time spent.

• Report on key performance indicators.

To set up your agency for time recording, you define:

1. Time recording categories and subcategories.

See Setting Up Time Categories and Subcategories.

Note:  This step is not strictly required because you can add time entries without categories or subcategories.
You must define time recording categories and subcategories, however, before associating them with time
entry types.

2. Time entry types.

See Setting Up Time Entry Types.
3. Fee schedules.

See Setting Up Fee Schedules.

Note:  This step is required for billing based on time spent.

Once you’ve setup up your time recording framework, agency staff can enter time and assess fees on the transaction
pages. For more information, see Adding Time Entries and Assessing Fees for Time Entries.

Setting Up Time Categories and Subcategories  
Time categories and subcategories enable agencies to classify how their staff is spending their time.

Categories and their subcategories are reusable across transactions and products, and can be used to calculate fees and
generate reporting information.

You add, modify, and delete time categories and subcategories on the Time Category page (Time Recording Setup >
Time Category).

This example shows the Time Category page
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Adding a Time Category
1. On the Time Category page, click Add.
2. On the Time Category Details page, enter a Category ID, a Category, and a Description for the category.
3. Turn on the Enable switch to make this category available to select for time entry types. This switch is turned

off by default for new time categories.
4. Add a subcategory.

Note:  You must have values defined for all required time category fields before you can add a subcategory.

5. Click Save.

Adding a Time Subcategory
1. Click a row on the Time Calendar page.
2. On the Time Category Details page, click Add.
3. On the Time Subcategory Details page, enter a Subcategory ID, a Subcategory, and a Description for the

subcategory.
4. Ensure that the Enable switch is turned on so that the subcategory is available to select for time entry types.

This switch is turned on by default for new time subcategories.
5. Click Save.

Modifying a Time Category
1. Click a row on the Time Calendar page.
2. On the Time Category Details page, you can:

◦ Update the time category fields.

Note:  You can’t edit the Category ID field.

◦ Enable or disable the time category.

◦ Delete the time category. You will be prompted to confirm the permanent deletion.

◦ Add, modify, or delete time subcategories.

3. Click Save.

Modifying a Time Subcategory
1. Click a Time Subcategory row on the Time Category Details page.
2. On the Time Subcategory Details page, you can:

◦ Update the time subcategory fields.

Note:  You can’t edit the Subcategory ID field.

◦ Enable or disable the time subcategory.

◦ Delete the time subcategory. You will be prompted to confirm the permanent deletion.

3. Click Save.
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Deleting Time Categories
1. On the Time Category page, click Select Multiple.
2. Select the check boxes next to all the time categories you want to delete.
3. Click Delete. You will be prompted to confirm the permanent deletion.

Deleting Time Subcategories
1. On the Time Category Details page, click Select Multiple.
2. Select the check boxes next to all the time subcategories you want to delete.
3. Click Delete. You will be prompted to confirm the permanent deletion.

Setting Up Time Entry Types  
Time entry types enable you to associate time categories and subcategories with the transactions where they can be
used to record time.

Each time entry type represents a unique, reusable combination of time category, time subcategory, classification, and
transaction. For example, you might create a time entry type for air travel associated with a permit inspection.

You add, modify, and delete time entry types on the Time Entry Type page (Time Recording Setup > Time Entry Type).

This example shows the Time Entry Type page

Adding a Time Entry Type
1. On the Time Entry Type page, click Add.
2. For the new time entry type row, enter values for the following fields:

Page Element Description

Time Type Code
 

Enter the code that agency staff members use to enter all the default values associated with
this time entry type when adding time entries.
 

Classification Select a product area, such as Permit or Planning and Zoning.
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Page Element Description

  

Transaction
 

Select a specific transaction, such as Plan Review, Inspection, or Planning Application.
 

Note:
The transactions that are available to select depend on the Classification you selected.
 

Category and Subcategory
 

Select the time category and subcategory for the time entry type. For more information on time
categories and subcategories, see Setting Up Time Categories and Subcategories.
 

Note:
You can leave these fields blank. You can’t select a subcategory without first selecting a
category.
 

Billable
 

Turn this switch on to make entries associated with this time entry type billable by default.
 

Assess Now
 

Turn this switch on to immediately assess fees for entries associated with this time entry type
by default.
 

Note:
This switch is available only when the Billable switch is turned on.
 

Override
 

Turn this switch on to enable agency staff to override the Billable default setting when adding a
time entry.
 

Enabled
 

Turn this switch on to make the time entry type available to select when adding time entries.
 

3. Click Save.

Modifying a Time Entry Type
Once you save a time entry type, you can no longer edit the following fields:

• Time Type Code

• Classification

• Transaction

• Category

• Subcategory
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You can toggle the four switches:

• Billable

• Assess Now

• Override

• Enabled

Deleting a Time Entry Type
Click the Delete button next to a time entry type row to delete it.

Note:  You can’t delete a time entry type if it is used for any time entries.

GS Sample Topic  
This topic describes how to add a topic to a map in the new UA system.

Not sure about this task.

But going with it.

First Section
Here are the steps for the first section.

1. step 1
2. step 2

Second Section
Considerations for this task.

• consideration 1

• consideration 2
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