3Analytics

This chapter contains the following:

Create and Edit Analytics

Create and edit analytics to provide real-time reporting on your transactional data. You can:

  • Create an analysis. You may, for instance, want to track overdue assessments. Your analysis includes assessment name, state, and due date. It filters records to exclude completed assessments and include those with due dates earlier than the present date. An analysis may present information in a table, graphically, or both.

  • Create a dashboard. You may, for example, group the overdue-assessment analysis together with other analyses that display other information about assessments.

  • Use predefined dashboards, which display predefined analyses.

Analytics display data retrieved from subject areas, which are logical groupings of columns that store individual data points.

You may use the BI catalog to create either an analysis or a dashboard. For an analysis, however, you have the option of using a wizard available in the Reports and Analytics pane.

Analyses

Use a Wizard to Create or Edit an Analysis

You can use a wizard to guide you through the creation an analysis. Although you can also create analyses in the BI catalog, the wizard provides a directed process that's simpler, but suitable for many of the analyses you will create.

  1. Select Reports and Analytics in the Tools work area. Then:

    • To create a new analysis, click the Create button. From the list it presents, select the Analysis option. A Select Subject Area list appears. Click the check box for one subject area that will provide data for your analysis. Then click the Continue button.

    • To edit an existing analysis, open the folder in which it's saved. (A Favorites filter may be in force by default. If so, click Clear Filters in the Search area to see a list of folders.) In the record of the analysis, click an ellipsis icon, then click Edit.

  2. You're now in a Select Columns page. In its Subject Areas region, you have the option of adding subject areas or removing any you don't need. If you want to, click the Add/Remove Subject Areas button, select or clear check boxes for subjects areas, and click OK.

    However, you can't remove the original subject area selected for the analysis. To remove any other subject area, first remove its columns from the analysis.

  3. From here on, make selections in a series of analysis-definition pages, selecting Next or Back to navigate among them.

    • In the Select Columns page, expand your subject area and folders within it to choose the columns from which your analysis is to draw data. Also set options for those columns.

    • In a Select Views page, determine whether your analysis is to include a table, a graph, or both. For either, select among several types. If you include both, select the order in which they appear.

    • In Edit Table and Edit Graph pages, select options that apply to your table and graph layouts. Each of these pages is active only if you selected the item it applies to in the Select Views page.

    • In a Sort and Filter page, optionally apply filters to any of your columns to select particular records (and so exclude others), and apply sorts to arrange the order in which records are presented.

    • In a Highlight page, optionally add color highlights to numeric column values that exceed thresholds you set.

    • In a Save page, create a name for the analysis, select a folder to save it in, and click Submit.

In general, these pages are designed so that procedures for using them are readily apparent. Even so, here are some things you will want to know.

Select Columns Page

For each column in your analysis, you select an Interaction option.

  • Two of the options, Default and Drill, do the same thing: If you click on a column header, the analysis adds a column displaying values at the next hierarchical level. (For example, if you click on Control Name, the analysis adds a Control ID column.) If you click on a column value, the analysis adds the subordinate column, but also filters to display only records containing the value you clicked.

  • Navigate to Transaction: If you click on a value from a column for which this option is set, the analysis presents a link to the record of an object the value applies to.

    For such links to work, however, further configuration is required: You need to define paths to the records that are to be opened. If you want to use this option, you're probably better off creating the analysis in the BI catalog. However, you can create it in the wizard, then edit it in the BI catalog. See the topic titled Link Analyses to Application Pages.

  • None: This option in effect turns the Default option off and turns nothing on. Nothing happens if you click on a value in a column for which this option is set.

For each column, you can also select a Hidden option. This prevents the analysis from displaying the column, but leaves its values available for use behind the scenes, for example in filters.

Select Views Page

You can add a graph to your analysis only if it includes at least one column from a fact folder. (You can include a table in your analysis no matter what columns you select for it.) A fact column contains numeric values, such as counts of incidents returned by advanced controls. Other columns contain attributes of objects, such as names of advanced controls. Without numeric values, there's nothing to base a graph on.

You can create a title for the analysis in this page, but doing so is optional. You also create a name for the analysis in the Save page, and that one is required. If you create both, the analysis displays both; they don't have to be the same.

You can use a Preview option to ensure the analysis returns data you expect. Turn it on or off in this page or in subsequent wizard pages. Once it's on, the preview remains on in other wizard pages you navigate to, unless you turn it off.

Edit Table Page

Here are the layout options you can select for tables:

  • Columns: This is the default. Each column you assign this value to appears as a column in the table.

  • Prompt For: In a prompt field, you select among values from the column you're configuring. For example, you would select a date if the column were Calendar Month Start Date. The table would then display only rows containing the value you selected.

  • Section By: The table is divided into sections. Each value of the column you're configuring becomes a header, and the section beneath each header includes rows containing that value.

  • Excluded: The column you select is no longer available to the view you're configuring. (A "view" is a table or graph you include in the analysis.) The column is hidden, and its values are unavailable for behind-the-scenes tasks such as filtering. However, the column remains available to other views in your analysis.

Edit Graph Page

You can't apply layout options to fact columns. For other columns, graph layout options include Prompt For, Section By, and Excluded, which have the same effect as they do in tables. You can also apply these options in graphs:

  • Vary Color By: Each value in the column you're configuring is represented by a distinct color in the graph.

  • Group By: Values in the columns you assign this option to are combined in the graph. For example, if you select this option for the State and Calendar Month Start Date columns in a bar graph, each bar represents a particular status on a particular date.

Highlight Page

You can use this feature only if your analysis includes at least one fact column, and you can apply it only to fact columns.

An Example of Creating an Analysis in the Wizard

Suppose you want to monitor the number of Financial Reporting Compliance issues created each month, but you're interested only in those that are still being worked on. You would need to select columns that provide counts of issues and that track time, and you would need to filter the issues to exclude those that are closed.

  1. Open the wizard: Navigate to Tools > Reports and Analytics. Click the Create button. In its list, click Analysis.

  2. Under Select Subject Area, click the check box for the Risk Management Cloud - Compliance Real Time subject area. Then click Continue.

  3. Select three columns: Count of Issues from the Facts - Issue folder, State from the Issue Details folder, and Calendar Month Start Date from the Time folder. In each case, expand the folder in the Subject Area list, click the column name, and then click the > button.

  4. Click Next. In the Select Views page, enter a title: Unresolved Issues by Month. In the Table list, select the value Table (recommended). In the Graph list, select the value Bar (recommended). In the Layout list, select Table below Graph.

  5. Click the Preview option. You should now see:

    • A bar graph. Each vertical bar represents a number of issues that were created in a particular month and are now at a particular state. All bars are the same color.

    • A table. Each row reports a number of issues that were created in a particular month and are now at a particular state. Columns correspond to your selections from the Compliance Real Time subject area, in the order you selected them.

  6. Click Next. In the Edit Table page, leave all of the columns in the Columns field. But change their order to organize records by issue-creation month: Select Calendar Month Start Date, and click the Up button until that column is on top. Leave Count of Issues second and State third. In the preview, the table reflects your changes.

  7. Click Next. In the Edit Graph page, make the bars in the graph easily distinguishable by making them different colors. In the Group By field, select Calendar Month Start Date. Then open the Move To list, and select Vary Color By. The column name moves to the Vary Color By field. In the preview, bars appear in distinct colors representing the months issues were created.

  8. Click Next. In a Sort and Filter page:

    • Remove records of issues that are resolved. Click Add Filter and, in its list, click the State column. A row appears; in its Operator field, select is not equal to, and in its Value field, type a state that indicates resolution, for example Final Close. Create a distinct filter for each state you want to exclude. (State and status values that apply to object records are defined in the user guides for Financial Reporting Compliance and Advanced Controls.)

    • Sort records in the table. For each of the following sorts, click Add Sort, select a column, and choose a sort order. For Calendar Month and Start Date, select Ascending sort order. For Count of Issues, select the High to Low sort order.

      Note that the first column you select is the primary sort column, the second is secondary, and so on. Each sort you create takes effect only if it doesn't undo a higher-level sort. You can rearrange the sort order: click the Up or Down icon in the row for each sort parameter to move it.

  9. Click Next until you reach the Save page. Reenter the analysis title, Unresolved Issues by Month, and select the folder in which you want to save the analysis. Then click Submit.

An Introduction to Working with Analyses in the BI Catalog

You can create analyses in the BI catalog. You can also create analyses in the wizard, but the BI catalog enables you to use advanced features that support complex analyses or specific requirements. For example, every analysis consists of "views," such as tables and graphs. The BI catalog provides a much greater variety of views than the wizard does, and these include specialized items such as view selectors (which enable users to toggle among views in an analysis). For another example, the BI catalog enables you to use SQL statements to define criteria for filters.

To create or edit an analysis in the BI catalog:

  1. Navigate to Tools > Reports and Analytics. Click the Browse Catalog button.

  2. Click New > Analysis. A Select Subject Area list appears; in it, select the subject area from which your analysis is to draw data.

    Or, select an existing analysis in the catalog and click Edit.

  3. The analysis opens. Use features available on four tabs to define your analysis.

  4. Click the Save Analysis icon to save an existing analysis at its current location. Or click the Save As icon and, in a Save As dialog, enter a name and select the folder in which to save the analysis.

Here are the basic things you can do in each of the four tabs:

Criteria

Expand folders in your subject area and choose columns to include in the analysis. Drag each column from its folder and drop it in the Selected Columns region. Or, double-click each column.

For any column you select, you may click a menu icon (it looks like a gear) to create filters, to sort the order in which records are presented, or to configure column properties. (The topics that follow this one provide examples of filtering and column-property configuration.) You can view and edit filters you have created in a Filters region below the Selected Columns region.

Results

The initial view in any analysis is a table consisting of the columns you selected in the Criteria tab. In the Results tab, you can review it to confirm it returns data you expect. You can also add views, configure the layout of each view, and more.

To add a view to the analysis, click a New View icon and select among a wide variety of formats for tables, graphs, and other items. Each view appears in its own box in a Compound Layout region, with a descriptive title such as "Table" or "Graph."

You can add a graph only if the analysis includes at least one column from a fact folder. Only fact-folder columns contain numeric values, without which there's nothing to base a graph on. If you want to add a graph but are uncertain which type to select, click the Best Visualization option. It automatically selects the type of graph that presents your data most clearly.

You set layout options for each view individually:

  1. Click the Edit View icon (it looks like a pencil) in the title line of a view.

  2. A Layout region opens, with fields representing options suitable for the type of view you're working with. For example, table options are the same as they would be if you were working with a table in the wizard, so there are Table, Table Prompts, Sections, and Excluded fields.

  3. Within the Layout region, drag a column to a field representing an option to apply that option to the column. Then click a Done button.

Prompts

A prompt is a drop-down list that enables a user to select among records the analysis is to display. In an analysis of Financial Reporting Compliance issues, for instance, a user might be prompted to select issues at one or more states. In the Results tab, you can configure similar prompts, but each applies only to an individual view. Each prompt you create in the Prompts tab, however, applies to all views in the analysis.

For a simple example, your analysis might include the State column from the Issue Details folder of the Compliance Real Time subject area. You may want to enable users to view issues at states they choose. In the Prompts tab:

  1. Select New > Column Prompt > State.

  2. In a New Prompt dialog, accept default values: is equal to/is in for Operator, and Choice List for User Input. To ensure users can select only among actual state values, select Options and clear the Enable user to type values check box.

  3. Then check your work: Click the Preview icon. A preview window presents a drop-down list; in it, you can select any combination of states and then click an OK button. The preview window then displays the analysis, filtered so that only records at prompted-for states appear.

Advanced

Review or modify the XML code and logical SQL statement that the analysis generates.

An Example of Creating an Analysis in the BI Catalog

Suppose you want to track overdue Financial Reporting Compliance assessments. You need to select columns that identify records of assessments, and that provide values to filter those records so that your analysis includes only assessments that aren't complete and that have due dates before the current date.

Create this analysis in the BI catalog because it enables you to specify a relative date, and so the analysis can add records of assessments that become overdue at any point up to the date you view it.

  1. Open the BI catalog: Navigate to Tools > Reports and Analytics. Click the Browse Catalog button. In the catalog, click New > Analysis.

  2. Under Select Subject Area, select the Risk Management Cloud - Assessment Results Real Time subject area. The analysis opens with the Criteria tab selected by default.

  3. In the Subject Areas list, expand the Assessment Results Real Time > Assessment Details folder. From it, select three columns: Assessment Name, Assessment State, and Assessment Result Due Date. Drag each column to the Selected Columns area, and drop it there.

  4. Hide the Assessment State column: Click its menu (it looks like a gear) and select Column Properties. Select the Column Format tab, click the Hide check box, and click OK.

    You need the Assessment State column so that you can filter by state to include only assessments that are still being worked on. But you can hide the column because viewers of the analysis don't need to see the state values. The purpose of the analysis is to show overdue assessments, so viewers can take for granted that all assessments are at an incomplete state.

  5. Create filters:

    • Click the menu for the Assessment State column, and click its Filter option. In the Operator field of a New Filter dialog, select is not equal to/is not in. In the Value field, insert Rejected; Closed; Completed; Canceled. Then click OK to close the dialog.

      Note that in the Value field, you can expand a list and select values from it. However, some values may be missing from the list. You can also type values directly into the Value field. Use a semicolon as the value delimiter. (State and status values that apply to object records are defined in the user guides for Financial Reporting Compliance and Advanced Controls.)

    • Click the menu for the Assessment Result Due Date column, and click its Filter option. In the New Filter dialog, select is less than or equal to in the Operator field. Expand the Add More Options list and select SQL Expression. A SQL Expression field appears; in it, type CURRENT_DATE. Click OK to close the dialog.

  6. Sort the analysis to arrange records from the oldest overdue assessments to the most recent. Click the menu for the Assessment Result Due Date column. Then select Sort > Sort Ascending.

  7. Click the Save Analysis icon. In a Save As dialog, enter a name, Overdue Assessments, in the Name field and select the folder in which you want to save the analysis. Then click OK.

  8. Click the Results tab to see your analysis. You should see that the assessment name and due date columns are visible but the state column isn't, that analyses are arranged in date order, and that all due dates are earlier than the current date.

Analyses of Access Model Results

The development of an access model is typically an iterative process. You define the model and generate results. Upon reviewing them, you may discover the model returns false-positives and so modify the model logic to eliminate them, typically by adding condition filters. Or you might discover the model fails to return expected results and so correct the model logic, for example by adding or editing access point or entitlement filters. You may even discover there are conflicts you can resolve right away, and do so without waiting to create a control. In any case, you generate and review results repeatedly until you're satisfied with the records the model returns.

You can create an OTBI analysis that presents model results for review as you work through this development process. The analysis would include data that's also available in the model's Result page, but it would enable you to focus on result values you consider to be key, pivot the data in various ways, and so create your preferred view of the data.

The Advanced Access Models Real Time subject area supplies data to this analysis. Each time you refine and then run the model, you run a synchronization job to update the subject area with fresh data before you review results in the analysis. You run the synchronization job from the Models page of the Advanced Controls work area; as you do, you can limit the job to the model (or models) whose results you're interested in seeing.

You can create a single analysis that prompts you to select among the models you're authorized to work with, and then refreshes to display only results for the model you select. Here's an example:

  1. Open the BI catalog: Navigate to Tools > Reports and Analytics. Click the Browse Catalog button. In the catalog, click New > Analysis.

  2. Under Select Subject Area, select the Risk Management Cloud - Advanced Access Models Real Time subject area. The analysis opens with the Criteria tab selected by default.

  3. Select columns in the Subject Areas list, drag them to the Selected Columns area, and drop them there. It's up to you to decide which columns you consider to be important for your review. But:

    • No matter what else you select, expand the Model Details folder and select the Model Name column. This is the value that enables you to select among models as you use the analysis.

    • For this example, also select Global User Name, First Name, Last Name, Incident Information, Role Name, and Entitlement Name. These are all available in the Result Details folder.

      The first three of these identify a user whose access the model defines as risky. Incident Information reports the path to the access point that's the focus of the result record, and Role Name identifies the role that grants that access point to the user. Entitlement Name identifies the entitlement (if any) that's named in the model and includes the Incident Information access point.

  4. Click the Results tab. It displays a single view, labeled Table, which displays the columns you have selected.

  5. In the title line of the Table view, click Edit View (a pencil icon). A Layout region appears beneath the table. In it, drag the Model Name column to a Table Prompts field. Then click the Done button. The Model Name column now appears as a list field positioned above the other columns, which display data only for the model selected in the list field.

  6. Click the Save Analysis icon. In a Save As dialog, enter a name in the Name field, for example Access Model Results, and select the folder in which you want to save the analysis. Then click OK.

Analyses of Transaction Control Results

You can create analyses that present results returned by transaction controls (those created in Advanced Financial Controls). But results returned by each transaction control are incompatible with results returned by any other transaction control. That's because:

  • A transaction model cites business objects and attributes of those objects, which supply data for analysis. Each business object is a set of related data fields from a business application; an attribute is one field within the set.

  • While creating a model, a user selects result attributes. For each risky transaction it finds, the model returns a value for each of these attributes.

  • Controls are developed from models, and each control inherits the result attributes selected for its model. For each incident it generates, a control returns a value for each of these attributes.

Because the selection of result attributes is unique for each control, you must limit the scope of result analyses. You have two options:

First, an analysis may report on amount values returned by multiple controls. For this to happen, though, some result attributes must be the same for all the controls included in the analysis, they must occupy the same position among the result attributes in each control, and the analysis must include only the columns that provide values for these attributes.

The recommendation is that as you create models from which these controls are deployed, you place the amount value second among result attributes and a date related to the amount third. Examples of such attributes are Amount and Date in the Payables business object. But it's up to your organization to enforce this convention while creating models.

Your second, and more typical, option is to focus an analysis of transaction-control results on a single control. Here's an example of how to create such an analysis:

  1. Open the BI catalog: Select Tools > Reports and Analytics, then click Browse Catalog.

  2. Click New > Analysis.

  3. Select the Risk Management Cloud - Advanced Financial Controls Real Time subject area.

  4. In the Subject Areas list of the Criteria tab, expand the Advanced Control Details folder. Drag the Name dimension to the Selected Columns region.

  5. Expand the Transaction Incident Result Headers folder. Drag the Result Header 1, Result Header 2, and Result Header 3 dimensions to the Selected Columns Region.

  6. Click the Results tab. In the Compound Layout region, a grid displays records for all the controls you can access. In the grid, each of the dimensions you have selected is a column header, and each row identifies the attributes selected for one control.

    In this example, suppose you have access to two controls. The Compound Layout grid might look like this:

    Name Result Header 1 Result Header 2 Result Header 3

    Duplicate Invoices

    Supplier.Supplier Name

    Payables Invoice.Amount

    Payables Invoice.Date

    Expenses over Meal Limits

    Person.Full Name

    Expense Report Details.Original Receipt Amount

    Expense Report Information.Date

    Note that:

    • The standard way to identify an attribute is to concatenate its name with the name of its business object, with a period as the delimiter. For example, "Supplier.Supplier Name" indicates the Supplier Name attribute of the Supplier business object.

    • The order in which result attributes are selected for a model, and therefore for its control, is the same as the order in which they're made available for an analysis. For the Duplicate Invoices control, for example, Supplier.Supplier Name is Result Header 1 because it was the first result attribute selected for the model that served as the basis of the control.

  7. After viewing return values for your controls, decide which control you want to select for an analysis. Make a note of its result headers. Later, you will rename result-value columns. The result headers will serve as reminders of what the new names should be.

  8. Click the Criteria tab. Create a filter that selects the one control you want. For example:

    • In the Name dimension, click the menu icon (it looks like a gear) and select Filter.

    • In a Filter dialog, "Name" is selected as a Column value because you opened the dialog from the Name dimension. Specify an operator and a value to complete the filter, for example "Is equal to" and "Duplicate Invoices."

    • Click OK to close the dialog.

  9. Remove the three result-header dimensions. Open the menu for each and select Delete.

  10. In the Risk Management Cloud - Advanced Financial Controls Real Time subject area, expand the Transaction Incident Result Values folder. Drag the Result Value 1, Result Value 2, and Result Value 3 dimensions to the Selected Columns region.

  11. Rename the column headers. For each result value:

    • Click the menu icon and select Column Properties.

    • In a Column Properties dialog, select the Column Format tab.

    • Select the Custom Headings check box.

    • Enter a new name in the Column Heading field. For example, as you rename Result Value 1, you might enter "Supplier Name."

    • Click OK to close the dialog.

  12. Click the Results tab. The grid in the Compound Layout region now displays results only for the control you selected. These results consist of return-attribute values for each incident generated by the control, rather than return-attribute names.

Link Analyses to Application Pages

An analysis can contain links to Risk Management pages, where you can work on items included in the analysis. These are known as "deep links." For example, an analysis might list issues raised against risks. From the analysis, you might drill down to an issue so that you can take action on it. Analyses can link to application pages concerning:

  • Processes, risks, controls, remediation plans, issues, and assessments in Financial Reporting Compliance.

  • The Manage Controls page, control definitions, control results, and result detail pages in Advanced Controls.

  • The Access Certifications page, owner overviews, manager overviews, and certifier worksheets in Access Certification.

Deep-Link URLs

To configure a deep link, you set an "interaction" property for a column in your analysis whose values are to be links to application pages. This involves associating the column with a deep-link URL. You can copy URLs from the following tables, which list the pages you can link to and the URL appropriate for each.

As you work with these URLs:

  • Copy URLs from the HTML version of this guide, not from the PDF version.

  • Replace <server_url> with the URL of your instance.

  • Each URL contains one or more parameters. In some cases, you're linking to a page (such as Manage Risks in Financial Reporting Compliance) in which you don't need to distinguish between records on the page. In those cases, you can retain the parameter value embedded in the URL you copy from the following tables. It's shown in all-capital letters.

    When you link to a page in which you need to distinguish one record from another, however, you need to define parameter values. In the following tables, such parameters appear as the value "@{x}," in which x is a number. Entries for these URLs correlate the numbers to parameter names, which identify values you need to enter. As you set the interaction property, you use all-capital parameter names exactly as they're shown, but select values for those shown in mixed-case letters.

These URLs apply to Financial Reporting Compliance:

Object Type Deep-Link URL

Manage Risks

https://<server_url>/fscmUI/faces/deeplink?objType=MANAGE_RISKS

Create Risk

https://<server_url>/fscmUI/faces/deeplink?objType=CREATE_RISK_OBJECT&objKey=calledByAction=CREATE

Manage Controls

https://<server_url>/fscmUI/faces/deeplink?objType=MANAGE_CONTROLS

Create Control

https://<server_url>/fscmUI/faces/deeplink?objType=CREATE_CONTROL_OBJECT&objKey=calledByAction=CREATE;calledAsTaskFlow=Y

Manage Processes

https://<server_url>/fscmUI/faces/deeplink?objType=MANAGE_PROCESS

Create Process

https://<server_url>/fscmUI/faces/deeplink?objType=CREATE_PROCESS_OBJECT&objKey=calledByAction=CREATE

Manage Issues

https://<server_url>/fscmUI/faces/deeplink?objType=MANAGE_ISSUES

Create Issue

https://<server_url>/fscmUI/faces/deeplink?objType=CREATE_ISSUE_OBJECT&objKey=calledAsTaskFlow=Y

Manage Remediation Plans

https://<server_url>/fscmUI/faces/deeplink?objType=MANAGE_REMED_PLANS

Create Remediation Plan

https://<server_url>/fscmUI/faces/deeplink?objType=CREATE_REMED_PLAN&objKey=calledAsTaskFlow=Y

Assessment Batches

https://<server_url>/fscmUI/faces/deeplink?objType=MANAGE_ASSESSMENTS

Note: The standard navigation path to this page would be Risk Management > Assessments > Assessment Batches. It's the page in which you view and open records of assessment batches.

Manage Surveys

https://<server_url>/fscmUI/faces/deeplink?objType=MANAGE_SURVEYS

View Risk

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&objKey=ObjectKey=@{2}

Parameters: 1, VIEW_RISK_OBJECT. 2, risk ID.

View Control

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&objKey=ObjectKey=@{2}

Parameters: 1, VIEW_CONTROL_OBJECT. 2, control ID.

View Process

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&objKey=ObjectKey=@{2};calledAsTaskFlow=Y

Parameters: 1, VIEW_PROCESS_OBJECT. 2, process ID.

View Issue

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&objKey=ObjectKey=@{2};calledAsTaskFlow=Y

Parameters: 1, VIEW_ISSUE_OBJECT. 2, issue ID.

View Remediation Plan

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&objKey=ObjectKey=@{2};calledAsTaskFlow=Y

Parameters: 1, VIEW_REMED_PLAN. 2, remediation plan ID.

View Assessment Batch Records

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&objKey=ObjectKey=@{2}

Parameters: 1, VIEW_ASSESSMENT. 2, assessment ID.

Note: This links to the Assessment Records page. The standard way to navigate to this page is to select Risk Management > Assessments > Assessment Batches, then select the Count value for an assessment batch. The assessment ID parameter identifies the batch whose Count value you would select.

Complete Assessment

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&objKey=ResultId=@{2}

Parameters: 1, COMPLETE_ASSESSMENT_RESULT. 2, result ID.

Note: This links to the Introduction page of the "train" to complete an assessment. The standard way to reach this page is to navigate to Risk Management > Assessments > My Assessments, select a type of object and then an object record of that type, and finally select Actions > Perform Assessment. The Result ID parameter identifies the assessment you would be completing.

View Assessment Result

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&objKey=ResultId=@{2}

Parameters: 1, VIEW_ASSESSMENT_RESULT. 2, result ID.

Note: This links to a view version of the "train" to complete an assessment. The link opens the Introduction page of the train if the state of the assessment is New, Request for Information in Review, Request for Information in Approval, or Rejected. Or, the link opens the Complete Assessment page if the assessment state is In Review, Awaiting Approval, or Completed. Once the link opens either of these pages, a user can navigate to other train stops. The standard navigation path is the same as for the Complete Assessment link, except you would select View Assessment from the Actions menu.

View Survey

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&objKey=ObjectKey=@{2}

Parameters: 1, VIEW_SURVEY. 2, survey ID

These URLs apply to Advanced Controls

Object Type Deep-Link URL

Manage Controls

https://<server_url>/fscmUI/faces/deeplink?objType=GRC_AC_MANAGE_CONTROLS&action=VIEW

Edit a Control

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=ControlId=@{3};Navigation=deepLink;EditMode=true

Parameters: 1, GRC_AC_CONTROL. 2, VIEW. 3, control ID.

View a Control

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=ControlId=@{3};Navigation=deepLink;EditMode=false

Parameters: 1, GRC_AC_CONTROL. 2, VIEW. 3, control ID.

View Results for a Control

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=controlId=@{3};Navigation=deepLink

Parameters: 1, GRC_AC_RESULTS. 2, VIEW. 3, control ID.

View Results for a Control and User

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=controlId=@{3};Navigation=deepLink;GlobalUser=@{4}

Parameters: 1, GRC_AC_RESULTS. 2, VIEW. 3, control ID. 4, global user name.

View Results for a Control and Entitlement

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=controlId=@{3};Navigation=deepLink;Entitlement=@{4}

Parameters: 1, GRC_AC_RESULTS. 2, VIEW. 3, control ID. 4, entitlement name.

View Results for a Control and a Role

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=controlId=@{3};Navigation=deepLink;Role=@{4}

Parameters: 1, GRC_AC_RESULTS. 2, VIEW. 3, control ID. 4, role name.

View Results for a Control and User and Role and Entitlement

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=controlId=@{3};Navigation=deepLink;GlobalUser=@{4};Entitlement=@{5};Role=@{6}

Parameters: 1, GRC_AC_RESULTS. 2, VIEW. 3, control ID. 4, global user name. 5, entitlement name. 6, role name.

View a Result

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=IsReadOnly=true;IncidentId=@{3};Navigation=deepLink

Parameters: 1, GRC_AC_VIEW_RESULT. 2, VIEW. 3, result ID.

Edit a Result

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=IsReadOnly=false;IncidentId=@{3};Navigation=deepLink

Parameters: 1, GRC_AC_VIEW_RESULT. 2, VIEW. 3, result ID.

These URLs apply to Access Certification.

Object Type Deep-Link URL

Certification List

https://<server_url>/fscmUI/faces/deeplink?objType=ACCESS_CERTIFICATION&action=CERTIFICATION_LIST

Certification List (filtered to individual certification)

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=certificationId=@{3}

Parameters: 1, ACCESS_CERTIFICATION. 2, CERTIFICATION_LIST. 3, certification ID.

Owner Overview

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=certificationId=@{3}

Parameters: 1, ACCESS_CERTIFICATION. 2, OWNER_OVERVIEW. 3, certification ID.

Manager Overview

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=certificationId=@{3}

Parameters: 1, ACCESS_CERTIFICATION. 2, MANAGER_OVERVIEW. 3, certification ID.

Certifier Worksheet

https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=certificationId=@{3}

Parameters: 1, ACCESS_CERTIFICATION. 2, CERTIFIER_WORKSHEET. 3, certification ID.

How to Add Deep Links to Analyses

To add deep links to an analysis, you configure the column whose values you want turn into links: You supply an appropriate deep-link URL. If it contains parameters you need to define, you also modify these so that they return the results you want.

As general principles:

  • An analysis may include columns that provide ID values. A deep link in such an analysis fails if ID numbers are incorrectly formatted. For any column that provides ID values, click its menu icon (it looks like a gear), select Column Properties, and then the Data Format tab. Then set the format to Number, with no decimals or commas.

  • If you want to create a deep link in an analysis that includes multiple columns, you should configure the link for the last column you add to the analysis. For example, if you select Control ID, then Control Name, then Global User Name, you should create the deep link in the Global User Name column.

Link to a Page

As a first example, suppose an analysis displays records of Financial Reporting Compliance risks. The last column you add to the analysis is Risk Name from the Compliance Real Time subject area. You want the analysis to link to the Manage Risks page.

This would use a deep-link URL that doesn't require you to define parameters. Moreover, every link would go to the same place (in this example, the Manage Risk page), so there's no reason for the analysis to contain more than one link. So this example shows how to add the deep link to the Risk Name column heading in the analysis, not to individual values.

  1. Open the analysis in the BI catalog.

  2. Click the menu icon for the column whose values you want to turn into links: Risk Name in this case. Select Column Properties, and then the Interaction tab.

  3. Two Primary Interaction fields appear, one for Column Heading and the other for Value. In the one that applies to Column Heading, select Action Links. Click the Add Action Link icon.

  4. A New Action Link window appears. In a Link Text field, enter a description of what your link does. It might, for example, be "Open the Manage Risks Page." (Users who click on a value in your analysis will see this description, and then click on it to open the Manage Risks page.)

  5. Next to an Action field, click the Create New Action icon and select its Navigate to a Web Page option.

  6. Enter the appropriate deep-link URL in the Create New Action dialog. In this case, it's the one you can copy from the Manage Risks entry in the table of Financial Reporting Compliance URLs. Be sure to replace <server_url> with your URL.

    https://<server_url>/fscmUI/faces/deeplink?objType=MANAGE_RISKS

  7. Having confirmed that it contains no parameters you need to define (none contains an @{x} value), don't click the Define Parameters button. Do click the Options button, and select Open in New Window.

  8. Click OK to close each of the windows you have worked in, and run your analysis.

Link to Individual Records

Now suppose an analysis lists advanced controls and the global users for whom those controls have generated incidents. It consists of three columns: Control ID, Name, and Global User. ("Name" is the heading of the column that provides the control name.) All three of these are available in the Advanced Access Controls Real Time subject area. The Control ID and Name columns are in the Advanced Control Details folder, and the Global User column is in the Incident Result Details folder.

You want to make each global user a link to the incident result involving that user. This would use a deep-link URL that does require you to define parameters. Moreover, because you intend links to open distinct records of distinct incidents, you want to add links to individual values of the Global User column in the analysis, not to the column heading.

  1. Complete steps 1 through 5 from the previous example. In this case, though:

    • You will be turning values from the Global User column into links, and so selecting its menu icon.

    • You will work with the Primary Interaction field that applies to Value, not to Column Heading.

    • The Link Text you create might be "Open this user's incident."

  2. Having reached the Create New Action dialog, enter the appropriate deep-link URL. This time, it's the one you can copy from the View Results for a Control and User entry in the table of Advanced Controls URLs. Again, be sure to replace <server_url> with your URL.

    https://<server_url>/fscmUI/faces/deeplink?objType=@{1}&action=@{2}&objKey=controlId=@{3};Navigation=deepLink;GlobalUser=@{4}

  3. Having determined that you need to define parameters (the URL contains @{x} values), click the Define Parameters button.

  4. Create rows in which to define parameters: Click the Add Parameters icon once for each parameter in the URL (in this case, four times). Note that in a Name column, each row includes a number that corresponds to a parameter number in the URL.

  5. For the first two parameters, the View Results for a Control and User entry in the table of Advanced Controls URLs shows literal values. (They're in upper-case letters.) In the row for each parameter:

    • Enter the literal value exactly in the Value Column: GRC_AC_RESULTS for parameter 1 and VIEW for parameter 2.

    • Enter a prompt in the Prompt column. You can find the prompt immediately to the left of an equals sign that precedes each parameter in the URL: objType for parameter 1 and action for parameter 2.

  6. For the remaining two parameters, the View Results for a Control and User entry in the table of Advanced Controls URLs shows descriptions of what you need to define: control ID and global user name. (Note that they're in mixed-case letters.)

    • In the Prompt column of row 3, enter control ID.

    • In row 3, select the drop-down list to the left of the Value field and select Column Value. Another drop-down list appears to the right of the field; in it, select "Advanced Control Details"."Control Id".

    • In the prompt column of row 4, enter global user name.

    • In row 4, once again select the drop-down list to the left of the Value field and select Column Value. In the drop-down list to the right of the field, select "Incident Result Details"."Global User Name".

    Note that these values exist to be selected because you included their columns in the analysis.

  7. Click the Options button, and select Open in New Window.

  8. Click OK to close each of the windows you have worked in, and run your analysis.

Deep Links to Other Applications

You can create links from your analyses to records in Oracle Cloud applications other than Risk Management. Product areas that offer deep links generally share examples in My Oracle Support. For example, see:

  • Note 2603149.1 for examples of linking to AP invoices, AP payments, journals, assets, credit transactions, credit memos, receipts, customers, and subledger accounting.

  • Note 2444555.1 for examples of linking to purchase orders and purchase agreements.

Essentially, you follow the procedures outlined in the Risk Management examples, but you use deep-link URLs and parameter definitions provided in the documents on My Oracle Support.

Dashboards

An Introduction to Working with Dashboards

A dashboard presents a set of related analyses or other objects created in Transaction Business Intelligence. You may add other items, such as explanatory text, links to actions or alerts appropriate for records that appear in the dashboard, or links to "embedded content" such as spreadsheets or web sites.

To create or edit a dashboard:

  1. Navigate to Tools > Reports and Analytics. Click the Browse Catalog button.

  2. Click New > Dashboard. A New Dashboard dialog opens; in it, supply a name and optionally a description, select a location in which to save the dashboard, select an Add Content Now button, and click OK.

    Or, select an existing dashboard in the catalog and click its Edit option.

  3. The dashboard opens, displaying a "page" that will contain content. Each dashboard initially has a single page, but you may add pages: click the Add Dashboard Page icon. You can view each page by clicking its tab at the top of the dashboard. If you choose to delete a page, select its tab, then click the Delete Current Page icon.

  4. Drag content from a Dashboard Objects panel or a Catalog panel to the dashboard page. If you've added pages to the dashboard, you would add content to each page.

    • In the Catalog panel, navigate through the folder hierarchy to select items stored in the BI catalog, such as analyses or other dashboards.

    • In the Dashboard Objects panel, select additional items, which are described below.

    As you add items, each must be contained in a "section," and each section must be contained in a "column." These containers are created automatically whenever the need for them is apparent. For example, if you drag an analysis into a blank page, it's automatically contained in a section, and that section in a column. If you drag a second object to that section, it would be included there; if you were to drop it within the column but outside the section, a new section would be created for it.

  5. Arrange the items you've added until they're organized as you want them. You can drag items within a section, or from one section to another; you can move sections within a column, or from one column to another; you can drag columns in relation to one another. You can move an item or a container above, to either side of, or below another item or container.

    You can also delete items, sections, or columns. For each, click the delete icon in its corner. If you delete a section, you also delete all the items it contains. If you delete a column, you also delete all the sections and items it contains.

  6. When you're satisfied with your arrangement, click Save.

The objects you can select in the Dashboard Objects panel include the following:

  • Columns and sections: Add these only when they wouldn't be added automatically. For example, if you drag an analysis into a blank page, it's contained by a section and a column. But if you want to add a second analysis in a second column, you would need to add the column manually.

  • Alert Section: Adds a section to display alerts from agents, if you have configured agents.

  • Action Link or Action Link Menu: Adds a link, or a set of links, to related content or to operations, functions, or processes in external systems.

  • Link or Image: Adds text or an image that serves as a link, and specifies what should happen when a user clicks it. You can link to a web site, another dashboard, documents, or other items. You can also add text or an image only, without a link.

  • Embedded Content: Adds a spreadsheet, document, web site, or other content. To embed the content, you specify a URL that provides it.

  • Text: Adds plain text.

  • Folder: Adds a view of a BI catalog folder and its contents. You might, for example, add a folder that contains analyses you run frequently. From the dashboard, you can open the folder and run any of the analyses.

In most cases, you must set properties for dashboard objects you select. Click the Properties icon for the object, then click the Help icon in the Properties dialog for detailed information.

Note: By default, the first page in any dashboard is named Page 1. You can change that name. You name other pages as you create them, but you can rename them too:
  1. Click the Catalog link.

  2. In the Folders panel, select your dashboard.

  3. In the row for the page whose name you want to change, click More and select Rename.

  4. Enter the new name and click OK.

Use Predefined Risk Management Dashboards

Predefined dashboards provide analyses that document your use of Risk Management applications:

  • For Financial Reporting Compliance, a Related Records dashboard reports relationships you have configured between processes, risks, and controls. For example, you might relate several controls to a risk to indicate that each control plays a part in reducing the risk.

  • For Advanced Access Controls, a Simulation Remediation Plan dashboard documents remediation-plan steps and their results. Each step simulates the removal of an access point from a role hierarchy. If the simulated change were actually made, conflicts involving that access point in that hierarchy would be resolved, because the access point would no longer be granted to users.

  • For Access Certifications, an Access Certification Detail dashboard displays information about a selected certification project, including:

    • The assignable roles it scopes, the users assigned each role, and the action selected for each user-role pairing.

    • The certifiers and managers who participate in reviewing each user-role pairing.

    • The start and due dates for the certification.

  • Three dashboards provide administrative information for each of Advanced Access Controls, Advanced Financial Controls, and Financial Reporting Compliance. Each product has its own set of these three dashboards, with each set displaying information about its product.

    • Change History: For Financial Reporting Compliance, this dashboard provides information recorded in revision history about changes to objects. For Advanced Controls, most object changes are documented through audit history. This dashboard reports only incident status changes.

    • Inaccessible Records: Identifies records that are no longer accessible by any application user.

    • Unassigned Perspective: Identifies perspective hierarchies and values that aren't assigned to any object.

To use these dashboards and their analyses, open them from the BI catalog.

  1. From Tools in the springboard, open the Reports and Analytics work area. Or, open the Reports and Analytics pane if it's available in other work areas.

  2. Click the Browse Catalog button.

  3. Locate the dashboard you want. In the Folders tree, navigate to an appropriate subfolder of Shared Folders > Risk Management:

    • In most cases, the subfolder is [Product Name] > Administration.

    • For the Simulation Remediation Plan dashboard, the subfolder is Advanced Access Controls > Simulation.

    • For the Access Certification Detail dashboard, the subfolder is Access Certification.